PerpetuumSoft.Charts Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Charts Namespace
Send Feedback
The PerpetuumSoft.Charts namespace contains classes for the creation and use of charts.

Classes

Class | Description
AreaSeriesView | Represents an object used to display series data in the form of area.
AreaSeriesViewBase | Represents a base class for all classes representing series data in form of area.
Axis | Represents the chart axis.
AxisArrow | Represents a the base class for drawing axis arrow shape.
AxisSeriesView | Represent a base class for series view displaying series data with the use of coordinate axis.
BarSeriesView | Represents a series view to display series data in the form of bars.
BarSeriesViewBase | Represent a base class for series view representing series data in the form of bars.
CandleStickSeriesView | Represents series view for series data painted in the form of the candle stick chart.
Chart | Represents a chart.
ChartArea | Represents chart area for the series painting.
ChartComposite | Represents a base class for charts constituents.
ChartPaintContext | Defines the context to draw chart series.
ColoredPalette | Represents a base class for multicolored palettes.
CustomPalette | Represents the user defined palette.
CustomPaletteItem | Represents information on the palette's element settings.
CustomPaletteItemCollection | Represents collection of CustomPaletteItem objects.
DataBindingException | Data Binding Exception
DataProvider | Defines the data provider for chart series.
EmptyAxisArrow | Defines an empty shape for an axis arrow.
FinancialSeriesValue | Specifies a base class for the series values used in financial charts.
FinancialSeriesViewBase | Defines a base class for painting of the series values in the form of a financial chart.
GridLines | Determines the grid lines of chart axis.
Legend | Indicates chart legend.
LegendItem | Defines a base class for an item in the chart legend.
LegendSeriesItem | Defines a legend item to indicate series.
LegendValuesItem | Represents a legend element that corresponds to the series value.
LevelSeriesView | Represents series view to display series data in the form of the Level.
LevelSeriesView..::.LevelProperties | Represents properties for the top and bottom layers of the Level.
LineAxisArrow | Represents an axel end in the form of a line.
LineSeriesView | Represents SeriesView to display series data in the form of the broken line.
LineSeriesViewBase | Determines a base class for a lenear chart.
NamedSeriesValueCollection | Defines the named series value collection.
Palette | Defines a base class for the palette used for series elements painting.
PaletteBlackAndWhite | Represents black-and-white palette.
PaletteBlue | Represents palette that uses blue colors.
PaletteChemical | Represents a palette which contains grey and green color tones.
PaletteCold | Represents palette that uses cold colors.
PaletteContrast | Indicates palette for contrast painting of the series elements.
PaletteEmpty | Indicates empty palette for series elements.
PaletteGray | Indicates palette to paint series elements in gray.
PaletteGreen | Indicates palette to paint series elements in green.
PaletteHot | Represents palette that uses warm colors.
PaletteLightBlue | Represents a palette which contains light blue color tones.
PaletteOrange | Represents a palette which contains orange color tones.
PalettePurple | Represents a palette which contains purple color tones.
PaletteRainbow | Indicates palette to paint series elements in rainbow colors.
PaletteRed | Indicates palette for painting series elements in red.
PaletteSunset | Represents a palette which contains purple and orange color tones.
PieSeriesValue | Indicates series values for the Pie series type.
PieSeriesView | Defines series view to present series data in the form of the Pie.
PointSeriesValue | Defines series data displaying in the form of points.
PointSeriesView | Defines series view to display series data in the form of points.
PolygonElement | Defines the Polygon element.
PolylineElement | Defines the PolyLine element.
PseudoBar | Represents a chart element in the form of the pseudo 3D parallelepiped.
PseudoCylinder | Represents a chart element in the form of the pseudo 3D cylinder.
PseudoElement | Represents a base class for pseudo 3D chart elements.
RectangleComposite | Represents a rectangle as a composite element; a base class for the composite elements with the rectangular area.
Series | Represents chart series.
SeriesBase | Represents a base class for chart series.
SeriesBinding | Represents the correspondence between the data of the source and series data.
SeriesBindingCollection | Represents a collection of SeriesBinding objects.
SeriesDataBindingHelper | Represents a class designed to build series values by a data source.
SeriesValue | Represents series value.
SeriesValueBase | Represents a base class for series values.
SeriesValueBaseComparer | Represent a comparer for series value.
SeriesValueInfoCollection | Represents a collection of SeriesValueInfo objects.
SeriesView | Represents a base class for all series views dispalying the series data.
SharpAngleAxisArrow | Represents axis arrow with a sharp angle.
SimpleAxisSeriesView | Represents a base class for SeriesView which builds a chart along axes independent of other series with the same SeriesView.
SimplePalette | Represents a base class for palettes.
SplineAreaElement | Represents an element, spline area.
SplineAreaSeriesView | Represents series view to display series data in the form of an area limited by spline.
SplineElement | Represents an element - spline.
SplineSeriesView | Represents series view to display series data in the form of spline.
SplineSeriesViewBase | Represents a base class for series view displaying series data in the form of the spline.
Stacked100AreaSeriesView | Represents series view to display series data in the form of neighboring areas restricted by lines which go through points which correspond to ratio of series value to the total series value with the given argument.
Stacked100BarSeriesView | Represents series view to display series data in the form of columns. Columns hight is the ratio of the series value to the total series value with the given argument.
StackedAreaSeriesView | Represents series view to display series data in the form of the neighboring areas restricted by lines which go through the points which correspond to series data.
StackedBarSeriesView | Represents series view to display series data in the form of the stacked bar.
StepLineSeriesView | Represents series view to display series data in the form of the step line.
StockSeriesView | Represents a financial type of the Stock chart.
TankSeriesView | Represents series view to display series data in the form of the Tank.
ThermometerSeriesView | Represents series view to display series data in the form of the Thermometer.
Title | Represents a chart title.
ValueLabels | Represents labels to display series values.
ValueMarkers | Represents a marker to indicate characteristic points on chart series.

Structures

Structure | Description
Bounds | Represents the double value bounds.
Segment | Defines line segment.

Interfaces

Interface | Description
IChartElement | Defines methods of a chart element drawing to the specified layer.
IDockable | Defines methods for element docking.

Enumerations

Enumeration | Description
AxisDirection | Enumerates the axis directions.
AxisType | Enumerates the destination of the used axis.
ChartAreaDockStyle | Enumerates dock style for chart area.
ChartLayer | Enumeretes layers to which chart elements are painted.
DisplayingInLegendType | Enumereates types of the legend display.
DockingStyle | Enumerates docking styles for chart elements.
DockingType | Enumerates docking type of the chart elements which are inside another element.
ImageSizeMode | Enumerates image sizing modes.
LabelsPosition | Enumerates types of label positions.
LegendType | Enumerates type of the legend items position.
PieSeriesDrawingStyle | Enumerates the series elements drawing effect types in the form of pie.
PieSeriesPlacingType | Enumereates cross placing type of series which are presented by charts of the Pie type.
PointSeriesDrawingStyle | Enumerates the series elements drawing effect types in the form of points.
ReductionValue | Represents values by which the reduction of the financial series values is specified.
ScaleType | Enumerates scale types.
SortingType | Enumerates sorting type.
StockViewMode | Enumerates a type that specifies view mode of a Stock chart.
ViewType | Enumerates display type of the series data in the form of bar chart.

Send comments on this topic to support@perpetuumsoft.com

(c) 2002-2009 Perpetuum Software LLC


AreaSeriesView Class

[image]

.NET ModelKit Suite ClassReference
AreaSeriesView Class
Members See Also Send Feedback
Represents an object used to display series data in the form of area.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class AreaSeriesView : AreaSeriesViewBase
Visual Basic (Declaration)
Public Class AreaSeriesView _
    Inherits AreaSeriesViewBase
Visual C++
public ref class AreaSeriesView : public AreaSeriesViewBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.AreaSeriesViewBase
PerpetuumSoft.Charts..::.AreaSeriesView

See Also

AreaSeriesView Members
PerpetuumSoft.Charts Namespace


AreaSeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
AreaSeriesView Members
AreaSeriesView Class Constructors Methods Properties Events See Also Send Feedback

The AreaSeriesView type exposes the following members.

Constructors

Name | Description
AreaSeriesView | Initializes a new instance of the AreaSeriesView class.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElementForSeries | Creates chart elements by series data. (Overrides AreaSeriesViewBase..::.CreateElementForSeries(ChartArea, Series, array<AreaSeriesViewPoint>[]()[]).)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from AreaSeriesViewBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Returns element, built by the assigned points subject to the specified palette index. (Inherited from AreaSeriesViewBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AreaSeriesViewBase.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from AreaSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from AreaSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from AreaSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from AreaSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

AreaSeriesView Class
PerpetuumSoft.Charts Namespace


AreaSeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
AreaSeriesView Constructor
AreaSeriesView Class See Also Send Feedback
Initializes a new instance of the AreaSeriesView class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public AreaSeriesView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaSeriesView()

See Also

AreaSeriesView Class
PerpetuumSoft.Charts Namespace


AreaSeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
AreaSeriesView Methods
AreaSeriesView Class See Also Send Feedback

The AreaSeriesView type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElementForSeries | Creates chart elements by series data. (Overrides AreaSeriesViewBase..::.CreateElementForSeries(ChartArea, Series, array<AreaSeriesViewPoint>[]()[]).)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from AreaSeriesViewBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Returns element, built by the assigned points subject to the specified palette index. (Inherited from AreaSeriesViewBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AreaSeriesViewBase.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from AreaSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from AreaSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from AreaSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaSeriesView Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
AreaSeriesView..::.Clone Method
AreaSeriesView Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesView Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesView
Visual C++
public:
virtual SeriesView^ Clone() override

See Also

AreaSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElementForSeries Method

[image]

.NET ModelKit Suite ClassReference
AreaSeriesView..::.CreateElementForSeries Method
AreaSeriesView Class See Also Send Feedback
Creates chart elements by series data.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void CreateElementForSeries(
    ChartArea area,
    Series series,
    AreaSeriesViewPoint[] items
)
Visual Basic (Declaration)
Protected Overrides Sub CreateElementForSeries ( _
    area As ChartArea, _
    series As Series, _
    items As AreaSeriesViewPoint() _
)
Visual C++
protected:
virtual void CreateElementForSeries(
    ChartArea^ area,
    Series^ series,
    array<AreaSeriesViewPoint>^ items
) override

Parameters

area
Type: PerpetuumSoft.Charts..::.ChartArea
series
Type: PerpetuumSoft.Charts..::.Series
items
Type: array< AreaSeriesViewPoint >[]()[]

See Also

AreaSeriesView Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
AreaSeriesView..::.GetSeries Method
AreaSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

AreaSeriesView Class
AreaSeriesView Members
PerpetuumSoft.Charts Namespace


AreaSeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
AreaSeriesView Properties
AreaSeriesView Class See Also Send Feedback

The AreaSeriesView type exposes the following members.

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from AreaSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

See Also

AreaSeriesView Class
PerpetuumSoft.Charts Namespace


AreaSeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
AreaSeriesView Events
AreaSeriesView Class See Also Send Feedback

The AreaSeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

AreaSeriesView Class
PerpetuumSoft.Charts Namespace


AreaSeriesViewBase Class

[image]

.NET ModelKit Suite ClassReference
AreaSeriesViewBase Class
Members See Also Send Feedback
Represents a base class for all classes representing series data in form of area.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract class AreaSeriesViewBase : AxisSeriesView
Visual Basic (Declaration)
Public MustInherit Class AreaSeriesViewBase _
    Inherits AxisSeriesView
Visual C++
public ref class AreaSeriesViewBase abstract : public AxisSeriesView

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.AreaSeriesViewBase
PerpetuumSoft.Charts..::.AreaSeriesView
PerpetuumSoft.Charts..::.Stacked100AreaSeriesView
PerpetuumSoft.Charts..::.StackedAreaSeriesView

See Also

AreaSeriesViewBase Members
PerpetuumSoft.Charts Namespace


AreaSeriesViewBase Members

[image] [image]

.NET ModelKit Suite ClassReference
AreaSeriesViewBase Members
AreaSeriesViewBase Class Constructors Methods Properties Events See Also Send Feedback

The AreaSeriesViewBase type exposes the following members.

Constructors

Name | Description
AreaSeriesViewBase | Initializes a new instance of the AreaSeriesViewBase class

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Creates an object copy. (Inherited from SeriesView.)
CreateElementForSeries | Creates chart elements by series data.
CreateElements | Overridden. See CreateElements(ChartArea). (Overrides SeriesView..::.CreateElements(ChartArea).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Returns element, built by the assigned points subject to the specified palette index.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Overrides AxisSeriesView..::.GetSeriesValueType()()().)
GetSideIndent | Overridden. See GetSideIndent()()(). (Overrides SeriesView..::.GetSideIndent()()().)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Overrides SeriesView..::.PaintLegendBadge(GraphicStream, VectorRectangle).)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Overrides SeriesView..::.PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Overrides SeriesView..::.IsValueLegendItemSupported.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

AreaSeriesViewBase Class
PerpetuumSoft.Charts Namespace


AreaSeriesViewBase Constructor

[image]

.NET ModelKit Suite ClassReference
AreaSeriesViewBase Constructor
AreaSeriesViewBase Class See Also Send Feedback
Initializes a new instance of the AreaSeriesViewBase class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected AreaSeriesViewBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
AreaSeriesViewBase()

See Also

AreaSeriesViewBase Class
PerpetuumSoft.Charts Namespace


AreaSeriesViewBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
AreaSeriesViewBase Methods
AreaSeriesViewBase Class See Also Send Feedback

The AreaSeriesViewBase type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Creates an object copy. (Inherited from SeriesView.)
CreateElementForSeries | Creates chart elements by series data.
CreateElements | Overridden. See CreateElements(ChartArea). (Overrides SeriesView..::.CreateElements(ChartArea).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Returns element, built by the assigned points subject to the specified palette index.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Overrides AxisSeriesView..::.GetSeriesValueType()()().)
GetSideIndent | Overridden. See GetSideIndent()()(). (Overrides SeriesView..::.GetSideIndent()()().)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Overrides SeriesView..::.PaintLegendBadge(GraphicStream, VectorRectangle).)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Overrides SeriesView..::.PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaSeriesViewBase Class
PerpetuumSoft.Charts Namespace


CreateElementForSeries Method

[image]

.NET ModelKit Suite ClassReference
AreaSeriesViewBase..::.CreateElementForSeries Method
AreaSeriesViewBase Class See Also Send Feedback
Creates chart elements by series data.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected abstract void CreateElementForSeries(
    ChartArea area,
    Series series,
    AreaSeriesViewPoint[] points
)
Visual Basic (Declaration)
Protected MustOverride Sub CreateElementForSeries ( _
    area As ChartArea, _
    series As Series, _
    points As AreaSeriesViewPoint() _
)
Visual C++
protected:
virtual void CreateElementForSeries(
    ChartArea^ area,
    Series^ series,
    array<AreaSeriesViewPoint>^ points
) abstract

Parameters

area
Type: PerpetuumSoft.Charts..::.ChartArea
series
Type: PerpetuumSoft.Charts..::.Series
points
Type: array< AreaSeriesViewPoint >[]()[]

See Also

AreaSeriesViewBase Class
PerpetuumSoft.Charts Namespace


CreateElements Method

[image]

.NET ModelKit Suite ClassReference
AreaSeriesViewBase..::.CreateElements Method
AreaSeriesViewBase Class See Also Send Feedback
Overridden. See CreateElements(ChartArea).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void CreateElements(
    ChartArea area
)
Visual Basic (Declaration)
Public Overrides Sub CreateElements ( _
    area As ChartArea _
)
Visual C++
public:
virtual void CreateElements(
    ChartArea^ area
) override

Parameters

area
Type: PerpetuumSoft.Charts..::.ChartArea

See Also

AreaSeriesViewBase Class
PerpetuumSoft.Charts Namespace


GetElement Method

[image]

.NET ModelKit Suite ClassReference
AreaSeriesViewBase..::.GetElement Method
AreaSeriesViewBase Class See Also Send Feedback
Returns element, built by the assigned points subject to the specified palette index.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected virtual Element GetElement(
    Vector[] points,
    int paletteIndex
)
Visual Basic (Declaration)
Protected Overridable Function GetElement ( _
    points As Vector(), _
    paletteIndex As Integer _
) As Element
Visual C++
protected:
virtual Element^ GetElement(
    array<Vector>^ points,
    int paletteIndex
)

Parameters

points
Type: array< PerpetuumSoft.Framework.Drawing..::.Vector >[]()[]
paletteIndex
Type: System..::.Int32

See Also

AreaSeriesViewBase Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
AreaSeriesViewBase..::.GetSeries Method
AreaSeriesViewBase Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

AreaSeriesViewBase Class
AreaSeriesViewBase Members
PerpetuumSoft.Charts Namespace


GetSeriesValueType Method

[image]

.NET ModelKit Suite ClassReference
AreaSeriesViewBase..::.GetSeriesValueType Method
AreaSeriesViewBase Class See Also Send Feedback
Overridden. See GetSeriesValueType()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Type GetSeriesValueType()
Visual Basic (Declaration)
Public Overrides Function GetSeriesValueType As Type
Visual C++
public:
virtual Type^ GetSeriesValueType() override

See Also

AreaSeriesViewBase Class
PerpetuumSoft.Charts Namespace


GetSideIndent Method

[image]

.NET ModelKit Suite ClassReference
AreaSeriesViewBase..::.GetSideIndent Method
AreaSeriesViewBase Class See Also Send Feedback
Overridden. See GetSideIndent()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override double GetSideIndent()
Visual Basic (Declaration)
Public Overrides Function GetSideIndent As Double
Visual C++
public:
virtual double GetSideIndent() override

See Also

AreaSeriesViewBase Class
PerpetuumSoft.Charts Namespace


PaintLegendBadge Method

[image]

.NET ModelKit Suite ClassReference
AreaSeriesViewBase..::.PaintLegendBadge Method
AreaSeriesViewBase Class See Also Send Feedback
Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintLegendBadge(
    GraphicStream graphicStream,
    VectorRectangle area
)
Visual Basic (Declaration)
Public Overrides Sub PaintLegendBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle _
)
Visual C++
public:
virtual void PaintLegendBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area
) override

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

AreaSeriesViewBase Class
PerpetuumSoft.Charts Namespace


PaintLegendValueBadge Method

[image]

.NET ModelKit Suite ClassReference
AreaSeriesViewBase..::.PaintLegendValueBadge Method
AreaSeriesViewBase Class See Also Send Feedback
Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintLegendValueBadge(
    GraphicStream graphicStream,
    VectorRectangle area,
    int seriesValueIndex
)
Visual Basic (Declaration)
Public Overrides Sub PaintLegendValueBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle, _
    seriesValueIndex As Integer _
)
Visual C++
public:
virtual void PaintLegendValueBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area,
    int seriesValueIndex
) override

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
seriesValueIndex
Type: System..::.Int32

See Also

AreaSeriesViewBase Class
PerpetuumSoft.Charts Namespace


AreaSeriesViewBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
AreaSeriesViewBase Properties
AreaSeriesViewBase Class See Also Send Feedback

The AreaSeriesViewBase type exposes the following members.

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Overrides SeriesView..::.IsValueLegendItemSupported.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

See Also

AreaSeriesViewBase Class
PerpetuumSoft.Charts Namespace


IsValueLegendItemSupported Property

[image]

.NET ModelKit Suite ClassReference
AreaSeriesViewBase..::.IsValueLegendItemSupported Property
AreaSeriesViewBase Class See Also Send Feedback
Overridden. See IsValueLegendItemSupported.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValueLegendItemSupported { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsValueLegendItemSupported As Boolean
Visual C++
public:
virtual property bool IsValueLegendItemSupported {
    bool get () override;
}

See Also

AreaSeriesViewBase Class
PerpetuumSoft.Charts Namespace


AreaSeriesViewBase Events

[image] [image]

.NET ModelKit Suite ClassReference
AreaSeriesViewBase Events
AreaSeriesViewBase Class See Also Send Feedback

The AreaSeriesViewBase type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

AreaSeriesViewBase Class
PerpetuumSoft.Charts Namespace


Axis Class

[image]

.NET ModelKit Suite ClassReference
Axis Class
Members See Also Send Feedback
Represents the chart axis.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class Axis : ChartComposite, IScale, ISupportInitialize
Visual Basic (Declaration)
Public Class Axis _
    Inherits ChartComposite _
    Implements IScale, ISupportInitialize
Visual C++
public ref class Axis : public ChartComposite,
    IScale, ISupportInitialize

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.Composite
PerpetuumSoft.Charts..::.ChartComposite
PerpetuumSoft.Charts..::.Axis

See Also

Axis Members
PerpetuumSoft.Charts Namespace


Axis Members

[image] [image]

.NET ModelKit Suite ClassReference
Axis Members
Axis Class Constructors Methods Properties Events See Also Send Feedback

The Axis type exposes the following members.

Constructors

Name | Description
Axis | Initializes a new instance of the Axis class.

Methods

Name | Description
AlignScaleElements | Positions all axis elements taking into account the docking.
BeginInit | Implements BeginInit()()().
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See ['M:PerpetuumSoft.Instrumentation.Model.Element.Calculate]. (Overrides Composite..::.Calculate()()().)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
EndInit | Implements EndInit()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
FromRealValue | Implements FromRealValue(Object).
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetDiscreteValue | Implements GetDiscreteValue(Int32).
GetDiscreteValuesCount | Implements GetDiscreteValuesCount()()().
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetElementAtLayer | Implements GetElementAtLayer(Vector, ChartLayer). (Inherited from ChartComposite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Overrides Element..::.GetObject(String).)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueFromSmartValue | Returns axis value corresponding to the specified SmartValue.
Invalidate | Overloaded.
IsIncludePoint | Returns value that indicates whether a point is placed between the start and the end points.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Overridden. See ['M:PerpetuumSoft.Instrumentation.Model.Element.OnParentChanged]. (Overrides Element..::.OnParentChanged()()().)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLayer | Implements PaintLayer(PaintArguments, ChartLayer). (Inherited from ChartComposite.)
PaintSelf | Overridden. See PaintSelf(PaintArguments). (Overrides ChartComposite..::.PaintSelf(PaintArguments).)
PercentToValue | Implements PercentToValue(Double).
PointToValue | Implements PointToValue(Vector).
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetIScaleElements | Calls recalculation of all axis elements position.
ToRealValue | Implements ToRealValue(Double).
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValueToBoundedCoordinate | Returns coordinates of the point corresponding to the specified value.
ValueToPercent | Implements ValueToPercent(Double).
ValueToPoint | Implements ValueToPoint(Double, Double).

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Arrow | Gets or sets AxisArrow object that determines shape drawing at the end point of the axis.
AxisIndent | Sets axis end shift from the scale end.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Implements Colorizer.
CrossValue | Gets or sets a value where this axis will cross over the axis determined in the 'PerpendicularAxis property.
DefaultLayer | Overridden. See DefaultLayer. (Overrides ChartComposite..::.DefaultLayer.)
Direction | Gets or sets axis direction.
Elements | Implements Elements. (Inherited from Composite.)
EndPoint | Gets the end point of the axis.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
IsDiscrete | Implements IsDiscrete.
Margins | Gets or sets margins of this element.
MaxValue | Gets or sets a maximum value along this axis.
MinValue | Gets or sets a minimum value along this axis.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
PerpendicularAxis | Gets or sets an axis that is perpendicular to this axis.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Reverse | Gets or sets a value that indicates whether start and end axis points is in reverse.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartFromZero | Gets or sets a value that indicates whether the axis includes zero point.
StartPoint | Gets the start point of the axis.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Axis Class
PerpetuumSoft.Charts Namespace


Axis Constructor

[image]

.NET ModelKit Suite ClassReference
Axis Constructor
Axis Class See Also Send Feedback
Initializes a new instance of the Axis class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Axis()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Axis()

See Also

Axis Class
PerpetuumSoft.Charts Namespace


Axis Methods

[image] [image]

.NET ModelKit Suite ClassReference
Axis Methods
Axis Class See Also Send Feedback

The Axis type exposes the following members.

Methods

Name | Description
AlignScaleElements | Positions all axis elements taking into account the docking.
BeginInit | Implements BeginInit()()().
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See ['M:PerpetuumSoft.Instrumentation.Model.Element.Calculate]. (Overrides Composite..::.Calculate()()().)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
EndInit | Implements EndInit()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
FromRealValue | Implements FromRealValue(Object).
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetDiscreteValue | Implements GetDiscreteValue(Int32).
GetDiscreteValuesCount | Implements GetDiscreteValuesCount()()().
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetElementAtLayer | Implements GetElementAtLayer(Vector, ChartLayer). (Inherited from ChartComposite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Overrides Element..::.GetObject(String).)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueFromSmartValue | Returns axis value corresponding to the specified SmartValue.
Invalidate | Overloaded.
IsIncludePoint | Returns value that indicates whether a point is placed between the start and the end points.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Overridden. See ['M:PerpetuumSoft.Instrumentation.Model.Element.OnParentChanged]. (Overrides Element..::.OnParentChanged()()().)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLayer | Implements PaintLayer(PaintArguments, ChartLayer). (Inherited from ChartComposite.)
PaintSelf | Overridden. See PaintSelf(PaintArguments). (Overrides ChartComposite..::.PaintSelf(PaintArguments).)
PercentToValue | Implements PercentToValue(Double).
PointToValue | Implements PointToValue(Vector).
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetIScaleElements | Calls recalculation of all axis elements position.
ToRealValue | Implements ToRealValue(Double).
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValueToBoundedCoordinate | Returns coordinates of the point corresponding to the specified value.
ValueToPercent | Implements ValueToPercent(Double).
ValueToPoint | Implements ValueToPoint(Double, Double).

See Also

Axis Class
PerpetuumSoft.Charts Namespace


AlignScaleElements Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.AlignScaleElements Method
Axis Class See Also Send Feedback
Positions all axis elements taking into account the docking.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void AlignScaleElements()
Visual Basic (Declaration)
Public Sub AlignScaleElements
Visual C++
public:
void AlignScaleElements()

See Also

Axis Class
PerpetuumSoft.Charts Namespace


BeginInit Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.BeginInit Method
Axis Class See Also Send Feedback
Implements BeginInit()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void BeginInit()
Visual Basic (Declaration)
Public Sub BeginInit
Visual C++
public:
virtual void BeginInit() sealed

Implements

ISupportInitialize..::.BeginInit()()()

See Also

Axis Class
PerpetuumSoft.Charts Namespace


Calculate Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.Calculate Method
Axis Class See Also Send Feedback
Overridden. See ['M:PerpetuumSoft.Instrumentation.Model.Element.Calculate].

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void Calculate()
Visual Basic (Declaration)
Protected Overrides Sub Calculate
Visual C++
protected:
virtual void Calculate() override

See Also

Axis Class
PerpetuumSoft.Charts Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Axis..::.Dispose Method
Axis Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from Composite.)

See Also

Axis Class
Axis Members
PerpetuumSoft.Charts Namespace


EndInit Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.EndInit Method
Axis Class See Also Send Feedback
Implements EndInit()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void EndInit()
Visual Basic (Declaration)
Public Sub EndInit
Visual C++
public:
virtual void EndInit() sealed

Implements

ISupportInitialize..::.EndInit()()()

See Also

Axis Class
PerpetuumSoft.Charts Namespace


FromRealValue Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.FromRealValue Method
Axis Class See Also Send Feedback
Implements FromRealValue(Object).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double FromRealValue(
    Object value
)
Visual Basic (Declaration)
Public Function FromRealValue ( _
    value As Object _
) As Double
Visual C++
public:
virtual double FromRealValue(
    Object^ value
) sealed

Parameters

value
Type: System..::.Object

Implements

IScale..::.FromRealValue(Object)

See Also

Axis Class
PerpetuumSoft.Charts Namespace


GetDiscreteValue Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.GetDiscreteValue Method
Axis Class See Also Send Feedback
Implements GetDiscreteValue(Int32).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Object GetDiscreteValue(
    int index
)
Visual Basic (Declaration)
Public Function GetDiscreteValue ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ GetDiscreteValue(
    int index
) sealed

Parameters

index
Type: System..::.Int32

Implements

IScale..::.GetDiscreteValue(Int32)

See Also

Axis Class
PerpetuumSoft.Charts Namespace


GetDiscreteValuesCount Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.GetDiscreteValuesCount Method
Axis Class See Also Send Feedback
Implements GetDiscreteValuesCount()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public int GetDiscreteValuesCount()
Visual Basic (Declaration)
Public Function GetDiscreteValuesCount As Integer
Visual C++
public:
virtual int GetDiscreteValuesCount() sealed

Implements

IScale..::.GetDiscreteValuesCount()()()

See Also

Axis Class
PerpetuumSoft.Charts Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.GetHitTest Method
Axis Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Axis Class
PerpetuumSoft.Charts Namespace


GetObject Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.GetObject Method
Axis Class See Also Send Feedback
Implements GetObject(String).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Object GetObject(
    string name
)
Visual Basic (Declaration)
Public Overrides Function GetObject ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetObject(
    String^ name
) override

Parameters

name
Type: System..::.String

See Also

Axis Class
PerpetuumSoft.Charts Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Axis..::.GetStyle Method
Axis Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Axis Class
Axis Members
PerpetuumSoft.Charts Namespace


GetValueFromSmartValue Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.GetValueFromSmartValue Method
Axis Class See Also Send Feedback
Returns axis value corresponding to the specified SmartValue.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double GetValueFromSmartValue(
    SmartValue smartValue
)
Visual Basic (Declaration)
Public Function GetValueFromSmartValue ( _
    smartValue As SmartValue _
) As Double
Visual C++
public:
double GetValueFromSmartValue(
    SmartValue smartValue
)

Parameters

smartValue
Type: PerpetuumSoft.Instrumentation.Model..::.SmartValue

See Also

Axis Class
PerpetuumSoft.Charts Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Axis..::.Invalidate Method
Axis Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Axis Class
Axis Members
PerpetuumSoft.Charts Namespace


IsIncludePoint Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.IsIncludePoint Method
Axis Class See Also Send Feedback
Returns value that indicates whether a point is placed between the start and the end points.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected bool IsIncludePoint(
    Vector point,
    Vector startPoint,
    Vector endPoint
)
Visual Basic (Declaration)
Protected Function IsIncludePoint ( _
    point As Vector, _
    startPoint As Vector, _
    endPoint As Vector _
) As Boolean
Visual C++
protected:
bool IsIncludePoint(
    Vector point,
    Vector startPoint,
    Vector endPoint
)

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector
startPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
endPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Axis Class
PerpetuumSoft.Charts Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Axis..::.OnPaint Method
Axis Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Overrides Composite..::.OnPaint(PaintArguments).)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

Axis Class
Axis Members
PerpetuumSoft.Charts Namespace


OnPaint Method (PaintArguments)

[image]

.NET ModelKit Suite ClassReference
Axis..::.OnPaint Method (PaintArguments)
Axis Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

Axis Class
OnPaint Overload
PerpetuumSoft.Charts Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
Axis..::.OnPaint Method (PaintArguments, Fill, Stroke)
Axis Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Axis Class
OnPaint Overload
PerpetuumSoft.Charts Namespace


OnParentChanged Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.OnParentChanged Method
Axis Class See Also Send Feedback
Overridden. See ['M:PerpetuumSoft.Instrumentation.Model.Element.OnParentChanged].

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnParentChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnParentChanged
Visual C++
protected:
virtual void OnParentChanged() override

See Also

Axis Class
PerpetuumSoft.Charts Namespace


PaintSelf Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.PaintSelf Method
Axis Class See Also Send Feedback
Overridden. See PaintSelf(PaintArguments).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintSelf(
    PaintArguments args
)
Visual Basic (Declaration)
Public Overrides Sub PaintSelf ( _
    args As PaintArguments _
)
Visual C++
public:
virtual void PaintSelf(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

Axis Class
PerpetuumSoft.Charts Namespace


PercentToValue Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.PercentToValue Method
Axis Class See Also Send Feedback
Implements PercentToValue(Double).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double PercentToValue(
    double percent
)
Visual Basic (Declaration)
Public Function PercentToValue ( _
    percent As Double _
) As Double
Visual C++
public:
virtual double PercentToValue(
    double percent
) sealed

Parameters

percent
Type: System..::.Double

Implements

IScale..::.PercentToValue(Double)

See Also

Axis Class
PerpetuumSoft.Charts Namespace


PointToValue Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.PointToValue Method
Axis Class See Also Send Feedback
Implements PointToValue(Vector).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double PointToValue(
    Vector point
)
Visual Basic (Declaration)
Public Function PointToValue ( _
    point As Vector _
) As Double
Visual C++
public:
virtual double PointToValue(
    Vector point
) sealed

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

Implements

IScale..::.PointToValue(Vector)

See Also

Axis Class
PerpetuumSoft.Charts Namespace


ResetIScaleElements Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.ResetIScaleElements Method
Axis Class See Also Send Feedback
Calls recalculation of all axis elements position.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void ResetIScaleElements()
Visual Basic (Declaration)
Public Sub ResetIScaleElements
Visual C++
public:
void ResetIScaleElements()

See Also

Axis Class
PerpetuumSoft.Charts Namespace


ToRealValue Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.ToRealValue Method
Axis Class See Also Send Feedback
Implements ToRealValue(Double).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Object ToRealValue(
    double value
)
Visual Basic (Declaration)
Public Function ToRealValue ( _
    value As Double _
) As Object
Visual C++
public:
virtual Object^ ToRealValue(
    double value
) sealed

Parameters

value
Type: System..::.Double

Implements

IScale..::.ToRealValue(Double)

See Also

Axis Class
PerpetuumSoft.Charts Namespace


ValueToBoundedCoordinate Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.ValueToBoundedCoordinate Method
Axis Class See Also Send Feedback
Returns coordinates of the point corresponding to the specified value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double ValueToBoundedCoordinate(
    double value
)
Visual Basic (Declaration)
Public Function ValueToBoundedCoordinate ( _
    value As Double _
) As Double
Visual C++
public:
double ValueToBoundedCoordinate(
    double value
)

Parameters

value
Type: System..::.Double

See Also

Axis Class
PerpetuumSoft.Charts Namespace


ValueToPercent Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.ValueToPercent Method
Axis Class See Also Send Feedback
Implements ValueToPercent(Double).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double ValueToPercent(
    double value
)
Visual Basic (Declaration)
Public Function ValueToPercent ( _
    value As Double _
) As Double
Visual C++
public:
virtual double ValueToPercent(
    double value
) sealed

Parameters

value
Type: System..::.Double

Implements

IScale..::.ValueToPercent(Double)

See Also

Axis Class
PerpetuumSoft.Charts Namespace


ValueToPoint Method

[image]

.NET ModelKit Suite ClassReference
Axis..::.ValueToPoint Method
Axis Class See Also Send Feedback
Implements ValueToPoint(Double, Double).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Vector ValueToPoint(
    double value,
    double radius
)
Visual Basic (Declaration)
Public Function ValueToPoint ( _
    value As Double, _
    radius As Double _
) As Vector
Visual C++
public:
virtual Vector ValueToPoint(
    double value,
    double radius
) sealed

Parameters

value
Type: System..::.Double
radius
Type: System..::.Double

Implements

IScale..::.ValueToPoint(Double, Double)

See Also

Axis Class
PerpetuumSoft.Charts Namespace


Axis Properties

[image] [image]

.NET ModelKit Suite ClassReference
Axis Properties
Axis Class See Also Send Feedback

The Axis type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Arrow | Gets or sets AxisArrow object that determines shape drawing at the end point of the axis.
AxisIndent | Sets axis end shift from the scale end.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Implements Colorizer.
CrossValue | Gets or sets a value where this axis will cross over the axis determined in the 'PerpendicularAxis property.
DefaultLayer | Overridden. See DefaultLayer. (Overrides ChartComposite..::.DefaultLayer.)
Direction | Gets or sets axis direction.
Elements | Implements Elements. (Inherited from Composite.)
EndPoint | Gets the end point of the axis.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
IsDiscrete | Implements IsDiscrete.
Margins | Gets or sets margins of this element.
MaxValue | Gets or sets a maximum value along this axis.
MinValue | Gets or sets a minimum value along this axis.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
PerpendicularAxis | Gets or sets an axis that is perpendicular to this axis.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Reverse | Gets or sets a value that indicates whether start and end axis points is in reverse.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartFromZero | Gets or sets a value that indicates whether the axis includes zero point.
StartPoint | Gets the start point of the axis.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Axis Class
PerpetuumSoft.Charts Namespace


Arrow Property

[image]

.NET ModelKit Suite ClassReference
Axis..::.Arrow Property
Axis Class See Also Send Feedback
Gets or sets AxisArrow object that determines shape drawing at the end point of the axis.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public AxisArrow Arrow { get; set; }
Visual Basic (Declaration)
Public Property Arrow As AxisArrow
Visual C++
public:
property AxisArrow^ Arrow {
    AxisArrow^ get ();
    void set (AxisArrow^ value);
}

See Also

Axis Class
PerpetuumSoft.Charts Namespace


AxisIndent Property

[image]

.NET ModelKit Suite ClassReference
Axis..::.AxisIndent Property
Axis Class See Also Send Feedback
Sets axis end shift from the scale end.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue AxisIndent { get; set; }
Visual Basic (Declaration)
Public Property AxisIndent As SmartValue
Visual C++
public:
property SmartValue AxisIndent {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

Axis Class
PerpetuumSoft.Charts Namespace


Colorizer Property

[image]

.NET ModelKit Suite ClassReference
Axis..::.Colorizer Property
Axis Class See Also Send Feedback
Implements Colorizer.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Colorizer Colorizer { get; set; }
Visual Basic (Declaration)
Public Property Colorizer As Colorizer
Visual C++
public:
virtual property Colorizer^ Colorizer {
    Colorizer^ get () sealed;
    void set (Colorizer^ value) sealed;
}

Implements

IScale..::.Colorizer

See Also

Axis Class
PerpetuumSoft.Charts Namespace


CrossValue Property

[image]

.NET ModelKit Suite ClassReference
Axis..::.CrossValue Property
Axis Class See Also Send Feedback
Gets or sets a value where this axis will cross over the axis determined in the 'PerpendicularAxis property.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue CrossValue { get; set; }
Visual Basic (Declaration)
Public Property CrossValue As SmartValue
Visual C++
public:
property SmartValue CrossValue {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

Axis Class
PerpetuumSoft.Charts Namespace


DefaultLayer Property

[image]

.NET ModelKit Suite ClassReference
Axis..::.DefaultLayer Property
Axis Class See Also Send Feedback
Overridden. See DefaultLayer.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override ChartLayer DefaultLayer { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultLayer As ChartLayer
Visual C++
public:
virtual property ChartLayer DefaultLayer {
    ChartLayer get () override;
}

See Also

Axis Class
PerpetuumSoft.Charts Namespace


Direction Property

[image]

.NET ModelKit Suite ClassReference
Axis..::.Direction Property
Axis Class See Also Send Feedback
Gets or sets axis direction.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public AxisDirection Direction { get; set; }
Visual Basic (Declaration)
Public Property Direction As AxisDirection
Visual C++
public:
property AxisDirection Direction {
    AxisDirection get ();
    void set (AxisDirection value);
}

See Also

Axis Class
PerpetuumSoft.Charts Namespace


EndPoint Property

[image]

.NET ModelKit Suite ClassReference
Axis..::.EndPoint Property
Axis Class See Also Send Feedback
Gets the end point of the axis.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Vector EndPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndPoint As Vector
Visual C++
public:
property Vector EndPoint {
    Vector get ();
}

See Also

Axis Class
PerpetuumSoft.Charts Namespace


IsDiscrete Property

[image]

.NET ModelKit Suite ClassReference
Axis..::.IsDiscrete Property
Axis Class See Also Send Feedback
Implements IsDiscrete.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool IsDiscrete { get; set; }
Visual Basic (Declaration)
Public Property IsDiscrete As Boolean
Visual C++
public:
virtual property bool IsDiscrete {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IScale..::.IsDiscrete

See Also

Axis Class
PerpetuumSoft.Charts Namespace


Margins Property

[image]

.NET ModelKit Suite ClassReference
Axis..::.Margins Property
Axis Class See Also Send Feedback
Gets or sets margins of this element.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Margins Margins { get; set; }
Visual Basic (Declaration)
Public Property Margins As Margins
Visual C++
public:
property Margins Margins {
    Margins get ();
    void set (Margins value);
}

See Also

Axis Class
PerpetuumSoft.Charts Namespace


MaxValue Property

[image]

.NET ModelKit Suite ClassReference
Axis..::.MaxValue Property
Axis Class See Also Send Feedback
Gets or sets a maximum value along this axis.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue MaxValue { get; set; }
Visual Basic (Declaration)
Public Property MaxValue As SmartValue
Visual C++
public:
property SmartValue MaxValue {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

Axis Class
PerpetuumSoft.Charts Namespace


MinValue Property

[image]

.NET ModelKit Suite ClassReference
Axis..::.MinValue Property
Axis Class See Also Send Feedback
Gets or sets a minimum value along this axis.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue MinValue { get; set; }
Visual Basic (Declaration)
Public Property MinValue As SmartValue
Visual C++
public:
property SmartValue MinValue {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

Axis Class
PerpetuumSoft.Charts Namespace


PerpendicularAxis Property

[image]

.NET ModelKit Suite ClassReference
Axis..::.PerpendicularAxis Property
Axis Class See Also Send Feedback
Gets or sets an axis that is perpendicular to this axis.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Axis PerpendicularAxis { get; set; }
Visual Basic (Declaration)
Public Property PerpendicularAxis As Axis
Visual C++
public:
property Axis^ PerpendicularAxis {
    Axis^ get ();
    void set (Axis^ value);
}

See Also

Axis Class
PerpetuumSoft.Charts Namespace


Reverse Property

[image]

.NET ModelKit Suite ClassReference
Axis..::.Reverse Property
Axis Class See Also Send Feedback
Gets or sets a value that indicates whether start and end axis points is in reverse.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool Reverse { get; set; }
Visual Basic (Declaration)
Public Property Reverse As Boolean
Visual C++
public:
property bool Reverse {
    bool get ();
    void set (bool value);
}

See Also

Axis Class
PerpetuumSoft.Charts Namespace


StartFromZero Property

[image]

.NET ModelKit Suite ClassReference
Axis..::.StartFromZero Property
Axis Class See Also Send Feedback
Gets or sets a value that indicates whether the axis includes zero point.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool StartFromZero { get; set; }
Visual Basic (Declaration)
Public Property StartFromZero As Boolean
Visual C++
public:
property bool StartFromZero {
    bool get ();
    void set (bool value);
}

See Also

Axis Class
PerpetuumSoft.Charts Namespace


StartPoint Property

[image]

.NET ModelKit Suite ClassReference
Axis..::.StartPoint Property
Axis Class See Also Send Feedback
Gets the start point of the axis.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Vector StartPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartPoint As Vector
Visual C++
public:
property Vector StartPoint {
    Vector get ();
}

See Also

Axis Class
PerpetuumSoft.Charts Namespace


Axis Events

[image] [image]

.NET ModelKit Suite ClassReference
Axis Events
Axis Class See Also Send Feedback

The Axis type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Axis Class
PerpetuumSoft.Charts Namespace


AxisArrow Class

[image]

.NET ModelKit Suite ClassReference
AxisArrow Class
Members See Also Send Feedback
Represents a the base class for drawing axis arrow shape.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract class AxisArrow
Visual Basic (Declaration)
Public MustInherit Class AxisArrow
Visual C++
public ref class AxisArrow abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.AxisArrow
PerpetuumSoft.Charts..::.EmptyAxisArrow
PerpetuumSoft.Charts..::.LineAxisArrow
PerpetuumSoft.Charts..::.SharpAngleAxisArrow

See Also

AxisArrow Members
PerpetuumSoft.Charts Namespace


AxisArrow Members

[image] [image]

.NET ModelKit Suite ClassReference
AxisArrow Members
AxisArrow Class Constructors Methods See Also Send Feedback

The AxisArrow type exposes the following members.

Constructors

Name | Description
AxisArrow | Initializes a new instance of the AxisArrow class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSize | Returns size of arrow shape.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Paint | Paints axis arrow shape.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AxisArrow Class
PerpetuumSoft.Charts Namespace


AxisArrow Constructor

[image]

.NET ModelKit Suite ClassReference
AxisArrow Constructor
AxisArrow Class See Also Send Feedback
Initializes a new instance of the AxisArrow class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected AxisArrow()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
AxisArrow()

See Also

AxisArrow Class
PerpetuumSoft.Charts Namespace


AxisArrow Methods

[image] [image]

.NET ModelKit Suite ClassReference
AxisArrow Methods
AxisArrow Class See Also Send Feedback

The AxisArrow type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSize | Returns size of arrow shape.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Paint | Paints axis arrow shape.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AxisArrow Class
PerpetuumSoft.Charts Namespace


GetSize Method

[image]

.NET ModelKit Suite ClassReference
AxisArrow..::.GetSize Method
AxisArrow Class See Also Send Feedback
Returns size of arrow shape.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract Vector GetSize(
    AxisDirection direction
)
Visual Basic (Declaration)
Public MustOverride Function GetSize ( _
    direction As AxisDirection _
) As Vector
Visual C++
public:
virtual Vector GetSize(
    AxisDirection direction
) abstract

Parameters

direction
Type: PerpetuumSoft.Charts..::.AxisDirection

See Also

AxisArrow Class
PerpetuumSoft.Charts Namespace


Paint Method

[image]

.NET ModelKit Suite ClassReference
AxisArrow..::.Paint Method
AxisArrow Class See Also Send Feedback
Paints axis arrow shape.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract void Paint(
    GraphicStream g,
    Vector startPoint,
    AxisDirection direction,
    Stroke stroke,
    bool reverse
)
Visual Basic (Declaration)
Public MustOverride Sub Paint ( _
    g As GraphicStream, _
    startPoint As Vector, _
    direction As AxisDirection, _
    stroke As Stroke, _
    reverse As Boolean _
)
Visual C++
public:
virtual void Paint(
    GraphicStream^ g,
    Vector startPoint,
    AxisDirection direction,
    Stroke^ stroke,
    bool reverse
) abstract

Parameters

g
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
startPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
direction
Type: PerpetuumSoft.Charts..::.AxisDirection
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
reverse
Type: System..::.Boolean

See Also

AxisArrow Class
PerpetuumSoft.Charts Namespace


AxisDirection Enumeration

[image]

.NET ModelKit Suite ClassReference
AxisDirection Enumeration
See Also Send Feedback
Enumerates the axis directions.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public enum AxisDirection
Visual Basic (Declaration)
Public Enumeration AxisDirection
Visual C++
public enum class AxisDirection

Members

Member name | Description
X | Specifies the directions along the X axis in Cartesian coordinates.
Y | Specifies the directions along the Y axis in Cartesian coordinates.

See Also

PerpetuumSoft.Charts Namespace


AxisSeriesView Class

[image]

.NET ModelKit Suite ClassReference
AxisSeriesView Class
Members See Also Send Feedback
Represent a base class for series view displaying series data with the use of coordinate axis.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract class AxisSeriesView : SeriesView
Visual Basic (Declaration)
Public MustInherit Class AxisSeriesView _
    Inherits SeriesView
Visual C++
public ref class AxisSeriesView abstract : public SeriesView

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.AreaSeriesViewBase
PerpetuumSoft.Charts..::.BarSeriesViewBase
PerpetuumSoft.Charts..::.SimpleAxisSeriesView

See Also

AxisSeriesView Members
PerpetuumSoft.Charts Namespace


AxisSeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
AxisSeriesView Members
AxisSeriesView Class Constructors Methods Properties Events See Also Send Feedback

The AxisSeriesView type exposes the following members.

Constructors

Name | Description
AxisSeriesView | Initializes a new instance of the AxisSeriesView class

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series.
CalculateStacked100ValueBounds | Calculates values bounds for stacked100 series.
CalculateStackedValueBounds | Calculates values bounds for stacked series.
ClearSeriesValueRectangles | Clears the segments of the series values.
Clone | Creates an object copy. (Inherited from SeriesView.)
CreateArgumentValuesMap | Creates a Hashtable that contains information on values of the series arguments and the corresponding series values.
CreateElements | Creates elements representing a chart. (Inherited from SeriesView.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Overrides SeriesView..::.GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double).)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value.
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Overrides SeriesView..::.GetSeriesValueType()()().)
GetSideIndent | Gets indents on the scale. (Inherited from SeriesView.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position.
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Overrides SeriesView..::.GetValuePosition(SeriesValueBase, LabelsPosition).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Paints a legend badge for the series. (Inherited from SeriesView.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value.
PaintLegendValueBadge | Paints a legend badge for the series value. (Inherited from SeriesView.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Returns a value that shows whether this chart type is displayed in the legend by the values. (Inherited from SeriesView.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

AxisSeriesView Class
PerpetuumSoft.Charts Namespace


AxisSeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
AxisSeriesView Constructor
AxisSeriesView Class See Also Send Feedback
Initializes a new instance of the AxisSeriesView class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected AxisSeriesView()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
AxisSeriesView()

See Also

AxisSeriesView Class
PerpetuumSoft.Charts Namespace


AxisSeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
AxisSeriesView Methods
AxisSeriesView Class See Also Send Feedback

The AxisSeriesView type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series.
CalculateStacked100ValueBounds | Calculates values bounds for stacked100 series.
CalculateStackedValueBounds | Calculates values bounds for stacked series.
ClearSeriesValueRectangles | Clears the segments of the series values.
Clone | Creates an object copy. (Inherited from SeriesView.)
CreateArgumentValuesMap | Creates a Hashtable that contains information on values of the series arguments and the corresponding series values.
CreateElements | Creates elements representing a chart. (Inherited from SeriesView.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Overrides SeriesView..::.GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double).)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value.
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Overrides SeriesView..::.GetSeriesValueType()()().)
GetSideIndent | Gets indents on the scale. (Inherited from SeriesView.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position.
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Overrides SeriesView..::.GetValuePosition(SeriesValueBase, LabelsPosition).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Paints a legend badge for the series. (Inherited from SeriesView.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value.
PaintLegendValueBadge | Paints a legend badge for the series value. (Inherited from SeriesView.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AxisSeriesView Class
PerpetuumSoft.Charts Namespace


AddSeriesValueSegment Method

[image]

.NET ModelKit Suite ClassReference
AxisSeriesView..::.AddSeriesValueSegment Method
AxisSeriesView Class See Also Send Feedback
Adds a segment that corresponds to the specified value of the series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected void AddSeriesValueSegment(
    SeriesValueBase seriesValue,
    Segment segment
)
Visual Basic (Declaration)
Protected Sub AddSeriesValueSegment ( _
    seriesValue As SeriesValueBase, _
    segment As Segment _
)
Visual C++
protected:
void AddSeriesValueSegment(
    SeriesValueBase^ seriesValue,
    Segment segment
)

Parameters

seriesValue
Type: PerpetuumSoft.Charts..::.SeriesValueBase
segment
Type: PerpetuumSoft.Charts..::.Segment

See Also

AxisSeriesView Class
PerpetuumSoft.Charts Namespace


CalculateStacked100ValueBounds Method

[image]

.NET ModelKit Suite ClassReference
AxisSeriesView..::.CalculateStacked100ValueBounds Method
AxisSeriesView Class See Also Send Feedback
Calculates values bounds for stacked100 series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected static Bounds CalculateStacked100ValueBounds(
    Series[] series
)
Visual Basic (Declaration)
Protected Shared Function CalculateStacked100ValueBounds ( _
    series As Series() _
) As Bounds
Visual C++
protected:
static Bounds CalculateStacked100ValueBounds(
    array<Series^>^ series
)

Parameters

series
Type: array< PerpetuumSoft.Charts..::.Series >[]()[]

See Also

AxisSeriesView Class
PerpetuumSoft.Charts Namespace


CalculateStackedValueBounds Method

[image]

.NET ModelKit Suite ClassReference
AxisSeriesView..::.CalculateStackedValueBounds Method
AxisSeriesView Class See Also Send Feedback
Calculates values bounds for stacked series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected static Bounds CalculateStackedValueBounds(
    Series[] series
)
Visual Basic (Declaration)
Protected Shared Function CalculateStackedValueBounds ( _
    series As Series() _
) As Bounds
Visual C++
protected:
static Bounds CalculateStackedValueBounds(
    array<Series^>^ series
)

Parameters

series
Type: array< PerpetuumSoft.Charts..::.Series >[]()[]

See Also

AxisSeriesView Class
PerpetuumSoft.Charts Namespace


ClearSeriesValueRectangles Method

[image]

.NET ModelKit Suite ClassReference
AxisSeriesView..::.ClearSeriesValueRectangles Method
AxisSeriesView Class See Also Send Feedback
Clears the segments of the series values.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected void ClearSeriesValueRectangles()
Visual Basic (Declaration)
Protected Sub ClearSeriesValueRectangles
Visual C++
protected:
void ClearSeriesValueRectangles()

See Also

AxisSeriesView Class
PerpetuumSoft.Charts Namespace


CreateArgumentValuesMap Method

[image]

.NET ModelKit Suite ClassReference
AxisSeriesView..::.CreateArgumentValuesMap Method
AxisSeriesView Class See Also Send Feedback
Creates a Hashtable that contains information on values of the series arguments and the corresponding series values.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected static ArgumentValuesMap CreateArgumentValuesMap(
    Series[] series
)
Visual Basic (Declaration)
Protected Shared Function CreateArgumentValuesMap ( _
    series As Series() _
) As ArgumentValuesMap
Visual C++
protected:
static ArgumentValuesMap^ CreateArgumentValuesMap(
    array<Series^>^ series
)

Parameters

series
Type: array< PerpetuumSoft.Charts..::.Series >[]()[]

See Also

AxisSeriesView Class
PerpetuumSoft.Charts Namespace


GetLabelPosition Method

[image]

.NET ModelKit Suite ClassReference
AxisSeriesView..::.GetLabelPosition Method
AxisSeriesView Class See Also Send Feedback
Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Vector GetLabelPosition(
    SeriesValueBase seriesValue,
    LabelsPosition labelPosition,
    Vector itemSize,
    double distance
)
Visual Basic (Declaration)
Public Overrides Function GetLabelPosition ( _
    seriesValue As SeriesValueBase, _
    labelPosition As LabelsPosition, _
    itemSize As Vector, _
    distance As Double _
) As Vector
Visual C++
public:
virtual Vector GetLabelPosition(
    SeriesValueBase^ seriesValue,
    LabelsPosition labelPosition,
    Vector itemSize,
    double distance
) override

Parameters

seriesValue
Type: PerpetuumSoft.Charts..::.SeriesValueBase
labelPosition
Type: PerpetuumSoft.Charts..::.LabelsPosition
itemSize
Type: PerpetuumSoft.Framework.Drawing..::.Vector
distance
Type: System..::.Double

See Also

AxisSeriesView Class
PerpetuumSoft.Charts Namespace


GetSegmentBySeriesValue Method

[image]

.NET ModelKit Suite ClassReference
AxisSeriesView..::.GetSegmentBySeriesValue Method
AxisSeriesView Class See Also Send Feedback
Returns a segment that corresponds to the series value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Segment GetSegmentBySeriesValue(
    SeriesValueBase seriesValue
)
Visual Basic (Declaration)
Protected Function GetSegmentBySeriesValue ( _
    seriesValue As SeriesValueBase _
) As Segment
Visual C++
protected:
Segment GetSegmentBySeriesValue(
    SeriesValueBase^ seriesValue
)

Parameters

seriesValue
Type: PerpetuumSoft.Charts..::.SeriesValueBase

See Also

AxisSeriesView Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
AxisSeriesView..::.GetSeries Method
AxisSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

AxisSeriesView Class
AxisSeriesView Members
PerpetuumSoft.Charts Namespace


GetSeriesValueType Method

[image]

.NET ModelKit Suite ClassReference
AxisSeriesView..::.GetSeriesValueType Method
AxisSeriesView Class See Also Send Feedback
Overridden. See GetSeriesValueType()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Type GetSeriesValueType()
Visual Basic (Declaration)
Public Overrides Function GetSeriesValueType As Type
Visual C++
public:
virtual Type^ GetSeriesValueType() override

See Also

AxisSeriesView Class
PerpetuumSoft.Charts Namespace


GetStartPoint Method

[image]

.NET ModelKit Suite ClassReference
AxisSeriesView..::.GetStartPoint Method
AxisSeriesView Class See Also Send Feedback
Returns coordinates of the point that corresponds to the series' zero value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Vector GetStartPoint(
    Vector valuePoint,
    LabelsPosition position,
    Vector itemSize,
    bool negativeValue,
    double distance
)
Visual Basic (Declaration)
Protected Function GetStartPoint ( _
    valuePoint As Vector, _
    position As LabelsPosition, _
    itemSize As Vector, _
    negativeValue As Boolean, _
    distance As Double _
) As Vector
Visual C++
protected:
Vector GetStartPoint(
    Vector valuePoint,
    LabelsPosition position,
    Vector itemSize,
    bool negativeValue,
    double distance
)

Parameters

valuePoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
position
Type: PerpetuumSoft.Charts..::.LabelsPosition
itemSize
Type: PerpetuumSoft.Framework.Drawing..::.Vector
negativeValue
Type: System..::.Boolean
distance
Type: System..::.Double

See Also

AxisSeriesView Class
PerpetuumSoft.Charts Namespace


GetValuePoint Method

[image]

.NET ModelKit Suite ClassReference
AxisSeriesView..::.GetValuePoint Method
AxisSeriesView Class See Also Send Feedback
Returns coordinates of the point that corresponds to the specified value and label position.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Vector GetValuePoint(
    Segment segment,
    LabelsPosition position
)
Visual Basic (Declaration)
Protected Function GetValuePoint ( _
    segment As Segment, _
    position As LabelsPosition _
) As Vector
Visual C++
protected:
Vector GetValuePoint(
    Segment segment,
    LabelsPosition position
)

Parameters

segment
Type: PerpetuumSoft.Charts..::.Segment
position
Type: PerpetuumSoft.Charts..::.LabelsPosition

See Also

AxisSeriesView Class
PerpetuumSoft.Charts Namespace


GetValuePosition Method

[image]

.NET ModelKit Suite ClassReference
AxisSeriesView..::.GetValuePosition Method
AxisSeriesView Class See Also Send Feedback
Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Vector GetValuePosition(
    SeriesValueBase seriesValue,
    LabelsPosition labelPosition
)
Visual Basic (Declaration)
Public Overrides Function GetValuePosition ( _
    seriesValue As SeriesValueBase, _
    labelPosition As LabelsPosition _
) As Vector
Visual C++
public:
virtual Vector GetValuePosition(
    SeriesValueBase^ seriesValue,
    LabelsPosition labelPosition
) override

Parameters

seriesValue
Type: PerpetuumSoft.Charts..::.SeriesValueBase
labelPosition
Type: PerpetuumSoft.Charts..::.LabelsPosition

See Also

AxisSeriesView Class
PerpetuumSoft.Charts Namespace


PaintLegendMarkers Method

[image]

.NET ModelKit Suite ClassReference
AxisSeriesView..::.PaintLegendMarkers Method
AxisSeriesView Class See Also Send Feedback
Paints a marker in a legend for the series value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected void PaintLegendMarkers(
    GraphicStream g,
    Vector legendSize,
    Vector centerMarker,
    int seriesIndex
)
Visual Basic (Declaration)
Protected Sub PaintLegendMarkers ( _
    g As GraphicStream, _
    legendSize As Vector, _
    centerMarker As Vector, _
    seriesIndex As Integer _
)
Visual C++
protected:
void PaintLegendMarkers(
    GraphicStream^ g,
    Vector legendSize,
    Vector centerMarker,
    int seriesIndex
)

Parameters

g
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
legendSize
Type: PerpetuumSoft.Framework.Drawing..::.Vector
centerMarker
Type: PerpetuumSoft.Framework.Drawing..::.Vector
seriesIndex
Type: System..::.Int32

See Also

AxisSeriesView Class
PerpetuumSoft.Charts Namespace


AxisSeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
AxisSeriesView Properties
AxisSeriesView Class See Also Send Feedback

The AxisSeriesView type exposes the following members.

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Returns a value that shows whether this chart type is displayed in the legend by the values. (Inherited from SeriesView.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

See Also

AxisSeriesView Class
PerpetuumSoft.Charts Namespace


AxisSeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
AxisSeriesView Events
AxisSeriesView Class See Also Send Feedback

The AxisSeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

AxisSeriesView Class
PerpetuumSoft.Charts Namespace


AxisType Enumeration

[image]

.NET ModelKit Suite ClassReference
AxisType Enumeration
See Also Send Feedback
Enumerates the destination of the used axis.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public enum AxisType
Visual Basic (Declaration)
Public Enumeration AxisType
Visual C++
public enum class AxisType

Members

Member name | Description
Argument | Specifies that the axis will be used for arguments.
Value | Specifies that the axis will be used for values.

See Also

PerpetuumSoft.Charts Namespace


BarSeriesView Class

[image]

.NET ModelKit Suite ClassReference
BarSeriesView Class
Members See Also Send Feedback
Represents a series view to display series data in the form of bars.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class BarSeriesView : BarSeriesViewBase
Visual Basic (Declaration)
Public Class BarSeriesView _
    Inherits BarSeriesViewBase
Visual C++
public ref class BarSeriesView : public BarSeriesViewBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.BarSeriesViewBase
PerpetuumSoft.Charts..::.BarSeriesView

See Also

BarSeriesView Members
PerpetuumSoft.Charts Namespace


BarSeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
BarSeriesView Members
BarSeriesView Class Constructors Methods Properties Events See Also Send Feedback

The BarSeriesView type exposes the following members.

Constructors

Name | Description
BarSeriesView | Initializes a new instance of the BarSeriesView class.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElements | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from BarSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from BarSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from BarSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AreaWidth | Gets or sets the ratio between the width of the occupied Bars and the available space. (Inherited from BarSeriesViewBase.)
ColumnImage | Gets or sets Image which sets the image drawn in the column. (Inherited from BarSeriesViewBase.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
ImageSizeMode | Gets or sets ImageSizeMode which sets zoom mode for the image displayed in the column. (Inherited from BarSeriesViewBase.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from BarSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
ViewType | Gets or sets ViewType object that determines kind of Bars. (Inherited from BarSeriesViewBase.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

BarSeriesView Class
PerpetuumSoft.Charts Namespace


BarSeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
BarSeriesView Constructor
BarSeriesView Class See Also Send Feedback
Initializes a new instance of the BarSeriesView class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public BarSeriesView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarSeriesView()

See Also

BarSeriesView Class
PerpetuumSoft.Charts Namespace


BarSeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
BarSeriesView Methods
BarSeriesView Class See Also Send Feedback

The BarSeriesView type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElements | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from BarSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from BarSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from BarSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarSeriesView Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
BarSeriesView..::.Clone Method
BarSeriesView Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesView Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesView
Visual C++
public:
virtual SeriesView^ Clone() override

See Also

BarSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElements Method

[image] [image]

.NET ModelKit Suite ClassReference
BarSeriesView..::.CreateElements Method
BarSeriesView Class See Also Send Feedback

Overload List

Name | Description
CreateElements(ChartArea) | Overridden. See CreateElements(ChartArea). (Inherited from BarSeriesViewBase.)
CreateElements(ArgumentValuesMap, ChartArea) | Creates chart elements by series data. (Overrides BarSeriesViewBase..::.CreateElements(ArgumentValuesMap, ChartArea).)

See Also

BarSeriesView Class
BarSeriesView Members
PerpetuumSoft.Charts Namespace


CreateElements Method (, ChartArea)

[image]

.NET ModelKit Suite ClassReference
BarSeriesView..::.CreateElements Method (, ChartArea)
BarSeriesView Class See Also Send Feedback
Creates chart elements by series data.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void CreateElements(
    ArgumentValuesMap map,
    ChartArea area
)
Visual Basic (Declaration)
Protected Overrides Sub CreateElements ( _
    map As ArgumentValuesMap, _
    area As ChartArea _
)
Visual C++
protected:
virtual void CreateElements(
    ArgumentValuesMap^ map,
    ChartArea^ area
) override

Parameters

map
Type: ArgumentValuesMap
area
Type: PerpetuumSoft.Charts..::.ChartArea

See Also

BarSeriesView Class
CreateElements Overload
PerpetuumSoft.Charts Namespace


GetElement Method

[image] [image]

.NET ModelKit Suite ClassReference
BarSeriesView..::.GetElement Method
BarSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetElement(VectorRectangle, Double) | Returns an element that corresponds to the specified area and value. (Inherited from BarSeriesViewBase.)
GetElement(VectorRectangle, Double, Int32) | Returns an element that corresponds to the specified area, value and the number in the palette. (Inherited from BarSeriesViewBase.)

See Also

BarSeriesView Class
BarSeriesView Members
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
BarSeriesView..::.GetSeries Method
BarSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

BarSeriesView Class
BarSeriesView Members
PerpetuumSoft.Charts Namespace


BarSeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
BarSeriesView Properties
BarSeriesView Class See Also Send Feedback

The BarSeriesView type exposes the following members.

Properties

Name | Description
AreaWidth | Gets or sets the ratio between the width of the occupied Bars and the available space. (Inherited from BarSeriesViewBase.)
ColumnImage | Gets or sets Image which sets the image drawn in the column. (Inherited from BarSeriesViewBase.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
ImageSizeMode | Gets or sets ImageSizeMode which sets zoom mode for the image displayed in the column. (Inherited from BarSeriesViewBase.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from BarSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
ViewType | Gets or sets ViewType object that determines kind of Bars. (Inherited from BarSeriesViewBase.)

See Also

BarSeriesView Class
PerpetuumSoft.Charts Namespace


BarSeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
BarSeriesView Events
BarSeriesView Class See Also Send Feedback

The BarSeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

BarSeriesView Class
PerpetuumSoft.Charts Namespace


BarSeriesViewBase Class

[image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase Class
Members See Also Send Feedback
Represent a base class for series view representing series data in the form of bars.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract class BarSeriesViewBase : AxisSeriesView
Visual Basic (Declaration)
Public MustInherit Class BarSeriesViewBase _
    Inherits AxisSeriesView
Visual C++
public ref class BarSeriesViewBase abstract : public AxisSeriesView

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.BarSeriesViewBase
PerpetuumSoft.Charts..::.BarSeriesView
PerpetuumSoft.Charts..::.LevelSeriesView
PerpetuumSoft.Charts..::.Stacked100BarSeriesView
PerpetuumSoft.Charts..::.StackedBarSeriesView
PerpetuumSoft.Charts..::.TankSeriesView

See Also

BarSeriesViewBase Members
PerpetuumSoft.Charts Namespace


BarSeriesViewBase Members

[image] [image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase Members
BarSeriesViewBase Class Constructors Methods Properties Events See Also Send Feedback

The BarSeriesViewBase type exposes the following members.

Constructors

Name | Description
BarSeriesViewBase | Initializes a new instance of the BarSeriesViewBase class

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Creates an object copy. (Inherited from SeriesView.)
CreateElements | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Overrides SeriesView..::.GetSideIndent()()().)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Overrides SeriesView..::.PaintLegendBadge(GraphicStream, VectorRectangle).)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Overrides SeriesView..::.PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AreaWidth | Gets or sets the ratio between the width of the occupied Bars and the available space.
ColumnImage | Gets or sets Image which sets the image drawn in the column.
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
ImageSizeMode | Gets or sets ImageSizeMode which sets zoom mode for the image displayed in the column.
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Overrides SeriesView..::.IsValueLegendItemSupported.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
ViewType | Gets or sets ViewType object that determines kind of Bars.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

BarSeriesViewBase Class
PerpetuumSoft.Charts Namespace


BarSeriesViewBase Constructor

[image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase Constructor
BarSeriesViewBase Class See Also Send Feedback
Initializes a new instance of the BarSeriesViewBase class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected BarSeriesViewBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
BarSeriesViewBase()

See Also

BarSeriesViewBase Class
PerpetuumSoft.Charts Namespace


BarSeriesViewBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase Methods
BarSeriesViewBase Class See Also Send Feedback

The BarSeriesViewBase type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Creates an object copy. (Inherited from SeriesView.)
CreateElements | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Overrides SeriesView..::.GetSideIndent()()().)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Overrides SeriesView..::.PaintLegendBadge(GraphicStream, VectorRectangle).)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Overrides SeriesView..::.PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarSeriesViewBase Class
PerpetuumSoft.Charts Namespace


CreateElements Method

[image] [image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase..::.CreateElements Method
BarSeriesViewBase Class See Also Send Feedback

Overload List

Name | Description
CreateElements(ChartArea) | Overridden. See CreateElements(ChartArea). (Overrides SeriesView..::.CreateElements(ChartArea).)
CreateElements(ArgumentValuesMap, ChartArea) | Creates chart elements by series data.

See Also

BarSeriesViewBase Class
BarSeriesViewBase Members
PerpetuumSoft.Charts Namespace


CreateElements Method (ChartArea)

[image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase..::.CreateElements Method (ChartArea)
BarSeriesViewBase Class See Also Send Feedback
Overridden. See CreateElements(ChartArea).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void CreateElements(
    ChartArea area
)
Visual Basic (Declaration)
Public Overrides Sub CreateElements ( _
    area As ChartArea _
)
Visual C++
public:
virtual void CreateElements(
    ChartArea^ area
) override

Parameters

area
Type: PerpetuumSoft.Charts..::.ChartArea

See Also

BarSeriesViewBase Class
CreateElements Overload
PerpetuumSoft.Charts Namespace


CreateElements Method (, ChartArea)

[image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase..::.CreateElements Method (, ChartArea)
BarSeriesViewBase Class See Also Send Feedback
Creates chart elements by series data.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected abstract void CreateElements(
    ArgumentValuesMap map,
    ChartArea area
)
Visual Basic (Declaration)
Protected MustOverride Sub CreateElements ( _
    map As ArgumentValuesMap, _
    area As ChartArea _
)
Visual C++
protected:
virtual void CreateElements(
    ArgumentValuesMap^ map,
    ChartArea^ area
) abstract

Parameters

map
Type: ArgumentValuesMap
area
Type: PerpetuumSoft.Charts..::.ChartArea

See Also

BarSeriesViewBase Class
CreateElements Overload
PerpetuumSoft.Charts Namespace


GetElement Method

[image] [image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase..::.GetElement Method
BarSeriesViewBase Class See Also Send Feedback

Overload List

Name | Description
GetElement(VectorRectangle, Double) | Returns an element that corresponds to the specified area and value.
GetElement(VectorRectangle, Double, Int32) | Returns an element that corresponds to the specified area, value and the number in the palette.

See Also

BarSeriesViewBase Class
BarSeriesViewBase Members
PerpetuumSoft.Charts Namespace


GetElement Method (VectorRectangle, Double)

[image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase..::.GetElement Method (VectorRectangle, Double)
BarSeriesViewBase Class See Also Send Feedback
Returns an element that corresponds to the specified area and value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected virtual Element GetElement(
    VectorRectangle area,
    double value
)
Visual Basic (Declaration)
Protected Overridable Function GetElement ( _
    area As VectorRectangle, _
    value As Double _
) As Element
Visual C++
protected:
virtual Element^ GetElement(
    VectorRectangle area,
    double value
)

Parameters

area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
value
Type: System..::.Double

See Also

BarSeriesViewBase Class
GetElement Overload
PerpetuumSoft.Charts Namespace


GetElement Method (VectorRectangle, Double, Int32)

[image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase..::.GetElement Method (VectorRectangle, Double, Int32)
BarSeriesViewBase Class See Also Send Feedback
Returns an element that corresponds to the specified area, value and the number in the palette.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected virtual Element GetElement(
    VectorRectangle area,
    double value,
    int paletteIndex
)
Visual Basic (Declaration)
Protected Overridable Function GetElement ( _
    area As VectorRectangle, _
    value As Double, _
    paletteIndex As Integer _
) As Element
Visual C++
protected:
virtual Element^ GetElement(
    VectorRectangle area,
    double value,
    int paletteIndex
)

Parameters

area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
value
Type: System..::.Double
paletteIndex
Type: System..::.Int32

See Also

BarSeriesViewBase Class
GetElement Overload
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase..::.GetSeries Method
BarSeriesViewBase Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

BarSeriesViewBase Class
BarSeriesViewBase Members
PerpetuumSoft.Charts Namespace


GetSideIndent Method

[image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase..::.GetSideIndent Method
BarSeriesViewBase Class See Also Send Feedback
Overridden. See GetSideIndent()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override double GetSideIndent()
Visual Basic (Declaration)
Public Overrides Function GetSideIndent As Double
Visual C++
public:
virtual double GetSideIndent() override

See Also

BarSeriesViewBase Class
PerpetuumSoft.Charts Namespace


PaintLegendBadge Method

[image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase..::.PaintLegendBadge Method
BarSeriesViewBase Class See Also Send Feedback
Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintLegendBadge(
    GraphicStream graphicStream,
    VectorRectangle area
)
Visual Basic (Declaration)
Public Overrides Sub PaintLegendBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle _
)
Visual C++
public:
virtual void PaintLegendBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area
) override

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

BarSeriesViewBase Class
PerpetuumSoft.Charts Namespace


PaintLegendValueBadge Method

[image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase..::.PaintLegendValueBadge Method
BarSeriesViewBase Class See Also Send Feedback
Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintLegendValueBadge(
    GraphicStream graphicStream,
    VectorRectangle area,
    int seriesValueIndex
)
Visual Basic (Declaration)
Public Overrides Sub PaintLegendValueBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle, _
    seriesValueIndex As Integer _
)
Visual C++
public:
virtual void PaintLegendValueBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area,
    int seriesValueIndex
) override

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
seriesValueIndex
Type: System..::.Int32

See Also

BarSeriesViewBase Class
PerpetuumSoft.Charts Namespace


BarSeriesViewBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase Properties
BarSeriesViewBase Class See Also Send Feedback

The BarSeriesViewBase type exposes the following members.

Properties

Name | Description
AreaWidth | Gets or sets the ratio between the width of the occupied Bars and the available space.
ColumnImage | Gets or sets Image which sets the image drawn in the column.
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
ImageSizeMode | Gets or sets ImageSizeMode which sets zoom mode for the image displayed in the column.
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Overrides SeriesView..::.IsValueLegendItemSupported.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
ViewType | Gets or sets ViewType object that determines kind of Bars.

See Also

BarSeriesViewBase Class
PerpetuumSoft.Charts Namespace


AreaWidth Property

[image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase..::.AreaWidth Property
BarSeriesViewBase Class See Also Send Feedback
Gets or sets the ratio between the width of the occupied Bars and the available space.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double AreaWidth { get; set; }
Visual Basic (Declaration)
Public Property AreaWidth As Double
Visual C++
public:
property double AreaWidth {
    double get ();
    void set (double value);
}

See Also

BarSeriesViewBase Class
PerpetuumSoft.Charts Namespace


ColumnImage Property

[image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase..::.ColumnImage Property
BarSeriesViewBase Class See Also Send Feedback
Gets or sets Image which sets the image drawn in the column.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Image ColumnImage { get; set; }
Visual Basic (Declaration)
Public Property ColumnImage As Image
Visual C++
public:
property Image^ ColumnImage {
    Image^ get ();
    void set (Image^ value);
}

See Also

BarSeriesViewBase Class
PerpetuumSoft.Charts Namespace


ImageSizeMode Property

[image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase..::.ImageSizeMode Property
BarSeriesViewBase Class See Also Send Feedback
Gets or sets ImageSizeMode which sets zoom mode for the image displayed in the column.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ImageSizeMode ImageSizeMode { get; set; }
Visual Basic (Declaration)
Public Property ImageSizeMode As ImageSizeMode
Visual C++
public:
property ImageSizeMode ImageSizeMode {
    ImageSizeMode get ();
    void set (ImageSizeMode value);
}

See Also

BarSeriesViewBase Class
PerpetuumSoft.Charts Namespace


IsValueLegendItemSupported Property

[image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase..::.IsValueLegendItemSupported Property
BarSeriesViewBase Class See Also Send Feedback
Overridden. See IsValueLegendItemSupported.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValueLegendItemSupported { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsValueLegendItemSupported As Boolean
Visual C++
public:
virtual property bool IsValueLegendItemSupported {
    bool get () override;
}

See Also

BarSeriesViewBase Class
PerpetuumSoft.Charts Namespace


ViewType Property

[image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase..::.ViewType Property
BarSeriesViewBase Class See Also Send Feedback
Gets or sets ViewType object that determines kind of Bars.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ViewType ViewType { get; set; }
Visual Basic (Declaration)
Public Property ViewType As ViewType
Visual C++
public:
property ViewType ViewType {
    ViewType get ();
    void set (ViewType value);
}

See Also

BarSeriesViewBase Class
PerpetuumSoft.Charts Namespace


BarSeriesViewBase Events

[image] [image]

.NET ModelKit Suite ClassReference
BarSeriesViewBase Events
BarSeriesViewBase Class See Also Send Feedback

The BarSeriesViewBase type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

BarSeriesViewBase Class
PerpetuumSoft.Charts Namespace


Bounds Structure

[image]

.NET ModelKit Suite ClassReference
Bounds Structure
Members See Also Send Feedback
Represents the double value bounds.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public struct Bounds
Visual Basic (Declaration)
Public Structure Bounds
Visual C++
public value class Bounds

See Also

Bounds Members
PerpetuumSoft.Charts Namespace


Bounds Members

[image] [image]

.NET ModelKit Suite ClassReference
Bounds Members
Bounds Structure Constructors Methods Properties See Also Send Feedback

The Bounds type exposes the following members.

Constructors

Name | Description
Bounds | Overloaded.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUnion | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides ValueType..::.ToString()()().)
Union | Overloaded.

Properties

Name | Description
Empty | Gets empty bounds.
IsEmpty | Gets value that indicates that the range is empty.
Length | Gets bounds length.
Max | Gets maximum value in these bounds.
Min | Gets minimum value in these bounds.

See Also

Bounds Structure
PerpetuumSoft.Charts Namespace


Bounds Constructor

[image] [image]

.NET ModelKit Suite ClassReference
Bounds Constructor
Bounds Structure See Also Send Feedback

Overload List

Name | Description
Bounds(Double) | Initializes a new instance of the Bounds, this bound includes one value specified by a given parameter.
Bounds(Double, Double) | Initializes a new instance of the Bounds class that intializes this bound min and max value.

See Also

Bounds Structure
Bounds Members
PerpetuumSoft.Charts Namespace


Bounds Constructor (Double)

[image]

.NET ModelKit Suite ClassReference
Bounds Constructor (Double)
Bounds Structure See Also Send Feedback
Initializes a new instance of the Bounds, this bound includes one value specified by a given parameter.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Bounds(
    double value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Double _
)
Visual C++
public:
Bounds(
    double value
)

Parameters

value
Type: System..::.Double

See Also

Bounds Structure
Bounds Overload
PerpetuumSoft.Charts Namespace


Bounds Constructor (Double, Double)

[image]

.NET ModelKit Suite ClassReference
Bounds Constructor (Double, Double)
Bounds Structure See Also Send Feedback
Initializes a new instance of the Bounds class that intializes this bound min and max value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Bounds(
    double min,
    double max
)
Visual Basic (Declaration)
Public Sub New ( _
    min As Double, _
    max As Double _
)
Visual C++
public:
Bounds(
    double min,
    double max
)

Parameters

min
Type: System..::.Double
max
Type: System..::.Double

See Also

Bounds Structure
Bounds Overload
PerpetuumSoft.Charts Namespace


Bounds Methods

[image] [image]

.NET ModelKit Suite ClassReference
Bounds Methods
Bounds Structure See Also Send Feedback

The Bounds type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUnion | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides ValueType..::.ToString()()().)
Union | Overloaded.

See Also

Bounds Structure
PerpetuumSoft.Charts Namespace


GetUnion Method

[image] [image]

.NET ModelKit Suite ClassReference
Bounds..::.GetUnion Method
Bounds Structure See Also Send Feedback

Overload List

Name | Description
GetUnion(Bounds) | Returns new bounds as a result of these bounds and the bounds specified by parameters.
GetUnion(Double) | Returns new bounds expanded such a way to include the specified value.

See Also

Bounds Structure
Bounds Members
PerpetuumSoft.Charts Namespace


GetUnion Method (Bounds)

[image]

.NET ModelKit Suite ClassReference
Bounds..::.GetUnion Method (Bounds)
Bounds Structure See Also Send Feedback
Returns new bounds as a result of these bounds and the bounds specified by parameters.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Bounds GetUnion(
    Bounds bounds
)
Visual Basic (Declaration)
Public Function GetUnion ( _
    bounds As Bounds _
) As Bounds
Visual C++
public:
Bounds GetUnion(
    Bounds bounds
)

Parameters

bounds
Type: PerpetuumSoft.Charts..::.Bounds

See Also

Bounds Structure
GetUnion Overload
PerpetuumSoft.Charts Namespace


GetUnion Method (Double)

[image]

.NET ModelKit Suite ClassReference
Bounds..::.GetUnion Method (Double)
Bounds Structure See Also Send Feedback
Returns new bounds expanded such a way to include the specified value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Bounds GetUnion(
    double val
)
Visual Basic (Declaration)
Public Function GetUnion ( _
    val As Double _
) As Bounds
Visual C++
public:
Bounds GetUnion(
    double val
)

Parameters

val
Type: System..::.Double

See Also

Bounds Structure
GetUnion Overload
PerpetuumSoft.Charts Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
Bounds..::.ToString Method
Bounds Structure See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Bounds Structure
PerpetuumSoft.Charts Namespace


Union Method

[image] [image]

.NET ModelKit Suite ClassReference
Bounds..::.Union Method
Bounds Structure See Also Send Feedback

Overload List

Name | Description
Union(Bounds) | Unites these bounds with the specified ones.
Union(Double) | Expands bounds in order to include the specified value.

See Also

Bounds Structure
Bounds Members
PerpetuumSoft.Charts Namespace


Union Method (Bounds)

[image]

.NET ModelKit Suite ClassReference
Bounds..::.Union Method (Bounds)
Bounds Structure See Also Send Feedback
Unites these bounds with the specified ones.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Bounds Union(
    Bounds bounds
)
Visual Basic (Declaration)
Public Function Union ( _
    bounds As Bounds _
) As Bounds
Visual C++
public:
Bounds Union(
    Bounds bounds
)

Parameters

bounds
Type: PerpetuumSoft.Charts..::.Bounds

See Also

Bounds Structure
Union Overload
PerpetuumSoft.Charts Namespace


Union Method (Double)

[image]

.NET ModelKit Suite ClassReference
Bounds..::.Union Method (Double)
Bounds Structure See Also Send Feedback
Expands bounds in order to include the specified value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void Union(
    double value
)
Visual Basic (Declaration)
Public Sub Union ( _
    value As Double _
)
Visual C++
public:
void Union(
    double value
)

Parameters

value
Type: System..::.Double

See Also

Bounds Structure
Union Overload
PerpetuumSoft.Charts Namespace


Bounds Properties

[image] [image]

.NET ModelKit Suite ClassReference
Bounds Properties
Bounds Structure See Also Send Feedback

The Bounds type exposes the following members.

Properties

Name | Description
Empty | Gets empty bounds.
IsEmpty | Gets value that indicates that the range is empty.
Length | Gets bounds length.
Max | Gets maximum value in these bounds.
Min | Gets minimum value in these bounds.

See Also

Bounds Structure
PerpetuumSoft.Charts Namespace


Empty Property

[image]

.NET ModelKit Suite ClassReference
Bounds..::.Empty Property
Bounds Structure See Also Send Feedback
Gets empty bounds.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public static Bounds Empty { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Empty As Bounds
Visual C++
public:
static property Bounds Empty {
    Bounds get ();
}

See Also

Bounds Structure
PerpetuumSoft.Charts Namespace


IsEmpty Property

[image]

.NET ModelKit Suite ClassReference
Bounds..::.IsEmpty Property
Bounds Structure See Also Send Feedback
Gets value that indicates that the range is empty.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

Bounds Structure
PerpetuumSoft.Charts Namespace


Length Property

[image]

.NET ModelKit Suite ClassReference
Bounds..::.Length Property
Bounds Structure See Also Send Feedback
Gets bounds length.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Double
Visual C++
public:
property double Length {
    double get ();
}

See Also

Bounds Structure
PerpetuumSoft.Charts Namespace


Max Property

[image]

.NET ModelKit Suite ClassReference
Bounds..::.Max Property
Bounds Structure See Also Send Feedback
Gets maximum value in these bounds.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double Max { get; }
Visual Basic (Declaration)
Public ReadOnly Property Max As Double
Visual C++
public:
property double Max {
    double get ();
}

See Also

Bounds Structure
PerpetuumSoft.Charts Namespace


Min Property

[image]

.NET ModelKit Suite ClassReference
Bounds..::.Min Property
Bounds Structure See Also Send Feedback
Gets minimum value in these bounds.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double Min { get; }
Visual Basic (Declaration)
Public ReadOnly Property Min As Double
Visual C++
public:
property double Min {
    double get ();
}

See Also

Bounds Structure
PerpetuumSoft.Charts Namespace


CandleStickSeriesView Class

[image]

.NET ModelKit Suite ClassReference
CandleStickSeriesView Class
Members See Also Send Feedback
Represents series view for series data painted in the form of the candle stick chart.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class CandleStickSeriesView : FinancialSeriesViewBase
Visual Basic (Declaration)
Public Class CandleStickSeriesView _
    Inherits FinancialSeriesViewBase
Visual C++
public ref class CandleStickSeriesView : public FinancialSeriesViewBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.SimpleAxisSeriesView
PerpetuumSoft.Charts..::.FinancialSeriesViewBase
PerpetuumSoft.Charts..::.CandleStickSeriesView

See Also

CandleStickSeriesView Members
PerpetuumSoft.Charts Namespace


CandleStickSeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
CandleStickSeriesView Members
CandleStickSeriesView Class Constructors Methods Properties Events See Also Send Feedback

The CandleStickSeriesView type exposes the following members.

Constructors

Name | Description
CandleStickSeriesView | Initializes a new instance of the CandleStickSeriesView class.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElement | Creates chart elements by series values. (Overrides FinancialSeriesViewBase..::.CreateElement(Series, FinancialSeriesValue, Boolean).)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates elements which correspond to the specified series. (Inherited from FinancialSeriesViewBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Inherited from FinancialSeriesViewBase.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetReductionValueForSeriesValue | Returns the value field of the financial series with the specified reduction value. (Inherited from FinancialSeriesViewBase.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from FinancialSeriesViewBase.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from FinancialSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Overrides SeriesView..::.PaintLegendBadge(GraphicStream, VectorRectangle).)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from FinancialSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Color | Gets or sets color of elements displaying increasing values.
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from FinancialSeriesViewBase.)
LineWidth | Gets or sets lines width.
ReductionColor | Gets or sets color of elements displaying reducing values.
ReductionValue | Gets or sets a value which indicates according to which field the values with the reduced index will be chosen. (Inherited from FinancialSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
Width | Gets or sets relational width of the element which corresponds to the series value. (Inherited from FinancialSeriesViewBase.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

CandleStickSeriesView Class
PerpetuumSoft.Charts Namespace


CandleStickSeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
CandleStickSeriesView Constructor
CandleStickSeriesView Class See Also Send Feedback
Initializes a new instance of the CandleStickSeriesView class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public CandleStickSeriesView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CandleStickSeriesView()

See Also

CandleStickSeriesView Class
PerpetuumSoft.Charts Namespace


CandleStickSeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
CandleStickSeriesView Methods
CandleStickSeriesView Class See Also Send Feedback

The CandleStickSeriesView type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElement | Creates chart elements by series values. (Overrides FinancialSeriesViewBase..::.CreateElement(Series, FinancialSeriesValue, Boolean).)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates elements which correspond to the specified series. (Inherited from FinancialSeriesViewBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Inherited from FinancialSeriesViewBase.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetReductionValueForSeriesValue | Returns the value field of the financial series with the specified reduction value. (Inherited from FinancialSeriesViewBase.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from FinancialSeriesViewBase.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from FinancialSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Overrides SeriesView..::.PaintLegendBadge(GraphicStream, VectorRectangle).)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from FinancialSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CandleStickSeriesView Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
CandleStickSeriesView..::.Clone Method
CandleStickSeriesView Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesView Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesView
Visual C++
public:
virtual SeriesView^ Clone() override

See Also

CandleStickSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElement Method

[image]

.NET ModelKit Suite ClassReference
CandleStickSeriesView..::.CreateElement Method
CandleStickSeriesView Class See Also Send Feedback
Creates chart elements by series values.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void CreateElement(
    Series series,
    FinancialSeriesValue seriesValue,
    bool isReduction
)
Visual Basic (Declaration)
Protected Overrides Sub CreateElement ( _
    series As Series, _
    seriesValue As FinancialSeriesValue, _
    isReduction As Boolean _
)
Visual C++
protected:
virtual void CreateElement(
    Series^ series,
    FinancialSeriesValue^ seriesValue,
    bool isReduction
) override

Parameters

series
Type: PerpetuumSoft.Charts..::.Series
seriesValue
Type: PerpetuumSoft.Charts..::.FinancialSeriesValue
isReduction
Type: System..::.Boolean

See Also

CandleStickSeriesView Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
CandleStickSeriesView..::.GetSeries Method
CandleStickSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

CandleStickSeriesView Class
CandleStickSeriesView Members
PerpetuumSoft.Charts Namespace


PaintLegendBadge Method

[image]

.NET ModelKit Suite ClassReference
CandleStickSeriesView..::.PaintLegendBadge Method
CandleStickSeriesView Class See Also Send Feedback
Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintLegendBadge(
    GraphicStream graphicStream,
    VectorRectangle area
)
Visual Basic (Declaration)
Public Overrides Sub PaintLegendBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle _
)
Visual C++
public:
virtual void PaintLegendBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area
) override

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

CandleStickSeriesView Class
PerpetuumSoft.Charts Namespace


CandleStickSeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
CandleStickSeriesView Properties
CandleStickSeriesView Class See Also Send Feedback

The CandleStickSeriesView type exposes the following members.

Properties

Name | Description
Color | Gets or sets color of elements displaying increasing values.
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from FinancialSeriesViewBase.)
LineWidth | Gets or sets lines width.
ReductionColor | Gets or sets color of elements displaying reducing values.
ReductionValue | Gets or sets a value which indicates according to which field the values with the reduced index will be chosen. (Inherited from FinancialSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
Width | Gets or sets relational width of the element which corresponds to the series value. (Inherited from FinancialSeriesViewBase.)

See Also

CandleStickSeriesView Class
PerpetuumSoft.Charts Namespace


Color Property

[image]

.NET ModelKit Suite ClassReference
CandleStickSeriesView..::.Color Property
CandleStickSeriesView Class See Also Send Feedback
Gets or sets color of elements displaying increasing values.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

CandleStickSeriesView Class
PerpetuumSoft.Charts Namespace


LineWidth Property

[image]

.NET ModelKit Suite ClassReference
CandleStickSeriesView..::.LineWidth Property
CandleStickSeriesView Class See Also Send Feedback
Gets or sets lines width.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double LineWidth { get; set; }
Visual Basic (Declaration)
Public Property LineWidth As Double
Visual C++
public:
property double LineWidth {
    double get ();
    void set (double value);
}

See Also

CandleStickSeriesView Class
PerpetuumSoft.Charts Namespace


ReductionColor Property

[image]

.NET ModelKit Suite ClassReference
CandleStickSeriesView..::.ReductionColor Property
CandleStickSeriesView Class See Also Send Feedback
Gets or sets color of elements displaying reducing values.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Color ReductionColor { get; set; }
Visual Basic (Declaration)
Public Property ReductionColor As Color
Visual C++
public:
property Color ReductionColor {
    Color get ();
    void set (Color value);
}

See Also

CandleStickSeriesView Class
PerpetuumSoft.Charts Namespace


CandleStickSeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
CandleStickSeriesView Events
CandleStickSeriesView Class See Also Send Feedback

The CandleStickSeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

CandleStickSeriesView Class
PerpetuumSoft.Charts Namespace


Chart Class

[image]

.NET ModelKit Suite ClassReference
Chart Class
Members See Also Send Feedback
Represents a chart.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class Chart : Instrument, ISupportInitialize
Visual Basic (Declaration)
Public Class Chart _
    Inherits Instrument _
    Implements ISupportInitialize
Visual C++
public ref class Chart : public Instrument,
    ISupportInitialize

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.Composite
PerpetuumSoft.Instrumentation.Model..::.Instrument
PerpetuumSoft.Charts..::.Chart

See Also

Chart Members
PerpetuumSoft.Charts Namespace


Chart Members

[image] [image]

.NET ModelKit Suite ClassReference
Chart Members
Chart Class Constructors Methods Properties Events See Also Send Feedback

The Chart type exposes the following members.

Constructors

Name | Description
Chart | Initializes a new instance of the Chart class.

Methods

Name | Description
BeginInit | Implements BeginInit()()().
BeginUpdate | Starts the group operations, where Invalidate method will be called once for the whole group. (Inherited from Instrument.)
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
CreateChartDesignerForm | Creates chart designer form with the specific settings.
CreateImage | Overloaded.
DataChanged | Indicates that the data in the chart source have been changed. Leads to the chart renewal.
Dispose | Overloaded.
EndInit | Implements EndInit()()().
EndUpdate | Completes the group operations, where Invalidate method was called once for whole group. (Inherited from Instrument.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Instrument.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetDockingBounds | Gets rectangular area in which the inner content will be located. (Inherited from Instrument.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Instrument.)
GetFunction | Implements GetFunction(String). (Inherited from Instrument.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Instrument.)
GetParameterValue | Returns value of the instrument parameter by its name. (Inherited from Instrument.)
GetPropertyNames | (Inherited from Instrument.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetDataSources | Resets selected data sources. (Inherited from Instrument.)
SaveAsImage | Overloaded.
SetParameterValue | Sets value of the instrument parameter by its name. (Inherited from Instrument.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Write | Overloaded.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Bevel | Gets or sets Bevel which sets the drawing style of the bevel around the instrument. (Inherited from Instrument.)
Bounds | Gets the bounds of the instrument. (Inherited from Instrument.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Instrument.)
CustomFunctions | Gets collection of user defined functions to use in expressions specially set for this instrument. (Inherited from Instrument.)
DataContext | Gets or sets IDataContext object for data provide. (Inherited from Instrument.)
Elements | Implements Elements. (Inherited from Composite.)
Enabled | Gets or sets whether the instrument handles the mouse events. (Inherited from Instrument.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Focused | Gets or sets whether the instrument has the focus. (Inherited from Instrument.)
GridStep | Gets or sets the step of the grid in the design mode. (Inherited from Instrument.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
IsFixed | Gets or sets the value which indicates that the instrument size is not changed. (Inherited from Instrument.)
MeasureUnit | Gets and sets the measure unit for the instrument. (Inherited from Instrument.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
ShowGrid | Gets and sets whether the grid should be displayed in the design mode. (Inherited from Instrument.)
Size | Gets or sets the instrument size. (Inherited from Instrument.)
Smooth | Gets or sets value that indicates whether smoothing will be applied. (Inherited from Instrument.)
SnapToGrid | Gets and sets whether objects should be snapped to grid in the design mode. (Inherited from Instrument.)
Stroke | Gets or sets the Stroke object that is used to trace. (Inherited from Instrument.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
StyleProvider | (Inherited from Instrument.)
Styles | Gets the collection of styles. (Inherited from Instrument.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
Invalidated | Occurs after the element's display requires redrawing. (Inherited from Instrument.)
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Chart Class
PerpetuumSoft.Charts Namespace


Chart Constructor

[image]

.NET ModelKit Suite ClassReference
Chart Constructor
Chart Class See Also Send Feedback
Initializes a new instance of the Chart class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Chart()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Chart()

See Also

Chart Class
PerpetuumSoft.Charts Namespace


Chart Methods

[image] [image]

.NET ModelKit Suite ClassReference
Chart Methods
Chart Class See Also Send Feedback

The Chart type exposes the following members.

Methods

Name | Description
BeginInit | Implements BeginInit()()().
BeginUpdate | Starts the group operations, where Invalidate method will be called once for the whole group. (Inherited from Instrument.)
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
CreateChartDesignerForm | Creates chart designer form with the specific settings.
CreateImage | Overloaded.
DataChanged | Indicates that the data in the chart source have been changed. Leads to the chart renewal.
Dispose | Overloaded.
EndInit | Implements EndInit()()().
EndUpdate | Completes the group operations, where Invalidate method was called once for whole group. (Inherited from Instrument.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Instrument.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetDockingBounds | Gets rectangular area in which the inner content will be located. (Inherited from Instrument.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Instrument.)
GetFunction | Implements GetFunction(String). (Inherited from Instrument.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Instrument.)
GetParameterValue | Returns value of the instrument parameter by its name. (Inherited from Instrument.)
GetPropertyNames | (Inherited from Instrument.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetDataSources | Resets selected data sources. (Inherited from Instrument.)
SaveAsImage | Overloaded.
SetParameterValue | Sets value of the instrument parameter by its name. (Inherited from Instrument.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Write | Overloaded.

See Also

Chart Class
PerpetuumSoft.Charts Namespace


BeginInit Method

[image]

.NET ModelKit Suite ClassReference
Chart..::.BeginInit Method
Chart Class See Also Send Feedback
Implements BeginInit()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void BeginInit()
Visual Basic (Declaration)
Public Sub BeginInit
Visual C++
public:
virtual void BeginInit() sealed

Implements

ISupportInitialize..::.BeginInit()()()

See Also

Chart Class
PerpetuumSoft.Charts Namespace


CreateChartDesignerForm Method

[image]

.NET ModelKit Suite ClassReference
Chart..::.CreateChartDesignerForm Method
Chart Class See Also Send Feedback
Creates chart designer form with the specific settings.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public static DesignerForm CreateChartDesignerForm()
Visual Basic (Declaration)
Public Shared Function CreateChartDesignerForm As DesignerForm
Visual C++
public:
static DesignerForm^ CreateChartDesignerForm()

See Also

Chart Class
PerpetuumSoft.Charts Namespace


CreateImage Method

[image] [image]

.NET ModelKit Suite ClassReference
Chart..::.CreateImage Method
Chart Class See Also Send Feedback

Overload List

Name | Description
CreateImage()()() | Creates image. (Inherited from Instrument.)
CreateImage(Single) | Creates image with a given resolution. (Inherited from Instrument.)
CreateImage(Int32, Int32) | Creates image with a given size. (Inherited from Instrument.)
CreateImage(Single, Single) | Creates image with a given resolution and scale. (Inherited from Instrument.)
CreateImage(Int32, Int32, Single) | Creates image with a given size and scale. (Inherited from Instrument.)

See Also

Chart Class
Chart Members
PerpetuumSoft.Charts Namespace


DataChanged Method

[image]

.NET ModelKit Suite ClassReference
Chart..::.DataChanged Method
Chart Class See Also Send Feedback
Indicates that the data in the chart source have been changed. Leads to the chart renewal.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void DataChanged()
Visual Basic (Declaration)
Public Sub DataChanged
Visual C++
public:
void DataChanged()

See Also

Chart Class
PerpetuumSoft.Charts Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Chart..::.Dispose Method
Chart Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from Composite.)

See Also

Chart Class
Chart Members
PerpetuumSoft.Charts Namespace


EndInit Method

[image]

.NET ModelKit Suite ClassReference
Chart..::.EndInit Method
Chart Class See Also Send Feedback
Implements EndInit()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void EndInit()
Visual Basic (Declaration)
Public Sub EndInit
Visual C++
public:
virtual void EndInit() sealed

Implements

ISupportInitialize..::.EndInit()()()

See Also

Chart Class
PerpetuumSoft.Charts Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Chart..::.GetStyle Method
Chart Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Overridden. See GetStyle(String). (Inherited from Instrument.)

See Also

Chart Class
Chart Members
PerpetuumSoft.Charts Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Chart..::.Invalidate Method
Chart Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Instrument.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Instrument.)

See Also

Chart Class
Chart Members
PerpetuumSoft.Charts Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Chart..::.OnPaint Method
Chart Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Inherited from Instrument.)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

Chart Class
Chart Members
PerpetuumSoft.Charts Namespace


SaveAsImage Method

[image] [image]

.NET ModelKit Suite ClassReference
Chart..::.SaveAsImage Method
Chart Class See Also Send Feedback

Overload List

Name | Description
SaveAsImage(Stream, PictureFormat) | Saves instrument as image to the given stream with given size, scale and PictureFormat. (Inherited from Instrument.)
SaveAsImage(Stream, Int32) | Saves instrument as JPEG image into given stream with given jpegQuality. (Inherited from Instrument.)
SaveAsImage(String, PictureFormat) | Saves instrument as image to the given filename with given PictureFormat. (Inherited from Instrument.)
SaveAsImage(String, Int32) | Saves instrument as JPEG image into given filename with given jpegQuality. (Inherited from Instrument.)
SaveAsImage(Stream, Single, PictureFormat) | Saves instrument as image to the given stream with given resolution and PictureFormat. (Inherited from Instrument.)
SaveAsImage(Stream, Single, Int32) | Saves instrument as JPEG image into given stream with given resolution and jpegQuality. (Inherited from Instrument.)
SaveAsImage(String, Single, PictureFormat) | Saves instrument as image to the given filename with given resolution and PictureFormat. (Inherited from Instrument.)
SaveAsImage(String, Single, Int32) | Saves instrument as JPEG image into given filename with given resolution and jpegQuality. (Inherited from Instrument.)
SaveAsImage(Stream, Int32, Int32, PictureFormat) | Saves instrument as image to the given filename with given size and PictureFormat. (Inherited from Instrument.)
SaveAsImage(Stream, Int32, Int32, Int32) | Saves instrument as JPEG image into given stream with given size and jpegQuality. (Inherited from Instrument.)
SaveAsImage(Stream, Single, Single, PictureFormat) | Saves instrument as image to the given stream with given resolution, scale and PictureFormat. (Inherited from Instrument.)
SaveAsImage(Stream, Single, Single, Int32) | Saves instrument as JPEG image into given stream with given resolution, scale and jpegQuality. (Inherited from Instrument.)
SaveAsImage(String, Int32, Int32, PictureFormat) | Saves instrument as image to a file with given name with given height, width and PictureFormat. (Inherited from Instrument.)
SaveAsImage(String, Int32, Int32, Int32) | Saves instrument as JPEG image into given filename with given size and jpegQuality. (Inherited from Instrument.)
SaveAsImage(String, Single, Single, PictureFormat) | Saves instrument as image to the given filename with given resolution, scale and PictureFormat. (Inherited from Instrument.)
SaveAsImage(String, Single, Single, Int32) | Saves instrument as JPEG image into given filename with given resolution, scale and jpegQuality. (Inherited from Instrument.)
SaveAsImage(Stream, Int32, Int32, Single, PictureFormat) | Saves instrument as image to the given stream with given size, scale and PictureFormat. (Inherited from Instrument.)
SaveAsImage(Stream, Int32, Int32, Single, Int32) | Saves instrument as JPEG image into given stream with given size, scale and jpegQuality. (Inherited from Instrument.)
SaveAsImage(String, Int32, Int32, Single, PictureFormat) | Saves instrument as image to a file with given name. (Inherited from Instrument.)
SaveAsImage(String, Int32, Int32, Single, Int32) | Saves instrument as JPEG image into given filename with given size, scale and jpegQuality. (Inherited from Instrument.)

See Also

Chart Class
Chart Members
PerpetuumSoft.Charts Namespace


Write Method

[image] [image]

.NET ModelKit Suite ClassReference
Chart..::.Write Method
Chart Class See Also Send Feedback

Overload List

Name | Description
Write(Stream) | Serializes instrument into given stream. (Inherited from Instrument.)
Write(String) | Serializes instrument into given filename. (Inherited from Instrument.)

See Also

Chart Class
Chart Members
PerpetuumSoft.Charts Namespace


Chart Properties

[image] [image]

.NET ModelKit Suite ClassReference
Chart Properties
Chart Class See Also Send Feedback

The Chart type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Bevel | Gets or sets Bevel which sets the drawing style of the bevel around the instrument. (Inherited from Instrument.)
Bounds | Gets the bounds of the instrument. (Inherited from Instrument.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Instrument.)
CustomFunctions | Gets collection of user defined functions to use in expressions specially set for this instrument. (Inherited from Instrument.)
DataContext | Gets or sets IDataContext object for data provide. (Inherited from Instrument.)
Elements | Implements Elements. (Inherited from Composite.)
Enabled | Gets or sets whether the instrument handles the mouse events. (Inherited from Instrument.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Focused | Gets or sets whether the instrument has the focus. (Inherited from Instrument.)
GridStep | Gets or sets the step of the grid in the design mode. (Inherited from Instrument.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
IsFixed | Gets or sets the value which indicates that the instrument size is not changed. (Inherited from Instrument.)
MeasureUnit | Gets and sets the measure unit for the instrument. (Inherited from Instrument.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
ShowGrid | Gets and sets whether the grid should be displayed in the design mode. (Inherited from Instrument.)
Size | Gets or sets the instrument size. (Inherited from Instrument.)
Smooth | Gets or sets value that indicates whether smoothing will be applied. (Inherited from Instrument.)
SnapToGrid | Gets and sets whether objects should be snapped to grid in the design mode. (Inherited from Instrument.)
Stroke | Gets or sets the Stroke object that is used to trace. (Inherited from Instrument.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
StyleProvider | (Inherited from Instrument.)
Styles | Gets the collection of styles. (Inherited from Instrument.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Chart Class
PerpetuumSoft.Charts Namespace


Chart Events

[image] [image]

.NET ModelKit Suite ClassReference
Chart Events
Chart Class See Also Send Feedback

The Chart type exposes the following members.

Events

Name | Description
Invalidated | Occurs after the element's display requires redrawing. (Inherited from Instrument.)
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Chart Class
PerpetuumSoft.Charts Namespace


ChartArea Class

[image]

.NET ModelKit Suite ClassReference
ChartArea Class
Members See Also Send Feedback
Represents chart area for the series painting.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class ChartArea : RectangleComposite, ISupportInitialize
Visual Basic (Declaration)
Public Class ChartArea _
    Inherits RectangleComposite _
    Implements ISupportInitialize
Visual C++
public ref class ChartArea : public RectangleComposite,
    ISupportInitialize

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.Composite
PerpetuumSoft.Charts..::.RectangleComposite
PerpetuumSoft.Charts..::.ChartArea

See Also

ChartArea Members
PerpetuumSoft.Charts Namespace


ChartArea Members

[image] [image]

.NET ModelKit Suite ClassReference
ChartArea Members
ChartArea Class Constructors Methods Properties Events See Also Send Feedback

The ChartArea type exposes the following members.

Constructors

Name | Description
ChartArea | Initializes a new instance of the ChartArea class.

Methods

Name | Description
BeginInit | Implements BeginInit()()().
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Overrides Composite..::.Calculate()()().)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | Occurs when the child element is removed. (Overrides Composite..::.ChildElementRemoved(Element).)
Dispose | Overloaded.
DrawContent | Draws the content of this element. (Overrides RectangleComposite..::.DrawContent(PaintArguments).)
EndInit | Implements EndInit()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetAxes | Returns all axes included in the ChartArea.
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleComposite.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Overrides RectangleComposite..::.GetElementAt(Vector).)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetPrimaryAxis | Returns the primary axis by the specified direction.
GetSeries | Returns all axes included in the ChartArea.
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MakeStatic | Modifies a chart such way that it contains the current series values independently of the data source.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Bounds | Gets or sets bounds of the area occupied by an element. (Inherited from RectangleComposite.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from RectangleComposite.)
Dock | Gets or sets docking style.
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Margins | Gets or sets area margins.
Name | Gets or sets the element's name. (Inherited from Element.)
PaintContext | Gets ChartPaintContext the context for a chart drawing.
PaintingArea | Gets an area to which series are painted.
Palette | Gets or sets palette used by series included into this ChartArea.
Parent | Implements Parent. (Inherited from Element.)
PrimaryArgumentAxis | Gets or sets the primary axis on which the arguments are placed.
PrimaryValueAxis | Gets or sets the primary axis on which the values are placed.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets the size of the rectangle. (Inherited from RectangleComposite.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


ChartArea Constructor

[image]

.NET ModelKit Suite ClassReference
ChartArea Constructor
ChartArea Class See Also Send Feedback
Initializes a new instance of the ChartArea class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ChartArea()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartArea()

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


ChartArea Methods

[image] [image]

.NET ModelKit Suite ClassReference
ChartArea Methods
ChartArea Class See Also Send Feedback

The ChartArea type exposes the following members.

Methods

Name | Description
BeginInit | Implements BeginInit()()().
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Overrides Composite..::.Calculate()()().)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | Occurs when the child element is removed. (Overrides Composite..::.ChildElementRemoved(Element).)
Dispose | Overloaded.
DrawContent | Draws the content of this element. (Overrides RectangleComposite..::.DrawContent(PaintArguments).)
EndInit | Implements EndInit()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetAxes | Returns all axes included in the ChartArea.
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleComposite.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Overrides RectangleComposite..::.GetElementAt(Vector).)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetPrimaryAxis | Returns the primary axis by the specified direction.
GetSeries | Returns all axes included in the ChartArea.
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MakeStatic | Modifies a chart such way that it contains the current series values independently of the data source.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


BeginInit Method

[image]

.NET ModelKit Suite ClassReference
ChartArea..::.BeginInit Method
ChartArea Class See Also Send Feedback
Implements BeginInit()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void BeginInit()
Visual Basic (Declaration)
Public Sub BeginInit
Visual C++
public:
virtual void BeginInit() sealed

Implements

ISupportInitialize..::.BeginInit()()()

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


Calculate Method

[image]

.NET ModelKit Suite ClassReference
ChartArea..::.Calculate Method
ChartArea Class See Also Send Feedback
Overridden. See Calculate()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void Calculate()
Visual Basic (Declaration)
Protected Overrides Sub Calculate
Visual C++
protected:
virtual void Calculate() override

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


ChildElementRemoved Method

[image]

.NET ModelKit Suite ClassReference
ChartArea..::.ChildElementRemoved Method
ChartArea Class See Also Send Feedback
Occurs when the child element is removed.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void ChildElementRemoved(
    Element element
)
Visual Basic (Declaration)
Protected Overrides Sub ChildElementRemoved ( _
    element As Element _
)
Visual C++
protected:
virtual void ChildElementRemoved(
    Element^ element
) override

Parameters

element
Type: PerpetuumSoft.Instrumentation.Model..::.Element

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartArea..::.Dispose Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from Composite.)

See Also

ChartArea Class
ChartArea Members
PerpetuumSoft.Charts Namespace


DrawContent Method

[image]

.NET ModelKit Suite ClassReference
ChartArea..::.DrawContent Method
ChartArea Class See Also Send Feedback
Draws the content of this element.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void DrawContent(
    PaintArguments args
)
Visual Basic (Declaration)
Protected Overrides Sub DrawContent ( _
    args As PaintArguments _
)
Visual C++
protected:
virtual void DrawContent(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


EndInit Method

[image]

.NET ModelKit Suite ClassReference
ChartArea..::.EndInit Method
ChartArea Class See Also Send Feedback
Implements EndInit()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void EndInit()
Visual Basic (Declaration)
Public Sub EndInit
Visual C++
public:
virtual void EndInit() sealed

Implements

ISupportInitialize..::.EndInit()()()

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


GetAxes Method

[image]

.NET ModelKit Suite ClassReference
ChartArea..::.GetAxes Method
ChartArea Class See Also Send Feedback
Returns all axes included in the ChartArea.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Axis[] GetAxes()
Visual Basic (Declaration)
Public Function GetAxes As Axis()
Visual C++
public:
array<Axis^>^ GetAxes()

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


GetElementAt Method

[image]

.NET ModelKit Suite ClassReference
ChartArea..::.GetElementAt Method
ChartArea Class See Also Send Feedback
Implements GetElementAt(Vector).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override IElement GetElementAt(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetElementAt ( _
    point As Vector _
) As IElement
Visual C++
public:
virtual IElement^ GetElementAt(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

Implements

IElement..::.GetElementAt(Vector)
IElement..::.GetElementAt(Vector)

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


GetPrimaryAxis Method

[image]

.NET ModelKit Suite ClassReference
ChartArea..::.GetPrimaryAxis Method
ChartArea Class See Also Send Feedback
Returns the primary axis by the specified direction.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Axis GetPrimaryAxis(
    AxisDirection direction
)
Visual Basic (Declaration)
Public Function GetPrimaryAxis ( _
    direction As AxisDirection _
) As Axis
Visual C++
public:
Axis^ GetPrimaryAxis(
    AxisDirection direction
)

Parameters

direction
Type: PerpetuumSoft.Charts..::.AxisDirection

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image]

.NET ModelKit Suite ClassReference
ChartArea..::.GetSeries Method
ChartArea Class See Also Send Feedback
Returns all axes included in the ChartArea.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Series[] GetSeries()
Visual Basic (Declaration)
Public Function GetSeries As Series()
Visual C++
public:
array<Series^>^ GetSeries()

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartArea..::.GetStyle Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

ChartArea Class
ChartArea Members
PerpetuumSoft.Charts Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartArea..::.Invalidate Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

ChartArea Class
ChartArea Members
PerpetuumSoft.Charts Namespace


MakeStatic Method

[image]

.NET ModelKit Suite ClassReference
ChartArea..::.MakeStatic Method
ChartArea Class See Also Send Feedback
Modifies a chart such way that it contains the current series values independently of the data source.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void MakeStatic()
Visual Basic (Declaration)
Public Sub MakeStatic
Visual C++
public:
void MakeStatic()

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartArea..::.OnPaint Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Overrides RectangleComposite..::.OnPaint(PaintArguments).)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

ChartArea Class
ChartArea Members
PerpetuumSoft.Charts Namespace


OnPaint Method (PaintArguments)

[image]

.NET ModelKit Suite ClassReference
ChartArea..::.OnPaint Method (PaintArguments)
ChartArea Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

ChartArea Class
OnPaint Overload
PerpetuumSoft.Charts Namespace


ChartArea Properties

[image] [image]

.NET ModelKit Suite ClassReference
ChartArea Properties
ChartArea Class See Also Send Feedback

The ChartArea type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Bounds | Gets or sets bounds of the area occupied by an element. (Inherited from RectangleComposite.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from RectangleComposite.)
Dock | Gets or sets docking style.
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Margins | Gets or sets area margins.
Name | Gets or sets the element's name. (Inherited from Element.)
PaintContext | Gets ChartPaintContext the context for a chart drawing.
PaintingArea | Gets an area to which series are painted.
Palette | Gets or sets palette used by series included into this ChartArea.
Parent | Implements Parent. (Inherited from Element.)
PrimaryArgumentAxis | Gets or sets the primary axis on which the arguments are placed.
PrimaryValueAxis | Gets or sets the primary axis on which the values are placed.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets the size of the rectangle. (Inherited from RectangleComposite.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


Dock Property

[image]

.NET ModelKit Suite ClassReference
ChartArea..::.Dock Property
ChartArea Class See Also Send Feedback
Gets or sets docking style.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ChartAreaDockStyle Dock { get; set; }
Visual Basic (Declaration)
Public Property Dock As ChartAreaDockStyle
Visual C++
public:
property ChartAreaDockStyle Dock {
    ChartAreaDockStyle get ();
    void set (ChartAreaDockStyle value);
}

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


Margins Property

[image]

.NET ModelKit Suite ClassReference
ChartArea..::.Margins Property
ChartArea Class See Also Send Feedback
Gets or sets area margins.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Margins Margins { get; set; }
Visual Basic (Declaration)
Public Property Margins As Margins
Visual C++
public:
property Margins Margins {
    Margins get ();
    void set (Margins value);
}

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


PaintContext Property

[image]

.NET ModelKit Suite ClassReference
ChartArea..::.PaintContext Property
ChartArea Class See Also Send Feedback
Gets ChartPaintContext the context for a chart drawing.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ChartPaintContext PaintContext { get; }
Visual Basic (Declaration)
Public ReadOnly Property PaintContext As ChartPaintContext
Visual C++
public:
property ChartPaintContext^ PaintContext {
    ChartPaintContext^ get ();
}

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


PaintingArea Property

[image]

.NET ModelKit Suite ClassReference
ChartArea..::.PaintingArea Property
ChartArea Class See Also Send Feedback
Gets an area to which series are painted.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle PaintingArea { get; }
Visual Basic (Declaration)
Public ReadOnly Property PaintingArea As VectorRectangle
Visual C++
public:
property VectorRectangle PaintingArea {
    VectorRectangle get ();
}

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


Palette Property

[image]

.NET ModelKit Suite ClassReference
ChartArea..::.Palette Property
ChartArea Class See Also Send Feedback
Gets or sets palette used by series included into this ChartArea.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Palette Palette { get; set; }
Visual Basic (Declaration)
Public Property Palette As Palette
Visual C++
public:
property Palette^ Palette {
    Palette^ get ();
    void set (Palette^ value);
}

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


PrimaryArgumentAxis Property

[image]

.NET ModelKit Suite ClassReference
ChartArea..::.PrimaryArgumentAxis Property
ChartArea Class See Also Send Feedback
Gets or sets the primary axis on which the arguments are placed.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Axis PrimaryArgumentAxis { get; set; }
Visual Basic (Declaration)
Public Property PrimaryArgumentAxis As Axis
Visual C++
public:
property Axis^ PrimaryArgumentAxis {
    Axis^ get ();
    void set (Axis^ value);
}

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


PrimaryValueAxis Property

[image]

.NET ModelKit Suite ClassReference
ChartArea..::.PrimaryValueAxis Property
ChartArea Class See Also Send Feedback
Gets or sets the primary axis on which the values are placed.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Axis PrimaryValueAxis { get; set; }
Visual Basic (Declaration)
Public Property PrimaryValueAxis As Axis
Visual C++
public:
property Axis^ PrimaryValueAxis {
    Axis^ get ();
    void set (Axis^ value);
}

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


ChartArea Events

[image] [image]

.NET ModelKit Suite ClassReference
ChartArea Events
ChartArea Class See Also Send Feedback

The ChartArea type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ChartArea Class
PerpetuumSoft.Charts Namespace


ChartAreaDockStyle Enumeration

[image]

.NET ModelKit Suite ClassReference
ChartAreaDockStyle Enumeration
See Also Send Feedback
Enumerates dock style for chart area.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public enum ChartAreaDockStyle
Visual Basic (Declaration)
Public Enumeration ChartAreaDockStyle
Visual C++
public enum class ChartAreaDockStyle

Members

Member name | Description
None | Specifies lack of the docking.
Client | Specifies docking to the whole client region.

See Also

PerpetuumSoft.Charts Namespace


ChartComposite Class

[image]

.NET ModelKit Suite ClassReference
ChartComposite Class
Members See Also Send Feedback
Represents a base class for charts constituents.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract class ChartComposite : Composite,
    IChartElement
Visual Basic (Declaration)
Public MustInherit Class ChartComposite _
    Inherits Composite _
    Implements IChartElement
Visual C++
public ref class ChartComposite abstract : public Composite,
    IChartElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.Composite
PerpetuumSoft.Charts..::.ChartComposite
PerpetuumSoft.Charts..::.Axis
PerpetuumSoft.Charts..::.SeriesBase

See Also

ChartComposite Members
PerpetuumSoft.Charts Namespace


ChartComposite Members

[image] [image]

.NET ModelKit Suite ClassReference
ChartComposite Members
ChartComposite Class Constructors Methods Properties Events See Also Send Feedback

The ChartComposite type exposes the following members.

Constructors

Name | Description
ChartComposite | Initializes a new instance of the ChartComposite class

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetElementAtLayer | Implements GetElementAtLayer(Vector, ChartLayer).
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLayer | Implements PaintLayer(PaintArguments, ChartLayer).
PaintSelf | Paints the element itself without the nested elements.
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
DefaultLayer | Gets default drawing layer.
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ChartComposite Class
PerpetuumSoft.Charts Namespace


ChartComposite Constructor

[image]

.NET ModelKit Suite ClassReference
ChartComposite Constructor
ChartComposite Class See Also Send Feedback
Initializes a new instance of the ChartComposite class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected ChartComposite()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ChartComposite()

See Also

ChartComposite Class
PerpetuumSoft.Charts Namespace


ChartComposite Methods

[image] [image]

.NET ModelKit Suite ClassReference
ChartComposite Methods
ChartComposite Class See Also Send Feedback

The ChartComposite type exposes the following members.

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetElementAtLayer | Implements GetElementAtLayer(Vector, ChartLayer).
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLayer | Implements PaintLayer(PaintArguments, ChartLayer).
PaintSelf | Paints the element itself without the nested elements.
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChartComposite Class
PerpetuumSoft.Charts Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartComposite..::.Dispose Method
ChartComposite Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from Composite.)

See Also

ChartComposite Class
ChartComposite Members
PerpetuumSoft.Charts Namespace


GetElementAtLayer Method

[image]

.NET ModelKit Suite ClassReference
ChartComposite..::.GetElementAtLayer Method
ChartComposite Class See Also Send Feedback
Implements GetElementAtLayer(Vector, ChartLayer).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public IElement GetElementAtLayer(
    Vector point,
    ChartLayer layer
)
Visual Basic (Declaration)
Public Function GetElementAtLayer ( _
    point As Vector, _
    layer As ChartLayer _
) As IElement
Visual C++
public:
virtual IElement^ GetElementAtLayer(
    Vector point,
    ChartLayer layer
) sealed

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector
layer
Type: PerpetuumSoft.Charts..::.ChartLayer

Implements

IChartElement..::.GetElementAtLayer(Vector, ChartLayer)

See Also

ChartComposite Class
PerpetuumSoft.Charts Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartComposite..::.GetStyle Method
ChartComposite Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

ChartComposite Class
ChartComposite Members
PerpetuumSoft.Charts Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartComposite..::.Invalidate Method
ChartComposite Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

ChartComposite Class
ChartComposite Members
PerpetuumSoft.Charts Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartComposite..::.OnPaint Method
ChartComposite Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Inherited from Composite.)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

ChartComposite Class
ChartComposite Members
PerpetuumSoft.Charts Namespace


PaintLayer Method

[image]

.NET ModelKit Suite ClassReference
ChartComposite..::.PaintLayer Method
ChartComposite Class See Also Send Feedback
Implements PaintLayer(PaintArguments, ChartLayer).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void PaintLayer(
    PaintArguments args,
    ChartLayer layer
)
Visual Basic (Declaration)
Public Sub PaintLayer ( _
    args As PaintArguments, _
    layer As ChartLayer _
)
Visual C++
public:
virtual void PaintLayer(
    PaintArguments^ args,
    ChartLayer layer
) sealed

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
layer
Type: PerpetuumSoft.Charts..::.ChartLayer

Implements

IChartElement..::.PaintLayer(PaintArguments, ChartLayer)

See Also

ChartComposite Class
PerpetuumSoft.Charts Namespace


PaintSelf Method

[image]

.NET ModelKit Suite ClassReference
ChartComposite..::.PaintSelf Method
ChartComposite Class See Also Send Feedback
Paints the element itself without the nested elements.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract void PaintSelf(
    PaintArguments args
)
Visual Basic (Declaration)
Public MustOverride Sub PaintSelf ( _
    args As PaintArguments _
)
Visual C++
public:
virtual void PaintSelf(
    PaintArguments^ args
) abstract

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

ChartComposite Class
PerpetuumSoft.Charts Namespace


ChartComposite Properties

[image] [image]

.NET ModelKit Suite ClassReference
ChartComposite Properties
ChartComposite Class See Also Send Feedback

The ChartComposite type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
DefaultLayer | Gets default drawing layer.
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

ChartComposite Class
PerpetuumSoft.Charts Namespace


DefaultLayer Property

[image]

.NET ModelKit Suite ClassReference
ChartComposite..::.DefaultLayer Property
ChartComposite Class See Also Send Feedback
Gets default drawing layer.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract ChartLayer DefaultLayer { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property DefaultLayer As ChartLayer
Visual C++
public:
virtual property ChartLayer DefaultLayer {
    ChartLayer get () abstract;
}

See Also

ChartComposite Class
PerpetuumSoft.Charts Namespace


ChartComposite Events

[image] [image]

.NET ModelKit Suite ClassReference
ChartComposite Events
ChartComposite Class See Also Send Feedback

The ChartComposite type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ChartComposite Class
PerpetuumSoft.Charts Namespace


ChartLayer Enumeration

[image]

.NET ModelKit Suite ClassReference
ChartLayer Enumeration
See Also Send Feedback
Enumeretes layers to which chart elements are painted.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public enum ChartLayer
Visual Basic (Declaration)
Public Enumeration ChartLayer
Visual C++
public enum class ChartLayer

Members

Member name | Description
Background | Specifies a layer for the background painting.
GridLinesBackGround | Specifies a layer for the background of the grid lines painting.
GridLines | Specifies a layer for grid lines painting.
Series | Specifies a layer for the series painting.
Axis | Specifies a layer for axes painting.
SeriesMarkers | Specifies a layer for the series markers painting.
SeriesValues | Specifies a layer for the series values painting.
Foreground | Specifies a layer for the foreground painting.

See Also

PerpetuumSoft.Charts Namespace


ChartPaintContext Class

[image]

.NET ModelKit Suite ClassReference
ChartPaintContext Class
Members See Also Send Feedback
Defines the context to draw chart series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class ChartPaintContext
Visual Basic (Declaration)
Public Class ChartPaintContext
Visual C++
public ref class ChartPaintContext

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.ChartPaintContext

See Also

ChartPaintContext Members
PerpetuumSoft.Charts Namespace


ChartPaintContext Members

[image] [image]

.NET ModelKit Suite ClassReference
ChartPaintContext Members
ChartPaintContext Class Constructors Methods See Also Send Feedback

The ChartPaintContext type exposes the following members.

Constructors

Name | Description
ChartPaintContext | Initializes a new instance of the ChartPaintContext class.

Methods

Name | Description
AddSeries | Adds the painted series to the context.
Clear | Clears the context.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsSeriesPainted | Returns a value that defines whether the specified series has been already painted.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChartPaintContext Class
PerpetuumSoft.Charts Namespace


ChartPaintContext Constructor

[image]

.NET ModelKit Suite ClassReference
ChartPaintContext Constructor
ChartPaintContext Class See Also Send Feedback
Initializes a new instance of the ChartPaintContext class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ChartPaintContext()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartPaintContext()

See Also

ChartPaintContext Class
PerpetuumSoft.Charts Namespace


ChartPaintContext Methods

[image] [image]

.NET ModelKit Suite ClassReference
ChartPaintContext Methods
ChartPaintContext Class See Also Send Feedback

The ChartPaintContext type exposes the following members.

Methods

Name | Description
AddSeries | Adds the painted series to the context.
Clear | Clears the context.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsSeriesPainted | Returns a value that defines whether the specified series has been already painted.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChartPaintContext Class
PerpetuumSoft.Charts Namespace


AddSeries Method

[image]

.NET ModelKit Suite ClassReference
ChartPaintContext..::.AddSeries Method
ChartPaintContext Class See Also Send Feedback
Adds the painted series to the context.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void AddSeries(
    Series series
)
Visual Basic (Declaration)
Public Sub AddSeries ( _
    series As Series _
)
Visual C++
public:
void AddSeries(
    Series^ series
)

Parameters

series
Type: PerpetuumSoft.Charts..::.Series

See Also

ChartPaintContext Class
PerpetuumSoft.Charts Namespace


Clear Method

[image]

.NET ModelKit Suite ClassReference
ChartPaintContext..::.Clear Method
ChartPaintContext Class See Also Send Feedback
Clears the context.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

See Also

ChartPaintContext Class
PerpetuumSoft.Charts Namespace


IsSeriesPainted Method

[image]

.NET ModelKit Suite ClassReference
ChartPaintContext..::.IsSeriesPainted Method
ChartPaintContext Class See Also Send Feedback
Returns a value that defines whether the specified series has been already painted.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool IsSeriesPainted(
    Series series
)
Visual Basic (Declaration)
Public Function IsSeriesPainted ( _
    series As Series _
) As Boolean
Visual C++
public:
bool IsSeriesPainted(
    Series^ series
)

Parameters

series
Type: PerpetuumSoft.Charts..::.Series

See Also

ChartPaintContext Class
PerpetuumSoft.Charts Namespace


ColoredPalette Class

[image]

.NET ModelKit Suite ClassReference
ColoredPalette Class
Members See Also Send Feedback
Represents a base class for multicolored palettes.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract class ColoredPalette : SimplePalette
Visual Basic (Declaration)
Public MustInherit Class ColoredPalette _
    Inherits SimplePalette
Visual C++
public ref class ColoredPalette abstract : public SimplePalette

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.Palette
PerpetuumSoft.Charts..::.SimplePalette
PerpetuumSoft.Charts..::.ColoredPalette
PerpetuumSoft.Charts..::.PaletteBlue
PerpetuumSoft.Charts..::.PaletteChemical
PerpetuumSoft.Charts..::.PaletteCold
PerpetuumSoft.Charts..::.PaletteContrast
PerpetuumSoft.Charts..::.PaletteEmpty
PerpetuumSoft.Charts..::.PaletteGray
PerpetuumSoft.Charts..::.PaletteGreen
PerpetuumSoft.Charts..::.PaletteHot
PerpetuumSoft.Charts..::.PaletteLightBlue
PerpetuumSoft.Charts..::.PaletteOrange
PerpetuumSoft.Charts..::.PalettePurple
PerpetuumSoft.Charts..::.PaletteRainbow
PerpetuumSoft.Charts..::.PaletteRed
PerpetuumSoft.Charts..::.PaletteSunset

See Also

ColoredPalette Members
PerpetuumSoft.Charts Namespace


ColoredPalette Members

[image] [image]

.NET ModelKit Suite ClassReference
ColoredPalette Members
ColoredPalette Class Constructors Methods Events See Also Send Feedback

The ColoredPalette type exposes the following members.

Constructors

Name | Description
ColoredPalette | Initializes a new instance of the ColoredPalette class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Overrides Palette..::.GetColor(Int32).)
GetColors | Returns palette array of colors.
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

ColoredPalette Class
PerpetuumSoft.Charts Namespace


ColoredPalette Constructor

[image]

.NET ModelKit Suite ClassReference
ColoredPalette Constructor
ColoredPalette Class See Also Send Feedback
Initializes a new instance of the ColoredPalette class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected ColoredPalette()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ColoredPalette()

See Also

ColoredPalette Class
PerpetuumSoft.Charts Namespace


ColoredPalette Methods

[image] [image]

.NET ModelKit Suite ClassReference
ColoredPalette Methods
ColoredPalette Class See Also Send Feedback

The ColoredPalette type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Overrides Palette..::.GetColor(Int32).)
GetColors | Returns palette array of colors.
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColoredPalette Class
PerpetuumSoft.Charts Namespace


GetColor Method

[image]

.NET ModelKit Suite ClassReference
ColoredPalette..::.GetColor Method
ColoredPalette Class See Also Send Feedback
Overridden. See GetColor(Int32).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Color GetColor(
    int index
)
Visual Basic (Declaration)
Public Overrides Function GetColor ( _
    index As Integer _
) As Color
Visual C++
public:
virtual Color GetColor(
    int index
) override

Parameters

index
Type: System..::.Int32

See Also

ColoredPalette Class
PerpetuumSoft.Charts Namespace


GetColors Method

[image]

.NET ModelKit Suite ClassReference
ColoredPalette..::.GetColors Method
ColoredPalette Class See Also Send Feedback
Returns palette array of colors.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected abstract Color[] GetColors()
Visual Basic (Declaration)
Protected MustOverride Function GetColors As Color()
Visual C++
protected:
virtual array<Color>^ GetColors() abstract

See Also

ColoredPalette Class
PerpetuumSoft.Charts Namespace


ColoredPalette Events

[image] [image]

.NET ModelKit Suite ClassReference
ColoredPalette Events
ColoredPalette Class See Also Send Feedback

The ColoredPalette type exposes the following members.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

ColoredPalette Class
PerpetuumSoft.Charts Namespace


CustomPalette Class

[image]

.NET ModelKit Suite ClassReference
CustomPalette Class
Members See Also Send Feedback
Represents the user defined palette.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class CustomPalette : Palette
Visual Basic (Declaration)
Public Class CustomPalette _
    Inherits Palette
Visual C++
public ref class CustomPalette : public Palette

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.Palette
PerpetuumSoft.Charts..::.CustomPalette

See Also

CustomPalette Members
PerpetuumSoft.Charts Namespace


CustomPalette Members

[image] [image]

.NET ModelKit Suite ClassReference
CustomPalette Members
CustomPalette Class Constructors Methods Properties Events See Also Send Feedback

The CustomPalette type exposes the following members.

Constructors

Name | Description
CustomPalette | Initializes a new instance of the CustomPalette class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Overrides Palette..::.GetColor(Int32).)
GetFill | Overridden. See GetFill(Int32). (Overrides Palette..::.GetFill(Int32).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Overrides Palette..::.GetLineStroke(Color, Double, Int32).)
GetShape | Overridden. See GetShape(Int32). (Overrides Palette..::.GetShape(Int32).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Items | Gets custom palette items.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

CustomPalette Class
PerpetuumSoft.Charts Namespace


CustomPalette Constructor

[image]

.NET ModelKit Suite ClassReference
CustomPalette Constructor
CustomPalette Class See Also Send Feedback
Initializes a new instance of the CustomPalette class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public CustomPalette()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CustomPalette()

See Also

CustomPalette Class
PerpetuumSoft.Charts Namespace


CustomPalette Methods

[image] [image]

.NET ModelKit Suite ClassReference
CustomPalette Methods
CustomPalette Class See Also Send Feedback

The CustomPalette type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Overrides Palette..::.GetColor(Int32).)
GetFill | Overridden. See GetFill(Int32). (Overrides Palette..::.GetFill(Int32).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Overrides Palette..::.GetLineStroke(Color, Double, Int32).)
GetShape | Overridden. See GetShape(Int32). (Overrides Palette..::.GetShape(Int32).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomPalette Class
PerpetuumSoft.Charts Namespace


GetColor Method

[image]

.NET ModelKit Suite ClassReference
CustomPalette..::.GetColor Method
CustomPalette Class See Also Send Feedback
Overridden. See GetColor(Int32).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Color GetColor(
    int index
)
Visual Basic (Declaration)
Public Overrides Function GetColor ( _
    index As Integer _
) As Color
Visual C++
public:
virtual Color GetColor(
    int index
) override

Parameters

index
Type: System..::.Int32

See Also

CustomPalette Class
PerpetuumSoft.Charts Namespace


GetFill Method

[image]

.NET ModelKit Suite ClassReference
CustomPalette..::.GetFill Method
CustomPalette Class See Also Send Feedback
Overridden. See GetFill(Int32).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Fill GetFill(
    int index
)
Visual Basic (Declaration)
Public Overrides Function GetFill ( _
    index As Integer _
) As Fill
Visual C++
public:
virtual Fill^ GetFill(
    int index
) override

Parameters

index
Type: System..::.Int32

See Also

CustomPalette Class
PerpetuumSoft.Charts Namespace


GetLineStroke Method

[image]

.NET ModelKit Suite ClassReference
CustomPalette..::.GetLineStroke Method
CustomPalette Class See Also Send Feedback
Overridden. See GetLineStroke(Color, Double, Int32).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Stroke GetLineStroke(
    Color color,
    double width,
    int index
)
Visual Basic (Declaration)
Public Overrides Function GetLineStroke ( _
    color As Color, _
    width As Double, _
    index As Integer _
) As Stroke
Visual C++
public:
virtual Stroke^ GetLineStroke(
    Color color,
    double width,
    int index
) override

Parameters

color
Type: System.Drawing..::.Color
width
Type: System..::.Double
index
Type: System..::.Int32

See Also

CustomPalette Class
PerpetuumSoft.Charts Namespace


GetShape Method

[image]

.NET ModelKit Suite ClassReference
CustomPalette..::.GetShape Method
CustomPalette Class See Also Send Feedback
Overridden. See GetShape(Int32).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override ShapeBase GetShape(
    int index
)
Visual Basic (Declaration)
Public Overrides Function GetShape ( _
    index As Integer _
) As ShapeBase
Visual C++
public:
virtual ShapeBase^ GetShape(
    int index
) override

Parameters

index
Type: System..::.Int32

See Also

CustomPalette Class
PerpetuumSoft.Charts Namespace


CustomPalette Properties

[image] [image]

.NET ModelKit Suite ClassReference
CustomPalette Properties
CustomPalette Class See Also Send Feedback

The CustomPalette type exposes the following members.

Properties

Name | Description
Items | Gets custom palette items.

See Also

CustomPalette Class
PerpetuumSoft.Charts Namespace


Items Property

[image]

.NET ModelKit Suite ClassReference
CustomPalette..::.Items Property
CustomPalette Class See Also Send Feedback
Gets custom palette items.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public CustomPaletteItemCollection Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As CustomPaletteItemCollection
Visual C++
public:
property CustomPaletteItemCollection^ Items {
    CustomPaletteItemCollection^ get ();
}

See Also

CustomPalette Class
PerpetuumSoft.Charts Namespace


CustomPalette Events

[image] [image]

.NET ModelKit Suite ClassReference
CustomPalette Events
CustomPalette Class See Also Send Feedback

The CustomPalette type exposes the following members.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

CustomPalette Class
PerpetuumSoft.Charts Namespace


CustomPaletteItem Class

[image]

.NET ModelKit Suite ClassReference
CustomPaletteItem Class
Members See Also Send Feedback
Represents information on the palette's element settings.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class CustomPaletteItem : ICloneable
Visual Basic (Declaration)
Public Class CustomPaletteItem _
    Implements ICloneable
Visual C++
public ref class CustomPaletteItem : ICloneable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.CustomPaletteItem

See Also

CustomPaletteItem Members
PerpetuumSoft.Charts Namespace


CustomPaletteItem Members

[image] [image]

.NET ModelKit Suite ClassReference
CustomPaletteItem Members
CustomPaletteItem Class Constructors Methods Properties See Also Send Feedback

The CustomPaletteItem type exposes the following members.

Constructors

Name | Description
CustomPaletteItem | Initializes a new instance of the CustomPaletteItem class.

Methods

Name | Description
Clone | Implements Clone()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Color | Determines the palette color.
Fill | Determines the palette Fill object.
Shape | Determines the palette shape.
Stroke | Determines the palette stroke.

See Also

CustomPaletteItem Class
PerpetuumSoft.Charts Namespace


CustomPaletteItem Constructor

[image]

.NET ModelKit Suite ClassReference
CustomPaletteItem Constructor
CustomPaletteItem Class See Also Send Feedback
Initializes a new instance of the CustomPaletteItem class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public CustomPaletteItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CustomPaletteItem()

See Also

CustomPaletteItem Class
PerpetuumSoft.Charts Namespace


CustomPaletteItem Methods

[image] [image]

.NET ModelKit Suite ClassReference
CustomPaletteItem Methods
CustomPaletteItem Class See Also Send Feedback

The CustomPaletteItem type exposes the following members.

Methods

Name | Description
Clone | Implements Clone()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomPaletteItem Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
CustomPaletteItem..::.Clone Method
CustomPaletteItem Class See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Implements

ICloneable..::.Clone()()()

See Also

CustomPaletteItem Class
PerpetuumSoft.Charts Namespace


CustomPaletteItem Properties

[image] [image]

.NET ModelKit Suite ClassReference
CustomPaletteItem Properties
CustomPaletteItem Class See Also Send Feedback

The CustomPaletteItem type exposes the following members.

Properties

Name | Description
Color | Determines the palette color.
Fill | Determines the palette Fill object.
Shape | Determines the palette shape.
Stroke | Determines the palette stroke.

See Also

CustomPaletteItem Class
PerpetuumSoft.Charts Namespace


Color Property

[image]

.NET ModelKit Suite ClassReference
CustomPaletteItem..::.Color Property
CustomPaletteItem Class See Also Send Feedback
Determines the palette color.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

CustomPaletteItem Class
PerpetuumSoft.Charts Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
CustomPaletteItem..::.Fill Property
CustomPaletteItem Class See Also Send Feedback
Determines the palette Fill object.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

CustomPaletteItem Class
PerpetuumSoft.Charts Namespace


Shape Property

[image]

.NET ModelKit Suite ClassReference
CustomPaletteItem..::.Shape Property
CustomPaletteItem Class See Also Send Feedback
Determines the palette shape.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ShapeBase Shape { get; set; }
Visual Basic (Declaration)
Public Property Shape As ShapeBase
Visual C++
public:
property ShapeBase^ Shape {
    ShapeBase^ get ();
    void set (ShapeBase^ value);
}

See Also

CustomPaletteItem Class
PerpetuumSoft.Charts Namespace


Stroke Property

[image]

.NET ModelKit Suite ClassReference
CustomPaletteItem..::.Stroke Property
CustomPaletteItem Class See Also Send Feedback
Determines the palette stroke.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Stroke Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Stroke
Visual C++
public:
property Stroke^ Stroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

CustomPaletteItem Class
PerpetuumSoft.Charts Namespace


CustomPaletteItemCollection Class

[image]

.NET ModelKit Suite ClassReference
CustomPaletteItemCollection Class
Members See Also Send Feedback
Represents collection of CustomPaletteItem objects.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class CustomPaletteItemCollection : CollectionBase
Visual Basic (Declaration)
Public Class CustomPaletteItemCollection _
    Inherits CollectionBase
Visual C++
public ref class CustomPaletteItemCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Charts..::.CustomPaletteItemCollection

See Also

CustomPaletteItemCollection Members
PerpetuumSoft.Charts Namespace


CustomPaletteItemCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
CustomPaletteItemCollection Members
CustomPaletteItemCollection Class Constructors Methods Properties Events See Also Send Feedback

The CustomPaletteItemCollection type exposes the following members.

Constructors

Name | Description
CustomPaletteItemCollection | Initializes a new instance of the CustomPaletteItemCollection class.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Add elements to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after adding an element to the collection. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the collection. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Implements Item[([(Int32])]).
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

Name | Description
CustomPaletteItemCollectionChanged | Occurs when collection is changed.

See Also

CustomPaletteItemCollection Class
PerpetuumSoft.Charts Namespace


CustomPaletteItemCollection Constructor

[image]

.NET ModelKit Suite ClassReference
CustomPaletteItemCollection Constructor
CustomPaletteItemCollection Class See Also Send Feedback
Initializes a new instance of the CustomPaletteItemCollection class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public CustomPaletteItemCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CustomPaletteItemCollection()

See Also

CustomPaletteItemCollection Class
PerpetuumSoft.Charts Namespace


CustomPaletteItemCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
CustomPaletteItemCollection Methods
CustomPaletteItemCollection Class See Also Send Feedback

The CustomPaletteItemCollection type exposes the following members.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Add elements to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after adding an element to the collection. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the collection. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomPaletteItemCollection Class
PerpetuumSoft.Charts Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
CustomPaletteItemCollection..::.Add Method
CustomPaletteItemCollection Class See Also Send Feedback
Implements Add(Object).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public CustomPaletteItem Add(
    CustomPaletteItem value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As CustomPaletteItem _
) As CustomPaletteItem
Visual C++
public:
CustomPaletteItem^ Add(
    CustomPaletteItem^ value
)

Parameters

value
Type: PerpetuumSoft.Charts..::.CustomPaletteItem

See Also

CustomPaletteItemCollection Class
PerpetuumSoft.Charts Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
CustomPaletteItemCollection..::.AddRange Method
CustomPaletteItemCollection Class See Also Send Feedback
Add elements to the collection.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    CustomPaletteItem[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As CustomPaletteItem() _
)
Visual C++
public:
void AddRange(
    array<CustomPaletteItem^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Charts..::.CustomPaletteItem >[]()[]

See Also

CustomPaletteItemCollection Class
PerpetuumSoft.Charts Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
CustomPaletteItemCollection..::.Contains Method
CustomPaletteItemCollection Class See Also Send Feedback
Implements Contains(Object).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    CustomPaletteItem value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As CustomPaletteItem _
) As Boolean
Visual C++
public:
bool Contains(
    CustomPaletteItem^ value
)

Parameters

value
Type: PerpetuumSoft.Charts..::.CustomPaletteItem

See Also

CustomPaletteItemCollection Class
PerpetuumSoft.Charts Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
CustomPaletteItemCollection..::.IndexOf Method
CustomPaletteItemCollection Class See Also Send Feedback
Implements IndexOf(Object).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    CustomPaletteItem value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As CustomPaletteItem _
) As Integer
Visual C++
public:
int IndexOf(
    CustomPaletteItem^ value
)

Parameters

value
Type: PerpetuumSoft.Charts..::.CustomPaletteItem

See Also

CustomPaletteItemCollection Class
PerpetuumSoft.Charts Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
CustomPaletteItemCollection..::.Insert Method
CustomPaletteItemCollection Class See Also Send Feedback
Implements Insert(Int32, Object).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    CustomPaletteItem value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As CustomPaletteItem _
)
Visual C++
public:
void Insert(
    int index,
    CustomPaletteItem^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Charts..::.CustomPaletteItem

See Also

CustomPaletteItemCollection Class
PerpetuumSoft.Charts Namespace


OnInsertComplete Method

[image]

.NET ModelKit Suite ClassReference
CustomPaletteItemCollection..::.OnInsertComplete Method
CustomPaletteItemCollection Class See Also Send Feedback
Performs additional custom processes after adding an element to the collection.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsertComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsertComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsertComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

CustomPaletteItemCollection Class
PerpetuumSoft.Charts Namespace


OnRemoveComplete Method

[image]

.NET ModelKit Suite ClassReference
CustomPaletteItemCollection..::.OnRemoveComplete Method
CustomPaletteItemCollection Class See Also Send Feedback
Performs additional custom processes after removing an element from the collection.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnRemoveComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemoveComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemoveComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

CustomPaletteItemCollection Class
PerpetuumSoft.Charts Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
CustomPaletteItemCollection..::.Remove Method
CustomPaletteItemCollection Class See Also Send Feedback
Implements Remove(Object).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    CustomPaletteItem value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As CustomPaletteItem _
)
Visual C++
public:
void Remove(
    CustomPaletteItem^ value
)

Parameters

value
Type: PerpetuumSoft.Charts..::.CustomPaletteItem

See Also

CustomPaletteItemCollection Class
PerpetuumSoft.Charts Namespace


CustomPaletteItemCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
CustomPaletteItemCollection Properties
CustomPaletteItemCollection Class See Also Send Feedback

The CustomPaletteItemCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Implements Item[([(Int32])]).
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

CustomPaletteItemCollection Class
PerpetuumSoft.Charts Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
CustomPaletteItemCollection..::.Item Property
CustomPaletteItemCollection Class See Also Send Feedback
Implements Item[([(Int32])]).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public CustomPaletteItem this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As CustomPaletteItem
Visual C++
public:
property CustomPaletteItem^ default[int index] {
    CustomPaletteItem^ get (int index);
    void set (int index, CustomPaletteItem^ value);
}

Parameters

index
Type: System..::.Int32

See Also

CustomPaletteItemCollection Class
PerpetuumSoft.Charts Namespace


CustomPaletteItemCollection Events

[image] [image]

.NET ModelKit Suite ClassReference
CustomPaletteItemCollection Events
CustomPaletteItemCollection Class See Also Send Feedback

The CustomPaletteItemCollection type exposes the following members.

Events

Name | Description
CustomPaletteItemCollectionChanged | Occurs when collection is changed.

See Also

CustomPaletteItemCollection Class
PerpetuumSoft.Charts Namespace


CustomPaletteItemCollectionChanged Event

[image]

.NET ModelKit Suite ClassReference
CustomPaletteItemCollection..::.CustomPaletteItemCollectionChanged Event
CustomPaletteItemCollection Class See Also Send Feedback
Occurs when collection is changed.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler CustomPaletteItemCollectionChanged
Visual Basic (Declaration)
Public Event CustomPaletteItemCollectionChanged As EventHandler
Visual C++
public:
 event EventHandler^ CustomPaletteItemCollectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

CustomPaletteItemCollection Class
PerpetuumSoft.Charts Namespace


DataBindingException Class

[image]

.NET ModelKit Suite ClassReference
DataBindingException Class
Members See Also Send Feedback
Data Binding Exception

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class DataBindingException : InvalidOperationException
Visual Basic (Declaration)
Public Class DataBindingException _
    Inherits InvalidOperationException
Visual C++
public ref class DataBindingException : public InvalidOperationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.SystemException
System..::.InvalidOperationException
PerpetuumSoft.Charts..::.DataBindingException

See Also

DataBindingException Members
PerpetuumSoft.Charts Namespace


DataBindingException Members

[image] [image]

.NET ModelKit Suite ClassReference
DataBindingException Members
DataBindingException Class Constructors Methods Properties See Also Send Feedback

The DataBindingException type exposes the following members.

Constructors

Name | Description
DataBindingException | Initializes a new instance of the DataBindingException class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DataBindingException Class
PerpetuumSoft.Charts Namespace


DataBindingException Constructor

[image]

.NET ModelKit Suite ClassReference
DataBindingException Constructor
DataBindingException Class See Also Send Feedback
Initializes a new instance of the DataBindingException class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public DataBindingException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
DataBindingException(
    String^ message
)

Parameters

message
Type: System..::.String

See Also

DataBindingException Class
PerpetuumSoft.Charts Namespace


DataBindingException Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataBindingException Methods
DataBindingException Class See Also Send Feedback

The DataBindingException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DataBindingException Class
PerpetuumSoft.Charts Namespace


DataBindingException Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataBindingException Properties
DataBindingException Class See Also Send Feedback

The DataBindingException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DataBindingException Class
PerpetuumSoft.Charts Namespace


DataProvider Class

[image]

.NET ModelKit Suite ClassReference
DataProvider Class
Members See Also Send Feedback
Defines the data provider for chart series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract class DataProvider
Visual Basic (Declaration)
Public MustInherit Class DataProvider
Visual C++
public ref class DataProvider abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.DataProvider

See Also

DataProvider Members
PerpetuumSoft.Charts Namespace


DataProvider Members

[image] [image]

.NET ModelKit Suite ClassReference
DataProvider Members
DataProvider Class Constructors Methods See Also Send Feedback

The DataProvider type exposes the following members.

Constructors

Name | Description
DataProvider | Initializes a new instance of the DataProvider class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSeriesValueCollections | Returns collections of series values.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataProvider Class
PerpetuumSoft.Charts Namespace


DataProvider Constructor

[image]

.NET ModelKit Suite ClassReference
DataProvider Constructor
DataProvider Class See Also Send Feedback
Initializes a new instance of the DataProvider class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected DataProvider()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
DataProvider()

See Also

DataProvider Class
PerpetuumSoft.Charts Namespace


DataProvider Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataProvider Methods
DataProvider Class See Also Send Feedback

The DataProvider type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSeriesValueCollections | Returns collections of series values.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataProvider Class
PerpetuumSoft.Charts Namespace


GetSeriesValueCollections Method

[image]

.NET ModelKit Suite ClassReference
DataProvider..::.GetSeriesValueCollections Method
DataProvider Class See Also Send Feedback
Returns collections of series values.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract SeriesValueCollection[] GetSeriesValueCollections()
Visual Basic (Declaration)
Public MustOverride Function GetSeriesValueCollections As SeriesValueCollection()
Visual C++
public:
virtual array<SeriesValueCollection^>^ GetSeriesValueCollections() abstract

See Also

DataProvider Class
PerpetuumSoft.Charts Namespace


DisplayingInLegendType Enumeration

[image]

.NET ModelKit Suite ClassReference
DisplayingInLegendType Enumeration
See Also Send Feedback
Enumereates types of the legend display.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public enum DisplayingInLegendType
Visual Basic (Declaration)
Public Enumeration DisplayingInLegendType
Visual C++
public enum class DisplayingInLegendType

Members

Member name | Description
None | Indicates that the display type of the legend is not specified.
Series | Defines legend display type by series.
Values | Defines legend display type by series value.

See Also

PerpetuumSoft.Charts Namespace


DockingStyle Enumeration

[image]

.NET ModelKit Suite ClassReference
DockingStyle Enumeration
See Also Send Feedback
Enumerates docking styles for chart elements.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public enum DockingStyle
Visual Basic (Declaration)
Public Enumeration DockingStyle
Visual C++
public enum class DockingStyle

Members

Member name | Description
Inside | Indicates that an element is placed inside the area.
Outside | Indicates that an element is placed outside the area.

See Also

PerpetuumSoft.Charts Namespace


DockingType Enumeration

[image]

.NET ModelKit Suite ClassReference
DockingType Enumeration
See Also Send Feedback
Enumerates docking type of the chart elements which are inside another element.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public enum DockingType
Visual Basic (Declaration)
Public Enumeration DockingType
Visual C++
public enum class DockingType

Members

Member name | Description
Top | Assigns the top position.
Left | Assigns the left position.
Bottom | Assigns the bottom position.
Right | Assigns the right position.
None | Indicates that the postion is not assigned.

See Also

PerpetuumSoft.Charts Namespace


EmptyAxisArrow Class

[image]

.NET ModelKit Suite ClassReference
EmptyAxisArrow Class
Members See Also Send Feedback
Defines an empty shape for an axis arrow.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class EmptyAxisArrow : AxisArrow
Visual Basic (Declaration)
Public Class EmptyAxisArrow _
    Inherits AxisArrow
Visual C++
public ref class EmptyAxisArrow : public AxisArrow

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.AxisArrow
PerpetuumSoft.Charts..::.EmptyAxisArrow

See Also

EmptyAxisArrow Members
PerpetuumSoft.Charts Namespace


EmptyAxisArrow Members

[image] [image]

.NET ModelKit Suite ClassReference
EmptyAxisArrow Members
EmptyAxisArrow Class Constructors Methods See Also Send Feedback

The EmptyAxisArrow type exposes the following members.

Constructors

Name | Description
EmptyAxisArrow | Initializes a new instance of the EmptyAxisArrow class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSize | Overridden. See GetSize(AxisDirection). (Overrides AxisArrow..::.GetSize(AxisDirection).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Paint | Overridden. See Paint(GraphicStream, Vector, AxisDirection, Stroke, Boolean). (Overrides AxisArrow..::.Paint(GraphicStream, Vector, AxisDirection, Stroke, Boolean).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmptyAxisArrow Class
PerpetuumSoft.Charts Namespace


EmptyAxisArrow Constructor

[image]

.NET ModelKit Suite ClassReference
EmptyAxisArrow Constructor
EmptyAxisArrow Class See Also Send Feedback
Initializes a new instance of the EmptyAxisArrow class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public EmptyAxisArrow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EmptyAxisArrow()

See Also

EmptyAxisArrow Class
PerpetuumSoft.Charts Namespace


EmptyAxisArrow Methods

[image] [image]

.NET ModelKit Suite ClassReference
EmptyAxisArrow Methods
EmptyAxisArrow Class See Also Send Feedback

The EmptyAxisArrow type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSize | Overridden. See GetSize(AxisDirection). (Overrides AxisArrow..::.GetSize(AxisDirection).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Paint | Overridden. See Paint(GraphicStream, Vector, AxisDirection, Stroke, Boolean). (Overrides AxisArrow..::.Paint(GraphicStream, Vector, AxisDirection, Stroke, Boolean).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmptyAxisArrow Class
PerpetuumSoft.Charts Namespace


GetSize Method

[image]

.NET ModelKit Suite ClassReference
EmptyAxisArrow..::.GetSize Method
EmptyAxisArrow Class See Also Send Feedback
Overridden. See GetSize(AxisDirection).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Vector GetSize(
    AxisDirection direction
)
Visual Basic (Declaration)
Public Overrides Function GetSize ( _
    direction As AxisDirection _
) As Vector
Visual C++
public:
virtual Vector GetSize(
    AxisDirection direction
) override

Parameters

direction
Type: PerpetuumSoft.Charts..::.AxisDirection

See Also

EmptyAxisArrow Class
PerpetuumSoft.Charts Namespace


Paint Method

[image]

.NET ModelKit Suite ClassReference
EmptyAxisArrow..::.Paint Method
EmptyAxisArrow Class See Also Send Feedback
Overridden. See Paint(GraphicStream, Vector, AxisDirection, Stroke, Boolean).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void Paint(
    GraphicStream g,
    Vector startPoint,
    AxisDirection direction,
    Stroke stroke,
    bool reverse
)
Visual Basic (Declaration)
Public Overrides Sub Paint ( _
    g As GraphicStream, _
    startPoint As Vector, _
    direction As AxisDirection, _
    stroke As Stroke, _
    reverse As Boolean _
)
Visual C++
public:
virtual void Paint(
    GraphicStream^ g,
    Vector startPoint,
    AxisDirection direction,
    Stroke^ stroke,
    bool reverse
) override

Parameters

g
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
startPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
direction
Type: PerpetuumSoft.Charts..::.AxisDirection
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
reverse
Type: System..::.Boolean

See Also

EmptyAxisArrow Class
PerpetuumSoft.Charts Namespace


FinancialSeriesValue Class

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesValue Class
Members See Also Send Feedback
Specifies a base class for the series values used in financial charts.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class FinancialSeriesValue : SeriesValueBase
Visual Basic (Declaration)
Public Class FinancialSeriesValue _
    Inherits SeriesValueBase
Visual C++
public ref class FinancialSeriesValue : public SeriesValueBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesValueBase
PerpetuumSoft.Charts..::.FinancialSeriesValue

See Also

FinancialSeriesValue Members
PerpetuumSoft.Charts Namespace


FinancialSeriesValue Members

[image] [image]

.NET ModelKit Suite ClassReference
FinancialSeriesValue Members
FinancialSeriesValue Class Constructors Methods Properties See Also Send Feedback

The FinancialSeriesValue type exposes the following members.

Constructors

Name | Description
FinancialSeriesValue | Initializes a new instance of the FinancialSeriesValue class.

Methods

Name | Description
Clone | Overridden. See Clone()()(). (Overrides SeriesValueBase..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRepresentationObject | Overridden. See GetRepresentationObject()()(). (Overrides SeriesValueBase..::.GetRepresentationObject()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueBounds | Overridden. See GetValueBounds()()(). (Overrides SeriesValueBase..::.GetValueBounds()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sum | Overridden. See Sum(SeriesValueBase). (Overrides SeriesValueBase..::.Sum(SeriesValueBase).)
ToString | Overridden. See ToString()()(). (Inherited from SeriesValueBase.)

Properties

Name | Description
Argument | Gets or sets an argument. (Inherited from SeriesValueBase.)
Close | Gets or sets the Close value for financial SeriesValue.
Hi | Gets or sets the Hi value for financial SeriesValue.
Lo | Gets or sets the Lo value for financial SeriesValue.
Open | Gets or sets the Open value for financial SeriesValue.
Sort | Gets or sets the sort expression value for series value. (Inherited from SeriesValueBase.)
UserData | Gets or sets additional data of the series value. (Inherited from SeriesValueBase.)

See Also

FinancialSeriesValue Class
PerpetuumSoft.Charts Namespace


FinancialSeriesValue Constructor

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesValue Constructor
FinancialSeriesValue Class See Also Send Feedback
Initializes a new instance of the FinancialSeriesValue class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public FinancialSeriesValue()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FinancialSeriesValue()

See Also

FinancialSeriesValue Class
PerpetuumSoft.Charts Namespace


FinancialSeriesValue Methods

[image] [image]

.NET ModelKit Suite ClassReference
FinancialSeriesValue Methods
FinancialSeriesValue Class See Also Send Feedback

The FinancialSeriesValue type exposes the following members.

Methods

Name | Description
Clone | Overridden. See Clone()()(). (Overrides SeriesValueBase..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRepresentationObject | Overridden. See GetRepresentationObject()()(). (Overrides SeriesValueBase..::.GetRepresentationObject()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueBounds | Overridden. See GetValueBounds()()(). (Overrides SeriesValueBase..::.GetValueBounds()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sum | Overridden. See Sum(SeriesValueBase). (Overrides SeriesValueBase..::.Sum(SeriesValueBase).)
ToString | Overridden. See ToString()()(). (Inherited from SeriesValueBase.)

See Also

FinancialSeriesValue Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesValue..::.Clone Method
FinancialSeriesValue Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesValueBase Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesValueBase
Visual C++
public:
virtual SeriesValueBase^ Clone() override

See Also

FinancialSeriesValue Class
PerpetuumSoft.Charts Namespace


GetRepresentationObject Method

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesValue..::.GetRepresentationObject Method
FinancialSeriesValue Class See Also Send Feedback
Overridden. See GetRepresentationObject()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Object GetRepresentationObject()
Visual Basic (Declaration)
Public Overrides Function GetRepresentationObject As Object
Visual C++
public:
virtual Object^ GetRepresentationObject() override

See Also

FinancialSeriesValue Class
PerpetuumSoft.Charts Namespace


GetValueBounds Method

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesValue..::.GetValueBounds Method
FinancialSeriesValue Class See Also Send Feedback
Overridden. See GetValueBounds()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Bounds GetValueBounds()
Visual Basic (Declaration)
Public Overrides Function GetValueBounds As Bounds
Visual C++
public:
virtual Bounds GetValueBounds() override

See Also

FinancialSeriesValue Class
PerpetuumSoft.Charts Namespace


Sum Method

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesValue..::.Sum Method
FinancialSeriesValue Class See Also Send Feedback
Overridden. See Sum(SeriesValueBase).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void Sum(
    SeriesValueBase seriesValue
)
Visual Basic (Declaration)
Public Overrides Sub Sum ( _
    seriesValue As SeriesValueBase _
)
Visual C++
public:
virtual void Sum(
    SeriesValueBase^ seriesValue
) override

Parameters

seriesValue
Type: PerpetuumSoft.Charts..::.SeriesValueBase

See Also

FinancialSeriesValue Class
PerpetuumSoft.Charts Namespace


FinancialSeriesValue Properties

[image] [image]

.NET ModelKit Suite ClassReference
FinancialSeriesValue Properties
FinancialSeriesValue Class See Also Send Feedback

The FinancialSeriesValue type exposes the following members.

Properties

Name | Description
Argument | Gets or sets an argument. (Inherited from SeriesValueBase.)
Close | Gets or sets the Close value for financial SeriesValue.
Hi | Gets or sets the Hi value for financial SeriesValue.
Lo | Gets or sets the Lo value for financial SeriesValue.
Open | Gets or sets the Open value for financial SeriesValue.
Sort | Gets or sets the sort expression value for series value. (Inherited from SeriesValueBase.)
UserData | Gets or sets additional data of the series value. (Inherited from SeriesValueBase.)

See Also

FinancialSeriesValue Class
PerpetuumSoft.Charts Namespace


Close Property

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesValue..::.Close Property
FinancialSeriesValue Class See Also Send Feedback
Gets or sets the Close value for financial SeriesValue.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double Close { get; set; }
Visual Basic (Declaration)
Public Property Close As Double
Visual C++
public:
property double Close {
    double get ();
    void set (double value);
}

See Also

FinancialSeriesValue Class
PerpetuumSoft.Charts Namespace


Hi Property

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesValue..::.Hi Property
FinancialSeriesValue Class See Also Send Feedback
Gets or sets the Hi value for financial SeriesValue.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double Hi { get; set; }
Visual Basic (Declaration)
Public Property Hi As Double
Visual C++
public:
property double Hi {
    double get ();
    void set (double value);
}

See Also

FinancialSeriesValue Class
PerpetuumSoft.Charts Namespace


Lo Property

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesValue..::.Lo Property
FinancialSeriesValue Class See Also Send Feedback
Gets or sets the Lo value for financial SeriesValue.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double Lo { get; set; }
Visual Basic (Declaration)
Public Property Lo As Double
Visual C++
public:
property double Lo {
    double get ();
    void set (double value);
}

See Also

FinancialSeriesValue Class
PerpetuumSoft.Charts Namespace


Open Property

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesValue..::.Open Property
FinancialSeriesValue Class See Also Send Feedback
Gets or sets the Open value for financial SeriesValue.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double Open { get; set; }
Visual Basic (Declaration)
Public Property Open As Double
Visual C++
public:
property double Open {
    double get ();
    void set (double value);
}

See Also

FinancialSeriesValue Class
PerpetuumSoft.Charts Namespace


FinancialSeriesViewBase Class

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesViewBase Class
Members See Also Send Feedback
Defines a base class for painting of the series values in the form of a financial chart.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract class FinancialSeriesViewBase : SimpleAxisSeriesView
Visual Basic (Declaration)
Public MustInherit Class FinancialSeriesViewBase _
    Inherits SimpleAxisSeriesView
Visual C++
public ref class FinancialSeriesViewBase abstract : public SimpleAxisSeriesView

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.SimpleAxisSeriesView
PerpetuumSoft.Charts..::.FinancialSeriesViewBase
PerpetuumSoft.Charts..::.CandleStickSeriesView
PerpetuumSoft.Charts..::.StockSeriesView

See Also

FinancialSeriesViewBase Members
PerpetuumSoft.Charts Namespace


FinancialSeriesViewBase Members

[image] [image]

.NET ModelKit Suite ClassReference
FinancialSeriesViewBase Members
FinancialSeriesViewBase Class Constructors Methods Properties Events See Also Send Feedback

The FinancialSeriesViewBase type exposes the following members.

Constructors

Name | Description
FinancialSeriesViewBase | Initializes a new instance of the FinancialSeriesViewBase class

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Creates an object copy. (Inherited from SeriesView.)
CreateElement | Creates an element that corresponds to this series value.
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates elements which correspond to the specified series. (Overrides SimpleAxisSeriesView..::.CreateElementsForSeries(Series).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Overrides SeriesView..::.GetBounds(Series, AxisType, array<Series>[]()[]).)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetReductionValueForSeriesValue | Returns the value field of the financial series with the specified reduction value.
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Overrides AxisSeriesView..::.GetSeriesValueType()()().)
GetSideIndent | Overridden. See GetSideIndent()()(). (Overrides SeriesView..::.GetSideIndent()()().)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Paints a legend badge for the series. (Inherited from SeriesView.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Overrides SeriesView..::.PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Overrides SeriesView..::.IsValueLegendItemSupported.)
ReductionValue | Gets or sets a value which indicates according to which field the values with the reduced index will be chosen.
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
Width | Gets or sets relational width of the element which corresponds to the series value.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

FinancialSeriesViewBase Class
PerpetuumSoft.Charts Namespace


FinancialSeriesViewBase Constructor

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesViewBase Constructor
FinancialSeriesViewBase Class See Also Send Feedback
Initializes a new instance of the FinancialSeriesViewBase class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected FinancialSeriesViewBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
FinancialSeriesViewBase()

See Also

FinancialSeriesViewBase Class
PerpetuumSoft.Charts Namespace


FinancialSeriesViewBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
FinancialSeriesViewBase Methods
FinancialSeriesViewBase Class See Also Send Feedback

The FinancialSeriesViewBase type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Creates an object copy. (Inherited from SeriesView.)
CreateElement | Creates an element that corresponds to this series value.
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates elements which correspond to the specified series. (Overrides SimpleAxisSeriesView..::.CreateElementsForSeries(Series).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Overrides SeriesView..::.GetBounds(Series, AxisType, array<Series>[]()[]).)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetReductionValueForSeriesValue | Returns the value field of the financial series with the specified reduction value.
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Overrides AxisSeriesView..::.GetSeriesValueType()()().)
GetSideIndent | Overridden. See GetSideIndent()()(). (Overrides SeriesView..::.GetSideIndent()()().)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Paints a legend badge for the series. (Inherited from SeriesView.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Overrides SeriesView..::.PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FinancialSeriesViewBase Class
PerpetuumSoft.Charts Namespace


CreateElement Method

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesViewBase..::.CreateElement Method
FinancialSeriesViewBase Class See Also Send Feedback
Creates an element that corresponds to this series value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected abstract void CreateElement(
    Series series,
    FinancialSeriesValue seriesValue,
    bool isReduction
)
Visual Basic (Declaration)
Protected MustOverride Sub CreateElement ( _
    series As Series, _
    seriesValue As FinancialSeriesValue, _
    isReduction As Boolean _
)
Visual C++
protected:
virtual void CreateElement(
    Series^ series,
    FinancialSeriesValue^ seriesValue,
    bool isReduction
) abstract

Parameters

series
Type: PerpetuumSoft.Charts..::.Series
seriesValue
Type: PerpetuumSoft.Charts..::.FinancialSeriesValue
isReduction
Type: System..::.Boolean

See Also

FinancialSeriesViewBase Class
PerpetuumSoft.Charts Namespace


CreateElementsForSeries Method

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesViewBase..::.CreateElementsForSeries Method
FinancialSeriesViewBase Class See Also Send Feedback
Creates elements which correspond to the specified series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void CreateElementsForSeries(
    Series series
)
Visual Basic (Declaration)
Protected Overrides Sub CreateElementsForSeries ( _
    series As Series _
)
Visual C++
protected:
virtual void CreateElementsForSeries(
    Series^ series
) override

Parameters

series
Type: PerpetuumSoft.Charts..::.Series

See Also

FinancialSeriesViewBase Class
PerpetuumSoft.Charts Namespace


GetBounds Method

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesViewBase..::.GetBounds Method
FinancialSeriesViewBase Class See Also Send Feedback
Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Bounds GetBounds(
    Series series,
    AxisType axisType,
    Series[] allSeries
)
Visual Basic (Declaration)
Public Overrides Function GetBounds ( _
    series As Series, _
    axisType As AxisType, _
    allSeries As Series() _
) As Bounds
Visual C++
public:
virtual Bounds GetBounds(
    Series^ series,
    AxisType axisType,
    array<Series^>^ allSeries
) override

Parameters

series
Type: PerpetuumSoft.Charts..::.Series
axisType
Type: PerpetuumSoft.Charts..::.AxisType
allSeries
Type: array< PerpetuumSoft.Charts..::.Series >[]()[]

See Also

FinancialSeriesViewBase Class
PerpetuumSoft.Charts Namespace


GetReductionValueForSeriesValue Method

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesViewBase..::.GetReductionValueForSeriesValue Method
FinancialSeriesViewBase Class See Also Send Feedback
Returns the value field of the financial series with the specified reduction value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected double GetReductionValueForSeriesValue(
    FinancialSeriesValue seriesValue
)
Visual Basic (Declaration)
Protected Function GetReductionValueForSeriesValue ( _
    seriesValue As FinancialSeriesValue _
) As Double
Visual C++
protected:
double GetReductionValueForSeriesValue(
    FinancialSeriesValue^ seriesValue
)

Parameters

seriesValue
Type: PerpetuumSoft.Charts..::.FinancialSeriesValue

See Also

FinancialSeriesViewBase Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
FinancialSeriesViewBase..::.GetSeries Method
FinancialSeriesViewBase Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

FinancialSeriesViewBase Class
FinancialSeriesViewBase Members
PerpetuumSoft.Charts Namespace


GetSeriesValueType Method

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesViewBase..::.GetSeriesValueType Method
FinancialSeriesViewBase Class See Also Send Feedback
Overridden. See GetSeriesValueType()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Type GetSeriesValueType()
Visual Basic (Declaration)
Public Overrides Function GetSeriesValueType As Type
Visual C++
public:
virtual Type^ GetSeriesValueType() override

See Also

FinancialSeriesViewBase Class
PerpetuumSoft.Charts Namespace


GetSideIndent Method

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesViewBase..::.GetSideIndent Method
FinancialSeriesViewBase Class See Also Send Feedback
Overridden. See GetSideIndent()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override double GetSideIndent()
Visual Basic (Declaration)
Public Overrides Function GetSideIndent As Double
Visual C++
public:
virtual double GetSideIndent() override

See Also

FinancialSeriesViewBase Class
PerpetuumSoft.Charts Namespace


PaintLegendValueBadge Method

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesViewBase..::.PaintLegendValueBadge Method
FinancialSeriesViewBase Class See Also Send Feedback
Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintLegendValueBadge(
    GraphicStream graphicStream,
    VectorRectangle area,
    int seriesValueIndex
)
Visual Basic (Declaration)
Public Overrides Sub PaintLegendValueBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle, _
    seriesValueIndex As Integer _
)
Visual C++
public:
virtual void PaintLegendValueBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area,
    int seriesValueIndex
) override

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
seriesValueIndex
Type: System..::.Int32

See Also

FinancialSeriesViewBase Class
PerpetuumSoft.Charts Namespace


FinancialSeriesViewBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
FinancialSeriesViewBase Properties
FinancialSeriesViewBase Class See Also Send Feedback

The FinancialSeriesViewBase type exposes the following members.

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Overrides SeriesView..::.IsValueLegendItemSupported.)
ReductionValue | Gets or sets a value which indicates according to which field the values with the reduced index will be chosen.
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
Width | Gets or sets relational width of the element which corresponds to the series value.

See Also

FinancialSeriesViewBase Class
PerpetuumSoft.Charts Namespace


IsValueLegendItemSupported Property

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesViewBase..::.IsValueLegendItemSupported Property
FinancialSeriesViewBase Class See Also Send Feedback
Overridden. See IsValueLegendItemSupported.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValueLegendItemSupported { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsValueLegendItemSupported As Boolean
Visual C++
public:
virtual property bool IsValueLegendItemSupported {
    bool get () override;
}

See Also

FinancialSeriesViewBase Class
PerpetuumSoft.Charts Namespace


ReductionValue Property

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesViewBase..::.ReductionValue Property
FinancialSeriesViewBase Class See Also Send Feedback
Gets or sets a value which indicates according to which field the values with the reduced index will be chosen.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ReductionValue ReductionValue { get; set; }
Visual Basic (Declaration)
Public Property ReductionValue As ReductionValue
Visual C++
public:
property ReductionValue ReductionValue {
    ReductionValue get ();
    void set (ReductionValue value);
}

See Also

FinancialSeriesViewBase Class
PerpetuumSoft.Charts Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
FinancialSeriesViewBase..::.Width Property
FinancialSeriesViewBase Class See Also Send Feedback
Gets or sets relational width of the element which corresponds to the series value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

FinancialSeriesViewBase Class
PerpetuumSoft.Charts Namespace


FinancialSeriesViewBase Events

[image] [image]

.NET ModelKit Suite ClassReference
FinancialSeriesViewBase Events
FinancialSeriesViewBase Class See Also Send Feedback

The FinancialSeriesViewBase type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

FinancialSeriesViewBase Class
PerpetuumSoft.Charts Namespace


GridLines Class

[image]

.NET ModelKit Suite ClassReference
GridLines Class
Members See Also Send Feedback
Determines the grid lines of chart axis.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class GridLines : Element, IChartElement
Visual Basic (Declaration)
Public Class GridLines _
    Inherits Element _
    Implements IChartElement
Visual C++
public ref class GridLines : public Element,
    IChartElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Charts..::.GridLines

See Also

GridLines Members
PerpetuumSoft.Charts Namespace


GridLines Members

[image] [image]

.NET ModelKit Suite ClassReference
GridLines Members
GridLines Class Constructors Methods Properties Events See Also Send Feedback

The GridLines type exposes the following members.

Constructors

Name | Description
GridLines | Initializes a new instance of the GridLines class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetElementAtLayer | Implements GetElementAtLayer(Vector, ChartLayer).
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLayer | Implements PaintLayer(PaintArguments, ChartLayer).
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
AlternativeFill | Gets or sets the fill for interleaved stripes between grid lines.
Axis | Gets the axis for which the data of the grid line are painted.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Divisions | Gets or sets the number of the grid lines.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MaxLimit | Gets or sets maximum value within which grid lines are painted.
MinLimit | Gets or sets minimum value within which grid lines are painted.
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets axial point where the grid line should pass through.
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Step | Gets or sets a step betwwen the grid lines.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SubLinesCount | Gets or sets the number of the sub lines between the primary lines.
SubStroke | Gets or sets Stroke for sub lines drawing.
UseDescreteValues | Gets or sets a value that indicates whether the grid lines go through descrete values on the axis.
UseRoundValues | Gets or sets value that indicates if grid lines will correspond to round values.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

GridLines Class
PerpetuumSoft.Charts Namespace


GridLines Constructor

[image]

.NET ModelKit Suite ClassReference
GridLines Constructor
GridLines Class See Also Send Feedback
Initializes a new instance of the GridLines class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public GridLines()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridLines()

See Also

GridLines Class
PerpetuumSoft.Charts Namespace


GridLines Methods

[image] [image]

.NET ModelKit Suite ClassReference
GridLines Methods
GridLines Class See Also Send Feedback

The GridLines type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetElementAtLayer | Implements GetElementAtLayer(Vector, ChartLayer).
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLayer | Implements PaintLayer(PaintArguments, ChartLayer).
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridLines Class
PerpetuumSoft.Charts Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
GridLines..::.Dispose Method
GridLines Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

GridLines Class
GridLines Members
PerpetuumSoft.Charts Namespace


GetElementAtLayer Method

[image]

.NET ModelKit Suite ClassReference
GridLines..::.GetElementAtLayer Method
GridLines Class See Also Send Feedback
Implements GetElementAtLayer(Vector, ChartLayer).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public IElement GetElementAtLayer(
    Vector point,
    ChartLayer layer
)
Visual Basic (Declaration)
Public Function GetElementAtLayer ( _
    point As Vector, _
    layer As ChartLayer _
) As IElement
Visual C++
public:
virtual IElement^ GetElementAtLayer(
    Vector point,
    ChartLayer layer
) sealed

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector
layer
Type: PerpetuumSoft.Charts..::.ChartLayer

Implements

IChartElement..::.GetElementAtLayer(Vector, ChartLayer)

See Also

GridLines Class
PerpetuumSoft.Charts Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
GridLines..::.GetHitTest Method
GridLines Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

GridLines Class
PerpetuumSoft.Charts Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
GridLines..::.GetStyle Method
GridLines Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

GridLines Class
GridLines Members
PerpetuumSoft.Charts Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
GridLines..::.Invalidate Method
GridLines Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

GridLines Class
GridLines Members
PerpetuumSoft.Charts Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
GridLines..::.OnPaint Method
GridLines Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Overrides Element..::.OnPaint(PaintArguments).)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

GridLines Class
GridLines Members
PerpetuumSoft.Charts Namespace


OnPaint Method (PaintArguments)

[image]

.NET ModelKit Suite ClassReference
GridLines..::.OnPaint Method (PaintArguments)
GridLines Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

GridLines Class
OnPaint Overload
PerpetuumSoft.Charts Namespace


PaintLayer Method

[image]

.NET ModelKit Suite ClassReference
GridLines..::.PaintLayer Method
GridLines Class See Also Send Feedback
Implements PaintLayer(PaintArguments, ChartLayer).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void PaintLayer(
    PaintArguments args,
    ChartLayer layer
)
Visual Basic (Declaration)
Public Sub PaintLayer ( _
    args As PaintArguments, _
    layer As ChartLayer _
)
Visual C++
public:
virtual void PaintLayer(
    PaintArguments^ args,
    ChartLayer layer
) sealed

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
layer
Type: PerpetuumSoft.Charts..::.ChartLayer

Implements

IChartElement..::.PaintLayer(PaintArguments, ChartLayer)

See Also

GridLines Class
PerpetuumSoft.Charts Namespace


GridLines Properties

[image] [image]

.NET ModelKit Suite ClassReference
GridLines Properties
GridLines Class See Also Send Feedback

The GridLines type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
AlternativeFill | Gets or sets the fill for interleaved stripes between grid lines.
Axis | Gets the axis for which the data of the grid line are painted.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Divisions | Gets or sets the number of the grid lines.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MaxLimit | Gets or sets maximum value within which grid lines are painted.
MinLimit | Gets or sets minimum value within which grid lines are painted.
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets axial point where the grid line should pass through.
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Step | Gets or sets a step betwwen the grid lines.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SubLinesCount | Gets or sets the number of the sub lines between the primary lines.
SubStroke | Gets or sets Stroke for sub lines drawing.
UseDescreteValues | Gets or sets a value that indicates whether the grid lines go through descrete values on the axis.
UseRoundValues | Gets or sets value that indicates if grid lines will correspond to round values.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

GridLines Class
PerpetuumSoft.Charts Namespace


AlternativeFill Property

[image]

.NET ModelKit Suite ClassReference
GridLines..::.AlternativeFill Property
GridLines Class See Also Send Feedback
Gets or sets the fill for interleaved stripes between grid lines.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Fill AlternativeFill { get; set; }
Visual Basic (Declaration)
Public Property AlternativeFill As Fill
Visual C++
public:
property Fill^ AlternativeFill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

GridLines Class
PerpetuumSoft.Charts Namespace


Axis Property

[image]

.NET ModelKit Suite ClassReference
GridLines..::.Axis Property
GridLines Class See Also Send Feedback
Gets the axis for which the data of the grid line are painted.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Axis Axis { get; }
Visual Basic (Declaration)
Public ReadOnly Property Axis As Axis
Visual C++
public:
property Axis^ Axis {
    Axis^ get ();
}

See Also

GridLines Class
PerpetuumSoft.Charts Namespace


Divisions Property

[image]

.NET ModelKit Suite ClassReference
GridLines..::.Divisions Property
GridLines Class See Also Send Feedback
Gets or sets the number of the grid lines.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public int Divisions { get; set; }
Visual Basic (Declaration)
Public Property Divisions As Integer
Visual C++
public:
property int Divisions {
    int get ();
    void set (int value);
}

See Also

GridLines Class
PerpetuumSoft.Charts Namespace


MaxLimit Property

[image]

.NET ModelKit Suite ClassReference
GridLines..::.MaxLimit Property
GridLines Class See Also Send Feedback
Gets or sets maximum value within which grid lines are painted.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue MaxLimit { get; set; }
Visual Basic (Declaration)
Public Property MaxLimit As SmartValue
Visual C++
public:
property SmartValue MaxLimit {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

GridLines Class
PerpetuumSoft.Charts Namespace


MinLimit Property

[image]

.NET ModelKit Suite ClassReference
GridLines..::.MinLimit Property
GridLines Class See Also Send Feedback
Gets or sets minimum value within which grid lines are painted.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue MinLimit { get; set; }
Visual Basic (Declaration)
Public Property MinLimit As SmartValue
Visual C++
public:
property SmartValue MinLimit {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

GridLines Class
PerpetuumSoft.Charts Namespace


Origin Property

[image]

.NET ModelKit Suite ClassReference
GridLines..::.Origin Property
GridLines Class See Also Send Feedback
Gets or sets axial point where the grid line should pass through.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue Origin { get; set; }
Visual Basic (Declaration)
Public Property Origin As SmartValue
Visual C++
public:
property SmartValue Origin {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

GridLines Class
PerpetuumSoft.Charts Namespace


Step Property

[image]

.NET ModelKit Suite ClassReference
GridLines..::.Step Property
GridLines Class See Also Send Feedback
Gets or sets a step betwwen the grid lines.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue Step { get; set; }
Visual Basic (Declaration)
Public Property Step As SmartValue
Visual C++
public:
property SmartValue Step {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

GridLines Class
PerpetuumSoft.Charts Namespace


SubLinesCount Property

[image]

.NET ModelKit Suite ClassReference
GridLines..::.SubLinesCount Property
GridLines Class See Also Send Feedback
Gets or sets the number of the sub lines between the primary lines.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public int SubLinesCount { get; set; }
Visual Basic (Declaration)
Public Property SubLinesCount As Integer
Visual C++
public:
property int SubLinesCount {
    int get ();
    void set (int value);
}

See Also

GridLines Class
PerpetuumSoft.Charts Namespace


SubStroke Property

[image]

.NET ModelKit Suite ClassReference
GridLines..::.SubStroke Property
GridLines Class See Also Send Feedback
Gets or sets Stroke for sub lines drawing.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Stroke SubStroke { get; set; }
Visual Basic (Declaration)
Public Property SubStroke As Stroke
Visual C++
public:
property Stroke^ SubStroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

GridLines Class
PerpetuumSoft.Charts Namespace


UseDescreteValues Property

[image]

.NET ModelKit Suite ClassReference
GridLines..::.UseDescreteValues Property
GridLines Class See Also Send Feedback
Gets or sets a value that indicates whether the grid lines go through descrete values on the axis.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool UseDescreteValues { get; set; }
Visual Basic (Declaration)
Public Property UseDescreteValues As Boolean
Visual C++
public:
property bool UseDescreteValues {
    bool get ();
    void set (bool value);
}

See Also

GridLines Class
PerpetuumSoft.Charts Namespace


UseRoundValues Property

[image]

.NET ModelKit Suite ClassReference
GridLines..::.UseRoundValues Property
GridLines Class See Also Send Feedback
Gets or sets value that indicates if grid lines will correspond to round values.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool UseRoundValues { get; set; }
Visual Basic (Declaration)
Public Property UseRoundValues As Boolean
Visual C++
public:
property bool UseRoundValues {
    bool get ();
    void set (bool value);
}

See Also

GridLines Class
PerpetuumSoft.Charts Namespace


GridLines Events

[image] [image]

.NET ModelKit Suite ClassReference
GridLines Events
GridLines Class See Also Send Feedback

The GridLines type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

GridLines Class
PerpetuumSoft.Charts Namespace


IChartElement Interface

[image]

.NET ModelKit Suite ClassReference
IChartElement Interface
Members See Also Send Feedback
Defines methods of a chart element drawing to the specified layer.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public interface IChartElement
Visual Basic (Declaration)
Public Interface IChartElement
Visual C++
public interface class IChartElement

See Also

IChartElement Members
PerpetuumSoft.Charts Namespace


IChartElement Members

[image] [image]

.NET ModelKit Suite ClassReference
IChartElement Members
IChartElement Interface Methods See Also Send Feedback

The IChartElement type exposes the following members.

Methods

Name | Description
GetElementAtLayer | Returns an element of the specified layer to which the specified point belongs.
PaintLayer | Paints an element to the particular layer.

See Also

IChartElement Interface
PerpetuumSoft.Charts Namespace


IChartElement Methods

[image] [image]

.NET ModelKit Suite ClassReference
IChartElement Methods
IChartElement Interface See Also Send Feedback

The IChartElement type exposes the following members.

Methods

Name | Description
GetElementAtLayer | Returns an element of the specified layer to which the specified point belongs.
PaintLayer | Paints an element to the particular layer.

See Also

IChartElement Interface
PerpetuumSoft.Charts Namespace


GetElementAtLayer Method

[image]

.NET ModelKit Suite ClassReference
IChartElement..::.GetElementAtLayer Method
IChartElement Interface See Also Send Feedback
Returns an element of the specified layer to which the specified point belongs.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
IElement GetElementAtLayer(
    Vector point,
    ChartLayer layer
)
Visual Basic (Declaration)
Function GetElementAtLayer ( _
    point As Vector, _
    layer As ChartLayer _
) As IElement
Visual C++
IElement^ GetElementAtLayer(
    Vector point,
    ChartLayer layer
)

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector
layer
Type: PerpetuumSoft.Charts..::.ChartLayer

See Also

IChartElement Interface
PerpetuumSoft.Charts Namespace


PaintLayer Method

[image]

.NET ModelKit Suite ClassReference
IChartElement..::.PaintLayer Method
IChartElement Interface See Also Send Feedback
Paints an element to the particular layer.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
void PaintLayer(
    PaintArguments args,
    ChartLayer layer
)
Visual Basic (Declaration)
Sub PaintLayer ( _
    args As PaintArguments, _
    layer As ChartLayer _
)
Visual C++
void PaintLayer(
    PaintArguments^ args,
    ChartLayer layer
)

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
layer
Type: PerpetuumSoft.Charts..::.ChartLayer

See Also

IChartElement Interface
PerpetuumSoft.Charts Namespace


IDockable Interface

[image]

.NET ModelKit Suite ClassReference
IDockable Interface
Members See Also Send Feedback
Defines methods for element docking.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public interface IDockable
Visual Basic (Declaration)
Public Interface IDockable
Visual C++
public interface class IDockable

See Also

IDockable Members
PerpetuumSoft.Charts Namespace


IDockable Members

[image] [image]

.NET ModelKit Suite ClassReference
IDockable Members
IDockable Interface Methods Properties See Also Send Feedback

The IDockable type exposes the following members.

Methods

Name | Description
GetSize | Returns element's size.
SetBounds | Specifies an area where an element is placed.

Properties

Name | Description
DockingStyle | Gets DockingStyle docking style.
DockingType | Gets DockingType docking type.

See Also

IDockable Interface
PerpetuumSoft.Charts Namespace


IDockable Methods

[image] [image]

.NET ModelKit Suite ClassReference
IDockable Methods
IDockable Interface See Also Send Feedback

The IDockable type exposes the following members.

Methods

Name | Description
GetSize | Returns element's size.
SetBounds | Specifies an area where an element is placed.

See Also

IDockable Interface
PerpetuumSoft.Charts Namespace


GetSize Method

[image]

.NET ModelKit Suite ClassReference
IDockable..::.GetSize Method
IDockable Interface See Also Send Feedback
Returns element's size.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
double GetSize()
Visual Basic (Declaration)
Function GetSize As Double
Visual C++
double GetSize()

See Also

IDockable Interface
PerpetuumSoft.Charts Namespace


SetBounds Method

[image]

.NET ModelKit Suite ClassReference
IDockable..::.SetBounds Method
IDockable Interface See Also Send Feedback
Specifies an area where an element is placed.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
void SetBounds(
    VectorRectangle bounds
)
Visual Basic (Declaration)
Sub SetBounds ( _
    bounds As VectorRectangle _
)
Visual C++
void SetBounds(
    VectorRectangle bounds
)

Parameters

bounds
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

IDockable Interface
PerpetuumSoft.Charts Namespace


IDockable Properties

[image] [image]

.NET ModelKit Suite ClassReference
IDockable Properties
IDockable Interface See Also Send Feedback

The IDockable type exposes the following members.

Properties

Name | Description
DockingStyle | Gets DockingStyle docking style.
DockingType | Gets DockingType docking type.

See Also

IDockable Interface
PerpetuumSoft.Charts Namespace


DockingStyle Property

[image]

.NET ModelKit Suite ClassReference
IDockable..::.DockingStyle Property
IDockable Interface See Also Send Feedback
Gets DockingStyle docking style.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
DockingStyle DockingStyle { get; }
Visual Basic (Declaration)
ReadOnly Property DockingStyle As DockingStyle
Visual C++
property DockingStyle DockingStyle {
    DockingStyle get ();
}

See Also

IDockable Interface
PerpetuumSoft.Charts Namespace


DockingType Property

[image]

.NET ModelKit Suite ClassReference
IDockable..::.DockingType Property
IDockable Interface See Also Send Feedback
Gets DockingType docking type.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
DockingType DockingType { get; }
Visual Basic (Declaration)
ReadOnly Property DockingType As DockingType
Visual C++
property DockingType DockingType {
    DockingType get ();
}

See Also

IDockable Interface
PerpetuumSoft.Charts Namespace


ImageSizeMode Enumeration

[image]

.NET ModelKit Suite ClassReference
ImageSizeMode Enumeration
See Also Send Feedback
Enumerates image sizing modes.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public enum ImageSizeMode
Visual Basic (Declaration)
Public Enumeration ImageSizeMode
Visual C++
public enum class ImageSizeMode

Members

Member name | Description
Stretch | Determines image stretch.
Scale | Determines image sizing in proportions.

See Also

PerpetuumSoft.Charts Namespace


LabelsPosition Enumeration

[image]

.NET ModelKit Suite ClassReference
LabelsPosition Enumeration
See Also Send Feedback
Enumerates types of label positions.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public enum LabelsPosition
Visual Basic (Declaration)
Public Enumeration LabelsPosition
Visual C++
public enum class LabelsPosition

Members

Member name | Description
Top | Specifies the top position.
Center | Specifies the center position.
Bottom | Specifies the bottom position.

See Also

PerpetuumSoft.Charts Namespace


Legend Class

[image]

.NET ModelKit Suite ClassReference
Legend Class
Members See Also Send Feedback
Indicates chart legend.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class Legend : SimpleRectangleElement, IDockable
Visual Basic (Declaration)
Public Class Legend _
    Inherits SimpleRectangleElement _
    Implements IDockable
Visual C++
public ref class Legend : public SimpleRectangleElement,
    IDockable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement
PerpetuumSoft.Charts..::.Legend

See Also

Legend Members
PerpetuumSoft.Charts Namespace


Legend Members

[image] [image]

.NET ModelKit Suite ClassReference
Legend Members
Legend Class Constructors Methods Properties Events See Also Send Feedback

The Legend type exposes the following members.

Constructors

Name | Description
Legend | Initializes a new instance of the Legend class.

Methods

Name | Description
Calculate | Overridden. See Calculate()()(). (Overrides Element..::.Calculate()()().)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from SimpleRectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from SimpleRectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()().
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | Occurs when the Bounds property has been changed. (Overrides SimpleRectangleElement..::.OnBoundsChanged()()().)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Occurs when the Visible property has been changed. (Overrides Element..::.OnVisibleChanged()()().)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetFont |
SetBounds | Implements SetBounds(VectorRectangle).
ShouldSerializeFont |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Alignment | Gets or sets alignment.
BadgeIndent | Determines indent between legend badge and item text.
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
ColumnsCount | Determines the count of columns.
DockingStyle | Implements DockingStyle.
DockingType | Implements DockingType.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets FontDescriptor font for legend facing.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
ItemCount | Gets a number of the legend items.
ItemMargins | Gets or sets margins for legend points.
LegendType | Gets or sets LegendType legend type.
Margins | Gets or sets margins of this element.
Name | Gets or sets the element's name. (Inherited from Element.)
Padding | Gets or sets padding of this element.
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
TextFill | Gets or sets Fill fill for the legend facing.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Legend Class
PerpetuumSoft.Charts Namespace


Legend Constructor

[image]

.NET ModelKit Suite ClassReference
Legend Constructor
Legend Class See Also Send Feedback
Initializes a new instance of the Legend class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Legend()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Legend()

See Also

Legend Class
PerpetuumSoft.Charts Namespace


Legend Methods

[image] [image]

.NET ModelKit Suite ClassReference
Legend Methods
Legend Class See Also Send Feedback

The Legend type exposes the following members.

Methods

Name | Description
Calculate | Overridden. See Calculate()()(). (Overrides Element..::.Calculate()()().)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from SimpleRectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from SimpleRectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()().
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | Occurs when the Bounds property has been changed. (Overrides SimpleRectangleElement..::.OnBoundsChanged()()().)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Occurs when the Visible property has been changed. (Overrides Element..::.OnVisibleChanged()()().)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetFont |
SetBounds | Implements SetBounds(VectorRectangle).
ShouldSerializeFont |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Legend Class
PerpetuumSoft.Charts Namespace


Calculate Method

[image]

.NET ModelKit Suite ClassReference
Legend..::.Calculate Method
Legend Class See Also Send Feedback
Overridden. See Calculate()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void Calculate()
Visual Basic (Declaration)
Protected Overrides Sub Calculate
Visual C++
protected:
virtual void Calculate() override

See Also

Legend Class
PerpetuumSoft.Charts Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Legend..::.Dispose Method
Legend Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

Legend Class
Legend Members
PerpetuumSoft.Charts Namespace


GetSize Method

[image]

.NET ModelKit Suite ClassReference
Legend..::.GetSize Method
Legend Class See Also Send Feedback
Implements GetSize()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double GetSize()
Visual Basic (Declaration)
Public Function GetSize As Double
Visual C++
public:
virtual double GetSize() sealed

Implements

IDockable..::.GetSize()()()

See Also

Legend Class
PerpetuumSoft.Charts Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Legend..::.GetStyle Method
Legend Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Legend Class
Legend Members
PerpetuumSoft.Charts Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Legend..::.Invalidate Method
Legend Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Legend Class
Legend Members
PerpetuumSoft.Charts Namespace


OnBoundsChanged Method

[image]

.NET ModelKit Suite ClassReference
Legend..::.OnBoundsChanged Method
Legend Class See Also Send Feedback
Occurs when the Bounds property has been changed.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnBoundsChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnBoundsChanged
Visual C++
protected:
virtual void OnBoundsChanged() override

See Also

Legend Class
PerpetuumSoft.Charts Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Legend..::.OnPaint Method
Legend Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

Legend Class
Legend Members
PerpetuumSoft.Charts Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
Legend..::.OnPaint Method (PaintArguments, Fill, Stroke)
Legend Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Legend Class
OnPaint Overload
PerpetuumSoft.Charts Namespace


OnVisibleChanged Method

[image]

.NET ModelKit Suite ClassReference
Legend..::.OnVisibleChanged Method
Legend Class See Also Send Feedback
Occurs when the Visible property has been changed.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnVisibleChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnVisibleChanged
Visual C++
protected:
virtual void OnVisibleChanged() override

See Also

Legend Class
PerpetuumSoft.Charts Namespace


ResetFont Method

[image]

.NET ModelKit Suite ClassReference
Legend..::.ResetFont Method
Legend Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Charts.Legend.ResetFont]

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void ResetFont()
Visual Basic (Declaration)
Public Sub ResetFont
Visual C++
public:
void ResetFont()

See Also

Legend Class
PerpetuumSoft.Charts Namespace


SetBounds Method

[image]

.NET ModelKit Suite ClassReference
Legend..::.SetBounds Method
Legend Class See Also Send Feedback
Implements SetBounds(VectorRectangle).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void SetBounds(
    VectorRectangle bounds
)
Visual Basic (Declaration)
Public Sub SetBounds ( _
    bounds As VectorRectangle _
)
Visual C++
public:
virtual void SetBounds(
    VectorRectangle bounds
) sealed

Parameters

bounds
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

Implements

IDockable..::.SetBounds(VectorRectangle)

See Also

Legend Class
PerpetuumSoft.Charts Namespace


ShouldSerializeFont Method

[image]

.NET ModelKit Suite ClassReference
Legend..::.ShouldSerializeFont Method
Legend Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Charts.Legend.ShouldSerializeFont]

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool ShouldSerializeFont()
Visual Basic (Declaration)
Public Function ShouldSerializeFont As Boolean
Visual C++
public:
bool ShouldSerializeFont()

See Also

Legend Class
PerpetuumSoft.Charts Namespace


Legend Properties

[image] [image]

.NET ModelKit Suite ClassReference
Legend Properties
Legend Class See Also Send Feedback

The Legend type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Alignment | Gets or sets alignment.
BadgeIndent | Determines indent between legend badge and item text.
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
ColumnsCount | Determines the count of columns.
DockingStyle | Implements DockingStyle.
DockingType | Implements DockingType.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets FontDescriptor font for legend facing.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
ItemCount | Gets a number of the legend items.
ItemMargins | Gets or sets margins for legend points.
LegendType | Gets or sets LegendType legend type.
Margins | Gets or sets margins of this element.
Name | Gets or sets the element's name. (Inherited from Element.)
Padding | Gets or sets padding of this element.
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
TextFill | Gets or sets Fill fill for the legend facing.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Legend Class
PerpetuumSoft.Charts Namespace


Alignment Property

[image]

.NET ModelKit Suite ClassReference
Legend..::.Alignment Property
Legend Class See Also Send Feedback
Gets or sets alignment.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public StringAlignment Alignment { get; set; }
Visual Basic (Declaration)
Public Property Alignment As StringAlignment
Visual C++
public:
property StringAlignment Alignment {
    StringAlignment get ();
    void set (StringAlignment value);
}

See Also

Legend Class
PerpetuumSoft.Charts Namespace


BadgeIndent Property

[image]

.NET ModelKit Suite ClassReference
Legend..::.BadgeIndent Property
Legend Class See Also Send Feedback
Determines indent between legend badge and item text.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double BadgeIndent { get; set; }
Visual Basic (Declaration)
Public Property BadgeIndent As Double
Visual C++
public:
property double BadgeIndent {
    double get ();
    void set (double value);
}

See Also

Legend Class
PerpetuumSoft.Charts Namespace


ColumnsCount Property

[image]

.NET ModelKit Suite ClassReference
Legend..::.ColumnsCount Property
Legend Class See Also Send Feedback
Determines the count of columns.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public int ColumnsCount { get; set; }
Visual Basic (Declaration)
Public Property ColumnsCount As Integer
Visual C++
public:
property int ColumnsCount {
    int get ();
    void set (int value);
}

See Also

Legend Class
PerpetuumSoft.Charts Namespace


DockingStyle Property

[image]

.NET ModelKit Suite ClassReference
Legend..::.DockingStyle Property
Legend Class See Also Send Feedback
Implements DockingStyle.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public DockingStyle DockingStyle { get; set; }
Visual Basic (Declaration)
Public Property DockingStyle As DockingStyle
Visual C++
public:
virtual property DockingStyle DockingStyle {
    DockingStyle get () sealed;
    void set (DockingStyle value) sealed;
}

Implements

IDockable..::.DockingStyle

See Also

Legend Class
PerpetuumSoft.Charts Namespace


DockingType Property

[image]

.NET ModelKit Suite ClassReference
Legend..::.DockingType Property
Legend Class See Also Send Feedback
Implements DockingType.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public DockingType DockingType { get; set; }
Visual Basic (Declaration)
Public Property DockingType As DockingType
Visual C++
public:
virtual property DockingType DockingType {
    DockingType get () sealed;
    void set (DockingType value) sealed;
}

Implements

IDockable..::.DockingType

See Also

Legend Class
PerpetuumSoft.Charts Namespace


Font Property

[image]

.NET ModelKit Suite ClassReference
Legend..::.Font Property
Legend Class See Also Send Feedback
Gets or sets FontDescriptor font for legend facing.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public FontDescriptor Font { get; set; }
Visual Basic (Declaration)
Public Property Font As FontDescriptor
Visual C++
public:
property FontDescriptor^ Font {
    FontDescriptor^ get ();
    void set (FontDescriptor^ value);
}

See Also

Legend Class
PerpetuumSoft.Charts Namespace


ItemCount Property

[image]

.NET ModelKit Suite ClassReference
Legend..::.ItemCount Property
Legend Class See Also Send Feedback
Gets a number of the legend items.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public int ItemCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemCount As Integer
Visual C++
public:
property int ItemCount {
    int get ();
}

See Also

Legend Class
PerpetuumSoft.Charts Namespace


ItemMargins Property

[image]

.NET ModelKit Suite ClassReference
Legend..::.ItemMargins Property
Legend Class See Also Send Feedback
Gets or sets margins for legend points.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Margins ItemMargins { get; set; }
Visual Basic (Declaration)
Public Property ItemMargins As Margins
Visual C++
public:
property Margins ItemMargins {
    Margins get ();
    void set (Margins value);
}

See Also

Legend Class
PerpetuumSoft.Charts Namespace


LegendType Property

[image]

.NET ModelKit Suite ClassReference
Legend..::.LegendType Property
Legend Class See Also Send Feedback
Gets or sets LegendType legend type.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public LegendType LegendType { get; set; }
Visual Basic (Declaration)
Public Property LegendType As LegendType
Visual C++
public:
property LegendType LegendType {
    LegendType get ();
    void set (LegendType value);
}

See Also

Legend Class
PerpetuumSoft.Charts Namespace


Margins Property

[image]

.NET ModelKit Suite ClassReference
Legend..::.Margins Property
Legend Class See Also Send Feedback
Gets or sets margins of this element.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Margins Margins { get; set; }
Visual Basic (Declaration)
Public Property Margins As Margins
Visual C++
public:
property Margins Margins {
    Margins get ();
    void set (Margins value);
}

See Also

Legend Class
PerpetuumSoft.Charts Namespace


Padding Property

[image]

.NET ModelKit Suite ClassReference
Legend..::.Padding Property
Legend Class See Also Send Feedback
Gets or sets padding of this element.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Margins Padding { get; set; }
Visual Basic (Declaration)
Public Property Padding As Margins
Visual C++
public:
property Margins Padding {
    Margins get ();
    void set (Margins value);
}

See Also

Legend Class
PerpetuumSoft.Charts Namespace


TextFill Property

[image]

.NET ModelKit Suite ClassReference
Legend..::.TextFill Property
Legend Class See Also Send Feedback
Gets or sets Fill fill for the legend facing.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Fill TextFill { get; set; }
Visual Basic (Declaration)
Public Property TextFill As Fill
Visual C++
public:
property Fill^ TextFill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

Legend Class
PerpetuumSoft.Charts Namespace


Legend Events

[image] [image]

.NET ModelKit Suite ClassReference
Legend Events
Legend Class See Also Send Feedback

The Legend type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Legend Class
PerpetuumSoft.Charts Namespace


LegendItem Class

[image]

.NET ModelKit Suite ClassReference
LegendItem Class
Members See Also Send Feedback
Defines a base class for an item in the chart legend.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract class LegendItem
Visual Basic (Declaration)
Public MustInherit Class LegendItem
Visual C++
public ref class LegendItem abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.LegendItem
PerpetuumSoft.Charts..::.LegendSeriesItem
PerpetuumSoft.Charts..::.LegendValuesItem

See Also

LegendItem Members
PerpetuumSoft.Charts Namespace


LegendItem Members

[image] [image]

.NET ModelKit Suite ClassReference
LegendItem Members
LegendItem Class Constructors Methods Properties See Also Send Feedback

The LegendItem type exposes the following members.

Constructors

Name | Description
LegendItem | Initializes a new instance of the LegendItem class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBadgeSize | Returns badge size.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSize | Returns the size of a legend item.
GetTextSize | Returns text size.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnLegendItemChanged | Occures when a legend item has been changed.
Paint | Overloaded.
PaintBadge | Paints the badge for this item.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColumnNumber | Determines the column numder of the LegenItem.
ExpressionString | Gets or sets an expression to calculate a value that is displayed in the legend item.
Fill | Gets or sets the fill used for drawing.
Legend | Determines the specified legend.
RowNumber | Determines the row number of the LegenItem.
Series | Gets or sets legend series.
StartPoint | Gets or sets the coordinates of the left-up corner of the LegendItem.
Text | Gets a text displayed in a legend item.

See Also

LegendItem Class
PerpetuumSoft.Charts Namespace


LegendItem Constructor

[image]

.NET ModelKit Suite ClassReference
LegendItem Constructor
LegendItem Class See Also Send Feedback
Initializes a new instance of the LegendItem class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected LegendItem()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
LegendItem()

See Also

LegendItem Class
PerpetuumSoft.Charts Namespace


LegendItem Methods

[image] [image]

.NET ModelKit Suite ClassReference
LegendItem Methods
LegendItem Class See Also Send Feedback

The LegendItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBadgeSize | Returns badge size.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSize | Returns the size of a legend item.
GetTextSize | Returns text size.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnLegendItemChanged | Occures when a legend item has been changed.
Paint | Overloaded.
PaintBadge | Paints the badge for this item.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegendItem Class
PerpetuumSoft.Charts Namespace


GetBadgeSize Method

[image]

.NET ModelKit Suite ClassReference
LegendItem..::.GetBadgeSize Method
LegendItem Class See Also Send Feedback
Returns badge size.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Vector GetBadgeSize()
Visual Basic (Declaration)
Protected Function GetBadgeSize As Vector
Visual C++
protected:
Vector GetBadgeSize()

See Also

LegendItem Class
PerpetuumSoft.Charts Namespace


GetSize Method

[image]

.NET ModelKit Suite ClassReference
LegendItem..::.GetSize Method
LegendItem Class See Also Send Feedback
Returns the size of a legend item.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Vector GetSize()
Visual Basic (Declaration)
Public Function GetSize As Vector
Visual C++
public:
Vector GetSize()

See Also

LegendItem Class
PerpetuumSoft.Charts Namespace


GetTextSize Method

[image]

.NET ModelKit Suite ClassReference
LegendItem..::.GetTextSize Method
LegendItem Class See Also Send Feedback
Returns text size.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Vector GetTextSize()
Visual Basic (Declaration)
Protected Function GetTextSize As Vector
Visual C++
protected:
Vector GetTextSize()

See Also

LegendItem Class
PerpetuumSoft.Charts Namespace


OnLegendItemChanged Method

[image]

.NET ModelKit Suite ClassReference
LegendItem..::.OnLegendItemChanged Method
LegendItem Class See Also Send Feedback
Occures when a legend item has been changed.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnLegendItemChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnLegendItemChanged
Visual C++
protected:
virtual void OnLegendItemChanged()

See Also

LegendItem Class
PerpetuumSoft.Charts Namespace


Paint Method

[image] [image]

.NET ModelKit Suite ClassReference
LegendItem..::.Paint Method
LegendItem Class See Also Send Feedback

Overload List

Name | Description
Paint(GraphicStream) | Paint a legend item.
Paint(GraphicStream, Vector) | Paints a legend item.

See Also

LegendItem Class
LegendItem Members
PerpetuumSoft.Charts Namespace


Paint Method (GraphicStream)

[image]

.NET ModelKit Suite ClassReference
LegendItem..::.Paint Method (GraphicStream)
LegendItem Class See Also Send Feedback
Paint a legend item.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void Paint(
    GraphicStream graphicStream
)
Visual Basic (Declaration)
Public Sub Paint ( _
    graphicStream As GraphicStream _
)
Visual C++
public:
void Paint(
    GraphicStream^ graphicStream
)

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream

See Also

LegendItem Class
Paint Overload
PerpetuumSoft.Charts Namespace


Paint Method (GraphicStream, Vector)

[image]

.NET ModelKit Suite ClassReference
LegendItem..::.Paint Method (GraphicStream, Vector)
LegendItem Class See Also Send Feedback
Paints a legend item.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void Paint(
    GraphicStream graphicStream,
    Vector topLeftPoint
)
Visual Basic (Declaration)
Public Sub Paint ( _
    graphicStream As GraphicStream, _
    topLeftPoint As Vector _
)
Visual C++
public:
void Paint(
    GraphicStream^ graphicStream,
    Vector topLeftPoint
)

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
topLeftPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

LegendItem Class
Paint Overload
PerpetuumSoft.Charts Namespace


PaintBadge Method

[image]

.NET ModelKit Suite ClassReference
LegendItem..::.PaintBadge Method
LegendItem Class See Also Send Feedback
Paints the badge for this item.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract void PaintBadge(
    GraphicStream graphicStream,
    VectorRectangle area
)
Visual Basic (Declaration)
Public MustOverride Sub PaintBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle _
)
Visual C++
public:
virtual void PaintBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area
) abstract

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

LegendItem Class
PerpetuumSoft.Charts Namespace


LegendItem Properties

[image] [image]

.NET ModelKit Suite ClassReference
LegendItem Properties
LegendItem Class See Also Send Feedback

The LegendItem type exposes the following members.

Properties

Name | Description
ColumnNumber | Determines the column numder of the LegenItem.
ExpressionString | Gets or sets an expression to calculate a value that is displayed in the legend item.
Fill | Gets or sets the fill used for drawing.
Legend | Determines the specified legend.
RowNumber | Determines the row number of the LegenItem.
Series | Gets or sets legend series.
StartPoint | Gets or sets the coordinates of the left-up corner of the LegendItem.
Text | Gets a text displayed in a legend item.

See Also

LegendItem Class
PerpetuumSoft.Charts Namespace


ColumnNumber Property

[image]

.NET ModelKit Suite ClassReference
LegendItem..::.ColumnNumber Property
LegendItem Class See Also Send Feedback
Determines the column numder of the LegenItem.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public int ColumnNumber { get; set; }
Visual Basic (Declaration)
Public Property ColumnNumber As Integer
Visual C++
public:
property int ColumnNumber {
    int get ();
    void set (int value);
}

See Also

LegendItem Class
PerpetuumSoft.Charts Namespace


ExpressionString Property

[image]

.NET ModelKit Suite ClassReference
LegendItem..::.ExpressionString Property
LegendItem Class See Also Send Feedback
Gets or sets an expression to calculate a value that is displayed in the legend item.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected string ExpressionString { get; set; }
Visual Basic (Declaration)
Protected Property ExpressionString As String
Visual C++
protected:
property String^ ExpressionString {
    String^ get ();
    void set (String^ value);
}

See Also

LegendItem Class
PerpetuumSoft.Charts Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
LegendItem..::.Fill Property
LegendItem Class See Also Send Feedback
Gets or sets the fill used for drawing.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Fill Fill { get; set; }
Visual Basic (Declaration)
Protected Property Fill As Fill
Visual C++
protected:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

LegendItem Class
PerpetuumSoft.Charts Namespace


Legend Property

[image]

.NET ModelKit Suite ClassReference
LegendItem..::.Legend Property
LegendItem Class See Also Send Feedback
Determines the specified legend.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Legend Legend { get; set; }
Visual Basic (Declaration)
Public Property Legend As Legend
Visual C++
public:
property Legend^ Legend {
    Legend^ get ();
    void set (Legend^ value);
}

See Also

LegendItem Class
PerpetuumSoft.Charts Namespace


RowNumber Property

[image]

.NET ModelKit Suite ClassReference
LegendItem..::.RowNumber Property
LegendItem Class See Also Send Feedback
Determines the row number of the LegenItem.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public int RowNumber { get; set; }
Visual Basic (Declaration)
Public Property RowNumber As Integer
Visual C++
public:
property int RowNumber {
    int get ();
    void set (int value);
}

See Also

LegendItem Class
PerpetuumSoft.Charts Namespace


Series Property

[image]

.NET ModelKit Suite ClassReference
LegendItem..::.Series Property
LegendItem Class See Also Send Feedback
Gets or sets legend series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Series Series { get; set; }
Visual Basic (Declaration)
Protected Property Series As Series
Visual C++
protected:
property Series^ Series {
    Series^ get ();
    void set (Series^ value);
}

See Also

LegendItem Class
PerpetuumSoft.Charts Namespace


StartPoint Property

[image]

.NET ModelKit Suite ClassReference
LegendItem..::.StartPoint Property
LegendItem Class See Also Send Feedback
Gets or sets the coordinates of the left-up corner of the LegendItem.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Vector StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Vector
Visual C++
public:
property Vector StartPoint {
    Vector get ();
    void set (Vector value);
}

See Also

LegendItem Class
PerpetuumSoft.Charts Namespace


Text Property

[image]

.NET ModelKit Suite ClassReference
LegendItem..::.Text Property
LegendItem Class See Also Send Feedback
Gets a text displayed in a legend item.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract string Text { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property Text As String
Visual C++
public:
virtual property String^ Text {
    String^ get () abstract;
}

See Also

LegendItem Class
PerpetuumSoft.Charts Namespace


LegendSeriesItem Class

[image]

.NET ModelKit Suite ClassReference
LegendSeriesItem Class
Members See Also Send Feedback
Defines a legend item to indicate series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class LegendSeriesItem : LegendItem
Visual Basic (Declaration)
Public Class LegendSeriesItem _
    Inherits LegendItem
Visual C++
public ref class LegendSeriesItem : public LegendItem

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.LegendItem
PerpetuumSoft.Charts..::.LegendSeriesItem

See Also

LegendSeriesItem Members
PerpetuumSoft.Charts Namespace


LegendSeriesItem Members

[image] [image]

.NET ModelKit Suite ClassReference
LegendSeriesItem Members
LegendSeriesItem Class Constructors Methods Properties See Also Send Feedback

The LegendSeriesItem type exposes the following members.

Constructors

Name | Description
LegendSeriesItem | Initializes a new instance of the LegendSeriesItem class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBadgeSize | Returns badge size. (Inherited from LegendItem.)
GetFunction | Implements GetFunction(String).
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObject | Implements GetObject(String).
GetSize | Returns the size of a legend item. (Inherited from LegendItem.)
GetTextSize | Returns text size. (Inherited from LegendItem.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnLegendItemChanged | Occures when a legend item has been changed. (Inherited from LegendItem.)
Paint | Overloaded.
PaintBadge | Overridden. See PaintBadge(GraphicStream, VectorRectangle). (Overrides LegendItem..::.PaintBadge(GraphicStream, VectorRectangle).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColumnNumber | Determines the column numder of the LegenItem. (Inherited from LegendItem.)
ExpressionString | Gets or sets an expression to calculate a value that is displayed in the legend item. (Inherited from LegendItem.)
Fill | Gets or sets the fill used for drawing. (Inherited from LegendItem.)
Legend | Determines the specified legend. (Inherited from LegendItem.)
RowNumber | Determines the row number of the LegenItem. (Inherited from LegendItem.)
Series | Gets or sets legend series. (Inherited from LegendItem.)
StartPoint | Gets or sets the coordinates of the left-up corner of the LegendItem. (Inherited from LegendItem.)
Text | Overridden. See Text. (Overrides LegendItem..::.Text.)

See Also

LegendSeriesItem Class
PerpetuumSoft.Charts Namespace


LegendSeriesItem Constructor

[image]

.NET ModelKit Suite ClassReference
LegendSeriesItem Constructor
LegendSeriesItem Class See Also Send Feedback
Initializes a new instance of the LegendSeriesItem class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public LegendSeriesItem(
    Legend legend,
    Series series
)
Visual Basic (Declaration)
Public Sub New ( _
    legend As Legend, _
    series As Series _
)
Visual C++
public:
LegendSeriesItem(
    Legend^ legend,
    Series^ series
)

Parameters

legend
Type: PerpetuumSoft.Charts..::.Legend
series
Type: PerpetuumSoft.Charts..::.Series

See Also

LegendSeriesItem Class
PerpetuumSoft.Charts Namespace


LegendSeriesItem Methods

[image] [image]

.NET ModelKit Suite ClassReference
LegendSeriesItem Methods
LegendSeriesItem Class See Also Send Feedback

The LegendSeriesItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBadgeSize | Returns badge size. (Inherited from LegendItem.)
GetFunction | Implements GetFunction(String).
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObject | Implements GetObject(String).
GetSize | Returns the size of a legend item. (Inherited from LegendItem.)
GetTextSize | Returns text size. (Inherited from LegendItem.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnLegendItemChanged | Occures when a legend item has been changed. (Inherited from LegendItem.)
Paint | Overloaded.
PaintBadge | Overridden. See PaintBadge(GraphicStream, VectorRectangle). (Overrides LegendItem..::.PaintBadge(GraphicStream, VectorRectangle).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegendSeriesItem Class
PerpetuumSoft.Charts Namespace


GetFunction Method

[image]

.NET ModelKit Suite ClassReference
LegendSeriesItem..::.GetFunction Method
LegendSeriesItem Class See Also Send Feedback
Implements GetFunction(String).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public IFunction GetFunction(
    string name
)
Visual Basic (Declaration)
Public Function GetFunction ( _
    name As String _
) As IFunction
Visual C++
public:
virtual IFunction^ GetFunction(
    String^ name
) sealed

Parameters

name
Type: System..::.String

See Also

LegendSeriesItem Class
PerpetuumSoft.Charts Namespace


GetObject Method

[image]

.NET ModelKit Suite ClassReference
LegendSeriesItem..::.GetObject Method
LegendSeriesItem Class See Also Send Feedback
Implements GetObject(String).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Object GetObject(
    string name
)
Visual Basic (Declaration)
Public Function GetObject ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetObject(
    String^ name
) sealed

Parameters

name
Type: System..::.String

See Also

LegendSeriesItem Class
PerpetuumSoft.Charts Namespace


Paint Method

[image] [image]

.NET ModelKit Suite ClassReference
LegendSeriesItem..::.Paint Method
LegendSeriesItem Class See Also Send Feedback

Overload List

Name | Description
Paint(GraphicStream) | Paint a legend item. (Inherited from LegendItem.)
Paint(GraphicStream, Vector) | Paints a legend item. (Inherited from LegendItem.)

See Also

LegendSeriesItem Class
LegendSeriesItem Members
PerpetuumSoft.Charts Namespace


PaintBadge Method

[image]

.NET ModelKit Suite ClassReference
LegendSeriesItem..::.PaintBadge Method
LegendSeriesItem Class See Also Send Feedback
Overridden. See PaintBadge(GraphicStream, VectorRectangle).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintBadge(
    GraphicStream graphicStream,
    VectorRectangle area
)
Visual Basic (Declaration)
Public Overrides Sub PaintBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle _
)
Visual C++
public:
virtual void PaintBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area
) override

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

LegendSeriesItem Class
PerpetuumSoft.Charts Namespace


LegendSeriesItem Properties

[image] [image]

.NET ModelKit Suite ClassReference
LegendSeriesItem Properties
LegendSeriesItem Class See Also Send Feedback

The LegendSeriesItem type exposes the following members.

Properties

Name | Description
ColumnNumber | Determines the column numder of the LegenItem. (Inherited from LegendItem.)
ExpressionString | Gets or sets an expression to calculate a value that is displayed in the legend item. (Inherited from LegendItem.)
Fill | Gets or sets the fill used for drawing. (Inherited from LegendItem.)
Legend | Determines the specified legend. (Inherited from LegendItem.)
RowNumber | Determines the row number of the LegenItem. (Inherited from LegendItem.)
Series | Gets or sets legend series. (Inherited from LegendItem.)
StartPoint | Gets or sets the coordinates of the left-up corner of the LegendItem. (Inherited from LegendItem.)
Text | Overridden. See Text. (Overrides LegendItem..::.Text.)

See Also

LegendSeriesItem Class
PerpetuumSoft.Charts Namespace


Text Property

[image]

.NET ModelKit Suite ClassReference
LegendSeriesItem..::.Text Property
LegendSeriesItem Class See Also Send Feedback
Overridden. See Text.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override string Text { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Text As String
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
}

See Also

LegendSeriesItem Class
PerpetuumSoft.Charts Namespace


LegendType Enumeration

[image]

.NET ModelKit Suite ClassReference
LegendType Enumeration
See Also Send Feedback
Enumerates type of the legend items position.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public enum LegendType
Visual Basic (Declaration)
Public Enumeration LegendType
Visual C++
public enum class LegendType

Members

Member name | Description
Horisontal | Indicates that the legend items are placed horizontally.
Verical | Indicates that the legend items are placed vertically.

See Also

PerpetuumSoft.Charts Namespace


LegendValuesItem Class

[image]

.NET ModelKit Suite ClassReference
LegendValuesItem Class
Members See Also Send Feedback
Represents a legend element that corresponds to the series value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class LegendValuesItem : LegendItem
Visual Basic (Declaration)
Public Class LegendValuesItem _
    Inherits LegendItem
Visual C++
public ref class LegendValuesItem : public LegendItem

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.LegendItem
PerpetuumSoft.Charts..::.LegendValuesItem

See Also

LegendValuesItem Members
PerpetuumSoft.Charts Namespace


LegendValuesItem Members

[image] [image]

.NET ModelKit Suite ClassReference
LegendValuesItem Members
LegendValuesItem Class Constructors Methods Properties See Also Send Feedback

The LegendValuesItem type exposes the following members.

Constructors

Name | Description
LegendValuesItem | Initializes a new instance of the LegendValuesItem class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBadgeSize | Returns badge size. (Inherited from LegendItem.)
GetFunction | Implements GetFunction(String).
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObject | Implements GetObject(String).
GetSize | Returns the size of a legend item. (Inherited from LegendItem.)
GetTextSize | Returns text size. (Inherited from LegendItem.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnLegendItemChanged | Occures when a legend item has been changed. (Inherited from LegendItem.)
Paint | Overloaded.
PaintBadge | Overridden. See PaintBadge(GraphicStream, VectorRectangle). (Overrides LegendItem..::.PaintBadge(GraphicStream, VectorRectangle).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColumnNumber | Determines the column numder of the LegenItem. (Inherited from LegendItem.)
ExpressionString | Gets or sets an expression to calculate a value that is displayed in the legend item. (Inherited from LegendItem.)
Fill | Gets or sets the fill used for drawing. (Inherited from LegendItem.)
Index | Returns an index of the corresponding series value.
Legend | Determines the specified legend. (Inherited from LegendItem.)
RowNumber | Determines the row number of the LegenItem. (Inherited from LegendItem.)
Series | Gets or sets legend series. (Inherited from LegendItem.)
StartPoint | Gets or sets the coordinates of the left-up corner of the LegendItem. (Inherited from LegendItem.)
Text | Overridden. See Text. (Overrides LegendItem..::.Text.)

See Also

LegendValuesItem Class
PerpetuumSoft.Charts Namespace


LegendValuesItem Constructor

[image]

.NET ModelKit Suite ClassReference
LegendValuesItem Constructor
LegendValuesItem Class See Also Send Feedback
Initializes a new instance of the LegendValuesItem class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public LegendValuesItem(
    Legend legend,
    int index,
    Series series
)
Visual Basic (Declaration)
Public Sub New ( _
    legend As Legend, _
    index As Integer, _
    series As Series _
)
Visual C++
public:
LegendValuesItem(
    Legend^ legend,
    int index,
    Series^ series
)

Parameters

legend
Type: PerpetuumSoft.Charts..::.Legend
index
Type: System..::.Int32
series
Type: PerpetuumSoft.Charts..::.Series

See Also

LegendValuesItem Class
PerpetuumSoft.Charts Namespace


LegendValuesItem Methods

[image] [image]

.NET ModelKit Suite ClassReference
LegendValuesItem Methods
LegendValuesItem Class See Also Send Feedback

The LegendValuesItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBadgeSize | Returns badge size. (Inherited from LegendItem.)
GetFunction | Implements GetFunction(String).
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObject | Implements GetObject(String).
GetSize | Returns the size of a legend item. (Inherited from LegendItem.)
GetTextSize | Returns text size. (Inherited from LegendItem.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnLegendItemChanged | Occures when a legend item has been changed. (Inherited from LegendItem.)
Paint | Overloaded.
PaintBadge | Overridden. See PaintBadge(GraphicStream, VectorRectangle). (Overrides LegendItem..::.PaintBadge(GraphicStream, VectorRectangle).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegendValuesItem Class
PerpetuumSoft.Charts Namespace


GetFunction Method

[image]

.NET ModelKit Suite ClassReference
LegendValuesItem..::.GetFunction Method
LegendValuesItem Class See Also Send Feedback
Implements GetFunction(String).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public IFunction GetFunction(
    string name
)
Visual Basic (Declaration)
Public Function GetFunction ( _
    name As String _
) As IFunction
Visual C++
public:
virtual IFunction^ GetFunction(
    String^ name
) sealed

Parameters

name
Type: System..::.String

See Also

LegendValuesItem Class
PerpetuumSoft.Charts Namespace


GetObject Method

[image]

.NET ModelKit Suite ClassReference
LegendValuesItem..::.GetObject Method
LegendValuesItem Class See Also Send Feedback
Implements GetObject(String).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Object GetObject(
    string name
)
Visual Basic (Declaration)
Public Function GetObject ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetObject(
    String^ name
) sealed

Parameters

name
Type: System..::.String

See Also

LegendValuesItem Class
PerpetuumSoft.Charts Namespace


Paint Method

[image] [image]

.NET ModelKit Suite ClassReference
LegendValuesItem..::.Paint Method
LegendValuesItem Class See Also Send Feedback

Overload List

Name | Description
Paint(GraphicStream) | Paint a legend item. (Inherited from LegendItem.)
Paint(GraphicStream, Vector) | Paints a legend item. (Inherited from LegendItem.)

See Also

LegendValuesItem Class
LegendValuesItem Members
PerpetuumSoft.Charts Namespace


PaintBadge Method

[image]

.NET ModelKit Suite ClassReference
LegendValuesItem..::.PaintBadge Method
LegendValuesItem Class See Also Send Feedback
Overridden. See PaintBadge(GraphicStream, VectorRectangle).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintBadge(
    GraphicStream graphicStream,
    VectorRectangle area
)
Visual Basic (Declaration)
Public Overrides Sub PaintBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle _
)
Visual C++
public:
virtual void PaintBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area
) override

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

LegendValuesItem Class
PerpetuumSoft.Charts Namespace


LegendValuesItem Properties

[image] [image]

.NET ModelKit Suite ClassReference
LegendValuesItem Properties
LegendValuesItem Class See Also Send Feedback

The LegendValuesItem type exposes the following members.

Properties

Name | Description
ColumnNumber | Determines the column numder of the LegenItem. (Inherited from LegendItem.)
ExpressionString | Gets or sets an expression to calculate a value that is displayed in the legend item. (Inherited from LegendItem.)
Fill | Gets or sets the fill used for drawing. (Inherited from LegendItem.)
Index | Returns an index of the corresponding series value.
Legend | Determines the specified legend. (Inherited from LegendItem.)
RowNumber | Determines the row number of the LegenItem. (Inherited from LegendItem.)
Series | Gets or sets legend series. (Inherited from LegendItem.)
StartPoint | Gets or sets the coordinates of the left-up corner of the LegendItem. (Inherited from LegendItem.)
Text | Overridden. See Text. (Overrides LegendItem..::.Text.)

See Also

LegendValuesItem Class
PerpetuumSoft.Charts Namespace


Index Property

[image]

.NET ModelKit Suite ClassReference
LegendValuesItem..::.Index Property
LegendValuesItem Class See Also Send Feedback
Returns an index of the corresponding series value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

LegendValuesItem Class
PerpetuumSoft.Charts Namespace


Text Property

[image]

.NET ModelKit Suite ClassReference
LegendValuesItem..::.Text Property
LegendValuesItem Class See Also Send Feedback
Overridden. See Text.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override string Text { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Text As String
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
}

See Also

LegendValuesItem Class
PerpetuumSoft.Charts Namespace


LevelSeriesView Class

[image]

.NET ModelKit Suite ClassReference
LevelSeriesView Class
Members See Also Send Feedback
Represents series view to display series data in the form of the Level.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class LevelSeriesView : BarSeriesViewBase
Visual Basic (Declaration)
Public Class LevelSeriesView _
    Inherits BarSeriesViewBase
Visual C++
public ref class LevelSeriesView : public BarSeriesViewBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.BarSeriesViewBase
PerpetuumSoft.Charts..::.LevelSeriesView
PerpetuumSoft.Charts..::.ThermometerSeriesView

See Also

LevelSeriesView Members
PerpetuumSoft.Charts Namespace


LevelSeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
LevelSeriesView Members
LevelSeriesView Class Constructors Methods Properties Events See Also Send Feedback

The LevelSeriesView type exposes the following members.

Constructors

Name | Description
LevelSeriesView | Initializes a new instance of the LevelSeriesView class.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElements | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from BarSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from BarSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from BarSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AciveLayer | Gets or sets LevelSeriesView..::.LevelProperties for the top layer of the Level element.
AreaWidth | Gets or sets the ratio between the width of the occupied Bars and the available space. (Inherited from BarSeriesViewBase.)
ColumnImage | Gets or sets Image which sets the image drawn in the column. (Inherited from BarSeriesViewBase.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
ImageSizeMode | Gets or sets ImageSizeMode which sets zoom mode for the image displayed in the column. (Inherited from BarSeriesViewBase.)
InaciveLayer | Gets or sets LevelSeriesView..::.LevelProperties for the bottom layer of the Level element.
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from BarSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
ViewType | Gets or sets ViewType object that determines kind of Bars. (Inherited from BarSeriesViewBase.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

LevelSeriesView Class
PerpetuumSoft.Charts Namespace


LevelSeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
LevelSeriesView Constructor
LevelSeriesView Class See Also Send Feedback
Initializes a new instance of the LevelSeriesView class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public LevelSeriesView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LevelSeriesView()

See Also

LevelSeriesView Class
PerpetuumSoft.Charts Namespace


LevelSeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
LevelSeriesView Methods
LevelSeriesView Class See Also Send Feedback

The LevelSeriesView type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElements | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from BarSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from BarSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from BarSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LevelSeriesView Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
LevelSeriesView..::.Clone Method
LevelSeriesView Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesView Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesView
Visual C++
public:
virtual SeriesView^ Clone() override

See Also

LevelSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElements Method

[image] [image]

.NET ModelKit Suite ClassReference
LevelSeriesView..::.CreateElements Method
LevelSeriesView Class See Also Send Feedback

Overload List

Name | Description
CreateElements(ChartArea) | Overridden. See CreateElements(ChartArea). (Inherited from BarSeriesViewBase.)
CreateElements(ArgumentValuesMap, ChartArea) | Creates chart elements by series data. (Inherited from BarSeriesViewBase.)

See Also

LevelSeriesView Class
LevelSeriesView Members
PerpetuumSoft.Charts Namespace


GetElement Method

[image] [image]

.NET ModelKit Suite ClassReference
LevelSeriesView..::.GetElement Method
LevelSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetElement(VectorRectangle, Double) | Returns an element that corresponds to the specified area and value. (Inherited from BarSeriesViewBase.)
GetElement(VectorRectangle, Double, Int32) | Returns an element that corresponds to the specified area, value and the number in the palette. (Inherited from BarSeriesViewBase.)

See Also

LevelSeriesView Class
LevelSeriesView Members
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
LevelSeriesView..::.GetSeries Method
LevelSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

LevelSeriesView Class
LevelSeriesView Members
PerpetuumSoft.Charts Namespace


LevelSeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
LevelSeriesView Properties
LevelSeriesView Class See Also Send Feedback

The LevelSeriesView type exposes the following members.

Properties

Name | Description
AciveLayer | Gets or sets LevelSeriesView..::.LevelProperties for the top layer of the Level element.
AreaWidth | Gets or sets the ratio between the width of the occupied Bars and the available space. (Inherited from BarSeriesViewBase.)
ColumnImage | Gets or sets Image which sets the image drawn in the column. (Inherited from BarSeriesViewBase.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
ImageSizeMode | Gets or sets ImageSizeMode which sets zoom mode for the image displayed in the column. (Inherited from BarSeriesViewBase.)
InaciveLayer | Gets or sets LevelSeriesView..::.LevelProperties for the bottom layer of the Level element.
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from BarSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
ViewType | Gets or sets ViewType object that determines kind of Bars. (Inherited from BarSeriesViewBase.)

See Also

LevelSeriesView Class
PerpetuumSoft.Charts Namespace


AciveLayer Property

[image]

.NET ModelKit Suite ClassReference
LevelSeriesView..::.AciveLayer Property
LevelSeriesView Class See Also Send Feedback
Gets or sets LevelSeriesView..::.LevelProperties for the top layer of the Level element.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public LevelSeriesView..::.LevelProperties AciveLayer { get; set; }
Visual Basic (Declaration)
Public Property AciveLayer As LevelSeriesView..::.LevelProperties
Visual C++
public:
property LevelSeriesView..::.LevelProperties^ AciveLayer {
    LevelSeriesView..::.LevelProperties^ get ();
    void set (LevelSeriesView..::.LevelProperties^ value);
}

See Also

LevelSeriesView Class
PerpetuumSoft.Charts Namespace


InaciveLayer Property

[image]

.NET ModelKit Suite ClassReference
LevelSeriesView..::.InaciveLayer Property
LevelSeriesView Class See Also Send Feedback
Gets or sets LevelSeriesView..::.LevelProperties for the bottom layer of the Level element.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public LevelSeriesView..::.LevelProperties InaciveLayer { get; set; }
Visual Basic (Declaration)
Public Property InaciveLayer As LevelSeriesView..::.LevelProperties
Visual C++
public:
property LevelSeriesView..::.LevelProperties^ InaciveLayer {
    LevelSeriesView..::.LevelProperties^ get ();
    void set (LevelSeriesView..::.LevelProperties^ value);
}

See Also

LevelSeriesView Class
PerpetuumSoft.Charts Namespace


LevelSeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
LevelSeriesView Events
LevelSeriesView Class See Also Send Feedback

The LevelSeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

LevelSeriesView Class
PerpetuumSoft.Charts Namespace


LevelSeriesView.LevelProperties Class

[image]

.NET ModelKit Suite ClassReference
LevelSeriesView..::.LevelProperties Class
LevelSeriesView Class Members See Also Send Feedback
Represents properties for the top and bottom layers of the Level.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class LevelProperties : ICloneable
Visual Basic (Declaration)
Public Class LevelProperties _
    Implements ICloneable
Visual C++
public ref class LevelProperties : ICloneable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.LevelSeriesView..::.LevelProperties

See Also

LevelSeriesView..::.LevelProperties Members
PerpetuumSoft.Charts Namespace


LevelSeriesView.LevelProperties Members

[image] [image]

.NET ModelKit Suite ClassReference
LevelSeriesView..::.LevelProperties Members
LevelSeriesView..::.LevelProperties Class Constructors Methods Properties See Also Send Feedback

Represents series view to display series data in the form of the Level.

The LevelSeriesView..::.LevelProperties type exposes the following members.

Constructors

Name | Description
LevelSeriesView..::.LevelProperties | Initializes a new instance of the LevelSeriesView..::.LevelProperties class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Colors | Gets ColorSectionCollection. This collection represents the colors that will be used for the Level element painting.
Divisions | Gets or sets a value that indicates the count of the divisions on the Level.
DivisionsStroke | Gets or sets Stroke for the Divisions drawing.
Effect3D | Gets or sets Effect3D style of the Level element painting.
EndCap | Gets or sets CapStyle style of end Level element painting.
EndColor | Gets or sets Color of the end Level element painting.
StartCap | Gets or sets CapStyle style of the Start Level element painting
StartColor | Gets or sets Color of the start Level element painting.

See Also

LevelSeriesView..::.LevelProperties Class
PerpetuumSoft.Charts Namespace


LevelSeriesView.LevelProperties Constructor

[image]

.NET ModelKit Suite ClassReference
LevelSeriesView..::.LevelProperties Constructor
LevelSeriesView..::.LevelProperties Class See Also Send Feedback
Initializes a new instance of the LevelSeriesView..::.LevelProperties class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public LevelProperties()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LevelProperties()

See Also

LevelSeriesView..::.LevelProperties Class
PerpetuumSoft.Charts Namespace


LevelSeriesView.LevelProperties Methods

[image] [image]

.NET ModelKit Suite ClassReference
LevelSeriesView..::.LevelProperties Methods
LevelSeriesView..::.LevelProperties Class See Also Send Feedback

The LevelSeriesView..::.LevelProperties type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LevelSeriesView..::.LevelProperties Class
PerpetuumSoft.Charts Namespace


LevelSeriesView.LevelProperties Properties

[image] [image]

.NET ModelKit Suite ClassReference
LevelSeriesView..::.LevelProperties Properties
LevelSeriesView..::.LevelProperties Class See Also Send Feedback

The LevelSeriesView..::.LevelProperties type exposes the following members.

Properties

Name | Description
Colors | Gets ColorSectionCollection. This collection represents the colors that will be used for the Level element painting.
Divisions | Gets or sets a value that indicates the count of the divisions on the Level.
DivisionsStroke | Gets or sets Stroke for the Divisions drawing.
Effect3D | Gets or sets Effect3D style of the Level element painting.
EndCap | Gets or sets CapStyle style of end Level element painting.
EndColor | Gets or sets Color of the end Level element painting.
StartCap | Gets or sets CapStyle style of the Start Level element painting
StartColor | Gets or sets Color of the start Level element painting.

See Also

LevelSeriesView..::.LevelProperties Class
PerpetuumSoft.Charts Namespace


Colors Property

[image]

.NET ModelKit Suite ClassReference
LevelSeriesView..::.LevelProperties..::.Colors Property
LevelSeriesView..::.LevelProperties Class See Also Send Feedback
Gets ColorSectionCollection. This collection represents the colors that will be used for the Level element painting.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ColorSectionCollection Colors { get; }
Visual Basic (Declaration)
Public ReadOnly Property Colors As ColorSectionCollection
Visual C++
public:
property ColorSectionCollection^ Colors {
    ColorSectionCollection^ get ();
}

See Also

LevelSeriesView..::.LevelProperties Class
PerpetuumSoft.Charts Namespace


Divisions Property

[image]

.NET ModelKit Suite ClassReference
LevelSeriesView..::.LevelProperties..::.Divisions Property
LevelSeriesView..::.LevelProperties Class See Also Send Feedback
Gets or sets a value that indicates the count of the divisions on the Level.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public int Divisions { get; set; }
Visual Basic (Declaration)
Public Property Divisions As Integer
Visual C++
public:
property int Divisions {
    int get ();
    void set (int value);
}

See Also

LevelSeriesView..::.LevelProperties Class
PerpetuumSoft.Charts Namespace


DivisionsStroke Property

[image]

.NET ModelKit Suite ClassReference
LevelSeriesView..::.LevelProperties..::.DivisionsStroke Property
LevelSeriesView..::.LevelProperties Class See Also Send Feedback
Gets or sets Stroke for the Divisions drawing.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Stroke DivisionsStroke { get; set; }
Visual Basic (Declaration)
Public Property DivisionsStroke As Stroke
Visual C++
public:
property Stroke^ DivisionsStroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

LevelSeriesView..::.LevelProperties Class
PerpetuumSoft.Charts Namespace


Effect3D Property

[image]

.NET ModelKit Suite ClassReference
LevelSeriesView..::.LevelProperties..::.Effect3D Property
LevelSeriesView..::.LevelProperties Class See Also Send Feedback
Gets or sets Effect3D style of the Level element painting.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Effect3D Effect3D { get; set; }
Visual Basic (Declaration)
Public Property Effect3D As Effect3D
Visual C++
public:
property Effect3D Effect3D {
    Effect3D get ();
    void set (Effect3D value);
}

See Also

LevelSeriesView..::.LevelProperties Class
PerpetuumSoft.Charts Namespace


EndCap Property

[image]

.NET ModelKit Suite ClassReference
LevelSeriesView..::.LevelProperties..::.EndCap Property
LevelSeriesView..::.LevelProperties Class See Also Send Feedback
Gets or sets CapStyle style of end Level element painting.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public CapStyle EndCap { get; set; }
Visual Basic (Declaration)
Public Property EndCap As CapStyle
Visual C++
public:
property CapStyle EndCap {
    CapStyle get ();
    void set (CapStyle value);
}

See Also

LevelSeriesView..::.LevelProperties Class
PerpetuumSoft.Charts Namespace


EndColor Property

[image]

.NET ModelKit Suite ClassReference
LevelSeriesView..::.LevelProperties..::.EndColor Property
LevelSeriesView..::.LevelProperties Class See Also Send Feedback
Gets or sets Color of the end Level element painting.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Color EndColor { get; set; }
Visual Basic (Declaration)
Public Property EndColor As Color
Visual C++
public:
property Color EndColor {
    Color get ();
    void set (Color value);
}

See Also

LevelSeriesView..::.LevelProperties Class
PerpetuumSoft.Charts Namespace


StartCap Property

[image]

.NET ModelKit Suite ClassReference
LevelSeriesView..::.LevelProperties..::.StartCap Property
LevelSeriesView..::.LevelProperties Class See Also Send Feedback
Gets or sets CapStyle style of the Start Level element painting

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public CapStyle StartCap { get; set; }
Visual Basic (Declaration)
Public Property StartCap As CapStyle
Visual C++
public:
property CapStyle StartCap {
    CapStyle get ();
    void set (CapStyle value);
}

See Also

LevelSeriesView..::.LevelProperties Class
PerpetuumSoft.Charts Namespace


StartColor Property

[image]

.NET ModelKit Suite ClassReference
LevelSeriesView..::.LevelProperties..::.StartColor Property
LevelSeriesView..::.LevelProperties Class See Also Send Feedback
Gets or sets Color of the start Level element painting.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Color StartColor { get; set; }
Visual Basic (Declaration)
Public Property StartColor As Color
Visual C++
public:
property Color StartColor {
    Color get ();
    void set (Color value);
}

See Also

LevelSeriesView..::.LevelProperties Class
PerpetuumSoft.Charts Namespace


LineAxisArrow Class

[image]

.NET ModelKit Suite ClassReference
LineAxisArrow Class
Members See Also Send Feedback
Represents an axel end in the form of a line.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class LineAxisArrow : AxisArrow
Visual Basic (Declaration)
Public Class LineAxisArrow _
    Inherits AxisArrow
Visual C++
public ref class LineAxisArrow : public AxisArrow

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.AxisArrow
PerpetuumSoft.Charts..::.LineAxisArrow

See Also

LineAxisArrow Members
PerpetuumSoft.Charts Namespace


LineAxisArrow Members

[image] [image]

.NET ModelKit Suite ClassReference
LineAxisArrow Members
LineAxisArrow Class Constructors Methods Properties See Also Send Feedback

The LineAxisArrow type exposes the following members.

Constructors

Name | Description
LineAxisArrow | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSize | Overridden. See GetSize(AxisDirection). (Overrides AxisArrow..::.GetSize(AxisDirection).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Paint | Overridden. See Paint(GraphicStream, Vector, AxisDirection, Stroke, Boolean). (Overrides AxisArrow..::.Paint(GraphicStream, Vector, AxisDirection, Stroke, Boolean).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Length | Gets or sets the length of an axel end.

See Also

LineAxisArrow Class
PerpetuumSoft.Charts Namespace


LineAxisArrow Constructor

[image] [image]

.NET ModelKit Suite ClassReference
LineAxisArrow Constructor
LineAxisArrow Class See Also Send Feedback

Overload List

Name | Description
LineAxisArrow()()() | Initializes a new instance of the LineAxisArrow class.
LineAxisArrow(Double) | Initializes a new instance of the LineAxisArrow class.

See Also

LineAxisArrow Class
LineAxisArrow Members
PerpetuumSoft.Charts Namespace


LineAxisArrow Constructor

[image]

.NET ModelKit Suite ClassReference
LineAxisArrow Constructor
LineAxisArrow Class See Also Send Feedback
Initializes a new instance of the LineAxisArrow class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public LineAxisArrow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LineAxisArrow()

See Also

LineAxisArrow Class
LineAxisArrow Overload
PerpetuumSoft.Charts Namespace


LineAxisArrow Constructor (Double)

[image]

.NET ModelKit Suite ClassReference
LineAxisArrow Constructor (Double)
LineAxisArrow Class See Also Send Feedback
Initializes a new instance of the LineAxisArrow class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public LineAxisArrow(
    double length
)
Visual Basic (Declaration)
Public Sub New ( _
    length As Double _
)
Visual C++
public:
LineAxisArrow(
    double length
)

Parameters

length
Type: System..::.Double

See Also

LineAxisArrow Class
LineAxisArrow Overload
PerpetuumSoft.Charts Namespace


LineAxisArrow Methods

[image] [image]

.NET ModelKit Suite ClassReference
LineAxisArrow Methods
LineAxisArrow Class See Also Send Feedback

The LineAxisArrow type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSize | Overridden. See GetSize(AxisDirection). (Overrides AxisArrow..::.GetSize(AxisDirection).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Paint | Overridden. See Paint(GraphicStream, Vector, AxisDirection, Stroke, Boolean). (Overrides AxisArrow..::.Paint(GraphicStream, Vector, AxisDirection, Stroke, Boolean).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineAxisArrow Class
PerpetuumSoft.Charts Namespace


GetSize Method

[image]

.NET ModelKit Suite ClassReference
LineAxisArrow..::.GetSize Method
LineAxisArrow Class See Also Send Feedback
Overridden. See GetSize(AxisDirection).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Vector GetSize(
    AxisDirection direction
)
Visual Basic (Declaration)
Public Overrides Function GetSize ( _
    direction As AxisDirection _
) As Vector
Visual C++
public:
virtual Vector GetSize(
    AxisDirection direction
) override

Parameters

direction
Type: PerpetuumSoft.Charts..::.AxisDirection

See Also

LineAxisArrow Class
PerpetuumSoft.Charts Namespace


Paint Method

[image]

.NET ModelKit Suite ClassReference
LineAxisArrow..::.Paint Method
LineAxisArrow Class See Also Send Feedback
Overridden. See Paint(GraphicStream, Vector, AxisDirection, Stroke, Boolean).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void Paint(
    GraphicStream g,
    Vector startPoint,
    AxisDirection direction,
    Stroke stroke,
    bool reverse
)
Visual Basic (Declaration)
Public Overrides Sub Paint ( _
    g As GraphicStream, _
    startPoint As Vector, _
    direction As AxisDirection, _
    stroke As Stroke, _
    reverse As Boolean _
)
Visual C++
public:
virtual void Paint(
    GraphicStream^ g,
    Vector startPoint,
    AxisDirection direction,
    Stroke^ stroke,
    bool reverse
) override

Parameters

g
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
startPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
direction
Type: PerpetuumSoft.Charts..::.AxisDirection
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
reverse
Type: System..::.Boolean

See Also

LineAxisArrow Class
PerpetuumSoft.Charts Namespace


LineAxisArrow Properties

[image] [image]

.NET ModelKit Suite ClassReference
LineAxisArrow Properties
LineAxisArrow Class See Also Send Feedback

The LineAxisArrow type exposes the following members.

Properties

Name | Description
Length | Gets or sets the length of an axel end.

See Also

LineAxisArrow Class
PerpetuumSoft.Charts Namespace


Length Property

[image]

.NET ModelKit Suite ClassReference
LineAxisArrow..::.Length Property
LineAxisArrow Class See Also Send Feedback
Gets or sets the length of an axel end.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double Length { get; set; }
Visual Basic (Declaration)
Public Property Length As Double
Visual C++
public:
property double Length {
    double get ();
    void set (double value);
}

See Also

LineAxisArrow Class
PerpetuumSoft.Charts Namespace


LineSeriesView Class

[image]

.NET ModelKit Suite ClassReference
LineSeriesView Class
Members See Also Send Feedback
Represents SeriesView to display series data in the form of the broken line.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class LineSeriesView : LineSeriesViewBase
Visual Basic (Declaration)
Public Class LineSeriesView _
    Inherits LineSeriesViewBase
Visual C++
public ref class LineSeriesView : public LineSeriesViewBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.SimpleAxisSeriesView
PerpetuumSoft.Charts..::.LineSeriesViewBase
PerpetuumSoft.Charts..::.LineSeriesView

See Also

LineSeriesView Members
PerpetuumSoft.Charts Namespace


LineSeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
LineSeriesView Members
LineSeriesView Class Constructors Methods Properties Events See Also Send Feedback

The LineSeriesView type exposes the following members.

Constructors

Name | Description
LineSeriesView | Initializes a new instance of the LineSeriesView class.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElement | Creates an element that represents a chart by the corresponding points. (Inherited from LineSeriesViewBase.)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates elements which correspond to the specified series. (Overrides SimpleAxisSeriesView..::.CreateElementsForSeries(Series).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetLineSeriesViewStroke | Returns the Stroke taking into account the specified palette. (Inherited from LineSeriesViewBase.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from LineSeriesViewBase.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from LineSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from LineSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from LineSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DefaultColor | 'Gets or sets default line color. (Inherited from LineSeriesViewBase.)
DefaultLineStyle | 'Gets or sets default line style. (Inherited from LineSeriesViewBase.)
DefaultLineWidth | Gets or sets default line width. (Inherited from LineSeriesViewBase.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from LineSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

LineSeriesView Class
PerpetuumSoft.Charts Namespace


LineSeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
LineSeriesView Constructor
LineSeriesView Class See Also Send Feedback
Initializes a new instance of the LineSeriesView class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public LineSeriesView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LineSeriesView()

See Also

LineSeriesView Class
PerpetuumSoft.Charts Namespace


LineSeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
LineSeriesView Methods
LineSeriesView Class See Also Send Feedback

The LineSeriesView type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElement | Creates an element that represents a chart by the corresponding points. (Inherited from LineSeriesViewBase.)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates elements which correspond to the specified series. (Overrides SimpleAxisSeriesView..::.CreateElementsForSeries(Series).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetLineSeriesViewStroke | Returns the Stroke taking into account the specified palette. (Inherited from LineSeriesViewBase.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from LineSeriesViewBase.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from LineSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from LineSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from LineSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineSeriesView Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
LineSeriesView..::.Clone Method
LineSeriesView Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesView Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesView
Visual C++
public:
virtual SeriesView^ Clone() override

See Also

LineSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElementsForSeries Method

[image]

.NET ModelKit Suite ClassReference
LineSeriesView..::.CreateElementsForSeries Method
LineSeriesView Class See Also Send Feedback
Creates elements which correspond to the specified series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void CreateElementsForSeries(
    Series series
)
Visual Basic (Declaration)
Protected Overrides Sub CreateElementsForSeries ( _
    series As Series _
)
Visual C++
protected:
virtual void CreateElementsForSeries(
    Series^ series
) override

Parameters

series
Type: PerpetuumSoft.Charts..::.Series

See Also

LineSeriesView Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
LineSeriesView..::.GetSeries Method
LineSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

LineSeriesView Class
LineSeriesView Members
PerpetuumSoft.Charts Namespace


LineSeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
LineSeriesView Properties
LineSeriesView Class See Also Send Feedback

The LineSeriesView type exposes the following members.

Properties

Name | Description
DefaultColor | 'Gets or sets default line color. (Inherited from LineSeriesViewBase.)
DefaultLineStyle | 'Gets or sets default line style. (Inherited from LineSeriesViewBase.)
DefaultLineWidth | Gets or sets default line width. (Inherited from LineSeriesViewBase.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from LineSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

See Also

LineSeriesView Class
PerpetuumSoft.Charts Namespace


LineSeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
LineSeriesView Events
LineSeriesView Class See Also Send Feedback

The LineSeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

LineSeriesView Class
PerpetuumSoft.Charts Namespace


LineSeriesViewBase Class

[image]

.NET ModelKit Suite ClassReference
LineSeriesViewBase Class
Members See Also Send Feedback
Determines a base class for a lenear chart.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract class LineSeriesViewBase : SimpleAxisSeriesView
Visual Basic (Declaration)
Public MustInherit Class LineSeriesViewBase _
    Inherits SimpleAxisSeriesView
Visual C++
public ref class LineSeriesViewBase abstract : public SimpleAxisSeriesView

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.SimpleAxisSeriesView
PerpetuumSoft.Charts..::.LineSeriesViewBase
PerpetuumSoft.Charts..::.LineSeriesView
PerpetuumSoft.Charts..::.StepLineSeriesView

See Also

LineSeriesViewBase Members
PerpetuumSoft.Charts Namespace


LineSeriesViewBase Members

[image] [image]

.NET ModelKit Suite ClassReference
LineSeriesViewBase Members
LineSeriesViewBase Class Constructors Methods Properties Events See Also Send Feedback

The LineSeriesViewBase type exposes the following members.

Constructors

Name | Description
LineSeriesViewBase | Initializes a new instance of the LineSeriesViewBase class

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Creates an object copy. (Inherited from SeriesView.)
CreateElement | Creates an element that represents a chart by the corresponding points.
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates array of elements which represent a chart of the specified series. (Inherited from SimpleAxisSeriesView.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetLineSeriesViewStroke | Returns the Stroke taking into account the specified palette.
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Overrides AxisSeriesView..::.GetSeriesValueType()()().)
GetSideIndent | Overridden. See GetSideIndent()()(). (Overrides SeriesView..::.GetSideIndent()()().)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Overrides SeriesView..::.PaintLegendBadge(GraphicStream, VectorRectangle).)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Overrides SeriesView..::.PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DefaultColor | 'Gets or sets default line color.
DefaultLineStyle | 'Gets or sets default line style.
DefaultLineWidth | Gets or sets default line width.
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Overrides SeriesView..::.IsValueLegendItemSupported.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

LineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


LineSeriesViewBase Constructor

[image]

.NET ModelKit Suite ClassReference
LineSeriesViewBase Constructor
LineSeriesViewBase Class See Also Send Feedback
Initializes a new instance of the LineSeriesViewBase class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected LineSeriesViewBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
LineSeriesViewBase()

See Also

LineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


LineSeriesViewBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
LineSeriesViewBase Methods
LineSeriesViewBase Class See Also Send Feedback

The LineSeriesViewBase type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Creates an object copy. (Inherited from SeriesView.)
CreateElement | Creates an element that represents a chart by the corresponding points.
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates array of elements which represent a chart of the specified series. (Inherited from SimpleAxisSeriesView.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetLineSeriesViewStroke | Returns the Stroke taking into account the specified palette.
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Overrides AxisSeriesView..::.GetSeriesValueType()()().)
GetSideIndent | Overridden. See GetSideIndent()()(). (Overrides SeriesView..::.GetSideIndent()()().)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Overrides SeriesView..::.PaintLegendBadge(GraphicStream, VectorRectangle).)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Overrides SeriesView..::.PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


CreateElement Method

[image]

.NET ModelKit Suite ClassReference
LineSeriesViewBase..::.CreateElement Method
LineSeriesViewBase Class See Also Send Feedback
Creates an element that represents a chart by the corresponding points.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void CreateElement(
    Series series,
    Vector[] points
)
Visual Basic (Declaration)
Protected Overridable Sub CreateElement ( _
    series As Series, _
    points As Vector() _
)
Visual C++
protected:
virtual void CreateElement(
    Series^ series,
    array<Vector>^ points
)

Parameters

series
Type: PerpetuumSoft.Charts..::.Series
points
Type: array< PerpetuumSoft.Framework.Drawing..::.Vector >[]()[]

See Also

LineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


GetLineSeriesViewStroke Method

[image]

.NET ModelKit Suite ClassReference
LineSeriesViewBase..::.GetLineSeriesViewStroke Method
LineSeriesViewBase Class See Also Send Feedback
Returns the Stroke taking into account the specified palette.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Stroke GetLineSeriesViewStroke(
    int palleteIndex
)
Visual Basic (Declaration)
Protected Function GetLineSeriesViewStroke ( _
    palleteIndex As Integer _
) As Stroke
Visual C++
protected:
Stroke^ GetLineSeriesViewStroke(
    int palleteIndex
)

Parameters

palleteIndex
Type: System..::.Int32

See Also

LineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
LineSeriesViewBase..::.GetSeries Method
LineSeriesViewBase Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

LineSeriesViewBase Class
LineSeriesViewBase Members
PerpetuumSoft.Charts Namespace


GetSeriesValueType Method

[image]

.NET ModelKit Suite ClassReference
LineSeriesViewBase..::.GetSeriesValueType Method
LineSeriesViewBase Class See Also Send Feedback
Overridden. See GetSeriesValueType()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Type GetSeriesValueType()
Visual Basic (Declaration)
Public Overrides Function GetSeriesValueType As Type
Visual C++
public:
virtual Type^ GetSeriesValueType() override

See Also

LineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


GetSideIndent Method

[image]

.NET ModelKit Suite ClassReference
LineSeriesViewBase..::.GetSideIndent Method
LineSeriesViewBase Class See Also Send Feedback
Overridden. See GetSideIndent()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override double GetSideIndent()
Visual Basic (Declaration)
Public Overrides Function GetSideIndent As Double
Visual C++
public:
virtual double GetSideIndent() override

See Also

LineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


PaintLegendBadge Method

[image]

.NET ModelKit Suite ClassReference
LineSeriesViewBase..::.PaintLegendBadge Method
LineSeriesViewBase Class See Also Send Feedback
Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintLegendBadge(
    GraphicStream graphicStream,
    VectorRectangle area
)
Visual Basic (Declaration)
Public Overrides Sub PaintLegendBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle _
)
Visual C++
public:
virtual void PaintLegendBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area
) override

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

LineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


PaintLegendValueBadge Method

[image]

.NET ModelKit Suite ClassReference
LineSeriesViewBase..::.PaintLegendValueBadge Method
LineSeriesViewBase Class See Also Send Feedback
Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintLegendValueBadge(
    GraphicStream graphicStream,
    VectorRectangle area,
    int seriesValueIndex
)
Visual Basic (Declaration)
Public Overrides Sub PaintLegendValueBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle, _
    seriesValueIndex As Integer _
)
Visual C++
public:
virtual void PaintLegendValueBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area,
    int seriesValueIndex
) override

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
seriesValueIndex
Type: System..::.Int32

See Also

LineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


LineSeriesViewBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
LineSeriesViewBase Properties
LineSeriesViewBase Class See Also Send Feedback

The LineSeriesViewBase type exposes the following members.

Properties

Name | Description
DefaultColor | 'Gets or sets default line color.
DefaultLineStyle | 'Gets or sets default line style.
DefaultLineWidth | Gets or sets default line width.
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Overrides SeriesView..::.IsValueLegendItemSupported.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

See Also

LineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


DefaultColor Property

[image]

.NET ModelKit Suite ClassReference
LineSeriesViewBase..::.DefaultColor Property
LineSeriesViewBase Class See Also Send Feedback
'Gets or sets default line color.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Color DefaultColor { get; set; }
Visual Basic (Declaration)
Public Property DefaultColor As Color
Visual C++
public:
property Color DefaultColor {
    Color get ();
    void set (Color value);
}

See Also

LineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


DefaultLineStyle Property

[image]

.NET ModelKit Suite ClassReference
LineSeriesViewBase..::.DefaultLineStyle Property
LineSeriesViewBase Class See Also Send Feedback
'Gets or sets default line style.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public LineStyle DefaultLineStyle { get; set; }
Visual Basic (Declaration)
Public Property DefaultLineStyle As LineStyle
Visual C++
public:
property LineStyle DefaultLineStyle {
    LineStyle get ();
    void set (LineStyle value);
}

See Also

LineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


DefaultLineWidth Property

[image]

.NET ModelKit Suite ClassReference
LineSeriesViewBase..::.DefaultLineWidth Property
LineSeriesViewBase Class See Also Send Feedback
Gets or sets default line width.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double DefaultLineWidth { get; set; }
Visual Basic (Declaration)
Public Property DefaultLineWidth As Double
Visual C++
public:
property double DefaultLineWidth {
    double get ();
    void set (double value);
}

See Also

LineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


IsValueLegendItemSupported Property

[image]

.NET ModelKit Suite ClassReference
LineSeriesViewBase..::.IsValueLegendItemSupported Property
LineSeriesViewBase Class See Also Send Feedback
Overridden. See IsValueLegendItemSupported.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValueLegendItemSupported { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsValueLegendItemSupported As Boolean
Visual C++
public:
virtual property bool IsValueLegendItemSupported {
    bool get () override;
}

See Also

LineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


LineSeriesViewBase Events

[image] [image]

.NET ModelKit Suite ClassReference
LineSeriesViewBase Events
LineSeriesViewBase Class See Also Send Feedback

The LineSeriesViewBase type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

LineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


NamedSeriesValueCollection Class

[image]

.NET ModelKit Suite ClassReference
NamedSeriesValueCollection Class
Members See Also Send Feedback
Defines the named series value collection.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class NamedSeriesValueCollection
Visual Basic (Declaration)
Public Class NamedSeriesValueCollection
Visual C++
public ref class NamedSeriesValueCollection

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.NamedSeriesValueCollection

See Also

NamedSeriesValueCollection Members
PerpetuumSoft.Charts Namespace


NamedSeriesValueCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
NamedSeriesValueCollection Members
NamedSeriesValueCollection Class Constructors Methods Properties See Also Send Feedback

The NamedSeriesValueCollection type exposes the following members.

Constructors

Name | Description
NamedSeriesValueCollection | Initializes a new instance of the NamedSeriesValueCollection class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Collection | Gets SeriesValueCollection the collection of the series value.
Key | Gets a name, key of the series value collection.

See Also

NamedSeriesValueCollection Class
PerpetuumSoft.Charts Namespace


NamedSeriesValueCollection Constructor

[image]

.NET ModelKit Suite ClassReference
NamedSeriesValueCollection Constructor
NamedSeriesValueCollection Class See Also Send Feedback
Initializes a new instance of the NamedSeriesValueCollection class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public NamedSeriesValueCollection(
    SeriesValueCollection collection,
    Object key
)
Visual Basic (Declaration)
Public Sub New ( _
    collection As SeriesValueCollection, _
    key As Object _
)
Visual C++
public:
NamedSeriesValueCollection(
    SeriesValueCollection^ collection,
    Object^ key
)

Parameters

collection
Type: SeriesValueCollection
key
Type: System..::.Object

See Also

NamedSeriesValueCollection Class
PerpetuumSoft.Charts Namespace


NamedSeriesValueCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
NamedSeriesValueCollection Methods
NamedSeriesValueCollection Class See Also Send Feedback

The NamedSeriesValueCollection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NamedSeriesValueCollection Class
PerpetuumSoft.Charts Namespace


NamedSeriesValueCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
NamedSeriesValueCollection Properties
NamedSeriesValueCollection Class See Also Send Feedback

The NamedSeriesValueCollection type exposes the following members.

Properties

Name | Description
Collection | Gets SeriesValueCollection the collection of the series value.
Key | Gets a name, key of the series value collection.

See Also

NamedSeriesValueCollection Class
PerpetuumSoft.Charts Namespace


Collection Property

[image]

.NET ModelKit Suite ClassReference
NamedSeriesValueCollection..::.Collection Property
NamedSeriesValueCollection Class See Also Send Feedback
Gets SeriesValueCollection the collection of the series value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesValueCollection Collection { get; }
Visual Basic (Declaration)
Public ReadOnly Property Collection As SeriesValueCollection
Visual C++
public:
property SeriesValueCollection^ Collection {
    SeriesValueCollection^ get ();
}

See Also

NamedSeriesValueCollection Class
PerpetuumSoft.Charts Namespace


Key Property

[image]

.NET ModelKit Suite ClassReference
NamedSeriesValueCollection..::.Key Property
NamedSeriesValueCollection Class See Also Send Feedback
Gets a name, key of the series value collection.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Object Key { get; }
Visual Basic (Declaration)
Public ReadOnly Property Key As Object
Visual C++
public:
property Object^ Key {
    Object^ get ();
}

See Also

NamedSeriesValueCollection Class
PerpetuumSoft.Charts Namespace


Palette Class

[image]

.NET ModelKit Suite ClassReference
Palette Class
Members See Also Send Feedback
Defines a base class for the palette used for series elements painting.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract class Palette
Visual Basic (Declaration)
Public MustInherit Class Palette
Visual C++
public ref class Palette abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.Palette
PerpetuumSoft.Charts..::.CustomPalette
PerpetuumSoft.Charts..::.SimplePalette

See Also

Palette Members
PerpetuumSoft.Charts Namespace


Palette Members

[image] [image]

.NET ModelKit Suite ClassReference
Palette Members
Palette Class Constructors Methods Events See Also Send Feedback

The Palette type exposes the following members.

Constructors

Name | Description
Palette | Initializes a new instance of the Palette class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Returns one of the colors available by its index.
GetFill | Returns of the fills available by its index.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Returns one of the strokes available with the specified color and lines width by its index.
GetShape | Returns one of shapes available by its index.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed.

See Also

Palette Class
PerpetuumSoft.Charts Namespace


Palette Constructor

[image]

.NET ModelKit Suite ClassReference
Palette Constructor
Palette Class See Also Send Feedback
Initializes a new instance of the Palette class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Palette()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
Palette()

See Also

Palette Class
PerpetuumSoft.Charts Namespace


Palette Methods

[image] [image]

.NET ModelKit Suite ClassReference
Palette Methods
Palette Class See Also Send Feedback

The Palette type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Returns one of the colors available by its index.
GetFill | Returns of the fills available by its index.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Returns one of the strokes available with the specified color and lines width by its index.
GetShape | Returns one of shapes available by its index.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Palette Class
PerpetuumSoft.Charts Namespace


GetColor Method

[image]

.NET ModelKit Suite ClassReference
Palette..::.GetColor Method
Palette Class See Also Send Feedback
Returns one of the colors available by its index.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract Color GetColor(
    int index
)
Visual Basic (Declaration)
Public MustOverride Function GetColor ( _
    index As Integer _
) As Color
Visual C++
public:
virtual Color GetColor(
    int index
) abstract

Parameters

index
Type: System..::.Int32

See Also

Palette Class
PerpetuumSoft.Charts Namespace


GetFill Method

[image]

.NET ModelKit Suite ClassReference
Palette..::.GetFill Method
Palette Class See Also Send Feedback
Returns of the fills available by its index.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public virtual Fill GetFill(
    int index
)
Visual Basic (Declaration)
Public Overridable Function GetFill ( _
    index As Integer _
) As Fill
Visual C++
public:
virtual Fill^ GetFill(
    int index
)

Parameters

index
Type: System..::.Int32

See Also

Palette Class
PerpetuumSoft.Charts Namespace


GetLineStroke Method

[image]

.NET ModelKit Suite ClassReference
Palette..::.GetLineStroke Method
Palette Class See Also Send Feedback
Returns one of the strokes available with the specified color and lines width by its index.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract Stroke GetLineStroke(
    Color color,
    double width,
    int index
)
Visual Basic (Declaration)
Public MustOverride Function GetLineStroke ( _
    color As Color, _
    width As Double, _
    index As Integer _
) As Stroke
Visual C++
public:
virtual Stroke^ GetLineStroke(
    Color color,
    double width,
    int index
) abstract

Parameters

color
Type: System.Drawing..::.Color
width
Type: System..::.Double
index
Type: System..::.Int32

See Also

Palette Class
PerpetuumSoft.Charts Namespace


GetShape Method

[image]

.NET ModelKit Suite ClassReference
Palette..::.GetShape Method
Palette Class See Also Send Feedback
Returns one of shapes available by its index.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract ShapeBase GetShape(
    int index
)
Visual Basic (Declaration)
Public MustOverride Function GetShape ( _
    index As Integer _
) As ShapeBase
Visual C++
public:
virtual ShapeBase^ GetShape(
    int index
) abstract

Parameters

index
Type: System..::.Int32

See Also

Palette Class
PerpetuumSoft.Charts Namespace


OnPaletteChanged Method

[image]

.NET ModelKit Suite ClassReference
Palette..::.OnPaletteChanged Method
Palette Class See Also Send Feedback
Raises the PaletteChanged event.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnPaletteChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnPaletteChanged
Visual C++
protected:
virtual void OnPaletteChanged()

See Also

Palette Class
PerpetuumSoft.Charts Namespace


Palette Events

[image] [image]

.NET ModelKit Suite ClassReference
Palette Events
Palette Class See Also Send Feedback

The Palette type exposes the following members.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed.

See Also

Palette Class
PerpetuumSoft.Charts Namespace


PaletteChanged Event

[image]

.NET ModelKit Suite ClassReference
Palette..::.PaletteChanged Event
Palette Class See Also Send Feedback
Occurs after the palette has been changed.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler PaletteChanged
Visual Basic (Declaration)
Public Event PaletteChanged As EventHandler
Visual C++
public:
 event EventHandler^ PaletteChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

Palette Class
PerpetuumSoft.Charts Namespace


PaletteBlackAndWhite Class

[image]

.NET ModelKit Suite ClassReference
PaletteBlackAndWhite Class
Members See Also Send Feedback
Represents black-and-white palette.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PaletteBlackAndWhite : SimplePalette
Visual Basic (Declaration)
Public Class PaletteBlackAndWhite _
    Inherits SimplePalette
Visual C++
public ref class PaletteBlackAndWhite : public SimplePalette

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.Palette
PerpetuumSoft.Charts..::.SimplePalette
PerpetuumSoft.Charts..::.PaletteBlackAndWhite

See Also

PaletteBlackAndWhite Members
PerpetuumSoft.Charts Namespace


PaletteBlackAndWhite Members

[image] [image]

.NET ModelKit Suite ClassReference
PaletteBlackAndWhite Members
PaletteBlackAndWhite Class Constructors Methods Events See Also Send Feedback

The PaletteBlackAndWhite type exposes the following members.

Constructors

Name | Description
PaletteBlackAndWhite | Initializes a new instance of the PaletteBlackAndWhite class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Overrides Palette..::.GetColor(Int32).)
GetFill | Overridden. See GetFill(Int32). (Overrides Palette..::.GetFill(Int32).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteBlackAndWhite Class
PerpetuumSoft.Charts Namespace


PaletteBlackAndWhite Constructor

[image]

.NET ModelKit Suite ClassReference
PaletteBlackAndWhite Constructor
PaletteBlackAndWhite Class See Also Send Feedback
Initializes a new instance of the PaletteBlackAndWhite class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PaletteBlackAndWhite()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaletteBlackAndWhite()

See Also

PaletteBlackAndWhite Class
PerpetuumSoft.Charts Namespace


PaletteBlackAndWhite Methods

[image] [image]

.NET ModelKit Suite ClassReference
PaletteBlackAndWhite Methods
PaletteBlackAndWhite Class See Also Send Feedback

The PaletteBlackAndWhite type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Overrides Palette..::.GetColor(Int32).)
GetFill | Overridden. See GetFill(Int32). (Overrides Palette..::.GetFill(Int32).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaletteBlackAndWhite Class
PerpetuumSoft.Charts Namespace


GetColor Method

[image]

.NET ModelKit Suite ClassReference
PaletteBlackAndWhite..::.GetColor Method
PaletteBlackAndWhite Class See Also Send Feedback
Overridden. See GetColor(Int32).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Color GetColor(
    int index
)
Visual Basic (Declaration)
Public Overrides Function GetColor ( _
    index As Integer _
) As Color
Visual C++
public:
virtual Color GetColor(
    int index
) override

Parameters

index
Type: System..::.Int32

See Also

PaletteBlackAndWhite Class
PerpetuumSoft.Charts Namespace


GetFill Method

[image]

.NET ModelKit Suite ClassReference
PaletteBlackAndWhite..::.GetFill Method
PaletteBlackAndWhite Class See Also Send Feedback
Overridden. See GetFill(Int32).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Fill GetFill(
    int index
)
Visual Basic (Declaration)
Public Overrides Function GetFill ( _
    index As Integer _
) As Fill
Visual C++
public:
virtual Fill^ GetFill(
    int index
) override

Parameters

index
Type: System..::.Int32

See Also

PaletteBlackAndWhite Class
PerpetuumSoft.Charts Namespace


PaletteBlackAndWhite Events

[image] [image]

.NET ModelKit Suite ClassReference
PaletteBlackAndWhite Events
PaletteBlackAndWhite Class See Also Send Feedback

The PaletteBlackAndWhite type exposes the following members.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteBlackAndWhite Class
PerpetuumSoft.Charts Namespace


PaletteBlue Class

[image]

.NET ModelKit Suite ClassReference
PaletteBlue Class
Members See Also Send Feedback
Represents palette that uses blue colors.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PaletteBlue : ColoredPalette
Visual Basic (Declaration)
Public Class PaletteBlue _
    Inherits ColoredPalette
Visual C++
public ref class PaletteBlue : public ColoredPalette

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.Palette
PerpetuumSoft.Charts..::.SimplePalette
PerpetuumSoft.Charts..::.ColoredPalette
PerpetuumSoft.Charts..::.PaletteBlue

See Also

PaletteBlue Members
PerpetuumSoft.Charts Namespace


PaletteBlue Members

[image] [image]

.NET ModelKit Suite ClassReference
PaletteBlue Members
PaletteBlue Class Constructors Methods Events See Also Send Feedback

The PaletteBlue type exposes the following members.

Constructors

Name | Description
PaletteBlue | Initializes a new instance of the PaletteBlue class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Returns palette array of colors. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteBlue Class
PerpetuumSoft.Charts Namespace


PaletteBlue Constructor

[image]

.NET ModelKit Suite ClassReference
PaletteBlue Constructor
PaletteBlue Class See Also Send Feedback
Initializes a new instance of the PaletteBlue class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PaletteBlue()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaletteBlue()

See Also

PaletteBlue Class
PerpetuumSoft.Charts Namespace


PaletteBlue Methods

[image] [image]

.NET ModelKit Suite ClassReference
PaletteBlue Methods
PaletteBlue Class See Also Send Feedback

The PaletteBlue type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Returns palette array of colors. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaletteBlue Class
PerpetuumSoft.Charts Namespace


GetColors Method

[image]

.NET ModelKit Suite ClassReference
PaletteBlue..::.GetColors Method
PaletteBlue Class See Also Send Feedback
Returns palette array of colors.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override Color[] GetColors()
Visual Basic (Declaration)
Protected Overrides Function GetColors As Color()
Visual C++
protected:
virtual array<Color>^ GetColors() override

See Also

PaletteBlue Class
PerpetuumSoft.Charts Namespace


PaletteBlue Events

[image] [image]

.NET ModelKit Suite ClassReference
PaletteBlue Events
PaletteBlue Class See Also Send Feedback

The PaletteBlue type exposes the following members.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteBlue Class
PerpetuumSoft.Charts Namespace


PaletteChemical Class

[image]

.NET ModelKit Suite ClassReference
PaletteChemical Class
Members See Also Send Feedback
Represents a palette which contains grey and green color tones.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PaletteChemical : ColoredPalette
Visual Basic (Declaration)
Public Class PaletteChemical _
    Inherits ColoredPalette
Visual C++
public ref class PaletteChemical : public ColoredPalette

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.Palette
PerpetuumSoft.Charts..::.SimplePalette
PerpetuumSoft.Charts..::.ColoredPalette
PerpetuumSoft.Charts..::.PaletteChemical

See Also

PaletteChemical Members
PerpetuumSoft.Charts Namespace


PaletteChemical Members

[image] [image]

.NET ModelKit Suite ClassReference
PaletteChemical Members
PaletteChemical Class Constructors Methods Events See Also Send Feedback

The PaletteChemical type exposes the following members.

Constructors

Name | Description
PaletteChemical | Initializes a new instance of the PaletteChemical class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Gets palette colors. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteChemical Class
PerpetuumSoft.Charts Namespace


PaletteChemical Constructor

[image]

.NET ModelKit Suite ClassReference
PaletteChemical Constructor
PaletteChemical Class See Also Send Feedback
Initializes a new instance of the PaletteChemical class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PaletteChemical()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaletteChemical()

See Also

PaletteChemical Class
PerpetuumSoft.Charts Namespace


PaletteChemical Methods

[image] [image]

.NET ModelKit Suite ClassReference
PaletteChemical Methods
PaletteChemical Class See Also Send Feedback

The PaletteChemical type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Gets palette colors. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaletteChemical Class
PerpetuumSoft.Charts Namespace


GetColors Method

[image]

.NET ModelKit Suite ClassReference
PaletteChemical..::.GetColors Method
PaletteChemical Class See Also Send Feedback
Gets palette colors.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override Color[] GetColors()
Visual Basic (Declaration)
Protected Overrides Function GetColors As Color()
Visual C++
protected:
virtual array<Color>^ GetColors() override

See Also

PaletteChemical Class
PerpetuumSoft.Charts Namespace


PaletteChemical Events

[image] [image]

.NET ModelKit Suite ClassReference
PaletteChemical Events
PaletteChemical Class See Also Send Feedback

The PaletteChemical type exposes the following members.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteChemical Class
PerpetuumSoft.Charts Namespace


PaletteCold Class

[image]

.NET ModelKit Suite ClassReference
PaletteCold Class
Members See Also Send Feedback
Represents palette that uses cold colors.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PaletteCold : ColoredPalette
Visual Basic (Declaration)
Public Class PaletteCold _
    Inherits ColoredPalette
Visual C++
public ref class PaletteCold : public ColoredPalette

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.Palette
PerpetuumSoft.Charts..::.SimplePalette
PerpetuumSoft.Charts..::.ColoredPalette
PerpetuumSoft.Charts..::.PaletteCold

See Also

PaletteCold Members
PerpetuumSoft.Charts Namespace


PaletteCold Members

[image] [image]

.NET ModelKit Suite ClassReference
PaletteCold Members
PaletteCold Class Constructors Methods Events See Also Send Feedback

The PaletteCold type exposes the following members.

Constructors

Name | Description
PaletteCold | Initializes a new instance of the PaletteCold class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Returns palette array of colors. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteCold Class
PerpetuumSoft.Charts Namespace


PaletteCold Constructor

[image]

.NET ModelKit Suite ClassReference
PaletteCold Constructor
PaletteCold Class See Also Send Feedback
Initializes a new instance of the PaletteCold class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PaletteCold()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaletteCold()

See Also

PaletteCold Class
PerpetuumSoft.Charts Namespace


PaletteCold Methods

[image] [image]

.NET ModelKit Suite ClassReference
PaletteCold Methods
PaletteCold Class See Also Send Feedback

The PaletteCold type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Returns palette array of colors. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaletteCold Class
PerpetuumSoft.Charts Namespace


GetColors Method

[image]

.NET ModelKit Suite ClassReference
PaletteCold..::.GetColors Method
PaletteCold Class See Also Send Feedback
Returns palette array of colors.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override Color[] GetColors()
Visual Basic (Declaration)
Protected Overrides Function GetColors As Color()
Visual C++
protected:
virtual array<Color>^ GetColors() override

See Also

PaletteCold Class
PerpetuumSoft.Charts Namespace


PaletteCold Events

[image] [image]

.NET ModelKit Suite ClassReference
PaletteCold Events
PaletteCold Class See Also Send Feedback

The PaletteCold type exposes the following members.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteCold Class
PerpetuumSoft.Charts Namespace


PaletteContrast Class

[image]

.NET ModelKit Suite ClassReference
PaletteContrast Class
Members See Also Send Feedback
Indicates palette for contrast painting of the series elements.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PaletteContrast : ColoredPalette
Visual Basic (Declaration)
Public Class PaletteContrast _
    Inherits ColoredPalette
Visual C++
public ref class PaletteContrast : public ColoredPalette

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.Palette
PerpetuumSoft.Charts..::.SimplePalette
PerpetuumSoft.Charts..::.ColoredPalette
PerpetuumSoft.Charts..::.PaletteContrast

See Also

PaletteContrast Members
PerpetuumSoft.Charts Namespace


PaletteContrast Members

[image] [image]

.NET ModelKit Suite ClassReference
PaletteContrast Members
PaletteContrast Class Constructors Methods Events See Also Send Feedback

The PaletteContrast type exposes the following members.

Constructors

Name | Description
PaletteContrast | Initializes a new instance of the PaletteContrast class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Returns the color. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteContrast Class
PerpetuumSoft.Charts Namespace


PaletteContrast Constructor

[image]

.NET ModelKit Suite ClassReference
PaletteContrast Constructor
PaletteContrast Class See Also Send Feedback
Initializes a new instance of the PaletteContrast class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PaletteContrast()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaletteContrast()

See Also

PaletteContrast Class
PerpetuumSoft.Charts Namespace


PaletteContrast Methods

[image] [image]

.NET ModelKit Suite ClassReference
PaletteContrast Methods
PaletteContrast Class See Also Send Feedback

The PaletteContrast type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Returns the color. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaletteContrast Class
PerpetuumSoft.Charts Namespace


GetColors Method

[image]

.NET ModelKit Suite ClassReference
PaletteContrast..::.GetColors Method
PaletteContrast Class See Also Send Feedback
Returns the color.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override Color[] GetColors()
Visual Basic (Declaration)
Protected Overrides Function GetColors As Color()
Visual C++
protected:
virtual array<Color>^ GetColors() override

See Also

PaletteContrast Class
PerpetuumSoft.Charts Namespace


PaletteContrast Events

[image] [image]

.NET ModelKit Suite ClassReference
PaletteContrast Events
PaletteContrast Class See Also Send Feedback

The PaletteContrast type exposes the following members.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteContrast Class
PerpetuumSoft.Charts Namespace


PaletteEmpty Class

[image]

.NET ModelKit Suite ClassReference
PaletteEmpty Class
Members See Also Send Feedback
Indicates empty palette for series elements.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PaletteEmpty : ColoredPalette
Visual Basic (Declaration)
Public Class PaletteEmpty _
    Inherits ColoredPalette
Visual C++
public ref class PaletteEmpty : public ColoredPalette

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.Palette
PerpetuumSoft.Charts..::.SimplePalette
PerpetuumSoft.Charts..::.ColoredPalette
PerpetuumSoft.Charts..::.PaletteEmpty

See Also

PaletteEmpty Members
PerpetuumSoft.Charts Namespace


PaletteEmpty Members

[image] [image]

.NET ModelKit Suite ClassReference
PaletteEmpty Members
PaletteEmpty Class Constructors Methods Events See Also Send Feedback

The PaletteEmpty type exposes the following members.

Constructors

Name | Description
PaletteEmpty | Initializes a new instance of the PaletteEmpty class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Returns the color. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteEmpty Class
PerpetuumSoft.Charts Namespace


PaletteEmpty Constructor

[image]

.NET ModelKit Suite ClassReference
PaletteEmpty Constructor
PaletteEmpty Class See Also Send Feedback
Initializes a new instance of the PaletteEmpty class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PaletteEmpty()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaletteEmpty()

See Also

PaletteEmpty Class
PerpetuumSoft.Charts Namespace


PaletteEmpty Methods

[image] [image]

.NET ModelKit Suite ClassReference
PaletteEmpty Methods
PaletteEmpty Class See Also Send Feedback

The PaletteEmpty type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Returns the color. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaletteEmpty Class
PerpetuumSoft.Charts Namespace


GetColors Method

[image]

.NET ModelKit Suite ClassReference
PaletteEmpty..::.GetColors Method
PaletteEmpty Class See Also Send Feedback
Returns the color.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override Color[] GetColors()
Visual Basic (Declaration)
Protected Overrides Function GetColors As Color()
Visual C++
protected:
virtual array<Color>^ GetColors() override

See Also

PaletteEmpty Class
PerpetuumSoft.Charts Namespace


PaletteEmpty Events

[image] [image]

.NET ModelKit Suite ClassReference
PaletteEmpty Events
PaletteEmpty Class See Also Send Feedback

The PaletteEmpty type exposes the following members.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteEmpty Class
PerpetuumSoft.Charts Namespace


PaletteGray Class

[image]

.NET ModelKit Suite ClassReference
PaletteGray Class
Members See Also Send Feedback
Indicates palette to paint series elements in gray.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PaletteGray : ColoredPalette
Visual Basic (Declaration)
Public Class PaletteGray _
    Inherits ColoredPalette
Visual C++
public ref class PaletteGray : public ColoredPalette

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.Palette
PerpetuumSoft.Charts..::.SimplePalette
PerpetuumSoft.Charts..::.ColoredPalette
PerpetuumSoft.Charts..::.PaletteGray

See Also

PaletteGray Members
PerpetuumSoft.Charts Namespace


PaletteGray Members

[image] [image]

.NET ModelKit Suite ClassReference
PaletteGray Members
PaletteGray Class Constructors Methods Events See Also Send Feedback

The PaletteGray type exposes the following members.

Constructors

Name | Description
PaletteGray | Initializes a new instance of the PaletteGray class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Returns the color. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteGray Class
PerpetuumSoft.Charts Namespace


PaletteGray Constructor

[image]

.NET ModelKit Suite ClassReference
PaletteGray Constructor
PaletteGray Class See Also Send Feedback
Initializes a new instance of the PaletteGray class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PaletteGray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaletteGray()

See Also

PaletteGray Class
PerpetuumSoft.Charts Namespace


PaletteGray Methods

[image] [image]

.NET ModelKit Suite ClassReference
PaletteGray Methods
PaletteGray Class See Also Send Feedback

The PaletteGray type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Returns the color. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaletteGray Class
PerpetuumSoft.Charts Namespace


GetColors Method

[image]

.NET ModelKit Suite ClassReference
PaletteGray..::.GetColors Method
PaletteGray Class See Also Send Feedback
Returns the color.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override Color[] GetColors()
Visual Basic (Declaration)
Protected Overrides Function GetColors As Color()
Visual C++
protected:
virtual array<Color>^ GetColors() override

See Also

PaletteGray Class
PerpetuumSoft.Charts Namespace


PaletteGray Events

[image] [image]

.NET ModelKit Suite ClassReference
PaletteGray Events
PaletteGray Class See Also Send Feedback

The PaletteGray type exposes the following members.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteGray Class
PerpetuumSoft.Charts Namespace


PaletteGreen Class

[image]

.NET ModelKit Suite ClassReference
PaletteGreen Class
Members See Also Send Feedback
Indicates palette to paint series elements in green.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PaletteGreen : ColoredPalette
Visual Basic (Declaration)
Public Class PaletteGreen _
    Inherits ColoredPalette
Visual C++
public ref class PaletteGreen : public ColoredPalette

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.Palette
PerpetuumSoft.Charts..::.SimplePalette
PerpetuumSoft.Charts..::.ColoredPalette
PerpetuumSoft.Charts..::.PaletteGreen

See Also

PaletteGreen Members
PerpetuumSoft.Charts Namespace


PaletteGreen Members

[image] [image]

.NET ModelKit Suite ClassReference
PaletteGreen Members
PaletteGreen Class Constructors Methods Events See Also Send Feedback

The PaletteGreen type exposes the following members.

Constructors

Name | Description
PaletteGreen | Initializes a new instance of the PaletteGreen class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Returns the color. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteGreen Class
PerpetuumSoft.Charts Namespace


PaletteGreen Constructor

[image]

.NET ModelKit Suite ClassReference
PaletteGreen Constructor
PaletteGreen Class See Also Send Feedback
Initializes a new instance of the PaletteGreen class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PaletteGreen()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaletteGreen()

See Also

PaletteGreen Class
PerpetuumSoft.Charts Namespace


PaletteGreen Methods

[image] [image]

.NET ModelKit Suite ClassReference
PaletteGreen Methods
PaletteGreen Class See Also Send Feedback

The PaletteGreen type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Returns the color. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaletteGreen Class
PerpetuumSoft.Charts Namespace


GetColors Method

[image]

.NET ModelKit Suite ClassReference
PaletteGreen..::.GetColors Method
PaletteGreen Class See Also Send Feedback
Returns the color.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override Color[] GetColors()
Visual Basic (Declaration)
Protected Overrides Function GetColors As Color()
Visual C++
protected:
virtual array<Color>^ GetColors() override

See Also

PaletteGreen Class
PerpetuumSoft.Charts Namespace


PaletteGreen Events

[image] [image]

.NET ModelKit Suite ClassReference
PaletteGreen Events
PaletteGreen Class See Also Send Feedback

The PaletteGreen type exposes the following members.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteGreen Class
PerpetuumSoft.Charts Namespace


PaletteHot Class

[image]

.NET ModelKit Suite ClassReference
PaletteHot Class
Members See Also Send Feedback
Represents palette that uses warm colors.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PaletteHot : ColoredPalette
Visual Basic (Declaration)
Public Class PaletteHot _
    Inherits ColoredPalette
Visual C++
public ref class PaletteHot : public ColoredPalette

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.Palette
PerpetuumSoft.Charts..::.SimplePalette
PerpetuumSoft.Charts..::.ColoredPalette
PerpetuumSoft.Charts..::.PaletteHot

See Also

PaletteHot Members
PerpetuumSoft.Charts Namespace


PaletteHot Members

[image] [image]

.NET ModelKit Suite ClassReference
PaletteHot Members
PaletteHot Class Constructors Methods Events See Also Send Feedback

The PaletteHot type exposes the following members.

Constructors

Name | Description
PaletteHot | Initializes a new instance of the PaletteHot class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Returns palette array of colors. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteHot Class
PerpetuumSoft.Charts Namespace


PaletteHot Constructor

[image]

.NET ModelKit Suite ClassReference
PaletteHot Constructor
PaletteHot Class See Also Send Feedback
Initializes a new instance of the PaletteHot class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PaletteHot()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaletteHot()

See Also

PaletteHot Class
PerpetuumSoft.Charts Namespace


PaletteHot Methods

[image] [image]

.NET ModelKit Suite ClassReference
PaletteHot Methods
PaletteHot Class See Also Send Feedback

The PaletteHot type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Returns palette array of colors. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaletteHot Class
PerpetuumSoft.Charts Namespace


GetColors Method

[image]

.NET ModelKit Suite ClassReference
PaletteHot..::.GetColors Method
PaletteHot Class See Also Send Feedback
Returns palette array of colors.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override Color[] GetColors()
Visual Basic (Declaration)
Protected Overrides Function GetColors As Color()
Visual C++
protected:
virtual array<Color>^ GetColors() override

See Also

PaletteHot Class
PerpetuumSoft.Charts Namespace


PaletteHot Events

[image] [image]

.NET ModelKit Suite ClassReference
PaletteHot Events
PaletteHot Class See Also Send Feedback

The PaletteHot type exposes the following members.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteHot Class
PerpetuumSoft.Charts Namespace


PaletteLightBlue Class

[image]

.NET ModelKit Suite ClassReference
PaletteLightBlue Class
Members See Also Send Feedback
Represents a palette which contains light blue color tones.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PaletteLightBlue : ColoredPalette
Visual Basic (Declaration)
Public Class PaletteLightBlue _
    Inherits ColoredPalette
Visual C++
public ref class PaletteLightBlue : public ColoredPalette

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.Palette
PerpetuumSoft.Charts..::.SimplePalette
PerpetuumSoft.Charts..::.ColoredPalette
PerpetuumSoft.Charts..::.PaletteLightBlue

See Also

PaletteLightBlue Members
PerpetuumSoft.Charts Namespace


PaletteLightBlue Members

[image] [image]

.NET ModelKit Suite ClassReference
PaletteLightBlue Members
PaletteLightBlue Class Constructors Methods Events See Also Send Feedback

The PaletteLightBlue type exposes the following members.

Constructors

Name | Description
PaletteLightBlue | Initializes a new instance of the PaletteLightBlue class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Gets palette colors. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteLightBlue Class
PerpetuumSoft.Charts Namespace


PaletteLightBlue Constructor

[image]

.NET ModelKit Suite ClassReference
PaletteLightBlue Constructor
PaletteLightBlue Class See Also Send Feedback
Initializes a new instance of the PaletteLightBlue class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PaletteLightBlue()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaletteLightBlue()

See Also

PaletteLightBlue Class
PerpetuumSoft.Charts Namespace


PaletteLightBlue Methods

[image] [image]

.NET ModelKit Suite ClassReference
PaletteLightBlue Methods
PaletteLightBlue Class See Also Send Feedback

The PaletteLightBlue type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Gets palette colors. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaletteLightBlue Class
PerpetuumSoft.Charts Namespace


GetColors Method

[image]

.NET ModelKit Suite ClassReference
PaletteLightBlue..::.GetColors Method
PaletteLightBlue Class See Also Send Feedback
Gets palette colors.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override Color[] GetColors()
Visual Basic (Declaration)
Protected Overrides Function GetColors As Color()
Visual C++
protected:
virtual array<Color>^ GetColors() override

See Also

PaletteLightBlue Class
PerpetuumSoft.Charts Namespace


PaletteLightBlue Events

[image] [image]

.NET ModelKit Suite ClassReference
PaletteLightBlue Events
PaletteLightBlue Class See Also Send Feedback

The PaletteLightBlue type exposes the following members.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteLightBlue Class
PerpetuumSoft.Charts Namespace


PaletteOrange Class

[image]

.NET ModelKit Suite ClassReference
PaletteOrange Class
Members See Also Send Feedback
Represents a palette which contains orange color tones.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PaletteOrange : ColoredPalette
Visual Basic (Declaration)
Public Class PaletteOrange _
    Inherits ColoredPalette
Visual C++
public ref class PaletteOrange : public ColoredPalette

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.Palette
PerpetuumSoft.Charts..::.SimplePalette
PerpetuumSoft.Charts..::.ColoredPalette
PerpetuumSoft.Charts..::.PaletteOrange

See Also

PaletteOrange Members
PerpetuumSoft.Charts Namespace


PaletteOrange Members

[image] [image]

.NET ModelKit Suite ClassReference
PaletteOrange Members
PaletteOrange Class Constructors Methods Events See Also Send Feedback

The PaletteOrange type exposes the following members.

Constructors

Name | Description
PaletteOrange | Initializes a new instance of the PaletteOrange class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Gets palette colors. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteOrange Class
PerpetuumSoft.Charts Namespace


PaletteOrange Constructor

[image]

.NET ModelKit Suite ClassReference
PaletteOrange Constructor
PaletteOrange Class See Also Send Feedback
Initializes a new instance of the PaletteOrange class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PaletteOrange()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaletteOrange()

See Also

PaletteOrange Class
PerpetuumSoft.Charts Namespace


PaletteOrange Methods

[image] [image]

.NET ModelKit Suite ClassReference
PaletteOrange Methods
PaletteOrange Class See Also Send Feedback

The PaletteOrange type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Gets palette colors. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaletteOrange Class
PerpetuumSoft.Charts Namespace


GetColors Method

[image]

.NET ModelKit Suite ClassReference
PaletteOrange..::.GetColors Method
PaletteOrange Class See Also Send Feedback
Gets palette colors.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override Color[] GetColors()
Visual Basic (Declaration)
Protected Overrides Function GetColors As Color()
Visual C++
protected:
virtual array<Color>^ GetColors() override

See Also

PaletteOrange Class
PerpetuumSoft.Charts Namespace


PaletteOrange Events

[image] [image]

.NET ModelKit Suite ClassReference
PaletteOrange Events
PaletteOrange Class See Also Send Feedback

The PaletteOrange type exposes the following members.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteOrange Class
PerpetuumSoft.Charts Namespace


PalettePurple Class

[image]

.NET ModelKit Suite ClassReference
PalettePurple Class
Members See Also Send Feedback
Represents a palette which contains purple color tones.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PalettePurple : ColoredPalette
Visual Basic (Declaration)
Public Class PalettePurple _
    Inherits ColoredPalette
Visual C++
public ref class PalettePurple : public ColoredPalette

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.Palette
PerpetuumSoft.Charts..::.SimplePalette
PerpetuumSoft.Charts..::.ColoredPalette
PerpetuumSoft.Charts..::.PalettePurple

See Also

PalettePurple Members
PerpetuumSoft.Charts Namespace


PalettePurple Members

[image] [image]

.NET ModelKit Suite ClassReference
PalettePurple Members
PalettePurple Class Constructors Methods Events See Also Send Feedback

The PalettePurple type exposes the following members.

Constructors

Name | Description
PalettePurple | Initializes a new instance of the PalettePurple class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Gets palette colors. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PalettePurple Class
PerpetuumSoft.Charts Namespace


PalettePurple Constructor

[image]

.NET ModelKit Suite ClassReference
PalettePurple Constructor
PalettePurple Class See Also Send Feedback
Initializes a new instance of the PalettePurple class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PalettePurple()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PalettePurple()

See Also

PalettePurple Class
PerpetuumSoft.Charts Namespace


PalettePurple Methods

[image] [image]

.NET ModelKit Suite ClassReference
PalettePurple Methods
PalettePurple Class See Also Send Feedback

The PalettePurple type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Gets palette colors. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PalettePurple Class
PerpetuumSoft.Charts Namespace


GetColors Method

[image]

.NET ModelKit Suite ClassReference
PalettePurple..::.GetColors Method
PalettePurple Class See Also Send Feedback
Gets palette colors.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override Color[] GetColors()
Visual Basic (Declaration)
Protected Overrides Function GetColors As Color()
Visual C++
protected:
virtual array<Color>^ GetColors() override

See Also

PalettePurple Class
PerpetuumSoft.Charts Namespace


PalettePurple Events

[image] [image]

.NET ModelKit Suite ClassReference
PalettePurple Events
PalettePurple Class See Also Send Feedback

The PalettePurple type exposes the following members.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PalettePurple Class
PerpetuumSoft.Charts Namespace


PaletteRainbow Class

[image]

.NET ModelKit Suite ClassReference
PaletteRainbow Class
Members See Also Send Feedback
Indicates palette to paint series elements in rainbow colors.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PaletteRainbow : ColoredPalette
Visual Basic (Declaration)
Public Class PaletteRainbow _
    Inherits ColoredPalette
Visual C++
public ref class PaletteRainbow : public ColoredPalette

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.Palette
PerpetuumSoft.Charts..::.SimplePalette
PerpetuumSoft.Charts..::.ColoredPalette
PerpetuumSoft.Charts..::.PaletteRainbow

See Also

PaletteRainbow Members
PerpetuumSoft.Charts Namespace


PaletteRainbow Members

[image] [image]

.NET ModelKit Suite ClassReference
PaletteRainbow Members
PaletteRainbow Class Constructors Methods Events See Also Send Feedback

The PaletteRainbow type exposes the following members.

Constructors

Name | Description
PaletteRainbow | Initializes a new instance of the PaletteRainbow class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Returns the color. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteRainbow Class
PerpetuumSoft.Charts Namespace


PaletteRainbow Constructor

[image]

.NET ModelKit Suite ClassReference
PaletteRainbow Constructor
PaletteRainbow Class See Also Send Feedback
Initializes a new instance of the PaletteRainbow class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PaletteRainbow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaletteRainbow()

See Also

PaletteRainbow Class
PerpetuumSoft.Charts Namespace


PaletteRainbow Methods

[image] [image]

.NET ModelKit Suite ClassReference
PaletteRainbow Methods
PaletteRainbow Class See Also Send Feedback

The PaletteRainbow type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Returns the color. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaletteRainbow Class
PerpetuumSoft.Charts Namespace


GetColors Method

[image]

.NET ModelKit Suite ClassReference
PaletteRainbow..::.GetColors Method
PaletteRainbow Class See Also Send Feedback
Returns the color.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override Color[] GetColors()
Visual Basic (Declaration)
Protected Overrides Function GetColors As Color()
Visual C++
protected:
virtual array<Color>^ GetColors() override

See Also

PaletteRainbow Class
PerpetuumSoft.Charts Namespace


PaletteRainbow Events

[image] [image]

.NET ModelKit Suite ClassReference
PaletteRainbow Events
PaletteRainbow Class See Also Send Feedback

The PaletteRainbow type exposes the following members.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteRainbow Class
PerpetuumSoft.Charts Namespace


PaletteRed Class

[image]

.NET ModelKit Suite ClassReference
PaletteRed Class
Members See Also Send Feedback
Indicates palette for painting series elements in red.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PaletteRed : ColoredPalette
Visual Basic (Declaration)
Public Class PaletteRed _
    Inherits ColoredPalette
Visual C++
public ref class PaletteRed : public ColoredPalette

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.Palette
PerpetuumSoft.Charts..::.SimplePalette
PerpetuumSoft.Charts..::.ColoredPalette
PerpetuumSoft.Charts..::.PaletteRed

See Also

PaletteRed Members
PerpetuumSoft.Charts Namespace


PaletteRed Members

[image] [image]

.NET ModelKit Suite ClassReference
PaletteRed Members
PaletteRed Class Constructors Methods Events See Also Send Feedback

The PaletteRed type exposes the following members.

Constructors

Name | Description
PaletteRed | Initializes a new instance of the PaletteRed class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Returns the color. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteRed Class
PerpetuumSoft.Charts Namespace


PaletteRed Constructor

[image]

.NET ModelKit Suite ClassReference
PaletteRed Constructor
PaletteRed Class See Also Send Feedback
Initializes a new instance of the PaletteRed class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PaletteRed()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaletteRed()

See Also

PaletteRed Class
PerpetuumSoft.Charts Namespace


PaletteRed Methods

[image] [image]

.NET ModelKit Suite ClassReference
PaletteRed Methods
PaletteRed Class See Also Send Feedback

The PaletteRed type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Returns the color. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaletteRed Class
PerpetuumSoft.Charts Namespace


GetColors Method

[image]

.NET ModelKit Suite ClassReference
PaletteRed..::.GetColors Method
PaletteRed Class See Also Send Feedback
Returns the color.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override Color[] GetColors()
Visual Basic (Declaration)
Protected Overrides Function GetColors As Color()
Visual C++
protected:
virtual array<Color>^ GetColors() override

See Also

PaletteRed Class
PerpetuumSoft.Charts Namespace


PaletteRed Events

[image] [image]

.NET ModelKit Suite ClassReference
PaletteRed Events
PaletteRed Class See Also Send Feedback

The PaletteRed type exposes the following members.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteRed Class
PerpetuumSoft.Charts Namespace


PaletteSunset Class

[image]

.NET ModelKit Suite ClassReference
PaletteSunset Class
Members See Also Send Feedback
Represents a palette which contains purple and orange color tones.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PaletteSunset : ColoredPalette
Visual Basic (Declaration)
Public Class PaletteSunset _
    Inherits ColoredPalette
Visual C++
public ref class PaletteSunset : public ColoredPalette

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.Palette
PerpetuumSoft.Charts..::.SimplePalette
PerpetuumSoft.Charts..::.ColoredPalette
PerpetuumSoft.Charts..::.PaletteSunset

See Also

PaletteSunset Members
PerpetuumSoft.Charts Namespace


PaletteSunset Members

[image] [image]

.NET ModelKit Suite ClassReference
PaletteSunset Members
PaletteSunset Class Constructors Methods Events See Also Send Feedback

The PaletteSunset type exposes the following members.

Constructors

Name | Description
PaletteSunset | Initializes a new instance of the PaletteSunset class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Gets palette colors. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteSunset Class
PerpetuumSoft.Charts Namespace


PaletteSunset Constructor

[image]

.NET ModelKit Suite ClassReference
PaletteSunset Constructor
PaletteSunset Class See Also Send Feedback
Initializes a new instance of the PaletteSunset class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PaletteSunset()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaletteSunset()

See Also

PaletteSunset Class
PerpetuumSoft.Charts Namespace


PaletteSunset Methods

[image] [image]

.NET ModelKit Suite ClassReference
PaletteSunset Methods
PaletteSunset Class See Also Send Feedback

The PaletteSunset type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Int32). (Inherited from ColoredPalette.)
GetColors | Gets palette colors. (Overrides ColoredPalette..::.GetColors()()().)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Inherited from SimplePalette.)
GetShape | Overridden. See GetShape(Int32). (Inherited from SimplePalette.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaletteSunset Class
PerpetuumSoft.Charts Namespace


GetColors Method

[image]

.NET ModelKit Suite ClassReference
PaletteSunset..::.GetColors Method
PaletteSunset Class See Also Send Feedback
Gets palette colors.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override Color[] GetColors()
Visual Basic (Declaration)
Protected Overrides Function GetColors As Color()
Visual C++
protected:
virtual array<Color>^ GetColors() override

See Also

PaletteSunset Class
PerpetuumSoft.Charts Namespace


PaletteSunset Events

[image] [image]

.NET ModelKit Suite ClassReference
PaletteSunset Events
PaletteSunset Class See Also Send Feedback

The PaletteSunset type exposes the following members.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

PaletteSunset Class
PerpetuumSoft.Charts Namespace


PieSeriesDrawingStyle Enumeration

[image]

.NET ModelKit Suite ClassReference
PieSeriesDrawingStyle Enumeration
See Also Send Feedback
Enumerates the series elements drawing effect types in the form of pie.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public enum PieSeriesDrawingStyle
Visual Basic (Declaration)
Public Enumeration PieSeriesDrawingStyle
Visual C++
public enum class PieSeriesDrawingStyle

Members

Member name | Description
None | Determines absence of the effect.
Concave | Determines the concavity effect.
SoftEdge | Determines the soft edge effect.

See Also

PerpetuumSoft.Charts Namespace


PieSeriesPlacingType Enumeration

[image]

.NET ModelKit Suite ClassReference
PieSeriesPlacingType Enumeration
See Also Send Feedback
Enumereates cross placing type of series which are presented by charts of the Pie type.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public enum PieSeriesPlacingType
Visual Basic (Declaration)
Public Enumeration PieSeriesPlacingType
Visual C++
public enum class PieSeriesPlacingType

Members

Member name | Description
Vertical | Specifies vertical position.
Horisontal | Specifies horizontal position.
Inside | Specifies the position inside each other.

See Also

PerpetuumSoft.Charts Namespace


PieSeriesValue Class

[image]

.NET ModelKit Suite ClassReference
PieSeriesValue Class
Members See Also Send Feedback
Indicates series values for the Pie series type.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PieSeriesValue : SeriesValue
Visual Basic (Declaration)
Public Class PieSeriesValue _
    Inherits SeriesValue
Visual C++
public ref class PieSeriesValue : public SeriesValue

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesValueBase
PerpetuumSoft.Charts..::.SeriesValue
PerpetuumSoft.Charts..::.PieSeriesValue

See Also

PieSeriesValue Members
PerpetuumSoft.Charts Namespace


PieSeriesValue Members

[image] [image]

.NET ModelKit Suite ClassReference
PieSeriesValue Members
PieSeriesValue Class Constructors Methods Properties See Also Send Feedback

The PieSeriesValue type exposes the following members.

Constructors

Name | Description
PieSeriesValue | Overloaded.

Methods

Name | Description
Clone | Overridden. See Clone()()(). (Overrides SeriesValue..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRepresentationObject | Overridden. See GetRepresentationObject()()(). (Inherited from SeriesValue.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueBounds | Overridden. See GetValueBounds()()(). (Inherited from SeriesValue.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sum | Overridden. See Sum(SeriesValueBase). (Inherited from SeriesValue.)
ToString | Overridden. See ToString()()(). (Inherited from SeriesValueBase.)

Properties

Name | Description
Argument | Gets or sets an argument. (Inherited from SeriesValueBase.)
Fill | Gets or sets the fill to paint the Pie segment.
Shift | Gets or sets the value that assigns shift range of a segment.
Sort | Gets or sets the sort expression value for series value. (Inherited from SeriesValueBase.)
UserData | Gets or sets additional data of the series value. (Inherited from SeriesValueBase.)
Value | Gets or sets series value. (Inherited from SeriesValue.)

See Also

PieSeriesValue Class
PerpetuumSoft.Charts Namespace


PieSeriesValue Constructor

[image] [image]

.NET ModelKit Suite ClassReference
PieSeriesValue Constructor
PieSeriesValue Class See Also Send Feedback

Overload List

Name | Description
PieSeriesValue()()() | Initializes a new instance of the PieSeriesValue class.
PieSeriesValue(Double, Double, Fill) | Initializes a new instance of the PieSeriesValue class.
PieSeriesValue(String, Double, Fill) | Initializes a new instance of the PieSeriesValue class.

See Also

PieSeriesValue Class
PieSeriesValue Members
PerpetuumSoft.Charts Namespace


PieSeriesValue Constructor

[image]

.NET ModelKit Suite ClassReference
PieSeriesValue Constructor
PieSeriesValue Class See Also Send Feedback
Initializes a new instance of the PieSeriesValue class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PieSeriesValue()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PieSeriesValue()

See Also

PieSeriesValue Class
PieSeriesValue Overload
PerpetuumSoft.Charts Namespace


PieSeriesValue Constructor (Double, Double, Fill)

[image]

.NET ModelKit Suite ClassReference
PieSeriesValue Constructor (Double, Double, Fill)
PieSeriesValue Class See Also Send Feedback
Initializes a new instance of the PieSeriesValue class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PieSeriesValue(
    double argument,
    double value,
    Fill fill
)
Visual Basic (Declaration)
Public Sub New ( _
    argument As Double, _
    value As Double, _
    fill As Fill _
)
Visual C++
public:
PieSeriesValue(
    double argument,
    double value,
    Fill^ fill
)

Parameters

argument
Type: System..::.Double
value
Type: System..::.Double
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill

See Also

PieSeriesValue Class
PieSeriesValue Overload
PerpetuumSoft.Charts Namespace


PieSeriesValue Constructor (String, Double, Fill)

[image]

.NET ModelKit Suite ClassReference
PieSeriesValue Constructor (String, Double, Fill)
PieSeriesValue Class See Also Send Feedback
Initializes a new instance of the PieSeriesValue class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PieSeriesValue(
    string argument,
    double value,
    Fill fill
)
Visual Basic (Declaration)
Public Sub New ( _
    argument As String, _
    value As Double, _
    fill As Fill _
)
Visual C++
public:
PieSeriesValue(
    String^ argument,
    double value,
    Fill^ fill
)

Parameters

argument
Type: System..::.String
value
Type: System..::.Double
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill

See Also

PieSeriesValue Class
PieSeriesValue Overload
PerpetuumSoft.Charts Namespace


PieSeriesValue Methods

[image] [image]

.NET ModelKit Suite ClassReference
PieSeriesValue Methods
PieSeriesValue Class See Also Send Feedback

The PieSeriesValue type exposes the following members.

Methods

Name | Description
Clone | Overridden. See Clone()()(). (Overrides SeriesValue..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRepresentationObject | Overridden. See GetRepresentationObject()()(). (Inherited from SeriesValue.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueBounds | Overridden. See GetValueBounds()()(). (Inherited from SeriesValue.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sum | Overridden. See Sum(SeriesValueBase). (Inherited from SeriesValue.)
ToString | Overridden. See ToString()()(). (Inherited from SeriesValueBase.)

See Also

PieSeriesValue Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
PieSeriesValue..::.Clone Method
PieSeriesValue Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesValueBase Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesValueBase
Visual C++
public:
virtual SeriesValueBase^ Clone() override

See Also

PieSeriesValue Class
PerpetuumSoft.Charts Namespace


PieSeriesValue Properties

[image] [image]

.NET ModelKit Suite ClassReference
PieSeriesValue Properties
PieSeriesValue Class See Also Send Feedback

The PieSeriesValue type exposes the following members.

Properties

Name | Description
Argument | Gets or sets an argument. (Inherited from SeriesValueBase.)
Fill | Gets or sets the fill to paint the Pie segment.
Shift | Gets or sets the value that assigns shift range of a segment.
Sort | Gets or sets the sort expression value for series value. (Inherited from SeriesValueBase.)
UserData | Gets or sets additional data of the series value. (Inherited from SeriesValueBase.)
Value | Gets or sets series value. (Inherited from SeriesValue.)

See Also

PieSeriesValue Class
PerpetuumSoft.Charts Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
PieSeriesValue..::.Fill Property
PieSeriesValue Class See Also Send Feedback
Gets or sets the fill to paint the Pie segment.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

PieSeriesValue Class
PerpetuumSoft.Charts Namespace


Shift Property

[image]

.NET ModelKit Suite ClassReference
PieSeriesValue..::.Shift Property
PieSeriesValue Class See Also Send Feedback
Gets or sets the value that assigns shift range of a segment.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double Shift { get; set; }
Visual Basic (Declaration)
Public Property Shift As Double
Visual C++
public:
property double Shift {
    double get ();
    void set (double value);
}

See Also

PieSeriesValue Class
PerpetuumSoft.Charts Namespace


PieSeriesView Class

[image]

.NET ModelKit Suite ClassReference
PieSeriesView Class
Members See Also Send Feedback
Defines series view to present series data in the form of the Pie.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PieSeriesView : SeriesView
Visual Basic (Declaration)
Public Class PieSeriesView _
    Inherits SeriesView
Visual C++
public ref class PieSeriesView : public SeriesView

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.PieSeriesView

See Also

PieSeriesView Members
PerpetuumSoft.Charts Namespace


PieSeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
PieSeriesView Members
PieSeriesView Class Constructors Methods Properties Events See Also Send Feedback

The PieSeriesView type exposes the following members.

Constructors

Name | Description
PieSeriesView | Initializes a new instance of the PieSeriesView class.

Methods

Name | Description
AddSeriesValueRingSector | Adds a RingSector that represents the specified series value.
ClearSeriesValueRingSectors | Clears the set of the series sectors.
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElements | Overridden. See CreateElements(ChartArea). (Overrides SeriesView..::.CreateElements(ChartArea).)
CreateElementsBySeries | Creates elements of the specified series by taking into account the specified area.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElementsBySeries | Returns element array that represents the specified series.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Overrides SeriesView..::.GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double).)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetRingSector | Returns a sector by taking into account the specified radius that represents the specified value.
GetRingSectorBySeriesValue | Returns a sector for the specified series value.
GetRingSectorCenter | Returns the center of the RingSector by taking into account the specified parameters.
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Overrides SeriesView..::.GetSeriesValueType()()().)
GetSideIndent | Overridden. See GetSideIndent()()(). (Overrides SeriesView..::.GetSideIndent()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Overrides SeriesView..::.GetValuePosition(SeriesValueBase, LabelsPosition).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Overrides SeriesView..::.PaintLegendBadge(GraphicStream, VectorRectangle).)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Overrides SeriesView..::.PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DrawingStyle | Gets or sets PieSeriesDrawingStyle which represents series elements drawing style.
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
InternalRadius | Gets or sets pie internal radius.
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Overrides SeriesView..::.IsValueLegendItemSupported.)
PlacingType | Gets or sets cross placing type of several pies for different series.
Radius | Gets or sets pie radius.
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
StartAngle | Gets or sets pie start angle.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


PieSeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
PieSeriesView Constructor
PieSeriesView Class See Also Send Feedback
Initializes a new instance of the PieSeriesView class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PieSeriesView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PieSeriesView()

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


PieSeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
PieSeriesView Methods
PieSeriesView Class See Also Send Feedback

The PieSeriesView type exposes the following members.

Methods

Name | Description
AddSeriesValueRingSector | Adds a RingSector that represents the specified series value.
ClearSeriesValueRingSectors | Clears the set of the series sectors.
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElements | Overridden. See CreateElements(ChartArea). (Overrides SeriesView..::.CreateElements(ChartArea).)
CreateElementsBySeries | Creates elements of the specified series by taking into account the specified area.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElementsBySeries | Returns element array that represents the specified series.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Overrides SeriesView..::.GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double).)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetRingSector | Returns a sector by taking into account the specified radius that represents the specified value.
GetRingSectorBySeriesValue | Returns a sector for the specified series value.
GetRingSectorCenter | Returns the center of the RingSector by taking into account the specified parameters.
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Overrides SeriesView..::.GetSeriesValueType()()().)
GetSideIndent | Overridden. See GetSideIndent()()(). (Overrides SeriesView..::.GetSideIndent()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Overrides SeriesView..::.GetValuePosition(SeriesValueBase, LabelsPosition).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Overrides SeriesView..::.PaintLegendBadge(GraphicStream, VectorRectangle).)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Overrides SeriesView..::.PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


AddSeriesValueRingSector Method

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.AddSeriesValueRingSector Method
PieSeriesView Class See Also Send Feedback
Adds a RingSector that represents the specified series value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected void AddSeriesValueRingSector(
    SeriesValueBase seriesValue,
    RingSector sector
)
Visual Basic (Declaration)
Protected Sub AddSeriesValueRingSector ( _
    seriesValue As SeriesValueBase, _
    sector As RingSector _
)
Visual C++
protected:
void AddSeriesValueRingSector(
    SeriesValueBase^ seriesValue,
    RingSector^ sector
)

Parameters

seriesValue
Type: PerpetuumSoft.Charts..::.SeriesValueBase
sector
Type: PerpetuumSoft.Instrumentation.Model..::.RingSector

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


ClearSeriesValueRingSectors Method

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.ClearSeriesValueRingSectors Method
PieSeriesView Class See Also Send Feedback
Clears the set of the series sectors.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected void ClearSeriesValueRingSectors()
Visual Basic (Declaration)
Protected Sub ClearSeriesValueRingSectors
Visual C++
protected:
void ClearSeriesValueRingSectors()

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.Clone Method
PieSeriesView Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesView Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesView
Visual C++
public:
virtual SeriesView^ Clone() override

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElements Method

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.CreateElements Method
PieSeriesView Class See Also Send Feedback
Overridden. See CreateElements(ChartArea).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void CreateElements(
    ChartArea area
)
Visual Basic (Declaration)
Public Overrides Sub CreateElements ( _
    area As ChartArea _
)
Visual C++
public:
virtual void CreateElements(
    ChartArea^ area
) override

Parameters

area
Type: PerpetuumSoft.Charts..::.ChartArea

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElementsBySeries Method

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.CreateElementsBySeries Method
PieSeriesView Class See Also Send Feedback
Creates elements of the specified series by taking into account the specified area.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected void CreateElementsBySeries(
    ChartPaintContext paintContext,
    Series series,
    VectorRectangle area
)
Visual Basic (Declaration)
Protected Sub CreateElementsBySeries ( _
    paintContext As ChartPaintContext, _
    series As Series, _
    area As VectorRectangle _
)
Visual C++
protected:
void CreateElementsBySeries(
    ChartPaintContext^ paintContext,
    Series^ series,
    VectorRectangle area
)

Parameters

paintContext
Type: PerpetuumSoft.Charts..::.ChartPaintContext
series
Type: PerpetuumSoft.Charts..::.Series
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


GetElementsBySeries Method

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.GetElementsBySeries Method
PieSeriesView Class See Also Send Feedback
Returns element array that represents the specified series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Element[] GetElementsBySeries(
    Series series,
    VectorRectangle area
)
Visual Basic (Declaration)
Protected Function GetElementsBySeries ( _
    series As Series, _
    area As VectorRectangle _
) As Element()
Visual C++
protected:
array<Element^>^ GetElementsBySeries(
    Series^ series,
    VectorRectangle area
)

Parameters

series
Type: PerpetuumSoft.Charts..::.Series
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


GetLabelPosition Method

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.GetLabelPosition Method
PieSeriesView Class See Also Send Feedback
Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Vector GetLabelPosition(
    SeriesValueBase seriesValue,
    LabelsPosition labelPosition,
    Vector itemSize,
    double distance
)
Visual Basic (Declaration)
Public Overrides Function GetLabelPosition ( _
    seriesValue As SeriesValueBase, _
    labelPosition As LabelsPosition, _
    itemSize As Vector, _
    distance As Double _
) As Vector
Visual C++
public:
virtual Vector GetLabelPosition(
    SeriesValueBase^ seriesValue,
    LabelsPosition labelPosition,
    Vector itemSize,
    double distance
) override

Parameters

seriesValue
Type: PerpetuumSoft.Charts..::.SeriesValueBase
labelPosition
Type: PerpetuumSoft.Charts..::.LabelsPosition
itemSize
Type: PerpetuumSoft.Framework.Drawing..::.Vector
distance
Type: System..::.Double

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


GetRingSector Method

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.GetRingSector Method
PieSeriesView Class See Also Send Feedback
Returns a sector by taking into account the specified radius that represents the specified value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected virtual RingSector GetRingSector(
    Vector center,
    double radius,
    double startAngle,
    double sweepAngle,
    SeriesValue seriesValue
)
Visual Basic (Declaration)
Protected Overridable Function GetRingSector ( _
    center As Vector, _
    radius As Double, _
    startAngle As Double, _
    sweepAngle As Double, _
    seriesValue As SeriesValue _
) As RingSector
Visual C++
protected:
virtual RingSector^ GetRingSector(
    Vector center,
    double radius,
    double startAngle,
    double sweepAngle,
    SeriesValue^ seriesValue
)

Parameters

center
Type: PerpetuumSoft.Framework.Drawing..::.Vector
radius
Type: System..::.Double
startAngle
Type: System..::.Double
sweepAngle
Type: System..::.Double
seriesValue
Type: PerpetuumSoft.Charts..::.SeriesValue

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


GetRingSectorBySeriesValue Method

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.GetRingSectorBySeriesValue Method
PieSeriesView Class See Also Send Feedback
Returns a sector for the specified series value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected RingSector GetRingSectorBySeriesValue(
    SeriesValueBase seriesValue
)
Visual Basic (Declaration)
Protected Function GetRingSectorBySeriesValue ( _
    seriesValue As SeriesValueBase _
) As RingSector
Visual C++
protected:
RingSector^ GetRingSectorBySeriesValue(
    SeriesValueBase^ seriesValue
)

Parameters

seriesValue
Type: PerpetuumSoft.Charts..::.SeriesValueBase

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


GetRingSectorCenter Method

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.GetRingSectorCenter Method
PieSeriesView Class See Also Send Feedback
Returns the center of the RingSector by taking into account the specified parameters.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected static Vector GetRingSectorCenter(
    Vector center,
    double radius,
    double startAngle,
    double sweepAngle,
    double shift
)
Visual Basic (Declaration)
Protected Shared Function GetRingSectorCenter ( _
    center As Vector, _
    radius As Double, _
    startAngle As Double, _
    sweepAngle As Double, _
    shift As Double _
) As Vector
Visual C++
protected:
static Vector GetRingSectorCenter(
    Vector center,
    double radius,
    double startAngle,
    double sweepAngle,
    double shift
)

Parameters

center
Type: PerpetuumSoft.Framework.Drawing..::.Vector
radius
Type: System..::.Double
startAngle
Type: System..::.Double
sweepAngle
Type: System..::.Double
shift
Type: System..::.Double

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.GetSeries Method
PieSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

PieSeriesView Class
PieSeriesView Members
PerpetuumSoft.Charts Namespace


GetSeriesValueType Method

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.GetSeriesValueType Method
PieSeriesView Class See Also Send Feedback
Overridden. See GetSeriesValueType()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Type GetSeriesValueType()
Visual Basic (Declaration)
Public Overrides Function GetSeriesValueType As Type
Visual C++
public:
virtual Type^ GetSeriesValueType() override

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


GetSideIndent Method

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.GetSideIndent Method
PieSeriesView Class See Also Send Feedback
Overridden. See GetSideIndent()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override double GetSideIndent()
Visual Basic (Declaration)
Public Overrides Function GetSideIndent As Double
Visual C++
public:
virtual double GetSideIndent() override

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


GetValuePosition Method

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.GetValuePosition Method
PieSeriesView Class See Also Send Feedback
Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Vector GetValuePosition(
    SeriesValueBase seriesValue,
    LabelsPosition labelPosition
)
Visual Basic (Declaration)
Public Overrides Function GetValuePosition ( _
    seriesValue As SeriesValueBase, _
    labelPosition As LabelsPosition _
) As Vector
Visual C++
public:
virtual Vector GetValuePosition(
    SeriesValueBase^ seriesValue,
    LabelsPosition labelPosition
) override

Parameters

seriesValue
Type: PerpetuumSoft.Charts..::.SeriesValueBase
labelPosition
Type: PerpetuumSoft.Charts..::.LabelsPosition

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


PaintLegendBadge Method

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.PaintLegendBadge Method
PieSeriesView Class See Also Send Feedback
Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintLegendBadge(
    GraphicStream graphicStream,
    VectorRectangle area
)
Visual Basic (Declaration)
Public Overrides Sub PaintLegendBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle _
)
Visual C++
public:
virtual void PaintLegendBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area
) override

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


PaintLegendValueBadge Method

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.PaintLegendValueBadge Method
PieSeriesView Class See Also Send Feedback
Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintLegendValueBadge(
    GraphicStream graphicStream,
    VectorRectangle area,
    int seriesValueIndex
)
Visual Basic (Declaration)
Public Overrides Sub PaintLegendValueBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle, _
    seriesValueIndex As Integer _
)
Visual C++
public:
virtual void PaintLegendValueBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area,
    int seriesValueIndex
) override

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
seriesValueIndex
Type: System..::.Int32

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


PieSeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
PieSeriesView Properties
PieSeriesView Class See Also Send Feedback

The PieSeriesView type exposes the following members.

Properties

Name | Description
DrawingStyle | Gets or sets PieSeriesDrawingStyle which represents series elements drawing style.
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
InternalRadius | Gets or sets pie internal radius.
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Overrides SeriesView..::.IsValueLegendItemSupported.)
PlacingType | Gets or sets cross placing type of several pies for different series.
Radius | Gets or sets pie radius.
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
StartAngle | Gets or sets pie start angle.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


DrawingStyle Property

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.DrawingStyle Property
PieSeriesView Class See Also Send Feedback
Gets or sets PieSeriesDrawingStyle which represents series elements drawing style.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PieSeriesDrawingStyle DrawingStyle { get; set; }
Visual Basic (Declaration)
Public Property DrawingStyle As PieSeriesDrawingStyle
Visual C++
public:
property PieSeriesDrawingStyle DrawingStyle {
    PieSeriesDrawingStyle get ();
    void set (PieSeriesDrawingStyle value);
}

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


InternalRadius Property

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.InternalRadius Property
PieSeriesView Class See Also Send Feedback
Gets or sets pie internal radius.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double InternalRadius { get; set; }
Visual Basic (Declaration)
Public Property InternalRadius As Double
Visual C++
public:
property double InternalRadius {
    double get ();
    void set (double value);
}

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


IsValueLegendItemSupported Property

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.IsValueLegendItemSupported Property
PieSeriesView Class See Also Send Feedback
Overridden. See IsValueLegendItemSupported.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValueLegendItemSupported { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsValueLegendItemSupported As Boolean
Visual C++
public:
virtual property bool IsValueLegendItemSupported {
    bool get () override;
}

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


PlacingType Property

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.PlacingType Property
PieSeriesView Class See Also Send Feedback
Gets or sets cross placing type of several pies for different series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PieSeriesPlacingType PlacingType { get; set; }
Visual Basic (Declaration)
Public Property PlacingType As PieSeriesPlacingType
Visual C++
public:
property PieSeriesPlacingType PlacingType {
    PieSeriesPlacingType get ();
    void set (PieSeriesPlacingType value);
}

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


Radius Property

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.Radius Property
PieSeriesView Class See Also Send Feedback
Gets or sets pie radius.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue Radius { get; set; }
Visual Basic (Declaration)
Public Property Radius As SmartValue
Visual C++
public:
property SmartValue Radius {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


StartAngle Property

[image]

.NET ModelKit Suite ClassReference
PieSeriesView..::.StartAngle Property
PieSeriesView Class See Also Send Feedback
Gets or sets pie start angle.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double StartAngle { get; set; }
Visual Basic (Declaration)
Public Property StartAngle As Double
Visual C++
public:
property double StartAngle {
    double get ();
    void set (double value);
}

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


PieSeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
PieSeriesView Events
PieSeriesView Class See Also Send Feedback

The PieSeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

PieSeriesView Class
PerpetuumSoft.Charts Namespace


PointSeriesDrawingStyle Enumeration

[image]

.NET ModelKit Suite ClassReference
PointSeriesDrawingStyle Enumeration
See Also Send Feedback
Enumerates the series elements drawing effect types in the form of points.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public enum PointSeriesDrawingStyle
Visual Basic (Declaration)
Public Enumeration PointSeriesDrawingStyle
Visual C++
public enum class PointSeriesDrawingStyle

Members

Member name | Description
None | Determines absence of the effect.
Concave | Determines the concavity effect.
SoftEdge | Determines the soft edge effect.

See Also

PerpetuumSoft.Charts Namespace


PointSeriesValue Class

[image]

.NET ModelKit Suite ClassReference
PointSeriesValue Class
Members See Also Send Feedback
Defines series data displaying in the form of points.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PointSeriesValue : SeriesValue
Visual Basic (Declaration)
Public Class PointSeriesValue _
    Inherits SeriesValue
Visual C++
public ref class PointSeriesValue : public SeriesValue

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesValueBase
PerpetuumSoft.Charts..::.SeriesValue
PerpetuumSoft.Charts..::.PointSeriesValue

See Also

PointSeriesValue Members
PerpetuumSoft.Charts Namespace


PointSeriesValue Members

[image] [image]

.NET ModelKit Suite ClassReference
PointSeriesValue Members
PointSeriesValue Class Constructors Methods Properties See Also Send Feedback

The PointSeriesValue type exposes the following members.

Constructors

Name | Description
PointSeriesValue | Overloaded.

Methods

Name | Description
Clone | Overridden. See Clone()()(). (Overrides SeriesValue..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRepresentationObject | Overridden. See GetRepresentationObject()()(). (Inherited from SeriesValue.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueBounds | Overridden. See GetValueBounds()()(). (Inherited from SeriesValue.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sum | Overridden. See Sum(SeriesValueBase). (Inherited from SeriesValue.)
ToString | Overridden. See ToString()()(). (Inherited from SeriesValueBase.)

Properties

Name | Description
Argument | Gets or sets an argument. (Inherited from SeriesValueBase.)
Radius | Gets or sets points radius.
Sort | Gets or sets the sort expression value for series value. (Inherited from SeriesValueBase.)
UserData | Gets or sets additional data of the series value. (Inherited from SeriesValueBase.)
Value | Gets or sets series value. (Inherited from SeriesValue.)

See Also

PointSeriesValue Class
PerpetuumSoft.Charts Namespace


PointSeriesValue Constructor

[image] [image]

.NET ModelKit Suite ClassReference
PointSeriesValue Constructor
PointSeriesValue Class See Also Send Feedback

Overload List

Name | Description
PointSeriesValue()()() | Initializes a new instance of the PointSeriesValue class.
PointSeriesValue(String, Double, Double) | Initializes a new instance of the PointSeriesValue class.

See Also

PointSeriesValue Class
PointSeriesValue Members
PerpetuumSoft.Charts Namespace


PointSeriesValue Constructor

[image]

.NET ModelKit Suite ClassReference
PointSeriesValue Constructor
PointSeriesValue Class See Also Send Feedback
Initializes a new instance of the PointSeriesValue class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PointSeriesValue()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PointSeriesValue()

See Also

PointSeriesValue Class
PointSeriesValue Overload
PerpetuumSoft.Charts Namespace


PointSeriesValue Constructor (String, Double, Double)

[image]

.NET ModelKit Suite ClassReference
PointSeriesValue Constructor (String, Double, Double)
PointSeriesValue Class See Also Send Feedback
Initializes a new instance of the PointSeriesValue class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PointSeriesValue(
    string argument,
    double value,
    double radius
)
Visual Basic (Declaration)
Public Sub New ( _
    argument As String, _
    value As Double, _
    radius As Double _
)
Visual C++
public:
PointSeriesValue(
    String^ argument,
    double value,
    double radius
)

Parameters

argument
Type: System..::.String
value
Type: System..::.Double
radius
Type: System..::.Double

See Also

PointSeriesValue Class
PointSeriesValue Overload
PerpetuumSoft.Charts Namespace


PointSeriesValue Methods

[image] [image]

.NET ModelKit Suite ClassReference
PointSeriesValue Methods
PointSeriesValue Class See Also Send Feedback

The PointSeriesValue type exposes the following members.

Methods

Name | Description
Clone | Overridden. See Clone()()(). (Overrides SeriesValue..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRepresentationObject | Overridden. See GetRepresentationObject()()(). (Inherited from SeriesValue.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueBounds | Overridden. See GetValueBounds()()(). (Inherited from SeriesValue.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sum | Overridden. See Sum(SeriesValueBase). (Inherited from SeriesValue.)
ToString | Overridden. See ToString()()(). (Inherited from SeriesValueBase.)

See Also

PointSeriesValue Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
PointSeriesValue..::.Clone Method
PointSeriesValue Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesValueBase Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesValueBase
Visual C++
public:
virtual SeriesValueBase^ Clone() override

See Also

PointSeriesValue Class
PerpetuumSoft.Charts Namespace


PointSeriesValue Properties

[image] [image]

.NET ModelKit Suite ClassReference
PointSeriesValue Properties
PointSeriesValue Class See Also Send Feedback

The PointSeriesValue type exposes the following members.

Properties

Name | Description
Argument | Gets or sets an argument. (Inherited from SeriesValueBase.)
Radius | Gets or sets points radius.
Sort | Gets or sets the sort expression value for series value. (Inherited from SeriesValueBase.)
UserData | Gets or sets additional data of the series value. (Inherited from SeriesValueBase.)
Value | Gets or sets series value. (Inherited from SeriesValue.)

See Also

PointSeriesValue Class
PerpetuumSoft.Charts Namespace


Radius Property

[image]

.NET ModelKit Suite ClassReference
PointSeriesValue..::.Radius Property
PointSeriesValue Class See Also Send Feedback
Gets or sets points radius.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double Radius { get; set; }
Visual Basic (Declaration)
Public Property Radius As Double
Visual C++
public:
property double Radius {
    double get ();
    void set (double value);
}

See Also

PointSeriesValue Class
PerpetuumSoft.Charts Namespace


PointSeriesView Class

[image]

.NET ModelKit Suite ClassReference
PointSeriesView Class
Members See Also Send Feedback
Defines series view to display series data in the form of points.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PointSeriesView : SimpleAxisSeriesView
Visual Basic (Declaration)
Public Class PointSeriesView _
    Inherits SimpleAxisSeriesView
Visual C++
public ref class PointSeriesView : public SimpleAxisSeriesView

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.SimpleAxisSeriesView
PerpetuumSoft.Charts..::.PointSeriesView

See Also

PointSeriesView Members
PerpetuumSoft.Charts Namespace


PointSeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
PointSeriesView Members
PointSeriesView Class Constructors Methods Properties Events See Also Send Feedback

The PointSeriesView type exposes the following members.

Constructors

Name | Description
PointSeriesView | Initializes a new instance of the PointSeriesView class.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates elements that represent a chart by the specified series. (Overrides SimpleAxisSeriesView..::.CreateElementsForSeries(Series).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElementAtValue | Returns an element that represents the specified series value by taking into account the specified minimum and maximum radiuses.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Overrides AxisSeriesView..::.GetSeriesValueType()()().)
GetSideIndent | Overridden. See GetSideIndent()()(). (Overrides SeriesView..::.GetSideIndent()()().)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Overrides SeriesView..::.PaintLegendBadge(GraphicStream, VectorRectangle).)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Overrides SeriesView..::.PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DrawingStyle | Gets or sets PointSeriesDrawingStyle which represents the series elements drawing style.
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Overrides SeriesView..::.IsValueLegendItemSupported.)
MaxRadius | Gets or sets maximum radius of the points.
MinRadius | Gets or sets minimum radius of the points.
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

PointSeriesView Class
PerpetuumSoft.Charts Namespace


PointSeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
PointSeriesView Constructor
PointSeriesView Class See Also Send Feedback
Initializes a new instance of the PointSeriesView class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PointSeriesView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PointSeriesView()

See Also

PointSeriesView Class
PerpetuumSoft.Charts Namespace


PointSeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
PointSeriesView Methods
PointSeriesView Class See Also Send Feedback

The PointSeriesView type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates elements that represent a chart by the specified series. (Overrides SimpleAxisSeriesView..::.CreateElementsForSeries(Series).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElementAtValue | Returns an element that represents the specified series value by taking into account the specified minimum and maximum radiuses.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Overrides AxisSeriesView..::.GetSeriesValueType()()().)
GetSideIndent | Overridden. See GetSideIndent()()(). (Overrides SeriesView..::.GetSideIndent()()().)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Overrides SeriesView..::.PaintLegendBadge(GraphicStream, VectorRectangle).)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Overrides SeriesView..::.PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointSeriesView Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
PointSeriesView..::.Clone Method
PointSeriesView Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesView Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesView
Visual C++
public:
virtual SeriesView^ Clone() override

See Also

PointSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElementsForSeries Method

[image]

.NET ModelKit Suite ClassReference
PointSeriesView..::.CreateElementsForSeries Method
PointSeriesView Class See Also Send Feedback
Creates elements that represent a chart by the specified series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void CreateElementsForSeries(
    Series series
)
Visual Basic (Declaration)
Protected Overrides Sub CreateElementsForSeries ( _
    series As Series _
)
Visual C++
protected:
virtual void CreateElementsForSeries(
    Series^ series
) override

Parameters

series
Type: PerpetuumSoft.Charts..::.Series

See Also

PointSeriesView Class
PerpetuumSoft.Charts Namespace


GetElementAtValue Method

[image]

.NET ModelKit Suite ClassReference
PointSeriesView..::.GetElementAtValue Method
PointSeriesView Class See Also Send Feedback
Returns an element that represents the specified series value by taking into account the specified minimum and maximum radiuses.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected virtual Element GetElementAtValue(
    Series series,
    SeriesValue seriesValue,
    double k,
    double minRadius
)
Visual Basic (Declaration)
Protected Overridable Function GetElementAtValue ( _
    series As Series, _
    seriesValue As SeriesValue, _
    k As Double, _
    minRadius As Double _
) As Element
Visual C++
protected:
virtual Element^ GetElementAtValue(
    Series^ series,
    SeriesValue^ seriesValue,
    double k,
    double minRadius
)

Parameters

series
Type: PerpetuumSoft.Charts..::.Series
seriesValue
Type: PerpetuumSoft.Charts..::.SeriesValue
k
Type: System..::.Double
minRadius
Type: System..::.Double

See Also

PointSeriesView Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
PointSeriesView..::.GetSeries Method
PointSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

PointSeriesView Class
PointSeriesView Members
PerpetuumSoft.Charts Namespace


GetSeriesValueType Method

[image]

.NET ModelKit Suite ClassReference
PointSeriesView..::.GetSeriesValueType Method
PointSeriesView Class See Also Send Feedback
Overridden. See GetSeriesValueType()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Type GetSeriesValueType()
Visual Basic (Declaration)
Public Overrides Function GetSeriesValueType As Type
Visual C++
public:
virtual Type^ GetSeriesValueType() override

See Also

PointSeriesView Class
PerpetuumSoft.Charts Namespace


GetSideIndent Method

[image]

.NET ModelKit Suite ClassReference
PointSeriesView..::.GetSideIndent Method
PointSeriesView Class See Also Send Feedback
Overridden. See GetSideIndent()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override double GetSideIndent()
Visual Basic (Declaration)
Public Overrides Function GetSideIndent As Double
Visual C++
public:
virtual double GetSideIndent() override

See Also

PointSeriesView Class
PerpetuumSoft.Charts Namespace


PaintLegendBadge Method

[image]

.NET ModelKit Suite ClassReference
PointSeriesView..::.PaintLegendBadge Method
PointSeriesView Class See Also Send Feedback
Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintLegendBadge(
    GraphicStream graphicStream,
    VectorRectangle area
)
Visual Basic (Declaration)
Public Overrides Sub PaintLegendBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle _
)
Visual C++
public:
virtual void PaintLegendBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area
) override

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

PointSeriesView Class
PerpetuumSoft.Charts Namespace


PaintLegendValueBadge Method

[image]

.NET ModelKit Suite ClassReference
PointSeriesView..::.PaintLegendValueBadge Method
PointSeriesView Class See Also Send Feedback
Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintLegendValueBadge(
    GraphicStream graphicStream,
    VectorRectangle area,
    int seriesValueIndex
)
Visual Basic (Declaration)
Public Overrides Sub PaintLegendValueBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle, _
    seriesValueIndex As Integer _
)
Visual C++
public:
virtual void PaintLegendValueBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area,
    int seriesValueIndex
) override

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
seriesValueIndex
Type: System..::.Int32

See Also

PointSeriesView Class
PerpetuumSoft.Charts Namespace


PointSeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
PointSeriesView Properties
PointSeriesView Class See Also Send Feedback

The PointSeriesView type exposes the following members.

Properties

Name | Description
DrawingStyle | Gets or sets PointSeriesDrawingStyle which represents the series elements drawing style.
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Overrides SeriesView..::.IsValueLegendItemSupported.)
MaxRadius | Gets or sets maximum radius of the points.
MinRadius | Gets or sets minimum radius of the points.
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

See Also

PointSeriesView Class
PerpetuumSoft.Charts Namespace


DrawingStyle Property

[image]

.NET ModelKit Suite ClassReference
PointSeriesView..::.DrawingStyle Property
PointSeriesView Class See Also Send Feedback
Gets or sets PointSeriesDrawingStyle which represents the series elements drawing style.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PointSeriesDrawingStyle DrawingStyle { get; set; }
Visual Basic (Declaration)
Public Property DrawingStyle As PointSeriesDrawingStyle
Visual C++
public:
property PointSeriesDrawingStyle DrawingStyle {
    PointSeriesDrawingStyle get ();
    void set (PointSeriesDrawingStyle value);
}

See Also

PointSeriesView Class
PerpetuumSoft.Charts Namespace


IsValueLegendItemSupported Property

[image]

.NET ModelKit Suite ClassReference
PointSeriesView..::.IsValueLegendItemSupported Property
PointSeriesView Class See Also Send Feedback
Overridden. See IsValueLegendItemSupported.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValueLegendItemSupported { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsValueLegendItemSupported As Boolean
Visual C++
public:
virtual property bool IsValueLegendItemSupported {
    bool get () override;
}

See Also

PointSeriesView Class
PerpetuumSoft.Charts Namespace


MaxRadius Property

[image]

.NET ModelKit Suite ClassReference
PointSeriesView..::.MaxRadius Property
PointSeriesView Class See Also Send Feedback
Gets or sets maximum radius of the points.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue MaxRadius { get; set; }
Visual Basic (Declaration)
Public Property MaxRadius As SmartValue
Visual C++
public:
property SmartValue MaxRadius {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

PointSeriesView Class
PerpetuumSoft.Charts Namespace


MinRadius Property

[image]

.NET ModelKit Suite ClassReference
PointSeriesView..::.MinRadius Property
PointSeriesView Class See Also Send Feedback
Gets or sets minimum radius of the points.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue MinRadius { get; set; }
Visual Basic (Declaration)
Public Property MinRadius As SmartValue
Visual C++
public:
property SmartValue MinRadius {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

PointSeriesView Class
PerpetuumSoft.Charts Namespace


PointSeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
PointSeriesView Events
PointSeriesView Class See Also Send Feedback

The PointSeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

PointSeriesView Class
PerpetuumSoft.Charts Namespace


PolygonElement Class

[image]

.NET ModelKit Suite ClassReference
PolygonElement Class
Members See Also Send Feedback
Defines the Polygon element.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PolygonElement : Element
Visual Basic (Declaration)
Public Class PolygonElement _
    Inherits Element
Visual C++
public ref class PolygonElement : public Element

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Charts..::.PolygonElement

See Also

PolygonElement Members
PerpetuumSoft.Charts Namespace


PolygonElement Members

[image] [image]

.NET ModelKit Suite ClassReference
PolygonElement Members
PolygonElement Class Constructors Methods Properties Events See Also Send Feedback

The PolygonElement type exposes the following members.

Constructors

Name | Description
PolygonElement | Overloaded.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

PolygonElement Class
PerpetuumSoft.Charts Namespace


PolygonElement Constructor

[image] [image]

.NET ModelKit Suite ClassReference
PolygonElement Constructor
PolygonElement Class See Also Send Feedback

Overload List

Name | Description
PolygonElement()()() | Initializes a new instance of the PolygonElement class.
PolygonElement(array<Vector>[]()[]) | Initializes a new instance of the PolygonElement class.

See Also

PolygonElement Class
PolygonElement Members
PerpetuumSoft.Charts Namespace


PolygonElement Constructor

[image]

.NET ModelKit Suite ClassReference
PolygonElement Constructor
PolygonElement Class See Also Send Feedback
Initializes a new instance of the PolygonElement class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PolygonElement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PolygonElement()

See Also

PolygonElement Class
PolygonElement Overload
PerpetuumSoft.Charts Namespace


PolygonElement Constructor (Vector[])

[image]

.NET ModelKit Suite ClassReference
PolygonElement Constructor (array<Vector>[]()[])
PolygonElement Class See Also Send Feedback
Initializes a new instance of the PolygonElement class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PolygonElement(
    Vector[] points
)
Visual Basic (Declaration)
Public Sub New ( _
    points As Vector() _
)
Visual C++
public:
PolygonElement(
    array<Vector>^ points
)

Parameters

points
Type: array< PerpetuumSoft.Framework.Drawing..::.Vector >[]()[]

See Also

PolygonElement Class
PolygonElement Overload
PerpetuumSoft.Charts Namespace


PolygonElement Methods

[image] [image]

.NET ModelKit Suite ClassReference
PolygonElement Methods
PolygonElement Class See Also Send Feedback

The PolygonElement type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PolygonElement Class
PerpetuumSoft.Charts Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
PolygonElement..::.Dispose Method
PolygonElement Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

PolygonElement Class
PolygonElement Members
PerpetuumSoft.Charts Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
PolygonElement..::.GetBoundedBox Method
PolygonElement Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

PolygonElement Class
PerpetuumSoft.Charts Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
PolygonElement..::.GetHitTest Method
PolygonElement Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

PolygonElement Class
PerpetuumSoft.Charts Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
PolygonElement..::.GetStyle Method
PolygonElement Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

PolygonElement Class
PolygonElement Members
PerpetuumSoft.Charts Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
PolygonElement..::.Invalidate Method
PolygonElement Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

PolygonElement Class
PolygonElement Members
PerpetuumSoft.Charts Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
PolygonElement..::.OnPaint Method
PolygonElement Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

PolygonElement Class
PolygonElement Members
PerpetuumSoft.Charts Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
PolygonElement..::.OnPaint Method (PaintArguments, Fill, Stroke)
PolygonElement Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

PolygonElement Class
OnPaint Overload
PerpetuumSoft.Charts Namespace


PolygonElement Properties

[image] [image]

.NET ModelKit Suite ClassReference
PolygonElement Properties
PolygonElement Class See Also Send Feedback

The PolygonElement type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

PolygonElement Class
PerpetuumSoft.Charts Namespace


PolygonElement Events

[image] [image]

.NET ModelKit Suite ClassReference
PolygonElement Events
PolygonElement Class See Also Send Feedback

The PolygonElement type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

PolygonElement Class
PerpetuumSoft.Charts Namespace


PolylineElement Class

[image]

.NET ModelKit Suite ClassReference
PolylineElement Class
Members See Also Send Feedback
Defines the PolyLine element.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PolylineElement : Element
Visual Basic (Declaration)
Public Class PolylineElement _
    Inherits Element
Visual C++
public ref class PolylineElement : public Element

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Charts..::.PolylineElement

See Also

PolylineElement Members
PerpetuumSoft.Charts Namespace


PolylineElement Members

[image] [image]

.NET ModelKit Suite ClassReference
PolylineElement Members
PolylineElement Class Constructors Methods Properties Events See Also Send Feedback

The PolylineElement type exposes the following members.

Constructors

Name | Description
PolylineElement | Overloaded.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsIncludePoint | Returns a value that indicates whether the specified point is included into the area outlined by this line.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

PolylineElement Class
PerpetuumSoft.Charts Namespace


PolylineElement Constructor

[image] [image]

.NET ModelKit Suite ClassReference
PolylineElement Constructor
PolylineElement Class See Also Send Feedback

Overload List

Name | Description
PolylineElement()()() | Initializes a new instance of the PolylineElement class.
PolylineElement(array<Vector>[]()[]) | Initializes a new instance of the PolylineElement class.

See Also

PolylineElement Class
PolylineElement Members
PerpetuumSoft.Charts Namespace


PolylineElement Constructor

[image]

.NET ModelKit Suite ClassReference
PolylineElement Constructor
PolylineElement Class See Also Send Feedback
Initializes a new instance of the PolylineElement class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PolylineElement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PolylineElement()

See Also

PolylineElement Class
PolylineElement Overload
PerpetuumSoft.Charts Namespace


PolylineElement Constructor (Vector[])

[image]

.NET ModelKit Suite ClassReference
PolylineElement Constructor (array<Vector>[]()[])
PolylineElement Class See Also Send Feedback
Initializes a new instance of the PolylineElement class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PolylineElement(
    Vector[] points
)
Visual Basic (Declaration)
Public Sub New ( _
    points As Vector() _
)
Visual C++
public:
PolylineElement(
    array<Vector>^ points
)

Parameters

points
Type: array< PerpetuumSoft.Framework.Drawing..::.Vector >[]()[]

See Also

PolylineElement Class
PolylineElement Overload
PerpetuumSoft.Charts Namespace


PolylineElement Methods

[image] [image]

.NET ModelKit Suite ClassReference
PolylineElement Methods
PolylineElement Class See Also Send Feedback

The PolylineElement type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsIncludePoint | Returns a value that indicates whether the specified point is included into the area outlined by this line.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PolylineElement Class
PerpetuumSoft.Charts Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
PolylineElement..::.Dispose Method
PolylineElement Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

PolylineElement Class
PolylineElement Members
PerpetuumSoft.Charts Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
PolylineElement..::.GetBoundedBox Method
PolylineElement Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

PolylineElement Class
PerpetuumSoft.Charts Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
PolylineElement..::.GetHitTest Method
PolylineElement Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

PolylineElement Class
PerpetuumSoft.Charts Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
PolylineElement..::.GetStyle Method
PolylineElement Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

PolylineElement Class
PolylineElement Members
PerpetuumSoft.Charts Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
PolylineElement..::.Invalidate Method
PolylineElement Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

PolylineElement Class
PolylineElement Members
PerpetuumSoft.Charts Namespace


IsIncludePoint Method

[image]

.NET ModelKit Suite ClassReference
PolylineElement..::.IsIncludePoint Method
PolylineElement Class See Also Send Feedback
Returns a value that indicates whether the specified point is included into the area outlined by this line.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected bool IsIncludePoint(
    Vector point,
    Vector startPoint,
    Vector endPoint
)
Visual Basic (Declaration)
Protected Function IsIncludePoint ( _
    point As Vector, _
    startPoint As Vector, _
    endPoint As Vector _
) As Boolean
Visual C++
protected:
bool IsIncludePoint(
    Vector point,
    Vector startPoint,
    Vector endPoint
)

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector
startPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
endPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

PolylineElement Class
PerpetuumSoft.Charts Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
PolylineElement..::.OnPaint Method
PolylineElement Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

PolylineElement Class
PolylineElement Members
PerpetuumSoft.Charts Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
PolylineElement..::.OnPaint Method (PaintArguments, Fill, Stroke)
PolylineElement Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

PolylineElement Class
OnPaint Overload
PerpetuumSoft.Charts Namespace


PolylineElement Properties

[image] [image]

.NET ModelKit Suite ClassReference
PolylineElement Properties
PolylineElement Class See Also Send Feedback

The PolylineElement type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

PolylineElement Class
PerpetuumSoft.Charts Namespace


PolylineElement Events

[image] [image]

.NET ModelKit Suite ClassReference
PolylineElement Events
PolylineElement Class See Also Send Feedback

The PolylineElement type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

PolylineElement Class
PerpetuumSoft.Charts Namespace


PseudoBar Class

[image]

.NET ModelKit Suite ClassReference
PseudoBar Class
Members See Also Send Feedback
Represents a chart element in the form of the pseudo 3D parallelepiped.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PseudoBar : PseudoElement
Visual Basic (Declaration)
Public Class PseudoBar _
    Inherits PseudoElement
Visual C++
public ref class PseudoBar : public PseudoElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Charts..::.PseudoElement
PerpetuumSoft.Charts..::.PseudoBar

See Also

PseudoBar Members
PerpetuumSoft.Charts Namespace


PseudoBar Members

[image] [image]

.NET ModelKit Suite ClassReference
PseudoBar Members
PseudoBar Class Constructors Methods Properties Events See Also Send Feedback

The PseudoBar type exposes the following members.

Constructors

Name | Description
PseudoBar | Overloaded.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetModifiedColor | Overloaded.
GetModifiedStroke | Returns the Stroke that is created by the specified lines type and coefficient. (Inherited from PseudoElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Area | Gets or sets an area occupied by an element. (Inherited from PseudoElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Color | Gets or sets element's color. (Inherited from PseudoElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets element's fill. (Inherited from PseudoElement.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

PseudoBar Class
PerpetuumSoft.Charts Namespace


PseudoBar Constructor

[image] [image]

.NET ModelKit Suite ClassReference
PseudoBar Constructor
PseudoBar Class See Also Send Feedback

Overload List

Name | Description
PseudoBar()()() | Initializes a new instance of the PseudoBar class.
PseudoBar(VectorRectangle, Color, Double, Double) | Initializes a new instance of the PseudoBar class.

See Also

PseudoBar Class
PseudoBar Members
PerpetuumSoft.Charts Namespace


PseudoBar Constructor

[image]

.NET ModelKit Suite ClassReference
PseudoBar Constructor
PseudoBar Class See Also Send Feedback
Initializes a new instance of the PseudoBar class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PseudoBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PseudoBar()

See Also

PseudoBar Class
PseudoBar Overload
PerpetuumSoft.Charts Namespace


PseudoBar Constructor (VectorRectangle, Color, Double, Double)

[image]

.NET ModelKit Suite ClassReference
PseudoBar Constructor (VectorRectangle, Color, Double, Double)
PseudoBar Class See Also Send Feedback
Initializes a new instance of the PseudoBar class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PseudoBar(
    VectorRectangle area,
    Color color,
    double horisontalShift,
    double verticalShift
)
Visual Basic (Declaration)
Public Sub New ( _
    area As VectorRectangle, _
    color As Color, _
    horisontalShift As Double, _
    verticalShift As Double _
)
Visual C++
public:
PseudoBar(
    VectorRectangle area,
    Color color,
    double horisontalShift,
    double verticalShift
)

Parameters

area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
color
Type: System.Drawing..::.Color
horisontalShift
Type: System..::.Double
verticalShift
Type: System..::.Double

See Also

PseudoBar Class
PseudoBar Overload
PerpetuumSoft.Charts Namespace


PseudoBar Methods

[image] [image]

.NET ModelKit Suite ClassReference
PseudoBar Methods
PseudoBar Class See Also Send Feedback

The PseudoBar type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetModifiedColor | Overloaded.
GetModifiedStroke | Returns the Stroke that is created by the specified lines type and coefficient. (Inherited from PseudoElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PseudoBar Class
PerpetuumSoft.Charts Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
PseudoBar..::.Dispose Method
PseudoBar Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

PseudoBar Class
PseudoBar Members
PerpetuumSoft.Charts Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
PseudoBar..::.GetHitTest Method
PseudoBar Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

PseudoBar Class
PerpetuumSoft.Charts Namespace


GetModifiedColor Method

[image] [image]

.NET ModelKit Suite ClassReference
PseudoBar..::.GetModifiedColor Method
PseudoBar Class See Also Send Feedback

Overload List

Name | Description
GetModifiedColor(Fill, Double) | Returns color that is created by the specified color and coefficient. (Inherited from PseudoElement.)
GetModifiedColor(Color, Double) | Returns color that is created by the specified fill and coefficient. (Inherited from PseudoElement.)

See Also

PseudoBar Class
PseudoBar Members
PerpetuumSoft.Charts Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
PseudoBar..::.GetStyle Method
PseudoBar Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

PseudoBar Class
PseudoBar Members
PerpetuumSoft.Charts Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
PseudoBar..::.Invalidate Method
PseudoBar Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

PseudoBar Class
PseudoBar Members
PerpetuumSoft.Charts Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
PseudoBar..::.OnPaint Method
PseudoBar Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

PseudoBar Class
PseudoBar Members
PerpetuumSoft.Charts Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
PseudoBar..::.OnPaint Method (PaintArguments, Fill, Stroke)
PseudoBar Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

PseudoBar Class
OnPaint Overload
PerpetuumSoft.Charts Namespace


PseudoBar Properties

[image] [image]

.NET ModelKit Suite ClassReference
PseudoBar Properties
PseudoBar Class See Also Send Feedback

The PseudoBar type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Area | Gets or sets an area occupied by an element. (Inherited from PseudoElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Color | Gets or sets element's color. (Inherited from PseudoElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets element's fill. (Inherited from PseudoElement.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

PseudoBar Class
PerpetuumSoft.Charts Namespace


PseudoBar Events

[image] [image]

.NET ModelKit Suite ClassReference
PseudoBar Events
PseudoBar Class See Also Send Feedback

The PseudoBar type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

PseudoBar Class
PerpetuumSoft.Charts Namespace


PseudoCylinder Class

[image]

.NET ModelKit Suite ClassReference
PseudoCylinder Class
Members See Also Send Feedback
Represents a chart element in the form of the pseudo 3D cylinder.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class PseudoCylinder : PseudoElement
Visual Basic (Declaration)
Public Class PseudoCylinder _
    Inherits PseudoElement
Visual C++
public ref class PseudoCylinder : public PseudoElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Charts..::.PseudoElement
PerpetuumSoft.Charts..::.PseudoCylinder

See Also

PseudoCylinder Members
PerpetuumSoft.Charts Namespace


PseudoCylinder Members

[image] [image]

.NET ModelKit Suite ClassReference
PseudoCylinder Members
PseudoCylinder Class Constructors Methods Properties Events See Also Send Feedback

The PseudoCylinder type exposes the following members.

Constructors

Name | Description
PseudoCylinder | Overloaded.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetModifiedColor | Overloaded.
GetModifiedStroke | Returns the Stroke that is created by the specified lines type and coefficient. (Inherited from PseudoElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Area | Gets or sets an area occupied by an element. (Inherited from PseudoElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Color | Gets or sets element's color. (Inherited from PseudoElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets element's fill. (Inherited from PseudoElement.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
IsVertical | Gets or sets a value that indicates whether the cylinder is palced vertically.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

PseudoCylinder Class
PerpetuumSoft.Charts Namespace


PseudoCylinder Constructor

[image] [image]

.NET ModelKit Suite ClassReference
PseudoCylinder Constructor
PseudoCylinder Class See Also Send Feedback

Overload List

Name | Description
PseudoCylinder()()() | Initializes a new instance of the PseudoCylinder class.
PseudoCylinder(VectorRectangle, Color, Boolean) | Initializes a new instance of the PseudoCylinder class.

See Also

PseudoCylinder Class
PseudoCylinder Members
PerpetuumSoft.Charts Namespace


PseudoCylinder Constructor

[image]

.NET ModelKit Suite ClassReference
PseudoCylinder Constructor
PseudoCylinder Class See Also Send Feedback
Initializes a new instance of the PseudoCylinder class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PseudoCylinder()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PseudoCylinder()

See Also

PseudoCylinder Class
PseudoCylinder Overload
PerpetuumSoft.Charts Namespace


PseudoCylinder Constructor (VectorRectangle, Color, Boolean)

[image]

.NET ModelKit Suite ClassReference
PseudoCylinder Constructor (VectorRectangle, Color, Boolean)
PseudoCylinder Class See Also Send Feedback
Initializes a new instance of the PseudoCylinder class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public PseudoCylinder(
    VectorRectangle area,
    Color color,
    bool isVertical
)
Visual Basic (Declaration)
Public Sub New ( _
    area As VectorRectangle, _
    color As Color, _
    isVertical As Boolean _
)
Visual C++
public:
PseudoCylinder(
    VectorRectangle area,
    Color color,
    bool isVertical
)

Parameters

area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
color
Type: System.Drawing..::.Color
isVertical
Type: System..::.Boolean

See Also

PseudoCylinder Class
PseudoCylinder Overload
PerpetuumSoft.Charts Namespace


PseudoCylinder Methods

[image] [image]

.NET ModelKit Suite ClassReference
PseudoCylinder Methods
PseudoCylinder Class See Also Send Feedback

The PseudoCylinder type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetModifiedColor | Overloaded.
GetModifiedStroke | Returns the Stroke that is created by the specified lines type and coefficient. (Inherited from PseudoElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PseudoCylinder Class
PerpetuumSoft.Charts Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
PseudoCylinder..::.Dispose Method
PseudoCylinder Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

PseudoCylinder Class
PseudoCylinder Members
PerpetuumSoft.Charts Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
PseudoCylinder..::.GetHitTest Method
PseudoCylinder Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

PseudoCylinder Class
PerpetuumSoft.Charts Namespace


GetModifiedColor Method

[image] [image]

.NET ModelKit Suite ClassReference
PseudoCylinder..::.GetModifiedColor Method
PseudoCylinder Class See Also Send Feedback

Overload List

Name | Description
GetModifiedColor(Fill, Double) | Returns color that is created by the specified color and coefficient. (Inherited from PseudoElement.)
GetModifiedColor(Color, Double) | Returns color that is created by the specified fill and coefficient. (Inherited from PseudoElement.)

See Also

PseudoCylinder Class
PseudoCylinder Members
PerpetuumSoft.Charts Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
PseudoCylinder..::.GetStyle Method
PseudoCylinder Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

PseudoCylinder Class
PseudoCylinder Members
PerpetuumSoft.Charts Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
PseudoCylinder..::.Invalidate Method
PseudoCylinder Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

PseudoCylinder Class
PseudoCylinder Members
PerpetuumSoft.Charts Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
PseudoCylinder..::.OnPaint Method
PseudoCylinder Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

PseudoCylinder Class
PseudoCylinder Members
PerpetuumSoft.Charts Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
PseudoCylinder..::.OnPaint Method (PaintArguments, Fill, Stroke)
PseudoCylinder Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

PseudoCylinder Class
OnPaint Overload
PerpetuumSoft.Charts Namespace


PseudoCylinder Properties

[image] [image]

.NET ModelKit Suite ClassReference
PseudoCylinder Properties
PseudoCylinder Class See Also Send Feedback

The PseudoCylinder type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Area | Gets or sets an area occupied by an element. (Inherited from PseudoElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Color | Gets or sets element's color. (Inherited from PseudoElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets element's fill. (Inherited from PseudoElement.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
IsVertical | Gets or sets a value that indicates whether the cylinder is palced vertically.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

PseudoCylinder Class
PerpetuumSoft.Charts Namespace


IsVertical Property

[image]

.NET ModelKit Suite ClassReference
PseudoCylinder..::.IsVertical Property
PseudoCylinder Class See Also Send Feedback
Gets or sets a value that indicates whether the cylinder is palced vertically.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool IsVertical { get; set; }
Visual Basic (Declaration)
Public Property IsVertical As Boolean
Visual C++
public:
property bool IsVertical {
    bool get ();
    void set (bool value);
}

See Also

PseudoCylinder Class
PerpetuumSoft.Charts Namespace


PseudoCylinder Events

[image] [image]

.NET ModelKit Suite ClassReference
PseudoCylinder Events
PseudoCylinder Class See Also Send Feedback

The PseudoCylinder type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

PseudoCylinder Class
PerpetuumSoft.Charts Namespace


PseudoElement Class

[image]

.NET ModelKit Suite ClassReference
PseudoElement Class
Members See Also Send Feedback
Represents a base class for pseudo 3D chart elements.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract class PseudoElement : Element
Visual Basic (Declaration)
Public MustInherit Class PseudoElement _
    Inherits Element
Visual C++
public ref class PseudoElement abstract : public Element

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Charts..::.PseudoElement
PerpetuumSoft.Charts..::.PseudoBar
PerpetuumSoft.Charts..::.PseudoCylinder

See Also

PseudoElement Members
PerpetuumSoft.Charts Namespace


PseudoElement Members

[image] [image]

.NET ModelKit Suite ClassReference
PseudoElement Members
PseudoElement Class Constructors Methods Properties Events See Also Send Feedback

The PseudoElement type exposes the following members.

Constructors

Name | Description
PseudoElement | Initializes a new instance of the PseudoElement class

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetModifiedColor | Overloaded.
GetModifiedStroke | Returns the Stroke that is created by the specified lines type and coefficient.
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Area | Gets or sets an area occupied by an element.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Color | Gets or sets element's color.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets element's fill.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

PseudoElement Class
PerpetuumSoft.Charts Namespace


PseudoElement Constructor

[image]

.NET ModelKit Suite ClassReference
PseudoElement Constructor
PseudoElement Class See Also Send Feedback
Initializes a new instance of the PseudoElement class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected PseudoElement()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
PseudoElement()

See Also

PseudoElement Class
PerpetuumSoft.Charts Namespace


PseudoElement Methods

[image] [image]

.NET ModelKit Suite ClassReference
PseudoElement Methods
PseudoElement Class See Also Send Feedback

The PseudoElement type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetModifiedColor | Overloaded.
GetModifiedStroke | Returns the Stroke that is created by the specified lines type and coefficient.
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PseudoElement Class
PerpetuumSoft.Charts Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
PseudoElement..::.Dispose Method
PseudoElement Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

PseudoElement Class
PseudoElement Members
PerpetuumSoft.Charts Namespace


GetModifiedColor Method

[image] [image]

.NET ModelKit Suite ClassReference
PseudoElement..::.GetModifiedColor Method
PseudoElement Class See Also Send Feedback

Overload List

Name | Description
GetModifiedColor(Fill, Double) | Returns color that is created by the specified color and coefficient.
GetModifiedColor(Color, Double) | Returns color that is created by the specified fill and coefficient.

See Also

PseudoElement Class
PseudoElement Members
PerpetuumSoft.Charts Namespace


GetModifiedColor Method (Fill, Double)

[image]

.NET ModelKit Suite ClassReference
PseudoElement..::.GetModifiedColor Method (Fill, Double)
PseudoElement Class See Also Send Feedback
Returns color that is created by the specified color and coefficient.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Color GetModifiedColor(
    Fill fill,
    double k
)
Visual Basic (Declaration)
Protected Function GetModifiedColor ( _
    fill As Fill, _
    k As Double _
) As Color
Visual C++
protected:
Color GetModifiedColor(
    Fill^ fill,
    double k
)

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
k
Type: System..::.Double

See Also

PseudoElement Class
GetModifiedColor Overload
PerpetuumSoft.Charts Namespace


GetModifiedColor Method (Color, Double)

[image]

.NET ModelKit Suite ClassReference
PseudoElement..::.GetModifiedColor Method (Color, Double)
PseudoElement Class See Also Send Feedback
Returns color that is created by the specified fill and coefficient.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Color GetModifiedColor(
    Color color,
    double k
)
Visual Basic (Declaration)
Protected Function GetModifiedColor ( _
    color As Color, _
    k As Double _
) As Color
Visual C++
protected:
Color GetModifiedColor(
    Color color,
    double k
)

Parameters

color
Type: System.Drawing..::.Color
k
Type: System..::.Double

See Also

PseudoElement Class
GetModifiedColor Overload
PerpetuumSoft.Charts Namespace


GetModifiedStroke Method

[image]

.NET ModelKit Suite ClassReference
PseudoElement..::.GetModifiedStroke Method
PseudoElement Class See Also Send Feedback
Returns the Stroke that is created by the specified lines type and coefficient.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Stroke GetModifiedStroke(
    Stroke stroke,
    double k
)
Visual Basic (Declaration)
Protected Function GetModifiedStroke ( _
    stroke As Stroke, _
    k As Double _
) As Stroke
Visual C++
protected:
Stroke^ GetModifiedStroke(
    Stroke^ stroke,
    double k
)

Parameters

stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
k
Type: System..::.Double

See Also

PseudoElement Class
PerpetuumSoft.Charts Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
PseudoElement..::.GetStyle Method
PseudoElement Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

PseudoElement Class
PseudoElement Members
PerpetuumSoft.Charts Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
PseudoElement..::.Invalidate Method
PseudoElement Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

PseudoElement Class
PseudoElement Members
PerpetuumSoft.Charts Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
PseudoElement..::.OnPaint Method
PseudoElement Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

PseudoElement Class
PseudoElement Members
PerpetuumSoft.Charts Namespace


PseudoElement Properties

[image] [image]

.NET ModelKit Suite ClassReference
PseudoElement Properties
PseudoElement Class See Also Send Feedback

The PseudoElement type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Area | Gets or sets an area occupied by an element.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Color | Gets or sets element's color.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets element's fill.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

PseudoElement Class
PerpetuumSoft.Charts Namespace


Area Property

[image]

.NET ModelKit Suite ClassReference
PseudoElement..::.Area Property
PseudoElement Class See Also Send Feedback
Gets or sets an area occupied by an element.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle Area { get; set; }
Visual Basic (Declaration)
Public Property Area As VectorRectangle
Visual C++
public:
property VectorRectangle Area {
    VectorRectangle get ();
    void set (VectorRectangle value);
}

See Also

PseudoElement Class
PerpetuumSoft.Charts Namespace


Color Property

[image]

.NET ModelKit Suite ClassReference
PseudoElement..::.Color Property
PseudoElement Class See Also Send Feedback
Gets or sets element's color.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

PseudoElement Class
PerpetuumSoft.Charts Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
PseudoElement..::.Fill Property
PseudoElement Class See Also Send Feedback
Gets or sets element's fill.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

PseudoElement Class
PerpetuumSoft.Charts Namespace


PseudoElement Events

[image] [image]

.NET ModelKit Suite ClassReference
PseudoElement Events
PseudoElement Class See Also Send Feedback

The PseudoElement type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

PseudoElement Class
PerpetuumSoft.Charts Namespace


RectangleComposite Class

[image]

.NET ModelKit Suite ClassReference
RectangleComposite Class
Members See Also Send Feedback
Represents a rectangle as a composite element; a base class for the composite elements with the rectangular area.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract class RectangleComposite : Composite
Visual Basic (Declaration)
Public MustInherit Class RectangleComposite _
    Inherits Composite
Visual C++
public ref class RectangleComposite abstract : public Composite

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.Composite
PerpetuumSoft.Charts..::.RectangleComposite
PerpetuumSoft.Charts..::.ChartArea

See Also

RectangleComposite Members
PerpetuumSoft.Charts Namespace


RectangleComposite Members

[image] [image]

.NET ModelKit Suite ClassReference
RectangleComposite Members
RectangleComposite Class Constructors Methods Properties Events See Also Send Feedback

The RectangleComposite type exposes the following members.

Constructors

Name | Description
RectangleComposite | Initializes a new instance of the RectangleComposite class

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
DrawContent | Paints content of the rectabgular area.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Overrides Composite..::.GetElementAt(Vector).)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Bounds | Gets or sets bounds of the area occupied by an element.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle.
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets the size of the rectangle.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

RectangleComposite Class
PerpetuumSoft.Charts Namespace


RectangleComposite Constructor

[image]

.NET ModelKit Suite ClassReference
RectangleComposite Constructor
RectangleComposite Class See Also Send Feedback
Initializes a new instance of the RectangleComposite class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected RectangleComposite()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
RectangleComposite()

See Also

RectangleComposite Class
PerpetuumSoft.Charts Namespace


RectangleComposite Methods

[image] [image]

.NET ModelKit Suite ClassReference
RectangleComposite Methods
RectangleComposite Class See Also Send Feedback

The RectangleComposite type exposes the following members.

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
DrawContent | Paints content of the rectabgular area.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Overrides Composite..::.GetElementAt(Vector).)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RectangleComposite Class
PerpetuumSoft.Charts Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
RectangleComposite..::.Dispose Method
RectangleComposite Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from Composite.)

See Also

RectangleComposite Class
RectangleComposite Members
PerpetuumSoft.Charts Namespace


DrawContent Method

[image]

.NET ModelKit Suite ClassReference
RectangleComposite..::.DrawContent Method
RectangleComposite Class See Also Send Feedback
Paints content of the rectabgular area.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void DrawContent(
    PaintArguments args
)
Visual Basic (Declaration)
Protected Overridable Sub DrawContent ( _
    args As PaintArguments _
)
Visual C++
protected:
virtual void DrawContent(
    PaintArguments^ args
)

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

RectangleComposite Class
PerpetuumSoft.Charts Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
RectangleComposite..::.GetBoundedBox Method
RectangleComposite Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

RectangleComposite Class
PerpetuumSoft.Charts Namespace


GetElementAt Method

[image]

.NET ModelKit Suite ClassReference
RectangleComposite..::.GetElementAt Method
RectangleComposite Class See Also Send Feedback
Implements GetElementAt(Vector).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override IElement GetElementAt(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetElementAt ( _
    point As Vector _
) As IElement
Visual C++
public:
virtual IElement^ GetElementAt(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

Implements

IElement..::.GetElementAt(Vector)
IElement..::.GetElementAt(Vector)

See Also

RectangleComposite Class
PerpetuumSoft.Charts Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
RectangleComposite..::.GetStyle Method
RectangleComposite Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

RectangleComposite Class
RectangleComposite Members
PerpetuumSoft.Charts Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
RectangleComposite..::.Invalidate Method
RectangleComposite Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

RectangleComposite Class
RectangleComposite Members
PerpetuumSoft.Charts Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
RectangleComposite..::.OnPaint Method
RectangleComposite Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Overrides Composite..::.OnPaint(PaintArguments).)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

RectangleComposite Class
RectangleComposite Members
PerpetuumSoft.Charts Namespace


OnPaint Method (PaintArguments)

[image]

.NET ModelKit Suite ClassReference
RectangleComposite..::.OnPaint Method (PaintArguments)
RectangleComposite Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

RectangleComposite Class
OnPaint Overload
PerpetuumSoft.Charts Namespace


RectangleComposite Properties

[image] [image]

.NET ModelKit Suite ClassReference
RectangleComposite Properties
RectangleComposite Class See Also Send Feedback

The RectangleComposite type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Bounds | Gets or sets bounds of the area occupied by an element.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle.
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets the size of the rectangle.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

RectangleComposite Class
PerpetuumSoft.Charts Namespace


Bounds Property

[image]

.NET ModelKit Suite ClassReference
RectangleComposite..::.Bounds Property
RectangleComposite Class See Also Send Feedback
Gets or sets bounds of the area occupied by an element.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle Bounds { get; set; }
Visual Basic (Declaration)
Public Property Bounds As VectorRectangle
Visual C++
public:
property VectorRectangle Bounds {
    VectorRectangle get ();
    void set (VectorRectangle value);
}

See Also

RectangleComposite Class
PerpetuumSoft.Charts Namespace


Center Property

[image]

.NET ModelKit Suite ClassReference
RectangleComposite..::.Center Property
RectangleComposite Class See Also Send Feedback
Gets or sets the center of the rectangle.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Vector Center { get; set; }
Visual Basic (Declaration)
Public Property Center As Vector
Visual C++
public:
property Vector Center {
    Vector get ();
    void set (Vector value);
}

See Also

RectangleComposite Class
PerpetuumSoft.Charts Namespace


Size Property

[image]

.NET ModelKit Suite ClassReference
RectangleComposite..::.Size Property
RectangleComposite Class See Also Send Feedback
Gets or sets the size of the rectangle.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Vector Size { get; set; }
Visual Basic (Declaration)
Public Property Size As Vector
Visual C++
public:
property Vector Size {
    Vector get ();
    void set (Vector value);
}

See Also

RectangleComposite Class
PerpetuumSoft.Charts Namespace


RectangleComposite Events

[image] [image]

.NET ModelKit Suite ClassReference
RectangleComposite Events
RectangleComposite Class See Also Send Feedback

The RectangleComposite type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

RectangleComposite Class
PerpetuumSoft.Charts Namespace


ReductionValue Enumeration

[image]

.NET ModelKit Suite ClassReference
ReductionValue Enumeration
See Also Send Feedback
Represents values by which the reduction of the financial series values is specified.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public enum ReductionValue
Visual Basic (Declaration)
Public Enumeration ReductionValue
Visual C++
public enum class ReductionValue

Members

Member name | Description
Hi | Indicates that the reduction of the series values is determined by the Hi field.
Lo | Indicates that the reduction of the series values is determined by the Lo field.
Open | Indicates that the reduction of the series values is determined by the Open field.
Close | Indicates that the reduction of the series values is determined by the Close field.

See Also

PerpetuumSoft.Charts Namespace


ScaleType Enumeration

[image]

.NET ModelKit Suite ClassReference
ScaleType Enumeration
See Also Send Feedback
Enumerates scale types.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public enum ScaleType
Visual Basic (Declaration)
Public Enumeration ScaleType
Visual C++
public enum class ScaleType

Members

Member name | Description
Numerical | Corresponds to the numerical scale type.
Qualitative | Corresponds to the discrete scale type.

See Also

PerpetuumSoft.Charts Namespace


Segment Structure

[image]

.NET ModelKit Suite ClassReference
Segment Structure
Members See Also Send Feedback
Defines line segment.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public struct Segment
Visual Basic (Declaration)
Public Structure Segment
Visual C++
public value class Segment

See Also

Segment Members
PerpetuumSoft.Charts Namespace


Segment Members

[image] [image]

.NET ModelKit Suite ClassReference
Segment Members
Segment Structure Constructors Methods Properties See Also Send Feedback

The Segment type exposes the following members.

Constructors

Name | Description
Segment | Initializes a new instance of the Segment class.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
CenterPoint | Gets the center point of a segment.
Empty | Gets an empty segment.
EndPoint | Gets the end point of a segment.
IsEmpty | Gets a value that indicates that the segment is empty.
StartPoint | Gets the start point of a segment.

See Also

Segment Structure
PerpetuumSoft.Charts Namespace


Segment Constructor

[image]

.NET ModelKit Suite ClassReference
Segment Constructor
Segment Structure See Also Send Feedback
Initializes a new instance of the Segment class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Segment(
    Vector startPoint,
    Vector endPoint
)
Visual Basic (Declaration)
Public Sub New ( _
    startPoint As Vector, _
    endPoint As Vector _
)
Visual C++
public:
Segment(
    Vector startPoint,
    Vector endPoint
)

Parameters

startPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
endPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Segment Structure
PerpetuumSoft.Charts Namespace


Segment Methods

[image] [image]

.NET ModelKit Suite ClassReference
Segment Methods
Segment Structure See Also Send Feedback

The Segment type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Segment Structure
PerpetuumSoft.Charts Namespace


Segment Properties

[image] [image]

.NET ModelKit Suite ClassReference
Segment Properties
Segment Structure See Also Send Feedback

The Segment type exposes the following members.

Properties

Name | Description
CenterPoint | Gets the center point of a segment.
Empty | Gets an empty segment.
EndPoint | Gets the end point of a segment.
IsEmpty | Gets a value that indicates that the segment is empty.
StartPoint | Gets the start point of a segment.

See Also

Segment Structure
PerpetuumSoft.Charts Namespace


CenterPoint Property

[image]

.NET ModelKit Suite ClassReference
Segment..::.CenterPoint Property
Segment Structure See Also Send Feedback
Gets the center point of a segment.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Vector CenterPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property CenterPoint As Vector
Visual C++
public:
property Vector CenterPoint {
    Vector get ();
}

See Also

Segment Structure
PerpetuumSoft.Charts Namespace


Empty Property

[image]

.NET ModelKit Suite ClassReference
Segment..::.Empty Property
Segment Structure See Also Send Feedback
Gets an empty segment.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public static Segment Empty { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Empty As Segment
Visual C++
public:
static property Segment Empty {
    Segment get ();
}

See Also

Segment Structure
PerpetuumSoft.Charts Namespace


EndPoint Property

[image]

.NET ModelKit Suite ClassReference
Segment..::.EndPoint Property
Segment Structure See Also Send Feedback
Gets the end point of a segment.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Vector EndPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndPoint As Vector
Visual C++
public:
property Vector EndPoint {
    Vector get ();
}

See Also

Segment Structure
PerpetuumSoft.Charts Namespace


IsEmpty Property

[image]

.NET ModelKit Suite ClassReference
Segment..::.IsEmpty Property
Segment Structure See Also Send Feedback
Gets a value that indicates that the segment is empty.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

Segment Structure
PerpetuumSoft.Charts Namespace


StartPoint Property

[image]

.NET ModelKit Suite ClassReference
Segment..::.StartPoint Property
Segment Structure See Also Send Feedback
Gets the start point of a segment.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Vector StartPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartPoint As Vector
Visual C++
public:
property Vector StartPoint {
    Vector get ();
}

See Also

Segment Structure
PerpetuumSoft.Charts Namespace


Series Class

[image]

.NET ModelKit Suite ClassReference
Series Class
Members See Also Send Feedback
Represents chart series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class Series : SeriesBase, IDataReceiver
Visual Basic (Declaration)
Public Class Series _
    Inherits SeriesBase _
    Implements IDataReceiver
Visual C++
public ref class Series : public SeriesBase,
    IDataReceiver

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.Composite
PerpetuumSoft.Charts..::.ChartComposite
PerpetuumSoft.Charts..::.SeriesBase
PerpetuumSoft.Charts..::.Series

See Also

Series Members
PerpetuumSoft.Charts Namespace


Series Members

[image] [image]

.NET ModelKit Suite ClassReference
Series Members
Series Class Constructors Methods Properties Events See Also Send Feedback

The Series type exposes the following members.

Constructors

Name | Description
Series | Initializes a new instance of the Series class.

Methods

Name | Description
AddElement | Adds an element to a collection of elements which represent series chart.
AddElements | Adds elements array to the collection of elements which represent series chart.
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
ClearElements | Clears the collection of elements which represent series chart.
DataSourceChanged | Implements DataSourceChanged()()().
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetArgumentByIndex | Returns an argument of the series value with the corresponding index.
GetArgumentBySeriesValue | Returns an argument of the specified series value.
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetDataSource | Returns a series data source.
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetElementAtLayer | Implements GetElementAtLayer(Vector, ChartLayer). (Inherited from ChartComposite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetPaletteColor | (Inherited from SeriesBase.)
GetPaletteFill | (Inherited from SeriesBase.)
GetPaletteStroke | (Inherited from SeriesBase.)
GetSeries | Overridden. See GetSeries()()(). (Overrides SeriesBase..::.GetSeries()()().)
GetSimpleBounds | Returns the bounds for the axis of the specified type.
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnDataPropertiesChanged | Occurs after the data in the source have been changed. (Inherited from SeriesBase.)
OnFillChanged | Occurs after the Fill property has been changed. (Inherited from SeriesBase.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Occurs after the Stroke property has been changed. (Inherited from SeriesBase.)
OnStyleChanged | Occurs after the Style property has been changed. (Overrides Element..::.OnStyleChanged()()().)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLayer | Implements PaintLayer(PaintArguments, ChartLayer). (Inherited from ChartComposite.)
PaintSelf | Overridden. See PaintSelf(PaintArguments). (Overrides ChartComposite..::.PaintSelf(PaintArguments).)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetAxes | Recalculates the range of the axes specified in series. (Inherited from SeriesBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
ArgumentAxis | Gets or sets axis arguments. (Inherited from SeriesBase.)
AutoArgument | Gets or sets a value that shows that arguments values will be automatically generated.
Bindings | Gets SeriesBindingCollection list of correspondences between data fields for a series and fields in a data source.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Caption | Gets or sets series caption.
ChartArea | Gets ChartArea in which this series is placed. (Inherited from SeriesBase.)
DataMember | Gets or sets a data source field name for nested series.
DataSource | Gets or sets a data source name for a series.
DefaultLayer | Overridden. See DefaultLayer. (Overrides ChartComposite..::.DefaultLayer.)
DisplayingInLegendType | Gets or sets DisplayingInLegendType which assigns what should be displayed in a legend. (Inherited from SeriesBase.)
Elements | Implements Elements. (Inherited from Composite.)
Error | Gets or sets an error from which the data calculation for series has been terminated.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
LegendExpression | Gets or sets expressions to calculate values displayed in a legend. (Inherited from SeriesBase.)
Name | Gets or sets the element's name. (Inherited from Element.)
Palette | Gets or sets a palette to color series elements. (Inherited from SeriesBase.)
PaletteIndex | Gets or sets palette index. (Inherited from SeriesBase.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets a value that indicates that the expressions for all elements should be recalculated. (Inherited from SeriesBase.)
ScaleType | Gets or sets a value that defines scale type. (Inherited from SeriesBase.)
SeriesSortingType | Gets or sets sorting type of series.
SeriesSplitter | Gets or sets a data source field name by values of which the data will be split into separate series.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Sort | Gets or sets an expression to calculated values used when sorting.
SortingType | Gets or sets a sorting type of values.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
ValueAxis | Gets or sets axis values. (Inherited from SeriesBase.)
Values | Gets SeriesValueCollection collection of the series values.
View | Gets or sets SeriesView object that determines the presentation of the series data.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Series Class
PerpetuumSoft.Charts Namespace


Series Constructor

[image]

.NET ModelKit Suite ClassReference
Series Constructor
Series Class See Also Send Feedback
Initializes a new instance of the Series class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Series()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Series()

See Also

Series Class
PerpetuumSoft.Charts Namespace


Series Methods

[image] [image]

.NET ModelKit Suite ClassReference
Series Methods
Series Class See Also Send Feedback

The Series type exposes the following members.

Methods

Name | Description
AddElement | Adds an element to a collection of elements which represent series chart.
AddElements | Adds elements array to the collection of elements which represent series chart.
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
ClearElements | Clears the collection of elements which represent series chart.
DataSourceChanged | Implements DataSourceChanged()()().
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetArgumentByIndex | Returns an argument of the series value with the corresponding index.
GetArgumentBySeriesValue | Returns an argument of the specified series value.
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetDataSource | Returns a series data source.
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetElementAtLayer | Implements GetElementAtLayer(Vector, ChartLayer). (Inherited from ChartComposite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetPaletteColor | (Inherited from SeriesBase.)
GetPaletteFill | (Inherited from SeriesBase.)
GetPaletteStroke | (Inherited from SeriesBase.)
GetSeries | Overridden. See GetSeries()()(). (Overrides SeriesBase..::.GetSeries()()().)
GetSimpleBounds | Returns the bounds for the axis of the specified type.
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnDataPropertiesChanged | Occurs after the data in the source have been changed. (Inherited from SeriesBase.)
OnFillChanged | Occurs after the Fill property has been changed. (Inherited from SeriesBase.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Occurs after the Stroke property has been changed. (Inherited from SeriesBase.)
OnStyleChanged | Occurs after the Style property has been changed. (Overrides Element..::.OnStyleChanged()()().)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLayer | Implements PaintLayer(PaintArguments, ChartLayer). (Inherited from ChartComposite.)
PaintSelf | Overridden. See PaintSelf(PaintArguments). (Overrides ChartComposite..::.PaintSelf(PaintArguments).)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetAxes | Recalculates the range of the axes specified in series. (Inherited from SeriesBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Series Class
PerpetuumSoft.Charts Namespace


AddElement Method

[image]

.NET ModelKit Suite ClassReference
Series..::.AddElement Method
Series Class See Also Send Feedback
Adds an element to a collection of elements which represent series chart.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void AddElement(
    Element element
)
Visual Basic (Declaration)
Public Sub AddElement ( _
    element As Element _
)
Visual C++
public:
void AddElement(
    Element^ element
)

Parameters

element
Type: PerpetuumSoft.Instrumentation.Model..::.Element

See Also

Series Class
PerpetuumSoft.Charts Namespace


AddElements Method

[image]

.NET ModelKit Suite ClassReference
Series..::.AddElements Method
Series Class See Also Send Feedback
Adds elements array to the collection of elements which represent series chart.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void AddElements(
    Element[] elements
)
Visual Basic (Declaration)
Public Sub AddElements ( _
    elements As Element() _
)
Visual C++
public:
void AddElements(
    array<Element^>^ elements
)

Parameters

elements
Type: array< PerpetuumSoft.Instrumentation.Model..::.Element >[]()[]

See Also

Series Class
PerpetuumSoft.Charts Namespace


ClearElements Method

[image]

.NET ModelKit Suite ClassReference
Series..::.ClearElements Method
Series Class See Also Send Feedback
Clears the collection of elements which represent series chart.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void ClearElements()
Visual Basic (Declaration)
Public Sub ClearElements
Visual C++
public:
void ClearElements()

See Also

Series Class
PerpetuumSoft.Charts Namespace


DataSourceChanged Method

[image]

.NET ModelKit Suite ClassReference
Series..::.DataSourceChanged Method
Series Class See Also Send Feedback
Implements DataSourceChanged()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void DataSourceChanged()
Visual Basic (Declaration)
Public Sub DataSourceChanged
Visual C++
public:
virtual void DataSourceChanged() sealed

Implements

IDataReceiver..::.DataSourceChanged()()()

See Also

Series Class
PerpetuumSoft.Charts Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Series..::.Dispose Method
Series Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from Composite.)

See Also

Series Class
Series Members
PerpetuumSoft.Charts Namespace


GetArgumentByIndex Method

[image]

.NET ModelKit Suite ClassReference
Series..::.GetArgumentByIndex Method
Series Class See Also Send Feedback
Returns an argument of the series value with the corresponding index.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double GetArgumentByIndex(
    int index
)
Visual Basic (Declaration)
Public Function GetArgumentByIndex ( _
    index As Integer _
) As Double
Visual C++
public:
double GetArgumentByIndex(
    int index
)

Parameters

index
Type: System..::.Int32

See Also

Series Class
PerpetuumSoft.Charts Namespace


GetArgumentBySeriesValue Method

[image]

.NET ModelKit Suite ClassReference
Series..::.GetArgumentBySeriesValue Method
Series Class See Also Send Feedback
Returns an argument of the specified series value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double GetArgumentBySeriesValue(
    SeriesValueBase seriesValue
)
Visual Basic (Declaration)
Public Function GetArgumentBySeriesValue ( _
    seriesValue As SeriesValueBase _
) As Double
Visual C++
public:
double GetArgumentBySeriesValue(
    SeriesValueBase^ seriesValue
)

Parameters

seriesValue
Type: PerpetuumSoft.Charts..::.SeriesValueBase

See Also

Series Class
PerpetuumSoft.Charts Namespace


GetDataSource Method

[image]

.NET ModelKit Suite ClassReference
Series..::.GetDataSource Method
Series Class See Also Send Feedback
Returns a series data source.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Object GetDataSource()
Visual Basic (Declaration)
Public Function GetDataSource As Object
Visual C++
public:
Object^ GetDataSource()

See Also

Series Class
PerpetuumSoft.Charts Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
Series..::.GetHitTest Method
Series Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Series Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image]

.NET ModelKit Suite ClassReference
Series..::.GetSeries Method
Series Class See Also Send Feedback
Overridden. See GetSeries()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Series[] GetSeries()
Visual Basic (Declaration)
Public Overrides Function GetSeries As Series()
Visual C++
public:
virtual array<Series^>^ GetSeries() override

See Also

Series Class
PerpetuumSoft.Charts Namespace


GetSimpleBounds Method

[image]

.NET ModelKit Suite ClassReference
Series..::.GetSimpleBounds Method
Series Class See Also Send Feedback
Returns the bounds for the axis of the specified type.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Bounds GetSimpleBounds(
    AxisType axisType
)
Visual Basic (Declaration)
Public Function GetSimpleBounds ( _
    axisType As AxisType _
) As Bounds
Visual C++
public:
Bounds GetSimpleBounds(
    AxisType axisType
)

Parameters

axisType
Type: PerpetuumSoft.Charts..::.AxisType

See Also

Series Class
PerpetuumSoft.Charts Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Series..::.GetStyle Method
Series Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Series Class
Series Members
PerpetuumSoft.Charts Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Series..::.Invalidate Method
Series Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Series Class
Series Members
PerpetuumSoft.Charts Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Series..::.OnPaint Method
Series Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Inherited from Composite.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

Series Class
Series Members
PerpetuumSoft.Charts Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
Series..::.OnPaint Method (PaintArguments, Fill, Stroke)
Series Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Series Class
OnPaint Overload
PerpetuumSoft.Charts Namespace


OnStyleChanged Method

[image]

.NET ModelKit Suite ClassReference
Series..::.OnStyleChanged Method
Series Class See Also Send Feedback
Occurs after the Style property has been changed.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnStyleChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnStyleChanged
Visual C++
protected:
virtual void OnStyleChanged() override

See Also

Series Class
PerpetuumSoft.Charts Namespace


PaintSelf Method

[image]

.NET ModelKit Suite ClassReference
Series..::.PaintSelf Method
Series Class See Also Send Feedback
Overridden. See PaintSelf(PaintArguments).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintSelf(
    PaintArguments args
)
Visual Basic (Declaration)
Public Overrides Sub PaintSelf ( _
    args As PaintArguments _
)
Visual C++
public:
virtual void PaintSelf(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

Series Class
PerpetuumSoft.Charts Namespace


Series Properties

[image] [image]

.NET ModelKit Suite ClassReference
Series Properties
Series Class See Also Send Feedback

The Series type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
ArgumentAxis | Gets or sets axis arguments. (Inherited from SeriesBase.)
AutoArgument | Gets or sets a value that shows that arguments values will be automatically generated.
Bindings | Gets SeriesBindingCollection list of correspondences between data fields for a series and fields in a data source.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Caption | Gets or sets series caption.
ChartArea | Gets ChartArea in which this series is placed. (Inherited from SeriesBase.)
DataMember | Gets or sets a data source field name for nested series.
DataSource | Gets or sets a data source name for a series.
DefaultLayer | Overridden. See DefaultLayer. (Overrides ChartComposite..::.DefaultLayer.)
DisplayingInLegendType | Gets or sets DisplayingInLegendType which assigns what should be displayed in a legend. (Inherited from SeriesBase.)
Elements | Implements Elements. (Inherited from Composite.)
Error | Gets or sets an error from which the data calculation for series has been terminated.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
LegendExpression | Gets or sets expressions to calculate values displayed in a legend. (Inherited from SeriesBase.)
Name | Gets or sets the element's name. (Inherited from Element.)
Palette | Gets or sets a palette to color series elements. (Inherited from SeriesBase.)
PaletteIndex | Gets or sets palette index. (Inherited from SeriesBase.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets a value that indicates that the expressions for all elements should be recalculated. (Inherited from SeriesBase.)
ScaleType | Gets or sets a value that defines scale type. (Inherited from SeriesBase.)
SeriesSortingType | Gets or sets sorting type of series.
SeriesSplitter | Gets or sets a data source field name by values of which the data will be split into separate series.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Sort | Gets or sets an expression to calculated values used when sorting.
SortingType | Gets or sets a sorting type of values.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
ValueAxis | Gets or sets axis values. (Inherited from SeriesBase.)
Values | Gets SeriesValueCollection collection of the series values.
View | Gets or sets SeriesView object that determines the presentation of the series data.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Series Class
PerpetuumSoft.Charts Namespace


AutoArgument Property

[image]

.NET ModelKit Suite ClassReference
Series..::.AutoArgument Property
Series Class See Also Send Feedback
Gets or sets a value that shows that arguments values will be automatically generated.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool AutoArgument { get; set; }
Visual Basic (Declaration)
Public Property AutoArgument As Boolean
Visual C++
public:
property bool AutoArgument {
    bool get ();
    void set (bool value);
}

See Also

Series Class
PerpetuumSoft.Charts Namespace


Bindings Property

[image]

.NET ModelKit Suite ClassReference
Series..::.Bindings Property
Series Class See Also Send Feedback
Gets SeriesBindingCollection list of correspondences between data fields for a series and fields in a data source.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesBindingCollection Bindings { get; }
Visual Basic (Declaration)
Public ReadOnly Property Bindings As SeriesBindingCollection
Visual C++
public:
property SeriesBindingCollection^ Bindings {
    SeriesBindingCollection^ get ();
}

See Also

Series Class
PerpetuumSoft.Charts Namespace


Caption Property

[image]

.NET ModelKit Suite ClassReference
Series..::.Caption Property
Series Class See Also Send Feedback
Gets or sets series caption.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public string Caption { get; set; }
Visual Basic (Declaration)
Public Property Caption As String
Visual C++
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}

See Also

Series Class
PerpetuumSoft.Charts Namespace


DataMember Property

[image]

.NET ModelKit Suite ClassReference
Series..::.DataMember Property
Series Class See Also Send Feedback
Gets or sets a data source field name for nested series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public string DataMember { get; set; }
Visual Basic (Declaration)
Public Property DataMember As String
Visual C++
public:
property String^ DataMember {
    String^ get ();
    void set (String^ value);
}

See Also

Series Class
PerpetuumSoft.Charts Namespace


DataSource Property

[image]

.NET ModelKit Suite ClassReference
Series..::.DataSource Property
Series Class See Also Send Feedback
Gets or sets a data source name for a series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public string DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As String
Visual C++
public:
property String^ DataSource {
    String^ get ();
    void set (String^ value);
}

See Also

Series Class
PerpetuumSoft.Charts Namespace


DefaultLayer Property

[image]

.NET ModelKit Suite ClassReference
Series..::.DefaultLayer Property
Series Class See Also Send Feedback
Overridden. See DefaultLayer.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override ChartLayer DefaultLayer { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultLayer As ChartLayer
Visual C++
public:
virtual property ChartLayer DefaultLayer {
    ChartLayer get () override;
}

See Also

Series Class
PerpetuumSoft.Charts Namespace


Error Property

[image]

.NET ModelKit Suite ClassReference
Series..::.Error Property
Series Class See Also Send Feedback
Gets or sets an error from which the data calculation for series has been terminated.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Exception Error { get; set; }
Visual Basic (Declaration)
Public Property Error As Exception
Visual C++
public:
property Exception^ Error {
    Exception^ get ();
    void set (Exception^ value);
}

See Also

Series Class
PerpetuumSoft.Charts Namespace


SeriesSortingType Property

[image]

.NET ModelKit Suite ClassReference
Series..::.SeriesSortingType Property
Series Class See Also Send Feedback
Gets or sets sorting type of series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SortingType SeriesSortingType { get; set; }
Visual Basic (Declaration)
Public Property SeriesSortingType As SortingType
Visual C++
public:
property SortingType SeriesSortingType {
    SortingType get ();
    void set (SortingType value);
}

See Also

Series Class
PerpetuumSoft.Charts Namespace


SeriesSplitter Property

[image]

.NET ModelKit Suite ClassReference
Series..::.SeriesSplitter Property
Series Class See Also Send Feedback
Gets or sets a data source field name by values of which the data will be split into separate series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public string SeriesSplitter { get; set; }
Visual Basic (Declaration)
Public Property SeriesSplitter As String
Visual C++
public:
property String^ SeriesSplitter {
    String^ get ();
    void set (String^ value);
}

See Also

Series Class
PerpetuumSoft.Charts Namespace


Sort Property

[image]

.NET ModelKit Suite ClassReference
Series..::.Sort Property
Series Class See Also Send Feedback
Gets or sets an expression to calculated values used when sorting.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public string Sort { get; set; }
Visual Basic (Declaration)
Public Property Sort As String
Visual C++
public:
property String^ Sort {
    String^ get ();
    void set (String^ value);
}

See Also

Series Class
PerpetuumSoft.Charts Namespace


SortingType Property

[image]

.NET ModelKit Suite ClassReference
Series..::.SortingType Property
Series Class See Also Send Feedback
Gets or sets a sorting type of values.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SortingType SortingType { get; set; }
Visual Basic (Declaration)
Public Property SortingType As SortingType
Visual C++
public:
property SortingType SortingType {
    SortingType get ();
    void set (SortingType value);
}

See Also

Series Class
PerpetuumSoft.Charts Namespace


Values Property

[image]

.NET ModelKit Suite ClassReference
Series..::.Values Property
Series Class See Also Send Feedback
Gets SeriesValueCollection collection of the series values.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesValueCollection Values { get; }
Visual Basic (Declaration)
Public ReadOnly Property Values As SeriesValueCollection
Visual C++
public:
property SeriesValueCollection^ Values {
    SeriesValueCollection^ get ();
}

See Also

Series Class
PerpetuumSoft.Charts Namespace


View Property

[image]

.NET ModelKit Suite ClassReference
Series..::.View Property
Series Class See Also Send Feedback
Gets or sets SeriesView object that determines the presentation of the series data.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesView View { get; set; }
Visual Basic (Declaration)
Public Property View As SeriesView
Visual C++
public:
property SeriesView^ View {
    SeriesView^ get ();
    void set (SeriesView^ value);
}

See Also

Series Class
PerpetuumSoft.Charts Namespace


Series Events

[image] [image]

.NET ModelKit Suite ClassReference
Series Events
Series Class See Also Send Feedback

The Series type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Series Class
PerpetuumSoft.Charts Namespace


SeriesBase Class

[image]

.NET ModelKit Suite ClassReference
SeriesBase Class
Members See Also Send Feedback
Represents a base class for chart series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract class SeriesBase : ChartComposite
Visual Basic (Declaration)
Public MustInherit Class SeriesBase _
    Inherits ChartComposite
Visual C++
public ref class SeriesBase abstract : public ChartComposite

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.Composite
PerpetuumSoft.Charts..::.ChartComposite
PerpetuumSoft.Charts..::.SeriesBase
PerpetuumSoft.Charts..::.Series

See Also

SeriesBase Members
PerpetuumSoft.Charts Namespace


SeriesBase Members

[image] [image]

.NET ModelKit Suite ClassReference
SeriesBase Members
SeriesBase Class Constructors Methods Properties Events See Also Send Feedback

The SeriesBase type exposes the following members.

Constructors

Name | Description
SeriesBase | Initializes a new instance of the SeriesBase class

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetElementAtLayer | Implements GetElementAtLayer(Vector, ChartLayer). (Inherited from ChartComposite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetPaletteColor |
GetPaletteFill |
GetPaletteStroke |
GetSeries | Returns array of series of the specified type.
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnDataPropertiesChanged | Occurs after the data in the source have been changed.
OnFillChanged | Occurs after the Fill property has been changed. (Overrides Element..::.OnFillChanged()()().)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Occurs after the Stroke property has been changed. (Overrides Element..::.OnStrokeChanged()()().)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLayer | Implements PaintLayer(PaintArguments, ChartLayer). (Inherited from ChartComposite.)
PaintSelf | Paints the element itself without the nested elements. (Inherited from ChartComposite.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetAxes | Recalculates the range of the axes specified in series.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
ArgumentAxis | Gets or sets axis arguments.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
ChartArea | Gets ChartArea in which this series is placed.
DefaultLayer | Gets default drawing layer. (Inherited from ChartComposite.)
DisplayingInLegendType | Gets or sets DisplayingInLegendType which assigns what should be displayed in a legend.
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
LegendExpression | Gets or sets expressions to calculate values displayed in a legend.
Name | Gets or sets the element's name. (Inherited from Element.)
Palette | Gets or sets a palette to color series elements.
PaletteIndex | Gets or sets palette index.
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets a value that indicates that the expressions for all elements should be recalculated.
ScaleType | Gets or sets a value that defines scale type.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
ValueAxis | Gets or sets axis values.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


SeriesBase Constructor

[image]

.NET ModelKit Suite ClassReference
SeriesBase Constructor
SeriesBase Class See Also Send Feedback
Initializes a new instance of the SeriesBase class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected SeriesBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
SeriesBase()

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


SeriesBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
SeriesBase Methods
SeriesBase Class See Also Send Feedback

The SeriesBase type exposes the following members.

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetElementAtLayer | Implements GetElementAtLayer(Vector, ChartLayer). (Inherited from ChartComposite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetPaletteColor |
GetPaletteFill |
GetPaletteStroke |
GetSeries | Returns array of series of the specified type.
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnDataPropertiesChanged | Occurs after the data in the source have been changed.
OnFillChanged | Occurs after the Fill property has been changed. (Overrides Element..::.OnFillChanged()()().)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Occurs after the Stroke property has been changed. (Overrides Element..::.OnStrokeChanged()()().)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLayer | Implements PaintLayer(PaintArguments, ChartLayer). (Inherited from ChartComposite.)
PaintSelf | Paints the element itself without the nested elements. (Inherited from ChartComposite.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetAxes | Recalculates the range of the axes specified in series.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
SeriesBase..::.Dispose Method
SeriesBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from Composite.)

See Also

SeriesBase Class
SeriesBase Members
PerpetuumSoft.Charts Namespace


GetPaletteColor Method

[image]

.NET ModelKit Suite ClassReference
SeriesBase..::.GetPaletteColor Method
SeriesBase Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Charts.SeriesBase.GetPaletteColor(System.Int32)]

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected internal Color GetPaletteColor(
    int index
)
Visual Basic (Declaration)
Protected Friend Function GetPaletteColor ( _
    index As Integer _
) As Color
Visual C++
protected public:
Color GetPaletteColor(
    int index
)

Parameters

index
Type: System..::.Int32

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


GetPaletteFill Method

[image]

.NET ModelKit Suite ClassReference
SeriesBase..::.GetPaletteFill Method
SeriesBase Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Charts.SeriesBase.GetPaletteFill(System.Int32)]

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected internal Fill GetPaletteFill(
    int index
)
Visual Basic (Declaration)
Protected Friend Function GetPaletteFill ( _
    index As Integer _
) As Fill
Visual C++
protected public:
Fill^ GetPaletteFill(
    int index
)

Parameters

index
Type: System..::.Int32

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


GetPaletteStroke Method

[image]

.NET ModelKit Suite ClassReference
SeriesBase..::.GetPaletteStroke Method
SeriesBase Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Charts.SeriesBase.GetPaletteStroke(System.Int32)]

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected internal Stroke GetPaletteStroke(
    int index
)
Visual Basic (Declaration)
Protected Friend Function GetPaletteStroke ( _
    index As Integer _
) As Stroke
Visual C++
protected public:
Stroke^ GetPaletteStroke(
    int index
)

Parameters

index
Type: System..::.Int32

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image]

.NET ModelKit Suite ClassReference
SeriesBase..::.GetSeries Method
SeriesBase Class See Also Send Feedback
Returns array of series of the specified type.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract Series[] GetSeries()
Visual Basic (Declaration)
Public MustOverride Function GetSeries As Series()
Visual C++
public:
virtual array<Series^>^ GetSeries() abstract

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
SeriesBase..::.GetStyle Method
SeriesBase Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

SeriesBase Class
SeriesBase Members
PerpetuumSoft.Charts Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
SeriesBase..::.Invalidate Method
SeriesBase Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

SeriesBase Class
SeriesBase Members
PerpetuumSoft.Charts Namespace


OnDataPropertiesChanged Method

[image]

.NET ModelKit Suite ClassReference
SeriesBase..::.OnDataPropertiesChanged Method
SeriesBase Class See Also Send Feedback
Occurs after the data in the source have been changed.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnDataPropertiesChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnDataPropertiesChanged
Visual C++
protected:
virtual void OnDataPropertiesChanged()

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


OnFillChanged Method

[image]

.NET ModelKit Suite ClassReference
SeriesBase..::.OnFillChanged Method
SeriesBase Class See Also Send Feedback
Occurs after the Fill property has been changed.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnFillChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnFillChanged
Visual C++
protected:
virtual void OnFillChanged() override

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
SeriesBase..::.OnPaint Method
SeriesBase Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Inherited from Composite.)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

SeriesBase Class
SeriesBase Members
PerpetuumSoft.Charts Namespace


OnStrokeChanged Method

[image]

.NET ModelKit Suite ClassReference
SeriesBase..::.OnStrokeChanged Method
SeriesBase Class See Also Send Feedback
Occurs after the Stroke property has been changed.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnStrokeChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnStrokeChanged
Visual C++
protected:
virtual void OnStrokeChanged() override

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


ResetAxes Method

[image]

.NET ModelKit Suite ClassReference
SeriesBase..::.ResetAxes Method
SeriesBase Class See Also Send Feedback
Recalculates the range of the axes specified in series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected void ResetAxes()
Visual Basic (Declaration)
Protected Sub ResetAxes
Visual C++
protected:
void ResetAxes()

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


SeriesBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
SeriesBase Properties
SeriesBase Class See Also Send Feedback

The SeriesBase type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
ArgumentAxis | Gets or sets axis arguments.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
ChartArea | Gets ChartArea in which this series is placed.
DefaultLayer | Gets default drawing layer. (Inherited from ChartComposite.)
DisplayingInLegendType | Gets or sets DisplayingInLegendType which assigns what should be displayed in a legend.
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
LegendExpression | Gets or sets expressions to calculate values displayed in a legend.
Name | Gets or sets the element's name. (Inherited from Element.)
Palette | Gets or sets a palette to color series elements.
PaletteIndex | Gets or sets palette index.
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets a value that indicates that the expressions for all elements should be recalculated.
ScaleType | Gets or sets a value that defines scale type.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
ValueAxis | Gets or sets axis values.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


ArgumentAxis Property

[image]

.NET ModelKit Suite ClassReference
SeriesBase..::.ArgumentAxis Property
SeriesBase Class See Also Send Feedback
Gets or sets axis arguments.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Axis ArgumentAxis { get; set; }
Visual Basic (Declaration)
Public Property ArgumentAxis As Axis
Visual C++
public:
property Axis^ ArgumentAxis {
    Axis^ get ();
    void set (Axis^ value);
}

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


ChartArea Property

[image]

.NET ModelKit Suite ClassReference
SeriesBase..::.ChartArea Property
SeriesBase Class See Also Send Feedback
Gets ChartArea in which this series is placed.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ChartArea ChartArea { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChartArea As ChartArea
Visual C++
public:
property ChartArea^ ChartArea {
    ChartArea^ get ();
}

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


DisplayingInLegendType Property

[image]

.NET ModelKit Suite ClassReference
SeriesBase..::.DisplayingInLegendType Property
SeriesBase Class See Also Send Feedback
Gets or sets DisplayingInLegendType which assigns what should be displayed in a legend.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public DisplayingInLegendType DisplayingInLegendType { get; set; }
Visual Basic (Declaration)
Public Property DisplayingInLegendType As DisplayingInLegendType
Visual C++
public:
property DisplayingInLegendType DisplayingInLegendType {
    DisplayingInLegendType get ();
    void set (DisplayingInLegendType value);
}

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


LegendExpression Property

[image]

.NET ModelKit Suite ClassReference
SeriesBase..::.LegendExpression Property
SeriesBase Class See Also Send Feedback
Gets or sets expressions to calculate values displayed in a legend.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public string LegendExpression { get; set; }
Visual Basic (Declaration)
Public Property LegendExpression As String
Visual C++
public:
property String^ LegendExpression {
    String^ get ();
    void set (String^ value);
}

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


Palette Property

[image]

.NET ModelKit Suite ClassReference
SeriesBase..::.Palette Property
SeriesBase Class See Also Send Feedback
Gets or sets a palette to color series elements.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Palette Palette { get; set; }
Visual Basic (Declaration)
Public Property Palette As Palette
Visual C++
public:
property Palette^ Palette {
    Palette^ get ();
    void set (Palette^ value);
}

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


PaletteIndex Property

[image]

.NET ModelKit Suite ClassReference
SeriesBase..::.PaletteIndex Property
SeriesBase Class See Also Send Feedback
Gets or sets palette index.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public int PaletteIndex { get; set; }
Visual Basic (Declaration)
Public Property PaletteIndex As Integer
Visual C++
public:
property int PaletteIndex {
    int get ();
    void set (int value);
}

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


RecalculateAll Property

[image]

.NET ModelKit Suite ClassReference
SeriesBase..::.RecalculateAll Property
SeriesBase Class See Also Send Feedback
Gets or sets a value that indicates that the expressions for all elements should be recalculated.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool RecalculateAll { get; set; }
Visual Basic (Declaration)
Public Property RecalculateAll As Boolean
Visual C++
public:
property bool RecalculateAll {
    bool get ();
    void set (bool value);
}

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


ScaleType Property

[image]

.NET ModelKit Suite ClassReference
SeriesBase..::.ScaleType Property
SeriesBase Class See Also Send Feedback
Gets or sets a value that defines scale type.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ScaleType ScaleType { get; set; }
Visual Basic (Declaration)
Public Property ScaleType As ScaleType
Visual C++
public:
property ScaleType ScaleType {
    ScaleType get ();
    void set (ScaleType value);
}

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


ValueAxis Property

[image]

.NET ModelKit Suite ClassReference
SeriesBase..::.ValueAxis Property
SeriesBase Class See Also Send Feedback
Gets or sets axis values.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Axis ValueAxis { get; set; }
Visual Basic (Declaration)
Public Property ValueAxis As Axis
Visual C++
public:
property Axis^ ValueAxis {
    Axis^ get ();
    void set (Axis^ value);
}

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


SeriesBase Events

[image] [image]

.NET ModelKit Suite ClassReference
SeriesBase Events
SeriesBase Class See Also Send Feedback

The SeriesBase type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

SeriesBase Class
PerpetuumSoft.Charts Namespace


SeriesBinding Class

[image]

.NET ModelKit Suite ClassReference
SeriesBinding Class
Members See Also Send Feedback
Represents the correspondence between the data of the source and series data.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class SeriesBinding
Visual Basic (Declaration)
Public Class SeriesBinding
Visual C++
public ref class SeriesBinding

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesBinding

See Also

SeriesBinding Members
PerpetuumSoft.Charts Namespace


SeriesBinding Members

[image] [image]

.NET ModelKit Suite ClassReference
SeriesBinding Members
SeriesBinding Class Constructors Methods Properties See Also Send Feedback

The SeriesBinding type exposes the following members.

Constructors

Name | Description
SeriesBinding | Overloaded.

Methods

Name | Description
Clone | Creates a copy of this object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PropertyName | Gets or sets a name of the source field.
SeriesValueName | Gets or sets a property name in the series data.

See Also

SeriesBinding Class
PerpetuumSoft.Charts Namespace


SeriesBinding Constructor

[image] [image]

.NET ModelKit Suite ClassReference
SeriesBinding Constructor
SeriesBinding Class See Also Send Feedback

Overload List

Name | Description
SeriesBinding()()() | Initializes a new instance of the SeriesBinding class.
SeriesBinding(String, String) | Initializes a new instance of the SeriesBinding class.

See Also

SeriesBinding Class
SeriesBinding Members
PerpetuumSoft.Charts Namespace


SeriesBinding Constructor

[image]

.NET ModelKit Suite ClassReference
SeriesBinding Constructor
SeriesBinding Class See Also Send Feedback
Initializes a new instance of the SeriesBinding class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesBinding()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SeriesBinding()

See Also

SeriesBinding Class
SeriesBinding Overload
PerpetuumSoft.Charts Namespace


SeriesBinding Constructor (String, String)

[image]

.NET ModelKit Suite ClassReference
SeriesBinding Constructor (String, String)
SeriesBinding Class See Also Send Feedback
Initializes a new instance of the SeriesBinding class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesBinding(
    string seriesValueName,
    string propertyName
)
Visual Basic (Declaration)
Public Sub New ( _
    seriesValueName As String, _
    propertyName As String _
)
Visual C++
public:
SeriesBinding(
    String^ seriesValueName,
    String^ propertyName
)

Parameters

seriesValueName
Type: System..::.String
propertyName
Type: System..::.String

See Also

SeriesBinding Class
SeriesBinding Overload
PerpetuumSoft.Charts Namespace


SeriesBinding Methods

[image] [image]

.NET ModelKit Suite ClassReference
SeriesBinding Methods
SeriesBinding Class See Also Send Feedback

The SeriesBinding type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of this object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SeriesBinding Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
SeriesBinding..::.Clone Method
SeriesBinding Class See Also Send Feedback
Creates a copy of this object.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesBinding Clone()
Visual Basic (Declaration)
Public Function Clone As SeriesBinding
Visual C++
public:
SeriesBinding^ Clone()

See Also

SeriesBinding Class
PerpetuumSoft.Charts Namespace


SeriesBinding Properties

[image] [image]

.NET ModelKit Suite ClassReference
SeriesBinding Properties
SeriesBinding Class See Also Send Feedback

The SeriesBinding type exposes the following members.

Properties

Name | Description
PropertyName | Gets or sets a name of the source field.
SeriesValueName | Gets or sets a property name in the series data.

See Also

SeriesBinding Class
PerpetuumSoft.Charts Namespace


PropertyName Property

[image]

.NET ModelKit Suite ClassReference
SeriesBinding..::.PropertyName Property
SeriesBinding Class See Also Send Feedback
Gets or sets a name of the source field.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public string PropertyName { get; set; }
Visual Basic (Declaration)
Public Property PropertyName As String
Visual C++
public:
property String^ PropertyName {
    String^ get ();
    void set (String^ value);
}

See Also

SeriesBinding Class
PerpetuumSoft.Charts Namespace


SeriesValueName Property

[image]

.NET ModelKit Suite ClassReference
SeriesBinding..::.SeriesValueName Property
SeriesBinding Class See Also Send Feedback
Gets or sets a property name in the series data.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public string SeriesValueName { get; set; }
Visual Basic (Declaration)
Public Property SeriesValueName As String
Visual C++
public:
property String^ SeriesValueName {
    String^ get ();
    void set (String^ value);
}

See Also

SeriesBinding Class
PerpetuumSoft.Charts Namespace


SeriesBindingCollection Class

[image]

.NET ModelKit Suite ClassReference
SeriesBindingCollection Class
Members See Also Send Feedback
Represents a collection of SeriesBinding objects.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class SeriesBindingCollection : CollectionBase
Visual Basic (Declaration)
Public Class SeriesBindingCollection _
    Inherits CollectionBase
Visual C++
public ref class SeriesBindingCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Charts..::.SeriesBindingCollection

See Also

SeriesBindingCollection Members
PerpetuumSoft.Charts Namespace


SeriesBindingCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
SeriesBindingCollection Members
SeriesBindingCollection Class Constructors Methods Properties Events See Also Send Feedback

The SeriesBindingCollection type exposes the following members.

Constructors

Name | Description
SeriesBindingCollection | Initializes a new instance of the SeriesBindingCollection class.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Adds elements to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Occurs after an element of the collection has been inserted. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Occurs after an element has been removed from the collection. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

Name | Description
SeriesBindingCollectionChanged | Represents the method that handles the SeriesBindingCollectionChanged event raised when adding elements to or removing elements from a collection.

See Also

SeriesBindingCollection Class
PerpetuumSoft.Charts Namespace


SeriesBindingCollection Constructor

[image]

.NET ModelKit Suite ClassReference
SeriesBindingCollection Constructor
SeriesBindingCollection Class See Also Send Feedback
Initializes a new instance of the SeriesBindingCollection class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesBindingCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SeriesBindingCollection()

See Also

SeriesBindingCollection Class
PerpetuumSoft.Charts Namespace


SeriesBindingCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
SeriesBindingCollection Methods
SeriesBindingCollection Class See Also Send Feedback

The SeriesBindingCollection type exposes the following members.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Adds elements to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Occurs after an element of the collection has been inserted. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Occurs after an element has been removed from the collection. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SeriesBindingCollection Class
PerpetuumSoft.Charts Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
SeriesBindingCollection..::.Add Method
SeriesBindingCollection Class See Also Send Feedback
Implements Add(Object).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesBinding Add(
    SeriesBinding value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As SeriesBinding _
) As SeriesBinding
Visual C++
public:
SeriesBinding^ Add(
    SeriesBinding^ value
)

Parameters

value
Type: PerpetuumSoft.Charts..::.SeriesBinding

See Also

SeriesBindingCollection Class
PerpetuumSoft.Charts Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
SeriesBindingCollection..::.AddRange Method
SeriesBindingCollection Class See Also Send Feedback
Adds elements to the collection.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    SeriesBinding[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As SeriesBinding() _
)
Visual C++
public:
void AddRange(
    array<SeriesBinding^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Charts..::.SeriesBinding >[]()[]

See Also

SeriesBindingCollection Class
PerpetuumSoft.Charts Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
SeriesBindingCollection..::.Contains Method
SeriesBindingCollection Class See Also Send Feedback
Implements Contains(Object).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    SeriesBinding value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As SeriesBinding _
) As Boolean
Visual C++
public:
bool Contains(
    SeriesBinding^ value
)

Parameters

value
Type: PerpetuumSoft.Charts..::.SeriesBinding

See Also

SeriesBindingCollection Class
PerpetuumSoft.Charts Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
SeriesBindingCollection..::.IndexOf Method
SeriesBindingCollection Class See Also Send Feedback
Implements IndexOf(Object).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    SeriesBinding value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As SeriesBinding _
) As Integer
Visual C++
public:
int IndexOf(
    SeriesBinding^ value
)

Parameters

value
Type: PerpetuumSoft.Charts..::.SeriesBinding

See Also

SeriesBindingCollection Class
PerpetuumSoft.Charts Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
SeriesBindingCollection..::.Insert Method
SeriesBindingCollection Class See Also Send Feedback
Implements Insert(Int32, Object).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    SeriesBinding value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As SeriesBinding _
)
Visual C++
public:
void Insert(
    int index,
    SeriesBinding^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Charts..::.SeriesBinding

See Also

SeriesBindingCollection Class
PerpetuumSoft.Charts Namespace


OnInsertComplete Method

[image]

.NET ModelKit Suite ClassReference
SeriesBindingCollection..::.OnInsertComplete Method
SeriesBindingCollection Class See Also Send Feedback
Occurs after an element of the collection has been inserted.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsertComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsertComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsertComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

SeriesBindingCollection Class
PerpetuumSoft.Charts Namespace


OnRemoveComplete Method

[image]

.NET ModelKit Suite ClassReference
SeriesBindingCollection..::.OnRemoveComplete Method
SeriesBindingCollection Class See Also Send Feedback
Occurs after an element has been removed from the collection.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnRemoveComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemoveComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemoveComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

SeriesBindingCollection Class
PerpetuumSoft.Charts Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
SeriesBindingCollection..::.Remove Method
SeriesBindingCollection Class See Also Send Feedback
Implements Remove(Object).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    SeriesBinding value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As SeriesBinding _
)
Visual C++
public:
void Remove(
    SeriesBinding^ value
)

Parameters

value
Type: PerpetuumSoft.Charts..::.SeriesBinding

See Also

SeriesBindingCollection Class
PerpetuumSoft.Charts Namespace


SeriesBindingCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
SeriesBindingCollection Properties
SeriesBindingCollection Class See Also Send Feedback

The SeriesBindingCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

SeriesBindingCollection Class
PerpetuumSoft.Charts Namespace


Item Property

[image] [image]

.NET ModelKit Suite ClassReference
SeriesBindingCollection..::.Item Property
SeriesBindingCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Implements Item[([(Int32])]).
Item[([(String])]) | Gets SeriesBinding

See Also

SeriesBindingCollection Class
SeriesBindingCollection Members
PerpetuumSoft.Charts Namespace


Item Property (Int32)

[image]

.NET ModelKit Suite ClassReference
SeriesBindingCollection..::.Item Property (Int32)
SeriesBindingCollection Class See Also Send Feedback
Implements Item[([(Int32])]).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesBinding this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As SeriesBinding
Visual C++
public:
property SeriesBinding^ default[int index] {
    SeriesBinding^ get (int index);
    void set (int index, SeriesBinding^ value);
}

Parameters

index
Type: System..::.Int32

See Also

SeriesBindingCollection Class
Item Overload
PerpetuumSoft.Charts Namespace


Item Property (String)

[image]

.NET ModelKit Suite ClassReference
SeriesBindingCollection..::.Item Property (String)
SeriesBindingCollection Class See Also Send Feedback
Gets SeriesBinding

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesBinding this[
    string seresValueName
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    seresValueName As String _
) As SeriesBinding
Visual C++
public:
property SeriesBinding^ default[String^ seresValueName] {
    SeriesBinding^ get (String^ seresValueName);
}

Parameters

seresValueName
Type: System..::.String

See Also

SeriesBindingCollection Class
Item Overload
PerpetuumSoft.Charts Namespace


SeriesBindingCollection Events

[image] [image]

.NET ModelKit Suite ClassReference
SeriesBindingCollection Events
SeriesBindingCollection Class See Also Send Feedback

The SeriesBindingCollection type exposes the following members.

Events

Name | Description
SeriesBindingCollectionChanged | Represents the method that handles the SeriesBindingCollectionChanged event raised when adding elements to or removing elements from a collection.

See Also

SeriesBindingCollection Class
PerpetuumSoft.Charts Namespace


SeriesBindingCollectionChanged Event

[image]

.NET ModelKit Suite ClassReference
SeriesBindingCollection..::.SeriesBindingCollectionChanged Event
SeriesBindingCollection Class See Also Send Feedback
Represents the method that handles the SeriesBindingCollectionChanged event raised when adding elements to or removing elements from a collection.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler SeriesBindingCollectionChanged
Visual Basic (Declaration)
Public Event SeriesBindingCollectionChanged As EventHandler
Visual C++
public:
 event EventHandler^ SeriesBindingCollectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

SeriesBindingCollection Class
PerpetuumSoft.Charts Namespace


SeriesDataBindingHelper Class

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper Class
Members See Also Send Feedback
Represents a class designed to build series values by a data source.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class SeriesDataBindingHelper
Visual Basic (Declaration)
Public Class SeriesDataBindingHelper
Visual C++
public ref class SeriesDataBindingHelper

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesDataBindingHelper

See Also

SeriesDataBindingHelper Members
PerpetuumSoft.Charts Namespace


SeriesDataBindingHelper Members

[image] [image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper Members
SeriesDataBindingHelper Class Constructors Methods Properties See Also Send Feedback

The SeriesDataBindingHelper type exposes the following members.

Constructors

Name | Description
SeriesDataBindingHelper | Overloaded.

Methods

Name | Description
BindPoints | Returns a Hashtable that contains sets of series elements.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPropertyNames | Overloaded.
GetSortNamedSeriesValueCollections | Returns the sorted collection that contains sets of series elements.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AutoArgument | Gets or sets value that indicates whether the incremental argument is used.
Bindings | Gets or sets a collection of correspondences between data source fields and series value fields.
DataMember | Gets or sets a property name that contains a nested data source.
DataSource | Gets or sets a series data source.
DefaultSeriesName | Gets or sets default series name.
SeriesSortingType | Gets or sets a type of series sorting.
SeriesSplitter | Gets or sets an expression that groups values by series.
SeriesValueType | Gets or sets a type of the series value.
Sort | Gets or sets an expression of the series values sorting.
SortingType | Gets or sets a type of series values sorting.

See Also

SeriesDataBindingHelper Class
PerpetuumSoft.Charts Namespace


SeriesDataBindingHelper Constructor

[image] [image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper Constructor
SeriesDataBindingHelper Class See Also Send Feedback

Overload List

Name | Description
SeriesDataBindingHelper()()() | Initializes a new instance of the SeriesDataBindingHelper class.
SeriesDataBindingHelper(IEnumerable, String, SeriesBindingCollection, Boolean, Type) | Initializes a new instance of the SeriesDataBindingHelper class.
SeriesDataBindingHelper(IEnumerable, String, SeriesBindingCollection, Boolean, Type, SortingType) | Initializes a new instance of the SeriesDataBindingHelper class.
SeriesDataBindingHelper(IEnumerable, String, SeriesBindingCollection, Boolean, Type, SortingType, String) | Initializes a new instance of the SeriesDataBindingHelper class.
SeriesDataBindingHelper(IEnumerable, String, SeriesBindingCollection, Boolean, Type, SortingType, String, String) | Initializes a new instance of the SeriesDataBindingHelper class.
SeriesDataBindingHelper(IEnumerable, String, SeriesBindingCollection, Boolean, Type, SortingType, String, String, SortingType) | Initializes a new instance of the SeriesDataBindingHelper class.

See Also

SeriesDataBindingHelper Class
SeriesDataBindingHelper Members
PerpetuumSoft.Charts Namespace


SeriesDataBindingHelper Constructor

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper Constructor
SeriesDataBindingHelper Class See Also Send Feedback
Initializes a new instance of the SeriesDataBindingHelper class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesDataBindingHelper()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SeriesDataBindingHelper()

See Also

SeriesDataBindingHelper Class
SeriesDataBindingHelper Overload
PerpetuumSoft.Charts Namespace


SeriesDataBindingHelper Constructor (IEnumerable, String, SeriesBindingCollection, Boolean, Type)

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper Constructor (IEnumerable, String, SeriesBindingCollection, Boolean, Type)
SeriesDataBindingHelper Class See Also Send Feedback
Initializes a new instance of the SeriesDataBindingHelper class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesDataBindingHelper(
    IEnumerable dataSource,
    string seriesSplitter,
    SeriesBindingCollection bindings,
    bool autoArgument,
    Type seriesValueType
)
Visual Basic (Declaration)
Public Sub New ( _
    dataSource As IEnumerable, _
    seriesSplitter As String, _
    bindings As SeriesBindingCollection, _
    autoArgument As Boolean, _
    seriesValueType As Type _
)
Visual C++
public:
SeriesDataBindingHelper(
    IEnumerable^ dataSource,
    String^ seriesSplitter,
    SeriesBindingCollection^ bindings,
    bool autoArgument,
    Type^ seriesValueType
)

Parameters

dataSource
Type: System.Collections..::.IEnumerable
seriesSplitter
Type: System..::.String
bindings
Type: PerpetuumSoft.Charts..::.SeriesBindingCollection
autoArgument
Type: System..::.Boolean
seriesValueType
Type: System..::.Type

See Also

SeriesDataBindingHelper Class
SeriesDataBindingHelper Overload
PerpetuumSoft.Charts Namespace


SeriesDataBindingHelper Constructor (IEnumerable, String, SeriesBindingCollection, Boolean, Type, SortingType)

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper Constructor (IEnumerable, String, SeriesBindingCollection, Boolean, Type, SortingType)
SeriesDataBindingHelper Class See Also Send Feedback
Initializes a new instance of the SeriesDataBindingHelper class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesDataBindingHelper(
    IEnumerable dataSource,
    string seriesSplitter,
    SeriesBindingCollection bindings,
    bool autoArgument,
    Type seriesValueType,
    SortingType sortingType
)
Visual Basic (Declaration)
Public Sub New ( _
    dataSource As IEnumerable, _
    seriesSplitter As String, _
    bindings As SeriesBindingCollection, _
    autoArgument As Boolean, _
    seriesValueType As Type, _
    sortingType As SortingType _
)
Visual C++
public:
SeriesDataBindingHelper(
    IEnumerable^ dataSource,
    String^ seriesSplitter,
    SeriesBindingCollection^ bindings,
    bool autoArgument,
    Type^ seriesValueType,
    SortingType sortingType
)

Parameters

dataSource
Type: System.Collections..::.IEnumerable
seriesSplitter
Type: System..::.String
bindings
Type: PerpetuumSoft.Charts..::.SeriesBindingCollection
autoArgument
Type: System..::.Boolean
seriesValueType
Type: System..::.Type
sortingType
Type: PerpetuumSoft.Charts..::.SortingType

See Also

SeriesDataBindingHelper Class
SeriesDataBindingHelper Overload
PerpetuumSoft.Charts Namespace


SeriesDataBindingHelper Constructor (IEnumerable, String, SeriesBindingCollection, Boolean, Type, SortingType, String)

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper Constructor (IEnumerable, String, SeriesBindingCollection, Boolean, Type, SortingType, String)
SeriesDataBindingHelper Class See Also Send Feedback
Initializes a new instance of the SeriesDataBindingHelper class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesDataBindingHelper(
    IEnumerable dataSource,
    string seriesSplitter,
    SeriesBindingCollection bindings,
    bool autoArgument,
    Type seriesValueType,
    SortingType sortingType,
    string sort
)
Visual Basic (Declaration)
Public Sub New ( _
    dataSource As IEnumerable, _
    seriesSplitter As String, _
    bindings As SeriesBindingCollection, _
    autoArgument As Boolean, _
    seriesValueType As Type, _
    sortingType As SortingType, _
    sort As String _
)
Visual C++
public:
SeriesDataBindingHelper(
    IEnumerable^ dataSource,
    String^ seriesSplitter,
    SeriesBindingCollection^ bindings,
    bool autoArgument,
    Type^ seriesValueType,
    SortingType sortingType,
    String^ sort
)

Parameters

dataSource
Type: System.Collections..::.IEnumerable
seriesSplitter
Type: System..::.String
bindings
Type: PerpetuumSoft.Charts..::.SeriesBindingCollection
autoArgument
Type: System..::.Boolean
seriesValueType
Type: System..::.Type
sortingType
Type: PerpetuumSoft.Charts..::.SortingType
sort
Type: System..::.String

See Also

SeriesDataBindingHelper Class
SeriesDataBindingHelper Overload
PerpetuumSoft.Charts Namespace


SeriesDataBindingHelper Constructor (IEnumerable, String, SeriesBindingCollection, Boolean, Type, SortingType, String, String)

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper Constructor (IEnumerable, String, SeriesBindingCollection, Boolean, Type, SortingType, String, String)
SeriesDataBindingHelper Class See Also Send Feedback
Initializes a new instance of the SeriesDataBindingHelper class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesDataBindingHelper(
    IEnumerable dataSource,
    string seriesSplitter,
    SeriesBindingCollection bindings,
    bool autoArgument,
    Type seriesValueType,
    SortingType sortingType,
    string sort,
    string dataMember
)
Visual Basic (Declaration)
Public Sub New ( _
    dataSource As IEnumerable, _
    seriesSplitter As String, _
    bindings As SeriesBindingCollection, _
    autoArgument As Boolean, _
    seriesValueType As Type, _
    sortingType As SortingType, _
    sort As String, _
    dataMember As String _
)
Visual C++
public:
SeriesDataBindingHelper(
    IEnumerable^ dataSource,
    String^ seriesSplitter,
    SeriesBindingCollection^ bindings,
    bool autoArgument,
    Type^ seriesValueType,
    SortingType sortingType,
    String^ sort,
    String^ dataMember
)

Parameters

dataSource
Type: System.Collections..::.IEnumerable
seriesSplitter
Type: System..::.String
bindings
Type: PerpetuumSoft.Charts..::.SeriesBindingCollection
autoArgument
Type: System..::.Boolean
seriesValueType
Type: System..::.Type
sortingType
Type: PerpetuumSoft.Charts..::.SortingType
sort
Type: System..::.String
dataMember
Type: System..::.String

See Also

SeriesDataBindingHelper Class
SeriesDataBindingHelper Overload
PerpetuumSoft.Charts Namespace


SeriesDataBindingHelper Constructor (IEnumerable, String, SeriesBindingCollection, Boolean, Type, SortingType, String, String, SortingType)

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper Constructor (IEnumerable, String, SeriesBindingCollection, Boolean, Type, SortingType, String, String, SortingType)
SeriesDataBindingHelper Class See Also Send Feedback
Initializes a new instance of the SeriesDataBindingHelper class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesDataBindingHelper(
    IEnumerable dataSource,
    string seriesSplitter,
    SeriesBindingCollection bindings,
    bool autoArgument,
    Type seriesValueType,
    SortingType sortingType,
    string sort,
    string dataMember,
    SortingType seriesSortingType
)
Visual Basic (Declaration)
Public Sub New ( _
    dataSource As IEnumerable, _
    seriesSplitter As String, _
    bindings As SeriesBindingCollection, _
    autoArgument As Boolean, _
    seriesValueType As Type, _
    sortingType As SortingType, _
    sort As String, _
    dataMember As String, _
    seriesSortingType As SortingType _
)
Visual C++
public:
SeriesDataBindingHelper(
    IEnumerable^ dataSource,
    String^ seriesSplitter,
    SeriesBindingCollection^ bindings,
    bool autoArgument,
    Type^ seriesValueType,
    SortingType sortingType,
    String^ sort,
    String^ dataMember,
    SortingType seriesSortingType
)

Parameters

dataSource
Type: System.Collections..::.IEnumerable
seriesSplitter
Type: System..::.String
bindings
Type: PerpetuumSoft.Charts..::.SeriesBindingCollection
autoArgument
Type: System..::.Boolean
seriesValueType
Type: System..::.Type
sortingType
Type: PerpetuumSoft.Charts..::.SortingType
sort
Type: System..::.String
dataMember
Type: System..::.String
seriesSortingType
Type: PerpetuumSoft.Charts..::.SortingType

See Also

SeriesDataBindingHelper Class
SeriesDataBindingHelper Overload
PerpetuumSoft.Charts Namespace


SeriesDataBindingHelper Methods

[image] [image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper Methods
SeriesDataBindingHelper Class See Also Send Feedback

The SeriesDataBindingHelper type exposes the following members.

Methods

Name | Description
BindPoints | Returns a Hashtable that contains sets of series elements.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPropertyNames | Overloaded.
GetSortNamedSeriesValueCollections | Returns the sorted collection that contains sets of series elements.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SeriesDataBindingHelper Class
PerpetuumSoft.Charts Namespace


BindPoints Method

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper..::.BindPoints Method
SeriesDataBindingHelper Class See Also Send Feedback
Returns a Hashtable that contains sets of series elements.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Hashtable BindPoints()
Visual Basic (Declaration)
Public Function BindPoints As Hashtable
Visual C++
public:
Hashtable^ BindPoints()

See Also

SeriesDataBindingHelper Class
PerpetuumSoft.Charts Namespace


GetPropertyNames Method

[image] [image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper..::.GetPropertyNames Method
SeriesDataBindingHelper Class See Also Send Feedback

Overload List

Name | Description
GetPropertyNames(Object) | Returns properties names array of the specified object.
GetPropertyNames(Object, String) | Returns properies names array of the specified object field.
GetPropertyNames(Object, Type) | Returns properties names array of the specified object type.

See Also

SeriesDataBindingHelper Class
SeriesDataBindingHelper Members
PerpetuumSoft.Charts Namespace


GetPropertyNames Method (Object)

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper..::.GetPropertyNames Method (Object)
SeriesDataBindingHelper Class See Also Send Feedback
Returns properties names array of the specified object.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public static string[] GetPropertyNames(
    Object obj
)
Visual Basic (Declaration)
Public Shared Function GetPropertyNames ( _
    obj As Object _
) As String()
Visual C++
public:
static array<String^>^ GetPropertyNames(
    Object^ obj
)

Parameters

obj
Type: System..::.Object

See Also

SeriesDataBindingHelper Class
GetPropertyNames Overload
PerpetuumSoft.Charts Namespace


GetPropertyNames Method (Object, String)

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper..::.GetPropertyNames Method (Object, String)
SeriesDataBindingHelper Class See Also Send Feedback
Returns properies names array of the specified object field.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public static string[] GetPropertyNames(
    Object dataSource,
    string dataMember
)
Visual Basic (Declaration)
Public Shared Function GetPropertyNames ( _
    dataSource As Object, _
    dataMember As String _
) As String()
Visual C++
public:
static array<String^>^ GetPropertyNames(
    Object^ dataSource,
    String^ dataMember
)

Parameters

dataSource
Type: System..::.Object
dataMember
Type: System..::.String

See Also

SeriesDataBindingHelper Class
GetPropertyNames Overload
PerpetuumSoft.Charts Namespace


GetPropertyNames Method (Object, Type)

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper..::.GetPropertyNames Method (Object, Type)
SeriesDataBindingHelper Class See Also Send Feedback
Returns properties names array of the specified object type.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public static string[] GetPropertyNames(
    Object dataSource,
    Type interfaceType
)
Visual Basic (Declaration)
Public Shared Function GetPropertyNames ( _
    dataSource As Object, _
    interfaceType As Type _
) As String()
Visual C++
public:
static array<String^>^ GetPropertyNames(
    Object^ dataSource,
    Type^ interfaceType
)

Parameters

dataSource
Type: System..::.Object
interfaceType
Type: System..::.Type

See Also

SeriesDataBindingHelper Class
GetPropertyNames Overload
PerpetuumSoft.Charts Namespace


GetSortNamedSeriesValueCollections Method

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper..::.GetSortNamedSeriesValueCollections Method
SeriesDataBindingHelper Class See Also Send Feedback
Returns the sorted collection that contains sets of series elements.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public NamedSeriesValueCollection[] GetSortNamedSeriesValueCollections()
Visual Basic (Declaration)
Public Function GetSortNamedSeriesValueCollections As NamedSeriesValueCollection()
Visual C++
public:
array<NamedSeriesValueCollection^>^ GetSortNamedSeriesValueCollections()

See Also

SeriesDataBindingHelper Class
PerpetuumSoft.Charts Namespace


SeriesDataBindingHelper Properties

[image] [image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper Properties
SeriesDataBindingHelper Class See Also Send Feedback

The SeriesDataBindingHelper type exposes the following members.

Properties

Name | Description
AutoArgument | Gets or sets value that indicates whether the incremental argument is used.
Bindings | Gets or sets a collection of correspondences between data source fields and series value fields.
DataMember | Gets or sets a property name that contains a nested data source.
DataSource | Gets or sets a series data source.
DefaultSeriesName | Gets or sets default series name.
SeriesSortingType | Gets or sets a type of series sorting.
SeriesSplitter | Gets or sets an expression that groups values by series.
SeriesValueType | Gets or sets a type of the series value.
Sort | Gets or sets an expression of the series values sorting.
SortingType | Gets or sets a type of series values sorting.

See Also

SeriesDataBindingHelper Class
PerpetuumSoft.Charts Namespace


AutoArgument Property

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper..::.AutoArgument Property
SeriesDataBindingHelper Class See Also Send Feedback
Gets or sets value that indicates whether the incremental argument is used.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool AutoArgument { get; set; }
Visual Basic (Declaration)
Public Property AutoArgument As Boolean
Visual C++
public:
property bool AutoArgument {
    bool get ();
    void set (bool value);
}

See Also

SeriesDataBindingHelper Class
PerpetuumSoft.Charts Namespace


Bindings Property

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper..::.Bindings Property
SeriesDataBindingHelper Class See Also Send Feedback
Gets or sets a collection of correspondences between data source fields and series value fields.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesBindingCollection Bindings { get; set; }
Visual Basic (Declaration)
Public Property Bindings As SeriesBindingCollection
Visual C++
public:
property SeriesBindingCollection^ Bindings {
    SeriesBindingCollection^ get ();
    void set (SeriesBindingCollection^ value);
}

See Also

SeriesDataBindingHelper Class
PerpetuumSoft.Charts Namespace


DataMember Property

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper..::.DataMember Property
SeriesDataBindingHelper Class See Also Send Feedback
Gets or sets a property name that contains a nested data source.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public string DataMember { get; set; }
Visual Basic (Declaration)
Public Property DataMember As String
Visual C++
public:
property String^ DataMember {
    String^ get ();
    void set (String^ value);
}

See Also

SeriesDataBindingHelper Class
PerpetuumSoft.Charts Namespace


DataSource Property

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper..::.DataSource Property
SeriesDataBindingHelper Class See Also Send Feedback
Gets or sets a series data source.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public IEnumerable DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As IEnumerable
Visual C++
public:
property IEnumerable^ DataSource {
    IEnumerable^ get ();
    void set (IEnumerable^ value);
}

See Also

SeriesDataBindingHelper Class
PerpetuumSoft.Charts Namespace


DefaultSeriesName Property

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper..::.DefaultSeriesName Property
SeriesDataBindingHelper Class See Also Send Feedback
Gets or sets default series name.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public string DefaultSeriesName { get; set; }
Visual Basic (Declaration)
Public Property DefaultSeriesName As String
Visual C++
public:
property String^ DefaultSeriesName {
    String^ get ();
    void set (String^ value);
}

See Also

SeriesDataBindingHelper Class
PerpetuumSoft.Charts Namespace


SeriesSortingType Property

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper..::.SeriesSortingType Property
SeriesDataBindingHelper Class See Also Send Feedback
Gets or sets a type of series sorting.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SortingType SeriesSortingType { get; set; }
Visual Basic (Declaration)
Public Property SeriesSortingType As SortingType
Visual C++
public:
property SortingType SeriesSortingType {
    SortingType get ();
    void set (SortingType value);
}

See Also

SeriesDataBindingHelper Class
PerpetuumSoft.Charts Namespace


SeriesSplitter Property

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper..::.SeriesSplitter Property
SeriesDataBindingHelper Class See Also Send Feedback
Gets or sets an expression that groups values by series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public string SeriesSplitter { get; set; }
Visual Basic (Declaration)
Public Property SeriesSplitter As String
Visual C++
public:
property String^ SeriesSplitter {
    String^ get ();
    void set (String^ value);
}

See Also

SeriesDataBindingHelper Class
PerpetuumSoft.Charts Namespace


SeriesValueType Property

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper..::.SeriesValueType Property
SeriesDataBindingHelper Class See Also Send Feedback
Gets or sets a type of the series value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Type SeriesValueType { get; set; }
Visual Basic (Declaration)
Public Property SeriesValueType As Type
Visual C++
public:
property Type^ SeriesValueType {
    Type^ get ();
    void set (Type^ value);
}

See Also

SeriesDataBindingHelper Class
PerpetuumSoft.Charts Namespace


Sort Property

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper..::.Sort Property
SeriesDataBindingHelper Class See Also Send Feedback
Gets or sets an expression of the series values sorting.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public string Sort { get; set; }
Visual Basic (Declaration)
Public Property Sort As String
Visual C++
public:
property String^ Sort {
    String^ get ();
    void set (String^ value);
}

See Also

SeriesDataBindingHelper Class
PerpetuumSoft.Charts Namespace


SortingType Property

[image]

.NET ModelKit Suite ClassReference
SeriesDataBindingHelper..::.SortingType Property
SeriesDataBindingHelper Class See Also Send Feedback
Gets or sets a type of series values sorting.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SortingType SortingType { get; set; }
Visual Basic (Declaration)
Public Property SortingType As SortingType
Visual C++
public:
property SortingType SortingType {
    SortingType get ();
    void set (SortingType value);
}

See Also

SeriesDataBindingHelper Class
PerpetuumSoft.Charts Namespace


SeriesValue Class

[image]

.NET ModelKit Suite ClassReference
SeriesValue Class
Members See Also Send Feedback
Represents series value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class SeriesValue : SeriesValueBase
Visual Basic (Declaration)
Public Class SeriesValue _
    Inherits SeriesValueBase
Visual C++
public ref class SeriesValue : public SeriesValueBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesValueBase
PerpetuumSoft.Charts..::.SeriesValue
PerpetuumSoft.Charts..::.PieSeriesValue
PerpetuumSoft.Charts..::.PointSeriesValue

See Also

SeriesValue Members
PerpetuumSoft.Charts Namespace


SeriesValue Members

[image] [image]

.NET ModelKit Suite ClassReference
SeriesValue Members
SeriesValue Class Constructors Methods Properties See Also Send Feedback

The SeriesValue type exposes the following members.

Constructors

Name | Description
SeriesValue | Overloaded.

Methods

Name | Description
Clone | Overridden. See Clone()()(). (Overrides SeriesValueBase..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRepresentationObject | Overridden. See GetRepresentationObject()()(). (Overrides SeriesValueBase..::.GetRepresentationObject()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueBounds | Overridden. See GetValueBounds()()(). (Overrides SeriesValueBase..::.GetValueBounds()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sum | Overridden. See Sum(SeriesValueBase). (Overrides SeriesValueBase..::.Sum(SeriesValueBase).)
ToString | Overridden. See ToString()()(). (Inherited from SeriesValueBase.)

Properties

Name | Description
Argument | Gets or sets an argument. (Inherited from SeriesValueBase.)
Sort | Gets or sets the sort expression value for series value. (Inherited from SeriesValueBase.)
UserData | Gets or sets additional data of the series value. (Inherited from SeriesValueBase.)
Value | Gets or sets series value.

See Also

SeriesValue Class
PerpetuumSoft.Charts Namespace


SeriesValue Constructor

[image] [image]

.NET ModelKit Suite ClassReference
SeriesValue Constructor
SeriesValue Class See Also Send Feedback

Overload List

Name | Description
SeriesValue()()() | Initializes a new instance of the SeriesValue class.
SeriesValue(Double, Double) | Initializes a new instance of the SeriesValue class.
SeriesValue(String, Double) | Initializes a new instance of the SeriesValue class.

See Also

SeriesValue Class
SeriesValue Members
PerpetuumSoft.Charts Namespace


SeriesValue Constructor

[image]

.NET ModelKit Suite ClassReference
SeriesValue Constructor
SeriesValue Class See Also Send Feedback
Initializes a new instance of the SeriesValue class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesValue()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SeriesValue()

See Also

SeriesValue Class
SeriesValue Overload
PerpetuumSoft.Charts Namespace


SeriesValue Constructor (Double, Double)

[image]

.NET ModelKit Suite ClassReference
SeriesValue Constructor (Double, Double)
SeriesValue Class See Also Send Feedback
Initializes a new instance of the SeriesValue class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesValue(
    double argument,
    double value
)
Visual Basic (Declaration)
Public Sub New ( _
    argument As Double, _
    value As Double _
)
Visual C++
public:
SeriesValue(
    double argument,
    double value
)

Parameters

argument
Type: System..::.Double
value
Type: System..::.Double

See Also

SeriesValue Class
SeriesValue Overload
PerpetuumSoft.Charts Namespace


SeriesValue Constructor (String, Double)

[image]

.NET ModelKit Suite ClassReference
SeriesValue Constructor (String, Double)
SeriesValue Class See Also Send Feedback
Initializes a new instance of the SeriesValue class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesValue(
    string argument,
    double value
)
Visual Basic (Declaration)
Public Sub New ( _
    argument As String, _
    value As Double _
)
Visual C++
public:
SeriesValue(
    String^ argument,
    double value
)

Parameters

argument
Type: System..::.String
value
Type: System..::.Double

See Also

SeriesValue Class
SeriesValue Overload
PerpetuumSoft.Charts Namespace


SeriesValue Methods

[image] [image]

.NET ModelKit Suite ClassReference
SeriesValue Methods
SeriesValue Class See Also Send Feedback

The SeriesValue type exposes the following members.

Methods

Name | Description
Clone | Overridden. See Clone()()(). (Overrides SeriesValueBase..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRepresentationObject | Overridden. See GetRepresentationObject()()(). (Overrides SeriesValueBase..::.GetRepresentationObject()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueBounds | Overridden. See GetValueBounds()()(). (Overrides SeriesValueBase..::.GetValueBounds()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sum | Overridden. See Sum(SeriesValueBase). (Overrides SeriesValueBase..::.Sum(SeriesValueBase).)
ToString | Overridden. See ToString()()(). (Inherited from SeriesValueBase.)

See Also

SeriesValue Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
SeriesValue..::.Clone Method
SeriesValue Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesValueBase Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesValueBase
Visual C++
public:
virtual SeriesValueBase^ Clone() override

See Also

SeriesValue Class
PerpetuumSoft.Charts Namespace


GetRepresentationObject Method

[image]

.NET ModelKit Suite ClassReference
SeriesValue..::.GetRepresentationObject Method
SeriesValue Class See Also Send Feedback
Overridden. See GetRepresentationObject()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Object GetRepresentationObject()
Visual Basic (Declaration)
Public Overrides Function GetRepresentationObject As Object
Visual C++
public:
virtual Object^ GetRepresentationObject() override

See Also

SeriesValue Class
PerpetuumSoft.Charts Namespace


GetValueBounds Method

[image]

.NET ModelKit Suite ClassReference
SeriesValue..::.GetValueBounds Method
SeriesValue Class See Also Send Feedback
Overridden. See GetValueBounds()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Bounds GetValueBounds()
Visual Basic (Declaration)
Public Overrides Function GetValueBounds As Bounds
Visual C++
public:
virtual Bounds GetValueBounds() override

See Also

SeriesValue Class
PerpetuumSoft.Charts Namespace


Sum Method

[image]

.NET ModelKit Suite ClassReference
SeriesValue..::.Sum Method
SeriesValue Class See Also Send Feedback
Overridden. See Sum(SeriesValueBase).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void Sum(
    SeriesValueBase seriesValue
)
Visual Basic (Declaration)
Public Overrides Sub Sum ( _
    seriesValue As SeriesValueBase _
)
Visual C++
public:
virtual void Sum(
    SeriesValueBase^ seriesValue
) override

Parameters

seriesValue
Type: PerpetuumSoft.Charts..::.SeriesValueBase

See Also

SeriesValue Class
PerpetuumSoft.Charts Namespace


SeriesValue Properties

[image] [image]

.NET ModelKit Suite ClassReference
SeriesValue Properties
SeriesValue Class See Also Send Feedback

The SeriesValue type exposes the following members.

Properties

Name | Description
Argument | Gets or sets an argument. (Inherited from SeriesValueBase.)
Sort | Gets or sets the sort expression value for series value. (Inherited from SeriesValueBase.)
UserData | Gets or sets additional data of the series value. (Inherited from SeriesValueBase.)
Value | Gets or sets series value.

See Also

SeriesValue Class
PerpetuumSoft.Charts Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
SeriesValue..::.Value Property
SeriesValue Class See Also Send Feedback
Gets or sets series value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Double
Visual C++
public:
property double Value {
    double get ();
    void set (double value);
}

See Also

SeriesValue Class
PerpetuumSoft.Charts Namespace


SeriesValueBase Class

[image]

.NET ModelKit Suite ClassReference
SeriesValueBase Class
Members See Also Send Feedback
Represents a base class for series values.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract class SeriesValueBase
Visual Basic (Declaration)
Public MustInherit Class SeriesValueBase
Visual C++
public ref class SeriesValueBase abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesValueBase
PerpetuumSoft.Charts..::.FinancialSeriesValue
PerpetuumSoft.Charts..::.SeriesValue

See Also

SeriesValueBase Members
PerpetuumSoft.Charts Namespace


SeriesValueBase Members

[image] [image]

.NET ModelKit Suite ClassReference
SeriesValueBase Members
SeriesValueBase Class Constructors Methods Properties See Also Send Feedback

The SeriesValueBase type exposes the following members.

Constructors

Name | Description
SeriesValueBase | Overloaded.

Methods

Name | Description
Clone | Creates a copy of an object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRepresentationObject | Returns an object that represents series value.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueBounds | Returns the bounds of the series values.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sum | Summarizes with the specified series value.
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
Argument | Gets or sets an argument.
Sort | Gets or sets the sort expression value for series value.
UserData | Gets or sets additional data of the series value.

See Also

SeriesValueBase Class
PerpetuumSoft.Charts Namespace


SeriesValueBase Constructor

[image] [image]

.NET ModelKit Suite ClassReference
SeriesValueBase Constructor
SeriesValueBase Class See Also Send Feedback

Overload List

Name | Description
SeriesValueBase()()() | Initializes a new instance of the SeriesValueBase class
SeriesValueBase(Double) | Initializes a new instance of the SeriesValueBase class
SeriesValueBase(Object) | Initializes a new instance of the SeriesValueBase class

See Also

SeriesValueBase Class
SeriesValueBase Members
PerpetuumSoft.Charts Namespace


SeriesValueBase Constructor

[image]

.NET ModelKit Suite ClassReference
SeriesValueBase Constructor
SeriesValueBase Class See Also Send Feedback
Initializes a new instance of the SeriesValueBase class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected SeriesValueBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
SeriesValueBase()

See Also

SeriesValueBase Class
SeriesValueBase Overload
PerpetuumSoft.Charts Namespace


SeriesValueBase Constructor (Double)

[image]

.NET ModelKit Suite ClassReference
SeriesValueBase Constructor (Double)
SeriesValueBase Class See Also Send Feedback
Initializes a new instance of the SeriesValueBase class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected SeriesValueBase(
    double argument
)
Visual Basic (Declaration)
Protected Sub New ( _
    argument As Double _
)
Visual C++
protected:
SeriesValueBase(
    double argument
)

Parameters

argument
Type: System..::.Double

See Also

SeriesValueBase Class
SeriesValueBase Overload
PerpetuumSoft.Charts Namespace


SeriesValueBase Constructor (Object)

[image]

.NET ModelKit Suite ClassReference
SeriesValueBase Constructor (Object)
SeriesValueBase Class See Also Send Feedback
Initializes a new instance of the SeriesValueBase class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected SeriesValueBase(
    Object argument
)
Visual Basic (Declaration)
Protected Sub New ( _
    argument As Object _
)
Visual C++
protected:
SeriesValueBase(
    Object^ argument
)

Parameters

argument
Type: System..::.Object

See Also

SeriesValueBase Class
SeriesValueBase Overload
PerpetuumSoft.Charts Namespace


SeriesValueBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
SeriesValueBase Methods
SeriesValueBase Class See Also Send Feedback

The SeriesValueBase type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of an object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRepresentationObject | Returns an object that represents series value.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueBounds | Returns the bounds of the series values.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sum | Summarizes with the specified series value.
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

SeriesValueBase Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
SeriesValueBase..::.Clone Method
SeriesValueBase Class See Also Send Feedback
Creates a copy of an object.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract SeriesValueBase Clone()
Visual Basic (Declaration)
Public MustOverride Function Clone As SeriesValueBase
Visual C++
public:
virtual SeriesValueBase^ Clone() abstract

See Also

SeriesValueBase Class
PerpetuumSoft.Charts Namespace


GetRepresentationObject Method

[image]

.NET ModelKit Suite ClassReference
SeriesValueBase..::.GetRepresentationObject Method
SeriesValueBase Class See Also Send Feedback
Returns an object that represents series value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public virtual Object GetRepresentationObject()
Visual Basic (Declaration)
Public Overridable Function GetRepresentationObject As Object
Visual C++
public:
virtual Object^ GetRepresentationObject()

See Also

SeriesValueBase Class
PerpetuumSoft.Charts Namespace


GetValueBounds Method

[image]

.NET ModelKit Suite ClassReference
SeriesValueBase..::.GetValueBounds Method
SeriesValueBase Class See Also Send Feedback
Returns the bounds of the series values.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract Bounds GetValueBounds()
Visual Basic (Declaration)
Public MustOverride Function GetValueBounds As Bounds
Visual C++
public:
virtual Bounds GetValueBounds() abstract

See Also

SeriesValueBase Class
PerpetuumSoft.Charts Namespace


Sum Method

[image]

.NET ModelKit Suite ClassReference
SeriesValueBase..::.Sum Method
SeriesValueBase Class See Also Send Feedback
Summarizes with the specified series value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract void Sum(
    SeriesValueBase seriesValue
)
Visual Basic (Declaration)
Public MustOverride Sub Sum ( _
    seriesValue As SeriesValueBase _
)
Visual C++
public:
virtual void Sum(
    SeriesValueBase^ seriesValue
) abstract

Parameters

seriesValue
Type: PerpetuumSoft.Charts..::.SeriesValueBase

See Also

SeriesValueBase Class
PerpetuumSoft.Charts Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
SeriesValueBase..::.ToString Method
SeriesValueBase Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

SeriesValueBase Class
PerpetuumSoft.Charts Namespace


SeriesValueBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
SeriesValueBase Properties
SeriesValueBase Class See Also Send Feedback

The SeriesValueBase type exposes the following members.

Properties

Name | Description
Argument | Gets or sets an argument.
Sort | Gets or sets the sort expression value for series value.
UserData | Gets or sets additional data of the series value.

See Also

SeriesValueBase Class
PerpetuumSoft.Charts Namespace


Argument Property

[image]

.NET ModelKit Suite ClassReference
SeriesValueBase..::.Argument Property
SeriesValueBase Class See Also Send Feedback
Gets or sets an argument.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Object Argument { get; set; }
Visual Basic (Declaration)
Public Property Argument As Object
Visual C++
public:
property Object^ Argument {
    Object^ get ();
    void set (Object^ value);
}

See Also

SeriesValueBase Class
PerpetuumSoft.Charts Namespace


Sort Property

[image]

.NET ModelKit Suite ClassReference
SeriesValueBase..::.Sort Property
SeriesValueBase Class See Also Send Feedback
Gets or sets the sort expression value for series value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Object Sort { get; set; }
Visual Basic (Declaration)
Public Property Sort As Object
Visual C++
public:
property Object^ Sort {
    Object^ get ();
    void set (Object^ value);
}

See Also

SeriesValueBase Class
PerpetuumSoft.Charts Namespace


UserData Property

[image]

.NET ModelKit Suite ClassReference
SeriesValueBase..::.UserData Property
SeriesValueBase Class See Also Send Feedback
Gets or sets additional data of the series value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Object UserData { get; set; }
Visual Basic (Declaration)
Public Property UserData As Object
Visual C++
public:
property Object^ UserData {
    Object^ get ();
    void set (Object^ value);
}

See Also

SeriesValueBase Class
PerpetuumSoft.Charts Namespace


SeriesValueBaseComparer Class

[image]

.NET ModelKit Suite ClassReference
SeriesValueBaseComparer Class
Members See Also Send Feedback
Represent a comparer for series value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class SeriesValueBaseComparer : IComparer
Visual Basic (Declaration)
Public Class SeriesValueBaseComparer _
    Implements IComparer
Visual C++
public ref class SeriesValueBaseComparer : IComparer

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesValueBaseComparer

See Also

SeriesValueBaseComparer Members
PerpetuumSoft.Charts Namespace


SeriesValueBaseComparer Members

[image] [image]

.NET ModelKit Suite ClassReference
SeriesValueBaseComparer Members
SeriesValueBaseComparer Class Constructors Methods See Also Send Feedback

The SeriesValueBaseComparer type exposes the following members.

Constructors

Name | Description
SeriesValueBaseComparer | Initializes a new instance of the SeriesValueBaseComparer class.

Methods

Name | Description
Compare | Implements Compare(Object, Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SeriesValueBaseComparer Class
PerpetuumSoft.Charts Namespace


SeriesValueBaseComparer Constructor

[image]

.NET ModelKit Suite ClassReference
SeriesValueBaseComparer Constructor
SeriesValueBaseComparer Class See Also Send Feedback
Initializes a new instance of the SeriesValueBaseComparer class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesValueBaseComparer(
    bool reverse
)
Visual Basic (Declaration)
Public Sub New ( _
    reverse As Boolean _
)
Visual C++
public:
SeriesValueBaseComparer(
    bool reverse
)

Parameters

reverse
Type: System..::.Boolean

See Also

SeriesValueBaseComparer Class
PerpetuumSoft.Charts Namespace


SeriesValueBaseComparer Methods

[image] [image]

.NET ModelKit Suite ClassReference
SeriesValueBaseComparer Methods
SeriesValueBaseComparer Class See Also Send Feedback

The SeriesValueBaseComparer type exposes the following members.

Methods

Name | Description
Compare | Implements Compare(Object, Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SeriesValueBaseComparer Class
PerpetuumSoft.Charts Namespace


Compare Method

[image]

.NET ModelKit Suite ClassReference
SeriesValueBaseComparer..::.Compare Method
SeriesValueBaseComparer Class See Also Send Feedback
Implements Compare(Object, Object).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public int Compare(
    Object x,
    Object y
)
Visual Basic (Declaration)
Public Function Compare ( _
    x As Object, _
    y As Object _
) As Integer
Visual C++
public:
virtual int Compare(
    Object^ x,
    Object^ y
) sealed

Parameters

x
Type: System..::.Object
y
Type: System..::.Object

Implements

IComparer..::.Compare(Object, Object)

See Also

SeriesValueBaseComparer Class
PerpetuumSoft.Charts Namespace


SeriesValueInfoCollection Class

[image]

.NET ModelKit Suite ClassReference
SeriesValueInfoCollection Class
Members See Also Send Feedback
Represents a collection of SeriesValueInfo objects.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class SeriesValueInfoCollection : CollectionBase
Visual Basic (Declaration)
Public Class SeriesValueInfoCollection _
    Inherits CollectionBase
Visual C++
public ref class SeriesValueInfoCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Charts..::.SeriesValueInfoCollection

See Also

SeriesValueInfoCollection Members
PerpetuumSoft.Charts Namespace


SeriesValueInfoCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
SeriesValueInfoCollection Members
SeriesValueInfoCollection Class Constructors Methods Properties Events See Also Send Feedback

The SeriesValueInfoCollection type exposes the following members.

Constructors

Name | Description
SeriesValueInfoCollection | Initializes a new instance of the SeriesValueInfoCollection class.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Adds elements to a collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Occurs when an element is added to a collection. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Occurs when an element is removed from a collection. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Implements Item[([(Int32])]).
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

Name | Description
CollectionChanged | Represents the method that handles the CollectionChanged event raised when adding elements to or removing elements from a collection.

See Also

SeriesValueInfoCollection Class
PerpetuumSoft.Charts Namespace


SeriesValueInfoCollection Constructor

[image]

.NET ModelKit Suite ClassReference
SeriesValueInfoCollection Constructor
SeriesValueInfoCollection Class See Also Send Feedback
Initializes a new instance of the SeriesValueInfoCollection class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesValueInfoCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SeriesValueInfoCollection()

See Also

SeriesValueInfoCollection Class
PerpetuumSoft.Charts Namespace


SeriesValueInfoCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
SeriesValueInfoCollection Methods
SeriesValueInfoCollection Class See Also Send Feedback

The SeriesValueInfoCollection type exposes the following members.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Adds elements to a collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Occurs when an element is added to a collection. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Occurs when an element is removed from a collection. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SeriesValueInfoCollection Class
PerpetuumSoft.Charts Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
SeriesValueInfoCollection..::.Add Method
SeriesValueInfoCollection Class See Also Send Feedback
Implements Add(Object).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesValueInfo Add(
    SeriesValueInfo value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As SeriesValueInfo _
) As SeriesValueInfo
Visual C++
public:
SeriesValueInfo^ Add(
    SeriesValueInfo^ value
)

Parameters

value
Type: SeriesValueInfo

See Also

SeriesValueInfoCollection Class
PerpetuumSoft.Charts Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
SeriesValueInfoCollection..::.AddRange Method
SeriesValueInfoCollection Class See Also Send Feedback
Adds elements to a collection.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    SeriesValueInfo[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As SeriesValueInfo() _
)
Visual C++
public:
void AddRange(
    array<SeriesValueInfo^>^ values
)

Parameters

values
Type: array< SeriesValueInfo >[]()[]

See Also

SeriesValueInfoCollection Class
PerpetuumSoft.Charts Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
SeriesValueInfoCollection..::.Contains Method
SeriesValueInfoCollection Class See Also Send Feedback
Implements Contains(Object).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    SeriesValueInfo value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As SeriesValueInfo _
) As Boolean
Visual C++
public:
bool Contains(
    SeriesValueInfo^ value
)

Parameters

value
Type: SeriesValueInfo

See Also

SeriesValueInfoCollection Class
PerpetuumSoft.Charts Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
SeriesValueInfoCollection..::.IndexOf Method
SeriesValueInfoCollection Class See Also Send Feedback
Implements IndexOf(Object).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    SeriesValueInfo value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As SeriesValueInfo _
) As Integer
Visual C++
public:
int IndexOf(
    SeriesValueInfo^ value
)

Parameters

value
Type: SeriesValueInfo

See Also

SeriesValueInfoCollection Class
PerpetuumSoft.Charts Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
SeriesValueInfoCollection..::.Insert Method
SeriesValueInfoCollection Class See Also Send Feedback
Implements Insert(Int32, Object).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    SeriesValueInfo value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As SeriesValueInfo _
)
Visual C++
public:
void Insert(
    int index,
    SeriesValueInfo^ value
)

Parameters

index
Type: System..::.Int32
value
Type: SeriesValueInfo

See Also

SeriesValueInfoCollection Class
PerpetuumSoft.Charts Namespace


OnInsertComplete Method

[image]

.NET ModelKit Suite ClassReference
SeriesValueInfoCollection..::.OnInsertComplete Method
SeriesValueInfoCollection Class See Also Send Feedback
Occurs when an element is added to a collection.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsertComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsertComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsertComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

SeriesValueInfoCollection Class
PerpetuumSoft.Charts Namespace


OnRemoveComplete Method

[image]

.NET ModelKit Suite ClassReference
SeriesValueInfoCollection..::.OnRemoveComplete Method
SeriesValueInfoCollection Class See Also Send Feedback
Occurs when an element is removed from a collection.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnRemoveComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemoveComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemoveComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

SeriesValueInfoCollection Class
PerpetuumSoft.Charts Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
SeriesValueInfoCollection..::.Remove Method
SeriesValueInfoCollection Class See Also Send Feedback
Implements Remove(Object).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    SeriesValueInfo value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As SeriesValueInfo _
)
Visual C++
public:
void Remove(
    SeriesValueInfo^ value
)

Parameters

value
Type: SeriesValueInfo

See Also

SeriesValueInfoCollection Class
PerpetuumSoft.Charts Namespace


SeriesValueInfoCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
SeriesValueInfoCollection Properties
SeriesValueInfoCollection Class See Also Send Feedback

The SeriesValueInfoCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Implements Item[([(Int32])]).
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

SeriesValueInfoCollection Class
PerpetuumSoft.Charts Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
SeriesValueInfoCollection..::.Item Property
SeriesValueInfoCollection Class See Also Send Feedback
Implements Item[([(Int32])]).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SeriesValueInfo this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As SeriesValueInfo
Visual C++
public:
property SeriesValueInfo^ default[int index] {
    SeriesValueInfo^ get (int index);
    void set (int index, SeriesValueInfo^ value);
}

Parameters

index
Type: System..::.Int32

See Also

SeriesValueInfoCollection Class
PerpetuumSoft.Charts Namespace


SeriesValueInfoCollection Events

[image] [image]

.NET ModelKit Suite ClassReference
SeriesValueInfoCollection Events
SeriesValueInfoCollection Class See Also Send Feedback

The SeriesValueInfoCollection type exposes the following members.

Events

Name | Description
CollectionChanged | Represents the method that handles the CollectionChanged event raised when adding elements to or removing elements from a collection.

See Also

SeriesValueInfoCollection Class
PerpetuumSoft.Charts Namespace


CollectionChanged Event

[image]

.NET ModelKit Suite ClassReference
SeriesValueInfoCollection..::.CollectionChanged Event
SeriesValueInfoCollection Class See Also Send Feedback
Represents the method that handles the CollectionChanged event raised when adding elements to or removing elements from a collection.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler CollectionChanged
Visual Basic (Declaration)
Public Event CollectionChanged As EventHandler
Visual C++
public:
 event EventHandler^ CollectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

SeriesValueInfoCollection Class
PerpetuumSoft.Charts Namespace


SeriesView Class

[image]

.NET ModelKit Suite ClassReference
SeriesView Class
Members See Also Send Feedback
Represents a base class for all series views dispalying the series data.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract class SeriesView
Visual Basic (Declaration)
Public MustInherit Class SeriesView
Visual C++
public ref class SeriesView abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.PieSeriesView

See Also

SeriesView Members
PerpetuumSoft.Charts Namespace


SeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
SeriesView Members
SeriesView Class Constructors Methods Properties Events See Also Send Feedback

The SeriesView type exposes the following members.

Constructors

Name | Description
SeriesView | Initializes a new instance of the SeriesView class

Methods

Name | Description
Clone | Creates an object copy.
CreateElements | Creates elements representing a chart.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type.
GetChartAreaPalette | Returns palette specified in the ChartArea.
GetCurrentElementIndex | Returns index of the current series.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Returns the center of the mark with the specified value.
GetNextElementIndex | Returns index of the next series.
GetNotPaintedSeries | Returns the array of unpainted series of the specified type.
GetPaletteColor | Returns the Color specified in the palette.
GetPaletteFill | Returns the Fill specified in the palette.
GetPaletteStroke | Returns the Stroke specified in the palette.
GetSeries | Overloaded.
GetSeriesValueType | Returns the type of the series values.
GetSideIndent | Gets indents on the scale.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePosition | Returns a point that corresponds to the specified value.
IsValidSeries | Returns a value that indicates that the series can be painted with the help of the specified SeriesView.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event.
PaintLegendBadge | Paints a legend badge for the series.
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image.
PaintLegendValueBadge | Paints a legend badge for the series value.
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image.
ResetElementIndex | Resets index of the series.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over.
IsValueLegendItemSupported | Returns a value that shows whether this chart type is displayed in the legend by the values.
Series | Gets or sets the series displayed.
Stroke | Gets or sets Stroke object that is used to trace.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state.

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


SeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
SeriesView Constructor
SeriesView Class See Also Send Feedback
Initializes a new instance of the SeriesView class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected SeriesView()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
SeriesView()

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


SeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
SeriesView Methods
SeriesView Class See Also Send Feedback

The SeriesView type exposes the following members.

Methods

Name | Description
Clone | Creates an object copy.
CreateElements | Creates elements representing a chart.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type.
GetChartAreaPalette | Returns palette specified in the ChartArea.
GetCurrentElementIndex | Returns index of the current series.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Returns the center of the mark with the specified value.
GetNextElementIndex | Returns index of the next series.
GetNotPaintedSeries | Returns the array of unpainted series of the specified type.
GetPaletteColor | Returns the Color specified in the palette.
GetPaletteFill | Returns the Fill specified in the palette.
GetPaletteStroke | Returns the Stroke specified in the palette.
GetSeries | Overloaded.
GetSeriesValueType | Returns the type of the series values.
GetSideIndent | Gets indents on the scale.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePosition | Returns a point that corresponds to the specified value.
IsValidSeries | Returns a value that indicates that the series can be painted with the help of the specified SeriesView.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event.
PaintLegendBadge | Paints a legend badge for the series.
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image.
PaintLegendValueBadge | Paints a legend badge for the series value.
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image.
ResetElementIndex | Resets index of the series.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.Clone Method
SeriesView Class See Also Send Feedback
Creates an object copy.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract SeriesView Clone()
Visual Basic (Declaration)
Public MustOverride Function Clone As SeriesView
Visual C++
public:
virtual SeriesView^ Clone() abstract

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


CreateElements Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.CreateElements Method
SeriesView Class See Also Send Feedback
Creates elements representing a chart.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract void CreateElements(
    ChartArea area
)
Visual Basic (Declaration)
Public MustOverride Sub CreateElements ( _
    area As ChartArea _
)
Visual C++
public:
virtual void CreateElements(
    ChartArea^ area
) abstract

Parameters

area
Type: PerpetuumSoft.Charts..::.ChartArea

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


GetBounds Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.GetBounds Method
SeriesView Class See Also Send Feedback
Returns chart bounds for the axis of the specified type.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public virtual Bounds GetBounds(
    Series series,
    AxisType axisType,
    Series[] allSeries
)
Visual Basic (Declaration)
Public Overridable Function GetBounds ( _
    series As Series, _
    axisType As AxisType, _
    allSeries As Series() _
) As Bounds
Visual C++
public:
virtual Bounds GetBounds(
    Series^ series,
    AxisType axisType,
    array<Series^>^ allSeries
)

Parameters

series
Type: PerpetuumSoft.Charts..::.Series
axisType
Type: PerpetuumSoft.Charts..::.AxisType
allSeries
Type: array< PerpetuumSoft.Charts..::.Series >[]()[]

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


GetChartAreaPalette Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.GetChartAreaPalette Method
SeriesView Class See Also Send Feedback
Returns palette specified in the ChartArea.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Palette GetChartAreaPalette()
Visual Basic (Declaration)
Protected Function GetChartAreaPalette As Palette
Visual C++
protected:
Palette^ GetChartAreaPalette()

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


GetCurrentElementIndex Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.GetCurrentElementIndex Method
SeriesView Class See Also Send Feedback
Returns index of the current series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double GetCurrentElementIndex()
Visual Basic (Declaration)
Public Function GetCurrentElementIndex As Double
Visual C++
public:
double GetCurrentElementIndex()

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


GetLabelPosition Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.GetLabelPosition Method
SeriesView Class See Also Send Feedback
Returns the center of the mark with the specified value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract Vector GetLabelPosition(
    SeriesValueBase seriesValue,
    LabelsPosition labelPosition,
    Vector itemSize,
    double distance
)
Visual Basic (Declaration)
Public MustOverride Function GetLabelPosition ( _
    seriesValue As SeriesValueBase, _
    labelPosition As LabelsPosition, _
    itemSize As Vector, _
    distance As Double _
) As Vector
Visual C++
public:
virtual Vector GetLabelPosition(
    SeriesValueBase^ seriesValue,
    LabelsPosition labelPosition,
    Vector itemSize,
    double distance
) abstract

Parameters

seriesValue
Type: PerpetuumSoft.Charts..::.SeriesValueBase
labelPosition
Type: PerpetuumSoft.Charts..::.LabelsPosition
itemSize
Type: PerpetuumSoft.Framework.Drawing..::.Vector
distance
Type: System..::.Double

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


GetNextElementIndex Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.GetNextElementIndex Method
SeriesView Class See Also Send Feedback
Returns index of the next series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public int GetNextElementIndex()
Visual Basic (Declaration)
Public Function GetNextElementIndex As Integer
Visual C++
public:
int GetNextElementIndex()

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


GetNotPaintedSeries Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.GetNotPaintedSeries Method
SeriesView Class See Also Send Feedback
Returns the array of unpainted series of the specified type.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Series[] GetNotPaintedSeries(
    ChartArea area,
    Type seriesViewType
)
Visual Basic (Declaration)
Protected Function GetNotPaintedSeries ( _
    area As ChartArea, _
    seriesViewType As Type _
) As Series()
Visual C++
protected:
array<Series^>^ GetNotPaintedSeries(
    ChartArea^ area,
    Type^ seriesViewType
)

Parameters

area
Type: PerpetuumSoft.Charts..::.ChartArea
seriesViewType
Type: System..::.Type

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


GetPaletteColor Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.GetPaletteColor Method
SeriesView Class See Also Send Feedback
Returns the Color specified in the palette.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Color GetPaletteColor(
    int index
)
Visual Basic (Declaration)
Protected Function GetPaletteColor ( _
    index As Integer _
) As Color
Visual C++
protected:
Color GetPaletteColor(
    int index
)

Parameters

index
Type: System..::.Int32

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


GetPaletteFill Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.GetPaletteFill Method
SeriesView Class See Also Send Feedback
Returns the Fill specified in the palette.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Fill GetPaletteFill(
    int index
)
Visual Basic (Declaration)
Protected Function GetPaletteFill ( _
    index As Integer _
) As Fill
Visual C++
protected:
Fill^ GetPaletteFill(
    int index
)

Parameters

index
Type: System..::.Int32

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


GetPaletteStroke Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.GetPaletteStroke Method
SeriesView Class See Also Send Feedback
Returns the Stroke specified in the palette.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Stroke GetPaletteStroke(
    int index
)
Visual Basic (Declaration)
Protected Function GetPaletteStroke ( _
    index As Integer _
) As Stroke
Visual C++
protected:
Stroke^ GetPaletteStroke(
    int index
)

Parameters

index
Type: System..::.Int32

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
SeriesView..::.GetSeries Method
SeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type.
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type.

See Also

SeriesView Class
SeriesView Members
PerpetuumSoft.Charts Namespace


GetSeries Method (ChartArea, Type)

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.GetSeries Method (ChartArea, Type)
SeriesView Class See Also Send Feedback
Returns series array of the specified type.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Series[] GetSeries(
    ChartArea area,
    Type seriesViewType
)
Visual Basic (Declaration)
Protected Function GetSeries ( _
    area As ChartArea, _
    seriesViewType As Type _
) As Series()
Visual C++
protected:
array<Series^>^ GetSeries(
    ChartArea^ area,
    Type^ seriesViewType
)

Parameters

area
Type: PerpetuumSoft.Charts..::.ChartArea
seriesViewType
Type: System..::.Type

See Also

SeriesView Class
GetSeries Overload
PerpetuumSoft.Charts Namespace


GetSeries Method (Series[], Type)

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.GetSeries Method (array<Series>[]()[], Type)
SeriesView Class See Also Send Feedback
Returns series array of the specified type.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Series[] GetSeries(
    Series[] series,
    Type seriesViewType
)
Visual Basic (Declaration)
Protected Function GetSeries ( _
    series As Series(), _
    seriesViewType As Type _
) As Series()
Visual C++
protected:
array<Series^>^ GetSeries(
    array<Series^>^ series,
    Type^ seriesViewType
)

Parameters

series
Type: array< PerpetuumSoft.Charts..::.Series >[]()[]
seriesViewType
Type: System..::.Type

See Also

SeriesView Class
GetSeries Overload
PerpetuumSoft.Charts Namespace


GetSeriesValueType Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.GetSeriesValueType Method
SeriesView Class See Also Send Feedback
Returns the type of the series values.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract Type GetSeriesValueType()
Visual Basic (Declaration)
Public MustOverride Function GetSeriesValueType As Type
Visual C++
public:
virtual Type^ GetSeriesValueType() abstract

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


GetSideIndent Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.GetSideIndent Method
SeriesView Class See Also Send Feedback
Gets indents on the scale.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract double GetSideIndent()
Visual Basic (Declaration)
Public MustOverride Function GetSideIndent As Double
Visual C++
public:
virtual double GetSideIndent() abstract

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


GetValuePosition Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.GetValuePosition Method
SeriesView Class See Also Send Feedback
Returns a point that corresponds to the specified value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract Vector GetValuePosition(
    SeriesValueBase seriesValue,
    LabelsPosition labelPosition
)
Visual Basic (Declaration)
Public MustOverride Function GetValuePosition ( _
    seriesValue As SeriesValueBase, _
    labelPosition As LabelsPosition _
) As Vector
Visual C++
public:
virtual Vector GetValuePosition(
    SeriesValueBase^ seriesValue,
    LabelsPosition labelPosition
) abstract

Parameters

seriesValue
Type: PerpetuumSoft.Charts..::.SeriesValueBase
labelPosition
Type: PerpetuumSoft.Charts..::.LabelsPosition

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


IsValidSeries Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.IsValidSeries Method
SeriesView Class See Also Send Feedback
Returns a value that indicates that the series can be painted with the help of the specified SeriesView.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected static bool IsValidSeries(
    Series series,
    Type seriesViewType
)
Visual Basic (Declaration)
Protected Shared Function IsValidSeries ( _
    series As Series, _
    seriesViewType As Type _
) As Boolean
Visual C++
protected:
static bool IsValidSeries(
    Series^ series,
    Type^ seriesViewType
)

Parameters

series
Type: PerpetuumSoft.Charts..::.Series
seriesViewType
Type: System..::.Type

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


OnSeriesViewChanged Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.OnSeriesViewChanged Method
SeriesView Class See Also Send Feedback
Raises the SeriesViewChanged event.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected void OnSeriesViewChanged(
    EventArgs args
)
Visual Basic (Declaration)
Protected Sub OnSeriesViewChanged ( _
    args As EventArgs _
)
Visual C++
protected:
void OnSeriesViewChanged(
    EventArgs^ args
)

Parameters

args
Type: System..::.EventArgs

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


PaintLegendBadge Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.PaintLegendBadge Method
SeriesView Class See Also Send Feedback
Paints a legend badge for the series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract void PaintLegendBadge(
    GraphicStream graphicStream,
    VectorRectangle area
)
Visual Basic (Declaration)
Public MustOverride Sub PaintLegendBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle _
)
Visual C++
public:
virtual void PaintLegendBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area
) abstract

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


PaintLegendBadgeToImage Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.PaintLegendBadgeToImage Method
SeriesView Class See Also Send Feedback
Paints a legend badge for the series to a specified image.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void PaintLegendBadgeToImage(
    Image image
)
Visual Basic (Declaration)
Public Sub PaintLegendBadgeToImage ( _
    image As Image _
)
Visual C++
public:
void PaintLegendBadgeToImage(
    Image^ image
)

Parameters

image
Type: System.Drawing..::.Image

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


PaintLegendValueBadge Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.PaintLegendValueBadge Method
SeriesView Class See Also Send Feedback
Paints a legend badge for the series value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract void PaintLegendValueBadge(
    GraphicStream graphicStream,
    VectorRectangle area,
    int seriesValueIndex
)
Visual Basic (Declaration)
Public MustOverride Sub PaintLegendValueBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle, _
    seriesValueIndex As Integer _
)
Visual C++
public:
virtual void PaintLegendValueBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area,
    int seriesValueIndex
) abstract

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
seriesValueIndex
Type: System..::.Int32

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


PaintLegendValueBadgeToImage Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.PaintLegendValueBadgeToImage Method
SeriesView Class See Also Send Feedback
Paints a legend badge for the series value to specified image.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void PaintLegendValueBadgeToImage(
    Image image,
    int seriesValueIndex
)
Visual Basic (Declaration)
Public Sub PaintLegendValueBadgeToImage ( _
    image As Image, _
    seriesValueIndex As Integer _
)
Visual C++
public:
void PaintLegendValueBadgeToImage(
    Image^ image,
    int seriesValueIndex
)

Parameters

image
Type: System.Drawing..::.Image
seriesValueIndex
Type: System..::.Int32

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


ResetElementIndex Method

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.ResetElementIndex Method
SeriesView Class See Also Send Feedback
Resets index of the series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void ResetElementIndex()
Visual Basic (Declaration)
Public Sub ResetElementIndex
Visual C++
public:
void ResetElementIndex()

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


SeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
SeriesView Properties
SeriesView Class See Also Send Feedback

The SeriesView type exposes the following members.

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over.
IsValueLegendItemSupported | Returns a value that shows whether this chart type is displayed in the legend by the values.
Series | Gets or sets the series displayed.
Stroke | Gets or sets Stroke object that is used to trace.

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.Fill Property
SeriesView Class See Also Send Feedback
Gets or sets Fill object that is used to paint over.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


IsValueLegendItemSupported Property

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.IsValueLegendItemSupported Property
SeriesView Class See Also Send Feedback
Returns a value that shows whether this chart type is displayed in the legend by the values.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract bool IsValueLegendItemSupported { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property IsValueLegendItemSupported As Boolean
Visual C++
public:
virtual property bool IsValueLegendItemSupported {
    bool get () abstract;
}

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


Series Property

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.Series Property
SeriesView Class See Also Send Feedback
Gets or sets the series displayed.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Series Series { get; set; }
Visual Basic (Declaration)
Public Property Series As Series
Visual C++
public:
property Series^ Series {
    Series^ get ();
    void set (Series^ value);
}

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


Stroke Property

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.Stroke Property
SeriesView Class See Also Send Feedback
Gets or sets Stroke object that is used to trace.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Stroke Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Stroke
Visual C++
public:
property Stroke^ Stroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


SeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
SeriesView Events
SeriesView Class See Also Send Feedback

The SeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state.

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


SeriesViewChanged Event

[image]

.NET ModelKit Suite ClassReference
SeriesView..::.SeriesViewChanged Event
SeriesView Class See Also Send Feedback
Occurs after the change of an object state.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler SeriesViewChanged
Visual Basic (Declaration)
Public Event SeriesViewChanged As EventHandler
Visual C++
public:
 event EventHandler^ SeriesViewChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

SeriesView Class
PerpetuumSoft.Charts Namespace


SharpAngleAxisArrow Class

[image]

.NET ModelKit Suite ClassReference
SharpAngleAxisArrow Class
Members See Also Send Feedback
Represents axis arrow with a sharp angle.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class SharpAngleAxisArrow : AxisArrow
Visual Basic (Declaration)
Public Class SharpAngleAxisArrow _
    Inherits AxisArrow
Visual C++
public ref class SharpAngleAxisArrow : public AxisArrow

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.AxisArrow
PerpetuumSoft.Charts..::.SharpAngleAxisArrow

See Also

SharpAngleAxisArrow Members
PerpetuumSoft.Charts Namespace


SharpAngleAxisArrow Members

[image] [image]

.NET ModelKit Suite ClassReference
SharpAngleAxisArrow Members
SharpAngleAxisArrow Class Constructors Methods Properties See Also Send Feedback

The SharpAngleAxisArrow type exposes the following members.

Constructors

Name | Description
SharpAngleAxisArrow | Initializes a new instance of the SharpAngleAxisArrow class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSize | Overridden. See GetSize(AxisDirection). (Overrides AxisArrow..::.GetSize(AxisDirection).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Paint | Overridden. See Paint(GraphicStream, Vector, AxisDirection, Stroke, Boolean). (Overrides AxisArrow..::.Paint(GraphicStream, Vector, AxisDirection, Stroke, Boolean).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Size | Gets or sets shape size.

See Also

SharpAngleAxisArrow Class
PerpetuumSoft.Charts Namespace


SharpAngleAxisArrow Constructor

[image]

.NET ModelKit Suite ClassReference
SharpAngleAxisArrow Constructor
SharpAngleAxisArrow Class See Also Send Feedback
Initializes a new instance of the SharpAngleAxisArrow class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SharpAngleAxisArrow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SharpAngleAxisArrow()

See Also

SharpAngleAxisArrow Class
PerpetuumSoft.Charts Namespace


SharpAngleAxisArrow Methods

[image] [image]

.NET ModelKit Suite ClassReference
SharpAngleAxisArrow Methods
SharpAngleAxisArrow Class See Also Send Feedback

The SharpAngleAxisArrow type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSize | Overridden. See GetSize(AxisDirection). (Overrides AxisArrow..::.GetSize(AxisDirection).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Paint | Overridden. See Paint(GraphicStream, Vector, AxisDirection, Stroke, Boolean). (Overrides AxisArrow..::.Paint(GraphicStream, Vector, AxisDirection, Stroke, Boolean).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SharpAngleAxisArrow Class
PerpetuumSoft.Charts Namespace


GetSize Method

[image]

.NET ModelKit Suite ClassReference
SharpAngleAxisArrow..::.GetSize Method
SharpAngleAxisArrow Class See Also Send Feedback
Overridden. See GetSize(AxisDirection).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Vector GetSize(
    AxisDirection direction
)
Visual Basic (Declaration)
Public Overrides Function GetSize ( _
    direction As AxisDirection _
) As Vector
Visual C++
public:
virtual Vector GetSize(
    AxisDirection direction
) override

Parameters

direction
Type: PerpetuumSoft.Charts..::.AxisDirection

See Also

SharpAngleAxisArrow Class
PerpetuumSoft.Charts Namespace


Paint Method

[image]

.NET ModelKit Suite ClassReference
SharpAngleAxisArrow..::.Paint Method
SharpAngleAxisArrow Class See Also Send Feedback
Overridden. See Paint(GraphicStream, Vector, AxisDirection, Stroke, Boolean).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void Paint(
    GraphicStream g,
    Vector startPoint,
    AxisDirection direction,
    Stroke stroke,
    bool reverse
)
Visual Basic (Declaration)
Public Overrides Sub Paint ( _
    g As GraphicStream, _
    startPoint As Vector, _
    direction As AxisDirection, _
    stroke As Stroke, _
    reverse As Boolean _
)
Visual C++
public:
virtual void Paint(
    GraphicStream^ g,
    Vector startPoint,
    AxisDirection direction,
    Stroke^ stroke,
    bool reverse
) override

Parameters

g
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
startPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
direction
Type: PerpetuumSoft.Charts..::.AxisDirection
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
reverse
Type: System..::.Boolean

See Also

SharpAngleAxisArrow Class
PerpetuumSoft.Charts Namespace


SharpAngleAxisArrow Properties

[image] [image]

.NET ModelKit Suite ClassReference
SharpAngleAxisArrow Properties
SharpAngleAxisArrow Class See Also Send Feedback

The SharpAngleAxisArrow type exposes the following members.

Properties

Name | Description
Size | Gets or sets shape size.

See Also

SharpAngleAxisArrow Class
PerpetuumSoft.Charts Namespace


Size Property

[image]

.NET ModelKit Suite ClassReference
SharpAngleAxisArrow..::.Size Property
SharpAngleAxisArrow Class See Also Send Feedback
Gets or sets shape size.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Vector Size { get; set; }
Visual Basic (Declaration)
Public Property Size As Vector
Visual C++
public:
property Vector Size {
    Vector get ();
    void set (Vector value);
}

See Also

SharpAngleAxisArrow Class
PerpetuumSoft.Charts Namespace


SimpleAxisSeriesView Class

[image]

.NET ModelKit Suite ClassReference
SimpleAxisSeriesView Class
Members See Also Send Feedback
Represents a base class for SeriesView which builds a chart along axes independent of other series with the same SeriesView.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract class SimpleAxisSeriesView : AxisSeriesView
Visual Basic (Declaration)
Public MustInherit Class SimpleAxisSeriesView _
    Inherits AxisSeriesView
Visual C++
public ref class SimpleAxisSeriesView abstract : public AxisSeriesView

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.SimpleAxisSeriesView
PerpetuumSoft.Charts..::.FinancialSeriesViewBase
PerpetuumSoft.Charts..::.LineSeriesViewBase
PerpetuumSoft.Charts..::.PointSeriesView
PerpetuumSoft.Charts..::.SplineSeriesViewBase

See Also

SimpleAxisSeriesView Members
PerpetuumSoft.Charts Namespace


SimpleAxisSeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
SimpleAxisSeriesView Members
SimpleAxisSeriesView Class Constructors Methods Properties Events See Also Send Feedback

The SimpleAxisSeriesView type exposes the following members.

Constructors

Name | Description
SimpleAxisSeriesView | Initializes a new instance of the SimpleAxisSeriesView class

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Creates an object copy. (Inherited from SeriesView.)
CreateElements | Overridden. See CreateElements(ChartArea). (Overrides SeriesView..::.CreateElements(ChartArea).)
CreateElementsForSeries | Creates array of elements which represent a chart of the specified series.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Gets indents on the scale. (Inherited from SeriesView.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Paints a legend badge for the series. (Inherited from SeriesView.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Paints a legend badge for the series value. (Inherited from SeriesView.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Returns a value that shows whether this chart type is displayed in the legend by the values. (Inherited from SeriesView.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

SimpleAxisSeriesView Class
PerpetuumSoft.Charts Namespace


SimpleAxisSeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
SimpleAxisSeriesView Constructor
SimpleAxisSeriesView Class See Also Send Feedback
Initializes a new instance of the SimpleAxisSeriesView class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected SimpleAxisSeriesView()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
SimpleAxisSeriesView()

See Also

SimpleAxisSeriesView Class
PerpetuumSoft.Charts Namespace


SimpleAxisSeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
SimpleAxisSeriesView Methods
SimpleAxisSeriesView Class See Also Send Feedback

The SimpleAxisSeriesView type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Creates an object copy. (Inherited from SeriesView.)
CreateElements | Overridden. See CreateElements(ChartArea). (Overrides SeriesView..::.CreateElements(ChartArea).)
CreateElementsForSeries | Creates array of elements which represent a chart of the specified series.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Gets indents on the scale. (Inherited from SeriesView.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Paints a legend badge for the series. (Inherited from SeriesView.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Paints a legend badge for the series value. (Inherited from SeriesView.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleAxisSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElements Method

[image]

.NET ModelKit Suite ClassReference
SimpleAxisSeriesView..::.CreateElements Method
SimpleAxisSeriesView Class See Also Send Feedback
Overridden. See CreateElements(ChartArea).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void CreateElements(
    ChartArea area
)
Visual Basic (Declaration)
Public Overrides Sub CreateElements ( _
    area As ChartArea _
)
Visual C++
public:
virtual void CreateElements(
    ChartArea^ area
) override

Parameters

area
Type: PerpetuumSoft.Charts..::.ChartArea

See Also

SimpleAxisSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElementsForSeries Method

[image]

.NET ModelKit Suite ClassReference
SimpleAxisSeriesView..::.CreateElementsForSeries Method
SimpleAxisSeriesView Class See Also Send Feedback
Creates array of elements which represent a chart of the specified series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected abstract void CreateElementsForSeries(
    Series series
)
Visual Basic (Declaration)
Protected MustOverride Sub CreateElementsForSeries ( _
    series As Series _
)
Visual C++
protected:
virtual void CreateElementsForSeries(
    Series^ series
) abstract

Parameters

series
Type: PerpetuumSoft.Charts..::.Series

See Also

SimpleAxisSeriesView Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleAxisSeriesView..::.GetSeries Method
SimpleAxisSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

SimpleAxisSeriesView Class
SimpleAxisSeriesView Members
PerpetuumSoft.Charts Namespace


SimpleAxisSeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
SimpleAxisSeriesView Properties
SimpleAxisSeriesView Class See Also Send Feedback

The SimpleAxisSeriesView type exposes the following members.

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Returns a value that shows whether this chart type is displayed in the legend by the values. (Inherited from SeriesView.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

See Also

SimpleAxisSeriesView Class
PerpetuumSoft.Charts Namespace


SimpleAxisSeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
SimpleAxisSeriesView Events
SimpleAxisSeriesView Class See Also Send Feedback

The SimpleAxisSeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

SimpleAxisSeriesView Class
PerpetuumSoft.Charts Namespace


SimplePalette Class

[image]

.NET ModelKit Suite ClassReference
SimplePalette Class
Members See Also Send Feedback
Represents a base class for palettes.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract class SimplePalette : Palette
Visual Basic (Declaration)
Public MustInherit Class SimplePalette _
    Inherits Palette
Visual C++
public ref class SimplePalette abstract : public Palette

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.Palette
PerpetuumSoft.Charts..::.SimplePalette
PerpetuumSoft.Charts..::.ColoredPalette
PerpetuumSoft.Charts..::.PaletteBlackAndWhite

See Also

SimplePalette Members
PerpetuumSoft.Charts Namespace


SimplePalette Members

[image] [image]

.NET ModelKit Suite ClassReference
SimplePalette Members
SimplePalette Class Constructors Methods Events See Also Send Feedback

The SimplePalette type exposes the following members.

Constructors

Name | Description
SimplePalette | Initializes a new instance of the SimplePalette class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Returns one of the colors available by its index. (Inherited from Palette.)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Overrides Palette..::.GetLineStroke(Color, Double, Int32).)
GetShape | Overridden. See GetShape(Int32). (Overrides Palette..::.GetShape(Int32).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

SimplePalette Class
PerpetuumSoft.Charts Namespace


SimplePalette Constructor

[image]

.NET ModelKit Suite ClassReference
SimplePalette Constructor
SimplePalette Class See Also Send Feedback
Initializes a new instance of the SimplePalette class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected SimplePalette()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
SimplePalette()

See Also

SimplePalette Class
PerpetuumSoft.Charts Namespace


SimplePalette Methods

[image] [image]

.NET ModelKit Suite ClassReference
SimplePalette Methods
SimplePalette Class See Also Send Feedback

The SimplePalette type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Returns one of the colors available by its index. (Inherited from Palette.)
GetFill | Returns of the fills available by its index. (Inherited from Palette.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLineStroke | Overridden. See GetLineStroke(Color, Double, Int32). (Overrides Palette..::.GetLineStroke(Color, Double, Int32).)
GetShape | Overridden. See GetShape(Int32). (Overrides Palette..::.GetShape(Int32).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPaletteChanged | Raises the PaletteChanged event. (Inherited from Palette.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimplePalette Class
PerpetuumSoft.Charts Namespace


GetLineStroke Method

[image]

.NET ModelKit Suite ClassReference
SimplePalette..::.GetLineStroke Method
SimplePalette Class See Also Send Feedback
Overridden. See GetLineStroke(Color, Double, Int32).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Stroke GetLineStroke(
    Color color,
    double width,
    int index
)
Visual Basic (Declaration)
Public Overrides Function GetLineStroke ( _
    color As Color, _
    width As Double, _
    index As Integer _
) As Stroke
Visual C++
public:
virtual Stroke^ GetLineStroke(
    Color color,
    double width,
    int index
) override

Parameters

color
Type: System.Drawing..::.Color
width
Type: System..::.Double
index
Type: System..::.Int32

See Also

SimplePalette Class
PerpetuumSoft.Charts Namespace


GetShape Method

[image]

.NET ModelKit Suite ClassReference
SimplePalette..::.GetShape Method
SimplePalette Class See Also Send Feedback
Overridden. See GetShape(Int32).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override ShapeBase GetShape(
    int index
)
Visual Basic (Declaration)
Public Overrides Function GetShape ( _
    index As Integer _
) As ShapeBase
Visual C++
public:
virtual ShapeBase^ GetShape(
    int index
) override

Parameters

index
Type: System..::.Int32

See Also

SimplePalette Class
PerpetuumSoft.Charts Namespace


SimplePalette Events

[image] [image]

.NET ModelKit Suite ClassReference
SimplePalette Events
SimplePalette Class See Also Send Feedback

The SimplePalette type exposes the following members.

Events

Name | Description
PaletteChanged | Occurs after the palette has been changed. (Inherited from Palette.)

See Also

SimplePalette Class
PerpetuumSoft.Charts Namespace


SortingType Enumeration

[image]

.NET ModelKit Suite ClassReference
SortingType Enumeration
See Also Send Feedback
Enumerates sorting type.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public enum SortingType
Visual Basic (Declaration)
Public Enumeration SortingType
Visual C++
public enum class SortingType

Members

Member name | Description
Ascending | Specifies ascending sorting.
Descending | Specifies descending sorting.
None | Specifies no sorting.

See Also

PerpetuumSoft.Charts Namespace


SplineAreaElement Class

[image]

.NET ModelKit Suite ClassReference
SplineAreaElement Class
Members See Also Send Feedback
Represents an element, spline area.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class SplineAreaElement : Element
Visual Basic (Declaration)
Public Class SplineAreaElement _
    Inherits Element
Visual C++
public ref class SplineAreaElement : public Element

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Charts..::.SplineAreaElement

See Also

SplineAreaElement Members
PerpetuumSoft.Charts Namespace


SplineAreaElement Members

[image] [image]

.NET ModelKit Suite ClassReference
SplineAreaElement Members
SplineAreaElement Class Constructors Methods Properties Events See Also Send Feedback

The SplineAreaElement type exposes the following members.

Constructors

Name | Description
SplineAreaElement | Initializes a new instance of the SplineAreaElement class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

SplineAreaElement Class
PerpetuumSoft.Charts Namespace


SplineAreaElement Constructor

[image]

.NET ModelKit Suite ClassReference
SplineAreaElement Constructor
SplineAreaElement Class See Also Send Feedback
Initializes a new instance of the SplineAreaElement class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SplineAreaElement(
    Vector[] points,
    Vector startPoint,
    Vector endPoint
)
Visual Basic (Declaration)
Public Sub New ( _
    points As Vector(), _
    startPoint As Vector, _
    endPoint As Vector _
)
Visual C++
public:
SplineAreaElement(
    array<Vector>^ points,
    Vector startPoint,
    Vector endPoint
)

Parameters

points
Type: array< PerpetuumSoft.Framework.Drawing..::.Vector >[]()[]
startPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
endPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

SplineAreaElement Class
PerpetuumSoft.Charts Namespace


SplineAreaElement Methods

[image] [image]

.NET ModelKit Suite ClassReference
SplineAreaElement Methods
SplineAreaElement Class See Also Send Feedback

The SplineAreaElement type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SplineAreaElement Class
PerpetuumSoft.Charts Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
SplineAreaElement..::.Dispose Method
SplineAreaElement Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

SplineAreaElement Class
SplineAreaElement Members
PerpetuumSoft.Charts Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
SplineAreaElement..::.GetHitTest Method
SplineAreaElement Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

SplineAreaElement Class
PerpetuumSoft.Charts Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
SplineAreaElement..::.GetStyle Method
SplineAreaElement Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

SplineAreaElement Class
SplineAreaElement Members
PerpetuumSoft.Charts Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
SplineAreaElement..::.Invalidate Method
SplineAreaElement Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

SplineAreaElement Class
SplineAreaElement Members
PerpetuumSoft.Charts Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
SplineAreaElement..::.OnPaint Method
SplineAreaElement Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

SplineAreaElement Class
SplineAreaElement Members
PerpetuumSoft.Charts Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
SplineAreaElement..::.OnPaint Method (PaintArguments, Fill, Stroke)
SplineAreaElement Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

SplineAreaElement Class
OnPaint Overload
PerpetuumSoft.Charts Namespace


SplineAreaElement Properties

[image] [image]

.NET ModelKit Suite ClassReference
SplineAreaElement Properties
SplineAreaElement Class See Also Send Feedback

The SplineAreaElement type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

SplineAreaElement Class
PerpetuumSoft.Charts Namespace


SplineAreaElement Events

[image] [image]

.NET ModelKit Suite ClassReference
SplineAreaElement Events
SplineAreaElement Class See Also Send Feedback

The SplineAreaElement type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

SplineAreaElement Class
PerpetuumSoft.Charts Namespace


SplineAreaSeriesView Class

[image]

.NET ModelKit Suite ClassReference
SplineAreaSeriesView Class
Members See Also Send Feedback
Represents series view to display series data in the form of an area limited by spline.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class SplineAreaSeriesView : SplineSeriesViewBase
Visual Basic (Declaration)
Public Class SplineAreaSeriesView _
    Inherits SplineSeriesViewBase
Visual C++
public ref class SplineAreaSeriesView : public SplineSeriesViewBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.SimpleAxisSeriesView
PerpetuumSoft.Charts..::.SplineSeriesViewBase
PerpetuumSoft.Charts..::.SplineAreaSeriesView

See Also

SplineAreaSeriesView Members
PerpetuumSoft.Charts Namespace


SplineAreaSeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
SplineAreaSeriesView Members
SplineAreaSeriesView Class Constructors Methods Properties Events See Also Send Feedback

The SplineAreaSeriesView type exposes the following members.

Constructors

Name | Description
SplineAreaSeriesView | Initializes a new instance of the SplineAreaSeriesView class.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates series elements. (Overrides SimpleAxisSeriesView..::.CreateElementsForSeries(Series).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Inherited from SplineSeriesViewBase.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from SplineSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Overrides SeriesView..::.PaintLegendBadge(GraphicStream, VectorRectangle).)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from SplineSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from SplineSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

SplineAreaSeriesView Class
PerpetuumSoft.Charts Namespace


SplineAreaSeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
SplineAreaSeriesView Constructor
SplineAreaSeriesView Class See Also Send Feedback
Initializes a new instance of the SplineAreaSeriesView class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SplineAreaSeriesView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SplineAreaSeriesView()

See Also

SplineAreaSeriesView Class
PerpetuumSoft.Charts Namespace


SplineAreaSeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
SplineAreaSeriesView Methods
SplineAreaSeriesView Class See Also Send Feedback

The SplineAreaSeriesView type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates series elements. (Overrides SimpleAxisSeriesView..::.CreateElementsForSeries(Series).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Inherited from SplineSeriesViewBase.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from SplineSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Overrides SeriesView..::.PaintLegendBadge(GraphicStream, VectorRectangle).)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from SplineSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SplineAreaSeriesView Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
SplineAreaSeriesView..::.Clone Method
SplineAreaSeriesView Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesView Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesView
Visual C++
public:
virtual SeriesView^ Clone() override

See Also

SplineAreaSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElementsForSeries Method

[image]

.NET ModelKit Suite ClassReference
SplineAreaSeriesView..::.CreateElementsForSeries Method
SplineAreaSeriesView Class See Also Send Feedback
Creates series elements.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void CreateElementsForSeries(
    Series series
)
Visual Basic (Declaration)
Protected Overrides Sub CreateElementsForSeries ( _
    series As Series _
)
Visual C++
protected:
virtual void CreateElementsForSeries(
    Series^ series
) override

Parameters

series
Type: PerpetuumSoft.Charts..::.Series

See Also

SplineAreaSeriesView Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
SplineAreaSeriesView..::.GetSeries Method
SplineAreaSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

SplineAreaSeriesView Class
SplineAreaSeriesView Members
PerpetuumSoft.Charts Namespace


PaintLegendBadge Method

[image]

.NET ModelKit Suite ClassReference
SplineAreaSeriesView..::.PaintLegendBadge Method
SplineAreaSeriesView Class See Also Send Feedback
Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintLegendBadge(
    GraphicStream graphicStream,
    VectorRectangle area
)
Visual Basic (Declaration)
Public Overrides Sub PaintLegendBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle _
)
Visual C++
public:
virtual void PaintLegendBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area
) override

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

SplineAreaSeriesView Class
PerpetuumSoft.Charts Namespace


SplineAreaSeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
SplineAreaSeriesView Properties
SplineAreaSeriesView Class See Also Send Feedback

The SplineAreaSeriesView type exposes the following members.

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from SplineSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

See Also

SplineAreaSeriesView Class
PerpetuumSoft.Charts Namespace


SplineAreaSeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
SplineAreaSeriesView Events
SplineAreaSeriesView Class See Also Send Feedback

The SplineAreaSeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

SplineAreaSeriesView Class
PerpetuumSoft.Charts Namespace


SplineElement Class

[image]

.NET ModelKit Suite ClassReference
SplineElement Class
Members See Also Send Feedback
Represents an element - spline.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class SplineElement : Element
Visual Basic (Declaration)
Public Class SplineElement _
    Inherits Element
Visual C++
public ref class SplineElement : public Element

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Charts..::.SplineElement

See Also

SplineElement Members
PerpetuumSoft.Charts Namespace


SplineElement Members

[image] [image]

.NET ModelKit Suite ClassReference
SplineElement Members
SplineElement Class Constructors Methods Properties Events See Also Send Feedback

The SplineElement type exposes the following members.

Constructors

Name | Description
SplineElement | Overloaded.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

SplineElement Class
PerpetuumSoft.Charts Namespace


SplineElement Constructor

[image] [image]

.NET ModelKit Suite ClassReference
SplineElement Constructor
SplineElement Class See Also Send Feedback

Overload List

Name | Description
SplineElement()()() | Initializes a new instance of the SplineElement class.
SplineElement(array<Vector>[]()[]) | Initializes a new instance of the SplineElement class.

See Also

SplineElement Class
SplineElement Members
PerpetuumSoft.Charts Namespace


SplineElement Constructor

[image]

.NET ModelKit Suite ClassReference
SplineElement Constructor
SplineElement Class See Also Send Feedback
Initializes a new instance of the SplineElement class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SplineElement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SplineElement()

See Also

SplineElement Class
SplineElement Overload
PerpetuumSoft.Charts Namespace


SplineElement Constructor (Vector[])

[image]

.NET ModelKit Suite ClassReference
SplineElement Constructor (array<Vector>[]()[])
SplineElement Class See Also Send Feedback
Initializes a new instance of the SplineElement class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SplineElement(
    Vector[] points
)
Visual Basic (Declaration)
Public Sub New ( _
    points As Vector() _
)
Visual C++
public:
SplineElement(
    array<Vector>^ points
)

Parameters

points
Type: array< PerpetuumSoft.Framework.Drawing..::.Vector >[]()[]

See Also

SplineElement Class
SplineElement Overload
PerpetuumSoft.Charts Namespace


SplineElement Methods

[image] [image]

.NET ModelKit Suite ClassReference
SplineElement Methods
SplineElement Class See Also Send Feedback

The SplineElement type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SplineElement Class
PerpetuumSoft.Charts Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
SplineElement..::.Dispose Method
SplineElement Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

SplineElement Class
SplineElement Members
PerpetuumSoft.Charts Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
SplineElement..::.GetHitTest Method
SplineElement Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

SplineElement Class
PerpetuumSoft.Charts Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
SplineElement..::.GetStyle Method
SplineElement Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

SplineElement Class
SplineElement Members
PerpetuumSoft.Charts Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
SplineElement..::.Invalidate Method
SplineElement Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

SplineElement Class
SplineElement Members
PerpetuumSoft.Charts Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
SplineElement..::.OnPaint Method
SplineElement Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

SplineElement Class
SplineElement Members
PerpetuumSoft.Charts Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
SplineElement..::.OnPaint Method (PaintArguments, Fill, Stroke)
SplineElement Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

SplineElement Class
OnPaint Overload
PerpetuumSoft.Charts Namespace


SplineElement Properties

[image] [image]

.NET ModelKit Suite ClassReference
SplineElement Properties
SplineElement Class See Also Send Feedback

The SplineElement type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

SplineElement Class
PerpetuumSoft.Charts Namespace


SplineElement Events

[image] [image]

.NET ModelKit Suite ClassReference
SplineElement Events
SplineElement Class See Also Send Feedback

The SplineElement type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

SplineElement Class
PerpetuumSoft.Charts Namespace


SplineSeriesView Class

[image]

.NET ModelKit Suite ClassReference
SplineSeriesView Class
Members See Also Send Feedback
Represents series view to display series data in the form of spline.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class SplineSeriesView : SplineSeriesViewBase
Visual Basic (Declaration)
Public Class SplineSeriesView _
    Inherits SplineSeriesViewBase
Visual C++
public ref class SplineSeriesView : public SplineSeriesViewBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.SimpleAxisSeriesView
PerpetuumSoft.Charts..::.SplineSeriesViewBase
PerpetuumSoft.Charts..::.SplineSeriesView

See Also

SplineSeriesView Members
PerpetuumSoft.Charts Namespace


SplineSeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
SplineSeriesView Members
SplineSeriesView Class Constructors Methods Properties Events See Also Send Feedback

The SplineSeriesView type exposes the following members.

Constructors

Name | Description
SplineSeriesView | Initializes a new instance of the SplineSeriesView class.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates series elements. (Overrides SimpleAxisSeriesView..::.CreateElementsForSeries(Series).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Inherited from SplineSeriesViewBase.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from SplineSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Overrides SeriesView..::.PaintLegendBadge(GraphicStream, VectorRectangle).)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Overrides SplineSeriesViewBase..::.PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DefaultColor | Gets or sets default line color.
DefaultLineStyle | Gets or sets default line style.
DefaultLineWidth | Gets or sets default line width.
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from SplineSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

SplineSeriesView Class
PerpetuumSoft.Charts Namespace


SplineSeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
SplineSeriesView Constructor
SplineSeriesView Class See Also Send Feedback
Initializes a new instance of the SplineSeriesView class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SplineSeriesView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SplineSeriesView()

See Also

SplineSeriesView Class
PerpetuumSoft.Charts Namespace


SplineSeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
SplineSeriesView Methods
SplineSeriesView Class See Also Send Feedback

The SplineSeriesView type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates series elements. (Overrides SimpleAxisSeriesView..::.CreateElementsForSeries(Series).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Inherited from SplineSeriesViewBase.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from SplineSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Overrides SeriesView..::.PaintLegendBadge(GraphicStream, VectorRectangle).)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Overrides SplineSeriesViewBase..::.PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SplineSeriesView Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
SplineSeriesView..::.Clone Method
SplineSeriesView Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesView Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesView
Visual C++
public:
virtual SeriesView^ Clone() override

See Also

SplineSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElementsForSeries Method

[image]

.NET ModelKit Suite ClassReference
SplineSeriesView..::.CreateElementsForSeries Method
SplineSeriesView Class See Also Send Feedback
Creates series elements.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void CreateElementsForSeries(
    Series series
)
Visual Basic (Declaration)
Protected Overrides Sub CreateElementsForSeries ( _
    series As Series _
)
Visual C++
protected:
virtual void CreateElementsForSeries(
    Series^ series
) override

Parameters

series
Type: PerpetuumSoft.Charts..::.Series

See Also

SplineSeriesView Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
SplineSeriesView..::.GetSeries Method
SplineSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

SplineSeriesView Class
SplineSeriesView Members
PerpetuumSoft.Charts Namespace


PaintLegendBadge Method

[image]

.NET ModelKit Suite ClassReference
SplineSeriesView..::.PaintLegendBadge Method
SplineSeriesView Class See Also Send Feedback
Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintLegendBadge(
    GraphicStream graphicStream,
    VectorRectangle area
)
Visual Basic (Declaration)
Public Overrides Sub PaintLegendBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle _
)
Visual C++
public:
virtual void PaintLegendBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area
) override

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

SplineSeriesView Class
PerpetuumSoft.Charts Namespace


PaintLegendValueBadge Method

[image]

.NET ModelKit Suite ClassReference
SplineSeriesView..::.PaintLegendValueBadge Method
SplineSeriesView Class See Also Send Feedback
Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintLegendValueBadge(
    GraphicStream graphicStream,
    VectorRectangle area,
    int seriesValueIndex
)
Visual Basic (Declaration)
Public Overrides Sub PaintLegendValueBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle, _
    seriesValueIndex As Integer _
)
Visual C++
public:
virtual void PaintLegendValueBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area,
    int seriesValueIndex
) override

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
seriesValueIndex
Type: System..::.Int32

See Also

SplineSeriesView Class
PerpetuumSoft.Charts Namespace


SplineSeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
SplineSeriesView Properties
SplineSeriesView Class See Also Send Feedback

The SplineSeriesView type exposes the following members.

Properties

Name | Description
DefaultColor | Gets or sets default line color.
DefaultLineStyle | Gets or sets default line style.
DefaultLineWidth | Gets or sets default line width.
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from SplineSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

See Also

SplineSeriesView Class
PerpetuumSoft.Charts Namespace


DefaultColor Property

[image]

.NET ModelKit Suite ClassReference
SplineSeriesView..::.DefaultColor Property
SplineSeriesView Class See Also Send Feedback
Gets or sets default line color.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Color DefaultColor { get; set; }
Visual Basic (Declaration)
Public Property DefaultColor As Color
Visual C++
public:
property Color DefaultColor {
    Color get ();
    void set (Color value);
}

See Also

SplineSeriesView Class
PerpetuumSoft.Charts Namespace


DefaultLineStyle Property

[image]

.NET ModelKit Suite ClassReference
SplineSeriesView..::.DefaultLineStyle Property
SplineSeriesView Class See Also Send Feedback
Gets or sets default line style.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public LineStyle DefaultLineStyle { get; set; }
Visual Basic (Declaration)
Public Property DefaultLineStyle As LineStyle
Visual C++
public:
property LineStyle DefaultLineStyle {
    LineStyle get ();
    void set (LineStyle value);
}

See Also

SplineSeriesView Class
PerpetuumSoft.Charts Namespace


DefaultLineWidth Property

[image]

.NET ModelKit Suite ClassReference
SplineSeriesView..::.DefaultLineWidth Property
SplineSeriesView Class See Also Send Feedback
Gets or sets default line width.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double DefaultLineWidth { get; set; }
Visual Basic (Declaration)
Public Property DefaultLineWidth As Double
Visual C++
public:
property double DefaultLineWidth {
    double get ();
    void set (double value);
}

See Also

SplineSeriesView Class
PerpetuumSoft.Charts Namespace


SplineSeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
SplineSeriesView Events
SplineSeriesView Class See Also Send Feedback

The SplineSeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

SplineSeriesView Class
PerpetuumSoft.Charts Namespace


SplineSeriesViewBase Class

[image]

.NET ModelKit Suite ClassReference
SplineSeriesViewBase Class
Members See Also Send Feedback
Represents a base class for series view displaying series data in the form of the spline.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public abstract class SplineSeriesViewBase : SimpleAxisSeriesView
Visual Basic (Declaration)
Public MustInherit Class SplineSeriesViewBase _
    Inherits SimpleAxisSeriesView
Visual C++
public ref class SplineSeriesViewBase abstract : public SimpleAxisSeriesView

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.SimpleAxisSeriesView
PerpetuumSoft.Charts..::.SplineSeriesViewBase
PerpetuumSoft.Charts..::.SplineAreaSeriesView
PerpetuumSoft.Charts..::.SplineSeriesView

See Also

SplineSeriesViewBase Members
PerpetuumSoft.Charts Namespace


SplineSeriesViewBase Members

[image] [image]

.NET ModelKit Suite ClassReference
SplineSeriesViewBase Members
SplineSeriesViewBase Class Constructors Methods Properties Events See Also Send Feedback

The SplineSeriesViewBase type exposes the following members.

Constructors

Name | Description
SplineSeriesViewBase | Initializes a new instance of the SplineSeriesViewBase class

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Creates an object copy. (Inherited from SeriesView.)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates array of elements which represent a chart of the specified series. (Inherited from SimpleAxisSeriesView.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Overrides SeriesView..::.GetBounds(Series, AxisType, array<Series>[]()[]).)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Overrides SeriesView..::.GetSideIndent()()().)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Paints a legend badge for the series. (Inherited from SeriesView.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Overrides SeriesView..::.PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Overrides SeriesView..::.IsValueLegendItemSupported.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

SplineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


SplineSeriesViewBase Constructor

[image]

.NET ModelKit Suite ClassReference
SplineSeriesViewBase Constructor
SplineSeriesViewBase Class See Also Send Feedback
Initializes a new instance of the SplineSeriesViewBase class

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected SplineSeriesViewBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
SplineSeriesViewBase()

See Also

SplineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


SplineSeriesViewBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
SplineSeriesViewBase Methods
SplineSeriesViewBase Class See Also Send Feedback

The SplineSeriesViewBase type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Creates an object copy. (Inherited from SeriesView.)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates array of elements which represent a chart of the specified series. (Inherited from SimpleAxisSeriesView.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Overrides SeriesView..::.GetBounds(Series, AxisType, array<Series>[]()[]).)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Overrides SeriesView..::.GetSideIndent()()().)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Paints a legend badge for the series. (Inherited from SeriesView.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Overrides SeriesView..::.PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SplineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


GetBounds Method

[image]

.NET ModelKit Suite ClassReference
SplineSeriesViewBase..::.GetBounds Method
SplineSeriesViewBase Class See Also Send Feedback
Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Bounds GetBounds(
    Series series,
    AxisType axisType,
    Series[] allSeries
)
Visual Basic (Declaration)
Public Overrides Function GetBounds ( _
    series As Series, _
    axisType As AxisType, _
    allSeries As Series() _
) As Bounds
Visual C++
public:
virtual Bounds GetBounds(
    Series^ series,
    AxisType axisType,
    array<Series^>^ allSeries
) override

Parameters

series
Type: PerpetuumSoft.Charts..::.Series
axisType
Type: PerpetuumSoft.Charts..::.AxisType
allSeries
Type: array< PerpetuumSoft.Charts..::.Series >[]()[]

See Also

SplineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
SplineSeriesViewBase..::.GetSeries Method
SplineSeriesViewBase Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

SplineSeriesViewBase Class
SplineSeriesViewBase Members
PerpetuumSoft.Charts Namespace


GetSideIndent Method

[image]

.NET ModelKit Suite ClassReference
SplineSeriesViewBase..::.GetSideIndent Method
SplineSeriesViewBase Class See Also Send Feedback
Overridden. See GetSideIndent()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override double GetSideIndent()
Visual Basic (Declaration)
Public Overrides Function GetSideIndent As Double
Visual C++
public:
virtual double GetSideIndent() override

See Also

SplineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


PaintLegendValueBadge Method

[image]

.NET ModelKit Suite ClassReference
SplineSeriesViewBase..::.PaintLegendValueBadge Method
SplineSeriesViewBase Class See Also Send Feedback
Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintLegendValueBadge(
    GraphicStream graphicStream,
    VectorRectangle area,
    int seriesValueIndex
)
Visual Basic (Declaration)
Public Overrides Sub PaintLegendValueBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle, _
    seriesValueIndex As Integer _
)
Visual C++
public:
virtual void PaintLegendValueBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area,
    int seriesValueIndex
) override

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
seriesValueIndex
Type: System..::.Int32

See Also

SplineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


SplineSeriesViewBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
SplineSeriesViewBase Properties
SplineSeriesViewBase Class See Also Send Feedback

The SplineSeriesViewBase type exposes the following members.

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Overrides SeriesView..::.IsValueLegendItemSupported.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

See Also

SplineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


IsValueLegendItemSupported Property

[image]

.NET ModelKit Suite ClassReference
SplineSeriesViewBase..::.IsValueLegendItemSupported Property
SplineSeriesViewBase Class See Also Send Feedback
Overridden. See IsValueLegendItemSupported.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValueLegendItemSupported { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsValueLegendItemSupported As Boolean
Visual C++
public:
virtual property bool IsValueLegendItemSupported {
    bool get () override;
}

See Also

SplineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


SplineSeriesViewBase Events

[image] [image]

.NET ModelKit Suite ClassReference
SplineSeriesViewBase Events
SplineSeriesViewBase Class See Also Send Feedback

The SplineSeriesViewBase type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

SplineSeriesViewBase Class
PerpetuumSoft.Charts Namespace


Stacked100AreaSeriesView Class

[image]

.NET ModelKit Suite ClassReference
Stacked100AreaSeriesView Class
Members See Also Send Feedback
Represents series view to display series data in the form of neighboring areas restricted by lines which go through points which correspond to ratio of series value to the total series value with the given argument.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class Stacked100AreaSeriesView : AreaSeriesViewBase
Visual Basic (Declaration)
Public Class Stacked100AreaSeriesView _
    Inherits AreaSeriesViewBase
Visual C++
public ref class Stacked100AreaSeriesView : public AreaSeriesViewBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.AreaSeriesViewBase
PerpetuumSoft.Charts..::.Stacked100AreaSeriesView

See Also

Stacked100AreaSeriesView Members
PerpetuumSoft.Charts Namespace


Stacked100AreaSeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
Stacked100AreaSeriesView Members
Stacked100AreaSeriesView Class Constructors Methods Properties Events See Also Send Feedback

The Stacked100AreaSeriesView type exposes the following members.

Constructors

Name | Description
Stacked100AreaSeriesView | Initializes a new instance of the Stacked100AreaSeriesView class.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElementForSeries | Creates series elements. (Overrides AreaSeriesViewBase..::.CreateElementForSeries(ChartArea, Series, array<AreaSeriesViewPoint>[]()[]).)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from AreaSeriesViewBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Overrides SeriesView..::.GetBounds(Series, AxisType, array<Series>[]()[]).)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Returns element, built by the assigned points subject to the specified palette index. (Inherited from AreaSeriesViewBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AreaSeriesViewBase.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from AreaSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from AreaSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from AreaSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from AreaSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
TopValue | Gets or sets a value that assigns the top bound of series.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

Stacked100AreaSeriesView Class
PerpetuumSoft.Charts Namespace


Stacked100AreaSeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
Stacked100AreaSeriesView Constructor
Stacked100AreaSeriesView Class See Also Send Feedback
Initializes a new instance of the Stacked100AreaSeriesView class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Stacked100AreaSeriesView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Stacked100AreaSeriesView()

See Also

Stacked100AreaSeriesView Class
PerpetuumSoft.Charts Namespace


Stacked100AreaSeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
Stacked100AreaSeriesView Methods
Stacked100AreaSeriesView Class See Also Send Feedback

The Stacked100AreaSeriesView type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElementForSeries | Creates series elements. (Overrides AreaSeriesViewBase..::.CreateElementForSeries(ChartArea, Series, array<AreaSeriesViewPoint>[]()[]).)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from AreaSeriesViewBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Overrides SeriesView..::.GetBounds(Series, AxisType, array<Series>[]()[]).)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Returns element, built by the assigned points subject to the specified palette index. (Inherited from AreaSeriesViewBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AreaSeriesViewBase.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from AreaSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from AreaSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from AreaSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Stacked100AreaSeriesView Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
Stacked100AreaSeriesView..::.Clone Method
Stacked100AreaSeriesView Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesView Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesView
Visual C++
public:
virtual SeriesView^ Clone() override

See Also

Stacked100AreaSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElementForSeries Method

[image]

.NET ModelKit Suite ClassReference
Stacked100AreaSeriesView..::.CreateElementForSeries Method
Stacked100AreaSeriesView Class See Also Send Feedback
Creates series elements.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void CreateElementForSeries(
    ChartArea area,
    Series series,
    AreaSeriesViewPoint[] items
)
Visual Basic (Declaration)
Protected Overrides Sub CreateElementForSeries ( _
    area As ChartArea, _
    series As Series, _
    items As AreaSeriesViewPoint() _
)
Visual C++
protected:
virtual void CreateElementForSeries(
    ChartArea^ area,
    Series^ series,
    array<AreaSeriesViewPoint>^ items
) override

Parameters

area
Type: PerpetuumSoft.Charts..::.ChartArea
series
Type: PerpetuumSoft.Charts..::.Series
items
Type: array< AreaSeriesViewPoint >[]()[]

See Also

Stacked100AreaSeriesView Class
PerpetuumSoft.Charts Namespace


GetBounds Method

[image]

.NET ModelKit Suite ClassReference
Stacked100AreaSeriesView..::.GetBounds Method
Stacked100AreaSeriesView Class See Also Send Feedback
Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Bounds GetBounds(
    Series series,
    AxisType axisType,
    Series[] allSeries
)
Visual Basic (Declaration)
Public Overrides Function GetBounds ( _
    series As Series, _
    axisType As AxisType, _
    allSeries As Series() _
) As Bounds
Visual C++
public:
virtual Bounds GetBounds(
    Series^ series,
    AxisType axisType,
    array<Series^>^ allSeries
) override

Parameters

series
Type: PerpetuumSoft.Charts..::.Series
axisType
Type: PerpetuumSoft.Charts..::.AxisType
allSeries
Type: array< PerpetuumSoft.Charts..::.Series >[]()[]

See Also

Stacked100AreaSeriesView Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
Stacked100AreaSeriesView..::.GetSeries Method
Stacked100AreaSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

Stacked100AreaSeriesView Class
Stacked100AreaSeriesView Members
PerpetuumSoft.Charts Namespace


Stacked100AreaSeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
Stacked100AreaSeriesView Properties
Stacked100AreaSeriesView Class See Also Send Feedback

The Stacked100AreaSeriesView type exposes the following members.

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from AreaSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
TopValue | Gets or sets a value that assigns the top bound of series.

See Also

Stacked100AreaSeriesView Class
PerpetuumSoft.Charts Namespace


TopValue Property

[image]

.NET ModelKit Suite ClassReference
Stacked100AreaSeriesView..::.TopValue Property
Stacked100AreaSeriesView Class See Also Send Feedback
Gets or sets a value that assigns the top bound of series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue TopValue { get; set; }
Visual Basic (Declaration)
Public Property TopValue As SmartValue
Visual C++
public:
property SmartValue TopValue {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

Stacked100AreaSeriesView Class
PerpetuumSoft.Charts Namespace


Stacked100AreaSeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
Stacked100AreaSeriesView Events
Stacked100AreaSeriesView Class See Also Send Feedback

The Stacked100AreaSeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

Stacked100AreaSeriesView Class
PerpetuumSoft.Charts Namespace


Stacked100BarSeriesView Class

[image]

.NET ModelKit Suite ClassReference
Stacked100BarSeriesView Class
Members See Also Send Feedback
Represents series view to display series data in the form of columns. Columns hight is the ratio of the series value to the total series value with the given argument.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class Stacked100BarSeriesView : BarSeriesViewBase
Visual Basic (Declaration)
Public Class Stacked100BarSeriesView _
    Inherits BarSeriesViewBase
Visual C++
public ref class Stacked100BarSeriesView : public BarSeriesViewBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.BarSeriesViewBase
PerpetuumSoft.Charts..::.Stacked100BarSeriesView

See Also

Stacked100BarSeriesView Members
PerpetuumSoft.Charts Namespace


Stacked100BarSeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
Stacked100BarSeriesView Members
Stacked100BarSeriesView Class Constructors Methods Properties Events See Also Send Feedback

The Stacked100BarSeriesView type exposes the following members.

Constructors

Name | Description
Stacked100BarSeriesView | Initializes a new instance of the Stacked100BarSeriesView class.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElements | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Overrides SeriesView..::.GetBounds(Series, AxisType, array<Series>[]()[]).)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from BarSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from BarSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from BarSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AreaWidth | Gets or sets the ratio between the width of the occupied Bars and the available space. (Inherited from BarSeriesViewBase.)
BottomValue | Gets or sets a value that assigns the bottom bound of series.
ColumnImage | Gets or sets Image which sets the image drawn in the column. (Inherited from BarSeriesViewBase.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
ImageSizeMode | Gets or sets ImageSizeMode which sets zoom mode for the image displayed in the column. (Inherited from BarSeriesViewBase.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from BarSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
TopValue | Gets or sets a value that assigns the top bound of series.
ViewType | Gets or sets ViewType object that determines kind of Bars. (Inherited from BarSeriesViewBase.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

Stacked100BarSeriesView Class
PerpetuumSoft.Charts Namespace


Stacked100BarSeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
Stacked100BarSeriesView Constructor
Stacked100BarSeriesView Class See Also Send Feedback
Initializes a new instance of the Stacked100BarSeriesView class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Stacked100BarSeriesView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Stacked100BarSeriesView()

See Also

Stacked100BarSeriesView Class
PerpetuumSoft.Charts Namespace


Stacked100BarSeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
Stacked100BarSeriesView Methods
Stacked100BarSeriesView Class See Also Send Feedback

The Stacked100BarSeriesView type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElements | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Overrides SeriesView..::.GetBounds(Series, AxisType, array<Series>[]()[]).)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from BarSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from BarSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from BarSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Stacked100BarSeriesView Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
Stacked100BarSeriesView..::.Clone Method
Stacked100BarSeriesView Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesView Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesView
Visual C++
public:
virtual SeriesView^ Clone() override

See Also

Stacked100BarSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElements Method

[image] [image]

.NET ModelKit Suite ClassReference
Stacked100BarSeriesView..::.CreateElements Method
Stacked100BarSeriesView Class See Also Send Feedback

Overload List

Name | Description
CreateElements(ChartArea) | Overridden. See CreateElements(ChartArea). (Inherited from BarSeriesViewBase.)
CreateElements(ArgumentValuesMap, ChartArea) | Creates elements to display series data. (Overrides BarSeriesViewBase..::.CreateElements(ArgumentValuesMap, ChartArea).)

See Also

Stacked100BarSeriesView Class
Stacked100BarSeriesView Members
PerpetuumSoft.Charts Namespace


CreateElements Method (, ChartArea)

[image]

.NET ModelKit Suite ClassReference
Stacked100BarSeriesView..::.CreateElements Method (, ChartArea)
Stacked100BarSeriesView Class See Also Send Feedback
Creates elements to display series data.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void CreateElements(
    ArgumentValuesMap map,
    ChartArea area
)
Visual Basic (Declaration)
Protected Overrides Sub CreateElements ( _
    map As ArgumentValuesMap, _
    area As ChartArea _
)
Visual C++
protected:
virtual void CreateElements(
    ArgumentValuesMap^ map,
    ChartArea^ area
) override

Parameters

map
Type: ArgumentValuesMap
area
Type: PerpetuumSoft.Charts..::.ChartArea

See Also

Stacked100BarSeriesView Class
CreateElements Overload
PerpetuumSoft.Charts Namespace


GetBounds Method

[image]

.NET ModelKit Suite ClassReference
Stacked100BarSeriesView..::.GetBounds Method
Stacked100BarSeriesView Class See Also Send Feedback
Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Bounds GetBounds(
    Series series,
    AxisType axisType,
    Series[] allSeries
)
Visual Basic (Declaration)
Public Overrides Function GetBounds ( _
    series As Series, _
    axisType As AxisType, _
    allSeries As Series() _
) As Bounds
Visual C++
public:
virtual Bounds GetBounds(
    Series^ series,
    AxisType axisType,
    array<Series^>^ allSeries
) override

Parameters

series
Type: PerpetuumSoft.Charts..::.Series
axisType
Type: PerpetuumSoft.Charts..::.AxisType
allSeries
Type: array< PerpetuumSoft.Charts..::.Series >[]()[]

See Also

Stacked100BarSeriesView Class
PerpetuumSoft.Charts Namespace


GetElement Method

[image] [image]

.NET ModelKit Suite ClassReference
Stacked100BarSeriesView..::.GetElement Method
Stacked100BarSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetElement(VectorRectangle, Double) | Returns an element that corresponds to the specified area and value. (Inherited from BarSeriesViewBase.)
GetElement(VectorRectangle, Double, Int32) | Returns an element that corresponds to the specified area, value and the number in the palette. (Inherited from BarSeriesViewBase.)

See Also

Stacked100BarSeriesView Class
Stacked100BarSeriesView Members
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
Stacked100BarSeriesView..::.GetSeries Method
Stacked100BarSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

Stacked100BarSeriesView Class
Stacked100BarSeriesView Members
PerpetuumSoft.Charts Namespace


Stacked100BarSeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
Stacked100BarSeriesView Properties
Stacked100BarSeriesView Class See Also Send Feedback

The Stacked100BarSeriesView type exposes the following members.

Properties

Name | Description
AreaWidth | Gets or sets the ratio between the width of the occupied Bars and the available space. (Inherited from BarSeriesViewBase.)
BottomValue | Gets or sets a value that assigns the bottom bound of series.
ColumnImage | Gets or sets Image which sets the image drawn in the column. (Inherited from BarSeriesViewBase.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
ImageSizeMode | Gets or sets ImageSizeMode which sets zoom mode for the image displayed in the column. (Inherited from BarSeriesViewBase.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from BarSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
TopValue | Gets or sets a value that assigns the top bound of series.
ViewType | Gets or sets ViewType object that determines kind of Bars. (Inherited from BarSeriesViewBase.)

See Also

Stacked100BarSeriesView Class
PerpetuumSoft.Charts Namespace


BottomValue Property

[image]

.NET ModelKit Suite ClassReference
Stacked100BarSeriesView..::.BottomValue Property
Stacked100BarSeriesView Class See Also Send Feedback
Gets or sets a value that assigns the bottom bound of series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue BottomValue { get; set; }
Visual Basic (Declaration)
Public Property BottomValue As SmartValue
Visual C++
public:
property SmartValue BottomValue {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

Stacked100BarSeriesView Class
PerpetuumSoft.Charts Namespace


TopValue Property

[image]

.NET ModelKit Suite ClassReference
Stacked100BarSeriesView..::.TopValue Property
Stacked100BarSeriesView Class See Also Send Feedback
Gets or sets a value that assigns the top bound of series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue TopValue { get; set; }
Visual Basic (Declaration)
Public Property TopValue As SmartValue
Visual C++
public:
property SmartValue TopValue {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

Stacked100BarSeriesView Class
PerpetuumSoft.Charts Namespace


Stacked100BarSeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
Stacked100BarSeriesView Events
Stacked100BarSeriesView Class See Also Send Feedback

The Stacked100BarSeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

Stacked100BarSeriesView Class
PerpetuumSoft.Charts Namespace


StackedAreaSeriesView Class

[image]

.NET ModelKit Suite ClassReference
StackedAreaSeriesView Class
Members See Also Send Feedback
Represents series view to display series data in the form of the neighboring areas restricted by lines which go through the points which correspond to series data.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class StackedAreaSeriesView : AreaSeriesViewBase
Visual Basic (Declaration)
Public Class StackedAreaSeriesView _
    Inherits AreaSeriesViewBase
Visual C++
public ref class StackedAreaSeriesView : public AreaSeriesViewBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.AreaSeriesViewBase
PerpetuumSoft.Charts..::.StackedAreaSeriesView

See Also

StackedAreaSeriesView Members
PerpetuumSoft.Charts Namespace


StackedAreaSeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
StackedAreaSeriesView Members
StackedAreaSeriesView Class Constructors Methods Properties Events See Also Send Feedback

The StackedAreaSeriesView type exposes the following members.

Constructors

Name | Description
StackedAreaSeriesView | Initializes a new instance of the StackedAreaSeriesView class.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElementForSeries | Creates series elements. (Overrides AreaSeriesViewBase..::.CreateElementForSeries(ChartArea, Series, array<AreaSeriesViewPoint>[]()[]).)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from AreaSeriesViewBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Overrides SeriesView..::.GetBounds(Series, AxisType, array<Series>[]()[]).)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Returns element, built by the assigned points subject to the specified palette index. (Inherited from AreaSeriesViewBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AreaSeriesViewBase.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from AreaSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from AreaSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from AreaSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from AreaSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

StackedAreaSeriesView Class
PerpetuumSoft.Charts Namespace


StackedAreaSeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
StackedAreaSeriesView Constructor
StackedAreaSeriesView Class See Also Send Feedback
Initializes a new instance of the StackedAreaSeriesView class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public StackedAreaSeriesView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StackedAreaSeriesView()

See Also

StackedAreaSeriesView Class
PerpetuumSoft.Charts Namespace


StackedAreaSeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
StackedAreaSeriesView Methods
StackedAreaSeriesView Class See Also Send Feedback

The StackedAreaSeriesView type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElementForSeries | Creates series elements. (Overrides AreaSeriesViewBase..::.CreateElementForSeries(ChartArea, Series, array<AreaSeriesViewPoint>[]()[]).)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from AreaSeriesViewBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Overrides SeriesView..::.GetBounds(Series, AxisType, array<Series>[]()[]).)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Returns element, built by the assigned points subject to the specified palette index. (Inherited from AreaSeriesViewBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AreaSeriesViewBase.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from AreaSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from AreaSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from AreaSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StackedAreaSeriesView Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
StackedAreaSeriesView..::.Clone Method
StackedAreaSeriesView Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesView Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesView
Visual C++
public:
virtual SeriesView^ Clone() override

See Also

StackedAreaSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElementForSeries Method

[image]

.NET ModelKit Suite ClassReference
StackedAreaSeriesView..::.CreateElementForSeries Method
StackedAreaSeriesView Class See Also Send Feedback
Creates series elements.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void CreateElementForSeries(
    ChartArea area,
    Series series,
    AreaSeriesViewPoint[] items
)
Visual Basic (Declaration)
Protected Overrides Sub CreateElementForSeries ( _
    area As ChartArea, _
    series As Series, _
    items As AreaSeriesViewPoint() _
)
Visual C++
protected:
virtual void CreateElementForSeries(
    ChartArea^ area,
    Series^ series,
    array<AreaSeriesViewPoint>^ items
) override

Parameters

area
Type: PerpetuumSoft.Charts..::.ChartArea
series
Type: PerpetuumSoft.Charts..::.Series
items
Type: array< AreaSeriesViewPoint >[]()[]

See Also

StackedAreaSeriesView Class
PerpetuumSoft.Charts Namespace


GetBounds Method

[image]

.NET ModelKit Suite ClassReference
StackedAreaSeriesView..::.GetBounds Method
StackedAreaSeriesView Class See Also Send Feedback
Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Bounds GetBounds(
    Series series,
    AxisType axisType,
    Series[] allSeries
)
Visual Basic (Declaration)
Public Overrides Function GetBounds ( _
    series As Series, _
    axisType As AxisType, _
    allSeries As Series() _
) As Bounds
Visual C++
public:
virtual Bounds GetBounds(
    Series^ series,
    AxisType axisType,
    array<Series^>^ allSeries
) override

Parameters

series
Type: PerpetuumSoft.Charts..::.Series
axisType
Type: PerpetuumSoft.Charts..::.AxisType
allSeries
Type: array< PerpetuumSoft.Charts..::.Series >[]()[]

See Also

StackedAreaSeriesView Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
StackedAreaSeriesView..::.GetSeries Method
StackedAreaSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

StackedAreaSeriesView Class
StackedAreaSeriesView Members
PerpetuumSoft.Charts Namespace


StackedAreaSeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
StackedAreaSeriesView Properties
StackedAreaSeriesView Class See Also Send Feedback

The StackedAreaSeriesView type exposes the following members.

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from AreaSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

See Also

StackedAreaSeriesView Class
PerpetuumSoft.Charts Namespace


StackedAreaSeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
StackedAreaSeriesView Events
StackedAreaSeriesView Class See Also Send Feedback

The StackedAreaSeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

StackedAreaSeriesView Class
PerpetuumSoft.Charts Namespace


StackedBarSeriesView Class

[image]

.NET ModelKit Suite ClassReference
StackedBarSeriesView Class
Members See Also Send Feedback
Represents series view to display series data in the form of the stacked bar.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class StackedBarSeriesView : BarSeriesViewBase
Visual Basic (Declaration)
Public Class StackedBarSeriesView _
    Inherits BarSeriesViewBase
Visual C++
public ref class StackedBarSeriesView : public BarSeriesViewBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.BarSeriesViewBase
PerpetuumSoft.Charts..::.StackedBarSeriesView

See Also

StackedBarSeriesView Members
PerpetuumSoft.Charts Namespace


StackedBarSeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
StackedBarSeriesView Members
StackedBarSeriesView Class Constructors Methods Properties Events See Also Send Feedback

The StackedBarSeriesView type exposes the following members.

Constructors

Name | Description
StackedBarSeriesView | Initializes a new instance of the StackedBarSeriesView class.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElements | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Overrides SeriesView..::.GetBounds(Series, AxisType, array<Series>[]()[]).)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from BarSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from BarSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from BarSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AreaWidth | Gets or sets the ratio between the width of the occupied Bars and the available space. (Inherited from BarSeriesViewBase.)
ColumnImage | Gets or sets Image which sets the image drawn in the column. (Inherited from BarSeriesViewBase.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
ImageSizeMode | Gets or sets ImageSizeMode which sets zoom mode for the image displayed in the column. (Inherited from BarSeriesViewBase.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from BarSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
ViewType | Gets or sets ViewType object that determines kind of Bars. (Inherited from BarSeriesViewBase.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

StackedBarSeriesView Class
PerpetuumSoft.Charts Namespace


StackedBarSeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
StackedBarSeriesView Constructor
StackedBarSeriesView Class See Also Send Feedback
Initializes a new instance of the StackedBarSeriesView class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public StackedBarSeriesView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StackedBarSeriesView()

See Also

StackedBarSeriesView Class
PerpetuumSoft.Charts Namespace


StackedBarSeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
StackedBarSeriesView Methods
StackedBarSeriesView Class See Also Send Feedback

The StackedBarSeriesView type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElements | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Overrides SeriesView..::.GetBounds(Series, AxisType, array<Series>[]()[]).)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from BarSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from BarSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from BarSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StackedBarSeriesView Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
StackedBarSeriesView..::.Clone Method
StackedBarSeriesView Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesView Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesView
Visual C++
public:
virtual SeriesView^ Clone() override

See Also

StackedBarSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElements Method

[image] [image]

.NET ModelKit Suite ClassReference
StackedBarSeriesView..::.CreateElements Method
StackedBarSeriesView Class See Also Send Feedback

Overload List

Name | Description
CreateElements(ChartArea) | Overridden. See CreateElements(ChartArea). (Inherited from BarSeriesViewBase.)
CreateElements(ArgumentValuesMap, ChartArea) | Creates elements displaying series data. (Overrides BarSeriesViewBase..::.CreateElements(ArgumentValuesMap, ChartArea).)

See Also

StackedBarSeriesView Class
StackedBarSeriesView Members
PerpetuumSoft.Charts Namespace


CreateElements Method (, ChartArea)

[image]

.NET ModelKit Suite ClassReference
StackedBarSeriesView..::.CreateElements Method (, ChartArea)
StackedBarSeriesView Class See Also Send Feedback
Creates elements displaying series data.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void CreateElements(
    ArgumentValuesMap map,
    ChartArea area
)
Visual Basic (Declaration)
Protected Overrides Sub CreateElements ( _
    map As ArgumentValuesMap, _
    area As ChartArea _
)
Visual C++
protected:
virtual void CreateElements(
    ArgumentValuesMap^ map,
    ChartArea^ area
) override

Parameters

map
Type: ArgumentValuesMap
area
Type: PerpetuumSoft.Charts..::.ChartArea

See Also

StackedBarSeriesView Class
CreateElements Overload
PerpetuumSoft.Charts Namespace


GetBounds Method

[image]

.NET ModelKit Suite ClassReference
StackedBarSeriesView..::.GetBounds Method
StackedBarSeriesView Class See Also Send Feedback
Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Bounds GetBounds(
    Series series,
    AxisType axisType,
    Series[] allSeries
)
Visual Basic (Declaration)
Public Overrides Function GetBounds ( _
    series As Series, _
    axisType As AxisType, _
    allSeries As Series() _
) As Bounds
Visual C++
public:
virtual Bounds GetBounds(
    Series^ series,
    AxisType axisType,
    array<Series^>^ allSeries
) override

Parameters

series
Type: PerpetuumSoft.Charts..::.Series
axisType
Type: PerpetuumSoft.Charts..::.AxisType
allSeries
Type: array< PerpetuumSoft.Charts..::.Series >[]()[]

See Also

StackedBarSeriesView Class
PerpetuumSoft.Charts Namespace


GetElement Method

[image] [image]

.NET ModelKit Suite ClassReference
StackedBarSeriesView..::.GetElement Method
StackedBarSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetElement(VectorRectangle, Double) | Returns an element that corresponds to the specified area and value. (Inherited from BarSeriesViewBase.)
GetElement(VectorRectangle, Double, Int32) | Returns an element that corresponds to the specified area, value and the number in the palette. (Inherited from BarSeriesViewBase.)

See Also

StackedBarSeriesView Class
StackedBarSeriesView Members
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
StackedBarSeriesView..::.GetSeries Method
StackedBarSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

StackedBarSeriesView Class
StackedBarSeriesView Members
PerpetuumSoft.Charts Namespace


StackedBarSeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
StackedBarSeriesView Properties
StackedBarSeriesView Class See Also Send Feedback

The StackedBarSeriesView type exposes the following members.

Properties

Name | Description
AreaWidth | Gets or sets the ratio between the width of the occupied Bars and the available space. (Inherited from BarSeriesViewBase.)
ColumnImage | Gets or sets Image which sets the image drawn in the column. (Inherited from BarSeriesViewBase.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
ImageSizeMode | Gets or sets ImageSizeMode which sets zoom mode for the image displayed in the column. (Inherited from BarSeriesViewBase.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from BarSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
ViewType | Gets or sets ViewType object that determines kind of Bars. (Inherited from BarSeriesViewBase.)

See Also

StackedBarSeriesView Class
PerpetuumSoft.Charts Namespace


StackedBarSeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
StackedBarSeriesView Events
StackedBarSeriesView Class See Also Send Feedback

The StackedBarSeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

StackedBarSeriesView Class
PerpetuumSoft.Charts Namespace


StepLineSeriesView Class

[image]

.NET ModelKit Suite ClassReference
StepLineSeriesView Class
Members See Also Send Feedback
Represents series view to display series data in the form of the step line.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class StepLineSeriesView : LineSeriesViewBase
Visual Basic (Declaration)
Public Class StepLineSeriesView _
    Inherits LineSeriesViewBase
Visual C++
public ref class StepLineSeriesView : public LineSeriesViewBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.SimpleAxisSeriesView
PerpetuumSoft.Charts..::.LineSeriesViewBase
PerpetuumSoft.Charts..::.StepLineSeriesView

See Also

StepLineSeriesView Members
PerpetuumSoft.Charts Namespace


StepLineSeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
StepLineSeriesView Members
StepLineSeriesView Class Constructors Methods Properties Events See Also Send Feedback

The StepLineSeriesView type exposes the following members.

Constructors

Name | Description
StepLineSeriesView | Initializes a new instance of the StepLineSeriesView class.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElement | Creates an element that represents a chart by the corresponding points. (Inherited from LineSeriesViewBase.)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates elements to display series data. (Overrides SimpleAxisSeriesView..::.CreateElementsForSeries(Series).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetLineSeriesViewStroke | Returns the Stroke taking into account the specified palette. (Inherited from LineSeriesViewBase.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from LineSeriesViewBase.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from LineSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from LineSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from LineSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DefaultColor | 'Gets or sets default line color. (Inherited from LineSeriesViewBase.)
DefaultLineStyle | 'Gets or sets default line style. (Inherited from LineSeriesViewBase.)
DefaultLineWidth | Gets or sets default line width. (Inherited from LineSeriesViewBase.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from LineSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

StepLineSeriesView Class
PerpetuumSoft.Charts Namespace


StepLineSeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
StepLineSeriesView Constructor
StepLineSeriesView Class See Also Send Feedback
Initializes a new instance of the StepLineSeriesView class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public StepLineSeriesView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StepLineSeriesView()

See Also

StepLineSeriesView Class
PerpetuumSoft.Charts Namespace


StepLineSeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
StepLineSeriesView Methods
StepLineSeriesView Class See Also Send Feedback

The StepLineSeriesView type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElement | Creates an element that represents a chart by the corresponding points. (Inherited from LineSeriesViewBase.)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates elements to display series data. (Overrides SimpleAxisSeriesView..::.CreateElementsForSeries(Series).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetLineSeriesViewStroke | Returns the Stroke taking into account the specified palette. (Inherited from LineSeriesViewBase.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from LineSeriesViewBase.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from LineSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from LineSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from LineSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StepLineSeriesView Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
StepLineSeriesView..::.Clone Method
StepLineSeriesView Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesView Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesView
Visual C++
public:
virtual SeriesView^ Clone() override

See Also

StepLineSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElementsForSeries Method

[image]

.NET ModelKit Suite ClassReference
StepLineSeriesView..::.CreateElementsForSeries Method
StepLineSeriesView Class See Also Send Feedback
Creates elements to display series data.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void CreateElementsForSeries(
    Series series
)
Visual Basic (Declaration)
Protected Overrides Sub CreateElementsForSeries ( _
    series As Series _
)
Visual C++
protected:
virtual void CreateElementsForSeries(
    Series^ series
) override

Parameters

series
Type: PerpetuumSoft.Charts..::.Series

See Also

StepLineSeriesView Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
StepLineSeriesView..::.GetSeries Method
StepLineSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

StepLineSeriesView Class
StepLineSeriesView Members
PerpetuumSoft.Charts Namespace


StepLineSeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
StepLineSeriesView Properties
StepLineSeriesView Class See Also Send Feedback

The StepLineSeriesView type exposes the following members.

Properties

Name | Description
DefaultColor | 'Gets or sets default line color. (Inherited from LineSeriesViewBase.)
DefaultLineStyle | 'Gets or sets default line style. (Inherited from LineSeriesViewBase.)
DefaultLineWidth | Gets or sets default line width. (Inherited from LineSeriesViewBase.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from LineSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)

See Also

StepLineSeriesView Class
PerpetuumSoft.Charts Namespace


StepLineSeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
StepLineSeriesView Events
StepLineSeriesView Class See Also Send Feedback

The StepLineSeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

StepLineSeriesView Class
PerpetuumSoft.Charts Namespace


StockSeriesView Class

[image]

.NET ModelKit Suite ClassReference
StockSeriesView Class
Members See Also Send Feedback
Represents a financial type of the Stock chart.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class StockSeriesView : FinancialSeriesViewBase
Visual Basic (Declaration)
Public Class StockSeriesView _
    Inherits FinancialSeriesViewBase
Visual C++
public ref class StockSeriesView : public FinancialSeriesViewBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.SimpleAxisSeriesView
PerpetuumSoft.Charts..::.FinancialSeriesViewBase
PerpetuumSoft.Charts..::.StockSeriesView

See Also

StockSeriesView Members
PerpetuumSoft.Charts Namespace


StockSeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
StockSeriesView Members
StockSeriesView Class Constructors Methods Properties Events See Also Send Feedback

The StockSeriesView type exposes the following members.

Constructors

Name | Description
StockSeriesView | Initializes a new instance of the StockSeriesView class.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElement | Creates an element by the specified series value, series type. (Overrides FinancialSeriesViewBase..::.CreateElement(Series, FinancialSeriesValue, Boolean).)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates elements which correspond to the specified series. (Inherited from FinancialSeriesViewBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Inherited from FinancialSeriesViewBase.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetReductionValueForSeriesValue | Returns the value field of the financial series with the specified reduction value. (Inherited from FinancialSeriesViewBase.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from FinancialSeriesViewBase.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from FinancialSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Overrides SeriesView..::.PaintLegendBadge(GraphicStream, VectorRectangle).)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from FinancialSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from FinancialSeriesViewBase.)
ReductionStroke | Gets or sets line type for the descending series values.
ReductionValue | Gets or sets a value which indicates according to which field the values with the reduced index will be chosen. (Inherited from FinancialSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
ViewMode | Gets or sets view mode of the series values.
Width | Gets or sets relational width of the element which corresponds to the series value. (Inherited from FinancialSeriesViewBase.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

StockSeriesView Class
PerpetuumSoft.Charts Namespace


StockSeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
StockSeriesView Constructor
StockSeriesView Class See Also Send Feedback
Initializes a new instance of the StockSeriesView class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public StockSeriesView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StockSeriesView()

See Also

StockSeriesView Class
PerpetuumSoft.Charts Namespace


StockSeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
StockSeriesView Methods
StockSeriesView Class See Also Send Feedback

The StockSeriesView type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElement | Creates an element by the specified series value, series type. (Overrides FinancialSeriesViewBase..::.CreateElement(Series, FinancialSeriesValue, Boolean).)
CreateElements | Overridden. See CreateElements(ChartArea). (Inherited from SimpleAxisSeriesView.)
CreateElementsForSeries | Creates elements which correspond to the specified series. (Inherited from FinancialSeriesViewBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Overridden. See GetBounds(Series, AxisType, array<Series>[]()[]). (Inherited from FinancialSeriesViewBase.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetReductionValueForSeriesValue | Returns the value field of the financial series with the specified reduction value. (Inherited from FinancialSeriesViewBase.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from FinancialSeriesViewBase.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from FinancialSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Overrides SeriesView..::.PaintLegendBadge(GraphicStream, VectorRectangle).)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from FinancialSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StockSeriesView Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
StockSeriesView..::.Clone Method
StockSeriesView Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesView Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesView
Visual C++
public:
virtual SeriesView^ Clone() override

See Also

StockSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElement Method

[image]

.NET ModelKit Suite ClassReference
StockSeriesView..::.CreateElement Method
StockSeriesView Class See Also Send Feedback
Creates an element by the specified series value, series type.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void CreateElement(
    Series series,
    FinancialSeriesValue seriesValue,
    bool isReduction
)
Visual Basic (Declaration)
Protected Overrides Sub CreateElement ( _
    series As Series, _
    seriesValue As FinancialSeriesValue, _
    isReduction As Boolean _
)
Visual C++
protected:
virtual void CreateElement(
    Series^ series,
    FinancialSeriesValue^ seriesValue,
    bool isReduction
) override

Parameters

series
Type: PerpetuumSoft.Charts..::.Series
seriesValue
Type: PerpetuumSoft.Charts..::.FinancialSeriesValue
isReduction
Type: System..::.Boolean

See Also

StockSeriesView Class
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
StockSeriesView..::.GetSeries Method
StockSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

StockSeriesView Class
StockSeriesView Members
PerpetuumSoft.Charts Namespace


PaintLegendBadge Method

[image]

.NET ModelKit Suite ClassReference
StockSeriesView..::.PaintLegendBadge Method
StockSeriesView Class See Also Send Feedback
Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void PaintLegendBadge(
    GraphicStream graphicStream,
    VectorRectangle area
)
Visual Basic (Declaration)
Public Overrides Sub PaintLegendBadge ( _
    graphicStream As GraphicStream, _
    area As VectorRectangle _
)
Visual C++
public:
virtual void PaintLegendBadge(
    GraphicStream^ graphicStream,
    VectorRectangle area
) override

Parameters

graphicStream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
area
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

StockSeriesView Class
PerpetuumSoft.Charts Namespace


StockSeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
StockSeriesView Properties
StockSeriesView Class See Also Send Feedback

The StockSeriesView type exposes the following members.

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from FinancialSeriesViewBase.)
ReductionStroke | Gets or sets line type for the descending series values.
ReductionValue | Gets or sets a value which indicates according to which field the values with the reduced index will be chosen. (Inherited from FinancialSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
ViewMode | Gets or sets view mode of the series values.
Width | Gets or sets relational width of the element which corresponds to the series value. (Inherited from FinancialSeriesViewBase.)

See Also

StockSeriesView Class
PerpetuumSoft.Charts Namespace


ReductionStroke Property

[image]

.NET ModelKit Suite ClassReference
StockSeriesView..::.ReductionStroke Property
StockSeriesView Class See Also Send Feedback
Gets or sets line type for the descending series values.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Stroke ReductionStroke { get; set; }
Visual Basic (Declaration)
Public Property ReductionStroke As Stroke
Visual C++
public:
property Stroke^ ReductionStroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

StockSeriesView Class
PerpetuumSoft.Charts Namespace


ViewMode Property

[image]

.NET ModelKit Suite ClassReference
StockSeriesView..::.ViewMode Property
StockSeriesView Class See Also Send Feedback
Gets or sets view mode of the series values.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public StockViewMode ViewMode { get; set; }
Visual Basic (Declaration)
Public Property ViewMode As StockViewMode
Visual C++
public:
property StockViewMode ViewMode {
    StockViewMode get ();
    void set (StockViewMode value);
}

See Also

StockSeriesView Class
PerpetuumSoft.Charts Namespace


StockSeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
StockSeriesView Events
StockSeriesView Class See Also Send Feedback

The StockSeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

StockSeriesView Class
PerpetuumSoft.Charts Namespace


StockViewMode Enumeration

[image]

.NET ModelKit Suite ClassReference
StockViewMode Enumeration
See Also Send Feedback
Enumerates a type that specifies view mode of a Stock chart.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public enum StockViewMode
Visual Basic (Declaration)
Public Enumeration StockViewMode
Visual C++
public enum class StockViewMode

Members

Member name | Description
Both | To show the Open and Close values.
Open | To show the Open value.
Close | To show the Close value.
None | Not to show the Open and Close values.

See Also

PerpetuumSoft.Charts Namespace


TankSeriesView Class

[image]

.NET ModelKit Suite ClassReference
TankSeriesView Class
Members See Also Send Feedback
Represents series view to display series data in the form of the Tank.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class TankSeriesView : BarSeriesViewBase
Visual Basic (Declaration)
Public Class TankSeriesView _
    Inherits BarSeriesViewBase
Visual C++
public ref class TankSeriesView : public BarSeriesViewBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.BarSeriesViewBase
PerpetuumSoft.Charts..::.TankSeriesView

See Also

TankSeriesView Members
PerpetuumSoft.Charts Namespace


TankSeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
TankSeriesView Members
TankSeriesView Class Constructors Methods Properties Events See Also Send Feedback

The TankSeriesView type exposes the following members.

Constructors

Name | Description
TankSeriesView | Initializes a new instance of the TankSeriesView class.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElements | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from BarSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from BarSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from BarSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AreaWidth | Gets or sets the ratio between the width of the occupied Bars and the available space. (Inherited from BarSeriesViewBase.)
ColumnImage |
Depth | Gets or sets Double. This value represent the depth of the 3rd dimension of the Tank.
Effect3D | Gets or sets Effect3D style of the Tank element painting.
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
ImageSizeMode | Gets or sets ImageSizeMode which sets zoom mode for the image displayed in the column. (Inherited from BarSeriesViewBase.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from BarSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
TankColor | Gets or sets Color of the tank side.
TankWidth | Gets or sets Double. This is the width of the tank side.
ViewType | Gets or sets ViewType object that determines kind of Bars. (Inherited from BarSeriesViewBase.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

TankSeriesView Class
PerpetuumSoft.Charts Namespace


TankSeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
TankSeriesView Constructor
TankSeriesView Class See Also Send Feedback
Initializes a new instance of the TankSeriesView class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public TankSeriesView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TankSeriesView()

See Also

TankSeriesView Class
PerpetuumSoft.Charts Namespace


TankSeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
TankSeriesView Methods
TankSeriesView Class See Also Send Feedback

The TankSeriesView type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides SeriesView..::.Clone()()().)
CreateElements | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from BarSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from BarSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from BarSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TankSeriesView Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
TankSeriesView..::.Clone Method
TankSeriesView Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesView Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesView
Visual C++
public:
virtual SeriesView^ Clone() override

See Also

TankSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElements Method

[image] [image]

.NET ModelKit Suite ClassReference
TankSeriesView..::.CreateElements Method
TankSeriesView Class See Also Send Feedback

Overload List

Name | Description
CreateElements(ChartArea) | Overridden. See CreateElements(ChartArea). (Inherited from BarSeriesViewBase.)
CreateElements(ArgumentValuesMap, ChartArea) | Creates chart elements by series data. (Inherited from BarSeriesViewBase.)

See Also

TankSeriesView Class
TankSeriesView Members
PerpetuumSoft.Charts Namespace


GetElement Method

[image] [image]

.NET ModelKit Suite ClassReference
TankSeriesView..::.GetElement Method
TankSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetElement(VectorRectangle, Double) | Returns an element that corresponds to the specified area and value. (Inherited from BarSeriesViewBase.)
GetElement(VectorRectangle, Double, Int32) | Returns an element that corresponds to the specified area, value and the number in the palette. (Inherited from BarSeriesViewBase.)

See Also

TankSeriesView Class
TankSeriesView Members
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
TankSeriesView..::.GetSeries Method
TankSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

TankSeriesView Class
TankSeriesView Members
PerpetuumSoft.Charts Namespace


TankSeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
TankSeriesView Properties
TankSeriesView Class See Also Send Feedback

The TankSeriesView type exposes the following members.

Properties

Name | Description
AreaWidth | Gets or sets the ratio between the width of the occupied Bars and the available space. (Inherited from BarSeriesViewBase.)
ColumnImage |
Depth | Gets or sets Double. This value represent the depth of the 3rd dimension of the Tank.
Effect3D | Gets or sets Effect3D style of the Tank element painting.
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
ImageSizeMode | Gets or sets ImageSizeMode which sets zoom mode for the image displayed in the column. (Inherited from BarSeriesViewBase.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from BarSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
TankColor | Gets or sets Color of the tank side.
TankWidth | Gets or sets Double. This is the width of the tank side.
ViewType | Gets or sets ViewType object that determines kind of Bars. (Inherited from BarSeriesViewBase.)

See Also

TankSeriesView Class
PerpetuumSoft.Charts Namespace


ColumnImage Property

[image]

.NET ModelKit Suite ClassReference
TankSeriesView..::.ColumnImage Property
TankSeriesView Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Charts.TankSeriesView.ColumnImage]

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Image ColumnImage { get; set; }
Visual Basic (Declaration)
Public Property ColumnImage As Image
Visual C++
public:
property Image^ ColumnImage {
    Image^ get ();
    void set (Image^ value);
}

See Also

TankSeriesView Class
PerpetuumSoft.Charts Namespace


Depth Property

[image]

.NET ModelKit Suite ClassReference
TankSeriesView..::.Depth Property
TankSeriesView Class See Also Send Feedback
Gets or sets Double. This value represent the depth of the 3rd dimension of the Tank.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double Depth { get; set; }
Visual Basic (Declaration)
Public Property Depth As Double
Visual C++
public:
property double Depth {
    double get ();
    void set (double value);
}

See Also

TankSeriesView Class
PerpetuumSoft.Charts Namespace


Effect3D Property

[image]

.NET ModelKit Suite ClassReference
TankSeriesView..::.Effect3D Property
TankSeriesView Class See Also Send Feedback
Gets or sets Effect3D style of the Tank element painting.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Effect3D Effect3D { get; set; }
Visual Basic (Declaration)
Public Property Effect3D As Effect3D
Visual C++
public:
property Effect3D Effect3D {
    Effect3D get ();
    void set (Effect3D value);
}

See Also

TankSeriesView Class
PerpetuumSoft.Charts Namespace


TankColor Property

[image]

.NET ModelKit Suite ClassReference
TankSeriesView..::.TankColor Property
TankSeriesView Class See Also Send Feedback
Gets or sets Color of the tank side.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Color TankColor { get; set; }
Visual Basic (Declaration)
Public Property TankColor As Color
Visual C++
public:
property Color TankColor {
    Color get ();
    void set (Color value);
}

See Also

TankSeriesView Class
PerpetuumSoft.Charts Namespace


TankWidth Property

[image]

.NET ModelKit Suite ClassReference
TankSeriesView..::.TankWidth Property
TankSeriesView Class See Also Send Feedback
Gets or sets Double. This is the width of the tank side.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double TankWidth { get; set; }
Visual Basic (Declaration)
Public Property TankWidth As Double
Visual C++
public:
property double TankWidth {
    double get ();
    void set (double value);
}

See Also

TankSeriesView Class
PerpetuumSoft.Charts Namespace


TankSeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
TankSeriesView Events
TankSeriesView Class See Also Send Feedback

The TankSeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

TankSeriesView Class
PerpetuumSoft.Charts Namespace


ThermometerSeriesView Class

[image]

.NET ModelKit Suite ClassReference
ThermometerSeriesView Class
Members See Also Send Feedback
Represents series view to display series data in the form of the Thermometer.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class ThermometerSeriesView : LevelSeriesView
Visual Basic (Declaration)
Public Class ThermometerSeriesView _
    Inherits LevelSeriesView
Visual C++
public ref class ThermometerSeriesView : public LevelSeriesView

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Charts..::.SeriesView
PerpetuumSoft.Charts..::.AxisSeriesView
PerpetuumSoft.Charts..::.BarSeriesViewBase
PerpetuumSoft.Charts..::.LevelSeriesView
PerpetuumSoft.Charts..::.ThermometerSeriesView

See Also

ThermometerSeriesView Members
PerpetuumSoft.Charts Namespace


ThermometerSeriesView Members

[image] [image]

.NET ModelKit Suite ClassReference
ThermometerSeriesView Members
ThermometerSeriesView Class Constructors Methods Properties Events See Also Send Feedback

The ThermometerSeriesView type exposes the following members.

Constructors

Name | Description
ThermometerSeriesView | Initializes a new instance of the ThermometerSeriesView class.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides LevelSeriesView..::.Clone()()().)
CreateElements | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from BarSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from BarSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from BarSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AciveLayer | Gets or sets LevelSeriesView..::.LevelProperties for the top layer of the Level element. (Inherited from LevelSeriesView.)
AreaWidth | Gets or sets the ratio between the width of the occupied Bars and the available space. (Inherited from BarSeriesViewBase.)
ColumnImage | Gets or sets Image which sets the image drawn in the column. (Inherited from BarSeriesViewBase.)
CoreWidth | Gets or sets Double. It is the width of the core of the thermometer.
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
ImageSizeMode | Gets or sets ImageSizeMode which sets zoom mode for the image displayed in the column. (Inherited from BarSeriesViewBase.)
InaciveLayer | Gets or sets LevelSeriesView..::.LevelProperties for the bottom layer of the Level element. (Inherited from LevelSeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from BarSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
ViewType | Gets or sets ViewType object that determines kind of Bars. (Inherited from BarSeriesViewBase.)

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

ThermometerSeriesView Class
PerpetuumSoft.Charts Namespace


ThermometerSeriesView Constructor

[image]

.NET ModelKit Suite ClassReference
ThermometerSeriesView Constructor
ThermometerSeriesView Class See Also Send Feedback
Initializes a new instance of the ThermometerSeriesView class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ThermometerSeriesView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ThermometerSeriesView()

See Also

ThermometerSeriesView Class
PerpetuumSoft.Charts Namespace


ThermometerSeriesView Methods

[image] [image]

.NET ModelKit Suite ClassReference
ThermometerSeriesView Methods
ThermometerSeriesView Class See Also Send Feedback

The ThermometerSeriesView type exposes the following members.

Methods

Name | Description
AddSeriesValueSegment | Adds a segment that corresponds to the specified value of the series. (Inherited from AxisSeriesView.)
ClearSeriesValueRectangles | Clears the segments of the series values. (Inherited from AxisSeriesView.)
Clone | Overridden. See Clone()()(). (Overrides LevelSeriesView..::.Clone()()().)
CreateElements | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBounds | Returns chart bounds for the axis of the specified type. (Inherited from SeriesView.)
GetChartAreaPalette | Returns palette specified in the ChartArea. (Inherited from SeriesView.)
GetCurrentElementIndex | Returns index of the current series. (Inherited from SeriesView.)
GetElement | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLabelPosition | Overridden. See GetLabelPosition(SeriesValueBase, LabelsPosition, Vector, Double). (Inherited from AxisSeriesView.)
GetNextElementIndex | Returns index of the next series. (Inherited from SeriesView.)
GetNotPaintedSeries | Returns the array of unpainted series of the specified type. (Inherited from SeriesView.)
GetPaletteColor | Returns the Color specified in the palette. (Inherited from SeriesView.)
GetPaletteFill | Returns the Fill specified in the palette. (Inherited from SeriesView.)
GetPaletteStroke | Returns the Stroke specified in the palette. (Inherited from SeriesView.)
GetSegmentBySeriesValue | Returns a segment that corresponds to the series value. (Inherited from AxisSeriesView.)
GetSeries | Overloaded.
GetSeriesValueType | Overridden. See GetSeriesValueType()()(). (Inherited from AxisSeriesView.)
GetSideIndent | Overridden. See GetSideIndent()()(). (Inherited from BarSeriesViewBase.)
GetStartPoint | Returns coordinates of the point that corresponds to the series' zero value. (Inherited from AxisSeriesView.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValuePoint | Returns coordinates of the point that corresponds to the specified value and label position. (Inherited from AxisSeriesView.)
GetValuePosition | Overridden. See GetValuePosition(SeriesValueBase, LabelsPosition). (Inherited from AxisSeriesView.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnSeriesViewChanged | Raises the SeriesViewChanged event. (Inherited from SeriesView.)
PaintLegendBadge | Overridden. See PaintLegendBadge(GraphicStream, VectorRectangle). (Inherited from BarSeriesViewBase.)
PaintLegendBadgeToImage | Paints a legend badge for the series to a specified image. (Inherited from SeriesView.)
PaintLegendMarkers | Paints a marker in a legend for the series value. (Inherited from AxisSeriesView.)
PaintLegendValueBadge | Overridden. See PaintLegendValueBadge(GraphicStream, VectorRectangle, Int32). (Inherited from BarSeriesViewBase.)
PaintLegendValueBadgeToImage | Paints a legend badge for the series value to specified image. (Inherited from SeriesView.)
ResetElementIndex | Resets index of the series. (Inherited from SeriesView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ThermometerSeriesView Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
ThermometerSeriesView..::.Clone Method
ThermometerSeriesView Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override SeriesView Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As SeriesView
Visual C++
public:
virtual SeriesView^ Clone() override

See Also

ThermometerSeriesView Class
PerpetuumSoft.Charts Namespace


CreateElements Method

[image] [image]

.NET ModelKit Suite ClassReference
ThermometerSeriesView..::.CreateElements Method
ThermometerSeriesView Class See Also Send Feedback

Overload List

Name | Description
CreateElements(ChartArea) | Overridden. See CreateElements(ChartArea). (Inherited from BarSeriesViewBase.)
CreateElements(ArgumentValuesMap, ChartArea) | Creates chart elements by series data. (Inherited from BarSeriesViewBase.)

See Also

ThermometerSeriesView Class
ThermometerSeriesView Members
PerpetuumSoft.Charts Namespace


GetElement Method

[image] [image]

.NET ModelKit Suite ClassReference
ThermometerSeriesView..::.GetElement Method
ThermometerSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetElement(VectorRectangle, Double) | Returns an element that corresponds to the specified area and value. (Inherited from BarSeriesViewBase.)
GetElement(VectorRectangle, Double, Int32) | Returns an element that corresponds to the specified area, value and the number in the palette. (Inherited from BarSeriesViewBase.)

See Also

ThermometerSeriesView Class
ThermometerSeriesView Members
PerpetuumSoft.Charts Namespace


GetSeries Method

[image] [image]

.NET ModelKit Suite ClassReference
ThermometerSeriesView..::.GetSeries Method
ThermometerSeriesView Class See Also Send Feedback

Overload List

Name | Description
GetSeries(ChartArea, Type) | Returns series array of the specified type. (Inherited from SeriesView.)
GetSeries(array<Series>[]()[], Type) | Returns series array of the specified type. (Inherited from SeriesView.)

See Also

ThermometerSeriesView Class
ThermometerSeriesView Members
PerpetuumSoft.Charts Namespace


ThermometerSeriesView Properties

[image] [image]

.NET ModelKit Suite ClassReference
ThermometerSeriesView Properties
ThermometerSeriesView Class See Also Send Feedback

The ThermometerSeriesView type exposes the following members.

Properties

Name | Description
AciveLayer | Gets or sets LevelSeriesView..::.LevelProperties for the top layer of the Level element. (Inherited from LevelSeriesView.)
AreaWidth | Gets or sets the ratio between the width of the occupied Bars and the available space. (Inherited from BarSeriesViewBase.)
ColumnImage | Gets or sets Image which sets the image drawn in the column. (Inherited from BarSeriesViewBase.)
CoreWidth | Gets or sets Double. It is the width of the core of the thermometer.
Fill | Gets or sets Fill object that is used to paint over. (Inherited from SeriesView.)
ImageSizeMode | Gets or sets ImageSizeMode which sets zoom mode for the image displayed in the column. (Inherited from BarSeriesViewBase.)
InaciveLayer | Gets or sets LevelSeriesView..::.LevelProperties for the bottom layer of the Level element. (Inherited from LevelSeriesView.)
IsValueLegendItemSupported | Overridden. See IsValueLegendItemSupported. (Inherited from BarSeriesViewBase.)
Series | Gets or sets the series displayed. (Inherited from SeriesView.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from SeriesView.)
ViewType | Gets or sets ViewType object that determines kind of Bars. (Inherited from BarSeriesViewBase.)

See Also

ThermometerSeriesView Class
PerpetuumSoft.Charts Namespace


CoreWidth Property

[image]

.NET ModelKit Suite ClassReference
ThermometerSeriesView..::.CoreWidth Property
ThermometerSeriesView Class See Also Send Feedback
Gets or sets Double. It is the width of the core of the thermometer.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double CoreWidth { get; set; }
Visual Basic (Declaration)
Public Property CoreWidth As Double
Visual C++
public:
property double CoreWidth {
    double get ();
    void set (double value);
}

See Also

ThermometerSeriesView Class
PerpetuumSoft.Charts Namespace


ThermometerSeriesView Events

[image] [image]

.NET ModelKit Suite ClassReference
ThermometerSeriesView Events
ThermometerSeriesView Class See Also Send Feedback

The ThermometerSeriesView type exposes the following members.

Events

Name | Description
SeriesViewChanged | Occurs after the change of an object state. (Inherited from SeriesView.)

See Also

ThermometerSeriesView Class
PerpetuumSoft.Charts Namespace


Title Class

[image]

.NET ModelKit Suite ClassReference
Title Class
Members See Also Send Feedback
Represents a chart title.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class Title : SimpleRectangleElement, IDockable
Visual Basic (Declaration)
Public Class Title _
    Inherits SimpleRectangleElement _
    Implements IDockable
Visual C++
public ref class Title : public SimpleRectangleElement,
    IDockable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement
PerpetuumSoft.Charts..::.Title

See Also

Title Members
PerpetuumSoft.Charts Namespace


Title Members

[image] [image]

.NET ModelKit Suite ClassReference
Title Members
Title Class Constructors Methods Properties Events See Also Send Feedback

The Title type exposes the following members.

Constructors

Name | Description
Title | Initializes a new instance of the Title class.

Methods

Name | Description
Calculate | Overridden. See Calculate()()(). (Overrides Element..::.Calculate()()().)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from SimpleRectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from SimpleRectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetRotatedRectangleSize | Returns size of the title bounds taking into account the specified angle of the text rotation.
GetSize | Implements GetSize()()().
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | Is called when bounds of a rectangle are chaged. (Inherited from SimpleRectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Occurs after the Visible property has been changed. (Overrides Element..::.OnVisibleChanged()()().)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetFont |
SetBounds | Implements SetBounds(VectorRectangle).
ShouldSerializeFont |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Alignment | Gets or sets text alingment within an element.
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
DockingStyle | Implements DockingStyle.
DockingType | Implements DockingType.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets font for the title text.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Margins | Gets or sets margins of the text.
Name | Gets or sets the element's name. (Inherited from Element.)
Padding | Gets or sets indent for this element.
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets a value that indicates whether expressions will be recalculate for all elements or for these elements only.
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Text | Gets or sets text displayed in the title.
TextAngle | Gets or sets an angle of the text rotation.
TextFill | Gets or sets Fill used to face title text.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Title Class
PerpetuumSoft.Charts Namespace


Title Constructor

[image]

.NET ModelKit Suite ClassReference
Title Constructor
Title Class See Also Send Feedback
Initializes a new instance of the Title class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Title()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Title()

See Also

Title Class
PerpetuumSoft.Charts Namespace


Title Methods

[image] [image]

.NET ModelKit Suite ClassReference
Title Methods
Title Class See Also Send Feedback

The Title type exposes the following members.

Methods

Name | Description
Calculate | Overridden. See Calculate()()(). (Overrides Element..::.Calculate()()().)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from SimpleRectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from SimpleRectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetRotatedRectangleSize | Returns size of the title bounds taking into account the specified angle of the text rotation.
GetSize | Implements GetSize()()().
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | Is called when bounds of a rectangle are chaged. (Inherited from SimpleRectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Occurs after the Visible property has been changed. (Overrides Element..::.OnVisibleChanged()()().)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetFont |
SetBounds | Implements SetBounds(VectorRectangle).
ShouldSerializeFont |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Title Class
PerpetuumSoft.Charts Namespace


Calculate Method

[image]

.NET ModelKit Suite ClassReference
Title..::.Calculate Method
Title Class See Also Send Feedback
Overridden. See Calculate()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void Calculate()
Visual Basic (Declaration)
Protected Overrides Sub Calculate
Visual C++
protected:
virtual void Calculate() override

See Also

Title Class
PerpetuumSoft.Charts Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Title..::.Dispose Method
Title Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

Title Class
Title Members
PerpetuumSoft.Charts Namespace


GetRotatedRectangleSize Method

[image]

.NET ModelKit Suite ClassReference
Title..::.GetRotatedRectangleSize Method
Title Class See Also Send Feedback
Returns size of the title bounds taking into account the specified angle of the text rotation.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected static Vector GetRotatedRectangleSize(
    Vector vector,
    double angle
)
Visual Basic (Declaration)
Protected Shared Function GetRotatedRectangleSize ( _
    vector As Vector, _
    angle As Double _
) As Vector
Visual C++
protected:
static Vector GetRotatedRectangleSize(
    Vector vector,
    double angle
)

Parameters

vector
Type: PerpetuumSoft.Framework.Drawing..::.Vector
angle
Type: System..::.Double

See Also

Title Class
PerpetuumSoft.Charts Namespace


GetSize Method

[image]

.NET ModelKit Suite ClassReference
Title..::.GetSize Method
Title Class See Also Send Feedback
Implements GetSize()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double GetSize()
Visual Basic (Declaration)
Public Function GetSize As Double
Visual C++
public:
virtual double GetSize() sealed

Implements

IDockable..::.GetSize()()()

See Also

Title Class
PerpetuumSoft.Charts Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Title..::.GetStyle Method
Title Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Title Class
Title Members
PerpetuumSoft.Charts Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Title..::.Invalidate Method
Title Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Title Class
Title Members
PerpetuumSoft.Charts Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Title..::.OnPaint Method
Title Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

Title Class
Title Members
PerpetuumSoft.Charts Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
Title..::.OnPaint Method (PaintArguments, Fill, Stroke)
Title Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Title Class
OnPaint Overload
PerpetuumSoft.Charts Namespace


OnVisibleChanged Method

[image]

.NET ModelKit Suite ClassReference
Title..::.OnVisibleChanged Method
Title Class See Also Send Feedback
Occurs after the Visible property has been changed.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnVisibleChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnVisibleChanged
Visual C++
protected:
virtual void OnVisibleChanged() override

See Also

Title Class
PerpetuumSoft.Charts Namespace


ResetFont Method

[image]

.NET ModelKit Suite ClassReference
Title..::.ResetFont Method
Title Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Charts.Title.ResetFont]

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void ResetFont()
Visual Basic (Declaration)
Public Sub ResetFont
Visual C++
public:
void ResetFont()

See Also

Title Class
PerpetuumSoft.Charts Namespace


SetBounds Method

[image]

.NET ModelKit Suite ClassReference
Title..::.SetBounds Method
Title Class See Also Send Feedback
Implements SetBounds(VectorRectangle).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void SetBounds(
    VectorRectangle bounds
)
Visual Basic (Declaration)
Public Sub SetBounds ( _
    bounds As VectorRectangle _
)
Visual C++
public:
virtual void SetBounds(
    VectorRectangle bounds
) sealed

Parameters

bounds
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

Implements

IDockable..::.SetBounds(VectorRectangle)

See Also

Title Class
PerpetuumSoft.Charts Namespace


ShouldSerializeFont Method

[image]

.NET ModelKit Suite ClassReference
Title..::.ShouldSerializeFont Method
Title Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Charts.Title.ShouldSerializeFont]

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool ShouldSerializeFont()
Visual Basic (Declaration)
Public Function ShouldSerializeFont As Boolean
Visual C++
public:
bool ShouldSerializeFont()

See Also

Title Class
PerpetuumSoft.Charts Namespace


Title Properties

[image] [image]

.NET ModelKit Suite ClassReference
Title Properties
Title Class See Also Send Feedback

The Title type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Alignment | Gets or sets text alingment within an element.
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
DockingStyle | Implements DockingStyle.
DockingType | Implements DockingType.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets font for the title text.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Margins | Gets or sets margins of the text.
Name | Gets or sets the element's name. (Inherited from Element.)
Padding | Gets or sets indent for this element.
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets a value that indicates whether expressions will be recalculate for all elements or for these elements only.
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Text | Gets or sets text displayed in the title.
TextAngle | Gets or sets an angle of the text rotation.
TextFill | Gets or sets Fill used to face title text.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Title Class
PerpetuumSoft.Charts Namespace


Alignment Property

[image]

.NET ModelKit Suite ClassReference
Title..::.Alignment Property
Title Class See Also Send Feedback
Gets or sets text alingment within an element.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public StringAlignment Alignment { get; set; }
Visual Basic (Declaration)
Public Property Alignment As StringAlignment
Visual C++
public:
property StringAlignment Alignment {
    StringAlignment get ();
    void set (StringAlignment value);
}

See Also

Title Class
PerpetuumSoft.Charts Namespace


DockingStyle Property

[image]

.NET ModelKit Suite ClassReference
Title..::.DockingStyle Property
Title Class See Also Send Feedback
Implements DockingStyle.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public DockingStyle DockingStyle { get; set; }
Visual Basic (Declaration)
Public Property DockingStyle As DockingStyle
Visual C++
public:
virtual property DockingStyle DockingStyle {
    DockingStyle get () sealed;
    void set (DockingStyle value) sealed;
}

Implements

IDockable..::.DockingStyle

See Also

Title Class
PerpetuumSoft.Charts Namespace


DockingType Property

[image]

.NET ModelKit Suite ClassReference
Title..::.DockingType Property
Title Class See Also Send Feedback
Implements DockingType.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public DockingType DockingType { get; set; }
Visual Basic (Declaration)
Public Property DockingType As DockingType
Visual C++
public:
virtual property DockingType DockingType {
    DockingType get () sealed;
    void set (DockingType value) sealed;
}

Implements

IDockable..::.DockingType

See Also

Title Class
PerpetuumSoft.Charts Namespace


Font Property

[image]

.NET ModelKit Suite ClassReference
Title..::.Font Property
Title Class See Also Send Feedback
Gets or sets font for the title text.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public FontDescriptor Font { get; set; }
Visual Basic (Declaration)
Public Property Font As FontDescriptor
Visual C++
public:
property FontDescriptor^ Font {
    FontDescriptor^ get ();
    void set (FontDescriptor^ value);
}

See Also

Title Class
PerpetuumSoft.Charts Namespace


Margins Property

[image]

.NET ModelKit Suite ClassReference
Title..::.Margins Property
Title Class See Also Send Feedback
Gets or sets margins of the text.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Margins Margins { get; set; }
Visual Basic (Declaration)
Public Property Margins As Margins
Visual C++
public:
property Margins Margins {
    Margins get ();
    void set (Margins value);
}

See Also

Title Class
PerpetuumSoft.Charts Namespace


Padding Property

[image]

.NET ModelKit Suite ClassReference
Title..::.Padding Property
Title Class See Also Send Feedback
Gets or sets indent for this element.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Margins Padding { get; set; }
Visual Basic (Declaration)
Public Property Padding As Margins
Visual C++
public:
property Margins Padding {
    Margins get ();
    void set (Margins value);
}

See Also

Title Class
PerpetuumSoft.Charts Namespace


RecalculateAll Property

[image]

.NET ModelKit Suite ClassReference
Title..::.RecalculateAll Property
Title Class See Also Send Feedback
Gets or sets a value that indicates whether expressions will be recalculate for all elements or for these elements only.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool RecalculateAll { get; set; }
Visual Basic (Declaration)
Public Property RecalculateAll As Boolean
Visual C++
public:
property bool RecalculateAll {
    bool get ();
    void set (bool value);
}

See Also

Title Class
PerpetuumSoft.Charts Namespace


Text Property

[image]

.NET ModelKit Suite ClassReference
Title..::.Text Property
Title Class See Also Send Feedback
Gets or sets text displayed in the title.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

Title Class
PerpetuumSoft.Charts Namespace


TextAngle Property

[image]

.NET ModelKit Suite ClassReference
Title..::.TextAngle Property
Title Class See Also Send Feedback
Gets or sets an angle of the text rotation.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double TextAngle { get; set; }
Visual Basic (Declaration)
Public Property TextAngle As Double
Visual C++
public:
property double TextAngle {
    double get ();
    void set (double value);
}

See Also

Title Class
PerpetuumSoft.Charts Namespace


TextFill Property

[image]

.NET ModelKit Suite ClassReference
Title..::.TextFill Property
Title Class See Also Send Feedback
Gets or sets Fill used to face title text.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Fill TextFill { get; set; }
Visual Basic (Declaration)
Public Property TextFill As Fill
Visual C++
public:
property Fill^ TextFill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

Title Class
PerpetuumSoft.Charts Namespace


Title Events

[image] [image]

.NET ModelKit Suite ClassReference
Title Events
Title Class See Also Send Feedback

The Title type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Title Class
PerpetuumSoft.Charts Namespace


ValueLabels Class

[image]

.NET ModelKit Suite ClassReference
ValueLabels Class
Members See Also Send Feedback
Represents labels to display series values.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class ValueLabels : Element,
    ICloneable, IChartElement
Visual Basic (Declaration)
Public Class ValueLabels _
    Inherits Element _
    Implements ICloneable, IChartElement
Visual C++
public ref class ValueLabels : public Element,
    ICloneable, IChartElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Charts..::.ValueLabels

See Also

ValueLabels Members
PerpetuumSoft.Charts Namespace


ValueLabels Members

[image] [image]

.NET ModelKit Suite ClassReference
ValueLabels Members
ValueLabels Class Constructors Methods Properties Events See Also Send Feedback

The ValueLabels type exposes the following members.

Constructors

Name | Description
ValueLabels | Initializes a new instance of the ValueLabels class.

Methods

Name | Description
Calculate | Overridden. See Calculate()()(). (Overrides Element..::.Calculate()()().)
Clone | Implements Clone()()().
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetElementAtLayer | Returns an element from the specified layer.
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Overrides Element..::.GetObject(String).)
GetStyle | Overloaded.
GetTextLabel | Returns label text.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLayer | Paints an element specified in the layer.
PaintValueLabelInfo | Paints text by the specified parameters with the center in the specified point.
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetFont |
ResetMeasure | Implements ResetMeasure()()().
ShouldSerializeFont |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Determines labels rotation angle.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Distance | Gets or sets the distance between a label and a chart.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets label text font.
Formula | Gets or sets an expression that is used for calculation of the displayed label value.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
LineStroke | Gets or sets Stroke used to face label lines.
Margins | Gets or sets margins of the label text.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Position | Gets or sets label position.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Series | Gets Series series for which a lebel is used.
Shift | Gets or sets shift by two coordinates.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
TextFill | Gets or sets fill to face label text.
TextFormat | Gets or sets a string to format a value displayed by the label.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


ValueLabels Constructor

[image]

.NET ModelKit Suite ClassReference
ValueLabels Constructor
ValueLabels Class See Also Send Feedback
Initializes a new instance of the ValueLabels class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ValueLabels()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ValueLabels()

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


ValueLabels Methods

[image] [image]

.NET ModelKit Suite ClassReference
ValueLabels Methods
ValueLabels Class See Also Send Feedback

The ValueLabels type exposes the following members.

Methods

Name | Description
Calculate | Overridden. See Calculate()()(). (Overrides Element..::.Calculate()()().)
Clone | Implements Clone()()().
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetElementAtLayer | Returns an element from the specified layer.
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Overrides Element..::.GetObject(String).)
GetStyle | Overloaded.
GetTextLabel | Returns label text.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLayer | Paints an element specified in the layer.
PaintValueLabelInfo | Paints text by the specified parameters with the center in the specified point.
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetFont |
ResetMeasure | Implements ResetMeasure()()().
ShouldSerializeFont |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


Calculate Method

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.Calculate Method
ValueLabels Class See Also Send Feedback
Overridden. See Calculate()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void Calculate()
Visual Basic (Declaration)
Protected Overrides Sub Calculate
Visual C++
protected:
virtual void Calculate() override

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.Clone Method
ValueLabels Class See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Implements

ICloneable..::.Clone()()()

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ValueLabels..::.Dispose Method
ValueLabels Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

ValueLabels Class
ValueLabels Members
PerpetuumSoft.Charts Namespace


GetElementAtLayer Method

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.GetElementAtLayer Method
ValueLabels Class See Also Send Feedback
Returns an element from the specified layer.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public IElement GetElementAtLayer(
    Vector point,
    ChartLayer layer
)
Visual Basic (Declaration)
Public Function GetElementAtLayer ( _
    point As Vector, _
    layer As ChartLayer _
) As IElement
Visual C++
public:
virtual IElement^ GetElementAtLayer(
    Vector point,
    ChartLayer layer
) sealed

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector
layer
Type: PerpetuumSoft.Charts..::.ChartLayer

Implements

IChartElement..::.GetElementAtLayer(Vector, ChartLayer)

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.GetHitTest Method
ValueLabels Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


GetObject Method

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.GetObject Method
ValueLabels Class See Also Send Feedback
Implements GetObject(String).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override Object GetObject(
    string name
)
Visual Basic (Declaration)
Public Overrides Function GetObject ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetObject(
    String^ name
) override

Parameters

name
Type: System..::.String

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
ValueLabels..::.GetStyle Method
ValueLabels Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

ValueLabels Class
ValueLabels Members
PerpetuumSoft.Charts Namespace


GetTextLabel Method

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.GetTextLabel Method
ValueLabels Class See Also Send Feedback
Returns label text.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected string GetTextLabel(
    Object obj
)
Visual Basic (Declaration)
Protected Function GetTextLabel ( _
    obj As Object _
) As String
Visual C++
protected:
String^ GetTextLabel(
    Object^ obj
)

Parameters

obj
Type: System..::.Object

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ValueLabels..::.Invalidate Method
ValueLabels Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

ValueLabels Class
ValueLabels Members
PerpetuumSoft.Charts Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
ValueLabels..::.OnPaint Method
ValueLabels Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

ValueLabels Class
ValueLabels Members
PerpetuumSoft.Charts Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.OnPaint Method (PaintArguments, Fill, Stroke)
ValueLabels Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

ValueLabels Class
OnPaint Overload
PerpetuumSoft.Charts Namespace


PaintLayer Method

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.PaintLayer Method
ValueLabels Class See Also Send Feedback
Paints an element specified in the layer.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void PaintLayer(
    PaintArguments args,
    ChartLayer layer
)
Visual Basic (Declaration)
Public Sub PaintLayer ( _
    args As PaintArguments, _
    layer As ChartLayer _
)
Visual C++
public:
virtual void PaintLayer(
    PaintArguments^ args,
    ChartLayer layer
) sealed

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
layer
Type: PerpetuumSoft.Charts..::.ChartLayer

Implements

IChartElement..::.PaintLayer(PaintArguments, ChartLayer)

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


PaintValueLabelInfo Method

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.PaintValueLabelInfo Method
ValueLabels Class See Also Send Feedback
Paints text by the specified parameters with the center in the specified point.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void PaintValueLabelInfo(
    string text,
    VectorRectangle itemArea,
    Vector centerTextPoint,
    Vector valueLocation,
    GraphicStream stream,
    Fill fill,
    Stroke stroke,
    Vector textSize
)
Visual Basic (Declaration)
Protected Overridable Sub PaintValueLabelInfo ( _
    text As String, _
    itemArea As VectorRectangle, _
    centerTextPoint As Vector, _
    valueLocation As Vector, _
    stream As GraphicStream, _
    fill As Fill, _
    stroke As Stroke, _
    textSize As Vector _
)
Visual C++
protected:
virtual void PaintValueLabelInfo(
    String^ text,
    VectorRectangle itemArea,
    Vector centerTextPoint,
    Vector valueLocation,
    GraphicStream^ stream,
    Fill^ fill,
    Stroke^ stroke,
    Vector textSize
)

Parameters

text
Type: System..::.String
itemArea
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
centerTextPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
valueLocation
Type: PerpetuumSoft.Framework.Drawing..::.Vector
stream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
textSize
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


ResetFont Method

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.ResetFont Method
ValueLabels Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Charts.ValueLabels.ResetFont]

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void ResetFont()
Visual Basic (Declaration)
Public Sub ResetFont
Visual C++
public:
void ResetFont()

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


ResetMeasure Method

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.ResetMeasure Method
ValueLabels Class See Also Send Feedback
Implements ResetMeasure()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void ResetMeasure()
Visual Basic (Declaration)
Public Sub ResetMeasure
Visual C++
public:
void ResetMeasure()

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


ShouldSerializeFont Method

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.ShouldSerializeFont Method
ValueLabels Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Charts.ValueLabels.ShouldSerializeFont]

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool ShouldSerializeFont()
Visual Basic (Declaration)
Public Function ShouldSerializeFont As Boolean
Visual C++
public:
bool ShouldSerializeFont()

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


ValueLabels Properties

[image] [image]

.NET ModelKit Suite ClassReference
ValueLabels Properties
ValueLabels Class See Also Send Feedback

The ValueLabels type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Determines labels rotation angle.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Distance | Gets or sets the distance between a label and a chart.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets label text font.
Formula | Gets or sets an expression that is used for calculation of the displayed label value.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
LineStroke | Gets or sets Stroke used to face label lines.
Margins | Gets or sets margins of the label text.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Position | Gets or sets label position.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Series | Gets Series series for which a lebel is used.
Shift | Gets or sets shift by two coordinates.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
TextFill | Gets or sets fill to face label text.
TextFormat | Gets or sets a string to format a value displayed by the label.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


Angle Property

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.Angle Property
ValueLabels Class See Also Send Feedback
Determines labels rotation angle.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


Distance Property

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.Distance Property
ValueLabels Class See Also Send Feedback
Gets or sets the distance between a label and a chart.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double Distance { get; set; }
Visual Basic (Declaration)
Public Property Distance As Double
Visual C++
public:
property double Distance {
    double get ();
    void set (double value);
}

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


Font Property

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.Font Property
ValueLabels Class See Also Send Feedback
Gets or sets label text font.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public FontDescriptor Font { get; set; }
Visual Basic (Declaration)
Public Property Font As FontDescriptor
Visual C++
public:
property FontDescriptor^ Font {
    FontDescriptor^ get ();
    void set (FontDescriptor^ value);
}

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


Formula Property

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.Formula Property
ValueLabels Class See Also Send Feedback
Gets or sets an expression that is used for calculation of the displayed label value.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public string Formula { get; set; }
Visual Basic (Declaration)
Public Property Formula As String
Visual C++
public:
property String^ Formula {
    String^ get ();
    void set (String^ value);
}

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


LineStroke Property

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.LineStroke Property
ValueLabels Class See Also Send Feedback
Gets or sets Stroke used to face label lines.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Stroke LineStroke { get; set; }
Visual Basic (Declaration)
Public Property LineStroke As Stroke
Visual C++
public:
property Stroke^ LineStroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


Margins Property

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.Margins Property
ValueLabels Class See Also Send Feedback
Gets or sets margins of the label text.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Margins Margins { get; set; }
Visual Basic (Declaration)
Public Property Margins As Margins
Visual C++
public:
property Margins Margins {
    Margins get ();
    void set (Margins value);
}

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


Position Property

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.Position Property
ValueLabels Class See Also Send Feedback
Gets or sets label position.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public LabelsPosition Position { get; set; }
Visual Basic (Declaration)
Public Property Position As LabelsPosition
Visual C++
public:
property LabelsPosition Position {
    LabelsPosition get ();
    void set (LabelsPosition value);
}

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


Series Property

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.Series Property
ValueLabels Class See Also Send Feedback
Gets Series series for which a lebel is used.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected Series Series { get; }
Visual Basic (Declaration)
Protected ReadOnly Property Series As Series
Visual C++
protected:
property Series^ Series {
    Series^ get ();
}

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


Shift Property

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.Shift Property
ValueLabels Class See Also Send Feedback
Gets or sets shift by two coordinates.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Vector Shift { get; set; }
Visual Basic (Declaration)
Public Property Shift As Vector
Visual C++
public:
property Vector Shift {
    Vector get ();
    void set (Vector value);
}

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


TextFill Property

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.TextFill Property
ValueLabels Class See Also Send Feedback
Gets or sets fill to face label text.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Fill TextFill { get; set; }
Visual Basic (Declaration)
Public Property TextFill As Fill
Visual C++
public:
property Fill^ TextFill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


TextFormat Property

[image]

.NET ModelKit Suite ClassReference
ValueLabels..::.TextFormat Property
ValueLabels Class See Also Send Feedback
Gets or sets a string to format a value displayed by the label.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public TextFormat TextFormat { get; set; }
Visual Basic (Declaration)
Public Property TextFormat As TextFormat
Visual C++
public:
property TextFormat^ TextFormat {
    TextFormat^ get ();
    void set (TextFormat^ value);
}

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


ValueLabels Events

[image] [image]

.NET ModelKit Suite ClassReference
ValueLabels Events
ValueLabels Class See Also Send Feedback

The ValueLabels type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ValueLabels Class
PerpetuumSoft.Charts Namespace


ValueMarkers Class

[image]

.NET ModelKit Suite ClassReference
ValueMarkers Class
Members See Also Send Feedback
Represents a marker to indicate characteristic points on chart series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class ValueMarkers : Element,
    ICloneable, IChartElement
Visual Basic (Declaration)
Public Class ValueMarkers _
    Inherits Element _
    Implements ICloneable, IChartElement
Visual C++
public ref class ValueMarkers : public Element,
    ICloneable, IChartElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Charts..::.ValueMarkers

See Also

ValueMarkers Members
PerpetuumSoft.Charts Namespace


ValueMarkers Members

[image] [image]

.NET ModelKit Suite ClassReference
ValueMarkers Members
ValueMarkers Class Constructors Methods Properties Events See Also Send Feedback

The ValueMarkers type exposes the following members.

Constructors

Name | Description
ValueMarkers | Initializes a new instance of the ValueMarkers class.

Methods

Name | Description
Calculate | Overridden. See Calculate()()(). (Overrides Element..::.Calculate()()().)
Clone | Implements Clone()()().
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetElementAtLayer | Implements GetElementAtLayer(Vector, ChartLayer).
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLayer | Implements PaintLayer(PaintArguments, ChartLayer).
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Distance | Gets or sets shift of a marker from the series.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Position | Gets or sets marker position.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
SeriesBase | Gets series to which these markers belong.
Shape | Gets or sets shape to paint a marker.
Shift | Gets or sets marker shift by both coordinates.
Size | Gets or sets marker size.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ValueMarkers Class
PerpetuumSoft.Charts Namespace


ValueMarkers Constructor

[image]

.NET ModelKit Suite ClassReference
ValueMarkers Constructor
ValueMarkers Class See Also Send Feedback
Initializes a new instance of the ValueMarkers class.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ValueMarkers()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ValueMarkers()

See Also

ValueMarkers Class
PerpetuumSoft.Charts Namespace


ValueMarkers Methods

[image] [image]

.NET ModelKit Suite ClassReference
ValueMarkers Methods
ValueMarkers Class See Also Send Feedback

The ValueMarkers type exposes the following members.

Methods

Name | Description
Calculate | Overridden. See Calculate()()(). (Overrides Element..::.Calculate()()().)
Clone | Implements Clone()()().
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetElementAtLayer | Implements GetElementAtLayer(Vector, ChartLayer).
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLayer | Implements PaintLayer(PaintArguments, ChartLayer).
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValueMarkers Class
PerpetuumSoft.Charts Namespace


Calculate Method

[image]

.NET ModelKit Suite ClassReference
ValueMarkers..::.Calculate Method
ValueMarkers Class See Also Send Feedback
Overridden. See Calculate()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void Calculate()
Visual Basic (Declaration)
Protected Overrides Sub Calculate
Visual C++
protected:
virtual void Calculate() override

See Also

ValueMarkers Class
PerpetuumSoft.Charts Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
ValueMarkers..::.Clone Method
ValueMarkers Class See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Implements

ICloneable..::.Clone()()()

See Also

ValueMarkers Class
PerpetuumSoft.Charts Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ValueMarkers..::.Dispose Method
ValueMarkers Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

ValueMarkers Class
ValueMarkers Members
PerpetuumSoft.Charts Namespace


GetElementAtLayer Method

[image]

.NET ModelKit Suite ClassReference
ValueMarkers..::.GetElementAtLayer Method
ValueMarkers Class See Also Send Feedback
Implements GetElementAtLayer(Vector, ChartLayer).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public IElement GetElementAtLayer(
    Vector point,
    ChartLayer layer
)
Visual Basic (Declaration)
Public Function GetElementAtLayer ( _
    point As Vector, _
    layer As ChartLayer _
) As IElement
Visual C++
public:
virtual IElement^ GetElementAtLayer(
    Vector point,
    ChartLayer layer
) sealed

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector
layer
Type: PerpetuumSoft.Charts..::.ChartLayer

Implements

IChartElement..::.GetElementAtLayer(Vector, ChartLayer)

See Also

ValueMarkers Class
PerpetuumSoft.Charts Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
ValueMarkers..::.GetHitTest Method
ValueMarkers Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

ValueMarkers Class
PerpetuumSoft.Charts Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
ValueMarkers..::.GetStyle Method
ValueMarkers Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

ValueMarkers Class
ValueMarkers Members
PerpetuumSoft.Charts Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ValueMarkers..::.Invalidate Method
ValueMarkers Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

ValueMarkers Class
ValueMarkers Members
PerpetuumSoft.Charts Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
ValueMarkers..::.OnPaint Method
ValueMarkers Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Overrides Element..::.OnPaint(PaintArguments).)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

ValueMarkers Class
ValueMarkers Members
PerpetuumSoft.Charts Namespace


OnPaint Method (PaintArguments)

[image]

.NET ModelKit Suite ClassReference
ValueMarkers..::.OnPaint Method (PaintArguments)
ValueMarkers Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

ValueMarkers Class
OnPaint Overload
PerpetuumSoft.Charts Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
ValueMarkers..::.OnPaint Method (PaintArguments, Fill, Stroke)
ValueMarkers Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

ValueMarkers Class
OnPaint Overload
PerpetuumSoft.Charts Namespace


PaintLayer Method

[image]

.NET ModelKit Suite ClassReference
ValueMarkers..::.PaintLayer Method
ValueMarkers Class See Also Send Feedback
Implements PaintLayer(PaintArguments, ChartLayer).

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void PaintLayer(
    PaintArguments args,
    ChartLayer layer
)
Visual Basic (Declaration)
Public Sub PaintLayer ( _
    args As PaintArguments, _
    layer As ChartLayer _
)
Visual C++
public:
virtual void PaintLayer(
    PaintArguments^ args,
    ChartLayer layer
) sealed

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
layer
Type: PerpetuumSoft.Charts..::.ChartLayer

Implements

IChartElement..::.PaintLayer(PaintArguments, ChartLayer)

See Also

ValueMarkers Class
PerpetuumSoft.Charts Namespace


ValueMarkers Properties

[image] [image]

.NET ModelKit Suite ClassReference
ValueMarkers Properties
ValueMarkers Class See Also Send Feedback

The ValueMarkers type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Distance | Gets or sets shift of a marker from the series.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Position | Gets or sets marker position.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
SeriesBase | Gets series to which these markers belong.
Shape | Gets or sets shape to paint a marker.
Shift | Gets or sets marker shift by both coordinates.
Size | Gets or sets marker size.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

ValueMarkers Class
PerpetuumSoft.Charts Namespace


Distance Property

[image]

.NET ModelKit Suite ClassReference
ValueMarkers..::.Distance Property
ValueMarkers Class See Also Send Feedback
Gets or sets shift of a marker from the series.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double Distance { get; set; }
Visual Basic (Declaration)
Public Property Distance As Double
Visual C++
public:
property double Distance {
    double get ();
    void set (double value);
}

See Also

ValueMarkers Class
PerpetuumSoft.Charts Namespace


Position Property

[image]

.NET ModelKit Suite ClassReference
ValueMarkers..::.Position Property
ValueMarkers Class See Also Send Feedback
Gets or sets marker position.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public LabelsPosition Position { get; set; }
Visual Basic (Declaration)
Public Property Position As LabelsPosition
Visual C++
public:
property LabelsPosition Position {
    LabelsPosition get ();
    void set (LabelsPosition value);
}

See Also

ValueMarkers Class
PerpetuumSoft.Charts Namespace


SeriesBase Property

[image]

.NET ModelKit Suite ClassReference
ValueMarkers..::.SeriesBase Property
ValueMarkers Class See Also Send Feedback
Gets series to which these markers belong.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected SeriesBase SeriesBase { get; }
Visual Basic (Declaration)
Protected ReadOnly Property SeriesBase As SeriesBase
Visual C++
protected:
property SeriesBase^ SeriesBase {
    SeriesBase^ get ();
}

See Also

ValueMarkers Class
PerpetuumSoft.Charts Namespace


Shape Property

[image]

.NET ModelKit Suite ClassReference
ValueMarkers..::.Shape Property
ValueMarkers Class See Also Send Feedback
Gets or sets shape to paint a marker.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ShapeBase Shape { get; set; }
Visual Basic (Declaration)
Public Property Shape As ShapeBase
Visual C++
public:
property ShapeBase^ Shape {
    ShapeBase^ get ();
    void set (ShapeBase^ value);
}

See Also

ValueMarkers Class
PerpetuumSoft.Charts Namespace


Shift Property

[image]

.NET ModelKit Suite ClassReference
ValueMarkers..::.Shift Property
ValueMarkers Class See Also Send Feedback
Gets or sets marker shift by both coordinates.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Vector Shift { get; set; }
Visual Basic (Declaration)
Public Property Shift As Vector
Visual C++
public:
property Vector Shift {
    Vector get ();
    void set (Vector value);
}

See Also

ValueMarkers Class
PerpetuumSoft.Charts Namespace


Size Property

[image]

.NET ModelKit Suite ClassReference
ValueMarkers..::.Size Property
ValueMarkers Class See Also Send Feedback
Gets or sets marker size.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Vector Size { get; set; }
Visual Basic (Declaration)
Public Property Size As Vector
Visual C++
public:
property Vector Size {
    Vector get ();
    void set (Vector value);
}

See Also

ValueMarkers Class
PerpetuumSoft.Charts Namespace


ValueMarkers Events

[image] [image]

.NET ModelKit Suite ClassReference
ValueMarkers Events
ValueMarkers Class See Also Send Feedback

The ValueMarkers type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ValueMarkers Class
PerpetuumSoft.Charts Namespace


ViewType Enumeration

[image]

.NET ModelKit Suite ClassReference
ViewType Enumeration
See Also Send Feedback
Enumerates display type of the series data in the form of bar chart.

Namespace: PerpetuumSoft.Charts
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public enum ViewType
Visual Basic (Declaration)
Public Enumeration ViewType
Visual C++
public enum class ViewType

Members

Member name | Description
Bar | Enumerates display type of the series data in the form of rectangles.
Bar3D | Enumerates display type of the series data in the form of parallelepiped.
Pyramide | Enumerates display type of the series data in the form of pyramids.
Cylinder | Enumerates display type of the series data in the form of cylinders.
Brick | Determines the "Brick" effect when the series elements are drawn.
RoundedBar | Determines the series elements drawing in the form of rounded rectangle.

See Also

PerpetuumSoft.Charts Namespace


PerpetuumSoft.Charts.Web Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Charts.Web Namespace
Send Feedback
The PerpetuumSoft.Charts.Web namespace contains classes to use the Chart on a Web Form.

Classes

Class | Description
WebChartViewer | Represents a control to display a chart on a web page.
WebDashboardViewer | Represents a control to display a dashboard on a web page.


WebChartViewer Class

[image]

.NET ModelKit Suite ClassReference
WebChartViewer Class
Members See Also Send Feedback
Represents a control to display a chart on a web page.

Namespace: PerpetuumSoft.Charts.Web
Assembly: PerpetuumSoft.Chart.Web (in PerpetuumSoft.Chart.Web.dll) Version: 3.9.0.1

Syntax

C#
public class WebChartViewer : DataBoundControl
Visual Basic (Declaration)
Public Class WebChartViewer _
    Inherits DataBoundControl
Visual C++
public ref class WebChartViewer : public DataBoundControl

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI.WebControls..::.WebControl
System.Web.UI.WebControls..::.BaseDataBoundControl
System.Web.UI.WebControls..::.DataBoundControl
PerpetuumSoft.Charts.Web..::.WebChartViewer
PerpetuumSoft.Charts.Web..::.WebDashboardViewer

See Also

WebChartViewer Members
PerpetuumSoft.Charts.Web Namespace


WebChartViewer Members

[image] [image]

.NET ModelKit Suite ClassReference
WebChartViewer Members
WebChartViewer Class Constructors Methods Properties Events See Also Send Feedback

The WebChartViewer type exposes the following members.

Constructors

Name | Description
WebChartViewer | Initializes a new instance of the WebChartViewer class.

Methods

Name | Description
AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
ConfirmInitState | Sets the initialized state of the data-bound control. (Inherited from BaseDataBoundControl.)
CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
CreateDataSourceSelectArguments | Creates a default DataSourceSelectArguments object used by the data-bound control if no arguments are specified. (Inherited from DataBoundControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureDataBound | Calls the DataBind()()() method if the DataSourceID property is set and the data-bound control is marked to require binding. (Inherited from BaseDataBoundControl.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
GetData | Retrieves a DataSourceView object that the data-bound control uses to perform data operations. (Inherited from DataBoundControl.)
GetDataSource | Retrieves the IDataSource interface that the data-bound control is associated with, if any. (Inherited from DataBoundControl.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MarkAsDataBound | Sets the state of the control in view state as successfully bound to data. (Inherited from DataBoundControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnDataBound | Raises the DataBound event. (Inherited from BaseDataBoundControl.)
OnDataPropertyChanged | Rebinds the data-bound control to its data after one of the base data source identification properties changes. (Inherited from DataBoundControl.)
OnDataSourceViewChanged | Raises the DataSourceViewChanged event. (Inherited from DataBoundControl.)
OnInit | Overridden. See OnInit(EventArgs). (Overrides BaseDataBoundControl..::.OnInit(EventArgs).)
OnLoad | Handles the Load event. (Inherited from DataBoundControl.)
OnPagePreLoad | Sets the initialized state of the data-bound control before the control is loaded. (Inherited from DataBoundControl.)
OnPreRender | Handles the PreRender event. (Inherited from BaseDataBoundControl.)
OnUnload | Raises the Unload event. (Inherited from Control.)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
PerformDataBinding | Overridden. See PerformDataBinding(IEnumerable). (Overrides DataBoundControl..::.PerformDataBinding(IEnumerable).)
PerformSelect | Retrieves data from the associated data source. (Inherited from DataBoundControl.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderContents | Overridden. See [M:System.Web.UI.WebControls.WebControl..RenderContents(System.Web.UI.HtmlTextWriter)]. (Overrides WebControl..::.RenderContents(HtmlTextWriter).)
RenderControl | Overloaded.
RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SaveViewState | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
ValidateDataSource | Verifies that the object a data-bound control binds to is one it can work with. (Inherited from DataBoundControl.)

Properties

Name | Description
AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Chart | Gets or sets Chart object that represents a chart being displayed in this control.
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
DataMember | Gets or sets the name of the list of data that the data-bound control binds to, in cases where the data source contains more than one distinct list of data items. (Inherited from DataBoundControl.)
DataSource | Gets or sets the object from which the data-bound control retrieves its list of data items. (Inherited from BaseDataBoundControl.)
DataSourceID | Gets or sets the ID of the control from which the data-bound control retrieves its list of data items. (Inherited from DataBoundControl.)
DataSourceObject | (Inherited from DataBoundControl.)
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Initialized | Gets a value indicating whether the data-bound control has been initialized. (Inherited from BaseDataBoundControl.)
IsBoundUsingDataSourceID | Gets a value indicating whether the DataSourceID property is set. (Inherited from BaseDataBoundControl.)
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
JpegQuality | Gets or sets the quality of a JPEG picture that represents a chart in a final html document.
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
PictureFormat | Gets or sets a picture format that represents a chart in a final html document.
RequiresDataBinding | Gets or sets a value indicating whether the DataBind()()() method should be called. (Inherited from BaseDataBoundControl.)
SelectArguments | Gets a DataSourceSelectArguments object that the data-bound control uses when retrieving data from a data source control. (Inherited from DataBoundControl.)
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

Events

Name | Description
DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
DataBound | Occurs after the server control binds to a data source. (Inherited from BaseDataBoundControl.)
Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

WebChartViewer Class
PerpetuumSoft.Charts.Web Namespace


WebChartViewer Constructor

[image]

.NET ModelKit Suite ClassReference
WebChartViewer Constructor
WebChartViewer Class See Also Send Feedback
Initializes a new instance of the WebChartViewer class.

Namespace: PerpetuumSoft.Charts.Web
Assembly: PerpetuumSoft.Chart.Web (in PerpetuumSoft.Chart.Web.dll) Version: 3.9.0.1

Syntax

C#
public WebChartViewer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WebChartViewer()

See Also

WebChartViewer Class
PerpetuumSoft.Charts.Web Namespace


WebChartViewer Methods

[image] [image]

.NET ModelKit Suite ClassReference
WebChartViewer Methods
WebChartViewer Class See Also Send Feedback

The WebChartViewer type exposes the following members.

Methods

Name | Description
AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
ConfirmInitState | Sets the initialized state of the data-bound control. (Inherited from BaseDataBoundControl.)
CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
CreateDataSourceSelectArguments | Creates a default DataSourceSelectArguments object used by the data-bound control if no arguments are specified. (Inherited from DataBoundControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureDataBound | Calls the DataBind()()() method if the DataSourceID property is set and the data-bound control is marked to require binding. (Inherited from BaseDataBoundControl.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
GetData | Retrieves a DataSourceView object that the data-bound control uses to perform data operations. (Inherited from DataBoundControl.)
GetDataSource | Retrieves the IDataSource interface that the data-bound control is associated with, if any. (Inherited from DataBoundControl.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MarkAsDataBound | Sets the state of the control in view state as successfully bound to data. (Inherited from DataBoundControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnDataBound | Raises the DataBound event. (Inherited from BaseDataBoundControl.)
OnDataPropertyChanged | Rebinds the data-bound control to its data after one of the base data source identification properties changes. (Inherited from DataBoundControl.)
OnDataSourceViewChanged | Raises the DataSourceViewChanged event. (Inherited from DataBoundControl.)
OnInit | Overridden. See OnInit(EventArgs). (Overrides BaseDataBoundControl..::.OnInit(EventArgs).)
OnLoad | Handles the Load event. (Inherited from DataBoundControl.)
OnPagePreLoad | Sets the initialized state of the data-bound control before the control is loaded. (Inherited from DataBoundControl.)
OnPreRender | Handles the PreRender event. (Inherited from BaseDataBoundControl.)
OnUnload | Raises the Unload event. (Inherited from Control.)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
PerformDataBinding | Overridden. See PerformDataBinding(IEnumerable). (Overrides DataBoundControl..::.PerformDataBinding(IEnumerable).)
PerformSelect | Retrieves data from the associated data source. (Inherited from DataBoundControl.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderContents | Overridden. See [M:System.Web.UI.WebControls.WebControl..RenderContents(System.Web.UI.HtmlTextWriter)]. (Overrides WebControl..::.RenderContents(HtmlTextWriter).)
RenderControl | Overloaded.
RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SaveViewState | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
ValidateDataSource | Verifies that the object a data-bound control binds to is one it can work with. (Inherited from DataBoundControl.)

See Also

WebChartViewer Class
PerpetuumSoft.Charts.Web Namespace


DataBind Method

[image] [image]

.NET ModelKit Suite ClassReference
WebChartViewer..::.DataBind Method
WebChartViewer Class See Also Send Feedback

Overload List

Name | Description
DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from BaseDataBoundControl.)
DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

WebChartViewer Class
WebChartViewer Members
PerpetuumSoft.Charts.Web Namespace


FindControl Method

[image] [image]

.NET ModelKit Suite ClassReference
WebChartViewer..::.FindControl Method
WebChartViewer Class See Also Send Feedback

Overload List

Name | Description
FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)

See Also

WebChartViewer Class
WebChartViewer Members
PerpetuumSoft.Charts.Web Namespace


OnInit Method

[image]

.NET ModelKit Suite ClassReference
WebChartViewer..::.OnInit Method
WebChartViewer Class See Also Send Feedback
Overridden. See OnInit(EventArgs).

Namespace: PerpetuumSoft.Charts.Web
Assembly: PerpetuumSoft.Chart.Web (in PerpetuumSoft.Chart.Web.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInit(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnInit ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnInit(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

WebChartViewer Class
PerpetuumSoft.Charts.Web Namespace


PerformDataBinding Method

[image]

.NET ModelKit Suite ClassReference
WebChartViewer..::.PerformDataBinding Method
WebChartViewer Class See Also Send Feedback
Overridden. See PerformDataBinding(IEnumerable).

Namespace: PerpetuumSoft.Charts.Web
Assembly: PerpetuumSoft.Chart.Web (in PerpetuumSoft.Chart.Web.dll) Version: 3.9.0.1

Syntax

C#
protected override void PerformDataBinding(
    IEnumerable data
)
Visual Basic (Declaration)
Protected Overrides Sub PerformDataBinding ( _
    data As IEnumerable _
)
Visual C++
protected:
virtual void PerformDataBinding(
    IEnumerable^ data
) override

Parameters

data
Type: System.Collections..::.IEnumerable

See Also

WebChartViewer Class
PerpetuumSoft.Charts.Web Namespace


RenderContents Method

[image]

.NET ModelKit Suite ClassReference
WebChartViewer..::.RenderContents Method
WebChartViewer Class See Also Send Feedback
Overridden. See [M:System.Web.UI.WebControls.WebControl..RenderContents(System.Web.UI.HtmlTextWriter)].

Namespace: PerpetuumSoft.Charts.Web
Assembly: PerpetuumSoft.Chart.Web (in PerpetuumSoft.Chart.Web.dll) Version: 3.9.0.1

Syntax

C#
protected override void RenderContents(
    HtmlTextWriter writer
)
Visual Basic (Declaration)
Protected Overrides Sub RenderContents ( _
    writer As HtmlTextWriter _
)
Visual C++
protected:
virtual void RenderContents(
    HtmlTextWriter^ writer
) override

Parameters

writer
Type: System.Web.UI..::.HtmlTextWriter

See Also

WebChartViewer Class
PerpetuumSoft.Charts.Web Namespace


RenderControl Method

[image] [image]

.NET ModelKit Suite ClassReference
WebChartViewer..::.RenderControl Method
WebChartViewer Class See Also Send Feedback

Overload List

Name | Description
RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

WebChartViewer Class
WebChartViewer Members
PerpetuumSoft.Charts.Web Namespace


WebChartViewer Properties

[image] [image]

.NET ModelKit Suite ClassReference
WebChartViewer Properties
WebChartViewer Class See Also Send Feedback

The WebChartViewer type exposes the following members.

Properties

Name | Description
AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Chart | Gets or sets Chart object that represents a chart being displayed in this control.
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
DataMember | Gets or sets the name of the list of data that the data-bound control binds to, in cases where the data source contains more than one distinct list of data items. (Inherited from DataBoundControl.)
DataSource | Gets or sets the object from which the data-bound control retrieves its list of data items. (Inherited from BaseDataBoundControl.)
DataSourceID | Gets or sets the ID of the control from which the data-bound control retrieves its list of data items. (Inherited from DataBoundControl.)
DataSourceObject | (Inherited from DataBoundControl.)
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Initialized | Gets a value indicating whether the data-bound control has been initialized. (Inherited from BaseDataBoundControl.)
IsBoundUsingDataSourceID | Gets a value indicating whether the DataSourceID property is set. (Inherited from BaseDataBoundControl.)
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
JpegQuality | Gets or sets the quality of a JPEG picture that represents a chart in a final html document.
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
PictureFormat | Gets or sets a picture format that represents a chart in a final html document.
RequiresDataBinding | Gets or sets a value indicating whether the DataBind()()() method should be called. (Inherited from BaseDataBoundControl.)
SelectArguments | Gets a DataSourceSelectArguments object that the data-bound control uses when retrieving data from a data source control. (Inherited from DataBoundControl.)
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

See Also

WebChartViewer Class
PerpetuumSoft.Charts.Web Namespace


Chart Property

[image]

.NET ModelKit Suite ClassReference
WebChartViewer..::.Chart Property
WebChartViewer Class See Also Send Feedback
Gets or sets Chart object that represents a chart being displayed in this control.

Namespace: PerpetuumSoft.Charts.Web
Assembly: PerpetuumSoft.Chart.Web (in PerpetuumSoft.Chart.Web.dll) Version: 3.9.0.1

Syntax

C#
public Chart Chart { get; set; }
Visual Basic (Declaration)
Public Property Chart As Chart
Visual C++
public:
property Chart^ Chart {
    Chart^ get ();
    void set (Chart^ value);
}

See Also

WebChartViewer Class
PerpetuumSoft.Charts.Web Namespace


JpegQuality Property

[image]

.NET ModelKit Suite ClassReference
WebChartViewer..::.JpegQuality Property
WebChartViewer Class See Also Send Feedback
Gets or sets the quality of a JPEG picture that represents a chart in a final html document.

Namespace: PerpetuumSoft.Charts.Web
Assembly: PerpetuumSoft.Chart.Web (in PerpetuumSoft.Chart.Web.dll) Version: 3.9.0.1

Syntax

C#
public byte JpegQuality { get; set; }
Visual Basic (Declaration)
Public Property JpegQuality As Byte
Visual C++
public:
property unsigned char JpegQuality {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

WebChartViewer Class
PerpetuumSoft.Charts.Web Namespace


PictureFormat Property

[image]

.NET ModelKit Suite ClassReference
WebChartViewer..::.PictureFormat Property
WebChartViewer Class See Also Send Feedback
Gets or sets a picture format that represents a chart in a final html document.

Namespace: PerpetuumSoft.Charts.Web
Assembly: PerpetuumSoft.Chart.Web (in PerpetuumSoft.Chart.Web.dll) Version: 3.9.0.1

Syntax

C#
public PictureFormat PictureFormat { get; set; }
Visual Basic (Declaration)
Public Property PictureFormat As PictureFormat
Visual C++
public:
property PictureFormat PictureFormat {
    PictureFormat get ();
    void set (PictureFormat value);
}

See Also

WebChartViewer Class
PerpetuumSoft.Charts.Web Namespace


WebChartViewer Events

[image] [image]

.NET ModelKit Suite ClassReference
WebChartViewer Events
WebChartViewer Class See Also Send Feedback

The WebChartViewer type exposes the following members.

Events

Name | Description
DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
DataBound | Occurs after the server control binds to a data source. (Inherited from BaseDataBoundControl.)
Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

WebChartViewer Class
PerpetuumSoft.Charts.Web Namespace


WebDashboardViewer Class

[image]

.NET ModelKit Suite ClassReference
WebDashboardViewer Class
Members See Also Send Feedback
Represents a control to display a dashboard on a web page.

Namespace: PerpetuumSoft.Charts.Web
Assembly: PerpetuumSoft.Chart.Web (in PerpetuumSoft.Chart.Web.dll) Version: 3.9.0.1

Syntax

C#
public class WebDashboardViewer : WebChartViewer
Visual Basic (Declaration)
Public Class WebDashboardViewer _
    Inherits WebChartViewer
Visual C++
public ref class WebDashboardViewer : public WebChartViewer

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI.WebControls..::.WebControl
System.Web.UI.WebControls..::.BaseDataBoundControl
System.Web.UI.WebControls..::.DataBoundControl
PerpetuumSoft.Charts.Web..::.WebChartViewer
PerpetuumSoft.Charts.Web..::.WebDashboardViewer

See Also

WebDashboardViewer Members
PerpetuumSoft.Charts.Web Namespace


WebDashboardViewer Members

[image] [image]

.NET ModelKit Suite ClassReference
WebDashboardViewer Members
WebDashboardViewer Class Constructors Methods Properties Events See Also Send Feedback

The WebDashboardViewer type exposes the following members.

Constructors

Name | Description
WebDashboardViewer | Initializes a new instance of the WebDashboardViewer class.

Methods

Name | Description
AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
ConfirmInitState | Sets the initialized state of the data-bound control. (Inherited from BaseDataBoundControl.)
CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
CreateDataSourceSelectArguments | Creates a default DataSourceSelectArguments object used by the data-bound control if no arguments are specified. (Inherited from DataBoundControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureDataBound | Calls the DataBind()()() method if the DataSourceID property is set and the data-bound control is marked to require binding. (Inherited from BaseDataBoundControl.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
GetData | Retrieves a DataSourceView object that the data-bound control uses to perform data operations. (Inherited from DataBoundControl.)
GetDataSource | Retrieves the IDataSource interface that the data-bound control is associated with, if any. (Inherited from DataBoundControl.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MarkAsDataBound | Sets the state of the control in view state as successfully bound to data. (Inherited from DataBoundControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnDataBound | Raises the DataBound event. (Inherited from BaseDataBoundControl.)
OnDataPropertyChanged | Rebinds the data-bound control to its data after one of the base data source identification properties changes. (Inherited from DataBoundControl.)
OnDataSourceViewChanged | Raises the DataSourceViewChanged event. (Inherited from DataBoundControl.)
OnInit | Overridden. See OnInit(EventArgs). (Inherited from WebChartViewer.)
OnLoad | Handles the Load event. (Inherited from DataBoundControl.)
OnPagePreLoad | Sets the initialized state of the data-bound control before the control is loaded. (Inherited from DataBoundControl.)
OnPreRender | Handles the PreRender event. (Inherited from BaseDataBoundControl.)
OnUnload | Raises the Unload event. (Inherited from Control.)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
PerformDataBinding | Overridden. See PerformDataBinding(IEnumerable). (Inherited from WebChartViewer.)
PerformSelect | Retrieves data from the associated data source. (Inherited from DataBoundControl.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderContents | Overridden. See [M:System.Web.UI.WebControls.WebControl..RenderContents(System.Web.UI.HtmlTextWriter)]. (Inherited from WebChartViewer.)
RenderControl | Overloaded.
RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SaveViewState | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
ValidateDataSource | Verifies that the object a data-bound control binds to is one it can work with. (Inherited from DataBoundControl.)

Properties

Name | Description
AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Chart | Gets or sets Chart object that represents a chart being displayed in this control. (Inherited from WebChartViewer.)
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
DataMember | Gets or sets the name of the list of data that the data-bound control binds to, in cases where the data source contains more than one distinct list of data items. (Inherited from DataBoundControl.)
DataSource | Gets or sets the object from which the data-bound control retrieves its list of data items. (Inherited from BaseDataBoundControl.)
DataSourceID | Gets or sets the ID of the control from which the data-bound control retrieves its list of data items. (Inherited from DataBoundControl.)
DataSourceObject | (Inherited from DataBoundControl.)
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Initialized | Gets a value indicating whether the data-bound control has been initialized. (Inherited from BaseDataBoundControl.)
IsBoundUsingDataSourceID | Gets a value indicating whether the DataSourceID property is set. (Inherited from BaseDataBoundControl.)
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
JpegQuality | Gets or sets the quality of a JPEG picture that represents a chart in a final html document. (Inherited from WebChartViewer.)
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
PictureFormat | Gets or sets a picture format that represents a chart in a final html document. (Inherited from WebChartViewer.)
RequiresDataBinding | Gets or sets a value indicating whether the DataBind()()() method should be called. (Inherited from BaseDataBoundControl.)
SelectArguments | Gets a DataSourceSelectArguments object that the data-bound control uses when retrieving data from a data source control. (Inherited from DataBoundControl.)
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

Events

Name | Description
DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
DataBound | Occurs after the server control binds to a data source. (Inherited from BaseDataBoundControl.)
Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

WebDashboardViewer Class
PerpetuumSoft.Charts.Web Namespace


WebDashboardViewer Constructor

[image]

.NET ModelKit Suite ClassReference
WebDashboardViewer Constructor
WebDashboardViewer Class See Also Send Feedback
Initializes a new instance of the WebDashboardViewer class.

Namespace: PerpetuumSoft.Charts.Web
Assembly: PerpetuumSoft.Chart.Web (in PerpetuumSoft.Chart.Web.dll) Version: 3.9.0.1

Syntax

C#
public WebDashboardViewer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WebDashboardViewer()

See Also

WebDashboardViewer Class
PerpetuumSoft.Charts.Web Namespace


WebDashboardViewer Methods

[image] [image]

.NET ModelKit Suite ClassReference
WebDashboardViewer Methods
WebDashboardViewer Class See Also Send Feedback

The WebDashboardViewer type exposes the following members.

Methods

Name | Description
AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
ConfirmInitState | Sets the initialized state of the data-bound control. (Inherited from BaseDataBoundControl.)
CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
CreateDataSourceSelectArguments | Creates a default DataSourceSelectArguments object used by the data-bound control if no arguments are specified. (Inherited from DataBoundControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureDataBound | Calls the DataBind()()() method if the DataSourceID property is set and the data-bound control is marked to require binding. (Inherited from BaseDataBoundControl.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
GetData | Retrieves a DataSourceView object that the data-bound control uses to perform data operations. (Inherited from DataBoundControl.)
GetDataSource | Retrieves the IDataSource interface that the data-bound control is associated with, if any. (Inherited from DataBoundControl.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MarkAsDataBound | Sets the state of the control in view state as successfully bound to data. (Inherited from DataBoundControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnDataBound | Raises the DataBound event. (Inherited from BaseDataBoundControl.)
OnDataPropertyChanged | Rebinds the data-bound control to its data after one of the base data source identification properties changes. (Inherited from DataBoundControl.)
OnDataSourceViewChanged | Raises the DataSourceViewChanged event. (Inherited from DataBoundControl.)
OnInit | Overridden. See OnInit(EventArgs). (Inherited from WebChartViewer.)
OnLoad | Handles the Load event. (Inherited from DataBoundControl.)
OnPagePreLoad | Sets the initialized state of the data-bound control before the control is loaded. (Inherited from DataBoundControl.)
OnPreRender | Handles the PreRender event. (Inherited from BaseDataBoundControl.)
OnUnload | Raises the Unload event. (Inherited from Control.)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
PerformDataBinding | Overridden. See PerformDataBinding(IEnumerable). (Inherited from WebChartViewer.)
PerformSelect | Retrieves data from the associated data source. (Inherited from DataBoundControl.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderContents | Overridden. See [M:System.Web.UI.WebControls.WebControl..RenderContents(System.Web.UI.HtmlTextWriter)]. (Inherited from WebChartViewer.)
RenderControl | Overloaded.
RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SaveViewState | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
ValidateDataSource | Verifies that the object a data-bound control binds to is one it can work with. (Inherited from DataBoundControl.)

See Also

WebDashboardViewer Class
PerpetuumSoft.Charts.Web Namespace


DataBind Method

[image] [image]

.NET ModelKit Suite ClassReference
WebDashboardViewer..::.DataBind Method
WebDashboardViewer Class See Also Send Feedback

Overload List

Name | Description
DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from BaseDataBoundControl.)
DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

WebDashboardViewer Class
WebDashboardViewer Members
PerpetuumSoft.Charts.Web Namespace


FindControl Method

[image] [image]

.NET ModelKit Suite ClassReference
WebDashboardViewer..::.FindControl Method
WebDashboardViewer Class See Also Send Feedback

Overload List

Name | Description
FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)

See Also

WebDashboardViewer Class
WebDashboardViewer Members
PerpetuumSoft.Charts.Web Namespace


RenderControl Method

[image] [image]

.NET ModelKit Suite ClassReference
WebDashboardViewer..::.RenderControl Method
WebDashboardViewer Class See Also Send Feedback

Overload List

Name | Description
RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

WebDashboardViewer Class
WebDashboardViewer Members
PerpetuumSoft.Charts.Web Namespace


WebDashboardViewer Properties

[image] [image]

.NET ModelKit Suite ClassReference
WebDashboardViewer Properties
WebDashboardViewer Class See Also Send Feedback

The WebDashboardViewer type exposes the following members.

Properties

Name | Description
AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Chart | Gets or sets Chart object that represents a chart being displayed in this control. (Inherited from WebChartViewer.)
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
DataMember | Gets or sets the name of the list of data that the data-bound control binds to, in cases where the data source contains more than one distinct list of data items. (Inherited from DataBoundControl.)
DataSource | Gets or sets the object from which the data-bound control retrieves its list of data items. (Inherited from BaseDataBoundControl.)
DataSourceID | Gets or sets the ID of the control from which the data-bound control retrieves its list of data items. (Inherited from DataBoundControl.)
DataSourceObject | (Inherited from DataBoundControl.)
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Initialized | Gets a value indicating whether the data-bound control has been initialized. (Inherited from BaseDataBoundControl.)
IsBoundUsingDataSourceID | Gets a value indicating whether the DataSourceID property is set. (Inherited from BaseDataBoundControl.)
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
JpegQuality | Gets or sets the quality of a JPEG picture that represents a chart in a final html document. (Inherited from WebChartViewer.)
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
PictureFormat | Gets or sets a picture format that represents a chart in a final html document. (Inherited from WebChartViewer.)
RequiresDataBinding | Gets or sets a value indicating whether the DataBind()()() method should be called. (Inherited from BaseDataBoundControl.)
SelectArguments | Gets a DataSourceSelectArguments object that the data-bound control uses when retrieving data from a data source control. (Inherited from DataBoundControl.)
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

See Also

WebDashboardViewer Class
PerpetuumSoft.Charts.Web Namespace


WebDashboardViewer Events

[image] [image]

.NET ModelKit Suite ClassReference
WebDashboardViewer Events
WebDashboardViewer Class See Also Send Feedback

The WebDashboardViewer type exposes the following members.

Events

Name | Description
DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
DataBound | Occurs after the server control binds to a data source. (Inherited from BaseDataBoundControl.)
Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

WebDashboardViewer Class
PerpetuumSoft.Charts.Web Namespace


PerpetuumSoft.Charts.Windows.Forms Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Charts.Windows.Forms Namespace
Send Feedback
The PerpetuumSoft.Charts.Windows.Forms namespace contains classes which are used to display charts in Windows Forms applications.

Classes

Class | Description
ChartDataSource | Represents the description of a chart data source.
ChartDataSourceCollection | Represents a collection of the ChartDatasource objects.
ChartViewer | Presents a control to display a chart.
DashboardViewer | Presents a control to display a dashboard.


ChartDataSource Class

[image]

.NET ModelKit Suite ClassReference
ChartDataSource Class
Members See Also Send Feedback
Represents the description of a chart data source.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class ChartDataSource : Component
Visual Basic (Declaration)
Public Class ChartDataSource _
    Inherits Component
Visual C++
public ref class ChartDataSource : public Component

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Charts.Windows.Forms..::.ChartDataSource

See Also

ChartDataSource Members
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartDataSource Members

[image] [image]

.NET ModelKit Suite ClassReference
ChartDataSource Members
ChartDataSource Class Constructors Methods Properties Events See Also Send Feedback

The ChartDataSource type exposes the following members.

Constructors

Name | Description
ChartDataSource | Overloaded.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataMember | Gets or sets a name of a data source field.
DataSource | Gets or sets a data source.
DataSourceName | Gets or sets a name of a data source.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ChartDataSource Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartDataSource Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ChartDataSource Constructor
ChartDataSource Class See Also Send Feedback

Overload List

Name | Description
ChartDataSource()()() | Initializes a new instance of the ChartDataSource class.
ChartDataSource(IContainer) | Initializes a new instance of the ChartDataSource class.
ChartDataSource(Object, String) | Initializes a new instance of the ChartDataSource class.

See Also

ChartDataSource Class
ChartDataSource Members
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartDataSource Constructor

[image]

.NET ModelKit Suite ClassReference
ChartDataSource Constructor
ChartDataSource Class See Also Send Feedback
Initializes a new instance of the ChartDataSource class.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ChartDataSource()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartDataSource()

See Also

ChartDataSource Class
ChartDataSource Overload
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartDataSource Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
ChartDataSource Constructor (IContainer)
ChartDataSource Class See Also Send Feedback
Initializes a new instance of the ChartDataSource class.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ChartDataSource(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
ChartDataSource(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

ChartDataSource Class
ChartDataSource Overload
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartDataSource Constructor (Object, String)

[image]

.NET ModelKit Suite ClassReference
ChartDataSource Constructor (Object, String)
ChartDataSource Class See Also Send Feedback
Initializes a new instance of the ChartDataSource class.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ChartDataSource(
    Object dataSource,
    string dataSourceName
)
Visual Basic (Declaration)
Public Sub New ( _
    dataSource As Object, _
    dataSourceName As String _
)
Visual C++
public:
ChartDataSource(
    Object^ dataSource,
    String^ dataSourceName
)

Parameters

dataSource
Type: System..::.Object
dataSourceName
Type: System..::.String

See Also

ChartDataSource Class
ChartDataSource Overload
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartDataSource Methods

[image] [image]

.NET ModelKit Suite ClassReference
ChartDataSource Methods
ChartDataSource Class See Also Send Feedback

The ChartDataSource type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ChartDataSource Class
PerpetuumSoft.Charts.Windows.Forms Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartDataSource..::.Dispose Method
ChartDataSource Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Overridden. See Dispose. (Overrides Component..::.Dispose(Boolean).)

See Also

ChartDataSource Class
ChartDataSource Members
PerpetuumSoft.Charts.Windows.Forms Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
ChartDataSource..::.Dispose Method (Boolean)
ChartDataSource Class See Also Send Feedback
Overridden. See Dispose.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

ChartDataSource Class
Dispose Overload
PerpetuumSoft.Charts.Windows.Forms Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartDataSource..::.MemberwiseClone Method
ChartDataSource Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ChartDataSource Class
ChartDataSource Members
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartDataSource Properties

[image] [image]

.NET ModelKit Suite ClassReference
ChartDataSource Properties
ChartDataSource Class See Also Send Feedback

The ChartDataSource type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataMember | Gets or sets a name of a data source field.
DataSource | Gets or sets a data source.
DataSourceName | Gets or sets a name of a data source.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

ChartDataSource Class
PerpetuumSoft.Charts.Windows.Forms Namespace


DataMember Property

[image]

.NET ModelKit Suite ClassReference
ChartDataSource..::.DataMember Property
ChartDataSource Class See Also Send Feedback
Gets or sets a name of a data source field.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public string DataMember { get; set; }
Visual Basic (Declaration)
Public Property DataMember As String
Visual C++
public:
property String^ DataMember {
    String^ get ();
    void set (String^ value);
}

See Also

ChartDataSource Class
PerpetuumSoft.Charts.Windows.Forms Namespace


DataSource Property

[image]

.NET ModelKit Suite ClassReference
ChartDataSource..::.DataSource Property
ChartDataSource Class See Also Send Feedback
Gets or sets a data source.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Object DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As Object
Visual C++
public:
property Object^ DataSource {
    Object^ get ();
    void set (Object^ value);
}

See Also

ChartDataSource Class
PerpetuumSoft.Charts.Windows.Forms Namespace


DataSourceName Property

[image]

.NET ModelKit Suite ClassReference
ChartDataSource..::.DataSourceName Property
ChartDataSource Class See Also Send Feedback
Gets or sets a name of a data source.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public string DataSourceName { get; set; }
Visual Basic (Declaration)
Public Property DataSourceName As String
Visual C++
public:
property String^ DataSourceName {
    String^ get ();
    void set (String^ value);
}

See Also

ChartDataSource Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartDataSource Events

[image] [image]

.NET ModelKit Suite ClassReference
ChartDataSource Events
ChartDataSource Class See Also Send Feedback

The ChartDataSource type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ChartDataSource Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartDataSourceCollection Class

[image]

.NET ModelKit Suite ClassReference
ChartDataSourceCollection Class
Members See Also Send Feedback
Represents a collection of the ChartDatasource objects.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class ChartDataSourceCollection : CollectionBase
Visual Basic (Declaration)
Public Class ChartDataSourceCollection _
    Inherits CollectionBase
Visual C++
public ref class ChartDataSourceCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Charts.Windows.Forms..::.ChartDataSourceCollection

See Also

ChartDataSourceCollection Members
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartDataSourceCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
ChartDataSourceCollection Members
ChartDataSourceCollection Class Constructors Methods Properties Events See Also Send Feedback

The ChartDataSourceCollection type exposes the following members.

Constructors

Name | Description
ChartDataSourceCollection | Initializes a new instance of the ChartDataSourceCollection class.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Adds elements to a collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName | Gets or sets a data source by the name.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Occurs when an element is added to a collection. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Occurs when an element is removed from a collection. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Implements Item[([(Int32])]).
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

Name | Description
CollectionChanged | Represents the method that handles the CollectionChanged event raised when adding elements to or removing elements from a collection.

See Also

ChartDataSourceCollection Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartDataSourceCollection Constructor

[image]

.NET ModelKit Suite ClassReference
ChartDataSourceCollection Constructor
ChartDataSourceCollection Class See Also Send Feedback
Initializes a new instance of the ChartDataSourceCollection class.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ChartDataSourceCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartDataSourceCollection()

See Also

ChartDataSourceCollection Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartDataSourceCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
ChartDataSourceCollection Methods
ChartDataSourceCollection Class See Also Send Feedback

The ChartDataSourceCollection type exposes the following members.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Adds elements to a collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName | Gets or sets a data source by the name.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Occurs when an element is added to a collection. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Occurs when an element is removed from a collection. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChartDataSourceCollection Class
PerpetuumSoft.Charts.Windows.Forms Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
ChartDataSourceCollection..::.Add Method
ChartDataSourceCollection Class See Also Send Feedback
Implements Add(Object).

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ChartDataSource Add(
    ChartDataSource value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As ChartDataSource _
) As ChartDataSource
Visual C++
public:
ChartDataSource^ Add(
    ChartDataSource^ value
)

Parameters

value
Type: PerpetuumSoft.Charts.Windows.Forms..::.ChartDataSource

See Also

ChartDataSourceCollection Class
PerpetuumSoft.Charts.Windows.Forms Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
ChartDataSourceCollection..::.AddRange Method
ChartDataSourceCollection Class See Also Send Feedback
Adds elements to a collection.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    ChartDataSource[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As ChartDataSource() _
)
Visual C++
public:
void AddRange(
    array<ChartDataSource^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Charts.Windows.Forms..::.ChartDataSource >[]()[]

See Also

ChartDataSourceCollection Class
PerpetuumSoft.Charts.Windows.Forms Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
ChartDataSourceCollection..::.Contains Method
ChartDataSourceCollection Class See Also Send Feedback
Implements Contains(Object).

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    ChartDataSource value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As ChartDataSource _
) As Boolean
Visual C++
public:
bool Contains(
    ChartDataSource^ value
)

Parameters

value
Type: PerpetuumSoft.Charts.Windows.Forms..::.ChartDataSource

See Also

ChartDataSourceCollection Class
PerpetuumSoft.Charts.Windows.Forms Namespace


GetByName Method

[image]

.NET ModelKit Suite ClassReference
ChartDataSourceCollection..::.GetByName Method
ChartDataSourceCollection Class See Also Send Feedback
Gets or sets a data source by the name.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ChartDataSource GetByName(
    string dataSourceName
)
Visual Basic (Declaration)
Public Function GetByName ( _
    dataSourceName As String _
) As ChartDataSource
Visual C++
public:
ChartDataSource^ GetByName(
    String^ dataSourceName
)

Parameters

dataSourceName
Type: System..::.String

See Also

ChartDataSourceCollection Class
PerpetuumSoft.Charts.Windows.Forms Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
ChartDataSourceCollection..::.IndexOf Method
ChartDataSourceCollection Class See Also Send Feedback
Implements IndexOf(Object).

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    ChartDataSource value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As ChartDataSource _
) As Integer
Visual C++
public:
int IndexOf(
    ChartDataSource^ value
)

Parameters

value
Type: PerpetuumSoft.Charts.Windows.Forms..::.ChartDataSource

See Also

ChartDataSourceCollection Class
PerpetuumSoft.Charts.Windows.Forms Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
ChartDataSourceCollection..::.Insert Method
ChartDataSourceCollection Class See Also Send Feedback
Implements Insert(Int32, Object).

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    ChartDataSource value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As ChartDataSource _
)
Visual C++
public:
void Insert(
    int index,
    ChartDataSource^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Charts.Windows.Forms..::.ChartDataSource

See Also

ChartDataSourceCollection Class
PerpetuumSoft.Charts.Windows.Forms Namespace


OnInsertComplete Method

[image]

.NET ModelKit Suite ClassReference
ChartDataSourceCollection..::.OnInsertComplete Method
ChartDataSourceCollection Class See Also Send Feedback
Occurs when an element is added to a collection.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsertComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsertComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsertComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ChartDataSourceCollection Class
PerpetuumSoft.Charts.Windows.Forms Namespace


OnRemoveComplete Method

[image]

.NET ModelKit Suite ClassReference
ChartDataSourceCollection..::.OnRemoveComplete Method
ChartDataSourceCollection Class See Also Send Feedback
Occurs when an element is removed from a collection.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnRemoveComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemoveComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemoveComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ChartDataSourceCollection Class
PerpetuumSoft.Charts.Windows.Forms Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
ChartDataSourceCollection..::.Remove Method
ChartDataSourceCollection Class See Also Send Feedback
Implements Remove(Object).

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    ChartDataSource value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As ChartDataSource _
)
Visual C++
public:
void Remove(
    ChartDataSource^ value
)

Parameters

value
Type: PerpetuumSoft.Charts.Windows.Forms..::.ChartDataSource

See Also

ChartDataSourceCollection Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartDataSourceCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
ChartDataSourceCollection Properties
ChartDataSourceCollection Class See Also Send Feedback

The ChartDataSourceCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Implements Item[([(Int32])]).
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ChartDataSourceCollection Class
PerpetuumSoft.Charts.Windows.Forms Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
ChartDataSourceCollection..::.Item Property
ChartDataSourceCollection Class See Also Send Feedback
Implements Item[([(Int32])]).

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ChartDataSource this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As ChartDataSource
Visual C++
public:
property ChartDataSource^ default[int index] {
    ChartDataSource^ get (int index);
    void set (int index, ChartDataSource^ value);
}

Parameters

index
Type: System..::.Int32

See Also

ChartDataSourceCollection Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartDataSourceCollection Events

[image] [image]

.NET ModelKit Suite ClassReference
ChartDataSourceCollection Events
ChartDataSourceCollection Class See Also Send Feedback

The ChartDataSourceCollection type exposes the following members.

Events

Name | Description
CollectionChanged | Represents the method that handles the CollectionChanged event raised when adding elements to or removing elements from a collection.

See Also

ChartDataSourceCollection Class
PerpetuumSoft.Charts.Windows.Forms Namespace


CollectionChanged Event

[image]

.NET ModelKit Suite ClassReference
ChartDataSourceCollection..::.CollectionChanged Event
ChartDataSourceCollection Class See Also Send Feedback
Represents the method that handles the CollectionChanged event raised when adding elements to or removing elements from a collection.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler CollectionChanged
Visual Basic (Declaration)
Public Event CollectionChanged As EventHandler
Visual C++
public:
 event EventHandler^ CollectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ChartDataSourceCollection Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartViewer Class

[image]

.NET ModelKit Suite ClassReference
ChartViewer Class
Members See Also Send Feedback
Presents a control to display a chart.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class ChartViewer : UserControl,
    IDataContext
Visual Basic (Declaration)
Public Class ChartViewer _
    Inherits UserControl _
    Implements IDataContext
Visual C++
public ref class ChartViewer : public UserControl,
    IDataContext

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Charts.Windows.Forms..::.ChartViewer
PerpetuumSoft.Charts.Windows.Forms..::.DashboardViewer

See Also

ChartViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartViewer Members

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer Members
ChartViewer Class Constructors Methods Properties Events See Also Send Feedback

The ChartViewer type exposes the following members.

Constructors

Name | Description
ChartViewer | Initializes a new instance of the ChartViewer class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CopyToClipboard | Copies chart image to the clipboard.
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateNewChart | Creates a new chart.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetDataList | Implements GetDataList(String).
GetDataListNames | Implements GetDataListNames()()().
GetElementAt | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Overrides Control..::.OnEnabledChanged(EventArgs).)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Overrides Control..::.OnGotFocus(EventArgs).)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInstrumentLoad | Occures after a chart has been loaded.
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Overrides Control..::.OnLostFocus(EventArgs).)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Overrides Control..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Overrides Control..::.OnSizeChanged(EventArgs).)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
OpenChart | Loads a chart from a file specified by a name.
OpenDialog | Shows an open dialog for chart loading from a file.
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Print | Prints chart image.
PrintDialog | Shows the printing dialog.
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Reload | Recalculates a chart.
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RunDesigner | Runs the designer for the chart displayed.
SaveAsImageDialog | Shows a dialog for a chart saving in the form of a picture.
SaveChart | Saves a chart to a file specified by name.
SaveDialog | Shows a dialog for a chart saving to a file.
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Chart | Gets or sets Chart - a chart displayed.
ChartRectangle | Gets the area occupied by a chart.
ChartStream | Gets chart serialized to a string.
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DataSources | Gets a collection of data sources for a chart.
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFocusRectangle | Gets or sets a value which points that there is no need for display of the control framing even when it is in focus.
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvalidateInterval | Gets or sets image renewal interval.
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowCopyToClipboard | Gets or sets visibility of the 'Copy to clipboard' button on the Toolbar.
ShowDesigner | Gets or sets visibility of the 'Designer' button on the Toolbar.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowNew | Gets or sets visibility of the 'New' button on the Toolbar.
ShowOpen | Gets or sets visibility of the 'Open' button on the Toolbar.
ShowPrint | Gets or sets visibility of the 'Print' button on the Toolbar.
ShowSave | Gets or sets visibility of the 'Save' button on the Toolbar.
ShowSaveAsImage | Gets or sets visibility of the 'Save as image' button on the Toolbar.
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
ToolBarVisible | Gets or sets a value indicating that the toolbar is visible.
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
ZoomScale | Gets or sets zoom scale.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InstrumentLoad | Loads a chart.
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartViewer Constructor

[image]

.NET ModelKit Suite ClassReference
ChartViewer Constructor
ChartViewer Class See Also Send Feedback
Initializes a new instance of the ChartViewer class.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ChartViewer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartViewer()

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartViewer Methods

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer Methods
ChartViewer Class See Also Send Feedback

The ChartViewer type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CopyToClipboard | Copies chart image to the clipboard.
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateNewChart | Creates a new chart.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetDataList | Implements GetDataList(String).
GetDataListNames | Implements GetDataListNames()()().
GetElementAt | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Overrides Control..::.OnEnabledChanged(EventArgs).)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Overrides Control..::.OnGotFocus(EventArgs).)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInstrumentLoad | Occures after a chart has been loaded.
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Overrides Control..::.OnLostFocus(EventArgs).)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Overrides Control..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Overrides Control..::.OnSizeChanged(EventArgs).)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
OpenChart | Loads a chart from a file specified by a name.
OpenDialog | Shows an open dialog for chart loading from a file.
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Print | Prints chart image.
PrintDialog | Shows the printing dialog.
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Reload | Recalculates a chart.
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RunDesigner | Runs the designer for the chart displayed.
SaveAsImageDialog | Shows a dialog for a chart saving in the form of a picture.
SaveChart | Saves a chart to a file specified by name.
SaveDialog | Shows a dialog for a chart saving to a file.
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer..::.AccessibilityNotifyClients Method
ChartViewer Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ChartViewer Class
ChartViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer..::.BeginInvoke Method
ChartViewer Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ChartViewer Class
ChartViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


CopyToClipboard Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.CopyToClipboard Method
ChartViewer Class See Also Send Feedback
Copies chart image to the clipboard.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void CopyToClipboard()
Visual Basic (Declaration)
Public Sub CopyToClipboard
Visual C++
public:
void CopyToClipboard()

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


CreateNewChart Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.CreateNewChart Method
ChartViewer Class See Also Send Feedback
Creates a new chart.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void CreateNewChart()
Visual Basic (Declaration)
Public Sub CreateNewChart
Visual C++
public:
void CreateNewChart()

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer..::.Dispose Method
ChartViewer Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Overloaded. Releases the resources used by the Component. (Overrides ContainerControl..::.Dispose(Boolean).)

See Also

ChartViewer Class
ChartViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.Dispose Method (Boolean)
ChartViewer Class See Also Send Feedback
Overloaded. Releases the resources used by the Component.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

ChartViewer Class
Dispose Overload
PerpetuumSoft.Charts.Windows.Forms Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer..::.GetChildAtPoint Method
ChartViewer Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ChartViewer Class
ChartViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


GetDataList Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.GetDataList Method
ChartViewer Class See Also Send Feedback
Implements GetDataList(String).

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Object GetDataList(
    string name
)
Visual Basic (Declaration)
Public Function GetDataList ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetDataList(
    String^ name
) sealed

Parameters

name
Type: System..::.String

Implements

IDataContext..::.GetDataList(String)

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


GetDataListNames Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.GetDataListNames Method
ChartViewer Class See Also Send Feedback
Implements GetDataListNames()()().

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public string[] GetDataListNames()
Visual Basic (Declaration)
Public Function GetDataListNames As String()
Visual C++
public:
virtual array<String^>^ GetDataListNames() sealed

Implements

IDataContext..::.GetDataListNames()()()

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


GetElementAt Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer..::.GetElementAt Method
ChartViewer Class See Also Send Feedback

Overload List

Name | Description
GetElementAt(Point) | Returns a chart element placed at the specified point.
GetElementAt(Int32, Int32) | Returns a chart element placed at the specified point.

See Also

ChartViewer Class
ChartViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


GetElementAt Method (Point)

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.GetElementAt Method (Point)
ChartViewer Class See Also Send Feedback
Returns a chart element placed at the specified point.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Element GetElementAt(
    Point point
)
Visual Basic (Declaration)
Public Function GetElementAt ( _
    point As Point _
) As Element
Visual C++
public:
Element^ GetElementAt(
    Point point
)

Parameters

point
Type: System.Drawing..::.Point

See Also

ChartViewer Class
GetElementAt Overload
PerpetuumSoft.Charts.Windows.Forms Namespace


GetElementAt Method (Int32, Int32)

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.GetElementAt Method (Int32, Int32)
ChartViewer Class See Also Send Feedback
Returns a chart element placed at the specified point.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Element GetElementAt(
    int x,
    int y
)
Visual Basic (Declaration)
Public Function GetElementAt ( _
    x As Integer, _
    y As Integer _
) As Element
Visual C++
public:
Element^ GetElementAt(
    int x,
    int y
)

Parameters

x
Type: System..::.Int32
y
Type: System..::.Int32

See Also

ChartViewer Class
GetElementAt Overload
PerpetuumSoft.Charts.Windows.Forms Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer..::.Invalidate Method
ChartViewer Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ChartViewer Class
ChartViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer..::.Invoke Method
ChartViewer Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ChartViewer Class
ChartViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer..::.MemberwiseClone Method
ChartViewer Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ChartViewer Class
ChartViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


OnEnabledChanged Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.OnEnabledChanged Method
ChartViewer Class See Also Send Feedback
Raises the EnabledChanged event.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnEnabledChanged(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnEnabledChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnEnabledChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


OnGotFocus Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.OnGotFocus Method
ChartViewer Class See Also Send Feedback
Raises the GotFocus event.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnGotFocus(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnGotFocus ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnGotFocus(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


OnInstrumentLoad Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.OnInstrumentLoad Method
ChartViewer Class See Also Send Feedback
Occures after a chart has been loaded.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnInstrumentLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnInstrumentLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnInstrumentLoad(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.OnLoad Method
ChartViewer Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


OnLostFocus Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.OnLostFocus Method
ChartViewer Class See Also Send Feedback
Raises the LostFocus event.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLostFocus(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLostFocus ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLostFocus(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


OnPaint Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.OnPaint Method
ChartViewer Class See Also Send Feedback
Raises the Paint event.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.PaintEventArgs

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


OnSizeChanged Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.OnSizeChanged Method
ChartViewer Class See Also Send Feedback
Raises the SizeChanged event.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnSizeChanged(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnSizeChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSizeChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


OpenChart Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.OpenChart Method
ChartViewer Class See Also Send Feedback
Loads a chart from a file specified by a name.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void OpenChart(
    string fileName
)
Visual Basic (Declaration)
Public Sub OpenChart ( _
    fileName As String _
)
Visual C++
public:
void OpenChart(
    String^ fileName
)

Parameters

fileName
Type: System..::.String

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


OpenDialog Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.OpenDialog Method
ChartViewer Class See Also Send Feedback
Shows an open dialog for chart loading from a file.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void OpenDialog()
Visual Basic (Declaration)
Public Sub OpenDialog
Visual C++
public:
void OpenDialog()

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer..::.PerformLayout Method
ChartViewer Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ChartViewer Class
ChartViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


Print Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.Print Method
ChartViewer Class See Also Send Feedback
Prints chart image.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void Print(
    PrinterSettings printerSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    printerSettings As PrinterSettings _
)
Visual C++
public:
void Print(
    PrinterSettings^ printerSettings
)

Parameters

printerSettings
Type: System.Drawing.Printing..::.PrinterSettings

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


PrintDialog Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.PrintDialog Method
ChartViewer Class See Also Send Feedback
Shows the printing dialog.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void PrintDialog()
Visual Basic (Declaration)
Public Sub PrintDialog
Visual C++
public:
void PrintDialog()

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


Reload Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.Reload Method
ChartViewer Class See Also Send Feedback
Recalculates a chart.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void Reload()
Visual Basic (Declaration)
Public Sub Reload
Visual C++
public:
void Reload()

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer..::.ResumeLayout Method
ChartViewer Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ChartViewer Class
ChartViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer..::.RtlTranslateAlignment Method
ChartViewer Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ChartViewer Class
ChartViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


RunDesigner Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.RunDesigner Method
ChartViewer Class See Also Send Feedback
Runs the designer for the chart displayed.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public virtual void RunDesigner()
Visual Basic (Declaration)
Public Overridable Sub RunDesigner
Visual C++
public:
virtual void RunDesigner()

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


SaveAsImageDialog Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.SaveAsImageDialog Method
ChartViewer Class See Also Send Feedback
Shows a dialog for a chart saving in the form of a picture.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImageDialog()
Visual Basic (Declaration)
Public Sub SaveAsImageDialog
Visual C++
public:
void SaveAsImageDialog()

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


SaveChart Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.SaveChart Method
ChartViewer Class See Also Send Feedback
Saves a chart to a file specified by name.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void SaveChart(
    string fileName
)
Visual Basic (Declaration)
Public Sub SaveChart ( _
    fileName As String _
)
Visual C++
public:
void SaveChart(
    String^ fileName
)

Parameters

fileName
Type: System..::.String

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


SaveDialog Method

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.SaveDialog Method
ChartViewer Class See Also Send Feedback
Shows a dialog for a chart saving to a file.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public void SaveDialog()
Visual Basic (Declaration)
Public Sub SaveDialog
Visual C++
public:
void SaveDialog()

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer..::.Scale Method
ChartViewer Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ChartViewer Class
ChartViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer..::.Select Method
ChartViewer Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ChartViewer Class
ChartViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer..::.SetBounds Method
ChartViewer Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ChartViewer Class
ChartViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer..::.UpdateBounds Method
ChartViewer Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ChartViewer Class
ChartViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer..::.Validate Method
ChartViewer Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ChartViewer Class
ChartViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer..::.ValidateChildren Method
ChartViewer Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ChartViewer Class
ChartViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartViewer Properties

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer Properties
ChartViewer Class See Also Send Feedback

The ChartViewer type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Chart | Gets or sets Chart - a chart displayed.
ChartRectangle | Gets the area occupied by a chart.
ChartStream | Gets chart serialized to a string.
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DataSources | Gets a collection of data sources for a chart.
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFocusRectangle | Gets or sets a value which points that there is no need for display of the control framing even when it is in focus.
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvalidateInterval | Gets or sets image renewal interval.
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowCopyToClipboard | Gets or sets visibility of the 'Copy to clipboard' button on the Toolbar.
ShowDesigner | Gets or sets visibility of the 'Designer' button on the Toolbar.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowNew | Gets or sets visibility of the 'New' button on the Toolbar.
ShowOpen | Gets or sets visibility of the 'Open' button on the Toolbar.
ShowPrint | Gets or sets visibility of the 'Print' button on the Toolbar.
ShowSave | Gets or sets visibility of the 'Save' button on the Toolbar.
ShowSaveAsImage | Gets or sets visibility of the 'Save as image' button on the Toolbar.
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
ToolBarVisible | Gets or sets a value indicating that the toolbar is visible.
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
ZoomScale | Gets or sets zoom scale.

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


Chart Property

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.Chart Property
ChartViewer Class See Also Send Feedback
Gets or sets Chart - a chart displayed.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Chart Chart { get; set; }
Visual Basic (Declaration)
Public Property Chart As Chart
Visual C++
public:
property Chart^ Chart {
    Chart^ get ();
    void set (Chart^ value);
}

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartRectangle Property

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.ChartRectangle Property
ChartViewer Class See Also Send Feedback
Gets the area occupied by a chart.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public Rectangle ChartRectangle { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChartRectangle As Rectangle
Visual C++
public:
property Rectangle ChartRectangle {
    Rectangle get ();
}

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartStream Property

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.ChartStream Property
ChartViewer Class See Also Send Feedback
Gets chart serialized to a string.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public string ChartStream { get; set; }
Visual Basic (Declaration)
Public Property ChartStream As String
Visual C++
public:
property String^ ChartStream {
    String^ get ();
    void set (String^ value);
}

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


DataSources Property

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.DataSources Property
ChartViewer Class See Also Send Feedback
Gets a collection of data sources for a chart.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public ChartDataSourceCollection DataSources { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataSources As ChartDataSourceCollection
Visual C++
public:
property ChartDataSourceCollection^ DataSources {
    ChartDataSourceCollection^ get ();
}

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


HideFocusRectangle Property

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.HideFocusRectangle Property
ChartViewer Class See Also Send Feedback
Gets or sets a value which points that there is no need for display of the control framing even when it is in focus.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool HideFocusRectangle { get; set; }
Visual Basic (Declaration)
Public Property HideFocusRectangle As Boolean
Visual C++
public:
property bool HideFocusRectangle {
    bool get ();
    void set (bool value);
}

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


InvalidateInterval Property

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.InvalidateInterval Property
ChartViewer Class See Also Send Feedback
Gets or sets image renewal interval.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public int InvalidateInterval { get; set; }
Visual Basic (Declaration)
Public Property InvalidateInterval As Integer
Visual C++
public:
property int InvalidateInterval {
    int get ();
    void set (int value);
}

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ShowCopyToClipboard Property

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.ShowCopyToClipboard Property
ChartViewer Class See Also Send Feedback
Gets or sets visibility of the 'Copy to clipboard' button on the Toolbar.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowCopyToClipboard { get; set; }
Visual Basic (Declaration)
Public Property ShowCopyToClipboard As Boolean
Visual C++
public:
property bool ShowCopyToClipboard {
    bool get ();
    void set (bool value);
}

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ShowDesigner Property

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.ShowDesigner Property
ChartViewer Class See Also Send Feedback
Gets or sets visibility of the 'Designer' button on the Toolbar.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowDesigner { get; set; }
Visual Basic (Declaration)
Public Property ShowDesigner As Boolean
Visual C++
public:
property bool ShowDesigner {
    bool get ();
    void set (bool value);
}

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ShowNew Property

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.ShowNew Property
ChartViewer Class See Also Send Feedback
Gets or sets visibility of the 'New' button on the Toolbar.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowNew { get; set; }
Visual Basic (Declaration)
Public Property ShowNew As Boolean
Visual C++
public:
property bool ShowNew {
    bool get ();
    void set (bool value);
}

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ShowOpen Property

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.ShowOpen Property
ChartViewer Class See Also Send Feedback
Gets or sets visibility of the 'Open' button on the Toolbar.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowOpen { get; set; }
Visual Basic (Declaration)
Public Property ShowOpen As Boolean
Visual C++
public:
property bool ShowOpen {
    bool get ();
    void set (bool value);
}

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ShowPrint Property

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.ShowPrint Property
ChartViewer Class See Also Send Feedback
Gets or sets visibility of the 'Print' button on the Toolbar.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowPrint { get; set; }
Visual Basic (Declaration)
Public Property ShowPrint As Boolean
Visual C++
public:
property bool ShowPrint {
    bool get ();
    void set (bool value);
}

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ShowSave Property

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.ShowSave Property
ChartViewer Class See Also Send Feedback
Gets or sets visibility of the 'Save' button on the Toolbar.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowSave { get; set; }
Visual Basic (Declaration)
Public Property ShowSave As Boolean
Visual C++
public:
property bool ShowSave {
    bool get ();
    void set (bool value);
}

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ShowSaveAsImage Property

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.ShowSaveAsImage Property
ChartViewer Class See Also Send Feedback
Gets or sets visibility of the 'Save as image' button on the Toolbar.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowSaveAsImage { get; set; }
Visual Basic (Declaration)
Public Property ShowSaveAsImage As Boolean
Visual C++
public:
property bool ShowSaveAsImage {
    bool get ();
    void set (bool value);
}

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ToolBarVisible Property

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.ToolBarVisible Property
ChartViewer Class See Also Send Feedback
Gets or sets a value indicating that the toolbar is visible.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public bool ToolBarVisible { get; set; }
Visual Basic (Declaration)
Public Property ToolBarVisible As Boolean
Visual C++
public:
property bool ToolBarVisible {
    bool get ();
    void set (bool value);
}

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ZoomScale Property

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.ZoomScale Property
ChartViewer Class See Also Send Feedback
Gets or sets zoom scale.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public double ZoomScale { get; set; }
Visual Basic (Declaration)
Public Property ZoomScale As Double
Visual C++
public:
property double ZoomScale {
    double get ();
    void set (double value);
}

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


ChartViewer Events

[image] [image]

.NET ModelKit Suite ClassReference
ChartViewer Events
ChartViewer Class See Also Send Feedback

The ChartViewer type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InstrumentLoad | Loads a chart.
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


InstrumentLoad Event

[image]

.NET ModelKit Suite ClassReference
ChartViewer..::.InstrumentLoad Event
ChartViewer Class See Also Send Feedback
Loads a chart.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler InstrumentLoad
Visual Basic (Declaration)
Public Event InstrumentLoad As EventHandler
Visual C++
public:
 event EventHandler^ InstrumentLoad {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ChartViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


DashboardViewer Class

[image]

.NET ModelKit Suite ClassReference
DashboardViewer Class
Members See Also Send Feedback
Presents a control to display a dashboard.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public class DashboardViewer : ChartViewer
Visual Basic (Declaration)
Public Class DashboardViewer _
    Inherits ChartViewer
Visual C++
public ref class DashboardViewer : public ChartViewer

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Charts.Windows.Forms..::.ChartViewer
PerpetuumSoft.Charts.Windows.Forms..::.DashboardViewer

See Also

DashboardViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


DashboardViewer Members

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer Members
DashboardViewer Class Constructors Methods Properties Events See Also Send Feedback

The DashboardViewer type exposes the following members.

Constructors

Name | Description
DashboardViewer | Initializes a new instance of the DashboardViewer class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CopyToClipboard | Copies chart image to the clipboard. (Inherited from ChartViewer.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateDashboardDesignerForm | Returns the initialized form of the designer to edit dashboard.
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateNewChart | Creates a new chart. (Inherited from ChartViewer.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetDataList | Implements GetDataList(String). (Inherited from ChartViewer.)
GetDataListNames | Implements GetDataListNames()()(). (Inherited from ChartViewer.)
GetElementAt | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from ChartViewer.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from ChartViewer.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInstrumentLoad | Occures after a chart has been loaded. (Inherited from ChartViewer.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from ChartViewer.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from ChartViewer.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from ChartViewer.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from ChartViewer.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
OpenChart | Loads a chart from a file specified by a name. (Inherited from ChartViewer.)
OpenDialog | Shows an open dialog for chart loading from a file. (Inherited from ChartViewer.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Print | Prints chart image. (Inherited from ChartViewer.)
PrintDialog | Shows the printing dialog. (Inherited from ChartViewer.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Reload | Recalculates a chart. (Inherited from ChartViewer.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RunDesigner | Overridden. See RunDesigner()()(). (Overrides ChartViewer..::.RunDesigner()()().)
SaveAsImageDialog | Shows a dialog for a chart saving in the form of a picture. (Inherited from ChartViewer.)
SaveChart | Saves a chart to a file specified by name. (Inherited from ChartViewer.)
SaveDialog | Shows a dialog for a chart saving to a file. (Inherited from ChartViewer.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Chart | Gets or sets Chart - a chart displayed. (Inherited from ChartViewer.)
ChartRectangle | Gets the area occupied by a chart. (Inherited from ChartViewer.)
ChartStream | Gets chart serialized to a string. (Inherited from ChartViewer.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DataSources | Gets a collection of data sources for a chart. (Inherited from ChartViewer.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFocusRectangle | Gets or sets a value which points that there is no need for display of the control framing even when it is in focus. (Inherited from ChartViewer.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvalidateInterval | Gets or sets image renewal interval. (Inherited from ChartViewer.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowCopyToClipboard | Gets or sets visibility of the 'Copy to clipboard' button on the Toolbar. (Inherited from ChartViewer.)
ShowDesigner | Gets or sets visibility of the 'Designer' button on the Toolbar. (Inherited from ChartViewer.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowNew | Gets or sets visibility of the 'New' button on the Toolbar. (Inherited from ChartViewer.)
ShowOpen | Gets or sets visibility of the 'Open' button on the Toolbar. (Inherited from ChartViewer.)
ShowPrint | Gets or sets visibility of the 'Print' button on the Toolbar. (Inherited from ChartViewer.)
ShowSave | Gets or sets visibility of the 'Save' button on the Toolbar. (Inherited from ChartViewer.)
ShowSaveAsImage | Gets or sets visibility of the 'Save as image' button on the Toolbar. (Inherited from ChartViewer.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
ToolBarVisible | Gets or sets a value indicating that the toolbar is visible. (Inherited from ChartViewer.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
ZoomScale | Gets or sets zoom scale. (Inherited from ChartViewer.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InstrumentLoad | Loads a chart. (Inherited from ChartViewer.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DashboardViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


DashboardViewer Constructor

[image]

.NET ModelKit Suite ClassReference
DashboardViewer Constructor
DashboardViewer Class See Also Send Feedback
Initializes a new instance of the DashboardViewer class.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public DashboardViewer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DashboardViewer()

See Also

DashboardViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


DashboardViewer Methods

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer Methods
DashboardViewer Class See Also Send Feedback

The DashboardViewer type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CopyToClipboard | Copies chart image to the clipboard. (Inherited from ChartViewer.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateDashboardDesignerForm | Returns the initialized form of the designer to edit dashboard.
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateNewChart | Creates a new chart. (Inherited from ChartViewer.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetDataList | Implements GetDataList(String). (Inherited from ChartViewer.)
GetDataListNames | Implements GetDataListNames()()(). (Inherited from ChartViewer.)
GetElementAt | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from ChartViewer.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from ChartViewer.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInstrumentLoad | Occures after a chart has been loaded. (Inherited from ChartViewer.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from ChartViewer.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from ChartViewer.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from ChartViewer.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from ChartViewer.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
OpenChart | Loads a chart from a file specified by a name. (Inherited from ChartViewer.)
OpenDialog | Shows an open dialog for chart loading from a file. (Inherited from ChartViewer.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Print | Prints chart image. (Inherited from ChartViewer.)
PrintDialog | Shows the printing dialog. (Inherited from ChartViewer.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Reload | Recalculates a chart. (Inherited from ChartViewer.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RunDesigner | Overridden. See RunDesigner()()(). (Overrides ChartViewer..::.RunDesigner()()().)
SaveAsImageDialog | Shows a dialog for a chart saving in the form of a picture. (Inherited from ChartViewer.)
SaveChart | Saves a chart to a file specified by name. (Inherited from ChartViewer.)
SaveDialog | Shows a dialog for a chart saving to a file. (Inherited from ChartViewer.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

DashboardViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer..::.AccessibilityNotifyClients Method
DashboardViewer Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DashboardViewer Class
DashboardViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer..::.BeginInvoke Method
DashboardViewer Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DashboardViewer Class
DashboardViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


CreateDashboardDesignerForm Method

[image]

.NET ModelKit Suite ClassReference
DashboardViewer..::.CreateDashboardDesignerForm Method
DashboardViewer Class See Also Send Feedback
Returns the initialized form of the designer to edit dashboard.

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public static DesignerForm CreateDashboardDesignerForm()
Visual Basic (Declaration)
Public Shared Function CreateDashboardDesignerForm As DesignerForm
Visual C++
public:
static DesignerForm^ CreateDashboardDesignerForm()

See Also

DashboardViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer..::.Dispose Method
DashboardViewer Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Overloaded. Releases the resources used by the Component. (Inherited from ChartViewer.)

See Also

DashboardViewer Class
DashboardViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer..::.GetChildAtPoint Method
DashboardViewer Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DashboardViewer Class
DashboardViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


GetElementAt Method

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer..::.GetElementAt Method
DashboardViewer Class See Also Send Feedback

Overload List

Name | Description
GetElementAt(Point) | Returns a chart element placed at the specified point. (Inherited from ChartViewer.)
GetElementAt(Int32, Int32) | Returns a chart element placed at the specified point. (Inherited from ChartViewer.)

See Also

DashboardViewer Class
DashboardViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer..::.Invalidate Method
DashboardViewer Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DashboardViewer Class
DashboardViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer..::.Invoke Method
DashboardViewer Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DashboardViewer Class
DashboardViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer..::.MemberwiseClone Method
DashboardViewer Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DashboardViewer Class
DashboardViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer..::.PerformLayout Method
DashboardViewer Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DashboardViewer Class
DashboardViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer..::.ResumeLayout Method
DashboardViewer Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DashboardViewer Class
DashboardViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer..::.RtlTranslateAlignment Method
DashboardViewer Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DashboardViewer Class
DashboardViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


RunDesigner Method

[image]

.NET ModelKit Suite ClassReference
DashboardViewer..::.RunDesigner Method
DashboardViewer Class See Also Send Feedback
Overridden. See RunDesigner()()().

Namespace: PerpetuumSoft.Charts.Windows.Forms
Assembly: PerpetuumSoft.Charts (in PerpetuumSoft.Charts.dll) Version: 3.9.0.1

Syntax

C#
public override void RunDesigner()
Visual Basic (Declaration)
Public Overrides Sub RunDesigner
Visual C++
public:
virtual void RunDesigner() override

See Also

DashboardViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer..::.Scale Method
DashboardViewer Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DashboardViewer Class
DashboardViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer..::.Select Method
DashboardViewer Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

DashboardViewer Class
DashboardViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer..::.SetBounds Method
DashboardViewer Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DashboardViewer Class
DashboardViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer..::.UpdateBounds Method
DashboardViewer Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DashboardViewer Class
DashboardViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer..::.Validate Method
DashboardViewer Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DashboardViewer Class
DashboardViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer..::.ValidateChildren Method
DashboardViewer Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

DashboardViewer Class
DashboardViewer Members
PerpetuumSoft.Charts.Windows.Forms Namespace


DashboardViewer Properties

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer Properties
DashboardViewer Class See Also Send Feedback

The DashboardViewer type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Chart | Gets or sets Chart - a chart displayed. (Inherited from ChartViewer.)
ChartRectangle | Gets the area occupied by a chart. (Inherited from ChartViewer.)
ChartStream | Gets chart serialized to a string. (Inherited from ChartViewer.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DataSources | Gets a collection of data sources for a chart. (Inherited from ChartViewer.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFocusRectangle | Gets or sets a value which points that there is no need for display of the control framing even when it is in focus. (Inherited from ChartViewer.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvalidateInterval | Gets or sets image renewal interval. (Inherited from ChartViewer.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowCopyToClipboard | Gets or sets visibility of the 'Copy to clipboard' button on the Toolbar. (Inherited from ChartViewer.)
ShowDesigner | Gets or sets visibility of the 'Designer' button on the Toolbar. (Inherited from ChartViewer.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowNew | Gets or sets visibility of the 'New' button on the Toolbar. (Inherited from ChartViewer.)
ShowOpen | Gets or sets visibility of the 'Open' button on the Toolbar. (Inherited from ChartViewer.)
ShowPrint | Gets or sets visibility of the 'Print' button on the Toolbar. (Inherited from ChartViewer.)
ShowSave | Gets or sets visibility of the 'Save' button on the Toolbar. (Inherited from ChartViewer.)
ShowSaveAsImage | Gets or sets visibility of the 'Save as image' button on the Toolbar. (Inherited from ChartViewer.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
ToolBarVisible | Gets or sets a value indicating that the toolbar is visible. (Inherited from ChartViewer.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
ZoomScale | Gets or sets zoom scale. (Inherited from ChartViewer.)

See Also

DashboardViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


DashboardViewer Events

[image] [image]

.NET ModelKit Suite ClassReference
DashboardViewer Events
DashboardViewer Class See Also Send Feedback

The DashboardViewer type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InstrumentLoad | Loads a chart. (Inherited from ChartViewer.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DashboardViewer Class
PerpetuumSoft.Charts.Windows.Forms Namespace


PerpetuumSoft.Framework Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Framework Namespace
Send Feedback
The PerpetuumSoft.Framework namespace contains base classes which are used in the Perpetuum Software products.

Classes

Class | Description
Atom | Represents the base class for objects that have immutable behaviour.


Atom Class

[image]

.NET ModelKit Suite ClassReference
Atom Class
Members See Also Send Feedback
Represents the base class for objects that have immutable behaviour.

Namespace: PerpetuumSoft.Framework
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract class Atom : ICloneable
Visual Basic (Declaration)
Public MustInherit Class Atom _
    Implements ICloneable
Visual C++
public ref class Atom abstract : ICloneable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework..::.Atom
PerpetuumSoft.Framework.Drawing..::.Border
PerpetuumSoft.Framework.Drawing..::.Fill
PerpetuumSoft.Framework.Drawing..::.Stroke
PerpetuumSoft.Instrumentation.Model..::.Bevel
PerpetuumSoft.Reporting.DOM..::.GraphicsSettings

See Also

Atom Members
PerpetuumSoft.Framework Namespace


Atom Members

[image] [image]

.NET ModelKit Suite ClassReference
Atom Members
Atom Class Constructors Methods Properties See Also Send Feedback

The Atom type exposes the following members.

Constructors

Name | Description
Atom | Initializes a new instance of the Atom class

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type.
Clone | Returns the copy of this object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImmutableOrNull | Returns the immutable version of the given object or null, if the given object is null.
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsImmutable | Gets whether this object is immutable.

See Also

Atom Class
PerpetuumSoft.Framework Namespace


Atom Constructor

[image]

.NET ModelKit Suite ClassReference
Atom Constructor
Atom Class See Also Send Feedback
Initializes a new instance of the Atom class

Namespace: PerpetuumSoft.Framework
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected Atom()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
Atom()

See Also

Atom Class
PerpetuumSoft.Framework Namespace


Atom Methods

[image] [image]

.NET ModelKit Suite ClassReference
Atom Methods
Atom Class See Also Send Feedback

The Atom type exposes the following members.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type.
Clone | Returns the copy of this object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImmutableOrNull | Returns the immutable version of the given object or null, if the given object is null.
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Atom Class
PerpetuumSoft.Framework Namespace


CheckMutable Method

[image]

.NET ModelKit Suite ClassReference
Atom..::.CheckMutable Method
Atom Class See Also Send Feedback
Throws an exception if the object is immutable. Exception has InvalidOperationException type.

Namespace: PerpetuumSoft.Framework
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected void CheckMutable()
Visual Basic (Declaration)
Protected Sub CheckMutable
Visual C++
protected:
void CheckMutable()

See Also

Atom Class
PerpetuumSoft.Framework Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
Atom..::.Clone Method
Atom Class See Also Send Feedback
Returns the copy of this object.

Namespace: PerpetuumSoft.Framework
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public virtual Object Clone()
Visual Basic (Declaration)
Public Overridable Function Clone As Object
Visual C++
public:
virtual Object^ Clone()

Implements

ICloneable..::.Clone()()()

See Also

Atom Class
PerpetuumSoft.Framework Namespace


GetImmutableOrNull Method

[image]

.NET ModelKit Suite ClassReference
Atom..::.GetImmutableOrNull Method
Atom Class See Also Send Feedback
Returns the immutable version of the given object or null, if the given object is null.

Namespace: PerpetuumSoft.Framework
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Atom GetImmutableOrNull(
    Atom source
)
Visual Basic (Declaration)
Public Shared Function GetImmutableOrNull ( _
    source As Atom _
) As Atom
Visual C++
public:
static Atom^ GetImmutableOrNull(
    Atom^ source
)

Parameters

source
Type: PerpetuumSoft.Framework..::.Atom

See Also

Atom Class
PerpetuumSoft.Framework Namespace


GetImmutableVersion Method

[image]

.NET ModelKit Suite ClassReference
Atom..::.GetImmutableVersion Method
Atom Class See Also Send Feedback
Returns this object if it is immutable or immutable clone of it.

Namespace: PerpetuumSoft.Framework
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Atom GetImmutableVersion()
Visual Basic (Declaration)
Public Function GetImmutableVersion As Atom
Visual C++
public:
Atom^ GetImmutableVersion()

See Also

Atom Class
PerpetuumSoft.Framework Namespace


MakeImmutable Method

[image]

.NET ModelKit Suite ClassReference
Atom..::.MakeImmutable Method
Atom Class See Also Send Feedback
Makes this class as immutable.

Namespace: PerpetuumSoft.Framework
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void MakeImmutable()
Visual Basic (Declaration)
Public Sub MakeImmutable
Visual C++
public:
void MakeImmutable()

See Also

Atom Class
PerpetuumSoft.Framework Namespace


Atom Properties

[image] [image]

.NET ModelKit Suite ClassReference
Atom Properties
Atom Class See Also Send Feedback

The Atom type exposes the following members.

Properties

Name | Description
IsImmutable | Gets whether this object is immutable.

See Also

Atom Class
PerpetuumSoft.Framework Namespace


IsImmutable Property

[image]

.NET ModelKit Suite ClassReference
Atom..::.IsImmutable Property
Atom Class See Also Send Feedback
Gets whether this object is immutable.

Namespace: PerpetuumSoft.Framework
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public bool IsImmutable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsImmutable As Boolean
Visual C++
public:
property bool IsImmutable {
    bool get ();
}

See Also

Atom Class
PerpetuumSoft.Framework Namespace


PerpetuumSoft.Framework.Connectivity Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Framework.Connectivity Namespace
Send Feedback
The PerpetuumSoft.Framework.Connectivity namespace contains classes which give access to the OPC server data.

Classes

Class | Description
Connection | Abstract Connection Component class.
DataChannel | Abstract DataChannel Component class.
DataError | Class to be used to report both synchrnous and asynchronous errors/warning during DataChannel operations
DataPoint | Represent data for one item, one time.
DataSlice | Represent data for many items, one time.
DataSlicesEventArgs | Provides data for DataTransmission event.
ItemCollection | Collection of items as used in the DataChannel component.
ItemSpec | Item specification to be used in ItemCollectionEditor.
OPCChannel | Provides access to data from a process using concrete OPC Server Note: DataPoint time is the same if provided by an OPC server, different if provided by a device.
OPCConnection | Class desсribes all the connection parameters for OPC Data Access.
TransactionItemsStatus | Represent information about DataItem.
WriteStatusEventArgs | Provides data for the WriteStatus event.

Structures

Structure | Description
ItemInfo | Represent information about DataItem.
OPCServerDetail | Represents information about OPC Server.

Interfaces

Interface | Description
ITransaction | Represent basic functionality for transaction classes.

Delegates

Delegate | Description
DataTransmissionEventHandler | Represents the method that will handle the DataTransmittion event.
WriteStatusEventHandler | Represents the method that will handle the WriteStatus event.

Enumerations

Enumeration | Description
AccessRights | Represents access rights for DataItem.
Quality | Represents possible qualities of DataPoint.


AccessRights Enumeration

[image]

.NET ModelKit Suite ClassReference
AccessRights Enumeration
See Also Send Feedback
Represents access rights for DataItem.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
[FlagsAttribute]
public enum AccessRights
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration AccessRights
Visual C++
[FlagsAttribute]
public enum class AccessRights

Members

Member name | Description
All | Full access.
Readable | Access to read.
Writeable | Access to write.

See Also

PerpetuumSoft.Framework.Connectivity Namespace


Connection Class

[image]

.NET ModelKit Suite ClassReference
Connection Class
Members See Also Send Feedback
Abstract Connection Component class.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public abstract class Connection : Component
Visual Basic (Declaration)
Public MustInherit Class Connection _
    Inherits Component
Visual C++
public ref class Connection abstract : public Component

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Framework.Connectivity..::.Connection
PerpetuumSoft.Framework.Connectivity..::.OPCConnection

See Also

Connection Members
PerpetuumSoft.Framework.Connectivity Namespace


Connection Members

[image] [image]

.NET ModelKit Suite ClassReference
Connection Members
Connection Class Methods Properties Events See Also Send Feedback

The Connection type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Connection Class
PerpetuumSoft.Framework.Connectivity Namespace


Connection Methods

[image] [image]

.NET ModelKit Suite ClassReference
Connection Methods
Connection Class See Also Send Feedback

The Connection type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

Connection Class
PerpetuumSoft.Framework.Connectivity Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Connection..::.Dispose Method
Connection Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

Connection Class
Connection Members
PerpetuumSoft.Framework.Connectivity Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
Connection..::.MemberwiseClone Method
Connection Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

Connection Class
Connection Members
PerpetuumSoft.Framework.Connectivity Namespace


Connection Properties

[image] [image]

.NET ModelKit Suite ClassReference
Connection Properties
Connection Class See Also Send Feedback

The Connection type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

Connection Class
PerpetuumSoft.Framework.Connectivity Namespace


Connection Events

[image] [image]

.NET ModelKit Suite ClassReference
Connection Events
Connection Class See Also Send Feedback

The Connection type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

Connection Class
PerpetuumSoft.Framework.Connectivity Namespace


DataChannel Class

[image]

.NET ModelKit Suite ClassReference
DataChannel Class
Members See Also Send Feedback
Abstract DataChannel Component class.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public abstract class DataChannel : Component
Visual Basic (Declaration)
Public MustInherit Class DataChannel _
    Inherits Component
Visual C++
public ref class DataChannel abstract : public Component

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Framework.Connectivity..::.DataChannel
PerpetuumSoft.Framework.Connectivity..::.OPCChannel

See Also

DataChannel Members
PerpetuumSoft.Framework.Connectivity Namespace


DataChannel Members

[image] [image]

.NET ModelKit Suite ClassReference
DataChannel Members
DataChannel Class Methods Properties Events See Also Send Feedback

The DataChannel type exposes the following members.

Methods

Name | Description
AsynchronousRead | Sends request to get items (for current time) asyncronously from a provider. Data will be returned for all items in one event in EventArgs.
AsynchronousSubscription | Overloaded.
CancelSubscription | Cancels any transaction.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EstablishConnection | Establishes connection.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetAvailableItems | Returns an array of ItemInfo that represents avaliable Items.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
ReloadItemInfos | Reloads information about avaliable items.
ResetConnection | Resets current connection.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Write | Writes data into a DataChannel.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ConnectionSet | Flag indicating that the connection has been set and established. Note: Connection must be always established at the moment of setting as a current one for given DataChannel.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataCultureInfo | Gets or sets CultureInfo (language) to provide data with current DataChannel (if available).
DataProviderCurrentTime | Returns DataProvider current time, can be used to synchronize provider and system clock.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
DataTransmission | Occurs when data is transmitted.
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
WriteStatus | Occurs when writing to DataChannel is complete.

See Also

DataChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


DataChannel Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataChannel Methods
DataChannel Class See Also Send Feedback

The DataChannel type exposes the following members.

Methods

Name | Description
AsynchronousRead | Sends request to get items (for current time) asyncronously from a provider. Data will be returned for all items in one event in EventArgs.
AsynchronousSubscription | Overloaded.
CancelSubscription | Cancels any transaction.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EstablishConnection | Establishes connection.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetAvailableItems | Returns an array of ItemInfo that represents avaliable Items.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
ReloadItemInfos | Reloads information about avaliable items.
ResetConnection | Resets current connection.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Write | Writes data into a DataChannel.

See Also

DataChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


AsynchronousRead Method

[image]

.NET ModelKit Suite ClassReference
DataChannel..::.AsynchronousRead Method
DataChannel Class See Also Send Feedback
Sends request to get items (for current time) asyncronously from a provider. Data will be returned for all items in one event in EventArgs.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public abstract TransactionItemsStatus AsynchronousRead()
Visual Basic (Declaration)
Public MustOverride Function AsynchronousRead As TransactionItemsStatus
Visual C++
public:
virtual TransactionItemsStatus^ AsynchronousRead() abstract

See Also

DataChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


AsynchronousSubscription Method

[image] [image]

.NET ModelKit Suite ClassReference
DataChannel..::.AsynchronousSubscription Method
DataChannel Class See Also Send Feedback

Overload List

Name | Description
AsynchronousSubscription(UInt32) | Sends subscription request.
AsynchronousSubscription(UInt32, UInt32) | Sends subscription request, data will be buffered to send events at 'resfreshRate'.

See Also

DataChannel Class
DataChannel Members
PerpetuumSoft.Framework.Connectivity Namespace


AsynchronousSubscription Method (UInt32)

[image]

.NET ModelKit Suite ClassReference
DataChannel..::.AsynchronousSubscription Method (UInt32)
DataChannel Class See Also Send Feedback
Sends subscription request.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public abstract ITransaction AsynchronousSubscription(
    uint dataRate
)
Visual Basic (Declaration)
Public MustOverride Function AsynchronousSubscription ( _
    dataRate As UInteger _
) As ITransaction
Visual C++
public:
virtual ITransaction^ AsynchronousSubscription(
    unsigned int dataRate
) abstract

Parameters

dataRate
Type: System..::.UInt32

See Also

DataChannel Class
AsynchronousSubscription Overload
PerpetuumSoft.Framework.Connectivity Namespace


AsynchronousSubscription Method (UInt32, UInt32)

[image]

.NET ModelKit Suite ClassReference
DataChannel..::.AsynchronousSubscription Method (UInt32, UInt32)
DataChannel Class See Also Send Feedback
Sends subscription request, data will be buffered to send events at 'resfreshRate'.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public abstract ITransaction AsynchronousSubscription(
    uint dataRate,
    uint refreshRate
)
Visual Basic (Declaration)
Public MustOverride Function AsynchronousSubscription ( _
    dataRate As UInteger, _
    refreshRate As UInteger _
) As ITransaction
Visual C++
public:
virtual ITransaction^ AsynchronousSubscription(
    unsigned int dataRate,
    unsigned int refreshRate
) abstract

Parameters

dataRate
Type: System..::.UInt32
refreshRate
Type: System..::.UInt32

See Also

DataChannel Class
AsynchronousSubscription Overload
PerpetuumSoft.Framework.Connectivity Namespace


CancelSubscription Method

[image]

.NET ModelKit Suite ClassReference
DataChannel..::.CancelSubscription Method
DataChannel Class See Also Send Feedback
Cancels any transaction.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public abstract bool CancelSubscription(
    ITransaction transaction
)
Visual Basic (Declaration)
Public MustOverride Function CancelSubscription ( _
    transaction As ITransaction _
) As Boolean
Visual C++
public:
virtual bool CancelSubscription(
    ITransaction^ transaction
) abstract

Parameters

transaction
Type: PerpetuumSoft.Framework.Connectivity..::.ITransaction

See Also

DataChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
DataChannel..::.Dispose Method
DataChannel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

DataChannel Class
DataChannel Members
PerpetuumSoft.Framework.Connectivity Namespace


EstablishConnection Method

[image]

.NET ModelKit Suite ClassReference
DataChannel..::.EstablishConnection Method
DataChannel Class See Also Send Feedback
Establishes connection.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public abstract void EstablishConnection()
Visual Basic (Declaration)
Public MustOverride Sub EstablishConnection
Visual C++
public:
virtual void EstablishConnection() abstract

See Also

DataChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


GetAvailableItems Method

[image]

.NET ModelKit Suite ClassReference
DataChannel..::.GetAvailableItems Method
DataChannel Class See Also Send Feedback
Returns an array of ItemInfo that represents avaliable Items.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public abstract ItemInfo[] GetAvailableItems()
Visual Basic (Declaration)
Public MustOverride Function GetAvailableItems As ItemInfo()
Visual C++
public:
virtual array<ItemInfo>^ GetAvailableItems() abstract

See Also

DataChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
DataChannel..::.MemberwiseClone Method
DataChannel Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DataChannel Class
DataChannel Members
PerpetuumSoft.Framework.Connectivity Namespace


ReloadItemInfos Method

[image]

.NET ModelKit Suite ClassReference
DataChannel..::.ReloadItemInfos Method
DataChannel Class See Also Send Feedback
Reloads information about avaliable items.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public abstract void ReloadItemInfos()
Visual Basic (Declaration)
Public MustOverride Sub ReloadItemInfos
Visual C++
public:
virtual void ReloadItemInfos() abstract

See Also

DataChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


ResetConnection Method

[image]

.NET ModelKit Suite ClassReference
DataChannel..::.ResetConnection Method
DataChannel Class See Also Send Feedback
Resets current connection.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public abstract void ResetConnection()
Visual Basic (Declaration)
Public MustOverride Sub ResetConnection
Visual C++
public:
virtual void ResetConnection() abstract

See Also

DataChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


Write Method

[image]

.NET ModelKit Suite ClassReference
DataChannel..::.Write Method
DataChannel Class See Also Send Feedback
Writes data into a DataChannel.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public abstract TransactionItemsStatus Write(
    Object[] values
)
Visual Basic (Declaration)
Public MustOverride Function Write ( _
    values As Object() _
) As TransactionItemsStatus
Visual C++
public:
virtual TransactionItemsStatus^ Write(
    array<Object^>^ values
) abstract

Parameters

values
Type: array< System..::.Object >[]()[]

See Also

DataChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


DataChannel Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataChannel Properties
DataChannel Class See Also Send Feedback

The DataChannel type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ConnectionSet | Flag indicating that the connection has been set and established. Note: Connection must be always established at the moment of setting as a current one for given DataChannel.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataCultureInfo | Gets or sets CultureInfo (language) to provide data with current DataChannel (if available).
DataProviderCurrentTime | Returns DataProvider current time, can be used to synchronize provider and system clock.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

DataChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


ConnectionSet Property

[image]

.NET ModelKit Suite ClassReference
DataChannel..::.ConnectionSet Property
DataChannel Class See Also Send Feedback
Flag indicating that the connection has been set and established. Note: Connection must be always established at the moment of setting as a current one for given DataChannel.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public bool ConnectionSet { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConnectionSet As Boolean
Visual C++
public:
property bool ConnectionSet {
    bool get ();
}

See Also

DataChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


DataCultureInfo Property

[image]

.NET ModelKit Suite ClassReference
DataChannel..::.DataCultureInfo Property
DataChannel Class See Also Send Feedback
Gets or sets CultureInfo (language) to provide data with current DataChannel (if available).

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public abstract CultureInfo DataCultureInfo { get; set; }
Visual Basic (Declaration)
Public MustOverride Property DataCultureInfo As CultureInfo
Visual C++
public:
virtual property CultureInfo^ DataCultureInfo {
    CultureInfo^ get () abstract;
    void set (CultureInfo^ value) abstract;
}

See Also

DataChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


DataProviderCurrentTime Property

[image]

.NET ModelKit Suite ClassReference
DataChannel..::.DataProviderCurrentTime Property
DataChannel Class See Also Send Feedback
Returns DataProvider current time, can be used to synchronize provider and system clock.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public abstract DateTime DataProviderCurrentTime { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property DataProviderCurrentTime As DateTime
Visual C++
public:
virtual property DateTime DataProviderCurrentTime {
    DateTime get () abstract;
}

See Also

DataChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


DataChannel Events

[image] [image]

.NET ModelKit Suite ClassReference
DataChannel Events
DataChannel Class See Also Send Feedback

The DataChannel type exposes the following members.

Events

Name | Description
DataTransmission | Occurs when data is transmitted.
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
WriteStatus | Occurs when writing to DataChannel is complete.

See Also

DataChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


DataTransmission Event

[image]

.NET ModelKit Suite ClassReference
DataChannel..::.DataTransmission Event
DataChannel Class See Also Send Feedback
Occurs when data is transmitted.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public abstract event DataTransmissionEventHandler DataTransmission
Visual Basic (Declaration)
Public MustOverride Event DataTransmission As DataTransmissionEventHandler
Visual C++
public:
virtual  event DataTransmissionEventHandler^ DataTransmission {
    void add (DataTransmissionEventHandler^ value);
    void remove (DataTransmissionEventHandler^ value);
}

See Also

DataChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


WriteStatus Event

[image]

.NET ModelKit Suite ClassReference
DataChannel..::.WriteStatus Event
DataChannel Class See Also Send Feedback
Occurs when writing to DataChannel is complete.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public abstract event WriteStatusEventHandler WriteStatus
Visual Basic (Declaration)
Public MustOverride Event WriteStatus As WriteStatusEventHandler
Visual C++
public:
virtual  event WriteStatusEventHandler^ WriteStatus {
    void add (WriteStatusEventHandler^ value);
    void remove (WriteStatusEventHandler^ value);
}

See Also

DataChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


DataError Class

[image]

.NET ModelKit Suite ClassReference
DataError Class
Members See Also Send Feedback
Class to be used to report both synchrnous and asynchronous errors/warning during DataChannel operations

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public class DataError
Visual Basic (Declaration)
Public Class DataError
Visual C++
public ref class DataError

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Connectivity..::.DataError

See Also

DataError Members
PerpetuumSoft.Framework.Connectivity Namespace


DataError Members

[image] [image]

.NET ModelKit Suite ClassReference
DataError Members
DataError Class Constructors Methods Properties See Also Send Feedback

The DataError type exposes the following members.

Constructors

Name | Description
DataError | Initializes a new instance of the DataError class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ErrorNumber | Gets error number.
ErrorText | Gets error text.
IsWarning | Returns value indicating that an instance of DataError is a warning.
ItemID | Gets error ID.

See Also

DataError Class
PerpetuumSoft.Framework.Connectivity Namespace


DataError Constructor

[image]

.NET ModelKit Suite ClassReference
DataError Constructor
DataError Class See Also Send Feedback
Initializes a new instance of the DataError class.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public DataError(
    string itemID,
    uint errorNumber,
    string errorText,
    bool isWarning
)
Visual Basic (Declaration)
Public Sub New ( _
    itemID As String, _
    errorNumber As UInteger, _
    errorText As String, _
    isWarning As Boolean _
)
Visual C++
public:
DataError(
    String^ itemID,
    unsigned int errorNumber,
    String^ errorText,
    bool isWarning
)

Parameters

itemID
Type: System..::.String
errorNumber
Type: System..::.UInt32
errorText
Type: System..::.String
isWarning
Type: System..::.Boolean

See Also

DataError Class
PerpetuumSoft.Framework.Connectivity Namespace


DataError Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataError Methods
DataError Class See Also Send Feedback

The DataError type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataError Class
PerpetuumSoft.Framework.Connectivity Namespace


DataError Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataError Properties
DataError Class See Also Send Feedback

The DataError type exposes the following members.

Properties

Name | Description
ErrorNumber | Gets error number.
ErrorText | Gets error text.
IsWarning | Returns value indicating that an instance of DataError is a warning.
ItemID | Gets error ID.

See Also

DataError Class
PerpetuumSoft.Framework.Connectivity Namespace


ErrorNumber Property

[image]

.NET ModelKit Suite ClassReference
DataError..::.ErrorNumber Property
DataError Class See Also Send Feedback
Gets error number.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public uint ErrorNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property ErrorNumber As UInteger
Visual C++
public:
property unsigned int ErrorNumber {
    unsigned int get ();
}

See Also

DataError Class
PerpetuumSoft.Framework.Connectivity Namespace


ErrorText Property

[image]

.NET ModelKit Suite ClassReference
DataError..::.ErrorText Property
DataError Class See Also Send Feedback
Gets error text.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public string ErrorText { get; }
Visual Basic (Declaration)
Public ReadOnly Property ErrorText As String
Visual C++
public:
property String^ ErrorText {
    String^ get ();
}

See Also

DataError Class
PerpetuumSoft.Framework.Connectivity Namespace


IsWarning Property

[image]

.NET ModelKit Suite ClassReference
DataError..::.IsWarning Property
DataError Class See Also Send Feedback
Returns value indicating that an instance of DataError is a warning.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public bool IsWarning { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsWarning As Boolean
Visual C++
public:
property bool IsWarning {
    bool get ();
}

See Also

DataError Class
PerpetuumSoft.Framework.Connectivity Namespace


ItemID Property

[image]

.NET ModelKit Suite ClassReference
DataError..::.ItemID Property
DataError Class See Also Send Feedback
Gets error ID.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public string ItemID { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemID As String
Visual C++
public:
property String^ ItemID {
    String^ get ();
}

See Also

DataError Class
PerpetuumSoft.Framework.Connectivity Namespace


DataPoint Class

[image]

.NET ModelKit Suite ClassReference
DataPoint Class
Members See Also Send Feedback
Represent data for one item, one time.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public class DataPoint
Visual Basic (Declaration)
Public Class DataPoint
Visual C++
public ref class DataPoint

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Connectivity..::.DataPoint

See Also

DataPoint Members
PerpetuumSoft.Framework.Connectivity Namespace


DataPoint Members

[image] [image]

.NET ModelKit Suite ClassReference
DataPoint Members
DataPoint Class Constructors Methods Fields Properties See Also Send Feedback

The DataPoint type exposes the following members.

Constructors

Name | Description
DataPoint | Initializes a new instance of the DataPoint class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Empty | Represents empty DataPoint.

Properties

Name | Description
Quality | Gets quality of DataPoint.
Timestamp | Gets DateTime.
Value | Gets DataPoint value.

See Also

DataPoint Class
PerpetuumSoft.Framework.Connectivity Namespace


DataPoint Constructor

[image]

.NET ModelKit Suite ClassReference
DataPoint Constructor
DataPoint Class See Also Send Feedback
Initializes a new instance of the DataPoint class.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public DataPoint(
    Object pointValue,
    DateTime timestamp,
    Quality quality
)
Visual Basic (Declaration)
Public Sub New ( _
    pointValue As Object, _
    timestamp As DateTime, _
    quality As Quality _
)
Visual C++
public:
DataPoint(
    Object^ pointValue,
    DateTime timestamp,
    Quality quality
)

Parameters

pointValue
Type: System..::.Object
timestamp
Type: System..::.DateTime
quality
Type: PerpetuumSoft.Framework.Connectivity..::.Quality

See Also

DataPoint Class
PerpetuumSoft.Framework.Connectivity Namespace


DataPoint Fields

[image] [image]

.NET ModelKit Suite ClassReference
DataPoint Fields
DataPoint Class See Also Send Feedback

The DataPoint type exposes the following members.

Fields

Name | Description
Empty | Represents empty DataPoint.

See Also

DataPoint Class
PerpetuumSoft.Framework.Connectivity Namespace


Empty Field

[image]

.NET ModelKit Suite ClassReference
DataPoint..::.Empty Field
DataPoint Class See Also Send Feedback
Represents empty DataPoint.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public static readonly DataPoint Empty
Visual Basic (Declaration)
Public Shared ReadOnly Empty As DataPoint
Visual C++
public:
static initonly DataPoint^ Empty

See Also

DataPoint Class
PerpetuumSoft.Framework.Connectivity Namespace


DataPoint Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataPoint Methods
DataPoint Class See Also Send Feedback

The DataPoint type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataPoint Class
PerpetuumSoft.Framework.Connectivity Namespace


DataPoint Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataPoint Properties
DataPoint Class See Also Send Feedback

The DataPoint type exposes the following members.

Properties

Name | Description
Quality | Gets quality of DataPoint.
Timestamp | Gets DateTime.
Value | Gets DataPoint value.

See Also

DataPoint Class
PerpetuumSoft.Framework.Connectivity Namespace


Quality Property

[image]

.NET ModelKit Suite ClassReference
DataPoint..::.Quality Property
DataPoint Class See Also Send Feedback
Gets quality of DataPoint.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public Quality Quality { get; }
Visual Basic (Declaration)
Public ReadOnly Property Quality As Quality
Visual C++
public:
property Quality Quality {
    Quality get ();
}

See Also

DataPoint Class
PerpetuumSoft.Framework.Connectivity Namespace


Timestamp Property

[image]

.NET ModelKit Suite ClassReference
DataPoint..::.Timestamp Property
DataPoint Class See Also Send Feedback
Gets DateTime.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public DateTime Timestamp { get; }
Visual Basic (Declaration)
Public ReadOnly Property Timestamp As DateTime
Visual C++
public:
property DateTime Timestamp {
    DateTime get ();
}

See Also

DataPoint Class
PerpetuumSoft.Framework.Connectivity Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
DataPoint..::.Value Property
DataPoint Class See Also Send Feedback
Gets DataPoint value.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public Object Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
}

See Also

DataPoint Class
PerpetuumSoft.Framework.Connectivity Namespace


DataSlice Class

[image]

.NET ModelKit Suite ClassReference
DataSlice Class
Members See Also Send Feedback
Represent data for many items, one time.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public class DataSlice
Visual Basic (Declaration)
Public Class DataSlice
Visual C++
public ref class DataSlice

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Connectivity..::.DataSlice

See Also

DataSlice Members
PerpetuumSoft.Framework.Connectivity Namespace


DataSlice Members

[image] [image]

.NET ModelKit Suite ClassReference
DataSlice Members
DataSlice Class Constructors Methods See Also Send Feedback

The DataSlice type exposes the following members.

Constructors

Name | Description
DataSlice | Initializes a new instance of the DataSlice class.

Methods

Name | Description
Add | Adds DataPoint with specified Item ID.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataPoint | Returns DataPoint from gived Item ID.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItemIDs | Returns an array of Item IDs contained in DataSlice.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataSlice Class
PerpetuumSoft.Framework.Connectivity Namespace


DataSlice Constructor

[image]

.NET ModelKit Suite ClassReference
DataSlice Constructor
DataSlice Class See Also Send Feedback
Initializes a new instance of the DataSlice class.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public DataSlice(
    int capacity
)
Visual Basic (Declaration)
Public Sub New ( _
    capacity As Integer _
)
Visual C++
public:
DataSlice(
    int capacity
)

Parameters

capacity
Type: System..::.Int32

See Also

DataSlice Class
PerpetuumSoft.Framework.Connectivity Namespace


DataSlice Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataSlice Methods
DataSlice Class See Also Send Feedback

The DataSlice type exposes the following members.

Methods

Name | Description
Add | Adds DataPoint with specified Item ID.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataPoint | Returns DataPoint from gived Item ID.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItemIDs | Returns an array of Item IDs contained in DataSlice.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataSlice Class
PerpetuumSoft.Framework.Connectivity Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
DataSlice..::.Add Method
DataSlice Class See Also Send Feedback
Adds DataPoint with specified Item ID.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public void Add(
    string itemID,
    DataPoint dataPoint
)
Visual Basic (Declaration)
Public Sub Add ( _
    itemID As String, _
    dataPoint As DataPoint _
)
Visual C++
public:
void Add(
    String^ itemID,
    DataPoint^ dataPoint
)

Parameters

itemID
Type: System..::.String
dataPoint
Type: PerpetuumSoft.Framework.Connectivity..::.DataPoint

See Also

DataSlice Class
PerpetuumSoft.Framework.Connectivity Namespace


GetDataPoint Method

[image]

.NET ModelKit Suite ClassReference
DataSlice..::.GetDataPoint Method
DataSlice Class See Also Send Feedback
Returns DataPoint from gived Item ID.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public DataPoint GetDataPoint(
    string itemID
)
Visual Basic (Declaration)
Public Function GetDataPoint ( _
    itemID As String _
) As DataPoint
Visual C++
public:
DataPoint^ GetDataPoint(
    String^ itemID
)

Parameters

itemID
Type: System..::.String

See Also

DataSlice Class
PerpetuumSoft.Framework.Connectivity Namespace


GetItemIDs Method

[image]

.NET ModelKit Suite ClassReference
DataSlice..::.GetItemIDs Method
DataSlice Class See Also Send Feedback
Returns an array of Item IDs contained in DataSlice.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public string[] GetItemIDs()
Visual Basic (Declaration)
Public Function GetItemIDs As String()
Visual C++
public:
array<String^>^ GetItemIDs()

See Also

DataSlice Class
PerpetuumSoft.Framework.Connectivity Namespace


DataSlicesEventArgs Class

[image]

.NET ModelKit Suite ClassReference
DataSlicesEventArgs Class
Members See Also Send Feedback
Provides data for DataTransmission event.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public class DataSlicesEventArgs : EventArgs,
    ITransaction
Visual Basic (Declaration)
Public Class DataSlicesEventArgs _
    Inherits EventArgs _
    Implements ITransaction
Visual C++
public ref class DataSlicesEventArgs : public EventArgs,
    ITransaction

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Framework.Connectivity..::.DataSlicesEventArgs

See Also

DataSlicesEventArgs Members
PerpetuumSoft.Framework.Connectivity Namespace


DataSlicesEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
DataSlicesEventArgs Members
DataSlicesEventArgs Class Constructors Methods Properties See Also Send Feedback

The DataSlicesEventArgs type exposes the following members.

Constructors

Name | Description
DataSlicesEventArgs | Initializes a new instance of the DataSlicesEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | Implements Description.
ID | Implements ID.
Item | Gets DataSlice
Ticks | Gets Int32

See Also

DataSlicesEventArgs Class
PerpetuumSoft.Framework.Connectivity Namespace


DataSlicesEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
DataSlicesEventArgs Constructor
DataSlicesEventArgs Class See Also Send Feedback
Initializes a new instance of the DataSlicesEventArgs class.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public DataSlicesEventArgs(
    int transactionID,
    int capacity
)
Visual Basic (Declaration)
Public Sub New ( _
    transactionID As Integer, _
    capacity As Integer _
)
Visual C++
public:
DataSlicesEventArgs(
    int transactionID,
    int capacity
)

Parameters

transactionID
Type: System..::.Int32
capacity
Type: System..::.Int32

See Also

DataSlicesEventArgs Class
PerpetuumSoft.Framework.Connectivity Namespace


DataSlicesEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataSlicesEventArgs Methods
DataSlicesEventArgs Class See Also Send Feedback

The DataSlicesEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataSlicesEventArgs Class
PerpetuumSoft.Framework.Connectivity Namespace


DataSlicesEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataSlicesEventArgs Properties
DataSlicesEventArgs Class See Also Send Feedback

The DataSlicesEventArgs type exposes the following members.

Properties

Name | Description
Description | Implements Description.
ID | Implements ID.
Item | Gets DataSlice
Ticks | Gets Int32

See Also

DataSlicesEventArgs Class
PerpetuumSoft.Framework.Connectivity Namespace


Description Property

[image]

.NET ModelKit Suite ClassReference
DataSlicesEventArgs..::.Description Property
DataSlicesEventArgs Class See Also Send Feedback
Implements Description.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () sealed;
}

Implements

ITransaction..::.Description

See Also

DataSlicesEventArgs Class
PerpetuumSoft.Framework.Connectivity Namespace


ID Property

[image]

.NET ModelKit Suite ClassReference
DataSlicesEventArgs..::.ID Property
DataSlicesEventArgs Class See Also Send Feedback
Implements ID.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public int ID { get; }
Visual Basic (Declaration)
Public ReadOnly Property ID As Integer
Visual C++
public:
virtual property int ID {
    int get () sealed;
}

Implements

ITransaction..::.ID

See Also

DataSlicesEventArgs Class
PerpetuumSoft.Framework.Connectivity Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
DataSlicesEventArgs..::.Item Property
DataSlicesEventArgs Class See Also Send Feedback
Gets DataSlice

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public DataSlice this[
    int tick
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    tick As Integer _
) As DataSlice
Visual C++
public:
property DataSlice^ default[int tick] {
    DataSlice^ get (int tick);
}

Parameters

tick
Type: System..::.Int32

See Also

DataSlicesEventArgs Class
PerpetuumSoft.Framework.Connectivity Namespace


Ticks Property

[image]

.NET ModelKit Suite ClassReference
DataSlicesEventArgs..::.Ticks Property
DataSlicesEventArgs Class See Also Send Feedback
Gets Int32

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public int Ticks { get; }
Visual Basic (Declaration)
Public ReadOnly Property Ticks As Integer
Visual C++
public:
property int Ticks {
    int get ();
}

See Also

DataSlicesEventArgs Class
PerpetuumSoft.Framework.Connectivity Namespace


DataTransmissionEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
DataTransmissionEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the DataTransmittion event.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public delegate void DataTransmissionEventHandler(
    Object sender,
    DataSlicesEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub DataTransmissionEventHandler ( _
    sender As Object, _
    e As DataSlicesEventArgs _
)
Visual C++
public delegate void DataTransmissionEventHandler(
    Object^ sender,
    DataSlicesEventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: PerpetuumSoft.Framework.Connectivity..::.DataSlicesEventArgs

See Also

PerpetuumSoft.Framework.Connectivity Namespace


ItemCollection Class

[image]

.NET ModelKit Suite ClassReference
ItemCollection Class
Members See Also Send Feedback
Collection of items as used in the DataChannel component.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public class ItemCollection : CollectionBase,
    ICollection, IEnumerable
Visual Basic (Declaration)
Public Class ItemCollection _
    Inherits CollectionBase _
    Implements ICollection, IEnumerable
Visual C++
public ref class ItemCollection : public CollectionBase,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Framework.Connectivity..::.ItemCollection

See Also

ItemCollection Members
PerpetuumSoft.Framework.Connectivity Namespace


ItemCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
ItemCollection Members
ItemCollection Class Constructors Methods Properties See Also Send Feedback

The ItemCollection type exposes the following members.

Constructors

Name | Description
ItemCollection | Initializes a new instance of the ItemCollection class.

Methods

Name | Description
Add | Implements Add(Object).
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Channel | Gets DataChannel
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Implements Item[([(Int32])]).
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ItemCollection Class
PerpetuumSoft.Framework.Connectivity Namespace


ItemCollection Constructor

[image]

.NET ModelKit Suite ClassReference
ItemCollection Constructor
ItemCollection Class See Also Send Feedback
Initializes a new instance of the ItemCollection class.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public ItemCollection(
    DataChannel channel
)
Visual Basic (Declaration)
Public Sub New ( _
    channel As DataChannel _
)
Visual C++
public:
ItemCollection(
    DataChannel^ channel
)

Parameters

channel
Type: PerpetuumSoft.Framework.Connectivity..::.DataChannel

See Also

ItemCollection Class
PerpetuumSoft.Framework.Connectivity Namespace


ItemCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
ItemCollection Methods
ItemCollection Class See Also Send Feedback

The ItemCollection type exposes the following members.

Methods

Name | Description
Add | Implements Add(Object).
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemCollection Class
PerpetuumSoft.Framework.Connectivity Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
ItemCollection..::.Add Method
ItemCollection Class See Also Send Feedback
Implements Add(Object).

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public ItemSpec Add(
    ItemSpec value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As ItemSpec _
) As ItemSpec
Visual C++
public:
ItemSpec^ Add(
    ItemSpec^ value
)

Parameters

value
Type: PerpetuumSoft.Framework.Connectivity..::.ItemSpec

See Also

ItemCollection Class
PerpetuumSoft.Framework.Connectivity Namespace


ItemCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
ItemCollection Properties
ItemCollection Class See Also Send Feedback

The ItemCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Channel | Gets DataChannel
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Implements Item[([(Int32])]).
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ItemCollection Class
PerpetuumSoft.Framework.Connectivity Namespace


Channel Property

[image]

.NET ModelKit Suite ClassReference
ItemCollection..::.Channel Property
ItemCollection Class See Also Send Feedback
Gets DataChannel

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public DataChannel Channel { get; }
Visual Basic (Declaration)
Public ReadOnly Property Channel As DataChannel
Visual C++
public:
property DataChannel^ Channel {
    DataChannel^ get ();
}

See Also

ItemCollection Class
PerpetuumSoft.Framework.Connectivity Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
ItemCollection..::.Item Property
ItemCollection Class See Also Send Feedback
Implements Item[([(Int32])]).

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public ItemSpec this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As ItemSpec
Visual C++
public:
property ItemSpec^ default[int index] {
    ItemSpec^ get (int index);
    void set (int index, ItemSpec^ value);
}

Parameters

index
Type: System..::.Int32

See Also

ItemCollection Class
PerpetuumSoft.Framework.Connectivity Namespace


ItemInfo Structure

[image]

.NET ModelKit Suite ClassReference
ItemInfo Structure
Members See Also Send Feedback
Represent information about DataItem.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public struct ItemInfo
Visual Basic (Declaration)
Public Structure ItemInfo
Visual C++
public value class ItemInfo

See Also

ItemInfo Members
PerpetuumSoft.Framework.Connectivity Namespace


ItemInfo Members

[image] [image]

.NET ModelKit Suite ClassReference
ItemInfo Members
ItemInfo Structure Constructors Methods Fields Properties See Also Send Feedback

The ItemInfo type exposes the following members.

Constructors

Name | Description
ItemInfo | Overloaded.

Methods

Name | Description
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides ValueType..::.ToString()()().)

Fields

Name | Description
Empty | Represent empty item.

Properties

Name | Description
AccessRights | Gets acess rights of an item.
DataType | Gets item data type.
ItemID | Gets Item ID.

See Also

ItemInfo Structure
PerpetuumSoft.Framework.Connectivity Namespace


ItemInfo Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ItemInfo Constructor
ItemInfo Structure See Also Send Feedback

Overload List

Name | Description
ItemInfo(String) | Initializes a new instance of the ItemInfo class.
ItemInfo(String, Type, AccessRights) | Initializes a new instance of the ItemInfo class.

See Also

ItemInfo Structure
ItemInfo Members
PerpetuumSoft.Framework.Connectivity Namespace


ItemInfo Constructor (String)

[image]

.NET ModelKit Suite ClassReference
ItemInfo Constructor (String)
ItemInfo Structure See Also Send Feedback
Initializes a new instance of the ItemInfo class.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public ItemInfo(
    string itemID
)
Visual Basic (Declaration)
Public Sub New ( _
    itemID As String _
)
Visual C++
public:
ItemInfo(
    String^ itemID
)

Parameters

itemID
Type: System..::.String

See Also

ItemInfo Structure
ItemInfo Overload
PerpetuumSoft.Framework.Connectivity Namespace


ItemInfo Constructor (String, Type, AccessRights)

[image]

.NET ModelKit Suite ClassReference
ItemInfo Constructor (String, Type, AccessRights)
ItemInfo Structure See Also Send Feedback
Initializes a new instance of the ItemInfo class.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public ItemInfo(
    string itemID,
    Type type,
    AccessRights accessRights
)
Visual Basic (Declaration)
Public Sub New ( _
    itemID As String, _
    type As Type, _
    accessRights As AccessRights _
)
Visual C++
public:
ItemInfo(
    String^ itemID,
    Type^ type,
    AccessRights accessRights
)

Parameters

itemID
Type: System..::.String
type
Type: System..::.Type
accessRights
Type: PerpetuumSoft.Framework.Connectivity..::.AccessRights

See Also

ItemInfo Structure
ItemInfo Overload
PerpetuumSoft.Framework.Connectivity Namespace


ItemInfo Fields

[image] [image]

.NET ModelKit Suite ClassReference
ItemInfo Fields
ItemInfo Structure See Also Send Feedback

The ItemInfo type exposes the following members.

Fields

Name | Description
Empty | Represent empty item.

See Also

ItemInfo Structure
PerpetuumSoft.Framework.Connectivity Namespace


Empty Field

[image]

.NET ModelKit Suite ClassReference
ItemInfo..::.Empty Field
ItemInfo Structure See Also Send Feedback
Represent empty item.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public static readonly ItemInfo Empty
Visual Basic (Declaration)
Public Shared ReadOnly Empty As ItemInfo
Visual C++
public:
static initonly ItemInfo Empty

See Also

ItemInfo Structure
PerpetuumSoft.Framework.Connectivity Namespace


ItemInfo Methods

[image] [image]

.NET ModelKit Suite ClassReference
ItemInfo Methods
ItemInfo Structure See Also Send Feedback

The ItemInfo type exposes the following members.

Methods

Name | Description
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides ValueType..::.ToString()()().)

See Also

ItemInfo Structure
PerpetuumSoft.Framework.Connectivity Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
ItemInfo..::.Equals Method
ItemInfo Structure See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

ItemInfo Structure
PerpetuumSoft.Framework.Connectivity Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
ItemInfo..::.GetHashCode Method
ItemInfo Structure See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

ItemInfo Structure
PerpetuumSoft.Framework.Connectivity Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
ItemInfo..::.ToString Method
ItemInfo Structure See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

ItemInfo Structure
PerpetuumSoft.Framework.Connectivity Namespace


ItemInfo Properties

[image] [image]

.NET ModelKit Suite ClassReference
ItemInfo Properties
ItemInfo Structure See Also Send Feedback

The ItemInfo type exposes the following members.

Properties

Name | Description
AccessRights | Gets acess rights of an item.
DataType | Gets item data type.
ItemID | Gets Item ID.

See Also

ItemInfo Structure
PerpetuumSoft.Framework.Connectivity Namespace


AccessRights Property

[image]

.NET ModelKit Suite ClassReference
ItemInfo..::.AccessRights Property
ItemInfo Structure See Also Send Feedback
Gets acess rights of an item.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public AccessRights AccessRights { get; }
Visual Basic (Declaration)
Public ReadOnly Property AccessRights As AccessRights
Visual C++
public:
property AccessRights AccessRights {
    AccessRights get ();
}

See Also

ItemInfo Structure
PerpetuumSoft.Framework.Connectivity Namespace


DataType Property

[image]

.NET ModelKit Suite ClassReference
ItemInfo..::.DataType Property
ItemInfo Structure See Also Send Feedback
Gets item data type.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public Type DataType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataType As Type
Visual C++
public:
property Type^ DataType {
    Type^ get ();
}

See Also

ItemInfo Structure
PerpetuumSoft.Framework.Connectivity Namespace


ItemID Property

[image]

.NET ModelKit Suite ClassReference
ItemInfo..::.ItemID Property
ItemInfo Structure See Also Send Feedback
Gets Item ID.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public string ItemID { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemID As String
Visual C++
public:
property String^ ItemID {
    String^ get ();
}

See Also

ItemInfo Structure
PerpetuumSoft.Framework.Connectivity Namespace


ItemSpec Class

[image]

.NET ModelKit Suite ClassReference
ItemSpec Class
Members See Also Send Feedback
Item specification to be used in ItemCollectionEditor.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public class ItemSpec : MarshalByRefObject
Visual Basic (Declaration)
Public Class ItemSpec _
    Inherits MarshalByRefObject
Visual C++
public ref class ItemSpec : public MarshalByRefObject

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
PerpetuumSoft.Framework.Connectivity..::.ItemSpec

See Also

ItemSpec Members
PerpetuumSoft.Framework.Connectivity Namespace


ItemSpec Members

[image] [image]

.NET ModelKit Suite ClassReference
ItemSpec Members
ItemSpec Class Methods See Also Send Feedback

The ItemSpec type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemSpec Class
PerpetuumSoft.Framework.Connectivity Namespace


ItemSpec Methods

[image] [image]

.NET ModelKit Suite ClassReference
ItemSpec Methods
ItemSpec Class See Also Send Feedback

The ItemSpec type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemSpec Class
PerpetuumSoft.Framework.Connectivity Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
ItemSpec..::.MemberwiseClone Method
ItemSpec Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ItemSpec Class
ItemSpec Members
PerpetuumSoft.Framework.Connectivity Namespace


ITransaction Interface

[image]

.NET ModelKit Suite ClassReference
ITransaction Interface
Members See Also Send Feedback
Represent basic functionality for transaction classes.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public interface ITransaction
Visual Basic (Declaration)
Public Interface ITransaction
Visual C++
public interface class ITransaction

See Also

ITransaction Members
PerpetuumSoft.Framework.Connectivity Namespace


ITransaction Members

[image] [image]

.NET ModelKit Suite ClassReference
ITransaction Members
ITransaction Interface Properties See Also Send Feedback

The ITransaction type exposes the following members.

Properties

Name | Description
Description | Gets transaction descriprion.
ID | Gets transaction ID.

See Also

ITransaction Interface
PerpetuumSoft.Framework.Connectivity Namespace


ITransaction Properties

[image] [image]

.NET ModelKit Suite ClassReference
ITransaction Properties
ITransaction Interface See Also Send Feedback

The ITransaction type exposes the following members.

Properties

Name | Description
Description | Gets transaction descriprion.
ID | Gets transaction ID.

See Also

ITransaction Interface
PerpetuumSoft.Framework.Connectivity Namespace


Description Property

[image]

.NET ModelKit Suite ClassReference
ITransaction..::.Description Property
ITransaction Interface See Also Send Feedback
Gets transaction descriprion.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

ITransaction Interface
PerpetuumSoft.Framework.Connectivity Namespace


ID Property

[image]

.NET ModelKit Suite ClassReference
ITransaction..::.ID Property
ITransaction Interface See Also Send Feedback
Gets transaction ID.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
int ID { get; }
Visual Basic (Declaration)
ReadOnly Property ID As Integer
Visual C++
property int ID {
    int get ();
}

See Also

ITransaction Interface
PerpetuumSoft.Framework.Connectivity Namespace


OPCChannel Class

[image]

.NET ModelKit Suite ClassReference
OPCChannel Class
Members See Also Send Feedback
Provides access to data from a process using concrete OPC Server Note: DataPoint time is the same if provided by an OPC server, different if provided by a device.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public sealed class OPCChannel : DataChannel
Visual Basic (Declaration)
Public NotInheritable Class OPCChannel _
    Inherits DataChannel
Visual C++
public ref class OPCChannel sealed : public DataChannel

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Framework.Connectivity..::.DataChannel
PerpetuumSoft.Framework.Connectivity..::.OPCChannel

See Also

OPCChannel Members
PerpetuumSoft.Framework.Connectivity Namespace


OPCChannel Members

[image] [image]

.NET ModelKit Suite ClassReference
OPCChannel Members
OPCChannel Class Constructors Methods Properties Events See Also Send Feedback

The OPCChannel type exposes the following members.

Constructors

Name | Description
OPCChannel | Overloaded.

Methods

Name | Description
AsynchronousRead | Overridden. See AsynchronousRead()()(). (Overrides DataChannel..::.AsynchronousRead()()().)
AsynchronousSubscription | Overloaded.
CancelSubscription | Cancels subscription, doesn't throw an exception even if not canceled. Returns false in case of error. (Overrides DataChannel..::.CancelSubscription(ITransaction).)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EstablishConnection | Overridden. See EstablishConnection()()(). (Overrides DataChannel..::.EstablishConnection()()().)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetAvailableItems | Overridden. See GetAvailableItems()()(). (Overrides DataChannel..::.GetAvailableItems()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
ReloadItemInfos | Overridden. See ReloadItemInfos()()(). (Overrides DataChannel..::.ReloadItemInfos()()().)
ResetConnection | Overridden. See ResetConnection()()(). (Overrides DataChannel..::.ResetConnection()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Write | Overridden. See Write(array<Object>[]()[]). (Overrides DataChannel..::.Write(array<Object>[]()[]).)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ConnectionSet | Flag indicating that the connection has been set and established. Note: Connection must be always established at the moment of setting as a current one for given DataChannel. (Inherited from DataChannel.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataCultureInfo | Overridden. See DataCultureInfo. (Overrides DataChannel..::.DataCultureInfo.)
DataProviderCurrentTime | Overridden. See DataProviderCurrentTime. (Overrides DataChannel..::.DataProviderCurrentTime.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Items | Gets ItemCollection
OPCConnection | Gets or sets OPCConnection
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
DataTransmission | Overridden. See DataTransmission()()(). (Overrides DataChannel..::.DataTransmission.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
WriteStatus | Overridden. See WriteStatus()()(). (Overrides DataChannel..::.WriteStatus.)

See Also

OPCChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


OPCChannel Constructor

[image] [image]

.NET ModelKit Suite ClassReference
OPCChannel Constructor
OPCChannel Class See Also Send Feedback

Overload List

Name | Description
OPCChannel()()() | Initializes a new instance of the OPCChannel class.
OPCChannel(OPCConnection) | Initializes a new instance of the OPCChannel class.

See Also

OPCChannel Class
OPCChannel Members
PerpetuumSoft.Framework.Connectivity Namespace


OPCChannel Constructor

[image]

.NET ModelKit Suite ClassReference
OPCChannel Constructor
OPCChannel Class See Also Send Feedback
Initializes a new instance of the OPCChannel class.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public OPCChannel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OPCChannel()

See Also

OPCChannel Class
OPCChannel Overload
PerpetuumSoft.Framework.Connectivity Namespace


OPCChannel Constructor (OPCConnection)

[image]

.NET ModelKit Suite ClassReference
OPCChannel Constructor (OPCConnection)
OPCChannel Class See Also Send Feedback
Initializes a new instance of the OPCChannel class.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public OPCChannel(
    OPCConnection connection
)
Visual Basic (Declaration)
Public Sub New ( _
    connection As OPCConnection _
)
Visual C++
public:
OPCChannel(
    OPCConnection^ connection
)

Parameters

connection
Type: PerpetuumSoft.Framework.Connectivity..::.OPCConnection

See Also

OPCChannel Class
OPCChannel Overload
PerpetuumSoft.Framework.Connectivity Namespace


OPCChannel Methods

[image] [image]

.NET ModelKit Suite ClassReference
OPCChannel Methods
OPCChannel Class See Also Send Feedback

The OPCChannel type exposes the following members.

Methods

Name | Description
AsynchronousRead | Overridden. See AsynchronousRead()()(). (Overrides DataChannel..::.AsynchronousRead()()().)
AsynchronousSubscription | Overloaded.
CancelSubscription | Cancels subscription, doesn't throw an exception even if not canceled. Returns false in case of error. (Overrides DataChannel..::.CancelSubscription(ITransaction).)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EstablishConnection | Overridden. See EstablishConnection()()(). (Overrides DataChannel..::.EstablishConnection()()().)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetAvailableItems | Overridden. See GetAvailableItems()()(). (Overrides DataChannel..::.GetAvailableItems()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
ReloadItemInfos | Overridden. See ReloadItemInfos()()(). (Overrides DataChannel..::.ReloadItemInfos()()().)
ResetConnection | Overridden. See ResetConnection()()(). (Overrides DataChannel..::.ResetConnection()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Write | Overridden. See Write(array<Object>[]()[]). (Overrides DataChannel..::.Write(array<Object>[]()[]).)

See Also

OPCChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


AsynchronousRead Method

[image]

.NET ModelKit Suite ClassReference
OPCChannel..::.AsynchronousRead Method
OPCChannel Class See Also Send Feedback
Overridden. See AsynchronousRead()()().

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public override TransactionItemsStatus AsynchronousRead()
Visual Basic (Declaration)
Public Overrides Function AsynchronousRead As TransactionItemsStatus
Visual C++
public:
virtual TransactionItemsStatus^ AsynchronousRead() override

See Also

OPCChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


AsynchronousSubscription Method

[image] [image]

.NET ModelKit Suite ClassReference
OPCChannel..::.AsynchronousSubscription Method
OPCChannel Class See Also Send Feedback

Overload List

Name | Description
AsynchronousSubscription(UInt32) | Overridden. See AsynchronousSubscription(UInt32). (Overrides DataChannel..::.AsynchronousSubscription(UInt32).)
AsynchronousSubscription(UInt32, UInt32) | Overridden. See AsynchronousSubscription(UInt32, UInt32). (Overrides DataChannel..::.AsynchronousSubscription(UInt32, UInt32).)

See Also

OPCChannel Class
OPCChannel Members
PerpetuumSoft.Framework.Connectivity Namespace


AsynchronousSubscription Method (UInt32)

[image]

.NET ModelKit Suite ClassReference
OPCChannel..::.AsynchronousSubscription Method (UInt32)
OPCChannel Class See Also Send Feedback
Overridden. See AsynchronousSubscription(UInt32).

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public override ITransaction AsynchronousSubscription(
    uint dataRate
)
Visual Basic (Declaration)
Public Overrides Function AsynchronousSubscription ( _
    dataRate As UInteger _
) As ITransaction
Visual C++
public:
virtual ITransaction^ AsynchronousSubscription(
    unsigned int dataRate
) override

Parameters

dataRate
Type: System..::.UInt32

See Also

OPCChannel Class
AsynchronousSubscription Overload
PerpetuumSoft.Framework.Connectivity Namespace


AsynchronousSubscription Method (UInt32, UInt32)

[image]

.NET ModelKit Suite ClassReference
OPCChannel..::.AsynchronousSubscription Method (UInt32, UInt32)
OPCChannel Class See Also Send Feedback
Overridden. See AsynchronousSubscription(UInt32, UInt32).

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public override ITransaction AsynchronousSubscription(
    uint dataRate,
    uint refreshRate
)
Visual Basic (Declaration)
Public Overrides Function AsynchronousSubscription ( _
    dataRate As UInteger, _
    refreshRate As UInteger _
) As ITransaction
Visual C++
public:
virtual ITransaction^ AsynchronousSubscription(
    unsigned int dataRate,
    unsigned int refreshRate
) override

Parameters

dataRate
Type: System..::.UInt32
refreshRate
Type: System..::.UInt32

See Also

OPCChannel Class
AsynchronousSubscription Overload
PerpetuumSoft.Framework.Connectivity Namespace


CancelSubscription Method

[image]

.NET ModelKit Suite ClassReference
OPCChannel..::.CancelSubscription Method
OPCChannel Class See Also Send Feedback
Cancels subscription, doesn't throw an exception even if not canceled. Returns false in case of error.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public override bool CancelSubscription(
    ITransaction transaction
)
Visual Basic (Declaration)
Public Overrides Function CancelSubscription ( _
    transaction As ITransaction _
) As Boolean
Visual C++
public:
virtual bool CancelSubscription(
    ITransaction^ transaction
) override

Parameters

transaction
Type: PerpetuumSoft.Framework.Connectivity..::.ITransaction

See Also

OPCChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
OPCChannel..::.Dispose Method
OPCChannel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

OPCChannel Class
OPCChannel Members
PerpetuumSoft.Framework.Connectivity Namespace


EstablishConnection Method

[image]

.NET ModelKit Suite ClassReference
OPCChannel..::.EstablishConnection Method
OPCChannel Class See Also Send Feedback
Overridden. See EstablishConnection()()().

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public override void EstablishConnection()
Visual Basic (Declaration)
Public Overrides Sub EstablishConnection
Visual C++
public:
virtual void EstablishConnection() override

See Also

OPCChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


GetAvailableItems Method

[image]

.NET ModelKit Suite ClassReference
OPCChannel..::.GetAvailableItems Method
OPCChannel Class See Also Send Feedback
Overridden. See GetAvailableItems()()().

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public override ItemInfo[] GetAvailableItems()
Visual Basic (Declaration)
Public Overrides Function GetAvailableItems As ItemInfo()
Visual C++
public:
virtual array<ItemInfo>^ GetAvailableItems() override

See Also

OPCChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
OPCChannel..::.MemberwiseClone Method
OPCChannel Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

OPCChannel Class
OPCChannel Members
PerpetuumSoft.Framework.Connectivity Namespace


ReloadItemInfos Method

[image]

.NET ModelKit Suite ClassReference
OPCChannel..::.ReloadItemInfos Method
OPCChannel Class See Also Send Feedback
Overridden. See ReloadItemInfos()()().

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public override void ReloadItemInfos()
Visual Basic (Declaration)
Public Overrides Sub ReloadItemInfos
Visual C++
public:
virtual void ReloadItemInfos() override

See Also

OPCChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


ResetConnection Method

[image]

.NET ModelKit Suite ClassReference
OPCChannel..::.ResetConnection Method
OPCChannel Class See Also Send Feedback
Overridden. See ResetConnection()()().

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public override void ResetConnection()
Visual Basic (Declaration)
Public Overrides Sub ResetConnection
Visual C++
public:
virtual void ResetConnection() override

See Also

OPCChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


Write Method

[image]

.NET ModelKit Suite ClassReference
OPCChannel..::.Write Method
OPCChannel Class See Also Send Feedback
Overridden. See Write(array<Object>[]()[]).

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public override TransactionItemsStatus Write(
    Object[] values
)
Visual Basic (Declaration)
Public Overrides Function Write ( _
    values As Object() _
) As TransactionItemsStatus
Visual C++
public:
virtual TransactionItemsStatus^ Write(
    array<Object^>^ values
) override

Parameters

values
Type: array< System..::.Object >[]()[]

See Also

OPCChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


OPCChannel Properties

[image] [image]

.NET ModelKit Suite ClassReference
OPCChannel Properties
OPCChannel Class See Also Send Feedback

The OPCChannel type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ConnectionSet | Flag indicating that the connection has been set and established. Note: Connection must be always established at the moment of setting as a current one for given DataChannel. (Inherited from DataChannel.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataCultureInfo | Overridden. See DataCultureInfo. (Overrides DataChannel..::.DataCultureInfo.)
DataProviderCurrentTime | Overridden. See DataProviderCurrentTime. (Overrides DataChannel..::.DataProviderCurrentTime.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Items | Gets ItemCollection
OPCConnection | Gets or sets OPCConnection
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

OPCChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


DataCultureInfo Property

[image]

.NET ModelKit Suite ClassReference
OPCChannel..::.DataCultureInfo Property
OPCChannel Class See Also Send Feedback
Overridden. See DataCultureInfo.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public override CultureInfo DataCultureInfo { get; set; }
Visual Basic (Declaration)
Public Overrides Property DataCultureInfo As CultureInfo
Visual C++
public:
virtual property CultureInfo^ DataCultureInfo {
    CultureInfo^ get () override;
    void set (CultureInfo^ value) override;
}

See Also

OPCChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


DataProviderCurrentTime Property

[image]

.NET ModelKit Suite ClassReference
OPCChannel..::.DataProviderCurrentTime Property
OPCChannel Class See Also Send Feedback
Overridden. See DataProviderCurrentTime.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public override DateTime DataProviderCurrentTime { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DataProviderCurrentTime As DateTime
Visual C++
public:
virtual property DateTime DataProviderCurrentTime {
    DateTime get () override;
}

See Also

OPCChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


Items Property

[image]

.NET ModelKit Suite ClassReference
OPCChannel..::.Items Property
OPCChannel Class See Also Send Feedback
Gets ItemCollection

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public ItemCollection Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As ItemCollection
Visual C++
public:
property ItemCollection^ Items {
    ItemCollection^ get ();
}

See Also

OPCChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


OPCConnection Property

[image]

.NET ModelKit Suite ClassReference
OPCChannel..::.OPCConnection Property
OPCChannel Class See Also Send Feedback
Gets or sets OPCConnection

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public OPCConnection OPCConnection { get; set; }
Visual Basic (Declaration)
Public Property OPCConnection As OPCConnection
Visual C++
public:
property OPCConnection^ OPCConnection {
    OPCConnection^ get ();
    void set (OPCConnection^ value);
}

See Also

OPCChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


OPCChannel Events

[image] [image]

.NET ModelKit Suite ClassReference
OPCChannel Events
OPCChannel Class See Also Send Feedback

The OPCChannel type exposes the following members.

Events

Name | Description
DataTransmission | Overridden. See DataTransmission()()(). (Overrides DataChannel..::.DataTransmission.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
WriteStatus | Overridden. See WriteStatus()()(). (Overrides DataChannel..::.WriteStatus.)

See Also

OPCChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


DataTransmission Event

[image]

.NET ModelKit Suite ClassReference
OPCChannel..::.DataTransmission Event
OPCChannel Class See Also Send Feedback
Overridden. See DataTransmission()()().

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public override event DataTransmissionEventHandler DataTransmission
Visual Basic (Declaration)
Public Overrides Event DataTransmission As DataTransmissionEventHandler
Visual C++
public:
virtual  event DataTransmissionEventHandler^ DataTransmission {
    void add (DataTransmissionEventHandler^ value);
    void remove (DataTransmissionEventHandler^ value);
}

See Also

OPCChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


WriteStatus Event

[image]

.NET ModelKit Suite ClassReference
OPCChannel..::.WriteStatus Event
OPCChannel Class See Also Send Feedback
Overridden. See WriteStatus()()().

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public override event WriteStatusEventHandler WriteStatus
Visual Basic (Declaration)
Public Overrides Event WriteStatus As WriteStatusEventHandler
Visual C++
public:
virtual  event WriteStatusEventHandler^ WriteStatus {
    void add (WriteStatusEventHandler^ value);
    void remove (WriteStatusEventHandler^ value);
}

See Also

OPCChannel Class
PerpetuumSoft.Framework.Connectivity Namespace


OPCConnection Class

[image]

.NET ModelKit Suite ClassReference
OPCConnection Class
Members See Also Send Feedback
Class desсribes all the connection parameters for OPC Data Access.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public class OPCConnection : Connection
Visual Basic (Declaration)
Public Class OPCConnection _
    Inherits Connection
Visual C++
public ref class OPCConnection : public Connection

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Framework.Connectivity..::.Connection
PerpetuumSoft.Framework.Connectivity..::.OPCConnection

See Also

OPCConnection Members
PerpetuumSoft.Framework.Connectivity Namespace


OPCConnection Members

[image] [image]

.NET ModelKit Suite ClassReference
OPCConnection Members
OPCConnection Class Constructors Methods Properties Events See Also Send Feedback

The OPCConnection type exposes the following members.

Constructors

Name | Description
OPCConnection | Overloaded.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetOPCServers | Overloaded.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Host | Gets Host.
OPCServer | Gets or sets OPCServerInfo
ProgID | Gets COM server progID, always not null.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

OPCConnection Class
PerpetuumSoft.Framework.Connectivity Namespace


OPCConnection Constructor

[image] [image]

.NET ModelKit Suite ClassReference
OPCConnection Constructor
OPCConnection Class See Also Send Feedback

Overload List

Name | Description
OPCConnection()()() | Initializes a new instance of the OPCConnection class.
OPCConnection(String) | Initializes a new instance of the OPCConnection class with specified OPC COM server ProgID.
OPCConnection(String, String) | Initializes a new instance of the OPCConnection class with OPC COM server ProgID and host name.

See Also

OPCConnection Class
OPCConnection Members
PerpetuumSoft.Framework.Connectivity Namespace


OPCConnection Constructor

[image]

.NET ModelKit Suite ClassReference
OPCConnection Constructor
OPCConnection Class See Also Send Feedback
Initializes a new instance of the OPCConnection class.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public OPCConnection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OPCConnection()

See Also

OPCConnection Class
OPCConnection Overload
PerpetuumSoft.Framework.Connectivity Namespace


OPCConnection Constructor (String)

[image]

.NET ModelKit Suite ClassReference
OPCConnection Constructor (String)
OPCConnection Class See Also Send Feedback
Initializes a new instance of the OPCConnection class with specified OPC COM server ProgID.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public OPCConnection(
    string progID
)
Visual Basic (Declaration)
Public Sub New ( _
    progID As String _
)
Visual C++
public:
OPCConnection(
    String^ progID
)

Parameters

progID
Type: System..::.String

See Also

OPCConnection Class
OPCConnection Overload
PerpetuumSoft.Framework.Connectivity Namespace


OPCConnection Constructor (String, String)

[image]

.NET ModelKit Suite ClassReference
OPCConnection Constructor (String, String)
OPCConnection Class See Also Send Feedback
Initializes a new instance of the OPCConnection class with OPC COM server ProgID and host name.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public OPCConnection(
    string progID,
    string host
)
Visual Basic (Declaration)
Public Sub New ( _
    progID As String, _
    host As String _
)
Visual C++
public:
OPCConnection(
    String^ progID,
    String^ host
)

Parameters

progID
Type: System..::.String
host
Type: System..::.String

See Also

OPCConnection Class
OPCConnection Overload
PerpetuumSoft.Framework.Connectivity Namespace


OPCConnection Methods

[image] [image]

.NET ModelKit Suite ClassReference
OPCConnection Methods
OPCConnection Class See Also Send Feedback

The OPCConnection type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetOPCServers | Overloaded.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

OPCConnection Class
PerpetuumSoft.Framework.Connectivity Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
OPCConnection..::.Dispose Method
OPCConnection Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

OPCConnection Class
OPCConnection Members
PerpetuumSoft.Framework.Connectivity Namespace


GetOPCServers Method

[image] [image]

.NET ModelKit Suite ClassReference
OPCConnection..::.GetOPCServers Method
OPCConnection Class See Also Send Feedback

Overload List

Name | Description
GetOPCServers()()() | Returns list of available OPC servers
GetOPCServers(String) | Returns list of available OPC servers.

See Also

OPCConnection Class
OPCConnection Members
PerpetuumSoft.Framework.Connectivity Namespace


GetOPCServers Method

[image]

.NET ModelKit Suite ClassReference
OPCConnection..::.GetOPCServers Method
OPCConnection Class See Also Send Feedback
Returns list of available OPC servers

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public static OPCServerDetail[] GetOPCServers()
Visual Basic (Declaration)
Public Shared Function GetOPCServers As OPCServerDetail()
Visual C++
public:
static array<OPCServerDetail>^ GetOPCServers()

See Also

OPCConnection Class
GetOPCServers Overload
PerpetuumSoft.Framework.Connectivity Namespace


GetOPCServers Method (String)

[image]

.NET ModelKit Suite ClassReference
OPCConnection..::.GetOPCServers Method (String)
OPCConnection Class See Also Send Feedback
Returns list of available OPC servers.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public static OPCServerDetail[] GetOPCServers(
    string host
)
Visual Basic (Declaration)
Public Shared Function GetOPCServers ( _
    host As String _
) As OPCServerDetail()
Visual C++
public:
static array<OPCServerDetail>^ GetOPCServers(
    String^ host
)

Parameters

host
Type: System..::.String

See Also

OPCConnection Class
GetOPCServers Overload
PerpetuumSoft.Framework.Connectivity Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
OPCConnection..::.MemberwiseClone Method
OPCConnection Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

OPCConnection Class
OPCConnection Members
PerpetuumSoft.Framework.Connectivity Namespace


OPCConnection Properties

[image] [image]

.NET ModelKit Suite ClassReference
OPCConnection Properties
OPCConnection Class See Also Send Feedback

The OPCConnection type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Host | Gets Host.
OPCServer | Gets or sets OPCServerInfo
ProgID | Gets COM server progID, always not null.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

OPCConnection Class
PerpetuumSoft.Framework.Connectivity Namespace


Host Property

[image]

.NET ModelKit Suite ClassReference
OPCConnection..::.Host Property
OPCConnection Class See Also Send Feedback
Gets Host.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public string Host { get; set; }
Visual Basic (Declaration)
Public Property Host As String
Visual C++
public:
property String^ Host {
    String^ get ();
    void set (String^ value);
}

See Also

OPCConnection Class
PerpetuumSoft.Framework.Connectivity Namespace


OPCServer Property

[image]

.NET ModelKit Suite ClassReference
OPCConnection..::.OPCServer Property
OPCConnection Class See Also Send Feedback
Gets or sets OPCServerInfo

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public OPCServerInfo OPCServer { get; set; }
Visual Basic (Declaration)
Public Property OPCServer As OPCServerInfo
Visual C++
public:
property OPCServerInfo OPCServer {
    OPCServerInfo get ();
    void set (OPCServerInfo value);
}

See Also

OPCConnection Class
PerpetuumSoft.Framework.Connectivity Namespace


ProgID Property

[image]

.NET ModelKit Suite ClassReference
OPCConnection..::.ProgID Property
OPCConnection Class See Also Send Feedback
Gets COM server progID, always not null.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public string ProgID { get; set; }
Visual Basic (Declaration)
Public Property ProgID As String
Visual C++
public:
property String^ ProgID {
    String^ get ();
    void set (String^ value);
}

See Also

OPCConnection Class
PerpetuumSoft.Framework.Connectivity Namespace


OPCConnection Events

[image] [image]

.NET ModelKit Suite ClassReference
OPCConnection Events
OPCConnection Class See Also Send Feedback

The OPCConnection type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

OPCConnection Class
PerpetuumSoft.Framework.Connectivity Namespace


OPCServerDetail Structure

[image]

.NET ModelKit Suite ClassReference
OPCServerDetail Structure
Members See Also Send Feedback
Represents information about OPC Server.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public struct OPCServerDetail
Visual Basic (Declaration)
Public Structure OPCServerDetail
Visual C++
public value class OPCServerDetail

See Also

OPCServerDetail Members
PerpetuumSoft.Framework.Connectivity Namespace


OPCServerDetail Members

[image] [image]

.NET ModelKit Suite ClassReference
OPCServerDetail Members
OPCServerDetail Structure Constructors Methods Properties See Also Send Feedback

The OPCServerDetail type exposes the following members.

Constructors

Name | Description
OPCServerDetail | Initializes a new instance of the OPCServerDetail class.

Methods

Name | Description
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Name | Gets String
ProgID | Gets ProgID of OPC Server.

See Also

OPCServerDetail Structure
PerpetuumSoft.Framework.Connectivity Namespace


OPCServerDetail Constructor

[image]

.NET ModelKit Suite ClassReference
OPCServerDetail Constructor
OPCServerDetail Structure See Also Send Feedback
Initializes a new instance of the OPCServerDetail class.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public OPCServerDetail(
    string progID,
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    progID As String, _
    name As String _
)
Visual C++
public:
OPCServerDetail(
    String^ progID,
    String^ name
)

Parameters

progID
Type: System..::.String
name
Type: System..::.String

See Also

OPCServerDetail Structure
PerpetuumSoft.Framework.Connectivity Namespace


OPCServerDetail Methods

[image] [image]

.NET ModelKit Suite ClassReference
OPCServerDetail Methods
OPCServerDetail Structure See Also Send Feedback

The OPCServerDetail type exposes the following members.

Methods

Name | Description
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

OPCServerDetail Structure
PerpetuumSoft.Framework.Connectivity Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
OPCServerDetail..::.Equals Method
OPCServerDetail Structure See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

OPCServerDetail Structure
PerpetuumSoft.Framework.Connectivity Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
OPCServerDetail..::.GetHashCode Method
OPCServerDetail Structure See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

OPCServerDetail Structure
PerpetuumSoft.Framework.Connectivity Namespace


OPCServerDetail Properties

[image] [image]

.NET ModelKit Suite ClassReference
OPCServerDetail Properties
OPCServerDetail Structure See Also Send Feedback

The OPCServerDetail type exposes the following members.

Properties

Name | Description
Name | Gets String
ProgID | Gets ProgID of OPC Server.

See Also

OPCServerDetail Structure
PerpetuumSoft.Framework.Connectivity Namespace


Name Property

[image]

.NET ModelKit Suite ClassReference
OPCServerDetail..::.Name Property
OPCServerDetail Structure See Also Send Feedback
Gets String

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

OPCServerDetail Structure
PerpetuumSoft.Framework.Connectivity Namespace


ProgID Property

[image]

.NET ModelKit Suite ClassReference
OPCServerDetail..::.ProgID Property
OPCServerDetail Structure See Also Send Feedback
Gets ProgID of OPC Server.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public string ProgID { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProgID As String
Visual C++
public:
property String^ ProgID {
    String^ get ();
}

See Also

OPCServerDetail Structure
PerpetuumSoft.Framework.Connectivity Namespace


Quality Enumeration

[image]

.NET ModelKit Suite ClassReference
Quality Enumeration
See Also Send Feedback
Represents possible qualities of DataPoint.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public enum Quality
Visual Basic (Declaration)
Public Enumeration Quality
Visual C++
public enum class Quality

Members

Member name | Description
Error | Error.
Bad | Bad.
Good | Good.
Uncertain | Uncertain.

See Also

PerpetuumSoft.Framework.Connectivity Namespace


TransactionItemsStatus Class

[image]

.NET ModelKit Suite ClassReference
TransactionItemsStatus Class
Members See Also Send Feedback
Represent information about DataItem.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public class TransactionItemsStatus : ITransaction
Visual Basic (Declaration)
Public Class TransactionItemsStatus _
    Implements ITransaction
Visual C++
public ref class TransactionItemsStatus : ITransaction

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Connectivity..::.TransactionItemsStatus

See Also

TransactionItemsStatus Members
PerpetuumSoft.Framework.Connectivity Namespace


TransactionItemsStatus Members

[image] [image]

.NET ModelKit Suite ClassReference
TransactionItemsStatus Members
TransactionItemsStatus Class Constructors Methods Properties See Also Send Feedback

The TransactionItemsStatus type exposes the following members.

Constructors

Name | Description
TransactionItemsStatus | Initializes a new instance of the TransactionItemsStatus class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | Implements Description.
ID | Implements ID.
Item | Gets DataError with specified index.

See Also

TransactionItemsStatus Class
PerpetuumSoft.Framework.Connectivity Namespace


TransactionItemsStatus Constructor

[image]

.NET ModelKit Suite ClassReference
TransactionItemsStatus Constructor
TransactionItemsStatus Class See Also Send Feedback
Initializes a new instance of the TransactionItemsStatus class.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public TransactionItemsStatus(
    int transactionID
)
Visual Basic (Declaration)
Public Sub New ( _
    transactionID As Integer _
)
Visual C++
public:
TransactionItemsStatus(
    int transactionID
)

Parameters

transactionID
Type: System..::.Int32

See Also

TransactionItemsStatus Class
PerpetuumSoft.Framework.Connectivity Namespace


TransactionItemsStatus Methods

[image] [image]

.NET ModelKit Suite ClassReference
TransactionItemsStatus Methods
TransactionItemsStatus Class See Also Send Feedback

The TransactionItemsStatus type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransactionItemsStatus Class
PerpetuumSoft.Framework.Connectivity Namespace


TransactionItemsStatus Properties

[image] [image]

.NET ModelKit Suite ClassReference
TransactionItemsStatus Properties
TransactionItemsStatus Class See Also Send Feedback

The TransactionItemsStatus type exposes the following members.

Properties

Name | Description
Description | Implements Description.
ID | Implements ID.
Item | Gets DataError with specified index.

See Also

TransactionItemsStatus Class
PerpetuumSoft.Framework.Connectivity Namespace


Description Property

[image]

.NET ModelKit Suite ClassReference
TransactionItemsStatus..::.Description Property
TransactionItemsStatus Class See Also Send Feedback
Implements Description.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () sealed;
}

Implements

ITransaction..::.Description

See Also

TransactionItemsStatus Class
PerpetuumSoft.Framework.Connectivity Namespace


ID Property

[image]

.NET ModelKit Suite ClassReference
TransactionItemsStatus..::.ID Property
TransactionItemsStatus Class See Also Send Feedback
Implements ID.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public int ID { get; }
Visual Basic (Declaration)
Public ReadOnly Property ID As Integer
Visual C++
public:
virtual property int ID {
    int get () sealed;
}

Implements

ITransaction..::.ID

See Also

TransactionItemsStatus Class
PerpetuumSoft.Framework.Connectivity Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
TransactionItemsStatus..::.Item Property
TransactionItemsStatus Class See Also Send Feedback
Gets DataError with specified index.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public DataError this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As DataError
Visual C++
public:
property DataError^ default[int index] {
    DataError^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

TransactionItemsStatus Class
PerpetuumSoft.Framework.Connectivity Namespace


WriteStatusEventArgs Class

[image]

.NET ModelKit Suite ClassReference
WriteStatusEventArgs Class
Members See Also Send Feedback
Provides data for the WriteStatus event.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public class WriteStatusEventArgs : EventArgs,
    ITransaction
Visual Basic (Declaration)
Public Class WriteStatusEventArgs _
    Inherits EventArgs _
    Implements ITransaction
Visual C++
public ref class WriteStatusEventArgs : public EventArgs,
    ITransaction

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Framework.Connectivity..::.WriteStatusEventArgs

See Also

WriteStatusEventArgs Members
PerpetuumSoft.Framework.Connectivity Namespace


WriteStatusEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
WriteStatusEventArgs Members
WriteStatusEventArgs Class Constructors Methods Properties See Also Send Feedback

The WriteStatusEventArgs type exposes the following members.

Constructors

Name | Description
WriteStatusEventArgs | Initializes a new instance of the WriteStatusEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | Implements Description.
ID | Implements ID.
Item | Gets DataError with specified index.

See Also

WriteStatusEventArgs Class
PerpetuumSoft.Framework.Connectivity Namespace


WriteStatusEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
WriteStatusEventArgs Constructor
WriteStatusEventArgs Class See Also Send Feedback
Initializes a new instance of the WriteStatusEventArgs class.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public WriteStatusEventArgs(
    int transactionID
)
Visual Basic (Declaration)
Public Sub New ( _
    transactionID As Integer _
)
Visual C++
public:
WriteStatusEventArgs(
    int transactionID
)

Parameters

transactionID
Type: System..::.Int32

See Also

WriteStatusEventArgs Class
PerpetuumSoft.Framework.Connectivity Namespace


WriteStatusEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
WriteStatusEventArgs Methods
WriteStatusEventArgs Class See Also Send Feedback

The WriteStatusEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WriteStatusEventArgs Class
PerpetuumSoft.Framework.Connectivity Namespace


WriteStatusEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
WriteStatusEventArgs Properties
WriteStatusEventArgs Class See Also Send Feedback

The WriteStatusEventArgs type exposes the following members.

Properties

Name | Description
Description | Implements Description.
ID | Implements ID.
Item | Gets DataError with specified index.

See Also

WriteStatusEventArgs Class
PerpetuumSoft.Framework.Connectivity Namespace


Description Property

[image]

.NET ModelKit Suite ClassReference
WriteStatusEventArgs..::.Description Property
WriteStatusEventArgs Class See Also Send Feedback
Implements Description.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () sealed;
}

Implements

ITransaction..::.Description

See Also

WriteStatusEventArgs Class
PerpetuumSoft.Framework.Connectivity Namespace


ID Property

[image]

.NET ModelKit Suite ClassReference
WriteStatusEventArgs..::.ID Property
WriteStatusEventArgs Class See Also Send Feedback
Implements ID.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public int ID { get; }
Visual Basic (Declaration)
Public ReadOnly Property ID As Integer
Visual C++
public:
virtual property int ID {
    int get () sealed;
}

Implements

ITransaction..::.ID

See Also

WriteStatusEventArgs Class
PerpetuumSoft.Framework.Connectivity Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
WriteStatusEventArgs..::.Item Property
WriteStatusEventArgs Class See Also Send Feedback
Gets DataError with specified index.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public DataError this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As DataError
Visual C++
public:
property DataError^ default[int index] {
    DataError^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

WriteStatusEventArgs Class
PerpetuumSoft.Framework.Connectivity Namespace


WriteStatusEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
WriteStatusEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the WriteStatus event.

Namespace: PerpetuumSoft.Framework.Connectivity
Assembly: PerpetuumSoft.Framework.Connectivity (in PerpetuumSoft.Framework.Connectivity.dll) Version: 3.9.0.1

Syntax

C#
public delegate void WriteStatusEventHandler(
    Object sender,
    WriteStatusEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub WriteStatusEventHandler ( _
    sender As Object, _
    e As WriteStatusEventArgs _
)
Visual C++
public delegate void WriteStatusEventHandler(
    Object^ sender,
    WriteStatusEventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: PerpetuumSoft.Framework.Connectivity..::.WriteStatusEventArgs

See Also

PerpetuumSoft.Framework.Connectivity Namespace


PerpetuumSoft.Framework.Drawing Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Framework.Drawing Namespace
Send Feedback
The PerpetuumSoft.Framework.Drawing namespace contains classes for the work with graphics.

Classes

Class | Description
BarCodePainter | Draws a barcode.
Border | Defines the kind of a border around an element.
ConicalFill | Represent the conical gradient fill.
EmptyFill | Represents a null fill.
EmptyStroke | Represents a null stroke.
Fill | Represents base abstract class for all fill types.
Fill..::.Utilities |
FontDescriptor | Describes the Font object.
GradientColor | Represents the gradient color, defined by Color structure and portion in the end fill.
GradientColorCollection | Represents the collection of gradient colors.
GraphicStream | Encapsulates drawing surface.
HatchFill | Defines the fill with a hatch style, a foreground color, and a background color.
LinearGradientFill | Encapsulates the Fill object with a linear gradient.
MultiGradientFill | Encapsulates the Fill object with a multilinear gradient.
Pdf417Settings | Represents barcode settings of the PDF417 type.
RoundedVectorRectangle | Rounded rectangle.
SimpleStroke | Encapsulates the Stroke object with a simple stroke.
SolidFill | Encapsulates the Fill object with single fill.
SphericalFill | Encapsulates the Fill object with the spherical gradient.
Stroke | Represents base abstract class for all stroke types.
ToolboxImageAttribute | Represents the attribute which sets the collection of icons of different sizes.

Structures

Structure | Description
BorderLine | Defines parameters for line drawing: style, color, and width.
Margins | Represents control's margins.
Unit | Incapsulates properties of a measure unit.
Vector | Defines the properties of vectors on a plane and operations on these vectors.
VectorRectangle | Defines the location and the size of a rectangle on a surface.

Delegates

Delegate | Description
GradientColorCollection..::.CollectionChangedEventHandler | Represents the method that will handle the CollectionChanged.

Enumerations

Enumeration | Description
BarCodeLabelPosition | Definitions for barcode label position and alignment.
BarCodeType | Available barcode types.
Direction | Enumrates vector directions.
FontStyleMode | Enumerates modes for font styles.
LineStyle | Enumerates the styles for line drawing.
PictureFormat | Available Image Formats.
ToolButtonsDisplayMode | Enumerates icon displaying modes.


BarCodeLabelPosition Enumeration

[image]

.NET ModelKit Suite ClassReference
BarCodeLabelPosition Enumeration
See Also Send Feedback
Definitions for barcode label position and alignment.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public enum BarCodeLabelPosition
Visual Basic (Declaration)
Public Enumeration BarCodeLabelPosition
Visual C++
public enum class BarCodeLabelPosition

Members

Member name | Description
BottomLeft | Bottom-left.
BottomCenter | Bottom-center.
BottomRight | Bottom-right.
TopLeft | Top-left.
TopCenter | Top-center.
TopRight | Top-right.

See Also

PerpetuumSoft.Framework.Drawing Namespace


BarCodePainter Class

[image]

.NET ModelKit Suite ClassReference
BarCodePainter Class
Members See Also Send Feedback
Draws a barcode.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class BarCodePainter
Visual Basic (Declaration)
Public Class BarCodePainter
Visual C++
public ref class BarCodePainter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Drawing..::.BarCodePainter

See Also

BarCodePainter Members
PerpetuumSoft.Framework.Drawing Namespace


BarCodePainter Members

[image] [image]

.NET ModelKit Suite ClassReference
BarCodePainter Members
BarCodePainter Class Constructors Methods Properties See Also Send Feedback

The BarCodePainter type exposes the following members.

Constructors

Name | Description
BarCodePainter | Initializes a new instance of the BarCodePainter class.

Methods

Name | Description
DrawBarCode | Draws the barcode based on the specified graphics parameters in the specified rectangle.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BackColor | Gets or sets the color of spaces between the bars (the background color).
BarCodeSize |
BarColor | Gets or sets the bars color (the foreground color).
BarPoint | Gets or sets bar point.
BarRatio | Gets or sets bar ratio for barcode, default value 2.0f.
CheckSumm | Gets or sets whether a check sum should be calculated for the current instance of BarCodePainter.
Code | Gets or set the value coded in the BarCodePainter object.
CodeType | Gets or sets the type of barcode.
Font | Gets or sets the barcode label font.
LabelPosition | Label position for the current instance of BarCodePainter.
MicroQRCodeSettings |
Modul | Gets or sets module, values from 1 to 49 are allowed.
Pdf417Settings | Gets or sets Pdf417Settings object that represents barcode settings.
QRCodeSettings |
ShowCheckDigit | Gets or sets whether the check sum should be drawn in the label.
ShowLabel | Gets or sets whether the label should be drawn for the current instance of BarCodePainter.
TextColor | Gets or sets the text label color.

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


BarCodePainter Constructor

[image]

.NET ModelKit Suite ClassReference
BarCodePainter Constructor
BarCodePainter Class See Also Send Feedback
Initializes a new instance of the BarCodePainter class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public BarCodePainter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarCodePainter()

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


BarCodePainter Methods

[image] [image]

.NET ModelKit Suite ClassReference
BarCodePainter Methods
BarCodePainter Class See Also Send Feedback

The BarCodePainter type exposes the following members.

Methods

Name | Description
DrawBarCode | Draws the barcode based on the specified graphics parameters in the specified rectangle.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


DrawBarCode Method

[image]

.NET ModelKit Suite ClassReference
BarCodePainter..::.DrawBarCode Method
BarCodePainter Class See Also Send Feedback
Draws the barcode based on the specified graphics parameters in the specified rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawBarCode(
    Graphics g,
    RectangleF r
)
Visual Basic (Declaration)
Public Sub DrawBarCode ( _
    g As Graphics, _
    r As RectangleF _
)
Visual C++
public:
void DrawBarCode(
    Graphics^ g,
    RectangleF r
)

Parameters

g
Type: System.Drawing..::.Graphics
r
Type: System.Drawing..::.RectangleF

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


BarCodePainter Properties

[image] [image]

.NET ModelKit Suite ClassReference
BarCodePainter Properties
BarCodePainter Class See Also Send Feedback

The BarCodePainter type exposes the following members.

Properties

Name | Description
BackColor | Gets or sets the color of spaces between the bars (the background color).
BarCodeSize |
BarColor | Gets or sets the bars color (the foreground color).
BarPoint | Gets or sets bar point.
BarRatio | Gets or sets bar ratio for barcode, default value 2.0f.
CheckSumm | Gets or sets whether a check sum should be calculated for the current instance of BarCodePainter.
Code | Gets or set the value coded in the BarCodePainter object.
CodeType | Gets or sets the type of barcode.
Font | Gets or sets the barcode label font.
LabelPosition | Label position for the current instance of BarCodePainter.
MicroQRCodeSettings |
Modul | Gets or sets module, values from 1 to 49 are allowed.
Pdf417Settings | Gets or sets Pdf417Settings object that represents barcode settings.
QRCodeSettings |
ShowCheckDigit | Gets or sets whether the check sum should be drawn in the label.
ShowLabel | Gets or sets whether the label should be drawn for the current instance of BarCodePainter.
TextColor | Gets or sets the text label color.

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


BackColor Property

[image]

.NET ModelKit Suite ClassReference
BarCodePainter..::.BackColor Property
BarCodePainter Class See Also Send Feedback
Gets or sets the color of spaces between the bars (the background color).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Color BackColor { get; set; }
Visual Basic (Declaration)
Public Property BackColor As Color
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


BarCodeSize Property

[image]

.NET ModelKit Suite ClassReference
BarCodePainter..::.BarCodeSize Property
BarCodePainter Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Framework.Drawing.BarCodePainter.BarCodeSize]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public SizeF BarCodeSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarCodeSize As SizeF
Visual C++
public:
property SizeF BarCodeSize {
    SizeF get ();
}

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


BarColor Property

[image]

.NET ModelKit Suite ClassReference
BarCodePainter..::.BarColor Property
BarCodePainter Class See Also Send Feedback
Gets or sets the bars color (the foreground color).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Color BarColor { get; set; }
Visual Basic (Declaration)
Public Property BarColor As Color
Visual C++
public:
property Color BarColor {
    Color get ();
    void set (Color value);
}

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


BarPoint Property

[image]

.NET ModelKit Suite ClassReference
BarCodePainter..::.BarPoint Property
BarCodePainter Class See Also Send Feedback
Gets or sets bar point.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double BarPoint { get; set; }
Visual Basic (Declaration)
Public Property BarPoint As Double
Visual C++
public:
property double BarPoint {
    double get ();
    void set (double value);
}

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


BarRatio Property

[image]

.NET ModelKit Suite ClassReference
BarCodePainter..::.BarRatio Property
BarCodePainter Class See Also Send Feedback
Gets or sets bar ratio for barcode, default value 2.0f.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public float BarRatio { get; set; }
Visual Basic (Declaration)
Public Property BarRatio As Single
Visual C++
public:
property float BarRatio {
    float get ();
    void set (float value);
}

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


CheckSumm Property

[image]

.NET ModelKit Suite ClassReference
BarCodePainter..::.CheckSumm Property
BarCodePainter Class See Also Send Feedback
Gets or sets whether a check sum should be calculated for the current instance of BarCodePainter.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public bool CheckSumm { get; set; }
Visual Basic (Declaration)
Public Property CheckSumm As Boolean
Visual C++
public:
property bool CheckSumm {
    bool get ();
    void set (bool value);
}

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


Code Property

[image]

.NET ModelKit Suite ClassReference
BarCodePainter..::.Code Property
BarCodePainter Class See Also Send Feedback
Gets or set the value coded in the BarCodePainter object.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public string Code { get; set; }
Visual Basic (Declaration)
Public Property Code As String
Visual C++
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


CodeType Property

[image]

.NET ModelKit Suite ClassReference
BarCodePainter..::.CodeType Property
BarCodePainter Class See Also Send Feedback
Gets or sets the type of barcode.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public BarCodeType CodeType { get; set; }
Visual Basic (Declaration)
Public Property CodeType As BarCodeType
Visual C++
public:
property BarCodeType CodeType {
    BarCodeType get ();
    void set (BarCodeType value);
}

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


Font Property

[image]

.NET ModelKit Suite ClassReference
BarCodePainter..::.Font Property
BarCodePainter Class See Also Send Feedback
Gets or sets the barcode label font.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public FontDescriptor Font { get; set; }
Visual Basic (Declaration)
Public Property Font As FontDescriptor
Visual C++
public:
property FontDescriptor^ Font {
    FontDescriptor^ get ();
    void set (FontDescriptor^ value);
}

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


LabelPosition Property

[image]

.NET ModelKit Suite ClassReference
BarCodePainter..::.LabelPosition Property
BarCodePainter Class See Also Send Feedback
Label position for the current instance of BarCodePainter.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public BarCodeLabelPosition LabelPosition { get; set; }
Visual Basic (Declaration)
Public Property LabelPosition As BarCodeLabelPosition
Visual C++
public:
property BarCodeLabelPosition LabelPosition {
    BarCodeLabelPosition get ();
    void set (BarCodeLabelPosition value);
}

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


MicroQRCodeSettings Property

[image]

.NET ModelKit Suite ClassReference
BarCodePainter..::.MicroQRCodeSettings Property
BarCodePainter Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Framework.Drawing.BarCodePainter.MicroQRCodeSettings]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public MicroQRCodeSettings MicroQRCodeSettings { get; set; }
Visual Basic (Declaration)
Public Property MicroQRCodeSettings As MicroQRCodeSettings
Visual C++
public:
property MicroQRCodeSettings^ MicroQRCodeSettings {
    MicroQRCodeSettings^ get ();
    void set (MicroQRCodeSettings^ value);
}

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


Modul Property

[image]

.NET ModelKit Suite ClassReference
BarCodePainter..::.Modul Property
BarCodePainter Class See Also Send Feedback
Gets or sets module, values from 1 to 49 are allowed.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public int Modul { get; set; }
Visual Basic (Declaration)
Public Property Modul As Integer
Visual C++
public:
property int Modul {
    int get ();
    void set (int value);
}

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


Pdf417Settings Property

[image]

.NET ModelKit Suite ClassReference
BarCodePainter..::.Pdf417Settings Property
BarCodePainter Class See Also Send Feedback
Gets or sets Pdf417Settings object that represents barcode settings.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Pdf417Settings Pdf417Settings { get; set; }
Visual Basic (Declaration)
Public Property Pdf417Settings As Pdf417Settings
Visual C++
public:
property Pdf417Settings^ Pdf417Settings {
    Pdf417Settings^ get ();
    void set (Pdf417Settings^ value);
}

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


QRCodeSettings Property

[image]

.NET ModelKit Suite ClassReference
BarCodePainter..::.QRCodeSettings Property
BarCodePainter Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Framework.Drawing.BarCodePainter.QRCodeSettings]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public QRCodeSettings QRCodeSettings { get; set; }
Visual Basic (Declaration)
Public Property QRCodeSettings As QRCodeSettings
Visual C++
public:
property QRCodeSettings^ QRCodeSettings {
    QRCodeSettings^ get ();
    void set (QRCodeSettings^ value);
}

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


ShowCheckDigit Property

[image]

.NET ModelKit Suite ClassReference
BarCodePainter..::.ShowCheckDigit Property
BarCodePainter Class See Also Send Feedback
Gets or sets whether the check sum should be drawn in the label.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowCheckDigit { get; set; }
Visual Basic (Declaration)
Public Property ShowCheckDigit As Boolean
Visual C++
public:
property bool ShowCheckDigit {
    bool get ();
    void set (bool value);
}

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


ShowLabel Property

[image]

.NET ModelKit Suite ClassReference
BarCodePainter..::.ShowLabel Property
BarCodePainter Class See Also Send Feedback
Gets or sets whether the label should be drawn for the current instance of BarCodePainter.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowLabel { get; set; }
Visual Basic (Declaration)
Public Property ShowLabel As Boolean
Visual C++
public:
property bool ShowLabel {
    bool get ();
    void set (bool value);
}

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


TextColor Property

[image]

.NET ModelKit Suite ClassReference
BarCodePainter..::.TextColor Property
BarCodePainter Class See Also Send Feedback
Gets or sets the text label color.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Color TextColor { get; set; }
Visual Basic (Declaration)
Public Property TextColor As Color
Visual C++
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}

See Also

BarCodePainter Class
PerpetuumSoft.Framework.Drawing Namespace


BarCodeType Enumeration

[image]

.NET ModelKit Suite ClassReference
BarCodeType Enumeration
See Also Send Feedback
Available barcode types.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public enum BarCodeType
Visual Basic (Declaration)
Public Enumeration BarCodeType
Visual C++
public enum class BarCodeType

Members

Member name | Description
Code_2_5_interleaved | Code 25 interleaved.
Code_2_5_industrial | Code25 industrial.
Code_2_5_matrix | Code 25 matrix.
Code39 | Code 39.
Code39Extended | Code 39 Extended.
Code128A | Code 128A.
Code128B | Code 128B.
Code128C | Code 128C.
Code93 | Code 93.
Code93Extended | Code 93 Extended.
CodeMSI | Code MSI.
CodePostNet | Code PostNet.
CodeCodabar | Code Codabar.
CodeEAN8 | Code EAN8.
CodeJAN8 | Code JAN8.
CodeEAN13 | Code EAN13.
CodeJAN13 | Code JAN13.
CodeUPC_A | Code UPC_A.
CodeUPC_E0 | Code UPC_E0.
CodeUPC_E1 | Code UPC_E1.
CodeUPC_Supp2 | Code UPC_Supp2.
CodeUPC_Supp5 | Code UPC_Supp5.
CodeEAN128A | Code EAN128A.
CodeEAN128B | Code EAN128B.
CodeEAN128C | Code EAN128C.
Japan_Postal | Japan postal bar code.
PDF417 | Code PDF417.
PDF417Compact | Code PDF417Compact.
QRCode |
MicroQRCode |

See Also

PerpetuumSoft.Framework.Drawing Namespace


Border Class

[image]

.NET ModelKit Suite ClassReference
Border Class
Members See Also Send Feedback
Defines the kind of a border around an element.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class Border : Atom
Visual Basic (Declaration)
Public Class Border _
    Inherits Atom
Visual C++
public ref class Border : public Atom

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework..::.Atom
PerpetuumSoft.Framework.Drawing..::.Border

See Also

Border Members
PerpetuumSoft.Framework.Drawing Namespace


Border Members

[image] [image]

.NET ModelKit Suite ClassReference
Border Members
Border Class Constructors Methods Properties See Also Send Feedback

The Border type exposes the following members.

Constructors

Name | Description
Border | Overloaded.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Creates a copy of the Border. (Overrides Atom..::.Clone()()().)
DrawBorder | Overloaded.
Equals | Overridden. See Equals(Object). (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Object..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
All | Allows to set a uniform line style for all sides at once.
AllLinesSameStyle | Determines whether the border has uniform lines. Returns true if all border lines are of the same style.
BottomLine | Gets or sets the bottom line of the border.
IsEmpty | Determines whether it's necessary to draw the border. Returns true if none of the borders is specified.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
LeftLine | Gets or sets the left line of the border.
RightLine | Gets or sets the right line of the border.
TopLine | Gets or sets the upper line of the border.

See Also

Border Class
PerpetuumSoft.Framework.Drawing Namespace


Border Constructor

[image] [image]

.NET ModelKit Suite ClassReference
Border Constructor
Border Class See Also Send Feedback

Overload List

Name | Description
Border()()() | Default constructor.
Border(BorderLine) | Creates a border with a uniform style of line on all sides.
Border(BorderLine, BorderLine, BorderLine, BorderLine) | Creates a border with a specified lines style.

See Also

Border Class
Border Members
PerpetuumSoft.Framework.Drawing Namespace


Border Constructor

[image]

.NET ModelKit Suite ClassReference
Border Constructor
Border Class See Also Send Feedback
Default constructor.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Border()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Border()

See Also

Border Class
Border Overload
PerpetuumSoft.Framework.Drawing Namespace


Border Constructor (BorderLine)

[image]

.NET ModelKit Suite ClassReference
Border Constructor (BorderLine)
Border Class See Also Send Feedback
Creates a border with a uniform style of line on all sides.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Border(
    BorderLine line
)
Visual Basic (Declaration)
Public Sub New ( _
    line As BorderLine _
)
Visual C++
public:
Border(
    BorderLine line
)

Parameters

line
Type: PerpetuumSoft.Framework.Drawing..::.BorderLine

See Also

Border Class
Border Overload
PerpetuumSoft.Framework.Drawing Namespace


Border Constructor (BorderLine, BorderLine, BorderLine, BorderLine)

[image]

.NET ModelKit Suite ClassReference
Border Constructor (BorderLine, BorderLine, BorderLine, BorderLine)
Border Class See Also Send Feedback
Creates a border with a specified lines style.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Border(
    BorderLine topLine,
    BorderLine bottomLine,
    BorderLine leftLine,
    BorderLine rightLine
)
Visual Basic (Declaration)
Public Sub New ( _
    topLine As BorderLine, _
    bottomLine As BorderLine, _
    leftLine As BorderLine, _
    rightLine As BorderLine _
)
Visual C++
public:
Border(
    BorderLine topLine,
    BorderLine bottomLine,
    BorderLine leftLine,
    BorderLine rightLine
)

Parameters

topLine
Type: PerpetuumSoft.Framework.Drawing..::.BorderLine
bottomLine
Type: PerpetuumSoft.Framework.Drawing..::.BorderLine
leftLine
Type: PerpetuumSoft.Framework.Drawing..::.BorderLine
rightLine
Type: PerpetuumSoft.Framework.Drawing..::.BorderLine

See Also

Border Class
Border Overload
PerpetuumSoft.Framework.Drawing Namespace


Border Methods

[image] [image]

.NET ModelKit Suite ClassReference
Border Methods
Border Class See Also Send Feedback

The Border type exposes the following members.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Creates a copy of the Border. (Overrides Atom..::.Clone()()().)
DrawBorder | Overloaded.
Equals | Overridden. See Equals(Object). (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Object..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

Border Class
PerpetuumSoft.Framework.Drawing Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
Border..::.Clone Method
Border Class See Also Send Feedback
Creates a copy of the Border.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Implements

ICloneable..::.Clone()()()

See Also

Border Class
PerpetuumSoft.Framework.Drawing Namespace


DrawBorder Method

[image] [image]

.NET ModelKit Suite ClassReference
Border..::.DrawBorder Method
Border Class See Also Send Feedback

Overload List

Name | Description
DrawBorder(Graphics, RectangleF) | Draws the border.
DrawBorder(Graphics, RectangleF, Unit) | Draws the border.

See Also

Border Class
Border Members
PerpetuumSoft.Framework.Drawing Namespace


DrawBorder Method (Graphics, RectangleF)

[image]

.NET ModelKit Suite ClassReference
Border..::.DrawBorder Method (Graphics, RectangleF)
Border Class See Also Send Feedback
Draws the border.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawBorder(
    Graphics g,
    RectangleF rect
)
Visual Basic (Declaration)
Public Sub DrawBorder ( _
    g As Graphics, _
    rect As RectangleF _
)
Visual C++
public:
void DrawBorder(
    Graphics^ g,
    RectangleF rect
)

Parameters

g
Type: System.Drawing..::.Graphics
rect
Type: System.Drawing..::.RectangleF

See Also

Border Class
DrawBorder Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawBorder Method (Graphics, RectangleF, Unit)

[image]

.NET ModelKit Suite ClassReference
Border..::.DrawBorder Method (Graphics, RectangleF, Unit)
Border Class See Also Send Feedback
Draws the border.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawBorder(
    Graphics g,
    RectangleF rect,
    Unit createPenUnit
)
Visual Basic (Declaration)
Public Sub DrawBorder ( _
    g As Graphics, _
    rect As RectangleF, _
    createPenUnit As Unit _
)
Visual C++
public:
void DrawBorder(
    Graphics^ g,
    RectangleF rect,
    Unit createPenUnit
)

Parameters

g
Type: System.Drawing..::.Graphics
rect
Type: System.Drawing..::.RectangleF
createPenUnit
Type: PerpetuumSoft.Framework.Drawing..::.Unit

See Also

Border Class
DrawBorder Overload
PerpetuumSoft.Framework.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
Border..::.Equals Method
Border Class See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

Border Class
PerpetuumSoft.Framework.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
Border..::.GetHashCode Method
Border Class See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

Border Class
PerpetuumSoft.Framework.Drawing Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
Border..::.ToString Method
Border Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Border Class
PerpetuumSoft.Framework.Drawing Namespace


Border Properties

[image] [image]

.NET ModelKit Suite ClassReference
Border Properties
Border Class See Also Send Feedback

The Border type exposes the following members.

Properties

Name | Description
All | Allows to set a uniform line style for all sides at once.
AllLinesSameStyle | Determines whether the border has uniform lines. Returns true if all border lines are of the same style.
BottomLine | Gets or sets the bottom line of the border.
IsEmpty | Determines whether it's necessary to draw the border. Returns true if none of the borders is specified.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
LeftLine | Gets or sets the left line of the border.
RightLine | Gets or sets the right line of the border.
TopLine | Gets or sets the upper line of the border.

See Also

Border Class
PerpetuumSoft.Framework.Drawing Namespace


All Property

[image]

.NET ModelKit Suite ClassReference
Border..::.All Property
Border Class See Also Send Feedback
Allows to set a uniform line style for all sides at once.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public BorderLine All { get; set; }
Visual Basic (Declaration)
Public Property All As BorderLine
Visual C++
public:
property BorderLine All {
    BorderLine get ();
    void set (BorderLine value);
}

See Also

Border Class
PerpetuumSoft.Framework.Drawing Namespace


AllLinesSameStyle Property

[image]

.NET ModelKit Suite ClassReference
Border..::.AllLinesSameStyle Property
Border Class See Also Send Feedback
Determines whether the border has uniform lines. Returns true if all border lines are of the same style.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public bool AllLinesSameStyle { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllLinesSameStyle As Boolean
Visual C++
public:
property bool AllLinesSameStyle {
    bool get ();
}

See Also

Border Class
PerpetuumSoft.Framework.Drawing Namespace


BottomLine Property

[image]

.NET ModelKit Suite ClassReference
Border..::.BottomLine Property
Border Class See Also Send Feedback
Gets or sets the bottom line of the border.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public BorderLine BottomLine { get; set; }
Visual Basic (Declaration)
Public Property BottomLine As BorderLine
Visual C++
public:
property BorderLine BottomLine {
    BorderLine get ();
    void set (BorderLine value);
}

See Also

Border Class
PerpetuumSoft.Framework.Drawing Namespace


IsEmpty Property

[image]

.NET ModelKit Suite ClassReference
Border..::.IsEmpty Property
Border Class See Also Send Feedback
Determines whether it's necessary to draw the border. Returns true if none of the borders is specified.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

Border Class
PerpetuumSoft.Framework.Drawing Namespace


LeftLine Property

[image]

.NET ModelKit Suite ClassReference
Border..::.LeftLine Property
Border Class See Also Send Feedback
Gets or sets the left line of the border.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public BorderLine LeftLine { get; set; }
Visual Basic (Declaration)
Public Property LeftLine As BorderLine
Visual C++
public:
property BorderLine LeftLine {
    BorderLine get ();
    void set (BorderLine value);
}

See Also

Border Class
PerpetuumSoft.Framework.Drawing Namespace


RightLine Property

[image]

.NET ModelKit Suite ClassReference
Border..::.RightLine Property
Border Class See Also Send Feedback
Gets or sets the right line of the border.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public BorderLine RightLine { get; set; }
Visual Basic (Declaration)
Public Property RightLine As BorderLine
Visual C++
public:
property BorderLine RightLine {
    BorderLine get ();
    void set (BorderLine value);
}

See Also

Border Class
PerpetuumSoft.Framework.Drawing Namespace


TopLine Property

[image]

.NET ModelKit Suite ClassReference
Border..::.TopLine Property
Border Class See Also Send Feedback
Gets or sets the upper line of the border.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public BorderLine TopLine { get; set; }
Visual Basic (Declaration)
Public Property TopLine As BorderLine
Visual C++
public:
property BorderLine TopLine {
    BorderLine get ();
    void set (BorderLine value);
}

See Also

Border Class
PerpetuumSoft.Framework.Drawing Namespace


BorderLine Structure

[image]

.NET ModelKit Suite ClassReference
BorderLine Structure
Members See Also Send Feedback
Defines parameters for line drawing: style, color, and width.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public struct BorderLine
Visual Basic (Declaration)
Public Structure BorderLine
Visual C++
public value class BorderLine

See Also

BorderLine Members
PerpetuumSoft.Framework.Drawing Namespace


BorderLine Members

[image] [image]

.NET ModelKit Suite ClassReference
BorderLine Members
BorderLine Structure Constructors Methods Properties See Also Send Feedback

The BorderLine type exposes the following members.

Constructors

Name | Description
BorderLine | Initializes a new instance of BorderLine.

Methods

Name | Description
CreatePen | Overloaded.
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

Name | Description
Color | Gets or sets line color.
Style | Gets or sets line style.
Width | Gets or sets line width.

See Also

BorderLine Structure
PerpetuumSoft.Framework.Drawing Namespace


BorderLine Constructor

[image]

.NET ModelKit Suite ClassReference
BorderLine Constructor
BorderLine Structure See Also Send Feedback
Initializes a new instance of BorderLine.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public BorderLine(
    LineStyle style,
    Color color,
    double width
)
Visual Basic (Declaration)
Public Sub New ( _
    style As LineStyle, _
    color As Color, _
    width As Double _
)
Visual C++
public:
BorderLine(
    LineStyle style,
    Color color,
    double width
)

Parameters

style
Type: PerpetuumSoft.Framework.Drawing..::.LineStyle
color
Type: System.Drawing..::.Color
width
Type: System..::.Double

See Also

BorderLine Structure
PerpetuumSoft.Framework.Drawing Namespace


BorderLine Methods

[image] [image]

.NET ModelKit Suite ClassReference
BorderLine Methods
BorderLine Structure See Also Send Feedback

The BorderLine type exposes the following members.

Methods

Name | Description
CreatePen | Overloaded.
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality |
Inequality |

See Also

BorderLine Structure
PerpetuumSoft.Framework.Drawing Namespace


CreatePen Method

[image] [image]

.NET ModelKit Suite ClassReference
BorderLine..::.CreatePen Method
BorderLine Structure See Also Send Feedback

Overload List

Name | Description
CreatePen()()() | Creates a Pen object appropriate to the line parameters.
CreatePen(Unit) | Creates a Pen object appropriate to the line parameters using the specified output device resolution.

See Also

BorderLine Structure
BorderLine Members
PerpetuumSoft.Framework.Drawing Namespace


CreatePen Method

[image]

.NET ModelKit Suite ClassReference
BorderLine..::.CreatePen Method
BorderLine Structure See Also Send Feedback
Creates a Pen object appropriate to the line parameters.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Pen CreatePen()
Visual Basic (Declaration)
Public Function CreatePen As Pen
Visual C++
public:
Pen^ CreatePen()

See Also

BorderLine Structure
CreatePen Overload
PerpetuumSoft.Framework.Drawing Namespace


CreatePen Method (Unit)

[image]

.NET ModelKit Suite ClassReference
BorderLine..::.CreatePen Method (Unit)
BorderLine Structure See Also Send Feedback
Creates a Pen object appropriate to the line parameters using the specified output device resolution.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Pen CreatePen(
    Unit unit
)
Visual Basic (Declaration)
Public Function CreatePen ( _
    unit As Unit _
) As Pen
Visual C++
public:
Pen^ CreatePen(
    Unit unit
)

Parameters

unit
Type: PerpetuumSoft.Framework.Drawing..::.Unit

See Also

BorderLine Structure
CreatePen Overload
PerpetuumSoft.Framework.Drawing Namespace


Equality Operator

[image]

.NET ModelKit Suite ClassReference
BorderLine..::.Equality Operator
BorderLine Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.BorderLine.op_Equality(PerpetuumSoft.Framework.Drawing.BorderLine,PerpetuumSoft.Framework.Drawing.BorderLine)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static bool operator ==(
    BorderLine line1,
    BorderLine line2
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    line1 As BorderLine, _
    line2 As BorderLine _
) As Boolean
Visual C++
public:
static bool operator ==(
    BorderLine line1,
    BorderLine line2
)

Parameters

line1
Type: PerpetuumSoft.Framework.Drawing..::.BorderLine
line2
Type: PerpetuumSoft.Framework.Drawing..::.BorderLine

See Also

BorderLine Structure
PerpetuumSoft.Framework.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
BorderLine..::.Equals Method
BorderLine Structure See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::.Object

See Also

BorderLine Structure
PerpetuumSoft.Framework.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
BorderLine..::.GetHashCode Method
BorderLine Structure See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

BorderLine Structure
PerpetuumSoft.Framework.Drawing Namespace


Inequality Operator

[image]

.NET ModelKit Suite ClassReference
BorderLine..::.Inequality Operator
BorderLine Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.BorderLine.op_Inequality(PerpetuumSoft.Framework.Drawing.BorderLine,PerpetuumSoft.Framework.Drawing.BorderLine)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static bool operator !=(
    BorderLine line1,
    BorderLine line2
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    line1 As BorderLine, _
    line2 As BorderLine _
) As Boolean
Visual C++
public:
static bool operator !=(
    BorderLine line1,
    BorderLine line2
)

Parameters

line1
Type: PerpetuumSoft.Framework.Drawing..::.BorderLine
line2
Type: PerpetuumSoft.Framework.Drawing..::.BorderLine

See Also

BorderLine Structure
PerpetuumSoft.Framework.Drawing Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
BorderLine..::.ToString Method
BorderLine Structure See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

BorderLine Structure
PerpetuumSoft.Framework.Drawing Namespace


BorderLine Properties

[image] [image]

.NET ModelKit Suite ClassReference
BorderLine Properties
BorderLine Structure See Also Send Feedback

The BorderLine type exposes the following members.

Properties

Name | Description
Color | Gets or sets line color.
Style | Gets or sets line style.
Width | Gets or sets line width.

See Also

BorderLine Structure
PerpetuumSoft.Framework.Drawing Namespace


Color Property

[image]

.NET ModelKit Suite ClassReference
BorderLine..::.Color Property
BorderLine Structure See Also Send Feedback
Gets or sets line color.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

BorderLine Structure
PerpetuumSoft.Framework.Drawing Namespace


Style Property

[image]

.NET ModelKit Suite ClassReference
BorderLine..::.Style Property
BorderLine Structure See Also Send Feedback
Gets or sets line style.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public LineStyle Style { get; set; }
Visual Basic (Declaration)
Public Property Style As LineStyle
Visual C++
public:
property LineStyle Style {
    LineStyle get ();
    void set (LineStyle value);
}

See Also

BorderLine Structure
PerpetuumSoft.Framework.Drawing Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
BorderLine..::.Width Property
BorderLine Structure See Also Send Feedback
Gets or sets line width.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

BorderLine Structure
PerpetuumSoft.Framework.Drawing Namespace


ConicalFill Class

[image]

.NET ModelKit Suite ClassReference
ConicalFill Class
Members See Also Send Feedback
Represent the conical gradient fill.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class ConicalFill : MultiGradientFill
Visual Basic (Declaration)
Public Class ConicalFill _
    Inherits MultiGradientFill
Visual C++
public ref class ConicalFill : public MultiGradientFill

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework..::.Atom
PerpetuumSoft.Framework.Drawing..::.Fill
PerpetuumSoft.Framework.Drawing..::.MultiGradientFill
PerpetuumSoft.Framework.Drawing..::.ConicalFill

See Also

ConicalFill Members
PerpetuumSoft.Framework.Drawing Namespace


ConicalFill Members

[image] [image]

.NET ModelKit Suite ClassReference
ConicalFill Members
ConicalFill Class Constructors Methods Properties See Also Send Feedback

The ConicalFill type exposes the following members.

Constructors

Name | Description
ConicalFill | Initializes a new instance of the ConicalFill class.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Implements Clone()()(). (Overrides MultiGradientFill..::.Clone()()().)
CreateBrush | Overridden. See CreateBrush(VectorRectangle). (Overrides MultiGradientFill..::.CreateBrush(VectorRectangle).)
Equals | Overridden. See Equals(Object). (Overrides MultiGradientFill..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides MultiGradientFill..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetReplaceColor | Overridden. See GetReplaceColor()()(). (Inherited from MultiGradientFill.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from Fill.)

Properties

Name | Description
Angle | Gets or sets the angle of fill. (Inherited from MultiGradientFill.)
CenterColor | Gets or sets the Color in the center of the cone.
Colors | Gets collection of colors for the fill specified by the GradientColorCollection object. (Inherited from MultiGradientFill.)
Delta | Gets or sets the value which assigns the offset radius of the polar coordinates.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
StartAngle | Gets or sets the initial angle of use of the colors spectrum set in the Colors property.
TotalAngle | Gets or sets the total angle of use of the colors spectrum set in the Colors property.

See Also

ConicalFill Class
PerpetuumSoft.Framework.Drawing Namespace


ConicalFill Constructor

[image]

.NET ModelKit Suite ClassReference
ConicalFill Constructor
ConicalFill Class See Also Send Feedback
Initializes a new instance of the ConicalFill class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public ConicalFill()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConicalFill()

See Also

ConicalFill Class
PerpetuumSoft.Framework.Drawing Namespace


ConicalFill Methods

[image] [image]

.NET ModelKit Suite ClassReference
ConicalFill Methods
ConicalFill Class See Also Send Feedback

The ConicalFill type exposes the following members.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Implements Clone()()(). (Overrides MultiGradientFill..::.Clone()()().)
CreateBrush | Overridden. See CreateBrush(VectorRectangle). (Overrides MultiGradientFill..::.CreateBrush(VectorRectangle).)
Equals | Overridden. See Equals(Object). (Overrides MultiGradientFill..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides MultiGradientFill..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetReplaceColor | Overridden. See GetReplaceColor()()(). (Inherited from MultiGradientFill.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from Fill.)

See Also

ConicalFill Class
PerpetuumSoft.Framework.Drawing Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
ConicalFill..::.Clone Method
ConicalFill Class See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Implements

ICloneable..::.Clone()()()

See Also

ConicalFill Class
PerpetuumSoft.Framework.Drawing Namespace


CreateBrush Method

[image]

.NET ModelKit Suite ClassReference
ConicalFill..::.CreateBrush Method
ConicalFill Class See Also Send Feedback
Overridden. See CreateBrush(VectorRectangle).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Brush CreateBrush(
    VectorRectangle rect
)
Visual Basic (Declaration)
Public Overrides Function CreateBrush ( _
    rect As VectorRectangle _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    VectorRectangle rect
) override

Parameters

rect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

ConicalFill Class
PerpetuumSoft.Framework.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
ConicalFill..::.Equals Method
ConicalFill Class See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

ConicalFill Class
PerpetuumSoft.Framework.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
ConicalFill..::.GetHashCode Method
ConicalFill Class See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

ConicalFill Class
PerpetuumSoft.Framework.Drawing Namespace


ConicalFill Properties

[image] [image]

.NET ModelKit Suite ClassReference
ConicalFill Properties
ConicalFill Class See Also Send Feedback

The ConicalFill type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the angle of fill. (Inherited from MultiGradientFill.)
CenterColor | Gets or sets the Color in the center of the cone.
Colors | Gets collection of colors for the fill specified by the GradientColorCollection object. (Inherited from MultiGradientFill.)
Delta | Gets or sets the value which assigns the offset radius of the polar coordinates.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
StartAngle | Gets or sets the initial angle of use of the colors spectrum set in the Colors property.
TotalAngle | Gets or sets the total angle of use of the colors spectrum set in the Colors property.

See Also

ConicalFill Class
PerpetuumSoft.Framework.Drawing Namespace


CenterColor Property

[image]

.NET ModelKit Suite ClassReference
ConicalFill..::.CenterColor Property
ConicalFill Class See Also Send Feedback
Gets or sets the Color in the center of the cone.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Color CenterColor { get; set; }
Visual Basic (Declaration)
Public Property CenterColor As Color
Visual C++
public:
property Color CenterColor {
    Color get ();
    void set (Color value);
}

See Also

ConicalFill Class
PerpetuumSoft.Framework.Drawing Namespace


Delta Property

[image]

.NET ModelKit Suite ClassReference
ConicalFill..::.Delta Property
ConicalFill Class See Also Send Feedback
Gets or sets the value which assigns the offset radius of the polar coordinates.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Delta { get; set; }
Visual Basic (Declaration)
Public Property Delta As Double
Visual C++
public:
property double Delta {
    double get ();
    void set (double value);
}

See Also

ConicalFill Class
PerpetuumSoft.Framework.Drawing Namespace


StartAngle Property

[image]

.NET ModelKit Suite ClassReference
ConicalFill..::.StartAngle Property
ConicalFill Class See Also Send Feedback
Gets or sets the initial angle of use of the colors spectrum set in the Colors property.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double StartAngle { get; set; }
Visual Basic (Declaration)
Public Property StartAngle As Double
Visual C++
public:
property double StartAngle {
    double get ();
    void set (double value);
}

See Also

ConicalFill Class
PerpetuumSoft.Framework.Drawing Namespace


TotalAngle Property

[image]

.NET ModelKit Suite ClassReference
ConicalFill..::.TotalAngle Property
ConicalFill Class See Also Send Feedback
Gets or sets the total angle of use of the colors spectrum set in the Colors property.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double TotalAngle { get; set; }
Visual Basic (Declaration)
Public Property TotalAngle As Double
Visual C++
public:
property double TotalAngle {
    double get ();
    void set (double value);
}

See Also

ConicalFill Class
PerpetuumSoft.Framework.Drawing Namespace


Direction Enumeration

[image]

.NET ModelKit Suite ClassReference
Direction Enumeration
See Also Send Feedback
Enumrates vector directions.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public enum Direction
Visual Basic (Declaration)
Public Enumeration Direction
Visual C++
public enum class Direction

Members

Member name | Description
X | Vertical direction.
Y | Horizontal direction.

See Also

PerpetuumSoft.Framework.Drawing Namespace


EmptyFill Class

[image]

.NET ModelKit Suite ClassReference
EmptyFill Class
Members See Also Send Feedback
Represents a null fill.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class EmptyFill : Fill
Visual Basic (Declaration)
Public Class EmptyFill _
    Inherits Fill
Visual C++
public ref class EmptyFill : public Fill

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework..::.Atom
PerpetuumSoft.Framework.Drawing..::.Fill
PerpetuumSoft.Framework.Drawing..::.EmptyFill

See Also

EmptyFill Members
PerpetuumSoft.Framework.Drawing Namespace


EmptyFill Members

[image] [image]

.NET ModelKit Suite ClassReference
EmptyFill Members
EmptyFill Class Constructors Methods Properties See Also Send Feedback

The EmptyFill type exposes the following members.

Constructors

Name | Description
EmptyFill | Initializes a new instance of the EmptyFill class.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Overridden. See Clone()()(). (Overrides Atom..::.Clone()()().)
CreateBrush | Overridden. See CreateBrush(VectorRectangle). (Overrides Fill..::.CreateBrush(VectorRectangle).)
Equals | Overridden. See Equals(Object). (Overrides Fill..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Fill..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetReplaceColor | Overridden. See GetReplaceColor()()(). (Overrides Fill..::.GetReplaceColor()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from Fill.)

Properties

Name | Description
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)

See Also

EmptyFill Class
PerpetuumSoft.Framework.Drawing Namespace


EmptyFill Constructor

[image]

.NET ModelKit Suite ClassReference
EmptyFill Constructor
EmptyFill Class See Also Send Feedback
Initializes a new instance of the EmptyFill class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public EmptyFill()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EmptyFill()

See Also

EmptyFill Class
PerpetuumSoft.Framework.Drawing Namespace


EmptyFill Methods

[image] [image]

.NET ModelKit Suite ClassReference
EmptyFill Methods
EmptyFill Class See Also Send Feedback

The EmptyFill type exposes the following members.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Overridden. See Clone()()(). (Overrides Atom..::.Clone()()().)
CreateBrush | Overridden. See CreateBrush(VectorRectangle). (Overrides Fill..::.CreateBrush(VectorRectangle).)
Equals | Overridden. See Equals(Object). (Overrides Fill..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Fill..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetReplaceColor | Overridden. See GetReplaceColor()()(). (Overrides Fill..::.GetReplaceColor()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from Fill.)

See Also

EmptyFill Class
PerpetuumSoft.Framework.Drawing Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
EmptyFill..::.Clone Method
EmptyFill Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Implements

ICloneable..::.Clone()()()

See Also

EmptyFill Class
PerpetuumSoft.Framework.Drawing Namespace


CreateBrush Method

[image]

.NET ModelKit Suite ClassReference
EmptyFill..::.CreateBrush Method
EmptyFill Class See Also Send Feedback
Overridden. See CreateBrush(VectorRectangle).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Brush CreateBrush(
    VectorRectangle rect
)
Visual Basic (Declaration)
Public Overrides Function CreateBrush ( _
    rect As VectorRectangle _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    VectorRectangle rect
) override

Parameters

rect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

EmptyFill Class
PerpetuumSoft.Framework.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
EmptyFill..::.Equals Method
EmptyFill Class See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

EmptyFill Class
PerpetuumSoft.Framework.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
EmptyFill..::.GetHashCode Method
EmptyFill Class See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

EmptyFill Class
PerpetuumSoft.Framework.Drawing Namespace


GetReplaceColor Method

[image]

.NET ModelKit Suite ClassReference
EmptyFill..::.GetReplaceColor Method
EmptyFill Class See Also Send Feedback
Overridden. See GetReplaceColor()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Color GetReplaceColor()
Visual Basic (Declaration)
Public Overrides Function GetReplaceColor As Color
Visual C++
public:
virtual Color GetReplaceColor() override

See Also

EmptyFill Class
PerpetuumSoft.Framework.Drawing Namespace


EmptyFill Properties

[image] [image]

.NET ModelKit Suite ClassReference
EmptyFill Properties
EmptyFill Class See Also Send Feedback

The EmptyFill type exposes the following members.

Properties

Name | Description
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)

See Also

EmptyFill Class
PerpetuumSoft.Framework.Drawing Namespace


EmptyStroke Class

[image]

.NET ModelKit Suite ClassReference
EmptyStroke Class
Members See Also Send Feedback
Represents a null stroke.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class EmptyStroke : Stroke
Visual Basic (Declaration)
Public Class EmptyStroke _
    Inherits Stroke
Visual C++
public ref class EmptyStroke : public Stroke

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework..::.Atom
PerpetuumSoft.Framework.Drawing..::.Stroke
PerpetuumSoft.Framework.Drawing..::.EmptyStroke

See Also

EmptyStroke Members
PerpetuumSoft.Framework.Drawing Namespace


EmptyStroke Members

[image] [image]

.NET ModelKit Suite ClassReference
EmptyStroke Members
EmptyStroke Class Constructors Methods Properties See Also Send Feedback

The EmptyStroke type exposes the following members.

Constructors

Name | Description
EmptyStroke | Initializes a new instance of the EmptyStroke class.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Overridden. See Clone()()(). (Overrides Atom..::.Clone()()().)
CreatePen | Overridden. See CreatePen()()(). (Overrides Stroke..::.CreatePen()()().)
Equals | Overridden. See Equals(Object). (Overrides Stroke..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Stroke..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from Stroke.)

Properties

Name | Description
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
Width | Overridden. See Width. (Overrides Stroke..::.Width.)

See Also

EmptyStroke Class
PerpetuumSoft.Framework.Drawing Namespace


EmptyStroke Constructor

[image]

.NET ModelKit Suite ClassReference
EmptyStroke Constructor
EmptyStroke Class See Also Send Feedback
Initializes a new instance of the EmptyStroke class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public EmptyStroke()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EmptyStroke()

See Also

EmptyStroke Class
PerpetuumSoft.Framework.Drawing Namespace


EmptyStroke Methods

[image] [image]

.NET ModelKit Suite ClassReference
EmptyStroke Methods
EmptyStroke Class See Also Send Feedback

The EmptyStroke type exposes the following members.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Overridden. See Clone()()(). (Overrides Atom..::.Clone()()().)
CreatePen | Overridden. See CreatePen()()(). (Overrides Stroke..::.CreatePen()()().)
Equals | Overridden. See Equals(Object). (Overrides Stroke..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Stroke..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from Stroke.)

See Also

EmptyStroke Class
PerpetuumSoft.Framework.Drawing Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
EmptyStroke..::.Clone Method
EmptyStroke Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Implements

ICloneable..::.Clone()()()

See Also

EmptyStroke Class
PerpetuumSoft.Framework.Drawing Namespace


CreatePen Method

[image]

.NET ModelKit Suite ClassReference
EmptyStroke..::.CreatePen Method
EmptyStroke Class See Also Send Feedback
Overridden. See CreatePen()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Pen CreatePen()
Visual Basic (Declaration)
Public Overrides Function CreatePen As Pen
Visual C++
public:
virtual Pen^ CreatePen() override

See Also

EmptyStroke Class
PerpetuumSoft.Framework.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
EmptyStroke..::.Equals Method
EmptyStroke Class See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

EmptyStroke Class
PerpetuumSoft.Framework.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
EmptyStroke..::.GetHashCode Method
EmptyStroke Class See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

EmptyStroke Class
PerpetuumSoft.Framework.Drawing Namespace


EmptyStroke Properties

[image] [image]

.NET ModelKit Suite ClassReference
EmptyStroke Properties
EmptyStroke Class See Also Send Feedback

The EmptyStroke type exposes the following members.

Properties

Name | Description
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
Width | Overridden. See Width. (Overrides Stroke..::.Width.)

See Also

EmptyStroke Class
PerpetuumSoft.Framework.Drawing Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
EmptyStroke..::.Width Property
EmptyStroke Class See Also Send Feedback
Overridden. See Width.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override double Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Double
Visual C++
public:
virtual property double Width {
    double get () override;
    void set (double value) override;
}

See Also

EmptyStroke Class
PerpetuumSoft.Framework.Drawing Namespace


Fill Class

[image]

.NET ModelKit Suite ClassReference
Fill Class
Members See Also Send Feedback
Represents base abstract class for all fill types.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract class Fill : Atom
Visual Basic (Declaration)
Public MustInherit Class Fill _
    Inherits Atom
Visual C++
public ref class Fill abstract : public Atom

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework..::.Atom
PerpetuumSoft.Framework.Drawing..::.Fill
PerpetuumSoft.Framework.Drawing..::.EmptyFill
PerpetuumSoft.Framework.Drawing..::.HatchFill
PerpetuumSoft.Framework.Drawing..::.LinearGradientFill
PerpetuumSoft.Framework.Drawing..::.MultiGradientFill
PerpetuumSoft.Framework.Drawing..::.SolidFill
PerpetuumSoft.Framework.Drawing..::.SphericalFill

See Also

Fill Members
PerpetuumSoft.Framework.Drawing Namespace


Fill Members

[image] [image]

.NET ModelKit Suite ClassReference
Fill Members
Fill Class Constructors Methods Properties See Also Send Feedback

The Fill type exposes the following members.

Constructors

Name | Description
Fill | Initializes a new instance of the Fill class

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Returns the copy of this object. (Inherited from Atom.)
CreateBrush | Returns a Brush object for the choosen fill type.
Equals | Overridden. See Equals(Object). (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Object..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetReplaceColor | Returns the substitute fill color for formats with limited color functionality.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsNullOrEmpty |
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
Empty | Defines a "null"-fill.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)

See Also

Fill Class
PerpetuumSoft.Framework.Drawing Namespace


Fill Constructor

[image]

.NET ModelKit Suite ClassReference
Fill Constructor
Fill Class See Also Send Feedback
Initializes a new instance of the Fill class

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected Fill()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
Fill()

See Also

Fill Class
PerpetuumSoft.Framework.Drawing Namespace


Fill Methods

[image] [image]

.NET ModelKit Suite ClassReference
Fill Methods
Fill Class See Also Send Feedback

The Fill type exposes the following members.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Returns the copy of this object. (Inherited from Atom.)
CreateBrush | Returns a Brush object for the choosen fill type.
Equals | Overridden. See Equals(Object). (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Object..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetReplaceColor | Returns the substitute fill color for formats with limited color functionality.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsNullOrEmpty |
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

Fill Class
PerpetuumSoft.Framework.Drawing Namespace


CreateBrush Method

[image]

.NET ModelKit Suite ClassReference
Fill..::.CreateBrush Method
Fill Class See Also Send Feedback
Returns a Brush object for the choosen fill type.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract Brush CreateBrush(
    VectorRectangle rect
)
Visual Basic (Declaration)
Public MustOverride Function CreateBrush ( _
    rect As VectorRectangle _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    VectorRectangle rect
) abstract

Parameters

rect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

Fill Class
PerpetuumSoft.Framework.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
Fill..::.Equals Method
Fill Class See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

Fill Class
PerpetuumSoft.Framework.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
Fill..::.GetHashCode Method
Fill Class See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

Fill Class
PerpetuumSoft.Framework.Drawing Namespace


GetReplaceColor Method

[image]

.NET ModelKit Suite ClassReference
Fill..::.GetReplaceColor Method
Fill Class See Also Send Feedback
Returns the substitute fill color for formats with limited color functionality.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract Color GetReplaceColor()
Visual Basic (Declaration)
Public MustOverride Function GetReplaceColor As Color
Visual C++
public:
virtual Color GetReplaceColor() abstract

See Also

Fill Class
PerpetuumSoft.Framework.Drawing Namespace


IsNullOrEmpty Method

[image]

.NET ModelKit Suite ClassReference
Fill..::.IsNullOrEmpty Method
Fill Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Fill.IsNullOrEmpty(PerpetuumSoft.Framework.Drawing.Fill)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static bool IsNullOrEmpty(
    Fill fill
)
Visual Basic (Declaration)
Public Shared Function IsNullOrEmpty ( _
    fill As Fill _
) As Boolean
Visual C++
public:
static bool IsNullOrEmpty(
    Fill^ fill
)

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill

See Also

Fill Class
PerpetuumSoft.Framework.Drawing Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
Fill..::.ToString Method
Fill Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Fill Class
PerpetuumSoft.Framework.Drawing Namespace


Fill Properties

[image] [image]

.NET ModelKit Suite ClassReference
Fill Properties
Fill Class See Also Send Feedback

The Fill type exposes the following members.

Properties

Name | Description
Empty | Defines a "null"-fill.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)

See Also

Fill Class
PerpetuumSoft.Framework.Drawing Namespace


Empty Property

[image]

.NET ModelKit Suite ClassReference
Fill..::.Empty Property
Fill Class See Also Send Feedback
Defines a "null"-fill.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Fill Empty { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Empty As Fill
Visual C++
public:
static property Fill^ Empty {
    Fill^ get ();
}

See Also

Fill Class
PerpetuumSoft.Framework.Drawing Namespace


Fill.Utilities Class

[image]

.NET ModelKit Suite ClassReference
Fill..::.Utilities Class
Fill Class Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Framework.Drawing.Fill.Utilities]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected class Utilities
Visual Basic (Declaration)
Protected Class Utilities
Visual C++
protected ref class Utilities

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Drawing..::.Fill..::.Utilities

See Also

Fill..::.Utilities Members
PerpetuumSoft.Framework.Drawing Namespace


Fill.Utilities Members

[image] [image]

.NET ModelKit Suite ClassReference
Fill..::.Utilities Members
Fill..::.Utilities Class Methods See Also Send Feedback

Represents base abstract class for all fill types.

The Fill..::.Utilities type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCenterPoint |
GetFillRectangle |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortColorsByPortion |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Fill..::.Utilities Class
PerpetuumSoft.Framework.Drawing Namespace


Fill.Utilities Methods

[image] [image]

.NET ModelKit Suite ClassReference
Fill..::.Utilities Methods
Fill..::.Utilities Class See Also Send Feedback

The Fill..::.Utilities type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCenterPoint |
GetFillRectangle |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortColorsByPortion |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Fill..::.Utilities Class
PerpetuumSoft.Framework.Drawing Namespace


GetCenterPoint Method

[image]

.NET ModelKit Suite ClassReference
Fill..::.Utilities..::.GetCenterPoint Method
Fill..::.Utilities Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Fill.Utilities.GetCenterPoint(PerpetuumSoft.Framework.Drawing.VectorRectangle,System.Double,System.Double)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Vector GetCenterPoint(
    VectorRectangle rect,
    double delta,
    double angle
)
Visual Basic (Declaration)
Public Shared Function GetCenterPoint ( _
    rect As VectorRectangle, _
    delta As Double, _
    angle As Double _
) As Vector
Visual C++
public:
static Vector GetCenterPoint(
    VectorRectangle rect,
    double delta,
    double angle
)

Parameters

rect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
delta
Type: System..::.Double
angle
Type: System..::.Double

See Also

Fill..::.Utilities Class
PerpetuumSoft.Framework.Drawing Namespace


GetFillRectangle Method

[image]

.NET ModelKit Suite ClassReference
Fill..::.Utilities..::.GetFillRectangle Method
Fill..::.Utilities Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Fill.Utilities.GetFillRectangle(PerpetuumSoft.Framework.Drawing.VectorRectangle,System.Double,System.Double)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static VectorRectangle GetFillRectangle(
    VectorRectangle rect,
    double delta,
    double angle
)
Visual Basic (Declaration)
Public Shared Function GetFillRectangle ( _
    rect As VectorRectangle, _
    delta As Double, _
    angle As Double _
) As VectorRectangle
Visual C++
public:
static VectorRectangle GetFillRectangle(
    VectorRectangle rect,
    double delta,
    double angle
)

Parameters

rect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
delta
Type: System..::.Double
angle
Type: System..::.Double

See Also

Fill..::.Utilities Class
PerpetuumSoft.Framework.Drawing Namespace


SortColorsByPortion Method

[image]

.NET ModelKit Suite ClassReference
Fill..::.Utilities..::.SortColorsByPortion Method
Fill..::.Utilities Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Fill.Utilities.SortColorsByPortion(PerpetuumSoft.Framework.Drawing.GradientColorCollection)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static void SortColorsByPortion(
    GradientColorCollection colors
)
Visual Basic (Declaration)
Public Shared Sub SortColorsByPortion ( _
    colors As GradientColorCollection _
)
Visual C++
public:
static void SortColorsByPortion(
    GradientColorCollection^ colors
)

Parameters

colors
Type: PerpetuumSoft.Framework.Drawing..::.GradientColorCollection

See Also

Fill..::.Utilities Class
PerpetuumSoft.Framework.Drawing Namespace


FontDescriptor Class

[image]

.NET ModelKit Suite ClassReference
FontDescriptor Class
Members See Also Send Feedback
Describes the Font object.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class FontDescriptor : IDisposable
Visual Basic (Declaration)
Public Class FontDescriptor _
    Implements IDisposable
Visual C++
public ref class FontDescriptor : IDisposable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Drawing..::.FontDescriptor

See Also

FontDescriptor Members
PerpetuumSoft.Framework.Drawing Namespace


FontDescriptor Members

[image] [image]

.NET ModelKit Suite ClassReference
FontDescriptor Members
FontDescriptor Class Constructors Methods Properties See Also Send Feedback

The FontDescriptor type exposes the following members.

Constructors

Name | Description
FontDescriptor | Overloaded.

Methods

Name | Description
Dispose | Implements Dispose()()().
Equals | Overridden. See Equals(Object). (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFont | Returns the Font object with setted parameters.
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bold | Gets or sets the value that indicates whether font object is bold.
FamilyName | Gets or sets a family name of font.
Italic | Gets or sets the value that indicates whether font object is italic.
Size | Gets or sets the size of font.
Strikeout | Gets or sets the strikeout mode of a string that is displayed with this font.
Underline | Gets or sets the value that indicates whether font object is underline.

See Also

FontDescriptor Class
PerpetuumSoft.Framework.Drawing Namespace


FontDescriptor Constructor

[image] [image]

.NET ModelKit Suite ClassReference
FontDescriptor Constructor
FontDescriptor Class See Also Send Feedback

Overload List

Name | Description
FontDescriptor()()() | Initializes the new instance of the FontDescriptor class with default parameters.
FontDescriptor(FontDescriptor) | Initializes a new instance of the FontDescriptor class.
FontDescriptor(Font) | Initializes a new instance of the FontDescriptor class.
FontDescriptor(String, Single) | Initializes the new instance of the FontDescriptor class by FontFamily name and size.
FontDescriptor(String, Single, FontStyleMode, FontStyleMode, FontStyleMode) | Initializes the new instance of the FontDescriptor class with specified parameters.
FontDescriptor(String, Single, FontStyleMode, FontStyleMode, FontStyleMode, FontStyleMode) | Initializes a new instance of the FontDescriptor class.

See Also

FontDescriptor Class
FontDescriptor Members
PerpetuumSoft.Framework.Drawing Namespace


FontDescriptor Constructor

[image]

.NET ModelKit Suite ClassReference
FontDescriptor Constructor
FontDescriptor Class See Also Send Feedback
Initializes the new instance of the FontDescriptor class with default parameters.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public FontDescriptor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FontDescriptor()

See Also

FontDescriptor Class
FontDescriptor Overload
PerpetuumSoft.Framework.Drawing Namespace


FontDescriptor Constructor (FontDescriptor)

[image]

.NET ModelKit Suite ClassReference
FontDescriptor Constructor (FontDescriptor)
FontDescriptor Class See Also Send Feedback
Initializes a new instance of the FontDescriptor class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public FontDescriptor(
    FontDescriptor fontDescriptor
)
Visual Basic (Declaration)
Public Sub New ( _
    fontDescriptor As FontDescriptor _
)
Visual C++
public:
FontDescriptor(
    FontDescriptor^ fontDescriptor
)

Parameters

fontDescriptor
Type: PerpetuumSoft.Framework.Drawing..::.FontDescriptor

See Also

FontDescriptor Class
FontDescriptor Overload
PerpetuumSoft.Framework.Drawing Namespace


FontDescriptor Constructor (Font)

[image]

.NET ModelKit Suite ClassReference
FontDescriptor Constructor (Font)
FontDescriptor Class See Also Send Feedback
Initializes a new instance of the FontDescriptor class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public FontDescriptor(
    Font font
)
Visual Basic (Declaration)
Public Sub New ( _
    font As Font _
)
Visual C++
public:
FontDescriptor(
    Font^ font
)

Parameters

font
Type: System.Drawing..::.Font

See Also

FontDescriptor Class
FontDescriptor Overload
PerpetuumSoft.Framework.Drawing Namespace


FontDescriptor Constructor (String, Single)

[image]

.NET ModelKit Suite ClassReference
FontDescriptor Constructor (String, Single)
FontDescriptor Class See Also Send Feedback
Initializes the new instance of the FontDescriptor class by FontFamily name and size.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public FontDescriptor(
    string familyName,
    float size
)
Visual Basic (Declaration)
Public Sub New ( _
    familyName As String, _
    size As Single _
)
Visual C++
public:
FontDescriptor(
    String^ familyName,
    float size
)

Parameters

familyName
Type: System..::.String
size
Type: System..::.Single

See Also

FontDescriptor Class
FontDescriptor Overload
PerpetuumSoft.Framework.Drawing Namespace


FontDescriptor Constructor (String, Single, FontStyleMode, FontStyleMode, FontStyleMode)

[image]

.NET ModelKit Suite ClassReference
FontDescriptor Constructor (String, Single, FontStyleMode, FontStyleMode, FontStyleMode)
FontDescriptor Class See Also Send Feedback
Initializes the new instance of the FontDescriptor class with specified parameters.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public FontDescriptor(
    string familyname,
    float size,
    FontStyleMode bold,
    FontStyleMode italic,
    FontStyleMode underline
)
Visual Basic (Declaration)
Public Sub New ( _
    familyname As String, _
    size As Single, _
    bold As FontStyleMode, _
    italic As FontStyleMode, _
    underline As FontStyleMode _
)
Visual C++
public:
FontDescriptor(
    String^ familyname,
    float size,
    FontStyleMode bold,
    FontStyleMode italic,
    FontStyleMode underline
)

Parameters

familyname
Type: System..::.String
size
Type: System..::.Single
bold
Type: PerpetuumSoft.Framework.Drawing..::.FontStyleMode
italic
Type: PerpetuumSoft.Framework.Drawing..::.FontStyleMode
underline
Type: PerpetuumSoft.Framework.Drawing..::.FontStyleMode

See Also

FontDescriptor Class
FontDescriptor Overload
PerpetuumSoft.Framework.Drawing Namespace


FontDescriptor Constructor (String, Single, FontStyleMode, FontStyleMode, FontStyleMode, FontStyleMode)

[image]

.NET ModelKit Suite ClassReference
FontDescriptor Constructor (String, Single, FontStyleMode, FontStyleMode, FontStyleMode, FontStyleMode)
FontDescriptor Class See Also Send Feedback
Initializes a new instance of the FontDescriptor class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public FontDescriptor(
    string familyName,
    float size,
    FontStyleMode bold,
    FontStyleMode italic,
    FontStyleMode underline,
    FontStyleMode strikeout
)
Visual Basic (Declaration)
Public Sub New ( _
    familyName As String, _
    size As Single, _
    bold As FontStyleMode, _
    italic As FontStyleMode, _
    underline As FontStyleMode, _
    strikeout As FontStyleMode _
)
Visual C++
public:
FontDescriptor(
    String^ familyName,
    float size,
    FontStyleMode bold,
    FontStyleMode italic,
    FontStyleMode underline,
    FontStyleMode strikeout
)

Parameters

familyName
Type: System..::.String
size
Type: System..::.Single
bold
Type: PerpetuumSoft.Framework.Drawing..::.FontStyleMode
italic
Type: PerpetuumSoft.Framework.Drawing..::.FontStyleMode
underline
Type: PerpetuumSoft.Framework.Drawing..::.FontStyleMode
strikeout
Type: PerpetuumSoft.Framework.Drawing..::.FontStyleMode

See Also

FontDescriptor Class
FontDescriptor Overload
PerpetuumSoft.Framework.Drawing Namespace


FontDescriptor Methods

[image] [image]

.NET ModelKit Suite ClassReference
FontDescriptor Methods
FontDescriptor Class See Also Send Feedback

The FontDescriptor type exposes the following members.

Methods

Name | Description
Dispose | Implements Dispose()()().
Equals | Overridden. See Equals(Object). (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFont | Returns the Font object with setted parameters.
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontDescriptor Class
PerpetuumSoft.Framework.Drawing Namespace


Dispose Method

[image]

.NET ModelKit Suite ClassReference
FontDescriptor..::.Dispose Method
FontDescriptor Class See Also Send Feedback
Implements Dispose()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

FontDescriptor Class
PerpetuumSoft.Framework.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
FontDescriptor..::.Equals Method
FontDescriptor Class See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

FontDescriptor Class
PerpetuumSoft.Framework.Drawing Namespace


GetFont Method

[image]

.NET ModelKit Suite ClassReference
FontDescriptor..::.GetFont Method
FontDescriptor Class See Also Send Feedback
Returns the Font object with setted parameters.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Font GetFont()
Visual Basic (Declaration)
Public Function GetFont As Font
Visual C++
public:
Font^ GetFont()

See Also

FontDescriptor Class
PerpetuumSoft.Framework.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
FontDescriptor..::.GetHashCode Method
FontDescriptor Class See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

FontDescriptor Class
PerpetuumSoft.Framework.Drawing Namespace


FontDescriptor Properties

[image] [image]

.NET ModelKit Suite ClassReference
FontDescriptor Properties
FontDescriptor Class See Also Send Feedback

The FontDescriptor type exposes the following members.

Properties

Name | Description
Bold | Gets or sets the value that indicates whether font object is bold.
FamilyName | Gets or sets a family name of font.
Italic | Gets or sets the value that indicates whether font object is italic.
Size | Gets or sets the size of font.
Strikeout | Gets or sets the strikeout mode of a string that is displayed with this font.
Underline | Gets or sets the value that indicates whether font object is underline.

See Also

FontDescriptor Class
PerpetuumSoft.Framework.Drawing Namespace


Bold Property

[image]

.NET ModelKit Suite ClassReference
FontDescriptor..::.Bold Property
FontDescriptor Class See Also Send Feedback
Gets or sets the value that indicates whether font object is bold.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public FontStyleMode Bold { get; set; }
Visual Basic (Declaration)
Public Property Bold As FontStyleMode
Visual C++
public:
property FontStyleMode Bold {
    FontStyleMode get ();
    void set (FontStyleMode value);
}

See Also

FontDescriptor Class
PerpetuumSoft.Framework.Drawing Namespace


FamilyName Property

[image]

.NET ModelKit Suite ClassReference
FontDescriptor..::.FamilyName Property
FontDescriptor Class See Also Send Feedback
Gets or sets a family name of font.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public string FamilyName { get; set; }
Visual Basic (Declaration)
Public Property FamilyName As String
Visual C++
public:
property String^ FamilyName {
    String^ get ();
    void set (String^ value);
}

See Also

FontDescriptor Class
PerpetuumSoft.Framework.Drawing Namespace


Italic Property

[image]

.NET ModelKit Suite ClassReference
FontDescriptor..::.Italic Property
FontDescriptor Class See Also Send Feedback
Gets or sets the value that indicates whether font object is italic.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public FontStyleMode Italic { get; set; }
Visual Basic (Declaration)
Public Property Italic As FontStyleMode
Visual C++
public:
property FontStyleMode Italic {
    FontStyleMode get ();
    void set (FontStyleMode value);
}

See Also

FontDescriptor Class
PerpetuumSoft.Framework.Drawing Namespace


Size Property

[image]

.NET ModelKit Suite ClassReference
FontDescriptor..::.Size Property
FontDescriptor Class See Also Send Feedback
Gets or sets the size of font.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Size { get; set; }
Visual Basic (Declaration)
Public Property Size As Double
Visual C++
public:
property double Size {
    double get ();
    void set (double value);
}

See Also

FontDescriptor Class
PerpetuumSoft.Framework.Drawing Namespace


Strikeout Property

[image]

.NET ModelKit Suite ClassReference
FontDescriptor..::.Strikeout Property
FontDescriptor Class See Also Send Feedback
Gets or sets the strikeout mode of a string that is displayed with this font.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public FontStyleMode Strikeout { get; set; }
Visual Basic (Declaration)
Public Property Strikeout As FontStyleMode
Visual C++
public:
property FontStyleMode Strikeout {
    FontStyleMode get ();
    void set (FontStyleMode value);
}

See Also

FontDescriptor Class
PerpetuumSoft.Framework.Drawing Namespace


Underline Property

[image]

.NET ModelKit Suite ClassReference
FontDescriptor..::.Underline Property
FontDescriptor Class See Also Send Feedback
Gets or sets the value that indicates whether font object is underline.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public FontStyleMode Underline { get; set; }
Visual Basic (Declaration)
Public Property Underline As FontStyleMode
Visual C++
public:
property FontStyleMode Underline {
    FontStyleMode get ();
    void set (FontStyleMode value);
}

See Also

FontDescriptor Class
PerpetuumSoft.Framework.Drawing Namespace


FontStyleMode Enumeration

[image]

.NET ModelKit Suite ClassReference
FontStyleMode Enumeration
See Also Send Feedback
Enumerates modes for font styles.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public enum FontStyleMode
Visual Basic (Declaration)
Public Enumeration FontStyleMode
Visual C++
public enum class FontStyleMode

Members

Member name | Description
Default | Default mode.
On | Style is enabled.
Off | Style is disabled.

See Also

PerpetuumSoft.Framework.Drawing Namespace


GradientColor Class

[image]

.NET ModelKit Suite ClassReference
GradientColor Class
Members See Also Send Feedback
Represents the gradient color, defined by Color structure and portion in the end fill.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class GradientColor
Visual Basic (Declaration)
Public Class GradientColor
Visual C++
public ref class GradientColor

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Drawing..::.GradientColor

See Also

GradientColor Members
PerpetuumSoft.Framework.Drawing Namespace


GradientColor Members

[image] [image]

.NET ModelKit Suite ClassReference
GradientColor Members
GradientColor Class Constructors Methods Properties See Also Send Feedback

The GradientColor type exposes the following members.

Constructors

Name | Description
GradientColor | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Color | Gets or sets gradient color.
Portion | Gets or sets the bound the current color is used up to.

See Also

GradientColor Class
PerpetuumSoft.Framework.Drawing Namespace


GradientColor Constructor

[image] [image]

.NET ModelKit Suite ClassReference
GradientColor Constructor
GradientColor Class See Also Send Feedback

Overload List

Name | Description
GradientColor()()() | Initializes a new instance of the GradientColor class.
GradientColor(Color, Double) | Initializes a new instance of the GradientColor class with specified parameters.

See Also

GradientColor Class
GradientColor Members
PerpetuumSoft.Framework.Drawing Namespace


GradientColor Constructor

[image]

.NET ModelKit Suite ClassReference
GradientColor Constructor
GradientColor Class See Also Send Feedback
Initializes a new instance of the GradientColor class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public GradientColor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GradientColor()

See Also

GradientColor Class
GradientColor Overload
PerpetuumSoft.Framework.Drawing Namespace


GradientColor Constructor (Color, Double)

[image]

.NET ModelKit Suite ClassReference
GradientColor Constructor (Color, Double)
GradientColor Class See Also Send Feedback
Initializes a new instance of the GradientColor class with specified parameters.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public GradientColor(
    Color color,
    double portion
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color, _
    portion As Double _
)
Visual C++
public:
GradientColor(
    Color color,
    double portion
)

Parameters

color
Type: System.Drawing..::.Color
portion
Type: System..::.Double

See Also

GradientColor Class
GradientColor Overload
PerpetuumSoft.Framework.Drawing Namespace


GradientColor Methods

[image] [image]

.NET ModelKit Suite ClassReference
GradientColor Methods
GradientColor Class See Also Send Feedback

The GradientColor type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GradientColor Class
PerpetuumSoft.Framework.Drawing Namespace


GradientColor Properties

[image] [image]

.NET ModelKit Suite ClassReference
GradientColor Properties
GradientColor Class See Also Send Feedback

The GradientColor type exposes the following members.

Properties

Name | Description
Color | Gets or sets gradient color.
Portion | Gets or sets the bound the current color is used up to.

See Also

GradientColor Class
PerpetuumSoft.Framework.Drawing Namespace


Color Property

[image]

.NET ModelKit Suite ClassReference
GradientColor..::.Color Property
GradientColor Class See Also Send Feedback
Gets or sets gradient color.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

GradientColor Class
PerpetuumSoft.Framework.Drawing Namespace


Portion Property

[image]

.NET ModelKit Suite ClassReference
GradientColor..::.Portion Property
GradientColor Class See Also Send Feedback
Gets or sets the bound the current color is used up to.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Portion { get; set; }
Visual Basic (Declaration)
Public Property Portion As Double
Visual C++
public:
property double Portion {
    double get ();
    void set (double value);
}

See Also

GradientColor Class
PerpetuumSoft.Framework.Drawing Namespace


GradientColorCollection Class

[image]

.NET ModelKit Suite ClassReference
GradientColorCollection Class
Members See Also Send Feedback
Represents the collection of gradient colors.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class GradientColorCollection : CollectionBase
Visual Basic (Declaration)
Public Class GradientColorCollection _
    Inherits CollectionBase
Visual C++
public ref class GradientColorCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Framework.Drawing..::.GradientColorCollection

See Also

GradientColorCollection Members
PerpetuumSoft.Framework.Drawing Namespace


GradientColorCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
GradientColorCollection Members
GradientColorCollection Class Constructors Methods Properties Events See Also Send Feedback

The GradientColorCollection type exposes the following members.

Constructors

Name | Description
GradientColorCollection | Initializes a new instance of the GradientColorCollection class.

Methods

Name | Description
Add | Adds the gradient color to the collection.
AddRange |
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether a gradient color is in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded. Returns the zero-based index of the first gradient color occurrence in the collection or in a portion of it.
Insert | Inserts the gradient color into the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new gradient color into the collection instance. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new gradient color into the collection instance. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing the gradient color from the collection instance. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Overrides CollectionBase..::.OnValidate(Object).)
Remove | Removes the first occurrence of a gradient color from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the gradient color at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

Name | Description
CollectionChanged | Occurs after the collection has been changed.

See Also

GradientColorCollection Class
PerpetuumSoft.Framework.Drawing Namespace


GradientColorCollection Constructor

[image]

.NET ModelKit Suite ClassReference
GradientColorCollection Constructor
GradientColorCollection Class See Also Send Feedback
Initializes a new instance of the GradientColorCollection class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public GradientColorCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GradientColorCollection()

See Also

GradientColorCollection Class
PerpetuumSoft.Framework.Drawing Namespace


GradientColorCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
GradientColorCollection Methods
GradientColorCollection Class See Also Send Feedback

The GradientColorCollection type exposes the following members.

Methods

Name | Description
Add | Adds the gradient color to the collection.
AddRange |
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether a gradient color is in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded. Returns the zero-based index of the first gradient color occurrence in the collection or in a portion of it.
Insert | Inserts the gradient color into the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new gradient color into the collection instance. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new gradient color into the collection instance. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing the gradient color from the collection instance. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Overrides CollectionBase..::.OnValidate(Object).)
Remove | Removes the first occurrence of a gradient color from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GradientColorCollection Class
PerpetuumSoft.Framework.Drawing Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
GradientColorCollection..::.Add Method
GradientColorCollection Class See Also Send Feedback
Adds the gradient color to the collection.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public GradientColor Add(
    GradientColor value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As GradientColor _
) As GradientColor
Visual C++
public:
GradientColor^ Add(
    GradientColor^ value
)

Parameters

value
Type: PerpetuumSoft.Framework.Drawing..::.GradientColor

See Also

GradientColorCollection Class
PerpetuumSoft.Framework.Drawing Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
GradientColorCollection..::.AddRange Method
GradientColorCollection Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.GradientColorCollection.AddRange(PerpetuumSoft.Framework.Drawing.GradientColor[])]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    GradientColor[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As GradientColor() _
)
Visual C++
public:
void AddRange(
    array<GradientColor^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Framework.Drawing..::.GradientColor >[]()[]

See Also

GradientColorCollection Class
PerpetuumSoft.Framework.Drawing Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
GradientColorCollection..::.Contains Method
GradientColorCollection Class See Also Send Feedback
Determines whether a gradient color is in the collection.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    GradientColor value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As GradientColor _
) As Boolean
Visual C++
public:
bool Contains(
    GradientColor^ value
)

Parameters

value
Type: PerpetuumSoft.Framework.Drawing..::.GradientColor

See Also

GradientColorCollection Class
PerpetuumSoft.Framework.Drawing Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
GradientColorCollection..::.IndexOf Method
GradientColorCollection Class See Also Send Feedback
Overloaded. Returns the zero-based index of the first gradient color occurrence in the collection or in a portion of it.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    GradientColor value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As GradientColor _
) As Integer
Visual C++
public:
int IndexOf(
    GradientColor^ value
)

Parameters

value
Type: PerpetuumSoft.Framework.Drawing..::.GradientColor

See Also

GradientColorCollection Class
PerpetuumSoft.Framework.Drawing Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
GradientColorCollection..::.Insert Method
GradientColorCollection Class See Also Send Feedback
Inserts the gradient color into the collection at the specified index.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    GradientColor value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As GradientColor _
)
Visual C++
public:
void Insert(
    int index,
    GradientColor^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Framework.Drawing..::.GradientColor

See Also

GradientColorCollection Class
PerpetuumSoft.Framework.Drawing Namespace


OnInsert Method

[image]

.NET ModelKit Suite ClassReference
GradientColorCollection..::.OnInsert Method
GradientColorCollection Class See Also Send Feedback
Performs additional custom processes before inserting a new gradient color into the collection instance.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsert(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsert ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsert(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

GradientColorCollection Class
PerpetuumSoft.Framework.Drawing Namespace


OnInsertComplete Method

[image]

.NET ModelKit Suite ClassReference
GradientColorCollection..::.OnInsertComplete Method
GradientColorCollection Class See Also Send Feedback
Performs additional custom processes after inserting a new gradient color into the collection instance.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsertComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsertComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsertComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

GradientColorCollection Class
PerpetuumSoft.Framework.Drawing Namespace


OnRemoveComplete Method

[image]

.NET ModelKit Suite ClassReference
GradientColorCollection..::.OnRemoveComplete Method
GradientColorCollection Class See Also Send Feedback
Performs additional custom processes after removing the gradient color from the collection instance.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnRemoveComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemoveComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemoveComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

GradientColorCollection Class
PerpetuumSoft.Framework.Drawing Namespace


OnValidate Method

[image]

.NET ModelKit Suite ClassReference
GradientColorCollection..::.OnValidate Method
GradientColorCollection Class See Also Send Feedback
Performs additional custom processes when validating a value.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnValidate(
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnValidate ( _
    value As Object _
)
Visual C++
protected:
virtual void OnValidate(
    Object^ value
) override

Parameters

value
Type: System..::.Object

See Also

GradientColorCollection Class
PerpetuumSoft.Framework.Drawing Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
GradientColorCollection..::.Remove Method
GradientColorCollection Class See Also Send Feedback
Removes the first occurrence of a gradient color from the collection.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    GradientColor value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As GradientColor _
)
Visual C++
public:
void Remove(
    GradientColor^ value
)

Parameters

value
Type: PerpetuumSoft.Framework.Drawing..::.GradientColor

See Also

GradientColorCollection Class
PerpetuumSoft.Framework.Drawing Namespace


GradientColorCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
GradientColorCollection Properties
GradientColorCollection Class See Also Send Feedback

The GradientColorCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the gradient color at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

GradientColorCollection Class
PerpetuumSoft.Framework.Drawing Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
GradientColorCollection..::.Item Property
GradientColorCollection Class See Also Send Feedback
Gets or sets the gradient color at the specified index.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public GradientColor this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As GradientColor
Visual C++
public:
property GradientColor^ default[int index] {
    GradientColor^ get (int index);
    void set (int index, GradientColor^ value);
}

Parameters

index
Type: System..::.Int32

See Also

GradientColorCollection Class
PerpetuumSoft.Framework.Drawing Namespace


GradientColorCollection Events

[image] [image]

.NET ModelKit Suite ClassReference
GradientColorCollection Events
GradientColorCollection Class See Also Send Feedback

The GradientColorCollection type exposes the following members.

Events

Name | Description
CollectionChanged | Occurs after the collection has been changed.

See Also

GradientColorCollection Class
PerpetuumSoft.Framework.Drawing Namespace


CollectionChanged Event

[image]

.NET ModelKit Suite ClassReference
GradientColorCollection..::.CollectionChanged Event
GradientColorCollection Class See Also Send Feedback
Occurs after the collection has been changed.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public event GradientColorCollection..::.CollectionChangedEventHandler CollectionChanged
Visual Basic (Declaration)
Public Event CollectionChanged As GradientColorCollection..::.CollectionChangedEventHandler
Visual C++
public:
 event GradientColorCollection..::.CollectionChangedEventHandler^ CollectionChanged {
    void add (GradientColorCollection..::.CollectionChangedEventHandler^ value);
    void remove (GradientColorCollection..::.CollectionChangedEventHandler^ value);
}

See Also

GradientColorCollection Class
PerpetuumSoft.Framework.Drawing Namespace


GradientColorCollection.CollectionChangedEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
GradientColorCollection..::.CollectionChangedEventHandler Delegate
GradientColorCollection Class See Also Send Feedback
Represents the method that will handle the CollectionChanged.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public delegate void CollectionChangedEventHandler(
    GradientColor gradientColor
)
Visual Basic (Declaration)
Public Delegate Sub CollectionChangedEventHandler ( _
    gradientColor As GradientColor _
)
Visual C++
public delegate void CollectionChangedEventHandler(
    GradientColor^ gradientColor
)

Parameters

gradientColor
Type: PerpetuumSoft.Framework.Drawing..::.GradientColor

See Also

PerpetuumSoft.Framework.Drawing Namespace


GraphicStream Class

[image]

.NET ModelKit Suite ClassReference
GraphicStream Class
Members See Also Send Feedback
Encapsulates drawing surface.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract class GraphicStream
Visual Basic (Declaration)
Public MustInherit Class GraphicStream
Visual C++
public ref class GraphicStream abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Drawing..::.GraphicStream

See Also

GraphicStream Members
PerpetuumSoft.Framework.Drawing Namespace


GraphicStream Members

[image] [image]

.NET ModelKit Suite ClassReference
GraphicStream Members
GraphicStream Class Constructors Methods See Also Send Feedback

The GraphicStream type exposes the following members.

Constructors

Name | Description
GraphicStream | Initializes a new instance of the GraphicStream class

Methods

Name | Description
BeginGroup | Saves a graphics container with the current state of this Graphics object and opens and uses a new graphics container.
ClipPath | Sets the clipping assigned by the Path.
ClipRectangle | Limits the drawing region of this GraphicStream object.
Close | Close the graphics stream.
DrawArc | Overloaded.
DrawCircle | Overloaded.
DrawEllipse | Overloaded.
DrawGraphicsPath | Overloaded.
DrawHtmlText | Draws formatted text.
DrawImage | Overloaded.
DrawLine | Overloaded.
DrawPie | Overloaded.
DrawPolygon |
DrawRectangle | Overloaded.
DrawText | Overloaded.
EndGroup | Closes the current graphics container and restores the state of this Graphics object to the state saved by the call to the BeginGroup()()() method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FillCircle | Overloaded.
FillEllipse | Overloaded.
FillPath | Overloaded.
FillPie | Overloaded.
FillPolygon | Overloaded.
FillRectangle | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Flush | Flushes any underlying stream, performs all the operations required to complete the operation.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetSmoothMode | Sets the smooth graphics settings.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Transform | Applies the given transform matrix for current graphics object.

See Also

GraphicStream Class
PerpetuumSoft.Framework.Drawing Namespace


GraphicStream Constructor

[image]

.NET ModelKit Suite ClassReference
GraphicStream Constructor
GraphicStream Class See Also Send Feedback
Initializes a new instance of the GraphicStream class

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected GraphicStream()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
GraphicStream()

See Also

GraphicStream Class
PerpetuumSoft.Framework.Drawing Namespace


GraphicStream Methods

[image] [image]

.NET ModelKit Suite ClassReference
GraphicStream Methods
GraphicStream Class See Also Send Feedback

The GraphicStream type exposes the following members.

Methods

Name | Description
BeginGroup | Saves a graphics container with the current state of this Graphics object and opens and uses a new graphics container.
ClipPath | Sets the clipping assigned by the Path.
ClipRectangle | Limits the drawing region of this GraphicStream object.
Close | Close the graphics stream.
DrawArc | Overloaded.
DrawCircle | Overloaded.
DrawEllipse | Overloaded.
DrawGraphicsPath | Overloaded.
DrawHtmlText | Draws formatted text.
DrawImage | Overloaded.
DrawLine | Overloaded.
DrawPie | Overloaded.
DrawPolygon |
DrawRectangle | Overloaded.
DrawText | Overloaded.
EndGroup | Closes the current graphics container and restores the state of this Graphics object to the state saved by the call to the BeginGroup()()() method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FillCircle | Overloaded.
FillEllipse | Overloaded.
FillPath | Overloaded.
FillPie | Overloaded.
FillPolygon | Overloaded.
FillRectangle | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Flush | Flushes any underlying stream, performs all the operations required to complete the operation.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetSmoothMode | Sets the smooth graphics settings.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Transform | Applies the given transform matrix for current graphics object.

See Also

GraphicStream Class
PerpetuumSoft.Framework.Drawing Namespace


BeginGroup Method

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.BeginGroup Method
GraphicStream Class See Also Send Feedback
Saves a graphics container with the current state of this Graphics object and opens and uses a new graphics container.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void BeginGroup()
Visual Basic (Declaration)
Public MustOverride Sub BeginGroup
Visual C++
public:
virtual void BeginGroup() abstract

See Also

GraphicStream Class
PerpetuumSoft.Framework.Drawing Namespace


ClipPath Method

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.ClipPath Method
GraphicStream Class See Also Send Feedback
Sets the clipping assigned by the Path.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public virtual void ClipPath(
    GraphicsPath path
)
Visual Basic (Declaration)
Public Overridable Sub ClipPath ( _
    path As GraphicsPath _
)
Visual C++
public:
virtual void ClipPath(
    GraphicsPath^ path
)

Parameters

path
Type: System.Drawing.Drawing2D..::.GraphicsPath

See Also

GraphicStream Class
PerpetuumSoft.Framework.Drawing Namespace


ClipRectangle Method

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.ClipRectangle Method
GraphicStream Class See Also Send Feedback
Limits the drawing region of this GraphicStream object.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void ClipRectangle(
    VectorRectangle rectangle
)
Visual Basic (Declaration)
Public MustOverride Sub ClipRectangle ( _
    rectangle As VectorRectangle _
)
Visual C++
public:
virtual void ClipRectangle(
    VectorRectangle rectangle
) abstract

Parameters

rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

GraphicStream Class
PerpetuumSoft.Framework.Drawing Namespace


Close Method

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.Close Method
GraphicStream Class See Also Send Feedback
Close the graphics stream.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void Close()
Visual Basic (Declaration)
Public MustOverride Sub Close
Visual C++
public:
virtual void Close() abstract

See Also

GraphicStream Class
PerpetuumSoft.Framework.Drawing Namespace


DrawArc Method

[image] [image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawArc Method
GraphicStream Class See Also Send Feedback

Overload List

Name | Description
DrawArc(Stroke, VectorRectangle, Double, Double) | Draws the arc representing a portion of an ellipse specified by a VectorRectangle structure.
DrawArc(Stroke, Vector, Vector, Double, Double) | Draws the arc representing a portion of an ellipse specified by two Vector structures.
DrawArc(Stroke, Double, Double, Double, Double, Double, Double) | Draws the arc representing a portion of an ellipse specified by a pair of coordinates, width and height.

See Also

GraphicStream Class
GraphicStream Members
PerpetuumSoft.Framework.Drawing Namespace


DrawArc Method (Stroke, VectorRectangle, Double, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawArc Method (Stroke, VectorRectangle, Double, Double)
GraphicStream Class See Also Send Feedback
Draws the arc representing a portion of an ellipse specified by a VectorRectangle structure.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawArc(
    Stroke stroke,
    VectorRectangle rect,
    double startAngle,
    double sweepAngle
)
Visual Basic (Declaration)
Public MustOverride Sub DrawArc ( _
    stroke As Stroke, _
    rect As VectorRectangle, _
    startAngle As Double, _
    sweepAngle As Double _
)
Visual C++
public:
virtual void DrawArc(
    Stroke^ stroke,
    VectorRectangle rect,
    double startAngle,
    double sweepAngle
) abstract

Parameters

stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
rect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
startAngle
Type: System..::.Double
sweepAngle
Type: System..::.Double

See Also

GraphicStream Class
DrawArc Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawArc Method (Stroke, Vector, Vector, Double, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawArc Method (Stroke, Vector, Vector, Double, Double)
GraphicStream Class See Also Send Feedback
Draws the arc representing a portion of an ellipse specified by two Vector structures.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawArc(
    Stroke stroke,
    Vector location,
    Vector size,
    double startAngle,
    double sweepAngle
)
Visual Basic (Declaration)
Public Sub DrawArc ( _
    stroke As Stroke, _
    location As Vector, _
    size As Vector, _
    startAngle As Double, _
    sweepAngle As Double _
)
Visual C++
public:
void DrawArc(
    Stroke^ stroke,
    Vector location,
    Vector size,
    double startAngle,
    double sweepAngle
)

Parameters

stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
location
Type: PerpetuumSoft.Framework.Drawing..::.Vector
size
Type: PerpetuumSoft.Framework.Drawing..::.Vector
startAngle
Type: System..::.Double
sweepAngle
Type: System..::.Double

See Also

GraphicStream Class
DrawArc Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawArc Method (Stroke, Double, Double, Double, Double, Double, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawArc Method (Stroke, Double, Double, Double, Double, Double, Double)
GraphicStream Class See Also Send Feedback
Draws the arc representing a portion of an ellipse specified by a pair of coordinates, width and height.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawArc(
    Stroke stroke,
    double x,
    double y,
    double width,
    double height,
    double startAngle,
    double sweepAngle
)
Visual Basic (Declaration)
Public Sub DrawArc ( _
    stroke As Stroke, _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    startAngle As Double, _
    sweepAngle As Double _
)
Visual C++
public:
void DrawArc(
    Stroke^ stroke,
    double x,
    double y,
    double width,
    double height,
    double startAngle,
    double sweepAngle
)

Parameters

stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
x
Type: System..::.Double
y
Type: System..::.Double
width
Type: System..::.Double
height
Type: System..::.Double
startAngle
Type: System..::.Double
sweepAngle
Type: System..::.Double

See Also

GraphicStream Class
DrawArc Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawCircle Method

[image] [image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawCircle Method
GraphicStream Class See Also Send Feedback

Overload List

Name | Description
DrawCircle(Stroke, Vector, Double) | Draws the interior of the circle defined by the Stroke object, center point specified by the Vector structure and the given radius.
DrawCircle(Color, Vector, Double) | Draws the interior of the circle defined by the Color stroke, center point specified by the Vector structure and the given radius.

See Also

GraphicStream Class
GraphicStream Members
PerpetuumSoft.Framework.Drawing Namespace


DrawCircle Method (Stroke, Vector, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawCircle Method (Stroke, Vector, Double)
GraphicStream Class See Also Send Feedback
Draws the interior of the circle defined by the Stroke object, center point specified by the Vector structure and the given radius.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawCircle(
    Stroke stroke,
    Vector center,
    double radius
)
Visual Basic (Declaration)
Public MustOverride Sub DrawCircle ( _
    stroke As Stroke, _
    center As Vector, _
    radius As Double _
)
Visual C++
public:
virtual void DrawCircle(
    Stroke^ stroke,
    Vector center,
    double radius
) abstract

Parameters

stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
center
Type: PerpetuumSoft.Framework.Drawing..::.Vector
radius
Type: System..::.Double

See Also

GraphicStream Class
DrawCircle Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawCircle Method (Color, Vector, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawCircle Method (Color, Vector, Double)
GraphicStream Class See Also Send Feedback
Draws the interior of the circle defined by the Color stroke, center point specified by the Vector structure and the given radius.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawCircle(
    Color color,
    Vector center,
    double radius
)
Visual Basic (Declaration)
Public Sub DrawCircle ( _
    color As Color, _
    center As Vector, _
    radius As Double _
)
Visual C++
public:
void DrawCircle(
    Color color,
    Vector center,
    double radius
)

Parameters

color
Type: System.Drawing..::.Color
center
Type: PerpetuumSoft.Framework.Drawing..::.Vector
radius
Type: System..::.Double

See Also

GraphicStream Class
DrawCircle Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawEllipse Method

[image] [image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawEllipse Method
GraphicStream Class See Also Send Feedback

Overload List

Name | Description
DrawEllipse(Stroke, VectorRectangle) | Draws the interior of an ellipse defined by the Stroke object and bounding rectangle specified by the VectorRectangle structure.
DrawEllipse(Color, VectorRectangle) | Draws the interior of an ellipse defined by the Color structure and bounding rectangle specified by the VectorRectangle structure.

See Also

GraphicStream Class
GraphicStream Members
PerpetuumSoft.Framework.Drawing Namespace


DrawEllipse Method (Stroke, VectorRectangle)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawEllipse Method (Stroke, VectorRectangle)
GraphicStream Class See Also Send Feedback
Draws the interior of an ellipse defined by the Stroke object and bounding rectangle specified by the VectorRectangle structure.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawEllipse(
    Stroke stroke,
    VectorRectangle rectangle
)
Visual Basic (Declaration)
Public MustOverride Sub DrawEllipse ( _
    stroke As Stroke, _
    rectangle As VectorRectangle _
)
Visual C++
public:
virtual void DrawEllipse(
    Stroke^ stroke,
    VectorRectangle rectangle
) abstract

Parameters

stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

GraphicStream Class
DrawEllipse Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawEllipse Method (Color, VectorRectangle)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawEllipse Method (Color, VectorRectangle)
GraphicStream Class See Also Send Feedback
Draws the interior of an ellipse defined by the Color structure and bounding rectangle specified by the VectorRectangle structure.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawEllipse(
    Color color,
    VectorRectangle rectangle
)
Visual Basic (Declaration)
Public Sub DrawEllipse ( _
    color As Color, _
    rectangle As VectorRectangle _
)
Visual C++
public:
void DrawEllipse(
    Color color,
    VectorRectangle rectangle
)

Parameters

color
Type: System.Drawing..::.Color
rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

GraphicStream Class
DrawEllipse Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawGraphicsPath Method

[image] [image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawGraphicsPath Method
GraphicStream Class See Also Send Feedback

Overload List

Name | Description
DrawGraphicsPath(Stroke, GraphicsPath) | Draws the interior of the GraphicsPath object.
DrawGraphicsPath(Color, GraphicsPath) | Draws the interior of the GraphicsPath object.

See Also

GraphicStream Class
GraphicStream Members
PerpetuumSoft.Framework.Drawing Namespace


DrawGraphicsPath Method (Stroke, GraphicsPath)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawGraphicsPath Method (Stroke, GraphicsPath)
GraphicStream Class See Also Send Feedback
Draws the interior of the GraphicsPath object.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawGraphicsPath(
    Stroke stroke,
    GraphicsPath path
)
Visual Basic (Declaration)
Public MustOverride Sub DrawGraphicsPath ( _
    stroke As Stroke, _
    path As GraphicsPath _
)
Visual C++
public:
virtual void DrawGraphicsPath(
    Stroke^ stroke,
    GraphicsPath^ path
) abstract

Parameters

stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
path
Type: System.Drawing.Drawing2D..::.GraphicsPath

See Also

GraphicStream Class
DrawGraphicsPath Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawGraphicsPath Method (Color, GraphicsPath)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawGraphicsPath Method (Color, GraphicsPath)
GraphicStream Class See Also Send Feedback
Draws the interior of the GraphicsPath object.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawGraphicsPath(
    Color color,
    GraphicsPath path
)
Visual Basic (Declaration)
Public Sub DrawGraphicsPath ( _
    color As Color, _
    path As GraphicsPath _
)
Visual C++
public:
void DrawGraphicsPath(
    Color color,
    GraphicsPath^ path
)

Parameters

color
Type: System.Drawing..::.Color
path
Type: System.Drawing.Drawing2D..::.GraphicsPath

See Also

GraphicStream Class
DrawGraphicsPath Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawHtmlText Method

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawHtmlText Method
GraphicStream Class See Also Send Feedback
Draws formatted text.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawHtmlText(
    VectorRectangle layoutRect,
    FormattedText formattedText
)
Visual Basic (Declaration)
Public MustOverride Sub DrawHtmlText ( _
    layoutRect As VectorRectangle, _
    formattedText As FormattedText _
)
Visual C++
public:
virtual void DrawHtmlText(
    VectorRectangle layoutRect,
    FormattedText^ formattedText
) abstract

Parameters

layoutRect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
formattedText
Type: FormattedText

See Also

GraphicStream Class
PerpetuumSoft.Framework.Drawing Namespace


DrawImage Method

[image] [image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawImage Method
GraphicStream Class See Also Send Feedback

Overload List

Name | Description
DrawImage(Image, Vector) | Draws the specified Image object, using its original physical size, at the specified location.
DrawImage(Image, VectorRectangle) | Draws the specified Image object at the specified location and with the specified size.
DrawImage(Image, Double, Double) | Draws the specified image, using its original physical size, at the location specified by a coordinate pair.
DrawImage(Image, Vector, VectorRectangle, GraphicsUnit) | Draws the specified portion of the specified Image object at the specified location and with the specified size.
DrawImage(Image, VectorRectangle, VectorRectangle, GraphicsUnit) | Draws the specified portion of the specified Image object at the specified location and with the specified size.
DrawImage(Image, Double, Double, VectorRectangle, GraphicsUnit) | Draws a portion of an image at a specified location.
DrawImage(Image, Double, Double, Double, Double) | Draws the specified Image object at the specified location and with the specified size.

See Also

GraphicStream Class
GraphicStream Members
PerpetuumSoft.Framework.Drawing Namespace


DrawImage Method (Image, Vector)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawImage Method (Image, Vector)
GraphicStream Class See Also Send Feedback
Draws the specified Image object, using its original physical size, at the specified location.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawImage(
    Image image,
    Vector location
)
Visual Basic (Declaration)
Public Sub DrawImage ( _
    image As Image, _
    location As Vector _
)
Visual C++
public:
void DrawImage(
    Image^ image,
    Vector location
)

Parameters

image
Type: System.Drawing..::.Image
location
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

GraphicStream Class
DrawImage Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawImage Method (Image, VectorRectangle)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawImage Method (Image, VectorRectangle)
GraphicStream Class See Also Send Feedback
Draws the specified Image object at the specified location and with the specified size.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawImage(
    Image image,
    VectorRectangle destRect
)
Visual Basic (Declaration)
Public Sub DrawImage ( _
    image As Image, _
    destRect As VectorRectangle _
)
Visual C++
public:
void DrawImage(
    Image^ image,
    VectorRectangle destRect
)

Parameters

image
Type: System.Drawing..::.Image
destRect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

GraphicStream Class
DrawImage Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawImage Method (Image, Double, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawImage Method (Image, Double, Double)
GraphicStream Class See Also Send Feedback
Draws the specified image, using its original physical size, at the location specified by a coordinate pair.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawImage(
    Image image,
    double x,
    double y
)
Visual Basic (Declaration)
Public Sub DrawImage ( _
    image As Image, _
    x As Double, _
    y As Double _
)
Visual C++
public:
void DrawImage(
    Image^ image,
    double x,
    double y
)

Parameters

image
Type: System.Drawing..::.Image
x
Type: System..::.Double
y
Type: System..::.Double

See Also

GraphicStream Class
DrawImage Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawImage Method (Image, Vector, VectorRectangle, GraphicsUnit)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawImage Method (Image, Vector, VectorRectangle, GraphicsUnit)
GraphicStream Class See Also Send Feedback
Draws the specified portion of the specified Image object at the specified location and with the specified size.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawImage(
    Image image,
    Vector location,
    VectorRectangle srcRect,
    GraphicsUnit srcUnit
)
Visual Basic (Declaration)
Public Sub DrawImage ( _
    image As Image, _
    location As Vector, _
    srcRect As VectorRectangle, _
    srcUnit As GraphicsUnit _
)
Visual C++
public:
void DrawImage(
    Image^ image,
    Vector location,
    VectorRectangle srcRect,
    GraphicsUnit srcUnit
)

Parameters

image
Type: System.Drawing..::.Image
location
Type: PerpetuumSoft.Framework.Drawing..::.Vector
srcRect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
srcUnit
Type: System.Drawing..::.GraphicsUnit

See Also

GraphicStream Class
DrawImage Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawImage Method (Image, VectorRectangle, VectorRectangle, GraphicsUnit)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawImage Method (Image, VectorRectangle, VectorRectangle, GraphicsUnit)
GraphicStream Class See Also Send Feedback
Draws the specified portion of the specified Image object at the specified location and with the specified size.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawImage(
    Image image,
    VectorRectangle destRect,
    VectorRectangle srcRect,
    GraphicsUnit srcUnit
)
Visual Basic (Declaration)
Public MustOverride Sub DrawImage ( _
    image As Image, _
    destRect As VectorRectangle, _
    srcRect As VectorRectangle, _
    srcUnit As GraphicsUnit _
)
Visual C++
public:
virtual void DrawImage(
    Image^ image,
    VectorRectangle destRect,
    VectorRectangle srcRect,
    GraphicsUnit srcUnit
) abstract

Parameters

image
Type: System.Drawing..::.Image
destRect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
srcRect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
srcUnit
Type: System.Drawing..::.GraphicsUnit

See Also

GraphicStream Class
DrawImage Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawImage Method (Image, Double, Double, VectorRectangle, GraphicsUnit)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawImage Method (Image, Double, Double, VectorRectangle, GraphicsUnit)
GraphicStream Class See Also Send Feedback
Draws a portion of an image at a specified location.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawImage(
    Image image,
    double x,
    double y,
    VectorRectangle srcRect,
    GraphicsUnit srcUnit
)
Visual Basic (Declaration)
Public Sub DrawImage ( _
    image As Image, _
    x As Double, _
    y As Double, _
    srcRect As VectorRectangle, _
    srcUnit As GraphicsUnit _
)
Visual C++
public:
void DrawImage(
    Image^ image,
    double x,
    double y,
    VectorRectangle srcRect,
    GraphicsUnit srcUnit
)

Parameters

image
Type: System.Drawing..::.Image
x
Type: System..::.Double
y
Type: System..::.Double
srcRect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
srcUnit
Type: System.Drawing..::.GraphicsUnit

See Also

GraphicStream Class
DrawImage Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawImage Method (Image, Double, Double, Double, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawImage Method (Image, Double, Double, Double, Double)
GraphicStream Class See Also Send Feedback
Draws the specified Image object at the specified location and with the specified size.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawImage(
    Image image,
    double x,
    double y,
    double width,
    double height
)
Visual Basic (Declaration)
Public Sub DrawImage ( _
    image As Image, _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double _
)
Visual C++
public:
void DrawImage(
    Image^ image,
    double x,
    double y,
    double width,
    double height
)

Parameters

image
Type: System.Drawing..::.Image
x
Type: System..::.Double
y
Type: System..::.Double
width
Type: System..::.Double
height
Type: System..::.Double

See Also

GraphicStream Class
DrawImage Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawLine Method

[image] [image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawLine Method
GraphicStream Class See Also Send Feedback

Overload List

Name | Description
DrawLine(Stroke, array<Vector>[]()[]) |
DrawLine(Stroke, Vector, Vector) | Draws a line connecting two points defined by Vector structures.
DrawLine(Color, Vector, Vector) | Draws a line connecting two points defined by Vector structures.
DrawLine(Color, Double, Vector, Vector) | Draws a line.

See Also

GraphicStream Class
GraphicStream Members
PerpetuumSoft.Framework.Drawing Namespace


DrawLine Method (Stroke, Vector[])

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawLine Method (Stroke, array<Vector>[]()[])
GraphicStream Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.GraphicStream.DrawLine(PerpetuumSoft.Framework.Drawing.Stroke,PerpetuumSoft.Framework.Drawing.Vector[])]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawLine(
    Stroke stroke,
    Vector[] points
)
Visual Basic (Declaration)
Public MustOverride Sub DrawLine ( _
    stroke As Stroke, _
    points As Vector() _
)
Visual C++
public:
virtual void DrawLine(
    Stroke^ stroke,
    array<Vector>^ points
) abstract

Parameters

stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
points
Type: array< PerpetuumSoft.Framework.Drawing..::.Vector >[]()[]

See Also

GraphicStream Class
DrawLine Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawLine Method (Stroke, Vector, Vector)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawLine Method (Stroke, Vector, Vector)
GraphicStream Class See Also Send Feedback
Draws a line connecting two points defined by Vector structures.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawLine(
    Stroke stroke,
    Vector startPoint,
    Vector endPoint
)
Visual Basic (Declaration)
Public Sub DrawLine ( _
    stroke As Stroke, _
    startPoint As Vector, _
    endPoint As Vector _
)
Visual C++
public:
void DrawLine(
    Stroke^ stroke,
    Vector startPoint,
    Vector endPoint
)

Parameters

stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
startPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
endPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

GraphicStream Class
DrawLine Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawLine Method (Color, Vector, Vector)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawLine Method (Color, Vector, Vector)
GraphicStream Class See Also Send Feedback
Draws a line connecting two points defined by Vector structures.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawLine(
    Color color,
    Vector startPoint,
    Vector endPoint
)
Visual Basic (Declaration)
Public Sub DrawLine ( _
    color As Color, _
    startPoint As Vector, _
    endPoint As Vector _
)
Visual C++
public:
void DrawLine(
    Color color,
    Vector startPoint,
    Vector endPoint
)

Parameters

color
Type: System.Drawing..::.Color
startPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
endPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

GraphicStream Class
DrawLine Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawLine Method (Color, Double, Vector, Vector)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawLine Method (Color, Double, Vector, Vector)
GraphicStream Class See Also Send Feedback
Draws a line.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawLine(
    Color color,
    double width,
    Vector startPoint,
    Vector endPoint
)
Visual Basic (Declaration)
Public Sub DrawLine ( _
    color As Color, _
    width As Double, _
    startPoint As Vector, _
    endPoint As Vector _
)
Visual C++
public:
void DrawLine(
    Color color,
    double width,
    Vector startPoint,
    Vector endPoint
)

Parameters

color
Type: System.Drawing..::.Color
width
Type: System..::.Double
startPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
endPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

GraphicStream Class
DrawLine Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawPie Method

[image] [image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawPie Method
GraphicStream Class See Also Send Feedback

Overload List

Name | Description
DrawPie(Stroke, VectorRectangle, Double, Double) | Draws the interior of a pie section defined by an ellipse specified by a VectorRectangle structure and two radial lines.
DrawPie(Stroke, Vector, Vector, Double, Double) | Draws the interior of a pie section defined by an ellipse specified by two Vector structures and two radial lines.
DrawPie(Stroke, Double, Double, Double, Double, Double, Double) | Draws the interior of a pie section defined by an ellipse specified by a pair of coordinates, width, height and two radial lines.

See Also

GraphicStream Class
GraphicStream Members
PerpetuumSoft.Framework.Drawing Namespace


DrawPie Method (Stroke, VectorRectangle, Double, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawPie Method (Stroke, VectorRectangle, Double, Double)
GraphicStream Class See Also Send Feedback
Draws the interior of a pie section defined by an ellipse specified by a VectorRectangle structure and two radial lines.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawPie(
    Stroke stroke,
    VectorRectangle rect,
    double startAngle,
    double sweepAngle
)
Visual Basic (Declaration)
Public MustOverride Sub DrawPie ( _
    stroke As Stroke, _
    rect As VectorRectangle, _
    startAngle As Double, _
    sweepAngle As Double _
)
Visual C++
public:
virtual void DrawPie(
    Stroke^ stroke,
    VectorRectangle rect,
    double startAngle,
    double sweepAngle
) abstract

Parameters

stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
rect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
startAngle
Type: System..::.Double
sweepAngle
Type: System..::.Double

See Also

GraphicStream Class
DrawPie Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawPie Method (Stroke, Vector, Vector, Double, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawPie Method (Stroke, Vector, Vector, Double, Double)
GraphicStream Class See Also Send Feedback
Draws the interior of a pie section defined by an ellipse specified by two Vector structures and two radial lines.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawPie(
    Stroke stroke,
    Vector location,
    Vector size,
    double startAngle,
    double sweepAngle
)
Visual Basic (Declaration)
Public Sub DrawPie ( _
    stroke As Stroke, _
    location As Vector, _
    size As Vector, _
    startAngle As Double, _
    sweepAngle As Double _
)
Visual C++
public:
void DrawPie(
    Stroke^ stroke,
    Vector location,
    Vector size,
    double startAngle,
    double sweepAngle
)

Parameters

stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
location
Type: PerpetuumSoft.Framework.Drawing..::.Vector
size
Type: PerpetuumSoft.Framework.Drawing..::.Vector
startAngle
Type: System..::.Double
sweepAngle
Type: System..::.Double

See Also

GraphicStream Class
DrawPie Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawPie Method (Stroke, Double, Double, Double, Double, Double, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawPie Method (Stroke, Double, Double, Double, Double, Double, Double)
GraphicStream Class See Also Send Feedback
Draws the interior of a pie section defined by an ellipse specified by a pair of coordinates, width, height and two radial lines.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawPie(
    Stroke stroke,
    double x,
    double y,
    double width,
    double height,
    double startAngle,
    double sweepAngle
)
Visual Basic (Declaration)
Public Sub DrawPie ( _
    stroke As Stroke, _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    startAngle As Double, _
    sweepAngle As Double _
)
Visual C++
public:
void DrawPie(
    Stroke^ stroke,
    double x,
    double y,
    double width,
    double height,
    double startAngle,
    double sweepAngle
)

Parameters

stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
x
Type: System..::.Double
y
Type: System..::.Double
width
Type: System..::.Double
height
Type: System..::.Double
startAngle
Type: System..::.Double
sweepAngle
Type: System..::.Double

See Also

GraphicStream Class
DrawPie Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawPolygon Method

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawPolygon Method
GraphicStream Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.GraphicStream.DrawPolygon(PerpetuumSoft.Framework.Drawing.Stroke,PerpetuumSoft.Framework.Drawing.Vector[])]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawPolygon(
    Stroke stroke,
    Vector[] points
)
Visual Basic (Declaration)
Public MustOverride Sub DrawPolygon ( _
    stroke As Stroke, _
    points As Vector() _
)
Visual C++
public:
virtual void DrawPolygon(
    Stroke^ stroke,
    array<Vector>^ points
) abstract

Parameters

stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
points
Type: array< PerpetuumSoft.Framework.Drawing..::.Vector >[]()[]

See Also

GraphicStream Class
PerpetuumSoft.Framework.Drawing Namespace


DrawRectangle Method

[image] [image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawRectangle Method
GraphicStream Class See Also Send Feedback

Overload List

Name | Description
DrawRectangle(Stroke, VectorRectangle) | Draws the interior of an recrangle defined by the Stroke object and bounding rectangle specified by the VectorRectangle structure.
DrawRectangle(Color, VectorRectangle) | Draws the interior of an rectangle defined by the Color structure and bounding rectangle specified by the VectorRectangle structure.
DrawRectangle(Stroke, VectorRectangle, Double) | Draws the interior of an recrangle.
DrawRectangle(Color, VectorRectangle, Double) | Draws the interior of an recrangle.

See Also

GraphicStream Class
GraphicStream Members
PerpetuumSoft.Framework.Drawing Namespace


DrawRectangle Method (Stroke, VectorRectangle)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawRectangle Method (Stroke, VectorRectangle)
GraphicStream Class See Also Send Feedback
Draws the interior of an recrangle defined by the Stroke object and bounding rectangle specified by the VectorRectangle structure.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawRectangle(
    Stroke stroke,
    VectorRectangle rectangle
)
Visual Basic (Declaration)
Public MustOverride Sub DrawRectangle ( _
    stroke As Stroke, _
    rectangle As VectorRectangle _
)
Visual C++
public:
virtual void DrawRectangle(
    Stroke^ stroke,
    VectorRectangle rectangle
) abstract

Parameters

stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

GraphicStream Class
DrawRectangle Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawRectangle Method (Color, VectorRectangle)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawRectangle Method (Color, VectorRectangle)
GraphicStream Class See Also Send Feedback
Draws the interior of an rectangle defined by the Color structure and bounding rectangle specified by the VectorRectangle structure.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawRectangle(
    Color color,
    VectorRectangle rectangle
)
Visual Basic (Declaration)
Public Sub DrawRectangle ( _
    color As Color, _
    rectangle As VectorRectangle _
)
Visual C++
public:
void DrawRectangle(
    Color color,
    VectorRectangle rectangle
)

Parameters

color
Type: System.Drawing..::.Color
rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

GraphicStream Class
DrawRectangle Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawRectangle Method (Stroke, VectorRectangle, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawRectangle Method (Stroke, VectorRectangle, Double)
GraphicStream Class See Also Send Feedback
Draws the interior of an recrangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawRectangle(
    Stroke stroke,
    VectorRectangle rectangle,
    double angle
)
Visual Basic (Declaration)
Public Sub DrawRectangle ( _
    stroke As Stroke, _
    rectangle As VectorRectangle, _
    angle As Double _
)
Visual C++
public:
void DrawRectangle(
    Stroke^ stroke,
    VectorRectangle rectangle,
    double angle
)

Parameters

stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
angle
Type: System..::.Double

See Also

GraphicStream Class
DrawRectangle Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawRectangle Method (Color, VectorRectangle, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawRectangle Method (Color, VectorRectangle, Double)
GraphicStream Class See Also Send Feedback
Draws the interior of an recrangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawRectangle(
    Color color,
    VectorRectangle rectangle,
    double angle
)
Visual Basic (Declaration)
Public Sub DrawRectangle ( _
    color As Color, _
    rectangle As VectorRectangle, _
    angle As Double _
)
Visual C++
public:
void DrawRectangle(
    Color color,
    VectorRectangle rectangle,
    double angle
)

Parameters

color
Type: System.Drawing..::.Color
rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
angle
Type: System..::.Double

See Also

GraphicStream Class
DrawRectangle Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawText Method

[image] [image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawText Method
GraphicStream Class See Also Send Feedback

Overload List

Name | Description
DrawText(String, FontDescriptor, Fill, Vector, Double) | Draws the specified text string at the location rectangle with the specified Fill and Font objects at specified angle.
DrawText(String, FontDescriptor, Fill, VectorRectangle, ContentAlignment) | Draws the specified text string in the specified rectangle with the specified [t:PerpetuumSoft.Framework.Drawing.Fill] and Font objects using the alignment of the specified ContentAlignment object.
DrawText(String, FontDescriptor, Color, Vector, Double) | Draws the specified text string at the location rectangle with the specified Color structure and Font object at specified angle.
DrawText(String, FontDescriptor, Color, VectorRectangle, ContentAlignment) | Draws the specified text string.
DrawText(String, Font, Fill, Vector, Double) | Draws the specified text string at the location rectangle with the specified Fill and Font objects at specified angle.
DrawText(String, Font, Fill, VectorRectangle, ContentAlignment) | Draws the specified text string in the specified rectangle with the specified Fill and Font objects using the alignment of the specified ContentAlignment object.
DrawText(String, Font, Color, Vector, Double) | Draws the specified text string at the location rectangle with the specified Color structure and Font object at specified angle.
DrawText(String, Font, Color, VectorRectangle, ContentAlignment) | Draws the specified text string.
DrawText(String, FontDescriptor, Fill, Vector, Double, Vector) | Draws the Text.
DrawText(String, FontDescriptor, Color, Vector, Double, Vector) | Draws the Text.
DrawText(String, Font, Fill, Vector, Double, Vector) | Draws the Text.
DrawText(String, Font, Color, Vector, Double, Vector) | Draws the Text.

See Also

GraphicStream Class
GraphicStream Members
PerpetuumSoft.Framework.Drawing Namespace


DrawText Method (String, FontDescriptor, Fill, Vector, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawText Method (String, FontDescriptor, Fill, Vector, Double)
GraphicStream Class See Also Send Feedback
Draws the specified text string at the location rectangle with the specified Fill and Font objects at specified angle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawText(
    string str,
    FontDescriptor fontDescriptor,
    Fill fill,
    Vector centerPoint,
    double angle
)
Visual Basic (Declaration)
Public Sub DrawText ( _
    str As String, _
    fontDescriptor As FontDescriptor, _
    fill As Fill, _
    centerPoint As Vector, _
    angle As Double _
)
Visual C++
public:
void DrawText(
    String^ str,
    FontDescriptor^ fontDescriptor,
    Fill^ fill,
    Vector centerPoint,
    double angle
)

Parameters

str
Type: System..::.String
fontDescriptor
Type: PerpetuumSoft.Framework.Drawing..::.FontDescriptor
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
centerPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
angle
Type: System..::.Double

See Also

GraphicStream Class
DrawText Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawText Method (String, FontDescriptor, Fill, VectorRectangle, ContentAlignment)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawText Method (String, FontDescriptor, Fill, VectorRectangle, ContentAlignment)
GraphicStream Class See Also Send Feedback
Draws the specified text string in the specified rectangle with the specified [t:PerpetuumSoft.Framework.Drawing.Fill] and Font objects using the alignment of the specified ContentAlignment object.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawText(
    string str,
    FontDescriptor fontDescriptor,
    Fill fill,
    VectorRectangle layoutRect,
    ContentAlignment align
)
Visual Basic (Declaration)
Public Sub DrawText ( _
    str As String, _
    fontDescriptor As FontDescriptor, _
    fill As Fill, _
    layoutRect As VectorRectangle, _
    align As ContentAlignment _
)
Visual C++
public:
void DrawText(
    String^ str,
    FontDescriptor^ fontDescriptor,
    Fill^ fill,
    VectorRectangle layoutRect,
    ContentAlignment align
)

Parameters

str
Type: System..::.String
fontDescriptor
Type: PerpetuumSoft.Framework.Drawing..::.FontDescriptor
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
layoutRect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
align
Type: System.Drawing..::.ContentAlignment

See Also

GraphicStream Class
DrawText Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawText Method (String, FontDescriptor, Color, Vector, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawText Method (String, FontDescriptor, Color, Vector, Double)
GraphicStream Class See Also Send Feedback
Draws the specified text string at the location rectangle with the specified Color structure and Font object at specified angle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawText(
    string str,
    FontDescriptor fontDescriptor,
    Color color,
    Vector centerPoint,
    double angle
)
Visual Basic (Declaration)
Public Sub DrawText ( _
    str As String, _
    fontDescriptor As FontDescriptor, _
    color As Color, _
    centerPoint As Vector, _
    angle As Double _
)
Visual C++
public:
void DrawText(
    String^ str,
    FontDescriptor^ fontDescriptor,
    Color color,
    Vector centerPoint,
    double angle
)

Parameters

str
Type: System..::.String
fontDescriptor
Type: PerpetuumSoft.Framework.Drawing..::.FontDescriptor
color
Type: System.Drawing..::.Color
centerPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
angle
Type: System..::.Double

See Also

GraphicStream Class
DrawText Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawText Method (String, FontDescriptor, Color, VectorRectangle, ContentAlignment)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawText Method (String, FontDescriptor, Color, VectorRectangle, ContentAlignment)
GraphicStream Class See Also Send Feedback
Draws the specified text string.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawText(
    string str,
    FontDescriptor fontDescriptor,
    Color color,
    VectorRectangle layoutRect,
    ContentAlignment align
)
Visual Basic (Declaration)
Public Sub DrawText ( _
    str As String, _
    fontDescriptor As FontDescriptor, _
    color As Color, _
    layoutRect As VectorRectangle, _
    align As ContentAlignment _
)
Visual C++
public:
void DrawText(
    String^ str,
    FontDescriptor^ fontDescriptor,
    Color color,
    VectorRectangle layoutRect,
    ContentAlignment align
)

Parameters

str
Type: System..::.String
fontDescriptor
Type: PerpetuumSoft.Framework.Drawing..::.FontDescriptor
color
Type: System.Drawing..::.Color
layoutRect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
align
Type: System.Drawing..::.ContentAlignment

See Also

GraphicStream Class
DrawText Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawText Method (String, Font, Fill, Vector, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawText Method (String, Font, Fill, Vector, Double)
GraphicStream Class See Also Send Feedback
Draws the specified text string at the location rectangle with the specified Fill and Font objects at specified angle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawText(
    string str,
    Font font,
    Fill fill,
    Vector centerPoint,
    double angle
)
Visual Basic (Declaration)
Public MustOverride Sub DrawText ( _
    str As String, _
    font As Font, _
    fill As Fill, _
    centerPoint As Vector, _
    angle As Double _
)
Visual C++
public:
virtual void DrawText(
    String^ str,
    Font^ font,
    Fill^ fill,
    Vector centerPoint,
    double angle
) abstract

Parameters

str
Type: System..::.String
font
Type: System.Drawing..::.Font
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
centerPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
angle
Type: System..::.Double

See Also

GraphicStream Class
DrawText Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawText Method (String, Font, Fill, VectorRectangle, ContentAlignment)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawText Method (String, Font, Fill, VectorRectangle, ContentAlignment)
GraphicStream Class See Also Send Feedback
Draws the specified text string in the specified rectangle with the specified Fill and Font objects using the alignment of the specified ContentAlignment object.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawText(
    string str,
    Font font,
    Fill fill,
    VectorRectangle layoutRect,
    ContentAlignment align
)
Visual Basic (Declaration)
Public MustOverride Sub DrawText ( _
    str As String, _
    font As Font, _
    fill As Fill, _
    layoutRect As VectorRectangle, _
    align As ContentAlignment _
)
Visual C++
public:
virtual void DrawText(
    String^ str,
    Font^ font,
    Fill^ fill,
    VectorRectangle layoutRect,
    ContentAlignment align
) abstract

Parameters

str
Type: System..::.String
font
Type: System.Drawing..::.Font
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
layoutRect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
align
Type: System.Drawing..::.ContentAlignment

See Also

GraphicStream Class
DrawText Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawText Method (String, Font, Color, Vector, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawText Method (String, Font, Color, Vector, Double)
GraphicStream Class See Also Send Feedback
Draws the specified text string at the location rectangle with the specified Color structure and Font object at specified angle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawText(
    string str,
    Font font,
    Color color,
    Vector centerPoint,
    double angle
)
Visual Basic (Declaration)
Public Sub DrawText ( _
    str As String, _
    font As Font, _
    color As Color, _
    centerPoint As Vector, _
    angle As Double _
)
Visual C++
public:
void DrawText(
    String^ str,
    Font^ font,
    Color color,
    Vector centerPoint,
    double angle
)

Parameters

str
Type: System..::.String
font
Type: System.Drawing..::.Font
color
Type: System.Drawing..::.Color
centerPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
angle
Type: System..::.Double

See Also

GraphicStream Class
DrawText Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawText Method (String, Font, Color, VectorRectangle, ContentAlignment)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawText Method (String, Font, Color, VectorRectangle, ContentAlignment)
GraphicStream Class See Also Send Feedback
Draws the specified text string.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawText(
    string str,
    Font font,
    Color color,
    VectorRectangle layoutRect,
    ContentAlignment align
)
Visual Basic (Declaration)
Public Sub DrawText ( _
    str As String, _
    font As Font, _
    color As Color, _
    layoutRect As VectorRectangle, _
    align As ContentAlignment _
)
Visual C++
public:
void DrawText(
    String^ str,
    Font^ font,
    Color color,
    VectorRectangle layoutRect,
    ContentAlignment align
)

Parameters

str
Type: System..::.String
font
Type: System.Drawing..::.Font
color
Type: System.Drawing..::.Color
layoutRect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
align
Type: System.Drawing..::.ContentAlignment

See Also

GraphicStream Class
DrawText Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawText Method (String, FontDescriptor, Fill, Vector, Double, Vector)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawText Method (String, FontDescriptor, Fill, Vector, Double, Vector)
GraphicStream Class See Also Send Feedback
Draws the Text.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public virtual void DrawText(
    string str,
    FontDescriptor fontDescriptor,
    Fill fill,
    Vector centerPoint,
    double angle,
    Vector textSize
)
Visual Basic (Declaration)
Public Overridable Sub DrawText ( _
    str As String, _
    fontDescriptor As FontDescriptor, _
    fill As Fill, _
    centerPoint As Vector, _
    angle As Double, _
    textSize As Vector _
)
Visual C++
public:
virtual void DrawText(
    String^ str,
    FontDescriptor^ fontDescriptor,
    Fill^ fill,
    Vector centerPoint,
    double angle,
    Vector textSize
)

Parameters

str
Type: System..::.String
fontDescriptor
Type: PerpetuumSoft.Framework.Drawing..::.FontDescriptor
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
centerPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
angle
Type: System..::.Double
textSize
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

GraphicStream Class
DrawText Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawText Method (String, FontDescriptor, Color, Vector, Double, Vector)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawText Method (String, FontDescriptor, Color, Vector, Double, Vector)
GraphicStream Class See Also Send Feedback
Draws the Text.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawText(
    string str,
    FontDescriptor fontDescriptor,
    Color color,
    Vector centerPoint,
    double angle,
    Vector textSize
)
Visual Basic (Declaration)
Public Sub DrawText ( _
    str As String, _
    fontDescriptor As FontDescriptor, _
    color As Color, _
    centerPoint As Vector, _
    angle As Double, _
    textSize As Vector _
)
Visual C++
public:
void DrawText(
    String^ str,
    FontDescriptor^ fontDescriptor,
    Color color,
    Vector centerPoint,
    double angle,
    Vector textSize
)

Parameters

str
Type: System..::.String
fontDescriptor
Type: PerpetuumSoft.Framework.Drawing..::.FontDescriptor
color
Type: System.Drawing..::.Color
centerPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
angle
Type: System..::.Double
textSize
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

GraphicStream Class
DrawText Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawText Method (String, Font, Fill, Vector, Double, Vector)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawText Method (String, Font, Fill, Vector, Double, Vector)
GraphicStream Class See Also Send Feedback
Draws the Text.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public virtual void DrawText(
    string str,
    Font font,
    Fill fill,
    Vector centerPoint,
    double angle,
    Vector textSize
)
Visual Basic (Declaration)
Public Overridable Sub DrawText ( _
    str As String, _
    font As Font, _
    fill As Fill, _
    centerPoint As Vector, _
    angle As Double, _
    textSize As Vector _
)
Visual C++
public:
virtual void DrawText(
    String^ str,
    Font^ font,
    Fill^ fill,
    Vector centerPoint,
    double angle,
    Vector textSize
)

Parameters

str
Type: System..::.String
font
Type: System.Drawing..::.Font
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
centerPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
angle
Type: System..::.Double
textSize
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

GraphicStream Class
DrawText Overload
PerpetuumSoft.Framework.Drawing Namespace


DrawText Method (String, Font, Color, Vector, Double, Vector)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.DrawText Method (String, Font, Color, Vector, Double, Vector)
GraphicStream Class See Also Send Feedback
Draws the Text.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void DrawText(
    string str,
    Font font,
    Color color,
    Vector centerPoint,
    double angle,
    Vector textSize
)
Visual Basic (Declaration)
Public Sub DrawText ( _
    str As String, _
    font As Font, _
    color As Color, _
    centerPoint As Vector, _
    angle As Double, _
    textSize As Vector _
)
Visual C++
public:
void DrawText(
    String^ str,
    Font^ font,
    Color color,
    Vector centerPoint,
    double angle,
    Vector textSize
)

Parameters

str
Type: System..::.String
font
Type: System.Drawing..::.Font
color
Type: System.Drawing..::.Color
centerPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
angle
Type: System..::.Double
textSize
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

GraphicStream Class
DrawText Overload
PerpetuumSoft.Framework.Drawing Namespace


EndGroup Method

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.EndGroup Method
GraphicStream Class See Also Send Feedback
Closes the current graphics container and restores the state of this Graphics object to the state saved by the call to the BeginGroup()()() method.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void EndGroup()
Visual Basic (Declaration)
Public MustOverride Sub EndGroup
Visual C++
public:
virtual void EndGroup() abstract

See Also

GraphicStream Class
PerpetuumSoft.Framework.Drawing Namespace


FillCircle Method

[image] [image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillCircle Method
GraphicStream Class See Also Send Feedback

Overload List

Name | Description
FillCircle(Fill, Vector, Double) | Fills the interior of the circle defined by the Fill object, center point specified by the Vector structure and the given radius.
FillCircle(Color, Vector, Double) | Fills the interior of the circle defined by the Color stroke, center point specified by the Vector structure and the given radius.

See Also

GraphicStream Class
GraphicStream Members
PerpetuumSoft.Framework.Drawing Namespace


FillCircle Method (Fill, Vector, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillCircle Method (Fill, Vector, Double)
GraphicStream Class See Also Send Feedback
Fills the interior of the circle defined by the Fill object, center point specified by the Vector structure and the given radius.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void FillCircle(
    Fill fill,
    Vector center,
    double radius
)
Visual Basic (Declaration)
Public MustOverride Sub FillCircle ( _
    fill As Fill, _
    center As Vector, _
    radius As Double _
)
Visual C++
public:
virtual void FillCircle(
    Fill^ fill,
    Vector center,
    double radius
) abstract

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
center
Type: PerpetuumSoft.Framework.Drawing..::.Vector
radius
Type: System..::.Double

See Also

GraphicStream Class
FillCircle Overload
PerpetuumSoft.Framework.Drawing Namespace


FillCircle Method (Color, Vector, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillCircle Method (Color, Vector, Double)
GraphicStream Class See Also Send Feedback
Fills the interior of the circle defined by the Color stroke, center point specified by the Vector structure and the given radius.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void FillCircle(
    Color color,
    Vector center,
    double radius
)
Visual Basic (Declaration)
Public Sub FillCircle ( _
    color As Color, _
    center As Vector, _
    radius As Double _
)
Visual C++
public:
void FillCircle(
    Color color,
    Vector center,
    double radius
)

Parameters

color
Type: System.Drawing..::.Color
center
Type: PerpetuumSoft.Framework.Drawing..::.Vector
radius
Type: System..::.Double

See Also

GraphicStream Class
FillCircle Overload
PerpetuumSoft.Framework.Drawing Namespace


FillEllipse Method

[image] [image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillEllipse Method
GraphicStream Class See Also Send Feedback

Overload List

Name | Description
FillEllipse(Fill, VectorRectangle) | Fills the interior of an ellipse defined by the Fill object and bounding rectangle specified by the VectorRectangle structure.
FillEllipse(Color, VectorRectangle) | Fills the interior of an ellipse defined by the Color structure and bounding rectangle specified by the VectorRectangle structure.

See Also

GraphicStream Class
GraphicStream Members
PerpetuumSoft.Framework.Drawing Namespace


FillEllipse Method (Fill, VectorRectangle)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillEllipse Method (Fill, VectorRectangle)
GraphicStream Class See Also Send Feedback
Fills the interior of an ellipse defined by the Fill object and bounding rectangle specified by the VectorRectangle structure.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void FillEllipse(
    Fill fill,
    VectorRectangle rectangle
)
Visual Basic (Declaration)
Public MustOverride Sub FillEllipse ( _
    fill As Fill, _
    rectangle As VectorRectangle _
)
Visual C++
public:
virtual void FillEllipse(
    Fill^ fill,
    VectorRectangle rectangle
) abstract

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

GraphicStream Class
FillEllipse Overload
PerpetuumSoft.Framework.Drawing Namespace


FillEllipse Method (Color, VectorRectangle)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillEllipse Method (Color, VectorRectangle)
GraphicStream Class See Also Send Feedback
Fills the interior of an ellipse defined by the Color structure and bounding rectangle specified by the VectorRectangle structure.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void FillEllipse(
    Color color,
    VectorRectangle rectangle
)
Visual Basic (Declaration)
Public Sub FillEllipse ( _
    color As Color, _
    rectangle As VectorRectangle _
)
Visual C++
public:
void FillEllipse(
    Color color,
    VectorRectangle rectangle
)

Parameters

color
Type: System.Drawing..::.Color
rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

GraphicStream Class
FillEllipse Overload
PerpetuumSoft.Framework.Drawing Namespace


FillPath Method

[image] [image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillPath Method
GraphicStream Class See Also Send Feedback

Overload List

Name | Description
FillPath(Fill, GraphicsPath) | Fills the interior of the GraphicsPath object.
FillPath(Fill, GraphicsPath, VectorRectangle) | Fills the region assigned by the Path.

See Also

GraphicStream Class
GraphicStream Members
PerpetuumSoft.Framework.Drawing Namespace


FillPath Method (Fill, GraphicsPath)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillPath Method (Fill, GraphicsPath)
GraphicStream Class See Also Send Feedback
Fills the interior of the GraphicsPath object.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public virtual void FillPath(
    Fill fill,
    GraphicsPath path
)
Visual Basic (Declaration)
Public Overridable Sub FillPath ( _
    fill As Fill, _
    path As GraphicsPath _
)
Visual C++
public:
virtual void FillPath(
    Fill^ fill,
    GraphicsPath^ path
)

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
path
Type: System.Drawing.Drawing2D..::.GraphicsPath

See Also

GraphicStream Class
FillPath Overload
PerpetuumSoft.Framework.Drawing Namespace


FillPath Method (Fill, GraphicsPath, VectorRectangle)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillPath Method (Fill, GraphicsPath, VectorRectangle)
GraphicStream Class See Also Send Feedback
Fills the region assigned by the Path.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void FillPath(
    Fill fill,
    GraphicsPath path,
    VectorRectangle fillRect
)
Visual Basic (Declaration)
Public MustOverride Sub FillPath ( _
    fill As Fill, _
    path As GraphicsPath, _
    fillRect As VectorRectangle _
)
Visual C++
public:
virtual void FillPath(
    Fill^ fill,
    GraphicsPath^ path,
    VectorRectangle fillRect
) abstract

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
path
Type: System.Drawing.Drawing2D..::.GraphicsPath
fillRect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

GraphicStream Class
FillPath Overload
PerpetuumSoft.Framework.Drawing Namespace


FillPie Method

[image] [image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillPie Method
GraphicStream Class See Also Send Feedback

Overload List

Name | Description
FillPie(Fill, VectorRectangle, Double, Double) | Fills the interior of a pie section defined by an ellipse specified by the VectorRectangle structure and two radial lines.
FillPie(Fill, Vector, Vector, Double, Double) | Fills the interior of a pie section defined by an ellipse specified by two Vector structures and two radial lines.
FillPie(Fill, Double, Double, Double, Double, Double, Double) | Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, width, height and two radial lines.

See Also

GraphicStream Class
GraphicStream Members
PerpetuumSoft.Framework.Drawing Namespace


FillPie Method (Fill, VectorRectangle, Double, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillPie Method (Fill, VectorRectangle, Double, Double)
GraphicStream Class See Also Send Feedback
Fills the interior of a pie section defined by an ellipse specified by the VectorRectangle structure and two radial lines.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void FillPie(
    Fill fill,
    VectorRectangle rect,
    double startAngle,
    double sweepAngle
)
Visual Basic (Declaration)
Public MustOverride Sub FillPie ( _
    fill As Fill, _
    rect As VectorRectangle, _
    startAngle As Double, _
    sweepAngle As Double _
)
Visual C++
public:
virtual void FillPie(
    Fill^ fill,
    VectorRectangle rect,
    double startAngle,
    double sweepAngle
) abstract

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
rect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
startAngle
Type: System..::.Double
sweepAngle
Type: System..::.Double

See Also

GraphicStream Class
FillPie Overload
PerpetuumSoft.Framework.Drawing Namespace


FillPie Method (Fill, Vector, Vector, Double, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillPie Method (Fill, Vector, Vector, Double, Double)
GraphicStream Class See Also Send Feedback
Fills the interior of a pie section defined by an ellipse specified by two Vector structures and two radial lines.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void FillPie(
    Fill fill,
    Vector location,
    Vector size,
    double startAngle,
    double sweepAngle
)
Visual Basic (Declaration)
Public Sub FillPie ( _
    fill As Fill, _
    location As Vector, _
    size As Vector, _
    startAngle As Double, _
    sweepAngle As Double _
)
Visual C++
public:
void FillPie(
    Fill^ fill,
    Vector location,
    Vector size,
    double startAngle,
    double sweepAngle
)

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
location
Type: PerpetuumSoft.Framework.Drawing..::.Vector
size
Type: PerpetuumSoft.Framework.Drawing..::.Vector
startAngle
Type: System..::.Double
sweepAngle
Type: System..::.Double

See Also

GraphicStream Class
FillPie Overload
PerpetuumSoft.Framework.Drawing Namespace


FillPie Method (Fill, Double, Double, Double, Double, Double, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillPie Method (Fill, Double, Double, Double, Double, Double, Double)
GraphicStream Class See Also Send Feedback
Fills the interior of a pie section defined by an ellipse specified by a pair of coordinates, width, height and two radial lines.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void FillPie(
    Fill fill,
    double x,
    double y,
    double width,
    double height,
    double startAngle,
    double sweepAngle
)
Visual Basic (Declaration)
Public Sub FillPie ( _
    fill As Fill, _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    startAngle As Double, _
    sweepAngle As Double _
)
Visual C++
public:
void FillPie(
    Fill^ fill,
    double x,
    double y,
    double width,
    double height,
    double startAngle,
    double sweepAngle
)

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
x
Type: System..::.Double
y
Type: System..::.Double
width
Type: System..::.Double
height
Type: System..::.Double
startAngle
Type: System..::.Double
sweepAngle
Type: System..::.Double

See Also

GraphicStream Class
FillPie Overload
PerpetuumSoft.Framework.Drawing Namespace


FillPolygon Method

[image] [image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillPolygon Method
GraphicStream Class See Also Send Feedback

Overload List

Name | Description
FillPolygon(Fill, array<Vector>[]()[]) |
FillPolygon(Fill, array<Vector>[]()[], FillMode) |

See Also

GraphicStream Class
GraphicStream Members
PerpetuumSoft.Framework.Drawing Namespace


FillPolygon Method (Fill, Vector[])

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillPolygon Method (Fill, array<Vector>[]()[])
GraphicStream Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.GraphicStream.FillPolygon(PerpetuumSoft.Framework.Drawing.Fill,PerpetuumSoft.Framework.Drawing.Vector[])]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void FillPolygon(
    Fill fill,
    Vector[] points
)
Visual Basic (Declaration)
Public Sub FillPolygon ( _
    fill As Fill, _
    points As Vector() _
)
Visual C++
public:
void FillPolygon(
    Fill^ fill,
    array<Vector>^ points
)

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
points
Type: array< PerpetuumSoft.Framework.Drawing..::.Vector >[]()[]

See Also

GraphicStream Class
FillPolygon Overload
PerpetuumSoft.Framework.Drawing Namespace


FillPolygon Method (Fill, Vector[], FillMode)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillPolygon Method (Fill, array<Vector>[]()[], FillMode)
GraphicStream Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.GraphicStream.FillPolygon(PerpetuumSoft.Framework.Drawing.Fill,PerpetuumSoft.Framework.Drawing.Vector[],System.Drawing.Drawing2D.FillMode)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void FillPolygon(
    Fill fill,
    Vector[] points,
    FillMode fillMode
)
Visual Basic (Declaration)
Public MustOverride Sub FillPolygon ( _
    fill As Fill, _
    points As Vector(), _
    fillMode As FillMode _
)
Visual C++
public:
virtual void FillPolygon(
    Fill^ fill,
    array<Vector>^ points,
    FillMode fillMode
) abstract

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
points
Type: array< PerpetuumSoft.Framework.Drawing..::.Vector >[]()[]
fillMode
Type: System.Drawing.Drawing2D..::.FillMode

See Also

GraphicStream Class
FillPolygon Overload
PerpetuumSoft.Framework.Drawing Namespace


FillRectangle Method

[image] [image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillRectangle Method
GraphicStream Class See Also Send Feedback

Overload List

Name | Description
FillRectangle(Fill, VectorRectangle) | Fills the interior of an recrangle defined by the Fill object and bounding rectangle specified by the VectorRectangle structure.
FillRectangle(Color, VectorRectangle) | Fills the interior of an rectangle defined by the Color structure and bounding rectangle specified by the VectorRectangle structure.
FillRectangle(Fill, VectorRectangle, Double) | Fills a rectangle.

See Also

GraphicStream Class
GraphicStream Members
PerpetuumSoft.Framework.Drawing Namespace


FillRectangle Method (Fill, VectorRectangle)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillRectangle Method (Fill, VectorRectangle)
GraphicStream Class See Also Send Feedback
Fills the interior of an recrangle defined by the Fill object and bounding rectangle specified by the VectorRectangle structure.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void FillRectangle(
    Fill fill,
    VectorRectangle rectangle
)
Visual Basic (Declaration)
Public MustOverride Sub FillRectangle ( _
    fill As Fill, _
    rectangle As VectorRectangle _
)
Visual C++
public:
virtual void FillRectangle(
    Fill^ fill,
    VectorRectangle rectangle
) abstract

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

GraphicStream Class
FillRectangle Overload
PerpetuumSoft.Framework.Drawing Namespace


FillRectangle Method (Color, VectorRectangle)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillRectangle Method (Color, VectorRectangle)
GraphicStream Class See Also Send Feedback
Fills the interior of an rectangle defined by the Color structure and bounding rectangle specified by the VectorRectangle structure.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void FillRectangle(
    Color color,
    VectorRectangle rectangle
)
Visual Basic (Declaration)
Public Sub FillRectangle ( _
    color As Color, _
    rectangle As VectorRectangle _
)
Visual C++
public:
void FillRectangle(
    Color color,
    VectorRectangle rectangle
)

Parameters

color
Type: System.Drawing..::.Color
rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

GraphicStream Class
FillRectangle Overload
PerpetuumSoft.Framework.Drawing Namespace


FillRectangle Method (Fill, VectorRectangle, Double)

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.FillRectangle Method (Fill, VectorRectangle, Double)
GraphicStream Class See Also Send Feedback
Fills a rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void FillRectangle(
    Fill fill,
    VectorRectangle rectangle,
    double angle
)
Visual Basic (Declaration)
Public Sub FillRectangle ( _
    fill As Fill, _
    rectangle As VectorRectangle, _
    angle As Double _
)
Visual C++
public:
void FillRectangle(
    Fill^ fill,
    VectorRectangle rectangle,
    double angle
)

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
angle
Type: System..::.Double

See Also

GraphicStream Class
FillRectangle Overload
PerpetuumSoft.Framework.Drawing Namespace


Flush Method

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.Flush Method
GraphicStream Class See Also Send Feedback
Flushes any underlying stream, performs all the operations required to complete the operation.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public virtual void Flush()
Visual Basic (Declaration)
Public Overridable Sub Flush
Visual C++
public:
virtual void Flush()

See Also

GraphicStream Class
PerpetuumSoft.Framework.Drawing Namespace


SetSmoothMode Method

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.SetSmoothMode Method
GraphicStream Class See Also Send Feedback
Sets the smooth graphics settings.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void SetSmoothMode(
    bool smooth
)
Visual Basic (Declaration)
Public MustOverride Sub SetSmoothMode ( _
    smooth As Boolean _
)
Visual C++
public:
virtual void SetSmoothMode(
    bool smooth
) abstract

Parameters

smooth
Type: System..::.Boolean

See Also

GraphicStream Class
PerpetuumSoft.Framework.Drawing Namespace


Transform Method

[image]

.NET ModelKit Suite ClassReference
GraphicStream..::.Transform Method
GraphicStream Class See Also Send Feedback
Applies the given transform matrix for current graphics object.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract void Transform(
    Matrix m
)
Visual Basic (Declaration)
Public MustOverride Sub Transform ( _
    m As Matrix _
)
Visual C++
public:
virtual void Transform(
    Matrix^ m
) abstract

Parameters

m
Type: System.Drawing.Drawing2D..::.Matrix

See Also

GraphicStream Class
PerpetuumSoft.Framework.Drawing Namespace


HatchFill Class

[image]

.NET ModelKit Suite ClassReference
HatchFill Class
Members See Also Send Feedback
Defines the fill with a hatch style, a foreground color, and a background color.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class HatchFill : Fill
Visual Basic (Declaration)
Public Class HatchFill _
    Inherits Fill
Visual C++
public ref class HatchFill : public Fill

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework..::.Atom
PerpetuumSoft.Framework.Drawing..::.Fill
PerpetuumSoft.Framework.Drawing..::.HatchFill

See Also

HatchFill Members
PerpetuumSoft.Framework.Drawing Namespace


HatchFill Members

[image] [image]

.NET ModelKit Suite ClassReference
HatchFill Members
HatchFill Class Constructors Methods Properties See Also Send Feedback

The HatchFill type exposes the following members.

Constructors

Name | Description
HatchFill | Overloaded.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Overridden. See Clone()()(). (Overrides Atom..::.Clone()()().)
CreateBrush | Overridden. See CreateBrush(VectorRectangle). (Overrides Fill..::.CreateBrush(VectorRectangle).)
Equals | Overridden. See Equals(Object). (Overrides Fill..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Fill..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetReplaceColor | Overridden. See GetReplaceColor()()(). (Overrides Fill..::.GetReplaceColor()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from Fill.)

Properties

Name | Description
BackColor | Gets the color of spaces between the hatch lines drawn by this HatchFill object.
ForeColor | Gets the color of hatch lines drawn by this HatchFill object.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
Style | Gets the hatch style of this HatchFill object.

See Also

HatchFill Class
PerpetuumSoft.Framework.Drawing Namespace


HatchFill Constructor

[image] [image]

.NET ModelKit Suite ClassReference
HatchFill Constructor
HatchFill Class See Also Send Feedback

Overload List

Name | Description
HatchFill()()() | Initializes a new instance of the HatchFill class.
HatchFill(Color, Color, HatchStyle) | Initializes the new instance of the HatchFill class with the specified style.

See Also

HatchFill Class
HatchFill Members
PerpetuumSoft.Framework.Drawing Namespace


HatchFill Constructor

[image]

.NET ModelKit Suite ClassReference
HatchFill Constructor
HatchFill Class See Also Send Feedback
Initializes a new instance of the HatchFill class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public HatchFill()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HatchFill()

See Also

HatchFill Class
HatchFill Overload
PerpetuumSoft.Framework.Drawing Namespace


HatchFill Constructor (Color, Color, HatchStyle)

[image]

.NET ModelKit Suite ClassReference
HatchFill Constructor (Color, Color, HatchStyle)
HatchFill Class See Also Send Feedback
Initializes the new instance of the HatchFill class with the specified style.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public HatchFill(
    Color foreColor,
    Color backColor,
    HatchStyle style
)
Visual Basic (Declaration)
Public Sub New ( _
    foreColor As Color, _
    backColor As Color, _
    style As HatchStyle _
)
Visual C++
public:
HatchFill(
    Color foreColor,
    Color backColor,
    HatchStyle style
)

Parameters

foreColor
Type: System.Drawing..::.Color
backColor
Type: System.Drawing..::.Color
style
Type: System.Drawing.Drawing2D..::.HatchStyle

See Also

HatchFill Class
HatchFill Overload
PerpetuumSoft.Framework.Drawing Namespace


HatchFill Methods

[image] [image]

.NET ModelKit Suite ClassReference
HatchFill Methods
HatchFill Class See Also Send Feedback

The HatchFill type exposes the following members.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Overridden. See Clone()()(). (Overrides Atom..::.Clone()()().)
CreateBrush | Overridden. See CreateBrush(VectorRectangle). (Overrides Fill..::.CreateBrush(VectorRectangle).)
Equals | Overridden. See Equals(Object). (Overrides Fill..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Fill..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetReplaceColor | Overridden. See GetReplaceColor()()(). (Overrides Fill..::.GetReplaceColor()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from Fill.)

See Also

HatchFill Class
PerpetuumSoft.Framework.Drawing Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
HatchFill..::.Clone Method
HatchFill Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Implements

ICloneable..::.Clone()()()

See Also

HatchFill Class
PerpetuumSoft.Framework.Drawing Namespace


CreateBrush Method

[image]

.NET ModelKit Suite ClassReference
HatchFill..::.CreateBrush Method
HatchFill Class See Also Send Feedback
Overridden. See CreateBrush(VectorRectangle).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Brush CreateBrush(
    VectorRectangle rect
)
Visual Basic (Declaration)
Public Overrides Function CreateBrush ( _
    rect As VectorRectangle _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    VectorRectangle rect
) override

Parameters

rect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

HatchFill Class
PerpetuumSoft.Framework.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
HatchFill..::.Equals Method
HatchFill Class See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

HatchFill Class
PerpetuumSoft.Framework.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
HatchFill..::.GetHashCode Method
HatchFill Class See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

HatchFill Class
PerpetuumSoft.Framework.Drawing Namespace


GetReplaceColor Method

[image]

.NET ModelKit Suite ClassReference
HatchFill..::.GetReplaceColor Method
HatchFill Class See Also Send Feedback
Overridden. See GetReplaceColor()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Color GetReplaceColor()
Visual Basic (Declaration)
Public Overrides Function GetReplaceColor As Color
Visual C++
public:
virtual Color GetReplaceColor() override

See Also

HatchFill Class
PerpetuumSoft.Framework.Drawing Namespace


HatchFill Properties

[image] [image]

.NET ModelKit Suite ClassReference
HatchFill Properties
HatchFill Class See Also Send Feedback

The HatchFill type exposes the following members.

Properties

Name | Description
BackColor | Gets the color of spaces between the hatch lines drawn by this HatchFill object.
ForeColor | Gets the color of hatch lines drawn by this HatchFill object.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
Style | Gets the hatch style of this HatchFill object.

See Also

HatchFill Class
PerpetuumSoft.Framework.Drawing Namespace


BackColor Property

[image]

.NET ModelKit Suite ClassReference
HatchFill..::.BackColor Property
HatchFill Class See Also Send Feedback
Gets the color of spaces between the hatch lines drawn by this HatchFill object.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Color BackColor { get; set; }
Visual Basic (Declaration)
Public Property BackColor As Color
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}

See Also

HatchFill Class
PerpetuumSoft.Framework.Drawing Namespace


ForeColor Property

[image]

.NET ModelKit Suite ClassReference
HatchFill..::.ForeColor Property
HatchFill Class See Also Send Feedback
Gets the color of hatch lines drawn by this HatchFill object.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Color ForeColor { get; set; }
Visual Basic (Declaration)
Public Property ForeColor As Color
Visual C++
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}

See Also

HatchFill Class
PerpetuumSoft.Framework.Drawing Namespace


Style Property

[image]

.NET ModelKit Suite ClassReference
HatchFill..::.Style Property
HatchFill Class See Also Send Feedback
Gets the hatch style of this HatchFill object.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public HatchStyle Style { get; set; }
Visual Basic (Declaration)
Public Property Style As HatchStyle
Visual C++
public:
property HatchStyle Style {
    HatchStyle get ();
    void set (HatchStyle value);
}

See Also

HatchFill Class
PerpetuumSoft.Framework.Drawing Namespace


LinearGradientFill Class

[image]

.NET ModelKit Suite ClassReference
LinearGradientFill Class
Members See Also Send Feedback
Encapsulates the Fill object with a linear gradient.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class LinearGradientFill : Fill
Visual Basic (Declaration)
Public Class LinearGradientFill _
    Inherits Fill
Visual C++
public ref class LinearGradientFill : public Fill

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework..::.Atom
PerpetuumSoft.Framework.Drawing..::.Fill
PerpetuumSoft.Framework.Drawing..::.LinearGradientFill

See Also

LinearGradientFill Members
PerpetuumSoft.Framework.Drawing Namespace


LinearGradientFill Members

[image] [image]

.NET ModelKit Suite ClassReference
LinearGradientFill Members
LinearGradientFill Class Constructors Methods Properties See Also Send Feedback

The LinearGradientFill type exposes the following members.

Constructors

Name | Description
LinearGradientFill | Overloaded.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Overridden. See Clone()()(). (Overrides Atom..::.Clone()()().)
CreateBrush | Overridden. See CreateBrush(VectorRectangle). (Overrides Fill..::.CreateBrush(VectorRectangle).)
Equals | Overridden. See Equals(Object). (Overrides Fill..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Fill..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetReplaceColor | Overridden. See GetReplaceColor()()(). (Overrides Fill..::.GetReplaceColor()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from Fill.)

Properties

Name | Description
Angle | Gets or sets the angle of fill.
Colors | Gets the set of colors used for the fill.
EndColor | Gets or sets the end color.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
StartColor | Gets or sets the beginning color.

See Also

LinearGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


LinearGradientFill Constructor

[image] [image]

.NET ModelKit Suite ClassReference
LinearGradientFill Constructor
LinearGradientFill Class See Also Send Feedback

Overload List

Name | Description
LinearGradientFill()()() | Initializes a new instance of the LinearGradientFill class.
LinearGradientFill(Color, Color, Double) | Initializes the new instance of the LinearGradientFill class with specified parameters.

See Also

LinearGradientFill Class
LinearGradientFill Members
PerpetuumSoft.Framework.Drawing Namespace


LinearGradientFill Constructor

[image]

.NET ModelKit Suite ClassReference
LinearGradientFill Constructor
LinearGradientFill Class See Also Send Feedback
Initializes a new instance of the LinearGradientFill class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public LinearGradientFill()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LinearGradientFill()

See Also

LinearGradientFill Class
LinearGradientFill Overload
PerpetuumSoft.Framework.Drawing Namespace


LinearGradientFill Constructor (Color, Color, Double)

[image]

.NET ModelKit Suite ClassReference
LinearGradientFill Constructor (Color, Color, Double)
LinearGradientFill Class See Also Send Feedback
Initializes the new instance of the LinearGradientFill class with specified parameters.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public LinearGradientFill(
    Color startColor,
    Color endColor,
    double angle
)
Visual Basic (Declaration)
Public Sub New ( _
    startColor As Color, _
    endColor As Color, _
    angle As Double _
)
Visual C++
public:
LinearGradientFill(
    Color startColor,
    Color endColor,
    double angle
)

Parameters

startColor
Type: System.Drawing..::.Color
endColor
Type: System.Drawing..::.Color
angle
Type: System..::.Double

See Also

LinearGradientFill Class
LinearGradientFill Overload
PerpetuumSoft.Framework.Drawing Namespace


LinearGradientFill Methods

[image] [image]

.NET ModelKit Suite ClassReference
LinearGradientFill Methods
LinearGradientFill Class See Also Send Feedback

The LinearGradientFill type exposes the following members.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Overridden. See Clone()()(). (Overrides Atom..::.Clone()()().)
CreateBrush | Overridden. See CreateBrush(VectorRectangle). (Overrides Fill..::.CreateBrush(VectorRectangle).)
Equals | Overridden. See Equals(Object). (Overrides Fill..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Fill..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetReplaceColor | Overridden. See GetReplaceColor()()(). (Overrides Fill..::.GetReplaceColor()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from Fill.)

See Also

LinearGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
LinearGradientFill..::.Clone Method
LinearGradientFill Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Implements

ICloneable..::.Clone()()()

See Also

LinearGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


CreateBrush Method

[image]

.NET ModelKit Suite ClassReference
LinearGradientFill..::.CreateBrush Method
LinearGradientFill Class See Also Send Feedback
Overridden. See CreateBrush(VectorRectangle).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Brush CreateBrush(
    VectorRectangle rect
)
Visual Basic (Declaration)
Public Overrides Function CreateBrush ( _
    rect As VectorRectangle _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    VectorRectangle rect
) override

Parameters

rect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

LinearGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
LinearGradientFill..::.Equals Method
LinearGradientFill Class See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

LinearGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
LinearGradientFill..::.GetHashCode Method
LinearGradientFill Class See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

LinearGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


GetReplaceColor Method

[image]

.NET ModelKit Suite ClassReference
LinearGradientFill..::.GetReplaceColor Method
LinearGradientFill Class See Also Send Feedback
Overridden. See GetReplaceColor()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Color GetReplaceColor()
Visual Basic (Declaration)
Public Overrides Function GetReplaceColor As Color
Visual C++
public:
virtual Color GetReplaceColor() override

See Also

LinearGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


LinearGradientFill Properties

[image] [image]

.NET ModelKit Suite ClassReference
LinearGradientFill Properties
LinearGradientFill Class See Also Send Feedback

The LinearGradientFill type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the angle of fill.
Colors | Gets the set of colors used for the fill.
EndColor | Gets or sets the end color.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
StartColor | Gets or sets the beginning color.

See Also

LinearGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


Angle Property

[image]

.NET ModelKit Suite ClassReference
LinearGradientFill..::.Angle Property
LinearGradientFill Class See Also Send Feedback
Gets or sets the angle of fill.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

See Also

LinearGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


Colors Property

[image]

.NET ModelKit Suite ClassReference
LinearGradientFill..::.Colors Property
LinearGradientFill Class See Also Send Feedback
Gets the set of colors used for the fill.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public GradientColorCollection Colors { get; }
Visual Basic (Declaration)
Public ReadOnly Property Colors As GradientColorCollection
Visual C++
public:
property GradientColorCollection^ Colors {
    GradientColorCollection^ get ();
}

See Also

LinearGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


EndColor Property

[image]

.NET ModelKit Suite ClassReference
LinearGradientFill..::.EndColor Property
LinearGradientFill Class See Also Send Feedback
Gets or sets the end color.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Color EndColor { get; set; }
Visual Basic (Declaration)
Public Property EndColor As Color
Visual C++
public:
property Color EndColor {
    Color get ();
    void set (Color value);
}

See Also

LinearGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


StartColor Property

[image]

.NET ModelKit Suite ClassReference
LinearGradientFill..::.StartColor Property
LinearGradientFill Class See Also Send Feedback
Gets or sets the beginning color.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Color StartColor { get; set; }
Visual Basic (Declaration)
Public Property StartColor As Color
Visual C++
public:
property Color StartColor {
    Color get ();
    void set (Color value);
}

See Also

LinearGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


LineStyle Enumeration

[image]

.NET ModelKit Suite ClassReference
LineStyle Enumeration
See Also Send Feedback
Enumerates the styles for line drawing.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public enum LineStyle
Visual Basic (Declaration)
Public Enumeration LineStyle
Visual C++
public enum class LineStyle

Members

Member name | Description
None | No line.
Solid | Specifies a solid line.
Dot | Specifies a line consisting of dots.
Dash | Specifies a line consisting of dashes.
DashDot | Specifies a line consisting of the repeated pattern of dash-dot.
DashDotDot | Specifies a line consisting of a repeated pattern of dash-dot-dot.

See Also

PerpetuumSoft.Framework.Drawing Namespace


Margins Structure

[image]

.NET ModelKit Suite ClassReference
Margins Structure
Members See Also Send Feedback
Represents control's margins.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public struct Margins : ICloneable
Visual Basic (Declaration)
Public Structure Margins _
    Implements ICloneable
Visual C++
public value class Margins : ICloneable

See Also

Margins Members
PerpetuumSoft.Framework.Drawing Namespace


Margins Members

[image] [image]

.NET ModelKit Suite ClassReference
Margins Members
Margins Structure Constructors Methods Properties See Also Send Feedback

The Margins type exposes the following members.

Constructors

Name | Description
Margins | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the Margins.
ConvertUnits | Create new margins in the new system of counting.
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse | Overloaded.
ToString | Overloaded.

Operators

Name | Description
Addition |
Equality |
Inequality |
Multiply |

Properties

Name | Description
Bottom | Gets or sets the bottom margin of an element.
Empty | Gets the empty Margins.
IsEmpty | Returns true if Left, Top, Right and Bottom properties are zero; otherwise, false.
Left | Gets or sets the left margin of an element.
Right | Gets or sets the right margin of an element.
Size | Gets the size of margins.
Top | Gets or sets the top margin of an element.

See Also

Margins Structure
PerpetuumSoft.Framework.Drawing Namespace


Margins Constructor

[image] [image]

.NET ModelKit Suite ClassReference
Margins Constructor
Margins Structure See Also Send Feedback

Overload List

Name | Description
Margins(Double) | Initializes a new instance of the Margins class with specified parameters.
Margins(Double, Double, Double, Double) | Initializes the new instance of the Margins class with specified parameters.

See Also

Margins Structure
Margins Members
PerpetuumSoft.Framework.Drawing Namespace


Margins Constructor (Double)

[image]

.NET ModelKit Suite ClassReference
Margins Constructor (Double)
Margins Structure See Also Send Feedback
Initializes a new instance of the Margins class with specified parameters.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Margins(
    double ext
)
Visual Basic (Declaration)
Public Sub New ( _
    ext As Double _
)
Visual C++
public:
Margins(
    double ext
)

Parameters

ext
Type: System..::.Double

See Also

Margins Structure
Margins Overload
PerpetuumSoft.Framework.Drawing Namespace


Margins Constructor (Double, Double, Double, Double)

[image]

.NET ModelKit Suite ClassReference
Margins Constructor (Double, Double, Double, Double)
Margins Structure See Also Send Feedback
Initializes the new instance of the Margins class with specified parameters.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Margins(
    double top,
    double bottom,
    double left,
    double right
)
Visual Basic (Declaration)
Public Sub New ( _
    top As Double, _
    bottom As Double, _
    left As Double, _
    right As Double _
)
Visual C++
public:
Margins(
    double top,
    double bottom,
    double left,
    double right
)

Parameters

top
Type: System..::.Double
bottom
Type: System..::.Double
left
Type: System..::.Double
right
Type: System..::.Double

See Also

Margins Structure
Margins Overload
PerpetuumSoft.Framework.Drawing Namespace


Margins Methods

[image] [image]

.NET ModelKit Suite ClassReference
Margins Methods
Margins Structure See Also Send Feedback

The Margins type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the Margins.
ConvertUnits | Create new margins in the new system of counting.
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse | Overloaded.
ToString | Overloaded.

Operators

Name | Description
Addition |
Equality |
Inequality |
Multiply |

See Also

Margins Structure
PerpetuumSoft.Framework.Drawing Namespace


Addition Operator

[image]

.NET ModelKit Suite ClassReference
Margins..::.Addition Operator
Margins Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Margins.op_Addition(PerpetuumSoft.Framework.Drawing.Margins,PerpetuumSoft.Framework.Drawing.Margins)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Margins operator +(
    Margins a,
    Margins b
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    a As Margins, _
    b As Margins _
) As Margins
Visual C++
public:
static Margins operator +(
    Margins a,
    Margins b
)

Parameters

a
Type: PerpetuumSoft.Framework.Drawing..::.Margins
b
Type: PerpetuumSoft.Framework.Drawing..::.Margins

See Also

Margins Structure
PerpetuumSoft.Framework.Drawing Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
Margins..::.Clone Method
Margins Structure See Also Send Feedback
Creates a copy of the Margins.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Implements

ICloneable..::.Clone()()()

See Also

Margins Structure
PerpetuumSoft.Framework.Drawing Namespace


ConvertUnits Method

[image]

.NET ModelKit Suite ClassReference
Margins..::.ConvertUnits Method
Margins Structure See Also Send Feedback
Create new margins in the new system of counting.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Margins ConvertUnits(
    Unit fromUnit,
    Unit toUnit
)
Visual Basic (Declaration)
Public Function ConvertUnits ( _
    fromUnit As Unit, _
    toUnit As Unit _
) As Margins
Visual C++
public:
Margins ConvertUnits(
    Unit fromUnit,
    Unit toUnit
)

Parameters

fromUnit
Type: PerpetuumSoft.Framework.Drawing..::.Unit
toUnit
Type: PerpetuumSoft.Framework.Drawing..::.Unit

See Also

Margins Structure
PerpetuumSoft.Framework.Drawing Namespace


Equality Operator

[image]

.NET ModelKit Suite ClassReference
Margins..::.Equality Operator
Margins Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Margins.op_Equality(PerpetuumSoft.Framework.Drawing.Margins,PerpetuumSoft.Framework.Drawing.Margins)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static bool operator ==(
    Margins m1,
    Margins m2
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    m1 As Margins, _
    m2 As Margins _
) As Boolean
Visual C++
public:
static bool operator ==(
    Margins m1,
    Margins m2
)

Parameters

m1
Type: PerpetuumSoft.Framework.Drawing..::.Margins
m2
Type: PerpetuumSoft.Framework.Drawing..::.Margins

See Also

Margins Structure
PerpetuumSoft.Framework.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
Margins..::.Equals Method
Margins Structure See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

Margins Structure
PerpetuumSoft.Framework.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
Margins..::.GetHashCode Method
Margins Structure See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

Margins Structure
PerpetuumSoft.Framework.Drawing Namespace


Inequality Operator

[image]

.NET ModelKit Suite ClassReference
Margins..::.Inequality Operator
Margins Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Margins.op_Inequality(PerpetuumSoft.Framework.Drawing.Margins,PerpetuumSoft.Framework.Drawing.Margins)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static bool operator !=(
    Margins m1,
    Margins m2
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    m1 As Margins, _
    m2 As Margins _
) As Boolean
Visual C++
public:
static bool operator !=(
    Margins m1,
    Margins m2
)

Parameters

m1
Type: PerpetuumSoft.Framework.Drawing..::.Margins
m2
Type: PerpetuumSoft.Framework.Drawing..::.Margins

See Also

Margins Structure
PerpetuumSoft.Framework.Drawing Namespace


Multiply Operator

[image]

.NET ModelKit Suite ClassReference
Margins..::.Multiply Operator
Margins Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Margins.op_Multiply(PerpetuumSoft.Framework.Drawing.Margins,PerpetuumSoft.Framework.Drawing.Margins)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Margins operator *(
    Margins a,
    Margins b
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    a As Margins, _
    b As Margins _
) As Margins
Visual C++
public:
static Margins operator *(
    Margins a,
    Margins b
)

Parameters

a
Type: PerpetuumSoft.Framework.Drawing..::.Margins
b
Type: PerpetuumSoft.Framework.Drawing..::.Margins

See Also

Margins Structure
PerpetuumSoft.Framework.Drawing Namespace


Parse Method

[image] [image]

.NET ModelKit Suite ClassReference
Margins..::.Parse Method
Margins Structure See Also Send Feedback

Overload List

Name | Description
Parse(String) | Converts the string representation of margins to its equivalent.
Parse(String, NumberStyles) | Converts the string representation of margins in a specified style to its equivalent.
Parse(String, IFormatProvider) | Converts the string representation of margins in a specified culture-specific format to its equivalent.
Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of margins in a specified style and culture-specific format to its equivalent.

See Also

Margins Structure
Margins Members
PerpetuumSoft.Framework.Drawing Namespace


Parse Method (String)

[image]

.NET ModelKit Suite ClassReference
Margins..::.Parse Method (String)
Margins Structure See Also Send Feedback
Converts the string representation of margins to its equivalent.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Margins Parse(
    string s
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    s As String _
) As Margins
Visual C++
public:
static Margins Parse(
    String^ s
)

Parameters

s
Type: System..::.String

See Also

Margins Structure
Parse Overload
PerpetuumSoft.Framework.Drawing Namespace


Parse Method (String, NumberStyles)

[image]

.NET ModelKit Suite ClassReference
Margins..::.Parse Method (String, NumberStyles)
Margins Structure See Also Send Feedback
Converts the string representation of margins in a specified style to its equivalent.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Margins Parse(
    string s,
    NumberStyles style
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    s As String, _
    style As NumberStyles _
) As Margins
Visual C++
public:
static Margins Parse(
    String^ s,
    NumberStyles style
)

Parameters

s
Type: System..::.String
style
Type: System.Globalization..::.NumberStyles

See Also

Margins Structure
Parse Overload
PerpetuumSoft.Framework.Drawing Namespace


Parse Method (String, IFormatProvider)

[image]

.NET ModelKit Suite ClassReference
Margins..::.Parse Method (String, IFormatProvider)
Margins Structure See Also Send Feedback
Converts the string representation of margins in a specified culture-specific format to its equivalent.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Margins Parse(
    string s,
    IFormatProvider provider
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    s As String, _
    provider As IFormatProvider _
) As Margins
Visual C++
public:
static Margins Parse(
    String^ s,
    IFormatProvider^ provider
)

Parameters

s
Type: System..::.String
provider
Type: System..::.IFormatProvider

See Also

Margins Structure
Parse Overload
PerpetuumSoft.Framework.Drawing Namespace


Parse Method (String, NumberStyles, IFormatProvider)

[image]

.NET ModelKit Suite ClassReference
Margins..::.Parse Method (String, NumberStyles, IFormatProvider)
Margins Structure See Also Send Feedback
Converts the string representation of margins in a specified style and culture-specific format to its equivalent.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Margins Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    s As String, _
    style As NumberStyles, _
    provider As IFormatProvider _
) As Margins
Visual C++
public:
static Margins Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)

Parameters

s
Type: System..::.String
style
Type: System.Globalization..::.NumberStyles
provider
Type: System..::.IFormatProvider

See Also

Margins Structure
Parse Overload
PerpetuumSoft.Framework.Drawing Namespace


ToString Method

[image] [image]

.NET ModelKit Suite ClassReference
Margins..::.ToString Method
Margins Structure See Also Send Feedback

Overload List

Name | Description
ToString()()() | Overridden. See ToString()()(). (Overrides ValueType..::.ToString()()().)
ToString(IFormatProvider) | Returns a string that represents the Margins object.
ToString(String) | Returns a string that represents the Margins object.
ToString(String, IFormatProvider) | Returns a string that represents the Margins object.

See Also

Margins Structure
Margins Members
PerpetuumSoft.Framework.Drawing Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
Margins..::.ToString Method
Margins Structure See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Margins Structure
ToString Overload
PerpetuumSoft.Framework.Drawing Namespace


ToString Method (IFormatProvider)

[image]

.NET ModelKit Suite ClassReference
Margins..::.ToString Method (IFormatProvider)
Margins Structure See Also Send Feedback
Returns a string that represents the Margins object.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public string ToString(
    IFormatProvider provider
)
Visual Basic (Declaration)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
Visual C++
public:
String^ ToString(
    IFormatProvider^ provider
)

Parameters

provider
Type: System..::.IFormatProvider

See Also

Margins Structure
ToString Overload
PerpetuumSoft.Framework.Drawing Namespace


ToString Method (String)

[image]

.NET ModelKit Suite ClassReference
Margins..::.ToString Method (String)
Margins Structure See Also Send Feedback
Returns a string that represents the Margins object.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public string ToString(
    string format
)
Visual Basic (Declaration)
Public Function ToString ( _
    format As String _
) As String
Visual C++
public:
String^ ToString(
    String^ format
)

Parameters

format
Type: System..::.String

See Also

Margins Structure
ToString Overload
PerpetuumSoft.Framework.Drawing Namespace


ToString Method (String, IFormatProvider)

[image]

.NET ModelKit Suite ClassReference
Margins..::.ToString Method (String, IFormatProvider)
Margins Structure See Also Send Feedback
Returns a string that represents the Margins object.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public string ToString(
    string format,
    IFormatProvider provider
)
Visual Basic (Declaration)
Public Function ToString ( _
    format As String, _
    provider As IFormatProvider _
) As String
Visual C++
public:
String^ ToString(
    String^ format,
    IFormatProvider^ provider
)

Parameters

format
Type: System..::.String
provider
Type: System..::.IFormatProvider

See Also

Margins Structure
ToString Overload
PerpetuumSoft.Framework.Drawing Namespace


Margins Properties

[image] [image]

.NET ModelKit Suite ClassReference
Margins Properties
Margins Structure See Also Send Feedback

The Margins type exposes the following members.

Properties

Name | Description
Bottom | Gets or sets the bottom margin of an element.
Empty | Gets the empty Margins.
IsEmpty | Returns true if Left, Top, Right and Bottom properties are zero; otherwise, false.
Left | Gets or sets the left margin of an element.
Right | Gets or sets the right margin of an element.
Size | Gets the size of margins.
Top | Gets or sets the top margin of an element.

See Also

Margins Structure
PerpetuumSoft.Framework.Drawing Namespace


Bottom Property

[image]

.NET ModelKit Suite ClassReference
Margins..::.Bottom Property
Margins Structure See Also Send Feedback
Gets or sets the bottom margin of an element.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Bottom { get; }
Visual Basic (Declaration)
Public ReadOnly Property Bottom As Double
Visual C++
public:
property double Bottom {
    double get ();
}

See Also

Margins Structure
PerpetuumSoft.Framework.Drawing Namespace


Empty Property

[image]

.NET ModelKit Suite ClassReference
Margins..::.Empty Property
Margins Structure See Also Send Feedback
Gets the empty Margins.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Margins Empty { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Empty As Margins
Visual C++
public:
static property Margins Empty {
    Margins get ();
}

See Also

Margins Structure
PerpetuumSoft.Framework.Drawing Namespace


IsEmpty Property

[image]

.NET ModelKit Suite ClassReference
Margins..::.IsEmpty Property
Margins Structure See Also Send Feedback
Returns true if Left, Top, Right and Bottom properties are zero; otherwise, false.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

Margins Structure
PerpetuumSoft.Framework.Drawing Namespace


Left Property

[image]

.NET ModelKit Suite ClassReference
Margins..::.Left Property
Margins Structure See Also Send Feedback
Gets or sets the left margin of an element.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Left { get; }
Visual Basic (Declaration)
Public ReadOnly Property Left As Double
Visual C++
public:
property double Left {
    double get ();
}

See Also

Margins Structure
PerpetuumSoft.Framework.Drawing Namespace


Right Property

[image]

.NET ModelKit Suite ClassReference
Margins..::.Right Property
Margins Structure See Also Send Feedback
Gets or sets the right margin of an element.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Right { get; }
Visual Basic (Declaration)
Public ReadOnly Property Right As Double
Visual C++
public:
property double Right {
    double get ();
}

See Also

Margins Structure
PerpetuumSoft.Framework.Drawing Namespace


Size Property

[image]

.NET ModelKit Suite ClassReference
Margins..::.Size Property
Margins Structure See Also Send Feedback
Gets the size of margins.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector Size { get; }
Visual Basic (Declaration)
Public ReadOnly Property Size As Vector
Visual C++
public:
property Vector Size {
    Vector get ();
}

See Also

Margins Structure
PerpetuumSoft.Framework.Drawing Namespace


Top Property

[image]

.NET ModelKit Suite ClassReference
Margins..::.Top Property
Margins Structure See Also Send Feedback
Gets or sets the top margin of an element.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Top { get; }
Visual Basic (Declaration)
Public ReadOnly Property Top As Double
Visual C++
public:
property double Top {
    double get ();
}

See Also

Margins Structure
PerpetuumSoft.Framework.Drawing Namespace


MultiGradientFill Class

[image]

.NET ModelKit Suite ClassReference
MultiGradientFill Class
Members See Also Send Feedback
Encapsulates the Fill object with a multilinear gradient.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class MultiGradientFill : Fill
Visual Basic (Declaration)
Public Class MultiGradientFill _
    Inherits Fill
Visual C++
public ref class MultiGradientFill : public Fill

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework..::.Atom
PerpetuumSoft.Framework.Drawing..::.Fill
PerpetuumSoft.Framework.Drawing..::.MultiGradientFill
PerpetuumSoft.Framework.Drawing..::.ConicalFill

See Also

MultiGradientFill Members
PerpetuumSoft.Framework.Drawing Namespace


MultiGradientFill Members

[image] [image]

.NET ModelKit Suite ClassReference
MultiGradientFill Members
MultiGradientFill Class Constructors Methods Properties See Also Send Feedback

The MultiGradientFill type exposes the following members.

Constructors

Name | Description
MultiGradientFill | Overloaded.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Overridden. See Clone()()(). (Overrides Atom..::.Clone()()().)
CreateBrush | Overridden. See CreateBrush(VectorRectangle). (Overrides Fill..::.CreateBrush(VectorRectangle).)
Equals | Overridden. See Equals(Object). (Overrides Fill..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Fill..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetReplaceColor | Overridden. See GetReplaceColor()()(). (Overrides Fill..::.GetReplaceColor()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from Fill.)

Properties

Name | Description
Angle | Gets or sets the angle of fill.
Colors | Gets collection of colors for the fill specified by the GradientColorCollection object.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)

See Also

MultiGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


MultiGradientFill Constructor

[image] [image]

.NET ModelKit Suite ClassReference
MultiGradientFill Constructor
MultiGradientFill Class See Also Send Feedback

Overload List

Name | Description
MultiGradientFill()()() | Initializes a new instance of the MultiGradientFill class.
MultiGradientFill(Double) | Initializes the new instance of the MultiGradientFill class with specified parameters.

See Also

MultiGradientFill Class
MultiGradientFill Members
PerpetuumSoft.Framework.Drawing Namespace


MultiGradientFill Constructor

[image]

.NET ModelKit Suite ClassReference
MultiGradientFill Constructor
MultiGradientFill Class See Also Send Feedback
Initializes a new instance of the MultiGradientFill class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public MultiGradientFill()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MultiGradientFill()

See Also

MultiGradientFill Class
MultiGradientFill Overload
PerpetuumSoft.Framework.Drawing Namespace


MultiGradientFill Constructor (Double)

[image]

.NET ModelKit Suite ClassReference
MultiGradientFill Constructor (Double)
MultiGradientFill Class See Also Send Feedback
Initializes the new instance of the MultiGradientFill class with specified parameters.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public MultiGradientFill(
    double angle
)
Visual Basic (Declaration)
Public Sub New ( _
    angle As Double _
)
Visual C++
public:
MultiGradientFill(
    double angle
)

Parameters

angle
Type: System..::.Double

See Also

MultiGradientFill Class
MultiGradientFill Overload
PerpetuumSoft.Framework.Drawing Namespace


MultiGradientFill Methods

[image] [image]

.NET ModelKit Suite ClassReference
MultiGradientFill Methods
MultiGradientFill Class See Also Send Feedback

The MultiGradientFill type exposes the following members.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Overridden. See Clone()()(). (Overrides Atom..::.Clone()()().)
CreateBrush | Overridden. See CreateBrush(VectorRectangle). (Overrides Fill..::.CreateBrush(VectorRectangle).)
Equals | Overridden. See Equals(Object). (Overrides Fill..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Fill..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetReplaceColor | Overridden. See GetReplaceColor()()(). (Overrides Fill..::.GetReplaceColor()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from Fill.)

See Also

MultiGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
MultiGradientFill..::.Clone Method
MultiGradientFill Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Implements

ICloneable..::.Clone()()()

See Also

MultiGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


CreateBrush Method

[image]

.NET ModelKit Suite ClassReference
MultiGradientFill..::.CreateBrush Method
MultiGradientFill Class See Also Send Feedback
Overridden. See CreateBrush(VectorRectangle).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Brush CreateBrush(
    VectorRectangle rect
)
Visual Basic (Declaration)
Public Overrides Function CreateBrush ( _
    rect As VectorRectangle _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    VectorRectangle rect
) override

Parameters

rect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

MultiGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
MultiGradientFill..::.Equals Method
MultiGradientFill Class See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

MultiGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
MultiGradientFill..::.GetHashCode Method
MultiGradientFill Class See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

MultiGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


GetReplaceColor Method

[image]

.NET ModelKit Suite ClassReference
MultiGradientFill..::.GetReplaceColor Method
MultiGradientFill Class See Also Send Feedback
Overridden. See GetReplaceColor()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Color GetReplaceColor()
Visual Basic (Declaration)
Public Overrides Function GetReplaceColor As Color
Visual C++
public:
virtual Color GetReplaceColor() override

See Also

MultiGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


MultiGradientFill Properties

[image] [image]

.NET ModelKit Suite ClassReference
MultiGradientFill Properties
MultiGradientFill Class See Also Send Feedback

The MultiGradientFill type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the angle of fill.
Colors | Gets collection of colors for the fill specified by the GradientColorCollection object.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)

See Also

MultiGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


Angle Property

[image]

.NET ModelKit Suite ClassReference
MultiGradientFill..::.Angle Property
MultiGradientFill Class See Also Send Feedback
Gets or sets the angle of fill.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

See Also

MultiGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


Colors Property

[image]

.NET ModelKit Suite ClassReference
MultiGradientFill..::.Colors Property
MultiGradientFill Class See Also Send Feedback
Gets collection of colors for the fill specified by the GradientColorCollection object.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public GradientColorCollection Colors { get; }
Visual Basic (Declaration)
Public ReadOnly Property Colors As GradientColorCollection
Visual C++
public:
property GradientColorCollection^ Colors {
    GradientColorCollection^ get ();
}

See Also

MultiGradientFill Class
PerpetuumSoft.Framework.Drawing Namespace


Pdf417Settings Class

[image]

.NET ModelKit Suite ClassReference
Pdf417Settings Class
Members See Also Send Feedback
Represents barcode settings of the PDF417 type.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class Pdf417Settings
Visual Basic (Declaration)
Public Class Pdf417Settings
Visual C++
public ref class Pdf417Settings

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Drawing..::.Pdf417Settings

See Also

Pdf417Settings Members
PerpetuumSoft.Framework.Drawing Namespace


Pdf417Settings Members

[image] [image]

.NET ModelKit Suite ClassReference
Pdf417Settings Members
Pdf417Settings Class Constructors Methods Properties See Also Send Feedback

The Pdf417Settings type exposes the following members.

Constructors

Name | Description
Pdf417Settings | Initializes a new instance of the Pdf417Settings class.

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValidSettings | Defines if the specified setting values are correct in the aggregate. Returns "true" if values are correct and "false" is not.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
ColumnsCount | Gets or sets columns count.
ErrorLevel | Gets or sets error correction level.
RowsCount | Gets or sets rows count.
Type | Gets or sets a compaction mode.

See Also

Pdf417Settings Class
PerpetuumSoft.Framework.Drawing Namespace


Pdf417Settings Constructor

[image]

.NET ModelKit Suite ClassReference
Pdf417Settings Constructor
Pdf417Settings Class See Also Send Feedback
Initializes a new instance of the Pdf417Settings class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Pdf417Settings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Pdf417Settings()

See Also

Pdf417Settings Class
PerpetuumSoft.Framework.Drawing Namespace


Pdf417Settings Methods

[image] [image]

.NET ModelKit Suite ClassReference
Pdf417Settings Methods
Pdf417Settings Class See Also Send Feedback

The Pdf417Settings type exposes the following members.

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValidSettings | Defines if the specified setting values are correct in the aggregate. Returns "true" if values are correct and "false" is not.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

Pdf417Settings Class
PerpetuumSoft.Framework.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
Pdf417Settings..::.Equals Method
Pdf417Settings Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Pdf417Settings.Equals(System.Object)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

Pdf417Settings Class
PerpetuumSoft.Framework.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
Pdf417Settings..::.GetHashCode Method
Pdf417Settings Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Pdf417Settings.GetHashCode]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

Pdf417Settings Class
PerpetuumSoft.Framework.Drawing Namespace


IsValidSettings Method

[image]

.NET ModelKit Suite ClassReference
Pdf417Settings..::.IsValidSettings Method
Pdf417Settings Class See Also Send Feedback
Defines if the specified setting values are correct in the aggregate. Returns "true" if values are correct and "false" is not.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static string IsValidSettings(
    string data,
    int rowsCount,
    int columnsCount,
    int errorLevel,
    TypeBarCode typeBarCode
)
Visual Basic (Declaration)
Public Shared Function IsValidSettings ( _
    data As String, _
    rowsCount As Integer, _
    columnsCount As Integer, _
    errorLevel As Integer, _
    typeBarCode As TypeBarCode _
) As String
Visual C++
public:
static String^ IsValidSettings(
    String^ data,
    int rowsCount,
    int columnsCount,
    int errorLevel,
    TypeBarCode typeBarCode
)

Parameters

data
Type: System..::.String
rowsCount
Type: System..::.Int32
columnsCount
Type: System..::.Int32
errorLevel
Type: System..::.Int32
typeBarCode
Type: PerpetuumSoft.Framework.Drawing.PDF417BarCode..::.TypeBarCode

See Also

Pdf417Settings Class
PerpetuumSoft.Framework.Drawing Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
Pdf417Settings..::.ToString Method
Pdf417Settings Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Pdf417Settings Class
PerpetuumSoft.Framework.Drawing Namespace


Pdf417Settings Properties

[image] [image]

.NET ModelKit Suite ClassReference
Pdf417Settings Properties
Pdf417Settings Class See Also Send Feedback

The Pdf417Settings type exposes the following members.

Properties

Name | Description
ColumnsCount | Gets or sets columns count.
ErrorLevel | Gets or sets error correction level.
RowsCount | Gets or sets rows count.
Type | Gets or sets a compaction mode.

See Also

Pdf417Settings Class
PerpetuumSoft.Framework.Drawing Namespace


ColumnsCount Property

[image]

.NET ModelKit Suite ClassReference
Pdf417Settings..::.ColumnsCount Property
Pdf417Settings Class See Also Send Feedback
Gets or sets columns count.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public int ColumnsCount { get; set; }
Visual Basic (Declaration)
Public Property ColumnsCount As Integer
Visual C++
public:
property int ColumnsCount {
    int get ();
    void set (int value);
}

See Also

Pdf417Settings Class
PerpetuumSoft.Framework.Drawing Namespace


ErrorLevel Property

[image]

.NET ModelKit Suite ClassReference
Pdf417Settings..::.ErrorLevel Property
Pdf417Settings Class See Also Send Feedback
Gets or sets error correction level.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public int ErrorLevel { get; set; }
Visual Basic (Declaration)
Public Property ErrorLevel As Integer
Visual C++
public:
property int ErrorLevel {
    int get ();
    void set (int value);
}

See Also

Pdf417Settings Class
PerpetuumSoft.Framework.Drawing Namespace


RowsCount Property

[image]

.NET ModelKit Suite ClassReference
Pdf417Settings..::.RowsCount Property
Pdf417Settings Class See Also Send Feedback
Gets or sets rows count.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public int RowsCount { get; set; }
Visual Basic (Declaration)
Public Property RowsCount As Integer
Visual C++
public:
property int RowsCount {
    int get ();
    void set (int value);
}

See Also

Pdf417Settings Class
PerpetuumSoft.Framework.Drawing Namespace


Type Property

[image]

.NET ModelKit Suite ClassReference
Pdf417Settings..::.Type Property
Pdf417Settings Class See Also Send Feedback
Gets or sets a compaction mode.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public TypeBarCode Type { get; set; }
Visual Basic (Declaration)
Public Property Type As TypeBarCode
Visual C++
public:
property TypeBarCode Type {
    TypeBarCode get ();
    void set (TypeBarCode value);
}

See Also

Pdf417Settings Class
PerpetuumSoft.Framework.Drawing Namespace


PictureFormat Enumeration

[image]

.NET ModelKit Suite ClassReference
PictureFormat Enumeration
See Also Send Feedback
Available Image Formats.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public enum PictureFormat
Visual Basic (Declaration)
Public Enumeration PictureFormat
Visual C++
public enum class PictureFormat

Members

Member name | Description
Jpeg | JPEG image format.
Png | PNG image format.
Gif | GIF image format.
Bmp | BMP image format.
Svg | SVG image format.
Flash | FLASH image format.

See Also

PerpetuumSoft.Framework.Drawing Namespace


RoundedVectorRectangle Class

[image]

.NET ModelKit Suite ClassReference
RoundedVectorRectangle Class
Members See Also Send Feedback
Rounded rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class RoundedVectorRectangle
Visual Basic (Declaration)
Public Class RoundedVectorRectangle
Visual C++
public ref class RoundedVectorRectangle

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Drawing..::.RoundedVectorRectangle

See Also

RoundedVectorRectangle Members
PerpetuumSoft.Framework.Drawing Namespace


RoundedVectorRectangle Members

[image] [image]

.NET ModelKit Suite ClassReference
RoundedVectorRectangle Members
RoundedVectorRectangle Class Constructors Methods Properties See Also Send Feedback

The RoundedVectorRectangle type exposes the following members.

Constructors

Name | Description
RoundedVectorRectangle | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Height | Gets or sets height of the rectangle.
Rx | Gets or sets x-axis radius of the ellipse used to round off the corners of the rectangle.
Ry | Gets or sets y-axis radius of the ellipse used to round off the corners of the rectangle.
VectorRectangle | Gets or sets a rectangle.
Width | Gets or sets width of the rectangle.
X | Gets or sets X coordinate of the top left corner of the rectangle.
Y | Gets or sets Y coordinate of the top left corner of the rectangle.

See Also

RoundedVectorRectangle Class
PerpetuumSoft.Framework.Drawing Namespace


RoundedVectorRectangle Constructor

[image] [image]

.NET ModelKit Suite ClassReference
RoundedVectorRectangle Constructor
RoundedVectorRectangle Class See Also Send Feedback

Overload List

Name | Description
RoundedVectorRectangle(VectorRectangle) | Initializes a new instance of the RoundedVectorRectangle class.
RoundedVectorRectangle(VectorRectangle, Double, Double) | Initializes a new instance of the RoundedVectorRectangle class.
RoundedVectorRectangle(Double, Double, Double, Double) | Initializes a new instance of the RoundedVectorRectangle class.
RoundedVectorRectangle(Double, Double, Double, Double, Double, Double) | Initializes a new instance of the RoundedVectorRectangle class.

See Also

RoundedVectorRectangle Class
RoundedVectorRectangle Members
PerpetuumSoft.Framework.Drawing Namespace


RoundedVectorRectangle Constructor (VectorRectangle)

[image]

.NET ModelKit Suite ClassReference
RoundedVectorRectangle Constructor (VectorRectangle)
RoundedVectorRectangle Class See Also Send Feedback
Initializes a new instance of the RoundedVectorRectangle class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public RoundedVectorRectangle(
    VectorRectangle vectorRectangle
)
Visual Basic (Declaration)
Public Sub New ( _
    vectorRectangle As VectorRectangle _
)
Visual C++
public:
RoundedVectorRectangle(
    VectorRectangle vectorRectangle
)

Parameters

vectorRectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

RoundedVectorRectangle Class
RoundedVectorRectangle Overload
PerpetuumSoft.Framework.Drawing Namespace


RoundedVectorRectangle Constructor (VectorRectangle, Double, Double)

[image]

.NET ModelKit Suite ClassReference
RoundedVectorRectangle Constructor (VectorRectangle, Double, Double)
RoundedVectorRectangle Class See Also Send Feedback
Initializes a new instance of the RoundedVectorRectangle class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public RoundedVectorRectangle(
    VectorRectangle vectorRectangle,
    double rx,
    double ry
)
Visual Basic (Declaration)
Public Sub New ( _
    vectorRectangle As VectorRectangle, _
    rx As Double, _
    ry As Double _
)
Visual C++
public:
RoundedVectorRectangle(
    VectorRectangle vectorRectangle,
    double rx,
    double ry
)

Parameters

vectorRectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
rx
Type: System..::.Double
ry
Type: System..::.Double

See Also

RoundedVectorRectangle Class
RoundedVectorRectangle Overload
PerpetuumSoft.Framework.Drawing Namespace


RoundedVectorRectangle Constructor (Double, Double, Double, Double)

[image]

.NET ModelKit Suite ClassReference
RoundedVectorRectangle Constructor (Double, Double, Double, Double)
RoundedVectorRectangle Class See Also Send Feedback
Initializes a new instance of the RoundedVectorRectangle class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public RoundedVectorRectangle(
    double x,
    double y,
    double width,
    double height
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double _
)
Visual C++
public:
RoundedVectorRectangle(
    double x,
    double y,
    double width,
    double height
)

Parameters

x
Type: System..::.Double
y
Type: System..::.Double
width
Type: System..::.Double
height
Type: System..::.Double

See Also

RoundedVectorRectangle Class
RoundedVectorRectangle Overload
PerpetuumSoft.Framework.Drawing Namespace


RoundedVectorRectangle Constructor (Double, Double, Double, Double, Double, Double)

[image]

.NET ModelKit Suite ClassReference
RoundedVectorRectangle Constructor (Double, Double, Double, Double, Double, Double)
RoundedVectorRectangle Class See Also Send Feedback
Initializes a new instance of the RoundedVectorRectangle class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public RoundedVectorRectangle(
    double x,
    double y,
    double width,
    double height,
    double rx,
    double ry
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    rx As Double, _
    ry As Double _
)
Visual C++
public:
RoundedVectorRectangle(
    double x,
    double y,
    double width,
    double height,
    double rx,
    double ry
)

Parameters

x
Type: System..::.Double
y
Type: System..::.Double
width
Type: System..::.Double
height
Type: System..::.Double
rx
Type: System..::.Double
ry
Type: System..::.Double

See Also

RoundedVectorRectangle Class
RoundedVectorRectangle Overload
PerpetuumSoft.Framework.Drawing Namespace


RoundedVectorRectangle Methods

[image] [image]

.NET ModelKit Suite ClassReference
RoundedVectorRectangle Methods
RoundedVectorRectangle Class See Also Send Feedback

The RoundedVectorRectangle type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoundedVectorRectangle Class
PerpetuumSoft.Framework.Drawing Namespace


RoundedVectorRectangle Properties

[image] [image]

.NET ModelKit Suite ClassReference
RoundedVectorRectangle Properties
RoundedVectorRectangle Class See Also Send Feedback

The RoundedVectorRectangle type exposes the following members.

Properties

Name | Description
Height | Gets or sets height of the rectangle.
Rx | Gets or sets x-axis radius of the ellipse used to round off the corners of the rectangle.
Ry | Gets or sets y-axis radius of the ellipse used to round off the corners of the rectangle.
VectorRectangle | Gets or sets a rectangle.
Width | Gets or sets width of the rectangle.
X | Gets or sets X coordinate of the top left corner of the rectangle.
Y | Gets or sets Y coordinate of the top left corner of the rectangle.

See Also

RoundedVectorRectangle Class
PerpetuumSoft.Framework.Drawing Namespace


Height Property

[image]

.NET ModelKit Suite ClassReference
RoundedVectorRectangle..::.Height Property
RoundedVectorRectangle Class See Also Send Feedback
Gets or sets height of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Double
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

See Also

RoundedVectorRectangle Class
PerpetuumSoft.Framework.Drawing Namespace


Rx Property

[image]

.NET ModelKit Suite ClassReference
RoundedVectorRectangle..::.Rx Property
RoundedVectorRectangle Class See Also Send Feedback
Gets or sets x-axis radius of the ellipse used to round off the corners of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Rx { get; set; }
Visual Basic (Declaration)
Public Property Rx As Double
Visual C++
public:
property double Rx {
    double get ();
    void set (double value);
}

See Also

RoundedVectorRectangle Class
PerpetuumSoft.Framework.Drawing Namespace


Ry Property

[image]

.NET ModelKit Suite ClassReference
RoundedVectorRectangle..::.Ry Property
RoundedVectorRectangle Class See Also Send Feedback
Gets or sets y-axis radius of the ellipse used to round off the corners of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Ry { get; set; }
Visual Basic (Declaration)
Public Property Ry As Double
Visual C++
public:
property double Ry {
    double get ();
    void set (double value);
}

See Also

RoundedVectorRectangle Class
PerpetuumSoft.Framework.Drawing Namespace


VectorRectangle Property

[image]

.NET ModelKit Suite ClassReference
RoundedVectorRectangle..::.VectorRectangle Property
RoundedVectorRectangle Class See Also Send Feedback
Gets or sets a rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle VectorRectangle { get; set; }
Visual Basic (Declaration)
Public Property VectorRectangle As VectorRectangle
Visual C++
public:
property VectorRectangle VectorRectangle {
    VectorRectangle get ();
    void set (VectorRectangle value);
}

See Also

RoundedVectorRectangle Class
PerpetuumSoft.Framework.Drawing Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
RoundedVectorRectangle..::.Width Property
RoundedVectorRectangle Class See Also Send Feedback
Gets or sets width of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

RoundedVectorRectangle Class
PerpetuumSoft.Framework.Drawing Namespace


X Property

[image]

.NET ModelKit Suite ClassReference
RoundedVectorRectangle..::.X Property
RoundedVectorRectangle Class See Also Send Feedback
Gets or sets X coordinate of the top left corner of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double X { get; set; }
Visual Basic (Declaration)
Public Property X As Double
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}

See Also

RoundedVectorRectangle Class
PerpetuumSoft.Framework.Drawing Namespace


Y Property

[image]

.NET ModelKit Suite ClassReference
RoundedVectorRectangle..::.Y Property
RoundedVectorRectangle Class See Also Send Feedback
Gets or sets Y coordinate of the top left corner of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Double
Visual C++
public:
property double Y {
    double get ();
    void set (double value);
}

See Also

RoundedVectorRectangle Class
PerpetuumSoft.Framework.Drawing Namespace


SimpleStroke Class

[image]

.NET ModelKit Suite ClassReference
SimpleStroke Class
Members See Also Send Feedback
Encapsulates the Stroke object with a simple stroke.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class SimpleStroke : Stroke
Visual Basic (Declaration)
Public Class SimpleStroke _
    Inherits Stroke
Visual C++
public ref class SimpleStroke : public Stroke

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework..::.Atom
PerpetuumSoft.Framework.Drawing..::.Stroke
PerpetuumSoft.Framework.Drawing..::.SimpleStroke

See Also

SimpleStroke Members
PerpetuumSoft.Framework.Drawing Namespace


SimpleStroke Members

[image] [image]

.NET ModelKit Suite ClassReference
SimpleStroke Members
SimpleStroke Class Constructors Methods Properties See Also Send Feedback

The SimpleStroke type exposes the following members.

Constructors

Name | Description
SimpleStroke | Overloaded.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Overridden. See Clone()()(). (Overrides Atom..::.Clone()()().)
CreatePen | Overridden. See CreatePen()()(). (Overrides Stroke..::.CreatePen()()().)
Equals | Overridden. See Equals(Object). (Overrides Stroke..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Stroke..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from Stroke.)

Properties

Name | Description
Color | Gets or sets the Color of stroke.
DashLenght | Gets or sets dash length.
DotLenght | Gets or sets dot length.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
SpaceLenght | Gets or sets space length.
Style | Gets or sets the LineStyle of this stroke.
Width | Overridden. See Width. (Overrides Stroke..::.Width.)

See Also

SimpleStroke Class
PerpetuumSoft.Framework.Drawing Namespace


SimpleStroke Constructor

[image] [image]

.NET ModelKit Suite ClassReference
SimpleStroke Constructor
SimpleStroke Class See Also Send Feedback

Overload List

Name | Description
SimpleStroke()()() | Initializes a new instance of the SimpleStroke class.
SimpleStroke(LineStyle, Color, Double) | Initializes the new instance of the SimpleStroke class with specified parameters.
SimpleStroke(LineStyle, Color, Double, Single, Single, Single) | Initializes a new instance of the SimpleStroke class with specific parameters.

See Also

SimpleStroke Class
SimpleStroke Members
PerpetuumSoft.Framework.Drawing Namespace


SimpleStroke Constructor

[image]

.NET ModelKit Suite ClassReference
SimpleStroke Constructor
SimpleStroke Class See Also Send Feedback
Initializes a new instance of the SimpleStroke class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public SimpleStroke()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SimpleStroke()

See Also

SimpleStroke Class
SimpleStroke Overload
PerpetuumSoft.Framework.Drawing Namespace


SimpleStroke Constructor (LineStyle, Color, Double)

[image]

.NET ModelKit Suite ClassReference
SimpleStroke Constructor (LineStyle, Color, Double)
SimpleStroke Class See Also Send Feedback
Initializes the new instance of the SimpleStroke class with specified parameters.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public SimpleStroke(
    LineStyle style,
    Color color,
    double width
)
Visual Basic (Declaration)
Public Sub New ( _
    style As LineStyle, _
    color As Color, _
    width As Double _
)
Visual C++
public:
SimpleStroke(
    LineStyle style,
    Color color,
    double width
)

Parameters

style
Type: PerpetuumSoft.Framework.Drawing..::.LineStyle
color
Type: System.Drawing..::.Color
width
Type: System..::.Double

See Also

SimpleStroke Class
SimpleStroke Overload
PerpetuumSoft.Framework.Drawing Namespace


SimpleStroke Constructor (LineStyle, Color, Double, Single, Single, Single)

[image]

.NET ModelKit Suite ClassReference
SimpleStroke Constructor (LineStyle, Color, Double, Single, Single, Single)
SimpleStroke Class See Also Send Feedback
Initializes a new instance of the SimpleStroke class with specific parameters.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public SimpleStroke(
    LineStyle style,
    Color color,
    double width,
    float dashLenght,
    float dotLenght,
    float spaceLenght
)
Visual Basic (Declaration)
Public Sub New ( _
    style As LineStyle, _
    color As Color, _
    width As Double, _
    dashLenght As Single, _
    dotLenght As Single, _
    spaceLenght As Single _
)
Visual C++
public:
SimpleStroke(
    LineStyle style,
    Color color,
    double width,
    float dashLenght,
    float dotLenght,
    float spaceLenght
)

Parameters

style
Type: PerpetuumSoft.Framework.Drawing..::.LineStyle
color
Type: System.Drawing..::.Color
width
Type: System..::.Double
dashLenght
Type: System..::.Single
dotLenght
Type: System..::.Single
spaceLenght
Type: System..::.Single

See Also

SimpleStroke Class
SimpleStroke Overload
PerpetuumSoft.Framework.Drawing Namespace


SimpleStroke Methods

[image] [image]

.NET ModelKit Suite ClassReference
SimpleStroke Methods
SimpleStroke Class See Also Send Feedback

The SimpleStroke type exposes the following members.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Overridden. See Clone()()(). (Overrides Atom..::.Clone()()().)
CreatePen | Overridden. See CreatePen()()(). (Overrides Stroke..::.CreatePen()()().)
Equals | Overridden. See Equals(Object). (Overrides Stroke..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Stroke..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from Stroke.)

See Also

SimpleStroke Class
PerpetuumSoft.Framework.Drawing Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
SimpleStroke..::.Clone Method
SimpleStroke Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Implements

ICloneable..::.Clone()()()

See Also

SimpleStroke Class
PerpetuumSoft.Framework.Drawing Namespace


CreatePen Method

[image]

.NET ModelKit Suite ClassReference
SimpleStroke..::.CreatePen Method
SimpleStroke Class See Also Send Feedback
Overridden. See CreatePen()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Pen CreatePen()
Visual Basic (Declaration)
Public Overrides Function CreatePen As Pen
Visual C++
public:
virtual Pen^ CreatePen() override

See Also

SimpleStroke Class
PerpetuumSoft.Framework.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
SimpleStroke..::.Equals Method
SimpleStroke Class See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

SimpleStroke Class
PerpetuumSoft.Framework.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
SimpleStroke..::.GetHashCode Method
SimpleStroke Class See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

SimpleStroke Class
PerpetuumSoft.Framework.Drawing Namespace


SimpleStroke Properties

[image] [image]

.NET ModelKit Suite ClassReference
SimpleStroke Properties
SimpleStroke Class See Also Send Feedback

The SimpleStroke type exposes the following members.

Properties

Name | Description
Color | Gets or sets the Color of stroke.
DashLenght | Gets or sets dash length.
DotLenght | Gets or sets dot length.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
SpaceLenght | Gets or sets space length.
Style | Gets or sets the LineStyle of this stroke.
Width | Overridden. See Width. (Overrides Stroke..::.Width.)

See Also

SimpleStroke Class
PerpetuumSoft.Framework.Drawing Namespace


Color Property

[image]

.NET ModelKit Suite ClassReference
SimpleStroke..::.Color Property
SimpleStroke Class See Also Send Feedback
Gets or sets the Color of stroke.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

SimpleStroke Class
PerpetuumSoft.Framework.Drawing Namespace


DashLenght Property

[image]

.NET ModelKit Suite ClassReference
SimpleStroke..::.DashLenght Property
SimpleStroke Class See Also Send Feedback
Gets or sets dash length.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public float DashLenght { get; set; }
Visual Basic (Declaration)
Public Property DashLenght As Single
Visual C++
public:
property float DashLenght {
    float get ();
    void set (float value);
}

See Also

SimpleStroke Class
PerpetuumSoft.Framework.Drawing Namespace


DotLenght Property

[image]

.NET ModelKit Suite ClassReference
SimpleStroke..::.DotLenght Property
SimpleStroke Class See Also Send Feedback
Gets or sets dot length.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public float DotLenght { get; set; }
Visual Basic (Declaration)
Public Property DotLenght As Single
Visual C++
public:
property float DotLenght {
    float get ();
    void set (float value);
}

See Also

SimpleStroke Class
PerpetuumSoft.Framework.Drawing Namespace


SpaceLenght Property

[image]

.NET ModelKit Suite ClassReference
SimpleStroke..::.SpaceLenght Property
SimpleStroke Class See Also Send Feedback
Gets or sets space length.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public float SpaceLenght { get; set; }
Visual Basic (Declaration)
Public Property SpaceLenght As Single
Visual C++
public:
property float SpaceLenght {
    float get ();
    void set (float value);
}

See Also

SimpleStroke Class
PerpetuumSoft.Framework.Drawing Namespace


Style Property

[image]

.NET ModelKit Suite ClassReference
SimpleStroke..::.Style Property
SimpleStroke Class See Also Send Feedback
Gets or sets the LineStyle of this stroke.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public LineStyle Style { get; set; }
Visual Basic (Declaration)
Public Property Style As LineStyle
Visual C++
public:
property LineStyle Style {
    LineStyle get ();
    void set (LineStyle value);
}

See Also

SimpleStroke Class
PerpetuumSoft.Framework.Drawing Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
SimpleStroke..::.Width Property
SimpleStroke Class See Also Send Feedback
Overridden. See Width.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override double Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Double
Visual C++
public:
virtual property double Width {
    double get () override;
    void set (double value) override;
}

See Also

SimpleStroke Class
PerpetuumSoft.Framework.Drawing Namespace


SolidFill Class

[image]

.NET ModelKit Suite ClassReference
SolidFill Class
Members See Also Send Feedback
Encapsulates the Fill object with single fill.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class SolidFill : Fill
Visual Basic (Declaration)
Public Class SolidFill _
    Inherits Fill
Visual C++
public ref class SolidFill : public Fill

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework..::.Atom
PerpetuumSoft.Framework.Drawing..::.Fill
PerpetuumSoft.Framework.Drawing..::.SolidFill

See Also

SolidFill Members
PerpetuumSoft.Framework.Drawing Namespace


SolidFill Members

[image] [image]

.NET ModelKit Suite ClassReference
SolidFill Members
SolidFill Class Constructors Methods Properties See Also Send Feedback

The SolidFill type exposes the following members.

Constructors

Name | Description
SolidFill | Overloaded.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Overridden. See Clone()()(). (Overrides Atom..::.Clone()()().)
CreateBrush | Overridden. See CreateBrush(VectorRectangle). (Overrides Fill..::.CreateBrush(VectorRectangle).)
Equals | Overridden. See Equals(Object). (Overrides Fill..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Fill..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetReplaceColor | Overridden. See GetReplaceColor()()(). (Overrides Fill..::.GetReplaceColor()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from Fill.)

Properties

Name | Description
Color | Gets or sets the Color of current fill.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)

See Also

SolidFill Class
PerpetuumSoft.Framework.Drawing Namespace


SolidFill Constructor

[image] [image]

.NET ModelKit Suite ClassReference
SolidFill Constructor
SolidFill Class See Also Send Feedback

Overload List

Name | Description
SolidFill()()() | Initializes a new instance of the SolidFill class.
SolidFill(Color) | Initializes the new instance of the SolidFill class with specified parameters.

See Also

SolidFill Class
SolidFill Members
PerpetuumSoft.Framework.Drawing Namespace


SolidFill Constructor

[image]

.NET ModelKit Suite ClassReference
SolidFill Constructor
SolidFill Class See Also Send Feedback
Initializes a new instance of the SolidFill class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public SolidFill()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SolidFill()

See Also

SolidFill Class
SolidFill Overload
PerpetuumSoft.Framework.Drawing Namespace


SolidFill Constructor (Color)

[image]

.NET ModelKit Suite ClassReference
SolidFill Constructor (Color)
SolidFill Class See Also Send Feedback
Initializes the new instance of the SolidFill class with specified parameters.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public SolidFill(
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color _
)
Visual C++
public:
SolidFill(
    Color color
)

Parameters

color
Type: System.Drawing..::.Color

See Also

SolidFill Class
SolidFill Overload
PerpetuumSoft.Framework.Drawing Namespace


SolidFill Methods

[image] [image]

.NET ModelKit Suite ClassReference
SolidFill Methods
SolidFill Class See Also Send Feedback

The SolidFill type exposes the following members.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Overridden. See Clone()()(). (Overrides Atom..::.Clone()()().)
CreateBrush | Overridden. See CreateBrush(VectorRectangle). (Overrides Fill..::.CreateBrush(VectorRectangle).)
Equals | Overridden. See Equals(Object). (Overrides Fill..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Fill..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetReplaceColor | Overridden. See GetReplaceColor()()(). (Overrides Fill..::.GetReplaceColor()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from Fill.)

See Also

SolidFill Class
PerpetuumSoft.Framework.Drawing Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
SolidFill..::.Clone Method
SolidFill Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Implements

ICloneable..::.Clone()()()

See Also

SolidFill Class
PerpetuumSoft.Framework.Drawing Namespace


CreateBrush Method

[image]

.NET ModelKit Suite ClassReference
SolidFill..::.CreateBrush Method
SolidFill Class See Also Send Feedback
Overridden. See CreateBrush(VectorRectangle).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Brush CreateBrush(
    VectorRectangle rect
)
Visual Basic (Declaration)
Public Overrides Function CreateBrush ( _
    rect As VectorRectangle _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    VectorRectangle rect
) override

Parameters

rect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

SolidFill Class
PerpetuumSoft.Framework.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
SolidFill..::.Equals Method
SolidFill Class See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

SolidFill Class
PerpetuumSoft.Framework.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
SolidFill..::.GetHashCode Method
SolidFill Class See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

SolidFill Class
PerpetuumSoft.Framework.Drawing Namespace


GetReplaceColor Method

[image]

.NET ModelKit Suite ClassReference
SolidFill..::.GetReplaceColor Method
SolidFill Class See Also Send Feedback
Overridden. See GetReplaceColor()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Color GetReplaceColor()
Visual Basic (Declaration)
Public Overrides Function GetReplaceColor As Color
Visual C++
public:
virtual Color GetReplaceColor() override

See Also

SolidFill Class
PerpetuumSoft.Framework.Drawing Namespace


SolidFill Properties

[image] [image]

.NET ModelKit Suite ClassReference
SolidFill Properties
SolidFill Class See Also Send Feedback

The SolidFill type exposes the following members.

Properties

Name | Description
Color | Gets or sets the Color of current fill.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)

See Also

SolidFill Class
PerpetuumSoft.Framework.Drawing Namespace


Color Property

[image]

.NET ModelKit Suite ClassReference
SolidFill..::.Color Property
SolidFill Class See Also Send Feedback
Gets or sets the Color of current fill.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

SolidFill Class
PerpetuumSoft.Framework.Drawing Namespace


SphericalFill Class

[image]

.NET ModelKit Suite ClassReference
SphericalFill Class
Members See Also Send Feedback
Encapsulates the Fill object with the spherical gradient.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class SphericalFill : Fill
Visual Basic (Declaration)
Public Class SphericalFill _
    Inherits Fill
Visual C++
public ref class SphericalFill : public Fill

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework..::.Atom
PerpetuumSoft.Framework.Drawing..::.Fill
PerpetuumSoft.Framework.Drawing..::.SphericalFill

See Also

SphericalFill Members
PerpetuumSoft.Framework.Drawing Namespace


SphericalFill Members

[image] [image]

.NET ModelKit Suite ClassReference
SphericalFill Members
SphericalFill Class Constructors Methods Properties See Also Send Feedback

The SphericalFill type exposes the following members.

Constructors

Name | Description
SphericalFill | Overloaded.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Overridden. See Clone()()(). (Overrides Atom..::.Clone()()().)
CreateBrush | Overridden. See CreateBrush(VectorRectangle). (Overrides Fill..::.CreateBrush(VectorRectangle).)
Equals | Overridden. See Equals(Object). (Overrides Fill..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Fill..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetReplaceColor | Overridden. See GetReplaceColor()()(). (Overrides Fill..::.GetReplaceColor()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from Fill.)

Properties

Name | Description
Angle | Gets or sets the angle of center fill position relative to center of element.
Colors | Gets the set of colors used for the fill.
Delta | Gets or sets the position center fill.
EndColor | Gets or sets the end color.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
StartColor | Gets or sets the beginning color.

See Also

SphericalFill Class
PerpetuumSoft.Framework.Drawing Namespace


SphericalFill Constructor

[image] [image]

.NET ModelKit Suite ClassReference
SphericalFill Constructor
SphericalFill Class See Also Send Feedback

Overload List

Name | Description
SphericalFill()()() | Initializes a new instance of the SphericalFill class.
SphericalFill(Color, Color, Double) | Initializes a new instance of the SphericalFill class.
SphericalFill(Color, Color, Double, Double) | Initializes the new instance of the SphericalFill class with specified parameters.

See Also

SphericalFill Class
SphericalFill Members
PerpetuumSoft.Framework.Drawing Namespace


SphericalFill Constructor

[image]

.NET ModelKit Suite ClassReference
SphericalFill Constructor
SphericalFill Class See Also Send Feedback
Initializes a new instance of the SphericalFill class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public SphericalFill()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SphericalFill()

See Also

SphericalFill Class
SphericalFill Overload
PerpetuumSoft.Framework.Drawing Namespace


SphericalFill Constructor (Color, Color, Double)

[image]

.NET ModelKit Suite ClassReference
SphericalFill Constructor (Color, Color, Double)
SphericalFill Class See Also Send Feedback
Initializes a new instance of the SphericalFill class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public SphericalFill(
    Color startColor,
    Color endColor,
    double angle
)
Visual Basic (Declaration)
Public Sub New ( _
    startColor As Color, _
    endColor As Color, _
    angle As Double _
)
Visual C++
public:
SphericalFill(
    Color startColor,
    Color endColor,
    double angle
)

Parameters

startColor
Type: System.Drawing..::.Color
endColor
Type: System.Drawing..::.Color
angle
Type: System..::.Double

See Also

SphericalFill Class
SphericalFill Overload
PerpetuumSoft.Framework.Drawing Namespace


SphericalFill Constructor (Color, Color, Double, Double)

[image]

.NET ModelKit Suite ClassReference
SphericalFill Constructor (Color, Color, Double, Double)
SphericalFill Class See Also Send Feedback
Initializes the new instance of the SphericalFill class with specified parameters.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public SphericalFill(
    Color startColor,
    Color endColor,
    double angle,
    double delta
)
Visual Basic (Declaration)
Public Sub New ( _
    startColor As Color, _
    endColor As Color, _
    angle As Double, _
    delta As Double _
)
Visual C++
public:
SphericalFill(
    Color startColor,
    Color endColor,
    double angle,
    double delta
)

Parameters

startColor
Type: System.Drawing..::.Color
endColor
Type: System.Drawing..::.Color
angle
Type: System..::.Double
delta
Type: System..::.Double

See Also

SphericalFill Class
SphericalFill Overload
PerpetuumSoft.Framework.Drawing Namespace


SphericalFill Methods

[image] [image]

.NET ModelKit Suite ClassReference
SphericalFill Methods
SphericalFill Class See Also Send Feedback

The SphericalFill type exposes the following members.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Overridden. See Clone()()(). (Overrides Atom..::.Clone()()().)
CreateBrush | Overridden. See CreateBrush(VectorRectangle). (Overrides Fill..::.CreateBrush(VectorRectangle).)
Equals | Overridden. See Equals(Object). (Overrides Fill..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Fill..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetReplaceColor | Overridden. See GetReplaceColor()()(). (Overrides Fill..::.GetReplaceColor()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from Fill.)

See Also

SphericalFill Class
PerpetuumSoft.Framework.Drawing Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
SphericalFill..::.Clone Method
SphericalFill Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Implements

ICloneable..::.Clone()()()

See Also

SphericalFill Class
PerpetuumSoft.Framework.Drawing Namespace


CreateBrush Method

[image]

.NET ModelKit Suite ClassReference
SphericalFill..::.CreateBrush Method
SphericalFill Class See Also Send Feedback
Overridden. See CreateBrush(VectorRectangle).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Brush CreateBrush(
    VectorRectangle rect
)
Visual Basic (Declaration)
Public Overrides Function CreateBrush ( _
    rect As VectorRectangle _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    VectorRectangle rect
) override

Parameters

rect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

SphericalFill Class
PerpetuumSoft.Framework.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
SphericalFill..::.Equals Method
SphericalFill Class See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

SphericalFill Class
PerpetuumSoft.Framework.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
SphericalFill..::.GetHashCode Method
SphericalFill Class See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

SphericalFill Class
PerpetuumSoft.Framework.Drawing Namespace


GetReplaceColor Method

[image]

.NET ModelKit Suite ClassReference
SphericalFill..::.GetReplaceColor Method
SphericalFill Class See Also Send Feedback
Overridden. See GetReplaceColor()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override Color GetReplaceColor()
Visual Basic (Declaration)
Public Overrides Function GetReplaceColor As Color
Visual C++
public:
virtual Color GetReplaceColor() override

See Also

SphericalFill Class
PerpetuumSoft.Framework.Drawing Namespace


SphericalFill Properties

[image] [image]

.NET ModelKit Suite ClassReference
SphericalFill Properties
SphericalFill Class See Also Send Feedback

The SphericalFill type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the angle of center fill position relative to center of element.
Colors | Gets the set of colors used for the fill.
Delta | Gets or sets the position center fill.
EndColor | Gets or sets the end color.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
StartColor | Gets or sets the beginning color.

See Also

SphericalFill Class
PerpetuumSoft.Framework.Drawing Namespace


Angle Property

[image]

.NET ModelKit Suite ClassReference
SphericalFill..::.Angle Property
SphericalFill Class See Also Send Feedback
Gets or sets the angle of center fill position relative to center of element.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

See Also

SphericalFill Class
PerpetuumSoft.Framework.Drawing Namespace


Colors Property

[image]

.NET ModelKit Suite ClassReference
SphericalFill..::.Colors Property
SphericalFill Class See Also Send Feedback
Gets the set of colors used for the fill.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public GradientColorCollection Colors { get; }
Visual Basic (Declaration)
Public ReadOnly Property Colors As GradientColorCollection
Visual C++
public:
property GradientColorCollection^ Colors {
    GradientColorCollection^ get ();
}

See Also

SphericalFill Class
PerpetuumSoft.Framework.Drawing Namespace


Delta Property

[image]

.NET ModelKit Suite ClassReference
SphericalFill..::.Delta Property
SphericalFill Class See Also Send Feedback
Gets or sets the position center fill.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Delta { get; set; }
Visual Basic (Declaration)
Public Property Delta As Double
Visual C++
public:
property double Delta {
    double get ();
    void set (double value);
}

See Also

SphericalFill Class
PerpetuumSoft.Framework.Drawing Namespace


EndColor Property

[image]

.NET ModelKit Suite ClassReference
SphericalFill..::.EndColor Property
SphericalFill Class See Also Send Feedback
Gets or sets the end color.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Color EndColor { get; set; }
Visual Basic (Declaration)
Public Property EndColor As Color
Visual C++
public:
property Color EndColor {
    Color get ();
    void set (Color value);
}

See Also

SphericalFill Class
PerpetuumSoft.Framework.Drawing Namespace


StartColor Property

[image]

.NET ModelKit Suite ClassReference
SphericalFill..::.StartColor Property
SphericalFill Class See Also Send Feedback
Gets or sets the beginning color.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Color StartColor { get; set; }
Visual Basic (Declaration)
Public Property StartColor As Color
Visual C++
public:
property Color StartColor {
    Color get ();
    void set (Color value);
}

See Also

SphericalFill Class
PerpetuumSoft.Framework.Drawing Namespace


Stroke Class

[image]

.NET ModelKit Suite ClassReference
Stroke Class
Members See Also Send Feedback
Represents base abstract class for all stroke types.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract class Stroke : Atom
Visual Basic (Declaration)
Public MustInherit Class Stroke _
    Inherits Atom
Visual C++
public ref class Stroke abstract : public Atom

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework..::.Atom
PerpetuumSoft.Framework.Drawing..::.Stroke
PerpetuumSoft.Framework.Drawing..::.EmptyStroke
PerpetuumSoft.Framework.Drawing..::.SimpleStroke

See Also

Stroke Members
PerpetuumSoft.Framework.Drawing Namespace


Stroke Members

[image] [image]

.NET ModelKit Suite ClassReference
Stroke Members
Stroke Class Constructors Methods Properties See Also Send Feedback

The Stroke type exposes the following members.

Constructors

Name | Description
Stroke | Initializes a new instance of the Stroke class

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Returns the copy of this object. (Inherited from Atom.)
CreatePen | Returns a Pen object for the choosen stroke type.
Equals | Overridden. See Equals(Object). (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Object..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
Empty | Gets the empty Stroke.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
Width | Gets or sets the width of the stroke.

See Also

Stroke Class
PerpetuumSoft.Framework.Drawing Namespace


Stroke Constructor

[image]

.NET ModelKit Suite ClassReference
Stroke Constructor
Stroke Class See Also Send Feedback
Initializes a new instance of the Stroke class

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected Stroke()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
Stroke()

See Also

Stroke Class
PerpetuumSoft.Framework.Drawing Namespace


Stroke Methods

[image] [image]

.NET ModelKit Suite ClassReference
Stroke Methods
Stroke Class See Also Send Feedback

The Stroke type exposes the following members.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Returns the copy of this object. (Inherited from Atom.)
CreatePen | Returns a Pen object for the choosen stroke type.
Equals | Overridden. See Equals(Object). (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Object..::.GetHashCode()()().)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

Stroke Class
PerpetuumSoft.Framework.Drawing Namespace


CreatePen Method

[image]

.NET ModelKit Suite ClassReference
Stroke..::.CreatePen Method
Stroke Class See Also Send Feedback
Returns a Pen object for the choosen stroke type.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract Pen CreatePen()
Visual Basic (Declaration)
Public MustOverride Function CreatePen As Pen
Visual C++
public:
virtual Pen^ CreatePen() abstract

See Also

Stroke Class
PerpetuumSoft.Framework.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
Stroke..::.Equals Method
Stroke Class See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

Stroke Class
PerpetuumSoft.Framework.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
Stroke..::.GetHashCode Method
Stroke Class See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

Stroke Class
PerpetuumSoft.Framework.Drawing Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
Stroke..::.ToString Method
Stroke Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Stroke Class
PerpetuumSoft.Framework.Drawing Namespace


Stroke Properties

[image] [image]

.NET ModelKit Suite ClassReference
Stroke Properties
Stroke Class See Also Send Feedback

The Stroke type exposes the following members.

Properties

Name | Description
Empty | Gets the empty Stroke.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
Width | Gets or sets the width of the stroke.

See Also

Stroke Class
PerpetuumSoft.Framework.Drawing Namespace


Empty Property

[image]

.NET ModelKit Suite ClassReference
Stroke..::.Empty Property
Stroke Class See Also Send Feedback
Gets the empty Stroke.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Stroke Empty { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Empty As Stroke
Visual C++
public:
static property Stroke^ Empty {
    Stroke^ get ();
}

See Also

Stroke Class
PerpetuumSoft.Framework.Drawing Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
Stroke..::.Width Property
Stroke Class See Also Send Feedback
Gets or sets the width of the stroke.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public abstract double Width { get; set; }
Visual Basic (Declaration)
Public MustOverride Property Width As Double
Visual C++
public:
virtual property double Width {
    double get () abstract;
    void set (double value) abstract;
}

See Also

Stroke Class
PerpetuumSoft.Framework.Drawing Namespace


ToolboxImageAttribute Class

[image]

.NET ModelKit Suite ClassReference
ToolboxImageAttribute Class
Members See Also Send Feedback
Represents the attribute which sets the collection of icons of different sizes.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class ToolboxImageAttribute : Attribute
Visual Basic (Declaration)
Public Class ToolboxImageAttribute _
    Inherits Attribute
Visual C++
public ref class ToolboxImageAttribute : public Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PerpetuumSoft.Framework.Drawing..::.ToolboxImageAttribute

See Also

ToolboxImageAttribute Members
PerpetuumSoft.Framework.Drawing Namespace


ToolboxImageAttribute Members

[image] [image]

.NET ModelKit Suite ClassReference
ToolboxImageAttribute Members
ToolboxImageAttribute Class Constructors Methods Properties See Also Send Feedback

The ToolboxImageAttribute type exposes the following members.

Constructors

Name | Description
ToolboxImageAttribute | Initializes a new instance of theToolboxImageAttribute class.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetImage | Overloaded.
GetSmallImage | Gets the image which corresponds to the lowest displaying mode.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ToolboxImageAttribute Class
PerpetuumSoft.Framework.Drawing Namespace


ToolboxImageAttribute Constructor

[image]

.NET ModelKit Suite ClassReference
ToolboxImageAttribute Constructor
ToolboxImageAttribute Class See Also Send Feedback
Initializes a new instance of theToolboxImageAttribute class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public ToolboxImageAttribute(
    Type type
)
Visual Basic (Declaration)
Public Sub New ( _
    type As Type _
)
Visual C++
public:
ToolboxImageAttribute(
    Type^ type
)

Parameters

type
Type: System..::.Type

See Also

ToolboxImageAttribute Class
PerpetuumSoft.Framework.Drawing Namespace


ToolboxImageAttribute Methods

[image] [image]

.NET ModelKit Suite ClassReference
ToolboxImageAttribute Methods
ToolboxImageAttribute Class See Also Send Feedback

The ToolboxImageAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetImage | Overloaded.
GetSmallImage | Gets the image which corresponds to the lowest displaying mode.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ToolboxImageAttribute Class
PerpetuumSoft.Framework.Drawing Namespace


GetImage Method

[image] [image]

.NET ModelKit Suite ClassReference
ToolboxImageAttribute..::.GetImage Method
ToolboxImageAttribute Class See Also Send Feedback

Overload List

Name | Description
GetImage(ToolButtonsDisplayMode) | Gets the image by the set displaying mode.
GetImage(Type, ToolButtonsDisplayMode) |

See Also

ToolboxImageAttribute Class
ToolboxImageAttribute Members
PerpetuumSoft.Framework.Drawing Namespace


GetImage Method (ToolButtonsDisplayMode)

[image]

.NET ModelKit Suite ClassReference
ToolboxImageAttribute..::.GetImage Method (ToolButtonsDisplayMode)
ToolboxImageAttribute Class See Also Send Feedback
Gets the image by the set displaying mode.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Image GetImage(
    ToolButtonsDisplayMode mode
)
Visual Basic (Declaration)
Public Function GetImage ( _
    mode As ToolButtonsDisplayMode _
) As Image
Visual C++
public:
Image^ GetImage(
    ToolButtonsDisplayMode mode
)

Parameters

mode
Type: PerpetuumSoft.Framework.Drawing..::.ToolButtonsDisplayMode

See Also

ToolboxImageAttribute Class
GetImage Overload
PerpetuumSoft.Framework.Drawing Namespace


GetImage Method (Type, ToolButtonsDisplayMode)

[image]

.NET ModelKit Suite ClassReference
ToolboxImageAttribute..::.GetImage Method (Type, ToolButtonsDisplayMode)
ToolboxImageAttribute Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.ToolboxImageAttribute.GetImage(System.Type,PerpetuumSoft.Framework.Drawing.ToolButtonsDisplayMode)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Image GetImage(
    Type controlType,
    ToolButtonsDisplayMode mode
)
Visual Basic (Declaration)
Public Shared Function GetImage ( _
    controlType As Type, _
    mode As ToolButtonsDisplayMode _
) As Image
Visual C++
public:
static Image^ GetImage(
    Type^ controlType,
    ToolButtonsDisplayMode mode
)

Parameters

controlType
Type: System..::.Type
mode
Type: PerpetuumSoft.Framework.Drawing..::.ToolButtonsDisplayMode

See Also

ToolboxImageAttribute Class
GetImage Overload
PerpetuumSoft.Framework.Drawing Namespace


GetSmallImage Method

[image]

.NET ModelKit Suite ClassReference
ToolboxImageAttribute..::.GetSmallImage Method
ToolboxImageAttribute Class See Also Send Feedback
Gets the image which corresponds to the lowest displaying mode.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Image GetSmallImage()
Visual Basic (Declaration)
Public Function GetSmallImage As Image
Visual C++
public:
Image^ GetSmallImage()

See Also

ToolboxImageAttribute Class
PerpetuumSoft.Framework.Drawing Namespace


ToolboxImageAttribute Properties

[image] [image]

.NET ModelKit Suite ClassReference
ToolboxImageAttribute Properties
ToolboxImageAttribute Class See Also Send Feedback

The ToolboxImageAttribute type exposes the following members.

Properties

Name | Description
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ToolboxImageAttribute Class
PerpetuumSoft.Framework.Drawing Namespace


ToolButtonsDisplayMode Enumeration

[image]

.NET ModelKit Suite ClassReference
ToolButtonsDisplayMode Enumeration
See Also Send Feedback
Enumerates icon displaying modes.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public enum ToolButtonsDisplayMode
Visual Basic (Declaration)
Public Enumeration ToolButtonsDisplayMode
Visual C++
public enum class ToolButtonsDisplayMode

Members

Member name | Description
Small |
Medium |
Large |

See Also

PerpetuumSoft.Framework.Drawing Namespace


Unit Structure

[image]

.NET ModelKit Suite ClassReference
Unit Structure
Members See Also Send Feedback
Incapsulates properties of a measure unit.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public struct Unit
Visual Basic (Declaration)
Public Structure Unit
Visual C++
public value class Unit

See Also

Unit Members
PerpetuumSoft.Framework.Drawing Namespace


Unit Members

[image] [image]

.NET ModelKit Suite ClassReference
Unit Members
Unit Structure Constructors Methods Fields Properties See Also Send Feedback

The Unit type exposes the following members.

Constructors

Name | Description
Unit | Initializes a new instance of the Unit class.

Methods

Name | Description
Convert | Converts a value from one specified measure unit to another.
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromName | Creates unit from name.
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetStandardUnits |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality |
Inequality |

Fields

Name | Description
StandardGraphicsUnit | Graphics unit used as the basis.

Properties

Name | Description
Centimeter | Predefined the measure unit equal to a centimeter.
Inch | Predefined the measure unit equal to an inch.
InternalUnit | Predefined the measure unit that is used for internal representation of sizes within the objects of the report generator.
K | Gets ratio of the measure unit to the internal unit.
Millimeter | Predefined the measure unit equal to a millimeter.
Name | Gets the name of a measure unit.
Pixel | Predefined the measure unit equal to an pixel.
Point | Predefined the measure unit equal to an point.
ShortName | Gets the short name of measure unit.
Twip | Predefined the measure unit equal to an twip.

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


Unit Constructor

[image]

.NET ModelKit Suite ClassReference
Unit Constructor
Unit Structure See Also Send Feedback
Initializes a new instance of the Unit class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Unit(
    string name,
    string shortName,
    double k
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    shortName As String, _
    k As Double _
)
Visual C++
public:
Unit(
    String^ name,
    String^ shortName,
    double k
)

Parameters

name
Type: System..::.String
shortName
Type: System..::.String
k
Type: System..::.Double

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


Unit Fields

[image] [image]

.NET ModelKit Suite ClassReference
Unit Fields
Unit Structure See Also Send Feedback

The Unit type exposes the following members.

Fields

Name | Description
StandardGraphicsUnit | Graphics unit used as the basis.

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


StandardGraphicsUnit Field

[image]

.NET ModelKit Suite ClassReference
Unit..::.StandardGraphicsUnit Field
Unit Structure See Also Send Feedback
Graphics unit used as the basis.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public const GraphicsUnit StandardGraphicsUnit
Visual Basic (Declaration)
Public Const StandardGraphicsUnit As GraphicsUnit
Visual C++
public:
literal GraphicsUnit StandardGraphicsUnit

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


Unit Methods

[image] [image]

.NET ModelKit Suite ClassReference
Unit Methods
Unit Structure See Also Send Feedback

The Unit type exposes the following members.

Methods

Name | Description
Convert | Converts a value from one specified measure unit to another.
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromName | Creates unit from name.
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetStandardUnits |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Equality |
Inequality |

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


Convert Method

[image]

.NET ModelKit Suite ClassReference
Unit..::.Convert Method
Unit Structure See Also Send Feedback
Converts a value from one specified measure unit to another.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static double Convert(
    double value,
    Unit fromUnit,
    Unit toUnit
)
Visual Basic (Declaration)
Public Shared Function Convert ( _
    value As Double, _
    fromUnit As Unit, _
    toUnit As Unit _
) As Double
Visual C++
public:
static double Convert(
    double value,
    Unit fromUnit,
    Unit toUnit
)

Parameters

value
Type: System..::.Double
fromUnit
Type: PerpetuumSoft.Framework.Drawing..::.Unit
toUnit
Type: PerpetuumSoft.Framework.Drawing..::.Unit

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


Equality Operator

[image]

.NET ModelKit Suite ClassReference
Unit..::.Equality Operator
Unit Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Unit.op_Equality(PerpetuumSoft.Framework.Drawing.Unit,PerpetuumSoft.Framework.Drawing.Unit)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static bool operator ==(
    Unit unit1,
    Unit unit2
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    unit1 As Unit, _
    unit2 As Unit _
) As Boolean
Visual C++
public:
static bool operator ==(
    Unit unit1,
    Unit unit2
)

Parameters

unit1
Type: PerpetuumSoft.Framework.Drawing..::.Unit
unit2
Type: PerpetuumSoft.Framework.Drawing..::.Unit

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
Unit..::.Equals Method
Unit Structure See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


FromName Method

[image]

.NET ModelKit Suite ClassReference
Unit..::.FromName Method
Unit Structure See Also Send Feedback
Creates unit from name.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Unit FromName(
    string name
)
Visual Basic (Declaration)
Public Shared Function FromName ( _
    name As String _
) As Unit
Visual C++
public:
static Unit FromName(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
Unit..::.GetHashCode Method
Unit Structure See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


GetStandardUnits Method

[image]

.NET ModelKit Suite ClassReference
Unit..::.GetStandardUnits Method
Unit Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Unit.GetStandardUnits]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Unit[] GetStandardUnits()
Visual Basic (Declaration)
Public Shared Function GetStandardUnits As Unit()
Visual C++
public:
static array<Unit>^ GetStandardUnits()

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


Inequality Operator

[image]

.NET ModelKit Suite ClassReference
Unit..::.Inequality Operator
Unit Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Unit.op_Inequality(PerpetuumSoft.Framework.Drawing.Unit,PerpetuumSoft.Framework.Drawing.Unit)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static bool operator !=(
    Unit unit1,
    Unit unit2
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    unit1 As Unit, _
    unit2 As Unit _
) As Boolean
Visual C++
public:
static bool operator !=(
    Unit unit1,
    Unit unit2
)

Parameters

unit1
Type: PerpetuumSoft.Framework.Drawing..::.Unit
unit2
Type: PerpetuumSoft.Framework.Drawing..::.Unit

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
Unit..::.ToString Method
Unit Structure See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


Unit Properties

[image] [image]

.NET ModelKit Suite ClassReference
Unit Properties
Unit Structure See Also Send Feedback

The Unit type exposes the following members.

Properties

Name | Description
Centimeter | Predefined the measure unit equal to a centimeter.
Inch | Predefined the measure unit equal to an inch.
InternalUnit | Predefined the measure unit that is used for internal representation of sizes within the objects of the report generator.
K | Gets ratio of the measure unit to the internal unit.
Millimeter | Predefined the measure unit equal to a millimeter.
Name | Gets the name of a measure unit.
Pixel | Predefined the measure unit equal to an pixel.
Point | Predefined the measure unit equal to an point.
ShortName | Gets the short name of measure unit.
Twip | Predefined the measure unit equal to an twip.

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


Centimeter Property

[image]

.NET ModelKit Suite ClassReference
Unit..::.Centimeter Property
Unit Structure See Also Send Feedback
Predefined the measure unit equal to a centimeter.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Unit Centimeter { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Centimeter As Unit
Visual C++
public:
static property Unit Centimeter {
    Unit get ();
}

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


Inch Property

[image]

.NET ModelKit Suite ClassReference
Unit..::.Inch Property
Unit Structure See Also Send Feedback
Predefined the measure unit equal to an inch.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Unit Inch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Inch As Unit
Visual C++
public:
static property Unit Inch {
    Unit get ();
}

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


InternalUnit Property

[image]

.NET ModelKit Suite ClassReference
Unit..::.InternalUnit Property
Unit Structure See Also Send Feedback
Predefined the measure unit that is used for internal representation of sizes within the objects of the report generator.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Unit InternalUnit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InternalUnit As Unit
Visual C++
public:
static property Unit InternalUnit {
    Unit get ();
}

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


K Property

[image]

.NET ModelKit Suite ClassReference
Unit..::.K Property
Unit Structure See Also Send Feedback
Gets ratio of the measure unit to the internal unit.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double K { get; }
Visual Basic (Declaration)
Public ReadOnly Property K As Double
Visual C++
public:
property double K {
    double get ();
}

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


Millimeter Property

[image]

.NET ModelKit Suite ClassReference
Unit..::.Millimeter Property
Unit Structure See Also Send Feedback
Predefined the measure unit equal to a millimeter.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Unit Millimeter { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Millimeter As Unit
Visual C++
public:
static property Unit Millimeter {
    Unit get ();
}

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


Name Property

[image]

.NET ModelKit Suite ClassReference
Unit..::.Name Property
Unit Structure See Also Send Feedback
Gets the name of a measure unit.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


Pixel Property

[image]

.NET ModelKit Suite ClassReference
Unit..::.Pixel Property
Unit Structure See Also Send Feedback
Predefined the measure unit equal to an pixel.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Unit Pixel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Pixel As Unit
Visual C++
public:
static property Unit Pixel {
    Unit get ();
}

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


Point Property

[image]

.NET ModelKit Suite ClassReference
Unit..::.Point Property
Unit Structure See Also Send Feedback
Predefined the measure unit equal to an point.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Unit Point { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Point As Unit
Visual C++
public:
static property Unit Point {
    Unit get ();
}

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


ShortName Property

[image]

.NET ModelKit Suite ClassReference
Unit..::.ShortName Property
Unit Structure See Also Send Feedback
Gets the short name of measure unit.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public string ShortName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShortName As String
Visual C++
public:
property String^ ShortName {
    String^ get ();
}

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


Twip Property

[image]

.NET ModelKit Suite ClassReference
Unit..::.Twip Property
Unit Structure See Also Send Feedback
Predefined the measure unit equal to an twip.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Unit Twip { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Twip As Unit
Visual C++
public:
static property Unit Twip {
    Unit get ();
}

See Also

Unit Structure
PerpetuumSoft.Framework.Drawing Namespace


Vector Structure

[image]

.NET ModelKit Suite ClassReference
Vector Structure
Members See Also Send Feedback
Defines the properties of vectors on a plane and operations on these vectors.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public struct Vector
Visual Basic (Declaration)
Public Structure Vector
Visual C++
public value class Vector

See Also

Vector Members
PerpetuumSoft.Framework.Drawing Namespace


Vector Members

[image] [image]

.NET ModelKit Suite ClassReference
Vector Members
Vector Structure Constructors Methods Properties See Also Send Feedback

The Vector type exposes the following members.

Constructors

Name | Description
Vector | Overloaded.

Methods

Name | Description
Abs | Returns the modulus of the vector.
ConvertUnits | Converts the vector from one specified measure units to another.
CrossProduct | Returns vectors cross product.
DotProduct | Returns vectors dot product.
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromPolar | Creates vector from polar coordinates.
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetNormalized | Returns a unit vector.
GetPerpendicular | Returns the vector that is perpendicular for this.
GetProjection | Returns the projection of this vector on the vector specified by parameters.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Quant | Snaps the vector to a grid with the specifed cell size.
QuantX | Snaps the X-component to a grid with the specified x-size of a cell.
QuantY | Snaps the Y-component to a grid with the specified y-size of a cell.
Rotate | Rotates the vector on the given angle in radians.
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Operators

Name | Description
Addition |
Division |
Equality |
ExclusiveOr |
Explicit | Overloaded.
Implicit | Overloaded.
Inequality |
Multiply | Overloaded.
Subtraction |
UnaryNegation |
UnaryPlus |

Properties

Name | Description
Empty | Defines a "null"-vector.
Height | Gets or sets the "height" duplicates the Y-value.
IsEmpty | Returns true if this is a "null"-vector.
Item | Gets or sets a value of the specified vector coordinate.
Length | Gets or sets the length of the vector.
Rotation | Gets or sets rotation angle in radians.
Width | Gets or sets the "width" duplicates the X-value.
X | Gets or sets X-component of the vector.
Y | Gets or sets Y-component of the vector.

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


Vector Constructor

[image] [image]

.NET ModelKit Suite ClassReference
Vector Constructor
Vector Structure See Also Send Feedback

Overload List

Name | Description
Vector(Point) | Constructs a vector for the specified point.
Vector(PointF) | Constructs a vector for the specified point.
Vector(Size) | Constructs a vector for the specified integer size.
Vector(SizeF) | Constructs a vector for the specified integer size.
Vector(Double, Double) | Constructs a vector using the specified coordinate values.

See Also

Vector Structure
Vector Members
PerpetuumSoft.Framework.Drawing Namespace


Vector Constructor (Point)

[image]

.NET ModelKit Suite ClassReference
Vector Constructor (Point)
Vector Structure See Also Send Feedback
Constructs a vector for the specified point.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector(
    Point point
)
Visual Basic (Declaration)
Public Sub New ( _
    point As Point _
)
Visual C++
public:
Vector(
    Point point
)

Parameters

point
Type: System.Drawing..::.Point

See Also

Vector Structure
Vector Overload
PerpetuumSoft.Framework.Drawing Namespace


Vector Constructor (PointF)

[image]

.NET ModelKit Suite ClassReference
Vector Constructor (PointF)
Vector Structure See Also Send Feedback
Constructs a vector for the specified point.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector(
    PointF point
)
Visual Basic (Declaration)
Public Sub New ( _
    point As PointF _
)
Visual C++
public:
Vector(
    PointF point
)

Parameters

point
Type: System.Drawing..::.PointF

See Also

Vector Structure
Vector Overload
PerpetuumSoft.Framework.Drawing Namespace


Vector Constructor (Size)

[image]

.NET ModelKit Suite ClassReference
Vector Constructor (Size)
Vector Structure See Also Send Feedback
Constructs a vector for the specified integer size.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector(
    Size size
)
Visual Basic (Declaration)
Public Sub New ( _
    size As Size _
)
Visual C++
public:
Vector(
    Size size
)

Parameters

size
Type: System.Drawing..::.Size

See Also

Vector Structure
Vector Overload
PerpetuumSoft.Framework.Drawing Namespace


Vector Constructor (SizeF)

[image]

.NET ModelKit Suite ClassReference
Vector Constructor (SizeF)
Vector Structure See Also Send Feedback
Constructs a vector for the specified integer size.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector(
    SizeF size
)
Visual Basic (Declaration)
Public Sub New ( _
    size As SizeF _
)
Visual C++
public:
Vector(
    SizeF size
)

Parameters

size
Type: System.Drawing..::.SizeF

See Also

Vector Structure
Vector Overload
PerpetuumSoft.Framework.Drawing Namespace


Vector Constructor (Double, Double)

[image]

.NET ModelKit Suite ClassReference
Vector Constructor (Double, Double)
Vector Structure See Also Send Feedback
Constructs a vector using the specified coordinate values.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector(
    double x,
    double y
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Double, _
    y As Double _
)
Visual C++
public:
Vector(
    double x,
    double y
)

Parameters

x
Type: System..::.Double
y
Type: System..::.Double

See Also

Vector Structure
Vector Overload
PerpetuumSoft.Framework.Drawing Namespace


Vector Methods

[image] [image]

.NET ModelKit Suite ClassReference
Vector Methods
Vector Structure See Also Send Feedback

The Vector type exposes the following members.

Methods

Name | Description
Abs | Returns the modulus of the vector.
ConvertUnits | Converts the vector from one specified measure units to another.
CrossProduct | Returns vectors cross product.
DotProduct | Returns vectors dot product.
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromPolar | Creates vector from polar coordinates.
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetNormalized | Returns a unit vector.
GetPerpendicular | Returns the vector that is perpendicular for this.
GetProjection | Returns the projection of this vector on the vector specified by parameters.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Quant | Snaps the vector to a grid with the specifed cell size.
QuantX | Snaps the X-component to a grid with the specified x-size of a cell.
QuantY | Snaps the Y-component to a grid with the specified y-size of a cell.
Rotate | Rotates the vector on the given angle in radians.
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Operators

Name | Description
Addition |
Division |
Equality |
ExclusiveOr |
Explicit | Overloaded.
Implicit | Overloaded.
Inequality |
Multiply | Overloaded.
Subtraction |
UnaryNegation |
UnaryPlus |

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


Abs Method

[image]

.NET ModelKit Suite ClassReference
Vector..::.Abs Method
Vector Structure See Also Send Feedback
Returns the modulus of the vector.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Abs()
Visual Basic (Declaration)
Public Function Abs As Double
Visual C++
public:
double Abs()

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


Addition Operator

[image]

.NET ModelKit Suite ClassReference
Vector..::.Addition Operator
Vector Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Vector.op_Addition(PerpetuumSoft.Framework.Drawing.Vector,PerpetuumSoft.Framework.Drawing.Vector)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Vector operator +(
    Vector a,
    Vector b
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    a As Vector, _
    b As Vector _
) As Vector
Visual C++
public:
static Vector operator +(
    Vector a,
    Vector b
)

Parameters

a
Type: PerpetuumSoft.Framework.Drawing..::.Vector
b
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


ConvertUnits Method

[image]

.NET ModelKit Suite ClassReference
Vector..::.ConvertUnits Method
Vector Structure See Also Send Feedback
Converts the vector from one specified measure units to another.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector ConvertUnits(
    Unit fromUnit,
    Unit toUnit
)
Visual Basic (Declaration)
Public Function ConvertUnits ( _
    fromUnit As Unit, _
    toUnit As Unit _
) As Vector
Visual C++
public:
Vector ConvertUnits(
    Unit fromUnit,
    Unit toUnit
)

Parameters

fromUnit
Type: PerpetuumSoft.Framework.Drawing..::.Unit
toUnit
Type: PerpetuumSoft.Framework.Drawing..::.Unit

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


CrossProduct Method

[image]

.NET ModelKit Suite ClassReference
Vector..::.CrossProduct Method
Vector Structure See Also Send Feedback
Returns vectors cross product.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double CrossProduct(
    Vector v
)
Visual Basic (Declaration)
Public Function CrossProduct ( _
    v As Vector _
) As Double
Visual C++
public:
double CrossProduct(
    Vector v
)

Parameters

v
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


Division Operator

[image]

.NET ModelKit Suite ClassReference
Vector..::.Division Operator
Vector Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Vector.op_Division(PerpetuumSoft.Framework.Drawing.Vector,System.Double)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Vector operator /(
    Vector v,
    double a
)
Visual Basic (Declaration)
Public Shared Operator / ( _
    v As Vector, _
    a As Double _
) As Vector
Visual C++
public:
static Vector operator /(
    Vector v,
    double a
)

Parameters

v
Type: PerpetuumSoft.Framework.Drawing..::.Vector
a
Type: System..::.Double

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


DotProduct Method

[image]

.NET ModelKit Suite ClassReference
Vector..::.DotProduct Method
Vector Structure See Also Send Feedback
Returns vectors dot product.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double DotProduct(
    Vector v
)
Visual Basic (Declaration)
Public Function DotProduct ( _
    v As Vector _
) As Double
Visual C++
public:
double DotProduct(
    Vector v
)

Parameters

v
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


Equality Operator

[image]

.NET ModelKit Suite ClassReference
Vector..::.Equality Operator
Vector Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Vector.op_Equality(PerpetuumSoft.Framework.Drawing.Vector,PerpetuumSoft.Framework.Drawing.Vector)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static bool operator ==(
    Vector v1,
    Vector v2
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    v1 As Vector, _
    v2 As Vector _
) As Boolean
Visual C++
public:
static bool operator ==(
    Vector v1,
    Vector v2
)

Parameters

v1
Type: PerpetuumSoft.Framework.Drawing..::.Vector
v2
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
Vector..::.Equals Method
Vector Structure See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


ExclusiveOr Operator

[image]

.NET ModelKit Suite ClassReference
Vector..::.ExclusiveOr Operator
Vector Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Vector.op_ExclusiveOr(PerpetuumSoft.Framework.Drawing.Vector,PerpetuumSoft.Framework.Drawing.Vector)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static double operator ^(
    Vector a,
    Vector b
)
Visual Basic (Declaration)
Public Shared Operator Xor ( _
    a As Vector, _
    b As Vector _
) As Double
Visual C++
public:
static double operator ^(
    Vector a,
    Vector b
)

Parameters

a
Type: PerpetuumSoft.Framework.Drawing..::.Vector
b
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


Explicit Method

[image] [image]

.NET ModelKit Suite ClassReference
Vector..::.Explicit Method
Vector Structure See Also Send Feedback

Overload List

Name | Description
Explicit(Vector) |
Explicit(Vector) |

See Also

Vector Structure
Vector Members
PerpetuumSoft.Framework.Drawing Namespace


Explicit Operator

[image]

.NET ModelKit Suite ClassReference
Vector..::.Explicit Operator
Vector Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Vector.op_Explicit(PerpetuumSoft.Framework.Drawing.Vector)~System.Drawing.Size]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static explicit operator Size (
    Vector vector
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    vector As Vector _
) As Size
Visual C++
static explicit operator Size (
    Vector vector
)

Parameters

vector
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Vector Structure
Explicit Overload
PerpetuumSoft.Framework.Drawing Namespace


Explicit Operator

[image]

.NET ModelKit Suite ClassReference
Vector..::.Explicit Operator
Vector Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Vector.op_Explicit(PerpetuumSoft.Framework.Drawing.Vector)~System.Drawing.Point]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static explicit operator Point (
    Vector vector
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    vector As Vector _
) As Point
Visual C++
static explicit operator Point (
    Vector vector
)

Parameters

vector
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Vector Structure
Explicit Overload
PerpetuumSoft.Framework.Drawing Namespace


FromPolar Method

[image]

.NET ModelKit Suite ClassReference
Vector..::.FromPolar Method
Vector Structure See Also Send Feedback
Creates vector from polar coordinates.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Vector FromPolar(
    double Length,
    double angle
)
Visual Basic (Declaration)
Public Shared Function FromPolar ( _
    Length As Double, _
    angle As Double _
) As Vector
Visual C++
public:
static Vector FromPolar(
    double Length,
    double angle
)

Parameters

Length
Type: System..::.Double
angle
Type: System..::.Double

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
Vector..::.GetHashCode Method
Vector Structure See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


GetNormalized Method

[image]

.NET ModelKit Suite ClassReference
Vector..::.GetNormalized Method
Vector Structure See Also Send Feedback
Returns a unit vector.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector GetNormalized()
Visual Basic (Declaration)
Public Function GetNormalized As Vector
Visual C++
public:
Vector GetNormalized()

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


GetPerpendicular Method

[image]

.NET ModelKit Suite ClassReference
Vector..::.GetPerpendicular Method
Vector Structure See Also Send Feedback
Returns the vector that is perpendicular for this.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector GetPerpendicular()
Visual Basic (Declaration)
Public Function GetPerpendicular As Vector
Visual C++
public:
Vector GetPerpendicular()

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


GetProjection Method

[image]

.NET ModelKit Suite ClassReference
Vector..::.GetProjection Method
Vector Structure See Also Send Feedback
Returns the projection of this vector on the vector specified by parameters.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector GetProjection(
    Vector startPoint,
    Vector endPoint
)
Visual Basic (Declaration)
Public Function GetProjection ( _
    startPoint As Vector, _
    endPoint As Vector _
) As Vector
Visual C++
public:
Vector GetProjection(
    Vector startPoint,
    Vector endPoint
)

Parameters

startPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
endPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


Implicit Method

[image] [image]

.NET ModelKit Suite ClassReference
Vector..::.Implicit Method
Vector Structure See Also Send Feedback

Overload List

Name | Description
Implicit(Vector) |
Implicit(Vector) |
Implicit(Point) |
Implicit(PointF) |
Implicit(Size) |
Implicit(SizeF) |

See Also

Vector Structure
Vector Members
PerpetuumSoft.Framework.Drawing Namespace


Implicit Operator

[image]

.NET ModelKit Suite ClassReference
Vector..::.Implicit Operator
Vector Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Vector.op_Implicit(PerpetuumSoft.Framework.Drawing.Vector)~System.Drawing.SizeF]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static implicit operator SizeF (
    Vector vector
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    vector As Vector _
) As SizeF
Visual C++
static implicit operator SizeF (
    Vector vector
)

Parameters

vector
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Vector Structure
Implicit Overload
PerpetuumSoft.Framework.Drawing Namespace


Implicit Operator

[image]

.NET ModelKit Suite ClassReference
Vector..::.Implicit Operator
Vector Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Vector.op_Implicit(PerpetuumSoft.Framework.Drawing.Vector)~System.Drawing.PointF]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static implicit operator PointF (
    Vector vector
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    vector As Vector _
) As PointF
Visual C++
static implicit operator PointF (
    Vector vector
)

Parameters

vector
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Vector Structure
Implicit Overload
PerpetuumSoft.Framework.Drawing Namespace


Implicit Operator

[image]

.NET ModelKit Suite ClassReference
Vector..::.Implicit Operator
Vector Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Vector.op_Implicit(System.Drawing.Point)~PerpetuumSoft.Framework.Drawing.Vector]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static implicit operator Vector (
    Point point
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    point As Point _
) As Vector
Visual C++
static implicit operator Vector (
    Point point
)

Parameters

point
Type: System.Drawing..::.Point

See Also

Vector Structure
Implicit Overload
PerpetuumSoft.Framework.Drawing Namespace


Implicit Operator

[image]

.NET ModelKit Suite ClassReference
Vector..::.Implicit Operator
Vector Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Vector.op_Implicit(System.Drawing.PointF)~PerpetuumSoft.Framework.Drawing.Vector]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static implicit operator Vector (
    PointF point
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    point As PointF _
) As Vector
Visual C++
static implicit operator Vector (
    PointF point
)

Parameters

point
Type: System.Drawing..::.PointF

See Also

Vector Structure
Implicit Overload
PerpetuumSoft.Framework.Drawing Namespace


Implicit Operator

[image]

.NET ModelKit Suite ClassReference
Vector..::.Implicit Operator
Vector Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Vector.op_Implicit(System.Drawing.Size)~PerpetuumSoft.Framework.Drawing.Vector]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static implicit operator Vector (
    Size size
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    size As Size _
) As Vector
Visual C++
static implicit operator Vector (
    Size size
)

Parameters

size
Type: System.Drawing..::.Size

See Also

Vector Structure
Implicit Overload
PerpetuumSoft.Framework.Drawing Namespace


Implicit Operator

[image]

.NET ModelKit Suite ClassReference
Vector..::.Implicit Operator
Vector Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Vector.op_Implicit(System.Drawing.SizeF)~PerpetuumSoft.Framework.Drawing.Vector]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static implicit operator Vector (
    SizeF size
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    size As SizeF _
) As Vector
Visual C++
static implicit operator Vector (
    SizeF size
)

Parameters

size
Type: System.Drawing..::.SizeF

See Also

Vector Structure
Implicit Overload
PerpetuumSoft.Framework.Drawing Namespace


Inequality Operator

[image]

.NET ModelKit Suite ClassReference
Vector..::.Inequality Operator
Vector Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Vector.op_Inequality(PerpetuumSoft.Framework.Drawing.Vector,PerpetuumSoft.Framework.Drawing.Vector)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static bool operator !=(
    Vector v1,
    Vector v2
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    v1 As Vector, _
    v2 As Vector _
) As Boolean
Visual C++
public:
static bool operator !=(
    Vector v1,
    Vector v2
)

Parameters

v1
Type: PerpetuumSoft.Framework.Drawing..::.Vector
v2
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


Multiply Method

[image] [image]

.NET ModelKit Suite ClassReference
Vector..::.Multiply Method
Vector Structure See Also Send Feedback

Overload List

Name | Description
Multiply(Vector, Vector) |
Multiply(Vector, Double) |
Multiply(Double, Vector) |

See Also

Vector Structure
Vector Members
PerpetuumSoft.Framework.Drawing Namespace


Multiply Operator

[image]

.NET ModelKit Suite ClassReference
Vector..::.Multiply Operator
Vector Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Vector.op_Multiply(PerpetuumSoft.Framework.Drawing.Vector,PerpetuumSoft.Framework.Drawing.Vector)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static double operator *(
    Vector a,
    Vector b
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    a As Vector, _
    b As Vector _
) As Double
Visual C++
public:
static double operator *(
    Vector a,
    Vector b
)

Parameters

a
Type: PerpetuumSoft.Framework.Drawing..::.Vector
b
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Vector Structure
Multiply Overload
PerpetuumSoft.Framework.Drawing Namespace


Multiply Operator

[image]

.NET ModelKit Suite ClassReference
Vector..::.Multiply Operator
Vector Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Vector.op_Multiply(PerpetuumSoft.Framework.Drawing.Vector,System.Double)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Vector operator *(
    Vector v,
    double a
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    v As Vector, _
    a As Double _
) As Vector
Visual C++
public:
static Vector operator *(
    Vector v,
    double a
)

Parameters

v
Type: PerpetuumSoft.Framework.Drawing..::.Vector
a
Type: System..::.Double

See Also

Vector Structure
Multiply Overload
PerpetuumSoft.Framework.Drawing Namespace


Multiply Operator

[image]

.NET ModelKit Suite ClassReference
Vector..::.Multiply Operator
Vector Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Vector.op_Multiply(System.Double,PerpetuumSoft.Framework.Drawing.Vector)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Vector operator *(
    double a,
    Vector v
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    a As Double, _
    v As Vector _
) As Vector
Visual C++
public:
static Vector operator *(
    double a,
    Vector v
)

Parameters

a
Type: System..::.Double
v
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Vector Structure
Multiply Overload
PerpetuumSoft.Framework.Drawing Namespace


Quant Method

[image]

.NET ModelKit Suite ClassReference
Vector..::.Quant Method
Vector Structure See Also Send Feedback
Snaps the vector to a grid with the specifed cell size.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector Quant(
    double xGrid,
    double yGrid
)
Visual Basic (Declaration)
Public Function Quant ( _
    xGrid As Double, _
    yGrid As Double _
) As Vector
Visual C++
public:
Vector Quant(
    double xGrid,
    double yGrid
)

Parameters

xGrid
Type: System..::.Double
yGrid
Type: System..::.Double

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


QuantX Method

[image]

.NET ModelKit Suite ClassReference
Vector..::.QuantX Method
Vector Structure See Also Send Feedback
Snaps the X-component to a grid with the specified x-size of a cell.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector QuantX(
    double xGrid
)
Visual Basic (Declaration)
Public Function QuantX ( _
    xGrid As Double _
) As Vector
Visual C++
public:
Vector QuantX(
    double xGrid
)

Parameters

xGrid
Type: System..::.Double

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


QuantY Method

[image]

.NET ModelKit Suite ClassReference
Vector..::.QuantY Method
Vector Structure See Also Send Feedback
Snaps the Y-component to a grid with the specified y-size of a cell.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector QuantY(
    double yGrid
)
Visual Basic (Declaration)
Public Function QuantY ( _
    yGrid As Double _
) As Vector
Visual C++
public:
Vector QuantY(
    double yGrid
)

Parameters

yGrid
Type: System..::.Double

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


Rotate Method

[image]

.NET ModelKit Suite ClassReference
Vector..::.Rotate Method
Vector Structure See Also Send Feedback
Rotates the vector on the given angle in radians.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector Rotate(
    double angle
)
Visual Basic (Declaration)
Public Function Rotate ( _
    angle As Double _
) As Vector
Visual C++
public:
Vector Rotate(
    double angle
)

Parameters

angle
Type: System..::.Double

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


Subtraction Operator

[image]

.NET ModelKit Suite ClassReference
Vector..::.Subtraction Operator
Vector Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Vector.op_Subtraction(PerpetuumSoft.Framework.Drawing.Vector,PerpetuumSoft.Framework.Drawing.Vector)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Vector operator -(
    Vector a,
    Vector b
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    a As Vector, _
    b As Vector _
) As Vector
Visual C++
public:
static Vector operator -(
    Vector a,
    Vector b
)

Parameters

a
Type: PerpetuumSoft.Framework.Drawing..::.Vector
b
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


UnaryNegation Operator

[image]

.NET ModelKit Suite ClassReference
Vector..::.UnaryNegation Operator
Vector Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Vector.op_UnaryNegation(PerpetuumSoft.Framework.Drawing.Vector)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Vector operator -(
    Vector v
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    v As Vector _
) As Vector
Visual C++
public:
static Vector operator -(
    Vector v
)

Parameters

v
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


UnaryPlus Operator

[image]

.NET ModelKit Suite ClassReference
Vector..::.UnaryPlus Operator
Vector Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.Vector.op_UnaryPlus(PerpetuumSoft.Framework.Drawing.Vector)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Vector operator +(
    Vector v
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    v As Vector _
) As Vector
Visual C++
public:
static Vector operator +(
    Vector v
)

Parameters

v
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


Vector Properties

[image] [image]

.NET ModelKit Suite ClassReference
Vector Properties
Vector Structure See Also Send Feedback

The Vector type exposes the following members.

Properties

Name | Description
Empty | Defines a "null"-vector.
Height | Gets or sets the "height" duplicates the Y-value.
IsEmpty | Returns true if this is a "null"-vector.
Item | Gets or sets a value of the specified vector coordinate.
Length | Gets or sets the length of the vector.
Rotation | Gets or sets rotation angle in radians.
Width | Gets or sets the "width" duplicates the X-value.
X | Gets or sets X-component of the vector.
Y | Gets or sets Y-component of the vector.

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


Empty Property

[image]

.NET ModelKit Suite ClassReference
Vector..::.Empty Property
Vector Structure See Also Send Feedback
Defines a "null"-vector.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Vector Empty { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Empty As Vector
Visual C++
public:
static property Vector Empty {
    Vector get ();
}

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


Height Property

[image]

.NET ModelKit Suite ClassReference
Vector..::.Height Property
Vector Structure See Also Send Feedback
Gets or sets the "height" duplicates the Y-value.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Double
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


IsEmpty Property

[image]

.NET ModelKit Suite ClassReference
Vector..::.IsEmpty Property
Vector Structure See Also Send Feedback
Returns true if this is a "null"-vector.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
Vector..::.Item Property
Vector Structure See Also Send Feedback
Gets or sets a value of the specified vector coordinate.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double this[
    Direction d
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    d As Direction _
) As Double
Visual C++
public:
property double default[Direction d] {
    double get (Direction d);
    void set (Direction d, double value);
}

Parameters

d
Type: PerpetuumSoft.Framework.Drawing..::.Direction

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


Length Property

[image]

.NET ModelKit Suite ClassReference
Vector..::.Length Property
Vector Structure See Also Send Feedback
Gets or sets the length of the vector.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Length { get; set; }
Visual Basic (Declaration)
Public Property Length As Double
Visual C++
public:
property double Length {
    double get ();
    void set (double value);
}

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


Rotation Property

[image]

.NET ModelKit Suite ClassReference
Vector..::.Rotation Property
Vector Structure See Also Send Feedback
Gets or sets rotation angle in radians.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Rotation { get; set; }
Visual Basic (Declaration)
Public Property Rotation As Double
Visual C++
public:
property double Rotation {
    double get ();
    void set (double value);
}

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
Vector..::.Width Property
Vector Structure See Also Send Feedback
Gets or sets the "width" duplicates the X-value.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


X Property

[image]

.NET ModelKit Suite ClassReference
Vector..::.X Property
Vector Structure See Also Send Feedback
Gets or sets X-component of the vector.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double X { get; set; }
Visual Basic (Declaration)
Public Property X As Double
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


Y Property

[image]

.NET ModelKit Suite ClassReference
Vector..::.Y Property
Vector Structure See Also Send Feedback
Gets or sets Y-component of the vector.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Double
Visual C++
public:
property double Y {
    double get ();
    void set (double value);
}

See Also

Vector Structure
PerpetuumSoft.Framework.Drawing Namespace


VectorRectangle Structure

[image]

.NET ModelKit Suite ClassReference
VectorRectangle Structure
Members See Also Send Feedback
Defines the location and the size of a rectangle on a surface.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public struct VectorRectangle
Visual Basic (Declaration)
Public Structure VectorRectangle
Visual C++
public value class VectorRectangle

See Also

VectorRectangle Members
PerpetuumSoft.Framework.Drawing Namespace


VectorRectangle Members

[image] [image]

.NET ModelKit Suite ClassReference
VectorRectangle Members
VectorRectangle Structure Constructors Methods Properties See Also Send Feedback

The VectorRectangle type exposes the following members.

Constructors

Name | Description
VectorRectangle | Overloaded.

Methods

Name | Description
Contains | Returns whether the current VectorRectangle contains the specified point.
ConvertUnits | Converts the vector from one specified measure units to another.
Divide | Implements division by given scalar value.
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDistance | Returns the distance between the current VectorRectangle object and the given point.
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetPositiveRectangle | Returns a new VectorRectangle instance with the geometry identical to the current instance and with positive width and height values.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Returns a new VectorRectangle instance that is an intersection of the two specified VectorRectangle objects.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Multiply | Implements multiplication by given scalar value.
Quant | Aligns the current VectorRectangle instance using the specified grid steps.
QuantX | Aligns the current VectorRectangle instance horizontally using the specified grid x-step.
QuantY | Aligns the current VectorRectangle instance vertically using the specified grid y-step.
ToString | Overridden. See ToString()()(). (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Addition |
BitwiseAnd |
BitwiseOr |
Division |
Equality |
Explicit |
Implicit | Overloaded.
Inequality |
Multiply |
Subtraction |

Properties

Name | Description
Area | Gets the area of the current VectorRectangle object.
Bottom | Gets Y coordinate of the bottom side of the rectangle.
BottomCenter | Gets location of the center of the rectangle bottom side.
BottomLeft | Gets location of the bottom left corner of the rectangle.
BottomRight | Gets location of the bottom right corner of the rectangle.
Center | Gets location of the center of the rectangle.
CenterX | Gets X coordinate of the center of the rectangle.
CenterY | Gets Y coordinate of the center of the rectangle.
Empty | Returns the "null" rectangle.
Height | Gets or sets the height of the rectangle.
IsEmpty | Gets if width and height of the current VectorRectangle are zeros.
Left | Gets X coordinate of the left side of the rectangle.
LeftCenter | Gets location of the center of the rectangle left side.
Location | Gets or sets the location of the rectangle (the top left corner).
Right | Gets X coordinate of the right side of the rectangle.
RightCenter | Gets location of the center of the rectangle right side.
Size | Gets or sets the size of the rectangle.
Top | Gets Y coordinate of the top side of the rectangle.
TopCenter | Gets location of the center of the rectangle top side.
TopLeft | Gets location of the top left corner of the rectangle.
TopRight | Gets location of the top right corner of the rectangle.
Width | Gets or sets the width of the rectangle.
X | Gets or sets X coordinate of the top left corner of the rectangle.
Y | Gets or sets Y coordinate of the top left corner of the rectangle.

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


VectorRectangle Constructor

[image] [image]

.NET ModelKit Suite ClassReference
VectorRectangle Constructor
VectorRectangle Structure See Also Send Feedback

Overload List

Name | Description
VectorRectangle(Rectangle) | Initializes a new instance of the VectorRectangle class.
VectorRectangle(RectangleF) | Initializes a new instance of the VectorRectangle class.
VectorRectangle(Vector, Vector) | Initializes a new instance of the VectorRectangle class.
VectorRectangle(Double, Double, Double, Double) | Initializes a new instance of the VectorRectangle class.

See Also

VectorRectangle Structure
VectorRectangle Members
PerpetuumSoft.Framework.Drawing Namespace


VectorRectangle Constructor (Rectangle)

[image]

.NET ModelKit Suite ClassReference
VectorRectangle Constructor (Rectangle)
VectorRectangle Structure See Also Send Feedback
Initializes a new instance of the VectorRectangle class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle(
    Rectangle rect
)
Visual Basic (Declaration)
Public Sub New ( _
    rect As Rectangle _
)
Visual C++
public:
VectorRectangle(
    Rectangle rect
)

Parameters

rect
Type: System.Drawing..::.Rectangle

See Also

VectorRectangle Structure
VectorRectangle Overload
PerpetuumSoft.Framework.Drawing Namespace


VectorRectangle Constructor (RectangleF)

[image]

.NET ModelKit Suite ClassReference
VectorRectangle Constructor (RectangleF)
VectorRectangle Structure See Also Send Feedback
Initializes a new instance of the VectorRectangle class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle(
    RectangleF rect
)
Visual Basic (Declaration)
Public Sub New ( _
    rect As RectangleF _
)
Visual C++
public:
VectorRectangle(
    RectangleF rect
)

Parameters

rect
Type: System.Drawing..::.RectangleF

See Also

VectorRectangle Structure
VectorRectangle Overload
PerpetuumSoft.Framework.Drawing Namespace


VectorRectangle Constructor (Vector, Vector)

[image]

.NET ModelKit Suite ClassReference
VectorRectangle Constructor (Vector, Vector)
VectorRectangle Structure See Also Send Feedback
Initializes a new instance of the VectorRectangle class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle(
    Vector location,
    Vector size
)
Visual Basic (Declaration)
Public Sub New ( _
    location As Vector, _
    size As Vector _
)
Visual C++
public:
VectorRectangle(
    Vector location,
    Vector size
)

Parameters

location
Type: PerpetuumSoft.Framework.Drawing..::.Vector
size
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

VectorRectangle Structure
VectorRectangle Overload
PerpetuumSoft.Framework.Drawing Namespace


VectorRectangle Constructor (Double, Double, Double, Double)

[image]

.NET ModelKit Suite ClassReference
VectorRectangle Constructor (Double, Double, Double, Double)
VectorRectangle Structure See Also Send Feedback
Initializes a new instance of the VectorRectangle class.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle(
    double x,
    double y,
    double width,
    double height
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double _
)
Visual C++
public:
VectorRectangle(
    double x,
    double y,
    double width,
    double height
)

Parameters

x
Type: System..::.Double
y
Type: System..::.Double
width
Type: System..::.Double
height
Type: System..::.Double

See Also

VectorRectangle Structure
VectorRectangle Overload
PerpetuumSoft.Framework.Drawing Namespace


VectorRectangle Methods

[image] [image]

.NET ModelKit Suite ClassReference
VectorRectangle Methods
VectorRectangle Structure See Also Send Feedback

The VectorRectangle type exposes the following members.

Methods

Name | Description
Contains | Returns whether the current VectorRectangle contains the specified point.
ConvertUnits | Converts the vector from one specified measure units to another.
Divide | Implements division by given scalar value.
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDistance | Returns the distance between the current VectorRectangle object and the given point.
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetPositiveRectangle | Returns a new VectorRectangle instance with the geometry identical to the current instance and with positive width and height values.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersect | Returns a new VectorRectangle instance that is an intersection of the two specified VectorRectangle objects.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Multiply | Implements multiplication by given scalar value.
Quant | Aligns the current VectorRectangle instance using the specified grid steps.
QuantX | Aligns the current VectorRectangle instance horizontally using the specified grid x-step.
QuantY | Aligns the current VectorRectangle instance vertically using the specified grid y-step.
ToString | Overridden. See ToString()()(). (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
Addition |
BitwiseAnd |
BitwiseOr |
Division |
Equality |
Explicit |
Implicit | Overloaded.
Inequality |
Multiply |
Subtraction |

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Addition Operator

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Addition Operator
VectorRectangle Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.VectorRectangle.op_Addition(PerpetuumSoft.Framework.Drawing.VectorRectangle,PerpetuumSoft.Framework.Drawing.Margins)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static VectorRectangle operator +(
    VectorRectangle v,
    Margins m
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    v As VectorRectangle, _
    m As Margins _
) As VectorRectangle
Visual C++
public:
static VectorRectangle operator +(
    VectorRectangle v,
    Margins m
)

Parameters

v
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
m
Type: PerpetuumSoft.Framework.Drawing..::.Margins

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


BitwiseAnd Operator

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.BitwiseAnd Operator
VectorRectangle Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.VectorRectangle.op_BitwiseAnd(PerpetuumSoft.Framework.Drawing.VectorRectangle,PerpetuumSoft.Framework.Drawing.VectorRectangle)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static VectorRectangle operator &(
    VectorRectangle a,
    VectorRectangle b
)
Visual Basic (Declaration)
Public Shared Operator And ( _
    a As VectorRectangle, _
    b As VectorRectangle _
) As VectorRectangle
Visual C++
public:
static VectorRectangle operator &(
    VectorRectangle a,
    VectorRectangle b
)

Parameters

a
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
b
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


BitwiseOr Operator

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.BitwiseOr Operator
VectorRectangle Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.VectorRectangle.op_BitwiseOr(PerpetuumSoft.Framework.Drawing.VectorRectangle,PerpetuumSoft.Framework.Drawing.VectorRectangle)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static VectorRectangle operator |(
    VectorRectangle a,
    VectorRectangle b
)
Visual Basic (Declaration)
Public Shared Operator Or ( _
    a As VectorRectangle, _
    b As VectorRectangle _
) As VectorRectangle
Visual C++
public:
static VectorRectangle operator |(
    VectorRectangle a,
    VectorRectangle b
)

Parameters

a
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
b
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Contains Method
VectorRectangle Structure See Also Send Feedback
Returns whether the current VectorRectangle contains the specified point.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    Vector v
)
Visual Basic (Declaration)
Public Function Contains ( _
    v As Vector _
) As Boolean
Visual C++
public:
bool Contains(
    Vector v
)

Parameters

v
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


ConvertUnits Method

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.ConvertUnits Method
VectorRectangle Structure See Also Send Feedback
Converts the vector from one specified measure units to another.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle ConvertUnits(
    Unit fromUnit,
    Unit toUnit
)
Visual Basic (Declaration)
Public Function ConvertUnits ( _
    fromUnit As Unit, _
    toUnit As Unit _
) As VectorRectangle
Visual C++
public:
VectorRectangle ConvertUnits(
    Unit fromUnit,
    Unit toUnit
)

Parameters

fromUnit
Type: PerpetuumSoft.Framework.Drawing..::.Unit
toUnit
Type: PerpetuumSoft.Framework.Drawing..::.Unit

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Divide Method

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Divide Method
VectorRectangle Structure See Also Send Feedback
Implements division by given scalar value.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle Divide(
    double m
)
Visual Basic (Declaration)
Public Function Divide ( _
    m As Double _
) As VectorRectangle
Visual C++
public:
VectorRectangle Divide(
    double m
)

Parameters

m
Type: System..::.Double

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Division Operator

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Division Operator
VectorRectangle Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.VectorRectangle.op_Division(PerpetuumSoft.Framework.Drawing.VectorRectangle,System.Double)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static VectorRectangle operator /(
    VectorRectangle v,
    double m
)
Visual Basic (Declaration)
Public Shared Operator / ( _
    v As VectorRectangle, _
    m As Double _
) As VectorRectangle
Visual C++
public:
static VectorRectangle operator /(
    VectorRectangle v,
    double m
)

Parameters

v
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
m
Type: System..::.Double

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Equality Operator

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Equality Operator
VectorRectangle Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.VectorRectangle.op_Equality(PerpetuumSoft.Framework.Drawing.VectorRectangle,PerpetuumSoft.Framework.Drawing.VectorRectangle)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static bool operator ==(
    VectorRectangle v1,
    VectorRectangle v2
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    v1 As VectorRectangle, _
    v2 As VectorRectangle _
) As Boolean
Visual C++
public:
static bool operator ==(
    VectorRectangle v1,
    VectorRectangle v2
)

Parameters

v1
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
v2
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Equals Method
VectorRectangle Structure See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Explicit Operator

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Explicit Operator
VectorRectangle Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.VectorRectangle.op_Explicit(PerpetuumSoft.Framework.Drawing.VectorRectangle)~System.Drawing.Rectangle]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static explicit operator Rectangle (
    VectorRectangle rect
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    rect As VectorRectangle _
) As Rectangle
Visual C++
static explicit operator Rectangle (
    VectorRectangle rect
)

Parameters

rect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


GetDistance Method

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.GetDistance Method
VectorRectangle Structure See Also Send Feedback
Returns the distance between the current VectorRectangle object and the given point.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double GetDistance(
    Vector p
)
Visual Basic (Declaration)
Public Function GetDistance ( _
    p As Vector _
) As Double
Visual C++
public:
double GetDistance(
    Vector p
)

Parameters

p
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.GetHashCode Method
VectorRectangle Structure See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


GetPositiveRectangle Method

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.GetPositiveRectangle Method
VectorRectangle Structure See Also Send Feedback
Returns a new VectorRectangle instance with the geometry identical to the current instance and with positive width and height values.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle GetPositiveRectangle()
Visual Basic (Declaration)
Public Function GetPositiveRectangle As VectorRectangle
Visual C++
public:
VectorRectangle GetPositiveRectangle()

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Implicit Method

[image] [image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Implicit Method
VectorRectangle Structure See Also Send Feedback

Overload List

Name | Description
Implicit(VectorRectangle) |
Implicit(Rectangle) |
Implicit(RectangleF) |

See Also

VectorRectangle Structure
VectorRectangle Members
PerpetuumSoft.Framework.Drawing Namespace


Implicit Operator

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Implicit Operator
VectorRectangle Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.VectorRectangle.op_Implicit(PerpetuumSoft.Framework.Drawing.VectorRectangle)~System.Drawing.RectangleF]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static implicit operator RectangleF (
    VectorRectangle rect
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    rect As VectorRectangle _
) As RectangleF
Visual C++
static implicit operator RectangleF (
    VectorRectangle rect
)

Parameters

rect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

VectorRectangle Structure
Implicit Overload
PerpetuumSoft.Framework.Drawing Namespace


Implicit Operator

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Implicit Operator
VectorRectangle Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.VectorRectangle.op_Implicit(System.Drawing.Rectangle)~PerpetuumSoft.Framework.Drawing.VectorRectangle]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static implicit operator VectorRectangle (
    Rectangle rect
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    rect As Rectangle _
) As VectorRectangle
Visual C++
static implicit operator VectorRectangle (
    Rectangle rect
)

Parameters

rect
Type: System.Drawing..::.Rectangle

See Also

VectorRectangle Structure
Implicit Overload
PerpetuumSoft.Framework.Drawing Namespace


Implicit Operator

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Implicit Operator
VectorRectangle Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.VectorRectangle.op_Implicit(System.Drawing.RectangleF)~PerpetuumSoft.Framework.Drawing.VectorRectangle]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static implicit operator VectorRectangle (
    RectangleF rect
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    rect As RectangleF _
) As VectorRectangle
Visual C++
static implicit operator VectorRectangle (
    RectangleF rect
)

Parameters

rect
Type: System.Drawing..::.RectangleF

See Also

VectorRectangle Structure
Implicit Overload
PerpetuumSoft.Framework.Drawing Namespace


Inequality Operator

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Inequality Operator
VectorRectangle Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.VectorRectangle.op_Inequality(PerpetuumSoft.Framework.Drawing.VectorRectangle,PerpetuumSoft.Framework.Drawing.VectorRectangle)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static bool operator !=(
    VectorRectangle v1,
    VectorRectangle v2
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    v1 As VectorRectangle, _
    v2 As VectorRectangle _
) As Boolean
Visual C++
public:
static bool operator !=(
    VectorRectangle v1,
    VectorRectangle v2
)

Parameters

v1
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
v2
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Intersect Method

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Intersect Method
VectorRectangle Structure See Also Send Feedback
Returns a new VectorRectangle instance that is an intersection of the two specified VectorRectangle objects.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static VectorRectangle Intersect(
    VectorRectangle a,
    VectorRectangle b
)
Visual Basic (Declaration)
Public Shared Function Intersect ( _
    a As VectorRectangle, _
    b As VectorRectangle _
) As VectorRectangle
Visual C++
public:
static VectorRectangle Intersect(
    VectorRectangle a,
    VectorRectangle b
)

Parameters

a
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
b
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Multiply Method

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Multiply Method
VectorRectangle Structure See Also Send Feedback
Implements multiplication by given scalar value.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle Multiply(
    double m
)
Visual Basic (Declaration)
Public Function Multiply ( _
    m As Double _
) As VectorRectangle
Visual C++
public:
VectorRectangle Multiply(
    double m
)

Parameters

m
Type: System..::.Double

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Multiply Operator

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Multiply Operator
VectorRectangle Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.VectorRectangle.op_Multiply(PerpetuumSoft.Framework.Drawing.VectorRectangle,System.Double)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static VectorRectangle operator *(
    VectorRectangle v,
    double m
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    v As VectorRectangle, _
    m As Double _
) As VectorRectangle
Visual C++
public:
static VectorRectangle operator *(
    VectorRectangle v,
    double m
)

Parameters

v
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
m
Type: System..::.Double

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Quant Method

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Quant Method
VectorRectangle Structure See Also Send Feedback
Aligns the current VectorRectangle instance using the specified grid steps.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle Quant(
    double xGrid,
    double yGrid
)
Visual Basic (Declaration)
Public Function Quant ( _
    xGrid As Double, _
    yGrid As Double _
) As VectorRectangle
Visual C++
public:
VectorRectangle Quant(
    double xGrid,
    double yGrid
)

Parameters

xGrid
Type: System..::.Double
yGrid
Type: System..::.Double

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


QuantX Method

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.QuantX Method
VectorRectangle Structure See Also Send Feedback
Aligns the current VectorRectangle instance horizontally using the specified grid x-step.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle QuantX(
    double xGrid
)
Visual Basic (Declaration)
Public Function QuantX ( _
    xGrid As Double _
) As VectorRectangle
Visual C++
public:
VectorRectangle QuantX(
    double xGrid
)

Parameters

xGrid
Type: System..::.Double

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


QuantY Method

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.QuantY Method
VectorRectangle Structure See Also Send Feedback
Aligns the current VectorRectangle instance vertically using the specified grid y-step.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle QuantY(
    double yGrid
)
Visual Basic (Declaration)
Public Function QuantY ( _
    yGrid As Double _
) As VectorRectangle
Visual C++
public:
VectorRectangle QuantY(
    double yGrid
)

Parameters

yGrid
Type: System..::.Double

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Subtraction Operator

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Subtraction Operator
VectorRectangle Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.VectorRectangle.op_Subtraction(PerpetuumSoft.Framework.Drawing.VectorRectangle,PerpetuumSoft.Framework.Drawing.Margins)]

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static VectorRectangle operator -(
    VectorRectangle v,
    Margins m
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    v As VectorRectangle, _
    m As Margins _
) As VectorRectangle
Visual C++
public:
static VectorRectangle operator -(
    VectorRectangle v,
    Margins m
)

Parameters

v
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
m
Type: PerpetuumSoft.Framework.Drawing..::.Margins

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.ToString Method
VectorRectangle Structure See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


VectorRectangle Properties

[image] [image]

.NET ModelKit Suite ClassReference
VectorRectangle Properties
VectorRectangle Structure See Also Send Feedback

The VectorRectangle type exposes the following members.

Properties

Name | Description
Area | Gets the area of the current VectorRectangle object.
Bottom | Gets Y coordinate of the bottom side of the rectangle.
BottomCenter | Gets location of the center of the rectangle bottom side.
BottomLeft | Gets location of the bottom left corner of the rectangle.
BottomRight | Gets location of the bottom right corner of the rectangle.
Center | Gets location of the center of the rectangle.
CenterX | Gets X coordinate of the center of the rectangle.
CenterY | Gets Y coordinate of the center of the rectangle.
Empty | Returns the "null" rectangle.
Height | Gets or sets the height of the rectangle.
IsEmpty | Gets if width and height of the current VectorRectangle are zeros.
Left | Gets X coordinate of the left side of the rectangle.
LeftCenter | Gets location of the center of the rectangle left side.
Location | Gets or sets the location of the rectangle (the top left corner).
Right | Gets X coordinate of the right side of the rectangle.
RightCenter | Gets location of the center of the rectangle right side.
Size | Gets or sets the size of the rectangle.
Top | Gets Y coordinate of the top side of the rectangle.
TopCenter | Gets location of the center of the rectangle top side.
TopLeft | Gets location of the top left corner of the rectangle.
TopRight | Gets location of the top right corner of the rectangle.
Width | Gets or sets the width of the rectangle.
X | Gets or sets X coordinate of the top left corner of the rectangle.
Y | Gets or sets Y coordinate of the top left corner of the rectangle.

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Area Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Area Property
VectorRectangle Structure See Also Send Feedback
Gets the area of the current VectorRectangle object.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Area { get; }
Visual Basic (Declaration)
Public ReadOnly Property Area As Double
Visual C++
public:
property double Area {
    double get ();
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Bottom Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Bottom Property
VectorRectangle Structure See Also Send Feedback
Gets Y coordinate of the bottom side of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Bottom { get; }
Visual Basic (Declaration)
Public ReadOnly Property Bottom As Double
Visual C++
public:
property double Bottom {
    double get ();
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


BottomCenter Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.BottomCenter Property
VectorRectangle Structure See Also Send Feedback
Gets location of the center of the rectangle bottom side.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector BottomCenter { get; }
Visual Basic (Declaration)
Public ReadOnly Property BottomCenter As Vector
Visual C++
public:
property Vector BottomCenter {
    Vector get ();
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


BottomLeft Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.BottomLeft Property
VectorRectangle Structure See Also Send Feedback
Gets location of the bottom left corner of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector BottomLeft { get; }
Visual Basic (Declaration)
Public ReadOnly Property BottomLeft As Vector
Visual C++
public:
property Vector BottomLeft {
    Vector get ();
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


BottomRight Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.BottomRight Property
VectorRectangle Structure See Also Send Feedback
Gets location of the bottom right corner of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector BottomRight { get; }
Visual Basic (Declaration)
Public ReadOnly Property BottomRight As Vector
Visual C++
public:
property Vector BottomRight {
    Vector get ();
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Center Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Center Property
VectorRectangle Structure See Also Send Feedback
Gets location of the center of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector Center { get; }
Visual Basic (Declaration)
Public ReadOnly Property Center As Vector
Visual C++
public:
property Vector Center {
    Vector get ();
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


CenterX Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.CenterX Property
VectorRectangle Structure See Also Send Feedback
Gets X coordinate of the center of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double CenterX { get; }
Visual Basic (Declaration)
Public ReadOnly Property CenterX As Double
Visual C++
public:
property double CenterX {
    double get ();
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


CenterY Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.CenterY Property
VectorRectangle Structure See Also Send Feedback
Gets Y coordinate of the center of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double CenterY { get; }
Visual Basic (Declaration)
Public ReadOnly Property CenterY As Double
Visual C++
public:
property double CenterY {
    double get ();
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Empty Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Empty Property
VectorRectangle Structure See Also Send Feedback
Returns the "null" rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static VectorRectangle Empty { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Empty As VectorRectangle
Visual C++
public:
static property VectorRectangle Empty {
    VectorRectangle get ();
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Height Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Height Property
VectorRectangle Structure See Also Send Feedback
Gets or sets the height of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Double
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


IsEmpty Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.IsEmpty Property
VectorRectangle Structure See Also Send Feedback
Gets if width and height of the current VectorRectangle are zeros.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Left Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Left Property
VectorRectangle Structure See Also Send Feedback
Gets X coordinate of the left side of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Left { get; }
Visual Basic (Declaration)
Public ReadOnly Property Left As Double
Visual C++
public:
property double Left {
    double get ();
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


LeftCenter Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.LeftCenter Property
VectorRectangle Structure See Also Send Feedback
Gets location of the center of the rectangle left side.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector LeftCenter { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeftCenter As Vector
Visual C++
public:
property Vector LeftCenter {
    Vector get ();
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Location Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Location Property
VectorRectangle Structure See Also Send Feedback
Gets or sets the location of the rectangle (the top left corner).

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector Location { get; set; }
Visual Basic (Declaration)
Public Property Location As Vector
Visual C++
public:
property Vector Location {
    Vector get ();
    void set (Vector value);
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Right Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Right Property
VectorRectangle Structure See Also Send Feedback
Gets X coordinate of the right side of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Right { get; }
Visual Basic (Declaration)
Public ReadOnly Property Right As Double
Visual C++
public:
property double Right {
    double get ();
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


RightCenter Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.RightCenter Property
VectorRectangle Structure See Also Send Feedback
Gets location of the center of the rectangle right side.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector RightCenter { get; }
Visual Basic (Declaration)
Public ReadOnly Property RightCenter As Vector
Visual C++
public:
property Vector RightCenter {
    Vector get ();
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Size Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Size Property
VectorRectangle Structure See Also Send Feedback
Gets or sets the size of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector Size { get; set; }
Visual Basic (Declaration)
Public Property Size As Vector
Visual C++
public:
property Vector Size {
    Vector get ();
    void set (Vector value);
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Top Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Top Property
VectorRectangle Structure See Also Send Feedback
Gets Y coordinate of the top side of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Top { get; }
Visual Basic (Declaration)
Public ReadOnly Property Top As Double
Visual C++
public:
property double Top {
    double get ();
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


TopCenter Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.TopCenter Property
VectorRectangle Structure See Also Send Feedback
Gets location of the center of the rectangle top side.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector TopCenter { get; }
Visual Basic (Declaration)
Public ReadOnly Property TopCenter As Vector
Visual C++
public:
property Vector TopCenter {
    Vector get ();
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


TopLeft Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.TopLeft Property
VectorRectangle Structure See Also Send Feedback
Gets location of the top left corner of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector TopLeft { get; }
Visual Basic (Declaration)
Public ReadOnly Property TopLeft As Vector
Visual C++
public:
property Vector TopLeft {
    Vector get ();
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


TopRight Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.TopRight Property
VectorRectangle Structure See Also Send Feedback
Gets location of the top right corner of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Vector TopRight { get; }
Visual Basic (Declaration)
Public ReadOnly Property TopRight As Vector
Visual C++
public:
property Vector TopRight {
    Vector get ();
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Width Property
VectorRectangle Structure See Also Send Feedback
Gets or sets the width of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


X Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.X Property
VectorRectangle Structure See Also Send Feedback
Gets or sets X coordinate of the top left corner of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double X { get; set; }
Visual Basic (Declaration)
Public Property X As Double
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


Y Property

[image]

.NET ModelKit Suite ClassReference
VectorRectangle..::.Y Property
VectorRectangle Structure See Also Send Feedback
Gets or sets Y coordinate of the top left corner of the rectangle.

Namespace: PerpetuumSoft.Framework.Drawing
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Double
Visual C++
public:
property double Y {
    double get ();
    void set (double value);
}

See Also

VectorRectangle Structure
PerpetuumSoft.Framework.Drawing Namespace


PerpetuumSoft.Framework.Drawing.Design Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Framework.Drawing.Design Namespace
Send Feedback
The PerpetuumSoft.Drawing.Design namespace contains classes that extend design-time user interface (UI) logic and drawing.

Classes

Class | Description
BorderEditorControl | Border editor control
FillChangedEventArgs | Contains information on the fill
FillEditorControl | Fill editor control
FillEditorForm | Fill editing form
MarginsEditorControl | Margins editor control
StrokeEditorControl | Stroke editor control

Interfaces

Interface | Description
IFillEditorControl | Provides methods for the Fill editing


BorderEditorControl Class

[image]

.NET ModelKit Suite ClassReference
BorderEditorControl Class
Members See Also Send Feedback
Border editor control

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class BorderEditorControl : UserControl
Visual Basic (Declaration)
Public Class BorderEditorControl _
    Inherits UserControl
Visual C++
public ref class BorderEditorControl : public UserControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Framework.Drawing.Design..::.BorderEditorControl

See Also

BorderEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


BorderEditorControl Members

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl Members
BorderEditorControl Class Constructors Methods Properties Events See Also Send Feedback

The BorderEditorControl type exposes the following members.

Constructors

Name | Description
BorderEditorControl | Initializes a new instance of the BorderEditorControl class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Border | Gets or sets Border
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

BorderEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


BorderEditorControl Constructor

[image]

.NET ModelKit Suite ClassReference
BorderEditorControl Constructor
BorderEditorControl Class See Also Send Feedback
Initializes a new instance of the BorderEditorControl class.

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public BorderEditorControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BorderEditorControl()

See Also

BorderEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


BorderEditorControl Methods

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl Methods
BorderEditorControl Class See Also Send Feedback

The BorderEditorControl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

BorderEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl..::.AccessibilityNotifyClients Method
BorderEditorControl Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

BorderEditorControl Class
BorderEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl..::.BeginInvoke Method
BorderEditorControl Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

BorderEditorControl Class
BorderEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl..::.Dispose Method
BorderEditorControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

BorderEditorControl Class
BorderEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl..::.GetChildAtPoint Method
BorderEditorControl Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

BorderEditorControl Class
BorderEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl..::.Invalidate Method
BorderEditorControl Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

BorderEditorControl Class
BorderEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl..::.Invoke Method
BorderEditorControl Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

BorderEditorControl Class
BorderEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl..::.MemberwiseClone Method
BorderEditorControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

BorderEditorControl Class
BorderEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
BorderEditorControl..::.OnLoad Method
BorderEditorControl Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

BorderEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl..::.PerformLayout Method
BorderEditorControl Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

BorderEditorControl Class
BorderEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl..::.ResumeLayout Method
BorderEditorControl Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

BorderEditorControl Class
BorderEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl..::.RtlTranslateAlignment Method
BorderEditorControl Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

BorderEditorControl Class
BorderEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl..::.Scale Method
BorderEditorControl Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

BorderEditorControl Class
BorderEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl..::.Select Method
BorderEditorControl Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

BorderEditorControl Class
BorderEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl..::.SetBounds Method
BorderEditorControl Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

BorderEditorControl Class
BorderEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl..::.UpdateBounds Method
BorderEditorControl Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

BorderEditorControl Class
BorderEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl..::.Validate Method
BorderEditorControl Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

BorderEditorControl Class
BorderEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl..::.ValidateChildren Method
BorderEditorControl Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

BorderEditorControl Class
BorderEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


BorderEditorControl Properties

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl Properties
BorderEditorControl Class See Also Send Feedback

The BorderEditorControl type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Border | Gets or sets Border
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

BorderEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


Border Property

[image]

.NET ModelKit Suite ClassReference
BorderEditorControl..::.Border Property
BorderEditorControl Class See Also Send Feedback
Gets or sets Border

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Border Border { get; set; }
Visual Basic (Declaration)
Public Property Border As Border
Visual C++
public:
property Border^ Border {
    Border^ get ();
    void set (Border^ value);
}

See Also

BorderEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


BorderEditorControl Events

[image] [image]

.NET ModelKit Suite ClassReference
BorderEditorControl Events
BorderEditorControl Class See Also Send Feedback

The BorderEditorControl type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

BorderEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


FillChangedEventArgs Class

[image]

.NET ModelKit Suite ClassReference
FillChangedEventArgs Class
Members See Also Send Feedback
Contains information on the fill

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class FillChangedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class FillChangedEventArgs _
    Inherits EventArgs
Visual C++
public ref class FillChangedEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Framework.Drawing.Design..::.FillChangedEventArgs

See Also

FillChangedEventArgs Members
PerpetuumSoft.Framework.Drawing.Design Namespace


FillChangedEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
FillChangedEventArgs Members
FillChangedEventArgs Class Constructors Methods Properties See Also Send Feedback

The FillChangedEventArgs type exposes the following members.

Constructors

Name | Description
FillChangedEventArgs | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Fill | Gets Fill

See Also

FillChangedEventArgs Class
PerpetuumSoft.Framework.Drawing.Design Namespace


FillChangedEventArgs Constructor

[image] [image]

.NET ModelKit Suite ClassReference
FillChangedEventArgs Constructor
FillChangedEventArgs Class See Also Send Feedback

Overload List

Name | Description
FillChangedEventArgs()()() | Initializes a new instance of the FillChangedEventArgs class.
FillChangedEventArgs(Fill) | Initializes a new instance of the FillChangedEventArgs class.

See Also

FillChangedEventArgs Class
FillChangedEventArgs Members
PerpetuumSoft.Framework.Drawing.Design Namespace


FillChangedEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
FillChangedEventArgs Constructor
FillChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the FillChangedEventArgs class.

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public FillChangedEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FillChangedEventArgs()

See Also

FillChangedEventArgs Class
FillChangedEventArgs Overload
PerpetuumSoft.Framework.Drawing.Design Namespace


FillChangedEventArgs Constructor (Fill)

[image]

.NET ModelKit Suite ClassReference
FillChangedEventArgs Constructor (Fill)
FillChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the FillChangedEventArgs class.

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public FillChangedEventArgs(
    Fill fill
)
Visual Basic (Declaration)
Public Sub New ( _
    fill As Fill _
)
Visual C++
public:
FillChangedEventArgs(
    Fill^ fill
)

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill

See Also

FillChangedEventArgs Class
FillChangedEventArgs Overload
PerpetuumSoft.Framework.Drawing.Design Namespace


FillChangedEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
FillChangedEventArgs Methods
FillChangedEventArgs Class See Also Send Feedback

The FillChangedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillChangedEventArgs Class
PerpetuumSoft.Framework.Drawing.Design Namespace


FillChangedEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
FillChangedEventArgs Properties
FillChangedEventArgs Class See Also Send Feedback

The FillChangedEventArgs type exposes the following members.

Properties

Name | Description
Fill | Gets Fill

See Also

FillChangedEventArgs Class
PerpetuumSoft.Framework.Drawing.Design Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
FillChangedEventArgs..::.Fill Property
FillChangedEventArgs Class See Also Send Feedback
Gets Fill

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; }
Visual Basic (Declaration)
Public ReadOnly Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
}

See Also

FillChangedEventArgs Class
PerpetuumSoft.Framework.Drawing.Design Namespace


FillEditorControl Class

[image]

.NET ModelKit Suite ClassReference
FillEditorControl Class
Members See Also Send Feedback
Fill editor control

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class FillEditorControl : UserControl
Visual Basic (Declaration)
Public Class FillEditorControl _
    Inherits UserControl
Visual C++
public ref class FillEditorControl : public UserControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Framework.Drawing.Design..::.FillEditorControl

See Also

FillEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


FillEditorControl Members

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl Members
FillEditorControl Class Constructors Methods Properties Events See Also Send Feedback

The FillEditorControl type exposes the following members.

Constructors

Name | Description
FillEditorControl | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEndEdit | Raises the OnEndEdit event.
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnValueChanged | Raises the OnValueChanged event.
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Fill | Gets or sets Fill
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
EndEdit | Occurs when editing is complete
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
ValueChanged | Occurs when the Fill property changes.
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

FillEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


FillEditorControl Constructor

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl Constructor
FillEditorControl Class See Also Send Feedback

Overload List

Name | Description
FillEditorControl()()() | Initializes a new instance of the FillEditorControl class.
FillEditorControl(Fill) | Initializes a new instance of the FillEditorControl class.

See Also

FillEditorControl Class
FillEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


FillEditorControl Constructor

[image]

.NET ModelKit Suite ClassReference
FillEditorControl Constructor
FillEditorControl Class See Also Send Feedback
Initializes a new instance of the FillEditorControl class.

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public FillEditorControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FillEditorControl()

See Also

FillEditorControl Class
FillEditorControl Overload
PerpetuumSoft.Framework.Drawing.Design Namespace


FillEditorControl Constructor (Fill)

[image]

.NET ModelKit Suite ClassReference
FillEditorControl Constructor (Fill)
FillEditorControl Class See Also Send Feedback
Initializes a new instance of the FillEditorControl class.

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public FillEditorControl(
    Fill fill
)
Visual Basic (Declaration)
Public Sub New ( _
    fill As Fill _
)
Visual C++
public:
FillEditorControl(
    Fill^ fill
)

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill

See Also

FillEditorControl Class
FillEditorControl Overload
PerpetuumSoft.Framework.Drawing.Design Namespace


FillEditorControl Methods

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl Methods
FillEditorControl Class See Also Send Feedback

The FillEditorControl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEndEdit | Raises the OnEndEdit event.
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnValueChanged | Raises the OnValueChanged event.
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

FillEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.AccessibilityNotifyClients Method
FillEditorControl Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

FillEditorControl Class
FillEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.BeginInvoke Method
FillEditorControl Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

FillEditorControl Class
FillEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.Dispose Method
FillEditorControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

FillEditorControl Class
FillEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.GetChildAtPoint Method
FillEditorControl Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

FillEditorControl Class
FillEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.Invalidate Method
FillEditorControl Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

FillEditorControl Class
FillEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.Invoke Method
FillEditorControl Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

FillEditorControl Class
FillEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.MemberwiseClone Method
FillEditorControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

FillEditorControl Class
FillEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


OnEndEdit Method

[image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.OnEndEdit Method
FillEditorControl Class See Also Send Feedback
Raises the OnEndEdit event.

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnEndEdit(
    CancelEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnEndEdit ( _
    e As CancelEventArgs _
)
Visual C++
protected:
virtual void OnEndEdit(
    CancelEventArgs^ e
)

Parameters

e
Type: System.ComponentModel..::.CancelEventArgs

See Also

FillEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.OnLoad Method
FillEditorControl Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

FillEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


OnValueChanged Method

[image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.OnValueChanged Method
FillEditorControl Class See Also Send Feedback
Raises the OnValueChanged event.

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnValueChanged(
    FillChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnValueChanged ( _
    e As FillChangedEventArgs _
)
Visual C++
protected:
virtual void OnValueChanged(
    FillChangedEventArgs^ e
)

Parameters

e
Type: PerpetuumSoft.Framework.Drawing.Design..::.FillChangedEventArgs

See Also

FillEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.PerformLayout Method
FillEditorControl Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

FillEditorControl Class
FillEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.ResumeLayout Method
FillEditorControl Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

FillEditorControl Class
FillEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.RtlTranslateAlignment Method
FillEditorControl Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

FillEditorControl Class
FillEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.Scale Method
FillEditorControl Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

FillEditorControl Class
FillEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.Select Method
FillEditorControl Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

FillEditorControl Class
FillEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.SetBounds Method
FillEditorControl Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

FillEditorControl Class
FillEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.UpdateBounds Method
FillEditorControl Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

FillEditorControl Class
FillEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.Validate Method
FillEditorControl Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

FillEditorControl Class
FillEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.ValidateChildren Method
FillEditorControl Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

FillEditorControl Class
FillEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


FillEditorControl Properties

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl Properties
FillEditorControl Class See Also Send Feedback

The FillEditorControl type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Fill | Gets or sets Fill
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

FillEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.Fill Property
FillEditorControl Class See Also Send Feedback
Gets or sets Fill

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

FillEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


FillEditorControl Events

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorControl Events
FillEditorControl Class See Also Send Feedback

The FillEditorControl type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
EndEdit | Occurs when editing is complete
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
ValueChanged | Occurs when the Fill property changes.
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

FillEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


EndEdit Event

[image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.EndEdit Event
FillEditorControl Class See Also Send Feedback
Occurs when editing is complete

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public event CancelEventHandler EndEdit
Visual Basic (Declaration)
Public Event EndEdit As CancelEventHandler
Visual C++
public:
 event CancelEventHandler^ EndEdit {
    void add (CancelEventHandler^ value);
    void remove (CancelEventHandler^ value);
}

See Also

FillEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


ValueChanged Event

[image]

.NET ModelKit Suite ClassReference
FillEditorControl..::.ValueChanged Event
FillEditorControl Class See Also Send Feedback
Occurs when the Fill property changes.

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public event FillChangedEventHandler ValueChanged
Visual Basic (Declaration)
Public Event ValueChanged As FillChangedEventHandler
Visual C++
public:
 event FillChangedEventHandler^ ValueChanged {
    void add (FillChangedEventHandler^ value);
    void remove (FillChangedEventHandler^ value);
}

See Also

FillEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


FillEditorForm Class

[image]

.NET ModelKit Suite ClassReference
FillEditorForm Class
Members See Also Send Feedback
Fill editing form

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class FillEditorForm : Form
Visual Basic (Declaration)
Public Class FillEditorForm _
    Inherits Form
Visual C++
public ref class FillEditorForm : public Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
PerpetuumSoft.Framework.Drawing.Design..::.FillEditorForm

See Also

FillEditorForm Members
PerpetuumSoft.Framework.Drawing.Design Namespace


FillEditorForm Members

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm Members
FillEditorForm Class Constructors Methods Properties Events See Also Send Feedback

The FillEditorForm type exposes the following members.

Constructors

Name | Description
FillEditorForm | Initializes a new instance of the FillEditorForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Fill | Gets or sets Fill
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

FillEditorForm Class
PerpetuumSoft.Framework.Drawing.Design Namespace


FillEditorForm Constructor

[image]

.NET ModelKit Suite ClassReference
FillEditorForm Constructor
FillEditorForm Class See Also Send Feedback
Initializes a new instance of the FillEditorForm class.

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public FillEditorForm(
    Fill fill
)
Visual Basic (Declaration)
Public Sub New ( _
    fill As Fill _
)
Visual C++
public:
FillEditorForm(
    Fill^ fill
)

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill

See Also

FillEditorForm Class
PerpetuumSoft.Framework.Drawing.Design Namespace


FillEditorForm Methods

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm Methods
FillEditorForm Class See Also Send Feedback

The FillEditorForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

FillEditorForm Class
PerpetuumSoft.Framework.Drawing.Design Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.AccessibilityNotifyClients Method
FillEditorForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

FillEditorForm Class
FillEditorForm Members
PerpetuumSoft.Framework.Drawing.Design Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.BeginInvoke Method
FillEditorForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

FillEditorForm Class
FillEditorForm Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.Dispose Method
FillEditorForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Disposes of the resources (other than memory) used by the Form. (Inherited from Form.)

See Also

FillEditorForm Class
FillEditorForm Members
PerpetuumSoft.Framework.Drawing.Design Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.GetChildAtPoint Method
FillEditorForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

FillEditorForm Class
FillEditorForm Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.Invalidate Method
FillEditorForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

FillEditorForm Class
FillEditorForm Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.Invoke Method
FillEditorForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

FillEditorForm Class
FillEditorForm Members
PerpetuumSoft.Framework.Drawing.Design Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.MemberwiseClone Method
FillEditorForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

FillEditorForm Class
FillEditorForm Members
PerpetuumSoft.Framework.Drawing.Design Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.OnLoad Method
FillEditorForm Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

FillEditorForm Class
PerpetuumSoft.Framework.Drawing.Design Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.PerformLayout Method
FillEditorForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

FillEditorForm Class
FillEditorForm Members
PerpetuumSoft.Framework.Drawing.Design Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.ResumeLayout Method
FillEditorForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

FillEditorForm Class
FillEditorForm Members
PerpetuumSoft.Framework.Drawing.Design Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.RtlTranslateAlignment Method
FillEditorForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

FillEditorForm Class
FillEditorForm Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.Scale Method
FillEditorForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

FillEditorForm Class
FillEditorForm Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.Select Method
FillEditorForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

FillEditorForm Class
FillEditorForm Members
PerpetuumSoft.Framework.Drawing.Design Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.SetBounds Method
FillEditorForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

FillEditorForm Class
FillEditorForm Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Show Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.Show Method
FillEditorForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

FillEditorForm Class
FillEditorForm Members
PerpetuumSoft.Framework.Drawing.Design Namespace


ShowDialog Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.ShowDialog Method
FillEditorForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

FillEditorForm Class
FillEditorForm Members
PerpetuumSoft.Framework.Drawing.Design Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.UpdateBounds Method
FillEditorForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

FillEditorForm Class
FillEditorForm Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.Validate Method
FillEditorForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

FillEditorForm Class
FillEditorForm Members
PerpetuumSoft.Framework.Drawing.Design Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.ValidateChildren Method
FillEditorForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

FillEditorForm Class
FillEditorForm Members
PerpetuumSoft.Framework.Drawing.Design Namespace


FillEditorForm Properties

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm Properties
FillEditorForm Class See Also Send Feedback

The FillEditorForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Fill | Gets or sets Fill
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

FillEditorForm Class
PerpetuumSoft.Framework.Drawing.Design Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
FillEditorForm..::.Fill Property
FillEditorForm Class See Also Send Feedback
Gets or sets Fill

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

FillEditorForm Class
PerpetuumSoft.Framework.Drawing.Design Namespace


FillEditorForm Events

[image] [image]

.NET ModelKit Suite ClassReference
FillEditorForm Events
FillEditorForm Class See Also Send Feedback

The FillEditorForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

FillEditorForm Class
PerpetuumSoft.Framework.Drawing.Design Namespace


IFillEditorControl Interface

[image]

.NET ModelKit Suite ClassReference
IFillEditorControl Interface
Members See Also Send Feedback
Provides methods for the Fill editing

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public interface IFillEditorControl
Visual Basic (Declaration)
Public Interface IFillEditorControl
Visual C++
public interface class IFillEditorControl

See Also

IFillEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


IFillEditorControl Members

[image] [image]

.NET ModelKit Suite ClassReference
IFillEditorControl Members
IFillEditorControl Interface Methods Events See Also Send Feedback

The IFillEditorControl type exposes the following members.

Methods

Name | Description
GetFill | Gets the Fill property
SetFill | Sets the Fill property

Events

Name | Description
ValueChanged | Occurs when the Fill property changes.

See Also

IFillEditorControl Interface
PerpetuumSoft.Framework.Drawing.Design Namespace


IFillEditorControl Methods

[image] [image]

.NET ModelKit Suite ClassReference
IFillEditorControl Methods
IFillEditorControl Interface See Also Send Feedback

The IFillEditorControl type exposes the following members.

Methods

Name | Description
GetFill | Gets the Fill property
SetFill | Sets the Fill property

See Also

IFillEditorControl Interface
PerpetuumSoft.Framework.Drawing.Design Namespace


GetFill Method

[image]

.NET ModelKit Suite ClassReference
IFillEditorControl..::.GetFill Method
IFillEditorControl Interface See Also Send Feedback
Gets the Fill property

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
Fill GetFill()
Visual Basic (Declaration)
Function GetFill As Fill
Visual C++
Fill^ GetFill()

See Also

IFillEditorControl Interface
PerpetuumSoft.Framework.Drawing.Design Namespace


SetFill Method

[image]

.NET ModelKit Suite ClassReference
IFillEditorControl..::.SetFill Method
IFillEditorControl Interface See Also Send Feedback
Sets the Fill property

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
void SetFill(
    Fill fill
)
Visual Basic (Declaration)
Sub SetFill ( _
    fill As Fill _
)
Visual C++
void SetFill(
    Fill^ fill
)

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill

See Also

IFillEditorControl Interface
PerpetuumSoft.Framework.Drawing.Design Namespace


IFillEditorControl Events

[image] [image]

.NET ModelKit Suite ClassReference
IFillEditorControl Events
IFillEditorControl Interface See Also Send Feedback

The IFillEditorControl type exposes the following members.

Events

Name | Description
ValueChanged | Occurs when the Fill property changes.

See Also

IFillEditorControl Interface
PerpetuumSoft.Framework.Drawing.Design Namespace


ValueChanged Event

[image]

.NET ModelKit Suite ClassReference
IFillEditorControl..::.ValueChanged Event
IFillEditorControl Interface See Also Send Feedback
Occurs when the Fill property changes.

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
event FillChangedEventHandler ValueChanged
Visual Basic (Declaration)
Event ValueChanged As FillChangedEventHandler
Visual C++
 event FillChangedEventHandler^ ValueChanged {
    void add (FillChangedEventHandler^ value);
    void remove (FillChangedEventHandler^ value);
}

See Also

IFillEditorControl Interface
PerpetuumSoft.Framework.Drawing.Design Namespace


MarginsEditorControl Class

[image]

.NET ModelKit Suite ClassReference
MarginsEditorControl Class
Members See Also Send Feedback
Margins editor control

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class MarginsEditorControl : UserControl
Visual Basic (Declaration)
Public Class MarginsEditorControl _
    Inherits UserControl
Visual C++
public ref class MarginsEditorControl : public UserControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Framework.Drawing.Design..::.MarginsEditorControl

See Also

MarginsEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


MarginsEditorControl Members

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl Members
MarginsEditorControl Class Constructors Methods Properties Events See Also Send Feedback

The MarginsEditorControl type exposes the following members.

Constructors

Name | Description
MarginsEditorControl | Initializes a new instance of the MarginsEditorControl class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
Margins | Gets or sets Margins
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Unit | Gets or sets Unit
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

MarginsEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


MarginsEditorControl Constructor

[image]

.NET ModelKit Suite ClassReference
MarginsEditorControl Constructor
MarginsEditorControl Class See Also Send Feedback
Initializes a new instance of the MarginsEditorControl class.

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public MarginsEditorControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MarginsEditorControl()

See Also

MarginsEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


MarginsEditorControl Methods

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl Methods
MarginsEditorControl Class See Also Send Feedback

The MarginsEditorControl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

MarginsEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl..::.AccessibilityNotifyClients Method
MarginsEditorControl Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

MarginsEditorControl Class
MarginsEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl..::.BeginInvoke Method
MarginsEditorControl Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

MarginsEditorControl Class
MarginsEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl..::.Dispose Method
MarginsEditorControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

MarginsEditorControl Class
MarginsEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl..::.GetChildAtPoint Method
MarginsEditorControl Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

MarginsEditorControl Class
MarginsEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl..::.Invalidate Method
MarginsEditorControl Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

MarginsEditorControl Class
MarginsEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl..::.Invoke Method
MarginsEditorControl Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

MarginsEditorControl Class
MarginsEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl..::.MemberwiseClone Method
MarginsEditorControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

MarginsEditorControl Class
MarginsEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl..::.PerformLayout Method
MarginsEditorControl Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

MarginsEditorControl Class
MarginsEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl..::.ResumeLayout Method
MarginsEditorControl Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

MarginsEditorControl Class
MarginsEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl..::.RtlTranslateAlignment Method
MarginsEditorControl Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

MarginsEditorControl Class
MarginsEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl..::.Scale Method
MarginsEditorControl Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

MarginsEditorControl Class
MarginsEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl..::.Select Method
MarginsEditorControl Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

MarginsEditorControl Class
MarginsEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl..::.SetBounds Method
MarginsEditorControl Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

MarginsEditorControl Class
MarginsEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl..::.UpdateBounds Method
MarginsEditorControl Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

MarginsEditorControl Class
MarginsEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl..::.Validate Method
MarginsEditorControl Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

MarginsEditorControl Class
MarginsEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl..::.ValidateChildren Method
MarginsEditorControl Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

MarginsEditorControl Class
MarginsEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


MarginsEditorControl Properties

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl Properties
MarginsEditorControl Class See Also Send Feedback

The MarginsEditorControl type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
Margins | Gets or sets Margins
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Unit | Gets or sets Unit
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

MarginsEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


Margins Property

[image]

.NET ModelKit Suite ClassReference
MarginsEditorControl..::.Margins Property
MarginsEditorControl Class See Also Send Feedback
Gets or sets Margins

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Margins Margins { get; set; }
Visual Basic (Declaration)
Public Property Margins As Margins
Visual C++
public:
property Margins Margins {
    Margins get ();
    void set (Margins value);
}

See Also

MarginsEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


Unit Property

[image]

.NET ModelKit Suite ClassReference
MarginsEditorControl..::.Unit Property
MarginsEditorControl Class See Also Send Feedback
Gets or sets Unit

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Unit Unit { get; set; }
Visual Basic (Declaration)
Public Property Unit As Unit
Visual C++
public:
property Unit Unit {
    Unit get ();
    void set (Unit value);
}

See Also

MarginsEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


MarginsEditorControl Events

[image] [image]

.NET ModelKit Suite ClassReference
MarginsEditorControl Events
MarginsEditorControl Class See Also Send Feedback

The MarginsEditorControl type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

MarginsEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


StrokeEditorControl Class

[image]

.NET ModelKit Suite ClassReference
StrokeEditorControl Class
Members See Also Send Feedback
Stroke editor control

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class StrokeEditorControl : UserControl
Visual Basic (Declaration)
Public Class StrokeEditorControl _
    Inherits UserControl
Visual C++
public ref class StrokeEditorControl : public UserControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Framework.Drawing.Design..::.StrokeEditorControl

See Also

StrokeEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


StrokeEditorControl Members

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl Members
StrokeEditorControl Class Constructors Methods Properties Events See Also Send Feedback

The StrokeEditorControl type exposes the following members.

Constructors

Name | Description
StrokeEditorControl | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnValueChanged | Raises the OnValueChanged event.
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
Stroke | Gets or sets Stroke
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
ValueChanged | Occurs when the Fill property changes.
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

StrokeEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


StrokeEditorControl Constructor

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl Constructor
StrokeEditorControl Class See Also Send Feedback

Overload List

Name | Description
StrokeEditorControl()()() | Initializes a new instance of the StrokeEditorControl class.
StrokeEditorControl(Stroke) | Initializes a new instance of the StrokeEditorControl class.

See Also

StrokeEditorControl Class
StrokeEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


StrokeEditorControl Constructor

[image]

.NET ModelKit Suite ClassReference
StrokeEditorControl Constructor
StrokeEditorControl Class See Also Send Feedback
Initializes a new instance of the StrokeEditorControl class.

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public StrokeEditorControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StrokeEditorControl()

See Also

StrokeEditorControl Class
StrokeEditorControl Overload
PerpetuumSoft.Framework.Drawing.Design Namespace


StrokeEditorControl Constructor (Stroke)

[image]

.NET ModelKit Suite ClassReference
StrokeEditorControl Constructor (Stroke)
StrokeEditorControl Class See Also Send Feedback
Initializes a new instance of the StrokeEditorControl class.

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public StrokeEditorControl(
    Stroke stroke
)
Visual Basic (Declaration)
Public Sub New ( _
    stroke As Stroke _
)
Visual C++
public:
StrokeEditorControl(
    Stroke^ stroke
)

Parameters

stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

StrokeEditorControl Class
StrokeEditorControl Overload
PerpetuumSoft.Framework.Drawing.Design Namespace


StrokeEditorControl Methods

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl Methods
StrokeEditorControl Class See Also Send Feedback

The StrokeEditorControl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnValueChanged | Raises the OnValueChanged event.
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

StrokeEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.AccessibilityNotifyClients Method
StrokeEditorControl Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

StrokeEditorControl Class
StrokeEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.BeginInvoke Method
StrokeEditorControl Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

StrokeEditorControl Class
StrokeEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.Dispose Method
StrokeEditorControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

StrokeEditorControl Class
StrokeEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.GetChildAtPoint Method
StrokeEditorControl Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

StrokeEditorControl Class
StrokeEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.Invalidate Method
StrokeEditorControl Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

StrokeEditorControl Class
StrokeEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.Invoke Method
StrokeEditorControl Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

StrokeEditorControl Class
StrokeEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.MemberwiseClone Method
StrokeEditorControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

StrokeEditorControl Class
StrokeEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.OnLoad Method
StrokeEditorControl Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

StrokeEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


OnValueChanged Method

[image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.OnValueChanged Method
StrokeEditorControl Class See Also Send Feedback
Raises the OnValueChanged event.

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnValueChanged(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnValueChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnValueChanged(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

See Also

StrokeEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.PerformLayout Method
StrokeEditorControl Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

StrokeEditorControl Class
StrokeEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.ResumeLayout Method
StrokeEditorControl Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

StrokeEditorControl Class
StrokeEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.RtlTranslateAlignment Method
StrokeEditorControl Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

StrokeEditorControl Class
StrokeEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.Scale Method
StrokeEditorControl Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

StrokeEditorControl Class
StrokeEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.Select Method
StrokeEditorControl Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

StrokeEditorControl Class
StrokeEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.SetBounds Method
StrokeEditorControl Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

StrokeEditorControl Class
StrokeEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.UpdateBounds Method
StrokeEditorControl Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

StrokeEditorControl Class
StrokeEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.Validate Method
StrokeEditorControl Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

StrokeEditorControl Class
StrokeEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.ValidateChildren Method
StrokeEditorControl Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

StrokeEditorControl Class
StrokeEditorControl Members
PerpetuumSoft.Framework.Drawing.Design Namespace


StrokeEditorControl Properties

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl Properties
StrokeEditorControl Class See Also Send Feedback

The StrokeEditorControl type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
Stroke | Gets or sets Stroke
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

StrokeEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


Stroke Property

[image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.Stroke Property
StrokeEditorControl Class See Also Send Feedback
Gets or sets Stroke

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Stroke Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Stroke
Visual C++
public:
property Stroke^ Stroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

StrokeEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


StrokeEditorControl Events

[image] [image]

.NET ModelKit Suite ClassReference
StrokeEditorControl Events
StrokeEditorControl Class See Also Send Feedback

The StrokeEditorControl type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
ValueChanged | Occurs when the Fill property changes.
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

StrokeEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


ValueChanged Event

[image]

.NET ModelKit Suite ClassReference
StrokeEditorControl..::.ValueChanged Event
StrokeEditorControl Class See Also Send Feedback
Occurs when the Fill property changes.

Namespace: PerpetuumSoft.Framework.Drawing.Design
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler ValueChanged
Visual Basic (Declaration)
Public Event ValueChanged As EventHandler
Visual C++
public:
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

StrokeEditorControl Class
PerpetuumSoft.Framework.Drawing.Design Namespace


PerpetuumSoft.Framework.Drawing.PDF417BarCode Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Framework.Drawing.PDF417BarCode Namespace
Send Feedback
The PerpetuumSoft.Framework.Drawing.PDF417BarCod namespace contains classes for drawing of the PDF417 bar code type.

Enumerations

Enumeration | Description
TypeBarCode | Enumerates a compaction mode.


TypeBarCode Enumeration

[image]

.NET ModelKit Suite ClassReference
TypeBarCode Enumeration
See Also Send Feedback
Enumerates a compaction mode.

Namespace: PerpetuumSoft.Framework.Drawing.PDF417BarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public enum TypeBarCode
Visual Basic (Declaration)
Public Enumeration TypeBarCode
Visual C++
public enum class TypeBarCode

Members

Member name | Description
TextMode | Text compaction mode.
ByteMode | Byte compaction mode.
NumericMode | Numeric compaction mode.

See Also

PerpetuumSoft.Framework.Drawing.PDF417BarCode Namespace


PerpetuumSoft.Framework.Drawing.QRBarCode Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace
Send Feedback

[Missing <summary> documentation for N:PerpetuumSoft.Framework.Drawing.QRBarCode]

Classes

Class | Description
CodeSettings |
MicroQRCodeSettings |
QRCodeSettings |
StringHead |

Enumerations

Enumeration | Description
MicroQRCodeMask |
QRCodeErrorCorrectionLevel |
QRCodeMask |
QRCodeMode |


CodeSettings Class

[image]

.NET ModelKit Suite ClassReference
CodeSettings Class
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Framework.Drawing.QRBarCode.CodeSettings]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class CodeSettings
Visual Basic (Declaration)
Public Class CodeSettings
Visual C++
public ref class CodeSettings

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Drawing.QRBarCode..::.CodeSettings
PerpetuumSoft.Framework.Drawing.QRBarCode..::.MicroQRCodeSettings
PerpetuumSoft.Framework.Drawing.QRBarCode..::.QRCodeSettings

See Also

CodeSettings Members
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


CodeSettings Members

[image] [image]

.NET ModelKit Suite ClassReference
CodeSettings Members
CodeSettings Class Constructors Methods Properties See Also Send Feedback

The CodeSettings type exposes the following members.

Constructors

Name | Description
CodeSettings | Initializes a new instance of the CodeSettings class

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MaxVersion |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ErrorCorrectionLevel |
MirrorImaging |
ReflectanceReversal |
Version |

See Also

CodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


CodeSettings Constructor

[image]

.NET ModelKit Suite ClassReference
CodeSettings Constructor
CodeSettings Class See Also Send Feedback
Initializes a new instance of the CodeSettings class

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public CodeSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CodeSettings()

See Also

CodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


CodeSettings Methods

[image] [image]

.NET ModelKit Suite ClassReference
CodeSettings Methods
CodeSettings Class See Also Send Feedback

The CodeSettings type exposes the following members.

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MaxVersion |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
CodeSettings..::.Equals Method
CodeSettings Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.QRBarCode.CodeSettings.Equals(System.Object)]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

CodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
CodeSettings..::.GetHashCode Method
CodeSettings Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.QRBarCode.CodeSettings.GetHashCode]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

CodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


MaxVersion Method

[image]

.NET ModelKit Suite ClassReference
CodeSettings..::.MaxVersion Method
CodeSettings Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.QRBarCode.CodeSettings.MaxVersion]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected virtual int MaxVersion()
Visual Basic (Declaration)
Protected Overridable Function MaxVersion As Integer
Visual C++
protected:
virtual int MaxVersion()

See Also

CodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


CodeSettings Properties

[image] [image]

.NET ModelKit Suite ClassReference
CodeSettings Properties
CodeSettings Class See Also Send Feedback

The CodeSettings type exposes the following members.

Properties

Name | Description
ErrorCorrectionLevel |
MirrorImaging |
ReflectanceReversal |
Version |

See Also

CodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


ErrorCorrectionLevel Property

[image]

.NET ModelKit Suite ClassReference
CodeSettings..::.ErrorCorrectionLevel Property
CodeSettings Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Framework.Drawing.QRBarCode.CodeSettings.ErrorCorrectionLevel]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public QRCodeErrorCorrectionLevel ErrorCorrectionLevel { get; set; }
Visual Basic (Declaration)
Public Property ErrorCorrectionLevel As QRCodeErrorCorrectionLevel
Visual C++
public:
property QRCodeErrorCorrectionLevel ErrorCorrectionLevel {
    QRCodeErrorCorrectionLevel get ();
    void set (QRCodeErrorCorrectionLevel value);
}

See Also

CodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


MirrorImaging Property

[image]

.NET ModelKit Suite ClassReference
CodeSettings..::.MirrorImaging Property
CodeSettings Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Framework.Drawing.QRBarCode.CodeSettings.MirrorImaging]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public bool MirrorImaging { get; set; }
Visual Basic (Declaration)
Public Property MirrorImaging As Boolean
Visual C++
public:
property bool MirrorImaging {
    bool get ();
    void set (bool value);
}

See Also

CodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


ReflectanceReversal Property

[image]

.NET ModelKit Suite ClassReference
CodeSettings..::.ReflectanceReversal Property
CodeSettings Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Framework.Drawing.QRBarCode.CodeSettings.ReflectanceReversal]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public bool ReflectanceReversal { get; set; }
Visual Basic (Declaration)
Public Property ReflectanceReversal As Boolean
Visual C++
public:
property bool ReflectanceReversal {
    bool get ();
    void set (bool value);
}

See Also

CodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


Version Property

[image]

.NET ModelKit Suite ClassReference
CodeSettings..::.Version Property
CodeSettings Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Framework.Drawing.QRBarCode.CodeSettings.Version]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public int Version { get; set; }
Visual Basic (Declaration)
Public Property Version As Integer
Visual C++
public:
property int Version {
    int get ();
    void set (int value);
}

See Also

CodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


MicroQRCodeMask Enumeration

[image]

.NET ModelKit Suite ClassReference
MicroQRCodeMask Enumeration
See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Framework.Drawing.QRBarCode.MicroQRCodeMask]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public enum MicroQRCodeMask
Visual Basic (Declaration)
Public Enumeration MicroQRCodeMask
Visual C++
public enum class MicroQRCodeMask

Members

Member name | Description
Mask00 |
Mask01 |
Mask10 |
Mask11 |

See Also

PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


MicroQRCodeSettings Class

[image]

.NET ModelKit Suite ClassReference
MicroQRCodeSettings Class
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Framework.Drawing.QRBarCode.MicroQRCodeSettings]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class MicroQRCodeSettings : CodeSettings
Visual Basic (Declaration)
Public Class MicroQRCodeSettings _
    Inherits CodeSettings
Visual C++
public ref class MicroQRCodeSettings : public CodeSettings

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Drawing.QRBarCode..::.CodeSettings
PerpetuumSoft.Framework.Drawing.QRBarCode..::.MicroQRCodeSettings

See Also

MicroQRCodeSettings Members
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


MicroQRCodeSettings Members

[image] [image]

.NET ModelKit Suite ClassReference
MicroQRCodeSettings Members
MicroQRCodeSettings Class Constructors Methods Properties See Also Send Feedback

The MicroQRCodeSettings type exposes the following members.

Constructors

Name | Description
MicroQRCodeSettings | Initializes a new instance of the MicroQRCodeSettings class

Methods

Name | Description
Equals | (Overrides CodeSettings..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides CodeSettings..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MaxVersion | (Overrides CodeSettings..::.MaxVersion()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ErrorCorrectionLevel | (Inherited from CodeSettings.)
Mask |
MirrorImaging | (Inherited from CodeSettings.)
ReflectanceReversal | (Inherited from CodeSettings.)
Version | (Inherited from CodeSettings.)

See Also

MicroQRCodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


MicroQRCodeSettings Constructor

[image]

.NET ModelKit Suite ClassReference
MicroQRCodeSettings Constructor
MicroQRCodeSettings Class See Also Send Feedback
Initializes a new instance of the MicroQRCodeSettings class

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public MicroQRCodeSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MicroQRCodeSettings()

See Also

MicroQRCodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


MicroQRCodeSettings Methods

[image] [image]

.NET ModelKit Suite ClassReference
MicroQRCodeSettings Methods
MicroQRCodeSettings Class See Also Send Feedback

The MicroQRCodeSettings type exposes the following members.

Methods

Name | Description
Equals | (Overrides CodeSettings..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides CodeSettings..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MaxVersion | (Overrides CodeSettings..::.MaxVersion()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MicroQRCodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
MicroQRCodeSettings..::.Equals Method
MicroQRCodeSettings Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.QRBarCode.MicroQRCodeSettings.Equals(System.Object)]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

MicroQRCodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
MicroQRCodeSettings..::.GetHashCode Method
MicroQRCodeSettings Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.QRBarCode.MicroQRCodeSettings.GetHashCode]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

MicroQRCodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


MaxVersion Method

[image]

.NET ModelKit Suite ClassReference
MicroQRCodeSettings..::.MaxVersion Method
MicroQRCodeSettings Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.QRBarCode.MicroQRCodeSettings.MaxVersion]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected override int MaxVersion()
Visual Basic (Declaration)
Protected Overrides Function MaxVersion As Integer
Visual C++
protected:
virtual int MaxVersion() override

See Also

MicroQRCodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


MicroQRCodeSettings Properties

[image] [image]

.NET ModelKit Suite ClassReference
MicroQRCodeSettings Properties
MicroQRCodeSettings Class See Also Send Feedback

The MicroQRCodeSettings type exposes the following members.

Properties

Name | Description
ErrorCorrectionLevel | (Inherited from CodeSettings.)
Mask |
MirrorImaging | (Inherited from CodeSettings.)
ReflectanceReversal | (Inherited from CodeSettings.)
Version | (Inherited from CodeSettings.)

See Also

MicroQRCodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


Mask Property

[image]

.NET ModelKit Suite ClassReference
MicroQRCodeSettings..::.Mask Property
MicroQRCodeSettings Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Framework.Drawing.QRBarCode.MicroQRCodeSettings.Mask]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public MicroQRCodeMask Mask { get; set; }
Visual Basic (Declaration)
Public Property Mask As MicroQRCodeMask
Visual C++
public:
property MicroQRCodeMask Mask {
    MicroQRCodeMask get ();
    void set (MicroQRCodeMask value);
}

See Also

MicroQRCodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


QRCodeErrorCorrectionLevel Enumeration

[image]

.NET ModelKit Suite ClassReference
QRCodeErrorCorrectionLevel Enumeration
See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Framework.Drawing.QRBarCode.QRCodeErrorCorrectionLevel]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public enum QRCodeErrorCorrectionLevel
Visual Basic (Declaration)
Public Enumeration QRCodeErrorCorrectionLevel
Visual C++
public enum class QRCodeErrorCorrectionLevel

Members

Member name | Description
M |
L |
H |
Q |

See Also

PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


QRCodeMask Enumeration

[image]

.NET ModelKit Suite ClassReference
QRCodeMask Enumeration
See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Framework.Drawing.QRBarCode.QRCodeMask]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public enum QRCodeMask
Visual Basic (Declaration)
Public Enumeration QRCodeMask
Visual C++
public enum class QRCodeMask

Members

Member name | Description
Mask000 |
Mask001 |
Mask010 |
Mask011 |
Mask100 |
Mask101 |
Mask110 |
Mask111 |

See Also

PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


QRCodeMode Enumeration

[image]

.NET ModelKit Suite ClassReference
QRCodeMode Enumeration
See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Framework.Drawing.QRBarCode.QRCodeMode]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public enum QRCodeMode
Visual Basic (Declaration)
Public Enumeration QRCodeMode
Visual C++
public enum class QRCodeMode

Members

Member name | Description
NumericMode |
AlphanumericMode |
ByteMode |
Kanji |

See Also

PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


QRCodeSettings Class

[image]

.NET ModelKit Suite ClassReference
QRCodeSettings Class
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Framework.Drawing.QRBarCode.QRCodeSettings]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class QRCodeSettings : CodeSettings
Visual Basic (Declaration)
Public Class QRCodeSettings _
    Inherits CodeSettings
Visual C++
public ref class QRCodeSettings : public CodeSettings

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Drawing.QRBarCode..::.CodeSettings
PerpetuumSoft.Framework.Drawing.QRBarCode..::.QRCodeSettings

See Also

QRCodeSettings Members
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


QRCodeSettings Members

[image] [image]

.NET ModelKit Suite ClassReference
QRCodeSettings Members
QRCodeSettings Class Constructors Methods Properties See Also Send Feedback

The QRCodeSettings type exposes the following members.

Constructors

Name | Description
QRCodeSettings | Initializes a new instance of the QRCodeSettings class

Methods

Name | Description
Equals | (Overrides CodeSettings..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides CodeSettings..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MaxVersion | (Overrides CodeSettings..::.MaxVersion()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ErrorCorrectionLevel | (Inherited from CodeSettings.)
Mask |
MirrorImaging | (Inherited from CodeSettings.)
ReflectanceReversal | (Inherited from CodeSettings.)
Version | (Inherited from CodeSettings.)

See Also

QRCodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


QRCodeSettings Constructor

[image]

.NET ModelKit Suite ClassReference
QRCodeSettings Constructor
QRCodeSettings Class See Also Send Feedback
Initializes a new instance of the QRCodeSettings class

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public QRCodeSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
QRCodeSettings()

See Also

QRCodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


QRCodeSettings Methods

[image] [image]

.NET ModelKit Suite ClassReference
QRCodeSettings Methods
QRCodeSettings Class See Also Send Feedback

The QRCodeSettings type exposes the following members.

Methods

Name | Description
Equals | (Overrides CodeSettings..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides CodeSettings..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MaxVersion | (Overrides CodeSettings..::.MaxVersion()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QRCodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
QRCodeSettings..::.Equals Method
QRCodeSettings Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.QRBarCode.QRCodeSettings.Equals(System.Object)]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

QRCodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
QRCodeSettings..::.GetHashCode Method
QRCodeSettings Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.QRBarCode.QRCodeSettings.GetHashCode]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

QRCodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


MaxVersion Method

[image]

.NET ModelKit Suite ClassReference
QRCodeSettings..::.MaxVersion Method
QRCodeSettings Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.QRBarCode.QRCodeSettings.MaxVersion]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected override int MaxVersion()
Visual Basic (Declaration)
Protected Overrides Function MaxVersion As Integer
Visual C++
protected:
virtual int MaxVersion() override

See Also

QRCodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


QRCodeSettings Properties

[image] [image]

.NET ModelKit Suite ClassReference
QRCodeSettings Properties
QRCodeSettings Class See Also Send Feedback

The QRCodeSettings type exposes the following members.

Properties

Name | Description
ErrorCorrectionLevel | (Inherited from CodeSettings.)
Mask |
MirrorImaging | (Inherited from CodeSettings.)
ReflectanceReversal | (Inherited from CodeSettings.)
Version | (Inherited from CodeSettings.)

See Also

QRCodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


Mask Property

[image]

.NET ModelKit Suite ClassReference
QRCodeSettings..::.Mask Property
QRCodeSettings Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Framework.Drawing.QRBarCode.QRCodeSettings.Mask]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public QRCodeMask Mask { get; set; }
Visual Basic (Declaration)
Public Property Mask As QRCodeMask
Visual C++
public:
property QRCodeMask Mask {
    QRCodeMask get ();
    void set (QRCodeMask value);
}

See Also

QRCodeSettings Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


StringHead Class

[image]

.NET ModelKit Suite ClassReference
StringHead Class
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Framework.Drawing.QRBarCode.StringHead]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class StringHead
Visual Basic (Declaration)
Public Class StringHead
Visual C++
public ref class StringHead

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Drawing.QRBarCode..::.StringHead

See Also

StringHead Members
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


StringHead Members

[image] [image]

.NET ModelKit Suite ClassReference
StringHead Members
StringHead Class Constructors Methods See Also Send Feedback

The StringHead type exposes the following members.

Constructors

Name | Description
StringHead | Initializes a new instance of the StringHead class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetModeIndicator |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringHead Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


StringHead Constructor

[image]

.NET ModelKit Suite ClassReference
StringHead Constructor
StringHead Class See Also Send Feedback
Initializes a new instance of the StringHead class

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public StringHead()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StringHead()

See Also

StringHead Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


StringHead Methods

[image] [image]

.NET ModelKit Suite ClassReference
StringHead Methods
StringHead Class See Also Send Feedback

The StringHead type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetModeIndicator |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringHead Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


GetModeIndicator Method

[image]

.NET ModelKit Suite ClassReference
StringHead..::.GetModeIndicator Method
StringHead Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Drawing.QRBarCode.StringHead.GetModeIndicator(PerpetuumSoft.Framework.Drawing.QRBarCode.CodeSettings,PerpetuumSoft.Framework.Drawing.QRBarCode.QRCodeMode,System.String)]

Namespace: PerpetuumSoft.Framework.Drawing.QRBarCode
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static byte[] GetModeIndicator(
    CodeSettings settings,
    QRCodeMode mode,
    string value
)
Visual Basic (Declaration)
Public Shared Function GetModeIndicator ( _
    settings As CodeSettings, _
    mode As QRCodeMode, _
    value As String _
) As Byte()
Visual C++
public:
static array<unsigned char>^ GetModeIndicator(
    CodeSettings^ settings,
    QRCodeMode mode,
    String^ value
)

Parameters

settings
Type: PerpetuumSoft.Framework.Drawing.QRBarCode..::.CodeSettings
mode
Type: PerpetuumSoft.Framework.Drawing.QRBarCode..::.QRCodeMode
value
Type: System..::.String

See Also

StringHead Class
PerpetuumSoft.Framework.Drawing.QRBarCode Namespace


PerpetuumSoft.Framework.Export Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Framework.Export Namespace
Send Feedback
The PerpetuumSoft.Framework.Export namespace contains classes that are intended for images exporting to different formats.

Classes

Class | Description
BmpExport | Class used for export to BMP image.
Export | This class must be extended in order for Export to be available from export dialog.
FlashExport | Main class used for Flash export.
GifExport | Class used for export to GIF image.
ImageExport | Main class used for exporting to image.
JpegExport | Class used for export to JPEG image.
PngExport | Class used for export to PNG image.
SVGExport | Main class used for SVG export.
TiffExport |

Enumerations

Enumeration | Description
ImageExport..::.SizeMode | Represents avaliable picture scaling modes.


BmpExport Class

[image]

.NET ModelKit Suite ClassReference
BmpExport Class
Members See Also Send Feedback
Class used for export to BMP image.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public class BmpExport : ImageExport
Visual Basic (Declaration)
Public Class BmpExport _
    Inherits ImageExport
Visual C++
public ref class BmpExport : public ImageExport

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Export..::.Export
PerpetuumSoft.Framework.Export..::.ImageExport
PerpetuumSoft.Framework.Export..::.BmpExport

See Also

BmpExport Members
PerpetuumSoft.Framework.Export Namespace


BmpExport Members

[image] [image]

.NET ModelKit Suite ClassReference
BmpExport Members
BmpExport Class Constructors Methods Properties See Also Send Feedback

The BmpExport type exposes the following members.

Constructors

Name | Description
BmpExport | Overloaded.

Methods

Name | Description
CreateImage | Returns an image an object was exported to. (Inherited from ImageExport.)
CreateOptionsDialog | Overridden. See CreateOptionsDialog()()(). (Inherited from ImageExport.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllFilesFilter | Returns filter for all files. (Inherited from Export.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Overridden. See GetImageFormat()()(). (Overrides ImageExport..::.GetImageFormat()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Overridden. See ToString()()(). (Inherited from Export.)

Properties

Name | Description
Description | Overridden. See Description. (Overrides Export..::.Description.)
Filter | Overridden. See Filter. (Overrides Export..::.Filter.)
Mode | Gets or sets scaling mode. (Inherited from ImageExport.)
Resolution | Gets or sets image resolution. (Inherited from ImageExport.)
Scale | Gets or sets image scale. (Inherited from ImageExport.)
Size | Gets or sets image size. (Inherited from ImageExport.)

See Also

BmpExport Class
PerpetuumSoft.Framework.Export Namespace


BmpExport Constructor

[image] [image]

.NET ModelKit Suite ClassReference
BmpExport Constructor
BmpExport Class See Also Send Feedback

Overload List

Name | Description
BmpExport()()() | Initializes a new instance of the BmpExport class.
BmpExport(Vector) | Initializes a new instance of the BmpExport class with given size.
BmpExport(Double) | Initializes a new instance of the BmpExport class with given scale.
BmpExport(Int32) | Initializes a new instance of the BmpExport class with given resolution.
BmpExport(Int32, Double) | Initializes a new instance of the BmpExport class with given resolution and scale.

See Also

BmpExport Class
BmpExport Members
PerpetuumSoft.Framework.Export Namespace


BmpExport Constructor

[image]

.NET ModelKit Suite ClassReference
BmpExport Constructor
BmpExport Class See Also Send Feedback
Initializes a new instance of the BmpExport class.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public BmpExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BmpExport()

See Also

BmpExport Class
BmpExport Overload
PerpetuumSoft.Framework.Export Namespace


BmpExport Constructor (Vector)

[image]

.NET ModelKit Suite ClassReference
BmpExport Constructor (Vector)
BmpExport Class See Also Send Feedback
Initializes a new instance of the BmpExport class with given size.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public BmpExport(
    Vector size
)
Visual Basic (Declaration)
Public Sub New ( _
    size As Vector _
)
Visual C++
public:
BmpExport(
    Vector size
)

Parameters

size
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

BmpExport Class
BmpExport Overload
PerpetuumSoft.Framework.Export Namespace


BmpExport Constructor (Double)

[image]

.NET ModelKit Suite ClassReference
BmpExport Constructor (Double)
BmpExport Class See Also Send Feedback
Initializes a new instance of the BmpExport class with given scale.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public BmpExport(
    double scale
)
Visual Basic (Declaration)
Public Sub New ( _
    scale As Double _
)
Visual C++
public:
BmpExport(
    double scale
)

Parameters

scale
Type: System..::.Double

See Also

BmpExport Class
BmpExport Overload
PerpetuumSoft.Framework.Export Namespace


BmpExport Constructor (Int32)

[image]

.NET ModelKit Suite ClassReference
BmpExport Constructor (Int32)
BmpExport Class See Also Send Feedback
Initializes a new instance of the BmpExport class with given resolution.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public BmpExport(
    int resolution
)
Visual Basic (Declaration)
Public Sub New ( _
    resolution As Integer _
)
Visual C++
public:
BmpExport(
    int resolution
)

Parameters

resolution
Type: System..::.Int32

See Also

BmpExport Class
BmpExport Overload
PerpetuumSoft.Framework.Export Namespace


BmpExport Constructor (Int32, Double)

[image]

.NET ModelKit Suite ClassReference
BmpExport Constructor (Int32, Double)
BmpExport Class See Also Send Feedback
Initializes a new instance of the BmpExport class with given resolution and scale.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public BmpExport(
    int resolution,
    double scale
)
Visual Basic (Declaration)
Public Sub New ( _
    resolution As Integer, _
    scale As Double _
)
Visual C++
public:
BmpExport(
    int resolution,
    double scale
)

Parameters

resolution
Type: System..::.Int32
scale
Type: System..::.Double

See Also

BmpExport Class
BmpExport Overload
PerpetuumSoft.Framework.Export Namespace


BmpExport Methods

[image] [image]

.NET ModelKit Suite ClassReference
BmpExport Methods
BmpExport Class See Also Send Feedback

The BmpExport type exposes the following members.

Methods

Name | Description
CreateImage | Returns an image an object was exported to. (Inherited from ImageExport.)
CreateOptionsDialog | Overridden. See CreateOptionsDialog()()(). (Inherited from ImageExport.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllFilesFilter | Returns filter for all files. (Inherited from Export.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Overridden. See GetImageFormat()()(). (Overrides ImageExport..::.GetImageFormat()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Overridden. See ToString()()(). (Inherited from Export.)

See Also

BmpExport Class
PerpetuumSoft.Framework.Export Namespace


GetImageFormat Method

[image]

.NET ModelKit Suite ClassReference
BmpExport..::.GetImageFormat Method
BmpExport Class See Also Send Feedback
Overridden. See GetImageFormat()()().

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
protected override ImageFormat GetImageFormat()
Visual Basic (Declaration)
Protected Overrides Function GetImageFormat As ImageFormat
Visual C++
protected:
virtual ImageFormat^ GetImageFormat() override

See Also

BmpExport Class
PerpetuumSoft.Framework.Export Namespace


Save Method

[image] [image]

.NET ModelKit Suite ClassReference
BmpExport..::.Save Method
BmpExport Class See Also Send Feedback

Overload List

Name | Description
Save(String, PaintCallBack, Vector) | Saves an object being exported to file with given name. (Inherited from Export.)
Save(Stream, PaintCallBack, Vector) | Overridden. See Save(Stream, PaintCallBack, Vector). (Inherited from ImageExport.)

See Also

BmpExport Class
BmpExport Members
PerpetuumSoft.Framework.Export Namespace


BmpExport Properties

[image] [image]

.NET ModelKit Suite ClassReference
BmpExport Properties
BmpExport Class See Also Send Feedback

The BmpExport type exposes the following members.

Properties

Name | Description
Description | Overridden. See Description. (Overrides Export..::.Description.)
Filter | Overridden. See Filter. (Overrides Export..::.Filter.)
Mode | Gets or sets scaling mode. (Inherited from ImageExport.)
Resolution | Gets or sets image resolution. (Inherited from ImageExport.)
Scale | Gets or sets image scale. (Inherited from ImageExport.)
Size | Gets or sets image size. (Inherited from ImageExport.)

See Also

BmpExport Class
PerpetuumSoft.Framework.Export Namespace


Description Property

[image]

.NET ModelKit Suite ClassReference
BmpExport..::.Description Property
BmpExport Class See Also Send Feedback
Overridden. See Description.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override string Description { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () override;
}

See Also

BmpExport Class
PerpetuumSoft.Framework.Export Namespace


Filter Property

[image]

.NET ModelKit Suite ClassReference
BmpExport..::.Filter Property
BmpExport Class See Also Send Feedback
Overridden. See Filter.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override string Filter { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Filter As String
Visual C++
public:
virtual property String^ Filter {
    String^ get () override;
}

See Also

BmpExport Class
PerpetuumSoft.Framework.Export Namespace


Export Class

[image]

.NET ModelKit Suite ClassReference
Export Class
Members See Also Send Feedback
This class must be extended in order for Export to be available from export dialog.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public abstract class Export
Visual Basic (Declaration)
Public MustInherit Class Export
Visual C++
public ref class Export abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Export..::.Export
PerpetuumSoft.Framework.Export..::.FlashExport
PerpetuumSoft.Framework.Export..::.ImageExport
PerpetuumSoft.Framework.Export..::.SVGExport

See Also

Export Members
PerpetuumSoft.Framework.Export Namespace


Export Members

[image] [image]

.NET ModelKit Suite ClassReference
Export Members
Export Class Constructors Methods Properties See Also Send Feedback

The Export type exposes the following members.

Constructors

Name | Description
Export | Initializes a new instance of the Export class.

Methods

Name | Description
CreateOptionsDialog | Returns user control to be used in ExportDialog.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllFilesFilter | Returns filter for all files.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
Description | Returns description for Export.
Filter | FileExtension filter to be used in ExportDialog.

See Also

Export Class
PerpetuumSoft.Framework.Export Namespace


Export Constructor

[image]

.NET ModelKit Suite ClassReference
Export Constructor
Export Class See Also Send Feedback
Initializes a new instance of the Export class.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
protected Export()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
Export()

See Also

Export Class
PerpetuumSoft.Framework.Export Namespace


Export Methods

[image] [image]

.NET ModelKit Suite ClassReference
Export Methods
Export Class See Also Send Feedback

The Export type exposes the following members.

Methods

Name | Description
CreateOptionsDialog | Returns user control to be used in ExportDialog.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllFilesFilter | Returns filter for all files.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

Export Class
PerpetuumSoft.Framework.Export Namespace


CreateOptionsDialog Method

[image]

.NET ModelKit Suite ClassReference
Export..::.CreateOptionsDialog Method
Export Class See Also Send Feedback
Returns user control to be used in ExportDialog.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public virtual UserControl CreateOptionsDialog()
Visual Basic (Declaration)
Public Overridable Function CreateOptionsDialog As UserControl
Visual C++
public:
virtual UserControl^ CreateOptionsDialog()

See Also

Export Class
PerpetuumSoft.Framework.Export Namespace


GetAllFilesFilter Method

[image]

.NET ModelKit Suite ClassReference
Export..::.GetAllFilesFilter Method
Export Class See Also Send Feedback
Returns filter for all files.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
protected string GetAllFilesFilter()
Visual Basic (Declaration)
Protected Function GetAllFilesFilter As String
Visual C++
protected:
String^ GetAllFilesFilter()

See Also

Export Class
PerpetuumSoft.Framework.Export Namespace


Save Method

[image] [image]

.NET ModelKit Suite ClassReference
Export..::.Save Method
Export Class See Also Send Feedback

Overload List

Name | Description
Save(Stream, PaintCallBack, Vector) | Saves an object being exported to Stream.
Save(String, PaintCallBack, Vector) | Saves an object being exported to file with given name.

See Also

Export Class
Export Members
PerpetuumSoft.Framework.Export Namespace


Save Method (Stream, Export., Vector)

[image]

.NET ModelKit Suite ClassReference
Export..::.Save Method (Stream, Export..::., Vector)
Export Class See Also Send Feedback
Saves an object being exported to Stream.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public abstract void Save(
    Stream stream,
    PaintCallBack paintMethod,
    Vector size
)
Visual Basic (Declaration)
Public MustOverride Sub Save ( _
    stream As Stream, _
    paintMethod As PaintCallBack, _
    size As Vector _
)
Visual C++
public:
virtual void Save(
    Stream^ stream,
    PaintCallBack^ paintMethod,
    Vector size
) abstract

Parameters

stream
Type: System.IO..::.Stream
paintMethod
Type: PaintCallBack
size
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Export Class
Save Overload
PerpetuumSoft.Framework.Export Namespace


Save Method (String, Export., Vector)

[image]

.NET ModelKit Suite ClassReference
Export..::.Save Method (String, Export..::., Vector)
Export Class See Also Send Feedback
Saves an object being exported to file with given name.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public void Save(
    string fileName,
    PaintCallBack paintMethod,
    Vector size
)
Visual Basic (Declaration)
Public Sub Save ( _
    fileName As String, _
    paintMethod As PaintCallBack, _
    size As Vector _
)
Visual C++
public:
void Save(
    String^ fileName,
    PaintCallBack^ paintMethod,
    Vector size
)

Parameters

fileName
Type: System..::.String
paintMethod
Type: PaintCallBack
size
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Export Class
Save Overload
PerpetuumSoft.Framework.Export Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
Export..::.ToString Method
Export Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Export Class
PerpetuumSoft.Framework.Export Namespace


Export Properties

[image] [image]

.NET ModelKit Suite ClassReference
Export Properties
Export Class See Also Send Feedback

The Export type exposes the following members.

Properties

Name | Description
Description | Returns description for Export.
Filter | FileExtension filter to be used in ExportDialog.

See Also

Export Class
PerpetuumSoft.Framework.Export Namespace


Description Property

[image]

.NET ModelKit Suite ClassReference
Export..::.Description Property
Export Class See Also Send Feedback
Returns description for Export.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public abstract string Description { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () abstract;
}

See Also

Export Class
PerpetuumSoft.Framework.Export Namespace


Filter Property

[image]

.NET ModelKit Suite ClassReference
Export..::.Filter Property
Export Class See Also Send Feedback
FileExtension filter to be used in ExportDialog.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public abstract string Filter { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property Filter As String
Visual C++
public:
virtual property String^ Filter {
    String^ get () abstract;
}

See Also

Export Class
PerpetuumSoft.Framework.Export Namespace


FlashExport Class

[image]

.NET ModelKit Suite ClassReference
FlashExport Class
Members See Also Send Feedback
Main class used for Flash export.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public class FlashExport : Export
Visual Basic (Declaration)
Public Class FlashExport _
    Inherits Export
Visual C++
public ref class FlashExport : public Export

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Export..::.Export
PerpetuumSoft.Framework.Export..::.FlashExport

See Also

FlashExport Members
PerpetuumSoft.Framework.Export Namespace


FlashExport Members

[image] [image]

.NET ModelKit Suite ClassReference
FlashExport Members
FlashExport Class Constructors Methods Properties See Also Send Feedback

The FlashExport type exposes the following members.

Constructors

Name | Description
FlashExport | Initializes a new instance of the FlashExport class.

Methods

Name | Description
CreateOptionsDialog | Returns user control to be used in ExportDialog. (Inherited from Export.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllFilesFilter | Returns filter for all files. (Inherited from Export.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Overridden. See ToString()()(). (Inherited from Export.)

Properties

Name | Description
Description | Overridden. See Description. (Overrides Export..::.Description.)
Filter | Overridden. See Filter. (Overrides Export..::.Filter.)

See Also

FlashExport Class
PerpetuumSoft.Framework.Export Namespace


FlashExport Constructor

[image]

.NET ModelKit Suite ClassReference
FlashExport Constructor
FlashExport Class See Also Send Feedback
Initializes a new instance of the FlashExport class.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public FlashExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FlashExport()

See Also

FlashExport Class
PerpetuumSoft.Framework.Export Namespace


FlashExport Methods

[image] [image]

.NET ModelKit Suite ClassReference
FlashExport Methods
FlashExport Class See Also Send Feedback

The FlashExport type exposes the following members.

Methods

Name | Description
CreateOptionsDialog | Returns user control to be used in ExportDialog. (Inherited from Export.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllFilesFilter | Returns filter for all files. (Inherited from Export.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Overridden. See ToString()()(). (Inherited from Export.)

See Also

FlashExport Class
PerpetuumSoft.Framework.Export Namespace


Save Method

[image] [image]

.NET ModelKit Suite ClassReference
FlashExport..::.Save Method
FlashExport Class See Also Send Feedback

Overload List

Name | Description
Save(String, PaintCallBack, Vector) | Saves an object being exported to file with given name. (Inherited from Export.)
Save(Stream, PaintCallBack, Vector) | Overridden. See Save(Stream, PaintCallBack, Vector). (Overrides Export..::.Save(Stream, PaintCallBack, Vector).)

See Also

FlashExport Class
FlashExport Members
PerpetuumSoft.Framework.Export Namespace


Save Method (Stream, Export., Vector)

[image]

.NET ModelKit Suite ClassReference
FlashExport..::.Save Method (Stream, Export..::., Vector)
FlashExport Class See Also Send Feedback
Overridden. See Save(Stream, PaintCallBack, Vector).

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override void Save(
    Stream stream,
    PaintCallBack paintMethod,
    Vector size
)
Visual Basic (Declaration)
Public Overrides Sub Save ( _
    stream As Stream, _
    paintMethod As PaintCallBack, _
    size As Vector _
)
Visual C++
public:
virtual void Save(
    Stream^ stream,
    PaintCallBack^ paintMethod,
    Vector size
) override

Parameters

stream
Type: System.IO..::.Stream
paintMethod
Type: PaintCallBack
size
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

FlashExport Class
Save Overload
PerpetuumSoft.Framework.Export Namespace


FlashExport Properties

[image] [image]

.NET ModelKit Suite ClassReference
FlashExport Properties
FlashExport Class See Also Send Feedback

The FlashExport type exposes the following members.

Properties

Name | Description
Description | Overridden. See Description. (Overrides Export..::.Description.)
Filter | Overridden. See Filter. (Overrides Export..::.Filter.)

See Also

FlashExport Class
PerpetuumSoft.Framework.Export Namespace


Description Property

[image]

.NET ModelKit Suite ClassReference
FlashExport..::.Description Property
FlashExport Class See Also Send Feedback
Overridden. See Description.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override string Description { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () override;
}

See Also

FlashExport Class
PerpetuumSoft.Framework.Export Namespace


Filter Property

[image]

.NET ModelKit Suite ClassReference
FlashExport..::.Filter Property
FlashExport Class See Also Send Feedback
Overridden. See Filter.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override string Filter { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Filter As String
Visual C++
public:
virtual property String^ Filter {
    String^ get () override;
}

See Also

FlashExport Class
PerpetuumSoft.Framework.Export Namespace


GifExport Class

[image]

.NET ModelKit Suite ClassReference
GifExport Class
Members See Also Send Feedback
Class used for export to GIF image.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public class GifExport : ImageExport
Visual Basic (Declaration)
Public Class GifExport _
    Inherits ImageExport
Visual C++
public ref class GifExport : public ImageExport

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Export..::.Export
PerpetuumSoft.Framework.Export..::.ImageExport
PerpetuumSoft.Framework.Export..::.GifExport

See Also

GifExport Members
PerpetuumSoft.Framework.Export Namespace


GifExport Members

[image] [image]

.NET ModelKit Suite ClassReference
GifExport Members
GifExport Class Constructors Methods Properties See Also Send Feedback

The GifExport type exposes the following members.

Constructors

Name | Description
GifExport | Overloaded.

Methods

Name | Description
CreateImage | Returns an image an object was exported to. (Inherited from ImageExport.)
CreateOptionsDialog | Overridden. See CreateOptionsDialog()()(). (Inherited from ImageExport.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllFilesFilter | Returns filter for all files. (Inherited from Export.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Overridden. See GetImageFormat()()(). (Overrides ImageExport..::.GetImageFormat()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Overridden. See ToString()()(). (Inherited from Export.)

Properties

Name | Description
Description | Overridden. See Description. (Overrides Export..::.Description.)
Filter | Overridden. See Filter. (Overrides Export..::.Filter.)
Mode | Gets or sets scaling mode. (Inherited from ImageExport.)
Resolution | Gets or sets image resolution. (Inherited from ImageExport.)
Scale | Gets or sets image scale. (Inherited from ImageExport.)
Size | Gets or sets image size. (Inherited from ImageExport.)

See Also

GifExport Class
PerpetuumSoft.Framework.Export Namespace


GifExport Constructor

[image] [image]

.NET ModelKit Suite ClassReference
GifExport Constructor
GifExport Class See Also Send Feedback

Overload List

Name | Description
GifExport()()() | Initializes a new instance of the GifExport class.
GifExport(Vector) | Initializes a new instance of the GifExport class with given image size.
GifExport(Double) | Initializes a new instance of the GifExport class with given scale.
GifExport(Int32) | Initializes a new instance of the GifExport class with given resolution.
GifExport(Int32, Double) | Initializes a new instance of the GifExport class with given resolution and scale.

See Also

GifExport Class
GifExport Members
PerpetuumSoft.Framework.Export Namespace


GifExport Constructor

[image]

.NET ModelKit Suite ClassReference
GifExport Constructor
GifExport Class See Also Send Feedback
Initializes a new instance of the GifExport class.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public GifExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GifExport()

See Also

GifExport Class
GifExport Overload
PerpetuumSoft.Framework.Export Namespace


GifExport Constructor (Vector)

[image]

.NET ModelKit Suite ClassReference
GifExport Constructor (Vector)
GifExport Class See Also Send Feedback
Initializes a new instance of the GifExport class with given image size.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public GifExport(
    Vector size
)
Visual Basic (Declaration)
Public Sub New ( _
    size As Vector _
)
Visual C++
public:
GifExport(
    Vector size
)

Parameters

size
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

GifExport Class
GifExport Overload
PerpetuumSoft.Framework.Export Namespace


GifExport Constructor (Double)

[image]

.NET ModelKit Suite ClassReference
GifExport Constructor (Double)
GifExport Class See Also Send Feedback
Initializes a new instance of the GifExport class with given scale.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public GifExport(
    double scale
)
Visual Basic (Declaration)
Public Sub New ( _
    scale As Double _
)
Visual C++
public:
GifExport(
    double scale
)

Parameters

scale
Type: System..::.Double

See Also

GifExport Class
GifExport Overload
PerpetuumSoft.Framework.Export Namespace


GifExport Constructor (Int32)

[image]

.NET ModelKit Suite ClassReference
GifExport Constructor (Int32)
GifExport Class See Also Send Feedback
Initializes a new instance of the GifExport class with given resolution.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public GifExport(
    int resolution
)
Visual Basic (Declaration)
Public Sub New ( _
    resolution As Integer _
)
Visual C++
public:
GifExport(
    int resolution
)

Parameters

resolution
Type: System..::.Int32

See Also

GifExport Class
GifExport Overload
PerpetuumSoft.Framework.Export Namespace


GifExport Constructor (Int32, Double)

[image]

.NET ModelKit Suite ClassReference
GifExport Constructor (Int32, Double)
GifExport Class See Also Send Feedback
Initializes a new instance of the GifExport class with given resolution and scale.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public GifExport(
    int resolution,
    double scale
)
Visual Basic (Declaration)
Public Sub New ( _
    resolution As Integer, _
    scale As Double _
)
Visual C++
public:
GifExport(
    int resolution,
    double scale
)

Parameters

resolution
Type: System..::.Int32
scale
Type: System..::.Double

See Also

GifExport Class
GifExport Overload
PerpetuumSoft.Framework.Export Namespace


GifExport Methods

[image] [image]

.NET ModelKit Suite ClassReference
GifExport Methods
GifExport Class See Also Send Feedback

The GifExport type exposes the following members.

Methods

Name | Description
CreateImage | Returns an image an object was exported to. (Inherited from ImageExport.)
CreateOptionsDialog | Overridden. See CreateOptionsDialog()()(). (Inherited from ImageExport.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllFilesFilter | Returns filter for all files. (Inherited from Export.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Overridden. See GetImageFormat()()(). (Overrides ImageExport..::.GetImageFormat()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Overridden. See ToString()()(). (Inherited from Export.)

See Also

GifExport Class
PerpetuumSoft.Framework.Export Namespace


GetImageFormat Method

[image]

.NET ModelKit Suite ClassReference
GifExport..::.GetImageFormat Method
GifExport Class See Also Send Feedback
Overridden. See GetImageFormat()()().

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
protected override ImageFormat GetImageFormat()
Visual Basic (Declaration)
Protected Overrides Function GetImageFormat As ImageFormat
Visual C++
protected:
virtual ImageFormat^ GetImageFormat() override

See Also

GifExport Class
PerpetuumSoft.Framework.Export Namespace


Save Method

[image] [image]

.NET ModelKit Suite ClassReference
GifExport..::.Save Method
GifExport Class See Also Send Feedback

Overload List

Name | Description
Save(String, PaintCallBack, Vector) | Saves an object being exported to file with given name. (Inherited from Export.)
Save(Stream, PaintCallBack, Vector) | Overridden. See Save(Stream, PaintCallBack, Vector). (Inherited from ImageExport.)

See Also

GifExport Class
GifExport Members
PerpetuumSoft.Framework.Export Namespace


GifExport Properties

[image] [image]

.NET ModelKit Suite ClassReference
GifExport Properties
GifExport Class See Also Send Feedback

The GifExport type exposes the following members.

Properties

Name | Description
Description | Overridden. See Description. (Overrides Export..::.Description.)
Filter | Overridden. See Filter. (Overrides Export..::.Filter.)
Mode | Gets or sets scaling mode. (Inherited from ImageExport.)
Resolution | Gets or sets image resolution. (Inherited from ImageExport.)
Scale | Gets or sets image scale. (Inherited from ImageExport.)
Size | Gets or sets image size. (Inherited from ImageExport.)

See Also

GifExport Class
PerpetuumSoft.Framework.Export Namespace


Description Property

[image]

.NET ModelKit Suite ClassReference
GifExport..::.Description Property
GifExport Class See Also Send Feedback
Overridden. See Description.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override string Description { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () override;
}

See Also

GifExport Class
PerpetuumSoft.Framework.Export Namespace


Filter Property

[image]

.NET ModelKit Suite ClassReference
GifExport..::.Filter Property
GifExport Class See Also Send Feedback
Overridden. See Filter.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override string Filter { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Filter As String
Visual C++
public:
virtual property String^ Filter {
    String^ get () override;
}

See Also

GifExport Class
PerpetuumSoft.Framework.Export Namespace


ImageExport Class

[image]

.NET ModelKit Suite ClassReference
ImageExport Class
Members See Also Send Feedback
Main class used for exporting to image.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public abstract class ImageExport : Export
Visual Basic (Declaration)
Public MustInherit Class ImageExport _
    Inherits Export
Visual C++
public ref class ImageExport abstract : public Export

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Export..::.Export
PerpetuumSoft.Framework.Export..::.ImageExport
PerpetuumSoft.Framework.Export..::.BmpExport
PerpetuumSoft.Framework.Export..::.GifExport
PerpetuumSoft.Framework.Export..::.JpegExport
PerpetuumSoft.Framework.Export..::.PngExport
PerpetuumSoft.Framework.Export..::.TiffExport

See Also

ImageExport Members
PerpetuumSoft.Framework.Export Namespace


ImageExport Members

[image] [image]

.NET ModelKit Suite ClassReference
ImageExport Members
ImageExport Class Constructors Methods Properties See Also Send Feedback

The ImageExport type exposes the following members.

Constructors

Name | Description
ImageExport | Overloaded.

Methods

Name | Description
CreateImage | Returns an image an object was exported to.
CreateOptionsDialog | Overridden. See CreateOptionsDialog()()(). (Overrides Export..::.CreateOptionsDialog()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllFilesFilter | Returns filter for all files. (Inherited from Export.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Returns ImageFormat used.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Overridden. See ToString()()(). (Inherited from Export.)

Properties

Name | Description
Description | Returns description for Export. (Inherited from Export.)
Filter | FileExtension filter to be used in ExportDialog. (Inherited from Export.)
Mode | Gets or sets scaling mode.
Resolution | Gets or sets image resolution.
Scale | Gets or sets image scale.
Size | Gets or sets image size.

See Also

ImageExport Class
PerpetuumSoft.Framework.Export Namespace


ImageExport Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ImageExport Constructor
ImageExport Class See Also Send Feedback

Overload List

Name | Description
ImageExport()()() | Initializes a new instance of the ImageExport class.
ImageExport(Vector) | Initializes a new instance of the ImageExport class with given image size.
ImageExport(Double) | Initializes a new instance of the ImageExport class with given scale.
ImageExport(Int32) | Initializes a new instance of the ImageExport class with given resolution.
ImageExport(Int32, Double) | Initializes a new instance of the ImageExport class with given resolution and scale.

See Also

ImageExport Class
ImageExport Members
PerpetuumSoft.Framework.Export Namespace


ImageExport Constructor

[image]

.NET ModelKit Suite ClassReference
ImageExport Constructor
ImageExport Class See Also Send Feedback
Initializes a new instance of the ImageExport class.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public ImageExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ImageExport()

See Also

ImageExport Class
ImageExport Overload
PerpetuumSoft.Framework.Export Namespace


ImageExport Constructor (Vector)

[image]

.NET ModelKit Suite ClassReference
ImageExport Constructor (Vector)
ImageExport Class See Also Send Feedback
Initializes a new instance of the ImageExport class with given image size.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public ImageExport(
    Vector size
)
Visual Basic (Declaration)
Public Sub New ( _
    size As Vector _
)
Visual C++
public:
ImageExport(
    Vector size
)

Parameters

size
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

ImageExport Class
ImageExport Overload
PerpetuumSoft.Framework.Export Namespace


ImageExport Constructor (Double)

[image]

.NET ModelKit Suite ClassReference
ImageExport Constructor (Double)
ImageExport Class See Also Send Feedback
Initializes a new instance of the ImageExport class with given scale.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public ImageExport(
    double scale
)
Visual Basic (Declaration)
Public Sub New ( _
    scale As Double _
)
Visual C++
public:
ImageExport(
    double scale
)

Parameters

scale
Type: System..::.Double

See Also

ImageExport Class
ImageExport Overload
PerpetuumSoft.Framework.Export Namespace


ImageExport Constructor (Int32)

[image]

.NET ModelKit Suite ClassReference
ImageExport Constructor (Int32)
ImageExport Class See Also Send Feedback
Initializes a new instance of the ImageExport class with given resolution.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public ImageExport(
    int resolution
)
Visual Basic (Declaration)
Public Sub New ( _
    resolution As Integer _
)
Visual C++
public:
ImageExport(
    int resolution
)

Parameters

resolution
Type: System..::.Int32

See Also

ImageExport Class
ImageExport Overload
PerpetuumSoft.Framework.Export Namespace


ImageExport Constructor (Int32, Double)

[image]

.NET ModelKit Suite ClassReference
ImageExport Constructor (Int32, Double)
ImageExport Class See Also Send Feedback
Initializes a new instance of the ImageExport class with given resolution and scale.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public ImageExport(
    int resolution,
    double scale
)
Visual Basic (Declaration)
Public Sub New ( _
    resolution As Integer, _
    scale As Double _
)
Visual C++
public:
ImageExport(
    int resolution,
    double scale
)

Parameters

resolution
Type: System..::.Int32
scale
Type: System..::.Double

See Also

ImageExport Class
ImageExport Overload
PerpetuumSoft.Framework.Export Namespace


ImageExport Methods

[image] [image]

.NET ModelKit Suite ClassReference
ImageExport Methods
ImageExport Class See Also Send Feedback

The ImageExport type exposes the following members.

Methods

Name | Description
CreateImage | Returns an image an object was exported to.
CreateOptionsDialog | Overridden. See CreateOptionsDialog()()(). (Overrides Export..::.CreateOptionsDialog()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllFilesFilter | Returns filter for all files. (Inherited from Export.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Returns ImageFormat used.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Overridden. See ToString()()(). (Inherited from Export.)

See Also

ImageExport Class
PerpetuumSoft.Framework.Export Namespace


CreateImage Method

[image]

.NET ModelKit Suite ClassReference
ImageExport..::.CreateImage Method
ImageExport Class See Also Send Feedback
Returns an image an object was exported to.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public Image CreateImage(
    PaintCallBack paintMethod,
    Vector viewSize
)
Visual Basic (Declaration)
Public Function CreateImage ( _
    paintMethod As PaintCallBack, _
    viewSize As Vector _
) As Image
Visual C++
public:
Image^ CreateImage(
    PaintCallBack^ paintMethod,
    Vector viewSize
)

Parameters

paintMethod
Type: PaintCallBack
viewSize
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

ImageExport Class
PerpetuumSoft.Framework.Export Namespace


CreateOptionsDialog Method

[image]

.NET ModelKit Suite ClassReference
ImageExport..::.CreateOptionsDialog Method
ImageExport Class See Also Send Feedback
Overridden. See CreateOptionsDialog()()().

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override UserControl CreateOptionsDialog()
Visual Basic (Declaration)
Public Overrides Function CreateOptionsDialog As UserControl
Visual C++
public:
virtual UserControl^ CreateOptionsDialog() override

See Also

ImageExport Class
PerpetuumSoft.Framework.Export Namespace


GetImageFormat Method

[image]

.NET ModelKit Suite ClassReference
ImageExport..::.GetImageFormat Method
ImageExport Class See Also Send Feedback
Returns ImageFormat used.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
protected abstract ImageFormat GetImageFormat()
Visual Basic (Declaration)
Protected MustOverride Function GetImageFormat As ImageFormat
Visual C++
protected:
virtual ImageFormat^ GetImageFormat() abstract

See Also

ImageExport Class
PerpetuumSoft.Framework.Export Namespace


Save Method

[image] [image]

.NET ModelKit Suite ClassReference
ImageExport..::.Save Method
ImageExport Class See Also Send Feedback

Overload List

Name | Description
Save(String, PaintCallBack, Vector) | Saves an object being exported to file with given name. (Inherited from Export.)
Save(Stream, PaintCallBack, Vector) | Overridden. See Save(Stream, PaintCallBack, Vector). (Overrides Export..::.Save(Stream, PaintCallBack, Vector).)

See Also

ImageExport Class
ImageExport Members
PerpetuumSoft.Framework.Export Namespace


Save Method (Stream, Export., Vector)

[image]

.NET ModelKit Suite ClassReference
ImageExport..::.Save Method (Stream, Export..::., Vector)
ImageExport Class See Also Send Feedback
Overridden. See Save(Stream, PaintCallBack, Vector).

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override void Save(
    Stream stream,
    PaintCallBack paintMethod,
    Vector size
)
Visual Basic (Declaration)
Public Overrides Sub Save ( _
    stream As Stream, _
    paintMethod As PaintCallBack, _
    size As Vector _
)
Visual C++
public:
virtual void Save(
    Stream^ stream,
    PaintCallBack^ paintMethod,
    Vector size
) override

Parameters

stream
Type: System.IO..::.Stream
paintMethod
Type: PaintCallBack
size
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

ImageExport Class
Save Overload
PerpetuumSoft.Framework.Export Namespace


ImageExport Properties

[image] [image]

.NET ModelKit Suite ClassReference
ImageExport Properties
ImageExport Class See Also Send Feedback

The ImageExport type exposes the following members.

Properties

Name | Description
Description | Returns description for Export. (Inherited from Export.)
Filter | FileExtension filter to be used in ExportDialog. (Inherited from Export.)
Mode | Gets or sets scaling mode.
Resolution | Gets or sets image resolution.
Scale | Gets or sets image scale.
Size | Gets or sets image size.

See Also

ImageExport Class
PerpetuumSoft.Framework.Export Namespace


Mode Property

[image]

.NET ModelKit Suite ClassReference
ImageExport..::.Mode Property
ImageExport Class See Also Send Feedback
Gets or sets scaling mode.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public ImageExport..::.SizeMode Mode { get; set; }
Visual Basic (Declaration)
Public Property Mode As ImageExport..::.SizeMode
Visual C++
public:
property ImageExport..::.SizeMode Mode {
    ImageExport..::.SizeMode get ();
    void set (ImageExport..::.SizeMode value);
}

See Also

ImageExport Class
PerpetuumSoft.Framework.Export Namespace


Resolution Property

[image]

.NET ModelKit Suite ClassReference
ImageExport..::.Resolution Property
ImageExport Class See Also Send Feedback
Gets or sets image resolution.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public int Resolution { get; set; }
Visual Basic (Declaration)
Public Property Resolution As Integer
Visual C++
public:
property int Resolution {
    int get ();
    void set (int value);
}

See Also

ImageExport Class
PerpetuumSoft.Framework.Export Namespace


Scale Property

[image]

.NET ModelKit Suite ClassReference
ImageExport..::.Scale Property
ImageExport Class See Also Send Feedback
Gets or sets image scale.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public double Scale { get; set; }
Visual Basic (Declaration)
Public Property Scale As Double
Visual C++
public:
property double Scale {
    double get ();
    void set (double value);
}

See Also

ImageExport Class
PerpetuumSoft.Framework.Export Namespace


Size Property

[image]

.NET ModelKit Suite ClassReference
ImageExport..::.Size Property
ImageExport Class See Also Send Feedback
Gets or sets image size.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public Vector Size { get; set; }
Visual Basic (Declaration)
Public Property Size As Vector
Visual C++
public:
property Vector Size {
    Vector get ();
    void set (Vector value);
}

See Also

ImageExport Class
PerpetuumSoft.Framework.Export Namespace


ImageExport.SizeMode Enumeration

[image]

.NET ModelKit Suite ClassReference
ImageExport..::.SizeMode Enumeration
ImageExport Class See Also Send Feedback
Represents avaliable picture scaling modes.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public enum SizeMode
Visual Basic (Declaration)
Public Enumeration SizeMode
Visual C++
public enum class SizeMode

Members

Member name | Description
Size | Scaling by size.
Resolution | Scaling by resolution.

See Also

PerpetuumSoft.Framework.Export Namespace


JpegExport Class

[image]

.NET ModelKit Suite ClassReference
JpegExport Class
Members See Also Send Feedback
Class used for export to JPEG image.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public class JpegExport : ImageExport
Visual Basic (Declaration)
Public Class JpegExport _
    Inherits ImageExport
Visual C++
public ref class JpegExport : public ImageExport

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Export..::.Export
PerpetuumSoft.Framework.Export..::.ImageExport
PerpetuumSoft.Framework.Export..::.JpegExport

See Also

JpegExport Members
PerpetuumSoft.Framework.Export Namespace


JpegExport Members

[image] [image]

.NET ModelKit Suite ClassReference
JpegExport Members
JpegExport Class Constructors Methods Properties See Also Send Feedback

The JpegExport type exposes the following members.

Constructors

Name | Description
JpegExport | Overloaded.

Methods

Name | Description
CreateImage | Returns an image an object was exported to. (Inherited from ImageExport.)
CreateOptionsDialog | Overridden. See CreateOptionsDialog()()(). (Overrides ImageExport..::.CreateOptionsDialog()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllFilesFilter | Returns filter for all files. (Inherited from Export.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Overridden. See GetImageFormat()()(). (Overrides ImageExport..::.GetImageFormat()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Overridden. See ToString()()(). (Inherited from Export.)

Properties

Name | Description
Description | Overridden. See Description. (Overrides Export..::.Description.)
Filter | Overridden. See Filter. (Overrides Export..::.Filter.)
JpegQuality | Gets or sets Int32
Mode | Gets or sets scaling mode. (Inherited from ImageExport.)
Resolution | Gets or sets image resolution. (Inherited from ImageExport.)
Scale | Gets or sets image scale. (Inherited from ImageExport.)
Size | Gets or sets image size. (Inherited from ImageExport.)

See Also

JpegExport Class
PerpetuumSoft.Framework.Export Namespace


JpegExport Constructor

[image] [image]

.NET ModelKit Suite ClassReference
JpegExport Constructor
JpegExport Class See Also Send Feedback

Overload List

Name | Description
JpegExport()()() | Initializes a new instance of the JpegExport class.
JpegExport(Vector) | Initializes a new instance of the JpegExport class with given image size.
JpegExport(Double) | Initializes a new instance of the JpegExport class with given scale.
JpegExport(Int32) | Initializes a new instance of the JpegExport class with given resolution.
JpegExport(Int32, Double) | Initializes a new instance of the JpegExport class with given resolution and scale.

See Also

JpegExport Class
JpegExport Members
PerpetuumSoft.Framework.Export Namespace


JpegExport Constructor

[image]

.NET ModelKit Suite ClassReference
JpegExport Constructor
JpegExport Class See Also Send Feedback
Initializes a new instance of the JpegExport class.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public JpegExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
JpegExport()

See Also

JpegExport Class
JpegExport Overload
PerpetuumSoft.Framework.Export Namespace


JpegExport Constructor (Vector)

[image]

.NET ModelKit Suite ClassReference
JpegExport Constructor (Vector)
JpegExport Class See Also Send Feedback
Initializes a new instance of the JpegExport class with given image size.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public JpegExport(
    Vector size
)
Visual Basic (Declaration)
Public Sub New ( _
    size As Vector _
)
Visual C++
public:
JpegExport(
    Vector size
)

Parameters

size
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

JpegExport Class
JpegExport Overload
PerpetuumSoft.Framework.Export Namespace


JpegExport Constructor (Double)

[image]

.NET ModelKit Suite ClassReference
JpegExport Constructor (Double)
JpegExport Class See Also Send Feedback
Initializes a new instance of the JpegExport class with given scale.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public JpegExport(
    double scale
)
Visual Basic (Declaration)
Public Sub New ( _
    scale As Double _
)
Visual C++
public:
JpegExport(
    double scale
)

Parameters

scale
Type: System..::.Double

See Also

JpegExport Class
JpegExport Overload
PerpetuumSoft.Framework.Export Namespace


JpegExport Constructor (Int32)

[image]

.NET ModelKit Suite ClassReference
JpegExport Constructor (Int32)
JpegExport Class See Also Send Feedback
Initializes a new instance of the JpegExport class with given resolution.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public JpegExport(
    int resolution
)
Visual Basic (Declaration)
Public Sub New ( _
    resolution As Integer _
)
Visual C++
public:
JpegExport(
    int resolution
)

Parameters

resolution
Type: System..::.Int32

See Also

JpegExport Class
JpegExport Overload
PerpetuumSoft.Framework.Export Namespace


JpegExport Constructor (Int32, Double)

[image]

.NET ModelKit Suite ClassReference
JpegExport Constructor (Int32, Double)
JpegExport Class See Also Send Feedback
Initializes a new instance of the JpegExport class with given resolution and scale.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public JpegExport(
    int resolution,
    double scale
)
Visual Basic (Declaration)
Public Sub New ( _
    resolution As Integer, _
    scale As Double _
)
Visual C++
public:
JpegExport(
    int resolution,
    double scale
)

Parameters

resolution
Type: System..::.Int32
scale
Type: System..::.Double

See Also

JpegExport Class
JpegExport Overload
PerpetuumSoft.Framework.Export Namespace


JpegExport Methods

[image] [image]

.NET ModelKit Suite ClassReference
JpegExport Methods
JpegExport Class See Also Send Feedback

The JpegExport type exposes the following members.

Methods

Name | Description
CreateImage | Returns an image an object was exported to. (Inherited from ImageExport.)
CreateOptionsDialog | Overridden. See CreateOptionsDialog()()(). (Overrides ImageExport..::.CreateOptionsDialog()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllFilesFilter | Returns filter for all files. (Inherited from Export.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Overridden. See GetImageFormat()()(). (Overrides ImageExport..::.GetImageFormat()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Overridden. See ToString()()(). (Inherited from Export.)

See Also

JpegExport Class
PerpetuumSoft.Framework.Export Namespace


CreateOptionsDialog Method

[image]

.NET ModelKit Suite ClassReference
JpegExport..::.CreateOptionsDialog Method
JpegExport Class See Also Send Feedback
Overridden. See CreateOptionsDialog()()().

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override UserControl CreateOptionsDialog()
Visual Basic (Declaration)
Public Overrides Function CreateOptionsDialog As UserControl
Visual C++
public:
virtual UserControl^ CreateOptionsDialog() override

See Also

JpegExport Class
PerpetuumSoft.Framework.Export Namespace


GetImageFormat Method

[image]

.NET ModelKit Suite ClassReference
JpegExport..::.GetImageFormat Method
JpegExport Class See Also Send Feedback
Overridden. See GetImageFormat()()().

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
protected override ImageFormat GetImageFormat()
Visual Basic (Declaration)
Protected Overrides Function GetImageFormat As ImageFormat
Visual C++
protected:
virtual ImageFormat^ GetImageFormat() override

See Also

JpegExport Class
PerpetuumSoft.Framework.Export Namespace


Save Method

[image] [image]

.NET ModelKit Suite ClassReference
JpegExport..::.Save Method
JpegExport Class See Also Send Feedback

Overload List

Name | Description
Save(String, PaintCallBack, Vector) | Saves an object being exported to file with given name. (Inherited from Export.)
Save(Stream, PaintCallBack, Vector) | Overridden. See Save(Stream, PaintCallBack, Vector). (Overrides ImageExport..::.Save(Stream, PaintCallBack, Vector).)

See Also

JpegExport Class
JpegExport Members
PerpetuumSoft.Framework.Export Namespace


Save Method (Stream, Export., Vector)

[image]

.NET ModelKit Suite ClassReference
JpegExport..::.Save Method (Stream, Export..::., Vector)
JpegExport Class See Also Send Feedback
Overridden. See Save(Stream, PaintCallBack, Vector).

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override void Save(
    Stream stream,
    PaintCallBack paintMethod,
    Vector size
)
Visual Basic (Declaration)
Public Overrides Sub Save ( _
    stream As Stream, _
    paintMethod As PaintCallBack, _
    size As Vector _
)
Visual C++
public:
virtual void Save(
    Stream^ stream,
    PaintCallBack^ paintMethod,
    Vector size
) override

Parameters

stream
Type: System.IO..::.Stream
paintMethod
Type: PaintCallBack
size
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

JpegExport Class
Save Overload
PerpetuumSoft.Framework.Export Namespace


JpegExport Properties

[image] [image]

.NET ModelKit Suite ClassReference
JpegExport Properties
JpegExport Class See Also Send Feedback

The JpegExport type exposes the following members.

Properties

Name | Description
Description | Overridden. See Description. (Overrides Export..::.Description.)
Filter | Overridden. See Filter. (Overrides Export..::.Filter.)
JpegQuality | Gets or sets Int32
Mode | Gets or sets scaling mode. (Inherited from ImageExport.)
Resolution | Gets or sets image resolution. (Inherited from ImageExport.)
Scale | Gets or sets image scale. (Inherited from ImageExport.)
Size | Gets or sets image size. (Inherited from ImageExport.)

See Also

JpegExport Class
PerpetuumSoft.Framework.Export Namespace


Description Property

[image]

.NET ModelKit Suite ClassReference
JpegExport..::.Description Property
JpegExport Class See Also Send Feedback
Overridden. See Description.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override string Description { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () override;
}

See Also

JpegExport Class
PerpetuumSoft.Framework.Export Namespace


Filter Property

[image]

.NET ModelKit Suite ClassReference
JpegExport..::.Filter Property
JpegExport Class See Also Send Feedback
Overridden. See Filter.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override string Filter { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Filter As String
Visual C++
public:
virtual property String^ Filter {
    String^ get () override;
}

See Also

JpegExport Class
PerpetuumSoft.Framework.Export Namespace


JpegQuality Property

[image]

.NET ModelKit Suite ClassReference
JpegExport..::.JpegQuality Property
JpegExport Class See Also Send Feedback
Gets or sets Int32

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public int JpegQuality { get; set; }
Visual Basic (Declaration)
Public Property JpegQuality As Integer
Visual C++
public:
property int JpegQuality {
    int get ();
    void set (int value);
}

See Also

JpegExport Class
PerpetuumSoft.Framework.Export Namespace


PngExport Class

[image]

.NET ModelKit Suite ClassReference
PngExport Class
Members See Also Send Feedback
Class used for export to PNG image.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public class PngExport : ImageExport
Visual Basic (Declaration)
Public Class PngExport _
    Inherits ImageExport
Visual C++
public ref class PngExport : public ImageExport

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Export..::.Export
PerpetuumSoft.Framework.Export..::.ImageExport
PerpetuumSoft.Framework.Export..::.PngExport

See Also

PngExport Members
PerpetuumSoft.Framework.Export Namespace


PngExport Members

[image] [image]

.NET ModelKit Suite ClassReference
PngExport Members
PngExport Class Constructors Methods Properties See Also Send Feedback

The PngExport type exposes the following members.

Constructors

Name | Description
PngExport | Overloaded.

Methods

Name | Description
CreateImage | Returns an image an object was exported to. (Inherited from ImageExport.)
CreateOptionsDialog | Overridden. See CreateOptionsDialog()()(). (Inherited from ImageExport.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllFilesFilter | Returns filter for all files. (Inherited from Export.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Overridden. See GetImageFormat()()(). (Overrides ImageExport..::.GetImageFormat()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Overridden. See ToString()()(). (Inherited from Export.)

Properties

Name | Description
Description | Overridden. See Description. (Overrides Export..::.Description.)
Filter | Overridden. See Filter. (Overrides Export..::.Filter.)
Mode | Gets or sets scaling mode. (Inherited from ImageExport.)
Resolution | Gets or sets image resolution. (Inherited from ImageExport.)
Scale | Gets or sets image scale. (Inherited from ImageExport.)
Size | Gets or sets image size. (Inherited from ImageExport.)

See Also

PngExport Class
PerpetuumSoft.Framework.Export Namespace


PngExport Constructor

[image] [image]

.NET ModelKit Suite ClassReference
PngExport Constructor
PngExport Class See Also Send Feedback

Overload List

Name | Description
PngExport()()() | Initializes a new instance of the PngExport class.
PngExport(Vector) | Initializes a new instance of the PngExport class with given image size.
PngExport(Double) | Initializes a new instance of the PngExport class with given scale.
PngExport(Int32) | Initializes a new instance of the PngExport class with given resolution.
PngExport(Int32, Double) | Initializes a new instance of the PngExport class with given scale and resolution.

See Also

PngExport Class
PngExport Members
PerpetuumSoft.Framework.Export Namespace


PngExport Constructor

[image]

.NET ModelKit Suite ClassReference
PngExport Constructor
PngExport Class See Also Send Feedback
Initializes a new instance of the PngExport class.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public PngExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PngExport()

See Also

PngExport Class
PngExport Overload
PerpetuumSoft.Framework.Export Namespace


PngExport Constructor (Vector)

[image]

.NET ModelKit Suite ClassReference
PngExport Constructor (Vector)
PngExport Class See Also Send Feedback
Initializes a new instance of the PngExport class with given image size.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public PngExport(
    Vector size
)
Visual Basic (Declaration)
Public Sub New ( _
    size As Vector _
)
Visual C++
public:
PngExport(
    Vector size
)

Parameters

size
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

PngExport Class
PngExport Overload
PerpetuumSoft.Framework.Export Namespace


PngExport Constructor (Double)

[image]

.NET ModelKit Suite ClassReference
PngExport Constructor (Double)
PngExport Class See Also Send Feedback
Initializes a new instance of the PngExport class with given scale.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public PngExport(
    double scale
)
Visual Basic (Declaration)
Public Sub New ( _
    scale As Double _
)
Visual C++
public:
PngExport(
    double scale
)

Parameters

scale
Type: System..::.Double

See Also

PngExport Class
PngExport Overload
PerpetuumSoft.Framework.Export Namespace


PngExport Constructor (Int32)

[image]

.NET ModelKit Suite ClassReference
PngExport Constructor (Int32)
PngExport Class See Also Send Feedback
Initializes a new instance of the PngExport class with given resolution.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public PngExport(
    int resolution
)
Visual Basic (Declaration)
Public Sub New ( _
    resolution As Integer _
)
Visual C++
public:
PngExport(
    int resolution
)

Parameters

resolution
Type: System..::.Int32

See Also

PngExport Class
PngExport Overload
PerpetuumSoft.Framework.Export Namespace


PngExport Constructor (Int32, Double)

[image]

.NET ModelKit Suite ClassReference
PngExport Constructor (Int32, Double)
PngExport Class See Also Send Feedback
Initializes a new instance of the PngExport class with given scale and resolution.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public PngExport(
    int resolution,
    double scale
)
Visual Basic (Declaration)
Public Sub New ( _
    resolution As Integer, _
    scale As Double _
)
Visual C++
public:
PngExport(
    int resolution,
    double scale
)

Parameters

resolution
Type: System..::.Int32
scale
Type: System..::.Double

See Also

PngExport Class
PngExport Overload
PerpetuumSoft.Framework.Export Namespace


PngExport Methods

[image] [image]

.NET ModelKit Suite ClassReference
PngExport Methods
PngExport Class See Also Send Feedback

The PngExport type exposes the following members.

Methods

Name | Description
CreateImage | Returns an image an object was exported to. (Inherited from ImageExport.)
CreateOptionsDialog | Overridden. See CreateOptionsDialog()()(). (Inherited from ImageExport.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllFilesFilter | Returns filter for all files. (Inherited from Export.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Overridden. See GetImageFormat()()(). (Overrides ImageExport..::.GetImageFormat()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Overridden. See ToString()()(). (Inherited from Export.)

See Also

PngExport Class
PerpetuumSoft.Framework.Export Namespace


GetImageFormat Method

[image]

.NET ModelKit Suite ClassReference
PngExport..::.GetImageFormat Method
PngExport Class See Also Send Feedback
Overridden. See GetImageFormat()()().

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
protected override ImageFormat GetImageFormat()
Visual Basic (Declaration)
Protected Overrides Function GetImageFormat As ImageFormat
Visual C++
protected:
virtual ImageFormat^ GetImageFormat() override

See Also

PngExport Class
PerpetuumSoft.Framework.Export Namespace


Save Method

[image] [image]

.NET ModelKit Suite ClassReference
PngExport..::.Save Method
PngExport Class See Also Send Feedback

Overload List

Name | Description
Save(String, PaintCallBack, Vector) | Saves an object being exported to file with given name. (Inherited from Export.)
Save(Stream, PaintCallBack, Vector) | Overridden. See Save(Stream, PaintCallBack, Vector). (Inherited from ImageExport.)

See Also

PngExport Class
PngExport Members
PerpetuumSoft.Framework.Export Namespace


PngExport Properties

[image] [image]

.NET ModelKit Suite ClassReference
PngExport Properties
PngExport Class See Also Send Feedback

The PngExport type exposes the following members.

Properties

Name | Description
Description | Overridden. See Description. (Overrides Export..::.Description.)
Filter | Overridden. See Filter. (Overrides Export..::.Filter.)
Mode | Gets or sets scaling mode. (Inherited from ImageExport.)
Resolution | Gets or sets image resolution. (Inherited from ImageExport.)
Scale | Gets or sets image scale. (Inherited from ImageExport.)
Size | Gets or sets image size. (Inherited from ImageExport.)

See Also

PngExport Class
PerpetuumSoft.Framework.Export Namespace


Description Property

[image]

.NET ModelKit Suite ClassReference
PngExport..::.Description Property
PngExport Class See Also Send Feedback
Overridden. See Description.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override string Description { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () override;
}

See Also

PngExport Class
PerpetuumSoft.Framework.Export Namespace


Filter Property

[image]

.NET ModelKit Suite ClassReference
PngExport..::.Filter Property
PngExport Class See Also Send Feedback
Overridden. See Filter.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override string Filter { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Filter As String
Visual C++
public:
virtual property String^ Filter {
    String^ get () override;
}

See Also

PngExport Class
PerpetuumSoft.Framework.Export Namespace


SVGExport Class

[image]

.NET ModelKit Suite ClassReference
SVGExport Class
Members See Also Send Feedback
Main class used for SVG export.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public class SVGExport : Export
Visual Basic (Declaration)
Public Class SVGExport _
    Inherits Export
Visual C++
public ref class SVGExport : public Export

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Export..::.Export
PerpetuumSoft.Framework.Export..::.SVGExport

See Also

SVGExport Members
PerpetuumSoft.Framework.Export Namespace


SVGExport Members

[image] [image]

.NET ModelKit Suite ClassReference
SVGExport Members
SVGExport Class Constructors Methods Properties See Also Send Feedback

The SVGExport type exposes the following members.

Constructors

Name | Description
SVGExport | Initializes a new instance of the SVGExport class.

Methods

Name | Description
CreateOptionsDialog | Returns user control to be used in ExportDialog. (Inherited from Export.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllFilesFilter | Returns filter for all files. (Inherited from Export.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Overridden. See ToString()()(). (Inherited from Export.)

Properties

Name | Description
Description | Overridden. See Description. (Overrides Export..::.Description.)
Filter | Overridden. See Filter. (Overrides Export..::.Filter.)

See Also

SVGExport Class
PerpetuumSoft.Framework.Export Namespace


SVGExport Constructor

[image]

.NET ModelKit Suite ClassReference
SVGExport Constructor
SVGExport Class See Also Send Feedback
Initializes a new instance of the SVGExport class.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public SVGExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SVGExport()

See Also

SVGExport Class
PerpetuumSoft.Framework.Export Namespace


SVGExport Methods

[image] [image]

.NET ModelKit Suite ClassReference
SVGExport Methods
SVGExport Class See Also Send Feedback

The SVGExport type exposes the following members.

Methods

Name | Description
CreateOptionsDialog | Returns user control to be used in ExportDialog. (Inherited from Export.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllFilesFilter | Returns filter for all files. (Inherited from Export.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Overridden. See ToString()()(). (Inherited from Export.)

See Also

SVGExport Class
PerpetuumSoft.Framework.Export Namespace


Save Method

[image] [image]

.NET ModelKit Suite ClassReference
SVGExport..::.Save Method
SVGExport Class See Also Send Feedback

Overload List

Name | Description
Save(String, PaintCallBack, Vector) | Saves an object being exported to file with given name. (Inherited from Export.)
Save(Stream, PaintCallBack, Vector) | Overridden. See Save(Stream, PaintCallBack, Vector). (Overrides Export..::.Save(Stream, PaintCallBack, Vector).)

See Also

SVGExport Class
SVGExport Members
PerpetuumSoft.Framework.Export Namespace


Save Method (Stream, Export., Vector)

[image]

.NET ModelKit Suite ClassReference
SVGExport..::.Save Method (Stream, Export..::., Vector)
SVGExport Class See Also Send Feedback
Overridden. See Save(Stream, PaintCallBack, Vector).

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override void Save(
    Stream stream,
    PaintCallBack paintMethod,
    Vector size
)
Visual Basic (Declaration)
Public Overrides Sub Save ( _
    stream As Stream, _
    paintMethod As PaintCallBack, _
    size As Vector _
)
Visual C++
public:
virtual void Save(
    Stream^ stream,
    PaintCallBack^ paintMethod,
    Vector size
) override

Parameters

stream
Type: System.IO..::.Stream
paintMethod
Type: PaintCallBack
size
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

SVGExport Class
Save Overload
PerpetuumSoft.Framework.Export Namespace


SVGExport Properties

[image] [image]

.NET ModelKit Suite ClassReference
SVGExport Properties
SVGExport Class See Also Send Feedback

The SVGExport type exposes the following members.

Properties

Name | Description
Description | Overridden. See Description. (Overrides Export..::.Description.)
Filter | Overridden. See Filter. (Overrides Export..::.Filter.)

See Also

SVGExport Class
PerpetuumSoft.Framework.Export Namespace


Description Property

[image]

.NET ModelKit Suite ClassReference
SVGExport..::.Description Property
SVGExport Class See Also Send Feedback
Overridden. See Description.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override string Description { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () override;
}

See Also

SVGExport Class
PerpetuumSoft.Framework.Export Namespace


Filter Property

[image]

.NET ModelKit Suite ClassReference
SVGExport..::.Filter Property
SVGExport Class See Also Send Feedback
Overridden. See Filter.

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override string Filter { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Filter As String
Visual C++
public:
virtual property String^ Filter {
    String^ get () override;
}

See Also

SVGExport Class
PerpetuumSoft.Framework.Export Namespace


TiffExport Class

[image]

.NET ModelKit Suite ClassReference
TiffExport Class
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Framework.Export.TiffExport]

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public class TiffExport : ImageExport
Visual Basic (Declaration)
Public Class TiffExport _
    Inherits ImageExport
Visual C++
public ref class TiffExport : public ImageExport

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Export..::.Export
PerpetuumSoft.Framework.Export..::.ImageExport
PerpetuumSoft.Framework.Export..::.TiffExport

See Also

TiffExport Members
PerpetuumSoft.Framework.Export Namespace


TiffExport Members

[image] [image]

.NET ModelKit Suite ClassReference
TiffExport Members
TiffExport Class Constructors Methods Properties See Also Send Feedback

The TiffExport type exposes the following members.

Constructors

Name | Description
TiffExport | Overloaded.

Methods

Name | Description
CreateImage | Returns an image an object was exported to. (Inherited from ImageExport.)
CreateOptionsDialog | Overridden. See CreateOptionsDialog()()(). (Inherited from ImageExport.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllFilesFilter | Returns filter for all files. (Inherited from Export.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | (Overrides ImageExport..::.GetImageFormat()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Overridden. See ToString()()(). (Inherited from Export.)

Properties

Name | Description
Description | (Overrides Export..::.Description.)
Filter | (Overrides Export..::.Filter.)
Mode | Gets or sets scaling mode. (Inherited from ImageExport.)
Resolution | Gets or sets image resolution. (Inherited from ImageExport.)
Scale | Gets or sets image scale. (Inherited from ImageExport.)
Size | Gets or sets image size. (Inherited from ImageExport.)

See Also

TiffExport Class
PerpetuumSoft.Framework.Export Namespace


TiffExport Constructor

[image] [image]

.NET ModelKit Suite ClassReference
TiffExport Constructor
TiffExport Class See Also Send Feedback

Overload List

Name | Description
TiffExport()()() | Initializes a new instance of the TiffExport class
TiffExport(Vector) | Initializes a new instance of the TiffExport class
TiffExport(Double) | Initializes a new instance of the TiffExport class
TiffExport(Int32) | Initializes a new instance of the TiffExport class
TiffExport(Int32, Double) | Initializes a new instance of the TiffExport class

See Also

TiffExport Class
TiffExport Members
PerpetuumSoft.Framework.Export Namespace


TiffExport Constructor

[image]

.NET ModelKit Suite ClassReference
TiffExport Constructor
TiffExport Class See Also Send Feedback
Initializes a new instance of the TiffExport class

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public TiffExport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TiffExport()

See Also

TiffExport Class
TiffExport Overload
PerpetuumSoft.Framework.Export Namespace


TiffExport Constructor (Vector)

[image]

.NET ModelKit Suite ClassReference
TiffExport Constructor (Vector)
TiffExport Class See Also Send Feedback
Initializes a new instance of the TiffExport class

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public TiffExport(
    Vector size
)
Visual Basic (Declaration)
Public Sub New ( _
    size As Vector _
)
Visual C++
public:
TiffExport(
    Vector size
)

Parameters

size
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

TiffExport Class
TiffExport Overload
PerpetuumSoft.Framework.Export Namespace


TiffExport Constructor (Double)

[image]

.NET ModelKit Suite ClassReference
TiffExport Constructor (Double)
TiffExport Class See Also Send Feedback
Initializes a new instance of the TiffExport class

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public TiffExport(
    double scale
)
Visual Basic (Declaration)
Public Sub New ( _
    scale As Double _
)
Visual C++
public:
TiffExport(
    double scale
)

Parameters

scale
Type: System..::.Double

See Also

TiffExport Class
TiffExport Overload
PerpetuumSoft.Framework.Export Namespace


TiffExport Constructor (Int32)

[image]

.NET ModelKit Suite ClassReference
TiffExport Constructor (Int32)
TiffExport Class See Also Send Feedback
Initializes a new instance of the TiffExport class

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public TiffExport(
    int resolution
)
Visual Basic (Declaration)
Public Sub New ( _
    resolution As Integer _
)
Visual C++
public:
TiffExport(
    int resolution
)

Parameters

resolution
Type: System..::.Int32

See Also

TiffExport Class
TiffExport Overload
PerpetuumSoft.Framework.Export Namespace


TiffExport Constructor (Int32, Double)

[image]

.NET ModelKit Suite ClassReference
TiffExport Constructor (Int32, Double)
TiffExport Class See Also Send Feedback
Initializes a new instance of the TiffExport class

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public TiffExport(
    int resolution,
    double scale
)
Visual Basic (Declaration)
Public Sub New ( _
    resolution As Integer, _
    scale As Double _
)
Visual C++
public:
TiffExport(
    int resolution,
    double scale
)

Parameters

resolution
Type: System..::.Int32
scale
Type: System..::.Double

See Also

TiffExport Class
TiffExport Overload
PerpetuumSoft.Framework.Export Namespace


TiffExport Methods

[image] [image]

.NET ModelKit Suite ClassReference
TiffExport Methods
TiffExport Class See Also Send Feedback

The TiffExport type exposes the following members.

Methods

Name | Description
CreateImage | Returns an image an object was exported to. (Inherited from ImageExport.)
CreateOptionsDialog | Overridden. See CreateOptionsDialog()()(). (Inherited from ImageExport.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllFilesFilter | Returns filter for all files. (Inherited from Export.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | (Overrides ImageExport..::.GetImageFormat()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Overridden. See ToString()()(). (Inherited from Export.)

See Also

TiffExport Class
PerpetuumSoft.Framework.Export Namespace


GetImageFormat Method

[image]

.NET ModelKit Suite ClassReference
TiffExport..::.GetImageFormat Method
TiffExport Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Export.TiffExport.GetImageFormat]

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
protected override ImageFormat GetImageFormat()
Visual Basic (Declaration)
Protected Overrides Function GetImageFormat As ImageFormat
Visual C++
protected:
virtual ImageFormat^ GetImageFormat() override

See Also

TiffExport Class
PerpetuumSoft.Framework.Export Namespace


Save Method

[image] [image]

.NET ModelKit Suite ClassReference
TiffExport..::.Save Method
TiffExport Class See Also Send Feedback

Overload List

Name | Description
Save(String, PaintCallBack, Vector) | Saves an object being exported to file with given name. (Inherited from Export.)
Save(Stream, PaintCallBack, Vector) | Overridden. See Save(Stream, PaintCallBack, Vector). (Inherited from ImageExport.)

See Also

TiffExport Class
TiffExport Members
PerpetuumSoft.Framework.Export Namespace


TiffExport Properties

[image] [image]

.NET ModelKit Suite ClassReference
TiffExport Properties
TiffExport Class See Also Send Feedback

The TiffExport type exposes the following members.

Properties

Name | Description
Description | (Overrides Export..::.Description.)
Filter | (Overrides Export..::.Filter.)
Mode | Gets or sets scaling mode. (Inherited from ImageExport.)
Resolution | Gets or sets image resolution. (Inherited from ImageExport.)
Scale | Gets or sets image scale. (Inherited from ImageExport.)
Size | Gets or sets image size. (Inherited from ImageExport.)

See Also

TiffExport Class
PerpetuumSoft.Framework.Export Namespace


Description Property

[image]

.NET ModelKit Suite ClassReference
TiffExport..::.Description Property
TiffExport Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Framework.Export.TiffExport.Description]

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override string Description { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Description As String
Visual C++
public:
virtual property String^ Description {
    String^ get () override;
}

See Also

TiffExport Class
PerpetuumSoft.Framework.Export Namespace


Filter Property

[image]

.NET ModelKit Suite ClassReference
TiffExport..::.Filter Property
TiffExport Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Framework.Export.TiffExport.Filter]

Namespace: PerpetuumSoft.Framework.Export
Assembly: PerpetuumSoft.Framework.Export (in PerpetuumSoft.Framework.Export.dll) Version: 3.9.0.1

Syntax

C#
public override string Filter { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Filter As String
Visual C++
public:
virtual property String^ Filter {
    String^ get () override;
}

See Also

TiffExport Class
PerpetuumSoft.Framework.Export Namespace


PerpetuumSoft.Framework.Expressions Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Framework.Expressions Namespace
Send Feedback
The PerpetuumSoft.Framework.Expressions namespace contains classes for the work with the special expression language.

Classes

Class | Description
RangeValue | Respresents the range of values.

Interfaces

Interface | Description
ICustomFunction | Sets methods to calculate function value by the set arguments. Sets methods for getting the function description and needed number of parameters.
IFunction |


ICustomFunction Interface

[image]

.NET ModelKit Suite ClassReference
ICustomFunction Interface
Members See Also Send Feedback
Sets methods to calculate function value by the set arguments. Sets methods for getting the function description and needed number of parameters.

Namespace: PerpetuumSoft.Framework.Expressions
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public interface ICustomFunction : IFunction
Visual Basic (Declaration)
Public Interface ICustomFunction _
    Implements IFunction
Visual C++
public interface class ICustomFunction : IFunction

See Also

ICustomFunction Members
PerpetuumSoft.Framework.Expressions Namespace


ICustomFunction Members

[image] [image]

.NET ModelKit Suite ClassReference
ICustomFunction Members
ICustomFunction Interface Methods Properties See Also Send Feedback

The ICustomFunction type exposes the following members.

Methods

Name | Description
Evaluate | (Inherited from IFunction.)

Properties

Name | Description
CustomDescription | Gets function destination description.
QuantityParameters | Gets the needed function parameters number.

See Also

ICustomFunction Interface
PerpetuumSoft.Framework.Expressions Namespace


ICustomFunction Methods

[image] [image]

.NET ModelKit Suite ClassReference
ICustomFunction Methods
ICustomFunction Interface See Also Send Feedback

The ICustomFunction type exposes the following members.

Methods

Name | Description
Evaluate | (Inherited from IFunction.)

See Also

ICustomFunction Interface
PerpetuumSoft.Framework.Expressions Namespace


ICustomFunction Properties

[image] [image]

.NET ModelKit Suite ClassReference
ICustomFunction Properties
ICustomFunction Interface See Also Send Feedback

The ICustomFunction type exposes the following members.

Properties

Name | Description
CustomDescription | Gets function destination description.
QuantityParameters | Gets the needed function parameters number.

See Also

ICustomFunction Interface
PerpetuumSoft.Framework.Expressions Namespace


CustomDescription Property

[image]

.NET ModelKit Suite ClassReference
ICustomFunction..::.CustomDescription Property
ICustomFunction Interface See Also Send Feedback
Gets function destination description.

Namespace: PerpetuumSoft.Framework.Expressions
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
string CustomDescription { get; }
Visual Basic (Declaration)
ReadOnly Property CustomDescription As String
Visual C++
property String^ CustomDescription {
    String^ get ();
}

See Also

ICustomFunction Interface
PerpetuumSoft.Framework.Expressions Namespace


QuantityParameters Property

[image]

.NET ModelKit Suite ClassReference
ICustomFunction..::.QuantityParameters Property
ICustomFunction Interface See Also Send Feedback
Gets the needed function parameters number.

Namespace: PerpetuumSoft.Framework.Expressions
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
int QuantityParameters { get; }
Visual Basic (Declaration)
ReadOnly Property QuantityParameters As Integer
Visual C++
property int QuantityParameters {
    int get ();
}

See Also

ICustomFunction Interface
PerpetuumSoft.Framework.Expressions Namespace


IFunction Interface

[image]

.NET ModelKit Suite ClassReference
IFunction Interface
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Framework.Expressions.IFunction]

Namespace: PerpetuumSoft.Framework.Expressions
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public interface IFunction
Visual Basic (Declaration)
Public Interface IFunction
Visual C++
public interface class IFunction

See Also

IFunction Members
PerpetuumSoft.Framework.Expressions Namespace


IFunction Members

[image] [image]

.NET ModelKit Suite ClassReference
IFunction Members
IFunction Interface Methods See Also Send Feedback

The IFunction type exposes the following members.

Methods

Name | Description
Evaluate |

See Also

IFunction Interface
PerpetuumSoft.Framework.Expressions Namespace


IFunction Methods

[image] [image]

.NET ModelKit Suite ClassReference
IFunction Methods
IFunction Interface See Also Send Feedback

The IFunction type exposes the following members.

Methods

Name | Description
Evaluate |

See Also

IFunction Interface
PerpetuumSoft.Framework.Expressions Namespace


Evaluate Method

[image]

.NET ModelKit Suite ClassReference
IFunction..::.Evaluate Method
IFunction Interface See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Expressions.IFunction.Evaluate(System.String,System.Object[])]

Namespace: PerpetuumSoft.Framework.Expressions
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
Object Evaluate(
    string name,
    params Object[] prms
)
Visual Basic (Declaration)
Function Evaluate ( _
    name As String, _
    ParamArray prms As Object() _
) As Object
Visual C++
Object^ Evaluate(
    String^ name,
    ... array<Object^>^ prms
)

Parameters

name
Type: System..::.String
prms
Type: array< System..::.Object >[]()[]

See Also

IFunction Interface
PerpetuumSoft.Framework.Expressions Namespace


RangeValue Class

[image]

.NET ModelKit Suite ClassReference
RangeValue Class
Members See Also Send Feedback
Respresents the range of values.

Namespace: PerpetuumSoft.Framework.Expressions
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class RangeValue : IComparable
Visual Basic (Declaration)
Public Class RangeValue _
    Implements IComparable
Visual C++
public ref class RangeValue : IComparable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Expressions..::.RangeValue

See Also

RangeValue Members
PerpetuumSoft.Framework.Expressions Namespace


RangeValue Members

[image] [image]

.NET ModelKit Suite ClassReference
RangeValue Members
RangeValue Class Constructors Methods Properties See Also Send Feedback

The RangeValue type exposes the following members.

Constructors

Name | Description
RangeValue | Initializes a new instance of the RangeValue class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Returns a new RangeValue object.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Maximum | Gets the maximum range value.
Minimum | Gets the minimum range value.

See Also

RangeValue Class
PerpetuumSoft.Framework.Expressions Namespace


RangeValue Constructor

[image]

.NET ModelKit Suite ClassReference
RangeValue Constructor
RangeValue Class See Also Send Feedback
Initializes a new instance of the RangeValue class.

Namespace: PerpetuumSoft.Framework.Expressions
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public RangeValue(
    double minimum,
    double maximum
)
Visual Basic (Declaration)
Public Sub New ( _
    minimum As Double, _
    maximum As Double _
)
Visual C++
public:
RangeValue(
    double minimum,
    double maximum
)

Parameters

minimum
Type: System..::.Double
maximum
Type: System..::.Double

See Also

RangeValue Class
PerpetuumSoft.Framework.Expressions Namespace


RangeValue Methods

[image] [image]

.NET ModelKit Suite ClassReference
RangeValue Methods
RangeValue Class See Also Send Feedback

The RangeValue type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Returns a new RangeValue object.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RangeValue Class
PerpetuumSoft.Framework.Expressions Namespace


GetRange Method

[image]

.NET ModelKit Suite ClassReference
RangeValue..::.GetRange Method
RangeValue Class See Also Send Feedback
Returns a new RangeValue object.

Namespace: PerpetuumSoft.Framework.Expressions
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static RangeValue GetRange(
    double value,
    double rangeSize,
    double zeroPoint
)
Visual Basic (Declaration)
Public Shared Function GetRange ( _
    value As Double, _
    rangeSize As Double, _
    zeroPoint As Double _
) As RangeValue
Visual C++
public:
static RangeValue^ GetRange(
    double value,
    double rangeSize,
    double zeroPoint
)

Parameters

value
Type: System..::.Double
rangeSize
Type: System..::.Double
zeroPoint
Type: System..::.Double

See Also

RangeValue Class
PerpetuumSoft.Framework.Expressions Namespace


RangeValue Properties

[image] [image]

.NET ModelKit Suite ClassReference
RangeValue Properties
RangeValue Class See Also Send Feedback

The RangeValue type exposes the following members.

Properties

Name | Description
Maximum | Gets the maximum range value.
Minimum | Gets the minimum range value.

See Also

RangeValue Class
PerpetuumSoft.Framework.Expressions Namespace


Maximum Property

[image]

.NET ModelKit Suite ClassReference
RangeValue..::.Maximum Property
RangeValue Class See Also Send Feedback
Gets the maximum range value.

Namespace: PerpetuumSoft.Framework.Expressions
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Maximum { get; }
Visual Basic (Declaration)
Public ReadOnly Property Maximum As Double
Visual C++
public:
property double Maximum {
    double get ();
}

See Also

RangeValue Class
PerpetuumSoft.Framework.Expressions Namespace


Minimum Property

[image]

.NET ModelKit Suite ClassReference
RangeValue..::.Minimum Property
RangeValue Class See Also Send Feedback
Gets the minimum range value.

Namespace: PerpetuumSoft.Framework.Expressions
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Minimum { get; }
Visual Basic (Declaration)
Public ReadOnly Property Minimum As Double
Visual C++
public:
property double Minimum {
    double get ();
}

See Also

RangeValue Class
PerpetuumSoft.Framework.Expressions Namespace


PerpetuumSoft.Framework.Model Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Framework.Model Namespace
Send Feedback
The PerpetuumSoft.Framework.Model namespace contains classes of the document object model.

Classes

Class | Description
IElementCollection | Represents a collection of elements.
MouseArguments | Represents the arguments for the mouse event.
PaintArguments | Represents arguments for invalidating.

Interfaces

Interface | Description
ICompositeElement | Represents the composite element of an abstract model.
IElement | Represents element of an abstract model.
IElementList | List of the objects, implementing the IElement interface.
IRootElement | Represents the root element of an abstract model.

Delegates

Delegate | Description
IElementCollection..::.CollectionChanged | Represents method that will handle ElementAdded and ElementRemoved events.
InvalidateEventHandler | Represents method that will handle region drawing.
MouseEventHandler | Represents the method that will handle mouse events.


ICompositeElement Interface

[image]

.NET ModelKit Suite ClassReference
ICompositeElement Interface
Members See Also Send Feedback
Represents the composite element of an abstract model.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public interface ICompositeElement : IElement
Visual Basic (Declaration)
Public Interface ICompositeElement _
    Implements IElement
Visual C++
public interface class ICompositeElement : IElement

See Also

ICompositeElement Members
PerpetuumSoft.Framework.Model Namespace


ICompositeElement Members

[image] [image]

.NET ModelKit Suite ClassReference
ICompositeElement Members
ICompositeElement Interface Methods Properties See Also Send Feedback

The ICompositeElement type exposes the following members.

Methods

Name | Description
GetBoundedBox | Returns the circumscribed rectangle. (Inherited from IElement.)
GetElementAt | Returns an element that is placed under given point. (Inherited from IElement.)
Invalidate | Overloaded.
Paint | Draws the IElement object. (Inherited from IElement.)

Properties

Name | Description
Elements | Gets the IElementList collection, that contains inner elements.
Parent | Gets or sets ICompositeElement which is a parent for this element. (Inherited from IElement.)

See Also

ICompositeElement Interface
PerpetuumSoft.Framework.Model Namespace


ICompositeElement Methods

[image] [image]

.NET ModelKit Suite ClassReference
ICompositeElement Methods
ICompositeElement Interface See Also Send Feedback

The ICompositeElement type exposes the following members.

Methods

Name | Description
GetBoundedBox | Returns the circumscribed rectangle. (Inherited from IElement.)
GetElementAt | Returns an element that is placed under given point. (Inherited from IElement.)
Invalidate | Overloaded.
Paint | Draws the IElement object. (Inherited from IElement.)

See Also

ICompositeElement Interface
PerpetuumSoft.Framework.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ICompositeElement..::.Invalidate Method
ICompositeElement Interface See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the whole element. (Inherited from IElement.)
Invalidate(VectorRectangle) | Invalidates the given region. (Inherited from IElement.)

See Also

ICompositeElement Interface
ICompositeElement Members
PerpetuumSoft.Framework.Model Namespace


ICompositeElement Properties

[image] [image]

.NET ModelKit Suite ClassReference
ICompositeElement Properties
ICompositeElement Interface See Also Send Feedback

The ICompositeElement type exposes the following members.

Properties

Name | Description
Elements | Gets the IElementList collection, that contains inner elements.
Parent | Gets or sets ICompositeElement which is a parent for this element. (Inherited from IElement.)

See Also

ICompositeElement Interface
PerpetuumSoft.Framework.Model Namespace


Elements Property

[image]

.NET ModelKit Suite ClassReference
ICompositeElement..::.Elements Property
ICompositeElement Interface See Also Send Feedback
Gets the IElementList collection, that contains inner elements.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
IElementList Elements { get; }
Visual Basic (Declaration)
ReadOnly Property Elements As IElementList
Visual C++
property IElementList^ Elements {
    IElementList^ get ();
}

See Also

ICompositeElement Interface
PerpetuumSoft.Framework.Model Namespace


IElement Interface

[image]

.NET ModelKit Suite ClassReference
IElement Interface
Members See Also Send Feedback
Represents element of an abstract model.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public interface IElement
Visual Basic (Declaration)
Public Interface IElement
Visual C++
public interface class IElement

See Also

IElement Members
PerpetuumSoft.Framework.Model Namespace


IElement Members

[image] [image]

.NET ModelKit Suite ClassReference
IElement Members
IElement Interface Methods Properties See Also Send Feedback

The IElement type exposes the following members.

Methods

Name | Description
GetBoundedBox | Returns the circumscribed rectangle.
GetElementAt | Returns an element that is placed under given point.
Invalidate | Overloaded.
Paint | Draws the IElement object.

Properties

Name | Description
Parent | Gets or sets ICompositeElement which is a parent for this element.

See Also

IElement Interface
PerpetuumSoft.Framework.Model Namespace


IElement Methods

[image] [image]

.NET ModelKit Suite ClassReference
IElement Methods
IElement Interface See Also Send Feedback

The IElement type exposes the following members.

Methods

Name | Description
GetBoundedBox | Returns the circumscribed rectangle.
GetElementAt | Returns an element that is placed under given point.
Invalidate | Overloaded.
Paint | Draws the IElement object.

See Also

IElement Interface
PerpetuumSoft.Framework.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
IElement..::.GetBoundedBox Method
IElement Interface See Also Send Feedback
Returns the circumscribed rectangle.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Function GetBoundedBox As VectorRectangle
Visual C++
VectorRectangle GetBoundedBox()

See Also

IElement Interface
PerpetuumSoft.Framework.Model Namespace


GetElementAt Method

[image]

.NET ModelKit Suite ClassReference
IElement..::.GetElementAt Method
IElement Interface See Also Send Feedback
Returns an element that is placed under given point.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
IElement GetElementAt(
    Vector point
)
Visual Basic (Declaration)
Function GetElementAt ( _
    point As Vector _
) As IElement
Visual C++
IElement^ GetElementAt(
    Vector point
)

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

IElement Interface
PerpetuumSoft.Framework.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
IElement..::.Invalidate Method
IElement Interface See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the whole element.
Invalidate(VectorRectangle) | Invalidates the given region.

See Also

IElement Interface
IElement Members
PerpetuumSoft.Framework.Model Namespace


Invalidate Method

[image]

.NET ModelKit Suite ClassReference
IElement..::.Invalidate Method
IElement Interface See Also Send Feedback
Invalidates the whole element.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
void Invalidate()
Visual Basic (Declaration)
Sub Invalidate
Visual C++
void Invalidate()

See Also

IElement Interface
Invalidate Overload
PerpetuumSoft.Framework.Model Namespace


Invalidate Method (VectorRectangle)

[image]

.NET ModelKit Suite ClassReference
IElement..::.Invalidate Method (VectorRectangle)
IElement Interface See Also Send Feedback
Invalidates the given region.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
void Invalidate(
    VectorRectangle rectangle
)
Visual Basic (Declaration)
Sub Invalidate ( _
    rectangle As VectorRectangle _
)
Visual C++
void Invalidate(
    VectorRectangle rectangle
)

Parameters

rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

IElement Interface
Invalidate Overload
PerpetuumSoft.Framework.Model Namespace


Paint Method

[image]

.NET ModelKit Suite ClassReference
IElement..::.Paint Method
IElement Interface See Also Send Feedback
Draws the IElement object.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
void Paint(
    PaintArguments args
)
Visual Basic (Declaration)
Sub Paint ( _
    args As PaintArguments _
)
Visual C++
void Paint(
    PaintArguments^ args
)

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

IElement Interface
PerpetuumSoft.Framework.Model Namespace


IElement Properties

[image] [image]

.NET ModelKit Suite ClassReference
IElement Properties
IElement Interface See Also Send Feedback

The IElement type exposes the following members.

Properties

Name | Description
Parent | Gets or sets ICompositeElement which is a parent for this element.

See Also

IElement Interface
PerpetuumSoft.Framework.Model Namespace


Parent Property

[image]

.NET ModelKit Suite ClassReference
IElement..::.Parent Property
IElement Interface See Also Send Feedback
Gets or sets ICompositeElement which is a parent for this element.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
ICompositeElement Parent { get; set; }
Visual Basic (Declaration)
Property Parent As ICompositeElement
Visual C++
property ICompositeElement^ Parent {
    ICompositeElement^ get ();
    void set (ICompositeElement^ value);
}

See Also

IElement Interface
PerpetuumSoft.Framework.Model Namespace


IElementCollection Class

[image]

.NET ModelKit Suite ClassReference
IElementCollection Class
Members See Also Send Feedback
Represents a collection of elements.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public class IElementCollection : CollectionBase,
    IElementList, IList, ICollection, IEnumerable
Visual Basic (Declaration)
Public Class IElementCollection _
    Inherits CollectionBase _
    Implements IElementList, IList, ICollection, IEnumerable
Visual C++
public ref class IElementCollection : public CollectionBase,
    IElementList, IList, ICollection, IEnumerable

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Framework.Model..::.IElementCollection

See Also

IElementCollection Members
PerpetuumSoft.Framework.Model Namespace


IElementCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
IElementCollection Members
IElementCollection Class Constructors Methods Properties Events See Also Send Feedback

The IElementCollection type exposes the following members.

Constructors

Name | Description
IElementCollection | Initializes a new instance of the ElementCollection class.

Methods

Name | Description
Add | Adds an element to the collection.
AddRange | Adds an elements to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded. Returns the zero-based index of the first element occurrence in the collection or in its portion.
Insert | Inserts an element into the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs the additional custom processes before inserting a new element into the collection instance. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs the additional custom processes after inserting a new element into the collection instance. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs the additional custom processes after removing an element from the collection instance. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Overrides CollectionBase..::.OnValidate(Object).)
Remove | Removes the first occurrence of an element from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets an element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

Name | Description
ElementAdded | Occurs after an element was added.
ElementRemoved | Occurs after an element has been removed.

See Also

IElementCollection Class
PerpetuumSoft.Framework.Model Namespace


IElementCollection Constructor

[image]

.NET ModelKit Suite ClassReference
IElementCollection Constructor
IElementCollection Class See Also Send Feedback
Initializes a new instance of the ElementCollection class.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public IElementCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IElementCollection()

See Also

IElementCollection Class
PerpetuumSoft.Framework.Model Namespace


IElementCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
IElementCollection Methods
IElementCollection Class See Also Send Feedback

The IElementCollection type exposes the following members.

Methods

Name | Description
Add | Adds an element to the collection.
AddRange | Adds an elements to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded. Returns the zero-based index of the first element occurrence in the collection or in its portion.
Insert | Inserts an element into the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs the additional custom processes before inserting a new element into the collection instance. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs the additional custom processes after inserting a new element into the collection instance. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs the additional custom processes after removing an element from the collection instance. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Overrides CollectionBase..::.OnValidate(Object).)
Remove | Removes the first occurrence of an element from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IElementCollection Class
PerpetuumSoft.Framework.Model Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
IElementCollection..::.Add Method
IElementCollection Class See Also Send Feedback
Adds an element to the collection.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public IElement Add(
    IElement value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As IElement _
) As IElement
Visual C++
public:
virtual IElement^ Add(
    IElement^ value
) sealed

Parameters

value
Type: PerpetuumSoft.Framework.Model..::.IElement

Implements

IElementList..::.Add(IElement)

See Also

IElementCollection Class
PerpetuumSoft.Framework.Model Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
IElementCollection..::.AddRange Method
IElementCollection Class See Also Send Feedback
Adds an elements to the collection.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    IElement[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As IElement() _
)
Visual C++
public:
void AddRange(
    array<IElement^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Framework.Model..::.IElement >[]()[]

See Also

IElementCollection Class
PerpetuumSoft.Framework.Model Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
IElementCollection..::.Contains Method
IElementCollection Class See Also Send Feedback
Determines whether an element is in the collection.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    IElement value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As IElement _
) As Boolean
Visual C++
public:
bool Contains(
    IElement^ value
)

Parameters

value
Type: PerpetuumSoft.Framework.Model..::.IElement

See Also

IElementCollection Class
PerpetuumSoft.Framework.Model Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
IElementCollection..::.IndexOf Method
IElementCollection Class See Also Send Feedback
Overloaded. Returns the zero-based index of the first element occurrence in the collection or in its portion.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    IElement value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As IElement _
) As Integer
Visual C++
public:
int IndexOf(
    IElement^ value
)

Parameters

value
Type: PerpetuumSoft.Framework.Model..::.IElement

See Also

IElementCollection Class
PerpetuumSoft.Framework.Model Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
IElementCollection..::.Insert Method
IElementCollection Class See Also Send Feedback
Inserts an element into the collection at the specified index.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    IElement value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As IElement _
)
Visual C++
public:
void Insert(
    int index,
    IElement^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Framework.Model..::.IElement

See Also

IElementCollection Class
PerpetuumSoft.Framework.Model Namespace


OnInsert Method

[image]

.NET ModelKit Suite ClassReference
IElementCollection..::.OnInsert Method
IElementCollection Class See Also Send Feedback
Performs the additional custom processes before inserting a new element into the collection instance.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsert(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsert ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsert(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

IElementCollection Class
PerpetuumSoft.Framework.Model Namespace


OnInsertComplete Method

[image]

.NET ModelKit Suite ClassReference
IElementCollection..::.OnInsertComplete Method
IElementCollection Class See Also Send Feedback
Performs the additional custom processes after inserting a new element into the collection instance.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsertComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsertComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsertComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

IElementCollection Class
PerpetuumSoft.Framework.Model Namespace


OnRemoveComplete Method

[image]

.NET ModelKit Suite ClassReference
IElementCollection..::.OnRemoveComplete Method
IElementCollection Class See Also Send Feedback
Performs the additional custom processes after removing an element from the collection instance.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnRemoveComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemoveComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemoveComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

IElementCollection Class
PerpetuumSoft.Framework.Model Namespace


OnValidate Method

[image]

.NET ModelKit Suite ClassReference
IElementCollection..::.OnValidate Method
IElementCollection Class See Also Send Feedback
Performs additional custom processes when validating a value.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnValidate(
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnValidate ( _
    value As Object _
)
Visual C++
protected:
virtual void OnValidate(
    Object^ value
) override

Parameters

value
Type: System..::.Object

See Also

IElementCollection Class
PerpetuumSoft.Framework.Model Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
IElementCollection..::.Remove Method
IElementCollection Class See Also Send Feedback
Removes the first occurrence of an element from the collection.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    IElement value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As IElement _
)
Visual C++
public:
virtual void Remove(
    IElement^ value
) sealed

Parameters

value
Type: PerpetuumSoft.Framework.Model..::.IElement

Implements

IElementList..::.Remove(IElement)

See Also

IElementCollection Class
PerpetuumSoft.Framework.Model Namespace


IElementCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
IElementCollection Properties
IElementCollection Class See Also Send Feedback

The IElementCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets an element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

IElementCollection Class
PerpetuumSoft.Framework.Model Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
IElementCollection..::.Item Property
IElementCollection Class See Also Send Feedback
Gets or sets an element at the specified index.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public IElement this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As IElement
Visual C++
public:
virtual property IElement^ default[int index] {
    IElement^ get (int index) sealed;
    void set (int index, IElement^ value) sealed;
}

Parameters

index
Type: System..::.Int32

Implements

IElementList..::.Item[([(Int32])])

See Also

IElementCollection Class
PerpetuumSoft.Framework.Model Namespace


IElementCollection Events

[image] [image]

.NET ModelKit Suite ClassReference
IElementCollection Events
IElementCollection Class See Also Send Feedback

The IElementCollection type exposes the following members.

Events

Name | Description
ElementAdded | Occurs after an element was added.
ElementRemoved | Occurs after an element has been removed.

See Also

IElementCollection Class
PerpetuumSoft.Framework.Model Namespace


ElementAdded Event

[image]

.NET ModelKit Suite ClassReference
IElementCollection..::.ElementAdded Event
IElementCollection Class See Also Send Feedback
Occurs after an element was added.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public event IElementCollection..::.CollectionChanged ElementAdded
Visual Basic (Declaration)
Public Event ElementAdded As IElementCollection..::.CollectionChanged
Visual C++
public:
 event IElementCollection..::.CollectionChanged^ ElementAdded {
    void add (IElementCollection..::.CollectionChanged^ value);
    void remove (IElementCollection..::.CollectionChanged^ value);
}

See Also

IElementCollection Class
PerpetuumSoft.Framework.Model Namespace


ElementRemoved Event

[image]

.NET ModelKit Suite ClassReference
IElementCollection..::.ElementRemoved Event
IElementCollection Class See Also Send Feedback
Occurs after an element has been removed.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public event IElementCollection..::.CollectionChanged ElementRemoved
Visual Basic (Declaration)
Public Event ElementRemoved As IElementCollection..::.CollectionChanged
Visual C++
public:
 event IElementCollection..::.CollectionChanged^ ElementRemoved {
    void add (IElementCollection..::.CollectionChanged^ value);
    void remove (IElementCollection..::.CollectionChanged^ value);
}

See Also

IElementCollection Class
PerpetuumSoft.Framework.Model Namespace


IElementCollection.CollectionChanged Delegate

[image]

.NET ModelKit Suite ClassReference
IElementCollection..::.CollectionChanged Delegate
IElementCollection Class See Also Send Feedback
Represents method that will handle ElementAdded and ElementRemoved events.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public delegate void CollectionChanged(
    IElement element
)
Visual Basic (Declaration)
Public Delegate Sub CollectionChanged ( _
    element As IElement _
)
Visual C++
public delegate void CollectionChanged(
    IElement^ element
)

Parameters

element
Type: PerpetuumSoft.Framework.Model..::.IElement

See Also

PerpetuumSoft.Framework.Model Namespace


IElementList Interface

[image]

.NET ModelKit Suite ClassReference
IElementList Interface
Members See Also Send Feedback
List of the objects, implementing the IElement interface.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public interface IElementList : IList,
    ICollection, IEnumerable
Visual Basic (Declaration)
Public Interface IElementList _
    Implements IList, ICollection, IEnumerable
Visual C++
public interface class IElementList : IList,
    ICollection, IEnumerable

See Also

IElementList Members
PerpetuumSoft.Framework.Model Namespace


IElementList Members

[image] [image]

.NET ModelKit Suite ClassReference
IElementList Members
IElementList Interface Methods Properties See Also Send Feedback

The IElementList type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all items from the IList. (Inherited from IList.)
Contains | Determines whether the IList contains a specific value. (Inherited from IList.)
CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from ICollection.)
GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
IndexOf | Determines the index of a specific item in the IList. (Inherited from IList.)
Insert | Inserts an item to the IList at the specified index. (Inherited from IList.)
Remove | Overloaded.
RemoveAt | Removes the IList item at the specified index. (Inherited from IList.)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection. (Inherited from ICollection.)
IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from IList.)
IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from IList.)
IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from ICollection.)
Item | Overloaded.
SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from ICollection.)

See Also

IElementList Interface
PerpetuumSoft.Framework.Model Namespace


IElementList Methods

[image] [image]

.NET ModelKit Suite ClassReference
IElementList Methods
IElementList Interface See Also Send Feedback

The IElementList type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all items from the IList. (Inherited from IList.)
Contains | Determines whether the IList contains a specific value. (Inherited from IList.)
CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from ICollection.)
GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
IndexOf | Determines the index of a specific item in the IList. (Inherited from IList.)
Insert | Inserts an item to the IList at the specified index. (Inherited from IList.)
Remove | Overloaded.
RemoveAt | Removes the IList item at the specified index. (Inherited from IList.)

See Also

IElementList Interface
PerpetuumSoft.Framework.Model Namespace


Add Method

[image] [image]

.NET ModelKit Suite ClassReference
IElementList..::.Add Method
IElementList Interface See Also Send Feedback

Overload List

Name | Description
Add(Object) | Adds an item to the IList. (Inherited from IList.)
Add(IElement) | When implemented by a class, adds an element to the IList interface.

See Also

IElementList Interface
IElementList Members
PerpetuumSoft.Framework.Model Namespace


Add Method (IElement)

[image]

.NET ModelKit Suite ClassReference
IElementList..::.Add Method (IElement)
IElementList Interface See Also Send Feedback
When implemented by a class, adds an element to the IList interface.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
IElement Add(
    IElement element
)
Visual Basic (Declaration)
Function Add ( _
    element As IElement _
) As IElement
Visual C++
IElement^ Add(
    IElement^ element
)

Parameters

element
Type: PerpetuumSoft.Framework.Model..::.IElement

See Also

IElementList Interface
Add Overload
PerpetuumSoft.Framework.Model Namespace


Remove Method

[image] [image]

.NET ModelKit Suite ClassReference
IElementList..::.Remove Method
IElementList Interface See Also Send Feedback

Overload List

Name | Description
Remove(Object) | Removes the first occurrence of a specific object from the IList. (Inherited from IList.)
Remove(IElement) | When implemented by a class, removes the first specific element occurrence from the IList interface.

See Also

IElementList Interface
IElementList Members
PerpetuumSoft.Framework.Model Namespace


Remove Method (IElement)

[image]

.NET ModelKit Suite ClassReference
IElementList..::.Remove Method (IElement)
IElementList Interface See Also Send Feedback
When implemented by a class, removes the first specific element occurrence from the IList interface.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
void Remove(
    IElement element
)
Visual Basic (Declaration)
Sub Remove ( _
    element As IElement _
)
Visual C++
void Remove(
    IElement^ element
)

Parameters

element
Type: PerpetuumSoft.Framework.Model..::.IElement

See Also

IElementList Interface
Remove Overload
PerpetuumSoft.Framework.Model Namespace


IElementList Properties

[image] [image]

.NET ModelKit Suite ClassReference
IElementList Properties
IElementList Interface See Also Send Feedback

The IElementList type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection. (Inherited from ICollection.)
IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from IList.)
IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from IList.)
IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from ICollection.)
Item | Overloaded.
SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from ICollection.)

See Also

IElementList Interface
PerpetuumSoft.Framework.Model Namespace


Item Property

[image] [image]

.NET ModelKit Suite ClassReference
IElementList..::.Item Property
IElementList Interface See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from IList.)
Item[([(Int32])]) | When implemented by a class, gets or sets an element at the specified index.

See Also

IElementList Interface
IElementList Members
PerpetuumSoft.Framework.Model Namespace


Item Property (Int32)

[image]

.NET ModelKit Suite ClassReference
IElementList..::.Item Property (Int32)
IElementList Interface See Also Send Feedback
When implemented by a class, gets or sets an element at the specified index.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
IElement this[
    int index
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    index As Integer _
) As IElement
Visual C++
property IElement^ default[int index] {
    IElement^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

IElementList Interface
Item Overload
PerpetuumSoft.Framework.Model Namespace


InvalidateEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
InvalidateEventHandler Delegate
See Also Send Feedback
Represents method that will handle region drawing.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public delegate void InvalidateEventHandler(
    Object sender,
    InvalidateEventArgs args
)
Visual Basic (Declaration)
Public Delegate Sub InvalidateEventHandler ( _
    sender As Object, _
    args As InvalidateEventArgs _
)
Visual C++
public delegate void InvalidateEventHandler(
    Object^ sender,
    InvalidateEventArgs^ args
)

Parameters

sender
Type: System..::.Object
args
Type: InvalidateEventArgs

See Also

PerpetuumSoft.Framework.Model Namespace


IRootElement Interface

[image]

.NET ModelKit Suite ClassReference
IRootElement Interface
Members See Also Send Feedback
Represents the root element of an abstract model.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public interface IRootElement
Visual Basic (Declaration)
Public Interface IRootElement
Visual C++
public interface class IRootElement

See Also

IRootElement Members
PerpetuumSoft.Framework.Model Namespace


IRootElement Members

[image] [image]

.NET ModelKit Suite ClassReference
IRootElement Members
IRootElement Interface Events See Also Send Feedback

The IRootElement type exposes the following members.

Events

Name | Description
Invalidated | Occurs after invalidating.

See Also

IRootElement Interface
PerpetuumSoft.Framework.Model Namespace


IRootElement Events

[image] [image]

.NET ModelKit Suite ClassReference
IRootElement Events
IRootElement Interface See Also Send Feedback

The IRootElement type exposes the following members.

Events

Name | Description
Invalidated | Occurs after invalidating.

See Also

IRootElement Interface
PerpetuumSoft.Framework.Model Namespace


Invalidated Event

[image]

.NET ModelKit Suite ClassReference
IRootElement..::.Invalidated Event
IRootElement Interface See Also Send Feedback
Occurs after invalidating.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
event InvalidateEventHandler Invalidated
Visual Basic (Declaration)
Event Invalidated As InvalidateEventHandler
Visual C++
 event InvalidateEventHandler^ Invalidated {
    void add (InvalidateEventHandler^ value);
    void remove (InvalidateEventHandler^ value);
}

See Also

IRootElement Interface
PerpetuumSoft.Framework.Model Namespace


MouseArguments Class

[image]

.NET ModelKit Suite ClassReference
MouseArguments Class
Members See Also Send Feedback
Represents the arguments for the mouse event.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public class MouseArguments
Visual Basic (Declaration)
Public Class MouseArguments
Visual C++
public ref class MouseArguments

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Model..::.MouseArguments

See Also

MouseArguments Members
PerpetuumSoft.Framework.Model Namespace


MouseArguments Members

[image] [image]

.NET ModelKit Suite ClassReference
MouseArguments Members
MouseArguments Class Constructors Methods Properties See Also Send Feedback

The MouseArguments type exposes the following members.

Constructors

Name | Description
MouseArguments | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPosition | Returns the mouse position in the current view.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Alt | Gets whether Alt-key was pressed.
Button | Gets whether mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Ctrl | Gets whether Ctrl-key was pressed.
Delta | Gets the signed number count of the of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Shift | Gets whether Shift-key was pressed.
X | Gets the x-coordinate of the mouse cursor.
Y | Gets the y-coordinate of the mouse cursor.

See Also

MouseArguments Class
PerpetuumSoft.Framework.Model Namespace


MouseArguments Constructor

[image] [image]

.NET ModelKit Suite ClassReference
MouseArguments Constructor
MouseArguments Class See Also Send Feedback

Overload List

Name | Description
MouseArguments(Double, Double, MouseButtons, Int32, Int32, Boolean, Boolean, Boolean) | Initializes the new instance of the MouseArguments class with specified parameters. Parameters initialize the corresponding properies.
MouseArguments(Double, Double, MouseButtons, Int32, Int32, Boolean, Boolean, Boolean, View) | Initializes the new instance of the MouseArguments class with specified parameters. Parameters initialize the corresponding properies using a view.

See Also

MouseArguments Class
MouseArguments Members
PerpetuumSoft.Framework.Model Namespace


MouseArguments Constructor (Double, Double, MouseButtons, Int32, Int32, Boolean, Boolean, Boolean)

[image]

.NET ModelKit Suite ClassReference
MouseArguments Constructor (Double, Double, MouseButtons, Int32, Int32, Boolean, Boolean, Boolean)
MouseArguments Class See Also Send Feedback
Initializes the new instance of the MouseArguments class with specified parameters. Parameters initialize the corresponding properies.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public MouseArguments(
    double x,
    double y,
    MouseButtons button,
    int clicks,
    int delta,
    bool ctrl,
    bool alt,
    bool shift
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Double, _
    y As Double, _
    button As MouseButtons, _
    clicks As Integer, _
    delta As Integer, _
    ctrl As Boolean, _
    alt As Boolean, _
    shift As Boolean _
)
Visual C++
public:
MouseArguments(
    double x,
    double y,
    MouseButtons button,
    int clicks,
    int delta,
    bool ctrl,
    bool alt,
    bool shift
)

Parameters

x
Type: System..::.Double
y
Type: System..::.Double
button
Type: System.Windows.Forms..::.MouseButtons
clicks
Type: System..::.Int32
delta
Type: System..::.Int32
ctrl
Type: System..::.Boolean
alt
Type: System..::.Boolean
shift
Type: System..::.Boolean

See Also

MouseArguments Class
MouseArguments Overload
PerpetuumSoft.Framework.Model Namespace


MouseArguments Constructor (Double, Double, MouseButtons, Int32, Int32, Boolean, Boolean, Boolean, )

[image]

.NET ModelKit Suite ClassReference
MouseArguments Constructor (Double, Double, MouseButtons, Int32, Int32, Boolean, Boolean, Boolean, )
MouseArguments Class See Also Send Feedback
Initializes the new instance of the MouseArguments class with specified parameters. Parameters initialize the corresponding properies using a view.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public MouseArguments(
    double x,
    double y,
    MouseButtons button,
    int clicks,
    int delta,
    bool ctrl,
    bool alt,
    bool shift,
    View view
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Double, _
    y As Double, _
    button As MouseButtons, _
    clicks As Integer, _
    delta As Integer, _
    ctrl As Boolean, _
    alt As Boolean, _
    shift As Boolean, _
    view As View _
)
Visual C++
public:
MouseArguments(
    double x,
    double y,
    MouseButtons button,
    int clicks,
    int delta,
    bool ctrl,
    bool alt,
    bool shift,
    View^ view
)

Parameters

x
Type: System..::.Double
y
Type: System..::.Double
button
Type: System.Windows.Forms..::.MouseButtons
clicks
Type: System..::.Int32
delta
Type: System..::.Int32
ctrl
Type: System..::.Boolean
alt
Type: System..::.Boolean
shift
Type: System..::.Boolean
view
Type: View

See Also

MouseArguments Class
MouseArguments Overload
PerpetuumSoft.Framework.Model Namespace


MouseArguments Methods

[image] [image]

.NET ModelKit Suite ClassReference
MouseArguments Methods
MouseArguments Class See Also Send Feedback

The MouseArguments type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPosition | Returns the mouse position in the current view.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MouseArguments Class
PerpetuumSoft.Framework.Model Namespace


GetPosition Method

[image]

.NET ModelKit Suite ClassReference
MouseArguments..::.GetPosition Method
MouseArguments Class See Also Send Feedback
Returns the mouse position in the current view.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public Vector GetPosition(
    IElement element
)
Visual Basic (Declaration)
Public Function GetPosition ( _
    element As IElement _
) As Vector
Visual C++
public:
Vector GetPosition(
    IElement^ element
)

Parameters

element
Type: PerpetuumSoft.Framework.Model..::.IElement

See Also

MouseArguments Class
PerpetuumSoft.Framework.Model Namespace


MouseArguments Properties

[image] [image]

.NET ModelKit Suite ClassReference
MouseArguments Properties
MouseArguments Class See Also Send Feedback

The MouseArguments type exposes the following members.

Properties

Name | Description
Alt | Gets whether Alt-key was pressed.
Button | Gets whether mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Ctrl | Gets whether Ctrl-key was pressed.
Delta | Gets the signed number count of the of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Shift | Gets whether Shift-key was pressed.
X | Gets the x-coordinate of the mouse cursor.
Y | Gets the y-coordinate of the mouse cursor.

See Also

MouseArguments Class
PerpetuumSoft.Framework.Model Namespace


Alt Property

[image]

.NET ModelKit Suite ClassReference
MouseArguments..::.Alt Property
MouseArguments Class See Also Send Feedback
Gets whether Alt-key was pressed.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public bool Alt { get; }
Visual Basic (Declaration)
Public ReadOnly Property Alt As Boolean
Visual C++
public:
property bool Alt {
    bool get ();
}

See Also

MouseArguments Class
PerpetuumSoft.Framework.Model Namespace


Button Property

[image]

.NET ModelKit Suite ClassReference
MouseArguments..::.Button Property
MouseArguments Class See Also Send Feedback
Gets whether mouse button was pressed.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public MouseButtons Button { get; }
Visual Basic (Declaration)
Public ReadOnly Property Button As MouseButtons
Visual C++
public:
property MouseButtons Button {
    MouseButtons get ();
}

See Also

MouseArguments Class
PerpetuumSoft.Framework.Model Namespace


Clicks Property

[image]

.NET ModelKit Suite ClassReference
MouseArguments..::.Clicks Property
MouseArguments Class See Also Send Feedback
Gets the number of times the mouse button was pressed and released.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public int Clicks { get; }
Visual Basic (Declaration)
Public ReadOnly Property Clicks As Integer
Visual C++
public:
property int Clicks {
    int get ();
}

See Also

MouseArguments Class
PerpetuumSoft.Framework.Model Namespace


Ctrl Property

[image]

.NET ModelKit Suite ClassReference
MouseArguments..::.Ctrl Property
MouseArguments Class See Also Send Feedback
Gets whether Ctrl-key was pressed.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public bool Ctrl { get; }
Visual Basic (Declaration)
Public ReadOnly Property Ctrl As Boolean
Visual C++
public:
property bool Ctrl {
    bool get ();
}

See Also

MouseArguments Class
PerpetuumSoft.Framework.Model Namespace


Delta Property

[image]

.NET ModelKit Suite ClassReference
MouseArguments..::.Delta Property
MouseArguments Class See Also Send Feedback
Gets the signed number count of the of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public int Delta { get; }
Visual Basic (Declaration)
Public ReadOnly Property Delta As Integer
Visual C++
public:
property int Delta {
    int get ();
}

See Also

MouseArguments Class
PerpetuumSoft.Framework.Model Namespace


Shift Property

[image]

.NET ModelKit Suite ClassReference
MouseArguments..::.Shift Property
MouseArguments Class See Also Send Feedback
Gets whether Shift-key was pressed.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public bool Shift { get; }
Visual Basic (Declaration)
Public ReadOnly Property Shift As Boolean
Visual C++
public:
property bool Shift {
    bool get ();
}

See Also

MouseArguments Class
PerpetuumSoft.Framework.Model Namespace


X Property

[image]

.NET ModelKit Suite ClassReference
MouseArguments..::.X Property
MouseArguments Class See Also Send Feedback
Gets the x-coordinate of the mouse cursor.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public double X { get; }
Visual Basic (Declaration)
Public ReadOnly Property X As Double
Visual C++
public:
property double X {
    double get ();
}

See Also

MouseArguments Class
PerpetuumSoft.Framework.Model Namespace


Y Property

[image]

.NET ModelKit Suite ClassReference
MouseArguments..::.Y Property
MouseArguments Class See Also Send Feedback
Gets the y-coordinate of the mouse cursor.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public double Y { get; }
Visual Basic (Declaration)
Public ReadOnly Property Y As Double
Visual C++
public:
property double Y {
    double get ();
}

See Also

MouseArguments Class
PerpetuumSoft.Framework.Model Namespace


MouseEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
MouseEventHandler Delegate
See Also Send Feedback
Represents the method that will handle mouse events.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public delegate void MouseEventHandler(
    Object sender,
    MouseArguments e
)
Visual Basic (Declaration)
Public Delegate Sub MouseEventHandler ( _
    sender As Object, _
    e As MouseArguments _
)
Visual C++
public delegate void MouseEventHandler(
    Object^ sender,
    MouseArguments^ e
)

Parameters

sender
Type: System..::.Object
e
Type: PerpetuumSoft.Framework.Model..::.MouseArguments

See Also

PerpetuumSoft.Framework.Model Namespace


PaintArguments Class

[image]

.NET ModelKit Suite ClassReference
PaintArguments Class
Members See Also Send Feedback
Represents arguments for invalidating.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public class PaintArguments
Visual Basic (Declaration)
Public Class PaintArguments
Visual C++
public ref class PaintArguments

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

PaintArguments Members
PerpetuumSoft.Framework.Model Namespace


PaintArguments Members

[image] [image]

.NET ModelKit Suite ClassReference
PaintArguments Members
PaintArguments Class Constructors Methods Properties See Also Send Feedback

The PaintArguments type exposes the following members.

Constructors

Name | Description
PaintArguments | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ClipRectangle | Gets the rectangle to paint in.
Context | Gets context for drawing.
Stream | Gets the GraphicStream used to paint.

See Also

PaintArguments Class
PerpetuumSoft.Framework.Model Namespace


PaintArguments Constructor

[image] [image]

.NET ModelKit Suite ClassReference
PaintArguments Constructor
PaintArguments Class See Also Send Feedback

Overload List

Name | Description
PaintArguments(GraphicStream, VectorRectangle) | Initializes the new instance of the PaintArguments class with the specified graphics and clipping rectangle.
PaintArguments(GraphicStream, VectorRectangle, Object) | Initializes the new instance of the PaintArguments class with the specified graphics, clipping rectangle and drawing context.

See Also

PaintArguments Class
PaintArguments Members
PerpetuumSoft.Framework.Model Namespace


PaintArguments Constructor (GraphicStream, VectorRectangle)

[image]

.NET ModelKit Suite ClassReference
PaintArguments Constructor (GraphicStream, VectorRectangle)
PaintArguments Class See Also Send Feedback
Initializes the new instance of the PaintArguments class with the specified graphics and clipping rectangle.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public PaintArguments(
    GraphicStream stream,
    VectorRectangle clipRectangle
)
Visual Basic (Declaration)
Public Sub New ( _
    stream As GraphicStream, _
    clipRectangle As VectorRectangle _
)
Visual C++
public:
PaintArguments(
    GraphicStream^ stream,
    VectorRectangle clipRectangle
)

Parameters

stream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
clipRectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

PaintArguments Class
PaintArguments Overload
PerpetuumSoft.Framework.Model Namespace


PaintArguments Constructor (GraphicStream, VectorRectangle, Object)

[image]

.NET ModelKit Suite ClassReference
PaintArguments Constructor (GraphicStream, VectorRectangle, Object)
PaintArguments Class See Also Send Feedback
Initializes the new instance of the PaintArguments class with the specified graphics, clipping rectangle and drawing context.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public PaintArguments(
    GraphicStream stream,
    VectorRectangle clipRectangle,
    Object context
)
Visual Basic (Declaration)
Public Sub New ( _
    stream As GraphicStream, _
    clipRectangle As VectorRectangle, _
    context As Object _
)
Visual C++
public:
PaintArguments(
    GraphicStream^ stream,
    VectorRectangle clipRectangle,
    Object^ context
)

Parameters

stream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
clipRectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
context
Type: System..::.Object

See Also

PaintArguments Class
PaintArguments Overload
PerpetuumSoft.Framework.Model Namespace


PaintArguments Methods

[image] [image]

.NET ModelKit Suite ClassReference
PaintArguments Methods
PaintArguments Class See Also Send Feedback

The PaintArguments type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaintArguments Class
PerpetuumSoft.Framework.Model Namespace


PaintArguments Properties

[image] [image]

.NET ModelKit Suite ClassReference
PaintArguments Properties
PaintArguments Class See Also Send Feedback

The PaintArguments type exposes the following members.

Properties

Name | Description
ClipRectangle | Gets the rectangle to paint in.
Context | Gets context for drawing.
Stream | Gets the GraphicStream used to paint.

See Also

PaintArguments Class
PerpetuumSoft.Framework.Model Namespace


ClipRectangle Property

[image]

.NET ModelKit Suite ClassReference
PaintArguments..::.ClipRectangle Property
PaintArguments Class See Also Send Feedback
Gets the rectangle to paint in.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle ClipRectangle { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClipRectangle As VectorRectangle
Visual C++
public:
property VectorRectangle ClipRectangle {
    VectorRectangle get ();
}

See Also

PaintArguments Class
PerpetuumSoft.Framework.Model Namespace


Context Property

[image]

.NET ModelKit Suite ClassReference
PaintArguments..::.Context Property
PaintArguments Class See Also Send Feedback
Gets context for drawing.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public Object Context { get; }
Visual Basic (Declaration)
Public ReadOnly Property Context As Object
Visual C++
public:
property Object^ Context {
    Object^ get ();
}

See Also

PaintArguments Class
PerpetuumSoft.Framework.Model Namespace


Stream Property

[image]

.NET ModelKit Suite ClassReference
PaintArguments..::.Stream Property
PaintArguments Class See Also Send Feedback
Gets the GraphicStream used to paint.

Namespace: PerpetuumSoft.Framework.Model
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public GraphicStream Stream { get; }
Visual Basic (Declaration)
Public ReadOnly Property Stream As GraphicStream
Visual C++
public:
property GraphicStream^ Stream {
    GraphicStream^ get ();
}

See Also

PaintArguments Class
PerpetuumSoft.Framework.Model Namespace


PerpetuumSoft.Framework.Model.Viewing Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Framework.Model.Viewing Namespace
Send Feedback
The PerpetuumSoft.Framework.Model.Viewing namespace contains classes which are used to visualize the document object model.

Interfaces

Interface | Description
IViewFrame | Provides a means of displaying a frame.


IViewFrame Interface

[image]

.NET ModelKit Suite ClassReference
IViewFrame Interface
Members See Also Send Feedback
Provides a means of displaying a frame.

Namespace: PerpetuumSoft.Framework.Model.Viewing
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public interface IViewFrame
Visual Basic (Declaration)
Public Interface IViewFrame
Visual C++
public interface class IViewFrame

See Also

IViewFrame Members
PerpetuumSoft.Framework.Model.Viewing Namespace


IViewFrame Members

[image] [image]

.NET ModelKit Suite ClassReference
IViewFrame Members
IViewFrame Interface Methods Properties See Also Send Feedback

The IViewFrame type exposes the following members.

Methods

Name | Description
Invalidate | Overloaded.
UpdateView | Updates view.

Properties

Name | Description
ClientSize | Gets the size of client rectangle.

See Also

IViewFrame Interface
PerpetuumSoft.Framework.Model.Viewing Namespace


IViewFrame Methods

[image] [image]

.NET ModelKit Suite ClassReference
IViewFrame Methods
IViewFrame Interface See Also Send Feedback

The IViewFrame type exposes the following members.

Methods

Name | Description
Invalidate | Overloaded.
UpdateView | Updates view.

See Also

IViewFrame Interface
PerpetuumSoft.Framework.Model.Viewing Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
IViewFrame..::.Invalidate Method
IViewFrame Interface See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the view frame.
Invalidate(VectorRectangle) | Invalidates the specified area in the view frame.

See Also

IViewFrame Interface
IViewFrame Members
PerpetuumSoft.Framework.Model.Viewing Namespace


Invalidate Method

[image]

.NET ModelKit Suite ClassReference
IViewFrame..::.Invalidate Method
IViewFrame Interface See Also Send Feedback
Invalidates the view frame.

Namespace: PerpetuumSoft.Framework.Model.Viewing
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
void Invalidate()
Visual Basic (Declaration)
Sub Invalidate
Visual C++
void Invalidate()

See Also

IViewFrame Interface
Invalidate Overload
PerpetuumSoft.Framework.Model.Viewing Namespace


Invalidate Method (VectorRectangle)

[image]

.NET ModelKit Suite ClassReference
IViewFrame..::.Invalidate Method (VectorRectangle)
IViewFrame Interface See Also Send Feedback
Invalidates the specified area in the view frame.

Namespace: PerpetuumSoft.Framework.Model.Viewing
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
void Invalidate(
    VectorRectangle rectangle
)
Visual Basic (Declaration)
Sub Invalidate ( _
    rectangle As VectorRectangle _
)
Visual C++
void Invalidate(
    VectorRectangle rectangle
)

Parameters

rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

IViewFrame Interface
Invalidate Overload
PerpetuumSoft.Framework.Model.Viewing Namespace


UpdateView Method

[image]

.NET ModelKit Suite ClassReference
IViewFrame..::.UpdateView Method
IViewFrame Interface See Also Send Feedback
Updates view.

Namespace: PerpetuumSoft.Framework.Model.Viewing
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
void UpdateView()
Visual Basic (Declaration)
Sub UpdateView
Visual C++
void UpdateView()

See Also

IViewFrame Interface
PerpetuumSoft.Framework.Model.Viewing Namespace


IViewFrame Properties

[image] [image]

.NET ModelKit Suite ClassReference
IViewFrame Properties
IViewFrame Interface See Also Send Feedback

The IViewFrame type exposes the following members.

Properties

Name | Description
ClientSize | Gets the size of client rectangle.

See Also

IViewFrame Interface
PerpetuumSoft.Framework.Model.Viewing Namespace


ClientSize Property

[image]

.NET ModelKit Suite ClassReference
IViewFrame..::.ClientSize Property
IViewFrame Interface See Also Send Feedback
Gets the size of client rectangle.

Namespace: PerpetuumSoft.Framework.Model.Viewing
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
Vector ClientSize { get; }
Visual Basic (Declaration)
ReadOnly Property ClientSize As Vector
Visual C++
property Vector ClientSize {
    Vector get ();
}

See Also

IViewFrame Interface
PerpetuumSoft.Framework.Model.Viewing Namespace


PerpetuumSoft.Framework.Model.Windows.Forms Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Framework.Model.Windows.Forms Namespace
Send Feedback
The PerpetuumSoft.Framework.Model.Windows.Forms namespace contains classes which are used to display the document object model on Windows Forms.

Classes

Class | Description
SimpleViewFrame | Represents a control that be assigned to dispalying instrument.


SimpleViewFrame Class

[image]

.NET ModelKit Suite ClassReference
SimpleViewFrame Class
Members See Also Send Feedback
Represents a control that be assigned to dispalying instrument.

Namespace: PerpetuumSoft.Framework.Model.Windows.Forms
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public class SimpleViewFrame : UserControl,
    IViewFrame, IServiceProvider
Visual Basic (Declaration)
Public Class SimpleViewFrame _
    Inherits UserControl _
    Implements IViewFrame, IServiceProvider
Visual C++
public ref class SimpleViewFrame : public UserControl,
    IViewFrame, IServiceProvider

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Framework.Model.Windows.Forms..::.SimpleViewFrame
PerpetuumSoft.Instrumentation.Windows.Forms..::.Widget

See Also

SimpleViewFrame Members
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


SimpleViewFrame Members

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame Members
SimpleViewFrame Class Constructors Methods Properties Events See Also Send Feedback

The SimpleViewFrame type exposes the following members.

Constructors

Name | Description
SimpleViewFrame | Initializes a new instance of the SimpleViewFrame class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Overriden. See OnEnter(EventArgs). (Overrides Control..::.OnEnter(EventArgs).)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Overriden. See OnKeyDown(KeyEventArgs). (Overrides Control..::.OnKeyDown(KeyEventArgs).)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Overriden. See OnKeyUp(KeyEventArgs). (Overrides Control..::.OnKeyUp(KeyEventArgs).)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Overriden. See OnMouseDown(MouseEventArgs). (Overrides UserControl..::.OnMouseDown(MouseEventArgs).)
OnMouseEnter | Overriden. See OnMouseEnter(EventArgs). (Overrides Control..::.OnMouseEnter(EventArgs).)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Overriden. See OnMouseLeave(EventArgs). (Overrides Control..::.OnMouseLeave(EventArgs).)
OnMouseMove | Overriden. See OnMouseMove(MouseEventArgs). (Overrides Control..::.OnMouseMove(MouseEventArgs).)
OnMouseUp | Overriden. See OnMouseUp(MouseEventArgs). (Overrides Control..::.OnMouseUp(MouseEventArgs).)
OnMouseWheel | Overriden. See OnMouseWheel(MouseEventArgs). (Overrides ScrollableControl..::.OnMouseWheel(MouseEventArgs).)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Overriden. See OnPaint(PaintEventArgs). (Overrides Control..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Overriden. See OnResize(EventArgs). (Overrides UserControl..::.OnResize(EventArgs).)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateView | Implements UpdateView()()().
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewRectangle | Gets the size of client rectangle.
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SimpleViewFrame Class
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


SimpleViewFrame Constructor

[image]

.NET ModelKit Suite ClassReference
SimpleViewFrame Constructor
SimpleViewFrame Class See Also Send Feedback
Initializes a new instance of the SimpleViewFrame class.

Namespace: PerpetuumSoft.Framework.Model.Windows.Forms
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
public SimpleViewFrame()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SimpleViewFrame()

See Also

SimpleViewFrame Class
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


SimpleViewFrame Methods

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame Methods
SimpleViewFrame Class See Also Send Feedback

The SimpleViewFrame type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Overriden. See OnEnter(EventArgs). (Overrides Control..::.OnEnter(EventArgs).)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Overriden. See OnKeyDown(KeyEventArgs). (Overrides Control..::.OnKeyDown(KeyEventArgs).)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Overriden. See OnKeyUp(KeyEventArgs). (Overrides Control..::.OnKeyUp(KeyEventArgs).)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Overriden. See OnMouseDown(MouseEventArgs). (Overrides UserControl..::.OnMouseDown(MouseEventArgs).)
OnMouseEnter | Overriden. See OnMouseEnter(EventArgs). (Overrides Control..::.OnMouseEnter(EventArgs).)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Overriden. See OnMouseLeave(EventArgs). (Overrides Control..::.OnMouseLeave(EventArgs).)
OnMouseMove | Overriden. See OnMouseMove(MouseEventArgs). (Overrides Control..::.OnMouseMove(MouseEventArgs).)
OnMouseUp | Overriden. See OnMouseUp(MouseEventArgs). (Overrides Control..::.OnMouseUp(MouseEventArgs).)
OnMouseWheel | Overriden. See OnMouseWheel(MouseEventArgs). (Overrides ScrollableControl..::.OnMouseWheel(MouseEventArgs).)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Overriden. See OnPaint(PaintEventArgs). (Overrides Control..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Overriden. See OnResize(EventArgs). (Overrides UserControl..::.OnResize(EventArgs).)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateView | Implements UpdateView()()().
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

SimpleViewFrame Class
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.AccessibilityNotifyClients Method
SimpleViewFrame Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

SimpleViewFrame Class
SimpleViewFrame Members
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.BeginInvoke Method
SimpleViewFrame Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

SimpleViewFrame Class
SimpleViewFrame Members
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.Dispose Method
SimpleViewFrame Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

SimpleViewFrame Class
SimpleViewFrame Members
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.GetChildAtPoint Method
SimpleViewFrame Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

SimpleViewFrame Class
SimpleViewFrame Members
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.Invalidate Method
SimpleViewFrame Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

SimpleViewFrame Class
SimpleViewFrame Members
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.Invoke Method
SimpleViewFrame Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

SimpleViewFrame Class
SimpleViewFrame Members
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.MemberwiseClone Method
SimpleViewFrame Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SimpleViewFrame Class
SimpleViewFrame Members
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


OnEnter Method

[image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.OnEnter Method
SimpleViewFrame Class See Also Send Feedback
Overriden. See OnEnter(EventArgs).

Namespace: PerpetuumSoft.Framework.Model.Windows.Forms
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnEnter(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnEnter ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnEnter(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

SimpleViewFrame Class
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


OnKeyDown Method

[image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.OnKeyDown Method
SimpleViewFrame Class See Also Send Feedback
Overriden. See OnKeyDown(KeyEventArgs).

Namespace: PerpetuumSoft.Framework.Model.Windows.Forms
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.KeyEventArgs

See Also

SimpleViewFrame Class
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


OnKeyUp Method

[image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.OnKeyUp Method
SimpleViewFrame Class See Also Send Feedback
Overriden. See OnKeyUp(KeyEventArgs).

Namespace: PerpetuumSoft.Framework.Model.Windows.Forms
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnKeyUp(
    KeyEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnKeyUp ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyUp(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.KeyEventArgs

See Also

SimpleViewFrame Class
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


OnMouseDown Method

[image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.OnMouseDown Method
SimpleViewFrame Class See Also Send Feedback
Overriden. See OnMouseDown(MouseEventArgs).

Namespace: PerpetuumSoft.Framework.Model.Windows.Forms
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.MouseEventArgs

See Also

SimpleViewFrame Class
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


OnMouseEnter Method

[image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.OnMouseEnter Method
SimpleViewFrame Class See Also Send Feedback
Overriden. See OnMouseEnter(EventArgs).

Namespace: PerpetuumSoft.Framework.Model.Windows.Forms
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnMouseEnter(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseEnter ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseEnter(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

SimpleViewFrame Class
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


OnMouseLeave Method

[image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.OnMouseLeave Method
SimpleViewFrame Class See Also Send Feedback
Overriden. See OnMouseLeave(EventArgs).

Namespace: PerpetuumSoft.Framework.Model.Windows.Forms
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

SimpleViewFrame Class
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


OnMouseMove Method

[image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.OnMouseMove Method
SimpleViewFrame Class See Also Send Feedback
Overriden. See OnMouseMove(MouseEventArgs).

Namespace: PerpetuumSoft.Framework.Model.Windows.Forms
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.MouseEventArgs

See Also

SimpleViewFrame Class
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


OnMouseUp Method

[image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.OnMouseUp Method
SimpleViewFrame Class See Also Send Feedback
Overriden. See OnMouseUp(MouseEventArgs).

Namespace: PerpetuumSoft.Framework.Model.Windows.Forms
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.MouseEventArgs

See Also

SimpleViewFrame Class
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


OnMouseWheel Method

[image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.OnMouseWheel Method
SimpleViewFrame Class See Also Send Feedback
Overriden. See OnMouseWheel(MouseEventArgs).

Namespace: PerpetuumSoft.Framework.Model.Windows.Forms
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnMouseWheel(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseWheel ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseWheel(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.MouseEventArgs

See Also

SimpleViewFrame Class
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


OnPaint Method

[image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.OnPaint Method
SimpleViewFrame Class See Also Send Feedback
Overriden. See OnPaint(PaintEventArgs).

Namespace: PerpetuumSoft.Framework.Model.Windows.Forms
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.PaintEventArgs

See Also

SimpleViewFrame Class
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


OnResize Method

[image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.OnResize Method
SimpleViewFrame Class See Also Send Feedback
Overriden. See OnResize(EventArgs).

Namespace: PerpetuumSoft.Framework.Model.Windows.Forms
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnResize(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnResize ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnResize(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

SimpleViewFrame Class
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.PerformLayout Method
SimpleViewFrame Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

SimpleViewFrame Class
SimpleViewFrame Members
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.ResumeLayout Method
SimpleViewFrame Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

SimpleViewFrame Class
SimpleViewFrame Members
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.RtlTranslateAlignment Method
SimpleViewFrame Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

SimpleViewFrame Class
SimpleViewFrame Members
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.Scale Method
SimpleViewFrame Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

SimpleViewFrame Class
SimpleViewFrame Members
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.Select Method
SimpleViewFrame Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

SimpleViewFrame Class
SimpleViewFrame Members
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.SetBounds Method
SimpleViewFrame Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

SimpleViewFrame Class
SimpleViewFrame Members
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.UpdateBounds Method
SimpleViewFrame Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

SimpleViewFrame Class
SimpleViewFrame Members
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


UpdateView Method

[image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.UpdateView Method
SimpleViewFrame Class See Also Send Feedback
Implements UpdateView()()().

Namespace: PerpetuumSoft.Framework.Model.Windows.Forms
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void UpdateView()
Visual Basic (Declaration)
Protected Overridable Sub UpdateView
Visual C++
protected:
virtual void UpdateView()

See Also

SimpleViewFrame Class
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.Validate Method
SimpleViewFrame Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

SimpleViewFrame Class
SimpleViewFrame Members
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.ValidateChildren Method
SimpleViewFrame Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

SimpleViewFrame Class
SimpleViewFrame Members
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


SimpleViewFrame Properties

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame Properties
SimpleViewFrame Class See Also Send Feedback

The SimpleViewFrame type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewRectangle | Gets the size of client rectangle.
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

SimpleViewFrame Class
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


ViewRectangle Property

[image]

.NET ModelKit Suite ClassReference
SimpleViewFrame..::.ViewRectangle Property
SimpleViewFrame Class See Also Send Feedback
Gets the size of client rectangle.

Namespace: PerpetuumSoft.Framework.Model.Windows.Forms
Assembly: PerpetuumSoft.Framework.Model (in PerpetuumSoft.Framework.Model.dll) Version: 3.9.0.1

Syntax

C#
protected virtual Rectangle ViewRectangle { get; }
Visual Basic (Declaration)
Protected Overridable ReadOnly Property ViewRectangle As Rectangle
Visual C++
protected:
virtual property Rectangle ViewRectangle {
    Rectangle get ();
}

See Also

SimpleViewFrame Class
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


SimpleViewFrame Events

[image] [image]

.NET ModelKit Suite ClassReference
SimpleViewFrame Events
SimpleViewFrame Class See Also Send Feedback

The SimpleViewFrame type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SimpleViewFrame Class
PerpetuumSoft.Framework.Model.Windows.Forms Namespace


PerpetuumSoft.Framework.Serialization Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Framework.Serialization Namespace
Send Feedback
The PerpetuumSoft.Framework.Serialization namespace contains classes which are used for objects serialization and deserialization.

Classes

Class | Description
XSerializableAttribute | Specifies whether a property should be serialized.
XSerializationManager | Represents the class that is seralization manager.

Interfaces

Interface | Description
IXSerializationManager | Defines methods for object serialization.

Enumerations

Enumeration | Description
ReferencePersistMode | Enumerates the mode of serialization.


IXSerializationManager Interface

[image]

.NET ModelKit Suite ClassReference
IXSerializationManager Interface
Members See Also Send Feedback
Defines methods for object serialization.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public interface IXSerializationManager
Visual Basic (Declaration)
Public Interface IXSerializationManager
Visual C++
public interface class IXSerializationManager

See Also

IXSerializationManager Members
PerpetuumSoft.Framework.Serialization Namespace


IXSerializationManager Members

[image] [image]

.NET ModelKit Suite ClassReference
IXSerializationManager Members
IXSerializationManager Interface Methods See Also Send Feedback

The IXSerializationManager type exposes the following members.

Methods

Name | Description
AddPendingReference | Adds the pending reference.
GetObjectByID | Returns the object by the given ID.
GetObjectID | Creates ID for the given object.
GetProperties | Returns the collection of properties.
GetSerializer | Overloaded.
RegisterObjectID | Register the given object and ID in the inner Hashtable.

See Also

IXSerializationManager Interface
PerpetuumSoft.Framework.Serialization Namespace


IXSerializationManager Methods

[image] [image]

.NET ModelKit Suite ClassReference
IXSerializationManager Methods
IXSerializationManager Interface See Also Send Feedback

The IXSerializationManager type exposes the following members.

Methods

Name | Description
AddPendingReference | Adds the pending reference.
GetObjectByID | Returns the object by the given ID.
GetObjectID | Creates ID for the given object.
GetProperties | Returns the collection of properties.
GetSerializer | Overloaded.
RegisterObjectID | Register the given object and ID in the inner Hashtable.

See Also

IXSerializationManager Interface
PerpetuumSoft.Framework.Serialization Namespace


AddPendingReference Method

[image]

.NET ModelKit Suite ClassReference
IXSerializationManager..::.AddPendingReference Method
IXSerializationManager Interface See Also Send Feedback
Adds the pending reference.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
void AddPendingReference(
    Object obj,
    MetaProperty descriptor,
    int id
)
Visual Basic (Declaration)
Sub AddPendingReference ( _
    obj As Object, _
    descriptor As MetaProperty, _
    id As Integer _
)
Visual C++
void AddPendingReference(
    Object^ obj,
    MetaProperty^ descriptor,
    int id
)

Parameters

obj
Type: System..::.Object
descriptor
Type: MetaProperty
id
Type: System..::.Int32

See Also

IXSerializationManager Interface
PerpetuumSoft.Framework.Serialization Namespace


GetObjectByID Method

[image]

.NET ModelKit Suite ClassReference
IXSerializationManager..::.GetObjectByID Method
IXSerializationManager Interface See Also Send Feedback
Returns the object by the given ID.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
Object GetObjectByID(
    int id
)
Visual Basic (Declaration)
Function GetObjectByID ( _
    id As Integer _
) As Object
Visual C++
Object^ GetObjectByID(
    int id
)

Parameters

id
Type: System..::.Int32

See Also

IXSerializationManager Interface
PerpetuumSoft.Framework.Serialization Namespace


GetObjectID Method

[image]

.NET ModelKit Suite ClassReference
IXSerializationManager..::.GetObjectID Method
IXSerializationManager Interface See Also Send Feedback
Creates ID for the given object.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
int GetObjectID(
    Object obj
)
Visual Basic (Declaration)
Function GetObjectID ( _
    obj As Object _
) As Integer
Visual C++
int GetObjectID(
    Object^ obj
)

Parameters

obj
Type: System..::.Object

See Also

IXSerializationManager Interface
PerpetuumSoft.Framework.Serialization Namespace


GetProperties Method

[image]

.NET ModelKit Suite ClassReference
IXSerializationManager..::.GetProperties Method
IXSerializationManager Interface See Also Send Feedback
Returns the collection of properties.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
Hashtable GetProperties(
    Object target
)
Visual Basic (Declaration)
Function GetProperties ( _
    target As Object _
) As Hashtable
Visual C++
Hashtable^ GetProperties(
    Object^ target
)

Parameters

target
Type: System..::.Object

See Also

IXSerializationManager Interface
PerpetuumSoft.Framework.Serialization Namespace


GetSerializer Method

[image] [image]

.NET ModelKit Suite ClassReference
IXSerializationManager..::.GetSerializer Method
IXSerializationManager Interface See Also Send Feedback

Overload List

Name | Description
GetSerializer(Type) | Returns the serializer for the given type.
GetSerializer(Type, MetaProperty) | Returns the serializer for the given property of given type.

See Also

IXSerializationManager Interface
IXSerializationManager Members
PerpetuumSoft.Framework.Serialization Namespace


GetSerializer Method (Type)

[image]

.NET ModelKit Suite ClassReference
IXSerializationManager..::.GetSerializer Method (Type)
IXSerializationManager Interface See Also Send Feedback
Returns the serializer for the given type.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
XSerializer GetSerializer(
    Type type
)
Visual Basic (Declaration)
Function GetSerializer ( _
    type As Type _
) As XSerializer
Visual C++
XSerializer^ GetSerializer(
    Type^ type
)

Parameters

type
Type: System..::.Type

See Also

IXSerializationManager Interface
GetSerializer Overload
PerpetuumSoft.Framework.Serialization Namespace


GetSerializer Method (Type, )

[image]

.NET ModelKit Suite ClassReference
IXSerializationManager..::.GetSerializer Method (Type, )
IXSerializationManager Interface See Also Send Feedback
Returns the serializer for the given property of given type.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
XSerializer GetSerializer(
    Type type,
    MetaProperty property
)
Visual Basic (Declaration)
Function GetSerializer ( _
    type As Type, _
    property As MetaProperty _
) As XSerializer
Visual C++
XSerializer^ GetSerializer(
    Type^ type,
    MetaProperty^ property
)

Parameters

type
Type: System..::.Type
property
Type: MetaProperty

See Also

IXSerializationManager Interface
GetSerializer Overload
PerpetuumSoft.Framework.Serialization Namespace


RegisterObjectID Method

[image]

.NET ModelKit Suite ClassReference
IXSerializationManager..::.RegisterObjectID Method
IXSerializationManager Interface See Also Send Feedback
Register the given object and ID in the inner Hashtable.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
void RegisterObjectID(
    Object obj,
    int id
)
Visual Basic (Declaration)
Sub RegisterObjectID ( _
    obj As Object, _
    id As Integer _
)
Visual C++
void RegisterObjectID(
    Object^ obj,
    int id
)

Parameters

obj
Type: System..::.Object
id
Type: System..::.Int32

See Also

IXSerializationManager Interface
PerpetuumSoft.Framework.Serialization Namespace


ReferencePersistMode Enumeration

[image]

.NET ModelKit Suite ClassReference
ReferencePersistMode Enumeration
See Also Send Feedback
Enumerates the mode of serialization.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public enum ReferencePersistMode
Visual Basic (Declaration)
Public Enumeration ReferencePersistMode
Visual C++
public enum class ReferencePersistMode

Members

Member name | Description
Entity | Object is serialized as the entity.
Reference | Object is serialized as the reference.

See Also

PerpetuumSoft.Framework.Serialization Namespace


XSerializableAttribute Class

[image]

.NET ModelKit Suite ClassReference
XSerializableAttribute Class
Members See Also Send Feedback
Specifies whether a property should be serialized.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public sealed class XSerializableAttribute : Attribute
Visual Basic (Declaration)
Public NotInheritable Class XSerializableAttribute _
    Inherits Attribute
Visual C++
public ref class XSerializableAttribute sealed : public Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PerpetuumSoft.Framework.Serialization..::.XSerializableAttribute

See Also

XSerializableAttribute Members
PerpetuumSoft.Framework.Serialization Namespace


XSerializableAttribute Members

[image] [image]

.NET ModelKit Suite ClassReference
XSerializableAttribute Members
XSerializableAttribute Class Constructors Methods Properties See Also Send Feedback

The XSerializableAttribute type exposes the following members.

Constructors

Name | Description
XSerializableAttribute | Overloaded.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | Overridden. See Match(Object). (Overrides Attribute..::.Match(Object).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ReferenceMode | Gets the mode of serialization.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Yes | Gets predefined instance of XSerilizableAttribute.

See Also

XSerializableAttribute Class
PerpetuumSoft.Framework.Serialization Namespace


XSerializableAttribute Constructor

[image] [image]

.NET ModelKit Suite ClassReference
XSerializableAttribute Constructor
XSerializableAttribute Class See Also Send Feedback

Overload List

Name | Description
XSerializableAttribute()()() | Initializes a new instance of the XSerializableAttribute class.
XSerializableAttribute(ReferencePersistMode) | Initializes a new instance of the XSerializableAttribute class.

See Also

XSerializableAttribute Class
XSerializableAttribute Members
PerpetuumSoft.Framework.Serialization Namespace


XSerializableAttribute Constructor

[image]

.NET ModelKit Suite ClassReference
XSerializableAttribute Constructor
XSerializableAttribute Class See Also Send Feedback
Initializes a new instance of the XSerializableAttribute class.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public XSerializableAttribute()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XSerializableAttribute()

See Also

XSerializableAttribute Class
XSerializableAttribute Overload
PerpetuumSoft.Framework.Serialization Namespace


XSerializableAttribute Constructor (ReferencePersistMode)

[image]

.NET ModelKit Suite ClassReference
XSerializableAttribute Constructor (ReferencePersistMode)
XSerializableAttribute Class See Also Send Feedback
Initializes a new instance of the XSerializableAttribute class.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public XSerializableAttribute(
    ReferencePersistMode referenceMode
)
Visual Basic (Declaration)
Public Sub New ( _
    referenceMode As ReferencePersistMode _
)
Visual C++
public:
XSerializableAttribute(
    ReferencePersistMode referenceMode
)

Parameters

referenceMode
Type: PerpetuumSoft.Framework.Serialization..::.ReferencePersistMode

See Also

XSerializableAttribute Class
XSerializableAttribute Overload
PerpetuumSoft.Framework.Serialization Namespace


XSerializableAttribute Methods

[image] [image]

.NET ModelKit Suite ClassReference
XSerializableAttribute Methods
XSerializableAttribute Class See Also Send Feedback

The XSerializableAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | Overridden. See Match(Object). (Overrides Attribute..::.Match(Object).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XSerializableAttribute Class
PerpetuumSoft.Framework.Serialization Namespace


Match Method

[image]

.NET ModelKit Suite ClassReference
XSerializableAttribute..::.Match Method
XSerializableAttribute Class See Also Send Feedback
Overridden. See Match(Object).

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public override bool Match(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Match ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Match(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

XSerializableAttribute Class
PerpetuumSoft.Framework.Serialization Namespace


XSerializableAttribute Properties

[image] [image]

.NET ModelKit Suite ClassReference
XSerializableAttribute Properties
XSerializableAttribute Class See Also Send Feedback

The XSerializableAttribute type exposes the following members.

Properties

Name | Description
ReferenceMode | Gets the mode of serialization.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Yes | Gets predefined instance of XSerilizableAttribute.

See Also

XSerializableAttribute Class
PerpetuumSoft.Framework.Serialization Namespace


ReferenceMode Property

[image]

.NET ModelKit Suite ClassReference
XSerializableAttribute..::.ReferenceMode Property
XSerializableAttribute Class See Also Send Feedback
Gets the mode of serialization.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public ReferencePersistMode ReferenceMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReferenceMode As ReferencePersistMode
Visual C++
public:
property ReferencePersistMode ReferenceMode {
    ReferencePersistMode get ();
}

See Also

XSerializableAttribute Class
PerpetuumSoft.Framework.Serialization Namespace


Yes Property

[image]

.NET ModelKit Suite ClassReference
XSerializableAttribute..::.Yes Property
XSerializableAttribute Class See Also Send Feedback
Gets predefined instance of XSerilizableAttribute.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static XSerializableAttribute Yes { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Yes As XSerializableAttribute
Visual C++
public:
static property XSerializableAttribute^ Yes {
    XSerializableAttribute^ get ();
}

See Also

XSerializableAttribute Class
PerpetuumSoft.Framework.Serialization Namespace


XSerializationManager Class

[image]

.NET ModelKit Suite ClassReference
XSerializationManager Class
Members See Also Send Feedback
Represents the class that is seralization manager.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class XSerializationManager
Visual Basic (Declaration)
Public Class XSerializationManager
Visual C++
public ref class XSerializationManager

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Serialization..::.XSerializationManager

See Also

XSerializationManager Members
PerpetuumSoft.Framework.Serialization Namespace


XSerializationManager Members

[image] [image]

.NET ModelKit Suite ClassReference
XSerializationManager Members
XSerializationManager Class Constructors Methods See Also Send Feedback

The XSerializationManager type exposes the following members.

Constructors

Name | Description
XSerializationManager | Initializes a new instance of the XSerializationManager class.

Methods

Name | Description
AddPendingReference | Adds the pending reference.
Clone | Returns the copy of the given object.
Deserialize | Deserializes object using the specified reader.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMetaType | Returns MetaType for the given type.
GetObjectByID | Returns the object by the given ID.
GetObjectID | Creates ID for the given object.
GetProperties | Returns the collection of properties.
GetSerializer | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read | Overloaded.
RegisterObjectID | Register the given object and ID in an inner Hashtable.
Serialize | Serializes object using the specified writer.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Write | Overloaded.

See Also

XSerializationManager Class
PerpetuumSoft.Framework.Serialization Namespace


XSerializationManager Constructor

[image]

.NET ModelKit Suite ClassReference
XSerializationManager Constructor
XSerializationManager Class See Also Send Feedback
Initializes a new instance of the XSerializationManager class.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public XSerializationManager()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XSerializationManager()

See Also

XSerializationManager Class
PerpetuumSoft.Framework.Serialization Namespace


XSerializationManager Methods

[image] [image]

.NET ModelKit Suite ClassReference
XSerializationManager Methods
XSerializationManager Class See Also Send Feedback

The XSerializationManager type exposes the following members.

Methods

Name | Description
AddPendingReference | Adds the pending reference.
Clone | Returns the copy of the given object.
Deserialize | Deserializes object using the specified reader.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetMetaType | Returns MetaType for the given type.
GetObjectByID | Returns the object by the given ID.
GetObjectID | Creates ID for the given object.
GetProperties | Returns the collection of properties.
GetSerializer | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Read | Overloaded.
RegisterObjectID | Register the given object and ID in an inner Hashtable.
Serialize | Serializes object using the specified writer.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Write | Overloaded.

See Also

XSerializationManager Class
PerpetuumSoft.Framework.Serialization Namespace


AddPendingReference Method

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.AddPendingReference Method
XSerializationManager Class See Also Send Feedback
Adds the pending reference.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void AddPendingReference(
    Object obj,
    MetaProperty descriptor,
    int id
)
Visual Basic (Declaration)
Public Sub AddPendingReference ( _
    obj As Object, _
    descriptor As MetaProperty, _
    id As Integer _
)
Visual C++
public:
void AddPendingReference(
    Object^ obj,
    MetaProperty^ descriptor,
    int id
)

Parameters

obj
Type: System..::.Object
descriptor
Type: MetaProperty
id
Type: System..::.Int32

See Also

XSerializationManager Class
PerpetuumSoft.Framework.Serialization Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.Clone Method
XSerializationManager Class See Also Send Feedback
Returns the copy of the given object.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Object Clone(
    Object target
)
Visual Basic (Declaration)
Public Shared Function Clone ( _
    target As Object _
) As Object
Visual C++
public:
static Object^ Clone(
    Object^ target
)

Parameters

target
Type: System..::.Object

See Also

XSerializationManager Class
PerpetuumSoft.Framework.Serialization Namespace


Deserialize Method

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.Deserialize Method
XSerializationManager Class See Also Send Feedback
Deserializes object using the specified reader.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Object Deserialize(
    XmlReader reader
)
Visual Basic (Declaration)
Public Function Deserialize ( _
    reader As XmlReader _
) As Object
Visual C++
public:
Object^ Deserialize(
    XmlReader^ reader
)

Parameters

reader
Type: System.Xml..::.XmlReader

See Also

XSerializationManager Class
PerpetuumSoft.Framework.Serialization Namespace


GetMetaType Method

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.GetMetaType Method
XSerializationManager Class See Also Send Feedback
Returns MetaType for the given type.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static MetaType GetMetaType(
    Type type
)
Visual Basic (Declaration)
Public Shared Function GetMetaType ( _
    type As Type _
) As MetaType
Visual C++
public:
static MetaType^ GetMetaType(
    Type^ type
)

Parameters

type
Type: System..::.Type

See Also

XSerializationManager Class
PerpetuumSoft.Framework.Serialization Namespace


GetObjectByID Method

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.GetObjectByID Method
XSerializationManager Class See Also Send Feedback
Returns the object by the given ID.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Object GetObjectByID(
    int id
)
Visual Basic (Declaration)
Public Function GetObjectByID ( _
    id As Integer _
) As Object
Visual C++
public:
Object^ GetObjectByID(
    int id
)

Parameters

id
Type: System..::.Int32

See Also

XSerializationManager Class
PerpetuumSoft.Framework.Serialization Namespace


GetObjectID Method

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.GetObjectID Method
XSerializationManager Class See Also Send Feedback
Creates ID for the given object.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public int GetObjectID(
    Object obj
)
Visual Basic (Declaration)
Public Function GetObjectID ( _
    obj As Object _
) As Integer
Visual C++
public:
int GetObjectID(
    Object^ obj
)

Parameters

obj
Type: System..::.Object

See Also

XSerializationManager Class
PerpetuumSoft.Framework.Serialization Namespace


GetProperties Method

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.GetProperties Method
XSerializationManager Class See Also Send Feedback
Returns the collection of properties.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Hashtable GetProperties(
    Object target
)
Visual Basic (Declaration)
Public Shared Function GetProperties ( _
    target As Object _
) As Hashtable
Visual C++
public:
static Hashtable^ GetProperties(
    Object^ target
)

Parameters

target
Type: System..::.Object

See Also

XSerializationManager Class
PerpetuumSoft.Framework.Serialization Namespace


GetSerializer Method

[image] [image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.GetSerializer Method
XSerializationManager Class See Also Send Feedback

Overload List

Name | Description
GetSerializer(Type) | Returns the serializer for the given property of the given type.
GetSerializer(Type, MetaProperty) | Returns the serializer for the given type.

See Also

XSerializationManager Class
XSerializationManager Members
PerpetuumSoft.Framework.Serialization Namespace


GetSerializer Method (Type)

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.GetSerializer Method (Type)
XSerializationManager Class See Also Send Feedback
Returns the serializer for the given property of the given type.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static XSerializer GetSerializer(
    Type type
)
Visual Basic (Declaration)
Public Shared Function GetSerializer ( _
    type As Type _
) As XSerializer
Visual C++
public:
static XSerializer^ GetSerializer(
    Type^ type
)

Parameters

type
Type: System..::.Type

See Also

XSerializationManager Class
GetSerializer Overload
PerpetuumSoft.Framework.Serialization Namespace


GetSerializer Method (Type, )

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.GetSerializer Method (Type, )
XSerializationManager Class See Also Send Feedback
Returns the serializer for the given type.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static XSerializer GetSerializer(
    Type type,
    MetaProperty property
)
Visual Basic (Declaration)
Public Shared Function GetSerializer ( _
    type As Type, _
    property As MetaProperty _
) As XSerializer
Visual C++
public:
static XSerializer^ GetSerializer(
    Type^ type,
    MetaProperty^ property
)

Parameters

type
Type: System..::.Type
property
Type: MetaProperty

See Also

XSerializationManager Class
GetSerializer Overload
PerpetuumSoft.Framework.Serialization Namespace


Read Method

[image] [image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.Read Method
XSerializationManager Class See Also Send Feedback

Overload List

Name | Description
Read(Stream) | Returns the object from the given stream.
Read(TextReader) | Returns the object using the given reader.
Read(String) | Returns the object from the given file.
Read(XmlReader) | Returns the object using the given reader.
Read(Type, String) | Returns the object from resources.

See Also

XSerializationManager Class
XSerializationManager Members
PerpetuumSoft.Framework.Serialization Namespace


Read Method (Stream)

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.Read Method (Stream)
XSerializationManager Class See Also Send Feedback
Returns the object from the given stream.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Object Read(
    Stream stream
)
Visual Basic (Declaration)
Public Shared Function Read ( _
    stream As Stream _
) As Object
Visual C++
public:
static Object^ Read(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

XSerializationManager Class
Read Overload
PerpetuumSoft.Framework.Serialization Namespace


Read Method (TextReader)

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.Read Method (TextReader)
XSerializationManager Class See Also Send Feedback
Returns the object using the given reader.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Object Read(
    TextReader reader
)
Visual Basic (Declaration)
Public Shared Function Read ( _
    reader As TextReader _
) As Object
Visual C++
public:
static Object^ Read(
    TextReader^ reader
)

Parameters

reader
Type: System.IO..::.TextReader

See Also

XSerializationManager Class
Read Overload
PerpetuumSoft.Framework.Serialization Namespace


Read Method (String)

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.Read Method (String)
XSerializationManager Class See Also Send Feedback
Returns the object from the given file.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Object Read(
    string fileName
)
Visual Basic (Declaration)
Public Shared Function Read ( _
    fileName As String _
) As Object
Visual C++
public:
static Object^ Read(
    String^ fileName
)

Parameters

fileName
Type: System..::.String

See Also

XSerializationManager Class
Read Overload
PerpetuumSoft.Framework.Serialization Namespace


Read Method (XmlReader)

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.Read Method (XmlReader)
XSerializationManager Class See Also Send Feedback
Returns the object using the given reader.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Object Read(
    XmlReader reader
)
Visual Basic (Declaration)
Public Shared Function Read ( _
    reader As XmlReader _
) As Object
Visual C++
public:
static Object^ Read(
    XmlReader^ reader
)

Parameters

reader
Type: System.Xml..::.XmlReader

See Also

XSerializationManager Class
Read Overload
PerpetuumSoft.Framework.Serialization Namespace


Read Method (Type, String)

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.Read Method (Type, String)
XSerializationManager Class See Also Send Feedback
Returns the object from resources.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Object Read(
    Type type,
    string resourceName
)
Visual Basic (Declaration)
Public Shared Function Read ( _
    type As Type, _
    resourceName As String _
) As Object
Visual C++
public:
static Object^ Read(
    Type^ type,
    String^ resourceName
)

Parameters

type
Type: System..::.Type
resourceName
Type: System..::.String

See Also

XSerializationManager Class
Read Overload
PerpetuumSoft.Framework.Serialization Namespace


RegisterObjectID Method

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.RegisterObjectID Method
XSerializationManager Class See Also Send Feedback
Register the given object and ID in an inner Hashtable.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void RegisterObjectID(
    Object obj,
    int id
)
Visual Basic (Declaration)
Public Sub RegisterObjectID ( _
    obj As Object, _
    id As Integer _
)
Visual C++
public:
void RegisterObjectID(
    Object^ obj,
    int id
)

Parameters

obj
Type: System..::.Object
id
Type: System..::.Int32

See Also

XSerializationManager Class
PerpetuumSoft.Framework.Serialization Namespace


Serialize Method

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.Serialize Method
XSerializationManager Class See Also Send Feedback
Serializes object using the specified writer.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void Serialize(
    Object target,
    XmlWriter writer
)
Visual Basic (Declaration)
Public Sub Serialize ( _
    target As Object, _
    writer As XmlWriter _
)
Visual C++
public:
void Serialize(
    Object^ target,
    XmlWriter^ writer
)

Parameters

target
Type: System..::.Object
writer
Type: System.Xml..::.XmlWriter

See Also

XSerializationManager Class
PerpetuumSoft.Framework.Serialization Namespace


Write Method

[image] [image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.Write Method
XSerializationManager Class See Also Send Feedback

Overload List

Name | Description
Write(Object, Stream) | Writes the given object to the given stream.
Write(Object, TextWriter) | Writes the given object using the given writer.
Write(Object, String) | Writes the given object to the given file.
Write(Object, XmlWriter) | Writes the given object using the given writer.

See Also

XSerializationManager Class
XSerializationManager Members
PerpetuumSoft.Framework.Serialization Namespace


Write Method (Object, Stream)

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.Write Method (Object, Stream)
XSerializationManager Class See Also Send Feedback
Writes the given object to the given stream.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static void Write(
    Object target,
    Stream stream
)
Visual Basic (Declaration)
Public Shared Sub Write ( _
    target As Object, _
    stream As Stream _
)
Visual C++
public:
static void Write(
    Object^ target,
    Stream^ stream
)

Parameters

target
Type: System..::.Object
stream
Type: System.IO..::.Stream

See Also

XSerializationManager Class
Write Overload
PerpetuumSoft.Framework.Serialization Namespace


Write Method (Object, TextWriter)

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.Write Method (Object, TextWriter)
XSerializationManager Class See Also Send Feedback
Writes the given object using the given writer.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static void Write(
    Object target,
    TextWriter writer
)
Visual Basic (Declaration)
Public Shared Sub Write ( _
    target As Object, _
    writer As TextWriter _
)
Visual C++
public:
static void Write(
    Object^ target,
    TextWriter^ writer
)

Parameters

target
Type: System..::.Object
writer
Type: System.IO..::.TextWriter

See Also

XSerializationManager Class
Write Overload
PerpetuumSoft.Framework.Serialization Namespace


Write Method (Object, String)

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.Write Method (Object, String)
XSerializationManager Class See Also Send Feedback
Writes the given object to the given file.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static void Write(
    Object target,
    string fileName
)
Visual Basic (Declaration)
Public Shared Sub Write ( _
    target As Object, _
    fileName As String _
)
Visual C++
public:
static void Write(
    Object^ target,
    String^ fileName
)

Parameters

target
Type: System..::.Object
fileName
Type: System..::.String

See Also

XSerializationManager Class
Write Overload
PerpetuumSoft.Framework.Serialization Namespace


Write Method (Object, XmlWriter)

[image]

.NET ModelKit Suite ClassReference
XSerializationManager..::.Write Method (Object, XmlWriter)
XSerializationManager Class See Also Send Feedback
Writes the given object using the given writer.

Namespace: PerpetuumSoft.Framework.Serialization
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static void Write(
    Object target,
    XmlWriter writer
)
Visual Basic (Declaration)
Public Shared Sub Write ( _
    target As Object, _
    writer As XmlWriter _
)
Visual C++
public:
static void Write(
    Object^ target,
    XmlWriter^ writer
)

Parameters

target
Type: System..::.Object
writer
Type: System.Xml..::.XmlWriter

See Also

XSerializationManager Class
Write Overload
PerpetuumSoft.Framework.Serialization Namespace


PerpetuumSoft.Framework.Text Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Framework.Text Namespace
Send Feedback
The PerpetuumSoft.Framework.Text namespace contains classes which are used for text processing and display.

Classes

Class | Description
GDIPlusFormattedTextBuilder | FormattedTextBuilder for GDI+.

Structures

Structure | Description
TextMetric | Describes text metrics.


GDIPlusFormattedTextBuilder Class

[image]

.NET ModelKit Suite ClassReference
GDIPlusFormattedTextBuilder Class
Members See Also Send Feedback
FormattedTextBuilder for GDI+.

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class GDIPlusFormattedTextBuilder
Visual Basic (Declaration)
Public Class GDIPlusFormattedTextBuilder
Visual C++
public ref class GDIPlusFormattedTextBuilder

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Text..::.GDIPlusFormattedTextBuilder

See Also

GDIPlusFormattedTextBuilder Members
PerpetuumSoft.Framework.Text Namespace


GDIPlusFormattedTextBuilder Members

[image] [image]

.NET ModelKit Suite ClassReference
GDIPlusFormattedTextBuilder Members
GDIPlusFormattedTextBuilder Class Constructors Methods Properties See Also Send Feedback

The GDIPlusFormattedTextBuilder type exposes the following members.

Constructors

Name | Description
GDIPlusFormattedTextBuilder | Initializes a new instance of the GDIPlusFormattedTextBuilder class.

Methods

Name | Description
EndBuild | Implements EndBuild()()().
EndParagraph | Implements EndParagraph()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTextMetric | Implements GetTextMetric(String, TextStyle).
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NewLine | Implements NewLine(Vector, TextMetric).
NewParagraph | Implements NewParagraph(ParagraphStyle).
OutLine | Implements OutLine(Color, Double, Double, Double, Double).
OutText | Overloaded.
StartBuild | Implements StartBuild()()().
StartParagraph | Implements StartParagraph()()().
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
RightToLeft | Text orientation.

See Also

GDIPlusFormattedTextBuilder Class
PerpetuumSoft.Framework.Text Namespace


GDIPlusFormattedTextBuilder Constructor

[image]

.NET ModelKit Suite ClassReference
GDIPlusFormattedTextBuilder Constructor
GDIPlusFormattedTextBuilder Class See Also Send Feedback
Initializes a new instance of the GDIPlusFormattedTextBuilder class.

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public GDIPlusFormattedTextBuilder(
    Graphics g
)
Visual Basic (Declaration)
Public Sub New ( _
    g As Graphics _
)
Visual C++
public:
GDIPlusFormattedTextBuilder(
    Graphics^ g
)

Parameters

g
Type: System.Drawing..::.Graphics

See Also

GDIPlusFormattedTextBuilder Class
PerpetuumSoft.Framework.Text Namespace


GDIPlusFormattedTextBuilder Methods

[image] [image]

.NET ModelKit Suite ClassReference
GDIPlusFormattedTextBuilder Methods
GDIPlusFormattedTextBuilder Class See Also Send Feedback

The GDIPlusFormattedTextBuilder type exposes the following members.

Methods

Name | Description
EndBuild | Implements EndBuild()()().
EndParagraph | Implements EndParagraph()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTextMetric | Implements GetTextMetric(String, TextStyle).
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NewLine | Implements NewLine(Vector, TextMetric).
NewParagraph | Implements NewParagraph(ParagraphStyle).
OutLine | Implements OutLine(Color, Double, Double, Double, Double).
OutText | Overloaded.
StartBuild | Implements StartBuild()()().
StartParagraph | Implements StartParagraph()()().
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GDIPlusFormattedTextBuilder Class
PerpetuumSoft.Framework.Text Namespace


EndBuild Method

[image]

.NET ModelKit Suite ClassReference
GDIPlusFormattedTextBuilder..::.EndBuild Method
GDIPlusFormattedTextBuilder Class See Also Send Feedback
Implements EndBuild()()().

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void EndBuild()
Visual Basic (Declaration)
Public Sub EndBuild
Visual C++
public:
virtual void EndBuild() sealed

See Also

GDIPlusFormattedTextBuilder Class
PerpetuumSoft.Framework.Text Namespace


EndParagraph Method

[image]

.NET ModelKit Suite ClassReference
GDIPlusFormattedTextBuilder..::.EndParagraph Method
GDIPlusFormattedTextBuilder Class See Also Send Feedback
Implements EndParagraph()()().

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void EndParagraph()
Visual Basic (Declaration)
Public Sub EndParagraph
Visual C++
public:
virtual void EndParagraph() sealed

See Also

GDIPlusFormattedTextBuilder Class
PerpetuumSoft.Framework.Text Namespace


GetTextMetric Method

[image]

.NET ModelKit Suite ClassReference
GDIPlusFormattedTextBuilder..::.GetTextMetric Method
GDIPlusFormattedTextBuilder Class See Also Send Feedback
Implements GetTextMetric(String, TextStyle).

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public TextMetric GetTextMetric(
    string text,
    TextStyle style
)
Visual Basic (Declaration)
Public Function GetTextMetric ( _
    text As String, _
    style As TextStyle _
) As TextMetric
Visual C++
public:
virtual TextMetric GetTextMetric(
    String^ text,
    TextStyle^ style
) sealed

Parameters

text
Type: System..::.String
style
Type: TextStyle

See Also

GDIPlusFormattedTextBuilder Class
PerpetuumSoft.Framework.Text Namespace


NewLine Method

[image]

.NET ModelKit Suite ClassReference
GDIPlusFormattedTextBuilder..::.NewLine Method
GDIPlusFormattedTextBuilder Class See Also Send Feedback
Implements NewLine(Vector, TextMetric).

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void NewLine(
    Vector startPoint,
    TextMetric lineMetric
)
Visual Basic (Declaration)
Public Sub NewLine ( _
    startPoint As Vector, _
    lineMetric As TextMetric _
)
Visual C++
public:
virtual void NewLine(
    Vector startPoint,
    TextMetric lineMetric
) sealed

Parameters

startPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
lineMetric
Type: PerpetuumSoft.Framework.Text..::.TextMetric

See Also

GDIPlusFormattedTextBuilder Class
PerpetuumSoft.Framework.Text Namespace


NewParagraph Method

[image]

.NET ModelKit Suite ClassReference
GDIPlusFormattedTextBuilder..::.NewParagraph Method
GDIPlusFormattedTextBuilder Class See Also Send Feedback
Implements NewParagraph(ParagraphStyle).

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void NewParagraph(
    ParagraphStyle style
)
Visual Basic (Declaration)
Public Sub NewParagraph ( _
    style As ParagraphStyle _
)
Visual C++
public:
virtual void NewParagraph(
    ParagraphStyle style
) sealed

Parameters

style
Type: ParagraphStyle

See Also

GDIPlusFormattedTextBuilder Class
PerpetuumSoft.Framework.Text Namespace


OutLine Method

[image]

.NET ModelKit Suite ClassReference
GDIPlusFormattedTextBuilder..::.OutLine Method
GDIPlusFormattedTextBuilder Class See Also Send Feedback
Implements OutLine(Color, Double, Double, Double, Double).

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void OutLine(
    Color color,
    double width,
    double startX,
    double endX,
    double y
)
Visual Basic (Declaration)
Public Sub OutLine ( _
    color As Color, _
    width As Double, _
    startX As Double, _
    endX As Double, _
    y As Double _
)
Visual C++
public:
virtual void OutLine(
    Color color,
    double width,
    double startX,
    double endX,
    double y
) sealed

Parameters

color
Type: System.Drawing..::.Color
width
Type: System..::.Double
startX
Type: System..::.Double
endX
Type: System..::.Double
y
Type: System..::.Double

See Also

GDIPlusFormattedTextBuilder Class
PerpetuumSoft.Framework.Text Namespace


OutText Method

[image] [image]

.NET ModelKit Suite ClassReference
GDIPlusFormattedTextBuilder..::.OutText Method
GDIPlusFormattedTextBuilder Class See Also Send Feedback

Overload List

Name | Description
OutText(String, TextStyle, TextMetric, Double) | Implements OutText(String, TextStyle, TextMetric, Double).
OutText(String, TextStyle, TextMetric, Double, StringFormat) | Implements OutText(String, TextStyle, TextMetric, Double, StringFormat).

See Also

GDIPlusFormattedTextBuilder Class
GDIPlusFormattedTextBuilder Members
PerpetuumSoft.Framework.Text Namespace


OutText Method (String, , TextMetric, Double)

[image]

.NET ModelKit Suite ClassReference
GDIPlusFormattedTextBuilder..::.OutText Method (String, , TextMetric, Double)
GDIPlusFormattedTextBuilder Class See Also Send Feedback
Implements OutText(String, TextStyle, TextMetric, Double).

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void OutText(
    string text,
    TextStyle style,
    TextMetric metric,
    double shift
)
Visual Basic (Declaration)
Public Sub OutText ( _
    text As String, _
    style As TextStyle, _
    metric As TextMetric, _
    shift As Double _
)
Visual C++
public:
virtual void OutText(
    String^ text,
    TextStyle^ style,
    TextMetric metric,
    double shift
) sealed

Parameters

text
Type: System..::.String
style
Type: TextStyle
metric
Type: PerpetuumSoft.Framework.Text..::.TextMetric
shift
Type: System..::.Double

See Also

GDIPlusFormattedTextBuilder Class
OutText Overload
PerpetuumSoft.Framework.Text Namespace


OutText Method (String, , TextMetric, Double, StringFormat)

[image]

.NET ModelKit Suite ClassReference
GDIPlusFormattedTextBuilder..::.OutText Method (String, , TextMetric, Double, StringFormat)
GDIPlusFormattedTextBuilder Class See Also Send Feedback
Implements OutText(String, TextStyle, TextMetric, Double, StringFormat).

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void OutText(
    string text,
    TextStyle style,
    TextMetric metric,
    double shift,
    StringFormat format
)
Visual Basic (Declaration)
Public Sub OutText ( _
    text As String, _
    style As TextStyle, _
    metric As TextMetric, _
    shift As Double, _
    format As StringFormat _
)
Visual C++
public:
virtual void OutText(
    String^ text,
    TextStyle^ style,
    TextMetric metric,
    double shift,
    StringFormat^ format
) sealed

Parameters

text
Type: System..::.String
style
Type: TextStyle
metric
Type: PerpetuumSoft.Framework.Text..::.TextMetric
shift
Type: System..::.Double
format
Type: System.Drawing..::.StringFormat

See Also

GDIPlusFormattedTextBuilder Class
OutText Overload
PerpetuumSoft.Framework.Text Namespace


StartBuild Method

[image]

.NET ModelKit Suite ClassReference
GDIPlusFormattedTextBuilder..::.StartBuild Method
GDIPlusFormattedTextBuilder Class See Also Send Feedback
Implements StartBuild()()().

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void StartBuild()
Visual Basic (Declaration)
Public Sub StartBuild
Visual C++
public:
virtual void StartBuild() sealed

See Also

GDIPlusFormattedTextBuilder Class
PerpetuumSoft.Framework.Text Namespace


StartParagraph Method

[image]

.NET ModelKit Suite ClassReference
GDIPlusFormattedTextBuilder..::.StartParagraph Method
GDIPlusFormattedTextBuilder Class See Also Send Feedback
Implements StartParagraph()()().

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public void StartParagraph()
Visual Basic (Declaration)
Public Sub StartParagraph
Visual C++
public:
virtual void StartParagraph() sealed

See Also

GDIPlusFormattedTextBuilder Class
PerpetuumSoft.Framework.Text Namespace


GDIPlusFormattedTextBuilder Properties

[image] [image]

.NET ModelKit Suite ClassReference
GDIPlusFormattedTextBuilder Properties
GDIPlusFormattedTextBuilder Class See Also Send Feedback

The GDIPlusFormattedTextBuilder type exposes the following members.

Properties

Name | Description
RightToLeft | Text orientation.

See Also

GDIPlusFormattedTextBuilder Class
PerpetuumSoft.Framework.Text Namespace


RightToLeft Property

[image]

.NET ModelKit Suite ClassReference
GDIPlusFormattedTextBuilder..::.RightToLeft Property
GDIPlusFormattedTextBuilder Class See Also Send Feedback
Text orientation.

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public bool RightToLeft { get; set; }
Visual Basic (Declaration)
Public Property RightToLeft As Boolean
Visual C++
public:
property bool RightToLeft {
    bool get ();
    void set (bool value);
}

See Also

GDIPlusFormattedTextBuilder Class
PerpetuumSoft.Framework.Text Namespace


TextMetric Structure

[image]

.NET ModelKit Suite ClassReference
TextMetric Structure
Members See Also Send Feedback
Describes text metrics.

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public struct TextMetric
Visual Basic (Declaration)
Public Structure TextMetric
Visual C++
public value class TextMetric

See Also

TextMetric Members
PerpetuumSoft.Framework.Text Namespace


TextMetric Members

[image] [image]

.NET ModelKit Suite ClassReference
TextMetric Members
TextMetric Structure Constructors Methods Properties See Also Send Feedback

The TextMetric type exposes the following members.

Constructors

Name | Description
TextMetric | Overloaded.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Ascent | Text ascent.
Descent | Text descent.
EmptyTextMetric | Returns TextMetric with empty parameters.
Height | Text heigth.
IsBreak |
IsCalculated | Flasg indicating wether metrics has been calculated.
Width | Text width.

See Also

TextMetric Structure
PerpetuumSoft.Framework.Text Namespace


TextMetric Constructor

[image] [image]

.NET ModelKit Suite ClassReference
TextMetric Constructor
TextMetric Structure See Also Send Feedback

Overload List

Name | Description
TextMetric(Double, Double, Double) | Initializes a new instance of the TextMetric class.
TextMetric(Double, Double, Double, Boolean) | Initializes a new instance of the TextMetric class

See Also

TextMetric Structure
TextMetric Members
PerpetuumSoft.Framework.Text Namespace


TextMetric Constructor (Double, Double, Double)

[image]

.NET ModelKit Suite ClassReference
TextMetric Constructor (Double, Double, Double)
TextMetric Structure See Also Send Feedback
Initializes a new instance of the TextMetric class.

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public TextMetric(
    double width,
    double height,
    double ascent
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Double, _
    height As Double, _
    ascent As Double _
)
Visual C++
public:
TextMetric(
    double width,
    double height,
    double ascent
)

Parameters

width
Type: System..::.Double
height
Type: System..::.Double
ascent
Type: System..::.Double

See Also

TextMetric Structure
TextMetric Overload
PerpetuumSoft.Framework.Text Namespace


TextMetric Constructor (Double, Double, Double, Boolean)

[image]

.NET ModelKit Suite ClassReference
TextMetric Constructor (Double, Double, Double, Boolean)
TextMetric Structure See Also Send Feedback
Initializes a new instance of the TextMetric class

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public TextMetric(
    double width,
    double height,
    double ascent,
    bool isBreak
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Double, _
    height As Double, _
    ascent As Double, _
    isBreak As Boolean _
)
Visual C++
public:
TextMetric(
    double width,
    double height,
    double ascent,
    bool isBreak
)

Parameters

width
Type: System..::.Double
height
Type: System..::.Double
ascent
Type: System..::.Double
isBreak
Type: System..::.Boolean

See Also

TextMetric Structure
TextMetric Overload
PerpetuumSoft.Framework.Text Namespace


TextMetric Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextMetric Methods
TextMetric Structure See Also Send Feedback

The TextMetric type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

TextMetric Structure
PerpetuumSoft.Framework.Text Namespace


TextMetric Properties

[image] [image]

.NET ModelKit Suite ClassReference
TextMetric Properties
TextMetric Structure See Also Send Feedback

The TextMetric type exposes the following members.

Properties

Name | Description
Ascent | Text ascent.
Descent | Text descent.
EmptyTextMetric | Returns TextMetric with empty parameters.
Height | Text heigth.
IsBreak |
IsCalculated | Flasg indicating wether metrics has been calculated.
Width | Text width.

See Also

TextMetric Structure
PerpetuumSoft.Framework.Text Namespace


Ascent Property

[image]

.NET ModelKit Suite ClassReference
TextMetric..::.Ascent Property
TextMetric Structure See Also Send Feedback
Text ascent.

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Ascent { get; }
Visual Basic (Declaration)
Public ReadOnly Property Ascent As Double
Visual C++
public:
property double Ascent {
    double get ();
}

See Also

TextMetric Structure
PerpetuumSoft.Framework.Text Namespace


Descent Property

[image]

.NET ModelKit Suite ClassReference
TextMetric..::.Descent Property
TextMetric Structure See Also Send Feedback
Text descent.

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Descent { get; }
Visual Basic (Declaration)
Public ReadOnly Property Descent As Double
Visual C++
public:
property double Descent {
    double get ();
}

See Also

TextMetric Structure
PerpetuumSoft.Framework.Text Namespace


EmptyTextMetric Property

[image]

.NET ModelKit Suite ClassReference
TextMetric..::.EmptyTextMetric Property
TextMetric Structure See Also Send Feedback
Returns TextMetric with empty parameters.

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static TextMetric EmptyTextMetric { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EmptyTextMetric As TextMetric
Visual C++
public:
static property TextMetric EmptyTextMetric {
    TextMetric get ();
}

See Also

TextMetric Structure
PerpetuumSoft.Framework.Text Namespace


Height Property

[image]

.NET ModelKit Suite ClassReference
TextMetric..::.Height Property
TextMetric Structure See Also Send Feedback
Text heigth.

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Height { get; }
Visual Basic (Declaration)
Public ReadOnly Property Height As Double
Visual C++
public:
property double Height {
    double get ();
}

See Also

TextMetric Structure
PerpetuumSoft.Framework.Text Namespace


IsBreak Property

[image]

.NET ModelKit Suite ClassReference
TextMetric..::.IsBreak Property
TextMetric Structure See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Framework.Text.TextMetric.IsBreak]

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public bool IsBreak { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsBreak As Boolean
Visual C++
public:
property bool IsBreak {
    bool get ();
}

See Also

TextMetric Structure
PerpetuumSoft.Framework.Text Namespace


IsCalculated Property

[image]

.NET ModelKit Suite ClassReference
TextMetric..::.IsCalculated Property
TextMetric Structure See Also Send Feedback
Flasg indicating wether metrics has been calculated.

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public bool IsCalculated { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCalculated As Boolean
Visual C++
public:
property bool IsCalculated {
    bool get ();
}

See Also

TextMetric Structure
PerpetuumSoft.Framework.Text Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
TextMetric..::.Width Property
TextMetric Structure See Also Send Feedback
Text width.

Namespace: PerpetuumSoft.Framework.Text
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public double Width { get; }
Visual Basic (Declaration)
Public ReadOnly Property Width As Double
Visual C++
public:
property double Width {
    double get ();
}

See Also

TextMetric Structure
PerpetuumSoft.Framework.Text Namespace


PerpetuumSoft.Framework.Utilities Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Framework.Utilities Namespace
Send Feedback
The PerpetuumSoft.Framework.Utilities namespace contains classes which provide various utility functionality.

Classes

Class | Description
COMUtilities | Utilities for COM interoperability.
GraphicsUtilites | Utilities for Graphics operations.
RegistryAccessor |
UserSettingsManager | The type for worknig with form settings
WinAPIUtilities | API wrappers.


COMUtilities Class

[image]

.NET ModelKit Suite ClassReference
COMUtilities Class
Members See Also Send Feedback
Utilities for COM interoperability.

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public sealed class COMUtilities
Visual Basic (Declaration)
Public NotInheritable Class COMUtilities
Visual C++
public ref class COMUtilities sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Utilities..::.COMUtilities

See Also

COMUtilities Members
PerpetuumSoft.Framework.Utilities Namespace


COMUtilities Members

[image] [image]

.NET ModelKit Suite ClassReference
COMUtilities Members
COMUtilities Class Methods See Also Send Feedback

The COMUtilities type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Overloaded.
GetVarEnum | Gets VarEnum based on given type.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

COMUtilities Class
PerpetuumSoft.Framework.Utilities Namespace


COMUtilities Methods

[image] [image]

.NET ModelKit Suite ClassReference
COMUtilities Methods
COMUtilities Class See Also Send Feedback

The COMUtilities type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Overloaded.
GetVarEnum | Gets VarEnum based on given type.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

COMUtilities Class
PerpetuumSoft.Framework.Utilities Namespace


GetType Method

[image] [image]

.NET ModelKit Suite ClassReference
COMUtilities..::.GetType Method
COMUtilities Class See Also Send Feedback

Overload List

Name | Description
GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
GetType(VarEnum) | Gets type based on given VarEnum.

See Also

COMUtilities Class
COMUtilities Members
PerpetuumSoft.Framework.Utilities Namespace


GetType Method (VarEnum)

[image]

.NET ModelKit Suite ClassReference
COMUtilities..::.GetType Method (VarEnum)
COMUtilities Class See Also Send Feedback
Gets type based on given VarEnum.

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Type GetType(
    VarEnum varEnum
)
Visual Basic (Declaration)
Public Shared Function GetType ( _
    varEnum As VarEnum _
) As Type
Visual C++
public:
static Type^ GetType(
    VarEnum varEnum
)

Parameters

varEnum
Type: System.Runtime.InteropServices..::.VarEnum

See Also

COMUtilities Class
GetType Overload
PerpetuumSoft.Framework.Utilities Namespace


GetVarEnum Method

[image]

.NET ModelKit Suite ClassReference
COMUtilities..::.GetVarEnum Method
COMUtilities Class See Also Send Feedback
Gets VarEnum based on given type.

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static VarEnum GetVarEnum(
    Type type
)
Visual Basic (Declaration)
Public Shared Function GetVarEnum ( _
    type As Type _
) As VarEnum
Visual C++
public:
static VarEnum GetVarEnum(
    Type^ type
)

Parameters

type
Type: System..::.Type

See Also

COMUtilities Class
PerpetuumSoft.Framework.Utilities Namespace


GraphicsUtilites Class

[image]

.NET ModelKit Suite ClassReference
GraphicsUtilites Class
Members See Also Send Feedback
Utilities for Graphics operations.

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public sealed class GraphicsUtilites
Visual Basic (Declaration)
Public NotInheritable Class GraphicsUtilites
Visual C++
public ref class GraphicsUtilites sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Utilities..::.GraphicsUtilites

See Also

GraphicsUtilites Members
PerpetuumSoft.Framework.Utilities Namespace


GraphicsUtilites Members

[image] [image]

.NET ModelKit Suite ClassReference
GraphicsUtilites Members
GraphicsUtilites Class Methods See Also Send Feedback

The GraphicsUtilites type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MeasureText | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MiddleColor | Calculates a middle color between two given colors.
ScaleColor | Scales brightness of the color using the given coefficient.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GraphicsUtilites Class
PerpetuumSoft.Framework.Utilities Namespace


GraphicsUtilites Methods

[image] [image]

.NET ModelKit Suite ClassReference
GraphicsUtilites Methods
GraphicsUtilites Class See Also Send Feedback

The GraphicsUtilites type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MeasureText | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MiddleColor | Calculates a middle color between two given colors.
ScaleColor | Scales brightness of the color using the given coefficient.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GraphicsUtilites Class
PerpetuumSoft.Framework.Utilities Namespace


MeasureText Method

[image] [image]

.NET ModelKit Suite ClassReference
GraphicsUtilites..::.MeasureText Method
GraphicsUtilites Class See Also Send Feedback

Overload List

Name | Description
MeasureText(String, Font) | Measures the specified string that is drawn with the specified Font object.
MeasureText(Graphics, String, Font) | Returns the size of the text if drawn with the given font for given Graphics.

See Also

GraphicsUtilites Class
GraphicsUtilites Members
PerpetuumSoft.Framework.Utilities Namespace


MeasureText Method (String, Font)

[image]

.NET ModelKit Suite ClassReference
GraphicsUtilites..::.MeasureText Method (String, Font)
GraphicsUtilites Class See Also Send Feedback
Measures the specified string that is drawn with the specified Font object.

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Vector MeasureText(
    string text,
    Font font
)
Visual Basic (Declaration)
Public Shared Function MeasureText ( _
    text As String, _
    font As Font _
) As Vector
Visual C++
public:
static Vector MeasureText(
    String^ text,
    Font^ font
)

Parameters

text
Type: System..::.String
font
Type: System.Drawing..::.Font

See Also

GraphicsUtilites Class
MeasureText Overload
PerpetuumSoft.Framework.Utilities Namespace


MeasureText Method (Graphics, String, Font)

[image]

.NET ModelKit Suite ClassReference
GraphicsUtilites..::.MeasureText Method (Graphics, String, Font)
GraphicsUtilites Class See Also Send Feedback
Returns the size of the text if drawn with the given font for given Graphics.

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Vector MeasureText(
    Graphics g,
    string text,
    Font font
)
Visual Basic (Declaration)
Public Shared Function MeasureText ( _
    g As Graphics, _
    text As String, _
    font As Font _
) As Vector
Visual C++
public:
static Vector MeasureText(
    Graphics^ g,
    String^ text,
    Font^ font
)

Parameters

g
Type: System.Drawing..::.Graphics
text
Type: System..::.String
font
Type: System.Drawing..::.Font

See Also

GraphicsUtilites Class
MeasureText Overload
PerpetuumSoft.Framework.Utilities Namespace


MiddleColor Method

[image]

.NET ModelKit Suite ClassReference
GraphicsUtilites..::.MiddleColor Method
GraphicsUtilites Class See Also Send Feedback
Calculates a middle color between two given colors.

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Color MiddleColor(
    Color color1,
    Color color2
)
Visual Basic (Declaration)
Public Shared Function MiddleColor ( _
    color1 As Color, _
    color2 As Color _
) As Color
Visual C++
public:
static Color MiddleColor(
    Color color1,
    Color color2
)

Parameters

color1
Type: System.Drawing..::.Color
color2
Type: System.Drawing..::.Color

See Also

GraphicsUtilites Class
PerpetuumSoft.Framework.Utilities Namespace


ScaleColor Method

[image]

.NET ModelKit Suite ClassReference
GraphicsUtilites..::.ScaleColor Method
GraphicsUtilites Class See Also Send Feedback
Scales brightness of the color using the given coefficient.

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Color ScaleColor(
    Color sourceColor,
    double scale
)
Visual Basic (Declaration)
Public Shared Function ScaleColor ( _
    sourceColor As Color, _
    scale As Double _
) As Color
Visual C++
public:
static Color ScaleColor(
    Color sourceColor,
    double scale
)

Parameters

sourceColor
Type: System.Drawing..::.Color
scale
Type: System..::.Double

See Also

GraphicsUtilites Class
PerpetuumSoft.Framework.Utilities Namespace


RegistryAccessor Class

[image]

.NET ModelKit Suite ClassReference
RegistryAccessor Class
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Framework.Utilities.RegistryAccessor]

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class RegistryAccessor
Visual Basic (Declaration)
Public Class RegistryAccessor
Visual C++
public ref class RegistryAccessor

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Utilities..::.RegistryAccessor

See Also

RegistryAccessor Members
PerpetuumSoft.Framework.Utilities Namespace


RegistryAccessor Members

[image] [image]

.NET ModelKit Suite ClassReference
RegistryAccessor Members
RegistryAccessor Class Methods See Also Send Feedback

The RegistryAccessor type exposes the following members.

Methods

Name | Description
DeleteValue |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetKeys | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetValue |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RegistryAccessor Class
PerpetuumSoft.Framework.Utilities Namespace


RegistryAccessor Methods

[image] [image]

.NET ModelKit Suite ClassReference
RegistryAccessor Methods
RegistryAccessor Class See Also Send Feedback

The RegistryAccessor type exposes the following members.

Methods

Name | Description
DeleteValue |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetKeys | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetValue |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RegistryAccessor Class
PerpetuumSoft.Framework.Utilities Namespace


DeleteValue Method

[image]

.NET ModelKit Suite ClassReference
RegistryAccessor..::.DeleteValue Method
RegistryAccessor Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Utilities.RegistryAccessor.DeleteValue(System.String)]

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static void DeleteValue(
    string keyName
)
Visual Basic (Declaration)
Public Shared Sub DeleteValue ( _
    keyName As String _
)
Visual C++
public:
static void DeleteValue(
    String^ keyName
)

Parameters

keyName
Type: System..::.String

See Also

RegistryAccessor Class
PerpetuumSoft.Framework.Utilities Namespace


GetKeys Method

[image] [image]

.NET ModelKit Suite ClassReference
RegistryAccessor..::.GetKeys Method
RegistryAccessor Class See Also Send Feedback

Overload List

Name | Description
GetKeys()()() |
GetKeys(String) |

See Also

RegistryAccessor Class
RegistryAccessor Members
PerpetuumSoft.Framework.Utilities Namespace


GetKeys Method

[image]

.NET ModelKit Suite ClassReference
RegistryAccessor..::.GetKeys Method
RegistryAccessor Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Utilities.RegistryAccessor.GetKeys]

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static string[] GetKeys()
Visual Basic (Declaration)
Public Shared Function GetKeys As String()
Visual C++
public:
static array<String^>^ GetKeys()

See Also

RegistryAccessor Class
GetKeys Overload
PerpetuumSoft.Framework.Utilities Namespace


GetKeys Method (String)

[image]

.NET ModelKit Suite ClassReference
RegistryAccessor..::.GetKeys Method (String)
RegistryAccessor Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Utilities.RegistryAccessor.GetKeys(System.String)]

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static string[] GetKeys(
    string pathName
)
Visual Basic (Declaration)
Public Shared Function GetKeys ( _
    pathName As String _
) As String()
Visual C++
public:
static array<String^>^ GetKeys(
    String^ pathName
)

Parameters

pathName
Type: System..::.String

See Also

RegistryAccessor Class
GetKeys Overload
PerpetuumSoft.Framework.Utilities Namespace


GetValue Method

[image]

.NET ModelKit Suite ClassReference
RegistryAccessor..::.GetValue Method
RegistryAccessor Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Utilities.RegistryAccessor.GetValue(System.String)]

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static Object GetValue(
    string keyName
)
Visual Basic (Declaration)
Public Shared Function GetValue ( _
    keyName As String _
) As Object
Visual C++
public:
static Object^ GetValue(
    String^ keyName
)

Parameters

keyName
Type: System..::.String

See Also

RegistryAccessor Class
PerpetuumSoft.Framework.Utilities Namespace


SetValue Method

[image]

.NET ModelKit Suite ClassReference
RegistryAccessor..::.SetValue Method
RegistryAccessor Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Framework.Utilities.RegistryAccessor.SetValue(System.String,System.Object)]

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static void SetValue(
    string keyName,
    Object value
)
Visual Basic (Declaration)
Public Shared Sub SetValue ( _
    keyName As String, _
    value As Object _
)
Visual C++
public:
static void SetValue(
    String^ keyName,
    Object^ value
)

Parameters

keyName
Type: System..::.String
value
Type: System..::.Object

See Also

RegistryAccessor Class
PerpetuumSoft.Framework.Utilities Namespace


UserSettingsManager Class

[image]

.NET ModelKit Suite ClassReference
UserSettingsManager Class
Members See Also Send Feedback
The type for worknig with form settings

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static class UserSettingsManager
Visual Basic (Declaration)
Public NotInheritable Class UserSettingsManager
Visual C++
public ref class UserSettingsManager abstract sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Utilities..::.UserSettingsManager

See Also

UserSettingsManager Members
PerpetuumSoft.Framework.Utilities Namespace


UserSettingsManager Members

[image] [image]

.NET ModelKit Suite ClassReference
UserSettingsManager Members
UserSettingsManager Class Methods See Also Send Feedback

The UserSettingsManager type exposes the following members.

Methods

Name | Description
LoadParam | Loads parameter from register.
LoadSettings | Loads form settings
SaveParam | Saves the specified parameter in the register.
SaveSettings | Saves form settings

See Also

UserSettingsManager Class
PerpetuumSoft.Framework.Utilities Namespace


UserSettingsManager Methods

[image] [image]

.NET ModelKit Suite ClassReference
UserSettingsManager Methods
UserSettingsManager Class See Also Send Feedback

The UserSettingsManager type exposes the following members.

Methods

Name | Description
LoadParam | Loads parameter from register.
LoadSettings | Loads form settings
SaveParam | Saves the specified parameter in the register.
SaveSettings | Saves form settings

See Also

UserSettingsManager Class
PerpetuumSoft.Framework.Utilities Namespace


LoadParam Method

[image]

.NET ModelKit Suite ClassReference
UserSettingsManager..::.LoadParam Method
UserSettingsManager Class See Also Send Feedback
Loads parameter from register.

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static int LoadParam(
    Form sourceForm
)
Visual Basic (Declaration)
Public Shared Function LoadParam ( _
    sourceForm As Form _
) As Integer
Visual C++
public:
static int LoadParam(
    Form^ sourceForm
)

Parameters

sourceForm
Type: System.Windows.Forms..::.Form

See Also

UserSettingsManager Class
PerpetuumSoft.Framework.Utilities Namespace


LoadSettings Method

[image]

.NET ModelKit Suite ClassReference
UserSettingsManager..::.LoadSettings Method
UserSettingsManager Class See Also Send Feedback
Loads form settings

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static void LoadSettings(
    Form sourceForm
)
Visual Basic (Declaration)
Public Shared Sub LoadSettings ( _
    sourceForm As Form _
)
Visual C++
public:
static void LoadSettings(
    Form^ sourceForm
)

Parameters

sourceForm
Type: System.Windows.Forms..::.Form

See Also

UserSettingsManager Class
PerpetuumSoft.Framework.Utilities Namespace


SaveParam Method

[image]

.NET ModelKit Suite ClassReference
UserSettingsManager..::.SaveParam Method
UserSettingsManager Class See Also Send Feedback
Saves the specified parameter in the register.

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static void SaveParam(
    Form sourceForm,
    int param
)
Visual Basic (Declaration)
Public Shared Sub SaveParam ( _
    sourceForm As Form, _
    param As Integer _
)
Visual C++
public:
static void SaveParam(
    Form^ sourceForm,
    int param
)

Parameters

sourceForm
Type: System.Windows.Forms..::.Form
param
Type: System..::.Int32

See Also

UserSettingsManager Class
PerpetuumSoft.Framework.Utilities Namespace


SaveSettings Method

[image]

.NET ModelKit Suite ClassReference
UserSettingsManager..::.SaveSettings Method
UserSettingsManager Class See Also Send Feedback
Saves form settings

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static void SaveSettings(
    Form sourceForm
)
Visual Basic (Declaration)
Public Shared Sub SaveSettings ( _
    sourceForm As Form _
)
Visual C++
public:
static void SaveSettings(
    Form^ sourceForm
)

Parameters

sourceForm
Type: System.Windows.Forms..::.Form

See Also

UserSettingsManager Class
PerpetuumSoft.Framework.Utilities Namespace


WinAPIUtilities Class

[image]

.NET ModelKit Suite ClassReference
WinAPIUtilities Class
Members See Also Send Feedback
API wrappers.

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public sealed class WinAPIUtilities
Visual Basic (Declaration)
Public NotInheritable Class WinAPIUtilities
Visual C++
public ref class WinAPIUtilities sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework.Utilities..::.WinAPIUtilities

See Also

WinAPIUtilities Members
PerpetuumSoft.Framework.Utilities Namespace


WinAPIUtilities Members

[image] [image]

.NET ModelKit Suite ClassReference
WinAPIUtilities Members
WinAPIUtilities Class Methods See Also Send Feedback

The WinAPIUtilities type exposes the following members.

Methods

Name | Description
BrowseLocalNetwork | Gets names of the hosts in the local network.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetComputerName | Gets name of the current host.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WinAPIUtilities Class
PerpetuumSoft.Framework.Utilities Namespace


WinAPIUtilities Methods

[image] [image]

.NET ModelKit Suite ClassReference
WinAPIUtilities Methods
WinAPIUtilities Class See Also Send Feedback

The WinAPIUtilities type exposes the following members.

Methods

Name | Description
BrowseLocalNetwork | Gets names of the hosts in the local network.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetComputerName | Gets name of the current host.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WinAPIUtilities Class
PerpetuumSoft.Framework.Utilities Namespace


BrowseLocalNetwork Method

[image]

.NET ModelKit Suite ClassReference
WinAPIUtilities..::.BrowseLocalNetwork Method
WinAPIUtilities Class See Also Send Feedback
Gets names of the hosts in the local network.

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static string[] BrowseLocalNetwork()
Visual Basic (Declaration)
Public Shared Function BrowseLocalNetwork As String()
Visual C++
public:
static array<String^>^ BrowseLocalNetwork()

See Also

WinAPIUtilities Class
PerpetuumSoft.Framework.Utilities Namespace


GetComputerName Method

[image]

.NET ModelKit Suite ClassReference
WinAPIUtilities..::.GetComputerName Method
WinAPIUtilities Class See Also Send Feedback
Gets name of the current host.

Namespace: PerpetuumSoft.Framework.Utilities
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public static string GetComputerName()
Visual Basic (Declaration)
Public Shared Function GetComputerName As String
Visual C++
public:
static String^ GetComputerName()

See Also

WinAPIUtilities Class
PerpetuumSoft.Framework.Utilities Namespace


PerpetuumSoft.Framework.Windows.Forms Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Framework.Windows.Forms Namespace
Send Feedback
The PerpetuumSoft.Framework.Windows.Forms namespace contains classes for creation of custom user interface in Windows Forms applications.

Classes

Class | Description
AdvancedLabel | Advanced label control.


AdvancedLabel Class

[image]

.NET ModelKit Suite ClassReference
AdvancedLabel Class
Members See Also Send Feedback
Advanced label control.

Namespace: PerpetuumSoft.Framework.Windows.Forms
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public class AdvancedLabel : Label
Visual Basic (Declaration)
Public Class AdvancedLabel _
    Inherits Label
Visual C++
public ref class AdvancedLabel : public Label

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.Label
PerpetuumSoft.Framework.Windows.Forms..::.AdvancedLabel

See Also

AdvancedLabel Members
PerpetuumSoft.Framework.Windows.Forms Namespace


AdvancedLabel Members

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedLabel Members
AdvancedLabel Class Constructors Methods Properties Events See Also Send Feedback

The AdvancedLabel type exposes the following members.

Constructors

Name | Description
AdvancedLabel | Initializes a new instance of the AdvancedLabel class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CalcImageRenderBounds | Determines the size and location of an image drawn within the Label control based on the alignment of the control. (Inherited from Label.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Label.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawImage | Draws an Image within the specified bounds. (Inherited from Label.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | (Inherited from Label.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Label.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | (Inherited from Label.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Label.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | (Inherited from Label.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | (Inherited from Label.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from Label.)
OnPaint | (Inherited from Label.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Label.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Overrides standard OnResize logic. (Overrides Control..::.OnResize(EventArgs).)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Label.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextAlignChanged | Raises the TextAlignChanged event. (Inherited from Label.)
OnTextChanged | (Inherited from Label.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Label.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from Label.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Sets the specified bounds of the label. (Inherited from Label.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Label.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Label.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the Label, denoting that the Label text extends beyond the specified length of the Label. (Inherited from Label.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents. (Inherited from Label.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the image rendered on the background of the control. (Inherited from Label.)
BackgroundImageLayout | This property is not relevant for this class. (Inherited from Label.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
BorderStyle | Gets or sets the border style for the control. (Inherited from Label.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlMinWidth | Gets or sets minimum width of the linked control.
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Label.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from Label.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Label.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Label.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FlatStyle | Gets or sets the flat style appearance of the label control. (Inherited from Label.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
Image | Gets or sets the image that is displayed on a Label. (Inherited from Label.)
ImageAlign | Gets or sets the alignment of an image that is displayed in the control. (Inherited from Label.)
ImageIndex | Gets or sets the index value of the image displayed on the Label. (Inherited from Label.)
ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from Label.)
ImageList | Gets or sets the ImageList that contains the images to display in the Label control. (Inherited from Label.)
ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. (Inherited from Label.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LinkControl | Gets or sets control linked to the lable.
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PreferredHeight | Gets the preferred height of the control. (Inherited from Label.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
PreferredWidth | Gets the preferred width of the control. (Inherited from Label.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
RenderTransparent | Obsolete. Indicates whether the container control background is rendered on the Label. (Inherited from Label.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can tab to the Label. (Inherited from Label.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Label.)
TextAlign | Gets or sets the alignment of text in the label. (Inherited from Label.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseCompatibleTextRendering | Gets or sets a value that specifies whether text rendering should be compatible with previous releases of Windows Forms. (Inherited from Label.)
UseMnemonic | Gets or sets a value indicating whether the control interprets an ampersand character (&) in the control's Text property to be an access key prefix character. (Inherited from Label.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from Label.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the BackgroundImage property changes. (Inherited from Label.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Label.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property changes. (Inherited from Label.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when the user presses a key while the label has focus. (Inherited from Label.)
KeyPress | Occurs when the user presses a key while the label has focus. (Inherited from Label.)
KeyUp | Occurs when the user releases a key while the label has focus. (Inherited from Label.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property changes. (Inherited from Label.)
TextAlignChanged | Occurs when the value of the TextAlign property has changed. (Inherited from Label.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

AdvancedLabel Class
PerpetuumSoft.Framework.Windows.Forms Namespace


AdvancedLabel Constructor

[image]

.NET ModelKit Suite ClassReference
AdvancedLabel Constructor
AdvancedLabel Class See Also Send Feedback
Initializes a new instance of the AdvancedLabel class.

Namespace: PerpetuumSoft.Framework.Windows.Forms
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public AdvancedLabel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AdvancedLabel()

See Also

AdvancedLabel Class
PerpetuumSoft.Framework.Windows.Forms Namespace


AdvancedLabel Methods

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedLabel Methods
AdvancedLabel Class See Also Send Feedback

The AdvancedLabel type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CalcImageRenderBounds | Determines the size and location of an image drawn within the Label control based on the alignment of the control. (Inherited from Label.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | (Inherited from Label.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawImage | Draws an Image within the specified bounds. (Inherited from Label.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | (Inherited from Label.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl()()() method. (Inherited from Control.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Label.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | (Inherited from Label.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Label.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | Raises the Layout event. (Inherited from Control.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | (Inherited from Label.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | (Inherited from Label.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from Label.)
OnPaint | (Inherited from Label.)
OnPaintBackground | Paints the background of the control. (Inherited from Control.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from Label.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Overrides standard OnResize logic. (Overrides Control..::.OnResize(EventArgs).)
OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Label.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextAlignChanged | Raises the TextAlignChanged event. (Inherited from Label.)
OnTextChanged | (Inherited from Label.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from Label.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Control.)
ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from Label.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Sets the specified bounds of the label. (Inherited from Label.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Label.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
WndProc | (Inherited from Label.)

See Also

AdvancedLabel Class
PerpetuumSoft.Framework.Windows.Forms Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedLabel..::.AccessibilityNotifyClients Method
AdvancedLabel Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

AdvancedLabel Class
AdvancedLabel Members
PerpetuumSoft.Framework.Windows.Forms Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedLabel..::.BeginInvoke Method
AdvancedLabel Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

AdvancedLabel Class
AdvancedLabel Members
PerpetuumSoft.Framework.Windows.Forms Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedLabel..::.Dispose Method
AdvancedLabel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Label and optionally releases the managed resources. (Inherited from Label.)

See Also

AdvancedLabel Class
AdvancedLabel Members
PerpetuumSoft.Framework.Windows.Forms Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedLabel..::.GetChildAtPoint Method
AdvancedLabel Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

AdvancedLabel Class
AdvancedLabel Members
PerpetuumSoft.Framework.Windows.Forms Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedLabel..::.Invalidate Method
AdvancedLabel Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

AdvancedLabel Class
AdvancedLabel Members
PerpetuumSoft.Framework.Windows.Forms Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedLabel..::.Invoke Method
AdvancedLabel Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

AdvancedLabel Class
AdvancedLabel Members
PerpetuumSoft.Framework.Windows.Forms Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedLabel..::.MemberwiseClone Method
AdvancedLabel Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

AdvancedLabel Class
AdvancedLabel Members
PerpetuumSoft.Framework.Windows.Forms Namespace


OnResize Method

[image]

.NET ModelKit Suite ClassReference
AdvancedLabel..::.OnResize Method
AdvancedLabel Class See Also Send Feedback
Overrides standard OnResize logic.

Namespace: PerpetuumSoft.Framework.Windows.Forms
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnResize(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnResize ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnResize(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

AdvancedLabel Class
PerpetuumSoft.Framework.Windows.Forms Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedLabel..::.PerformLayout Method
AdvancedLabel Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

AdvancedLabel Class
AdvancedLabel Members
PerpetuumSoft.Framework.Windows.Forms Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedLabel..::.ResumeLayout Method
AdvancedLabel Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

AdvancedLabel Class
AdvancedLabel Members
PerpetuumSoft.Framework.Windows.Forms Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedLabel..::.RtlTranslateAlignment Method
AdvancedLabel Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

AdvancedLabel Class
AdvancedLabel Members
PerpetuumSoft.Framework.Windows.Forms Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedLabel..::.Scale Method
AdvancedLabel Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

AdvancedLabel Class
AdvancedLabel Members
PerpetuumSoft.Framework.Windows.Forms Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedLabel..::.Select Method
AdvancedLabel Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)

See Also

AdvancedLabel Class
AdvancedLabel Members
PerpetuumSoft.Framework.Windows.Forms Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedLabel..::.SetBounds Method
AdvancedLabel Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

AdvancedLabel Class
AdvancedLabel Members
PerpetuumSoft.Framework.Windows.Forms Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedLabel..::.UpdateBounds Method
AdvancedLabel Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

AdvancedLabel Class
AdvancedLabel Members
PerpetuumSoft.Framework.Windows.Forms Namespace


AdvancedLabel Properties

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedLabel Properties
AdvancedLabel Class See Also Send Feedback

The AdvancedLabel type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoEllipsis | Gets or sets a value indicating whether the ellipsis character (...) appears at the right edge of the Label, denoting that the Label text extends beyond the specified length of the Label. (Inherited from Label.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents. (Inherited from Label.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the image rendered on the background of the control. (Inherited from Label.)
BackgroundImageLayout | This property is not relevant for this class. (Inherited from Label.)
BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
BorderStyle | Gets or sets the border style for the control. (Inherited from Label.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlMinWidth | Gets or sets minimum width of the linked control.
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Label.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by this control. (Inherited from Label.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Label.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Label.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FlatStyle | Gets or sets the flat style appearance of the label control. (Inherited from Label.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
Image | Gets or sets the image that is displayed on a Label. (Inherited from Label.)
ImageAlign | Gets or sets the alignment of an image that is displayed in the control. (Inherited from Label.)
ImageIndex | Gets or sets the index value of the image displayed on the Label. (Inherited from Label.)
ImageKey | Gets or sets the key accessor for the image in the ImageList. (Inherited from Label.)
ImageList | Gets or sets the ImageList that contains the images to display in the Label control. (Inherited from Label.)
ImeMode | Gets or sets the Input Method Editor (IME) mode supported by this control. (Inherited from Label.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
LinkControl | Gets or sets control linked to the lable.
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
PreferredHeight | Gets the preferred height of the control. (Inherited from Label.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
PreferredWidth | Gets the preferred width of the control. (Inherited from Label.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
RenderTransparent | Obsolete. Indicates whether the container control background is rendered on the Label. (Inherited from Label.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can tab to the Label. (Inherited from Label.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Label.)
TextAlign | Gets or sets the alignment of text in the label. (Inherited from Label.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseCompatibleTextRendering | Gets or sets a value that specifies whether text rendering should be compatible with previous releases of Windows Forms. (Inherited from Label.)
UseMnemonic | Gets or sets a value indicating whether the control interprets an ampersand character (&) in the control's Text property to be an access key prefix character. (Inherited from Label.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

AdvancedLabel Class
PerpetuumSoft.Framework.Windows.Forms Namespace


ControlMinWidth Property

[image]

.NET ModelKit Suite ClassReference
AdvancedLabel..::.ControlMinWidth Property
AdvancedLabel Class See Also Send Feedback
Gets or sets minimum width of the linked control.

Namespace: PerpetuumSoft.Framework.Windows.Forms
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public int ControlMinWidth { get; set; }
Visual Basic (Declaration)
Public Property ControlMinWidth As Integer
Visual C++
public:
property int ControlMinWidth {
    int get ();
    void set (int value);
}

See Also

AdvancedLabel Class
PerpetuumSoft.Framework.Windows.Forms Namespace


LinkControl Property

[image]

.NET ModelKit Suite ClassReference
AdvancedLabel..::.LinkControl Property
AdvancedLabel Class See Also Send Feedback
Gets or sets control linked to the lable.

Namespace: PerpetuumSoft.Framework.Windows.Forms
Assembly: PerpetuumSoft.Framework (in PerpetuumSoft.Framework.dll) Version: 3.9.0.1

Syntax

C#
public Control LinkControl { get; set; }
Visual Basic (Declaration)
Public Property LinkControl As Control
Visual C++
public:
property Control^ LinkControl {
    Control^ get ();
    void set (Control^ value);
}

See Also

AdvancedLabel Class
PerpetuumSoft.Framework.Windows.Forms Namespace


AdvancedLabel Events

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedLabel Events
AdvancedLabel Class See Also Send Feedback

The AdvancedLabel type exposes the following members.

Events

Name | Description
AutoSizeChanged | Occurs when the value of the AutoSize property changes. (Inherited from Label.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the BackgroundImage property changes. (Inherited from Label.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Label.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property changes. (Inherited from Label.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when the user presses a key while the label has focus. (Inherited from Label.)
KeyPress | Occurs when the user presses a key while the label has focus. (Inherited from Label.)
KeyUp | Occurs when the user releases a key while the label has focus. (Inherited from Label.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property changes. (Inherited from Label.)
TextAlignChanged | Occurs when the value of the TextAlign property has changed. (Inherited from Label.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

AdvancedLabel Class
PerpetuumSoft.Framework.Windows.Forms Namespace


PerpetuumSoft.Instrumentation.Model Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Instrumentation.Model Namespace
Send Feedback
The PerpetuumSoft.Instrumentation.Model namespace contains classes of the Instrument object model.

Classes

Class | Description
Arc | Represents the arc.
ArcBase | Represents the base class for arc elements.
Bevel | Basic class for all types represetning bevels.
ButtonBase |
CalculableAttribute | Marks the properties that can be bound to an expression.
Circle | Represents the circle.
CircularNotches | Represents the notches located circular.
CircularShape | Represents a figure that is set by the center and size.
Composite | Base class for all composite elements in the Instrumentation Model Kit.
ControlPointAttribute | Marks property that should be control point.
CustomBevel | Represents bevel with wide opportunities in customization.
CustomLabels | Represents Text labels.
DockableTrajectoryBase | Defines base class for Trajectory.
Element | Base class for all elements in the Instrumentation Model Kit library.
ElementCollection | Represents the collection of the elements.
Ellipse | Represents the ellipse.
EllipseBevel | Represents the ellipse bevel.
Frame | Represents the frame.
Gear | Represents Gear.
Group | Represents the container for the group objects.
Guide | Represents the linear trajectory.
Highlight | Represents Highlight for dial instruments.
ImageCollection | Represents the collection of the images.
ImageWrap | Represents the wrap for the image.
Instrument | Represents the instrument.
Joint | Represents the Joint.
Label | Represents the Label.
LevelBase | Reperesents base class for level elements.
Line | Represents the Line.
LinearLevel | Represents Linear level.
LinearNotches | Represents Linear notches.
LineElement | Represents the basic class for line elements.
Needle | Represents the Needle.
NeedlePoint | Represents the needle point.
NeedlePointCollection | Represents collection of NeedlePoint objects.
NumericLabels | Obsolete. Represents the Numeric labels.
Picture | Represents the Picture.
PictureSet | Represents the set of pictures.
Pie | Represents the Pie.
Polygon | Represents the Poligon.
PushButton |
RangedLevel | Represents level with ranged width.
Rectangle | Represents the Rectangle.
RectangleElement | Represents a rectangle element.
RingSector | Represents the Ring sector.
RoundedRectangle | Represents rectangle with rounded angles.
Scale | Represents the Scale.
ScaleElement | Represents basic class for scale elements.
ScaleLabels | Represents Scale labels.
ScaleLabelsBase | Represents the base class for scale labels.
ScaleMarks | Represents marks on the scale.
ScaleMarksBase | Represents the base class for scale marks.
ScaleTitle | Represents title of a scale.
SimpleRectangleElement | Represents the simple rectangle.
Slider | Represents the Slider.
SliderBase | Represents the basic class for slider elements.
Spring | Represents the Spring.
StandardBevel | Represents simple rectangular bevel.
Star | Represents the Star.
Tank | Determines the tank element, visualizes value in the form of level.
TextItem | Represents the text using in text labels elements.
TextItemCollection | Represents the collection of TextItem elements.
TextLabels | Obsolete. Represent Text labels.
Ticks | Represents the Ticks.
TruncatedEllipse | Represents the TruncaredEllipse.
ValuePresenterScaleElement | Represents base class for scale elements, representing data value.

Structures

Structure | Description
Element..::.CategoryType | Describes a registered type element.
SmartValue | Represents data type with the ability to assign absolute values, relative values in percentage and a specific Auto value, specifying the need to automatically calculate value, subject to the use context.

Interfaces

Interface | Description
IDataContext | Defines methods for data provision.
IDataReceiver | Defines a method for data reciving.
ILinkedSupported | Defines a method to bind the element to trajectory.
IScale | Main interface for scale.
IScaleElement | Represents the element that can be located on the scale.
ISlider | Main interface for slider.
ITrajectory | Represents the trajectory.

Delegates

Delegate | Description
ElementCollection..::.CollectionChanged | Represents the method that will handle the ElementAdded and ElementRemoved.
ImageCollection..::.CollectionChanged | Represents the method that will handle the ImageAdded and ImageRemoved.
NeedlePointCollection..::.CollectionChangedEventHandler | Represents method which calls after collection changing.
TextItemCollection..::.CollectionChangedEventHandler | Represents method which was call after TextItemCollection change.

Enumerations

Enumeration | Description
Align | Enumerates alignment types.
AlignmentMode | Enumerates alignment mode.
BevelStyle | Defines the kind of bevel.
CapStyle | Enumerates cap styles.
Effect3D | Enumerates 3d effects.
EllipseBevelDrawingStyle | Enumerates the ellipse bevel drawing effect types.
GuideDirection | Enumerates the trajectory directions type.
JointDocking | Enumerates joint docking types.
LabelPosition | Enumerates the label position types.
NotchesStyle | Represents notches styles.
PointMode | Represents the control point mode.
RectangleBevelDrawingStyle | Enumerates the rectangular bevel drawing effect types.
ScaleDocking | Enumerates the scale docking type.
ScaleKind | Enumerates scale types.
ShowMode | Showing modes for Needle element.
SmartValueKind | Enumerates the smart value type.
SubTicksPosition | Represents SubTicks positions.
TextRotationMode | Represents the text rotation mode.


Align Enumeration

[image]

.NET ModelKit Suite ClassReference
Align Enumeration
See Also Send Feedback
Enumerates alignment types.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public enum Align
Visual Basic (Declaration)
Public Enumeration Align
Visual C++
public enum class Align

Members

Member name | Description
Center | Specifies alignment of the instrument's center.
Near | Specifies the near alignment.
Far | Specifies the far alignment.

See Also

PerpetuumSoft.Instrumentation.Model Namespace


AlignmentMode Enumeration

[image]

.NET ModelKit Suite ClassReference
AlignmentMode Enumeration
See Also Send Feedback
Enumerates alignment mode.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public enum AlignmentMode
Visual Basic (Declaration)
Public Enumeration AlignmentMode
Visual C++
public enum class AlignmentMode

Members

Member name | Description
Far | Specifies the center alignment.
Near | Specifies the near alignment.
Center | Specifies the far alignment.

See Also

PerpetuumSoft.Instrumentation.Model Namespace


Arc Class

[image]

.NET ModelKit Suite ClassReference
Arc Class
Members See Also Send Feedback
Represents the arc.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Arc : ArcBase
Visual Basic (Declaration)
Public Class Arc _
    Inherits ArcBase
Visual C++
public ref class Arc : public ArcBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement
PerpetuumSoft.Instrumentation.Model..::.RectangleElement
PerpetuumSoft.Instrumentation.Model..::.ArcBase
PerpetuumSoft.Instrumentation.Model..::.Arc

See Also

Arc Members
PerpetuumSoft.Instrumentation.Model Namespace


Arc Members

[image] [image]

.NET ModelKit Suite ClassReference
Arc Members
Arc Class Constructors Methods Properties Events See Also Send Feedback

The Arc type exposes the following members.

Constructors

Name | Description
Arc | Initializes a new instance of the Arc class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Draws element's contents, drawing is determined in the derived classes. (Inherited from ArcBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides ArcBase..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartAngle | Gets or sets angle in degrees measured clockwise from the x-axis to the starting point of the arc. (Inherited from ArcBase.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SweepAngle | Gets or sets angle in degrees measured clockwise from the startAngle parameter to ending point of the arc. (Inherited from ArcBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Arc Class
PerpetuumSoft.Instrumentation.Model Namespace


Arc Constructor

[image]

.NET ModelKit Suite ClassReference
Arc Constructor
Arc Class See Also Send Feedback
Initializes a new instance of the Arc class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Arc()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Arc()

See Also

Arc Class
PerpetuumSoft.Instrumentation.Model Namespace


Arc Methods

[image] [image]

.NET ModelKit Suite ClassReference
Arc Methods
Arc Class See Also Send Feedback

The Arc type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Draws element's contents, drawing is determined in the derived classes. (Inherited from ArcBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides ArcBase..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Arc Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Arc..::.Dispose Method
Arc Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from RectangleElement.)

See Also

Arc Class
Arc Members
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
Arc..::.GetHitTest Method
Arc Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Arc Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Arc..::.GetStyle Method
Arc Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Arc Class
Arc Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Arc..::.Invalidate Method
Arc Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Arc Class
Arc Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Arc..::.OnPaint Method
Arc Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from RectangleElement.)

See Also

Arc Class
Arc Members
PerpetuumSoft.Instrumentation.Model Namespace


Arc Properties

[image] [image]

.NET ModelKit Suite ClassReference
Arc Properties
Arc Class See Also Send Feedback

The Arc type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartAngle | Gets or sets angle in degrees measured clockwise from the x-axis to the starting point of the arc. (Inherited from ArcBase.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SweepAngle | Gets or sets angle in degrees measured clockwise from the startAngle parameter to ending point of the arc. (Inherited from ArcBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Arc Class
PerpetuumSoft.Instrumentation.Model Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
Arc..::.Fill Property
Arc Class See Also Send Feedback
Gets or sets the Fill object that is used to paint over.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

Arc Class
PerpetuumSoft.Instrumentation.Model Namespace


Arc Events

[image] [image]

.NET ModelKit Suite ClassReference
Arc Events
Arc Class See Also Send Feedback

The Arc type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Arc Class
PerpetuumSoft.Instrumentation.Model Namespace


ArcBase Class

[image]

.NET ModelKit Suite ClassReference
ArcBase Class
Members See Also Send Feedback
Represents the base class for arc elements.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract class ArcBase : RectangleElement
Visual Basic (Declaration)
Public MustInherit Class ArcBase _
    Inherits RectangleElement
Visual C++
public ref class ArcBase abstract : public RectangleElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement
PerpetuumSoft.Instrumentation.Model..::.RectangleElement
PerpetuumSoft.Instrumentation.Model..::.ArcBase
PerpetuumSoft.Instrumentation.Model..::.Arc
PerpetuumSoft.Instrumentation.Model..::.Pie
PerpetuumSoft.Instrumentation.Model..::.RingSector
PerpetuumSoft.Instrumentation.Model..::.TruncatedEllipse

See Also

ArcBase Members
PerpetuumSoft.Instrumentation.Model Namespace


ArcBase Members

[image] [image]

.NET ModelKit Suite ClassReference
ArcBase Members
ArcBase Class Constructors Methods Properties Events See Also Send Feedback

The ArcBase type exposes the following members.

Constructors

Name | Description
ArcBase | Initializes a new instance of the ArcBase class

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Draws element's contents, drawing is determined in the derived classes. (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides RectangleElement..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartAngle | Gets or sets angle in degrees measured clockwise from the x-axis to the starting point of the arc.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SweepAngle | Gets or sets angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ArcBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ArcBase Constructor

[image]

.NET ModelKit Suite ClassReference
ArcBase Constructor
ArcBase Class See Also Send Feedback
Initializes a new instance of the ArcBase class

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected ArcBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ArcBase()

See Also

ArcBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ArcBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
ArcBase Methods
ArcBase Class See Also Send Feedback

The ArcBase type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Draws element's contents, drawing is determined in the derived classes. (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides RectangleElement..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ArcBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ArcBase..::.Dispose Method
ArcBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from RectangleElement.)

See Also

ArcBase Class
ArcBase Members
PerpetuumSoft.Instrumentation.Model Namespace


DrawContent Method

[image]

.NET ModelKit Suite ClassReference
ArcBase..::.DrawContent Method
ArcBase Class See Also Send Feedback
Draws element's contents, drawing is determined in the derived classes.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void DrawContent(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Protected Overrides Sub DrawContent ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
protected:
virtual void DrawContent(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

ArcBase Class
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
ArcBase..::.GetHitTest Method
ArcBase Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

ArcBase Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
ArcBase..::.GetStyle Method
ArcBase Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

ArcBase Class
ArcBase Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ArcBase..::.Invalidate Method
ArcBase Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

ArcBase Class
ArcBase Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
ArcBase..::.OnPaint Method
ArcBase Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from RectangleElement.)

See Also

ArcBase Class
ArcBase Members
PerpetuumSoft.Instrumentation.Model Namespace


ArcBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
ArcBase Properties
ArcBase Class See Also Send Feedback

The ArcBase type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartAngle | Gets or sets angle in degrees measured clockwise from the x-axis to the starting point of the arc.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SweepAngle | Gets or sets angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

ArcBase Class
PerpetuumSoft.Instrumentation.Model Namespace


StartAngle Property

[image]

.NET ModelKit Suite ClassReference
ArcBase..::.StartAngle Property
ArcBase Class See Also Send Feedback
Gets or sets angle in degrees measured clockwise from the x-axis to the starting point of the arc.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double StartAngle { get; set; }
Visual Basic (Declaration)
Public Property StartAngle As Double
Visual C++
public:
property double StartAngle {
    double get ();
    void set (double value);
}

See Also

ArcBase Class
PerpetuumSoft.Instrumentation.Model Namespace


SweepAngle Property

[image]

.NET ModelKit Suite ClassReference
ArcBase..::.SweepAngle Property
ArcBase Class See Also Send Feedback
Gets or sets angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double SweepAngle { get; set; }
Visual Basic (Declaration)
Public Property SweepAngle As Double
Visual C++
public:
property double SweepAngle {
    double get ();
    void set (double value);
}

See Also

ArcBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ArcBase Events

[image] [image]

.NET ModelKit Suite ClassReference
ArcBase Events
ArcBase Class See Also Send Feedback

The ArcBase type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ArcBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Bevel Class

[image]

.NET ModelKit Suite ClassReference
Bevel Class
Members See Also Send Feedback
Basic class for all types represetning bevels.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract class Bevel : Atom
Visual Basic (Declaration)
Public MustInherit Class Bevel _
    Inherits Atom
Visual C++
public ref class Bevel abstract : public Atom

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework..::.Atom
PerpetuumSoft.Instrumentation.Model..::.Bevel
PerpetuumSoft.Instrumentation.Model..::.CustomBevel
PerpetuumSoft.Instrumentation.Model..::.EllipseBevel
PerpetuumSoft.Instrumentation.Model..::.StandardBevel

See Also

Bevel Members
PerpetuumSoft.Instrumentation.Model Namespace


Bevel Members

[image] [image]

.NET ModelKit Suite ClassReference
Bevel Members
Bevel Class Constructors Methods Properties See Also Send Feedback

The Bevel type exposes the following members.

Constructors

Name | Description
Bevel | Initializes a new instance of the Bevel class

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Returns the copy of this object. (Inherited from Atom.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDockingBounds | Gets a rectangle bounding the area around which a bevel is drawn.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Paint | Paints a bevel.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)

See Also

Bevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Bevel Constructor

[image]

.NET ModelKit Suite ClassReference
Bevel Constructor
Bevel Class See Also Send Feedback
Initializes a new instance of the Bevel class

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected Bevel()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
Bevel()

See Also

Bevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Bevel Methods

[image] [image]

.NET ModelKit Suite ClassReference
Bevel Methods
Bevel Class See Also Send Feedback

The Bevel type exposes the following members.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Returns the copy of this object. (Inherited from Atom.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDockingBounds | Gets a rectangle bounding the area around which a bevel is drawn.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Paint | Paints a bevel.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Bevel Class
PerpetuumSoft.Instrumentation.Model Namespace


GetDockingBounds Method

[image]

.NET ModelKit Suite ClassReference
Bevel..::.GetDockingBounds Method
Bevel Class See Also Send Feedback
Gets a rectangle bounding the area around which a bevel is drawn.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract VectorRectangle GetDockingBounds(
    VectorRectangle rectangle
)
Visual Basic (Declaration)
Public MustOverride Function GetDockingBounds ( _
    rectangle As VectorRectangle _
) As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetDockingBounds(
    VectorRectangle rectangle
) abstract

Parameters

rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

Bevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Paint Method

[image]

.NET ModelKit Suite ClassReference
Bevel..::.Paint Method
Bevel Class See Also Send Feedback
Paints a bevel.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract void Paint(
    VectorRectangle rectangle,
    GraphicStream stream
)
Visual Basic (Declaration)
Public MustOverride Sub Paint ( _
    rectangle As VectorRectangle, _
    stream As GraphicStream _
)
Visual C++
public:
virtual void Paint(
    VectorRectangle rectangle,
    GraphicStream^ stream
) abstract

Parameters

rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
stream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream

See Also

Bevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Bevel Properties

[image] [image]

.NET ModelKit Suite ClassReference
Bevel Properties
Bevel Class See Also Send Feedback

The Bevel type exposes the following members.

Properties

Name | Description
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)

See Also

Bevel Class
PerpetuumSoft.Instrumentation.Model Namespace


BevelStyle Enumeration

[image]

.NET ModelKit Suite ClassReference
BevelStyle Enumeration
See Also Send Feedback
Defines the kind of bevel.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public enum BevelStyle
Visual Basic (Declaration)
Public Enumeration BevelStyle
Visual C++
public enum class BevelStyle

Members

Member name | Description
None | No bevel.
Flat | Flat Flat-style bevel appearance.
Single | Single width black bevel.
Double | Double width black bevel.
Raised | 3D Raised style bevel.
Lowered | 3D Lowered style bevel.
DoubleRaised | 3D Raised style bevel with double width.
DoubleLowered | 3D Lowered style bevel with double width.
FrameRaised | Raised Frame.
FrameLowered | Lowered Frame.

See Also

PerpetuumSoft.Instrumentation.Model Namespace


ButtonBase Class

[image]

.NET ModelKit Suite ClassReference
ButtonBase Class
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Instrumentation.Model.ButtonBase]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract class ButtonBase : Composite
Visual Basic (Declaration)
Public MustInherit Class ButtonBase _
    Inherits Composite
Visual C++
public ref class ButtonBase abstract : public Composite

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.Composite
PerpetuumSoft.Instrumentation.Model..::.ButtonBase
PerpetuumSoft.Instrumentation.Model..::.PushButton

See Also

ButtonBase Members
PerpetuumSoft.Instrumentation.Model Namespace


ButtonBase Members

[image] [image]

.NET ModelKit Suite ClassReference
ButtonBase Members
ButtonBase Class Constructors Methods Properties Events See Also Send Feedback

The ButtonBase type exposes the following members.

Constructors

Name | Description
ButtonBase | Initializes a new instance of the ButtonBase class

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | (Overrides Element..::.GetObject(String).)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
SetHot |
SetOn |
SetPressed |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Hot |
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
On |
Parent | Implements Parent. (Inherited from Element.)
Pressed |
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ButtonBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ButtonBase Constructor

[image]

.NET ModelKit Suite ClassReference
ButtonBase Constructor
ButtonBase Class See Also Send Feedback
Initializes a new instance of the ButtonBase class

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected ButtonBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ButtonBase()

See Also

ButtonBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ButtonBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
ButtonBase Methods
ButtonBase Class See Also Send Feedback

The ButtonBase type exposes the following members.

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | (Overrides Element..::.GetObject(String).)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
SetHot |
SetOn |
SetPressed |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ButtonBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ButtonBase..::.Dispose Method
ButtonBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from Composite.)

See Also

ButtonBase Class
ButtonBase Members
PerpetuumSoft.Instrumentation.Model Namespace


GetObject Method

[image]

.NET ModelKit Suite ClassReference
ButtonBase..::.GetObject Method
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.ButtonBase.GetObject(System.String)]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Object GetObject(
    string name
)
Visual Basic (Declaration)
Public Overrides Function GetObject ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetObject(
    String^ name
) override

Parameters

name
Type: System..::.String

See Also

ButtonBase Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
ButtonBase..::.GetStyle Method
ButtonBase Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

ButtonBase Class
ButtonBase Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ButtonBase..::.Invalidate Method
ButtonBase Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

ButtonBase Class
ButtonBase Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
ButtonBase..::.OnPaint Method
ButtonBase Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Inherited from Composite.)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

ButtonBase Class
ButtonBase Members
PerpetuumSoft.Instrumentation.Model Namespace


SetHot Method

[image]

.NET ModelKit Suite ClassReference
ButtonBase..::.SetHot Method
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.ButtonBase.SetHot(System.Boolean)]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected void SetHot(
    bool value
)
Visual Basic (Declaration)
Protected Sub SetHot ( _
    value As Boolean _
)
Visual C++
protected:
void SetHot(
    bool value
)

Parameters

value
Type: System..::.Boolean

See Also

ButtonBase Class
PerpetuumSoft.Instrumentation.Model Namespace


SetOn Method

[image]

.NET ModelKit Suite ClassReference
ButtonBase..::.SetOn Method
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.ButtonBase.SetOn(System.Boolean)]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected void SetOn(
    bool value
)
Visual Basic (Declaration)
Protected Sub SetOn ( _
    value As Boolean _
)
Visual C++
protected:
void SetOn(
    bool value
)

Parameters

value
Type: System..::.Boolean

See Also

ButtonBase Class
PerpetuumSoft.Instrumentation.Model Namespace


SetPressed Method

[image]

.NET ModelKit Suite ClassReference
ButtonBase..::.SetPressed Method
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.ButtonBase.SetPressed(System.Boolean)]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected void SetPressed(
    bool value
)
Visual Basic (Declaration)
Protected Sub SetPressed ( _
    value As Boolean _
)
Visual C++
protected:
void SetPressed(
    bool value
)

Parameters

value
Type: System..::.Boolean

See Also

ButtonBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ButtonBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
ButtonBase Properties
ButtonBase Class See Also Send Feedback

The ButtonBase type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Hot |
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
On |
Parent | Implements Parent. (Inherited from Element.)
Pressed |
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

ButtonBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Hot Property

[image]

.NET ModelKit Suite ClassReference
ButtonBase..::.Hot Property
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Instrumentation.Model.ButtonBase.Hot]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Hot { get; }
Visual Basic (Declaration)
Public ReadOnly Property Hot As Boolean
Visual C++
public:
property bool Hot {
    bool get ();
}

See Also

ButtonBase Class
PerpetuumSoft.Instrumentation.Model Namespace


On Property

[image]

.NET ModelKit Suite ClassReference
ButtonBase..::.On Property
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Instrumentation.Model.ButtonBase.On]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool On { get; }
Visual Basic (Declaration)
Public ReadOnly Property On As Boolean
Visual C++
public:
property bool On {
    bool get ();
}

See Also

ButtonBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Pressed Property

[image]

.NET ModelKit Suite ClassReference
ButtonBase..::.Pressed Property
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Instrumentation.Model.ButtonBase.Pressed]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Pressed { get; }
Visual Basic (Declaration)
Public ReadOnly Property Pressed As Boolean
Visual C++
public:
property bool Pressed {
    bool get ();
}

See Also

ButtonBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ButtonBase Events

[image] [image]

.NET ModelKit Suite ClassReference
ButtonBase Events
ButtonBase Class See Also Send Feedback

The ButtonBase type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ButtonBase Class
PerpetuumSoft.Instrumentation.Model Namespace


CalculableAttribute Class

[image]

.NET ModelKit Suite ClassReference
CalculableAttribute Class
Members See Also Send Feedback
Marks the properties that can be bound to an expression.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public sealed class CalculableAttribute : Attribute
Visual Basic (Declaration)
Public NotInheritable Class CalculableAttribute _
    Inherits Attribute
Visual C++
public ref class CalculableAttribute sealed : public Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PerpetuumSoft.Instrumentation.Model..::.CalculableAttribute

See Also

CalculableAttribute Members
PerpetuumSoft.Instrumentation.Model Namespace


CalculableAttribute Members

[image] [image]

.NET ModelKit Suite ClassReference
CalculableAttribute Members
CalculableAttribute Class Constructors Methods Properties See Also Send Feedback

The CalculableAttribute type exposes the following members.

Constructors

Name | Description
CalculableAttribute | Overloaded.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | Overridden. See Match(Object). (Overrides Attribute..::.Match(Object).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsCalculable | Gets whether the property supports expression.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Yes | Gets predefined instance of CalculableAttribute where IsCalculable property set to true.

See Also

CalculableAttribute Class
PerpetuumSoft.Instrumentation.Model Namespace


CalculableAttribute Constructor

[image] [image]

.NET ModelKit Suite ClassReference
CalculableAttribute Constructor
CalculableAttribute Class See Also Send Feedback

Overload List

Name | Description
CalculableAttribute()()() | Initializes a new instance of the CalculableAttribute class.
CalculableAttribute(Boolean) | Initializes a new instance of the CalculableAttribute class with the specified bindability attribute.

See Also

CalculableAttribute Class
CalculableAttribute Members
PerpetuumSoft.Instrumentation.Model Namespace


CalculableAttribute Constructor

[image]

.NET ModelKit Suite ClassReference
CalculableAttribute Constructor
CalculableAttribute Class See Also Send Feedback
Initializes a new instance of the CalculableAttribute class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public CalculableAttribute()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CalculableAttribute()

See Also

CalculableAttribute Class
CalculableAttribute Overload
PerpetuumSoft.Instrumentation.Model Namespace


CalculableAttribute Constructor (Boolean)

[image]

.NET ModelKit Suite ClassReference
CalculableAttribute Constructor (Boolean)
CalculableAttribute Class See Also Send Feedback
Initializes a new instance of the CalculableAttribute class with the specified bindability attribute.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public CalculableAttribute(
    bool isCalculable
)
Visual Basic (Declaration)
Public Sub New ( _
    isCalculable As Boolean _
)
Visual C++
public:
CalculableAttribute(
    bool isCalculable
)

Parameters

isCalculable
Type: System..::.Boolean

See Also

CalculableAttribute Class
CalculableAttribute Overload
PerpetuumSoft.Instrumentation.Model Namespace


CalculableAttribute Methods

[image] [image]

.NET ModelKit Suite ClassReference
CalculableAttribute Methods
CalculableAttribute Class See Also Send Feedback

The CalculableAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | Overridden. See Match(Object). (Overrides Attribute..::.Match(Object).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CalculableAttribute Class
PerpetuumSoft.Instrumentation.Model Namespace


Match Method

[image]

.NET ModelKit Suite ClassReference
CalculableAttribute..::.Match Method
CalculableAttribute Class See Also Send Feedback
Overridden. See Match(Object).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool Match(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Match ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Match(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

CalculableAttribute Class
PerpetuumSoft.Instrumentation.Model Namespace


CalculableAttribute Properties

[image] [image]

.NET ModelKit Suite ClassReference
CalculableAttribute Properties
CalculableAttribute Class See Also Send Feedback

The CalculableAttribute type exposes the following members.

Properties

Name | Description
IsCalculable | Gets whether the property supports expression.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Yes | Gets predefined instance of CalculableAttribute where IsCalculable property set to true.

See Also

CalculableAttribute Class
PerpetuumSoft.Instrumentation.Model Namespace


IsCalculable Property

[image]

.NET ModelKit Suite ClassReference
CalculableAttribute..::.IsCalculable Property
CalculableAttribute Class See Also Send Feedback
Gets whether the property supports expression.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool IsCalculable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCalculable As Boolean
Visual C++
public:
property bool IsCalculable {
    bool get ();
}

See Also

CalculableAttribute Class
PerpetuumSoft.Instrumentation.Model Namespace


Yes Property

[image]

.NET ModelKit Suite ClassReference
CalculableAttribute..::.Yes Property
CalculableAttribute Class See Also Send Feedback
Gets predefined instance of CalculableAttribute where IsCalculable property set to true.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static CalculableAttribute Yes { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Yes As CalculableAttribute
Visual C++
public:
static property CalculableAttribute^ Yes {
    CalculableAttribute^ get ();
}

See Also

CalculableAttribute Class
PerpetuumSoft.Instrumentation.Model Namespace


CapStyle Enumeration

[image]

.NET ModelKit Suite ClassReference
CapStyle Enumeration
See Also Send Feedback
Enumerates cap styles.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public enum CapStyle
Visual Basic (Declaration)
Public Enumeration CapStyle
Visual C++
public enum class CapStyle

Members

Member name | Description
Flat | Specifies the flat cap style.
Rounded | Specifies the rounded cap style.

See Also

PerpetuumSoft.Instrumentation.Model Namespace


Circle Class

[image]

.NET ModelKit Suite ClassReference
Circle Class
Members See Also Send Feedback
Represents the circle.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Circle : Element
Visual Basic (Declaration)
Public Class Circle _
    Inherits Element
Visual C++
public ref class Circle : public Element

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.Circle

See Also

Circle Members
PerpetuumSoft.Instrumentation.Model Namespace


Circle Members

[image] [image]

.NET ModelKit Suite ClassReference
Circle Members
Circle Class Constructors Methods Properties Events See Also Send Feedback

The Circle type exposes the following members.

Constructors

Name | Description
Circle | Initializes a new instance of the Circle class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets center of the circle.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Radius | Gets or sets radius of the circle.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Circle Class
PerpetuumSoft.Instrumentation.Model Namespace


Circle Constructor

[image]

.NET ModelKit Suite ClassReference
Circle Constructor
Circle Class See Also Send Feedback
Initializes a new instance of the Circle class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Circle()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Circle()

See Also

Circle Class
PerpetuumSoft.Instrumentation.Model Namespace


Circle Methods

[image] [image]

.NET ModelKit Suite ClassReference
Circle Methods
Circle Class See Also Send Feedback

The Circle type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Circle Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Circle..::.Dispose Method
Circle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

Circle Class
Circle Members
PerpetuumSoft.Instrumentation.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
Circle..::.GetBoundedBox Method
Circle Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

Circle Class
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
Circle..::.GetHitTest Method
Circle Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Circle Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Circle..::.GetStyle Method
Circle Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Circle Class
Circle Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Circle..::.Invalidate Method
Circle Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Circle Class
Circle Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Circle..::.OnPaint Method
Circle Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

Circle Class
Circle Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
Circle..::.OnPaint Method (PaintArguments, Fill, Stroke)
Circle Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Circle Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


Circle Properties

[image] [image]

.NET ModelKit Suite ClassReference
Circle Properties
Circle Class See Also Send Feedback

The Circle type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets center of the circle.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Radius | Gets or sets radius of the circle.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Circle Class
PerpetuumSoft.Instrumentation.Model Namespace


Center Property

[image]

.NET ModelKit Suite ClassReference
Circle..::.Center Property
Circle Class See Also Send Feedback
Gets or sets center of the circle.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Vector Center { get; set; }
Visual Basic (Declaration)
Public Property Center As Vector
Visual C++
public:
property Vector Center {
    Vector get ();
    void set (Vector value);
}

See Also

Circle Class
PerpetuumSoft.Instrumentation.Model Namespace


Radius Property

[image]

.NET ModelKit Suite ClassReference
Circle..::.Radius Property
Circle Class See Also Send Feedback
Gets or sets radius of the circle.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Radius { get; set; }
Visual Basic (Declaration)
Public Property Radius As Double
Visual C++
public:
property double Radius {
    double get ();
    void set (double value);
}

See Also

Circle Class
PerpetuumSoft.Instrumentation.Model Namespace


Circle Events

[image] [image]

.NET ModelKit Suite ClassReference
Circle Events
Circle Class See Also Send Feedback

The Circle type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Circle Class
PerpetuumSoft.Instrumentation.Model Namespace


CircularNotches Class

[image]

.NET ModelKit Suite ClassReference
CircularNotches Class
Members See Also Send Feedback
Represents the notches located circular.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class CircularNotches : CircularShape
Visual Basic (Declaration)
Public Class CircularNotches _
    Inherits CircularShape
Visual C++
public ref class CircularNotches : public CircularShape

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.CircularShape
PerpetuumSoft.Instrumentation.Model..::.CircularNotches

See Also

CircularNotches Members
PerpetuumSoft.Instrumentation.Model Namespace


CircularNotches Members

[image] [image]

.NET ModelKit Suite ClassReference
CircularNotches Members
CircularNotches Class Constructors Methods Properties Events See Also Send Feedback

The CircularNotches type exposes the following members.

Constructors

Name | Description
CircularNotches | Initializes a new instance of the CircularNotches class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Gets or sets the angle by clockwize of the shape. (Inherited from CircularShape.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the shape. (Inherited from CircularShape.)
Count | Gets or sets the count of the notches.
DarkColor | Gets or sets the dark color of the notches.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Length | Gets or sets the length of the notches.
LightColor | Gets or sets the light color of the notches.
Name | Gets or sets the element's name. (Inherited from Element.)
NotchesStyle | Gets or sets the style of the notches.
Parent | Implements Parent. (Inherited from Element.)
Radius | Gets or sets the radius of the shape. (Inherited from CircularShape.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets the Stroke object that is used to trace.
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)
Width |

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

CircularNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


CircularNotches Constructor

[image]

.NET ModelKit Suite ClassReference
CircularNotches Constructor
CircularNotches Class See Also Send Feedback
Initializes a new instance of the CircularNotches class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public CircularNotches()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CircularNotches()

See Also

CircularNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


CircularNotches Methods

[image] [image]

.NET ModelKit Suite ClassReference
CircularNotches Methods
CircularNotches Class See Also Send Feedback

The CircularNotches type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CircularNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
CircularNotches..::.Dispose Method
CircularNotches Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

CircularNotches Class
CircularNotches Members
PerpetuumSoft.Instrumentation.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
CircularNotches..::.GetBoundedBox Method
CircularNotches Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

CircularNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
CircularNotches..::.GetHitTest Method
CircularNotches Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

CircularNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
CircularNotches..::.GetStyle Method
CircularNotches Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

CircularNotches Class
CircularNotches Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
CircularNotches..::.Invalidate Method
CircularNotches Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

CircularNotches Class
CircularNotches Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
CircularNotches..::.OnPaint Method
CircularNotches Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Overrides Element..::.OnPaint(PaintArguments).)
OnPaint(PaintArguments, Stroke, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke).
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

CircularNotches Class
CircularNotches Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments)

[image]

.NET ModelKit Suite ClassReference
CircularNotches..::.OnPaint Method (PaintArguments)
CircularNotches Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

CircularNotches Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments, Stroke, Stroke)

[image]

.NET ModelKit Suite ClassReference
CircularNotches..::.OnPaint Method (PaintArguments, Stroke, Stroke)
CircularNotches Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public virtual void OnPaint(
    PaintArguments args,
    Stroke lightStroke,
    Stroke darkStroke
)
Visual Basic (Declaration)
Public Overridable Sub OnPaint ( _
    args As PaintArguments, _
    lightStroke As Stroke, _
    darkStroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Stroke^ lightStroke,
    Stroke^ darkStroke
)

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
lightStroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
darkStroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

CircularNotches Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


CircularNotches Properties

[image] [image]

.NET ModelKit Suite ClassReference
CircularNotches Properties
CircularNotches Class See Also Send Feedback

The CircularNotches type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Gets or sets the angle by clockwize of the shape. (Inherited from CircularShape.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the shape. (Inherited from CircularShape.)
Count | Gets or sets the count of the notches.
DarkColor | Gets or sets the dark color of the notches.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Length | Gets or sets the length of the notches.
LightColor | Gets or sets the light color of the notches.
Name | Gets or sets the element's name. (Inherited from Element.)
NotchesStyle | Gets or sets the style of the notches.
Parent | Implements Parent. (Inherited from Element.)
Radius | Gets or sets the radius of the shape. (Inherited from CircularShape.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets the Stroke object that is used to trace.
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)
Width |

See Also

CircularNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


Count Property

[image]

.NET ModelKit Suite ClassReference
CircularNotches..::.Count Property
CircularNotches Class See Also Send Feedback
Gets or sets the count of the notches.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int Count { get; set; }
Visual Basic (Declaration)
Public Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
    void set (int value);
}

See Also

CircularNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


DarkColor Property

[image]

.NET ModelKit Suite ClassReference
CircularNotches..::.DarkColor Property
CircularNotches Class See Also Send Feedback
Gets or sets the dark color of the notches.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Color DarkColor { get; set; }
Visual Basic (Declaration)
Public Property DarkColor As Color
Visual C++
public:
property Color DarkColor {
    Color get ();
    void set (Color value);
}

See Also

CircularNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
CircularNotches..::.Fill Property
CircularNotches Class See Also Send Feedback
Gets or sets the Fill object that is used to paint over.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

CircularNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


Length Property

[image]

.NET ModelKit Suite ClassReference
CircularNotches..::.Length Property
CircularNotches Class See Also Send Feedback
Gets or sets the length of the notches.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Length { get; set; }
Visual Basic (Declaration)
Public Property Length As Double
Visual C++
public:
property double Length {
    double get ();
    void set (double value);
}

See Also

CircularNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


LightColor Property

[image]

.NET ModelKit Suite ClassReference
CircularNotches..::.LightColor Property
CircularNotches Class See Also Send Feedback
Gets or sets the light color of the notches.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Color LightColor { get; set; }
Visual Basic (Declaration)
Public Property LightColor As Color
Visual C++
public:
property Color LightColor {
    Color get ();
    void set (Color value);
}

See Also

CircularNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


NotchesStyle Property

[image]

.NET ModelKit Suite ClassReference
CircularNotches..::.NotchesStyle Property
CircularNotches Class See Also Send Feedback
Gets or sets the style of the notches.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public NotchesStyle NotchesStyle { get; set; }
Visual Basic (Declaration)
Public Property NotchesStyle As NotchesStyle
Visual C++
public:
property NotchesStyle NotchesStyle {
    NotchesStyle get ();
    void set (NotchesStyle value);
}

See Also

CircularNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


Stroke Property

[image]

.NET ModelKit Suite ClassReference
CircularNotches..::.Stroke Property
CircularNotches Class See Also Send Feedback
Gets or sets the Stroke object that is used to trace.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Stroke Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Stroke
Visual C++
public:
property Stroke^ Stroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

CircularNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
CircularNotches..::.Width Property
CircularNotches Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Instrumentation.Model.CircularNotches.Width]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

CircularNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


CircularNotches Events

[image] [image]

.NET ModelKit Suite ClassReference
CircularNotches Events
CircularNotches Class See Also Send Feedback

The CircularNotches type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

CircularNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


CircularShape Class

[image]

.NET ModelKit Suite ClassReference
CircularShape Class
Members See Also Send Feedback
Represents a figure that is set by the center and size.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract class CircularShape : Element
Visual Basic (Declaration)
Public MustInherit Class CircularShape _
    Inherits Element
Visual C++
public ref class CircularShape abstract : public Element

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.CircularShape
PerpetuumSoft.Instrumentation.Model..::.CircularNotches
PerpetuumSoft.Instrumentation.Model..::.Gear
PerpetuumSoft.Instrumentation.Model..::.Highlight
PerpetuumSoft.Instrumentation.Model..::.Polygon

See Also

CircularShape Members
PerpetuumSoft.Instrumentation.Model Namespace


CircularShape Members

[image] [image]

.NET ModelKit Suite ClassReference
CircularShape Members
CircularShape Class Constructors Methods Properties Events See Also Send Feedback

The CircularShape type exposes the following members.

Constructors

Name | Description
CircularShape | Initializes a new instance of the CircularShape class

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Gets or sets the angle by clockwize of the shape.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the shape.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Radius | Gets or sets the radius of the shape.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

CircularShape Class
PerpetuumSoft.Instrumentation.Model Namespace


CircularShape Constructor

[image]

.NET ModelKit Suite ClassReference
CircularShape Constructor
CircularShape Class See Also Send Feedback
Initializes a new instance of the CircularShape class

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected CircularShape()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
CircularShape()

See Also

CircularShape Class
PerpetuumSoft.Instrumentation.Model Namespace


CircularShape Methods

[image] [image]

.NET ModelKit Suite ClassReference
CircularShape Methods
CircularShape Class See Also Send Feedback

The CircularShape type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CircularShape Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
CircularShape..::.Dispose Method
CircularShape Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

CircularShape Class
CircularShape Members
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
CircularShape..::.GetStyle Method
CircularShape Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

CircularShape Class
CircularShape Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
CircularShape..::.Invalidate Method
CircularShape Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

CircularShape Class
CircularShape Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
CircularShape..::.OnPaint Method
CircularShape Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

CircularShape Class
CircularShape Members
PerpetuumSoft.Instrumentation.Model Namespace


CircularShape Properties

[image] [image]

.NET ModelKit Suite ClassReference
CircularShape Properties
CircularShape Class See Also Send Feedback

The CircularShape type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Gets or sets the angle by clockwize of the shape.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the shape.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Radius | Gets or sets the radius of the shape.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

CircularShape Class
PerpetuumSoft.Instrumentation.Model Namespace


Angle Property

[image]

.NET ModelKit Suite ClassReference
CircularShape..::.Angle Property
CircularShape Class See Also Send Feedback
Gets or sets the angle by clockwize of the shape.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

See Also

CircularShape Class
PerpetuumSoft.Instrumentation.Model Namespace


Center Property

[image]

.NET ModelKit Suite ClassReference
CircularShape..::.Center Property
CircularShape Class See Also Send Feedback
Gets or sets the center of the shape.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Vector Center { get; set; }
Visual Basic (Declaration)
Public Property Center As Vector
Visual C++
public:
property Vector Center {
    Vector get ();
    void set (Vector value);
}

See Also

CircularShape Class
PerpetuumSoft.Instrumentation.Model Namespace


Radius Property

[image]

.NET ModelKit Suite ClassReference
CircularShape..::.Radius Property
CircularShape Class See Also Send Feedback
Gets or sets the radius of the shape.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Radius { get; set; }
Visual Basic (Declaration)
Public Property Radius As Double
Visual C++
public:
property double Radius {
    double get ();
    void set (double value);
}

See Also

CircularShape Class
PerpetuumSoft.Instrumentation.Model Namespace


CircularShape Events

[image] [image]

.NET ModelKit Suite ClassReference
CircularShape Events
CircularShape Class See Also Send Feedback

The CircularShape type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

CircularShape Class
PerpetuumSoft.Instrumentation.Model Namespace


Composite Class

[image]

.NET ModelKit Suite ClassReference
Composite Class
Members See Also Send Feedback
Base class for all composite elements in the Instrumentation Model Kit.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract class Composite : Element,
    ICompositeElement, IElement
Visual Basic (Declaration)
Public MustInherit Class Composite _
    Inherits Element _
    Implements ICompositeElement, IElement
Visual C++
public ref class Composite abstract : public Element,
    ICompositeElement, IElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.Composite
PerpetuumSoft.Charts..::.ChartComposite
PerpetuumSoft.Charts..::.RectangleComposite
PerpetuumSoft.Instrumentation.Model..::.ButtonBase
PerpetuumSoft.Instrumentation.Model..::.DockableTrajectoryBase
PerpetuumSoft.Instrumentation.Model..::.Group
PerpetuumSoft.Instrumentation.Model..::.Instrument
PerpetuumSoft.Instrumentation.Model..::.Scale
PerpetuumSoft.Instrumentation.Model..::.SliderBase

See Also

Composite Members
PerpetuumSoft.Instrumentation.Model Namespace


Composite Members

[image] [image]

.NET ModelKit Suite ClassReference
Composite Members
Composite Class Constructors Methods Properties Events See Also Send Feedback

The Composite type exposes the following members.

Constructors

Name | Description
Composite | Initializes a new instance of the Composite class.

Methods

Name | Description
BringToFront | Sends the elements to front.
Calculate | Overridden. See Calculate()()(). (Overrides Element..::.Calculate()()().)
CanMoveBack | Determines whether the elements can move to back.
CanMoveForward | Determines whether the elements can move to forward.
ChildElementAdded | This method is called when the child element is added.
ChildElementRemoved | This method is called when the child element is removed.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Overrides Element..::.GetByName(String).)
GetElementAt | Implements GetElementAt(Vector). (Overrides Element..::.GetElementAt(Vector).)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward.
MoveForward | Moves elements on the one position to forward.
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back.
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Elements | Implements Elements.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Composite Class
PerpetuumSoft.Instrumentation.Model Namespace


Composite Constructor

[image]

.NET ModelKit Suite ClassReference
Composite Constructor
Composite Class See Also Send Feedback
Initializes a new instance of the Composite class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Composite()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Composite()

See Also

Composite Class
PerpetuumSoft.Instrumentation.Model Namespace


Composite Methods

[image] [image]

.NET ModelKit Suite ClassReference
Composite Methods
Composite Class See Also Send Feedback

The Composite type exposes the following members.

Methods

Name | Description
BringToFront | Sends the elements to front.
Calculate | Overridden. See Calculate()()(). (Overrides Element..::.Calculate()()().)
CanMoveBack | Determines whether the elements can move to back.
CanMoveForward | Determines whether the elements can move to forward.
ChildElementAdded | This method is called when the child element is added.
ChildElementRemoved | This method is called when the child element is removed.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Overrides Element..::.GetByName(String).)
GetElementAt | Implements GetElementAt(Vector). (Overrides Element..::.GetElementAt(Vector).)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward.
MoveForward | Moves elements on the one position to forward.
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back.
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Composite Class
PerpetuumSoft.Instrumentation.Model Namespace


BringToFront Method

[image]

.NET ModelKit Suite ClassReference
Composite..::.BringToFront Method
Composite Class See Also Send Feedback
Sends the elements to front.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void BringToFront(
    ElementCollection elements
)
Visual Basic (Declaration)
Public Sub BringToFront ( _
    elements As ElementCollection _
)
Visual C++
public:
void BringToFront(
    ElementCollection^ elements
)

Parameters

elements
Type: PerpetuumSoft.Instrumentation.Model..::.ElementCollection

See Also

Composite Class
PerpetuumSoft.Instrumentation.Model Namespace


Calculate Method

[image]

.NET ModelKit Suite ClassReference
Composite..::.Calculate Method
Composite Class See Also Send Feedback
Overridden. See Calculate()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void Calculate()
Visual Basic (Declaration)
Protected Overrides Sub Calculate
Visual C++
protected:
virtual void Calculate() override

See Also

Composite Class
PerpetuumSoft.Instrumentation.Model Namespace


CanMoveBack Method

[image]

.NET ModelKit Suite ClassReference
Composite..::.CanMoveBack Method
Composite Class See Also Send Feedback
Determines whether the elements can move to back.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool CanMoveBack(
    ElementCollection elements
)
Visual Basic (Declaration)
Public Function CanMoveBack ( _
    elements As ElementCollection _
) As Boolean
Visual C++
public:
bool CanMoveBack(
    ElementCollection^ elements
)

Parameters

elements
Type: PerpetuumSoft.Instrumentation.Model..::.ElementCollection

See Also

Composite Class
PerpetuumSoft.Instrumentation.Model Namespace


CanMoveForward Method

[image]

.NET ModelKit Suite ClassReference
Composite..::.CanMoveForward Method
Composite Class See Also Send Feedback
Determines whether the elements can move to forward.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool CanMoveForward(
    ElementCollection elements
)
Visual Basic (Declaration)
Public Function CanMoveForward ( _
    elements As ElementCollection _
) As Boolean
Visual C++
public:
bool CanMoveForward(
    ElementCollection^ elements
)

Parameters

elements
Type: PerpetuumSoft.Instrumentation.Model..::.ElementCollection

See Also

Composite Class
PerpetuumSoft.Instrumentation.Model Namespace


ChildElementAdded Method

[image]

.NET ModelKit Suite ClassReference
Composite..::.ChildElementAdded Method
Composite Class See Also Send Feedback
This method is called when the child element is added.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void ChildElementAdded(
    Element element
)
Visual Basic (Declaration)
Protected Overridable Sub ChildElementAdded ( _
    element As Element _
)
Visual C++
protected:
virtual void ChildElementAdded(
    Element^ element
)

Parameters

element
Type: PerpetuumSoft.Instrumentation.Model..::.Element

See Also

Composite Class
PerpetuumSoft.Instrumentation.Model Namespace


ChildElementRemoved Method

[image]

.NET ModelKit Suite ClassReference
Composite..::.ChildElementRemoved Method
Composite Class See Also Send Feedback
This method is called when the child element is removed.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void ChildElementRemoved(
    Element element
)
Visual Basic (Declaration)
Protected Overridable Sub ChildElementRemoved ( _
    element As Element _
)
Visual C++
protected:
virtual void ChildElementRemoved(
    Element^ element
)

Parameters

element
Type: PerpetuumSoft.Instrumentation.Model..::.Element

See Also

Composite Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Composite..::.Dispose Method
Composite Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Overrides Element..::.Dispose(Boolean).)

See Also

Composite Class
Composite Members
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
Composite..::.Dispose Method (Boolean)
Composite Class See Also Send Feedback
Overridden. See Dispose(Boolean).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

Composite Class
Dispose Overload
PerpetuumSoft.Instrumentation.Model Namespace


GetByName Method

[image]

.NET ModelKit Suite ClassReference
Composite..::.GetByName Method
Composite Class See Also Send Feedback
Overridden. See GetByName(String).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Element GetByName(
    string name
)
Visual Basic (Declaration)
Public Overrides Function GetByName ( _
    name As String _
) As Element
Visual C++
public:
virtual Element^ GetByName(
    String^ name
) override

Parameters

name
Type: System..::.String

See Also

Composite Class
PerpetuumSoft.Instrumentation.Model Namespace


GetElementAt Method

[image]

.NET ModelKit Suite ClassReference
Composite..::.GetElementAt Method
Composite Class See Also Send Feedback
Implements GetElementAt(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override IElement GetElementAt(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetElementAt ( _
    point As Vector _
) As IElement
Visual C++
public:
virtual IElement^ GetElementAt(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

Implements

IElement..::.GetElementAt(Vector)
IElement..::.GetElementAt(Vector)

See Also

Composite Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Composite..::.GetStyle Method
Composite Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Composite Class
Composite Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Composite..::.Invalidate Method
Composite Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Composite Class
Composite Members
PerpetuumSoft.Instrumentation.Model Namespace


MoveBackward Method

[image]

.NET ModelKit Suite ClassReference
Composite..::.MoveBackward Method
Composite Class See Also Send Feedback
Moves the elements on the one position to backward.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void MoveBackward(
    ElementCollection elements
)
Visual Basic (Declaration)
Public Sub MoveBackward ( _
    elements As ElementCollection _
)
Visual C++
public:
void MoveBackward(
    ElementCollection^ elements
)

Parameters

elements
Type: PerpetuumSoft.Instrumentation.Model..::.ElementCollection

See Also

Composite Class
PerpetuumSoft.Instrumentation.Model Namespace


MoveForward Method

[image]

.NET ModelKit Suite ClassReference
Composite..::.MoveForward Method
Composite Class See Also Send Feedback
Moves elements on the one position to forward.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void MoveForward(
    ElementCollection elements
)
Visual Basic (Declaration)
Public Sub MoveForward ( _
    elements As ElementCollection _
)
Visual C++
public:
void MoveForward(
    ElementCollection^ elements
)

Parameters

elements
Type: PerpetuumSoft.Instrumentation.Model..::.ElementCollection

See Also

Composite Class
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Composite..::.OnPaint Method
Composite Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Overrides Element..::.OnPaint(PaintArguments).)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

Composite Class
Composite Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments)

[image]

.NET ModelKit Suite ClassReference
Composite..::.OnPaint Method (PaintArguments)
Composite Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

Composite Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


PutToBack Method

[image]

.NET ModelKit Suite ClassReference
Composite..::.PutToBack Method
Composite Class See Also Send Feedback
Sends the elements to back.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void PutToBack(
    ElementCollection elements
)
Visual Basic (Declaration)
Public Sub PutToBack ( _
    elements As ElementCollection _
)
Visual C++
public:
void PutToBack(
    ElementCollection^ elements
)

Parameters

elements
Type: PerpetuumSoft.Instrumentation.Model..::.ElementCollection

See Also

Composite Class
PerpetuumSoft.Instrumentation.Model Namespace


Composite Properties

[image] [image]

.NET ModelKit Suite ClassReference
Composite Properties
Composite Class See Also Send Feedback

The Composite type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Elements | Implements Elements.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Composite Class
PerpetuumSoft.Instrumentation.Model Namespace


Elements Property

[image]

.NET ModelKit Suite ClassReference
Composite..::.Elements Property
Composite Class See Also Send Feedback
Implements Elements.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ElementCollection Elements { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements As ElementCollection
Visual C++
public:
property ElementCollection^ Elements {
    ElementCollection^ get ();
}

See Also

Composite Class
PerpetuumSoft.Instrumentation.Model Namespace


Composite Events

[image] [image]

.NET ModelKit Suite ClassReference
Composite Events
Composite Class See Also Send Feedback

The Composite type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Composite Class
PerpetuumSoft.Instrumentation.Model Namespace


ControlPointAttribute Class

[image]

.NET ModelKit Suite ClassReference
ControlPointAttribute Class
Members See Also Send Feedback
Marks property that should be control point.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public sealed class ControlPointAttribute : Attribute
Visual Basic (Declaration)
Public NotInheritable Class ControlPointAttribute _
    Inherits Attribute
Visual C++
public ref class ControlPointAttribute sealed : public Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PerpetuumSoft.Instrumentation.Model..::.ControlPointAttribute

See Also

ControlPointAttribute Members
PerpetuumSoft.Instrumentation.Model Namespace


ControlPointAttribute Members

[image] [image]

.NET ModelKit Suite ClassReference
ControlPointAttribute Members
ControlPointAttribute Class Constructors Methods Properties See Also Send Feedback

The ControlPointAttribute type exposes the following members.

Constructors

Name | Description
ControlPointAttribute | Initializes a new instance of the ControlPointAttribute class with specific parameters. Parameters indicate point mode and whether the point will be used in move operations.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DependsOn | Gets or sets properties' names which depend on this control point.
PointMode | Gets PointMode that indicates point mode.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
UseInMoveOperation | Gets whether the point will be used in move operations.

See Also

ControlPointAttribute Class
PerpetuumSoft.Instrumentation.Model Namespace


ControlPointAttribute Constructor

[image]

.NET ModelKit Suite ClassReference
ControlPointAttribute Constructor
ControlPointAttribute Class See Also Send Feedback
Initializes a new instance of the ControlPointAttribute class with specific parameters. Parameters indicate point mode and whether the point will be used in move operations.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ControlPointAttribute(
    PointMode pointMode,
    bool useInMoveOperation
)
Visual Basic (Declaration)
Public Sub New ( _
    pointMode As PointMode, _
    useInMoveOperation As Boolean _
)
Visual C++
public:
ControlPointAttribute(
    PointMode pointMode,
    bool useInMoveOperation
)

Parameters

pointMode
Type: PerpetuumSoft.Instrumentation.Model..::.PointMode
useInMoveOperation
Type: System..::.Boolean

See Also

ControlPointAttribute Class
PerpetuumSoft.Instrumentation.Model Namespace


ControlPointAttribute Methods

[image] [image]

.NET ModelKit Suite ClassReference
ControlPointAttribute Methods
ControlPointAttribute Class See Also Send Feedback

The ControlPointAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ControlPointAttribute Class
PerpetuumSoft.Instrumentation.Model Namespace


ControlPointAttribute Properties

[image] [image]

.NET ModelKit Suite ClassReference
ControlPointAttribute Properties
ControlPointAttribute Class See Also Send Feedback

The ControlPointAttribute type exposes the following members.

Properties

Name | Description
DependsOn | Gets or sets properties' names which depend on this control point.
PointMode | Gets PointMode that indicates point mode.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
UseInMoveOperation | Gets whether the point will be used in move operations.

See Also

ControlPointAttribute Class
PerpetuumSoft.Instrumentation.Model Namespace


DependsOn Property

[image]

.NET ModelKit Suite ClassReference
ControlPointAttribute..::.DependsOn Property
ControlPointAttribute Class See Also Send Feedback
Gets or sets properties' names which depend on this control point.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string[] DependsOn { get; set; }
Visual Basic (Declaration)
Public Property DependsOn As String()
Visual C++
public:
property array<String^>^ DependsOn {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

ControlPointAttribute Class
PerpetuumSoft.Instrumentation.Model Namespace


PointMode Property

[image]

.NET ModelKit Suite ClassReference
ControlPointAttribute..::.PointMode Property
ControlPointAttribute Class See Also Send Feedback
Gets PointMode that indicates point mode.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public PointMode PointMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PointMode As PointMode
Visual C++
public:
property PointMode PointMode {
    PointMode get ();
}

See Also

ControlPointAttribute Class
PerpetuumSoft.Instrumentation.Model Namespace


UseInMoveOperation Property

[image]

.NET ModelKit Suite ClassReference
ControlPointAttribute..::.UseInMoveOperation Property
ControlPointAttribute Class See Also Send Feedback
Gets whether the point will be used in move operations.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool UseInMoveOperation { get; }
Visual Basic (Declaration)
Public ReadOnly Property UseInMoveOperation As Boolean
Visual C++
public:
property bool UseInMoveOperation {
    bool get ();
}

See Also

ControlPointAttribute Class
PerpetuumSoft.Instrumentation.Model Namespace


CustomBevel Class

[image]

.NET ModelKit Suite ClassReference
CustomBevel Class
Members See Also Send Feedback
Represents bevel with wide opportunities in customization.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class CustomBevel : Bevel
Visual Basic (Declaration)
Public Class CustomBevel _
    Inherits Bevel
Visual C++
public ref class CustomBevel : public Bevel

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework..::.Atom
PerpetuumSoft.Instrumentation.Model..::.Bevel
PerpetuumSoft.Instrumentation.Model..::.CustomBevel

See Also

CustomBevel Members
PerpetuumSoft.Instrumentation.Model Namespace


CustomBevel Members

[image] [image]

.NET ModelKit Suite ClassReference
CustomBevel Members
CustomBevel Class Constructors Methods Properties See Also Send Feedback

The CustomBevel type exposes the following members.

Constructors

Name | Description
CustomBevel | Initializes a new instance of the CustomBevel class.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Implements Clone()()(). (Overrides Atom..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDockingBounds | Overridden. See GetDockingBounds(VectorRectangle). (Overrides Bevel..::.GetDockingBounds(VectorRectangle).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Paint | Overridden. See Paint(VectorRectangle, GraphicStream). (Overrides Bevel..::.Paint(VectorRectangle, GraphicStream).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BevelShadow | Gets or sets CornerRadiuses which sets radiuses for outer angles rounding.
DownOffset | Gets or sets the bevel inner effect offset.
Fill | Gets or sets Fill используеммый при отрисовки фона.
InnerRadiuses | Gets or sets CornerRadiuses which sets radiuses for inner angles rounding.
InnerStroke | Gets or sets Stroke which is used during the inner bevel lines drawing.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
Margins | Gets or sets Margins which sets margins.
Padding | Gets or sets the inner bounds padding.
Radiuses | Gets or sets CornerRadiuses which sets radiuses for outer angles rounding.
ShadowSize | Gets or sets размер эфекта тени.
Stroke | Gets or sets Stroke which is used during the outer bevel lines drawing.
UpOffset | Gets or sets the bevel outer effect offset.

See Also

CustomBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


CustomBevel Constructor

[image]

.NET ModelKit Suite ClassReference
CustomBevel Constructor
CustomBevel Class See Also Send Feedback
Initializes a new instance of the CustomBevel class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public CustomBevel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CustomBevel()

See Also

CustomBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


CustomBevel Methods

[image] [image]

.NET ModelKit Suite ClassReference
CustomBevel Methods
CustomBevel Class See Also Send Feedback

The CustomBevel type exposes the following members.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Implements Clone()()(). (Overrides Atom..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDockingBounds | Overridden. See GetDockingBounds(VectorRectangle). (Overrides Bevel..::.GetDockingBounds(VectorRectangle).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Paint | Overridden. See Paint(VectorRectangle, GraphicStream). (Overrides Bevel..::.Paint(VectorRectangle, GraphicStream).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
CustomBevel..::.Clone Method
CustomBevel Class See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Implements

ICloneable..::.Clone()()()

See Also

CustomBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


GetDockingBounds Method

[image]

.NET ModelKit Suite ClassReference
CustomBevel..::.GetDockingBounds Method
CustomBevel Class See Also Send Feedback
Overridden. See GetDockingBounds(VectorRectangle).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetDockingBounds(
    VectorRectangle rectangle
)
Visual Basic (Declaration)
Public Overrides Function GetDockingBounds ( _
    rectangle As VectorRectangle _
) As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetDockingBounds(
    VectorRectangle rectangle
) override

Parameters

rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

CustomBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Paint Method

[image]

.NET ModelKit Suite ClassReference
CustomBevel..::.Paint Method
CustomBevel Class See Also Send Feedback
Overridden. See Paint(VectorRectangle, GraphicStream).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void Paint(
    VectorRectangle rectangle,
    GraphicStream stream
)
Visual Basic (Declaration)
Public Overrides Sub Paint ( _
    rectangle As VectorRectangle, _
    stream As GraphicStream _
)
Visual C++
public:
virtual void Paint(
    VectorRectangle rectangle,
    GraphicStream^ stream
) override

Parameters

rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
stream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream

See Also

CustomBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


CustomBevel Properties

[image] [image]

.NET ModelKit Suite ClassReference
CustomBevel Properties
CustomBevel Class See Also Send Feedback

The CustomBevel type exposes the following members.

Properties

Name | Description
BevelShadow | Gets or sets CornerRadiuses which sets radiuses for outer angles rounding.
DownOffset | Gets or sets the bevel inner effect offset.
Fill | Gets or sets Fill используеммый при отрисовки фона.
InnerRadiuses | Gets or sets CornerRadiuses which sets radiuses for inner angles rounding.
InnerStroke | Gets or sets Stroke which is used during the inner bevel lines drawing.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
Margins | Gets or sets Margins which sets margins.
Padding | Gets or sets the inner bounds padding.
Radiuses | Gets or sets CornerRadiuses which sets radiuses for outer angles rounding.
ShadowSize | Gets or sets размер эфекта тени.
Stroke | Gets or sets Stroke which is used during the outer bevel lines drawing.
UpOffset | Gets or sets the bevel outer effect offset.

See Also

CustomBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


BevelShadow Property

[image]

.NET ModelKit Suite ClassReference
CustomBevel..::.BevelShadow Property
CustomBevel Class See Also Send Feedback
Gets or sets CornerRadiuses which sets radiuses for outer angles rounding.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Shadow BevelShadow { get; set; }
Visual Basic (Declaration)
Public Property BevelShadow As Shadow
Visual C++
public:
property Shadow^ BevelShadow {
    Shadow^ get ();
    void set (Shadow^ value);
}

See Also

CustomBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


DownOffset Property

[image]

.NET ModelKit Suite ClassReference
CustomBevel..::.DownOffset Property
CustomBevel Class See Also Send Feedback
Gets or sets the bevel inner effect offset.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double DownOffset { get; set; }
Visual Basic (Declaration)
Public Property DownOffset As Double
Visual C++
public:
property double DownOffset {
    double get ();
    void set (double value);
}

See Also

CustomBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
CustomBevel..::.Fill Property
CustomBevel Class See Also Send Feedback
Gets or sets Fill используеммый при отрисовки фона.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

CustomBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


InnerRadiuses Property

[image]

.NET ModelKit Suite ClassReference
CustomBevel..::.InnerRadiuses Property
CustomBevel Class See Also Send Feedback
Gets or sets CornerRadiuses which sets radiuses for inner angles rounding.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public CornerRadiuses InnerRadiuses { get; set; }
Visual Basic (Declaration)
Public Property InnerRadiuses As CornerRadiuses
Visual C++
public:
property CornerRadiuses InnerRadiuses {
    CornerRadiuses get ();
    void set (CornerRadiuses value);
}

See Also

CustomBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


InnerStroke Property

[image]

.NET ModelKit Suite ClassReference
CustomBevel..::.InnerStroke Property
CustomBevel Class See Also Send Feedback
Gets or sets Stroke which is used during the inner bevel lines drawing.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Stroke InnerStroke { get; set; }
Visual Basic (Declaration)
Public Property InnerStroke As Stroke
Visual C++
public:
property Stroke^ InnerStroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

CustomBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Margins Property

[image]

.NET ModelKit Suite ClassReference
CustomBevel..::.Margins Property
CustomBevel Class See Also Send Feedback
Gets or sets Margins which sets margins.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Margins Margins { get; set; }
Visual Basic (Declaration)
Public Property Margins As Margins
Visual C++
public:
property Margins Margins {
    Margins get ();
    void set (Margins value);
}

See Also

CustomBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Padding Property

[image]

.NET ModelKit Suite ClassReference
CustomBevel..::.Padding Property
CustomBevel Class See Also Send Feedback
Gets or sets the inner bounds padding.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Margins Padding { get; set; }
Visual Basic (Declaration)
Public Property Padding As Margins
Visual C++
public:
property Margins Padding {
    Margins get ();
    void set (Margins value);
}

See Also

CustomBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Radiuses Property

[image]

.NET ModelKit Suite ClassReference
CustomBevel..::.Radiuses Property
CustomBevel Class See Also Send Feedback
Gets or sets CornerRadiuses which sets radiuses for outer angles rounding.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public CornerRadiuses Radiuses { get; set; }
Visual Basic (Declaration)
Public Property Radiuses As CornerRadiuses
Visual C++
public:
property CornerRadiuses Radiuses {
    CornerRadiuses get ();
    void set (CornerRadiuses value);
}

See Also

CustomBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


ShadowSize Property

[image]

.NET ModelKit Suite ClassReference
CustomBevel..::.ShadowSize Property
CustomBevel Class See Also Send Feedback
Gets or sets размер эфекта тени.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double ShadowSize { get; set; }
Visual Basic (Declaration)
Public Property ShadowSize As Double
Visual C++
public:
property double ShadowSize {
    double get ();
    void set (double value);
}

See Also

CustomBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Stroke Property

[image]

.NET ModelKit Suite ClassReference
CustomBevel..::.Stroke Property
CustomBevel Class See Also Send Feedback
Gets or sets Stroke which is used during the outer bevel lines drawing.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Stroke Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Stroke
Visual C++
public:
property Stroke^ Stroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

CustomBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


UpOffset Property

[image]

.NET ModelKit Suite ClassReference
CustomBevel..::.UpOffset Property
CustomBevel Class See Also Send Feedback
Gets or sets the bevel outer effect offset.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double UpOffset { get; set; }
Visual Basic (Declaration)
Public Property UpOffset As Double
Visual C++
public:
property double UpOffset {
    double get ();
    void set (double value);
}

See Also

CustomBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


CustomLabels Class

[image]

.NET ModelKit Suite ClassReference
CustomLabels Class
Members See Also Send Feedback
Represents Text labels.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class CustomLabels : ScaleLabelsBase
Visual Basic (Declaration)
Public Class CustomLabels _
    Inherits ScaleLabelsBase
Visual C++
public ref class CustomLabels : public ScaleLabelsBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.ScaleElement
PerpetuumSoft.Instrumentation.Model..::.ScaleLabelsBase
PerpetuumSoft.Instrumentation.Model..::.CustomLabels
PerpetuumSoft.Instrumentation.Model..::.TextLabels

See Also

CustomLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


CustomLabels Members

[image] [image]

.NET ModelKit Suite ClassReference
CustomLabels Members
CustomLabels Class Constructors Methods Properties Events See Also Send Feedback

The CustomLabels type exposes the following members.

Constructors

Name | Description
CustomLabels | Initializes a new instance of the CustomLabels class.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from ScaleLabelsBase.)
GetLabelsCount | Overridden. See GetLabelsCount()()(). (Overrides ScaleLabelsBase..::.GetLabelsCount()()().)
GetObject | Implements GetObject(String). (Inherited from ScaleLabelsBase.)
GetObjectByIndex | Overridden. See GetObjectByIndex(Int32). (Overrides ScaleLabelsBase..::.GetObjectByIndex(Int32).)
GetSize | Implements GetSize()()(). (Inherited from ScaleLabelsBase.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetTextLabel | Returns label text by the assigned value. (Inherited from ScaleLabelsBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueByIndex | Overridden. See GetValueByIndex(Int32). (Overrides ScaleLabelsBase..::.GetValueByIndex(Int32).)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Raises the OnParentChanged event. (Inherited from ScaleLabelsBase.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is called when element's visibility is changed. (Inherited from ScaleLabelsBase.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLabel | Draws a scale mark. (Inherited from ScaleLabelsBase.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleLabelsBase.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleLabelsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets FontDescriptor of the element. (Inherited from ScaleLabelsBase.)
Format | Gets and sets text format for the labels. (Inherited from ScaleLabelsBase.)
Formula | Gets or sets expression used for calculating labels value. (Inherited from ScaleLabelsBase.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
ItemMargins | Gets or sets item margins. (Inherited from ScaleLabelsBase.)
Labels | Gets TextItemCollection of label values.
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
OddLabelsDistance | Gets or sets distance foк odd labels. (Inherited from ScaleLabelsBase.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
Position | Gets or sets label position mode. (Inherited from ScaleLabelsBase.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
ShowSuperposableLabels | Gets or sets value that indicates whether superposable labels will be shown. (Inherited from ScaleLabelsBase.)
Size | Gets element size. (Inherited from ScaleLabelsBase.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
TextAlignment | Gets or sets text alignment. (Inherited from ScaleLabelsBase.)
TextAngle | Gets or sets text angle. (Inherited from ScaleLabelsBase.)
TextRotationMode | Gets or sets text rotation mode. (Inherited from ScaleLabelsBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

CustomLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


CustomLabels Constructor

[image]

.NET ModelKit Suite ClassReference
CustomLabels Constructor
CustomLabels Class See Also Send Feedback
Initializes a new instance of the CustomLabels class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public CustomLabels()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CustomLabels()

See Also

CustomLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


CustomLabels Methods

[image] [image]

.NET ModelKit Suite ClassReference
CustomLabels Methods
CustomLabels Class See Also Send Feedback

The CustomLabels type exposes the following members.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from ScaleLabelsBase.)
GetLabelsCount | Overridden. See GetLabelsCount()()(). (Overrides ScaleLabelsBase..::.GetLabelsCount()()().)
GetObject | Implements GetObject(String). (Inherited from ScaleLabelsBase.)
GetObjectByIndex | Overridden. See GetObjectByIndex(Int32). (Overrides ScaleLabelsBase..::.GetObjectByIndex(Int32).)
GetSize | Implements GetSize()()(). (Inherited from ScaleLabelsBase.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetTextLabel | Returns label text by the assigned value. (Inherited from ScaleLabelsBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueByIndex | Overridden. See GetValueByIndex(Int32). (Overrides ScaleLabelsBase..::.GetValueByIndex(Int32).)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Raises the OnParentChanged event. (Inherited from ScaleLabelsBase.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is called when element's visibility is changed. (Inherited from ScaleLabelsBase.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLabel | Draws a scale mark. (Inherited from ScaleLabelsBase.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleLabelsBase.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleLabelsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
CustomLabels..::.Dispose Method
CustomLabels Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

CustomLabels Class
CustomLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


GetLabelsCount Method

[image]

.NET ModelKit Suite ClassReference
CustomLabels..::.GetLabelsCount Method
CustomLabels Class See Also Send Feedback
Overridden. See GetLabelsCount()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override int GetLabelsCount()
Visual Basic (Declaration)
Public Overrides Function GetLabelsCount As Integer
Visual C++
public:
virtual int GetLabelsCount() override

See Also

CustomLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


GetObjectByIndex Method

[image]

.NET ModelKit Suite ClassReference
CustomLabels..::.GetObjectByIndex Method
CustomLabels Class See Also Send Feedback
Overridden. See GetObjectByIndex(Int32).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Object GetObjectByIndex(
    int index
)
Visual Basic (Declaration)
Public Overrides Function GetObjectByIndex ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ GetObjectByIndex(
    int index
) override

Parameters

index
Type: System..::.Int32

See Also

CustomLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
CustomLabels..::.GetStyle Method
CustomLabels Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

CustomLabels Class
CustomLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


GetValueByIndex Method

[image]

.NET ModelKit Suite ClassReference
CustomLabels..::.GetValueByIndex Method
CustomLabels Class See Also Send Feedback
Overridden. See GetValueByIndex(Int32).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override double GetValueByIndex(
    int index
)
Visual Basic (Declaration)
Public Overrides Function GetValueByIndex ( _
    index As Integer _
) As Double
Visual C++
public:
virtual double GetValueByIndex(
    int index
) override

Parameters

index
Type: System..::.Int32

See Also

CustomLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
CustomLabels..::.Invalidate Method
CustomLabels Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

CustomLabels Class
CustomLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
CustomLabels..::.OnPaint Method
CustomLabels Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from ScaleLabelsBase.)

See Also

CustomLabels Class
CustomLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


CustomLabels Properties

[image] [image]

.NET ModelKit Suite ClassReference
CustomLabels Properties
CustomLabels Class See Also Send Feedback

The CustomLabels type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets FontDescriptor of the element. (Inherited from ScaleLabelsBase.)
Format | Gets and sets text format for the labels. (Inherited from ScaleLabelsBase.)
Formula | Gets or sets expression used for calculating labels value. (Inherited from ScaleLabelsBase.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
ItemMargins | Gets or sets item margins. (Inherited from ScaleLabelsBase.)
Labels | Gets TextItemCollection of label values.
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
OddLabelsDistance | Gets or sets distance foк odd labels. (Inherited from ScaleLabelsBase.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
Position | Gets or sets label position mode. (Inherited from ScaleLabelsBase.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
ShowSuperposableLabels | Gets or sets value that indicates whether superposable labels will be shown. (Inherited from ScaleLabelsBase.)
Size | Gets element size. (Inherited from ScaleLabelsBase.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
TextAlignment | Gets or sets text alignment. (Inherited from ScaleLabelsBase.)
TextAngle | Gets or sets text angle. (Inherited from ScaleLabelsBase.)
TextRotationMode | Gets or sets text rotation mode. (Inherited from ScaleLabelsBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

CustomLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


Labels Property

[image]

.NET ModelKit Suite ClassReference
CustomLabels..::.Labels Property
CustomLabels Class See Also Send Feedback
Gets TextItemCollection of label values.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public TextItemCollection Labels { get; }
Visual Basic (Declaration)
Public ReadOnly Property Labels As TextItemCollection
Visual C++
public:
property TextItemCollection^ Labels {
    TextItemCollection^ get ();
}

See Also

CustomLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


CustomLabels Events

[image] [image]

.NET ModelKit Suite ClassReference
CustomLabels Events
CustomLabels Class See Also Send Feedback

The CustomLabels type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

CustomLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


DockableTrajectoryBase Class

[image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase Class
Members See Also Send Feedback
Defines base class for Trajectory.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract class DockableTrajectoryBase : Composite,
    ITrajectory
Visual Basic (Declaration)
Public MustInherit Class DockableTrajectoryBase _
    Inherits Composite _
    Implements ITrajectory
Visual C++
public ref class DockableTrajectoryBase abstract : public Composite,
    ITrajectory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.Composite
PerpetuumSoft.Instrumentation.Model..::.DockableTrajectoryBase
PerpetuumSoft.Instrumentation.Model..::.Guide
PerpetuumSoft.Instrumentation.Model..::.Joint

See Also

DockableTrajectoryBase Members
PerpetuumSoft.Instrumentation.Model Namespace


DockableTrajectoryBase Members

[image] [image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase Members
DockableTrajectoryBase Class Constructors Methods Properties Events See Also Send Feedback

The DockableTrajectoryBase type exposes the following members.

Constructors

Name | Description
DockableTrajectoryBase | Initializes a new instance of the DockableTrajectoryBase class

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Overrides Composite..::.Calculate()()().)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetInsideSize | Returns inside size.
GetObject | Implements GetObject(String). (Inherited from Element.)
GetOutsideSize | Returns outside size.
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PercentToPoint | Implements PercentToPoint(Double, Double).
PointToPercent | Implements PointToPercent(Vector).
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
RecalculatePosition | Recalculates Trajectory position.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object used to paint over.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Margins | Gets and sets Trajectory margins.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smoothing will be applied.
StartDistance | Implements StartDistance.
Stroke | Gets or sets the Stroke object used to trace.
Style | Gets or sets name of the used style.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

DockableTrajectoryBase Class
PerpetuumSoft.Instrumentation.Model Namespace


DockableTrajectoryBase Constructor

[image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase Constructor
DockableTrajectoryBase Class See Also Send Feedback
Initializes a new instance of the DockableTrajectoryBase class

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected DockableTrajectoryBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
DockableTrajectoryBase()

See Also

DockableTrajectoryBase Class
PerpetuumSoft.Instrumentation.Model Namespace


DockableTrajectoryBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase Methods
DockableTrajectoryBase Class See Also Send Feedback

The DockableTrajectoryBase type exposes the following members.

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Overrides Composite..::.Calculate()()().)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetInsideSize | Returns inside size.
GetObject | Implements GetObject(String). (Inherited from Element.)
GetOutsideSize | Returns outside size.
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PercentToPoint | Implements PercentToPoint(Double, Double).
PointToPercent | Implements PointToPercent(Vector).
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
RecalculatePosition | Recalculates Trajectory position.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DockableTrajectoryBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Calculate Method

[image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase..::.Calculate Method
DockableTrajectoryBase Class See Also Send Feedback
Overridden. See Calculate()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void Calculate()
Visual Basic (Declaration)
Protected Overrides Sub Calculate
Visual C++
protected:
virtual void Calculate() override

See Also

DockableTrajectoryBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase..::.Dispose Method
DockableTrajectoryBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from Composite.)

See Also

DockableTrajectoryBase Class
DockableTrajectoryBase Members
PerpetuumSoft.Instrumentation.Model Namespace


GetInsideSize Method

[image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase..::.GetInsideSize Method
DockableTrajectoryBase Class See Also Send Feedback
Returns inside size.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected double GetInsideSize()
Visual Basic (Declaration)
Protected Function GetInsideSize As Double
Visual C++
protected:
double GetInsideSize()

See Also

DockableTrajectoryBase Class
PerpetuumSoft.Instrumentation.Model Namespace


GetOutsideSize Method

[image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase..::.GetOutsideSize Method
DockableTrajectoryBase Class See Also Send Feedback
Returns outside size.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected double GetOutsideSize()
Visual Basic (Declaration)
Protected Function GetOutsideSize As Double
Visual C++
protected:
double GetOutsideSize()

See Also

DockableTrajectoryBase Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase..::.GetStyle Method
DockableTrajectoryBase Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

DockableTrajectoryBase Class
DockableTrajectoryBase Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase..::.Invalidate Method
DockableTrajectoryBase Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

DockableTrajectoryBase Class
DockableTrajectoryBase Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase..::.OnPaint Method
DockableTrajectoryBase Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Inherited from Composite.)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

DockableTrajectoryBase Class
DockableTrajectoryBase Members
PerpetuumSoft.Instrumentation.Model Namespace


PercentToPoint Method

[image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase..::.PercentToPoint Method
DockableTrajectoryBase Class See Also Send Feedback
Implements PercentToPoint(Double, Double).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract Vector PercentToPoint(
    double portion,
    double radius
)
Visual Basic (Declaration)
Public MustOverride Function PercentToPoint ( _
    portion As Double, _
    radius As Double _
) As Vector
Visual C++
public:
virtual Vector PercentToPoint(
    double portion,
    double radius
) abstract

Parameters

portion
Type: System..::.Double
radius
Type: System..::.Double

Implements

ITrajectory..::.PercentToPoint(Double, Double)

See Also

DockableTrajectoryBase Class
PerpetuumSoft.Instrumentation.Model Namespace


PointToPercent Method

[image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase..::.PointToPercent Method
DockableTrajectoryBase Class See Also Send Feedback
Implements PointToPercent(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract double PointToPercent(
    Vector point
)
Visual Basic (Declaration)
Public MustOverride Function PointToPercent ( _
    point As Vector _
) As Double
Visual C++
public:
virtual double PointToPercent(
    Vector point
) abstract

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

Implements

ITrajectory..::.PointToPercent(Vector)

See Also

DockableTrajectoryBase Class
PerpetuumSoft.Instrumentation.Model Namespace


RecalculatePosition Method

[image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase..::.RecalculatePosition Method
DockableTrajectoryBase Class See Also Send Feedback
Recalculates Trajectory position.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected abstract void RecalculatePosition()
Visual Basic (Declaration)
Protected MustOverride Sub RecalculatePosition
Visual C++
protected:
virtual void RecalculatePosition() abstract

See Also

DockableTrajectoryBase Class
PerpetuumSoft.Instrumentation.Model Namespace


DockableTrajectoryBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase Properties
DockableTrajectoryBase Class See Also Send Feedback

The DockableTrajectoryBase type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object used to paint over.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Margins | Gets and sets Trajectory margins.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smoothing will be applied.
StartDistance | Implements StartDistance.
Stroke | Gets or sets the Stroke object used to trace.
Style | Gets or sets name of the used style.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

DockableTrajectoryBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase..::.Fill Property
DockableTrajectoryBase Class See Also Send Feedback
Gets or sets the Fill object used to paint over.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

DockableTrajectoryBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Margins Property

[image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase..::.Margins Property
DockableTrajectoryBase Class See Also Send Feedback
Gets and sets Trajectory margins.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Margins Margins { get; set; }
Visual Basic (Declaration)
Public Property Margins As Margins
Visual C++
public:
property Margins Margins {
    Margins get ();
    void set (Margins value);
}

See Also

DockableTrajectoryBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Smooth Property

[image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase..::.Smooth Property
DockableTrajectoryBase Class See Also Send Feedback
Gets or sets value that indicates whether smoothing will be applied.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Smooth { get; set; }
Visual Basic (Declaration)
Public Property Smooth As Boolean
Visual C++
public:
property bool Smooth {
    bool get ();
    void set (bool value);
}

See Also

DockableTrajectoryBase Class
PerpetuumSoft.Instrumentation.Model Namespace


StartDistance Property

[image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase..::.StartDistance Property
DockableTrajectoryBase Class See Also Send Feedback
Implements StartDistance.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract double StartDistance { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property StartDistance As Double
Visual C++
public:
virtual property double StartDistance {
    double get () abstract;
}

Implements

ITrajectory..::.StartDistance

See Also

DockableTrajectoryBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Stroke Property

[image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase..::.Stroke Property
DockableTrajectoryBase Class See Also Send Feedback
Gets or sets the Stroke object used to trace.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Stroke Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Stroke
Visual C++
public:
property Stroke^ Stroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

DockableTrajectoryBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Style Property

[image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase..::.Style Property
DockableTrajectoryBase Class See Also Send Feedback
Gets or sets name of the used style.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string Style { get; set; }
Visual Basic (Declaration)
Public Property Style As String
Visual C++
public:
property String^ Style {
    String^ get ();
    void set (String^ value);
}

See Also

DockableTrajectoryBase Class
PerpetuumSoft.Instrumentation.Model Namespace


DockableTrajectoryBase Events

[image] [image]

.NET ModelKit Suite ClassReference
DockableTrajectoryBase Events
DockableTrajectoryBase Class See Also Send Feedback

The DockableTrajectoryBase type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

DockableTrajectoryBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Effect3D Enumeration

[image]

.NET ModelKit Suite ClassReference
Effect3D Enumeration
See Also Send Feedback
Enumerates 3d effects.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public enum Effect3D
Visual Basic (Declaration)
Public Enumeration Effect3D
Visual C++
public enum class Effect3D

Members

Member name | Description
Raised | Specifies the raised effect.
Lowered | Specifies the lowered effect.
Flat | Specifies the flat effect.

See Also

PerpetuumSoft.Instrumentation.Model Namespace


Element Class

[image]

.NET ModelKit Suite ClassReference
Element Class
Members See Also Send Feedback
Base class for all elements in the Instrumentation Model Kit library.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract class Element : IElement,
    IDisposable
Visual Basic (Declaration)
Public MustInherit Class Element _
    Implements IElement, IDisposable
Visual C++
public ref class Element abstract : IElement,
    IDisposable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Charts..::.GridLines
PerpetuumSoft.Charts..::.PolygonElement
PerpetuumSoft.Charts..::.PolylineElement
PerpetuumSoft.Charts..::.PseudoElement
PerpetuumSoft.Charts..::.SplineAreaElement
PerpetuumSoft.Charts..::.SplineElement
PerpetuumSoft.Charts..::.ValueLabels
PerpetuumSoft.Charts..::.ValueMarkers
PerpetuumSoft.Instrumentation.Model..::.Circle
PerpetuumSoft.Instrumentation.Model..::.CircularShape
PerpetuumSoft.Instrumentation.Model..::.Composite
PerpetuumSoft.Instrumentation.Model..::.LineElement
PerpetuumSoft.Instrumentation.Model..::.ScaleElement
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement

See Also

Element Members
PerpetuumSoft.Instrumentation.Model Namespace


Element Members

[image] [image]

.NET ModelKit Suite ClassReference
Element Members
Element Class Constructors Methods Fields Properties Events See Also Send Feedback

The Element type exposes the following members.

Constructors

Name | Description
Element | Initializes a new instance of the Element class

Methods

Name | Description
AddElement | Registers the element type for the use in the designer tool box.
Calculate | Calculates the expressions and sets the result to the corresponded properties.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Overrides Object..::.Finalize()()().)
GetBoundedBox | Implements GetBoundedBox()()().
GetByName | Returns the element by the name.
GetElementAt | Implements GetElementAt(Vector).
GetFunction | Implements GetFunction(String).
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point.
GetObject | Implements GetObject(String).
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed.
OnMouseDown | Raises the MouseDown event.
OnMouseEnter | Raises the MouseEnter event.
OnMouseLeave | Raises the MouseLeave event.
OnMouseMove | Raises the MouseMove event.
OnMouseUp | Raises the MouseUp event.
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed.
OnStrokeChanged | Is executeв if the stroke was changed.
OnStyleChanged | Executes if the style was changed.
OnVisibleChanged | Is executed if the visibility was changed.
Paint | Implements Paint(PaintArguments).
Recalculate | Recalculates the expressions.
RegisterType | Registers the element's type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ControlTypes | Types of the register's elements.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element.
Fill | Gets or sets Fill object that is used to paint over.
Instrument | Gets Instrument, which contains this element.
Name | Gets or sets the element's name.
Parent | Implements Parent.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only.
Smooth | Gets or sets value that indicates whether smooth will be used.
Stroke | Gets or sets Stroke object that is used to trace.
Style | Gets or sets the name of the used style.
Visible | Gets or sets a value indicating whether the element is displayed.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed.
MouseEnter | Occurs when the mouse pointer enters the element.
MouseLeave | Occurs when the mouse pointer leaves the element.
MouseMove | Occurs when the mouse pointer is moved over the element.
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released.

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Element Constructor

[image]

.NET ModelKit Suite ClassReference
Element Constructor
Element Class See Also Send Feedback
Initializes a new instance of the Element class

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected Element()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
Element()

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Element Fields

[image] [image]

.NET ModelKit Suite ClassReference
Element Fields
Element Class See Also Send Feedback

The Element type exposes the following members.

Fields

Name | Description
ControlTypes | Types of the register's elements.

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


ControlTypes Field

[image]

.NET ModelKit Suite ClassReference
Element..::.ControlTypes Field
Element Class See Also Send Feedback
Types of the register's elements.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static readonly ArrayList ControlTypes
Visual Basic (Declaration)
Public Shared ReadOnly ControlTypes As ArrayList
Visual C++
public:
static initonly ArrayList^ ControlTypes

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Element Methods

[image] [image]

.NET ModelKit Suite ClassReference
Element Methods
Element Class See Also Send Feedback

The Element type exposes the following members.

Methods

Name | Description
AddElement | Registers the element type for the use in the designer tool box.
Calculate | Calculates the expressions and sets the result to the corresponded properties.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Overrides Object..::.Finalize()()().)
GetBoundedBox | Implements GetBoundedBox()()().
GetByName | Returns the element by the name.
GetElementAt | Implements GetElementAt(Vector).
GetFunction | Implements GetFunction(String).
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point.
GetObject | Implements GetObject(String).
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed.
OnMouseDown | Raises the MouseDown event.
OnMouseEnter | Raises the MouseEnter event.
OnMouseLeave | Raises the MouseLeave event.
OnMouseMove | Raises the MouseMove event.
OnMouseUp | Raises the MouseUp event.
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed.
OnStrokeChanged | Is executeв if the stroke was changed.
OnStyleChanged | Executes if the style was changed.
OnVisibleChanged | Is executed if the visibility was changed.
Paint | Implements Paint(PaintArguments).
Recalculate | Recalculates the expressions.
RegisterType | Registers the element's type.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


AddElement Method

[image]

.NET ModelKit Suite ClassReference
Element..::.AddElement Method
Element Class See Also Send Feedback
Registers the element type for the use in the designer tool box.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static void AddElement(
    string categoryType,
    Type type
)
Visual Basic (Declaration)
Public Shared Sub AddElement ( _
    categoryType As String, _
    type As Type _
)
Visual C++
public:
static void AddElement(
    String^ categoryType,
    Type^ type
)

Parameters

categoryType
Type: System..::.String
type
Type: System..::.Type

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Calculate Method

[image]

.NET ModelKit Suite ClassReference
Element..::.Calculate Method
Element Class See Also Send Feedback
Calculates the expressions and sets the result to the corresponded properties.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void Calculate()
Visual Basic (Declaration)
Protected Overridable Sub Calculate
Visual C++
protected:
virtual void Calculate()

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Element..::.Dispose Method
Element Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element.
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources.

See Also

Element Class
Element Members
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image]

.NET ModelKit Suite ClassReference
Element..::.Dispose Method
Element Class See Also Send Feedback
Releases all resources used by the Element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

Element Class
Dispose Overload
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
Element..::.Dispose Method (Boolean)
Element Class See Also Send Feedback
Releases the unmanaged resources used by the Element and optionally releases the managed resources.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean

See Also

Element Class
Dispose Overload
PerpetuumSoft.Instrumentation.Model Namespace


Finalize Method

[image]

.NET ModelKit Suite ClassReference
Element..::.Finalize Method
Element Class See Also Send Feedback
Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
Element..::.GetBoundedBox Method
Element Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public virtual VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overridable Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox()

Implements

IElement..::.GetBoundedBox()()()

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


GetByName Method

[image]

.NET ModelKit Suite ClassReference
Element..::.GetByName Method
Element Class See Also Send Feedback
Returns the element by the name.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public virtual Element GetByName(
    string name
)
Visual Basic (Declaration)
Public Overridable Function GetByName ( _
    name As String _
) As Element
Visual C++
public:
virtual Element^ GetByName(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


GetElementAt Method

[image]

.NET ModelKit Suite ClassReference
Element..::.GetElementAt Method
Element Class See Also Send Feedback
Implements GetElementAt(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public virtual IElement GetElementAt(
    Vector point
)
Visual Basic (Declaration)
Public Overridable Function GetElementAt ( _
    point As Vector _
) As IElement
Visual C++
public:
virtual IElement^ GetElementAt(
    Vector point
)

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

Implements

IElement..::.GetElementAt(Vector)

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


GetFunction Method

[image]

.NET ModelKit Suite ClassReference
Element..::.GetFunction Method
Element Class See Also Send Feedback
Implements GetFunction(String).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public virtual IFunction GetFunction(
    string name
)
Visual Basic (Declaration)
Public Overridable Function GetFunction ( _
    name As String _
) As IFunction
Visual C++
public:
virtual IFunction^ GetFunction(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
Element..::.GetHitTest Method
Element Class See Also Send Feedback
Returns the elements that are placed at the given point.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public virtual bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overridable Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
)

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


GetObject Method

[image]

.NET ModelKit Suite ClassReference
Element..::.GetObject Method
Element Class See Also Send Feedback
Implements GetObject(String).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public virtual Object GetObject(
    string name
)
Visual Basic (Declaration)
Public Overridable Function GetObject ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetObject(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Element..::.GetStyle Method
Element Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name.
GetStyle(String) | Returns the style by the name.

See Also

Element Class
Element Members
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image]

.NET ModelKit Suite ClassReference
Element..::.GetStyle Method
Element Class See Also Send Feedback
Returns the style by name.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Style GetStyle()
Visual Basic (Declaration)
Public Function GetStyle As Style
Visual C++
public:
Style^ GetStyle()

See Also

Element Class
GetStyle Overload
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method (String)

[image]

.NET ModelKit Suite ClassReference
Element..::.GetStyle Method (String)
Element Class See Also Send Feedback
Returns the style by the name.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public virtual Style GetStyle(
    string name
)
Visual Basic (Declaration)
Public Overridable Function GetStyle ( _
    name As String _
) As Style
Visual C++
public:
virtual Style^ GetStyle(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

Element Class
GetStyle Overload
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Element..::.Invalidate Method
Element Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()().
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle).

See Also

Element Class
Element Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image]

.NET ModelKit Suite ClassReference
Element..::.Invalidate Method
Element Class See Also Send Feedback
Implements Invalidate()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public virtual void Invalidate()
Visual Basic (Declaration)
Public Overridable Sub Invalidate
Visual C++
public:
virtual void Invalidate()

Implements

IElement..::.Invalidate()()()

See Also

Element Class
Invalidate Overload
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method (VectorRectangle)

[image]

.NET ModelKit Suite ClassReference
Element..::.Invalidate Method (VectorRectangle)
Element Class See Also Send Feedback
Implements Invalidate(VectorRectangle).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public virtual void Invalidate(
    VectorRectangle rectangle
)
Visual Basic (Declaration)
Public Overridable Sub Invalidate ( _
    rectangle As VectorRectangle _
)
Visual C++
public:
virtual void Invalidate(
    VectorRectangle rectangle
)

Parameters

rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

Implements

IElement..::.Invalidate(VectorRectangle)

See Also

Element Class
Invalidate Overload
PerpetuumSoft.Instrumentation.Model Namespace


OnFillChanged Method

[image]

.NET ModelKit Suite ClassReference
Element..::.OnFillChanged Method
Element Class See Also Send Feedback
Executes if the fill was changed.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnFillChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnFillChanged
Visual C++
protected:
virtual void OnFillChanged()

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


OnMouseDown Method

[image]

.NET ModelKit Suite ClassReference
Element..::.OnMouseDown Method
Element Class See Also Send Feedback
Raises the MouseDown event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnMouseDown(
    MouseArguments args
)
Visual Basic (Declaration)
Protected Overridable Sub OnMouseDown ( _
    args As MouseArguments _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseArguments^ args
)

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.MouseArguments

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


OnMouseEnter Method

[image]

.NET ModelKit Suite ClassReference
Element..::.OnMouseEnter Method
Element Class See Also Send Feedback
Raises the MouseEnter event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnMouseEnter(
    MouseArguments args
)
Visual Basic (Declaration)
Protected Overridable Sub OnMouseEnter ( _
    args As MouseArguments _
)
Visual C++
protected:
virtual void OnMouseEnter(
    MouseArguments^ args
)

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.MouseArguments

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


OnMouseLeave Method

[image]

.NET ModelKit Suite ClassReference
Element..::.OnMouseLeave Method
Element Class See Also Send Feedback
Raises the MouseLeave event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnMouseLeave(
    MouseArguments args
)
Visual Basic (Declaration)
Protected Overridable Sub OnMouseLeave ( _
    args As MouseArguments _
)
Visual C++
protected:
virtual void OnMouseLeave(
    MouseArguments^ args
)

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.MouseArguments

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


OnMouseMove Method

[image]

.NET ModelKit Suite ClassReference
Element..::.OnMouseMove Method
Element Class See Also Send Feedback
Raises the MouseMove event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnMouseMove(
    MouseArguments args
)
Visual Basic (Declaration)
Protected Overridable Sub OnMouseMove ( _
    args As MouseArguments _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseArguments^ args
)

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.MouseArguments

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


OnMouseUp Method

[image]

.NET ModelKit Suite ClassReference
Element..::.OnMouseUp Method
Element Class See Also Send Feedback
Raises the MouseUp event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnMouseUp(
    MouseArguments args
)
Visual Basic (Declaration)
Protected Overridable Sub OnMouseUp ( _
    args As MouseArguments _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseArguments^ args
)

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.MouseArguments

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Element..::.OnPaint Method
Element Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing.
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke.

See Also

Element Class
Element Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments)

[image]

.NET ModelKit Suite ClassReference
Element..::.OnPaint Method (PaintArguments)
Element Class See Also Send Feedback
Performs element drawing.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public virtual void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Public Overridable Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args
)

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

Element Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
Element..::.OnPaint Method (PaintArguments, Fill, Stroke)
Element Class See Also Send Feedback
Performs element's drawing with specific fill and stroke.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public virtual void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overridable Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
)

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Element Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


OnParentChanged Method

[image]

.NET ModelKit Suite ClassReference
Element..::.OnParentChanged Method
Element Class See Also Send Feedback
Is executed if the parent was changed.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnParentChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnParentChanged
Visual C++
protected:
virtual void OnParentChanged()

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


OnStrokeChanged Method

[image]

.NET ModelKit Suite ClassReference
Element..::.OnStrokeChanged Method
Element Class See Also Send Feedback
Is executeв if the stroke was changed.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnStrokeChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnStrokeChanged
Visual C++
protected:
virtual void OnStrokeChanged()

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


OnStyleChanged Method

[image]

.NET ModelKit Suite ClassReference
Element..::.OnStyleChanged Method
Element Class See Also Send Feedback
Executes if the style was changed.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnStyleChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnStyleChanged
Visual C++
protected:
virtual void OnStyleChanged()

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


OnVisibleChanged Method

[image]

.NET ModelKit Suite ClassReference
Element..::.OnVisibleChanged Method
Element Class See Also Send Feedback
Is executed if the visibility was changed.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnVisibleChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnVisibleChanged
Visual C++
protected:
virtual void OnVisibleChanged()

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Paint Method

[image]

.NET ModelKit Suite ClassReference
Element..::.Paint Method
Element Class See Also Send Feedback
Implements Paint(PaintArguments).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void Paint(
    PaintArguments args
)
Visual Basic (Declaration)
Public Sub Paint ( _
    args As PaintArguments _
)
Visual C++
public:
virtual void Paint(
    PaintArguments^ args
) sealed

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

Implements

IElement..::.Paint(PaintArguments)

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Recalculate Method

[image]

.NET ModelKit Suite ClassReference
Element..::.Recalculate Method
Element Class See Also Send Feedback
Recalculates the expressions.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void Recalculate()
Visual Basic (Declaration)
Public Sub Recalculate
Visual C++
public:
void Recalculate()

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


RegisterType Method

[image]

.NET ModelKit Suite ClassReference
Element..::.RegisterType Method
Element Class See Also Send Feedback
Registers the element's type.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static void RegisterType(
    string category,
    Type type
)
Visual Basic (Declaration)
Public Shared Sub RegisterType ( _
    category As String, _
    type As Type _
)
Visual C++
public:
static void RegisterType(
    String^ category,
    Type^ type
)

Parameters

category
Type: System..::.String
type
Type: System..::.Type

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Element Properties

[image] [image]

.NET ModelKit Suite ClassReference
Element Properties
Element Class See Also Send Feedback

The Element type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element.
Fill | Gets or sets Fill object that is used to paint over.
Instrument | Gets Instrument, which contains this element.
Name | Gets or sets the element's name.
Parent | Implements Parent.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only.
Smooth | Gets or sets value that indicates whether smooth will be used.
Stroke | Gets or sets Stroke object that is used to trace.
Style | Gets or sets the name of the used style.
Visible | Gets or sets a value indicating whether the element is displayed.

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Active Property

[image]

.NET ModelKit Suite ClassReference
Element..::.Active Property
Element Class See Also Send Feedback
Gets or sets value that indicates whether events will be passed to this element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Active { get; set; }
Visual Basic (Declaration)
Public Property Active As Boolean
Visual C++
public:
property bool Active {
    bool get ();
    void set (bool value);
}

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


BreakEventsBubbling Property

[image]

.NET ModelKit Suite ClassReference
Element..::.BreakEventsBubbling Property
Element Class See Also Send Feedback
Gets or sets value that indicates whether events will be passed to parent.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool BreakEventsBubbling { get; set; }
Visual Basic (Declaration)
Public Property BreakEventsBubbling As Boolean
Visual C++
public:
property bool BreakEventsBubbling {
    bool get ();
    void set (bool value);
}

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Expressions Property

[image]

.NET ModelKit Suite ClassReference
Element..::.Expressions Property
Element Class See Also Send Feedback
Gets ExpressionBindingCollection expressions that are used by this element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ExpressionBindingCollection Expressions { get; }
Visual Basic (Declaration)
Public ReadOnly Property Expressions As ExpressionBindingCollection
Visual C++
public:
property ExpressionBindingCollection^ Expressions {
    ExpressionBindingCollection^ get ();
}

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
Element..::.Fill Property
Element Class See Also Send Feedback
Gets or sets Fill object that is used to paint over.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Instrument Property

[image]

.NET ModelKit Suite ClassReference
Element..::.Instrument Property
Element Class See Also Send Feedback
Gets Instrument, which contains this element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Instrument Instrument { get; }
Visual Basic (Declaration)
Public ReadOnly Property Instrument As Instrument
Visual C++
public:
property Instrument^ Instrument {
    Instrument^ get ();
}

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Name Property

[image]

.NET ModelKit Suite ClassReference
Element..::.Name Property
Element Class See Also Send Feedback
Gets or sets the element's name.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Parent Property

[image]

.NET ModelKit Suite ClassReference
Element..::.Parent Property
Element Class See Also Send Feedback
Implements Parent.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Composite Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As Composite
Visual C++
public:
property Composite^ Parent {
    Composite^ get ();
    void set (Composite^ value);
}

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


RecalculateAll Property

[image]

.NET ModelKit Suite ClassReference
Element..::.RecalculateAll Property
Element Class See Also Send Feedback
Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool RecalculateAll { get; set; }
Visual Basic (Declaration)
Public Property RecalculateAll As Boolean
Visual C++
public:
property bool RecalculateAll {
    bool get ();
    void set (bool value);
}

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Smooth Property

[image]

.NET ModelKit Suite ClassReference
Element..::.Smooth Property
Element Class See Also Send Feedback
Gets or sets value that indicates whether smooth will be used.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Smooth { get; set; }
Visual Basic (Declaration)
Public Property Smooth As Boolean
Visual C++
public:
property bool Smooth {
    bool get ();
    void set (bool value);
}

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Stroke Property

[image]

.NET ModelKit Suite ClassReference
Element..::.Stroke Property
Element Class See Also Send Feedback
Gets or sets Stroke object that is used to trace.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Stroke Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Stroke
Visual C++
public:
property Stroke^ Stroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Style Property

[image]

.NET ModelKit Suite ClassReference
Element..::.Style Property
Element Class See Also Send Feedback
Gets or sets the name of the used style.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string Style { get; set; }
Visual Basic (Declaration)
Public Property Style As String
Visual C++
public:
property String^ Style {
    String^ get ();
    void set (String^ value);
}

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Visible Property

[image]

.NET ModelKit Suite ClassReference
Element..::.Visible Property
Element Class See Also Send Feedback
Gets or sets a value indicating whether the element is displayed.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
virtual property bool Visible {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Element Events

[image] [image]

.NET ModelKit Suite ClassReference
Element Events
Element Class See Also Send Feedback

The Element type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed.
MouseEnter | Occurs when the mouse pointer enters the element.
MouseLeave | Occurs when the mouse pointer leaves the element.
MouseMove | Occurs when the mouse pointer is moved over the element.
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released.

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


MouseDown Event

[image]

.NET ModelKit Suite ClassReference
Element..::.MouseDown Event
Element Class See Also Send Feedback
Occurs when the mouse pointer is over the element and a mouse button is pressed.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public event MouseEventHandler MouseDown
Visual Basic (Declaration)
Public Event MouseDown As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseDown {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


MouseEnter Event

[image]

.NET ModelKit Suite ClassReference
Element..::.MouseEnter Event
Element Class See Also Send Feedback
Occurs when the mouse pointer enters the element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public event MouseEventHandler MouseEnter
Visual Basic (Declaration)
Public Event MouseEnter As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseEnter {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


MouseLeave Event

[image]

.NET ModelKit Suite ClassReference
Element..::.MouseLeave Event
Element Class See Also Send Feedback
Occurs when the mouse pointer leaves the element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public event MouseEventHandler MouseLeave
Visual Basic (Declaration)
Public Event MouseLeave As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseLeave {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


MouseMove Event

[image]

.NET ModelKit Suite ClassReference
Element..::.MouseMove Event
Element Class See Also Send Feedback
Occurs when the mouse pointer is moved over the element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public event MouseEventHandler MouseMove
Visual Basic (Declaration)
Public Event MouseMove As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseMove {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


MouseUp Event

[image]

.NET ModelKit Suite ClassReference
Element..::.MouseUp Event
Element Class See Also Send Feedback
Occurs when the mouse pointer is over the element and a mouse button is released.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public event MouseEventHandler MouseUp
Visual Basic (Declaration)
Public Event MouseUp As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseUp {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

Element Class
PerpetuumSoft.Instrumentation.Model Namespace


Element.CategoryType Structure

[image]

.NET ModelKit Suite ClassReference
Element..::.CategoryType Structure
Element Class Members See Also Send Feedback
Describes a registered type element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public struct CategoryType
Visual Basic (Declaration)
Public Structure CategoryType
Visual C++
public value class CategoryType

See Also

Element..::.CategoryType Members
PerpetuumSoft.Instrumentation.Model Namespace


Element.CategoryType Members

[image] [image]

.NET ModelKit Suite ClassReference
Element..::.CategoryType Members
Element..::.CategoryType Structure Constructors Methods Fields See Also Send Feedback

Base class for all elements in the Instrumentation Model Kit library.

The Element..::.CategoryType type exposes the following members.

Constructors

Name | Description
Element..::.CategoryType | Overloaded.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
CategoryName | Gets name of element category.
Type | Gets type of element.

See Also

Element..::.CategoryType Structure
PerpetuumSoft.Instrumentation.Model Namespace


Element.CategoryType Constructor

[image] [image]

.NET ModelKit Suite ClassReference
Element..::.CategoryType Constructor
Element..::.CategoryType Structure See Also Send Feedback

Overload List

Name | Description
Element..::.CategoryType(String, Type) | Initializes a new instance of the Element..::.CategoryType class with specific parameters. Parameters set name of element category and element type.
Element..::.CategoryType(String, Type, Int32) | Initializes a new instance of the Element..::.CategoryType class.

See Also

Element..::.CategoryType Structure
Element..::.CategoryType Members
PerpetuumSoft.Instrumentation.Model Namespace


Element.CategoryType Constructor (String, Type)

[image]

.NET ModelKit Suite ClassReference
Element..::.CategoryType Constructor (String, Type)
Element..::.CategoryType Structure See Also Send Feedback
Initializes a new instance of the Element..::.CategoryType class with specific parameters. Parameters set name of element category and element type.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public CategoryType(
    string categoryName,
    Type type
)
Visual Basic (Declaration)
Public Sub New ( _
    categoryName As String, _
    type As Type _
)
Visual C++
public:
CategoryType(
    String^ categoryName,
    Type^ type
)

Parameters

categoryName
Type: System..::.String
type
Type: System..::.Type

See Also

Element..::.CategoryType Structure
Element..::.CategoryType Overload
PerpetuumSoft.Instrumentation.Model Namespace


Element.CategoryType Constructor (String, Type, Int32)

[image]

.NET ModelKit Suite ClassReference
Element..::.CategoryType Constructor (String, Type, Int32)
Element..::.CategoryType Structure See Also Send Feedback
Initializes a new instance of the Element..::.CategoryType class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public CategoryType(
    string categoryName,
    Type type,
    int priority
)
Visual Basic (Declaration)
Public Sub New ( _
    categoryName As String, _
    type As Type, _
    priority As Integer _
)
Visual C++
public:
CategoryType(
    String^ categoryName,
    Type^ type,
    int priority
)

Parameters

categoryName
Type: System..::.String
type
Type: System..::.Type
priority
Type: System..::.Int32

See Also

Element..::.CategoryType Structure
Element..::.CategoryType Overload
PerpetuumSoft.Instrumentation.Model Namespace


Element.CategoryType Fields

[image] [image]

.NET ModelKit Suite ClassReference
Element..::.CategoryType Fields
Element..::.CategoryType Structure See Also Send Feedback

The Element..::.CategoryType type exposes the following members.

Fields

Name | Description
CategoryName | Gets name of element category.
Type | Gets type of element.

See Also

Element..::.CategoryType Structure
PerpetuumSoft.Instrumentation.Model Namespace


CategoryName Field

[image]

.NET ModelKit Suite ClassReference
Element..::.CategoryType..::.CategoryName Field
Element..::.CategoryType Structure See Also Send Feedback
Gets name of element category.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public readonly string CategoryName
Visual Basic (Declaration)
Public ReadOnly CategoryName As String
Visual C++
public:
initonly String^ CategoryName

See Also

Element..::.CategoryType Structure
PerpetuumSoft.Instrumentation.Model Namespace


Type Field

[image]

.NET ModelKit Suite ClassReference
Element..::.CategoryType..::.Type Field
Element..::.CategoryType Structure See Also Send Feedback
Gets type of element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public readonly Type Type
Visual Basic (Declaration)
Public ReadOnly Type As Type
Visual C++
public:
initonly Type^ Type

See Also

Element..::.CategoryType Structure
PerpetuumSoft.Instrumentation.Model Namespace


Element.CategoryType Methods

[image] [image]

.NET ModelKit Suite ClassReference
Element..::.CategoryType Methods
Element..::.CategoryType Structure See Also Send Feedback

The Element..::.CategoryType type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Element..::.CategoryType Structure
PerpetuumSoft.Instrumentation.Model Namespace


ElementCollection Class

[image]

.NET ModelKit Suite ClassReference
ElementCollection Class
Members See Also Send Feedback
Represents the collection of the elements.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class ElementCollection : CollectionBase,
    IElementList, IList, ICollection, IEnumerable
Visual Basic (Declaration)
Public Class ElementCollection _
    Inherits CollectionBase _
    Implements IElementList, IList, ICollection, IEnumerable
Visual C++
public ref class ElementCollection : public CollectionBase,
    IElementList, IList, ICollection, IEnumerable

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Instrumentation.Model..::.ElementCollection

See Also

ElementCollection Members
PerpetuumSoft.Instrumentation.Model Namespace


ElementCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
ElementCollection Members
ElementCollection Class Constructors Methods Properties Events See Also Send Feedback

The ElementCollection type exposes the following members.

Constructors

Name | Description
ElementCollection | Initializes a new instance of the ElementCollection class.

Methods

Name | Description
Add | Adds an element to the collection.
AddRange | Adds the elements to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded. Returns the zero-based index of the first occurrence of an element in the collection or in a portion of it.
Insert | Inserts an element into the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the collection instance. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new element into the collection instance. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the collection instance. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Overrides CollectionBase..::.OnValidate(Object).)
Remove | Removes the first occurrence of an element from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

Name | Description
ElementAdded | Occurs after the element was added.
ElementRemoved | Occurs after the element was removed.

See Also

ElementCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


ElementCollection Constructor

[image]

.NET ModelKit Suite ClassReference
ElementCollection Constructor
ElementCollection Class See Also Send Feedback
Initializes a new instance of the ElementCollection class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ElementCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementCollection()

See Also

ElementCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


ElementCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
ElementCollection Methods
ElementCollection Class See Also Send Feedback

The ElementCollection type exposes the following members.

Methods

Name | Description
Add | Adds an element to the collection.
AddRange | Adds the elements to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an element is in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded. Returns the zero-based index of the first occurrence of an element in the collection or in a portion of it.
Insert | Inserts an element into the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the collection instance. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new element into the collection instance. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the collection instance. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Overrides CollectionBase..::.OnValidate(Object).)
Remove | Removes the first occurrence of an element from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
ElementCollection..::.Add Method
ElementCollection Class See Also Send Feedback
Adds an element to the collection.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Element Add(
    Element value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As Element _
) As Element
Visual C++
public:
Element^ Add(
    Element^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model..::.Element

See Also

ElementCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
ElementCollection..::.AddRange Method
ElementCollection Class See Also Send Feedback
Adds the elements to the collection.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    Element[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As Element() _
)
Visual C++
public:
void AddRange(
    array<Element^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Instrumentation.Model..::.Element >[]()[]

See Also

ElementCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
ElementCollection..::.Contains Method
ElementCollection Class See Also Send Feedback
Determines whether an element is in the collection.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    Element value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As Element _
) As Boolean
Visual C++
public:
bool Contains(
    Element^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model..::.Element

See Also

ElementCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
ElementCollection..::.IndexOf Method
ElementCollection Class See Also Send Feedback
Overloaded. Returns the zero-based index of the first occurrence of an element in the collection or in a portion of it.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    Element value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As Element _
) As Integer
Visual C++
public:
int IndexOf(
    Element^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model..::.Element

See Also

ElementCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
ElementCollection..::.Insert Method
ElementCollection Class See Also Send Feedback
Inserts an element into the collection at the specified index.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    Element value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As Element _
)
Visual C++
public:
void Insert(
    int index,
    Element^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Instrumentation.Model..::.Element

See Also

ElementCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


OnInsert Method

[image]

.NET ModelKit Suite ClassReference
ElementCollection..::.OnInsert Method
ElementCollection Class See Also Send Feedback
Performs additional custom processes before inserting a new element into the collection instance.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsert(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsert ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsert(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ElementCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


OnInsertComplete Method

[image]

.NET ModelKit Suite ClassReference
ElementCollection..::.OnInsertComplete Method
ElementCollection Class See Also Send Feedback
Performs additional custom processes after inserting a new element into the collection instance.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsertComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsertComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsertComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ElementCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


OnRemoveComplete Method

[image]

.NET ModelKit Suite ClassReference
ElementCollection..::.OnRemoveComplete Method
ElementCollection Class See Also Send Feedback
Performs additional custom processes after removing an element from the collection instance.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnRemoveComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemoveComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemoveComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ElementCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


OnValidate Method

[image]

.NET ModelKit Suite ClassReference
ElementCollection..::.OnValidate Method
ElementCollection Class See Also Send Feedback
Performs additional custom processes when validating a value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnValidate(
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnValidate ( _
    value As Object _
)
Visual C++
protected:
virtual void OnValidate(
    Object^ value
) override

Parameters

value
Type: System..::.Object

See Also

ElementCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
ElementCollection..::.Remove Method
ElementCollection Class See Also Send Feedback
Removes the first occurrence of an element from the collection.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    Element value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As Element _
)
Visual C++
public:
void Remove(
    Element^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model..::.Element

See Also

ElementCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


ElementCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
ElementCollection Properties
ElementCollection Class See Also Send Feedback

The ElementCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ElementCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
ElementCollection..::.Item Property
ElementCollection Class See Also Send Feedback
Gets or sets the element at the specified index.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Element this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Element
Visual C++
public:
property Element^ default[int index] {
    Element^ get (int index);
    void set (int index, Element^ value);
}

Parameters

index
Type: System..::.Int32

See Also

ElementCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


ElementCollection Events

[image] [image]

.NET ModelKit Suite ClassReference
ElementCollection Events
ElementCollection Class See Also Send Feedback

The ElementCollection type exposes the following members.

Events

Name | Description
ElementAdded | Occurs after the element was added.
ElementRemoved | Occurs after the element was removed.

See Also

ElementCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


ElementAdded Event

[image]

.NET ModelKit Suite ClassReference
ElementCollection..::.ElementAdded Event
ElementCollection Class See Also Send Feedback
Occurs after the element was added.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public event ElementCollection..::.CollectionChanged ElementAdded
Visual Basic (Declaration)
Public Event ElementAdded As ElementCollection..::.CollectionChanged
Visual C++
public:
 event ElementCollection..::.CollectionChanged^ ElementAdded {
    void add (ElementCollection..::.CollectionChanged^ value);
    void remove (ElementCollection..::.CollectionChanged^ value);
}

See Also

ElementCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


ElementRemoved Event

[image]

.NET ModelKit Suite ClassReference
ElementCollection..::.ElementRemoved Event
ElementCollection Class See Also Send Feedback
Occurs after the element was removed.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public event ElementCollection..::.CollectionChanged ElementRemoved
Visual Basic (Declaration)
Public Event ElementRemoved As ElementCollection..::.CollectionChanged
Visual C++
public:
 event ElementCollection..::.CollectionChanged^ ElementRemoved {
    void add (ElementCollection..::.CollectionChanged^ value);
    void remove (ElementCollection..::.CollectionChanged^ value);
}

See Also

ElementCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


ElementCollection.CollectionChanged Delegate

[image]

.NET ModelKit Suite ClassReference
ElementCollection..::.CollectionChanged Delegate
ElementCollection Class See Also Send Feedback
Represents the method that will handle the ElementAdded and ElementRemoved.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public delegate void CollectionChanged(
    Element element
)
Visual Basic (Declaration)
Public Delegate Sub CollectionChanged ( _
    element As Element _
)
Visual C++
public delegate void CollectionChanged(
    Element^ element
)

Parameters

element
Type: PerpetuumSoft.Instrumentation.Model..::.Element

See Also

PerpetuumSoft.Instrumentation.Model Namespace


Ellipse Class

[image]

.NET ModelKit Suite ClassReference
Ellipse Class
Members See Also Send Feedback
Represents the ellipse.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Ellipse : RectangleElement
Visual Basic (Declaration)
Public Class Ellipse _
    Inherits RectangleElement
Visual C++
public ref class Ellipse : public RectangleElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement
PerpetuumSoft.Instrumentation.Model..::.RectangleElement
PerpetuumSoft.Instrumentation.Model..::.Ellipse

See Also

Ellipse Members
PerpetuumSoft.Instrumentation.Model Namespace


Ellipse Members

[image] [image]

.NET ModelKit Suite ClassReference
Ellipse Members
Ellipse Class Constructors Methods Properties Events See Also Send Feedback

The Ellipse type exposes the following members.

Constructors

Name | Description
Ellipse | Initializes a new instance of the Ellipse class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides RectangleElement..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Ellipse Class
PerpetuumSoft.Instrumentation.Model Namespace


Ellipse Constructor

[image]

.NET ModelKit Suite ClassReference
Ellipse Constructor
Ellipse Class See Also Send Feedback
Initializes a new instance of the Ellipse class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Ellipse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Ellipse()

See Also

Ellipse Class
PerpetuumSoft.Instrumentation.Model Namespace


Ellipse Methods

[image] [image]

.NET ModelKit Suite ClassReference
Ellipse Methods
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides RectangleElement..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Ellipse Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Ellipse..::.Dispose Method
Ellipse Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from RectangleElement.)

See Also

Ellipse Class
Ellipse Members
PerpetuumSoft.Instrumentation.Model Namespace


DrawContent Method

[image]

.NET ModelKit Suite ClassReference
Ellipse..::.DrawContent Method
Ellipse Class See Also Send Feedback
Overridden. See DrawContent(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void DrawContent(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Protected Overrides Sub DrawContent ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
protected:
virtual void DrawContent(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Ellipse Class
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
Ellipse..::.GetHitTest Method
Ellipse Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Ellipse Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Ellipse..::.GetStyle Method
Ellipse Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Ellipse Class
Ellipse Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Ellipse..::.Invalidate Method
Ellipse Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Ellipse Class
Ellipse Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Ellipse..::.OnPaint Method
Ellipse Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from RectangleElement.)

See Also

Ellipse Class
Ellipse Members
PerpetuumSoft.Instrumentation.Model Namespace


Ellipse Properties

[image] [image]

.NET ModelKit Suite ClassReference
Ellipse Properties
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Ellipse Class
PerpetuumSoft.Instrumentation.Model Namespace


Ellipse Events

[image] [image]

.NET ModelKit Suite ClassReference
Ellipse Events
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Ellipse Class
PerpetuumSoft.Instrumentation.Model Namespace


EllipseBevel Class

[image]

.NET ModelKit Suite ClassReference
EllipseBevel Class
Members See Also Send Feedback
Represents the ellipse bevel.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class EllipseBevel : Bevel
Visual Basic (Declaration)
Public Class EllipseBevel _
    Inherits Bevel
Visual C++
public ref class EllipseBevel : public Bevel

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework..::.Atom
PerpetuumSoft.Instrumentation.Model..::.Bevel
PerpetuumSoft.Instrumentation.Model..::.EllipseBevel

See Also

EllipseBevel Members
PerpetuumSoft.Instrumentation.Model Namespace


EllipseBevel Members

[image] [image]

.NET ModelKit Suite ClassReference
EllipseBevel Members
EllipseBevel Class Constructors Methods Properties See Also Send Feedback

The EllipseBevel type exposes the following members.

Constructors

Name | Description
EllipseBevel | Initializes a new instance of the EllipseBevel class.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Gets or sets the bevel inner effect offset. (Overrides Atom..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDockingBounds | Gets or sets the bevel outer effect offset. (Overrides Bevel..::.GetDockingBounds(VectorRectangle).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Paint | Represents bevel with wide opportunities in customization. (Overrides Bevel..::.Paint(VectorRectangle, GraphicStream).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BevelShadow | Gets or sets Shadow which sets the bevel shadow effect.
DownOffset | Gets or sets the bevel inner effect offset.
DrawingStyle | Gets or sets EllipseBevelDrawingStyle which represents the bevel drawing style.
Fill | Gets or sets Fill which is used during the background drawing.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
Margins | Gets or sets Margins which sets margins.
Stroke | Gets or sets Stroke which is used during the lines drawing.
UpOffset | Gets or sets the bevel outer effect offset.

See Also

EllipseBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


EllipseBevel Constructor

[image]

.NET ModelKit Suite ClassReference
EllipseBevel Constructor
EllipseBevel Class See Also Send Feedback
Initializes a new instance of the EllipseBevel class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public EllipseBevel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EllipseBevel()

See Also

EllipseBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


EllipseBevel Methods

[image] [image]

.NET ModelKit Suite ClassReference
EllipseBevel Methods
EllipseBevel Class See Also Send Feedback

The EllipseBevel type exposes the following members.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Gets or sets the bevel inner effect offset. (Overrides Atom..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDockingBounds | Gets or sets the bevel outer effect offset. (Overrides Bevel..::.GetDockingBounds(VectorRectangle).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Paint | Represents bevel with wide opportunities in customization. (Overrides Bevel..::.Paint(VectorRectangle, GraphicStream).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EllipseBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
EllipseBevel..::.Clone Method
EllipseBevel Class See Also Send Feedback
Gets or sets the bevel inner effect offset.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Implements

ICloneable..::.Clone()()()

See Also

EllipseBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


GetDockingBounds Method

[image]

.NET ModelKit Suite ClassReference
EllipseBevel..::.GetDockingBounds Method
EllipseBevel Class See Also Send Feedback
Gets or sets the bevel outer effect offset.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetDockingBounds(
    VectorRectangle rectangle
)
Visual Basic (Declaration)
Public Overrides Function GetDockingBounds ( _
    rectangle As VectorRectangle _
) As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetDockingBounds(
    VectorRectangle rectangle
) override

Parameters

rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

EllipseBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Paint Method

[image]

.NET ModelKit Suite ClassReference
EllipseBevel..::.Paint Method
EllipseBevel Class See Also Send Feedback
Represents bevel with wide opportunities in customization.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void Paint(
    VectorRectangle rectangle,
    GraphicStream stream
)
Visual Basic (Declaration)
Public Overrides Sub Paint ( _
    rectangle As VectorRectangle, _
    stream As GraphicStream _
)
Visual C++
public:
virtual void Paint(
    VectorRectangle rectangle,
    GraphicStream^ stream
) override

Parameters

rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
stream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream

See Also

EllipseBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


EllipseBevel Properties

[image] [image]

.NET ModelKit Suite ClassReference
EllipseBevel Properties
EllipseBevel Class See Also Send Feedback

The EllipseBevel type exposes the following members.

Properties

Name | Description
BevelShadow | Gets or sets Shadow which sets the bevel shadow effect.
DownOffset | Gets or sets the bevel inner effect offset.
DrawingStyle | Gets or sets EllipseBevelDrawingStyle which represents the bevel drawing style.
Fill | Gets or sets Fill which is used during the background drawing.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
Margins | Gets or sets Margins which sets margins.
Stroke | Gets or sets Stroke which is used during the lines drawing.
UpOffset | Gets or sets the bevel outer effect offset.

See Also

EllipseBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


BevelShadow Property

[image]

.NET ModelKit Suite ClassReference
EllipseBevel..::.BevelShadow Property
EllipseBevel Class See Also Send Feedback
Gets or sets Shadow which sets the bevel shadow effect.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Shadow BevelShadow { get; set; }
Visual Basic (Declaration)
Public Property BevelShadow As Shadow
Visual C++
public:
property Shadow^ BevelShadow {
    Shadow^ get ();
    void set (Shadow^ value);
}

See Also

EllipseBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


DownOffset Property

[image]

.NET ModelKit Suite ClassReference
EllipseBevel..::.DownOffset Property
EllipseBevel Class See Also Send Feedback
Gets or sets the bevel inner effect offset.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double DownOffset { get; set; }
Visual Basic (Declaration)
Public Property DownOffset As Double
Visual C++
public:
property double DownOffset {
    double get ();
    void set (double value);
}

See Also

EllipseBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


DrawingStyle Property

[image]

.NET ModelKit Suite ClassReference
EllipseBevel..::.DrawingStyle Property
EllipseBevel Class See Also Send Feedback
Gets or sets EllipseBevelDrawingStyle which represents the bevel drawing style.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public EllipseBevelDrawingStyle DrawingStyle { get; set; }
Visual Basic (Declaration)
Public Property DrawingStyle As EllipseBevelDrawingStyle
Visual C++
public:
property EllipseBevelDrawingStyle DrawingStyle {
    EllipseBevelDrawingStyle get ();
    void set (EllipseBevelDrawingStyle value);
}

See Also

EllipseBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
EllipseBevel..::.Fill Property
EllipseBevel Class See Also Send Feedback
Gets or sets Fill which is used during the background drawing.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

EllipseBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Margins Property

[image]

.NET ModelKit Suite ClassReference
EllipseBevel..::.Margins Property
EllipseBevel Class See Also Send Feedback
Gets or sets Margins which sets margins.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Margins Margins { get; set; }
Visual Basic (Declaration)
Public Property Margins As Margins
Visual C++
public:
property Margins Margins {
    Margins get ();
    void set (Margins value);
}

See Also

EllipseBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Stroke Property

[image]

.NET ModelKit Suite ClassReference
EllipseBevel..::.Stroke Property
EllipseBevel Class See Also Send Feedback
Gets or sets Stroke which is used during the lines drawing.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Stroke Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Stroke
Visual C++
public:
property Stroke^ Stroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

EllipseBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


UpOffset Property

[image]

.NET ModelKit Suite ClassReference
EllipseBevel..::.UpOffset Property
EllipseBevel Class See Also Send Feedback
Gets or sets the bevel outer effect offset.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double UpOffset { get; set; }
Visual Basic (Declaration)
Public Property UpOffset As Double
Visual C++
public:
property double UpOffset {
    double get ();
    void set (double value);
}

See Also

EllipseBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


EllipseBevelDrawingStyle Enumeration

[image]

.NET ModelKit Suite ClassReference
EllipseBevelDrawingStyle Enumeration
See Also Send Feedback
Enumerates the ellipse bevel drawing effect types.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public enum EllipseBevelDrawingStyle
Visual Basic (Declaration)
Public Enumeration EllipseBevelDrawingStyle
Visual C++
public enum class EllipseBevelDrawingStyle

Members

Member name | Description
Sharp | Defines the sharp gradation.
Smooth | Defines the smooth gradation.

See Also

PerpetuumSoft.Instrumentation.Model Namespace


Frame Class

[image]

.NET ModelKit Suite ClassReference
Frame Class
Members See Also Send Feedback
Represents the frame.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Frame : RectangleElement
Visual Basic (Declaration)
Public Class Frame _
    Inherits RectangleElement
Visual C++
public ref class Frame : public RectangleElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement
PerpetuumSoft.Instrumentation.Model..::.RectangleElement
PerpetuumSoft.Instrumentation.Model..::.Frame

See Also

Frame Members
PerpetuumSoft.Instrumentation.Model Namespace


Frame Members

[image] [image]

.NET ModelKit Suite ClassReference
Frame Members
Frame Class Constructors Methods Properties Events See Also Send Feedback

The Frame type exposes the following members.

Constructors

Name | Description
Frame | Initializes a new instance of the Frame class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from RectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
BevelStyle | Gets or sets the style of frame.
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
DarkColor | Gets or sets the dark color of the frame.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
InnerColor | Gets or sets inner color of the frame.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
InternalBounds | Gets the internal bounds of the frame.
LightColor | Gets or sets the light color of the frame.
Name | Gets or sets the element's name. (Inherited from Element.)
OuterColor | Gets or sets outer color of the frame.
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Frame Class
PerpetuumSoft.Instrumentation.Model Namespace


Frame Constructor

[image]

.NET ModelKit Suite ClassReference
Frame Constructor
Frame Class See Also Send Feedback
Initializes a new instance of the Frame class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Frame()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Frame()

See Also

Frame Class
PerpetuumSoft.Instrumentation.Model Namespace


Frame Methods

[image] [image]

.NET ModelKit Suite ClassReference
Frame Methods
Frame Class See Also Send Feedback

The Frame type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from RectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Frame Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Frame..::.Dispose Method
Frame Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from RectangleElement.)

See Also

Frame Class
Frame Members
PerpetuumSoft.Instrumentation.Model Namespace


DrawContent Method

[image]

.NET ModelKit Suite ClassReference
Frame..::.DrawContent Method
Frame Class See Also Send Feedback
Overridden. See DrawContent(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void DrawContent(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Protected Overrides Sub DrawContent ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
protected:
virtual void DrawContent(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Frame Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Frame..::.GetStyle Method
Frame Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Frame Class
Frame Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Frame..::.Invalidate Method
Frame Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Frame Class
Frame Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Frame..::.OnPaint Method
Frame Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from RectangleElement.)

See Also

Frame Class
Frame Members
PerpetuumSoft.Instrumentation.Model Namespace


Frame Properties

[image] [image]

.NET ModelKit Suite ClassReference
Frame Properties
Frame Class See Also Send Feedback

The Frame type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
BevelStyle | Gets or sets the style of frame.
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
DarkColor | Gets or sets the dark color of the frame.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
InnerColor | Gets or sets inner color of the frame.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
InternalBounds | Gets the internal bounds of the frame.
LightColor | Gets or sets the light color of the frame.
Name | Gets or sets the element's name. (Inherited from Element.)
OuterColor | Gets or sets outer color of the frame.
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Frame Class
PerpetuumSoft.Instrumentation.Model Namespace


BevelStyle Property

[image]

.NET ModelKit Suite ClassReference
Frame..::.BevelStyle Property
Frame Class See Also Send Feedback
Gets or sets the style of frame.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public BevelStyle BevelStyle { get; set; }
Visual Basic (Declaration)
Public Property BevelStyle As BevelStyle
Visual C++
public:
property BevelStyle BevelStyle {
    BevelStyle get ();
    void set (BevelStyle value);
}

See Also

Frame Class
PerpetuumSoft.Instrumentation.Model Namespace


DarkColor Property

[image]

.NET ModelKit Suite ClassReference
Frame..::.DarkColor Property
Frame Class See Also Send Feedback
Gets or sets the dark color of the frame.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Color DarkColor { get; set; }
Visual Basic (Declaration)
Public Property DarkColor As Color
Visual C++
public:
property Color DarkColor {
    Color get ();
    void set (Color value);
}

See Also

Frame Class
PerpetuumSoft.Instrumentation.Model Namespace


InnerColor Property

[image]

.NET ModelKit Suite ClassReference
Frame..::.InnerColor Property
Frame Class See Also Send Feedback
Gets or sets inner color of the frame.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Color InnerColor { get; set; }
Visual Basic (Declaration)
Public Property InnerColor As Color
Visual C++
public:
property Color InnerColor {
    Color get ();
    void set (Color value);
}

See Also

Frame Class
PerpetuumSoft.Instrumentation.Model Namespace


InternalBounds Property

[image]

.NET ModelKit Suite ClassReference
Frame..::.InternalBounds Property
Frame Class See Also Send Feedback
Gets the internal bounds of the frame.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle InternalBounds { get; }
Visual Basic (Declaration)
Public ReadOnly Property InternalBounds As VectorRectangle
Visual C++
public:
property VectorRectangle InternalBounds {
    VectorRectangle get ();
}

See Also

Frame Class
PerpetuumSoft.Instrumentation.Model Namespace


LightColor Property

[image]

.NET ModelKit Suite ClassReference
Frame..::.LightColor Property
Frame Class See Also Send Feedback
Gets or sets the light color of the frame.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Color LightColor { get; set; }
Visual Basic (Declaration)
Public Property LightColor As Color
Visual C++
public:
property Color LightColor {
    Color get ();
    void set (Color value);
}

See Also

Frame Class
PerpetuumSoft.Instrumentation.Model Namespace


OuterColor Property

[image]

.NET ModelKit Suite ClassReference
Frame..::.OuterColor Property
Frame Class See Also Send Feedback
Gets or sets outer color of the frame.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Color OuterColor { get; set; }
Visual Basic (Declaration)
Public Property OuterColor As Color
Visual C++
public:
property Color OuterColor {
    Color get ();
    void set (Color value);
}

See Also

Frame Class
PerpetuumSoft.Instrumentation.Model Namespace


Frame Events

[image] [image]

.NET ModelKit Suite ClassReference
Frame Events
Frame Class See Also Send Feedback

The Frame type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Frame Class
PerpetuumSoft.Instrumentation.Model Namespace


Gear Class

[image]

.NET ModelKit Suite ClassReference
Gear Class
Members See Also Send Feedback
Represents Gear.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Gear : CircularShape
Visual Basic (Declaration)
Public Class Gear _
    Inherits CircularShape
Visual C++
public ref class Gear : public CircularShape

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.CircularShape
PerpetuumSoft.Instrumentation.Model..::.Gear

See Also

Gear Members
PerpetuumSoft.Instrumentation.Model Namespace


Gear Members

[image] [image]

.NET ModelKit Suite ClassReference
Gear Members
Gear Class Constructors Methods Properties Events See Also Send Feedback

The Gear type exposes the following members.

Constructors

Name | Description
Gear | Initializes a new instance of the Gear class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Gets or sets the angle by clockwize of the shape. (Inherited from CircularShape.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the shape. (Inherited from CircularShape.)
Count | Gets or sets count of edges.
Depth | Gets or sets size of an edge.
DimensionsRatio | Gets or sets dimensions ratio.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Radius | Gets or sets the radius of the shape. (Inherited from CircularShape.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Gear Class
PerpetuumSoft.Instrumentation.Model Namespace


Gear Constructor

[image]

.NET ModelKit Suite ClassReference
Gear Constructor
Gear Class See Also Send Feedback
Initializes a new instance of the Gear class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Gear()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Gear()

See Also

Gear Class
PerpetuumSoft.Instrumentation.Model Namespace


Gear Methods

[image] [image]

.NET ModelKit Suite ClassReference
Gear Methods
Gear Class See Also Send Feedback

The Gear type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Gear Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Gear..::.Dispose Method
Gear Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

Gear Class
Gear Members
PerpetuumSoft.Instrumentation.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
Gear..::.GetBoundedBox Method
Gear Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

Gear Class
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
Gear..::.GetHitTest Method
Gear Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Gear Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Gear..::.GetStyle Method
Gear Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Gear Class
Gear Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Gear..::.Invalidate Method
Gear Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Gear Class
Gear Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Gear..::.OnPaint Method
Gear Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

Gear Class
Gear Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
Gear..::.OnPaint Method (PaintArguments, Fill, Stroke)
Gear Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Gear Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


Gear Properties

[image] [image]

.NET ModelKit Suite ClassReference
Gear Properties
Gear Class See Also Send Feedback

The Gear type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Gets or sets the angle by clockwize of the shape. (Inherited from CircularShape.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the shape. (Inherited from CircularShape.)
Count | Gets or sets count of edges.
Depth | Gets or sets size of an edge.
DimensionsRatio | Gets or sets dimensions ratio.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Radius | Gets or sets the radius of the shape. (Inherited from CircularShape.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Gear Class
PerpetuumSoft.Instrumentation.Model Namespace


Count Property

[image]

.NET ModelKit Suite ClassReference
Gear..::.Count Property
Gear Class See Also Send Feedback
Gets or sets count of edges.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int Count { get; set; }
Visual Basic (Declaration)
Public Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
    void set (int value);
}

See Also

Gear Class
PerpetuumSoft.Instrumentation.Model Namespace


Depth Property

[image]

.NET ModelKit Suite ClassReference
Gear..::.Depth Property
Gear Class See Also Send Feedback
Gets or sets size of an edge.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Depth { get; set; }
Visual Basic (Declaration)
Public Property Depth As Double
Visual C++
public:
property double Depth {
    double get ();
    void set (double value);
}

See Also

Gear Class
PerpetuumSoft.Instrumentation.Model Namespace


DimensionsRatio Property

[image]

.NET ModelKit Suite ClassReference
Gear..::.DimensionsRatio Property
Gear Class See Also Send Feedback
Gets or sets dimensions ratio.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double DimensionsRatio { get; set; }
Visual Basic (Declaration)
Public Property DimensionsRatio As Double
Visual C++
public:
property double DimensionsRatio {
    double get ();
    void set (double value);
}

See Also

Gear Class
PerpetuumSoft.Instrumentation.Model Namespace


Gear Events

[image] [image]

.NET ModelKit Suite ClassReference
Gear Events
Gear Class See Also Send Feedback

The Gear type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Gear Class
PerpetuumSoft.Instrumentation.Model Namespace


Group Class

[image]

.NET ModelKit Suite ClassReference
Group Class
Members See Also Send Feedback
Represents the container for the group objects.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Group : Composite
Visual Basic (Declaration)
Public Class Group _
    Inherits Composite
Visual C++
public ref class Group : public Composite

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.Composite
PerpetuumSoft.Instrumentation.Model..::.Group

See Also

Group Members
PerpetuumSoft.Instrumentation.Model Namespace


Group Members

[image] [image]

.NET ModelKit Suite ClassReference
Group Members
Group Class Constructors Methods Properties Events See Also Send Feedback

The Group type exposes the following members.

Constructors

Name | Description
Group | Initializes a new instance of the Group class.

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smoothing will be applied.
Stroke | Gets or sets the Stroke object that is used to trace.
Style | Gets or sets name of the used style.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Group Class
PerpetuumSoft.Instrumentation.Model Namespace


Group Constructor

[image]

.NET ModelKit Suite ClassReference
Group Constructor
Group Class See Also Send Feedback
Initializes a new instance of the Group class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Group()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Group()

See Also

Group Class
PerpetuumSoft.Instrumentation.Model Namespace


Group Methods

[image] [image]

.NET ModelKit Suite ClassReference
Group Methods
Group Class See Also Send Feedback

The Group type exposes the following members.

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Group Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Group..::.Dispose Method
Group Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from Composite.)

See Also

Group Class
Group Members
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Group..::.GetStyle Method
Group Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Group Class
Group Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Group..::.Invalidate Method
Group Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Group Class
Group Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Group..::.OnPaint Method
Group Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Inherited from Composite.)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

Group Class
Group Members
PerpetuumSoft.Instrumentation.Model Namespace


Group Properties

[image] [image]

.NET ModelKit Suite ClassReference
Group Properties
Group Class See Also Send Feedback

The Group type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smoothing will be applied.
Stroke | Gets or sets the Stroke object that is used to trace.
Style | Gets or sets name of the used style.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Group Class
PerpetuumSoft.Instrumentation.Model Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
Group..::.Fill Property
Group Class See Also Send Feedback
Gets or sets the Fill object that is used to paint over.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

Group Class
PerpetuumSoft.Instrumentation.Model Namespace


Smooth Property

[image]

.NET ModelKit Suite ClassReference
Group..::.Smooth Property
Group Class See Also Send Feedback
Gets or sets value that indicates whether smoothing will be applied.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Smooth { get; set; }
Visual Basic (Declaration)
Public Property Smooth As Boolean
Visual C++
public:
property bool Smooth {
    bool get ();
    void set (bool value);
}

See Also

Group Class
PerpetuumSoft.Instrumentation.Model Namespace


Stroke Property

[image]

.NET ModelKit Suite ClassReference
Group..::.Stroke Property
Group Class See Also Send Feedback
Gets or sets the Stroke object that is used to trace.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Stroke Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Stroke
Visual C++
public:
property Stroke^ Stroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

Group Class
PerpetuumSoft.Instrumentation.Model Namespace


Style Property

[image]

.NET ModelKit Suite ClassReference
Group..::.Style Property
Group Class See Also Send Feedback
Gets or sets name of the used style.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string Style { get; set; }
Visual Basic (Declaration)
Public Property Style As String
Visual C++
public:
property String^ Style {
    String^ get ();
    void set (String^ value);
}

See Also

Group Class
PerpetuumSoft.Instrumentation.Model Namespace


Group Events

[image] [image]

.NET ModelKit Suite ClassReference
Group Events
Group Class See Also Send Feedback

The Group type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Group Class
PerpetuumSoft.Instrumentation.Model Namespace


Guide Class

[image]

.NET ModelKit Suite ClassReference
Guide Class
Members See Also Send Feedback
Represents the linear trajectory.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Guide : DockableTrajectoryBase
Visual Basic (Declaration)
Public Class Guide _
    Inherits DockableTrajectoryBase
Visual C++
public ref class Guide : public DockableTrajectoryBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.Composite
PerpetuumSoft.Instrumentation.Model..::.DockableTrajectoryBase
PerpetuumSoft.Instrumentation.Model..::.Guide

See Also

Guide Members
PerpetuumSoft.Instrumentation.Model Namespace


Guide Members

[image] [image]

.NET ModelKit Suite ClassReference
Guide Members
Guide Class Constructors Methods Properties Events See Also Send Feedback

The Guide type exposes the following members.

Constructors

Name | Description
Guide | Initializes a new instance of the Guide class.

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from DockableTrajectoryBase.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | Overridden. See ChildElementAdded(Element). (Overrides Composite..::.ChildElementAdded(Element).)
ChildElementRemoved | Overridden. See ChildElementRemoved(Element). (Overrides Composite..::.ChildElementRemoved(Element).)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetInsideSize | Returns inside size. (Inherited from DockableTrajectoryBase.)
GetObject | Implements GetObject(String). (Overrides Element..::.GetObject(String).)
GetOutsideSize | Returns outside size. (Inherited from DockableTrajectoryBase.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PercentToPoint | Overloaded.
PointToPercent | Overloaded.
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
RecalculatePosition | Overridden. See ['M:PerpetuumSoft.Instrumentation.Model.DockableTrajectoryBase.RecalculatePosition]. (Overrides DockableTrajectoryBase..::.RecalculatePosition()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Align | Gets or sets alignment.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Elements | Implements Elements. (Inherited from Composite.)
EndPoint | Gets or sets the end point of the trajectory.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object used to paint over. (Inherited from DockableTrajectoryBase.)
GuideDirection | Gets or sets guide direction.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Margins | Gets and sets Trajectory margins. (Inherited from DockableTrajectoryBase.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smoothing will be applied. (Inherited from DockableTrajectoryBase.)
StartDistance | Implements StartDistance. (Overrides DockableTrajectoryBase..::.StartDistance.)
StartPoint | Gets or sets the begin point of the trajectory.
Stroke | Gets or sets the Stroke object used to trace. (Inherited from DockableTrajectoryBase.)
Style | Gets or sets name of the used style. (Inherited from DockableTrajectoryBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Guide Class
PerpetuumSoft.Instrumentation.Model Namespace


Guide Constructor

[image]

.NET ModelKit Suite ClassReference
Guide Constructor
Guide Class See Also Send Feedback
Initializes a new instance of the Guide class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Guide()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Guide()

See Also

Guide Class
PerpetuumSoft.Instrumentation.Model Namespace


Guide Methods

[image] [image]

.NET ModelKit Suite ClassReference
Guide Methods
Guide Class See Also Send Feedback

The Guide type exposes the following members.

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from DockableTrajectoryBase.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | Overridden. See ChildElementAdded(Element). (Overrides Composite..::.ChildElementAdded(Element).)
ChildElementRemoved | Overridden. See ChildElementRemoved(Element). (Overrides Composite..::.ChildElementRemoved(Element).)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetInsideSize | Returns inside size. (Inherited from DockableTrajectoryBase.)
GetObject | Implements GetObject(String). (Overrides Element..::.GetObject(String).)
GetOutsideSize | Returns outside size. (Inherited from DockableTrajectoryBase.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PercentToPoint | Overloaded.
PointToPercent | Overloaded.
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
RecalculatePosition | Overridden. See ['M:PerpetuumSoft.Instrumentation.Model.DockableTrajectoryBase.RecalculatePosition]. (Overrides DockableTrajectoryBase..::.RecalculatePosition()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Guide Class
PerpetuumSoft.Instrumentation.Model Namespace


ChildElementAdded Method

[image]

.NET ModelKit Suite ClassReference
Guide..::.ChildElementAdded Method
Guide Class See Also Send Feedback
Overridden. See ChildElementAdded(Element).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void ChildElementAdded(
    Element element
)
Visual Basic (Declaration)
Protected Overrides Sub ChildElementAdded ( _
    element As Element _
)
Visual C++
protected:
virtual void ChildElementAdded(
    Element^ element
) override

Parameters

element
Type: PerpetuumSoft.Instrumentation.Model..::.Element

See Also

Guide Class
PerpetuumSoft.Instrumentation.Model Namespace


ChildElementRemoved Method

[image]

.NET ModelKit Suite ClassReference
Guide..::.ChildElementRemoved Method
Guide Class See Also Send Feedback
Overridden. See ChildElementRemoved(Element).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void ChildElementRemoved(
    Element element
)
Visual Basic (Declaration)
Protected Overrides Sub ChildElementRemoved ( _
    element As Element _
)
Visual C++
protected:
virtual void ChildElementRemoved(
    Element^ element
) override

Parameters

element
Type: PerpetuumSoft.Instrumentation.Model..::.Element

See Also

Guide Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Guide..::.Dispose Method
Guide Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from Composite.)

See Also

Guide Class
Guide Members
PerpetuumSoft.Instrumentation.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
Guide..::.GetBoundedBox Method
Guide Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

Guide Class
PerpetuumSoft.Instrumentation.Model Namespace


GetObject Method

[image]

.NET ModelKit Suite ClassReference
Guide..::.GetObject Method
Guide Class See Also Send Feedback
Implements GetObject(String).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Object GetObject(
    string name
)
Visual Basic (Declaration)
Public Overrides Function GetObject ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetObject(
    String^ name
) override

Parameters

name
Type: System..::.String

See Also

Guide Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Guide..::.GetStyle Method
Guide Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Guide Class
Guide Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Guide..::.Invalidate Method
Guide Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Guide Class
Guide Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Guide..::.OnPaint Method
Guide Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Inherited from Composite.)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

Guide Class
Guide Members
PerpetuumSoft.Instrumentation.Model Namespace


PercentToPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
Guide..::.PercentToPoint Method
Guide Class See Also Send Feedback

Overload List

Name | Description
PercentToPoint(Double, Double) | Implements PercentToPoint(Double, Double). (Overrides DockableTrajectoryBase..::.PercentToPoint(Double, Double).)
PercentToPoint(Vector, Vector, Double, Double) | Implements PointToPercent(Vector).

See Also

Guide Class
Guide Members
PerpetuumSoft.Instrumentation.Model Namespace


PercentToPoint Method (Double, Double)

[image]

.NET ModelKit Suite ClassReference
Guide..::.PercentToPoint Method (Double, Double)
Guide Class See Also Send Feedback
Implements PercentToPoint(Double, Double).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Vector PercentToPoint(
    double portion,
    double radius
)
Visual Basic (Declaration)
Public Overrides Function PercentToPoint ( _
    portion As Double, _
    radius As Double _
) As Vector
Visual C++
public:
virtual Vector PercentToPoint(
    double portion,
    double radius
) override

Parameters

portion
Type: System..::.Double
radius
Type: System..::.Double

Implements

ITrajectory..::.PercentToPoint(Double, Double)

See Also

Guide Class
PercentToPoint Overload
PerpetuumSoft.Instrumentation.Model Namespace


PercentToPoint Method (Vector, Vector, Double, Double)

[image]

.NET ModelKit Suite ClassReference
Guide..::.PercentToPoint Method (Vector, Vector, Double, Double)
Guide Class See Also Send Feedback
Implements PointToPercent(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static Vector PercentToPoint(
    Vector startPoint,
    Vector endPoint,
    double portion,
    double radius
)
Visual Basic (Declaration)
Public Shared Function PercentToPoint ( _
    startPoint As Vector, _
    endPoint As Vector, _
    portion As Double, _
    radius As Double _
) As Vector
Visual C++
public:
static Vector PercentToPoint(
    Vector startPoint,
    Vector endPoint,
    double portion,
    double radius
)

Parameters

startPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
endPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
portion
Type: System..::.Double
radius
Type: System..::.Double

See Also

Guide Class
PercentToPoint Overload
PerpetuumSoft.Instrumentation.Model Namespace


PointToPercent Method

[image] [image]

.NET ModelKit Suite ClassReference
Guide..::.PointToPercent Method
Guide Class See Also Send Feedback

Overload List

Name | Description
PointToPercent(Vector) | Implements PointToPercent(Vector). (Overrides DockableTrajectoryBase..::.PointToPercent(Vector).)
PointToPercent(Vector, Vector, Vector) | Implements PercentToPoint(Double, Double).

See Also

Guide Class
Guide Members
PerpetuumSoft.Instrumentation.Model Namespace


PointToPercent Method (Vector)

[image]

.NET ModelKit Suite ClassReference
Guide..::.PointToPercent Method (Vector)
Guide Class See Also Send Feedback
Implements PointToPercent(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override double PointToPercent(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function PointToPercent ( _
    point As Vector _
) As Double
Visual C++
public:
virtual double PointToPercent(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

Implements

ITrajectory..::.PointToPercent(Vector)

See Also

Guide Class
PointToPercent Overload
PerpetuumSoft.Instrumentation.Model Namespace


PointToPercent Method (Vector, Vector, Vector)

[image]

.NET ModelKit Suite ClassReference
Guide..::.PointToPercent Method (Vector, Vector, Vector)
Guide Class See Also Send Feedback
Implements PercentToPoint(Double, Double).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static double PointToPercent(
    Vector startPoint,
    Vector endPoint,
    Vector point
)
Visual Basic (Declaration)
Public Shared Function PointToPercent ( _
    startPoint As Vector, _
    endPoint As Vector, _
    point As Vector _
) As Double
Visual C++
public:
static double PointToPercent(
    Vector startPoint,
    Vector endPoint,
    Vector point
)

Parameters

startPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
endPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Guide Class
PointToPercent Overload
PerpetuumSoft.Instrumentation.Model Namespace


RecalculatePosition Method

[image]

.NET ModelKit Suite ClassReference
Guide..::.RecalculatePosition Method
Guide Class See Also Send Feedback
Overridden. See ['M:PerpetuumSoft.Instrumentation.Model.DockableTrajectoryBase.RecalculatePosition].

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void RecalculatePosition()
Visual Basic (Declaration)
Protected Overrides Sub RecalculatePosition
Visual C++
protected:
virtual void RecalculatePosition() override

See Also

Guide Class
PerpetuumSoft.Instrumentation.Model Namespace


Guide Properties

[image] [image]

.NET ModelKit Suite ClassReference
Guide Properties
Guide Class See Also Send Feedback

The Guide type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Align | Gets or sets alignment.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Elements | Implements Elements. (Inherited from Composite.)
EndPoint | Gets or sets the end point of the trajectory.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object used to paint over. (Inherited from DockableTrajectoryBase.)
GuideDirection | Gets or sets guide direction.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Margins | Gets and sets Trajectory margins. (Inherited from DockableTrajectoryBase.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smoothing will be applied. (Inherited from DockableTrajectoryBase.)
StartDistance | Implements StartDistance. (Overrides DockableTrajectoryBase..::.StartDistance.)
StartPoint | Gets or sets the begin point of the trajectory.
Stroke | Gets or sets the Stroke object used to trace. (Inherited from DockableTrajectoryBase.)
Style | Gets or sets name of the used style. (Inherited from DockableTrajectoryBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Guide Class
PerpetuumSoft.Instrumentation.Model Namespace


Align Property

[image]

.NET ModelKit Suite ClassReference
Guide..::.Align Property
Guide Class See Also Send Feedback
Gets or sets alignment.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Align Align { get; set; }
Visual Basic (Declaration)
Public Property Align As Align
Visual C++
public:
property Align Align {
    Align get ();
    void set (Align value);
}

See Also

Guide Class
PerpetuumSoft.Instrumentation.Model Namespace


EndPoint Property

[image]

.NET ModelKit Suite ClassReference
Guide..::.EndPoint Property
Guide Class See Also Send Feedback
Gets or sets the end point of the trajectory.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Vector EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As Vector
Visual C++
public:
property Vector EndPoint {
    Vector get ();
    void set (Vector value);
}

See Also

Guide Class
PerpetuumSoft.Instrumentation.Model Namespace


GuideDirection Property

[image]

.NET ModelKit Suite ClassReference
Guide..::.GuideDirection Property
Guide Class See Also Send Feedback
Gets or sets guide direction.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public GuideDirection GuideDirection { get; set; }
Visual Basic (Declaration)
Public Property GuideDirection As GuideDirection
Visual C++
public:
property GuideDirection GuideDirection {
    GuideDirection get ();
    void set (GuideDirection value);
}

See Also

Guide Class
PerpetuumSoft.Instrumentation.Model Namespace


StartDistance Property

[image]

.NET ModelKit Suite ClassReference
Guide..::.StartDistance Property
Guide Class See Also Send Feedback
Implements StartDistance.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override double StartDistance { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property StartDistance As Double
Visual C++
public:
virtual property double StartDistance {
    double get () override;
}

Implements

ITrajectory..::.StartDistance

See Also

Guide Class
PerpetuumSoft.Instrumentation.Model Namespace


StartPoint Property

[image]

.NET ModelKit Suite ClassReference
Guide..::.StartPoint Property
Guide Class See Also Send Feedback
Gets or sets the begin point of the trajectory.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Vector StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Vector
Visual C++
public:
property Vector StartPoint {
    Vector get ();
    void set (Vector value);
}

See Also

Guide Class
PerpetuumSoft.Instrumentation.Model Namespace


Guide Events

[image] [image]

.NET ModelKit Suite ClassReference
Guide Events
Guide Class See Also Send Feedback

The Guide type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Guide Class
PerpetuumSoft.Instrumentation.Model Namespace


GuideDirection Enumeration

[image]

.NET ModelKit Suite ClassReference
GuideDirection Enumeration
See Also Send Feedback
Enumerates the trajectory directions type.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public enum GuideDirection
Visual Basic (Declaration)
Public Enumeration GuideDirection
Visual C++
public enum class GuideDirection

Members

Member name | Description
Free | Specifies the arbitrary direction.
BottomToTop | Specifies direction from bottom to left.
TopToBottom | Specifies direction from top to bottom.
LeftToRight | Specifies direction from left to right.
RightToLeft | Specifies direction from right to left.

See Also

PerpetuumSoft.Instrumentation.Model Namespace


Highlight Class

[image]

.NET ModelKit Suite ClassReference
Highlight Class
Members See Also Send Feedback
Represents Highlight for dial instruments.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Highlight : CircularShape
Visual Basic (Declaration)
Public Class Highlight _
    Inherits CircularShape
Visual C++
public ref class Highlight : public CircularShape

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.CircularShape
PerpetuumSoft.Instrumentation.Model..::.Highlight

See Also

Highlight Members
PerpetuumSoft.Instrumentation.Model Namespace


Highlight Members

[image] [image]

.NET ModelKit Suite ClassReference
Highlight Members
Highlight Class Constructors Methods Properties Events See Also Send Feedback

The Highlight type exposes the following members.

Constructors

Name | Description
Highlight | Initializes a new instance of the Highlight class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Gets or sets the angle by clockwize of the shape. (Inherited from CircularShape.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the shape. (Inherited from CircularShape.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
K | Gets or sets coefficient assigning Highlight concavity.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Radius | Gets or sets the radius of the shape. (Inherited from CircularShape.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SweepAngle | Gets or sets sweep angle.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Highlight Class
PerpetuumSoft.Instrumentation.Model Namespace


Highlight Constructor

[image]

.NET ModelKit Suite ClassReference
Highlight Constructor
Highlight Class See Also Send Feedback
Initializes a new instance of the Highlight class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Highlight()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Highlight()

See Also

Highlight Class
PerpetuumSoft.Instrumentation.Model Namespace


Highlight Methods

[image] [image]

.NET ModelKit Suite ClassReference
Highlight Methods
Highlight Class See Also Send Feedback

The Highlight type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Highlight Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Highlight..::.Dispose Method
Highlight Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

Highlight Class
Highlight Members
PerpetuumSoft.Instrumentation.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
Highlight..::.GetBoundedBox Method
Highlight Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

Highlight Class
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
Highlight..::.GetHitTest Method
Highlight Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Highlight Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Highlight..::.GetStyle Method
Highlight Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Highlight Class
Highlight Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Highlight..::.Invalidate Method
Highlight Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Highlight Class
Highlight Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Highlight..::.OnPaint Method
Highlight Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

Highlight Class
Highlight Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
Highlight..::.OnPaint Method (PaintArguments, Fill, Stroke)
Highlight Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Highlight Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


Highlight Properties

[image] [image]

.NET ModelKit Suite ClassReference
Highlight Properties
Highlight Class See Also Send Feedback

The Highlight type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Gets or sets the angle by clockwize of the shape. (Inherited from CircularShape.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the shape. (Inherited from CircularShape.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
K | Gets or sets coefficient assigning Highlight concavity.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Radius | Gets or sets the radius of the shape. (Inherited from CircularShape.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SweepAngle | Gets or sets sweep angle.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Highlight Class
PerpetuumSoft.Instrumentation.Model Namespace


K Property

[image]

.NET ModelKit Suite ClassReference
Highlight..::.K Property
Highlight Class See Also Send Feedback
Gets or sets coefficient assigning Highlight concavity.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double K { get; set; }
Visual Basic (Declaration)
Public Property K As Double
Visual C++
public:
property double K {
    double get ();
    void set (double value);
}

See Also

Highlight Class
PerpetuumSoft.Instrumentation.Model Namespace


SweepAngle Property

[image]

.NET ModelKit Suite ClassReference
Highlight..::.SweepAngle Property
Highlight Class See Also Send Feedback
Gets or sets sweep angle.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double SweepAngle { get; set; }
Visual Basic (Declaration)
Public Property SweepAngle As Double
Visual C++
public:
property double SweepAngle {
    double get ();
    void set (double value);
}

See Also

Highlight Class
PerpetuumSoft.Instrumentation.Model Namespace


Highlight Events

[image] [image]

.NET ModelKit Suite ClassReference
Highlight Events
Highlight Class See Also Send Feedback

The Highlight type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Highlight Class
PerpetuumSoft.Instrumentation.Model Namespace


IDataContext Interface

[image]

.NET ModelKit Suite ClassReference
IDataContext Interface
Members See Also Send Feedback
Defines methods for data provision.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public interface IDataContext
Visual Basic (Declaration)
Public Interface IDataContext
Visual C++
public interface class IDataContext

See Also

IDataContext Members
PerpetuumSoft.Instrumentation.Model Namespace


IDataContext Members

[image] [image]

.NET ModelKit Suite ClassReference
IDataContext Members
IDataContext Interface Methods See Also Send Feedback

The IDataContext type exposes the following members.

Methods

Name | Description
GetDataList | Returns data object by its name.
GetDataListNames | Returns names of all available data sources.

See Also

IDataContext Interface
PerpetuumSoft.Instrumentation.Model Namespace


IDataContext Methods

[image] [image]

.NET ModelKit Suite ClassReference
IDataContext Methods
IDataContext Interface See Also Send Feedback

The IDataContext type exposes the following members.

Methods

Name | Description
GetDataList | Returns data object by its name.
GetDataListNames | Returns names of all available data sources.

See Also

IDataContext Interface
PerpetuumSoft.Instrumentation.Model Namespace


GetDataList Method

[image]

.NET ModelKit Suite ClassReference
IDataContext..::.GetDataList Method
IDataContext Interface See Also Send Feedback
Returns data object by its name.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
Object GetDataList(
    string name
)
Visual Basic (Declaration)
Function GetDataList ( _
    name As String _
) As Object
Visual C++
Object^ GetDataList(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

IDataContext Interface
PerpetuumSoft.Instrumentation.Model Namespace


GetDataListNames Method

[image]

.NET ModelKit Suite ClassReference
IDataContext..::.GetDataListNames Method
IDataContext Interface See Also Send Feedback
Returns names of all available data sources.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
string[] GetDataListNames()
Visual Basic (Declaration)
Function GetDataListNames As String()
Visual C++
array<String^>^ GetDataListNames()

See Also

IDataContext Interface
PerpetuumSoft.Instrumentation.Model Namespace


IDataReceiver Interface

[image]

.NET ModelKit Suite ClassReference
IDataReceiver Interface
Members See Also Send Feedback
Defines a method for data reciving.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public interface IDataReceiver
Visual Basic (Declaration)
Public Interface IDataReceiver
Visual C++
public interface class IDataReceiver

See Also

IDataReceiver Members
PerpetuumSoft.Instrumentation.Model Namespace


IDataReceiver Members

[image] [image]

.NET ModelKit Suite ClassReference
IDataReceiver Members
IDataReceiver Interface Methods See Also Send Feedback

The IDataReceiver type exposes the following members.

Methods

Name | Description
DataSourceChanged | Is executed if the data source was changed.

See Also

IDataReceiver Interface
PerpetuumSoft.Instrumentation.Model Namespace


IDataReceiver Methods

[image] [image]

.NET ModelKit Suite ClassReference
IDataReceiver Methods
IDataReceiver Interface See Also Send Feedback

The IDataReceiver type exposes the following members.

Methods

Name | Description
DataSourceChanged | Is executed if the data source was changed.

See Also

IDataReceiver Interface
PerpetuumSoft.Instrumentation.Model Namespace


DataSourceChanged Method

[image]

.NET ModelKit Suite ClassReference
IDataReceiver..::.DataSourceChanged Method
IDataReceiver Interface See Also Send Feedback
Is executed if the data source was changed.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
void DataSourceChanged()
Visual Basic (Declaration)
Sub DataSourceChanged
Visual C++
void DataSourceChanged()

See Also

IDataReceiver Interface
PerpetuumSoft.Instrumentation.Model Namespace


ILinkedSupported Interface

[image]

.NET ModelKit Suite ClassReference
ILinkedSupported Interface
Members See Also Send Feedback
Defines a method to bind the element to trajectory.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public interface ILinkedSupported
Visual Basic (Declaration)
Public Interface ILinkedSupported
Visual C++
public interface class ILinkedSupported

See Also

ILinkedSupported Members
PerpetuumSoft.Instrumentation.Model Namespace


ILinkedSupported Members

[image] [image]

.NET ModelKit Suite ClassReference
ILinkedSupported Members
ILinkedSupported Interface Methods See Also Send Feedback

The ILinkedSupported type exposes the following members.

Methods

Name | Description
GetRadius | Returns distance between the given point and trajectory.

See Also

ILinkedSupported Interface
PerpetuumSoft.Instrumentation.Model Namespace


ILinkedSupported Methods

[image] [image]

.NET ModelKit Suite ClassReference
ILinkedSupported Methods
ILinkedSupported Interface See Also Send Feedback

The ILinkedSupported type exposes the following members.

Methods

Name | Description
GetRadius | Returns distance between the given point and trajectory.

See Also

ILinkedSupported Interface
PerpetuumSoft.Instrumentation.Model Namespace


GetRadius Method

[image]

.NET ModelKit Suite ClassReference
ILinkedSupported..::.GetRadius Method
ILinkedSupported Interface See Also Send Feedback
Returns distance between the given point and trajectory.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
double GetRadius(
    Vector point
)
Visual Basic (Declaration)
Function GetRadius ( _
    point As Vector _
) As Double
Visual C++
double GetRadius(
    Vector point
)

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

ILinkedSupported Interface
PerpetuumSoft.Instrumentation.Model Namespace


ImageCollection Class

[image]

.NET ModelKit Suite ClassReference
ImageCollection Class
Members See Also Send Feedback
Represents the collection of the images.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class ImageCollection : CollectionBase
Visual Basic (Declaration)
Public Class ImageCollection _
    Inherits CollectionBase
Visual C++
public ref class ImageCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Instrumentation.Model..::.ImageCollection

See Also

ImageCollection Members
PerpetuumSoft.Instrumentation.Model Namespace


ImageCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
ImageCollection Members
ImageCollection Class Constructors Methods Properties Events See Also Send Feedback

The ImageCollection type exposes the following members.

Constructors

Name | Description
ImageCollection | Initializes a new instance of the ImageCollection class.

Methods

Name | Description
Add | Adds an image to the collection.
AddRange | Adds the images to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an image is in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded. Returns the zero-based index of the first occurrence of an image in the collection or in a portion of it.
Insert | Inserts an image into the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new image into the collection instance. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new image into the collection instance. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an image from the collection instance. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Overrides CollectionBase..::.OnValidate(Object).)
Remove | Removes the first occurrence of an image from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the image at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

Name | Description
ImageWrapChanged | Occurs when collection was changed.

See Also

ImageCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


ImageCollection Constructor

[image]

.NET ModelKit Suite ClassReference
ImageCollection Constructor
ImageCollection Class See Also Send Feedback
Initializes a new instance of the ImageCollection class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ImageCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ImageCollection()

See Also

ImageCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


ImageCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
ImageCollection Methods
ImageCollection Class See Also Send Feedback

The ImageCollection type exposes the following members.

Methods

Name | Description
Add | Adds an image to the collection.
AddRange | Adds the images to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether an image is in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded. Returns the zero-based index of the first occurrence of an image in the collection or in a portion of it.
Insert | Inserts an image into the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new image into the collection instance. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new image into the collection instance. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an image from the collection instance. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Overrides CollectionBase..::.OnValidate(Object).)
Remove | Removes the first occurrence of an image from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
ImageCollection..::.Add Method
ImageCollection Class See Also Send Feedback
Adds an image to the collection.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ImageWrap Add(
    ImageWrap value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As ImageWrap _
) As ImageWrap
Visual C++
public:
ImageWrap^ Add(
    ImageWrap^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model..::.ImageWrap

See Also

ImageCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
ImageCollection..::.AddRange Method
ImageCollection Class See Also Send Feedback
Adds the images to the collection.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    ImageWrap[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As ImageWrap() _
)
Visual C++
public:
void AddRange(
    array<ImageWrap^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Instrumentation.Model..::.ImageWrap >[]()[]

See Also

ImageCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
ImageCollection..::.Contains Method
ImageCollection Class See Also Send Feedback
Determines whether an image is in the collection.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    ImageWrap value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As ImageWrap _
) As Boolean
Visual C++
public:
bool Contains(
    ImageWrap^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model..::.ImageWrap

See Also

ImageCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
ImageCollection..::.IndexOf Method
ImageCollection Class See Also Send Feedback
Overloaded. Returns the zero-based index of the first occurrence of an image in the collection or in a portion of it.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    ImageWrap value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As ImageWrap _
) As Integer
Visual C++
public:
int IndexOf(
    ImageWrap^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model..::.ImageWrap

See Also

ImageCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
ImageCollection..::.Insert Method
ImageCollection Class See Also Send Feedback
Inserts an image into the collection at the specified index.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    ImageWrap value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As ImageWrap _
)
Visual C++
public:
void Insert(
    int index,
    ImageWrap^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Instrumentation.Model..::.ImageWrap

See Also

ImageCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


OnInsert Method

[image]

.NET ModelKit Suite ClassReference
ImageCollection..::.OnInsert Method
ImageCollection Class See Also Send Feedback
Performs additional custom processes before inserting a new image into the collection instance.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsert(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsert ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsert(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ImageCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


OnInsertComplete Method

[image]

.NET ModelKit Suite ClassReference
ImageCollection..::.OnInsertComplete Method
ImageCollection Class See Also Send Feedback
Performs additional custom processes after inserting a new image into the collection instance.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsertComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsertComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsertComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ImageCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


OnRemoveComplete Method

[image]

.NET ModelKit Suite ClassReference
ImageCollection..::.OnRemoveComplete Method
ImageCollection Class See Also Send Feedback
Performs additional custom processes after removing an image from the collection instance.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnRemoveComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemoveComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemoveComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ImageCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


OnValidate Method

[image]

.NET ModelKit Suite ClassReference
ImageCollection..::.OnValidate Method
ImageCollection Class See Also Send Feedback
Performs additional custom processes when validating a value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnValidate(
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnValidate ( _
    value As Object _
)
Visual C++
protected:
virtual void OnValidate(
    Object^ value
) override

Parameters

value
Type: System..::.Object

See Also

ImageCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
ImageCollection..::.Remove Method
ImageCollection Class See Also Send Feedback
Removes the first occurrence of an image from the collection.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    ImageWrap value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As ImageWrap _
)
Visual C++
public:
void Remove(
    ImageWrap^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model..::.ImageWrap

See Also

ImageCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


ImageCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
ImageCollection Properties
ImageCollection Class See Also Send Feedback

The ImageCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets or sets the image at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ImageCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
ImageCollection..::.Item Property
ImageCollection Class See Also Send Feedback
Gets or sets the image at the specified index.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ImageWrap this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As ImageWrap
Visual C++
public:
property ImageWrap^ default[int index] {
    ImageWrap^ get (int index);
    void set (int index, ImageWrap^ value);
}

Parameters

index
Type: System..::.Int32

See Also

ImageCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


ImageCollection Events

[image] [image]

.NET ModelKit Suite ClassReference
ImageCollection Events
ImageCollection Class See Also Send Feedback

The ImageCollection type exposes the following members.

Events

Name | Description
ImageWrapChanged | Occurs when collection was changed.

See Also

ImageCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


ImageWrapChanged Event

[image]

.NET ModelKit Suite ClassReference
ImageCollection..::.ImageWrapChanged Event
ImageCollection Class See Also Send Feedback
Occurs when collection was changed.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public event ImageCollection..::.CollectionChanged ImageWrapChanged
Visual Basic (Declaration)
Public Event ImageWrapChanged As ImageCollection..::.CollectionChanged
Visual C++
public:
 event ImageCollection..::.CollectionChanged^ ImageWrapChanged {
    void add (ImageCollection..::.CollectionChanged^ value);
    void remove (ImageCollection..::.CollectionChanged^ value);
}

See Also

ImageCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


ImageCollection.CollectionChanged Delegate

[image]

.NET ModelKit Suite ClassReference
ImageCollection..::.CollectionChanged Delegate
ImageCollection Class See Also Send Feedback
Represents the method that will handle the ImageAdded and ImageRemoved.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public delegate void CollectionChanged(
    ImageWrap image
)
Visual Basic (Declaration)
Public Delegate Sub CollectionChanged ( _
    image As ImageWrap _
)
Visual C++
public delegate void CollectionChanged(
    ImageWrap^ image
)

Parameters

image
Type: PerpetuumSoft.Instrumentation.Model..::.ImageWrap

See Also

PerpetuumSoft.Instrumentation.Model Namespace


ImageWrap Class

[image]

.NET ModelKit Suite ClassReference
ImageWrap Class
Members See Also Send Feedback
Represents the wrap for the image.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class ImageWrap : IDisposable
Visual Basic (Declaration)
Public Class ImageWrap _
    Implements IDisposable
Visual C++
public ref class ImageWrap : IDisposable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.ImageWrap

See Also

ImageWrap Members
PerpetuumSoft.Instrumentation.Model Namespace


ImageWrap Members

[image] [image]

.NET ModelKit Suite ClassReference
ImageWrap Members
ImageWrap Class Constructors Methods Properties See Also Send Feedback

The ImageWrap type exposes the following members.

Constructors

Name | Description
ImageWrap | Overloaded.

Methods

Name | Description
Dispose | Implements Dispose()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Image | Gets or sets image.

See Also

ImageWrap Class
PerpetuumSoft.Instrumentation.Model Namespace


ImageWrap Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ImageWrap Constructor
ImageWrap Class See Also Send Feedback

Overload List

Name | Description
ImageWrap()()() | Initializes a new instance of the ImageWrap class.
ImageWrap(Bitmap) | Initializes a new instance of the ImageWrap class.

See Also

ImageWrap Class
ImageWrap Members
PerpetuumSoft.Instrumentation.Model Namespace


ImageWrap Constructor

[image]

.NET ModelKit Suite ClassReference
ImageWrap Constructor
ImageWrap Class See Also Send Feedback
Initializes a new instance of the ImageWrap class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ImageWrap()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ImageWrap()

See Also

ImageWrap Class
ImageWrap Overload
PerpetuumSoft.Instrumentation.Model Namespace


ImageWrap Constructor (Bitmap)

[image]

.NET ModelKit Suite ClassReference
ImageWrap Constructor (Bitmap)
ImageWrap Class See Also Send Feedback
Initializes a new instance of the ImageWrap class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ImageWrap(
    Bitmap bitmap
)
Visual Basic (Declaration)
Public Sub New ( _
    bitmap As Bitmap _
)
Visual C++
public:
ImageWrap(
    Bitmap^ bitmap
)

Parameters

bitmap
Type: System.Drawing..::.Bitmap

See Also

ImageWrap Class
ImageWrap Overload
PerpetuumSoft.Instrumentation.Model Namespace


ImageWrap Methods

[image] [image]

.NET ModelKit Suite ClassReference
ImageWrap Methods
ImageWrap Class See Also Send Feedback

The ImageWrap type exposes the following members.

Methods

Name | Description
Dispose | Implements Dispose()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageWrap Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image]

.NET ModelKit Suite ClassReference
ImageWrap..::.Dispose Method
ImageWrap Class See Also Send Feedback
Implements Dispose()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

ImageWrap Class
PerpetuumSoft.Instrumentation.Model Namespace


ImageWrap Properties

[image] [image]

.NET ModelKit Suite ClassReference
ImageWrap Properties
ImageWrap Class See Also Send Feedback

The ImageWrap type exposes the following members.

Properties

Name | Description
Image | Gets or sets image.

See Also

ImageWrap Class
PerpetuumSoft.Instrumentation.Model Namespace


Image Property

[image]

.NET ModelKit Suite ClassReference
ImageWrap..::.Image Property
ImageWrap Class See Also Send Feedback
Gets or sets image.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Image Image { get; set; }
Visual Basic (Declaration)
Public Property Image As Image
Visual C++
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}

See Also

ImageWrap Class
PerpetuumSoft.Instrumentation.Model Namespace


Instrument Class

[image]

.NET ModelKit Suite ClassReference
Instrument Class
Members See Also Send Feedback
Represents the instrument.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Instrument : Composite, IRootElement,
    ISupportInitialize
Visual Basic (Declaration)
Public Class Instrument _
    Inherits Composite _
    Implements IRootElement, ISupportInitialize
Visual C++
public ref class Instrument : public Composite,
    IRootElement, ISupportInitialize

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.Composite
PerpetuumSoft.Instrumentation.Model..::.Instrument
PerpetuumSoft.Charts..::.Chart

See Also

Instrument Members
PerpetuumSoft.Instrumentation.Model Namespace


Instrument Members

[image] [image]

.NET ModelKit Suite ClassReference
Instrument Members
Instrument Class Constructors Methods Properties Events See Also Send Feedback

The Instrument type exposes the following members.

Constructors

Name | Description
Instrument | Initializes a new instance of the Instrument class.

Methods

Name | Description
BeginUpdate | Starts the group operations, where Invalidate method will be called once for the whole group.
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
CreateEmptyInstrument | Creates new empty instrument.
CreateImage | Overloaded.
CreateInstrumentDesignerForm | Creates specific instrument designer.
Dispose | Overloaded.
EndUpdate | Completes the group operations, where Invalidate method was called once for whole group.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetDockingBounds | Gets rectangular area in which the inner content will be located.
GetElementAt | Implements GetElementAt(Vector). (Overrides Composite..::.GetElementAt(Vector).)
GetFunction | Implements GetFunction(String). (Overrides Element..::.GetFunction(String).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Overrides Element..::.GetObject(String).)
GetParameterValue | Returns value of the instrument parameter by its name.
GetPropertyNames |
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Read | Overloaded.
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetDataSources | Resets selected data sources.
SaveAsImage | Overloaded.
SetParameterValue | Sets value of the instrument parameter by its name.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Write | Overloaded.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Bevel | Gets or sets Bevel which sets the drawing style of the bevel around the instrument.
Bounds | Gets the bounds of the instrument.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent.
CustomFunctions | Gets collection of user defined functions to use in expressions specially set for this instrument.
DataContext | Gets or sets IDataContext object for data provide.
DefaultStyleName |
Elements | Implements Elements. (Inherited from Composite.)
Enabled | Gets or sets whether the instrument handles the mouse events.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Focused | Gets or sets whether the instrument has the focus.
GridStep | Gets or sets the step of the grid in the design mode.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
IsFixed | Gets or sets the value which indicates that the instrument size is not changed.
MeasureUnit | Gets and sets the measure unit for the instrument.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
ShowGrid | Gets and sets whether the grid should be displayed in the design mode.
Size | Gets or sets the instrument size.
Smooth | Gets or sets value that indicates whether smoothing will be applied.
SnapToGrid | Gets and sets whether objects should be snapped to grid in the design mode.
Stroke | Gets or sets the Stroke object that is used to trace.
Style | Gets or sets the name of the used style. (Inherited from Element.)
StyleProvider |
Styles | Gets the collection of styles.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
Invalidated | Occurs after the element's display requires redrawing.
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


Instrument Constructor

[image]

.NET ModelKit Suite ClassReference
Instrument Constructor
Instrument Class See Also Send Feedback
Initializes a new instance of the Instrument class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Instrument()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Instrument()

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


Instrument Methods

[image] [image]

.NET ModelKit Suite ClassReference
Instrument Methods
Instrument Class See Also Send Feedback

The Instrument type exposes the following members.

Methods

Name | Description
BeginUpdate | Starts the group operations, where Invalidate method will be called once for the whole group.
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
CreateEmptyInstrument | Creates new empty instrument.
CreateImage | Overloaded.
CreateInstrumentDesignerForm | Creates specific instrument designer.
Dispose | Overloaded.
EndUpdate | Completes the group operations, where Invalidate method was called once for whole group.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetDockingBounds | Gets rectangular area in which the inner content will be located.
GetElementAt | Implements GetElementAt(Vector). (Overrides Composite..::.GetElementAt(Vector).)
GetFunction | Implements GetFunction(String). (Overrides Element..::.GetFunction(String).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Overrides Element..::.GetObject(String).)
GetParameterValue | Returns value of the instrument parameter by its name.
GetPropertyNames |
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Read | Overloaded.
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetDataSources | Resets selected data sources.
SaveAsImage | Overloaded.
SetParameterValue | Sets value of the instrument parameter by its name.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Write | Overloaded.

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


BeginUpdate Method

[image]

.NET ModelKit Suite ClassReference
Instrument..::.BeginUpdate Method
Instrument Class See Also Send Feedback
Starts the group operations, where Invalidate method will be called once for the whole group.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void BeginUpdate()
Visual Basic (Declaration)
Public Sub BeginUpdate
Visual C++
public:
void BeginUpdate()

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


CreateEmptyInstrument Method

[image]

.NET ModelKit Suite ClassReference
Instrument..::.CreateEmptyInstrument Method
Instrument Class See Also Send Feedback
Creates new empty instrument.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static Instrument CreateEmptyInstrument()
Visual Basic (Declaration)
Public Shared Function CreateEmptyInstrument As Instrument
Visual C++
public:
static Instrument^ CreateEmptyInstrument()

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


CreateImage Method

[image] [image]

.NET ModelKit Suite ClassReference
Instrument..::.CreateImage Method
Instrument Class See Also Send Feedback

Overload List

Name | Description
CreateImage()()() | Creates image.
CreateImage(Single) | Creates image with a given resolution.
CreateImage(Int32, Int32) | Creates image with a given size.
CreateImage(Single, Single) | Creates image with a given resolution and scale.
CreateImage(Int32, Int32, Single) | Creates image with a given size and scale.

See Also

Instrument Class
Instrument Members
PerpetuumSoft.Instrumentation.Model Namespace


CreateImage Method

[image]

.NET ModelKit Suite ClassReference
Instrument..::.CreateImage Method
Instrument Class See Also Send Feedback
Creates image.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Image CreateImage()
Visual Basic (Declaration)
Public Function CreateImage As Image
Visual C++
public:
Image^ CreateImage()

See Also

Instrument Class
CreateImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


CreateImage Method (Single)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.CreateImage Method (Single)
Instrument Class See Also Send Feedback
Creates image with a given resolution.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Image CreateImage(
    float resolution
)
Visual Basic (Declaration)
Public Function CreateImage ( _
    resolution As Single _
) As Image
Visual C++
public:
Image^ CreateImage(
    float resolution
)

Parameters

resolution
Type: System..::.Single

See Also

Instrument Class
CreateImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


CreateImage Method (Int32, Int32)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.CreateImage Method (Int32, Int32)
Instrument Class See Also Send Feedback
Creates image with a given size.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Image CreateImage(
    int width,
    int height
)
Visual Basic (Declaration)
Public Function CreateImage ( _
    width As Integer, _
    height As Integer _
) As Image
Visual C++
public:
Image^ CreateImage(
    int width,
    int height
)

Parameters

width
Type: System..::.Int32
height
Type: System..::.Int32

See Also

Instrument Class
CreateImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


CreateImage Method (Single, Single)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.CreateImage Method (Single, Single)
Instrument Class See Also Send Feedback
Creates image with a given resolution and scale.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Image CreateImage(
    float resolution,
    float scale
)
Visual Basic (Declaration)
Public Function CreateImage ( _
    resolution As Single, _
    scale As Single _
) As Image
Visual C++
public:
Image^ CreateImage(
    float resolution,
    float scale
)

Parameters

resolution
Type: System..::.Single
scale
Type: System..::.Single

See Also

Instrument Class
CreateImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


CreateImage Method (Int32, Int32, Single)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.CreateImage Method (Int32, Int32, Single)
Instrument Class See Also Send Feedback
Creates image with a given size and scale.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Image CreateImage(
    int width,
    int height,
    float scale
)
Visual Basic (Declaration)
Public Function CreateImage ( _
    width As Integer, _
    height As Integer, _
    scale As Single _
) As Image
Visual C++
public:
Image^ CreateImage(
    int width,
    int height,
    float scale
)

Parameters

width
Type: System..::.Int32
height
Type: System..::.Int32
scale
Type: System..::.Single

See Also

Instrument Class
CreateImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


CreateInstrumentDesignerForm Method

[image]

.NET ModelKit Suite ClassReference
Instrument..::.CreateInstrumentDesignerForm Method
Instrument Class See Also Send Feedback
Creates specific instrument designer.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static DesignerForm CreateInstrumentDesignerForm()
Visual Basic (Declaration)
Public Shared Function CreateInstrumentDesignerForm As DesignerForm
Visual C++
public:
static DesignerForm^ CreateInstrumentDesignerForm()

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Instrument..::.Dispose Method
Instrument Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from Composite.)

See Also

Instrument Class
Instrument Members
PerpetuumSoft.Instrumentation.Model Namespace


EndUpdate Method

[image]

.NET ModelKit Suite ClassReference
Instrument..::.EndUpdate Method
Instrument Class See Also Send Feedback
Completes the group operations, where Invalidate method was called once for whole group.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void EndUpdate()
Visual Basic (Declaration)
Public Sub EndUpdate
Visual C++
public:
void EndUpdate()

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
Instrument..::.GetBoundedBox Method
Instrument Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


GetDockingBounds Method

[image]

.NET ModelKit Suite ClassReference
Instrument..::.GetDockingBounds Method
Instrument Class See Also Send Feedback
Gets rectangular area in which the inner content will be located.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle GetDockingBounds()
Visual Basic (Declaration)
Public Function GetDockingBounds As VectorRectangle
Visual C++
public:
VectorRectangle GetDockingBounds()

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


GetElementAt Method

[image]

.NET ModelKit Suite ClassReference
Instrument..::.GetElementAt Method
Instrument Class See Also Send Feedback
Implements GetElementAt(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override IElement GetElementAt(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetElementAt ( _
    point As Vector _
) As IElement
Visual C++
public:
virtual IElement^ GetElementAt(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

Implements

IElement..::.GetElementAt(Vector)
IElement..::.GetElementAt(Vector)

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


GetFunction Method

[image]

.NET ModelKit Suite ClassReference
Instrument..::.GetFunction Method
Instrument Class See Also Send Feedback
Implements GetFunction(String).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override IFunction GetFunction(
    string name
)
Visual Basic (Declaration)
Public Overrides Function GetFunction ( _
    name As String _
) As IFunction
Visual C++
public:
virtual IFunction^ GetFunction(
    String^ name
) override

Parameters

name
Type: System..::.String

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


GetObject Method

[image]

.NET ModelKit Suite ClassReference
Instrument..::.GetObject Method
Instrument Class See Also Send Feedback
Implements GetObject(String).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Object GetObject(
    string name
)
Visual Basic (Declaration)
Public Overrides Function GetObject ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetObject(
    String^ name
) override

Parameters

name
Type: System..::.String

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


GetParameterValue Method

[image]

.NET ModelKit Suite ClassReference
Instrument..::.GetParameterValue Method
Instrument Class See Also Send Feedback
Returns value of the instrument parameter by its name.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Object GetParameterValue(
    string parameterName
)
Visual Basic (Declaration)
Public Function GetParameterValue ( _
    parameterName As String _
) As Object
Visual C++
public:
Object^ GetParameterValue(
    String^ parameterName
)

Parameters

parameterName
Type: System..::.String

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


GetPropertyNames Method

[image]

.NET ModelKit Suite ClassReference
Instrument..::.GetPropertyNames Method
Instrument Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.Instrument.GetPropertyNames(System.Object)]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string[] GetPropertyNames(
    Object obj
)
Visual Basic (Declaration)
Public Function GetPropertyNames ( _
    obj As Object _
) As String()
Visual C++
public:
array<String^>^ GetPropertyNames(
    Object^ obj
)

Parameters

obj
Type: System..::.Object

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Instrument..::.GetStyle Method
Instrument Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Overridden. See GetStyle(String). (Overrides Element..::.GetStyle(String).)

See Also

Instrument Class
Instrument Members
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method (String)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.GetStyle Method (String)
Instrument Class See Also Send Feedback
Overridden. See GetStyle(String).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Style GetStyle(
    string name
)
Visual Basic (Declaration)
Public Overrides Function GetStyle ( _
    name As String _
) As Style
Visual C++
public:
virtual Style^ GetStyle(
    String^ name
) override

Parameters

name
Type: System..::.String

See Also

Instrument Class
GetStyle Overload
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Instrument..::.Invalidate Method
Instrument Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Overrides Element..::.Invalidate()()().)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Overrides Element..::.Invalidate(VectorRectangle).)

See Also

Instrument Class
Instrument Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image]

.NET ModelKit Suite ClassReference
Instrument..::.Invalidate Method
Instrument Class See Also Send Feedback
Implements Invalidate()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void Invalidate()
Visual Basic (Declaration)
Public Overrides Sub Invalidate
Visual C++
public:
virtual void Invalidate() override

Implements

IElement..::.Invalidate()()()

See Also

Instrument Class
Invalidate Overload
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method (VectorRectangle)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.Invalidate Method (VectorRectangle)
Instrument Class See Also Send Feedback
Implements Invalidate(VectorRectangle).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void Invalidate(
    VectorRectangle rectangle
)
Visual Basic (Declaration)
Public Overrides Sub Invalidate ( _
    rectangle As VectorRectangle _
)
Visual C++
public:
virtual void Invalidate(
    VectorRectangle rectangle
) override

Parameters

rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

Implements

IElement..::.Invalidate(VectorRectangle)

See Also

Instrument Class
Invalidate Overload
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Instrument..::.OnPaint Method
Instrument Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Overrides Composite..::.OnPaint(PaintArguments).)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

Instrument Class
Instrument Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.OnPaint Method (PaintArguments)
Instrument Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

Instrument Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


Read Method

[image] [image]

.NET ModelKit Suite ClassReference
Instrument..::.Read Method
Instrument Class See Also Send Feedback

Overload List

Name | Description
Read(Stream) | Deserializes instrument from the given stream.
Read(String) | Deserializes instrument from the given filename.

See Also

Instrument Class
Instrument Members
PerpetuumSoft.Instrumentation.Model Namespace


Read Method (Stream)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.Read Method (Stream)
Instrument Class See Also Send Feedback
Deserializes instrument from the given stream.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static Instrument Read(
    Stream stream
)
Visual Basic (Declaration)
Public Shared Function Read ( _
    stream As Stream _
) As Instrument
Visual C++
public:
static Instrument^ Read(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

Instrument Class
Read Overload
PerpetuumSoft.Instrumentation.Model Namespace


Read Method (String)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.Read Method (String)
Instrument Class See Also Send Feedback
Deserializes instrument from the given filename.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static Instrument Read(
    string filename
)
Visual Basic (Declaration)
Public Shared Function Read ( _
    filename As String _
) As Instrument
Visual C++
public:
static Instrument^ Read(
    String^ filename
)

Parameters

filename
Type: System..::.String

See Also

Instrument Class
Read Overload
PerpetuumSoft.Instrumentation.Model Namespace


ResetDataSources Method

[image]

.NET ModelKit Suite ClassReference
Instrument..::.ResetDataSources Method
Instrument Class See Also Send Feedback
Resets selected data sources.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void ResetDataSources()
Visual Basic (Declaration)
Public Sub ResetDataSources
Visual C++
public:
void ResetDataSources()

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method

[image] [image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method
Instrument Class See Also Send Feedback

Overload List

Name | Description
SaveAsImage(Stream, PictureFormat) | Saves instrument as image to the given stream with given size, scale and PictureFormat.
SaveAsImage(Stream, Int32) | Saves instrument as JPEG image into given stream with given jpegQuality.
SaveAsImage(String, PictureFormat) | Saves instrument as image to the given filename with given PictureFormat.
SaveAsImage(String, Int32) | Saves instrument as JPEG image into given filename with given jpegQuality.
SaveAsImage(Stream, Single, PictureFormat) | Saves instrument as image to the given stream with given resolution and PictureFormat.
SaveAsImage(Stream, Single, Int32) | Saves instrument as JPEG image into given stream with given resolution and jpegQuality.
SaveAsImage(String, Single, PictureFormat) | Saves instrument as image to the given filename with given resolution and PictureFormat.
SaveAsImage(String, Single, Int32) | Saves instrument as JPEG image into given filename with given resolution and jpegQuality.
SaveAsImage(Stream, Int32, Int32, PictureFormat) | Saves instrument as image to the given filename with given size and PictureFormat.
SaveAsImage(Stream, Int32, Int32, Int32) | Saves instrument as JPEG image into given stream with given size and jpegQuality.
SaveAsImage(Stream, Single, Single, PictureFormat) | Saves instrument as image to the given stream with given resolution, scale and PictureFormat.
SaveAsImage(Stream, Single, Single, Int32) | Saves instrument as JPEG image into given stream with given resolution, scale and jpegQuality.
SaveAsImage(String, Int32, Int32, PictureFormat) | Saves instrument as image to a file with given name with given height, width and PictureFormat.
SaveAsImage(String, Int32, Int32, Int32) | Saves instrument as JPEG image into given filename with given size and jpegQuality.
SaveAsImage(String, Single, Single, PictureFormat) | Saves instrument as image to the given filename with given resolution, scale and PictureFormat.
SaveAsImage(String, Single, Single, Int32) | Saves instrument as JPEG image into given filename with given resolution, scale and jpegQuality.
SaveAsImage(Stream, Int32, Int32, Single, PictureFormat) | Saves instrument as image to the given stream with given size, scale and PictureFormat.
SaveAsImage(Stream, Int32, Int32, Single, Int32) | Saves instrument as JPEG image into given stream with given size, scale and jpegQuality.
SaveAsImage(String, Int32, Int32, Single, PictureFormat) | Saves instrument as image to a file with given name.
SaveAsImage(String, Int32, Int32, Single, Int32) | Saves instrument as JPEG image into given filename with given size, scale and jpegQuality.

See Also

Instrument Class
Instrument Members
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (Stream, PictureFormat)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (Stream, PictureFormat)
Instrument Class See Also Send Feedback
Saves instrument as image to the given stream with given size, scale and PictureFormat.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    Stream stream,
    PictureFormat format
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    stream As Stream, _
    format As PictureFormat _
)
Visual C++
public:
void SaveAsImage(
    Stream^ stream,
    PictureFormat format
)

Parameters

stream
Type: System.IO..::.Stream
format
Type: PerpetuumSoft.Framework.Drawing..::.PictureFormat

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (Stream, Int32)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (Stream, Int32)
Instrument Class See Also Send Feedback
Saves instrument as JPEG image into given stream with given jpegQuality.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    Stream stream,
    int jpegQuality
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    stream As Stream, _
    jpegQuality As Integer _
)
Visual C++
public:
void SaveAsImage(
    Stream^ stream,
    int jpegQuality
)

Parameters

stream
Type: System.IO..::.Stream
jpegQuality
Type: System..::.Int32

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (String, PictureFormat)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (String, PictureFormat)
Instrument Class See Also Send Feedback
Saves instrument as image to the given filename with given PictureFormat.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    string filename,
    PictureFormat format
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    filename As String, _
    format As PictureFormat _
)
Visual C++
public:
void SaveAsImage(
    String^ filename,
    PictureFormat format
)

Parameters

filename
Type: System..::.String
format
Type: PerpetuumSoft.Framework.Drawing..::.PictureFormat

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (String, Int32)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (String, Int32)
Instrument Class See Also Send Feedback
Saves instrument as JPEG image into given filename with given jpegQuality.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    string filename,
    int jpegQuality
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    filename As String, _
    jpegQuality As Integer _
)
Visual C++
public:
void SaveAsImage(
    String^ filename,
    int jpegQuality
)

Parameters

filename
Type: System..::.String
jpegQuality
Type: System..::.Int32

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (Stream, Single, PictureFormat)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (Stream, Single, PictureFormat)
Instrument Class See Also Send Feedback
Saves instrument as image to the given stream with given resolution and PictureFormat.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    Stream stream,
    float resolution,
    PictureFormat format
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    stream As Stream, _
    resolution As Single, _
    format As PictureFormat _
)
Visual C++
public:
void SaveAsImage(
    Stream^ stream,
    float resolution,
    PictureFormat format
)

Parameters

stream
Type: System.IO..::.Stream
resolution
Type: System..::.Single
format
Type: PerpetuumSoft.Framework.Drawing..::.PictureFormat

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (Stream, Single, Int32)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (Stream, Single, Int32)
Instrument Class See Also Send Feedback
Saves instrument as JPEG image into given stream with given resolution and jpegQuality.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    Stream stream,
    float resolution,
    int jpegQuality
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    stream As Stream, _
    resolution As Single, _
    jpegQuality As Integer _
)
Visual C++
public:
void SaveAsImage(
    Stream^ stream,
    float resolution,
    int jpegQuality
)

Parameters

stream
Type: System.IO..::.Stream
resolution
Type: System..::.Single
jpegQuality
Type: System..::.Int32

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (String, Single, PictureFormat)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (String, Single, PictureFormat)
Instrument Class See Also Send Feedback
Saves instrument as image to the given filename with given resolution and PictureFormat.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    string filename,
    float resolution,
    PictureFormat format
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    filename As String, _
    resolution As Single, _
    format As PictureFormat _
)
Visual C++
public:
void SaveAsImage(
    String^ filename,
    float resolution,
    PictureFormat format
)

Parameters

filename
Type: System..::.String
resolution
Type: System..::.Single
format
Type: PerpetuumSoft.Framework.Drawing..::.PictureFormat

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (String, Single, Int32)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (String, Single, Int32)
Instrument Class See Also Send Feedback
Saves instrument as JPEG image into given filename with given resolution and jpegQuality.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    string filename,
    float resolution,
    int jpegQuality
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    filename As String, _
    resolution As Single, _
    jpegQuality As Integer _
)
Visual C++
public:
void SaveAsImage(
    String^ filename,
    float resolution,
    int jpegQuality
)

Parameters

filename
Type: System..::.String
resolution
Type: System..::.Single
jpegQuality
Type: System..::.Int32

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (Stream, Int32, Int32, PictureFormat)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (Stream, Int32, Int32, PictureFormat)
Instrument Class See Also Send Feedback
Saves instrument as image to the given filename with given size and PictureFormat.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    Stream stream,
    int width,
    int height,
    PictureFormat format
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    stream As Stream, _
    width As Integer, _
    height As Integer, _
    format As PictureFormat _
)
Visual C++
public:
void SaveAsImage(
    Stream^ stream,
    int width,
    int height,
    PictureFormat format
)

Parameters

stream
Type: System.IO..::.Stream
width
Type: System..::.Int32
height
Type: System..::.Int32
format
Type: PerpetuumSoft.Framework.Drawing..::.PictureFormat

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (Stream, Int32, Int32, Int32)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (Stream, Int32, Int32, Int32)
Instrument Class See Also Send Feedback
Saves instrument as JPEG image into given stream with given size and jpegQuality.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    Stream stream,
    int width,
    int height,
    int jpegQuality
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    stream As Stream, _
    width As Integer, _
    height As Integer, _
    jpegQuality As Integer _
)
Visual C++
public:
void SaveAsImage(
    Stream^ stream,
    int width,
    int height,
    int jpegQuality
)

Parameters

stream
Type: System.IO..::.Stream
width
Type: System..::.Int32
height
Type: System..::.Int32
jpegQuality
Type: System..::.Int32

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (Stream, Single, Single, PictureFormat)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (Stream, Single, Single, PictureFormat)
Instrument Class See Also Send Feedback
Saves instrument as image to the given stream with given resolution, scale and PictureFormat.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    Stream stream,
    float resolution,
    float scale,
    PictureFormat format
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    stream As Stream, _
    resolution As Single, _
    scale As Single, _
    format As PictureFormat _
)
Visual C++
public:
void SaveAsImage(
    Stream^ stream,
    float resolution,
    float scale,
    PictureFormat format
)

Parameters

stream
Type: System.IO..::.Stream
resolution
Type: System..::.Single
scale
Type: System..::.Single
format
Type: PerpetuumSoft.Framework.Drawing..::.PictureFormat

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (Stream, Single, Single, Int32)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (Stream, Single, Single, Int32)
Instrument Class See Also Send Feedback
Saves instrument as JPEG image into given stream with given resolution, scale and jpegQuality.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    Stream stream,
    float resolution,
    float scale,
    int jpegQuality
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    stream As Stream, _
    resolution As Single, _
    scale As Single, _
    jpegQuality As Integer _
)
Visual C++
public:
void SaveAsImage(
    Stream^ stream,
    float resolution,
    float scale,
    int jpegQuality
)

Parameters

stream
Type: System.IO..::.Stream
resolution
Type: System..::.Single
scale
Type: System..::.Single
jpegQuality
Type: System..::.Int32

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (String, Int32, Int32, PictureFormat)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (String, Int32, Int32, PictureFormat)
Instrument Class See Also Send Feedback
Saves instrument as image to a file with given name with given height, width and PictureFormat.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    string filename,
    int width,
    int height,
    PictureFormat format
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    filename As String, _
    width As Integer, _
    height As Integer, _
    format As PictureFormat _
)
Visual C++
public:
void SaveAsImage(
    String^ filename,
    int width,
    int height,
    PictureFormat format
)

Parameters

filename
Type: System..::.String
width
Type: System..::.Int32
height
Type: System..::.Int32
format
Type: PerpetuumSoft.Framework.Drawing..::.PictureFormat

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (String, Int32, Int32, Int32)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (String, Int32, Int32, Int32)
Instrument Class See Also Send Feedback
Saves instrument as JPEG image into given filename with given size and jpegQuality.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    string filename,
    int width,
    int height,
    int jpegQuality
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    filename As String, _
    width As Integer, _
    height As Integer, _
    jpegQuality As Integer _
)
Visual C++
public:
void SaveAsImage(
    String^ filename,
    int width,
    int height,
    int jpegQuality
)

Parameters

filename
Type: System..::.String
width
Type: System..::.Int32
height
Type: System..::.Int32
jpegQuality
Type: System..::.Int32

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (String, Single, Single, PictureFormat)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (String, Single, Single, PictureFormat)
Instrument Class See Also Send Feedback
Saves instrument as image to the given filename with given resolution, scale and PictureFormat.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    string filename,
    float resolution,
    float scale,
    PictureFormat format
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    filename As String, _
    resolution As Single, _
    scale As Single, _
    format As PictureFormat _
)
Visual C++
public:
void SaveAsImage(
    String^ filename,
    float resolution,
    float scale,
    PictureFormat format
)

Parameters

filename
Type: System..::.String
resolution
Type: System..::.Single
scale
Type: System..::.Single
format
Type: PerpetuumSoft.Framework.Drawing..::.PictureFormat

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (String, Single, Single, Int32)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (String, Single, Single, Int32)
Instrument Class See Also Send Feedback
Saves instrument as JPEG image into given filename with given resolution, scale and jpegQuality.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    string filename,
    float resolution,
    float scale,
    int jpegQuality
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    filename As String, _
    resolution As Single, _
    scale As Single, _
    jpegQuality As Integer _
)
Visual C++
public:
void SaveAsImage(
    String^ filename,
    float resolution,
    float scale,
    int jpegQuality
)

Parameters

filename
Type: System..::.String
resolution
Type: System..::.Single
scale
Type: System..::.Single
jpegQuality
Type: System..::.Int32

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (Stream, Int32, Int32, Single, PictureFormat)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (Stream, Int32, Int32, Single, PictureFormat)
Instrument Class See Also Send Feedback
Saves instrument as image to the given stream with given size, scale and PictureFormat.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    Stream stream,
    int width,
    int height,
    float scale,
    PictureFormat format
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    stream As Stream, _
    width As Integer, _
    height As Integer, _
    scale As Single, _
    format As PictureFormat _
)
Visual C++
public:
void SaveAsImage(
    Stream^ stream,
    int width,
    int height,
    float scale,
    PictureFormat format
)

Parameters

stream
Type: System.IO..::.Stream
width
Type: System..::.Int32
height
Type: System..::.Int32
scale
Type: System..::.Single
format
Type: PerpetuumSoft.Framework.Drawing..::.PictureFormat

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (Stream, Int32, Int32, Single, Int32)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (Stream, Int32, Int32, Single, Int32)
Instrument Class See Also Send Feedback
Saves instrument as JPEG image into given stream with given size, scale and jpegQuality.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    Stream stream,
    int width,
    int height,
    float scale,
    int jpegQuality
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    stream As Stream, _
    width As Integer, _
    height As Integer, _
    scale As Single, _
    jpegQuality As Integer _
)
Visual C++
public:
void SaveAsImage(
    Stream^ stream,
    int width,
    int height,
    float scale,
    int jpegQuality
)

Parameters

stream
Type: System.IO..::.Stream
width
Type: System..::.Int32
height
Type: System..::.Int32
scale
Type: System..::.Single
jpegQuality
Type: System..::.Int32

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (String, Int32, Int32, Single, PictureFormat)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (String, Int32, Int32, Single, PictureFormat)
Instrument Class See Also Send Feedback
Saves instrument as image to a file with given name.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    string filename,
    int width,
    int height,
    float scale,
    PictureFormat format
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    filename As String, _
    width As Integer, _
    height As Integer, _
    scale As Single, _
    format As PictureFormat _
)
Visual C++
public:
void SaveAsImage(
    String^ filename,
    int width,
    int height,
    float scale,
    PictureFormat format
)

Parameters

filename
Type: System..::.String
width
Type: System..::.Int32
height
Type: System..::.Int32
scale
Type: System..::.Single
format
Type: PerpetuumSoft.Framework.Drawing..::.PictureFormat

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SaveAsImage Method (String, Int32, Int32, Single, Int32)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SaveAsImage Method (String, Int32, Int32, Single, Int32)
Instrument Class See Also Send Feedback
Saves instrument as JPEG image into given filename with given size, scale and jpegQuality.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SaveAsImage(
    string filename,
    int width,
    int height,
    float scale,
    int jpegQuality
)
Visual Basic (Declaration)
Public Sub SaveAsImage ( _
    filename As String, _
    width As Integer, _
    height As Integer, _
    scale As Single, _
    jpegQuality As Integer _
)
Visual C++
public:
void SaveAsImage(
    String^ filename,
    int width,
    int height,
    float scale,
    int jpegQuality
)

Parameters

filename
Type: System..::.String
width
Type: System..::.Int32
height
Type: System..::.Int32
scale
Type: System..::.Single
jpegQuality
Type: System..::.Int32

See Also

Instrument Class
SaveAsImage Overload
PerpetuumSoft.Instrumentation.Model Namespace


SetParameterValue Method

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SetParameterValue Method
Instrument Class See Also Send Feedback
Sets value of the instrument parameter by its name.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void SetParameterValue(
    string parameterName,
    Object parameterValue
)
Visual Basic (Declaration)
Public Sub SetParameterValue ( _
    parameterName As String, _
    parameterValue As Object _
)
Visual C++
public:
void SetParameterValue(
    String^ parameterName,
    Object^ parameterValue
)

Parameters

parameterName
Type: System..::.String
parameterValue
Type: System..::.Object

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


Write Method

[image] [image]

.NET ModelKit Suite ClassReference
Instrument..::.Write Method
Instrument Class See Also Send Feedback

Overload List

Name | Description
Write(Stream) | Serializes instrument into given stream.
Write(String) | Serializes instrument into given filename.

See Also

Instrument Class
Instrument Members
PerpetuumSoft.Instrumentation.Model Namespace


Write Method (Stream)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.Write Method (Stream)
Instrument Class See Also Send Feedback
Serializes instrument into given stream.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void Write(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Write ( _
    stream As Stream _
)
Visual C++
public:
void Write(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

Instrument Class
Write Overload
PerpetuumSoft.Instrumentation.Model Namespace


Write Method (String)

[image]

.NET ModelKit Suite ClassReference
Instrument..::.Write Method (String)
Instrument Class See Also Send Feedback
Serializes instrument into given filename.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void Write(
    string filename
)
Visual Basic (Declaration)
Public Sub Write ( _
    filename As String _
)
Visual C++
public:
void Write(
    String^ filename
)

Parameters

filename
Type: System..::.String

See Also

Instrument Class
Write Overload
PerpetuumSoft.Instrumentation.Model Namespace


Instrument Properties

[image] [image]

.NET ModelKit Suite ClassReference
Instrument Properties
Instrument Class See Also Send Feedback

The Instrument type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Bevel | Gets or sets Bevel which sets the drawing style of the bevel around the instrument.
Bounds | Gets the bounds of the instrument.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent.
CustomFunctions | Gets collection of user defined functions to use in expressions specially set for this instrument.
DataContext | Gets or sets IDataContext object for data provide.
DefaultStyleName |
Elements | Implements Elements. (Inherited from Composite.)
Enabled | Gets or sets whether the instrument handles the mouse events.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Focused | Gets or sets whether the instrument has the focus.
GridStep | Gets or sets the step of the grid in the design mode.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
IsFixed | Gets or sets the value which indicates that the instrument size is not changed.
MeasureUnit | Gets and sets the measure unit for the instrument.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
ShowGrid | Gets and sets whether the grid should be displayed in the design mode.
Size | Gets or sets the instrument size.
Smooth | Gets or sets value that indicates whether smoothing will be applied.
SnapToGrid | Gets and sets whether objects should be snapped to grid in the design mode.
Stroke | Gets or sets the Stroke object that is used to trace.
Style | Gets or sets the name of the used style. (Inherited from Element.)
StyleProvider |
Styles | Gets the collection of styles.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


Bevel Property

[image]

.NET ModelKit Suite ClassReference
Instrument..::.Bevel Property
Instrument Class See Also Send Feedback
Gets or sets Bevel which sets the drawing style of the bevel around the instrument.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Bevel Bevel { get; set; }
Visual Basic (Declaration)
Public Property Bevel As Bevel
Visual C++
public:
property Bevel^ Bevel {
    Bevel^ get ();
    void set (Bevel^ value);
}

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


Bounds Property

[image]

.NET ModelKit Suite ClassReference
Instrument..::.Bounds Property
Instrument Class See Also Send Feedback
Gets the bounds of the instrument.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle Bounds { get; }
Visual Basic (Declaration)
Public ReadOnly Property Bounds As VectorRectangle
Visual C++
public:
property VectorRectangle Bounds {
    VectorRectangle get ();
}

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


BreakEventsBubbling Property

[image]

.NET ModelKit Suite ClassReference
Instrument..::.BreakEventsBubbling Property
Instrument Class See Also Send Feedback
Gets or sets value that indicates whether events will be passed to parent.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool BreakEventsBubbling { get; set; }
Visual Basic (Declaration)
Public Property BreakEventsBubbling As Boolean
Visual C++
public:
property bool BreakEventsBubbling {
    bool get ();
    void set (bool value);
}

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


CustomFunctions Property

[image]

.NET ModelKit Suite ClassReference
Instrument..::.CustomFunctions Property
Instrument Class See Also Send Feedback
Gets collection of user defined functions to use in expressions specially set for this instrument.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Dictionary<string, IFunction> CustomFunctions { get; }
Visual Basic (Declaration)
Public ReadOnly Property CustomFunctions As Dictionary(Of String, IFunction)
Visual C++
public:
property Dictionary<String^, IFunction^>^ CustomFunctions {
    Dictionary<String^, IFunction^>^ get ();
}

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


DataContext Property

[image]

.NET ModelKit Suite ClassReference
Instrument..::.DataContext Property
Instrument Class See Also Send Feedback
Gets or sets IDataContext object for data provide.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public IDataContext DataContext { get; set; }
Visual Basic (Declaration)
Public Property DataContext As IDataContext
Visual C++
public:
property IDataContext^ DataContext {
    IDataContext^ get ();
    void set (IDataContext^ value);
}

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


DefaultStyleName Property

[image]

.NET ModelKit Suite ClassReference
Instrument..::.DefaultStyleName Property
Instrument Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Instrumentation.Model.Instrument.DefaultStyleName]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static string DefaultStyleName { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DefaultStyleName As String
Visual C++
public:
static property String^ DefaultStyleName {
    String^ get ();
}

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


Enabled Property

[image]

.NET ModelKit Suite ClassReference
Instrument..::.Enabled Property
Instrument Class See Also Send Feedback
Gets or sets whether the instrument handles the mouse events.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


Focused Property

[image]

.NET ModelKit Suite ClassReference
Instrument..::.Focused Property
Instrument Class See Also Send Feedback
Gets or sets whether the instrument has the focus.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Focused { get; set; }
Visual Basic (Declaration)
Public Property Focused As Boolean
Visual C++
public:
property bool Focused {
    bool get ();
    void set (bool value);
}

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


GridStep Property

[image]

.NET ModelKit Suite ClassReference
Instrument..::.GridStep Property
Instrument Class See Also Send Feedback
Gets or sets the step of the grid in the design mode.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double GridStep { get; set; }
Visual Basic (Declaration)
Public Property GridStep As Double
Visual C++
public:
property double GridStep {
    double get ();
    void set (double value);
}

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


IsFixed Property

[image]

.NET ModelKit Suite ClassReference
Instrument..::.IsFixed Property
Instrument Class See Also Send Feedback
Gets or sets the value which indicates that the instrument size is not changed.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool IsFixed { get; set; }
Visual Basic (Declaration)
Public Property IsFixed As Boolean
Visual C++
public:
property bool IsFixed {
    bool get ();
    void set (bool value);
}

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


MeasureUnit Property

[image]

.NET ModelKit Suite ClassReference
Instrument..::.MeasureUnit Property
Instrument Class See Also Send Feedback
Gets and sets the measure unit for the instrument.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Unit MeasureUnit { get; set; }
Visual Basic (Declaration)
Public Property MeasureUnit As Unit
Visual C++
public:
property Unit MeasureUnit {
    Unit get ();
    void set (Unit value);
}

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


ShowGrid Property

[image]

.NET ModelKit Suite ClassReference
Instrument..::.ShowGrid Property
Instrument Class See Also Send Feedback
Gets and sets whether the grid should be displayed in the design mode.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowGrid { get; set; }
Visual Basic (Declaration)
Public Property ShowGrid As Boolean
Visual C++
public:
property bool ShowGrid {
    bool get ();
    void set (bool value);
}

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


Size Property

[image]

.NET ModelKit Suite ClassReference
Instrument..::.Size Property
Instrument Class See Also Send Feedback
Gets or sets the instrument size.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Vector Size { get; set; }
Visual Basic (Declaration)
Public Property Size As Vector
Visual C++
public:
property Vector Size {
    Vector get ();
    void set (Vector value);
}

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


Smooth Property

[image]

.NET ModelKit Suite ClassReference
Instrument..::.Smooth Property
Instrument Class See Also Send Feedback
Gets or sets value that indicates whether smoothing will be applied.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Smooth { get; set; }
Visual Basic (Declaration)
Public Property Smooth As Boolean
Visual C++
public:
property bool Smooth {
    bool get ();
    void set (bool value);
}

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


SnapToGrid Property

[image]

.NET ModelKit Suite ClassReference
Instrument..::.SnapToGrid Property
Instrument Class See Also Send Feedback
Gets and sets whether objects should be snapped to grid in the design mode.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool SnapToGrid { get; set; }
Visual Basic (Declaration)
Public Property SnapToGrid As Boolean
Visual C++
public:
property bool SnapToGrid {
    bool get ();
    void set (bool value);
}

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


Stroke Property

[image]

.NET ModelKit Suite ClassReference
Instrument..::.Stroke Property
Instrument Class See Also Send Feedback
Gets or sets the Stroke object that is used to trace.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Stroke Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Stroke
Visual C++
public:
property Stroke^ Stroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


StyleProvider Property

[image]

.NET ModelKit Suite ClassReference
Instrument..::.StyleProvider Property
Instrument Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Instrumentation.Model.Instrument.StyleProvider]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public IStyleService StyleProvider { get; set; }
Visual Basic (Declaration)
Public Property StyleProvider As IStyleService
Visual C++
public:
property IStyleService^ StyleProvider {
    IStyleService^ get ();
    void set (IStyleService^ value);
}

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


Styles Property

[image]

.NET ModelKit Suite ClassReference
Instrument..::.Styles Property
Instrument Class See Also Send Feedback
Gets the collection of styles.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public StyleCollection Styles { get; }
Visual Basic (Declaration)
Public ReadOnly Property Styles As StyleCollection
Visual C++
public:
property StyleCollection^ Styles {
    StyleCollection^ get ();
}

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


Instrument Events

[image] [image]

.NET ModelKit Suite ClassReference
Instrument Events
Instrument Class See Also Send Feedback

The Instrument type exposes the following members.

Events

Name | Description
Invalidated | Occurs after the element's display requires redrawing.
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


Invalidated Event

[image]

.NET ModelKit Suite ClassReference
Instrument..::.Invalidated Event
Instrument Class See Also Send Feedback
Occurs after the element's display requires redrawing.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public event InvalidateEventHandler Invalidated
Visual Basic (Declaration)
Public Event Invalidated As InvalidateEventHandler
Visual C++
public:
virtual  event InvalidateEventHandler^ Invalidated {
    void add (InvalidateEventHandler^ value);
    void remove (InvalidateEventHandler^ value);
}

Implements

IRootElement..::.Invalidated

See Also

Instrument Class
PerpetuumSoft.Instrumentation.Model Namespace


IScale Interface

[image]

.NET ModelKit Suite ClassReference
IScale Interface
Members See Also Send Feedback
Main interface for scale.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public interface IScale
Visual Basic (Declaration)
Public Interface IScale
Visual C++
public interface class IScale

See Also

IScale Members
PerpetuumSoft.Instrumentation.Model Namespace


IScale Members

[image] [image]

.NET ModelKit Suite ClassReference
IScale Members
IScale Interface Methods Properties See Also Send Feedback

The IScale type exposes the following members.

Methods

Name | Description
FromRealValue | Returns scale value by source data value.
GetDiscreteValue | Returnы discrete value by index.
GetDiscreteValuesCount | Returnы count of discrete values.
PercentToValue | Converts percentage to value.
PointToValue | Converts point to value.
ToRealValue | Returns source data value by its scale value.
ValueToPercent | Converts value to percentage.
ValueToPoint | Converts value to point.

Properties

Name | Description
Colorizer | Gets Colorizer object that is used for scale elements colouring.
IsDiscrete | Gets value indicating that this scale is discrete.
Maximum | Gets or sets maximum value.
Minimum | Gets or sets minimum value.

See Also

IScale Interface
PerpetuumSoft.Instrumentation.Model Namespace


IScale Methods

[image] [image]

.NET ModelKit Suite ClassReference
IScale Methods
IScale Interface See Also Send Feedback

The IScale type exposes the following members.

Methods

Name | Description
FromRealValue | Returns scale value by source data value.
GetDiscreteValue | Returnы discrete value by index.
GetDiscreteValuesCount | Returnы count of discrete values.
PercentToValue | Converts percentage to value.
PointToValue | Converts point to value.
ToRealValue | Returns source data value by its scale value.
ValueToPercent | Converts value to percentage.
ValueToPoint | Converts value to point.

See Also

IScale Interface
PerpetuumSoft.Instrumentation.Model Namespace


FromRealValue Method

[image]

.NET ModelKit Suite ClassReference
IScale..::.FromRealValue Method
IScale Interface See Also Send Feedback
Returns scale value by source data value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
double FromRealValue(
    Object value
)
Visual Basic (Declaration)
Function FromRealValue ( _
    value As Object _
) As Double
Visual C++
double FromRealValue(
    Object^ value
)

Parameters

value
Type: System..::.Object

See Also

IScale Interface
PerpetuumSoft.Instrumentation.Model Namespace


GetDiscreteValue Method

[image]

.NET ModelKit Suite ClassReference
IScale..::.GetDiscreteValue Method
IScale Interface See Also Send Feedback
Returnы discrete value by index.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
Object GetDiscreteValue(
    int index
)
Visual Basic (Declaration)
Function GetDiscreteValue ( _
    index As Integer _
) As Object
Visual C++
Object^ GetDiscreteValue(
    int index
)

Parameters

index
Type: System..::.Int32

See Also

IScale Interface
PerpetuumSoft.Instrumentation.Model Namespace


GetDiscreteValuesCount Method

[image]

.NET ModelKit Suite ClassReference
IScale..::.GetDiscreteValuesCount Method
IScale Interface See Also Send Feedback
Returnы count of discrete values.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
int GetDiscreteValuesCount()
Visual Basic (Declaration)
Function GetDiscreteValuesCount As Integer
Visual C++
int GetDiscreteValuesCount()

See Also

IScale Interface
PerpetuumSoft.Instrumentation.Model Namespace


PercentToValue Method

[image]

.NET ModelKit Suite ClassReference
IScale..::.PercentToValue Method
IScale Interface See Also Send Feedback
Converts percentage to value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
double PercentToValue(
    double percent
)
Visual Basic (Declaration)
Function PercentToValue ( _
    percent As Double _
) As Double
Visual C++
double PercentToValue(
    double percent
)

Parameters

percent
Type: System..::.Double

See Also

IScale Interface
PerpetuumSoft.Instrumentation.Model Namespace


PointToValue Method

[image]

.NET ModelKit Suite ClassReference
IScale..::.PointToValue Method
IScale Interface See Also Send Feedback
Converts point to value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
double PointToValue(
    Vector point
)
Visual Basic (Declaration)
Function PointToValue ( _
    point As Vector _
) As Double
Visual C++
double PointToValue(
    Vector point
)

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

IScale Interface
PerpetuumSoft.Instrumentation.Model Namespace


ToRealValue Method

[image]

.NET ModelKit Suite ClassReference
IScale..::.ToRealValue Method
IScale Interface See Also Send Feedback
Returns source data value by its scale value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
Object ToRealValue(
    double value
)
Visual Basic (Declaration)
Function ToRealValue ( _
    value As Double _
) As Object
Visual C++
Object^ ToRealValue(
    double value
)

Parameters

value
Type: System..::.Double

See Also

IScale Interface
PerpetuumSoft.Instrumentation.Model Namespace


ValueToPercent Method

[image]

.NET ModelKit Suite ClassReference
IScale..::.ValueToPercent Method
IScale Interface See Also Send Feedback
Converts value to percentage.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
double ValueToPercent(
    double value
)
Visual Basic (Declaration)
Function ValueToPercent ( _
    value As Double _
) As Double
Visual C++
double ValueToPercent(
    double value
)

Parameters

value
Type: System..::.Double

See Also

IScale Interface
PerpetuumSoft.Instrumentation.Model Namespace


ValueToPoint Method

[image]

.NET ModelKit Suite ClassReference
IScale..::.ValueToPoint Method
IScale Interface See Also Send Feedback
Converts value to point.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
Vector ValueToPoint(
    double value,
    double radius
)
Visual Basic (Declaration)
Function ValueToPoint ( _
    value As Double, _
    radius As Double _
) As Vector
Visual C++
Vector ValueToPoint(
    double value,
    double radius
)

Parameters

value
Type: System..::.Double
radius
Type: System..::.Double

See Also

IScale Interface
PerpetuumSoft.Instrumentation.Model Namespace


IScale Properties

[image] [image]

.NET ModelKit Suite ClassReference
IScale Properties
IScale Interface See Also Send Feedback

The IScale type exposes the following members.

Properties

Name | Description
Colorizer | Gets Colorizer object that is used for scale elements colouring.
IsDiscrete | Gets value indicating that this scale is discrete.
Maximum | Gets or sets maximum value.
Minimum | Gets or sets minimum value.

See Also

IScale Interface
PerpetuumSoft.Instrumentation.Model Namespace


Colorizer Property

[image]

.NET ModelKit Suite ClassReference
IScale..::.Colorizer Property
IScale Interface See Also Send Feedback
Gets Colorizer object that is used for scale elements colouring.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
Colorizer Colorizer { get; }
Visual Basic (Declaration)
ReadOnly Property Colorizer As Colorizer
Visual C++
property Colorizer^ Colorizer {
    Colorizer^ get ();
}

See Also

IScale Interface
PerpetuumSoft.Instrumentation.Model Namespace


IsDiscrete Property

[image]

.NET ModelKit Suite ClassReference
IScale..::.IsDiscrete Property
IScale Interface See Also Send Feedback
Gets value indicating that this scale is discrete.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
bool IsDiscrete { get; }
Visual Basic (Declaration)
ReadOnly Property IsDiscrete As Boolean
Visual C++
property bool IsDiscrete {
    bool get ();
}

See Also

IScale Interface
PerpetuumSoft.Instrumentation.Model Namespace


Maximum Property

[image]

.NET ModelKit Suite ClassReference
IScale..::.Maximum Property
IScale Interface See Also Send Feedback
Gets or sets maximum value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
double Maximum { get; set; }
Visual Basic (Declaration)
Property Maximum As Double
Visual C++
property double Maximum {
    double get ();
    void set (double value);
}

See Also

IScale Interface
PerpetuumSoft.Instrumentation.Model Namespace


Minimum Property

[image]

.NET ModelKit Suite ClassReference
IScale..::.Minimum Property
IScale Interface See Also Send Feedback
Gets or sets minimum value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
double Minimum { get; set; }
Visual Basic (Declaration)
Property Minimum As Double
Visual C++
property double Minimum {
    double get ();
    void set (double value);
}

See Also

IScale Interface
PerpetuumSoft.Instrumentation.Model Namespace


IScaleElement Interface

[image]

.NET ModelKit Suite ClassReference
IScaleElement Interface
Members See Also Send Feedback
Represents the element that can be located on the scale.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public interface IScaleElement
Visual Basic (Declaration)
Public Interface IScaleElement
Visual C++
public interface class IScaleElement

See Also

IScaleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


IScaleElement Members

[image] [image]

.NET ModelKit Suite ClassReference
IScaleElement Members
IScaleElement Interface Methods Properties See Also Send Feedback

The IScaleElement type exposes the following members.

Methods

Name | Description
GetSize | Returns size of the area occupied by the scale elements.
ResetMeasure | Recalculates scale elements position.
SetStartDistance | Sets default distance of the scale elements in relation to the scale.

Properties

Name | Description
Dock | Gets dock in relation to the scale.
Padding | Gets indent from the scale.
Visible | Gets the element's visisbility.

See Also

IScaleElement Interface
PerpetuumSoft.Instrumentation.Model Namespace


IScaleElement Methods

[image] [image]

.NET ModelKit Suite ClassReference
IScaleElement Methods
IScaleElement Interface See Also Send Feedback

The IScaleElement type exposes the following members.

Methods

Name | Description
GetSize | Returns size of the area occupied by the scale elements.
ResetMeasure | Recalculates scale elements position.
SetStartDistance | Sets default distance of the scale elements in relation to the scale.

See Also

IScaleElement Interface
PerpetuumSoft.Instrumentation.Model Namespace


GetSize Method

[image]

.NET ModelKit Suite ClassReference
IScaleElement..::.GetSize Method
IScaleElement Interface See Also Send Feedback
Returns size of the area occupied by the scale elements.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
double GetSize()
Visual Basic (Declaration)
Function GetSize As Double
Visual C++
double GetSize()

See Also

IScaleElement Interface
PerpetuumSoft.Instrumentation.Model Namespace


ResetMeasure Method

[image]

.NET ModelKit Suite ClassReference
IScaleElement..::.ResetMeasure Method
IScaleElement Interface See Also Send Feedback
Recalculates scale elements position.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
void ResetMeasure()
Visual Basic (Declaration)
Sub ResetMeasure
Visual C++
void ResetMeasure()

See Also

IScaleElement Interface
PerpetuumSoft.Instrumentation.Model Namespace


SetStartDistance Method

[image]

.NET ModelKit Suite ClassReference
IScaleElement..::.SetStartDistance Method
IScaleElement Interface See Also Send Feedback
Sets default distance of the scale elements in relation to the scale.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
void SetStartDistance(
    double distance
)
Visual Basic (Declaration)
Sub SetStartDistance ( _
    distance As Double _
)
Visual C++
void SetStartDistance(
    double distance
)

Parameters

distance
Type: System..::.Double

See Also

IScaleElement Interface
PerpetuumSoft.Instrumentation.Model Namespace


IScaleElement Properties

[image] [image]

.NET ModelKit Suite ClassReference
IScaleElement Properties
IScaleElement Interface See Also Send Feedback

The IScaleElement type exposes the following members.

Properties

Name | Description
Dock | Gets dock in relation to the scale.
Padding | Gets indent from the scale.
Visible | Gets the element's visisbility.

See Also

IScaleElement Interface
PerpetuumSoft.Instrumentation.Model Namespace


Dock Property

[image]

.NET ModelKit Suite ClassReference
IScaleElement..::.Dock Property
IScaleElement Interface See Also Send Feedback
Gets dock in relation to the scale.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
ScaleDocking Dock { get; }
Visual Basic (Declaration)
ReadOnly Property Dock As ScaleDocking
Visual C++
property ScaleDocking Dock {
    ScaleDocking get ();
}

See Also

IScaleElement Interface
PerpetuumSoft.Instrumentation.Model Namespace


Padding Property

[image]

.NET ModelKit Suite ClassReference
IScaleElement..::.Padding Property
IScaleElement Interface See Also Send Feedback
Gets indent from the scale.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
double Padding { get; }
Visual Basic (Declaration)
ReadOnly Property Padding As Double
Visual C++
property double Padding {
    double get ();
}

See Also

IScaleElement Interface
PerpetuumSoft.Instrumentation.Model Namespace


Visible Property

[image]

.NET ModelKit Suite ClassReference
IScaleElement..::.Visible Property
IScaleElement Interface See Also Send Feedback
Gets the element's visisbility.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
bool Visible { get; }
Visual Basic (Declaration)
ReadOnly Property Visible As Boolean
Visual C++
property bool Visible {
    bool get ();
}

See Also

IScaleElement Interface
PerpetuumSoft.Instrumentation.Model Namespace


ISlider Interface

[image]

.NET ModelKit Suite ClassReference
ISlider Interface
Members See Also Send Feedback
Main interface for slider.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public interface ISlider
Visual Basic (Declaration)
Public Interface ISlider
Visual C++
public interface class ISlider

See Also

ISlider Members
PerpetuumSoft.Instrumentation.Model Namespace


ISlider Members

[image] [image]

.NET ModelKit Suite ClassReference
ISlider Members
ISlider Interface Methods Properties See Also Send Feedback

The ISlider type exposes the following members.

Methods

Name | Description
GetPosition | Returns position by specific radius.

Properties

Name | Description
MaxLimit | Gets maximum value limit.
MinLimit | Gets minimum value limit.
Value | Gets element value.

See Also

ISlider Interface
PerpetuumSoft.Instrumentation.Model Namespace


ISlider Methods

[image] [image]

.NET ModelKit Suite ClassReference
ISlider Methods
ISlider Interface See Also Send Feedback

The ISlider type exposes the following members.

Methods

Name | Description
GetPosition | Returns position by specific radius.

See Also

ISlider Interface
PerpetuumSoft.Instrumentation.Model Namespace


GetPosition Method

[image]

.NET ModelKit Suite ClassReference
ISlider..::.GetPosition Method
ISlider Interface See Also Send Feedback
Returns position by specific radius.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
Vector GetPosition(
    double radius
)
Visual Basic (Declaration)
Function GetPosition ( _
    radius As Double _
) As Vector
Visual C++
Vector GetPosition(
    double radius
)

Parameters

radius
Type: System..::.Double

See Also

ISlider Interface
PerpetuumSoft.Instrumentation.Model Namespace


ISlider Properties

[image] [image]

.NET ModelKit Suite ClassReference
ISlider Properties
ISlider Interface See Also Send Feedback

The ISlider type exposes the following members.

Properties

Name | Description
MaxLimit | Gets maximum value limit.
MinLimit | Gets minimum value limit.
Value | Gets element value.

See Also

ISlider Interface
PerpetuumSoft.Instrumentation.Model Namespace


MaxLimit Property

[image]

.NET ModelKit Suite ClassReference
ISlider..::.MaxLimit Property
ISlider Interface See Also Send Feedback
Gets maximum value limit.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
SmartValue MaxLimit { get; }
Visual Basic (Declaration)
ReadOnly Property MaxLimit As SmartValue
Visual C++
property SmartValue MaxLimit {
    SmartValue get ();
}

See Also

ISlider Interface
PerpetuumSoft.Instrumentation.Model Namespace


MinLimit Property

[image]

.NET ModelKit Suite ClassReference
ISlider..::.MinLimit Property
ISlider Interface See Also Send Feedback
Gets minimum value limit.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
SmartValue MinLimit { get; }
Visual Basic (Declaration)
ReadOnly Property MinLimit As SmartValue
Visual C++
property SmartValue MinLimit {
    SmartValue get ();
}

See Also

ISlider Interface
PerpetuumSoft.Instrumentation.Model Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
ISlider..::.Value Property
ISlider Interface See Also Send Feedback
Gets element value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
double Value { get; }
Visual Basic (Declaration)
ReadOnly Property Value As Double
Visual C++
property double Value {
    double get ();
}

See Also

ISlider Interface
PerpetuumSoft.Instrumentation.Model Namespace


ITrajectory Interface

[image]

.NET ModelKit Suite ClassReference
ITrajectory Interface
Members See Also Send Feedback
Represents the trajectory.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public interface ITrajectory
Visual Basic (Declaration)
Public Interface ITrajectory
Visual C++
public interface class ITrajectory

See Also

ITrajectory Members
PerpetuumSoft.Instrumentation.Model Namespace


ITrajectory Members

[image] [image]

.NET ModelKit Suite ClassReference
ITrajectory Members
ITrajectory Interface Methods Properties See Also Send Feedback

The ITrajectory type exposes the following members.

Methods

Name | Description
PercentToPoint | Returns point that corresponds given percent and distance to trajectory.
PointToPercent | Returns percent that corresponds to given point.

Properties

Name | Description
StartDistance | Gets start distance in relation to trajectory.

See Also

ITrajectory Interface
PerpetuumSoft.Instrumentation.Model Namespace


ITrajectory Methods

[image] [image]

.NET ModelKit Suite ClassReference
ITrajectory Methods
ITrajectory Interface See Also Send Feedback

The ITrajectory type exposes the following members.

Methods

Name | Description
PercentToPoint | Returns point that corresponds given percent and distance to trajectory.
PointToPercent | Returns percent that corresponds to given point.

See Also

ITrajectory Interface
PerpetuumSoft.Instrumentation.Model Namespace


PercentToPoint Method

[image]

.NET ModelKit Suite ClassReference
ITrajectory..::.PercentToPoint Method
ITrajectory Interface See Also Send Feedback
Returns point that corresponds given percent and distance to trajectory.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
Vector PercentToPoint(
    double portion,
    double radius
)
Visual Basic (Declaration)
Function PercentToPoint ( _
    portion As Double, _
    radius As Double _
) As Vector
Visual C++
Vector PercentToPoint(
    double portion,
    double radius
)

Parameters

portion
Type: System..::.Double
radius
Type: System..::.Double

See Also

ITrajectory Interface
PerpetuumSoft.Instrumentation.Model Namespace


PointToPercent Method

[image]

.NET ModelKit Suite ClassReference
ITrajectory..::.PointToPercent Method
ITrajectory Interface See Also Send Feedback
Returns percent that corresponds to given point.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
double PointToPercent(
    Vector point
)
Visual Basic (Declaration)
Function PointToPercent ( _
    point As Vector _
) As Double
Visual C++
double PointToPercent(
    Vector point
)

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

ITrajectory Interface
PerpetuumSoft.Instrumentation.Model Namespace


ITrajectory Properties

[image] [image]

.NET ModelKit Suite ClassReference
ITrajectory Properties
ITrajectory Interface See Also Send Feedback

The ITrajectory type exposes the following members.

Properties

Name | Description
StartDistance | Gets start distance in relation to trajectory.

See Also

ITrajectory Interface
PerpetuumSoft.Instrumentation.Model Namespace


StartDistance Property

[image]

.NET ModelKit Suite ClassReference
ITrajectory..::.StartDistance Property
ITrajectory Interface See Also Send Feedback
Gets start distance in relation to trajectory.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
double StartDistance { get; }
Visual Basic (Declaration)
ReadOnly Property StartDistance As Double
Visual C++
property double StartDistance {
    double get ();
}

See Also

ITrajectory Interface
PerpetuumSoft.Instrumentation.Model Namespace


Joint Class

[image]

.NET ModelKit Suite ClassReference
Joint Class
Members See Also Send Feedback
Represents the Joint.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Joint : DockableTrajectoryBase
Visual Basic (Declaration)
Public Class Joint _
    Inherits DockableTrajectoryBase
Visual C++
public ref class Joint : public DockableTrajectoryBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.Composite
PerpetuumSoft.Instrumentation.Model..::.DockableTrajectoryBase
PerpetuumSoft.Instrumentation.Model..::.Joint

See Also

Joint Members
PerpetuumSoft.Instrumentation.Model Namespace


Joint Members

[image] [image]

.NET ModelKit Suite ClassReference
Joint Members
Joint Class Constructors Methods Properties Events See Also Send Feedback

The Joint type exposes the following members.

Constructors

Name | Description
Joint | Initializes a new instance of the Joint class.

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from DockableTrajectoryBase.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetInsideSize | Returns inside size. (Inherited from DockableTrajectoryBase.)
GetObject | Implements GetObject(String). (Overrides Element..::.GetObject(String).)
GetOutsideSize | Returns outside size. (Inherited from DockableTrajectoryBase.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PercentToPoint | Implements PercentToPoint(Double, Double). (Overrides DockableTrajectoryBase..::.PercentToPoint(Double, Double).)
PointToPercent | Implements PointToPercent(Vector). (Overrides DockableTrajectoryBase..::.PointToPercent(Vector).)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
RecalculatePosition | Overridden. See ['M:PerpetuumSoft.Instrumentation.Model.DockableTrajectoryBase.RecalculatePosition]. (Overrides DockableTrajectoryBase..::.RecalculatePosition()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets center of joint element.
Dock | Gets or sets docking of this element.
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object used to paint over. (Inherited from DockableTrajectoryBase.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Margins | Gets and sets Trajectory margins. (Inherited from DockableTrajectoryBase.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Radius | Gets or sets radius of joint element.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smoothing will be applied. (Inherited from DockableTrajectoryBase.)
StartAngle | Gets or sets start angle.
StartDistance | Implements StartDistance. (Overrides DockableTrajectoryBase..::.StartDistance.)
Stroke | Gets or sets the Stroke object used to trace. (Inherited from DockableTrajectoryBase.)
Style | Gets or sets name of the used style. (Inherited from DockableTrajectoryBase.)
TotalAngle | Gets or sets total angle.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Joint Class
PerpetuumSoft.Instrumentation.Model Namespace


Joint Constructor

[image]

.NET ModelKit Suite ClassReference
Joint Constructor
Joint Class See Also Send Feedback
Initializes a new instance of the Joint class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Joint()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Joint()

See Also

Joint Class
PerpetuumSoft.Instrumentation.Model Namespace


Joint Methods

[image] [image]

.NET ModelKit Suite ClassReference
Joint Methods
Joint Class See Also Send Feedback

The Joint type exposes the following members.

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from DockableTrajectoryBase.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetInsideSize | Returns inside size. (Inherited from DockableTrajectoryBase.)
GetObject | Implements GetObject(String). (Overrides Element..::.GetObject(String).)
GetOutsideSize | Returns outside size. (Inherited from DockableTrajectoryBase.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PercentToPoint | Implements PercentToPoint(Double, Double). (Overrides DockableTrajectoryBase..::.PercentToPoint(Double, Double).)
PointToPercent | Implements PointToPercent(Vector). (Overrides DockableTrajectoryBase..::.PointToPercent(Vector).)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
RecalculatePosition | Overridden. See ['M:PerpetuumSoft.Instrumentation.Model.DockableTrajectoryBase.RecalculatePosition]. (Overrides DockableTrajectoryBase..::.RecalculatePosition()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Joint Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Joint..::.Dispose Method
Joint Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from Composite.)

See Also

Joint Class
Joint Members
PerpetuumSoft.Instrumentation.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
Joint..::.GetBoundedBox Method
Joint Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

Joint Class
PerpetuumSoft.Instrumentation.Model Namespace


GetObject Method

[image]

.NET ModelKit Suite ClassReference
Joint..::.GetObject Method
Joint Class See Also Send Feedback
Implements GetObject(String).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Object GetObject(
    string name
)
Visual Basic (Declaration)
Public Overrides Function GetObject ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetObject(
    String^ name
) override

Parameters

name
Type: System..::.String

See Also

Joint Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Joint..::.GetStyle Method
Joint Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Joint Class
Joint Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Joint..::.Invalidate Method
Joint Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Joint Class
Joint Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Joint..::.OnPaint Method
Joint Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Inherited from Composite.)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

Joint Class
Joint Members
PerpetuumSoft.Instrumentation.Model Namespace


PercentToPoint Method

[image]

.NET ModelKit Suite ClassReference
Joint..::.PercentToPoint Method
Joint Class See Also Send Feedback
Implements PercentToPoint(Double, Double).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Vector PercentToPoint(
    double portion,
    double radius
)
Visual Basic (Declaration)
Public Overrides Function PercentToPoint ( _
    portion As Double, _
    radius As Double _
) As Vector
Visual C++
public:
virtual Vector PercentToPoint(
    double portion,
    double radius
) override

Parameters

portion
Type: System..::.Double
radius
Type: System..::.Double

Implements

ITrajectory..::.PercentToPoint(Double, Double)

See Also

Joint Class
PerpetuumSoft.Instrumentation.Model Namespace


PointToPercent Method

[image]

.NET ModelKit Suite ClassReference
Joint..::.PointToPercent Method
Joint Class See Also Send Feedback
Implements PointToPercent(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override double PointToPercent(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function PointToPercent ( _
    point As Vector _
) As Double
Visual C++
public:
virtual double PointToPercent(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

Implements

ITrajectory..::.PointToPercent(Vector)

See Also

Joint Class
PerpetuumSoft.Instrumentation.Model Namespace


RecalculatePosition Method

[image]

.NET ModelKit Suite ClassReference
Joint..::.RecalculatePosition Method
Joint Class See Also Send Feedback
Overridden. See ['M:PerpetuumSoft.Instrumentation.Model.DockableTrajectoryBase.RecalculatePosition].

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void RecalculatePosition()
Visual Basic (Declaration)
Protected Overrides Sub RecalculatePosition
Visual C++
protected:
virtual void RecalculatePosition() override

See Also

Joint Class
PerpetuumSoft.Instrumentation.Model Namespace


Joint Properties

[image] [image]

.NET ModelKit Suite ClassReference
Joint Properties
Joint Class See Also Send Feedback

The Joint type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets center of joint element.
Dock | Gets or sets docking of this element.
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object used to paint over. (Inherited from DockableTrajectoryBase.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Margins | Gets and sets Trajectory margins. (Inherited from DockableTrajectoryBase.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Radius | Gets or sets radius of joint element.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smoothing will be applied. (Inherited from DockableTrajectoryBase.)
StartAngle | Gets or sets start angle.
StartDistance | Implements StartDistance. (Overrides DockableTrajectoryBase..::.StartDistance.)
Stroke | Gets or sets the Stroke object used to trace. (Inherited from DockableTrajectoryBase.)
Style | Gets or sets name of the used style. (Inherited from DockableTrajectoryBase.)
TotalAngle | Gets or sets total angle.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Joint Class
PerpetuumSoft.Instrumentation.Model Namespace


Center Property

[image]

.NET ModelKit Suite ClassReference
Joint..::.Center Property
Joint Class See Also Send Feedback
Gets or sets center of joint element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Vector Center { get; set; }
Visual Basic (Declaration)
Public Property Center As Vector
Visual C++
public:
property Vector Center {
    Vector get ();
    void set (Vector value);
}

See Also

Joint Class
PerpetuumSoft.Instrumentation.Model Namespace


Dock Property

[image]

.NET ModelKit Suite ClassReference
Joint..::.Dock Property
Joint Class See Also Send Feedback
Gets or sets docking of this element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public JointDocking Dock { get; set; }
Visual Basic (Declaration)
Public Property Dock As JointDocking
Visual C++
public:
property JointDocking Dock {
    JointDocking get ();
    void set (JointDocking value);
}

See Also

Joint Class
PerpetuumSoft.Instrumentation.Model Namespace


Radius Property

[image]

.NET ModelKit Suite ClassReference
Joint..::.Radius Property
Joint Class See Also Send Feedback
Gets or sets radius of joint element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Radius { get; set; }
Visual Basic (Declaration)
Public Property Radius As Double
Visual C++
public:
property double Radius {
    double get ();
    void set (double value);
}

See Also

Joint Class
PerpetuumSoft.Instrumentation.Model Namespace


StartAngle Property

[image]

.NET ModelKit Suite ClassReference
Joint..::.StartAngle Property
Joint Class See Also Send Feedback
Gets or sets start angle.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double StartAngle { get; set; }
Visual Basic (Declaration)
Public Property StartAngle As Double
Visual C++
public:
property double StartAngle {
    double get ();
    void set (double value);
}

See Also

Joint Class
PerpetuumSoft.Instrumentation.Model Namespace


StartDistance Property

[image]

.NET ModelKit Suite ClassReference
Joint..::.StartDistance Property
Joint Class See Also Send Feedback
Implements StartDistance.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override double StartDistance { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property StartDistance As Double
Visual C++
public:
virtual property double StartDistance {
    double get () override;
}

Implements

ITrajectory..::.StartDistance

See Also

Joint Class
PerpetuumSoft.Instrumentation.Model Namespace


TotalAngle Property

[image]

.NET ModelKit Suite ClassReference
Joint..::.TotalAngle Property
Joint Class See Also Send Feedback
Gets or sets total angle.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double TotalAngle { get; set; }
Visual Basic (Declaration)
Public Property TotalAngle As Double
Visual C++
public:
property double TotalAngle {
    double get ();
    void set (double value);
}

See Also

Joint Class
PerpetuumSoft.Instrumentation.Model Namespace


Joint Events

[image] [image]

.NET ModelKit Suite ClassReference
Joint Events
Joint Class See Also Send Feedback

The Joint type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Joint Class
PerpetuumSoft.Instrumentation.Model Namespace


JointDocking Enumeration

[image]

.NET ModelKit Suite ClassReference
JointDocking Enumeration
See Also Send Feedback
Enumerates joint docking types.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public enum JointDocking
Visual Basic (Declaration)
Public Enumeration JointDocking
Visual C++
public enum class JointDocking

Members

Member name | Description
None | Specifes docking absence.
Center | Specifies docking center.
Left | Sets docking to left.
Right | Sets docking to right.
Top | Sets docking to top.
Bottom | Sets docking to bottom.
LeftBottom | Sets docking to left bottom.
LeftTop | Sets docking to left top.
RightBottom | Sets docking to right bottom.
RightTop | Sets docking to right top.

See Also

PerpetuumSoft.Instrumentation.Model Namespace


Label Class

[image]

.NET ModelKit Suite ClassReference
Label Class
Members See Also Send Feedback
Represents the Label.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Label : RectangleElement
Visual Basic (Declaration)
Public Class Label _
    Inherits RectangleElement
Visual C++
public ref class Label : public RectangleElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement
PerpetuumSoft.Instrumentation.Model..::.RectangleElement
PerpetuumSoft.Instrumentation.Model..::.Label

See Also

Label Members
PerpetuumSoft.Instrumentation.Model Namespace


Label Members

[image] [image]

.NET ModelKit Suite ClassReference
Label Members
Label Class Constructors Methods Properties Events See Also Send Feedback

The Label type exposes the following members.

Constructors

Name | Description
Label | Initializes a new instance of the Label class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from RectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets label font.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Margins | Gets or sets element matgins.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Text | Gets or sets label text.
TextAlign | Gets or sets label text alignment.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Label Class
PerpetuumSoft.Instrumentation.Model Namespace


Label Constructor

[image]

.NET ModelKit Suite ClassReference
Label Constructor
Label Class See Also Send Feedback
Initializes a new instance of the Label class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Label()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Label()

See Also

Label Class
PerpetuumSoft.Instrumentation.Model Namespace


Label Methods

[image] [image]

.NET ModelKit Suite ClassReference
Label Methods
Label Class See Also Send Feedback

The Label type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from RectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Label Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Label..::.Dispose Method
Label Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from RectangleElement.)

See Also

Label Class
Label Members
PerpetuumSoft.Instrumentation.Model Namespace


DrawContent Method

[image]

.NET ModelKit Suite ClassReference
Label..::.DrawContent Method
Label Class See Also Send Feedback
Overridden. See DrawContent(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void DrawContent(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Protected Overrides Sub DrawContent ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
protected:
virtual void DrawContent(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Label Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Label..::.GetStyle Method
Label Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Label Class
Label Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Label..::.Invalidate Method
Label Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Label Class
Label Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Label..::.OnPaint Method
Label Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from RectangleElement.)

See Also

Label Class
Label Members
PerpetuumSoft.Instrumentation.Model Namespace


Label Properties

[image] [image]

.NET ModelKit Suite ClassReference
Label Properties
Label Class See Also Send Feedback

The Label type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets label font.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Margins | Gets or sets element matgins.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Text | Gets or sets label text.
TextAlign | Gets or sets label text alignment.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Label Class
PerpetuumSoft.Instrumentation.Model Namespace


Font Property

[image]

.NET ModelKit Suite ClassReference
Label..::.Font Property
Label Class See Also Send Feedback
Gets or sets label font.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public FontDescriptor Font { get; set; }
Visual Basic (Declaration)
Public Property Font As FontDescriptor
Visual C++
public:
property FontDescriptor^ Font {
    FontDescriptor^ get ();
    void set (FontDescriptor^ value);
}

See Also

Label Class
PerpetuumSoft.Instrumentation.Model Namespace


Margins Property

[image]

.NET ModelKit Suite ClassReference
Label..::.Margins Property
Label Class See Also Send Feedback
Gets or sets element matgins.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Margins Margins { get; set; }
Visual Basic (Declaration)
Public Property Margins As Margins
Visual C++
public:
property Margins Margins {
    Margins get ();
    void set (Margins value);
}

See Also

Label Class
PerpetuumSoft.Instrumentation.Model Namespace


Text Property

[image]

.NET ModelKit Suite ClassReference
Label..::.Text Property
Label Class See Also Send Feedback
Gets or sets label text.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

Label Class
PerpetuumSoft.Instrumentation.Model Namespace


TextAlign Property

[image]

.NET ModelKit Suite ClassReference
Label..::.TextAlign Property
Label Class See Also Send Feedback
Gets or sets label text alignment.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ContentAlignment TextAlign { get; set; }
Visual Basic (Declaration)
Public Property TextAlign As ContentAlignment
Visual C++
public:
property ContentAlignment TextAlign {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

Label Class
PerpetuumSoft.Instrumentation.Model Namespace


Label Events

[image] [image]

.NET ModelKit Suite ClassReference
Label Events
Label Class See Also Send Feedback

The Label type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Label Class
PerpetuumSoft.Instrumentation.Model Namespace


LabelPosition Enumeration

[image]

.NET ModelKit Suite ClassReference
LabelPosition Enumeration
See Also Send Feedback
Enumerates the label position types.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public enum LabelPosition
Visual Basic (Declaration)
Public Enumeration LabelPosition
Visual C++
public enum class LabelPosition

Members

Member name | Description
Near | Specifies the near position.
Center | Specifies the center position.
Far | Specifies the far position.

See Also

PerpetuumSoft.Instrumentation.Model Namespace


LevelBase Class

[image]

.NET ModelKit Suite ClassReference
LevelBase Class
Members See Also Send Feedback
Reperesents base class for level elements.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract class LevelBase : ValuePresenterScaleElement
Visual Basic (Declaration)
Public MustInherit Class LevelBase _
    Inherits ValuePresenterScaleElement
Visual C++
public ref class LevelBase abstract : public ValuePresenterScaleElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.ScaleElement
PerpetuumSoft.Instrumentation.Model..::.ValuePresenterScaleElement
PerpetuumSoft.Instrumentation.Model..::.LevelBase
PerpetuumSoft.Instrumentation.Model..::.LinearLevel
PerpetuumSoft.Instrumentation.Model..::.RangedLevel

See Also

LevelBase Members
PerpetuumSoft.Instrumentation.Model Namespace


LevelBase Members

[image] [image]

.NET ModelKit Suite ClassReference
LevelBase Members
LevelBase Class Constructors Methods Properties Events See Also Send Feedback

The LevelBase type exposes the following members.

Constructors

Name | Description
LevelBase | Initializes a new instance of the LevelBase class

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetMaxValue | Return maximim value from represented values. (Inherited from ValuePresenterScaleElement.)
GetMinValue | Returns minimum value from represented values. (Inherited from ValuePresenterScaleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()(). (Inherited from ScaleElement.)
GetSmartValue | Returns value by SmartValue amd calculated value for the Auto case. (Inherited from ValuePresenterScaleElement.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Inherited from ScaleElement.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleElement.)
SetStartDistance | Implements SetStartDistance(Double). (Overrides ScaleElement..::.SetStartDistance(Double).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Colors | Gets ColorSectionCollection, reperesenting colors used in the level gradient fill.
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Divisions | Gets or sets divisions count.
DivisionsStroke | Gets or sets stroke used for darwing divisions.
Dock | Implements Dock. (Inherited from ScaleElement.)
EndColor | Gets or sets color used in the end point of the level gradient fill.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartColor | Gets or sets color used in the start point of the level gradient fill.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Value | Gets or sets represented value. (Inherited from ValuePresenterScaleElement.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

LevelBase Class
PerpetuumSoft.Instrumentation.Model Namespace


LevelBase Constructor

[image]

.NET ModelKit Suite ClassReference
LevelBase Constructor
LevelBase Class See Also Send Feedback
Initializes a new instance of the LevelBase class

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected LevelBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
LevelBase()

See Also

LevelBase Class
PerpetuumSoft.Instrumentation.Model Namespace


LevelBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
LevelBase Methods
LevelBase Class See Also Send Feedback

The LevelBase type exposes the following members.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetMaxValue | Return maximim value from represented values. (Inherited from ValuePresenterScaleElement.)
GetMinValue | Returns minimum value from represented values. (Inherited from ValuePresenterScaleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()(). (Inherited from ScaleElement.)
GetSmartValue | Returns value by SmartValue amd calculated value for the Auto case. (Inherited from ValuePresenterScaleElement.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Inherited from ScaleElement.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleElement.)
SetStartDistance | Implements SetStartDistance(Double). (Overrides ScaleElement..::.SetStartDistance(Double).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LevelBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
LevelBase..::.Dispose Method
LevelBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

LevelBase Class
LevelBase Members
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
LevelBase..::.GetStyle Method
LevelBase Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

LevelBase Class
LevelBase Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
LevelBase..::.Invalidate Method
LevelBase Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

LevelBase Class
LevelBase Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
LevelBase..::.OnPaint Method
LevelBase Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

LevelBase Class
LevelBase Members
PerpetuumSoft.Instrumentation.Model Namespace


SetStartDistance Method

[image]

.NET ModelKit Suite ClassReference
LevelBase..::.SetStartDistance Method
LevelBase Class See Also Send Feedback
Implements SetStartDistance(Double).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void SetStartDistance(
    double distance
)
Visual Basic (Declaration)
Public Overrides Sub SetStartDistance ( _
    distance As Double _
)
Visual C++
public:
virtual void SetStartDistance(
    double distance
) override

Parameters

distance
Type: System..::.Double

Implements

IScaleElement..::.SetStartDistance(Double)

See Also

LevelBase Class
PerpetuumSoft.Instrumentation.Model Namespace


LevelBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
LevelBase Properties
LevelBase Class See Also Send Feedback

The LevelBase type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Colors | Gets ColorSectionCollection, reperesenting colors used in the level gradient fill.
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Divisions | Gets or sets divisions count.
DivisionsStroke | Gets or sets stroke used for darwing divisions.
Dock | Implements Dock. (Inherited from ScaleElement.)
EndColor | Gets or sets color used in the end point of the level gradient fill.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartColor | Gets or sets color used in the start point of the level gradient fill.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Value | Gets or sets represented value. (Inherited from ValuePresenterScaleElement.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

LevelBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Colors Property

[image]

.NET ModelKit Suite ClassReference
LevelBase..::.Colors Property
LevelBase Class See Also Send Feedback
Gets ColorSectionCollection, reperesenting colors used in the level gradient fill.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ColorSectionCollection Colors { get; }
Visual Basic (Declaration)
Public ReadOnly Property Colors As ColorSectionCollection
Visual C++
public:
property ColorSectionCollection^ Colors {
    ColorSectionCollection^ get ();
}

See Also

LevelBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Divisions Property

[image]

.NET ModelKit Suite ClassReference
LevelBase..::.Divisions Property
LevelBase Class See Also Send Feedback
Gets or sets divisions count.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int Divisions { get; set; }
Visual Basic (Declaration)
Public Property Divisions As Integer
Visual C++
public:
property int Divisions {
    int get ();
    void set (int value);
}

See Also

LevelBase Class
PerpetuumSoft.Instrumentation.Model Namespace


DivisionsStroke Property

[image]

.NET ModelKit Suite ClassReference
LevelBase..::.DivisionsStroke Property
LevelBase Class See Also Send Feedback
Gets or sets stroke used for darwing divisions.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Stroke DivisionsStroke { get; set; }
Visual Basic (Declaration)
Public Property DivisionsStroke As Stroke
Visual C++
public:
property Stroke^ DivisionsStroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

LevelBase Class
PerpetuumSoft.Instrumentation.Model Namespace


EndColor Property

[image]

.NET ModelKit Suite ClassReference
LevelBase..::.EndColor Property
LevelBase Class See Also Send Feedback
Gets or sets color used in the end point of the level gradient fill.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Color EndColor { get; set; }
Visual Basic (Declaration)
Public Property EndColor As Color
Visual C++
public:
property Color EndColor {
    Color get ();
    void set (Color value);
}

See Also

LevelBase Class
PerpetuumSoft.Instrumentation.Model Namespace


StartColor Property

[image]

.NET ModelKit Suite ClassReference
LevelBase..::.StartColor Property
LevelBase Class See Also Send Feedback
Gets or sets color used in the start point of the level gradient fill.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Color StartColor { get; set; }
Visual Basic (Declaration)
Public Property StartColor As Color
Visual C++
public:
property Color StartColor {
    Color get ();
    void set (Color value);
}

See Also

LevelBase Class
PerpetuumSoft.Instrumentation.Model Namespace


LevelBase Events

[image] [image]

.NET ModelKit Suite ClassReference
LevelBase Events
LevelBase Class See Also Send Feedback

The LevelBase type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

LevelBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Line Class

[image]

.NET ModelKit Suite ClassReference
Line Class
Members See Also Send Feedback
Represents the Line.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Line : LineElement
Visual Basic (Declaration)
Public Class Line _
    Inherits LineElement
Visual C++
public ref class Line : public LineElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.LineElement
PerpetuumSoft.Instrumentation.Model..::.Line

See Also

Line Members
PerpetuumSoft.Instrumentation.Model Namespace


Line Members

[image] [image]

.NET ModelKit Suite ClassReference
Line Members
Line Class Constructors Methods Properties Events See Also Send Feedback

The Line type exposes the following members.

Constructors

Name | Description
Line | Initializes a new instance of the Line class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides LineElement..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsIncludePoint | Returns the value indicating whether an element includes a point. (Inherited from LineElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
EndPoint | Gets or sets the end point of the element. (Inherited from LineElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartPoint | Gets or sets the begin point of the element. (Inherited from LineElement.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Line Class
PerpetuumSoft.Instrumentation.Model Namespace


Line Constructor

[image]

.NET ModelKit Suite ClassReference
Line Constructor
Line Class See Also Send Feedback
Initializes a new instance of the Line class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Line()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Line()

See Also

Line Class
PerpetuumSoft.Instrumentation.Model Namespace


Line Methods

[image] [image]

.NET ModelKit Suite ClassReference
Line Methods
Line Class See Also Send Feedback

The Line type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides LineElement..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsIncludePoint | Returns the value indicating whether an element includes a point. (Inherited from LineElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Line Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Line..::.Dispose Method
Line Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

Line Class
Line Members
PerpetuumSoft.Instrumentation.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
Line..::.GetBoundedBox Method
Line Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

Line Class
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
Line..::.GetHitTest Method
Line Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Line Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Line..::.GetStyle Method
Line Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Line Class
Line Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Line..::.Invalidate Method
Line Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Line Class
Line Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Line..::.OnPaint Method
Line Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

Line Class
Line Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
Line..::.OnPaint Method (PaintArguments, Fill, Stroke)
Line Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Line Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


Line Properties

[image] [image]

.NET ModelKit Suite ClassReference
Line Properties
Line Class See Also Send Feedback

The Line type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
EndPoint | Gets or sets the end point of the element. (Inherited from LineElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartPoint | Gets or sets the begin point of the element. (Inherited from LineElement.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Line Class
PerpetuumSoft.Instrumentation.Model Namespace


Line Events

[image] [image]

.NET ModelKit Suite ClassReference
Line Events
Line Class See Also Send Feedback

The Line type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Line Class
PerpetuumSoft.Instrumentation.Model Namespace


LinearLevel Class

[image]

.NET ModelKit Suite ClassReference
LinearLevel Class
Members See Also Send Feedback
Represents Linear level.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class LinearLevel : LevelBase
Visual Basic (Declaration)
Public Class LinearLevel _
    Inherits LevelBase
Visual C++
public ref class LinearLevel : public LevelBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.ScaleElement
PerpetuumSoft.Instrumentation.Model..::.ValuePresenterScaleElement
PerpetuumSoft.Instrumentation.Model..::.LevelBase
PerpetuumSoft.Instrumentation.Model..::.LinearLevel

See Also

LinearLevel Members
PerpetuumSoft.Instrumentation.Model Namespace


LinearLevel Members

[image] [image]

.NET ModelKit Suite ClassReference
LinearLevel Members
LinearLevel Class Constructors Methods Properties Events See Also Send Feedback

The LinearLevel type exposes the following members.

Constructors

Name | Description
LinearLevel | Initializes a new instance of the LinearLevel class.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetMaxValue | Return maximim value from represented values. (Inherited from ValuePresenterScaleElement.)
GetMinValue | Returns minimum value from represented values. (Inherited from ValuePresenterScaleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()(). (Overrides ScaleElement..::.GetSize()()().)
GetSmartValue | Returns value by SmartValue amd calculated value for the Auto case. (Inherited from ValuePresenterScaleElement.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Inherited from ScaleElement.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleElement.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from LevelBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Colors | Gets ColorSectionCollection, reperesenting colors used in the level gradient fill. (Inherited from LevelBase.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Divisions | Gets or sets divisions count. (Inherited from LevelBase.)
DivisionsStroke | Gets or sets stroke used for darwing divisions. (Inherited from LevelBase.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Effect3D | Gets or sets values, indicating use of 3d effects.
EndCap | Gets or sets style of a cap in the end point.
EndColor | Gets or sets color used in the end point of the level gradient fill. (Inherited from LevelBase.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
PocketRadius | Gets or sets the thermometer pocket radius.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
ShowAsThermometer | Gets or sets value, indicating it the element will be drawn in the form of a thermometer.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartCap | Gets or sets style of a cap in the start point.
StartColor | Gets or sets color used in the start point of the level gradient fill. (Inherited from LevelBase.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Value | Gets or sets represented value. (Inherited from ValuePresenterScaleElement.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)
Width | Gets or sets width of the level elemets.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

LinearLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


LinearLevel Constructor

[image]

.NET ModelKit Suite ClassReference
LinearLevel Constructor
LinearLevel Class See Also Send Feedback
Initializes a new instance of the LinearLevel class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public LinearLevel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LinearLevel()

See Also

LinearLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


LinearLevel Methods

[image] [image]

.NET ModelKit Suite ClassReference
LinearLevel Methods
LinearLevel Class See Also Send Feedback

The LinearLevel type exposes the following members.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetMaxValue | Return maximim value from represented values. (Inherited from ValuePresenterScaleElement.)
GetMinValue | Returns minimum value from represented values. (Inherited from ValuePresenterScaleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()(). (Overrides ScaleElement..::.GetSize()()().)
GetSmartValue | Returns value by SmartValue amd calculated value for the Auto case. (Inherited from ValuePresenterScaleElement.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Inherited from ScaleElement.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleElement.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from LevelBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinearLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
LinearLevel..::.Dispose Method
LinearLevel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

LinearLevel Class
LinearLevel Members
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
LinearLevel..::.GetHitTest Method
LinearLevel Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

LinearLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


GetSize Method

[image]

.NET ModelKit Suite ClassReference
LinearLevel..::.GetSize Method
LinearLevel Class See Also Send Feedback
Implements GetSize()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override double GetSize()
Visual Basic (Declaration)
Public Overrides Function GetSize As Double
Visual C++
public:
virtual double GetSize() override

Implements

IScaleElement..::.GetSize()()()

See Also

LinearLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
LinearLevel..::.GetStyle Method
LinearLevel Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

LinearLevel Class
LinearLevel Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
LinearLevel..::.Invalidate Method
LinearLevel Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

LinearLevel Class
LinearLevel Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
LinearLevel..::.OnPaint Method
LinearLevel Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Overrides Element..::.OnPaint(PaintArguments).)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

LinearLevel Class
LinearLevel Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments)

[image]

.NET ModelKit Suite ClassReference
LinearLevel..::.OnPaint Method (PaintArguments)
LinearLevel Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

LinearLevel Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


LinearLevel Properties

[image] [image]

.NET ModelKit Suite ClassReference
LinearLevel Properties
LinearLevel Class See Also Send Feedback

The LinearLevel type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Colors | Gets ColorSectionCollection, reperesenting colors used in the level gradient fill. (Inherited from LevelBase.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Divisions | Gets or sets divisions count. (Inherited from LevelBase.)
DivisionsStroke | Gets or sets stroke used for darwing divisions. (Inherited from LevelBase.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Effect3D | Gets or sets values, indicating use of 3d effects.
EndCap | Gets or sets style of a cap in the end point.
EndColor | Gets or sets color used in the end point of the level gradient fill. (Inherited from LevelBase.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
PocketRadius | Gets or sets the thermometer pocket radius.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
ShowAsThermometer | Gets or sets value, indicating it the element will be drawn in the form of a thermometer.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartCap | Gets or sets style of a cap in the start point.
StartColor | Gets or sets color used in the start point of the level gradient fill. (Inherited from LevelBase.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Value | Gets or sets represented value. (Inherited from ValuePresenterScaleElement.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)
Width | Gets or sets width of the level elemets.

See Also

LinearLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Effect3D Property

[image]

.NET ModelKit Suite ClassReference
LinearLevel..::.Effect3D Property
LinearLevel Class See Also Send Feedback
Gets or sets values, indicating use of 3d effects.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Effect3D Effect3D { get; set; }
Visual Basic (Declaration)
Public Property Effect3D As Effect3D
Visual C++
public:
property Effect3D Effect3D {
    Effect3D get ();
    void set (Effect3D value);
}

See Also

LinearLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


EndCap Property

[image]

.NET ModelKit Suite ClassReference
LinearLevel..::.EndCap Property
LinearLevel Class See Also Send Feedback
Gets or sets style of a cap in the end point.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public CapStyle EndCap { get; set; }
Visual Basic (Declaration)
Public Property EndCap As CapStyle
Visual C++
public:
property CapStyle EndCap {
    CapStyle get ();
    void set (CapStyle value);
}

See Also

LinearLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


PocketRadius Property

[image]

.NET ModelKit Suite ClassReference
LinearLevel..::.PocketRadius Property
LinearLevel Class See Also Send Feedback
Gets or sets the thermometer pocket radius.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double PocketRadius { get; set; }
Visual Basic (Declaration)
Public Property PocketRadius As Double
Visual C++
public:
property double PocketRadius {
    double get ();
    void set (double value);
}

See Also

LinearLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


ShowAsThermometer Property

[image]

.NET ModelKit Suite ClassReference
LinearLevel..::.ShowAsThermometer Property
LinearLevel Class See Also Send Feedback
Gets or sets value, indicating it the element will be drawn in the form of a thermometer.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowAsThermometer { get; set; }
Visual Basic (Declaration)
Public Property ShowAsThermometer As Boolean
Visual C++
public:
property bool ShowAsThermometer {
    bool get ();
    void set (bool value);
}

See Also

LinearLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


StartCap Property

[image]

.NET ModelKit Suite ClassReference
LinearLevel..::.StartCap Property
LinearLevel Class See Also Send Feedback
Gets or sets style of a cap in the start point.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public CapStyle StartCap { get; set; }
Visual Basic (Declaration)
Public Property StartCap As CapStyle
Visual C++
public:
property CapStyle StartCap {
    CapStyle get ();
    void set (CapStyle value);
}

See Also

LinearLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
LinearLevel..::.Width Property
LinearLevel Class See Also Send Feedback
Gets or sets width of the level elemets.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

LinearLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


LinearLevel Events

[image] [image]

.NET ModelKit Suite ClassReference
LinearLevel Events
LinearLevel Class See Also Send Feedback

The LinearLevel type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

LinearLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


LinearNotches Class

[image]

.NET ModelKit Suite ClassReference
LinearNotches Class
Members See Also Send Feedback
Represents Linear notches.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class LinearNotches : LineElement
Visual Basic (Declaration)
Public Class LinearNotches _
    Inherits LineElement
Visual C++
public ref class LinearNotches : public LineElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.LineElement
PerpetuumSoft.Instrumentation.Model..::.LinearNotches

See Also

LinearNotches Members
PerpetuumSoft.Instrumentation.Model Namespace


LinearNotches Members

[image] [image]

.NET ModelKit Suite ClassReference
LinearNotches Members
LinearNotches Class Constructors Methods Properties Events See Also Send Feedback

The LinearNotches type exposes the following members.

Constructors

Name | Description
LinearNotches | Initializes a new instance of the LinearNotches class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides LineElement..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsIncludePoint | Returns the value indicating whether an element includes a point. (Inherited from LineElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Count | Gets or sets linear notches count.
DarkColor | Gets or sets linear notches dark color.
EndPoint | Gets or sets the end point of the element. (Inherited from LineElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
LightColor | Gets or sets linear notches light color.
Name | Gets or sets the element's name. (Inherited from Element.)
NotchesStyle | Gets or sets notches style.
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartPoint | Gets or sets the begin point of the element. (Inherited from LineElement.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)
Width | Gets or sets linear nothes width.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

LinearNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


LinearNotches Constructor

[image]

.NET ModelKit Suite ClassReference
LinearNotches Constructor
LinearNotches Class See Also Send Feedback
Initializes a new instance of the LinearNotches class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public LinearNotches()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LinearNotches()

See Also

LinearNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


LinearNotches Methods

[image] [image]

.NET ModelKit Suite ClassReference
LinearNotches Methods
LinearNotches Class See Also Send Feedback

The LinearNotches type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides LineElement..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsIncludePoint | Returns the value indicating whether an element includes a point. (Inherited from LineElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinearNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
LinearNotches..::.Dispose Method
LinearNotches Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

LinearNotches Class
LinearNotches Members
PerpetuumSoft.Instrumentation.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
LinearNotches..::.GetBoundedBox Method
LinearNotches Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

LinearNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
LinearNotches..::.GetHitTest Method
LinearNotches Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

LinearNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
LinearNotches..::.GetStyle Method
LinearNotches Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

LinearNotches Class
LinearNotches Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
LinearNotches..::.Invalidate Method
LinearNotches Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

LinearNotches Class
LinearNotches Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
LinearNotches..::.OnPaint Method
LinearNotches Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Overrides Element..::.OnPaint(PaintArguments).)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)
OnPaint(PaintArguments, Stroke, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke).

See Also

LinearNotches Class
LinearNotches Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments)

[image]

.NET ModelKit Suite ClassReference
LinearNotches..::.OnPaint Method (PaintArguments)
LinearNotches Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

LinearNotches Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments, Stroke, Stroke)

[image]

.NET ModelKit Suite ClassReference
LinearNotches..::.OnPaint Method (PaintArguments, Stroke, Stroke)
LinearNotches Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public virtual void OnPaint(
    PaintArguments args,
    Stroke lightStroke,
    Stroke darkStroke
)
Visual Basic (Declaration)
Public Overridable Sub OnPaint ( _
    args As PaintArguments, _
    lightStroke As Stroke, _
    darkStroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Stroke^ lightStroke,
    Stroke^ darkStroke
)

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
lightStroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
darkStroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

LinearNotches Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


LinearNotches Properties

[image] [image]

.NET ModelKit Suite ClassReference
LinearNotches Properties
LinearNotches Class See Also Send Feedback

The LinearNotches type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Count | Gets or sets linear notches count.
DarkColor | Gets or sets linear notches dark color.
EndPoint | Gets or sets the end point of the element. (Inherited from LineElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
LightColor | Gets or sets linear notches light color.
Name | Gets or sets the element's name. (Inherited from Element.)
NotchesStyle | Gets or sets notches style.
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartPoint | Gets or sets the begin point of the element. (Inherited from LineElement.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)
Width | Gets or sets linear nothes width.

See Also

LinearNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


Count Property

[image]

.NET ModelKit Suite ClassReference
LinearNotches..::.Count Property
LinearNotches Class See Also Send Feedback
Gets or sets linear notches count.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int Count { get; set; }
Visual Basic (Declaration)
Public Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
    void set (int value);
}

See Also

LinearNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


DarkColor Property

[image]

.NET ModelKit Suite ClassReference
LinearNotches..::.DarkColor Property
LinearNotches Class See Also Send Feedback
Gets or sets linear notches dark color.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Color DarkColor { get; set; }
Visual Basic (Declaration)
Public Property DarkColor As Color
Visual C++
public:
property Color DarkColor {
    Color get ();
    void set (Color value);
}

See Also

LinearNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


LightColor Property

[image]

.NET ModelKit Suite ClassReference
LinearNotches..::.LightColor Property
LinearNotches Class See Also Send Feedback
Gets or sets linear notches light color.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Color LightColor { get; set; }
Visual Basic (Declaration)
Public Property LightColor As Color
Visual C++
public:
property Color LightColor {
    Color get ();
    void set (Color value);
}

See Also

LinearNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


NotchesStyle Property

[image]

.NET ModelKit Suite ClassReference
LinearNotches..::.NotchesStyle Property
LinearNotches Class See Also Send Feedback
Gets or sets notches style.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public NotchesStyle NotchesStyle { get; set; }
Visual Basic (Declaration)
Public Property NotchesStyle As NotchesStyle
Visual C++
public:
property NotchesStyle NotchesStyle {
    NotchesStyle get ();
    void set (NotchesStyle value);
}

See Also

LinearNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
LinearNotches..::.Width Property
LinearNotches Class See Also Send Feedback
Gets or sets linear nothes width.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

LinearNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


LinearNotches Events

[image] [image]

.NET ModelKit Suite ClassReference
LinearNotches Events
LinearNotches Class See Also Send Feedback

The LinearNotches type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

LinearNotches Class
PerpetuumSoft.Instrumentation.Model Namespace


LineElement Class

[image]

.NET ModelKit Suite ClassReference
LineElement Class
Members See Also Send Feedback
Represents the basic class for line elements.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract class LineElement : Element
Visual Basic (Declaration)
Public MustInherit Class LineElement _
    Inherits Element
Visual C++
public ref class LineElement abstract : public Element

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.LineElement
PerpetuumSoft.Instrumentation.Model..::.Line
PerpetuumSoft.Instrumentation.Model..::.LinearNotches
PerpetuumSoft.Instrumentation.Model..::.Needle
PerpetuumSoft.Instrumentation.Model..::.Spring

See Also

LineElement Members
PerpetuumSoft.Instrumentation.Model Namespace


LineElement Members

[image] [image]

.NET ModelKit Suite ClassReference
LineElement Members
LineElement Class Constructors Methods Properties Events See Also Send Feedback

The LineElement type exposes the following members.

Constructors

Name | Description
LineElement | Initializes a new instance of the LineElement class

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsIncludePoint | Returns the value indicating whether an element includes a point.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
EndPoint | Gets or sets the end point of the element.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartPoint | Gets or sets the begin point of the element.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

LineElement Class
PerpetuumSoft.Instrumentation.Model Namespace


LineElement Constructor

[image]

.NET ModelKit Suite ClassReference
LineElement Constructor
LineElement Class See Also Send Feedback
Initializes a new instance of the LineElement class

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected LineElement()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
LineElement()

See Also

LineElement Class
PerpetuumSoft.Instrumentation.Model Namespace


LineElement Methods

[image] [image]

.NET ModelKit Suite ClassReference
LineElement Methods
LineElement Class See Also Send Feedback

The LineElement type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsIncludePoint | Returns the value indicating whether an element includes a point.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineElement Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
LineElement..::.Dispose Method
LineElement Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

LineElement Class
LineElement Members
PerpetuumSoft.Instrumentation.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
LineElement..::.GetBoundedBox Method
LineElement Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

LineElement Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
LineElement..::.GetStyle Method
LineElement Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

LineElement Class
LineElement Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
LineElement..::.Invalidate Method
LineElement Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

LineElement Class
LineElement Members
PerpetuumSoft.Instrumentation.Model Namespace


IsIncludePoint Method

[image]

.NET ModelKit Suite ClassReference
LineElement..::.IsIncludePoint Method
LineElement Class See Also Send Feedback
Returns the value indicating whether an element includes a point.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected bool IsIncludePoint(
    Vector point,
    Vector sPoint,
    Vector ePoint
)
Visual Basic (Declaration)
Protected Function IsIncludePoint ( _
    point As Vector, _
    sPoint As Vector, _
    ePoint As Vector _
) As Boolean
Visual C++
protected:
bool IsIncludePoint(
    Vector point,
    Vector sPoint,
    Vector ePoint
)

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector
sPoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector
ePoint
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

LineElement Class
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
LineElement..::.OnPaint Method
LineElement Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

LineElement Class
LineElement Members
PerpetuumSoft.Instrumentation.Model Namespace


LineElement Properties

[image] [image]

.NET ModelKit Suite ClassReference
LineElement Properties
LineElement Class See Also Send Feedback

The LineElement type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
EndPoint | Gets or sets the end point of the element.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartPoint | Gets or sets the begin point of the element.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

LineElement Class
PerpetuumSoft.Instrumentation.Model Namespace


EndPoint Property

[image]

.NET ModelKit Suite ClassReference
LineElement..::.EndPoint Property
LineElement Class See Also Send Feedback
Gets or sets the end point of the element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Vector EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As Vector
Visual C++
public:
property Vector EndPoint {
    Vector get ();
    void set (Vector value);
}

See Also

LineElement Class
PerpetuumSoft.Instrumentation.Model Namespace


StartPoint Property

[image]

.NET ModelKit Suite ClassReference
LineElement..::.StartPoint Property
LineElement Class See Also Send Feedback
Gets or sets the begin point of the element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Vector StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Vector
Visual C++
public:
property Vector StartPoint {
    Vector get ();
    void set (Vector value);
}

See Also

LineElement Class
PerpetuumSoft.Instrumentation.Model Namespace


LineElement Events

[image] [image]

.NET ModelKit Suite ClassReference
LineElement Events
LineElement Class See Also Send Feedback

The LineElement type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

LineElement Class
PerpetuumSoft.Instrumentation.Model Namespace


Needle Class

[image]

.NET ModelKit Suite ClassReference
Needle Class
Members See Also Send Feedback
Represents the Needle.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Needle : LineElement
Visual Basic (Declaration)
Public Class Needle _
    Inherits LineElement
Visual C++
public ref class Needle : public LineElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.LineElement
PerpetuumSoft.Instrumentation.Model..::.Needle

See Also

Needle Members
PerpetuumSoft.Instrumentation.Model Namespace


Needle Members

[image] [image]

.NET ModelKit Suite ClassReference
Needle Members
Needle Class Constructors Methods Properties Events See Also Send Feedback

The Needle type exposes the following members.

Constructors

Name | Description
Needle | Initializes a new instance of the Needle class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides LineElement..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsIncludePoint | Returns the value indicating whether an element includes a point. (Inherited from LineElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
EndPoint | Gets or sets the end point of the element. (Inherited from LineElement.)
EndWidth | Gets or sets width of the end needle side.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
NeedlePoints | Gets collection of needle points.
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
ShowMode | Gets or sets view mode of an element.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartPoint | Gets or sets the begin point of the element. (Inherited from LineElement.)
StartWidth | Gets or sets width of the begin needle side.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Needle Class
PerpetuumSoft.Instrumentation.Model Namespace


Needle Constructor

[image]

.NET ModelKit Suite ClassReference
Needle Constructor
Needle Class See Also Send Feedback
Initializes a new instance of the Needle class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Needle()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Needle()

See Also

Needle Class
PerpetuumSoft.Instrumentation.Model Namespace


Needle Methods

[image] [image]

.NET ModelKit Suite ClassReference
Needle Methods
Needle Class See Also Send Feedback

The Needle type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides LineElement..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsIncludePoint | Returns the value indicating whether an element includes a point. (Inherited from LineElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Needle Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Needle..::.Dispose Method
Needle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

Needle Class
Needle Members
PerpetuumSoft.Instrumentation.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
Needle..::.GetBoundedBox Method
Needle Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

Needle Class
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
Needle..::.GetHitTest Method
Needle Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Needle Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Needle..::.GetStyle Method
Needle Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Needle Class
Needle Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Needle..::.Invalidate Method
Needle Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Needle Class
Needle Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Needle..::.OnPaint Method
Needle Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

Needle Class
Needle Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
Needle..::.OnPaint Method (PaintArguments, Fill, Stroke)
Needle Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Needle Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


Needle Properties

[image] [image]

.NET ModelKit Suite ClassReference
Needle Properties
Needle Class See Also Send Feedback

The Needle type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
EndPoint | Gets or sets the end point of the element. (Inherited from LineElement.)
EndWidth | Gets or sets width of the end needle side.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
NeedlePoints | Gets collection of needle points.
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
ShowMode | Gets or sets view mode of an element.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartPoint | Gets or sets the begin point of the element. (Inherited from LineElement.)
StartWidth | Gets or sets width of the begin needle side.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Needle Class
PerpetuumSoft.Instrumentation.Model Namespace


EndWidth Property

[image]

.NET ModelKit Suite ClassReference
Needle..::.EndWidth Property
Needle Class See Also Send Feedback
Gets or sets width of the end needle side.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double EndWidth { get; set; }
Visual Basic (Declaration)
Public Property EndWidth As Double
Visual C++
public:
property double EndWidth {
    double get ();
    void set (double value);
}

See Also

Needle Class
PerpetuumSoft.Instrumentation.Model Namespace


NeedlePoints Property

[image]

.NET ModelKit Suite ClassReference
Needle..::.NeedlePoints Property
Needle Class See Also Send Feedback
Gets collection of needle points.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public NeedlePointCollection NeedlePoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property NeedlePoints As NeedlePointCollection
Visual C++
public:
property NeedlePointCollection^ NeedlePoints {
    NeedlePointCollection^ get ();
}

See Also

Needle Class
PerpetuumSoft.Instrumentation.Model Namespace


ShowMode Property

[image]

.NET ModelKit Suite ClassReference
Needle..::.ShowMode Property
Needle Class See Also Send Feedback
Gets or sets view mode of an element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ShowMode ShowMode { get; set; }
Visual Basic (Declaration)
Public Property ShowMode As ShowMode
Visual C++
public:
property ShowMode ShowMode {
    ShowMode get ();
    void set (ShowMode value);
}

See Also

Needle Class
PerpetuumSoft.Instrumentation.Model Namespace


StartWidth Property

[image]

.NET ModelKit Suite ClassReference
Needle..::.StartWidth Property
Needle Class See Also Send Feedback
Gets or sets width of the begin needle side.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double StartWidth { get; set; }
Visual Basic (Declaration)
Public Property StartWidth As Double
Visual C++
public:
property double StartWidth {
    double get ();
    void set (double value);
}

See Also

Needle Class
PerpetuumSoft.Instrumentation.Model Namespace


Needle Events

[image] [image]

.NET ModelKit Suite ClassReference
Needle Events
Needle Class See Also Send Feedback

The Needle type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Needle Class
PerpetuumSoft.Instrumentation.Model Namespace


NeedlePoint Class

[image]

.NET ModelKit Suite ClassReference
NeedlePoint Class
Members See Also Send Feedback
Represents the needle point.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class NeedlePoint
Visual Basic (Declaration)
Public Class NeedlePoint
Visual C++
public ref class NeedlePoint

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.NeedlePoint

See Also

NeedlePoint Members
PerpetuumSoft.Instrumentation.Model Namespace


NeedlePoint Members

[image] [image]

.NET ModelKit Suite ClassReference
NeedlePoint Members
NeedlePoint Class Constructors Methods Properties See Also Send Feedback

The NeedlePoint type exposes the following members.

Constructors

Name | Description
NeedlePoint | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Portion | Gets or sets needle point portion.
Width | Gets or sets needle point width.

See Also

NeedlePoint Class
PerpetuumSoft.Instrumentation.Model Namespace


NeedlePoint Constructor

[image] [image]

.NET ModelKit Suite ClassReference
NeedlePoint Constructor
NeedlePoint Class See Also Send Feedback

Overload List

Name | Description
NeedlePoint()()() | Initializes a new instance of the NeedlePoint class.
NeedlePoint(Double, Double) | Initializes a new instance of the NeedlePoint class.

See Also

NeedlePoint Class
NeedlePoint Members
PerpetuumSoft.Instrumentation.Model Namespace


NeedlePoint Constructor

[image]

.NET ModelKit Suite ClassReference
NeedlePoint Constructor
NeedlePoint Class See Also Send Feedback
Initializes a new instance of the NeedlePoint class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public NeedlePoint()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NeedlePoint()

See Also

NeedlePoint Class
NeedlePoint Overload
PerpetuumSoft.Instrumentation.Model Namespace


NeedlePoint Constructor (Double, Double)

[image]

.NET ModelKit Suite ClassReference
NeedlePoint Constructor (Double, Double)
NeedlePoint Class See Also Send Feedback
Initializes a new instance of the NeedlePoint class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public NeedlePoint(
    double portion,
    double width
)
Visual Basic (Declaration)
Public Sub New ( _
    portion As Double, _
    width As Double _
)
Visual C++
public:
NeedlePoint(
    double portion,
    double width
)

Parameters

portion
Type: System..::.Double
width
Type: System..::.Double

See Also

NeedlePoint Class
NeedlePoint Overload
PerpetuumSoft.Instrumentation.Model Namespace


NeedlePoint Methods

[image] [image]

.NET ModelKit Suite ClassReference
NeedlePoint Methods
NeedlePoint Class See Also Send Feedback

The NeedlePoint type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NeedlePoint Class
PerpetuumSoft.Instrumentation.Model Namespace


NeedlePoint Properties

[image] [image]

.NET ModelKit Suite ClassReference
NeedlePoint Properties
NeedlePoint Class See Also Send Feedback

The NeedlePoint type exposes the following members.

Properties

Name | Description
Portion | Gets or sets needle point portion.
Width | Gets or sets needle point width.

See Also

NeedlePoint Class
PerpetuumSoft.Instrumentation.Model Namespace


Portion Property

[image]

.NET ModelKit Suite ClassReference
NeedlePoint..::.Portion Property
NeedlePoint Class See Also Send Feedback
Gets or sets needle point portion.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Portion { get; set; }
Visual Basic (Declaration)
Public Property Portion As Double
Visual C++
public:
property double Portion {
    double get ();
    void set (double value);
}

See Also

NeedlePoint Class
PerpetuumSoft.Instrumentation.Model Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
NeedlePoint..::.Width Property
NeedlePoint Class See Also Send Feedback
Gets or sets needle point width.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

NeedlePoint Class
PerpetuumSoft.Instrumentation.Model Namespace


NeedlePointCollection Class

[image]

.NET ModelKit Suite ClassReference
NeedlePointCollection Class
Members See Also Send Feedback
Represents collection of NeedlePoint objects.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class NeedlePointCollection : CollectionBase
Visual Basic (Declaration)
Public Class NeedlePointCollection _
    Inherits CollectionBase
Visual C++
public ref class NeedlePointCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Instrumentation.Model..::.NeedlePointCollection

See Also

NeedlePointCollection Members
PerpetuumSoft.Instrumentation.Model Namespace


NeedlePointCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
NeedlePointCollection Members
NeedlePointCollection Class Constructors Methods Properties Events See Also Send Feedback

The NeedlePointCollection type exposes the following members.

Constructors

Name | Description
NeedlePointCollection | Initializes a new instance of the NeedlePointCollection class.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Add array of NeedlePoint objects into collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Raise Insert event. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Raise InsertComplete event. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Raise RemoveComplete event. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Raise Validate event. (Overrides CollectionBase..::.OnValidate(Object).)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Implements Item[([(Int32])]).
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

Name | Description
CollectionChanged | Occurs after collection changing.

See Also

NeedlePointCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


NeedlePointCollection Constructor

[image]

.NET ModelKit Suite ClassReference
NeedlePointCollection Constructor
NeedlePointCollection Class See Also Send Feedback
Initializes a new instance of the NeedlePointCollection class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public NeedlePointCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NeedlePointCollection()

See Also

NeedlePointCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


NeedlePointCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
NeedlePointCollection Methods
NeedlePointCollection Class See Also Send Feedback

The NeedlePointCollection type exposes the following members.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Add array of NeedlePoint objects into collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Raise Insert event. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Raise InsertComplete event. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Raise RemoveComplete event. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Raise Validate event. (Overrides CollectionBase..::.OnValidate(Object).)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NeedlePointCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
NeedlePointCollection..::.Add Method
NeedlePointCollection Class See Also Send Feedback
Implements Add(Object).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public NeedlePoint Add(
    NeedlePoint value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As NeedlePoint _
) As NeedlePoint
Visual C++
public:
NeedlePoint^ Add(
    NeedlePoint^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model..::.NeedlePoint

See Also

NeedlePointCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
NeedlePointCollection..::.AddRange Method
NeedlePointCollection Class See Also Send Feedback
Add array of NeedlePoint objects into collection.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    NeedlePoint[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As NeedlePoint() _
)
Visual C++
public:
void AddRange(
    array<NeedlePoint^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Instrumentation.Model..::.NeedlePoint >[]()[]

See Also

NeedlePointCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
NeedlePointCollection..::.Contains Method
NeedlePointCollection Class See Also Send Feedback
Implements Contains(Object).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    NeedlePoint value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As NeedlePoint _
) As Boolean
Visual C++
public:
bool Contains(
    NeedlePoint^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model..::.NeedlePoint

See Also

NeedlePointCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
NeedlePointCollection..::.IndexOf Method
NeedlePointCollection Class See Also Send Feedback
Implements IndexOf(Object).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    NeedlePoint value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As NeedlePoint _
) As Integer
Visual C++
public:
int IndexOf(
    NeedlePoint^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model..::.NeedlePoint

See Also

NeedlePointCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
NeedlePointCollection..::.Insert Method
NeedlePointCollection Class See Also Send Feedback
Implements Insert(Int32, Object).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    NeedlePoint value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As NeedlePoint _
)
Visual C++
public:
void Insert(
    int index,
    NeedlePoint^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Instrumentation.Model..::.NeedlePoint

See Also

NeedlePointCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


OnInsert Method

[image]

.NET ModelKit Suite ClassReference
NeedlePointCollection..::.OnInsert Method
NeedlePointCollection Class See Also Send Feedback
Raise Insert event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsert(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsert ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsert(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

NeedlePointCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


OnInsertComplete Method

[image]

.NET ModelKit Suite ClassReference
NeedlePointCollection..::.OnInsertComplete Method
NeedlePointCollection Class See Also Send Feedback
Raise InsertComplete event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsertComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsertComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsertComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

NeedlePointCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


OnRemoveComplete Method

[image]

.NET ModelKit Suite ClassReference
NeedlePointCollection..::.OnRemoveComplete Method
NeedlePointCollection Class See Also Send Feedback
Raise RemoveComplete event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnRemoveComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemoveComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemoveComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

NeedlePointCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


OnValidate Method

[image]

.NET ModelKit Suite ClassReference
NeedlePointCollection..::.OnValidate Method
NeedlePointCollection Class See Also Send Feedback
Raise Validate event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnValidate(
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnValidate ( _
    value As Object _
)
Visual C++
protected:
virtual void OnValidate(
    Object^ value
) override

Parameters

value
Type: System..::.Object

See Also

NeedlePointCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
NeedlePointCollection..::.Remove Method
NeedlePointCollection Class See Also Send Feedback
Implements Remove(Object).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    NeedlePoint value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As NeedlePoint _
)
Visual C++
public:
void Remove(
    NeedlePoint^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model..::.NeedlePoint

See Also

NeedlePointCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


NeedlePointCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
NeedlePointCollection Properties
NeedlePointCollection Class See Also Send Feedback

The NeedlePointCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Implements Item[([(Int32])]).
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

NeedlePointCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
NeedlePointCollection..::.Item Property
NeedlePointCollection Class See Also Send Feedback
Implements Item[([(Int32])]).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public NeedlePoint this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As NeedlePoint
Visual C++
public:
property NeedlePoint^ default[int index] {
    NeedlePoint^ get (int index);
    void set (int index, NeedlePoint^ value);
}

Parameters

index
Type: System..::.Int32

See Also

NeedlePointCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


NeedlePointCollection Events

[image] [image]

.NET ModelKit Suite ClassReference
NeedlePointCollection Events
NeedlePointCollection Class See Also Send Feedback

The NeedlePointCollection type exposes the following members.

Events

Name | Description
CollectionChanged | Occurs after collection changing.

See Also

NeedlePointCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


CollectionChanged Event

[image]

.NET ModelKit Suite ClassReference
NeedlePointCollection..::.CollectionChanged Event
NeedlePointCollection Class See Also Send Feedback
Occurs after collection changing.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public event NeedlePointCollection..::.CollectionChangedEventHandler CollectionChanged
Visual Basic (Declaration)
Public Event CollectionChanged As NeedlePointCollection..::.CollectionChangedEventHandler
Visual C++
public:
 event NeedlePointCollection..::.CollectionChangedEventHandler^ CollectionChanged {
    void add (NeedlePointCollection..::.CollectionChangedEventHandler^ value);
    void remove (NeedlePointCollection..::.CollectionChangedEventHandler^ value);
}

See Also

NeedlePointCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


NeedlePointCollection.CollectionChangedEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
NeedlePointCollection..::.CollectionChangedEventHandler Delegate
NeedlePointCollection Class See Also Send Feedback
Represents method which calls after collection changing.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public delegate void CollectionChangedEventHandler(
    NeedlePoint needlePoint
)
Visual Basic (Declaration)
Public Delegate Sub CollectionChangedEventHandler ( _
    needlePoint As NeedlePoint _
)
Visual C++
public delegate void CollectionChangedEventHandler(
    NeedlePoint^ needlePoint
)

Parameters

needlePoint
Type: PerpetuumSoft.Instrumentation.Model..::.NeedlePoint

See Also

PerpetuumSoft.Instrumentation.Model Namespace


NotchesStyle Enumeration

[image]

.NET ModelKit Suite ClassReference
NotchesStyle Enumeration
See Also Send Feedback
Represents notches styles.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public enum NotchesStyle
Visual Basic (Declaration)
Public Enumeration NotchesStyle
Visual C++
public enum class NotchesStyle

Members

Member name | Description
Raised | Raised notches.
Lowered | Lowered notches.
Flat | Flat notches.

See Also

PerpetuumSoft.Instrumentation.Model Namespace


NumericLabels Class

[image]

.NET ModelKit Suite ClassReference
NumericLabels Class
Members See Also Send Feedback
Represents the Numeric labels.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
[ObsoleteAttribute("This class is obsolete; use class ScaleLabels instead")]
public class NumericLabels : ScaleLabels
Visual Basic (Declaration)
<ObsoleteAttribute("This class is obsolete; use class ScaleLabels instead")> _
Public Class NumericLabels _
    Inherits ScaleLabels
Visual C++
[ObsoleteAttribute(L"This class is obsolete; use class ScaleLabels instead")]
public ref class NumericLabels : public ScaleLabels

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.ScaleElement
PerpetuumSoft.Instrumentation.Model..::.ScaleLabelsBase
PerpetuumSoft.Instrumentation.Model..::.ScaleLabels
PerpetuumSoft.Instrumentation.Model..::.NumericLabels

See Also

NumericLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


NumericLabels Members

[image] [image]

.NET ModelKit Suite ClassReference
NumericLabels Members
NumericLabels Class Constructors Methods Properties Events See Also Send Feedback

The NumericLabels type exposes the following members.

Constructors

Name | Description
NumericLabels | Initializes a new instance of the NumericLabels class.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from ScaleLabels.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from ScaleLabelsBase.)
GetLabel | Returns label text. (Inherited from ScaleLabels.)
GetLabelsCount | Return labels count. (Inherited from ScaleLabels.)
GetObject | Implements GetObject(String). (Inherited from ScaleLabelsBase.)
GetObjectByIndex | Overridden. See GetObjectByIndex(Int32). (Inherited from ScaleLabels.)
GetSize | Implements GetSize()()(). (Inherited from ScaleLabelsBase.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetTextLabel | Returns label text by the assigned value. (Inherited from ScaleLabelsBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueByIndex | Overridden. See GetValueByIndex(Int32). (Inherited from ScaleLabels.)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Raises the OnParentChanged event. (Inherited from ScaleLabelsBase.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is called when element's visibility is changed. (Inherited from ScaleLabelsBase.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLabel | Draws a scale mark. (Inherited from ScaleLabelsBase.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleLabelsBase.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleLabelsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Divisions | Gets or sets divisions count, will be used if the Step property is set to Auto. (Inherited from ScaleLabels.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets FontDescriptor of the element. (Inherited from ScaleLabelsBase.)
Format | Gets and sets text format for the labels. (Inherited from ScaleLabelsBase.)
Formula | Gets or sets expression used for calculating labels value. (Inherited from ScaleLabelsBase.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
ItemMargins | Gets or sets item margins. (Inherited from ScaleLabelsBase.)
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
NumbersFormat | Gets or sets format of numeric labels values.
OddLabelsDistance | Gets or sets distance foк odd labels. (Inherited from ScaleLabelsBase.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
Position | Gets or sets label position mode. (Inherited from ScaleLabelsBase.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
ShowSuperposableLabels | Gets or sets value that indicates whether superposable labels will be shown. (Inherited from ScaleLabelsBase.)
Size | Gets element size. (Inherited from ScaleLabelsBase.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Step | Gets or sets interval between labels. (Inherited from ScaleLabels.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
TextAlignment | Gets or sets text alignment. (Inherited from ScaleLabelsBase.)
TextAngle | Gets or sets text angle. (Inherited from ScaleLabelsBase.)
TextRotationMode | Gets or sets text rotation mode. (Inherited from ScaleLabelsBase.)
UseRoundValues | Gets or sets value that indicates if label values will be round. (Inherited from ScaleLabels.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

NumericLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


NumericLabels Constructor

[image]

.NET ModelKit Suite ClassReference
NumericLabels Constructor
NumericLabels Class See Also Send Feedback
Initializes a new instance of the NumericLabels class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public NumericLabels()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NumericLabels()

See Also

NumericLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


NumericLabels Methods

[image] [image]

.NET ModelKit Suite ClassReference
NumericLabels Methods
NumericLabels Class See Also Send Feedback

The NumericLabels type exposes the following members.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from ScaleLabels.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from ScaleLabelsBase.)
GetLabel | Returns label text. (Inherited from ScaleLabels.)
GetLabelsCount | Return labels count. (Inherited from ScaleLabels.)
GetObject | Implements GetObject(String). (Inherited from ScaleLabelsBase.)
GetObjectByIndex | Overridden. See GetObjectByIndex(Int32). (Inherited from ScaleLabels.)
GetSize | Implements GetSize()()(). (Inherited from ScaleLabelsBase.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetTextLabel | Returns label text by the assigned value. (Inherited from ScaleLabelsBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueByIndex | Overridden. See GetValueByIndex(Int32). (Inherited from ScaleLabels.)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Raises the OnParentChanged event. (Inherited from ScaleLabelsBase.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is called when element's visibility is changed. (Inherited from ScaleLabelsBase.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLabel | Draws a scale mark. (Inherited from ScaleLabelsBase.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleLabelsBase.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleLabelsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NumericLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
NumericLabels..::.Dispose Method
NumericLabels Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

NumericLabels Class
NumericLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
NumericLabels..::.GetStyle Method
NumericLabels Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

NumericLabels Class
NumericLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
NumericLabels..::.Invalidate Method
NumericLabels Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

NumericLabels Class
NumericLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
NumericLabels..::.OnPaint Method
NumericLabels Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from ScaleLabelsBase.)

See Also

NumericLabels Class
NumericLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


NumericLabels Properties

[image] [image]

.NET ModelKit Suite ClassReference
NumericLabels Properties
NumericLabels Class See Also Send Feedback

The NumericLabels type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Divisions | Gets or sets divisions count, will be used if the Step property is set to Auto. (Inherited from ScaleLabels.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets FontDescriptor of the element. (Inherited from ScaleLabelsBase.)
Format | Gets and sets text format for the labels. (Inherited from ScaleLabelsBase.)
Formula | Gets or sets expression used for calculating labels value. (Inherited from ScaleLabelsBase.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
ItemMargins | Gets or sets item margins. (Inherited from ScaleLabelsBase.)
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
NumbersFormat | Gets or sets format of numeric labels values.
OddLabelsDistance | Gets or sets distance foк odd labels. (Inherited from ScaleLabelsBase.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
Position | Gets or sets label position mode. (Inherited from ScaleLabelsBase.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
ShowSuperposableLabels | Gets or sets value that indicates whether superposable labels will be shown. (Inherited from ScaleLabelsBase.)
Size | Gets element size. (Inherited from ScaleLabelsBase.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Step | Gets or sets interval between labels. (Inherited from ScaleLabels.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
TextAlignment | Gets or sets text alignment. (Inherited from ScaleLabelsBase.)
TextAngle | Gets or sets text angle. (Inherited from ScaleLabelsBase.)
TextRotationMode | Gets or sets text rotation mode. (Inherited from ScaleLabelsBase.)
UseRoundValues | Gets or sets value that indicates if label values will be round. (Inherited from ScaleLabels.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

NumericLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


NumbersFormat Property

[image]

.NET ModelKit Suite ClassReference
NumericLabels..::.NumbersFormat Property
NumericLabels Class See Also Send Feedback
Gets or sets format of numeric labels values.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string NumbersFormat { get; set; }
Visual Basic (Declaration)
Public Property NumbersFormat As String
Visual C++
public:
property String^ NumbersFormat {
    String^ get ();
    void set (String^ value);
}

See Also

NumericLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


NumericLabels Events

[image] [image]

.NET ModelKit Suite ClassReference
NumericLabels Events
NumericLabels Class See Also Send Feedback

The NumericLabels type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

NumericLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


Picture Class

[image]

.NET ModelKit Suite ClassReference
Picture Class
Members See Also Send Feedback
Represents the Picture.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Picture : RectangleElement
Visual Basic (Declaration)
Public Class Picture _
    Inherits RectangleElement
Visual C++
public ref class Picture : public RectangleElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement
PerpetuumSoft.Instrumentation.Model..::.RectangleElement
PerpetuumSoft.Instrumentation.Model..::.Picture

See Also

Picture Members
PerpetuumSoft.Instrumentation.Model Namespace


Picture Members

[image] [image]

.NET ModelKit Suite ClassReference
Picture Members
Picture Class Constructors Methods Properties Events See Also Send Feedback

The Picture type exposes the following members.

Constructors

Name | Description
Picture | Initializes a new instance of the Picture class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from RectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over.
Image | Gets or sets Image of Picture element.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets the Stroke object that is used to trace.
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Picture Class
PerpetuumSoft.Instrumentation.Model Namespace


Picture Constructor

[image]

.NET ModelKit Suite ClassReference
Picture Constructor
Picture Class See Also Send Feedback
Initializes a new instance of the Picture class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Picture()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Picture()

See Also

Picture Class
PerpetuumSoft.Instrumentation.Model Namespace


Picture Methods

[image] [image]

.NET ModelKit Suite ClassReference
Picture Methods
Picture Class See Also Send Feedback

The Picture type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from RectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Picture Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Picture..::.Dispose Method
Picture Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Clean up any resources being used. (Overrides RectangleElement..::.Dispose(Boolean).)

See Also

Picture Class
Picture Members
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
Picture..::.Dispose Method (Boolean)
Picture Class See Also Send Feedback
Clean up any resources being used.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

Picture Class
Dispose Overload
PerpetuumSoft.Instrumentation.Model Namespace


DrawContent Method

[image]

.NET ModelKit Suite ClassReference
Picture..::.DrawContent Method
Picture Class See Also Send Feedback
Overridden. See DrawContent(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void DrawContent(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Protected Overrides Sub DrawContent ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
protected:
virtual void DrawContent(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Picture Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Picture..::.GetStyle Method
Picture Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Picture Class
Picture Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Picture..::.Invalidate Method
Picture Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Picture Class
Picture Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Picture..::.OnPaint Method
Picture Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from RectangleElement.)

See Also

Picture Class
Picture Members
PerpetuumSoft.Instrumentation.Model Namespace


Picture Properties

[image] [image]

.NET ModelKit Suite ClassReference
Picture Properties
Picture Class See Also Send Feedback

The Picture type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over.
Image | Gets or sets Image of Picture element.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets the Stroke object that is used to trace.
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Picture Class
PerpetuumSoft.Instrumentation.Model Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
Picture..::.Fill Property
Picture Class See Also Send Feedback
Gets or sets the Fill object that is used to paint over.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

Picture Class
PerpetuumSoft.Instrumentation.Model Namespace


Image Property

[image]

.NET ModelKit Suite ClassReference
Picture..::.Image Property
Picture Class See Also Send Feedback
Gets or sets Image of Picture element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Image Image { get; set; }
Visual Basic (Declaration)
Public Property Image As Image
Visual C++
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}

See Also

Picture Class
PerpetuumSoft.Instrumentation.Model Namespace


Stroke Property

[image]

.NET ModelKit Suite ClassReference
Picture..::.Stroke Property
Picture Class See Also Send Feedback
Gets or sets the Stroke object that is used to trace.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Stroke Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Stroke
Visual C++
public:
property Stroke^ Stroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

Picture Class
PerpetuumSoft.Instrumentation.Model Namespace


Picture Events

[image] [image]

.NET ModelKit Suite ClassReference
Picture Events
Picture Class See Also Send Feedback

The Picture type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Picture Class
PerpetuumSoft.Instrumentation.Model Namespace


PictureSet Class

[image]

.NET ModelKit Suite ClassReference
PictureSet Class
Members See Also Send Feedback
Represents the set of pictures.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class PictureSet : RectangleElement
Visual Basic (Declaration)
Public Class PictureSet _
    Inherits RectangleElement
Visual C++
public ref class PictureSet : public RectangleElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement
PerpetuumSoft.Instrumentation.Model..::.RectangleElement
PerpetuumSoft.Instrumentation.Model..::.PictureSet

See Also

PictureSet Members
PerpetuumSoft.Instrumentation.Model Namespace


PictureSet Members

[image] [image]

.NET ModelKit Suite ClassReference
PictureSet Members
PictureSet Class Constructors Methods Properties Events See Also Send Feedback

The PictureSet type exposes the following members.

Constructors

Name | Description
PictureSet | Initializes a new instance of the PictureSet class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from RectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
ImageIndex | Gets or sets index of the current image.
Images | Gets ImageCollection of Element.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets the Stroke object that is used to trace.
Style | Gets or sets name of the used style.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

PictureSet Class
PerpetuumSoft.Instrumentation.Model Namespace


PictureSet Constructor

[image]

.NET ModelKit Suite ClassReference
PictureSet Constructor
PictureSet Class See Also Send Feedback
Initializes a new instance of the PictureSet class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public PictureSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PictureSet()

See Also

PictureSet Class
PerpetuumSoft.Instrumentation.Model Namespace


PictureSet Methods

[image] [image]

.NET ModelKit Suite ClassReference
PictureSet Methods
PictureSet Class See Also Send Feedback

The PictureSet type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from RectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PictureSet Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureSet..::.Dispose Method
PictureSet Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Clean up any resources being used. (Overrides RectangleElement..::.Dispose(Boolean).)

See Also

PictureSet Class
PictureSet Members
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
PictureSet..::.Dispose Method (Boolean)
PictureSet Class See Also Send Feedback
Clean up any resources being used.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

PictureSet Class
Dispose Overload
PerpetuumSoft.Instrumentation.Model Namespace


DrawContent Method

[image]

.NET ModelKit Suite ClassReference
PictureSet..::.DrawContent Method
PictureSet Class See Also Send Feedback
Overridden. See DrawContent(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void DrawContent(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Protected Overrides Sub DrawContent ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
protected:
virtual void DrawContent(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

PictureSet Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureSet..::.GetStyle Method
PictureSet Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

PictureSet Class
PictureSet Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureSet..::.Invalidate Method
PictureSet Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

PictureSet Class
PictureSet Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureSet..::.OnPaint Method
PictureSet Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from RectangleElement.)

See Also

PictureSet Class
PictureSet Members
PerpetuumSoft.Instrumentation.Model Namespace


PictureSet Properties

[image] [image]

.NET ModelKit Suite ClassReference
PictureSet Properties
PictureSet Class See Also Send Feedback

The PictureSet type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
ImageIndex | Gets or sets index of the current image.
Images | Gets ImageCollection of Element.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets the Stroke object that is used to trace.
Style | Gets or sets name of the used style.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

PictureSet Class
PerpetuumSoft.Instrumentation.Model Namespace


ImageIndex Property

[image]

.NET ModelKit Suite ClassReference
PictureSet..::.ImageIndex Property
PictureSet Class See Also Send Feedback
Gets or sets index of the current image.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int ImageIndex { get; set; }
Visual Basic (Declaration)
Public Property ImageIndex As Integer
Visual C++
public:
property int ImageIndex {
    int get ();
    void set (int value);
}

See Also

PictureSet Class
PerpetuumSoft.Instrumentation.Model Namespace


Images Property

[image]

.NET ModelKit Suite ClassReference
PictureSet..::.Images Property
PictureSet Class See Also Send Feedback
Gets ImageCollection of Element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ImageCollection Images { get; }
Visual Basic (Declaration)
Public ReadOnly Property Images As ImageCollection
Visual C++
public:
property ImageCollection^ Images {
    ImageCollection^ get ();
}

See Also

PictureSet Class
PerpetuumSoft.Instrumentation.Model Namespace


Stroke Property

[image]

.NET ModelKit Suite ClassReference
PictureSet..::.Stroke Property
PictureSet Class See Also Send Feedback
Gets or sets the Stroke object that is used to trace.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Stroke Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Stroke
Visual C++
public:
property Stroke^ Stroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

PictureSet Class
PerpetuumSoft.Instrumentation.Model Namespace


Style Property

[image]

.NET ModelKit Suite ClassReference
PictureSet..::.Style Property
PictureSet Class See Also Send Feedback
Gets or sets name of the used style.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string Style { get; set; }
Visual Basic (Declaration)
Public Property Style As String
Visual C++
public:
property String^ Style {
    String^ get ();
    void set (String^ value);
}

See Also

PictureSet Class
PerpetuumSoft.Instrumentation.Model Namespace


PictureSet Events

[image] [image]

.NET ModelKit Suite ClassReference
PictureSet Events
PictureSet Class See Also Send Feedback

The PictureSet type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

PictureSet Class
PerpetuumSoft.Instrumentation.Model Namespace


Pie Class

[image]

.NET ModelKit Suite ClassReference
Pie Class
Members See Also Send Feedback
Represents the Pie.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Pie : ArcBase
Visual Basic (Declaration)
Public Class Pie _
    Inherits ArcBase
Visual C++
public ref class Pie : public ArcBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement
PerpetuumSoft.Instrumentation.Model..::.RectangleElement
PerpetuumSoft.Instrumentation.Model..::.ArcBase
PerpetuumSoft.Instrumentation.Model..::.Pie

See Also

Pie Members
PerpetuumSoft.Instrumentation.Model Namespace


Pie Members

[image] [image]

.NET ModelKit Suite ClassReference
Pie Members
Pie Class Constructors Methods Properties Events See Also Send Feedback

The Pie type exposes the following members.

Constructors

Name | Description
Pie | Initializes a new instance of the Pie class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides ArcBase..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from ArcBase.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartAngle | Gets or sets angle in degrees measured clockwise from the x-axis to the starting point of the arc. (Inherited from ArcBase.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SweepAngle | Gets or sets angle in degrees measured clockwise from the startAngle parameter to ending point of the arc. (Inherited from ArcBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Pie Class
PerpetuumSoft.Instrumentation.Model Namespace


Pie Constructor

[image]

.NET ModelKit Suite ClassReference
Pie Constructor
Pie Class See Also Send Feedback
Initializes a new instance of the Pie class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Pie()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Pie()

See Also

Pie Class
PerpetuumSoft.Instrumentation.Model Namespace


Pie Methods

[image] [image]

.NET ModelKit Suite ClassReference
Pie Methods
Pie Class See Also Send Feedback

The Pie type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides ArcBase..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from ArcBase.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Pie Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Pie..::.Dispose Method
Pie Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from RectangleElement.)

See Also

Pie Class
Pie Members
PerpetuumSoft.Instrumentation.Model Namespace


DrawContent Method

[image]

.NET ModelKit Suite ClassReference
Pie..::.DrawContent Method
Pie Class See Also Send Feedback
Overridden. See DrawContent(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void DrawContent(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Protected Overrides Sub DrawContent ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
protected:
virtual void DrawContent(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Pie Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Pie..::.GetStyle Method
Pie Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Pie Class
Pie Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Pie..::.Invalidate Method
Pie Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Pie Class
Pie Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Pie..::.OnPaint Method
Pie Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from RectangleElement.)

See Also

Pie Class
Pie Members
PerpetuumSoft.Instrumentation.Model Namespace


Pie Properties

[image] [image]

.NET ModelKit Suite ClassReference
Pie Properties
Pie Class See Also Send Feedback

The Pie type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartAngle | Gets or sets angle in degrees measured clockwise from the x-axis to the starting point of the arc. (Inherited from ArcBase.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SweepAngle | Gets or sets angle in degrees measured clockwise from the startAngle parameter to ending point of the arc. (Inherited from ArcBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Pie Class
PerpetuumSoft.Instrumentation.Model Namespace


Pie Events

[image] [image]

.NET ModelKit Suite ClassReference
Pie Events
Pie Class See Also Send Feedback

The Pie type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Pie Class
PerpetuumSoft.Instrumentation.Model Namespace


PointMode Enumeration

[image]

.NET ModelKit Suite ClassReference
PointMode Enumeration
See Also Send Feedback
Represents the control point mode.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public enum PointMode
Visual Basic (Declaration)
Public Enumeration PointMode
Visual C++
public enum class PointMode

Members

Member name | Description
Move | Intended for element moving.
MovePoint | Intended for change a linear property of the element.
SizeWE | The two-headed horizontal (west/east) element sizing.
SizeNS | The two-headed vertical (north/south) element sizing.
SizeNWSE | The two-headed diagonal (northwest/southeast) element sizing.
SizeNESW | The two-headed diagonal (northeast/southwest) element sizing.
Rotate | Intended for element rotating.
RotatePoint | Intended for change an angular property of the element.

See Also

PerpetuumSoft.Instrumentation.Model Namespace


Polygon Class

[image]

.NET ModelKit Suite ClassReference
Polygon Class
Members See Also Send Feedback
Represents the Poligon.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Polygon : CircularShape
Visual Basic (Declaration)
Public Class Polygon _
    Inherits CircularShape
Visual C++
public ref class Polygon : public CircularShape

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.CircularShape
PerpetuumSoft.Instrumentation.Model..::.Polygon
PerpetuumSoft.Instrumentation.Model..::.Star

See Also

Polygon Members
PerpetuumSoft.Instrumentation.Model Namespace


Polygon Members

[image] [image]

.NET ModelKit Suite ClassReference
Polygon Members
Polygon Class Constructors Methods Properties Events See Also Send Feedback

The Polygon type exposes the following members.

Constructors

Name | Description
Polygon | Initializes a new instance of the Polygon class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVertex | Returns vertexes of the poligon element.
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Gets or sets the angle by clockwize of the shape. (Inherited from CircularShape.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the shape. (Inherited from CircularShape.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Radius | Gets or sets the radius of the shape. (Inherited from CircularShape.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Sides | Gets or sets element sides count.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Polygon Class
PerpetuumSoft.Instrumentation.Model Namespace


Polygon Constructor

[image]

.NET ModelKit Suite ClassReference
Polygon Constructor
Polygon Class See Also Send Feedback
Initializes a new instance of the Polygon class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Polygon()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Polygon()

See Also

Polygon Class
PerpetuumSoft.Instrumentation.Model Namespace


Polygon Methods

[image] [image]

.NET ModelKit Suite ClassReference
Polygon Methods
Polygon Class See Also Send Feedback

The Polygon type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVertex | Returns vertexes of the poligon element.
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Polygon Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Polygon..::.Dispose Method
Polygon Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

Polygon Class
Polygon Members
PerpetuumSoft.Instrumentation.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
Polygon..::.GetBoundedBox Method
Polygon Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

Polygon Class
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
Polygon..::.GetHitTest Method
Polygon Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Polygon Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Polygon..::.GetStyle Method
Polygon Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Polygon Class
Polygon Members
PerpetuumSoft.Instrumentation.Model Namespace


GetVertex Method

[image]

.NET ModelKit Suite ClassReference
Polygon..::.GetVertex Method
Polygon Class See Also Send Feedback
Returns vertexes of the poligon element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual Vector[] GetVertex()
Visual Basic (Declaration)
Protected Overridable Function GetVertex As Vector()
Visual C++
protected:
virtual array<Vector>^ GetVertex()

See Also

Polygon Class
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Polygon..::.Invalidate Method
Polygon Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Polygon Class
Polygon Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Polygon..::.OnPaint Method
Polygon Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

Polygon Class
Polygon Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
Polygon..::.OnPaint Method (PaintArguments, Fill, Stroke)
Polygon Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Polygon Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


Polygon Properties

[image] [image]

.NET ModelKit Suite ClassReference
Polygon Properties
Polygon Class See Also Send Feedback

The Polygon type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Gets or sets the angle by clockwize of the shape. (Inherited from CircularShape.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the shape. (Inherited from CircularShape.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Radius | Gets or sets the radius of the shape. (Inherited from CircularShape.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Sides | Gets or sets element sides count.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Polygon Class
PerpetuumSoft.Instrumentation.Model Namespace


Sides Property

[image]

.NET ModelKit Suite ClassReference
Polygon..::.Sides Property
Polygon Class See Also Send Feedback
Gets or sets element sides count.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int Sides { get; set; }
Visual Basic (Declaration)
Public Property Sides As Integer
Visual C++
public:
property int Sides {
    int get ();
    void set (int value);
}

See Also

Polygon Class
PerpetuumSoft.Instrumentation.Model Namespace


Polygon Events

[image] [image]

.NET ModelKit Suite ClassReference
Polygon Events
Polygon Class See Also Send Feedback

The Polygon type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Polygon Class
PerpetuumSoft.Instrumentation.Model Namespace


PushButton Class

[image]

.NET ModelKit Suite ClassReference
PushButton Class
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Instrumentation.Model.PushButton]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class PushButton : ButtonBase
Visual Basic (Declaration)
Public Class PushButton _
    Inherits ButtonBase
Visual C++
public ref class PushButton : public ButtonBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.Composite
PerpetuumSoft.Instrumentation.Model..::.ButtonBase
PerpetuumSoft.Instrumentation.Model..::.PushButton

See Also

PushButton Members
PerpetuumSoft.Instrumentation.Model Namespace


PushButton Members

[image] [image]

.NET ModelKit Suite ClassReference
PushButton Members
PushButton Class Constructors Methods Properties Events See Also Send Feedback

The PushButton type exposes the following members.

Constructors

Name | Description
PushButton | Initializes a new instance of the PushButton class

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | (Inherited from ButtonBase.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | (Overrides Element..::.OnMouseDown(MouseArguments).)
OnMouseEnter | (Overrides Element..::.OnMouseEnter(MouseArguments).)
OnMouseLeave | (Overrides Element..::.OnMouseLeave(MouseArguments).)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | (Overrides Element..::.OnMouseUp(MouseArguments).)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
SetHot | (Inherited from ButtonBase.)
SetOn | (Inherited from ButtonBase.)
SetPressed | (Inherited from ButtonBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Hot | (Inherited from ButtonBase.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
On | (Inherited from ButtonBase.)
Parent | Implements Parent. (Inherited from Element.)
Pressed | (Inherited from ButtonBase.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

PushButton Class
PerpetuumSoft.Instrumentation.Model Namespace


PushButton Constructor

[image]

.NET ModelKit Suite ClassReference
PushButton Constructor
PushButton Class See Also Send Feedback
Initializes a new instance of the PushButton class

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public PushButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PushButton()

See Also

PushButton Class
PerpetuumSoft.Instrumentation.Model Namespace


PushButton Methods

[image] [image]

.NET ModelKit Suite ClassReference
PushButton Methods
PushButton Class See Also Send Feedback

The PushButton type exposes the following members.

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | (Inherited from ButtonBase.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | (Overrides Element..::.OnMouseDown(MouseArguments).)
OnMouseEnter | (Overrides Element..::.OnMouseEnter(MouseArguments).)
OnMouseLeave | (Overrides Element..::.OnMouseLeave(MouseArguments).)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | (Overrides Element..::.OnMouseUp(MouseArguments).)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
SetHot | (Inherited from ButtonBase.)
SetOn | (Inherited from ButtonBase.)
SetPressed | (Inherited from ButtonBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PushButton Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
PushButton..::.Dispose Method
PushButton Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from Composite.)

See Also

PushButton Class
PushButton Members
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
PushButton..::.GetStyle Method
PushButton Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

PushButton Class
PushButton Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
PushButton..::.Invalidate Method
PushButton Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

PushButton Class
PushButton Members
PerpetuumSoft.Instrumentation.Model Namespace


OnMouseDown Method

[image]

.NET ModelKit Suite ClassReference
PushButton..::.OnMouseDown Method
PushButton Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.PushButton.OnMouseDown(PerpetuumSoft.Framework.Model.MouseArguments)]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnMouseDown(
    MouseArguments args
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseDown ( _
    args As MouseArguments _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.MouseArguments

See Also

PushButton Class
PerpetuumSoft.Instrumentation.Model Namespace


OnMouseEnter Method

[image]

.NET ModelKit Suite ClassReference
PushButton..::.OnMouseEnter Method
PushButton Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.PushButton.OnMouseEnter(PerpetuumSoft.Framework.Model.MouseArguments)]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnMouseEnter(
    MouseArguments args
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseEnter ( _
    args As MouseArguments _
)
Visual C++
protected:
virtual void OnMouseEnter(
    MouseArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.MouseArguments

See Also

PushButton Class
PerpetuumSoft.Instrumentation.Model Namespace


OnMouseLeave Method

[image]

.NET ModelKit Suite ClassReference
PushButton..::.OnMouseLeave Method
PushButton Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.PushButton.OnMouseLeave(PerpetuumSoft.Framework.Model.MouseArguments)]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnMouseLeave(
    MouseArguments args
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeave ( _
    args As MouseArguments _
)
Visual C++
protected:
virtual void OnMouseLeave(
    MouseArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.MouseArguments

See Also

PushButton Class
PerpetuumSoft.Instrumentation.Model Namespace


OnMouseUp Method

[image]

.NET ModelKit Suite ClassReference
PushButton..::.OnMouseUp Method
PushButton Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.PushButton.OnMouseUp(PerpetuumSoft.Framework.Model.MouseArguments)]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnMouseUp(
    MouseArguments args
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseUp ( _
    args As MouseArguments _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.MouseArguments

See Also

PushButton Class
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
PushButton..::.OnPaint Method
PushButton Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Inherited from Composite.)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

PushButton Class
PushButton Members
PerpetuumSoft.Instrumentation.Model Namespace


PushButton Properties

[image] [image]

.NET ModelKit Suite ClassReference
PushButton Properties
PushButton Class See Also Send Feedback

The PushButton type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Hot | (Inherited from ButtonBase.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
On | (Inherited from ButtonBase.)
Parent | Implements Parent. (Inherited from Element.)
Pressed | (Inherited from ButtonBase.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

PushButton Class
PerpetuumSoft.Instrumentation.Model Namespace


PushButton Events

[image] [image]

.NET ModelKit Suite ClassReference
PushButton Events
PushButton Class See Also Send Feedback

The PushButton type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

PushButton Class
PerpetuumSoft.Instrumentation.Model Namespace


RangedLevel Class

[image]

.NET ModelKit Suite ClassReference
RangedLevel Class
Members See Also Send Feedback
Represents level with ranged width.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class RangedLevel : LevelBase
Visual Basic (Declaration)
Public Class RangedLevel _
    Inherits LevelBase
Visual C++
public ref class RangedLevel : public LevelBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.ScaleElement
PerpetuumSoft.Instrumentation.Model..::.ValuePresenterScaleElement
PerpetuumSoft.Instrumentation.Model..::.LevelBase
PerpetuumSoft.Instrumentation.Model..::.RangedLevel

See Also

RangedLevel Members
PerpetuumSoft.Instrumentation.Model Namespace


RangedLevel Members

[image] [image]

.NET ModelKit Suite ClassReference
RangedLevel Members
RangedLevel Class Constructors Methods Properties Events See Also Send Feedback

The RangedLevel type exposes the following members.

Constructors

Name | Description
RangedLevel | Initializes a new instance of the RangedLevel class.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetMaxValue | Return maximim value from represented values. (Inherited from ValuePresenterScaleElement.)
GetMinValue | Returns minimum value from represented values. (Inherited from ValuePresenterScaleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()(). (Overrides ScaleElement..::.GetSize()()().)
GetSmartValue | Returns value by SmartValue amd calculated value for the Auto case. (Inherited from ValuePresenterScaleElement.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Inherited from ScaleElement.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleElement.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from LevelBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
AlignmentMode | Gets or sets alignment mode.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets object used for scale coloring.
Colors | Gets ColorSectionCollection, reperesenting colors used in the level gradient fill. (Inherited from LevelBase.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Divisions | Gets or sets divisions count. (Inherited from LevelBase.)
DivisionsStroke | Gets or sets stroke used for darwing divisions. (Inherited from LevelBase.)
Dock | Implements Dock. (Inherited from ScaleElement.)
EndColor | Gets or sets color used in the end point of the level gradient fill. (Inherited from LevelBase.)
EndWidth | Gets or sets end width.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartColor | Gets or sets color used in the start point of the level gradient fill. (Inherited from LevelBase.)
StartWidth | Gets or sets start width.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Value | Gets or sets represented value. (Inherited from ValuePresenterScaleElement.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

RangedLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


RangedLevel Constructor

[image]

.NET ModelKit Suite ClassReference
RangedLevel Constructor
RangedLevel Class See Also Send Feedback
Initializes a new instance of the RangedLevel class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public RangedLevel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RangedLevel()

See Also

RangedLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


RangedLevel Methods

[image] [image]

.NET ModelKit Suite ClassReference
RangedLevel Methods
RangedLevel Class See Also Send Feedback

The RangedLevel type exposes the following members.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetMaxValue | Return maximim value from represented values. (Inherited from ValuePresenterScaleElement.)
GetMinValue | Returns minimum value from represented values. (Inherited from ValuePresenterScaleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()(). (Overrides ScaleElement..::.GetSize()()().)
GetSmartValue | Returns value by SmartValue amd calculated value for the Auto case. (Inherited from ValuePresenterScaleElement.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Inherited from ScaleElement.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleElement.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from LevelBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RangedLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
RangedLevel..::.Dispose Method
RangedLevel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

RangedLevel Class
RangedLevel Members
PerpetuumSoft.Instrumentation.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
RangedLevel..::.GetBoundedBox Method
RangedLevel Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

RangedLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
RangedLevel..::.GetHitTest Method
RangedLevel Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

RangedLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


GetSize Method

[image]

.NET ModelKit Suite ClassReference
RangedLevel..::.GetSize Method
RangedLevel Class See Also Send Feedback
Implements GetSize()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override double GetSize()
Visual Basic (Declaration)
Public Overrides Function GetSize As Double
Visual C++
public:
virtual double GetSize() override

Implements

IScaleElement..::.GetSize()()()

See Also

RangedLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
RangedLevel..::.GetStyle Method
RangedLevel Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

RangedLevel Class
RangedLevel Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
RangedLevel..::.Invalidate Method
RangedLevel Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

RangedLevel Class
RangedLevel Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
RangedLevel..::.OnPaint Method
RangedLevel Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Overrides Element..::.OnPaint(PaintArguments).)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

RangedLevel Class
RangedLevel Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments)

[image]

.NET ModelKit Suite ClassReference
RangedLevel..::.OnPaint Method (PaintArguments)
RangedLevel Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

RangedLevel Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
RangedLevel..::.OnPaint Method (PaintArguments, Fill, Stroke)
RangedLevel Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

RangedLevel Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


RangedLevel Properties

[image] [image]

.NET ModelKit Suite ClassReference
RangedLevel Properties
RangedLevel Class See Also Send Feedback

The RangedLevel type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
AlignmentMode | Gets or sets alignment mode.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets object used for scale coloring.
Colors | Gets ColorSectionCollection, reperesenting colors used in the level gradient fill. (Inherited from LevelBase.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Divisions | Gets or sets divisions count. (Inherited from LevelBase.)
DivisionsStroke | Gets or sets stroke used for darwing divisions. (Inherited from LevelBase.)
Dock | Implements Dock. (Inherited from ScaleElement.)
EndColor | Gets or sets color used in the end point of the level gradient fill. (Inherited from LevelBase.)
EndWidth | Gets or sets end width.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartColor | Gets or sets color used in the start point of the level gradient fill. (Inherited from LevelBase.)
StartWidth | Gets or sets start width.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Value | Gets or sets represented value. (Inherited from ValuePresenterScaleElement.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

RangedLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


AlignmentMode Property

[image]

.NET ModelKit Suite ClassReference
RangedLevel..::.AlignmentMode Property
RangedLevel Class See Also Send Feedback
Gets or sets alignment mode.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public AlignmentMode AlignmentMode { get; set; }
Visual Basic (Declaration)
Public Property AlignmentMode As AlignmentMode
Visual C++
public:
property AlignmentMode AlignmentMode {
    AlignmentMode get ();
    void set (AlignmentMode value);
}

See Also

RangedLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Colorizer Property

[image]

.NET ModelKit Suite ClassReference
RangedLevel..::.Colorizer Property
RangedLevel Class See Also Send Feedback
Gets object used for scale coloring.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Colorizer Colorizer { get; set; }
Visual Basic (Declaration)
Public Property Colorizer As Colorizer
Visual C++
public:
property Colorizer^ Colorizer {
    Colorizer^ get ();
    void set (Colorizer^ value);
}

See Also

RangedLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


EndWidth Property

[image]

.NET ModelKit Suite ClassReference
RangedLevel..::.EndWidth Property
RangedLevel Class See Also Send Feedback
Gets or sets end width.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double EndWidth { get; set; }
Visual Basic (Declaration)
Public Property EndWidth As Double
Visual C++
public:
property double EndWidth {
    double get ();
    void set (double value);
}

See Also

RangedLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


StartWidth Property

[image]

.NET ModelKit Suite ClassReference
RangedLevel..::.StartWidth Property
RangedLevel Class See Also Send Feedback
Gets or sets start width.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double StartWidth { get; set; }
Visual Basic (Declaration)
Public Property StartWidth As Double
Visual C++
public:
property double StartWidth {
    double get ();
    void set (double value);
}

See Also

RangedLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


RangedLevel Events

[image] [image]

.NET ModelKit Suite ClassReference
RangedLevel Events
RangedLevel Class See Also Send Feedback

The RangedLevel type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

RangedLevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Rectangle Class

[image]

.NET ModelKit Suite ClassReference
Rectangle Class
Members See Also Send Feedback
Represents the Rectangle.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Rectangle : RectangleElement
Visual Basic (Declaration)
Public Class Rectangle _
    Inherits RectangleElement
Visual C++
public ref class Rectangle : public RectangleElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement
PerpetuumSoft.Instrumentation.Model..::.RectangleElement
PerpetuumSoft.Instrumentation.Model..::.Rectangle

See Also

Rectangle Members
PerpetuumSoft.Instrumentation.Model Namespace


Rectangle Members

[image] [image]

.NET ModelKit Suite ClassReference
Rectangle Members
Rectangle Class Constructors Methods Properties Events See Also Send Feedback

The Rectangle type exposes the following members.

Constructors

Name | Description
Rectangle | Initializes a new instance of the Rectangle class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from RectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Rectangle Class
PerpetuumSoft.Instrumentation.Model Namespace


Rectangle Constructor

[image]

.NET ModelKit Suite ClassReference
Rectangle Constructor
Rectangle Class See Also Send Feedback
Initializes a new instance of the Rectangle class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Rectangle()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Rectangle()

See Also

Rectangle Class
PerpetuumSoft.Instrumentation.Model Namespace


Rectangle Methods

[image] [image]

.NET ModelKit Suite ClassReference
Rectangle Methods
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from RectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Rectangle Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Rectangle..::.Dispose Method
Rectangle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from RectangleElement.)

See Also

Rectangle Class
Rectangle Members
PerpetuumSoft.Instrumentation.Model Namespace


DrawContent Method

[image]

.NET ModelKit Suite ClassReference
Rectangle..::.DrawContent Method
Rectangle Class See Also Send Feedback
Overridden. See DrawContent(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void DrawContent(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Protected Overrides Sub DrawContent ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
protected:
virtual void DrawContent(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Rectangle Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Rectangle..::.GetStyle Method
Rectangle Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Rectangle Class
Rectangle Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Rectangle..::.Invalidate Method
Rectangle Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Rectangle Class
Rectangle Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Rectangle..::.OnPaint Method
Rectangle Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from RectangleElement.)

See Also

Rectangle Class
Rectangle Members
PerpetuumSoft.Instrumentation.Model Namespace


Rectangle Properties

[image] [image]

.NET ModelKit Suite ClassReference
Rectangle Properties
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Rectangle Class
PerpetuumSoft.Instrumentation.Model Namespace


Rectangle Events

[image] [image]

.NET ModelKit Suite ClassReference
Rectangle Events
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Rectangle Class
PerpetuumSoft.Instrumentation.Model Namespace


RectangleBevelDrawingStyle Enumeration

[image]

.NET ModelKit Suite ClassReference
RectangleBevelDrawingStyle Enumeration
See Also Send Feedback
Enumerates the rectangular bevel drawing effect types.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public enum RectangleBevelDrawingStyle
Visual Basic (Declaration)
Public Enumeration RectangleBevelDrawingStyle
Visual C++
public enum class RectangleBevelDrawingStyle

Members

Member name | Description
Sharp | Defines the sharp gradation effect.
Smooth | Defines the smooth gradation effect.

See Also

PerpetuumSoft.Instrumentation.Model Namespace


RectangleElement Class

[image]

.NET ModelKit Suite ClassReference
RectangleElement Class
Members See Also Send Feedback
Represents a rectangle element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract class RectangleElement : SimpleRectangleElement
Visual Basic (Declaration)
Public MustInherit Class RectangleElement _
    Inherits SimpleRectangleElement
Visual C++
public ref class RectangleElement abstract : public SimpleRectangleElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement
PerpetuumSoft.Instrumentation.Model..::.RectangleElement
PerpetuumSoft.Instrumentation.Model..::.ArcBase
PerpetuumSoft.Instrumentation.Model..::.Ellipse
PerpetuumSoft.Instrumentation.Model..::.Frame
PerpetuumSoft.Instrumentation.Model..::.Label
PerpetuumSoft.Instrumentation.Model..::.Picture
PerpetuumSoft.Instrumentation.Model..::.PictureSet
PerpetuumSoft.Instrumentation.Model..::.Rectangle
PerpetuumSoft.Instrumentation.Model..::.RoundedRectangle
PerpetuumSoft.Instrumentation.Model.Specialized..::.DigitalText
PerpetuumSoft.Instrumentation.Model.Specialized..::.Digits
PerpetuumSoft.Instrumentation.Model.Specialized..::.Odometer

See Also

RectangleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


RectangleElement Members

[image] [image]

.NET ModelKit Suite ClassReference
RectangleElement Members
RectangleElement Class Constructors Methods Properties Events See Also Send Feedback

The RectangleElement type exposes the following members.

Constructors

Name | Description
RectangleElement | Initializes a new instance of the RectangleElement class

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Draws element's contents, drawing is determined in the derived classes.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides SimpleRectangleElement..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides SimpleRectangleElement..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Overrides SimpleRectangleElement..::.OnBoundsChanged()()().)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle.
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

RectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


RectangleElement Constructor

[image]

.NET ModelKit Suite ClassReference
RectangleElement Constructor
RectangleElement Class See Also Send Feedback
Initializes a new instance of the RectangleElement class

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected RectangleElement()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
RectangleElement()

See Also

RectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


RectangleElement Methods

[image] [image]

.NET ModelKit Suite ClassReference
RectangleElement Methods
RectangleElement Class See Also Send Feedback

The RectangleElement type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Draws element's contents, drawing is determined in the derived classes.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides SimpleRectangleElement..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides SimpleRectangleElement..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Overrides SimpleRectangleElement..::.OnBoundsChanged()()().)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
RectangleElement..::.Dispose Method
RectangleElement Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Overrides Element..::.Dispose(Boolean).)

See Also

RectangleElement Class
RectangleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
RectangleElement..::.Dispose Method (Boolean)
RectangleElement Class See Also Send Feedback
Overridden. See Dispose(Boolean).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

RectangleElement Class
Dispose Overload
PerpetuumSoft.Instrumentation.Model Namespace


DrawContent Method

[image]

.NET ModelKit Suite ClassReference
RectangleElement..::.DrawContent Method
RectangleElement Class See Also Send Feedback
Draws element's contents, drawing is determined in the derived classes.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void DrawContent(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Protected Overridable Sub DrawContent ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
protected:
virtual void DrawContent(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
)

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

RectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
RectangleElement..::.GetBoundedBox Method
RectangleElement Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

RectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
RectangleElement..::.GetHitTest Method
RectangleElement Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

RectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
RectangleElement..::.GetStyle Method
RectangleElement Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

RectangleElement Class
RectangleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
RectangleElement..::.Invalidate Method
RectangleElement Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

RectangleElement Class
RectangleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


OnBoundsChanged Method

[image]

.NET ModelKit Suite ClassReference
RectangleElement..::.OnBoundsChanged Method
RectangleElement Class See Also Send Feedback
This method is called when bounds are changed.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnBoundsChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnBoundsChanged
Visual C++
protected:
virtual void OnBoundsChanged() override

See Also

RectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
RectangleElement..::.OnPaint Method
RectangleElement Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

RectangleElement Class
RectangleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
RectangleElement..::.OnPaint Method (PaintArguments, Fill, Stroke)
RectangleElement Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

RectangleElement Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


RectangleElement Properties

[image] [image]

.NET ModelKit Suite ClassReference
RectangleElement Properties
RectangleElement Class See Also Send Feedback

The RectangleElement type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle.
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

RectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


Angle Property

[image]

.NET ModelKit Suite ClassReference
RectangleElement..::.Angle Property
RectangleElement Class See Also Send Feedback
Angle in degrees measured clockwise from the x-axis of the rectangle.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

See Also

RectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


RectangleElement Events

[image] [image]

.NET ModelKit Suite ClassReference
RectangleElement Events
RectangleElement Class See Also Send Feedback

The RectangleElement type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

RectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


RingSector Class

[image]

.NET ModelKit Suite ClassReference
RingSector Class
Members See Also Send Feedback
Represents the Ring sector.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class RingSector : ArcBase
Visual Basic (Declaration)
Public Class RingSector _
    Inherits ArcBase
Visual C++
public ref class RingSector : public ArcBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement
PerpetuumSoft.Instrumentation.Model..::.RectangleElement
PerpetuumSoft.Instrumentation.Model..::.ArcBase
PerpetuumSoft.Instrumentation.Model..::.RingSector

See Also

RingSector Members
PerpetuumSoft.Instrumentation.Model Namespace


RingSector Members

[image] [image]

.NET ModelKit Suite ClassReference
RingSector Members
RingSector Class Constructors Methods Properties Events See Also Send Feedback

The RingSector type exposes the following members.

Constructors

Name | Description
RingSector | Initializes a new instance of the RingSector class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides ArcBase..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides ArcBase..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
InternalRadius | Gets or sets internal radius of element.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartAngle | Gets or sets angle in degrees measured clockwise from the x-axis to the starting point of the arc. (Inherited from ArcBase.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SweepAngle | Gets or sets angle in degrees measured clockwise from the startAngle parameter to ending point of the arc. (Inherited from ArcBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

RingSector Class
PerpetuumSoft.Instrumentation.Model Namespace


RingSector Constructor

[image]

.NET ModelKit Suite ClassReference
RingSector Constructor
RingSector Class See Also Send Feedback
Initializes a new instance of the RingSector class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public RingSector()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RingSector()

See Also

RingSector Class
PerpetuumSoft.Instrumentation.Model Namespace


RingSector Methods

[image] [image]

.NET ModelKit Suite ClassReference
RingSector Methods
RingSector Class See Also Send Feedback

The RingSector type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides ArcBase..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides ArcBase..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RingSector Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
RingSector..::.Dispose Method
RingSector Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from RectangleElement.)

See Also

RingSector Class
RingSector Members
PerpetuumSoft.Instrumentation.Model Namespace


DrawContent Method

[image]

.NET ModelKit Suite ClassReference
RingSector..::.DrawContent Method
RingSector Class See Also Send Feedback
Overridden. See DrawContent(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void DrawContent(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Protected Overrides Sub DrawContent ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
protected:
virtual void DrawContent(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

RingSector Class
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
RingSector..::.GetHitTest Method
RingSector Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

RingSector Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
RingSector..::.GetStyle Method
RingSector Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

RingSector Class
RingSector Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
RingSector..::.Invalidate Method
RingSector Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

RingSector Class
RingSector Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
RingSector..::.OnPaint Method
RingSector Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from RectangleElement.)

See Also

RingSector Class
RingSector Members
PerpetuumSoft.Instrumentation.Model Namespace


RingSector Properties

[image] [image]

.NET ModelKit Suite ClassReference
RingSector Properties
RingSector Class See Also Send Feedback

The RingSector type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
InternalRadius | Gets or sets internal radius of element.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartAngle | Gets or sets angle in degrees measured clockwise from the x-axis to the starting point of the arc. (Inherited from ArcBase.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SweepAngle | Gets or sets angle in degrees measured clockwise from the startAngle parameter to ending point of the arc. (Inherited from ArcBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

RingSector Class
PerpetuumSoft.Instrumentation.Model Namespace


InternalRadius Property

[image]

.NET ModelKit Suite ClassReference
RingSector..::.InternalRadius Property
RingSector Class See Also Send Feedback
Gets or sets internal radius of element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double InternalRadius { get; set; }
Visual Basic (Declaration)
Public Property InternalRadius As Double
Visual C++
public:
property double InternalRadius {
    double get ();
    void set (double value);
}

See Also

RingSector Class
PerpetuumSoft.Instrumentation.Model Namespace


RingSector Events

[image] [image]

.NET ModelKit Suite ClassReference
RingSector Events
RingSector Class See Also Send Feedback

The RingSector type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

RingSector Class
PerpetuumSoft.Instrumentation.Model Namespace


RoundedRectangle Class

[image]

.NET ModelKit Suite ClassReference
RoundedRectangle Class
Members See Also Send Feedback
Represents rectangle with rounded angles.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class RoundedRectangle : RectangleElement
Visual Basic (Declaration)
Public Class RoundedRectangle _
    Inherits RectangleElement
Visual C++
public ref class RoundedRectangle : public RectangleElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement
PerpetuumSoft.Instrumentation.Model..::.RectangleElement
PerpetuumSoft.Instrumentation.Model..::.RoundedRectangle

See Also

RoundedRectangle Members
PerpetuumSoft.Instrumentation.Model Namespace


RoundedRectangle Members

[image] [image]

.NET ModelKit Suite ClassReference
RoundedRectangle Members
RoundedRectangle Class Constructors Methods Properties Events See Also Send Feedback

The RoundedRectangle type exposes the following members.

Constructors

Name | Description
RoundedRectangle | Initializes a new instance of the RoundedRectangle class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from RectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Radius | Gets or sets radius of angles.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

RoundedRectangle Class
PerpetuumSoft.Instrumentation.Model Namespace


RoundedRectangle Constructor

[image]

.NET ModelKit Suite ClassReference
RoundedRectangle Constructor
RoundedRectangle Class See Also Send Feedback
Initializes a new instance of the RoundedRectangle class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public RoundedRectangle()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoundedRectangle()

See Also

RoundedRectangle Class
PerpetuumSoft.Instrumentation.Model Namespace


RoundedRectangle Methods

[image] [image]

.NET ModelKit Suite ClassReference
RoundedRectangle Methods
RoundedRectangle Class See Also Send Feedback

The RoundedRectangle type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from RectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoundedRectangle Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
RoundedRectangle..::.Dispose Method
RoundedRectangle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from RectangleElement.)

See Also

RoundedRectangle Class
RoundedRectangle Members
PerpetuumSoft.Instrumentation.Model Namespace


DrawContent Method

[image]

.NET ModelKit Suite ClassReference
RoundedRectangle..::.DrawContent Method
RoundedRectangle Class See Also Send Feedback
Overridden. See DrawContent(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void DrawContent(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Protected Overrides Sub DrawContent ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
protected:
virtual void DrawContent(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

RoundedRectangle Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
RoundedRectangle..::.GetStyle Method
RoundedRectangle Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

RoundedRectangle Class
RoundedRectangle Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
RoundedRectangle..::.Invalidate Method
RoundedRectangle Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

RoundedRectangle Class
RoundedRectangle Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
RoundedRectangle..::.OnPaint Method
RoundedRectangle Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from RectangleElement.)

See Also

RoundedRectangle Class
RoundedRectangle Members
PerpetuumSoft.Instrumentation.Model Namespace


RoundedRectangle Properties

[image] [image]

.NET ModelKit Suite ClassReference
RoundedRectangle Properties
RoundedRectangle Class See Also Send Feedback

The RoundedRectangle type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Radius | Gets or sets radius of angles.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

RoundedRectangle Class
PerpetuumSoft.Instrumentation.Model Namespace


Radius Property

[image]

.NET ModelKit Suite ClassReference
RoundedRectangle..::.Radius Property
RoundedRectangle Class See Also Send Feedback
Gets or sets radius of angles.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Radius { get; set; }
Visual Basic (Declaration)
Public Property Radius As Double
Visual C++
public:
property double Radius {
    double get ();
    void set (double value);
}

See Also

RoundedRectangle Class
PerpetuumSoft.Instrumentation.Model Namespace


RoundedRectangle Events

[image] [image]

.NET ModelKit Suite ClassReference
RoundedRectangle Events
RoundedRectangle Class See Also Send Feedback

The RoundedRectangle type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

RoundedRectangle Class
PerpetuumSoft.Instrumentation.Model Namespace


Scale Class

[image]

.NET ModelKit Suite ClassReference
Scale Class
Members See Also Send Feedback
Represents the Scale.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Scale : Composite, IScale
Visual Basic (Declaration)
Public Class Scale _
    Inherits Composite _
    Implements IScale
Visual C++
public ref class Scale : public Composite,
    IScale

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.Composite
PerpetuumSoft.Instrumentation.Model..::.Scale

See Also

Scale Members
PerpetuumSoft.Instrumentation.Model Namespace


Scale Members

[image] [image]

.NET ModelKit Suite ClassReference
Scale Members
Scale Class Constructors Methods Properties Events See Also Send Feedback

The Scale type exposes the following members.

Constructors

Name | Description
Scale | Initializes a new instance of the Scale class.

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See [M:PerpetuumSoft.Instrumentation.Model.Element.Calculate*].] (Overrides Composite..::.Calculate()()().)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
FromRealValue | Implements FromRealValue(Object).
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetDiscreteValue | Implements GetDiscreteValue(Int32).
GetDiscreteValuesCount | Implements GetDiscreteValuesCount()()().
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Overrides Element..::.GetObject(String).)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PercentToValue | Implements PercentToValue(Double).
PointToValue | Implements PointToValue(Vector).
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToRealValue | Implements ToRealValue(Double).
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValueToPercent | Implements ValueToPercent(Double).
ValueToPoint | Implements ValueToPoint(Double, Double).

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Implements Colorizer.
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
IsDiscrete | Implements IsDiscrete.
Maximum | Implements Maximum.
Minimum | Implements Minimum.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Reverse | Gets or sets Boolean
Smooth | Gets or sets value that indicates whether smoothing will be applied.
Stroke | Gets or sets the Stroke object that is used to trace.
Style | Gets or sets name of the used style.
Trajectory | Gets scale trajectory.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


Scale Constructor

[image]

.NET ModelKit Suite ClassReference
Scale Constructor
Scale Class See Also Send Feedback
Initializes a new instance of the Scale class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Scale()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Scale()

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


Scale Methods

[image] [image]

.NET ModelKit Suite ClassReference
Scale Methods
Scale Class See Also Send Feedback

The Scale type exposes the following members.

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See [M:PerpetuumSoft.Instrumentation.Model.Element.Calculate*].] (Overrides Composite..::.Calculate()()().)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
FromRealValue | Implements FromRealValue(Object).
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetDiscreteValue | Implements GetDiscreteValue(Int32).
GetDiscreteValuesCount | Implements GetDiscreteValuesCount()()().
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Overrides Element..::.GetObject(String).)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PercentToValue | Implements PercentToValue(Double).
PointToValue | Implements PointToValue(Vector).
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToRealValue | Implements ToRealValue(Double).
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValueToPercent | Implements ValueToPercent(Double).
ValueToPoint | Implements ValueToPoint(Double, Double).

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


Calculate Method

[image]

.NET ModelKit Suite ClassReference
Scale..::.Calculate Method
Scale Class See Also Send Feedback
Overridden. See [M:PerpetuumSoft.Instrumentation.Model.Element.Calculate*].]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void Calculate()
Visual Basic (Declaration)
Protected Overrides Sub Calculate
Visual C++
protected:
virtual void Calculate() override

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Scale..::.Dispose Method
Scale Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from Composite.)

See Also

Scale Class
Scale Members
PerpetuumSoft.Instrumentation.Model Namespace


FromRealValue Method

[image]

.NET ModelKit Suite ClassReference
Scale..::.FromRealValue Method
Scale Class See Also Send Feedback
Implements FromRealValue(Object).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double FromRealValue(
    Object value
)
Visual Basic (Declaration)
Public Function FromRealValue ( _
    value As Object _
) As Double
Visual C++
public:
virtual double FromRealValue(
    Object^ value
) sealed

Parameters

value
Type: System..::.Object

Implements

IScale..::.FromRealValue(Object)

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


GetDiscreteValue Method

[image]

.NET ModelKit Suite ClassReference
Scale..::.GetDiscreteValue Method
Scale Class See Also Send Feedback
Implements GetDiscreteValue(Int32).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Object GetDiscreteValue(
    int index
)
Visual Basic (Declaration)
Public Function GetDiscreteValue ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ GetDiscreteValue(
    int index
) sealed

Parameters

index
Type: System..::.Int32

Implements

IScale..::.GetDiscreteValue(Int32)

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


GetDiscreteValuesCount Method

[image]

.NET ModelKit Suite ClassReference
Scale..::.GetDiscreteValuesCount Method
Scale Class See Also Send Feedback
Implements GetDiscreteValuesCount()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int GetDiscreteValuesCount()
Visual Basic (Declaration)
Public Function GetDiscreteValuesCount As Integer
Visual C++
public:
virtual int GetDiscreteValuesCount() sealed

Implements

IScale..::.GetDiscreteValuesCount()()()

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


GetObject Method

[image]

.NET ModelKit Suite ClassReference
Scale..::.GetObject Method
Scale Class See Also Send Feedback
Implements GetObject(String).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Object GetObject(
    string name
)
Visual Basic (Declaration)
Public Overrides Function GetObject ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetObject(
    String^ name
) override

Parameters

name
Type: System..::.String

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Scale..::.GetStyle Method
Scale Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Scale Class
Scale Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Scale..::.Invalidate Method
Scale Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Scale Class
Scale Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Scale..::.OnPaint Method
Scale Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Inherited from Composite.)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

Scale Class
Scale Members
PerpetuumSoft.Instrumentation.Model Namespace


PercentToValue Method

[image]

.NET ModelKit Suite ClassReference
Scale..::.PercentToValue Method
Scale Class See Also Send Feedback
Implements PercentToValue(Double).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double PercentToValue(
    double percent
)
Visual Basic (Declaration)
Public Function PercentToValue ( _
    percent As Double _
) As Double
Visual C++
public:
virtual double PercentToValue(
    double percent
) sealed

Parameters

percent
Type: System..::.Double

Implements

IScale..::.PercentToValue(Double)

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


PointToValue Method

[image]

.NET ModelKit Suite ClassReference
Scale..::.PointToValue Method
Scale Class See Also Send Feedback
Implements PointToValue(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double PointToValue(
    Vector point
)
Visual Basic (Declaration)
Public Function PointToValue ( _
    point As Vector _
) As Double
Visual C++
public:
virtual double PointToValue(
    Vector point
) sealed

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

Implements

IScale..::.PointToValue(Vector)

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


ToRealValue Method

[image]

.NET ModelKit Suite ClassReference
Scale..::.ToRealValue Method
Scale Class See Also Send Feedback
Implements ToRealValue(Double).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Object ToRealValue(
    double value
)
Visual Basic (Declaration)
Public Function ToRealValue ( _
    value As Double _
) As Object
Visual C++
public:
virtual Object^ ToRealValue(
    double value
) sealed

Parameters

value
Type: System..::.Double

Implements

IScale..::.ToRealValue(Double)

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


ValueToPercent Method

[image]

.NET ModelKit Suite ClassReference
Scale..::.ValueToPercent Method
Scale Class See Also Send Feedback
Implements ValueToPercent(Double).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double ValueToPercent(
    double value
)
Visual Basic (Declaration)
Public Function ValueToPercent ( _
    value As Double _
) As Double
Visual C++
public:
virtual double ValueToPercent(
    double value
) sealed

Parameters

value
Type: System..::.Double

Implements

IScale..::.ValueToPercent(Double)

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


ValueToPoint Method

[image]

.NET ModelKit Suite ClassReference
Scale..::.ValueToPoint Method
Scale Class See Also Send Feedback
Implements ValueToPoint(Double, Double).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Vector ValueToPoint(
    double value,
    double radius
)
Visual Basic (Declaration)
Public Function ValueToPoint ( _
    value As Double, _
    radius As Double _
) As Vector
Visual C++
public:
virtual Vector ValueToPoint(
    double value,
    double radius
) sealed

Parameters

value
Type: System..::.Double
radius
Type: System..::.Double

Implements

IScale..::.ValueToPoint(Double, Double)

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


Scale Properties

[image] [image]

.NET ModelKit Suite ClassReference
Scale Properties
Scale Class See Also Send Feedback

The Scale type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Implements Colorizer.
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
IsDiscrete | Implements IsDiscrete.
Maximum | Implements Maximum.
Minimum | Implements Minimum.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Reverse | Gets or sets Boolean
Smooth | Gets or sets value that indicates whether smoothing will be applied.
Stroke | Gets or sets the Stroke object that is used to trace.
Style | Gets or sets name of the used style.
Trajectory | Gets scale trajectory.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


Colorizer Property

[image]

.NET ModelKit Suite ClassReference
Scale..::.Colorizer Property
Scale Class See Also Send Feedback
Implements Colorizer.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Colorizer Colorizer { get; set; }
Visual Basic (Declaration)
Public Property Colorizer As Colorizer
Visual C++
public:
virtual property Colorizer^ Colorizer {
    Colorizer^ get () sealed;
    void set (Colorizer^ value) sealed;
}

Implements

IScale..::.Colorizer

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
Scale..::.Fill Property
Scale Class See Also Send Feedback
Gets or sets the Fill object that is used to paint over.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


IsDiscrete Property

[image]

.NET ModelKit Suite ClassReference
Scale..::.IsDiscrete Property
Scale Class See Also Send Feedback
Implements IsDiscrete.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool IsDiscrete { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDiscrete As Boolean
Visual C++
public:
virtual property bool IsDiscrete {
    bool get () sealed;
}

Implements

IScale..::.IsDiscrete

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


Maximum Property

[image]

.NET ModelKit Suite ClassReference
Scale..::.Maximum Property
Scale Class See Also Send Feedback
Implements Maximum.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Maximum { get; set; }
Visual Basic (Declaration)
Public Property Maximum As Double
Visual C++
public:
virtual property double Maximum {
    double get () sealed;
    void set (double value) sealed;
}

Implements

IScale..::.Maximum

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


Minimum Property

[image]

.NET ModelKit Suite ClassReference
Scale..::.Minimum Property
Scale Class See Also Send Feedback
Implements Minimum.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Minimum { get; set; }
Visual Basic (Declaration)
Public Property Minimum As Double
Visual C++
public:
virtual property double Minimum {
    double get () sealed;
    void set (double value) sealed;
}

Implements

IScale..::.Minimum

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


Reverse Property

[image]

.NET ModelKit Suite ClassReference
Scale..::.Reverse Property
Scale Class See Also Send Feedback
Gets or sets Boolean

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Reverse { get; set; }
Visual Basic (Declaration)
Public Property Reverse As Boolean
Visual C++
public:
property bool Reverse {
    bool get ();
    void set (bool value);
}

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


Smooth Property

[image]

.NET ModelKit Suite ClassReference
Scale..::.Smooth Property
Scale Class See Also Send Feedback
Gets or sets value that indicates whether smoothing will be applied.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Smooth { get; set; }
Visual Basic (Declaration)
Public Property Smooth As Boolean
Visual C++
public:
property bool Smooth {
    bool get ();
    void set (bool value);
}

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


Stroke Property

[image]

.NET ModelKit Suite ClassReference
Scale..::.Stroke Property
Scale Class See Also Send Feedback
Gets or sets the Stroke object that is used to trace.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Stroke Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Stroke
Visual C++
public:
property Stroke^ Stroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


Style Property

[image]

.NET ModelKit Suite ClassReference
Scale..::.Style Property
Scale Class See Also Send Feedback
Gets or sets name of the used style.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string Style { get; set; }
Visual Basic (Declaration)
Public Property Style As String
Visual C++
public:
property String^ Style {
    String^ get ();
    void set (String^ value);
}

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


Trajectory Property

[image]

.NET ModelKit Suite ClassReference
Scale..::.Trajectory Property
Scale Class See Also Send Feedback
Gets scale trajectory.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ITrajectory Trajectory { get; }
Visual Basic (Declaration)
Public ReadOnly Property Trajectory As ITrajectory
Visual C++
public:
property ITrajectory^ Trajectory {
    ITrajectory^ get ();
}

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


Scale Events

[image] [image]

.NET ModelKit Suite ClassReference
Scale Events
Scale Class See Also Send Feedback

The Scale type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Scale Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleDocking Enumeration

[image]

.NET ModelKit Suite ClassReference
ScaleDocking Enumeration
See Also Send Feedback
Enumerates the scale docking type.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public enum ScaleDocking
Visual Basic (Declaration)
Public Enumeration ScaleDocking
Visual C++
public enum class ScaleDocking

Members

Member name | Description
None | Specifies that the scale docking is not defined.
Inside | Specifies the inside scale docing.
Outside | Specifies the outside scale docing.
Center | Specifies the center scale docing.

See Also

PerpetuumSoft.Instrumentation.Model Namespace


ScaleElement Class

[image]

.NET ModelKit Suite ClassReference
ScaleElement Class
Members See Also Send Feedback
Represents basic class for scale elements.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract class ScaleElement : Element,
    IScaleElement
Visual Basic (Declaration)
Public MustInherit Class ScaleElement _
    Inherits Element _
    Implements IScaleElement
Visual C++
public ref class ScaleElement abstract : public Element,
    IScaleElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.ScaleElement
PerpetuumSoft.Instrumentation.Model..::.ScaleLabelsBase
PerpetuumSoft.Instrumentation.Model..::.ScaleMarksBase
PerpetuumSoft.Instrumentation.Model..::.ValuePresenterScaleElement

See Also

ScaleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


ScaleElement Members

[image] [image]

.NET ModelKit Suite ClassReference
ScaleElement Members
ScaleElement Class Constructors Methods Properties Events See Also Send Feedback

The ScaleElement type exposes the following members.

Constructors

Name | Description
ScaleElement | Initializes a new instance of the ScaleElement class

Methods

Name | Description
Calculate | (Overrides Element..::.Calculate()()().)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value.
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()().
GetStartValue | Overloaded.
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsPaint | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Overrides Element..::.OnParentChanged()()().)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Overrides Element..::.OnStyleChanged()()().)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()().
SetStartDistance | Implements SetStartDistance(Double).
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element.
Distance | Gets or sets distance.
Dock | Implements Dock.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MaxLimit | Gets or sets maximum value limit.
MinLimit | Gets or sets minimum value limit.
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets scale start point that is used during scale elements allocation.
Padding | Implements Padding.
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleElement Constructor

[image]

.NET ModelKit Suite ClassReference
ScaleElement Constructor
ScaleElement Class See Also Send Feedback
Initializes a new instance of the ScaleElement class

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected ScaleElement()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ScaleElement()

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleElement Methods

[image] [image]

.NET ModelKit Suite ClassReference
ScaleElement Methods
ScaleElement Class See Also Send Feedback

The ScaleElement type exposes the following members.

Methods

Name | Description
Calculate | (Overrides Element..::.Calculate()()().)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value.
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()().
GetStartValue | Overloaded.
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsPaint | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Overrides Element..::.OnParentChanged()()().)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Overrides Element..::.OnStyleChanged()()().)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()().
SetStartDistance | Implements SetStartDistance(Double).
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


Calculate Method

[image]

.NET ModelKit Suite ClassReference
ScaleElement..::.Calculate Method
ScaleElement Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.ScaleElement.Calculate]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void Calculate()
Visual Basic (Declaration)
Protected Overrides Sub Calculate
Visual C++
protected:
virtual void Calculate() override

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleElement..::.Dispose Method
ScaleElement Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

ScaleElement Class
ScaleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


GetColor Method

[image]

.NET ModelKit Suite ClassReference
ScaleElement..::.GetColor Method
ScaleElement Class See Also Send Feedback
Returns the color by the given value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual Color GetColor(
    double value
)
Visual Basic (Declaration)
Protected Overridable Function GetColor ( _
    value As Double _
) As Color
Visual C++
protected:
virtual Color GetColor(
    double value
)

Parameters

value
Type: System..::.Double

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


GetSize Method

[image]

.NET ModelKit Suite ClassReference
ScaleElement..::.GetSize Method
ScaleElement Class See Also Send Feedback
Implements GetSize()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract double GetSize()
Visual Basic (Declaration)
Public MustOverride Function GetSize As Double
Visual C++
public:
virtual double GetSize() abstract

Implements

IScaleElement..::.GetSize()()()

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStartValue Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleElement..::.GetStartValue Method
ScaleElement Class See Also Send Feedback

Overload List

Name | Description
GetStartValue(Double) | Returns start value.
GetStartValue(IScale, SmartValue, Double) | Returns start value with specific parameters.

See Also

ScaleElement Class
ScaleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


GetStartValue Method (Double)

[image]

.NET ModelKit Suite ClassReference
ScaleElement..::.GetStartValue Method (Double)
ScaleElement Class See Also Send Feedback
Returns start value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double GetStartValue(
    double length
)
Visual Basic (Declaration)
Public Function GetStartValue ( _
    length As Double _
) As Double
Visual C++
public:
double GetStartValue(
    double length
)

Parameters

length
Type: System..::.Double

See Also

ScaleElement Class
GetStartValue Overload
PerpetuumSoft.Instrumentation.Model Namespace


GetStartValue Method (IScale, SmartValue, Double)

[image]

.NET ModelKit Suite ClassReference
ScaleElement..::.GetStartValue Method (IScale, SmartValue, Double)
ScaleElement Class See Also Send Feedback
Returns start value with specific parameters.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static double GetStartValue(
    IScale scale,
    SmartValue origin,
    double length
)
Visual Basic (Declaration)
Public Shared Function GetStartValue ( _
    scale As IScale, _
    origin As SmartValue, _
    length As Double _
) As Double
Visual C++
public:
static double GetStartValue(
    IScale^ scale,
    SmartValue origin,
    double length
)

Parameters

scale
Type: PerpetuumSoft.Instrumentation.Model..::.IScale
origin
Type: PerpetuumSoft.Instrumentation.Model..::.SmartValue
length
Type: System..::.Double

See Also

ScaleElement Class
GetStartValue Overload
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleElement..::.GetStyle Method
ScaleElement Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

ScaleElement Class
ScaleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleElement..::.Invalidate Method
ScaleElement Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

ScaleElement Class
ScaleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


IsPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleElement..::.IsPaint Method
ScaleElement Class See Also Send Feedback

Overload List

Name | Description
IsPaint(Double) | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale.
IsPaint(IScale, SmartValue, SmartValue, Double) | Returns value, indicating whether element is drawn at the specified scale value.

See Also

ScaleElement Class
ScaleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


IsPaint Method (Double)

[image]

.NET ModelKit Suite ClassReference
ScaleElement..::.IsPaint Method (Double)
ScaleElement Class See Also Send Feedback
Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected bool IsPaint(
    double value
)
Visual Basic (Declaration)
Protected Function IsPaint ( _
    value As Double _
) As Boolean
Visual C++
protected:
bool IsPaint(
    double value
)

Parameters

value
Type: System..::.Double

See Also

ScaleElement Class
IsPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


IsPaint Method (IScale, SmartValue, SmartValue, Double)

[image]

.NET ModelKit Suite ClassReference
ScaleElement..::.IsPaint Method (IScale, SmartValue, SmartValue, Double)
ScaleElement Class See Also Send Feedback
Returns value, indicating whether element is drawn at the specified scale value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static bool IsPaint(
    IScale scale,
    SmartValue minLimit,
    SmartValue maxLimit,
    double value
)
Visual Basic (Declaration)
Public Shared Function IsPaint ( _
    scale As IScale, _
    minLimit As SmartValue, _
    maxLimit As SmartValue, _
    value As Double _
) As Boolean
Visual C++
public:
static bool IsPaint(
    IScale^ scale,
    SmartValue minLimit,
    SmartValue maxLimit,
    double value
)

Parameters

scale
Type: PerpetuumSoft.Instrumentation.Model..::.IScale
minLimit
Type: PerpetuumSoft.Instrumentation.Model..::.SmartValue
maxLimit
Type: PerpetuumSoft.Instrumentation.Model..::.SmartValue
value
Type: System..::.Double

See Also

ScaleElement Class
IsPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleElement..::.OnPaint Method
ScaleElement Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

ScaleElement Class
ScaleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


OnParentChanged Method

[image]

.NET ModelKit Suite ClassReference
ScaleElement..::.OnParentChanged Method
ScaleElement Class See Also Send Feedback
Is called when the Parent property is changed.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnParentChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnParentChanged
Visual C++
protected:
virtual void OnParentChanged() override

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


OnStyleChanged Method

[image]

.NET ModelKit Suite ClassReference
ScaleElement..::.OnStyleChanged Method
ScaleElement Class See Also Send Feedback
Is called when the Style property is changed.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnStyleChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnStyleChanged
Visual C++
protected:
virtual void OnStyleChanged() override

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


ResetMeasure Method

[image]

.NET ModelKit Suite ClassReference
ScaleElement..::.ResetMeasure Method
ScaleElement Class See Also Send Feedback
Implements ResetMeasure()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public virtual void ResetMeasure()
Visual Basic (Declaration)
Public Overridable Sub ResetMeasure
Visual C++
public:
virtual void ResetMeasure()

Implements

IScaleElement..::.ResetMeasure()()()

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


SetStartDistance Method

[image]

.NET ModelKit Suite ClassReference
ScaleElement..::.SetStartDistance Method
ScaleElement Class See Also Send Feedback
Implements SetStartDistance(Double).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public virtual void SetStartDistance(
    double distance
)
Visual Basic (Declaration)
Public Overridable Sub SetStartDistance ( _
    distance As Double _
)
Visual C++
public:
virtual void SetStartDistance(
    double distance
)

Parameters

distance
Type: System..::.Double

Implements

IScaleElement..::.SetStartDistance(Double)

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleElement Properties

[image] [image]

.NET ModelKit Suite ClassReference
ScaleElement Properties
ScaleElement Class See Also Send Feedback

The ScaleElement type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element.
Distance | Gets or sets distance.
Dock | Implements Dock.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MaxLimit | Gets or sets maximum value limit.
MinLimit | Gets or sets minimum value limit.
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets scale start point that is used during scale elements allocation.
Padding | Implements Padding.
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


Colorizer Property

[image]

.NET ModelKit Suite ClassReference
ScaleElement..::.Colorizer Property
ScaleElement Class See Also Send Feedback
Gets or sets Colorizer for element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Colorizer Colorizer { get; set; }
Visual Basic (Declaration)
Public Property Colorizer As Colorizer
Visual C++
public:
property Colorizer^ Colorizer {
    Colorizer^ get ();
    void set (Colorizer^ value);
}

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


Distance Property

[image]

.NET ModelKit Suite ClassReference
ScaleElement..::.Distance Property
ScaleElement Class See Also Send Feedback
Gets or sets distance.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Distance { get; set; }
Visual Basic (Declaration)
Public Property Distance As Double
Visual C++
public:
property double Distance {
    double get ();
    void set (double value);
}

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


Dock Property

[image]

.NET ModelKit Suite ClassReference
ScaleElement..::.Dock Property
ScaleElement Class See Also Send Feedback
Implements Dock.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ScaleDocking Dock { get; set; }
Visual Basic (Declaration)
Public Property Dock As ScaleDocking
Visual C++
public:
virtual property ScaleDocking Dock {
    ScaleDocking get () sealed;
    void set (ScaleDocking value) sealed;
}

Implements

IScaleElement..::.Dock

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


MaxLimit Property

[image]

.NET ModelKit Suite ClassReference
ScaleElement..::.MaxLimit Property
ScaleElement Class See Also Send Feedback
Gets or sets maximum value limit.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue MaxLimit { get; set; }
Visual Basic (Declaration)
Public Property MaxLimit As SmartValue
Visual C++
public:
property SmartValue MaxLimit {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


MinLimit Property

[image]

.NET ModelKit Suite ClassReference
ScaleElement..::.MinLimit Property
ScaleElement Class See Also Send Feedback
Gets or sets minimum value limit.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue MinLimit { get; set; }
Visual Basic (Declaration)
Public Property MinLimit As SmartValue
Visual C++
public:
property SmartValue MinLimit {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


Origin Property

[image]

.NET ModelKit Suite ClassReference
ScaleElement..::.Origin Property
ScaleElement Class See Also Send Feedback
Gets or sets scale start point that is used during scale elements allocation.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue Origin { get; set; }
Visual Basic (Declaration)
Public Property Origin As SmartValue
Visual C++
public:
property SmartValue Origin {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


Padding Property

[image]

.NET ModelKit Suite ClassReference
ScaleElement..::.Padding Property
ScaleElement Class See Also Send Feedback
Implements Padding.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Padding { get; set; }
Visual Basic (Declaration)
Public Property Padding As Double
Visual C++
public:
virtual property double Padding {
    double get () sealed;
    void set (double value) sealed;
}

Implements

IScaleElement..::.Padding

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


Scale Property

[image]

.NET ModelKit Suite ClassReference
ScaleElement..::.Scale Property
ScaleElement Class See Also Send Feedback
Gets a scale where an element is located.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public IScale Scale { get; }
Visual Basic (Declaration)
Public ReadOnly Property Scale As IScale
Visual C++
public:
property IScale^ Scale {
    IScale^ get ();
}

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleElement Events

[image] [image]

.NET ModelKit Suite ClassReference
ScaleElement Events
ScaleElement Class See Also Send Feedback

The ScaleElement type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleKind Enumeration

[image]

.NET ModelKit Suite ClassReference
ScaleKind Enumeration
See Also Send Feedback
Enumerates scale types.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public enum ScaleKind
Visual Basic (Declaration)
Public Enumeration ScaleKind
Visual C++
public enum class ScaleKind

Members

Member name | Description
ExcludeMinimum | Specifies scale with excluded maximum value.
ExcludeMaximum | Specifies scale with excluded minimum value.
IncludeBoth | Specifies scale with excluded maximum and minimum values.

See Also

PerpetuumSoft.Instrumentation.Model Namespace


ScaleLabels Class

[image]

.NET ModelKit Suite ClassReference
ScaleLabels Class
Members See Also Send Feedback
Represents Scale labels.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class ScaleLabels : ScaleLabelsBase
Visual Basic (Declaration)
Public Class ScaleLabels _
    Inherits ScaleLabelsBase
Visual C++
public ref class ScaleLabels : public ScaleLabelsBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.ScaleElement
PerpetuumSoft.Instrumentation.Model..::.ScaleLabelsBase
PerpetuumSoft.Instrumentation.Model..::.ScaleLabels
PerpetuumSoft.Instrumentation.Model..::.NumericLabels

See Also

ScaleLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


ScaleLabels Members

[image] [image]

.NET ModelKit Suite ClassReference
ScaleLabels Members
ScaleLabels Class Constructors Methods Properties Events See Also Send Feedback

The ScaleLabels type exposes the following members.

Constructors

Name | Description
ScaleLabels | Initializes a new instance of the ScaleLabels class.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from ScaleLabelsBase.)
GetLabel | Returns label text.
GetLabelsCount | Return labels count. (Overrides ScaleLabelsBase..::.GetLabelsCount()()().)
GetObject | Implements GetObject(String). (Inherited from ScaleLabelsBase.)
GetObjectByIndex | Overridden. See GetObjectByIndex(Int32). (Overrides ScaleLabelsBase..::.GetObjectByIndex(Int32).)
GetSize | Implements GetSize()()(). (Inherited from ScaleLabelsBase.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetTextLabel | Returns label text by the assigned value. (Inherited from ScaleLabelsBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueByIndex | Overridden. See GetValueByIndex(Int32). (Overrides ScaleLabelsBase..::.GetValueByIndex(Int32).)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Raises the OnParentChanged event. (Inherited from ScaleLabelsBase.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is called when element's visibility is changed. (Inherited from ScaleLabelsBase.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLabel | Draws a scale mark. (Inherited from ScaleLabelsBase.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleLabelsBase.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleLabelsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Divisions | Gets or sets divisions count, will be used if the Step property is set to Auto.
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets FontDescriptor of the element. (Inherited from ScaleLabelsBase.)
Format | Gets and sets text format for the labels. (Inherited from ScaleLabelsBase.)
Formula | Gets or sets expression used for calculating labels value. (Inherited from ScaleLabelsBase.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
ItemMargins | Gets or sets item margins. (Inherited from ScaleLabelsBase.)
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
OddLabelsDistance | Gets or sets distance foк odd labels. (Inherited from ScaleLabelsBase.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
Position | Gets or sets label position mode. (Inherited from ScaleLabelsBase.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
ShowSuperposableLabels | Gets or sets value that indicates whether superposable labels will be shown. (Inherited from ScaleLabelsBase.)
Size | Gets element size. (Inherited from ScaleLabelsBase.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Step | Gets or sets interval between labels.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
TextAlignment | Gets or sets text alignment. (Inherited from ScaleLabelsBase.)
TextAngle | Gets or sets text angle. (Inherited from ScaleLabelsBase.)
TextRotationMode | Gets or sets text rotation mode. (Inherited from ScaleLabelsBase.)
UseRoundValues | Gets or sets value that indicates if label values will be round.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ScaleLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleLabels Constructor

[image]

.NET ModelKit Suite ClassReference
ScaleLabels Constructor
ScaleLabels Class See Also Send Feedback
Initializes a new instance of the ScaleLabels class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ScaleLabels()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ScaleLabels()

See Also

ScaleLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleLabels Methods

[image] [image]

.NET ModelKit Suite ClassReference
ScaleLabels Methods
ScaleLabels Class See Also Send Feedback

The ScaleLabels type exposes the following members.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from ScaleLabelsBase.)
GetLabel | Returns label text.
GetLabelsCount | Return labels count. (Overrides ScaleLabelsBase..::.GetLabelsCount()()().)
GetObject | Implements GetObject(String). (Inherited from ScaleLabelsBase.)
GetObjectByIndex | Overridden. See GetObjectByIndex(Int32). (Overrides ScaleLabelsBase..::.GetObjectByIndex(Int32).)
GetSize | Implements GetSize()()(). (Inherited from ScaleLabelsBase.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetTextLabel | Returns label text by the assigned value. (Inherited from ScaleLabelsBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueByIndex | Overridden. See GetValueByIndex(Int32). (Overrides ScaleLabelsBase..::.GetValueByIndex(Int32).)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Raises the OnParentChanged event. (Inherited from ScaleLabelsBase.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is called when element's visibility is changed. (Inherited from ScaleLabelsBase.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLabel | Draws a scale mark. (Inherited from ScaleLabelsBase.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleLabelsBase.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleLabelsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScaleLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleLabels..::.Dispose Method
ScaleLabels Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

ScaleLabels Class
ScaleLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
ScaleLabels..::.GetBoundedBox Method
ScaleLabels Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

ScaleLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


GetLabel Method

[image]

.NET ModelKit Suite ClassReference
ScaleLabels..::.GetLabel Method
ScaleLabels Class See Also Send Feedback
Returns label text.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public virtual string GetLabel(
    int index
)
Visual Basic (Declaration)
Public Overridable Function GetLabel ( _
    index As Integer _
) As String
Visual C++
public:
virtual String^ GetLabel(
    int index
)

Parameters

index
Type: System..::.Int32

See Also

ScaleLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


GetLabelsCount Method

[image]

.NET ModelKit Suite ClassReference
ScaleLabels..::.GetLabelsCount Method
ScaleLabels Class See Also Send Feedback
Return labels count.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override int GetLabelsCount()
Visual Basic (Declaration)
Public Overrides Function GetLabelsCount As Integer
Visual C++
public:
virtual int GetLabelsCount() override

See Also

ScaleLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


GetObjectByIndex Method

[image]

.NET ModelKit Suite ClassReference
ScaleLabels..::.GetObjectByIndex Method
ScaleLabels Class See Also Send Feedback
Overridden. See GetObjectByIndex(Int32).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Object GetObjectByIndex(
    int index
)
Visual Basic (Declaration)
Public Overrides Function GetObjectByIndex ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ GetObjectByIndex(
    int index
) override

Parameters

index
Type: System..::.Int32

See Also

ScaleLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleLabels..::.GetStyle Method
ScaleLabels Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

ScaleLabels Class
ScaleLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


GetValueByIndex Method

[image]

.NET ModelKit Suite ClassReference
ScaleLabels..::.GetValueByIndex Method
ScaleLabels Class See Also Send Feedback
Overridden. See GetValueByIndex(Int32).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override double GetValueByIndex(
    int index
)
Visual Basic (Declaration)
Public Overrides Function GetValueByIndex ( _
    index As Integer _
) As Double
Visual C++
public:
virtual double GetValueByIndex(
    int index
) override

Parameters

index
Type: System..::.Int32

See Also

ScaleLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleLabels..::.Invalidate Method
ScaleLabels Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

ScaleLabels Class
ScaleLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleLabels..::.OnPaint Method
ScaleLabels Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from ScaleLabelsBase.)

See Also

ScaleLabels Class
ScaleLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


ScaleLabels Properties

[image] [image]

.NET ModelKit Suite ClassReference
ScaleLabels Properties
ScaleLabels Class See Also Send Feedback

The ScaleLabels type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Divisions | Gets or sets divisions count, will be used if the Step property is set to Auto.
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets FontDescriptor of the element. (Inherited from ScaleLabelsBase.)
Format | Gets and sets text format for the labels. (Inherited from ScaleLabelsBase.)
Formula | Gets or sets expression used for calculating labels value. (Inherited from ScaleLabelsBase.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
ItemMargins | Gets or sets item margins. (Inherited from ScaleLabelsBase.)
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
OddLabelsDistance | Gets or sets distance foк odd labels. (Inherited from ScaleLabelsBase.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
Position | Gets or sets label position mode. (Inherited from ScaleLabelsBase.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
ShowSuperposableLabels | Gets or sets value that indicates whether superposable labels will be shown. (Inherited from ScaleLabelsBase.)
Size | Gets element size. (Inherited from ScaleLabelsBase.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Step | Gets or sets interval between labels.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
TextAlignment | Gets or sets text alignment. (Inherited from ScaleLabelsBase.)
TextAngle | Gets or sets text angle. (Inherited from ScaleLabelsBase.)
TextRotationMode | Gets or sets text rotation mode. (Inherited from ScaleLabelsBase.)
UseRoundValues | Gets or sets value that indicates if label values will be round.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

ScaleLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


Divisions Property

[image]

.NET ModelKit Suite ClassReference
ScaleLabels..::.Divisions Property
ScaleLabels Class See Also Send Feedback
Gets or sets divisions count, will be used if the Step property is set to Auto.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int Divisions { get; set; }
Visual Basic (Declaration)
Public Property Divisions As Integer
Visual C++
public:
property int Divisions {
    int get ();
    void set (int value);
}

See Also

ScaleLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


Step Property

[image]

.NET ModelKit Suite ClassReference
ScaleLabels..::.Step Property
ScaleLabels Class See Also Send Feedback
Gets or sets interval between labels.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue Step { get; set; }
Visual Basic (Declaration)
Public Property Step As SmartValue
Visual C++
public:
property SmartValue Step {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

ScaleLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


UseRoundValues Property

[image]

.NET ModelKit Suite ClassReference
ScaleLabels..::.UseRoundValues Property
ScaleLabels Class See Also Send Feedback
Gets or sets value that indicates if label values will be round.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool UseRoundValues { get; set; }
Visual Basic (Declaration)
Public Property UseRoundValues As Boolean
Visual C++
public:
property bool UseRoundValues {
    bool get ();
    void set (bool value);
}

See Also

ScaleLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleLabels Events

[image] [image]

.NET ModelKit Suite ClassReference
ScaleLabels Events
ScaleLabels Class See Also Send Feedback

The ScaleLabels type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ScaleLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleLabelsBase Class

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase Class
Members See Also Send Feedback
Represents the base class for scale labels.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract class ScaleLabelsBase : ScaleElement
Visual Basic (Declaration)
Public MustInherit Class ScaleLabelsBase _
    Inherits ScaleElement
Visual C++
public ref class ScaleLabelsBase abstract : public ScaleElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.ScaleElement
PerpetuumSoft.Instrumentation.Model..::.ScaleLabelsBase
PerpetuumSoft.Instrumentation.Model..::.CustomLabels
PerpetuumSoft.Instrumentation.Model..::.ScaleLabels
PerpetuumSoft.Instrumentation.Model..::.ScaleTitle

See Also

ScaleLabelsBase Members
PerpetuumSoft.Instrumentation.Model Namespace


ScaleLabelsBase Members

[image] [image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase Members
ScaleLabelsBase Class Constructors Methods Properties Events See Also Send Feedback

The ScaleLabelsBase type exposes the following members.

Constructors

Name | Description
ScaleLabelsBase | Initializes a new instance of the ScaleLabelsBase class

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetLabelsCount | Return labels count.
GetObject | Implements GetObject(String). (Overrides Element..::.GetObject(String).)
GetObjectByIndex | Returns scale mark value by its index.
GetSize | Implements GetSize()()(). (Overrides ScaleElement..::.GetSize()()().)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetTextLabel | Returns label text by the assigned value.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueByIndex | Returns scale mark value by its index.
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Raises the OnParentChanged event. (Overrides ScaleElement..::.OnParentChanged()()().)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is called when element's visibility is changed. (Overrides Element..::.OnVisibleChanged()()().)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLabel | Draws a scale mark.
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Overrides ScaleElement..::.ResetMeasure()()().)
SetStartDistance | Implements SetStartDistance(Double). (Overrides ScaleElement..::.SetStartDistance(Double).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets FontDescriptor of the element.
Format | Gets and sets text format for the labels.
Formula | Gets or sets expression used for calculating labels value.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
ItemMargins | Gets or sets item margins.
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
OddLabelsDistance | Gets or sets distance foк odd labels.
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
Position | Gets or sets label position mode.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
ShowSuperposableLabels | Gets or sets value that indicates whether superposable labels will be shown.
Size | Gets element size.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
TextAlignment | Gets or sets text alignment.
TextAngle | Gets or sets text angle.
TextRotationMode | Gets or sets text rotation mode.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleLabelsBase Constructor

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase Constructor
ScaleLabelsBase Class See Also Send Feedback
Initializes a new instance of the ScaleLabelsBase class

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected ScaleLabelsBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ScaleLabelsBase()

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleLabelsBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase Methods
ScaleLabelsBase Class See Also Send Feedback

The ScaleLabelsBase type exposes the following members.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetLabelsCount | Return labels count.
GetObject | Implements GetObject(String). (Overrides Element..::.GetObject(String).)
GetObjectByIndex | Returns scale mark value by its index.
GetSize | Implements GetSize()()(). (Overrides ScaleElement..::.GetSize()()().)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetTextLabel | Returns label text by the assigned value.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueByIndex | Returns scale mark value by its index.
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Raises the OnParentChanged event. (Overrides ScaleElement..::.OnParentChanged()()().)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is called when element's visibility is changed. (Overrides Element..::.OnVisibleChanged()()().)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLabel | Draws a scale mark.
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Overrides ScaleElement..::.ResetMeasure()()().)
SetStartDistance | Implements SetStartDistance(Double). (Overrides ScaleElement..::.SetStartDistance(Double).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.Dispose Method
ScaleLabelsBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

ScaleLabelsBase Class
ScaleLabelsBase Members
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.GetHitTest Method
ScaleLabelsBase Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


GetLabelsCount Method

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.GetLabelsCount Method
ScaleLabelsBase Class See Also Send Feedback
Return labels count.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract int GetLabelsCount()
Visual Basic (Declaration)
Public MustOverride Function GetLabelsCount As Integer
Visual C++
public:
virtual int GetLabelsCount() abstract

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


GetObject Method

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.GetObject Method
ScaleLabelsBase Class See Also Send Feedback
Implements GetObject(String).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Object GetObject(
    string name
)
Visual Basic (Declaration)
Public Overrides Function GetObject ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetObject(
    String^ name
) override

Parameters

name
Type: System..::.String

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


GetObjectByIndex Method

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.GetObjectByIndex Method
ScaleLabelsBase Class See Also Send Feedback
Returns scale mark value by its index.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract Object GetObjectByIndex(
    int index
)
Visual Basic (Declaration)
Public MustOverride Function GetObjectByIndex ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ GetObjectByIndex(
    int index
) abstract

Parameters

index
Type: System..::.Int32

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


GetSize Method

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.GetSize Method
ScaleLabelsBase Class See Also Send Feedback
Implements GetSize()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override double GetSize()
Visual Basic (Declaration)
Public Overrides Function GetSize As Double
Visual C++
public:
virtual double GetSize() override

Implements

IScaleElement..::.GetSize()()()

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.GetStyle Method
ScaleLabelsBase Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

ScaleLabelsBase Class
ScaleLabelsBase Members
PerpetuumSoft.Instrumentation.Model Namespace


GetTextLabel Method

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.GetTextLabel Method
ScaleLabelsBase Class See Also Send Feedback
Returns label text by the assigned value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected string GetTextLabel(
    Object obj
)
Visual Basic (Declaration)
Protected Function GetTextLabel ( _
    obj As Object _
) As String
Visual C++
protected:
String^ GetTextLabel(
    Object^ obj
)

Parameters

obj
Type: System..::.Object

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


GetValueByIndex Method

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.GetValueByIndex Method
ScaleLabelsBase Class See Also Send Feedback
Returns scale mark value by its index.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract double GetValueByIndex(
    int index
)
Visual Basic (Declaration)
Public MustOverride Function GetValueByIndex ( _
    index As Integer _
) As Double
Visual C++
public:
virtual double GetValueByIndex(
    int index
) abstract

Parameters

index
Type: System..::.Int32

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.Invalidate Method
ScaleLabelsBase Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

ScaleLabelsBase Class
ScaleLabelsBase Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.OnPaint Method
ScaleLabelsBase Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

ScaleLabelsBase Class
ScaleLabelsBase Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.OnPaint Method (PaintArguments, Fill, Stroke)
ScaleLabelsBase Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

ScaleLabelsBase Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


OnParentChanged Method

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.OnParentChanged Method
ScaleLabelsBase Class See Also Send Feedback
Raises the OnParentChanged event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnParentChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnParentChanged
Visual C++
protected:
virtual void OnParentChanged() override

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


OnVisibleChanged Method

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.OnVisibleChanged Method
ScaleLabelsBase Class See Also Send Feedback
Is called when element's visibility is changed.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnVisibleChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnVisibleChanged
Visual C++
protected:
virtual void OnVisibleChanged() override

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


PaintLabel Method

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.PaintLabel Method
ScaleLabelsBase Class See Also Send Feedback
Draws a scale mark.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void PaintLabel(
    GraphicStream stream,
    string text,
    double value,
    VectorRectangle labelArea,
    Vector textSize,
    Vector centerTextPosition,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Protected Overridable Sub PaintLabel ( _
    stream As GraphicStream, _
    text As String, _
    value As Double, _
    labelArea As VectorRectangle, _
    textSize As Vector, _
    centerTextPosition As Vector, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
protected:
virtual void PaintLabel(
    GraphicStream^ stream,
    String^ text,
    double value,
    VectorRectangle labelArea,
    Vector textSize,
    Vector centerTextPosition,
    Fill^ fill,
    Stroke^ stroke
)

Parameters

stream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
text
Type: System..::.String
value
Type: System..::.Double
labelArea
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
textSize
Type: PerpetuumSoft.Framework.Drawing..::.Vector
centerTextPosition
Type: PerpetuumSoft.Framework.Drawing..::.Vector
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ResetMeasure Method

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.ResetMeasure Method
ScaleLabelsBase Class See Also Send Feedback
Implements ResetMeasure()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void ResetMeasure()
Visual Basic (Declaration)
Public Overrides Sub ResetMeasure
Visual C++
public:
virtual void ResetMeasure() override

Implements

IScaleElement..::.ResetMeasure()()()

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


SetStartDistance Method

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.SetStartDistance Method
ScaleLabelsBase Class See Also Send Feedback
Implements SetStartDistance(Double).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void SetStartDistance(
    double distance
)
Visual Basic (Declaration)
Public Overrides Sub SetStartDistance ( _
    distance As Double _
)
Visual C++
public:
virtual void SetStartDistance(
    double distance
) override

Parameters

distance
Type: System..::.Double

Implements

IScaleElement..::.SetStartDistance(Double)

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleLabelsBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase Properties
ScaleLabelsBase Class See Also Send Feedback

The ScaleLabelsBase type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets FontDescriptor of the element.
Format | Gets and sets text format for the labels.
Formula | Gets or sets expression used for calculating labels value.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
ItemMargins | Gets or sets item margins.
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
OddLabelsDistance | Gets or sets distance foк odd labels.
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
Position | Gets or sets label position mode.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
ShowSuperposableLabels | Gets or sets value that indicates whether superposable labels will be shown.
Size | Gets element size.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
TextAlignment | Gets or sets text alignment.
TextAngle | Gets or sets text angle.
TextRotationMode | Gets or sets text rotation mode.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Font Property

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.Font Property
ScaleLabelsBase Class See Also Send Feedback
Gets or sets FontDescriptor of the element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public FontDescriptor Font { get; set; }
Visual Basic (Declaration)
Public Property Font As FontDescriptor
Visual C++
public:
property FontDescriptor^ Font {
    FontDescriptor^ get ();
    void set (FontDescriptor^ value);
}

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Format Property

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.Format Property
ScaleLabelsBase Class See Also Send Feedback
Gets and sets text format for the labels.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public TextFormat Format { get; set; }
Visual Basic (Declaration)
Public Property Format As TextFormat
Visual C++
public:
property TextFormat^ Format {
    TextFormat^ get ();
    void set (TextFormat^ value);
}

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Formula Property

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.Formula Property
ScaleLabelsBase Class See Also Send Feedback
Gets or sets expression used for calculating labels value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string Formula { get; set; }
Visual Basic (Declaration)
Public Property Formula As String
Visual C++
public:
property String^ Formula {
    String^ get ();
    void set (String^ value);
}

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ItemMargins Property

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.ItemMargins Property
ScaleLabelsBase Class See Also Send Feedback
Gets or sets item margins.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Margins ItemMargins { get; set; }
Visual Basic (Declaration)
Public Property ItemMargins As Margins
Visual C++
public:
property Margins ItemMargins {
    Margins get ();
    void set (Margins value);
}

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


OddLabelsDistance Property

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.OddLabelsDistance Property
ScaleLabelsBase Class See Also Send Feedback
Gets or sets distance foк odd labels.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double OddLabelsDistance { get; set; }
Visual Basic (Declaration)
Public Property OddLabelsDistance As Double
Visual C++
public:
property double OddLabelsDistance {
    double get ();
    void set (double value);
}

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Position Property

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.Position Property
ScaleLabelsBase Class See Also Send Feedback
Gets or sets label position mode.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public LabelPosition Position { get; set; }
Visual Basic (Declaration)
Public Property Position As LabelPosition
Visual C++
public:
property LabelPosition Position {
    LabelPosition get ();
    void set (LabelPosition value);
}

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ShowSuperposableLabels Property

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.ShowSuperposableLabels Property
ScaleLabelsBase Class See Also Send Feedback
Gets or sets value that indicates whether superposable labels will be shown.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowSuperposableLabels { get; set; }
Visual Basic (Declaration)
Public Property ShowSuperposableLabels As Boolean
Visual C++
public:
property bool ShowSuperposableLabels {
    bool get ();
    void set (bool value);
}

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Size Property

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.Size Property
ScaleLabelsBase Class See Also Send Feedback
Gets element size.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Size { get; }
Visual Basic (Declaration)
Public ReadOnly Property Size As Double
Visual C++
public:
property double Size {
    double get ();
}

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


TextAlignment Property

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.TextAlignment Property
ScaleLabelsBase Class See Also Send Feedback
Gets or sets text alignment.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public StringAlignment TextAlignment { get; set; }
Visual Basic (Declaration)
Public Property TextAlignment As StringAlignment
Visual C++
public:
property StringAlignment TextAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


TextAngle Property

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.TextAngle Property
ScaleLabelsBase Class See Also Send Feedback
Gets or sets text angle.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double TextAngle { get; set; }
Visual Basic (Declaration)
Public Property TextAngle As Double
Visual C++
public:
property double TextAngle {
    double get ();
    void set (double value);
}

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


TextRotationMode Property

[image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase..::.TextRotationMode Property
ScaleLabelsBase Class See Also Send Feedback
Gets or sets text rotation mode.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public TextRotationMode TextRotationMode { get; set; }
Visual Basic (Declaration)
Public Property TextRotationMode As TextRotationMode
Visual C++
public:
property TextRotationMode TextRotationMode {
    TextRotationMode get ();
    void set (TextRotationMode value);
}

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleLabelsBase Events

[image] [image]

.NET ModelKit Suite ClassReference
ScaleLabelsBase Events
ScaleLabelsBase Class See Also Send Feedback

The ScaleLabelsBase type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ScaleLabelsBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleMarks Class

[image]

.NET ModelKit Suite ClassReference
ScaleMarks Class
Members See Also Send Feedback
Represents marks on the scale.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class ScaleMarks : ScaleMarksBase
Visual Basic (Declaration)
Public Class ScaleMarks _
    Inherits ScaleMarksBase
Visual C++
public ref class ScaleMarks : public ScaleMarksBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.ScaleElement
PerpetuumSoft.Instrumentation.Model..::.ScaleMarksBase
PerpetuumSoft.Instrumentation.Model..::.ScaleMarks

See Also

ScaleMarks Members
PerpetuumSoft.Instrumentation.Model Namespace


ScaleMarks Members

[image] [image]

.NET ModelKit Suite ClassReference
ScaleMarks Members
ScaleMarks Class Constructors Methods Properties Events See Also Send Feedback

The ScaleMarks type exposes the following members.

Constructors

Name | Description
ScaleMarks | Initializes a new instance of the ScaleMarks class.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()(). (Overrides ScaleElement..::.GetSize()()().)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetSubWidth | Returns sub marks width. (Overrides ScaleMarksBase..::.GetSubWidth()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWidth | Returns marks width. (Overrides ScaleMarksBase..::.GetWidth()()().)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NeedPaint | Returns value, indicating whehter mark is painted. (Inherited from ScaleMarksBase.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Inherited from ScaleElement.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintMark | Draws marks. (Overrides ScaleMarksBase..::.PaintMark(GraphicStream, Double, Double, Fill, Double, Stroke, Boolean).)
PaintSubMark | (Overrides ScaleMarksBase..::.PaintSubMark(GraphicStream, Double, Double, Fill, Stroke, Boolean).)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleElement.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Divisions | Gets or sets divisions count. (Inherited from ScaleMarksBase.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MarksAngle | Gets or sets tilt angle of maks.
MarksSize | Gets or sets size of marks.
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
RotationMode | Gets or sets rotation mode.
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
Shape | Gets or sets ShapeBase object, used for marks shape drawing.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Step | Gets or sets interval between marks. (Inherited from ScaleMarksBase.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SubDivisions | Gets or sets sub divisions count. (Inherited from ScaleMarksBase.)
SubMarksSize | Gets or sets size of sub marks.
SubTicksPosition | Gets or sets the subticks position relative to the base trajectory. (Inherited from ScaleMarksBase.)
UseDescreteValues | Gets or sets value, indicating whether discrete values are used. (Inherited from ScaleMarksBase.)
UseRoundValues | Gets or sets value that indicates if the marks will correspond to round values. (Inherited from ScaleMarksBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ScaleMarks Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleMarks Constructor

[image]

.NET ModelKit Suite ClassReference
ScaleMarks Constructor
ScaleMarks Class See Also Send Feedback
Initializes a new instance of the ScaleMarks class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ScaleMarks()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ScaleMarks()

See Also

ScaleMarks Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleMarks Methods

[image] [image]

.NET ModelKit Suite ClassReference
ScaleMarks Methods
ScaleMarks Class See Also Send Feedback

The ScaleMarks type exposes the following members.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()(). (Overrides ScaleElement..::.GetSize()()().)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetSubWidth | Returns sub marks width. (Overrides ScaleMarksBase..::.GetSubWidth()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWidth | Returns marks width. (Overrides ScaleMarksBase..::.GetWidth()()().)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NeedPaint | Returns value, indicating whehter mark is painted. (Inherited from ScaleMarksBase.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Inherited from ScaleElement.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintMark | Draws marks. (Overrides ScaleMarksBase..::.PaintMark(GraphicStream, Double, Double, Fill, Double, Stroke, Boolean).)
PaintSubMark | (Overrides ScaleMarksBase..::.PaintSubMark(GraphicStream, Double, Double, Fill, Stroke, Boolean).)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleElement.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScaleMarks Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleMarks..::.Dispose Method
ScaleMarks Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

ScaleMarks Class
ScaleMarks Members
PerpetuumSoft.Instrumentation.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
ScaleMarks..::.GetBoundedBox Method
ScaleMarks Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

ScaleMarks Class
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
ScaleMarks..::.GetHitTest Method
ScaleMarks Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

ScaleMarks Class
PerpetuumSoft.Instrumentation.Model Namespace


GetSize Method

[image]

.NET ModelKit Suite ClassReference
ScaleMarks..::.GetSize Method
ScaleMarks Class See Also Send Feedback
Implements GetSize()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override double GetSize()
Visual Basic (Declaration)
Public Overrides Function GetSize As Double
Visual C++
public:
virtual double GetSize() override

Implements

IScaleElement..::.GetSize()()()

See Also

ScaleMarks Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleMarks..::.GetStyle Method
ScaleMarks Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

ScaleMarks Class
ScaleMarks Members
PerpetuumSoft.Instrumentation.Model Namespace


GetSubWidth Method

[image]

.NET ModelKit Suite ClassReference
ScaleMarks..::.GetSubWidth Method
ScaleMarks Class See Also Send Feedback
Returns sub marks width.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override double GetSubWidth()
Visual Basic (Declaration)
Protected Overrides Function GetSubWidth As Double
Visual C++
protected:
virtual double GetSubWidth() override

See Also

ScaleMarks Class
PerpetuumSoft.Instrumentation.Model Namespace


GetWidth Method

[image]

.NET ModelKit Suite ClassReference
ScaleMarks..::.GetWidth Method
ScaleMarks Class See Also Send Feedback
Returns marks width.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override double GetWidth()
Visual Basic (Declaration)
Protected Overrides Function GetWidth As Double
Visual C++
protected:
virtual double GetWidth() override

See Also

ScaleMarks Class
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleMarks..::.Invalidate Method
ScaleMarks Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

ScaleMarks Class
ScaleMarks Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleMarks..::.OnPaint Method
ScaleMarks Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from ScaleMarksBase.)

See Also

ScaleMarks Class
ScaleMarks Members
PerpetuumSoft.Instrumentation.Model Namespace


PaintMark Method

[image]

.NET ModelKit Suite ClassReference
ScaleMarks..::.PaintMark Method
ScaleMarks Class See Also Send Feedback
Draws marks.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void PaintMark(
    GraphicStream stream,
    double value,
    double length,
    Fill fill,
    double distance,
    Stroke stroke,
    bool useStroke
)
Visual Basic (Declaration)
Protected Overrides Sub PaintMark ( _
    stream As GraphicStream, _
    value As Double, _
    length As Double, _
    fill As Fill, _
    distance As Double, _
    stroke As Stroke, _
    useStroke As Boolean _
)
Visual C++
protected:
virtual void PaintMark(
    GraphicStream^ stream,
    double value,
    double length,
    Fill^ fill,
    double distance,
    Stroke^ stroke,
    bool useStroke
) override

Parameters

stream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
value
Type: System..::.Double
length
Type: System..::.Double
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
distance
Type: System..::.Double
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
useStroke
Type: System..::.Boolean

See Also

ScaleMarks Class
PerpetuumSoft.Instrumentation.Model Namespace


PaintSubMark Method

[image]

.NET ModelKit Suite ClassReference
ScaleMarks..::.PaintSubMark Method
ScaleMarks Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.ScaleMarks.PaintSubMark(PerpetuumSoft.Framework.Drawing.GraphicStream,System.Double,System.Double,PerpetuumSoft.Framework.Drawing.Fill,PerpetuumSoft.Framework.Drawing.Stroke,System.Boolean)]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void PaintSubMark(
    GraphicStream stream,
    double startValue,
    double endValue,
    Fill fill,
    Stroke stroke,
    bool useStroke
)
Visual Basic (Declaration)
Protected Overrides Sub PaintSubMark ( _
    stream As GraphicStream, _
    startValue As Double, _
    endValue As Double, _
    fill As Fill, _
    stroke As Stroke, _
    useStroke As Boolean _
)
Visual C++
protected:
virtual void PaintSubMark(
    GraphicStream^ stream,
    double startValue,
    double endValue,
    Fill^ fill,
    Stroke^ stroke,
    bool useStroke
) override

Parameters

stream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
startValue
Type: System..::.Double
endValue
Type: System..::.Double
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
useStroke
Type: System..::.Boolean

See Also

ScaleMarks Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleMarks Properties

[image] [image]

.NET ModelKit Suite ClassReference
ScaleMarks Properties
ScaleMarks Class See Also Send Feedback

The ScaleMarks type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Divisions | Gets or sets divisions count. (Inherited from ScaleMarksBase.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MarksAngle | Gets or sets tilt angle of maks.
MarksSize | Gets or sets size of marks.
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
RotationMode | Gets or sets rotation mode.
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
Shape | Gets or sets ShapeBase object, used for marks shape drawing.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Step | Gets or sets interval between marks. (Inherited from ScaleMarksBase.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SubDivisions | Gets or sets sub divisions count. (Inherited from ScaleMarksBase.)
SubMarksSize | Gets or sets size of sub marks.
SubTicksPosition | Gets or sets the subticks position relative to the base trajectory. (Inherited from ScaleMarksBase.)
UseDescreteValues | Gets or sets value, indicating whether discrete values are used. (Inherited from ScaleMarksBase.)
UseRoundValues | Gets or sets value that indicates if the marks will correspond to round values. (Inherited from ScaleMarksBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

ScaleMarks Class
PerpetuumSoft.Instrumentation.Model Namespace


MarksAngle Property

[image]

.NET ModelKit Suite ClassReference
ScaleMarks..::.MarksAngle Property
ScaleMarks Class See Also Send Feedback
Gets or sets tilt angle of maks.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double MarksAngle { get; set; }
Visual Basic (Declaration)
Public Property MarksAngle As Double
Visual C++
public:
property double MarksAngle {
    double get ();
    void set (double value);
}

See Also

ScaleMarks Class
PerpetuumSoft.Instrumentation.Model Namespace


MarksSize Property

[image]

.NET ModelKit Suite ClassReference
ScaleMarks..::.MarksSize Property
ScaleMarks Class See Also Send Feedback
Gets or sets size of marks.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Vector MarksSize { get; set; }
Visual Basic (Declaration)
Public Property MarksSize As Vector
Visual C++
public:
property Vector MarksSize {
    Vector get ();
    void set (Vector value);
}

See Also

ScaleMarks Class
PerpetuumSoft.Instrumentation.Model Namespace


RotationMode Property

[image]

.NET ModelKit Suite ClassReference
ScaleMarks..::.RotationMode Property
ScaleMarks Class See Also Send Feedback
Gets or sets rotation mode.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public TextRotationMode RotationMode { get; set; }
Visual Basic (Declaration)
Public Property RotationMode As TextRotationMode
Visual C++
public:
property TextRotationMode RotationMode {
    TextRotationMode get ();
    void set (TextRotationMode value);
}

See Also

ScaleMarks Class
PerpetuumSoft.Instrumentation.Model Namespace


Shape Property

[image]

.NET ModelKit Suite ClassReference
ScaleMarks..::.Shape Property
ScaleMarks Class See Also Send Feedback
Gets or sets ShapeBase object, used for marks shape drawing.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ShapeBase Shape { get; set; }
Visual Basic (Declaration)
Public Property Shape As ShapeBase
Visual C++
public:
property ShapeBase^ Shape {
    ShapeBase^ get ();
    void set (ShapeBase^ value);
}

See Also

ScaleMarks Class
PerpetuumSoft.Instrumentation.Model Namespace


SubMarksSize Property

[image]

.NET ModelKit Suite ClassReference
ScaleMarks..::.SubMarksSize Property
ScaleMarks Class See Also Send Feedback
Gets or sets size of sub marks.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Vector SubMarksSize { get; set; }
Visual Basic (Declaration)
Public Property SubMarksSize As Vector
Visual C++
public:
property Vector SubMarksSize {
    Vector get ();
    void set (Vector value);
}

See Also

ScaleMarks Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleMarks Events

[image] [image]

.NET ModelKit Suite ClassReference
ScaleMarks Events
ScaleMarks Class See Also Send Feedback

The ScaleMarks type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ScaleMarks Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleMarksBase Class

[image]

.NET ModelKit Suite ClassReference
ScaleMarksBase Class
Members See Also Send Feedback
Represents the base class for scale marks.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract class ScaleMarksBase : ScaleElement
Visual Basic (Declaration)
Public MustInherit Class ScaleMarksBase _
    Inherits ScaleElement
Visual C++
public ref class ScaleMarksBase abstract : public ScaleElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.ScaleElement
PerpetuumSoft.Instrumentation.Model..::.ScaleMarksBase
PerpetuumSoft.Instrumentation.Model..::.ScaleMarks
PerpetuumSoft.Instrumentation.Model..::.Ticks

See Also

ScaleMarksBase Members
PerpetuumSoft.Instrumentation.Model Namespace


ScaleMarksBase Members

[image] [image]

.NET ModelKit Suite ClassReference
ScaleMarksBase Members
ScaleMarksBase Class Constructors Methods Properties Events See Also Send Feedback

The ScaleMarksBase type exposes the following members.

Constructors

Name | Description
ScaleMarksBase | Initializes a new instance of the ScaleMarksBase class

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()(). (Inherited from ScaleElement.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetSubWidth | Returns sub marks width.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWidth | Returns marks width.
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NeedPaint | Returns value, indicating whehter mark is painted.
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Inherited from ScaleElement.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintMark | Paints marks.
PaintSubMark |
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleElement.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Divisions | Gets or sets divisions count.
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Step | Gets or sets interval between marks.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SubDivisions | Gets or sets sub divisions count.
SubTicksPosition | Gets or sets the subticks position relative to the base trajectory.
UseDescreteValues | Gets or sets value, indicating whether discrete values are used.
UseRoundValues | Gets or sets value that indicates if the marks will correspond to round values.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ScaleMarksBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleMarksBase Constructor

[image]

.NET ModelKit Suite ClassReference
ScaleMarksBase Constructor
ScaleMarksBase Class See Also Send Feedback
Initializes a new instance of the ScaleMarksBase class

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected ScaleMarksBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ScaleMarksBase()

See Also

ScaleMarksBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleMarksBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
ScaleMarksBase Methods
ScaleMarksBase Class See Also Send Feedback

The ScaleMarksBase type exposes the following members.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()(). (Inherited from ScaleElement.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetSubWidth | Returns sub marks width.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWidth | Returns marks width.
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NeedPaint | Returns value, indicating whehter mark is painted.
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Inherited from ScaleElement.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintMark | Paints marks.
PaintSubMark |
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleElement.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScaleMarksBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleMarksBase..::.Dispose Method
ScaleMarksBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

ScaleMarksBase Class
ScaleMarksBase Members
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleMarksBase..::.GetStyle Method
ScaleMarksBase Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

ScaleMarksBase Class
ScaleMarksBase Members
PerpetuumSoft.Instrumentation.Model Namespace


GetSubWidth Method

[image]

.NET ModelKit Suite ClassReference
ScaleMarksBase..::.GetSubWidth Method
ScaleMarksBase Class See Also Send Feedback
Returns sub marks width.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected abstract double GetSubWidth()
Visual Basic (Declaration)
Protected MustOverride Function GetSubWidth As Double
Visual C++
protected:
virtual double GetSubWidth() abstract

See Also

ScaleMarksBase Class
PerpetuumSoft.Instrumentation.Model Namespace


GetWidth Method

[image]

.NET ModelKit Suite ClassReference
ScaleMarksBase..::.GetWidth Method
ScaleMarksBase Class See Also Send Feedback
Returns marks width.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected abstract double GetWidth()
Visual Basic (Declaration)
Protected MustOverride Function GetWidth As Double
Visual C++
protected:
virtual double GetWidth() abstract

See Also

ScaleMarksBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleMarksBase..::.Invalidate Method
ScaleMarksBase Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

ScaleMarksBase Class
ScaleMarksBase Members
PerpetuumSoft.Instrumentation.Model Namespace


NeedPaint Method

[image]

.NET ModelKit Suite ClassReference
ScaleMarksBase..::.NeedPaint Method
ScaleMarksBase Class See Also Send Feedback
Returns value, indicating whehter mark is painted.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected bool NeedPaint(
    double value
)
Visual Basic (Declaration)
Protected Function NeedPaint ( _
    value As Double _
) As Boolean
Visual C++
protected:
bool NeedPaint(
    double value
)

Parameters

value
Type: System..::.Double

See Also

ScaleMarksBase Class
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleMarksBase..::.OnPaint Method
ScaleMarksBase Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

ScaleMarksBase Class
ScaleMarksBase Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
ScaleMarksBase..::.OnPaint Method (PaintArguments, Fill, Stroke)
ScaleMarksBase Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

ScaleMarksBase Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


PaintMark Method

[image]

.NET ModelKit Suite ClassReference
ScaleMarksBase..::.PaintMark Method
ScaleMarksBase Class See Also Send Feedback
Paints marks.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected abstract void PaintMark(
    GraphicStream stream,
    double value,
    double length,
    Fill fill,
    double distance,
    Stroke stroke,
    bool useStroke
)
Visual Basic (Declaration)
Protected MustOverride Sub PaintMark ( _
    stream As GraphicStream, _
    value As Double, _
    length As Double, _
    fill As Fill, _
    distance As Double, _
    stroke As Stroke, _
    useStroke As Boolean _
)
Visual C++
protected:
virtual void PaintMark(
    GraphicStream^ stream,
    double value,
    double length,
    Fill^ fill,
    double distance,
    Stroke^ stroke,
    bool useStroke
) abstract

Parameters

stream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
value
Type: System..::.Double
length
Type: System..::.Double
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
distance
Type: System..::.Double
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
useStroke
Type: System..::.Boolean

See Also

ScaleMarksBase Class
PerpetuumSoft.Instrumentation.Model Namespace


PaintSubMark Method

[image]

.NET ModelKit Suite ClassReference
ScaleMarksBase..::.PaintSubMark Method
ScaleMarksBase Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.ScaleMarksBase.PaintSubMark(PerpetuumSoft.Framework.Drawing.GraphicStream,System.Double,System.Double,PerpetuumSoft.Framework.Drawing.Fill,PerpetuumSoft.Framework.Drawing.Stroke,System.Boolean)]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected abstract void PaintSubMark(
    GraphicStream stream,
    double startValue,
    double endValue,
    Fill fill,
    Stroke stroke,
    bool useStroke
)
Visual Basic (Declaration)
Protected MustOverride Sub PaintSubMark ( _
    stream As GraphicStream, _
    startValue As Double, _
    endValue As Double, _
    fill As Fill, _
    stroke As Stroke, _
    useStroke As Boolean _
)
Visual C++
protected:
virtual void PaintSubMark(
    GraphicStream^ stream,
    double startValue,
    double endValue,
    Fill^ fill,
    Stroke^ stroke,
    bool useStroke
) abstract

Parameters

stream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
startValue
Type: System..::.Double
endValue
Type: System..::.Double
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
useStroke
Type: System..::.Boolean

See Also

ScaleMarksBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleMarksBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
ScaleMarksBase Properties
ScaleMarksBase Class See Also Send Feedback

The ScaleMarksBase type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Divisions | Gets or sets divisions count.
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Step | Gets or sets interval between marks.
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SubDivisions | Gets or sets sub divisions count.
SubTicksPosition | Gets or sets the subticks position relative to the base trajectory.
UseDescreteValues | Gets or sets value, indicating whether discrete values are used.
UseRoundValues | Gets or sets value that indicates if the marks will correspond to round values.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

ScaleMarksBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Divisions Property

[image]

.NET ModelKit Suite ClassReference
ScaleMarksBase..::.Divisions Property
ScaleMarksBase Class See Also Send Feedback
Gets or sets divisions count.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int Divisions { get; set; }
Visual Basic (Declaration)
Public Property Divisions As Integer
Visual C++
public:
property int Divisions {
    int get ();
    void set (int value);
}

See Also

ScaleMarksBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Step Property

[image]

.NET ModelKit Suite ClassReference
ScaleMarksBase..::.Step Property
ScaleMarksBase Class See Also Send Feedback
Gets or sets interval between marks.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue Step { get; set; }
Visual Basic (Declaration)
Public Property Step As SmartValue
Visual C++
public:
property SmartValue Step {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

ScaleMarksBase Class
PerpetuumSoft.Instrumentation.Model Namespace


SubDivisions Property

[image]

.NET ModelKit Suite ClassReference
ScaleMarksBase..::.SubDivisions Property
ScaleMarksBase Class See Also Send Feedback
Gets or sets sub divisions count.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int SubDivisions { get; set; }
Visual Basic (Declaration)
Public Property SubDivisions As Integer
Visual C++
public:
property int SubDivisions {
    int get ();
    void set (int value);
}

See Also

ScaleMarksBase Class
PerpetuumSoft.Instrumentation.Model Namespace


SubTicksPosition Property

[image]

.NET ModelKit Suite ClassReference
ScaleMarksBase..::.SubTicksPosition Property
ScaleMarksBase Class See Also Send Feedback
Gets or sets the subticks position relative to the base trajectory.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public SubTicksPosition SubTicksPosition { get; set; }
Visual Basic (Declaration)
Public Property SubTicksPosition As SubTicksPosition
Visual C++
public:
property SubTicksPosition SubTicksPosition {
    SubTicksPosition get ();
    void set (SubTicksPosition value);
}

See Also

ScaleMarksBase Class
PerpetuumSoft.Instrumentation.Model Namespace


UseDescreteValues Property

[image]

.NET ModelKit Suite ClassReference
ScaleMarksBase..::.UseDescreteValues Property
ScaleMarksBase Class See Also Send Feedback
Gets or sets value, indicating whether discrete values are used.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool UseDescreteValues { get; set; }
Visual Basic (Declaration)
Public Property UseDescreteValues As Boolean
Visual C++
public:
property bool UseDescreteValues {
    bool get ();
    void set (bool value);
}

See Also

ScaleMarksBase Class
PerpetuumSoft.Instrumentation.Model Namespace


UseRoundValues Property

[image]

.NET ModelKit Suite ClassReference
ScaleMarksBase..::.UseRoundValues Property
ScaleMarksBase Class See Also Send Feedback
Gets or sets value that indicates if the marks will correspond to round values.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool UseRoundValues { get; set; }
Visual Basic (Declaration)
Public Property UseRoundValues As Boolean
Visual C++
public:
property bool UseRoundValues {
    bool get ();
    void set (bool value);
}

See Also

ScaleMarksBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleMarksBase Events

[image] [image]

.NET ModelKit Suite ClassReference
ScaleMarksBase Events
ScaleMarksBase Class See Also Send Feedback

The ScaleMarksBase type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ScaleMarksBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleTitle Class

[image]

.NET ModelKit Suite ClassReference
ScaleTitle Class
Members See Also Send Feedback
Represents title of a scale.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class ScaleTitle : ScaleLabelsBase
Visual Basic (Declaration)
Public Class ScaleTitle _
    Inherits ScaleLabelsBase
Visual C++
public ref class ScaleTitle : public ScaleLabelsBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.ScaleElement
PerpetuumSoft.Instrumentation.Model..::.ScaleLabelsBase
PerpetuumSoft.Instrumentation.Model..::.ScaleTitle

See Also

ScaleTitle Members
PerpetuumSoft.Instrumentation.Model Namespace


ScaleTitle Members

[image] [image]

.NET ModelKit Suite ClassReference
ScaleTitle Members
ScaleTitle Class Constructors Methods Properties Events See Also Send Feedback

The ScaleTitle type exposes the following members.

Constructors

Name | Description
ScaleTitle | Initializes a new instance of the ScaleTitle class.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from ScaleLabelsBase.)
GetLabelsCount | Overridden. See GetLabelsCount()()(). (Overrides ScaleLabelsBase..::.GetLabelsCount()()().)
GetObject | Implements GetObject(String). (Inherited from ScaleLabelsBase.)
GetObjectByIndex | Overridden. See GetObjectByIndex(Int32). (Overrides ScaleLabelsBase..::.GetObjectByIndex(Int32).)
GetSize | Implements GetSize()()(). (Inherited from ScaleLabelsBase.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetTextLabel | Returns label text by the assigned value. (Inherited from ScaleLabelsBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueByIndex | Overridden. See GetValueByIndex(Int32). (Overrides ScaleLabelsBase..::.GetValueByIndex(Int32).)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Raises the OnParentChanged event. (Inherited from ScaleLabelsBase.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is called when element's visibility is changed. (Inherited from ScaleLabelsBase.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLabel | Draws a scale mark. (Inherited from ScaleLabelsBase.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleLabelsBase.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleLabelsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets FontDescriptor of the element. (Inherited from ScaleLabelsBase.)
Format | Gets and sets text format for the labels. (Inherited from ScaleLabelsBase.)
Formula | Gets or sets expression used for calculating labels value. (Inherited from ScaleLabelsBase.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
ItemMargins | Gets or sets item margins. (Inherited from ScaleLabelsBase.)
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
OddLabelsDistance | Gets or sets distance foк odd labels. (Inherited from ScaleLabelsBase.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
Position | Gets or sets label position mode. (Inherited from ScaleLabelsBase.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
ShowSuperposableLabels | Gets or sets value that indicates whether superposable labels will be shown. (Inherited from ScaleLabelsBase.)
Size | Gets element size. (Inherited from ScaleLabelsBase.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Text | Gets or sets text, displayed in this title.
TextAlignment | Gets or sets text alignment. (Inherited from ScaleLabelsBase.)
TextAngle | Gets or sets text angle. (Inherited from ScaleLabelsBase.)
TextRotationMode | Gets or sets text rotation mode. (Inherited from ScaleLabelsBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ScaleTitle Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleTitle Constructor

[image]

.NET ModelKit Suite ClassReference
ScaleTitle Constructor
ScaleTitle Class See Also Send Feedback
Initializes a new instance of the ScaleTitle class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ScaleTitle()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ScaleTitle()

See Also

ScaleTitle Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleTitle Methods

[image] [image]

.NET ModelKit Suite ClassReference
ScaleTitle Methods
ScaleTitle Class See Also Send Feedback

The ScaleTitle type exposes the following members.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from ScaleLabelsBase.)
GetLabelsCount | Overridden. See GetLabelsCount()()(). (Overrides ScaleLabelsBase..::.GetLabelsCount()()().)
GetObject | Implements GetObject(String). (Inherited from ScaleLabelsBase.)
GetObjectByIndex | Overridden. See GetObjectByIndex(Int32). (Overrides ScaleLabelsBase..::.GetObjectByIndex(Int32).)
GetSize | Implements GetSize()()(). (Inherited from ScaleLabelsBase.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetTextLabel | Returns label text by the assigned value. (Inherited from ScaleLabelsBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueByIndex | Overridden. See GetValueByIndex(Int32). (Overrides ScaleLabelsBase..::.GetValueByIndex(Int32).)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Raises the OnParentChanged event. (Inherited from ScaleLabelsBase.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is called when element's visibility is changed. (Inherited from ScaleLabelsBase.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLabel | Draws a scale mark. (Inherited from ScaleLabelsBase.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleLabelsBase.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleLabelsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScaleTitle Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleTitle..::.Dispose Method
ScaleTitle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

ScaleTitle Class
ScaleTitle Members
PerpetuumSoft.Instrumentation.Model Namespace


GetLabelsCount Method

[image]

.NET ModelKit Suite ClassReference
ScaleTitle..::.GetLabelsCount Method
ScaleTitle Class See Also Send Feedback
Overridden. See GetLabelsCount()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override int GetLabelsCount()
Visual Basic (Declaration)
Public Overrides Function GetLabelsCount As Integer
Visual C++
public:
virtual int GetLabelsCount() override

See Also

ScaleTitle Class
PerpetuumSoft.Instrumentation.Model Namespace


GetObjectByIndex Method

[image]

.NET ModelKit Suite ClassReference
ScaleTitle..::.GetObjectByIndex Method
ScaleTitle Class See Also Send Feedback
Overridden. See GetObjectByIndex(Int32).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Object GetObjectByIndex(
    int index
)
Visual Basic (Declaration)
Public Overrides Function GetObjectByIndex ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ GetObjectByIndex(
    int index
) override

Parameters

index
Type: System..::.Int32

See Also

ScaleTitle Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleTitle..::.GetStyle Method
ScaleTitle Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

ScaleTitle Class
ScaleTitle Members
PerpetuumSoft.Instrumentation.Model Namespace


GetValueByIndex Method

[image]

.NET ModelKit Suite ClassReference
ScaleTitle..::.GetValueByIndex Method
ScaleTitle Class See Also Send Feedback
Overridden. See GetValueByIndex(Int32).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override double GetValueByIndex(
    int index
)
Visual Basic (Declaration)
Public Overrides Function GetValueByIndex ( _
    index As Integer _
) As Double
Visual C++
public:
virtual double GetValueByIndex(
    int index
) override

Parameters

index
Type: System..::.Int32

See Also

ScaleTitle Class
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleTitle..::.Invalidate Method
ScaleTitle Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

ScaleTitle Class
ScaleTitle Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
ScaleTitle..::.OnPaint Method
ScaleTitle Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from ScaleLabelsBase.)

See Also

ScaleTitle Class
ScaleTitle Members
PerpetuumSoft.Instrumentation.Model Namespace


ScaleTitle Properties

[image] [image]

.NET ModelKit Suite ClassReference
ScaleTitle Properties
ScaleTitle Class See Also Send Feedback

The ScaleTitle type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets FontDescriptor of the element. (Inherited from ScaleLabelsBase.)
Format | Gets and sets text format for the labels. (Inherited from ScaleLabelsBase.)
Formula | Gets or sets expression used for calculating labels value. (Inherited from ScaleLabelsBase.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
ItemMargins | Gets or sets item margins. (Inherited from ScaleLabelsBase.)
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
OddLabelsDistance | Gets or sets distance foк odd labels. (Inherited from ScaleLabelsBase.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
Position | Gets or sets label position mode. (Inherited from ScaleLabelsBase.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
ShowSuperposableLabels | Gets or sets value that indicates whether superposable labels will be shown. (Inherited from ScaleLabelsBase.)
Size | Gets element size. (Inherited from ScaleLabelsBase.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Text | Gets or sets text, displayed in this title.
TextAlignment | Gets or sets text alignment. (Inherited from ScaleLabelsBase.)
TextAngle | Gets or sets text angle. (Inherited from ScaleLabelsBase.)
TextRotationMode | Gets or sets text rotation mode. (Inherited from ScaleLabelsBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

ScaleTitle Class
PerpetuumSoft.Instrumentation.Model Namespace


Text Property

[image]

.NET ModelKit Suite ClassReference
ScaleTitle..::.Text Property
ScaleTitle Class See Also Send Feedback
Gets or sets text, displayed in this title.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

ScaleTitle Class
PerpetuumSoft.Instrumentation.Model Namespace


ScaleTitle Events

[image] [image]

.NET ModelKit Suite ClassReference
ScaleTitle Events
ScaleTitle Class See Also Send Feedback

The ScaleTitle type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ScaleTitle Class
PerpetuumSoft.Instrumentation.Model Namespace


ShowMode Enumeration

[image]

.NET ModelKit Suite ClassReference
ShowMode Enumeration
See Also Send Feedback
Showing modes for Needle element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public enum ShowMode
Visual Basic (Declaration)
Public Enumeration ShowMode
Visual C++
public enum class ShowMode

Members

Member name | Description
ShowBoth | ShowBoth mode.
ShowLeft | ShowLeft mode.
ShowRigth | ShowRight mode.

See Also

PerpetuumSoft.Instrumentation.Model Namespace


SimpleRectangleElement Class

[image]

.NET ModelKit Suite ClassReference
SimpleRectangleElement Class
Members See Also Send Feedback
Represents the simple rectangle.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract class SimpleRectangleElement : Element
Visual Basic (Declaration)
Public MustInherit Class SimpleRectangleElement _
    Inherits Element
Visual C++
public ref class SimpleRectangleElement abstract : public Element

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement
PerpetuumSoft.Charts..::.Legend
PerpetuumSoft.Charts..::.Title
PerpetuumSoft.Instrumentation.Model..::.RectangleElement

See Also

SimpleRectangleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


SimpleRectangleElement Members

[image] [image]

.NET ModelKit Suite ClassReference
SimpleRectangleElement Members
SimpleRectangleElement Class Constructors Methods Properties Events See Also Send Feedback

The SimpleRectangleElement type exposes the following members.

Constructors

Name | Description
SimpleRectangleElement | Initializes a new instance of the SimpleRectangleElement class

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | Is called when bounds of a rectangle are chaged.
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Bounds | Bound of the rectangle.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

SimpleRectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


SimpleRectangleElement Constructor

[image]

.NET ModelKit Suite ClassReference
SimpleRectangleElement Constructor
SimpleRectangleElement Class See Also Send Feedback
Initializes a new instance of the SimpleRectangleElement class

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected SimpleRectangleElement()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
SimpleRectangleElement()

See Also

SimpleRectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


SimpleRectangleElement Methods

[image] [image]

.NET ModelKit Suite ClassReference
SimpleRectangleElement Methods
SimpleRectangleElement Class See Also Send Feedback

The SimpleRectangleElement type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | Is called when bounds of a rectangle are chaged.
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimpleRectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleRectangleElement..::.Dispose Method
SimpleRectangleElement Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

SimpleRectangleElement Class
SimpleRectangleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
SimpleRectangleElement..::.GetBoundedBox Method
SimpleRectangleElement Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

SimpleRectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
SimpleRectangleElement..::.GetHitTest Method
SimpleRectangleElement Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

SimpleRectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleRectangleElement..::.GetStyle Method
SimpleRectangleElement Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

SimpleRectangleElement Class
SimpleRectangleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleRectangleElement..::.Invalidate Method
SimpleRectangleElement Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

SimpleRectangleElement Class
SimpleRectangleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


OnBoundsChanged Method

[image]

.NET ModelKit Suite ClassReference
SimpleRectangleElement..::.OnBoundsChanged Method
SimpleRectangleElement Class See Also Send Feedback
Is called when bounds of a rectangle are chaged.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnBoundsChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnBoundsChanged
Visual C++
protected:
virtual void OnBoundsChanged()

See Also

SimpleRectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
SimpleRectangleElement..::.OnPaint Method
SimpleRectangleElement Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

SimpleRectangleElement Class
SimpleRectangleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


SimpleRectangleElement Properties

[image] [image]

.NET ModelKit Suite ClassReference
SimpleRectangleElement Properties
SimpleRectangleElement Class See Also Send Feedback

The SimpleRectangleElement type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Bounds | Bound of the rectangle.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle.
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

SimpleRectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


Bounds Property

[image]

.NET ModelKit Suite ClassReference
SimpleRectangleElement..::.Bounds Property
SimpleRectangleElement Class See Also Send Feedback
Bound of the rectangle.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle Bounds { get; set; }
Visual Basic (Declaration)
Public Property Bounds As VectorRectangle
Visual C++
public:
property VectorRectangle Bounds {
    VectorRectangle get ();
    void set (VectorRectangle value);
}

See Also

SimpleRectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


Center Property

[image]

.NET ModelKit Suite ClassReference
SimpleRectangleElement..::.Center Property
SimpleRectangleElement Class See Also Send Feedback
Gets or sets the center of the rectangle.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Vector Center { get; set; }
Visual Basic (Declaration)
Public Property Center As Vector
Visual C++
public:
property Vector Center {
    Vector get ();
    void set (Vector value);
}

See Also

SimpleRectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


Size Property

[image]

.NET ModelKit Suite ClassReference
SimpleRectangleElement..::.Size Property
SimpleRectangleElement Class See Also Send Feedback
Gets or sets size of the rectangle.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Vector Size { get; set; }
Visual Basic (Declaration)
Public Property Size As Vector
Visual C++
public:
property Vector Size {
    Vector get ();
    void set (Vector value);
}

See Also

SimpleRectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


SimpleRectangleElement Events

[image] [image]

.NET ModelKit Suite ClassReference
SimpleRectangleElement Events
SimpleRectangleElement Class See Also Send Feedback

The SimpleRectangleElement type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

SimpleRectangleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


Slider Class

[image]

.NET ModelKit Suite ClassReference
Slider Class
Members See Also Send Feedback
Represents the Slider.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Slider : SliderBase
Visual Basic (Declaration)
Public Class Slider _
    Inherits SliderBase
Visual C++
public ref class Slider : public SliderBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.Composite
PerpetuumSoft.Instrumentation.Model..::.SliderBase
PerpetuumSoft.Instrumentation.Model..::.Slider

See Also

Slider Members
PerpetuumSoft.Instrumentation.Model Namespace


Slider Members

[image] [image]

.NET ModelKit Suite ClassReference
Slider Members
Slider Class Constructors Methods Properties Events See Also Send Feedback

The Slider type exposes the following members.

Constructors

Name | Description
Slider | Initializes a new instance of the Slider class.

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetFunction | Implements GetFunction(String). (Inherited from SliderBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from SliderBase.)
GetPosition | Implements GetPosition(Double). (Overrides SliderBase..::.GetPosition(Double).)
GetRadius | Implements GetRadius(Vector). (Inherited from SliderBase.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raise the MouseDown event. (Overrides Element..::.OnMouseDown(MouseArguments).)
OnMouseEnter | Raise the MouseEnter event. (Overrides Element..::.OnMouseEnter(MouseArguments).)
OnMouseLeave | Raise the MouseLeave event. (Overrides Element..::.OnMouseLeave(MouseArguments).)
OnMouseMove | Raise the MouseMove event. (Overrides Element..::.OnMouseMove(MouseArguments).)
OnMouseUp | Raise the MouseUp event. (Overrides Element..::.OnMouseUp(MouseArguments).)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Inherited from SliderBase.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnValueChanged | Raise the ValueChanget event. (Inherited from SliderBase.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
RoundValue | Returns the number nearest the specified value. (Inherited from SliderBase.)
SetDragged | Sets Dragged property. (Inherited from SliderBase.)
SetHot | Sets Hot property. (Inherited from SliderBase.)
SetPressed | Sets Pressed property. (Inherited from SliderBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Dragged | Gets the value indicating whether element is dragged. (Inherited from SliderBase.)
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over. (Inherited from SliderBase.)
Hot | Gets the value indicating whether mouse cursode is over element. (Inherited from SliderBase.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MaxLimit | Implements MaxLimit. (Inherited from SliderBase.)
MinLimit | Implements MinLimit. (Inherited from SliderBase.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Pressed | Gets the value indicating whether mouse button was pressed. (Inherited from SliderBase.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets IScale object of SliderBase element. (Inherited from SliderBase.)
Smooth | Gets or sets value that indicates whether smoothing will be applied. (Inherited from SliderBase.)
Step | Gets or sets step of SliderBase element. (Inherited from SliderBase.)
Stroke | Gets or sets the Stroke object that is used to trace. (Inherited from SliderBase.)
Style | Gets or sets name of the used style. (Inherited from SliderBase.)
Value | Implements Value. (Inherited from SliderBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)
ValueChanged | Occurs after slider value changing. (Inherited from SliderBase.)

See Also

Slider Class
PerpetuumSoft.Instrumentation.Model Namespace


Slider Constructor

[image]

.NET ModelKit Suite ClassReference
Slider Constructor
Slider Class See Also Send Feedback
Initializes a new instance of the Slider class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Slider()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Slider()

See Also

Slider Class
PerpetuumSoft.Instrumentation.Model Namespace


Slider Methods

[image] [image]

.NET ModelKit Suite ClassReference
Slider Methods
Slider Class See Also Send Feedback

The Slider type exposes the following members.

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetFunction | Implements GetFunction(String). (Inherited from SliderBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Inherited from SliderBase.)
GetPosition | Implements GetPosition(Double). (Overrides SliderBase..::.GetPosition(Double).)
GetRadius | Implements GetRadius(Vector). (Inherited from SliderBase.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raise the MouseDown event. (Overrides Element..::.OnMouseDown(MouseArguments).)
OnMouseEnter | Raise the MouseEnter event. (Overrides Element..::.OnMouseEnter(MouseArguments).)
OnMouseLeave | Raise the MouseLeave event. (Overrides Element..::.OnMouseLeave(MouseArguments).)
OnMouseMove | Raise the MouseMove event. (Overrides Element..::.OnMouseMove(MouseArguments).)
OnMouseUp | Raise the MouseUp event. (Overrides Element..::.OnMouseUp(MouseArguments).)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Inherited from SliderBase.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnValueChanged | Raise the ValueChanget event. (Inherited from SliderBase.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
RoundValue | Returns the number nearest the specified value. (Inherited from SliderBase.)
SetDragged | Sets Dragged property. (Inherited from SliderBase.)
SetHot | Sets Hot property. (Inherited from SliderBase.)
SetPressed | Sets Pressed property. (Inherited from SliderBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Slider Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Slider..::.Dispose Method
Slider Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from Composite.)

See Also

Slider Class
Slider Members
PerpetuumSoft.Instrumentation.Model Namespace


GetPosition Method

[image]

.NET ModelKit Suite ClassReference
Slider..::.GetPosition Method
Slider Class See Also Send Feedback
Implements GetPosition(Double).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Vector GetPosition(
    double radius
)
Visual Basic (Declaration)
Public Overrides Function GetPosition ( _
    radius As Double _
) As Vector
Visual C++
public:
virtual Vector GetPosition(
    double radius
) override

Parameters

radius
Type: System..::.Double

Implements

ISlider..::.GetPosition(Double)

See Also

Slider Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Slider..::.GetStyle Method
Slider Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Slider Class
Slider Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Slider..::.Invalidate Method
Slider Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Slider Class
Slider Members
PerpetuumSoft.Instrumentation.Model Namespace


OnMouseDown Method

[image]

.NET ModelKit Suite ClassReference
Slider..::.OnMouseDown Method
Slider Class See Also Send Feedback
Raise the MouseDown event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnMouseDown(
    MouseArguments args
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseDown ( _
    args As MouseArguments _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.MouseArguments

See Also

Slider Class
PerpetuumSoft.Instrumentation.Model Namespace


OnMouseEnter Method

[image]

.NET ModelKit Suite ClassReference
Slider..::.OnMouseEnter Method
Slider Class See Also Send Feedback
Raise the MouseEnter event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnMouseEnter(
    MouseArguments args
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseEnter ( _
    args As MouseArguments _
)
Visual C++
protected:
virtual void OnMouseEnter(
    MouseArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.MouseArguments

See Also

Slider Class
PerpetuumSoft.Instrumentation.Model Namespace


OnMouseLeave Method

[image]

.NET ModelKit Suite ClassReference
Slider..::.OnMouseLeave Method
Slider Class See Also Send Feedback
Raise the MouseLeave event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnMouseLeave(
    MouseArguments args
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeave ( _
    args As MouseArguments _
)
Visual C++
protected:
virtual void OnMouseLeave(
    MouseArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.MouseArguments

See Also

Slider Class
PerpetuumSoft.Instrumentation.Model Namespace


OnMouseMove Method

[image]

.NET ModelKit Suite ClassReference
Slider..::.OnMouseMove Method
Slider Class See Also Send Feedback
Raise the MouseMove event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnMouseMove(
    MouseArguments args
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseMove ( _
    args As MouseArguments _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.MouseArguments

See Also

Slider Class
PerpetuumSoft.Instrumentation.Model Namespace


OnMouseUp Method

[image]

.NET ModelKit Suite ClassReference
Slider..::.OnMouseUp Method
Slider Class See Also Send Feedback
Raise the MouseUp event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnMouseUp(
    MouseArguments args
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseUp ( _
    args As MouseArguments _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.MouseArguments

See Also

Slider Class
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Slider..::.OnPaint Method
Slider Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Inherited from Composite.)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

Slider Class
Slider Members
PerpetuumSoft.Instrumentation.Model Namespace


Slider Properties

[image] [image]

.NET ModelKit Suite ClassReference
Slider Properties
Slider Class See Also Send Feedback

The Slider type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Dragged | Gets the value indicating whether element is dragged. (Inherited from SliderBase.)
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over. (Inherited from SliderBase.)
Hot | Gets the value indicating whether mouse cursode is over element. (Inherited from SliderBase.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MaxLimit | Implements MaxLimit. (Inherited from SliderBase.)
MinLimit | Implements MinLimit. (Inherited from SliderBase.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Pressed | Gets the value indicating whether mouse button was pressed. (Inherited from SliderBase.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets IScale object of SliderBase element. (Inherited from SliderBase.)
Smooth | Gets or sets value that indicates whether smoothing will be applied. (Inherited from SliderBase.)
Step | Gets or sets step of SliderBase element. (Inherited from SliderBase.)
Stroke | Gets or sets the Stroke object that is used to trace. (Inherited from SliderBase.)
Style | Gets or sets name of the used style. (Inherited from SliderBase.)
Value | Implements Value. (Inherited from SliderBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Slider Class
PerpetuumSoft.Instrumentation.Model Namespace


Slider Events

[image] [image]

.NET ModelKit Suite ClassReference
Slider Events
Slider Class See Also Send Feedback

The Slider type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)
ValueChanged | Occurs after slider value changing. (Inherited from SliderBase.)

See Also

Slider Class
PerpetuumSoft.Instrumentation.Model Namespace


SliderBase Class

[image]

.NET ModelKit Suite ClassReference
SliderBase Class
Members See Also Send Feedback
Represents the basic class for slider elements.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract class SliderBase : Composite,
    ISlider, ILinkedSupported
Visual Basic (Declaration)
Public MustInherit Class SliderBase _
    Inherits Composite _
    Implements ISlider, ILinkedSupported
Visual C++
public ref class SliderBase abstract : public Composite,
    ISlider, ILinkedSupported

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.Composite
PerpetuumSoft.Instrumentation.Model..::.SliderBase
PerpetuumSoft.Instrumentation.Model..::.Slider

See Also

SliderBase Members
PerpetuumSoft.Instrumentation.Model Namespace


SliderBase Members

[image] [image]

.NET ModelKit Suite ClassReference
SliderBase Members
SliderBase Class Constructors Methods Properties Events See Also Send Feedback

The SliderBase type exposes the following members.

Constructors

Name | Description
SliderBase | Initializes a new instance of the SliderBase class

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetFunction | Implements GetFunction(String). (Overrides Element..::.GetFunction(String).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Overrides Element..::.GetObject(String).)
GetPosition | Implements GetPosition(Double).
GetRadius | Implements GetRadius(Vector).
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Overrides Element..::.OnParentChanged()()().)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnValueChanged | Raise the ValueChanget event.
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
RoundValue | Returns the number nearest the specified value.
SetDragged | Sets Dragged property.
SetHot | Sets Hot property.
SetPressed | Sets Pressed property.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Dragged | Gets the value indicating whether element is dragged.
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over.
Hot | Gets the value indicating whether mouse cursode is over element.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MaxLimit | Implements MaxLimit.
MinLimit | Implements MinLimit.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Pressed | Gets the value indicating whether mouse button was pressed.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets IScale object of SliderBase element.
Smooth | Gets or sets value that indicates whether smoothing will be applied.
Step | Gets or sets step of SliderBase element.
Stroke | Gets or sets the Stroke object that is used to trace.
Style | Gets or sets name of the used style.
Value | Implements Value.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)
ValueChanged | Occurs after slider value changing.

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


SliderBase Constructor

[image]

.NET ModelKit Suite ClassReference
SliderBase Constructor
SliderBase Class See Also Send Feedback
Initializes a new instance of the SliderBase class

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected SliderBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
SliderBase()

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


SliderBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
SliderBase Methods
SliderBase Class See Also Send Feedback

The SliderBase type exposes the following members.

Methods

Name | Description
BringToFront | Sends the elements to front. (Inherited from Composite.)
Calculate | Overridden. See Calculate()()(). (Inherited from Composite.)
CanMoveBack | Determines whether the elements can move to back. (Inherited from Composite.)
CanMoveForward | Determines whether the elements can move to forward. (Inherited from Composite.)
ChildElementAdded | This method is called when the child element is added. (Inherited from Composite.)
ChildElementRemoved | This method is called when the child element is removed. (Inherited from Composite.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Overridden. See GetByName(String). (Inherited from Composite.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Composite.)
GetFunction | Implements GetFunction(String). (Overrides Element..::.GetFunction(String).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetObject | Implements GetObject(String). (Overrides Element..::.GetObject(String).)
GetPosition | Implements GetPosition(Double).
GetRadius | Implements GetRadius(Vector).
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the elements on the one position to backward. (Inherited from Composite.)
MoveForward | Moves elements on the one position to forward. (Inherited from Composite.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Overrides Element..::.OnParentChanged()()().)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnValueChanged | Raise the ValueChanget event.
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PutToBack | Sends the elements to back. (Inherited from Composite.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
RoundValue | Returns the number nearest the specified value.
SetDragged | Sets Dragged property.
SetHot | Sets Hot property.
SetPressed | Sets Pressed property.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
SliderBase..::.Dispose Method
SliderBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from Composite.)

See Also

SliderBase Class
SliderBase Members
PerpetuumSoft.Instrumentation.Model Namespace


GetFunction Method

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.GetFunction Method
SliderBase Class See Also Send Feedback
Implements GetFunction(String).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override IFunction GetFunction(
    string name
)
Visual Basic (Declaration)
Public Overrides Function GetFunction ( _
    name As String _
) As IFunction
Visual C++
public:
virtual IFunction^ GetFunction(
    String^ name
) override

Parameters

name
Type: System..::.String

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


GetObject Method

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.GetObject Method
SliderBase Class See Also Send Feedback
Implements GetObject(String).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Object GetObject(
    string name
)
Visual Basic (Declaration)
Public Overrides Function GetObject ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetObject(
    String^ name
) override

Parameters

name
Type: System..::.String

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


GetPosition Method

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.GetPosition Method
SliderBase Class See Also Send Feedback
Implements GetPosition(Double).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract Vector GetPosition(
    double radius
)
Visual Basic (Declaration)
Public MustOverride Function GetPosition ( _
    radius As Double _
) As Vector
Visual C++
public:
virtual Vector GetPosition(
    double radius
) abstract

Parameters

radius
Type: System..::.Double

Implements

ISlider..::.GetPosition(Double)

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


GetRadius Method

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.GetRadius Method
SliderBase Class See Also Send Feedback
Implements GetRadius(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double GetRadius(
    Vector point
)
Visual Basic (Declaration)
Public Function GetRadius ( _
    point As Vector _
) As Double
Visual C++
public:
virtual double GetRadius(
    Vector point
) sealed

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

Implements

ILinkedSupported..::.GetRadius(Vector)

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
SliderBase..::.GetStyle Method
SliderBase Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

SliderBase Class
SliderBase Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
SliderBase..::.Invalidate Method
SliderBase Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

SliderBase Class
SliderBase Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
SliderBase..::.OnPaint Method
SliderBase Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Inherited from Composite.)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

SliderBase Class
SliderBase Members
PerpetuumSoft.Instrumentation.Model Namespace


OnParentChanged Method

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.OnParentChanged Method
SliderBase Class See Also Send Feedback
Is called when the Parent property is changed.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnParentChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnParentChanged
Visual C++
protected:
virtual void OnParentChanged() override

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


OnValueChanged Method

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.OnValueChanged Method
SliderBase Class See Also Send Feedback
Raise the ValueChanget event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnValueChanged(
    PropertyEventArgs args
)
Visual Basic (Declaration)
Protected Overridable Sub OnValueChanged ( _
    args As PropertyEventArgs _
)
Visual C++
protected:
virtual void OnValueChanged(
    PropertyEventArgs^ args
)

Parameters

args
Type: PropertyEventArgs

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


RoundValue Method

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.RoundValue Method
SliderBase Class See Also Send Feedback
Returns the number nearest the specified value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected double RoundValue(
    double value
)
Visual Basic (Declaration)
Protected Function RoundValue ( _
    value As Double _
) As Double
Visual C++
protected:
double RoundValue(
    double value
)

Parameters

value
Type: System..::.Double

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


SetDragged Method

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.SetDragged Method
SliderBase Class See Also Send Feedback
Sets Dragged property.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected void SetDragged(
    bool value
)
Visual Basic (Declaration)
Protected Sub SetDragged ( _
    value As Boolean _
)
Visual C++
protected:
void SetDragged(
    bool value
)

Parameters

value
Type: System..::.Boolean

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


SetHot Method

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.SetHot Method
SliderBase Class See Also Send Feedback
Sets Hot property.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected void SetHot(
    bool value
)
Visual Basic (Declaration)
Protected Sub SetHot ( _
    value As Boolean _
)
Visual C++
protected:
void SetHot(
    bool value
)

Parameters

value
Type: System..::.Boolean

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


SetPressed Method

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.SetPressed Method
SliderBase Class See Also Send Feedback
Sets Pressed property.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected void SetPressed(
    bool value
)
Visual Basic (Declaration)
Protected Sub SetPressed ( _
    value As Boolean _
)
Visual C++
protected:
void SetPressed(
    bool value
)

Parameters

value
Type: System..::.Boolean

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


SliderBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
SliderBase Properties
SliderBase Class See Also Send Feedback

The SliderBase type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Dragged | Gets the value indicating whether element is dragged.
Elements | Implements Elements. (Inherited from Composite.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over.
Hot | Gets the value indicating whether mouse cursode is over element.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MaxLimit | Implements MaxLimit.
MinLimit | Implements MinLimit.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Pressed | Gets the value indicating whether mouse button was pressed.
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets IScale object of SliderBase element.
Smooth | Gets or sets value that indicates whether smoothing will be applied.
Step | Gets or sets step of SliderBase element.
Stroke | Gets or sets the Stroke object that is used to trace.
Style | Gets or sets name of the used style.
Value | Implements Value.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Dragged Property

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.Dragged Property
SliderBase Class See Also Send Feedback
Gets the value indicating whether element is dragged.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Dragged { get; }
Visual Basic (Declaration)
Public ReadOnly Property Dragged As Boolean
Visual C++
public:
property bool Dragged {
    bool get ();
}

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.Fill Property
SliderBase Class See Also Send Feedback
Gets or sets the Fill object that is used to paint over.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Hot Property

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.Hot Property
SliderBase Class See Also Send Feedback
Gets the value indicating whether mouse cursode is over element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Hot { get; }
Visual Basic (Declaration)
Public ReadOnly Property Hot As Boolean
Visual C++
public:
property bool Hot {
    bool get ();
}

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


MaxLimit Property

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.MaxLimit Property
SliderBase Class See Also Send Feedback
Implements MaxLimit.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue MaxLimit { get; set; }
Visual Basic (Declaration)
Public Property MaxLimit As SmartValue
Visual C++
public:
virtual property SmartValue MaxLimit {
    SmartValue get () sealed;
    void set (SmartValue value) sealed;
}

Implements

ISlider..::.MaxLimit

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


MinLimit Property

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.MinLimit Property
SliderBase Class See Also Send Feedback
Implements MinLimit.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue MinLimit { get; set; }
Visual Basic (Declaration)
Public Property MinLimit As SmartValue
Visual C++
public:
virtual property SmartValue MinLimit {
    SmartValue get () sealed;
    void set (SmartValue value) sealed;
}

Implements

ISlider..::.MinLimit

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Pressed Property

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.Pressed Property
SliderBase Class See Also Send Feedback
Gets the value indicating whether mouse button was pressed.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Pressed { get; }
Visual Basic (Declaration)
Public ReadOnly Property Pressed As Boolean
Visual C++
public:
property bool Pressed {
    bool get ();
}

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Scale Property

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.Scale Property
SliderBase Class See Also Send Feedback
Gets IScale object of SliderBase element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public IScale Scale { get; }
Visual Basic (Declaration)
Public ReadOnly Property Scale As IScale
Visual C++
public:
property IScale^ Scale {
    IScale^ get ();
}

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Smooth Property

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.Smooth Property
SliderBase Class See Also Send Feedback
Gets or sets value that indicates whether smoothing will be applied.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Smooth { get; set; }
Visual Basic (Declaration)
Public Property Smooth As Boolean
Visual C++
public:
property bool Smooth {
    bool get ();
    void set (bool value);
}

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Step Property

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.Step Property
SliderBase Class See Also Send Feedback
Gets or sets step of SliderBase element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Step { get; set; }
Visual Basic (Declaration)
Public Property Step As Double
Visual C++
public:
property double Step {
    double get ();
    void set (double value);
}

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Stroke Property

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.Stroke Property
SliderBase Class See Also Send Feedback
Gets or sets the Stroke object that is used to trace.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Stroke Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Stroke
Visual C++
public:
property Stroke^ Stroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Style Property

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.Style Property
SliderBase Class See Also Send Feedback
Gets or sets name of the used style.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string Style { get; set; }
Visual Basic (Declaration)
Public Property Style As String
Visual C++
public:
property String^ Style {
    String^ get ();
    void set (String^ value);
}

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.Value Property
SliderBase Class See Also Send Feedback
Implements Value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Double
Visual C++
public:
virtual property double Value {
    double get () sealed;
    void set (double value) sealed;
}

Implements

ISlider..::.Value

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


SliderBase Events

[image] [image]

.NET ModelKit Suite ClassReference
SliderBase Events
SliderBase Class See Also Send Feedback

The SliderBase type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)
ValueChanged | Occurs after slider value changing.

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


ValueChanged Event

[image]

.NET ModelKit Suite ClassReference
SliderBase..::.ValueChanged Event
SliderBase Class See Also Send Feedback
Occurs after slider value changing.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public event PropertyEventHandler ValueChanged
Visual Basic (Declaration)
Public Event ValueChanged As PropertyEventHandler
Visual C++
public:
 event PropertyEventHandler^ ValueChanged {
    void add (PropertyEventHandler^ value);
    void remove (PropertyEventHandler^ value);
}

See Also

SliderBase Class
PerpetuumSoft.Instrumentation.Model Namespace


SmartValue Structure

[image]

.NET ModelKit Suite ClassReference
SmartValue Structure
Members See Also Send Feedback
Represents data type with the ability to assign absolute values, relative values in percentage and a specific Auto value, specifying the need to automatically calculate value, subject to the use context.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public struct SmartValue : IFormattable
Visual Basic (Declaration)
Public Structure SmartValue _
    Implements IFormattable
Visual C++
public value class SmartValue : IFormattable

See Also

SmartValue Members
PerpetuumSoft.Instrumentation.Model Namespace


SmartValue Members

[image] [image]

.NET ModelKit Suite ClassReference
SmartValue Members
SmartValue Structure Constructors Methods Fields Properties See Also Send Feedback

The SmartValue type exposes the following members.

Constructors

Name | Description
SmartValue | Overloaded.

Methods

Name | Description
Clone | Creates a clone of this SmartValue.
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse | Overloaded.
ToString | Overloaded.

Operators

Name | Description
Equality |
Implicit |
Inequality |

Fields

Name | Description
Auto | Gets Auto SmartValue.

Properties

Name | Description
Kind | Gets kind of value.
Value | Gets value.

See Also

SmartValue Structure
PerpetuumSoft.Instrumentation.Model Namespace


SmartValue Constructor

[image] [image]

.NET ModelKit Suite ClassReference
SmartValue Constructor
SmartValue Structure See Also Send Feedback

Overload List

Name | Description
SmartValue(SmartValueKind) | Initializes a new instance of the SmartValue class with parameter for initializing the Kind prioperty.
SmartValue(Double) | Initializes a new instance of the SmartValue class with parameter for initializing the Value property.
SmartValue(SmartValueKind, Double) | Initializes a new instance of the SmartValue class with parameter for initializing the Kind and Value prioperties.

See Also

SmartValue Structure
SmartValue Members
PerpetuumSoft.Instrumentation.Model Namespace


SmartValue Constructor (SmartValueKind)

[image]

.NET ModelKit Suite ClassReference
SmartValue Constructor (SmartValueKind)
SmartValue Structure See Also Send Feedback
Initializes a new instance of the SmartValue class with parameter for initializing the Kind prioperty.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue(
    SmartValueKind kind
)
Visual Basic (Declaration)
Public Sub New ( _
    kind As SmartValueKind _
)
Visual C++
public:
SmartValue(
    SmartValueKind kind
)

Parameters

kind
Type: PerpetuumSoft.Instrumentation.Model..::.SmartValueKind

See Also

SmartValue Structure
SmartValue Overload
PerpetuumSoft.Instrumentation.Model Namespace


SmartValue Constructor (Double)

[image]

.NET ModelKit Suite ClassReference
SmartValue Constructor (Double)
SmartValue Structure See Also Send Feedback
Initializes a new instance of the SmartValue class with parameter for initializing the Value property.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue(
    double value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Double _
)
Visual C++
public:
SmartValue(
    double value
)

Parameters

value
Type: System..::.Double

See Also

SmartValue Structure
SmartValue Overload
PerpetuumSoft.Instrumentation.Model Namespace


SmartValue Constructor (SmartValueKind, Double)

[image]

.NET ModelKit Suite ClassReference
SmartValue Constructor (SmartValueKind, Double)
SmartValue Structure See Also Send Feedback
Initializes a new instance of the SmartValue class with parameter for initializing the Kind and Value prioperties.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue(
    SmartValueKind kind,
    double value
)
Visual Basic (Declaration)
Public Sub New ( _
    kind As SmartValueKind, _
    value As Double _
)
Visual C++
public:
SmartValue(
    SmartValueKind kind,
    double value
)

Parameters

kind
Type: PerpetuumSoft.Instrumentation.Model..::.SmartValueKind
value
Type: System..::.Double

See Also

SmartValue Structure
SmartValue Overload
PerpetuumSoft.Instrumentation.Model Namespace


SmartValue Fields

[image] [image]

.NET ModelKit Suite ClassReference
SmartValue Fields
SmartValue Structure See Also Send Feedback

The SmartValue type exposes the following members.

Fields

Name | Description
Auto | Gets Auto SmartValue.

See Also

SmartValue Structure
PerpetuumSoft.Instrumentation.Model Namespace


Auto Field

[image]

.NET ModelKit Suite ClassReference
SmartValue..::.Auto Field
SmartValue Structure See Also Send Feedback
Gets Auto SmartValue.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static readonly SmartValue Auto
Visual Basic (Declaration)
Public Shared ReadOnly Auto As SmartValue
Visual C++
public:
static initonly SmartValue Auto

See Also

SmartValue Structure
PerpetuumSoft.Instrumentation.Model Namespace


SmartValue Methods

[image] [image]

.NET ModelKit Suite ClassReference
SmartValue Methods
SmartValue Structure See Also Send Feedback

The SmartValue type exposes the following members.

Methods

Name | Description
Clone | Creates a clone of this SmartValue.
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse | Overloaded.
ToString | Overloaded.

Operators

Name | Description
Equality |
Implicit |
Inequality |

See Also

SmartValue Structure
PerpetuumSoft.Instrumentation.Model Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
SmartValue..::.Clone Method
SmartValue Structure See Also Send Feedback
Creates a clone of this SmartValue.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue Clone()
Visual Basic (Declaration)
Public Function Clone As SmartValue
Visual C++
public:
SmartValue Clone()

See Also

SmartValue Structure
PerpetuumSoft.Instrumentation.Model Namespace


Equality Operator

[image]

.NET ModelKit Suite ClassReference
SmartValue..::.Equality Operator
SmartValue Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.SmartValue.op_Equality(PerpetuumSoft.Instrumentation.Model.SmartValue,PerpetuumSoft.Instrumentation.Model.SmartValue)]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static bool operator ==(
    SmartValue interval1,
    SmartValue interval2
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    interval1 As SmartValue, _
    interval2 As SmartValue _
) As Boolean
Visual C++
public:
static bool operator ==(
    SmartValue interval1,
    SmartValue interval2
)

Parameters

interval1
Type: PerpetuumSoft.Instrumentation.Model..::.SmartValue
interval2
Type: PerpetuumSoft.Instrumentation.Model..::.SmartValue

See Also

SmartValue Structure
PerpetuumSoft.Instrumentation.Model Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
SmartValue..::.Equals Method
SmartValue Structure See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

SmartValue Structure
PerpetuumSoft.Instrumentation.Model Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
SmartValue..::.GetHashCode Method
SmartValue Structure See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

SmartValue Structure
PerpetuumSoft.Instrumentation.Model Namespace


Implicit Operator

[image]

.NET ModelKit Suite ClassReference
SmartValue..::.Implicit Operator
SmartValue Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.SmartValue.op_Implicit(System.Double)~PerpetuumSoft.Instrumentation.Model.SmartValue]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static implicit operator SmartValue (
    double value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As Double _
) As SmartValue
Visual C++
static implicit operator SmartValue (
    double value
)

Parameters

value
Type: System..::.Double

See Also

SmartValue Structure
PerpetuumSoft.Instrumentation.Model Namespace


Inequality Operator

[image]

.NET ModelKit Suite ClassReference
SmartValue..::.Inequality Operator
SmartValue Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.SmartValue.op_Inequality(PerpetuumSoft.Instrumentation.Model.SmartValue,PerpetuumSoft.Instrumentation.Model.SmartValue)]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static bool operator !=(
    SmartValue interval1,
    SmartValue interval2
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    interval1 As SmartValue, _
    interval2 As SmartValue _
) As Boolean
Visual C++
public:
static bool operator !=(
    SmartValue interval1,
    SmartValue interval2
)

Parameters

interval1
Type: PerpetuumSoft.Instrumentation.Model..::.SmartValue
interval2
Type: PerpetuumSoft.Instrumentation.Model..::.SmartValue

See Also

SmartValue Structure
PerpetuumSoft.Instrumentation.Model Namespace


Parse Method

[image] [image]

.NET ModelKit Suite ClassReference
SmartValue..::.Parse Method
SmartValue Structure See Also Send Feedback

Overload List

Name | Description
Parse(String) | Creates SmartValue by its string representation.
Parse(String, IFormatProvider) | Creates SmartValue by its string representation, with the use of FormatProvider for reading values.
Parse(String, NumberStyles, IFormatProvider) | Creates SmartValue by its string representation, with the use of NumberStyle and FormatProvider.

See Also

SmartValue Structure
SmartValue Members
PerpetuumSoft.Instrumentation.Model Namespace


Parse Method (String)

[image]

.NET ModelKit Suite ClassReference
SmartValue..::.Parse Method (String)
SmartValue Structure See Also Send Feedback
Creates SmartValue by its string representation.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static SmartValue Parse(
    string s
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    s As String _
) As SmartValue
Visual C++
public:
static SmartValue Parse(
    String^ s
)

Parameters

s
Type: System..::.String

See Also

SmartValue Structure
Parse Overload
PerpetuumSoft.Instrumentation.Model Namespace


Parse Method (String, IFormatProvider)

[image]

.NET ModelKit Suite ClassReference
SmartValue..::.Parse Method (String, IFormatProvider)
SmartValue Structure See Also Send Feedback
Creates SmartValue by its string representation, with the use of FormatProvider for reading values.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static SmartValue Parse(
    string s,
    IFormatProvider provider
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    s As String, _
    provider As IFormatProvider _
) As SmartValue
Visual C++
public:
static SmartValue Parse(
    String^ s,
    IFormatProvider^ provider
)

Parameters

s
Type: System..::.String
provider
Type: System..::.IFormatProvider

See Also

SmartValue Structure
Parse Overload
PerpetuumSoft.Instrumentation.Model Namespace


Parse Method (String, NumberStyles, IFormatProvider)

[image]

.NET ModelKit Suite ClassReference
SmartValue..::.Parse Method (String, NumberStyles, IFormatProvider)
SmartValue Structure See Also Send Feedback
Creates SmartValue by its string representation, with the use of NumberStyle and FormatProvider.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static SmartValue Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    s As String, _
    style As NumberStyles, _
    provider As IFormatProvider _
) As SmartValue
Visual C++
public:
static SmartValue Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)

Parameters

s
Type: System..::.String
style
Type: System.Globalization..::.NumberStyles
provider
Type: System..::.IFormatProvider

See Also

SmartValue Structure
Parse Overload
PerpetuumSoft.Instrumentation.Model Namespace


ToString Method

[image] [image]

.NET ModelKit Suite ClassReference
SmartValue..::.ToString Method
SmartValue Structure See Also Send Feedback

Overload List

Name | Description
ToString()()() | Overridden. See ToString()()(). (Overrides ValueType..::.ToString()()().)
ToString(IFormatProvider) | Returns text, representing this SmartValue.

See Also

SmartValue Structure
SmartValue Members
PerpetuumSoft.Instrumentation.Model Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
SmartValue..::.ToString Method
SmartValue Structure See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

SmartValue Structure
ToString Overload
PerpetuumSoft.Instrumentation.Model Namespace


ToString Method (IFormatProvider)

[image]

.NET ModelKit Suite ClassReference
SmartValue..::.ToString Method (IFormatProvider)
SmartValue Structure See Also Send Feedback
Returns text, representing this SmartValue.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string ToString(
    IFormatProvider formatProvider
)
Visual Basic (Declaration)
Public Function ToString ( _
    formatProvider As IFormatProvider _
) As String
Visual C++
public:
String^ ToString(
    IFormatProvider^ formatProvider
)

Parameters

formatProvider
Type: System..::.IFormatProvider

See Also

SmartValue Structure
ToString Overload
PerpetuumSoft.Instrumentation.Model Namespace


SmartValue Properties

[image] [image]

.NET ModelKit Suite ClassReference
SmartValue Properties
SmartValue Structure See Also Send Feedback

The SmartValue type exposes the following members.

Properties

Name | Description
Kind | Gets kind of value.
Value | Gets value.

See Also

SmartValue Structure
PerpetuumSoft.Instrumentation.Model Namespace


Kind Property

[image]

.NET ModelKit Suite ClassReference
SmartValue..::.Kind Property
SmartValue Structure See Also Send Feedback
Gets kind of value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public SmartValueKind Kind { get; }
Visual Basic (Declaration)
Public ReadOnly Property Kind As SmartValueKind
Visual C++
public:
property SmartValueKind Kind {
    SmartValueKind get ();
}

See Also

SmartValue Structure
PerpetuumSoft.Instrumentation.Model Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
SmartValue..::.Value Property
SmartValue Structure See Also Send Feedback
Gets value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Double
Visual C++
public:
property double Value {
    double get ();
}

See Also

SmartValue Structure
PerpetuumSoft.Instrumentation.Model Namespace


SmartValueKind Enumeration

[image]

.NET ModelKit Suite ClassReference
SmartValueKind Enumeration
See Also Send Feedback
Enumerates the smart value type.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public enum SmartValueKind
Visual Basic (Declaration)
Public Enumeration SmartValueKind
Visual C++
public enum class SmartValueKind

Members

Member name | Description
Auto | Specifies that the SmartValue is auto. I.e. value will be calculated automatically subject to the use context.
Constant | Specifies constant SmartValue.
Percent | Specifies SmartValue in percentage.

See Also

PerpetuumSoft.Instrumentation.Model Namespace


Spring Class

[image]

.NET ModelKit Suite ClassReference
Spring Class
Members See Also Send Feedback
Represents the Spring.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Spring : LineElement
Visual Basic (Declaration)
Public Class Spring _
    Inherits LineElement
Visual C++
public ref class Spring : public LineElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.LineElement
PerpetuumSoft.Instrumentation.Model..::.Spring

See Also

Spring Members
PerpetuumSoft.Instrumentation.Model Namespace


Spring Members

[image] [image]

.NET ModelKit Suite ClassReference
Spring Members
Spring Class Constructors Methods Properties Events See Also Send Feedback

The Spring type exposes the following members.

Constructors

Name | Description
Spring | Initializes a new instance of the Spring class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from LineElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsIncludePoint | Returns the value indicating whether an element includes a point. (Inherited from LineElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Amplitude | Gets or sets spring coils amplitude.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
CoilsCount | Gets or sets coils count.
EndPoint | Gets or sets the end point of the element. (Inherited from LineElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartPoint | Gets or sets the begin point of the element. (Inherited from LineElement.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Spring Class
PerpetuumSoft.Instrumentation.Model Namespace


Spring Constructor

[image]

.NET ModelKit Suite ClassReference
Spring Constructor
Spring Class See Also Send Feedback
Initializes a new instance of the Spring class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Spring()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Spring()

See Also

Spring Class
PerpetuumSoft.Instrumentation.Model Namespace


Spring Methods

[image] [image]

.NET ModelKit Suite ClassReference
Spring Methods
Spring Class See Also Send Feedback

The Spring type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from LineElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsIncludePoint | Returns the value indicating whether an element includes a point. (Inherited from LineElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Spring Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Spring..::.Dispose Method
Spring Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

Spring Class
Spring Members
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
Spring..::.GetHitTest Method
Spring Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Spring Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Spring..::.GetStyle Method
Spring Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Spring Class
Spring Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Spring..::.Invalidate Method
Spring Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Spring Class
Spring Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Spring..::.OnPaint Method
Spring Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Overrides Element..::.OnPaint(PaintArguments, Fill, Stroke).)

See Also

Spring Class
Spring Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments, Fill, Stroke)

[image]

.NET ModelKit Suite ClassReference
Spring..::.OnPaint Method (PaintArguments, Fill, Stroke)
Spring Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Spring Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


Spring Properties

[image] [image]

.NET ModelKit Suite ClassReference
Spring Properties
Spring Class See Also Send Feedback

The Spring type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Amplitude | Gets or sets spring coils amplitude.
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
CoilsCount | Gets or sets coils count.
EndPoint | Gets or sets the end point of the element. (Inherited from LineElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartPoint | Gets or sets the begin point of the element. (Inherited from LineElement.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Spring Class
PerpetuumSoft.Instrumentation.Model Namespace


Amplitude Property

[image]

.NET ModelKit Suite ClassReference
Spring..::.Amplitude Property
Spring Class See Also Send Feedback
Gets or sets spring coils amplitude.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Amplitude { get; set; }
Visual Basic (Declaration)
Public Property Amplitude As Double
Visual C++
public:
property double Amplitude {
    double get ();
    void set (double value);
}

See Also

Spring Class
PerpetuumSoft.Instrumentation.Model Namespace


CoilsCount Property

[image]

.NET ModelKit Suite ClassReference
Spring..::.CoilsCount Property
Spring Class See Also Send Feedback
Gets or sets coils count.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int CoilsCount { get; set; }
Visual Basic (Declaration)
Public Property CoilsCount As Integer
Visual C++
public:
property int CoilsCount {
    int get ();
    void set (int value);
}

See Also

Spring Class
PerpetuumSoft.Instrumentation.Model Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
Spring..::.Fill Property
Spring Class See Also Send Feedback
Gets or sets the Fill object that is used to paint over.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

Spring Class
PerpetuumSoft.Instrumentation.Model Namespace


Spring Events

[image] [image]

.NET ModelKit Suite ClassReference
Spring Events
Spring Class See Also Send Feedback

The Spring type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Spring Class
PerpetuumSoft.Instrumentation.Model Namespace


StandardBevel Class

[image]

.NET ModelKit Suite ClassReference
StandardBevel Class
Members See Also Send Feedback
Represents simple rectangular bevel.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class StandardBevel : Bevel
Visual Basic (Declaration)
Public Class StandardBevel _
    Inherits Bevel
Visual C++
public ref class StandardBevel : public Bevel

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework..::.Atom
PerpetuumSoft.Instrumentation.Model..::.Bevel
PerpetuumSoft.Instrumentation.Model..::.StandardBevel

See Also

StandardBevel Members
PerpetuumSoft.Instrumentation.Model Namespace


StandardBevel Members

[image] [image]

.NET ModelKit Suite ClassReference
StandardBevel Members
StandardBevel Class Constructors Methods Properties See Also Send Feedback

The StandardBevel type exposes the following members.

Constructors

Name | Description
StandardBevel | Initializes a new instance of the StandardBevel class.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Implements Clone()()(). (Overrides Atom..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDockingBounds | Overridden. See GetDockingBounds(VectorRectangle). (Overrides Bevel..::.GetDockingBounds(VectorRectangle).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Paint | Overridden. See Paint(VectorRectangle, GraphicStream). (Overrides Bevel..::.Paint(VectorRectangle, GraphicStream).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BevelShadow | Gets or sets Shadow which sets the bevel shadow effect.
CornerRadius | Gets or sets corner radius.
DownOffset | Gets or sets the bevel inner effect offset.
DrawingStyle | Gets or sets RectangleBevelDrawingStyle which represents the bevel drawing style.
Fill | Gets or sets Fill which is used during the background drawing.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
Margins | Gets or sets Margins which sets margins.
Stroke | Gets or sets Stroke which is used during the lines drawing.
UpOffset | Gets or sets the bevel outer effect offset.

See Also

StandardBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


StandardBevel Constructor

[image]

.NET ModelKit Suite ClassReference
StandardBevel Constructor
StandardBevel Class See Also Send Feedback
Initializes a new instance of the StandardBevel class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public StandardBevel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StandardBevel()

See Also

StandardBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


StandardBevel Methods

[image] [image]

.NET ModelKit Suite ClassReference
StandardBevel Methods
StandardBevel Class See Also Send Feedback

The StandardBevel type exposes the following members.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Implements Clone()()(). (Overrides Atom..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDockingBounds | Overridden. See GetDockingBounds(VectorRectangle). (Overrides Bevel..::.GetDockingBounds(VectorRectangle).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Paint | Overridden. See Paint(VectorRectangle, GraphicStream). (Overrides Bevel..::.Paint(VectorRectangle, GraphicStream).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StandardBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
StandardBevel..::.Clone Method
StandardBevel Class See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Implements

ICloneable..::.Clone()()()

See Also

StandardBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


GetDockingBounds Method

[image]

.NET ModelKit Suite ClassReference
StandardBevel..::.GetDockingBounds Method
StandardBevel Class See Also Send Feedback
Overridden. See GetDockingBounds(VectorRectangle).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetDockingBounds(
    VectorRectangle rectangle
)
Visual Basic (Declaration)
Public Overrides Function GetDockingBounds ( _
    rectangle As VectorRectangle _
) As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetDockingBounds(
    VectorRectangle rectangle
) override

Parameters

rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

StandardBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Paint Method

[image]

.NET ModelKit Suite ClassReference
StandardBevel..::.Paint Method
StandardBevel Class See Also Send Feedback
Overridden. See Paint(VectorRectangle, GraphicStream).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void Paint(
    VectorRectangle rectangle,
    GraphicStream stream
)
Visual Basic (Declaration)
Public Overrides Sub Paint ( _
    rectangle As VectorRectangle, _
    stream As GraphicStream _
)
Visual C++
public:
virtual void Paint(
    VectorRectangle rectangle,
    GraphicStream^ stream
) override

Parameters

rectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
stream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream

See Also

StandardBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


StandardBevel Properties

[image] [image]

.NET ModelKit Suite ClassReference
StandardBevel Properties
StandardBevel Class See Also Send Feedback

The StandardBevel type exposes the following members.

Properties

Name | Description
BevelShadow | Gets or sets Shadow which sets the bevel shadow effect.
CornerRadius | Gets or sets corner radius.
DownOffset | Gets or sets the bevel inner effect offset.
DrawingStyle | Gets or sets RectangleBevelDrawingStyle which represents the bevel drawing style.
Fill | Gets or sets Fill which is used during the background drawing.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
Margins | Gets or sets Margins which sets margins.
Stroke | Gets or sets Stroke which is used during the lines drawing.
UpOffset | Gets or sets the bevel outer effect offset.

See Also

StandardBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


BevelShadow Property

[image]

.NET ModelKit Suite ClassReference
StandardBevel..::.BevelShadow Property
StandardBevel Class See Also Send Feedback
Gets or sets Shadow which sets the bevel shadow effect.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Shadow BevelShadow { get; set; }
Visual Basic (Declaration)
Public Property BevelShadow As Shadow
Visual C++
public:
property Shadow^ BevelShadow {
    Shadow^ get ();
    void set (Shadow^ value);
}

See Also

StandardBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


CornerRadius Property

[image]

.NET ModelKit Suite ClassReference
StandardBevel..::.CornerRadius Property
StandardBevel Class See Also Send Feedback
Gets or sets corner radius.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double CornerRadius { get; set; }
Visual Basic (Declaration)
Public Property CornerRadius As Double
Visual C++
public:
property double CornerRadius {
    double get ();
    void set (double value);
}

See Also

StandardBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


DownOffset Property

[image]

.NET ModelKit Suite ClassReference
StandardBevel..::.DownOffset Property
StandardBevel Class See Also Send Feedback
Gets or sets the bevel inner effect offset.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double DownOffset { get; set; }
Visual Basic (Declaration)
Public Property DownOffset As Double
Visual C++
public:
property double DownOffset {
    double get ();
    void set (double value);
}

See Also

StandardBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


DrawingStyle Property

[image]

.NET ModelKit Suite ClassReference
StandardBevel..::.DrawingStyle Property
StandardBevel Class See Also Send Feedback
Gets or sets RectangleBevelDrawingStyle which represents the bevel drawing style.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public RectangleBevelDrawingStyle DrawingStyle { get; set; }
Visual Basic (Declaration)
Public Property DrawingStyle As RectangleBevelDrawingStyle
Visual C++
public:
property RectangleBevelDrawingStyle DrawingStyle {
    RectangleBevelDrawingStyle get ();
    void set (RectangleBevelDrawingStyle value);
}

See Also

StandardBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
StandardBevel..::.Fill Property
StandardBevel Class See Also Send Feedback
Gets or sets Fill which is used during the background drawing.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

StandardBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Margins Property

[image]

.NET ModelKit Suite ClassReference
StandardBevel..::.Margins Property
StandardBevel Class See Also Send Feedback
Gets or sets Margins which sets margins.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Margins Margins { get; set; }
Visual Basic (Declaration)
Public Property Margins As Margins
Visual C++
public:
property Margins Margins {
    Margins get ();
    void set (Margins value);
}

See Also

StandardBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Stroke Property

[image]

.NET ModelKit Suite ClassReference
StandardBevel..::.Stroke Property
StandardBevel Class See Also Send Feedback
Gets or sets Stroke which is used during the lines drawing.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Stroke Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Stroke
Visual C++
public:
property Stroke^ Stroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

StandardBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


UpOffset Property

[image]

.NET ModelKit Suite ClassReference
StandardBevel..::.UpOffset Property
StandardBevel Class See Also Send Feedback
Gets or sets the bevel outer effect offset.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double UpOffset { get; set; }
Visual Basic (Declaration)
Public Property UpOffset As Double
Visual C++
public:
property double UpOffset {
    double get ();
    void set (double value);
}

See Also

StandardBevel Class
PerpetuumSoft.Instrumentation.Model Namespace


Star Class

[image]

.NET ModelKit Suite ClassReference
Star Class
Members See Also Send Feedback
Represents the Star.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Star : Polygon
Visual Basic (Declaration)
Public Class Star _
    Inherits Polygon
Visual C++
public ref class Star : public Polygon

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.CircularShape
PerpetuumSoft.Instrumentation.Model..::.Polygon
PerpetuumSoft.Instrumentation.Model..::.Star

See Also

Star Members
PerpetuumSoft.Instrumentation.Model Namespace


Star Members

[image] [image]

.NET ModelKit Suite ClassReference
Star Members
Star Class Constructors Methods Properties Events See Also Send Feedback

The Star type exposes the following members.

Constructors

Name | Description
Star | Initializes a new instance of the Star class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Polygon.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from Polygon.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVertex | Returns vertexes of the star element. (Overrides Polygon..::.GetVertex()()().)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Gets or sets the angle by clockwize of the shape. (Inherited from CircularShape.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the shape. (Inherited from CircularShape.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
InternalRadius | Gets or sets star internal radius.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Radius | Gets or sets the radius of the shape. (Inherited from CircularShape.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Sides | Gets or sets element sides count. (Inherited from Polygon.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Star Class
PerpetuumSoft.Instrumentation.Model Namespace


Star Constructor

[image]

.NET ModelKit Suite ClassReference
Star Constructor
Star Class See Also Send Feedback
Initializes a new instance of the Star class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Star()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Star()

See Also

Star Class
PerpetuumSoft.Instrumentation.Model Namespace


Star Methods

[image] [image]

.NET ModelKit Suite ClassReference
Star Methods
Star Class See Also Send Feedback

The Star type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Polygon.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from Polygon.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVertex | Returns vertexes of the star element. (Overrides Polygon..::.GetVertex()()().)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Star Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Star..::.Dispose Method
Star Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

Star Class
Star Members
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Star..::.GetStyle Method
Star Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Star Class
Star Members
PerpetuumSoft.Instrumentation.Model Namespace


GetVertex Method

[image]

.NET ModelKit Suite ClassReference
Star..::.GetVertex Method
Star Class See Also Send Feedback
Returns vertexes of the star element.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override Vector[] GetVertex()
Visual Basic (Declaration)
Protected Overrides Function GetVertex As Vector()
Visual C++
protected:
virtual array<Vector>^ GetVertex() override

See Also

Star Class
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Star..::.Invalidate Method
Star Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Star Class
Star Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Star..::.OnPaint Method
Star Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from Polygon.)

See Also

Star Class
Star Members
PerpetuumSoft.Instrumentation.Model Namespace


Star Properties

[image] [image]

.NET ModelKit Suite ClassReference
Star Properties
Star Class See Also Send Feedback

The Star type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Gets or sets the angle by clockwize of the shape. (Inherited from CircularShape.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the shape. (Inherited from CircularShape.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
InternalRadius | Gets or sets star internal radius.
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
Radius | Gets or sets the radius of the shape. (Inherited from CircularShape.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Sides | Gets or sets element sides count. (Inherited from Polygon.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Star Class
PerpetuumSoft.Instrumentation.Model Namespace


InternalRadius Property

[image]

.NET ModelKit Suite ClassReference
Star..::.InternalRadius Property
Star Class See Also Send Feedback
Gets or sets star internal radius.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double InternalRadius { get; set; }
Visual Basic (Declaration)
Public Property InternalRadius As Double
Visual C++
public:
property double InternalRadius {
    double get ();
    void set (double value);
}

See Also

Star Class
PerpetuumSoft.Instrumentation.Model Namespace


Star Events

[image] [image]

.NET ModelKit Suite ClassReference
Star Events
Star Class See Also Send Feedback

The Star type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Star Class
PerpetuumSoft.Instrumentation.Model Namespace


SubTicksPosition Enumeration

[image]

.NET ModelKit Suite ClassReference
SubTicksPosition Enumeration
See Also Send Feedback
Represents SubTicks positions.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public enum SubTicksPosition
Visual Basic (Declaration)
Public Enumeration SubTicksPosition
Visual C++
public enum class SubTicksPosition

Members

Member name | Description
Near | Near position.
Center | Center position.
Far | Far position.

See Also

PerpetuumSoft.Instrumentation.Model Namespace


Tank Class

[image]

.NET ModelKit Suite ClassReference
Tank Class
Members See Also Send Feedback
Determines the tank element, visualizes value in the form of level.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Tank : ValuePresenterScaleElement
Visual Basic (Declaration)
Public Class Tank _
    Inherits ValuePresenterScaleElement
Visual C++
public ref class Tank : public ValuePresenterScaleElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.ScaleElement
PerpetuumSoft.Instrumentation.Model..::.ValuePresenterScaleElement
PerpetuumSoft.Instrumentation.Model..::.Tank

See Also

Tank Members
PerpetuumSoft.Instrumentation.Model Namespace


Tank Members

[image] [image]

.NET ModelKit Suite ClassReference
Tank Members
Tank Class Constructors Methods Properties Events See Also Send Feedback

The Tank type exposes the following members.

Constructors

Name | Description
Tank | Initializes a new instance of the Tank class.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetMaxValue | Return maximim value from represented values. (Inherited from ValuePresenterScaleElement.)
GetMinValue | Returns minimum value from represented values. (Inherited from ValuePresenterScaleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()(). (Overrides ScaleElement..::.GetSize()()().)
GetSmartValue | Returns value by SmartValue amd calculated value for the Auto case. (Inherited from ValuePresenterScaleElement.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Inherited from ScaleElement.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleElement.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Depth | Gets or sets depth of the tank.
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Effect3D | Gets or sets 3d effects mode.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
LiquidColor | Gets or sets liquid color in this tank.
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
TankColor | Gets or sets the color of the tank.
TankWidth | Gets or sets width of the tank wall.
Value | Gets or sets represented value. (Inherited from ValuePresenterScaleElement.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)
Width | Gets or sets width of the thank.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Tank Class
PerpetuumSoft.Instrumentation.Model Namespace


Tank Constructor

[image]

.NET ModelKit Suite ClassReference
Tank Constructor
Tank Class See Also Send Feedback
Initializes a new instance of the Tank class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Tank()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Tank()

See Also

Tank Class
PerpetuumSoft.Instrumentation.Model Namespace


Tank Methods

[image] [image]

.NET ModelKit Suite ClassReference
Tank Methods
Tank Class See Also Send Feedback

The Tank type exposes the following members.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetMaxValue | Return maximim value from represented values. (Inherited from ValuePresenterScaleElement.)
GetMinValue | Returns minimum value from represented values. (Inherited from ValuePresenterScaleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()(). (Overrides ScaleElement..::.GetSize()()().)
GetSmartValue | Returns value by SmartValue amd calculated value for the Auto case. (Inherited from ValuePresenterScaleElement.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Inherited from ScaleElement.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleElement.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Tank Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Tank..::.Dispose Method
Tank Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

Tank Class
Tank Members
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
Tank..::.GetHitTest Method
Tank Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Tank Class
PerpetuumSoft.Instrumentation.Model Namespace


GetSize Method

[image]

.NET ModelKit Suite ClassReference
Tank..::.GetSize Method
Tank Class See Also Send Feedback
Implements GetSize()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override double GetSize()
Visual Basic (Declaration)
Public Overrides Function GetSize As Double
Visual C++
public:
virtual double GetSize() override

Implements

IScaleElement..::.GetSize()()()

See Also

Tank Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Tank..::.GetStyle Method
Tank Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Tank Class
Tank Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Tank..::.Invalidate Method
Tank Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Tank Class
Tank Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Tank..::.OnPaint Method
Tank Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Overridden. See OnPaint(PaintArguments). (Overrides Element..::.OnPaint(PaintArguments).)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

Tank Class
Tank Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method (PaintArguments)

[image]

.NET ModelKit Suite ClassReference
Tank..::.OnPaint Method (PaintArguments)
Tank Class See Also Send Feedback
Overridden. See OnPaint(PaintArguments).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Public Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
public:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments

See Also

Tank Class
OnPaint Overload
PerpetuumSoft.Instrumentation.Model Namespace


Tank Properties

[image] [image]

.NET ModelKit Suite ClassReference
Tank Properties
Tank Class See Also Send Feedback

The Tank type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Depth | Gets or sets depth of the tank.
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Effect3D | Gets or sets 3d effects mode.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
LiquidColor | Gets or sets liquid color in this tank.
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
TankColor | Gets or sets the color of the tank.
TankWidth | Gets or sets width of the tank wall.
Value | Gets or sets represented value. (Inherited from ValuePresenterScaleElement.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)
Width | Gets or sets width of the thank.

See Also

Tank Class
PerpetuumSoft.Instrumentation.Model Namespace


Depth Property

[image]

.NET ModelKit Suite ClassReference
Tank..::.Depth Property
Tank Class See Also Send Feedback
Gets or sets depth of the tank.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Depth { get; set; }
Visual Basic (Declaration)
Public Property Depth As Double
Visual C++
public:
property double Depth {
    double get ();
    void set (double value);
}

See Also

Tank Class
PerpetuumSoft.Instrumentation.Model Namespace


Effect3D Property

[image]

.NET ModelKit Suite ClassReference
Tank..::.Effect3D Property
Tank Class See Also Send Feedback
Gets or sets 3d effects mode.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Effect3D Effect3D { get; set; }
Visual Basic (Declaration)
Public Property Effect3D As Effect3D
Visual C++
public:
property Effect3D Effect3D {
    Effect3D get ();
    void set (Effect3D value);
}

See Also

Tank Class
PerpetuumSoft.Instrumentation.Model Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
Tank..::.Fill Property
Tank Class See Also Send Feedback
Gets or sets the Fill object that is used to paint over.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

Tank Class
PerpetuumSoft.Instrumentation.Model Namespace


LiquidColor Property

[image]

.NET ModelKit Suite ClassReference
Tank..::.LiquidColor Property
Tank Class See Also Send Feedback
Gets or sets liquid color in this tank.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Color LiquidColor { get; set; }
Visual Basic (Declaration)
Public Property LiquidColor As Color
Visual C++
public:
property Color LiquidColor {
    Color get ();
    void set (Color value);
}

See Also

Tank Class
PerpetuumSoft.Instrumentation.Model Namespace


TankColor Property

[image]

.NET ModelKit Suite ClassReference
Tank..::.TankColor Property
Tank Class See Also Send Feedback
Gets or sets the color of the tank.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Color TankColor { get; set; }
Visual Basic (Declaration)
Public Property TankColor As Color
Visual C++
public:
property Color TankColor {
    Color get ();
    void set (Color value);
}

See Also

Tank Class
PerpetuumSoft.Instrumentation.Model Namespace


TankWidth Property

[image]

.NET ModelKit Suite ClassReference
Tank..::.TankWidth Property
Tank Class See Also Send Feedback
Gets or sets width of the tank wall.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double TankWidth { get; set; }
Visual Basic (Declaration)
Public Property TankWidth As Double
Visual C++
public:
property double TankWidth {
    double get ();
    void set (double value);
}

See Also

Tank Class
PerpetuumSoft.Instrumentation.Model Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
Tank..::.Width Property
Tank Class See Also Send Feedback
Gets or sets width of the thank.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

Tank Class
PerpetuumSoft.Instrumentation.Model Namespace


Tank Events

[image] [image]

.NET ModelKit Suite ClassReference
Tank Events
Tank Class See Also Send Feedback

The Tank type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Tank Class
PerpetuumSoft.Instrumentation.Model Namespace


TextItem Class

[image]

.NET ModelKit Suite ClassReference
TextItem Class
Members See Also Send Feedback
Represents the text using in text labels elements.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class TextItem
Visual Basic (Declaration)
Public Class TextItem
Visual C++
public ref class TextItem

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.TextItem

See Also

TextItem Members
PerpetuumSoft.Instrumentation.Model Namespace


TextItem Members

[image] [image]

.NET ModelKit Suite ClassReference
TextItem Members
TextItem Class Constructors Methods Properties See Also Send Feedback

The TextItem type exposes the following members.

Constructors

Name | Description
TextItem | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
Text | Gets or sets TextItem object value.
Value | Gets or sets value of text item.

See Also

TextItem Class
PerpetuumSoft.Instrumentation.Model Namespace


TextItem Constructor

[image] [image]

.NET ModelKit Suite ClassReference
TextItem Constructor
TextItem Class See Also Send Feedback

Overload List

Name | Description
TextItem()()() | Initializes a new instance of the TextItem class.
TextItem(SmartValue, String) | Initializes a new instance of the TextItem class.

See Also

TextItem Class
TextItem Members
PerpetuumSoft.Instrumentation.Model Namespace


TextItem Constructor

[image]

.NET ModelKit Suite ClassReference
TextItem Constructor
TextItem Class See Also Send Feedback
Initializes a new instance of the TextItem class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public TextItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextItem()

See Also

TextItem Class
TextItem Overload
PerpetuumSoft.Instrumentation.Model Namespace


TextItem Constructor (SmartValue, String)

[image]

.NET ModelKit Suite ClassReference
TextItem Constructor (SmartValue, String)
TextItem Class See Also Send Feedback
Initializes a new instance of the TextItem class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public TextItem(
    SmartValue value,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    value As SmartValue, _
    text As String _
)
Visual C++
public:
TextItem(
    SmartValue value,
    String^ text
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model..::.SmartValue
text
Type: System..::.String

See Also

TextItem Class
TextItem Overload
PerpetuumSoft.Instrumentation.Model Namespace


TextItem Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextItem Methods
TextItem Class See Also Send Feedback

The TextItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

TextItem Class
PerpetuumSoft.Instrumentation.Model Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
TextItem..::.ToString Method
TextItem Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

TextItem Class
PerpetuumSoft.Instrumentation.Model Namespace


TextItem Properties

[image] [image]

.NET ModelKit Suite ClassReference
TextItem Properties
TextItem Class See Also Send Feedback

The TextItem type exposes the following members.

Properties

Name | Description
Text | Gets or sets TextItem object value.
Value | Gets or sets value of text item.

See Also

TextItem Class
PerpetuumSoft.Instrumentation.Model Namespace


Text Property

[image]

.NET ModelKit Suite ClassReference
TextItem..::.Text Property
TextItem Class See Also Send Feedback
Gets or sets TextItem object value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

TextItem Class
PerpetuumSoft.Instrumentation.Model Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
TextItem..::.Value Property
TextItem Class See Also Send Feedback
Gets or sets value of text item.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue Value { get; set; }
Visual Basic (Declaration)
Public Property Value As SmartValue
Visual C++
public:
property SmartValue Value {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

TextItem Class
PerpetuumSoft.Instrumentation.Model Namespace


TextItemCollection Class

[image]

.NET ModelKit Suite ClassReference
TextItemCollection Class
Members See Also Send Feedback
Represents the collection of TextItem elements.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class TextItemCollection : CollectionBase
Visual Basic (Declaration)
Public Class TextItemCollection _
    Inherits CollectionBase
Visual C++
public ref class TextItemCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Instrumentation.Model..::.TextItemCollection

See Also

TextItemCollection Members
PerpetuumSoft.Instrumentation.Model Namespace


TextItemCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
TextItemCollection Members
TextItemCollection Class Constructors Methods Properties Events See Also Send Feedback

The TextItemCollection type exposes the following members.

Constructors

Name | Description
TextItemCollection | Initializes a new instance of the TextItemCollection class.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Add array of TextItem objects into collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Raise Insert event. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Raise InsertComplete event. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Raise RemoveComplete event. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Raise Validate event. (Overrides CollectionBase..::.OnValidate(Object).)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Implements Item[([(Int32])]).
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

Name | Description
CollectionChanged | Occurs after changed collection.

See Also

TextItemCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


TextItemCollection Constructor

[image]

.NET ModelKit Suite ClassReference
TextItemCollection Constructor
TextItemCollection Class See Also Send Feedback
Initializes a new instance of the TextItemCollection class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public TextItemCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextItemCollection()

See Also

TextItemCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


TextItemCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextItemCollection Methods
TextItemCollection Class See Also Send Feedback

The TextItemCollection type exposes the following members.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Add array of TextItem objects into collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Raise Insert event. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Raise InsertComplete event. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Raise RemoveComplete event. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Raise Validate event. (Overrides CollectionBase..::.OnValidate(Object).)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextItemCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
TextItemCollection..::.Add Method
TextItemCollection Class See Also Send Feedback
Implements Add(Object).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public TextItem Add(
    TextItem value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As TextItem _
) As TextItem
Visual C++
public:
TextItem^ Add(
    TextItem^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model..::.TextItem

See Also

TextItemCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
TextItemCollection..::.AddRange Method
TextItemCollection Class See Also Send Feedback
Add array of TextItem objects into collection.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    TextItem[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As TextItem() _
)
Visual C++
public:
void AddRange(
    array<TextItem^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Instrumentation.Model..::.TextItem >[]()[]

See Also

TextItemCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
TextItemCollection..::.Contains Method
TextItemCollection Class See Also Send Feedback
Implements Contains(Object).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    TextItem value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As TextItem _
) As Boolean
Visual C++
public:
bool Contains(
    TextItem^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model..::.TextItem

See Also

TextItemCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
TextItemCollection..::.IndexOf Method
TextItemCollection Class See Also Send Feedback
Implements IndexOf(Object).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    TextItem value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As TextItem _
) As Integer
Visual C++
public:
int IndexOf(
    TextItem^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model..::.TextItem

See Also

TextItemCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
TextItemCollection..::.Insert Method
TextItemCollection Class See Also Send Feedback
Implements Insert(Int32, Object).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    TextItem value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As TextItem _
)
Visual C++
public:
void Insert(
    int index,
    TextItem^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Instrumentation.Model..::.TextItem

See Also

TextItemCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


OnInsert Method

[image]

.NET ModelKit Suite ClassReference
TextItemCollection..::.OnInsert Method
TextItemCollection Class See Also Send Feedback
Raise Insert event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsert(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsert ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsert(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

TextItemCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


OnInsertComplete Method

[image]

.NET ModelKit Suite ClassReference
TextItemCollection..::.OnInsertComplete Method
TextItemCollection Class See Also Send Feedback
Raise InsertComplete event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsertComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsertComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsertComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

TextItemCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


OnRemoveComplete Method

[image]

.NET ModelKit Suite ClassReference
TextItemCollection..::.OnRemoveComplete Method
TextItemCollection Class See Also Send Feedback
Raise RemoveComplete event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnRemoveComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemoveComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemoveComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

TextItemCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


OnValidate Method

[image]

.NET ModelKit Suite ClassReference
TextItemCollection..::.OnValidate Method
TextItemCollection Class See Also Send Feedback
Raise Validate event.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnValidate(
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnValidate ( _
    value As Object _
)
Visual C++
protected:
virtual void OnValidate(
    Object^ value
) override

Parameters

value
Type: System..::.Object

See Also

TextItemCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
TextItemCollection..::.Remove Method
TextItemCollection Class See Also Send Feedback
Implements Remove(Object).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    TextItem value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As TextItem _
)
Visual C++
public:
void Remove(
    TextItem^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model..::.TextItem

See Also

TextItemCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


TextItemCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
TextItemCollection Properties
TextItemCollection Class See Also Send Feedback

The TextItemCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Implements Item[([(Int32])]).
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

TextItemCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
TextItemCollection..::.Item Property
TextItemCollection Class See Also Send Feedback
Implements Item[([(Int32])]).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public TextItem this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As TextItem
Visual C++
public:
property TextItem^ default[int index] {
    TextItem^ get (int index);
    void set (int index, TextItem^ value);
}

Parameters

index
Type: System..::.Int32

See Also

TextItemCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


TextItemCollection Events

[image] [image]

.NET ModelKit Suite ClassReference
TextItemCollection Events
TextItemCollection Class See Also Send Feedback

The TextItemCollection type exposes the following members.

Events

Name | Description
CollectionChanged | Occurs after changed collection.

See Also

TextItemCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


CollectionChanged Event

[image]

.NET ModelKit Suite ClassReference
TextItemCollection..::.CollectionChanged Event
TextItemCollection Class See Also Send Feedback
Occurs after changed collection.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public event TextItemCollection..::.CollectionChangedEventHandler CollectionChanged
Visual Basic (Declaration)
Public Event CollectionChanged As TextItemCollection..::.CollectionChangedEventHandler
Visual C++
public:
 event TextItemCollection..::.CollectionChangedEventHandler^ CollectionChanged {
    void add (TextItemCollection..::.CollectionChangedEventHandler^ value);
    void remove (TextItemCollection..::.CollectionChangedEventHandler^ value);
}

See Also

TextItemCollection Class
PerpetuumSoft.Instrumentation.Model Namespace


TextItemCollection.CollectionChangedEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
TextItemCollection..::.CollectionChangedEventHandler Delegate
TextItemCollection Class See Also Send Feedback
Represents method which was call after TextItemCollection change.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public delegate void CollectionChangedEventHandler(
    TextItem textItem
)
Visual Basic (Declaration)
Public Delegate Sub CollectionChangedEventHandler ( _
    textItem As TextItem _
)
Visual C++
public delegate void CollectionChangedEventHandler(
    TextItem^ textItem
)

Parameters

textItem
Type: PerpetuumSoft.Instrumentation.Model..::.TextItem

See Also

PerpetuumSoft.Instrumentation.Model Namespace


TextLabels Class

[image]

.NET ModelKit Suite ClassReference
TextLabels Class
Members See Also Send Feedback
Represent Text labels.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
[ObsoleteAttribute("This class is obsolete; use class CustomLabels instead")]
public class TextLabels : CustomLabels
Visual Basic (Declaration)
<ObsoleteAttribute("This class is obsolete; use class CustomLabels instead")> _
Public Class TextLabels _
    Inherits CustomLabels
Visual C++
[ObsoleteAttribute(L"This class is obsolete; use class CustomLabels instead")]
public ref class TextLabels : public CustomLabels

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.ScaleElement
PerpetuumSoft.Instrumentation.Model..::.ScaleLabelsBase
PerpetuumSoft.Instrumentation.Model..::.CustomLabels
PerpetuumSoft.Instrumentation.Model..::.TextLabels

See Also

TextLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


TextLabels Members

[image] [image]

.NET ModelKit Suite ClassReference
TextLabels Members
TextLabels Class Constructors Methods Properties Events See Also Send Feedback

The TextLabels type exposes the following members.

Constructors

Name | Description
TextLabels | Initializes a new instance of the TextLabels class.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from ScaleLabelsBase.)
GetLabelsCount | Overridden. See GetLabelsCount()()(). (Inherited from CustomLabels.)
GetObject | Implements GetObject(String). (Inherited from ScaleLabelsBase.)
GetObjectByIndex | Overridden. See GetObjectByIndex(Int32). (Inherited from CustomLabels.)
GetSize | Implements GetSize()()(). (Inherited from ScaleLabelsBase.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetTextLabel | Returns label text by the assigned value. (Inherited from ScaleLabelsBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueByIndex | Overridden. See GetValueByIndex(Int32). (Inherited from CustomLabels.)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Raises the OnParentChanged event. (Inherited from ScaleLabelsBase.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is called when element's visibility is changed. (Inherited from ScaleLabelsBase.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLabel | Draws a scale mark. (Inherited from ScaleLabelsBase.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleLabelsBase.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleLabelsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets FontDescriptor of the element. (Inherited from ScaleLabelsBase.)
Format | Gets and sets text format for the labels. (Inherited from ScaleLabelsBase.)
Formula | Gets or sets expression used for calculating labels value. (Inherited from ScaleLabelsBase.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
ItemMargins | Gets or sets item margins. (Inherited from ScaleLabelsBase.)
Labels | Gets TextItemCollection of label values. (Inherited from CustomLabels.)
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
OddLabelsDistance | Gets or sets distance foк odd labels. (Inherited from ScaleLabelsBase.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
Position | Gets or sets label position mode. (Inherited from ScaleLabelsBase.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
ShowSuperposableLabels | Gets or sets value that indicates whether superposable labels will be shown. (Inherited from ScaleLabelsBase.)
Size | Gets element size. (Inherited from ScaleLabelsBase.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
TextAlignment | Gets or sets text alignment. (Inherited from ScaleLabelsBase.)
TextAngle | Gets or sets text angle. (Inherited from ScaleLabelsBase.)
TextRotationMode | Gets or sets text rotation mode. (Inherited from ScaleLabelsBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

TextLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


TextLabels Constructor

[image]

.NET ModelKit Suite ClassReference
TextLabels Constructor
TextLabels Class See Also Send Feedback
Initializes a new instance of the TextLabels class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public TextLabels()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextLabels()

See Also

TextLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


TextLabels Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextLabels Methods
TextLabels Class See Also Send Feedback

The TextLabels type exposes the following members.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from ScaleLabelsBase.)
GetLabelsCount | Overridden. See GetLabelsCount()()(). (Inherited from CustomLabels.)
GetObject | Implements GetObject(String). (Inherited from ScaleLabelsBase.)
GetObjectByIndex | Overridden. See GetObjectByIndex(Int32). (Inherited from CustomLabels.)
GetSize | Implements GetSize()()(). (Inherited from ScaleLabelsBase.)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetTextLabel | Returns label text by the assigned value. (Inherited from ScaleLabelsBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueByIndex | Overridden. See GetValueByIndex(Int32). (Inherited from CustomLabels.)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Raises the OnParentChanged event. (Inherited from ScaleLabelsBase.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is called when element's visibility is changed. (Inherited from ScaleLabelsBase.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintLabel | Draws a scale mark. (Inherited from ScaleLabelsBase.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleLabelsBase.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleLabelsBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
TextLabels..::.Dispose Method
TextLabels Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

TextLabels Class
TextLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
TextLabels..::.GetStyle Method
TextLabels Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

TextLabels Class
TextLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
TextLabels..::.Invalidate Method
TextLabels Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

TextLabels Class
TextLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
TextLabels..::.OnPaint Method
TextLabels Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from ScaleLabelsBase.)

See Also

TextLabels Class
TextLabels Members
PerpetuumSoft.Instrumentation.Model Namespace


TextLabels Properties

[image] [image]

.NET ModelKit Suite ClassReference
TextLabels Properties
TextLabels Class See Also Send Feedback

The TextLabels type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets FontDescriptor of the element. (Inherited from ScaleLabelsBase.)
Format | Gets and sets text format for the labels. (Inherited from ScaleLabelsBase.)
Formula | Gets or sets expression used for calculating labels value. (Inherited from ScaleLabelsBase.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
ItemMargins | Gets or sets item margins. (Inherited from ScaleLabelsBase.)
Labels | Gets TextItemCollection of label values. (Inherited from CustomLabels.)
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
OddLabelsDistance | Gets or sets distance foк odd labels. (Inherited from ScaleLabelsBase.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
Position | Gets or sets label position mode. (Inherited from ScaleLabelsBase.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
ShowSuperposableLabels | Gets or sets value that indicates whether superposable labels will be shown. (Inherited from ScaleLabelsBase.)
Size | Gets element size. (Inherited from ScaleLabelsBase.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
TextAlignment | Gets or sets text alignment. (Inherited from ScaleLabelsBase.)
TextAngle | Gets or sets text angle. (Inherited from ScaleLabelsBase.)
TextRotationMode | Gets or sets text rotation mode. (Inherited from ScaleLabelsBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

TextLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


TextLabels Events

[image] [image]

.NET ModelKit Suite ClassReference
TextLabels Events
TextLabels Class See Also Send Feedback

The TextLabels type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

TextLabels Class
PerpetuumSoft.Instrumentation.Model Namespace


TextRotationMode Enumeration

[image]

.NET ModelKit Suite ClassReference
TextRotationMode Enumeration
See Also Send Feedback
Represents the text rotation mode.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public enum TextRotationMode
Visual Basic (Declaration)
Public Enumeration TextRotationMode
Visual C++
public enum class TextRotationMode

Members

Member name | Description
Screen | Rotation relative to screen.
Scale | Rotation relative to scale.

See Also

PerpetuumSoft.Instrumentation.Model Namespace


Ticks Class

[image]

.NET ModelKit Suite ClassReference
Ticks Class
Members See Also Send Feedback
Represents the Ticks.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Ticks : ScaleMarksBase
Visual Basic (Declaration)
Public Class Ticks _
    Inherits ScaleMarksBase
Visual C++
public ref class Ticks : public ScaleMarksBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.ScaleElement
PerpetuumSoft.Instrumentation.Model..::.ScaleMarksBase
PerpetuumSoft.Instrumentation.Model..::.Ticks

See Also

Ticks Members
PerpetuumSoft.Instrumentation.Model Namespace


Ticks Members

[image] [image]

.NET ModelKit Suite ClassReference
Ticks Members
Ticks Class Constructors Methods Properties Events See Also Send Feedback

The Ticks type exposes the following members.

Constructors

Name | Description
Ticks | Initializes a new instance of the Ticks class.

Methods

Name | Description
Calculate | Overridden. SeeCalculate()()(). (Overrides ScaleElement..::.Calculate()()().)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()(). (Overrides ScaleElement..::.GetSize()()().)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetSubWidth | Returns width of sub marks. (Overrides ScaleMarksBase..::.GetSubWidth()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWidth | Returns width of marks. (Overrides ScaleMarksBase..::.GetWidth()()().)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NeedPaint | Returns value, indicating whehter mark is painted. (Inherited from ScaleMarksBase.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Inherited from ScaleElement.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintMark | Paints marks. (Overrides ScaleMarksBase..::.PaintMark(GraphicStream, Double, Double, Fill, Double, Stroke, Boolean).)
PaintSubMark | (Overrides ScaleMarksBase..::.PaintSubMark(GraphicStream, Double, Double, Fill, Stroke, Boolean).)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleElement.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Divisions | Gets or sets divisions count. (Inherited from ScaleMarksBase.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Length | Gets or sets ticks length.
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Step | Gets or sets interval between marks. (Inherited from ScaleMarksBase.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SubDivisions | Gets or sets sub divisions count. (Inherited from ScaleMarksBase.)
SubLength | Gets or sets length of the scale sub-ticks.
SubTicksPosition | Gets or sets the subticks position relative to the base trajectory. (Inherited from ScaleMarksBase.)
UseDescreteValues | Gets or sets value, indicating whether discrete values are used. (Inherited from ScaleMarksBase.)
UseRoundValues | Gets or sets value that indicates if the marks will correspond to round values. (Inherited from ScaleMarksBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Ticks Class
PerpetuumSoft.Instrumentation.Model Namespace


Ticks Constructor

[image]

.NET ModelKit Suite ClassReference
Ticks Constructor
Ticks Class See Also Send Feedback
Initializes a new instance of the Ticks class.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Ticks()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Ticks()

See Also

Ticks Class
PerpetuumSoft.Instrumentation.Model Namespace


Ticks Methods

[image] [image]

.NET ModelKit Suite ClassReference
Ticks Methods
Ticks Class See Also Send Feedback

The Ticks type exposes the following members.

Methods

Name | Description
Calculate | Overridden. SeeCalculate()()(). (Overrides ScaleElement..::.Calculate()()().)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Overrides Element..::.GetBoundedBox()()().)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides Element..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()(). (Overrides ScaleElement..::.GetSize()()().)
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetSubWidth | Returns width of sub marks. (Overrides ScaleMarksBase..::.GetSubWidth()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWidth | Returns width of marks. (Overrides ScaleMarksBase..::.GetWidth()()().)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NeedPaint | Returns value, indicating whehter mark is painted. (Inherited from ScaleMarksBase.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Inherited from ScaleElement.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
PaintMark | Paints marks. (Overrides ScaleMarksBase..::.PaintMark(GraphicStream, Double, Double, Fill, Double, Stroke, Boolean).)
PaintSubMark | (Overrides ScaleMarksBase..::.PaintSubMark(GraphicStream, Double, Double, Fill, Stroke, Boolean).)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleElement.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Ticks Class
PerpetuumSoft.Instrumentation.Model Namespace


Calculate Method

[image]

.NET ModelKit Suite ClassReference
Ticks..::.Calculate Method
Ticks Class See Also Send Feedback
Overridden. SeeCalculate()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void Calculate()
Visual Basic (Declaration)
Protected Overrides Sub Calculate
Visual C++
protected:
virtual void Calculate() override

See Also

Ticks Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Ticks..::.Dispose Method
Ticks Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

Ticks Class
Ticks Members
PerpetuumSoft.Instrumentation.Model Namespace


GetBoundedBox Method

[image]

.NET ModelKit Suite ClassReference
Ticks..::.GetBoundedBox Method
Ticks Class See Also Send Feedback
Implements GetBoundedBox()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle GetBoundedBox()
Visual Basic (Declaration)
Public Overrides Function GetBoundedBox As VectorRectangle
Visual C++
public:
virtual VectorRectangle GetBoundedBox() override

Implements

IElement..::.GetBoundedBox()()()

See Also

Ticks Class
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
Ticks..::.GetHitTest Method
Ticks Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

Ticks Class
PerpetuumSoft.Instrumentation.Model Namespace


GetSize Method

[image]

.NET ModelKit Suite ClassReference
Ticks..::.GetSize Method
Ticks Class See Also Send Feedback
Implements GetSize()()().

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override double GetSize()
Visual Basic (Declaration)
Public Overrides Function GetSize As Double
Visual C++
public:
virtual double GetSize() override

Implements

IScaleElement..::.GetSize()()()

See Also

Ticks Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Ticks..::.GetStyle Method
Ticks Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Ticks Class
Ticks Members
PerpetuumSoft.Instrumentation.Model Namespace


GetSubWidth Method

[image]

.NET ModelKit Suite ClassReference
Ticks..::.GetSubWidth Method
Ticks Class See Also Send Feedback
Returns width of sub marks.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override double GetSubWidth()
Visual Basic (Declaration)
Protected Overrides Function GetSubWidth As Double
Visual C++
protected:
virtual double GetSubWidth() override

See Also

Ticks Class
PerpetuumSoft.Instrumentation.Model Namespace


GetWidth Method

[image]

.NET ModelKit Suite ClassReference
Ticks..::.GetWidth Method
Ticks Class See Also Send Feedback
Returns width of marks.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override double GetWidth()
Visual Basic (Declaration)
Protected Overrides Function GetWidth As Double
Visual C++
protected:
virtual double GetWidth() override

See Also

Ticks Class
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Ticks..::.Invalidate Method
Ticks Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Ticks Class
Ticks Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Ticks..::.OnPaint Method
Ticks Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from ScaleMarksBase.)

See Also

Ticks Class
Ticks Members
PerpetuumSoft.Instrumentation.Model Namespace


PaintMark Method

[image]

.NET ModelKit Suite ClassReference
Ticks..::.PaintMark Method
Ticks Class See Also Send Feedback
Paints marks.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void PaintMark(
    GraphicStream stream,
    double value,
    double length,
    Fill fill,
    double distance,
    Stroke stroke,
    bool useStroke
)
Visual Basic (Declaration)
Protected Overrides Sub PaintMark ( _
    stream As GraphicStream, _
    value As Double, _
    length As Double, _
    fill As Fill, _
    distance As Double, _
    stroke As Stroke, _
    useStroke As Boolean _
)
Visual C++
protected:
virtual void PaintMark(
    GraphicStream^ stream,
    double value,
    double length,
    Fill^ fill,
    double distance,
    Stroke^ stroke,
    bool useStroke
) override

Parameters

stream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
value
Type: System..::.Double
length
Type: System..::.Double
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
distance
Type: System..::.Double
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
useStroke
Type: System..::.Boolean

See Also

Ticks Class
PerpetuumSoft.Instrumentation.Model Namespace


PaintSubMark Method

[image]

.NET ModelKit Suite ClassReference
Ticks..::.PaintSubMark Method
Ticks Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.Ticks.PaintSubMark(PerpetuumSoft.Framework.Drawing.GraphicStream,System.Double,System.Double,PerpetuumSoft.Framework.Drawing.Fill,PerpetuumSoft.Framework.Drawing.Stroke,System.Boolean)]

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void PaintSubMark(
    GraphicStream stream,
    double startValue,
    double endValue,
    Fill fill,
    Stroke stroke,
    bool useStroke
)
Visual Basic (Declaration)
Protected Overrides Sub PaintSubMark ( _
    stream As GraphicStream, _
    startValue As Double, _
    endValue As Double, _
    fill As Fill, _
    stroke As Stroke, _
    useStroke As Boolean _
)
Visual C++
protected:
virtual void PaintSubMark(
    GraphicStream^ stream,
    double startValue,
    double endValue,
    Fill^ fill,
    Stroke^ stroke,
    bool useStroke
) override

Parameters

stream
Type: PerpetuumSoft.Framework.Drawing..::.GraphicStream
startValue
Type: System..::.Double
endValue
Type: System..::.Double
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke
useStroke
Type: System..::.Boolean

See Also

Ticks Class
PerpetuumSoft.Instrumentation.Model Namespace


Ticks Properties

[image] [image]

.NET ModelKit Suite ClassReference
Ticks Properties
Ticks Class See Also Send Feedback

The Ticks type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Divisions | Gets or sets divisions count. (Inherited from ScaleMarksBase.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets the Fill object that is used to paint over.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Length | Gets or sets ticks length.
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Step | Gets or sets interval between marks. (Inherited from ScaleMarksBase.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SubDivisions | Gets or sets sub divisions count. (Inherited from ScaleMarksBase.)
SubLength | Gets or sets length of the scale sub-ticks.
SubTicksPosition | Gets or sets the subticks position relative to the base trajectory. (Inherited from ScaleMarksBase.)
UseDescreteValues | Gets or sets value, indicating whether discrete values are used. (Inherited from ScaleMarksBase.)
UseRoundValues | Gets or sets value that indicates if the marks will correspond to round values. (Inherited from ScaleMarksBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Ticks Class
PerpetuumSoft.Instrumentation.Model Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
Ticks..::.Fill Property
Ticks Class See Also Send Feedback
Gets or sets the Fill object that is used to paint over.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

Ticks Class
PerpetuumSoft.Instrumentation.Model Namespace


Length Property

[image]

.NET ModelKit Suite ClassReference
Ticks..::.Length Property
Ticks Class See Also Send Feedback
Gets or sets ticks length.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Length { get; set; }
Visual Basic (Declaration)
Public Property Length As Double
Visual C++
public:
property double Length {
    double get ();
    void set (double value);
}

See Also

Ticks Class
PerpetuumSoft.Instrumentation.Model Namespace


SubLength Property

[image]

.NET ModelKit Suite ClassReference
Ticks..::.SubLength Property
Ticks Class See Also Send Feedback
Gets or sets length of the scale sub-ticks.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double SubLength { get; set; }
Visual Basic (Declaration)
Public Property SubLength As Double
Visual C++
public:
property double SubLength {
    double get ();
    void set (double value);
}

See Also

Ticks Class
PerpetuumSoft.Instrumentation.Model Namespace


Ticks Events

[image] [image]

.NET ModelKit Suite ClassReference
Ticks Events
Ticks Class See Also Send Feedback

The Ticks type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Ticks Class
PerpetuumSoft.Instrumentation.Model Namespace


TruncatedEllipse Class

[image]

.NET ModelKit Suite ClassReference
TruncatedEllipse Class
Members See Also Send Feedback
Represents the TruncaredEllipse.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class TruncatedEllipse : ArcBase
Visual Basic (Declaration)
Public Class TruncatedEllipse _
    Inherits ArcBase
Visual C++
public ref class TruncatedEllipse : public ArcBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement
PerpetuumSoft.Instrumentation.Model..::.RectangleElement
PerpetuumSoft.Instrumentation.Model..::.ArcBase
PerpetuumSoft.Instrumentation.Model..::.TruncatedEllipse

See Also

TruncatedEllipse Members
PerpetuumSoft.Instrumentation.Model Namespace


TruncatedEllipse Members

[image] [image]

.NET ModelKit Suite ClassReference
TruncatedEllipse Members
TruncatedEllipse Class Constructors Methods Properties Events See Also Send Feedback

The TruncatedEllipse type exposes the following members.

Constructors

Name | Description
TruncatedEllipse | Initializes a new instance of the TruncatedEllipse.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Draws the element content. (Overrides ArcBase..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides ArcBase..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartAngle | Gets or sets angle in degrees measured clockwise from the x-axis to the starting point of the arc. (Inherited from ArcBase.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SweepAngle | Gets or sets angle in degrees measured clockwise from the startAngle parameter to ending point of the arc. (Inherited from ArcBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

TruncatedEllipse Class
PerpetuumSoft.Instrumentation.Model Namespace


TruncatedEllipse Constructor

[image]

.NET ModelKit Suite ClassReference
TruncatedEllipse Constructor
TruncatedEllipse Class See Also Send Feedback
Initializes a new instance of the TruncatedEllipse.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public TruncatedEllipse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TruncatedEllipse()

See Also

TruncatedEllipse Class
PerpetuumSoft.Instrumentation.Model Namespace


TruncatedEllipse Methods

[image] [image]

.NET ModelKit Suite ClassReference
TruncatedEllipse Methods
TruncatedEllipse Class See Also Send Feedback

The TruncatedEllipse type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Draws the element content. (Overrides ArcBase..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Overrides ArcBase..::.GetHitTest(Vector).)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TruncatedEllipse Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
TruncatedEllipse..::.Dispose Method
TruncatedEllipse Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from RectangleElement.)

See Also

TruncatedEllipse Class
TruncatedEllipse Members
PerpetuumSoft.Instrumentation.Model Namespace


DrawContent Method

[image]

.NET ModelKit Suite ClassReference
TruncatedEllipse..::.DrawContent Method
TruncatedEllipse Class See Also Send Feedback
Draws the element content.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void DrawContent(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Protected Overrides Sub DrawContent ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
protected:
virtual void DrawContent(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

TruncatedEllipse Class
PerpetuumSoft.Instrumentation.Model Namespace


GetHitTest Method

[image]

.NET ModelKit Suite ClassReference
TruncatedEllipse..::.GetHitTest Method
TruncatedEllipse Class See Also Send Feedback
Overridden. See GetHitTest(Vector).

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool GetHitTest(
    Vector point
)
Visual Basic (Declaration)
Public Overrides Function GetHitTest ( _
    point As Vector _
) As Boolean
Visual C++
public:
virtual bool GetHitTest(
    Vector point
) override

Parameters

point
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

TruncatedEllipse Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
TruncatedEllipse..::.GetStyle Method
TruncatedEllipse Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

TruncatedEllipse Class
TruncatedEllipse Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
TruncatedEllipse..::.Invalidate Method
TruncatedEllipse Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

TruncatedEllipse Class
TruncatedEllipse Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
TruncatedEllipse..::.OnPaint Method
TruncatedEllipse Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from RectangleElement.)

See Also

TruncatedEllipse Class
TruncatedEllipse Members
PerpetuumSoft.Instrumentation.Model Namespace


TruncatedEllipse Properties

[image] [image]

.NET ModelKit Suite ClassReference
TruncatedEllipse Properties
TruncatedEllipse Class See Also Send Feedback

The TruncatedEllipse type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
StartAngle | Gets or sets angle in degrees measured clockwise from the x-axis to the starting point of the arc. (Inherited from ArcBase.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
SweepAngle | Gets or sets angle in degrees measured clockwise from the startAngle parameter to ending point of the arc. (Inherited from ArcBase.)
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

TruncatedEllipse Class
PerpetuumSoft.Instrumentation.Model Namespace


TruncatedEllipse Events

[image] [image]

.NET ModelKit Suite ClassReference
TruncatedEllipse Events
TruncatedEllipse Class See Also Send Feedback

The TruncatedEllipse type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

TruncatedEllipse Class
PerpetuumSoft.Instrumentation.Model Namespace


ValuePresenterScaleElement Class

[image]

.NET ModelKit Suite ClassReference
ValuePresenterScaleElement Class
Members See Also Send Feedback
Represents base class for scale elements, representing data value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract class ValuePresenterScaleElement : ScaleElement
Visual Basic (Declaration)
Public MustInherit Class ValuePresenterScaleElement _
    Inherits ScaleElement
Visual C++
public ref class ValuePresenterScaleElement abstract : public ScaleElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.ScaleElement
PerpetuumSoft.Instrumentation.Model..::.ValuePresenterScaleElement
PerpetuumSoft.Instrumentation.Model..::.LevelBase
PerpetuumSoft.Instrumentation.Model..::.Tank

See Also

ValuePresenterScaleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


ValuePresenterScaleElement Members

[image] [image]

.NET ModelKit Suite ClassReference
ValuePresenterScaleElement Members
ValuePresenterScaleElement Class Constructors Methods Properties Events See Also Send Feedback

The ValuePresenterScaleElement type exposes the following members.

Constructors

Name | Description
ValuePresenterScaleElement | Initializes a new instance of the ValuePresenterScaleElement class

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetMaxValue | Return maximim value from represented values.
GetMinValue | Returns minimum value from represented values.
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()(). (Inherited from ScaleElement.)
GetSmartValue | Returns value by SmartValue amd calculated value for the Auto case.
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Inherited from ScaleElement.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleElement.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Value | Gets or sets represented value.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ValuePresenterScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


ValuePresenterScaleElement Constructor

[image]

.NET ModelKit Suite ClassReference
ValuePresenterScaleElement Constructor
ValuePresenterScaleElement Class See Also Send Feedback
Initializes a new instance of the ValuePresenterScaleElement class

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected ValuePresenterScaleElement()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ValuePresenterScaleElement()

See Also

ValuePresenterScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


ValuePresenterScaleElement Methods

[image] [image]

.NET ModelKit Suite ClassReference
ValuePresenterScaleElement Methods
ValuePresenterScaleElement Class See Also Send Feedback

The ValuePresenterScaleElement type exposes the following members.

Methods

Name | Description
Calculate | (Inherited from ScaleElement.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from Element.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetColor | Returns the color by the given value. (Inherited from ScaleElement.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Returns the elements that are placed at the given point. (Inherited from Element.)
GetMaxValue | Return maximim value from represented values.
GetMinValue | Returns minimum value from represented values.
GetObject | Implements GetObject(String). (Inherited from Element.)
GetSize | Implements GetSize()()(). (Inherited from ScaleElement.)
GetSmartValue | Returns value by SmartValue amd calculated value for the Auto case.
GetStartValue | Returns start value. (Inherited from ScaleElement.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
IsPaint | Returns a value that shows whether it is needed to draw a scale element by the specified value on the scale. (Inherited from ScaleElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is called when the Parent property is changed. (Inherited from ScaleElement.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Is called when the Style property is changed. (Inherited from ScaleElement.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetMeasure | Implements ResetMeasure()()(). (Inherited from ScaleElement.)
SetStartDistance | Implements SetStartDistance(Double). (Inherited from ScaleElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValuePresenterScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ValuePresenterScaleElement..::.Dispose Method
ValuePresenterScaleElement Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Releases the unmanaged resources used by the Element and optionally releases the managed resources. (Inherited from Element.)

See Also

ValuePresenterScaleElement Class
ValuePresenterScaleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


GetMaxValue Method

[image]

.NET ModelKit Suite ClassReference
ValuePresenterScaleElement..::.GetMaxValue Method
ValuePresenterScaleElement Class See Also Send Feedback
Return maximim value from represented values.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected double GetMaxValue()
Visual Basic (Declaration)
Protected Function GetMaxValue As Double
Visual C++
protected:
double GetMaxValue()

See Also

ValuePresenterScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


GetMinValue Method

[image]

.NET ModelKit Suite ClassReference
ValuePresenterScaleElement..::.GetMinValue Method
ValuePresenterScaleElement Class See Also Send Feedback
Returns minimum value from represented values.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected double GetMinValue()
Visual Basic (Declaration)
Protected Function GetMinValue As Double
Visual C++
protected:
double GetMinValue()

See Also

ValuePresenterScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


GetSmartValue Method

[image]

.NET ModelKit Suite ClassReference
ValuePresenterScaleElement..::.GetSmartValue Method
ValuePresenterScaleElement Class See Also Send Feedback
Returns value by SmartValue amd calculated value for the Auto case.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected double GetSmartValue(
    SmartValue value,
    double autoValue
)
Visual Basic (Declaration)
Protected Function GetSmartValue ( _
    value As SmartValue, _
    autoValue As Double _
) As Double
Visual C++
protected:
double GetSmartValue(
    SmartValue value,
    double autoValue
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model..::.SmartValue
autoValue
Type: System..::.Double

See Also

ValuePresenterScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
ValuePresenterScaleElement..::.GetStyle Method
ValuePresenterScaleElement Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

ValuePresenterScaleElement Class
ValuePresenterScaleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ValuePresenterScaleElement..::.Invalidate Method
ValuePresenterScaleElement Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

ValuePresenterScaleElement Class
ValuePresenterScaleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
ValuePresenterScaleElement..::.OnPaint Method
ValuePresenterScaleElement Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Performs element's drawing with specific fill and stroke. (Inherited from Element.)

See Also

ValuePresenterScaleElement Class
ValuePresenterScaleElement Members
PerpetuumSoft.Instrumentation.Model Namespace


ValuePresenterScaleElement Properties

[image] [image]

.NET ModelKit Suite ClassReference
ValuePresenterScaleElement Properties
ValuePresenterScaleElement Class See Also Send Feedback

The ValuePresenterScaleElement type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Colorizer | Gets or sets Colorizer for element. (Inherited from ScaleElement.)
Distance | Gets or sets distance. (Inherited from ScaleElement.)
Dock | Implements Dock. (Inherited from ScaleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
MaxLimit | Gets or sets maximum value limit. (Inherited from ScaleElement.)
MinLimit | Gets or sets minimum value limit. (Inherited from ScaleElement.)
Name | Gets or sets the element's name. (Inherited from Element.)
Origin | Gets or sets scale start point that is used during scale elements allocation. (Inherited from ScaleElement.)
Padding | Implements Padding. (Inherited from ScaleElement.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Scale | Gets a scale where an element is located. (Inherited from ScaleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Value | Gets or sets represented value.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

ValuePresenterScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
ValuePresenterScaleElement..::.Value Property
ValuePresenterScaleElement Class See Also Send Feedback
Gets or sets represented value.

Namespace: PerpetuumSoft.Instrumentation.Model
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public SmartValue Value { get; set; }
Visual Basic (Declaration)
Public Property Value As SmartValue
Visual C++
public:
property SmartValue Value {
    SmartValue get ();
    void set (SmartValue value);
}

See Also

ValuePresenterScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


ValuePresenterScaleElement Events

[image] [image]

.NET ModelKit Suite ClassReference
ValuePresenterScaleElement Events
ValuePresenterScaleElement Class See Also Send Feedback

The ValuePresenterScaleElement type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

ValuePresenterScaleElement Class
PerpetuumSoft.Instrumentation.Model Namespace


PerpetuumSoft.Instrumentation.Model.Design Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Instrumentation.Model.Design Namespace
Send Feedback
The PerpetuumSoft.Instrumentation.Model.Design namespace contains classes that extend design time user interface for the Instrument creation and editing.

Enumerations

Enumeration | Description
PointType | Represents point types.


PointType Enumeration

[image]

.NET ModelKit Suite ClassReference
PointType Enumeration
See Also Send Feedback
Represents point types.

Namespace: PerpetuumSoft.Instrumentation.Model.Design
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public enum PointType
Visual Basic (Declaration)
Public Enumeration PointType
Visual C++
public enum class PointType

Members

Member name | Description
Free | Free point type.
Linked | Linked point type.
Frozen | Frozen point type.

See Also

PerpetuumSoft.Instrumentation.Model.Design Namespace


PerpetuumSoft.Instrumentation.Model.Drawing Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Instrumentation.Model.Drawing Namespace
Send Feedback
The PerpetuumSoft.Instrumentation.Model.Drawing namespace contains classes to visualize the Instrument and its elements.

Classes

Class | Description
Colorizer | Represents object using for scale coloring.
ColorSection | Represents color section.
ColorSectionCollection | Represents the collection of ColorSection objects.
SectionsColorizer | Represents colorizer section.
SingleColorColorizer | Represent single color for Colorizer.

Structures

Structure | Description
CornerRadiuses | Represents parameters for rectangles corner rounding.

Delegates

Delegate | Description
ColorSectionCollection..::.CollectionChangedEventHandler | Represents method which calls after collection changing.


Colorizer Class

[image]

.NET ModelKit Suite ClassReference
Colorizer Class
Members See Also Send Feedback
Represents object using for scale coloring.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract class Colorizer
Visual Basic (Declaration)
Public MustInherit Class Colorizer
Visual C++
public ref class Colorizer abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model.Drawing..::.Colorizer
PerpetuumSoft.Instrumentation.Model.Drawing..::.SectionsColorizer
PerpetuumSoft.Instrumentation.Model.Drawing..::.SingleColorColorizer

See Also

Colorizer Members
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Colorizer Members

[image] [image]

.NET ModelKit Suite ClassReference
Colorizer Members
Colorizer Class Constructors Methods See Also Send Feedback

The Colorizer type exposes the following members.

Constructors

Name | Description
Colorizer | Initializes a new instance of the Colorizer class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Returns color by the given value.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Colorizer Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Colorizer Constructor

[image]

.NET ModelKit Suite ClassReference
Colorizer Constructor
Colorizer Class See Also Send Feedback
Initializes a new instance of the Colorizer class

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected Colorizer()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
Colorizer()

See Also

Colorizer Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Colorizer Methods

[image] [image]

.NET ModelKit Suite ClassReference
Colorizer Methods
Colorizer Class See Also Send Feedback

The Colorizer type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Returns color by the given value.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Colorizer Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


GetColor Method

[image]

.NET ModelKit Suite ClassReference
Colorizer..::.GetColor Method
Colorizer Class See Also Send Feedback
Returns color by the given value.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public abstract Color GetColor(
    double portion
)
Visual Basic (Declaration)
Public MustOverride Function GetColor ( _
    portion As Double _
) As Color
Visual C++
public:
virtual Color GetColor(
    double portion
) abstract

Parameters

portion
Type: System..::.Double

See Also

Colorizer Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ColorSection Class

[image]

.NET ModelKit Suite ClassReference
ColorSection Class
Members See Also Send Feedback
Represents color section.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class ColorSection : ICloneable
Visual Basic (Declaration)
Public Class ColorSection _
    Implements ICloneable
Visual C++
public ref class ColorSection : ICloneable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model.Drawing..::.ColorSection

See Also

ColorSection Members
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ColorSection Members

[image] [image]

.NET ModelKit Suite ClassReference
ColorSection Members
ColorSection Class Constructors Methods Properties See Also Send Feedback

The ColorSection type exposes the following members.

Constructors

Name | Description
ColorSection | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
Color | Gets or sets the color of this section.
Portion | Gets or sets color section portion.

See Also

ColorSection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ColorSection Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ColorSection Constructor
ColorSection Class See Also Send Feedback

Overload List

Name | Description
ColorSection()()() | Initializes a new instance of the ColorSection class.
ColorSection(Color, Double) | Initializes a new instance of the ColorSection class.

See Also

ColorSection Class
ColorSection Members
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ColorSection Constructor

[image]

.NET ModelKit Suite ClassReference
ColorSection Constructor
ColorSection Class See Also Send Feedback
Initializes a new instance of the ColorSection class.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ColorSection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColorSection()

See Also

ColorSection Class
ColorSection Overload
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ColorSection Constructor (Color, Double)

[image]

.NET ModelKit Suite ClassReference
ColorSection Constructor (Color, Double)
ColorSection Class See Also Send Feedback
Initializes a new instance of the ColorSection class.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ColorSection(
    Color color,
    double portion
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color, _
    portion As Double _
)
Visual C++
public:
ColorSection(
    Color color,
    double portion
)

Parameters

color
Type: System.Drawing..::.Color
portion
Type: System..::.Double

See Also

ColorSection Class
ColorSection Overload
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ColorSection Methods

[image] [image]

.NET ModelKit Suite ClassReference
ColorSection Methods
ColorSection Class See Also Send Feedback

The ColorSection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

ColorSection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
ColorSection..::.ToString Method
ColorSection Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

ColorSection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ColorSection Properties

[image] [image]

.NET ModelKit Suite ClassReference
ColorSection Properties
ColorSection Class See Also Send Feedback

The ColorSection type exposes the following members.

Properties

Name | Description
Color | Gets or sets the color of this section.
Portion | Gets or sets color section portion.

See Also

ColorSection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Color Property

[image]

.NET ModelKit Suite ClassReference
ColorSection..::.Color Property
ColorSection Class See Also Send Feedback
Gets or sets the color of this section.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

ColorSection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Portion Property

[image]

.NET ModelKit Suite ClassReference
ColorSection..::.Portion Property
ColorSection Class See Also Send Feedback
Gets or sets color section portion.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Portion { get; set; }
Visual Basic (Declaration)
Public Property Portion As Double
Visual C++
public:
property double Portion {
    double get ();
    void set (double value);
}

See Also

ColorSection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ColorSectionCollection Class

[image]

.NET ModelKit Suite ClassReference
ColorSectionCollection Class
Members See Also Send Feedback
Represents the collection of ColorSection objects.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class ColorSectionCollection : CollectionBase
Visual Basic (Declaration)
Public Class ColorSectionCollection _
    Inherits CollectionBase
Visual C++
public ref class ColorSectionCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Instrumentation.Model.Drawing..::.ColorSectionCollection

See Also

ColorSectionCollection Members
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ColorSectionCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
ColorSectionCollection Members
ColorSectionCollection Class Constructors Methods Properties Events See Also Send Feedback

The ColorSectionCollection type exposes the following members.

Constructors

Name | Description
ColorSectionCollection | Initializes a new instance of the ColorSectionCollection class.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Add array of [T:PerpetuumSoft.Instrumentation.Model.Drawing.ColorSection} objects into collection.]
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Raise Insert event. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Raise InsertComplete event. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Raise RemoveComplete event. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Raise Validate event. (Overrides CollectionBase..::.OnValidate(Object).)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Implements Item[([(Int32])]).
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

Name | Description
CollectionChanged | Occurs after changed collection.

See Also

ColorSectionCollection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ColorSectionCollection Constructor

[image]

.NET ModelKit Suite ClassReference
ColorSectionCollection Constructor
ColorSectionCollection Class See Also Send Feedback
Initializes a new instance of the ColorSectionCollection class.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ColorSectionCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColorSectionCollection()

See Also

ColorSectionCollection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ColorSectionCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
ColorSectionCollection Methods
ColorSectionCollection Class See Also Send Feedback

The ColorSectionCollection type exposes the following members.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Add array of [T:PerpetuumSoft.Instrumentation.Model.Drawing.ColorSection} objects into collection.]
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Raise Insert event. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Raise InsertComplete event. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Raise RemoveComplete event. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Raise Validate event. (Overrides CollectionBase..::.OnValidate(Object).)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorSectionCollection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
ColorSectionCollection..::.Add Method
ColorSectionCollection Class See Also Send Feedback
Implements Add(Object).

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ColorSection Add(
    ColorSection value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As ColorSection _
) As ColorSection
Visual C++
public:
ColorSection^ Add(
    ColorSection^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model.Drawing..::.ColorSection

See Also

ColorSectionCollection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
ColorSectionCollection..::.AddRange Method
ColorSectionCollection Class See Also Send Feedback
Add array of [T:PerpetuumSoft.Instrumentation.Model.Drawing.ColorSection} objects into collection.]

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    ColorSection[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As ColorSection() _
)
Visual C++
public:
void AddRange(
    array<ColorSection^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Instrumentation.Model.Drawing..::.ColorSection >[]()[]

See Also

ColorSectionCollection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
ColorSectionCollection..::.Contains Method
ColorSectionCollection Class See Also Send Feedback
Implements Contains(Object).

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    ColorSection value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As ColorSection _
) As Boolean
Visual C++
public:
bool Contains(
    ColorSection^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model.Drawing..::.ColorSection

See Also

ColorSectionCollection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
ColorSectionCollection..::.IndexOf Method
ColorSectionCollection Class See Also Send Feedback
Implements IndexOf(Object).

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    ColorSection value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As ColorSection _
) As Integer
Visual C++
public:
int IndexOf(
    ColorSection^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model.Drawing..::.ColorSection

See Also

ColorSectionCollection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
ColorSectionCollection..::.Insert Method
ColorSectionCollection Class See Also Send Feedback
Implements Insert(Int32, Object).

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    ColorSection value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As ColorSection _
)
Visual C++
public:
void Insert(
    int index,
    ColorSection^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Instrumentation.Model.Drawing..::.ColorSection

See Also

ColorSectionCollection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


OnInsert Method

[image]

.NET ModelKit Suite ClassReference
ColorSectionCollection..::.OnInsert Method
ColorSectionCollection Class See Also Send Feedback
Raise Insert event.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsert(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsert ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsert(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ColorSectionCollection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


OnInsertComplete Method

[image]

.NET ModelKit Suite ClassReference
ColorSectionCollection..::.OnInsertComplete Method
ColorSectionCollection Class See Also Send Feedback
Raise InsertComplete event.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsertComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsertComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsertComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ColorSectionCollection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


OnRemoveComplete Method

[image]

.NET ModelKit Suite ClassReference
ColorSectionCollection..::.OnRemoveComplete Method
ColorSectionCollection Class See Also Send Feedback
Raise RemoveComplete event.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnRemoveComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemoveComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemoveComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ColorSectionCollection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


OnValidate Method

[image]

.NET ModelKit Suite ClassReference
ColorSectionCollection..::.OnValidate Method
ColorSectionCollection Class See Also Send Feedback
Raise Validate event.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnValidate(
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnValidate ( _
    value As Object _
)
Visual C++
protected:
virtual void OnValidate(
    Object^ value
) override

Parameters

value
Type: System..::.Object

See Also

ColorSectionCollection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
ColorSectionCollection..::.Remove Method
ColorSectionCollection Class See Also Send Feedback
Implements Remove(Object).

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    ColorSection value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As ColorSection _
)
Visual C++
public:
void Remove(
    ColorSection^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Model.Drawing..::.ColorSection

See Also

ColorSectionCollection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ColorSectionCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
ColorSectionCollection Properties
ColorSectionCollection Class See Also Send Feedback

The ColorSectionCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Implements Item[([(Int32])]).
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ColorSectionCollection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
ColorSectionCollection..::.Item Property
ColorSectionCollection Class See Also Send Feedback
Implements Item[([(Int32])]).

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ColorSection this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As ColorSection
Visual C++
public:
property ColorSection^ default[int index] {
    ColorSection^ get (int index);
    void set (int index, ColorSection^ value);
}

Parameters

index
Type: System..::.Int32

See Also

ColorSectionCollection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ColorSectionCollection Events

[image] [image]

.NET ModelKit Suite ClassReference
ColorSectionCollection Events
ColorSectionCollection Class See Also Send Feedback

The ColorSectionCollection type exposes the following members.

Events

Name | Description
CollectionChanged | Occurs after changed collection.

See Also

ColorSectionCollection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


CollectionChanged Event

[image]

.NET ModelKit Suite ClassReference
ColorSectionCollection..::.CollectionChanged Event
ColorSectionCollection Class See Also Send Feedback
Occurs after changed collection.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public event ColorSectionCollection..::.CollectionChangedEventHandler CollectionChanged
Visual Basic (Declaration)
Public Event CollectionChanged As ColorSectionCollection..::.CollectionChangedEventHandler
Visual C++
public:
 event ColorSectionCollection..::.CollectionChangedEventHandler^ CollectionChanged {
    void add (ColorSectionCollection..::.CollectionChangedEventHandler^ value);
    void remove (ColorSectionCollection..::.CollectionChangedEventHandler^ value);
}

See Also

ColorSectionCollection Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ColorSectionCollection.CollectionChangedEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
ColorSectionCollection..::.CollectionChangedEventHandler Delegate
ColorSectionCollection Class See Also Send Feedback
Represents method which calls after collection changing.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public delegate void CollectionChangedEventHandler(
    ColorSection colorSection
)
Visual Basic (Declaration)
Public Delegate Sub CollectionChangedEventHandler ( _
    colorSection As ColorSection _
)
Visual C++
public delegate void CollectionChangedEventHandler(
    ColorSection^ colorSection
)

Parameters

colorSection
Type: PerpetuumSoft.Instrumentation.Model.Drawing..::.ColorSection

See Also

PerpetuumSoft.Instrumentation.Model.Drawing Namespace


CornerRadiuses Structure

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses Structure
Members See Also Send Feedback
Represents parameters for rectangles corner rounding.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public struct CornerRadiuses : ICloneable
Visual Basic (Declaration)
Public Structure CornerRadiuses _
    Implements ICloneable
Visual C++
public value class CornerRadiuses : ICloneable

See Also

CornerRadiuses Members
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


CornerRadiuses Members

[image] [image]

.NET ModelKit Suite ClassReference
CornerRadiuses Members
CornerRadiuses Structure Constructors Methods Properties See Also Send Feedback

The CornerRadiuses type exposes the following members.

Constructors

Name | Description
CornerRadiuses | Initializes a new instance of the CornerRadiuses class.

Methods

Name | Description
Clone | Implements Clone()()().
ConvertUnits | Parses the specified string and returns an CornerRadiuses .
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse | Overloaded.
ToString | Overloaded.

Operators

Name | Description
Equality |
Inequality |

Properties

Name | Description
Empty | Gets CornerRadiuses which sets missing rounding radiuses for the corners.
IsEmpty | Gets a value showing that rounding radiuses are not set.
LeftBottom | Gets or sets rounding radius for the bottom right corner.
LeftTop | Gets or sets rounding radius for the top left corner.
RightBottom | Gets or sets rounding radius for the bottom left corner.
RightTop | Gets or sets rounding radius for the top right corner.

See Also

CornerRadiuses Structure
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


CornerRadiuses Constructor

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses Constructor
CornerRadiuses Structure See Also Send Feedback
Initializes a new instance of the CornerRadiuses class.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public CornerRadiuses(
    double leftBottom,
    double leftTop,
    double rightTop,
    double rightBottom
)
Visual Basic (Declaration)
Public Sub New ( _
    leftBottom As Double, _
    leftTop As Double, _
    rightTop As Double, _
    rightBottom As Double _
)
Visual C++
public:
CornerRadiuses(
    double leftBottom,
    double leftTop,
    double rightTop,
    double rightBottom
)

Parameters

leftBottom
Type: System..::.Double
leftTop
Type: System..::.Double
rightTop
Type: System..::.Double
rightBottom
Type: System..::.Double

See Also

CornerRadiuses Structure
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


CornerRadiuses Methods

[image] [image]

.NET ModelKit Suite ClassReference
CornerRadiuses Methods
CornerRadiuses Structure See Also Send Feedback

The CornerRadiuses type exposes the following members.

Methods

Name | Description
Clone | Implements Clone()()().
ConvertUnits | Parses the specified string and returns an CornerRadiuses .
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse | Overloaded.
ToString | Overloaded.

Operators

Name | Description
Equality |
Inequality |

See Also

CornerRadiuses Structure
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.Clone Method
CornerRadiuses Structure See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Implements

ICloneable..::.Clone()()()

See Also

CornerRadiuses Structure
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ConvertUnits Method

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.ConvertUnits Method
CornerRadiuses Structure See Also Send Feedback
Parses the specified string and returns an CornerRadiuses .

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public CornerRadiuses ConvertUnits(
    Unit fromUnit,
    Unit toUnit
)
Visual Basic (Declaration)
Public Function ConvertUnits ( _
    fromUnit As Unit, _
    toUnit As Unit _
) As CornerRadiuses
Visual C++
public:
CornerRadiuses ConvertUnits(
    Unit fromUnit,
    Unit toUnit
)

Parameters

fromUnit
Type: PerpetuumSoft.Framework.Drawing..::.Unit
toUnit
Type: PerpetuumSoft.Framework.Drawing..::.Unit

See Also

CornerRadiuses Structure
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Equality Operator

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.Equality Operator
CornerRadiuses Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.Drawing.CornerRadiuses.op_Equality(PerpetuumSoft.Instrumentation.Model.Drawing.CornerRadiuses,PerpetuumSoft.Instrumentation.Model.Drawing.CornerRadiuses)]

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static bool operator ==(
    CornerRadiuses r1,
    CornerRadiuses r2
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    r1 As CornerRadiuses, _
    r2 As CornerRadiuses _
) As Boolean
Visual C++
public:
static bool operator ==(
    CornerRadiuses r1,
    CornerRadiuses r2
)

Parameters

r1
Type: PerpetuumSoft.Instrumentation.Model.Drawing..::.CornerRadiuses
r2
Type: PerpetuumSoft.Instrumentation.Model.Drawing..::.CornerRadiuses

See Also

CornerRadiuses Structure
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.Equals Method
CornerRadiuses Structure See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

CornerRadiuses Structure
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.GetHashCode Method
CornerRadiuses Structure See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

CornerRadiuses Structure
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Inequality Operator

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.Inequality Operator
CornerRadiuses Structure See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.Drawing.CornerRadiuses.op_Inequality(PerpetuumSoft.Instrumentation.Model.Drawing.CornerRadiuses,PerpetuumSoft.Instrumentation.Model.Drawing.CornerRadiuses)]

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static bool operator !=(
    CornerRadiuses r1,
    CornerRadiuses r2
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    r1 As CornerRadiuses, _
    r2 As CornerRadiuses _
) As Boolean
Visual C++
public:
static bool operator !=(
    CornerRadiuses r1,
    CornerRadiuses r2
)

Parameters

r1
Type: PerpetuumSoft.Instrumentation.Model.Drawing..::.CornerRadiuses
r2
Type: PerpetuumSoft.Instrumentation.Model.Drawing..::.CornerRadiuses

See Also

CornerRadiuses Structure
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Parse Method

[image] [image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.Parse Method
CornerRadiuses Structure See Also Send Feedback

Overload List

Name | Description
Parse(String) | Parses the specified string and returns an CornerRadiuses .
Parse(String, NumberStyles) | Parses the specified string and returns an CornerRadiuses .
Parse(String, IFormatProvider) | Parses the specified string and returns an CornerRadiuses .
Parse(String, NumberStyles, IFormatProvider) | Parses the specified string and returns an CornerRadiuses .

See Also

CornerRadiuses Structure
CornerRadiuses Members
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Parse Method (String)

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.Parse Method (String)
CornerRadiuses Structure See Also Send Feedback
Parses the specified string and returns an CornerRadiuses .

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static CornerRadiuses Parse(
    string s
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    s As String _
) As CornerRadiuses
Visual C++
public:
static CornerRadiuses Parse(
    String^ s
)

Parameters

s
Type: System..::.String

See Also

CornerRadiuses Structure
Parse Overload
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Parse Method (String, NumberStyles)

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.Parse Method (String, NumberStyles)
CornerRadiuses Structure See Also Send Feedback
Parses the specified string and returns an CornerRadiuses .

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static CornerRadiuses Parse(
    string s,
    NumberStyles style
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    s As String, _
    style As NumberStyles _
) As CornerRadiuses
Visual C++
public:
static CornerRadiuses Parse(
    String^ s,
    NumberStyles style
)

Parameters

s
Type: System..::.String
style
Type: System.Globalization..::.NumberStyles

See Also

CornerRadiuses Structure
Parse Overload
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Parse Method (String, IFormatProvider)

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.Parse Method (String, IFormatProvider)
CornerRadiuses Structure See Also Send Feedback
Parses the specified string and returns an CornerRadiuses .

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static CornerRadiuses Parse(
    string s,
    IFormatProvider provider
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    s As String, _
    provider As IFormatProvider _
) As CornerRadiuses
Visual C++
public:
static CornerRadiuses Parse(
    String^ s,
    IFormatProvider^ provider
)

Parameters

s
Type: System..::.String
provider
Type: System..::.IFormatProvider

See Also

CornerRadiuses Structure
Parse Overload
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Parse Method (String, NumberStyles, IFormatProvider)

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.Parse Method (String, NumberStyles, IFormatProvider)
CornerRadiuses Structure See Also Send Feedback
Parses the specified string and returns an CornerRadiuses .

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static CornerRadiuses Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    s As String, _
    style As NumberStyles, _
    provider As IFormatProvider _
) As CornerRadiuses
Visual C++
public:
static CornerRadiuses Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)

Parameters

s
Type: System..::.String
style
Type: System.Globalization..::.NumberStyles
provider
Type: System..::.IFormatProvider

See Also

CornerRadiuses Structure
Parse Overload
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ToString Method

[image] [image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.ToString Method
CornerRadiuses Structure See Also Send Feedback

Overload List

Name | Description
ToString()()() | Overridden. See ToString()()(). (Overrides ValueType..::.ToString()()().)
ToString(IFormatProvider) | Overridden. See ToString(IFormatProvider).
ToString(String) | Overridden. See ToString(String).
ToString(String, IFormatProvider) | Overridden. See ToString(String, IFormatProvider).

See Also

CornerRadiuses Structure
CornerRadiuses Members
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.ToString Method
CornerRadiuses Structure See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

CornerRadiuses Structure
ToString Overload
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ToString Method (IFormatProvider)

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.ToString Method (IFormatProvider)
CornerRadiuses Structure See Also Send Feedback
Overridden. See ToString(IFormatProvider).

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string ToString(
    IFormatProvider provider
)
Visual Basic (Declaration)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
Visual C++
public:
String^ ToString(
    IFormatProvider^ provider
)

Parameters

provider
Type: System..::.IFormatProvider

See Also

CornerRadiuses Structure
ToString Overload
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ToString Method (String)

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.ToString Method (String)
CornerRadiuses Structure See Also Send Feedback
Overridden. See ToString(String).

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string ToString(
    string format
)
Visual Basic (Declaration)
Public Function ToString ( _
    format As String _
) As String
Visual C++
public:
String^ ToString(
    String^ format
)

Parameters

format
Type: System..::.String

See Also

CornerRadiuses Structure
ToString Overload
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ToString Method (String, IFormatProvider)

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.ToString Method (String, IFormatProvider)
CornerRadiuses Structure See Also Send Feedback
Overridden. See ToString(String, IFormatProvider).

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string ToString(
    string format,
    IFormatProvider provider
)
Visual Basic (Declaration)
Public Function ToString ( _
    format As String, _
    provider As IFormatProvider _
) As String
Visual C++
public:
String^ ToString(
    String^ format,
    IFormatProvider^ provider
)

Parameters

format
Type: System..::.String
provider
Type: System..::.IFormatProvider

See Also

CornerRadiuses Structure
ToString Overload
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


CornerRadiuses Properties

[image] [image]

.NET ModelKit Suite ClassReference
CornerRadiuses Properties
CornerRadiuses Structure See Also Send Feedback

The CornerRadiuses type exposes the following members.

Properties

Name | Description
Empty | Gets CornerRadiuses which sets missing rounding radiuses for the corners.
IsEmpty | Gets a value showing that rounding radiuses are not set.
LeftBottom | Gets or sets rounding radius for the bottom right corner.
LeftTop | Gets or sets rounding radius for the top left corner.
RightBottom | Gets or sets rounding radius for the bottom left corner.
RightTop | Gets or sets rounding radius for the top right corner.

See Also

CornerRadiuses Structure
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Empty Property

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.Empty Property
CornerRadiuses Structure See Also Send Feedback
Gets CornerRadiuses which sets missing rounding radiuses for the corners.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public static CornerRadiuses Empty { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Empty As CornerRadiuses
Visual C++
public:
static property CornerRadiuses Empty {
    CornerRadiuses get ();
}

See Also

CornerRadiuses Structure
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


IsEmpty Property

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.IsEmpty Property
CornerRadiuses Structure See Also Send Feedback
Gets a value showing that rounding radiuses are not set.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

CornerRadiuses Structure
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


LeftBottom Property

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.LeftBottom Property
CornerRadiuses Structure See Also Send Feedback
Gets or sets rounding radius for the bottom right corner.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double LeftBottom { get; set; }
Visual Basic (Declaration)
Public Property LeftBottom As Double
Visual C++
public:
property double LeftBottom {
    double get ();
    void set (double value);
}

See Also

CornerRadiuses Structure
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


LeftTop Property

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.LeftTop Property
CornerRadiuses Structure See Also Send Feedback
Gets or sets rounding radius for the top left corner.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double LeftTop { get; set; }
Visual Basic (Declaration)
Public Property LeftTop As Double
Visual C++
public:
property double LeftTop {
    double get ();
    void set (double value);
}

See Also

CornerRadiuses Structure
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


RightBottom Property

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.RightBottom Property
CornerRadiuses Structure See Also Send Feedback
Gets or sets rounding radius for the bottom left corner.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double RightBottom { get; set; }
Visual Basic (Declaration)
Public Property RightBottom As Double
Visual C++
public:
property double RightBottom {
    double get ();
    void set (double value);
}

See Also

CornerRadiuses Structure
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


RightTop Property

[image]

.NET ModelKit Suite ClassReference
CornerRadiuses..::.RightTop Property
CornerRadiuses Structure See Also Send Feedback
Gets or sets rounding radius for the top right corner.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double RightTop { get; set; }
Visual Basic (Declaration)
Public Property RightTop As Double
Visual C++
public:
property double RightTop {
    double get ();
    void set (double value);
}

See Also

CornerRadiuses Structure
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


SectionsColorizer Class

[image]

.NET ModelKit Suite ClassReference
SectionsColorizer Class
Members See Also Send Feedback
Represents colorizer section.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class SectionsColorizer : Colorizer
Visual Basic (Declaration)
Public Class SectionsColorizer _
    Inherits Colorizer
Visual C++
public ref class SectionsColorizer : public Colorizer

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model.Drawing..::.Colorizer
PerpetuumSoft.Instrumentation.Model.Drawing..::.SectionsColorizer

See Also

SectionsColorizer Members
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


SectionsColorizer Members

[image] [image]

.NET ModelKit Suite ClassReference
SectionsColorizer Members
SectionsColorizer Class Constructors Methods Properties See Also Send Feedback

The SectionsColorizer type exposes the following members.

Constructors

Name | Description
SectionsColorizer | Initializes a new instance of the SectionsColorizer class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Double). (Overrides Colorizer..::.GetColor(Double).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorSections | Gets ColorSectionCollection - a collection of the sections colors.

See Also

SectionsColorizer Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


SectionsColorizer Constructor

[image]

.NET ModelKit Suite ClassReference
SectionsColorizer Constructor
SectionsColorizer Class See Also Send Feedback
Initializes a new instance of the SectionsColorizer class.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public SectionsColorizer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SectionsColorizer()

See Also

SectionsColorizer Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


SectionsColorizer Methods

[image] [image]

.NET ModelKit Suite ClassReference
SectionsColorizer Methods
SectionsColorizer Class See Also Send Feedback

The SectionsColorizer type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Double). (Overrides Colorizer..::.GetColor(Double).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SectionsColorizer Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


GetColor Method

[image]

.NET ModelKit Suite ClassReference
SectionsColorizer..::.GetColor Method
SectionsColorizer Class See Also Send Feedback
Overridden. See GetColor(Double).

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Color GetColor(
    double portion
)
Visual Basic (Declaration)
Public Overrides Function GetColor ( _
    portion As Double _
) As Color
Visual C++
public:
virtual Color GetColor(
    double portion
) override

Parameters

portion
Type: System..::.Double

See Also

SectionsColorizer Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


SectionsColorizer Properties

[image] [image]

.NET ModelKit Suite ClassReference
SectionsColorizer Properties
SectionsColorizer Class See Also Send Feedback

The SectionsColorizer type exposes the following members.

Properties

Name | Description
ColorSections | Gets ColorSectionCollection - a collection of the sections colors.

See Also

SectionsColorizer Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


ColorSections Property

[image]

.NET ModelKit Suite ClassReference
SectionsColorizer..::.ColorSections Property
SectionsColorizer Class See Also Send Feedback
Gets ColorSectionCollection - a collection of the sections colors.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public ColorSectionCollection ColorSections { get; }
Visual Basic (Declaration)
Public ReadOnly Property ColorSections As ColorSectionCollection
Visual C++
public:
property ColorSectionCollection^ ColorSections {
    ColorSectionCollection^ get ();
}

See Also

SectionsColorizer Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


SingleColorColorizer Class

[image]

.NET ModelKit Suite ClassReference
SingleColorColorizer Class
Members See Also Send Feedback
Represent single color for Colorizer.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class SingleColorColorizer : Colorizer
Visual Basic (Declaration)
Public Class SingleColorColorizer _
    Inherits Colorizer
Visual C++
public ref class SingleColorColorizer : public Colorizer

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model.Drawing..::.Colorizer
PerpetuumSoft.Instrumentation.Model.Drawing..::.SingleColorColorizer

See Also

SingleColorColorizer Members
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


SingleColorColorizer Members

[image] [image]

.NET ModelKit Suite ClassReference
SingleColorColorizer Members
SingleColorColorizer Class Constructors Methods Properties See Also Send Feedback

The SingleColorColorizer type exposes the following members.

Constructors

Name | Description
SingleColorColorizer | Initializes a new instance of the SingleColorColorizer class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Double). (Overrides Colorizer..::.GetColor(Double).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Color | Gets or sets the color used for painting.

See Also

SingleColorColorizer Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


SingleColorColorizer Constructor

[image]

.NET ModelKit Suite ClassReference
SingleColorColorizer Constructor
SingleColorColorizer Class See Also Send Feedback
Initializes a new instance of the SingleColorColorizer class.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public SingleColorColorizer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SingleColorColorizer()

See Also

SingleColorColorizer Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


SingleColorColorizer Methods

[image] [image]

.NET ModelKit Suite ClassReference
SingleColorColorizer Methods
SingleColorColorizer Class See Also Send Feedback

The SingleColorColorizer type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColor | Overridden. See GetColor(Double). (Overrides Colorizer..::.GetColor(Double).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SingleColorColorizer Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


GetColor Method

[image]

.NET ModelKit Suite ClassReference
SingleColorColorizer..::.GetColor Method
SingleColorColorizer Class See Also Send Feedback
Overridden. See GetColor(Double).

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override Color GetColor(
    double portion
)
Visual Basic (Declaration)
Public Overrides Function GetColor ( _
    portion As Double _
) As Color
Visual C++
public:
virtual Color GetColor(
    double portion
) override

Parameters

portion
Type: System..::.Double

See Also

SingleColorColorizer Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


SingleColorColorizer Properties

[image] [image]

.NET ModelKit Suite ClassReference
SingleColorColorizer Properties
SingleColorColorizer Class See Also Send Feedback

The SingleColorColorizer type exposes the following members.

Properties

Name | Description
Color | Gets or sets the color used for painting.

See Also

SingleColorColorizer Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


Color Property

[image]

.NET ModelKit Suite ClassReference
SingleColorColorizer..::.Color Property
SingleColorColorizer Class See Also Send Feedback
Gets or sets the color used for painting.

Namespace: PerpetuumSoft.Instrumentation.Model.Drawing
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

SingleColorColorizer Class
PerpetuumSoft.Instrumentation.Model.Drawing Namespace


PerpetuumSoft.Instrumentation.Model.Specialized Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Instrumentation.Model.Specialized Namespace
Send Feedback
The PerpetuumSoft.Instrumentation.Model.Specialized namespace contains classes that represent the specialized elements of the Instrument.

Classes

Class | Description
DigitalText | Represents the text displayed with digital display effect.
Digits | Represents the Digits.
Odometer | Represents the Odometer.


DigitalText Class

[image]

.NET ModelKit Suite ClassReference
DigitalText Class
Members See Also Send Feedback
Represents the text displayed with digital display effect.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class DigitalText : RectangleElement
Visual Basic (Declaration)
Public Class DigitalText _
    Inherits RectangleElement
Visual C++
public ref class DigitalText : public RectangleElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement
PerpetuumSoft.Instrumentation.Model..::.RectangleElement
PerpetuumSoft.Instrumentation.Model.Specialized..::.DigitalText

See Also

DigitalText Members
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


DigitalText Members

[image] [image]

.NET ModelKit Suite ClassReference
DigitalText Members
DigitalText Class Constructors Methods Properties Events See Also Send Feedback

The DigitalText type exposes the following members.

Constructors

Name | Description
DigitalText | Initializes a new instance of the DigitalText class.

Methods

Name | Description
Calculate | (Overrides Element..::.Calculate()()().)
Dispose | Overloaded.
DrawContent | Draws the element content. (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from RectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetFont |
ShouldSerializeFont |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
ActiveColor | Gets or sets the color for the active display segments.
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
DigitalBackgroundVisible | Gets or sets a value showing if background should be displayed with the digital display effect.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets font used during the text display.
InactiveColor | Gets or sets the color for the inactive display segments.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
SegmentSize | Gets or sets the symbol segment size.
SegmentSpaces | Gets or sets space between segments.
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Text | Gets or sets the displayed text.
TextHorizontalOffset | Gets or sets the text horizontal offset.
TextVerticalOffset | Gets or sets the text vertical offset.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

DigitalText Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


DigitalText Constructor

[image]

.NET ModelKit Suite ClassReference
DigitalText Constructor
DigitalText Class See Also Send Feedback
Initializes a new instance of the DigitalText class.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public DigitalText()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DigitalText()

See Also

DigitalText Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


DigitalText Methods

[image] [image]

.NET ModelKit Suite ClassReference
DigitalText Methods
DigitalText Class See Also Send Feedback

The DigitalText type exposes the following members.

Methods

Name | Description
Calculate | (Overrides Element..::.Calculate()()().)
Dispose | Overloaded.
DrawContent | Draws the element content. (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from RectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ResetFont |
ShouldSerializeFont |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DigitalText Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Calculate Method

[image]

.NET ModelKit Suite ClassReference
DigitalText..::.Calculate Method
DigitalText Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.Specialized.DigitalText.Calculate]

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void Calculate()
Visual Basic (Declaration)
Protected Overrides Sub Calculate
Visual C++
protected:
virtual void Calculate() override

See Also

DigitalText Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
DigitalText..::.Dispose Method
DigitalText Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from RectangleElement.)

See Also

DigitalText Class
DigitalText Members
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


DrawContent Method

[image]

.NET ModelKit Suite ClassReference
DigitalText..::.DrawContent Method
DigitalText Class See Also Send Feedback
Draws the element content.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void DrawContent(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Protected Overrides Sub DrawContent ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
protected:
virtual void DrawContent(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

DigitalText Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
DigitalText..::.GetStyle Method
DigitalText Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

DigitalText Class
DigitalText Members
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
DigitalText..::.Invalidate Method
DigitalText Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

DigitalText Class
DigitalText Members
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
DigitalText..::.OnPaint Method
DigitalText Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from RectangleElement.)

See Also

DigitalText Class
DigitalText Members
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


ResetFont Method

[image]

.NET ModelKit Suite ClassReference
DigitalText..::.ResetFont Method
DigitalText Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.Specialized.DigitalText.ResetFont]

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void ResetFont()
Visual Basic (Declaration)
Public Sub ResetFont
Visual C++
public:
void ResetFont()

See Also

DigitalText Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


ShouldSerializeFont Method

[image]

.NET ModelKit Suite ClassReference
DigitalText..::.ShouldSerializeFont Method
DigitalText Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Model.Specialized.DigitalText.ShouldSerializeFont]

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool ShouldSerializeFont()
Visual Basic (Declaration)
Public Function ShouldSerializeFont As Boolean
Visual C++
public:
bool ShouldSerializeFont()

See Also

DigitalText Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


DigitalText Properties

[image] [image]

.NET ModelKit Suite ClassReference
DigitalText Properties
DigitalText Class See Also Send Feedback

The DigitalText type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
ActiveColor | Gets or sets the color for the active display segments.
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
DigitalBackgroundVisible | Gets or sets a value showing if background should be displayed with the digital display effect.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
Font | Gets or sets font used during the text display.
InactiveColor | Gets or sets the color for the inactive display segments.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
SegmentSize | Gets or sets the symbol segment size.
SegmentSpaces | Gets or sets space between segments.
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Text | Gets or sets the displayed text.
TextHorizontalOffset | Gets or sets the text horizontal offset.
TextVerticalOffset | Gets or sets the text vertical offset.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

DigitalText Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


ActiveColor Property

[image]

.NET ModelKit Suite ClassReference
DigitalText..::.ActiveColor Property
DigitalText Class See Also Send Feedback
Gets or sets the color for the active display segments.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Color ActiveColor { get; set; }
Visual Basic (Declaration)
Public Property ActiveColor As Color
Visual C++
public:
property Color ActiveColor {
    Color get ();
    void set (Color value);
}

See Also

DigitalText Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


DigitalBackgroundVisible Property

[image]

.NET ModelKit Suite ClassReference
DigitalText..::.DigitalBackgroundVisible Property
DigitalText Class See Also Send Feedback
Gets or sets a value showing if background should be displayed with the digital display effect.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool DigitalBackgroundVisible { get; set; }
Visual Basic (Declaration)
Public Property DigitalBackgroundVisible As Boolean
Visual C++
public:
property bool DigitalBackgroundVisible {
    bool get ();
    void set (bool value);
}

See Also

DigitalText Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Font Property

[image]

.NET ModelKit Suite ClassReference
DigitalText..::.Font Property
DigitalText Class See Also Send Feedback
Gets or sets font used during the text display.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public FontDescriptor Font { get; set; }
Visual Basic (Declaration)
Public Property Font As FontDescriptor
Visual C++
public:
property FontDescriptor^ Font {
    FontDescriptor^ get ();
    void set (FontDescriptor^ value);
}

See Also

DigitalText Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


InactiveColor Property

[image]

.NET ModelKit Suite ClassReference
DigitalText..::.InactiveColor Property
DigitalText Class See Also Send Feedback
Gets or sets the color for the inactive display segments.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Color InactiveColor { get; set; }
Visual Basic (Declaration)
Public Property InactiveColor As Color
Visual C++
public:
property Color InactiveColor {
    Color get ();
    void set (Color value);
}

See Also

DigitalText Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


SegmentSize Property

[image]

.NET ModelKit Suite ClassReference
DigitalText..::.SegmentSize Property
DigitalText Class See Also Send Feedback
Gets or sets the symbol segment size.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Vector SegmentSize { get; set; }
Visual Basic (Declaration)
Public Property SegmentSize As Vector
Visual C++
public:
property Vector SegmentSize {
    Vector get ();
    void set (Vector value);
}

See Also

DigitalText Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


SegmentSpaces Property

[image]

.NET ModelKit Suite ClassReference
DigitalText..::.SegmentSpaces Property
DigitalText Class See Also Send Feedback
Gets or sets space between segments.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Vector SegmentSpaces { get; set; }
Visual Basic (Declaration)
Public Property SegmentSpaces As Vector
Visual C++
public:
property Vector SegmentSpaces {
    Vector get ();
    void set (Vector value);
}

See Also

DigitalText Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Text Property

[image]

.NET ModelKit Suite ClassReference
DigitalText..::.Text Property
DigitalText Class See Also Send Feedback
Gets or sets the displayed text.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

DigitalText Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


TextHorizontalOffset Property

[image]

.NET ModelKit Suite ClassReference
DigitalText..::.TextHorizontalOffset Property
DigitalText Class See Also Send Feedback
Gets or sets the text horizontal offset.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int TextHorizontalOffset { get; set; }
Visual Basic (Declaration)
Public Property TextHorizontalOffset As Integer
Visual C++
public:
property int TextHorizontalOffset {
    int get ();
    void set (int value);
}

See Also

DigitalText Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


TextVerticalOffset Property

[image]

.NET ModelKit Suite ClassReference
DigitalText..::.TextVerticalOffset Property
DigitalText Class See Also Send Feedback
Gets or sets the text vertical offset.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int TextVerticalOffset { get; set; }
Visual Basic (Declaration)
Public Property TextVerticalOffset As Integer
Visual C++
public:
property int TextVerticalOffset {
    int get ();
    void set (int value);
}

See Also

DigitalText Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


DigitalText Events

[image] [image]

.NET ModelKit Suite ClassReference
DigitalText Events
DigitalText Class See Also Send Feedback

The DigitalText type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

DigitalText Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Digits Class

[image]

.NET ModelKit Suite ClassReference
Digits Class
Members See Also Send Feedback
Represents the Digits.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Digits : RectangleElement
Visual Basic (Declaration)
Public Class Digits _
    Inherits RectangleElement
Visual C++
public ref class Digits : public RectangleElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement
PerpetuumSoft.Instrumentation.Model..::.RectangleElement
PerpetuumSoft.Instrumentation.Model.Specialized..::.Digits

See Also

Digits Members
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Digits Members

[image] [image]

.NET ModelKit Suite ClassReference
Digits Members
Digits Class Constructors Methods Properties Events See Also Send Feedback

The Digits type exposes the following members.

Constructors

Name | Description
Digits | Initializes a new instance of the Digits class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from RectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
ActiveColor | Gets or sets digits active color.
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
DigitHeight | Gets or sets digits height.
DigitSpace | Gets or sets digit space.
DigitWidth | Gets or sets digit width.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
InactiveColor | Gets or sets digits inactive color.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
SegmentSpace | Gets or sets digit segment space.
SegmentThickness | Gets or sets segment thickness.
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Text | Gets or sets digits text.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Digits Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Digits Constructor

[image]

.NET ModelKit Suite ClassReference
Digits Constructor
Digits Class See Also Send Feedback
Initializes a new instance of the Digits class.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Digits()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Digits()

See Also

Digits Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Digits Methods

[image] [image]

.NET ModelKit Suite ClassReference
Digits Methods
Digits Class See Also Send Feedback

The Digits type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from RectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Digits Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Digits..::.Dispose Method
Digits Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from RectangleElement.)

See Also

Digits Class
Digits Members
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


DrawContent Method

[image]

.NET ModelKit Suite ClassReference
Digits..::.DrawContent Method
Digits Class See Also Send Feedback
Overridden. See DrawContent(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void DrawContent(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Protected Overrides Sub DrawContent ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
protected:
virtual void DrawContent(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Digits Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Digits..::.GetStyle Method
Digits Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Digits Class
Digits Members
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Digits..::.Invalidate Method
Digits Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Digits Class
Digits Members
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Digits..::.OnPaint Method
Digits Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from RectangleElement.)

See Also

Digits Class
Digits Members
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Digits Properties

[image] [image]

.NET ModelKit Suite ClassReference
Digits Properties
Digits Class See Also Send Feedback

The Digits type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
ActiveColor | Gets or sets digits active color.
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
DigitHeight | Gets or sets digits height.
DigitSpace | Gets or sets digit space.
DigitWidth | Gets or sets digit width.
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
InactiveColor | Gets or sets digits inactive color.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
SegmentSpace | Gets or sets digit segment space.
SegmentThickness | Gets or sets segment thickness.
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Text | Gets or sets digits text.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Digits Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


ActiveColor Property

[image]

.NET ModelKit Suite ClassReference
Digits..::.ActiveColor Property
Digits Class See Also Send Feedback
Gets or sets digits active color.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Color ActiveColor { get; set; }
Visual Basic (Declaration)
Public Property ActiveColor As Color
Visual C++
public:
property Color ActiveColor {
    Color get ();
    void set (Color value);
}

See Also

Digits Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


DigitHeight Property

[image]

.NET ModelKit Suite ClassReference
Digits..::.DigitHeight Property
Digits Class See Also Send Feedback
Gets or sets digits height.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int DigitHeight { get; set; }
Visual Basic (Declaration)
Public Property DigitHeight As Integer
Visual C++
public:
property int DigitHeight {
    int get ();
    void set (int value);
}

See Also

Digits Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


DigitSpace Property

[image]

.NET ModelKit Suite ClassReference
Digits..::.DigitSpace Property
Digits Class See Also Send Feedback
Gets or sets digit space.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int DigitSpace { get; set; }
Visual Basic (Declaration)
Public Property DigitSpace As Integer
Visual C++
public:
property int DigitSpace {
    int get ();
    void set (int value);
}

See Also

Digits Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


DigitWidth Property

[image]

.NET ModelKit Suite ClassReference
Digits..::.DigitWidth Property
Digits Class See Also Send Feedback
Gets or sets digit width.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int DigitWidth { get; set; }
Visual Basic (Declaration)
Public Property DigitWidth As Integer
Visual C++
public:
property int DigitWidth {
    int get ();
    void set (int value);
}

See Also

Digits Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


InactiveColor Property

[image]

.NET ModelKit Suite ClassReference
Digits..::.InactiveColor Property
Digits Class See Also Send Feedback
Gets or sets digits inactive color.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Color InactiveColor { get; set; }
Visual Basic (Declaration)
Public Property InactiveColor As Color
Visual C++
public:
property Color InactiveColor {
    Color get ();
    void set (Color value);
}

See Also

Digits Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


SegmentSpace Property

[image]

.NET ModelKit Suite ClassReference
Digits..::.SegmentSpace Property
Digits Class See Also Send Feedback
Gets or sets digit segment space.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int SegmentSpace { get; set; }
Visual Basic (Declaration)
Public Property SegmentSpace As Integer
Visual C++
public:
property int SegmentSpace {
    int get ();
    void set (int value);
}

See Also

Digits Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


SegmentThickness Property

[image]

.NET ModelKit Suite ClassReference
Digits..::.SegmentThickness Property
Digits Class See Also Send Feedback
Gets or sets segment thickness.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int SegmentThickness { get; set; }
Visual Basic (Declaration)
Public Property SegmentThickness As Integer
Visual C++
public:
property int SegmentThickness {
    int get ();
    void set (int value);
}

See Also

Digits Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Text Property

[image]

.NET ModelKit Suite ClassReference
Digits..::.Text Property
Digits Class See Also Send Feedback
Gets or sets digits text.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

Digits Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Digits Events

[image] [image]

.NET ModelKit Suite ClassReference
Digits Events
Digits Class See Also Send Feedback

The Digits type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Digits Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Odometer Class

[image]

.NET ModelKit Suite ClassReference
Odometer Class
Members See Also Send Feedback
Represents the Odometer.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Odometer : RectangleElement
Visual Basic (Declaration)
Public Class Odometer _
    Inherits RectangleElement
Visual C++
public ref class Odometer : public RectangleElement

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Model..::.Element
PerpetuumSoft.Instrumentation.Model..::.SimpleRectangleElement
PerpetuumSoft.Instrumentation.Model..::.RectangleElement
PerpetuumSoft.Instrumentation.Model.Specialized..::.Odometer

See Also

Odometer Members
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Odometer Members

[image] [image]

.NET ModelKit Suite ClassReference
Odometer Members
Odometer Class Constructors Methods Properties Events See Also Send Feedback

The Odometer type exposes the following members.

Constructors

Name | Description
Odometer | Initializes a new instance of the Odometer class.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from RectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
BackFill | Gets or sets back Fill for dodmeter element.
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
FirstDigitBackFill | Gets or sets back Fill for first odometer element digit.
FirstDigitForeFill | Gets or sets fore Fill fo first odometer element digit.
Font | Gets or sets font that is used for the text display.
ForeFill | Gets or sets fore Fill for ododmeter element.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Value | Gets or sets odometer value.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Odometer Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Odometer Constructor

[image]

.NET ModelKit Suite ClassReference
Odometer Constructor
Odometer Class See Also Send Feedback
Initializes a new instance of the Odometer class.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Odometer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Odometer()

See Also

Odometer Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Odometer Methods

[image] [image]

.NET ModelKit Suite ClassReference
Odometer Methods
Odometer Class See Also Send Feedback

The Odometer type exposes the following members.

Methods

Name | Description
Calculate | Calculates the expressions and sets the result to the corresponded properties. (Inherited from Element.)
Dispose | Overloaded.
DrawContent | Overridden. See DrawContent(PaintArguments, Fill, Stroke). (Overrides RectangleElement..::.DrawContent(PaintArguments, Fill, Stroke).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Overridden. Releases unmanaged resources and performs other cleanup operations before the Element is reclaimed by garbage collection. (Inherited from Element.)
GetBoundedBox | Implements GetBoundedBox()()(). (Inherited from RectangleElement.)
GetByName | Returns the element by the name. (Inherited from Element.)
GetElementAt | Implements GetElementAt(Vector). (Inherited from Element.)
GetFunction | Implements GetFunction(String). (Inherited from Element.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHitTest | Overridden. See GetHitTest(Vector). (Inherited from RectangleElement.)
GetObject | Implements GetObject(String). (Inherited from Element.)
GetStyle | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
Invalidate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBoundsChanged | This method is called when bounds are changed. (Inherited from RectangleElement.)
OnFillChanged | Executes if the fill was changed. (Inherited from Element.)
OnMouseDown | Raises the MouseDown event. (Inherited from Element.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Element.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Element.)
OnMouseMove | Raises the MouseMove event. (Inherited from Element.)
OnMouseUp | Raises the MouseUp event. (Inherited from Element.)
OnPaint | Overloaded.
OnParentChanged | Is executed if the parent was changed. (Inherited from Element.)
OnStrokeChanged | Is executeв if the stroke was changed. (Inherited from Element.)
OnStyleChanged | Executes if the style was changed. (Inherited from Element.)
OnVisibleChanged | Is executed if the visibility was changed. (Inherited from Element.)
Paint | Implements Paint(PaintArguments). (Inherited from Element.)
Recalculate | Recalculates the expressions. (Inherited from Element.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Odometer Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Odometer..::.Dispose Method
Odometer Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Element. (Inherited from Element.)
Dispose(Boolean) | Overridden. See Dispose(Boolean). (Inherited from RectangleElement.)

See Also

Odometer Class
Odometer Members
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


DrawContent Method

[image]

.NET ModelKit Suite ClassReference
Odometer..::.DrawContent Method
Odometer Class See Also Send Feedback
Overridden. See DrawContent(PaintArguments, Fill, Stroke).

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void DrawContent(
    PaintArguments args,
    Fill fill,
    Stroke stroke
)
Visual Basic (Declaration)
Protected Overrides Sub DrawContent ( _
    args As PaintArguments, _
    fill As Fill, _
    stroke As Stroke _
)
Visual C++
protected:
virtual void DrawContent(
    PaintArguments^ args,
    Fill^ fill,
    Stroke^ stroke
) override

Parameters

args
Type: PerpetuumSoft.Framework.Model..::.PaintArguments
fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
stroke
Type: PerpetuumSoft.Framework.Drawing..::.Stroke

See Also

Odometer Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


GetStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
Odometer..::.GetStyle Method
Odometer Class See Also Send Feedback

Overload List

Name | Description
GetStyle()()() | Returns the style by name. (Inherited from Element.)
GetStyle(String) | Returns the style by the name. (Inherited from Element.)

See Also

Odometer Class
Odometer Members
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Odometer..::.Invalidate Method
Odometer Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Implements Invalidate()()(). (Inherited from Element.)
Invalidate(VectorRectangle) | Implements Invalidate(VectorRectangle). (Inherited from Element.)

See Also

Odometer Class
Odometer Members
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


OnPaint Method

[image] [image]

.NET ModelKit Suite ClassReference
Odometer..::.OnPaint Method
Odometer Class See Also Send Feedback

Overload List

Name | Description
OnPaint(PaintArguments) | Performs element drawing. (Inherited from Element.)
OnPaint(PaintArguments, Fill, Stroke) | Overridden. See OnPaint(PaintArguments, Fill, Stroke). (Inherited from RectangleElement.)

See Also

Odometer Class
Odometer Members
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Odometer Properties

[image] [image]

.NET ModelKit Suite ClassReference
Odometer Properties
Odometer Class See Also Send Feedback

The Odometer type exposes the following members.

Properties

Name | Description
Active | Gets or sets value that indicates whether events will be passed to this element. (Inherited from Element.)
Angle | Angle in degrees measured clockwise from the x-axis of the rectangle. (Inherited from RectangleElement.)
BackFill | Gets or sets back Fill for dodmeter element.
Bounds | Bound of the rectangle. (Inherited from SimpleRectangleElement.)
BreakEventsBubbling | Gets or sets value that indicates whether events will be passed to parent. (Inherited from Element.)
Center | Gets or sets the center of the rectangle. (Inherited from SimpleRectangleElement.)
Expressions | Gets ExpressionBindingCollection expressions that are used by this element. (Inherited from Element.)
Fill | Gets or sets Fill object that is used to paint over. (Inherited from Element.)
FirstDigitBackFill | Gets or sets back Fill for first odometer element digit.
FirstDigitForeFill | Gets or sets fore Fill fo first odometer element digit.
Font | Gets or sets font that is used for the text display.
ForeFill | Gets or sets fore Fill for ododmeter element.
Instrument | Gets Instrument, which contains this element. (Inherited from Element.)
Name | Gets or sets the element's name. (Inherited from Element.)
Parent | Implements Parent. (Inherited from Element.)
RecalculateAll | Gets or sets value that indicates whether expressions will be recalculate for all elemnts or for of these elements only. (Inherited from Element.)
Size | Gets or sets size of the rectangle. (Inherited from SimpleRectangleElement.)
Smooth | Gets or sets value that indicates whether smooth will be used. (Inherited from Element.)
Stroke | Gets or sets Stroke object that is used to trace. (Inherited from Element.)
Style | Gets or sets the name of the used style. (Inherited from Element.)
Value | Gets or sets odometer value.
Visible | Gets or sets a value indicating whether the element is displayed. (Inherited from Element.)

See Also

Odometer Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


BackFill Property

[image]

.NET ModelKit Suite ClassReference
Odometer..::.BackFill Property
Odometer Class See Also Send Feedback
Gets or sets back Fill for dodmeter element.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Fill BackFill { get; set; }
Visual Basic (Declaration)
Public Property BackFill As Fill
Visual C++
public:
property Fill^ BackFill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

Odometer Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


FirstDigitBackFill Property

[image]

.NET ModelKit Suite ClassReference
Odometer..::.FirstDigitBackFill Property
Odometer Class See Also Send Feedback
Gets or sets back Fill for first odometer element digit.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Fill FirstDigitBackFill { get; set; }
Visual Basic (Declaration)
Public Property FirstDigitBackFill As Fill
Visual C++
public:
property Fill^ FirstDigitBackFill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

Odometer Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


FirstDigitForeFill Property

[image]

.NET ModelKit Suite ClassReference
Odometer..::.FirstDigitForeFill Property
Odometer Class See Also Send Feedback
Gets or sets fore Fill fo first odometer element digit.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Fill FirstDigitForeFill { get; set; }
Visual Basic (Declaration)
Public Property FirstDigitForeFill As Fill
Visual C++
public:
property Fill^ FirstDigitForeFill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

Odometer Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Font Property

[image]

.NET ModelKit Suite ClassReference
Odometer..::.Font Property
Odometer Class See Also Send Feedback
Gets or sets font that is used for the text display.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public FontDescriptor Font { get; set; }
Visual Basic (Declaration)
Public Property Font As FontDescriptor
Visual C++
public:
property FontDescriptor^ Font {
    FontDescriptor^ get ();
    void set (FontDescriptor^ value);
}

See Also

Odometer Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


ForeFill Property

[image]

.NET ModelKit Suite ClassReference
Odometer..::.ForeFill Property
Odometer Class See Also Send Feedback
Gets or sets fore Fill for ododmeter element.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Fill ForeFill { get; set; }
Visual Basic (Declaration)
Public Property ForeFill As Fill
Visual C++
public:
property Fill^ ForeFill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

Odometer Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
Odometer..::.Value Property
Odometer Class See Also Send Feedback
Gets or sets odometer value.

Namespace: PerpetuumSoft.Instrumentation.Model.Specialized
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Double
Visual C++
public:
property double Value {
    double get ();
    void set (double value);
}

See Also

Odometer Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


Odometer Events

[image] [image]

.NET ModelKit Suite ClassReference
Odometer Events
Odometer Class See Also Send Feedback

The Odometer type exposes the following members.

Events

Name | Description
MouseDown | Occurs when the mouse pointer is over the element and a mouse button is pressed. (Inherited from Element.)
MouseEnter | Occurs when the mouse pointer enters the element. (Inherited from Element.)
MouseLeave | Occurs when the mouse pointer leaves the element. (Inherited from Element.)
MouseMove | Occurs when the mouse pointer is moved over the element. (Inherited from Element.)
MouseUp | Occurs when the mouse pointer is over the element and a mouse button is released. (Inherited from Element.)

See Also

Odometer Class
PerpetuumSoft.Instrumentation.Model.Specialized Namespace


PerpetuumSoft.Instrumentation.Styles Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Instrumentation.Styles Namespace
Send Feedback
The PerpetuumSoft.Instrumentation.Styles namespace contains classes which are used to assign visual styles to the Instrument.

Classes

Class | Description
Style | Represent style.
StyleCollection | Represent collection of ['T:PerpetuumSoft.Instrumentation.Styles.Style] objects.

Delegates

Delegate | Description
StyleCollection..::.CollectionChanged | Represents method wich called after changing collection.


Style Class

[image]

.NET ModelKit Suite ClassReference
Style Class
Members See Also Send Feedback
Represent style.

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Style : ICloneable
Visual Basic (Declaration)
Public Class Style _
    Implements ICloneable
Visual C++
public ref class Style : ICloneable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Styles..::.Style

See Also

Style Members
PerpetuumSoft.Instrumentation.Styles Namespace


Style Members

[image] [image]

.NET ModelKit Suite ClassReference
Style Members
Style Class Constructors Methods Properties See Also Send Feedback

The Style type exposes the following members.

Constructors

Name | Description
Style | Initializes a new instance of the Style class.

Methods

Name | Description
Clone |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over.
Font | Gets or sets FontDescriptor for the style.
Image | Gets or sets Image object for the style.
Name | Gets or sets style name.
Stroke | Gets or sets Stroke object that is used to trace.

See Also

Style Class
PerpetuumSoft.Instrumentation.Styles Namespace


Style Constructor

[image]

.NET ModelKit Suite ClassReference
Style Constructor
Style Class See Also Send Feedback
Initializes a new instance of the Style class.

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Style()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Style()

See Also

Style Class
PerpetuumSoft.Instrumentation.Styles Namespace


Style Methods

[image] [image]

.NET ModelKit Suite ClassReference
Style Methods
Style Class See Also Send Feedback

The Style type exposes the following members.

Methods

Name | Description
Clone |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

See Also

Style Class
PerpetuumSoft.Instrumentation.Styles Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
Style..::.Clone Method
Style Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Styles.Style.Clone]

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Implements

ICloneable..::.Clone()()()

See Also

Style Class
PerpetuumSoft.Instrumentation.Styles Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
Style..::.ToString Method
Style Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Styles.Style.ToString]

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Style Class
PerpetuumSoft.Instrumentation.Styles Namespace


Style Properties

[image] [image]

.NET ModelKit Suite ClassReference
Style Properties
Style Class See Also Send Feedback

The Style type exposes the following members.

Properties

Name | Description
Fill | Gets or sets Fill object that is used to paint over.
Font | Gets or sets FontDescriptor for the style.
Image | Gets or sets Image object for the style.
Name | Gets or sets style name.
Stroke | Gets or sets Stroke object that is used to trace.

See Also

Style Class
PerpetuumSoft.Instrumentation.Styles Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
Style..::.Fill Property
Style Class See Also Send Feedback
Gets or sets Fill object that is used to paint over.

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

Style Class
PerpetuumSoft.Instrumentation.Styles Namespace


Font Property

[image]

.NET ModelKit Suite ClassReference
Style..::.Font Property
Style Class See Also Send Feedback
Gets or sets FontDescriptor for the style.

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public FontDescriptor Font { get; set; }
Visual Basic (Declaration)
Public Property Font As FontDescriptor
Visual C++
public:
property FontDescriptor^ Font {
    FontDescriptor^ get ();
    void set (FontDescriptor^ value);
}

See Also

Style Class
PerpetuumSoft.Instrumentation.Styles Namespace


Image Property

[image]

.NET ModelKit Suite ClassReference
Style..::.Image Property
Style Class See Also Send Feedback
Gets or sets Image object for the style.

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Image Image { get; set; }
Visual Basic (Declaration)
Public Property Image As Image
Visual C++
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}

See Also

Style Class
PerpetuumSoft.Instrumentation.Styles Namespace


Name Property

[image]

.NET ModelKit Suite ClassReference
Style..::.Name Property
Style Class See Also Send Feedback
Gets or sets style name.

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Style Class
PerpetuumSoft.Instrumentation.Styles Namespace


Stroke Property

[image]

.NET ModelKit Suite ClassReference
Style..::.Stroke Property
Style Class See Also Send Feedback
Gets or sets Stroke object that is used to trace.

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Stroke Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Stroke
Visual C++
public:
property Stroke^ Stroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

Style Class
PerpetuumSoft.Instrumentation.Styles Namespace


StyleCollection Class

[image]

.NET ModelKit Suite ClassReference
StyleCollection Class
Members See Also Send Feedback
Represent collection of ['T:PerpetuumSoft.Instrumentation.Styles.Style] objects.

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class StyleCollection : CollectionBase
Visual Basic (Declaration)
Public Class StyleCollection _
    Inherits CollectionBase
Visual C++
public ref class StyleCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Instrumentation.Styles..::.StyleCollection

See Also

StyleCollection Members
PerpetuumSoft.Instrumentation.Styles Namespace


StyleCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
StyleCollection Members
StyleCollection Class Constructors Methods Properties Events See Also Send Feedback

The StyleCollection type exposes the following members.

Constructors

Name | Description
StyleCollection | Initializes a new instance of the StyleCollection class.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Add array of Style objects into collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Raise Insert event. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Raise InsertComplete event. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Raise RemoveComplete event. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Raise Validate event. (Overrides CollectionBase..::.OnValidate(Object).)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

Name | Description
StyleAdded | Occurs after added style.
StyleRemoved | Occurs after removed style.

See Also

StyleCollection Class
PerpetuumSoft.Instrumentation.Styles Namespace


StyleCollection Constructor

[image]

.NET ModelKit Suite ClassReference
StyleCollection Constructor
StyleCollection Class See Also Send Feedback
Initializes a new instance of the StyleCollection class.

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public StyleCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StyleCollection()

See Also

StyleCollection Class
PerpetuumSoft.Instrumentation.Styles Namespace


StyleCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
StyleCollection Methods
StyleCollection Class See Also Send Feedback

The StyleCollection type exposes the following members.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Add array of Style objects into collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Raise Insert event. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Raise InsertComplete event. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Raise RemoveComplete event. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Raise Validate event. (Overrides CollectionBase..::.OnValidate(Object).)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StyleCollection Class
PerpetuumSoft.Instrumentation.Styles Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.Add Method
StyleCollection Class See Also Send Feedback
Implements Add(Object).

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Style Add(
    Style value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As Style _
) As Style
Visual C++
public:
Style^ Add(
    Style^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Styles..::.Style

See Also

StyleCollection Class
PerpetuumSoft.Instrumentation.Styles Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.AddRange Method
StyleCollection Class See Also Send Feedback
Add array of Style objects into collection.

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    Style[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As Style() _
)
Visual C++
public:
void AddRange(
    array<Style^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Instrumentation.Styles..::.Style >[]()[]

See Also

StyleCollection Class
PerpetuumSoft.Instrumentation.Styles Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.Contains Method
StyleCollection Class See Also Send Feedback
Implements Contains(Object).

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    Style value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As Style _
) As Boolean
Visual C++
public:
bool Contains(
    Style^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Styles..::.Style

See Also

StyleCollection Class
PerpetuumSoft.Instrumentation.Styles Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.IndexOf Method
StyleCollection Class See Also Send Feedback
Implements IndexOf(Object).

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    Style value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As Style _
) As Integer
Visual C++
public:
int IndexOf(
    Style^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Styles..::.Style

See Also

StyleCollection Class
PerpetuumSoft.Instrumentation.Styles Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.Insert Method
StyleCollection Class See Also Send Feedback
Implements Insert(Int32, Object).

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    Style value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As Style _
)
Visual C++
public:
void Insert(
    int index,
    Style^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Instrumentation.Styles..::.Style

See Also

StyleCollection Class
PerpetuumSoft.Instrumentation.Styles Namespace


OnInsert Method

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.OnInsert Method
StyleCollection Class See Also Send Feedback
Raise Insert event.

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsert(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsert ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsert(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

StyleCollection Class
PerpetuumSoft.Instrumentation.Styles Namespace


OnInsertComplete Method

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.OnInsertComplete Method
StyleCollection Class See Also Send Feedback
Raise InsertComplete event.

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsertComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsertComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsertComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

StyleCollection Class
PerpetuumSoft.Instrumentation.Styles Namespace


OnRemoveComplete Method

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.OnRemoveComplete Method
StyleCollection Class See Also Send Feedback
Raise RemoveComplete event.

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnRemoveComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemoveComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemoveComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

StyleCollection Class
PerpetuumSoft.Instrumentation.Styles Namespace


OnValidate Method

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.OnValidate Method
StyleCollection Class See Also Send Feedback
Raise Validate event.

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnValidate(
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnValidate ( _
    value As Object _
)
Visual C++
protected:
virtual void OnValidate(
    Object^ value
) override

Parameters

value
Type: System..::.Object

See Also

StyleCollection Class
PerpetuumSoft.Instrumentation.Styles Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.Remove Method
StyleCollection Class See Also Send Feedback
Implements Remove(Object).

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    Style value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As Style _
)
Visual C++
public:
void Remove(
    Style^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Styles..::.Style

See Also

StyleCollection Class
PerpetuumSoft.Instrumentation.Styles Namespace


StyleCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
StyleCollection Properties
StyleCollection Class See Also Send Feedback

The StyleCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

StyleCollection Class
PerpetuumSoft.Instrumentation.Styles Namespace


Item Property

[image] [image]

.NET ModelKit Suite ClassReference
StyleCollection..::.Item Property
StyleCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Implements Item[([(Int32])]).
Item[([(String])]) | Gets Style by specific name.

See Also

StyleCollection Class
StyleCollection Members
PerpetuumSoft.Instrumentation.Styles Namespace


Item Property (Int32)

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.Item Property (Int32)
StyleCollection Class See Also Send Feedback
Implements Item[([(Int32])]).

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Style this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Style
Visual C++
public:
property Style^ default[int index] {
    Style^ get (int index);
    void set (int index, Style^ value);
}

Parameters

index
Type: System..::.Int32

See Also

StyleCollection Class
Item Overload
PerpetuumSoft.Instrumentation.Styles Namespace


Item Property (String)

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.Item Property (String)
StyleCollection Class See Also Send Feedback
Gets Style by specific name.

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Style this[
    string styleName
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    styleName As String _
) As Style
Visual C++
public:
property Style^ default[String^ styleName] {
    Style^ get (String^ styleName);
}

Parameters

styleName
Type: System..::.String

See Also

StyleCollection Class
Item Overload
PerpetuumSoft.Instrumentation.Styles Namespace


StyleCollection Events

[image] [image]

.NET ModelKit Suite ClassReference
StyleCollection Events
StyleCollection Class See Also Send Feedback

The StyleCollection type exposes the following members.

Events

Name | Description
StyleAdded | Occurs after added style.
StyleRemoved | Occurs after removed style.

See Also

StyleCollection Class
PerpetuumSoft.Instrumentation.Styles Namespace


StyleAdded Event

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.StyleAdded Event
StyleCollection Class See Also Send Feedback
Occurs after added style.

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public event StyleCollection..::.CollectionChanged StyleAdded
Visual Basic (Declaration)
Public Event StyleAdded As StyleCollection..::.CollectionChanged
Visual C++
public:
 event StyleCollection..::.CollectionChanged^ StyleAdded {
    void add (StyleCollection..::.CollectionChanged^ value);
    void remove (StyleCollection..::.CollectionChanged^ value);
}

See Also

StyleCollection Class
PerpetuumSoft.Instrumentation.Styles Namespace


StyleRemoved Event

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.StyleRemoved Event
StyleCollection Class See Also Send Feedback
Occurs after removed style.

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public event StyleCollection..::.CollectionChanged StyleRemoved
Visual Basic (Declaration)
Public Event StyleRemoved As StyleCollection..::.CollectionChanged
Visual C++
public:
 event StyleCollection..::.CollectionChanged^ StyleRemoved {
    void add (StyleCollection..::.CollectionChanged^ value);
    void remove (StyleCollection..::.CollectionChanged^ value);
}

See Also

StyleCollection Class
PerpetuumSoft.Instrumentation.Styles Namespace


StyleCollection.CollectionChanged Delegate

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.CollectionChanged Delegate
StyleCollection Class See Also Send Feedback
Represents method wich called after changing collection.

Namespace: PerpetuumSoft.Instrumentation.Styles
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public delegate void CollectionChanged(
    Style style
)
Visual Basic (Declaration)
Public Delegate Sub CollectionChanged ( _
    style As Style _
)
Visual C++
public delegate void CollectionChanged(
    Style^ style
)

Parameters

style
Type: PerpetuumSoft.Instrumentation.Styles..::.Style

See Also

PerpetuumSoft.Instrumentation.Styles Namespace


PerpetuumSoft.Instrumentation.Web Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Instrumentation.Web Namespace
Send Feedback
The PerpetuumSoft.Instrumentation.Web namespace contains classes to use the Instrument on a Web Form.

Classes

Class | Description
InstrumentClickEventArgs | Provides data for the InstrumentClick event.
ParameterCollection | Represents collection of WidgetParameters.
WidgetHolder | Displays an instrument, contained within the WidgetProducer component. The WidgetHolder component is used for instrument displaying and for its control by the mouse.
WidgetParameter | Represent value of some element property.
WidgetProducer | Contains the displayed instrument. This component is placed on a separate page. When this page is applied to, the component replaces the page content by the instrument image.

Delegates

Delegate | Description
InstrumentClickEventHandler | Represents the method that will handle the InstrumentClick event.
ParameterCollection..::.CollectionChangedEventHandler | Represents the method that will handle CollectionChanged.


InstrumentClickEventArgs Class

[image]

.NET ModelKit Suite ClassReference
InstrumentClickEventArgs Class
Members See Also Send Feedback
Provides data for the InstrumentClick event.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public class InstrumentClickEventArgs : EventArgs
Visual Basic (Declaration)
Public Class InstrumentClickEventArgs _
    Inherits EventArgs
Visual C++
public ref class InstrumentClickEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Instrumentation.Web..::.InstrumentClickEventArgs

See Also

InstrumentClickEventArgs Members
PerpetuumSoft.Instrumentation.Web Namespace


InstrumentClickEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
InstrumentClickEventArgs Members
InstrumentClickEventArgs Class Constructors Methods Properties See Also Send Feedback

The InstrumentClickEventArgs type exposes the following members.

Constructors

Name | Description
InstrumentClickEventArgs | Initializes a new instance of the InstrumentClickEventArgs class with given coordinate and element.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Element | Gets a specified element.
X | Gets X-coordinate.
Y | Gets Y-coordinate.

See Also

InstrumentClickEventArgs Class
PerpetuumSoft.Instrumentation.Web Namespace


InstrumentClickEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
InstrumentClickEventArgs Constructor
InstrumentClickEventArgs Class See Also Send Feedback
Initializes a new instance of the InstrumentClickEventArgs class with given coordinate and element.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public InstrumentClickEventArgs(
    int x,
    int y,
    Element element
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Integer, _
    y As Integer, _
    element As Element _
)
Visual C++
public:
InstrumentClickEventArgs(
    int x,
    int y,
    Element^ element
)

Parameters

x
Type: System..::.Int32
y
Type: System..::.Int32
element
Type: PerpetuumSoft.Instrumentation.Model..::.Element

See Also

InstrumentClickEventArgs Class
PerpetuumSoft.Instrumentation.Web Namespace


InstrumentClickEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
InstrumentClickEventArgs Methods
InstrumentClickEventArgs Class See Also Send Feedback

The InstrumentClickEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstrumentClickEventArgs Class
PerpetuumSoft.Instrumentation.Web Namespace


InstrumentClickEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
InstrumentClickEventArgs Properties
InstrumentClickEventArgs Class See Also Send Feedback

The InstrumentClickEventArgs type exposes the following members.

Properties

Name | Description
Element | Gets a specified element.
X | Gets X-coordinate.
Y | Gets Y-coordinate.

See Also

InstrumentClickEventArgs Class
PerpetuumSoft.Instrumentation.Web Namespace


Element Property

[image]

.NET ModelKit Suite ClassReference
InstrumentClickEventArgs..::.Element Property
InstrumentClickEventArgs Class See Also Send Feedback
Gets a specified element.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public Element Element { get; }
Visual Basic (Declaration)
Public ReadOnly Property Element As Element
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

See Also

InstrumentClickEventArgs Class
PerpetuumSoft.Instrumentation.Web Namespace


X Property

[image]

.NET ModelKit Suite ClassReference
InstrumentClickEventArgs..::.X Property
InstrumentClickEventArgs Class See Also Send Feedback
Gets X-coordinate.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public int X { get; }
Visual Basic (Declaration)
Public ReadOnly Property X As Integer
Visual C++
public:
property int X {
    int get ();
}

See Also

InstrumentClickEventArgs Class
PerpetuumSoft.Instrumentation.Web Namespace


Y Property

[image]

.NET ModelKit Suite ClassReference
InstrumentClickEventArgs..::.Y Property
InstrumentClickEventArgs Class See Also Send Feedback
Gets Y-coordinate.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public int Y { get; }
Visual Basic (Declaration)
Public ReadOnly Property Y As Integer
Visual C++
public:
property int Y {
    int get ();
}

See Also

InstrumentClickEventArgs Class
PerpetuumSoft.Instrumentation.Web Namespace


InstrumentClickEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
InstrumentClickEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the InstrumentClick event.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public delegate void InstrumentClickEventHandler(
    Object sender,
    InstrumentClickEventArgs args
)
Visual Basic (Declaration)
Public Delegate Sub InstrumentClickEventHandler ( _
    sender As Object, _
    args As InstrumentClickEventArgs _
)
Visual C++
public delegate void InstrumentClickEventHandler(
    Object^ sender,
    InstrumentClickEventArgs^ args
)

Parameters

sender
Type: System..::.Object
args
Type: PerpetuumSoft.Instrumentation.Web..::.InstrumentClickEventArgs

See Also

PerpetuumSoft.Instrumentation.Web Namespace


ParameterCollection Class

[image]

.NET ModelKit Suite ClassReference
ParameterCollection Class
Members See Also Send Feedback
Represents collection of WidgetParameters.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
[SerializableAttribute]
public class ParameterCollection : CollectionBase
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ParameterCollection _
    Inherits CollectionBase
Visual C++
[SerializableAttribute]
public ref class ParameterCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Instrumentation.Web..::.ParameterCollection

See Also

ParameterCollection Members
PerpetuumSoft.Instrumentation.Web Namespace


ParameterCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
ParameterCollection Members
ParameterCollection Class Constructors Methods Properties Events See Also Send Feedback

The ParameterCollection type exposes the following members.

Constructors

Name | Description
ParameterCollection | Initializes a new instance of the ParameterCollection class.

Methods

Name | Description
Add | Adds Paramater to the collection.
AddRange | Adds parameters to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new parameter into the collection instance. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new parameter into the collection instance. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing a parameter from the collection instance. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Overrides CollectionBase..::.OnValidate(Object).)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

Name | Description
CollectionChanged | Occurs after the collection has been changed.

See Also

ParameterCollection Class
PerpetuumSoft.Instrumentation.Web Namespace


ParameterCollection Constructor

[image]

.NET ModelKit Suite ClassReference
ParameterCollection Constructor
ParameterCollection Class See Also Send Feedback
Initializes a new instance of the ParameterCollection class.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public ParameterCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterCollection()

See Also

ParameterCollection Class
PerpetuumSoft.Instrumentation.Web Namespace


ParameterCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
ParameterCollection Methods
ParameterCollection Class See Also Send Feedback

The ParameterCollection type exposes the following members.

Methods

Name | Description
Add | Adds Paramater to the collection.
AddRange | Adds parameters to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new parameter into the collection instance. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new parameter into the collection instance. (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing a parameter from the collection instance. (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Overrides CollectionBase..::.OnValidate(Object).)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterCollection Class
PerpetuumSoft.Instrumentation.Web Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.Add Method
ParameterCollection Class See Also Send Feedback
Adds Paramater to the collection.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public WidgetParameter Add(
    WidgetParameter value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As WidgetParameter _
) As WidgetParameter
Visual C++
public:
WidgetParameter^ Add(
    WidgetParameter^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Web..::.WidgetParameter

See Also

ParameterCollection Class
PerpetuumSoft.Instrumentation.Web Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.AddRange Method
ParameterCollection Class See Also Send Feedback
Adds parameters to the collection.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    WidgetParameter[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As WidgetParameter() _
)
Visual C++
public:
void AddRange(
    array<WidgetParameter^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Instrumentation.Web..::.WidgetParameter >[]()[]

See Also

ParameterCollection Class
PerpetuumSoft.Instrumentation.Web Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.Contains Method
ParameterCollection Class See Also Send Feedback
Implements Contains(Object).

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    WidgetParameter value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As WidgetParameter _
) As Boolean
Visual C++
public:
bool Contains(
    WidgetParameter^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Web..::.WidgetParameter

See Also

ParameterCollection Class
PerpetuumSoft.Instrumentation.Web Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.IndexOf Method
ParameterCollection Class See Also Send Feedback
Implements IndexOf(Object).

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    WidgetParameter value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As WidgetParameter _
) As Integer
Visual C++
public:
int IndexOf(
    WidgetParameter^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Web..::.WidgetParameter

See Also

ParameterCollection Class
PerpetuumSoft.Instrumentation.Web Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.Insert Method
ParameterCollection Class See Also Send Feedback
Implements Insert(Int32, Object).

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    WidgetParameter value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As WidgetParameter _
)
Visual C++
public:
void Insert(
    int index,
    WidgetParameter^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Instrumentation.Web..::.WidgetParameter

See Also

ParameterCollection Class
PerpetuumSoft.Instrumentation.Web Namespace


OnInsert Method

[image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.OnInsert Method
ParameterCollection Class See Also Send Feedback
Performs additional custom processes before inserting a new parameter into the collection instance.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsert(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsert ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsert(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ParameterCollection Class
PerpetuumSoft.Instrumentation.Web Namespace


OnInsertComplete Method

[image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.OnInsertComplete Method
ParameterCollection Class See Also Send Feedback
Performs additional custom processes after inserting a new parameter into the collection instance.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsertComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsertComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsertComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ParameterCollection Class
PerpetuumSoft.Instrumentation.Web Namespace


OnRemoveComplete Method

[image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.OnRemoveComplete Method
ParameterCollection Class See Also Send Feedback
Performs additional custom processes after removing a parameter from the collection instance.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnRemoveComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemoveComplete ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemoveComplete(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ParameterCollection Class
PerpetuumSoft.Instrumentation.Web Namespace


OnValidate Method

[image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.OnValidate Method
ParameterCollection Class See Also Send Feedback
Performs additional custom processes when validating a value.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnValidate(
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnValidate ( _
    value As Object _
)
Visual C++
protected:
virtual void OnValidate(
    Object^ value
) override

Parameters

value
Type: System..::.Object

See Also

ParameterCollection Class
PerpetuumSoft.Instrumentation.Web Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.Remove Method
ParameterCollection Class See Also Send Feedback
Implements Remove(Object).

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    WidgetParameter value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As WidgetParameter _
)
Visual C++
public:
void Remove(
    WidgetParameter^ value
)

Parameters

value
Type: PerpetuumSoft.Instrumentation.Web..::.WidgetParameter

See Also

ParameterCollection Class
PerpetuumSoft.Instrumentation.Web Namespace


ParameterCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
ParameterCollection Properties
ParameterCollection Class See Also Send Feedback

The ParameterCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ParameterCollection Class
PerpetuumSoft.Instrumentation.Web Namespace


Item Property

[image] [image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.Item Property
ParameterCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets WidgetParamenter for specified index.
Item[([(String, String])]) | Gets or sets parameter value for a specified elment name and property name.

See Also

ParameterCollection Class
ParameterCollection Members
PerpetuumSoft.Instrumentation.Web Namespace


Item Property (Int32)

[image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.Item Property (Int32)
ParameterCollection Class See Also Send Feedback
Gets or sets WidgetParamenter for specified index.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public WidgetParameter this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As WidgetParameter
Visual C++
public:
property WidgetParameter^ default[int index] {
    WidgetParameter^ get (int index);
    void set (int index, WidgetParameter^ value);
}

Parameters

index
Type: System..::.Int32

See Also

ParameterCollection Class
Item Overload
PerpetuumSoft.Instrumentation.Web Namespace


Item Property (String, String)

[image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.Item Property (String, String)
ParameterCollection Class See Also Send Feedback
Gets or sets parameter value for a specified elment name and property name.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public string this[
    string elementName,
    string propertyName
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    elementName As String, _
    propertyName As String _
) As String
Visual C++
public:
property String^ default[String^ elementName, String^ propertyName] {
    String^ get (String^ elementName, String^ propertyName);
    void set (String^ elementName, String^ propertyName, String^ value);
}

Parameters

elementName
Type: System..::.String
propertyName
Type: System..::.String

See Also

ParameterCollection Class
Item Overload
PerpetuumSoft.Instrumentation.Web Namespace


ParameterCollection Events

[image] [image]

.NET ModelKit Suite ClassReference
ParameterCollection Events
ParameterCollection Class See Also Send Feedback

The ParameterCollection type exposes the following members.

Events

Name | Description
CollectionChanged | Occurs after the collection has been changed.

See Also

ParameterCollection Class
PerpetuumSoft.Instrumentation.Web Namespace


CollectionChanged Event

[image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.CollectionChanged Event
ParameterCollection Class See Also Send Feedback
Occurs after the collection has been changed.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public event ParameterCollection..::.CollectionChangedEventHandler CollectionChanged
Visual Basic (Declaration)
Public Event CollectionChanged As ParameterCollection..::.CollectionChangedEventHandler
Visual C++
public:
 event ParameterCollection..::.CollectionChangedEventHandler^ CollectionChanged {
    void add (ParameterCollection..::.CollectionChangedEventHandler^ value);
    void remove (ParameterCollection..::.CollectionChangedEventHandler^ value);
}

See Also

ParameterCollection Class
PerpetuumSoft.Instrumentation.Web Namespace


ParameterCollection.CollectionChangedEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.CollectionChangedEventHandler Delegate
ParameterCollection Class See Also Send Feedback
Represents the method that will handle CollectionChanged.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public delegate void CollectionChangedEventHandler(
    WidgetParameter needlePoint
)
Visual Basic (Declaration)
Public Delegate Sub CollectionChangedEventHandler ( _
    needlePoint As WidgetParameter _
)
Visual C++
public delegate void CollectionChangedEventHandler(
    WidgetParameter^ needlePoint
)

Parameters

needlePoint
Type: PerpetuumSoft.Instrumentation.Web..::.WidgetParameter

See Also

PerpetuumSoft.Instrumentation.Web Namespace


WidgetHolder Class

[image]

.NET ModelKit Suite ClassReference
WidgetHolder Class
Members See Also Send Feedback
Displays an instrument, contained within the WidgetProducer component. The WidgetHolder component is used for instrument displaying and for its control by the mouse.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public class WidgetHolder : WebControl,
    IPostBackEventHandler
Visual Basic (Declaration)
Public Class WidgetHolder _
    Inherits WebControl _
    Implements IPostBackEventHandler
Visual C++
public ref class WidgetHolder : public WebControl,
    IPostBackEventHandler

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI.WebControls..::.WebControl
PerpetuumSoft.Instrumentation.Web..::.WidgetHolder

See Also

WidgetHolder Members
PerpetuumSoft.Instrumentation.Web Namespace


WidgetHolder Members

[image] [image]

.NET ModelKit Suite ClassReference
WidgetHolder Members
WidgetHolder Class Constructors Methods Properties Events See Also Send Feedback

The WidgetHolder type exposes the following members.

Constructors

Name | Description
WidgetHolder | Initializes a new instance of the WidgetHolder class.

Methods

Name | Description
AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnInit | Raises the Init event. (Inherited from Control.)
OnInstrumentClick | Raises the CollectionChanged event.
OnLoad | Raises the Load event. (Inherited from Control.)
OnPreRender | Raises the PreRender event. (Inherited from Control.)
OnUnload | Raises the Unload event. (Inherited from Control.)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderContents | Overridden. See RenderContents(HtmlTextWriter). (Overrides WebControl..::.RenderContents(HtmlTextWriter).)
RenderControl | Overloaded.
RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SaveViewState | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Properties

Name | Description
AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
EnablePostBack | Gets or sets a value indicating WidgetHolder possibility to send cursor coordinates on server.
EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
JpegQuality | Gets or sets quality of JPEG picture. Makes sense if PictureFormat is set into PictureFormat.Jpeg.
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Parameters | Gets WidgetHolder parameters collection.
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
PictureFormat | Gets or sets Picture format for displaying instrument.
ProducerUrl | Gets or sets WidgetProduser URL.
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

Events

Name | Description
DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
InstrumentClick | Occurs after clicking on an instrument.
Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

WidgetHolder Class
PerpetuumSoft.Instrumentation.Web Namespace


WidgetHolder Constructor

[image]

.NET ModelKit Suite ClassReference
WidgetHolder Constructor
WidgetHolder Class See Also Send Feedback
Initializes a new instance of the WidgetHolder class.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public WidgetHolder()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WidgetHolder()

See Also

WidgetHolder Class
PerpetuumSoft.Instrumentation.Web Namespace


WidgetHolder Methods

[image] [image]

.NET ModelKit Suite ClassReference
WidgetHolder Methods
WidgetHolder Class See Also Send Feedback

The WidgetHolder type exposes the following members.

Methods

Name | Description
AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnInit | Raises the Init event. (Inherited from Control.)
OnInstrumentClick | Raises the CollectionChanged event.
OnLoad | Raises the Load event. (Inherited from Control.)
OnPreRender | Raises the PreRender event. (Inherited from Control.)
OnUnload | Raises the Unload event. (Inherited from Control.)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderContents | Overridden. See RenderContents(HtmlTextWriter). (Overrides WebControl..::.RenderContents(HtmlTextWriter).)
RenderControl | Overloaded.
RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SaveViewState | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

See Also

WidgetHolder Class
PerpetuumSoft.Instrumentation.Web Namespace


DataBind Method

[image] [image]

.NET ModelKit Suite ClassReference
WidgetHolder..::.DataBind Method
WidgetHolder Class See Also Send Feedback

Overload List

Name | Description
DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

WidgetHolder Class
WidgetHolder Members
PerpetuumSoft.Instrumentation.Web Namespace


FindControl Method

[image] [image]

.NET ModelKit Suite ClassReference
WidgetHolder..::.FindControl Method
WidgetHolder Class See Also Send Feedback

Overload List

Name | Description
FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)

See Also

WidgetHolder Class
WidgetHolder Members
PerpetuumSoft.Instrumentation.Web Namespace


OnInstrumentClick Method

[image]

.NET ModelKit Suite ClassReference
WidgetHolder..::.OnInstrumentClick Method
WidgetHolder Class See Also Send Feedback
Raises the CollectionChanged event.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnInstrumentClick(
    InstrumentClickEventArgs args
)
Visual Basic (Declaration)
Protected Overridable Sub OnInstrumentClick ( _
    args As InstrumentClickEventArgs _
)
Visual C++
protected:
virtual void OnInstrumentClick(
    InstrumentClickEventArgs^ args
)

Parameters

args
Type: PerpetuumSoft.Instrumentation.Web..::.InstrumentClickEventArgs

See Also

WidgetHolder Class
PerpetuumSoft.Instrumentation.Web Namespace


RenderContents Method

[image]

.NET ModelKit Suite ClassReference
WidgetHolder..::.RenderContents Method
WidgetHolder Class See Also Send Feedback
Overridden. See RenderContents(HtmlTextWriter).

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
protected override void RenderContents(
    HtmlTextWriter writer
)
Visual Basic (Declaration)
Protected Overrides Sub RenderContents ( _
    writer As HtmlTextWriter _
)
Visual C++
protected:
virtual void RenderContents(
    HtmlTextWriter^ writer
) override

Parameters

writer
Type: System.Web.UI..::.HtmlTextWriter

See Also

WidgetHolder Class
PerpetuumSoft.Instrumentation.Web Namespace


RenderControl Method

[image] [image]

.NET ModelKit Suite ClassReference
WidgetHolder..::.RenderControl Method
WidgetHolder Class See Also Send Feedback

Overload List

Name | Description
RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

WidgetHolder Class
WidgetHolder Members
PerpetuumSoft.Instrumentation.Web Namespace


WidgetHolder Properties

[image] [image]

.NET ModelKit Suite ClassReference
WidgetHolder Properties
WidgetHolder Class See Also Send Feedback

The WidgetHolder type exposes the following members.

Properties

Name | Description
AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
EnablePostBack | Gets or sets a value indicating WidgetHolder possibility to send cursor coordinates on server.
EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
JpegQuality | Gets or sets quality of JPEG picture. Makes sense if PictureFormat is set into PictureFormat.Jpeg.
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Parameters | Gets WidgetHolder parameters collection.
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
PictureFormat | Gets or sets Picture format for displaying instrument.
ProducerUrl | Gets or sets WidgetProduser URL.
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

See Also

WidgetHolder Class
PerpetuumSoft.Instrumentation.Web Namespace


EnablePostBack Property

[image]

.NET ModelKit Suite ClassReference
WidgetHolder..::.EnablePostBack Property
WidgetHolder Class See Also Send Feedback
Gets or sets a value indicating WidgetHolder possibility to send cursor coordinates on server.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public bool EnablePostBack { get; set; }
Visual Basic (Declaration)
Public Property EnablePostBack As Boolean
Visual C++
public:
property bool EnablePostBack {
    bool get ();
    void set (bool value);
}

See Also

WidgetHolder Class
PerpetuumSoft.Instrumentation.Web Namespace


JpegQuality Property

[image]

.NET ModelKit Suite ClassReference
WidgetHolder..::.JpegQuality Property
WidgetHolder Class See Also Send Feedback
Gets or sets quality of JPEG picture. Makes sense if PictureFormat is set into PictureFormat.Jpeg.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public byte JpegQuality { get; set; }
Visual Basic (Declaration)
Public Property JpegQuality As Byte
Visual C++
public:
property unsigned char JpegQuality {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

WidgetHolder Class
PerpetuumSoft.Instrumentation.Web Namespace


Parameters Property

[image]

.NET ModelKit Suite ClassReference
WidgetHolder..::.Parameters Property
WidgetHolder Class See Also Send Feedback
Gets WidgetHolder parameters collection.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public ParameterCollection Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterCollection
Visual C++
public:
property ParameterCollection^ Parameters {
    ParameterCollection^ get ();
}

See Also

WidgetHolder Class
PerpetuumSoft.Instrumentation.Web Namespace


PictureFormat Property

[image]

.NET ModelKit Suite ClassReference
WidgetHolder..::.PictureFormat Property
WidgetHolder Class See Also Send Feedback
Gets or sets Picture format for displaying instrument.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public PictureFormat PictureFormat { get; set; }
Visual Basic (Declaration)
Public Property PictureFormat As PictureFormat
Visual C++
public:
property PictureFormat PictureFormat {
    PictureFormat get ();
    void set (PictureFormat value);
}

See Also

WidgetHolder Class
PerpetuumSoft.Instrumentation.Web Namespace


ProducerUrl Property

[image]

.NET ModelKit Suite ClassReference
WidgetHolder..::.ProducerUrl Property
WidgetHolder Class See Also Send Feedback
Gets or sets WidgetProduser URL.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public string ProducerUrl { get; set; }
Visual Basic (Declaration)
Public Property ProducerUrl As String
Visual C++
public:
property String^ ProducerUrl {
    String^ get ();
    void set (String^ value);
}

See Also

WidgetHolder Class
PerpetuumSoft.Instrumentation.Web Namespace


WidgetHolder Events

[image] [image]

.NET ModelKit Suite ClassReference
WidgetHolder Events
WidgetHolder Class See Also Send Feedback

The WidgetHolder type exposes the following members.

Events

Name | Description
DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
InstrumentClick | Occurs after clicking on an instrument.
Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

WidgetHolder Class
PerpetuumSoft.Instrumentation.Web Namespace


InstrumentClick Event

[image]

.NET ModelKit Suite ClassReference
WidgetHolder..::.InstrumentClick Event
WidgetHolder Class See Also Send Feedback
Occurs after clicking on an instrument.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public event InstrumentClickEventHandler InstrumentClick
Visual Basic (Declaration)
Public Event InstrumentClick As InstrumentClickEventHandler
Visual C++
public:
 event InstrumentClickEventHandler^ InstrumentClick {
    void add (InstrumentClickEventHandler^ value);
    void remove (InstrumentClickEventHandler^ value);
}

See Also

WidgetHolder Class
PerpetuumSoft.Instrumentation.Web Namespace


WidgetParameter Class

[image]

.NET ModelKit Suite ClassReference
WidgetParameter Class
Members See Also Send Feedback
Represent value of some element property.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
[SerializableAttribute]
public class WidgetParameter
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class WidgetParameter
Visual C++
[SerializableAttribute]
public ref class WidgetParameter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Instrumentation.Web..::.WidgetParameter

See Also

WidgetParameter Members
PerpetuumSoft.Instrumentation.Web Namespace


WidgetParameter Members

[image] [image]

.NET ModelKit Suite ClassReference
WidgetParameter Members
WidgetParameter Class Constructors Methods Properties See Also Send Feedback

The WidgetParameter type exposes the following members.

Constructors

Name | Description
WidgetParameter | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ElementName | Gets or sets element name.
PropertyName | Gets or sets property name.
Value | Gets or sets property value.

See Also

WidgetParameter Class
PerpetuumSoft.Instrumentation.Web Namespace


WidgetParameter Constructor

[image] [image]

.NET ModelKit Suite ClassReference
WidgetParameter Constructor
WidgetParameter Class See Also Send Feedback

Overload List

Name | Description
WidgetParameter()()() | Initializes a new instance of the WidgetParameter class with given element name, property name and property value.
WidgetParameter(String, String, String) | Initializes a new instance of the WidgetParameter class.

See Also

WidgetParameter Class
WidgetParameter Members
PerpetuumSoft.Instrumentation.Web Namespace


WidgetParameter Constructor

[image]

.NET ModelKit Suite ClassReference
WidgetParameter Constructor
WidgetParameter Class See Also Send Feedback
Initializes a new instance of the WidgetParameter class with given element name, property name and property value.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public WidgetParameter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WidgetParameter()

See Also

WidgetParameter Class
WidgetParameter Overload
PerpetuumSoft.Instrumentation.Web Namespace


WidgetParameter Constructor (String, String, String)

[image]

.NET ModelKit Suite ClassReference
WidgetParameter Constructor (String, String, String)
WidgetParameter Class See Also Send Feedback
Initializes a new instance of the WidgetParameter class.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public WidgetParameter(
    string elementName,
    string propertyName,
    string value
)
Visual Basic (Declaration)
Public Sub New ( _
    elementName As String, _
    propertyName As String, _
    value As String _
)
Visual C++
public:
WidgetParameter(
    String^ elementName,
    String^ propertyName,
    String^ value
)

Parameters

elementName
Type: System..::.String
propertyName
Type: System..::.String
value
Type: System..::.String

See Also

WidgetParameter Class
WidgetParameter Overload
PerpetuumSoft.Instrumentation.Web Namespace


WidgetParameter Methods

[image] [image]

.NET ModelKit Suite ClassReference
WidgetParameter Methods
WidgetParameter Class See Also Send Feedback

The WidgetParameter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WidgetParameter Class
PerpetuumSoft.Instrumentation.Web Namespace


WidgetParameter Properties

[image] [image]

.NET ModelKit Suite ClassReference
WidgetParameter Properties
WidgetParameter Class See Also Send Feedback

The WidgetParameter type exposes the following members.

Properties

Name | Description
ElementName | Gets or sets element name.
PropertyName | Gets or sets property name.
Value | Gets or sets property value.

See Also

WidgetParameter Class
PerpetuumSoft.Instrumentation.Web Namespace


ElementName Property

[image]

.NET ModelKit Suite ClassReference
WidgetParameter..::.ElementName Property
WidgetParameter Class See Also Send Feedback
Gets or sets element name.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public string ElementName { get; set; }
Visual Basic (Declaration)
Public Property ElementName As String
Visual C++
public:
property String^ ElementName {
    String^ get ();
    void set (String^ value);
}

See Also

WidgetParameter Class
PerpetuumSoft.Instrumentation.Web Namespace


PropertyName Property

[image]

.NET ModelKit Suite ClassReference
WidgetParameter..::.PropertyName Property
WidgetParameter Class See Also Send Feedback
Gets or sets property name.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public string PropertyName { get; set; }
Visual Basic (Declaration)
Public Property PropertyName As String
Visual C++
public:
property String^ PropertyName {
    String^ get ();
    void set (String^ value);
}

See Also

WidgetParameter Class
PerpetuumSoft.Instrumentation.Web Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
WidgetParameter..::.Value Property
WidgetParameter Class See Also Send Feedback
Gets or sets property value.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

WidgetParameter Class
PerpetuumSoft.Instrumentation.Web Namespace


WidgetProducer Class

[image]

.NET ModelKit Suite ClassReference
WidgetProducer Class
Members See Also Send Feedback
Contains the displayed instrument. This component is placed on a separate page. When this page is applied to, the component replaces the page content by the instrument image.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public class WidgetProducer : WebControl
Visual Basic (Declaration)
Public Class WidgetProducer _
    Inherits WebControl
Visual C++
public ref class WidgetProducer : public WebControl

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI.WebControls..::.WebControl
PerpetuumSoft.Instrumentation.Web..::.WidgetProducer

See Also

WidgetProducer Members
PerpetuumSoft.Instrumentation.Web Namespace


WidgetProducer Members

[image] [image]

.NET ModelKit Suite ClassReference
WidgetProducer Members
WidgetProducer Class Constructors Methods Properties Events See Also Send Feedback

The WidgetProducer type exposes the following members.

Constructors

Name | Description
WidgetProducer | Initializes a new instance of the WidgetProducer class.

Methods

Name | Description
AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnInit | Overridden. See OnInit(EventArgs). (Overrides Control..::.OnInit(EventArgs).)
OnLoad | Raises the Load event. (Inherited from Control.)
OnPreRender | Raises the PreRender event. (Inherited from Control.)
OnUnload | Raises the Unload event. (Inherited from Control.)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderContents | Overridden. See RenderContents(HtmlTextWriter). (Overrides WebControl..::.RenderContents(HtmlTextWriter).)
RenderControl | Overloaded.
RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SaveViewState | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Properties

Name | Description
AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Instrument | Gets or sets Instrument being displayed .
InstrumentData | Gets or sets serialized instrument.
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

Events

Name | Description
DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

WidgetProducer Class
PerpetuumSoft.Instrumentation.Web Namespace


WidgetProducer Constructor

[image]

.NET ModelKit Suite ClassReference
WidgetProducer Constructor
WidgetProducer Class See Also Send Feedback
Initializes a new instance of the WidgetProducer class.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public WidgetProducer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WidgetProducer()

See Also

WidgetProducer Class
PerpetuumSoft.Instrumentation.Web Namespace


WidgetProducer Methods

[image] [image]

.NET ModelKit Suite ClassReference
WidgetProducer Methods
WidgetProducer Class See Also Send Feedback

The WidgetProducer type exposes the following members.

Methods

Name | Description
AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnInit | Overridden. See OnInit(EventArgs). (Overrides Control..::.OnInit(EventArgs).)
OnLoad | Raises the Load event. (Inherited from Control.)
OnPreRender | Raises the PreRender event. (Inherited from Control.)
OnUnload | Raises the Unload event. (Inherited from Control.)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderContents | Overridden. See RenderContents(HtmlTextWriter). (Overrides WebControl..::.RenderContents(HtmlTextWriter).)
RenderControl | Overloaded.
RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SaveViewState | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

See Also

WidgetProducer Class
PerpetuumSoft.Instrumentation.Web Namespace


DataBind Method

[image] [image]

.NET ModelKit Suite ClassReference
WidgetProducer..::.DataBind Method
WidgetProducer Class See Also Send Feedback

Overload List

Name | Description
DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

WidgetProducer Class
WidgetProducer Members
PerpetuumSoft.Instrumentation.Web Namespace


FindControl Method

[image] [image]

.NET ModelKit Suite ClassReference
WidgetProducer..::.FindControl Method
WidgetProducer Class See Also Send Feedback

Overload List

Name | Description
FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)

See Also

WidgetProducer Class
WidgetProducer Members
PerpetuumSoft.Instrumentation.Web Namespace


OnInit Method

[image]

.NET ModelKit Suite ClassReference
WidgetProducer..::.OnInit Method
WidgetProducer Class See Also Send Feedback
Overridden. See OnInit(EventArgs).

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInit(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnInit ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnInit(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

WidgetProducer Class
PerpetuumSoft.Instrumentation.Web Namespace


RenderContents Method

[image]

.NET ModelKit Suite ClassReference
WidgetProducer..::.RenderContents Method
WidgetProducer Class See Also Send Feedback
Overridden. See RenderContents(HtmlTextWriter).

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
protected override void RenderContents(
    HtmlTextWriter writer
)
Visual Basic (Declaration)
Protected Overrides Sub RenderContents ( _
    writer As HtmlTextWriter _
)
Visual C++
protected:
virtual void RenderContents(
    HtmlTextWriter^ writer
) override

Parameters

writer
Type: System.Web.UI..::.HtmlTextWriter

See Also

WidgetProducer Class
PerpetuumSoft.Instrumentation.Web Namespace


RenderControl Method

[image] [image]

.NET ModelKit Suite ClassReference
WidgetProducer..::.RenderControl Method
WidgetProducer Class See Also Send Feedback

Overload List

Name | Description
RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

WidgetProducer Class
WidgetProducer Members
PerpetuumSoft.Instrumentation.Web Namespace


WidgetProducer Properties

[image] [image]

.NET ModelKit Suite ClassReference
WidgetProducer Properties
WidgetProducer Class See Also Send Feedback

The WidgetProducer type exposes the following members.

Properties

Name | Description
AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
Instrument | Gets or sets Instrument being displayed .
InstrumentData | Gets or sets serialized instrument.
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)

See Also

WidgetProducer Class
PerpetuumSoft.Instrumentation.Web Namespace


Instrument Property

[image]

.NET ModelKit Suite ClassReference
WidgetProducer..::.Instrument Property
WidgetProducer Class See Also Send Feedback
Gets or sets Instrument being displayed .

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public Instrument Instrument { get; set; }
Visual Basic (Declaration)
Public Property Instrument As Instrument
Visual C++
public:
property Instrument^ Instrument {
    Instrument^ get ();
    void set (Instrument^ value);
}

See Also

WidgetProducer Class
PerpetuumSoft.Instrumentation.Web Namespace


InstrumentData Property

[image]

.NET ModelKit Suite ClassReference
WidgetProducer..::.InstrumentData Property
WidgetProducer Class See Also Send Feedback
Gets or sets serialized instrument.

Namespace: PerpetuumSoft.Instrumentation.Web
Assembly: PerpetuumSoft.Instrumentation.Web (in PerpetuumSoft.Instrumentation.Web.dll) Version: 3.9.0.1

Syntax

C#
public string InstrumentData { get; set; }
Visual Basic (Declaration)
Public Property InstrumentData As String
Visual C++
public:
property String^ InstrumentData {
    String^ get ();
    void set (String^ value);
}

See Also

WidgetProducer Class
PerpetuumSoft.Instrumentation.Web Namespace


WidgetProducer Events

[image] [image]

.NET ModelKit Suite ClassReference
WidgetProducer Events
WidgetProducer Class See Also Send Feedback

The WidgetProducer type exposes the following members.

Events

Name | Description
DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

WidgetProducer Class
PerpetuumSoft.Instrumentation.Web Namespace


PerpetuumSoft.Instrumentation.Windows.Forms Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Instrumentation.Windows.Forms Namespace
Send Feedback
The PerpetuumSoft.Instrumentation.Windows.Forms namespace contains classes to use the Instrument on a Windows Form.

Classes

Class | Description
IndicatorWidget | Represents a special Widget control, providing additional abilities of work with slider instruments.
Widget | Represents a control for displaying instruments.


IndicatorWidget Class

[image]

.NET ModelKit Suite ClassReference
IndicatorWidget Class
Members See Also Send Feedback
Represents a special Widget control, providing additional abilities of work with slider instruments.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class IndicatorWidget : Widget
Visual Basic (Declaration)
Public Class IndicatorWidget _
    Inherits Widget
Visual C++
public ref class IndicatorWidget : public Widget

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Framework.Model.Windows.Forms..::.SimpleViewFrame
PerpetuumSoft.Instrumentation.Windows.Forms..::.Widget
PerpetuumSoft.Instrumentation.Windows.Forms..::.IndicatorWidget

See Also

IndicatorWidget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


IndicatorWidget Members

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget Members
IndicatorWidget Class Constructors Methods Properties Events See Also Send Feedback

The IndicatorWidget type exposes the following members.

Constructors

Name | Description
IndicatorWidget | Gets or sets active slider name.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetElementAt | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnableChanged event. (Inherited from Widget.)
OnEnter | Overriden. See OnEnter(EventArgs). (Inherited from SimpleViewFrame.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Widget.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInstrumentLoad | Raises the InstrumentLoad event. (Overrides Widget..::.OnInstrumentLoad(EventArgs).)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | 'Raises the KeyDown event. (Overrides SimpleViewFrame..::.OnKeyDown(KeyEventArgs).)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Overriden. See OnKeyUp(KeyEventArgs). (Inherited from SimpleViewFrame.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | (Inherited from Widget.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Widget.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Overriden. See OnMouseDown(MouseEventArgs). (Inherited from SimpleViewFrame.)
OnMouseEnter | Overriden. See OnMouseEnter(EventArgs). (Inherited from SimpleViewFrame.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Widget.)
OnMouseMove | Overriden. See OnMouseMove(MouseEventArgs). (Inherited from SimpleViewFrame.)
OnMouseUp | Overriden. See OnMouseUp(MouseEventArgs). (Inherited from SimpleViewFrame.)
OnMouseWheel | Overriden. See OnMouseWheel(MouseEventArgs). (Inherited from SimpleViewFrame.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the OnPaint event. (Inherited from Widget.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Overriden. See OnResize(EventArgs). (Inherited from SimpleViewFrame.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Occurs when size is changed. (Inherited from Widget.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnValueChanged | Raises the ValueChanged event.
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateView | Implements UpdateView()()(). (Inherited from SimpleViewFrame.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFocusRectangle | Gets or sets value that determines if rectangle border will be hidden, when the Widget gets focus. (Inherited from Widget.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
Increment | Gets or sets the value change step.
Instrument | Gets or sets the instrument. (Inherited from Widget.)
InstrumentationStream | Gets or sets the instrument serialized to a string. (Inherited from Widget.)
InvalidateInterval | Gets or sets interval for the instrument re-drawing. (Inherited from Widget.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
MainSlider | Gets active slider.
Margin | Gets or sets the space between controls. (Inherited from Control.)
Maximum | Gets or sets minimum value active slider can possess.
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Minimum | Gets or sets maximum value active slider can possess.
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
SliderName | Gets or sets active slider name.
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Value | Gets or sets active slider value.
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewRectangle | Gets the size of client rectangle. (Inherited from SimpleViewFrame.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
ZoomScale | Gets or sets zoom for displaying the instrument. (Inherited from Widget.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InstrumentLoad | Occurs when the instrument is loaded. (Inherited from Widget.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
ValueChanged | Occurs when value is changed.
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

IndicatorWidget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


IndicatorWidget Constructor

[image]

.NET ModelKit Suite ClassReference
IndicatorWidget Constructor
IndicatorWidget Class See Also Send Feedback
Gets or sets active slider name.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public IndicatorWidget()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IndicatorWidget()

See Also

IndicatorWidget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


IndicatorWidget Methods

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget Methods
IndicatorWidget Class See Also Send Feedback

The IndicatorWidget type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetElementAt | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnableChanged event. (Inherited from Widget.)
OnEnter | Overriden. See OnEnter(EventArgs). (Inherited from SimpleViewFrame.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Widget.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInstrumentLoad | Raises the InstrumentLoad event. (Overrides Widget..::.OnInstrumentLoad(EventArgs).)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | 'Raises the KeyDown event. (Overrides SimpleViewFrame..::.OnKeyDown(KeyEventArgs).)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Overriden. See OnKeyUp(KeyEventArgs). (Inherited from SimpleViewFrame.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | (Inherited from Widget.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Widget.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Overriden. See OnMouseDown(MouseEventArgs). (Inherited from SimpleViewFrame.)
OnMouseEnter | Overriden. See OnMouseEnter(EventArgs). (Inherited from SimpleViewFrame.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Widget.)
OnMouseMove | Overriden. See OnMouseMove(MouseEventArgs). (Inherited from SimpleViewFrame.)
OnMouseUp | Overriden. See OnMouseUp(MouseEventArgs). (Inherited from SimpleViewFrame.)
OnMouseWheel | Overriden. See OnMouseWheel(MouseEventArgs). (Inherited from SimpleViewFrame.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the OnPaint event. (Inherited from Widget.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Overriden. See OnResize(EventArgs). (Inherited from SimpleViewFrame.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Occurs when size is changed. (Inherited from Widget.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnValueChanged | Raises the ValueChanged event.
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateView | Implements UpdateView()()(). (Inherited from SimpleViewFrame.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

IndicatorWidget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.AccessibilityNotifyClients Method
IndicatorWidget Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

IndicatorWidget Class
IndicatorWidget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.BeginInvoke Method
IndicatorWidget Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

IndicatorWidget Class
IndicatorWidget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.Dispose Method
IndicatorWidget Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

IndicatorWidget Class
IndicatorWidget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.GetChildAtPoint Method
IndicatorWidget Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

IndicatorWidget Class
IndicatorWidget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


GetElementAt Method

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.GetElementAt Method
IndicatorWidget Class See Also Send Feedback

Overload List

Name | Description
GetElementAt(Point) | Returns the element that belongs to the instrument and is located in the specified point. (Inherited from Widget.)
GetElementAt(Int32, Int32) | Returns the element that belongs to the instrument and is located in the point with specified coordinates. (Inherited from Widget.)

See Also

IndicatorWidget Class
IndicatorWidget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.Invalidate Method
IndicatorWidget Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

IndicatorWidget Class
IndicatorWidget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.Invoke Method
IndicatorWidget Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

IndicatorWidget Class
IndicatorWidget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.MemberwiseClone Method
IndicatorWidget Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

IndicatorWidget Class
IndicatorWidget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


OnInstrumentLoad Method

[image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.OnInstrumentLoad Method
IndicatorWidget Class See Also Send Feedback
Raises the InstrumentLoad event.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInstrumentLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnInstrumentLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnInstrumentLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

IndicatorWidget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


OnKeyDown Method

[image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.OnKeyDown Method
IndicatorWidget Class See Also Send Feedback
'Raises the KeyDown event.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.KeyEventArgs

See Also

IndicatorWidget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


OnValueChanged Method

[image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.OnValueChanged Method
IndicatorWidget Class See Also Send Feedback
Raises the ValueChanged event.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnValueChanged(
    EventArgs args
)
Visual Basic (Declaration)
Protected Overridable Sub OnValueChanged ( _
    args As EventArgs _
)
Visual C++
protected:
virtual void OnValueChanged(
    EventArgs^ args
)

Parameters

args
Type: System..::.EventArgs

See Also

IndicatorWidget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.PerformLayout Method
IndicatorWidget Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

IndicatorWidget Class
IndicatorWidget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.ResumeLayout Method
IndicatorWidget Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

IndicatorWidget Class
IndicatorWidget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.RtlTranslateAlignment Method
IndicatorWidget Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

IndicatorWidget Class
IndicatorWidget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.Scale Method
IndicatorWidget Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

IndicatorWidget Class
IndicatorWidget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.Select Method
IndicatorWidget Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

IndicatorWidget Class
IndicatorWidget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.SetBounds Method
IndicatorWidget Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

IndicatorWidget Class
IndicatorWidget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.UpdateBounds Method
IndicatorWidget Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

IndicatorWidget Class
IndicatorWidget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.Validate Method
IndicatorWidget Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

IndicatorWidget Class
IndicatorWidget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.ValidateChildren Method
IndicatorWidget Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

IndicatorWidget Class
IndicatorWidget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


IndicatorWidget Properties

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget Properties
IndicatorWidget Class See Also Send Feedback

The IndicatorWidget type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFocusRectangle | Gets or sets value that determines if rectangle border will be hidden, when the Widget gets focus. (Inherited from Widget.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
Increment | Gets or sets the value change step.
Instrument | Gets or sets the instrument. (Inherited from Widget.)
InstrumentationStream | Gets or sets the instrument serialized to a string. (Inherited from Widget.)
InvalidateInterval | Gets or sets interval for the instrument re-drawing. (Inherited from Widget.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
MainSlider | Gets active slider.
Margin | Gets or sets the space between controls. (Inherited from Control.)
Maximum | Gets or sets minimum value active slider can possess.
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Minimum | Gets or sets maximum value active slider can possess.
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
SliderName | Gets or sets active slider name.
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Value | Gets or sets active slider value.
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewRectangle | Gets the size of client rectangle. (Inherited from SimpleViewFrame.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
ZoomScale | Gets or sets zoom for displaying the instrument. (Inherited from Widget.)

See Also

IndicatorWidget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Increment Property

[image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.Increment Property
IndicatorWidget Class See Also Send Feedback
Gets or sets the value change step.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Increment { get; set; }
Visual Basic (Declaration)
Public Property Increment As Double
Visual C++
public:
property double Increment {
    double get ();
    void set (double value);
}

See Also

IndicatorWidget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


MainSlider Property

[image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.MainSlider Property
IndicatorWidget Class See Also Send Feedback
Gets active slider.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public SliderBase MainSlider { get; }
Visual Basic (Declaration)
Public ReadOnly Property MainSlider As SliderBase
Visual C++
public:
property SliderBase^ MainSlider {
    SliderBase^ get ();
}

See Also

IndicatorWidget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Maximum Property

[image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.Maximum Property
IndicatorWidget Class See Also Send Feedback
Gets or sets minimum value active slider can possess.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Maximum { get; set; }
Visual Basic (Declaration)
Public Property Maximum As Double
Visual C++
public:
property double Maximum {
    double get ();
    void set (double value);
}

See Also

IndicatorWidget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Minimum Property

[image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.Minimum Property
IndicatorWidget Class See Also Send Feedback
Gets or sets maximum value active slider can possess.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Minimum { get; set; }
Visual Basic (Declaration)
Public Property Minimum As Double
Visual C++
public:
property double Minimum {
    double get ();
    void set (double value);
}

See Also

IndicatorWidget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


SliderName Property

[image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.SliderName Property
IndicatorWidget Class See Also Send Feedback
Gets or sets active slider name.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string SliderName { get; set; }
Visual Basic (Declaration)
Public Property SliderName As String
Visual C++
public:
property String^ SliderName {
    String^ get ();
    void set (String^ value);
}

See Also

IndicatorWidget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.Value Property
IndicatorWidget Class See Also Send Feedback
Gets or sets active slider value.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Double
Visual C++
public:
property double Value {
    double get ();
    void set (double value);
}

See Also

IndicatorWidget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


IndicatorWidget Events

[image] [image]

.NET ModelKit Suite ClassReference
IndicatorWidget Events
IndicatorWidget Class See Also Send Feedback

The IndicatorWidget type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InstrumentLoad | Occurs when the instrument is loaded. (Inherited from Widget.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
ValueChanged | Occurs when value is changed.
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

IndicatorWidget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


ValueChanged Event

[image]

.NET ModelKit Suite ClassReference
IndicatorWidget..::.ValueChanged Event
IndicatorWidget Class See Also Send Feedback
Occurs when value is changed.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler ValueChanged
Visual Basic (Declaration)
Public Event ValueChanged As EventHandler
Visual C++
public:
 event EventHandler^ ValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

IndicatorWidget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Widget Class

[image]

.NET ModelKit Suite ClassReference
Widget Class
Members See Also Send Feedback
Represents a control for displaying instruments.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public class Widget : SimpleViewFrame, ICustomTypeDescriptor
Visual Basic (Declaration)
Public Class Widget _
    Inherits SimpleViewFrame _
    Implements ICustomTypeDescriptor
Visual C++
public ref class Widget : public SimpleViewFrame,
    ICustomTypeDescriptor

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Framework.Model.Windows.Forms..::.SimpleViewFrame
PerpetuumSoft.Instrumentation.Windows.Forms..::.Widget
PerpetuumSoft.Instrumentation.Windows.Forms..::.IndicatorWidget

See Also

Widget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Widget Members

[image] [image]

.NET ModelKit Suite ClassReference
Widget Members
Widget Class Constructors Methods Properties Events See Also Send Feedback

The Widget type exposes the following members.

Constructors

Name | Description
Widget | Creates a new instant of the Widget class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetElementAt | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnableChanged event. (Overrides Control..::.OnEnabledChanged(EventArgs).)
OnEnter | Overriden. See OnEnter(EventArgs). (Inherited from SimpleViewFrame.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Overrides Control..::.OnGotFocus(EventArgs).)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInstrumentLoad | Raises the InstrumentLoad event.
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Overriden. See OnKeyDown(KeyEventArgs). (Inherited from SimpleViewFrame.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Overriden. See OnKeyUp(KeyEventArgs). (Inherited from SimpleViewFrame.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Overrides Control..::.OnLostFocus(EventArgs).)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Overriden. See OnMouseDown(MouseEventArgs). (Inherited from SimpleViewFrame.)
OnMouseEnter | Overriden. See OnMouseEnter(EventArgs). (Inherited from SimpleViewFrame.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Overrides SimpleViewFrame..::.OnMouseLeave(EventArgs).)
OnMouseMove | Overriden. See OnMouseMove(MouseEventArgs). (Inherited from SimpleViewFrame.)
OnMouseUp | Overriden. See OnMouseUp(MouseEventArgs). (Inherited from SimpleViewFrame.)
OnMouseWheel | Overriden. See OnMouseWheel(MouseEventArgs). (Inherited from SimpleViewFrame.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the OnPaint event. (Overrides SimpleViewFrame..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Overriden. See OnResize(EventArgs). (Inherited from SimpleViewFrame.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Occurs when size is changed. (Overrides Control..::.OnSizeChanged(EventArgs).)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateView | Implements UpdateView()()(). (Inherited from SimpleViewFrame.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFocusRectangle | Gets or sets value that determines if rectangle border will be hidden, when the Widget gets focus.
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
Instrument | Gets or sets the instrument.
InstrumentationStream | Gets or sets the instrument serialized to a string.
InvalidateInterval | Gets or sets interval for the instrument re-drawing.
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewRectangle | Gets the size of client rectangle. (Inherited from SimpleViewFrame.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
ZoomScale | Gets or sets zoom for displaying the instrument.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InstrumentLoad | Occurs when the instrument is loaded.
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

Widget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Widget Constructor

[image]

.NET ModelKit Suite ClassReference
Widget Constructor
Widget Class See Also Send Feedback
Creates a new instant of the Widget class.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Widget()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Widget()

See Also

Widget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Widget Methods

[image] [image]

.NET ModelKit Suite ClassReference
Widget Methods
Widget Class See Also Send Feedback

The Widget type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetElementAt | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnableChanged event. (Overrides Control..::.OnEnabledChanged(EventArgs).)
OnEnter | Overriden. See OnEnter(EventArgs). (Inherited from SimpleViewFrame.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Overrides Control..::.OnGotFocus(EventArgs).)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInstrumentLoad | Raises the InstrumentLoad event.
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Overriden. See OnKeyDown(KeyEventArgs). (Inherited from SimpleViewFrame.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Overriden. See OnKeyUp(KeyEventArgs). (Inherited from SimpleViewFrame.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Overrides Control..::.OnLostFocus(EventArgs).)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Overriden. See OnMouseDown(MouseEventArgs). (Inherited from SimpleViewFrame.)
OnMouseEnter | Overriden. See OnMouseEnter(EventArgs). (Inherited from SimpleViewFrame.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Overrides SimpleViewFrame..::.OnMouseLeave(EventArgs).)
OnMouseMove | Overriden. See OnMouseMove(MouseEventArgs). (Inherited from SimpleViewFrame.)
OnMouseUp | Overriden. See OnMouseUp(MouseEventArgs). (Inherited from SimpleViewFrame.)
OnMouseWheel | Overriden. See OnMouseWheel(MouseEventArgs). (Inherited from SimpleViewFrame.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the OnPaint event. (Overrides SimpleViewFrame..::.OnPaint(PaintEventArgs).)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Overriden. See OnResize(EventArgs). (Inherited from SimpleViewFrame.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Occurs when size is changed. (Overrides Control..::.OnSizeChanged(EventArgs).)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateView | Implements UpdateView()()(). (Inherited from SimpleViewFrame.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

Widget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
Widget..::.AccessibilityNotifyClients Method
Widget Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

Widget Class
Widget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
Widget..::.BeginInvoke Method
Widget Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

Widget Class
Widget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
Widget..::.Dispose Method
Widget Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

Widget Class
Widget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
Widget..::.GetChildAtPoint Method
Widget Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

Widget Class
Widget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


GetElementAt Method

[image] [image]

.NET ModelKit Suite ClassReference
Widget..::.GetElementAt Method
Widget Class See Also Send Feedback

Overload List

Name | Description
GetElementAt(Point) | Returns the element that belongs to the instrument and is located in the specified point.
GetElementAt(Int32, Int32) | Returns the element that belongs to the instrument and is located in the point with specified coordinates.

See Also

Widget Class
Widget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


GetElementAt Method (Point)

[image]

.NET ModelKit Suite ClassReference
Widget..::.GetElementAt Method (Point)
Widget Class See Also Send Feedback
Returns the element that belongs to the instrument and is located in the specified point.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Element GetElementAt(
    Point point
)
Visual Basic (Declaration)
Public Function GetElementAt ( _
    point As Point _
) As Element
Visual C++
public:
Element^ GetElementAt(
    Point point
)

Parameters

point
Type: System.Drawing..::.Point

See Also

Widget Class
GetElementAt Overload
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


GetElementAt Method (Int32, Int32)

[image]

.NET ModelKit Suite ClassReference
Widget..::.GetElementAt Method (Int32, Int32)
Widget Class See Also Send Feedback
Returns the element that belongs to the instrument and is located in the point with specified coordinates.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Element GetElementAt(
    int x,
    int y
)
Visual Basic (Declaration)
Public Function GetElementAt ( _
    x As Integer, _
    y As Integer _
) As Element
Visual C++
public:
Element^ GetElementAt(
    int x,
    int y
)

Parameters

x
Type: System..::.Int32
y
Type: System..::.Int32

See Also

Widget Class
GetElementAt Overload
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
Widget..::.Invalidate Method
Widget Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

Widget Class
Widget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
Widget..::.Invoke Method
Widget Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

Widget Class
Widget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
Widget..::.MemberwiseClone Method
Widget Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

Widget Class
Widget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


OnEnabledChanged Method

[image]

.NET ModelKit Suite ClassReference
Widget..::.OnEnabledChanged Method
Widget Class See Also Send Feedback
Raises the EnableChanged event.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnEnabledChanged(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnEnabledChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnEnabledChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

Widget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


OnGotFocus Method

[image]

.NET ModelKit Suite ClassReference
Widget..::.OnGotFocus Method
Widget Class See Also Send Feedback
Raises the GotFocus event.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnGotFocus(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnGotFocus ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnGotFocus(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

Widget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


OnInstrumentLoad Method

[image]

.NET ModelKit Suite ClassReference
Widget..::.OnInstrumentLoad Method
Widget Class See Also Send Feedback
Raises the InstrumentLoad event.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnInstrumentLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnInstrumentLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnInstrumentLoad(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

See Also

Widget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
Widget..::.OnLoad Method
Widget Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Instrumentation.Windows.Forms.Widget.OnLoad(System.EventArgs)]

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

Widget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


OnLostFocus Method

[image]

.NET ModelKit Suite ClassReference
Widget..::.OnLostFocus Method
Widget Class See Also Send Feedback
Raises the LostFocus event.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLostFocus(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLostFocus ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLostFocus(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

Widget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


OnMouseLeave Method

[image]

.NET ModelKit Suite ClassReference
Widget..::.OnMouseLeave Method
Widget Class See Also Send Feedback
Raises the MouseLeave event.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

Widget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


OnPaint Method

[image]

.NET ModelKit Suite ClassReference
Widget..::.OnPaint Method
Widget Class See Also Send Feedback
Raises the OnPaint event.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.PaintEventArgs

See Also

Widget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


OnSizeChanged Method

[image]

.NET ModelKit Suite ClassReference
Widget..::.OnSizeChanged Method
Widget Class See Also Send Feedback
Occurs when size is changed.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnSizeChanged(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnSizeChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSizeChanged(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

Widget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
Widget..::.PerformLayout Method
Widget Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

Widget Class
Widget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
Widget..::.ResumeLayout Method
Widget Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

Widget Class
Widget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
Widget..::.RtlTranslateAlignment Method
Widget Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

Widget Class
Widget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
Widget..::.Scale Method
Widget Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

Widget Class
Widget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
Widget..::.Select Method
Widget Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

Widget Class
Widget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
Widget..::.SetBounds Method
Widget Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

Widget Class
Widget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
Widget..::.UpdateBounds Method
Widget Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

Widget Class
Widget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
Widget..::.Validate Method
Widget Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

Widget Class
Widget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
Widget..::.ValidateChildren Method
Widget Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

Widget Class
Widget Members
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Widget Properties

[image] [image]

.NET ModelKit Suite ClassReference
Widget Properties
Widget Class See Also Send Feedback

The Widget type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HideFocusRectangle | Gets or sets value that determines if rectangle border will be hidden, when the Widget gets focus.
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
Instrument | Gets or sets the instrument.
InstrumentationStream | Gets or sets the instrument serialized to a string.
InvalidateInterval | Gets or sets interval for the instrument re-drawing.
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewRectangle | Gets the size of client rectangle. (Inherited from SimpleViewFrame.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
ZoomScale | Gets or sets zoom for displaying the instrument.

See Also

Widget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


HideFocusRectangle Property

[image]

.NET ModelKit Suite ClassReference
Widget..::.HideFocusRectangle Property
Widget Class See Also Send Feedback
Gets or sets value that determines if rectangle border will be hidden, when the Widget gets focus.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public bool HideFocusRectangle { get; set; }
Visual Basic (Declaration)
Public Property HideFocusRectangle As Boolean
Visual C++
public:
property bool HideFocusRectangle {
    bool get ();
    void set (bool value);
}

See Also

Widget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Instrument Property

[image]

.NET ModelKit Suite ClassReference
Widget..::.Instrument Property
Widget Class See Also Send Feedback
Gets or sets the instrument.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public Instrument Instrument { get; set; }
Visual Basic (Declaration)
Public Property Instrument As Instrument
Visual C++
public:
virtual property Instrument^ Instrument {
    Instrument^ get () sealed;
    void set (Instrument^ value) sealed;
}

See Also

Widget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


InstrumentationStream Property

[image]

.NET ModelKit Suite ClassReference
Widget..::.InstrumentationStream Property
Widget Class See Also Send Feedback
Gets or sets the instrument serialized to a string.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public string InstrumentationStream { get; set; }
Visual Basic (Declaration)
Public Property InstrumentationStream As String
Visual C++
public:
property String^ InstrumentationStream {
    String^ get ();
    void set (String^ value);
}

See Also

Widget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


InvalidateInterval Property

[image]

.NET ModelKit Suite ClassReference
Widget..::.InvalidateInterval Property
Widget Class See Also Send Feedback
Gets or sets interval for the instrument re-drawing.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public int InvalidateInterval { get; set; }
Visual Basic (Declaration)
Public Property InvalidateInterval As Integer
Visual C++
public:
property int InvalidateInterval {
    int get ();
    void set (int value);
}

See Also

Widget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


ZoomScale Property

[image]

.NET ModelKit Suite ClassReference
Widget..::.ZoomScale Property
Widget Class See Also Send Feedback
Gets or sets zoom for displaying the instrument.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public double ZoomScale { get; set; }
Visual Basic (Declaration)
Public Property ZoomScale As Double
Visual C++
public:
property double ZoomScale {
    double get ();
    void set (double value);
}

See Also

Widget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


Widget Events

[image] [image]

.NET ModelKit Suite ClassReference
Widget Events
Widget Class See Also Send Feedback

The Widget type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InstrumentLoad | Occurs when the instrument is loaded.
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

Widget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


InstrumentLoad Event

[image]

.NET ModelKit Suite ClassReference
Widget..::.InstrumentLoad Event
Widget Class See Also Send Feedback
Occurs when the instrument is loaded.

Namespace: PerpetuumSoft.Instrumentation.Windows.Forms
Assembly: PerpetuumSoft.Instrumentation (in PerpetuumSoft.Instrumentation.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler InstrumentLoad
Visual Basic (Declaration)
Public Event InstrumentLoad As EventHandler
Visual C++
public:
 event EventHandler^ InstrumentLoad {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

Widget Class
PerpetuumSoft.Instrumentation.Windows.Forms Namespace


PerpetuumSoft.Olap Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Olap Namespace
Send Feedback
The PerpetuumSoft.Olap namespace contains classes which are used to calculate a data cube.

Classes

Class | Description
AggregateFunctionFactory | Represents basic class for all factories of aggregate functions.
AggregateFunctionFactory..::.Avg | Average value.
AggregateFunctionFactory..::.Count | Count of values.
AggregateFunctionFactory..::.EstimateOfStandardDeviation | Represents an aggregate function for estimate of the standard deviation calculation.
AggregateFunctionFactory..::.EstimateOfVariance | Represents an aggregate function for calculation of the estimate of the variance.
AggregateFunctionFactory..::.Kurtosis | Represents an aggregate function for kurtosis calculation.
AggregateFunctionFactory..::.Max | Maximum value among all values.
AggregateFunctionFactory..::.Median | Represents an aggregate function for median calculation.
AggregateFunctionFactory..::.Min | Minimum value among all values.
AggregateFunctionFactory..::.Skewness | Represents an aggregate function for skewness calculation.
AggregateFunctionFactory..::.StandardDeviation | Represents an aggregate function for the standard deviation calculation.
AggregateFunctionFactory..::.Sum | Sum of values.
AggregateFunctionFactory..::.Variance | Represents an aggregate function for variance calculation.
CellBorder | Represents the object used for cell border drawing.
CellEventArgs | Represents data for the CellClick event.
CellInfo | Represents information of a pivot table selected area.
CellStyle | Represents the object used for cell drawing.
DataCube | Represents data for a pivot table.
DataCubePrintDocument | Represents a reusable pivot table that sends output to a printer.
DataCubePrintSettings | Represents pivot table print settings.
DataCubeRowView | Represents view of a DataCube row or column.
DataCubeView | Represents a databindable view of a DataCube.
DrawCellEventArgs | Provides data for the DrawCell event.
DrawGridItemEventArgs | Provides data for the DrawGridItem event.
EmptyFilter | Represents an empty filter.
Field | Represents a pivot table field.
FieldItem | Represents a dimension item of a pivot table.
FieldItem..::.ErrorValue | Represents data for an incorrect field item.
FieldItem..::.NullValue | Represents an indeterminate value for FieldItem.
FieldItem..::.TotalValue | Represents data for the total item.
FieldItemCollection | Represents a collection of FieldItem.
FieldsCollection | Represents a collection of Field.
FilterByCondition | Represents the filter by the expression assigned condition for field values.
FilterByValue | Represents the filter for field values by one of its values.
FilterException | Base class for all exceptions thrown from filters.
Painter | Represents the object for drawing a pivot table in graphics.
PivotTable | Represents a pivot table.
StyleSheet | Represents a pivot table style sheet.

Interfaces

Interface | Description
IAggregateFunction | Represents an aggregate function.
IFilter | Represents a data filter.

Delegates

Delegate | Description
CellEventHandler | Represents the method that will be called when a pivot table cell is clicked.
DrawCellEventHandler | Represents the method that will handle the [E:PerpetuumSoft.Olap.Windows.Forms.DataCubeGrid.DrawCell} event of a {*T:PerpetuumSoft.Olap.Windows.Forms.DataCubeGrid}]
DrawGridItemEventHandler | Represents the method that will handle the [E:PerpetuumSoft.Olap.Windows.Forms.DataCubeGrid.DrawGridItem} event of a {*T:PerpetuumSoft.Olap.Windows.Forms.DataCubeGrid}]
FieldsCollection..::.CollectionChangeEventHandler | Represents method that will handle CollectionChanged.

Enumerations

Enumeration | Description
ControlState | Represents the control state.
Direction | Enumerates the directions.
FieldType | Enumerates a field type.
Gradient | Enumerates the gradinet fill types.
SortOrder | Enumerates the sort order.
ViewDimension | Enumerates a dimension type.


AggregateFunctionFactory Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory Class
Members See Also Send Feedback
Represents basic class for all factories of aggregate functions.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public abstract class AggregateFunctionFactory
Visual Basic (Declaration)
Public MustInherit Class AggregateFunctionFactory
Visual C++
public ref class AggregateFunctionFactory abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.Avg
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.Count
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.EstimateOfStandardDeviation
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.EstimateOfVariance
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.Kurtosis
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.Max
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.Median
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.Min
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.Skewness
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.StandardDeviation
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.Sum
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.Variance

See Also

AggregateFunctionFactory Members
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory Members
AggregateFunctionFactory Class Constructors Methods Properties See Also Send Feedback

The AggregateFunctionFactory type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory | Initializes a new instance of the AggregateFunctionFactory class

Methods

Name | Description
CreateFuntion | Returns a newly created aggregate function.
Equals | Overridden. See Equals(Object). (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Object..::.GetHashCode()()().)
GetName | Returns the aggregate function symbolic name.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
CanGetPercent | Gets the value which indicates whether the result may be represented as percentage.

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory Constructor
AggregateFunctionFactory Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory class

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
protected AggregateFunctionFactory()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
AggregateFunctionFactory()

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory Methods
AggregateFunctionFactory Class See Also Send Feedback

The AggregateFunctionFactory type exposes the following members.

Methods

Name | Description
CreateFuntion | Returns a newly created aggregate function.
Equals | Overridden. See Equals(Object). (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Object..::.GetHashCode()()().)
GetName | Returns the aggregate function symbolic name.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.CreateFuntion Method
AggregateFunctionFactory Class See Also Send Feedback
Returns a newly created aggregate function.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public abstract IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public MustOverride Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() abstract

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Olap Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Equals Method
AggregateFunctionFactory Class See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Olap Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.GetHashCode Method
AggregateFunctionFactory Class See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.GetName Method
AggregateFunctionFactory Class See Also Send Feedback
Returns the aggregate function symbolic name.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public abstract string GetName()
Visual Basic (Declaration)
Public MustOverride Function GetName As String
Visual C++
public:
virtual String^ GetName() abstract

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Olap Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.ToString Method
AggregateFunctionFactory Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory Properties
AggregateFunctionFactory Class See Also Send Feedback

The AggregateFunctionFactory type exposes the following members.

Properties

Name | Description
CanGetPercent | Gets the value which indicates whether the result may be represented as percentage.

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.CanGetPercent Property
AggregateFunctionFactory Class See Also Send Feedback
Gets the value which indicates whether the result may be represented as percentage.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public abstract bool CanGetPercent { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () abstract;
}

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Avg Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Avg Class
AggregateFunctionFactory Class Members See Also Send Feedback
Average value.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class Avg : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class Avg _
    Inherits AggregateFunctionFactory
Visual C++
public ref class Avg : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.Avg

See Also

AggregateFunctionFactory..::.Avg Members
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Avg Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Avg Members
AggregateFunctionFactory..::.Avg Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.Avg type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.Avg | Initializes a new instance of the AggregateFunctionFactory..::.Avg class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Avg Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Avg Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Avg Constructor
AggregateFunctionFactory..::.Avg Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.Avg class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Avg()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Avg()

See Also

AggregateFunctionFactory..::.Avg Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Avg Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Avg Methods
AggregateFunctionFactory..::.Avg Class See Also Send Feedback

The AggregateFunctionFactory..::.Avg type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.Avg Class
PerpetuumSoft.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Avg..::.CreateFuntion Method
AggregateFunctionFactory..::.Avg Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.Avg Class
PerpetuumSoft.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Avg..::.GetName Method
AggregateFunctionFactory..::.Avg Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.Avg Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Avg Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Avg Properties
AggregateFunctionFactory..::.Avg Class See Also Send Feedback

The AggregateFunctionFactory..::.Avg type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Avg Class
PerpetuumSoft.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Avg..::.CanGetPercent Property
AggregateFunctionFactory..::.Avg Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.Avg Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Count Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Count Class
AggregateFunctionFactory Class Members See Also Send Feedback
Count of values.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class Count : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class Count _
    Inherits AggregateFunctionFactory
Visual C++
public ref class Count : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.Count

See Also

AggregateFunctionFactory..::.Count Members
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Count Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Count Members
AggregateFunctionFactory..::.Count Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.Count type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.Count | Initializes a new instance of the AggregateFunctionFactory..::.Count class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Count Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Count Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Count Constructor
AggregateFunctionFactory..::.Count Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.Count class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Count()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Count()

See Also

AggregateFunctionFactory..::.Count Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Count Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Count Methods
AggregateFunctionFactory..::.Count Class See Also Send Feedback

The AggregateFunctionFactory..::.Count type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.Count Class
PerpetuumSoft.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Count..::.CreateFuntion Method
AggregateFunctionFactory..::.Count Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.Count Class
PerpetuumSoft.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Count..::.GetName Method
AggregateFunctionFactory..::.Count Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.Count Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Count Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Count Properties
AggregateFunctionFactory..::.Count Class See Also Send Feedback

The AggregateFunctionFactory..::.Count type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Count Class
PerpetuumSoft.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Count..::.CanGetPercent Property
AggregateFunctionFactory..::.Count Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.Count Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.EstimateOfStandardDeviation Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfStandardDeviation Class
AggregateFunctionFactory Class Members See Also Send Feedback
Represents an aggregate function for estimate of the standard deviation calculation.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class EstimateOfStandardDeviation : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class EstimateOfStandardDeviation _
    Inherits AggregateFunctionFactory
Visual C++
public ref class EstimateOfStandardDeviation : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.EstimateOfStandardDeviation

See Also

AggregateFunctionFactory..::.EstimateOfStandardDeviation Members
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.EstimateOfStandardDeviation Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfStandardDeviation Members
AggregateFunctionFactory..::.EstimateOfStandardDeviation Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.EstimateOfStandardDeviation type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.EstimateOfStandardDeviation | Initializes a new instance of the AggregateFunctionFactory..::.EstimateOfStandardDeviation class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.EstimateOfStandardDeviation Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.EstimateOfStandardDeviation Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfStandardDeviation Constructor
AggregateFunctionFactory..::.EstimateOfStandardDeviation Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.EstimateOfStandardDeviation class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public EstimateOfStandardDeviation()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EstimateOfStandardDeviation()

See Also

AggregateFunctionFactory..::.EstimateOfStandardDeviation Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.EstimateOfStandardDeviation Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfStandardDeviation Methods
AggregateFunctionFactory..::.EstimateOfStandardDeviation Class See Also Send Feedback

The AggregateFunctionFactory..::.EstimateOfStandardDeviation type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.EstimateOfStandardDeviation Class
PerpetuumSoft.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfStandardDeviation..::.CreateFuntion Method
AggregateFunctionFactory..::.EstimateOfStandardDeviation Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.EstimateOfStandardDeviation Class
PerpetuumSoft.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfStandardDeviation..::.GetName Method
AggregateFunctionFactory..::.EstimateOfStandardDeviation Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.EstimateOfStandardDeviation Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.EstimateOfStandardDeviation Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfStandardDeviation Properties
AggregateFunctionFactory..::.EstimateOfStandardDeviation Class See Also Send Feedback

The AggregateFunctionFactory..::.EstimateOfStandardDeviation type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.EstimateOfStandardDeviation Class
PerpetuumSoft.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfStandardDeviation..::.CanGetPercent Property
AggregateFunctionFactory..::.EstimateOfStandardDeviation Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.EstimateOfStandardDeviation Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.EstimateOfVariance Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfVariance Class
AggregateFunctionFactory Class Members See Also Send Feedback
Represents an aggregate function for calculation of the estimate of the variance.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class EstimateOfVariance : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class EstimateOfVariance _
    Inherits AggregateFunctionFactory
Visual C++
public ref class EstimateOfVariance : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.EstimateOfVariance

See Also

AggregateFunctionFactory..::.EstimateOfVariance Members
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.EstimateOfVariance Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfVariance Members
AggregateFunctionFactory..::.EstimateOfVariance Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.EstimateOfVariance type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.EstimateOfVariance | Initializes a new instance of the AggregateFunctionFactory..::.EstimateOfVariance class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.EstimateOfVariance Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.EstimateOfVariance Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfVariance Constructor
AggregateFunctionFactory..::.EstimateOfVariance Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.EstimateOfVariance class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public EstimateOfVariance()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EstimateOfVariance()

See Also

AggregateFunctionFactory..::.EstimateOfVariance Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.EstimateOfVariance Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfVariance Methods
AggregateFunctionFactory..::.EstimateOfVariance Class See Also Send Feedback

The AggregateFunctionFactory..::.EstimateOfVariance type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.EstimateOfVariance Class
PerpetuumSoft.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfVariance..::.CreateFuntion Method
AggregateFunctionFactory..::.EstimateOfVariance Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.EstimateOfVariance Class
PerpetuumSoft.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfVariance..::.GetName Method
AggregateFunctionFactory..::.EstimateOfVariance Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.EstimateOfVariance Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.EstimateOfVariance Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfVariance Properties
AggregateFunctionFactory..::.EstimateOfVariance Class See Also Send Feedback

The AggregateFunctionFactory..::.EstimateOfVariance type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.EstimateOfVariance Class
PerpetuumSoft.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfVariance..::.CanGetPercent Property
AggregateFunctionFactory..::.EstimateOfVariance Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.EstimateOfVariance Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Kurtosis Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Kurtosis Class
AggregateFunctionFactory Class Members See Also Send Feedback
Represents an aggregate function for kurtosis calculation.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class Kurtosis : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class Kurtosis _
    Inherits AggregateFunctionFactory
Visual C++
public ref class Kurtosis : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.Kurtosis

See Also

AggregateFunctionFactory..::.Kurtosis Members
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Kurtosis Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Kurtosis Members
AggregateFunctionFactory..::.Kurtosis Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.Kurtosis type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.Kurtosis | Initializes a new instance of the AggregateFunctionFactory..::.Kurtosis class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Kurtosis Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Kurtosis Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Kurtosis Constructor
AggregateFunctionFactory..::.Kurtosis Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.Kurtosis class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Kurtosis()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Kurtosis()

See Also

AggregateFunctionFactory..::.Kurtosis Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Kurtosis Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Kurtosis Methods
AggregateFunctionFactory..::.Kurtosis Class See Also Send Feedback

The AggregateFunctionFactory..::.Kurtosis type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.Kurtosis Class
PerpetuumSoft.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Kurtosis..::.CreateFuntion Method
AggregateFunctionFactory..::.Kurtosis Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.Kurtosis Class
PerpetuumSoft.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Kurtosis..::.GetName Method
AggregateFunctionFactory..::.Kurtosis Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.Kurtosis Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Kurtosis Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Kurtosis Properties
AggregateFunctionFactory..::.Kurtosis Class See Also Send Feedback

The AggregateFunctionFactory..::.Kurtosis type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Kurtosis Class
PerpetuumSoft.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Kurtosis..::.CanGetPercent Property
AggregateFunctionFactory..::.Kurtosis Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.Kurtosis Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Max Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Max Class
AggregateFunctionFactory Class Members See Also Send Feedback
Maximum value among all values.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class Max : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class Max _
    Inherits AggregateFunctionFactory
Visual C++
public ref class Max : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.Max

See Also

AggregateFunctionFactory..::.Max Members
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Max Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Max Members
AggregateFunctionFactory..::.Max Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.Max type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.Max | Initializes a new instance of the AggregateFunctionFactory..::.Max class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Max Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Max Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Max Constructor
AggregateFunctionFactory..::.Max Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.Max class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Max()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Max()

See Also

AggregateFunctionFactory..::.Max Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Max Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Max Methods
AggregateFunctionFactory..::.Max Class See Also Send Feedback

The AggregateFunctionFactory..::.Max type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.Max Class
PerpetuumSoft.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Max..::.CreateFuntion Method
AggregateFunctionFactory..::.Max Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.Max Class
PerpetuumSoft.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Max..::.GetName Method
AggregateFunctionFactory..::.Max Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.Max Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Max Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Max Properties
AggregateFunctionFactory..::.Max Class See Also Send Feedback

The AggregateFunctionFactory..::.Max type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Max Class
PerpetuumSoft.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Max..::.CanGetPercent Property
AggregateFunctionFactory..::.Max Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.Max Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Median Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Median Class
AggregateFunctionFactory Class Members See Also Send Feedback
Represents an aggregate function for median calculation.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class Median : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class Median _
    Inherits AggregateFunctionFactory
Visual C++
public ref class Median : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.Median

See Also

AggregateFunctionFactory..::.Median Members
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Median Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Median Members
AggregateFunctionFactory..::.Median Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.Median type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.Median | Initializes a new instance of the AggregateFunctionFactory..::.Median class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Median Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Median Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Median Constructor
AggregateFunctionFactory..::.Median Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.Median class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Median()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Median()

See Also

AggregateFunctionFactory..::.Median Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Median Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Median Methods
AggregateFunctionFactory..::.Median Class See Also Send Feedback

The AggregateFunctionFactory..::.Median type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.Median Class
PerpetuumSoft.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Median..::.CreateFuntion Method
AggregateFunctionFactory..::.Median Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.Median Class
PerpetuumSoft.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Median..::.GetName Method
AggregateFunctionFactory..::.Median Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.Median Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Median Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Median Properties
AggregateFunctionFactory..::.Median Class See Also Send Feedback

The AggregateFunctionFactory..::.Median type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Median Class
PerpetuumSoft.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Median..::.CanGetPercent Property
AggregateFunctionFactory..::.Median Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.Median Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Min Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Min Class
AggregateFunctionFactory Class Members See Also Send Feedback
Minimum value among all values.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class Min : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class Min _
    Inherits AggregateFunctionFactory
Visual C++
public ref class Min : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.Min

See Also

AggregateFunctionFactory..::.Min Members
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Min Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Min Members
AggregateFunctionFactory..::.Min Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.Min type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.Min | Initializes a new instance of the AggregateFunctionFactory..::.Min class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Min Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Min Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Min Constructor
AggregateFunctionFactory..::.Min Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.Min class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Min()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Min()

See Also

AggregateFunctionFactory..::.Min Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Min Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Min Methods
AggregateFunctionFactory..::.Min Class See Also Send Feedback

The AggregateFunctionFactory..::.Min type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.Min Class
PerpetuumSoft.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Min..::.CreateFuntion Method
AggregateFunctionFactory..::.Min Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.Min Class
PerpetuumSoft.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Min..::.GetName Method
AggregateFunctionFactory..::.Min Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.Min Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Min Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Min Properties
AggregateFunctionFactory..::.Min Class See Also Send Feedback

The AggregateFunctionFactory..::.Min type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Min Class
PerpetuumSoft.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Min..::.CanGetPercent Property
AggregateFunctionFactory..::.Min Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.Min Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Skewness Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Skewness Class
AggregateFunctionFactory Class Members See Also Send Feedback
Represents an aggregate function for skewness calculation.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class Skewness : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class Skewness _
    Inherits AggregateFunctionFactory
Visual C++
public ref class Skewness : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.Skewness

See Also

AggregateFunctionFactory..::.Skewness Members
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Skewness Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Skewness Members
AggregateFunctionFactory..::.Skewness Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.Skewness type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.Skewness | Initializes a new instance of the AggregateFunctionFactory..::.Skewness class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Skewness Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Skewness Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Skewness Constructor
AggregateFunctionFactory..::.Skewness Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.Skewness class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Skewness()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Skewness()

See Also

AggregateFunctionFactory..::.Skewness Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Skewness Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Skewness Methods
AggregateFunctionFactory..::.Skewness Class See Also Send Feedback

The AggregateFunctionFactory..::.Skewness type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.Skewness Class
PerpetuumSoft.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Skewness..::.CreateFuntion Method
AggregateFunctionFactory..::.Skewness Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.Skewness Class
PerpetuumSoft.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Skewness..::.GetName Method
AggregateFunctionFactory..::.Skewness Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.Skewness Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Skewness Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Skewness Properties
AggregateFunctionFactory..::.Skewness Class See Also Send Feedback

The AggregateFunctionFactory..::.Skewness type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Skewness Class
PerpetuumSoft.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Skewness..::.CanGetPercent Property
AggregateFunctionFactory..::.Skewness Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.Skewness Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.StandardDeviation Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.StandardDeviation Class
AggregateFunctionFactory Class Members See Also Send Feedback
Represents an aggregate function for the standard deviation calculation.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class StandardDeviation : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class StandardDeviation _
    Inherits AggregateFunctionFactory
Visual C++
public ref class StandardDeviation : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.StandardDeviation

See Also

AggregateFunctionFactory..::.StandardDeviation Members
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.StandardDeviation Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.StandardDeviation Members
AggregateFunctionFactory..::.StandardDeviation Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.StandardDeviation type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.StandardDeviation | Initializes a new instance of the AggregateFunctionFactory..::.StandardDeviation class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.StandardDeviation Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.StandardDeviation Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.StandardDeviation Constructor
AggregateFunctionFactory..::.StandardDeviation Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.StandardDeviation class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public StandardDeviation()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StandardDeviation()

See Also

AggregateFunctionFactory..::.StandardDeviation Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.StandardDeviation Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.StandardDeviation Methods
AggregateFunctionFactory..::.StandardDeviation Class See Also Send Feedback

The AggregateFunctionFactory..::.StandardDeviation type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.StandardDeviation Class
PerpetuumSoft.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.StandardDeviation..::.CreateFuntion Method
AggregateFunctionFactory..::.StandardDeviation Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.StandardDeviation Class
PerpetuumSoft.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.StandardDeviation..::.GetName Method
AggregateFunctionFactory..::.StandardDeviation Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.StandardDeviation Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.StandardDeviation Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.StandardDeviation Properties
AggregateFunctionFactory..::.StandardDeviation Class See Also Send Feedback

The AggregateFunctionFactory..::.StandardDeviation type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.StandardDeviation Class
PerpetuumSoft.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.StandardDeviation..::.CanGetPercent Property
AggregateFunctionFactory..::.StandardDeviation Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.StandardDeviation Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Sum Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Sum Class
AggregateFunctionFactory Class Members See Also Send Feedback
Sum of values.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class Sum : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class Sum _
    Inherits AggregateFunctionFactory
Visual C++
public ref class Sum : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.Sum

See Also

AggregateFunctionFactory..::.Sum Members
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Sum Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Sum Members
AggregateFunctionFactory..::.Sum Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.Sum type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.Sum | Initializes a new instance of the AggregateFunctionFactory..::.Sum class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Sum Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Sum Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Sum Constructor
AggregateFunctionFactory..::.Sum Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.Sum class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Sum()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Sum()

See Also

AggregateFunctionFactory..::.Sum Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Sum Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Sum Methods
AggregateFunctionFactory..::.Sum Class See Also Send Feedback

The AggregateFunctionFactory..::.Sum type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.Sum Class
PerpetuumSoft.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Sum..::.CreateFuntion Method
AggregateFunctionFactory..::.Sum Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.Sum Class
PerpetuumSoft.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Sum..::.GetName Method
AggregateFunctionFactory..::.Sum Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.Sum Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Sum Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Sum Properties
AggregateFunctionFactory..::.Sum Class See Also Send Feedback

The AggregateFunctionFactory..::.Sum type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Sum Class
PerpetuumSoft.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Sum..::.CanGetPercent Property
AggregateFunctionFactory..::.Sum Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.Sum Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Variance Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Variance Class
AggregateFunctionFactory Class Members See Also Send Feedback
Represents an aggregate function for variance calculation.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class Variance : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class Variance _
    Inherits AggregateFunctionFactory
Visual C++
public ref class Variance : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Olap..::.AggregateFunctionFactory..::.Variance

See Also

AggregateFunctionFactory..::.Variance Members
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Variance Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Variance Members
AggregateFunctionFactory..::.Variance Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.Variance type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.Variance | Initializes a new instance of the AggregateFunctionFactory..::.Variance class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Variance Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Variance Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Variance Constructor
AggregateFunctionFactory..::.Variance Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.Variance class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Variance()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Variance()

See Also

AggregateFunctionFactory..::.Variance Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Variance Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Variance Methods
AggregateFunctionFactory..::.Variance Class See Also Send Feedback

The AggregateFunctionFactory..::.Variance type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.Variance Class
PerpetuumSoft.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Variance..::.CreateFuntion Method
AggregateFunctionFactory..::.Variance Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.Variance Class
PerpetuumSoft.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Variance..::.GetName Method
AggregateFunctionFactory..::.Variance Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.Variance Class
PerpetuumSoft.Olap Namespace


AggregateFunctionFactory.Variance Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Variance Properties
AggregateFunctionFactory..::.Variance Class See Also Send Feedback

The AggregateFunctionFactory..::.Variance type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Variance Class
PerpetuumSoft.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Variance..::.CanGetPercent Property
AggregateFunctionFactory..::.Variance Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.Variance Class
PerpetuumSoft.Olap Namespace


CellBorder Class

[image]

.NET ModelKit Suite ClassReference
CellBorder Class
Members See Also Send Feedback
Represents the object used for cell border drawing.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class CellBorder
Visual Basic (Declaration)
Public Class CellBorder
Visual C++
public ref class CellBorder

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.CellBorder

See Also

CellBorder Members
PerpetuumSoft.Olap Namespace


CellBorder Members

[image] [image]

.NET ModelKit Suite ClassReference
CellBorder Members
CellBorder Class Constructors Methods Properties See Also Send Feedback

The CellBorder type exposes the following members.

Constructors

Name | Description
CellBorder | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Black | Gets the CellBorder object all lines of which are of black color.
HorizontalLineColor | Gets or sets the horisontal border line color.
VerticalLineColor | 'Gets or sets the vertical border line color.

See Also

CellBorder Class
PerpetuumSoft.Olap Namespace


CellBorder Constructor

[image] [image]

.NET ModelKit Suite ClassReference
CellBorder Constructor
CellBorder Class See Also Send Feedback

Overload List

Name | Description
CellBorder()()() | Initializes a new instance of the CellBorder class.
CellBorder(Color, Color) | Initializes a new instance of the CellBorder class with specific parameters. Parameters set colors for horizontal and vertical line.

See Also

CellBorder Class
CellBorder Members
PerpetuumSoft.Olap Namespace


CellBorder Constructor

[image]

.NET ModelKit Suite ClassReference
CellBorder Constructor
CellBorder Class See Also Send Feedback
Initializes a new instance of the CellBorder class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellBorder()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CellBorder()

See Also

CellBorder Class
CellBorder Overload
PerpetuumSoft.Olap Namespace


CellBorder Constructor (Color, Color)

[image]

.NET ModelKit Suite ClassReference
CellBorder Constructor (Color, Color)
CellBorder Class See Also Send Feedback
Initializes a new instance of the CellBorder class with specific parameters. Parameters set colors for horizontal and vertical line.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellBorder(
    Color horizontalLineColor,
    Color verticalLineColor
)
Visual Basic (Declaration)
Public Sub New ( _
    horizontalLineColor As Color, _
    verticalLineColor As Color _
)
Visual C++
public:
CellBorder(
    Color horizontalLineColor,
    Color verticalLineColor
)

Parameters

horizontalLineColor
Type: System.Drawing..::.Color
verticalLineColor
Type: System.Drawing..::.Color

See Also

CellBorder Class
CellBorder Overload
PerpetuumSoft.Olap Namespace


CellBorder Methods

[image] [image]

.NET ModelKit Suite ClassReference
CellBorder Methods
CellBorder Class See Also Send Feedback

The CellBorder type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CellBorder Class
PerpetuumSoft.Olap Namespace


CellBorder Properties

[image] [image]

.NET ModelKit Suite ClassReference
CellBorder Properties
CellBorder Class See Also Send Feedback

The CellBorder type exposes the following members.

Properties

Name | Description
Black | Gets the CellBorder object all lines of which are of black color.
HorizontalLineColor | Gets or sets the horisontal border line color.
VerticalLineColor | 'Gets or sets the vertical border line color.

See Also

CellBorder Class
PerpetuumSoft.Olap Namespace


Black Property

[image]

.NET ModelKit Suite ClassReference
CellBorder..::.Black Property
CellBorder Class See Also Send Feedback
Gets the CellBorder object all lines of which are of black color.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public static CellBorder Black { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Black As CellBorder
Visual C++
public:
static property CellBorder^ Black {
    CellBorder^ get ();
}

See Also

CellBorder Class
PerpetuumSoft.Olap Namespace


HorizontalLineColor Property

[image]

.NET ModelKit Suite ClassReference
CellBorder..::.HorizontalLineColor Property
CellBorder Class See Also Send Feedback
Gets or sets the horisontal border line color.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Color HorizontalLineColor { get; set; }
Visual Basic (Declaration)
Public Property HorizontalLineColor As Color
Visual C++
public:
property Color HorizontalLineColor {
    Color get ();
    void set (Color value);
}

See Also

CellBorder Class
PerpetuumSoft.Olap Namespace


VerticalLineColor Property

[image]

.NET ModelKit Suite ClassReference
CellBorder..::.VerticalLineColor Property
CellBorder Class See Also Send Feedback
'Gets or sets the vertical border line color.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Color VerticalLineColor { get; set; }
Visual Basic (Declaration)
Public Property VerticalLineColor As Color
Visual C++
public:
property Color VerticalLineColor {
    Color get ();
    void set (Color value);
}

See Also

CellBorder Class
PerpetuumSoft.Olap Namespace


CellEventArgs Class

[image]

.NET ModelKit Suite ClassReference
CellEventArgs Class
Members See Also Send Feedback
Represents data for the CellClick event.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class CellEventArgs : EventArgs
Visual Basic (Declaration)
Public Class CellEventArgs _
    Inherits EventArgs
Visual C++
public ref class CellEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Olap..::.CellEventArgs

See Also

CellEventArgs Members
PerpetuumSoft.Olap Namespace


CellEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
CellEventArgs Members
CellEventArgs Class Constructors Methods Properties See Also Send Feedback

The CellEventArgs type exposes the following members.

Constructors

Name | Description
CellEventArgs | Initializes a new instance of the CellEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CellInfo | Gets information on a pivot table cell.

See Also

CellEventArgs Class
PerpetuumSoft.Olap Namespace


CellEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
CellEventArgs Constructor
CellEventArgs Class See Also Send Feedback
Initializes a new instance of the CellEventArgs class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellEventArgs(
    CellInfo cellInfo
)
Visual Basic (Declaration)
Public Sub New ( _
    cellInfo As CellInfo _
)
Visual C++
public:
CellEventArgs(
    CellInfo^ cellInfo
)

Parameters

cellInfo
Type: PerpetuumSoft.Olap..::.CellInfo

See Also

CellEventArgs Class
PerpetuumSoft.Olap Namespace


CellEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
CellEventArgs Methods
CellEventArgs Class See Also Send Feedback

The CellEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CellEventArgs Class
PerpetuumSoft.Olap Namespace


CellEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
CellEventArgs Properties
CellEventArgs Class See Also Send Feedback

The CellEventArgs type exposes the following members.

Properties

Name | Description
CellInfo | Gets information on a pivot table cell.

See Also

CellEventArgs Class
PerpetuumSoft.Olap Namespace


CellInfo Property

[image]

.NET ModelKit Suite ClassReference
CellEventArgs..::.CellInfo Property
CellEventArgs Class See Also Send Feedback
Gets information on a pivot table cell.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellInfo CellInfo { get; }
Visual Basic (Declaration)
Public ReadOnly Property CellInfo As CellInfo
Visual C++
public:
property CellInfo^ CellInfo {
    CellInfo^ get ();
}

See Also

CellEventArgs Class
PerpetuumSoft.Olap Namespace


CellEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
CellEventHandler Delegate
See Also Send Feedback
Represents the method that will be called when a pivot table cell is clicked.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public delegate void CellEventHandler(
    Object seneder,
    CellEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub CellEventHandler ( _
    seneder As Object, _
    e As CellEventArgs _
)
Visual C++
public delegate void CellEventHandler(
    Object^ seneder,
    CellEventArgs^ e
)

Parameters

seneder
Type: System..::.Object
e
Type: PerpetuumSoft.Olap..::.CellEventArgs

See Also

PerpetuumSoft.Olap Namespace


CellInfo Class

[image]

.NET ModelKit Suite ClassReference
CellInfo Class
Members See Also Send Feedback
Represents information of a pivot table selected area.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class CellInfo
Visual Basic (Declaration)
Public Class CellInfo
Visual C++
public ref class CellInfo

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.CellInfo

See Also

CellInfo Members
PerpetuumSoft.Olap Namespace


CellInfo Members

[image] [image]

.NET ModelKit Suite ClassReference
CellInfo Members
CellInfo Class Constructors Methods Properties See Also Send Feedback

The CellInfo type exposes the following members.

Constructors

Name | Description
CellInfo | Overloaded.

Methods

Name | Description
Equals | Overriden. See Equals(Object). (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overriden. See GetHashCode()()(). (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Column | Gets the column position for a selected cell.
ColumnShift | Gets the column shift for a selected cell.
Field | Gets the Field object that specifies a field for a selected sell.
Row | Gets the row position for a selected cell.
RowShift | Gets the row shift for a selected cell.
XFieldItem | Gets the FieldItem object that specifies an X dimension field item for a selected sell.
YFieldItem | Gets FieldItem object that specifies an Y dimension field item for a selected sell.

See Also

CellInfo Class
PerpetuumSoft.Olap Namespace


CellInfo Constructor

[image] [image]

.NET ModelKit Suite ClassReference
CellInfo Constructor
CellInfo Class See Also Send Feedback

Overload List

Name | Description
CellInfo()()() | Initializes a new instance of the CellInfo class.
CellInfo(FieldItem, FieldItem, Field, Int32, Int32) | Initializes a new instance of the CellInfo class.
CellInfo(FieldItem, FieldItem, Field, Int32, Int32, Int32, Int32) | Initializes a new instance of the CellInfo class.

See Also

CellInfo Class
CellInfo Members
PerpetuumSoft.Olap Namespace


CellInfo Constructor

[image]

.NET ModelKit Suite ClassReference
CellInfo Constructor
CellInfo Class See Also Send Feedback
Initializes a new instance of the CellInfo class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CellInfo()

See Also

CellInfo Class
CellInfo Overload
PerpetuumSoft.Olap Namespace


CellInfo Constructor (FieldItem, FieldItem, Field, Int32, Int32)

[image]

.NET ModelKit Suite ClassReference
CellInfo Constructor (FieldItem, FieldItem, Field, Int32, Int32)
CellInfo Class See Also Send Feedback
Initializes a new instance of the CellInfo class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellInfo(
    FieldItem xItem,
    FieldItem yItem,
    Field field,
    int row,
    int column
)
Visual Basic (Declaration)
Public Sub New ( _
    xItem As FieldItem, _
    yItem As FieldItem, _
    field As Field, _
    row As Integer, _
    column As Integer _
)
Visual C++
public:
CellInfo(
    FieldItem^ xItem,
    FieldItem^ yItem,
    Field^ field,
    int row,
    int column
)

Parameters

xItem
Type: PerpetuumSoft.Olap..::.FieldItem
yItem
Type: PerpetuumSoft.Olap..::.FieldItem
field
Type: PerpetuumSoft.Olap..::.Field
row
Type: System..::.Int32
column
Type: System..::.Int32

See Also

CellInfo Class
CellInfo Overload
PerpetuumSoft.Olap Namespace


CellInfo Constructor (FieldItem, FieldItem, Field, Int32, Int32, Int32, Int32)

[image]

.NET ModelKit Suite ClassReference
CellInfo Constructor (FieldItem, FieldItem, Field, Int32, Int32, Int32, Int32)
CellInfo Class See Also Send Feedback
Initializes a new instance of the CellInfo class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellInfo(
    FieldItem xItem,
    FieldItem yItem,
    Field field,
    int row,
    int column,
    int rowShift,
    int columnShift
)
Visual Basic (Declaration)
Public Sub New ( _
    xItem As FieldItem, _
    yItem As FieldItem, _
    field As Field, _
    row As Integer, _
    column As Integer, _
    rowShift As Integer, _
    columnShift As Integer _
)
Visual C++
public:
CellInfo(
    FieldItem^ xItem,
    FieldItem^ yItem,
    Field^ field,
    int row,
    int column,
    int rowShift,
    int columnShift
)

Parameters

xItem
Type: PerpetuumSoft.Olap..::.FieldItem
yItem
Type: PerpetuumSoft.Olap..::.FieldItem
field
Type: PerpetuumSoft.Olap..::.Field
row
Type: System..::.Int32
column
Type: System..::.Int32
rowShift
Type: System..::.Int32
columnShift
Type: System..::.Int32

See Also

CellInfo Class
CellInfo Overload
PerpetuumSoft.Olap Namespace


CellInfo Methods

[image] [image]

.NET ModelKit Suite ClassReference
CellInfo Methods
CellInfo Class See Also Send Feedback

The CellInfo type exposes the following members.

Methods

Name | Description
Equals | Overriden. See Equals(Object). (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overriden. See GetHashCode()()(). (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CellInfo Class
PerpetuumSoft.Olap Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
CellInfo..::.Equals Method
CellInfo Class See Also Send Feedback
Overriden. See Equals(Object).

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

CellInfo Class
PerpetuumSoft.Olap Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
CellInfo..::.GetHashCode Method
CellInfo Class See Also Send Feedback
Overriden. See GetHashCode()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

CellInfo Class
PerpetuumSoft.Olap Namespace


CellInfo Properties

[image] [image]

.NET ModelKit Suite ClassReference
CellInfo Properties
CellInfo Class See Also Send Feedback

The CellInfo type exposes the following members.

Properties

Name | Description
Column | Gets the column position for a selected cell.
ColumnShift | Gets the column shift for a selected cell.
Field | Gets the Field object that specifies a field for a selected sell.
Row | Gets the row position for a selected cell.
RowShift | Gets the row shift for a selected cell.
XFieldItem | Gets the FieldItem object that specifies an X dimension field item for a selected sell.
YFieldItem | Gets FieldItem object that specifies an Y dimension field item for a selected sell.

See Also

CellInfo Class
PerpetuumSoft.Olap Namespace


Column Property

[image]

.NET ModelKit Suite ClassReference
CellInfo..::.Column Property
CellInfo Class See Also Send Feedback
Gets the column position for a selected cell.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public int Column { get; }
Visual Basic (Declaration)
Public ReadOnly Property Column As Integer
Visual C++
public:
property int Column {
    int get ();
}

See Also

CellInfo Class
PerpetuumSoft.Olap Namespace


ColumnShift Property

[image]

.NET ModelKit Suite ClassReference
CellInfo..::.ColumnShift Property
CellInfo Class See Also Send Feedback
Gets the column shift for a selected cell.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public int ColumnShift { get; }
Visual Basic (Declaration)
Public ReadOnly Property ColumnShift As Integer
Visual C++
public:
property int ColumnShift {
    int get ();
}

See Also

CellInfo Class
PerpetuumSoft.Olap Namespace


Field Property

[image]

.NET ModelKit Suite ClassReference
CellInfo..::.Field Property
CellInfo Class See Also Send Feedback
Gets the Field object that specifies a field for a selected sell.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Field Field { get; }
Visual Basic (Declaration)
Public ReadOnly Property Field As Field
Visual C++
public:
property Field^ Field {
    Field^ get ();
}

See Also

CellInfo Class
PerpetuumSoft.Olap Namespace


Row Property

[image]

.NET ModelKit Suite ClassReference
CellInfo..::.Row Property
CellInfo Class See Also Send Feedback
Gets the row position for a selected cell.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public int Row { get; }
Visual Basic (Declaration)
Public ReadOnly Property Row As Integer
Visual C++
public:
property int Row {
    int get ();
}

See Also

CellInfo Class
PerpetuumSoft.Olap Namespace


RowShift Property

[image]

.NET ModelKit Suite ClassReference
CellInfo..::.RowShift Property
CellInfo Class See Also Send Feedback
Gets the row shift for a selected cell.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public int RowShift { get; }
Visual Basic (Declaration)
Public ReadOnly Property RowShift As Integer
Visual C++
public:
property int RowShift {
    int get ();
}

See Also

CellInfo Class
PerpetuumSoft.Olap Namespace


XFieldItem Property

[image]

.NET ModelKit Suite ClassReference
CellInfo..::.XFieldItem Property
CellInfo Class See Also Send Feedback
Gets the FieldItem object that specifies an X dimension field item for a selected sell.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem XFieldItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property XFieldItem As FieldItem
Visual C++
public:
property FieldItem^ XFieldItem {
    FieldItem^ get ();
}

See Also

CellInfo Class
PerpetuumSoft.Olap Namespace


YFieldItem Property

[image]

.NET ModelKit Suite ClassReference
CellInfo..::.YFieldItem Property
CellInfo Class See Also Send Feedback
Gets FieldItem object that specifies an Y dimension field item for a selected sell.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem YFieldItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property YFieldItem As FieldItem
Visual C++
public:
property FieldItem^ YFieldItem {
    FieldItem^ get ();
}

See Also

CellInfo Class
PerpetuumSoft.Olap Namespace


CellStyle Class

[image]

.NET ModelKit Suite ClassReference
CellStyle Class
Members See Also Send Feedback
Represents the object used for cell drawing.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class CellStyle
Visual Basic (Declaration)
Public Class CellStyle
Visual C++
public ref class CellStyle

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.CellStyle

See Also

CellStyle Members
PerpetuumSoft.Olap Namespace


CellStyle Members

[image] [image]

.NET ModelKit Suite ClassReference
CellStyle Members
CellStyle Class Constructors Methods Properties See Also Send Feedback

The CellStyle type exposes the following members.

Constructors

Name | Description
CellStyle | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStringWidth | Returns string width in pixels.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BackColor | Gets or sets cell text background color.
ContentAlignment | Gets or sets text aligment type within a cell.
Font | Gets or sets cell text font.
ForeColor | Gets or sets cell text fore color.
Gradient | Gets or sets the type of gradient fill for cell text.
GradientBackColor | Gets or sets cell text gradient background color.
ProgressBarColor | Gets or sets cell text progress color.

See Also

CellStyle Class
PerpetuumSoft.Olap Namespace


CellStyle Constructor

[image] [image]

.NET ModelKit Suite ClassReference
CellStyle Constructor
CellStyle Class See Also Send Feedback

Overload List

Name | Description
CellStyle()()() | Initializes a new instance of the CellStyle class.
CellStyle(Color, Color) | Initializes a new instance of the CellStyle class with specified back color and fore color.

See Also

CellStyle Class
CellStyle Members
PerpetuumSoft.Olap Namespace


CellStyle Constructor

[image]

.NET ModelKit Suite ClassReference
CellStyle Constructor
CellStyle Class See Also Send Feedback
Initializes a new instance of the CellStyle class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellStyle()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CellStyle()

See Also

CellStyle Class
CellStyle Overload
PerpetuumSoft.Olap Namespace


CellStyle Constructor (Color, Color)

[image]

.NET ModelKit Suite ClassReference
CellStyle Constructor (Color, Color)
CellStyle Class See Also Send Feedback
Initializes a new instance of the CellStyle class with specified back color and fore color.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellStyle(
    Color backColor,
    Color foreColor
)
Visual Basic (Declaration)
Public Sub New ( _
    backColor As Color, _
    foreColor As Color _
)
Visual C++
public:
CellStyle(
    Color backColor,
    Color foreColor
)

Parameters

backColor
Type: System.Drawing..::.Color
foreColor
Type: System.Drawing..::.Color

See Also

CellStyle Class
CellStyle Overload
PerpetuumSoft.Olap Namespace


CellStyle Methods

[image] [image]

.NET ModelKit Suite ClassReference
CellStyle Methods
CellStyle Class See Also Send Feedback

The CellStyle type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStringWidth | Returns string width in pixels.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CellStyle Class
PerpetuumSoft.Olap Namespace


GetStringWidth Method

[image]

.NET ModelKit Suite ClassReference
CellStyle..::.GetStringWidth Method
CellStyle Class See Also Send Feedback
Returns string width in pixels.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public float GetStringWidth(
    Graphics graphics,
    string text
)
Visual Basic (Declaration)
Public Function GetStringWidth ( _
    graphics As Graphics, _
    text As String _
) As Single
Visual C++
public:
float GetStringWidth(
    Graphics^ graphics,
    String^ text
)

Parameters

graphics
Type: System.Drawing..::.Graphics
text
Type: System..::.String

See Also

CellStyle Class
PerpetuumSoft.Olap Namespace


CellStyle Properties

[image] [image]

.NET ModelKit Suite ClassReference
CellStyle Properties
CellStyle Class See Also Send Feedback

The CellStyle type exposes the following members.

Properties

Name | Description
BackColor | Gets or sets cell text background color.
ContentAlignment | Gets or sets text aligment type within a cell.
Font | Gets or sets cell text font.
ForeColor | Gets or sets cell text fore color.
Gradient | Gets or sets the type of gradient fill for cell text.
GradientBackColor | Gets or sets cell text gradient background color.
ProgressBarColor | Gets or sets cell text progress color.

See Also

CellStyle Class
PerpetuumSoft.Olap Namespace


BackColor Property

[image]

.NET ModelKit Suite ClassReference
CellStyle..::.BackColor Property
CellStyle Class See Also Send Feedback
Gets or sets cell text background color.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Color BackColor { get; set; }
Visual Basic (Declaration)
Public Property BackColor As Color
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}

See Also

CellStyle Class
PerpetuumSoft.Olap Namespace


ContentAlignment Property

[image]

.NET ModelKit Suite ClassReference
CellStyle..::.ContentAlignment Property
CellStyle Class See Also Send Feedback
Gets or sets text aligment type within a cell.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public ContentAlignment ContentAlignment { get; set; }
Visual Basic (Declaration)
Public Property ContentAlignment As ContentAlignment
Visual C++
public:
property ContentAlignment ContentAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

CellStyle Class
PerpetuumSoft.Olap Namespace


Font Property

[image]

.NET ModelKit Suite ClassReference
CellStyle..::.Font Property
CellStyle Class See Also Send Feedback
Gets or sets cell text font.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Font Font { get; set; }
Visual Basic (Declaration)
Public Property Font As Font
Visual C++
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

See Also

CellStyle Class
PerpetuumSoft.Olap Namespace


ForeColor Property

[image]

.NET ModelKit Suite ClassReference
CellStyle..::.ForeColor Property
CellStyle Class See Also Send Feedback
Gets or sets cell text fore color.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Color ForeColor { get; set; }
Visual Basic (Declaration)
Public Property ForeColor As Color
Visual C++
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}

See Also

CellStyle Class
PerpetuumSoft.Olap Namespace


Gradient Property

[image]

.NET ModelKit Suite ClassReference
CellStyle..::.Gradient Property
CellStyle Class See Also Send Feedback
Gets or sets the type of gradient fill for cell text.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Gradient Gradient { get; set; }
Visual Basic (Declaration)
Public Property Gradient As Gradient
Visual C++
public:
property Gradient Gradient {
    Gradient get ();
    void set (Gradient value);
}

See Also

CellStyle Class
PerpetuumSoft.Olap Namespace


GradientBackColor Property

[image]

.NET ModelKit Suite ClassReference
CellStyle..::.GradientBackColor Property
CellStyle Class See Also Send Feedback
Gets or sets cell text gradient background color.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Color GradientBackColor { get; set; }
Visual Basic (Declaration)
Public Property GradientBackColor As Color
Visual C++
public:
property Color GradientBackColor {
    Color get ();
    void set (Color value);
}

See Also

CellStyle Class
PerpetuumSoft.Olap Namespace


ProgressBarColor Property

[image]

.NET ModelKit Suite ClassReference
CellStyle..::.ProgressBarColor Property
CellStyle Class See Also Send Feedback
Gets or sets cell text progress color.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Color ProgressBarColor { get; set; }
Visual Basic (Declaration)
Public Property ProgressBarColor As Color
Visual C++
public:
property Color ProgressBarColor {
    Color get ();
    void set (Color value);
}

See Also

CellStyle Class
PerpetuumSoft.Olap Namespace


ControlState Enumeration

[image]

.NET ModelKit Suite ClassReference
ControlState Enumeration
See Also Send Feedback
Represents the control state.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public enum ControlState
Visual Basic (Declaration)
Public Enumeration ControlState
Visual C++
public enum class ControlState

Members

Member name | Description
Normal | Control is in normal state.
Hot | Control is in hot state.
Pressed | Control is in pressed state.

See Also

PerpetuumSoft.Olap Namespace


DataCube Class

[image]

.NET ModelKit Suite ClassReference
DataCube Class
Members See Also Send Feedback
Represents data for a pivot table.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class DataCube : Component, IServiceProvider
Visual Basic (Declaration)
Public Class DataCube _
    Inherits Component _
    Implements IServiceProvider
Visual C++
public ref class DataCube : public Component,
    IServiceProvider

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Olap..::.DataCube

See Also

DataCube Members
PerpetuumSoft.Olap Namespace


DataCube Members

[image] [image]

.NET ModelKit Suite ClassReference
DataCube Members
DataCube Class Constructors Methods Properties Events See Also Send Feedback

The DataCube type exposes the following members.

Constructors

Name | Description
DataCube | Initializes a new instance of the DataCube class.

Methods

Name | Description
CancelRecalculate | Stops pivot table calculation.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportToExcel | Overloaded.
ExportToHtml | Overloaded.
ExportToPdf | Overloaded.
Fill | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPercentValueByCell | Returns percentage value for a given pivot table cell.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSourceRowsByCell | Returns IList that contains data source rows for a given pivot table cell.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueByCell | Returns value for a given pivot table cell.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Load | Overloaded.
MemberwiseClone | Overloaded.
Print | Overloaded.
PrintPreview | Overloaded.
Recalculate | Recalculates a pivot table.
Save | Overloaded.
StartRecalculate | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Caption | Gets or sets a title for a pivot table.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSource | Gets or sets a data source for a pivot table.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Facts | Gets FieldsCollection that contains fields for building pivot table facts.
Footer |
Header |
InactiveFields | Gets FieldsCollection that contains the fields not used for pivot table building.
JointFields | Gets or sets array<String>[]()[]
LastRecalculateTime | Gets TimeSpan that represents the latest calculation time of a pivot table.
Layout | Gets or sets DataCube settings serialized to XML format.
PageFooter |
PageHeader |
PivotTable | Gets the PivotTable object representing a pivot table.
ShowSingleFact | Gets or sets whether a single fact caption should be visible.
ShowZeroValues | Gets or sets whether zero values should be visible.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StringRegKey | Gets or sets license key for the current machine.
StyleSheet | Gets or sets the StyleSheet object representing visual styles for a pivot table.
XDimensions | Gets FieldsCollection that contains fields for building pivot table columns.
YDimensions | Gets FieldsCollection that contains fields for building pivot table rows.

Events

Name | Description
DataCubeChanged | Occurs after Pivot table change.
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
PivotTableChanged | Occurs when a pivot table is changed.

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


DataCube Constructor

[image]

.NET ModelKit Suite ClassReference
DataCube Constructor
DataCube Class See Also Send Feedback
Initializes a new instance of the DataCube class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public DataCube()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataCube()

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


DataCube Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataCube Methods
DataCube Class See Also Send Feedback

The DataCube type exposes the following members.

Methods

Name | Description
CancelRecalculate | Stops pivot table calculation.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportToExcel | Overloaded.
ExportToHtml | Overloaded.
ExportToPdf | Overloaded.
Fill | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetPercentValueByCell | Returns percentage value for a given pivot table cell.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSourceRowsByCell | Returns IList that contains data source rows for a given pivot table cell.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueByCell | Returns value for a given pivot table cell.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Load | Overloaded.
MemberwiseClone | Overloaded.
Print | Overloaded.
PrintPreview | Overloaded.
Recalculate | Recalculates a pivot table.
Save | Overloaded.
StartRecalculate | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


CancelRecalculate Method

[image]

.NET ModelKit Suite ClassReference
DataCube..::.CancelRecalculate Method
DataCube Class See Also Send Feedback
Stops pivot table calculation.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void CancelRecalculate()
Visual Basic (Declaration)
Public Sub CancelRecalculate
Visual C++
public:
void CancelRecalculate()

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCube..::.Dispose Method
DataCube Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

DataCube Class
DataCube Members
PerpetuumSoft.Olap Namespace


ExportToExcel Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCube..::.ExportToExcel Method
DataCube Class See Also Send Feedback

Overload List

Name | Description
ExportToExcel(Stream) | Writes a pivot table to a stream in Excel document format.
ExportToExcel(String) | Writes a pivot table to a file in Excel document format.

See Also

DataCube Class
DataCube Members
PerpetuumSoft.Olap Namespace


ExportToExcel Method (Stream)

[image]

.NET ModelKit Suite ClassReference
DataCube..::.ExportToExcel Method (Stream)
DataCube Class See Also Send Feedback
Writes a pivot table to a stream in Excel document format.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void ExportToExcel(
    Stream stream
)
Visual Basic (Declaration)
Public Sub ExportToExcel ( _
    stream As Stream _
)
Visual C++
public:
void ExportToExcel(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

DataCube Class
ExportToExcel Overload
PerpetuumSoft.Olap Namespace


ExportToExcel Method (String)

[image]

.NET ModelKit Suite ClassReference
DataCube..::.ExportToExcel Method (String)
DataCube Class See Also Send Feedback
Writes a pivot table to a file in Excel document format.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void ExportToExcel(
    string fileName
)
Visual Basic (Declaration)
Public Sub ExportToExcel ( _
    fileName As String _
)
Visual C++
public:
void ExportToExcel(
    String^ fileName
)

Parameters

fileName
Type: System..::.String

See Also

DataCube Class
ExportToExcel Overload
PerpetuumSoft.Olap Namespace


ExportToHtml Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCube..::.ExportToHtml Method
DataCube Class See Also Send Feedback

Overload List

Name | Description
ExportToHtml(Stream) | Writes a pivot table to a stream in HTML format.
ExportToHtml(String) | Writes a pivot table to a file in HTML format.

See Also

DataCube Class
DataCube Members
PerpetuumSoft.Olap Namespace


ExportToHtml Method (Stream)

[image]

.NET ModelKit Suite ClassReference
DataCube..::.ExportToHtml Method (Stream)
DataCube Class See Also Send Feedback
Writes a pivot table to a stream in HTML format.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void ExportToHtml(
    Stream stream
)
Visual Basic (Declaration)
Public Sub ExportToHtml ( _
    stream As Stream _
)
Visual C++
public:
void ExportToHtml(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

DataCube Class
ExportToHtml Overload
PerpetuumSoft.Olap Namespace


ExportToHtml Method (String)

[image]

.NET ModelKit Suite ClassReference
DataCube..::.ExportToHtml Method (String)
DataCube Class See Also Send Feedback
Writes a pivot table to a file in HTML format.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void ExportToHtml(
    string fileName
)
Visual Basic (Declaration)
Public Sub ExportToHtml ( _
    fileName As String _
)
Visual C++
public:
void ExportToHtml(
    String^ fileName
)

Parameters

fileName
Type: System..::.String

See Also

DataCube Class
ExportToHtml Overload
PerpetuumSoft.Olap Namespace


ExportToPdf Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCube..::.ExportToPdf Method
DataCube Class See Also Send Feedback

Overload List

Name | Description
ExportToPdf(Stream) | Writes a pivot table to a stream in PDF document format.
ExportToPdf(String) | Writes a pivot table to a file in PDF document format.
ExportToPdf(Stream, PdfExportSettings) | Writes a pivot table to a stream in PDF document format with specific settings.
ExportToPdf(String, PdfExportSettings) | Writes a pivot table to a file in PDF document format with specific settings.

See Also

DataCube Class
DataCube Members
PerpetuumSoft.Olap Namespace


ExportToPdf Method (Stream)

[image]

.NET ModelKit Suite ClassReference
DataCube..::.ExportToPdf Method (Stream)
DataCube Class See Also Send Feedback
Writes a pivot table to a stream in PDF document format.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void ExportToPdf(
    Stream stream
)
Visual Basic (Declaration)
Public Sub ExportToPdf ( _
    stream As Stream _
)
Visual C++
public:
void ExportToPdf(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

DataCube Class
ExportToPdf Overload
PerpetuumSoft.Olap Namespace


ExportToPdf Method (String)

[image]

.NET ModelKit Suite ClassReference
DataCube..::.ExportToPdf Method (String)
DataCube Class See Also Send Feedback
Writes a pivot table to a file in PDF document format.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void ExportToPdf(
    string fileName
)
Visual Basic (Declaration)
Public Sub ExportToPdf ( _
    fileName As String _
)
Visual C++
public:
void ExportToPdf(
    String^ fileName
)

Parameters

fileName
Type: System..::.String

See Also

DataCube Class
ExportToPdf Overload
PerpetuumSoft.Olap Namespace


ExportToPdf Method (Stream, )

[image]

.NET ModelKit Suite ClassReference
DataCube..::.ExportToPdf Method (Stream, )
DataCube Class See Also Send Feedback
Writes a pivot table to a stream in PDF document format with specific settings.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void ExportToPdf(
    Stream stream,
    PdfExportSettings exportSettings
)
Visual Basic (Declaration)
Public Sub ExportToPdf ( _
    stream As Stream, _
    exportSettings As PdfExportSettings _
)
Visual C++
public:
void ExportToPdf(
    Stream^ stream,
    PdfExportSettings^ exportSettings
)

Parameters

stream
Type: System.IO..::.Stream
exportSettings
Type: PdfExportSettings

See Also

DataCube Class
ExportToPdf Overload
PerpetuumSoft.Olap Namespace


ExportToPdf Method (String, )

[image]

.NET ModelKit Suite ClassReference
DataCube..::.ExportToPdf Method (String, )
DataCube Class See Also Send Feedback
Writes a pivot table to a file in PDF document format with specific settings.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void ExportToPdf(
    string fileName,
    PdfExportSettings exportSettings
)
Visual Basic (Declaration)
Public Sub ExportToPdf ( _
    fileName As String, _
    exportSettings As PdfExportSettings _
)
Visual C++
public:
void ExportToPdf(
    String^ fileName,
    PdfExportSettings^ exportSettings
)

Parameters

fileName
Type: System..::.String
exportSettings
Type: PdfExportSettings

See Also

DataCube Class
ExportToPdf Overload
PerpetuumSoft.Olap Namespace


Fill Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCube..::.Fill Method
DataCube Class See Also Send Feedback

Overload List

Name | Description
Fill(ViewDimension, array<DataTable>[]()[]) | Implements pivot table roll-out into array of tables.
Fill(ViewDimension, DataSet, Int32) | Implements pivot table roll-out into a DataSet by a specified dimension up to the given nesting level.
Fill(ViewDimension, DataSet, array<String>[]()[]) | Implements pivot table roll-out into a DataSet filling the tables specified by names.

See Also

DataCube Class
DataCube Members
PerpetuumSoft.Olap Namespace


Fill Method (ViewDimension, DataTable[])

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Fill Method (ViewDimension, array<DataTable>[]()[])
DataCube Class See Also Send Feedback
Implements pivot table roll-out into array of tables.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void Fill(
    ViewDimension primaryDimension,
    params DataTable[] tables
)
Visual Basic (Declaration)
Public Sub Fill ( _
    primaryDimension As ViewDimension, _
    ParamArray tables As DataTable() _
)
Visual C++
public:
void Fill(
    ViewDimension primaryDimension,
    ... array<DataTable^>^ tables
)

Parameters

primaryDimension
Type: PerpetuumSoft.Olap..::.ViewDimension
tables
Type: array< System.Data..::.DataTable >[]()[]

See Also

DataCube Class
Fill Overload
PerpetuumSoft.Olap Namespace


Fill Method (ViewDimension, DataSet, Int32)

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Fill Method (ViewDimension, DataSet, Int32)
DataCube Class See Also Send Feedback
Implements pivot table roll-out into a DataSet by a specified dimension up to the given nesting level.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void Fill(
    ViewDimension primaryDimension,
    DataSet dataSet,
    int depth
)
Visual Basic (Declaration)
Public Sub Fill ( _
    primaryDimension As ViewDimension, _
    dataSet As DataSet, _
    depth As Integer _
)
Visual C++
public:
void Fill(
    ViewDimension primaryDimension,
    DataSet^ dataSet,
    int depth
)

Parameters

primaryDimension
Type: PerpetuumSoft.Olap..::.ViewDimension
dataSet
Type: System.Data..::.DataSet
depth
Type: System..::.Int32

See Also

DataCube Class
Fill Overload
PerpetuumSoft.Olap Namespace


Fill Method (ViewDimension, DataSet, String[])

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Fill Method (ViewDimension, DataSet, array<String>[]()[])
DataCube Class See Also Send Feedback
Implements pivot table roll-out into a DataSet filling the tables specified by names.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void Fill(
    ViewDimension primaryDimension,
    DataSet dataSet,
    params string[] tableNames
)
Visual Basic (Declaration)
Public Sub Fill ( _
    primaryDimension As ViewDimension, _
    dataSet As DataSet, _
    ParamArray tableNames As String() _
)
Visual C++
public:
void Fill(
    ViewDimension primaryDimension,
    DataSet^ dataSet,
    ... array<String^>^ tableNames
)

Parameters

primaryDimension
Type: PerpetuumSoft.Olap..::.ViewDimension
dataSet
Type: System.Data..::.DataSet
tableNames
Type: array< System..::.String >[]()[]

See Also

DataCube Class
Fill Overload
PerpetuumSoft.Olap Namespace


GetPercentValueByCell Method

[image]

.NET ModelKit Suite ClassReference
DataCube..::.GetPercentValueByCell Method
DataCube Class See Also Send Feedback
Returns percentage value for a given pivot table cell.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Object GetPercentValueByCell(
    CellInfo cellInfo
)
Visual Basic (Declaration)
Public Function GetPercentValueByCell ( _
    cellInfo As CellInfo _
) As Object
Visual C++
public:
Object^ GetPercentValueByCell(
    CellInfo^ cellInfo
)

Parameters

cellInfo
Type: PerpetuumSoft.Olap..::.CellInfo

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


GetSourceRowsByCell Method

[image]

.NET ModelKit Suite ClassReference
DataCube..::.GetSourceRowsByCell Method
DataCube Class See Also Send Feedback
Returns IList that contains data source rows for a given pivot table cell.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public IList GetSourceRowsByCell(
    CellInfo cellInfo
)
Visual Basic (Declaration)
Public Function GetSourceRowsByCell ( _
    cellInfo As CellInfo _
) As IList
Visual C++
public:
IList^ GetSourceRowsByCell(
    CellInfo^ cellInfo
)

Parameters

cellInfo
Type: PerpetuumSoft.Olap..::.CellInfo

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


GetValueByCell Method

[image]

.NET ModelKit Suite ClassReference
DataCube..::.GetValueByCell Method
DataCube Class See Also Send Feedback
Returns value for a given pivot table cell.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Object GetValueByCell(
    CellInfo cellInfo
)
Visual Basic (Declaration)
Public Function GetValueByCell ( _
    cellInfo As CellInfo _
) As Object
Visual C++
public:
Object^ GetValueByCell(
    CellInfo^ cellInfo
)

Parameters

cellInfo
Type: PerpetuumSoft.Olap..::.CellInfo

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


Load Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCube..::.Load Method
DataCube Class See Also Send Feedback

Overload List

Name | Description
Load(Stream) | Loads data cube settings from a stream.
Load(String) | Loads data cube settings from a file.

See Also

DataCube Class
DataCube Members
PerpetuumSoft.Olap Namespace


Load Method (Stream)

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Load Method (Stream)
DataCube Class See Also Send Feedback
Loads data cube settings from a stream.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void Load(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Load ( _
    stream As Stream _
)
Visual C++
public:
void Load(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

DataCube Class
Load Overload
PerpetuumSoft.Olap Namespace


Load Method (String)

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Load Method (String)
DataCube Class See Also Send Feedback
Loads data cube settings from a file.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void Load(
    string fileName
)
Visual Basic (Declaration)
Public Sub Load ( _
    fileName As String _
)
Visual C++
public:
void Load(
    String^ fileName
)

Parameters

fileName
Type: System..::.String

See Also

DataCube Class
Load Overload
PerpetuumSoft.Olap Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCube..::.MemberwiseClone Method
DataCube Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DataCube Class
DataCube Members
PerpetuumSoft.Olap Namespace


Print Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCube..::.Print Method
DataCube Class See Also Send Feedback

Overload List

Name | Description
Print()()() | Prints a pivot table.
Print(DataCubePrintSettings) | Prints a pivot table using the print settings assigned by the parameter.
Print(DataCubePrintDocument, PrinterSettings, DataCubePrintSettings) | Pivot table printing.

See Also

DataCube Class
DataCube Members
PerpetuumSoft.Olap Namespace


Print Method

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Print Method
DataCube Class See Also Send Feedback
Prints a pivot table.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void Print()
Visual Basic (Declaration)
Public Sub Print
Visual C++
public:
void Print()

See Also

DataCube Class
Print Overload
PerpetuumSoft.Olap Namespace


Print Method (DataCubePrintSettings)

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Print Method (DataCubePrintSettings)
DataCube Class See Also Send Feedback
Prints a pivot table using the print settings assigned by the parameter.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void Print(
    DataCubePrintSettings printSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    printSettings As DataCubePrintSettings _
)
Visual C++
public:
void Print(
    DataCubePrintSettings^ printSettings
)

Parameters

printSettings
Type: PerpetuumSoft.Olap..::.DataCubePrintSettings

See Also

DataCube Class
Print Overload
PerpetuumSoft.Olap Namespace


Print Method (DataCubePrintDocument, PrinterSettings, DataCubePrintSettings)

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Print Method (DataCubePrintDocument, PrinterSettings, DataCubePrintSettings)
DataCube Class See Also Send Feedback
Pivot table printing.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void Print(
    DataCubePrintDocument dc,
    PrinterSettings printSetting,
    DataCubePrintSettings dataCubeSettings
)
Visual Basic (Declaration)
Public Sub Print ( _
    dc As DataCubePrintDocument, _
    printSetting As PrinterSettings, _
    dataCubeSettings As DataCubePrintSettings _
)
Visual C++
public:
void Print(
    DataCubePrintDocument^ dc,
    PrinterSettings^ printSetting,
    DataCubePrintSettings^ dataCubeSettings
)

Parameters

dc
Type: PerpetuumSoft.Olap..::.DataCubePrintDocument
printSetting
Type: System.Drawing.Printing..::.PrinterSettings
dataCubeSettings
Type: PerpetuumSoft.Olap..::.DataCubePrintSettings

See Also

DataCube Class
Print Overload
PerpetuumSoft.Olap Namespace


PrintPreview Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCube..::.PrintPreview Method
DataCube Class See Also Send Feedback

Overload List

Name | Description
PrintPreview()()() | Shows the print preview dialog.
PrintPreview(DataCubePrintSettings) | Shows the print preview dialog using the print settings assigned by the parameter.

See Also

DataCube Class
DataCube Members
PerpetuumSoft.Olap Namespace


PrintPreview Method

[image]

.NET ModelKit Suite ClassReference
DataCube..::.PrintPreview Method
DataCube Class See Also Send Feedback
Shows the print preview dialog.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void PrintPreview()
Visual Basic (Declaration)
Public Sub PrintPreview
Visual C++
public:
void PrintPreview()

See Also

DataCube Class
PrintPreview Overload
PerpetuumSoft.Olap Namespace


PrintPreview Method (DataCubePrintSettings)

[image]

.NET ModelKit Suite ClassReference
DataCube..::.PrintPreview Method (DataCubePrintSettings)
DataCube Class See Also Send Feedback
Shows the print preview dialog using the print settings assigned by the parameter.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void PrintPreview(
    DataCubePrintSettings printSettings
)
Visual Basic (Declaration)
Public Sub PrintPreview ( _
    printSettings As DataCubePrintSettings _
)
Visual C++
public:
void PrintPreview(
    DataCubePrintSettings^ printSettings
)

Parameters

printSettings
Type: PerpetuumSoft.Olap..::.DataCubePrintSettings

See Also

DataCube Class
PrintPreview Overload
PerpetuumSoft.Olap Namespace


Recalculate Method

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Recalculate Method
DataCube Class See Also Send Feedback
Recalculates a pivot table.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void Recalculate()
Visual Basic (Declaration)
Public Sub Recalculate
Visual C++
public:
void Recalculate()

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


Save Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCube..::.Save Method
DataCube Class See Also Send Feedback

Overload List

Name | Description
Save(Stream, UpdateMode) | Saves the DataCube settings to stream with the indicated save mode assigned by the parameter.
Save(String, UpdateMode) | Saves the DataCube settings to a file with indicated save mode assigned by the parameter.

See Also

DataCube Class
DataCube Members
PerpetuumSoft.Olap Namespace


Save Method (Stream, .)

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Save Method (Stream, ..::.)
DataCube Class See Also Send Feedback
Saves the DataCube settings to stream with the indicated save mode assigned by the parameter.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void Save(
    Stream stream,
    UpdateMode mode
)
Visual Basic (Declaration)
Public Sub Save ( _
    stream As Stream, _
    mode As UpdateMode _
)
Visual C++
public:
void Save(
    Stream^ stream,
    UpdateMode mode
)

Parameters

stream
Type: System.IO..::.Stream
mode
Type: UpdateMode

See Also

DataCube Class
Save Overload
PerpetuumSoft.Olap Namespace


Save Method (String, .)

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Save Method (String, ..::.)
DataCube Class See Also Send Feedback
Saves the DataCube settings to a file with indicated save mode assigned by the parameter.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void Save(
    string fileName,
    UpdateMode mode
)
Visual Basic (Declaration)
Public Sub Save ( _
    fileName As String, _
    mode As UpdateMode _
)
Visual C++
public:
void Save(
    String^ fileName,
    UpdateMode mode
)

Parameters

fileName
Type: System..::.String
mode
Type: UpdateMode

See Also

DataCube Class
Save Overload
PerpetuumSoft.Olap Namespace


StartRecalculate Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCube..::.StartRecalculate Method
DataCube Class See Also Send Feedback

Overload List

Name | Description
StartRecalculate()()() | Starts pivot table calculation.
StartRecalculate(IEngineSite) | Starts pivot table calculation with specific parameter that represents progress site.

See Also

DataCube Class
DataCube Members
PerpetuumSoft.Olap Namespace


StartRecalculate Method

[image]

.NET ModelKit Suite ClassReference
DataCube..::.StartRecalculate Method
DataCube Class See Also Send Feedback
Starts pivot table calculation.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void StartRecalculate()
Visual Basic (Declaration)
Public Sub StartRecalculate
Visual C++
public:
void StartRecalculate()

See Also

DataCube Class
StartRecalculate Overload
PerpetuumSoft.Olap Namespace


StartRecalculate Method (IEngineSite)

[image]

.NET ModelKit Suite ClassReference
DataCube..::.StartRecalculate Method (IEngineSite)
DataCube Class See Also Send Feedback
Starts pivot table calculation with specific parameter that represents progress site.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void StartRecalculate(
    IEngineSite engineSite
)
Visual Basic (Declaration)
Public Sub StartRecalculate ( _
    engineSite As IEngineSite _
)
Visual C++
public:
void StartRecalculate(
    IEngineSite^ engineSite
)

Parameters

engineSite
Type: PerpetuumSoft.Olap.Data..::.IEngineSite

See Also

DataCube Class
StartRecalculate Overload
PerpetuumSoft.Olap Namespace


DataCube Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataCube Properties
DataCube Class See Also Send Feedback

The DataCube type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Caption | Gets or sets a title for a pivot table.
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSource | Gets or sets a data source for a pivot table.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Facts | Gets FieldsCollection that contains fields for building pivot table facts.
Footer |
Header |
InactiveFields | Gets FieldsCollection that contains the fields not used for pivot table building.
JointFields | Gets or sets array<String>[]()[]
LastRecalculateTime | Gets TimeSpan that represents the latest calculation time of a pivot table.
Layout | Gets or sets DataCube settings serialized to XML format.
PageFooter |
PageHeader |
PivotTable | Gets the PivotTable object representing a pivot table.
ShowSingleFact | Gets or sets whether a single fact caption should be visible.
ShowZeroValues | Gets or sets whether zero values should be visible.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StringRegKey | Gets or sets license key for the current machine.
StyleSheet | Gets or sets the StyleSheet object representing visual styles for a pivot table.
XDimensions | Gets FieldsCollection that contains fields for building pivot table columns.
YDimensions | Gets FieldsCollection that contains fields for building pivot table rows.

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


Caption Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Caption Property
DataCube Class See Also Send Feedback
Gets or sets a title for a pivot table.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public string Caption { get; set; }
Visual Basic (Declaration)
Public Property Caption As String
Visual C++
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


DataSource Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.DataSource Property
DataCube Class See Also Send Feedback
Gets or sets a data source for a pivot table.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Object DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As Object
Visual C++
public:
property Object^ DataSource {
    Object^ get ();
    void set (Object^ value);
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


Facts Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Facts Property
DataCube Class See Also Send Feedback
Gets FieldsCollection that contains fields for building pivot table facts.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldsCollection Facts { get; }
Visual Basic (Declaration)
Public ReadOnly Property Facts As FieldsCollection
Visual C++
public:
property FieldsCollection^ Facts {
    FieldsCollection^ get ();
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


Footer Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Footer Property
DataCube Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Olap.DataCube.Footer]

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public HeadlineSettings Footer { get; set; }
Visual Basic (Declaration)
Public Property Footer As HeadlineSettings
Visual C++
public:
property HeadlineSettings^ Footer {
    HeadlineSettings^ get ();
    void set (HeadlineSettings^ value);
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


Header Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Header Property
DataCube Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Olap.DataCube.Header]

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public HeadlineSettings Header { get; set; }
Visual Basic (Declaration)
Public Property Header As HeadlineSettings
Visual C++
public:
property HeadlineSettings^ Header {
    HeadlineSettings^ get ();
    void set (HeadlineSettings^ value);
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


InactiveFields Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.InactiveFields Property
DataCube Class See Also Send Feedback
Gets FieldsCollection that contains the fields not used for pivot table building.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldsCollection InactiveFields { get; }
Visual Basic (Declaration)
Public ReadOnly Property InactiveFields As FieldsCollection
Visual C++
public:
property FieldsCollection^ InactiveFields {
    FieldsCollection^ get ();
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


JointFields Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.JointFields Property
DataCube Class See Also Send Feedback
Gets or sets array<String>[]()[]

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public string[] JointFields { get; set; }
Visual Basic (Declaration)
Public Property JointFields As String()
Visual C++
public:
property array<String^>^ JointFields {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


LastRecalculateTime Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.LastRecalculateTime Property
DataCube Class See Also Send Feedback
Gets TimeSpan that represents the latest calculation time of a pivot table.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public TimeSpan LastRecalculateTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property LastRecalculateTime As TimeSpan
Visual C++
public:
property TimeSpan LastRecalculateTime {
    TimeSpan get ();
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


Layout Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Layout Property
DataCube Class See Also Send Feedback
Gets or sets DataCube settings serialized to XML format.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public string Layout { get; set; }
Visual Basic (Declaration)
Public Property Layout As String
Visual C++
public:
property String^ Layout {
    String^ get ();
    void set (String^ value);
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


PageFooter Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.PageFooter Property
DataCube Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Olap.DataCube.PageFooter]

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public HeadlineSettings PageFooter { get; set; }
Visual Basic (Declaration)
Public Property PageFooter As HeadlineSettings
Visual C++
public:
property HeadlineSettings^ PageFooter {
    HeadlineSettings^ get ();
    void set (HeadlineSettings^ value);
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


PageHeader Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.PageHeader Property
DataCube Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Olap.DataCube.PageHeader]

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public HeadlineSettings PageHeader { get; set; }
Visual Basic (Declaration)
Public Property PageHeader As HeadlineSettings
Visual C++
public:
property HeadlineSettings^ PageHeader {
    HeadlineSettings^ get ();
    void set (HeadlineSettings^ value);
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


PivotTable Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.PivotTable Property
DataCube Class See Also Send Feedback
Gets the PivotTable object representing a pivot table.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public PivotTable PivotTable { get; }
Visual Basic (Declaration)
Public ReadOnly Property PivotTable As PivotTable
Visual C++
public:
property PivotTable^ PivotTable {
    PivotTable^ get ();
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


ShowSingleFact Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.ShowSingleFact Property
DataCube Class See Also Send Feedback
Gets or sets whether a single fact caption should be visible.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowSingleFact { get; set; }
Visual Basic (Declaration)
Public Property ShowSingleFact As Boolean
Visual C++
public:
property bool ShowSingleFact {
    bool get ();
    void set (bool value);
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


ShowZeroValues Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.ShowZeroValues Property
DataCube Class See Also Send Feedback
Gets or sets whether zero values should be visible.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowZeroValues { get; set; }
Visual Basic (Declaration)
Public Property ShowZeroValues As Boolean
Visual C++
public:
property bool ShowZeroValues {
    bool get ();
    void set (bool value);
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


StringRegKey Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.StringRegKey Property
DataCube Class See Also Send Feedback
Gets or sets license key for the current machine.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public string StringRegKey { get; set; }
Visual Basic (Declaration)
Public Property StringRegKey As String
Visual C++
public:
property String^ StringRegKey {
    String^ get ();
    void set (String^ value);
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


StyleSheet Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.StyleSheet Property
DataCube Class See Also Send Feedback
Gets or sets the StyleSheet object representing visual styles for a pivot table.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public StyleSheet StyleSheet { get; set; }
Visual Basic (Declaration)
Public Property StyleSheet As StyleSheet
Visual C++
public:
property StyleSheet^ StyleSheet {
    StyleSheet^ get ();
    void set (StyleSheet^ value);
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


XDimensions Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.XDimensions Property
DataCube Class See Also Send Feedback
Gets FieldsCollection that contains fields for building pivot table columns.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldsCollection XDimensions { get; }
Visual Basic (Declaration)
Public ReadOnly Property XDimensions As FieldsCollection
Visual C++
public:
property FieldsCollection^ XDimensions {
    FieldsCollection^ get ();
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


YDimensions Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.YDimensions Property
DataCube Class See Also Send Feedback
Gets FieldsCollection that contains fields for building pivot table rows.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldsCollection YDimensions { get; }
Visual Basic (Declaration)
Public ReadOnly Property YDimensions As FieldsCollection
Visual C++
public:
property FieldsCollection^ YDimensions {
    FieldsCollection^ get ();
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


DataCube Events

[image] [image]

.NET ModelKit Suite ClassReference
DataCube Events
DataCube Class See Also Send Feedback

The DataCube type exposes the following members.

Events

Name | Description
DataCubeChanged | Occurs after Pivot table change.
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
PivotTableChanged | Occurs when a pivot table is changed.

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


DataCubeChanged Event

[image]

.NET ModelKit Suite ClassReference
DataCube..::.DataCubeChanged Event
DataCube Class See Also Send Feedback
Occurs after Pivot table change.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler DataCubeChanged
Visual Basic (Declaration)
Public Event DataCubeChanged As EventHandler
Visual C++
public:
 event EventHandler^ DataCubeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


PivotTableChanged Event

[image]

.NET ModelKit Suite ClassReference
DataCube..::.PivotTableChanged Event
DataCube Class See Also Send Feedback
Occurs when a pivot table is changed.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler PivotTableChanged
Visual Basic (Declaration)
Public Event PivotTableChanged As EventHandler
Visual C++
public:
 event EventHandler^ PivotTableChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DataCube Class
PerpetuumSoft.Olap Namespace


DataCubePrintDocument Class

[image]

.NET ModelKit Suite ClassReference
DataCubePrintDocument Class
Members See Also Send Feedback
Represents a reusable pivot table that sends output to a printer.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class DataCubePrintDocument : PrintDocument
Visual Basic (Declaration)
Public Class DataCubePrintDocument _
    Inherits PrintDocument
Visual C++
public ref class DataCubePrintDocument : public PrintDocument

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Drawing.Printing..::.PrintDocument
PerpetuumSoft.Olap..::.DataCubePrintDocument

See Also

DataCubePrintDocument Members
PerpetuumSoft.Olap Namespace


DataCubePrintDocument Members

[image] [image]

.NET ModelKit Suite ClassReference
DataCubePrintDocument Members
DataCubePrintDocument Class Constructors Methods Properties Events See Also Send Feedback

The DataCubePrintDocument type exposes the following members.

Constructors

Name | Description
DataCubePrintDocument | Initializes a new instance of the DataCubePrintDocument class.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
OnBeginPrint | Raises the BeginPrint event. It is called after the Print method is called and before the first page of the document is printed. (Overrides PrintDocument..::.OnBeginPrint(PrintEventArgs).)
OnEndPrint | Raises the EndPrint event. It is called when the last page of the document has been printed. (Overrides PrintDocument..::.OnEndPrint(PrintEventArgs).)
OnPrintPage | Raises the PrintPage event. It is called before a page is printed. (Overrides PrintDocument..::.OnPrintPage(PrintPageEventArgs).)
OnQueryPageSettings | Raises the QueryPageSettings event. It is called immediately before each PrintPage event. (Inherited from PrintDocument.)
Print | Starts the document's printing process. (Inherited from PrintDocument.)
ToString | Provides information about the print document, in string form. (Inherited from PrintDocument.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataCube | Gets or sets DataCube used as pivot table source.
DefaultPageSettings | Gets or sets page settings that are used as defaults for all pages to be printed. (Inherited from PrintDocument.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DocumentName | Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document. (Inherited from PrintDocument.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Footer | Gets or sets pivot table footer which is used during printing.
Header | Gets or sets pivot table header which is used during printing.
OriginAtMargins | Gets or sets a value indicating whether the position of a graphics object associated with a page is located just inside the user-specified margins or at the top-left corner of the printable area of the page. (Inherited from PrintDocument.)
PageFooter | Gets or sets pivot table page footer which is used during printing.
PageHeader | Gets or sets pivot table page header which is used during printing.
PrintController | Gets or sets the print controller that guides the printing process. (Inherited from PrintDocument.)
PrinterSettings | Gets or sets the printer that prints the document. (Inherited from PrintDocument.)
PrintSettings | Gets or sets the DataCubePrintSettings object representing the print settings.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
BeginPrint | Occurs when the Print()()() method is called and before the first page of the document prints. (Inherited from PrintDocument.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
EndPrint | Occurs when the last page of the document has printed. (Inherited from PrintDocument.)
PrintPage | Occurs when the output to print for the current page is needed. (Inherited from PrintDocument.)
QueryPageSettings | Occurs immediately before each PrintPage event. (Inherited from PrintDocument.)

See Also

DataCubePrintDocument Class
PerpetuumSoft.Olap Namespace


DataCubePrintDocument Constructor

[image]

.NET ModelKit Suite ClassReference
DataCubePrintDocument Constructor
DataCubePrintDocument Class See Also Send Feedback
Initializes a new instance of the DataCubePrintDocument class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public DataCubePrintDocument()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataCubePrintDocument()

See Also

DataCubePrintDocument Class
PerpetuumSoft.Olap Namespace


DataCubePrintDocument Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataCubePrintDocument Methods
DataCubePrintDocument Class See Also Send Feedback

The DataCubePrintDocument type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
OnBeginPrint | Raises the BeginPrint event. It is called after the Print method is called and before the first page of the document is printed. (Overrides PrintDocument..::.OnBeginPrint(PrintEventArgs).)
OnEndPrint | Raises the EndPrint event. It is called when the last page of the document has been printed. (Overrides PrintDocument..::.OnEndPrint(PrintEventArgs).)
OnPrintPage | Raises the PrintPage event. It is called before a page is printed. (Overrides PrintDocument..::.OnPrintPage(PrintPageEventArgs).)
OnQueryPageSettings | Raises the QueryPageSettings event. It is called immediately before each PrintPage event. (Inherited from PrintDocument.)
Print | Starts the document's printing process. (Inherited from PrintDocument.)
ToString | Provides information about the print document, in string form. (Inherited from PrintDocument.)

See Also

DataCubePrintDocument Class
PerpetuumSoft.Olap Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubePrintDocument..::.Dispose Method
DataCubePrintDocument Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

DataCubePrintDocument Class
DataCubePrintDocument Members
PerpetuumSoft.Olap Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubePrintDocument..::.MemberwiseClone Method
DataCubePrintDocument Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DataCubePrintDocument Class
DataCubePrintDocument Members
PerpetuumSoft.Olap Namespace


OnBeginPrint Method

[image]

.NET ModelKit Suite ClassReference
DataCubePrintDocument..::.OnBeginPrint Method
DataCubePrintDocument Class See Also Send Feedback
Raises the BeginPrint event. It is called after the Print method is called and before the first page of the document is printed.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnBeginPrint(
    PrintEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnBeginPrint ( _
    e As PrintEventArgs _
)
Visual C++
protected:
virtual void OnBeginPrint(
    PrintEventArgs^ e
) override

Parameters

e
Type: System.Drawing.Printing..::.PrintEventArgs

See Also

DataCubePrintDocument Class
PerpetuumSoft.Olap Namespace


OnEndPrint Method

[image]

.NET ModelKit Suite ClassReference
DataCubePrintDocument..::.OnEndPrint Method
DataCubePrintDocument Class See Also Send Feedback
Raises the EndPrint event. It is called when the last page of the document has been printed.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnEndPrint(
    PrintEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnEndPrint ( _
    e As PrintEventArgs _
)
Visual C++
protected:
virtual void OnEndPrint(
    PrintEventArgs^ e
) override

Parameters

e
Type: System.Drawing.Printing..::.PrintEventArgs

See Also

DataCubePrintDocument Class
PerpetuumSoft.Olap Namespace


OnPrintPage Method

[image]

.NET ModelKit Suite ClassReference
DataCubePrintDocument..::.OnPrintPage Method
DataCubePrintDocument Class See Also Send Feedback
Raises the PrintPage event. It is called before a page is printed.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnPrintPage(
    PrintPageEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnPrintPage ( _
    e As PrintPageEventArgs _
)
Visual C++
protected:
virtual void OnPrintPage(
    PrintPageEventArgs^ e
) override

Parameters

e
Type: System.Drawing.Printing..::.PrintPageEventArgs

See Also

DataCubePrintDocument Class
PerpetuumSoft.Olap Namespace


DataCubePrintDocument Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataCubePrintDocument Properties
DataCubePrintDocument Class See Also Send Feedback

The DataCubePrintDocument type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataCube | Gets or sets DataCube used as pivot table source.
DefaultPageSettings | Gets or sets page settings that are used as defaults for all pages to be printed. (Inherited from PrintDocument.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DocumentName | Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document. (Inherited from PrintDocument.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Footer | Gets or sets pivot table footer which is used during printing.
Header | Gets or sets pivot table header which is used during printing.
OriginAtMargins | Gets or sets a value indicating whether the position of a graphics object associated with a page is located just inside the user-specified margins or at the top-left corner of the printable area of the page. (Inherited from PrintDocument.)
PageFooter | Gets or sets pivot table page footer which is used during printing.
PageHeader | Gets or sets pivot table page header which is used during printing.
PrintController | Gets or sets the print controller that guides the printing process. (Inherited from PrintDocument.)
PrinterSettings | Gets or sets the printer that prints the document. (Inherited from PrintDocument.)
PrintSettings | Gets or sets the DataCubePrintSettings object representing the print settings.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

DataCubePrintDocument Class
PerpetuumSoft.Olap Namespace


DataCube Property

[image]

.NET ModelKit Suite ClassReference
DataCubePrintDocument..::.DataCube Property
DataCubePrintDocument Class See Also Send Feedback
Gets or sets DataCube used as pivot table source.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public DataCube DataCube { get; set; }
Visual Basic (Declaration)
Public Property DataCube As DataCube
Visual C++
public:
property DataCube^ DataCube {
    DataCube^ get ();
    void set (DataCube^ value);
}

See Also

DataCubePrintDocument Class
PerpetuumSoft.Olap Namespace


Footer Property

[image]

.NET ModelKit Suite ClassReference
DataCubePrintDocument..::.Footer Property
DataCubePrintDocument Class See Also Send Feedback
Gets or sets pivot table footer which is used during printing.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public HeadlineSettings Footer { get; set; }
Visual Basic (Declaration)
Public Property Footer As HeadlineSettings
Visual C++
public:
property HeadlineSettings^ Footer {
    HeadlineSettings^ get ();
    void set (HeadlineSettings^ value);
}

See Also

DataCubePrintDocument Class
PerpetuumSoft.Olap Namespace


Header Property

[image]

.NET ModelKit Suite ClassReference
DataCubePrintDocument..::.Header Property
DataCubePrintDocument Class See Also Send Feedback
Gets or sets pivot table header which is used during printing.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public HeadlineSettings Header { get; set; }
Visual Basic (Declaration)
Public Property Header As HeadlineSettings
Visual C++
public:
property HeadlineSettings^ Header {
    HeadlineSettings^ get ();
    void set (HeadlineSettings^ value);
}

See Also

DataCubePrintDocument Class
PerpetuumSoft.Olap Namespace


PageFooter Property

[image]

.NET ModelKit Suite ClassReference
DataCubePrintDocument..::.PageFooter Property
DataCubePrintDocument Class See Also Send Feedback
Gets or sets pivot table page footer which is used during printing.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public HeadlineSettings PageFooter { get; set; }
Visual Basic (Declaration)
Public Property PageFooter As HeadlineSettings
Visual C++
public:
property HeadlineSettings^ PageFooter {
    HeadlineSettings^ get ();
    void set (HeadlineSettings^ value);
}

See Also

DataCubePrintDocument Class
PerpetuumSoft.Olap Namespace


PageHeader Property

[image]

.NET ModelKit Suite ClassReference
DataCubePrintDocument..::.PageHeader Property
DataCubePrintDocument Class See Also Send Feedback
Gets or sets pivot table page header which is used during printing.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public HeadlineSettings PageHeader { get; set; }
Visual Basic (Declaration)
Public Property PageHeader As HeadlineSettings
Visual C++
public:
property HeadlineSettings^ PageHeader {
    HeadlineSettings^ get ();
    void set (HeadlineSettings^ value);
}

See Also

DataCubePrintDocument Class
PerpetuumSoft.Olap Namespace


PrintSettings Property

[image]

.NET ModelKit Suite ClassReference
DataCubePrintDocument..::.PrintSettings Property
DataCubePrintDocument Class See Also Send Feedback
Gets or sets the DataCubePrintSettings object representing the print settings.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public DataCubePrintSettings PrintSettings { get; set; }
Visual Basic (Declaration)
Public Property PrintSettings As DataCubePrintSettings
Visual C++
public:
property DataCubePrintSettings^ PrintSettings {
    DataCubePrintSettings^ get ();
    void set (DataCubePrintSettings^ value);
}

See Also

DataCubePrintDocument Class
PerpetuumSoft.Olap Namespace


DataCubePrintDocument Events

[image] [image]

.NET ModelKit Suite ClassReference
DataCubePrintDocument Events
DataCubePrintDocument Class See Also Send Feedback

The DataCubePrintDocument type exposes the following members.

Events

Name | Description
BeginPrint | Occurs when the Print()()() method is called and before the first page of the document prints. (Inherited from PrintDocument.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
EndPrint | Occurs when the last page of the document has printed. (Inherited from PrintDocument.)
PrintPage | Occurs when the output to print for the current page is needed. (Inherited from PrintDocument.)
QueryPageSettings | Occurs immediately before each PrintPage event. (Inherited from PrintDocument.)

See Also

DataCubePrintDocument Class
PerpetuumSoft.Olap Namespace


DataCubePrintSettings Class

[image]

.NET ModelKit Suite ClassReference
DataCubePrintSettings Class
Members See Also Send Feedback
Represents pivot table print settings.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class DataCubePrintSettings
Visual Basic (Declaration)
Public Class DataCubePrintSettings
Visual C++
public ref class DataCubePrintSettings

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.DataCubePrintSettings

See Also

DataCubePrintSettings Members
PerpetuumSoft.Olap Namespace


DataCubePrintSettings Members

[image] [image]

.NET ModelKit Suite ClassReference
DataCubePrintSettings Members
DataCubePrintSettings Class Constructors Methods Properties See Also Send Feedback

The DataCubePrintSettings type exposes the following members.

Constructors

Name | Description
DataCubePrintSettings | Initializes a new instance of the DataCubePrintSettings class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DimensionsOnEveryPage | Gets or sets the value indicating whether dimension cells will be printed on every page.
FieldCaptionsOnEveryPage | Gets or sets the value indicating whether field captions will be printed on every page.
IgnoreColors | Gets or sets the value indicating whether the multicolor style will be ignored.
TitleOnEveryPage | Gets or sets the value indicating whether a pivot table title will be printed on every page.

See Also

DataCubePrintSettings Class
PerpetuumSoft.Olap Namespace


DataCubePrintSettings Constructor

[image]

.NET ModelKit Suite ClassReference
DataCubePrintSettings Constructor
DataCubePrintSettings Class See Also Send Feedback
Initializes a new instance of the DataCubePrintSettings class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public DataCubePrintSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataCubePrintSettings()

See Also

DataCubePrintSettings Class
PerpetuumSoft.Olap Namespace


DataCubePrintSettings Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataCubePrintSettings Methods
DataCubePrintSettings Class See Also Send Feedback

The DataCubePrintSettings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataCubePrintSettings Class
PerpetuumSoft.Olap Namespace


DataCubePrintSettings Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataCubePrintSettings Properties
DataCubePrintSettings Class See Also Send Feedback

The DataCubePrintSettings type exposes the following members.

Properties

Name | Description
DimensionsOnEveryPage | Gets or sets the value indicating whether dimension cells will be printed on every page.
FieldCaptionsOnEveryPage | Gets or sets the value indicating whether field captions will be printed on every page.
IgnoreColors | Gets or sets the value indicating whether the multicolor style will be ignored.
TitleOnEveryPage | Gets or sets the value indicating whether a pivot table title will be printed on every page.

See Also

DataCubePrintSettings Class
PerpetuumSoft.Olap Namespace


DimensionsOnEveryPage Property

[image]

.NET ModelKit Suite ClassReference
DataCubePrintSettings..::.DimensionsOnEveryPage Property
DataCubePrintSettings Class See Also Send Feedback
Gets or sets the value indicating whether dimension cells will be printed on every page.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool DimensionsOnEveryPage { get; set; }
Visual Basic (Declaration)
Public Property DimensionsOnEveryPage As Boolean
Visual C++
public:
property bool DimensionsOnEveryPage {
    bool get ();
    void set (bool value);
}

See Also

DataCubePrintSettings Class
PerpetuumSoft.Olap Namespace


FieldCaptionsOnEveryPage Property

[image]

.NET ModelKit Suite ClassReference
DataCubePrintSettings..::.FieldCaptionsOnEveryPage Property
DataCubePrintSettings Class See Also Send Feedback
Gets or sets the value indicating whether field captions will be printed on every page.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool FieldCaptionsOnEveryPage { get; set; }
Visual Basic (Declaration)
Public Property FieldCaptionsOnEveryPage As Boolean
Visual C++
public:
property bool FieldCaptionsOnEveryPage {
    bool get ();
    void set (bool value);
}

See Also

DataCubePrintSettings Class
PerpetuumSoft.Olap Namespace


IgnoreColors Property

[image]

.NET ModelKit Suite ClassReference
DataCubePrintSettings..::.IgnoreColors Property
DataCubePrintSettings Class See Also Send Feedback
Gets or sets the value indicating whether the multicolor style will be ignored.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool IgnoreColors { get; set; }
Visual Basic (Declaration)
Public Property IgnoreColors As Boolean
Visual C++
public:
property bool IgnoreColors {
    bool get ();
    void set (bool value);
}

See Also

DataCubePrintSettings Class
PerpetuumSoft.Olap Namespace


TitleOnEveryPage Property

[image]

.NET ModelKit Suite ClassReference
DataCubePrintSettings..::.TitleOnEveryPage Property
DataCubePrintSettings Class See Also Send Feedback
Gets or sets the value indicating whether a pivot table title will be printed on every page.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool TitleOnEveryPage { get; set; }
Visual Basic (Declaration)
Public Property TitleOnEveryPage As Boolean
Visual C++
public:
property bool TitleOnEveryPage {
    bool get ();
    void set (bool value);
}

See Also

DataCubePrintSettings Class
PerpetuumSoft.Olap Namespace


DataCubeRowView Class

[image]

.NET ModelKit Suite ClassReference
DataCubeRowView Class
Members See Also Send Feedback
Represents view of a DataCube row or column.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class DataCubeRowView : ICustomTypeDescriptor
Visual Basic (Declaration)
Public Class DataCubeRowView _
    Implements ICustomTypeDescriptor
Visual C++
public ref class DataCubeRowView : ICustomTypeDescriptor

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.DataCubeRowView

See Also

DataCubeRowView Members
PerpetuumSoft.Olap Namespace


DataCubeRowView Members

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeRowView Members
DataCubeRowView Class Constructors Methods Properties See Also Send Feedback

The DataCubeRowView type exposes the following members.

Constructors

Name | Description
DataCubeRowView | Initializes a new instance of the DataCubeRowView class.

Methods

Name | Description
CreateChildView | Creates child DataCubeView.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFactValue | Returns the fact value given by the parameter.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
Caption | Gets the Caption of FieldItem this DataRowView represents.
Item | Gets FieldItem this DataCubeRow corresponds to.
OrtogonalItem | Gets the ortogonal item FieldItem for this DataCubeRowView.
View | Gets the DataCubeView this row belongs to.

See Also

DataCubeRowView Class
PerpetuumSoft.Olap Namespace


DataCubeRowView Constructor

[image]

.NET ModelKit Suite ClassReference
DataCubeRowView Constructor
DataCubeRowView Class See Also Send Feedback
Initializes a new instance of the DataCubeRowView class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public DataCubeRowView(
    DataCubeView view,
    FieldItem item,
    FieldItem ortogonalItem
)
Visual Basic (Declaration)
Public Sub New ( _
    view As DataCubeView, _
    item As FieldItem, _
    ortogonalItem As FieldItem _
)
Visual C++
public:
DataCubeRowView(
    DataCubeView^ view,
    FieldItem^ item,
    FieldItem^ ortogonalItem
)

Parameters

view
Type: PerpetuumSoft.Olap..::.DataCubeView
item
Type: PerpetuumSoft.Olap..::.FieldItem
ortogonalItem
Type: PerpetuumSoft.Olap..::.FieldItem

See Also

DataCubeRowView Class
PerpetuumSoft.Olap Namespace


DataCubeRowView Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeRowView Methods
DataCubeRowView Class See Also Send Feedback

The DataCubeRowView type exposes the following members.

Methods

Name | Description
CreateChildView | Creates child DataCubeView.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFactValue | Returns the fact value given by the parameter.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

DataCubeRowView Class
PerpetuumSoft.Olap Namespace


CreateChildView Method

[image]

.NET ModelKit Suite ClassReference
DataCubeRowView..::.CreateChildView Method
DataCubeRowView Class See Also Send Feedback
Creates child DataCubeView.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public DataCubeView CreateChildView()
Visual Basic (Declaration)
Public Function CreateChildView As DataCubeView
Visual C++
public:
DataCubeView^ CreateChildView()

See Also

DataCubeRowView Class
PerpetuumSoft.Olap Namespace


GetFactValue Method

[image]

.NET ModelKit Suite ClassReference
DataCubeRowView..::.GetFactValue Method
DataCubeRowView Class See Also Send Feedback
Returns the fact value given by the parameter.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public double GetFactValue(
    string fact
)
Visual Basic (Declaration)
Public Function GetFactValue ( _
    fact As String _
) As Double
Visual C++
public:
double GetFactValue(
    String^ fact
)

Parameters

fact
Type: System..::.String

See Also

DataCubeRowView Class
PerpetuumSoft.Olap Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
DataCubeRowView..::.ToString Method
DataCubeRowView Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

DataCubeRowView Class
PerpetuumSoft.Olap Namespace


DataCubeRowView Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeRowView Properties
DataCubeRowView Class See Also Send Feedback

The DataCubeRowView type exposes the following members.

Properties

Name | Description
Caption | Gets the Caption of FieldItem this DataRowView represents.
Item | Gets FieldItem this DataCubeRow corresponds to.
OrtogonalItem | Gets the ortogonal item FieldItem for this DataCubeRowView.
View | Gets the DataCubeView this row belongs to.

See Also

DataCubeRowView Class
PerpetuumSoft.Olap Namespace


Caption Property

[image]

.NET ModelKit Suite ClassReference
DataCubeRowView..::.Caption Property
DataCubeRowView Class See Also Send Feedback
Gets the Caption of FieldItem this DataRowView represents.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public string Caption { get; }
Visual Basic (Declaration)
Public ReadOnly Property Caption As String
Visual C++
public:
property String^ Caption {
    String^ get ();
}

See Also

DataCubeRowView Class
PerpetuumSoft.Olap Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
DataCubeRowView..::.Item Property
DataCubeRowView Class See Also Send Feedback
Gets FieldItem this DataCubeRow corresponds to.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem Item { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item As FieldItem
Visual C++
public:
property FieldItem^ Item {
    FieldItem^ get ();
}

See Also

DataCubeRowView Class
PerpetuumSoft.Olap Namespace


OrtogonalItem Property

[image]

.NET ModelKit Suite ClassReference
DataCubeRowView..::.OrtogonalItem Property
DataCubeRowView Class See Also Send Feedback
Gets the ortogonal item FieldItem for this DataCubeRowView.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem OrtogonalItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property OrtogonalItem As FieldItem
Visual C++
public:
property FieldItem^ OrtogonalItem {
    FieldItem^ get ();
}

See Also

DataCubeRowView Class
PerpetuumSoft.Olap Namespace


View Property

[image]

.NET ModelKit Suite ClassReference
DataCubeRowView..::.View Property
DataCubeRowView Class See Also Send Feedback
Gets the DataCubeView this row belongs to.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public DataCubeView View { get; }
Visual Basic (Declaration)
Public ReadOnly Property View As DataCubeView
Visual C++
public:
property DataCubeView^ View {
    DataCubeView^ get ();
}

See Also

DataCubeRowView Class
PerpetuumSoft.Olap Namespace


DataCubeView Class

[image]

.NET ModelKit Suite ClassReference
DataCubeView Class
Members See Also Send Feedback
Represents a databindable view of a DataCube.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class DataCubeView : Component,
    IBindingList, IList, ICollection, IEnumerable, ITypedList
Visual Basic (Declaration)
Public Class DataCubeView _
    Inherits Component _
    Implements IBindingList, IList, ICollection, IEnumerable,  _
    ITypedList
Visual C++
public ref class DataCubeView : public Component,
    IBindingList, IList, ICollection, IEnumerable, ITypedList

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Olap..::.DataCubeView

See Also

DataCubeView Members
PerpetuumSoft.Olap Namespace


DataCubeView Members

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeView Members
DataCubeView Class Constructors Methods Properties Events See Also Send Feedback

The DataCubeView type exposes the following members.

Constructors

Name | Description
DataCubeView | Overloaded.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItemProperties | Returns PropertyDescriptorCollection for DataCubeView.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetOrtogonalItem | Returns the ortogonal item for this DataCubeView.
GetRootItem | Returns the root item of a PivotTable for the current DataCubeView PrimaryDimesion.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
RaiseListChanged | Raises the ListChanged event.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Count | Implements Count.
DataCube | Gets or sets the DataCube source.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dimension | Gets the current dimension Field for this DataCubeView.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Item | Implements Item[([(Int32])]).
PrimaryDimension | Gets or sets the primary dimension for ViewDimension.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
ListChanged | Occurs when the list managed by DataCubeView is changed.

See Also

DataCubeView Class
PerpetuumSoft.Olap Namespace


DataCubeView Constructor

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeView Constructor
DataCubeView Class See Also Send Feedback

Overload List

Name | Description
DataCubeView()()() | Initializes a new instance of the DataCubeView class.
DataCubeView(IContainer) | Initializes a new instance of the DataCubeView class.

See Also

DataCubeView Class
DataCubeView Members
PerpetuumSoft.Olap Namespace


DataCubeView Constructor

[image]

.NET ModelKit Suite ClassReference
DataCubeView Constructor
DataCubeView Class See Also Send Feedback
Initializes a new instance of the DataCubeView class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public DataCubeView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataCubeView()

See Also

DataCubeView Class
DataCubeView Overload
PerpetuumSoft.Olap Namespace


DataCubeView Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
DataCubeView Constructor (IContainer)
DataCubeView Class See Also Send Feedback
Initializes a new instance of the DataCubeView class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public DataCubeView(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
DataCubeView(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

DataCubeView Class
DataCubeView Overload
PerpetuumSoft.Olap Namespace


DataCubeView Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeView Methods
DataCubeView Class See Also Send Feedback

The DataCubeView type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetItemProperties | Returns PropertyDescriptorCollection for DataCubeView.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetOrtogonalItem | Returns the ortogonal item for this DataCubeView.
GetRootItem | Returns the root item of a PivotTable for the current DataCubeView PrimaryDimesion.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
RaiseListChanged | Raises the ListChanged event.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

DataCubeView Class
PerpetuumSoft.Olap Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeView..::.Dispose Method
DataCubeView Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

DataCubeView Class
DataCubeView Members
PerpetuumSoft.Olap Namespace


GetItemProperties Method

[image]

.NET ModelKit Suite ClassReference
DataCubeView..::.GetItemProperties Method
DataCubeView Class See Also Send Feedback
Returns PropertyDescriptorCollection for DataCubeView.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public PropertyDescriptorCollection GetItemProperties()
Visual Basic (Declaration)
Public Function GetItemProperties As PropertyDescriptorCollection
Visual C++
public:
PropertyDescriptorCollection^ GetItemProperties()

See Also

DataCubeView Class
PerpetuumSoft.Olap Namespace


GetOrtogonalItem Method

[image]

.NET ModelKit Suite ClassReference
DataCubeView..::.GetOrtogonalItem Method
DataCubeView Class See Also Send Feedback
Returns the ortogonal item for this DataCubeView.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
protected virtual FieldItem GetOrtogonalItem()
Visual Basic (Declaration)
Protected Overridable Function GetOrtogonalItem As FieldItem
Visual C++
protected:
virtual FieldItem^ GetOrtogonalItem()

See Also

DataCubeView Class
PerpetuumSoft.Olap Namespace


GetRootItem Method

[image]

.NET ModelKit Suite ClassReference
DataCubeView..::.GetRootItem Method
DataCubeView Class See Also Send Feedback
Returns the root item of a PivotTable for the current DataCubeView PrimaryDimesion.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
protected virtual FieldItem GetRootItem()
Visual Basic (Declaration)
Protected Overridable Function GetRootItem As FieldItem
Visual C++
protected:
virtual FieldItem^ GetRootItem()

See Also

DataCubeView Class
PerpetuumSoft.Olap Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeView..::.MemberwiseClone Method
DataCubeView Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DataCubeView Class
DataCubeView Members
PerpetuumSoft.Olap Namespace


RaiseListChanged Method

[image]

.NET ModelKit Suite ClassReference
DataCubeView..::.RaiseListChanged Method
DataCubeView Class See Also Send Feedback
Raises the ListChanged event.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
protected void RaiseListChanged()
Visual Basic (Declaration)
Protected Sub RaiseListChanged
Visual C++
protected:
void RaiseListChanged()

See Also

DataCubeView Class
PerpetuumSoft.Olap Namespace


DataCubeView Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeView Properties
DataCubeView Class See Also Send Feedback

The DataCubeView type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Count | Implements Count.
DataCube | Gets or sets the DataCube source.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Dimension | Gets the current dimension Field for this DataCubeView.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Item | Implements Item[([(Int32])]).
PrimaryDimension | Gets or sets the primary dimension for ViewDimension.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

DataCubeView Class
PerpetuumSoft.Olap Namespace


Count Property

[image]

.NET ModelKit Suite ClassReference
DataCubeView..::.Count Property
DataCubeView Class See Also Send Feedback
Implements Count.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection..::.Count

See Also

DataCubeView Class
PerpetuumSoft.Olap Namespace


DataCube Property

[image]

.NET ModelKit Suite ClassReference
DataCubeView..::.DataCube Property
DataCubeView Class See Also Send Feedback
Gets or sets the DataCube source.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public DataCube DataCube { get; set; }
Visual Basic (Declaration)
Public Property DataCube As DataCube
Visual C++
public:
property DataCube^ DataCube {
    DataCube^ get ();
    void set (DataCube^ value);
}

See Also

DataCubeView Class
PerpetuumSoft.Olap Namespace


Dimension Property

[image]

.NET ModelKit Suite ClassReference
DataCubeView..::.Dimension Property
DataCubeView Class See Also Send Feedback
Gets the current dimension Field for this DataCubeView.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Field Dimension { get; }
Visual Basic (Declaration)
Public ReadOnly Property Dimension As Field
Visual C++
public:
property Field^ Dimension {
    Field^ get ();
}

See Also

DataCubeView Class
PerpetuumSoft.Olap Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
DataCubeView..::.Item Property
DataCubeView Class See Also Send Feedback
Implements Item[([(Int32])]).

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public DataCubeRowView this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As DataCubeRowView
Visual C++
public:
property DataCubeRowView^ default[int index] {
    DataCubeRowView^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

DataCubeView Class
PerpetuumSoft.Olap Namespace


PrimaryDimension Property

[image]

.NET ModelKit Suite ClassReference
DataCubeView..::.PrimaryDimension Property
DataCubeView Class See Also Send Feedback
Gets or sets the primary dimension for ViewDimension.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public ViewDimension PrimaryDimension { get; set; }
Visual Basic (Declaration)
Public Property PrimaryDimension As ViewDimension
Visual C++
public:
property ViewDimension PrimaryDimension {
    ViewDimension get ();
    void set (ViewDimension value);
}

See Also

DataCubeView Class
PerpetuumSoft.Olap Namespace


DataCubeView Events

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeView Events
DataCubeView Class See Also Send Feedback

The DataCubeView type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
ListChanged | Occurs when the list managed by DataCubeView is changed.

See Also

DataCubeView Class
PerpetuumSoft.Olap Namespace


ListChanged Event

[image]

.NET ModelKit Suite ClassReference
DataCubeView..::.ListChanged Event
DataCubeView Class See Also Send Feedback
Occurs when the list managed by DataCubeView is changed.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public event ListChangedEventHandler ListChanged
Visual Basic (Declaration)
Public Event ListChanged As ListChangedEventHandler
Visual C++
public:
virtual  event ListChangedEventHandler^ ListChanged {
    void add (ListChangedEventHandler^ value);
    void remove (ListChangedEventHandler^ value);
}

Implements

IBindingList..::.ListChanged

See Also

DataCubeView Class
PerpetuumSoft.Olap Namespace


Direction Enumeration

[image]

.NET ModelKit Suite ClassReference
Direction Enumeration
See Also Send Feedback
Enumerates the directions.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public enum Direction
Visual Basic (Declaration)
Public Enumeration Direction
Visual C++
public enum class Direction

Members

Member name | Description
RightToLeft | Right to left.
LeftToRight | Left to right.
TopDown | Top-down.
BottomUp | Bottom-up.

See Also

PerpetuumSoft.Olap Namespace


DrawCellEventArgs Class

[image]

.NET ModelKit Suite ClassReference
DrawCellEventArgs Class
Members See Also Send Feedback
Provides data for the DrawCell event.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class DrawCellEventArgs : EventArgs
Visual Basic (Declaration)
Public Class DrawCellEventArgs _
    Inherits EventArgs
Visual C++
public ref class DrawCellEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Olap..::.DrawCellEventArgs

See Also

DrawCellEventArgs Members
PerpetuumSoft.Olap Namespace


DrawCellEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
DrawCellEventArgs Members
DrawCellEventArgs Class Constructors Methods Properties See Also Send Feedback

The DrawCellEventArgs type exposes the following members.

Constructors

Name | Description
DrawCellEventArgs | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CellInfo | Gets CellInfo that supplies the information on a table sell drawn.
CellStyle | Gets or sets CellStyle that supplies the style of a table cell drawn.
IsActiveCell | Gets a value which indicates whether a cell is a selected table cell.

See Also

DrawCellEventArgs Class
PerpetuumSoft.Olap Namespace


DrawCellEventArgs Constructor

[image] [image]

.NET ModelKit Suite ClassReference
DrawCellEventArgs Constructor
DrawCellEventArgs Class See Also Send Feedback

Overload List

Name | Description
DrawCellEventArgs(CellInfo, CellStyle) | Initializes a new instance of the DrawCellEventArgs class whith specific parameters.
DrawCellEventArgs(CellInfo, CellStyle, Boolean) | Initializes a new instance of the DrawCellEventArgs class whith specific parameters.

See Also

DrawCellEventArgs Class
DrawCellEventArgs Members
PerpetuumSoft.Olap Namespace


DrawCellEventArgs Constructor (CellInfo, CellStyle)

[image]

.NET ModelKit Suite ClassReference
DrawCellEventArgs Constructor (CellInfo, CellStyle)
DrawCellEventArgs Class See Also Send Feedback
Initializes a new instance of the DrawCellEventArgs class whith specific parameters.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public DrawCellEventArgs(
    CellInfo cellInfo,
    CellStyle cellStyle
)
Visual Basic (Declaration)
Public Sub New ( _
    cellInfo As CellInfo, _
    cellStyle As CellStyle _
)
Visual C++
public:
DrawCellEventArgs(
    CellInfo^ cellInfo,
    CellStyle^ cellStyle
)

Parameters

cellInfo
Type: PerpetuumSoft.Olap..::.CellInfo
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle

See Also

DrawCellEventArgs Class
DrawCellEventArgs Overload
PerpetuumSoft.Olap Namespace


DrawCellEventArgs Constructor (CellInfo, CellStyle, Boolean)

[image]

.NET ModelKit Suite ClassReference
DrawCellEventArgs Constructor (CellInfo, CellStyle, Boolean)
DrawCellEventArgs Class See Also Send Feedback
Initializes a new instance of the DrawCellEventArgs class whith specific parameters.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public DrawCellEventArgs(
    CellInfo cellInfo,
    CellStyle cellStyle,
    bool isActiveCell
)
Visual Basic (Declaration)
Public Sub New ( _
    cellInfo As CellInfo, _
    cellStyle As CellStyle, _
    isActiveCell As Boolean _
)
Visual C++
public:
DrawCellEventArgs(
    CellInfo^ cellInfo,
    CellStyle^ cellStyle,
    bool isActiveCell
)

Parameters

cellInfo
Type: PerpetuumSoft.Olap..::.CellInfo
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
isActiveCell
Type: System..::.Boolean

See Also

DrawCellEventArgs Class
DrawCellEventArgs Overload
PerpetuumSoft.Olap Namespace


DrawCellEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
DrawCellEventArgs Methods
DrawCellEventArgs Class See Also Send Feedback

The DrawCellEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DrawCellEventArgs Class
PerpetuumSoft.Olap Namespace


DrawCellEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
DrawCellEventArgs Properties
DrawCellEventArgs Class See Also Send Feedback

The DrawCellEventArgs type exposes the following members.

Properties

Name | Description
CellInfo | Gets CellInfo that supplies the information on a table sell drawn.
CellStyle | Gets or sets CellStyle that supplies the style of a table cell drawn.
IsActiveCell | Gets a value which indicates whether a cell is a selected table cell.

See Also

DrawCellEventArgs Class
PerpetuumSoft.Olap Namespace


CellInfo Property

[image]

.NET ModelKit Suite ClassReference
DrawCellEventArgs..::.CellInfo Property
DrawCellEventArgs Class See Also Send Feedback
Gets CellInfo that supplies the information on a table sell drawn.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellInfo CellInfo { get; }
Visual Basic (Declaration)
Public ReadOnly Property CellInfo As CellInfo
Visual C++
public:
property CellInfo^ CellInfo {
    CellInfo^ get ();
}

See Also

DrawCellEventArgs Class
PerpetuumSoft.Olap Namespace


CellStyle Property

[image]

.NET ModelKit Suite ClassReference
DrawCellEventArgs..::.CellStyle Property
DrawCellEventArgs Class See Also Send Feedback
Gets or sets CellStyle that supplies the style of a table cell drawn.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellStyle CellStyle { get; set; }
Visual Basic (Declaration)
Public Property CellStyle As CellStyle
Visual C++
public:
property CellStyle^ CellStyle {
    CellStyle^ get ();
    void set (CellStyle^ value);
}

See Also

DrawCellEventArgs Class
PerpetuumSoft.Olap Namespace


IsActiveCell Property

[image]

.NET ModelKit Suite ClassReference
DrawCellEventArgs..::.IsActiveCell Property
DrawCellEventArgs Class See Also Send Feedback
Gets a value which indicates whether a cell is a selected table cell.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool IsActiveCell { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsActiveCell As Boolean
Visual C++
public:
property bool IsActiveCell {
    bool get ();
}

See Also

DrawCellEventArgs Class
PerpetuumSoft.Olap Namespace


DrawCellEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
DrawCellEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the [E:PerpetuumSoft.Olap.Windows.Forms.DataCubeGrid.DrawCell} event of a {*T:PerpetuumSoft.Olap.Windows.Forms.DataCubeGrid}]

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public delegate void DrawCellEventHandler(
    Object sender,
    DrawCellEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub DrawCellEventHandler ( _
    sender As Object, _
    e As DrawCellEventArgs _
)
Visual C++
public delegate void DrawCellEventHandler(
    Object^ sender,
    DrawCellEventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: PerpetuumSoft.Olap..::.DrawCellEventArgs

See Also

PerpetuumSoft.Olap Namespace


DrawGridItemEventArgs Class

[image]

.NET ModelKit Suite ClassReference
DrawGridItemEventArgs Class
Members See Also Send Feedback
Provides data for the DrawGridItem event.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class DrawGridItemEventArgs : EventArgs
Visual Basic (Declaration)
Public Class DrawGridItemEventArgs _
    Inherits EventArgs
Visual C++
public ref class DrawGridItemEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Olap..::.DrawGridItemEventArgs

See Also

DrawGridItemEventArgs Members
PerpetuumSoft.Olap Namespace


DrawGridItemEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
DrawGridItemEventArgs Members
DrawGridItemEventArgs Class Constructors Methods Properties See Also Send Feedback

The DrawGridItemEventArgs type exposes the following members.

Constructors

Name | Description
DrawGridItemEventArgs | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bounds | Gets Rectangle that represents the bounds of the object drawn.
CellInfo | Gets CellInfo that supplies the information on a table sell drawn.
CellStyle | Gets CellStyle that supplies the style of a table cell drawn.
Graphics | Gets the graphics used to paint.
Handled | Gets or sets a value indicating whether the [E:PerpetuumSoft.Olap.Windows.Forms.DataCubeGrid.DrawGridItem} event will be handled.]
Value | Gets or sets a value for the object displayed.

See Also

DrawGridItemEventArgs Class
PerpetuumSoft.Olap Namespace


DrawGridItemEventArgs Constructor

[image] [image]

.NET ModelKit Suite ClassReference
DrawGridItemEventArgs Constructor
DrawGridItemEventArgs Class See Also Send Feedback

Overload List

Name | Description
DrawGridItemEventArgs(Graphics, Rectangle, CellInfo, CellStyle) | Initializes a new instance of the DrawGridItemEventArgs class whith specific parameters.
DrawGridItemEventArgs(Graphics, Rectangle, CellInfo, CellStyle, String) | Initializes a new instance of the DrawGridItemEventArgs class whith specific parameters.

See Also

DrawGridItemEventArgs Class
DrawGridItemEventArgs Members
PerpetuumSoft.Olap Namespace


DrawGridItemEventArgs Constructor (Graphics, Rectangle, CellInfo, CellStyle)

[image]

.NET ModelKit Suite ClassReference
DrawGridItemEventArgs Constructor (Graphics, Rectangle, CellInfo, CellStyle)
DrawGridItemEventArgs Class See Also Send Feedback
Initializes a new instance of the DrawGridItemEventArgs class whith specific parameters.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public DrawGridItemEventArgs(
    Graphics graphics,
    Rectangle bounds,
    CellInfo cellInfo,
    CellStyle cellStyle
)
Visual Basic (Declaration)
Public Sub New ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellInfo As CellInfo, _
    cellStyle As CellStyle _
)
Visual C++
public:
DrawGridItemEventArgs(
    Graphics^ graphics,
    Rectangle bounds,
    CellInfo^ cellInfo,
    CellStyle^ cellStyle
)

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellInfo
Type: PerpetuumSoft.Olap..::.CellInfo
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle

See Also

DrawGridItemEventArgs Class
DrawGridItemEventArgs Overload
PerpetuumSoft.Olap Namespace


DrawGridItemEventArgs Constructor (Graphics, Rectangle, CellInfo, CellStyle, String)

[image]

.NET ModelKit Suite ClassReference
DrawGridItemEventArgs Constructor (Graphics, Rectangle, CellInfo, CellStyle, String)
DrawGridItemEventArgs Class See Also Send Feedback
Initializes a new instance of the DrawGridItemEventArgs class whith specific parameters.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public DrawGridItemEventArgs(
    Graphics graphics,
    Rectangle bounds,
    CellInfo cellInfo,
    CellStyle cellStyle,
    string value
)
Visual Basic (Declaration)
Public Sub New ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellInfo As CellInfo, _
    cellStyle As CellStyle, _
    value As String _
)
Visual C++
public:
DrawGridItemEventArgs(
    Graphics^ graphics,
    Rectangle bounds,
    CellInfo^ cellInfo,
    CellStyle^ cellStyle,
    String^ value
)

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellInfo
Type: PerpetuumSoft.Olap..::.CellInfo
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
value
Type: System..::.String

See Also

DrawGridItemEventArgs Class
DrawGridItemEventArgs Overload
PerpetuumSoft.Olap Namespace


DrawGridItemEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
DrawGridItemEventArgs Methods
DrawGridItemEventArgs Class See Also Send Feedback

The DrawGridItemEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DrawGridItemEventArgs Class
PerpetuumSoft.Olap Namespace


DrawGridItemEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
DrawGridItemEventArgs Properties
DrawGridItemEventArgs Class See Also Send Feedback

The DrawGridItemEventArgs type exposes the following members.

Properties

Name | Description
Bounds | Gets Rectangle that represents the bounds of the object drawn.
CellInfo | Gets CellInfo that supplies the information on a table sell drawn.
CellStyle | Gets CellStyle that supplies the style of a table cell drawn.
Graphics | Gets the graphics used to paint.
Handled | Gets or sets a value indicating whether the [E:PerpetuumSoft.Olap.Windows.Forms.DataCubeGrid.DrawGridItem} event will be handled.]
Value | Gets or sets a value for the object displayed.

See Also

DrawGridItemEventArgs Class
PerpetuumSoft.Olap Namespace


Bounds Property

[image]

.NET ModelKit Suite ClassReference
DrawGridItemEventArgs..::.Bounds Property
DrawGridItemEventArgs Class See Also Send Feedback
Gets Rectangle that represents the bounds of the object drawn.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Rectangle Bounds { get; }
Visual Basic (Declaration)
Public ReadOnly Property Bounds As Rectangle
Visual C++
public:
property Rectangle Bounds {
    Rectangle get ();
}

See Also

DrawGridItemEventArgs Class
PerpetuumSoft.Olap Namespace


CellInfo Property

[image]

.NET ModelKit Suite ClassReference
DrawGridItemEventArgs..::.CellInfo Property
DrawGridItemEventArgs Class See Also Send Feedback
Gets CellInfo that supplies the information on a table sell drawn.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellInfo CellInfo { get; }
Visual Basic (Declaration)
Public ReadOnly Property CellInfo As CellInfo
Visual C++
public:
property CellInfo^ CellInfo {
    CellInfo^ get ();
}

See Also

DrawGridItemEventArgs Class
PerpetuumSoft.Olap Namespace


CellStyle Property

[image]

.NET ModelKit Suite ClassReference
DrawGridItemEventArgs..::.CellStyle Property
DrawGridItemEventArgs Class See Also Send Feedback
Gets CellStyle that supplies the style of a table cell drawn.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellStyle CellStyle { get; }
Visual Basic (Declaration)
Public ReadOnly Property CellStyle As CellStyle
Visual C++
public:
property CellStyle^ CellStyle {
    CellStyle^ get ();
}

See Also

DrawGridItemEventArgs Class
PerpetuumSoft.Olap Namespace


Graphics Property

[image]

.NET ModelKit Suite ClassReference
DrawGridItemEventArgs..::.Graphics Property
DrawGridItemEventArgs Class See Also Send Feedback
Gets the graphics used to paint.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Graphics Graphics { get; }
Visual Basic (Declaration)
Public ReadOnly Property Graphics As Graphics
Visual C++
public:
property Graphics^ Graphics {
    Graphics^ get ();
}

See Also

DrawGridItemEventArgs Class
PerpetuumSoft.Olap Namespace


Handled Property

[image]

.NET ModelKit Suite ClassReference
DrawGridItemEventArgs..::.Handled Property
DrawGridItemEventArgs Class See Also Send Feedback
Gets or sets a value indicating whether the [E:PerpetuumSoft.Olap.Windows.Forms.DataCubeGrid.DrawGridItem} event will be handled.]

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool Handled { get; set; }
Visual Basic (Declaration)
Public Property Handled As Boolean
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

See Also

DrawGridItemEventArgs Class
PerpetuumSoft.Olap Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
DrawGridItemEventArgs..::.Value Property
DrawGridItemEventArgs Class See Also Send Feedback
Gets or sets a value for the object displayed.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

DrawGridItemEventArgs Class
PerpetuumSoft.Olap Namespace


DrawGridItemEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
DrawGridItemEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the [E:PerpetuumSoft.Olap.Windows.Forms.DataCubeGrid.DrawGridItem} event of a {*T:PerpetuumSoft.Olap.Windows.Forms.DataCubeGrid}]

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public delegate void DrawGridItemEventHandler(
    Object sender,
    DrawGridItemEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub DrawGridItemEventHandler ( _
    sender As Object, _
    e As DrawGridItemEventArgs _
)
Visual C++
public delegate void DrawGridItemEventHandler(
    Object^ sender,
    DrawGridItemEventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: PerpetuumSoft.Olap..::.DrawGridItemEventArgs

See Also

PerpetuumSoft.Olap Namespace


EmptyFilter Class

[image]

.NET ModelKit Suite ClassReference
EmptyFilter Class
Members See Also Send Feedback
Represents an empty filter.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class EmptyFilter : IFilter
Visual Basic (Declaration)
Public Class EmptyFilter _
    Implements IFilter
Visual C++
public ref class EmptyFilter : IFilter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.EmptyFilter

See Also

EmptyFilter Members
PerpetuumSoft.Olap Namespace


EmptyFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
EmptyFilter Members
EmptyFilter Class Methods Properties See Also Send Feedback

The EmptyFilter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsFiltered | Implements IsFiltered(Object, IExpressionSite).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Filter | Gets a single empty filter.
IsActive | Implements IsActive.

See Also

EmptyFilter Class
PerpetuumSoft.Olap Namespace


EmptyFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
EmptyFilter Methods
EmptyFilter Class See Also Send Feedback

The EmptyFilter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsFiltered | Implements IsFiltered(Object, IExpressionSite).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmptyFilter Class
PerpetuumSoft.Olap Namespace


IsFiltered Method

[image]

.NET ModelKit Suite ClassReference
EmptyFilter..::.IsFiltered Method
EmptyFilter Class See Also Send Feedback
Implements IsFiltered(Object, IExpressionSite).

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool IsFiltered(
    Object value,
    IExpressionSite site
)
Visual Basic (Declaration)
Public Function IsFiltered ( _
    value As Object, _
    site As IExpressionSite _
) As Boolean
Visual C++
public:
virtual bool IsFiltered(
    Object^ value,
    IExpressionSite^ site
) sealed

Parameters

value
Type: System..::.Object
site
Type: IExpressionSite

Implements

IFilter..::.IsFiltered(Object, IExpressionSite)

See Also

EmptyFilter Class
PerpetuumSoft.Olap Namespace


EmptyFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
EmptyFilter Properties
EmptyFilter Class See Also Send Feedback

The EmptyFilter type exposes the following members.

Properties

Name | Description
Filter | Gets a single empty filter.
IsActive | Implements IsActive.

See Also

EmptyFilter Class
PerpetuumSoft.Olap Namespace


Filter Property

[image]

.NET ModelKit Suite ClassReference
EmptyFilter..::.Filter Property
EmptyFilter Class See Also Send Feedback
Gets a single empty filter.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public static EmptyFilter Filter { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Filter As EmptyFilter
Visual C++
public:
static property EmptyFilter^ Filter {
    EmptyFilter^ get ();
}

See Also

EmptyFilter Class
PerpetuumSoft.Olap Namespace


IsActive Property

[image]

.NET ModelKit Suite ClassReference
EmptyFilter..::.IsActive Property
EmptyFilter Class See Also Send Feedback
Implements IsActive.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool IsActive { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsActive As Boolean
Visual C++
public:
virtual property bool IsActive {
    bool get () sealed;
}

Implements

IFilter..::.IsActive

See Also

EmptyFilter Class
PerpetuumSoft.Olap Namespace


Field Class

[image]

.NET ModelKit Suite ClassReference
Field Class
Members See Also Send Feedback
Represents a pivot table field.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class Field
Visual Basic (Declaration)
Public Class Field
Visual C++
public ref class Field

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.Field

See Also

Field Members
PerpetuumSoft.Olap Namespace


Field Members

[image] [image]

.NET ModelKit Suite ClassReference
Field Members
Field Class Constructors Methods Properties See Also Send Feedback

The Field type exposes the following members.

Constructors

Name | Description
Field | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValueToString | Returns a fields value string notion.

Properties

Name | Description
Aggregate | Gets or sets AggregateTableFactory object which creates an aggregate function.
Caption | Gets or sets field caption.
DisplayExpression | Gets or sets the expression for displaying data of the given field.
Expression | Gets or sets the expression for calculating data of a field.
FieldType | Gets or sets FieldType mode representing a way the given field can be used.
Filter | Gets or sets the IFilter object used for data filtering.
Format | Gets or sets string format used for field data printing.
Groups | Gets custom field groups.
ShowPercent | Gets or sets the value that indicates whether the data will be displayed in percentage terms.
ShowProgress | Gets or sets the value that indicates whether the data will be displayed as progess.
SortOrder | Gets or sets SortOrder indicating the sort order.
TotalLabel | Gets or sets the total value caption.
Width | Gets or sets field column width.

See Also

Field Class
PerpetuumSoft.Olap Namespace


Field Constructor

[image] [image]

.NET ModelKit Suite ClassReference
Field Constructor
Field Class See Also Send Feedback

Overload List

Name | Description
Field()()() | Initializes a new instance of the Field class.
Field(String, String) | Initializes the new instance of the Field class with specific parameters. The parameters indicate a caption and a field expression.
Field(String, String, SortOrder) | Initializes the new instance of the Field class with specific parameters. The parameters indicate a caption, a field exspression and sort order.

See Also

Field Class
Field Members
PerpetuumSoft.Olap Namespace


Field Constructor

[image]

.NET ModelKit Suite ClassReference
Field Constructor
Field Class See Also Send Feedback
Initializes a new instance of the Field class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Field()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Field()

See Also

Field Class
Field Overload
PerpetuumSoft.Olap Namespace


Field Constructor (String, String)

[image]

.NET ModelKit Suite ClassReference
Field Constructor (String, String)
Field Class See Also Send Feedback
Initializes the new instance of the Field class with specific parameters. The parameters indicate a caption and a field expression.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Field(
    string caption,
    string expression
)
Visual Basic (Declaration)
Public Sub New ( _
    caption As String, _
    expression As String _
)
Visual C++
public:
Field(
    String^ caption,
    String^ expression
)

Parameters

caption
Type: System..::.String
expression
Type: System..::.String

See Also

Field Class
Field Overload
PerpetuumSoft.Olap Namespace


Field Constructor (String, String, SortOrder)

[image]

.NET ModelKit Suite ClassReference
Field Constructor (String, String, SortOrder)
Field Class See Also Send Feedback
Initializes the new instance of the Field class with specific parameters. The parameters indicate a caption, a field exspression and sort order.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Field(
    string caption,
    string expression,
    SortOrder sortOrder
)
Visual Basic (Declaration)
Public Sub New ( _
    caption As String, _
    expression As String, _
    sortOrder As SortOrder _
)
Visual C++
public:
Field(
    String^ caption,
    String^ expression,
    SortOrder sortOrder
)

Parameters

caption
Type: System..::.String
expression
Type: System..::.String
sortOrder
Type: PerpetuumSoft.Olap..::.SortOrder

See Also

Field Class
Field Overload
PerpetuumSoft.Olap Namespace


Field Methods

[image] [image]

.NET ModelKit Suite ClassReference
Field Methods
Field Class See Also Send Feedback

The Field type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValueToString | Returns a fields value string notion.

See Also

Field Class
PerpetuumSoft.Olap Namespace


ValueToString Method

[image]

.NET ModelKit Suite ClassReference
Field..::.ValueToString Method
Field Class See Also Send Feedback
Returns a fields value string notion.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public string ValueToString(
    Object value,
    bool showZeroValues
)
Visual Basic (Declaration)
Public Function ValueToString ( _
    value As Object, _
    showZeroValues As Boolean _
) As String
Visual C++
public:
String^ ValueToString(
    Object^ value,
    bool showZeroValues
)

Parameters

value
Type: System..::.Object
showZeroValues
Type: System..::.Boolean

See Also

Field Class
PerpetuumSoft.Olap Namespace


Field Properties

[image] [image]

.NET ModelKit Suite ClassReference
Field Properties
Field Class See Also Send Feedback

The Field type exposes the following members.

Properties

Name | Description
Aggregate | Gets or sets AggregateTableFactory object which creates an aggregate function.
Caption | Gets or sets field caption.
DisplayExpression | Gets or sets the expression for displaying data of the given field.
Expression | Gets or sets the expression for calculating data of a field.
FieldType | Gets or sets FieldType mode representing a way the given field can be used.
Filter | Gets or sets the IFilter object used for data filtering.
Format | Gets or sets string format used for field data printing.
Groups | Gets custom field groups.
ShowPercent | Gets or sets the value that indicates whether the data will be displayed in percentage terms.
ShowProgress | Gets or sets the value that indicates whether the data will be displayed as progess.
SortOrder | Gets or sets SortOrder indicating the sort order.
TotalLabel | Gets or sets the total value caption.
Width | Gets or sets field column width.

See Also

Field Class
PerpetuumSoft.Olap Namespace


Aggregate Property

[image]

.NET ModelKit Suite ClassReference
Field..::.Aggregate Property
Field Class See Also Send Feedback
Gets or sets AggregateTableFactory object which creates an aggregate function.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public AggregateFunctionFactory Aggregate { get; set; }
Visual Basic (Declaration)
Public Property Aggregate As AggregateFunctionFactory
Visual C++
public:
property AggregateFunctionFactory^ Aggregate {
    AggregateFunctionFactory^ get ();
    void set (AggregateFunctionFactory^ value);
}

See Also

Field Class
PerpetuumSoft.Olap Namespace


Caption Property

[image]

.NET ModelKit Suite ClassReference
Field..::.Caption Property
Field Class See Also Send Feedback
Gets or sets field caption.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public string Caption { get; set; }
Visual Basic (Declaration)
Public Property Caption As String
Visual C++
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class
PerpetuumSoft.Olap Namespace


DisplayExpression Property

[image]

.NET ModelKit Suite ClassReference
Field..::.DisplayExpression Property
Field Class See Also Send Feedback
Gets or sets the expression for displaying data of the given field.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public string DisplayExpression { get; set; }
Visual Basic (Declaration)
Public Property DisplayExpression As String
Visual C++
public:
property String^ DisplayExpression {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class
PerpetuumSoft.Olap Namespace


Expression Property

[image]

.NET ModelKit Suite ClassReference
Field..::.Expression Property
Field Class See Also Send Feedback
Gets or sets the expression for calculating data of a field.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class
PerpetuumSoft.Olap Namespace


FieldType Property

[image]

.NET ModelKit Suite ClassReference
Field..::.FieldType Property
Field Class See Also Send Feedback
Gets or sets FieldType mode representing a way the given field can be used.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldType FieldType { get; set; }
Visual Basic (Declaration)
Public Property FieldType As FieldType
Visual C++
public:
property FieldType FieldType {
    FieldType get ();
    void set (FieldType value);
}

See Also

Field Class
PerpetuumSoft.Olap Namespace


Filter Property

[image]

.NET ModelKit Suite ClassReference
Field..::.Filter Property
Field Class See Also Send Feedback
Gets or sets the IFilter object used for data filtering.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public IFilter Filter { get; set; }
Visual Basic (Declaration)
Public Property Filter As IFilter
Visual C++
public:
property IFilter^ Filter {
    IFilter^ get ();
    void set (IFilter^ value);
}

See Also

Field Class
PerpetuumSoft.Olap Namespace


Format Property

[image]

.NET ModelKit Suite ClassReference
Field..::.Format Property
Field Class See Also Send Feedback
Gets or sets string format used for field data printing.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public string Format { get; set; }
Visual Basic (Declaration)
Public Property Format As String
Visual C++
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class
PerpetuumSoft.Olap Namespace


Groups Property

[image]

.NET ModelKit Suite ClassReference
Field..::.Groups Property
Field Class See Also Send Feedback
Gets custom field groups.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Hashtable Groups { get; }
Visual Basic (Declaration)
Public ReadOnly Property Groups As Hashtable
Visual C++
public:
property Hashtable^ Groups {
    Hashtable^ get ();
}

See Also

Field Class
PerpetuumSoft.Olap Namespace


ShowPercent Property

[image]

.NET ModelKit Suite ClassReference
Field..::.ShowPercent Property
Field Class See Also Send Feedback
Gets or sets the value that indicates whether the data will be displayed in percentage terms.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowPercent { get; set; }
Visual Basic (Declaration)
Public Property ShowPercent As Boolean
Visual C++
public:
property bool ShowPercent {
    bool get ();
    void set (bool value);
}

See Also

Field Class
PerpetuumSoft.Olap Namespace


ShowProgress Property

[image]

.NET ModelKit Suite ClassReference
Field..::.ShowProgress Property
Field Class See Also Send Feedback
Gets or sets the value that indicates whether the data will be displayed as progess.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowProgress { get; set; }
Visual Basic (Declaration)
Public Property ShowProgress As Boolean
Visual C++
public:
property bool ShowProgress {
    bool get ();
    void set (bool value);
}

See Also

Field Class
PerpetuumSoft.Olap Namespace


SortOrder Property

[image]

.NET ModelKit Suite ClassReference
Field..::.SortOrder Property
Field Class See Also Send Feedback
Gets or sets SortOrder indicating the sort order.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public SortOrder SortOrder { get; set; }
Visual Basic (Declaration)
Public Property SortOrder As SortOrder
Visual C++
public:
property SortOrder SortOrder {
    SortOrder get ();
    void set (SortOrder value);
}

See Also

Field Class
PerpetuumSoft.Olap Namespace


TotalLabel Property

[image]

.NET ModelKit Suite ClassReference
Field..::.TotalLabel Property
Field Class See Also Send Feedback
Gets or sets the total value caption.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public string TotalLabel { get; set; }
Visual Basic (Declaration)
Public Property TotalLabel As String
Visual C++
public:
property String^ TotalLabel {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class
PerpetuumSoft.Olap Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
Field..::.Width Property
Field Class See Also Send Feedback
Gets or sets field column width.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

See Also

Field Class
PerpetuumSoft.Olap Namespace


FieldItem Class

[image]

.NET ModelKit Suite ClassReference
FieldItem Class
Members See Also Send Feedback
Represents a dimension item of a pivot table.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class FieldItem
Visual Basic (Declaration)
Public Class FieldItem
Visual C++
public ref class FieldItem

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.FieldItem

See Also

FieldItem Members
PerpetuumSoft.Olap Namespace


FieldItem Members

[image] [image]

.NET ModelKit Suite ClassReference
FieldItem Members
FieldItem Class Constructors Methods Properties See Also Send Feedback

The FieldItem type exposes the following members.

Constructors

Name | Description
FieldItem | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSheetCount | Returns the number of "sheet" items for the given item.
GetTreeDepth | Returns the depth of a tree which root is the given item.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ChildItems | Gets FieldItemCollection containing child items.
Collapsed | Gets or sets the value indicating whether child items will be displayed.
DisplayValue | Gets value for field item displaying.
Index | Gets or sets an index of a pivot table row or column.
IsTotal | Gets the value indicating whether this item is a group total.
Parent | Gets a parent item for the given field item.
Value | Gets a field item value.

See Also

FieldItem Class
PerpetuumSoft.Olap Namespace


FieldItem Constructor

[image] [image]

.NET ModelKit Suite ClassReference
FieldItem Constructor
FieldItem Class See Also Send Feedback

Overload List

Name | Description
FieldItem(Object) | Initializes a new instance of the FieldItem class with specific parameters. Parameters set the Value property.
FieldItem(Object, FieldItem) | Initializes a new instance of the FieldItem class with specific parameters. Parameters set Value and Parent properties.
FieldItem(Object, Int32) | Initializes a new instance of the FieldItem class with specific parameters. Parameters set Value and Index properties.
FieldItem(Object, Int32, FieldItem) | Initializes a new instance of the FieldItem class with specific parameters. Parameters set Value, Index and Parent properties.
FieldItem(Object, Object, FieldItem) | Initializes a new instance of the FieldItem class with specific parameters. Parameters set Value, DisplayValue and Parent properties.
FieldItem(Object, Object, Int32, FieldItem) | Initializes a new instance of the FieldItem class with specific parameters. Parameters set Value, DisplayValue, Index and Parent properties.

See Also

FieldItem Class
FieldItem Members
PerpetuumSoft.Olap Namespace


FieldItem Constructor (Object)

[image]

.NET ModelKit Suite ClassReference
FieldItem Constructor (Object)
FieldItem Class See Also Send Feedback
Initializes a new instance of the FieldItem class with specific parameters. Parameters set the Value property.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem(
    Object value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Object _
)
Visual C++
public:
FieldItem(
    Object^ value
)

Parameters

value
Type: System..::.Object

See Also

FieldItem Class
FieldItem Overload
PerpetuumSoft.Olap Namespace


FieldItem Constructor (Object, FieldItem)

[image]

.NET ModelKit Suite ClassReference
FieldItem Constructor (Object, FieldItem)
FieldItem Class See Also Send Feedback
Initializes a new instance of the FieldItem class with specific parameters. Parameters set Value and Parent properties.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem(
    Object value,
    FieldItem parent
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Object, _
    parent As FieldItem _
)
Visual C++
public:
FieldItem(
    Object^ value,
    FieldItem^ parent
)

Parameters

value
Type: System..::.Object
parent
Type: PerpetuumSoft.Olap..::.FieldItem

See Also

FieldItem Class
FieldItem Overload
PerpetuumSoft.Olap Namespace


FieldItem Constructor (Object, Int32)

[image]

.NET ModelKit Suite ClassReference
FieldItem Constructor (Object, Int32)
FieldItem Class See Also Send Feedback
Initializes a new instance of the FieldItem class with specific parameters. Parameters set Value and Index properties.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem(
    Object value,
    int index
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Object, _
    index As Integer _
)
Visual C++
public:
FieldItem(
    Object^ value,
    int index
)

Parameters

value
Type: System..::.Object
index
Type: System..::.Int32

See Also

FieldItem Class
FieldItem Overload
PerpetuumSoft.Olap Namespace


FieldItem Constructor (Object, Int32, FieldItem)

[image]

.NET ModelKit Suite ClassReference
FieldItem Constructor (Object, Int32, FieldItem)
FieldItem Class See Also Send Feedback
Initializes a new instance of the FieldItem class with specific parameters. Parameters set Value, Index and Parent properties.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem(
    Object value,
    int index,
    FieldItem parent
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Object, _
    index As Integer, _
    parent As FieldItem _
)
Visual C++
public:
FieldItem(
    Object^ value,
    int index,
    FieldItem^ parent
)

Parameters

value
Type: System..::.Object
index
Type: System..::.Int32
parent
Type: PerpetuumSoft.Olap..::.FieldItem

See Also

FieldItem Class
FieldItem Overload
PerpetuumSoft.Olap Namespace


FieldItem Constructor (Object, Object, FieldItem)

[image]

.NET ModelKit Suite ClassReference
FieldItem Constructor (Object, Object, FieldItem)
FieldItem Class See Also Send Feedback
Initializes a new instance of the FieldItem class with specific parameters. Parameters set Value, DisplayValue and Parent properties.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem(
    Object value,
    Object displayValue,
    FieldItem parent
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Object, _
    displayValue As Object, _
    parent As FieldItem _
)
Visual C++
public:
FieldItem(
    Object^ value,
    Object^ displayValue,
    FieldItem^ parent
)

Parameters

value
Type: System..::.Object
displayValue
Type: System..::.Object
parent
Type: PerpetuumSoft.Olap..::.FieldItem

See Also

FieldItem Class
FieldItem Overload
PerpetuumSoft.Olap Namespace


FieldItem Constructor (Object, Object, Int32, FieldItem)

[image]

.NET ModelKit Suite ClassReference
FieldItem Constructor (Object, Object, Int32, FieldItem)
FieldItem Class See Also Send Feedback
Initializes a new instance of the FieldItem class with specific parameters. Parameters set Value, DisplayValue, Index and Parent properties.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem(
    Object value,
    Object displayValue,
    int index,
    FieldItem parent
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Object, _
    displayValue As Object, _
    index As Integer, _
    parent As FieldItem _
)
Visual C++
public:
FieldItem(
    Object^ value,
    Object^ displayValue,
    int index,
    FieldItem^ parent
)

Parameters

value
Type: System..::.Object
displayValue
Type: System..::.Object
index
Type: System..::.Int32
parent
Type: PerpetuumSoft.Olap..::.FieldItem

See Also

FieldItem Class
FieldItem Overload
PerpetuumSoft.Olap Namespace


FieldItem Methods

[image] [image]

.NET ModelKit Suite ClassReference
FieldItem Methods
FieldItem Class See Also Send Feedback

The FieldItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSheetCount | Returns the number of "sheet" items for the given item.
GetTreeDepth | Returns the depth of a tree which root is the given item.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldItem Class
PerpetuumSoft.Olap Namespace


GetSheetCount Method

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.GetSheetCount Method
FieldItem Class See Also Send Feedback
Returns the number of "sheet" items for the given item.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public int GetSheetCount()
Visual Basic (Declaration)
Public Function GetSheetCount As Integer
Visual C++
public:
int GetSheetCount()

See Also

FieldItem Class
PerpetuumSoft.Olap Namespace


GetTreeDepth Method

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.GetTreeDepth Method
FieldItem Class See Also Send Feedback
Returns the depth of a tree which root is the given item.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public int GetTreeDepth()
Visual Basic (Declaration)
Public Function GetTreeDepth As Integer
Visual C++
public:
int GetTreeDepth()

See Also

FieldItem Class
PerpetuumSoft.Olap Namespace


FieldItem Properties

[image] [image]

.NET ModelKit Suite ClassReference
FieldItem Properties
FieldItem Class See Also Send Feedback

The FieldItem type exposes the following members.

Properties

Name | Description
ChildItems | Gets FieldItemCollection containing child items.
Collapsed | Gets or sets the value indicating whether child items will be displayed.
DisplayValue | Gets value for field item displaying.
Index | Gets or sets an index of a pivot table row or column.
IsTotal | Gets the value indicating whether this item is a group total.
Parent | Gets a parent item for the given field item.
Value | Gets a field item value.

See Also

FieldItem Class
PerpetuumSoft.Olap Namespace


ChildItems Property

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.ChildItems Property
FieldItem Class See Also Send Feedback
Gets FieldItemCollection containing child items.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldItemCollection ChildItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChildItems As FieldItemCollection
Visual C++
public:
property FieldItemCollection^ ChildItems {
    FieldItemCollection^ get ();
}

See Also

FieldItem Class
PerpetuumSoft.Olap Namespace


Collapsed Property

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.Collapsed Property
FieldItem Class See Also Send Feedback
Gets or sets the value indicating whether child items will be displayed.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool Collapsed { get; set; }
Visual Basic (Declaration)
Public Property Collapsed As Boolean
Visual C++
public:
property bool Collapsed {
    bool get ();
    void set (bool value);
}

See Also

FieldItem Class
PerpetuumSoft.Olap Namespace


DisplayValue Property

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.DisplayValue Property
FieldItem Class See Also Send Feedback
Gets value for field item displaying.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Object DisplayValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayValue As Object
Visual C++
public:
property Object^ DisplayValue {
    Object^ get ();
}

See Also

FieldItem Class
PerpetuumSoft.Olap Namespace


Index Property

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.Index Property
FieldItem Class See Also Send Feedback
Gets or sets an index of a pivot table row or column.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public int Index { get; set; }
Visual Basic (Declaration)
Public Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
    void set (int value);
}

See Also

FieldItem Class
PerpetuumSoft.Olap Namespace


IsTotal Property

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.IsTotal Property
FieldItem Class See Also Send Feedback
Gets the value indicating whether this item is a group total.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool IsTotal { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsTotal As Boolean
Visual C++
public:
property bool IsTotal {
    bool get ();
}

See Also

FieldItem Class
PerpetuumSoft.Olap Namespace


Parent Property

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.Parent Property
FieldItem Class See Also Send Feedback
Gets a parent item for the given field item.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As FieldItem
Visual C++
public:
property FieldItem^ Parent {
    FieldItem^ get ();
    void set (FieldItem^ value);
}

See Also

FieldItem Class
PerpetuumSoft.Olap Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.Value Property
FieldItem Class See Also Send Feedback
Gets a field item value.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Object Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
}

See Also

FieldItem Class
PerpetuumSoft.Olap Namespace


FieldItem.ErrorValue Class

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.ErrorValue Class
FieldItem Class Members See Also Send Feedback
Represents data for an incorrect field item.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class ErrorValue
Visual Basic (Declaration)
Public Class ErrorValue
Visual C++
public ref class ErrorValue

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.FieldItem..::.ErrorValue

See Also

FieldItem..::.ErrorValue Members
PerpetuumSoft.Olap Namespace


FieldItem.ErrorValue Members

[image] [image]

.NET ModelKit Suite ClassReference
FieldItem..::.ErrorValue Members
FieldItem..::.ErrorValue Class Constructors Methods See Also Send Feedback

Represents a dimension item of a pivot table.

The FieldItem..::.ErrorValue type exposes the following members.

Constructors

Name | Description
FieldItem..::.ErrorValue | Initializes a new instance of the FieldItem..::.ErrorValue class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldItem..::.ErrorValue Class
PerpetuumSoft.Olap Namespace


FieldItem.ErrorValue Constructor

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.ErrorValue Constructor
FieldItem..::.ErrorValue Class See Also Send Feedback
Initializes a new instance of the FieldItem..::.ErrorValue class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public ErrorValue(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
ErrorValue(
    String^ message
)

Parameters

message
Type: System..::.String

See Also

FieldItem..::.ErrorValue Class
PerpetuumSoft.Olap Namespace


FieldItem.ErrorValue Methods

[image] [image]

.NET ModelKit Suite ClassReference
FieldItem..::.ErrorValue Methods
FieldItem..::.ErrorValue Class See Also Send Feedback

The FieldItem..::.ErrorValue type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldItem..::.ErrorValue Class
PerpetuumSoft.Olap Namespace


FieldItem.NullValue Class

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.NullValue Class
FieldItem Class Members See Also Send Feedback
Represents an indeterminate value for FieldItem.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class NullValue
Visual Basic (Declaration)
Public Class NullValue
Visual C++
public ref class NullValue

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.FieldItem..::.NullValue

See Also

FieldItem..::.NullValue Members
PerpetuumSoft.Olap Namespace


FieldItem.NullValue Members

[image] [image]

.NET ModelKit Suite ClassReference
FieldItem..::.NullValue Members
FieldItem..::.NullValue Class Methods Properties See Also Send Feedback

Represents a dimension item of a pivot table.

The FieldItem..::.NullValue type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Value | Gets FieldItem..::.NullValue.

See Also

FieldItem..::.NullValue Class
PerpetuumSoft.Olap Namespace


FieldItem.NullValue Methods

[image] [image]

.NET ModelKit Suite ClassReference
FieldItem..::.NullValue Methods
FieldItem..::.NullValue Class See Also Send Feedback

The FieldItem..::.NullValue type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldItem..::.NullValue Class
PerpetuumSoft.Olap Namespace


FieldItem.NullValue Properties

[image] [image]

.NET ModelKit Suite ClassReference
FieldItem..::.NullValue Properties
FieldItem..::.NullValue Class See Also Send Feedback

The FieldItem..::.NullValue type exposes the following members.

Properties

Name | Description
Value | Gets FieldItem..::.NullValue.

See Also

FieldItem..::.NullValue Class
PerpetuumSoft.Olap Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.NullValue..::.Value Property
FieldItem..::.NullValue Class See Also Send Feedback
Gets FieldItem..::.NullValue.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public static FieldItem..::.NullValue Value { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Value As FieldItem..::.NullValue
Visual C++
public:
static property FieldItem..::.NullValue^ Value {
    FieldItem..::.NullValue^ get ();
}

See Also

FieldItem..::.NullValue Class
PerpetuumSoft.Olap Namespace


FieldItem.TotalValue Class

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.TotalValue Class
FieldItem Class Members See Also Send Feedback
Represents data for the total item.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class TotalValue
Visual Basic (Declaration)
Public Class TotalValue
Visual C++
public ref class TotalValue

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.FieldItem..::.TotalValue

See Also

FieldItem..::.TotalValue Members
PerpetuumSoft.Olap Namespace


FieldItem.TotalValue Members

[image] [image]

.NET ModelKit Suite ClassReference
FieldItem..::.TotalValue Members
FieldItem..::.TotalValue Class Constructors Methods See Also Send Feedback

Represents a dimension item of a pivot table.

The FieldItem..::.TotalValue type exposes the following members.

Constructors

Name | Description
FieldItem..::.TotalValue | Initializes a new instance of the FieldItem..::.TotalValue class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldItem..::.TotalValue Class
PerpetuumSoft.Olap Namespace


FieldItem.TotalValue Constructor

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.TotalValue Constructor
FieldItem..::.TotalValue Class See Also Send Feedback
Initializes a new instance of the FieldItem..::.TotalValue class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public TotalValue(
    Field field
)
Visual Basic (Declaration)
Public Sub New ( _
    field As Field _
)
Visual C++
public:
TotalValue(
    Field^ field
)

Parameters

field
Type: PerpetuumSoft.Olap..::.Field

See Also

FieldItem..::.TotalValue Class
PerpetuumSoft.Olap Namespace


FieldItem.TotalValue Methods

[image] [image]

.NET ModelKit Suite ClassReference
FieldItem..::.TotalValue Methods
FieldItem..::.TotalValue Class See Also Send Feedback

The FieldItem..::.TotalValue type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldItem..::.TotalValue Class
PerpetuumSoft.Olap Namespace


FieldItemCollection Class

[image]

.NET ModelKit Suite ClassReference
FieldItemCollection Class
Members See Also Send Feedback
Represents a collection of FieldItem.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class FieldItemCollection : ICollection,
    IEnumerable
Visual Basic (Declaration)
Public Class FieldItemCollection _
    Implements ICollection, IEnumerable
Visual C++
public ref class FieldItemCollection : ICollection,
    IEnumerable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.FieldItemCollection

See Also

FieldItemCollection Members
PerpetuumSoft.Olap Namespace


FieldItemCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
FieldItemCollection Members
FieldItemCollection Class Constructors Methods Properties Events See Also Send Feedback

The FieldItemCollection type exposes the following members.

Constructors

Name | Description
FieldItemCollection | Initializes a new instance of the FieldItemCollection class.

Methods

Name | Description
Add | Adds FieldItem to the collection.
CopyTo | Implements CopyTo(Array, Int32).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Implements GetEnumerator()()().
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sort | Sorts a collection by a given comparer.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Implements Count.
Item | Overloaded.

Events

Name | Description
Changed | Occurs when a collection is changed.

See Also

FieldItemCollection Class
PerpetuumSoft.Olap Namespace


FieldItemCollection Constructor

[image]

.NET ModelKit Suite ClassReference
FieldItemCollection Constructor
FieldItemCollection Class See Also Send Feedback
Initializes a new instance of the FieldItemCollection class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldItemCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FieldItemCollection()

See Also

FieldItemCollection Class
PerpetuumSoft.Olap Namespace


FieldItemCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
FieldItemCollection Methods
FieldItemCollection Class See Also Send Feedback

The FieldItemCollection type exposes the following members.

Methods

Name | Description
Add | Adds FieldItem to the collection.
CopyTo | Implements CopyTo(Array, Int32).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Implements GetEnumerator()()().
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sort | Sorts a collection by a given comparer.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldItemCollection Class
PerpetuumSoft.Olap Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
FieldItemCollection..::.Add Method
FieldItemCollection Class See Also Send Feedback
Adds FieldItem to the collection.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem Add(
    FieldItem value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As FieldItem _
) As FieldItem
Visual C++
public:
FieldItem^ Add(
    FieldItem^ value
)

Parameters

value
Type: PerpetuumSoft.Olap..::.FieldItem

See Also

FieldItemCollection Class
PerpetuumSoft.Olap Namespace


CopyTo Method

[image]

.NET ModelKit Suite ClassReference
FieldItemCollection..::.CopyTo Method
FieldItemCollection Class See Also Send Feedback
Implements CopyTo(Array, Int32).

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed

Parameters

array
Type: System..::.Array
index
Type: System..::.Int32

Implements

ICollection..::.CopyTo(Array, Int32)

See Also

FieldItemCollection Class
PerpetuumSoft.Olap Namespace


GetEnumerator Method

[image]

.NET ModelKit Suite ClassReference
FieldItemCollection..::.GetEnumerator Method
FieldItemCollection Class See Also Send Feedback
Implements GetEnumerator()()().

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Implements

IEnumerable..::.GetEnumerator()()()

See Also

FieldItemCollection Class
PerpetuumSoft.Olap Namespace


Sort Method

[image]

.NET ModelKit Suite ClassReference
FieldItemCollection..::.Sort Method
FieldItemCollection Class See Also Send Feedback
Sorts a collection by a given comparer.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void Sort(
    IComparer comparer
)
Visual Basic (Declaration)
Public Sub Sort ( _
    comparer As IComparer _
)
Visual C++
public:
void Sort(
    IComparer^ comparer
)

Parameters

comparer
Type: System.Collections..::.IComparer

See Also

FieldItemCollection Class
PerpetuumSoft.Olap Namespace


FieldItemCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
FieldItemCollection Properties
FieldItemCollection Class See Also Send Feedback

The FieldItemCollection type exposes the following members.

Properties

Name | Description
Count | Implements Count.
Item | Overloaded.

See Also

FieldItemCollection Class
PerpetuumSoft.Olap Namespace


Count Property

[image]

.NET ModelKit Suite ClassReference
FieldItemCollection..::.Count Property
FieldItemCollection Class See Also Send Feedback
Implements Count.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection..::.Count

See Also

FieldItemCollection Class
PerpetuumSoft.Olap Namespace


Item Property

[image] [image]

.NET ModelKit Suite ClassReference
FieldItemCollection..::.Item Property
FieldItemCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets FieldItem at the specified index.
Item[([(Object])]) | Gets or sets the FieldItem item by the specified value.
Item[([(Int32, Boolean])]) | Gets or sets the FieldItem item by the specified index and method of beat.

See Also

FieldItemCollection Class
FieldItemCollection Members
PerpetuumSoft.Olap Namespace


Item Property (Int32)

[image]

.NET ModelKit Suite ClassReference
FieldItemCollection..::.Item Property (Int32)
FieldItemCollection Class See Also Send Feedback
Gets or sets FieldItem at the specified index.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As FieldItem
Visual C++
public:
property FieldItem^ default[int index] {
    FieldItem^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

FieldItemCollection Class
Item Overload
PerpetuumSoft.Olap Namespace


Item Property (Object)

[image]

.NET ModelKit Suite ClassReference
FieldItemCollection..::.Item Property (Object)
FieldItemCollection Class See Also Send Feedback
Gets or sets the FieldItem item by the specified value.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem this[
    Object value
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    value As Object _
) As FieldItem
Visual C++
public:
property FieldItem^ default[Object^ value] {
    FieldItem^ get (Object^ value);
}

Parameters

value
Type: System..::.Object

See Also

FieldItemCollection Class
Item Overload
PerpetuumSoft.Olap Namespace


Item Property (Int32, Boolean)

[image]

.NET ModelKit Suite ClassReference
FieldItemCollection..::.Item Property (Int32, Boolean)
FieldItemCollection Class See Also Send Feedback
Gets or sets the FieldItem item by the specified index and method of beat.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem this[
    int index,
    bool backOrder
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer, _
    backOrder As Boolean _
) As FieldItem
Visual C++
public:
property FieldItem^ default[int index, bool backOrder] {
    FieldItem^ get (int index, bool backOrder);
}

Parameters

index
Type: System..::.Int32
backOrder
Type: System..::.Boolean

See Also

FieldItemCollection Class
Item Overload
PerpetuumSoft.Olap Namespace


FieldItemCollection Events

[image] [image]

.NET ModelKit Suite ClassReference
FieldItemCollection Events
FieldItemCollection Class See Also Send Feedback

The FieldItemCollection type exposes the following members.

Events

Name | Description
Changed | Occurs when a collection is changed.

See Also

FieldItemCollection Class
PerpetuumSoft.Olap Namespace


Changed Event

[image]

.NET ModelKit Suite ClassReference
FieldItemCollection..::.Changed Event
FieldItemCollection Class See Also Send Feedback
Occurs when a collection is changed.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler Changed
Visual Basic (Declaration)
Public Event Changed As EventHandler
Visual C++
public:
 event EventHandler^ Changed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

FieldItemCollection Class
PerpetuumSoft.Olap Namespace


FieldsCollection Class

[image]

.NET ModelKit Suite ClassReference
FieldsCollection Class
Members See Also Send Feedback
Represents a collection of Field.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class FieldsCollection : CollectionBase
Visual Basic (Declaration)
Public Class FieldsCollection _
    Inherits CollectionBase
Visual C++
public ref class FieldsCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Olap..::.FieldsCollection

See Also

FieldsCollection Members
PerpetuumSoft.Olap Namespace


FieldsCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
FieldsCollection Members
FieldsCollection Class Constructors Methods Properties Events See Also Send Feedback

The FieldsCollection type exposes the following members.

Constructors

Name | Description
FieldsCollection | Initializes a new instance of the FieldsCollection class.

Methods

Name | Description
Add | Adds Field to the collection.
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether Field is in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded. Returns the zero-based index of the first Field occurrence in the collection or in its portion.
Insert | Inserts Field into the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the first Field occurrence from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

Name | Description
CollectionChanged | Occurs after collection change.

See Also

FieldsCollection Class
PerpetuumSoft.Olap Namespace


FieldsCollection Constructor

[image]

.NET ModelKit Suite ClassReference
FieldsCollection Constructor
FieldsCollection Class See Also Send Feedback
Initializes a new instance of the FieldsCollection class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldsCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FieldsCollection()

See Also

FieldsCollection Class
PerpetuumSoft.Olap Namespace


FieldsCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
FieldsCollection Methods
FieldsCollection Class See Also Send Feedback

The FieldsCollection type exposes the following members.

Methods

Name | Description
Add | Adds Field to the collection.
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Determines whether Field is in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded. Returns the zero-based index of the first Field occurrence in the collection or in its portion.
Insert | Inserts Field into the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the first Field occurrence from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldsCollection Class
PerpetuumSoft.Olap Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.Add Method
FieldsCollection Class See Also Send Feedback
Adds Field to the collection.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Field Add(
    Field value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As Field _
) As Field
Visual C++
public:
Field^ Add(
    Field^ value
)

Parameters

value
Type: PerpetuumSoft.Olap..::.Field

See Also

FieldsCollection Class
PerpetuumSoft.Olap Namespace


AddRange Method

[image] [image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.AddRange Method
FieldsCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Field>[]()[]) | Adds the array of Field to the collection.
AddRange(FieldsCollection) | Adds a collection of Field to the collection.

See Also

FieldsCollection Class
FieldsCollection Members
PerpetuumSoft.Olap Namespace


AddRange Method (Field[])

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.AddRange Method (array<Field>[]()[])
FieldsCollection Class See Also Send Feedback
Adds the array of Field to the collection.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    Field[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As Field() _
)
Visual C++
public:
void AddRange(
    array<Field^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Olap..::.Field >[]()[]

See Also

FieldsCollection Class
AddRange Overload
PerpetuumSoft.Olap Namespace


AddRange Method (FieldsCollection)

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.AddRange Method (FieldsCollection)
FieldsCollection Class See Also Send Feedback
Adds a collection of Field to the collection.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    FieldsCollection values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As FieldsCollection _
)
Visual C++
public:
void AddRange(
    FieldsCollection^ values
)

Parameters

values
Type: PerpetuumSoft.Olap..::.FieldsCollection

See Also

FieldsCollection Class
AddRange Overload
PerpetuumSoft.Olap Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.Contains Method
FieldsCollection Class See Also Send Feedback
Determines whether Field is in the collection.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    Field value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As Field _
) As Boolean
Visual C++
public:
bool Contains(
    Field^ value
)

Parameters

value
Type: PerpetuumSoft.Olap..::.Field

See Also

FieldsCollection Class
PerpetuumSoft.Olap Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.IndexOf Method
FieldsCollection Class See Also Send Feedback
Overloaded. Returns the zero-based index of the first Field occurrence in the collection or in its portion.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    Field value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As Field _
) As Integer
Visual C++
public:
int IndexOf(
    Field^ value
)

Parameters

value
Type: PerpetuumSoft.Olap..::.Field

See Also

FieldsCollection Class
PerpetuumSoft.Olap Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.Insert Method
FieldsCollection Class See Also Send Feedback
Inserts Field into the collection at the specified index.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    Field value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As Field _
)
Visual C++
public:
void Insert(
    int index,
    Field^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Olap..::.Field

See Also

FieldsCollection Class
PerpetuumSoft.Olap Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.Remove Method
FieldsCollection Class See Also Send Feedback
Removes the first Field occurrence from the collection.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    Field value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As Field _
)
Visual C++
public:
void Remove(
    Field^ value
)

Parameters

value
Type: PerpetuumSoft.Olap..::.Field

See Also

FieldsCollection Class
PerpetuumSoft.Olap Namespace


FieldsCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
FieldsCollection Properties
FieldsCollection Class See Also Send Feedback

The FieldsCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

FieldsCollection Class
PerpetuumSoft.Olap Namespace


Item Property

[image] [image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.Item Property
FieldsCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets Field at the specified index.
Item[([(String])]) | Gets or sets Field at the specified index.

See Also

FieldsCollection Class
FieldsCollection Members
PerpetuumSoft.Olap Namespace


Item Property (Int32)

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.Item Property (Int32)
FieldsCollection Class See Also Send Feedback
Gets or sets Field at the specified index.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Field this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Field
Visual C++
public:
property Field^ default[int index] {
    Field^ get (int index);
    void set (int index, Field^ value);
}

Parameters

index
Type: System..::.Int32

See Also

FieldsCollection Class
Item Overload
PerpetuumSoft.Olap Namespace


Item Property (String)

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.Item Property (String)
FieldsCollection Class See Also Send Feedback
Gets or sets Field at the specified index.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Field this[
    string caption
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    caption As String _
) As Field
Visual C++
public:
property Field^ default[String^ caption] {
    Field^ get (String^ caption);
}

Parameters

caption
Type: System..::.String

See Also

FieldsCollection Class
Item Overload
PerpetuumSoft.Olap Namespace


FieldsCollection Events

[image] [image]

.NET ModelKit Suite ClassReference
FieldsCollection Events
FieldsCollection Class See Also Send Feedback

The FieldsCollection type exposes the following members.

Events

Name | Description
CollectionChanged | Occurs after collection change.

See Also

FieldsCollection Class
PerpetuumSoft.Olap Namespace


CollectionChanged Event

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.CollectionChanged Event
FieldsCollection Class See Also Send Feedback
Occurs after collection change.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public event FieldsCollection..::.CollectionChangeEventHandler CollectionChanged
Visual Basic (Declaration)
Public Event CollectionChanged As FieldsCollection..::.CollectionChangeEventHandler
Visual C++
public:
 event FieldsCollection..::.CollectionChangeEventHandler^ CollectionChanged {
    void add (FieldsCollection..::.CollectionChangeEventHandler^ value);
    void remove (FieldsCollection..::.CollectionChangeEventHandler^ value);
}

See Also

FieldsCollection Class
PerpetuumSoft.Olap Namespace


FieldsCollection.CollectionChangeEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.CollectionChangeEventHandler Delegate
FieldsCollection Class See Also Send Feedback
Represents method that will handle CollectionChanged.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public delegate void CollectionChangeEventHandler(
    Object sender,
    EventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub CollectionChangeEventHandler ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
public delegate void CollectionChangeEventHandler(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

PerpetuumSoft.Olap Namespace


FieldType Enumeration

[image]

.NET ModelKit Suite ClassReference
FieldType Enumeration
See Also Send Feedback
Enumerates a field type.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public enum FieldType
Visual Basic (Declaration)
Public Enumeration FieldType
Visual C++
public enum class FieldType

Members

Member name | Description
Both | Field is taken to fact and dimension types.
FactOnly | Field is taken to facts type only.
DimensionOnly | Field is taken to dimensions type only.

See Also

PerpetuumSoft.Olap Namespace


FilterByCondition Class

[image]

.NET ModelKit Suite ClassReference
FilterByCondition Class
Members See Also Send Feedback
Represents the filter by the expression assigned condition for field values.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class FilterByCondition : IFilter
Visual Basic (Declaration)
Public Class FilterByCondition _
    Implements IFilter
Visual C++
public ref class FilterByCondition : IFilter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.FilterByCondition

See Also

FilterByCondition Members
PerpetuumSoft.Olap Namespace


FilterByCondition Members

[image] [image]

.NET ModelKit Suite ClassReference
FilterByCondition Members
FilterByCondition Class Constructors Methods Properties See Also Send Feedback

The FilterByCondition type exposes the following members.

Constructors

Name | Description
FilterByCondition | Initializes a new instance of the FilterByCondition class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsFiltered | Implements IsFiltered(Object, IExpressionSite).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Expression | Gets an expression that strikes the filter.
IsActive | Implements IsActive.

See Also

FilterByCondition Class
PerpetuumSoft.Olap Namespace


FilterByCondition Constructor

[image]

.NET ModelKit Suite ClassReference
FilterByCondition Constructor
FilterByCondition Class See Also Send Feedback
Initializes a new instance of the FilterByCondition class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FilterByCondition(
    string expression
)
Visual Basic (Declaration)
Public Sub New ( _
    expression As String _
)
Visual C++
public:
FilterByCondition(
    String^ expression
)

Parameters

expression
Type: System..::.String

See Also

FilterByCondition Class
PerpetuumSoft.Olap Namespace


FilterByCondition Methods

[image] [image]

.NET ModelKit Suite ClassReference
FilterByCondition Methods
FilterByCondition Class See Also Send Feedback

The FilterByCondition type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsFiltered | Implements IsFiltered(Object, IExpressionSite).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterByCondition Class
PerpetuumSoft.Olap Namespace


IsFiltered Method

[image]

.NET ModelKit Suite ClassReference
FilterByCondition..::.IsFiltered Method
FilterByCondition Class See Also Send Feedback
Implements IsFiltered(Object, IExpressionSite).

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool IsFiltered(
    Object value,
    IExpressionSite site
)
Visual Basic (Declaration)
Public Function IsFiltered ( _
    value As Object, _
    site As IExpressionSite _
) As Boolean
Visual C++
public:
virtual bool IsFiltered(
    Object^ value,
    IExpressionSite^ site
) sealed

Parameters

value
Type: System..::.Object
site
Type: IExpressionSite

Implements

IFilter..::.IsFiltered(Object, IExpressionSite)

See Also

FilterByCondition Class
PerpetuumSoft.Olap Namespace


FilterByCondition Properties

[image] [image]

.NET ModelKit Suite ClassReference
FilterByCondition Properties
FilterByCondition Class See Also Send Feedback

The FilterByCondition type exposes the following members.

Properties

Name | Description
Expression | Gets an expression that strikes the filter.
IsActive | Implements IsActive.

See Also

FilterByCondition Class
PerpetuumSoft.Olap Namespace


Expression Property

[image]

.NET ModelKit Suite ClassReference
FilterByCondition..::.Expression Property
FilterByCondition Class See Also Send Feedback
Gets an expression that strikes the filter.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public string Expression { get; }
Visual Basic (Declaration)
Public ReadOnly Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
}

See Also

FilterByCondition Class
PerpetuumSoft.Olap Namespace


IsActive Property

[image]

.NET ModelKit Suite ClassReference
FilterByCondition..::.IsActive Property
FilterByCondition Class See Also Send Feedback
Implements IsActive.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool IsActive { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsActive As Boolean
Visual C++
public:
virtual property bool IsActive {
    bool get () sealed;
}

Implements

IFilter..::.IsActive

See Also

FilterByCondition Class
PerpetuumSoft.Olap Namespace


FilterByValue Class

[image]

.NET ModelKit Suite ClassReference
FilterByValue Class
Members See Also Send Feedback
Represents the filter for field values by one of its values.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class FilterByValue : IFilter
Visual Basic (Declaration)
Public Class FilterByValue _
    Implements IFilter
Visual C++
public ref class FilterByValue : IFilter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.FilterByValue

See Also

FilterByValue Members
PerpetuumSoft.Olap Namespace


FilterByValue Members

[image] [image]

.NET ModelKit Suite ClassReference
FilterByValue Members
FilterByValue Class Constructors Methods Properties See Also Send Feedback

The FilterByValue type exposes the following members.

Constructors

Name | Description
FilterByValue | Initializes a new instance of the FilterByValue class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsFiltered | Implements IsFiltered(Object, IExpressionSite).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExcludedValues | Gets Hashtable containing the filtered value.
IsActive | Implements IsActive.

See Also

FilterByValue Class
PerpetuumSoft.Olap Namespace


FilterByValue Constructor

[image]

.NET ModelKit Suite ClassReference
FilterByValue Constructor
FilterByValue Class See Also Send Feedback
Initializes a new instance of the FilterByValue class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FilterByValue()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterByValue()

See Also

FilterByValue Class
PerpetuumSoft.Olap Namespace


FilterByValue Methods

[image] [image]

.NET ModelKit Suite ClassReference
FilterByValue Methods
FilterByValue Class See Also Send Feedback

The FilterByValue type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsFiltered | Implements IsFiltered(Object, IExpressionSite).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterByValue Class
PerpetuumSoft.Olap Namespace


IsFiltered Method

[image]

.NET ModelKit Suite ClassReference
FilterByValue..::.IsFiltered Method
FilterByValue Class See Also Send Feedback
Implements IsFiltered(Object, IExpressionSite).

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool IsFiltered(
    Object value,
    IExpressionSite site
)
Visual Basic (Declaration)
Public Function IsFiltered ( _
    value As Object, _
    site As IExpressionSite _
) As Boolean
Visual C++
public:
virtual bool IsFiltered(
    Object^ value,
    IExpressionSite^ site
) sealed

Parameters

value
Type: System..::.Object
site
Type: IExpressionSite

Implements

IFilter..::.IsFiltered(Object, IExpressionSite)

See Also

FilterByValue Class
PerpetuumSoft.Olap Namespace


FilterByValue Properties

[image] [image]

.NET ModelKit Suite ClassReference
FilterByValue Properties
FilterByValue Class See Also Send Feedback

The FilterByValue type exposes the following members.

Properties

Name | Description
ExcludedValues | Gets Hashtable containing the filtered value.
IsActive | Implements IsActive.

See Also

FilterByValue Class
PerpetuumSoft.Olap Namespace


ExcludedValues Property

[image]

.NET ModelKit Suite ClassReference
FilterByValue..::.ExcludedValues Property
FilterByValue Class See Also Send Feedback
Gets Hashtable containing the filtered value.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Hashtable ExcludedValues { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExcludedValues As Hashtable
Visual C++
public:
property Hashtable^ ExcludedValues {
    Hashtable^ get ();
}

See Also

FilterByValue Class
PerpetuumSoft.Olap Namespace


IsActive Property

[image]

.NET ModelKit Suite ClassReference
FilterByValue..::.IsActive Property
FilterByValue Class See Also Send Feedback
Implements IsActive.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool IsActive { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsActive As Boolean
Visual C++
public:
virtual property bool IsActive {
    bool get () sealed;
}

Implements

IFilter..::.IsActive

See Also

FilterByValue Class
PerpetuumSoft.Olap Namespace


FilterException Class

[image]

.NET ModelKit Suite ClassReference
FilterException Class
Members See Also Send Feedback
Base class for all exceptions thrown from filters.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
[SerializableAttribute]
public class FilterException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class FilterException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class FilterException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
PerpetuumSoft.Olap..::.FilterException

See Also

FilterException Members
PerpetuumSoft.Olap Namespace


FilterException Members

[image] [image]

.NET ModelKit Suite ClassReference
FilterException Members
FilterException Class Constructors Methods Properties See Also Send Feedback

The FilterException type exposes the following members.

Constructors

Name | Description
FilterException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FilterException Class
PerpetuumSoft.Olap Namespace


FilterException Constructor

[image] [image]

.NET ModelKit Suite ClassReference
FilterException Constructor
FilterException Class See Also Send Feedback

Overload List

Name | Description
FilterException()()() | Initializes a new instance of the FilterException class.
FilterException(String) | Initializes a new instance of the FilterException class with specific parameter. Parameter sets erкor message.
FilterException(String, Exception) | Initializes a new instance of the FilterException class with specific parameters. Parameters set error message and inner exception.

See Also

FilterException Class
FilterException Members
PerpetuumSoft.Olap Namespace


FilterException Constructor

[image]

.NET ModelKit Suite ClassReference
FilterException Constructor
FilterException Class See Also Send Feedback
Initializes a new instance of the FilterException class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FilterException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterException()

See Also

FilterException Class
FilterException Overload
PerpetuumSoft.Olap Namespace


FilterException Constructor (String)

[image]

.NET ModelKit Suite ClassReference
FilterException Constructor (String)
FilterException Class See Also Send Feedback
Initializes a new instance of the FilterException class with specific parameter. Parameter sets erкor message.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FilterException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
FilterException(
    String^ message
)

Parameters

message
Type: System..::.String

See Also

FilterException Class
FilterException Overload
PerpetuumSoft.Olap Namespace


FilterException Constructor (String, Exception)

[image]

.NET ModelKit Suite ClassReference
FilterException Constructor (String, Exception)
FilterException Class See Also Send Feedback
Initializes a new instance of the FilterException class with specific parameters. Parameters set error message and inner exception.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FilterException(
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
FilterException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::.String
innerException
Type: System..::.Exception

See Also

FilterException Class
FilterException Overload
PerpetuumSoft.Olap Namespace


FilterException Methods

[image] [image]

.NET ModelKit Suite ClassReference
FilterException Methods
FilterException Class See Also Send Feedback

The FilterException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FilterException Class
PerpetuumSoft.Olap Namespace


FilterException Properties

[image] [image]

.NET ModelKit Suite ClassReference
FilterException Properties
FilterException Class See Also Send Feedback

The FilterException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FilterException Class
PerpetuumSoft.Olap Namespace


Gradient Enumeration

[image]

.NET ModelKit Suite ClassReference
Gradient Enumeration
See Also Send Feedback
Enumerates the gradinet fill types.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public enum Gradient
Visual Basic (Declaration)
Public Enumeration Gradient
Visual C++
public enum class Gradient

Members

Member name | Description
None | Gradient fill is not used.
Vertical | Vertical gradient fill.
Horizontal | Horisontal gradient fill.

See Also

PerpetuumSoft.Olap Namespace


IAggregateFunction Interface

[image]

.NET ModelKit Suite ClassReference
IAggregateFunction Interface
Members See Also Send Feedback
Represents an aggregate function.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public interface IAggregateFunction
Visual Basic (Declaration)
Public Interface IAggregateFunction
Visual C++
public interface class IAggregateFunction

See Also

IAggregateFunction Members
PerpetuumSoft.Olap Namespace


IAggregateFunction Members

[image] [image]

.NET ModelKit Suite ClassReference
IAggregateFunction Members
IAggregateFunction Interface Methods Properties See Also Send Feedback

The IAggregateFunction type exposes the following members.

Methods

Name | Description
AddValue | Adds a value to aggregation result.
GetResult | Returns aggregation result.

Properties

Name | Description
ValidResult | Gets value indicating whether the GetResult function result is valid.

See Also

IAggregateFunction Interface
PerpetuumSoft.Olap Namespace


IAggregateFunction Methods

[image] [image]

.NET ModelKit Suite ClassReference
IAggregateFunction Methods
IAggregateFunction Interface See Also Send Feedback

The IAggregateFunction type exposes the following members.

Methods

Name | Description
AddValue | Adds a value to aggregation result.
GetResult | Returns aggregation result.

See Also

IAggregateFunction Interface
PerpetuumSoft.Olap Namespace


AddValue Method

[image]

.NET ModelKit Suite ClassReference
IAggregateFunction..::.AddValue Method
IAggregateFunction Interface See Also Send Feedback
Adds a value to aggregation result.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
void AddValue(
    double value
)
Visual Basic (Declaration)
Sub AddValue ( _
    value As Double _
)
Visual C++
void AddValue(
    double value
)

Parameters

value
Type: System..::.Double

See Also

IAggregateFunction Interface
PerpetuumSoft.Olap Namespace


GetResult Method

[image]

.NET ModelKit Suite ClassReference
IAggregateFunction..::.GetResult Method
IAggregateFunction Interface See Also Send Feedback
Returns aggregation result.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
double GetResult()
Visual Basic (Declaration)
Function GetResult As Double
Visual C++
double GetResult()

See Also

IAggregateFunction Interface
PerpetuumSoft.Olap Namespace


IAggregateFunction Properties

[image] [image]

.NET ModelKit Suite ClassReference
IAggregateFunction Properties
IAggregateFunction Interface See Also Send Feedback

The IAggregateFunction type exposes the following members.

Properties

Name | Description
ValidResult | Gets value indicating whether the GetResult function result is valid.

See Also

IAggregateFunction Interface
PerpetuumSoft.Olap Namespace


ValidResult Property

[image]

.NET ModelKit Suite ClassReference
IAggregateFunction..::.ValidResult Property
IAggregateFunction Interface See Also Send Feedback
Gets value indicating whether the GetResult function result is valid.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
bool ValidResult { get; }
Visual Basic (Declaration)
ReadOnly Property ValidResult As Boolean
Visual C++
property bool ValidResult {
    bool get ();
}

See Also

IAggregateFunction Interface
PerpetuumSoft.Olap Namespace


IFilter Interface

[image]

.NET ModelKit Suite ClassReference
IFilter Interface
Members See Also Send Feedback
Represents a data filter.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public interface IFilter
Visual Basic (Declaration)
Public Interface IFilter
Visual C++
public interface class IFilter

See Also

IFilter Members
PerpetuumSoft.Olap Namespace


IFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
IFilter Members
IFilter Interface Methods Properties See Also Send Feedback

The IFilter type exposes the following members.

Methods

Name | Description
IsFiltered | Returns a value indicated whether the source record was filtered.

Properties

Name | Description
IsActive | Returns the value indicating whether the filter is active.

See Also

IFilter Interface
PerpetuumSoft.Olap Namespace


IFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
IFilter Methods
IFilter Interface See Also Send Feedback

The IFilter type exposes the following members.

Methods

Name | Description
IsFiltered | Returns a value indicated whether the source record was filtered.

See Also

IFilter Interface
PerpetuumSoft.Olap Namespace


IsFiltered Method

[image]

.NET ModelKit Suite ClassReference
IFilter..::.IsFiltered Method
IFilter Interface See Also Send Feedback
Returns a value indicated whether the source record was filtered.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
bool IsFiltered(
    Object value,
    IExpressionSite site
)
Visual Basic (Declaration)
Function IsFiltered ( _
    value As Object, _
    site As IExpressionSite _
) As Boolean
Visual C++
bool IsFiltered(
    Object^ value,
    IExpressionSite^ site
)

Parameters

value
Type: System..::.Object
site
Type: IExpressionSite

See Also

IFilter Interface
PerpetuumSoft.Olap Namespace


IFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
IFilter Properties
IFilter Interface See Also Send Feedback

The IFilter type exposes the following members.

Properties

Name | Description
IsActive | Returns the value indicating whether the filter is active.

See Also

IFilter Interface
PerpetuumSoft.Olap Namespace


IsActive Property

[image]

.NET ModelKit Suite ClassReference
IFilter..::.IsActive Property
IFilter Interface See Also Send Feedback
Returns the value indicating whether the filter is active.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
bool IsActive { get; }
Visual Basic (Declaration)
ReadOnly Property IsActive As Boolean
Visual C++
property bool IsActive {
    bool get ();
}

See Also

IFilter Interface
PerpetuumSoft.Olap Namespace


Painter Class

[image]

.NET ModelKit Suite ClassReference
Painter Class
Members See Also Send Feedback
Represents the object for drawing a pivot table in graphics.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public abstract class Painter
Visual Basic (Declaration)
Public MustInherit Class Painter
Visual C++
public ref class Painter abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.Painter
PerpetuumSoft.Olap.Windows.Forms..::.OfficePainter
PerpetuumSoft.Olap.Windows.Forms..::.ProfessionalPainter
PerpetuumSoft.Olap.Windows.Forms..::.SmoothPainter
PerpetuumSoft.Olap.Windows.Forms..::.XPPainter

See Also

Painter Members
PerpetuumSoft.Olap Namespace


Painter Members

[image] [image]

.NET ModelKit Suite ClassReference
Painter Members
Painter Class Constructors Methods See Also Send Feedback

The Painter type exposes the following members.

Constructors

Name | Description
Painter | Initializes a new instance of the Painter class

Methods

Name | Description
DrawCollapseButton | Draws the icon for the Collapse button.
DrawDimensionCell | Draws a dimension cell.
DrawDropButton | Draws the icon for the Group down button.
DrawFieldCaption | Draws a field caption.
DrawProgressCell | Draws a progress bar cell.
DrawShiftButton | Draws the icon for the Shift button.
DrawSplitterLine | Draws a splitter line.
DrawTitle | Draws a title.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCaptionStringWidth | Returns the string width in pixels.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Painter Class
PerpetuumSoft.Olap Namespace


Painter Constructor

[image]

.NET ModelKit Suite ClassReference
Painter Constructor
Painter Class See Also Send Feedback
Initializes a new instance of the Painter class

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
protected Painter()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
Painter()

See Also

Painter Class
PerpetuumSoft.Olap Namespace


Painter Methods

[image] [image]

.NET ModelKit Suite ClassReference
Painter Methods
Painter Class See Also Send Feedback

The Painter type exposes the following members.

Methods

Name | Description
DrawCollapseButton | Draws the icon for the Collapse button.
DrawDimensionCell | Draws a dimension cell.
DrawDropButton | Draws the icon for the Group down button.
DrawFieldCaption | Draws a field caption.
DrawProgressCell | Draws a progress bar cell.
DrawShiftButton | Draws the icon for the Shift button.
DrawSplitterLine | Draws a splitter line.
DrawTitle | Draws a title.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCaptionStringWidth | Returns the string width in pixels.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Painter Class
PerpetuumSoft.Olap Namespace


DrawCollapseButton Method

[image]

.NET ModelKit Suite ClassReference
Painter..::.DrawCollapseButton Method
Painter Class See Also Send Feedback
Draws the icon for the Collapse button.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawCollapseButton(
    Graphics graphics,
    Rectangle bounds,
    bool isCollapse
)
Visual Basic (Declaration)
Public MustOverride Sub DrawCollapseButton ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    isCollapse As Boolean _
)
Visual C++
public:
virtual void DrawCollapseButton(
    Graphics^ graphics,
    Rectangle bounds,
    bool isCollapse
) abstract

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
isCollapse
Type: System..::.Boolean

See Also

Painter Class
PerpetuumSoft.Olap Namespace


DrawDimensionCell Method

[image]

.NET ModelKit Suite ClassReference
Painter..::.DrawDimensionCell Method
Painter Class See Also Send Feedback
Draws a dimension cell.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawDimensionCell(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    CellBorder border,
    string text,
    Point startTextPosition
)
Visual Basic (Declaration)
Public MustOverride Sub DrawDimensionCell ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    border As CellBorder, _
    text As String, _
    startTextPosition As Point _
)
Visual C++
public:
virtual void DrawDimensionCell(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    CellBorder^ border,
    String^ text,
    Point startTextPosition
) abstract

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
border
Type: PerpetuumSoft.Olap..::.CellBorder
text
Type: System..::.String
startTextPosition
Type: System.Drawing..::.Point

See Also

Painter Class
PerpetuumSoft.Olap Namespace


DrawDropButton Method

[image]

.NET ModelKit Suite ClassReference
Painter..::.DrawDropButton Method
Painter Class See Also Send Feedback
Draws the icon for the Group down button.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawDropButton(
    Graphics graphics,
    Rectangle bounds,
    ControlState state,
    bool select
)
Visual Basic (Declaration)
Public MustOverride Sub DrawDropButton ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    state As ControlState, _
    select As Boolean _
)
Visual C++
public:
virtual void DrawDropButton(
    Graphics^ graphics,
    Rectangle bounds,
    ControlState state,
    bool select
) abstract

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
state
Type: PerpetuumSoft.Olap..::.ControlState
select
Type: System..::.Boolean

See Also

Painter Class
PerpetuumSoft.Olap Namespace


DrawFieldCaption Method

[image]

.NET ModelKit Suite ClassReference
Painter..::.DrawFieldCaption Method
Painter Class See Also Send Feedback
Draws a field caption.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawFieldCaption(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    CellBorder border,
    ControlState state,
    SortOrder sortOrder,
    bool enabledSort,
    string text,
    Size clientSize
)
Visual Basic (Declaration)
Public MustOverride Sub DrawFieldCaption ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    border As CellBorder, _
    state As ControlState, _
    sortOrder As SortOrder, _
    enabledSort As Boolean, _
    text As String, _
    clientSize As Size _
)
Visual C++
public:
virtual void DrawFieldCaption(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    CellBorder^ border,
    ControlState state,
    SortOrder sortOrder,
    bool enabledSort,
    String^ text,
    Size clientSize
) abstract

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
border
Type: PerpetuumSoft.Olap..::.CellBorder
state
Type: PerpetuumSoft.Olap..::.ControlState
sortOrder
Type: PerpetuumSoft.Olap..::.SortOrder
enabledSort
Type: System..::.Boolean
text
Type: System..::.String
clientSize
Type: System.Drawing..::.Size

See Also

Painter Class
PerpetuumSoft.Olap Namespace


DrawProgressCell Method

[image]

.NET ModelKit Suite ClassReference
Painter..::.DrawProgressCell Method
Painter Class See Also Send Feedback
Draws a progress bar cell.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawProgressCell(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    CellBorder border,
    string text,
    double value
)
Visual Basic (Declaration)
Public MustOverride Sub DrawProgressCell ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    border As CellBorder, _
    text As String, _
    value As Double _
)
Visual C++
public:
virtual void DrawProgressCell(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    CellBorder^ border,
    String^ text,
    double value
) abstract

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
border
Type: PerpetuumSoft.Olap..::.CellBorder
text
Type: System..::.String
value
Type: System..::.Double

See Also

Painter Class
PerpetuumSoft.Olap Namespace


DrawShiftButton Method

[image]

.NET ModelKit Suite ClassReference
Painter..::.DrawShiftButton Method
Painter Class See Also Send Feedback
Draws the icon for the Shift button.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawShiftButton(
    Graphics graphics,
    Rectangle bounds,
    Direction direct
)
Visual Basic (Declaration)
Public MustOverride Sub DrawShiftButton ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    direct As Direction _
)
Visual C++
public:
virtual void DrawShiftButton(
    Graphics^ graphics,
    Rectangle bounds,
    Direction direct
) abstract

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
direct
Type: PerpetuumSoft.Olap..::.Direction

See Also

Painter Class
PerpetuumSoft.Olap Namespace


DrawSplitterLine Method

[image]

.NET ModelKit Suite ClassReference
Painter..::.DrawSplitterLine Method
Painter Class See Also Send Feedback
Draws a splitter line.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawSplitterLine(
    Graphics graphics,
    Rectangle bounds
)
Visual Basic (Declaration)
Public MustOverride Sub DrawSplitterLine ( _
    graphics As Graphics, _
    bounds As Rectangle _
)
Visual C++
public:
virtual void DrawSplitterLine(
    Graphics^ graphics,
    Rectangle bounds
) abstract

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle

See Also

Painter Class
PerpetuumSoft.Olap Namespace


DrawTitle Method

[image]

.NET ModelKit Suite ClassReference
Painter..::.DrawTitle Method
Painter Class See Also Send Feedback
Draws a title.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawTitle(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    string text
)
Visual Basic (Declaration)
Public MustOverride Sub DrawTitle ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    text As String _
)
Visual C++
public:
virtual void DrawTitle(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    String^ text
) abstract

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
text
Type: System..::.String

See Also

Painter Class
PerpetuumSoft.Olap Namespace


GetCaptionStringWidth Method

[image]

.NET ModelKit Suite ClassReference
Painter..::.GetCaptionStringWidth Method
Painter Class See Also Send Feedback
Returns the string width in pixels.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public virtual float GetCaptionStringWidth(
    Graphics graphics,
    string text
)
Visual Basic (Declaration)
Public Overridable Function GetCaptionStringWidth ( _
    graphics As Graphics, _
    text As String _
) As Single
Visual C++
public:
virtual float GetCaptionStringWidth(
    Graphics^ graphics,
    String^ text
)

Parameters

graphics
Type: System.Drawing..::.Graphics
text
Type: System..::.String

See Also

Painter Class
PerpetuumSoft.Olap Namespace


PivotTable Class

[image]

.NET ModelKit Suite ClassReference
PivotTable Class
Members See Also Send Feedback
Represents a pivot table.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class PivotTable
Visual Basic (Declaration)
Public Class PivotTable
Visual C++
public ref class PivotTable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.PivotTable

See Also

PivotTable Members
PerpetuumSoft.Olap Namespace


PivotTable Members

[image] [image]

.NET ModelKit Suite ClassReference
PivotTable Members
PivotTable Class Constructors Methods Properties See Also Send Feedback

The PivotTable type exposes the following members.

Constructors

Name | Description
PivotTable | Initializes a new instance of the PivotTable class.

Methods

Name | Description
AddTable | Adds facts table.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFactPercent | Returns the value from the facts table in percentage terms.
GetFactValue | Returns the value from the facts table.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTable | Returns the facts table by the given parameter.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValidFact | Gets value indicating whether the fact defined by the given parameters has valid result.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sort | Sorts pivot table by a given fact and a column number.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Error | Gets or sets an object representing error. If a pivot table has been built correctly this property should be NULL.
SortedColumn | Gets a pivot table column number by which a pivot table was sorted.
SortedFact | Gets a fact by which a pivot table was sorted.
XRoot | Gets FieldItem which is the root of X dimension.
YRoot | Gets FieldItem which is the root of Y dimension.

See Also

PivotTable Class
PerpetuumSoft.Olap Namespace


PivotTable Constructor

[image]

.NET ModelKit Suite ClassReference
PivotTable Constructor
PivotTable Class See Also Send Feedback
Initializes a new instance of the PivotTable class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public PivotTable()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PivotTable()

See Also

PivotTable Class
PerpetuumSoft.Olap Namespace


PivotTable Methods

[image] [image]

.NET ModelKit Suite ClassReference
PivotTable Methods
PivotTable Class See Also Send Feedback

The PivotTable type exposes the following members.

Methods

Name | Description
AddTable | Adds facts table.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFactPercent | Returns the value from the facts table in percentage terms.
GetFactValue | Returns the value from the facts table.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTable | Returns the facts table by the given parameter.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValidFact | Gets value indicating whether the fact defined by the given parameters has valid result.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sort | Sorts pivot table by a given fact and a column number.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PivotTable Class
PerpetuumSoft.Olap Namespace


AddTable Method

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.AddTable Method
PivotTable Class See Also Send Feedback
Adds facts table.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void AddTable(
    Field field,
    FactTable table
)
Visual Basic (Declaration)
Public Sub AddTable ( _
    field As Field, _
    table As FactTable _
)
Visual C++
public:
void AddTable(
    Field^ field,
    FactTable^ table
)

Parameters

field
Type: PerpetuumSoft.Olap..::.Field
table
Type: FactTable

See Also

PivotTable Class
PerpetuumSoft.Olap Namespace


GetFactPercent Method

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.GetFactPercent Method
PivotTable Class See Also Send Feedback
Returns the value from the facts table in percentage terms.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public double GetFactPercent(
    FieldItem yItem,
    FieldItem xItem,
    Field fact
)
Visual Basic (Declaration)
Public Function GetFactPercent ( _
    yItem As FieldItem, _
    xItem As FieldItem, _
    fact As Field _
) As Double
Visual C++
public:
double GetFactPercent(
    FieldItem^ yItem,
    FieldItem^ xItem,
    Field^ fact
)

Parameters

yItem
Type: PerpetuumSoft.Olap..::.FieldItem
xItem
Type: PerpetuumSoft.Olap..::.FieldItem
fact
Type: PerpetuumSoft.Olap..::.Field

See Also

PivotTable Class
PerpetuumSoft.Olap Namespace


GetFactValue Method

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.GetFactValue Method
PivotTable Class See Also Send Feedback
Returns the value from the facts table.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public double GetFactValue(
    FieldItem yItem,
    FieldItem xItem,
    Field fact
)
Visual Basic (Declaration)
Public Function GetFactValue ( _
    yItem As FieldItem, _
    xItem As FieldItem, _
    fact As Field _
) As Double
Visual C++
public:
double GetFactValue(
    FieldItem^ yItem,
    FieldItem^ xItem,
    Field^ fact
)

Parameters

yItem
Type: PerpetuumSoft.Olap..::.FieldItem
xItem
Type: PerpetuumSoft.Olap..::.FieldItem
fact
Type: PerpetuumSoft.Olap..::.Field

See Also

PivotTable Class
PerpetuumSoft.Olap Namespace


GetTable Method

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.GetTable Method
PivotTable Class See Also Send Feedback
Returns the facts table by the given parameter.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FactTable GetTable(
    Field field
)
Visual Basic (Declaration)
Public Function GetTable ( _
    field As Field _
) As FactTable
Visual C++
public:
FactTable^ GetTable(
    Field^ field
)

Parameters

field
Type: PerpetuumSoft.Olap..::.Field

See Also

PivotTable Class
PerpetuumSoft.Olap Namespace


IsValidFact Method

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.IsValidFact Method
PivotTable Class See Also Send Feedback
Gets value indicating whether the fact defined by the given parameters has valid result.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool IsValidFact(
    FieldItem yItem,
    FieldItem xItem,
    Field fact
)
Visual Basic (Declaration)
Public Function IsValidFact ( _
    yItem As FieldItem, _
    xItem As FieldItem, _
    fact As Field _
) As Boolean
Visual C++
public:
bool IsValidFact(
    FieldItem^ yItem,
    FieldItem^ xItem,
    Field^ fact
)

Parameters

yItem
Type: PerpetuumSoft.Olap..::.FieldItem
xItem
Type: PerpetuumSoft.Olap..::.FieldItem
fact
Type: PerpetuumSoft.Olap..::.Field

See Also

PivotTable Class
PerpetuumSoft.Olap Namespace


Sort Method

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.Sort Method
PivotTable Class See Also Send Feedback
Sorts pivot table by a given fact and a column number.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void Sort(
    Field fact,
    int column
)
Visual Basic (Declaration)
Public Sub Sort ( _
    fact As Field, _
    column As Integer _
)
Visual C++
public:
void Sort(
    Field^ fact,
    int column
)

Parameters

fact
Type: PerpetuumSoft.Olap..::.Field
column
Type: System..::.Int32

See Also

PivotTable Class
PerpetuumSoft.Olap Namespace


PivotTable Properties

[image] [image]

.NET ModelKit Suite ClassReference
PivotTable Properties
PivotTable Class See Also Send Feedback

The PivotTable type exposes the following members.

Properties

Name | Description
Error | Gets or sets an object representing error. If a pivot table has been built correctly this property should be NULL.
SortedColumn | Gets a pivot table column number by which a pivot table was sorted.
SortedFact | Gets a fact by which a pivot table was sorted.
XRoot | Gets FieldItem which is the root of X dimension.
YRoot | Gets FieldItem which is the root of Y dimension.

See Also

PivotTable Class
PerpetuumSoft.Olap Namespace


Error Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.Error Property
PivotTable Class See Also Send Feedback
Gets or sets an object representing error. If a pivot table has been built correctly this property should be NULL.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Object Error { get; set; }
Visual Basic (Declaration)
Public Property Error As Object
Visual C++
public:
property Object^ Error {
    Object^ get ();
    void set (Object^ value);
}

See Also

PivotTable Class
PerpetuumSoft.Olap Namespace


SortedColumn Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.SortedColumn Property
PivotTable Class See Also Send Feedback
Gets a pivot table column number by which a pivot table was sorted.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public int SortedColumn { get; }
Visual Basic (Declaration)
Public ReadOnly Property SortedColumn As Integer
Visual C++
public:
property int SortedColumn {
    int get ();
}

See Also

PivotTable Class
PerpetuumSoft.Olap Namespace


SortedFact Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.SortedFact Property
PivotTable Class See Also Send Feedback
Gets a fact by which a pivot table was sorted.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Field SortedFact { get; }
Visual Basic (Declaration)
Public ReadOnly Property SortedFact As Field
Visual C++
public:
property Field^ SortedFact {
    Field^ get ();
}

See Also

PivotTable Class
PerpetuumSoft.Olap Namespace


XRoot Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.XRoot Property
PivotTable Class See Also Send Feedback
Gets FieldItem which is the root of X dimension.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem XRoot { get; }
Visual Basic (Declaration)
Public ReadOnly Property XRoot As FieldItem
Visual C++
public:
property FieldItem^ XRoot {
    FieldItem^ get ();
}

See Also

PivotTable Class
PerpetuumSoft.Olap Namespace


YRoot Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.YRoot Property
PivotTable Class See Also Send Feedback
Gets FieldItem which is the root of Y dimension.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem YRoot { get; }
Visual Basic (Declaration)
Public ReadOnly Property YRoot As FieldItem
Visual C++
public:
property FieldItem^ YRoot {
    FieldItem^ get ();
}

See Also

PivotTable Class
PerpetuumSoft.Olap Namespace


SortOrder Enumeration

[image]

.NET ModelKit Suite ClassReference
SortOrder Enumeration
See Also Send Feedback
Enumerates the sort order.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public enum SortOrder
Visual Basic (Declaration)
Public Enumeration SortOrder
Visual C++
public enum class SortOrder

Members

Member name | Description
Ascending | Ascending sotring.
Descending | Descending sorting.

See Also

PerpetuumSoft.Olap Namespace


StyleSheet Class

[image]

.NET ModelKit Suite ClassReference
StyleSheet Class
Members See Also Send Feedback
Represents a pivot table style sheet.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class StyleSheet
Visual Basic (Declaration)
Public Class StyleSheet
Visual C++
public ref class StyleSheet

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.StyleSheet

See Also

StyleSheet Members
PerpetuumSoft.Olap Namespace


StyleSheet Members

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheet Members
StyleSheet Class Constructors Methods Properties See Also Send Feedback

The StyleSheet type exposes the following members.

Constructors

Name | Description
StyleSheet | Initializes a new instance of the StyleSheet class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStyles | Returns the predefined style sheets.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActiveCellStyle | Gets or sets CellStyle for active cells.
DimensionBorder | Gets or sets CellBorder for cells of both dimensions.
EvenRowFactStyle | Gets or sets CellStyle for fact cells included in even row.
FactBorder | Gets or sets CellBorder for fact cells.
FieldCaptionStyle | Gets or sets CellStyle for cells representing field caption.
GroupTotalStyle | Gets or sets CellStyle for fact cells containing group total.
MainTotalStyle | Gets or sets CellStyle for fact cells containing the pivot table total.
Name | Gets or sets a style sheet name.
OddRowFactStyle | Gets or sets CellStyle for fact cells included in odd row.
TableCaptionStyle | Gets or sets CellStyle for cells representing table caption.
TotalStyle | Gets or sets CellStyle for fact cells containing total by row or column.
XDimensionStyle | Gets or sets CellStyle for X dimension cells.
YDimensionStyle | Gets or sets CellStyle for Y dimension cells.

See Also

StyleSheet Class
PerpetuumSoft.Olap Namespace


StyleSheet Constructor

[image]

.NET ModelKit Suite ClassReference
StyleSheet Constructor
StyleSheet Class See Also Send Feedback
Initializes a new instance of the StyleSheet class.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public StyleSheet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StyleSheet()

See Also

StyleSheet Class
PerpetuumSoft.Olap Namespace


StyleSheet Methods

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheet Methods
StyleSheet Class See Also Send Feedback

The StyleSheet type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStyles | Returns the predefined style sheets.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StyleSheet Class
PerpetuumSoft.Olap Namespace


GetStyles Method

[image]

.NET ModelKit Suite ClassReference
StyleSheet..::.GetStyles Method
StyleSheet Class See Also Send Feedback
Returns the predefined style sheets.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public static StyleSheet[] GetStyles()
Visual Basic (Declaration)
Public Shared Function GetStyles As StyleSheet()
Visual C++
public:
static array<StyleSheet^>^ GetStyles()

See Also

StyleSheet Class
PerpetuumSoft.Olap Namespace


StyleSheet Properties

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheet Properties
StyleSheet Class See Also Send Feedback

The StyleSheet type exposes the following members.

Properties

Name | Description
ActiveCellStyle | Gets or sets CellStyle for active cells.
DimensionBorder | Gets or sets CellBorder for cells of both dimensions.
EvenRowFactStyle | Gets or sets CellStyle for fact cells included in even row.
FactBorder | Gets or sets CellBorder for fact cells.
FieldCaptionStyle | Gets or sets CellStyle for cells representing field caption.
GroupTotalStyle | Gets or sets CellStyle for fact cells containing group total.
MainTotalStyle | Gets or sets CellStyle for fact cells containing the pivot table total.
Name | Gets or sets a style sheet name.
OddRowFactStyle | Gets or sets CellStyle for fact cells included in odd row.
TableCaptionStyle | Gets or sets CellStyle for cells representing table caption.
TotalStyle | Gets or sets CellStyle for fact cells containing total by row or column.
XDimensionStyle | Gets or sets CellStyle for X dimension cells.
YDimensionStyle | Gets or sets CellStyle for Y dimension cells.

See Also

StyleSheet Class
PerpetuumSoft.Olap Namespace


ActiveCellStyle Property

[image]

.NET ModelKit Suite ClassReference
StyleSheet..::.ActiveCellStyle Property
StyleSheet Class See Also Send Feedback
Gets or sets CellStyle for active cells.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellStyle ActiveCellStyle { get; set; }
Visual Basic (Declaration)
Public Property ActiveCellStyle As CellStyle
Visual C++
public:
property CellStyle^ ActiveCellStyle {
    CellStyle^ get ();
    void set (CellStyle^ value);
}

See Also

StyleSheet Class
PerpetuumSoft.Olap Namespace


DimensionBorder Property

[image]

.NET ModelKit Suite ClassReference
StyleSheet..::.DimensionBorder Property
StyleSheet Class See Also Send Feedback
Gets or sets CellBorder for cells of both dimensions.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellBorder DimensionBorder { get; set; }
Visual Basic (Declaration)
Public Property DimensionBorder As CellBorder
Visual C++
public:
property CellBorder^ DimensionBorder {
    CellBorder^ get ();
    void set (CellBorder^ value);
}

See Also

StyleSheet Class
PerpetuumSoft.Olap Namespace


EvenRowFactStyle Property

[image]

.NET ModelKit Suite ClassReference
StyleSheet..::.EvenRowFactStyle Property
StyleSheet Class See Also Send Feedback
Gets or sets CellStyle for fact cells included in even row.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellStyle EvenRowFactStyle { get; set; }
Visual Basic (Declaration)
Public Property EvenRowFactStyle As CellStyle
Visual C++
public:
property CellStyle^ EvenRowFactStyle {
    CellStyle^ get ();
    void set (CellStyle^ value);
}

See Also

StyleSheet Class
PerpetuumSoft.Olap Namespace


FactBorder Property

[image]

.NET ModelKit Suite ClassReference
StyleSheet..::.FactBorder Property
StyleSheet Class See Also Send Feedback
Gets or sets CellBorder for fact cells.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellBorder FactBorder { get; set; }
Visual Basic (Declaration)
Public Property FactBorder As CellBorder
Visual C++
public:
property CellBorder^ FactBorder {
    CellBorder^ get ();
    void set (CellBorder^ value);
}

See Also

StyleSheet Class
PerpetuumSoft.Olap Namespace


FieldCaptionStyle Property

[image]

.NET ModelKit Suite ClassReference
StyleSheet..::.FieldCaptionStyle Property
StyleSheet Class See Also Send Feedback
Gets or sets CellStyle for cells representing field caption.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellStyle FieldCaptionStyle { get; set; }
Visual Basic (Declaration)
Public Property FieldCaptionStyle As CellStyle
Visual C++
public:
property CellStyle^ FieldCaptionStyle {
    CellStyle^ get ();
    void set (CellStyle^ value);
}

See Also

StyleSheet Class
PerpetuumSoft.Olap Namespace


GroupTotalStyle Property

[image]

.NET ModelKit Suite ClassReference
StyleSheet..::.GroupTotalStyle Property
StyleSheet Class See Also Send Feedback
Gets or sets CellStyle for fact cells containing group total.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellStyle GroupTotalStyle { get; set; }
Visual Basic (Declaration)
Public Property GroupTotalStyle As CellStyle
Visual C++
public:
property CellStyle^ GroupTotalStyle {
    CellStyle^ get ();
    void set (CellStyle^ value);
}

See Also

StyleSheet Class
PerpetuumSoft.Olap Namespace


MainTotalStyle Property

[image]

.NET ModelKit Suite ClassReference
StyleSheet..::.MainTotalStyle Property
StyleSheet Class See Also Send Feedback
Gets or sets CellStyle for fact cells containing the pivot table total.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellStyle MainTotalStyle { get; set; }
Visual Basic (Declaration)
Public Property MainTotalStyle As CellStyle
Visual C++
public:
property CellStyle^ MainTotalStyle {
    CellStyle^ get ();
    void set (CellStyle^ value);
}

See Also

StyleSheet Class
PerpetuumSoft.Olap Namespace


Name Property

[image]

.NET ModelKit Suite ClassReference
StyleSheet..::.Name Property
StyleSheet Class See Also Send Feedback
Gets or sets a style sheet name.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

StyleSheet Class
PerpetuumSoft.Olap Namespace


OddRowFactStyle Property

[image]

.NET ModelKit Suite ClassReference
StyleSheet..::.OddRowFactStyle Property
StyleSheet Class See Also Send Feedback
Gets or sets CellStyle for fact cells included in odd row.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellStyle OddRowFactStyle { get; set; }
Visual Basic (Declaration)
Public Property OddRowFactStyle As CellStyle
Visual C++
public:
property CellStyle^ OddRowFactStyle {
    CellStyle^ get ();
    void set (CellStyle^ value);
}

See Also

StyleSheet Class
PerpetuumSoft.Olap Namespace


TableCaptionStyle Property

[image]

.NET ModelKit Suite ClassReference
StyleSheet..::.TableCaptionStyle Property
StyleSheet Class See Also Send Feedback
Gets or sets CellStyle for cells representing table caption.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellStyle TableCaptionStyle { get; set; }
Visual Basic (Declaration)
Public Property TableCaptionStyle As CellStyle
Visual C++
public:
property CellStyle^ TableCaptionStyle {
    CellStyle^ get ();
    void set (CellStyle^ value);
}

See Also

StyleSheet Class
PerpetuumSoft.Olap Namespace


TotalStyle Property

[image]

.NET ModelKit Suite ClassReference
StyleSheet..::.TotalStyle Property
StyleSheet Class See Also Send Feedback
Gets or sets CellStyle for fact cells containing total by row or column.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellStyle TotalStyle { get; set; }
Visual Basic (Declaration)
Public Property TotalStyle As CellStyle
Visual C++
public:
property CellStyle^ TotalStyle {
    CellStyle^ get ();
    void set (CellStyle^ value);
}

See Also

StyleSheet Class
PerpetuumSoft.Olap Namespace


XDimensionStyle Property

[image]

.NET ModelKit Suite ClassReference
StyleSheet..::.XDimensionStyle Property
StyleSheet Class See Also Send Feedback
Gets or sets CellStyle for X dimension cells.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellStyle XDimensionStyle { get; set; }
Visual Basic (Declaration)
Public Property XDimensionStyle As CellStyle
Visual C++
public:
property CellStyle^ XDimensionStyle {
    CellStyle^ get ();
    void set (CellStyle^ value);
}

See Also

StyleSheet Class
PerpetuumSoft.Olap Namespace


YDimensionStyle Property

[image]

.NET ModelKit Suite ClassReference
StyleSheet..::.YDimensionStyle Property
StyleSheet Class See Also Send Feedback
Gets or sets CellStyle for Y dimension cells.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellStyle YDimensionStyle { get; set; }
Visual Basic (Declaration)
Public Property YDimensionStyle As CellStyle
Visual C++
public:
property CellStyle^ YDimensionStyle {
    CellStyle^ get ();
    void set (CellStyle^ value);
}

See Also

StyleSheet Class
PerpetuumSoft.Olap Namespace


ViewDimension Enumeration

[image]

.NET ModelKit Suite ClassReference
ViewDimension Enumeration
See Also Send Feedback
Enumerates a dimension type.

Namespace: PerpetuumSoft.Olap
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public enum ViewDimension
Visual Basic (Declaration)
Public Enumeration ViewDimension
Visual C++
public enum class ViewDimension

Members

Member name | Description
X | Specifies an X dimension.
Y | Specifies a Y dimension.

See Also

PerpetuumSoft.Olap Namespace


PerpetuumSoft.Olap.Data Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Olap.Data Namespace
Send Feedback
The PerpetuumSoft.Olap.Data namespace contains classes which are used while processing of the cube data.

Interfaces

Interface | Description
IEngineSite | Provides common interface for pivot table calculation clients.


IEngineSite Interface

[image]

.NET ModelKit Suite ClassReference
IEngineSite Interface
Members See Also Send Feedback
Provides common interface for pivot table calculation clients.

Namespace: PerpetuumSoft.Olap.Data
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public interface IEngineSite
Visual Basic (Declaration)
Public Interface IEngineSite
Visual C++
public interface class IEngineSite

See Also

IEngineSite Members
PerpetuumSoft.Olap.Data Namespace


IEngineSite Members

[image] [image]

.NET ModelKit Suite ClassReference
IEngineSite Members
IEngineSite Interface Methods Properties See Also Send Feedback

The IEngineSite type exposes the following members.

Methods

Name | Description
ProgressEnd | Stops recalculation process.
ProgressStart | Starts recalculation process.
ShowProgress | Refreshes a progress bar with specific text.

Properties

Name | Description
Canceled | Gets an indication that calculation process was interrupted.

See Also

IEngineSite Interface
PerpetuumSoft.Olap.Data Namespace


IEngineSite Methods

[image] [image]

.NET ModelKit Suite ClassReference
IEngineSite Methods
IEngineSite Interface See Also Send Feedback

The IEngineSite type exposes the following members.

Methods

Name | Description
ProgressEnd | Stops recalculation process.
ProgressStart | Starts recalculation process.
ShowProgress | Refreshes a progress bar with specific text.

See Also

IEngineSite Interface
PerpetuumSoft.Olap.Data Namespace


ProgressEnd Method

[image]

.NET ModelKit Suite ClassReference
IEngineSite..::.ProgressEnd Method
IEngineSite Interface See Also Send Feedback
Stops recalculation process.

Namespace: PerpetuumSoft.Olap.Data
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
void ProgressEnd()
Visual Basic (Declaration)
Sub ProgressEnd
Visual C++
void ProgressEnd()

See Also

IEngineSite Interface
PerpetuumSoft.Olap.Data Namespace


ProgressStart Method

[image]

.NET ModelKit Suite ClassReference
IEngineSite..::.ProgressStart Method
IEngineSite Interface See Also Send Feedback
Starts recalculation process.

Namespace: PerpetuumSoft.Olap.Data
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
void ProgressStart()
Visual Basic (Declaration)
Sub ProgressStart
Visual C++
void ProgressStart()

See Also

IEngineSite Interface
PerpetuumSoft.Olap.Data Namespace


ShowProgress Method

[image]

.NET ModelKit Suite ClassReference
IEngineSite..::.ShowProgress Method
IEngineSite Interface See Also Send Feedback
Refreshes a progress bar with specific text.

Namespace: PerpetuumSoft.Olap.Data
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
void ShowProgress(
    string state
)
Visual Basic (Declaration)
Sub ShowProgress ( _
    state As String _
)
Visual C++
void ShowProgress(
    String^ state
)

Parameters

state
Type: System..::.String

See Also

IEngineSite Interface
PerpetuumSoft.Olap.Data Namespace


IEngineSite Properties

[image] [image]

.NET ModelKit Suite ClassReference
IEngineSite Properties
IEngineSite Interface See Also Send Feedback

The IEngineSite type exposes the following members.

Properties

Name | Description
Canceled | Gets an indication that calculation process was interrupted.

See Also

IEngineSite Interface
PerpetuumSoft.Olap.Data Namespace


Canceled Property

[image]

.NET ModelKit Suite ClassReference
IEngineSite..::.Canceled Property
IEngineSite Interface See Also Send Feedback
Gets an indication that calculation process was interrupted.

Namespace: PerpetuumSoft.Olap.Data
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
bool Canceled { get; }
Visual Basic (Declaration)
ReadOnly Property Canceled As Boolean
Visual C++
property bool Canceled {
    bool get ();
}

See Also

IEngineSite Interface
PerpetuumSoft.Olap.Data Namespace


PerpetuumSoft.Olap.Windows.Forms Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Olap.Windows.Forms Namespace
Send Feedback
The PerpetuumSoft.Olap.WindowsForms namespace contains classes which are used to dysplay a data cube on Windows Forms.

Classes

Class | Description
DataCubeGrid | Represents the grid for reviewing DataCube.
OfficePainter | Represents the object used for drawing a pivot table in office style.
PrintSettingsDialog | Print settings dialog
ProfessionalPainter | Represents the object for drawing a pivot table in graphics.
SmoothPainter | Represents the object used for pivot table drawing in smooth style.
XPPainter | Represents the object used for drawing a pivot table in XP style.

Enumerations

Enumeration | Description
CalculationMode | Enumerates modes for pivot table calculation.


CalculationMode Enumeration

[image]

.NET ModelKit Suite ClassReference
CalculationMode Enumeration
See Also Send Feedback
Enumerates modes for pivot table calculation.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public enum CalculationMode
Visual Basic (Declaration)
Public Enumeration CalculationMode
Visual C++
public enum class CalculationMode

Members

Member name | Description
Synchronous | Synchronous mode.
Asynchronous | Asynchronous mode.

See Also

PerpetuumSoft.Olap.Windows.Forms Namespace


DataCubeGrid Class

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid Class
Members See Also Send Feedback
Represents the grid for reviewing DataCube.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class DataCubeGrid : UserControl,
    IEngineSite
Visual Basic (Declaration)
Public Class DataCubeGrid _
    Inherits UserControl _
    Implements IEngineSite
Visual C++
public ref class DataCubeGrid : public UserControl,
    IEngineSite

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Olap.Windows.Forms..::.DataCubeGrid

See Also

DataCubeGrid Members
PerpetuumSoft.Olap.Windows.Forms Namespace


DataCubeGrid Members

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid Members
DataCubeGrid Class Constructors Methods Properties Events See Also Send Feedback

The DataCubeGrid type exposes the following members.

Constructors

Name | Description
DataCubeGrid | Initializes a new instance of the DataCubeGrid class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
AlignmentField | Aligns a column according to the text width.
AlignmentFields | Aligns all columns according to the text width.
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CanAlignmentField | Indicates the possibility of changing field Aligment.
CanSetCollapse | Indicates the possibility of setting the Collapsed property.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportToExcel | Shows the dialog for pivot table export to Excel.
ExportToHtml | Shows the dialog for pivot table export to HTML format.
ExportToPdf | Shows the PDF export settings dialog with the following pivot table export.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetCellInfo | Overloaded.
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
Open | Shows the dialog for opening DataCube settings file.
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Print | Shows the dialog for print.
PrintPreview | Shows the dialog for print preview.
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Recalculate | Recalculates a pivot table.
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Shows the dialog for saving DataCube settings file.
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAllCollapsed | Sets the value assigned by the parameter to the Collapsed property.
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetCollapsedAllItems | Sets the value assigned by the parameter to the Collapsed property for the indicated Field.
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowPrintSettingsDialog | Shows the print settings dialog.
ShowWizardDialog | Shows the DataCube wizard.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveCell | Gets CellInfo which supplies the information on the selected pivot table cell.
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoRecalculate | Gets or sets value that indicates if a pivot table will be recalculated.
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CalculationMode | Gets or sets CalculationMode for pivot table calcaulation.
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Painter | Gets or sets the Painter object that is used to paint a pivot table.
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowAutoRecalculate | Gets and sets whether the AutoRecalculate toolbutton will be visible.
ShowExportToExcel | Gets and sets whether the ExportToExcel toolbutton will be visible.
ShowExportToHtml | Gets and sets whether the ExportToHtml toolbutton will be visible.
ShowExportToPdf | Gets and sets whether the ExportToPDF toolbutton will be visible.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowOpen | Gets and sets whether the Open toolbutton will be visible.
ShowPrint | Gets and sets whether the Print toolbutton will be visible.
ShowPrintPreview | Gets and sets whether the PrintPrview toolbutton will be visible.
ShowPrintSettings | Gets and sets whether the PrintSettings toolbutton will be visible.
ShowRecalculate | Gets and sets whether the Recalculate toolbutton will be visible.
ShowSave | Gets and sets whether the Save toolbutton will be visible.
ShowToolBar | Gets and sets whether the ToolBar will be visible.
ShowWizard | Gets and sets whether the Wizard toolbutton will be visible.
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
Source | Gets or sets DataCube for review.
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
CellClick | Occurs when a pivot table cell was clicked.
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
DrawCell | Occurs at table lement drawing after the execution of [E:PerpetuumSoft.Olap.Windows.Forms.DataCubeGrid.DrawGridItem}]
DrawGridItem | Occurs when a table is being drawn.
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DataCubeGrid Constructor

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid Constructor
DataCubeGrid Class See Also Send Feedback
Initializes a new instance of the DataCubeGrid class.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public DataCubeGrid()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataCubeGrid()

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DataCubeGrid Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid Methods
DataCubeGrid Class See Also Send Feedback

The DataCubeGrid type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
AlignmentField | Aligns a column according to the text width.
AlignmentFields | Aligns all columns according to the text width.
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CanAlignmentField | Indicates the possibility of changing field Aligment.
CanSetCollapse | Indicates the possibility of setting the Collapsed property.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportToExcel | Shows the dialog for pivot table export to Excel.
ExportToHtml | Shows the dialog for pivot table export to HTML format.
ExportToPdf | Shows the PDF export settings dialog with the following pivot table export.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetCellInfo | Overloaded.
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
Open | Shows the dialog for opening DataCube settings file.
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Print | Shows the dialog for print.
PrintPreview | Shows the dialog for print preview.
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Recalculate | Recalculates a pivot table.
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Save | Shows the dialog for saving DataCube settings file.
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAllCollapsed | Sets the value assigned by the parameter to the Collapsed property.
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetCollapsedAllItems | Sets the value assigned by the parameter to the Collapsed property for the indicated Field.
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowPrintSettingsDialog | Shows the print settings dialog.
ShowWizardDialog | Shows the DataCube wizard.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.AccessibilityNotifyClients Method
DataCubeGrid Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DataCubeGrid Class
DataCubeGrid Members
PerpetuumSoft.Olap.Windows.Forms Namespace


AlignmentField Method

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.AlignmentField Method
DataCubeGrid Class See Also Send Feedback
Aligns a column according to the text width.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void AlignmentField(
    Field field
)
Visual Basic (Declaration)
Public Sub AlignmentField ( _
    field As Field _
)
Visual C++
public:
void AlignmentField(
    Field^ field
)

Parameters

field
Type: PerpetuumSoft.Olap..::.Field

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


AlignmentFields Method

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.AlignmentFields Method
DataCubeGrid Class See Also Send Feedback
Aligns all columns according to the text width.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void AlignmentFields()
Visual Basic (Declaration)
Public Sub AlignmentFields
Visual C++
public:
void AlignmentFields()

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.BeginInvoke Method
DataCubeGrid Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DataCubeGrid Class
DataCubeGrid Members
PerpetuumSoft.Olap.Windows.Forms Namespace


CanAlignmentField Method

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.CanAlignmentField Method
DataCubeGrid Class See Also Send Feedback
Indicates the possibility of changing field Aligment.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool CanAlignmentField(
    Field field
)
Visual Basic (Declaration)
Public Function CanAlignmentField ( _
    field As Field _
) As Boolean
Visual C++
public:
bool CanAlignmentField(
    Field^ field
)

Parameters

field
Type: PerpetuumSoft.Olap..::.Field

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


CanSetCollapse Method

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.CanSetCollapse Method
DataCubeGrid Class See Also Send Feedback
Indicates the possibility of setting the Collapsed property.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool CanSetCollapse(
    Field field
)
Visual Basic (Declaration)
Public Function CanSetCollapse ( _
    field As Field _
) As Boolean
Visual C++
public:
bool CanSetCollapse(
    Field^ field
)

Parameters

field
Type: PerpetuumSoft.Olap..::.Field

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.Dispose Method
DataCubeGrid Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Inherited from ContainerControl.)

See Also

DataCubeGrid Class
DataCubeGrid Members
PerpetuumSoft.Olap.Windows.Forms Namespace


ExportToExcel Method

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ExportToExcel Method
DataCubeGrid Class See Also Send Feedback
Shows the dialog for pivot table export to Excel.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void ExportToExcel()
Visual Basic (Declaration)
Public Sub ExportToExcel
Visual C++
public:
void ExportToExcel()

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ExportToHtml Method

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ExportToHtml Method
DataCubeGrid Class See Also Send Feedback
Shows the dialog for pivot table export to HTML format.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void ExportToHtml()
Visual Basic (Declaration)
Public Sub ExportToHtml
Visual C++
public:
void ExportToHtml()

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ExportToPdf Method

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ExportToPdf Method
DataCubeGrid Class See Also Send Feedback
Shows the PDF export settings dialog with the following pivot table export.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void ExportToPdf()
Visual Basic (Declaration)
Public Sub ExportToPdf
Visual C++
public:
void ExportToPdf()

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


GetCellInfo Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.GetCellInfo Method
DataCubeGrid Class See Also Send Feedback

Overload List

Name | Description
GetCellInfo(Point) | Returns information on a cell by point.
GetCellInfo(Int32, Int32) | Returns information on a cell by a table column and a table row.

See Also

DataCubeGrid Class
DataCubeGrid Members
PerpetuumSoft.Olap.Windows.Forms Namespace


GetCellInfo Method (Point)

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.GetCellInfo Method (Point)
DataCubeGrid Class See Also Send Feedback
Returns information on a cell by point.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellInfo GetCellInfo(
    Point point
)
Visual Basic (Declaration)
Public Function GetCellInfo ( _
    point As Point _
) As CellInfo
Visual C++
public:
CellInfo^ GetCellInfo(
    Point point
)

Parameters

point
Type: System.Drawing..::.Point

See Also

DataCubeGrid Class
GetCellInfo Overload
PerpetuumSoft.Olap.Windows.Forms Namespace


GetCellInfo Method (Int32, Int32)

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.GetCellInfo Method (Int32, Int32)
DataCubeGrid Class See Also Send Feedback
Returns information on a cell by a table column and a table row.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellInfo GetCellInfo(
    int row,
    int column
)
Visual Basic (Declaration)
Public Function GetCellInfo ( _
    row As Integer, _
    column As Integer _
) As CellInfo
Visual C++
public:
CellInfo^ GetCellInfo(
    int row,
    int column
)

Parameters

row
Type: System..::.Int32
column
Type: System..::.Int32

See Also

DataCubeGrid Class
GetCellInfo Overload
PerpetuumSoft.Olap.Windows.Forms Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.GetChildAtPoint Method
DataCubeGrid Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DataCubeGrid Class
DataCubeGrid Members
PerpetuumSoft.Olap.Windows.Forms Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.Invalidate Method
DataCubeGrid Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DataCubeGrid Class
DataCubeGrid Members
PerpetuumSoft.Olap.Windows.Forms Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.Invoke Method
DataCubeGrid Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DataCubeGrid Class
DataCubeGrid Members
PerpetuumSoft.Olap.Windows.Forms Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.MemberwiseClone Method
DataCubeGrid Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DataCubeGrid Class
DataCubeGrid Members
PerpetuumSoft.Olap.Windows.Forms Namespace


Open Method

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.Open Method
DataCubeGrid Class See Also Send Feedback
Shows the dialog for opening DataCube settings file.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void Open()
Visual Basic (Declaration)
Public Sub Open
Visual C++
public:
void Open()

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.PerformLayout Method
DataCubeGrid Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DataCubeGrid Class
DataCubeGrid Members
PerpetuumSoft.Olap.Windows.Forms Namespace


Print Method

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.Print Method
DataCubeGrid Class See Also Send Feedback
Shows the dialog for print.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void Print()
Visual Basic (Declaration)
Public Sub Print
Visual C++
public:
void Print()

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


PrintPreview Method

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.PrintPreview Method
DataCubeGrid Class See Also Send Feedback
Shows the dialog for print preview.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void PrintPreview()
Visual Basic (Declaration)
Public Sub PrintPreview
Visual C++
public:
void PrintPreview()

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


Recalculate Method

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.Recalculate Method
DataCubeGrid Class See Also Send Feedback
Recalculates a pivot table.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void Recalculate()
Visual Basic (Declaration)
Public Sub Recalculate
Visual C++
public:
void Recalculate()

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ResumeLayout Method
DataCubeGrid Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DataCubeGrid Class
DataCubeGrid Members
PerpetuumSoft.Olap.Windows.Forms Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.RtlTranslateAlignment Method
DataCubeGrid Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DataCubeGrid Class
DataCubeGrid Members
PerpetuumSoft.Olap.Windows.Forms Namespace


Save Method

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.Save Method
DataCubeGrid Class See Also Send Feedback
Shows the dialog for saving DataCube settings file.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void Save()
Visual Basic (Declaration)
Public Sub Save
Visual C++
public:
void Save()

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.Scale Method
DataCubeGrid Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DataCubeGrid Class
DataCubeGrid Members
PerpetuumSoft.Olap.Windows.Forms Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.Select Method
DataCubeGrid Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

DataCubeGrid Class
DataCubeGrid Members
PerpetuumSoft.Olap.Windows.Forms Namespace


SetAllCollapsed Method

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.SetAllCollapsed Method
DataCubeGrid Class See Also Send Feedback
Sets the value assigned by the parameter to the Collapsed property.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void SetAllCollapsed(
    bool isCollapse
)
Visual Basic (Declaration)
Public Sub SetAllCollapsed ( _
    isCollapse As Boolean _
)
Visual C++
public:
void SetAllCollapsed(
    bool isCollapse
)

Parameters

isCollapse
Type: System..::.Boolean

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.SetBounds Method
DataCubeGrid Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DataCubeGrid Class
DataCubeGrid Members
PerpetuumSoft.Olap.Windows.Forms Namespace


SetCollapsedAllItems Method

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.SetCollapsedAllItems Method
DataCubeGrid Class See Also Send Feedback
Sets the value assigned by the parameter to the Collapsed property for the indicated Field.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void SetCollapsedAllItems(
    Field field,
    bool isCollapse
)
Visual Basic (Declaration)
Public Sub SetCollapsedAllItems ( _
    field As Field, _
    isCollapse As Boolean _
)
Visual C++
public:
void SetCollapsedAllItems(
    Field^ field,
    bool isCollapse
)

Parameters

field
Type: PerpetuumSoft.Olap..::.Field
isCollapse
Type: System..::.Boolean

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ShowPrintSettingsDialog Method

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ShowPrintSettingsDialog Method
DataCubeGrid Class See Also Send Feedback
Shows the print settings dialog.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void ShowPrintSettingsDialog()
Visual Basic (Declaration)
Public Sub ShowPrintSettingsDialog
Visual C++
public:
void ShowPrintSettingsDialog()

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ShowWizardDialog Method

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ShowWizardDialog Method
DataCubeGrid Class See Also Send Feedback
Shows the DataCube wizard.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public void ShowWizardDialog()
Visual Basic (Declaration)
Public Sub ShowWizardDialog
Visual C++
public:
void ShowWizardDialog()

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.UpdateBounds Method
DataCubeGrid Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DataCubeGrid Class
DataCubeGrid Members
PerpetuumSoft.Olap.Windows.Forms Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.Validate Method
DataCubeGrid Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DataCubeGrid Class
DataCubeGrid Members
PerpetuumSoft.Olap.Windows.Forms Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ValidateChildren Method
DataCubeGrid Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

DataCubeGrid Class
DataCubeGrid Members
PerpetuumSoft.Olap.Windows.Forms Namespace


DataCubeGrid Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid Properties
DataCubeGrid Class See Also Send Feedback

The DataCubeGrid type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveCell | Gets CellInfo which supplies the information on the selected pivot table cell.
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoRecalculate | Gets or sets value that indicates if a pivot table will be recalculated.
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CalculationMode | Gets or sets CalculationMode for pivot table calcaulation.
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Painter | Gets or sets the Painter object that is used to paint a pivot table.
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowAutoRecalculate | Gets and sets whether the AutoRecalculate toolbutton will be visible.
ShowExportToExcel | Gets and sets whether the ExportToExcel toolbutton will be visible.
ShowExportToHtml | Gets and sets whether the ExportToHtml toolbutton will be visible.
ShowExportToPdf | Gets and sets whether the ExportToPDF toolbutton will be visible.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowOpen | Gets and sets whether the Open toolbutton will be visible.
ShowPrint | Gets and sets whether the Print toolbutton will be visible.
ShowPrintPreview | Gets and sets whether the PrintPrview toolbutton will be visible.
ShowPrintSettings | Gets and sets whether the PrintSettings toolbutton will be visible.
ShowRecalculate | Gets and sets whether the Recalculate toolbutton will be visible.
ShowSave | Gets and sets whether the Save toolbutton will be visible.
ShowToolBar | Gets and sets whether the ToolBar will be visible.
ShowWizard | Gets and sets whether the Wizard toolbutton will be visible.
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
Source | Gets or sets DataCube for review.
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ActiveCell Property

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ActiveCell Property
DataCubeGrid Class See Also Send Feedback
Gets CellInfo which supplies the information on the selected pivot table cell.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CellInfo ActiveCell { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActiveCell As CellInfo
Visual C++
public:
property CellInfo^ ActiveCell {
    CellInfo^ get ();
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


AutoRecalculate Property

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.AutoRecalculate Property
DataCubeGrid Class See Also Send Feedback
Gets or sets value that indicates if a pivot table will be recalculated.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool AutoRecalculate { get; set; }
Visual Basic (Declaration)
Public Property AutoRecalculate As Boolean
Visual C++
public:
property bool AutoRecalculate {
    bool get ();
    void set (bool value);
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


CalculationMode Property

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.CalculationMode Property
DataCubeGrid Class See Also Send Feedback
Gets or sets CalculationMode for pivot table calcaulation.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public CalculationMode CalculationMode { get; set; }
Visual Basic (Declaration)
Public Property CalculationMode As CalculationMode
Visual C++
public:
property CalculationMode CalculationMode {
    CalculationMode get ();
    void set (CalculationMode value);
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


Painter Property

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.Painter Property
DataCubeGrid Class See Also Send Feedback
Gets or sets the Painter object that is used to paint a pivot table.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Painter Painter { get; set; }
Visual Basic (Declaration)
Public Property Painter As Painter
Visual C++
public:
property Painter^ Painter {
    Painter^ get ();
    void set (Painter^ value);
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ShowAutoRecalculate Property

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ShowAutoRecalculate Property
DataCubeGrid Class See Also Send Feedback
Gets and sets whether the AutoRecalculate toolbutton will be visible.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowAutoRecalculate { get; set; }
Visual Basic (Declaration)
Public Property ShowAutoRecalculate As Boolean
Visual C++
public:
property bool ShowAutoRecalculate {
    bool get ();
    void set (bool value);
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ShowExportToExcel Property

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ShowExportToExcel Property
DataCubeGrid Class See Also Send Feedback
Gets and sets whether the ExportToExcel toolbutton will be visible.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowExportToExcel { get; set; }
Visual Basic (Declaration)
Public Property ShowExportToExcel As Boolean
Visual C++
public:
property bool ShowExportToExcel {
    bool get ();
    void set (bool value);
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ShowExportToHtml Property

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ShowExportToHtml Property
DataCubeGrid Class See Also Send Feedback
Gets and sets whether the ExportToHtml toolbutton will be visible.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowExportToHtml { get; set; }
Visual Basic (Declaration)
Public Property ShowExportToHtml As Boolean
Visual C++
public:
property bool ShowExportToHtml {
    bool get ();
    void set (bool value);
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ShowExportToPdf Property

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ShowExportToPdf Property
DataCubeGrid Class See Also Send Feedback
Gets and sets whether the ExportToPDF toolbutton will be visible.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowExportToPdf { get; set; }
Visual Basic (Declaration)
Public Property ShowExportToPdf As Boolean
Visual C++
public:
property bool ShowExportToPdf {
    bool get ();
    void set (bool value);
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ShowOpen Property

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ShowOpen Property
DataCubeGrid Class See Also Send Feedback
Gets and sets whether the Open toolbutton will be visible.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowOpen { get; set; }
Visual Basic (Declaration)
Public Property ShowOpen As Boolean
Visual C++
public:
property bool ShowOpen {
    bool get ();
    void set (bool value);
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ShowPrint Property

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ShowPrint Property
DataCubeGrid Class See Also Send Feedback
Gets and sets whether the Print toolbutton will be visible.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowPrint { get; set; }
Visual Basic (Declaration)
Public Property ShowPrint As Boolean
Visual C++
public:
property bool ShowPrint {
    bool get ();
    void set (bool value);
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ShowPrintPreview Property

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ShowPrintPreview Property
DataCubeGrid Class See Also Send Feedback
Gets and sets whether the PrintPrview toolbutton will be visible.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowPrintPreview { get; set; }
Visual Basic (Declaration)
Public Property ShowPrintPreview As Boolean
Visual C++
public:
property bool ShowPrintPreview {
    bool get ();
    void set (bool value);
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ShowPrintSettings Property

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ShowPrintSettings Property
DataCubeGrid Class See Also Send Feedback
Gets and sets whether the PrintSettings toolbutton will be visible.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowPrintSettings { get; set; }
Visual Basic (Declaration)
Public Property ShowPrintSettings As Boolean
Visual C++
public:
property bool ShowPrintSettings {
    bool get ();
    void set (bool value);
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ShowRecalculate Property

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ShowRecalculate Property
DataCubeGrid Class See Also Send Feedback
Gets and sets whether the Recalculate toolbutton will be visible.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowRecalculate { get; set; }
Visual Basic (Declaration)
Public Property ShowRecalculate As Boolean
Visual C++
public:
property bool ShowRecalculate {
    bool get ();
    void set (bool value);
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ShowSave Property

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ShowSave Property
DataCubeGrid Class See Also Send Feedback
Gets and sets whether the Save toolbutton will be visible.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowSave { get; set; }
Visual Basic (Declaration)
Public Property ShowSave As Boolean
Visual C++
public:
property bool ShowSave {
    bool get ();
    void set (bool value);
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ShowToolBar Property

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ShowToolBar Property
DataCubeGrid Class See Also Send Feedback
Gets and sets whether the ToolBar will be visible.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowToolBar { get; set; }
Visual Basic (Declaration)
Public Property ShowToolBar As Boolean
Visual C++
public:
property bool ShowToolBar {
    bool get ();
    void set (bool value);
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ShowWizard Property

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.ShowWizard Property
DataCubeGrid Class See Also Send Feedback
Gets and sets whether the Wizard toolbutton will be visible.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowWizard { get; set; }
Visual Basic (Declaration)
Public Property ShowWizard As Boolean
Visual C++
public:
property bool ShowWizard {
    bool get ();
    void set (bool value);
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


Source Property

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.Source Property
DataCubeGrid Class See Also Send Feedback
Gets or sets DataCube for review.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public DataCube Source { get; set; }
Visual Basic (Declaration)
Public Property Source As DataCube
Visual C++
public:
property DataCube^ Source {
    DataCube^ get ();
    void set (DataCube^ value);
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DataCubeGrid Events

[image] [image]

.NET ModelKit Suite ClassReference
DataCubeGrid Events
DataCubeGrid Class See Also Send Feedback

The DataCubeGrid type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
CellClick | Occurs when a pivot table cell was clicked.
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
DrawCell | Occurs at table lement drawing after the execution of [E:PerpetuumSoft.Olap.Windows.Forms.DataCubeGrid.DrawGridItem}]
DrawGridItem | Occurs when a table is being drawn.
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


CellClick Event

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.CellClick Event
DataCubeGrid Class See Also Send Feedback
Occurs when a pivot table cell was clicked.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public event CellEventHandler CellClick
Visual Basic (Declaration)
Public Event CellClick As CellEventHandler
Visual C++
public:
 event CellEventHandler^ CellClick {
    void add (CellEventHandler^ value);
    void remove (CellEventHandler^ value);
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawCell Event

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.DrawCell Event
DataCubeGrid Class See Also Send Feedback
Occurs at table lement drawing after the execution of [E:PerpetuumSoft.Olap.Windows.Forms.DataCubeGrid.DrawGridItem}]

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public event DrawCellEventHandler DrawCell
Visual Basic (Declaration)
Public Event DrawCell As DrawCellEventHandler
Visual C++
public:
 event DrawCellEventHandler^ DrawCell {
    void add (DrawCellEventHandler^ value);
    void remove (DrawCellEventHandler^ value);
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawGridItem Event

[image]

.NET ModelKit Suite ClassReference
DataCubeGrid..::.DrawGridItem Event
DataCubeGrid Class See Also Send Feedback
Occurs when a table is being drawn.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public event DrawGridItemEventHandler DrawGridItem
Visual Basic (Declaration)
Public Event DrawGridItem As DrawGridItemEventHandler
Visual C++
public:
 event DrawGridItemEventHandler^ DrawGridItem {
    void add (DrawGridItemEventHandler^ value);
    void remove (DrawGridItemEventHandler^ value);
}

See Also

DataCubeGrid Class
PerpetuumSoft.Olap.Windows.Forms Namespace


OfficePainter Class

[image]

.NET ModelKit Suite ClassReference
OfficePainter Class
Members See Also Send Feedback
Represents the object used for drawing a pivot table in office style.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class OfficePainter : Painter
Visual Basic (Declaration)
Public Class OfficePainter _
    Inherits Painter
Visual C++
public ref class OfficePainter : public Painter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.Painter
PerpetuumSoft.Olap.Windows.Forms..::.OfficePainter

See Also

OfficePainter Members
PerpetuumSoft.Olap.Windows.Forms Namespace


OfficePainter Members

[image] [image]

.NET ModelKit Suite ClassReference
OfficePainter Members
OfficePainter Class Constructors Methods See Also Send Feedback

The OfficePainter type exposes the following members.

Constructors

Name | Description
OfficePainter | Initializes a new instance of the OfficePainter class.

Methods

Name | Description
DrawCollapseButton | Overridden. See DrawCollapseButton(Graphics, Rectangle, Boolean). (Overrides Painter..::.DrawCollapseButton(Graphics, Rectangle, Boolean).)
DrawDimensionCell | Overridden. See DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point). (Overrides Painter..::.DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point).)
DrawDropButton | Overridden. See DrawDropButton(Graphics, Rectangle, ControlState, Boolean). (Overrides Painter..::.DrawDropButton(Graphics, Rectangle, ControlState, Boolean).)
DrawFieldCaption | Overridden. See DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size). (Overrides Painter..::.DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size).)
DrawProgressCell | Overridden. See DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double). (Overrides Painter..::.DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double).)
DrawShiftButton | Overridden. See DrawShiftButton(Graphics, Rectangle, Direction). (Overrides Painter..::.DrawShiftButton(Graphics, Rectangle, Direction).)
DrawSplitterLine | Overridden. See DrawSplitterLine(Graphics, Rectangle). (Overrides Painter..::.DrawSplitterLine(Graphics, Rectangle).)
DrawTextCell | Overridden. See DrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String). (Overrides PainterDrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String).)
DrawTitle | Overridden. See DrawTitle(Graphics, Rectangle, CellStyle, String). (Overrides Painter..::.DrawTitle(Graphics, Rectangle, CellStyle, String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCaptionStringWidth | Returns the string width in pixels. (Inherited from Painter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

OfficePainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


OfficePainter Constructor

[image]

.NET ModelKit Suite ClassReference
OfficePainter Constructor
OfficePainter Class See Also Send Feedback
Initializes a new instance of the OfficePainter class.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public OfficePainter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OfficePainter()

See Also

OfficePainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


OfficePainter Methods

[image] [image]

.NET ModelKit Suite ClassReference
OfficePainter Methods
OfficePainter Class See Also Send Feedback

The OfficePainter type exposes the following members.

Methods

Name | Description
DrawCollapseButton | Overridden. See DrawCollapseButton(Graphics, Rectangle, Boolean). (Overrides Painter..::.DrawCollapseButton(Graphics, Rectangle, Boolean).)
DrawDimensionCell | Overridden. See DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point). (Overrides Painter..::.DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point).)
DrawDropButton | Overridden. See DrawDropButton(Graphics, Rectangle, ControlState, Boolean). (Overrides Painter..::.DrawDropButton(Graphics, Rectangle, ControlState, Boolean).)
DrawFieldCaption | Overridden. See DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size). (Overrides Painter..::.DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size).)
DrawProgressCell | Overridden. See DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double). (Overrides Painter..::.DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double).)
DrawShiftButton | Overridden. See DrawShiftButton(Graphics, Rectangle, Direction). (Overrides Painter..::.DrawShiftButton(Graphics, Rectangle, Direction).)
DrawSplitterLine | Overridden. See DrawSplitterLine(Graphics, Rectangle). (Overrides Painter..::.DrawSplitterLine(Graphics, Rectangle).)
DrawTextCell | Overridden. See DrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String). (Overrides PainterDrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String).)
DrawTitle | Overridden. See DrawTitle(Graphics, Rectangle, CellStyle, String). (Overrides Painter..::.DrawTitle(Graphics, Rectangle, CellStyle, String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCaptionStringWidth | Returns the string width in pixels. (Inherited from Painter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

OfficePainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawCollapseButton Method

[image]

.NET ModelKit Suite ClassReference
OfficePainter..::.DrawCollapseButton Method
OfficePainter Class See Also Send Feedback
Overridden. See DrawCollapseButton(Graphics, Rectangle, Boolean).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawCollapseButton(
    Graphics graphics,
    Rectangle bounds,
    bool isCollapse
)
Visual Basic (Declaration)
Public Overrides Sub DrawCollapseButton ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    isCollapse As Boolean _
)
Visual C++
public:
virtual void DrawCollapseButton(
    Graphics^ graphics,
    Rectangle bounds,
    bool isCollapse
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
isCollapse
Type: System..::.Boolean

See Also

OfficePainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawDimensionCell Method

[image]

.NET ModelKit Suite ClassReference
OfficePainter..::.DrawDimensionCell Method
OfficePainter Class See Also Send Feedback
Overridden. See DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawDimensionCell(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    CellBorder border,
    string text,
    Point startDrawPosition
)
Visual Basic (Declaration)
Public Overrides Sub DrawDimensionCell ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    border As CellBorder, _
    text As String, _
    startDrawPosition As Point _
)
Visual C++
public:
virtual void DrawDimensionCell(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    CellBorder^ border,
    String^ text,
    Point startDrawPosition
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
border
Type: PerpetuumSoft.Olap..::.CellBorder
text
Type: System..::.String
startDrawPosition
Type: System.Drawing..::.Point

See Also

OfficePainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawDropButton Method

[image]

.NET ModelKit Suite ClassReference
OfficePainter..::.DrawDropButton Method
OfficePainter Class See Also Send Feedback
Overridden. See DrawDropButton(Graphics, Rectangle, ControlState, Boolean).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawDropButton(
    Graphics graphics,
    Rectangle bounds,
    ControlState state,
    bool select
)
Visual Basic (Declaration)
Public Overrides Sub DrawDropButton ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    state As ControlState, _
    select As Boolean _
)
Visual C++
public:
virtual void DrawDropButton(
    Graphics^ graphics,
    Rectangle bounds,
    ControlState state,
    bool select
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
state
Type: PerpetuumSoft.Olap..::.ControlState
select
Type: System..::.Boolean

See Also

OfficePainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawFieldCaption Method

[image]

.NET ModelKit Suite ClassReference
OfficePainter..::.DrawFieldCaption Method
OfficePainter Class See Also Send Feedback
Overridden. See DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawFieldCaption(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    CellBorder border,
    ControlState state,
    SortOrder sortOrder,
    bool enabledSort,
    string text,
    Size clientSize
)
Visual Basic (Declaration)
Public Overrides Sub DrawFieldCaption ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    border As CellBorder, _
    state As ControlState, _
    sortOrder As SortOrder, _
    enabledSort As Boolean, _
    text As String, _
    clientSize As Size _
)
Visual C++
public:
virtual void DrawFieldCaption(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    CellBorder^ border,
    ControlState state,
    SortOrder sortOrder,
    bool enabledSort,
    String^ text,
    Size clientSize
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
border
Type: PerpetuumSoft.Olap..::.CellBorder
state
Type: PerpetuumSoft.Olap..::.ControlState
sortOrder
Type: PerpetuumSoft.Olap..::.SortOrder
enabledSort
Type: System..::.Boolean
text
Type: System..::.String
clientSize
Type: System.Drawing..::.Size

See Also

OfficePainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawProgressCell Method

[image]

.NET ModelKit Suite ClassReference
OfficePainter..::.DrawProgressCell Method
OfficePainter Class See Also Send Feedback
Overridden. See DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawProgressCell(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    CellBorder border,
    string text,
    double value
)
Visual Basic (Declaration)
Public Overrides Sub DrawProgressCell ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    border As CellBorder, _
    text As String, _
    value As Double _
)
Visual C++
public:
virtual void DrawProgressCell(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    CellBorder^ border,
    String^ text,
    double value
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
border
Type: PerpetuumSoft.Olap..::.CellBorder
text
Type: System..::.String
value
Type: System..::.Double

See Also

OfficePainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawShiftButton Method

[image]

.NET ModelKit Suite ClassReference
OfficePainter..::.DrawShiftButton Method
OfficePainter Class See Also Send Feedback
Overridden. See DrawShiftButton(Graphics, Rectangle, Direction).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawShiftButton(
    Graphics graphics,
    Rectangle bounds,
    Direction direct
)
Visual Basic (Declaration)
Public Overrides Sub DrawShiftButton ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    direct As Direction _
)
Visual C++
public:
virtual void DrawShiftButton(
    Graphics^ graphics,
    Rectangle bounds,
    Direction direct
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
direct
Type: PerpetuumSoft.Olap..::.Direction

See Also

OfficePainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawSplitterLine Method

[image]

.NET ModelKit Suite ClassReference
OfficePainter..::.DrawSplitterLine Method
OfficePainter Class See Also Send Feedback
Overridden. See DrawSplitterLine(Graphics, Rectangle).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawSplitterLine(
    Graphics graphics,
    Rectangle bounds
)
Visual Basic (Declaration)
Public Overrides Sub DrawSplitterLine ( _
    graphics As Graphics, _
    bounds As Rectangle _
)
Visual C++
public:
virtual void DrawSplitterLine(
    Graphics^ graphics,
    Rectangle bounds
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle

See Also

OfficePainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawTextCell Method

[image]

.NET ModelKit Suite ClassReference
OfficePainter..::.DrawTextCell Method
OfficePainter Class See Also Send Feedback
Overridden. See DrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawTextCell(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    CellBorder border,
    string text
)
Visual Basic (Declaration)
Public Overrides Sub DrawTextCell ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    border As CellBorder, _
    text As String _
)
Visual C++
public:
virtual void DrawTextCell(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    CellBorder^ border,
    String^ text
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
border
Type: PerpetuumSoft.Olap..::.CellBorder
text
Type: System..::.String

See Also

OfficePainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawTitle Method

[image]

.NET ModelKit Suite ClassReference
OfficePainter..::.DrawTitle Method
OfficePainter Class See Also Send Feedback
Overridden. See DrawTitle(Graphics, Rectangle, CellStyle, String).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawTitle(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    string text
)
Visual Basic (Declaration)
Public Overrides Sub DrawTitle ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    text As String _
)
Visual C++
public:
virtual void DrawTitle(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    String^ text
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
text
Type: System..::.String

See Also

OfficePainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
OfficePainter..::.ToString Method
OfficePainter Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

OfficePainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


PrintSettingsDialog Class

[image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog Class
Members See Also Send Feedback
Print settings dialog

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class PrintSettingsDialog : Form
Visual Basic (Declaration)
Public Class PrintSettingsDialog _
    Inherits Form
Visual C++
public ref class PrintSettingsDialog : public Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
PerpetuumSoft.Olap.Windows.Forms..::.PrintSettingsDialog

See Also

PrintSettingsDialog Members
PerpetuumSoft.Olap.Windows.Forms Namespace


PrintSettingsDialog Members

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog Members
PrintSettingsDialog Class Constructors Methods Properties Events See Also Send Feedback

The PrintSettingsDialog type exposes the following members.

Constructors

Name | Description
PrintSettingsDialog | Initializes a new instance of the PrintSettingsDialog class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
PrintSettings | Gets or sets DataCubePrintSettings
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PrintSettingsDialog Class
PerpetuumSoft.Olap.Windows.Forms Namespace


PrintSettingsDialog Constructor

[image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog Constructor
PrintSettingsDialog Class See Also Send Feedback
Initializes a new instance of the PrintSettingsDialog class.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public PrintSettingsDialog()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PrintSettingsDialog()

See Also

PrintSettingsDialog Class
PerpetuumSoft.Olap.Windows.Forms Namespace


PrintSettingsDialog Methods

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog Methods
PrintSettingsDialog Class See Also Send Feedback

The PrintSettingsDialog type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

PrintSettingsDialog Class
PerpetuumSoft.Olap.Windows.Forms Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog..::.AccessibilityNotifyClients Method
PrintSettingsDialog Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

PrintSettingsDialog Class
PrintSettingsDialog Members
PerpetuumSoft.Olap.Windows.Forms Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog..::.BeginInvoke Method
PrintSettingsDialog Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

PrintSettingsDialog Class
PrintSettingsDialog Members
PerpetuumSoft.Olap.Windows.Forms Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog..::.Dispose Method
PrintSettingsDialog Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Disposes of the resources (other than memory) used by the Form. (Inherited from Form.)

See Also

PrintSettingsDialog Class
PrintSettingsDialog Members
PerpetuumSoft.Olap.Windows.Forms Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog..::.GetChildAtPoint Method
PrintSettingsDialog Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

PrintSettingsDialog Class
PrintSettingsDialog Members
PerpetuumSoft.Olap.Windows.Forms Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog..::.Invalidate Method
PrintSettingsDialog Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

PrintSettingsDialog Class
PrintSettingsDialog Members
PerpetuumSoft.Olap.Windows.Forms Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog..::.Invoke Method
PrintSettingsDialog Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

PrintSettingsDialog Class
PrintSettingsDialog Members
PerpetuumSoft.Olap.Windows.Forms Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog..::.MemberwiseClone Method
PrintSettingsDialog Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PrintSettingsDialog Class
PrintSettingsDialog Members
PerpetuumSoft.Olap.Windows.Forms Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog..::.PerformLayout Method
PrintSettingsDialog Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

PrintSettingsDialog Class
PrintSettingsDialog Members
PerpetuumSoft.Olap.Windows.Forms Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog..::.ResumeLayout Method
PrintSettingsDialog Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

PrintSettingsDialog Class
PrintSettingsDialog Members
PerpetuumSoft.Olap.Windows.Forms Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog..::.RtlTranslateAlignment Method
PrintSettingsDialog Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

PrintSettingsDialog Class
PrintSettingsDialog Members
PerpetuumSoft.Olap.Windows.Forms Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog..::.Scale Method
PrintSettingsDialog Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

PrintSettingsDialog Class
PrintSettingsDialog Members
PerpetuumSoft.Olap.Windows.Forms Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog..::.Select Method
PrintSettingsDialog Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

PrintSettingsDialog Class
PrintSettingsDialog Members
PerpetuumSoft.Olap.Windows.Forms Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog..::.SetBounds Method
PrintSettingsDialog Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

PrintSettingsDialog Class
PrintSettingsDialog Members
PerpetuumSoft.Olap.Windows.Forms Namespace


Show Method

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog..::.Show Method
PrintSettingsDialog Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

PrintSettingsDialog Class
PrintSettingsDialog Members
PerpetuumSoft.Olap.Windows.Forms Namespace


ShowDialog Method

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog..::.ShowDialog Method
PrintSettingsDialog Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

PrintSettingsDialog Class
PrintSettingsDialog Members
PerpetuumSoft.Olap.Windows.Forms Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog..::.UpdateBounds Method
PrintSettingsDialog Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

PrintSettingsDialog Class
PrintSettingsDialog Members
PerpetuumSoft.Olap.Windows.Forms Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog..::.Validate Method
PrintSettingsDialog Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

PrintSettingsDialog Class
PrintSettingsDialog Members
PerpetuumSoft.Olap.Windows.Forms Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog..::.ValidateChildren Method
PrintSettingsDialog Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

PrintSettingsDialog Class
PrintSettingsDialog Members
PerpetuumSoft.Olap.Windows.Forms Namespace


PrintSettingsDialog Properties

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog Properties
PrintSettingsDialog Class See Also Send Feedback

The PrintSettingsDialog type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
PrintSettings | Gets or sets DataCubePrintSettings
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

PrintSettingsDialog Class
PerpetuumSoft.Olap.Windows.Forms Namespace


PrintSettings Property

[image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog..::.PrintSettings Property
PrintSettingsDialog Class See Also Send Feedback
Gets or sets DataCubePrintSettings

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public DataCubePrintSettings PrintSettings { get; set; }
Visual Basic (Declaration)
Public Property PrintSettings As DataCubePrintSettings
Visual C++
public:
property DataCubePrintSettings^ PrintSettings {
    DataCubePrintSettings^ get ();
    void set (DataCubePrintSettings^ value);
}

See Also

PrintSettingsDialog Class
PerpetuumSoft.Olap.Windows.Forms Namespace


PrintSettingsDialog Events

[image] [image]

.NET ModelKit Suite ClassReference
PrintSettingsDialog Events
PrintSettingsDialog Class See Also Send Feedback

The PrintSettingsDialog type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PrintSettingsDialog Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ProfessionalPainter Class

[image]

.NET ModelKit Suite ClassReference
ProfessionalPainter Class
Members See Also Send Feedback
Represents the object for drawing a pivot table in graphics.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class ProfessionalPainter : Painter
Visual Basic (Declaration)
Public Class ProfessionalPainter _
    Inherits Painter
Visual C++
public ref class ProfessionalPainter : public Painter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.Painter
PerpetuumSoft.Olap.Windows.Forms..::.ProfessionalPainter

See Also

ProfessionalPainter Members
PerpetuumSoft.Olap.Windows.Forms Namespace


ProfessionalPainter Members

[image] [image]

.NET ModelKit Suite ClassReference
ProfessionalPainter Members
ProfessionalPainter Class Constructors Methods Properties See Also Send Feedback

The ProfessionalPainter type exposes the following members.

Constructors

Name | Description
ProfessionalPainter | Overloaded.

Methods

Name | Description
DrawCollapseButton | Overridden. See DrawCollapseButton(Graphics, Rectangle, Boolean). (Overrides Painter..::.DrawCollapseButton(Graphics, Rectangle, Boolean).)
DrawDimensionCell | Overridden. See DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point). (Overrides Painter..::.DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point).)
DrawDropButton | Overridden. See DrawDropButton(Graphics, Rectangle, ControlState, Boolean). (Overrides Painter..::.DrawDropButton(Graphics, Rectangle, ControlState, Boolean).)
DrawFieldCaption | Overridden. See DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size). (Overrides Painter..::.DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size).)
DrawProgressCell | Overridden. See DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double). (Overrides Painter..::.DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double).)
DrawShiftButton | Overridden. See DrawShiftButton(Graphics, Rectangle, Direction). (Overrides Painter..::.DrawShiftButton(Graphics, Rectangle, Direction).)
DrawSplitterLine | Overridden. See DrawSplitterLine(Graphics, Rectangle). (Overrides Painter..::.DrawSplitterLine(Graphics, Rectangle).)
DrawTextCell | Overridden. See DrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String). (Overrides PainterDrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String).)
DrawTitle | Overridden. See DrawTitle(Graphics, Rectangle, CellStyle, String). (Overrides Painter..::.DrawTitle(Graphics, Rectangle, CellStyle, String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCaptionStringWidth | Returns the string width in pixels. (Inherited from Painter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
BackgroundColor | Gets or sets Color
BorderColor | Gets or sets Color
HighlightColor | Gets or sets Color

See Also

ProfessionalPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ProfessionalPainter Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ProfessionalPainter Constructor
ProfessionalPainter Class See Also Send Feedback

Overload List

Name | Description
ProfessionalPainter()()() | Initializes a new instance of the ProfessionalPainter class.
ProfessionalPainter(Color, Color) | Initializes a new instance of the ProfessionalPainter class.

See Also

ProfessionalPainter Class
ProfessionalPainter Members
PerpetuumSoft.Olap.Windows.Forms Namespace


ProfessionalPainter Constructor

[image]

.NET ModelKit Suite ClassReference
ProfessionalPainter Constructor
ProfessionalPainter Class See Also Send Feedback
Initializes a new instance of the ProfessionalPainter class.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public ProfessionalPainter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProfessionalPainter()

See Also

ProfessionalPainter Class
ProfessionalPainter Overload
PerpetuumSoft.Olap.Windows.Forms Namespace


ProfessionalPainter Constructor (Color, Color)

[image]

.NET ModelKit Suite ClassReference
ProfessionalPainter Constructor (Color, Color)
ProfessionalPainter Class See Also Send Feedback
Initializes a new instance of the ProfessionalPainter class.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public ProfessionalPainter(
    Color backgroundColor,
    Color borderColor
)
Visual Basic (Declaration)
Public Sub New ( _
    backgroundColor As Color, _
    borderColor As Color _
)
Visual C++
public:
ProfessionalPainter(
    Color backgroundColor,
    Color borderColor
)

Parameters

backgroundColor
Type: System.Drawing..::.Color
borderColor
Type: System.Drawing..::.Color

See Also

ProfessionalPainter Class
ProfessionalPainter Overload
PerpetuumSoft.Olap.Windows.Forms Namespace


ProfessionalPainter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ProfessionalPainter Methods
ProfessionalPainter Class See Also Send Feedback

The ProfessionalPainter type exposes the following members.

Methods

Name | Description
DrawCollapseButton | Overridden. See DrawCollapseButton(Graphics, Rectangle, Boolean). (Overrides Painter..::.DrawCollapseButton(Graphics, Rectangle, Boolean).)
DrawDimensionCell | Overridden. See DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point). (Overrides Painter..::.DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point).)
DrawDropButton | Overridden. See DrawDropButton(Graphics, Rectangle, ControlState, Boolean). (Overrides Painter..::.DrawDropButton(Graphics, Rectangle, ControlState, Boolean).)
DrawFieldCaption | Overridden. See DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size). (Overrides Painter..::.DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size).)
DrawProgressCell | Overridden. See DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double). (Overrides Painter..::.DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double).)
DrawShiftButton | Overridden. See DrawShiftButton(Graphics, Rectangle, Direction). (Overrides Painter..::.DrawShiftButton(Graphics, Rectangle, Direction).)
DrawSplitterLine | Overridden. See DrawSplitterLine(Graphics, Rectangle). (Overrides Painter..::.DrawSplitterLine(Graphics, Rectangle).)
DrawTextCell | Overridden. See DrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String). (Overrides PainterDrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String).)
DrawTitle | Overridden. See DrawTitle(Graphics, Rectangle, CellStyle, String). (Overrides Painter..::.DrawTitle(Graphics, Rectangle, CellStyle, String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCaptionStringWidth | Returns the string width in pixels. (Inherited from Painter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

ProfessionalPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawCollapseButton Method

[image]

.NET ModelKit Suite ClassReference
ProfessionalPainter..::.DrawCollapseButton Method
ProfessionalPainter Class See Also Send Feedback
Overridden. See DrawCollapseButton(Graphics, Rectangle, Boolean).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawCollapseButton(
    Graphics graphics,
    Rectangle bounds,
    bool isCollapse
)
Visual Basic (Declaration)
Public Overrides Sub DrawCollapseButton ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    isCollapse As Boolean _
)
Visual C++
public:
virtual void DrawCollapseButton(
    Graphics^ graphics,
    Rectangle bounds,
    bool isCollapse
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
isCollapse
Type: System..::.Boolean

See Also

ProfessionalPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawDimensionCell Method

[image]

.NET ModelKit Suite ClassReference
ProfessionalPainter..::.DrawDimensionCell Method
ProfessionalPainter Class See Also Send Feedback
Overridden. See DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawDimensionCell(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    CellBorder border,
    string text,
    Point startDrawPosition
)
Visual Basic (Declaration)
Public Overrides Sub DrawDimensionCell ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    border As CellBorder, _
    text As String, _
    startDrawPosition As Point _
)
Visual C++
public:
virtual void DrawDimensionCell(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    CellBorder^ border,
    String^ text,
    Point startDrawPosition
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
border
Type: PerpetuumSoft.Olap..::.CellBorder
text
Type: System..::.String
startDrawPosition
Type: System.Drawing..::.Point

See Also

ProfessionalPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawDropButton Method

[image]

.NET ModelKit Suite ClassReference
ProfessionalPainter..::.DrawDropButton Method
ProfessionalPainter Class See Also Send Feedback
Overridden. See DrawDropButton(Graphics, Rectangle, ControlState, Boolean).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawDropButton(
    Graphics graphics,
    Rectangle bounds,
    ControlState state,
    bool select
)
Visual Basic (Declaration)
Public Overrides Sub DrawDropButton ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    state As ControlState, _
    select As Boolean _
)
Visual C++
public:
virtual void DrawDropButton(
    Graphics^ graphics,
    Rectangle bounds,
    ControlState state,
    bool select
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
state
Type: PerpetuumSoft.Olap..::.ControlState
select
Type: System..::.Boolean

See Also

ProfessionalPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawFieldCaption Method

[image]

.NET ModelKit Suite ClassReference
ProfessionalPainter..::.DrawFieldCaption Method
ProfessionalPainter Class See Also Send Feedback
Overridden. See DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawFieldCaption(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    CellBorder border,
    ControlState state,
    SortOrder sortOrder,
    bool enabledSort,
    string text,
    Size clientSize
)
Visual Basic (Declaration)
Public Overrides Sub DrawFieldCaption ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    border As CellBorder, _
    state As ControlState, _
    sortOrder As SortOrder, _
    enabledSort As Boolean, _
    text As String, _
    clientSize As Size _
)
Visual C++
public:
virtual void DrawFieldCaption(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    CellBorder^ border,
    ControlState state,
    SortOrder sortOrder,
    bool enabledSort,
    String^ text,
    Size clientSize
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
border
Type: PerpetuumSoft.Olap..::.CellBorder
state
Type: PerpetuumSoft.Olap..::.ControlState
sortOrder
Type: PerpetuumSoft.Olap..::.SortOrder
enabledSort
Type: System..::.Boolean
text
Type: System..::.String
clientSize
Type: System.Drawing..::.Size

See Also

ProfessionalPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawProgressCell Method

[image]

.NET ModelKit Suite ClassReference
ProfessionalPainter..::.DrawProgressCell Method
ProfessionalPainter Class See Also Send Feedback
Overridden. See DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawProgressCell(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    CellBorder border,
    string text,
    double value
)
Visual Basic (Declaration)
Public Overrides Sub DrawProgressCell ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    border As CellBorder, _
    text As String, _
    value As Double _
)
Visual C++
public:
virtual void DrawProgressCell(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    CellBorder^ border,
    String^ text,
    double value
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
border
Type: PerpetuumSoft.Olap..::.CellBorder
text
Type: System..::.String
value
Type: System..::.Double

See Also

ProfessionalPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawShiftButton Method

[image]

.NET ModelKit Suite ClassReference
ProfessionalPainter..::.DrawShiftButton Method
ProfessionalPainter Class See Also Send Feedback
Overridden. See DrawShiftButton(Graphics, Rectangle, Direction).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawShiftButton(
    Graphics graphics,
    Rectangle bounds,
    Direction direct
)
Visual Basic (Declaration)
Public Overrides Sub DrawShiftButton ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    direct As Direction _
)
Visual C++
public:
virtual void DrawShiftButton(
    Graphics^ graphics,
    Rectangle bounds,
    Direction direct
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
direct
Type: PerpetuumSoft.Olap..::.Direction

See Also

ProfessionalPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawSplitterLine Method

[image]

.NET ModelKit Suite ClassReference
ProfessionalPainter..::.DrawSplitterLine Method
ProfessionalPainter Class See Also Send Feedback
Overridden. See DrawSplitterLine(Graphics, Rectangle).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawSplitterLine(
    Graphics graphics,
    Rectangle bounds
)
Visual Basic (Declaration)
Public Overrides Sub DrawSplitterLine ( _
    graphics As Graphics, _
    bounds As Rectangle _
)
Visual C++
public:
virtual void DrawSplitterLine(
    Graphics^ graphics,
    Rectangle bounds
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle

See Also

ProfessionalPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawTextCell Method

[image]

.NET ModelKit Suite ClassReference
ProfessionalPainter..::.DrawTextCell Method
ProfessionalPainter Class See Also Send Feedback
Overridden. See DrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawTextCell(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    CellBorder border,
    string text
)
Visual Basic (Declaration)
Public Overrides Sub DrawTextCell ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    border As CellBorder, _
    text As String _
)
Visual C++
public:
virtual void DrawTextCell(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    CellBorder^ border,
    String^ text
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
border
Type: PerpetuumSoft.Olap..::.CellBorder
text
Type: System..::.String

See Also

ProfessionalPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawTitle Method

[image]

.NET ModelKit Suite ClassReference
ProfessionalPainter..::.DrawTitle Method
ProfessionalPainter Class See Also Send Feedback
Overridden. See DrawTitle(Graphics, Rectangle, CellStyle, String).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawTitle(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    string text
)
Visual Basic (Declaration)
Public Overrides Sub DrawTitle ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    text As String _
)
Visual C++
public:
virtual void DrawTitle(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    String^ text
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
text
Type: System..::.String

See Also

ProfessionalPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
ProfessionalPainter..::.ToString Method
ProfessionalPainter Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

ProfessionalPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ProfessionalPainter Properties

[image] [image]

.NET ModelKit Suite ClassReference
ProfessionalPainter Properties
ProfessionalPainter Class See Also Send Feedback

The ProfessionalPainter type exposes the following members.

Properties

Name | Description
BackgroundColor | Gets or sets Color
BorderColor | Gets or sets Color
HighlightColor | Gets or sets Color

See Also

ProfessionalPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


BackgroundColor Property

[image]

.NET ModelKit Suite ClassReference
ProfessionalPainter..::.BackgroundColor Property
ProfessionalPainter Class See Also Send Feedback
Gets or sets Color

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Color BackgroundColor { get; set; }
Visual Basic (Declaration)
Public Property BackgroundColor As Color
Visual C++
public:
property Color BackgroundColor {
    Color get ();
    void set (Color value);
}

See Also

ProfessionalPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


BorderColor Property

[image]

.NET ModelKit Suite ClassReference
ProfessionalPainter..::.BorderColor Property
ProfessionalPainter Class See Also Send Feedback
Gets or sets Color

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Color BorderColor { get; set; }
Visual Basic (Declaration)
Public Property BorderColor As Color
Visual C++
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}

See Also

ProfessionalPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


HighlightColor Property

[image]

.NET ModelKit Suite ClassReference
ProfessionalPainter..::.HighlightColor Property
ProfessionalPainter Class See Also Send Feedback
Gets or sets Color

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public Color HighlightColor { get; set; }
Visual Basic (Declaration)
Public Property HighlightColor As Color
Visual C++
public:
property Color HighlightColor {
    Color get ();
    void set (Color value);
}

See Also

ProfessionalPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


SmoothPainter Class

[image]

.NET ModelKit Suite ClassReference
SmoothPainter Class
Members See Also Send Feedback
Represents the object used for pivot table drawing in smooth style.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class SmoothPainter : Painter
Visual Basic (Declaration)
Public Class SmoothPainter _
    Inherits Painter
Visual C++
public ref class SmoothPainter : public Painter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.Painter
PerpetuumSoft.Olap.Windows.Forms..::.SmoothPainter

See Also

SmoothPainter Members
PerpetuumSoft.Olap.Windows.Forms Namespace


SmoothPainter Members

[image] [image]

.NET ModelKit Suite ClassReference
SmoothPainter Members
SmoothPainter Class Constructors Methods See Also Send Feedback

The SmoothPainter type exposes the following members.

Constructors

Name | Description
SmoothPainter | Initializes a new instance of the SmoothPainter class.

Methods

Name | Description
DrawCollapseButton | Overridden. See DrawCollapseButton(Graphics, Rectangle, Boolean). (Overrides Painter..::.DrawCollapseButton(Graphics, Rectangle, Boolean).)
DrawDimensionCell | Overridden. See DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point). (Overrides Painter..::.DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point).)
DrawDropButton | Overridden. See DrawDropButton(Graphics, Rectangle, ControlState, Boolean). (Overrides Painter..::.DrawDropButton(Graphics, Rectangle, ControlState, Boolean).)
DrawFieldCaption | Overridden. See DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size). (Overrides Painter..::.DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size).)
DrawProgressCell | Overridden. See DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double). (Overrides Painter..::.DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double).)
DrawShiftButton | Overridden. See DrawShiftButton(Graphics, Rectangle, Direction). (Overrides Painter..::.DrawShiftButton(Graphics, Rectangle, Direction).)
DrawSplitterLine | Overridden. See DrawSplitterLine(Graphics, Rectangle). (Overrides Painter..::.DrawSplitterLine(Graphics, Rectangle).)
DrawTextCell | Overridden. See DrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String). (Overrides PainterDrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String).)
DrawTitle | Overridden. See DrawTitle(Graphics, Rectangle, CellStyle, String). (Overrides Painter..::.DrawTitle(Graphics, Rectangle, CellStyle, String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCaptionStringWidth | Returns the string width in pixels. (Inherited from Painter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

SmoothPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


SmoothPainter Constructor

[image]

.NET ModelKit Suite ClassReference
SmoothPainter Constructor
SmoothPainter Class See Also Send Feedback
Initializes a new instance of the SmoothPainter class.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public SmoothPainter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SmoothPainter()

See Also

SmoothPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


SmoothPainter Methods

[image] [image]

.NET ModelKit Suite ClassReference
SmoothPainter Methods
SmoothPainter Class See Also Send Feedback

The SmoothPainter type exposes the following members.

Methods

Name | Description
DrawCollapseButton | Overridden. See DrawCollapseButton(Graphics, Rectangle, Boolean). (Overrides Painter..::.DrawCollapseButton(Graphics, Rectangle, Boolean).)
DrawDimensionCell | Overridden. See DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point). (Overrides Painter..::.DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point).)
DrawDropButton | Overridden. See DrawDropButton(Graphics, Rectangle, ControlState, Boolean). (Overrides Painter..::.DrawDropButton(Graphics, Rectangle, ControlState, Boolean).)
DrawFieldCaption | Overridden. See DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size). (Overrides Painter..::.DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size).)
DrawProgressCell | Overridden. See DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double). (Overrides Painter..::.DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double).)
DrawShiftButton | Overridden. See DrawShiftButton(Graphics, Rectangle, Direction). (Overrides Painter..::.DrawShiftButton(Graphics, Rectangle, Direction).)
DrawSplitterLine | Overridden. See DrawSplitterLine(Graphics, Rectangle). (Overrides Painter..::.DrawSplitterLine(Graphics, Rectangle).)
DrawTextCell | Overridden. See DrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String). (Overrides PainterDrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String).)
DrawTitle | Overridden. See DrawTitle(Graphics, Rectangle, CellStyle, String). (Overrides Painter..::.DrawTitle(Graphics, Rectangle, CellStyle, String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCaptionStringWidth | Returns the string width in pixels. (Inherited from Painter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

SmoothPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawCollapseButton Method

[image]

.NET ModelKit Suite ClassReference
SmoothPainter..::.DrawCollapseButton Method
SmoothPainter Class See Also Send Feedback
Overridden. See DrawCollapseButton(Graphics, Rectangle, Boolean).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawCollapseButton(
    Graphics graphics,
    Rectangle bounds,
    bool isCollapse
)
Visual Basic (Declaration)
Public Overrides Sub DrawCollapseButton ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    isCollapse As Boolean _
)
Visual C++
public:
virtual void DrawCollapseButton(
    Graphics^ graphics,
    Rectangle bounds,
    bool isCollapse
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
isCollapse
Type: System..::.Boolean

See Also

SmoothPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawDimensionCell Method

[image]

.NET ModelKit Suite ClassReference
SmoothPainter..::.DrawDimensionCell Method
SmoothPainter Class See Also Send Feedback
Overridden. See DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawDimensionCell(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    CellBorder border,
    string text,
    Point startDrawPosition
)
Visual Basic (Declaration)
Public Overrides Sub DrawDimensionCell ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    border As CellBorder, _
    text As String, _
    startDrawPosition As Point _
)
Visual C++
public:
virtual void DrawDimensionCell(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    CellBorder^ border,
    String^ text,
    Point startDrawPosition
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
border
Type: PerpetuumSoft.Olap..::.CellBorder
text
Type: System..::.String
startDrawPosition
Type: System.Drawing..::.Point

See Also

SmoothPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawDropButton Method

[image]

.NET ModelKit Suite ClassReference
SmoothPainter..::.DrawDropButton Method
SmoothPainter Class See Also Send Feedback
Overridden. See DrawDropButton(Graphics, Rectangle, ControlState, Boolean).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawDropButton(
    Graphics graphics,
    Rectangle bounds,
    ControlState state,
    bool select
)
Visual Basic (Declaration)
Public Overrides Sub DrawDropButton ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    state As ControlState, _
    select As Boolean _
)
Visual C++
public:
virtual void DrawDropButton(
    Graphics^ graphics,
    Rectangle bounds,
    ControlState state,
    bool select
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
state
Type: PerpetuumSoft.Olap..::.ControlState
select
Type: System..::.Boolean

See Also

SmoothPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawFieldCaption Method

[image]

.NET ModelKit Suite ClassReference
SmoothPainter..::.DrawFieldCaption Method
SmoothPainter Class See Also Send Feedback
Overridden. See DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawFieldCaption(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    CellBorder border,
    ControlState state,
    SortOrder sortOrder,
    bool enabledSort,
    string text,
    Size clientSize
)
Visual Basic (Declaration)
Public Overrides Sub DrawFieldCaption ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    border As CellBorder, _
    state As ControlState, _
    sortOrder As SortOrder, _
    enabledSort As Boolean, _
    text As String, _
    clientSize As Size _
)
Visual C++
public:
virtual void DrawFieldCaption(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    CellBorder^ border,
    ControlState state,
    SortOrder sortOrder,
    bool enabledSort,
    String^ text,
    Size clientSize
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
border
Type: PerpetuumSoft.Olap..::.CellBorder
state
Type: PerpetuumSoft.Olap..::.ControlState
sortOrder
Type: PerpetuumSoft.Olap..::.SortOrder
enabledSort
Type: System..::.Boolean
text
Type: System..::.String
clientSize
Type: System.Drawing..::.Size

See Also

SmoothPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawProgressCell Method

[image]

.NET ModelKit Suite ClassReference
SmoothPainter..::.DrawProgressCell Method
SmoothPainter Class See Also Send Feedback
Overridden. See DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawProgressCell(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    CellBorder border,
    string text,
    double value
)
Visual Basic (Declaration)
Public Overrides Sub DrawProgressCell ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    border As CellBorder, _
    text As String, _
    value As Double _
)
Visual C++
public:
virtual void DrawProgressCell(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    CellBorder^ border,
    String^ text,
    double value
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
border
Type: PerpetuumSoft.Olap..::.CellBorder
text
Type: System..::.String
value
Type: System..::.Double

See Also

SmoothPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawShiftButton Method

[image]

.NET ModelKit Suite ClassReference
SmoothPainter..::.DrawShiftButton Method
SmoothPainter Class See Also Send Feedback
Overridden. See DrawShiftButton(Graphics, Rectangle, Direction).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawShiftButton(
    Graphics graphics,
    Rectangle bounds,
    Direction direct
)
Visual Basic (Declaration)
Public Overrides Sub DrawShiftButton ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    direct As Direction _
)
Visual C++
public:
virtual void DrawShiftButton(
    Graphics^ graphics,
    Rectangle bounds,
    Direction direct
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
direct
Type: PerpetuumSoft.Olap..::.Direction

See Also

SmoothPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawSplitterLine Method

[image]

.NET ModelKit Suite ClassReference
SmoothPainter..::.DrawSplitterLine Method
SmoothPainter Class See Also Send Feedback
Overridden. See DrawSplitterLine(Graphics, Rectangle).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawSplitterLine(
    Graphics graphics,
    Rectangle bounds
)
Visual Basic (Declaration)
Public Overrides Sub DrawSplitterLine ( _
    graphics As Graphics, _
    bounds As Rectangle _
)
Visual C++
public:
virtual void DrawSplitterLine(
    Graphics^ graphics,
    Rectangle bounds
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle

See Also

SmoothPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawTextCell Method

[image]

.NET ModelKit Suite ClassReference
SmoothPainter..::.DrawTextCell Method
SmoothPainter Class See Also Send Feedback
Overridden. See DrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawTextCell(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    CellBorder border,
    string text
)
Visual Basic (Declaration)
Public Overrides Sub DrawTextCell ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    border As CellBorder, _
    text As String _
)
Visual C++
public:
virtual void DrawTextCell(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    CellBorder^ border,
    String^ text
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
border
Type: PerpetuumSoft.Olap..::.CellBorder
text
Type: System..::.String

See Also

SmoothPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawTitle Method

[image]

.NET ModelKit Suite ClassReference
SmoothPainter..::.DrawTitle Method
SmoothPainter Class See Also Send Feedback
Overridden. See DrawTitle(Graphics, Rectangle, CellStyle, String).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawTitle(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    string text
)
Visual Basic (Declaration)
Public Overrides Sub DrawTitle ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    text As String _
)
Visual C++
public:
virtual void DrawTitle(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    String^ text
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
text
Type: System..::.String

See Also

SmoothPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
SmoothPainter..::.ToString Method
SmoothPainter Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

SmoothPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


XPPainter Class

[image]

.NET ModelKit Suite ClassReference
XPPainter Class
Members See Also Send Feedback
Represents the object used for drawing a pivot table in XP style.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public class XPPainter : Painter
Visual Basic (Declaration)
Public Class XPPainter _
    Inherits Painter
Visual C++
public ref class XPPainter : public Painter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Olap..::.Painter
PerpetuumSoft.Olap.Windows.Forms..::.XPPainter

See Also

XPPainter Members
PerpetuumSoft.Olap.Windows.Forms Namespace


XPPainter Members

[image] [image]

.NET ModelKit Suite ClassReference
XPPainter Members
XPPainter Class Constructors Methods See Also Send Feedback

The XPPainter type exposes the following members.

Constructors

Name | Description
XPPainter | Initializes a new instance of the XPPainter class.

Methods

Name | Description
DrawCollapseButton | Overridden. See DrawCollapseButton(Graphics, Rectangle, Boolean). (Overrides Painter..::.DrawCollapseButton(Graphics, Rectangle, Boolean).)
DrawDimensionCell | Overridden. See DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point). (Overrides Painter..::.DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point).)
DrawDropButton | Overridden. See DrawDropButton(Graphics, Rectangle, ControlState, Boolean). (Overrides Painter..::.DrawDropButton(Graphics, Rectangle, ControlState, Boolean).)
DrawFieldCaption | Overridden. See DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size). (Overrides Painter..::.DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size).)
DrawProgressCell | Overridden. See DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double). (Overrides Painter..::.DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double).)
DrawShiftButton | Overridden. See DrawShiftButton(Graphics, Rectangle, Direction). (Overrides Painter..::.DrawShiftButton(Graphics, Rectangle, Direction).)
DrawSplitterLine | Overridden. See DrawSplitterLine(Graphics, Rectangle). (Overrides Painter..::.DrawSplitterLine(Graphics, Rectangle).)
DrawTextCell | Overridden. See DrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String). (Overrides PainterDrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String).)
DrawTitle | Overridden. See DrawTitle(Graphics, Rectangle, CellStyle, String). (Overrides Painter..::.DrawTitle(Graphics, Rectangle, CellStyle, String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCaptionStringWidth | Returns the string width in pixels. (Inherited from Painter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

XPPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


XPPainter Constructor

[image]

.NET ModelKit Suite ClassReference
XPPainter Constructor
XPPainter Class See Also Send Feedback
Initializes a new instance of the XPPainter class.

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public XPPainter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XPPainter()

See Also

XPPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


XPPainter Methods

[image] [image]

.NET ModelKit Suite ClassReference
XPPainter Methods
XPPainter Class See Also Send Feedback

The XPPainter type exposes the following members.

Methods

Name | Description
DrawCollapseButton | Overridden. See DrawCollapseButton(Graphics, Rectangle, Boolean). (Overrides Painter..::.DrawCollapseButton(Graphics, Rectangle, Boolean).)
DrawDimensionCell | Overridden. See DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point). (Overrides Painter..::.DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point).)
DrawDropButton | Overridden. See DrawDropButton(Graphics, Rectangle, ControlState, Boolean). (Overrides Painter..::.DrawDropButton(Graphics, Rectangle, ControlState, Boolean).)
DrawFieldCaption | Overridden. See DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size). (Overrides Painter..::.DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size).)
DrawProgressCell | Overridden. See DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double). (Overrides Painter..::.DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double).)
DrawShiftButton | Overridden. See DrawShiftButton(Graphics, Rectangle, Direction). (Overrides Painter..::.DrawShiftButton(Graphics, Rectangle, Direction).)
DrawSplitterLine | Overridden. See DrawSplitterLine(Graphics, Rectangle). (Overrides Painter..::.DrawSplitterLine(Graphics, Rectangle).)
DrawTextCell | Overridden. See DrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String). (Overrides PainterDrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String).)
DrawTitle | Overridden. See DrawTitle(Graphics, Rectangle, CellStyle, String). (Overrides Painter..::.DrawTitle(Graphics, Rectangle, CellStyle, String).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCaptionStringWidth | Returns the string width in pixels. (Inherited from Painter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

XPPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawCollapseButton Method

[image]

.NET ModelKit Suite ClassReference
XPPainter..::.DrawCollapseButton Method
XPPainter Class See Also Send Feedback
Overridden. See DrawCollapseButton(Graphics, Rectangle, Boolean).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawCollapseButton(
    Graphics graphics,
    Rectangle bounds,
    bool isCollapse
)
Visual Basic (Declaration)
Public Overrides Sub DrawCollapseButton ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    isCollapse As Boolean _
)
Visual C++
public:
virtual void DrawCollapseButton(
    Graphics^ graphics,
    Rectangle bounds,
    bool isCollapse
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
isCollapse
Type: System..::.Boolean

See Also

XPPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawDimensionCell Method

[image]

.NET ModelKit Suite ClassReference
XPPainter..::.DrawDimensionCell Method
XPPainter Class See Also Send Feedback
Overridden. See DrawDimensionCell(Graphics, Rectangle, CellStyle, CellBorder, String, Point).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawDimensionCell(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    CellBorder border,
    string text,
    Point startDrawPosition
)
Visual Basic (Declaration)
Public Overrides Sub DrawDimensionCell ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    border As CellBorder, _
    text As String, _
    startDrawPosition As Point _
)
Visual C++
public:
virtual void DrawDimensionCell(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    CellBorder^ border,
    String^ text,
    Point startDrawPosition
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
border
Type: PerpetuumSoft.Olap..::.CellBorder
text
Type: System..::.String
startDrawPosition
Type: System.Drawing..::.Point

See Also

XPPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawDropButton Method

[image]

.NET ModelKit Suite ClassReference
XPPainter..::.DrawDropButton Method
XPPainter Class See Also Send Feedback
Overridden. See DrawDropButton(Graphics, Rectangle, ControlState, Boolean).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawDropButton(
    Graphics graphics,
    Rectangle bounds,
    ControlState state,
    bool select
)
Visual Basic (Declaration)
Public Overrides Sub DrawDropButton ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    state As ControlState, _
    select As Boolean _
)
Visual C++
public:
virtual void DrawDropButton(
    Graphics^ graphics,
    Rectangle bounds,
    ControlState state,
    bool select
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
state
Type: PerpetuumSoft.Olap..::.ControlState
select
Type: System..::.Boolean

See Also

XPPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawFieldCaption Method

[image]

.NET ModelKit Suite ClassReference
XPPainter..::.DrawFieldCaption Method
XPPainter Class See Also Send Feedback
Overridden. See DrawFieldCaption(Graphics, Rectangle, CellStyle, CellBorder, ControlState, SortOrder, Boolean, String, Size).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawFieldCaption(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    CellBorder border,
    ControlState state,
    SortOrder sortOrder,
    bool enabledSort,
    string text,
    Size clientSize
)
Visual Basic (Declaration)
Public Overrides Sub DrawFieldCaption ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    border As CellBorder, _
    state As ControlState, _
    sortOrder As SortOrder, _
    enabledSort As Boolean, _
    text As String, _
    clientSize As Size _
)
Visual C++
public:
virtual void DrawFieldCaption(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    CellBorder^ border,
    ControlState state,
    SortOrder sortOrder,
    bool enabledSort,
    String^ text,
    Size clientSize
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
border
Type: PerpetuumSoft.Olap..::.CellBorder
state
Type: PerpetuumSoft.Olap..::.ControlState
sortOrder
Type: PerpetuumSoft.Olap..::.SortOrder
enabledSort
Type: System..::.Boolean
text
Type: System..::.String
clientSize
Type: System.Drawing..::.Size

See Also

XPPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawProgressCell Method

[image]

.NET ModelKit Suite ClassReference
XPPainter..::.DrawProgressCell Method
XPPainter Class See Also Send Feedback
Overridden. See DrawProgressCell(Graphics, Rectangle, CellStyle, CellBorder, String, Double).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawProgressCell(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    CellBorder border,
    string text,
    double value
)
Visual Basic (Declaration)
Public Overrides Sub DrawProgressCell ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    border As CellBorder, _
    text As String, _
    value As Double _
)
Visual C++
public:
virtual void DrawProgressCell(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    CellBorder^ border,
    String^ text,
    double value
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
border
Type: PerpetuumSoft.Olap..::.CellBorder
text
Type: System..::.String
value
Type: System..::.Double

See Also

XPPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawShiftButton Method

[image]

.NET ModelKit Suite ClassReference
XPPainter..::.DrawShiftButton Method
XPPainter Class See Also Send Feedback
Overridden. See DrawShiftButton(Graphics, Rectangle, Direction).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawShiftButton(
    Graphics graphics,
    Rectangle bounds,
    Direction direct
)
Visual Basic (Declaration)
Public Overrides Sub DrawShiftButton ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    direct As Direction _
)
Visual C++
public:
virtual void DrawShiftButton(
    Graphics^ graphics,
    Rectangle bounds,
    Direction direct
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
direct
Type: PerpetuumSoft.Olap..::.Direction

See Also

XPPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawSplitterLine Method

[image]

.NET ModelKit Suite ClassReference
XPPainter..::.DrawSplitterLine Method
XPPainter Class See Also Send Feedback
Overridden. See DrawSplitterLine(Graphics, Rectangle).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawSplitterLine(
    Graphics graphics,
    Rectangle bounds
)
Visual Basic (Declaration)
Public Overrides Sub DrawSplitterLine ( _
    graphics As Graphics, _
    bounds As Rectangle _
)
Visual C++
public:
virtual void DrawSplitterLine(
    Graphics^ graphics,
    Rectangle bounds
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle

See Also

XPPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawTextCell Method

[image]

.NET ModelKit Suite ClassReference
XPPainter..::.DrawTextCell Method
XPPainter Class See Also Send Feedback
Overridden. See DrawTextCell(Graphics, Rectangle, CellStyle, CellBorder, String).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawTextCell(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    CellBorder border,
    string text
)
Visual Basic (Declaration)
Public Overrides Sub DrawTextCell ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    border As CellBorder, _
    text As String _
)
Visual C++
public:
virtual void DrawTextCell(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    CellBorder^ border,
    String^ text
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
border
Type: PerpetuumSoft.Olap..::.CellBorder
text
Type: System..::.String

See Also

XPPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


DrawTitle Method

[image]

.NET ModelKit Suite ClassReference
XPPainter..::.DrawTitle Method
XPPainter Class See Also Send Feedback
Overridden. See DrawTitle(Graphics, Rectangle, CellStyle, String).

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawTitle(
    Graphics graphics,
    Rectangle bounds,
    CellStyle cellStyle,
    string text
)
Visual Basic (Declaration)
Public Overrides Sub DrawTitle ( _
    graphics As Graphics, _
    bounds As Rectangle, _
    cellStyle As CellStyle, _
    text As String _
)
Visual C++
public:
virtual void DrawTitle(
    Graphics^ graphics,
    Rectangle bounds,
    CellStyle^ cellStyle,
    String^ text
) override

Parameters

graphics
Type: System.Drawing..::.Graphics
bounds
Type: System.Drawing..::.Rectangle
cellStyle
Type: PerpetuumSoft.Olap..::.CellStyle
text
Type: System..::.String

See Also

XPPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
XPPainter..::.ToString Method
XPPainter Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Olap.Windows.Forms
Assembly: PerpetuumSoft.Olap (in PerpetuumSoft.Olap.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

XPPainter Class
PerpetuumSoft.Olap.Windows.Forms Namespace


PerpetuumSoft.Reporting.CommandModel Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.CommandModel Namespace
Send Feedback
The PerpetuumSoft.Reporting.CommandModel namespace contains classes which represent separate operations in the templates designer.

Classes

Class | Description
AddCommand |
ChangePropertyCommand |
Command | Base class for all report designer commands.
CommandCollection | Represents the collection of Command objects.
CompositeCommand |
DeleteCommand |


AddCommand Class

[image]

.NET ModelKit Suite ClassReference
AddCommand Class
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Reporting.CommandModel.AddCommand]

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class AddCommand : Command
Visual Basic (Declaration)
Public Class AddCommand _
    Inherits Command
Visual C++
public ref class AddCommand : public Command

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.CommandModel..::.Command
PerpetuumSoft.Reporting.CommandModel..::.AddCommand

See Also

AddCommand Members
PerpetuumSoft.Reporting.CommandModel Namespace


AddCommand Members

[image] [image]

.NET ModelKit Suite ClassReference
AddCommand Members
AddCommand Class Constructors Methods See Also Send Feedback

The AddCommand type exposes the following members.

Constructors

Name | Description
AddCommand | Initializes a new instance of the AddCommand class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Redo | (Overrides Command..::.Redo()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Undo | (Overrides Command..::.Undo()()().)

See Also

AddCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


AddCommand Constructor

[image]

.NET ModelKit Suite ClassReference
AddCommand Constructor
AddCommand Class See Also Send Feedback
Initializes a new instance of the AddCommand class

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public AddCommand(
    Object target,
    IList list,
    int position
)
Visual Basic (Declaration)
Public Sub New ( _
    target As Object, _
    list As IList, _
    position As Integer _
)
Visual C++
public:
AddCommand(
    Object^ target,
    IList^ list,
    int position
)

Parameters

target
Type: System..::.Object
list
Type: System.Collections..::.IList
position
Type: System..::.Int32

See Also

AddCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


AddCommand Methods

[image] [image]

.NET ModelKit Suite ClassReference
AddCommand Methods
AddCommand Class See Also Send Feedback

The AddCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Redo | (Overrides Command..::.Redo()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Undo | (Overrides Command..::.Undo()()().)

See Also

AddCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


Redo Method

[image]

.NET ModelKit Suite ClassReference
AddCommand..::.Redo Method
AddCommand Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.CommandModel.AddCommand.Redo]

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Redo()
Visual Basic (Declaration)
Public Overrides Sub Redo
Visual C++
public:
virtual void Redo() override

See Also

AddCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


Undo Method

[image]

.NET ModelKit Suite ClassReference
AddCommand..::.Undo Method
AddCommand Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.CommandModel.AddCommand.Undo]

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Undo()
Visual Basic (Declaration)
Public Overrides Sub Undo
Visual C++
public:
virtual void Undo() override

See Also

AddCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


ChangePropertyCommand Class

[image]

.NET ModelKit Suite ClassReference
ChangePropertyCommand Class
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Reporting.CommandModel.ChangePropertyCommand]

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ChangePropertyCommand : Command
Visual Basic (Declaration)
Public Class ChangePropertyCommand _
    Inherits Command
Visual C++
public ref class ChangePropertyCommand : public Command

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.CommandModel..::.Command
PerpetuumSoft.Reporting.CommandModel..::.ChangePropertyCommand

See Also

ChangePropertyCommand Members
PerpetuumSoft.Reporting.CommandModel Namespace


ChangePropertyCommand Members

[image] [image]

.NET ModelKit Suite ClassReference
ChangePropertyCommand Members
ChangePropertyCommand Class Constructors Methods See Also Send Feedback

The ChangePropertyCommand type exposes the following members.

Constructors

Name | Description
ChangePropertyCommand | Initializes a new instance of the ChangePropertyCommand class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Redo | (Overrides Command..::.Redo()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Undo | (Overrides Command..::.Undo()()().)

See Also

ChangePropertyCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


ChangePropertyCommand Constructor

[image]

.NET ModelKit Suite ClassReference
ChangePropertyCommand Constructor
ChangePropertyCommand Class See Also Send Feedback
Initializes a new instance of the ChangePropertyCommand class

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ChangePropertyCommand(
    Object target,
    string propertyName,
    Object newValue,
    Object oldValue
)
Visual Basic (Declaration)
Public Sub New ( _
    target As Object, _
    propertyName As String, _
    newValue As Object, _
    oldValue As Object _
)
Visual C++
public:
ChangePropertyCommand(
    Object^ target,
    String^ propertyName,
    Object^ newValue,
    Object^ oldValue
)

Parameters

target
Type: System..::.Object
propertyName
Type: System..::.String
newValue
Type: System..::.Object
oldValue
Type: System..::.Object

See Also

ChangePropertyCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


ChangePropertyCommand Methods

[image] [image]

.NET ModelKit Suite ClassReference
ChangePropertyCommand Methods
ChangePropertyCommand Class See Also Send Feedback

The ChangePropertyCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Redo | (Overrides Command..::.Redo()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Undo | (Overrides Command..::.Undo()()().)

See Also

ChangePropertyCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


Redo Method

[image]

.NET ModelKit Suite ClassReference
ChangePropertyCommand..::.Redo Method
ChangePropertyCommand Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.CommandModel.ChangePropertyCommand.Redo]

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Redo()
Visual Basic (Declaration)
Public Overrides Sub Redo
Visual C++
public:
virtual void Redo() override

See Also

ChangePropertyCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


Undo Method

[image]

.NET ModelKit Suite ClassReference
ChangePropertyCommand..::.Undo Method
ChangePropertyCommand Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.CommandModel.ChangePropertyCommand.Undo]

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Undo()
Visual Basic (Declaration)
Public Overrides Sub Undo
Visual C++
public:
virtual void Undo() override

See Also

ChangePropertyCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


Command Class

[image]

.NET ModelKit Suite ClassReference
Command Class
Members See Also Send Feedback
Base class for all report designer commands.

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract class Command
Visual Basic (Declaration)
Public MustInherit Class Command
Visual C++
public ref class Command abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.CommandModel..::.Command
PerpetuumSoft.Reporting.CommandModel..::.AddCommand
PerpetuumSoft.Reporting.CommandModel..::.ChangePropertyCommand
PerpetuumSoft.Reporting.CommandModel..::.CompositeCommand
PerpetuumSoft.Reporting.CommandModel..::.DeleteCommand

See Also

Command Members
PerpetuumSoft.Reporting.CommandModel Namespace


Command Members

[image] [image]

.NET ModelKit Suite ClassReference
Command Members
Command Class Constructors Methods See Also Send Feedback

The Command type exposes the following members.

Constructors

Name | Description
Command | Initializes a new instance of the Command class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Redo | When overriden in derived class restore result of command.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Undo | When overriden in derived class undo result of this command.

See Also

Command Class
PerpetuumSoft.Reporting.CommandModel Namespace


Command Constructor

[image]

.NET ModelKit Suite ClassReference
Command Constructor
Command Class See Also Send Feedback
Initializes a new instance of the Command class

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected Command()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
Command()

See Also

Command Class
PerpetuumSoft.Reporting.CommandModel Namespace


Command Methods

[image] [image]

.NET ModelKit Suite ClassReference
Command Methods
Command Class See Also Send Feedback

The Command type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Redo | When overriden in derived class restore result of command.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Undo | When overriden in derived class undo result of this command.

See Also

Command Class
PerpetuumSoft.Reporting.CommandModel Namespace


Redo Method

[image]

.NET ModelKit Suite ClassReference
Command..::.Redo Method
Command Class See Also Send Feedback
When overriden in derived class restore result of command.

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract void Redo()
Visual Basic (Declaration)
Public MustOverride Sub Redo
Visual C++
public:
virtual void Redo() abstract

See Also

Command Class
PerpetuumSoft.Reporting.CommandModel Namespace


Undo Method

[image]

.NET ModelKit Suite ClassReference
Command..::.Undo Method
Command Class See Also Send Feedback
When overriden in derived class undo result of this command.

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract void Undo()
Visual Basic (Declaration)
Public MustOverride Sub Undo
Visual C++
public:
virtual void Undo() abstract

See Also

Command Class
PerpetuumSoft.Reporting.CommandModel Namespace


CommandCollection Class

[image]

.NET ModelKit Suite ClassReference
CommandCollection Class
Members See Also Send Feedback
Represents the collection of Command objects.

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class CommandCollection : CollectionBase
Visual Basic (Declaration)
Public Class CommandCollection _
    Inherits CollectionBase
Visual C++
public ref class CommandCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Reporting.CommandModel..::.CommandCollection

See Also

CommandCollection Members
PerpetuumSoft.Reporting.CommandModel Namespace


CommandCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
CommandCollection Members
CommandCollection Class Constructors Methods Properties See Also Send Feedback

The CommandCollection type exposes the following members.

Constructors

Name | Description
CommandCollection | Creates a new instance of CommandCollection class.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the object already exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified object's index in the collection.
Insert | Inserts the specified object to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified Command from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
RemoveRange | Removes the range of commands.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets the object at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

CommandCollection Class
PerpetuumSoft.Reporting.CommandModel Namespace


CommandCollection Constructor

[image]

.NET ModelKit Suite ClassReference
CommandCollection Constructor
CommandCollection Class See Also Send Feedback
Creates a new instance of CommandCollection class.

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public CommandCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CommandCollection()

See Also

CommandCollection Class
PerpetuumSoft.Reporting.CommandModel Namespace


CommandCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
CommandCollection Methods
CommandCollection Class See Also Send Feedback

The CommandCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the object already exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified object's index in the collection.
Insert | Inserts the specified object to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified Command from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
RemoveRange | Removes the range of commands.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CommandCollection Class
PerpetuumSoft.Reporting.CommandModel Namespace


Add Method

[image] [image]

.NET ModelKit Suite ClassReference
CommandCollection..::.Add Method
CommandCollection Class See Also Send Feedback

Overload List

Name | Description
Add(Command) | Adds the specified Command to the end of the collection.
Add(array<Command>[]()[]) | Adds the specified array Command objects to the end of the collection.

See Also

CommandCollection Class
CommandCollection Members
PerpetuumSoft.Reporting.CommandModel Namespace


Add Method (Command)

[image]

.NET ModelKit Suite ClassReference
CommandCollection..::.Add Method (Command)
CommandCollection Class See Also Send Feedback
Adds the specified Command to the end of the collection.

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Command Add(
    Command value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As Command _
) As Command
Visual C++
public:
Command^ Add(
    Command^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.CommandModel..::.Command

See Also

CommandCollection Class
Add Overload
PerpetuumSoft.Reporting.CommandModel Namespace


Add Method (Command[])

[image]

.NET ModelKit Suite ClassReference
CommandCollection..::.Add Method (array<Command>[]()[])
CommandCollection Class See Also Send Feedback
Adds the specified array Command objects to the end of the collection.

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Add(
    Command[] values
)
Visual Basic (Declaration)
Public Sub Add ( _
    values As Command() _
)
Visual C++
public:
void Add(
    array<Command^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Reporting.CommandModel..::.Command >[]()[]

See Also

CommandCollection Class
Add Overload
PerpetuumSoft.Reporting.CommandModel Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
CommandCollection..::.Contains Method
CommandCollection Class See Also Send Feedback
Returns whether the object already exists in the collection.

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    Command value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As Command _
) As Boolean
Visual C++
public:
bool Contains(
    Command^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.CommandModel..::.Command

See Also

CommandCollection Class
PerpetuumSoft.Reporting.CommandModel Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
CommandCollection..::.IndexOf Method
CommandCollection Class See Also Send Feedback
Returns the specified object's index in the collection.

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    Command value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As Command _
) As Integer
Visual C++
public:
int IndexOf(
    Command^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.CommandModel..::.Command

See Also

CommandCollection Class
PerpetuumSoft.Reporting.CommandModel Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
CommandCollection..::.Insert Method
CommandCollection Class See Also Send Feedback
Inserts the specified object to the collection at the specified index.

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    Command value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As Command _
)
Visual C++
public:
void Insert(
    int index,
    Command^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Reporting.CommandModel..::.Command

See Also

CommandCollection Class
PerpetuumSoft.Reporting.CommandModel Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
CommandCollection..::.Remove Method
CommandCollection Class See Also Send Feedback
Removes the specified Command from the collection.

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    Command value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As Command _
)
Visual C++
public:
void Remove(
    Command^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.CommandModel..::.Command

See Also

CommandCollection Class
PerpetuumSoft.Reporting.CommandModel Namespace


RemoveRange Method

[image]

.NET ModelKit Suite ClassReference
CommandCollection..::.RemoveRange Method
CommandCollection Class See Also Send Feedback
Removes the range of commands.

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void RemoveRange(
    int index,
    int count
)
Visual Basic (Declaration)
Public Sub RemoveRange ( _
    index As Integer, _
    count As Integer _
)
Visual C++
public:
void RemoveRange(
    int index,
    int count
)

Parameters

index
Type: System..::.Int32
count
Type: System..::.Int32

See Also

CommandCollection Class
PerpetuumSoft.Reporting.CommandModel Namespace


CommandCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
CommandCollection Properties
CommandCollection Class See Also Send Feedback

The CommandCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets the object at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

CommandCollection Class
PerpetuumSoft.Reporting.CommandModel Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
CommandCollection..::.Item Property
CommandCollection Class See Also Send Feedback
Gets the object at the specified index.

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Command this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Command
Visual C++
public:
property Command^ default[int index] {
    Command^ get (int index);
    void set (int index, Command^ value);
}

Parameters

index
Type: System..::.Int32

See Also

CommandCollection Class
PerpetuumSoft.Reporting.CommandModel Namespace


CompositeCommand Class

[image]

.NET ModelKit Suite ClassReference
CompositeCommand Class
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Reporting.CommandModel.CompositeCommand]

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class CompositeCommand : Command
Visual Basic (Declaration)
Public Class CompositeCommand _
    Inherits Command
Visual C++
public ref class CompositeCommand : public Command

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.CommandModel..::.Command
PerpetuumSoft.Reporting.CommandModel..::.CompositeCommand

See Also

CompositeCommand Members
PerpetuumSoft.Reporting.CommandModel Namespace


CompositeCommand Members

[image] [image]

.NET ModelKit Suite ClassReference
CompositeCommand Members
CompositeCommand Class Constructors Methods Properties See Also Send Feedback

The CompositeCommand type exposes the following members.

Constructors

Name | Description
CompositeCommand | Initializes a new instance of the CompositeCommand class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Redo | (Overrides Command..::.Redo()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Undo | (Overrides Command..::.Undo()()().)

Properties

Name | Description
Commands |

See Also

CompositeCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


CompositeCommand Constructor

[image]

.NET ModelKit Suite ClassReference
CompositeCommand Constructor
CompositeCommand Class See Also Send Feedback
Initializes a new instance of the CompositeCommand class

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public CompositeCommand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompositeCommand()

See Also

CompositeCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


CompositeCommand Methods

[image] [image]

.NET ModelKit Suite ClassReference
CompositeCommand Methods
CompositeCommand Class See Also Send Feedback

The CompositeCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Redo | (Overrides Command..::.Redo()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Undo | (Overrides Command..::.Undo()()().)

See Also

CompositeCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


Redo Method

[image]

.NET ModelKit Suite ClassReference
CompositeCommand..::.Redo Method
CompositeCommand Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.CommandModel.CompositeCommand.Redo]

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Redo()
Visual Basic (Declaration)
Public Overrides Sub Redo
Visual C++
public:
virtual void Redo() override

See Also

CompositeCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


Undo Method

[image]

.NET ModelKit Suite ClassReference
CompositeCommand..::.Undo Method
CompositeCommand Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.CommandModel.CompositeCommand.Undo]

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Undo()
Visual Basic (Declaration)
Public Overrides Sub Undo
Visual C++
public:
virtual void Undo() override

See Also

CompositeCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


CompositeCommand Properties

[image] [image]

.NET ModelKit Suite ClassReference
CompositeCommand Properties
CompositeCommand Class See Also Send Feedback

The CompositeCommand type exposes the following members.

Properties

Name | Description
Commands |

See Also

CompositeCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


Commands Property

[image]

.NET ModelKit Suite ClassReference
CompositeCommand..::.Commands Property
CompositeCommand Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.CommandModel.CompositeCommand.Commands]

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public CommandCollection Commands { get; }
Visual Basic (Declaration)
Public ReadOnly Property Commands As CommandCollection
Visual C++
public:
property CommandCollection^ Commands {
    CommandCollection^ get ();
}

See Also

CompositeCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


DeleteCommand Class

[image]

.NET ModelKit Suite ClassReference
DeleteCommand Class
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Reporting.CommandModel.DeleteCommand]

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DeleteCommand : Command
Visual Basic (Declaration)
Public Class DeleteCommand _
    Inherits Command
Visual C++
public ref class DeleteCommand : public Command

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.CommandModel..::.Command
PerpetuumSoft.Reporting.CommandModel..::.DeleteCommand

See Also

DeleteCommand Members
PerpetuumSoft.Reporting.CommandModel Namespace


DeleteCommand Members

[image] [image]

.NET ModelKit Suite ClassReference
DeleteCommand Members
DeleteCommand Class Constructors Methods See Also Send Feedback

The DeleteCommand type exposes the following members.

Constructors

Name | Description
DeleteCommand | Initializes a new instance of the DeleteCommand class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Redo | (Overrides Command..::.Redo()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Undo | (Overrides Command..::.Undo()()().)

See Also

DeleteCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


DeleteCommand Constructor

[image]

.NET ModelKit Suite ClassReference
DeleteCommand Constructor
DeleteCommand Class See Also Send Feedback
Initializes a new instance of the DeleteCommand class

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DeleteCommand(
    Object target,
    IList list,
    int position
)
Visual Basic (Declaration)
Public Sub New ( _
    target As Object, _
    list As IList, _
    position As Integer _
)
Visual C++
public:
DeleteCommand(
    Object^ target,
    IList^ list,
    int position
)

Parameters

target
Type: System..::.Object
list
Type: System.Collections..::.IList
position
Type: System..::.Int32

See Also

DeleteCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


DeleteCommand Methods

[image] [image]

.NET ModelKit Suite ClassReference
DeleteCommand Methods
DeleteCommand Class See Also Send Feedback

The DeleteCommand type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Redo | (Overrides Command..::.Redo()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Undo | (Overrides Command..::.Undo()()().)

See Also

DeleteCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


Redo Method

[image]

.NET ModelKit Suite ClassReference
DeleteCommand..::.Redo Method
DeleteCommand Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.CommandModel.DeleteCommand.Redo]

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Redo()
Visual Basic (Declaration)
Public Overrides Sub Redo
Visual C++
public:
virtual void Redo() override

See Also

DeleteCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


Undo Method

[image]

.NET ModelKit Suite ClassReference
DeleteCommand..::.Undo Method
DeleteCommand Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.CommandModel.DeleteCommand.Undo]

Namespace: PerpetuumSoft.Reporting.CommandModel
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Undo()
Visual Basic (Declaration)
Public Overrides Sub Undo
Visual C++
public:
virtual void Undo() override

See Also

DeleteCommand Class
PerpetuumSoft.Reporting.CommandModel Namespace


PerpetuumSoft.Reporting.Components Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Components Namespace
Send Feedback
The PerpetuumSoft.Reporting.Components namespace contains classes and components which are used for reports generation.

Classes

Class | Description
ErrorEventArgs | Provides data for ShowError and HandleException events.
FileReportSlot | Represents report source saved in a file.
GetAvailableTemplateNamesEventArgs | Represents names of available templates
GetReportParameterEventArgs | Provides data for the GetReportParameter event.
HyperlinkEventArgs | Provides data for Hyperlink click events.
InlineReportSlot | Represents report source saved in a string.
ObjectPointerCollection | Represents a collection of associated String keys and Object values. Manages the list of data sources in report.
RenderingErrorEventArgs | Represents the information on the rendering error.
ReportBase | Base class for all Report components in the library. Provides basic logic for working with final documents.
ReportGenerator | Obsolete. Defines the central component that provides interaction between all parts of Report Sharp-Shooter. It integrates the report template, rendering of the final document, runs the report template designer etc.
ReportManager | Contains reports collection and datasources collection.
ReportPrintDocument | Provides document printing.
ReportSlot | Represents base class for report sources.
ReportSlotCollection | Represents collection of ReportSlots.
ResolveDataSourceEventArgs | Provides data for the ResolveDataSource event.
ResolveSubReportEventArgs | Provides data for the ResolveSubReport event.
ResolveSubReportSourceEventArgs |
UrlReportSlot | Represents report source read from a specific URL.

Interfaces

Interface | Description
IReportSource | Provides functionality to report sources.

Delegates

Delegate | Description
ErrorEventHandler | Represents method that will handle ShowError and HandleException events.
GetAvailableTemplateNamesEventHandler | Occurs when it is necessary to get names of available templates
GetReportParameterEventHandler | Represents method that will handle the GetReportParameter event.
HyperlinkEventHandler | Represents method that will handle the HyperlinkClick event.
ResolveDataSourceEventHandler | Represents method that will handle the ResolveDataSource event.
ResolveSubReportEventHandler | Represents method that will handle the ResolveSubReport event.
ResolveSubReportSourceEventHandler |
ShowProgressDelegate | Represents method that will handle the ShowProgress event.


ErrorEventArgs Class

[image]

.NET ModelKit Suite ClassReference
ErrorEventArgs Class
Members See Also Send Feedback
Provides data for ShowError and HandleException events.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ErrorEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ErrorEventArgs _
    Inherits EventArgs
Visual C++
public ref class ErrorEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.Components..::.ErrorEventArgs

See Also

ErrorEventArgs Members
PerpetuumSoft.Reporting.Components Namespace


ErrorEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
ErrorEventArgs Members
ErrorEventArgs Class Constructors Methods Properties See Also Send Feedback

The ErrorEventArgs type exposes the following members.

Constructors

Name | Description
ErrorEventArgs | Initializes a new instance of the ErrorEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Exception | Gets thrown exception.
ExceptionMode | Gets or sets mode of exception handling
Handled | Gets or sets a value indicating whether the exception should be handled.

See Also

ErrorEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


ErrorEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
ErrorEventArgs Constructor
ErrorEventArgs Class See Also Send Feedback
Initializes a new instance of the ErrorEventArgs class.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ErrorEventArgs(
    Exception e
)
Visual Basic (Declaration)
Public Sub New ( _
    e As Exception _
)
Visual C++
public:
ErrorEventArgs(
    Exception^ e
)

Parameters

e
Type: System..::.Exception

See Also

ErrorEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


ErrorEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
ErrorEventArgs Methods
ErrorEventArgs Class See Also Send Feedback

The ErrorEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ErrorEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


ErrorEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
ErrorEventArgs Properties
ErrorEventArgs Class See Also Send Feedback

The ErrorEventArgs type exposes the following members.

Properties

Name | Description
Exception | Gets thrown exception.
ExceptionMode | Gets or sets mode of exception handling
Handled | Gets or sets a value indicating whether the exception should be handled.

See Also

ErrorEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


Exception Property

[image]

.NET ModelKit Suite ClassReference
ErrorEventArgs..::.Exception Property
ErrorEventArgs Class See Also Send Feedback
Gets thrown exception.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Exception Exception { get; }
Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
Visual C++
public:
property Exception^ Exception {
    Exception^ get ();
}

See Also

ErrorEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


ExceptionMode Property

[image]

.NET ModelKit Suite ClassReference
ErrorEventArgs..::.ExceptionMode Property
ErrorEventArgs Class See Also Send Feedback
Gets or sets mode of exception handling

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ExceptionMode ExceptionMode { get; set; }
Visual Basic (Declaration)
Public Property ExceptionMode As ExceptionMode
Visual C++
public:
property ExceptionMode ExceptionMode {
    ExceptionMode get ();
    void set (ExceptionMode value);
}

See Also

ErrorEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


Handled Property

[image]

.NET ModelKit Suite ClassReference
ErrorEventArgs..::.Handled Property
ErrorEventArgs Class See Also Send Feedback
Gets or sets a value indicating whether the exception should be handled.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Handled { get; set; }
Visual Basic (Declaration)
Public Property Handled As Boolean
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

See Also

ErrorEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


ErrorEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
ErrorEventHandler Delegate
See Also Send Feedback
Represents method that will handle ShowError and HandleException events.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate void ErrorEventHandler(
    Object sender,
    ErrorEventArgs args
)
Visual Basic (Declaration)
Public Delegate Sub ErrorEventHandler ( _
    sender As Object, _
    args As ErrorEventArgs _
)
Visual C++
public delegate void ErrorEventHandler(
    Object^ sender,
    ErrorEventArgs^ args
)

Parameters

sender
Type: System..::.Object
args
Type: PerpetuumSoft.Reporting.Components..::.ErrorEventArgs

See Also

PerpetuumSoft.Reporting.Components Namespace


FileReportSlot Class

[image]

.NET ModelKit Suite ClassReference
FileReportSlot Class
Members See Also Send Feedback
Represents report source saved in a file.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class FileReportSlot : ReportSlot
Visual Basic (Declaration)
Public Class FileReportSlot _
    Inherits ReportSlot
Visual C++
public ref class FileReportSlot : public ReportSlot

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Components..::.ReportSlot
PerpetuumSoft.Reporting.Components..::.FileReportSlot

See Also

FileReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


FileReportSlot Members

[image] [image]

.NET ModelKit Suite ClassReference
FileReportSlot Members
FileReportSlot Class Constructors Methods Properties Events See Also Send Feedback

The FileReportSlot type exposes the following members.

Constructors

Name | Description
FileReportSlot | Overloaded.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DesignTemplate | Runs report designer and opens a document corresponding to the given ReportSlot in it. (Inherited from ReportSlot.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
LoadReport | Overridden. See LoadReport()()(). (Overrides ReportSlot..::.LoadReport()()().)
MemberwiseClone | Overloaded.
OnGetReportParameter | Implements OnGetReportParameter(GetReportParameterEventArgs). (Inherited from ReportSlot.)
OnHyperlinkClick | Implements OnHyperlinkClick(HyperlinkEventArgs). (Inherited from ReportSlot.)
OnRenderCanceled | Implements OnRenderCanceled(EventArgs). (Inherited from ReportSlot.)
OnRenderingError | Implements OnRenderingError(RenderingErrorEventArgs). (Inherited from ReportSlot.)
Prepare | Overloaded.
RenderDocument | Overloaded.
SaveReport | Overridden. See SaveReport(Document). (Overrides ReportSlot..::.SaveReport(Document).)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Document | Implements Document. (Inherited from ReportSlot.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExceptionMode | Gets or sets exception mode for ReportSlot. (Inherited from ReportSlot.)
FilePath | Gets or sets path to a file containing report source.
Manager | Gets manager for ReportSlot. (Inherited from ReportSlot.)
ReportName | Gets or sets report name. (Inherited from ReportSlot.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StyleSheet | Gets or sets ReportSlot styles. (Inherited from ReportSlot.)
SupportsSaving | Overridden. See SupportsSaving. (Overrides ReportSlot..::.SupportsSaving.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
GetReportParameter | Implements GetReportParameter. (Inherited from ReportSlot.)
HyperlinkClick | Implements HyperlinkClick. (Inherited from ReportSlot.)
RenderCanceled | Occurs when rendering has been canceled (Inherited from ReportSlot.)
RenderCompleted | Implements RenderCompleted. (Inherited from ReportSlot.)
RenderingError | Occurs when the rendering is completed with an error. (Inherited from ReportSlot.)

See Also

FileReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


FileReportSlot Constructor

[image] [image]

.NET ModelKit Suite ClassReference
FileReportSlot Constructor
FileReportSlot Class See Also Send Feedback

Overload List

Name | Description
FileReportSlot()()() | Initializes a new instance of the FileReportSlot class.
FileReportSlot(IContainer) | Initializes a new instance of the FileReportSlot class.

See Also

FileReportSlot Class
FileReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


FileReportSlot Constructor

[image]

.NET ModelKit Suite ClassReference
FileReportSlot Constructor
FileReportSlot Class See Also Send Feedback
Initializes a new instance of the FileReportSlot class.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FileReportSlot()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FileReportSlot()

See Also

FileReportSlot Class
FileReportSlot Overload
PerpetuumSoft.Reporting.Components Namespace


FileReportSlot Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
FileReportSlot Constructor (IContainer)
FileReportSlot Class See Also Send Feedback
Initializes a new instance of the FileReportSlot class.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FileReportSlot(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
FileReportSlot(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

FileReportSlot Class
FileReportSlot Overload
PerpetuumSoft.Reporting.Components Namespace


FileReportSlot Methods

[image] [image]

.NET ModelKit Suite ClassReference
FileReportSlot Methods
FileReportSlot Class See Also Send Feedback

The FileReportSlot type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DesignTemplate | Runs report designer and opens a document corresponding to the given ReportSlot in it. (Inherited from ReportSlot.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
LoadReport | Overridden. See LoadReport()()(). (Overrides ReportSlot..::.LoadReport()()().)
MemberwiseClone | Overloaded.
OnGetReportParameter | Implements OnGetReportParameter(GetReportParameterEventArgs). (Inherited from ReportSlot.)
OnHyperlinkClick | Implements OnHyperlinkClick(HyperlinkEventArgs). (Inherited from ReportSlot.)
OnRenderCanceled | Implements OnRenderCanceled(EventArgs). (Inherited from ReportSlot.)
OnRenderingError | Implements OnRenderingError(RenderingErrorEventArgs). (Inherited from ReportSlot.)
Prepare | Overloaded.
RenderDocument | Overloaded.
SaveReport | Overridden. See SaveReport(Document). (Overrides ReportSlot..::.SaveReport(Document).)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

FileReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
FileReportSlot..::.Dispose Method
FileReportSlot Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

FileReportSlot Class
FileReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


LoadReport Method

[image]

.NET ModelKit Suite ClassReference
FileReportSlot..::.LoadReport Method
FileReportSlot Class See Also Send Feedback
Overridden. See LoadReport()()().

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override Document LoadReport()
Visual Basic (Declaration)
Public Overrides Function LoadReport As Document
Visual C++
public:
virtual Document^ LoadReport() override

See Also

FileReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
FileReportSlot..::.MemberwiseClone Method
FileReportSlot Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

FileReportSlot Class
FileReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


Prepare Method

[image] [image]

.NET ModelKit Suite ClassReference
FileReportSlot..::.Prepare Method
FileReportSlot Class See Also Send Feedback

Overload List

Name | Description
Prepare()()() | Implements Prepare()()(). (Inherited from ReportSlot.)
Prepare(IRenderSite) | Implements ['M:PerpetuumSoft.Reporting.Components.IReportSource.Prepare()]. (Inherited from ReportSlot.)

See Also

FileReportSlot Class
FileReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


RenderDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
FileReportSlot..::.RenderDocument Method
FileReportSlot Class See Also Send Feedback

Overload List

Name | Description
RenderDocument()()() | Implements RenderDocument()()(). (Inherited from ReportSlot.)
RenderDocument(IRenderSite) | Implements ['M:PerpetuumSoft.Reporting.Components.IReportSource.RenderDocument(PerpetuumSoft.Reporting.Rendering.IRenderSite)]. (Inherited from ReportSlot.)

See Also

FileReportSlot Class
FileReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


SaveReport Method

[image]

.NET ModelKit Suite ClassReference
FileReportSlot..::.SaveReport Method
FileReportSlot Class See Also Send Feedback
Overridden. See SaveReport(Document).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void SaveReport(
    Document document
)
Visual Basic (Declaration)
Public Overrides Sub SaveReport ( _
    document As Document _
)
Visual C++
public:
virtual void SaveReport(
    Document^ document
) override

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document

See Also

FileReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


FileReportSlot Properties

[image] [image]

.NET ModelKit Suite ClassReference
FileReportSlot Properties
FileReportSlot Class See Also Send Feedback

The FileReportSlot type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Document | Implements Document. (Inherited from ReportSlot.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExceptionMode | Gets or sets exception mode for ReportSlot. (Inherited from ReportSlot.)
FilePath | Gets or sets path to a file containing report source.
Manager | Gets manager for ReportSlot. (Inherited from ReportSlot.)
ReportName | Gets or sets report name. (Inherited from ReportSlot.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StyleSheet | Gets or sets ReportSlot styles. (Inherited from ReportSlot.)
SupportsSaving | Overridden. See SupportsSaving. (Overrides ReportSlot..::.SupportsSaving.)

See Also

FileReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


FilePath Property

[image]

.NET ModelKit Suite ClassReference
FileReportSlot..::.FilePath Property
FileReportSlot Class See Also Send Feedback
Gets or sets path to a file containing report source.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string FilePath { get; set; }
Visual Basic (Declaration)
Public Property FilePath As String
Visual C++
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

See Also

FileReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


SupportsSaving Property

[image]

.NET ModelKit Suite ClassReference
FileReportSlot..::.SupportsSaving Property
FileReportSlot Class See Also Send Feedback
Overridden. See SupportsSaving.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool SupportsSaving { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property SupportsSaving As Boolean
Visual C++
public:
virtual property bool SupportsSaving {
    bool get () override;
}

See Also

FileReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


FileReportSlot Events

[image] [image]

.NET ModelKit Suite ClassReference
FileReportSlot Events
FileReportSlot Class See Also Send Feedback

The FileReportSlot type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
GetReportParameter | Implements GetReportParameter. (Inherited from ReportSlot.)
HyperlinkClick | Implements HyperlinkClick. (Inherited from ReportSlot.)
RenderCanceled | Occurs when rendering has been canceled (Inherited from ReportSlot.)
RenderCompleted | Implements RenderCompleted. (Inherited from ReportSlot.)
RenderingError | Occurs when the rendering is completed with an error. (Inherited from ReportSlot.)

See Also

FileReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


GetAvailableTemplateNamesEventArgs Class

[image]

.NET ModelKit Suite ClassReference
GetAvailableTemplateNamesEventArgs Class
Members See Also Send Feedback
Represents names of available templates

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class GetAvailableTemplateNamesEventArgs : EventArgs
Visual Basic (Declaration)
Public Class GetAvailableTemplateNamesEventArgs _
    Inherits EventArgs
Visual C++
public ref class GetAvailableTemplateNamesEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.Components..::.GetAvailableTemplateNamesEventArgs

See Also

GetAvailableTemplateNamesEventArgs Members
PerpetuumSoft.Reporting.Components Namespace


GetAvailableTemplateNamesEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
GetAvailableTemplateNamesEventArgs Members
GetAvailableTemplateNamesEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetAvailableTemplateNamesEventArgs type exposes the following members.

Constructors

Name | Description
GetAvailableTemplateNamesEventArgs | Initializes a new instance of the GetAvailableTemplateNamesEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TemplateNames | Gets collection template names

See Also

GetAvailableTemplateNamesEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


GetAvailableTemplateNamesEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
GetAvailableTemplateNamesEventArgs Constructor
GetAvailableTemplateNamesEventArgs Class See Also Send Feedback
Initializes a new instance of the GetAvailableTemplateNamesEventArgs class.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public GetAvailableTemplateNamesEventArgs(
    StringCollection templateNames
)
Visual Basic (Declaration)
Public Sub New ( _
    templateNames As StringCollection _
)
Visual C++
public:
GetAvailableTemplateNamesEventArgs(
    StringCollection^ templateNames
)

Parameters

templateNames
Type: System.Collections.Specialized..::.StringCollection

See Also

GetAvailableTemplateNamesEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


GetAvailableTemplateNamesEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
GetAvailableTemplateNamesEventArgs Methods
GetAvailableTemplateNamesEventArgs Class See Also Send Feedback

The GetAvailableTemplateNamesEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetAvailableTemplateNamesEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


GetAvailableTemplateNamesEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
GetAvailableTemplateNamesEventArgs Properties
GetAvailableTemplateNamesEventArgs Class See Also Send Feedback

The GetAvailableTemplateNamesEventArgs type exposes the following members.

Properties

Name | Description
TemplateNames | Gets collection template names

See Also

GetAvailableTemplateNamesEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


TemplateNames Property

[image]

.NET ModelKit Suite ClassReference
GetAvailableTemplateNamesEventArgs..::.TemplateNames Property
GetAvailableTemplateNamesEventArgs Class See Also Send Feedback
Gets collection template names

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public StringCollection TemplateNames { get; }
Visual Basic (Declaration)
Public ReadOnly Property TemplateNames As StringCollection
Visual C++
public:
property StringCollection^ TemplateNames {
    StringCollection^ get ();
}

See Also

GetAvailableTemplateNamesEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


GetAvailableTemplateNamesEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
GetAvailableTemplateNamesEventHandler Delegate
See Also Send Feedback
Occurs when it is necessary to get names of available templates

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate void GetAvailableTemplateNamesEventHandler(
    Object sender,
    GetAvailableTemplateNamesEventArgs args
)
Visual Basic (Declaration)
Public Delegate Sub GetAvailableTemplateNamesEventHandler ( _
    sender As Object, _
    args As GetAvailableTemplateNamesEventArgs _
)
Visual C++
public delegate void GetAvailableTemplateNamesEventHandler(
    Object^ sender,
    GetAvailableTemplateNamesEventArgs^ args
)

Parameters

sender
Type: System..::.Object
args
Type: PerpetuumSoft.Reporting.Components..::.GetAvailableTemplateNamesEventArgs

See Also

PerpetuumSoft.Reporting.Components Namespace


GetReportParameterEventArgs Class

[image]

.NET ModelKit Suite ClassReference
GetReportParameterEventArgs Class
Members See Also Send Feedback
Provides data for the GetReportParameter event.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class GetReportParameterEventArgs : EventArgs
Visual Basic (Declaration)
Public Class GetReportParameterEventArgs _
    Inherits EventArgs
Visual C++
public ref class GetReportParameterEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.Components..::.GetReportParameterEventArgs

See Also

GetReportParameterEventArgs Members
PerpetuumSoft.Reporting.Components Namespace


GetReportParameterEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
GetReportParameterEventArgs Members
GetReportParameterEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetReportParameterEventArgs type exposes the following members.

Constructors

Name | Description
GetReportParameterEventArgs | Initializes a new instance of the GetReportParameterEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Parameters | Gets parameters collection.
TemplateName | Gets template name.

See Also

GetReportParameterEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


GetReportParameterEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
GetReportParameterEventArgs Constructor
GetReportParameterEventArgs Class See Also Send Feedback
Initializes a new instance of the GetReportParameterEventArgs class.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public GetReportParameterEventArgs(
    string templateName,
    ParameterCollection parameters
)
Visual Basic (Declaration)
Public Sub New ( _
    templateName As String, _
    parameters As ParameterCollection _
)
Visual C++
public:
GetReportParameterEventArgs(
    String^ templateName,
    ParameterCollection^ parameters
)

Parameters

templateName
Type: System..::.String
parameters
Type: PerpetuumSoft.Reporting.DOM..::.ParameterCollection

See Also

GetReportParameterEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


GetReportParameterEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
GetReportParameterEventArgs Methods
GetReportParameterEventArgs Class See Also Send Feedback

The GetReportParameterEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetReportParameterEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


GetReportParameterEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
GetReportParameterEventArgs Properties
GetReportParameterEventArgs Class See Also Send Feedback

The GetReportParameterEventArgs type exposes the following members.

Properties

Name | Description
Parameters | Gets parameters collection.
TemplateName | Gets template name.

See Also

GetReportParameterEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


Parameters Property

[image]

.NET ModelKit Suite ClassReference
GetReportParameterEventArgs..::.Parameters Property
GetReportParameterEventArgs Class See Also Send Feedback
Gets parameters collection.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ParameterCollection Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterCollection
Visual C++
public:
property ParameterCollection^ Parameters {
    ParameterCollection^ get ();
}

See Also

GetReportParameterEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


TemplateName Property

[image]

.NET ModelKit Suite ClassReference
GetReportParameterEventArgs..::.TemplateName Property
GetReportParameterEventArgs Class See Also Send Feedback
Gets template name.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string TemplateName { get; }
Visual Basic (Declaration)
Public ReadOnly Property TemplateName As String
Visual C++
public:
property String^ TemplateName {
    String^ get ();
}

See Also

GetReportParameterEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


GetReportParameterEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
GetReportParameterEventHandler Delegate
See Also Send Feedback
Represents method that will handle the GetReportParameter event.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate void GetReportParameterEventHandler(
    Object sender,
    GetReportParameterEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub GetReportParameterEventHandler ( _
    sender As Object, _
    e As GetReportParameterEventArgs _
)
Visual C++
public delegate void GetReportParameterEventHandler(
    Object^ sender,
    GetReportParameterEventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: PerpetuumSoft.Reporting.Components..::.GetReportParameterEventArgs

See Also

PerpetuumSoft.Reporting.Components Namespace


HyperlinkEventArgs Class

[image]

.NET ModelKit Suite ClassReference
HyperlinkEventArgs Class
Members See Also Send Feedback
Provides data for Hyperlink click events.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class HyperlinkEventArgs : EventArgs
Visual Basic (Declaration)
Public Class HyperlinkEventArgs _
    Inherits EventArgs
Visual C++
public ref class HyperlinkEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.Components..::.HyperlinkEventArgs

See Also

HyperlinkEventArgs Members
PerpetuumSoft.Reporting.Components Namespace


HyperlinkEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
HyperlinkEventArgs Members
HyperlinkEventArgs Class Constructors Methods Properties See Also Send Feedback

The HyperlinkEventArgs type exposes the following members.

Constructors

Name | Description
HyperlinkEventArgs | Constructor for HyperlinkEventArgs object.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Handled | Gets or sets the value indicating whether the hyperlink event was handled.
Hyperlink | Gets the hyperlink string.

See Also

HyperlinkEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


HyperlinkEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
HyperlinkEventArgs Constructor
HyperlinkEventArgs Class See Also Send Feedback
Constructor for HyperlinkEventArgs object.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public HyperlinkEventArgs(
    string hyperlink
)
Visual Basic (Declaration)
Public Sub New ( _
    hyperlink As String _
)
Visual C++
public:
HyperlinkEventArgs(
    String^ hyperlink
)

Parameters

hyperlink
Type: System..::.String

See Also

HyperlinkEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


HyperlinkEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
HyperlinkEventArgs Methods
HyperlinkEventArgs Class See Also Send Feedback

The HyperlinkEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HyperlinkEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


HyperlinkEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
HyperlinkEventArgs Properties
HyperlinkEventArgs Class See Also Send Feedback

The HyperlinkEventArgs type exposes the following members.

Properties

Name | Description
Handled | Gets or sets the value indicating whether the hyperlink event was handled.
Hyperlink | Gets the hyperlink string.

See Also

HyperlinkEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


Handled Property

[image]

.NET ModelKit Suite ClassReference
HyperlinkEventArgs..::.Handled Property
HyperlinkEventArgs Class See Also Send Feedback
Gets or sets the value indicating whether the hyperlink event was handled.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Handled { get; set; }
Visual Basic (Declaration)
Public Property Handled As Boolean
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

See Also

HyperlinkEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


Hyperlink Property

[image]

.NET ModelKit Suite ClassReference
HyperlinkEventArgs..::.Hyperlink Property
HyperlinkEventArgs Class See Also Send Feedback
Gets the hyperlink string.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Hyperlink { get; }
Visual Basic (Declaration)
Public ReadOnly Property Hyperlink As String
Visual C++
public:
property String^ Hyperlink {
    String^ get ();
}

See Also

HyperlinkEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


HyperlinkEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
HyperlinkEventHandler Delegate
See Also Send Feedback
Represents method that will handle the HyperlinkClick event.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate void HyperlinkEventHandler(
    Object sender,
    HyperlinkEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub HyperlinkEventHandler ( _
    sender As Object, _
    e As HyperlinkEventArgs _
)
Visual C++
public delegate void HyperlinkEventHandler(
    Object^ sender,
    HyperlinkEventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: PerpetuumSoft.Reporting.Components..::.HyperlinkEventArgs

See Also

PerpetuumSoft.Reporting.Components Namespace


InlineReportSlot Class

[image]

.NET ModelKit Suite ClassReference
InlineReportSlot Class
Members See Also Send Feedback
Represents report source saved in a string.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class InlineReportSlot : ReportSlot
Visual Basic (Declaration)
Public Class InlineReportSlot _
    Inherits ReportSlot
Visual C++
public ref class InlineReportSlot : public ReportSlot

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Components..::.ReportSlot
PerpetuumSoft.Reporting.Components..::.InlineReportSlot

See Also

InlineReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


InlineReportSlot Members

[image] [image]

.NET ModelKit Suite ClassReference
InlineReportSlot Members
InlineReportSlot Class Constructors Methods Properties Events See Also Send Feedback

The InlineReportSlot type exposes the following members.

Constructors

Name | Description
InlineReportSlot | Overloaded.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DesignTemplate | Runs report designer and opens a document corresponding to the given ReportSlot in it. (Inherited from ReportSlot.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
LoadReport | Overridden. See LoadReport()()(). (Overrides ReportSlot..::.LoadReport()()().)
MemberwiseClone | Overloaded.
OnGetReportParameter | Implements OnGetReportParameter(GetReportParameterEventArgs). (Inherited from ReportSlot.)
OnHyperlinkClick | Implements OnHyperlinkClick(HyperlinkEventArgs). (Inherited from ReportSlot.)
OnRenderCanceled | Implements OnRenderCanceled(EventArgs). (Inherited from ReportSlot.)
OnRenderingError | Implements OnRenderingError(RenderingErrorEventArgs). (Inherited from ReportSlot.)
Prepare | Overloaded.
RenderDocument | Overloaded.
SaveReport | Overridden. See SaveReport(Document). (Overrides ReportSlot..::.SaveReport(Document).)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Document | Implements Document. (Inherited from ReportSlot.)
DocumentStream | Gets or sets serialized document.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExceptionMode | Gets or sets exception mode for ReportSlot. (Inherited from ReportSlot.)
Manager | Gets manager for ReportSlot. (Inherited from ReportSlot.)
ReportName | Gets or sets report name. (Inherited from ReportSlot.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StyleSheet | Gets or sets ReportSlot styles. (Inherited from ReportSlot.)
SupportsSaving | Overridden. See SupportsSaving. (Overrides ReportSlot..::.SupportsSaving.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
GetReportParameter | Implements GetReportParameter. (Inherited from ReportSlot.)
HyperlinkClick | Implements HyperlinkClick. (Inherited from ReportSlot.)
RenderCanceled | Occurs when rendering has been canceled (Inherited from ReportSlot.)
RenderCompleted | Implements RenderCompleted. (Inherited from ReportSlot.)
RenderingError | Occurs when the rendering is completed with an error. (Inherited from ReportSlot.)

See Also

InlineReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


InlineReportSlot Constructor

[image] [image]

.NET ModelKit Suite ClassReference
InlineReportSlot Constructor
InlineReportSlot Class See Also Send Feedback

Overload List

Name | Description
InlineReportSlot()()() | Initializes a new instance of the InlineReportSlot class.
InlineReportSlot(IContainer) | Initializes a new instance of the InlineReportSlot class.

See Also

InlineReportSlot Class
InlineReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


InlineReportSlot Constructor

[image]

.NET ModelKit Suite ClassReference
InlineReportSlot Constructor
InlineReportSlot Class See Also Send Feedback
Initializes a new instance of the InlineReportSlot class.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public InlineReportSlot()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InlineReportSlot()

See Also

InlineReportSlot Class
InlineReportSlot Overload
PerpetuumSoft.Reporting.Components Namespace


InlineReportSlot Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
InlineReportSlot Constructor (IContainer)
InlineReportSlot Class See Also Send Feedback
Initializes a new instance of the InlineReportSlot class.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public InlineReportSlot(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
InlineReportSlot(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

InlineReportSlot Class
InlineReportSlot Overload
PerpetuumSoft.Reporting.Components Namespace


InlineReportSlot Methods

[image] [image]

.NET ModelKit Suite ClassReference
InlineReportSlot Methods
InlineReportSlot Class See Also Send Feedback

The InlineReportSlot type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DesignTemplate | Runs report designer and opens a document corresponding to the given ReportSlot in it. (Inherited from ReportSlot.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
LoadReport | Overridden. See LoadReport()()(). (Overrides ReportSlot..::.LoadReport()()().)
MemberwiseClone | Overloaded.
OnGetReportParameter | Implements OnGetReportParameter(GetReportParameterEventArgs). (Inherited from ReportSlot.)
OnHyperlinkClick | Implements OnHyperlinkClick(HyperlinkEventArgs). (Inherited from ReportSlot.)
OnRenderCanceled | Implements OnRenderCanceled(EventArgs). (Inherited from ReportSlot.)
OnRenderingError | Implements OnRenderingError(RenderingErrorEventArgs). (Inherited from ReportSlot.)
Prepare | Overloaded.
RenderDocument | Overloaded.
SaveReport | Overridden. See SaveReport(Document). (Overrides ReportSlot..::.SaveReport(Document).)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

InlineReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
InlineReportSlot..::.Dispose Method
InlineReportSlot Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

InlineReportSlot Class
InlineReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


LoadReport Method

[image]

.NET ModelKit Suite ClassReference
InlineReportSlot..::.LoadReport Method
InlineReportSlot Class See Also Send Feedback
Overridden. See LoadReport()()().

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override Document LoadReport()
Visual Basic (Declaration)
Public Overrides Function LoadReport As Document
Visual C++
public:
virtual Document^ LoadReport() override

See Also

InlineReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
InlineReportSlot..::.MemberwiseClone Method
InlineReportSlot Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

InlineReportSlot Class
InlineReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


Prepare Method

[image] [image]

.NET ModelKit Suite ClassReference
InlineReportSlot..::.Prepare Method
InlineReportSlot Class See Also Send Feedback

Overload List

Name | Description
Prepare()()() | Implements Prepare()()(). (Inherited from ReportSlot.)
Prepare(IRenderSite) | Implements ['M:PerpetuumSoft.Reporting.Components.IReportSource.Prepare()]. (Inherited from ReportSlot.)

See Also

InlineReportSlot Class
InlineReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


RenderDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
InlineReportSlot..::.RenderDocument Method
InlineReportSlot Class See Also Send Feedback

Overload List

Name | Description
RenderDocument()()() | Implements RenderDocument()()(). (Inherited from ReportSlot.)
RenderDocument(IRenderSite) | Implements ['M:PerpetuumSoft.Reporting.Components.IReportSource.RenderDocument(PerpetuumSoft.Reporting.Rendering.IRenderSite)]. (Inherited from ReportSlot.)

See Also

InlineReportSlot Class
InlineReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


SaveReport Method

[image]

.NET ModelKit Suite ClassReference
InlineReportSlot..::.SaveReport Method
InlineReportSlot Class See Also Send Feedback
Overridden. See SaveReport(Document).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void SaveReport(
    Document document
)
Visual Basic (Declaration)
Public Overrides Sub SaveReport ( _
    document As Document _
)
Visual C++
public:
virtual void SaveReport(
    Document^ document
) override

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document

See Also

InlineReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


InlineReportSlot Properties

[image] [image]

.NET ModelKit Suite ClassReference
InlineReportSlot Properties
InlineReportSlot Class See Also Send Feedback

The InlineReportSlot type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Document | Implements Document. (Inherited from ReportSlot.)
DocumentStream | Gets or sets serialized document.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExceptionMode | Gets or sets exception mode for ReportSlot. (Inherited from ReportSlot.)
Manager | Gets manager for ReportSlot. (Inherited from ReportSlot.)
ReportName | Gets or sets report name. (Inherited from ReportSlot.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StyleSheet | Gets or sets ReportSlot styles. (Inherited from ReportSlot.)
SupportsSaving | Overridden. See SupportsSaving. (Overrides ReportSlot..::.SupportsSaving.)

See Also

InlineReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


DocumentStream Property

[image]

.NET ModelKit Suite ClassReference
InlineReportSlot..::.DocumentStream Property
InlineReportSlot Class See Also Send Feedback
Gets or sets serialized document.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string DocumentStream { get; set; }
Visual Basic (Declaration)
Public Property DocumentStream As String
Visual C++
public:
property String^ DocumentStream {
    String^ get ();
    void set (String^ value);
}

See Also

InlineReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


SupportsSaving Property

[image]

.NET ModelKit Suite ClassReference
InlineReportSlot..::.SupportsSaving Property
InlineReportSlot Class See Also Send Feedback
Overridden. See SupportsSaving.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool SupportsSaving { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property SupportsSaving As Boolean
Visual C++
public:
virtual property bool SupportsSaving {
    bool get () override;
}

See Also

InlineReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


InlineReportSlot Events

[image] [image]

.NET ModelKit Suite ClassReference
InlineReportSlot Events
InlineReportSlot Class See Also Send Feedback

The InlineReportSlot type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
GetReportParameter | Implements GetReportParameter. (Inherited from ReportSlot.)
HyperlinkClick | Implements HyperlinkClick. (Inherited from ReportSlot.)
RenderCanceled | Occurs when rendering has been canceled (Inherited from ReportSlot.)
RenderCompleted | Implements RenderCompleted. (Inherited from ReportSlot.)
RenderingError | Occurs when the rendering is completed with an error. (Inherited from ReportSlot.)

See Also

InlineReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


IReportSource Interface

[image]

.NET ModelKit Suite ClassReference
IReportSource Interface
Members See Also Send Feedback
Provides functionality to report sources.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public interface IReportSource
Visual Basic (Declaration)
Public Interface IReportSource
Visual C++
public interface class IReportSource

See Also

IReportSource Members
PerpetuumSoft.Reporting.Components Namespace


IReportSource Members

[image] [image]

.NET ModelKit Suite ClassReference
IReportSource Members
IReportSource Interface Methods Properties Events See Also Send Feedback

The IReportSource type exposes the following members.

Methods

Name | Description
OnGetReportParameter | Performs additional custom processes when receiving report parameters.
OnHyperlinkClick | Performs additional custom processes when clicking on a hyperlink.
OnRenderCanceled | Raises the RenderCanceled event.
OnRenderCompleted | Performs additional custom processes when rendering is complete.
OnRenderingError | Raises the RenderingError event.
Prepare | Prepares document.
RenderDocument | Renders document.

Properties

Name | Description
Document | Gets or sets document.

Events

Name | Description
GetReportParameter | Occurs when report parameters are received.
HyperlinkClick | Occurs when hyperlink is clicked.
RenderCanceled | Occurs when rendering has been canceled
RenderCompleted | Occurs when rendering is complete.
RenderingError | Occurs when the rendering is completed with an error.

See Also

IReportSource Interface
PerpetuumSoft.Reporting.Components Namespace


IReportSource Methods

[image] [image]

.NET ModelKit Suite ClassReference
IReportSource Methods
IReportSource Interface See Also Send Feedback

The IReportSource type exposes the following members.

Methods

Name | Description
OnGetReportParameter | Performs additional custom processes when receiving report parameters.
OnHyperlinkClick | Performs additional custom processes when clicking on a hyperlink.
OnRenderCanceled | Raises the RenderCanceled event.
OnRenderCompleted | Performs additional custom processes when rendering is complete.
OnRenderingError | Raises the RenderingError event.
Prepare | Prepares document.
RenderDocument | Renders document.

See Also

IReportSource Interface
PerpetuumSoft.Reporting.Components Namespace


OnGetReportParameter Method

[image]

.NET ModelKit Suite ClassReference
IReportSource..::.OnGetReportParameter Method
IReportSource Interface See Also Send Feedback
Performs additional custom processes when receiving report parameters.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void OnGetReportParameter(
    GetReportParameterEventArgs e
)
Visual Basic (Declaration)
Sub OnGetReportParameter ( _
    e As GetReportParameterEventArgs _
)
Visual C++
void OnGetReportParameter(
    GetReportParameterEventArgs^ e
)

Parameters

e
Type: PerpetuumSoft.Reporting.Components..::.GetReportParameterEventArgs

See Also

IReportSource Interface
PerpetuumSoft.Reporting.Components Namespace


OnHyperlinkClick Method

[image]

.NET ModelKit Suite ClassReference
IReportSource..::.OnHyperlinkClick Method
IReportSource Interface See Also Send Feedback
Performs additional custom processes when clicking on a hyperlink.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void OnHyperlinkClick(
    HyperlinkEventArgs e
)
Visual Basic (Declaration)
Sub OnHyperlinkClick ( _
    e As HyperlinkEventArgs _
)
Visual C++
void OnHyperlinkClick(
    HyperlinkEventArgs^ e
)

Parameters

e
Type: PerpetuumSoft.Reporting.Components..::.HyperlinkEventArgs

See Also

IReportSource Interface
PerpetuumSoft.Reporting.Components Namespace


OnRenderCanceled Method

[image]

.NET ModelKit Suite ClassReference
IReportSource..::.OnRenderCanceled Method
IReportSource Interface See Also Send Feedback
Raises the RenderCanceled event.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void OnRenderCanceled(
    EventArgs e
)
Visual Basic (Declaration)
Sub OnRenderCanceled ( _
    e As EventArgs _
)
Visual C++
void OnRenderCanceled(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

See Also

IReportSource Interface
PerpetuumSoft.Reporting.Components Namespace


OnRenderCompleted Method

[image]

.NET ModelKit Suite ClassReference
IReportSource..::.OnRenderCompleted Method
IReportSource Interface See Also Send Feedback
Performs additional custom processes when rendering is complete.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void OnRenderCompleted()
Visual Basic (Declaration)
Sub OnRenderCompleted
Visual C++
void OnRenderCompleted()

See Also

IReportSource Interface
PerpetuumSoft.Reporting.Components Namespace


OnRenderingError Method

[image]

.NET ModelKit Suite ClassReference
IReportSource..::.OnRenderingError Method
IReportSource Interface See Also Send Feedback
Raises the RenderingError event.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void OnRenderingError(
    RenderingErrorEventArgs e
)
Visual Basic (Declaration)
Sub OnRenderingError ( _
    e As RenderingErrorEventArgs _
)
Visual C++
void OnRenderingError(
    RenderingErrorEventArgs^ e
)

Parameters

e
Type: PerpetuumSoft.Reporting.Components..::.RenderingErrorEventArgs

See Also

IReportSource Interface
PerpetuumSoft.Reporting.Components Namespace


Prepare Method

[image]

.NET ModelKit Suite ClassReference
IReportSource..::.Prepare Method
IReportSource Interface See Also Send Feedback
Prepares document.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void Prepare()
Visual Basic (Declaration)
Sub Prepare
Visual C++
void Prepare()

See Also

IReportSource Interface
PerpetuumSoft.Reporting.Components Namespace


RenderDocument Method

[image]

.NET ModelKit Suite ClassReference
IReportSource..::.RenderDocument Method
IReportSource Interface See Also Send Feedback
Renders document.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
Document RenderDocument()
Visual Basic (Declaration)
Function RenderDocument As Document
Visual C++
Document^ RenderDocument()

See Also

IReportSource Interface
PerpetuumSoft.Reporting.Components Namespace


IReportSource Properties

[image] [image]

.NET ModelKit Suite ClassReference
IReportSource Properties
IReportSource Interface See Also Send Feedback

The IReportSource type exposes the following members.

Properties

Name | Description
Document | Gets or sets document.

See Also

IReportSource Interface
PerpetuumSoft.Reporting.Components Namespace


Document Property

[image]

.NET ModelKit Suite ClassReference
IReportSource..::.Document Property
IReportSource Interface See Also Send Feedback
Gets or sets document.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
Document Document { get; set; }
Visual Basic (Declaration)
Property Document As Document
Visual C++
property Document^ Document {
    Document^ get ();
    void set (Document^ value);
}

See Also

IReportSource Interface
PerpetuumSoft.Reporting.Components Namespace


IReportSource Events

[image] [image]

.NET ModelKit Suite ClassReference
IReportSource Events
IReportSource Interface See Also Send Feedback

The IReportSource type exposes the following members.

Events

Name | Description
GetReportParameter | Occurs when report parameters are received.
HyperlinkClick | Occurs when hyperlink is clicked.
RenderCanceled | Occurs when rendering has been canceled
RenderCompleted | Occurs when rendering is complete.
RenderingError | Occurs when the rendering is completed with an error.

See Also

IReportSource Interface
PerpetuumSoft.Reporting.Components Namespace


GetReportParameter Event

[image]

.NET ModelKit Suite ClassReference
IReportSource..::.GetReportParameter Event
IReportSource Interface See Also Send Feedback
Occurs when report parameters are received.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
event GetReportParameterEventHandler GetReportParameter
Visual Basic (Declaration)
Event GetReportParameter As GetReportParameterEventHandler
Visual C++
 event GetReportParameterEventHandler^ GetReportParameter {
    void add (GetReportParameterEventHandler^ value);
    void remove (GetReportParameterEventHandler^ value);
}

See Also

IReportSource Interface
PerpetuumSoft.Reporting.Components Namespace


HyperlinkClick Event

[image]

.NET ModelKit Suite ClassReference
IReportSource..::.HyperlinkClick Event
IReportSource Interface See Also Send Feedback
Occurs when hyperlink is clicked.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
event HyperlinkEventHandler HyperlinkClick
Visual Basic (Declaration)
Event HyperlinkClick As HyperlinkEventHandler
Visual C++
 event HyperlinkEventHandler^ HyperlinkClick {
    void add (HyperlinkEventHandler^ value);
    void remove (HyperlinkEventHandler^ value);
}

See Also

IReportSource Interface
PerpetuumSoft.Reporting.Components Namespace


RenderCanceled Event

[image]

.NET ModelKit Suite ClassReference
IReportSource..::.RenderCanceled Event
IReportSource Interface See Also Send Feedback
Occurs when rendering has been canceled

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
event EventHandler RenderCanceled
Visual Basic (Declaration)
Event RenderCanceled As EventHandler
Visual C++
 event EventHandler^ RenderCanceled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

IReportSource Interface
PerpetuumSoft.Reporting.Components Namespace


RenderCompleted Event

[image]

.NET ModelKit Suite ClassReference
IReportSource..::.RenderCompleted Event
IReportSource Interface See Also Send Feedback
Occurs when rendering is complete.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
event EventHandler RenderCompleted
Visual Basic (Declaration)
Event RenderCompleted As EventHandler
Visual C++
 event EventHandler^ RenderCompleted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

IReportSource Interface
PerpetuumSoft.Reporting.Components Namespace


RenderingError Event

[image]

.NET ModelKit Suite ClassReference
IReportSource..::.RenderingError Event
IReportSource Interface See Also Send Feedback
Occurs when the rendering is completed with an error.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
event EventHandler<RenderingErrorEventArgs> RenderingError
Visual Basic (Declaration)
Event RenderingError As EventHandler(Of RenderingErrorEventArgs)
Visual C++
 event EventHandler<RenderingErrorEventArgs^>^ RenderingError {
    void add (EventHandler<RenderingErrorEventArgs^>^ value);
    void remove (EventHandler<RenderingErrorEventArgs^>^ value);
}

See Also

IReportSource Interface
PerpetuumSoft.Reporting.Components Namespace


ObjectPointerCollection Class

[image]

.NET ModelKit Suite ClassReference
ObjectPointerCollection Class
Members See Also Send Feedback
Represents a collection of associated String keys and Object values. Manages the list of data sources in report.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ObjectPointerCollection : NameObjectCollectionBase,
    IDataSourceManager
Visual Basic (Declaration)
Public Class ObjectPointerCollection _
    Inherits NameObjectCollectionBase _
    Implements IDataSourceManager
Visual C++
public ref class ObjectPointerCollection : public NameObjectCollectionBase,
    IDataSourceManager

Inheritance Hierarchy

System..::.Object
System.Collections.Specialized..::.NameObjectCollectionBase
PerpetuumSoft.Reporting.Components..::.ObjectPointerCollection

See Also

ObjectPointerCollection Members
PerpetuumSoft.Reporting.Components Namespace


ObjectPointerCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
ObjectPointerCollection Members
ObjectPointerCollection Class Constructors Methods Properties See Also Send Feedback

The ObjectPointerCollection type exposes the following members.

Constructors

Name | Description
ObjectPointerCollection | Overloaded.

Methods

Name | Description
Add | Adds an object to the collection.
BaseAdd | Adds an entry with the specified key and value into the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
BaseClear | Removes all entries from the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
BaseGet | Overloaded.
BaseGetAllKeys | Returns a String array that contains all the keys in the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
BaseGetAllValues | Overloaded.
BaseGetKey | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
BaseHasKeys | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null. (Inherited from NameObjectCollectionBase.)
BaseRemove | Removes the entries with the specified key from the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
BaseRemoveAt | Removes the entry at the specified index of the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
BaseSet | Overloaded.
Clear | Clears the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the NameObjectCollectionBase. (Inherited from NameObjectCollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from NameObjectCollectionBase.)
Remove | Removes an object from the collection.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
IsReadOnly | Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only. (Inherited from NameObjectCollectionBase.)
Item | Overloaded.
Keys | Gets a NameObjectCollectionBase..::.KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)

See Also

ObjectPointerCollection Class
PerpetuumSoft.Reporting.Components Namespace


ObjectPointerCollection Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ObjectPointerCollection Constructor
ObjectPointerCollection Class See Also Send Feedback

Overload List

Name | Description
ObjectPointerCollection()()() | Creates an empty collection.
ObjectPointerCollection(array<String>[]()[], array<Object>[]()[]) | Creates collection and fills it with the specified keys and objects.

See Also

ObjectPointerCollection Class
ObjectPointerCollection Members
PerpetuumSoft.Reporting.Components Namespace


ObjectPointerCollection Constructor

[image]

.NET ModelKit Suite ClassReference
ObjectPointerCollection Constructor
ObjectPointerCollection Class See Also Send Feedback
Creates an empty collection.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ObjectPointerCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ObjectPointerCollection()

See Also

ObjectPointerCollection Class
ObjectPointerCollection Overload
PerpetuumSoft.Reporting.Components Namespace


ObjectPointerCollection Constructor (String[], Object[])

[image]

.NET ModelKit Suite ClassReference
ObjectPointerCollection Constructor (array<String>[]()[], array<Object>[]()[])
ObjectPointerCollection Class See Also Send Feedback
Creates collection and fills it with the specified keys and objects.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ObjectPointerCollection(
    string[] names,
    Object[] objects
)
Visual Basic (Declaration)
Public Sub New ( _
    names As String(), _
    objects As Object() _
)
Visual C++
public:
ObjectPointerCollection(
    array<String^>^ names,
    array<Object^>^ objects
)

Parameters

names
Type: array< System..::.String >[]()[]
objects
Type: array< System..::.Object >[]()[]

See Also

ObjectPointerCollection Class
ObjectPointerCollection Overload
PerpetuumSoft.Reporting.Components Namespace


ObjectPointerCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
ObjectPointerCollection Methods
ObjectPointerCollection Class See Also Send Feedback

The ObjectPointerCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the collection.
BaseAdd | Adds an entry with the specified key and value into the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
BaseClear | Removes all entries from the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
BaseGet | Overloaded.
BaseGetAllKeys | Returns a String array that contains all the keys in the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
BaseGetAllValues | Overloaded.
BaseGetKey | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
BaseHasKeys | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null. (Inherited from NameObjectCollectionBase.)
BaseRemove | Removes the entries with the specified key from the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
BaseRemoveAt | Removes the entry at the specified index of the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
BaseSet | Overloaded.
Clear | Clears the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the NameObjectCollectionBase. (Inherited from NameObjectCollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from NameObjectCollectionBase.)
Remove | Removes an object from the collection.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjectPointerCollection Class
PerpetuumSoft.Reporting.Components Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
ObjectPointerCollection..::.Add Method
ObjectPointerCollection Class See Also Send Feedback
Adds an object to the collection.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Add(
    string name,
    Object value
)
Visual Basic (Declaration)
Public Sub Add ( _
    name As String, _
    value As Object _
)
Visual C++
public:
void Add(
    String^ name,
    Object^ value
)

Parameters

name
Type: System..::.String
value
Type: System..::.Object

See Also

ObjectPointerCollection Class
PerpetuumSoft.Reporting.Components Namespace


BaseGet Method

[image] [image]

.NET ModelKit Suite ClassReference
ObjectPointerCollection..::.BaseGet Method
ObjectPointerCollection Class See Also Send Feedback

Overload List

Name | Description
BaseGet(String) | Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
BaseGet(Int32) | Gets the value of the entry at the specified index of the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)

See Also

ObjectPointerCollection Class
ObjectPointerCollection Members
PerpetuumSoft.Reporting.Components Namespace


BaseGetAllValues Method

[image] [image]

.NET ModelKit Suite ClassReference
ObjectPointerCollection..::.BaseGetAllValues Method
ObjectPointerCollection Class See Also Send Feedback

Overload List

Name | Description
BaseGetAllValues()()() | Returns an Object array that contains all the values in the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
BaseGetAllValues(Type) | Returns an array of the specified type that contains all the values in the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)

See Also

ObjectPointerCollection Class
ObjectPointerCollection Members
PerpetuumSoft.Reporting.Components Namespace


BaseSet Method

[image] [image]

.NET ModelKit Suite ClassReference
ObjectPointerCollection..::.BaseSet Method
ObjectPointerCollection Class See Also Send Feedback

Overload List

Name | Description
BaseSet(String, Object) | Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
BaseSet(Int32, Object) | Sets the value of the entry at the specified index of the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)

See Also

ObjectPointerCollection Class
ObjectPointerCollection Members
PerpetuumSoft.Reporting.Components Namespace


Clear Method

[image]

.NET ModelKit Suite ClassReference
ObjectPointerCollection..::.Clear Method
ObjectPointerCollection Class See Also Send Feedback
Clears the collection.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

See Also

ObjectPointerCollection Class
PerpetuumSoft.Reporting.Components Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
ObjectPointerCollection..::.Remove Method
ObjectPointerCollection Class See Also Send Feedback
Removes an object from the collection.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    string name
)
Visual Basic (Declaration)
Public Sub Remove ( _
    name As String _
)
Visual C++
public:
void Remove(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

ObjectPointerCollection Class
PerpetuumSoft.Reporting.Components Namespace


ObjectPointerCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
ObjectPointerCollection Properties
ObjectPointerCollection Class See Also Send Feedback

The ObjectPointerCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)
IsReadOnly | Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only. (Inherited from NameObjectCollectionBase.)
Item | Overloaded.
Keys | Gets a NameObjectCollectionBase..::.KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance. (Inherited from NameObjectCollectionBase.)

See Also

ObjectPointerCollection Class
PerpetuumSoft.Reporting.Components Namespace


Item Property

[image] [image]

.NET ModelKit Suite ClassReference
ObjectPointerCollection..::.Item Property
ObjectPointerCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets an element by the specified index.
Item[([(String])]) | Gets the element associated with the specified key.

See Also

ObjectPointerCollection Class
ObjectPointerCollection Members
PerpetuumSoft.Reporting.Components Namespace


Item Property (Int32)

[image]

.NET ModelKit Suite ClassReference
ObjectPointerCollection..::.Item Property (Int32)
ObjectPointerCollection Class See Also Send Feedback
Gets an element by the specified index.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Object
Visual C++
public:
property Object^ default[int index] {
    Object^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

ObjectPointerCollection Class
Item Overload
PerpetuumSoft.Reporting.Components Namespace


Item Property (String)

[image]

.NET ModelKit Suite ClassReference
ObjectPointerCollection..::.Item Property (String)
ObjectPointerCollection Class See Also Send Feedback
Gets the element associated with the specified key.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object this[
    string name
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    name As String _
) As Object
Visual C++
public:
property Object^ default[String^ name] {
    Object^ get (String^ name);
    void set (String^ name, Object^ value);
}

Parameters

name
Type: System..::.String

See Also

ObjectPointerCollection Class
Item Overload
PerpetuumSoft.Reporting.Components Namespace


RenderingErrorEventArgs Class

[image]

.NET ModelKit Suite ClassReference
RenderingErrorEventArgs Class
Members See Also Send Feedback
Represents the information on the rendering error.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class RenderingErrorEventArgs : EventArgs
Visual Basic (Declaration)
Public Class RenderingErrorEventArgs _
    Inherits EventArgs
Visual C++
public ref class RenderingErrorEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.Components..::.RenderingErrorEventArgs

See Also

RenderingErrorEventArgs Members
PerpetuumSoft.Reporting.Components Namespace


RenderingErrorEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
RenderingErrorEventArgs Members
RenderingErrorEventArgs Class Constructors Methods Properties See Also Send Feedback

The RenderingErrorEventArgs type exposes the following members.

Constructors

Name | Description
RenderingErrorEventArgs | Initializes a new instance of the RenderingErrorEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Exception | Gets Exceptions which include the information on the error.
Handled | Gets or sets a value that indicates if an error is handled.

See Also

RenderingErrorEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


RenderingErrorEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
RenderingErrorEventArgs Constructor
RenderingErrorEventArgs Class See Also Send Feedback
Initializes a new instance of the RenderingErrorEventArgs class.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public RenderingErrorEventArgs(
    Exception exception
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception _
)
Visual C++
public:
RenderingErrorEventArgs(
    Exception^ exception
)

Parameters

exception
Type: System..::.Exception

See Also

RenderingErrorEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


RenderingErrorEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
RenderingErrorEventArgs Methods
RenderingErrorEventArgs Class See Also Send Feedback

The RenderingErrorEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderingErrorEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


RenderingErrorEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
RenderingErrorEventArgs Properties
RenderingErrorEventArgs Class See Also Send Feedback

The RenderingErrorEventArgs type exposes the following members.

Properties

Name | Description
Exception | Gets Exceptions which include the information on the error.
Handled | Gets or sets a value that indicates if an error is handled.

See Also

RenderingErrorEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


Exception Property

[image]

.NET ModelKit Suite ClassReference
RenderingErrorEventArgs..::.Exception Property
RenderingErrorEventArgs Class See Also Send Feedback
Gets Exceptions which include the information on the error.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Exception Exception { get; }
Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
Visual C++
public:
property Exception^ Exception {
    Exception^ get ();
}

See Also

RenderingErrorEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


Handled Property

[image]

.NET ModelKit Suite ClassReference
RenderingErrorEventArgs..::.Handled Property
RenderingErrorEventArgs Class See Also Send Feedback
Gets or sets a value that indicates if an error is handled.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Handled { get; set; }
Visual Basic (Declaration)
Public Property Handled As Boolean
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

See Also

RenderingErrorEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


ReportBase Class

[image]

.NET ModelKit Suite ClassReference
ReportBase Class
Members See Also Send Feedback
Base class for all Report components in the library. Provides basic logic for working with final documents.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract class ReportBase : Component
Visual Basic (Declaration)
Public MustInherit Class ReportBase _
    Inherits Component
Visual C++
public ref class ReportBase abstract : public Component

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Components..::.ReportBase
PerpetuumSoft.Reporting.Components..::.ReportGenerator

See Also

ReportBase Members
PerpetuumSoft.Reporting.Components Namespace


ReportBase Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportBase Members
ReportBase Class Constructors Methods Properties Events See Also Send Feedback

The ReportBase type exposes the following members.

Constructors

Name | Description
ReportBase | Overloaded.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
LoadDocument | Overloaded.
MemberwiseClone | Overloaded.
OnHyperlinkClick | Raises the HyperlinkClick event.
OnRenderCompleted | Raises the RenderComplited event.
Prepare | Overloaded.
RenderDocument | Overloaded.
SaveDocument | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
About | Gets the copyright string.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Document | Gets or sets the document handled by the report component.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
IsPrepared | Gets whether the final document is already prepared.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
HyperlinkClick | Occurs when user clicks on a hyperlink in report preview.
RenderCompleted | Occurs when the rendering process is finished.

See Also

ReportBase Class
PerpetuumSoft.Reporting.Components Namespace


ReportBase Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ReportBase Constructor
ReportBase Class See Also Send Feedback

Overload List

Name | Description
ReportBase()()() | Initializes a new instance of the ReportBase class.
ReportBase(IContainer) | Initializes a new instance of the ReportBase class with the specified container.

See Also

ReportBase Class
ReportBase Members
PerpetuumSoft.Reporting.Components Namespace


ReportBase Constructor

[image]

.NET ModelKit Suite ClassReference
ReportBase Constructor
ReportBase Class See Also Send Feedback
Initializes a new instance of the ReportBase class.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportBase()

See Also

ReportBase Class
ReportBase Overload
PerpetuumSoft.Reporting.Components Namespace


ReportBase Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
ReportBase Constructor (IContainer)
ReportBase Class See Also Send Feedback
Initializes a new instance of the ReportBase class with the specified container.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportBase(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
ReportBase(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

ReportBase Class
ReportBase Overload
PerpetuumSoft.Reporting.Components Namespace


ReportBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportBase Methods
ReportBase Class See Also Send Feedback

The ReportBase type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
LoadDocument | Overloaded.
MemberwiseClone | Overloaded.
OnHyperlinkClick | Raises the HyperlinkClick event.
OnRenderCompleted | Raises the RenderComplited event.
Prepare | Overloaded.
RenderDocument | Overloaded.
SaveDocument | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ReportBase Class
PerpetuumSoft.Reporting.Components Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportBase..::.Dispose Method
ReportBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

ReportBase Class
ReportBase Members
PerpetuumSoft.Reporting.Components Namespace


LoadDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportBase..::.LoadDocument Method
ReportBase Class See Also Send Feedback

Overload List

Name | Description
LoadDocument(Stream) | Loads a document from the specified stream.
LoadDocument(String) | Loads a document from the specified file.

See Also

ReportBase Class
ReportBase Members
PerpetuumSoft.Reporting.Components Namespace


LoadDocument Method (Stream)

[image]

.NET ModelKit Suite ClassReference
ReportBase..::.LoadDocument Method (Stream)
ReportBase Class See Also Send Feedback
Loads a document from the specified stream.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void LoadDocument(
    Stream stream
)
Visual Basic (Declaration)
Public Sub LoadDocument ( _
    stream As Stream _
)
Visual C++
public:
void LoadDocument(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

ReportBase Class
LoadDocument Overload
PerpetuumSoft.Reporting.Components Namespace


LoadDocument Method (String)

[image]

.NET ModelKit Suite ClassReference
ReportBase..::.LoadDocument Method (String)
ReportBase Class See Also Send Feedback
Loads a document from the specified file.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void LoadDocument(
    string filename
)
Visual Basic (Declaration)
Public Sub LoadDocument ( _
    filename As String _
)
Visual C++
public:
void LoadDocument(
    String^ filename
)

Parameters

filename
Type: System..::.String

See Also

ReportBase Class
LoadDocument Overload
PerpetuumSoft.Reporting.Components Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportBase..::.MemberwiseClone Method
ReportBase Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ReportBase Class
ReportBase Members
PerpetuumSoft.Reporting.Components Namespace


OnHyperlinkClick Method

[image]

.NET ModelKit Suite ClassReference
ReportBase..::.OnHyperlinkClick Method
ReportBase Class See Also Send Feedback
Raises the HyperlinkClick event.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void OnHyperlinkClick(
    HyperlinkEventArgs e
)
Visual Basic (Declaration)
Public Sub OnHyperlinkClick ( _
    e As HyperlinkEventArgs _
)
Visual C++
public:
virtual void OnHyperlinkClick(
    HyperlinkEventArgs^ e
) sealed

Parameters

e
Type: PerpetuumSoft.Reporting.Components..::.HyperlinkEventArgs

See Also

ReportBase Class
PerpetuumSoft.Reporting.Components Namespace


OnRenderCompleted Method

[image]

.NET ModelKit Suite ClassReference
ReportBase..::.OnRenderCompleted Method
ReportBase Class See Also Send Feedback
Raises the RenderComplited event.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected void OnRenderCompleted()
Visual Basic (Declaration)
Protected Sub OnRenderCompleted
Visual C++
protected:
void OnRenderCompleted()

See Also

ReportBase Class
PerpetuumSoft.Reporting.Components Namespace


Prepare Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportBase..::.Prepare Method
ReportBase Class See Also Send Feedback

Overload List

Name | Description
Prepare()()() | Renders the final document.
Prepare(IRenderSite) | Renders the final document using the specified RenderSite.

See Also

ReportBase Class
ReportBase Members
PerpetuumSoft.Reporting.Components Namespace


Prepare Method

[image]

.NET ModelKit Suite ClassReference
ReportBase..::.Prepare Method
ReportBase Class See Also Send Feedback
Renders the final document.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract void Prepare()
Visual Basic (Declaration)
Public MustOverride Sub Prepare
Visual C++
public:
virtual void Prepare() abstract

See Also

ReportBase Class
Prepare Overload
PerpetuumSoft.Reporting.Components Namespace


Prepare Method (IRenderSite)

[image]

.NET ModelKit Suite ClassReference
ReportBase..::.Prepare Method (IRenderSite)
ReportBase Class See Also Send Feedback
Renders the final document using the specified RenderSite.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract void Prepare(
    IRenderSite renderSite
)
Visual Basic (Declaration)
Public MustOverride Sub Prepare ( _
    renderSite As IRenderSite _
)
Visual C++
public:
virtual void Prepare(
    IRenderSite^ renderSite
) abstract

Parameters

renderSite
Type: PerpetuumSoft.Reporting.Rendering..::.IRenderSite

See Also

ReportBase Class
Prepare Overload
PerpetuumSoft.Reporting.Components Namespace


RenderDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportBase..::.RenderDocument Method
ReportBase Class See Also Send Feedback

Overload List

Name | Description
RenderDocument()()() | Renders the final document.
RenderDocument(IRenderSite) | Renders the final document using the specified RenderSite.

See Also

ReportBase Class
ReportBase Members
PerpetuumSoft.Reporting.Components Namespace


RenderDocument Method

[image]

.NET ModelKit Suite ClassReference
ReportBase..::.RenderDocument Method
ReportBase Class See Also Send Feedback
Renders the final document.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Document RenderDocument()
Visual Basic (Declaration)
Public Function RenderDocument As Document
Visual C++
public:
virtual Document^ RenderDocument() sealed

See Also

ReportBase Class
RenderDocument Overload
PerpetuumSoft.Reporting.Components Namespace


RenderDocument Method (IRenderSite)

[image]

.NET ModelKit Suite ClassReference
ReportBase..::.RenderDocument Method (IRenderSite)
ReportBase Class See Also Send Feedback
Renders the final document using the specified RenderSite.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract Document RenderDocument(
    IRenderSite renderSite
)
Visual Basic (Declaration)
Public MustOverride Function RenderDocument ( _
    renderSite As IRenderSite _
) As Document
Visual C++
public:
virtual Document^ RenderDocument(
    IRenderSite^ renderSite
) abstract

Parameters

renderSite
Type: PerpetuumSoft.Reporting.Rendering..::.IRenderSite

See Also

ReportBase Class
RenderDocument Overload
PerpetuumSoft.Reporting.Components Namespace


SaveDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportBase..::.SaveDocument Method
ReportBase Class See Also Send Feedback

Overload List

Name | Description
SaveDocument(Stream) | Saves the final document to the specified stream.
SaveDocument(String) | Saves the final document to the specified file.

See Also

ReportBase Class
ReportBase Members
PerpetuumSoft.Reporting.Components Namespace


SaveDocument Method (Stream)

[image]

.NET ModelKit Suite ClassReference
ReportBase..::.SaveDocument Method (Stream)
ReportBase Class See Also Send Feedback
Saves the final document to the specified stream.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void SaveDocument(
    Stream stream
)
Visual Basic (Declaration)
Public Sub SaveDocument ( _
    stream As Stream _
)
Visual C++
public:
void SaveDocument(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

ReportBase Class
SaveDocument Overload
PerpetuumSoft.Reporting.Components Namespace


SaveDocument Method (String)

[image]

.NET ModelKit Suite ClassReference
ReportBase..::.SaveDocument Method (String)
ReportBase Class See Also Send Feedback
Saves the final document to the specified file.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void SaveDocument(
    string filename
)
Visual Basic (Declaration)
Public Sub SaveDocument ( _
    filename As String _
)
Visual C++
public:
void SaveDocument(
    String^ filename
)

Parameters

filename
Type: System..::.String

See Also

ReportBase Class
SaveDocument Overload
PerpetuumSoft.Reporting.Components Namespace


ReportBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportBase Properties
ReportBase Class See Also Send Feedback

The ReportBase type exposes the following members.

Properties

Name | Description
About | Gets the copyright string.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Document | Gets or sets the document handled by the report component.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
IsPrepared | Gets whether the final document is already prepared.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

ReportBase Class
PerpetuumSoft.Reporting.Components Namespace


About Property

[image]

.NET ModelKit Suite ClassReference
ReportBase..::.About Property
ReportBase Class See Also Send Feedback
Gets the copyright string.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string About { get; }
Visual Basic (Declaration)
Public ReadOnly Property About As String
Visual C++
public:
property String^ About {
    String^ get ();
}

See Also

ReportBase Class
PerpetuumSoft.Reporting.Components Namespace


Document Property

[image]

.NET ModelKit Suite ClassReference
ReportBase..::.Document Property
ReportBase Class See Also Send Feedback
Gets or sets the document handled by the report component.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual Document Document { get; set; }
Visual Basic (Declaration)
Public Overridable Property Document As Document
Visual C++
public:
virtual property Document^ Document {
    Document^ get ();
    void set (Document^ value);
}

See Also

ReportBase Class
PerpetuumSoft.Reporting.Components Namespace


IsPrepared Property

[image]

.NET ModelKit Suite ClassReference
ReportBase..::.IsPrepared Property
ReportBase Class See Also Send Feedback
Gets whether the final document is already prepared.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract bool IsPrepared { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property IsPrepared As Boolean
Visual C++
public:
virtual property bool IsPrepared {
    bool get () abstract;
}

See Also

ReportBase Class
PerpetuumSoft.Reporting.Components Namespace


ReportBase Events

[image] [image]

.NET ModelKit Suite ClassReference
ReportBase Events
ReportBase Class See Also Send Feedback

The ReportBase type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
HyperlinkClick | Occurs when user clicks on a hyperlink in report preview.
RenderCompleted | Occurs when the rendering process is finished.

See Also

ReportBase Class
PerpetuumSoft.Reporting.Components Namespace


HyperlinkClick Event

[image]

.NET ModelKit Suite ClassReference
ReportBase..::.HyperlinkClick Event
ReportBase Class See Also Send Feedback
Occurs when user clicks on a hyperlink in report preview.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event HyperlinkEventHandler HyperlinkClick
Visual Basic (Declaration)
Public Event HyperlinkClick As HyperlinkEventHandler
Visual C++
public:
virtual  event HyperlinkEventHandler^ HyperlinkClick {
    void add (HyperlinkEventHandler^ value);
    void remove (HyperlinkEventHandler^ value);
}

See Also

ReportBase Class
PerpetuumSoft.Reporting.Components Namespace


RenderCompleted Event

[image]

.NET ModelKit Suite ClassReference
ReportBase..::.RenderCompleted Event
ReportBase Class See Also Send Feedback
Occurs when the rendering process is finished.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler RenderCompleted
Visual Basic (Declaration)
Public Event RenderCompleted As EventHandler
Visual C++
public:
virtual  event EventHandler^ RenderCompleted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ReportBase Class
PerpetuumSoft.Reporting.Components Namespace


ReportGenerator Class

[image]

.NET ModelKit Suite ClassReference
ReportGenerator Class
Members See Also Send Feedback
Defines the central component that provides interaction between all parts of Report Sharp-Shooter. It integrates the report template, rendering of the final document, runs the report template designer etc.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
[ObsoleteAttribute("Please use the ReportManager component instead.")]
public class ReportGenerator : ReportBase,
    IRenderSite, IResolveSubReport, IReportSource
Visual Basic (Declaration)
<ObsoleteAttribute("Please use the ReportManager component instead.")> _
Public Class ReportGenerator _
    Inherits ReportBase _
    Implements IRenderSite, IResolveSubReport, IReportSource
Visual C++
[ObsoleteAttribute(L"Please use the ReportManager component instead.")]
public ref class ReportGenerator : public ReportBase,
    IRenderSite, IResolveSubReport, IReportSource

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Components..::.ReportBase
PerpetuumSoft.Reporting.Components..::.ReportGenerator

See Also

ReportGenerator Members
PerpetuumSoft.Reporting.Components Namespace


ReportGenerator Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportGenerator Members
ReportGenerator Class Constructors Methods Properties Events See Also Send Feedback

The ReportGenerator type exposes the following members.

Constructors

Name | Description
ReportGenerator | Overloaded.

Methods

Name | Description
CancelPrepare | Cancels preparing document.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DesignTemplate | Overloaded.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
LoadDocument | Overloaded.
LoadTemplate | Overloaded.
MemberwiseClone | Overloaded.
OnGetReportParameter | Implements OnGetReportParameter(GetReportParameterEventArgs).
OnHyperlinkClick | Raises the HyperlinkClick event. (Inherited from ReportBase.)
OnRenderCanceled | Implements OnRenderCanceled(EventArgs).
OnRenderCompleted | Raises the RenderComplited event. (Inherited from ReportBase.)
OnRenderingError | Implements OnRenderingError(RenderingErrorEventArgs).
Prepare | Overloaded.
Print | Prints the final document with the given printer settings.
RenderDocument | Overloaded.
SaveDocument | Overloaded.
SaveTemplate | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
About | Gets the copyright string. (Inherited from ReportBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSources | Gets and sets a collection of data sources for the ReportGenerator.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Document | Gets or sets the document handled by the report component. (Inherited from ReportBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExceptionMode | Gets and sets exception handling mode for rendering.
IsPrepared | Gets whether the final document is already prepared. (Overrides ReportBase..::.IsPrepared.)
ModalProgressForm | Gets or sets dialog progress mode.
OwnerForm | Gets or sets owner form for the rendering progress dialog.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Template | Gets and sets the Template for the ReportGenerator.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
GetReportParameter | Occurs when report parameters are received.
HyperlinkClick | Occurs when user clicks on a hyperlink in report preview. (Inherited from ReportBase.)
RenderCanceled | Occurs when rendering has been canceled
RenderCompleted | Occurs when the rendering process is finished. (Inherited from ReportBase.)
RenderingError | Occurs when the rendering is completed with an error.
ResolveSubReport | Occurs when subreport is resolved.

See Also

ReportGenerator Class
PerpetuumSoft.Reporting.Components Namespace


ReportGenerator Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ReportGenerator Constructor
ReportGenerator Class See Also Send Feedback

Overload List

Name | Description
ReportGenerator()()() | Initializes a new instance of the ReportBase class.
ReportGenerator(IContainer) | Initializes a new instance of the ReportGenerator class with the specified container.

See Also

ReportGenerator Class
ReportGenerator Members
PerpetuumSoft.Reporting.Components Namespace


ReportGenerator Constructor

[image]

.NET ModelKit Suite ClassReference
ReportGenerator Constructor
ReportGenerator Class See Also Send Feedback
Initializes a new instance of the ReportBase class.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportGenerator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportGenerator()

See Also

ReportGenerator Class
ReportGenerator Overload
PerpetuumSoft.Reporting.Components Namespace


ReportGenerator Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
ReportGenerator Constructor (IContainer)
ReportGenerator Class See Also Send Feedback
Initializes a new instance of the ReportGenerator class with the specified container.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportGenerator(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
ReportGenerator(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

ReportGenerator Class
ReportGenerator Overload
PerpetuumSoft.Reporting.Components Namespace


ReportGenerator Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportGenerator Methods
ReportGenerator Class See Also Send Feedback

The ReportGenerator type exposes the following members.

Methods

Name | Description
CancelPrepare | Cancels preparing document.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DesignTemplate | Overloaded.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
LoadDocument | Overloaded.
LoadTemplate | Overloaded.
MemberwiseClone | Overloaded.
OnGetReportParameter | Implements OnGetReportParameter(GetReportParameterEventArgs).
OnHyperlinkClick | Raises the HyperlinkClick event. (Inherited from ReportBase.)
OnRenderCanceled | Implements OnRenderCanceled(EventArgs).
OnRenderCompleted | Raises the RenderComplited event. (Inherited from ReportBase.)
OnRenderingError | Implements OnRenderingError(RenderingErrorEventArgs).
Prepare | Overloaded.
Print | Prints the final document with the given printer settings.
RenderDocument | Overloaded.
SaveDocument | Overloaded.
SaveTemplate | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ReportGenerator Class
PerpetuumSoft.Reporting.Components Namespace


CancelPrepare Method

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.CancelPrepare Method
ReportGenerator Class See Also Send Feedback
Cancels preparing document.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void CancelPrepare(
    Object sender,
    EventArgs e
)
Visual Basic (Declaration)
Public Sub CancelPrepare ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
public:
void CancelPrepare(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

ReportGenerator Class
PerpetuumSoft.Reporting.Components Namespace


DesignTemplate Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.DesignTemplate Method
ReportGenerator Class See Also Send Feedback

Overload List

Name | Description
DesignTemplate()()() | Runs report template designer for the end-user session.
DesignTemplate(String) | Runs report template designer for the end-user session.

See Also

ReportGenerator Class
ReportGenerator Members
PerpetuumSoft.Reporting.Components Namespace


DesignTemplate Method

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.DesignTemplate Method
ReportGenerator Class See Also Send Feedback
Runs report template designer for the end-user session.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void DesignTemplate()
Visual Basic (Declaration)
Public Sub DesignTemplate
Visual C++
public:
void DesignTemplate()

See Also

ReportGenerator Class
DesignTemplate Overload
PerpetuumSoft.Reporting.Components Namespace


DesignTemplate Method (String)

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.DesignTemplate Method (String)
ReportGenerator Class See Also Send Feedback
Runs report template designer for the end-user session.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void DesignTemplate(
    string fileName
)
Visual Basic (Declaration)
Public Sub DesignTemplate ( _
    fileName As String _
)
Visual C++
public:
void DesignTemplate(
    String^ fileName
)

Parameters

fileName
Type: System..::.String

See Also

ReportGenerator Class
DesignTemplate Overload
PerpetuumSoft.Reporting.Components Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.Dispose Method
ReportGenerator Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

ReportGenerator Class
ReportGenerator Members
PerpetuumSoft.Reporting.Components Namespace


LoadDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.LoadDocument Method
ReportGenerator Class See Also Send Feedback

Overload List

Name | Description
LoadDocument(Stream) | Loads a document from the specified stream. (Inherited from ReportBase.)
LoadDocument(String) | Loads a document from the specified file. (Inherited from ReportBase.)

See Also

ReportGenerator Class
ReportGenerator Members
PerpetuumSoft.Reporting.Components Namespace


LoadTemplate Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.LoadTemplate Method
ReportGenerator Class See Also Send Feedback

Overload List

Name | Description
LoadTemplate(Stream) | Loads a template from the specified stream.
LoadTemplate(String) | Loads a template from the specified file.

See Also

ReportGenerator Class
ReportGenerator Members
PerpetuumSoft.Reporting.Components Namespace


LoadTemplate Method (Stream)

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.LoadTemplate Method (Stream)
ReportGenerator Class See Also Send Feedback
Loads a template from the specified stream.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void LoadTemplate(
    Stream stream
)
Visual Basic (Declaration)
Public Sub LoadTemplate ( _
    stream As Stream _
)
Visual C++
public:
void LoadTemplate(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

ReportGenerator Class
LoadTemplate Overload
PerpetuumSoft.Reporting.Components Namespace


LoadTemplate Method (String)

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.LoadTemplate Method (String)
ReportGenerator Class See Also Send Feedback
Loads a template from the specified file.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void LoadTemplate(
    string filename
)
Visual Basic (Declaration)
Public Sub LoadTemplate ( _
    filename As String _
)
Visual C++
public:
void LoadTemplate(
    String^ filename
)

Parameters

filename
Type: System..::.String

See Also

ReportGenerator Class
LoadTemplate Overload
PerpetuumSoft.Reporting.Components Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.MemberwiseClone Method
ReportGenerator Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ReportGenerator Class
ReportGenerator Members
PerpetuumSoft.Reporting.Components Namespace


OnGetReportParameter Method

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.OnGetReportParameter Method
ReportGenerator Class See Also Send Feedback
Implements OnGetReportParameter(GetReportParameterEventArgs).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void OnGetReportParameter(
    GetReportParameterEventArgs args
)
Visual Basic (Declaration)
Public Sub OnGetReportParameter ( _
    args As GetReportParameterEventArgs _
)
Visual C++
public:
virtual void OnGetReportParameter(
    GetReportParameterEventArgs^ args
) sealed

Parameters

args
Type: PerpetuumSoft.Reporting.Components..::.GetReportParameterEventArgs

Implements

IReportSource..::.OnGetReportParameter(GetReportParameterEventArgs)

See Also

ReportGenerator Class
PerpetuumSoft.Reporting.Components Namespace


OnRenderCanceled Method

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.OnRenderCanceled Method
ReportGenerator Class See Also Send Feedback
Implements OnRenderCanceled(EventArgs).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual void OnRenderCanceled(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnRenderCanceled ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnRenderCanceled(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

Implements

IReportSource..::.OnRenderCanceled(EventArgs)

See Also

ReportGenerator Class
PerpetuumSoft.Reporting.Components Namespace


OnRenderingError Method

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.OnRenderingError Method
ReportGenerator Class See Also Send Feedback
Implements OnRenderingError(RenderingErrorEventArgs).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual void OnRenderingError(
    RenderingErrorEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnRenderingError ( _
    e As RenderingErrorEventArgs _
)
Visual C++
public:
virtual void OnRenderingError(
    RenderingErrorEventArgs^ e
)

Parameters

e
Type: PerpetuumSoft.Reporting.Components..::.RenderingErrorEventArgs

Implements

IReportSource..::.OnRenderingError(RenderingErrorEventArgs)

See Also

ReportGenerator Class
PerpetuumSoft.Reporting.Components Namespace


Prepare Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.Prepare Method
ReportGenerator Class See Also Send Feedback

Overload List

Name | Description
Prepare()()() | Renders the final document. (Overrides ReportBase..::.Prepare()()().)
Prepare(IRenderSite) | Renders the final document using the specified RenderSite. (Overrides ReportBase..::.Prepare(IRenderSite).)

See Also

ReportGenerator Class
ReportGenerator Members
PerpetuumSoft.Reporting.Components Namespace


Prepare Method

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.Prepare Method
ReportGenerator Class See Also Send Feedback
Renders the final document.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Prepare()
Visual Basic (Declaration)
Public Overrides Sub Prepare
Visual C++
public:
virtual void Prepare() override

Implements

IReportSource..::.Prepare()()()

See Also

ReportGenerator Class
Prepare Overload
PerpetuumSoft.Reporting.Components Namespace


Prepare Method (IRenderSite)

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.Prepare Method (IRenderSite)
ReportGenerator Class See Also Send Feedback
Renders the final document using the specified RenderSite.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Prepare(
    IRenderSite renderSite
)
Visual Basic (Declaration)
Public Overrides Sub Prepare ( _
    renderSite As IRenderSite _
)
Visual C++
public:
virtual void Prepare(
    IRenderSite^ renderSite
) override

Parameters

renderSite
Type: PerpetuumSoft.Reporting.Rendering..::.IRenderSite

See Also

ReportGenerator Class
Prepare Overload
PerpetuumSoft.Reporting.Components Namespace


Print Method

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.Print Method
ReportGenerator Class See Also Send Feedback
Prints the final document with the given printer settings.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Print(
    PrinterSettings ps
)
Visual Basic (Declaration)
Public Sub Print ( _
    ps As PrinterSettings _
)
Visual C++
public:
void Print(
    PrinterSettings^ ps
)

Parameters

ps
Type: System.Drawing.Printing..::.PrinterSettings

See Also

ReportGenerator Class
PerpetuumSoft.Reporting.Components Namespace


RenderDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.RenderDocument Method
ReportGenerator Class See Also Send Feedback

Overload List

Name | Description
RenderDocument()()() | Renders the final document. (Inherited from ReportBase.)
RenderDocument(IRenderSite) | Renders the final document using the specified RenderSite. (Overrides ReportBase..::.RenderDocument(IRenderSite).)

See Also

ReportGenerator Class
ReportGenerator Members
PerpetuumSoft.Reporting.Components Namespace


RenderDocument Method (IRenderSite)

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.RenderDocument Method (IRenderSite)
ReportGenerator Class See Also Send Feedback
Renders the final document using the specified RenderSite.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override Document RenderDocument(
    IRenderSite renderSite
)
Visual Basic (Declaration)
Public Overrides Function RenderDocument ( _
    renderSite As IRenderSite _
) As Document
Visual C++
public:
virtual Document^ RenderDocument(
    IRenderSite^ renderSite
) override

Parameters

renderSite
Type: PerpetuumSoft.Reporting.Rendering..::.IRenderSite

See Also

ReportGenerator Class
RenderDocument Overload
PerpetuumSoft.Reporting.Components Namespace


SaveDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.SaveDocument Method
ReportGenerator Class See Also Send Feedback

Overload List

Name | Description
SaveDocument(Stream) | Saves the final document to the specified stream. (Inherited from ReportBase.)
SaveDocument(String) | Saves the final document to the specified file. (Inherited from ReportBase.)

See Also

ReportGenerator Class
ReportGenerator Members
PerpetuumSoft.Reporting.Components Namespace


SaveTemplate Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.SaveTemplate Method
ReportGenerator Class See Also Send Feedback

Overload List

Name | Description
SaveTemplate(Stream) | Saves the template to the specified stream.
SaveTemplate(String) | Saves the template to the specified file.

See Also

ReportGenerator Class
ReportGenerator Members
PerpetuumSoft.Reporting.Components Namespace


SaveTemplate Method (Stream)

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.SaveTemplate Method (Stream)
ReportGenerator Class See Also Send Feedback
Saves the template to the specified stream.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void SaveTemplate(
    Stream stream
)
Visual Basic (Declaration)
Public Sub SaveTemplate ( _
    stream As Stream _
)
Visual C++
public:
void SaveTemplate(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

ReportGenerator Class
SaveTemplate Overload
PerpetuumSoft.Reporting.Components Namespace


SaveTemplate Method (String)

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.SaveTemplate Method (String)
ReportGenerator Class See Also Send Feedback
Saves the template to the specified file.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void SaveTemplate(
    string filename
)
Visual Basic (Declaration)
Public Sub SaveTemplate ( _
    filename As String _
)
Visual C++
public:
void SaveTemplate(
    String^ filename
)

Parameters

filename
Type: System..::.String

See Also

ReportGenerator Class
SaveTemplate Overload
PerpetuumSoft.Reporting.Components Namespace


ReportGenerator Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportGenerator Properties
ReportGenerator Class See Also Send Feedback

The ReportGenerator type exposes the following members.

Properties

Name | Description
About | Gets the copyright string. (Inherited from ReportBase.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSources | Gets and sets a collection of data sources for the ReportGenerator.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Document | Gets or sets the document handled by the report component. (Inherited from ReportBase.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExceptionMode | Gets and sets exception handling mode for rendering.
IsPrepared | Gets whether the final document is already prepared. (Overrides ReportBase..::.IsPrepared.)
ModalProgressForm | Gets or sets dialog progress mode.
OwnerForm | Gets or sets owner form for the rendering progress dialog.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Template | Gets and sets the Template for the ReportGenerator.

See Also

ReportGenerator Class
PerpetuumSoft.Reporting.Components Namespace


DataSources Property

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.DataSources Property
ReportGenerator Class See Also Send Feedback
Gets and sets a collection of data sources for the ReportGenerator.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ObjectPointerCollection DataSources { get; set; }
Visual Basic (Declaration)
Public Property DataSources As ObjectPointerCollection
Visual C++
public:
property ObjectPointerCollection^ DataSources {
    ObjectPointerCollection^ get ();
    void set (ObjectPointerCollection^ value);
}

See Also

ReportGenerator Class
PerpetuumSoft.Reporting.Components Namespace


ExceptionMode Property

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.ExceptionMode Property
ReportGenerator Class See Also Send Feedback
Gets and sets exception handling mode for rendering.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ExceptionMode ExceptionMode { get; set; }
Visual Basic (Declaration)
Public Property ExceptionMode As ExceptionMode
Visual C++
public:
property ExceptionMode ExceptionMode {
    ExceptionMode get ();
    void set (ExceptionMode value);
}

See Also

ReportGenerator Class
PerpetuumSoft.Reporting.Components Namespace


IsPrepared Property

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.IsPrepared Property
ReportGenerator Class See Also Send Feedback
Gets whether the final document is already prepared.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsPrepared { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsPrepared As Boolean
Visual C++
public:
virtual property bool IsPrepared {
    bool get () override;
}

See Also

ReportGenerator Class
PerpetuumSoft.Reporting.Components Namespace


ModalProgressForm Property

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.ModalProgressForm Property
ReportGenerator Class See Also Send Feedback
Gets or sets dialog progress mode.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ModalProgressForm { get; set; }
Visual Basic (Declaration)
Public Property ModalProgressForm As Boolean
Visual C++
public:
property bool ModalProgressForm {
    bool get ();
    void set (bool value);
}

See Also

ReportGenerator Class
PerpetuumSoft.Reporting.Components Namespace


OwnerForm Property

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.OwnerForm Property
ReportGenerator Class See Also Send Feedback
Gets or sets owner form for the rendering progress dialog.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Form OwnerForm { get; set; }
Visual Basic (Declaration)
Public Property OwnerForm As Form
Visual C++
public:
property Form^ OwnerForm {
    Form^ get ();
    void set (Form^ value);
}

See Also

ReportGenerator Class
PerpetuumSoft.Reporting.Components Namespace


Template Property

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.Template Property
ReportGenerator Class See Also Send Feedback
Gets and sets the Template for the ReportGenerator.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Document Template { get; set; }
Visual Basic (Declaration)
Public Property Template As Document
Visual C++
public:
property Document^ Template {
    Document^ get ();
    void set (Document^ value);
}

See Also

ReportGenerator Class
PerpetuumSoft.Reporting.Components Namespace


ReportGenerator Events

[image] [image]

.NET ModelKit Suite ClassReference
ReportGenerator Events
ReportGenerator Class See Also Send Feedback

The ReportGenerator type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
GetReportParameter | Occurs when report parameters are received.
HyperlinkClick | Occurs when user clicks on a hyperlink in report preview. (Inherited from ReportBase.)
RenderCanceled | Occurs when rendering has been canceled
RenderCompleted | Occurs when the rendering process is finished. (Inherited from ReportBase.)
RenderingError | Occurs when the rendering is completed with an error.
ResolveSubReport | Occurs when subreport is resolved.

See Also

ReportGenerator Class
PerpetuumSoft.Reporting.Components Namespace


GetReportParameter Event

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.GetReportParameter Event
ReportGenerator Class See Also Send Feedback
Occurs when report parameters are received.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event GetReportParameterEventHandler GetReportParameter
Visual Basic (Declaration)
Public Event GetReportParameter As GetReportParameterEventHandler
Visual C++
public:
virtual  event GetReportParameterEventHandler^ GetReportParameter {
    void add (GetReportParameterEventHandler^ value);
    void remove (GetReportParameterEventHandler^ value);
}

Implements

IReportSource..::.GetReportParameter

See Also

ReportGenerator Class
PerpetuumSoft.Reporting.Components Namespace


RenderCanceled Event

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.RenderCanceled Event
ReportGenerator Class See Also Send Feedback
Occurs when rendering has been canceled

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler RenderCanceled
Visual Basic (Declaration)
Public Event RenderCanceled As EventHandler
Visual C++
public:
virtual  event EventHandler^ RenderCanceled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Implements

IReportSource..::.RenderCanceled

See Also

ReportGenerator Class
PerpetuumSoft.Reporting.Components Namespace


RenderingError Event

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.RenderingError Event
ReportGenerator Class See Also Send Feedback
Occurs when the rendering is completed with an error.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler<RenderingErrorEventArgs> RenderingError
Visual Basic (Declaration)
Public Event RenderingError As EventHandler(Of RenderingErrorEventArgs)
Visual C++
public:
virtual  event EventHandler<RenderingErrorEventArgs^>^ RenderingError {
    void add (EventHandler<RenderingErrorEventArgs^>^ value);
    void remove (EventHandler<RenderingErrorEventArgs^>^ value);
}

Implements

IReportSource..::.RenderingError

See Also

ReportGenerator Class
PerpetuumSoft.Reporting.Components Namespace


ResolveSubReport Event

[image]

.NET ModelKit Suite ClassReference
ReportGenerator..::.ResolveSubReport Event
ReportGenerator Class See Also Send Feedback
Occurs when subreport is resolved.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event ResolveSubReportEventHandler ResolveSubReport
Visual Basic (Declaration)
Public Event ResolveSubReport As ResolveSubReportEventHandler
Visual C++
public:
 event ResolveSubReportEventHandler^ ResolveSubReport {
    void add (ResolveSubReportEventHandler^ value);
    void remove (ResolveSubReportEventHandler^ value);
}

See Also

ReportGenerator Class
PerpetuumSoft.Reporting.Components Namespace


ReportManager Class

[image]

.NET ModelKit Suite ClassReference
ReportManager Class
Members See Also Send Feedback
Contains reports collection and datasources collection.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ReportManager : Component,
    IDataSourceManager, IResolveSubReport
Visual Basic (Declaration)
Public Class ReportManager _
    Inherits Component _
    Implements IDataSourceManager, IResolveSubReport
Visual C++
public ref class ReportManager : public Component,
    IDataSourceManager, IResolveSubReport

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Components..::.ReportManager

See Also

ReportManager Members
PerpetuumSoft.Reporting.Components Namespace


ReportManager Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportManager Members
ReportManager Class Constructors Methods Properties Events See Also Send Feedback

The ReportManager type exposes the following members.

Constructors

Name | Description
ReportManager | Overloaded.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetDataSource | Implements GetDataSource(String).
GetDataSources | Implements GetDataSources()()().
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetKnownDataSourceNames | Implements GetKnownDataSourceNames()()().
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSubReportTemplate | Implements GetSubReportTemplate(String).
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSources | Gets or sets DataSource collection.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
OwnerForm | Gets or sets owner form for the rendering progress dialog.
Reports | Gets a set of documents templates.
ReportScriptType | Gets or sets the type used as a basic one for the dynamically generated type of the document template scripts
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
GetAvailableTemplateNames | Represents the method for getting names of the avalable templates
GetReportParameter | Occurs when report parameters are received.
HyperlinkClick | Occurs when hyperlink is clicked.
ResolveDataSource | Occurs when DataSource is resolved.
ResolveSubReport | Occurs when subreport is resolved.
ResolveSubReportSource |

See Also

ReportManager Class
PerpetuumSoft.Reporting.Components Namespace


ReportManager Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ReportManager Constructor
ReportManager Class See Also Send Feedback

Overload List

Name | Description
ReportManager()()() | Initializes a new instance of the ReportManager class.
ReportManager(IContainer) | Initializes a new instance of the ReportManager class.

See Also

ReportManager Class
ReportManager Members
PerpetuumSoft.Reporting.Components Namespace


ReportManager Constructor

[image]

.NET ModelKit Suite ClassReference
ReportManager Constructor
ReportManager Class See Also Send Feedback
Initializes a new instance of the ReportManager class.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportManager()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportManager()

See Also

ReportManager Class
ReportManager Overload
PerpetuumSoft.Reporting.Components Namespace


ReportManager Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
ReportManager Constructor (IContainer)
ReportManager Class See Also Send Feedback
Initializes a new instance of the ReportManager class.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportManager(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
ReportManager(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

ReportManager Class
ReportManager Overload
PerpetuumSoft.Reporting.Components Namespace


ReportManager Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportManager Methods
ReportManager Class See Also Send Feedback

The ReportManager type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetDataSource | Implements GetDataSource(String).
GetDataSources | Implements GetDataSources()()().
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetKnownDataSourceNames | Implements GetKnownDataSourceNames()()().
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetSubReportTemplate | Implements GetSubReportTemplate(String).
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ReportManager Class
PerpetuumSoft.Reporting.Components Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportManager..::.Dispose Method
ReportManager Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

ReportManager Class
ReportManager Members
PerpetuumSoft.Reporting.Components Namespace


GetDataSource Method

[image]

.NET ModelKit Suite ClassReference
ReportManager..::.GetDataSource Method
ReportManager Class See Also Send Feedback
Implements GetDataSource(String).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object GetDataSource(
    string name
)
Visual Basic (Declaration)
Public Function GetDataSource ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetDataSource(
    String^ name
) sealed

Parameters

name
Type: System..::.String

Implements

IDataSourceManager..::.GetDataSource(String)

See Also

ReportManager Class
PerpetuumSoft.Reporting.Components Namespace


GetDataSources Method

[image]

.NET ModelKit Suite ClassReference
ReportManager..::.GetDataSources Method
ReportManager Class See Also Send Feedback
Implements GetDataSources()()().

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object[] GetDataSources()
Visual Basic (Declaration)
Public Function GetDataSources As Object()
Visual C++
public:
virtual array<Object^>^ GetDataSources() sealed

Implements

IDataSourceManager..::.GetDataSources()()()

See Also

ReportManager Class
PerpetuumSoft.Reporting.Components Namespace


GetKnownDataSourceNames Method

[image]

.NET ModelKit Suite ClassReference
ReportManager..::.GetKnownDataSourceNames Method
ReportManager Class See Also Send Feedback
Implements GetKnownDataSourceNames()()().

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string[] GetKnownDataSourceNames()
Visual Basic (Declaration)
Public Function GetKnownDataSourceNames As String()
Visual C++
public:
virtual array<String^>^ GetKnownDataSourceNames() sealed

Implements

IDataSourceManager..::.GetKnownDataSourceNames()()()

See Also

ReportManager Class
PerpetuumSoft.Reporting.Components Namespace


GetSubReportTemplate Method

[image]

.NET ModelKit Suite ClassReference
ReportManager..::.GetSubReportTemplate Method
ReportManager Class See Also Send Feedback
Implements GetSubReportTemplate(String).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Document GetSubReportTemplate(
    string name
)
Visual Basic (Declaration)
Public Function GetSubReportTemplate ( _
    name As String _
) As Document
Visual C++
public:
virtual Document^ GetSubReportTemplate(
    String^ name
) sealed

Parameters

name
Type: System..::.String

Implements

IResolveSubReport..::.GetSubReportTemplate(String)

See Also

ReportManager Class
PerpetuumSoft.Reporting.Components Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportManager..::.MemberwiseClone Method
ReportManager Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ReportManager Class
ReportManager Members
PerpetuumSoft.Reporting.Components Namespace


ReportManager Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportManager Properties
ReportManager Class See Also Send Feedback

The ReportManager type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DataSources | Gets or sets DataSource collection.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
OwnerForm | Gets or sets owner form for the rendering progress dialog.
Reports | Gets a set of documents templates.
ReportScriptType | Gets or sets the type used as a basic one for the dynamically generated type of the document template scripts
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

ReportManager Class
PerpetuumSoft.Reporting.Components Namespace


DataSources Property

[image]

.NET ModelKit Suite ClassReference
ReportManager..::.DataSources Property
ReportManager Class See Also Send Feedback
Gets or sets DataSource collection.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ObjectPointerCollection DataSources { get; set; }
Visual Basic (Declaration)
Public Property DataSources As ObjectPointerCollection
Visual C++
public:
property ObjectPointerCollection^ DataSources {
    ObjectPointerCollection^ get ();
    void set (ObjectPointerCollection^ value);
}

See Also

ReportManager Class
PerpetuumSoft.Reporting.Components Namespace


OwnerForm Property

[image]

.NET ModelKit Suite ClassReference
ReportManager..::.OwnerForm Property
ReportManager Class See Also Send Feedback
Gets or sets owner form for the rendering progress dialog.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Form OwnerForm { get; set; }
Visual Basic (Declaration)
Public Property OwnerForm As Form
Visual C++
public:
property Form^ OwnerForm {
    Form^ get ();
    void set (Form^ value);
}

See Also

ReportManager Class
PerpetuumSoft.Reporting.Components Namespace


Reports Property

[image]

.NET ModelKit Suite ClassReference
ReportManager..::.Reports Property
ReportManager Class See Also Send Feedback
Gets a set of documents templates.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportSlotCollection Reports { get; internal set; }
Visual Basic (Declaration)
Public Property Reports As ReportSlotCollection
Visual C++
public:
property ReportSlotCollection^ Reports {
    ReportSlotCollection^ get ();
    void set (ReportSlotCollection^ value);
}

See Also

ReportManager Class
PerpetuumSoft.Reporting.Components Namespace


ReportScriptType Property

[image]

.NET ModelKit Suite ClassReference
ReportManager..::.ReportScriptType Property
ReportManager Class See Also Send Feedback
Gets or sets the type used as a basic one for the dynamically generated type of the document template scripts

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Type ReportScriptType { get; set; }
Visual Basic (Declaration)
Public Property ReportScriptType As Type
Visual C++
public:
property Type^ ReportScriptType {
    Type^ get ();
    void set (Type^ value);
}

See Also

ReportManager Class
PerpetuumSoft.Reporting.Components Namespace


ReportManager Events

[image] [image]

.NET ModelKit Suite ClassReference
ReportManager Events
ReportManager Class See Also Send Feedback

The ReportManager type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
GetAvailableTemplateNames | Represents the method for getting names of the avalable templates
GetReportParameter | Occurs when report parameters are received.
HyperlinkClick | Occurs when hyperlink is clicked.
ResolveDataSource | Occurs when DataSource is resolved.
ResolveSubReport | Occurs when subreport is resolved.
ResolveSubReportSource |

See Also

ReportManager Class
PerpetuumSoft.Reporting.Components Namespace


GetAvailableTemplateNames Event

[image]

.NET ModelKit Suite ClassReference
ReportManager..::.GetAvailableTemplateNames Event
ReportManager Class See Also Send Feedback
Represents the method for getting names of the avalable templates

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event GetAvailableTemplateNamesEventHandler GetAvailableTemplateNames
Visual Basic (Declaration)
Public Event GetAvailableTemplateNames As GetAvailableTemplateNamesEventHandler
Visual C++
public:
 event GetAvailableTemplateNamesEventHandler^ GetAvailableTemplateNames {
    void add (GetAvailableTemplateNamesEventHandler^ value);
    void remove (GetAvailableTemplateNamesEventHandler^ value);
}

See Also

ReportManager Class
PerpetuumSoft.Reporting.Components Namespace


GetReportParameter Event

[image]

.NET ModelKit Suite ClassReference
ReportManager..::.GetReportParameter Event
ReportManager Class See Also Send Feedback
Occurs when report parameters are received.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event GetReportParameterEventHandler GetReportParameter
Visual Basic (Declaration)
Public Event GetReportParameter As GetReportParameterEventHandler
Visual C++
public:
 event GetReportParameterEventHandler^ GetReportParameter {
    void add (GetReportParameterEventHandler^ value);
    void remove (GetReportParameterEventHandler^ value);
}

See Also

ReportManager Class
PerpetuumSoft.Reporting.Components Namespace


HyperlinkClick Event

[image]

.NET ModelKit Suite ClassReference
ReportManager..::.HyperlinkClick Event
ReportManager Class See Also Send Feedback
Occurs when hyperlink is clicked.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event HyperlinkEventHandler HyperlinkClick
Visual Basic (Declaration)
Public Event HyperlinkClick As HyperlinkEventHandler
Visual C++
public:
 event HyperlinkEventHandler^ HyperlinkClick {
    void add (HyperlinkEventHandler^ value);
    void remove (HyperlinkEventHandler^ value);
}

See Also

ReportManager Class
PerpetuumSoft.Reporting.Components Namespace


ResolveDataSource Event

[image]

.NET ModelKit Suite ClassReference
ReportManager..::.ResolveDataSource Event
ReportManager Class See Also Send Feedback
Occurs when DataSource is resolved.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event ResolveDataSourceEventHandler ResolveDataSource
Visual Basic (Declaration)
Public Event ResolveDataSource As ResolveDataSourceEventHandler
Visual C++
public:
 event ResolveDataSourceEventHandler^ ResolveDataSource {
    void add (ResolveDataSourceEventHandler^ value);
    void remove (ResolveDataSourceEventHandler^ value);
}

See Also

ReportManager Class
PerpetuumSoft.Reporting.Components Namespace


ResolveSubReport Event

[image]

.NET ModelKit Suite ClassReference
ReportManager..::.ResolveSubReport Event
ReportManager Class See Also Send Feedback
Occurs when subreport is resolved.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event ResolveSubReportEventHandler ResolveSubReport
Visual Basic (Declaration)
Public Event ResolveSubReport As ResolveSubReportEventHandler
Visual C++
public:
 event ResolveSubReportEventHandler^ ResolveSubReport {
    void add (ResolveSubReportEventHandler^ value);
    void remove (ResolveSubReportEventHandler^ value);
}

See Also

ReportManager Class
PerpetuumSoft.Reporting.Components Namespace


ResolveSubReportSource Event

[image]

.NET ModelKit Suite ClassReference
ReportManager..::.ResolveSubReportSource Event
ReportManager Class See Also Send Feedback

[Missing <summary> documentation for E:PerpetuumSoft.Reporting.Components.ReportManager.ResolveSubReportSource]

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event ResolveSubReportSourceEventHandler ResolveSubReportSource
Visual Basic (Declaration)
Public Event ResolveSubReportSource As ResolveSubReportSourceEventHandler
Visual C++
public:
 event ResolveSubReportSourceEventHandler^ ResolveSubReportSource {
    void add (ResolveSubReportSourceEventHandler^ value);
    void remove (ResolveSubReportSourceEventHandler^ value);
}

See Also

ReportManager Class
PerpetuumSoft.Reporting.Components Namespace


ReportPrintDocument Class

[image]

.NET ModelKit Suite ClassReference
ReportPrintDocument Class
Members See Also Send Feedback
Provides document printing.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ReportPrintDocument : PrintDocument
Visual Basic (Declaration)
Public Class ReportPrintDocument _
    Inherits PrintDocument
Visual C++
public ref class ReportPrintDocument : public PrintDocument

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Drawing.Printing..::.PrintDocument
PerpetuumSoft.Reporting.Components..::.ReportPrintDocument

See Also

ReportPrintDocument Members
PerpetuumSoft.Reporting.Components Namespace


ReportPrintDocument Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportPrintDocument Members
ReportPrintDocument Class Constructors Methods Properties Events See Also Send Feedback

The ReportPrintDocument type exposes the following members.

Constructors

Name | Description
ReportPrintDocument | Initializes a new instance of the ReportPrintDocument class.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GoNextPage | Sets the next page as a current one.
HasMorePages | Returns value indicating that the current page is the last one in a document.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
OnBeginPrint | Overridden. See OnBeginPrint(PrintEventArgs). (Overrides PrintDocument..::.OnBeginPrint(PrintEventArgs).)
OnEndPrint | Raises the EndPrint event. It is called when the last page of the document has printed. (Inherited from PrintDocument.)
OnPrintPage | Overridden. See OnPrintPage(PrintPageEventArgs). (Overrides PrintDocument..::.OnPrintPage(PrintPageEventArgs).)
OnQueryPageSettings | Overridden. See [M:System.Drawing.Printing.PrintDocument.OnQueryPageSettings( System.Drawing.Printing.QueryPageSettingsEventArgs)]. (Overrides PrintDocument..::.OnQueryPageSettings(QueryPageSettingsEventArgs).)
Print | Starts the document's printing process. (Inherited from PrintDocument.)
Reset | Sets ReportPrintDocument in its initial state.
ToString | Provides information about the print document, in string form. (Inherited from PrintDocument.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DefaultPageSettings | Gets or sets page settings that are used as defaults for all pages to be printed. (Inherited from PrintDocument.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Document | Gets a document from source.
DocumentName | Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document. (Inherited from PrintDocument.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
LastPageNumber | Gets a number of the last page.
OriginAtMargins | Gets or sets a value indicating whether the position of a graphics object associated with a page is located just inside the user-specified margins or at the top-left corner of the printable area of the page. (Inherited from PrintDocument.)
PrintController | Gets or sets the print controller that guides the printing process. (Inherited from PrintDocument.)
PrintedPage | Gets a page currently printed.
PrintedPageNumber | Gets a page number currently printed.
PrinterSettings | Gets or sets the printer that prints the document. (Inherited from PrintDocument.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Source | Gets or sets reports source.

Events

Name | Description
BeginPrint | Occurs when the Print()()() method is called and before the first page of the document prints. (Inherited from PrintDocument.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
EndPrint | Occurs when the last page of the document has printed. (Inherited from PrintDocument.)
PrintPage | Occurs when the output to print for the current page is needed. (Inherited from PrintDocument.)
QueryPageSettings | Occurs immediately before each PrintPage event. (Inherited from PrintDocument.)

See Also

ReportPrintDocument Class
PerpetuumSoft.Reporting.Components Namespace


ReportPrintDocument Constructor

[image]

.NET ModelKit Suite ClassReference
ReportPrintDocument Constructor
ReportPrintDocument Class See Also Send Feedback
Initializes a new instance of the ReportPrintDocument class.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportPrintDocument()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportPrintDocument()

See Also

ReportPrintDocument Class
PerpetuumSoft.Reporting.Components Namespace


ReportPrintDocument Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportPrintDocument Methods
ReportPrintDocument Class See Also Send Feedback

The ReportPrintDocument type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GoNextPage | Sets the next page as a current one.
HasMorePages | Returns value indicating that the current page is the last one in a document.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
OnBeginPrint | Overridden. See OnBeginPrint(PrintEventArgs). (Overrides PrintDocument..::.OnBeginPrint(PrintEventArgs).)
OnEndPrint | Raises the EndPrint event. It is called when the last page of the document has printed. (Inherited from PrintDocument.)
OnPrintPage | Overridden. See OnPrintPage(PrintPageEventArgs). (Overrides PrintDocument..::.OnPrintPage(PrintPageEventArgs).)
OnQueryPageSettings | Overridden. See [M:System.Drawing.Printing.PrintDocument.OnQueryPageSettings( System.Drawing.Printing.QueryPageSettingsEventArgs)]. (Overrides PrintDocument..::.OnQueryPageSettings(QueryPageSettingsEventArgs).)
Print | Starts the document's printing process. (Inherited from PrintDocument.)
Reset | Sets ReportPrintDocument in its initial state.
ToString | Provides information about the print document, in string form. (Inherited from PrintDocument.)

See Also

ReportPrintDocument Class
PerpetuumSoft.Reporting.Components Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportPrintDocument..::.Dispose Method
ReportPrintDocument Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

ReportPrintDocument Class
ReportPrintDocument Members
PerpetuumSoft.Reporting.Components Namespace


GoNextPage Method

[image]

.NET ModelKit Suite ClassReference
ReportPrintDocument..::.GoNextPage Method
ReportPrintDocument Class See Also Send Feedback
Sets the next page as a current one.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void GoNextPage()
Visual Basic (Declaration)
Public Sub GoNextPage
Visual C++
public:
void GoNextPage()

See Also

ReportPrintDocument Class
PerpetuumSoft.Reporting.Components Namespace


HasMorePages Method

[image]

.NET ModelKit Suite ClassReference
ReportPrintDocument..::.HasMorePages Method
ReportPrintDocument Class See Also Send Feedback
Returns value indicating that the current page is the last one in a document.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool HasMorePages()
Visual Basic (Declaration)
Public Function HasMorePages As Boolean
Visual C++
public:
bool HasMorePages()

See Also

ReportPrintDocument Class
PerpetuumSoft.Reporting.Components Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportPrintDocument..::.MemberwiseClone Method
ReportPrintDocument Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ReportPrintDocument Class
ReportPrintDocument Members
PerpetuumSoft.Reporting.Components Namespace


OnBeginPrint Method

[image]

.NET ModelKit Suite ClassReference
ReportPrintDocument..::.OnBeginPrint Method
ReportPrintDocument Class See Also Send Feedback
Overridden. See OnBeginPrint(PrintEventArgs).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnBeginPrint(
    PrintEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnBeginPrint ( _
    e As PrintEventArgs _
)
Visual C++
protected:
virtual void OnBeginPrint(
    PrintEventArgs^ e
) override

Parameters

e
Type: System.Drawing.Printing..::.PrintEventArgs

See Also

ReportPrintDocument Class
PerpetuumSoft.Reporting.Components Namespace


OnPrintPage Method

[image]

.NET ModelKit Suite ClassReference
ReportPrintDocument..::.OnPrintPage Method
ReportPrintDocument Class See Also Send Feedback
Overridden. See OnPrintPage(PrintPageEventArgs).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnPrintPage(
    PrintPageEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnPrintPage ( _
    e As PrintPageEventArgs _
)
Visual C++
protected:
virtual void OnPrintPage(
    PrintPageEventArgs^ e
) override

Parameters

e
Type: System.Drawing.Printing..::.PrintPageEventArgs

See Also

ReportPrintDocument Class
PerpetuumSoft.Reporting.Components Namespace


OnQueryPageSettings Method

[image]

.NET ModelKit Suite ClassReference
ReportPrintDocument..::.OnQueryPageSettings Method
ReportPrintDocument Class See Also Send Feedback
Overridden. See [M:System.Drawing.Printing.PrintDocument.OnQueryPageSettings( System.Drawing.Printing.QueryPageSettingsEventArgs)].

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnQueryPageSettings(
    QueryPageSettingsEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnQueryPageSettings ( _
    e As QueryPageSettingsEventArgs _
)
Visual C++
protected:
virtual void OnQueryPageSettings(
    QueryPageSettingsEventArgs^ e
) override

Parameters

e
Type: System.Drawing.Printing..::.QueryPageSettingsEventArgs

See Also

ReportPrintDocument Class
PerpetuumSoft.Reporting.Components Namespace


Reset Method

[image]

.NET ModelKit Suite ClassReference
ReportPrintDocument..::.Reset Method
ReportPrintDocument Class See Also Send Feedback
Sets ReportPrintDocument in its initial state.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Reset()
Visual Basic (Declaration)
Public Sub Reset
Visual C++
public:
void Reset()

See Also

ReportPrintDocument Class
PerpetuumSoft.Reporting.Components Namespace


ReportPrintDocument Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportPrintDocument Properties
ReportPrintDocument Class See Also Send Feedback

The ReportPrintDocument type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DefaultPageSettings | Gets or sets page settings that are used as defaults for all pages to be printed. (Inherited from PrintDocument.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Document | Gets a document from source.
DocumentName | Gets or sets the document name to display (for example, in a print status dialog box or printer queue) while printing the document. (Inherited from PrintDocument.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
LastPageNumber | Gets a number of the last page.
OriginAtMargins | Gets or sets a value indicating whether the position of a graphics object associated with a page is located just inside the user-specified margins or at the top-left corner of the printable area of the page. (Inherited from PrintDocument.)
PrintController | Gets or sets the print controller that guides the printing process. (Inherited from PrintDocument.)
PrintedPage | Gets a page currently printed.
PrintedPageNumber | Gets a page number currently printed.
PrinterSettings | Gets or sets the printer that prints the document. (Inherited from PrintDocument.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Source | Gets or sets reports source.

See Also

ReportPrintDocument Class
PerpetuumSoft.Reporting.Components Namespace


Document Property

[image]

.NET ModelKit Suite ClassReference
ReportPrintDocument..::.Document Property
ReportPrintDocument Class See Also Send Feedback
Gets a document from source.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Document Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

ReportPrintDocument Class
PerpetuumSoft.Reporting.Components Namespace


LastPageNumber Property

[image]

.NET ModelKit Suite ClassReference
ReportPrintDocument..::.LastPageNumber Property
ReportPrintDocument Class See Also Send Feedback
Gets a number of the last page.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int LastPageNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property LastPageNumber As Integer
Visual C++
public:
property int LastPageNumber {
    int get ();
}

See Also

ReportPrintDocument Class
PerpetuumSoft.Reporting.Components Namespace


PrintedPage Property

[image]

.NET ModelKit Suite ClassReference
ReportPrintDocument..::.PrintedPage Property
ReportPrintDocument Class See Also Send Feedback
Gets a page currently printed.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Page PrintedPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintedPage As Page
Visual C++
public:
property Page^ PrintedPage {
    Page^ get ();
}

See Also

ReportPrintDocument Class
PerpetuumSoft.Reporting.Components Namespace


PrintedPageNumber Property

[image]

.NET ModelKit Suite ClassReference
ReportPrintDocument..::.PrintedPageNumber Property
ReportPrintDocument Class See Also Send Feedback
Gets a page number currently printed.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int PrintedPageNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintedPageNumber As Integer
Visual C++
public:
property int PrintedPageNumber {
    int get ();
}

See Also

ReportPrintDocument Class
PerpetuumSoft.Reporting.Components Namespace


Source Property

[image]

.NET ModelKit Suite ClassReference
ReportPrintDocument..::.Source Property
ReportPrintDocument Class See Also Send Feedback
Gets or sets reports source.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public IReportSource Source { get; set; }
Visual Basic (Declaration)
Public Property Source As IReportSource
Visual C++
public:
property IReportSource^ Source {
    IReportSource^ get ();
    void set (IReportSource^ value);
}

See Also

ReportPrintDocument Class
PerpetuumSoft.Reporting.Components Namespace


ReportPrintDocument Events

[image] [image]

.NET ModelKit Suite ClassReference
ReportPrintDocument Events
ReportPrintDocument Class See Also Send Feedback

The ReportPrintDocument type exposes the following members.

Events

Name | Description
BeginPrint | Occurs when the Print()()() method is called and before the first page of the document prints. (Inherited from PrintDocument.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
EndPrint | Occurs when the last page of the document has printed. (Inherited from PrintDocument.)
PrintPage | Occurs when the output to print for the current page is needed. (Inherited from PrintDocument.)
QueryPageSettings | Occurs immediately before each PrintPage event. (Inherited from PrintDocument.)

See Also

ReportPrintDocument Class
PerpetuumSoft.Reporting.Components Namespace


ReportSlot Class

[image]

.NET ModelKit Suite ClassReference
ReportSlot Class
Members See Also Send Feedback
Represents base class for report sources.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract class ReportSlot : Component,
    IReportSource
Visual Basic (Declaration)
Public MustInherit Class ReportSlot _
    Inherits Component _
    Implements IReportSource
Visual C++
public ref class ReportSlot abstract : public Component,
    IReportSource

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Components..::.ReportSlot
PerpetuumSoft.Reporting.Components..::.FileReportSlot
PerpetuumSoft.Reporting.Components..::.InlineReportSlot
PerpetuumSoft.Reporting.Components..::.UrlReportSlot

See Also

ReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


ReportSlot Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportSlot Members
ReportSlot Class Constructors Methods Properties Events See Also Send Feedback

The ReportSlot type exposes the following members.

Constructors

Name | Description
ReportSlot | Initializes a new instance of the ReportSlot class

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DesignTemplate | Runs report designer and opens a document corresponding to the given ReportSlot in it.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
LoadReport | Returns report corresponding to the given ReportSlot.
MemberwiseClone | Overloaded.
OnGetReportParameter | Implements OnGetReportParameter(GetReportParameterEventArgs).
OnHyperlinkClick | Implements OnHyperlinkClick(HyperlinkEventArgs).
OnRenderCanceled | Implements OnRenderCanceled(EventArgs).
OnRenderingError | Implements OnRenderingError(RenderingErrorEventArgs).
Prepare | Overloaded.
RenderDocument | Overloaded.
SaveReport | Saves the given document.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Document | Implements Document.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExceptionMode | Gets or sets exception mode for ReportSlot.
Manager | Gets manager for ReportSlot.
ReportName | Gets or sets report name.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StyleSheet | Gets or sets ReportSlot styles.
SupportsSaving | Gets value indicating whether ReportSlot will save report or not.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
GetReportParameter | Implements GetReportParameter.
HyperlinkClick | Implements HyperlinkClick.
RenderCanceled | Occurs when rendering has been canceled
RenderCompleted | Implements RenderCompleted.
RenderingError | Occurs when the rendering is completed with an error.

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


ReportSlot Constructor

[image]

.NET ModelKit Suite ClassReference
ReportSlot Constructor
ReportSlot Class See Also Send Feedback
Initializes a new instance of the ReportSlot class

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected ReportSlot()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ReportSlot()

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


ReportSlot Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportSlot Methods
ReportSlot Class See Also Send Feedback

The ReportSlot type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DesignTemplate | Runs report designer and opens a document corresponding to the given ReportSlot in it.
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
LoadReport | Returns report corresponding to the given ReportSlot.
MemberwiseClone | Overloaded.
OnGetReportParameter | Implements OnGetReportParameter(GetReportParameterEventArgs).
OnHyperlinkClick | Implements OnHyperlinkClick(HyperlinkEventArgs).
OnRenderCanceled | Implements OnRenderCanceled(EventArgs).
OnRenderingError | Implements OnRenderingError(RenderingErrorEventArgs).
Prepare | Overloaded.
RenderDocument | Overloaded.
SaveReport | Saves the given document.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


DesignTemplate Method

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.DesignTemplate Method
ReportSlot Class See Also Send Feedback
Runs report designer and opens a document corresponding to the given ReportSlot in it.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void DesignTemplate()
Visual Basic (Declaration)
Public Sub DesignTemplate
Visual C++
public:
void DesignTemplate()

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportSlot..::.Dispose Method
ReportSlot Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

ReportSlot Class
ReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


LoadReport Method

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.LoadReport Method
ReportSlot Class See Also Send Feedback
Returns report corresponding to the given ReportSlot.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract Document LoadReport()
Visual Basic (Declaration)
Public MustOverride Function LoadReport As Document
Visual C++
public:
virtual Document^ LoadReport() abstract

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportSlot..::.MemberwiseClone Method
ReportSlot Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ReportSlot Class
ReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


OnGetReportParameter Method

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.OnGetReportParameter Method
ReportSlot Class See Also Send Feedback
Implements OnGetReportParameter(GetReportParameterEventArgs).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual void OnGetReportParameter(
    GetReportParameterEventArgs args
)
Visual Basic (Declaration)
Public Overridable Sub OnGetReportParameter ( _
    args As GetReportParameterEventArgs _
)
Visual C++
public:
virtual void OnGetReportParameter(
    GetReportParameterEventArgs^ args
)

Parameters

args
Type: PerpetuumSoft.Reporting.Components..::.GetReportParameterEventArgs

Implements

IReportSource..::.OnGetReportParameter(GetReportParameterEventArgs)

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


OnHyperlinkClick Method

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.OnHyperlinkClick Method
ReportSlot Class See Also Send Feedback
Implements OnHyperlinkClick(HyperlinkEventArgs).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void OnHyperlinkClick(
    HyperlinkEventArgs args
)
Visual Basic (Declaration)
Public Sub OnHyperlinkClick ( _
    args As HyperlinkEventArgs _
)
Visual C++
public:
virtual void OnHyperlinkClick(
    HyperlinkEventArgs^ args
) sealed

Parameters

args
Type: PerpetuumSoft.Reporting.Components..::.HyperlinkEventArgs

Implements

IReportSource..::.OnHyperlinkClick(HyperlinkEventArgs)

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


OnRenderCanceled Method

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.OnRenderCanceled Method
ReportSlot Class See Also Send Feedback
Implements OnRenderCanceled(EventArgs).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual void OnRenderCanceled(
    EventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnRenderCanceled ( _
    e As EventArgs _
)
Visual C++
public:
virtual void OnRenderCanceled(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

Implements

IReportSource..::.OnRenderCanceled(EventArgs)

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


OnRenderingError Method

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.OnRenderingError Method
ReportSlot Class See Also Send Feedback
Implements OnRenderingError(RenderingErrorEventArgs).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual void OnRenderingError(
    RenderingErrorEventArgs e
)
Visual Basic (Declaration)
Public Overridable Sub OnRenderingError ( _
    e As RenderingErrorEventArgs _
)
Visual C++
public:
virtual void OnRenderingError(
    RenderingErrorEventArgs^ e
)

Parameters

e
Type: PerpetuumSoft.Reporting.Components..::.RenderingErrorEventArgs

Implements

IReportSource..::.OnRenderingError(RenderingErrorEventArgs)

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


Prepare Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportSlot..::.Prepare Method
ReportSlot Class See Also Send Feedback

Overload List

Name | Description
Prepare()()() | Implements Prepare()()().
Prepare(IRenderSite) | Implements ['M:PerpetuumSoft.Reporting.Components.IReportSource.Prepare()].

See Also

ReportSlot Class
ReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


Prepare Method

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.Prepare Method
ReportSlot Class See Also Send Feedback
Implements Prepare()()().

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Prepare()
Visual Basic (Declaration)
Public Sub Prepare
Visual C++
public:
virtual void Prepare() sealed

Implements

IReportSource..::.Prepare()()()

See Also

ReportSlot Class
Prepare Overload
PerpetuumSoft.Reporting.Components Namespace


Prepare Method (IRenderSite)

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.Prepare Method (IRenderSite)
ReportSlot Class See Also Send Feedback
Implements ['M:PerpetuumSoft.Reporting.Components.IReportSource.Prepare()].

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Prepare(
    IRenderSite renderSite
)
Visual Basic (Declaration)
Public Sub Prepare ( _
    renderSite As IRenderSite _
)
Visual C++
public:
void Prepare(
    IRenderSite^ renderSite
)

Parameters

renderSite
Type: PerpetuumSoft.Reporting.Rendering..::.IRenderSite

See Also

ReportSlot Class
Prepare Overload
PerpetuumSoft.Reporting.Components Namespace


RenderDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportSlot..::.RenderDocument Method
ReportSlot Class See Also Send Feedback

Overload List

Name | Description
RenderDocument()()() | Implements RenderDocument()()().
RenderDocument(IRenderSite) | Implements ['M:PerpetuumSoft.Reporting.Components.IReportSource.RenderDocument(PerpetuumSoft.Reporting.Rendering.IRenderSite)].

See Also

ReportSlot Class
ReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


RenderDocument Method

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.RenderDocument Method
ReportSlot Class See Also Send Feedback
Implements RenderDocument()()().

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Document RenderDocument()
Visual Basic (Declaration)
Public Function RenderDocument As Document
Visual C++
public:
virtual Document^ RenderDocument() sealed

Implements

IReportSource..::.RenderDocument()()()

See Also

ReportSlot Class
RenderDocument Overload
PerpetuumSoft.Reporting.Components Namespace


RenderDocument Method (IRenderSite)

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.RenderDocument Method (IRenderSite)
ReportSlot Class See Also Send Feedback
Implements ['M:PerpetuumSoft.Reporting.Components.IReportSource.RenderDocument(PerpetuumSoft.Reporting.Rendering.IRenderSite)].

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Document RenderDocument(
    IRenderSite renderSite
)
Visual Basic (Declaration)
Public Function RenderDocument ( _
    renderSite As IRenderSite _
) As Document
Visual C++
public:
Document^ RenderDocument(
    IRenderSite^ renderSite
)

Parameters

renderSite
Type: PerpetuumSoft.Reporting.Rendering..::.IRenderSite

See Also

ReportSlot Class
RenderDocument Overload
PerpetuumSoft.Reporting.Components Namespace


SaveReport Method

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.SaveReport Method
ReportSlot Class See Also Send Feedback
Saves the given document.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract void SaveReport(
    Document document
)
Visual Basic (Declaration)
Public MustOverride Sub SaveReport ( _
    document As Document _
)
Visual C++
public:
virtual void SaveReport(
    Document^ document
) abstract

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


ReportSlot Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportSlot Properties
ReportSlot Class See Also Send Feedback

The ReportSlot type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Document | Implements Document.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExceptionMode | Gets or sets exception mode for ReportSlot.
Manager | Gets manager for ReportSlot.
ReportName | Gets or sets report name.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StyleSheet | Gets or sets ReportSlot styles.
SupportsSaving | Gets value indicating whether ReportSlot will save report or not.

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


Document Property

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.Document Property
ReportSlot Class See Also Send Feedback
Implements Document.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Document Document { get; set; }
Visual Basic (Declaration)
Public Property Document As Document
Visual C++
public:
virtual property Document^ Document {
    Document^ get () sealed;
    void set (Document^ value) sealed;
}

Implements

IReportSource..::.Document

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


ExceptionMode Property

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.ExceptionMode Property
ReportSlot Class See Also Send Feedback
Gets or sets exception mode for ReportSlot.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ExceptionMode ExceptionMode { get; set; }
Visual Basic (Declaration)
Public Property ExceptionMode As ExceptionMode
Visual C++
public:
property ExceptionMode ExceptionMode {
    ExceptionMode get ();
    void set (ExceptionMode value);
}

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


Manager Property

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.Manager Property
ReportSlot Class See Also Send Feedback
Gets manager for ReportSlot.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportManager Manager { get; }
Visual Basic (Declaration)
Public ReadOnly Property Manager As ReportManager
Visual C++
public:
property ReportManager^ Manager {
    ReportManager^ get ();
}

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


ReportName Property

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.ReportName Property
ReportSlot Class See Also Send Feedback
Gets or sets report name.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string ReportName { get; set; }
Visual Basic (Declaration)
Public Property ReportName As String
Visual C++
public:
property String^ ReportName {
    String^ get ();
    void set (String^ value);
}

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


StyleSheet Property

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.StyleSheet Property
ReportSlot Class See Also Send Feedback
Gets or sets ReportSlot styles.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public StyleSheet StyleSheet { get; set; }
Visual Basic (Declaration)
Public Property StyleSheet As StyleSheet
Visual C++
public:
property StyleSheet^ StyleSheet {
    StyleSheet^ get ();
    void set (StyleSheet^ value);
}

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


SupportsSaving Property

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.SupportsSaving Property
ReportSlot Class See Also Send Feedback
Gets value indicating whether ReportSlot will save report or not.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract bool SupportsSaving { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property SupportsSaving As Boolean
Visual C++
public:
virtual property bool SupportsSaving {
    bool get () abstract;
}

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


ReportSlot Events

[image] [image]

.NET ModelKit Suite ClassReference
ReportSlot Events
ReportSlot Class See Also Send Feedback

The ReportSlot type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
GetReportParameter | Implements GetReportParameter.
HyperlinkClick | Implements HyperlinkClick.
RenderCanceled | Occurs when rendering has been canceled
RenderCompleted | Implements RenderCompleted.
RenderingError | Occurs when the rendering is completed with an error.

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


GetReportParameter Event

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.GetReportParameter Event
ReportSlot Class See Also Send Feedback
Implements GetReportParameter.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event GetReportParameterEventHandler GetReportParameter
Visual Basic (Declaration)
Public Event GetReportParameter As GetReportParameterEventHandler
Visual C++
public:
virtual  event GetReportParameterEventHandler^ GetReportParameter {
    void add (GetReportParameterEventHandler^ value);
    void remove (GetReportParameterEventHandler^ value);
}

Implements

IReportSource..::.GetReportParameter

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


HyperlinkClick Event

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.HyperlinkClick Event
ReportSlot Class See Also Send Feedback
Implements HyperlinkClick.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event HyperlinkEventHandler HyperlinkClick
Visual Basic (Declaration)
Public Event HyperlinkClick As HyperlinkEventHandler
Visual C++
public:
virtual  event HyperlinkEventHandler^ HyperlinkClick {
    void add (HyperlinkEventHandler^ value);
    void remove (HyperlinkEventHandler^ value);
}

Implements

IReportSource..::.HyperlinkClick

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


RenderCanceled Event

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.RenderCanceled Event
ReportSlot Class See Also Send Feedback
Occurs when rendering has been canceled

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler RenderCanceled
Visual Basic (Declaration)
Public Event RenderCanceled As EventHandler
Visual C++
public:
virtual  event EventHandler^ RenderCanceled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Implements

IReportSource..::.RenderCanceled

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


RenderCompleted Event

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.RenderCompleted Event
ReportSlot Class See Also Send Feedback
Implements RenderCompleted.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler RenderCompleted
Visual Basic (Declaration)
Public Event RenderCompleted As EventHandler
Visual C++
public:
virtual  event EventHandler^ RenderCompleted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Implements

IReportSource..::.RenderCompleted

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


RenderingError Event

[image]

.NET ModelKit Suite ClassReference
ReportSlot..::.RenderingError Event
ReportSlot Class See Also Send Feedback
Occurs when the rendering is completed with an error.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler<RenderingErrorEventArgs> RenderingError
Visual Basic (Declaration)
Public Event RenderingError As EventHandler(Of RenderingErrorEventArgs)
Visual C++
public:
virtual  event EventHandler<RenderingErrorEventArgs^>^ RenderingError {
    void add (EventHandler<RenderingErrorEventArgs^>^ value);
    void remove (EventHandler<RenderingErrorEventArgs^>^ value);
}

Implements

IReportSource..::.RenderingError

See Also

ReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


ReportSlotCollection Class

[image]

.NET ModelKit Suite ClassReference
ReportSlotCollection Class
Members See Also Send Feedback
Represents collection of ReportSlots.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ReportSlotCollection : CollectionBase
Visual Basic (Declaration)
Public Class ReportSlotCollection _
    Inherits CollectionBase
Visual C++
public ref class ReportSlotCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Reporting.Components..::.ReportSlotCollection

See Also

ReportSlotCollection Members
PerpetuumSoft.Reporting.Components Namespace


ReportSlotCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportSlotCollection Members
ReportSlotCollection Class Constructors Methods Properties See Also Send Feedback

The ReportSlotCollection type exposes the following members.

Constructors

Name | Description
ReportSlotCollection | Initializes a new instance of the ReportSlotCollection class.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Adds a report slots to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the ReportSlotCollection instance. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the ReportSlotCollection instance. (Overrides CollectionBase..::.OnRemove(Int32, Object).)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ReportSlotCollection Class
PerpetuumSoft.Reporting.Components Namespace


ReportSlotCollection Constructor

[image]

.NET ModelKit Suite ClassReference
ReportSlotCollection Constructor
ReportSlotCollection Class See Also Send Feedback
Initializes a new instance of the ReportSlotCollection class.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportSlotCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportSlotCollection()

See Also

ReportSlotCollection Class
PerpetuumSoft.Reporting.Components Namespace


ReportSlotCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportSlotCollection Methods
ReportSlotCollection Class See Also Send Feedback

The ReportSlotCollection type exposes the following members.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Adds a report slots to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the ReportSlotCollection instance. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the ReportSlotCollection instance. (Overrides CollectionBase..::.OnRemove(Int32, Object).)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportSlotCollection Class
PerpetuumSoft.Reporting.Components Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
ReportSlotCollection..::.Add Method
ReportSlotCollection Class See Also Send Feedback
Implements Add(Object).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportSlot Add(
    ReportSlot value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As ReportSlot _
) As ReportSlot
Visual C++
public:
ReportSlot^ Add(
    ReportSlot^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Components..::.ReportSlot

See Also

ReportSlotCollection Class
PerpetuumSoft.Reporting.Components Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
ReportSlotCollection..::.AddRange Method
ReportSlotCollection Class See Also Send Feedback
Adds a report slots to the collection.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    ReportSlot[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As ReportSlot() _
)
Visual C++
public:
void AddRange(
    array<ReportSlot^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Reporting.Components..::.ReportSlot >[]()[]

See Also

ReportSlotCollection Class
PerpetuumSoft.Reporting.Components Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
ReportSlotCollection..::.Contains Method
ReportSlotCollection Class See Also Send Feedback
Implements Contains(Object).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    ReportSlot value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As ReportSlot _
) As Boolean
Visual C++
public:
bool Contains(
    ReportSlot^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Components..::.ReportSlot

See Also

ReportSlotCollection Class
PerpetuumSoft.Reporting.Components Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
ReportSlotCollection..::.IndexOf Method
ReportSlotCollection Class See Also Send Feedback
Implements IndexOf(Object).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    ReportSlot value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As ReportSlot _
) As Integer
Visual C++
public:
int IndexOf(
    ReportSlot^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Components..::.ReportSlot

See Also

ReportSlotCollection Class
PerpetuumSoft.Reporting.Components Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
ReportSlotCollection..::.Insert Method
ReportSlotCollection Class See Also Send Feedback
Implements Insert(Int32, Object).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    ReportSlot value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As ReportSlot _
)
Visual C++
public:
void Insert(
    int index,
    ReportSlot^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Reporting.Components..::.ReportSlot

See Also

ReportSlotCollection Class
PerpetuumSoft.Reporting.Components Namespace


OnInsert Method

[image]

.NET ModelKit Suite ClassReference
ReportSlotCollection..::.OnInsert Method
ReportSlotCollection Class See Also Send Feedback
Performs additional custom processes before inserting a new element into the ReportSlotCollection instance.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsert(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsert ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsert(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ReportSlotCollection Class
PerpetuumSoft.Reporting.Components Namespace


OnRemove Method

[image]

.NET ModelKit Suite ClassReference
ReportSlotCollection..::.OnRemove Method
ReportSlotCollection Class See Also Send Feedback
Performs additional custom processes when removing an element from the ReportSlotCollection instance.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnRemove(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemove ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemove(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ReportSlotCollection Class
PerpetuumSoft.Reporting.Components Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
ReportSlotCollection..::.Remove Method
ReportSlotCollection Class See Also Send Feedback
Implements Remove(Object).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    ReportSlot value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As ReportSlot _
)
Visual C++
public:
void Remove(
    ReportSlot^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Components..::.ReportSlot

See Also

ReportSlotCollection Class
PerpetuumSoft.Reporting.Components Namespace


ReportSlotCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportSlotCollection Properties
ReportSlotCollection Class See Also Send Feedback

The ReportSlotCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ReportSlotCollection Class
PerpetuumSoft.Reporting.Components Namespace


Item Property

[image] [image]

.NET ModelKit Suite ClassReference
ReportSlotCollection..::.Item Property
ReportSlotCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Implements Item[([(Int32])]).
Item[([(String])]) | Gets a control from the collection by the given name.

See Also

ReportSlotCollection Class
ReportSlotCollection Members
PerpetuumSoft.Reporting.Components Namespace


Item Property (Int32)

[image]

.NET ModelKit Suite ClassReference
ReportSlotCollection..::.Item Property (Int32)
ReportSlotCollection Class See Also Send Feedback
Implements Item[([(Int32])]).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportSlot this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As ReportSlot
Visual C++
public:
property ReportSlot^ default[int index] {
    ReportSlot^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

ReportSlotCollection Class
Item Overload
PerpetuumSoft.Reporting.Components Namespace


Item Property (String)

[image]

.NET ModelKit Suite ClassReference
ReportSlotCollection..::.Item Property (String)
ReportSlotCollection Class See Also Send Feedback
Gets a control from the collection by the given name.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportSlot this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As ReportSlot
Visual C++
public:
property ReportSlot^ default[String^ name] {
    ReportSlot^ get (String^ name);
}

Parameters

name
Type: System..::.String

See Also

ReportSlotCollection Class
Item Overload
PerpetuumSoft.Reporting.Components Namespace


ResolveDataSourceEventArgs Class

[image]

.NET ModelKit Suite ClassReference
ResolveDataSourceEventArgs Class
Members See Also Send Feedback
Provides data for the ResolveDataSource event.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ResolveDataSourceEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ResolveDataSourceEventArgs _
    Inherits EventArgs
Visual C++
public ref class ResolveDataSourceEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.Components..::.ResolveDataSourceEventArgs

See Also

ResolveDataSourceEventArgs Members
PerpetuumSoft.Reporting.Components Namespace


ResolveDataSourceEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
ResolveDataSourceEventArgs Members
ResolveDataSourceEventArgs Class Methods Properties See Also Send Feedback

The ResolveDataSourceEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DataSource | Gets or sets data source.
DataSourceName | Gets or sets data source name.

See Also

ResolveDataSourceEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


ResolveDataSourceEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
ResolveDataSourceEventArgs Methods
ResolveDataSourceEventArgs Class See Also Send Feedback

The ResolveDataSourceEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResolveDataSourceEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


ResolveDataSourceEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
ResolveDataSourceEventArgs Properties
ResolveDataSourceEventArgs Class See Also Send Feedback

The ResolveDataSourceEventArgs type exposes the following members.

Properties

Name | Description
DataSource | Gets or sets data source.
DataSourceName | Gets or sets data source name.

See Also

ResolveDataSourceEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


DataSource Property

[image]

.NET ModelKit Suite ClassReference
ResolveDataSourceEventArgs..::.DataSource Property
ResolveDataSourceEventArgs Class See Also Send Feedback
Gets or sets data source.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As Object
Visual C++
public:
property Object^ DataSource {
    Object^ get ();
    void set (Object^ value);
}

See Also

ResolveDataSourceEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


DataSourceName Property

[image]

.NET ModelKit Suite ClassReference
ResolveDataSourceEventArgs..::.DataSourceName Property
ResolveDataSourceEventArgs Class See Also Send Feedback
Gets or sets data source name.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string DataSourceName { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataSourceName As String
Visual C++
public:
property String^ DataSourceName {
    String^ get ();
}

See Also

ResolveDataSourceEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


ResolveDataSourceEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
ResolveDataSourceEventHandler Delegate
See Also Send Feedback
Represents method that will handle the ResolveDataSource event.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate void ResolveDataSourceEventHandler(
    Object sender,
    ResolveDataSourceEventArgs args
)
Visual Basic (Declaration)
Public Delegate Sub ResolveDataSourceEventHandler ( _
    sender As Object, _
    args As ResolveDataSourceEventArgs _
)
Visual C++
public delegate void ResolveDataSourceEventHandler(
    Object^ sender,
    ResolveDataSourceEventArgs^ args
)

Parameters

sender
Type: System..::.Object
args
Type: PerpetuumSoft.Reporting.Components..::.ResolveDataSourceEventArgs

See Also

PerpetuumSoft.Reporting.Components Namespace


ResolveSubReportEventArgs Class

[image]

.NET ModelKit Suite ClassReference
ResolveSubReportEventArgs Class
Members See Also Send Feedback
Provides data for the ResolveSubReport event.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ResolveSubReportEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ResolveSubReportEventArgs _
    Inherits EventArgs
Visual C++
public ref class ResolveSubReportEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.Components..::.ResolveSubReportEventArgs

See Also

ResolveSubReportEventArgs Members
PerpetuumSoft.Reporting.Components Namespace


ResolveSubReportEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
ResolveSubReportEventArgs Members
ResolveSubReportEventArgs Class Constructors Methods Properties See Also Send Feedback

The ResolveSubReportEventArgs type exposes the following members.

Constructors

Name | Description
ResolveSubReportEventArgs | Initializes a new instance of the ResolveSubReportEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Template | Gets or sets document template.
TemplateName | Gets document template name.

See Also

ResolveSubReportEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


ResolveSubReportEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
ResolveSubReportEventArgs Constructor
ResolveSubReportEventArgs Class See Also Send Feedback
Initializes a new instance of the ResolveSubReportEventArgs class.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ResolveSubReportEventArgs(
    string templateName
)
Visual Basic (Declaration)
Public Sub New ( _
    templateName As String _
)
Visual C++
public:
ResolveSubReportEventArgs(
    String^ templateName
)

Parameters

templateName
Type: System..::.String

See Also

ResolveSubReportEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


ResolveSubReportEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
ResolveSubReportEventArgs Methods
ResolveSubReportEventArgs Class See Also Send Feedback

The ResolveSubReportEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResolveSubReportEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


ResolveSubReportEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
ResolveSubReportEventArgs Properties
ResolveSubReportEventArgs Class See Also Send Feedback

The ResolveSubReportEventArgs type exposes the following members.

Properties

Name | Description
Template | Gets or sets document template.
TemplateName | Gets document template name.

See Also

ResolveSubReportEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


Template Property

[image]

.NET ModelKit Suite ClassReference
ResolveSubReportEventArgs..::.Template Property
ResolveSubReportEventArgs Class See Also Send Feedback
Gets or sets document template.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Document Template { get; set; }
Visual Basic (Declaration)
Public Property Template As Document
Visual C++
public:
property Document^ Template {
    Document^ get ();
    void set (Document^ value);
}

See Also

ResolveSubReportEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


TemplateName Property

[image]

.NET ModelKit Suite ClassReference
ResolveSubReportEventArgs..::.TemplateName Property
ResolveSubReportEventArgs Class See Also Send Feedback
Gets document template name.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string TemplateName { get; }
Visual Basic (Declaration)
Public ReadOnly Property TemplateName As String
Visual C++
public:
property String^ TemplateName {
    String^ get ();
}

See Also

ResolveSubReportEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


ResolveSubReportEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
ResolveSubReportEventHandler Delegate
See Also Send Feedback
Represents method that will handle the ResolveSubReport event.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate void ResolveSubReportEventHandler(
    Object sender,
    ResolveSubReportEventArgs args
)
Visual Basic (Declaration)
Public Delegate Sub ResolveSubReportEventHandler ( _
    sender As Object, _
    args As ResolveSubReportEventArgs _
)
Visual C++
public delegate void ResolveSubReportEventHandler(
    Object^ sender,
    ResolveSubReportEventArgs^ args
)

Parameters

sender
Type: System..::.Object
args
Type: PerpetuumSoft.Reporting.Components..::.ResolveSubReportEventArgs

See Also

PerpetuumSoft.Reporting.Components Namespace


ResolveSubReportSourceEventArgs Class

[image]

.NET ModelKit Suite ClassReference
ResolveSubReportSourceEventArgs Class
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Reporting.Components.ResolveSubReportSourceEventArgs]

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ResolveSubReportSourceEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ResolveSubReportSourceEventArgs _
    Inherits EventArgs
Visual C++
public ref class ResolveSubReportSourceEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.Components..::.ResolveSubReportSourceEventArgs

See Also

ResolveSubReportSourceEventArgs Members
PerpetuumSoft.Reporting.Components Namespace


ResolveSubReportSourceEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
ResolveSubReportSourceEventArgs Members
ResolveSubReportSourceEventArgs Class Constructors Methods Properties See Also Send Feedback

The ResolveSubReportSourceEventArgs type exposes the following members.

Constructors

Name | Description
ResolveSubReportSourceEventArgs | Initializes a new instance of the ResolveSubReportSourceEventArgs class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ReportSource |
TemplateName |

See Also

ResolveSubReportSourceEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


ResolveSubReportSourceEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
ResolveSubReportSourceEventArgs Constructor
ResolveSubReportSourceEventArgs Class See Also Send Feedback
Initializes a new instance of the ResolveSubReportSourceEventArgs class

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ResolveSubReportSourceEventArgs(
    string templateName
)
Visual Basic (Declaration)
Public Sub New ( _
    templateName As String _
)
Visual C++
public:
ResolveSubReportSourceEventArgs(
    String^ templateName
)

Parameters

templateName
Type: System..::.String

See Also

ResolveSubReportSourceEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


ResolveSubReportSourceEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
ResolveSubReportSourceEventArgs Methods
ResolveSubReportSourceEventArgs Class See Also Send Feedback

The ResolveSubReportSourceEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResolveSubReportSourceEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


ResolveSubReportSourceEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
ResolveSubReportSourceEventArgs Properties
ResolveSubReportSourceEventArgs Class See Also Send Feedback

The ResolveSubReportSourceEventArgs type exposes the following members.

Properties

Name | Description
ReportSource |
TemplateName |

See Also

ResolveSubReportSourceEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


ReportSource Property

[image]

.NET ModelKit Suite ClassReference
ResolveSubReportSourceEventArgs..::.ReportSource Property
ResolveSubReportSourceEventArgs Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.Components.ResolveSubReportSourceEventArgs.ReportSource]

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public IReportSource ReportSource { get; set; }
Visual Basic (Declaration)
Public Property ReportSource As IReportSource
Visual C++
public:
property IReportSource^ ReportSource {
    IReportSource^ get ();
    void set (IReportSource^ value);
}

See Also

ResolveSubReportSourceEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


TemplateName Property

[image]

.NET ModelKit Suite ClassReference
ResolveSubReportSourceEventArgs..::.TemplateName Property
ResolveSubReportSourceEventArgs Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.Components.ResolveSubReportSourceEventArgs.TemplateName]

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string TemplateName { get; }
Visual Basic (Declaration)
Public ReadOnly Property TemplateName As String
Visual C++
public:
property String^ TemplateName {
    String^ get ();
}

See Also

ResolveSubReportSourceEventArgs Class
PerpetuumSoft.Reporting.Components Namespace


ResolveSubReportSourceEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
ResolveSubReportSourceEventHandler Delegate
See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Reporting.Components.ResolveSubReportSourceEventHandler]

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate void ResolveSubReportSourceEventHandler(
    Object sender,
    ResolveSubReportSourceEventArgs args
)
Visual Basic (Declaration)
Public Delegate Sub ResolveSubReportSourceEventHandler ( _
    sender As Object, _
    args As ResolveSubReportSourceEventArgs _
)
Visual C++
public delegate void ResolveSubReportSourceEventHandler(
    Object^ sender,
    ResolveSubReportSourceEventArgs^ args
)

Parameters

sender
Type: System..::.Object
args
Type: PerpetuumSoft.Reporting.Components..::.ResolveSubReportSourceEventArgs

See Also

PerpetuumSoft.Reporting.Components Namespace


ShowProgressDelegate Delegate

[image]

.NET ModelKit Suite ClassReference
ShowProgressDelegate Delegate
See Also Send Feedback
Represents method that will handle the ShowProgress event.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate void ShowProgressDelegate(
    string state,
    string substate
)
Visual Basic (Declaration)
Public Delegate Sub ShowProgressDelegate ( _
    state As String, _
    substate As String _
)
Visual C++
public delegate void ShowProgressDelegate(
    String^ state,
    String^ substate
)

Parameters

state
Type: System..::.String
substate
Type: System..::.String

See Also

PerpetuumSoft.Reporting.Components Namespace


UrlReportSlot Class

[image]

.NET ModelKit Suite ClassReference
UrlReportSlot Class
Members See Also Send Feedback
Represents report source read from a specific URL.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class UrlReportSlot : ReportSlot
Visual Basic (Declaration)
Public Class UrlReportSlot _
    Inherits ReportSlot
Visual C++
public ref class UrlReportSlot : public ReportSlot

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Components..::.ReportSlot
PerpetuumSoft.Reporting.Components..::.UrlReportSlot

See Also

UrlReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


UrlReportSlot Members

[image] [image]

.NET ModelKit Suite ClassReference
UrlReportSlot Members
UrlReportSlot Class Constructors Methods Properties Events See Also Send Feedback

The UrlReportSlot type exposes the following members.

Constructors

Name | Description
UrlReportSlot | Overloaded.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DesignTemplate | Runs report designer and opens a document corresponding to the given ReportSlot in it. (Inherited from ReportSlot.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
LoadReport | Overridden. See LoadReport()()(). (Overrides ReportSlot..::.LoadReport()()().)
MemberwiseClone | Overloaded.
OnGetReportParameter | Implements OnGetReportParameter(GetReportParameterEventArgs). (Inherited from ReportSlot.)
OnHyperlinkClick | Implements OnHyperlinkClick(HyperlinkEventArgs). (Inherited from ReportSlot.)
OnRenderCanceled | Implements OnRenderCanceled(EventArgs). (Inherited from ReportSlot.)
OnRenderingError | Implements OnRenderingError(RenderingErrorEventArgs). (Inherited from ReportSlot.)
Prepare | Overloaded.
RenderDocument | Overloaded.
SaveReport | Overridden. See SaveReport(Document). (Overrides ReportSlot..::.SaveReport(Document).)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Document | Implements Document. (Inherited from ReportSlot.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExceptionMode | Gets or sets exception mode for ReportSlot. (Inherited from ReportSlot.)
Manager | Gets manager for ReportSlot. (Inherited from ReportSlot.)
ReportName | Gets or sets report name. (Inherited from ReportSlot.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StyleSheet | Gets or sets ReportSlot styles. (Inherited from ReportSlot.)
SupportsSaving | Overridden. See SupportsSaving. (Overrides ReportSlot..::.SupportsSaving.)
Url | Gets or sets URL.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
GetReportParameter | Implements GetReportParameter. (Inherited from ReportSlot.)
HyperlinkClick | Implements HyperlinkClick. (Inherited from ReportSlot.)
RenderCanceled | Occurs when rendering has been canceled (Inherited from ReportSlot.)
RenderCompleted | Implements RenderCompleted. (Inherited from ReportSlot.)
RenderingError | Occurs when the rendering is completed with an error. (Inherited from ReportSlot.)

See Also

UrlReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


UrlReportSlot Constructor

[image] [image]

.NET ModelKit Suite ClassReference
UrlReportSlot Constructor
UrlReportSlot Class See Also Send Feedback

Overload List

Name | Description
UrlReportSlot()()() | Initializes a new instance of the UrlReportSlot class.
UrlReportSlot(IContainer) | Initializes a new instance of the UrlReportSlot class.

See Also

UrlReportSlot Class
UrlReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


UrlReportSlot Constructor

[image]

.NET ModelKit Suite ClassReference
UrlReportSlot Constructor
UrlReportSlot Class See Also Send Feedback
Initializes a new instance of the UrlReportSlot class.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public UrlReportSlot()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UrlReportSlot()

See Also

UrlReportSlot Class
UrlReportSlot Overload
PerpetuumSoft.Reporting.Components Namespace


UrlReportSlot Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
UrlReportSlot Constructor (IContainer)
UrlReportSlot Class See Also Send Feedback
Initializes a new instance of the UrlReportSlot class.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public UrlReportSlot(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
UrlReportSlot(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

UrlReportSlot Class
UrlReportSlot Overload
PerpetuumSoft.Reporting.Components Namespace


UrlReportSlot Methods

[image] [image]

.NET ModelKit Suite ClassReference
UrlReportSlot Methods
UrlReportSlot Class See Also Send Feedback

The UrlReportSlot type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DesignTemplate | Runs report designer and opens a document corresponding to the given ReportSlot in it. (Inherited from ReportSlot.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
LoadReport | Overridden. See LoadReport()()(). (Overrides ReportSlot..::.LoadReport()()().)
MemberwiseClone | Overloaded.
OnGetReportParameter | Implements OnGetReportParameter(GetReportParameterEventArgs). (Inherited from ReportSlot.)
OnHyperlinkClick | Implements OnHyperlinkClick(HyperlinkEventArgs). (Inherited from ReportSlot.)
OnRenderCanceled | Implements OnRenderCanceled(EventArgs). (Inherited from ReportSlot.)
OnRenderingError | Implements OnRenderingError(RenderingErrorEventArgs). (Inherited from ReportSlot.)
Prepare | Overloaded.
RenderDocument | Overloaded.
SaveReport | Overridden. See SaveReport(Document). (Overrides ReportSlot..::.SaveReport(Document).)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

UrlReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
UrlReportSlot..::.Dispose Method
UrlReportSlot Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

UrlReportSlot Class
UrlReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


LoadReport Method

[image]

.NET ModelKit Suite ClassReference
UrlReportSlot..::.LoadReport Method
UrlReportSlot Class See Also Send Feedback
Overridden. See LoadReport()()().

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override Document LoadReport()
Visual Basic (Declaration)
Public Overrides Function LoadReport As Document
Visual C++
public:
virtual Document^ LoadReport() override

See Also

UrlReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
UrlReportSlot..::.MemberwiseClone Method
UrlReportSlot Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

UrlReportSlot Class
UrlReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


Prepare Method

[image] [image]

.NET ModelKit Suite ClassReference
UrlReportSlot..::.Prepare Method
UrlReportSlot Class See Also Send Feedback

Overload List

Name | Description
Prepare()()() | Implements Prepare()()(). (Inherited from ReportSlot.)
Prepare(IRenderSite) | Implements ['M:PerpetuumSoft.Reporting.Components.IReportSource.Prepare()]. (Inherited from ReportSlot.)

See Also

UrlReportSlot Class
UrlReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


RenderDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
UrlReportSlot..::.RenderDocument Method
UrlReportSlot Class See Also Send Feedback

Overload List

Name | Description
RenderDocument()()() | Implements RenderDocument()()(). (Inherited from ReportSlot.)
RenderDocument(IRenderSite) | Implements ['M:PerpetuumSoft.Reporting.Components.IReportSource.RenderDocument(PerpetuumSoft.Reporting.Rendering.IRenderSite)]. (Inherited from ReportSlot.)

See Also

UrlReportSlot Class
UrlReportSlot Members
PerpetuumSoft.Reporting.Components Namespace


SaveReport Method

[image]

.NET ModelKit Suite ClassReference
UrlReportSlot..::.SaveReport Method
UrlReportSlot Class See Also Send Feedback
Overridden. See SaveReport(Document).

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void SaveReport(
    Document document
)
Visual Basic (Declaration)
Public Overrides Sub SaveReport ( _
    document As Document _
)
Visual C++
public:
virtual void SaveReport(
    Document^ document
) override

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document

See Also

UrlReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


UrlReportSlot Properties

[image] [image]

.NET ModelKit Suite ClassReference
UrlReportSlot Properties
UrlReportSlot Class See Also Send Feedback

The UrlReportSlot type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Document | Implements Document. (Inherited from ReportSlot.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExceptionMode | Gets or sets exception mode for ReportSlot. (Inherited from ReportSlot.)
Manager | Gets manager for ReportSlot. (Inherited from ReportSlot.)
ReportName | Gets or sets report name. (Inherited from ReportSlot.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
StyleSheet | Gets or sets ReportSlot styles. (Inherited from ReportSlot.)
SupportsSaving | Overridden. See SupportsSaving. (Overrides ReportSlot..::.SupportsSaving.)
Url | Gets or sets URL.

See Also

UrlReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


SupportsSaving Property

[image]

.NET ModelKit Suite ClassReference
UrlReportSlot..::.SupportsSaving Property
UrlReportSlot Class See Also Send Feedback
Overridden. See SupportsSaving.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool SupportsSaving { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property SupportsSaving As Boolean
Visual C++
public:
virtual property bool SupportsSaving {
    bool get () override;
}

See Also

UrlReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


Url Property

[image]

.NET ModelKit Suite ClassReference
UrlReportSlot..::.Url Property
UrlReportSlot Class See Also Send Feedback
Gets or sets URL.

Namespace: PerpetuumSoft.Reporting.Components
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Url { get; set; }
Visual Basic (Declaration)
Public Property Url As String
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

See Also

UrlReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


UrlReportSlot Events

[image] [image]

.NET ModelKit Suite ClassReference
UrlReportSlot Events
UrlReportSlot Class See Also Send Feedback

The UrlReportSlot type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
GetReportParameter | Implements GetReportParameter. (Inherited from ReportSlot.)
HyperlinkClick | Implements HyperlinkClick. (Inherited from ReportSlot.)
RenderCanceled | Occurs when rendering has been canceled (Inherited from ReportSlot.)
RenderCompleted | Implements RenderCompleted. (Inherited from ReportSlot.)
RenderingError | Occurs when the rendering is completed with an error. (Inherited from ReportSlot.)

See Also

UrlReportSlot Class
PerpetuumSoft.Reporting.Components Namespace


PerpetuumSoft.Reporting.Data Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Data Namespace
Send Feedback
The PerpetuumSoft.Reporting.Data namespace contains classes of the interface that provide access to the data by which the report is generated.

Classes

Class | Description
DataNavigationException | The exception that is thrown when data navigation failed.
DataNavigationManager | Controls all data navigators associated with RenderEngine.
DataNavigator | Provides uniform mechanism for data navigation.
DocumentDataSource | Represents the document template data source.
DocumentDataSourceCollection | Represents the data sources collection.
OdbcDataSource | Represents data source for the document which gets data from the database supporting work through ODBC.
SqlBaseDataSource | Represents data source for the document which gets data from the database.
SqlDataSource | Represents data source for the document which gets data from the MS SQL database.
XmlDataSource | Represents data source for the document which gets data from the XML document.

Interfaces

Interface | Description
IDataSource | Provides interface for plug-in data sources.
IDataSourceManager | Provides access to data sources collection.


DataNavigationException Class

[image]

.NET ModelKit Suite ClassReference
DataNavigationException Class
Members See Also Send Feedback
The exception that is thrown when data navigation failed.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
[SerializableAttribute]
public class DataNavigationException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DataNavigationException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class DataNavigationException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
PerpetuumSoft.Reporting.Data..::.DataNavigationException

See Also

DataNavigationException Members
PerpetuumSoft.Reporting.Data Namespace


DataNavigationException Members

[image] [image]

.NET ModelKit Suite ClassReference
DataNavigationException Members
DataNavigationException Class Constructors Methods Properties See Also Send Feedback

The DataNavigationException type exposes the following members.

Constructors

Name | Description
DataNavigationException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
DataMember | Gets corresponding data member.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DataNavigationException Class
PerpetuumSoft.Reporting.Data Namespace


DataNavigationException Constructor

[image] [image]

.NET ModelKit Suite ClassReference
DataNavigationException Constructor
DataNavigationException Class See Also Send Feedback

Overload List

Name | Description
DataNavigationException()()() | Initializes a new instance of the DataNavigationException class.
DataNavigationException(String, String, Exception) | Creates new instance of DataNavigationException.

See Also

DataNavigationException Class
DataNavigationException Members
PerpetuumSoft.Reporting.Data Namespace


DataNavigationException Constructor

[image]

.NET ModelKit Suite ClassReference
DataNavigationException Constructor
DataNavigationException Class See Also Send Feedback
Initializes a new instance of the DataNavigationException class.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataNavigationException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataNavigationException()

See Also

DataNavigationException Class
DataNavigationException Overload
PerpetuumSoft.Reporting.Data Namespace


DataNavigationException Constructor (String, String, Exception)

[image]

.NET ModelKit Suite ClassReference
DataNavigationException Constructor (String, String, Exception)
DataNavigationException Class See Also Send Feedback
Creates new instance of DataNavigationException.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataNavigationException(
    string dataMember,
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    dataMember As String, _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
DataNavigationException(
    String^ dataMember,
    String^ message,
    Exception^ innerException
)

Parameters

dataMember
Type: System..::.String
message
Type: System..::.String
innerException
Type: System..::.Exception

See Also

DataNavigationException Class
DataNavigationException Overload
PerpetuumSoft.Reporting.Data Namespace


DataNavigationException Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataNavigationException Methods
DataNavigationException Class See Also Send Feedback

The DataNavigationException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DataNavigationException Class
PerpetuumSoft.Reporting.Data Namespace


DataNavigationException Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataNavigationException Properties
DataNavigationException Class See Also Send Feedback

The DataNavigationException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
DataMember | Gets corresponding data member.
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DataNavigationException Class
PerpetuumSoft.Reporting.Data Namespace


DataMember Property

[image]

.NET ModelKit Suite ClassReference
DataNavigationException..::.DataMember Property
DataNavigationException Class See Also Send Feedback
Gets corresponding data member.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string DataMember { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataMember As String
Visual C++
public:
property String^ DataMember {
    String^ get ();
}

See Also

DataNavigationException Class
PerpetuumSoft.Reporting.Data Namespace


DataNavigationManager Class

[image]

.NET ModelKit Suite ClassReference
DataNavigationManager Class
Members See Also Send Feedback
Controls all data navigators associated with RenderEngine.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DataNavigationManager
Visual Basic (Declaration)
Public Class DataNavigationManager
Visual C++
public ref class DataNavigationManager

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data..::.DataNavigationManager

See Also

DataNavigationManager Members
PerpetuumSoft.Reporting.Data Namespace


DataNavigationManager Members

[image] [image]

.NET ModelKit Suite ClassReference
DataNavigationManager Members
DataNavigationManager Class Constructors Methods See Also Send Feedback

The DataNavigationManager type exposes the following members.

Constructors

Name | Description
DataNavigationManager | Creates new instance of the DataNavigationManager class.

Methods

Name | Description
EndNavigator | Removes given navigator from navigator list.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFieldValue | Returns field value.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetNavigator | Gets active navigator associated with specified path.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RetrieveFieldPath | Retrieves field name.
RetrieveNavigatorPath | Retrieves navigator path.
StartNavigator | Overloaded.
StringToPath | Converts string to patrh array.
SubPath | Retrieves sub path.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataNavigationManager Class
PerpetuumSoft.Reporting.Data Namespace


DataNavigationManager Constructor

[image]

.NET ModelKit Suite ClassReference
DataNavigationManager Constructor
DataNavigationManager Class See Also Send Feedback
Creates new instance of the DataNavigationManager class.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataNavigationManager(
    IDataSourceManager dataSourceManager
)
Visual Basic (Declaration)
Public Sub New ( _
    dataSourceManager As IDataSourceManager _
)
Visual C++
public:
DataNavigationManager(
    IDataSourceManager^ dataSourceManager
)

Parameters

dataSourceManager
Type: PerpetuumSoft.Reporting.Data..::.IDataSourceManager

See Also

DataNavigationManager Class
PerpetuumSoft.Reporting.Data Namespace


DataNavigationManager Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataNavigationManager Methods
DataNavigationManager Class See Also Send Feedback

The DataNavigationManager type exposes the following members.

Methods

Name | Description
EndNavigator | Removes given navigator from navigator list.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFieldValue | Returns field value.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetNavigator | Gets active navigator associated with specified path.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RetrieveFieldPath | Retrieves field name.
RetrieveNavigatorPath | Retrieves navigator path.
StartNavigator | Overloaded.
StringToPath | Converts string to patrh array.
SubPath | Retrieves sub path.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataNavigationManager Class
PerpetuumSoft.Reporting.Data Namespace


EndNavigator Method

[image]

.NET ModelKit Suite ClassReference
DataNavigationManager..::.EndNavigator Method
DataNavigationManager Class See Also Send Feedback
Removes given navigator from navigator list.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void EndNavigator(
    DataNavigator dataNavigator
)
Visual Basic (Declaration)
Public Sub EndNavigator ( _
    dataNavigator As DataNavigator _
)
Visual C++
public:
void EndNavigator(
    DataNavigator^ dataNavigator
)

Parameters

dataNavigator
Type: PerpetuumSoft.Reporting.Data..::.DataNavigator

See Also

DataNavigationManager Class
PerpetuumSoft.Reporting.Data Namespace


GetFieldValue Method

[image]

.NET ModelKit Suite ClassReference
DataNavigationManager..::.GetFieldValue Method
DataNavigationManager Class See Also Send Feedback
Returns field value.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object GetFieldValue(
    string name
)
Visual Basic (Declaration)
Public Function GetFieldValue ( _
    name As String _
) As Object
Visual C++
public:
Object^ GetFieldValue(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

DataNavigationManager Class
PerpetuumSoft.Reporting.Data Namespace


GetNavigator Method

[image]

.NET ModelKit Suite ClassReference
DataNavigationManager..::.GetNavigator Method
DataNavigationManager Class See Also Send Feedback
Gets active navigator associated with specified path.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataNavigator GetNavigator(
    string path
)
Visual Basic (Declaration)
Public Function GetNavigator ( _
    path As String _
) As DataNavigator
Visual C++
public:
DataNavigator^ GetNavigator(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

DataNavigationManager Class
PerpetuumSoft.Reporting.Data Namespace


RetrieveFieldPath Method

[image]

.NET ModelKit Suite ClassReference
DataNavigationManager..::.RetrieveFieldPath Method
DataNavigationManager Class See Also Send Feedback
Retrieves field name.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static string RetrieveFieldPath(
    string path
)
Visual Basic (Declaration)
Public Shared Function RetrieveFieldPath ( _
    path As String _
) As String
Visual C++
public:
static String^ RetrieveFieldPath(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

DataNavigationManager Class
PerpetuumSoft.Reporting.Data Namespace


RetrieveNavigatorPath Method

[image]

.NET ModelKit Suite ClassReference
DataNavigationManager..::.RetrieveNavigatorPath Method
DataNavigationManager Class See Also Send Feedback
Retrieves navigator path.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static string RetrieveNavigatorPath(
    string path
)
Visual Basic (Declaration)
Public Shared Function RetrieveNavigatorPath ( _
    path As String _
) As String
Visual C++
public:
static String^ RetrieveNavigatorPath(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

DataNavigationManager Class
PerpetuumSoft.Reporting.Data Namespace


StartNavigator Method

[image] [image]

.NET ModelKit Suite ClassReference
DataNavigationManager..::.StartNavigator Method
DataNavigationManager Class See Also Send Feedback

Overload List

Name | Description
StartNavigator(String) | Creates new navigator and adds it to the navigators list.
StartNavigator(String, DataNavigator) | Creates new navigator and adds it to the navigators list.

See Also

DataNavigationManager Class
DataNavigationManager Members
PerpetuumSoft.Reporting.Data Namespace


StartNavigator Method (String)

[image]

.NET ModelKit Suite ClassReference
DataNavigationManager..::.StartNavigator Method (String)
DataNavigationManager Class See Also Send Feedback
Creates new navigator and adds it to the navigators list.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataNavigator StartNavigator(
    string path
)
Visual Basic (Declaration)
Public Function StartNavigator ( _
    path As String _
) As DataNavigator
Visual C++
public:
DataNavigator^ StartNavigator(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

DataNavigationManager Class
StartNavigator Overload
PerpetuumSoft.Reporting.Data Namespace


StartNavigator Method (String, DataNavigator)

[image]

.NET ModelKit Suite ClassReference
DataNavigationManager..::.StartNavigator Method (String, DataNavigator)
DataNavigationManager Class See Also Send Feedback
Creates new navigator and adds it to the navigators list.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void StartNavigator(
    string path,
    DataNavigator navigator
)
Visual Basic (Declaration)
Public Sub StartNavigator ( _
    path As String, _
    navigator As DataNavigator _
)
Visual C++
public:
void StartNavigator(
    String^ path,
    DataNavigator^ navigator
)

Parameters

path
Type: System..::.String
navigator
Type: PerpetuumSoft.Reporting.Data..::.DataNavigator

See Also

DataNavigationManager Class
StartNavigator Overload
PerpetuumSoft.Reporting.Data Namespace


StringToPath Method

[image]

.NET ModelKit Suite ClassReference
DataNavigationManager..::.StringToPath Method
DataNavigationManager Class See Also Send Feedback
Converts string to patrh array.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static string[] StringToPath(
    string stringPath
)
Visual Basic (Declaration)
Public Shared Function StringToPath ( _
    stringPath As String _
) As String()
Visual C++
public:
static array<String^>^ StringToPath(
    String^ stringPath
)

Parameters

stringPath
Type: System..::.String

See Also

DataNavigationManager Class
PerpetuumSoft.Reporting.Data Namespace


SubPath Method

[image]

.NET ModelKit Suite ClassReference
DataNavigationManager..::.SubPath Method
DataNavigationManager Class See Also Send Feedback
Retrieves sub path.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static string[] SubPath(
    string[] path,
    int startIndex,
    int count
)
Visual Basic (Declaration)
Public Shared Function SubPath ( _
    path As String(), _
    startIndex As Integer, _
    count As Integer _
) As String()
Visual C++
public:
static array<String^>^ SubPath(
    array<String^>^ path,
    int startIndex,
    int count
)

Parameters

path
Type: array< System..::.String >[]()[]
startIndex
Type: System..::.Int32
count
Type: System..::.Int32

See Also

DataNavigationManager Class
PerpetuumSoft.Reporting.Data Namespace


DataNavigator Class

[image]

.NET ModelKit Suite ClassReference
DataNavigator Class
Members See Also Send Feedback
Provides uniform mechanism for data navigation.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract class DataNavigator
Visual Basic (Declaration)
Public MustInherit Class DataNavigator
Visual C++
public ref class DataNavigator abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data..::.DataNavigator

See Also

DataNavigator Members
PerpetuumSoft.Reporting.Data Namespace


DataNavigator Members

[image] [image]

.NET ModelKit Suite ClassReference
DataNavigator Members
DataNavigator Class Constructors Methods Properties See Also Send Feedback

The DataNavigator type exposes the following members.

Constructors

Name | Description
DataNavigator | Initializes a new instance of the DataNavigator class

Methods

Name | Description
CreateNavigator | Creates navigator for the given object.
CreateRangeNavigator | Create mock navigator for given range.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetChildNavigators | Returns list of nested navigators.
GetFieldNavigator | Returns navigator for specified field.
GetFieldValue | Gets field value.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetList | Returns data list.
GetRecordChildNavigators | Returns list of nested navigators.
GetRecordFieldValue | Gets property value.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypePropertiesDescriptors | Get properties list.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveNext | Moves navigator to the next record.
Reset | Resets navigator state.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Current | Gets current object.
FirstRecord | Gets first record.
HasMoreItems | Gets if navigator has more records.
Item | Gets field value.
Name | Gets or sets navigator name.
PropogateMode | Gets or sets propogate mode.
RecordNumber | Gets current record number.
ValidRecord | Gets any valid record.

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


DataNavigator Constructor

[image]

.NET ModelKit Suite ClassReference
DataNavigator Constructor
DataNavigator Class See Also Send Feedback
Initializes a new instance of the DataNavigator class

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected DataNavigator()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
DataNavigator()

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


DataNavigator Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataNavigator Methods
DataNavigator Class See Also Send Feedback

The DataNavigator type exposes the following members.

Methods

Name | Description
CreateNavigator | Creates navigator for the given object.
CreateRangeNavigator | Create mock navigator for given range.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetChildNavigators | Returns list of nested navigators.
GetFieldNavigator | Returns navigator for specified field.
GetFieldValue | Gets field value.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetList | Returns data list.
GetRecordChildNavigators | Returns list of nested navigators.
GetRecordFieldValue | Gets property value.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypePropertiesDescriptors | Get properties list.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveNext | Moves navigator to the next record.
Reset | Resets navigator state.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


CreateNavigator Method

[image]

.NET ModelKit Suite ClassReference
DataNavigator..::.CreateNavigator Method
DataNavigator Class See Also Send Feedback
Creates navigator for the given object.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static DataNavigator CreateNavigator(
    Object dataObject
)
Visual Basic (Declaration)
Public Shared Function CreateNavigator ( _
    dataObject As Object _
) As DataNavigator
Visual C++
public:
static DataNavigator^ CreateNavigator(
    Object^ dataObject
)

Parameters

dataObject
Type: System..::.Object

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


CreateRangeNavigator Method

[image]

.NET ModelKit Suite ClassReference
DataNavigator..::.CreateRangeNavigator Method
DataNavigator Class See Also Send Feedback
Create mock navigator for given range.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static DataNavigator CreateRangeNavigator(
    int recordsNumber
)
Visual Basic (Declaration)
Public Shared Function CreateRangeNavigator ( _
    recordsNumber As Integer _
) As DataNavigator
Visual C++
public:
static DataNavigator^ CreateRangeNavigator(
    int recordsNumber
)

Parameters

recordsNumber
Type: System..::.Int32

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


GetChildNavigators Method

[image]

.NET ModelKit Suite ClassReference
DataNavigator..::.GetChildNavigators Method
DataNavigator Class See Also Send Feedback
Returns list of nested navigators.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual DataNavigator[] GetChildNavigators()
Visual Basic (Declaration)
Public Overridable Function GetChildNavigators As DataNavigator()
Visual C++
public:
virtual array<DataNavigator^>^ GetChildNavigators()

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


GetFieldNavigator Method

[image]

.NET ModelKit Suite ClassReference
DataNavigator..::.GetFieldNavigator Method
DataNavigator Class See Also Send Feedback
Returns navigator for specified field.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual DataNavigator GetFieldNavigator(
    string name
)
Visual Basic (Declaration)
Public Overridable Function GetFieldNavigator ( _
    name As String _
) As DataNavigator
Visual C++
public:
virtual DataNavigator^ GetFieldNavigator(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


GetFieldValue Method

[image]

.NET ModelKit Suite ClassReference
DataNavigator..::.GetFieldValue Method
DataNavigator Class See Also Send Feedback
Gets field value.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object GetFieldValue(
    string path
)
Visual Basic (Declaration)
Public Function GetFieldValue ( _
    path As String _
) As Object
Visual C++
public:
Object^ GetFieldValue(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


GetList Method

[image]

.NET ModelKit Suite ClassReference
DataNavigator..::.GetList Method
DataNavigator Class See Also Send Feedback
Returns data list.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract IList GetList()
Visual Basic (Declaration)
Public MustOverride Function GetList As IList
Visual C++
public:
virtual IList^ GetList() abstract

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


GetRecordChildNavigators Method

[image]

.NET ModelKit Suite ClassReference
DataNavigator..::.GetRecordChildNavigators Method
DataNavigator Class See Also Send Feedback
Returns list of nested navigators.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static DataNavigator[] GetRecordChildNavigators(
    Object record
)
Visual Basic (Declaration)
Public Shared Function GetRecordChildNavigators ( _
    record As Object _
) As DataNavigator()
Visual C++
public:
static array<DataNavigator^>^ GetRecordChildNavigators(
    Object^ record
)

Parameters

record
Type: System..::.Object

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


GetRecordFieldValue Method

[image]

.NET ModelKit Suite ClassReference
DataNavigator..::.GetRecordFieldValue Method
DataNavigator Class See Also Send Feedback
Gets property value.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static Object GetRecordFieldValue(
    string name,
    Object obj
)
Visual Basic (Declaration)
Public Shared Function GetRecordFieldValue ( _
    name As String, _
    obj As Object _
) As Object
Visual C++
public:
static Object^ GetRecordFieldValue(
    String^ name,
    Object^ obj
)

Parameters

name
Type: System..::.String
obj
Type: System..::.Object

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


GetTypePropertiesDescriptors Method

[image]

.NET ModelKit Suite ClassReference
DataNavigator..::.GetTypePropertiesDescriptors Method
DataNavigator Class See Also Send Feedback
Get properties list.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static PropertyDescriptorCollection GetTypePropertiesDescriptors(
    Type type
)
Visual Basic (Declaration)
Public Shared Function GetTypePropertiesDescriptors ( _
    type As Type _
) As PropertyDescriptorCollection
Visual C++
public:
static PropertyDescriptorCollection^ GetTypePropertiesDescriptors(
    Type^ type
)

Parameters

type
Type: System..::.Type

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


MoveNext Method

[image]

.NET ModelKit Suite ClassReference
DataNavigator..::.MoveNext Method
DataNavigator Class See Also Send Feedback
Moves navigator to the next record.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract void MoveNext()
Visual Basic (Declaration)
Public MustOverride Sub MoveNext
Visual C++
public:
virtual void MoveNext() abstract

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


Reset Method

[image]

.NET ModelKit Suite ClassReference
DataNavigator..::.Reset Method
DataNavigator Class See Also Send Feedback
Resets navigator state.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract void Reset()
Visual Basic (Declaration)
Public MustOverride Sub Reset
Visual C++
public:
virtual void Reset() abstract

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


DataNavigator Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataNavigator Properties
DataNavigator Class See Also Send Feedback

The DataNavigator type exposes the following members.

Properties

Name | Description
Current | Gets current object.
FirstRecord | Gets first record.
HasMoreItems | Gets if navigator has more records.
Item | Gets field value.
Name | Gets or sets navigator name.
PropogateMode | Gets or sets propogate mode.
RecordNumber | Gets current record number.
ValidRecord | Gets any valid record.

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


Current Property

[image]

.NET ModelKit Suite ClassReference
DataNavigator..::.Current Property
DataNavigator Class See Also Send Feedback
Gets current object.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract Object Current { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property Current As Object
Visual C++
public:
virtual property Object^ Current {
    Object^ get () abstract;
}

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


FirstRecord Property

[image]

.NET ModelKit Suite ClassReference
DataNavigator..::.FirstRecord Property
DataNavigator Class See Also Send Feedback
Gets first record.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract Object FirstRecord { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property FirstRecord As Object
Visual C++
public:
virtual property Object^ FirstRecord {
    Object^ get () abstract;
}

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


HasMoreItems Property

[image]

.NET ModelKit Suite ClassReference
DataNavigator..::.HasMoreItems Property
DataNavigator Class See Also Send Feedback
Gets if navigator has more records.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract bool HasMoreItems { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property HasMoreItems As Boolean
Visual C++
public:
virtual property bool HasMoreItems {
    bool get () abstract;
}

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
DataNavigator..::.Item Property
DataNavigator Class See Also Send Feedback
Gets field value.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object this[
    string path
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    path As String _
) As Object
Visual C++
public:
property Object^ default[String^ path] {
    Object^ get (String^ path);
}

Parameters

path
Type: System..::.String

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


Name Property

[image]

.NET ModelKit Suite ClassReference
DataNavigator..::.Name Property
DataNavigator Class See Also Send Feedback
Gets or sets navigator name.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


PropogateMode Property

[image]

.NET ModelKit Suite ClassReference
DataNavigator..::.PropogateMode Property
DataNavigator Class See Also Send Feedback
Gets or sets propogate mode.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool PropogateMode { get; set; }
Visual Basic (Declaration)
Public Property PropogateMode As Boolean
Visual C++
public:
property bool PropogateMode {
    bool get ();
    void set (bool value);
}

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


RecordNumber Property

[image]

.NET ModelKit Suite ClassReference
DataNavigator..::.RecordNumber Property
DataNavigator Class See Also Send Feedback
Gets current record number.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract int RecordNumber { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property RecordNumber As Integer
Visual C++
public:
virtual property int RecordNumber {
    int get () abstract;
}

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


ValidRecord Property

[image]

.NET ModelKit Suite ClassReference
DataNavigator..::.ValidRecord Property
DataNavigator Class See Also Send Feedback
Gets any valid record.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object ValidRecord { get; }
Visual Basic (Declaration)
Public ReadOnly Property ValidRecord As Object
Visual C++
public:
property Object^ ValidRecord {
    Object^ get ();
}

See Also

DataNavigator Class
PerpetuumSoft.Reporting.Data Namespace


DocumentDataSource Class

[image]

.NET ModelKit Suite ClassReference
DocumentDataSource Class
Members See Also Send Feedback
Represents the document template data source.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract class DocumentDataSource : IDataSource,
    ICloneable
Visual Basic (Declaration)
Public MustInherit Class DocumentDataSource _
    Implements IDataSource, ICloneable
Visual C++
public ref class DocumentDataSource abstract : IDataSource,
    ICloneable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data..::.DocumentDataSource
PerpetuumSoft.Reporting.Data..::.SqlBaseDataSource
PerpetuumSoft.Reporting.Data..::.XmlDataSource

See Also

DocumentDataSource Members
PerpetuumSoft.Reporting.Data Namespace


DocumentDataSource Members

[image] [image]

.NET ModelKit Suite ClassReference
DocumentDataSource Members
DocumentDataSource Class Constructors Methods Properties See Also Send Feedback

The DocumentDataSource type exposes the following members.

Constructors

Name | Description
DocumentDataSource | Initializes a new instance of the DocumentDataSource class

Methods

Name | Description
Clone | Implements Clone()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataNavigator | Implements GetDataNavigator()()().
GetDataSource | Gets data source.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
Name | Gets or sets имя.

See Also

DocumentDataSource Class
PerpetuumSoft.Reporting.Data Namespace


DocumentDataSource Constructor

[image]

.NET ModelKit Suite ClassReference
DocumentDataSource Constructor
DocumentDataSource Class See Also Send Feedback
Initializes a new instance of the DocumentDataSource class

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected DocumentDataSource()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
DocumentDataSource()

See Also

DocumentDataSource Class
PerpetuumSoft.Reporting.Data Namespace


DocumentDataSource Methods

[image] [image]

.NET ModelKit Suite ClassReference
DocumentDataSource Methods
DocumentDataSource Class See Also Send Feedback

The DocumentDataSource type exposes the following members.

Methods

Name | Description
Clone | Implements Clone()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataNavigator | Implements GetDataNavigator()()().
GetDataSource | Gets data source.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

DocumentDataSource Class
PerpetuumSoft.Reporting.Data Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
DocumentDataSource..::.Clone Method
DocumentDataSource Class See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract Object Clone()
Visual Basic (Declaration)
Public MustOverride Function Clone As Object
Visual C++
public:
virtual Object^ Clone() abstract

Implements

ICloneable..::.Clone()()()

See Also

DocumentDataSource Class
PerpetuumSoft.Reporting.Data Namespace


GetDataNavigator Method

[image]

.NET ModelKit Suite ClassReference
DocumentDataSource..::.GetDataNavigator Method
DocumentDataSource Class See Also Send Feedback
Implements GetDataNavigator()()().

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract DataNavigator GetDataNavigator()
Visual Basic (Declaration)
Public MustOverride Function GetDataNavigator As DataNavigator
Visual C++
public:
virtual DataNavigator^ GetDataNavigator() abstract

Implements

IDataSource..::.GetDataNavigator()()()

See Also

DocumentDataSource Class
PerpetuumSoft.Reporting.Data Namespace


GetDataSource Method

[image]

.NET ModelKit Suite ClassReference
DocumentDataSource..::.GetDataSource Method
DocumentDataSource Class See Also Send Feedback
Gets data source.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual Object GetDataSource()
Visual Basic (Declaration)
Public Overridable Function GetDataSource As Object
Visual C++
public:
virtual Object^ GetDataSource()

See Also

DocumentDataSource Class
PerpetuumSoft.Reporting.Data Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
DocumentDataSource..::.ToString Method
DocumentDataSource Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

DocumentDataSource Class
PerpetuumSoft.Reporting.Data Namespace


DocumentDataSource Properties

[image] [image]

.NET ModelKit Suite ClassReference
DocumentDataSource Properties
DocumentDataSource Class See Also Send Feedback

The DocumentDataSource type exposes the following members.

Properties

Name | Description
Name | Gets or sets имя.

See Also

DocumentDataSource Class
PerpetuumSoft.Reporting.Data Namespace


Name Property

[image]

.NET ModelKit Suite ClassReference
DocumentDataSource..::.Name Property
DocumentDataSource Class See Also Send Feedback
Gets or sets имя.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

DocumentDataSource Class
PerpetuumSoft.Reporting.Data Namespace


DocumentDataSourceCollection Class

[image]

.NET ModelKit Suite ClassReference
DocumentDataSourceCollection Class
Members See Also Send Feedback
Represents the data sources collection.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DocumentDataSourceCollection : Collection<DocumentDataSource>
Visual Basic (Declaration)
Public Class DocumentDataSourceCollection _
    Inherits Collection(Of DocumentDataSource)
Visual C++
public ref class DocumentDataSourceCollection : public Collection<DocumentDataSource^>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( DocumentDataSource >)>)
PerpetuumSoft.Reporting.Data..::.DocumentDataSourceCollection

See Also

DocumentDataSourceCollection Members
PerpetuumSoft.Reporting.Data Namespace


DocumentDataSourceCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
DocumentDataSourceCollection Members
DocumentDataSourceCollection Class Constructors Methods Properties See Also Send Feedback

The DocumentDataSourceCollection type exposes the following members.

Constructors

Name | Description
DocumentDataSourceCollection | Initializes a new instance of the DocumentDataSourceCollection class.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DocumentDataSource >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DocumentDataSource >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DocumentDataSource >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <( DocumentDataSource >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)

See Also

DocumentDataSourceCollection Class
PerpetuumSoft.Reporting.Data Namespace


DocumentDataSourceCollection Constructor

[image]

.NET ModelKit Suite ClassReference
DocumentDataSourceCollection Constructor
DocumentDataSourceCollection Class See Also Send Feedback
Initializes a new instance of the DocumentDataSourceCollection class.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DocumentDataSourceCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentDataSourceCollection()

See Also

DocumentDataSourceCollection Class
PerpetuumSoft.Reporting.Data Namespace


DocumentDataSourceCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
DocumentDataSourceCollection Methods
DocumentDataSourceCollection Class See Also Send Feedback

The DocumentDataSourceCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DocumentDataSource >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DocumentDataSource >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DocumentDataSource >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <( DocumentDataSource >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentDataSourceCollection Class
PerpetuumSoft.Reporting.Data Namespace


DocumentDataSourceCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
DocumentDataSourceCollection Properties
DocumentDataSourceCollection Class See Also Send Feedback

The DocumentDataSourceCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)
Item | Overloaded.
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DocumentDataSource >)>).)

See Also

DocumentDataSourceCollection Class
PerpetuumSoft.Reporting.Data Namespace


Item Property

[image] [image]

.NET ModelKit Suite ClassReference
DocumentDataSourceCollection..::.Item Property
DocumentDataSourceCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( DocumentDataSource >)>).)
Item[([(String])]) | Gets the DocumentDataSource by its name.

See Also

DocumentDataSourceCollection Class
DocumentDataSourceCollection Members
PerpetuumSoft.Reporting.Data Namespace


Item Property (String)

[image]

.NET ModelKit Suite ClassReference
DocumentDataSourceCollection..::.Item Property (String)
DocumentDataSourceCollection Class See Also Send Feedback
Gets the DocumentDataSource by its name.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DocumentDataSource this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As DocumentDataSource
Visual C++
public:
property DocumentDataSource^ default[String^ name] {
    DocumentDataSource^ get (String^ name);
}

Parameters

name
Type: System..::.String

See Also

DocumentDataSourceCollection Class
Item Overload
PerpetuumSoft.Reporting.Data Namespace


IDataSource Interface

[image]

.NET ModelKit Suite ClassReference
IDataSource Interface
Members See Also Send Feedback
Provides interface for plug-in data sources.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public interface IDataSource
Visual Basic (Declaration)
Public Interface IDataSource
Visual C++
public interface class IDataSource

See Also

IDataSource Members
PerpetuumSoft.Reporting.Data Namespace


IDataSource Members

[image] [image]

.NET ModelKit Suite ClassReference
IDataSource Members
IDataSource Interface Methods See Also Send Feedback

The IDataSource type exposes the following members.

Methods

Name | Description
GetDataNavigator | Returns DataNavigator for this instance of data source.

See Also

IDataSource Interface
PerpetuumSoft.Reporting.Data Namespace


IDataSource Methods

[image] [image]

.NET ModelKit Suite ClassReference
IDataSource Methods
IDataSource Interface See Also Send Feedback

The IDataSource type exposes the following members.

Methods

Name | Description
GetDataNavigator | Returns DataNavigator for this instance of data source.

See Also

IDataSource Interface
PerpetuumSoft.Reporting.Data Namespace


GetDataNavigator Method

[image]

.NET ModelKit Suite ClassReference
IDataSource..::.GetDataNavigator Method
IDataSource Interface See Also Send Feedback
Returns DataNavigator for this instance of data source.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
DataNavigator GetDataNavigator()
Visual Basic (Declaration)
Function GetDataNavigator As DataNavigator
Visual C++
DataNavigator^ GetDataNavigator()

See Also

IDataSource Interface
PerpetuumSoft.Reporting.Data Namespace


IDataSourceManager Interface

[image]

.NET ModelKit Suite ClassReference
IDataSourceManager Interface
Members See Also Send Feedback
Provides access to data sources collection.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public interface IDataSourceManager
Visual Basic (Declaration)
Public Interface IDataSourceManager
Visual C++
public interface class IDataSourceManager

See Also

IDataSourceManager Members
PerpetuumSoft.Reporting.Data Namespace


IDataSourceManager Members

[image] [image]

.NET ModelKit Suite ClassReference
IDataSourceManager Members
IDataSourceManager Interface Methods See Also Send Feedback

The IDataSourceManager type exposes the following members.

Methods

Name | Description
GetDataSource | Returns data source associated with specified name.
GetDataSources | Returns all data sources.
GetKnownDataSourceNames | Returns names of known data sources.

See Also

IDataSourceManager Interface
PerpetuumSoft.Reporting.Data Namespace


IDataSourceManager Methods

[image] [image]

.NET ModelKit Suite ClassReference
IDataSourceManager Methods
IDataSourceManager Interface See Also Send Feedback

The IDataSourceManager type exposes the following members.

Methods

Name | Description
GetDataSource | Returns data source associated with specified name.
GetDataSources | Returns all data sources.
GetKnownDataSourceNames | Returns names of known data sources.

See Also

IDataSourceManager Interface
PerpetuumSoft.Reporting.Data Namespace


GetDataSource Method

[image]

.NET ModelKit Suite ClassReference
IDataSourceManager..::.GetDataSource Method
IDataSourceManager Interface See Also Send Feedback
Returns data source associated with specified name.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
Object GetDataSource(
    string name
)
Visual Basic (Declaration)
Function GetDataSource ( _
    name As String _
) As Object
Visual C++
Object^ GetDataSource(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

IDataSourceManager Interface
PerpetuumSoft.Reporting.Data Namespace


GetDataSources Method

[image]

.NET ModelKit Suite ClassReference
IDataSourceManager..::.GetDataSources Method
IDataSourceManager Interface See Also Send Feedback
Returns all data sources.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
Object[] GetDataSources()
Visual Basic (Declaration)
Function GetDataSources As Object()
Visual C++
array<Object^>^ GetDataSources()

See Also

IDataSourceManager Interface
PerpetuumSoft.Reporting.Data Namespace


GetKnownDataSourceNames Method

[image]

.NET ModelKit Suite ClassReference
IDataSourceManager..::.GetKnownDataSourceNames Method
IDataSourceManager Interface See Also Send Feedback
Returns names of known data sources.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
string[] GetKnownDataSourceNames()
Visual Basic (Declaration)
Function GetKnownDataSourceNames As String()
Visual C++
array<String^>^ GetKnownDataSourceNames()

See Also

IDataSourceManager Interface
PerpetuumSoft.Reporting.Data Namespace


OdbcDataSource Class

[image]

.NET ModelKit Suite ClassReference
OdbcDataSource Class
Members See Also Send Feedback
Represents data source for the document which gets data from the database supporting work through ODBC.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class OdbcDataSource : SqlBaseDataSource
Visual Basic (Declaration)
Public Class OdbcDataSource _
    Inherits SqlBaseDataSource
Visual C++
public ref class OdbcDataSource : public SqlBaseDataSource

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data..::.DocumentDataSource
PerpetuumSoft.Reporting.Data..::.SqlBaseDataSource
PerpetuumSoft.Reporting.Data..::.OdbcDataSource

See Also

OdbcDataSource Members
PerpetuumSoft.Reporting.Data Namespace


OdbcDataSource Members

[image] [image]

.NET ModelKit Suite ClassReference
OdbcDataSource Members
OdbcDataSource Class Constructors Methods Properties See Also Send Feedback

The OdbcDataSource type exposes the following members.

Constructors

Name | Description
OdbcDataSource | Initializes a new instance of the OdbcDataSource class.

Methods

Name | Description
Clone | Implements Clone()()(). (Overrides DocumentDataSource..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FillDataTable | Overridden. See FillDataTable(DataTable). (Overrides SqlBaseDataSource..::.FillDataTable(DataTable).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataNavigator | Implements GetDataNavigator()()(). (Inherited from SqlBaseDataSource.)
GetDataSource | Gets data source. (Inherited from DocumentDataSource.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DocumentDataSource.)

Properties

Name | Description
ConnectionString | Gets or sets database connection string. (Inherited from SqlBaseDataSource.)
Name | Gets or sets имя. (Inherited from DocumentDataSource.)
SelectQuery | Gets or sets SQL query for getting data from the database. (Inherited from SqlBaseDataSource.)

See Also

OdbcDataSource Class
PerpetuumSoft.Reporting.Data Namespace


OdbcDataSource Constructor

[image]

.NET ModelKit Suite ClassReference
OdbcDataSource Constructor
OdbcDataSource Class See Also Send Feedback
Initializes a new instance of the OdbcDataSource class.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public OdbcDataSource()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OdbcDataSource()

See Also

OdbcDataSource Class
PerpetuumSoft.Reporting.Data Namespace


OdbcDataSource Methods

[image] [image]

.NET ModelKit Suite ClassReference
OdbcDataSource Methods
OdbcDataSource Class See Also Send Feedback

The OdbcDataSource type exposes the following members.

Methods

Name | Description
Clone | Implements Clone()()(). (Overrides DocumentDataSource..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FillDataTable | Overridden. See FillDataTable(DataTable). (Overrides SqlBaseDataSource..::.FillDataTable(DataTable).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataNavigator | Implements GetDataNavigator()()(). (Inherited from SqlBaseDataSource.)
GetDataSource | Gets data source. (Inherited from DocumentDataSource.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DocumentDataSource.)

See Also

OdbcDataSource Class
PerpetuumSoft.Reporting.Data Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
OdbcDataSource..::.Clone Method
OdbcDataSource Class See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Implements

ICloneable..::.Clone()()()

See Also

OdbcDataSource Class
PerpetuumSoft.Reporting.Data Namespace


FillDataTable Method

[image]

.NET ModelKit Suite ClassReference
OdbcDataSource..::.FillDataTable Method
OdbcDataSource Class See Also Send Feedback
Overridden. See FillDataTable(DataTable).

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void FillDataTable(
    DataTable table
)
Visual Basic (Declaration)
Public Overrides Sub FillDataTable ( _
    table As DataTable _
)
Visual C++
public:
virtual void FillDataTable(
    DataTable^ table
) override

Parameters

table
Type: System.Data..::.DataTable

See Also

OdbcDataSource Class
PerpetuumSoft.Reporting.Data Namespace


OdbcDataSource Properties

[image] [image]

.NET ModelKit Suite ClassReference
OdbcDataSource Properties
OdbcDataSource Class See Also Send Feedback

The OdbcDataSource type exposes the following members.

Properties

Name | Description
ConnectionString | Gets or sets database connection string. (Inherited from SqlBaseDataSource.)
Name | Gets or sets имя. (Inherited from DocumentDataSource.)
SelectQuery | Gets or sets SQL query for getting data from the database. (Inherited from SqlBaseDataSource.)

See Also

OdbcDataSource Class
PerpetuumSoft.Reporting.Data Namespace


SqlBaseDataSource Class

[image]

.NET ModelKit Suite ClassReference
SqlBaseDataSource Class
Members See Also Send Feedback
Represents data source for the document which gets data from the database.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract class SqlBaseDataSource : DocumentDataSource
Visual Basic (Declaration)
Public MustInherit Class SqlBaseDataSource _
    Inherits DocumentDataSource
Visual C++
public ref class SqlBaseDataSource abstract : public DocumentDataSource

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data..::.DocumentDataSource
PerpetuumSoft.Reporting.Data..::.SqlBaseDataSource
PerpetuumSoft.Reporting.Data..::.OdbcDataSource
PerpetuumSoft.Reporting.Data..::.SqlDataSource

See Also

SqlBaseDataSource Members
PerpetuumSoft.Reporting.Data Namespace


SqlBaseDataSource Members

[image] [image]

.NET ModelKit Suite ClassReference
SqlBaseDataSource Members
SqlBaseDataSource Class Constructors Methods Properties See Also Send Feedback

The SqlBaseDataSource type exposes the following members.

Constructors

Name | Description
SqlBaseDataSource | Initializes a new instance of the SqlBaseDataSource class

Methods

Name | Description
Clone | Implements Clone()()(). (Inherited from DocumentDataSource.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FillDataTable | Fills DataTable with data in accordance with SQL query and connection string.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataNavigator | Implements GetDataNavigator()()(). (Overrides DocumentDataSource..::.GetDataNavigator()()().)
GetDataSource | Gets data source. (Inherited from DocumentDataSource.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DocumentDataSource.)

Properties

Name | Description
ConnectionString | Gets or sets database connection string.
Name | Gets or sets имя. (Inherited from DocumentDataSource.)
SelectQuery | Gets or sets SQL query for getting data from the database.

See Also

SqlBaseDataSource Class
PerpetuumSoft.Reporting.Data Namespace


SqlBaseDataSource Constructor

[image]

.NET ModelKit Suite ClassReference
SqlBaseDataSource Constructor
SqlBaseDataSource Class See Also Send Feedback
Initializes a new instance of the SqlBaseDataSource class

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected SqlBaseDataSource()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
SqlBaseDataSource()

See Also

SqlBaseDataSource Class
PerpetuumSoft.Reporting.Data Namespace


SqlBaseDataSource Methods

[image] [image]

.NET ModelKit Suite ClassReference
SqlBaseDataSource Methods
SqlBaseDataSource Class See Also Send Feedback

The SqlBaseDataSource type exposes the following members.

Methods

Name | Description
Clone | Implements Clone()()(). (Inherited from DocumentDataSource.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FillDataTable | Fills DataTable with data in accordance with SQL query and connection string.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataNavigator | Implements GetDataNavigator()()(). (Overrides DocumentDataSource..::.GetDataNavigator()()().)
GetDataSource | Gets data source. (Inherited from DocumentDataSource.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DocumentDataSource.)

See Also

SqlBaseDataSource Class
PerpetuumSoft.Reporting.Data Namespace


FillDataTable Method

[image]

.NET ModelKit Suite ClassReference
SqlBaseDataSource..::.FillDataTable Method
SqlBaseDataSource Class See Also Send Feedback
Fills DataTable with data in accordance with SQL query and connection string.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract void FillDataTable(
    DataTable table
)
Visual Basic (Declaration)
Public MustOverride Sub FillDataTable ( _
    table As DataTable _
)
Visual C++
public:
virtual void FillDataTable(
    DataTable^ table
) abstract

Parameters

table
Type: System.Data..::.DataTable

See Also

SqlBaseDataSource Class
PerpetuumSoft.Reporting.Data Namespace


GetDataNavigator Method

[image]

.NET ModelKit Suite ClassReference
SqlBaseDataSource..::.GetDataNavigator Method
SqlBaseDataSource Class See Also Send Feedback
Implements GetDataNavigator()()().

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override DataNavigator GetDataNavigator()
Visual Basic (Declaration)
Public Overrides Function GetDataNavigator As DataNavigator
Visual C++
public:
virtual DataNavigator^ GetDataNavigator() override

Implements

IDataSource..::.GetDataNavigator()()()

See Also

SqlBaseDataSource Class
PerpetuumSoft.Reporting.Data Namespace


SqlBaseDataSource Properties

[image] [image]

.NET ModelKit Suite ClassReference
SqlBaseDataSource Properties
SqlBaseDataSource Class See Also Send Feedback

The SqlBaseDataSource type exposes the following members.

Properties

Name | Description
ConnectionString | Gets or sets database connection string.
Name | Gets or sets имя. (Inherited from DocumentDataSource.)
SelectQuery | Gets or sets SQL query for getting data from the database.

See Also

SqlBaseDataSource Class
PerpetuumSoft.Reporting.Data Namespace


ConnectionString Property

[image]

.NET ModelKit Suite ClassReference
SqlBaseDataSource..::.ConnectionString Property
SqlBaseDataSource Class See Also Send Feedback
Gets or sets database connection string.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string ConnectionString { get; set; }
Visual Basic (Declaration)
Public Property ConnectionString As String
Visual C++
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

See Also

SqlBaseDataSource Class
PerpetuumSoft.Reporting.Data Namespace


SelectQuery Property

[image]

.NET ModelKit Suite ClassReference
SqlBaseDataSource..::.SelectQuery Property
SqlBaseDataSource Class See Also Send Feedback
Gets or sets SQL query for getting data from the database.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string SelectQuery { get; set; }
Visual Basic (Declaration)
Public Property SelectQuery As String
Visual C++
public:
property String^ SelectQuery {
    String^ get ();
    void set (String^ value);
}

See Also

SqlBaseDataSource Class
PerpetuumSoft.Reporting.Data Namespace


SqlDataSource Class

[image]

.NET ModelKit Suite ClassReference
SqlDataSource Class
Members See Also Send Feedback
Represents data source for the document which gets data from the MS SQL database.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class SqlDataSource : SqlBaseDataSource
Visual Basic (Declaration)
Public Class SqlDataSource _
    Inherits SqlBaseDataSource
Visual C++
public ref class SqlDataSource : public SqlBaseDataSource

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data..::.DocumentDataSource
PerpetuumSoft.Reporting.Data..::.SqlBaseDataSource
PerpetuumSoft.Reporting.Data..::.SqlDataSource

See Also

SqlDataSource Members
PerpetuumSoft.Reporting.Data Namespace


SqlDataSource Members

[image] [image]

.NET ModelKit Suite ClassReference
SqlDataSource Members
SqlDataSource Class Constructors Methods Properties See Also Send Feedback

The SqlDataSource type exposes the following members.

Constructors

Name | Description
SqlDataSource | Initializes a new instance of the SqlDataSource class.

Methods

Name | Description
Clone | Implements Clone()()(). (Overrides DocumentDataSource..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FillDataTable | Overridden. See FillDataTable(DataTable). (Overrides SqlBaseDataSource..::.FillDataTable(DataTable).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataNavigator | Implements GetDataNavigator()()(). (Inherited from SqlBaseDataSource.)
GetDataSource | Gets data source. (Inherited from DocumentDataSource.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DocumentDataSource.)

Properties

Name | Description
ConnectionString | Gets or sets database connection string. (Inherited from SqlBaseDataSource.)
Name | Gets or sets имя. (Inherited from DocumentDataSource.)
SelectQuery | Gets or sets SQL query for getting data from the database. (Inherited from SqlBaseDataSource.)

See Also

SqlDataSource Class
PerpetuumSoft.Reporting.Data Namespace


SqlDataSource Constructor

[image]

.NET ModelKit Suite ClassReference
SqlDataSource Constructor
SqlDataSource Class See Also Send Feedback
Initializes a new instance of the SqlDataSource class.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public SqlDataSource()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SqlDataSource()

See Also

SqlDataSource Class
PerpetuumSoft.Reporting.Data Namespace


SqlDataSource Methods

[image] [image]

.NET ModelKit Suite ClassReference
SqlDataSource Methods
SqlDataSource Class See Also Send Feedback

The SqlDataSource type exposes the following members.

Methods

Name | Description
Clone | Implements Clone()()(). (Overrides DocumentDataSource..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FillDataTable | Overridden. See FillDataTable(DataTable). (Overrides SqlBaseDataSource..::.FillDataTable(DataTable).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataNavigator | Implements GetDataNavigator()()(). (Inherited from SqlBaseDataSource.)
GetDataSource | Gets data source. (Inherited from DocumentDataSource.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DocumentDataSource.)

See Also

SqlDataSource Class
PerpetuumSoft.Reporting.Data Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
SqlDataSource..::.Clone Method
SqlDataSource Class See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Implements

ICloneable..::.Clone()()()

See Also

SqlDataSource Class
PerpetuumSoft.Reporting.Data Namespace


FillDataTable Method

[image]

.NET ModelKit Suite ClassReference
SqlDataSource..::.FillDataTable Method
SqlDataSource Class See Also Send Feedback
Overridden. See FillDataTable(DataTable).

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void FillDataTable(
    DataTable table
)
Visual Basic (Declaration)
Public Overrides Sub FillDataTable ( _
    table As DataTable _
)
Visual C++
public:
virtual void FillDataTable(
    DataTable^ table
) override

Parameters

table
Type: System.Data..::.DataTable

See Also

SqlDataSource Class
PerpetuumSoft.Reporting.Data Namespace


SqlDataSource Properties

[image] [image]

.NET ModelKit Suite ClassReference
SqlDataSource Properties
SqlDataSource Class See Also Send Feedback

The SqlDataSource type exposes the following members.

Properties

Name | Description
ConnectionString | Gets or sets database connection string. (Inherited from SqlBaseDataSource.)
Name | Gets or sets имя. (Inherited from DocumentDataSource.)
SelectQuery | Gets or sets SQL query for getting data from the database. (Inherited from SqlBaseDataSource.)

See Also

SqlDataSource Class
PerpetuumSoft.Reporting.Data Namespace


XmlDataSource Class

[image]

.NET ModelKit Suite ClassReference
XmlDataSource Class
Members See Also Send Feedback
Represents data source for the document which gets data from the XML document.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class XmlDataSource : DocumentDataSource
Visual Basic (Declaration)
Public Class XmlDataSource _
    Inherits DocumentDataSource
Visual C++
public ref class XmlDataSource : public DocumentDataSource

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data..::.DocumentDataSource
PerpetuumSoft.Reporting.Data..::.XmlDataSource

See Also

XmlDataSource Members
PerpetuumSoft.Reporting.Data Namespace


XmlDataSource Members

[image] [image]

.NET ModelKit Suite ClassReference
XmlDataSource Members
XmlDataSource Class Constructors Methods Properties See Also Send Feedback

The XmlDataSource type exposes the following members.

Constructors

Name | Description
XmlDataSource | Initializes a new instance of the XmlDataSource class.

Methods

Name | Description
Clone | Implements Clone()()(). (Overrides DocumentDataSource..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataNavigator | Implements GetDataNavigator()()(). (Overrides DocumentDataSource..::.GetDataNavigator()()().)
GetDataSource | Gets data source. (Inherited from DocumentDataSource.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DocumentDataSource.)

Properties

Name | Description
DataFile | Gets or sets XML document location.
Name | Gets or sets имя. (Inherited from DocumentDataSource.)
XPath | Gets or sets the initial path used for getting data in XML document.

See Also

XmlDataSource Class
PerpetuumSoft.Reporting.Data Namespace


XmlDataSource Constructor

[image]

.NET ModelKit Suite ClassReference
XmlDataSource Constructor
XmlDataSource Class See Also Send Feedback
Initializes a new instance of the XmlDataSource class.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public XmlDataSource()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XmlDataSource()

See Also

XmlDataSource Class
PerpetuumSoft.Reporting.Data Namespace


XmlDataSource Methods

[image] [image]

.NET ModelKit Suite ClassReference
XmlDataSource Methods
XmlDataSource Class See Also Send Feedback

The XmlDataSource type exposes the following members.

Methods

Name | Description
Clone | Implements Clone()()(). (Overrides DocumentDataSource..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataNavigator | Implements GetDataNavigator()()(). (Overrides DocumentDataSource..::.GetDataNavigator()()().)
GetDataSource | Gets data source. (Inherited from DocumentDataSource.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from DocumentDataSource.)

See Also

XmlDataSource Class
PerpetuumSoft.Reporting.Data Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
XmlDataSource..::.Clone Method
XmlDataSource Class See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Implements

ICloneable..::.Clone()()()

See Also

XmlDataSource Class
PerpetuumSoft.Reporting.Data Namespace


GetDataNavigator Method

[image]

.NET ModelKit Suite ClassReference
XmlDataSource..::.GetDataNavigator Method
XmlDataSource Class See Also Send Feedback
Implements GetDataNavigator()()().

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override DataNavigator GetDataNavigator()
Visual Basic (Declaration)
Public Overrides Function GetDataNavigator As DataNavigator
Visual C++
public:
virtual DataNavigator^ GetDataNavigator() override

Implements

IDataSource..::.GetDataNavigator()()()

See Also

XmlDataSource Class
PerpetuumSoft.Reporting.Data Namespace


XmlDataSource Properties

[image] [image]

.NET ModelKit Suite ClassReference
XmlDataSource Properties
XmlDataSource Class See Also Send Feedback

The XmlDataSource type exposes the following members.

Properties

Name | Description
DataFile | Gets or sets XML document location.
Name | Gets or sets имя. (Inherited from DocumentDataSource.)
XPath | Gets or sets the initial path used for getting data in XML document.

See Also

XmlDataSource Class
PerpetuumSoft.Reporting.Data Namespace


DataFile Property

[image]

.NET ModelKit Suite ClassReference
XmlDataSource..::.DataFile Property
XmlDataSource Class See Also Send Feedback
Gets or sets XML document location.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string DataFile { get; set; }
Visual Basic (Declaration)
Public Property DataFile As String
Visual C++
public:
property String^ DataFile {
    String^ get ();
    void set (String^ value);
}

See Also

XmlDataSource Class
PerpetuumSoft.Reporting.Data Namespace


XPath Property

[image]

.NET ModelKit Suite ClassReference
XmlDataSource..::.XPath Property
XmlDataSource Class See Also Send Feedback
Gets or sets the initial path used for getting data in XML document.

Namespace: PerpetuumSoft.Reporting.Data
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string XPath { get; set; }
Visual Basic (Declaration)
Public Property XPath As String
Visual C++
public:
property String^ XPath {
    String^ get ();
    void set (String^ value);
}

See Also

XmlDataSource Class
PerpetuumSoft.Reporting.Data Namespace


PerpetuumSoft.Reporting.Data.Olap Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Data.Olap Namespace
Send Feedback
The PerpetuumSoft.Reporting.Data.Olap namespace contains classes which are used for pivot table calculation.

Classes

Class | Description
AggregateFunctionFactory | Represents basic class for all factories of aggregate functions.
AggregateFunctionFactory..::.Avg | Average value.
AggregateFunctionFactory..::.Count | Count of values.
AggregateFunctionFactory..::.EstimateOfStandardDeviation | Represents an aggregate function for estimate of the standard deviation calculation.
AggregateFunctionFactory..::.EstimateOfVariance | Represents an aggregate function for calculation of the estimate of the variance.
AggregateFunctionFactory..::.Kurtosis | Represents an aggregate function for kurtosis calculation.
AggregateFunctionFactory..::.Max | Maximum value.
AggregateFunctionFactory..::.Median | Represents an aggregate function for median calculation.
AggregateFunctionFactory..::.Min | Minimum value.
AggregateFunctionFactory..::.Skewness | Represents an aggregate function for skewness calculation.
AggregateFunctionFactory..::.StandardDeviation | Represents an aggregate function for the standard deviation calculation.
AggregateFunctionFactory..::.Sum | Sum of values.
AggregateFunctionFactory..::.Variance | Represents an aggregate function for variance calculation.
DataCube | Represents data view of the PivotTable element.
DataPivotTable | Represents the pivot table.
EmptyFilter | Represents an empty filter.
Field | Represents a pivot table field.
FieldItem | Represents a dimension item of a pivot table.
FieldItem..::.ErrorValue | Represents incorrect field item data.
FieldItem..::.TotalValue | Represents total item data.
FieldItemCollection | Represents the collection of FieldItem.
FieldsCollection | Represents the collection of Field.
FilterException | Base class for all exceptions thrown from filters.
JointPassTreeNode | Represents a tree element discribing nested data sources
JointPassTreeNodeCollection | Represents the tree node collection
NestedField | Represetnts a data source nested field for data navigation.
NestedFieldCollection | Represents the collection of NestedField.

Interfaces

Interface | Description
IAggregateFunction | Represents the aggregate function.
IFilter | Represents a data filter.

Delegates

Delegate | Description
ByPassRecordDelegate | Represents the method for pivot table data filtering.
CalculateRecordDelegate | Represents the method for calculating filed values for current data row.
FieldsCollection..::.CollectionChangeEventHandler | Represents the method that will handle CollectionChanged.

Enumerations

Enumeration | Description
SortOrder | Enumerates the sort order.


AggregateFunctionFactory Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory Class
Members See Also Send Feedback
Represents basic class for all factories of aggregate functions.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract class AggregateFunctionFactory
Visual Basic (Declaration)
Public MustInherit Class AggregateFunctionFactory
Visual C++
public ref class AggregateFunctionFactory abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.Avg
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.Count
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.EstimateOfStandardDeviation
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.EstimateOfVariance
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.Kurtosis
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.Max
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.Median
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.Min
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.Skewness
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.StandardDeviation
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.Sum
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.Variance

See Also

AggregateFunctionFactory Members
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory Members
AggregateFunctionFactory Class Constructors Methods Properties See Also Send Feedback

The AggregateFunctionFactory type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory | Initializes a new instance of the AggregateFunctionFactory class

Methods

Name | Description
CreateFuntion | Returns a newly created aggregate function.
Equals | Overridden. See Equals(Object). (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Object..::.GetHashCode()()().)
GetName | Returns aggregate function symbolic name.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
CanGetPercent | Gets value which indicates whether the result will be represented as percentage.

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory Constructor
AggregateFunctionFactory Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory class

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected AggregateFunctionFactory()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
AggregateFunctionFactory()

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory Methods
AggregateFunctionFactory Class See Also Send Feedback

The AggregateFunctionFactory type exposes the following members.

Methods

Name | Description
CreateFuntion | Returns a newly created aggregate function.
Equals | Overridden. See Equals(Object). (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides Object..::.GetHashCode()()().)
GetName | Returns aggregate function symbolic name.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.CreateFuntion Method
AggregateFunctionFactory Class See Also Send Feedback
Returns a newly created aggregate function.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public MustOverride Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() abstract

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Equals Method
AggregateFunctionFactory Class See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Reporting.Data.Olap Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.GetHashCode Method
AggregateFunctionFactory Class See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Reporting.Data.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.GetName Method
AggregateFunctionFactory Class See Also Send Feedback
Returns aggregate function symbolic name.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract string GetName()
Visual Basic (Declaration)
Public MustOverride Function GetName As String
Visual C++
public:
virtual String^ GetName() abstract

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Reporting.Data.Olap Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.ToString Method
AggregateFunctionFactory Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory Properties
AggregateFunctionFactory Class See Also Send Feedback

The AggregateFunctionFactory type exposes the following members.

Properties

Name | Description
CanGetPercent | Gets value which indicates whether the result will be represented as percentage.

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.CanGetPercent Property
AggregateFunctionFactory Class See Also Send Feedback
Gets value which indicates whether the result will be represented as percentage.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract bool CanGetPercent { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () abstract;
}

See Also

AggregateFunctionFactory Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Avg Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Avg Class
AggregateFunctionFactory Class Members See Also Send Feedback
Average value.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Avg : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class Avg _
    Inherits AggregateFunctionFactory
Visual C++
public ref class Avg : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.Avg

See Also

AggregateFunctionFactory..::.Avg Members
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Avg Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Avg Members
AggregateFunctionFactory..::.Avg Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.Avg type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.Avg | Initializes a new instance of the AggregateFunctionFactory..::.Avg class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Avg Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Avg Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Avg Constructor
AggregateFunctionFactory..::.Avg Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.Avg class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Avg()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Avg()

See Also

AggregateFunctionFactory..::.Avg Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Avg Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Avg Methods
AggregateFunctionFactory..::.Avg Class See Also Send Feedback

The AggregateFunctionFactory..::.Avg type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.Avg Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Avg..::.CreateFuntion Method
AggregateFunctionFactory..::.Avg Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.Avg Class
PerpetuumSoft.Reporting.Data.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Avg..::.GetName Method
AggregateFunctionFactory..::.Avg Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.Avg Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Avg Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Avg Properties
AggregateFunctionFactory..::.Avg Class See Also Send Feedback

The AggregateFunctionFactory..::.Avg type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Avg Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Avg..::.CanGetPercent Property
AggregateFunctionFactory..::.Avg Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.Avg Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Count Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Count Class
AggregateFunctionFactory Class Members See Also Send Feedback
Count of values.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Count : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class Count _
    Inherits AggregateFunctionFactory
Visual C++
public ref class Count : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.Count

See Also

AggregateFunctionFactory..::.Count Members
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Count Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Count Members
AggregateFunctionFactory..::.Count Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.Count type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.Count | Initializes a new instance of the AggregateFunctionFactory..::.Count class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Count Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Count Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Count Constructor
AggregateFunctionFactory..::.Count Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.Count class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Count()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Count()

See Also

AggregateFunctionFactory..::.Count Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Count Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Count Methods
AggregateFunctionFactory..::.Count Class See Also Send Feedback

The AggregateFunctionFactory..::.Count type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.Count Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Count..::.CreateFuntion Method
AggregateFunctionFactory..::.Count Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.Count Class
PerpetuumSoft.Reporting.Data.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Count..::.GetName Method
AggregateFunctionFactory..::.Count Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.Count Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Count Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Count Properties
AggregateFunctionFactory..::.Count Class See Also Send Feedback

The AggregateFunctionFactory..::.Count type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Count Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Count..::.CanGetPercent Property
AggregateFunctionFactory..::.Count Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.Count Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.EstimateOfStandardDeviation Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfStandardDeviation Class
AggregateFunctionFactory Class Members See Also Send Feedback
Represents an aggregate function for estimate of the standard deviation calculation.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class EstimateOfStandardDeviation : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class EstimateOfStandardDeviation _
    Inherits AggregateFunctionFactory
Visual C++
public ref class EstimateOfStandardDeviation : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.EstimateOfStandardDeviation

See Also

AggregateFunctionFactory..::.EstimateOfStandardDeviation Members
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.EstimateOfStandardDeviation Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfStandardDeviation Members
AggregateFunctionFactory..::.EstimateOfStandardDeviation Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.EstimateOfStandardDeviation type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.EstimateOfStandardDeviation | Initializes a new instance of the AggregateFunctionFactory..::.EstimateOfStandardDeviation class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.EstimateOfStandardDeviation Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.EstimateOfStandardDeviation Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfStandardDeviation Constructor
AggregateFunctionFactory..::.EstimateOfStandardDeviation Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.EstimateOfStandardDeviation class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public EstimateOfStandardDeviation()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EstimateOfStandardDeviation()

See Also

AggregateFunctionFactory..::.EstimateOfStandardDeviation Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.EstimateOfStandardDeviation Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfStandardDeviation Methods
AggregateFunctionFactory..::.EstimateOfStandardDeviation Class See Also Send Feedback

The AggregateFunctionFactory..::.EstimateOfStandardDeviation type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.EstimateOfStandardDeviation Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfStandardDeviation..::.CreateFuntion Method
AggregateFunctionFactory..::.EstimateOfStandardDeviation Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.EstimateOfStandardDeviation Class
PerpetuumSoft.Reporting.Data.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfStandardDeviation..::.GetName Method
AggregateFunctionFactory..::.EstimateOfStandardDeviation Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.EstimateOfStandardDeviation Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.EstimateOfStandardDeviation Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfStandardDeviation Properties
AggregateFunctionFactory..::.EstimateOfStandardDeviation Class See Also Send Feedback

The AggregateFunctionFactory..::.EstimateOfStandardDeviation type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.EstimateOfStandardDeviation Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfStandardDeviation..::.CanGetPercent Property
AggregateFunctionFactory..::.EstimateOfStandardDeviation Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.EstimateOfStandardDeviation Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.EstimateOfVariance Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfVariance Class
AggregateFunctionFactory Class Members See Also Send Feedback
Represents an aggregate function for calculation of the estimate of the variance.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class EstimateOfVariance : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class EstimateOfVariance _
    Inherits AggregateFunctionFactory
Visual C++
public ref class EstimateOfVariance : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.EstimateOfVariance

See Also

AggregateFunctionFactory..::.EstimateOfVariance Members
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.EstimateOfVariance Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfVariance Members
AggregateFunctionFactory..::.EstimateOfVariance Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.EstimateOfVariance type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.EstimateOfVariance | Initializes a new instance of the AggregateFunctionFactory..::.EstimateOfVariance class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.EstimateOfVariance Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.EstimateOfVariance Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfVariance Constructor
AggregateFunctionFactory..::.EstimateOfVariance Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.EstimateOfVariance class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public EstimateOfVariance()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EstimateOfVariance()

See Also

AggregateFunctionFactory..::.EstimateOfVariance Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.EstimateOfVariance Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfVariance Methods
AggregateFunctionFactory..::.EstimateOfVariance Class See Also Send Feedback

The AggregateFunctionFactory..::.EstimateOfVariance type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.EstimateOfVariance Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfVariance..::.CreateFuntion Method
AggregateFunctionFactory..::.EstimateOfVariance Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.EstimateOfVariance Class
PerpetuumSoft.Reporting.Data.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfVariance..::.GetName Method
AggregateFunctionFactory..::.EstimateOfVariance Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.EstimateOfVariance Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.EstimateOfVariance Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfVariance Properties
AggregateFunctionFactory..::.EstimateOfVariance Class See Also Send Feedback

The AggregateFunctionFactory..::.EstimateOfVariance type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.EstimateOfVariance Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.EstimateOfVariance..::.CanGetPercent Property
AggregateFunctionFactory..::.EstimateOfVariance Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.EstimateOfVariance Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Kurtosis Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Kurtosis Class
AggregateFunctionFactory Class Members See Also Send Feedback
Represents an aggregate function for kurtosis calculation.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Kurtosis : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class Kurtosis _
    Inherits AggregateFunctionFactory
Visual C++
public ref class Kurtosis : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.Kurtosis

See Also

AggregateFunctionFactory..::.Kurtosis Members
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Kurtosis Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Kurtosis Members
AggregateFunctionFactory..::.Kurtosis Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.Kurtosis type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.Kurtosis | Initializes a new instance of the AggregateFunctionFactory..::.Kurtosis class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Kurtosis Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Kurtosis Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Kurtosis Constructor
AggregateFunctionFactory..::.Kurtosis Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.Kurtosis class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Kurtosis()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Kurtosis()

See Also

AggregateFunctionFactory..::.Kurtosis Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Kurtosis Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Kurtosis Methods
AggregateFunctionFactory..::.Kurtosis Class See Also Send Feedback

The AggregateFunctionFactory..::.Kurtosis type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.Kurtosis Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Kurtosis..::.CreateFuntion Method
AggregateFunctionFactory..::.Kurtosis Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.Kurtosis Class
PerpetuumSoft.Reporting.Data.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Kurtosis..::.GetName Method
AggregateFunctionFactory..::.Kurtosis Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.Kurtosis Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Kurtosis Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Kurtosis Properties
AggregateFunctionFactory..::.Kurtosis Class See Also Send Feedback

The AggregateFunctionFactory..::.Kurtosis type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Kurtosis Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Kurtosis..::.CanGetPercent Property
AggregateFunctionFactory..::.Kurtosis Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.Kurtosis Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Max Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Max Class
AggregateFunctionFactory Class Members See Also Send Feedback
Maximum value.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Max : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class Max _
    Inherits AggregateFunctionFactory
Visual C++
public ref class Max : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.Max

See Also

AggregateFunctionFactory..::.Max Members
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Max Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Max Members
AggregateFunctionFactory..::.Max Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.Max type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.Max | Initializes a new instance of the AggregateFunctionFactory..::.Max class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Max Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Max Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Max Constructor
AggregateFunctionFactory..::.Max Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.Max class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Max()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Max()

See Also

AggregateFunctionFactory..::.Max Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Max Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Max Methods
AggregateFunctionFactory..::.Max Class See Also Send Feedback

The AggregateFunctionFactory..::.Max type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.Max Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Max..::.CreateFuntion Method
AggregateFunctionFactory..::.Max Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.Max Class
PerpetuumSoft.Reporting.Data.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Max..::.GetName Method
AggregateFunctionFactory..::.Max Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.Max Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Max Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Max Properties
AggregateFunctionFactory..::.Max Class See Also Send Feedback

The AggregateFunctionFactory..::.Max type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Max Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Max..::.CanGetPercent Property
AggregateFunctionFactory..::.Max Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.Max Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Median Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Median Class
AggregateFunctionFactory Class Members See Also Send Feedback
Represents an aggregate function for median calculation.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Median : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class Median _
    Inherits AggregateFunctionFactory
Visual C++
public ref class Median : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.Median

See Also

AggregateFunctionFactory..::.Median Members
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Median Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Median Members
AggregateFunctionFactory..::.Median Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.Median type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.Median | Initializes a new instance of the AggregateFunctionFactory..::.Median class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Median Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Median Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Median Constructor
AggregateFunctionFactory..::.Median Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.Median class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Median()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Median()

See Also

AggregateFunctionFactory..::.Median Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Median Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Median Methods
AggregateFunctionFactory..::.Median Class See Also Send Feedback

The AggregateFunctionFactory..::.Median type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.Median Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Median..::.CreateFuntion Method
AggregateFunctionFactory..::.Median Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.Median Class
PerpetuumSoft.Reporting.Data.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Median..::.GetName Method
AggregateFunctionFactory..::.Median Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.Median Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Median Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Median Properties
AggregateFunctionFactory..::.Median Class See Also Send Feedback

The AggregateFunctionFactory..::.Median type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Median Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Median..::.CanGetPercent Property
AggregateFunctionFactory..::.Median Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.Median Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Min Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Min Class
AggregateFunctionFactory Class Members See Also Send Feedback
Minimum value.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Min : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class Min _
    Inherits AggregateFunctionFactory
Visual C++
public ref class Min : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.Min

See Also

AggregateFunctionFactory..::.Min Members
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Min Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Min Members
AggregateFunctionFactory..::.Min Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.Min type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.Min | Initializes a new instance of the AggregateFunctionFactory..::.Min class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Min Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Min Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Min Constructor
AggregateFunctionFactory..::.Min Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.Min class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Min()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Min()

See Also

AggregateFunctionFactory..::.Min Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Min Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Min Methods
AggregateFunctionFactory..::.Min Class See Also Send Feedback

The AggregateFunctionFactory..::.Min type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.Min Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Min..::.CreateFuntion Method
AggregateFunctionFactory..::.Min Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.Min Class
PerpetuumSoft.Reporting.Data.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Min..::.GetName Method
AggregateFunctionFactory..::.Min Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.Min Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Min Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Min Properties
AggregateFunctionFactory..::.Min Class See Also Send Feedback

The AggregateFunctionFactory..::.Min type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Min Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Min..::.CanGetPercent Property
AggregateFunctionFactory..::.Min Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.Min Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Skewness Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Skewness Class
AggregateFunctionFactory Class Members See Also Send Feedback
Represents an aggregate function for skewness calculation.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Skewness : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class Skewness _
    Inherits AggregateFunctionFactory
Visual C++
public ref class Skewness : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.Skewness

See Also

AggregateFunctionFactory..::.Skewness Members
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Skewness Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Skewness Members
AggregateFunctionFactory..::.Skewness Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.Skewness type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.Skewness | Initializes a new instance of the AggregateFunctionFactory..::.Skewness class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Skewness Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Skewness Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Skewness Constructor
AggregateFunctionFactory..::.Skewness Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.Skewness class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Skewness()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Skewness()

See Also

AggregateFunctionFactory..::.Skewness Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Skewness Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Skewness Methods
AggregateFunctionFactory..::.Skewness Class See Also Send Feedback

The AggregateFunctionFactory..::.Skewness type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.Skewness Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Skewness..::.CreateFuntion Method
AggregateFunctionFactory..::.Skewness Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.Skewness Class
PerpetuumSoft.Reporting.Data.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Skewness..::.GetName Method
AggregateFunctionFactory..::.Skewness Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.Skewness Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Skewness Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Skewness Properties
AggregateFunctionFactory..::.Skewness Class See Also Send Feedback

The AggregateFunctionFactory..::.Skewness type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Skewness Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Skewness..::.CanGetPercent Property
AggregateFunctionFactory..::.Skewness Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.Skewness Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.StandardDeviation Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.StandardDeviation Class
AggregateFunctionFactory Class Members See Also Send Feedback
Represents an aggregate function for the standard deviation calculation.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class StandardDeviation : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class StandardDeviation _
    Inherits AggregateFunctionFactory
Visual C++
public ref class StandardDeviation : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.StandardDeviation

See Also

AggregateFunctionFactory..::.StandardDeviation Members
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.StandardDeviation Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.StandardDeviation Members
AggregateFunctionFactory..::.StandardDeviation Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.StandardDeviation type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.StandardDeviation | Initializes a new instance of the AggregateFunctionFactory..::.StandardDeviation class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.StandardDeviation Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.StandardDeviation Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.StandardDeviation Constructor
AggregateFunctionFactory..::.StandardDeviation Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.StandardDeviation class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public StandardDeviation()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StandardDeviation()

See Also

AggregateFunctionFactory..::.StandardDeviation Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.StandardDeviation Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.StandardDeviation Methods
AggregateFunctionFactory..::.StandardDeviation Class See Also Send Feedback

The AggregateFunctionFactory..::.StandardDeviation type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.StandardDeviation Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.StandardDeviation..::.CreateFuntion Method
AggregateFunctionFactory..::.StandardDeviation Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.StandardDeviation Class
PerpetuumSoft.Reporting.Data.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.StandardDeviation..::.GetName Method
AggregateFunctionFactory..::.StandardDeviation Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.StandardDeviation Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.StandardDeviation Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.StandardDeviation Properties
AggregateFunctionFactory..::.StandardDeviation Class See Also Send Feedback

The AggregateFunctionFactory..::.StandardDeviation type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.StandardDeviation Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.StandardDeviation..::.CanGetPercent Property
AggregateFunctionFactory..::.StandardDeviation Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.StandardDeviation Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Sum Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Sum Class
AggregateFunctionFactory Class Members See Also Send Feedback
Sum of values.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Sum : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class Sum _
    Inherits AggregateFunctionFactory
Visual C++
public ref class Sum : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.Sum

See Also

AggregateFunctionFactory..::.Sum Members
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Sum Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Sum Members
AggregateFunctionFactory..::.Sum Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.Sum type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.Sum | Initializes a new instance of the AggregateFunctionFactory..::.Sum class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Sum Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Sum Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Sum Constructor
AggregateFunctionFactory..::.Sum Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.Sum class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Sum()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Sum()

See Also

AggregateFunctionFactory..::.Sum Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Sum Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Sum Methods
AggregateFunctionFactory..::.Sum Class See Also Send Feedback

The AggregateFunctionFactory..::.Sum type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.Sum Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Sum..::.CreateFuntion Method
AggregateFunctionFactory..::.Sum Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.Sum Class
PerpetuumSoft.Reporting.Data.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Sum..::.GetName Method
AggregateFunctionFactory..::.Sum Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.Sum Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Sum Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Sum Properties
AggregateFunctionFactory..::.Sum Class See Also Send Feedback

The AggregateFunctionFactory..::.Sum type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Sum Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Sum..::.CanGetPercent Property
AggregateFunctionFactory..::.Sum Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.Sum Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Variance Class

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Variance Class
AggregateFunctionFactory Class Members See Also Send Feedback
Represents an aggregate function for variance calculation.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Variance : AggregateFunctionFactory
Visual Basic (Declaration)
Public Class Variance _
    Inherits AggregateFunctionFactory
Visual C++
public ref class Variance : public AggregateFunctionFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory
PerpetuumSoft.Reporting.Data.Olap..::.AggregateFunctionFactory..::.Variance

See Also

AggregateFunctionFactory..::.Variance Members
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Variance Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Variance Members
AggregateFunctionFactory..::.Variance Class Constructors Methods Properties See Also Send Feedback

Represents basic class for all factories of aggregate functions.

The AggregateFunctionFactory..::.Variance type exposes the following members.

Constructors

Name | Description
AggregateFunctionFactory..::.Variance | Initializes a new instance of the AggregateFunctionFactory..::.Variance class.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Variance Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Variance Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Variance Constructor
AggregateFunctionFactory..::.Variance Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionFactory..::.Variance class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Variance()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Variance()

See Also

AggregateFunctionFactory..::.Variance Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Variance Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Variance Methods
AggregateFunctionFactory..::.Variance Class See Also Send Feedback

The AggregateFunctionFactory..::.Variance type exposes the following members.

Methods

Name | Description
CreateFuntion | Overridden. See CreateFuntion()()(). (Overrides AggregateFunctionFactory..::.CreateFuntion()()().)
Equals | Overridden. See Equals(Object). (Inherited from AggregateFunctionFactory.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Inherited from AggregateFunctionFactory.)
GetName | Overridden. See GetName()()(). (Overrides AggregateFunctionFactory..::.GetName()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Inherited from AggregateFunctionFactory.)

See Also

AggregateFunctionFactory..::.Variance Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CreateFuntion Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Variance..::.CreateFuntion Method
AggregateFunctionFactory..::.Variance Class See Also Send Feedback
Overridden. See CreateFuntion()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override IAggregateFunction CreateFuntion()
Visual Basic (Declaration)
Public Overrides Function CreateFuntion As IAggregateFunction
Visual C++
public:
virtual IAggregateFunction^ CreateFuntion() override

See Also

AggregateFunctionFactory..::.Variance Class
PerpetuumSoft.Reporting.Data.Olap Namespace


GetName Method

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Variance..::.GetName Method
AggregateFunctionFactory..::.Variance Class See Also Send Feedback
Overridden. See GetName()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetName()
Visual Basic (Declaration)
Public Overrides Function GetName As String
Visual C++
public:
virtual String^ GetName() override

See Also

AggregateFunctionFactory..::.Variance Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AggregateFunctionFactory.Variance Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Variance Properties
AggregateFunctionFactory..::.Variance Class See Also Send Feedback

The AggregateFunctionFactory..::.Variance type exposes the following members.

Properties

Name | Description
CanGetPercent | Overridden. See CanGetPercent. (Overrides AggregateFunctionFactory..::.CanGetPercent.)

See Also

AggregateFunctionFactory..::.Variance Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CanGetPercent Property

[image]

.NET ModelKit Suite ClassReference
AggregateFunctionFactory..::.Variance..::.CanGetPercent Property
AggregateFunctionFactory..::.Variance Class See Also Send Feedback
Overridden. See CanGetPercent.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool CanGetPercent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGetPercent As Boolean
Visual C++
public:
virtual property bool CanGetPercent {
    bool get () override;
}

See Also

AggregateFunctionFactory..::.Variance Class
PerpetuumSoft.Reporting.Data.Olap Namespace


ByPassRecordDelegate Delegate

[image]

.NET ModelKit Suite ClassReference
ByPassRecordDelegate Delegate
See Also Send Feedback
Represents the method for pivot table data filtering.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate bool ByPassRecordDelegate()
Visual Basic (Declaration)
Public Delegate Function ByPassRecordDelegate As Boolean
Visual C++
public delegate bool ByPassRecordDelegate()

See Also

PerpetuumSoft.Reporting.Data.Olap Namespace


CalculateRecordDelegate Delegate

[image]

.NET ModelKit Suite ClassReference
CalculateRecordDelegate Delegate
See Also Send Feedback
Represents the method for calculating filed values for current data row.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate Hashtable CalculateRecordDelegate()
Visual Basic (Declaration)
Public Delegate Function CalculateRecordDelegate As Hashtable
Visual C++
public delegate Hashtable^ CalculateRecordDelegate()

See Also

PerpetuumSoft.Reporting.Data.Olap Namespace


DataCube Class

[image]

.NET ModelKit Suite ClassReference
DataCube Class
Members See Also Send Feedback
Represents data view of the PivotTable element.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DataCube
Visual Basic (Declaration)
Public Class DataCube
Visual C++
public ref class DataCube

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.DataCube

See Also

DataCube Members
PerpetuumSoft.Reporting.Data.Olap Namespace


DataCube Members

[image] [image]

.NET ModelKit Suite ClassReference
DataCube Members
DataCube Class Constructors Methods Properties See Also Send Feedback

The DataCube type exposes the following members.

Constructors

Name | Description
DataCube | Initializes a new instance of the DataCube class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Recalculate | Recalculates a pivot table.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Caption | Gets or sets a pivot table title.
DataSource | Gets or sets a data source for a pivot table.
Facts | Gets FieldsCollection that contains fields for building pivot table facts.
Layout | Gets or sets DataCube settings.
PivotTable | Gets the DataPivotTable object representing any pivot table.
ShowSingleFact | Gets or sets whether a single fact caption should be visible.
ShowZeroValues | Gets or sets whether zero values should be visible.
XDimensions | Gets FieldsCollection that contains fields for building pivot table columns.
YDimensions | Gets FieldsCollection that contains fields for building pivot table rows.

See Also

DataCube Class
PerpetuumSoft.Reporting.Data.Olap Namespace


DataCube Constructor

[image]

.NET ModelKit Suite ClassReference
DataCube Constructor
DataCube Class See Also Send Feedback
Initializes a new instance of the DataCube class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataCube()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataCube()

See Also

DataCube Class
PerpetuumSoft.Reporting.Data.Olap Namespace


DataCube Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataCube Methods
DataCube Class See Also Send Feedback

The DataCube type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Recalculate | Recalculates a pivot table.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataCube Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Recalculate Method

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Recalculate Method
DataCube Class See Also Send Feedback
Recalculates a pivot table.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Recalculate()
Visual Basic (Declaration)
Public Sub Recalculate
Visual C++
public:
void Recalculate()

See Also

DataCube Class
PerpetuumSoft.Reporting.Data.Olap Namespace


DataCube Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataCube Properties
DataCube Class See Also Send Feedback

The DataCube type exposes the following members.

Properties

Name | Description
Caption | Gets or sets a pivot table title.
DataSource | Gets or sets a data source for a pivot table.
Facts | Gets FieldsCollection that contains fields for building pivot table facts.
Layout | Gets or sets DataCube settings.
PivotTable | Gets the DataPivotTable object representing any pivot table.
ShowSingleFact | Gets or sets whether a single fact caption should be visible.
ShowZeroValues | Gets or sets whether zero values should be visible.
XDimensions | Gets FieldsCollection that contains fields for building pivot table columns.
YDimensions | Gets FieldsCollection that contains fields for building pivot table rows.

See Also

DataCube Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Caption Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Caption Property
DataCube Class See Also Send Feedback
Gets or sets a pivot table title.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Caption { get; set; }
Visual Basic (Declaration)
Public Property Caption As String
Visual C++
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}

See Also

DataCube Class
PerpetuumSoft.Reporting.Data.Olap Namespace


DataSource Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.DataSource Property
DataCube Class See Also Send Feedback
Gets or sets a data source for a pivot table.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataCubeDataSite DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As DataCubeDataSite
Visual C++
public:
property DataCubeDataSite^ DataSource {
    DataCubeDataSite^ get ();
    void set (DataCubeDataSite^ value);
}

See Also

DataCube Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Facts Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Facts Property
DataCube Class See Also Send Feedback
Gets FieldsCollection that contains fields for building pivot table facts.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldsCollection Facts { get; }
Visual Basic (Declaration)
Public ReadOnly Property Facts As FieldsCollection
Visual C++
public:
property FieldsCollection^ Facts {
    FieldsCollection^ get ();
}

See Also

DataCube Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Layout Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.Layout Property
DataCube Class See Also Send Feedback
Gets or sets DataCube settings.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Layout { get; set; }
Visual Basic (Declaration)
Public Property Layout As String
Visual C++
public:
property String^ Layout {
    String^ get ();
    void set (String^ value);
}

See Also

DataCube Class
PerpetuumSoft.Reporting.Data.Olap Namespace


PivotTable Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.PivotTable Property
DataCube Class See Also Send Feedback
Gets the DataPivotTable object representing any pivot table.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataPivotTable PivotTable { get; }
Visual Basic (Declaration)
Public ReadOnly Property PivotTable As DataPivotTable
Visual C++
public:
property DataPivotTable^ PivotTable {
    DataPivotTable^ get ();
}

See Also

DataCube Class
PerpetuumSoft.Reporting.Data.Olap Namespace


ShowSingleFact Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.ShowSingleFact Property
DataCube Class See Also Send Feedback
Gets or sets whether a single fact caption should be visible.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowSingleFact { get; set; }
Visual Basic (Declaration)
Public Property ShowSingleFact As Boolean
Visual C++
public:
property bool ShowSingleFact {
    bool get ();
    void set (bool value);
}

See Also

DataCube Class
PerpetuumSoft.Reporting.Data.Olap Namespace


ShowZeroValues Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.ShowZeroValues Property
DataCube Class See Also Send Feedback
Gets or sets whether zero values should be visible.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowZeroValues { get; set; }
Visual Basic (Declaration)
Public Property ShowZeroValues As Boolean
Visual C++
public:
property bool ShowZeroValues {
    bool get ();
    void set (bool value);
}

See Also

DataCube Class
PerpetuumSoft.Reporting.Data.Olap Namespace


XDimensions Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.XDimensions Property
DataCube Class See Also Send Feedback
Gets FieldsCollection that contains fields for building pivot table columns.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldsCollection XDimensions { get; }
Visual Basic (Declaration)
Public ReadOnly Property XDimensions As FieldsCollection
Visual C++
public:
property FieldsCollection^ XDimensions {
    FieldsCollection^ get ();
}

See Also

DataCube Class
PerpetuumSoft.Reporting.Data.Olap Namespace


YDimensions Property

[image]

.NET ModelKit Suite ClassReference
DataCube..::.YDimensions Property
DataCube Class See Also Send Feedback
Gets FieldsCollection that contains fields for building pivot table rows.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldsCollection YDimensions { get; }
Visual Basic (Declaration)
Public ReadOnly Property YDimensions As FieldsCollection
Visual C++
public:
property FieldsCollection^ YDimensions {
    FieldsCollection^ get ();
}

See Also

DataCube Class
PerpetuumSoft.Reporting.Data.Olap Namespace


DataPivotTable Class

[image]

.NET ModelKit Suite ClassReference
DataPivotTable Class
Members See Also Send Feedback
Represents the pivot table.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DataPivotTable
Visual Basic (Declaration)
Public Class DataPivotTable
Visual C++
public ref class DataPivotTable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.DataPivotTable

See Also

DataPivotTable Members
PerpetuumSoft.Reporting.Data.Olap Namespace


DataPivotTable Members

[image] [image]

.NET ModelKit Suite ClassReference
DataPivotTable Members
DataPivotTable Class Constructors Methods Properties See Also Send Feedback

The DataPivotTable type exposes the following members.

Constructors

Name | Description
DataPivotTable | Initializes a new instance of the DataPivotTable class.

Methods

Name | Description
AddTable | Adds a new fact table to the fact table collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFactPercent | Returns the value from the facts table in percentage terms.
GetFactValue | Returns the value from the facts table.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTable | Returns the fact table by the given parameter.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValidFact | Gets value indicating whether the fact defined by given parameters has valid result.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Error | Gets or sets the object representing an error. If a pivot table was built correctly this property should be NULL.
XRoot | Gets FieldItem which is the root of X dimension.
YRoot | Gets FieldItem which is the root of Y dimension.

See Also

DataPivotTable Class
PerpetuumSoft.Reporting.Data.Olap Namespace


DataPivotTable Constructor

[image]

.NET ModelKit Suite ClassReference
DataPivotTable Constructor
DataPivotTable Class See Also Send Feedback
Initializes a new instance of the DataPivotTable class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataPivotTable()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataPivotTable()

See Also

DataPivotTable Class
PerpetuumSoft.Reporting.Data.Olap Namespace


DataPivotTable Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataPivotTable Methods
DataPivotTable Class See Also Send Feedback

The DataPivotTable type exposes the following members.

Methods

Name | Description
AddTable | Adds a new fact table to the fact table collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFactPercent | Returns the value from the facts table in percentage terms.
GetFactValue | Returns the value from the facts table.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTable | Returns the fact table by the given parameter.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValidFact | Gets value indicating whether the fact defined by given parameters has valid result.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataPivotTable Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AddTable Method

[image]

.NET ModelKit Suite ClassReference
DataPivotTable..::.AddTable Method
DataPivotTable Class See Also Send Feedback
Adds a new fact table to the fact table collection.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void AddTable(
    Field field,
    FactTable table
)
Visual Basic (Declaration)
Public Sub AddTable ( _
    field As Field, _
    table As FactTable _
)
Visual C++
public:
void AddTable(
    Field^ field,
    FactTable^ table
)

Parameters

field
Type: PerpetuumSoft.Reporting.Data.Olap..::.Field
table
Type: FactTable

See Also

DataPivotTable Class
PerpetuumSoft.Reporting.Data.Olap Namespace


GetFactPercent Method

[image]

.NET ModelKit Suite ClassReference
DataPivotTable..::.GetFactPercent Method
DataPivotTable Class See Also Send Feedback
Returns the value from the facts table in percentage terms.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double GetFactPercent(
    FieldItem yItem,
    FieldItem xItem,
    Field fact
)
Visual Basic (Declaration)
Public Function GetFactPercent ( _
    yItem As FieldItem, _
    xItem As FieldItem, _
    fact As Field _
) As Double
Visual C++
public:
double GetFactPercent(
    FieldItem^ yItem,
    FieldItem^ xItem,
    Field^ fact
)

Parameters

yItem
Type: PerpetuumSoft.Reporting.Data.Olap..::.FieldItem
xItem
Type: PerpetuumSoft.Reporting.Data.Olap..::.FieldItem
fact
Type: PerpetuumSoft.Reporting.Data.Olap..::.Field

See Also

DataPivotTable Class
PerpetuumSoft.Reporting.Data.Olap Namespace


GetFactValue Method

[image]

.NET ModelKit Suite ClassReference
DataPivotTable..::.GetFactValue Method
DataPivotTable Class See Also Send Feedback
Returns the value from the facts table.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double GetFactValue(
    FieldItem yItem,
    FieldItem xItem,
    Field fact
)
Visual Basic (Declaration)
Public Function GetFactValue ( _
    yItem As FieldItem, _
    xItem As FieldItem, _
    fact As Field _
) As Double
Visual C++
public:
double GetFactValue(
    FieldItem^ yItem,
    FieldItem^ xItem,
    Field^ fact
)

Parameters

yItem
Type: PerpetuumSoft.Reporting.Data.Olap..::.FieldItem
xItem
Type: PerpetuumSoft.Reporting.Data.Olap..::.FieldItem
fact
Type: PerpetuumSoft.Reporting.Data.Olap..::.Field

See Also

DataPivotTable Class
PerpetuumSoft.Reporting.Data.Olap Namespace


GetTable Method

[image]

.NET ModelKit Suite ClassReference
DataPivotTable..::.GetTable Method
DataPivotTable Class See Also Send Feedback
Returns the fact table by the given parameter.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FactTable GetTable(
    Field field
)
Visual Basic (Declaration)
Public Function GetTable ( _
    field As Field _
) As FactTable
Visual C++
public:
FactTable^ GetTable(
    Field^ field
)

Parameters

field
Type: PerpetuumSoft.Reporting.Data.Olap..::.Field

See Also

DataPivotTable Class
PerpetuumSoft.Reporting.Data.Olap Namespace


IsValidFact Method

[image]

.NET ModelKit Suite ClassReference
DataPivotTable..::.IsValidFact Method
DataPivotTable Class See Also Send Feedback
Gets value indicating whether the fact defined by given parameters has valid result.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool IsValidFact(
    FieldItem yItem,
    FieldItem xItem,
    Field fact
)
Visual Basic (Declaration)
Public Function IsValidFact ( _
    yItem As FieldItem, _
    xItem As FieldItem, _
    fact As Field _
) As Boolean
Visual C++
public:
bool IsValidFact(
    FieldItem^ yItem,
    FieldItem^ xItem,
    Field^ fact
)

Parameters

yItem
Type: PerpetuumSoft.Reporting.Data.Olap..::.FieldItem
xItem
Type: PerpetuumSoft.Reporting.Data.Olap..::.FieldItem
fact
Type: PerpetuumSoft.Reporting.Data.Olap..::.Field

See Also

DataPivotTable Class
PerpetuumSoft.Reporting.Data.Olap Namespace


DataPivotTable Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataPivotTable Properties
DataPivotTable Class See Also Send Feedback

The DataPivotTable type exposes the following members.

Properties

Name | Description
Error | Gets or sets the object representing an error. If a pivot table was built correctly this property should be NULL.
XRoot | Gets FieldItem which is the root of X dimension.
YRoot | Gets FieldItem which is the root of Y dimension.

See Also

DataPivotTable Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Error Property

[image]

.NET ModelKit Suite ClassReference
DataPivotTable..::.Error Property
DataPivotTable Class See Also Send Feedback
Gets or sets the object representing an error. If a pivot table was built correctly this property should be NULL.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Exception Error { get; set; }
Visual Basic (Declaration)
Public Property Error As Exception
Visual C++
public:
property Exception^ Error {
    Exception^ get ();
    void set (Exception^ value);
}

See Also

DataPivotTable Class
PerpetuumSoft.Reporting.Data.Olap Namespace


XRoot Property

[image]

.NET ModelKit Suite ClassReference
DataPivotTable..::.XRoot Property
DataPivotTable Class See Also Send Feedback
Gets FieldItem which is the root of X dimension.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem XRoot { get; }
Visual Basic (Declaration)
Public ReadOnly Property XRoot As FieldItem
Visual C++
public:
property FieldItem^ XRoot {
    FieldItem^ get ();
}

See Also

DataPivotTable Class
PerpetuumSoft.Reporting.Data.Olap Namespace


YRoot Property

[image]

.NET ModelKit Suite ClassReference
DataPivotTable..::.YRoot Property
DataPivotTable Class See Also Send Feedback
Gets FieldItem which is the root of Y dimension.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem YRoot { get; }
Visual Basic (Declaration)
Public ReadOnly Property YRoot As FieldItem
Visual C++
public:
property FieldItem^ YRoot {
    FieldItem^ get ();
}

See Also

DataPivotTable Class
PerpetuumSoft.Reporting.Data.Olap Namespace


EmptyFilter Class

[image]

.NET ModelKit Suite ClassReference
EmptyFilter Class
Members See Also Send Feedback
Represents an empty filter.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class EmptyFilter : IFilter
Visual Basic (Declaration)
Public Class EmptyFilter _
    Implements IFilter
Visual C++
public ref class EmptyFilter : IFilter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.EmptyFilter

See Also

EmptyFilter Members
PerpetuumSoft.Reporting.Data.Olap Namespace


EmptyFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
EmptyFilter Members
EmptyFilter Class Methods Properties See Also Send Feedback

The EmptyFilter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsFiltered | Implements IsFiltered(Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Filter | Gets a single empty filter.

See Also

EmptyFilter Class
PerpetuumSoft.Reporting.Data.Olap Namespace


EmptyFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
EmptyFilter Methods
EmptyFilter Class See Also Send Feedback

The EmptyFilter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsFiltered | Implements IsFiltered(Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmptyFilter Class
PerpetuumSoft.Reporting.Data.Olap Namespace


IsFiltered Method

[image]

.NET ModelKit Suite ClassReference
EmptyFilter..::.IsFiltered Method
EmptyFilter Class See Also Send Feedback
Implements IsFiltered(Object).

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool IsFiltered(
    Object value
)
Visual Basic (Declaration)
Public Function IsFiltered ( _
    value As Object _
) As Boolean
Visual C++
public:
virtual bool IsFiltered(
    Object^ value
) sealed

Parameters

value
Type: System..::.Object

Implements

IFilter..::.IsFiltered(Object)

See Also

EmptyFilter Class
PerpetuumSoft.Reporting.Data.Olap Namespace


EmptyFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
EmptyFilter Properties
EmptyFilter Class See Also Send Feedback

The EmptyFilter type exposes the following members.

Properties

Name | Description
Filter | Gets a single empty filter.

See Also

EmptyFilter Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Filter Property

[image]

.NET ModelKit Suite ClassReference
EmptyFilter..::.Filter Property
EmptyFilter Class See Also Send Feedback
Gets a single empty filter.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static EmptyFilter Filter { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Filter As EmptyFilter
Visual C++
public:
static property EmptyFilter^ Filter {
    EmptyFilter^ get ();
}

See Also

EmptyFilter Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Field Class

[image]

.NET ModelKit Suite ClassReference
Field Class
Members See Also Send Feedback
Represents a pivot table field.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Field
Visual Basic (Declaration)
Public Class Field
Visual C++
public ref class Field

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.Field

See Also

Field Members
PerpetuumSoft.Reporting.Data.Olap Namespace


Field Members

[image] [image]

.NET ModelKit Suite ClassReference
Field Members
Field Class Constructors Methods Properties See Also Send Feedback

The Field type exposes the following members.

Constructors

Name | Description
Field | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValueToString | Returns a fields value string notion.

Properties

Name | Description
Aggregate | Gets or sets the AggregateFunctionFactory object which creates an aggregate function.
Caption | Gets or sets field caption.
DisplayExpression | Gets or sets the expression for displaying data of the given field.
Expression | Gets or sets the expression for calculating data of this field.
Filter | Gets or sets IFilter object used for data filtration.
Format | Gets or sets string format used for field data printing.
ShowPercent | Gets or sets the value that indicates whether the data will be displayed in percentage terms.
SortOrder | Gets or sets SortOrder indicating the sort order.
TotalLabel | Gets or sets the total value caption.
Width | Gets or sets field column width.

See Also

Field Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Field Constructor

[image] [image]

.NET ModelKit Suite ClassReference
Field Constructor
Field Class See Also Send Feedback

Overload List

Name | Description
Field()()() | Initializes a new instance of the Field class.
Field(String, String) | Initializes a new instance of the Field class.
Field(String, String, SortOrder) | Initializes a new instance of the Field class.

See Also

Field Class
Field Members
PerpetuumSoft.Reporting.Data.Olap Namespace


Field Constructor

[image]

.NET ModelKit Suite ClassReference
Field Constructor
Field Class See Also Send Feedback
Initializes a new instance of the Field class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Field()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Field()

See Also

Field Class
Field Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


Field Constructor (String, String)

[image]

.NET ModelKit Suite ClassReference
Field Constructor (String, String)
Field Class See Also Send Feedback
Initializes a new instance of the Field class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Field(
    string caption,
    string expression
)
Visual Basic (Declaration)
Public Sub New ( _
    caption As String, _
    expression As String _
)
Visual C++
public:
Field(
    String^ caption,
    String^ expression
)

Parameters

caption
Type: System..::.String
expression
Type: System..::.String

See Also

Field Class
Field Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


Field Constructor (String, String, SortOrder)

[image]

.NET ModelKit Suite ClassReference
Field Constructor (String, String, SortOrder)
Field Class See Also Send Feedback
Initializes a new instance of the Field class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Field(
    string caption,
    string expression,
    SortOrder sortOrder
)
Visual Basic (Declaration)
Public Sub New ( _
    caption As String, _
    expression As String, _
    sortOrder As SortOrder _
)
Visual C++
public:
Field(
    String^ caption,
    String^ expression,
    SortOrder sortOrder
)

Parameters

caption
Type: System..::.String
expression
Type: System..::.String
sortOrder
Type: PerpetuumSoft.Reporting.Data.Olap..::.SortOrder

See Also

Field Class
Field Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


Field Methods

[image] [image]

.NET ModelKit Suite ClassReference
Field Methods
Field Class See Also Send Feedback

The Field type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValueToString | Returns a fields value string notion.

See Also

Field Class
PerpetuumSoft.Reporting.Data.Olap Namespace


ValueToString Method

[image]

.NET ModelKit Suite ClassReference
Field..::.ValueToString Method
Field Class See Also Send Feedback
Returns a fields value string notion.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string ValueToString(
    Object value,
    bool showZeroValues
)
Visual Basic (Declaration)
Public Function ValueToString ( _
    value As Object, _
    showZeroValues As Boolean _
) As String
Visual C++
public:
String^ ValueToString(
    Object^ value,
    bool showZeroValues
)

Parameters

value
Type: System..::.Object
showZeroValues
Type: System..::.Boolean

See Also

Field Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Field Properties

[image] [image]

.NET ModelKit Suite ClassReference
Field Properties
Field Class See Also Send Feedback

The Field type exposes the following members.

Properties

Name | Description
Aggregate | Gets or sets the AggregateFunctionFactory object which creates an aggregate function.
Caption | Gets or sets field caption.
DisplayExpression | Gets or sets the expression for displaying data of the given field.
Expression | Gets or sets the expression for calculating data of this field.
Filter | Gets or sets IFilter object used for data filtration.
Format | Gets or sets string format used for field data printing.
ShowPercent | Gets or sets the value that indicates whether the data will be displayed in percentage terms.
SortOrder | Gets or sets SortOrder indicating the sort order.
TotalLabel | Gets or sets the total value caption.
Width | Gets or sets field column width.

See Also

Field Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Aggregate Property

[image]

.NET ModelKit Suite ClassReference
Field..::.Aggregate Property
Field Class See Also Send Feedback
Gets or sets the AggregateFunctionFactory object which creates an aggregate function.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public AggregateFunctionFactory Aggregate { get; set; }
Visual Basic (Declaration)
Public Property Aggregate As AggregateFunctionFactory
Visual C++
public:
property AggregateFunctionFactory^ Aggregate {
    AggregateFunctionFactory^ get ();
    void set (AggregateFunctionFactory^ value);
}

See Also

Field Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Caption Property

[image]

.NET ModelKit Suite ClassReference
Field..::.Caption Property
Field Class See Also Send Feedback
Gets or sets field caption.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Caption { get; set; }
Visual Basic (Declaration)
Public Property Caption As String
Visual C++
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class
PerpetuumSoft.Reporting.Data.Olap Namespace


DisplayExpression Property

[image]

.NET ModelKit Suite ClassReference
Field..::.DisplayExpression Property
Field Class See Also Send Feedback
Gets or sets the expression for displaying data of the given field.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string DisplayExpression { get; set; }
Visual Basic (Declaration)
Public Property DisplayExpression As String
Visual C++
public:
property String^ DisplayExpression {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Expression Property

[image]

.NET ModelKit Suite ClassReference
Field..::.Expression Property
Field Class See Also Send Feedback
Gets or sets the expression for calculating data of this field.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Filter Property

[image]

.NET ModelKit Suite ClassReference
Field..::.Filter Property
Field Class See Also Send Feedback
Gets or sets IFilter object used for data filtration.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public IFilter Filter { get; set; }
Visual Basic (Declaration)
Public Property Filter As IFilter
Visual C++
public:
property IFilter^ Filter {
    IFilter^ get ();
    void set (IFilter^ value);
}

See Also

Field Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Format Property

[image]

.NET ModelKit Suite ClassReference
Field..::.Format Property
Field Class See Also Send Feedback
Gets or sets string format used for field data printing.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Format { get; set; }
Visual Basic (Declaration)
Public Property Format As String
Visual C++
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class
PerpetuumSoft.Reporting.Data.Olap Namespace


ShowPercent Property

[image]

.NET ModelKit Suite ClassReference
Field..::.ShowPercent Property
Field Class See Also Send Feedback
Gets or sets the value that indicates whether the data will be displayed in percentage terms.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowPercent { get; set; }
Visual Basic (Declaration)
Public Property ShowPercent As Boolean
Visual C++
public:
property bool ShowPercent {
    bool get ();
    void set (bool value);
}

See Also

Field Class
PerpetuumSoft.Reporting.Data.Olap Namespace


SortOrder Property

[image]

.NET ModelKit Suite ClassReference
Field..::.SortOrder Property
Field Class See Also Send Feedback
Gets or sets SortOrder indicating the sort order.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public SortOrder SortOrder { get; set; }
Visual Basic (Declaration)
Public Property SortOrder As SortOrder
Visual C++
public:
property SortOrder SortOrder {
    SortOrder get ();
    void set (SortOrder value);
}

See Also

Field Class
PerpetuumSoft.Reporting.Data.Olap Namespace


TotalLabel Property

[image]

.NET ModelKit Suite ClassReference
Field..::.TotalLabel Property
Field Class See Also Send Feedback
Gets or sets the total value caption.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string TotalLabel { get; set; }
Visual Basic (Declaration)
Public Property TotalLabel As String
Visual C++
public:
property String^ TotalLabel {
    String^ get ();
    void set (String^ value);
}

See Also

Field Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
Field..::.Width Property
Field Class See Also Send Feedback
Gets or sets field column width.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public float Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Single
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}

See Also

Field Class
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItem Class

[image]

.NET ModelKit Suite ClassReference
FieldItem Class
Members See Also Send Feedback
Represents a dimension item of a pivot table.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class FieldItem
Visual Basic (Declaration)
Public Class FieldItem
Visual C++
public ref class FieldItem

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.FieldItem

See Also

FieldItem Members
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItem Members

[image] [image]

.NET ModelKit Suite ClassReference
FieldItem Members
FieldItem Class Constructors Methods Properties See Also Send Feedback

The FieldItem type exposes the following members.

Constructors

Name | Description
FieldItem | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSheetCount | Returns the number of "sheet" items for the given item.
GetTreeDepth | Returns the depth of a tree which root is the given item.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ChildItems | Gets FieldItemCollection containing child items.
Collapsed | Gets or sets the value indicating whether child items will be displayed.
DisplayValue | Gets a value for displaying a field item.
Index | Gets or sets an index of a pivot table row or column.
IsTotal | Gets the value indicating whether this item is the group total.
Parent | Gets a parent item for the given field item.
Value | Gets a field item value.

See Also

FieldItem Class
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItem Constructor

[image] [image]

.NET ModelKit Suite ClassReference
FieldItem Constructor
FieldItem Class See Also Send Feedback

Overload List

Name | Description
FieldItem(Object) | Initializes a new instance of the FieldItem class.
FieldItem(Object, FieldItem) | Initializes a new instance of the FieldItem class.
FieldItem(Object, Int32) | Initializes a new instance of the FieldItem class.
FieldItem(Object, Int32, FieldItem) | Initializes a new instance of the FieldItem class.
FieldItem(Object, Object, FieldItem) | Initializes a new instance of the FieldItem class.
FieldItem(Object, Object, Int32, FieldItem) | Initializes a new instance of the FieldItem class.

See Also

FieldItem Class
FieldItem Members
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItem Constructor (Object)

[image]

.NET ModelKit Suite ClassReference
FieldItem Constructor (Object)
FieldItem Class See Also Send Feedback
Initializes a new instance of the FieldItem class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem(
    Object value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Object _
)
Visual C++
public:
FieldItem(
    Object^ value
)

Parameters

value
Type: System..::.Object

See Also

FieldItem Class
FieldItem Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItem Constructor (Object, FieldItem)

[image]

.NET ModelKit Suite ClassReference
FieldItem Constructor (Object, FieldItem)
FieldItem Class See Also Send Feedback
Initializes a new instance of the FieldItem class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem(
    Object value,
    FieldItem parent
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Object, _
    parent As FieldItem _
)
Visual C++
public:
FieldItem(
    Object^ value,
    FieldItem^ parent
)

Parameters

value
Type: System..::.Object
parent
Type: PerpetuumSoft.Reporting.Data.Olap..::.FieldItem

See Also

FieldItem Class
FieldItem Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItem Constructor (Object, Int32)

[image]

.NET ModelKit Suite ClassReference
FieldItem Constructor (Object, Int32)
FieldItem Class See Also Send Feedback
Initializes a new instance of the FieldItem class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem(
    Object value,
    int index
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Object, _
    index As Integer _
)
Visual C++
public:
FieldItem(
    Object^ value,
    int index
)

Parameters

value
Type: System..::.Object
index
Type: System..::.Int32

See Also

FieldItem Class
FieldItem Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItem Constructor (Object, Int32, FieldItem)

[image]

.NET ModelKit Suite ClassReference
FieldItem Constructor (Object, Int32, FieldItem)
FieldItem Class See Also Send Feedback
Initializes a new instance of the FieldItem class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem(
    Object value,
    int index,
    FieldItem parent
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Object, _
    index As Integer, _
    parent As FieldItem _
)
Visual C++
public:
FieldItem(
    Object^ value,
    int index,
    FieldItem^ parent
)

Parameters

value
Type: System..::.Object
index
Type: System..::.Int32
parent
Type: PerpetuumSoft.Reporting.Data.Olap..::.FieldItem

See Also

FieldItem Class
FieldItem Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItem Constructor (Object, Object, FieldItem)

[image]

.NET ModelKit Suite ClassReference
FieldItem Constructor (Object, Object, FieldItem)
FieldItem Class See Also Send Feedback
Initializes a new instance of the FieldItem class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem(
    Object value,
    Object displayValue,
    FieldItem parent
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Object, _
    displayValue As Object, _
    parent As FieldItem _
)
Visual C++
public:
FieldItem(
    Object^ value,
    Object^ displayValue,
    FieldItem^ parent
)

Parameters

value
Type: System..::.Object
displayValue
Type: System..::.Object
parent
Type: PerpetuumSoft.Reporting.Data.Olap..::.FieldItem

See Also

FieldItem Class
FieldItem Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItem Constructor (Object, Object, Int32, FieldItem)

[image]

.NET ModelKit Suite ClassReference
FieldItem Constructor (Object, Object, Int32, FieldItem)
FieldItem Class See Also Send Feedback
Initializes a new instance of the FieldItem class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem(
    Object value,
    Object displayValue,
    int index,
    FieldItem parent
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Object, _
    displayValue As Object, _
    index As Integer, _
    parent As FieldItem _
)
Visual C++
public:
FieldItem(
    Object^ value,
    Object^ displayValue,
    int index,
    FieldItem^ parent
)

Parameters

value
Type: System..::.Object
displayValue
Type: System..::.Object
index
Type: System..::.Int32
parent
Type: PerpetuumSoft.Reporting.Data.Olap..::.FieldItem

See Also

FieldItem Class
FieldItem Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItem Methods

[image] [image]

.NET ModelKit Suite ClassReference
FieldItem Methods
FieldItem Class See Also Send Feedback

The FieldItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSheetCount | Returns the number of "sheet" items for the given item.
GetTreeDepth | Returns the depth of a tree which root is the given item.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldItem Class
PerpetuumSoft.Reporting.Data.Olap Namespace


GetSheetCount Method

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.GetSheetCount Method
FieldItem Class See Also Send Feedback
Returns the number of "sheet" items for the given item.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int GetSheetCount()
Visual Basic (Declaration)
Public Function GetSheetCount As Integer
Visual C++
public:
int GetSheetCount()

See Also

FieldItem Class
PerpetuumSoft.Reporting.Data.Olap Namespace


GetTreeDepth Method

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.GetTreeDepth Method
FieldItem Class See Also Send Feedback
Returns the depth of a tree which root is the given item.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int GetTreeDepth()
Visual Basic (Declaration)
Public Function GetTreeDepth As Integer
Visual C++
public:
int GetTreeDepth()

See Also

FieldItem Class
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItem Properties

[image] [image]

.NET ModelKit Suite ClassReference
FieldItem Properties
FieldItem Class See Also Send Feedback

The FieldItem type exposes the following members.

Properties

Name | Description
ChildItems | Gets FieldItemCollection containing child items.
Collapsed | Gets or sets the value indicating whether child items will be displayed.
DisplayValue | Gets a value for displaying a field item.
Index | Gets or sets an index of a pivot table row or column.
IsTotal | Gets the value indicating whether this item is the group total.
Parent | Gets a parent item for the given field item.
Value | Gets a field item value.

See Also

FieldItem Class
PerpetuumSoft.Reporting.Data.Olap Namespace


ChildItems Property

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.ChildItems Property
FieldItem Class See Also Send Feedback
Gets FieldItemCollection containing child items.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldItemCollection ChildItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChildItems As FieldItemCollection
Visual C++
public:
property FieldItemCollection^ ChildItems {
    FieldItemCollection^ get ();
}

See Also

FieldItem Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Collapsed Property

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.Collapsed Property
FieldItem Class See Also Send Feedback
Gets or sets the value indicating whether child items will be displayed.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Collapsed { get; set; }
Visual Basic (Declaration)
Public Property Collapsed As Boolean
Visual C++
public:
property bool Collapsed {
    bool get ();
    void set (bool value);
}

See Also

FieldItem Class
PerpetuumSoft.Reporting.Data.Olap Namespace


DisplayValue Property

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.DisplayValue Property
FieldItem Class See Also Send Feedback
Gets a value for displaying a field item.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object DisplayValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayValue As Object
Visual C++
public:
property Object^ DisplayValue {
    Object^ get ();
}

See Also

FieldItem Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Index Property

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.Index Property
FieldItem Class See Also Send Feedback
Gets or sets an index of a pivot table row or column.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int Index { get; set; }
Visual Basic (Declaration)
Public Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
    void set (int value);
}

See Also

FieldItem Class
PerpetuumSoft.Reporting.Data.Olap Namespace


IsTotal Property

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.IsTotal Property
FieldItem Class See Also Send Feedback
Gets the value indicating whether this item is the group total.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool IsTotal { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsTotal As Boolean
Visual C++
public:
property bool IsTotal {
    bool get ();
}

See Also

FieldItem Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Parent Property

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.Parent Property
FieldItem Class See Also Send Feedback
Gets a parent item for the given field item.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem Parent { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parent As FieldItem
Visual C++
public:
property FieldItem^ Parent {
    FieldItem^ get ();
}

See Also

FieldItem Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.Value Property
FieldItem Class See Also Send Feedback
Gets a field item value.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
}

See Also

FieldItem Class
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItem.ErrorValue Class

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.ErrorValue Class
FieldItem Class Members See Also Send Feedback
Represents incorrect field item data.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ErrorValue
Visual Basic (Declaration)
Public Class ErrorValue
Visual C++
public ref class ErrorValue

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.FieldItem..::.ErrorValue

See Also

FieldItem..::.ErrorValue Members
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItem.ErrorValue Members

[image] [image]

.NET ModelKit Suite ClassReference
FieldItem..::.ErrorValue Members
FieldItem..::.ErrorValue Class Constructors Methods See Also Send Feedback

Represents a dimension item of a pivot table.

The FieldItem..::.ErrorValue type exposes the following members.

Constructors

Name | Description
FieldItem..::.ErrorValue | Initializes a new instance of the FieldItem..::.ErrorValue class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldItem..::.ErrorValue Class
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItem.ErrorValue Constructor

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.ErrorValue Constructor
FieldItem..::.ErrorValue Class See Also Send Feedback
Initializes a new instance of the FieldItem..::.ErrorValue class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ErrorValue(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
ErrorValue(
    String^ message
)

Parameters

message
Type: System..::.String

See Also

FieldItem..::.ErrorValue Class
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItem.ErrorValue Methods

[image] [image]

.NET ModelKit Suite ClassReference
FieldItem..::.ErrorValue Methods
FieldItem..::.ErrorValue Class See Also Send Feedback

The FieldItem..::.ErrorValue type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldItem..::.ErrorValue Class
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItem.TotalValue Class

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.TotalValue Class
FieldItem Class Members See Also Send Feedback
Represents total item data.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class TotalValue
Visual Basic (Declaration)
Public Class TotalValue
Visual C++
public ref class TotalValue

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.FieldItem..::.TotalValue

See Also

FieldItem..::.TotalValue Members
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItem.TotalValue Members

[image] [image]

.NET ModelKit Suite ClassReference
FieldItem..::.TotalValue Members
FieldItem..::.TotalValue Class Constructors Methods See Also Send Feedback

Represents a dimension item of a pivot table.

The FieldItem..::.TotalValue type exposes the following members.

Constructors

Name | Description
FieldItem..::.TotalValue | Initializes a new instance of the FieldItem..::.TotalValue class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldItem..::.TotalValue Class
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItem.TotalValue Constructor

[image]

.NET ModelKit Suite ClassReference
FieldItem..::.TotalValue Constructor
FieldItem..::.TotalValue Class See Also Send Feedback
Initializes a new instance of the FieldItem..::.TotalValue class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public TotalValue(
    Field field
)
Visual Basic (Declaration)
Public Sub New ( _
    field As Field _
)
Visual C++
public:
TotalValue(
    Field^ field
)

Parameters

field
Type: PerpetuumSoft.Reporting.Data.Olap..::.Field

See Also

FieldItem..::.TotalValue Class
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItem.TotalValue Methods

[image] [image]

.NET ModelKit Suite ClassReference
FieldItem..::.TotalValue Methods
FieldItem..::.TotalValue Class See Also Send Feedback

The FieldItem..::.TotalValue type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldItem..::.TotalValue Class
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItemCollection Class

[image]

.NET ModelKit Suite ClassReference
FieldItemCollection Class
Members See Also Send Feedback
Represents the collection of FieldItem.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class FieldItemCollection : SortedList
Visual Basic (Declaration)
Public Class FieldItemCollection _
    Inherits SortedList
Visual C++
public ref class FieldItemCollection : public SortedList

Inheritance Hierarchy

System..::.Object
System.Collections..::.SortedList
PerpetuumSoft.Reporting.Data.Olap..::.FieldItemCollection

See Also

FieldItemCollection Members
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItemCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
FieldItemCollection Members
FieldItemCollection Class Constructors Methods Properties See Also Send Feedback

The FieldItemCollection type exposes the following members.

Constructors

Name | Description
FieldItemCollection | Initializes a new instance of the FieldItemCollection class.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all elements from a SortedList object. (Inherited from SortedList.)
Clone | Creates a shallow copy of a SortedList object. (Inherited from SortedList.)
Contains | Determines whether a SortedList object contains a specific key. (Inherited from SortedList.)
ContainsKey | Determines whether a SortedList object contains a specific key. (Inherited from SortedList.)
ContainsValue | Determines whether a SortedList object contains a specific value. (Inherited from SortedList.)
CopyTo | Copies SortedList elements to a one-dimensional Array object, starting at the specified index in the array. (Inherited from SortedList.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByIndex | Gets the value at the specified index of a SortedList object. (Inherited from SortedList.)
GetEnumerator | Implements GetEnumerator()()(). (Overrides SortedList..::.GetEnumerator()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetKey | Gets the key at the specified index of a SortedList object. (Inherited from SortedList.)
GetKeyList | Gets the keys in a SortedList object. (Inherited from SortedList.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueList | Gets the values in a SortedList object. (Inherited from SortedList.)
IndexOfKey | Returns the zero-based index of the specified key in a SortedList object. (Inherited from SortedList.)
IndexOfValue | Returns the zero-based index of the first occurrence of the specified value in a SortedList object. (Inherited from SortedList.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the element with the specified key from a SortedList object. (Inherited from SortedList.)
RemoveAt | Removes the element at the specified index of a SortedList object. (Inherited from SortedList.)
SetByIndex | Replaces the value at a specific index in a SortedList object. (Inherited from SortedList.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimToSize | Sets the capacity to the actual number of elements in a SortedList object. (Inherited from SortedList.)

Properties

Name | Description
Capacity | Gets or sets the capacity of a SortedList object. (Inherited from SortedList.)
Count | Gets the number of elements contained in a SortedList object. (Inherited from SortedList.)
IsFixedSize | Gets a value indicating whether a SortedList object has a fixed size. (Inherited from SortedList.)
IsReadOnly | Gets a value indicating whether a SortedList object is read-only. (Inherited from SortedList.)
IsSynchronized | Gets a value indicating whether access to a SortedList object is synchronized (thread safe). (Inherited from SortedList.)
Item | Overloaded.
Keys | Gets the keys in a SortedList object. (Inherited from SortedList.)
SyncRoot | Gets an object that can be used to synchronize access to a SortedList object. (Inherited from SortedList.)
Values | Gets the values in a SortedList object. (Inherited from SortedList.)

See Also

FieldItemCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItemCollection Constructor

[image]

.NET ModelKit Suite ClassReference
FieldItemCollection Constructor
FieldItemCollection Class See Also Send Feedback
Initializes a new instance of the FieldItemCollection class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldItemCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FieldItemCollection()

See Also

FieldItemCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItemCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
FieldItemCollection Methods
FieldItemCollection Class See Also Send Feedback

The FieldItemCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all elements from a SortedList object. (Inherited from SortedList.)
Clone | Creates a shallow copy of a SortedList object. (Inherited from SortedList.)
Contains | Determines whether a SortedList object contains a specific key. (Inherited from SortedList.)
ContainsKey | Determines whether a SortedList object contains a specific key. (Inherited from SortedList.)
ContainsValue | Determines whether a SortedList object contains a specific value. (Inherited from SortedList.)
CopyTo | Copies SortedList elements to a one-dimensional Array object, starting at the specified index in the array. (Inherited from SortedList.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByIndex | Gets the value at the specified index of a SortedList object. (Inherited from SortedList.)
GetEnumerator | Implements GetEnumerator()()(). (Overrides SortedList..::.GetEnumerator()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetKey | Gets the key at the specified index of a SortedList object. (Inherited from SortedList.)
GetKeyList | Gets the keys in a SortedList object. (Inherited from SortedList.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValueList | Gets the values in a SortedList object. (Inherited from SortedList.)
IndexOfKey | Returns the zero-based index of the specified key in a SortedList object. (Inherited from SortedList.)
IndexOfValue | Returns the zero-based index of the first occurrence of the specified value in a SortedList object. (Inherited from SortedList.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the element with the specified key from a SortedList object. (Inherited from SortedList.)
RemoveAt | Removes the element at the specified index of a SortedList object. (Inherited from SortedList.)
SetByIndex | Replaces the value at a specific index in a SortedList object. (Inherited from SortedList.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimToSize | Sets the capacity to the actual number of elements in a SortedList object. (Inherited from SortedList.)

See Also

FieldItemCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Add Method

[image] [image]

.NET ModelKit Suite ClassReference
FieldItemCollection..::.Add Method
FieldItemCollection Class See Also Send Feedback

Overload List

Name | Description
Add(FieldItem) | Adds the FieldItem to the collection.
Add(Object, Object) | Adds an element with the specified key and value to a SortedList object. (Inherited from SortedList.)

See Also

FieldItemCollection Class
FieldItemCollection Members
PerpetuumSoft.Reporting.Data.Olap Namespace


Add Method (FieldItem)

[image]

.NET ModelKit Suite ClassReference
FieldItemCollection..::.Add Method (FieldItem)
FieldItemCollection Class See Also Send Feedback
Adds the FieldItem to the collection.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem Add(
    FieldItem value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As FieldItem _
) As FieldItem
Visual C++
public:
FieldItem^ Add(
    FieldItem^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Data.Olap..::.FieldItem

See Also

FieldItemCollection Class
Add Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


GetEnumerator Method

[image]

.NET ModelKit Suite ClassReference
FieldItemCollection..::.GetEnumerator Method
FieldItemCollection Class See Also Send Feedback
Implements GetEnumerator()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override IDictionaryEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Overrides Function GetEnumerator As IDictionaryEnumerator
Visual C++
public:
virtual IDictionaryEnumerator^ GetEnumerator() override

Implements

IDictionary..::.GetEnumerator()()()

See Also

FieldItemCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldItemCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
FieldItemCollection Properties
FieldItemCollection Class See Also Send Feedback

The FieldItemCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the capacity of a SortedList object. (Inherited from SortedList.)
Count | Gets the number of elements contained in a SortedList object. (Inherited from SortedList.)
IsFixedSize | Gets a value indicating whether a SortedList object has a fixed size. (Inherited from SortedList.)
IsReadOnly | Gets a value indicating whether a SortedList object is read-only. (Inherited from SortedList.)
IsSynchronized | Gets a value indicating whether access to a SortedList object is synchronized (thread safe). (Inherited from SortedList.)
Item | Overloaded.
Keys | Gets the keys in a SortedList object. (Inherited from SortedList.)
SyncRoot | Gets an object that can be used to synchronize access to a SortedList object. (Inherited from SortedList.)
Values | Gets the values in a SortedList object. (Inherited from SortedList.)

See Also

FieldItemCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Item Property

[image] [image]

.NET ModelKit Suite ClassReference
FieldItemCollection..::.Item Property
FieldItemCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Implements Item[([(Object])]).
Item[([(Object])]) | Implements Item[([(Object])]).
Item[([(Int32, Boolean])]) | Gets FieldItem at the specified index.

See Also

FieldItemCollection Class
FieldItemCollection Members
PerpetuumSoft.Reporting.Data.Olap Namespace


Item Property (Int32)

[image]

.NET ModelKit Suite ClassReference
FieldItemCollection..::.Item Property (Int32)
FieldItemCollection Class See Also Send Feedback
Implements Item[([(Object])]).

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As FieldItem
Visual C++
public:
property FieldItem^ default[int index] {
    FieldItem^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

FieldItemCollection Class
Item Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


Item Property (Object)

[image]

.NET ModelKit Suite ClassReference
FieldItemCollection..::.Item Property (Object)
FieldItemCollection Class See Also Send Feedback
Implements Item[([(Object])]).

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem this[
    Object value
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    value As Object _
) As FieldItem
Visual C++
public:
property FieldItem^ default[Object^ value] {
    FieldItem^ get (Object^ value);
}

Parameters

value
Type: System..::.Object

See Also

FieldItemCollection Class
Item Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


Item Property (Int32, Boolean)

[image]

.NET ModelKit Suite ClassReference
FieldItemCollection..::.Item Property (Int32, Boolean)
FieldItemCollection Class See Also Send Feedback
Gets FieldItem at the specified index.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldItem this[
    int index,
    bool backOrder
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer, _
    backOrder As Boolean _
) As FieldItem
Visual C++
public:
property FieldItem^ default[int index, bool backOrder] {
    FieldItem^ get (int index, bool backOrder);
}

Parameters

index
Type: System..::.Int32
backOrder
Type: System..::.Boolean

See Also

FieldItemCollection Class
Item Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldsCollection Class

[image]

.NET ModelKit Suite ClassReference
FieldsCollection Class
Members See Also Send Feedback
Represents the collection of Field.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class FieldsCollection : CollectionBase
Visual Basic (Declaration)
Public Class FieldsCollection _
    Inherits CollectionBase
Visual C++
public ref class FieldsCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Reporting.Data.Olap..::.FieldsCollection

See Also

FieldsCollection Members
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldsCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
FieldsCollection Members
FieldsCollection Class Constructors Methods Properties Events See Also Send Feedback

The FieldsCollection type exposes the following members.

Constructors

Name | Description
FieldsCollection | Initializes a new instance of the FieldsCollection class.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

Events

Name | Description
CollectionChanged | Occurs after collection change.

See Also

FieldsCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldsCollection Constructor

[image]

.NET ModelKit Suite ClassReference
FieldsCollection Constructor
FieldsCollection Class See Also Send Feedback
Initializes a new instance of the FieldsCollection class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldsCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FieldsCollection()

See Also

FieldsCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldsCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
FieldsCollection Methods
FieldsCollection Class See Also Send Feedback

The FieldsCollection type exposes the following members.

Methods

Name | Description
Add | Implements Add(Object).
AddRange | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Implements Contains(Object).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
Insert | Implements Insert(Int32, Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Implements Remove(Object).
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldsCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.Add Method
FieldsCollection Class See Also Send Feedback
Implements Add(Object).

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Field Add(
    Field value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As Field _
) As Field
Visual C++
public:
Field^ Add(
    Field^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Data.Olap..::.Field

See Also

FieldsCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


AddRange Method

[image] [image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.AddRange Method
FieldsCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<Field>[]()[]) | Adds the array of Field to the collection.
AddRange(FieldsCollection) | Adds the collection of Field to the collection.

See Also

FieldsCollection Class
FieldsCollection Members
PerpetuumSoft.Reporting.Data.Olap Namespace


AddRange Method (Field[])

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.AddRange Method (array<Field>[]()[])
FieldsCollection Class See Also Send Feedback
Adds the array of Field to the collection.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    Field[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As Field() _
)
Visual C++
public:
void AddRange(
    array<Field^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Reporting.Data.Olap..::.Field >[]()[]

See Also

FieldsCollection Class
AddRange Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


AddRange Method (FieldsCollection)

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.AddRange Method (FieldsCollection)
FieldsCollection Class See Also Send Feedback
Adds the collection of Field to the collection.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    FieldsCollection values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As FieldsCollection _
)
Visual C++
public:
void AddRange(
    FieldsCollection^ values
)

Parameters

values
Type: PerpetuumSoft.Reporting.Data.Olap..::.FieldsCollection

See Also

FieldsCollection Class
AddRange Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.Contains Method
FieldsCollection Class See Also Send Feedback
Implements Contains(Object).

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    Field value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As Field _
) As Boolean
Visual C++
public:
bool Contains(
    Field^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Data.Olap..::.Field

See Also

FieldsCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.IndexOf Method
FieldsCollection Class See Also Send Feedback
Implements IndexOf(Object).

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    Field value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As Field _
) As Integer
Visual C++
public:
int IndexOf(
    Field^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Data.Olap..::.Field

See Also

FieldsCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.Insert Method
FieldsCollection Class See Also Send Feedback
Implements Insert(Int32, Object).

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    Field value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As Field _
)
Visual C++
public:
void Insert(
    int index,
    Field^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Reporting.Data.Olap..::.Field

See Also

FieldsCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.Remove Method
FieldsCollection Class See Also Send Feedback
Implements Remove(Object).

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    Field value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As Field _
)
Visual C++
public:
void Remove(
    Field^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Data.Olap..::.Field

See Also

FieldsCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldsCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
FieldsCollection Properties
FieldsCollection Class See Also Send Feedback

The FieldsCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

FieldsCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Item Property

[image] [image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.Item Property
FieldsCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Implements Item[([(Int32])]).
Item[([(String])]) | Gets Field at the specified index.

See Also

FieldsCollection Class
FieldsCollection Members
PerpetuumSoft.Reporting.Data.Olap Namespace


Item Property (Int32)

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.Item Property (Int32)
FieldsCollection Class See Also Send Feedback
Implements Item[([(Int32])]).

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Field this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Field
Visual C++
public:
property Field^ default[int index] {
    Field^ get (int index);
    void set (int index, Field^ value);
}

Parameters

index
Type: System..::.Int32

See Also

FieldsCollection Class
Item Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


Item Property (String)

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.Item Property (String)
FieldsCollection Class See Also Send Feedback
Gets Field at the specified index.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Field this[
    string caption
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    caption As String _
) As Field
Visual C++
public:
property Field^ default[String^ caption] {
    Field^ get (String^ caption);
}

Parameters

caption
Type: System..::.String

See Also

FieldsCollection Class
Item Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldsCollection Events

[image] [image]

.NET ModelKit Suite ClassReference
FieldsCollection Events
FieldsCollection Class See Also Send Feedback

The FieldsCollection type exposes the following members.

Events

Name | Description
CollectionChanged | Occurs after collection change.

See Also

FieldsCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


CollectionChanged Event

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.CollectionChanged Event
FieldsCollection Class See Also Send Feedback
Occurs after collection change.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event FieldsCollection..::.CollectionChangeEventHandler CollectionChanged
Visual Basic (Declaration)
Public Event CollectionChanged As FieldsCollection..::.CollectionChangeEventHandler
Visual C++
public:
 event FieldsCollection..::.CollectionChangeEventHandler^ CollectionChanged {
    void add (FieldsCollection..::.CollectionChangeEventHandler^ value);
    void remove (FieldsCollection..::.CollectionChangeEventHandler^ value);
}

See Also

FieldsCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


FieldsCollection.CollectionChangeEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
FieldsCollection..::.CollectionChangeEventHandler Delegate
FieldsCollection Class See Also Send Feedback
Represents the method that will handle CollectionChanged.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate void CollectionChangeEventHandler(
    Object sender,
    EventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub CollectionChangeEventHandler ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
public delegate void CollectionChangeEventHandler(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

PerpetuumSoft.Reporting.Data.Olap Namespace


FilterException Class

[image]

.NET ModelKit Suite ClassReference
FilterException Class
Members See Also Send Feedback
Base class for all exceptions thrown from filters.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
[SerializableAttribute]
public class FilterException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class FilterException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class FilterException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
PerpetuumSoft.Reporting.Data.Olap..::.FilterException

See Also

FilterException Members
PerpetuumSoft.Reporting.Data.Olap Namespace


FilterException Members

[image] [image]

.NET ModelKit Suite ClassReference
FilterException Members
FilterException Class Constructors Methods Properties See Also Send Feedback

The FilterException type exposes the following members.

Constructors

Name | Description
FilterException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FilterException Class
PerpetuumSoft.Reporting.Data.Olap Namespace


FilterException Constructor

[image] [image]

.NET ModelKit Suite ClassReference
FilterException Constructor
FilterException Class See Also Send Feedback

Overload List

Name | Description
FilterException()()() | Initializes a new instance of the FilterException class.
FilterException(String) | Initializes a new instance of the FilterException class.
FilterException(String, Exception) | Initializes a new instance of the FilterException class.

See Also

FilterException Class
FilterException Members
PerpetuumSoft.Reporting.Data.Olap Namespace


FilterException Constructor

[image]

.NET ModelKit Suite ClassReference
FilterException Constructor
FilterException Class See Also Send Feedback
Initializes a new instance of the FilterException class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FilterException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FilterException()

See Also

FilterException Class
FilterException Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


FilterException Constructor (String)

[image]

.NET ModelKit Suite ClassReference
FilterException Constructor (String)
FilterException Class See Also Send Feedback
Initializes a new instance of the FilterException class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FilterException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
FilterException(
    String^ message
)

Parameters

message
Type: System..::.String

See Also

FilterException Class
FilterException Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


FilterException Constructor (String, Exception)

[image]

.NET ModelKit Suite ClassReference
FilterException Constructor (String, Exception)
FilterException Class See Also Send Feedback
Initializes a new instance of the FilterException class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FilterException(
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
FilterException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::.String
innerException
Type: System..::.Exception

See Also

FilterException Class
FilterException Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


FilterException Methods

[image] [image]

.NET ModelKit Suite ClassReference
FilterException Methods
FilterException Class See Also Send Feedback

The FilterException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FilterException Class
PerpetuumSoft.Reporting.Data.Olap Namespace


FilterException Properties

[image] [image]

.NET ModelKit Suite ClassReference
FilterException Properties
FilterException Class See Also Send Feedback

The FilterException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FilterException Class
PerpetuumSoft.Reporting.Data.Olap Namespace


IAggregateFunction Interface

[image]

.NET ModelKit Suite ClassReference
IAggregateFunction Interface
Members See Also Send Feedback
Represents the aggregate function.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public interface IAggregateFunction
Visual Basic (Declaration)
Public Interface IAggregateFunction
Visual C++
public interface class IAggregateFunction

See Also

IAggregateFunction Members
PerpetuumSoft.Reporting.Data.Olap Namespace


IAggregateFunction Members

[image] [image]

.NET ModelKit Suite ClassReference
IAggregateFunction Members
IAggregateFunction Interface Methods Properties See Also Send Feedback

The IAggregateFunction type exposes the following members.

Methods

Name | Description
AddValue | Adds a value to the aggregation result.
GetResult | Returns the aggregation result.

Properties

Name | Description
ValidResult | Gets value indicating whether the GetResult function result is valid.

See Also

IAggregateFunction Interface
PerpetuumSoft.Reporting.Data.Olap Namespace


IAggregateFunction Methods

[image] [image]

.NET ModelKit Suite ClassReference
IAggregateFunction Methods
IAggregateFunction Interface See Also Send Feedback

The IAggregateFunction type exposes the following members.

Methods

Name | Description
AddValue | Adds a value to the aggregation result.
GetResult | Returns the aggregation result.

See Also

IAggregateFunction Interface
PerpetuumSoft.Reporting.Data.Olap Namespace


AddValue Method

[image]

.NET ModelKit Suite ClassReference
IAggregateFunction..::.AddValue Method
IAggregateFunction Interface See Also Send Feedback
Adds a value to the aggregation result.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void AddValue(
    double value
)
Visual Basic (Declaration)
Sub AddValue ( _
    value As Double _
)
Visual C++
void AddValue(
    double value
)

Parameters

value
Type: System..::.Double

See Also

IAggregateFunction Interface
PerpetuumSoft.Reporting.Data.Olap Namespace


GetResult Method

[image]

.NET ModelKit Suite ClassReference
IAggregateFunction..::.GetResult Method
IAggregateFunction Interface See Also Send Feedback
Returns the aggregation result.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
double GetResult()
Visual Basic (Declaration)
Function GetResult As Double
Visual C++
double GetResult()

See Also

IAggregateFunction Interface
PerpetuumSoft.Reporting.Data.Olap Namespace


IAggregateFunction Properties

[image] [image]

.NET ModelKit Suite ClassReference
IAggregateFunction Properties
IAggregateFunction Interface See Also Send Feedback

The IAggregateFunction type exposes the following members.

Properties

Name | Description
ValidResult | Gets value indicating whether the GetResult function result is valid.

See Also

IAggregateFunction Interface
PerpetuumSoft.Reporting.Data.Olap Namespace


ValidResult Property

[image]

.NET ModelKit Suite ClassReference
IAggregateFunction..::.ValidResult Property
IAggregateFunction Interface See Also Send Feedback
Gets value indicating whether the GetResult function result is valid.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
bool ValidResult { get; }
Visual Basic (Declaration)
ReadOnly Property ValidResult As Boolean
Visual C++
property bool ValidResult {
    bool get ();
}

See Also

IAggregateFunction Interface
PerpetuumSoft.Reporting.Data.Olap Namespace


IFilter Interface

[image]

.NET ModelKit Suite ClassReference
IFilter Interface
Members See Also Send Feedback
Represents a data filter.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public interface IFilter
Visual Basic (Declaration)
Public Interface IFilter
Visual C++
public interface class IFilter

See Also

IFilter Members
PerpetuumSoft.Reporting.Data.Olap Namespace


IFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
IFilter Members
IFilter Interface Methods See Also Send Feedback

The IFilter type exposes the following members.

Methods

Name | Description
IsFiltered | Returns the value indicating whether value is filtered.

See Also

IFilter Interface
PerpetuumSoft.Reporting.Data.Olap Namespace


IFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
IFilter Methods
IFilter Interface See Also Send Feedback

The IFilter type exposes the following members.

Methods

Name | Description
IsFiltered | Returns the value indicating whether value is filtered.

See Also

IFilter Interface
PerpetuumSoft.Reporting.Data.Olap Namespace


IsFiltered Method

[image]

.NET ModelKit Suite ClassReference
IFilter..::.IsFiltered Method
IFilter Interface See Also Send Feedback
Returns the value indicating whether value is filtered.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
bool IsFiltered(
    Object value
)
Visual Basic (Declaration)
Function IsFiltered ( _
    value As Object _
) As Boolean
Visual C++
bool IsFiltered(
    Object^ value
)

Parameters

value
Type: System..::.Object

See Also

IFilter Interface
PerpetuumSoft.Reporting.Data.Olap Namespace


JointPassTreeNode Class

[image]

.NET ModelKit Suite ClassReference
JointPassTreeNode Class
Members See Also Send Feedback
Represents a tree element discribing nested data sources

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class JointPassTreeNode
Visual Basic (Declaration)
Public Class JointPassTreeNode
Visual C++
public ref class JointPassTreeNode

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.JointPassTreeNode

See Also

JointPassTreeNode Members
PerpetuumSoft.Reporting.Data.Olap Namespace


JointPassTreeNode Members

[image] [image]

.NET ModelKit Suite ClassReference
JointPassTreeNode Members
JointPassTreeNode Class Constructors Methods Properties See Also Send Feedback

The JointPassTreeNode type exposes the following members.

Constructors

Name | Description
JointPassTreeNode | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ChildNodes | Gets child site JointPassTreeNodeCollection
Navigator | Gets nested data source navigator DataNavigator
Neighbor | Gets or sets neighbour node JointPassTreeNode
Parent | Gets or sets parent node JointPassTreeNode

See Also

JointPassTreeNode Class
PerpetuumSoft.Reporting.Data.Olap Namespace


JointPassTreeNode Constructor

[image] [image]

.NET ModelKit Suite ClassReference
JointPassTreeNode Constructor
JointPassTreeNode Class See Also Send Feedback

Overload List

Name | Description
JointPassTreeNode(DataNavigator) | Initializes a new instance of the JointPassTreeNode class.
JointPassTreeNode(DataNavigator, JointPassTreeNode) | Initializes a new instance of the JointPassTreeNode class.

See Also

JointPassTreeNode Class
JointPassTreeNode Members
PerpetuumSoft.Reporting.Data.Olap Namespace


JointPassTreeNode Constructor (DataNavigator)

[image]

.NET ModelKit Suite ClassReference
JointPassTreeNode Constructor (DataNavigator)
JointPassTreeNode Class See Also Send Feedback
Initializes a new instance of the JointPassTreeNode class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public JointPassTreeNode(
    DataNavigator navigator
)
Visual Basic (Declaration)
Public Sub New ( _
    navigator As DataNavigator _
)
Visual C++
public:
JointPassTreeNode(
    DataNavigator^ navigator
)

Parameters

navigator
Type: PerpetuumSoft.Reporting.Data..::.DataNavigator

See Also

JointPassTreeNode Class
JointPassTreeNode Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


JointPassTreeNode Constructor (DataNavigator, JointPassTreeNode)

[image]

.NET ModelKit Suite ClassReference
JointPassTreeNode Constructor (DataNavigator, JointPassTreeNode)
JointPassTreeNode Class See Also Send Feedback
Initializes a new instance of the JointPassTreeNode class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public JointPassTreeNode(
    DataNavigator navigator,
    JointPassTreeNode parent
)
Visual Basic (Declaration)
Public Sub New ( _
    navigator As DataNavigator, _
    parent As JointPassTreeNode _
)
Visual C++
public:
JointPassTreeNode(
    DataNavigator^ navigator,
    JointPassTreeNode^ parent
)

Parameters

navigator
Type: PerpetuumSoft.Reporting.Data..::.DataNavigator
parent
Type: PerpetuumSoft.Reporting.Data.Olap..::.JointPassTreeNode

See Also

JointPassTreeNode Class
JointPassTreeNode Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


JointPassTreeNode Methods

[image] [image]

.NET ModelKit Suite ClassReference
JointPassTreeNode Methods
JointPassTreeNode Class See Also Send Feedback

The JointPassTreeNode type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JointPassTreeNode Class
PerpetuumSoft.Reporting.Data.Olap Namespace


JointPassTreeNode Properties

[image] [image]

.NET ModelKit Suite ClassReference
JointPassTreeNode Properties
JointPassTreeNode Class See Also Send Feedback

The JointPassTreeNode type exposes the following members.

Properties

Name | Description
ChildNodes | Gets child site JointPassTreeNodeCollection
Navigator | Gets nested data source navigator DataNavigator
Neighbor | Gets or sets neighbour node JointPassTreeNode
Parent | Gets or sets parent node JointPassTreeNode

See Also

JointPassTreeNode Class
PerpetuumSoft.Reporting.Data.Olap Namespace


ChildNodes Property

[image]

.NET ModelKit Suite ClassReference
JointPassTreeNode..::.ChildNodes Property
JointPassTreeNode Class See Also Send Feedback
Gets child site JointPassTreeNodeCollection

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public JointPassTreeNodeCollection ChildNodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChildNodes As JointPassTreeNodeCollection
Visual C++
public:
property JointPassTreeNodeCollection^ ChildNodes {
    JointPassTreeNodeCollection^ get ();
}

See Also

JointPassTreeNode Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Navigator Property

[image]

.NET ModelKit Suite ClassReference
JointPassTreeNode..::.Navigator Property
JointPassTreeNode Class See Also Send Feedback
Gets nested data source navigator DataNavigator

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataNavigator Navigator { get; }
Visual Basic (Declaration)
Public ReadOnly Property Navigator As DataNavigator
Visual C++
public:
property DataNavigator^ Navigator {
    DataNavigator^ get ();
}

See Also

JointPassTreeNode Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Neighbor Property

[image]

.NET ModelKit Suite ClassReference
JointPassTreeNode..::.Neighbor Property
JointPassTreeNode Class See Also Send Feedback
Gets or sets neighbour node JointPassTreeNode

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public JointPassTreeNode Neighbor { get; set; }
Visual Basic (Declaration)
Public Property Neighbor As JointPassTreeNode
Visual C++
public:
property JointPassTreeNode^ Neighbor {
    JointPassTreeNode^ get ();
    void set (JointPassTreeNode^ value);
}

See Also

JointPassTreeNode Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Parent Property

[image]

.NET ModelKit Suite ClassReference
JointPassTreeNode..::.Parent Property
JointPassTreeNode Class See Also Send Feedback
Gets or sets parent node JointPassTreeNode

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public JointPassTreeNode Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As JointPassTreeNode
Visual C++
public:
property JointPassTreeNode^ Parent {
    JointPassTreeNode^ get ();
    void set (JointPassTreeNode^ value);
}

See Also

JointPassTreeNode Class
PerpetuumSoft.Reporting.Data.Olap Namespace


JointPassTreeNodeCollection Class

[image]

.NET ModelKit Suite ClassReference
JointPassTreeNodeCollection Class
Members See Also Send Feedback
Represents the tree node collection

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class JointPassTreeNodeCollection : CollectionBase
Visual Basic (Declaration)
Public Class JointPassTreeNodeCollection _
    Inherits CollectionBase
Visual C++
public ref class JointPassTreeNodeCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Reporting.Data.Olap..::.JointPassTreeNodeCollection

See Also

JointPassTreeNodeCollection Members
PerpetuumSoft.Reporting.Data.Olap Namespace


JointPassTreeNodeCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
JointPassTreeNodeCollection Members
JointPassTreeNodeCollection Class Constructors Methods Properties See Also Send Feedback

The JointPassTreeNodeCollection type exposes the following members.

Constructors

Name | Description
JointPassTreeNodeCollection | Initializes a new instance of the JointPassTreeNodeCollection class.

Methods

Name | Description
Add | Implements Add(Object).
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Implements Item[([(Int32])]).
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

JointPassTreeNodeCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


JointPassTreeNodeCollection Constructor

[image]

.NET ModelKit Suite ClassReference
JointPassTreeNodeCollection Constructor
JointPassTreeNodeCollection Class See Also Send Feedback
Initializes a new instance of the JointPassTreeNodeCollection class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public JointPassTreeNodeCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
JointPassTreeNodeCollection()

See Also

JointPassTreeNodeCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


JointPassTreeNodeCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
JointPassTreeNodeCollection Methods
JointPassTreeNodeCollection Class See Also Send Feedback

The JointPassTreeNodeCollection type exposes the following members.

Methods

Name | Description
Add | Implements Add(Object).
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Implements IndexOf(Object).
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JointPassTreeNodeCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
JointPassTreeNodeCollection..::.Add Method
JointPassTreeNodeCollection Class See Also Send Feedback
Implements Add(Object).

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Add(
    JointPassTreeNode node
)
Visual Basic (Declaration)
Public Sub Add ( _
    node As JointPassTreeNode _
)
Visual C++
public:
void Add(
    JointPassTreeNode^ node
)

Parameters

node
Type: PerpetuumSoft.Reporting.Data.Olap..::.JointPassTreeNode

See Also

JointPassTreeNodeCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
JointPassTreeNodeCollection..::.IndexOf Method
JointPassTreeNodeCollection Class See Also Send Feedback
Implements IndexOf(Object).

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    JointPassTreeNode node
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    node As JointPassTreeNode _
) As Integer
Visual C++
public:
int IndexOf(
    JointPassTreeNode^ node
)

Parameters

node
Type: PerpetuumSoft.Reporting.Data.Olap..::.JointPassTreeNode

See Also

JointPassTreeNodeCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


JointPassTreeNodeCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
JointPassTreeNodeCollection Properties
JointPassTreeNodeCollection Class See Also Send Feedback

The JointPassTreeNodeCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Implements Item[([(Int32])]).
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

JointPassTreeNodeCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
JointPassTreeNodeCollection..::.Item Property
JointPassTreeNodeCollection Class See Also Send Feedback
Implements Item[([(Int32])]).

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public JointPassTreeNode this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As JointPassTreeNode
Visual C++
public:
property JointPassTreeNode^ default[int index] {
    JointPassTreeNode^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

JointPassTreeNodeCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


NestedField Class

[image]

.NET ModelKit Suite ClassReference
NestedField Class
Members See Also Send Feedback
Represetnts a data source nested field for data navigation.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class NestedField : ICloneable
Visual Basic (Declaration)
Public Class NestedField _
    Implements ICloneable
Visual C++
public ref class NestedField : ICloneable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Data.Olap..::.NestedField

See Also

NestedField Members
PerpetuumSoft.Reporting.Data.Olap Namespace


NestedField Members

[image] [image]

.NET ModelKit Suite ClassReference
NestedField Members
NestedField Class Constructors Methods Properties See Also Send Feedback

The NestedField type exposes the following members.

Constructors

Name | Description
NestedField | Overloaded.

Methods

Name | Description
Clone | Implements Clone()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
Caption | Gets or sets nested field caption.
Path | Gets or sets nested field path.

See Also

NestedField Class
PerpetuumSoft.Reporting.Data.Olap Namespace


NestedField Constructor

[image] [image]

.NET ModelKit Suite ClassReference
NestedField Constructor
NestedField Class See Also Send Feedback

Overload List

Name | Description
NestedField()()() | Initializes a new instance of the NestedField class.
NestedField(String) | Initializes a new instance of the NestedField class.

See Also

NestedField Class
NestedField Members
PerpetuumSoft.Reporting.Data.Olap Namespace


NestedField Constructor

[image]

.NET ModelKit Suite ClassReference
NestedField Constructor
NestedField Class See Also Send Feedback
Initializes a new instance of the NestedField class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public NestedField()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NestedField()

See Also

NestedField Class
NestedField Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


NestedField Constructor (String)

[image]

.NET ModelKit Suite ClassReference
NestedField Constructor (String)
NestedField Class See Also Send Feedback
Initializes a new instance of the NestedField class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public NestedField(
    string path
)
Visual Basic (Declaration)
Public Sub New ( _
    path As String _
)
Visual C++
public:
NestedField(
    String^ path
)

Parameters

path
Type: System..::.String

See Also

NestedField Class
NestedField Overload
PerpetuumSoft.Reporting.Data.Olap Namespace


NestedField Methods

[image] [image]

.NET ModelKit Suite ClassReference
NestedField Methods
NestedField Class See Also Send Feedback

The NestedField type exposes the following members.

Methods

Name | Description
Clone | Implements Clone()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

NestedField Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
NestedField..::.Clone Method
NestedField Class See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Implements

ICloneable..::.Clone()()()

See Also

NestedField Class
PerpetuumSoft.Reporting.Data.Olap Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
NestedField..::.ToString Method
NestedField Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

NestedField Class
PerpetuumSoft.Reporting.Data.Olap Namespace


NestedField Properties

[image] [image]

.NET ModelKit Suite ClassReference
NestedField Properties
NestedField Class See Also Send Feedback

The NestedField type exposes the following members.

Properties

Name | Description
Caption | Gets or sets nested field caption.
Path | Gets or sets nested field path.

See Also

NestedField Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Caption Property

[image]

.NET ModelKit Suite ClassReference
NestedField..::.Caption Property
NestedField Class See Also Send Feedback
Gets or sets nested field caption.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Caption { get; set; }
Visual Basic (Declaration)
Public Property Caption As String
Visual C++
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}

See Also

NestedField Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Path Property

[image]

.NET ModelKit Suite ClassReference
NestedField..::.Path Property
NestedField Class See Also Send Feedback
Gets or sets nested field path.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Path { get; set; }
Visual Basic (Declaration)
Public Property Path As String
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

See Also

NestedField Class
PerpetuumSoft.Reporting.Data.Olap Namespace


NestedFieldCollection Class

[image]

.NET ModelKit Suite ClassReference
NestedFieldCollection Class
Members See Also Send Feedback
Represents the collection of NestedField.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class NestedFieldCollection : CollectionBase
Visual Basic (Declaration)
Public Class NestedFieldCollection _
    Inherits CollectionBase
Visual C++
public ref class NestedFieldCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Reporting.Data.Olap..::.NestedFieldCollection

See Also

NestedFieldCollection Members
PerpetuumSoft.Reporting.Data.Olap Namespace


NestedFieldCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
NestedFieldCollection Members
NestedFieldCollection Class Constructors Methods Properties See Also Send Feedback

The NestedFieldCollection type exposes the following members.

Constructors

Name | Description
NestedFieldCollection | Initializes a new instance of the NestedFieldCollection class.

Methods

Name | Description
Add | Implements Add(Object).
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Implements Item[([(Int32])]).
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

NestedFieldCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


NestedFieldCollection Constructor

[image]

.NET ModelKit Suite ClassReference
NestedFieldCollection Constructor
NestedFieldCollection Class See Also Send Feedback
Initializes a new instance of the NestedFieldCollection class.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public NestedFieldCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NestedFieldCollection()

See Also

NestedFieldCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


NestedFieldCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
NestedFieldCollection Methods
NestedFieldCollection Class See Also Send Feedback

The NestedFieldCollection type exposes the following members.

Methods

Name | Description
Add | Implements Add(Object).
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NestedFieldCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
NestedFieldCollection..::.Add Method
NestedFieldCollection Class See Also Send Feedback
Implements Add(Object).

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Add(
    NestedField value
)
Visual Basic (Declaration)
Public Sub Add ( _
    value As NestedField _
)
Visual C++
public:
void Add(
    NestedField^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Data.Olap..::.NestedField

See Also

NestedFieldCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


NestedFieldCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
NestedFieldCollection Properties
NestedFieldCollection Class See Also Send Feedback

The NestedFieldCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Implements Item[([(Int32])]).
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

NestedFieldCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
NestedFieldCollection..::.Item Property
NestedFieldCollection Class See Also Send Feedback
Implements Item[([(Int32])]).

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public NestedField this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As NestedField
Visual C++
public:
property NestedField^ default[int index] {
    NestedField^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

NestedFieldCollection Class
PerpetuumSoft.Reporting.Data.Olap Namespace


SortOrder Enumeration

[image]

.NET ModelKit Suite ClassReference
SortOrder Enumeration
See Also Send Feedback
Enumerates the sort order.

Namespace: PerpetuumSoft.Reporting.Data.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum SortOrder
Visual Basic (Declaration)
Public Enumeration SortOrder
Visual C++
public enum class SortOrder

Members

Member name | Description
Ascending | Ascending sotring.
Descending | Descending sorting.

See Also

PerpetuumSoft.Reporting.Data.Olap Namespace


PerpetuumSoft.Reporting.Designer Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Designer Namespace
Send Feedback
The PerpetuumSoft.Reporting.Designer namespace contains classes that realize user interface for creating and editing of reports templates.

Classes

Class | Description
Aligner | Incapsulates align logic.
AlignForm | Represents a dialog window for assigning alingment
DesignerDataSourcesTree | Contains TreeView with available data sources.
DesignerDocumentTree | Contains TreeView with Document objects tree.
DesignerErrorList | Contains list of errors in report scripts.
DesignerForm | Represents assembled report designer.
DesignerMouseEventArgs | 'Provides data for DesignerMouseUp, DesignerMouseDown events.
DesignerPropertyGrid | Contains PropertyGrid for ReportDesigner.
DesignerStatusBar | Contains StatusBar for ReportDesigner.
DesignerToolArgs | Provides information for UpdateTool methods.
DesignerToolBar | Contains ToolBar for ReportDesigner.
DesignerToolBox | Contains ToolBox for ReportDesigner.
DesignerToolControl | Base class for all ReportDesigner tools.
ElementAddedEventArgs | Provides data for the ElementAdding event.
ElementAddingEventArgs | Provides data for the ElementAdded event.
IDesignerToolCollection | Represents the collection of IDesignerTool objects.
ReportClipboard | This type supports the Report Sharp-Shooter infrastructure and is not intended to be used directly from your code.
ReportDesigner | Report Designer control.
RequestCodeSnippetsEventArgs | Represents data about the code snippets for the specified script language.
SelectionGroup | Represents collection of selected objects in ReportDesigner.

Structures

Structure | Description
ReportDesigner..::.MergablePropertyValue | Represents data about the merged properties value of multiple objects

Interfaces

Interface | Description
IDesignerTool | Common interface for all ReportDesigner tools.
IReportDesignerService | Provides common interface for access to the report designer environment.

Delegates

Delegate | Description
DesignerMouseEventHandler | Represents the method that will handle DesignerMouseUp, DesignerMouseDown events.
ElementAddedEventHandler | Represents the method that will handle the ElementAdded event.
ElementAddingEventHandler | Represents the method that will handle the ElementAdding event.
ReportDesigner..::.GetNewValueMethod | Defines method of getting a new value depending on the previous one

Enumerations

Enumeration | Description
AlignAction | Align modes.
AlignBoundKind | Align modes.


AlignAction Enumeration

[image]

.NET ModelKit Suite ClassReference
AlignAction Enumeration
See Also Send Feedback
Align modes.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum AlignAction
Visual Basic (Declaration)
Public Enumeration AlignAction
Visual C++
public enum class AlignAction

Members

Member name | Description
None | Do not align.
Near | Align to top/left.
Center | Align to center.
Far | Align to bottom/right.
Justify | Justify.

See Also

PerpetuumSoft.Reporting.Designer Namespace


AlignBoundKind Enumeration

[image]

.NET ModelKit Suite ClassReference
AlignBoundKind Enumeration
See Also Send Feedback
Align modes.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum AlignBoundKind
Visual Basic (Declaration)
Public Enumeration AlignBoundKind
Visual C++
public enum class AlignBoundKind

Members

Member name | Description
Page | Whole page.
Selection | Selection bounds.
Band | Current band bounds.

See Also

PerpetuumSoft.Reporting.Designer Namespace


Aligner Class

[image]

.NET ModelKit Suite ClassReference
Aligner Class
Members See Also Send Feedback
Incapsulates align logic.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public sealed class Aligner
Visual Basic (Declaration)
Public NotInheritable Class Aligner
Visual C++
public ref class Aligner sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Designer..::.Aligner

See Also

Aligner Members
PerpetuumSoft.Reporting.Designer Namespace


Aligner Members

[image] [image]

.NET ModelKit Suite ClassReference
Aligner Members
Aligner Class Methods See Also Send Feedback

The Aligner type exposes the following members.

Methods

Name | Description
Align | Returns specified rectangles vertically and horizontally aligned according to align actions and align bounds.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Aligner Class
PerpetuumSoft.Reporting.Designer Namespace


Aligner Methods

[image] [image]

.NET ModelKit Suite ClassReference
Aligner Methods
Aligner Class See Also Send Feedback

The Aligner type exposes the following members.

Methods

Name | Description
Align | Returns specified rectangles vertically and horizontally aligned according to align actions and align bounds.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Aligner Class
PerpetuumSoft.Reporting.Designer Namespace


Align Method

[image]

.NET ModelKit Suite ClassReference
Aligner..::.Align Method
Aligner Class See Also Send Feedback
Returns specified rectangles vertically and horizontally aligned according to align actions and align bounds.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static VectorRectangle[] Align(
    VectorRectangle[] boxes,
    AlignAction hAction,
    AlignAction vAction,
    VectorRectangle alignBounds
)
Visual Basic (Declaration)
Public Shared Function Align ( _
    boxes As VectorRectangle(), _
    hAction As AlignAction, _
    vAction As AlignAction, _
    alignBounds As VectorRectangle _
) As VectorRectangle()
Visual C++
public:
static array<VectorRectangle>^ Align(
    array<VectorRectangle>^ boxes,
    AlignAction hAction,
    AlignAction vAction,
    VectorRectangle alignBounds
)

Parameters

boxes
Type: array< PerpetuumSoft.Framework.Drawing..::.VectorRectangle >[]()[]
hAction
Type: PerpetuumSoft.Reporting.Designer..::.AlignAction
vAction
Type: PerpetuumSoft.Reporting.Designer..::.AlignAction
alignBounds
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

Aligner Class
PerpetuumSoft.Reporting.Designer Namespace


AlignForm Class

[image]

.NET ModelKit Suite ClassReference
AlignForm Class
Members See Also Send Feedback
Represents a dialog window for assigning alingment

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class AlignForm : Form
Visual Basic (Declaration)
Public Class AlignForm _
    Inherits Form
Visual C++
public ref class AlignForm : public Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
PerpetuumSoft.Reporting.Designer..::.AlignForm

See Also

AlignForm Members
PerpetuumSoft.Reporting.Designer Namespace


AlignForm Members

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm Members
AlignForm Class Constructors Methods Properties Events See Also Send Feedback

The AlignForm type exposes the following members.

Constructors

Name | Description
AlignForm | Initializes a new instance of the AlignForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

AlignForm Class
PerpetuumSoft.Reporting.Designer Namespace


AlignForm Constructor

[image]

.NET ModelKit Suite ClassReference
AlignForm Constructor
AlignForm Class See Also Send Feedback
Initializes a new instance of the AlignForm class.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public AlignForm(
    ReportDesigner designer
)
Visual Basic (Declaration)
Public Sub New ( _
    designer As ReportDesigner _
)
Visual C++
public:
AlignForm(
    ReportDesigner^ designer
)

Parameters

designer
Type: PerpetuumSoft.Reporting.Designer..::.ReportDesigner

See Also

AlignForm Class
PerpetuumSoft.Reporting.Designer Namespace


AlignForm Methods

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm Methods
AlignForm Class See Also Send Feedback

The AlignForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

AlignForm Class
PerpetuumSoft.Reporting.Designer Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm..::.AccessibilityNotifyClients Method
AlignForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

AlignForm Class
AlignForm Members
PerpetuumSoft.Reporting.Designer Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm..::.BeginInvoke Method
AlignForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

AlignForm Class
AlignForm Members
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm..::.Dispose Method
AlignForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | The Dispose Finalize pattern ensures that resources are released when the object is no longer needed (Overrides Form..::.Dispose(Boolean).)

See Also

AlignForm Class
AlignForm Members
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
AlignForm..::.Dispose Method (Boolean)
AlignForm Class See Also Send Feedback
The Dispose Finalize pattern ensures that resources are released when the object is no longer needed

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

AlignForm Class
Dispose Overload
PerpetuumSoft.Reporting.Designer Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm..::.GetChildAtPoint Method
AlignForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

AlignForm Class
AlignForm Members
PerpetuumSoft.Reporting.Designer Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm..::.Invalidate Method
AlignForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

AlignForm Class
AlignForm Members
PerpetuumSoft.Reporting.Designer Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm..::.Invoke Method
AlignForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

AlignForm Class
AlignForm Members
PerpetuumSoft.Reporting.Designer Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm..::.MemberwiseClone Method
AlignForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

AlignForm Class
AlignForm Members
PerpetuumSoft.Reporting.Designer Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
AlignForm..::.OnLoad Method
AlignForm Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

AlignForm Class
PerpetuumSoft.Reporting.Designer Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm..::.PerformLayout Method
AlignForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

AlignForm Class
AlignForm Members
PerpetuumSoft.Reporting.Designer Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm..::.ResumeLayout Method
AlignForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

AlignForm Class
AlignForm Members
PerpetuumSoft.Reporting.Designer Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm..::.RtlTranslateAlignment Method
AlignForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

AlignForm Class
AlignForm Members
PerpetuumSoft.Reporting.Designer Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm..::.Scale Method
AlignForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

AlignForm Class
AlignForm Members
PerpetuumSoft.Reporting.Designer Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm..::.Select Method
AlignForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

AlignForm Class
AlignForm Members
PerpetuumSoft.Reporting.Designer Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm..::.SetBounds Method
AlignForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

AlignForm Class
AlignForm Members
PerpetuumSoft.Reporting.Designer Namespace


Show Method

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm..::.Show Method
AlignForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

AlignForm Class
AlignForm Members
PerpetuumSoft.Reporting.Designer Namespace


ShowDialog Method

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm..::.ShowDialog Method
AlignForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

AlignForm Class
AlignForm Members
PerpetuumSoft.Reporting.Designer Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm..::.UpdateBounds Method
AlignForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

AlignForm Class
AlignForm Members
PerpetuumSoft.Reporting.Designer Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm..::.Validate Method
AlignForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

AlignForm Class
AlignForm Members
PerpetuumSoft.Reporting.Designer Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm..::.ValidateChildren Method
AlignForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

AlignForm Class
AlignForm Members
PerpetuumSoft.Reporting.Designer Namespace


AlignForm Properties

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm Properties
AlignForm Class See Also Send Feedback

The AlignForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

AlignForm Class
PerpetuumSoft.Reporting.Designer Namespace


AlignForm Events

[image] [image]

.NET ModelKit Suite ClassReference
AlignForm Events
AlignForm Class See Also Send Feedback

The AlignForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

AlignForm Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerDataSourcesTree Class

[image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree Class
Members See Also Send Feedback
Contains TreeView with available data sources.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DesignerDataSourcesTree : DesignerToolControl
Visual Basic (Declaration)
Public Class DesignerDataSourcesTree _
    Inherits DesignerToolControl
Visual C++
public ref class DesignerDataSourcesTree : public DesignerToolControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Reporting.Designer..::.DesignerToolControl
PerpetuumSoft.Reporting.Designer..::.DesignerDataSourcesTree

See Also

DesignerDataSourcesTree Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerDataSourcesTree Members

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree Members
DesignerDataSourcesTree Class Constructors Methods Properties Events See Also Send Feedback

The DesignerDataSourcesTree type exposes the following members.

Constructors

Name | Description
DesignerDataSourcesTree | Creates new instance of DesignerDataSourcesTree control.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BindControl | Binds control to designer's action. (Inherited from DesignerToolControl.)
BindControls | Performs actual controls binding. (Inherited from DesignerToolControl.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalBindControls | Runs controls binding. (Inherited from DesignerToolControl.)
InternalUnbindControls | Runs controls unbind operations. (Inherited from DesignerToolControl.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStatusText | Updates text in status bar. (Inherited from DesignerToolControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UnbindControls | Performs actual unbind operations. (Inherited from DesignerToolControl.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTool | Updates Tool state. (Overrides DesignerToolControl..::.UpdateTool(DesignerToolArgs).)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
About | Gets the copyright string. (Inherited from DesignerToolControl.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
Designer | Gets and sets associated ReportDesigner. (Inherited from DesignerToolControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerDataSourcesTree Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerDataSourcesTree Constructor

[image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree Constructor
DesignerDataSourcesTree Class See Also Send Feedback
Creates new instance of DesignerDataSourcesTree control.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DesignerDataSourcesTree()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DesignerDataSourcesTree()

See Also

DesignerDataSourcesTree Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerDataSourcesTree Methods

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree Methods
DesignerDataSourcesTree Class See Also Send Feedback

The DesignerDataSourcesTree type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BindControl | Binds control to designer's action. (Inherited from DesignerToolControl.)
BindControls | Performs actual controls binding. (Inherited from DesignerToolControl.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalBindControls | Runs controls binding. (Inherited from DesignerToolControl.)
InternalUnbindControls | Runs controls unbind operations. (Inherited from DesignerToolControl.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStatusText | Updates text in status bar. (Inherited from DesignerToolControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UnbindControls | Performs actual unbind operations. (Inherited from DesignerToolControl.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTool | Updates Tool state. (Overrides DesignerToolControl..::.UpdateTool(DesignerToolArgs).)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

DesignerDataSourcesTree Class
PerpetuumSoft.Reporting.Designer Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree..::.AccessibilityNotifyClients Method
DesignerDataSourcesTree Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DesignerDataSourcesTree Class
DesignerDataSourcesTree Members
PerpetuumSoft.Reporting.Designer Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree..::.BeginInvoke Method
DesignerDataSourcesTree Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DesignerDataSourcesTree Class
DesignerDataSourcesTree Members
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree..::.Dispose Method
DesignerDataSourcesTree Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides DesignerToolControl..::.Dispose(Boolean).)

See Also

DesignerDataSourcesTree Class
DesignerDataSourcesTree Members
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree..::.Dispose Method (Boolean)
DesignerDataSourcesTree Class See Also Send Feedback
Clean up any resources being used.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

DesignerDataSourcesTree Class
Dispose Overload
PerpetuumSoft.Reporting.Designer Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree..::.GetChildAtPoint Method
DesignerDataSourcesTree Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DesignerDataSourcesTree Class
DesignerDataSourcesTree Members
PerpetuumSoft.Reporting.Designer Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree..::.Invalidate Method
DesignerDataSourcesTree Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DesignerDataSourcesTree Class
DesignerDataSourcesTree Members
PerpetuumSoft.Reporting.Designer Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree..::.Invoke Method
DesignerDataSourcesTree Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DesignerDataSourcesTree Class
DesignerDataSourcesTree Members
PerpetuumSoft.Reporting.Designer Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree..::.MemberwiseClone Method
DesignerDataSourcesTree Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DesignerDataSourcesTree Class
DesignerDataSourcesTree Members
PerpetuumSoft.Reporting.Designer Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree..::.OnLoad Method
DesignerDataSourcesTree Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

DesignerDataSourcesTree Class
PerpetuumSoft.Reporting.Designer Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree..::.PerformLayout Method
DesignerDataSourcesTree Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DesignerDataSourcesTree Class
DesignerDataSourcesTree Members
PerpetuumSoft.Reporting.Designer Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree..::.ResumeLayout Method
DesignerDataSourcesTree Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DesignerDataSourcesTree Class
DesignerDataSourcesTree Members
PerpetuumSoft.Reporting.Designer Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree..::.RtlTranslateAlignment Method
DesignerDataSourcesTree Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DesignerDataSourcesTree Class
DesignerDataSourcesTree Members
PerpetuumSoft.Reporting.Designer Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree..::.Scale Method
DesignerDataSourcesTree Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DesignerDataSourcesTree Class
DesignerDataSourcesTree Members
PerpetuumSoft.Reporting.Designer Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree..::.Select Method
DesignerDataSourcesTree Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

DesignerDataSourcesTree Class
DesignerDataSourcesTree Members
PerpetuumSoft.Reporting.Designer Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree..::.SetBounds Method
DesignerDataSourcesTree Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DesignerDataSourcesTree Class
DesignerDataSourcesTree Members
PerpetuumSoft.Reporting.Designer Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree..::.UpdateBounds Method
DesignerDataSourcesTree Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DesignerDataSourcesTree Class
DesignerDataSourcesTree Members
PerpetuumSoft.Reporting.Designer Namespace


UpdateTool Method

[image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree..::.UpdateTool Method
DesignerDataSourcesTree Class See Also Send Feedback
Updates Tool state.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void UpdateTool(
    DesignerToolArgs args
)
Visual Basic (Declaration)
Public Overrides Sub UpdateTool ( _
    args As DesignerToolArgs _
)
Visual C++
public:
virtual void UpdateTool(
    DesignerToolArgs^ args
) override

Parameters

args
Type: PerpetuumSoft.Reporting.Designer..::.DesignerToolArgs

Implements

IDesignerTool..::.UpdateTool(DesignerToolArgs)

See Also

DesignerDataSourcesTree Class
PerpetuumSoft.Reporting.Designer Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree..::.Validate Method
DesignerDataSourcesTree Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DesignerDataSourcesTree Class
DesignerDataSourcesTree Members
PerpetuumSoft.Reporting.Designer Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree..::.ValidateChildren Method
DesignerDataSourcesTree Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

DesignerDataSourcesTree Class
DesignerDataSourcesTree Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerDataSourcesTree Properties

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree Properties
DesignerDataSourcesTree Class See Also Send Feedback

The DesignerDataSourcesTree type exposes the following members.

Properties

Name | Description
About | Gets the copyright string. (Inherited from DesignerToolControl.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
Designer | Gets and sets associated ReportDesigner. (Inherited from DesignerToolControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

DesignerDataSourcesTree Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerDataSourcesTree Events

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDataSourcesTree Events
DesignerDataSourcesTree Class See Also Send Feedback

The DesignerDataSourcesTree type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerDataSourcesTree Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerDocumentTree Class

[image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree Class
Members See Also Send Feedback
Contains TreeView with Document objects tree.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DesignerDocumentTree : DesignerToolControl
Visual Basic (Declaration)
Public Class DesignerDocumentTree _
    Inherits DesignerToolControl
Visual C++
public ref class DesignerDocumentTree : public DesignerToolControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Reporting.Designer..::.DesignerToolControl
PerpetuumSoft.Reporting.Designer..::.DesignerDocumentTree

See Also

DesignerDocumentTree Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerDocumentTree Members

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree Members
DesignerDocumentTree Class Constructors Methods Properties Events See Also Send Feedback

The DesignerDocumentTree type exposes the following members.

Constructors

Name | Description
DesignerDocumentTree | Creates new instance of DesignerDocumentTree control.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BindControl | Binds control to designer's action. (Inherited from DesignerToolControl.)
BindControls | Performs actual controls binding. (Inherited from DesignerToolControl.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalBindControls | Runs controls binding. (Inherited from DesignerToolControl.)
InternalUnbindControls | Runs controls unbind operations. (Inherited from DesignerToolControl.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStatusText | Updates text in status bar. (Inherited from DesignerToolControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UnbindControls | Performs actual unbind operations. (Inherited from DesignerToolControl.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTool | Updates Tool state. (Overrides DesignerToolControl..::.UpdateTool(DesignerToolArgs).)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
About | Gets the copyright string. (Inherited from DesignerToolControl.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | Get or sets caption text for the control.
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
Designer | Gets and sets associated ReportDesigner. (Inherited from DesignerToolControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerDocumentTree Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerDocumentTree Constructor

[image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree Constructor
DesignerDocumentTree Class See Also Send Feedback
Creates new instance of DesignerDocumentTree control.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DesignerDocumentTree()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DesignerDocumentTree()

See Also

DesignerDocumentTree Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerDocumentTree Methods

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree Methods
DesignerDocumentTree Class See Also Send Feedback

The DesignerDocumentTree type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BindControl | Binds control to designer's action. (Inherited from DesignerToolControl.)
BindControls | Performs actual controls binding. (Inherited from DesignerToolControl.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalBindControls | Runs controls binding. (Inherited from DesignerToolControl.)
InternalUnbindControls | Runs controls unbind operations. (Inherited from DesignerToolControl.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStatusText | Updates text in status bar. (Inherited from DesignerToolControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UnbindControls | Performs actual unbind operations. (Inherited from DesignerToolControl.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTool | Updates Tool state. (Overrides DesignerToolControl..::.UpdateTool(DesignerToolArgs).)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

DesignerDocumentTree Class
PerpetuumSoft.Reporting.Designer Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.AccessibilityNotifyClients Method
DesignerDocumentTree Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DesignerDocumentTree Class
DesignerDocumentTree Members
PerpetuumSoft.Reporting.Designer Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.BeginInvoke Method
DesignerDocumentTree Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DesignerDocumentTree Class
DesignerDocumentTree Members
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.Dispose Method
DesignerDocumentTree Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides DesignerToolControl..::.Dispose(Boolean).)

See Also

DesignerDocumentTree Class
DesignerDocumentTree Members
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.Dispose Method (Boolean)
DesignerDocumentTree Class See Also Send Feedback
Clean up any resources being used.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

DesignerDocumentTree Class
Dispose Overload
PerpetuumSoft.Reporting.Designer Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.GetChildAtPoint Method
DesignerDocumentTree Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DesignerDocumentTree Class
DesignerDocumentTree Members
PerpetuumSoft.Reporting.Designer Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.Invalidate Method
DesignerDocumentTree Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DesignerDocumentTree Class
DesignerDocumentTree Members
PerpetuumSoft.Reporting.Designer Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.Invoke Method
DesignerDocumentTree Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DesignerDocumentTree Class
DesignerDocumentTree Members
PerpetuumSoft.Reporting.Designer Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.MemberwiseClone Method
DesignerDocumentTree Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DesignerDocumentTree Class
DesignerDocumentTree Members
PerpetuumSoft.Reporting.Designer Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.OnLoad Method
DesignerDocumentTree Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

DesignerDocumentTree Class
PerpetuumSoft.Reporting.Designer Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.PerformLayout Method
DesignerDocumentTree Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DesignerDocumentTree Class
DesignerDocumentTree Members
PerpetuumSoft.Reporting.Designer Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.ResumeLayout Method
DesignerDocumentTree Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DesignerDocumentTree Class
DesignerDocumentTree Members
PerpetuumSoft.Reporting.Designer Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.RtlTranslateAlignment Method
DesignerDocumentTree Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DesignerDocumentTree Class
DesignerDocumentTree Members
PerpetuumSoft.Reporting.Designer Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.Scale Method
DesignerDocumentTree Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DesignerDocumentTree Class
DesignerDocumentTree Members
PerpetuumSoft.Reporting.Designer Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.Select Method
DesignerDocumentTree Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

DesignerDocumentTree Class
DesignerDocumentTree Members
PerpetuumSoft.Reporting.Designer Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.SetBounds Method
DesignerDocumentTree Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DesignerDocumentTree Class
DesignerDocumentTree Members
PerpetuumSoft.Reporting.Designer Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.UpdateBounds Method
DesignerDocumentTree Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DesignerDocumentTree Class
DesignerDocumentTree Members
PerpetuumSoft.Reporting.Designer Namespace


UpdateTool Method

[image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.UpdateTool Method
DesignerDocumentTree Class See Also Send Feedback
Updates Tool state.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void UpdateTool(
    DesignerToolArgs args
)
Visual Basic (Declaration)
Public Overrides Sub UpdateTool ( _
    args As DesignerToolArgs _
)
Visual C++
public:
virtual void UpdateTool(
    DesignerToolArgs^ args
) override

Parameters

args
Type: PerpetuumSoft.Reporting.Designer..::.DesignerToolArgs

Implements

IDesignerTool..::.UpdateTool(DesignerToolArgs)

See Also

DesignerDocumentTree Class
PerpetuumSoft.Reporting.Designer Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.Validate Method
DesignerDocumentTree Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DesignerDocumentTree Class
DesignerDocumentTree Members
PerpetuumSoft.Reporting.Designer Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.ValidateChildren Method
DesignerDocumentTree Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

DesignerDocumentTree Class
DesignerDocumentTree Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerDocumentTree Properties

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree Properties
DesignerDocumentTree Class See Also Send Feedback

The DesignerDocumentTree type exposes the following members.

Properties

Name | Description
About | Gets the copyright string. (Inherited from DesignerToolControl.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | Get or sets caption text for the control.
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
Designer | Gets and sets associated ReportDesigner. (Inherited from DesignerToolControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

DesignerDocumentTree Class
PerpetuumSoft.Reporting.Designer Namespace


Caption Property

[image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree..::.Caption Property
DesignerDocumentTree Class See Also Send Feedback
Get or sets caption text for the control.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Caption { get; set; }
Visual Basic (Declaration)
Public Property Caption As String
Visual C++
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}

See Also

DesignerDocumentTree Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerDocumentTree Events

[image] [image]

.NET ModelKit Suite ClassReference
DesignerDocumentTree Events
DesignerDocumentTree Class See Also Send Feedback

The DesignerDocumentTree type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerDocumentTree Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerErrorList Class

[image]

.NET ModelKit Suite ClassReference
DesignerErrorList Class
Members See Also Send Feedback
Contains list of errors in report scripts.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DesignerErrorList : DesignerToolControl
Visual Basic (Declaration)
Public Class DesignerErrorList _
    Inherits DesignerToolControl
Visual C++
public ref class DesignerErrorList : public DesignerToolControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Reporting.Designer..::.DesignerToolControl
PerpetuumSoft.Reporting.Designer..::.DesignerErrorList

See Also

DesignerErrorList Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerErrorList Members

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList Members
DesignerErrorList Class Constructors Methods Properties Events See Also Send Feedback

The DesignerErrorList type exposes the following members.

Constructors

Name | Description
DesignerErrorList | Creates a new instance of DesignerErrorList class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BindControl | Binds control to designer's action. (Inherited from DesignerToolControl.)
BindControls | Performs actual controls binding. (Inherited from DesignerToolControl.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalBindControls | Runs controls binding. (Inherited from DesignerToolControl.)
InternalUnbindControls | Runs controls unbind operations. (Inherited from DesignerToolControl.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStatusText | Updates text in status bar. (Inherited from DesignerToolControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UnbindControls | Performs actual unbind operations. (Inherited from DesignerToolControl.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTool | Updates Tool states. (Overrides DesignerToolControl..::.UpdateTool(DesignerToolArgs).)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
About | Gets the copyright string. (Inherited from DesignerToolControl.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | Gets or sets caption list for the control.
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
Designer | Gets and sets associated ReportDesigner. (Inherited from DesignerToolControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerErrorList Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerErrorList Constructor

[image]

.NET ModelKit Suite ClassReference
DesignerErrorList Constructor
DesignerErrorList Class See Also Send Feedback
Creates a new instance of DesignerErrorList class.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DesignerErrorList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DesignerErrorList()

See Also

DesignerErrorList Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerErrorList Methods

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList Methods
DesignerErrorList Class See Also Send Feedback

The DesignerErrorList type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BindControl | Binds control to designer's action. (Inherited from DesignerToolControl.)
BindControls | Performs actual controls binding. (Inherited from DesignerToolControl.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalBindControls | Runs controls binding. (Inherited from DesignerToolControl.)
InternalUnbindControls | Runs controls unbind operations. (Inherited from DesignerToolControl.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStatusText | Updates text in status bar. (Inherited from DesignerToolControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UnbindControls | Performs actual unbind operations. (Inherited from DesignerToolControl.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTool | Updates Tool states. (Overrides DesignerToolControl..::.UpdateTool(DesignerToolArgs).)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

DesignerErrorList Class
PerpetuumSoft.Reporting.Designer Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.AccessibilityNotifyClients Method
DesignerErrorList Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DesignerErrorList Class
DesignerErrorList Members
PerpetuumSoft.Reporting.Designer Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.BeginInvoke Method
DesignerErrorList Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DesignerErrorList Class
DesignerErrorList Members
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.Dispose Method
DesignerErrorList Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides DesignerToolControl..::.Dispose(Boolean).)

See Also

DesignerErrorList Class
DesignerErrorList Members
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.Dispose Method (Boolean)
DesignerErrorList Class See Also Send Feedback
Clean up any resources being used.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

DesignerErrorList Class
Dispose Overload
PerpetuumSoft.Reporting.Designer Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.GetChildAtPoint Method
DesignerErrorList Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DesignerErrorList Class
DesignerErrorList Members
PerpetuumSoft.Reporting.Designer Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.Invalidate Method
DesignerErrorList Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DesignerErrorList Class
DesignerErrorList Members
PerpetuumSoft.Reporting.Designer Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.Invoke Method
DesignerErrorList Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DesignerErrorList Class
DesignerErrorList Members
PerpetuumSoft.Reporting.Designer Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.MemberwiseClone Method
DesignerErrorList Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DesignerErrorList Class
DesignerErrorList Members
PerpetuumSoft.Reporting.Designer Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.OnLoad Method
DesignerErrorList Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

DesignerErrorList Class
PerpetuumSoft.Reporting.Designer Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.PerformLayout Method
DesignerErrorList Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DesignerErrorList Class
DesignerErrorList Members
PerpetuumSoft.Reporting.Designer Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.ResumeLayout Method
DesignerErrorList Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DesignerErrorList Class
DesignerErrorList Members
PerpetuumSoft.Reporting.Designer Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.RtlTranslateAlignment Method
DesignerErrorList Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DesignerErrorList Class
DesignerErrorList Members
PerpetuumSoft.Reporting.Designer Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.Scale Method
DesignerErrorList Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DesignerErrorList Class
DesignerErrorList Members
PerpetuumSoft.Reporting.Designer Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.Select Method
DesignerErrorList Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

DesignerErrorList Class
DesignerErrorList Members
PerpetuumSoft.Reporting.Designer Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.SetBounds Method
DesignerErrorList Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DesignerErrorList Class
DesignerErrorList Members
PerpetuumSoft.Reporting.Designer Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.UpdateBounds Method
DesignerErrorList Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DesignerErrorList Class
DesignerErrorList Members
PerpetuumSoft.Reporting.Designer Namespace


UpdateTool Method

[image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.UpdateTool Method
DesignerErrorList Class See Also Send Feedback
Updates Tool states.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void UpdateTool(
    DesignerToolArgs e
)
Visual Basic (Declaration)
Public Overrides Sub UpdateTool ( _
    e As DesignerToolArgs _
)
Visual C++
public:
virtual void UpdateTool(
    DesignerToolArgs^ e
) override

Parameters

e
Type: PerpetuumSoft.Reporting.Designer..::.DesignerToolArgs

Implements

IDesignerTool..::.UpdateTool(DesignerToolArgs)

See Also

DesignerErrorList Class
PerpetuumSoft.Reporting.Designer Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.Validate Method
DesignerErrorList Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DesignerErrorList Class
DesignerErrorList Members
PerpetuumSoft.Reporting.Designer Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.ValidateChildren Method
DesignerErrorList Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

DesignerErrorList Class
DesignerErrorList Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerErrorList Properties

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList Properties
DesignerErrorList Class See Also Send Feedback

The DesignerErrorList type exposes the following members.

Properties

Name | Description
About | Gets the copyright string. (Inherited from DesignerToolControl.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | Gets or sets caption list for the control.
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
Designer | Gets and sets associated ReportDesigner. (Inherited from DesignerToolControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

DesignerErrorList Class
PerpetuumSoft.Reporting.Designer Namespace


Caption Property

[image]

.NET ModelKit Suite ClassReference
DesignerErrorList..::.Caption Property
DesignerErrorList Class See Also Send Feedback
Gets or sets caption list for the control.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Caption { get; set; }
Visual Basic (Declaration)
Public Property Caption As String
Visual C++
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}

See Also

DesignerErrorList Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerErrorList Events

[image] [image]

.NET ModelKit Suite ClassReference
DesignerErrorList Events
DesignerErrorList Class See Also Send Feedback

The DesignerErrorList type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerErrorList Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerForm Class

[image]

.NET ModelKit Suite ClassReference
DesignerForm Class
Members See Also Send Feedback
Represents assembled report designer.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DesignerForm : Form,
    IDesignerTool
Visual Basic (Declaration)
Public Class DesignerForm _
    Inherits Form _
    Implements IDesignerTool
Visual C++
public ref class DesignerForm : public Form,
    IDesignerTool

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
PerpetuumSoft.Reporting.Designer..::.DesignerForm

See Also

DesignerForm Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerForm Members

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm Members
DesignerForm Class Constructors Methods Properties Events See Also Send Feedback

The DesignerForm type exposes the following members.

Constructors

Name | Description
DesignerForm | Creates new instance of DesignerForm.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Overrides Form..::.OnFormClosed(FormClosedEventArgs).)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesignerCaption | Gets or sets a header for the designer form.
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTool | Updates Tool state.
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
Designer | Gets internal ReportDesigner instance.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
IgnoreObsoleteWarning | Gets or sets a value that indicates if the warning about the use of obsolete report elements should be ignored.
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowErrorList | Gets and sets if ErrorList visible.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowToolWindow | Gets and sets if tool windows are visible.
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolButtonsDisplayMode | Gets or sets image displaying mode in the elements palette.
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerForm Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerForm Constructor

[image]

.NET ModelKit Suite ClassReference
DesignerForm Constructor
DesignerForm Class See Also Send Feedback
Creates new instance of DesignerForm.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DesignerForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DesignerForm()

See Also

DesignerForm Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerForm Methods

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm Methods
DesignerForm Class See Also Send Feedback

The DesignerForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Overrides Form..::.OnFormClosed(FormClosedEventArgs).)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesignerCaption | Gets or sets a header for the designer form.
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTool | Updates Tool state.
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

DesignerForm Class
PerpetuumSoft.Reporting.Designer Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm..::.AccessibilityNotifyClients Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
PerpetuumSoft.Reporting.Designer Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm..::.BeginInvoke Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm..::.Dispose Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

DesignerForm Class
DesignerForm Members
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
DesignerForm..::.Dispose Method (Boolean)
DesignerForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

DesignerForm Class
Dispose Overload
PerpetuumSoft.Reporting.Designer Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm..::.GetChildAtPoint Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
PerpetuumSoft.Reporting.Designer Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm..::.Invalidate Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
PerpetuumSoft.Reporting.Designer Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm..::.Invoke Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
PerpetuumSoft.Reporting.Designer Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm..::.MemberwiseClone Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DesignerForm Class
DesignerForm Members
PerpetuumSoft.Reporting.Designer Namespace


OnFormClosed Method

[image]

.NET ModelKit Suite ClassReference
DesignerForm..::.OnFormClosed Method
DesignerForm Class See Also Send Feedback
Raises the FormClosed event.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnFormClosed(
    FormClosedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnFormClosed ( _
    e As FormClosedEventArgs _
)
Visual C++
protected:
virtual void OnFormClosed(
    FormClosedEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.FormClosedEventArgs

See Also

DesignerForm Class
PerpetuumSoft.Reporting.Designer Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
DesignerForm..::.OnLoad Method
DesignerForm Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

DesignerForm Class
PerpetuumSoft.Reporting.Designer Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm..::.PerformLayout Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
PerpetuumSoft.Reporting.Designer Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm..::.ResumeLayout Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
PerpetuumSoft.Reporting.Designer Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm..::.RtlTranslateAlignment Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
PerpetuumSoft.Reporting.Designer Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm..::.Scale Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
PerpetuumSoft.Reporting.Designer Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm..::.Select Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

DesignerForm Class
DesignerForm Members
PerpetuumSoft.Reporting.Designer Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm..::.SetBounds Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
PerpetuumSoft.Reporting.Designer Namespace


SetDesignerCaption Method

[image]

.NET ModelKit Suite ClassReference
DesignerForm..::.SetDesignerCaption Method
DesignerForm Class See Also Send Feedback
Gets or sets a header for the designer form.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void SetDesignerCaption()
Visual Basic (Declaration)
Protected Overridable Sub SetDesignerCaption
Visual C++
protected:
virtual void SetDesignerCaption()

See Also

DesignerForm Class
PerpetuumSoft.Reporting.Designer Namespace


Show Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm..::.Show Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

DesignerForm Class
DesignerForm Members
PerpetuumSoft.Reporting.Designer Namespace


ShowDialog Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm..::.ShowDialog Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

DesignerForm Class
DesignerForm Members
PerpetuumSoft.Reporting.Designer Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm..::.UpdateBounds Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DesignerForm Class
DesignerForm Members
PerpetuumSoft.Reporting.Designer Namespace


UpdateTool Method

[image]

.NET ModelKit Suite ClassReference
DesignerForm..::.UpdateTool Method
DesignerForm Class See Also Send Feedback
Updates Tool state.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void UpdateTool(
    DesignerToolArgs arg
)
Visual Basic (Declaration)
Public Sub UpdateTool ( _
    arg As DesignerToolArgs _
)
Visual C++
public:
virtual void UpdateTool(
    DesignerToolArgs^ arg
) sealed

Parameters

arg
Type: PerpetuumSoft.Reporting.Designer..::.DesignerToolArgs

Implements

IDesignerTool..::.UpdateTool(DesignerToolArgs)

See Also

DesignerForm Class
PerpetuumSoft.Reporting.Designer Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm..::.Validate Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DesignerForm Class
DesignerForm Members
PerpetuumSoft.Reporting.Designer Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm..::.ValidateChildren Method
DesignerForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

DesignerForm Class
DesignerForm Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerForm Properties

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm Properties
DesignerForm Class See Also Send Feedback

The DesignerForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
Designer | Gets internal ReportDesigner instance.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
IgnoreObsoleteWarning | Gets or sets a value that indicates if the warning about the use of obsolete report elements should be ignored.
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowErrorList | Gets and sets if ErrorList visible.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowToolWindow | Gets and sets if tool windows are visible.
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolButtonsDisplayMode | Gets or sets image displaying mode in the elements palette.
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

DesignerForm Class
PerpetuumSoft.Reporting.Designer Namespace


Designer Property

[image]

.NET ModelKit Suite ClassReference
DesignerForm..::.Designer Property
DesignerForm Class See Also Send Feedback
Gets internal ReportDesigner instance.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportDesigner Designer { get; }
Visual Basic (Declaration)
Public ReadOnly Property Designer As ReportDesigner
Visual C++
public:
property ReportDesigner^ Designer {
    ReportDesigner^ get ();
}

See Also

DesignerForm Class
PerpetuumSoft.Reporting.Designer Namespace


IgnoreObsoleteWarning Property

[image]

.NET ModelKit Suite ClassReference
DesignerForm..::.IgnoreObsoleteWarning Property
DesignerForm Class See Also Send Feedback
Gets or sets a value that indicates if the warning about the use of obsolete report elements should be ignored.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static bool IgnoreObsoleteWarning { get; set; }
Visual Basic (Declaration)
Public Shared Property IgnoreObsoleteWarning As Boolean
Visual C++
public:
static property bool IgnoreObsoleteWarning {
    bool get ();
    void set (bool value);
}

See Also

DesignerForm Class
PerpetuumSoft.Reporting.Designer Namespace


ShowErrorList Property

[image]

.NET ModelKit Suite ClassReference
DesignerForm..::.ShowErrorList Property
DesignerForm Class See Also Send Feedback
Gets and sets if ErrorList visible.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowErrorList { get; set; }
Visual Basic (Declaration)
Public Property ShowErrorList As Boolean
Visual C++
public:
property bool ShowErrorList {
    bool get ();
    void set (bool value);
}

See Also

DesignerForm Class
PerpetuumSoft.Reporting.Designer Namespace


ShowToolWindow Property

[image]

.NET ModelKit Suite ClassReference
DesignerForm..::.ShowToolWindow Property
DesignerForm Class See Also Send Feedback
Gets and sets if tool windows are visible.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowToolWindow { get; set; }
Visual Basic (Declaration)
Public Property ShowToolWindow As Boolean
Visual C++
public:
property bool ShowToolWindow {
    bool get ();
    void set (bool value);
}

See Also

DesignerForm Class
PerpetuumSoft.Reporting.Designer Namespace


ToolButtonsDisplayMode Property

[image]

.NET ModelKit Suite ClassReference
DesignerForm..::.ToolButtonsDisplayMode Property
DesignerForm Class See Also Send Feedback
Gets or sets image displaying mode in the elements palette.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ToolButtonsDisplayMode ToolButtonsDisplayMode { get; set; }
Visual Basic (Declaration)
Public Property ToolButtonsDisplayMode As ToolButtonsDisplayMode
Visual C++
public:
property ToolButtonsDisplayMode ToolButtonsDisplayMode {
    ToolButtonsDisplayMode get ();
    void set (ToolButtonsDisplayMode value);
}

See Also

DesignerForm Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerForm Events

[image] [image]

.NET ModelKit Suite ClassReference
DesignerForm Events
DesignerForm Class See Also Send Feedback

The DesignerForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerForm Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerMouseEventArgs Class

[image]

.NET ModelKit Suite ClassReference
DesignerMouseEventArgs Class
Members See Also Send Feedback
'Provides data for DesignerMouseUp, DesignerMouseDown events.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DesignerMouseEventArgs : MouseEventArgs
Visual Basic (Declaration)
Public Class DesignerMouseEventArgs _
    Inherits MouseEventArgs
Visual C++
public ref class DesignerMouseEventArgs : public MouseEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.Windows.Forms..::.MouseEventArgs
PerpetuumSoft.Reporting.Designer..::.DesignerMouseEventArgs

See Also

DesignerMouseEventArgs Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerMouseEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
DesignerMouseEventArgs Members
DesignerMouseEventArgs Class Constructors Methods Properties See Also Send Feedback

The DesignerMouseEventArgs type exposes the following members.

Constructors

Name | Description
DesignerMouseEventArgs | Initializes a new instance of the DesignerMouseEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Button | Gets which mouse button was pressed. (Inherited from MouseEventArgs.)
Clicks | Gets the number of times the mouse button was pressed and released. (Inherited from MouseEventArgs.)
Control | Gets specified ReportControl.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel. (Inherited from MouseEventArgs.)
Handled | Gets or sets a value indicating whether the event should be handled.
Location | Gets the location of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)
MouseMode | Gets mouse mode name.
X | Gets the x-coordinate of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)
Y | Gets the y-coordinate of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)

See Also

DesignerMouseEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerMouseEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
DesignerMouseEventArgs Constructor
DesignerMouseEventArgs Class See Also Send Feedback
Initializes a new instance of the DesignerMouseEventArgs class.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DesignerMouseEventArgs(
    ReportControl control,
    string mouseModeName,
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Sub New ( _
    control As ReportControl, _
    mouseModeName As String, _
    args As MouseEventArgs _
)
Visual C++
public:
DesignerMouseEventArgs(
    ReportControl^ control,
    String^ mouseModeName,
    MouseEventArgs^ args
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
mouseModeName
Type: System..::.String
args
Type: System.Windows.Forms..::.MouseEventArgs

See Also

DesignerMouseEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerMouseEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
DesignerMouseEventArgs Methods
DesignerMouseEventArgs Class See Also Send Feedback

The DesignerMouseEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DesignerMouseEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerMouseEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
DesignerMouseEventArgs Properties
DesignerMouseEventArgs Class See Also Send Feedback

The DesignerMouseEventArgs type exposes the following members.

Properties

Name | Description
Button | Gets which mouse button was pressed. (Inherited from MouseEventArgs.)
Clicks | Gets the number of times the mouse button was pressed and released. (Inherited from MouseEventArgs.)
Control | Gets specified ReportControl.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel. (Inherited from MouseEventArgs.)
Handled | Gets or sets a value indicating whether the event should be handled.
Location | Gets the location of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)
MouseMode | Gets mouse mode name.
X | Gets the x-coordinate of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)
Y | Gets the y-coordinate of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)

See Also

DesignerMouseEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


Control Property

[image]

.NET ModelKit Suite ClassReference
DesignerMouseEventArgs..::.Control Property
DesignerMouseEventArgs Class See Also Send Feedback
Gets specified ReportControl.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportControl Control { get; }
Visual Basic (Declaration)
Public ReadOnly Property Control As ReportControl
Visual C++
public:
property ReportControl^ Control {
    ReportControl^ get ();
}

See Also

DesignerMouseEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


Handled Property

[image]

.NET ModelKit Suite ClassReference
DesignerMouseEventArgs..::.Handled Property
DesignerMouseEventArgs Class See Also Send Feedback
Gets or sets a value indicating whether the event should be handled.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Handled { get; set; }
Visual Basic (Declaration)
Public Property Handled As Boolean
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

See Also

DesignerMouseEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


MouseMode Property

[image]

.NET ModelKit Suite ClassReference
DesignerMouseEventArgs..::.MouseMode Property
DesignerMouseEventArgs Class See Also Send Feedback
Gets mouse mode name.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string MouseMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property MouseMode As String
Visual C++
public:
property String^ MouseMode {
    String^ get ();
}

See Also

DesignerMouseEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerMouseEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
DesignerMouseEventHandler Delegate
See Also Send Feedback
Represents the method that will handle DesignerMouseUp, DesignerMouseDown events.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate void DesignerMouseEventHandler(
    Object sender,
    DesignerMouseEventArgs args
)
Visual Basic (Declaration)
Public Delegate Sub DesignerMouseEventHandler ( _
    sender As Object, _
    args As DesignerMouseEventArgs _
)
Visual C++
public delegate void DesignerMouseEventHandler(
    Object^ sender,
    DesignerMouseEventArgs^ args
)

Parameters

sender
Type: System..::.Object
args
Type: PerpetuumSoft.Reporting.Designer..::.DesignerMouseEventArgs

See Also

PerpetuumSoft.Reporting.Designer Namespace


DesignerPropertyGrid Class

[image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid Class
Members See Also Send Feedback
Contains PropertyGrid for ReportDesigner.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DesignerPropertyGrid : DesignerToolControl
Visual Basic (Declaration)
Public Class DesignerPropertyGrid _
    Inherits DesignerToolControl
Visual C++
public ref class DesignerPropertyGrid : public DesignerToolControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Reporting.Designer..::.DesignerToolControl
PerpetuumSoft.Reporting.Designer..::.DesignerPropertyGrid

See Also

DesignerPropertyGrid Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerPropertyGrid Members

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid Members
DesignerPropertyGrid Class Constructors Methods Properties Events See Also Send Feedback

The DesignerPropertyGrid type exposes the following members.

Constructors

Name | Description
DesignerPropertyGrid | Creates new instance of DesignerPropertyGrid control.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BindControl | Binds control to designer's action. (Inherited from DesignerToolControl.)
BindControls | Performs actual controls binding. (Inherited from DesignerToolControl.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalBindControls | Runs controls binding. (Inherited from DesignerToolControl.)
InternalUnbindControls | Runs controls unbind operations. (Inherited from DesignerToolControl.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStatusText | Updates text in status bar. (Inherited from DesignerToolControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UnbindControls | Performs actual unbind operations. (Inherited from DesignerToolControl.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTool | Updates Tool state. (Overrides DesignerToolControl..::.UpdateTool(DesignerToolArgs).)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
About | Gets the copyright string. (Inherited from DesignerToolControl.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
Designer | Gets and sets associated ReportDesigner. (Overrides DesignerToolControl..::.Designer.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerPropertyGrid Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerPropertyGrid Constructor

[image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid Constructor
DesignerPropertyGrid Class See Also Send Feedback
Creates new instance of DesignerPropertyGrid control.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DesignerPropertyGrid()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DesignerPropertyGrid()

See Also

DesignerPropertyGrid Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerPropertyGrid Methods

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid Methods
DesignerPropertyGrid Class See Also Send Feedback

The DesignerPropertyGrid type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BindControl | Binds control to designer's action. (Inherited from DesignerToolControl.)
BindControls | Performs actual controls binding. (Inherited from DesignerToolControl.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalBindControls | Runs controls binding. (Inherited from DesignerToolControl.)
InternalUnbindControls | Runs controls unbind operations. (Inherited from DesignerToolControl.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStatusText | Updates text in status bar. (Inherited from DesignerToolControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UnbindControls | Performs actual unbind operations. (Inherited from DesignerToolControl.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTool | Updates Tool state. (Overrides DesignerToolControl..::.UpdateTool(DesignerToolArgs).)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

DesignerPropertyGrid Class
PerpetuumSoft.Reporting.Designer Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.AccessibilityNotifyClients Method
DesignerPropertyGrid Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DesignerPropertyGrid Class
DesignerPropertyGrid Members
PerpetuumSoft.Reporting.Designer Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.BeginInvoke Method
DesignerPropertyGrid Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DesignerPropertyGrid Class
DesignerPropertyGrid Members
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.Dispose Method
DesignerPropertyGrid Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides DesignerToolControl..::.Dispose(Boolean).)

See Also

DesignerPropertyGrid Class
DesignerPropertyGrid Members
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.Dispose Method (Boolean)
DesignerPropertyGrid Class See Also Send Feedback
Clean up any resources being used.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

DesignerPropertyGrid Class
Dispose Overload
PerpetuumSoft.Reporting.Designer Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.GetChildAtPoint Method
DesignerPropertyGrid Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DesignerPropertyGrid Class
DesignerPropertyGrid Members
PerpetuumSoft.Reporting.Designer Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.Invalidate Method
DesignerPropertyGrid Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DesignerPropertyGrid Class
DesignerPropertyGrid Members
PerpetuumSoft.Reporting.Designer Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.Invoke Method
DesignerPropertyGrid Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DesignerPropertyGrid Class
DesignerPropertyGrid Members
PerpetuumSoft.Reporting.Designer Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.MemberwiseClone Method
DesignerPropertyGrid Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DesignerPropertyGrid Class
DesignerPropertyGrid Members
PerpetuumSoft.Reporting.Designer Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.OnLoad Method
DesignerPropertyGrid Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

DesignerPropertyGrid Class
PerpetuumSoft.Reporting.Designer Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.PerformLayout Method
DesignerPropertyGrid Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DesignerPropertyGrid Class
DesignerPropertyGrid Members
PerpetuumSoft.Reporting.Designer Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.ResumeLayout Method
DesignerPropertyGrid Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DesignerPropertyGrid Class
DesignerPropertyGrid Members
PerpetuumSoft.Reporting.Designer Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.RtlTranslateAlignment Method
DesignerPropertyGrid Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DesignerPropertyGrid Class
DesignerPropertyGrid Members
PerpetuumSoft.Reporting.Designer Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.Scale Method
DesignerPropertyGrid Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DesignerPropertyGrid Class
DesignerPropertyGrid Members
PerpetuumSoft.Reporting.Designer Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.Select Method
DesignerPropertyGrid Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

DesignerPropertyGrid Class
DesignerPropertyGrid Members
PerpetuumSoft.Reporting.Designer Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.SetBounds Method
DesignerPropertyGrid Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DesignerPropertyGrid Class
DesignerPropertyGrid Members
PerpetuumSoft.Reporting.Designer Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.UpdateBounds Method
DesignerPropertyGrid Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DesignerPropertyGrid Class
DesignerPropertyGrid Members
PerpetuumSoft.Reporting.Designer Namespace


UpdateTool Method

[image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.UpdateTool Method
DesignerPropertyGrid Class See Also Send Feedback
Updates Tool state.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void UpdateTool(
    DesignerToolArgs args
)
Visual Basic (Declaration)
Public Overrides Sub UpdateTool ( _
    args As DesignerToolArgs _
)
Visual C++
public:
virtual void UpdateTool(
    DesignerToolArgs^ args
) override

Parameters

args
Type: PerpetuumSoft.Reporting.Designer..::.DesignerToolArgs

Implements

IDesignerTool..::.UpdateTool(DesignerToolArgs)

See Also

DesignerPropertyGrid Class
PerpetuumSoft.Reporting.Designer Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.Validate Method
DesignerPropertyGrid Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DesignerPropertyGrid Class
DesignerPropertyGrid Members
PerpetuumSoft.Reporting.Designer Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.ValidateChildren Method
DesignerPropertyGrid Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

DesignerPropertyGrid Class
DesignerPropertyGrid Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerPropertyGrid Properties

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid Properties
DesignerPropertyGrid Class See Also Send Feedback

The DesignerPropertyGrid type exposes the following members.

Properties

Name | Description
About | Gets the copyright string. (Inherited from DesignerToolControl.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
Designer | Gets and sets associated ReportDesigner. (Overrides DesignerToolControl..::.Designer.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

DesignerPropertyGrid Class
PerpetuumSoft.Reporting.Designer Namespace


Designer Property

[image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid..::.Designer Property
DesignerPropertyGrid Class See Also Send Feedback
Gets and sets associated ReportDesigner.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override ReportDesigner Designer { get; set; }
Visual Basic (Declaration)
Public Overrides Property Designer As ReportDesigner
Visual C++
public:
virtual property ReportDesigner^ Designer {
    ReportDesigner^ get () override;
    void set (ReportDesigner^ value) override;
}

See Also

DesignerPropertyGrid Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerPropertyGrid Events

[image] [image]

.NET ModelKit Suite ClassReference
DesignerPropertyGrid Events
DesignerPropertyGrid Class See Also Send Feedback

The DesignerPropertyGrid type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerPropertyGrid Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerStatusBar Class

[image]

.NET ModelKit Suite ClassReference
DesignerStatusBar Class
Members See Also Send Feedback
Contains StatusBar for ReportDesigner.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DesignerStatusBar : DesignerToolControl
Visual Basic (Declaration)
Public Class DesignerStatusBar _
    Inherits DesignerToolControl
Visual C++
public ref class DesignerStatusBar : public DesignerToolControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Reporting.Designer..::.DesignerToolControl
PerpetuumSoft.Reporting.Designer..::.DesignerStatusBar

See Also

DesignerStatusBar Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerStatusBar Members

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar Members
DesignerStatusBar Class Constructors Methods Properties Events See Also Send Feedback

The DesignerStatusBar type exposes the following members.

Constructors

Name | Description
DesignerStatusBar | Creates new instance of DesignerStatusBar.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BindControl | Binds control to designer's action. (Inherited from DesignerToolControl.)
BindControls | Performs actual controls binding. (Inherited from DesignerToolControl.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalBindControls | Runs controls binding. (Inherited from DesignerToolControl.)
InternalUnbindControls | Runs controls unbind operations. (Inherited from DesignerToolControl.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStatusText | Updates current status text. (Overrides DesignerToolControl..::.SetStatusText(String).)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UnbindControls | Performs actual unbind operations. (Inherited from DesignerToolControl.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTool | Updates Tool state. (Overrides DesignerToolControl..::.UpdateTool(DesignerToolArgs).)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
About | Gets the copyright string. (Inherited from DesignerToolControl.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
Designer | Gets and sets associated ReportDesigner. (Inherited from DesignerToolControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerStatusBar Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerStatusBar Constructor

[image]

.NET ModelKit Suite ClassReference
DesignerStatusBar Constructor
DesignerStatusBar Class See Also Send Feedback
Creates new instance of DesignerStatusBar.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DesignerStatusBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DesignerStatusBar()

See Also

DesignerStatusBar Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerStatusBar Methods

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar Methods
DesignerStatusBar Class See Also Send Feedback

The DesignerStatusBar type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BindControl | Binds control to designer's action. (Inherited from DesignerToolControl.)
BindControls | Performs actual controls binding. (Inherited from DesignerToolControl.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalBindControls | Runs controls binding. (Inherited from DesignerToolControl.)
InternalUnbindControls | Runs controls unbind operations. (Inherited from DesignerToolControl.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStatusText | Updates current status text. (Overrides DesignerToolControl..::.SetStatusText(String).)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UnbindControls | Performs actual unbind operations. (Inherited from DesignerToolControl.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTool | Updates Tool state. (Overrides DesignerToolControl..::.UpdateTool(DesignerToolArgs).)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

DesignerStatusBar Class
PerpetuumSoft.Reporting.Designer Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar..::.AccessibilityNotifyClients Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
PerpetuumSoft.Reporting.Designer Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar..::.BeginInvoke Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar..::.Dispose Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides DesignerToolControl..::.Dispose(Boolean).)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
DesignerStatusBar..::.Dispose Method (Boolean)
DesignerStatusBar Class See Also Send Feedback
Clean up any resources being used.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

DesignerStatusBar Class
Dispose Overload
PerpetuumSoft.Reporting.Designer Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar..::.GetChildAtPoint Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
PerpetuumSoft.Reporting.Designer Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar..::.Invalidate Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
PerpetuumSoft.Reporting.Designer Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar..::.Invoke Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
PerpetuumSoft.Reporting.Designer Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar..::.MemberwiseClone Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
PerpetuumSoft.Reporting.Designer Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar..::.PerformLayout Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
PerpetuumSoft.Reporting.Designer Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar..::.ResumeLayout Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
PerpetuumSoft.Reporting.Designer Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar..::.RtlTranslateAlignment Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
PerpetuumSoft.Reporting.Designer Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar..::.Scale Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
PerpetuumSoft.Reporting.Designer Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar..::.Select Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
PerpetuumSoft.Reporting.Designer Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar..::.SetBounds Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
PerpetuumSoft.Reporting.Designer Namespace


SetStatusText Method

[image]

.NET ModelKit Suite ClassReference
DesignerStatusBar..::.SetStatusText Method
DesignerStatusBar Class See Also Send Feedback
Updates current status text.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void SetStatusText(
    string text
)
Visual Basic (Declaration)
Public Overrides Sub SetStatusText ( _
    text As String _
)
Visual C++
public:
virtual void SetStatusText(
    String^ text
) override

Parameters

text
Type: System..::.String

Implements

IDesignerTool..::.SetStatusText(String)

See Also

DesignerStatusBar Class
PerpetuumSoft.Reporting.Designer Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar..::.UpdateBounds Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
PerpetuumSoft.Reporting.Designer Namespace


UpdateTool Method

[image]

.NET ModelKit Suite ClassReference
DesignerStatusBar..::.UpdateTool Method
DesignerStatusBar Class See Also Send Feedback
Updates Tool state.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void UpdateTool(
    DesignerToolArgs args
)
Visual Basic (Declaration)
Public Overrides Sub UpdateTool ( _
    args As DesignerToolArgs _
)
Visual C++
public:
virtual void UpdateTool(
    DesignerToolArgs^ args
) override

Parameters

args
Type: PerpetuumSoft.Reporting.Designer..::.DesignerToolArgs

Implements

IDesignerTool..::.UpdateTool(DesignerToolArgs)

See Also

DesignerStatusBar Class
PerpetuumSoft.Reporting.Designer Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar..::.Validate Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
PerpetuumSoft.Reporting.Designer Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar..::.ValidateChildren Method
DesignerStatusBar Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

DesignerStatusBar Class
DesignerStatusBar Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerStatusBar Properties

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar Properties
DesignerStatusBar Class See Also Send Feedback

The DesignerStatusBar type exposes the following members.

Properties

Name | Description
About | Gets the copyright string. (Inherited from DesignerToolControl.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
Designer | Gets and sets associated ReportDesigner. (Inherited from DesignerToolControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

DesignerStatusBar Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerStatusBar Events

[image] [image]

.NET ModelKit Suite ClassReference
DesignerStatusBar Events
DesignerStatusBar Class See Also Send Feedback

The DesignerStatusBar type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerStatusBar Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolArgs Class

[image]

.NET ModelKit Suite ClassReference
DesignerToolArgs Class
Members See Also Send Feedback
Provides information for UpdateTool methods.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DesignerToolArgs
Visual Basic (Declaration)
Public Class DesignerToolArgs
Visual C++
public ref class DesignerToolArgs

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Designer..::.DesignerToolArgs

See Also

DesignerToolArgs Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolArgs Members
DesignerToolArgs Class Constructors Methods Properties See Also Send Feedback

The DesignerToolArgs type exposes the following members.

Constructors

Name | Description
DesignerToolArgs | Creates a new instance of DesignerToolArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentChanged | Gets and sets if document was changed.
Init | Gets and sets if new design session was initialized.
SelectionChange | Gets and sets if selection was changed.
UpdateActions | Gets and sets if actions need to be updated.
UpdateErrorList | Gets and sets if Error list need to be updated.
UpdateScrolls | Gets and sets if scroll bars need to be updated.
UpdateView | Gets and sets if report designer view box need to be updated.

See Also

DesignerToolArgs Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolArgs Constructor

[image]

.NET ModelKit Suite ClassReference
DesignerToolArgs Constructor
DesignerToolArgs Class See Also Send Feedback
Creates a new instance of DesignerToolArgs class.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DesignerToolArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DesignerToolArgs()

See Also

DesignerToolArgs Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolArgs Methods
DesignerToolArgs Class See Also Send Feedback

The DesignerToolArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DesignerToolArgs Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolArgs Properties
DesignerToolArgs Class See Also Send Feedback

The DesignerToolArgs type exposes the following members.

Properties

Name | Description
DocumentChanged | Gets and sets if document was changed.
Init | Gets and sets if new design session was initialized.
SelectionChange | Gets and sets if selection was changed.
UpdateActions | Gets and sets if actions need to be updated.
UpdateErrorList | Gets and sets if Error list need to be updated.
UpdateScrolls | Gets and sets if scroll bars need to be updated.
UpdateView | Gets and sets if report designer view box need to be updated.

See Also

DesignerToolArgs Class
PerpetuumSoft.Reporting.Designer Namespace


DocumentChanged Property

[image]

.NET ModelKit Suite ClassReference
DesignerToolArgs..::.DocumentChanged Property
DesignerToolArgs Class See Also Send Feedback
Gets and sets if document was changed.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool DocumentChanged { get; set; }
Visual Basic (Declaration)
Public Property DocumentChanged As Boolean
Visual C++
public:
property bool DocumentChanged {
    bool get ();
    void set (bool value);
}

See Also

DesignerToolArgs Class
PerpetuumSoft.Reporting.Designer Namespace


Init Property

[image]

.NET ModelKit Suite ClassReference
DesignerToolArgs..::.Init Property
DesignerToolArgs Class See Also Send Feedback
Gets and sets if new design session was initialized.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Init { get; set; }
Visual Basic (Declaration)
Public Property Init As Boolean
Visual C++
public:
property bool Init {
    bool get ();
    void set (bool value);
}

See Also

DesignerToolArgs Class
PerpetuumSoft.Reporting.Designer Namespace


SelectionChange Property

[image]

.NET ModelKit Suite ClassReference
DesignerToolArgs..::.SelectionChange Property
DesignerToolArgs Class See Also Send Feedback
Gets and sets if selection was changed.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool SelectionChange { get; set; }
Visual Basic (Declaration)
Public Property SelectionChange As Boolean
Visual C++
public:
property bool SelectionChange {
    bool get ();
    void set (bool value);
}

See Also

DesignerToolArgs Class
PerpetuumSoft.Reporting.Designer Namespace


UpdateActions Property

[image]

.NET ModelKit Suite ClassReference
DesignerToolArgs..::.UpdateActions Property
DesignerToolArgs Class See Also Send Feedback
Gets and sets if actions need to be updated.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool UpdateActions { get; set; }
Visual Basic (Declaration)
Public Property UpdateActions As Boolean
Visual C++
public:
property bool UpdateActions {
    bool get ();
    void set (bool value);
}

See Also

DesignerToolArgs Class
PerpetuumSoft.Reporting.Designer Namespace


UpdateErrorList Property

[image]

.NET ModelKit Suite ClassReference
DesignerToolArgs..::.UpdateErrorList Property
DesignerToolArgs Class See Also Send Feedback
Gets and sets if Error list need to be updated.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool UpdateErrorList { get; set; }
Visual Basic (Declaration)
Public Property UpdateErrorList As Boolean
Visual C++
public:
property bool UpdateErrorList {
    bool get ();
    void set (bool value);
}

See Also

DesignerToolArgs Class
PerpetuumSoft.Reporting.Designer Namespace


UpdateScrolls Property

[image]

.NET ModelKit Suite ClassReference
DesignerToolArgs..::.UpdateScrolls Property
DesignerToolArgs Class See Also Send Feedback
Gets and sets if scroll bars need to be updated.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool UpdateScrolls { get; set; }
Visual Basic (Declaration)
Public Property UpdateScrolls As Boolean
Visual C++
public:
property bool UpdateScrolls {
    bool get ();
    void set (bool value);
}

See Also

DesignerToolArgs Class
PerpetuumSoft.Reporting.Designer Namespace


UpdateView Property

[image]

.NET ModelKit Suite ClassReference
DesignerToolArgs..::.UpdateView Property
DesignerToolArgs Class See Also Send Feedback
Gets and sets if report designer view box need to be updated.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool UpdateView { get; set; }
Visual Basic (Declaration)
Public Property UpdateView As Boolean
Visual C++
public:
property bool UpdateView {
    bool get ();
    void set (bool value);
}

See Also

DesignerToolArgs Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolBar Class

[image]

.NET ModelKit Suite ClassReference
DesignerToolBar Class
Members See Also Send Feedback
Contains ToolBar for ReportDesigner.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DesignerToolBar : DesignerToolControl
Visual Basic (Declaration)
Public Class DesignerToolBar _
    Inherits DesignerToolControl
Visual C++
public ref class DesignerToolBar : public DesignerToolControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Reporting.Designer..::.DesignerToolControl
PerpetuumSoft.Reporting.Designer..::.DesignerToolBar

See Also

DesignerToolBar Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolBar Members

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar Members
DesignerToolBar Class Constructors Methods Properties Events See Also Send Feedback

The DesignerToolBar type exposes the following members.

Constructors

Name | Description
DesignerToolBar | Creates new instance of the DesignerToolBar control.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BindControl | Binds control to designer's action. (Inherited from DesignerToolControl.)
BindControls | Binds control to actions. (Overrides DesignerToolControl..::.BindControls()()().)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalBindControls | Runs controls binding. (Inherited from DesignerToolControl.)
InternalUnbindControls | Runs controls unbind operations. (Inherited from DesignerToolControl.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStatusText | Updates text in status bar. (Inherited from DesignerToolControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UnbindControls | Performs actual unbind operations. (Inherited from DesignerToolControl.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTool | Updates Tool state. (Inherited from DesignerToolControl.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
About | Gets the copyright string. (Inherited from DesignerToolControl.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
Designer | Gets and sets associated ReportDesigner. (Inherited from DesignerToolControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerToolBar Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolBar Constructor

[image]

.NET ModelKit Suite ClassReference
DesignerToolBar Constructor
DesignerToolBar Class See Also Send Feedback
Creates new instance of the DesignerToolBar control.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DesignerToolBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DesignerToolBar()

See Also

DesignerToolBar Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolBar Methods

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar Methods
DesignerToolBar Class See Also Send Feedback

The DesignerToolBar type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BindControl | Binds control to designer's action. (Inherited from DesignerToolControl.)
BindControls | Binds control to actions. (Overrides DesignerToolControl..::.BindControls()()().)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalBindControls | Runs controls binding. (Inherited from DesignerToolControl.)
InternalUnbindControls | Runs controls unbind operations. (Inherited from DesignerToolControl.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStatusText | Updates text in status bar. (Inherited from DesignerToolControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UnbindControls | Performs actual unbind operations. (Inherited from DesignerToolControl.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTool | Updates Tool state. (Inherited from DesignerToolControl.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

DesignerToolBar Class
PerpetuumSoft.Reporting.Designer Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar..::.AccessibilityNotifyClients Method
DesignerToolBar Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DesignerToolBar Class
DesignerToolBar Members
PerpetuumSoft.Reporting.Designer Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar..::.BeginInvoke Method
DesignerToolBar Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DesignerToolBar Class
DesignerToolBar Members
PerpetuumSoft.Reporting.Designer Namespace


BindControls Method

[image]

.NET ModelKit Suite ClassReference
DesignerToolBar..::.BindControls Method
DesignerToolBar Class See Also Send Feedback
Binds control to actions.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void BindControls()
Visual Basic (Declaration)
Protected Overrides Sub BindControls
Visual C++
protected:
virtual void BindControls() override

See Also

DesignerToolBar Class
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar..::.Dispose Method
DesignerToolBar Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides DesignerToolControl..::.Dispose(Boolean).)

See Also

DesignerToolBar Class
DesignerToolBar Members
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
DesignerToolBar..::.Dispose Method (Boolean)
DesignerToolBar Class See Also Send Feedback
Clean up any resources being used.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

DesignerToolBar Class
Dispose Overload
PerpetuumSoft.Reporting.Designer Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar..::.GetChildAtPoint Method
DesignerToolBar Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DesignerToolBar Class
DesignerToolBar Members
PerpetuumSoft.Reporting.Designer Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar..::.Invalidate Method
DesignerToolBar Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DesignerToolBar Class
DesignerToolBar Members
PerpetuumSoft.Reporting.Designer Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar..::.Invoke Method
DesignerToolBar Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DesignerToolBar Class
DesignerToolBar Members
PerpetuumSoft.Reporting.Designer Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar..::.MemberwiseClone Method
DesignerToolBar Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DesignerToolBar Class
DesignerToolBar Members
PerpetuumSoft.Reporting.Designer Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar..::.PerformLayout Method
DesignerToolBar Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DesignerToolBar Class
DesignerToolBar Members
PerpetuumSoft.Reporting.Designer Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar..::.ResumeLayout Method
DesignerToolBar Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DesignerToolBar Class
DesignerToolBar Members
PerpetuumSoft.Reporting.Designer Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar..::.RtlTranslateAlignment Method
DesignerToolBar Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DesignerToolBar Class
DesignerToolBar Members
PerpetuumSoft.Reporting.Designer Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar..::.Scale Method
DesignerToolBar Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DesignerToolBar Class
DesignerToolBar Members
PerpetuumSoft.Reporting.Designer Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar..::.Select Method
DesignerToolBar Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

DesignerToolBar Class
DesignerToolBar Members
PerpetuumSoft.Reporting.Designer Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar..::.SetBounds Method
DesignerToolBar Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DesignerToolBar Class
DesignerToolBar Members
PerpetuumSoft.Reporting.Designer Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar..::.UpdateBounds Method
DesignerToolBar Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DesignerToolBar Class
DesignerToolBar Members
PerpetuumSoft.Reporting.Designer Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar..::.Validate Method
DesignerToolBar Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DesignerToolBar Class
DesignerToolBar Members
PerpetuumSoft.Reporting.Designer Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar..::.ValidateChildren Method
DesignerToolBar Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

DesignerToolBar Class
DesignerToolBar Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolBar Properties

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar Properties
DesignerToolBar Class See Also Send Feedback

The DesignerToolBar type exposes the following members.

Properties

Name | Description
About | Gets the copyright string. (Inherited from DesignerToolControl.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
Designer | Gets and sets associated ReportDesigner. (Inherited from DesignerToolControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

DesignerToolBar Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolBar Events

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBar Events
DesignerToolBar Class See Also Send Feedback

The DesignerToolBar type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerToolBar Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolBox Class

[image]

.NET ModelKit Suite ClassReference
DesignerToolBox Class
Members See Also Send Feedback
Contains ToolBox for ReportDesigner.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DesignerToolBox : DesignerToolControl
Visual Basic (Declaration)
Public Class DesignerToolBox _
    Inherits DesignerToolControl
Visual C++
public ref class DesignerToolBox : public DesignerToolControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Reporting.Designer..::.DesignerToolControl
PerpetuumSoft.Reporting.Designer..::.DesignerToolBox

See Also

DesignerToolBox Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolBox Members

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox Members
DesignerToolBox Class Constructors Methods Properties Events See Also Send Feedback

The DesignerToolBox type exposes the following members.

Constructors

Name | Description
DesignerToolBox | Creates new instance of DesignerToolBox control.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BindControl | Binds control to designer's action. (Inherited from DesignerToolControl.)
BindControls | Performs actual controls binding. (Inherited from DesignerToolControl.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalBindControls | Runs controls binding. (Inherited from DesignerToolControl.)
InternalUnbindControls | Runs controls unbind operations. (Inherited from DesignerToolControl.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStatusText | Updates text in status bar. (Inherited from DesignerToolControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UnbindControls | Performs actual unbind operations. (Inherited from DesignerToolControl.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTool | Updates Tool state. (Overrides DesignerToolControl..::.UpdateTool(DesignerToolArgs).)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
About | Gets the copyright string. (Inherited from DesignerToolControl.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
Designer | Gets and sets associated ReportDesigner. (Inherited from DesignerToolControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerToolBox Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolBox Constructor

[image]

.NET ModelKit Suite ClassReference
DesignerToolBox Constructor
DesignerToolBox Class See Also Send Feedback
Creates new instance of DesignerToolBox control.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DesignerToolBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DesignerToolBox()

See Also

DesignerToolBox Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolBox Methods

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox Methods
DesignerToolBox Class See Also Send Feedback

The DesignerToolBox type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BindControl | Binds control to designer's action. (Inherited from DesignerToolControl.)
BindControls | Performs actual controls binding. (Inherited from DesignerToolControl.)
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalBindControls | Runs controls binding. (Inherited from DesignerToolControl.)
InternalUnbindControls | Runs controls unbind operations. (Inherited from DesignerToolControl.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStatusText | Updates text in status bar. (Inherited from DesignerToolControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UnbindControls | Performs actual unbind operations. (Inherited from DesignerToolControl.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTool | Updates Tool state. (Overrides DesignerToolControl..::.UpdateTool(DesignerToolArgs).)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

DesignerToolBox Class
PerpetuumSoft.Reporting.Designer Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox..::.AccessibilityNotifyClients Method
DesignerToolBox Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DesignerToolBox Class
DesignerToolBox Members
PerpetuumSoft.Reporting.Designer Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox..::.BeginInvoke Method
DesignerToolBox Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DesignerToolBox Class
DesignerToolBox Members
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox..::.Dispose Method
DesignerToolBox Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides DesignerToolControl..::.Dispose(Boolean).)

See Also

DesignerToolBox Class
DesignerToolBox Members
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
DesignerToolBox..::.Dispose Method (Boolean)
DesignerToolBox Class See Also Send Feedback
Clean up any resources being used.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

DesignerToolBox Class
Dispose Overload
PerpetuumSoft.Reporting.Designer Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox..::.GetChildAtPoint Method
DesignerToolBox Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DesignerToolBox Class
DesignerToolBox Members
PerpetuumSoft.Reporting.Designer Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox..::.Invalidate Method
DesignerToolBox Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DesignerToolBox Class
DesignerToolBox Members
PerpetuumSoft.Reporting.Designer Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox..::.Invoke Method
DesignerToolBox Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DesignerToolBox Class
DesignerToolBox Members
PerpetuumSoft.Reporting.Designer Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox..::.MemberwiseClone Method
DesignerToolBox Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DesignerToolBox Class
DesignerToolBox Members
PerpetuumSoft.Reporting.Designer Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox..::.PerformLayout Method
DesignerToolBox Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DesignerToolBox Class
DesignerToolBox Members
PerpetuumSoft.Reporting.Designer Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox..::.ResumeLayout Method
DesignerToolBox Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DesignerToolBox Class
DesignerToolBox Members
PerpetuumSoft.Reporting.Designer Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox..::.RtlTranslateAlignment Method
DesignerToolBox Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DesignerToolBox Class
DesignerToolBox Members
PerpetuumSoft.Reporting.Designer Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox..::.Scale Method
DesignerToolBox Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DesignerToolBox Class
DesignerToolBox Members
PerpetuumSoft.Reporting.Designer Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox..::.Select Method
DesignerToolBox Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

DesignerToolBox Class
DesignerToolBox Members
PerpetuumSoft.Reporting.Designer Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox..::.SetBounds Method
DesignerToolBox Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DesignerToolBox Class
DesignerToolBox Members
PerpetuumSoft.Reporting.Designer Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox..::.UpdateBounds Method
DesignerToolBox Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DesignerToolBox Class
DesignerToolBox Members
PerpetuumSoft.Reporting.Designer Namespace


UpdateTool Method

[image]

.NET ModelKit Suite ClassReference
DesignerToolBox..::.UpdateTool Method
DesignerToolBox Class See Also Send Feedback
Updates Tool state.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void UpdateTool(
    DesignerToolArgs args
)
Visual Basic (Declaration)
Public Overrides Sub UpdateTool ( _
    args As DesignerToolArgs _
)
Visual C++
public:
virtual void UpdateTool(
    DesignerToolArgs^ args
) override

Parameters

args
Type: PerpetuumSoft.Reporting.Designer..::.DesignerToolArgs

Implements

IDesignerTool..::.UpdateTool(DesignerToolArgs)

See Also

DesignerToolBox Class
PerpetuumSoft.Reporting.Designer Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox..::.Validate Method
DesignerToolBox Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DesignerToolBox Class
DesignerToolBox Members
PerpetuumSoft.Reporting.Designer Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox..::.ValidateChildren Method
DesignerToolBox Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

DesignerToolBox Class
DesignerToolBox Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolBox Properties

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox Properties
DesignerToolBox Class See Also Send Feedback

The DesignerToolBox type exposes the following members.

Properties

Name | Description
About | Gets the copyright string. (Inherited from DesignerToolControl.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
Designer | Gets and sets associated ReportDesigner. (Inherited from DesignerToolControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

DesignerToolBox Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolBox Events

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolBox Events
DesignerToolBox Class See Also Send Feedback

The DesignerToolBox type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerToolBox Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolControl Class

[image]

.NET ModelKit Suite ClassReference
DesignerToolControl Class
Members See Also Send Feedback
Base class for all ReportDesigner tools.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DesignerToolControl : UserControl,
    IDesignerTool
Visual Basic (Declaration)
Public Class DesignerToolControl _
    Inherits UserControl _
    Implements IDesignerTool
Visual C++
public ref class DesignerToolControl : public UserControl,
    IDesignerTool

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Reporting.Designer..::.DesignerToolControl
PerpetuumSoft.Reporting.Designer..::.DesignerDataSourcesTree
PerpetuumSoft.Reporting.Designer..::.DesignerDocumentTree
PerpetuumSoft.Reporting.Designer..::.DesignerErrorList
PerpetuumSoft.Reporting.Designer..::.DesignerPropertyGrid
PerpetuumSoft.Reporting.Designer..::.DesignerStatusBar
PerpetuumSoft.Reporting.Designer..::.DesignerToolBar
PerpetuumSoft.Reporting.Designer..::.DesignerToolBox

See Also

DesignerToolControl Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolControl Members

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl Members
DesignerToolControl Class Constructors Methods Properties Events See Also Send Feedback

The DesignerToolControl type exposes the following members.

Constructors

Name | Description
DesignerToolControl | Creates new instance of DesignerToolControl.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BindControl | Binds control to designer's action.
BindControls | Performs actual controls binding.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalBindControls | Runs controls binding.
InternalUnbindControls | Runs controls unbind operations.
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStatusText | Updates text in status bar.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UnbindControls | Performs actual unbind operations.
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTool | Updates Tool state.
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
About | Gets the copyright string.
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
Designer | Gets and sets associated ReportDesigner.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerToolControl Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolControl Constructor

[image]

.NET ModelKit Suite ClassReference
DesignerToolControl Constructor
DesignerToolControl Class See Also Send Feedback
Creates new instance of DesignerToolControl.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DesignerToolControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DesignerToolControl()

See Also

DesignerToolControl Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolControl Methods

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl Methods
DesignerToolControl Class See Also Send Feedback

The DesignerToolControl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BindControl | Binds control to designer's action.
BindControls | Performs actual controls binding.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InternalBindControls | Runs controls binding.
InternalUnbindControls | Runs controls unbind operations.
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStatusText | Updates text in status bar.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UnbindControls | Performs actual unbind operations.
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTool | Updates Tool state.
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

DesignerToolControl Class
PerpetuumSoft.Reporting.Designer Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.AccessibilityNotifyClients Method
DesignerToolControl Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DesignerToolControl Class
DesignerToolControl Members
PerpetuumSoft.Reporting.Designer Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.BeginInvoke Method
DesignerToolControl Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DesignerToolControl Class
DesignerToolControl Members
PerpetuumSoft.Reporting.Designer Namespace


BindControl Method

[image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.BindControl Method
DesignerToolControl Class See Also Send Feedback
Binds control to designer's action.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected void BindControl(
    string actionName,
    Object control
)
Visual Basic (Declaration)
Protected Sub BindControl ( _
    actionName As String, _
    control As Object _
)
Visual C++
protected:
void BindControl(
    String^ actionName,
    Object^ control
)

Parameters

actionName
Type: System..::.String
control
Type: System..::.Object

See Also

DesignerToolControl Class
PerpetuumSoft.Reporting.Designer Namespace


BindControls Method

[image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.BindControls Method
DesignerToolControl Class See Also Send Feedback
Performs actual controls binding.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void BindControls()
Visual Basic (Declaration)
Protected Overridable Sub BindControls
Visual C++
protected:
virtual void BindControls()

See Also

DesignerToolControl Class
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.Dispose Method
DesignerToolControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl..::.Dispose(Boolean).)

See Also

DesignerToolControl Class
DesignerToolControl Members
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.Dispose Method (Boolean)
DesignerToolControl Class See Also Send Feedback
Clean up any resources being used.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

DesignerToolControl Class
Dispose Overload
PerpetuumSoft.Reporting.Designer Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.GetChildAtPoint Method
DesignerToolControl Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DesignerToolControl Class
DesignerToolControl Members
PerpetuumSoft.Reporting.Designer Namespace


InternalBindControls Method

[image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.InternalBindControls Method
DesignerToolControl Class See Also Send Feedback
Runs controls binding.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected void InternalBindControls()
Visual Basic (Declaration)
Protected Sub InternalBindControls
Visual C++
protected:
void InternalBindControls()

See Also

DesignerToolControl Class
PerpetuumSoft.Reporting.Designer Namespace


InternalUnbindControls Method

[image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.InternalUnbindControls Method
DesignerToolControl Class See Also Send Feedback
Runs controls unbind operations.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected void InternalUnbindControls()
Visual Basic (Declaration)
Protected Sub InternalUnbindControls
Visual C++
protected:
void InternalUnbindControls()

See Also

DesignerToolControl Class
PerpetuumSoft.Reporting.Designer Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.Invalidate Method
DesignerToolControl Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DesignerToolControl Class
DesignerToolControl Members
PerpetuumSoft.Reporting.Designer Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.Invoke Method
DesignerToolControl Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DesignerToolControl Class
DesignerToolControl Members
PerpetuumSoft.Reporting.Designer Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.MemberwiseClone Method
DesignerToolControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DesignerToolControl Class
DesignerToolControl Members
PerpetuumSoft.Reporting.Designer Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.PerformLayout Method
DesignerToolControl Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DesignerToolControl Class
DesignerToolControl Members
PerpetuumSoft.Reporting.Designer Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.ResumeLayout Method
DesignerToolControl Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DesignerToolControl Class
DesignerToolControl Members
PerpetuumSoft.Reporting.Designer Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.RtlTranslateAlignment Method
DesignerToolControl Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DesignerToolControl Class
DesignerToolControl Members
PerpetuumSoft.Reporting.Designer Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.Scale Method
DesignerToolControl Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

DesignerToolControl Class
DesignerToolControl Members
PerpetuumSoft.Reporting.Designer Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.Select Method
DesignerToolControl Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

DesignerToolControl Class
DesignerToolControl Members
PerpetuumSoft.Reporting.Designer Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.SetBounds Method
DesignerToolControl Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DesignerToolControl Class
DesignerToolControl Members
PerpetuumSoft.Reporting.Designer Namespace


SetStatusText Method

[image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.SetStatusText Method
DesignerToolControl Class See Also Send Feedback
Updates text in status bar.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual void SetStatusText(
    string text
)
Visual Basic (Declaration)
Public Overridable Sub SetStatusText ( _
    text As String _
)
Visual C++
public:
virtual void SetStatusText(
    String^ text
)

Parameters

text
Type: System..::.String

Implements

IDesignerTool..::.SetStatusText(String)

See Also

DesignerToolControl Class
PerpetuumSoft.Reporting.Designer Namespace


UnbindControls Method

[image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.UnbindControls Method
DesignerToolControl Class See Also Send Feedback
Performs actual unbind operations.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void UnbindControls()
Visual Basic (Declaration)
Protected Overridable Sub UnbindControls
Visual C++
protected:
virtual void UnbindControls()

See Also

DesignerToolControl Class
PerpetuumSoft.Reporting.Designer Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.UpdateBounds Method
DesignerToolControl Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DesignerToolControl Class
DesignerToolControl Members
PerpetuumSoft.Reporting.Designer Namespace


UpdateTool Method

[image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.UpdateTool Method
DesignerToolControl Class See Also Send Feedback
Updates Tool state.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual void UpdateTool(
    DesignerToolArgs args
)
Visual Basic (Declaration)
Public Overridable Sub UpdateTool ( _
    args As DesignerToolArgs _
)
Visual C++
public:
virtual void UpdateTool(
    DesignerToolArgs^ args
)

Parameters

args
Type: PerpetuumSoft.Reporting.Designer..::.DesignerToolArgs

Implements

IDesignerTool..::.UpdateTool(DesignerToolArgs)

See Also

DesignerToolControl Class
PerpetuumSoft.Reporting.Designer Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.Validate Method
DesignerToolControl Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DesignerToolControl Class
DesignerToolControl Members
PerpetuumSoft.Reporting.Designer Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.ValidateChildren Method
DesignerToolControl Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

DesignerToolControl Class
DesignerToolControl Members
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolControl Properties

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl Properties
DesignerToolControl Class See Also Send Feedback

The DesignerToolControl type exposes the following members.

Properties

Name | Description
About | Gets the copyright string.
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
Designer | Gets and sets associated ReportDesigner.
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

DesignerToolControl Class
PerpetuumSoft.Reporting.Designer Namespace


About Property

[image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.About Property
DesignerToolControl Class See Also Send Feedback
Gets the copyright string.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string About { get; }
Visual Basic (Declaration)
Public ReadOnly Property About As String
Visual C++
public:
property String^ About {
    String^ get ();
}

See Also

DesignerToolControl Class
PerpetuumSoft.Reporting.Designer Namespace


Designer Property

[image]

.NET ModelKit Suite ClassReference
DesignerToolControl..::.Designer Property
DesignerToolControl Class See Also Send Feedback
Gets and sets associated ReportDesigner.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual ReportDesigner Designer { get; set; }
Visual Basic (Declaration)
Public Overridable Property Designer As ReportDesigner
Visual C++
public:
virtual property ReportDesigner^ Designer {
    ReportDesigner^ get ();
    void set (ReportDesigner^ value);
}

See Also

DesignerToolControl Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerToolControl Events

[image] [image]

.NET ModelKit Suite ClassReference
DesignerToolControl Events
DesignerToolControl Class See Also Send Feedback

The DesignerToolControl type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DesignerToolControl Class
PerpetuumSoft.Reporting.Designer Namespace


ElementAddedEventArgs Class

[image]

.NET ModelKit Suite ClassReference
ElementAddedEventArgs Class
Members See Also Send Feedback
Provides data for the ElementAdding event.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ElementAddedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ElementAddedEventArgs _
    Inherits EventArgs
Visual C++
public ref class ElementAddedEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.Designer..::.ElementAddedEventArgs
PerpetuumSoft.Reporting.Designer..::.ElementAddingEventArgs

See Also

ElementAddedEventArgs Members
PerpetuumSoft.Reporting.Designer Namespace


ElementAddedEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
ElementAddedEventArgs Members
ElementAddedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ElementAddedEventArgs type exposes the following members.

Constructors

Name | Description
ElementAddedEventArgs | Initializes a new instance of the ElementAddedEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Control | Gets added control.

See Also

ElementAddedEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


ElementAddedEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
ElementAddedEventArgs Constructor
ElementAddedEventArgs Class See Also Send Feedback
Initializes a new instance of the ElementAddedEventArgs class.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ElementAddedEventArgs(
    ReportControl control
)
Visual Basic (Declaration)
Public Sub New ( _
    control As ReportControl _
)
Visual C++
public:
ElementAddedEventArgs(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ElementAddedEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


ElementAddedEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
ElementAddedEventArgs Methods
ElementAddedEventArgs Class See Also Send Feedback

The ElementAddedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementAddedEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


ElementAddedEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
ElementAddedEventArgs Properties
ElementAddedEventArgs Class See Also Send Feedback

The ElementAddedEventArgs type exposes the following members.

Properties

Name | Description
Control | Gets added control.

See Also

ElementAddedEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


Control Property

[image]

.NET ModelKit Suite ClassReference
ElementAddedEventArgs..::.Control Property
ElementAddedEventArgs Class See Also Send Feedback
Gets added control.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportControl Control { get; }
Visual Basic (Declaration)
Public ReadOnly Property Control As ReportControl
Visual C++
public:
property ReportControl^ Control {
    ReportControl^ get ();
}

See Also

ElementAddedEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


ElementAddedEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
ElementAddedEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the ElementAdded event.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate void ElementAddedEventHandler(
    Object sender,
    ElementAddedEventArgs args
)
Visual Basic (Declaration)
Public Delegate Sub ElementAddedEventHandler ( _
    sender As Object, _
    args As ElementAddedEventArgs _
)
Visual C++
public delegate void ElementAddedEventHandler(
    Object^ sender,
    ElementAddedEventArgs^ args
)

Parameters

sender
Type: System..::.Object
args
Type: PerpetuumSoft.Reporting.Designer..::.ElementAddedEventArgs

See Also

PerpetuumSoft.Reporting.Designer Namespace


ElementAddingEventArgs Class

[image]

.NET ModelKit Suite ClassReference
ElementAddingEventArgs Class
Members See Also Send Feedback
Provides data for the ElementAdded event.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ElementAddingEventArgs : ElementAddedEventArgs
Visual Basic (Declaration)
Public Class ElementAddingEventArgs _
    Inherits ElementAddedEventArgs
Visual C++
public ref class ElementAddingEventArgs : public ElementAddedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.Designer..::.ElementAddedEventArgs
PerpetuumSoft.Reporting.Designer..::.ElementAddingEventArgs

See Also

ElementAddingEventArgs Members
PerpetuumSoft.Reporting.Designer Namespace


ElementAddingEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
ElementAddingEventArgs Members
ElementAddingEventArgs Class Constructors Methods Properties See Also Send Feedback

The ElementAddingEventArgs type exposes the following members.

Constructors

Name | Description
ElementAddingEventArgs | Initializes a new instance of the ElementAddingEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Control | Gets added control. (Inherited from ElementAddedEventArgs.)
Handled | Gets or sets a value indicating whether the event should be handled.

See Also

ElementAddingEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


ElementAddingEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
ElementAddingEventArgs Constructor
ElementAddingEventArgs Class See Also Send Feedback
Initializes a new instance of the ElementAddingEventArgs class.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ElementAddingEventArgs(
    ReportControl control
)
Visual Basic (Declaration)
Public Sub New ( _
    control As ReportControl _
)
Visual C++
public:
ElementAddingEventArgs(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ElementAddingEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


ElementAddingEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
ElementAddingEventArgs Methods
ElementAddingEventArgs Class See Also Send Feedback

The ElementAddingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementAddingEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


ElementAddingEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
ElementAddingEventArgs Properties
ElementAddingEventArgs Class See Also Send Feedback

The ElementAddingEventArgs type exposes the following members.

Properties

Name | Description
Control | Gets added control. (Inherited from ElementAddedEventArgs.)
Handled | Gets or sets a value indicating whether the event should be handled.

See Also

ElementAddingEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


Handled Property

[image]

.NET ModelKit Suite ClassReference
ElementAddingEventArgs..::.Handled Property
ElementAddingEventArgs Class See Also Send Feedback
Gets or sets a value indicating whether the event should be handled.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Handled { get; set; }
Visual Basic (Declaration)
Public Property Handled As Boolean
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

See Also

ElementAddingEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


ElementAddingEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
ElementAddingEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the ElementAdding event.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate void ElementAddingEventHandler(
    Object sender,
    ElementAddingEventArgs args
)
Visual Basic (Declaration)
Public Delegate Sub ElementAddingEventHandler ( _
    sender As Object, _
    args As ElementAddingEventArgs _
)
Visual C++
public delegate void ElementAddingEventHandler(
    Object^ sender,
    ElementAddingEventArgs^ args
)

Parameters

sender
Type: System..::.Object
args
Type: PerpetuumSoft.Reporting.Designer..::.ElementAddingEventArgs

See Also

PerpetuumSoft.Reporting.Designer Namespace


IDesignerTool Interface

[image]

.NET ModelKit Suite ClassReference
IDesignerTool Interface
Members See Also Send Feedback
Common interface for all ReportDesigner tools.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public interface IDesignerTool
Visual Basic (Declaration)
Public Interface IDesignerTool
Visual C++
public interface class IDesignerTool

See Also

IDesignerTool Members
PerpetuumSoft.Reporting.Designer Namespace


IDesignerTool Members

[image] [image]

.NET ModelKit Suite ClassReference
IDesignerTool Members
IDesignerTool Interface Methods See Also Send Feedback

The IDesignerTool type exposes the following members.

Methods

Name | Description
SetStatusText | Updates text in StatusBar.
UpdateTool | Updates Tool state.

See Also

IDesignerTool Interface
PerpetuumSoft.Reporting.Designer Namespace


IDesignerTool Methods

[image] [image]

.NET ModelKit Suite ClassReference
IDesignerTool Methods
IDesignerTool Interface See Also Send Feedback

The IDesignerTool type exposes the following members.

Methods

Name | Description
SetStatusText | Updates text in StatusBar.
UpdateTool | Updates Tool state.

See Also

IDesignerTool Interface
PerpetuumSoft.Reporting.Designer Namespace


SetStatusText Method

[image]

.NET ModelKit Suite ClassReference
IDesignerTool..::.SetStatusText Method
IDesignerTool Interface See Also Send Feedback
Updates text in StatusBar.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void SetStatusText(
    string text
)
Visual Basic (Declaration)
Sub SetStatusText ( _
    text As String _
)
Visual C++
void SetStatusText(
    String^ text
)

Parameters

text
Type: System..::.String

See Also

IDesignerTool Interface
PerpetuumSoft.Reporting.Designer Namespace


UpdateTool Method

[image]

.NET ModelKit Suite ClassReference
IDesignerTool..::.UpdateTool Method
IDesignerTool Interface See Also Send Feedback
Updates Tool state.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void UpdateTool(
    DesignerToolArgs arg
)
Visual Basic (Declaration)
Sub UpdateTool ( _
    arg As DesignerToolArgs _
)
Visual C++
void UpdateTool(
    DesignerToolArgs^ arg
)

Parameters

arg
Type: PerpetuumSoft.Reporting.Designer..::.DesignerToolArgs

See Also

IDesignerTool Interface
PerpetuumSoft.Reporting.Designer Namespace


IDesignerToolCollection Class

[image]

.NET ModelKit Suite ClassReference
IDesignerToolCollection Class
Members See Also Send Feedback
Represents the collection of IDesignerTool objects.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class IDesignerToolCollection : CollectionBase
Visual Basic (Declaration)
Public Class IDesignerToolCollection _
    Inherits CollectionBase
Visual C++
public ref class IDesignerToolCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Reporting.Designer..::.IDesignerToolCollection

See Also

IDesignerToolCollection Members
PerpetuumSoft.Reporting.Designer Namespace


IDesignerToolCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
IDesignerToolCollection Members
IDesignerToolCollection Class Constructors Methods Properties See Also Send Feedback

The IDesignerToolCollection type exposes the following members.

Constructors

Name | Description
IDesignerToolCollection | Creates a new instance of IDesignerToolCollection class.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the object already exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified object's index in the collection.
Insert | Inserts the specified object to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified IDesignerTool from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets the object at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

IDesignerToolCollection Class
PerpetuumSoft.Reporting.Designer Namespace


IDesignerToolCollection Constructor

[image]

.NET ModelKit Suite ClassReference
IDesignerToolCollection Constructor
IDesignerToolCollection Class See Also Send Feedback
Creates a new instance of IDesignerToolCollection class.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public IDesignerToolCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IDesignerToolCollection()

See Also

IDesignerToolCollection Class
PerpetuumSoft.Reporting.Designer Namespace


IDesignerToolCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
IDesignerToolCollection Methods
IDesignerToolCollection Class See Also Send Feedback

The IDesignerToolCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the object already exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified object's index in the collection.
Insert | Inserts the specified object to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified IDesignerTool from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IDesignerToolCollection Class
PerpetuumSoft.Reporting.Designer Namespace


Add Method

[image] [image]

.NET ModelKit Suite ClassReference
IDesignerToolCollection..::.Add Method
IDesignerToolCollection Class See Also Send Feedback

Overload List

Name | Description
Add(IDesignerTool) | Adds the specified IDesignerTool to the end of the collection.
Add(array<IDesignerTool>[]()[]) | Adds the specified array IDesignerTool objects to the end of the collection.

See Also

IDesignerToolCollection Class
IDesignerToolCollection Members
PerpetuumSoft.Reporting.Designer Namespace


Add Method (IDesignerTool)

[image]

.NET ModelKit Suite ClassReference
IDesignerToolCollection..::.Add Method (IDesignerTool)
IDesignerToolCollection Class See Also Send Feedback
Adds the specified IDesignerTool to the end of the collection.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public IDesignerTool Add(
    IDesignerTool value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As IDesignerTool _
) As IDesignerTool
Visual C++
public:
IDesignerTool^ Add(
    IDesignerTool^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Designer..::.IDesignerTool

See Also

IDesignerToolCollection Class
Add Overload
PerpetuumSoft.Reporting.Designer Namespace


Add Method (IDesignerTool[])

[image]

.NET ModelKit Suite ClassReference
IDesignerToolCollection..::.Add Method (array<IDesignerTool>[]()[])
IDesignerToolCollection Class See Also Send Feedback
Adds the specified array IDesignerTool objects to the end of the collection.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Add(
    IDesignerTool[] values
)
Visual Basic (Declaration)
Public Sub Add ( _
    values As IDesignerTool() _
)
Visual C++
public:
void Add(
    array<IDesignerTool^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Reporting.Designer..::.IDesignerTool >[]()[]

See Also

IDesignerToolCollection Class
Add Overload
PerpetuumSoft.Reporting.Designer Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
IDesignerToolCollection..::.Contains Method
IDesignerToolCollection Class See Also Send Feedback
Returns whether the object already exists in the collection.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    IDesignerTool value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As IDesignerTool _
) As Boolean
Visual C++
public:
bool Contains(
    IDesignerTool^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Designer..::.IDesignerTool

See Also

IDesignerToolCollection Class
PerpetuumSoft.Reporting.Designer Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
IDesignerToolCollection..::.IndexOf Method
IDesignerToolCollection Class See Also Send Feedback
Returns the specified object's index in the collection.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    IDesignerTool value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As IDesignerTool _
) As Integer
Visual C++
public:
int IndexOf(
    IDesignerTool^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Designer..::.IDesignerTool

See Also

IDesignerToolCollection Class
PerpetuumSoft.Reporting.Designer Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
IDesignerToolCollection..::.Insert Method
IDesignerToolCollection Class See Also Send Feedback
Inserts the specified object to the collection at the specified index.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    IDesignerTool value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As IDesignerTool _
)
Visual C++
public:
void Insert(
    int index,
    IDesignerTool^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Reporting.Designer..::.IDesignerTool

See Also

IDesignerToolCollection Class
PerpetuumSoft.Reporting.Designer Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
IDesignerToolCollection..::.Remove Method
IDesignerToolCollection Class See Also Send Feedback
Removes the specified IDesignerTool from the collection.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    IDesignerTool value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As IDesignerTool _
)
Visual C++
public:
void Remove(
    IDesignerTool^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Designer..::.IDesignerTool

See Also

IDesignerToolCollection Class
PerpetuumSoft.Reporting.Designer Namespace


IDesignerToolCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
IDesignerToolCollection Properties
IDesignerToolCollection Class See Also Send Feedback

The IDesignerToolCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets the object at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

IDesignerToolCollection Class
PerpetuumSoft.Reporting.Designer Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
IDesignerToolCollection..::.Item Property
IDesignerToolCollection Class See Also Send Feedback
Gets the object at the specified index.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public IDesignerTool this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As IDesignerTool
Visual C++
public:
property IDesignerTool^ default[int index] {
    IDesignerTool^ get (int index);
    void set (int index, IDesignerTool^ value);
}

Parameters

index
Type: System..::.Int32

See Also

IDesignerToolCollection Class
PerpetuumSoft.Reporting.Designer Namespace


IReportDesignerService Interface

[image]

.NET ModelKit Suite ClassReference
IReportDesignerService Interface
Members See Also Send Feedback
Provides common interface for access to the report designer environment.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public interface IReportDesignerService : IServiceProvider
Visual Basic (Declaration)
Public Interface IReportDesignerService _
    Implements IServiceProvider
Visual C++
public interface class IReportDesignerService : IServiceProvider

See Also

IReportDesignerService Members
PerpetuumSoft.Reporting.Designer Namespace


IReportDesignerService Members

[image] [image]

.NET ModelKit Suite ClassReference
IReportDesignerService Members
IReportDesignerService Interface Methods Properties See Also Send Feedback

The IReportDesignerService type exposes the following members.

Methods

Name | Description
AddCommand | Add command in command stack.
GetService | Gets the service object of the specified type. (Inherited from IServiceProvider.)
ObjectBindingChanged | Handles binding's changes.
ObjectPropertyChanged | Handles property changes.

Properties

Name | Description
CurrentPage | Gets the Page that is currently edited.
DataSourceManager | Gets a DataObject collection associated with the current design session.
Document | Gets the document that is currently edited.
ReportControl | Gets the ReportControl that is currently edited.
ReportSource | Gets report source.

See Also

IReportDesignerService Interface
PerpetuumSoft.Reporting.Designer Namespace


IReportDesignerService Methods

[image] [image]

.NET ModelKit Suite ClassReference
IReportDesignerService Methods
IReportDesignerService Interface See Also Send Feedback

The IReportDesignerService type exposes the following members.

Methods

Name | Description
AddCommand | Add command in command stack.
GetService | Gets the service object of the specified type. (Inherited from IServiceProvider.)
ObjectBindingChanged | Handles binding's changes.
ObjectPropertyChanged | Handles property changes.

See Also

IReportDesignerService Interface
PerpetuumSoft.Reporting.Designer Namespace


AddCommand Method

[image]

.NET ModelKit Suite ClassReference
IReportDesignerService..::.AddCommand Method
IReportDesignerService Interface See Also Send Feedback
Add command in command stack.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void AddCommand(
    Command command
)
Visual Basic (Declaration)
Sub AddCommand ( _
    command As Command _
)
Visual C++
void AddCommand(
    Command^ command
)

Parameters

command
Type: PerpetuumSoft.Reporting.CommandModel..::.Command

See Also

IReportDesignerService Interface
PerpetuumSoft.Reporting.Designer Namespace


ObjectBindingChanged Method

[image]

.NET ModelKit Suite ClassReference
IReportDesignerService..::.ObjectBindingChanged Method
IReportDesignerService Interface See Also Send Feedback
Handles binding's changes.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void ObjectBindingChanged(
    Object component,
    string name,
    string oldValue,
    string newValue
)
Visual Basic (Declaration)
Sub ObjectBindingChanged ( _
    component As Object, _
    name As String, _
    oldValue As String, _
    newValue As String _
)
Visual C++
void ObjectBindingChanged(
    Object^ component,
    String^ name,
    String^ oldValue,
    String^ newValue
)

Parameters

component
Type: System..::.Object
name
Type: System..::.String
oldValue
Type: System..::.String
newValue
Type: System..::.String

See Also

IReportDesignerService Interface
PerpetuumSoft.Reporting.Designer Namespace


ObjectPropertyChanged Method

[image]

.NET ModelKit Suite ClassReference
IReportDesignerService..::.ObjectPropertyChanged Method
IReportDesignerService Interface See Also Send Feedback
Handles property changes.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void ObjectPropertyChanged(
    Object component,
    string name,
    Object oldValue,
    Object newValue
)
Visual Basic (Declaration)
Sub ObjectPropertyChanged ( _
    component As Object, _
    name As String, _
    oldValue As Object, _
    newValue As Object _
)
Visual C++
void ObjectPropertyChanged(
    Object^ component,
    String^ name,
    Object^ oldValue,
    Object^ newValue
)

Parameters

component
Type: System..::.Object
name
Type: System..::.String
oldValue
Type: System..::.Object
newValue
Type: System..::.Object

See Also

IReportDesignerService Interface
PerpetuumSoft.Reporting.Designer Namespace


IReportDesignerService Properties

[image] [image]

.NET ModelKit Suite ClassReference
IReportDesignerService Properties
IReportDesignerService Interface See Also Send Feedback

The IReportDesignerService type exposes the following members.

Properties

Name | Description
CurrentPage | Gets the Page that is currently edited.
DataSourceManager | Gets a DataObject collection associated with the current design session.
Document | Gets the document that is currently edited.
ReportControl | Gets the ReportControl that is currently edited.
ReportSource | Gets report source.

See Also

IReportDesignerService Interface
PerpetuumSoft.Reporting.Designer Namespace


CurrentPage Property

[image]

.NET ModelKit Suite ClassReference
IReportDesignerService..::.CurrentPage Property
IReportDesignerService Interface See Also Send Feedback
Gets the Page that is currently edited.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
Page CurrentPage { get; }
Visual Basic (Declaration)
ReadOnly Property CurrentPage As Page
Visual C++
property Page^ CurrentPage {
    Page^ get ();
}

See Also

IReportDesignerService Interface
PerpetuumSoft.Reporting.Designer Namespace


DataSourceManager Property

[image]

.NET ModelKit Suite ClassReference
IReportDesignerService..::.DataSourceManager Property
IReportDesignerService Interface See Also Send Feedback
Gets a DataObject collection associated with the current design session.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
IDataSourceManager DataSourceManager { get; set; }
Visual Basic (Declaration)
Property DataSourceManager As IDataSourceManager
Visual C++
property IDataSourceManager^ DataSourceManager {
    IDataSourceManager^ get ();
    void set (IDataSourceManager^ value);
}

See Also

IReportDesignerService Interface
PerpetuumSoft.Reporting.Designer Namespace


Document Property

[image]

.NET ModelKit Suite ClassReference
IReportDesignerService..::.Document Property
IReportDesignerService Interface See Also Send Feedback
Gets the document that is currently edited.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
Document Document { get; }
Visual Basic (Declaration)
ReadOnly Property Document As Document
Visual C++
property Document^ Document {
    Document^ get ();
}

See Also

IReportDesignerService Interface
PerpetuumSoft.Reporting.Designer Namespace


ReportControl Property

[image]

.NET ModelKit Suite ClassReference
IReportDesignerService..::.ReportControl Property
IReportDesignerService Interface See Also Send Feedback
Gets the ReportControl that is currently edited.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
ReportControl ReportControl { get; }
Visual Basic (Declaration)
ReadOnly Property ReportControl As ReportControl
Visual C++
property ReportControl^ ReportControl {
    ReportControl^ get ();
}

See Also

IReportDesignerService Interface
PerpetuumSoft.Reporting.Designer Namespace


ReportSource Property

[image]

.NET ModelKit Suite ClassReference
IReportDesignerService..::.ReportSource Property
IReportDesignerService Interface See Also Send Feedback
Gets report source.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
IReportSource ReportSource { get; }
Visual Basic (Declaration)
ReadOnly Property ReportSource As IReportSource
Visual C++
property IReportSource^ ReportSource {
    IReportSource^ get ();
}

See Also

IReportDesignerService Interface
PerpetuumSoft.Reporting.Designer Namespace


ReportClipboard Class

[image]

.NET ModelKit Suite ClassReference
ReportClipboard Class
Members See Also Send Feedback
This type supports the Report Sharp-Shooter infrastructure and is not intended to be used directly from your code.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ReportClipboard
Visual Basic (Declaration)
Public Class ReportClipboard
Visual C++
public ref class ReportClipboard

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Designer..::.ReportClipboard

See Also

ReportClipboard Members
PerpetuumSoft.Reporting.Designer Namespace


ReportClipboard Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportClipboard Members
ReportClipboard Class Constructors Methods Properties See Also Send Feedback

The ReportClipboard type exposes the following members.

Constructors

Name | Description
ReportClipboard | Initializes a new instance of ReportClipboard.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Controls | Gets a controls collection associated with the ReportClipboard.

See Also

ReportClipboard Class
PerpetuumSoft.Reporting.Designer Namespace


ReportClipboard Constructor

[image]

.NET ModelKit Suite ClassReference
ReportClipboard Constructor
ReportClipboard Class See Also Send Feedback
Initializes a new instance of ReportClipboard.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportClipboard()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportClipboard()

See Also

ReportClipboard Class
PerpetuumSoft.Reporting.Designer Namespace


ReportClipboard Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportClipboard Methods
ReportClipboard Class See Also Send Feedback

The ReportClipboard type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportClipboard Class
PerpetuumSoft.Reporting.Designer Namespace


ReportClipboard Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportClipboard Properties
ReportClipboard Class See Also Send Feedback

The ReportClipboard type exposes the following members.

Properties

Name | Description
Controls | Gets a controls collection associated with the ReportClipboard.

See Also

ReportClipboard Class
PerpetuumSoft.Reporting.Designer Namespace


Controls Property

[image]

.NET ModelKit Suite ClassReference
ReportClipboard..::.Controls Property
ReportClipboard Class See Also Send Feedback
Gets a controls collection associated with the ReportClipboard.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportControlCollection Controls { get; }
Visual Basic (Declaration)
Public ReadOnly Property Controls As ReportControlCollection
Visual C++
public:
property ReportControlCollection^ Controls {
    ReportControlCollection^ get ();
}

See Also

ReportClipboard Class
PerpetuumSoft.Reporting.Designer Namespace


ReportDesigner Class

[image]

.NET ModelKit Suite ClassReference
ReportDesigner Class
Members See Also Send Feedback
Report Designer control.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ReportDesigner : UserControl,
    IReportDesignerService, IServiceProvider
Visual Basic (Declaration)
Public Class ReportDesigner _
    Inherits UserControl _
    Implements IReportDesignerService, IServiceProvider
Visual C++
public ref class ReportDesigner : public UserControl,
    IReportDesignerService, IServiceProvider

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Reporting.Designer..::.ReportDesigner

See Also

ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


ReportDesigner Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner Members
ReportDesigner Class Constructors Methods Properties Events See Also Send Feedback

The ReportDesigner type exposes the following members.

Constructors

Name | Description
ReportDesigner | Creates new instance of the ReportDesigner control.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddPage | Adds new page to current document.
AdjustFormScrollbars | (Inherited from ContainerControl.)
AttachDocument | Overloaded.
BeginInvoke | Overloaded.
BringSelectionToFront | Brings selected objects to front.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CanResetSelectionProperty | Indicates if it is possible to reset property value to default for all selected document elements
CheckExistName |
CheckName |
CheckSaveDocument |
CheckScript | Overloaded.
ClearCommandStack | Clears command stack.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DeletePage | Removes current page from document.
DeleteSelectedObjects | Deletes selection.
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetSelectionMergablePropertyBinding | Gets a list of property names the Binding cab be assigned to.
GetSelectionMergablePropertyValue | Overloaded.
GetSelectionPropertyBindingNames | Gets a list of property names the Binding cab be assigned to for all selected document elements
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InsertControl | Allows to insert control given type.
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutBands | Performs bands auto-layout.
MemberwiseClone | Overloaded.
MoveSelectionBack | Moves selected objects to back.
MoveSelectionForward | Moves selected objects forward.
NewDocument | Creates new document.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDesignerMouseDown | Raises the DesignerMouseUp event.
OnDesignerMouseUp | Raises the DesignerMouseDown event.
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnElementAdded | Raises the ElementAdded event.
OnElementAdding | Raises the ElementAdding event.
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Redo | Redo last operation.
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetContextMenu | Resets comtextual menu.
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetSelectionProperty | Resets property value to default for all selected document elements
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveDocument | Saves document to file.
SaveDocumentAs | Shows "Save As..." dialog.
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendSelectionToBack | Sends selected objects to back.
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetContextMenu | Sets a contextual menu in the designer
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetSelectionPropertyBinding | Sets a new property value for all selected document elements
SetSelectionPropertyValue | Overloaded.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowCustomZoomDialog | Shows zoom dialog.
ShowDataSourcesEditor | Invokes the document data sources editor dialog.
ShowGotoPageDialog | Shows pages dialog.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Undo | Undo last operation.
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTools | Updates all attached designer tools.
UpdateView | Overloaded.
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
About | Gets the copyright string.
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Actions | Gets collection of all actions of the ReportDesigner.
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoLayoutBands | Gets and sets if auto-layout mode is enabled.
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
CompilerResults | Gets results of the report scripts compilation CompilerResults
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
CurrentPage | Get currently edited page.
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DataSourceManager | Gets or sets data source manager assigned withy this designer.
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Document | Gets and sets edited document.
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsModified | Gets whether report was modified by user.
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MetricUnitMenu | Gets the contextual menu for assigning measure units ContextMenuStrip
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MouseMode | Gets or sets mouse pointer in the designer DesignerMouseMode
MouseModeContextMenu | Gets the contextual menu for assigning mouse display mode ContextMenuStrip
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
PageNumber | Gets and sets edited page number.
PageTabContextMenu | Gets the contextual menu for assigning page tabs ContextMenuStrip
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Selection | Gets selection.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowRulers | Gets or sets if rulers should be displayed.
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
SubReportsResolver | Gets or sets SubReportResolver.
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Tools | Gets collection of currently registered tools.
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Zoom | Gets and sets zoom for the report designer.
ZoomMenu | Gets the contextual menu for assigning zoom ContextMenuStrip

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DesignerMouseDown | Occurs when the mouse pointer is over the designer and a mouse button is pressed.
DesignerMouseUp | Occurs when the mouse pointer is over the designer and a mouse button is released.
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
ElementAdded | Occurs when a new element is added to a document being edited.
ElementAdding | Occurs when a new element is added to a document being edited.
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
RequestCodeSnippets | Occures to get the code snippets by the specified script language.
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


ReportDesigner Constructor

[image]

.NET ModelKit Suite ClassReference
ReportDesigner Constructor
ReportDesigner Class See Also Send Feedback
Creates new instance of the ReportDesigner control.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportDesigner()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportDesigner()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


ReportDesigner Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner Methods
ReportDesigner Class See Also Send Feedback

The ReportDesigner type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddPage | Adds new page to current document.
AdjustFormScrollbars | (Inherited from ContainerControl.)
AttachDocument | Overloaded.
BeginInvoke | Overloaded.
BringSelectionToFront | Brings selected objects to front.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CanResetSelectionProperty | Indicates if it is possible to reset property value to default for all selected document elements
CheckExistName |
CheckName |
CheckSaveDocument |
CheckScript | Overloaded.
ClearCommandStack | Clears command stack.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DeletePage | Removes current page from document.
DeleteSelectedObjects | Deletes selection.
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetSelectionMergablePropertyBinding | Gets a list of property names the Binding cab be assigned to.
GetSelectionMergablePropertyValue | Overloaded.
GetSelectionPropertyBindingNames | Gets a list of property names the Binding cab be assigned to for all selected document elements
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
InsertControl | Allows to insert control given type.
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutBands | Performs bands auto-layout.
MemberwiseClone | Overloaded.
MoveSelectionBack | Moves selected objects to back.
MoveSelectionForward | Moves selected objects forward.
NewDocument | Creates new document.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDesignerMouseDown | Raises the DesignerMouseUp event.
OnDesignerMouseUp | Raises the DesignerMouseDown event.
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnElementAdded | Raises the ElementAdded event.
OnElementAdding | Raises the ElementAdding event.
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Redo | Redo last operation.
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetContextMenu | Resets comtextual menu.
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetSelectionProperty | Resets property value to default for all selected document elements
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveDocument | Saves document to file.
SaveDocumentAs | Shows "Save As..." dialog.
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendSelectionToBack | Sends selected objects to back.
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetContextMenu | Sets a contextual menu in the designer
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetSelectionPropertyBinding | Sets a new property value for all selected document elements
SetSelectionPropertyValue | Overloaded.
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowCustomZoomDialog | Shows zoom dialog.
ShowDataSourcesEditor | Invokes the document data sources editor dialog.
ShowGotoPageDialog | Shows pages dialog.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Undo | Undo last operation.
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateTools | Updates all attached designer tools.
UpdateView | Overloaded.
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.AccessibilityNotifyClients Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


AddPage Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.AddPage Method
ReportDesigner Class See Also Send Feedback
Adds new page to current document.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void AddPage()
Visual Basic (Declaration)
Public Sub AddPage
Visual C++
public:
void AddPage()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


AttachDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.AttachDocument Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
AttachDocument(ReportSlot, Document) | Assigns document and report slot.
AttachDocument(String, Document) | Assigns document and default path.

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


AttachDocument Method (ReportSlot, Document)

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.AttachDocument Method (ReportSlot, Document)
ReportDesigner Class See Also Send Feedback
Assigns document and report slot.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void AttachDocument(
    ReportSlot slot,
    Document document
)
Visual Basic (Declaration)
Public Sub AttachDocument ( _
    slot As ReportSlot, _
    document As Document _
)
Visual C++
public:
void AttachDocument(
    ReportSlot^ slot,
    Document^ document
)

Parameters

slot
Type: PerpetuumSoft.Reporting.Components..::.ReportSlot
document
Type: PerpetuumSoft.Reporting.DOM..::.Document

See Also

ReportDesigner Class
AttachDocument Overload
PerpetuumSoft.Reporting.Designer Namespace


AttachDocument Method (String, Document)

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.AttachDocument Method (String, Document)
ReportDesigner Class See Also Send Feedback
Assigns document and default path.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void AttachDocument(
    string fileName,
    Document document
)
Visual Basic (Declaration)
Public Sub AttachDocument ( _
    fileName As String, _
    document As Document _
)
Visual C++
public:
void AttachDocument(
    String^ fileName,
    Document^ document
)

Parameters

fileName
Type: System..::.String
document
Type: PerpetuumSoft.Reporting.DOM..::.Document

See Also

ReportDesigner Class
AttachDocument Overload
PerpetuumSoft.Reporting.Designer Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.BeginInvoke Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


BringSelectionToFront Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.BringSelectionToFront Method
ReportDesigner Class See Also Send Feedback
Brings selected objects to front.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void BringSelectionToFront()
Visual Basic (Declaration)
Public Sub BringSelectionToFront
Visual C++
public:
void BringSelectionToFront()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


CanResetSelectionProperty Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.CanResetSelectionProperty Method
ReportDesigner Class See Also Send Feedback
Indicates if it is possible to reset property value to default for all selected document elements

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool CanResetSelectionProperty(
    string propertyName,
    Type propertyType
)
Visual Basic (Declaration)
Public Function CanResetSelectionProperty ( _
    propertyName As String, _
    propertyType As Type _
) As Boolean
Visual C++
public:
bool CanResetSelectionProperty(
    String^ propertyName,
    Type^ propertyType
)

Parameters

propertyName
Type: System..::.String
propertyType
Type: System..::.Type

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


CheckExistName Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.CheckExistName Method
ReportDesigner Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Designer.ReportDesigner.CheckExistName(System.String)]

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool CheckExistName(
    string objectName
)
Visual Basic (Declaration)
Public Function CheckExistName ( _
    objectName As String _
) As Boolean
Visual C++
public:
bool CheckExistName(
    String^ objectName
)

Parameters

objectName
Type: System..::.String

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


CheckName Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.CheckName Method
ReportDesigner Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Designer.ReportDesigner.CheckName(System.String)]

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool CheckName(
    string objectName
)
Visual Basic (Declaration)
Public Function CheckName ( _
    objectName As String _
) As Boolean
Visual C++
public:
bool CheckName(
    String^ objectName
)

Parameters

objectName
Type: System..::.String

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


CheckSaveDocument Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.CheckSaveDocument Method
ReportDesigner Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Designer.ReportDesigner.CheckSaveDocument]

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool CheckSaveDocument()
Visual Basic (Declaration)
Public Function CheckSaveDocument As Boolean
Visual C++
public:
bool CheckSaveDocument()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


CheckScript Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.CheckScript Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
CheckScript()()() | Checks script in the current document.
CheckScript(Document) | Checks scripts in the given document and returns value indicating that scripts have errors.

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


CheckScript Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.CheckScript Method
ReportDesigner Class See Also Send Feedback
Checks script in the current document.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool CheckScript()
Visual Basic (Declaration)
Public Function CheckScript As Boolean
Visual C++
public:
bool CheckScript()

See Also

ReportDesigner Class
CheckScript Overload
PerpetuumSoft.Reporting.Designer Namespace


CheckScript Method (Document)

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.CheckScript Method (Document)
ReportDesigner Class See Also Send Feedback
Checks scripts in the given document and returns value indicating that scripts have errors.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool CheckScript(
    Document template
)
Visual Basic (Declaration)
Public Function CheckScript ( _
    template As Document _
) As Boolean
Visual C++
public:
bool CheckScript(
    Document^ template
)

Parameters

template
Type: PerpetuumSoft.Reporting.DOM..::.Document

See Also

ReportDesigner Class
CheckScript Overload
PerpetuumSoft.Reporting.Designer Namespace


ClearCommandStack Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.ClearCommandStack Method
ReportDesigner Class See Also Send Feedback
Clears command stack.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void ClearCommandStack()
Visual Basic (Declaration)
Public Sub ClearCommandStack
Visual C++
public:
void ClearCommandStack()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


DeletePage Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.DeletePage Method
ReportDesigner Class See Also Send Feedback
Removes current page from document.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void DeletePage()
Visual Basic (Declaration)
Public Sub DeletePage
Visual C++
public:
void DeletePage()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


DeleteSelectedObjects Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.DeleteSelectedObjects Method
ReportDesigner Class See Also Send Feedback
Deletes selection.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void DeleteSelectedObjects()
Visual Basic (Declaration)
Public Sub DeleteSelectedObjects
Visual C++
public:
void DeleteSelectedObjects()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.Dispose Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl..::.Dispose(Boolean).)

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.Dispose Method (Boolean)
ReportDesigner Class See Also Send Feedback
Clean up any resources being used.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

ReportDesigner Class
Dispose Overload
PerpetuumSoft.Reporting.Designer Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.GetChildAtPoint Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


GetSelectionMergablePropertyBinding Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.GetSelectionMergablePropertyBinding Method
ReportDesigner Class See Also Send Feedback
Gets a list of property names the Binding cab be assigned to.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string GetSelectionMergablePropertyBinding(
    string bindigName
)
Visual Basic (Declaration)
Public Function GetSelectionMergablePropertyBinding ( _
    bindigName As String _
) As String
Visual C++
public:
String^ GetSelectionMergablePropertyBinding(
    String^ bindigName
)

Parameters

bindigName
Type: System..::.String

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


GetSelectionMergablePropertyValue Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.GetSelectionMergablePropertyValue Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
GetSelectionMergablePropertyValue(Object, String, Type) | Gets merged properties' value of the selected document element
GetSelectionMergablePropertyValue(Object, String, Type, String, Type) | Gets merged properties' value of the selected document element

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


GetSelectionMergablePropertyValue Method (Object, String, Type)

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.GetSelectionMergablePropertyValue Method (Object, String, Type)
ReportDesigner Class See Also Send Feedback
Gets merged properties' value of the selected document element

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportDesigner..::.MergablePropertyValue GetSelectionMergablePropertyValue(
    Object defaultValue,
    string propertyName,
    Type propertyType
)
Visual Basic (Declaration)
Public Function GetSelectionMergablePropertyValue ( _
    defaultValue As Object, _
    propertyName As String, _
    propertyType As Type _
) As ReportDesigner..::.MergablePropertyValue
Visual C++
public:
ReportDesigner..::.MergablePropertyValue GetSelectionMergablePropertyValue(
    Object^ defaultValue,
    String^ propertyName,
    Type^ propertyType
)

Parameters

defaultValue
Type: System..::.Object
propertyName
Type: System..::.String
propertyType
Type: System..::.Type

See Also

ReportDesigner Class
GetSelectionMergablePropertyValue Overload
PerpetuumSoft.Reporting.Designer Namespace


GetSelectionMergablePropertyValue Method (Object, String, Type, String, Type)

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.GetSelectionMergablePropertyValue Method (Object, String, Type, String, Type)
ReportDesigner Class See Also Send Feedback
Gets merged properties' value of the selected document element

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportDesigner..::.MergablePropertyValue GetSelectionMergablePropertyValue(
    Object defaultValue,
    string propertyName,
    Type propertyType,
    string subPropertyName,
    Type subPropertyType
)
Visual Basic (Declaration)
Public Function GetSelectionMergablePropertyValue ( _
    defaultValue As Object, _
    propertyName As String, _
    propertyType As Type, _
    subPropertyName As String, _
    subPropertyType As Type _
) As ReportDesigner..::.MergablePropertyValue
Visual C++
public:
ReportDesigner..::.MergablePropertyValue GetSelectionMergablePropertyValue(
    Object^ defaultValue,
    String^ propertyName,
    Type^ propertyType,
    String^ subPropertyName,
    Type^ subPropertyType
)

Parameters

defaultValue
Type: System..::.Object
propertyName
Type: System..::.String
propertyType
Type: System..::.Type
subPropertyName
Type: System..::.String
subPropertyType
Type: System..::.Type

See Also

ReportDesigner Class
GetSelectionMergablePropertyValue Overload
PerpetuumSoft.Reporting.Designer Namespace


GetSelectionPropertyBindingNames Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.GetSelectionPropertyBindingNames Method
ReportDesigner Class See Also Send Feedback
Gets a list of property names the Binding cab be assigned to for all selected document elements

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string[] GetSelectionPropertyBindingNames()
Visual Basic (Declaration)
Public Function GetSelectionPropertyBindingNames As String()
Visual C++
public:
array<String^>^ GetSelectionPropertyBindingNames()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


InsertControl Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.InsertControl Method
ReportDesigner Class See Also Send Feedback
Allows to insert control given type.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void InsertControl(
    Type type
)
Visual Basic (Declaration)
Public Sub InsertControl ( _
    type As Type _
)
Visual C++
public:
void InsertControl(
    Type^ type
)

Parameters

type
Type: System..::.Type

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.Invalidate Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.Invoke Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


LayoutBands Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.LayoutBands Method
ReportDesigner Class See Also Send Feedback
Performs bands auto-layout.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void LayoutBands()
Visual Basic (Declaration)
Public Sub LayoutBands
Visual C++
public:
void LayoutBands()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.MemberwiseClone Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


MoveSelectionBack Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.MoveSelectionBack Method
ReportDesigner Class See Also Send Feedback
Moves selected objects to back.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void MoveSelectionBack()
Visual Basic (Declaration)
Public Sub MoveSelectionBack
Visual C++
public:
void MoveSelectionBack()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


MoveSelectionForward Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.MoveSelectionForward Method
ReportDesigner Class See Also Send Feedback
Moves selected objects forward.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void MoveSelectionForward()
Visual Basic (Declaration)
Public Sub MoveSelectionForward
Visual C++
public:
void MoveSelectionForward()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


NewDocument Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.NewDocument Method
ReportDesigner Class See Also Send Feedback
Creates new document.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void NewDocument()
Visual Basic (Declaration)
Public Sub NewDocument
Visual C++
public:
void NewDocument()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


OnDesignerMouseDown Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.OnDesignerMouseDown Method
ReportDesigner Class See Also Send Feedback
Raises the DesignerMouseUp event.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual void OnDesignerMouseDown(
    DesignerMouseEventArgs args
)
Visual Basic (Declaration)
Public Overridable Sub OnDesignerMouseDown ( _
    args As DesignerMouseEventArgs _
)
Visual C++
public:
virtual void OnDesignerMouseDown(
    DesignerMouseEventArgs^ args
)

Parameters

args
Type: PerpetuumSoft.Reporting.Designer..::.DesignerMouseEventArgs

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


OnDesignerMouseUp Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.OnDesignerMouseUp Method
ReportDesigner Class See Also Send Feedback
Raises the DesignerMouseDown event.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual void OnDesignerMouseUp(
    DesignerMouseEventArgs args
)
Visual Basic (Declaration)
Public Overridable Sub OnDesignerMouseUp ( _
    args As DesignerMouseEventArgs _
)
Visual C++
public:
virtual void OnDesignerMouseUp(
    DesignerMouseEventArgs^ args
)

Parameters

args
Type: PerpetuumSoft.Reporting.Designer..::.DesignerMouseEventArgs

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


OnElementAdded Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.OnElementAdded Method
ReportDesigner Class See Also Send Feedback
Raises the ElementAdded event.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual void OnElementAdded(
    ElementAddedEventArgs args
)
Visual Basic (Declaration)
Public Overridable Sub OnElementAdded ( _
    args As ElementAddedEventArgs _
)
Visual C++
public:
virtual void OnElementAdded(
    ElementAddedEventArgs^ args
)

Parameters

args
Type: PerpetuumSoft.Reporting.Designer..::.ElementAddedEventArgs

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


OnElementAdding Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.OnElementAdding Method
ReportDesigner Class See Also Send Feedback
Raises the ElementAdding event.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual void OnElementAdding(
    ElementAddingEventArgs args
)
Visual Basic (Declaration)
Public Overridable Sub OnElementAdding ( _
    args As ElementAddingEventArgs _
)
Visual C++
public:
virtual void OnElementAdding(
    ElementAddingEventArgs^ args
)

Parameters

args
Type: PerpetuumSoft.Reporting.Designer..::.ElementAddingEventArgs

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.OnLoad Method
ReportDesigner Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.PerformLayout Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


Redo Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.Redo Method
ReportDesigner Class See Also Send Feedback
Redo last operation.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Redo()
Visual Basic (Declaration)
Public Sub Redo
Visual C++
public:
void Redo()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


ResetContextMenu Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.ResetContextMenu Method
ReportDesigner Class See Also Send Feedback
Resets comtextual menu.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void ResetContextMenu()
Visual Basic (Declaration)
Public Sub ResetContextMenu
Visual C++
public:
void ResetContextMenu()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


ResetSelectionProperty Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.ResetSelectionProperty Method
ReportDesigner Class See Also Send Feedback
Resets property value to default for all selected document elements

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Command ResetSelectionProperty(
    string propertyName,
    Type propertyType
)
Visual Basic (Declaration)
Public Function ResetSelectionProperty ( _
    propertyName As String, _
    propertyType As Type _
) As Command
Visual C++
public:
Command^ ResetSelectionProperty(
    String^ propertyName,
    Type^ propertyType
)

Parameters

propertyName
Type: System..::.String
propertyType
Type: System..::.Type

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.ResumeLayout Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.RtlTranslateAlignment Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


SaveDocument Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.SaveDocument Method
ReportDesigner Class See Also Send Feedback
Saves document to file.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void SaveDocument()
Visual Basic (Declaration)
Public Sub SaveDocument
Visual C++
public:
void SaveDocument()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


SaveDocumentAs Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.SaveDocumentAs Method
ReportDesigner Class See Also Send Feedback
Shows "Save As..." dialog.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void SaveDocumentAs()
Visual Basic (Declaration)
Public Sub SaveDocumentAs
Visual C++
public:
void SaveDocumentAs()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.Scale Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.Select Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


SendSelectionToBack Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.SendSelectionToBack Method
ReportDesigner Class See Also Send Feedback
Sends selected objects to back.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void SendSelectionToBack()
Visual Basic (Declaration)
Public Sub SendSelectionToBack
Visual C++
public:
void SendSelectionToBack()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.SetBounds Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


SetContextMenu Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.SetContextMenu Method
ReportDesigner Class See Also Send Feedback
Sets a contextual menu in the designer

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void SetContextMenu(
    ContextMenuStrip contextMenu
)
Visual Basic (Declaration)
Public Sub SetContextMenu ( _
    contextMenu As ContextMenuStrip _
)
Visual C++
public:
void SetContextMenu(
    ContextMenuStrip^ contextMenu
)

Parameters

contextMenu
Type: System.Windows.Forms..::.ContextMenuStrip

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


SetSelectionPropertyBinding Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.SetSelectionPropertyBinding Method
ReportDesigner Class See Also Send Feedback
Sets a new property value for all selected document elements

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void SetSelectionPropertyBinding(
    string bindingName,
    string script
)
Visual Basic (Declaration)
Public Sub SetSelectionPropertyBinding ( _
    bindingName As String, _
    script As String _
)
Visual C++
public:
void SetSelectionPropertyBinding(
    String^ bindingName,
    String^ script
)

Parameters

bindingName
Type: System..::.String
script
Type: System..::.String

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


SetSelectionPropertyValue Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.SetSelectionPropertyValue Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
SetSelectionPropertyValue(String, Type, Object) | Sets a new Binding property for all selected documents elements
SetSelectionPropertyValue(String, Type, ReportDesigner..::.GetNewValueMethod, Object) | Sets new property value of all selected document elements

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


SetSelectionPropertyValue Method (String, Type, Object)

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.SetSelectionPropertyValue Method (String, Type, Object)
ReportDesigner Class See Also Send Feedback
Sets a new Binding property for all selected documents elements

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void SetSelectionPropertyValue(
    string propertyName,
    Type propertyType,
    Object newValue
)
Visual Basic (Declaration)
Public Sub SetSelectionPropertyValue ( _
    propertyName As String, _
    propertyType As Type, _
    newValue As Object _
)
Visual C++
public:
void SetSelectionPropertyValue(
    String^ propertyName,
    Type^ propertyType,
    Object^ newValue
)

Parameters

propertyName
Type: System..::.String
propertyType
Type: System..::.Type
newValue
Type: System..::.Object

See Also

ReportDesigner Class
SetSelectionPropertyValue Overload
PerpetuumSoft.Reporting.Designer Namespace


SetSelectionPropertyValue Method (String, Type, ReportDesigner.GetNewValueMethod, Object)

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.SetSelectionPropertyValue Method (String, Type, ReportDesigner..::.GetNewValueMethod, Object)
ReportDesigner Class See Also Send Feedback
Sets new property value of all selected document elements

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void SetSelectionPropertyValue(
    string propertyName,
    Type propertyType,
    ReportDesigner..::.GetNewValueMethod getNewValueMethod,
    Object newValue
)
Visual Basic (Declaration)
Public Sub SetSelectionPropertyValue ( _
    propertyName As String, _
    propertyType As Type, _
    getNewValueMethod As ReportDesigner..::.GetNewValueMethod, _
    newValue As Object _
)
Visual C++
public:
void SetSelectionPropertyValue(
    String^ propertyName,
    Type^ propertyType,
    ReportDesigner..::.GetNewValueMethod^ getNewValueMethod,
    Object^ newValue
)

Parameters

propertyName
Type: System..::.String
propertyType
Type: System..::.Type
getNewValueMethod
Type: PerpetuumSoft.Reporting.Designer..::.ReportDesigner..::.GetNewValueMethod
newValue
Type: System..::.Object

See Also

ReportDesigner Class
SetSelectionPropertyValue Overload
PerpetuumSoft.Reporting.Designer Namespace


ShowCustomZoomDialog Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.ShowCustomZoomDialog Method
ReportDesigner Class See Also Send Feedback
Shows zoom dialog.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void ShowCustomZoomDialog()
Visual Basic (Declaration)
Public Sub ShowCustomZoomDialog
Visual C++
public:
void ShowCustomZoomDialog()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


ShowDataSourcesEditor Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.ShowDataSourcesEditor Method
ReportDesigner Class See Also Send Feedback
Invokes the document data sources editor dialog.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void ShowDataSourcesEditor()
Visual Basic (Declaration)
Public Sub ShowDataSourcesEditor
Visual C++
public:
void ShowDataSourcesEditor()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


ShowGotoPageDialog Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.ShowGotoPageDialog Method
ReportDesigner Class See Also Send Feedback
Shows pages dialog.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void ShowGotoPageDialog()
Visual Basic (Declaration)
Public Sub ShowGotoPageDialog
Visual C++
public:
void ShowGotoPageDialog()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


Undo Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.Undo Method
ReportDesigner Class See Also Send Feedback
Undo last operation.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Undo()
Visual Basic (Declaration)
Public Sub Undo
Visual C++
public:
void Undo()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.UpdateBounds Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


UpdateTools Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.UpdateTools Method
ReportDesigner Class See Also Send Feedback
Updates all attached designer tools.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void UpdateTools()
Visual Basic (Declaration)
Public Sub UpdateTools
Visual C++
public:
void UpdateTools()

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


UpdateView Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.UpdateView Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
UpdateView()()() |
UpdateView(DesignerToolArgs) |

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


UpdateView Method

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.UpdateView Method
ReportDesigner Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Designer.ReportDesigner.UpdateView]

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void UpdateView()
Visual Basic (Declaration)
Public Sub UpdateView
Visual C++
public:
void UpdateView()

See Also

ReportDesigner Class
UpdateView Overload
PerpetuumSoft.Reporting.Designer Namespace


UpdateView Method (DesignerToolArgs)

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.UpdateView Method (DesignerToolArgs)
ReportDesigner Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Designer.ReportDesigner.UpdateView(PerpetuumSoft.Reporting.Designer.DesignerToolArgs)]

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void UpdateView(
    DesignerToolArgs args
)
Visual Basic (Declaration)
Public Sub UpdateView ( _
    args As DesignerToolArgs _
)
Visual C++
public:
void UpdateView(
    DesignerToolArgs^ args
)

Parameters

args
Type: PerpetuumSoft.Reporting.Designer..::.DesignerToolArgs

See Also

ReportDesigner Class
UpdateView Overload
PerpetuumSoft.Reporting.Designer Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.Validate Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.ValidateChildren Method
ReportDesigner Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ReportDesigner Class
ReportDesigner Members
PerpetuumSoft.Reporting.Designer Namespace


ReportDesigner Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner Properties
ReportDesigner Class See Also Send Feedback

The ReportDesigner type exposes the following members.

Properties

Name | Description
About | Gets the copyright string.
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Actions | Gets collection of all actions of the ReportDesigner.
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoLayoutBands | Gets and sets if auto-layout mode is enabled.
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
CompilerResults | Gets results of the report scripts compilation CompilerResults
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
CurrentPage | Get currently edited page.
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DataSourceManager | Gets or sets data source manager assigned withy this designer.
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Document | Gets and sets edited document.
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsModified | Gets whether report was modified by user.
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MetricUnitMenu | Gets the contextual menu for assigning measure units ContextMenuStrip
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MouseMode | Gets or sets mouse pointer in the designer DesignerMouseMode
MouseModeContextMenu | Gets the contextual menu for assigning mouse display mode ContextMenuStrip
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
PageNumber | Gets and sets edited page number.
PageTabContextMenu | Gets the contextual menu for assigning page tabs ContextMenuStrip
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Selection | Gets selection.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowRulers | Gets or sets if rulers should be displayed.
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
SubReportsResolver | Gets or sets SubReportResolver.
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Tools | Gets collection of currently registered tools.
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Zoom | Gets and sets zoom for the report designer.
ZoomMenu | Gets the contextual menu for assigning zoom ContextMenuStrip

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


About Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.About Property
ReportDesigner Class See Also Send Feedback
Gets the copyright string.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string About { get; }
Visual Basic (Declaration)
Public ReadOnly Property About As String
Visual C++
public:
property String^ About {
    String^ get ();
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


Actions Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.Actions Property
ReportDesigner Class See Also Send Feedback
Gets collection of all actions of the ReportDesigner.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ActionCollection Actions { get; }
Visual Basic (Declaration)
Public ReadOnly Property Actions As ActionCollection
Visual C++
public:
property ActionCollection^ Actions {
    ActionCollection^ get ();
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


AutoLayoutBands Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.AutoLayoutBands Property
ReportDesigner Class See Also Send Feedback
Gets and sets if auto-layout mode is enabled.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool AutoLayoutBands { get; set; }
Visual Basic (Declaration)
Public Property AutoLayoutBands As Boolean
Visual C++
public:
property bool AutoLayoutBands {
    bool get ();
    void set (bool value);
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


CompilerResults Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.CompilerResults Property
ReportDesigner Class See Also Send Feedback
Gets results of the report scripts compilation CompilerResults

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public CompilerResults CompilerResults { get; }
Visual Basic (Declaration)
Public ReadOnly Property CompilerResults As CompilerResults
Visual C++
public:
property CompilerResults^ CompilerResults {
    CompilerResults^ get ();
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


CurrentPage Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.CurrentPage Property
ReportDesigner Class See Also Send Feedback
Get currently edited page.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Page CurrentPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentPage As Page
Visual C++
public:
virtual property Page^ CurrentPage {
    Page^ get () sealed;
}

Implements

IReportDesignerService..::.CurrentPage

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


DataSourceManager Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.DataSourceManager Property
ReportDesigner Class See Also Send Feedback
Gets or sets data source manager assigned withy this designer.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public IDataSourceManager DataSourceManager { get; set; }
Visual Basic (Declaration)
Public Property DataSourceManager As IDataSourceManager
Visual C++
public:
virtual property IDataSourceManager^ DataSourceManager {
    IDataSourceManager^ get () sealed;
    void set (IDataSourceManager^ value) sealed;
}

Implements

IReportDesignerService..::.DataSourceManager

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


Document Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.Document Property
ReportDesigner Class See Also Send Feedback
Gets and sets edited document.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Document Document { get; set; }
Visual Basic (Declaration)
Public Property Document As Document
Visual C++
public:
virtual property Document^ Document {
    Document^ get () sealed;
    void set (Document^ value) sealed;
}

Implements

IReportDesignerService..::.Document

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


IsModified Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.IsModified Property
ReportDesigner Class See Also Send Feedback
Gets whether report was modified by user.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool IsModified { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsModified As Boolean
Visual C++
public:
property bool IsModified {
    bool get ();
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


MetricUnitMenu Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.MetricUnitMenu Property
ReportDesigner Class See Also Send Feedback
Gets the contextual menu for assigning measure units ContextMenuStrip

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ContextMenuStrip MetricUnitMenu { get; }
Visual Basic (Declaration)
Public ReadOnly Property MetricUnitMenu As ContextMenuStrip
Visual C++
public:
property ContextMenuStrip^ MetricUnitMenu {
    ContextMenuStrip^ get ();
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


MouseMode Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.MouseMode Property
ReportDesigner Class See Also Send Feedback
Gets or sets mouse pointer in the designer DesignerMouseMode

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DesignerMouseMode MouseMode { get; set; }
Visual Basic (Declaration)
Public Property MouseMode As DesignerMouseMode
Visual C++
public:
property DesignerMouseMode^ MouseMode {
    DesignerMouseMode^ get ();
    void set (DesignerMouseMode^ value);
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


MouseModeContextMenu Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.MouseModeContextMenu Property
ReportDesigner Class See Also Send Feedback
Gets the contextual menu for assigning mouse display mode ContextMenuStrip

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ContextMenuStrip MouseModeContextMenu { get; }
Visual Basic (Declaration)
Public ReadOnly Property MouseModeContextMenu As ContextMenuStrip
Visual C++
public:
property ContextMenuStrip^ MouseModeContextMenu {
    ContextMenuStrip^ get ();
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


PageNumber Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.PageNumber Property
ReportDesigner Class See Also Send Feedback
Gets and sets edited page number.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int PageNumber { get; set; }
Visual Basic (Declaration)
Public Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
    void set (int value);
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


PageTabContextMenu Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.PageTabContextMenu Property
ReportDesigner Class See Also Send Feedback
Gets the contextual menu for assigning page tabs ContextMenuStrip

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ContextMenuStrip PageTabContextMenu { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageTabContextMenu As ContextMenuStrip
Visual C++
public:
property ContextMenuStrip^ PageTabContextMenu {
    ContextMenuStrip^ get ();
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


Selection Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.Selection Property
ReportDesigner Class See Also Send Feedback
Gets selection.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public SelectionGroup Selection { get; }
Visual Basic (Declaration)
Public ReadOnly Property Selection As SelectionGroup
Visual C++
public:
property SelectionGroup^ Selection {
    SelectionGroup^ get ();
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


ShowRulers Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.ShowRulers Property
ReportDesigner Class See Also Send Feedback
Gets or sets if rulers should be displayed.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowRulers { get; set; }
Visual Basic (Declaration)
Public Property ShowRulers As Boolean
Visual C++
public:
property bool ShowRulers {
    bool get ();
    void set (bool value);
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


SubReportsResolver Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.SubReportsResolver Property
ReportDesigner Class See Also Send Feedback
Gets or sets SubReportResolver.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public IResolveSubReport SubReportsResolver { get; set; }
Visual Basic (Declaration)
Public Property SubReportsResolver As IResolveSubReport
Visual C++
public:
property IResolveSubReport^ SubReportsResolver {
    IResolveSubReport^ get ();
    void set (IResolveSubReport^ value);
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


Tools Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.Tools Property
ReportDesigner Class See Also Send Feedback
Gets collection of currently registered tools.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public IDesignerToolCollection Tools { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tools As IDesignerToolCollection
Visual C++
public:
property IDesignerToolCollection^ Tools {
    IDesignerToolCollection^ get ();
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


Zoom Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.Zoom Property
ReportDesigner Class See Also Send Feedback
Gets and sets zoom for the report designer.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Zoom Zoom { get; set; }
Visual Basic (Declaration)
Public Property Zoom As Zoom
Visual C++
public:
property Zoom Zoom {
    Zoom get ();
    void set (Zoom value);
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


ZoomMenu Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.ZoomMenu Property
ReportDesigner Class See Also Send Feedback
Gets the contextual menu for assigning zoom ContextMenuStrip

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ContextMenuStrip ZoomMenu { get; }
Visual Basic (Declaration)
Public ReadOnly Property ZoomMenu As ContextMenuStrip
Visual C++
public:
property ContextMenuStrip^ ZoomMenu {
    ContextMenuStrip^ get ();
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


ReportDesigner Events

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner Events
ReportDesigner Class See Also Send Feedback

The ReportDesigner type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DesignerMouseDown | Occurs when the mouse pointer is over the designer and a mouse button is pressed.
DesignerMouseUp | Occurs when the mouse pointer is over the designer and a mouse button is released.
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
ElementAdded | Occurs when a new element is added to a document being edited.
ElementAdding | Occurs when a new element is added to a document being edited.
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
RequestCodeSnippets | Occures to get the code snippets by the specified script language.
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerMouseDown Event

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.DesignerMouseDown Event
ReportDesigner Class See Also Send Feedback
Occurs when the mouse pointer is over the designer and a mouse button is pressed.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event DesignerMouseEventHandler DesignerMouseDown
Visual Basic (Declaration)
Public Event DesignerMouseDown As DesignerMouseEventHandler
Visual C++
public:
 event DesignerMouseEventHandler^ DesignerMouseDown {
    void add (DesignerMouseEventHandler^ value);
    void remove (DesignerMouseEventHandler^ value);
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


DesignerMouseUp Event

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.DesignerMouseUp Event
ReportDesigner Class See Also Send Feedback
Occurs when the mouse pointer is over the designer and a mouse button is released.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event DesignerMouseEventHandler DesignerMouseUp
Visual Basic (Declaration)
Public Event DesignerMouseUp As DesignerMouseEventHandler
Visual C++
public:
 event DesignerMouseEventHandler^ DesignerMouseUp {
    void add (DesignerMouseEventHandler^ value);
    void remove (DesignerMouseEventHandler^ value);
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


ElementAdded Event

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.ElementAdded Event
ReportDesigner Class See Also Send Feedback
Occurs when a new element is added to a document being edited.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event ElementAddedEventHandler ElementAdded
Visual Basic (Declaration)
Public Event ElementAdded As ElementAddedEventHandler
Visual C++
public:
 event ElementAddedEventHandler^ ElementAdded {
    void add (ElementAddedEventHandler^ value);
    void remove (ElementAddedEventHandler^ value);
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


ElementAdding Event

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.ElementAdding Event
ReportDesigner Class See Also Send Feedback
Occurs when a new element is added to a document being edited.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event ElementAddingEventHandler ElementAdding
Visual Basic (Declaration)
Public Event ElementAdding As ElementAddingEventHandler
Visual C++
public:
 event ElementAddingEventHandler^ ElementAdding {
    void add (ElementAddingEventHandler^ value);
    void remove (ElementAddingEventHandler^ value);
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


RequestCodeSnippets Event

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.RequestCodeSnippets Event
ReportDesigner Class See Also Send Feedback
Occures to get the code snippets by the specified script language.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static event EventHandler<RequestCodeSnippetsEventArgs> RequestCodeSnippets
Visual Basic (Declaration)
Public Shared Event RequestCodeSnippets As EventHandler(Of RequestCodeSnippetsEventArgs)
Visual C++
public:
static  event EventHandler<RequestCodeSnippetsEventArgs^>^ RequestCodeSnippets {
    void add (EventHandler<RequestCodeSnippetsEventArgs^>^ value);
    void remove (EventHandler<RequestCodeSnippetsEventArgs^>^ value);
}

See Also

ReportDesigner Class
PerpetuumSoft.Reporting.Designer Namespace


ReportDesigner.GetNewValueMethod Delegate

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.GetNewValueMethod Delegate
ReportDesigner Class See Also Send Feedback
Defines method of getting a new value depending on the previous one

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate Object GetNewValueMethod(
    Object oldValue,
    Object newValue
)
Visual Basic (Declaration)
Public Delegate Function GetNewValueMethod ( _
    oldValue As Object, _
    newValue As Object _
) As Object
Visual C++
public delegate Object^ GetNewValueMethod(
    Object^ oldValue,
    Object^ newValue
)

Parameters

oldValue
Type: System..::.Object
newValue
Type: System..::.Object

See Also

PerpetuumSoft.Reporting.Designer Namespace


ReportDesigner.MergablePropertyValue Structure

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.MergablePropertyValue Structure
ReportDesigner Class Members See Also Send Feedback
Represents data about the merged properties value of multiple objects

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public struct MergablePropertyValue
Visual Basic (Declaration)
Public Structure MergablePropertyValue
Visual C++
public value class MergablePropertyValue

See Also

ReportDesigner..::.MergablePropertyValue Members
PerpetuumSoft.Reporting.Designer Namespace


ReportDesigner.MergablePropertyValue Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.MergablePropertyValue Members
ReportDesigner..::.MergablePropertyValue Structure Methods Properties See Also Send Feedback

Report Designer control.

The ReportDesigner..::.MergablePropertyValue type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
IsEmpty | Gets value indicating if the property is empty Boolean
IsSingle | Indicates that the current value corresponds to the single object
Value | Gets object property value

See Also

ReportDesigner..::.MergablePropertyValue Structure
PerpetuumSoft.Reporting.Designer Namespace


ReportDesigner.MergablePropertyValue Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.MergablePropertyValue Methods
ReportDesigner..::.MergablePropertyValue Structure See Also Send Feedback

The ReportDesigner..::.MergablePropertyValue type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

ReportDesigner..::.MergablePropertyValue Structure
PerpetuumSoft.Reporting.Designer Namespace


ReportDesigner.MergablePropertyValue Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.MergablePropertyValue Properties
ReportDesigner..::.MergablePropertyValue Structure See Also Send Feedback

The ReportDesigner..::.MergablePropertyValue type exposes the following members.

Properties

Name | Description
IsEmpty | Gets value indicating if the property is empty Boolean
IsSingle | Indicates that the current value corresponds to the single object
Value | Gets object property value

See Also

ReportDesigner..::.MergablePropertyValue Structure
PerpetuumSoft.Reporting.Designer Namespace


IsEmpty Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.MergablePropertyValue..::.IsEmpty Property
ReportDesigner..::.MergablePropertyValue Structure See Also Send Feedback
Gets value indicating if the property is empty Boolean

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

ReportDesigner..::.MergablePropertyValue Structure
PerpetuumSoft.Reporting.Designer Namespace


IsSingle Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.MergablePropertyValue..::.IsSingle Property
ReportDesigner..::.MergablePropertyValue Structure See Also Send Feedback
Indicates that the current value corresponds to the single object

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool IsSingle { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSingle As Boolean
Visual C++
public:
property bool IsSingle {
    bool get ();
}

See Also

ReportDesigner..::.MergablePropertyValue Structure
PerpetuumSoft.Reporting.Designer Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
ReportDesigner..::.MergablePropertyValue..::.Value Property
ReportDesigner..::.MergablePropertyValue Structure See Also Send Feedback
Gets object property value

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
}

See Also

ReportDesigner..::.MergablePropertyValue Structure
PerpetuumSoft.Reporting.Designer Namespace


RequestCodeSnippetsEventArgs Class

[image]

.NET ModelKit Suite ClassReference
RequestCodeSnippetsEventArgs Class
Members See Also Send Feedback
Represents data about the code snippets for the specified script language.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class RequestCodeSnippetsEventArgs : EventArgs
Visual Basic (Declaration)
Public Class RequestCodeSnippetsEventArgs _
    Inherits EventArgs
Visual C++
public ref class RequestCodeSnippetsEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.Designer..::.RequestCodeSnippetsEventArgs

See Also

RequestCodeSnippetsEventArgs Members
PerpetuumSoft.Reporting.Designer Namespace


RequestCodeSnippetsEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
RequestCodeSnippetsEventArgs Members
RequestCodeSnippetsEventArgs Class Constructors Methods Properties See Also Send Feedback

The RequestCodeSnippetsEventArgs type exposes the following members.

Constructors

Name | Description
RequestCodeSnippetsEventArgs | Initializes a new instance of the RequestCodeSnippetsEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Language | Gets ScriptLanguage that sets scripts programming language.
Stream | Gets or sets the stream that contains the code snipets description.

See Also

RequestCodeSnippetsEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


RequestCodeSnippetsEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
RequestCodeSnippetsEventArgs Constructor
RequestCodeSnippetsEventArgs Class See Also Send Feedback
Initializes a new instance of the RequestCodeSnippetsEventArgs class.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public RequestCodeSnippetsEventArgs(
    ScriptLanguage language
)
Visual Basic (Declaration)
Public Sub New ( _
    language As ScriptLanguage _
)
Visual C++
public:
RequestCodeSnippetsEventArgs(
    ScriptLanguage language
)

Parameters

language
Type: PerpetuumSoft.Reporting.DOM..::.ScriptLanguage

See Also

RequestCodeSnippetsEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


RequestCodeSnippetsEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
RequestCodeSnippetsEventArgs Methods
RequestCodeSnippetsEventArgs Class See Also Send Feedback

The RequestCodeSnippetsEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RequestCodeSnippetsEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


RequestCodeSnippetsEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
RequestCodeSnippetsEventArgs Properties
RequestCodeSnippetsEventArgs Class See Also Send Feedback

The RequestCodeSnippetsEventArgs type exposes the following members.

Properties

Name | Description
Language | Gets ScriptLanguage that sets scripts programming language.
Stream | Gets or sets the stream that contains the code snipets description.

See Also

RequestCodeSnippetsEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


Language Property

[image]

.NET ModelKit Suite ClassReference
RequestCodeSnippetsEventArgs..::.Language Property
RequestCodeSnippetsEventArgs Class See Also Send Feedback
Gets ScriptLanguage that sets scripts programming language.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ScriptLanguage Language { get; }
Visual Basic (Declaration)
Public ReadOnly Property Language As ScriptLanguage
Visual C++
public:
property ScriptLanguage Language {
    ScriptLanguage get ();
}

See Also

RequestCodeSnippetsEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


Stream Property

[image]

.NET ModelKit Suite ClassReference
RequestCodeSnippetsEventArgs..::.Stream Property
RequestCodeSnippetsEventArgs Class See Also Send Feedback
Gets or sets the stream that contains the code snipets description.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Stream Stream { get; set; }
Visual Basic (Declaration)
Public Property Stream As Stream
Visual C++
public:
property Stream^ Stream {
    Stream^ get ();
    void set (Stream^ value);
}

See Also

RequestCodeSnippetsEventArgs Class
PerpetuumSoft.Reporting.Designer Namespace


SelectionGroup Class

[image]

.NET ModelKit Suite ClassReference
SelectionGroup Class
Members See Also Send Feedback
Represents collection of selected objects in ReportDesigner.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class SelectionGroup
Visual Basic (Declaration)
Public Class SelectionGroup
Visual C++
public ref class SelectionGroup

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Designer..::.SelectionGroup

See Also

SelectionGroup Members
PerpetuumSoft.Reporting.Designer Namespace


SelectionGroup Members

[image] [image]

.NET ModelKit Suite ClassReference
SelectionGroup Members
SelectionGroup Class Constructors Methods Properties Events See Also Send Feedback

The SelectionGroup type exposes the following members.

Constructors

Name | Description
SelectionGroup | Creates a new instance of SelectionGroup class.

Methods

Name | Description
Add | Adds control to selection.
AddRange | Add array of controls to selection.
Clear | Clears selection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Move | Moves all controls in selection to the given position.
RaiseSelectedChanged | Raises Chanded event.
Remove | Removes control from selection.
Select | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsEmpty | Gets if selection is empty.
IsSingle | Gets if selection contains single object.
Main | Gets primary selected object.
MainSelection | Gets selected objects that belongs to the same container as primary selection.
SelectedObject | Gets selected object.
SelectedObjects | Gets selected objects collection.
Selection | Gets collection contained all selected controls.
SelectionBounds | Gets bounds on selection reletive to the page.
Single | Gets selected object.

Events

Name | Description
Changed | Occurs when selection changed.

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


SelectionGroup Constructor

[image]

.NET ModelKit Suite ClassReference
SelectionGroup Constructor
SelectionGroup Class See Also Send Feedback
Creates a new instance of SelectionGroup class.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public SelectionGroup()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SelectionGroup()

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


SelectionGroup Methods

[image] [image]

.NET ModelKit Suite ClassReference
SelectionGroup Methods
SelectionGroup Class See Also Send Feedback

The SelectionGroup type exposes the following members.

Methods

Name | Description
Add | Adds control to selection.
AddRange | Add array of controls to selection.
Clear | Clears selection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Move | Moves all controls in selection to the given position.
RaiseSelectedChanged | Raises Chanded event.
Remove | Removes control from selection.
Select | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.Add Method
SelectionGroup Class See Also Send Feedback
Adds control to selection.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Add(
    ReportControl control
)
Visual Basic (Declaration)
Public Sub Add ( _
    control As ReportControl _
)
Visual C++
public:
void Add(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.AddRange Method
SelectionGroup Class See Also Send Feedback
Add array of controls to selection.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    ReportControl[] controls
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    controls As ReportControl() _
)
Visual C++
public:
void AddRange(
    array<ReportControl^>^ controls
)

Parameters

controls
Type: array< PerpetuumSoft.Reporting.DOM..::.ReportControl >[]()[]

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


Clear Method

[image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.Clear Method
SelectionGroup Class See Also Send Feedback
Clears selection.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


Move Method

[image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.Move Method
SelectionGroup Class See Also Send Feedback
Moves all controls in selection to the given position.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Move(
    Vector mainPosition
)
Visual Basic (Declaration)
Public Sub Move ( _
    mainPosition As Vector _
)
Visual C++
public:
void Move(
    Vector mainPosition
)

Parameters

mainPosition
Type: PerpetuumSoft.Framework.Drawing..::.Vector

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


RaiseSelectedChanged Method

[image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.RaiseSelectedChanged Method
SelectionGroup Class See Also Send Feedback
Raises Chanded event.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected void RaiseSelectedChanged()
Visual Basic (Declaration)
Protected Sub RaiseSelectedChanged
Visual C++
protected:
void RaiseSelectedChanged()

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.Remove Method
SelectionGroup Class See Also Send Feedback
Removes control from selection.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    ReportControl control
)
Visual Basic (Declaration)
Public Sub Remove ( _
    control As ReportControl _
)
Visual C++
public:
void Remove(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.Select Method
SelectionGroup Class See Also Send Feedback

Overload List

Name | Description
Select(ReportControl) | Selects specified control.
Select(array<ReportControl>[]()[]) | Selects specified controls.
Select(ReportControl, Boolean) | Selects specified control.

See Also

SelectionGroup Class
SelectionGroup Members
PerpetuumSoft.Reporting.Designer Namespace


Select Method (ReportControl)

[image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.Select Method (ReportControl)
SelectionGroup Class See Also Send Feedback
Selects specified control.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Select(
    ReportControl control
)
Visual Basic (Declaration)
Public Sub Select ( _
    control As ReportControl _
)
Visual C++
public:
void Select(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

SelectionGroup Class
Select Overload
PerpetuumSoft.Reporting.Designer Namespace


Select Method (ReportControl[])

[image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.Select Method (array<ReportControl>[]()[])
SelectionGroup Class See Also Send Feedback
Selects specified controls.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Select(
    ReportControl[] controls
)
Visual Basic (Declaration)
Public Sub Select ( _
    controls As ReportControl() _
)
Visual C++
public:
void Select(
    array<ReportControl^>^ controls
)

Parameters

controls
Type: array< PerpetuumSoft.Reporting.DOM..::.ReportControl >[]()[]

See Also

SelectionGroup Class
Select Overload
PerpetuumSoft.Reporting.Designer Namespace


Select Method (ReportControl, Boolean)

[image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.Select Method (ReportControl, Boolean)
SelectionGroup Class See Also Send Feedback
Selects specified control.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Select(
    ReportControl control,
    bool xormode
)
Visual Basic (Declaration)
Public Sub Select ( _
    control As ReportControl, _
    xormode As Boolean _
)
Visual C++
public:
void Select(
    ReportControl^ control,
    bool xormode
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
xormode
Type: System..::.Boolean

See Also

SelectionGroup Class
Select Overload
PerpetuumSoft.Reporting.Designer Namespace


SelectionGroup Properties

[image] [image]

.NET ModelKit Suite ClassReference
SelectionGroup Properties
SelectionGroup Class See Also Send Feedback

The SelectionGroup type exposes the following members.

Properties

Name | Description
IsEmpty | Gets if selection is empty.
IsSingle | Gets if selection contains single object.
Main | Gets primary selected object.
MainSelection | Gets selected objects that belongs to the same container as primary selection.
SelectedObject | Gets selected object.
SelectedObjects | Gets selected objects collection.
Selection | Gets collection contained all selected controls.
SelectionBounds | Gets bounds on selection reletive to the page.
Single | Gets selected object.

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


IsEmpty Property

[image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.IsEmpty Property
SelectionGroup Class See Also Send Feedback
Gets if selection is empty.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


IsSingle Property

[image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.IsSingle Property
SelectionGroup Class See Also Send Feedback
Gets if selection contains single object.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool IsSingle { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSingle As Boolean
Visual C++
public:
property bool IsSingle {
    bool get ();
}

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


Main Property

[image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.Main Property
SelectionGroup Class See Also Send Feedback
Gets primary selected object.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportControl Main { get; set; }
Visual Basic (Declaration)
Public Property Main As ReportControl
Visual C++
public:
property ReportControl^ Main {
    ReportControl^ get ();
    void set (ReportControl^ value);
}

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


MainSelection Property

[image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.MainSelection Property
SelectionGroup Class See Also Send Feedback
Gets selected objects that belongs to the same container as primary selection.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportControlCollection MainSelection { get; }
Visual Basic (Declaration)
Public ReadOnly Property MainSelection As ReportControlCollection
Visual C++
public:
property ReportControlCollection^ MainSelection {
    ReportControlCollection^ get ();
}

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


SelectedObject Property

[image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.SelectedObject Property
SelectionGroup Class See Also Send Feedback
Gets selected object.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object SelectedObject { get; set; }
Visual Basic (Declaration)
Public Property SelectedObject As Object
Visual C++
public:
property Object^ SelectedObject {
    Object^ get ();
    void set (Object^ value);
}

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


SelectedObjects Property

[image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.SelectedObjects Property
SelectionGroup Class See Also Send Feedback
Gets selected objects collection.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object[] SelectedObjects { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedObjects As Object()
Visual C++
public:
property array<Object^>^ SelectedObjects {
    array<Object^>^ get ();
}

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


Selection Property

[image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.Selection Property
SelectionGroup Class See Also Send Feedback
Gets collection contained all selected controls.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportControlCollection Selection { get; }
Visual Basic (Declaration)
Public ReadOnly Property Selection As ReportControlCollection
Visual C++
public:
property ReportControlCollection^ Selection {
    ReportControlCollection^ get ();
}

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


SelectionBounds Property

[image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.SelectionBounds Property
SelectionGroup Class See Also Send Feedback
Gets bounds on selection reletive to the page.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle SelectionBounds { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectionBounds As VectorRectangle
Visual C++
public:
property VectorRectangle SelectionBounds {
    VectorRectangle get ();
}

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


Single Property

[image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.Single Property
SelectionGroup Class See Also Send Feedback
Gets selected object.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportControl Single { get; }
Visual Basic (Declaration)
Public ReadOnly Property Single As ReportControl
Visual C++
public:
property ReportControl^ Single {
    ReportControl^ get ();
}

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


SelectionGroup Events

[image] [image]

.NET ModelKit Suite ClassReference
SelectionGroup Events
SelectionGroup Class See Also Send Feedback

The SelectionGroup type exposes the following members.

Events

Name | Description
Changed | Occurs when selection changed.

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


Changed Event

[image]

.NET ModelKit Suite ClassReference
SelectionGroup..::.Changed Event
SelectionGroup Class See Also Send Feedback
Occurs when selection changed.

Namespace: PerpetuumSoft.Reporting.Designer
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler Changed
Visual Basic (Declaration)
Public Event Changed As EventHandler
Visual C++
public:
 event EventHandler^ Changed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

SelectionGroup Class
PerpetuumSoft.Reporting.Designer Namespace


PerpetuumSoft.Reporting.DOM Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.DOM Namespace
Send Feedback
The PerpetuumSoft.Reporting.DOM namespace contains classes that represent the document object model of a template as well as of the generated document.

Classes

Class | Description
AdvancedText | Represents a boxed text control.
Aggregate | Summary description for Aggregate.
AggregateCollection | Represents the collection of Aggregate objects.
AggregateGroup | Summary description for AggregateGroup.
AggregateGroupCollection | Represents the collection of AggregateGroup objects.
AggregatesRegularBand | Base class for regular bands supporting aggregation.
BandBase | The base class for all band classes in the report generator.
BandContainer | Represents the BandContainer element.
BarCode | Defines a barcode object in report generator.
Box | Defines a boxed control with borders and fills.
CalculateSubReportParameterEventArgs | Represents the data for the CalulateParameter event contained in the sub report element.
ChartControl | Provides report element for creating a chart.
ContainerControl | Base class for all container controls.
Content | Used for Master Report. Outputs bands from a report related to this master.
CrossBand | Represents a vertical band for 2-dimensional reports.
DataBand | Creates instances of the nested controls for each record in the data source.
DataBandBase | Represents the base class for all bands
DataBandSort | The type representing data sorting settings
DataBandSortCollection | Represents the data sorting settings collection
DataBandTotal | Determines totals calculation settings collection
DataBandTotalCollection | Determines totals calculation settings collection
Detail | Defines a detail band.
DetailBase | Base class for all detail bands.
Document | Represents both report templates and final reports.
FindTextArgument | Defines arguments for FindText operations.
FindTextOptions | Specifies the options for FindText operations.
Footer | Defines a footer band.
GraphicsSettings | Represents graphics settings.
GroupBand | Base class for group bands.
GroupBandBase | Obsolete. Represents base class for all group bands
GroupFooter | Obsolete. Defines a group footer.
GroupHeader | Obsolete. Defines a group header.
Header | Represents header band.
Page | Represents a single page in the report document.
PageBand | Base class for those bands that must appear on every page, such as page headers and footer.
PageCollection | Represents the collection of pages in the document.
PageFooter | Represents a page footer.
PageHeader | Represents a page header.
PageOverlay | Represents a page overlay band.
PaintArguments | Provides data for painting a control.
Parameter | Represents partameter transmitted to a document.
ParameterCollection | Represent collection of document parameters.
Picture | Represents a picture control.
ProcessRecordEventArgs | Represents data about the processing of the source data records
RegularBand | Base class for standard bands.
RegularBandBase | Base class for regular bands.
ReportBindableAttribute | Marks the properties that can be bound to an expression.
ReportComponent | Base class for all components in the Report Sharp-Shooter library.
ReportControl | Base class for all controls in the Report Sharp-Shooter library.
ReportControlCollection | Defines a collection of controls in the report.
ReportControlException | The exception that is thrown in ReportControl method.
ReportDataBinding | Provides binding a component's property to a data/expression.
ReportDataBindingCollection | Defines a collection of data bindings in the report.
RichText | Represents rich text control.
Section | The base class for all band controls.
Shape | Defines a shape control.
SideBySide | Represents the SideBySide elemet.
Style | Defines a style for using in a style sheet.
StyleCollection | Defines the collection of styles for a style sheet.
StyleSheet | Defines a style sheet.
SubReport | Represents the SubReport elemet.
SubReportBase | Base class for sub reports.
SubReportParameter | Represents parameters for SubReport element.
SubReportParameterCollection | Represents collection of SubReportParameter.
TextBox | Represents a boxed text control.
TextControl | Base class for text elements.
VisualControl | Base class for all visual controls.
Widget | Provides report element for displaying an instrument from Instrumentation ModelKit.
WinFormsControl | Represents a Windows Forms control.
ZipCode | Represents a ZIP code control.

Interfaces

Interface | Description
IContainerControl | Defines common interface for all container controls.
IDataBand | Defines common interface for all data-aware bands.
IRegularBand | Defines common interface for all standard bands.

Delegates

Delegate | Description
CalculateSubReportParameterEventHandler | Represents the method that will handle the CalculateParameters event.

Enumerations

Enumeration | Description
AggregateDataType | Enumerates aggregeted data type.
FindDirection | Specifies search direction for FindText operations.
FindScope | Specifies the scope for FindText operations.
PageBandMode | Specifies rendering modes for PageBand.
PageOrientation | Specifies page orientation.
PaperKind | Specifies paper kinds.
PictureSizeMode | Specifies drawing modes for a picture.
ScriptLanguage | Specifies the script language for the report template.


AdvancedText Class

[image]

.NET ModelKit Suite ClassReference
AdvancedText Class
Members See Also Send Feedback
Represents a boxed text control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class AdvancedText : TextControl
Visual Basic (Declaration)
Public Class AdvancedText _
    Inherits TextControl
Visual C++
public ref class AdvancedText : public TextControl

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.VisualControl
PerpetuumSoft.Reporting.DOM..::.Box
PerpetuumSoft.Reporting.DOM..::.TextControl
PerpetuumSoft.Reporting.DOM..::.AdvancedText

See Also

AdvancedText Members
PerpetuumSoft.Reporting.DOM Namespace


AdvancedText Members

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedText Members
AdvancedText Class Constructors Methods Fields Properties Events See Also Send Feedback

The AdvancedText type exposes the following members.

Constructors

Name | Description
AdvancedText | Creates a new instance of AdvancedText class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the final rendered control. (Inherited from TextControl.)
CalculateTextHeight | Returns text height. (Overrides TextControl..::.CalculateTextHeight(Graphics).)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Overridden. See CreateBlankControl()()(). (Overrides ReportControl..::.CreateBlankControl()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Overridden. See FindText(String, FindTextOptions). (Overrides ReportControl..::.FindText(String, FindTextOptions).)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateValues | Raises the CalculateValues event.
OnFillChanged | Is called after the Fill property is changed. (Inherited from Box.)
OnFontChanged | Executes if font was changed. (Overrides TextControl..::.OnFontChanged()()().)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Overrides ReportControl..::.OnSizeChanged()()().)
OnStyleNameChanged | Executes if style name was changed. (Overrides ReportControl..::.OnStyleNameChanged()()().)
OnTextAlignmentChanged | Executes if text alignment was changed. (Overrides TextControl..::.OnTextAlignmentChanged()()().)
OnTextFillChanged | Executes if text fill was changed. (Overrides TextControl..::.OnTextFillChanged()()().)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Paints text control content. (Inherited from TextControl.)
PaintText | Paints control text. (Overrides TextControl..::.PaintText(Graphics, Brush, VectorRectangle).)
PopulateProperties | Fills the properties of the final rendered control. (Overrides TextControl..::.PopulateProperties(ReportControl).)
Prepare | Overridded. See Prepare()()(). (Overrides ReportControl..::.Prepare()()().)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateValues | Invokes OnCalculateValues method.
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
RunPropertyDesigner | Overridden. See RunPropertyDesigner(IReportDesignerService). (Overrides ReportControlRunPropertyDesigner(IReportDesignerService).)
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DefaultFont | Default font. (Inherited from TextControl.)

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanBreak | Implements CanBreak()()().
CanGrow | Gets and sets whether the control can grow in size during rendering to match a bigger size of its rendered content regardless of the control's size in the report template. (Inherited from TextControl.)
CanShrink | Gets and sets whether the control can shrink in size during rendering to match a smaller size of its rendered content regardless of the control's size in the report template. (Inherited from TextControl.)
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
Font | Gets and sets the font for the text control. (Inherited from TextControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
RightToLeft | Indicates whether the control text is printed right-to-left. (Inherited from TextControl.)
Rtf | Sets RTF formatted text.
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
Text | Gets or sets HTML formatted text.
TextAlign | Gets and sets alignment for the text. (Inherited from TextControl.)
TextFill | Gets and sets the pattern for filling the text. (Inherited from TextControl.)
TextFormat | Gets and sets the text format for the text control. (Inherited from TextControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
CalculateValues | Occurs when a Values recalculated.
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


AdvancedText Constructor

[image]

.NET ModelKit Suite ClassReference
AdvancedText Constructor
AdvancedText Class See Also Send Feedback
Creates a new instance of AdvancedText class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public AdvancedText()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AdvancedText()

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


AdvancedText Fields

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedText Fields
AdvancedText Class See Also Send Feedback

The AdvancedText type exposes the following members.

Fields

Name | Description
DefaultFont | Default font. (Inherited from TextControl.)

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


AdvancedText Methods

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedText Methods
AdvancedText Class See Also Send Feedback

The AdvancedText type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the final rendered control. (Inherited from TextControl.)
CalculateTextHeight | Returns text height. (Overrides TextControl..::.CalculateTextHeight(Graphics).)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Overridden. See CreateBlankControl()()(). (Overrides ReportControl..::.CreateBlankControl()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Overridden. See FindText(String, FindTextOptions). (Overrides ReportControl..::.FindText(String, FindTextOptions).)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateValues | Raises the CalculateValues event.
OnFillChanged | Is called after the Fill property is changed. (Inherited from Box.)
OnFontChanged | Executes if font was changed. (Overrides TextControl..::.OnFontChanged()()().)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Overrides ReportControl..::.OnSizeChanged()()().)
OnStyleNameChanged | Executes if style name was changed. (Overrides ReportControl..::.OnStyleNameChanged()()().)
OnTextAlignmentChanged | Executes if text alignment was changed. (Overrides TextControl..::.OnTextAlignmentChanged()()().)
OnTextFillChanged | Executes if text fill was changed. (Overrides TextControl..::.OnTextFillChanged()()().)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Paints text control content. (Inherited from TextControl.)
PaintText | Paints control text. (Overrides TextControl..::.PaintText(Graphics, Brush, VectorRectangle).)
PopulateProperties | Fills the properties of the final rendered control. (Overrides TextControl..::.PopulateProperties(ReportControl).)
Prepare | Overridded. See Prepare()()(). (Overrides ReportControl..::.Prepare()()().)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateValues | Invokes OnCalculateValues method.
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
RunPropertyDesigner | Overridden. See RunPropertyDesigner(IReportDesignerService). (Overrides ReportControlRunPropertyDesigner(IReportDesignerService).)
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateTextHeight Method

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.CalculateTextHeight Method
AdvancedText Class See Also Send Feedback
Returns text height.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override float CalculateTextHeight(
    Graphics g
)
Visual Basic (Declaration)
Protected Overrides Function CalculateTextHeight ( _
    g As Graphics _
) As Single
Visual C++
protected:
virtual float CalculateTextHeight(
    Graphics^ g
) override

Parameters

g
Type: System.Drawing..::.Graphics

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


CreateBlankControl Method

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.CreateBlankControl Method
AdvancedText Class See Also Send Feedback
Overridden. See CreateBlankControl()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override ReportControl CreateBlankControl()
Visual Basic (Declaration)
Protected Overrides Function CreateBlankControl As ReportControl
Visual C++
protected:
virtual ReportControl^ CreateBlankControl() override

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


FindText Method

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.FindText Method
AdvancedText Class See Also Send Feedback
Overridden. See FindText(String, FindTextOptions).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool FindText(
    string pattern,
    FindTextOptions options
)
Visual Basic (Declaration)
Public Overrides Function FindText ( _
    pattern As String, _
    options As FindTextOptions _
) As Boolean
Visual C++
public:
virtual bool FindText(
    String^ pattern,
    FindTextOptions^ options
) override

Parameters

pattern
Type: System..::.String
options
Type: PerpetuumSoft.Reporting.DOM..::.FindTextOptions

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedText..::.GetScripts Method
AdvancedText Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Overrides ReportControl..::.GetScripts(ScriptInfoCollection).)

See Also

AdvancedText Class
AdvancedText Members
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method (ScriptInfoCollection)

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.GetScripts Method (ScriptInfoCollection)
AdvancedText Class See Also Send Feedback
Fills the specified collection with all scripts assigned to the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void GetScripts(
    ScriptInfoCollection scripts
)
Visual Basic (Declaration)
Public Overrides Sub GetScripts ( _
    scripts As ScriptInfoCollection _
)
Visual C++
public:
virtual void GetScripts(
    ScriptInfoCollection^ scripts
) override

Parameters

scripts
Type: PerpetuumSoft.Reporting.Rendering..::.ScriptInfoCollection

See Also

AdvancedText Class
GetScripts Overload
PerpetuumSoft.Reporting.DOM Namespace


OnCalculateValues Method

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.OnCalculateValues Method
AdvancedText Class See Also Send Feedback
Raises the CalculateValues event.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnCalculateValues(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnCalculateValues ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnCalculateValues(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


OnFontChanged Method

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.OnFontChanged Method
AdvancedText Class See Also Send Feedback
Executes if font was changed.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnFontChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnFontChanged
Visual C++
protected:
virtual void OnFontChanged() override

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


OnSizeChanged Method

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.OnSizeChanged Method
AdvancedText Class See Also Send Feedback
Is called after the Size property is changed.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnSizeChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnSizeChanged
Visual C++
protected:
virtual void OnSizeChanged() override

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


OnStyleNameChanged Method

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.OnStyleNameChanged Method
AdvancedText Class See Also Send Feedback
Executes if style name was changed.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnStyleNameChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnStyleNameChanged
Visual C++
protected:
virtual void OnStyleNameChanged() override

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


OnTextAlignmentChanged Method

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.OnTextAlignmentChanged Method
AdvancedText Class See Also Send Feedback
Executes if text alignment was changed.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnTextAlignmentChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnTextAlignmentChanged
Visual C++
protected:
virtual void OnTextAlignmentChanged() override

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


OnTextFillChanged Method

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.OnTextFillChanged Method
AdvancedText Class See Also Send Feedback
Executes if text fill was changed.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnTextFillChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnTextFillChanged
Visual C++
protected:
virtual void OnTextFillChanged() override

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


PaintText Method

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.PaintText Method
AdvancedText Class See Also Send Feedback
Paints control text.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PaintText(
    Graphics g,
    Brush textBrush,
    VectorRectangle textRect
)
Visual Basic (Declaration)
Protected Overrides Sub PaintText ( _
    g As Graphics, _
    textBrush As Brush, _
    textRect As VectorRectangle _
)
Visual C++
protected:
virtual void PaintText(
    Graphics^ g,
    Brush^ textBrush,
    VectorRectangle textRect
) override

Parameters

g
Type: System.Drawing..::.Graphics
textBrush
Type: System.Drawing..::.Brush
textRect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


PopulateProperties Method

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.PopulateProperties Method
AdvancedText Class See Also Send Feedback
Fills the properties of the final rendered control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PopulateProperties(
    ReportControl production
)
Visual Basic (Declaration)
Protected Overrides Sub PopulateProperties ( _
    production As ReportControl _
)
Visual C++
protected:
virtual void PopulateProperties(
    ReportControl^ production
) override

Parameters

production
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


Prepare Method

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.Prepare Method
AdvancedText Class See Also Send Feedback
Overridded. See Prepare()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Prepare()
Visual Basic (Declaration)
Public Overrides Sub Prepare
Visual C++
public:
virtual void Prepare() override

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


RaiseCalculateValues Method

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.RaiseCalculateValues Method
AdvancedText Class See Also Send Feedback
Invokes OnCalculateValues method.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected void RaiseCalculateValues()
Visual Basic (Declaration)
Protected Sub RaiseCalculateValues
Visual C++
protected:
void RaiseCalculateValues()

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.Render Method
AdvancedText Class See Also Send Feedback
Renders the control to the final document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


RunPropertyDesigner Method

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.RunPropertyDesigner Method
AdvancedText Class See Also Send Feedback
Overridden. See RunPropertyDesigner(IReportDesignerService).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void RunPropertyDesigner(
    IReportDesignerService service
)
Visual Basic (Declaration)
Public Overrides Sub RunPropertyDesigner ( _
    service As IReportDesignerService _
)
Visual C++
public:
virtual void RunPropertyDesigner(
    IReportDesignerService^ service
) override

Parameters

service
Type: PerpetuumSoft.Reporting.Designer..::.IReportDesignerService

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


AdvancedText Properties

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedText Properties
AdvancedText Class See Also Send Feedback

The AdvancedText type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanBreak | Implements CanBreak()()().
CanGrow | Gets and sets whether the control can grow in size during rendering to match a bigger size of its rendered content regardless of the control's size in the report template. (Inherited from TextControl.)
CanShrink | Gets and sets whether the control can shrink in size during rendering to match a smaller size of its rendered content regardless of the control's size in the report template. (Inherited from TextControl.)
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
Font | Gets and sets the font for the text control. (Inherited from TextControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
RightToLeft | Indicates whether the control text is printed right-to-left. (Inherited from TextControl.)
Rtf | Sets RTF formatted text.
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
Text | Gets or sets HTML formatted text.
TextAlign | Gets and sets alignment for the text. (Inherited from TextControl.)
TextFill | Gets and sets the pattern for filling the text. (Inherited from TextControl.)
TextFormat | Gets and sets the text format for the text control. (Inherited from TextControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


CanBreak Property

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.CanBreak Property
AdvancedText Class See Also Send Feedback
Implements CanBreak()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool CanBreak { get; set; }
Visual Basic (Declaration)
Public Property CanBreak As Boolean
Visual C++
public:
virtual property bool CanBreak {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


Rtf Property

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.Rtf Property
AdvancedText Class See Also Send Feedback
Sets RTF formatted text.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Rtf { set; }
Visual Basic (Declaration)
Public WriteOnly Property Rtf As String
Visual C++
public:
property String^ Rtf {
    void set (String^ value);
}

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


Text Property

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.Text Property
AdvancedText Class See Also Send Feedback
Gets or sets HTML formatted text.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


AdvancedText Events

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedText Events
AdvancedText Class See Also Send Feedback

The AdvancedText type exposes the following members.

Events

Name | Description
CalculateValues | Occurs when a Values recalculated.
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateValues Event

[image]

.NET ModelKit Suite ClassReference
AdvancedText..::.CalculateValues Event
AdvancedText Class See Also Send Feedback
Occurs when a Values recalculated.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler CalculateValues
Visual Basic (Declaration)
Public Event CalculateValues As EventHandler
Visual C++
public:
 event EventHandler^ CalculateValues {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

AdvancedText Class
PerpetuumSoft.Reporting.DOM Namespace


Aggregate Class

[image]

.NET ModelKit Suite ClassReference
Aggregate Class
Members See Also Send Feedback
Summary description for Aggregate.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Aggregate : ICloneable
Visual Basic (Declaration)
Public Class Aggregate _
    Implements ICloneable
Visual C++
public ref class Aggregate : ICloneable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.Aggregate

See Also

Aggregate Members
PerpetuumSoft.Reporting.DOM Namespace


Aggregate Members

[image] [image]

.NET ModelKit Suite ClassReference
Aggregate Members
Aggregate Class Constructors Methods Properties See Also Send Feedback

The Aggregate type exposes the following members.

Constructors

Name | Description
Aggregate | Creates a new instance of Aggregate class.

Methods

Name | Description
ClearRecords | Clear all records in aggregate.
Clone | Implements Clone()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns aggregate name. (Overrides Object..::.ToString()()().)

Properties

Name | Description
DataType | Gets and sets type of the aggregate.
Expression | Gets and sets aggregate expression.
Groups | Gets a aggrgate groups collection.
Name | Gets and sets the name of the aggregate.
Running | Returns a value indicating whether the agrregate should be calculated on the second pass.
Value | Gets and sets aggregated value.

See Also

Aggregate Class
PerpetuumSoft.Reporting.DOM Namespace


Aggregate Constructor

[image]

.NET ModelKit Suite ClassReference
Aggregate Constructor
Aggregate Class See Also Send Feedback
Creates a new instance of Aggregate class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Aggregate()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Aggregate()

See Also

Aggregate Class
PerpetuumSoft.Reporting.DOM Namespace


Aggregate Methods

[image] [image]

.NET ModelKit Suite ClassReference
Aggregate Methods
Aggregate Class See Also Send Feedback

The Aggregate type exposes the following members.

Methods

Name | Description
ClearRecords | Clear all records in aggregate.
Clone | Implements Clone()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns aggregate name. (Overrides Object..::.ToString()()().)

See Also

Aggregate Class
PerpetuumSoft.Reporting.DOM Namespace


ClearRecords Method

[image]

.NET ModelKit Suite ClassReference
Aggregate..::.ClearRecords Method
Aggregate Class See Also Send Feedback
Clear all records in aggregate.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void ClearRecords()
Visual Basic (Declaration)
Public Sub ClearRecords
Visual C++
public:
void ClearRecords()

See Also

Aggregate Class
PerpetuumSoft.Reporting.DOM Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
Aggregate..::.Clone Method
Aggregate Class See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Implements

ICloneable..::.Clone()()()

See Also

Aggregate Class
PerpetuumSoft.Reporting.DOM Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
Aggregate..::.ToString Method
Aggregate Class See Also Send Feedback
Returns aggregate name.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Aggregate Class
PerpetuumSoft.Reporting.DOM Namespace


Aggregate Properties

[image] [image]

.NET ModelKit Suite ClassReference
Aggregate Properties
Aggregate Class See Also Send Feedback

The Aggregate type exposes the following members.

Properties

Name | Description
DataType | Gets and sets type of the aggregate.
Expression | Gets and sets aggregate expression.
Groups | Gets a aggrgate groups collection.
Name | Gets and sets the name of the aggregate.
Running | Returns a value indicating whether the agrregate should be calculated on the second pass.
Value | Gets and sets aggregated value.

See Also

Aggregate Class
PerpetuumSoft.Reporting.DOM Namespace


DataType Property

[image]

.NET ModelKit Suite ClassReference
Aggregate..::.DataType Property
Aggregate Class See Also Send Feedback
Gets and sets type of the aggregate.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public AggregateDataType DataType { get; set; }
Visual Basic (Declaration)
Public Property DataType As AggregateDataType
Visual C++
public:
property AggregateDataType DataType {
    AggregateDataType get ();
    void set (AggregateDataType value);
}

See Also

Aggregate Class
PerpetuumSoft.Reporting.DOM Namespace


Expression Property

[image]

.NET ModelKit Suite ClassReference
Aggregate..::.Expression Property
Aggregate Class See Also Send Feedback
Gets and sets aggregate expression.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

See Also

Aggregate Class
PerpetuumSoft.Reporting.DOM Namespace


Groups Property

[image]

.NET ModelKit Suite ClassReference
Aggregate..::.Groups Property
Aggregate Class See Also Send Feedback
Gets a aggrgate groups collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public AggregateGroupCollection Groups { get; }
Visual Basic (Declaration)
Public ReadOnly Property Groups As AggregateGroupCollection
Visual C++
public:
property AggregateGroupCollection^ Groups {
    AggregateGroupCollection^ get ();
}

See Also

Aggregate Class
PerpetuumSoft.Reporting.DOM Namespace


Name Property

[image]

.NET ModelKit Suite ClassReference
Aggregate..::.Name Property
Aggregate Class See Also Send Feedback
Gets and sets the name of the aggregate.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Aggregate Class
PerpetuumSoft.Reporting.DOM Namespace


Running Property

[image]

.NET ModelKit Suite ClassReference
Aggregate..::.Running Property
Aggregate Class See Also Send Feedback
Returns a value indicating whether the agrregate should be calculated on the second pass.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Running { get; set; }
Visual Basic (Declaration)
Public Property Running As Boolean
Visual C++
public:
property bool Running {
    bool get ();
    void set (bool value);
}

See Also

Aggregate Class
PerpetuumSoft.Reporting.DOM Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
Aggregate..::.Value Property
Aggregate Class See Also Send Feedback
Gets and sets aggregated value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

Aggregate Class
PerpetuumSoft.Reporting.DOM Namespace


AggregateCollection Class

[image]

.NET ModelKit Suite ClassReference
AggregateCollection Class
Members See Also Send Feedback
Represents the collection of Aggregate objects.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
[SerializableAttribute]
public class AggregateCollection : CollectionBase
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class AggregateCollection _
    Inherits CollectionBase
Visual C++
[SerializableAttribute]
public ref class AggregateCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Reporting.DOM..::.AggregateCollection

See Also

AggregateCollection Members
PerpetuumSoft.Reporting.DOM Namespace


AggregateCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateCollection Members
AggregateCollection Class Constructors Methods Properties See Also Send Feedback

The AggregateCollection type exposes the following members.

Constructors

Name | Description
AggregateCollection | Creates a new instance of AggregateCollection class.

Methods

Name | Description
Add | Adds the specified Aggregate to the end of the collection.
AddRange | Adds the specified array Aggregate objects to the end of the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the object already exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified object's index in the collection.
Insert | Inserts the specified object to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified Aggregate from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

AggregateCollection Class
PerpetuumSoft.Reporting.DOM Namespace


AggregateCollection Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateCollection Constructor
AggregateCollection Class See Also Send Feedback
Creates a new instance of AggregateCollection class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public AggregateCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AggregateCollection()

See Also

AggregateCollection Class
PerpetuumSoft.Reporting.DOM Namespace


AggregateCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateCollection Methods
AggregateCollection Class See Also Send Feedback

The AggregateCollection type exposes the following members.

Methods

Name | Description
Add | Adds the specified Aggregate to the end of the collection.
AddRange | Adds the specified array Aggregate objects to the end of the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the object already exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified object's index in the collection.
Insert | Inserts the specified object to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified Aggregate from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AggregateCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
AggregateCollection..::.Add Method
AggregateCollection Class See Also Send Feedback
Adds the specified Aggregate to the end of the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Aggregate Add(
    Aggregate value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As Aggregate _
) As Aggregate
Visual C++
public:
Aggregate^ Add(
    Aggregate^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.Aggregate

See Also

AggregateCollection Class
PerpetuumSoft.Reporting.DOM Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
AggregateCollection..::.AddRange Method
AggregateCollection Class See Also Send Feedback
Adds the specified array Aggregate objects to the end of the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    Aggregate[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As Aggregate() _
)
Visual C++
public:
void AddRange(
    array<Aggregate^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Reporting.DOM..::.Aggregate >[]()[]

See Also

AggregateCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
AggregateCollection..::.Contains Method
AggregateCollection Class See Also Send Feedback
Returns whether the object already exists in the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    Aggregate value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As Aggregate _
) As Boolean
Visual C++
public:
bool Contains(
    Aggregate^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.Aggregate

See Also

AggregateCollection Class
PerpetuumSoft.Reporting.DOM Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
AggregateCollection..::.IndexOf Method
AggregateCollection Class See Also Send Feedback
Returns the specified object's index in the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    Aggregate value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As Aggregate _
) As Integer
Visual C++
public:
int IndexOf(
    Aggregate^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.Aggregate

See Also

AggregateCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
AggregateCollection..::.Insert Method
AggregateCollection Class See Also Send Feedback
Inserts the specified object to the collection at the specified index.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    Aggregate value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As Aggregate _
)
Visual C++
public:
void Insert(
    int index,
    Aggregate^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Reporting.DOM..::.Aggregate

See Also

AggregateCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
AggregateCollection..::.Remove Method
AggregateCollection Class See Also Send Feedback
Removes the specified Aggregate from the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    Aggregate value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As Aggregate _
)
Visual C++
public:
void Remove(
    Aggregate^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.Aggregate

See Also

AggregateCollection Class
PerpetuumSoft.Reporting.DOM Namespace


AggregateCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateCollection Properties
AggregateCollection Class See Also Send Feedback

The AggregateCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

AggregateCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Item Property

[image] [image]

.NET ModelKit Suite ClassReference
AggregateCollection..::.Item Property
AggregateCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets the object at the specified index.
Item[([(String])]) | Gets the object with the specified name.

See Also

AggregateCollection Class
AggregateCollection Members
PerpetuumSoft.Reporting.DOM Namespace


Item Property (Int32)

[image]

.NET ModelKit Suite ClassReference
AggregateCollection..::.Item Property (Int32)
AggregateCollection Class See Also Send Feedback
Gets the object at the specified index.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Aggregate this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Aggregate
Visual C++
public:
property Aggregate^ default[int index] {
    Aggregate^ get (int index);
    void set (int index, Aggregate^ value);
}

Parameters

index
Type: System..::.Int32

See Also

AggregateCollection Class
Item Overload
PerpetuumSoft.Reporting.DOM Namespace


Item Property (String)

[image]

.NET ModelKit Suite ClassReference
AggregateCollection..::.Item Property (String)
AggregateCollection Class See Also Send Feedback
Gets the object with the specified name.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Aggregate this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As Aggregate
Visual C++
public:
property Aggregate^ default[String^ name] {
    Aggregate^ get (String^ name);
}

Parameters

name
Type: System..::.String

See Also

AggregateCollection Class
Item Overload
PerpetuumSoft.Reporting.DOM Namespace


AggregateDataType Enumeration

[image]

.NET ModelKit Suite ClassReference
AggregateDataType Enumeration
See Also Send Feedback
Enumerates aggregeted data type.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum AggregateDataType
Visual Basic (Declaration)
Public Enumeration AggregateDataType
Visual C++
public enum class AggregateDataType

Members

Member name | Description
Integer | Aggregate as integer.
Double | Aggregate as double.
Decimal | Aggregate as decimal.

See Also

PerpetuumSoft.Reporting.DOM Namespace


AggregateGroup Class

[image]

.NET ModelKit Suite ClassReference
AggregateGroup Class
Members See Also Send Feedback
Summary description for AggregateGroup.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class AggregateGroup : ICloneable
Visual Basic (Declaration)
Public Class AggregateGroup _
    Implements ICloneable
Visual C++
public ref class AggregateGroup : ICloneable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.AggregateGroup

See Also

AggregateGroup Members
PerpetuumSoft.Reporting.DOM Namespace


AggregateGroup Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateGroup Members
AggregateGroup Class Constructors Methods Properties See Also Send Feedback

The AggregateGroup type exposes the following members.

Constructors

Name | Description
AggregateGroup | Creates a new instance of AggregateGroup class.

Methods

Name | Description
Clone | Implements Clone()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Expression | Gets and sets group expression.
Value | Gets and sets group value.

See Also

AggregateGroup Class
PerpetuumSoft.Reporting.DOM Namespace


AggregateGroup Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateGroup Constructor
AggregateGroup Class See Also Send Feedback
Creates a new instance of AggregateGroup class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public AggregateGroup()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AggregateGroup()

See Also

AggregateGroup Class
PerpetuumSoft.Reporting.DOM Namespace


AggregateGroup Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateGroup Methods
AggregateGroup Class See Also Send Feedback

The AggregateGroup type exposes the following members.

Methods

Name | Description
Clone | Implements Clone()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AggregateGroup Class
PerpetuumSoft.Reporting.DOM Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
AggregateGroup..::.Clone Method
AggregateGroup Class See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Implements

ICloneable..::.Clone()()()

See Also

AggregateGroup Class
PerpetuumSoft.Reporting.DOM Namespace


AggregateGroup Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateGroup Properties
AggregateGroup Class See Also Send Feedback

The AggregateGroup type exposes the following members.

Properties

Name | Description
Expression | Gets and sets group expression.
Value | Gets and sets group value.

See Also

AggregateGroup Class
PerpetuumSoft.Reporting.DOM Namespace


Expression Property

[image]

.NET ModelKit Suite ClassReference
AggregateGroup..::.Expression Property
AggregateGroup Class See Also Send Feedback
Gets and sets group expression.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

See Also

AggregateGroup Class
PerpetuumSoft.Reporting.DOM Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
AggregateGroup..::.Value Property
AggregateGroup Class See Also Send Feedback
Gets and sets group value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

AggregateGroup Class
PerpetuumSoft.Reporting.DOM Namespace


AggregateGroupCollection Class

[image]

.NET ModelKit Suite ClassReference
AggregateGroupCollection Class
Members See Also Send Feedback
Represents the collection of AggregateGroup objects.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
[SerializableAttribute]
public class AggregateGroupCollection : CollectionBase
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class AggregateGroupCollection _
    Inherits CollectionBase
Visual C++
[SerializableAttribute]
public ref class AggregateGroupCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Reporting.DOM..::.AggregateGroupCollection

See Also

AggregateGroupCollection Members
PerpetuumSoft.Reporting.DOM Namespace


AggregateGroupCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregateGroupCollection Members
AggregateGroupCollection Class Constructors Methods Properties See Also Send Feedback

The AggregateGroupCollection type exposes the following members.

Constructors

Name | Description
AggregateGroupCollection | Creates a new instance of AggregateGroupCollection class.

Methods

Name | Description
Add | Adds the specified AggregateGroup to the end of the collection.
AddRange | Adds the specified array AggregateGroup objects to the end of the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the object already exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified object's index in the collection.
Insert | Inserts the specified object to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified AggregateGroup from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets the object at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

AggregateGroupCollection Class
PerpetuumSoft.Reporting.DOM Namespace


AggregateGroupCollection Constructor

[image]

.NET ModelKit Suite ClassReference
AggregateGroupCollection Constructor
AggregateGroupCollection Class See Also Send Feedback
Creates a new instance of AggregateGroupCollection class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public AggregateGroupCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AggregateGroupCollection()

See Also

AggregateGroupCollection Class
PerpetuumSoft.Reporting.DOM Namespace


AggregateGroupCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregateGroupCollection Methods
AggregateGroupCollection Class See Also Send Feedback

The AggregateGroupCollection type exposes the following members.

Methods

Name | Description
Add | Adds the specified AggregateGroup to the end of the collection.
AddRange | Adds the specified array AggregateGroup objects to the end of the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the object already exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified object's index in the collection.
Insert | Inserts the specified object to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified AggregateGroup from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AggregateGroupCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
AggregateGroupCollection..::.Add Method
AggregateGroupCollection Class See Also Send Feedback
Adds the specified AggregateGroup to the end of the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public AggregateGroup Add(
    AggregateGroup value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As AggregateGroup _
) As AggregateGroup
Visual C++
public:
AggregateGroup^ Add(
    AggregateGroup^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.AggregateGroup

See Also

AggregateGroupCollection Class
PerpetuumSoft.Reporting.DOM Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
AggregateGroupCollection..::.AddRange Method
AggregateGroupCollection Class See Also Send Feedback
Adds the specified array AggregateGroup objects to the end of the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    AggregateGroup[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As AggregateGroup() _
)
Visual C++
public:
void AddRange(
    array<AggregateGroup^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Reporting.DOM..::.AggregateGroup >[]()[]

See Also

AggregateGroupCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
AggregateGroupCollection..::.Contains Method
AggregateGroupCollection Class See Also Send Feedback
Returns whether the object already exists in the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    AggregateGroup value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As AggregateGroup _
) As Boolean
Visual C++
public:
bool Contains(
    AggregateGroup^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.AggregateGroup

See Also

AggregateGroupCollection Class
PerpetuumSoft.Reporting.DOM Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
AggregateGroupCollection..::.IndexOf Method
AggregateGroupCollection Class See Also Send Feedback
Returns the specified object's index in the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    AggregateGroup value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As AggregateGroup _
) As Integer
Visual C++
public:
int IndexOf(
    AggregateGroup^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.AggregateGroup

See Also

AggregateGroupCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
AggregateGroupCollection..::.Insert Method
AggregateGroupCollection Class See Also Send Feedback
Inserts the specified object to the collection at the specified index.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    AggregateGroup value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As AggregateGroup _
)
Visual C++
public:
void Insert(
    int index,
    AggregateGroup^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Reporting.DOM..::.AggregateGroup

See Also

AggregateGroupCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
AggregateGroupCollection..::.Remove Method
AggregateGroupCollection Class See Also Send Feedback
Removes the specified AggregateGroup from the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    AggregateGroup value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As AggregateGroup _
)
Visual C++
public:
void Remove(
    AggregateGroup^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.AggregateGroup

See Also

AggregateGroupCollection Class
PerpetuumSoft.Reporting.DOM Namespace


AggregateGroupCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregateGroupCollection Properties
AggregateGroupCollection Class See Also Send Feedback

The AggregateGroupCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets the object at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

AggregateGroupCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
AggregateGroupCollection..::.Item Property
AggregateGroupCollection Class See Also Send Feedback
Gets the object at the specified index.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public AggregateGroup this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As AggregateGroup
Visual C++
public:
property AggregateGroup^ default[int index] {
    AggregateGroup^ get (int index);
    void set (int index, AggregateGroup^ value);
}

Parameters

index
Type: System..::.Int32

See Also

AggregateGroupCollection Class
PerpetuumSoft.Reporting.DOM Namespace


AggregatesRegularBand Class

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand Class
Members See Also Send Feedback
Base class for regular bands supporting aggregation.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class AggregatesRegularBand : RegularBand
Visual Basic (Declaration)
Public Class AggregatesRegularBand _
    Inherits RegularBand
Visual C++
public ref class AggregatesRegularBand : public RegularBand

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.RegularBandBase
PerpetuumSoft.Reporting.DOM..::.RegularBand
PerpetuumSoft.Reporting.DOM..::.AggregatesRegularBand
PerpetuumSoft.Reporting.DOM..::.DataBandBase
PerpetuumSoft.Reporting.DOM..::.DetailBase

See Also

AggregatesRegularBand Members
PerpetuumSoft.Reporting.DOM Namespace


AggregatesRegularBand Members

[image] [image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand Members
AggregatesRegularBand Class Constructors Methods Properties Events See Also Send Feedback

The AggregatesRegularBand type exposes the following members.

Constructors

Name | Description
AggregatesRegularBand | Initializes a new instance of the AggregatesRegularBand class.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Inherited from Section.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from RegularBandBase.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event.
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation.
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method.
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Overrides ReportControl..::.Render()()().)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band.
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated.
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

AggregatesRegularBand Class
PerpetuumSoft.Reporting.DOM Namespace


AggregatesRegularBand Constructor

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand Constructor
AggregatesRegularBand Class See Also Send Feedback
Initializes a new instance of the AggregatesRegularBand class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public AggregatesRegularBand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AggregatesRegularBand()

See Also

AggregatesRegularBand Class
PerpetuumSoft.Reporting.DOM Namespace


AggregatesRegularBand Methods

[image] [image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand Methods
AggregatesRegularBand Class See Also Send Feedback

The AggregatesRegularBand type exposes the following members.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Inherited from Section.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from RegularBandBase.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event.
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation.
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method.
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Overrides ReportControl..::.Render()()().)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

See Also

AggregatesRegularBand Class
PerpetuumSoft.Reporting.DOM Namespace


Avg Method

[image] [image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Avg Method
AggregatesRegularBand Class See Also Send Feedback

Overload List

Name | Description
Avg(String) | Returns average value.
Avg(Int32, String) | Returns average value.
Avg(String, array<Object>[]()[]) | Returns average value.
Avg(Int32, String, array<Object>[]()[]) | Returns average value.

See Also

AggregatesRegularBand Class
AggregatesRegularBand Members
PerpetuumSoft.Reporting.DOM Namespace


Avg Method (String)

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Avg Method (String)
AggregatesRegularBand Class See Also Send Feedback
Returns average value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Avg(
    string name
)
Visual Basic (Declaration)
Public Function Avg ( _
    name As String _
) As Object
Visual C++
public:
Object^ Avg(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

AggregatesRegularBand Class
Avg Overload
PerpetuumSoft.Reporting.DOM Namespace


Avg Method (Int32, String)

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Avg Method (Int32, String)
AggregatesRegularBand Class See Also Send Feedback
Returns average value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Avg(
    int page,
    string name
)
Visual Basic (Declaration)
Public Function Avg ( _
    page As Integer, _
    name As String _
) As Object
Visual C++
public:
Object^ Avg(
    int page,
    String^ name
)

Parameters

page
Type: System..::.Int32
name
Type: System..::.String

See Also

AggregatesRegularBand Class
Avg Overload
PerpetuumSoft.Reporting.DOM Namespace


Avg Method (String, Object[])

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Avg Method (String, array<Object>[]()[])
AggregatesRegularBand Class See Also Send Feedback
Returns average value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Avg(
    string name,
    params Object[] groups
)
Visual Basic (Declaration)
Public Function Avg ( _
    name As String, _
    ParamArray groups As Object() _
) As Object
Visual C++
public:
Object^ Avg(
    String^ name,
    ... array<Object^>^ groups
)

Parameters

name
Type: System..::.String
groups
Type: array< System..::.Object >[]()[]

See Also

AggregatesRegularBand Class
Avg Overload
PerpetuumSoft.Reporting.DOM Namespace


Avg Method (Int32, String, Object[])

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Avg Method (Int32, String, array<Object>[]()[])
AggregatesRegularBand Class See Also Send Feedback
Returns average value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Avg(
    int page,
    string name,
    params Object[] groups
)
Visual Basic (Declaration)
Public Function Avg ( _
    page As Integer, _
    name As String, _
    ParamArray groups As Object() _
) As Object
Visual C++
public:
Object^ Avg(
    int page,
    String^ name,
    ... array<Object^>^ groups
)

Parameters

page
Type: System..::.Int32
name
Type: System..::.String
groups
Type: array< System..::.Object >[]()[]

See Also

AggregatesRegularBand Class
Avg Overload
PerpetuumSoft.Reporting.DOM Namespace


Count Method

[image] [image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Count Method
AggregatesRegularBand Class See Also Send Feedback

Overload List

Name | Description
Count(String) | Returns records count.
Count(Int32, String) | Returns records count.
Count(String, array<Object>[]()[]) | Returns records count.
Count(Int32, String, array<Object>[]()[]) | Returns records count.

See Also

AggregatesRegularBand Class
AggregatesRegularBand Members
PerpetuumSoft.Reporting.DOM Namespace


Count Method (String)

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Count Method (String)
AggregatesRegularBand Class See Also Send Feedback
Returns records count.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Count(
    string name
)
Visual Basic (Declaration)
Public Function Count ( _
    name As String _
) As Object
Visual C++
public:
Object^ Count(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

AggregatesRegularBand Class
Count Overload
PerpetuumSoft.Reporting.DOM Namespace


Count Method (Int32, String)

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Count Method (Int32, String)
AggregatesRegularBand Class See Also Send Feedback
Returns records count.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Count(
    int page,
    string name
)
Visual Basic (Declaration)
Public Function Count ( _
    page As Integer, _
    name As String _
) As Object
Visual C++
public:
Object^ Count(
    int page,
    String^ name
)

Parameters

page
Type: System..::.Int32
name
Type: System..::.String

See Also

AggregatesRegularBand Class
Count Overload
PerpetuumSoft.Reporting.DOM Namespace


Count Method (String, Object[])

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Count Method (String, array<Object>[]()[])
AggregatesRegularBand Class See Also Send Feedback
Returns records count.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Count(
    string name,
    params Object[] groups
)
Visual Basic (Declaration)
Public Function Count ( _
    name As String, _
    ParamArray groups As Object() _
) As Object
Visual C++
public:
Object^ Count(
    String^ name,
    ... array<Object^>^ groups
)

Parameters

name
Type: System..::.String
groups
Type: array< System..::.Object >[]()[]

See Also

AggregatesRegularBand Class
Count Overload
PerpetuumSoft.Reporting.DOM Namespace


Count Method (Int32, String, Object[])

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Count Method (Int32, String, array<Object>[]()[])
AggregatesRegularBand Class See Also Send Feedback
Returns records count.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Count(
    int page,
    string name,
    params Object[] groups
)
Visual Basic (Declaration)
Public Function Count ( _
    page As Integer, _
    name As String, _
    ParamArray groups As Object() _
) As Object
Visual C++
public:
Object^ Count(
    int page,
    String^ name,
    ... array<Object^>^ groups
)

Parameters

page
Type: System..::.Int32
name
Type: System..::.String
groups
Type: array< System..::.Object >[]()[]

See Also

AggregatesRegularBand Class
Count Overload
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.GetScripts Method
AggregatesRegularBand Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Overridden. See GetScripts(ScriptInfoCollection). (Overrides ReportControl..::.GetScripts(ScriptInfoCollection).)

See Also

AggregatesRegularBand Class
AggregatesRegularBand Members
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method (ScriptInfoCollection)

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.GetScripts Method (ScriptInfoCollection)
AggregatesRegularBand Class See Also Send Feedback
Overridden. See GetScripts(ScriptInfoCollection).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void GetScripts(
    ScriptInfoCollection scripts
)
Visual Basic (Declaration)
Public Overrides Sub GetScripts ( _
    scripts As ScriptInfoCollection _
)
Visual C++
public:
virtual void GetScripts(
    ScriptInfoCollection^ scripts
) override

Parameters

scripts
Type: PerpetuumSoft.Reporting.Rendering..::.ScriptInfoCollection

See Also

AggregatesRegularBand Class
GetScripts Overload
PerpetuumSoft.Reporting.DOM Namespace


Max Method

[image] [image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Max Method
AggregatesRegularBand Class See Also Send Feedback

Overload List

Name | Description
Max(String) | Returns maximum value.
Max(Int32, String) | Returns maximum value.
Max(String, array<Object>[]()[]) | Returns maximum value.
Max(Int32, String, array<Object>[]()[]) | Returns maximum value.

See Also

AggregatesRegularBand Class
AggregatesRegularBand Members
PerpetuumSoft.Reporting.DOM Namespace


Max Method (String)

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Max Method (String)
AggregatesRegularBand Class See Also Send Feedback
Returns maximum value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Max(
    string name
)
Visual Basic (Declaration)
Public Function Max ( _
    name As String _
) As Object
Visual C++
public:
Object^ Max(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

AggregatesRegularBand Class
Max Overload
PerpetuumSoft.Reporting.DOM Namespace


Max Method (Int32, String)

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Max Method (Int32, String)
AggregatesRegularBand Class See Also Send Feedback
Returns maximum value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Max(
    int page,
    string name
)
Visual Basic (Declaration)
Public Function Max ( _
    page As Integer, _
    name As String _
) As Object
Visual C++
public:
Object^ Max(
    int page,
    String^ name
)

Parameters

page
Type: System..::.Int32
name
Type: System..::.String

See Also

AggregatesRegularBand Class
Max Overload
PerpetuumSoft.Reporting.DOM Namespace


Max Method (String, Object[])

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Max Method (String, array<Object>[]()[])
AggregatesRegularBand Class See Also Send Feedback
Returns maximum value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Max(
    string name,
    params Object[] groups
)
Visual Basic (Declaration)
Public Function Max ( _
    name As String, _
    ParamArray groups As Object() _
) As Object
Visual C++
public:
Object^ Max(
    String^ name,
    ... array<Object^>^ groups
)

Parameters

name
Type: System..::.String
groups
Type: array< System..::.Object >[]()[]

See Also

AggregatesRegularBand Class
Max Overload
PerpetuumSoft.Reporting.DOM Namespace


Max Method (Int32, String, Object[])

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Max Method (Int32, String, array<Object>[]()[])
AggregatesRegularBand Class See Also Send Feedback
Returns maximum value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Max(
    int page,
    string name,
    params Object[] groups
)
Visual Basic (Declaration)
Public Function Max ( _
    page As Integer, _
    name As String, _
    ParamArray groups As Object() _
) As Object
Visual C++
public:
Object^ Max(
    int page,
    String^ name,
    ... array<Object^>^ groups
)

Parameters

page
Type: System..::.Int32
name
Type: System..::.String
groups
Type: array< System..::.Object >[]()[]

See Also

AggregatesRegularBand Class
Max Overload
PerpetuumSoft.Reporting.DOM Namespace


Min Method

[image] [image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Min Method
AggregatesRegularBand Class See Also Send Feedback

Overload List

Name | Description
Min(String) | Returns minimum value.
Min(Int32, String) | Returns minimum value.
Min(String, array<Object>[]()[]) | Returns minimum value.
Min(Int32, String, array<Object>[]()[]) | Returns minimum value.

See Also

AggregatesRegularBand Class
AggregatesRegularBand Members
PerpetuumSoft.Reporting.DOM Namespace


Min Method (String)

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Min Method (String)
AggregatesRegularBand Class See Also Send Feedback
Returns minimum value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Min(
    string name
)
Visual Basic (Declaration)
Public Function Min ( _
    name As String _
) As Object
Visual C++
public:
Object^ Min(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

AggregatesRegularBand Class
Min Overload
PerpetuumSoft.Reporting.DOM Namespace


Min Method (Int32, String)

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Min Method (Int32, String)
AggregatesRegularBand Class See Also Send Feedback
Returns minimum value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Min(
    int page,
    string name
)
Visual Basic (Declaration)
Public Function Min ( _
    page As Integer, _
    name As String _
) As Object
Visual C++
public:
Object^ Min(
    int page,
    String^ name
)

Parameters

page
Type: System..::.Int32
name
Type: System..::.String

See Also

AggregatesRegularBand Class
Min Overload
PerpetuumSoft.Reporting.DOM Namespace


Min Method (String, Object[])

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Min Method (String, array<Object>[]()[])
AggregatesRegularBand Class See Also Send Feedback
Returns minimum value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Min(
    string name,
    params Object[] groups
)
Visual Basic (Declaration)
Public Function Min ( _
    name As String, _
    ParamArray groups As Object() _
) As Object
Visual C++
public:
Object^ Min(
    String^ name,
    ... array<Object^>^ groups
)

Parameters

name
Type: System..::.String
groups
Type: array< System..::.Object >[]()[]

See Also

AggregatesRegularBand Class
Min Overload
PerpetuumSoft.Reporting.DOM Namespace


Min Method (Int32, String, Object[])

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Min Method (Int32, String, array<Object>[]()[])
AggregatesRegularBand Class See Also Send Feedback
Returns minimum value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Min(
    int page,
    string name,
    params Object[] groups
)
Visual Basic (Declaration)
Public Function Min ( _
    page As Integer, _
    name As String, _
    ParamArray groups As Object() _
) As Object
Visual C++
public:
Object^ Min(
    int page,
    String^ name,
    ... array<Object^>^ groups
)

Parameters

page
Type: System..::.Int32
name
Type: System..::.String
groups
Type: array< System..::.Object >[]()[]

See Also

AggregatesRegularBand Class
Min Overload
PerpetuumSoft.Reporting.DOM Namespace


OnCalculateAggregates Method

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.OnCalculateAggregates Method
AggregatesRegularBand Class See Also Send Feedback
Raises the CalculateAggregates event.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnCalculateAggregates(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnCalculateAggregates ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnCalculateAggregates(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

See Also

AggregatesRegularBand Class
PerpetuumSoft.Reporting.DOM Namespace


ProcessAggregates Method

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.ProcessAggregates Method
AggregatesRegularBand Class See Also Send Feedback
Forces aggregates calculation.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected void ProcessAggregates()
Visual Basic (Declaration)
Protected Sub ProcessAggregates
Visual C++
protected:
void ProcessAggregates()

See Also

AggregatesRegularBand Class
PerpetuumSoft.Reporting.DOM Namespace


RaiseCalculateAggregates Method

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.RaiseCalculateAggregates Method
AggregatesRegularBand Class See Also Send Feedback
Invokes the OnCalculateAggregates method.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected void RaiseCalculateAggregates()
Visual Basic (Declaration)
Protected Sub RaiseCalculateAggregates
Visual C++
protected:
void RaiseCalculateAggregates()

See Also

AggregatesRegularBand Class
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Render Method
AggregatesRegularBand Class See Also Send Feedback
Overridden. See Render()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

AggregatesRegularBand Class
PerpetuumSoft.Reporting.DOM Namespace


Sum Method

[image] [image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Sum Method
AggregatesRegularBand Class See Also Send Feedback

Overload List

Name | Description
Sum(String) | Returns sum.
Sum(Int32, String) | Returns sum.
Sum(String, array<Object>[]()[]) | Returns sum.
Sum(Int32, String, array<Object>[]()[]) | Returns sum.

See Also

AggregatesRegularBand Class
AggregatesRegularBand Members
PerpetuumSoft.Reporting.DOM Namespace


Sum Method (String)

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Sum Method (String)
AggregatesRegularBand Class See Also Send Feedback
Returns sum.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Sum(
    string name
)
Visual Basic (Declaration)
Public Function Sum ( _
    name As String _
) As Object
Visual C++
public:
Object^ Sum(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

AggregatesRegularBand Class
Sum Overload
PerpetuumSoft.Reporting.DOM Namespace


Sum Method (Int32, String)

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Sum Method (Int32, String)
AggregatesRegularBand Class See Also Send Feedback
Returns sum.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Sum(
    int page,
    string name
)
Visual Basic (Declaration)
Public Function Sum ( _
    page As Integer, _
    name As String _
) As Object
Visual C++
public:
Object^ Sum(
    int page,
    String^ name
)

Parameters

page
Type: System..::.Int32
name
Type: System..::.String

See Also

AggregatesRegularBand Class
Sum Overload
PerpetuumSoft.Reporting.DOM Namespace


Sum Method (String, Object[])

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Sum Method (String, array<Object>[]()[])
AggregatesRegularBand Class See Also Send Feedback
Returns sum.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Sum(
    string name,
    params Object[] groups
)
Visual Basic (Declaration)
Public Function Sum ( _
    name As String, _
    ParamArray groups As Object() _
) As Object
Visual C++
public:
Object^ Sum(
    String^ name,
    ... array<Object^>^ groups
)

Parameters

name
Type: System..::.String
groups
Type: array< System..::.Object >[]()[]

See Also

AggregatesRegularBand Class
Sum Overload
PerpetuumSoft.Reporting.DOM Namespace


Sum Method (Int32, String, Object[])

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Sum Method (Int32, String, array<Object>[]()[])
AggregatesRegularBand Class See Also Send Feedback
Returns sum.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Sum(
    int page,
    string name,
    params Object[] groups
)
Visual Basic (Declaration)
Public Function Sum ( _
    page As Integer, _
    name As String, _
    ParamArray groups As Object() _
) As Object
Visual C++
public:
Object^ Sum(
    int page,
    String^ name,
    ... array<Object^>^ groups
)

Parameters

page
Type: System..::.Int32
name
Type: System..::.String
groups
Type: array< System..::.Object >[]()[]

See Also

AggregatesRegularBand Class
Sum Overload
PerpetuumSoft.Reporting.DOM Namespace


AggregatesRegularBand Properties

[image] [image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand Properties
AggregatesRegularBand Class See Also Send Feedback

The AggregatesRegularBand type exposes the following members.

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band.
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

AggregatesRegularBand Class
PerpetuumSoft.Reporting.DOM Namespace


Aggregates Property

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.Aggregates Property
AggregatesRegularBand Class See Also Send Feedback
Gets a collection of the aggregates associated with the band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
[ObsoleteAttribute("This property is obsolted. Please, use the DataBand.Total property instead.")]
public AggregateCollection Aggregates { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("This property is obsolted. Please, use the DataBand.Total property instead.")> _
Public ReadOnly Property Aggregates As AggregateCollection
Visual C++
[ObsoleteAttribute(L"This property is obsolted. Please, use the DataBand.Total property instead.")]
public:
property AggregateCollection^ Aggregates {
    AggregateCollection^ get ();
}

See Also

AggregatesRegularBand Class
PerpetuumSoft.Reporting.DOM Namespace


AggregatesRegularBand Events

[image] [image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand Events
AggregatesRegularBand Class See Also Send Feedback

The AggregatesRegularBand type exposes the following members.

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated.
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

AggregatesRegularBand Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateAggregates Event

[image]

.NET ModelKit Suite ClassReference
AggregatesRegularBand..::.CalculateAggregates Event
AggregatesRegularBand Class See Also Send Feedback
Occurs when aggregates are recalculated.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler CalculateAggregates
Visual Basic (Declaration)
Public Event CalculateAggregates As EventHandler
Visual C++
public:
 event EventHandler^ CalculateAggregates {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

AggregatesRegularBand Class
PerpetuumSoft.Reporting.DOM Namespace


BandBase Class

[image]

.NET ModelKit Suite ClassReference
BandBase Class
Members See Also Send Feedback
The base class for all band classes in the report generator.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class BandBase : Section
Visual Basic (Declaration)
Public Class BandBase _
    Inherits Section
Visual C++
public ref class BandBase : public Section

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.PageBand
PerpetuumSoft.Reporting.DOM..::.RegularBandBase

See Also

BandBase Members
PerpetuumSoft.Reporting.DOM Namespace


BandBase Members

[image] [image]

.NET ModelKit Suite ClassReference
BandBase Members
BandBase Class Constructors Methods Properties Events See Also Send Feedback

The BandBase type exposes the following members.

Constructors

Name | Description
BandBase | Initializes a new instance of the BandBase class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Overrides ReportControl..::.CalculateRenderHeight()()().)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Overrides ContainerControl..::.ControlAt(PointF).)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Overrides Section..::.GetSectionCaption()()().)
GetSectionCaptionColor | Returns the color of the title bar. (Inherited from Section.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true.
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Returns whether the specified control can be placed into the band. (Inherited from Section.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Overrides ContainerControl..::.OnPaint(PaintArguments).)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Overrides ReportControl..::.ReCalculateBounds(VectorRectangle).)
Render | Renders the control to the final document. (Inherited from ReportControl.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template.
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template.
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode.
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

BandBase Class
PerpetuumSoft.Reporting.DOM Namespace


BandBase Constructor

[image]

.NET ModelKit Suite ClassReference
BandBase Constructor
BandBase Class See Also Send Feedback
Initializes a new instance of the BandBase class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public BandBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BandBase()

See Also

BandBase Class
PerpetuumSoft.Reporting.DOM Namespace


BandBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
BandBase Methods
BandBase Class See Also Send Feedback

The BandBase type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Overrides ReportControl..::.CalculateRenderHeight()()().)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Overrides ContainerControl..::.ControlAt(PointF).)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Overrides Section..::.GetSectionCaption()()().)
GetSectionCaptionColor | Returns the color of the title bar. (Inherited from Section.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true.
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Returns whether the specified control can be placed into the band. (Inherited from Section.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Overrides ContainerControl..::.OnPaint(PaintArguments).)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Overrides ReportControl..::.ReCalculateBounds(VectorRectangle).)
Render | Renders the control to the final document. (Inherited from ReportControl.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

See Also

BandBase Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateRenderHeight Method

[image]

.NET ModelKit Suite ClassReference
BandBase..::.CalculateRenderHeight Method
BandBase Class See Also Send Feedback
Calculates the height of the current band's content in the final report.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void CalculateRenderHeight()
Visual Basic (Declaration)
Protected Overrides Sub CalculateRenderHeight
Visual C++
protected:
virtual void CalculateRenderHeight() override

See Also

BandBase Class
PerpetuumSoft.Reporting.DOM Namespace


ControlAt Method

[image]

.NET ModelKit Suite ClassReference
BandBase..::.ControlAt Method
BandBase Class See Also Send Feedback
Returns a ReportControl object that is found in the location specified by the given PointF.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override ReportControl ControlAt(
    PointF point
)
Visual Basic (Declaration)
Public Overrides Function ControlAt ( _
    point As PointF _
) As ReportControl
Visual C++
public:
virtual ReportControl^ ControlAt(
    PointF point
) override

Parameters

point
Type: System.Drawing..::.PointF

See Also

BandBase Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
BandBase..::.GetScripts Method
BandBase Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

BandBase Class
BandBase Members
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaption Method

[image]

.NET ModelKit Suite ClassReference
BandBase..::.GetSectionCaption Method
BandBase Class See Also Send Feedback
Returns the title string of the band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override string GetSectionCaption()
Visual Basic (Declaration)
Protected Overrides Function GetSectionCaption As String
Visual C++
protected:
virtual String^ GetSectionCaption() override

See Also

BandBase Class
PerpetuumSoft.Reporting.DOM Namespace


GrowControls Method

[image]

.NET ModelKit Suite ClassReference
BandBase..::.GrowControls Method
BandBase Class See Also Send Feedback
Resizes controls within the current band that have the GrowToBottom property set to true.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void GrowControls()
Visual Basic (Declaration)
Protected Overridable Sub GrowControls
Visual C++
protected:
virtual void GrowControls()

See Also

BandBase Class
PerpetuumSoft.Reporting.DOM Namespace


OnPaint Method

[image]

.NET ModelKit Suite ClassReference
BandBase..::.OnPaint Method
BandBase Class See Also Send Feedback
Performs drawing of the band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
protected:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments

See Also

BandBase Class
PerpetuumSoft.Reporting.DOM Namespace


ReCalculateBounds Method

[image]

.NET ModelKit Suite ClassReference
BandBase..::.ReCalculateBounds Method
BandBase Class See Also Send Feedback
Recalculates the bounds of the current band object using all environment constraints and specified current state.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override VectorRectangle ReCalculateBounds(
    VectorRectangle currentBounds
)
Visual Basic (Declaration)
Protected Overrides Function ReCalculateBounds ( _
    currentBounds As VectorRectangle _
) As VectorRectangle
Visual C++
protected:
virtual VectorRectangle ReCalculateBounds(
    VectorRectangle currentBounds
) override

Parameters

currentBounds
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

BandBase Class
PerpetuumSoft.Reporting.DOM Namespace


BandBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
BandBase Properties
BandBase Class See Also Send Feedback

The BandBase type exposes the following members.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template.
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template.
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode.
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

BandBase Class
PerpetuumSoft.Reporting.DOM Namespace


CanGrow Property

[image]

.NET ModelKit Suite ClassReference
BandBase..::.CanGrow Property
BandBase Class See Also Send Feedback
Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool CanGrow { get; set; }
Visual Basic (Declaration)
Public Property CanGrow As Boolean
Visual C++
public:
property bool CanGrow {
    bool get ();
    void set (bool value);
}

See Also

BandBase Class
PerpetuumSoft.Reporting.DOM Namespace


CanShrink Property

[image]

.NET ModelKit Suite ClassReference
BandBase..::.CanShrink Property
BandBase Class See Also Send Feedback
Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool CanShrink { get; set; }
Visual Basic (Declaration)
Public Property CanShrink As Boolean
Visual C++
public:
property bool CanShrink {
    bool get ();
    void set (bool value);
}

See Also

BandBase Class
PerpetuumSoft.Reporting.DOM Namespace


ShowCaption Property

[image]

.NET ModelKit Suite ClassReference
BandBase..::.ShowCaption Property
BandBase Class See Also Send Feedback
Gets or sets whether the title line should be drawn for the current band object in design mode.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowCaption { get; set; }
Visual Basic (Declaration)
Public Property ShowCaption As Boolean
Visual C++
public:
property bool ShowCaption {
    bool get ();
    void set (bool value);
}

See Also

BandBase Class
PerpetuumSoft.Reporting.DOM Namespace


BandBase Events

[image] [image]

.NET ModelKit Suite ClassReference
BandBase Events
BandBase Class See Also Send Feedback

The BandBase type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

BandBase Class
PerpetuumSoft.Reporting.DOM Namespace


BandContainer Class

[image]

.NET ModelKit Suite ClassReference
BandContainer Class
Members See Also Send Feedback
Represents the BandContainer element.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class BandContainer : RegularBand
Visual Basic (Declaration)
Public Class BandContainer _
    Inherits RegularBand
Visual C++
public ref class BandContainer : public RegularBand

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.RegularBandBase
PerpetuumSoft.Reporting.DOM..::.RegularBand
PerpetuumSoft.Reporting.DOM..::.BandContainer

See Also

BandContainer Members
PerpetuumSoft.Reporting.DOM Namespace


BandContainer Members

[image] [image]

.NET ModelKit Suite ClassReference
BandContainer Members
BandContainer Class Constructors Methods Properties Events See Also Send Feedback

The BandContainer type exposes the following members.

Constructors

Name | Description
BandContainer | Initializes a new instance of the BandContainer class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Inherited from Section.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Overrides RegularBandBase..::.IsValidChild(ReportControl).)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Overrides ReportControl..::.Render()()().)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

BandContainer Class
PerpetuumSoft.Reporting.DOM Namespace


BandContainer Constructor

[image]

.NET ModelKit Suite ClassReference
BandContainer Constructor
BandContainer Class See Also Send Feedback
Initializes a new instance of the BandContainer class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public BandContainer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BandContainer()

See Also

BandContainer Class
PerpetuumSoft.Reporting.DOM Namespace


BandContainer Methods

[image] [image]

.NET ModelKit Suite ClassReference
BandContainer Methods
BandContainer Class See Also Send Feedback

The BandContainer type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Inherited from Section.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Overrides RegularBandBase..::.IsValidChild(ReportControl).)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Overrides ReportControl..::.Render()()().)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

See Also

BandContainer Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
BandContainer..::.GetScripts Method
BandContainer Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

BandContainer Class
BandContainer Members
PerpetuumSoft.Reporting.DOM Namespace


IsValidChild Method

[image]

.NET ModelKit Suite ClassReference
BandContainer..::.IsValidChild Method
BandContainer Class See Also Send Feedback
Implements IsValidChild(ReportControl).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValidChild(
    ReportControl c
)
Visual Basic (Declaration)
Public Overrides Function IsValidChild ( _
    c As ReportControl _
) As Boolean
Visual C++
public:
virtual bool IsValidChild(
    ReportControl^ c
) override

Parameters

c
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

Implements

IContainerControl..::.IsValidChild(ReportControl)

See Also

BandContainer Class
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
BandContainer..::.Render Method
BandContainer Class See Also Send Feedback
Overridden. See Render()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

BandContainer Class
PerpetuumSoft.Reporting.DOM Namespace


BandContainer Properties

[image] [image]

.NET ModelKit Suite ClassReference
BandContainer Properties
BandContainer Class See Also Send Feedback

The BandContainer type exposes the following members.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

BandContainer Class
PerpetuumSoft.Reporting.DOM Namespace


BandContainer Events

[image] [image]

.NET ModelKit Suite ClassReference
BandContainer Events
BandContainer Class See Also Send Feedback

The BandContainer type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

BandContainer Class
PerpetuumSoft.Reporting.DOM Namespace


BarCode Class

[image]

.NET ModelKit Suite ClassReference
BarCode Class
Members See Also Send Feedback
Defines a barcode object in report generator.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class BarCode : Box
Visual Basic (Declaration)
Public Class BarCode _
    Inherits Box
Visual C++
public ref class BarCode : public Box

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.VisualControl
PerpetuumSoft.Reporting.DOM..::.Box
PerpetuumSoft.Reporting.DOM..::.BarCode

See Also

BarCode Members
PerpetuumSoft.Reporting.DOM Namespace


BarCode Members

[image] [image]

.NET ModelKit Suite ClassReference
BarCode Members
BarCode Class Constructors Methods Fields Properties Events See Also Send Feedback

The BarCode type exposes the following members.

Constructors

Name | Description
BarCode | Creates a new instance of BarCode class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Overridden. See CreateBlankControl()()(). (Overrides ReportControl..::.CreateBlankControl()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of a Shape object created with visual tools such as Report Designer. (Overrides ReportControl..::.InitNew()()().)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed. (Inherited from Box.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Paints bar code content. (Overrides Box..::.PaintContent(PaintArguments, RectangleF).)
PopulateProperties | Fills the properties of the final rendered control. (Overrides Box..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBackColor | Resets the BackColor property to its default value (transparent).
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
ResetMicroQRCodeSettings |
ResetPdf417Settings |
ResetQRCodeSettings |
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ShouldSerializeBackColor | Returns whether the BackColor property should be persisted.
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ShouldSerializeMicroQRCodeSettings |
ShouldSerializePdf417Settings |
ShouldSerializeQRCodeSettings |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DefaultFont | Default font for bar code label.

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
BackColor | Gets and sets color of spaces between the bars (the backround color).
BarColor | Defines the color of bars (the foreground color).
BarPoint | Detepmines the bar point for japanese postal bar code.
BarRatio | Gets and sets the bar ratio.
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CalcCheckSumm | Gets or sets whether a check sum should be calculated for this BarCode object.
Code | Gets and sets the code for the BarCode control.
CodeType | Defines the type of barcode.
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
Font | Gets and sets the font.
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
LabelPosition | Gets and sets the label position.
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
MicroQRCodeSettings |
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
Pdf417Settings | Gets or sets Pdf417Settings class that represent the PDF417 barcode settings.
QRCodeSettings |
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCheckDigit | Gets or sets whether the check sum digits should be shown in the barcode label.
ShowLabel | Gets or sets whether the label should be drawn for this BarCode object.
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
TextColor | Gets and sets the color of the text label.
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


BarCode Constructor

[image]

.NET ModelKit Suite ClassReference
BarCode Constructor
BarCode Class See Also Send Feedback
Creates a new instance of BarCode class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public BarCode()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BarCode()

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


BarCode Fields

[image] [image]

.NET ModelKit Suite ClassReference
BarCode Fields
BarCode Class See Also Send Feedback

The BarCode type exposes the following members.

Fields

Name | Description
DefaultFont | Default font for bar code label.

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


DefaultFont Field

[image]

.NET ModelKit Suite ClassReference
BarCode..::.DefaultFont Field
BarCode Class See Also Send Feedback
Default font for bar code label.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected readonly FontDescriptor DefaultFont
Visual Basic (Declaration)
Protected ReadOnly DefaultFont As FontDescriptor
Visual C++
protected:
initonly FontDescriptor^ DefaultFont

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


BarCode Methods

[image] [image]

.NET ModelKit Suite ClassReference
BarCode Methods
BarCode Class See Also Send Feedback

The BarCode type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Overridden. See CreateBlankControl()()(). (Overrides ReportControl..::.CreateBlankControl()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of a Shape object created with visual tools such as Report Designer. (Overrides ReportControl..::.InitNew()()().)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed. (Inherited from Box.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Paints bar code content. (Overrides Box..::.PaintContent(PaintArguments, RectangleF).)
PopulateProperties | Fills the properties of the final rendered control. (Overrides Box..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBackColor | Resets the BackColor property to its default value (transparent).
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
ResetMicroQRCodeSettings |
ResetPdf417Settings |
ResetQRCodeSettings |
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ShouldSerializeBackColor | Returns whether the BackColor property should be persisted.
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ShouldSerializeMicroQRCodeSettings |
ShouldSerializePdf417Settings |
ShouldSerializeQRCodeSettings |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


CreateBlankControl Method

[image]

.NET ModelKit Suite ClassReference
BarCode..::.CreateBlankControl Method
BarCode Class See Also Send Feedback
Overridden. See CreateBlankControl()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override ReportControl CreateBlankControl()
Visual Basic (Declaration)
Protected Overrides Function CreateBlankControl As ReportControl
Visual C++
protected:
virtual ReportControl^ CreateBlankControl() override

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
BarCode..::.GetScripts Method
BarCode Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

BarCode Class
BarCode Members
PerpetuumSoft.Reporting.DOM Namespace


InitNew Method

[image]

.NET ModelKit Suite ClassReference
BarCode..::.InitNew Method
BarCode Class See Also Send Feedback
Sets the predefined values for the properties of a Shape object created with visual tools such as Report Designer.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void InitNew()
Visual Basic (Declaration)
Public Overrides Sub InitNew
Visual C++
public:
virtual void InitNew() override

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


PaintContent Method

[image]

.NET ModelKit Suite ClassReference
BarCode..::.PaintContent Method
BarCode Class See Also Send Feedback
Paints bar code content.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PaintContent(
    PaintArguments args,
    RectangleF contentRectangle
)
Visual Basic (Declaration)
Protected Overrides Sub PaintContent ( _
    args As PaintArguments, _
    contentRectangle As RectangleF _
)
Visual C++
protected:
virtual void PaintContent(
    PaintArguments^ args,
    RectangleF contentRectangle
) override

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments
contentRectangle
Type: System.Drawing..::.RectangleF

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


PopulateProperties Method

[image]

.NET ModelKit Suite ClassReference
BarCode..::.PopulateProperties Method
BarCode Class See Also Send Feedback
Fills the properties of the final rendered control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PopulateProperties(
    ReportControl production
)
Visual Basic (Declaration)
Protected Overrides Sub PopulateProperties ( _
    production As ReportControl _
)
Visual C++
protected:
virtual void PopulateProperties(
    ReportControl^ production
) override

Parameters

production
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
BarCode..::.Render Method
BarCode Class See Also Send Feedback
Renders the control to the final document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


ResetBackColor Method

[image]

.NET ModelKit Suite ClassReference
BarCode..::.ResetBackColor Method
BarCode Class See Also Send Feedback
Resets the BackColor property to its default value (transparent).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void ResetBackColor()
Visual Basic (Declaration)
Public Sub ResetBackColor
Visual C++
public:
void ResetBackColor()

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


ResetMicroQRCodeSettings Method

[image]

.NET ModelKit Suite ClassReference
BarCode..::.ResetMicroQRCodeSettings Method
BarCode Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.BarCode.ResetMicroQRCodeSettings]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void ResetMicroQRCodeSettings()
Visual Basic (Declaration)
Public Sub ResetMicroQRCodeSettings
Visual C++
public:
void ResetMicroQRCodeSettings()

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


ResetPdf417Settings Method

[image]

.NET ModelKit Suite ClassReference
BarCode..::.ResetPdf417Settings Method
BarCode Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.BarCode.ResetPdf417Settings]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void ResetPdf417Settings()
Visual Basic (Declaration)
Public Sub ResetPdf417Settings
Visual C++
public:
void ResetPdf417Settings()

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


ResetQRCodeSettings Method

[image]

.NET ModelKit Suite ClassReference
BarCode..::.ResetQRCodeSettings Method
BarCode Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.BarCode.ResetQRCodeSettings]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void ResetQRCodeSettings()
Visual Basic (Declaration)
Public Sub ResetQRCodeSettings
Visual C++
public:
void ResetQRCodeSettings()

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


ShouldSerializeBackColor Method

[image]

.NET ModelKit Suite ClassReference
BarCode..::.ShouldSerializeBackColor Method
BarCode Class See Also Send Feedback
Returns whether the BackColor property should be persisted.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShouldSerializeBackColor()
Visual Basic (Declaration)
Public Function ShouldSerializeBackColor As Boolean
Visual C++
public:
bool ShouldSerializeBackColor()

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


ShouldSerializeMicroQRCodeSettings Method

[image]

.NET ModelKit Suite ClassReference
BarCode..::.ShouldSerializeMicroQRCodeSettings Method
BarCode Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.BarCode.ShouldSerializeMicroQRCodeSettings]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShouldSerializeMicroQRCodeSettings()
Visual Basic (Declaration)
Public Function ShouldSerializeMicroQRCodeSettings As Boolean
Visual C++
public:
bool ShouldSerializeMicroQRCodeSettings()

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


ShouldSerializePdf417Settings Method

[image]

.NET ModelKit Suite ClassReference
BarCode..::.ShouldSerializePdf417Settings Method
BarCode Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.BarCode.ShouldSerializePdf417Settings]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShouldSerializePdf417Settings()
Visual Basic (Declaration)
Public Function ShouldSerializePdf417Settings As Boolean
Visual C++
public:
bool ShouldSerializePdf417Settings()

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


ShouldSerializeQRCodeSettings Method

[image]

.NET ModelKit Suite ClassReference
BarCode..::.ShouldSerializeQRCodeSettings Method
BarCode Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.BarCode.ShouldSerializeQRCodeSettings]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShouldSerializeQRCodeSettings()
Visual Basic (Declaration)
Public Function ShouldSerializeQRCodeSettings As Boolean
Visual C++
public:
bool ShouldSerializeQRCodeSettings()

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


BarCode Properties

[image] [image]

.NET ModelKit Suite ClassReference
BarCode Properties
BarCode Class See Also Send Feedback

The BarCode type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
BackColor | Gets and sets color of spaces between the bars (the backround color).
BarColor | Defines the color of bars (the foreground color).
BarPoint | Detepmines the bar point for japanese postal bar code.
BarRatio | Gets and sets the bar ratio.
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CalcCheckSumm | Gets or sets whether a check sum should be calculated for this BarCode object.
Code | Gets and sets the code for the BarCode control.
CodeType | Defines the type of barcode.
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
Font | Gets and sets the font.
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
LabelPosition | Gets and sets the label position.
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
MicroQRCodeSettings |
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
Pdf417Settings | Gets or sets Pdf417Settings class that represent the PDF417 barcode settings.
QRCodeSettings |
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCheckDigit | Gets or sets whether the check sum digits should be shown in the barcode label.
ShowLabel | Gets or sets whether the label should be drawn for this BarCode object.
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
TextColor | Gets and sets the color of the text label.
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


BackColor Property

[image]

.NET ModelKit Suite ClassReference
BarCode..::.BackColor Property
BarCode Class See Also Send Feedback
Gets and sets color of spaces between the bars (the backround color).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Color BackColor { get; set; }
Visual Basic (Declaration)
Public Property BackColor As Color
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


BarColor Property

[image]

.NET ModelKit Suite ClassReference
BarCode..::.BarColor Property
BarCode Class See Also Send Feedback
Defines the color of bars (the foreground color).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Color BarColor { get; set; }
Visual Basic (Declaration)
Public Property BarColor As Color
Visual C++
public:
property Color BarColor {
    Color get ();
    void set (Color value);
}

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


BarPoint Property

[image]

.NET ModelKit Suite ClassReference
BarCode..::.BarPoint Property
BarCode Class See Also Send Feedback
Detepmines the bar point for japanese postal bar code.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double BarPoint { get; set; }
Visual Basic (Declaration)
Public Property BarPoint As Double
Visual C++
public:
property double BarPoint {
    double get ();
    void set (double value);
}

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


BarRatio Property

[image]

.NET ModelKit Suite ClassReference
BarCode..::.BarRatio Property
BarCode Class See Also Send Feedback
Gets and sets the bar ratio.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public float BarRatio { get; set; }
Visual Basic (Declaration)
Public Property BarRatio As Single
Visual C++
public:
property float BarRatio {
    float get ();
    void set (float value);
}

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


CalcCheckSumm Property

[image]

.NET ModelKit Suite ClassReference
BarCode..::.CalcCheckSumm Property
BarCode Class See Also Send Feedback
Gets or sets whether a check sum should be calculated for this BarCode object.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool CalcCheckSumm { get; set; }
Visual Basic (Declaration)
Public Property CalcCheckSumm As Boolean
Visual C++
public:
property bool CalcCheckSumm {
    bool get ();
    void set (bool value);
}

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


Code Property

[image]

.NET ModelKit Suite ClassReference
BarCode..::.Code Property
BarCode Class See Also Send Feedback
Gets and sets the code for the BarCode control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Code { get; set; }
Visual Basic (Declaration)
Public Property Code As String
Visual C++
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


CodeType Property

[image]

.NET ModelKit Suite ClassReference
BarCode..::.CodeType Property
BarCode Class See Also Send Feedback
Defines the type of barcode.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public BarCodeType CodeType { get; set; }
Visual Basic (Declaration)
Public Property CodeType As BarCodeType
Visual C++
public:
property BarCodeType CodeType {
    BarCodeType get ();
    void set (BarCodeType value);
}

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


Font Property

[image]

.NET ModelKit Suite ClassReference
BarCode..::.Font Property
BarCode Class See Also Send Feedback
Gets and sets the font.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FontDescriptor Font { get; set; }
Visual Basic (Declaration)
Public Property Font As FontDescriptor
Visual C++
public:
property FontDescriptor^ Font {
    FontDescriptor^ get ();
    void set (FontDescriptor^ value);
}

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


LabelPosition Property

[image]

.NET ModelKit Suite ClassReference
BarCode..::.LabelPosition Property
BarCode Class See Also Send Feedback
Gets and sets the label position.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public BarCodeLabelPosition LabelPosition { get; set; }
Visual Basic (Declaration)
Public Property LabelPosition As BarCodeLabelPosition
Visual C++
public:
property BarCodeLabelPosition LabelPosition {
    BarCodeLabelPosition get ();
    void set (BarCodeLabelPosition value);
}

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


MicroQRCodeSettings Property

[image]

.NET ModelKit Suite ClassReference
BarCode..::.MicroQRCodeSettings Property
BarCode Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.DOM.BarCode.MicroQRCodeSettings]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public MicroQRCodeSettings MicroQRCodeSettings { get; set; }
Visual Basic (Declaration)
Public Property MicroQRCodeSettings As MicroQRCodeSettings
Visual C++
public:
property MicroQRCodeSettings^ MicroQRCodeSettings {
    MicroQRCodeSettings^ get ();
    void set (MicroQRCodeSettings^ value);
}

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


Pdf417Settings Property

[image]

.NET ModelKit Suite ClassReference
BarCode..::.Pdf417Settings Property
BarCode Class See Also Send Feedback
Gets or sets Pdf417Settings class that represent the PDF417 barcode settings.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Pdf417Settings Pdf417Settings { get; set; }
Visual Basic (Declaration)
Public Property Pdf417Settings As Pdf417Settings
Visual C++
public:
property Pdf417Settings^ Pdf417Settings {
    Pdf417Settings^ get ();
    void set (Pdf417Settings^ value);
}

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


QRCodeSettings Property

[image]

.NET ModelKit Suite ClassReference
BarCode..::.QRCodeSettings Property
BarCode Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.DOM.BarCode.QRCodeSettings]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public QRCodeSettings QRCodeSettings { get; set; }
Visual Basic (Declaration)
Public Property QRCodeSettings As QRCodeSettings
Visual C++
public:
property QRCodeSettings^ QRCodeSettings {
    QRCodeSettings^ get ();
    void set (QRCodeSettings^ value);
}

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


ShowCheckDigit Property

[image]

.NET ModelKit Suite ClassReference
BarCode..::.ShowCheckDigit Property
BarCode Class See Also Send Feedback
Gets or sets whether the check sum digits should be shown in the barcode label.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowCheckDigit { get; set; }
Visual Basic (Declaration)
Public Property ShowCheckDigit As Boolean
Visual C++
public:
property bool ShowCheckDigit {
    bool get ();
    void set (bool value);
}

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


ShowLabel Property

[image]

.NET ModelKit Suite ClassReference
BarCode..::.ShowLabel Property
BarCode Class See Also Send Feedback
Gets or sets whether the label should be drawn for this BarCode object.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowLabel { get; set; }
Visual Basic (Declaration)
Public Property ShowLabel As Boolean
Visual C++
public:
property bool ShowLabel {
    bool get ();
    void set (bool value);
}

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


TextColor Property

[image]

.NET ModelKit Suite ClassReference
BarCode..::.TextColor Property
BarCode Class See Also Send Feedback
Gets and sets the color of the text label.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Color TextColor { get; set; }
Visual Basic (Declaration)
Public Property TextColor As Color
Visual C++
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


BarCode Events

[image] [image]

.NET ModelKit Suite ClassReference
BarCode Events
BarCode Class See Also Send Feedback

The BarCode type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

BarCode Class
PerpetuumSoft.Reporting.DOM Namespace


Box Class

[image]

.NET ModelKit Suite ClassReference
Box Class
Members See Also Send Feedback
Defines a boxed control with borders and fills.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Box : VisualControl
Visual Basic (Declaration)
Public Class Box _
    Inherits VisualControl
Visual C++
public ref class Box : public VisualControl

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.VisualControl
PerpetuumSoft.Reporting.DOM..::.Box
PerpetuumSoft.Reporting.DOM..::.BarCode
PerpetuumSoft.Reporting.DOM..::.ChartControl
PerpetuumSoft.Reporting.DOM..::.Picture
PerpetuumSoft.Reporting.DOM..::.RichText
PerpetuumSoft.Reporting.DOM..::.TextControl
PerpetuumSoft.Reporting.DOM..::.Widget
PerpetuumSoft.Reporting.DOM..::.WinFormsControl
PerpetuumSoft.Reporting.DOM..::.ZipCode

See Also

Box Members
PerpetuumSoft.Reporting.DOM Namespace


Box Members

[image] [image]

.NET ModelKit Suite ClassReference
Box Members
Box Class Constructors Methods Properties Events See Also Send Feedback

The Box type exposes the following members.

Constructors

Name | Description
Box | Creates a new instance of Box class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle.
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed.
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Overrides ReportControl..::.OnPaint(PaintArguments).)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill.
PaintBorder | Paints a border around the box.
PaintContent | Paint box content.
PopulateProperties | Fills the properties of the final rendered control. (Overrides ReportControl..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Inherited from ReportControl.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value.
ResetFill | Resets the Fill property to its default value.
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ShouldSerializeBorder | Returns whether the Border property should be persisted.
ShouldSerializeFill | Returns whether the Fill property should be persisted.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | Gets or sets the angle of box rotation.
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border.
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings.
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill.
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins.
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


Box Constructor

[image]

.NET ModelKit Suite ClassReference
Box Constructor
Box Class See Also Send Feedback
Creates a new instance of Box class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Box()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Box()

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


Box Methods

[image] [image]

.NET ModelKit Suite ClassReference
Box Methods
Box Class See Also Send Feedback

The Box type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle.
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed.
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Overrides ReportControl..::.OnPaint(PaintArguments).)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill.
PaintBorder | Paints a border around the box.
PaintContent | Paint box content.
PopulateProperties | Fills the properties of the final rendered control. (Overrides ReportControl..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Inherited from ReportControl.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value.
ResetFill | Resets the Fill property to its default value.
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ShouldSerializeBorder | Returns whether the Border property should be persisted.
ShouldSerializeFill | Returns whether the Fill property should be persisted.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


GetRotatedContentRectangle Method

[image]

.NET ModelKit Suite ClassReference
Box..::.GetRotatedContentRectangle Method
Box Class See Also Send Feedback
Returns a given rectangle, rotated on box angle.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected RectangleF GetRotatedContentRectangle(
    RectangleF r
)
Visual Basic (Declaration)
Protected Function GetRotatedContentRectangle ( _
    r As RectangleF _
) As RectangleF
Visual C++
protected:
RectangleF GetRotatedContentRectangle(
    RectangleF r
)

Parameters

r
Type: System.Drawing..::.RectangleF

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
Box..::.GetScripts Method
Box Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

Box Class
Box Members
PerpetuumSoft.Reporting.DOM Namespace


OnFillChanged Method

[image]

.NET ModelKit Suite ClassReference
Box..::.OnFillChanged Method
Box Class See Also Send Feedback
Is called after the Fill property is changed.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnFillChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnFillChanged
Visual C++
protected:
virtual void OnFillChanged()

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


OnPaint Method

[image]

.NET ModelKit Suite ClassReference
Box..::.OnPaint Method
Box Class See Also Send Feedback
Paints the box.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
protected:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


PaintBackground Method

[image]

.NET ModelKit Suite ClassReference
Box..::.PaintBackground Method
Box Class See Also Send Feedback
Paints the background of the box using the current background fill.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected void PaintBackground(
    PaintArguments args
)
Visual Basic (Declaration)
Protected Sub PaintBackground ( _
    args As PaintArguments _
)
Visual C++
protected:
void PaintBackground(
    PaintArguments^ args
)

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


PaintBorder Method

[image]

.NET ModelKit Suite ClassReference
Box..::.PaintBorder Method
Box Class See Also Send Feedback
Paints a border around the box.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected void PaintBorder(
    PaintArguments args
)
Visual Basic (Declaration)
Protected Sub PaintBorder ( _
    args As PaintArguments _
)
Visual C++
protected:
void PaintBorder(
    PaintArguments^ args
)

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


PaintContent Method

[image]

.NET ModelKit Suite ClassReference
Box..::.PaintContent Method
Box Class See Also Send Feedback
Paint box content.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void PaintContent(
    PaintArguments args,
    RectangleF contentRectangle
)
Visual Basic (Declaration)
Protected Overridable Sub PaintContent ( _
    args As PaintArguments, _
    contentRectangle As RectangleF _
)
Visual C++
protected:
virtual void PaintContent(
    PaintArguments^ args,
    RectangleF contentRectangle
)

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments
contentRectangle
Type: System.Drawing..::.RectangleF

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


PopulateProperties Method

[image]

.NET ModelKit Suite ClassReference
Box..::.PopulateProperties Method
Box Class See Also Send Feedback
Fills the properties of the final rendered control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PopulateProperties(
    ReportControl production
)
Visual Basic (Declaration)
Protected Overrides Sub PopulateProperties ( _
    production As ReportControl _
)
Visual C++
protected:
virtual void PopulateProperties(
    ReportControl^ production
) override

Parameters

production
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


ResetBorder Method

[image]

.NET ModelKit Suite ClassReference
Box..::.ResetBorder Method
Box Class See Also Send Feedback
Resets the Border property to its default value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void ResetBorder()
Visual Basic (Declaration)
Public Sub ResetBorder
Visual C++
public:
void ResetBorder()

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


ResetFill Method

[image]

.NET ModelKit Suite ClassReference
Box..::.ResetFill Method
Box Class See Also Send Feedback
Resets the Fill property to its default value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void ResetFill()
Visual Basic (Declaration)
Public Sub ResetFill
Visual C++
public:
void ResetFill()

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


ShouldSerializeBorder Method

[image]

.NET ModelKit Suite ClassReference
Box..::.ShouldSerializeBorder Method
Box Class See Also Send Feedback
Returns whether the Border property should be persisted.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShouldSerializeBorder()
Visual Basic (Declaration)
Public Function ShouldSerializeBorder As Boolean
Visual C++
public:
bool ShouldSerializeBorder()

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


ShouldSerializeFill Method

[image]

.NET ModelKit Suite ClassReference
Box..::.ShouldSerializeFill Method
Box Class See Also Send Feedback
Returns whether the Fill property should be persisted.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShouldSerializeFill()
Visual Basic (Declaration)
Public Function ShouldSerializeFill As Boolean
Visual C++
public:
bool ShouldSerializeFill()

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


Box Properties

[image] [image]

.NET ModelKit Suite ClassReference
Box Properties
Box Class See Also Send Feedback

The Box type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the angle of box rotation.
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border.
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings.
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill.
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins.
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


Angle Property

[image]

.NET ModelKit Suite ClassReference
Box..::.Angle Property
Box Class See Also Send Feedback
Gets or sets the angle of box rotation.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Integer
Visual C++
public:
property int Angle {
    int get ();
    void set (int value);
}

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


Border Property

[image]

.NET ModelKit Suite ClassReference
Box..::.Border Property
Box Class See Also Send Feedback
Gets and sets the control's border.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Border Border { get; set; }
Visual Basic (Declaration)
Public Property Border As Border
Visual C++
public:
property Border^ Border {
    Border^ get ();
    void set (Border^ value);
}

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


ContentRectangle Property

[image]

.NET ModelKit Suite ClassReference
Box..::.ContentRectangle Property
Box Class See Also Send Feedback
Gets the internal rectangle in the box based on the box's Margins settings.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle ContentRectangle { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentRectangle As VectorRectangle
Visual C++
public:
property VectorRectangle ContentRectangle {
    VectorRectangle get ();
}

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
Box..::.Fill Property
Box Class See Also Send Feedback
Gets and sets the control's background fill.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


Margins Property

[image]

.NET ModelKit Suite ClassReference
Box..::.Margins Property
Box Class See Also Send Feedback
Gets and sets the control's margins.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Margins Margins { get; set; }
Visual Basic (Declaration)
Public Property Margins As Margins
Visual C++
public:
property Margins Margins {
    Margins get ();
    void set (Margins value);
}

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


Box Events

[image] [image]

.NET ModelKit Suite ClassReference
Box Events
Box Class See Also Send Feedback

The Box type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

Box Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateSubReportParameterEventArgs Class

[image]

.NET ModelKit Suite ClassReference
CalculateSubReportParameterEventArgs Class
Members See Also Send Feedback
Represents the data for the CalulateParameter event contained in the sub report element.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class CalculateSubReportParameterEventArgs
Visual Basic (Declaration)
Public Class CalculateSubReportParameterEventArgs
Visual C++
public ref class CalculateSubReportParameterEventArgs

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.CalculateSubReportParameterEventArgs

See Also

CalculateSubReportParameterEventArgs Members
PerpetuumSoft.Reporting.DOM Namespace


CalculateSubReportParameterEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
CalculateSubReportParameterEventArgs Members
CalculateSubReportParameterEventArgs Class Constructors Methods Properties See Also Send Feedback

The CalculateSubReportParameterEventArgs type exposes the following members.

Constructors

Name | Description
CalculateSubReportParameterEventArgs | Initializes a new instance of the CalculateSubReportParameterEventArgs class.

Methods

Name | Description
Add | Adds new parameter with specified value.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ParameterValues | Returns Hashtable. Key of the hashtable is a parameter name, value is a parameter value.

See Also

CalculateSubReportParameterEventArgs Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateSubReportParameterEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
CalculateSubReportParameterEventArgs Constructor
CalculateSubReportParameterEventArgs Class See Also Send Feedback
Initializes a new instance of the CalculateSubReportParameterEventArgs class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public CalculateSubReportParameterEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CalculateSubReportParameterEventArgs()

See Also

CalculateSubReportParameterEventArgs Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateSubReportParameterEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
CalculateSubReportParameterEventArgs Methods
CalculateSubReportParameterEventArgs Class See Also Send Feedback

The CalculateSubReportParameterEventArgs type exposes the following members.

Methods

Name | Description
Add | Adds new parameter with specified value.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CalculateSubReportParameterEventArgs Class
PerpetuumSoft.Reporting.DOM Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
CalculateSubReportParameterEventArgs..::.Add Method
CalculateSubReportParameterEventArgs Class See Also Send Feedback
Adds new parameter with specified value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Add(
    string name,
    Object value
)
Visual Basic (Declaration)
Public Sub Add ( _
    name As String, _
    value As Object _
)
Visual C++
public:
void Add(
    String^ name,
    Object^ value
)

Parameters

name
Type: System..::.String
value
Type: System..::.Object

See Also

CalculateSubReportParameterEventArgs Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateSubReportParameterEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
CalculateSubReportParameterEventArgs Properties
CalculateSubReportParameterEventArgs Class See Also Send Feedback

The CalculateSubReportParameterEventArgs type exposes the following members.

Properties

Name | Description
ParameterValues | Returns Hashtable. Key of the hashtable is a parameter name, value is a parameter value.

See Also

CalculateSubReportParameterEventArgs Class
PerpetuumSoft.Reporting.DOM Namespace


ParameterValues Property

[image]

.NET ModelKit Suite ClassReference
CalculateSubReportParameterEventArgs..::.ParameterValues Property
CalculateSubReportParameterEventArgs Class See Also Send Feedback
Returns Hashtable. Key of the hashtable is a parameter name, value is a parameter value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Hashtable ParameterValues { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParameterValues As Hashtable
Visual C++
public:
property Hashtable^ ParameterValues {
    Hashtable^ get ();
}

See Also

CalculateSubReportParameterEventArgs Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateSubReportParameterEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
CalculateSubReportParameterEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the CalculateParameters event.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate void CalculateSubReportParameterEventHandler(
    Object sender,
    CalculateSubReportParameterEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub CalculateSubReportParameterEventHandler ( _
    sender As Object, _
    e As CalculateSubReportParameterEventArgs _
)
Visual C++
public delegate void CalculateSubReportParameterEventHandler(
    Object^ sender,
    CalculateSubReportParameterEventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: PerpetuumSoft.Reporting.DOM..::.CalculateSubReportParameterEventArgs

See Also

PerpetuumSoft.Reporting.DOM Namespace


ChartControl Class

[image]

.NET ModelKit Suite ClassReference
ChartControl Class
Members See Also Send Feedback
Provides report element for creating a chart.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ChartControl : Box
Visual Basic (Declaration)
Public Class ChartControl _
    Inherits Box
Visual C++
public ref class ChartControl : public Box

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.VisualControl
PerpetuumSoft.Reporting.DOM..::.Box
PerpetuumSoft.Reporting.DOM..::.ChartControl

See Also

ChartControl Members
PerpetuumSoft.Reporting.DOM Namespace


ChartControl Members

[image] [image]

.NET ModelKit Suite ClassReference
ChartControl Members
ChartControl Class Constructors Methods Properties Events See Also Send Feedback

The ChartControl type exposes the following members.

Constructors

Name | Description
ChartControl | Initializes a new instance of the ChartControl class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Overridden. See CreateBlankControl()()(). (Overrides ReportControl..::.CreateBlankControl()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed. (Inherited from Box.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Draws element's content. (Overrides Box..::.PaintContent(PaintArguments, RectangleF).)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from Box.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Overridden. See Render()()(). (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
RunPropertyDesigner | Overridden. See RunPropertyDesigner(IReportDesignerService). (Overrides ReportControlRunPropertyDesigner(IReportDesignerService).)
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
Chart | Gets or sets the Chart object representing the chart.
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DataSource | Gets or sets name of a data source for building the chart.
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

ChartControl Class
PerpetuumSoft.Reporting.DOM Namespace


ChartControl Constructor

[image]

.NET ModelKit Suite ClassReference
ChartControl Constructor
ChartControl Class See Also Send Feedback
Initializes a new instance of the ChartControl class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ChartControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartControl()

See Also

ChartControl Class
PerpetuumSoft.Reporting.DOM Namespace


ChartControl Methods

[image] [image]

.NET ModelKit Suite ClassReference
ChartControl Methods
ChartControl Class See Also Send Feedback

The ChartControl type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Overridden. See CreateBlankControl()()(). (Overrides ReportControl..::.CreateBlankControl()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed. (Inherited from Box.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Draws element's content. (Overrides Box..::.PaintContent(PaintArguments, RectangleF).)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from Box.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Overridden. See Render()()(). (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
RunPropertyDesigner | Overridden. See RunPropertyDesigner(IReportDesignerService). (Overrides ReportControlRunPropertyDesigner(IReportDesignerService).)
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChartControl Class
PerpetuumSoft.Reporting.DOM Namespace


CreateBlankControl Method

[image]

.NET ModelKit Suite ClassReference
ChartControl..::.CreateBlankControl Method
ChartControl Class See Also Send Feedback
Overridden. See CreateBlankControl()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override ReportControl CreateBlankControl()
Visual Basic (Declaration)
Protected Overrides Function CreateBlankControl As ReportControl
Visual C++
protected:
virtual ReportControl^ CreateBlankControl() override

See Also

ChartControl Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
ChartControl..::.GetScripts Method
ChartControl Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

ChartControl Class
ChartControl Members
PerpetuumSoft.Reporting.DOM Namespace


PaintContent Method

[image]

.NET ModelKit Suite ClassReference
ChartControl..::.PaintContent Method
ChartControl Class See Also Send Feedback
Draws element's content.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PaintContent(
    PaintArguments args,
    RectangleF contentRectangle
)
Visual Basic (Declaration)
Protected Overrides Sub PaintContent ( _
    args As PaintArguments, _
    contentRectangle As RectangleF _
)
Visual C++
protected:
virtual void PaintContent(
    PaintArguments^ args,
    RectangleF contentRectangle
) override

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments
contentRectangle
Type: System.Drawing..::.RectangleF

See Also

ChartControl Class
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
ChartControl..::.Render Method
ChartControl Class See Also Send Feedback
Overridden. See Render()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

ChartControl Class
PerpetuumSoft.Reporting.DOM Namespace


RunPropertyDesigner Method

[image]

.NET ModelKit Suite ClassReference
ChartControl..::.RunPropertyDesigner Method
ChartControl Class See Also Send Feedback
Overridden. See RunPropertyDesigner(IReportDesignerService).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void RunPropertyDesigner(
    IReportDesignerService service
)
Visual Basic (Declaration)
Public Overrides Sub RunPropertyDesigner ( _
    service As IReportDesignerService _
)
Visual C++
public:
virtual void RunPropertyDesigner(
    IReportDesignerService^ service
) override

Parameters

service
Type: PerpetuumSoft.Reporting.Designer..::.IReportDesignerService

See Also

ChartControl Class
PerpetuumSoft.Reporting.DOM Namespace


ChartControl Properties

[image] [image]

.NET ModelKit Suite ClassReference
ChartControl Properties
ChartControl Class See Also Send Feedback

The ChartControl type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
Chart | Gets or sets the Chart object representing the chart.
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DataSource | Gets or sets name of a data source for building the chart.
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

ChartControl Class
PerpetuumSoft.Reporting.DOM Namespace


Chart Property

[image]

.NET ModelKit Suite ClassReference
ChartControl..::.Chart Property
ChartControl Class See Also Send Feedback
Gets or sets the Chart object representing the chart.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Chart Chart { get; set; }
Visual Basic (Declaration)
Public Property Chart As Chart
Visual C++
public:
property Chart^ Chart {
    Chart^ get ();
    void set (Chart^ value);
}

See Also

ChartControl Class
PerpetuumSoft.Reporting.DOM Namespace


DataSource Property

[image]

.NET ModelKit Suite ClassReference
ChartControl..::.DataSource Property
ChartControl Class See Also Send Feedback
Gets or sets name of a data source for building the chart.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As String
Visual C++
public:
property String^ DataSource {
    String^ get ();
    void set (String^ value);
}

See Also

ChartControl Class
PerpetuumSoft.Reporting.DOM Namespace


ChartControl Events

[image] [image]

.NET ModelKit Suite ClassReference
ChartControl Events
ChartControl Class See Also Send Feedback

The ChartControl type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

ChartControl Class
PerpetuumSoft.Reporting.DOM Namespace


ContainerControl Class

[image]

.NET ModelKit Suite ClassReference
ContainerControl Class
Members See Also Send Feedback
Base class for all container controls.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ContainerControl : ReportControl,
    IContainerControl
Visual Basic (Declaration)
Public Class ContainerControl _
    Inherits ReportControl _
    Implements IContainerControl
Visual C++
public ref class ContainerControl : public ReportControl,
    IContainerControl

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Page
PerpetuumSoft.Reporting.DOM..::.Section

See Also

ContainerControl Members
PerpetuumSoft.Reporting.DOM Namespace


ContainerControl Members

[image] [image]

.NET ModelKit Suite ClassReference
ContainerControl Members
ContainerControl Class Constructors Methods Properties Events See Also Send Feedback

The ContainerControl type exposes the following members.

Constructors

Name | Description
ContainerControl | Initializes a new instance of the ContainerControl class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Overrides ReportControl..::.ControlAt(PointF).)
ControlByName | Finds a nested ReportControl object with the specified name. (Overrides ReportControl..::.ControlByName(String).)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Overrides ReportControl..::.FindParent(ReportControl).)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Returns whether the specified ReportControl can be placed to the controls collection.
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the control. (Overrides ReportControl..::.OnPaint(PaintArguments).)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Inherited from ReportControl.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
Controls | Gets the collection of the nested controls.
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

ContainerControl Class
PerpetuumSoft.Reporting.DOM Namespace


ContainerControl Constructor

[image]

.NET ModelKit Suite ClassReference
ContainerControl Constructor
ContainerControl Class See Also Send Feedback
Initializes a new instance of the ContainerControl class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ContainerControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ContainerControl()

See Also

ContainerControl Class
PerpetuumSoft.Reporting.DOM Namespace


ContainerControl Methods

[image] [image]

.NET ModelKit Suite ClassReference
ContainerControl Methods
ContainerControl Class See Also Send Feedback

The ContainerControl type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Overrides ReportControl..::.ControlAt(PointF).)
ControlByName | Finds a nested ReportControl object with the specified name. (Overrides ReportControl..::.ControlByName(String).)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Overrides ReportControl..::.FindParent(ReportControl).)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Returns whether the specified ReportControl can be placed to the controls collection.
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the control. (Overrides ReportControl..::.OnPaint(PaintArguments).)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Inherited from ReportControl.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContainerControl Class
PerpetuumSoft.Reporting.DOM Namespace


ControlAt Method

[image]

.NET ModelKit Suite ClassReference
ContainerControl..::.ControlAt Method
ContainerControl Class See Also Send Feedback
Returns a ReportControl object that is found in the location specified by the given PointF.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override ReportControl ControlAt(
    PointF point
)
Visual Basic (Declaration)
Public Overrides Function ControlAt ( _
    point As PointF _
) As ReportControl
Visual C++
public:
virtual ReportControl^ ControlAt(
    PointF point
) override

Parameters

point
Type: System.Drawing..::.PointF

See Also

ContainerControl Class
PerpetuumSoft.Reporting.DOM Namespace


ControlByName Method

[image]

.NET ModelKit Suite ClassReference
ContainerControl..::.ControlByName Method
ContainerControl Class See Also Send Feedback
Finds a nested ReportControl object with the specified name.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override ReportControl ControlByName(
    string controlName
)
Visual Basic (Declaration)
Public Overrides Function ControlByName ( _
    controlName As String _
) As ReportControl
Visual C++
public:
virtual ReportControl^ ControlByName(
    String^ controlName
) override

Parameters

controlName
Type: System..::.String

See Also

ContainerControl Class
PerpetuumSoft.Reporting.DOM Namespace


FindParent Method

[image]

.NET ModelKit Suite ClassReference
ContainerControl..::.FindParent Method
ContainerControl Class See Also Send Feedback
Finds the ReportControl's parent.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override IContainerControl FindParent(
    ReportControl c
)
Visual Basic (Declaration)
Public Overrides Function FindParent ( _
    c As ReportControl _
) As IContainerControl
Visual C++
public:
virtual IContainerControl^ FindParent(
    ReportControl^ c
) override

Parameters

c
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ContainerControl Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
ContainerControl..::.GetScripts Method
ContainerControl Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

ContainerControl Class
ContainerControl Members
PerpetuumSoft.Reporting.DOM Namespace


IsValidChild Method

[image]

.NET ModelKit Suite ClassReference
ContainerControl..::.IsValidChild Method
ContainerControl Class See Also Send Feedback
Returns whether the specified ReportControl can be placed to the controls collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual bool IsValidChild(
    ReportControl c
)
Visual Basic (Declaration)
Public Overridable Function IsValidChild ( _
    c As ReportControl _
) As Boolean
Visual C++
public:
virtual bool IsValidChild(
    ReportControl^ c
)

Parameters

c
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

Implements

IContainerControl..::.IsValidChild(ReportControl)

See Also

ContainerControl Class
PerpetuumSoft.Reporting.DOM Namespace


OnPaint Method

[image]

.NET ModelKit Suite ClassReference
ContainerControl..::.OnPaint Method
ContainerControl Class See Also Send Feedback
Performs drawing of the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
protected:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments

See Also

ContainerControl Class
PerpetuumSoft.Reporting.DOM Namespace


ContainerControl Properties

[image] [image]

.NET ModelKit Suite ClassReference
ContainerControl Properties
ContainerControl Class See Also Send Feedback

The ContainerControl type exposes the following members.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
Controls | Gets the collection of the nested controls.
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

ContainerControl Class
PerpetuumSoft.Reporting.DOM Namespace


Controls Property

[image]

.NET ModelKit Suite ClassReference
ContainerControl..::.Controls Property
ContainerControl Class See Also Send Feedback
Gets the collection of the nested controls.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportControlCollection Controls { get; }
Visual Basic (Declaration)
Public ReadOnly Property Controls As ReportControlCollection
Visual C++
public:
virtual property ReportControlCollection^ Controls {
    ReportControlCollection^ get () sealed;
}

Implements

IContainerControl..::.Controls

See Also

ContainerControl Class
PerpetuumSoft.Reporting.DOM Namespace


ContainerControl Events

[image] [image]

.NET ModelKit Suite ClassReference
ContainerControl Events
ContainerControl Class See Also Send Feedback

The ContainerControl type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

ContainerControl Class
PerpetuumSoft.Reporting.DOM Namespace


Content Class

[image]

.NET ModelKit Suite ClassReference
Content Class
Members See Also Send Feedback
Used for Master Report. Outputs bands from a report related to this master.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Content : SubReportBase
Visual Basic (Declaration)
Public Class Content _
    Inherits SubReportBase
Visual C++
public ref class Content : public SubReportBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.RegularBandBase
PerpetuumSoft.Reporting.DOM..::.RegularBand
PerpetuumSoft.Reporting.DOM..::.SubReportBase
PerpetuumSoft.Reporting.DOM..::.Content

See Also

Content Members
PerpetuumSoft.Reporting.DOM Namespace


Content Members

[image] [image]

.NET ModelKit Suite ClassReference
Content Members
Content Class Constructors Methods Properties Events See Also Send Feedback

The Content type exposes the following members.

Constructors

Name | Description
Content | Initializes a new instance of the Content class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Overridden. See CheckConditions()()(). (Inherited from SubReportBase.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Overridden. See GetSectionCaptionColor()()(). (Inherited from SubReportBase.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetTemplate | Returns template. (Overrides SubReportBase..::.GetTemplate()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from SubReportBase.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Inherited from SubReportBase.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Shift | Gets or sets shif for sub-report elements. (Inherited from SubReportBase.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

Content Class
PerpetuumSoft.Reporting.DOM Namespace


Content Constructor

[image]

.NET ModelKit Suite ClassReference
Content Constructor
Content Class See Also Send Feedback
Initializes a new instance of the Content class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Content()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Content()

See Also

Content Class
PerpetuumSoft.Reporting.DOM Namespace


Content Methods

[image] [image]

.NET ModelKit Suite ClassReference
Content Methods
Content Class See Also Send Feedback

The Content type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Overridden. See CheckConditions()()(). (Inherited from SubReportBase.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Overridden. See GetSectionCaptionColor()()(). (Inherited from SubReportBase.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetTemplate | Returns template. (Overrides SubReportBase..::.GetTemplate()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from SubReportBase.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Inherited from SubReportBase.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

See Also

Content Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
Content..::.GetScripts Method
Content Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

Content Class
Content Members
PerpetuumSoft.Reporting.DOM Namespace


GetTemplate Method

[image]

.NET ModelKit Suite ClassReference
Content..::.GetTemplate Method
Content Class See Also Send Feedback
Returns template.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Document GetTemplate()
Visual Basic (Declaration)
Protected Overrides Function GetTemplate As Document
Visual C++
protected:
virtual Document^ GetTemplate() override

See Also

Content Class
PerpetuumSoft.Reporting.DOM Namespace


Content Properties

[image] [image]

.NET ModelKit Suite ClassReference
Content Properties
Content Class See Also Send Feedback

The Content type exposes the following members.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Shift | Gets or sets shif for sub-report elements. (Inherited from SubReportBase.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

Content Class
PerpetuumSoft.Reporting.DOM Namespace


Content Events

[image] [image]

.NET ModelKit Suite ClassReference
Content Events
Content Class See Also Send Feedback

The Content type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

Content Class
PerpetuumSoft.Reporting.DOM Namespace


CrossBand Class

[image]

.NET ModelKit Suite ClassReference
CrossBand Class
Members See Also Send Feedback
Represents a vertical band for 2-dimensional reports.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class CrossBand : Section
Visual Basic (Declaration)
Public Class CrossBand _
    Inherits Section
Visual C++
public ref class CrossBand : public Section

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.CrossBand

See Also

CrossBand Members
PerpetuumSoft.Reporting.DOM Namespace


CrossBand Members

[image] [image]

.NET ModelKit Suite ClassReference
CrossBand Members
CrossBand Class Constructors Methods Properties Events See Also Send Feedback

The CrossBand type exposes the following members.

Constructors

Name | Description
CrossBand | Creates a new instance of CrossBand class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Overrides Section..::.CalculateCaretPosition()()().)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
CheckConditions | Overridden. See CheckConditions()()(). (Overrides Section..::.CheckConditions()()().)
ControlAt | Returns a ReportControl object that is found on the in the location specified by the given PointF. (Overrides ContainerControl..::.ControlAt(PointF).)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string for the band. (Overrides Section..::.GetSectionCaption()()().)
GetSectionCaptionColor | Returns the color of the title bar. (Overrides Section..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Returns whether the specified control can be placed into the band. (Inherited from Section.)
IsValidParent | Returns if the band can be placed into the specified container. (Overrides ReportControl..::.IsValidParent(ReportControl).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnGetData | Raises the GetData event.
OnPaint | Performs drawing of the control. (Overrides ContainerControl..::.OnPaint(PaintArguments).)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
RaiseGetData | Invokes OnGetData method.
ReCalculateBounds | Recalculates band bounds. (Overrides ReportControl..::.ReCalculateBounds(VectorRectangle).)
Render | Renders the control to the final document. (Overrides ReportControl..::.Render()()().)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Overrides Section..::.UpdatePageArea()()().)

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
Count | Gets the number of the current record.
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DataItem | Gets the current record data.
DataSource | Gets and sets the DataSource name for the band.
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GetDataScript | Gets and sets the code of the script that will be invoked when the band obtains data from the data source.
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
InstanceCount | Gets and sets the total records count for unbound reports.
Item | Gets a value of the specified field from the current record.
LineNumber | Gets the number of the currently rendered line.
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)
GetData | Occurs when a data item is obtained from the data source.

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


CrossBand Constructor

[image]

.NET ModelKit Suite ClassReference
CrossBand Constructor
CrossBand Class See Also Send Feedback
Creates a new instance of CrossBand class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public CrossBand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CrossBand()

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


CrossBand Methods

[image] [image]

.NET ModelKit Suite ClassReference
CrossBand Methods
CrossBand Class See Also Send Feedback

The CrossBand type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Overrides Section..::.CalculateCaretPosition()()().)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
CheckConditions | Overridden. See CheckConditions()()(). (Overrides Section..::.CheckConditions()()().)
ControlAt | Returns a ReportControl object that is found on the in the location specified by the given PointF. (Overrides ContainerControl..::.ControlAt(PointF).)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string for the band. (Overrides Section..::.GetSectionCaption()()().)
GetSectionCaptionColor | Returns the color of the title bar. (Overrides Section..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Returns whether the specified control can be placed into the band. (Inherited from Section.)
IsValidParent | Returns if the band can be placed into the specified container. (Overrides ReportControl..::.IsValidParent(ReportControl).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnGetData | Raises the GetData event.
OnPaint | Performs drawing of the control. (Overrides ContainerControl..::.OnPaint(PaintArguments).)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
RaiseGetData | Invokes OnGetData method.
ReCalculateBounds | Recalculates band bounds. (Overrides ReportControl..::.ReCalculateBounds(VectorRectangle).)
Render | Renders the control to the final document. (Overrides ReportControl..::.Render()()().)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Overrides Section..::.UpdatePageArea()()().)

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateCaretPosition Method

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.CalculateCaretPosition Method
CrossBand Class See Also Send Feedback
Calculates the current position in the report for placing the current band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void CalculateCaretPosition()
Visual Basic (Declaration)
Protected Overrides Sub CalculateCaretPosition
Visual C++
protected:
virtual void CalculateCaretPosition() override

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


CheckConditions Method

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.CheckConditions Method
CrossBand Class See Also Send Feedback
Overridden. See CheckConditions()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override bool CheckConditions()
Visual Basic (Declaration)
Protected Overrides Function CheckConditions As Boolean
Visual C++
protected:
virtual bool CheckConditions() override

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


ControlAt Method

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.ControlAt Method
CrossBand Class See Also Send Feedback
Returns a ReportControl object that is found on the in the location specified by the given PointF.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override ReportControl ControlAt(
    PointF point
)
Visual Basic (Declaration)
Public Overrides Function ControlAt ( _
    point As PointF _
) As ReportControl
Visual C++
public:
virtual ReportControl^ ControlAt(
    PointF point
) override

Parameters

point
Type: System.Drawing..::.PointF

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
CrossBand..::.GetScripts Method
CrossBand Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Overrides ReportControl..::.GetScripts(ScriptInfoCollection).)

See Also

CrossBand Class
CrossBand Members
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method (ScriptInfoCollection)

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.GetScripts Method (ScriptInfoCollection)
CrossBand Class See Also Send Feedback
Fills the specified collection with all scripts assigned to the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void GetScripts(
    ScriptInfoCollection scripts
)
Visual Basic (Declaration)
Public Overrides Sub GetScripts ( _
    scripts As ScriptInfoCollection _
)
Visual C++
public:
virtual void GetScripts(
    ScriptInfoCollection^ scripts
) override

Parameters

scripts
Type: PerpetuumSoft.Reporting.Rendering..::.ScriptInfoCollection

See Also

CrossBand Class
GetScripts Overload
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaption Method

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.GetSectionCaption Method
CrossBand Class See Also Send Feedback
Returns the title string for the band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override string GetSectionCaption()
Visual Basic (Declaration)
Protected Overrides Function GetSectionCaption As String
Visual C++
protected:
virtual String^ GetSectionCaption() override

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaptionColor Method

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.GetSectionCaptionColor Method
CrossBand Class See Also Send Feedback
Returns the color of the title bar.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Color GetSectionCaptionColor()
Visual Basic (Declaration)
Protected Overrides Function GetSectionCaptionColor As Color
Visual C++
protected:
virtual Color GetSectionCaptionColor() override

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


IsValidParent Method

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.IsValidParent Method
CrossBand Class See Also Send Feedback
Returns if the band can be placed into the specified container.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValidParent(
    ReportControl c
)
Visual Basic (Declaration)
Public Overrides Function IsValidParent ( _
    c As ReportControl _
) As Boolean
Visual C++
public:
virtual bool IsValidParent(
    ReportControl^ c
) override

Parameters

c
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


OnGetData Method

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.OnGetData Method
CrossBand Class See Also Send Feedback
Raises the GetData event.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnGetData(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnGetData ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnGetData(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


OnPaint Method

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.OnPaint Method
CrossBand Class See Also Send Feedback
Performs drawing of the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
protected:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


RaiseGetData Method

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.RaiseGetData Method
CrossBand Class See Also Send Feedback
Invokes OnGetData method.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected void RaiseGetData()
Visual Basic (Declaration)
Protected Sub RaiseGetData
Visual C++
protected:
void RaiseGetData()

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


ReCalculateBounds Method

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.ReCalculateBounds Method
CrossBand Class See Also Send Feedback
Recalculates band bounds.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override VectorRectangle ReCalculateBounds(
    VectorRectangle currentBounds
)
Visual Basic (Declaration)
Protected Overrides Function ReCalculateBounds ( _
    currentBounds As VectorRectangle _
) As VectorRectangle
Visual C++
protected:
virtual VectorRectangle ReCalculateBounds(
    VectorRectangle currentBounds
) override

Parameters

currentBounds
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.Render Method
CrossBand Class See Also Send Feedback
Renders the control to the final document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


UpdatePageArea Method

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.UpdatePageArea Method
CrossBand Class See Also Send Feedback
Calculates the remaining free page area after the band is rendered.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void UpdatePageArea()
Visual Basic (Declaration)
Protected Overrides Sub UpdatePageArea
Visual C++
protected:
virtual void UpdatePageArea() override

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


CrossBand Properties

[image] [image]

.NET ModelKit Suite ClassReference
CrossBand Properties
CrossBand Class See Also Send Feedback

The CrossBand type exposes the following members.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
Count | Gets the number of the current record.
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DataItem | Gets the current record data.
DataSource | Gets and sets the DataSource name for the band.
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GetDataScript | Gets and sets the code of the script that will be invoked when the band obtains data from the data source.
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
InstanceCount | Gets and sets the total records count for unbound reports.
Item | Gets a value of the specified field from the current record.
LineNumber | Gets the number of the currently rendered line.
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


Count Property

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.Count Property
CrossBand Class See Also Send Feedback
Gets the number of the current record.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
}

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


DataItem Property

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.DataItem Property
CrossBand Class See Also Send Feedback
Gets the current record data.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object DataItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataItem As Object
Visual C++
public:
property Object^ DataItem {
    Object^ get ();
}

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


DataSource Property

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.DataSource Property
CrossBand Class See Also Send Feedback
Gets and sets the DataSource name for the band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As String
Visual C++
public:
property String^ DataSource {
    String^ get ();
    void set (String^ value);
}

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


GetDataScript Property

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.GetDataScript Property
CrossBand Class See Also Send Feedback
Gets and sets the code of the script that will be invoked when the band obtains data from the data source.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string GetDataScript { get; set; }
Visual Basic (Declaration)
Public Property GetDataScript As String
Visual C++
public:
property String^ GetDataScript {
    String^ get ();
    void set (String^ value);
}

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


InstanceCount Property

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.InstanceCount Property
CrossBand Class See Also Send Feedback
Gets and sets the total records count for unbound reports.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int InstanceCount { get; set; }
Visual Basic (Declaration)
Public Property InstanceCount As Integer
Visual C++
public:
property int InstanceCount {
    int get ();
    void set (int value);
}

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.Item Property
CrossBand Class See Also Send Feedback
Gets a value of the specified field from the current record.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object this[
    string field
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    field As String _
) As Object
Visual C++
public:
property Object^ default[String^ field] {
    Object^ get (String^ field);
}

Parameters

field
Type: System..::.String

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


LineNumber Property

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.LineNumber Property
CrossBand Class See Also Send Feedback
Gets the number of the currently rendered line.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int LineNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property LineNumber As Integer
Visual C++
public:
property int LineNumber {
    int get ();
}

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


CrossBand Events

[image] [image]

.NET ModelKit Suite ClassReference
CrossBand Events
CrossBand Class See Also Send Feedback

The CrossBand type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)
GetData | Occurs when a data item is obtained from the data source.

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


GetData Event

[image]

.NET ModelKit Suite ClassReference
CrossBand..::.GetData Event
CrossBand Class See Also Send Feedback
Occurs when a data item is obtained from the data source.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler GetData
Visual Basic (Declaration)
Public Event GetData As EventHandler
Visual C++
public:
 event EventHandler^ GetData {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

CrossBand Class
PerpetuumSoft.Reporting.DOM Namespace


DataBand Class

[image]

.NET ModelKit Suite ClassReference
DataBand Class
Members See Also Send Feedback
Creates instances of the nested controls for each record in the data source.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DataBand : DataBandBase
Visual Basic (Declaration)
Public Class DataBand _
    Inherits DataBandBase
Visual C++
public ref class DataBand : public DataBandBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.RegularBandBase
PerpetuumSoft.Reporting.DOM..::.RegularBand
PerpetuumSoft.Reporting.DOM..::.AggregatesRegularBand
PerpetuumSoft.Reporting.DOM..::.DataBandBase
PerpetuumSoft.Reporting.DOM..::.DataBand

See Also

DataBand Members
PerpetuumSoft.Reporting.DOM Namespace


DataBand Members

[image] [image]

.NET ModelKit Suite ClassReference
DataBand Members
DataBand Class Constructors Methods Properties Events See Also Send Feedback

The DataBand type exposes the following members.

Constructors

Name | Description
DataBand | Creates a new instance of DataBand class.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CalculateRunningTotals | (Inherited from DataBandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
CreateNavigator | Creates grouped data navigator (Overrides DataBandBase..::.CreateNavigator()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetGroup | Gets group (Overrides DataBandBase..::.GetGroup()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLevel | Gets the level of the current band. (Inherited from DataBandBase.)
GetPageTotal | Overloaded.
GetRunningTotal | Gets the running total by its name (Inherited from DataBandBase.)
GetScripts | Overloaded.
GetSectionCaption | Returns the band's title string. (Overrides BandBase..::.GetSectionCaption()()().)
GetSectionCaptionColor | Gets section caption color (Inherited from DataBandBase.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetTotal | Overloaded.
GetTotals | Gets total (Overrides DataBandBase..::.GetTotals()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from DataBandBase.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnGetData | Raises the GetData event. (Inherited from DataBandBase.)
OnPaint | Performs drawing of the control. (Inherited from DataBandBase.)
OnProcessRecord | Raises the ProcessRecord event.
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
ProcessRecordCore | (Overrides DataBandBase..::.ProcessRecordCore()()().)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
RaiseGetData | Invokes OnGetData method. (Inherited from DataBandBase.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Inherited from DataBandBase.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
StartPropagate | Switches the band to propagate mode. (Inherited from DataBandBase.)
StopPropagate | Resets value by the PropagateMode (Inherited from DataBandBase.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
ColumnsCount | Gets or sets columns count (Inherited from DataBandBase.)
ColumnsGap | Gets or sets gap between columns (Inherited from DataBandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DataItem | Gets the current record data. (Inherited from DataBandBase.)
DataSource | Gets and sets the name of the data source assigned to the band.
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
FilterExpression | Gets or sets the expression for filtering data from the data sourceString
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GetDataScript | Gets and sets the code of the script that will be invoked when the band obtains data from the data source. (Inherited from DataBandBase.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
InstanceCount | Gets and sets the total records count for unbound reports.
IsFirstLine | Gets if the first line is rendered. (Inherited from DataBandBase.)
IsLastLine | Gets if the last line is rendered. (Inherited from DataBandBase.)
Item | (Overrides DataBandBase..::.Item[([(String])]).)
LineNumber | Gets the number of the currently rendered line. (Inherited from DataBandBase.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RecordNumber | Gets the number of the current record. (Inherited from DataBandBase.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowBottom | Gets and sets whether the bottom bar of the band should be displayed in the design mode. (Inherited from DataBandBase.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
Sort | Gets sorting settings collection
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Totals | Gets totals calculation settings collection
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)
GetData | Occurs when a data item is obtained from the data source. (Inherited from DataBandBase.)
ProcessRecord | Data change event during source data processing

See Also

DataBand Class
PerpetuumSoft.Reporting.DOM Namespace


DataBand Constructor

[image]

.NET ModelKit Suite ClassReference
DataBand Constructor
DataBand Class See Also Send Feedback
Creates a new instance of DataBand class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataBand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataBand()

See Also

DataBand Class
PerpetuumSoft.Reporting.DOM Namespace


DataBand Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataBand Methods
DataBand Class See Also Send Feedback

The DataBand type exposes the following members.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CalculateRunningTotals | (Inherited from DataBandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
CreateNavigator | Creates grouped data navigator (Overrides DataBandBase..::.CreateNavigator()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetGroup | Gets group (Overrides DataBandBase..::.GetGroup()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLevel | Gets the level of the current band. (Inherited from DataBandBase.)
GetPageTotal | Overloaded.
GetRunningTotal | Gets the running total by its name (Inherited from DataBandBase.)
GetScripts | Overloaded.
GetSectionCaption | Returns the band's title string. (Overrides BandBase..::.GetSectionCaption()()().)
GetSectionCaptionColor | Gets section caption color (Inherited from DataBandBase.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetTotal | Overloaded.
GetTotals | Gets total (Overrides DataBandBase..::.GetTotals()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from DataBandBase.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnGetData | Raises the GetData event. (Inherited from DataBandBase.)
OnPaint | Performs drawing of the control. (Inherited from DataBandBase.)
OnProcessRecord | Raises the ProcessRecord event.
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
ProcessRecordCore | (Overrides DataBandBase..::.ProcessRecordCore()()().)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
RaiseGetData | Invokes OnGetData method. (Inherited from DataBandBase.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Inherited from DataBandBase.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
StartPropagate | Switches the band to propagate mode. (Inherited from DataBandBase.)
StopPropagate | Resets value by the PropagateMode (Inherited from DataBandBase.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

See Also

DataBand Class
PerpetuumSoft.Reporting.DOM Namespace


Avg Method

[image] [image]

.NET ModelKit Suite ClassReference
DataBand..::.Avg Method
DataBand Class See Also Send Feedback

Overload List

Name | Description
Avg(String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)

See Also

DataBand Class
DataBand Members
PerpetuumSoft.Reporting.DOM Namespace


Count Method

[image] [image]

.NET ModelKit Suite ClassReference
DataBand..::.Count Method
DataBand Class See Also Send Feedback

Overload List

Name | Description
Count(String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)

See Also

DataBand Class
DataBand Members
PerpetuumSoft.Reporting.DOM Namespace


CreateNavigator Method

[image]

.NET ModelKit Suite ClassReference
DataBand..::.CreateNavigator Method
DataBand Class See Also Send Feedback
Creates grouped data navigator

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override DataNavigator CreateNavigator()
Visual Basic (Declaration)
Protected Overrides Function CreateNavigator As DataNavigator
Visual C++
protected:
virtual DataNavigator^ CreateNavigator() override

See Also

DataBand Class
PerpetuumSoft.Reporting.DOM Namespace


GetGroup Method

[image]

.NET ModelKit Suite ClassReference
DataBand..::.GetGroup Method
DataBand Class See Also Send Feedback
Gets group

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Group GetGroup()
Visual Basic (Declaration)
Protected Overrides Function GetGroup As Group
Visual C++
protected:
virtual Group^ GetGroup() override

See Also

DataBand Class
PerpetuumSoft.Reporting.DOM Namespace


GetPageTotal Method

[image] [image]

.NET ModelKit Suite ClassReference
DataBand..::.GetPageTotal Method
DataBand Class See Also Send Feedback

Overload List

Name | Description
GetPageTotal(String) | Gets totals by collection
GetPageTotal(String, Int32) | Gets total by page.

See Also

DataBand Class
DataBand Members
PerpetuumSoft.Reporting.DOM Namespace


GetPageTotal Method (String)

[image]

.NET ModelKit Suite ClassReference
DataBand..::.GetPageTotal Method (String)
DataBand Class See Also Send Feedback
Gets totals by collection

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double GetPageTotal(
    string name
)
Visual Basic (Declaration)
Public Function GetPageTotal ( _
    name As String _
) As Double
Visual C++
public:
double GetPageTotal(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

DataBand Class
GetPageTotal Overload
PerpetuumSoft.Reporting.DOM Namespace


GetPageTotal Method (String, Int32)

[image]

.NET ModelKit Suite ClassReference
DataBand..::.GetPageTotal Method (String, Int32)
DataBand Class See Also Send Feedback
Gets total by page.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double GetPageTotal(
    string name,
    int pageNumber
)
Visual Basic (Declaration)
Public Function GetPageTotal ( _
    name As String, _
    pageNumber As Integer _
) As Double
Visual C++
public:
double GetPageTotal(
    String^ name,
    int pageNumber
)

Parameters

name
Type: System..::.String
pageNumber
Type: System..::.Int32

See Also

DataBand Class
GetPageTotal Overload
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
DataBand..::.GetScripts Method
DataBand Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Overrides DataBandBase..::.GetScripts(ScriptInfoCollection).)

See Also

DataBand Class
DataBand Members
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method (ScriptInfoCollection)

[image]

.NET ModelKit Suite ClassReference
DataBand..::.GetScripts Method (ScriptInfoCollection)
DataBand Class See Also Send Feedback
Fills the specified collection with all scripts assigned to the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void GetScripts(
    ScriptInfoCollection scripts
)
Visual Basic (Declaration)
Public Overrides Sub GetScripts ( _
    scripts As ScriptInfoCollection _
)
Visual C++
public:
virtual void GetScripts(
    ScriptInfoCollection^ scripts
) override

Parameters

scripts
Type: PerpetuumSoft.Reporting.Rendering..::.ScriptInfoCollection

See Also

DataBand Class
GetScripts Overload
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaption Method

[image]

.NET ModelKit Suite ClassReference
DataBand..::.GetSectionCaption Method
DataBand Class See Also Send Feedback
Returns the band's title string.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override string GetSectionCaption()
Visual Basic (Declaration)
Protected Overrides Function GetSectionCaption As String
Visual C++
protected:
virtual String^ GetSectionCaption() override

See Also

DataBand Class
PerpetuumSoft.Reporting.DOM Namespace


GetTotal Method

[image] [image]

.NET ModelKit Suite ClassReference
DataBand..::.GetTotal Method
DataBand Class See Also Send Feedback

Overload List

Name | Description
GetTotal(String) | Gets field total (Inherited from DataBandBase.)
GetTotal(String, Double) | (Inherited from DataBandBase.)

See Also

DataBand Class
DataBand Members
PerpetuumSoft.Reporting.DOM Namespace


GetTotals Method

[image]

.NET ModelKit Suite ClassReference
DataBand..::.GetTotals Method
DataBand Class See Also Send Feedback
Gets total

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override DataBandTotalCollection GetTotals()
Visual Basic (Declaration)
Protected Overrides Function GetTotals As DataBandTotalCollection
Visual C++
protected:
virtual DataBandTotalCollection^ GetTotals() override

See Also

DataBand Class
PerpetuumSoft.Reporting.DOM Namespace


Max Method

[image] [image]

.NET ModelKit Suite ClassReference
DataBand..::.Max Method
DataBand Class See Also Send Feedback

Overload List

Name | Description
Max(String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)

See Also

DataBand Class
DataBand Members
PerpetuumSoft.Reporting.DOM Namespace


Min Method

[image] [image]

.NET ModelKit Suite ClassReference
DataBand..::.Min Method
DataBand Class See Also Send Feedback

Overload List

Name | Description
Min(String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)

See Also

DataBand Class
DataBand Members
PerpetuumSoft.Reporting.DOM Namespace


OnProcessRecord Method

[image]

.NET ModelKit Suite ClassReference
DataBand..::.OnProcessRecord Method
DataBand Class See Also Send Feedback
Raises the ProcessRecord event.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnProcessRecord(
    ProcessRecordEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnProcessRecord ( _
    e As ProcessRecordEventArgs _
)
Visual C++
protected:
virtual void OnProcessRecord(
    ProcessRecordEventArgs^ e
)

Parameters

e
Type: PerpetuumSoft.Reporting.DOM..::.ProcessRecordEventArgs

See Also

DataBand Class
PerpetuumSoft.Reporting.DOM Namespace


ProcessRecordCore Method

[image]

.NET ModelKit Suite ClassReference
DataBand..::.ProcessRecordCore Method
DataBand Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.DataBand.ProcessRecordCore]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected internal override void ProcessRecordCore()
Visual Basic (Declaration)
Protected Friend Overrides Sub ProcessRecordCore
Visual C++
protected public:
virtual void ProcessRecordCore() override

See Also

DataBand Class
PerpetuumSoft.Reporting.DOM Namespace


Sum Method

[image] [image]

.NET ModelKit Suite ClassReference
DataBand..::.Sum Method
DataBand Class See Also Send Feedback

Overload List

Name | Description
Sum(String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)

See Also

DataBand Class
DataBand Members
PerpetuumSoft.Reporting.DOM Namespace


DataBand Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataBand Properties
DataBand Class See Also Send Feedback

The DataBand type exposes the following members.

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
ColumnsCount | Gets or sets columns count (Inherited from DataBandBase.)
ColumnsGap | Gets or sets gap between columns (Inherited from DataBandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DataItem | Gets the current record data. (Inherited from DataBandBase.)
DataSource | Gets and sets the name of the data source assigned to the band.
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
FilterExpression | Gets or sets the expression for filtering data from the data sourceString
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GetDataScript | Gets and sets the code of the script that will be invoked when the band obtains data from the data source. (Inherited from DataBandBase.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
InstanceCount | Gets and sets the total records count for unbound reports.
IsFirstLine | Gets if the first line is rendered. (Inherited from DataBandBase.)
IsLastLine | Gets if the last line is rendered. (Inherited from DataBandBase.)
Item | (Overrides DataBandBase..::.Item[([(String])]).)
LineNumber | Gets the number of the currently rendered line. (Inherited from DataBandBase.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RecordNumber | Gets the number of the current record. (Inherited from DataBandBase.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowBottom | Gets and sets whether the bottom bar of the band should be displayed in the design mode. (Inherited from DataBandBase.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
Sort | Gets sorting settings collection
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Totals | Gets totals calculation settings collection
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

DataBand Class
PerpetuumSoft.Reporting.DOM Namespace


DataSource Property

[image]

.NET ModelKit Suite ClassReference
DataBand..::.DataSource Property
DataBand Class See Also Send Feedback
Gets and sets the name of the data source assigned to the band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As String
Visual C++
public:
property String^ DataSource {
    String^ get ();
    void set (String^ value);
}

See Also

DataBand Class
PerpetuumSoft.Reporting.DOM Namespace


FilterExpression Property

[image]

.NET ModelKit Suite ClassReference
DataBand..::.FilterExpression Property
DataBand Class See Also Send Feedback
Gets or sets the expression for filtering data from the data sourceString

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string FilterExpression { get; set; }
Visual Basic (Declaration)
Public Property FilterExpression As String
Visual C++
public:
property String^ FilterExpression {
    String^ get ();
    void set (String^ value);
}

See Also

DataBand Class
PerpetuumSoft.Reporting.DOM Namespace


InstanceCount Property

[image]

.NET ModelKit Suite ClassReference
DataBand..::.InstanceCount Property
DataBand Class See Also Send Feedback
Gets and sets the total records count for unbound reports.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int InstanceCount { get; set; }
Visual Basic (Declaration)
Public Property InstanceCount As Integer
Visual C++
public:
property int InstanceCount {
    int get ();
    void set (int value);
}

See Also

DataBand Class
PerpetuumSoft.Reporting.DOM Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
DataBand..::.Item Property
DataBand Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.DOM.DataBand.Item(System.String)]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override Object this[
    string field
] { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Default Property Item ( _
    field As String _
) As Object
Visual C++
public:
virtual property Object^ default[String^ field] {
    Object^ get (String^ field) override;
}

Parameters

field
Type: System..::.String

See Also

DataBand Class
PerpetuumSoft.Reporting.DOM Namespace


Sort Property

[image]

.NET ModelKit Suite ClassReference
DataBand..::.Sort Property
DataBand Class See Also Send Feedback
Gets sorting settings collection

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataBandSortCollection Sort { get; }
Visual Basic (Declaration)
Public ReadOnly Property Sort As DataBandSortCollection
Visual C++
public:
property DataBandSortCollection^ Sort {
    DataBandSortCollection^ get ();
}

See Also

DataBand Class
PerpetuumSoft.Reporting.DOM Namespace


Totals Property

[image]

.NET ModelKit Suite ClassReference
DataBand..::.Totals Property
DataBand Class See Also Send Feedback
Gets totals calculation settings collection

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataBandTotalCollection Totals { get; }
Visual Basic (Declaration)
Public ReadOnly Property Totals As DataBandTotalCollection
Visual C++
public:
property DataBandTotalCollection^ Totals {
    DataBandTotalCollection^ get ();
}

See Also

DataBand Class
PerpetuumSoft.Reporting.DOM Namespace


DataBand Events

[image] [image]

.NET ModelKit Suite ClassReference
DataBand Events
DataBand Class See Also Send Feedback

The DataBand type exposes the following members.

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)
GetData | Occurs when a data item is obtained from the data source. (Inherited from DataBandBase.)
ProcessRecord | Data change event during source data processing

See Also

DataBand Class
PerpetuumSoft.Reporting.DOM Namespace


ProcessRecord Event

[image]

.NET ModelKit Suite ClassReference
DataBand..::.ProcessRecord Event
DataBand Class See Also Send Feedback
Data change event during source data processing

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler<ProcessRecordEventArgs> ProcessRecord
Visual Basic (Declaration)
Public Event ProcessRecord As EventHandler(Of ProcessRecordEventArgs)
Visual C++
public:
 event EventHandler<ProcessRecordEventArgs^>^ ProcessRecord {
    void add (EventHandler<ProcessRecordEventArgs^>^ value);
    void remove (EventHandler<ProcessRecordEventArgs^>^ value);
}

See Also

DataBand Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandBase Class

[image]

.NET ModelKit Suite ClassReference
DataBandBase Class
Members See Also Send Feedback
Represents the base class for all bands

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract class DataBandBase : AggregatesRegularBand
Visual Basic (Declaration)
Public MustInherit Class DataBandBase _
    Inherits AggregatesRegularBand
Visual C++
public ref class DataBandBase abstract : public AggregatesRegularBand

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.RegularBandBase
PerpetuumSoft.Reporting.DOM..::.RegularBand
PerpetuumSoft.Reporting.DOM..::.AggregatesRegularBand
PerpetuumSoft.Reporting.DOM..::.DataBandBase
PerpetuumSoft.Reporting.DOM..::.DataBand
PerpetuumSoft.Reporting.DOM..::.GroupBand

See Also

DataBandBase Members
PerpetuumSoft.Reporting.DOM Namespace


DataBandBase Members

[image] [image]

.NET ModelKit Suite ClassReference
DataBandBase Members
DataBandBase Class Constructors Methods Properties Events See Also Send Feedback

The DataBandBase type exposes the following members.

Constructors

Name | Description
DataBandBase | Initializes a new instance of the DataBandBase class

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CalculateRunningTotals |
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
CreateNavigator | Creates grouped data navigator
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetGroup | Gets Group
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLevel | Gets the level of the current band.
GetRunningTotal | Gets the running total by its name
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Gets section caption color (Overrides Section..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetTotal | Overloaded.
GetTotals | Gets total value
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Overrides RegularBandBase..::.IsValidChild(ReportControl).)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnGetData | Raises the GetData event.
OnPaint | Performs drawing of the control. (Overrides BandBase..::.OnPaint(PaintArguments).)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
ProcessRecordCore |
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
RaiseGetData | Invokes OnGetData method.
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Overrides AggregatesRegularBand..::.Render()()().)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
StartPropagate | Switches the band to propagate mode.
StopPropagate | Resets value by the PropagateMode
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
ColumnsCount | Gets or sets columns count
ColumnsGap | Gets or sets gap between columns
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DataItem | Gets the current record data.
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GetDataScript | Gets and sets the code of the script that will be invoked when the band obtains data from the data source.
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
IsFirstLine | Gets if the first line is rendered.
IsLastLine | Gets if the last line is rendered.
Item | Gets a value of the specified field from the current record.
LineNumber | Gets the number of the currently rendered line.
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RecordNumber | Gets the number of the current record.
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowBottom | Gets and sets whether the bottom bar of the band should be displayed in the design mode.
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)
GetData | Occurs when a data item is obtained from the data source.

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandBase Constructor

[image]

.NET ModelKit Suite ClassReference
DataBandBase Constructor
DataBandBase Class See Also Send Feedback
Initializes a new instance of the DataBandBase class

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected DataBandBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
DataBandBase()

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataBandBase Methods
DataBandBase Class See Also Send Feedback

The DataBandBase type exposes the following members.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CalculateRunningTotals |
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
CreateNavigator | Creates grouped data navigator
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetGroup | Gets Group
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLevel | Gets the level of the current band.
GetRunningTotal | Gets the running total by its name
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Gets section caption color (Overrides Section..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetTotal | Overloaded.
GetTotals | Gets total value
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Overrides RegularBandBase..::.IsValidChild(ReportControl).)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnGetData | Raises the GetData event.
OnPaint | Performs drawing of the control. (Overrides BandBase..::.OnPaint(PaintArguments).)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
ProcessRecordCore |
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
RaiseGetData | Invokes OnGetData method.
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Overrides AggregatesRegularBand..::.Render()()().)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
StartPropagate | Switches the band to propagate mode.
StopPropagate | Resets value by the PropagateMode
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


Avg Method

[image] [image]

.NET ModelKit Suite ClassReference
DataBandBase..::.Avg Method
DataBandBase Class See Also Send Feedback

Overload List

Name | Description
Avg(String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)

See Also

DataBandBase Class
DataBandBase Members
PerpetuumSoft.Reporting.DOM Namespace


CalculateRunningTotals Method

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.CalculateRunningTotals Method
DataBandBase Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.DataBandBase.CalculateRunningTotals]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected internal void CalculateRunningTotals()
Visual Basic (Declaration)
Protected Friend Sub CalculateRunningTotals
Visual C++
protected public:
void CalculateRunningTotals()

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


Count Method

[image] [image]

.NET ModelKit Suite ClassReference
DataBandBase..::.Count Method
DataBandBase Class See Also Send Feedback

Overload List

Name | Description
Count(String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)

See Also

DataBandBase Class
DataBandBase Members
PerpetuumSoft.Reporting.DOM Namespace


CreateNavigator Method

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.CreateNavigator Method
DataBandBase Class See Also Send Feedback
Creates grouped data navigator

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected abstract DataNavigator CreateNavigator()
Visual Basic (Declaration)
Protected MustOverride Function CreateNavigator As DataNavigator
Visual C++
protected:
virtual DataNavigator^ CreateNavigator() abstract

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


GetGroup Method

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.GetGroup Method
DataBandBase Class See Also Send Feedback
Gets Group

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected abstract Group GetGroup()
Visual Basic (Declaration)
Protected MustOverride Function GetGroup As Group
Visual C++
protected:
virtual Group^ GetGroup() abstract

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


GetLevel Method

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.GetLevel Method
DataBandBase Class See Also Send Feedback
Gets the level of the current band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected int GetLevel()
Visual Basic (Declaration)
Protected Function GetLevel As Integer
Visual C++
protected:
int GetLevel()

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


GetRunningTotal Method

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.GetRunningTotal Method
DataBandBase Class See Also Send Feedback
Gets the running total by its name

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double GetRunningTotal(
    string name
)
Visual Basic (Declaration)
Public Function GetRunningTotal ( _
    name As String _
) As Double
Visual C++
public:
double GetRunningTotal(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
DataBandBase..::.GetScripts Method
DataBandBase Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Overridden. See GetScripts(ScriptInfoCollection). (Overrides AggregatesRegularBand..::.GetScripts(ScriptInfoCollection).)

See Also

DataBandBase Class
DataBandBase Members
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method (ScriptInfoCollection)

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.GetScripts Method (ScriptInfoCollection)
DataBandBase Class See Also Send Feedback
Overridden. See GetScripts(ScriptInfoCollection).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void GetScripts(
    ScriptInfoCollection scripts
)
Visual Basic (Declaration)
Public Overrides Sub GetScripts ( _
    scripts As ScriptInfoCollection _
)
Visual C++
public:
virtual void GetScripts(
    ScriptInfoCollection^ scripts
) override

Parameters

scripts
Type: PerpetuumSoft.Reporting.Rendering..::.ScriptInfoCollection

See Also

DataBandBase Class
GetScripts Overload
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaptionColor Method

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.GetSectionCaptionColor Method
DataBandBase Class See Also Send Feedback
Gets section caption color

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Color GetSectionCaptionColor()
Visual Basic (Declaration)
Protected Overrides Function GetSectionCaptionColor As Color
Visual C++
protected:
virtual Color GetSectionCaptionColor() override

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


GetTotal Method

[image] [image]

.NET ModelKit Suite ClassReference
DataBandBase..::.GetTotal Method
DataBandBase Class See Also Send Feedback

Overload List

Name | Description
GetTotal(String) | Gets field total
GetTotal(String, Double) |

See Also

DataBandBase Class
DataBandBase Members
PerpetuumSoft.Reporting.DOM Namespace


GetTotal Method (String)

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.GetTotal Method (String)
DataBandBase Class See Also Send Feedback
Gets field total

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double GetTotal(
    string name
)
Visual Basic (Declaration)
Public Function GetTotal ( _
    name As String _
) As Double
Visual C++
public:
double GetTotal(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

DataBandBase Class
GetTotal Overload
PerpetuumSoft.Reporting.DOM Namespace


GetTotal Method (String, Double)

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.GetTotal Method (String, Double)
DataBandBase Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.DataBandBase.GetTotal(System.String,System.Double)]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double GetTotal(
    string name,
    double defaultValue
)
Visual Basic (Declaration)
Public Function GetTotal ( _
    name As String, _
    defaultValue As Double _
) As Double
Visual C++
public:
double GetTotal(
    String^ name,
    double defaultValue
)

Parameters

name
Type: System..::.String
defaultValue
Type: System..::.Double

See Also

DataBandBase Class
GetTotal Overload
PerpetuumSoft.Reporting.DOM Namespace


GetTotals Method

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.GetTotals Method
DataBandBase Class See Also Send Feedback
Gets total value

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected abstract DataBandTotalCollection GetTotals()
Visual Basic (Declaration)
Protected MustOverride Function GetTotals As DataBandTotalCollection
Visual C++
protected:
virtual DataBandTotalCollection^ GetTotals() abstract

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


IsValidChild Method

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.IsValidChild Method
DataBandBase Class See Also Send Feedback
Implements IsValidChild(ReportControl).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValidChild(
    ReportControl c
)
Visual Basic (Declaration)
Public Overrides Function IsValidChild ( _
    c As ReportControl _
) As Boolean
Visual C++
public:
virtual bool IsValidChild(
    ReportControl^ c
) override

Parameters

c
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

Implements

IContainerControl..::.IsValidChild(ReportControl)

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


Max Method

[image] [image]

.NET ModelKit Suite ClassReference
DataBandBase..::.Max Method
DataBandBase Class See Also Send Feedback

Overload List

Name | Description
Max(String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)

See Also

DataBandBase Class
DataBandBase Members
PerpetuumSoft.Reporting.DOM Namespace


Min Method

[image] [image]

.NET ModelKit Suite ClassReference
DataBandBase..::.Min Method
DataBandBase Class See Also Send Feedback

Overload List

Name | Description
Min(String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)

See Also

DataBandBase Class
DataBandBase Members
PerpetuumSoft.Reporting.DOM Namespace


OnGetData Method

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.OnGetData Method
DataBandBase Class See Also Send Feedback
Raises the GetData event.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnGetData(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnGetData ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnGetData(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


OnPaint Method

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.OnPaint Method
DataBandBase Class See Also Send Feedback
Performs drawing of the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
protected:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


ProcessRecordCore Method

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.ProcessRecordCore Method
DataBandBase Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.DataBandBase.ProcessRecordCore]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected internal abstract void ProcessRecordCore()
Visual Basic (Declaration)
Protected Friend MustOverride Sub ProcessRecordCore
Visual C++
protected public:
virtual void ProcessRecordCore() abstract

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


RaiseGetData Method

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.RaiseGetData Method
DataBandBase Class See Also Send Feedback
Invokes OnGetData method.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected void RaiseGetData()
Visual Basic (Declaration)
Protected Sub RaiseGetData
Visual C++
protected:
void RaiseGetData()

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.Render Method
DataBandBase Class See Also Send Feedback
Overridden. See Render()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


StartPropagate Method

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.StartPropagate Method
DataBandBase Class See Also Send Feedback
Switches the band to propagate mode.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void StartPropagate()
Visual Basic (Declaration)
Public Sub StartPropagate
Visual C++
public:
void StartPropagate()

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


StopPropagate Method

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.StopPropagate Method
DataBandBase Class See Also Send Feedback
Resets value by the PropagateMode

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void StopPropagate()
Visual Basic (Declaration)
Public Sub StopPropagate
Visual C++
public:
void StopPropagate()

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


Sum Method

[image] [image]

.NET ModelKit Suite ClassReference
DataBandBase..::.Sum Method
DataBandBase Class See Also Send Feedback

Overload List

Name | Description
Sum(String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)

See Also

DataBandBase Class
DataBandBase Members
PerpetuumSoft.Reporting.DOM Namespace


DataBandBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataBandBase Properties
DataBandBase Class See Also Send Feedback

The DataBandBase type exposes the following members.

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
ColumnsCount | Gets or sets columns count
ColumnsGap | Gets or sets gap between columns
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DataItem | Gets the current record data.
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GetDataScript | Gets and sets the code of the script that will be invoked when the band obtains data from the data source.
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
IsFirstLine | Gets if the first line is rendered.
IsLastLine | Gets if the last line is rendered.
Item | Gets a value of the specified field from the current record.
LineNumber | Gets the number of the currently rendered line.
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RecordNumber | Gets the number of the current record.
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowBottom | Gets and sets whether the bottom bar of the band should be displayed in the design mode.
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


ColumnsCount Property

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.ColumnsCount Property
DataBandBase Class See Also Send Feedback
Gets or sets columns count

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int ColumnsCount { get; set; }
Visual Basic (Declaration)
Public Property ColumnsCount As Integer
Visual C++
public:
property int ColumnsCount {
    int get ();
    void set (int value);
}

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


ColumnsGap Property

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.ColumnsGap Property
DataBandBase Class See Also Send Feedback
Gets or sets gap between columns

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double ColumnsGap { get; set; }
Visual Basic (Declaration)
Public Property ColumnsGap As Double
Visual C++
public:
property double ColumnsGap {
    double get ();
    void set (double value);
}

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


DataItem Property

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.DataItem Property
DataBandBase Class See Also Send Feedback
Gets the current record data.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object DataItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataItem As Object
Visual C++
public:
property Object^ DataItem {
    Object^ get ();
}

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


GetDataScript Property

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.GetDataScript Property
DataBandBase Class See Also Send Feedback
Gets and sets the code of the script that will be invoked when the band obtains data from the data source.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string GetDataScript { get; set; }
Visual Basic (Declaration)
Public Property GetDataScript As String
Visual C++
public:
property String^ GetDataScript {
    String^ get ();
    void set (String^ value);
}

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


IsFirstLine Property

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.IsFirstLine Property
DataBandBase Class See Also Send Feedback
Gets if the first line is rendered.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool IsFirstLine { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFirstLine As Boolean
Visual C++
public:
property bool IsFirstLine {
    bool get ();
}

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


IsLastLine Property

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.IsLastLine Property
DataBandBase Class See Also Send Feedback
Gets if the last line is rendered.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool IsLastLine { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsLastLine As Boolean
Visual C++
public:
property bool IsLastLine {
    bool get ();
}

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.Item Property
DataBandBase Class See Also Send Feedback
Gets a value of the specified field from the current record.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual Object this[
    string field
] { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Default Property Item ( _
    field As String _
) As Object
Visual C++
public:
virtual property Object^ default[String^ field] {
    Object^ get (String^ field);
}

Parameters

field
Type: System..::.String

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


LineNumber Property

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.LineNumber Property
DataBandBase Class See Also Send Feedback
Gets the number of the currently rendered line.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int LineNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property LineNumber As Integer
Visual C++
public:
property int LineNumber {
    int get ();
}

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


RecordNumber Property

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.RecordNumber Property
DataBandBase Class See Also Send Feedback
Gets the number of the current record.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int RecordNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property RecordNumber As Integer
Visual C++
public:
property int RecordNumber {
    int get ();
}

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


ShowBottom Property

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.ShowBottom Property
DataBandBase Class See Also Send Feedback
Gets and sets whether the bottom bar of the band should be displayed in the design mode.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowBottom { get; set; }
Visual Basic (Declaration)
Public Property ShowBottom As Boolean
Visual C++
public:
property bool ShowBottom {
    bool get ();
    void set (bool value);
}

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandBase Events

[image] [image]

.NET ModelKit Suite ClassReference
DataBandBase Events
DataBandBase Class See Also Send Feedback

The DataBandBase type exposes the following members.

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)
GetData | Occurs when a data item is obtained from the data source.

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


GetData Event

[image]

.NET ModelKit Suite ClassReference
DataBandBase..::.GetData Event
DataBandBase Class See Also Send Feedback
Occurs when a data item is obtained from the data source.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler GetData
Visual Basic (Declaration)
Public Event GetData As EventHandler
Visual C++
public:
 event EventHandler^ GetData {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DataBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandSort Class

[image]

.NET ModelKit Suite ClassReference
DataBandSort Class
Members See Also Send Feedback
The type representing data sorting settings

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DataBandSort : ICloneable
Visual Basic (Declaration)
Public Class DataBandSort _
    Implements ICloneable
Visual C++
public ref class DataBandSort : ICloneable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.DataBandSort

See Also

DataBandSort Members
PerpetuumSoft.Reporting.DOM Namespace


DataBandSort Members

[image] [image]

.NET ModelKit Suite ClassReference
DataBandSort Members
DataBandSort Class Constructors Methods Properties See Also Send Feedback

The DataBandSort type exposes the following members.

Constructors

Name | Description
DataBandSort | Initializes a new instance of the DataBandSort class.

Methods

Name | Description
Calculate | Implements Calculate(Object).
Clone | Implements Clone()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
Expression | Gets and sets sort expression.
Order | Implements Order()()().
Value | Gets or sets sorting expression value

See Also

DataBandSort Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandSort Constructor

[image]

.NET ModelKit Suite ClassReference
DataBandSort Constructor
DataBandSort Class See Also Send Feedback
Initializes a new instance of the DataBandSort class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataBandSort()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataBandSort()

See Also

DataBandSort Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandSort Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataBandSort Methods
DataBandSort Class See Also Send Feedback

The DataBandSort type exposes the following members.

Methods

Name | Description
Calculate | Implements Calculate(Object).
Clone | Implements Clone()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

DataBandSort Class
PerpetuumSoft.Reporting.DOM Namespace


Calculate Method

[image]

.NET ModelKit Suite ClassReference
DataBandSort..::.Calculate Method
DataBandSort Class See Also Send Feedback
Implements Calculate(Object).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Calculate(
    Object obj
)
Visual Basic (Declaration)
Public Function Calculate ( _
    obj As Object _
) As Object
Visual C++
public:
virtual Object^ Calculate(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object

See Also

DataBandSort Class
PerpetuumSoft.Reporting.DOM Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
DataBandSort..::.Clone Method
DataBandSort Class See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Implements

ICloneable..::.Clone()()()

See Also

DataBandSort Class
PerpetuumSoft.Reporting.DOM Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
DataBandSort..::.ToString Method
DataBandSort Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

DataBandSort Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandSort Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataBandSort Properties
DataBandSort Class See Also Send Feedback

The DataBandSort type exposes the following members.

Properties

Name | Description
Expression | Gets and sets sort expression.
Order | Implements Order()()().
Value | Gets or sets sorting expression value

See Also

DataBandSort Class
PerpetuumSoft.Reporting.DOM Namespace


Expression Property

[image]

.NET ModelKit Suite ClassReference
DataBandSort..::.Expression Property
DataBandSort Class See Also Send Feedback
Gets and sets sort expression.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

See Also

DataBandSort Class
PerpetuumSoft.Reporting.DOM Namespace


Order Property

[image]

.NET ModelKit Suite ClassReference
DataBandSort..::.Order Property
DataBandSort Class See Also Send Feedback
Implements Order()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public SortOrder Order { get; set; }
Visual Basic (Declaration)
Public Property Order As SortOrder
Visual C++
public:
virtual property SortOrder Order {
    SortOrder get () sealed;
    void set (SortOrder value) sealed;
}

See Also

DataBandSort Class
PerpetuumSoft.Reporting.DOM Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
DataBandSort..::.Value Property
DataBandSort Class See Also Send Feedback
Gets or sets sorting expression value

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

DataBandSort Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandSortCollection Class

[image]

.NET ModelKit Suite ClassReference
DataBandSortCollection Class
Members See Also Send Feedback
Represents the data sorting settings collection

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DataBandSortCollection : Collection<DataBandSort>
Visual Basic (Declaration)
Public Class DataBandSortCollection _
    Inherits Collection(Of DataBandSort)
Visual C++
public ref class DataBandSortCollection : public Collection<DataBandSort^>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( DataBandSort >)>)
PerpetuumSoft.Reporting.DOM..::.DataBandSortCollection

See Also

DataBandSortCollection Members
PerpetuumSoft.Reporting.DOM Namespace


DataBandSortCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
DataBandSortCollection Members
DataBandSortCollection Class Constructors Methods Properties See Also Send Feedback

The DataBandSortCollection type exposes the following members.

Constructors

Name | Description
DataBandSortCollection | Initializes a new instance of the DataBandSortCollection class.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DataBandSort >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DataBandSort >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DataBandSort >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <( DataBandSort >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( DataBandSort >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)

See Also

DataBandSortCollection Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandSortCollection Constructor

[image]

.NET ModelKit Suite ClassReference
DataBandSortCollection Constructor
DataBandSortCollection Class See Also Send Feedback
Initializes a new instance of the DataBandSortCollection class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataBandSortCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataBandSortCollection()

See Also

DataBandSortCollection Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandSortCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataBandSortCollection Methods
DataBandSortCollection Class See Also Send Feedback

The DataBandSortCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DataBandSort >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DataBandSort >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DataBandSort >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <( DataBandSort >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataBandSortCollection Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandSortCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataBandSortCollection Properties
DataBandSortCollection Class See Also Send Feedback

The DataBandSortCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( DataBandSort >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandSort >)>).)

See Also

DataBandSortCollection Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandTotal Class

[image]

.NET ModelKit Suite ClassReference
DataBandTotal Class
Members See Also Send Feedback
Determines totals calculation settings collection

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DataBandTotal : ICloneable
Visual Basic (Declaration)
Public Class DataBandTotal _
    Implements ICloneable
Visual C++
public ref class DataBandTotal : ICloneable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.DataBandTotal

See Also

DataBandTotal Members
PerpetuumSoft.Reporting.DOM Namespace


DataBandTotal Members

[image] [image]

.NET ModelKit Suite ClassReference
DataBandTotal Members
DataBandTotal Class Constructors Methods Properties See Also Send Feedback

The DataBandTotal type exposes the following members.

Constructors

Name | Description
DataBandTotal | Initializes a new instance of the DataBandTotal class.

Methods

Name | Description
Calculate | Implements Calculate(Object).
Clone | Implements Clone()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
AggregateFunction | Gets or sets AggregateFunctionFactory
Expression | Gets or sets aggregate expression.
Name | Gets or sets Name
Value | Gets or sets values totals are calculated by

See Also

DataBandTotal Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandTotal Constructor

[image]

.NET ModelKit Suite ClassReference
DataBandTotal Constructor
DataBandTotal Class See Also Send Feedback
Initializes a new instance of the DataBandTotal class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataBandTotal()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataBandTotal()

See Also

DataBandTotal Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandTotal Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataBandTotal Methods
DataBandTotal Class See Also Send Feedback

The DataBandTotal type exposes the following members.

Methods

Name | Description
Calculate | Implements Calculate(Object).
Clone | Implements Clone()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

DataBandTotal Class
PerpetuumSoft.Reporting.DOM Namespace


Calculate Method

[image]

.NET ModelKit Suite ClassReference
DataBandTotal..::.Calculate Method
DataBandTotal Class See Also Send Feedback
Implements Calculate(Object).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double Calculate(
    Object record
)
Visual Basic (Declaration)
Public Function Calculate ( _
    record As Object _
) As Double
Visual C++
public:
virtual double Calculate(
    Object^ record
) sealed

Parameters

record
Type: System..::.Object

See Also

DataBandTotal Class
PerpetuumSoft.Reporting.DOM Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
DataBandTotal..::.Clone Method
DataBandTotal Class See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Implements

ICloneable..::.Clone()()()

See Also

DataBandTotal Class
PerpetuumSoft.Reporting.DOM Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
DataBandTotal..::.ToString Method
DataBandTotal Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

DataBandTotal Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandTotal Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataBandTotal Properties
DataBandTotal Class See Also Send Feedback

The DataBandTotal type exposes the following members.

Properties

Name | Description
AggregateFunction | Gets or sets AggregateFunctionFactory
Expression | Gets or sets aggregate expression.
Name | Gets or sets Name
Value | Gets or sets values totals are calculated by

See Also

DataBandTotal Class
PerpetuumSoft.Reporting.DOM Namespace


AggregateFunction Property

[image]

.NET ModelKit Suite ClassReference
DataBandTotal..::.AggregateFunction Property
DataBandTotal Class See Also Send Feedback
Gets or sets AggregateFunctionFactory

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public AggregateFunctionFactory AggregateFunction { get; set; }
Visual Basic (Declaration)
Public Property AggregateFunction As AggregateFunctionFactory
Visual C++
public:
property AggregateFunctionFactory^ AggregateFunction {
    AggregateFunctionFactory^ get ();
    void set (AggregateFunctionFactory^ value);
}

See Also

DataBandTotal Class
PerpetuumSoft.Reporting.DOM Namespace


Expression Property

[image]

.NET ModelKit Suite ClassReference
DataBandTotal..::.Expression Property
DataBandTotal Class See Also Send Feedback
Gets or sets aggregate expression.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

See Also

DataBandTotal Class
PerpetuumSoft.Reporting.DOM Namespace


Name Property

[image]

.NET ModelKit Suite ClassReference
DataBandTotal..::.Name Property
DataBandTotal Class See Also Send Feedback
Gets or sets Name

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

DataBandTotal Class
PerpetuumSoft.Reporting.DOM Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
DataBandTotal..::.Value Property
DataBandTotal Class See Also Send Feedback
Gets or sets values totals are calculated by

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

DataBandTotal Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandTotalCollection Class

[image]

.NET ModelKit Suite ClassReference
DataBandTotalCollection Class
Members See Also Send Feedback
Determines totals calculation settings collection

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DataBandTotalCollection : Collection<DataBandTotal>
Visual Basic (Declaration)
Public Class DataBandTotalCollection _
    Inherits Collection(Of DataBandTotal)
Visual C++
public ref class DataBandTotalCollection : public Collection<DataBandTotal^>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( DataBandTotal >)>)
PerpetuumSoft.Reporting.DOM..::.DataBandTotalCollection

See Also

DataBandTotalCollection Members
PerpetuumSoft.Reporting.DOM Namespace


DataBandTotalCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
DataBandTotalCollection Members
DataBandTotalCollection Class Constructors Methods Properties See Also Send Feedback

The DataBandTotalCollection type exposes the following members.

Constructors

Name | Description
DataBandTotalCollection | Initializes a new instance of the DataBandTotalCollection class.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DataBandTotal >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DataBandTotal >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DataBandTotal >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <( DataBandTotal >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( DataBandTotal >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)

See Also

DataBandTotalCollection Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandTotalCollection Constructor

[image]

.NET ModelKit Suite ClassReference
DataBandTotalCollection Constructor
DataBandTotalCollection Class See Also Send Feedback
Initializes a new instance of the DataBandTotalCollection class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataBandTotalCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataBandTotalCollection()

See Also

DataBandTotalCollection Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandTotalCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataBandTotalCollection Methods
DataBandTotalCollection Class See Also Send Feedback

The DataBandTotalCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
ClearItems | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DataBandTotal >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DataBandTotal >)>).)
InsertItem | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DataBandTotal >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
RemoveItem | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <( DataBandTotal >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataBandTotalCollection Class
PerpetuumSoft.Reporting.DOM Namespace


DataBandTotalCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataBandTotalCollection Properties
DataBandTotalCollection Class See Also Send Feedback

The DataBandTotalCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( DataBandTotal >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataBandTotal >)>).)

See Also

DataBandTotalCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Detail Class

[image]

.NET ModelKit Suite ClassReference
Detail Class
Members See Also Send Feedback
Defines a detail band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Detail : DetailBase
Visual Basic (Declaration)
Public Class Detail _
    Inherits DetailBase
Visual C++
public ref class Detail : public DetailBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.RegularBandBase
PerpetuumSoft.Reporting.DOM..::.RegularBand
PerpetuumSoft.Reporting.DOM..::.AggregatesRegularBand
PerpetuumSoft.Reporting.DOM..::.DetailBase
PerpetuumSoft.Reporting.DOM..::.Detail

See Also

Detail Members
PerpetuumSoft.Reporting.DOM Namespace


Detail Members

[image] [image]

.NET ModelKit Suite ClassReference
Detail Members
Detail Class Constructors Methods Properties Events See Also Send Feedback

The Detail type exposes the following members.

Constructors

Name | Description
Detail | Creates a new instance of Detail class.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from DetailBase.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string for the band. (Inherited from DetailBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Overrides DetailBase..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from RegularBandBase.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the control to final document. (Inherited from DetailBase.)
RenderControls | (Inherited from DetailBase.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates free page area after the band is rendered. (Inherited from DetailBase.)

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanBreak | Indicates whether the breakable elements will break. (Inherited from DetailBase.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
MinSpaceAfter | Gets and sets minimum space beetween bands bottom and page bottom margins. (Inherited from DetailBase.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

Detail Class
PerpetuumSoft.Reporting.DOM Namespace


Detail Constructor

[image]

.NET ModelKit Suite ClassReference
Detail Constructor
Detail Class See Also Send Feedback
Creates a new instance of Detail class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Detail()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Detail()

See Also

Detail Class
PerpetuumSoft.Reporting.DOM Namespace


Detail Methods

[image] [image]

.NET ModelKit Suite ClassReference
Detail Methods
Detail Class See Also Send Feedback

The Detail type exposes the following members.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from DetailBase.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string for the band. (Inherited from DetailBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Overrides DetailBase..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from RegularBandBase.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the control to final document. (Inherited from DetailBase.)
RenderControls | (Inherited from DetailBase.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates free page area after the band is rendered. (Inherited from DetailBase.)

See Also

Detail Class
PerpetuumSoft.Reporting.DOM Namespace


Avg Method

[image] [image]

.NET ModelKit Suite ClassReference
Detail..::.Avg Method
Detail Class See Also Send Feedback

Overload List

Name | Description
Avg(String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)

See Also

Detail Class
Detail Members
PerpetuumSoft.Reporting.DOM Namespace


Count Method

[image] [image]

.NET ModelKit Suite ClassReference
Detail..::.Count Method
Detail Class See Also Send Feedback

Overload List

Name | Description
Count(String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)

See Also

Detail Class
Detail Members
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
Detail..::.GetScripts Method
Detail Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Overridden. See GetScripts(ScriptInfoCollection). (Inherited from AggregatesRegularBand.)

See Also

Detail Class
Detail Members
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaptionColor Method

[image]

.NET ModelKit Suite ClassReference
Detail..::.GetSectionCaptionColor Method
Detail Class See Also Send Feedback
Returns the color of the title bar.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Color GetSectionCaptionColor()
Visual Basic (Declaration)
Protected Overrides Function GetSectionCaptionColor As Color
Visual C++
protected:
virtual Color GetSectionCaptionColor() override

See Also

Detail Class
PerpetuumSoft.Reporting.DOM Namespace


Max Method

[image] [image]

.NET ModelKit Suite ClassReference
Detail..::.Max Method
Detail Class See Also Send Feedback

Overload List

Name | Description
Max(String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)

See Also

Detail Class
Detail Members
PerpetuumSoft.Reporting.DOM Namespace


Min Method

[image] [image]

.NET ModelKit Suite ClassReference
Detail..::.Min Method
Detail Class See Also Send Feedback

Overload List

Name | Description
Min(String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)

See Also

Detail Class
Detail Members
PerpetuumSoft.Reporting.DOM Namespace


Sum Method

[image] [image]

.NET ModelKit Suite ClassReference
Detail..::.Sum Method
Detail Class See Also Send Feedback

Overload List

Name | Description
Sum(String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)

See Also

Detail Class
Detail Members
PerpetuumSoft.Reporting.DOM Namespace


Detail Properties

[image] [image]

.NET ModelKit Suite ClassReference
Detail Properties
Detail Class See Also Send Feedback

The Detail type exposes the following members.

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanBreak | Indicates whether the breakable elements will break. (Inherited from DetailBase.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
MinSpaceAfter | Gets and sets minimum space beetween bands bottom and page bottom margins. (Inherited from DetailBase.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

Detail Class
PerpetuumSoft.Reporting.DOM Namespace


Detail Events

[image] [image]

.NET ModelKit Suite ClassReference
Detail Events
Detail Class See Also Send Feedback

The Detail type exposes the following members.

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

Detail Class
PerpetuumSoft.Reporting.DOM Namespace


DetailBase Class

[image]

.NET ModelKit Suite ClassReference
DetailBase Class
Members See Also Send Feedback
Base class for all detail bands.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DetailBase : AggregatesRegularBand
Visual Basic (Declaration)
Public Class DetailBase _
    Inherits AggregatesRegularBand
Visual C++
public ref class DetailBase : public AggregatesRegularBand

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.RegularBandBase
PerpetuumSoft.Reporting.DOM..::.RegularBand
PerpetuumSoft.Reporting.DOM..::.AggregatesRegularBand
PerpetuumSoft.Reporting.DOM..::.DetailBase
PerpetuumSoft.Reporting.DOM..::.Detail
PerpetuumSoft.Reporting.DOM..::.Footer
PerpetuumSoft.Reporting.DOM..::.GroupBandBase
PerpetuumSoft.Reporting.DOM..::.Header

See Also

DetailBase Members
PerpetuumSoft.Reporting.DOM Namespace


DetailBase Members

[image] [image]

.NET ModelKit Suite ClassReference
DetailBase Members
DetailBase Class Constructors Methods Properties Events See Also Send Feedback

The DetailBase type exposes the following members.

Constructors

Name | Description
DetailBase | Creates a new instance of DetailBase class.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Overrides Section..::.CalculateCaretPosition()()().)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string for the band. (Overrides BandBase..::.GetSectionCaption()()().)
GetSectionCaptionColor | Returns the color of the title bar. (Overrides Section..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from RegularBandBase.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the control to final document. (Overrides AggregatesRegularBand..::.Render()()().)
RenderControls | (Overrides Section..::.RenderControls()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates free page area after the band is rendered. (Overrides Section..::.UpdatePageArea()()().)

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanBreak | Indicates whether the breakable elements will break.
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
MinSpaceAfter | Gets and sets minimum space beetween bands bottom and page bottom margins.
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

DetailBase Class
PerpetuumSoft.Reporting.DOM Namespace


DetailBase Constructor

[image]

.NET ModelKit Suite ClassReference
DetailBase Constructor
DetailBase Class See Also Send Feedback
Creates a new instance of DetailBase class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DetailBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailBase()

See Also

DetailBase Class
PerpetuumSoft.Reporting.DOM Namespace


DetailBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
DetailBase Methods
DetailBase Class See Also Send Feedback

The DetailBase type exposes the following members.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Overrides Section..::.CalculateCaretPosition()()().)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string for the band. (Overrides BandBase..::.GetSectionCaption()()().)
GetSectionCaptionColor | Returns the color of the title bar. (Overrides Section..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from RegularBandBase.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the control to final document. (Overrides AggregatesRegularBand..::.Render()()().)
RenderControls | (Overrides Section..::.RenderControls()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates free page area after the band is rendered. (Overrides Section..::.UpdatePageArea()()().)

See Also

DetailBase Class
PerpetuumSoft.Reporting.DOM Namespace


Avg Method

[image] [image]

.NET ModelKit Suite ClassReference
DetailBase..::.Avg Method
DetailBase Class See Also Send Feedback

Overload List

Name | Description
Avg(String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)

See Also

DetailBase Class
DetailBase Members
PerpetuumSoft.Reporting.DOM Namespace


CalculateCaretPosition Method

[image]

.NET ModelKit Suite ClassReference
DetailBase..::.CalculateCaretPosition Method
DetailBase Class See Also Send Feedback
Calculates the current position in the report for placing the current band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void CalculateCaretPosition()
Visual Basic (Declaration)
Protected Overrides Sub CalculateCaretPosition
Visual C++
protected:
virtual void CalculateCaretPosition() override

See Also

DetailBase Class
PerpetuumSoft.Reporting.DOM Namespace


Count Method

[image] [image]

.NET ModelKit Suite ClassReference
DetailBase..::.Count Method
DetailBase Class See Also Send Feedback

Overload List

Name | Description
Count(String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)

See Also

DetailBase Class
DetailBase Members
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
DetailBase..::.GetScripts Method
DetailBase Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Overridden. See GetScripts(ScriptInfoCollection). (Inherited from AggregatesRegularBand.)

See Also

DetailBase Class
DetailBase Members
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaption Method

[image]

.NET ModelKit Suite ClassReference
DetailBase..::.GetSectionCaption Method
DetailBase Class See Also Send Feedback
Returns the title string for the band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override string GetSectionCaption()
Visual Basic (Declaration)
Protected Overrides Function GetSectionCaption As String
Visual C++
protected:
virtual String^ GetSectionCaption() override

See Also

DetailBase Class
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaptionColor Method

[image]

.NET ModelKit Suite ClassReference
DetailBase..::.GetSectionCaptionColor Method
DetailBase Class See Also Send Feedback
Returns the color of the title bar.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Color GetSectionCaptionColor()
Visual Basic (Declaration)
Protected Overrides Function GetSectionCaptionColor As Color
Visual C++
protected:
virtual Color GetSectionCaptionColor() override

See Also

DetailBase Class
PerpetuumSoft.Reporting.DOM Namespace


Max Method

[image] [image]

.NET ModelKit Suite ClassReference
DetailBase..::.Max Method
DetailBase Class See Also Send Feedback

Overload List

Name | Description
Max(String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)

See Also

DetailBase Class
DetailBase Members
PerpetuumSoft.Reporting.DOM Namespace


Min Method

[image] [image]

.NET ModelKit Suite ClassReference
DetailBase..::.Min Method
DetailBase Class See Also Send Feedback

Overload List

Name | Description
Min(String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)

See Also

DetailBase Class
DetailBase Members
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
DetailBase..::.Render Method
DetailBase Class See Also Send Feedback
Renders the control to final document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

DetailBase Class
PerpetuumSoft.Reporting.DOM Namespace


RenderControls Method

[image]

.NET ModelKit Suite ClassReference
DetailBase..::.RenderControls Method
DetailBase Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.DetailBase.RenderControls]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void RenderControls()
Visual Basic (Declaration)
Protected Overrides Sub RenderControls
Visual C++
protected:
virtual void RenderControls() override

See Also

DetailBase Class
PerpetuumSoft.Reporting.DOM Namespace


Sum Method

[image] [image]

.NET ModelKit Suite ClassReference
DetailBase..::.Sum Method
DetailBase Class See Also Send Feedback

Overload List

Name | Description
Sum(String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)

See Also

DetailBase Class
DetailBase Members
PerpetuumSoft.Reporting.DOM Namespace


UpdatePageArea Method

[image]

.NET ModelKit Suite ClassReference
DetailBase..::.UpdatePageArea Method
DetailBase Class See Also Send Feedback
Calculates free page area after the band is rendered.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void UpdatePageArea()
Visual Basic (Declaration)
Protected Overrides Sub UpdatePageArea
Visual C++
protected:
virtual void UpdatePageArea() override

See Also

DetailBase Class
PerpetuumSoft.Reporting.DOM Namespace


DetailBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
DetailBase Properties
DetailBase Class See Also Send Feedback

The DetailBase type exposes the following members.

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanBreak | Indicates whether the breakable elements will break.
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
MinSpaceAfter | Gets and sets minimum space beetween bands bottom and page bottom margins.
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

DetailBase Class
PerpetuumSoft.Reporting.DOM Namespace


CanBreak Property

[image]

.NET ModelKit Suite ClassReference
DetailBase..::.CanBreak Property
DetailBase Class See Also Send Feedback
Indicates whether the breakable elements will break.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool CanBreak { get; set; }
Visual Basic (Declaration)
Public Property CanBreak As Boolean
Visual C++
public:
property bool CanBreak {
    bool get ();
    void set (bool value);
}

See Also

DetailBase Class
PerpetuumSoft.Reporting.DOM Namespace


MinSpaceAfter Property

[image]

.NET ModelKit Suite ClassReference
DetailBase..::.MinSpaceAfter Property
DetailBase Class See Also Send Feedback
Gets and sets minimum space beetween bands bottom and page bottom margins.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double MinSpaceAfter { get; set; }
Visual Basic (Declaration)
Public Property MinSpaceAfter As Double
Visual C++
public:
property double MinSpaceAfter {
    double get ();
    void set (double value);
}

See Also

DetailBase Class
PerpetuumSoft.Reporting.DOM Namespace


DetailBase Events

[image] [image]

.NET ModelKit Suite ClassReference
DetailBase Events
DetailBase Class See Also Send Feedback

The DetailBase type exposes the following members.

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

DetailBase Class
PerpetuumSoft.Reporting.DOM Namespace


Document Class

[image]

.NET ModelKit Suite ClassReference
Document Class
Members See Also Send Feedback
Represents both report templates and final reports.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
[SerializableAttribute]
public class Document : ReportComponent, ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Document _
    Inherits ReportComponent _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class Document : public ReportComponent,
    ISerializable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.Document

See Also

Document Members
PerpetuumSoft.Reporting.DOM Namespace


Document Members

[image] [image]

.NET ModelKit Suite ClassReference
Document Members
Document Class Constructors Methods Properties Events See Also Send Feedback

The Document type exposes the following members.

Constructors

Name | Description
Document | Overloaded.

Methods

Name | Description
Assign | Assigns to all properties of this Document the corresponding values of the specified source document.
ControlByName | Finds a nested ReportControl object with the specified name.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the document.
GetScripts | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnGenerate | Raises Generate event.
RaiseGenerate | Invokes OnGenerate method.
RenderInstance | Renders the final document from the report template.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CommonScript | Gets and sets code of the main script sections. Allows you to declare global script variables as well as functions and procedures.
CompilerVersion |
CustomLanguageProvider | Gets and sets full name of the custom script language provider. Allows to use any .NET language as a script language for the Report Sharp-Shooter.
DataSources | Gets or sets DocumentDataSourceCollection
Description | Gets and sets document description.
DoublePass | Gets and sets whether second render pass should be done.
Engine | Gets and sets RenderEngine.
GenerateScript | Gets and sets code of the script that will be invoked before document is rendered.
GraphicsSettings | Gets or sets graphics settings to display controls in this document.
GridStep | Gets and sets the step of the grid.
Imports | Gets and sets collection of the used namespaces. Allows to use any namespaces available in the current application.
ImportsString | Gets and sets comma-separated list of the used namespaces. Allows to use any namespaces available in the current application.
IsTemplate | Gets and sets whether the document is report template.
MasterReport | Gets or sets master report name.
MetricUnit | Gets and sets the measure unit for the document.
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Pages | Gets the collection of pages in the document.
Parameters | Gets document parameters collection.
ScriptLanguage | Gets and sets script language for the report template.
ShowGrid | Gets and sets whether the grid should be displayed in the design mode.
ShowObjectBounds | Gets and sets a value indicating whether the object bounds should be displayed in the design mode.
SnapToGrid | Gets and sets whether objects should be snapped to grid in the design mode.
StyleSheet | Gets and sets StyleSheet for the document.
Title | Gets and sets document title.

Events

Name | Description
Generate | Occurs before the document is rendered.

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


Document Constructor

[image] [image]

.NET ModelKit Suite ClassReference
Document Constructor
Document Class See Also Send Feedback

Overload List

Name | Description
Document()()() | Initializes a new instance of the Document class.
Document(SerializationInfo, StreamingContext) | Initializes a new instance of the Document class

See Also

Document Class
Document Members
PerpetuumSoft.Reporting.DOM Namespace


Document Constructor

[image]

.NET ModelKit Suite ClassReference
Document Constructor
Document Class See Also Send Feedback
Initializes a new instance of the Document class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Document()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Document()

See Also

Document Class
Document Overload
PerpetuumSoft.Reporting.DOM Namespace


Document Constructor (SerializationInfo, StreamingContext)

[image]

.NET ModelKit Suite ClassReference
Document Constructor (SerializationInfo, StreamingContext)
Document Class See Also Send Feedback
Initializes a new instance of the Document class

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected Document(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
Document(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
context
Type: System.Runtime.Serialization..::.StreamingContext

See Also

Document Class
Document Overload
PerpetuumSoft.Reporting.DOM Namespace


Document Methods

[image] [image]

.NET ModelKit Suite ClassReference
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

Name | Description
Assign | Assigns to all properties of this Document the corresponding values of the specified source document.
ControlByName | Finds a nested ReportControl object with the specified name.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the document.
GetScripts | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnGenerate | Raises Generate event.
RaiseGenerate | Invokes OnGenerate method.
RenderInstance | Renders the final document from the report template.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


Assign Method

[image]

.NET ModelKit Suite ClassReference
Document..::.Assign Method
Document Class See Also Send Feedback
Assigns to all properties of this Document the corresponding values of the specified source document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual void Assign(
    Object source
)
Visual Basic (Declaration)
Public Overridable Sub Assign ( _
    source As Object _
)
Visual C++
public:
virtual void Assign(
    Object^ source
)

Parameters

source
Type: System..::.Object

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


ControlByName Method

[image]

.NET ModelKit Suite ClassReference
Document..::.ControlByName Method
Document Class See Also Send Feedback
Finds a nested ReportControl object with the specified name.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportControl ControlByName(
    string controlName
)
Visual Basic (Declaration)
Public Function ControlByName ( _
    controlName As String _
) As ReportControl
Visual C++
public:
ReportControl^ ControlByName(
    String^ controlName
)

Parameters

controlName
Type: System..::.String

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


GetObjectData Method

[image]

.NET ModelKit Suite ClassReference
Document..::.GetObjectData Method
Document Class See Also Send Feedback
Populates a SerializationInfo with the data needed to serialize the document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
context
Type: System.Runtime.Serialization..::.StreamingContext

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
Document..::.GetScripts Method
Document Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Overrides ReportComponent..::.GetScripts(ScriptInfoCollection).)

See Also

Document Class
Document Members
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method (ScriptInfoCollection)

[image]

.NET ModelKit Suite ClassReference
Document..::.GetScripts Method (ScriptInfoCollection)
Document Class See Also Send Feedback
Fills the specified collection with all scripts assigned to the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void GetScripts(
    ScriptInfoCollection scripts
)
Visual Basic (Declaration)
Public Overrides Sub GetScripts ( _
    scripts As ScriptInfoCollection _
)
Visual C++
public:
virtual void GetScripts(
    ScriptInfoCollection^ scripts
) override

Parameters

scripts
Type: PerpetuumSoft.Reporting.Rendering..::.ScriptInfoCollection

See Also

Document Class
GetScripts Overload
PerpetuumSoft.Reporting.DOM Namespace


OnGenerate Method

[image]

.NET ModelKit Suite ClassReference
Document..::.OnGenerate Method
Document Class See Also Send Feedback
Raises Generate event.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnGenerate(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnGenerate ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnGenerate(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


RaiseGenerate Method

[image]

.NET ModelKit Suite ClassReference
Document..::.RaiseGenerate Method
Document Class See Also Send Feedback
Invokes OnGenerate method.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected void RaiseGenerate()
Visual Basic (Declaration)
Protected Sub RaiseGenerate
Visual C++
protected:
void RaiseGenerate()

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


RenderInstance Method

[image]

.NET ModelKit Suite ClassReference
Document..::.RenderInstance Method
Document Class See Also Send Feedback
Renders the final document from the report template.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Document RenderInstance()
Visual Basic (Declaration)
Public Function RenderInstance As Document
Visual C++
public:
Document^ RenderInstance()

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


Document Properties

[image] [image]

.NET ModelKit Suite ClassReference
Document Properties
Document Class See Also Send Feedback

The Document type exposes the following members.

Properties

Name | Description
CommonScript | Gets and sets code of the main script sections. Allows you to declare global script variables as well as functions and procedures.
CompilerVersion |
CustomLanguageProvider | Gets and sets full name of the custom script language provider. Allows to use any .NET language as a script language for the Report Sharp-Shooter.
DataSources | Gets or sets DocumentDataSourceCollection
Description | Gets and sets document description.
DoublePass | Gets and sets whether second render pass should be done.
Engine | Gets and sets RenderEngine.
GenerateScript | Gets and sets code of the script that will be invoked before document is rendered.
GraphicsSettings | Gets or sets graphics settings to display controls in this document.
GridStep | Gets and sets the step of the grid.
Imports | Gets and sets collection of the used namespaces. Allows to use any namespaces available in the current application.
ImportsString | Gets and sets comma-separated list of the used namespaces. Allows to use any namespaces available in the current application.
IsTemplate | Gets and sets whether the document is report template.
MasterReport | Gets or sets master report name.
MetricUnit | Gets and sets the measure unit for the document.
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Pages | Gets the collection of pages in the document.
Parameters | Gets document parameters collection.
ScriptLanguage | Gets and sets script language for the report template.
ShowGrid | Gets and sets whether the grid should be displayed in the design mode.
ShowObjectBounds | Gets and sets a value indicating whether the object bounds should be displayed in the design mode.
SnapToGrid | Gets and sets whether objects should be snapped to grid in the design mode.
StyleSheet | Gets and sets StyleSheet for the document.
Title | Gets and sets document title.

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


CommonScript Property

[image]

.NET ModelKit Suite ClassReference
Document..::.CommonScript Property
Document Class See Also Send Feedback
Gets and sets code of the main script sections. Allows you to declare global script variables as well as functions and procedures.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string CommonScript { get; set; }
Visual Basic (Declaration)
Public Property CommonScript As String
Visual C++
public:
property String^ CommonScript {
    String^ get ();
    void set (String^ value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


CompilerVersion Property

[image]

.NET ModelKit Suite ClassReference
Document..::.CompilerVersion Property
Document Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.DOM.Document.CompilerVersion]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string CompilerVersion { get; set; }
Visual Basic (Declaration)
Public Property CompilerVersion As String
Visual C++
public:
property String^ CompilerVersion {
    String^ get ();
    void set (String^ value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


CustomLanguageProvider Property

[image]

.NET ModelKit Suite ClassReference
Document..::.CustomLanguageProvider Property
Document Class See Also Send Feedback
Gets and sets full name of the custom script language provider. Allows to use any .NET language as a script language for the Report Sharp-Shooter.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string CustomLanguageProvider { get; set; }
Visual Basic (Declaration)
Public Property CustomLanguageProvider As String
Visual C++
public:
property String^ CustomLanguageProvider {
    String^ get ();
    void set (String^ value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


DataSources Property

[image]

.NET ModelKit Suite ClassReference
Document..::.DataSources Property
Document Class See Also Send Feedback
Gets or sets DocumentDataSourceCollection

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DocumentDataSourceCollection DataSources { get; set; }
Visual Basic (Declaration)
Public Property DataSources As DocumentDataSourceCollection
Visual C++
public:
property DocumentDataSourceCollection^ DataSources {
    DocumentDataSourceCollection^ get ();
    void set (DocumentDataSourceCollection^ value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


Description Property

[image]

.NET ModelKit Suite ClassReference
Document..::.Description Property
Document Class See Also Send Feedback
Gets and sets document description.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


DoublePass Property

[image]

.NET ModelKit Suite ClassReference
Document..::.DoublePass Property
Document Class See Also Send Feedback
Gets and sets whether second render pass should be done.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool DoublePass { get; set; }
Visual Basic (Declaration)
Public Property DoublePass As Boolean
Visual C++
public:
property bool DoublePass {
    bool get ();
    void set (bool value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


Engine Property

[image]

.NET ModelKit Suite ClassReference
Document..::.Engine Property
Document Class See Also Send Feedback
Gets and sets RenderEngine.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public RenderEngine Engine { get; set; }
Visual Basic (Declaration)
Public Property Engine As RenderEngine
Visual C++
public:
property RenderEngine^ Engine {
    RenderEngine^ get ();
    void set (RenderEngine^ value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


GenerateScript Property

[image]

.NET ModelKit Suite ClassReference
Document..::.GenerateScript Property
Document Class See Also Send Feedback
Gets and sets code of the script that will be invoked before document is rendered.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string GenerateScript { get; set; }
Visual Basic (Declaration)
Public Property GenerateScript As String
Visual C++
public:
property String^ GenerateScript {
    String^ get ();
    void set (String^ value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


GraphicsSettings Property

[image]

.NET ModelKit Suite ClassReference
Document..::.GraphicsSettings Property
Document Class See Also Send Feedback
Gets or sets graphics settings to display controls in this document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public GraphicsSettings GraphicsSettings { get; set; }
Visual Basic (Declaration)
Public Property GraphicsSettings As GraphicsSettings
Visual C++
public:
property GraphicsSettings^ GraphicsSettings {
    GraphicsSettings^ get ();
    void set (GraphicsSettings^ value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


GridStep Property

[image]

.NET ModelKit Suite ClassReference
Document..::.GridStep Property
Document Class See Also Send Feedback
Gets and sets the step of the grid.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double GridStep { get; set; }
Visual Basic (Declaration)
Public Property GridStep As Double
Visual C++
public:
property double GridStep {
    double get ();
    void set (double value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


Imports Property

[image]

.NET ModelKit Suite ClassReference
Document..::.Imports Property
Document Class See Also Send Feedback
Gets and sets collection of the used namespaces. Allows to use any namespaces available in the current application.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Imports { get; set; }
Visual Basic (Declaration)
Public Property Imports As String
Visual C++
public:
property String^ Imports {
    String^ get ();
    void set (String^ value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


ImportsString Property

[image]

.NET ModelKit Suite ClassReference
Document..::.ImportsString Property
Document Class See Also Send Feedback
Gets and sets comma-separated list of the used namespaces. Allows to use any namespaces available in the current application.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string ImportsString { get; set; }
Visual Basic (Declaration)
Public Property ImportsString As String
Visual C++
public:
property String^ ImportsString {
    String^ get ();
    void set (String^ value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


IsTemplate Property

[image]

.NET ModelKit Suite ClassReference
Document..::.IsTemplate Property
Document Class See Also Send Feedback
Gets and sets whether the document is report template.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool IsTemplate { get; set; }
Visual Basic (Declaration)
Public Property IsTemplate As Boolean
Visual C++
public:
property bool IsTemplate {
    bool get ();
    void set (bool value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


MasterReport Property

[image]

.NET ModelKit Suite ClassReference
Document..::.MasterReport Property
Document Class See Also Send Feedback
Gets or sets master report name.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string MasterReport { get; set; }
Visual Basic (Declaration)
Public Property MasterReport As String
Visual C++
public:
property String^ MasterReport {
    String^ get ();
    void set (String^ value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


MetricUnit Property

[image]

.NET ModelKit Suite ClassReference
Document..::.MetricUnit Property
Document Class See Also Send Feedback
Gets and sets the measure unit for the document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Unit MetricUnit { get; set; }
Visual Basic (Declaration)
Public Property MetricUnit As Unit
Visual C++
public:
property Unit MetricUnit {
    Unit get ();
    void set (Unit value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


Pages Property

[image]

.NET ModelKit Suite ClassReference
Document..::.Pages Property
Document Class See Also Send Feedback
Gets the collection of pages in the document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PageCollection Pages { get; }
Visual Basic (Declaration)
Public ReadOnly Property Pages As PageCollection
Visual C++
public:
property PageCollection^ Pages {
    PageCollection^ get ();
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


Parameters Property

[image]

.NET ModelKit Suite ClassReference
Document..::.Parameters Property
Document Class See Also Send Feedback
Gets document parameters collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ParameterCollection Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterCollection
Visual C++
public:
property ParameterCollection^ Parameters {
    ParameterCollection^ get ();
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


ScriptLanguage Property

[image]

.NET ModelKit Suite ClassReference
Document..::.ScriptLanguage Property
Document Class See Also Send Feedback
Gets and sets script language for the report template.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ScriptLanguage ScriptLanguage { get; set; }
Visual Basic (Declaration)
Public Property ScriptLanguage As ScriptLanguage
Visual C++
public:
property ScriptLanguage ScriptLanguage {
    ScriptLanguage get ();
    void set (ScriptLanguage value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


ShowGrid Property

[image]

.NET ModelKit Suite ClassReference
Document..::.ShowGrid Property
Document Class See Also Send Feedback
Gets and sets whether the grid should be displayed in the design mode.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowGrid { get; set; }
Visual Basic (Declaration)
Public Property ShowGrid As Boolean
Visual C++
public:
property bool ShowGrid {
    bool get ();
    void set (bool value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


ShowObjectBounds Property

[image]

.NET ModelKit Suite ClassReference
Document..::.ShowObjectBounds Property
Document Class See Also Send Feedback
Gets and sets a value indicating whether the object bounds should be displayed in the design mode.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowObjectBounds { get; set; }
Visual Basic (Declaration)
Public Property ShowObjectBounds As Boolean
Visual C++
public:
property bool ShowObjectBounds {
    bool get ();
    void set (bool value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


SnapToGrid Property

[image]

.NET ModelKit Suite ClassReference
Document..::.SnapToGrid Property
Document Class See Also Send Feedback
Gets and sets whether objects should be snapped to grid in the design mode.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool SnapToGrid { get; set; }
Visual Basic (Declaration)
Public Property SnapToGrid As Boolean
Visual C++
public:
property bool SnapToGrid {
    bool get ();
    void set (bool value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


StyleSheet Property

[image]

.NET ModelKit Suite ClassReference
Document..::.StyleSheet Property
Document Class See Also Send Feedback
Gets and sets StyleSheet for the document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public StyleSheet StyleSheet { get; set; }
Visual Basic (Declaration)
Public Property StyleSheet As StyleSheet
Visual C++
public:
property StyleSheet^ StyleSheet {
    StyleSheet^ get ();
    void set (StyleSheet^ value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


Title Property

[image]

.NET ModelKit Suite ClassReference
Document..::.Title Property
Document Class See Also Send Feedback
Gets and sets document title.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


Document Events

[image] [image]

.NET ModelKit Suite ClassReference
Document Events
Document Class See Also Send Feedback

The Document type exposes the following members.

Events

Name | Description
Generate | Occurs before the document is rendered.

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


Generate Event

[image]

.NET ModelKit Suite ClassReference
Document..::.Generate Event
Document Class See Also Send Feedback
Occurs before the document is rendered.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler Generate
Visual Basic (Declaration)
Public Event Generate As EventHandler
Visual C++
public:
 event EventHandler^ Generate {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

Document Class
PerpetuumSoft.Reporting.DOM Namespace


FindDirection Enumeration

[image]

.NET ModelKit Suite ClassReference
FindDirection Enumeration
See Also Send Feedback
Specifies search direction for FindText operations.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum FindDirection
Visual Basic (Declaration)
Public Enumeration FindDirection
Visual C++
public enum class FindDirection

Members

Member name | Description
Up | Backward search.
Down | Forward search.

See Also

PerpetuumSoft.Reporting.DOM Namespace


FindScope Enumeration

[image]

.NET ModelKit Suite ClassReference
FindScope Enumeration
See Also Send Feedback
Specifies the scope for FindText operations.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum FindScope
Visual Basic (Declaration)
Public Enumeration FindScope
Visual C++
public enum class FindScope

Members

Member name | Description
FromBegin | Start search form the document beginning.
FromCurrent | Start search from the current position.
FromEnd | Enumerates text location types.

See Also

PerpetuumSoft.Reporting.DOM Namespace


FindTextArgument Class

[image]

.NET ModelKit Suite ClassReference
FindTextArgument Class
Members See Also Send Feedback
Defines arguments for FindText operations.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class FindTextArgument
Visual Basic (Declaration)
Public Class FindTextArgument
Visual C++
public ref class FindTextArgument

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.FindTextArgument

See Also

FindTextArgument Members
PerpetuumSoft.Reporting.DOM Namespace


FindTextArgument Members

[image] [image]

.NET ModelKit Suite ClassReference
FindTextArgument Members
FindTextArgument Class Constructors Methods Properties See Also Send Feedback

The FindTextArgument type exposes the following members.

Constructors

Name | Description
FindTextArgument | Creates a new instance of FindTextArgument class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FindDirection | Gets and sets search direction.
FindScope | Gets and sets search scope.
FindText | Gets and sets the text string for search.
Options | Gets and sets the options object.

See Also

FindTextArgument Class
PerpetuumSoft.Reporting.DOM Namespace


FindTextArgument Constructor

[image]

.NET ModelKit Suite ClassReference
FindTextArgument Constructor
FindTextArgument Class See Also Send Feedback
Creates a new instance of FindTextArgument class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FindTextArgument()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FindTextArgument()

See Also

FindTextArgument Class
PerpetuumSoft.Reporting.DOM Namespace


FindTextArgument Methods

[image] [image]

.NET ModelKit Suite ClassReference
FindTextArgument Methods
FindTextArgument Class See Also Send Feedback

The FindTextArgument type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FindTextArgument Class
PerpetuumSoft.Reporting.DOM Namespace


FindTextArgument Properties

[image] [image]

.NET ModelKit Suite ClassReference
FindTextArgument Properties
FindTextArgument Class See Also Send Feedback

The FindTextArgument type exposes the following members.

Properties

Name | Description
FindDirection | Gets and sets search direction.
FindScope | Gets and sets search scope.
FindText | Gets and sets the text string for search.
Options | Gets and sets the options object.

See Also

FindTextArgument Class
PerpetuumSoft.Reporting.DOM Namespace


FindDirection Property

[image]

.NET ModelKit Suite ClassReference
FindTextArgument..::.FindDirection Property
FindTextArgument Class See Also Send Feedback
Gets and sets search direction.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FindDirection FindDirection { get; set; }
Visual Basic (Declaration)
Public Property FindDirection As FindDirection
Visual C++
public:
property FindDirection FindDirection {
    FindDirection get ();
    void set (FindDirection value);
}

See Also

FindTextArgument Class
PerpetuumSoft.Reporting.DOM Namespace


FindScope Property

[image]

.NET ModelKit Suite ClassReference
FindTextArgument..::.FindScope Property
FindTextArgument Class See Also Send Feedback
Gets and sets search scope.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FindScope FindScope { get; set; }
Visual Basic (Declaration)
Public Property FindScope As FindScope
Visual C++
public:
property FindScope FindScope {
    FindScope get ();
    void set (FindScope value);
}

See Also

FindTextArgument Class
PerpetuumSoft.Reporting.DOM Namespace


FindText Property

[image]

.NET ModelKit Suite ClassReference
FindTextArgument..::.FindText Property
FindTextArgument Class See Also Send Feedback
Gets and sets the text string for search.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string FindText { get; set; }
Visual Basic (Declaration)
Public Property FindText As String
Visual C++
public:
property String^ FindText {
    String^ get ();
    void set (String^ value);
}

See Also

FindTextArgument Class
PerpetuumSoft.Reporting.DOM Namespace


Options Property

[image]

.NET ModelKit Suite ClassReference
FindTextArgument..::.Options Property
FindTextArgument Class See Also Send Feedback
Gets and sets the options object.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FindTextOptions Options { get; set; }
Visual Basic (Declaration)
Public Property Options As FindTextOptions
Visual C++
public:
property FindTextOptions^ Options {
    FindTextOptions^ get ();
    void set (FindTextOptions^ value);
}

See Also

FindTextArgument Class
PerpetuumSoft.Reporting.DOM Namespace


FindTextOptions Class

[image]

.NET ModelKit Suite ClassReference
FindTextOptions Class
Members See Also Send Feedback
Specifies the options for FindText operations.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class FindTextOptions
Visual Basic (Declaration)
Public Class FindTextOptions
Visual C++
public ref class FindTextOptions

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.FindTextOptions

See Also

FindTextOptions Members
PerpetuumSoft.Reporting.DOM Namespace


FindTextOptions Members

[image] [image]

.NET ModelKit Suite ClassReference
FindTextOptions Members
FindTextOptions Class Constructors Methods Properties See Also Send Feedback

The FindTextOptions type exposes the following members.

Constructors

Name | Description
FindTextOptions | Creates a new instance of FindTextOptions class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MatchCase | Gets or sets whether match case.

See Also

FindTextOptions Class
PerpetuumSoft.Reporting.DOM Namespace


FindTextOptions Constructor

[image]

.NET ModelKit Suite ClassReference
FindTextOptions Constructor
FindTextOptions Class See Also Send Feedback
Creates a new instance of FindTextOptions class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FindTextOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FindTextOptions()

See Also

FindTextOptions Class
PerpetuumSoft.Reporting.DOM Namespace


FindTextOptions Methods

[image] [image]

.NET ModelKit Suite ClassReference
FindTextOptions Methods
FindTextOptions Class See Also Send Feedback

The FindTextOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FindTextOptions Class
PerpetuumSoft.Reporting.DOM Namespace


FindTextOptions Properties

[image] [image]

.NET ModelKit Suite ClassReference
FindTextOptions Properties
FindTextOptions Class See Also Send Feedback

The FindTextOptions type exposes the following members.

Properties

Name | Description
MatchCase | Gets or sets whether match case.

See Also

FindTextOptions Class
PerpetuumSoft.Reporting.DOM Namespace


MatchCase Property

[image]

.NET ModelKit Suite ClassReference
FindTextOptions..::.MatchCase Property
FindTextOptions Class See Also Send Feedback
Gets or sets whether match case.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool MatchCase { get; set; }
Visual Basic (Declaration)
Public Property MatchCase As Boolean
Visual C++
public:
property bool MatchCase {
    bool get ();
    void set (bool value);
}

See Also

FindTextOptions Class
PerpetuumSoft.Reporting.DOM Namespace


Footer Class

[image]

.NET ModelKit Suite ClassReference
Footer Class
Members See Also Send Feedback
Defines a footer band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Footer : DetailBase
Visual Basic (Declaration)
Public Class Footer _
    Inherits DetailBase
Visual C++
public ref class Footer : public DetailBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.RegularBandBase
PerpetuumSoft.Reporting.DOM..::.RegularBand
PerpetuumSoft.Reporting.DOM..::.AggregatesRegularBand
PerpetuumSoft.Reporting.DOM..::.DetailBase
PerpetuumSoft.Reporting.DOM..::.Footer

See Also

Footer Members
PerpetuumSoft.Reporting.DOM Namespace


Footer Members

[image] [image]

.NET ModelKit Suite ClassReference
Footer Members
Footer Class Constructors Methods Properties Events See Also Send Feedback

The Footer type exposes the following members.

Constructors

Name | Description
Footer | Creates a new instance of Footer class.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from DetailBase.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string for the band. (Inherited from DetailBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Overrides DetailBase..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from RegularBandBase.)
IsValidParent | Returns whether the band can be placed into the specified container. (Overrides ReportControl..::.IsValidParent(ReportControl).)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the control to final document. (Inherited from DetailBase.)
RenderControls | (Inherited from DetailBase.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates free page area after the band is rendered. (Inherited from DetailBase.)

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanBreak | Indicates whether the breakable elements will break. (Inherited from DetailBase.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
MinSpaceAfter | Gets and sets minimum space beetween bands bottom and page bottom margins. (Inherited from DetailBase.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Overrides Section..::.SortPriority.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

Footer Class
PerpetuumSoft.Reporting.DOM Namespace


Footer Constructor

[image]

.NET ModelKit Suite ClassReference
Footer Constructor
Footer Class See Also Send Feedback
Creates a new instance of Footer class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Footer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Footer()

See Also

Footer Class
PerpetuumSoft.Reporting.DOM Namespace


Footer Methods

[image] [image]

.NET ModelKit Suite ClassReference
Footer Methods
Footer Class See Also Send Feedback

The Footer type exposes the following members.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from DetailBase.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string for the band. (Inherited from DetailBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Overrides DetailBase..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from RegularBandBase.)
IsValidParent | Returns whether the band can be placed into the specified container. (Overrides ReportControl..::.IsValidParent(ReportControl).)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the control to final document. (Inherited from DetailBase.)
RenderControls | (Inherited from DetailBase.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates free page area after the band is rendered. (Inherited from DetailBase.)

See Also

Footer Class
PerpetuumSoft.Reporting.DOM Namespace


Avg Method

[image] [image]

.NET ModelKit Suite ClassReference
Footer..::.Avg Method
Footer Class See Also Send Feedback

Overload List

Name | Description
Avg(String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)

See Also

Footer Class
Footer Members
PerpetuumSoft.Reporting.DOM Namespace


Count Method

[image] [image]

.NET ModelKit Suite ClassReference
Footer..::.Count Method
Footer Class See Also Send Feedback

Overload List

Name | Description
Count(String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)

See Also

Footer Class
Footer Members
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
Footer..::.GetScripts Method
Footer Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Overridden. See GetScripts(ScriptInfoCollection). (Inherited from AggregatesRegularBand.)

See Also

Footer Class
Footer Members
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaptionColor Method

[image]

.NET ModelKit Suite ClassReference
Footer..::.GetSectionCaptionColor Method
Footer Class See Also Send Feedback
Returns the color of the title bar.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Color GetSectionCaptionColor()
Visual Basic (Declaration)
Protected Overrides Function GetSectionCaptionColor As Color
Visual C++
protected:
virtual Color GetSectionCaptionColor() override

See Also

Footer Class
PerpetuumSoft.Reporting.DOM Namespace


IsValidParent Method

[image]

.NET ModelKit Suite ClassReference
Footer..::.IsValidParent Method
Footer Class See Also Send Feedback
Returns whether the band can be placed into the specified container.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValidParent(
    ReportControl c
)
Visual Basic (Declaration)
Public Overrides Function IsValidParent ( _
    c As ReportControl _
) As Boolean
Visual C++
public:
virtual bool IsValidParent(
    ReportControl^ c
) override

Parameters

c
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

Footer Class
PerpetuumSoft.Reporting.DOM Namespace


Max Method

[image] [image]

.NET ModelKit Suite ClassReference
Footer..::.Max Method
Footer Class See Also Send Feedback

Overload List

Name | Description
Max(String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)

See Also

Footer Class
Footer Members
PerpetuumSoft.Reporting.DOM Namespace


Min Method

[image] [image]

.NET ModelKit Suite ClassReference
Footer..::.Min Method
Footer Class See Also Send Feedback

Overload List

Name | Description
Min(String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)

See Also

Footer Class
Footer Members
PerpetuumSoft.Reporting.DOM Namespace


Sum Method

[image] [image]

.NET ModelKit Suite ClassReference
Footer..::.Sum Method
Footer Class See Also Send Feedback

Overload List

Name | Description
Sum(String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)

See Also

Footer Class
Footer Members
PerpetuumSoft.Reporting.DOM Namespace


Footer Properties

[image] [image]

.NET ModelKit Suite ClassReference
Footer Properties
Footer Class See Also Send Feedback

The Footer type exposes the following members.

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanBreak | Indicates whether the breakable elements will break. (Inherited from DetailBase.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
MinSpaceAfter | Gets and sets minimum space beetween bands bottom and page bottom margins. (Inherited from DetailBase.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Overrides Section..::.SortPriority.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

Footer Class
PerpetuumSoft.Reporting.DOM Namespace


SortPriority Property

[image]

.NET ModelKit Suite ClassReference
Footer..::.SortPriority Property
Footer Class See Also Send Feedback
Gets the band's priority for sorting operations.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override int SortPriority { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property SortPriority As Integer
Visual C++
public:
virtual property int SortPriority {
    int get () override;
}

See Also

Footer Class
PerpetuumSoft.Reporting.DOM Namespace


Footer Events

[image] [image]

.NET ModelKit Suite ClassReference
Footer Events
Footer Class See Also Send Feedback

The Footer type exposes the following members.

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

Footer Class
PerpetuumSoft.Reporting.DOM Namespace


GraphicsSettings Class

[image]

.NET ModelKit Suite ClassReference
GraphicsSettings Class
Members See Also Send Feedback
Represents graphics settings.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class GraphicsSettings : Atom
Visual Basic (Declaration)
Public Class GraphicsSettings _
    Inherits Atom
Visual C++
public ref class GraphicsSettings : public Atom

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Framework..::.Atom
PerpetuumSoft.Reporting.DOM..::.GraphicsSettings

See Also

GraphicsSettings Members
PerpetuumSoft.Reporting.DOM Namespace


GraphicsSettings Members

[image] [image]

.NET ModelKit Suite ClassReference
GraphicsSettings Members
GraphicsSettings Class Constructors Methods Properties See Also Send Feedback

The GraphicsSettings type exposes the following members.

Constructors

Name | Description
GraphicsSettings | Overloaded.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Implements Clone()()(). (Overrides Atom..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CompositingQuality | Gets or sets the rendering quality of composited images.
InterpolationMode | Gets or sets the interpolation mode.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
SmoothingMode | Gets or sets the rendering quality.
TextRenderingHint | Gets or sets the rendering mode for text.

See Also

GraphicsSettings Class
PerpetuumSoft.Reporting.DOM Namespace


GraphicsSettings Constructor

[image] [image]

.NET ModelKit Suite ClassReference
GraphicsSettings Constructor
GraphicsSettings Class See Also Send Feedback

Overload List

Name | Description
GraphicsSettings()()() | Creates a new instance of GraphicsSettings class.
GraphicsSettings(GraphicsSettings) | Creates a new instance of GraphicsSettings class.

See Also

GraphicsSettings Class
GraphicsSettings Members
PerpetuumSoft.Reporting.DOM Namespace


GraphicsSettings Constructor

[image]

.NET ModelKit Suite ClassReference
GraphicsSettings Constructor
GraphicsSettings Class See Also Send Feedback
Creates a new instance of GraphicsSettings class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public GraphicsSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GraphicsSettings()

See Also

GraphicsSettings Class
GraphicsSettings Overload
PerpetuumSoft.Reporting.DOM Namespace


GraphicsSettings Constructor (GraphicsSettings)

[image]

.NET ModelKit Suite ClassReference
GraphicsSettings Constructor (GraphicsSettings)
GraphicsSettings Class See Also Send Feedback
Creates a new instance of GraphicsSettings class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public GraphicsSettings(
    GraphicsSettings settings
)
Visual Basic (Declaration)
Public Sub New ( _
    settings As GraphicsSettings _
)
Visual C++
public:
GraphicsSettings(
    GraphicsSettings^ settings
)

Parameters

settings
Type: PerpetuumSoft.Reporting.DOM..::.GraphicsSettings

See Also

GraphicsSettings Class
GraphicsSettings Overload
PerpetuumSoft.Reporting.DOM Namespace


GraphicsSettings Methods

[image] [image]

.NET ModelKit Suite ClassReference
GraphicsSettings Methods
GraphicsSettings Class See Also Send Feedback

The GraphicsSettings type exposes the following members.

Methods

Name | Description
CheckMutable | Throws an exception if the object is immutable. Exception has InvalidOperationException type. (Inherited from Atom.)
Clone | Implements Clone()()(). (Overrides Atom..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImmutableVersion | Returns this object if it is immutable or immutable clone of it. (Inherited from Atom.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakeImmutable | Makes this class as immutable. (Inherited from Atom.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GraphicsSettings Class
PerpetuumSoft.Reporting.DOM Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
GraphicsSettings..::.Clone Method
GraphicsSettings Class See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Implements

ICloneable..::.Clone()()()

See Also

GraphicsSettings Class
PerpetuumSoft.Reporting.DOM Namespace


GraphicsSettings Properties

[image] [image]

.NET ModelKit Suite ClassReference
GraphicsSettings Properties
GraphicsSettings Class See Also Send Feedback

The GraphicsSettings type exposes the following members.

Properties

Name | Description
CompositingQuality | Gets or sets the rendering quality of composited images.
InterpolationMode | Gets or sets the interpolation mode.
IsImmutable | Gets whether this object is immutable. (Inherited from Atom.)
SmoothingMode | Gets or sets the rendering quality.
TextRenderingHint | Gets or sets the rendering mode for text.

See Also

GraphicsSettings Class
PerpetuumSoft.Reporting.DOM Namespace


CompositingQuality Property

[image]

.NET ModelKit Suite ClassReference
GraphicsSettings..::.CompositingQuality Property
GraphicsSettings Class See Also Send Feedback
Gets or sets the rendering quality of composited images.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public CompositingQuality CompositingQuality { get; set; }
Visual Basic (Declaration)
Public Property CompositingQuality As CompositingQuality
Visual C++
public:
property CompositingQuality CompositingQuality {
    CompositingQuality get ();
    void set (CompositingQuality value);
}

See Also

GraphicsSettings Class
PerpetuumSoft.Reporting.DOM Namespace


InterpolationMode Property

[image]

.NET ModelKit Suite ClassReference
GraphicsSettings..::.InterpolationMode Property
GraphicsSettings Class See Also Send Feedback
Gets or sets the interpolation mode.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public InterpolationMode InterpolationMode { get; set; }
Visual Basic (Declaration)
Public Property InterpolationMode As InterpolationMode
Visual C++
public:
property InterpolationMode InterpolationMode {
    InterpolationMode get ();
    void set (InterpolationMode value);
}

See Also

GraphicsSettings Class
PerpetuumSoft.Reporting.DOM Namespace


SmoothingMode Property

[image]

.NET ModelKit Suite ClassReference
GraphicsSettings..::.SmoothingMode Property
GraphicsSettings Class See Also Send Feedback
Gets or sets the rendering quality.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public SmoothingMode SmoothingMode { get; set; }
Visual Basic (Declaration)
Public Property SmoothingMode As SmoothingMode
Visual C++
public:
property SmoothingMode SmoothingMode {
    SmoothingMode get ();
    void set (SmoothingMode value);
}

See Also

GraphicsSettings Class
PerpetuumSoft.Reporting.DOM Namespace


TextRenderingHint Property

[image]

.NET ModelKit Suite ClassReference
GraphicsSettings..::.TextRenderingHint Property
GraphicsSettings Class See Also Send Feedback
Gets or sets the rendering mode for text.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public TextRenderingHint TextRenderingHint { get; set; }
Visual Basic (Declaration)
Public Property TextRenderingHint As TextRenderingHint
Visual C++
public:
property TextRenderingHint TextRenderingHint {
    TextRenderingHint get ();
    void set (TextRenderingHint value);
}

See Also

GraphicsSettings Class
PerpetuumSoft.Reporting.DOM Namespace


GroupBand Class

[image]

.NET ModelKit Suite ClassReference
GroupBand Class
Members See Also Send Feedback
Base class for group bands.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class GroupBand : DataBandBase
Visual Basic (Declaration)
Public Class GroupBand _
    Inherits DataBandBase
Visual C++
public ref class GroupBand : public DataBandBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.RegularBandBase
PerpetuumSoft.Reporting.DOM..::.RegularBand
PerpetuumSoft.Reporting.DOM..::.AggregatesRegularBand
PerpetuumSoft.Reporting.DOM..::.DataBandBase
PerpetuumSoft.Reporting.DOM..::.GroupBand

See Also

GroupBand Members
PerpetuumSoft.Reporting.DOM Namespace


GroupBand Members

[image] [image]

.NET ModelKit Suite ClassReference
GroupBand Members
GroupBand Class Constructors Methods Properties Events See Also Send Feedback

The GroupBand type exposes the following members.

Constructors

Name | Description
GroupBand | Creates a new instance of GroupBand class.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CalculateRunningTotals | (Inherited from DataBandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
CreateNavigator | Creates grouped data navigator (Overrides DataBandBase..::.CreateNavigator()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetGroup | Gets group (Overrides DataBandBase..::.GetGroup()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLevel | Gets the level of the current band. (Inherited from DataBandBase.)
GetMainBand | Gets root DataBand the element is located in
GetRunningTotal | Gets the running total by its name (Inherited from DataBandBase.)
GetScripts | Overloaded.
GetSectionCaption | Gets section caption (Overrides BandBase..::.GetSectionCaption()()().)
GetSectionCaptionColor | Gets section caption color (Inherited from DataBandBase.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetTotal | Overloaded.
GetTotals | Gets total value (Overrides DataBandBase..::.GetTotals()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from DataBandBase.)
IsValidParent | Returns whether the band can be placed into the specified container. (Overrides ReportControl..::.IsValidParent(ReportControl).)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnGetData | Raises the GetData event. (Inherited from DataBandBase.)
OnPaint | Performs drawing of the control. (Inherited from DataBandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
ProcessRecordCore | (Overrides DataBandBase..::.ProcessRecordCore()()().)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
RaiseGetData | Invokes OnGetData method. (Inherited from DataBandBase.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Inherited from DataBandBase.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
StartPropagate | Switches the band to propagate mode. (Inherited from DataBandBase.)
StopPropagate | Resets value by the PropagateMode (Inherited from DataBandBase.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
ColumnsCount | Gets or sets columns count (Inherited from DataBandBase.)
ColumnsGap | Gets or sets gap between columns (Inherited from DataBandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DataItem | Gets the current record data. (Inherited from DataBandBase.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GetDataScript | Gets and sets the code of the script that will be invoked when the band obtains data from the data source. (Inherited from DataBandBase.)
Group | Gets and sets the current group.
GroupExpression | Gets or sets String
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
IsFirstLine | Gets if the first line is rendered. (Inherited from DataBandBase.)
IsLastLine | Gets if the last line is rendered. (Inherited from DataBandBase.)
Item | Gets a value of the specified field from the current record. (Inherited from DataBandBase.)
LineNumber | Gets the number of the currently rendered line. (Inherited from DataBandBase.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Order | Implements Order()()().
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RecordNumber | Gets the number of the current record. (Inherited from DataBandBase.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowBottom | Gets and sets whether the bottom bar of the band should be displayed in the design mode. (Inherited from DataBandBase.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
Sort | Gets or sets sorting settings
SortExpression | Gets or sets String
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)
GetData | Occurs when a data item is obtained from the data source. (Inherited from DataBandBase.)

See Also

GroupBand Class
PerpetuumSoft.Reporting.DOM Namespace


GroupBand Constructor

[image]

.NET ModelKit Suite ClassReference
GroupBand Constructor
GroupBand Class See Also Send Feedback
Creates a new instance of GroupBand class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public GroupBand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupBand()

See Also

GroupBand Class
PerpetuumSoft.Reporting.DOM Namespace


GroupBand Methods

[image] [image]

.NET ModelKit Suite ClassReference
GroupBand Methods
GroupBand Class See Also Send Feedback

The GroupBand type exposes the following members.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CalculateRunningTotals | (Inherited from DataBandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
CreateNavigator | Creates grouped data navigator (Overrides DataBandBase..::.CreateNavigator()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetGroup | Gets group (Overrides DataBandBase..::.GetGroup()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLevel | Gets the level of the current band. (Inherited from DataBandBase.)
GetMainBand | Gets root DataBand the element is located in
GetRunningTotal | Gets the running total by its name (Inherited from DataBandBase.)
GetScripts | Overloaded.
GetSectionCaption | Gets section caption (Overrides BandBase..::.GetSectionCaption()()().)
GetSectionCaptionColor | Gets section caption color (Inherited from DataBandBase.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetTotal | Overloaded.
GetTotals | Gets total value (Overrides DataBandBase..::.GetTotals()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from DataBandBase.)
IsValidParent | Returns whether the band can be placed into the specified container. (Overrides ReportControl..::.IsValidParent(ReportControl).)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnGetData | Raises the GetData event. (Inherited from DataBandBase.)
OnPaint | Performs drawing of the control. (Inherited from DataBandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
ProcessRecordCore | (Overrides DataBandBase..::.ProcessRecordCore()()().)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
RaiseGetData | Invokes OnGetData method. (Inherited from DataBandBase.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Inherited from DataBandBase.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
StartPropagate | Switches the band to propagate mode. (Inherited from DataBandBase.)
StopPropagate | Resets value by the PropagateMode (Inherited from DataBandBase.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

See Also

GroupBand Class
PerpetuumSoft.Reporting.DOM Namespace


Avg Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupBand..::.Avg Method
GroupBand Class See Also Send Feedback

Overload List

Name | Description
Avg(String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)

See Also

GroupBand Class
GroupBand Members
PerpetuumSoft.Reporting.DOM Namespace


Count Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupBand..::.Count Method
GroupBand Class See Also Send Feedback

Overload List

Name | Description
Count(String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)

See Also

GroupBand Class
GroupBand Members
PerpetuumSoft.Reporting.DOM Namespace


CreateNavigator Method

[image]

.NET ModelKit Suite ClassReference
GroupBand..::.CreateNavigator Method
GroupBand Class See Also Send Feedback
Creates grouped data navigator

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override DataNavigator CreateNavigator()
Visual Basic (Declaration)
Protected Overrides Function CreateNavigator As DataNavigator
Visual C++
protected:
virtual DataNavigator^ CreateNavigator() override

See Also

GroupBand Class
PerpetuumSoft.Reporting.DOM Namespace


GetGroup Method

[image]

.NET ModelKit Suite ClassReference
GroupBand..::.GetGroup Method
GroupBand Class See Also Send Feedback
Gets group

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Group GetGroup()
Visual Basic (Declaration)
Protected Overrides Function GetGroup As Group
Visual C++
protected:
virtual Group^ GetGroup() override

See Also

GroupBand Class
PerpetuumSoft.Reporting.DOM Namespace


GetMainBand Method

[image]

.NET ModelKit Suite ClassReference
GroupBand..::.GetMainBand Method
GroupBand Class See Also Send Feedback
Gets root DataBand the element is located in

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected DataBand GetMainBand(
    ReportControl control
)
Visual Basic (Declaration)
Protected Function GetMainBand ( _
    control As ReportControl _
) As DataBand
Visual C++
protected:
DataBand^ GetMainBand(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

GroupBand Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupBand..::.GetScripts Method
GroupBand Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Overridden. See GetScripts(ScriptInfoCollection). (Inherited from DataBandBase.)

See Also

GroupBand Class
GroupBand Members
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaption Method

[image]

.NET ModelKit Suite ClassReference
GroupBand..::.GetSectionCaption Method
GroupBand Class See Also Send Feedback
Gets section caption

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override string GetSectionCaption()
Visual Basic (Declaration)
Protected Overrides Function GetSectionCaption As String
Visual C++
protected:
virtual String^ GetSectionCaption() override

See Also

GroupBand Class
PerpetuumSoft.Reporting.DOM Namespace


GetTotal Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupBand..::.GetTotal Method
GroupBand Class See Also Send Feedback

Overload List

Name | Description
GetTotal(String) | Gets field total (Inherited from DataBandBase.)
GetTotal(String, Double) | (Inherited from DataBandBase.)

See Also

GroupBand Class
GroupBand Members
PerpetuumSoft.Reporting.DOM Namespace


GetTotals Method

[image]

.NET ModelKit Suite ClassReference
GroupBand..::.GetTotals Method
GroupBand Class See Also Send Feedback
Gets total value

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override DataBandTotalCollection GetTotals()
Visual Basic (Declaration)
Protected Overrides Function GetTotals As DataBandTotalCollection
Visual C++
protected:
virtual DataBandTotalCollection^ GetTotals() override

See Also

GroupBand Class
PerpetuumSoft.Reporting.DOM Namespace


IsValidParent Method

[image]

.NET ModelKit Suite ClassReference
GroupBand..::.IsValidParent Method
GroupBand Class See Also Send Feedback
Returns whether the band can be placed into the specified container.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValidParent(
    ReportControl c
)
Visual Basic (Declaration)
Public Overrides Function IsValidParent ( _
    c As ReportControl _
) As Boolean
Visual C++
public:
virtual bool IsValidParent(
    ReportControl^ c
) override

Parameters

c
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

GroupBand Class
PerpetuumSoft.Reporting.DOM Namespace


Max Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupBand..::.Max Method
GroupBand Class See Also Send Feedback

Overload List

Name | Description
Max(String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)

See Also

GroupBand Class
GroupBand Members
PerpetuumSoft.Reporting.DOM Namespace


Min Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupBand..::.Min Method
GroupBand Class See Also Send Feedback

Overload List

Name | Description
Min(String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)

See Also

GroupBand Class
GroupBand Members
PerpetuumSoft.Reporting.DOM Namespace


ProcessRecordCore Method

[image]

.NET ModelKit Suite ClassReference
GroupBand..::.ProcessRecordCore Method
GroupBand Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.GroupBand.ProcessRecordCore]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected internal override void ProcessRecordCore()
Visual Basic (Declaration)
Protected Friend Overrides Sub ProcessRecordCore
Visual C++
protected public:
virtual void ProcessRecordCore() override

See Also

GroupBand Class
PerpetuumSoft.Reporting.DOM Namespace


Sum Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupBand..::.Sum Method
GroupBand Class See Also Send Feedback

Overload List

Name | Description
Sum(String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)

See Also

GroupBand Class
GroupBand Members
PerpetuumSoft.Reporting.DOM Namespace


GroupBand Properties

[image] [image]

.NET ModelKit Suite ClassReference
GroupBand Properties
GroupBand Class See Also Send Feedback

The GroupBand type exposes the following members.

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
ColumnsCount | Gets or sets columns count (Inherited from DataBandBase.)
ColumnsGap | Gets or sets gap between columns (Inherited from DataBandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DataItem | Gets the current record data. (Inherited from DataBandBase.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GetDataScript | Gets and sets the code of the script that will be invoked when the band obtains data from the data source. (Inherited from DataBandBase.)
Group | Gets and sets the current group.
GroupExpression | Gets or sets String
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
IsFirstLine | Gets if the first line is rendered. (Inherited from DataBandBase.)
IsLastLine | Gets if the last line is rendered. (Inherited from DataBandBase.)
Item | Gets a value of the specified field from the current record. (Inherited from DataBandBase.)
LineNumber | Gets the number of the currently rendered line. (Inherited from DataBandBase.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Order | Implements Order()()().
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RecordNumber | Gets the number of the current record. (Inherited from DataBandBase.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowBottom | Gets and sets whether the bottom bar of the band should be displayed in the design mode. (Inherited from DataBandBase.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
Sort | Gets or sets sorting settings
SortExpression | Gets or sets String
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

GroupBand Class
PerpetuumSoft.Reporting.DOM Namespace


Group Property

[image]

.NET ModelKit Suite ClassReference
GroupBand..::.Group Property
GroupBand Class See Also Send Feedback
Gets and sets the current group.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Group { get; set; }
Visual Basic (Declaration)
Public Property Group As Object
Visual C++
public:
property Object^ Group {
    Object^ get ();
    void set (Object^ value);
}

See Also

GroupBand Class
PerpetuumSoft.Reporting.DOM Namespace


GroupExpression Property

[image]

.NET ModelKit Suite ClassReference
GroupBand..::.GroupExpression Property
GroupBand Class See Also Send Feedback
Gets or sets String

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string GroupExpression { get; set; }
Visual Basic (Declaration)
Public Property GroupExpression As String
Visual C++
public:
property String^ GroupExpression {
    String^ get ();
    void set (String^ value);
}

See Also

GroupBand Class
PerpetuumSoft.Reporting.DOM Namespace


Order Property

[image]

.NET ModelKit Suite ClassReference
GroupBand..::.Order Property
GroupBand Class See Also Send Feedback
Implements Order()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public GroupOrder Order { get; set; }
Visual Basic (Declaration)
Public Property Order As GroupOrder
Visual C++
public:
virtual property GroupOrder Order {
    GroupOrder get () sealed;
    void set (GroupOrder value) sealed;
}

See Also

GroupBand Class
PerpetuumSoft.Reporting.DOM Namespace


Sort Property

[image]

.NET ModelKit Suite ClassReference
GroupBand..::.Sort Property
GroupBand Class See Also Send Feedback
Gets or sets sorting settings

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Sort { get; set; }
Visual Basic (Declaration)
Public Property Sort As Object
Visual C++
public:
property Object^ Sort {
    Object^ get ();
    void set (Object^ value);
}

See Also

GroupBand Class
PerpetuumSoft.Reporting.DOM Namespace


SortExpression Property

[image]

.NET ModelKit Suite ClassReference
GroupBand..::.SortExpression Property
GroupBand Class See Also Send Feedback
Gets or sets String

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string SortExpression { get; set; }
Visual Basic (Declaration)
Public Property SortExpression As String
Visual C++
public:
property String^ SortExpression {
    String^ get ();
    void set (String^ value);
}

See Also

GroupBand Class
PerpetuumSoft.Reporting.DOM Namespace


GroupBand Events

[image] [image]

.NET ModelKit Suite ClassReference
GroupBand Events
GroupBand Class See Also Send Feedback

The GroupBand type exposes the following members.

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)
GetData | Occurs when a data item is obtained from the data source. (Inherited from DataBandBase.)

See Also

GroupBand Class
PerpetuumSoft.Reporting.DOM Namespace


GroupBandBase Class

[image]

.NET ModelKit Suite ClassReference
GroupBandBase Class
Members See Also Send Feedback
Represents base class for all group bands

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
[ObsoleteAttribute("The GroupBandBase is an obsoleted type. Please use the GroupBand instead.")]
public class GroupBandBase : DetailBase
Visual Basic (Declaration)
<ObsoleteAttribute("The GroupBandBase is an obsoleted type. Please use the GroupBand instead.")> _
Public Class GroupBandBase _
    Inherits DetailBase
Visual C++
[ObsoleteAttribute(L"The GroupBandBase is an obsoleted type. Please use the GroupBand instead.")]
public ref class GroupBandBase : public DetailBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.RegularBandBase
PerpetuumSoft.Reporting.DOM..::.RegularBand
PerpetuumSoft.Reporting.DOM..::.AggregatesRegularBand
PerpetuumSoft.Reporting.DOM..::.DetailBase
PerpetuumSoft.Reporting.DOM..::.GroupBandBase
PerpetuumSoft.Reporting.DOM..::.GroupFooter
PerpetuumSoft.Reporting.DOM..::.GroupHeader

See Also

GroupBandBase Members
PerpetuumSoft.Reporting.DOM Namespace


GroupBandBase Members

[image] [image]

.NET ModelKit Suite ClassReference
GroupBandBase Members
GroupBandBase Class Constructors Methods Properties Events See Also Send Feedback

The GroupBandBase type exposes the following members.

Constructors

Name | Description
GroupBandBase | Initializes a new instance of the GroupBandBase class.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from DetailBase.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string for the band. (Inherited from DetailBase.)
GetSectionCaptionColor | Gets section caption color (Overrides DetailBase..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from RegularBandBase.)
IsValidParent | Overridden. See IsValidParent(ReportControl). (Overrides ReportControl..::.IsValidParent(ReportControl).)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the control to final document. (Inherited from DetailBase.)
RenderControls | (Inherited from DetailBase.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates free page area after the band is rendered. (Inherited from DetailBase.)

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanBreak | Indicates whether the breakable elements will break. (Inherited from DetailBase.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Group | Gets or sets the group
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
MinSpaceAfter | Gets and sets minimum space beetween bands bottom and page bottom margins. (Inherited from DetailBase.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

GroupBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


GroupBandBase Constructor

[image]

.NET ModelKit Suite ClassReference
GroupBandBase Constructor
GroupBandBase Class See Also Send Feedback
Initializes a new instance of the GroupBandBase class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public GroupBandBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupBandBase()

See Also

GroupBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


GroupBandBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
GroupBandBase Methods
GroupBandBase Class See Also Send Feedback

The GroupBandBase type exposes the following members.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from DetailBase.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string for the band. (Inherited from DetailBase.)
GetSectionCaptionColor | Gets section caption color (Overrides DetailBase..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from RegularBandBase.)
IsValidParent | Overridden. See IsValidParent(ReportControl). (Overrides ReportControl..::.IsValidParent(ReportControl).)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the control to final document. (Inherited from DetailBase.)
RenderControls | (Inherited from DetailBase.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates free page area after the band is rendered. (Inherited from DetailBase.)

See Also

GroupBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


Avg Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupBandBase..::.Avg Method
GroupBandBase Class See Also Send Feedback

Overload List

Name | Description
Avg(String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)

See Also

GroupBandBase Class
GroupBandBase Members
PerpetuumSoft.Reporting.DOM Namespace


Count Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupBandBase..::.Count Method
GroupBandBase Class See Also Send Feedback

Overload List

Name | Description
Count(String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)

See Also

GroupBandBase Class
GroupBandBase Members
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupBandBase..::.GetScripts Method
GroupBandBase Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Overridden. See GetScripts(ScriptInfoCollection). (Inherited from AggregatesRegularBand.)

See Also

GroupBandBase Class
GroupBandBase Members
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaptionColor Method

[image]

.NET ModelKit Suite ClassReference
GroupBandBase..::.GetSectionCaptionColor Method
GroupBandBase Class See Also Send Feedback
Gets section caption color

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Color GetSectionCaptionColor()
Visual Basic (Declaration)
Protected Overrides Function GetSectionCaptionColor As Color
Visual C++
protected:
virtual Color GetSectionCaptionColor() override

See Also

GroupBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


IsValidParent Method

[image]

.NET ModelKit Suite ClassReference
GroupBandBase..::.IsValidParent Method
GroupBandBase Class See Also Send Feedback
Overridden. See IsValidParent(ReportControl).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValidParent(
    ReportControl c
)
Visual Basic (Declaration)
Public Overrides Function IsValidParent ( _
    c As ReportControl _
) As Boolean
Visual C++
public:
virtual bool IsValidParent(
    ReportControl^ c
) override

Parameters

c
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

GroupBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


Max Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupBandBase..::.Max Method
GroupBandBase Class See Also Send Feedback

Overload List

Name | Description
Max(String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)

See Also

GroupBandBase Class
GroupBandBase Members
PerpetuumSoft.Reporting.DOM Namespace


Min Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupBandBase..::.Min Method
GroupBandBase Class See Also Send Feedback

Overload List

Name | Description
Min(String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)

See Also

GroupBandBase Class
GroupBandBase Members
PerpetuumSoft.Reporting.DOM Namespace


Sum Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupBandBase..::.Sum Method
GroupBandBase Class See Also Send Feedback

Overload List

Name | Description
Sum(String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)

See Also

GroupBandBase Class
GroupBandBase Members
PerpetuumSoft.Reporting.DOM Namespace


GroupBandBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
GroupBandBase Properties
GroupBandBase Class See Also Send Feedback

The GroupBandBase type exposes the following members.

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanBreak | Indicates whether the breakable elements will break. (Inherited from DetailBase.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Group | Gets or sets the group
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
MinSpaceAfter | Gets and sets minimum space beetween bands bottom and page bottom margins. (Inherited from DetailBase.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

GroupBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


Group Property

[image]

.NET ModelKit Suite ClassReference
GroupBandBase..::.Group Property
GroupBandBase Class See Also Send Feedback
Gets or sets the group

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Group { get; set; }
Visual Basic (Declaration)
Public Property Group As Object
Visual C++
public:
property Object^ Group {
    Object^ get ();
    void set (Object^ value);
}

See Also

GroupBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


GroupBandBase Events

[image] [image]

.NET ModelKit Suite ClassReference
GroupBandBase Events
GroupBandBase Class See Also Send Feedback

The GroupBandBase type exposes the following members.

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

GroupBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


GroupFooter Class

[image]

.NET ModelKit Suite ClassReference
GroupFooter Class
Members See Also Send Feedback
Defines a group footer.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
[ObsoleteAttribute("The GroupFooter is an obsoleted type. Please use the GroupBand and Footer instead.")]
public class GroupFooter : GroupBandBase
Visual Basic (Declaration)
<ObsoleteAttribute("The GroupFooter is an obsoleted type. Please use the GroupBand and Footer instead.")> _
Public Class GroupFooter _
    Inherits GroupBandBase
Visual C++
[ObsoleteAttribute(L"The GroupFooter is an obsoleted type. Please use the GroupBand and Footer instead.")]
public ref class GroupFooter : public GroupBandBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.RegularBandBase
PerpetuumSoft.Reporting.DOM..::.RegularBand
PerpetuumSoft.Reporting.DOM..::.AggregatesRegularBand
PerpetuumSoft.Reporting.DOM..::.DetailBase
PerpetuumSoft.Reporting.DOM..::.GroupBandBase
PerpetuumSoft.Reporting.DOM..::.GroupFooter

See Also

GroupFooter Members
PerpetuumSoft.Reporting.DOM Namespace


GroupFooter Members

[image] [image]

.NET ModelKit Suite ClassReference
GroupFooter Members
GroupFooter Class Constructors Methods Properties Events See Also Send Feedback

The GroupFooter type exposes the following members.

Constructors

Name | Description
GroupFooter | Creates a new instance of GroupFooter class.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from DetailBase.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Overrides Section..::.CheckConditions()()().)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string for the band. (Inherited from DetailBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Overrides GroupBandBase..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from RegularBandBase.)
IsValidParent | Overridden. See IsValidParent(ReportControl). (Inherited from GroupBandBase.)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the control to final document. (Inherited from DetailBase.)
RenderControls | Renders control for output. (Overrides DetailBase..::.RenderControls()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates free page area after the band is rendered. (Inherited from DetailBase.)

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanBreak | Indicates whether the breakable elements will break. (Inherited from DetailBase.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Group | Gets or sets the group (Inherited from GroupBandBase.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
MinSpaceAfter | Gets and sets minimum space beetween bands bottom and page bottom margins. (Inherited from DetailBase.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Overrides Section..::.SortPriority.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

GroupFooter Class
PerpetuumSoft.Reporting.DOM Namespace


GroupFooter Constructor

[image]

.NET ModelKit Suite ClassReference
GroupFooter Constructor
GroupFooter Class See Also Send Feedback
Creates a new instance of GroupFooter class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public GroupFooter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupFooter()

See Also

GroupFooter Class
PerpetuumSoft.Reporting.DOM Namespace


GroupFooter Methods

[image] [image]

.NET ModelKit Suite ClassReference
GroupFooter Methods
GroupFooter Class See Also Send Feedback

The GroupFooter type exposes the following members.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from DetailBase.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Overrides Section..::.CheckConditions()()().)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string for the band. (Inherited from DetailBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Overrides GroupBandBase..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from RegularBandBase.)
IsValidParent | Overridden. See IsValidParent(ReportControl). (Inherited from GroupBandBase.)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the control to final document. (Inherited from DetailBase.)
RenderControls | Renders control for output. (Overrides DetailBase..::.RenderControls()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates free page area after the band is rendered. (Inherited from DetailBase.)

See Also

GroupFooter Class
PerpetuumSoft.Reporting.DOM Namespace


Avg Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupFooter..::.Avg Method
GroupFooter Class See Also Send Feedback

Overload List

Name | Description
Avg(String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)

See Also

GroupFooter Class
GroupFooter Members
PerpetuumSoft.Reporting.DOM Namespace


CheckConditions Method

[image]

.NET ModelKit Suite ClassReference
GroupFooter..::.CheckConditions Method
GroupFooter Class See Also Send Feedback
Checks the band's condition.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override bool CheckConditions()
Visual Basic (Declaration)
Protected Overrides Function CheckConditions As Boolean
Visual C++
protected:
virtual bool CheckConditions() override

See Also

GroupFooter Class
PerpetuumSoft.Reporting.DOM Namespace


Count Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupFooter..::.Count Method
GroupFooter Class See Also Send Feedback

Overload List

Name | Description
Count(String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)

See Also

GroupFooter Class
GroupFooter Members
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupFooter..::.GetScripts Method
GroupFooter Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Overridden. See GetScripts(ScriptInfoCollection). (Inherited from AggregatesRegularBand.)

See Also

GroupFooter Class
GroupFooter Members
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaptionColor Method

[image]

.NET ModelKit Suite ClassReference
GroupFooter..::.GetSectionCaptionColor Method
GroupFooter Class See Also Send Feedback
Returns the color of the title bar.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Color GetSectionCaptionColor()
Visual Basic (Declaration)
Protected Overrides Function GetSectionCaptionColor As Color
Visual C++
protected:
virtual Color GetSectionCaptionColor() override

See Also

GroupFooter Class
PerpetuumSoft.Reporting.DOM Namespace


Max Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupFooter..::.Max Method
GroupFooter Class See Also Send Feedback

Overload List

Name | Description
Max(String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)

See Also

GroupFooter Class
GroupFooter Members
PerpetuumSoft.Reporting.DOM Namespace


Min Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupFooter..::.Min Method
GroupFooter Class See Also Send Feedback

Overload List

Name | Description
Min(String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)

See Also

GroupFooter Class
GroupFooter Members
PerpetuumSoft.Reporting.DOM Namespace


RenderControls Method

[image]

.NET ModelKit Suite ClassReference
GroupFooter..::.RenderControls Method
GroupFooter Class See Also Send Feedback
Renders control for output.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void RenderControls()
Visual Basic (Declaration)
Protected Overrides Sub RenderControls
Visual C++
protected:
virtual void RenderControls() override

See Also

GroupFooter Class
PerpetuumSoft.Reporting.DOM Namespace


Sum Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupFooter..::.Sum Method
GroupFooter Class See Also Send Feedback

Overload List

Name | Description
Sum(String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)

See Also

GroupFooter Class
GroupFooter Members
PerpetuumSoft.Reporting.DOM Namespace


GroupFooter Properties

[image] [image]

.NET ModelKit Suite ClassReference
GroupFooter Properties
GroupFooter Class See Also Send Feedback

The GroupFooter type exposes the following members.

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanBreak | Indicates whether the breakable elements will break. (Inherited from DetailBase.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Group | Gets or sets the group (Inherited from GroupBandBase.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
MinSpaceAfter | Gets and sets minimum space beetween bands bottom and page bottom margins. (Inherited from DetailBase.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Overrides Section..::.SortPriority.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

GroupFooter Class
PerpetuumSoft.Reporting.DOM Namespace


SortPriority Property

[image]

.NET ModelKit Suite ClassReference
GroupFooter..::.SortPriority Property
GroupFooter Class See Also Send Feedback
Gets the band's priority for sorting operations.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override int SortPriority { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property SortPriority As Integer
Visual C++
public:
virtual property int SortPriority {
    int get () override;
}

See Also

GroupFooter Class
PerpetuumSoft.Reporting.DOM Namespace


GroupFooter Events

[image] [image]

.NET ModelKit Suite ClassReference
GroupFooter Events
GroupFooter Class See Also Send Feedback

The GroupFooter type exposes the following members.

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

GroupFooter Class
PerpetuumSoft.Reporting.DOM Namespace


GroupHeader Class

[image]

.NET ModelKit Suite ClassReference
GroupHeader Class
Members See Also Send Feedback
Defines a group header.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
[ObsoleteAttribute("The GroupHeader is an obsoleted type. Please use the GroupBand and Header instead.")]
public class GroupHeader : GroupBandBase
Visual Basic (Declaration)
<ObsoleteAttribute("The GroupHeader is an obsoleted type. Please use the GroupBand and Header instead.")> _
Public Class GroupHeader _
    Inherits GroupBandBase
Visual C++
[ObsoleteAttribute(L"The GroupHeader is an obsoleted type. Please use the GroupBand and Header instead.")]
public ref class GroupHeader : public GroupBandBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.RegularBandBase
PerpetuumSoft.Reporting.DOM..::.RegularBand
PerpetuumSoft.Reporting.DOM..::.AggregatesRegularBand
PerpetuumSoft.Reporting.DOM..::.DetailBase
PerpetuumSoft.Reporting.DOM..::.GroupBandBase
PerpetuumSoft.Reporting.DOM..::.GroupHeader

See Also

GroupHeader Members
PerpetuumSoft.Reporting.DOM Namespace


GroupHeader Members

[image] [image]

.NET ModelKit Suite ClassReference
GroupHeader Members
GroupHeader Class Constructors Methods Fields Properties Events See Also Send Feedback

The GroupHeader type exposes the following members.

Constructors

Name | Description
GroupHeader | Creates a new instance of GroupHeader class.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from DetailBase.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Overrides Section..::.CheckConditions()()().)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string for the band. (Inherited from DetailBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Overrides GroupBandBase..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from RegularBandBase.)
IsValidParent | Overridden. See IsValidParent(ReportControl). (Inherited from GroupBandBase.)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | (Overrides DetailBase..::.Render()()().)
RenderControls | Renders control for output. (Overrides DetailBase..::.RenderControls()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates free page area after the band is rendered. (Inherited from DetailBase.)

Fields

Name | Description
checkConditions |

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanBreak | Indicates whether the breakable elements will break. (Inherited from DetailBase.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Group | Gets or sets the group (Inherited from GroupBandBase.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
MinSpaceAfter | Gets and sets minimum space beetween bands bottom and page bottom margins. (Inherited from DetailBase.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
RepeatEveryColumn | Gets and sets whether the band content should be repeated at the beginning of every column.
RepeatEveryPage | Gets and sets whether the band content should be repeated at the top of every page.
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Overrides Section..::.SortPriority.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

GroupHeader Class
PerpetuumSoft.Reporting.DOM Namespace


GroupHeader Constructor

[image]

.NET ModelKit Suite ClassReference
GroupHeader Constructor
GroupHeader Class See Also Send Feedback
Creates a new instance of GroupHeader class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public GroupHeader()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupHeader()

See Also

GroupHeader Class
PerpetuumSoft.Reporting.DOM Namespace


GroupHeader Fields

[image] [image]

.NET ModelKit Suite ClassReference
GroupHeader Fields
GroupHeader Class See Also Send Feedback

The GroupHeader type exposes the following members.

Fields

Name | Description
checkConditions |

See Also

GroupHeader Class
PerpetuumSoft.Reporting.DOM Namespace


checkConditions Field

[image]

.NET ModelKit Suite ClassReference
GroupHeader..::.checkConditions Field
GroupHeader Class See Also Send Feedback

[Missing <summary> documentation for F:PerpetuumSoft.Reporting.DOM.GroupHeader.checkConditions]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool checkConditions
Visual Basic (Declaration)
Public checkConditions As Boolean
Visual C++
public:
bool checkConditions

See Also

GroupHeader Class
PerpetuumSoft.Reporting.DOM Namespace


GroupHeader Methods

[image] [image]

.NET ModelKit Suite ClassReference
GroupHeader Methods
GroupHeader Class See Also Send Feedback

The GroupHeader type exposes the following members.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from DetailBase.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Overrides Section..::.CheckConditions()()().)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string for the band. (Inherited from DetailBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Overrides GroupBandBase..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from RegularBandBase.)
IsValidParent | Overridden. See IsValidParent(ReportControl). (Inherited from GroupBandBase.)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | (Overrides DetailBase..::.Render()()().)
RenderControls | Renders control for output. (Overrides DetailBase..::.RenderControls()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates free page area after the band is rendered. (Inherited from DetailBase.)

See Also

GroupHeader Class
PerpetuumSoft.Reporting.DOM Namespace


Avg Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupHeader..::.Avg Method
GroupHeader Class See Also Send Feedback

Overload List

Name | Description
Avg(String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)

See Also

GroupHeader Class
GroupHeader Members
PerpetuumSoft.Reporting.DOM Namespace


CheckConditions Method

[image]

.NET ModelKit Suite ClassReference
GroupHeader..::.CheckConditions Method
GroupHeader Class See Also Send Feedback
Checks the band's condition.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override bool CheckConditions()
Visual Basic (Declaration)
Protected Overrides Function CheckConditions As Boolean
Visual C++
protected:
virtual bool CheckConditions() override

See Also

GroupHeader Class
PerpetuumSoft.Reporting.DOM Namespace


Count Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupHeader..::.Count Method
GroupHeader Class See Also Send Feedback

Overload List

Name | Description
Count(String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)

See Also

GroupHeader Class
GroupHeader Members
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupHeader..::.GetScripts Method
GroupHeader Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Overridden. See GetScripts(ScriptInfoCollection). (Inherited from AggregatesRegularBand.)

See Also

GroupHeader Class
GroupHeader Members
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaptionColor Method

[image]

.NET ModelKit Suite ClassReference
GroupHeader..::.GetSectionCaptionColor Method
GroupHeader Class See Also Send Feedback
Returns the color of the title bar.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Color GetSectionCaptionColor()
Visual Basic (Declaration)
Protected Overrides Function GetSectionCaptionColor As Color
Visual C++
protected:
virtual Color GetSectionCaptionColor() override

See Also

GroupHeader Class
PerpetuumSoft.Reporting.DOM Namespace


Max Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupHeader..::.Max Method
GroupHeader Class See Also Send Feedback

Overload List

Name | Description
Max(String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)

See Also

GroupHeader Class
GroupHeader Members
PerpetuumSoft.Reporting.DOM Namespace


Min Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupHeader..::.Min Method
GroupHeader Class See Also Send Feedback

Overload List

Name | Description
Min(String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)

See Also

GroupHeader Class
GroupHeader Members
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
GroupHeader..::.Render Method
GroupHeader Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.GroupHeader.Render]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

GroupHeader Class
PerpetuumSoft.Reporting.DOM Namespace


RenderControls Method

[image]

.NET ModelKit Suite ClassReference
GroupHeader..::.RenderControls Method
GroupHeader Class See Also Send Feedback
Renders control for output.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void RenderControls()
Visual Basic (Declaration)
Protected Overrides Sub RenderControls
Visual C++
protected:
virtual void RenderControls() override

See Also

GroupHeader Class
PerpetuumSoft.Reporting.DOM Namespace


Sum Method

[image] [image]

.NET ModelKit Suite ClassReference
GroupHeader..::.Sum Method
GroupHeader Class See Also Send Feedback

Overload List

Name | Description
Sum(String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)

See Also

GroupHeader Class
GroupHeader Members
PerpetuumSoft.Reporting.DOM Namespace


GroupHeader Properties

[image] [image]

.NET ModelKit Suite ClassReference
GroupHeader Properties
GroupHeader Class See Also Send Feedback

The GroupHeader type exposes the following members.

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanBreak | Indicates whether the breakable elements will break. (Inherited from DetailBase.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Group | Gets or sets the group (Inherited from GroupBandBase.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
MinSpaceAfter | Gets and sets minimum space beetween bands bottom and page bottom margins. (Inherited from DetailBase.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
RepeatEveryColumn | Gets and sets whether the band content should be repeated at the beginning of every column.
RepeatEveryPage | Gets and sets whether the band content should be repeated at the top of every page.
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Overrides Section..::.SortPriority.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

GroupHeader Class
PerpetuumSoft.Reporting.DOM Namespace


RepeatEveryColumn Property

[image]

.NET ModelKit Suite ClassReference
GroupHeader..::.RepeatEveryColumn Property
GroupHeader Class See Also Send Feedback
Gets and sets whether the band content should be repeated at the beginning of every column.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool RepeatEveryColumn { get; set; }
Visual Basic (Declaration)
Public Property RepeatEveryColumn As Boolean
Visual C++
public:
property bool RepeatEveryColumn {
    bool get ();
    void set (bool value);
}

See Also

GroupHeader Class
PerpetuumSoft.Reporting.DOM Namespace


RepeatEveryPage Property

[image]

.NET ModelKit Suite ClassReference
GroupHeader..::.RepeatEveryPage Property
GroupHeader Class See Also Send Feedback
Gets and sets whether the band content should be repeated at the top of every page.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool RepeatEveryPage { get; set; }
Visual Basic (Declaration)
Public Property RepeatEveryPage As Boolean
Visual C++
public:
property bool RepeatEveryPage {
    bool get ();
    void set (bool value);
}

See Also

GroupHeader Class
PerpetuumSoft.Reporting.DOM Namespace


SortPriority Property

[image]

.NET ModelKit Suite ClassReference
GroupHeader..::.SortPriority Property
GroupHeader Class See Also Send Feedback
Gets the band's priority for sorting operations.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override int SortPriority { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property SortPriority As Integer
Visual C++
public:
virtual property int SortPriority {
    int get () override;
}

See Also

GroupHeader Class
PerpetuumSoft.Reporting.DOM Namespace


GroupHeader Events

[image] [image]

.NET ModelKit Suite ClassReference
GroupHeader Events
GroupHeader Class See Also Send Feedback

The GroupHeader type exposes the following members.

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

GroupHeader Class
PerpetuumSoft.Reporting.DOM Namespace


Header Class

[image]

.NET ModelKit Suite ClassReference
Header Class
Members See Also Send Feedback
Represents header band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Header : DetailBase
Visual Basic (Declaration)
Public Class Header _
    Inherits DetailBase
Visual C++
public ref class Header : public DetailBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.RegularBandBase
PerpetuumSoft.Reporting.DOM..::.RegularBand
PerpetuumSoft.Reporting.DOM..::.AggregatesRegularBand
PerpetuumSoft.Reporting.DOM..::.DetailBase
PerpetuumSoft.Reporting.DOM..::.Header

See Also

Header Members
PerpetuumSoft.Reporting.DOM Namespace


Header Members

[image] [image]

.NET ModelKit Suite ClassReference
Header Members
Header Class Constructors Methods Properties Events See Also Send Feedback

The Header type exposes the following members.

Constructors

Name | Description
Header | Creates a new instance of Header class.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from DetailBase.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string for the band. (Inherited from DetailBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Overrides DetailBase..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from RegularBandBase.)
IsValidParent | Returns whether the band can be placed into the specified container. (Overrides ReportControl..::.IsValidParent(ReportControl).)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the control to final document. (Inherited from DetailBase.)
RenderControls | (Inherited from DetailBase.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates free page area after the band is rendered. (Inherited from DetailBase.)

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanBreak | Indicates whether the breakable elements will break. (Inherited from DetailBase.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
MinSpaceAfter | Gets and sets minimum space beetween bands bottom and page bottom margins. (Inherited from DetailBase.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
RepeatEveryColumn | Gets and sets whether the band content should be repeated at the beginning of every column.
RepeatEveryPage | Gets and sets whether the band content should be repeated at the top of every page.
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Overrides Section..::.SortPriority.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

Header Class
PerpetuumSoft.Reporting.DOM Namespace


Header Constructor

[image]

.NET ModelKit Suite ClassReference
Header Constructor
Header Class See Also Send Feedback
Creates a new instance of Header class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Header()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Header()

See Also

Header Class
PerpetuumSoft.Reporting.DOM Namespace


Header Methods

[image] [image]

.NET ModelKit Suite ClassReference
Header Methods
Header Class See Also Send Feedback

The Header type exposes the following members.

Methods

Name | Description
Avg | Overloaded.
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from DetailBase.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
Count | Overloaded.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string for the band. (Inherited from DetailBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Overrides DetailBase..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from RegularBandBase.)
IsValidParent | Returns whether the band can be placed into the specified container. (Overrides ReportControl..::.IsValidParent(ReportControl).)
Max | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Min | Overloaded.
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateAggregates | Raises the CalculateAggregates event. (Inherited from AggregatesRegularBand.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
ProcessAggregates | Forces aggregates calculation. (Inherited from AggregatesRegularBand.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseCalculateAggregates | Invokes the OnCalculateAggregates method. (Inherited from AggregatesRegularBand.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the control to final document. (Inherited from DetailBase.)
RenderControls | (Inherited from DetailBase.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
Sum | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates free page area after the band is rendered. (Inherited from DetailBase.)

See Also

Header Class
PerpetuumSoft.Reporting.DOM Namespace


Avg Method

[image] [image]

.NET ModelKit Suite ClassReference
Header..::.Avg Method
Header Class See Also Send Feedback

Overload List

Name | Description
Avg(String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)
Avg(Int32, String, array<Object>[]()[]) | Returns average value. (Inherited from AggregatesRegularBand.)

See Also

Header Class
Header Members
PerpetuumSoft.Reporting.DOM Namespace


Count Method

[image] [image]

.NET ModelKit Suite ClassReference
Header..::.Count Method
Header Class See Also Send Feedback

Overload List

Name | Description
Count(String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)
Count(Int32, String, array<Object>[]()[]) | Returns records count. (Inherited from AggregatesRegularBand.)

See Also

Header Class
Header Members
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
Header..::.GetScripts Method
Header Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Overridden. See GetScripts(ScriptInfoCollection). (Inherited from AggregatesRegularBand.)

See Also

Header Class
Header Members
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaptionColor Method

[image]

.NET ModelKit Suite ClassReference
Header..::.GetSectionCaptionColor Method
Header Class See Also Send Feedback
Returns the color of the title bar.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Color GetSectionCaptionColor()
Visual Basic (Declaration)
Protected Overrides Function GetSectionCaptionColor As Color
Visual C++
protected:
virtual Color GetSectionCaptionColor() override

See Also

Header Class
PerpetuumSoft.Reporting.DOM Namespace


IsValidParent Method

[image]

.NET ModelKit Suite ClassReference
Header..::.IsValidParent Method
Header Class See Also Send Feedback
Returns whether the band can be placed into the specified container.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValidParent(
    ReportControl c
)
Visual Basic (Declaration)
Public Overrides Function IsValidParent ( _
    c As ReportControl _
) As Boolean
Visual C++
public:
virtual bool IsValidParent(
    ReportControl^ c
) override

Parameters

c
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

Header Class
PerpetuumSoft.Reporting.DOM Namespace


Max Method

[image] [image]

.NET ModelKit Suite ClassReference
Header..::.Max Method
Header Class See Also Send Feedback

Overload List

Name | Description
Max(String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)
Max(Int32, String, array<Object>[]()[]) | Returns maximum value. (Inherited from AggregatesRegularBand.)

See Also

Header Class
Header Members
PerpetuumSoft.Reporting.DOM Namespace


Min Method

[image] [image]

.NET ModelKit Suite ClassReference
Header..::.Min Method
Header Class See Also Send Feedback

Overload List

Name | Description
Min(String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)
Min(Int32, String, array<Object>[]()[]) | Returns minimum value. (Inherited from AggregatesRegularBand.)

See Also

Header Class
Header Members
PerpetuumSoft.Reporting.DOM Namespace


Sum Method

[image] [image]

.NET ModelKit Suite ClassReference
Header..::.Sum Method
Header Class See Also Send Feedback

Overload List

Name | Description
Sum(String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)
Sum(Int32, String, array<Object>[]()[]) | Returns sum. (Inherited from AggregatesRegularBand.)

See Also

Header Class
Header Members
PerpetuumSoft.Reporting.DOM Namespace


Header Properties

[image] [image]

.NET ModelKit Suite ClassReference
Header Properties
Header Class See Also Send Feedback

The Header type exposes the following members.

Properties

Name | Description
Aggregates | Obsolete. Gets a collection of the aggregates associated with the band. (Inherited from AggregatesRegularBand.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanBreak | Indicates whether the breakable elements will break. (Inherited from DetailBase.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
MinSpaceAfter | Gets and sets minimum space beetween bands bottom and page bottom margins. (Inherited from DetailBase.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
RepeatEveryColumn | Gets and sets whether the band content should be repeated at the beginning of every column.
RepeatEveryPage | Gets and sets whether the band content should be repeated at the top of every page.
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Overrides Section..::.SortPriority.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

Header Class
PerpetuumSoft.Reporting.DOM Namespace


RepeatEveryColumn Property

[image]

.NET ModelKit Suite ClassReference
Header..::.RepeatEveryColumn Property
Header Class See Also Send Feedback
Gets and sets whether the band content should be repeated at the beginning of every column.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool RepeatEveryColumn { get; set; }
Visual Basic (Declaration)
Public Property RepeatEveryColumn As Boolean
Visual C++
public:
property bool RepeatEveryColumn {
    bool get ();
    void set (bool value);
}

See Also

Header Class
PerpetuumSoft.Reporting.DOM Namespace


RepeatEveryPage Property

[image]

.NET ModelKit Suite ClassReference
Header..::.RepeatEveryPage Property
Header Class See Also Send Feedback
Gets and sets whether the band content should be repeated at the top of every page.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool RepeatEveryPage { get; set; }
Visual Basic (Declaration)
Public Property RepeatEveryPage As Boolean
Visual C++
public:
property bool RepeatEveryPage {
    bool get ();
    void set (bool value);
}

See Also

Header Class
PerpetuumSoft.Reporting.DOM Namespace


SortPriority Property

[image]

.NET ModelKit Suite ClassReference
Header..::.SortPriority Property
Header Class See Also Send Feedback
Gets the band's priority for sorting operations.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override int SortPriority { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property SortPriority As Integer
Visual C++
public:
virtual property int SortPriority {
    int get () override;
}

See Also

Header Class
PerpetuumSoft.Reporting.DOM Namespace


Header Events

[image] [image]

.NET ModelKit Suite ClassReference
Header Events
Header Class See Also Send Feedback

The Header type exposes the following members.

Events

Name | Description
CalculateAggregates | Occurs when aggregates are recalculated. (Inherited from AggregatesRegularBand.)
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

Header Class
PerpetuumSoft.Reporting.DOM Namespace


IContainerControl Interface

[image]

.NET ModelKit Suite ClassReference
IContainerControl Interface
Members See Also Send Feedback
Defines common interface for all container controls.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public interface IContainerControl
Visual Basic (Declaration)
Public Interface IContainerControl
Visual C++
public interface class IContainerControl

See Also

IContainerControl Members
PerpetuumSoft.Reporting.DOM Namespace


IContainerControl Members

[image] [image]

.NET ModelKit Suite ClassReference
IContainerControl Members
IContainerControl Interface Methods Properties See Also Send Feedback

The IContainerControl type exposes the following members.

Methods

Name | Description
IsValidChild | Returns whether the specified control can be placed into the container.

Properties

Name | Description
Controls | Gets the collection of nested controls.

See Also

IContainerControl Interface
PerpetuumSoft.Reporting.DOM Namespace


IContainerControl Methods

[image] [image]

.NET ModelKit Suite ClassReference
IContainerControl Methods
IContainerControl Interface See Also Send Feedback

The IContainerControl type exposes the following members.

Methods

Name | Description
IsValidChild | Returns whether the specified control can be placed into the container.

See Also

IContainerControl Interface
PerpetuumSoft.Reporting.DOM Namespace


IsValidChild Method

[image]

.NET ModelKit Suite ClassReference
IContainerControl..::.IsValidChild Method
IContainerControl Interface See Also Send Feedback
Returns whether the specified control can be placed into the container.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
bool IsValidChild(
    ReportControl c
)
Visual Basic (Declaration)
Function IsValidChild ( _
    c As ReportControl _
) As Boolean
Visual C++
bool IsValidChild(
    ReportControl^ c
)

Parameters

c
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

IContainerControl Interface
PerpetuumSoft.Reporting.DOM Namespace


IContainerControl Properties

[image] [image]

.NET ModelKit Suite ClassReference
IContainerControl Properties
IContainerControl Interface See Also Send Feedback

The IContainerControl type exposes the following members.

Properties

Name | Description
Controls | Gets the collection of nested controls.

See Also

IContainerControl Interface
PerpetuumSoft.Reporting.DOM Namespace


Controls Property

[image]

.NET ModelKit Suite ClassReference
IContainerControl..::.Controls Property
IContainerControl Interface See Also Send Feedback
Gets the collection of nested controls.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
ReportControlCollection Controls { get; }
Visual Basic (Declaration)
ReadOnly Property Controls As ReportControlCollection
Visual C++
property ReportControlCollection^ Controls {
    ReportControlCollection^ get ();
}

See Also

IContainerControl Interface
PerpetuumSoft.Reporting.DOM Namespace


IDataBand Interface

[image]

.NET ModelKit Suite ClassReference
IDataBand Interface
Members See Also Send Feedback
Defines common interface for all data-aware bands.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public interface IDataBand
Visual Basic (Declaration)
Public Interface IDataBand
Visual C++
public interface class IDataBand

See Also

IDataBand Members
PerpetuumSoft.Reporting.DOM Namespace


IDataBand Members

[image] [image]

.NET ModelKit Suite ClassReference
IDataBand Members
IDataBand Interface Properties See Also Send Feedback

The IDataBand type exposes the following members.

Properties

Name | Description
DataItem | Gets the current record.
Source | Gets the data source object.

See Also

IDataBand Interface
PerpetuumSoft.Reporting.DOM Namespace


IDataBand Properties

[image] [image]

.NET ModelKit Suite ClassReference
IDataBand Properties
IDataBand Interface See Also Send Feedback

The IDataBand type exposes the following members.

Properties

Name | Description
DataItem | Gets the current record.
Source | Gets the data source object.

See Also

IDataBand Interface
PerpetuumSoft.Reporting.DOM Namespace


DataItem Property

[image]

.NET ModelKit Suite ClassReference
IDataBand..::.DataItem Property
IDataBand Interface See Also Send Feedback
Gets the current record.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
Object DataItem { get; }
Visual Basic (Declaration)
ReadOnly Property DataItem As Object
Visual C++
property Object^ DataItem {
    Object^ get ();
}

See Also

IDataBand Interface
PerpetuumSoft.Reporting.DOM Namespace


Source Property

[image]

.NET ModelKit Suite ClassReference
IDataBand..::.Source Property
IDataBand Interface See Also Send Feedback
Gets the data source object.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
Object Source { get; }
Visual Basic (Declaration)
ReadOnly Property Source As Object
Visual C++
property Object^ Source {
    Object^ get ();
}

See Also

IDataBand Interface
PerpetuumSoft.Reporting.DOM Namespace


IRegularBand Interface

[image]

.NET ModelKit Suite ClassReference
IRegularBand Interface
Members See Also Send Feedback
Defines common interface for all standard bands.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public interface IRegularBand
Visual Basic (Declaration)
Public Interface IRegularBand
Visual C++
public interface class IRegularBand

See Also

IRegularBand Members
PerpetuumSoft.Reporting.DOM Namespace


IRegularBand Members

[image] [image]

.NET ModelKit Suite ClassReference
IRegularBand Members
IRegularBand Interface Methods Properties See Also Send Feedback

The IRegularBand type exposes the following members.

Methods

Name | Description
Render | Renders the control to the final document.

Properties

Name | Description
SortPriority | Gets the band's priority for sorting operations.

See Also

IRegularBand Interface
PerpetuumSoft.Reporting.DOM Namespace


IRegularBand Methods

[image] [image]

.NET ModelKit Suite ClassReference
IRegularBand Methods
IRegularBand Interface See Also Send Feedback

The IRegularBand type exposes the following members.

Methods

Name | Description
Render | Renders the control to the final document.

See Also

IRegularBand Interface
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
IRegularBand..::.Render Method
IRegularBand Interface See Also Send Feedback
Renders the control to the final document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void Render()
Visual Basic (Declaration)
Sub Render
Visual C++
void Render()

See Also

IRegularBand Interface
PerpetuumSoft.Reporting.DOM Namespace


IRegularBand Properties

[image] [image]

.NET ModelKit Suite ClassReference
IRegularBand Properties
IRegularBand Interface See Also Send Feedback

The IRegularBand type exposes the following members.

Properties

Name | Description
SortPriority | Gets the band's priority for sorting operations.

See Also

IRegularBand Interface
PerpetuumSoft.Reporting.DOM Namespace


SortPriority Property

[image]

.NET ModelKit Suite ClassReference
IRegularBand..::.SortPriority Property
IRegularBand Interface See Also Send Feedback
Gets the band's priority for sorting operations.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
int SortPriority { get; }
Visual Basic (Declaration)
ReadOnly Property SortPriority As Integer
Visual C++
property int SortPriority {
    int get ();
}

See Also

IRegularBand Interface
PerpetuumSoft.Reporting.DOM Namespace


Page Class

[image]

.NET ModelKit Suite ClassReference
Page Class
Members See Also Send Feedback
Represents a single page in the report document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Page : ContainerControl
Visual Basic (Declaration)
Public Class Page _
    Inherits ContainerControl
Visual C++
public ref class Page : public ContainerControl

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Page

See Also

Page Members
PerpetuumSoft.Reporting.DOM Namespace


Page Members

[image] [image]

.NET ModelKit Suite ClassReference
Page Members
Page Class Constructors Methods Properties Events See Also Send Feedback

The Page type exposes the following members.

Constructors

Name | Description
Page | Creates a new instance of Page class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Overrides ContainerControl..::.ControlAt(PointF).)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Overrides ContainerControl..::.FindParent(ReportControl).)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInternalRectangle | Returns the rectangle delimited by the page margins.
GetPageSize | Returns size for the given paper kind.
GetScripts | Overloaded.
GetSortedBands | Gets the array of nested bands sorted by position.
GetSortedPageBands |
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Returns whether the specified ReportControl can be placed to the controls collection. (Inherited from ContainerControl.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnManualBuild | Raises ManualBuild event.
OnPaint | Performs drawing of the control. (Overrides ContainerControl..::.OnPaint(PaintArguments).)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Overrides ReportControl..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
RaiseManualBuild | Invokes OnManualBuildEvent.
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ShouldSerializeTemplateSize | Returns whether the TemplateSize property should be persisted.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the page bounds. (Overrides ReportControl..::.Bounds.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
CustomSize | Gets and sets the size of custom page kind.
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
ManualBuildScript | Gets and sets the code for the script that must perform the page content rendering. If this script is set then the standard renedering mechanism is disabled.
Margins | Gets and sets the page margins.
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Orientation | Gets and sets the page orientation.
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
PaperKind | Gets and sets the kind of paper.
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
TemplateSize | Gets and sets page size for template edit mode.
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)
ManualBuild | Occurs when the manual build is performed.

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


Page Constructor

[image]

.NET ModelKit Suite ClassReference
Page Constructor
Page Class See Also Send Feedback
Creates a new instance of Page class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Page()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Page()

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


Page Methods

[image] [image]

.NET ModelKit Suite ClassReference
Page Methods
Page Class See Also Send Feedback

The Page type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Overrides ContainerControl..::.ControlAt(PointF).)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Overrides ContainerControl..::.FindParent(ReportControl).)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetInternalRectangle | Returns the rectangle delimited by the page margins.
GetPageSize | Returns size for the given paper kind.
GetScripts | Overloaded.
GetSortedBands | Gets the array of nested bands sorted by position.
GetSortedPageBands |
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Returns whether the specified ReportControl can be placed to the controls collection. (Inherited from ContainerControl.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnManualBuild | Raises ManualBuild event.
OnPaint | Performs drawing of the control. (Overrides ContainerControl..::.OnPaint(PaintArguments).)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Overrides ReportControl..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
RaiseManualBuild | Invokes OnManualBuildEvent.
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ShouldSerializeTemplateSize | Returns whether the TemplateSize property should be persisted.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


ControlAt Method

[image]

.NET ModelKit Suite ClassReference
Page..::.ControlAt Method
Page Class See Also Send Feedback
Returns a ReportControl object that is found in the location specified by the given PointF.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override ReportControl ControlAt(
    PointF point
)
Visual Basic (Declaration)
Public Overrides Function ControlAt ( _
    point As PointF _
) As ReportControl
Visual C++
public:
virtual ReportControl^ ControlAt(
    PointF point
) override

Parameters

point
Type: System.Drawing..::.PointF

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


FindParent Method

[image]

.NET ModelKit Suite ClassReference
Page..::.FindParent Method
Page Class See Also Send Feedback
Finds the ReportControl's parent.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override IContainerControl FindParent(
    ReportControl c
)
Visual Basic (Declaration)
Public Overrides Function FindParent ( _
    c As ReportControl _
) As IContainerControl
Visual C++
public:
virtual IContainerControl^ FindParent(
    ReportControl^ c
) override

Parameters

c
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


GetInternalRectangle Method

[image]

.NET ModelKit Suite ClassReference
Page..::.GetInternalRectangle Method
Page Class See Also Send Feedback
Returns the rectangle delimited by the page margins.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle GetInternalRectangle()
Visual Basic (Declaration)
Public Function GetInternalRectangle As VectorRectangle
Visual C++
public:
VectorRectangle GetInternalRectangle()

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


GetPageSize Method

[image]

.NET ModelKit Suite ClassReference
Page..::.GetPageSize Method
Page Class See Also Send Feedback
Returns size for the given paper kind.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static Vector GetPageSize(
    PaperKind kind
)
Visual Basic (Declaration)
Public Shared Function GetPageSize ( _
    kind As PaperKind _
) As Vector
Visual C++
public:
static Vector GetPageSize(
    PaperKind kind
)

Parameters

kind
Type: PerpetuumSoft.Reporting.DOM..::.PaperKind

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
Page..::.GetScripts Method
Page Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Overrides ReportControl..::.GetScripts(ScriptInfoCollection).)

See Also

Page Class
Page Members
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method (ScriptInfoCollection)

[image]

.NET ModelKit Suite ClassReference
Page..::.GetScripts Method (ScriptInfoCollection)
Page Class See Also Send Feedback
Fills the specified collection with all scripts assigned to the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void GetScripts(
    ScriptInfoCollection scripts
)
Visual Basic (Declaration)
Public Overrides Sub GetScripts ( _
    scripts As ScriptInfoCollection _
)
Visual C++
public:
virtual void GetScripts(
    ScriptInfoCollection^ scripts
) override

Parameters

scripts
Type: PerpetuumSoft.Reporting.Rendering..::.ScriptInfoCollection

See Also

Page Class
GetScripts Overload
PerpetuumSoft.Reporting.DOM Namespace


GetSortedBands Method

[image]

.NET ModelKit Suite ClassReference
Page..::.GetSortedBands Method
Page Class See Also Send Feedback
Gets the array of nested bands sorted by position.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected IRegularBand[] GetSortedBands()
Visual Basic (Declaration)
Protected Function GetSortedBands As IRegularBand()
Visual C++
protected:
array<IRegularBand^>^ GetSortedBands()

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


GetSortedPageBands Method

[image]

.NET ModelKit Suite ClassReference
Page..::.GetSortedPageBands Method
Page Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.Page.GetSortedPageBands(System.Predicate{PerpetuumSoft.Reporting.DOM.ReportControl},System.Boolean)]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected ReportControl[] GetSortedPageBands(
    Predicate<ReportControl> pred,
    bool reverse
)
Visual Basic (Declaration)
Protected Function GetSortedPageBands ( _
    pred As Predicate(Of ReportControl), _
    reverse As Boolean _
) As ReportControl()
Visual C++
protected:
array<ReportControl^>^ GetSortedPageBands(
    Predicate<ReportControl^>^ pred,
    bool reverse
)

Parameters

pred
Type: System..::.Predicate <(Of <( ReportControl >)>)
reverse
Type: System..::.Boolean

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


OnManualBuild Method

[image]

.NET ModelKit Suite ClassReference
Page..::.OnManualBuild Method
Page Class See Also Send Feedback
Raises ManualBuild event.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnManualBuild(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnManualBuild ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnManualBuild(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


OnPaint Method

[image]

.NET ModelKit Suite ClassReference
Page..::.OnPaint Method
Page Class See Also Send Feedback
Performs drawing of the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
protected:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


PopulateProperties Method

[image]

.NET ModelKit Suite ClassReference
Page..::.PopulateProperties Method
Page Class See Also Send Feedback
Fills the properties of the final rendered control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PopulateProperties(
    ReportControl production
)
Visual Basic (Declaration)
Protected Overrides Sub PopulateProperties ( _
    production As ReportControl _
)
Visual C++
protected:
virtual void PopulateProperties(
    ReportControl^ production
) override

Parameters

production
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


RaiseManualBuild Method

[image]

.NET ModelKit Suite ClassReference
Page..::.RaiseManualBuild Method
Page Class See Also Send Feedback
Invokes OnManualBuildEvent.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected void RaiseManualBuild()
Visual Basic (Declaration)
Protected Sub RaiseManualBuild
Visual C++
protected:
void RaiseManualBuild()

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
Page..::.Render Method
Page Class See Also Send Feedback
Renders the control to the final document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


ShouldSerializeTemplateSize Method

[image]

.NET ModelKit Suite ClassReference
Page..::.ShouldSerializeTemplateSize Method
Page Class See Also Send Feedback
Returns whether the TemplateSize property should be persisted.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShouldSerializeTemplateSize()
Visual Basic (Declaration)
Public Function ShouldSerializeTemplateSize As Boolean
Visual C++
public:
bool ShouldSerializeTemplateSize()

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


Page Properties

[image] [image]

.NET ModelKit Suite ClassReference
Page Properties
Page Class See Also Send Feedback

The Page type exposes the following members.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the page bounds. (Overrides ReportControl..::.Bounds.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
CustomSize | Gets and sets the size of custom page kind.
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
ManualBuildScript | Gets and sets the code for the script that must perform the page content rendering. If this script is set then the standard renedering mechanism is disabled.
Margins | Gets and sets the page margins.
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Orientation | Gets and sets the page orientation.
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
PaperKind | Gets and sets the kind of paper.
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
TemplateSize | Gets and sets page size for template edit mode.
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


Bounds Property

[image]

.NET ModelKit Suite ClassReference
Page..::.Bounds Property
Page Class See Also Send Feedback
Gets and sets the page bounds.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override VectorRectangle Bounds { get; set; }
Visual Basic (Declaration)
Public Overrides Property Bounds As VectorRectangle
Visual C++
public:
virtual property VectorRectangle Bounds {
    VectorRectangle get () override;
    void set (VectorRectangle value) override;
}

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


CustomSize Property

[image]

.NET ModelKit Suite ClassReference
Page..::.CustomSize Property
Page Class See Also Send Feedback
Gets and sets the size of custom page kind.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Vector CustomSize { get; set; }
Visual Basic (Declaration)
Public Property CustomSize As Vector
Visual C++
public:
property Vector CustomSize {
    Vector get ();
    void set (Vector value);
}

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


ManualBuildScript Property

[image]

.NET ModelKit Suite ClassReference
Page..::.ManualBuildScript Property
Page Class See Also Send Feedback
Gets and sets the code for the script that must perform the page content rendering. If this script is set then the standard renedering mechanism is disabled.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string ManualBuildScript { get; set; }
Visual Basic (Declaration)
Public Property ManualBuildScript As String
Visual C++
public:
property String^ ManualBuildScript {
    String^ get ();
    void set (String^ value);
}

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


Margins Property

[image]

.NET ModelKit Suite ClassReference
Page..::.Margins Property
Page Class See Also Send Feedback
Gets and sets the page margins.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Margins Margins { get; set; }
Visual Basic (Declaration)
Public Property Margins As Margins
Visual C++
public:
property Margins Margins {
    Margins get ();
    void set (Margins value);
}

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


Orientation Property

[image]

.NET ModelKit Suite ClassReference
Page..::.Orientation Property
Page Class See Also Send Feedback
Gets and sets the page orientation.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PageOrientation Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As PageOrientation
Visual C++
public:
property PageOrientation Orientation {
    PageOrientation get ();
    void set (PageOrientation value);
}

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


PaperKind Property

[image]

.NET ModelKit Suite ClassReference
Page..::.PaperKind Property
Page Class See Also Send Feedback
Gets and sets the kind of paper.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PaperKind PaperKind { get; set; }
Visual Basic (Declaration)
Public Property PaperKind As PaperKind
Visual C++
public:
property PaperKind PaperKind {
    PaperKind get ();
    void set (PaperKind value);
}

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


TemplateSize Property

[image]

.NET ModelKit Suite ClassReference
Page..::.TemplateSize Property
Page Class See Also Send Feedback
Gets and sets page size for template edit mode.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Vector TemplateSize { get; set; }
Visual Basic (Declaration)
Public Property TemplateSize As Vector
Visual C++
public:
property Vector TemplateSize {
    Vector get ();
    void set (Vector value);
}

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


Page Events

[image] [image]

.NET ModelKit Suite ClassReference
Page Events
Page Class See Also Send Feedback

The Page type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)
ManualBuild | Occurs when the manual build is performed.

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


ManualBuild Event

[image]

.NET ModelKit Suite ClassReference
Page..::.ManualBuild Event
Page Class See Also Send Feedback
Occurs when the manual build is performed.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler ManualBuild
Visual Basic (Declaration)
Public Event ManualBuild As EventHandler
Visual C++
public:
 event EventHandler^ ManualBuild {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

Page Class
PerpetuumSoft.Reporting.DOM Namespace


PageBand Class

[image]

.NET ModelKit Suite ClassReference
PageBand Class
Members See Also Send Feedback
Base class for those bands that must appear on every page, such as page headers and footer.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class PageBand : BandBase
Visual Basic (Declaration)
Public Class PageBand _
    Inherits BandBase
Visual C++
public ref class PageBand : public BandBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.PageBand
PerpetuumSoft.Reporting.DOM..::.PageFooter
PerpetuumSoft.Reporting.DOM..::.PageHeader
PerpetuumSoft.Reporting.DOM..::.PageOverlay

See Also

PageBand Members
PerpetuumSoft.Reporting.DOM Namespace


PageBand Members

[image] [image]

.NET ModelKit Suite ClassReference
PageBand Members
PageBand Class Constructors Methods Properties Events See Also Send Feedback

The PageBand type exposes the following members.

Constructors

Name | Description
PageBand | Creates a new instance of PageBand class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Overrides Section..::.CheckConditions()()().)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Overrides Section..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Returns whether the specified control can be placed into the band. (Inherited from Section.)
IsValidParent | Returns whether the band can be placed into the specified container. (Overrides ReportControl..::.IsValidParent(ReportControl).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the band to the final document. (Overrides ReportControl..::.Render()()().)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Mode | Gets and sets the rendering mode for the current page band.
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

PageBand Class
PerpetuumSoft.Reporting.DOM Namespace


PageBand Constructor

[image]

.NET ModelKit Suite ClassReference
PageBand Constructor
PageBand Class See Also Send Feedback
Creates a new instance of PageBand class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PageBand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageBand()

See Also

PageBand Class
PerpetuumSoft.Reporting.DOM Namespace


PageBand Methods

[image] [image]

.NET ModelKit Suite ClassReference
PageBand Methods
PageBand Class See Also Send Feedback

The PageBand type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Overrides Section..::.CheckConditions()()().)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Overrides Section..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Returns whether the specified control can be placed into the band. (Inherited from Section.)
IsValidParent | Returns whether the band can be placed into the specified container. (Overrides ReportControl..::.IsValidParent(ReportControl).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the band to the final document. (Overrides ReportControl..::.Render()()().)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

See Also

PageBand Class
PerpetuumSoft.Reporting.DOM Namespace


CheckConditions Method

[image]

.NET ModelKit Suite ClassReference
PageBand..::.CheckConditions Method
PageBand Class See Also Send Feedback
Checks the band's condition.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override bool CheckConditions()
Visual Basic (Declaration)
Protected Overrides Function CheckConditions As Boolean
Visual C++
protected:
virtual bool CheckConditions() override

See Also

PageBand Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
PageBand..::.GetScripts Method
PageBand Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

PageBand Class
PageBand Members
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaptionColor Method

[image]

.NET ModelKit Suite ClassReference
PageBand..::.GetSectionCaptionColor Method
PageBand Class See Also Send Feedback
Returns the color of the title bar.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Color GetSectionCaptionColor()
Visual Basic (Declaration)
Protected Overrides Function GetSectionCaptionColor As Color
Visual C++
protected:
virtual Color GetSectionCaptionColor() override

See Also

PageBand Class
PerpetuumSoft.Reporting.DOM Namespace


IsValidParent Method

[image]

.NET ModelKit Suite ClassReference
PageBand..::.IsValidParent Method
PageBand Class See Also Send Feedback
Returns whether the band can be placed into the specified container.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValidParent(
    ReportControl c
)
Visual Basic (Declaration)
Public Overrides Function IsValidParent ( _
    c As ReportControl _
) As Boolean
Visual C++
public:
virtual bool IsValidParent(
    ReportControl^ c
) override

Parameters

c
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

PageBand Class
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
PageBand..::.Render Method
PageBand Class See Also Send Feedback
Renders the band to the final document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

PageBand Class
PerpetuumSoft.Reporting.DOM Namespace


PageBand Properties

[image] [image]

.NET ModelKit Suite ClassReference
PageBand Properties
PageBand Class See Also Send Feedback

The PageBand type exposes the following members.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Mode | Gets and sets the rendering mode for the current page band.
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

PageBand Class
PerpetuumSoft.Reporting.DOM Namespace


Mode Property

[image]

.NET ModelKit Suite ClassReference
PageBand..::.Mode Property
PageBand Class See Also Send Feedback
Gets and sets the rendering mode for the current page band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PageBandMode Mode { get; set; }
Visual Basic (Declaration)
Public Property Mode As PageBandMode
Visual C++
public:
property PageBandMode Mode {
    PageBandMode get ();
    void set (PageBandMode value);
}

See Also

PageBand Class
PerpetuumSoft.Reporting.DOM Namespace


PageBand Events

[image] [image]

.NET ModelKit Suite ClassReference
PageBand Events
PageBand Class See Also Send Feedback

The PageBand type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

PageBand Class
PerpetuumSoft.Reporting.DOM Namespace


PageBandMode Enumeration

[image]

.NET ModelKit Suite ClassReference
PageBandMode Enumeration
See Also Send Feedback
Specifies rendering modes for PageBand.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum PageBandMode
Visual Basic (Declaration)
Public Enumeration PageBandMode
Visual C++
public enum class PageBandMode

Members

Member name | Description
AllPages | Print on every page.
OddPages | Print on odd pages only.
EvenPages | Print on even pages only.

See Also

PerpetuumSoft.Reporting.DOM Namespace


PageCollection Class

[image]

.NET ModelKit Suite ClassReference
PageCollection Class
Members See Also Send Feedback
Represents the collection of pages in the document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
[SerializableAttribute]
public class PageCollection : CollectionBase
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class PageCollection _
    Inherits CollectionBase
Visual C++
[SerializableAttribute]
public ref class PageCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Reporting.DOM..::.PageCollection

See Also

PageCollection Members
PerpetuumSoft.Reporting.DOM Namespace


PageCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
PageCollection Members
PageCollection Class Constructors Methods Properties See Also Send Feedback

The PageCollection type exposes the following members.

Constructors

Name | Description
PageCollection | Initializes a new instance of the PageCollection class.

Methods

Name | Description
Add | Adds the specified page to the end of the collection.
AddRange | Adds the specified array of pages to the end of the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the page already exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified page's index in the collection.
Insert | Inserts the specified page to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes when inserting pages. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing pages. (Overrides CollectionBase..::.OnRemove(Int32, Object).)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified page from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets the page at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

PageCollection Class
PerpetuumSoft.Reporting.DOM Namespace


PageCollection Constructor

[image]

.NET ModelKit Suite ClassReference
PageCollection Constructor
PageCollection Class See Also Send Feedback
Initializes a new instance of the PageCollection class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PageCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageCollection()

See Also

PageCollection Class
PerpetuumSoft.Reporting.DOM Namespace


PageCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
PageCollection Methods
PageCollection Class See Also Send Feedback

The PageCollection type exposes the following members.

Methods

Name | Description
Add | Adds the specified page to the end of the collection.
AddRange | Adds the specified array of pages to the end of the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the page already exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified page's index in the collection.
Insert | Inserts the specified page to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes when inserting pages. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing pages. (Overrides CollectionBase..::.OnRemove(Int32, Object).)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified page from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
PageCollection..::.Add Method
PageCollection Class See Also Send Feedback
Adds the specified page to the end of the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Page Add(
    Page value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As Page _
) As Page
Visual C++
public:
Page^ Add(
    Page^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.Page

See Also

PageCollection Class
PerpetuumSoft.Reporting.DOM Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
PageCollection..::.AddRange Method
PageCollection Class See Also Send Feedback
Adds the specified array of pages to the end of the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    Page[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As Page() _
)
Visual C++
public:
void AddRange(
    array<Page^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Reporting.DOM..::.Page >[]()[]

See Also

PageCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
PageCollection..::.Contains Method
PageCollection Class See Also Send Feedback
Returns whether the page already exists in the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    Page value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As Page _
) As Boolean
Visual C++
public:
bool Contains(
    Page^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.Page

See Also

PageCollection Class
PerpetuumSoft.Reporting.DOM Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
PageCollection..::.IndexOf Method
PageCollection Class See Also Send Feedback
Returns the specified page's index in the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    Page value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As Page _
) As Integer
Visual C++
public:
int IndexOf(
    Page^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.Page

See Also

PageCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
PageCollection..::.Insert Method
PageCollection Class See Also Send Feedback
Inserts the specified page to the collection at the specified index.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    Page value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As Page _
)
Visual C++
public:
void Insert(
    int index,
    Page^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Reporting.DOM..::.Page

See Also

PageCollection Class
PerpetuumSoft.Reporting.DOM Namespace


OnInsert Method

[image]

.NET ModelKit Suite ClassReference
PageCollection..::.OnInsert Method
PageCollection Class See Also Send Feedback
Performs additional custom processes when inserting pages.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsert(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsert ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsert(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

PageCollection Class
PerpetuumSoft.Reporting.DOM Namespace


OnRemove Method

[image]

.NET ModelKit Suite ClassReference
PageCollection..::.OnRemove Method
PageCollection Class See Also Send Feedback
Performs additional custom processes when removing pages.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnRemove(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemove ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemove(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

PageCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
PageCollection..::.Remove Method
PageCollection Class See Also Send Feedback
Removes the specified page from the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    Page value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As Page _
)
Visual C++
public:
void Remove(
    Page^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.Page

See Also

PageCollection Class
PerpetuumSoft.Reporting.DOM Namespace


PageCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
PageCollection Properties
PageCollection Class See Also Send Feedback

The PageCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets the page at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

PageCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
PageCollection..::.Item Property
PageCollection Class See Also Send Feedback
Gets the page at the specified index.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Page this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Page
Visual C++
public:
property Page^ default[int index] {
    Page^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

PageCollection Class
PerpetuumSoft.Reporting.DOM Namespace


PageFooter Class

[image]

.NET ModelKit Suite ClassReference
PageFooter Class
Members See Also Send Feedback
Represents a page footer.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class PageFooter : PageBand
Visual Basic (Declaration)
Public Class PageFooter _
    Inherits PageBand
Visual C++
public ref class PageFooter : public PageBand

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.PageBand
PerpetuumSoft.Reporting.DOM..::.PageFooter

See Also

PageFooter Members
PerpetuumSoft.Reporting.DOM Namespace


PageFooter Members

[image] [image]

.NET ModelKit Suite ClassReference
PageFooter Members
PageFooter Class Constructors Methods Properties Events See Also Send Feedback

The PageFooter type exposes the following members.

Constructors

Name | Description
PageFooter | Creates a new instance of PageFooter class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Overrides Section..::.CalculateCaretPosition()()().)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from PageBand.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Inherited from PageBand.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Returns whether the specified control can be placed into the band. (Inherited from Section.)
IsValidParent | Returns whether the band can be placed into the specified container. (Inherited from PageBand.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the band to the final document. (Inherited from PageBand.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free area on the page after the band is rendered. (Overrides Section..::.UpdatePageArea()()().)

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Mode | Gets and sets the rendering mode for the current page band. (Inherited from PageBand.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Overrides Section..::.SortPriority.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

PageFooter Class
PerpetuumSoft.Reporting.DOM Namespace


PageFooter Constructor

[image]

.NET ModelKit Suite ClassReference
PageFooter Constructor
PageFooter Class See Also Send Feedback
Creates a new instance of PageFooter class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PageFooter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageFooter()

See Also

PageFooter Class
PerpetuumSoft.Reporting.DOM Namespace


PageFooter Methods

[image] [image]

.NET ModelKit Suite ClassReference
PageFooter Methods
PageFooter Class See Also Send Feedback

The PageFooter type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Overrides Section..::.CalculateCaretPosition()()().)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from PageBand.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Inherited from PageBand.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Returns whether the specified control can be placed into the band. (Inherited from Section.)
IsValidParent | Returns whether the band can be placed into the specified container. (Inherited from PageBand.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the band to the final document. (Inherited from PageBand.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free area on the page after the band is rendered. (Overrides Section..::.UpdatePageArea()()().)

See Also

PageFooter Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateCaretPosition Method

[image]

.NET ModelKit Suite ClassReference
PageFooter..::.CalculateCaretPosition Method
PageFooter Class See Also Send Feedback
Calculates the current position in the report for placing the current band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void CalculateCaretPosition()
Visual Basic (Declaration)
Protected Overrides Sub CalculateCaretPosition
Visual C++
protected:
virtual void CalculateCaretPosition() override

See Also

PageFooter Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
PageFooter..::.GetScripts Method
PageFooter Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

PageFooter Class
PageFooter Members
PerpetuumSoft.Reporting.DOM Namespace


UpdatePageArea Method

[image]

.NET ModelKit Suite ClassReference
PageFooter..::.UpdatePageArea Method
PageFooter Class See Also Send Feedback
Calculates the remaining free area on the page after the band is rendered.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void UpdatePageArea()
Visual Basic (Declaration)
Protected Overrides Sub UpdatePageArea
Visual C++
protected:
virtual void UpdatePageArea() override

See Also

PageFooter Class
PerpetuumSoft.Reporting.DOM Namespace


PageFooter Properties

[image] [image]

.NET ModelKit Suite ClassReference
PageFooter Properties
PageFooter Class See Also Send Feedback

The PageFooter type exposes the following members.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Mode | Gets and sets the rendering mode for the current page band. (Inherited from PageBand.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Overrides Section..::.SortPriority.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

PageFooter Class
PerpetuumSoft.Reporting.DOM Namespace


SortPriority Property

[image]

.NET ModelKit Suite ClassReference
PageFooter..::.SortPriority Property
PageFooter Class See Also Send Feedback
Gets the band's priority for sorting operations.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override int SortPriority { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property SortPriority As Integer
Visual C++
public:
virtual property int SortPriority {
    int get () override;
}

See Also

PageFooter Class
PerpetuumSoft.Reporting.DOM Namespace


PageFooter Events

[image] [image]

.NET ModelKit Suite ClassReference
PageFooter Events
PageFooter Class See Also Send Feedback

The PageFooter type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

PageFooter Class
PerpetuumSoft.Reporting.DOM Namespace


PageHeader Class

[image]

.NET ModelKit Suite ClassReference
PageHeader Class
Members See Also Send Feedback
Represents a page header.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class PageHeader : PageBand
Visual Basic (Declaration)
Public Class PageHeader _
    Inherits PageBand
Visual C++
public ref class PageHeader : public PageBand

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.PageBand
PerpetuumSoft.Reporting.DOM..::.PageHeader

See Also

PageHeader Members
PerpetuumSoft.Reporting.DOM Namespace


PageHeader Members

[image] [image]

.NET ModelKit Suite ClassReference
PageHeader Members
PageHeader Class Constructors Methods Properties Events See Also Send Feedback

The PageHeader type exposes the following members.

Constructors

Name | Description
PageHeader | Creates a new instance of PageHeader class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Overrides Section..::.CalculateCaretPosition()()().)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from PageBand.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Inherited from PageBand.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Returns whether the specified control can be placed into the band. (Inherited from Section.)
IsValidParent | Returns whether the band can be placed into the specified container. (Inherited from PageBand.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the band to the final document. (Inherited from PageBand.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free area on the page after the band is rendered. (Overrides Section..::.UpdatePageArea()()().)

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Mode | Gets and sets the rendering mode for the current page band. (Inherited from PageBand.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Overrides Section..::.SortPriority.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

PageHeader Class
PerpetuumSoft.Reporting.DOM Namespace


PageHeader Constructor

[image]

.NET ModelKit Suite ClassReference
PageHeader Constructor
PageHeader Class See Also Send Feedback
Creates a new instance of PageHeader class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PageHeader()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageHeader()

See Also

PageHeader Class
PerpetuumSoft.Reporting.DOM Namespace


PageHeader Methods

[image] [image]

.NET ModelKit Suite ClassReference
PageHeader Methods
PageHeader Class See Also Send Feedback

The PageHeader type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Overrides Section..::.CalculateCaretPosition()()().)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from PageBand.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Inherited from PageBand.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Returns whether the specified control can be placed into the band. (Inherited from Section.)
IsValidParent | Returns whether the band can be placed into the specified container. (Inherited from PageBand.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the band to the final document. (Inherited from PageBand.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free area on the page after the band is rendered. (Overrides Section..::.UpdatePageArea()()().)

See Also

PageHeader Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateCaretPosition Method

[image]

.NET ModelKit Suite ClassReference
PageHeader..::.CalculateCaretPosition Method
PageHeader Class See Also Send Feedback
Calculates the current position in the report for placing the current band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void CalculateCaretPosition()
Visual Basic (Declaration)
Protected Overrides Sub CalculateCaretPosition
Visual C++
protected:
virtual void CalculateCaretPosition() override

See Also

PageHeader Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
PageHeader..::.GetScripts Method
PageHeader Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

PageHeader Class
PageHeader Members
PerpetuumSoft.Reporting.DOM Namespace


UpdatePageArea Method

[image]

.NET ModelKit Suite ClassReference
PageHeader..::.UpdatePageArea Method
PageHeader Class See Also Send Feedback
Calculates the remaining free area on the page after the band is rendered.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void UpdatePageArea()
Visual Basic (Declaration)
Protected Overrides Sub UpdatePageArea
Visual C++
protected:
virtual void UpdatePageArea() override

See Also

PageHeader Class
PerpetuumSoft.Reporting.DOM Namespace


PageHeader Properties

[image] [image]

.NET ModelKit Suite ClassReference
PageHeader Properties
PageHeader Class See Also Send Feedback

The PageHeader type exposes the following members.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Mode | Gets and sets the rendering mode for the current page band. (Inherited from PageBand.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Overrides Section..::.SortPriority.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

PageHeader Class
PerpetuumSoft.Reporting.DOM Namespace


SortPriority Property

[image]

.NET ModelKit Suite ClassReference
PageHeader..::.SortPriority Property
PageHeader Class See Also Send Feedback
Gets the band's priority for sorting operations.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override int SortPriority { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property SortPriority As Integer
Visual C++
public:
virtual property int SortPriority {
    int get () override;
}

See Also

PageHeader Class
PerpetuumSoft.Reporting.DOM Namespace


PageHeader Events

[image] [image]

.NET ModelKit Suite ClassReference
PageHeader Events
PageHeader Class See Also Send Feedback

The PageHeader type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

PageHeader Class
PerpetuumSoft.Reporting.DOM Namespace


PageOrientation Enumeration

[image]

.NET ModelKit Suite ClassReference
PageOrientation Enumeration
See Also Send Feedback
Specifies page orientation.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum PageOrientation
Visual Basic (Declaration)
Public Enumeration PageOrientation
Visual C++
public enum class PageOrientation

Members

Member name | Description
Portrait | Portrauit page.
Landscape | Landspace page.

See Also

PerpetuumSoft.Reporting.DOM Namespace


PageOverlay Class

[image]

.NET ModelKit Suite ClassReference
PageOverlay Class
Members See Also Send Feedback
Represents a page overlay band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class PageOverlay : PageBand
Visual Basic (Declaration)
Public Class PageOverlay _
    Inherits PageBand
Visual C++
public ref class PageOverlay : public PageBand

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.PageBand
PerpetuumSoft.Reporting.DOM..::.PageOverlay

See Also

PageOverlay Members
PerpetuumSoft.Reporting.DOM Namespace


PageOverlay Members

[image] [image]

.NET ModelKit Suite ClassReference
PageOverlay Members
PageOverlay Class Constructors Methods Properties Events See Also Send Feedback

The PageOverlay type exposes the following members.

Constructors

Name | Description
PageOverlay | Creates a new instance of PageOverlay class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Overrides Section..::.CalculateCaretPosition()()().)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from PageBand.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Overrides PageBand..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Returns whether the specified control can be placed into the band. (Inherited from Section.)
IsValidParent | Returns whether the band can be placed into the specified container. (Inherited from PageBand.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the band to the final document. (Inherited from PageBand.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free area on the page after the band is rendered. (Overrides Section..::.UpdatePageArea()()().)

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Mode | Gets and sets the rendering mode for the current page band. (Inherited from PageBand.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

PageOverlay Class
PerpetuumSoft.Reporting.DOM Namespace


PageOverlay Constructor

[image]

.NET ModelKit Suite ClassReference
PageOverlay Constructor
PageOverlay Class See Also Send Feedback
Creates a new instance of PageOverlay class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PageOverlay()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageOverlay()

See Also

PageOverlay Class
PerpetuumSoft.Reporting.DOM Namespace


PageOverlay Methods

[image] [image]

.NET ModelKit Suite ClassReference
PageOverlay Methods
PageOverlay Class See Also Send Feedback

The PageOverlay type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Overrides Section..::.CalculateCaretPosition()()().)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from PageBand.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Overrides PageBand..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Returns whether the specified control can be placed into the band. (Inherited from Section.)
IsValidParent | Returns whether the band can be placed into the specified container. (Inherited from PageBand.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the band to the final document. (Inherited from PageBand.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free area on the page after the band is rendered. (Overrides Section..::.UpdatePageArea()()().)

See Also

PageOverlay Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateCaretPosition Method

[image]

.NET ModelKit Suite ClassReference
PageOverlay..::.CalculateCaretPosition Method
PageOverlay Class See Also Send Feedback
Calculates the current position in the report for placing the current band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void CalculateCaretPosition()
Visual Basic (Declaration)
Protected Overrides Sub CalculateCaretPosition
Visual C++
protected:
virtual void CalculateCaretPosition() override

See Also

PageOverlay Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
PageOverlay..::.GetScripts Method
PageOverlay Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

PageOverlay Class
PageOverlay Members
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaptionColor Method

[image]

.NET ModelKit Suite ClassReference
PageOverlay..::.GetSectionCaptionColor Method
PageOverlay Class See Also Send Feedback
Returns the color of the title bar.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Color GetSectionCaptionColor()
Visual Basic (Declaration)
Protected Overrides Function GetSectionCaptionColor As Color
Visual C++
protected:
virtual Color GetSectionCaptionColor() override

See Also

PageOverlay Class
PerpetuumSoft.Reporting.DOM Namespace


UpdatePageArea Method

[image]

.NET ModelKit Suite ClassReference
PageOverlay..::.UpdatePageArea Method
PageOverlay Class See Also Send Feedback
Calculates the remaining free area on the page after the band is rendered.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void UpdatePageArea()
Visual Basic (Declaration)
Protected Overrides Sub UpdatePageArea
Visual C++
protected:
virtual void UpdatePageArea() override

See Also

PageOverlay Class
PerpetuumSoft.Reporting.DOM Namespace


PageOverlay Properties

[image] [image]

.NET ModelKit Suite ClassReference
PageOverlay Properties
PageOverlay Class See Also Send Feedback

The PageOverlay type exposes the following members.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Mode | Gets and sets the rendering mode for the current page band. (Inherited from PageBand.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

PageOverlay Class
PerpetuumSoft.Reporting.DOM Namespace


PageOverlay Events

[image] [image]

.NET ModelKit Suite ClassReference
PageOverlay Events
PageOverlay Class See Also Send Feedback

The PageOverlay type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

PageOverlay Class
PerpetuumSoft.Reporting.DOM Namespace


PaintArguments Class

[image]

.NET ModelKit Suite ClassReference
PaintArguments Class
Members See Also Send Feedback
Provides data for painting a control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class PaintArguments
Visual Basic (Declaration)
Public Class PaintArguments
Visual C++
public ref class PaintArguments

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.PaintArguments

See Also

PaintArguments Members
PerpetuumSoft.Reporting.DOM Namespace


PaintArguments Members

[image] [image]

.NET ModelKit Suite ClassReference
PaintArguments Members
PaintArguments Class Constructors Methods Properties See Also Send Feedback

The PaintArguments type exposes the following members.

Constructors

Name | Description
PaintArguments | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Clip | Gets the clip rectangle defining the region where to paint the control.
Graphics | Gets the graphics where to paint the control.
ShowBounds | Gets if designer need to show bounds for each report control.

See Also

PaintArguments Class
PerpetuumSoft.Reporting.DOM Namespace


PaintArguments Constructor

[image] [image]

.NET ModelKit Suite ClassReference
PaintArguments Constructor
PaintArguments Class See Also Send Feedback

Overload List

Name | Description
PaintArguments(Graphics, VectorRectangle) | Initializes a new instance of the PaintArguments class.
PaintArguments(Graphics, VectorRectangle, Boolean) | Initializes a new instance of the PaintArguments class.

See Also

PaintArguments Class
PaintArguments Members
PerpetuumSoft.Reporting.DOM Namespace


PaintArguments Constructor (Graphics, VectorRectangle)

[image]

.NET ModelKit Suite ClassReference
PaintArguments Constructor (Graphics, VectorRectangle)
PaintArguments Class See Also Send Feedback
Initializes a new instance of the PaintArguments class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PaintArguments(
    Graphics graphics,
    VectorRectangle clip
)
Visual Basic (Declaration)
Public Sub New ( _
    graphics As Graphics, _
    clip As VectorRectangle _
)
Visual C++
public:
PaintArguments(
    Graphics^ graphics,
    VectorRectangle clip
)

Parameters

graphics
Type: System.Drawing..::.Graphics
clip
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

PaintArguments Class
PaintArguments Overload
PerpetuumSoft.Reporting.DOM Namespace


PaintArguments Constructor (Graphics, VectorRectangle, Boolean)

[image]

.NET ModelKit Suite ClassReference
PaintArguments Constructor (Graphics, VectorRectangle, Boolean)
PaintArguments Class See Also Send Feedback
Initializes a new instance of the PaintArguments class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PaintArguments(
    Graphics graphics,
    VectorRectangle clip,
    bool showBounds
)
Visual Basic (Declaration)
Public Sub New ( _
    graphics As Graphics, _
    clip As VectorRectangle, _
    showBounds As Boolean _
)
Visual C++
public:
PaintArguments(
    Graphics^ graphics,
    VectorRectangle clip,
    bool showBounds
)

Parameters

graphics
Type: System.Drawing..::.Graphics
clip
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle
showBounds
Type: System..::.Boolean

See Also

PaintArguments Class
PaintArguments Overload
PerpetuumSoft.Reporting.DOM Namespace


PaintArguments Methods

[image] [image]

.NET ModelKit Suite ClassReference
PaintArguments Methods
PaintArguments Class See Also Send Feedback

The PaintArguments type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaintArguments Class
PerpetuumSoft.Reporting.DOM Namespace


PaintArguments Properties

[image] [image]

.NET ModelKit Suite ClassReference
PaintArguments Properties
PaintArguments Class See Also Send Feedback

The PaintArguments type exposes the following members.

Properties

Name | Description
Clip | Gets the clip rectangle defining the region where to paint the control.
Graphics | Gets the graphics where to paint the control.
ShowBounds | Gets if designer need to show bounds for each report control.

See Also

PaintArguments Class
PerpetuumSoft.Reporting.DOM Namespace


Clip Property

[image]

.NET ModelKit Suite ClassReference
PaintArguments..::.Clip Property
PaintArguments Class See Also Send Feedback
Gets the clip rectangle defining the region where to paint the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle Clip { get; }
Visual Basic (Declaration)
Public ReadOnly Property Clip As VectorRectangle
Visual C++
public:
property VectorRectangle Clip {
    VectorRectangle get ();
}

See Also

PaintArguments Class
PerpetuumSoft.Reporting.DOM Namespace


Graphics Property

[image]

.NET ModelKit Suite ClassReference
PaintArguments..::.Graphics Property
PaintArguments Class See Also Send Feedback
Gets the graphics where to paint the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Graphics Graphics { get; }
Visual Basic (Declaration)
Public ReadOnly Property Graphics As Graphics
Visual C++
public:
property Graphics^ Graphics {
    Graphics^ get ();
}

See Also

PaintArguments Class
PerpetuumSoft.Reporting.DOM Namespace


ShowBounds Property

[image]

.NET ModelKit Suite ClassReference
PaintArguments..::.ShowBounds Property
PaintArguments Class See Also Send Feedback
Gets if designer need to show bounds for each report control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowBounds { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShowBounds As Boolean
Visual C++
public:
property bool ShowBounds {
    bool get ();
}

See Also

PaintArguments Class
PerpetuumSoft.Reporting.DOM Namespace


PaperKind Enumeration

[image]

.NET ModelKit Suite ClassReference
PaperKind Enumeration
See Also Send Feedback
Specifies paper kinds.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum PaperKind
Visual Basic (Declaration)
Public Enumeration PaperKind
Visual C++
public enum class PaperKind

Members

Member name | Description
A2 | A2 paper (420 mm by 594 mm).
A3 | A3 paper (297 mm by 420 mm).
A4 | A4 paper (210 mm by 297 mm).
A5 | A5 paper.
A6 | A6 paper.
B4 | B4 paer.
B5 | B5 paper.
Legal | Legal paper.
Letter | Letter paper.
Folio | Folio paper.
Custom | Custom paper size.

See Also

PerpetuumSoft.Reporting.DOM Namespace


Parameter Class

[image]

.NET ModelKit Suite ClassReference
Parameter Class
Members See Also Send Feedback
Represents partameter transmitted to a document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Parameter : ICloneable
Visual Basic (Declaration)
Public Class Parameter _
    Implements ICloneable
Visual C++
public ref class Parameter : ICloneable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.Parameter

See Also

Parameter Members
PerpetuumSoft.Reporting.DOM Namespace


Parameter Members

[image] [image]

.NET ModelKit Suite ClassReference
Parameter Members
Parameter Class Constructors Methods Properties See Also Send Feedback

The Parameter type exposes the following members.

Constructors

Name | Description
Parameter | Initializes a new instance of the Parameter class.

Methods

Name | Description
Clone | Implements Clone()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns a parameter value casted to parameter type.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns parameter name. (Overrides Object..::.ToString()()().)

Properties

Name | Description
DefaultValue | Gets or sets parameter default value. Used when parameter value is null.
Name | Gets or sets parameter name.
ParameterType | Gets or sets parameter type name.
Value | Gets or sets parameter value.

See Also

Parameter Class
PerpetuumSoft.Reporting.DOM Namespace


Parameter Constructor

[image]

.NET ModelKit Suite ClassReference
Parameter Constructor
Parameter Class See Also Send Feedback
Initializes a new instance of the Parameter class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Parameter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Parameter()

See Also

Parameter Class
PerpetuumSoft.Reporting.DOM Namespace


Parameter Methods

[image] [image]

.NET ModelKit Suite ClassReference
Parameter Methods
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Methods

Name | Description
Clone | Implements Clone()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | Returns a parameter value casted to parameter type.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns parameter name. (Overrides Object..::.ToString()()().)

See Also

Parameter Class
PerpetuumSoft.Reporting.DOM Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
Parameter..::.Clone Method
Parameter Class See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Parameter Clone()
Visual Basic (Declaration)
Public Function Clone As Parameter
Visual C++
public:
Parameter^ Clone()

See Also

Parameter Class
PerpetuumSoft.Reporting.DOM Namespace


GetValue Method

[image]

.NET ModelKit Suite ClassReference
Parameter..::.GetValue Method
Parameter Class See Also Send Feedback
Returns a parameter value casted to parameter type.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object GetValue()
Visual Basic (Declaration)
Public Function GetValue As Object
Visual C++
public:
Object^ GetValue()

See Also

Parameter Class
PerpetuumSoft.Reporting.DOM Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
Parameter..::.ToString Method
Parameter Class See Also Send Feedback
Returns parameter name.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Parameter Class
PerpetuumSoft.Reporting.DOM Namespace


Parameter Properties

[image] [image]

.NET ModelKit Suite ClassReference
Parameter Properties
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Properties

Name | Description
DefaultValue | Gets or sets parameter default value. Used when parameter value is null.
Name | Gets or sets parameter name.
ParameterType | Gets or sets parameter type name.
Value | Gets or sets parameter value.

See Also

Parameter Class
PerpetuumSoft.Reporting.DOM Namespace


DefaultValue Property

[image]

.NET ModelKit Suite ClassReference
Parameter..::.DefaultValue Property
Parameter Class See Also Send Feedback
Gets or sets parameter default value. Used when parameter value is null.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string DefaultValue { get; set; }
Visual Basic (Declaration)
Public Property DefaultValue As String
Visual C++
public:
property String^ DefaultValue {
    String^ get ();
    void set (String^ value);
}

See Also

Parameter Class
PerpetuumSoft.Reporting.DOM Namespace


Name Property

[image]

.NET ModelKit Suite ClassReference
Parameter..::.Name Property
Parameter Class See Also Send Feedback
Gets or sets parameter name.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Parameter Class
PerpetuumSoft.Reporting.DOM Namespace


ParameterType Property

[image]

.NET ModelKit Suite ClassReference
Parameter..::.ParameterType Property
Parameter Class See Also Send Feedback
Gets or sets parameter type name.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string ParameterType { get; set; }
Visual Basic (Declaration)
Public Property ParameterType As String
Visual C++
public:
property String^ ParameterType {
    String^ get ();
    void set (String^ value);
}

See Also

Parameter Class
PerpetuumSoft.Reporting.DOM Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
Parameter..::.Value Property
Parameter Class See Also Send Feedback
Gets or sets parameter value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

Parameter Class
PerpetuumSoft.Reporting.DOM Namespace


ParameterCollection Class

[image]

.NET ModelKit Suite ClassReference
ParameterCollection Class
Members See Also Send Feedback
Represent collection of document parameters.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
[SerializableAttribute]
public class ParameterCollection : CollectionBase
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ParameterCollection _
    Inherits CollectionBase
Visual C++
[SerializableAttribute]
public ref class ParameterCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Reporting.DOM..::.ParameterCollection

See Also

ParameterCollection Members
PerpetuumSoft.Reporting.DOM Namespace


ParameterCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
ParameterCollection Members
ParameterCollection Class Constructors Methods Properties See Also Send Feedback

The ParameterCollection type exposes the following members.

Constructors

Name | Description
ParameterCollection | Initializes a new instance of the ParameterCollection class.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ParameterCollection Class
PerpetuumSoft.Reporting.DOM Namespace


ParameterCollection Constructor

[image]

.NET ModelKit Suite ClassReference
ParameterCollection Constructor
ParameterCollection Class See Also Send Feedback
Initializes a new instance of the ParameterCollection class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ParameterCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterCollection()

See Also

ParameterCollection Class
PerpetuumSoft.Reporting.DOM Namespace


ParameterCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
ParameterCollection Methods
ParameterCollection Class See Also Send Feedback

The ParameterCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Add Method

[image] [image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.Add Method
ParameterCollection Class See Also Send Feedback

Overload List

Name | Description
Add(Parameter) | Implements Add(Object).
Add(String, Object) | Adds a new parameter to the collection.

See Also

ParameterCollection Class
ParameterCollection Members
PerpetuumSoft.Reporting.DOM Namespace


Add Method (Parameter)

[image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.Add Method (Parameter)
ParameterCollection Class See Also Send Feedback
Implements Add(Object).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Add(
    Parameter parameter
)
Visual Basic (Declaration)
Public Sub Add ( _
    parameter As Parameter _
)
Visual C++
public:
void Add(
    Parameter^ parameter
)

Parameters

parameter
Type: PerpetuumSoft.Reporting.DOM..::.Parameter

See Also

ParameterCollection Class
Add Overload
PerpetuumSoft.Reporting.DOM Namespace


Add Method (String, Object)

[image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.Add Method (String, Object)
ParameterCollection Class See Also Send Feedback
Adds a new parameter to the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Add(
    string name,
    Object value
)
Visual Basic (Declaration)
Public Sub Add ( _
    name As String, _
    value As Object _
)
Visual C++
public:
void Add(
    String^ name,
    Object^ value
)

Parameters

name
Type: System..::.String
value
Type: System..::.Object

See Also

ParameterCollection Class
Add Overload
PerpetuumSoft.Reporting.DOM Namespace


ParameterCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
ParameterCollection Properties
ParameterCollection Class See Also Send Feedback

The ParameterCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ParameterCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Item Property

[image] [image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.Item Property
ParameterCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Implements Item[([(Int32])]).
Item[([(String])]) | Gets parameter for specified name.

See Also

ParameterCollection Class
ParameterCollection Members
PerpetuumSoft.Reporting.DOM Namespace


Item Property (Int32)

[image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.Item Property (Int32)
ParameterCollection Class See Also Send Feedback
Implements Item[([(Int32])]).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Parameter this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Parameter
Visual C++
public:
property Parameter^ default[int index] {
    Parameter^ get (int index);
    void set (int index, Parameter^ value);
}

Parameters

index
Type: System..::.Int32

See Also

ParameterCollection Class
Item Overload
PerpetuumSoft.Reporting.DOM Namespace


Item Property (String)

[image]

.NET ModelKit Suite ClassReference
ParameterCollection..::.Item Property (String)
ParameterCollection Class See Also Send Feedback
Gets parameter for specified name.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Parameter this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As Parameter
Visual C++
public:
property Parameter^ default[String^ name] {
    Parameter^ get (String^ name);
}

Parameters

name
Type: System..::.String

See Also

ParameterCollection Class
Item Overload
PerpetuumSoft.Reporting.DOM Namespace


Picture Class

[image]

.NET ModelKit Suite ClassReference
Picture Class
Members See Also Send Feedback
Represents a picture control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Picture : Box
Visual Basic (Declaration)
Public Class Picture _
    Inherits Box
Visual C++
public ref class Picture : public Box

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.VisualControl
PerpetuumSoft.Reporting.DOM..::.Box
PerpetuumSoft.Reporting.DOM..::.Picture

See Also

Picture Members
PerpetuumSoft.Reporting.DOM Namespace


Picture Members

[image] [image]

.NET ModelKit Suite ClassReference
Picture Members
Picture Class Constructors Methods Properties Events See Also Send Feedback

The Picture type exposes the following members.

Constructors

Name | Description
Picture | Creates a new instance of Picture class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Overridden. See CreateBlankControl()()(). (Overrides ReportControl..::.CreateBlankControl()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImagePosition | Returns location of the left-top corner of the image.
GetImageSize | Returns the size of the image after stretch.
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed. (Inherited from Box.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Paints picture element content. (Overrides Box..::.PaintContent(PaintArguments, RectangleF).)
PopulateProperties | Fills the properties of the final rendered control. (Overrides Box..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
RunPropertyDesigner | (Overrides ReportControlRunPropertyDesigner(IReportDesignerService).)
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Image | Gets and sets the image.
ImageAlign | Gets and sets the image alignment.
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SizeMode | Gets and sets the picture scaling mode.
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

Picture Class
PerpetuumSoft.Reporting.DOM Namespace


Picture Constructor

[image]

.NET ModelKit Suite ClassReference
Picture Constructor
Picture Class See Also Send Feedback
Creates a new instance of Picture class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Picture()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Picture()

See Also

Picture Class
PerpetuumSoft.Reporting.DOM Namespace


Picture Methods

[image] [image]

.NET ModelKit Suite ClassReference
Picture Methods
Picture Class See Also Send Feedback

The Picture type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Overridden. See CreateBlankControl()()(). (Overrides ReportControl..::.CreateBlankControl()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImagePosition | Returns location of the left-top corner of the image.
GetImageSize | Returns the size of the image after stretch.
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed. (Inherited from Box.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Paints picture element content. (Overrides Box..::.PaintContent(PaintArguments, RectangleF).)
PopulateProperties | Fills the properties of the final rendered control. (Overrides Box..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
RunPropertyDesigner | (Overrides ReportControlRunPropertyDesigner(IReportDesignerService).)
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Picture Class
PerpetuumSoft.Reporting.DOM Namespace


CreateBlankControl Method

[image]

.NET ModelKit Suite ClassReference
Picture..::.CreateBlankControl Method
Picture Class See Also Send Feedback
Overridden. See CreateBlankControl()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override ReportControl CreateBlankControl()
Visual Basic (Declaration)
Protected Overrides Function CreateBlankControl As ReportControl
Visual C++
protected:
virtual ReportControl^ CreateBlankControl() override

See Also

Picture Class
PerpetuumSoft.Reporting.DOM Namespace


GetImagePosition Method

[image]

.NET ModelKit Suite ClassReference
Picture..::.GetImagePosition Method
Picture Class See Also Send Feedback
Returns location of the left-top corner of the image.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Vector GetImagePosition()
Visual Basic (Declaration)
Public Function GetImagePosition As Vector
Visual C++
public:
Vector GetImagePosition()

See Also

Picture Class
PerpetuumSoft.Reporting.DOM Namespace


GetImageSize Method

[image]

.NET ModelKit Suite ClassReference
Picture..::.GetImageSize Method
Picture Class See Also Send Feedback
Returns the size of the image after stretch.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Vector GetImageSize()
Visual Basic (Declaration)
Public Function GetImageSize As Vector
Visual C++
public:
Vector GetImageSize()

See Also

Picture Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
Picture..::.GetScripts Method
Picture Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

Picture Class
Picture Members
PerpetuumSoft.Reporting.DOM Namespace


PaintContent Method

[image]

.NET ModelKit Suite ClassReference
Picture..::.PaintContent Method
Picture Class See Also Send Feedback
Paints picture element content.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PaintContent(
    PaintArguments args,
    RectangleF contentRectangle
)
Visual Basic (Declaration)
Protected Overrides Sub PaintContent ( _
    args As PaintArguments, _
    contentRectangle As RectangleF _
)
Visual C++
protected:
virtual void PaintContent(
    PaintArguments^ args,
    RectangleF contentRectangle
) override

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments
contentRectangle
Type: System.Drawing..::.RectangleF

See Also

Picture Class
PerpetuumSoft.Reporting.DOM Namespace


PopulateProperties Method

[image]

.NET ModelKit Suite ClassReference
Picture..::.PopulateProperties Method
Picture Class See Also Send Feedback
Fills the properties of the final rendered control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PopulateProperties(
    ReportControl production
)
Visual Basic (Declaration)
Protected Overrides Sub PopulateProperties ( _
    production As ReportControl _
)
Visual C++
protected:
virtual void PopulateProperties(
    ReportControl^ production
) override

Parameters

production
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

Picture Class
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
Picture..::.Render Method
Picture Class See Also Send Feedback
Renders the control to the final document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

Picture Class
PerpetuumSoft.Reporting.DOM Namespace


RunPropertyDesigner Method

[image]

.NET ModelKit Suite ClassReference
Picture..::.RunPropertyDesigner Method
Picture Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.Picture.RunPropertyDesigner(PerpetuumSoft.Reporting.Designer.IReportDesignerService)]

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void RunPropertyDesigner(
    IReportDesignerService service
)
Visual Basic (Declaration)
Public Overrides Sub RunPropertyDesigner ( _
    service As IReportDesignerService _
)
Visual C++
public:
virtual void RunPropertyDesigner(
    IReportDesignerService^ service
) override

Parameters

service
Type: PerpetuumSoft.Reporting.Designer..::.IReportDesignerService

See Also

Picture Class
PerpetuumSoft.Reporting.DOM Namespace


Picture Properties

[image] [image]

.NET ModelKit Suite ClassReference
Picture Properties
Picture Class See Also Send Feedback

The Picture type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Image | Gets and sets the image.
ImageAlign | Gets and sets the image alignment.
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SizeMode | Gets and sets the picture scaling mode.
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

Picture Class
PerpetuumSoft.Reporting.DOM Namespace


Image Property

[image]

.NET ModelKit Suite ClassReference
Picture..::.Image Property
Picture Class See Also Send Feedback
Gets and sets the image.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Image Image { get; set; }
Visual Basic (Declaration)
Public Property Image As Image
Visual C++
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}

See Also

Picture Class
PerpetuumSoft.Reporting.DOM Namespace


ImageAlign Property

[image]

.NET ModelKit Suite ClassReference
Picture..::.ImageAlign Property
Picture Class See Also Send Feedback
Gets and sets the image alignment.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ContentAlignment ImageAlign { get; set; }
Visual Basic (Declaration)
Public Property ImageAlign As ContentAlignment
Visual C++
public:
property ContentAlignment ImageAlign {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

Picture Class
PerpetuumSoft.Reporting.DOM Namespace


SizeMode Property

[image]

.NET ModelKit Suite ClassReference
Picture..::.SizeMode Property
Picture Class See Also Send Feedback
Gets and sets the picture scaling mode.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PictureSizeMode SizeMode { get; set; }
Visual Basic (Declaration)
Public Property SizeMode As PictureSizeMode
Visual C++
public:
property PictureSizeMode SizeMode {
    PictureSizeMode get ();
    void set (PictureSizeMode value);
}

See Also

Picture Class
PerpetuumSoft.Reporting.DOM Namespace


Picture Events

[image] [image]

.NET ModelKit Suite ClassReference
Picture Events
Picture Class See Also Send Feedback

The Picture type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

Picture Class
PerpetuumSoft.Reporting.DOM Namespace


PictureSizeMode Enumeration

[image]

.NET ModelKit Suite ClassReference
PictureSizeMode Enumeration
See Also Send Feedback
Specifies drawing modes for a picture.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum PictureSizeMode
Visual Basic (Declaration)
Public Enumeration PictureSizeMode
Visual C++
public enum class PictureSizeMode

Members

Member name | Description
Normal | Draw the picture with its actual size.
Stretch | Stretch the picture to the control's bounds.

See Also

PerpetuumSoft.Reporting.DOM Namespace


ProcessRecordEventArgs Class

[image]

.NET ModelKit Suite ClassReference
ProcessRecordEventArgs Class
Members See Also Send Feedback
Represents data about the processing of the source data records

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ProcessRecordEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ProcessRecordEventArgs _
    Inherits EventArgs
Visual C++
public ref class ProcessRecordEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.DOM..::.ProcessRecordEventArgs

See Also

ProcessRecordEventArgs Members
PerpetuumSoft.Reporting.DOM Namespace


ProcessRecordEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
ProcessRecordEventArgs Members
ProcessRecordEventArgs Class Constructors Methods Properties See Also Send Feedback

The ProcessRecordEventArgs type exposes the following members.

Constructors

Name | Description
ProcessRecordEventArgs | Initializes a new instance of the ProcessRecordEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Groups | Gets data grouping settings
PassBy | Gets or sets value indicating if the data is processed
Sort | Gets DataBandSortCollection representing settings for data sorting
Totals | Gets or sets DataBandTotalCollection representing settings for totals calculation

See Also

ProcessRecordEventArgs Class
PerpetuumSoft.Reporting.DOM Namespace


ProcessRecordEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
ProcessRecordEventArgs Constructor
ProcessRecordEventArgs Class See Also Send Feedback
Initializes a new instance of the ProcessRecordEventArgs class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ProcessRecordEventArgs(
    DataBand band
)
Visual Basic (Declaration)
Public Sub New ( _
    band As DataBand _
)
Visual C++
public:
ProcessRecordEventArgs(
    DataBand^ band
)

Parameters

band
Type: PerpetuumSoft.Reporting.DOM..::.DataBand

See Also

ProcessRecordEventArgs Class
PerpetuumSoft.Reporting.DOM Namespace


ProcessRecordEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
ProcessRecordEventArgs Methods
ProcessRecordEventArgs Class See Also Send Feedback

The ProcessRecordEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessRecordEventArgs Class
PerpetuumSoft.Reporting.DOM Namespace


ProcessRecordEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
ProcessRecordEventArgs Properties
ProcessRecordEventArgs Class See Also Send Feedback

The ProcessRecordEventArgs type exposes the following members.

Properties

Name | Description
Groups | Gets data grouping settings
PassBy | Gets or sets value indicating if the data is processed
Sort | Gets DataBandSortCollection representing settings for data sorting
Totals | Gets or sets DataBandTotalCollection representing settings for totals calculation

See Also

ProcessRecordEventArgs Class
PerpetuumSoft.Reporting.DOM Namespace


Groups Property

[image]

.NET ModelKit Suite ClassReference
ProcessRecordEventArgs..::.Groups Property
ProcessRecordEventArgs Class See Also Send Feedback
Gets data grouping settings

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public List<GroupBand> Groups { get; }
Visual Basic (Declaration)
Public ReadOnly Property Groups As List(Of GroupBand)
Visual C++
public:
property List<GroupBand^>^ Groups {
    List<GroupBand^>^ get ();
}

See Also

ProcessRecordEventArgs Class
PerpetuumSoft.Reporting.DOM Namespace


PassBy Property

[image]

.NET ModelKit Suite ClassReference
ProcessRecordEventArgs..::.PassBy Property
ProcessRecordEventArgs Class See Also Send Feedback
Gets or sets value indicating if the data is processed

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool PassBy { get; set; }
Visual Basic (Declaration)
Public Property PassBy As Boolean
Visual C++
public:
property bool PassBy {
    bool get ();
    void set (bool value);
}

See Also

ProcessRecordEventArgs Class
PerpetuumSoft.Reporting.DOM Namespace


Sort Property

[image]

.NET ModelKit Suite ClassReference
ProcessRecordEventArgs..::.Sort Property
ProcessRecordEventArgs Class See Also Send Feedback
Gets DataBandSortCollection representing settings for data sorting

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataBandSortCollection Sort { get; }
Visual Basic (Declaration)
Public ReadOnly Property Sort As DataBandSortCollection
Visual C++
public:
property DataBandSortCollection^ Sort {
    DataBandSortCollection^ get ();
}

See Also

ProcessRecordEventArgs Class
PerpetuumSoft.Reporting.DOM Namespace


Totals Property

[image]

.NET ModelKit Suite ClassReference
ProcessRecordEventArgs..::.Totals Property
ProcessRecordEventArgs Class See Also Send Feedback
Gets or sets DataBandTotalCollection representing settings for totals calculation

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataBandTotalCollection Totals { get; set; }
Visual Basic (Declaration)
Public Property Totals As DataBandTotalCollection
Visual C++
public:
property DataBandTotalCollection^ Totals {
    DataBandTotalCollection^ get ();
    void set (DataBandTotalCollection^ value);
}

See Also

ProcessRecordEventArgs Class
PerpetuumSoft.Reporting.DOM Namespace


RegularBand Class

[image]

.NET ModelKit Suite ClassReference
RegularBand Class
Members See Also Send Feedback
Base class for standard bands.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class RegularBand : RegularBandBase
Visual Basic (Declaration)
Public Class RegularBand _
    Inherits RegularBandBase
Visual C++
public ref class RegularBand : public RegularBandBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.RegularBandBase
PerpetuumSoft.Reporting.DOM..::.RegularBand
PerpetuumSoft.Reporting.DOM..::.AggregatesRegularBand
PerpetuumSoft.Reporting.DOM..::.BandContainer
PerpetuumSoft.Reporting.DOM..::.SideBySide
PerpetuumSoft.Reporting.DOM..::.SubReportBase

See Also

RegularBand Members
PerpetuumSoft.Reporting.DOM Namespace


RegularBand Members

[image] [image]

.NET ModelKit Suite ClassReference
RegularBand Members
RegularBand Class Constructors Methods Properties Events See Also Send Feedback

The RegularBand type exposes the following members.

Constructors

Name | Description
RegularBand | Creates a new instance of RegularBand class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Inherited from Section.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from RegularBandBase.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the control to the final document. (Inherited from ReportControl.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

RegularBand Class
PerpetuumSoft.Reporting.DOM Namespace


RegularBand Constructor

[image]

.NET ModelKit Suite ClassReference
RegularBand Constructor
RegularBand Class See Also Send Feedback
Creates a new instance of RegularBand class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public RegularBand()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RegularBand()

See Also

RegularBand Class
PerpetuumSoft.Reporting.DOM Namespace


RegularBand Methods

[image] [image]

.NET ModelKit Suite ClassReference
RegularBand Methods
RegularBand Class See Also Send Feedback

The RegularBand type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Inherited from Section.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from RegularBandBase.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the control to the final document. (Inherited from ReportControl.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

See Also

RegularBand Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
RegularBand..::.GetScripts Method
RegularBand Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

RegularBand Class
RegularBand Members
PerpetuumSoft.Reporting.DOM Namespace


RegularBand Properties

[image] [image]

.NET ModelKit Suite ClassReference
RegularBand Properties
RegularBand Class See Also Send Feedback

The RegularBand type exposes the following members.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

RegularBand Class
PerpetuumSoft.Reporting.DOM Namespace


RegularBand Events

[image] [image]

.NET ModelKit Suite ClassReference
RegularBand Events
RegularBand Class See Also Send Feedback

The RegularBand type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

RegularBand Class
PerpetuumSoft.Reporting.DOM Namespace


RegularBandBase Class

[image]

.NET ModelKit Suite ClassReference
RegularBandBase Class
Members See Also Send Feedback
Base class for regular bands.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class RegularBandBase : BandBase,
    IRegularBand
Visual Basic (Declaration)
Public Class RegularBandBase _
    Inherits BandBase _
    Implements IRegularBand
Visual C++
public ref class RegularBandBase : public BandBase,
    IRegularBand

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.RegularBandBase
PerpetuumSoft.Reporting.DOM.Olap..::.PivotTable
PerpetuumSoft.Reporting.DOM..::.RegularBand

See Also

RegularBandBase Members
PerpetuumSoft.Reporting.DOM Namespace


RegularBandBase Members

[image] [image]

.NET ModelKit Suite ClassReference
RegularBandBase Members
RegularBandBase Class Constructors Methods Properties Events See Also Send Feedback

The RegularBandBase type exposes the following members.

Constructors

Name | Description
RegularBandBase | Initializes a new instance of the RegularBandBase class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Inherited from Section.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Overrides Section..::.IsValidChild(ReportControl).)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the control to the final document. (Inherited from ReportControl.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content.
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering.
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content.
NewPageBefore | Gets and sets whether the band should be rendered on a new page.
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

RegularBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


RegularBandBase Constructor

[image]

.NET ModelKit Suite ClassReference
RegularBandBase Constructor
RegularBandBase Class See Also Send Feedback
Initializes a new instance of the RegularBandBase class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public RegularBandBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RegularBandBase()

See Also

RegularBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


RegularBandBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
RegularBandBase Methods
RegularBandBase Class See Also Send Feedback

The RegularBandBase type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Inherited from Section.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Overrides Section..::.IsValidChild(ReportControl).)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Renders the control to the final document. (Inherited from ReportControl.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

See Also

RegularBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
RegularBandBase..::.GetScripts Method
RegularBandBase Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

RegularBandBase Class
RegularBandBase Members
PerpetuumSoft.Reporting.DOM Namespace


IsValidChild Method

[image]

.NET ModelKit Suite ClassReference
RegularBandBase..::.IsValidChild Method
RegularBandBase Class See Also Send Feedback
Implements IsValidChild(ReportControl).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValidChild(
    ReportControl c
)
Visual Basic (Declaration)
Public Overrides Function IsValidChild ( _
    c As ReportControl _
) As Boolean
Visual C++
public:
virtual bool IsValidChild(
    ReportControl^ c
) override

Parameters

c
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

Implements

IContainerControl..::.IsValidChild(ReportControl)

See Also

RegularBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


RegularBandBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
RegularBandBase Properties
RegularBandBase Class See Also Send Feedback

The RegularBandBase type exposes the following members.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content.
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering.
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content.
NewPageBefore | Gets and sets whether the band should be rendered on a new page.
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

RegularBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


NewColumnAfter Property

[image]

.NET ModelKit Suite ClassReference
RegularBandBase..::.NewColumnAfter Property
RegularBandBase Class See Also Send Feedback
Gets or sets value indicating whether a new column should be inserted after the band's content.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool NewColumnAfter { get; set; }
Visual Basic (Declaration)
Public Property NewColumnAfter As Boolean
Visual C++
public:
property bool NewColumnAfter {
    bool get ();
    void set (bool value);
}

See Also

RegularBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


NewColumnBefore Property

[image]

.NET ModelKit Suite ClassReference
RegularBandBase..::.NewColumnBefore Property
RegularBandBase Class See Also Send Feedback
Gets and sets whether a new column should be started for the band's content rendering.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool NewColumnBefore { get; set; }
Visual Basic (Declaration)
Public Property NewColumnBefore As Boolean
Visual C++
public:
property bool NewColumnBefore {
    bool get ();
    void set (bool value);
}

See Also

RegularBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


NewPageAfter Property

[image]

.NET ModelKit Suite ClassReference
RegularBandBase..::.NewPageAfter Property
RegularBandBase Class See Also Send Feedback
Gets or sets value indicating whether a new page should be inserted after the band's content.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool NewPageAfter { get; set; }
Visual Basic (Declaration)
Public Property NewPageAfter As Boolean
Visual C++
public:
property bool NewPageAfter {
    bool get ();
    void set (bool value);
}

See Also

RegularBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


NewPageBefore Property

[image]

.NET ModelKit Suite ClassReference
RegularBandBase..::.NewPageBefore Property
RegularBandBase Class See Also Send Feedback
Gets and sets whether the band should be rendered on a new page.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool NewPageBefore { get; set; }
Visual Basic (Declaration)
Public Property NewPageBefore As Boolean
Visual C++
public:
property bool NewPageBefore {
    bool get ();
    void set (bool value);
}

See Also

RegularBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


RegularBandBase Events

[image] [image]

.NET ModelKit Suite ClassReference
RegularBandBase Events
RegularBandBase Class See Also Send Feedback

The RegularBandBase type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

RegularBandBase Class
PerpetuumSoft.Reporting.DOM Namespace


ReportBindableAttribute Class

[image]

.NET ModelKit Suite ClassReference
ReportBindableAttribute Class
Members See Also Send Feedback
Marks the properties that can be bound to an expression.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ReportBindableAttribute : Attribute
Visual Basic (Declaration)
Public Class ReportBindableAttribute _
    Inherits Attribute
Visual C++
public ref class ReportBindableAttribute : public Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PerpetuumSoft.Reporting.DOM..::.ReportBindableAttribute

See Also

ReportBindableAttribute Members
PerpetuumSoft.Reporting.DOM Namespace


ReportBindableAttribute Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportBindableAttribute Members
ReportBindableAttribute Class Constructors Methods Properties See Also Send Feedback

The ReportBindableAttribute type exposes the following members.

Constructors

Name | Description
ReportBindableAttribute | Overloaded.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | Returns a value indicating whether this instance equals a specified object. (Overrides Attribute..::.Match(Object).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Default | Marks the properties that can be bound to an expression.
IsBindable | Gets whether the property supports binding.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Yes | Gets predefined instance of ReportBindableAttribute.

See Also

ReportBindableAttribute Class
PerpetuumSoft.Reporting.DOM Namespace


ReportBindableAttribute Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ReportBindableAttribute Constructor
ReportBindableAttribute Class See Also Send Feedback

Overload List

Name | Description
ReportBindableAttribute()()() | Initializes a new instance of the ReportBindableAttribute class.
ReportBindableAttribute(Boolean) | Initializes a new instance of the ReportBindableAttribute class with the specified bindability attribute.

See Also

ReportBindableAttribute Class
ReportBindableAttribute Members
PerpetuumSoft.Reporting.DOM Namespace


ReportBindableAttribute Constructor

[image]

.NET ModelKit Suite ClassReference
ReportBindableAttribute Constructor
ReportBindableAttribute Class See Also Send Feedback
Initializes a new instance of the ReportBindableAttribute class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportBindableAttribute()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportBindableAttribute()

See Also

ReportBindableAttribute Class
ReportBindableAttribute Overload
PerpetuumSoft.Reporting.DOM Namespace


ReportBindableAttribute Constructor (Boolean)

[image]

.NET ModelKit Suite ClassReference
ReportBindableAttribute Constructor (Boolean)
ReportBindableAttribute Class See Also Send Feedback
Initializes a new instance of the ReportBindableAttribute class with the specified bindability attribute.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportBindableAttribute(
    bool isBindable
)
Visual Basic (Declaration)
Public Sub New ( _
    isBindable As Boolean _
)
Visual C++
public:
ReportBindableAttribute(
    bool isBindable
)

Parameters

isBindable
Type: System..::.Boolean

See Also

ReportBindableAttribute Class
ReportBindableAttribute Overload
PerpetuumSoft.Reporting.DOM Namespace


ReportBindableAttribute Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportBindableAttribute Methods
ReportBindableAttribute Class See Also Send Feedback

The ReportBindableAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | Returns a value indicating whether this instance equals a specified object. (Overrides Attribute..::.Match(Object).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportBindableAttribute Class
PerpetuumSoft.Reporting.DOM Namespace


Match Method

[image]

.NET ModelKit Suite ClassReference
ReportBindableAttribute..::.Match Method
ReportBindableAttribute Class See Also Send Feedback
Returns a value indicating whether this instance equals a specified object.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool Match(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Match ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Match(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

ReportBindableAttribute Class
PerpetuumSoft.Reporting.DOM Namespace


ReportBindableAttribute Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportBindableAttribute Properties
ReportBindableAttribute Class See Also Send Feedback

The ReportBindableAttribute type exposes the following members.

Properties

Name | Description
Default | Marks the properties that can be bound to an expression.
IsBindable | Gets whether the property supports binding.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Yes | Gets predefined instance of ReportBindableAttribute.

See Also

ReportBindableAttribute Class
PerpetuumSoft.Reporting.DOM Namespace


Default Property

[image]

.NET ModelKit Suite ClassReference
ReportBindableAttribute..::.Default Property
ReportBindableAttribute Class See Also Send Feedback
Marks the properties that can be bound to an expression.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static ReportBindableAttribute Default { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Default As ReportBindableAttribute
Visual C++
public:
static property ReportBindableAttribute^ Default {
    ReportBindableAttribute^ get ();
}

See Also

ReportBindableAttribute Class
PerpetuumSoft.Reporting.DOM Namespace


IsBindable Property

[image]

.NET ModelKit Suite ClassReference
ReportBindableAttribute..::.IsBindable Property
ReportBindableAttribute Class See Also Send Feedback
Gets whether the property supports binding.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool IsBindable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsBindable As Boolean
Visual C++
public:
property bool IsBindable {
    bool get ();
}

See Also

ReportBindableAttribute Class
PerpetuumSoft.Reporting.DOM Namespace


Yes Property

[image]

.NET ModelKit Suite ClassReference
ReportBindableAttribute..::.Yes Property
ReportBindableAttribute Class See Also Send Feedback
Gets predefined instance of ReportBindableAttribute.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static ReportBindableAttribute Yes { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Yes As ReportBindableAttribute
Visual C++
public:
static property ReportBindableAttribute^ Yes {
    ReportBindableAttribute^ get ();
}

See Also

ReportBindableAttribute Class
PerpetuumSoft.Reporting.DOM Namespace


ReportComponent Class

[image]

.NET ModelKit Suite ClassReference
ReportComponent Class
Members See Also Send Feedback
Base class for all components in the Report Sharp-Shooter library.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ReportComponent
Visual Basic (Declaration)
Public Class ReportComponent
Visual C++
public ref class ReportComponent

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.Document
PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ReportComponent Members
PerpetuumSoft.Reporting.DOM Namespace


ReportComponent Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportComponent Members
ReportComponent Class Constructors Methods Properties See Also Send Feedback

The ReportComponent type exposes the following members.

Constructors

Name | Description
ReportComponent | Creates a new instance of ReportComponent class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name | Gets and sets the name of the component.

See Also

ReportComponent Class
PerpetuumSoft.Reporting.DOM Namespace


ReportComponent Constructor

[image]

.NET ModelKit Suite ClassReference
ReportComponent Constructor
ReportComponent Class See Also Send Feedback
Creates a new instance of ReportComponent class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportComponent()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportComponent()

See Also

ReportComponent Class
PerpetuumSoft.Reporting.DOM Namespace


ReportComponent Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportComponent Methods
ReportComponent Class See Also Send Feedback

The ReportComponent type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportComponent Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportComponent..::.GetScripts Method
ReportComponent Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component.
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the component.

See Also

ReportComponent Class
ReportComponent Members
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image]

.NET ModelKit Suite ClassReference
ReportComponent..::.GetScripts Method
ReportComponent Class See Also Send Feedback
Returns the collection of all scripts assigned to the component.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ScriptInfoCollection GetScripts()
Visual Basic (Declaration)
Public Function GetScripts As ScriptInfoCollection
Visual C++
public:
ScriptInfoCollection^ GetScripts()

See Also

ReportComponent Class
GetScripts Overload
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method (ScriptInfoCollection)

[image]

.NET ModelKit Suite ClassReference
ReportComponent..::.GetScripts Method (ScriptInfoCollection)
ReportComponent Class See Also Send Feedback
Fills the specified collection with all scripts assigned to the component.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual void GetScripts(
    ScriptInfoCollection scripts
)
Visual Basic (Declaration)
Public Overridable Sub GetScripts ( _
    scripts As ScriptInfoCollection _
)
Visual C++
public:
virtual void GetScripts(
    ScriptInfoCollection^ scripts
)

Parameters

scripts
Type: PerpetuumSoft.Reporting.Rendering..::.ScriptInfoCollection

See Also

ReportComponent Class
GetScripts Overload
PerpetuumSoft.Reporting.DOM Namespace


ReportComponent Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportComponent Properties
ReportComponent Class See Also Send Feedback

The ReportComponent type exposes the following members.

Properties

Name | Description
Name | Gets and sets the name of the component.

See Also

ReportComponent Class
PerpetuumSoft.Reporting.DOM Namespace


Name Property

[image]

.NET ModelKit Suite ClassReference
ReportComponent..::.Name Property
ReportComponent Class See Also Send Feedback
Gets and sets the name of the component.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ReportComponent Class
PerpetuumSoft.Reporting.DOM Namespace


ReportControl Class

[image]

.NET ModelKit Suite ClassReference
ReportControl Class
Members See Also Send Feedback
Base class for all controls in the Report Sharp-Shooter library.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ReportControl : ReportComponent
Visual Basic (Declaration)
Public Class ReportControl _
    Inherits ReportComponent
Visual C++
public ref class ReportControl : public ReportComponent

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.VisualControl

See Also

ReportControl Members
PerpetuumSoft.Reporting.DOM Namespace


ReportControl Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportControl Members
ReportControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The ReportControl type exposes the following members.

Constructors

Name | Description
ReportControl | Creates a new instance of ReportControl class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container.
CalculateRenderHeight | Calculates the height of the control in the rendered report.
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF.
ControlByName | Finds a nested ReportControl object with the specified name.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent.
FindText | Returns whether the control contains the specified text.
GetDesignerToolTip | Returns string that will be shown in a control tooltip.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control.
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer.
IsValidParent | Returns whether the control can be placed into the specified container.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer.
MoveForward | Moves the control forward in Z-Buffer.
OnGenerate | Raises Generate event.
OnPaint | Performs control drawing.
OnSizeChanged | Is called after the Size property is changed.
OnStyleNameChanged | Executes if style name was changed.
Paint | Invokes OnPaint method.
PopulateProperties | Fills the properties of the final rendered control.
Prepare | Prepares the control for rendering.
PutToBack | Puts the control to the back of all controls in container.
RaiseGenerate | Invokes OnGenerate method.
ReCalculateBounds | Recalculates control bounds.
Register | Registers the controls library.
RegisterControlType | Adds the specified control type to the registered controls list.
Render | Renders the control to the final document.
RenderLocation | Calculates location of the control in the rendered report.
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ControlTypes | Collection of all registered control types.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control.
Bounds | Gets and sets the control's bounds within the parent control.
DataBindings | Gets the collection of the control's properties data/expressions bindings.
Document | Gets the document.
Engine | Gets the RenderEngine used.
GenerateScript | Gets and sets the code for the script that will be invoked before rendering.
Hyperlink | Gets and sets a hyperlink for the control.
Location | Gets and sets the control's top-left corner position within the parent control.
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page.
PageBounds | Gets and sets the control's bounds within the page.
PageLocation | Gets and sets the control's top-left corner position within the page.
Parent | Gets and sets the parent control.
RenderHeight | Gets and sets the height of the final control.
Size | Gets and sets the size of the control.
StyleName | Gets and sets the name of the style applied to the control.
Tag | Gets and sets an additional information for the control.
ToolTip | Gets and sets a tooltip for the control.
Visible | Gets and sets whether the control should be rendered to the final document.

Events

Name | Description
Generate | Occurs before the control is rendered.

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


ReportControl Constructor

[image]

.NET ModelKit Suite ClassReference
ReportControl Constructor
ReportControl Class See Also Send Feedback
Creates a new instance of ReportControl class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportControl()

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


ReportControl Fields

[image] [image]

.NET ModelKit Suite ClassReference
ReportControl Fields
ReportControl Class See Also Send Feedback

The ReportControl type exposes the following members.

Fields

Name | Description
ControlTypes | Collection of all registered control types.

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


ControlTypes Field

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.ControlTypes Field
ReportControl Class See Also Send Feedback
Collection of all registered control types.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static readonly ArrayList ControlTypes
Visual Basic (Declaration)
Public Shared ReadOnly ControlTypes As ArrayList
Visual C++
public:
static initonly ArrayList^ ControlTypes

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


ReportControl Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportControl Methods
ReportControl Class See Also Send Feedback

The ReportControl type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container.
CalculateRenderHeight | Calculates the height of the control in the rendered report.
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF.
ControlByName | Finds a nested ReportControl object with the specified name.
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent.
FindText | Returns whether the control contains the specified text.
GetDesignerToolTip | Returns string that will be shown in a control tooltip.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control.
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer.
IsValidParent | Returns whether the control can be placed into the specified container.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer.
MoveForward | Moves the control forward in Z-Buffer.
OnGenerate | Raises Generate event.
OnPaint | Performs control drawing.
OnSizeChanged | Is called after the Size property is changed.
OnStyleNameChanged | Executes if style name was changed.
Paint | Invokes OnPaint method.
PopulateProperties | Fills the properties of the final rendered control.
Prepare | Prepares the control for rendering.
PutToBack | Puts the control to the back of all controls in container.
RaiseGenerate | Invokes OnGenerate method.
ReCalculateBounds | Recalculates control bounds.
Register | Registers the controls library.
RegisterControlType | Adds the specified control type to the registered controls list.
Render | Renders the control to the final document.
RenderLocation | Calculates location of the control in the rendered report.
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


BringToFront Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.BringToFront Method
ReportControl Class See Also Send Feedback
Brings the control to the front of all controls in container.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void BringToFront()
Visual Basic (Declaration)
Public Sub BringToFront
Visual C++
public:
void BringToFront()

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateRenderHeight Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.CalculateRenderHeight Method
ReportControl Class See Also Send Feedback
Calculates the height of the control in the rendered report.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void CalculateRenderHeight()
Visual Basic (Declaration)
Protected Overridable Sub CalculateRenderHeight
Visual C++
protected:
virtual void CalculateRenderHeight()

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


ControlAt Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.ControlAt Method
ReportControl Class See Also Send Feedback
Returns a ReportControl object that is found in the location specified by the given PointF.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual ReportControl ControlAt(
    PointF point
)
Visual Basic (Declaration)
Public Overridable Function ControlAt ( _
    point As PointF _
) As ReportControl
Visual C++
public:
virtual ReportControl^ ControlAt(
    PointF point
)

Parameters

point
Type: System.Drawing..::.PointF

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


ControlByName Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.ControlByName Method
ReportControl Class See Also Send Feedback
Finds a nested ReportControl object with the specified name.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual ReportControl ControlByName(
    string controlName
)
Visual Basic (Declaration)
Public Overridable Function ControlByName ( _
    controlName As String _
) As ReportControl
Visual C++
public:
virtual ReportControl^ ControlByName(
    String^ controlName
)

Parameters

controlName
Type: System..::.String

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


CreateBlankControl Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.CreateBlankControl Method
ReportControl Class See Also Send Feedback
Creates a control for locating in the final document. It is used when element rendering.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual ReportControl CreateBlankControl()
Visual Basic (Declaration)
Protected Overridable Function CreateBlankControl As ReportControl
Visual C++
protected:
virtual ReportControl^ CreateBlankControl()

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


FindParent Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.FindParent Method
ReportControl Class See Also Send Feedback
Finds the control's parent.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual IContainerControl FindParent(
    ReportControl c
)
Visual Basic (Declaration)
Public Overridable Function FindParent ( _
    c As ReportControl _
) As IContainerControl
Visual C++
public:
virtual IContainerControl^ FindParent(
    ReportControl^ c
)

Parameters

c
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


FindText Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.FindText Method
ReportControl Class See Also Send Feedback
Returns whether the control contains the specified text.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual bool FindText(
    string pattern,
    FindTextOptions options
)
Visual Basic (Declaration)
Public Overridable Function FindText ( _
    pattern As String, _
    options As FindTextOptions _
) As Boolean
Visual C++
public:
virtual bool FindText(
    String^ pattern,
    FindTextOptions^ options
)

Parameters

pattern
Type: System..::.String
options
Type: PerpetuumSoft.Reporting.DOM..::.FindTextOptions

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


GetDesignerToolTip Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.GetDesignerToolTip Method
ReportControl Class See Also Send Feedback
Returns string that will be shown in a control tooltip.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual string GetDesignerToolTip()
Visual Basic (Declaration)
Public Overridable Function GetDesignerToolTip As String
Visual C++
public:
virtual String^ GetDesignerToolTip()

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportControl..::.GetScripts Method
ReportControl Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Overrides ReportComponent..::.GetScripts(ScriptInfoCollection).)

See Also

ReportControl Class
ReportControl Members
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method (ScriptInfoCollection)

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.GetScripts Method (ScriptInfoCollection)
ReportControl Class See Also Send Feedback
Fills the specified collection with all scripts assigned to the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void GetScripts(
    ScriptInfoCollection scripts
)
Visual Basic (Declaration)
Public Overrides Sub GetScripts ( _
    scripts As ScriptInfoCollection _
)
Visual C++
public:
virtual void GetScripts(
    ScriptInfoCollection^ scripts
) override

Parameters

scripts
Type: PerpetuumSoft.Reporting.Rendering..::.ScriptInfoCollection

See Also

ReportControl Class
GetScripts Overload
PerpetuumSoft.Reporting.DOM Namespace


GetStyle Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.GetStyle Method
ReportControl Class See Also Send Feedback
Returns a style object for the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected Style GetStyle()
Visual Basic (Declaration)
Protected Function GetStyle As Style
Visual C++
protected:
Style^ GetStyle()

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


InitNew Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.InitNew Method
ReportControl Class See Also Send Feedback
Sets the predefined values for the properties of the control created with visual tools such as Report Designer.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual void InitNew()
Visual Basic (Declaration)
Public Overridable Sub InitNew
Visual C++
public:
virtual void InitNew()

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


IsValidParent Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.IsValidParent Method
ReportControl Class See Also Send Feedback
Returns whether the control can be placed into the specified container.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual bool IsValidParent(
    ReportControl c
)
Visual Basic (Declaration)
Public Overridable Function IsValidParent ( _
    c As ReportControl _
) As Boolean
Visual C++
public:
virtual bool IsValidParent(
    ReportControl^ c
)

Parameters

c
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


MoveBackward Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.MoveBackward Method
ReportControl Class See Also Send Feedback
Moves the control backward in Z-Buffer.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void MoveBackward()
Visual Basic (Declaration)
Public Sub MoveBackward
Visual C++
public:
void MoveBackward()

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


MoveForward Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.MoveForward Method
ReportControl Class See Also Send Feedback
Moves the control forward in Z-Buffer.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void MoveForward()
Visual Basic (Declaration)
Public Sub MoveForward
Visual C++
public:
void MoveForward()

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


OnGenerate Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.OnGenerate Method
ReportControl Class See Also Send Feedback
Raises Generate event.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnGenerate(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnGenerate ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnGenerate(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


OnPaint Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.OnPaint Method
ReportControl Class See Also Send Feedback
Performs control drawing.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Protected Overridable Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
protected:
virtual void OnPaint(
    PaintArguments^ args
)

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


OnSizeChanged Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.OnSizeChanged Method
ReportControl Class See Also Send Feedback
Is called after the Size property is changed.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnSizeChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnSizeChanged
Visual C++
protected:
virtual void OnSizeChanged()

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


OnStyleNameChanged Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.OnStyleNameChanged Method
ReportControl Class See Also Send Feedback
Executes if style name was changed.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnStyleNameChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnStyleNameChanged
Visual C++
protected:
virtual void OnStyleNameChanged()

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


Paint Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.Paint Method
ReportControl Class See Also Send Feedback
Invokes OnPaint method.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Paint(
    PaintArguments args
)
Visual Basic (Declaration)
Public Sub Paint ( _
    args As PaintArguments _
)
Visual C++
public:
void Paint(
    PaintArguments^ args
)

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


PopulateProperties Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.PopulateProperties Method
ReportControl Class See Also Send Feedback
Fills the properties of the final rendered control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void PopulateProperties(
    ReportControl production
)
Visual Basic (Declaration)
Protected Overridable Sub PopulateProperties ( _
    production As ReportControl _
)
Visual C++
protected:
virtual void PopulateProperties(
    ReportControl^ production
)

Parameters

production
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


Prepare Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.Prepare Method
ReportControl Class See Also Send Feedback
Prepares the control for rendering.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual void Prepare()
Visual Basic (Declaration)
Public Overridable Sub Prepare
Visual C++
public:
virtual void Prepare()

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


PutToBack Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.PutToBack Method
ReportControl Class See Also Send Feedback
Puts the control to the back of all controls in container.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void PutToBack()
Visual Basic (Declaration)
Public Sub PutToBack
Visual C++
public:
void PutToBack()

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


RaiseGenerate Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.RaiseGenerate Method
ReportControl Class See Also Send Feedback
Invokes OnGenerate method.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected void RaiseGenerate()
Visual Basic (Declaration)
Protected Sub RaiseGenerate
Visual C++
protected:
void RaiseGenerate()

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


ReCalculateBounds Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.ReCalculateBounds Method
ReportControl Class See Also Send Feedback
Recalculates control bounds.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual VectorRectangle ReCalculateBounds(
    VectorRectangle currentBounds
)
Visual Basic (Declaration)
Protected Overridable Function ReCalculateBounds ( _
    currentBounds As VectorRectangle _
) As VectorRectangle
Visual C++
protected:
virtual VectorRectangle ReCalculateBounds(
    VectorRectangle currentBounds
)

Parameters

currentBounds
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


Register Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.Register Method
ReportControl Class See Also Send Feedback
Registers the controls library.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static void Register()
Visual Basic (Declaration)
Public Shared Sub Register
Visual C++
public:
static void Register()

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


RegisterControlType Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.RegisterControlType Method
ReportControl Class See Also Send Feedback
Adds the specified control type to the registered controls list.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static void RegisterControlType(
    Type ControlType
)
Visual Basic (Declaration)
Public Shared Sub RegisterControlType ( _
    ControlType As Type _
)
Visual C++
public:
static void RegisterControlType(
    Type^ ControlType
)

Parameters

ControlType
Type: System..::.Type

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.Render Method
ReportControl Class See Also Send Feedback
Renders the control to the final document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual void Render()
Visual Basic (Declaration)
Public Overridable Sub Render
Visual C++
public:
virtual void Render()

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


RenderLocation Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.RenderLocation Method
ReportControl Class See Also Send Feedback
Calculates location of the control in the rendered report.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void RenderLocation(
    ReportControl production
)
Visual Basic (Declaration)
Protected Overridable Sub RenderLocation ( _
    production As ReportControl _
)
Visual C++
protected:
virtual void RenderLocation(
    ReportControl^ production
)

Parameters

production
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


RunPropertyBindingDesigner Method

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.RunPropertyBindingDesigner Method
ReportControl Class See Also Send Feedback
Runs designer for the property binding defined by the bindingName parameter.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual void RunPropertyBindingDesigner(
    IReportDesignerService service,
    string bindingName
)
Visual Basic (Declaration)
Public Overridable Sub RunPropertyBindingDesigner ( _
    service As IReportDesignerService, _
    bindingName As String _
)
Visual C++
public:
virtual void RunPropertyBindingDesigner(
    IReportDesignerService^ service,
    String^ bindingName
)

Parameters

service
Type: PerpetuumSoft.Reporting.Designer..::.IReportDesignerService
bindingName
Type: System..::.String

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


ReportControl Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportControl Properties
ReportControl Class See Also Send Feedback

The ReportControl type exposes the following members.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control.
Bounds | Gets and sets the control's bounds within the parent control.
DataBindings | Gets the collection of the control's properties data/expressions bindings.
Document | Gets the document.
Engine | Gets the RenderEngine used.
GenerateScript | Gets and sets the code for the script that will be invoked before rendering.
Hyperlink | Gets and sets a hyperlink for the control.
Location | Gets and sets the control's top-left corner position within the parent control.
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page.
PageBounds | Gets and sets the control's bounds within the page.
PageLocation | Gets and sets the control's top-left corner position within the page.
Parent | Gets and sets the parent control.
RenderHeight | Gets and sets the height of the final control.
Size | Gets and sets the size of the control.
StyleName | Gets and sets the name of the style applied to the control.
Tag | Gets and sets an additional information for the control.
ToolTip | Gets and sets a tooltip for the control.
Visible | Gets and sets whether the control should be rendered to the final document.

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


Bookmark Property

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.Bookmark Property
ReportControl Class See Also Send Feedback
Gets and sets a bookmark for the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Bookmark { get; set; }
Visual Basic (Declaration)
Public Property Bookmark As String
Visual C++
public:
property String^ Bookmark {
    String^ get ();
    void set (String^ value);
}

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


Bounds Property

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.Bounds Property
ReportControl Class See Also Send Feedback
Gets and sets the control's bounds within the parent control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual VectorRectangle Bounds { get; set; }
Visual Basic (Declaration)
Public Overridable Property Bounds As VectorRectangle
Visual C++
public:
virtual property VectorRectangle Bounds {
    VectorRectangle get ();
    void set (VectorRectangle value);
}

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


DataBindings Property

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.DataBindings Property
ReportControl Class See Also Send Feedback
Gets the collection of the control's properties data/expressions bindings.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportDataBindingCollection DataBindings { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataBindings As ReportDataBindingCollection
Visual C++
public:
property ReportDataBindingCollection^ DataBindings {
    ReportDataBindingCollection^ get ();
}

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


Document Property

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.Document Property
ReportControl Class See Also Send Feedback
Gets the document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Document Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


Engine Property

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.Engine Property
ReportControl Class See Also Send Feedback
Gets the RenderEngine used.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public RenderEngine Engine { get; }
Visual Basic (Declaration)
Public ReadOnly Property Engine As RenderEngine
Visual C++
public:
property RenderEngine^ Engine {
    RenderEngine^ get ();
}

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


GenerateScript Property

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.GenerateScript Property
ReportControl Class See Also Send Feedback
Gets and sets the code for the script that will be invoked before rendering.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string GenerateScript { get; set; }
Visual Basic (Declaration)
Public Property GenerateScript As String
Visual C++
public:
property String^ GenerateScript {
    String^ get ();
    void set (String^ value);
}

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


Hyperlink Property

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.Hyperlink Property
ReportControl Class See Also Send Feedback
Gets and sets a hyperlink for the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Hyperlink { get; set; }
Visual Basic (Declaration)
Public Property Hyperlink As String
Visual C++
public:
property String^ Hyperlink {
    String^ get ();
    void set (String^ value);
}

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


Location Property

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.Location Property
ReportControl Class See Also Send Feedback
Gets and sets the control's top-left corner position within the parent control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Vector Location { get; set; }
Visual Basic (Declaration)
Public Property Location As Vector
Visual C++
public:
property Vector Location {
    Vector get ();
    void set (Vector value);
}

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


Page Property

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.Page Property
ReportControl Class See Also Send Feedback
Gets the page.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Page Page { get; }
Visual Basic (Declaration)
Public ReadOnly Property Page As Page
Visual C++
public:
property Page^ Page {
    Page^ get ();
}

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


PageBounds Property

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.PageBounds Property
ReportControl Class See Also Send Feedback
Gets and sets the control's bounds within the page.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle PageBounds { get; set; }
Visual Basic (Declaration)
Public Property PageBounds As VectorRectangle
Visual C++
public:
property VectorRectangle PageBounds {
    VectorRectangle get ();
    void set (VectorRectangle value);
}

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


PageLocation Property

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.PageLocation Property
ReportControl Class See Also Send Feedback
Gets and sets the control's top-left corner position within the page.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Vector PageLocation { get; set; }
Visual Basic (Declaration)
Public Property PageLocation As Vector
Visual C++
public:
property Vector PageLocation {
    Vector get ();
    void set (Vector value);
}

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


Parent Property

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.Parent Property
ReportControl Class See Also Send Feedback
Gets and sets the parent control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportComponent Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As ReportComponent
Visual C++
public:
property ReportComponent^ Parent {
    ReportComponent^ get ();
    void set (ReportComponent^ value);
}

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


RenderHeight Property

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.RenderHeight Property
ReportControl Class See Also Send Feedback
Gets and sets the height of the final control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double RenderHeight { get; set; }
Visual Basic (Declaration)
Public Property RenderHeight As Double
Visual C++
public:
property double RenderHeight {
    double get ();
    void set (double value);
}

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


Size Property

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.Size Property
ReportControl Class See Also Send Feedback
Gets and sets the size of the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Vector Size { get; set; }
Visual Basic (Declaration)
Public Property Size As Vector
Visual C++
public:
property Vector Size {
    Vector get ();
    void set (Vector value);
}

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


StyleName Property

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.StyleName Property
ReportControl Class See Also Send Feedback
Gets and sets the name of the style applied to the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string StyleName { get; set; }
Visual Basic (Declaration)
Public Property StyleName As String
Visual C++
public:
property String^ StyleName {
    String^ get ();
    void set (String^ value);
}

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


Tag Property

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.Tag Property
ReportControl Class See Also Send Feedback
Gets and sets an additional information for the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Tag { get; set; }
Visual Basic (Declaration)
Public Property Tag As String
Visual C++
public:
property String^ Tag {
    String^ get ();
    void set (String^ value);
}

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


ToolTip Property

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.ToolTip Property
ReportControl Class See Also Send Feedback
Gets and sets a tooltip for the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string ToolTip { get; set; }
Visual Basic (Declaration)
Public Property ToolTip As String
Visual C++
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


Visible Property

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.Visible Property
ReportControl Class See Also Send Feedback
Gets and sets whether the control should be rendered to the final document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


ReportControl Events

[image] [image]

.NET ModelKit Suite ClassReference
ReportControl Events
ReportControl Class See Also Send Feedback

The ReportControl type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered.

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


Generate Event

[image]

.NET ModelKit Suite ClassReference
ReportControl..::.Generate Event
ReportControl Class See Also Send Feedback
Occurs before the control is rendered.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler Generate
Visual Basic (Declaration)
Public Event Generate As EventHandler
Visual C++
public:
 event EventHandler^ Generate {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ReportControl Class
PerpetuumSoft.Reporting.DOM Namespace


ReportControlCollection Class

[image]

.NET ModelKit Suite ClassReference
ReportControlCollection Class
Members See Also Send Feedback
Defines a collection of controls in the report.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
[SerializableAttribute]
public class ReportControlCollection : CollectionBase
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ReportControlCollection _
    Inherits CollectionBase
Visual C++
[SerializableAttribute]
public ref class ReportControlCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Reporting.DOM..::.ReportControlCollection

See Also

ReportControlCollection Members
PerpetuumSoft.Reporting.DOM Namespace


ReportControlCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlCollection Members
ReportControlCollection Class Constructors Methods Properties See Also Send Feedback

The ReportControlCollection type exposes the following members.

Constructors

Name | Description
ReportControlCollection | Initializes a new instance of the ReportControlCollection class.

Methods

Name | Description
Add | Adds the specified control to the collection.
AddRange | Adds the specified array of controls to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the specified control exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified control's index in the collection.
Insert | Inserts the specified control to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Raises the Insert event. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Raises the Remove event. (Overrides CollectionBase..::.OnRemove(Int32, Object).)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified control from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets a control from the collection at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ReportControlCollection Class
PerpetuumSoft.Reporting.DOM Namespace


ReportControlCollection Constructor

[image]

.NET ModelKit Suite ClassReference
ReportControlCollection Constructor
ReportControlCollection Class See Also Send Feedback
Initializes a new instance of the ReportControlCollection class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportControlCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportControlCollection()

See Also

ReportControlCollection Class
PerpetuumSoft.Reporting.DOM Namespace


ReportControlCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlCollection Methods
ReportControlCollection Class See Also Send Feedback

The ReportControlCollection type exposes the following members.

Methods

Name | Description
Add | Adds the specified control to the collection.
AddRange | Adds the specified array of controls to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the specified control exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified control's index in the collection.
Insert | Inserts the specified control to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Raises the Insert event. (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Raises the Remove event. (Overrides CollectionBase..::.OnRemove(Int32, Object).)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified control from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportControlCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
ReportControlCollection..::.Add Method
ReportControlCollection Class See Also Send Feedback
Adds the specified control to the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportControl Add(
    ReportControl value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As ReportControl _
) As ReportControl
Visual C++
public:
ReportControl^ Add(
    ReportControl^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ReportControlCollection Class
PerpetuumSoft.Reporting.DOM Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
ReportControlCollection..::.AddRange Method
ReportControlCollection Class See Also Send Feedback
Adds the specified array of controls to the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    ReportControl[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As ReportControl() _
)
Visual C++
public:
void AddRange(
    array<ReportControl^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Reporting.DOM..::.ReportControl >[]()[]

See Also

ReportControlCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
ReportControlCollection..::.Contains Method
ReportControlCollection Class See Also Send Feedback
Returns whether the specified control exists in the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    ReportControl value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As ReportControl _
) As Boolean
Visual C++
public:
bool Contains(
    ReportControl^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ReportControlCollection Class
PerpetuumSoft.Reporting.DOM Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
ReportControlCollection..::.IndexOf Method
ReportControlCollection Class See Also Send Feedback
Returns the specified control's index in the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    ReportControl value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As ReportControl _
) As Integer
Visual C++
public:
int IndexOf(
    ReportControl^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ReportControlCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
ReportControlCollection..::.Insert Method
ReportControlCollection Class See Also Send Feedback
Inserts the specified control to the collection at the specified index.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    ReportControl value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As ReportControl _
)
Visual C++
public:
void Insert(
    int index,
    ReportControl^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ReportControlCollection Class
PerpetuumSoft.Reporting.DOM Namespace


OnInsert Method

[image]

.NET ModelKit Suite ClassReference
ReportControlCollection..::.OnInsert Method
ReportControlCollection Class See Also Send Feedback
Raises the Insert event.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInsert(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsert ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnInsert(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ReportControlCollection Class
PerpetuumSoft.Reporting.DOM Namespace


OnRemove Method

[image]

.NET ModelKit Suite ClassReference
ReportControlCollection..::.OnRemove Method
ReportControlCollection Class See Also Send Feedback
Raises the Remove event.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnRemove(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemove ( _
    index As Integer, _
    value As Object _
)
Visual C++
protected:
virtual void OnRemove(
    int index,
    Object^ value
) override

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ReportControlCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
ReportControlCollection..::.Remove Method
ReportControlCollection Class See Also Send Feedback
Removes the specified control from the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    ReportControl value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As ReportControl _
)
Visual C++
public:
void Remove(
    ReportControl^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ReportControlCollection Class
PerpetuumSoft.Reporting.DOM Namespace


ReportControlCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlCollection Properties
ReportControlCollection Class See Also Send Feedback

The ReportControlCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets a control from the collection at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ReportControlCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
ReportControlCollection..::.Item Property
ReportControlCollection Class See Also Send Feedback
Gets a control from the collection at the specified index.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportControl this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As ReportControl
Visual C++
public:
property ReportControl^ default[int index] {
    ReportControl^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

ReportControlCollection Class
PerpetuumSoft.Reporting.DOM Namespace


ReportControlException Class

[image]

.NET ModelKit Suite ClassReference
ReportControlException Class
Members See Also Send Feedback
The exception that is thrown in ReportControl method.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
[SerializableAttribute]
public class ReportControlException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ReportControlException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class ReportControlException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
PerpetuumSoft.Reporting.DOM..::.ReportControlException

See Also

ReportControlException Members
PerpetuumSoft.Reporting.DOM Namespace


ReportControlException Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlException Members
ReportControlException Class Constructors Methods Properties See Also Send Feedback

The ReportControlException type exposes the following members.

Constructors

Name | Description
ReportControlException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Control | Gets associated ReportControl object.
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ReportControlException Class
PerpetuumSoft.Reporting.DOM Namespace


ReportControlException Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlException Constructor
ReportControlException Class See Also Send Feedback

Overload List

Name | Description
ReportControlException()()() | Initializes a new instance of the ReportControlException class.
ReportControlException(ReportControl, String) | Initializes a new instance of the ReportControlException class.
ReportControlException(ReportControl, String, Exception) | Creates new instance of ReportControlException.

See Also

ReportControlException Class
ReportControlException Members
PerpetuumSoft.Reporting.DOM Namespace


ReportControlException Constructor

[image]

.NET ModelKit Suite ClassReference
ReportControlException Constructor
ReportControlException Class See Also Send Feedback
Initializes a new instance of the ReportControlException class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportControlException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportControlException()

See Also

ReportControlException Class
ReportControlException Overload
PerpetuumSoft.Reporting.DOM Namespace


ReportControlException Constructor (ReportControl, String)

[image]

.NET ModelKit Suite ClassReference
ReportControlException Constructor (ReportControl, String)
ReportControlException Class See Also Send Feedback
Initializes a new instance of the ReportControlException class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportControlException(
    ReportControl control,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    control As ReportControl, _
    message As String _
)
Visual C++
public:
ReportControlException(
    ReportControl^ control,
    String^ message
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
message
Type: System..::.String

See Also

ReportControlException Class
ReportControlException Overload
PerpetuumSoft.Reporting.DOM Namespace


ReportControlException Constructor (ReportControl, String, Exception)

[image]

.NET ModelKit Suite ClassReference
ReportControlException Constructor (ReportControl, String, Exception)
ReportControlException Class See Also Send Feedback
Creates new instance of ReportControlException.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportControlException(
    ReportControl control,
    string message,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    control As ReportControl, _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
ReportControlException(
    ReportControl^ control,
    String^ message,
    Exception^ innerException
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
message
Type: System..::.String
innerException
Type: System..::.Exception

See Also

ReportControlException Class
ReportControlException Overload
PerpetuumSoft.Reporting.DOM Namespace


ReportControlException Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlException Methods
ReportControlException Class See Also Send Feedback

The ReportControlException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ReportControlException Class
PerpetuumSoft.Reporting.DOM Namespace


ReportControlException Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlException Properties
ReportControlException Class See Also Send Feedback

The ReportControlException type exposes the following members.

Properties

Name | Description
Control | Gets associated ReportControl object.
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ReportControlException Class
PerpetuumSoft.Reporting.DOM Namespace


Control Property

[image]

.NET ModelKit Suite ClassReference
ReportControlException..::.Control Property
ReportControlException Class See Also Send Feedback
Gets associated ReportControl object.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportControl Control { get; }
Visual Basic (Declaration)
Public ReadOnly Property Control As ReportControl
Visual C++
public:
property ReportControl^ Control {
    ReportControl^ get ();
}

See Also

ReportControlException Class
PerpetuumSoft.Reporting.DOM Namespace


ReportDataBinding Class

[image]

.NET ModelKit Suite ClassReference
ReportDataBinding Class
Members See Also Send Feedback
Provides binding a component's property to a data/expression.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ReportDataBinding
Visual Basic (Declaration)
Public Class ReportDataBinding
Visual C++
public ref class ReportDataBinding

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportDataBinding

See Also

ReportDataBinding Members
PerpetuumSoft.Reporting.DOM Namespace


ReportDataBinding Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportDataBinding Members
ReportDataBinding Class Constructors Methods Properties See Also Send Feedback

The ReportDataBinding type exposes the following members.

Constructors

Name | Description
ReportDataBinding | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Expression | Gets and sets the string containing the expression to bind the property to.
PropertyName | Gets and sets the name of the property to bind to the data.

See Also

ReportDataBinding Class
PerpetuumSoft.Reporting.DOM Namespace


ReportDataBinding Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ReportDataBinding Constructor
ReportDataBinding Class See Also Send Feedback

Overload List

Name | Description
ReportDataBinding()()() | Creates new instance of the ReportDataBinding.
ReportDataBinding(String, String) | Creates new instance of the ReportDataBinding.

See Also

ReportDataBinding Class
ReportDataBinding Members
PerpetuumSoft.Reporting.DOM Namespace


ReportDataBinding Constructor

[image]

.NET ModelKit Suite ClassReference
ReportDataBinding Constructor
ReportDataBinding Class See Also Send Feedback
Creates new instance of the ReportDataBinding.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportDataBinding()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportDataBinding()

See Also

ReportDataBinding Class
ReportDataBinding Overload
PerpetuumSoft.Reporting.DOM Namespace


ReportDataBinding Constructor (String, String)

[image]

.NET ModelKit Suite ClassReference
ReportDataBinding Constructor (String, String)
ReportDataBinding Class See Also Send Feedback
Creates new instance of the ReportDataBinding.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportDataBinding(
    string propertyName,
    string expression
)
Visual Basic (Declaration)
Public Sub New ( _
    propertyName As String, _
    expression As String _
)
Visual C++
public:
ReportDataBinding(
    String^ propertyName,
    String^ expression
)

Parameters

propertyName
Type: System..::.String
expression
Type: System..::.String

See Also

ReportDataBinding Class
ReportDataBinding Overload
PerpetuumSoft.Reporting.DOM Namespace


ReportDataBinding Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportDataBinding Methods
ReportDataBinding Class See Also Send Feedback

The ReportDataBinding type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportDataBinding Class
PerpetuumSoft.Reporting.DOM Namespace


ReportDataBinding Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportDataBinding Properties
ReportDataBinding Class See Also Send Feedback

The ReportDataBinding type exposes the following members.

Properties

Name | Description
Expression | Gets and sets the string containing the expression to bind the property to.
PropertyName | Gets and sets the name of the property to bind to the data.

See Also

ReportDataBinding Class
PerpetuumSoft.Reporting.DOM Namespace


Expression Property

[image]

.NET ModelKit Suite ClassReference
ReportDataBinding..::.Expression Property
ReportDataBinding Class See Also Send Feedback
Gets and sets the string containing the expression to bind the property to.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

See Also

ReportDataBinding Class
PerpetuumSoft.Reporting.DOM Namespace


PropertyName Property

[image]

.NET ModelKit Suite ClassReference
ReportDataBinding..::.PropertyName Property
ReportDataBinding Class See Also Send Feedback
Gets and sets the name of the property to bind to the data.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string PropertyName { get; set; }
Visual Basic (Declaration)
Public Property PropertyName As String
Visual C++
public:
property String^ PropertyName {
    String^ get ();
    void set (String^ value);
}

See Also

ReportDataBinding Class
PerpetuumSoft.Reporting.DOM Namespace


ReportDataBindingCollection Class

[image]

.NET ModelKit Suite ClassReference
ReportDataBindingCollection Class
Members See Also Send Feedback
Defines a collection of data bindings in the report.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
[SerializableAttribute]
public class ReportDataBindingCollection : CollectionBase
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ReportDataBindingCollection _
    Inherits CollectionBase
Visual C++
[SerializableAttribute]
public ref class ReportDataBindingCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Reporting.DOM..::.ReportDataBindingCollection

See Also

ReportDataBindingCollection Members
PerpetuumSoft.Reporting.DOM Namespace


ReportDataBindingCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportDataBindingCollection Members
ReportDataBindingCollection Class Constructors Methods Properties See Also Send Feedback

The ReportDataBindingCollection type exposes the following members.

Constructors

Name | Description
ReportDataBindingCollection | Creates a new instance of ReportDataBindingCollection class.

Methods

Name | Description
Add | Adds the specified binding to the collection.
AddRange | Adds the specified array of bindings to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the specified binding exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindBinding | Finds a binding in the collection based on the specified property name.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified bindingэы index in the collection.
Insert | Inserts the specified binding to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified binding from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ReportDataBindingCollection Class
PerpetuumSoft.Reporting.DOM Namespace


ReportDataBindingCollection Constructor

[image]

.NET ModelKit Suite ClassReference
ReportDataBindingCollection Constructor
ReportDataBindingCollection Class See Also Send Feedback
Creates a new instance of ReportDataBindingCollection class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportDataBindingCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportDataBindingCollection()

See Also

ReportDataBindingCollection Class
PerpetuumSoft.Reporting.DOM Namespace


ReportDataBindingCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportDataBindingCollection Methods
ReportDataBindingCollection Class See Also Send Feedback

The ReportDataBindingCollection type exposes the following members.

Methods

Name | Description
Add | Adds the specified binding to the collection.
AddRange | Adds the specified array of bindings to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the specified binding exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindBinding | Finds a binding in the collection based on the specified property name.
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified bindingэы index in the collection.
Insert | Inserts the specified binding to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified binding from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportDataBindingCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
ReportDataBindingCollection..::.Add Method
ReportDataBindingCollection Class See Also Send Feedback
Adds the specified binding to the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportDataBinding Add(
    ReportDataBinding value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As ReportDataBinding _
) As ReportDataBinding
Visual C++
public:
ReportDataBinding^ Add(
    ReportDataBinding^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.ReportDataBinding

See Also

ReportDataBindingCollection Class
PerpetuumSoft.Reporting.DOM Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
ReportDataBindingCollection..::.AddRange Method
ReportDataBindingCollection Class See Also Send Feedback
Adds the specified array of bindings to the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    ReportDataBinding[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As ReportDataBinding() _
)
Visual C++
public:
void AddRange(
    array<ReportDataBinding^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Reporting.DOM..::.ReportDataBinding >[]()[]

See Also

ReportDataBindingCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
ReportDataBindingCollection..::.Contains Method
ReportDataBindingCollection Class See Also Send Feedback
Returns whether the specified binding exists in the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    ReportDataBinding value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As ReportDataBinding _
) As Boolean
Visual C++
public:
bool Contains(
    ReportDataBinding^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.ReportDataBinding

See Also

ReportDataBindingCollection Class
PerpetuumSoft.Reporting.DOM Namespace


FindBinding Method

[image]

.NET ModelKit Suite ClassReference
ReportDataBindingCollection..::.FindBinding Method
ReportDataBindingCollection Class See Also Send Feedback
Finds a binding in the collection based on the specified property name.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportDataBinding FindBinding(
    string propName
)
Visual Basic (Declaration)
Public Function FindBinding ( _
    propName As String _
) As ReportDataBinding
Visual C++
public:
ReportDataBinding^ FindBinding(
    String^ propName
)

Parameters

propName
Type: System..::.String

See Also

ReportDataBindingCollection Class
PerpetuumSoft.Reporting.DOM Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
ReportDataBindingCollection..::.IndexOf Method
ReportDataBindingCollection Class See Also Send Feedback
Returns the specified bindingэы index in the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    ReportDataBinding value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As ReportDataBinding _
) As Integer
Visual C++
public:
int IndexOf(
    ReportDataBinding^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.ReportDataBinding

See Also

ReportDataBindingCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
ReportDataBindingCollection..::.Insert Method
ReportDataBindingCollection Class See Also Send Feedback
Inserts the specified binding to the collection at the specified index.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    ReportDataBinding value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As ReportDataBinding _
)
Visual C++
public:
void Insert(
    int index,
    ReportDataBinding^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Reporting.DOM..::.ReportDataBinding

See Also

ReportDataBindingCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
ReportDataBindingCollection..::.Remove Method
ReportDataBindingCollection Class See Also Send Feedback
Removes the specified binding from the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    ReportDataBinding value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As ReportDataBinding _
)
Visual C++
public:
void Remove(
    ReportDataBinding^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.ReportDataBinding

See Also

ReportDataBindingCollection Class
PerpetuumSoft.Reporting.DOM Namespace


ReportDataBindingCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportDataBindingCollection Properties
ReportDataBindingCollection Class See Also Send Feedback

The ReportDataBindingCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ReportDataBindingCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Item Property

[image] [image]

.NET ModelKit Suite ClassReference
ReportDataBindingCollection..::.Item Property
ReportDataBindingCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets a binding from the collection at the specified index.
Item[([(String])]) | Gets ReportDataBinding by its name.

See Also

ReportDataBindingCollection Class
ReportDataBindingCollection Members
PerpetuumSoft.Reporting.DOM Namespace


Item Property (Int32)

[image]

.NET ModelKit Suite ClassReference
ReportDataBindingCollection..::.Item Property (Int32)
ReportDataBindingCollection Class See Also Send Feedback
Gets a binding from the collection at the specified index.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportDataBinding this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As ReportDataBinding
Visual C++
public:
property ReportDataBinding^ default[int index] {
    ReportDataBinding^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

ReportDataBindingCollection Class
Item Overload
PerpetuumSoft.Reporting.DOM Namespace


Item Property (String)

[image]

.NET ModelKit Suite ClassReference
ReportDataBindingCollection..::.Item Property (String)
ReportDataBindingCollection Class See Also Send Feedback
Gets ReportDataBinding by its name.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportDataBinding this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As ReportDataBinding
Visual C++
public:
property ReportDataBinding^ default[String^ name] {
    ReportDataBinding^ get (String^ name);
}

Parameters

name
Type: System..::.String

See Also

ReportDataBindingCollection Class
Item Overload
PerpetuumSoft.Reporting.DOM Namespace


RichText Class

[image]

.NET ModelKit Suite ClassReference
RichText Class
Members See Also Send Feedback
Represents rich text control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class RichText : Box
Visual Basic (Declaration)
Public Class RichText _
    Inherits Box
Visual C++
public ref class RichText : public Box

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.VisualControl
PerpetuumSoft.Reporting.DOM..::.Box
PerpetuumSoft.Reporting.DOM..::.RichText

See Also

RichText Members
PerpetuumSoft.Reporting.DOM Namespace


RichText Members

[image] [image]

.NET ModelKit Suite ClassReference
RichText Members
RichText Class Constructors Methods Properties Events See Also Send Feedback

The RichText type exposes the following members.

Constructors

Name | Description
RichText | Creates a new instance of RichText class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the final rendered control. (Overrides ReportControl..::.CalculateRenderHeight()()().)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Overridden. See CreateBlankControl()()(). (Overrides ReportControl..::.CreateBlankControl()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Searches the text control for the specified text based on the specified search options. (Overrides ReportControl..::.FindText(String, FindTextOptions).)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed. (Overrides Box..::.OnFillChanged()()().)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Overridden. See PaintContent()()(). (Overrides Box..::.PaintContent(PaintArguments, RectangleF).)
PopulateProperties | Fills the properties of the final rendered control. (Overrides Box..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
RunPropertyDesigner | Overridden. See RunPropertyDesigner(IReportDesignerService). (Overrides ReportControlRunPropertyDesigner(IReportDesignerService).)
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the control can grow in size during rendering to match a bigger size of its rendered content regardless of the control's size in the report template.
CanShrink | Gets and sets whether the control can shrink in size during rendering to match a smaller size of its rendered content regardless of the control's size in the report template.
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
RTFText | Gets and sets a string that contains the RTF.
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
Text | Gets a string that contains the RTF as plain text.
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

RichText Class
PerpetuumSoft.Reporting.DOM Namespace


RichText Constructor

[image]

.NET ModelKit Suite ClassReference
RichText Constructor
RichText Class See Also Send Feedback
Creates a new instance of RichText class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public RichText()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RichText()

See Also

RichText Class
PerpetuumSoft.Reporting.DOM Namespace


RichText Methods

[image] [image]

.NET ModelKit Suite ClassReference
RichText Methods
RichText Class See Also Send Feedback

The RichText type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the final rendered control. (Overrides ReportControl..::.CalculateRenderHeight()()().)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Overridden. See CreateBlankControl()()(). (Overrides ReportControl..::.CreateBlankControl()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Searches the text control for the specified text based on the specified search options. (Overrides ReportControl..::.FindText(String, FindTextOptions).)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed. (Overrides Box..::.OnFillChanged()()().)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Overridden. See PaintContent()()(). (Overrides Box..::.PaintContent(PaintArguments, RectangleF).)
PopulateProperties | Fills the properties of the final rendered control. (Overrides Box..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
RunPropertyDesigner | Overridden. See RunPropertyDesigner(IReportDesignerService). (Overrides ReportControlRunPropertyDesigner(IReportDesignerService).)
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RichText Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateRenderHeight Method

[image]

.NET ModelKit Suite ClassReference
RichText..::.CalculateRenderHeight Method
RichText Class See Also Send Feedback
Calculates the height of the final rendered control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void CalculateRenderHeight()
Visual Basic (Declaration)
Protected Overrides Sub CalculateRenderHeight
Visual C++
protected:
virtual void CalculateRenderHeight() override

See Also

RichText Class
PerpetuumSoft.Reporting.DOM Namespace


CreateBlankControl Method

[image]

.NET ModelKit Suite ClassReference
RichText..::.CreateBlankControl Method
RichText Class See Also Send Feedback
Overridden. See CreateBlankControl()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override ReportControl CreateBlankControl()
Visual Basic (Declaration)
Protected Overrides Function CreateBlankControl As ReportControl
Visual C++
protected:
virtual ReportControl^ CreateBlankControl() override

See Also

RichText Class
PerpetuumSoft.Reporting.DOM Namespace


FindText Method

[image]

.NET ModelKit Suite ClassReference
RichText..::.FindText Method
RichText Class See Also Send Feedback
Searches the text control for the specified text based on the specified search options.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool FindText(
    string pattern,
    FindTextOptions options
)
Visual Basic (Declaration)
Public Overrides Function FindText ( _
    pattern As String, _
    options As FindTextOptions _
) As Boolean
Visual C++
public:
virtual bool FindText(
    String^ pattern,
    FindTextOptions^ options
) override

Parameters

pattern
Type: System..::.String
options
Type: PerpetuumSoft.Reporting.DOM..::.FindTextOptions

See Also

RichText Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
RichText..::.GetScripts Method
RichText Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

RichText Class
RichText Members
PerpetuumSoft.Reporting.DOM Namespace


OnFillChanged Method

[image]

.NET ModelKit Suite ClassReference
RichText..::.OnFillChanged Method
RichText Class See Also Send Feedback
Is called after the Fill property is changed.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnFillChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnFillChanged
Visual C++
protected:
virtual void OnFillChanged() override

See Also

RichText Class
PerpetuumSoft.Reporting.DOM Namespace


PaintContent Method

[image]

.NET ModelKit Suite ClassReference
RichText..::.PaintContent Method
RichText Class See Also Send Feedback
Overridden. See PaintContent()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PaintContent(
    PaintArguments args,
    RectangleF contentRectangle
)
Visual Basic (Declaration)
Protected Overrides Sub PaintContent ( _
    args As PaintArguments, _
    contentRectangle As RectangleF _
)
Visual C++
protected:
virtual void PaintContent(
    PaintArguments^ args,
    RectangleF contentRectangle
) override

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments
contentRectangle
Type: System.Drawing..::.RectangleF

See Also

RichText Class
PerpetuumSoft.Reporting.DOM Namespace


PopulateProperties Method

[image]

.NET ModelKit Suite ClassReference
RichText..::.PopulateProperties Method
RichText Class See Also Send Feedback
Fills the properties of the final rendered control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PopulateProperties(
    ReportControl production
)
Visual Basic (Declaration)
Protected Overrides Sub PopulateProperties ( _
    production As ReportControl _
)
Visual C++
protected:
virtual void PopulateProperties(
    ReportControl^ production
) override

Parameters

production
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

RichText Class
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
RichText..::.Render Method
RichText Class See Also Send Feedback
Renders the control to the final document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

RichText Class
PerpetuumSoft.Reporting.DOM Namespace


RunPropertyDesigner Method

[image]

.NET ModelKit Suite ClassReference
RichText..::.RunPropertyDesigner Method
RichText Class See Also Send Feedback
Overridden. See RunPropertyDesigner(IReportDesignerService).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void RunPropertyDesigner(
    IReportDesignerService service
)
Visual Basic (Declaration)
Public Overrides Sub RunPropertyDesigner ( _
    service As IReportDesignerService _
)
Visual C++
public:
virtual void RunPropertyDesigner(
    IReportDesignerService^ service
) override

Parameters

service
Type: PerpetuumSoft.Reporting.Designer..::.IReportDesignerService

See Also

RichText Class
PerpetuumSoft.Reporting.DOM Namespace


RichText Properties

[image] [image]

.NET ModelKit Suite ClassReference
RichText Properties
RichText Class See Also Send Feedback

The RichText type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the control can grow in size during rendering to match a bigger size of its rendered content regardless of the control's size in the report template.
CanShrink | Gets and sets whether the control can shrink in size during rendering to match a smaller size of its rendered content regardless of the control's size in the report template.
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
RTFText | Gets and sets a string that contains the RTF.
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
Text | Gets a string that contains the RTF as plain text.
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

RichText Class
PerpetuumSoft.Reporting.DOM Namespace


CanGrow Property

[image]

.NET ModelKit Suite ClassReference
RichText..::.CanGrow Property
RichText Class See Also Send Feedback
Gets and sets whether the control can grow in size during rendering to match a bigger size of its rendered content regardless of the control's size in the report template.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool CanGrow { get; set; }
Visual Basic (Declaration)
Public Property CanGrow As Boolean
Visual C++
public:
property bool CanGrow {
    bool get ();
    void set (bool value);
}

See Also

RichText Class
PerpetuumSoft.Reporting.DOM Namespace


CanShrink Property

[image]

.NET ModelKit Suite ClassReference
RichText..::.CanShrink Property
RichText Class See Also Send Feedback
Gets and sets whether the control can shrink in size during rendering to match a smaller size of its rendered content regardless of the control's size in the report template.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool CanShrink { get; set; }
Visual Basic (Declaration)
Public Property CanShrink As Boolean
Visual C++
public:
property bool CanShrink {
    bool get ();
    void set (bool value);
}

See Also

RichText Class
PerpetuumSoft.Reporting.DOM Namespace


RTFText Property

[image]

.NET ModelKit Suite ClassReference
RichText..::.RTFText Property
RichText Class See Also Send Feedback
Gets and sets a string that contains the RTF.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string RTFText { get; set; }
Visual Basic (Declaration)
Public Property RTFText As String
Visual C++
public:
property String^ RTFText {
    String^ get ();
    void set (String^ value);
}

See Also

RichText Class
PerpetuumSoft.Reporting.DOM Namespace


Text Property

[image]

.NET ModelKit Suite ClassReference
RichText..::.Text Property
RichText Class See Also Send Feedback
Gets a string that contains the RTF as plain text.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

RichText Class
PerpetuumSoft.Reporting.DOM Namespace


RichText Events

[image] [image]

.NET ModelKit Suite ClassReference
RichText Events
RichText Class See Also Send Feedback

The RichText type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

RichText Class
PerpetuumSoft.Reporting.DOM Namespace


ScriptLanguage Enumeration

[image]

.NET ModelKit Suite ClassReference
ScriptLanguage Enumeration
See Also Send Feedback
Specifies the script language for the report template.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum ScriptLanguage
Visual Basic (Declaration)
Public Enumeration ScriptLanguage
Visual C++
public enum class ScriptLanguage

Members

Member name | Description
VisualBasicNET | Visual basic for NET.
CSharp | C#.
Custom | Custom script language.

See Also

PerpetuumSoft.Reporting.DOM Namespace


Section Class

[image]

.NET ModelKit Suite ClassReference
Section Class
Members See Also Send Feedback
The base class for all band controls.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Section : ContainerControl
Visual Basic (Declaration)
Public Class Section _
    Inherits ContainerControl
Visual C++
public ref class Section : public ContainerControl

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.CrossBand

See Also

Section Members
PerpetuumSoft.Reporting.DOM Namespace


Section Members

[image] [image]

.NET ModelKit Suite ClassReference
Section Members
Section Class Constructors Methods Properties Events See Also Send Feedback

The Section type exposes the following members.

Constructors

Name | Description
Section | Creates a new instance of Section class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band.
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
CheckConditions | Checks the band's condition.
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ContainerControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string for the band.
GetSectionCaptionColor | Returns the color of the title bar.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Returns whether the specified control can be placed into the band. (Overrides ContainerControl..::.IsValidChild(ReportControl).)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the control. (Inherited from ContainerControl.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying.
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Inherited from ReportControl.)
RenderControls | Renders control for output.
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band.
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations.
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

Section Class
PerpetuumSoft.Reporting.DOM Namespace


Section Constructor

[image]

.NET ModelKit Suite ClassReference
Section Constructor
Section Class See Also Send Feedback
Creates a new instance of Section class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Section()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Section()

See Also

Section Class
PerpetuumSoft.Reporting.DOM Namespace


Section Methods

[image] [image]

.NET ModelKit Suite ClassReference
Section Methods
Section Class See Also Send Feedback

The Section type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band.
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
CheckConditions | Checks the band's condition.
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ContainerControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string for the band.
GetSectionCaptionColor | Returns the color of the title bar.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Returns whether the specified control can be placed into the band. (Overrides ContainerControl..::.IsValidChild(ReportControl).)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the control. (Inherited from ContainerControl.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying.
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Inherited from ReportControl.)
RenderControls | Renders control for output.
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered.

See Also

Section Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateCaretPosition Method

[image]

.NET ModelKit Suite ClassReference
Section..::.CalculateCaretPosition Method
Section Class See Also Send Feedback
Calculates the current position in the report for placing the current band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void CalculateCaretPosition()
Visual Basic (Declaration)
Protected Overridable Sub CalculateCaretPosition
Visual C++
protected:
virtual void CalculateCaretPosition()

See Also

Section Class
PerpetuumSoft.Reporting.DOM Namespace


CheckConditions Method

[image]

.NET ModelKit Suite ClassReference
Section..::.CheckConditions Method
Section Class See Also Send Feedback
Checks the band's condition.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual bool CheckConditions()
Visual Basic (Declaration)
Protected Overridable Function CheckConditions As Boolean
Visual C++
protected:
virtual bool CheckConditions()

See Also

Section Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
Section..::.GetScripts Method
Section Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

Section Class
Section Members
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaption Method

[image]

.NET ModelKit Suite ClassReference
Section..::.GetSectionCaption Method
Section Class See Also Send Feedback
Returns the title string for the band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual string GetSectionCaption()
Visual Basic (Declaration)
Protected Overridable Function GetSectionCaption As String
Visual C++
protected:
virtual String^ GetSectionCaption()

See Also

Section Class
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaptionColor Method

[image]

.NET ModelKit Suite ClassReference
Section..::.GetSectionCaptionColor Method
Section Class See Also Send Feedback
Returns the color of the title bar.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual Color GetSectionCaptionColor()
Visual Basic (Declaration)
Protected Overridable Function GetSectionCaptionColor As Color
Visual C++
protected:
virtual Color GetSectionCaptionColor()

See Also

Section Class
PerpetuumSoft.Reporting.DOM Namespace


IsValidChild Method

[image]

.NET ModelKit Suite ClassReference
Section..::.IsValidChild Method
Section Class See Also Send Feedback
Returns whether the specified control can be placed into the band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValidChild(
    ReportControl c
)
Visual Basic (Declaration)
Public Overrides Function IsValidChild ( _
    c As ReportControl _
) As Boolean
Visual C++
public:
virtual bool IsValidChild(
    ReportControl^ c
) override

Parameters

c
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

Implements

IContainerControl..::.IsValidChild(ReportControl)

See Also

Section Class
PerpetuumSoft.Reporting.DOM Namespace


PrepareControls Method

[image]

.NET ModelKit Suite ClassReference
Section..::.PrepareControls Method
Section Class See Also Send Feedback
Prepares control before displaying.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void PrepareControls()
Visual Basic (Declaration)
Protected Overridable Sub PrepareControls
Visual C++
protected:
virtual void PrepareControls()

See Also

Section Class
PerpetuumSoft.Reporting.DOM Namespace


RenderControls Method

[image]

.NET ModelKit Suite ClassReference
Section..::.RenderControls Method
Section Class See Also Send Feedback
Renders control for output.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void RenderControls()
Visual Basic (Declaration)
Protected Overridable Sub RenderControls
Visual C++
protected:
virtual void RenderControls()

See Also

Section Class
PerpetuumSoft.Reporting.DOM Namespace


UpdatePageArea Method

[image]

.NET ModelKit Suite ClassReference
Section..::.UpdatePageArea Method
Section Class See Also Send Feedback
Calculates the remaining free page area after the band is rendered.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void UpdatePageArea()
Visual Basic (Declaration)
Protected Overridable Sub UpdatePageArea
Visual C++
protected:
virtual void UpdatePageArea()

See Also

Section Class
PerpetuumSoft.Reporting.DOM Namespace


Section Properties

[image] [image]

.NET ModelKit Suite ClassReference
Section Properties
Section Class See Also Send Feedback

The Section type exposes the following members.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band.
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations.
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

Section Class
PerpetuumSoft.Reporting.DOM Namespace


MasterBand Property

[image]

.NET ModelKit Suite ClassReference
Section..::.MasterBand Property
Section Class See Also Send Feedback
Gets the master band.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataBandBase MasterBand { get; }
Visual Basic (Declaration)
Public ReadOnly Property MasterBand As DataBandBase
Visual C++
public:
property DataBandBase^ MasterBand {
    DataBandBase^ get ();
}

See Also

Section Class
PerpetuumSoft.Reporting.DOM Namespace


SortPriority Property

[image]

.NET ModelKit Suite ClassReference
Section..::.SortPriority Property
Section Class See Also Send Feedback
Gets the band's priority for sorting operations.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual int SortPriority { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property SortPriority As Integer
Visual C++
public:
virtual property int SortPriority {
    int get ();
}

See Also

Section Class
PerpetuumSoft.Reporting.DOM Namespace


Section Events

[image] [image]

.NET ModelKit Suite ClassReference
Section Events
Section Class See Also Send Feedback

The Section type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

Section Class
PerpetuumSoft.Reporting.DOM Namespace


Shape Class

[image]

.NET ModelKit Suite ClassReference
Shape Class
Members See Also Send Feedback
Defines a shape control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Shape : VisualControl
Visual Basic (Declaration)
Public Class Shape _
    Inherits VisualControl
Visual C++
public ref class Shape : public VisualControl

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.VisualControl
PerpetuumSoft.Reporting.DOM..::.Shape

See Also

Shape Members
PerpetuumSoft.Reporting.DOM Namespace


Shape Members

[image] [image]

.NET ModelKit Suite ClassReference
Shape Members
Shape Class Constructors Methods Properties Events See Also Send Feedback

The Shape type exposes the following members.

Constructors

Name | Description
Shape | Creates a new instance of Shape class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Overridden. See CreateBlankControl()()(). (Overrides ReportControl..::.CreateBlankControl()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of a Shape object created with visual tools such as Report Designer. (Overrides ReportControl..::.InitNew()()().)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the shape. (Overrides ReportControl..::.OnPaint(PaintArguments).)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Overrides ReportControl..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the shape to the final document. (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the fill pattern for the shape.
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Line | Gets and sets the line style for the shape's border.
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Shadow | Gets and sets the shape's shadow (see Shadow for more information).
ShapeStyle | Gets and sets the style of the shape.
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

Shape Class
PerpetuumSoft.Reporting.DOM Namespace


Shape Constructor

[image]

.NET ModelKit Suite ClassReference
Shape Constructor
Shape Class See Also Send Feedback
Creates a new instance of Shape class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Shape()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Shape()

See Also

Shape Class
PerpetuumSoft.Reporting.DOM Namespace


Shape Methods

[image] [image]

.NET ModelKit Suite ClassReference
Shape Methods
Shape Class See Also Send Feedback

The Shape type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Overridden. See CreateBlankControl()()(). (Overrides ReportControl..::.CreateBlankControl()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of a Shape object created with visual tools such as Report Designer. (Overrides ReportControl..::.InitNew()()().)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the shape. (Overrides ReportControl..::.OnPaint(PaintArguments).)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Overrides ReportControl..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the shape to the final document. (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Shape Class
PerpetuumSoft.Reporting.DOM Namespace


CreateBlankControl Method

[image]

.NET ModelKit Suite ClassReference
Shape..::.CreateBlankControl Method
Shape Class See Also Send Feedback
Overridden. See CreateBlankControl()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override ReportControl CreateBlankControl()
Visual Basic (Declaration)
Protected Overrides Function CreateBlankControl As ReportControl
Visual C++
protected:
virtual ReportControl^ CreateBlankControl() override

See Also

Shape Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
Shape..::.GetScripts Method
Shape Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

Shape Class
Shape Members
PerpetuumSoft.Reporting.DOM Namespace


InitNew Method

[image]

.NET ModelKit Suite ClassReference
Shape..::.InitNew Method
Shape Class See Also Send Feedback
Sets the predefined values for the properties of a Shape object created with visual tools such as Report Designer.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void InitNew()
Visual Basic (Declaration)
Public Overrides Sub InitNew
Visual C++
public:
virtual void InitNew() override

See Also

Shape Class
PerpetuumSoft.Reporting.DOM Namespace


OnPaint Method

[image]

.NET ModelKit Suite ClassReference
Shape..::.OnPaint Method
Shape Class See Also Send Feedback
Paints the shape.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
protected:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments

See Also

Shape Class
PerpetuumSoft.Reporting.DOM Namespace


PopulateProperties Method

[image]

.NET ModelKit Suite ClassReference
Shape..::.PopulateProperties Method
Shape Class See Also Send Feedback
Fills the properties of the final rendered control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PopulateProperties(
    ReportControl production
)
Visual Basic (Declaration)
Protected Overrides Sub PopulateProperties ( _
    production As ReportControl _
)
Visual C++
protected:
virtual void PopulateProperties(
    ReportControl^ production
) override

Parameters

production
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

Shape Class
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
Shape..::.Render Method
Shape Class See Also Send Feedback
Renders the shape to the final document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

Shape Class
PerpetuumSoft.Reporting.DOM Namespace


Shape Properties

[image] [image]

.NET ModelKit Suite ClassReference
Shape Properties
Shape Class See Also Send Feedback

The Shape type exposes the following members.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the fill pattern for the shape.
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Line | Gets and sets the line style for the shape's border.
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Shadow | Gets and sets the shape's shadow (see Shadow for more information).
ShapeStyle | Gets and sets the style of the shape.
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

Shape Class
PerpetuumSoft.Reporting.DOM Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
Shape..::.Fill Property
Shape Class See Also Send Feedback
Gets and sets the fill pattern for the shape.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

Shape Class
PerpetuumSoft.Reporting.DOM Namespace


Line Property

[image]

.NET ModelKit Suite ClassReference
Shape..::.Line Property
Shape Class See Also Send Feedback
Gets and sets the line style for the shape's border.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public BorderLine Line { get; set; }
Visual Basic (Declaration)
Public Property Line As BorderLine
Visual C++
public:
property BorderLine Line {
    BorderLine get ();
    void set (BorderLine value);
}

See Also

Shape Class
PerpetuumSoft.Reporting.DOM Namespace


Shadow Property

[image]

.NET ModelKit Suite ClassReference
Shape..::.Shadow Property
Shape Class See Also Send Feedback
Gets and sets the shape's shadow (see Shadow for more information).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Shadow Shadow { get; set; }
Visual Basic (Declaration)
Public Property Shadow As Shadow
Visual C++
public:
property Shadow^ Shadow {
    Shadow^ get ();
    void set (Shadow^ value);
}

See Also

Shape Class
PerpetuumSoft.Reporting.DOM Namespace


ShapeStyle Property

[image]

.NET ModelKit Suite ClassReference
Shape..::.ShapeStyle Property
Shape Class See Also Send Feedback
Gets and sets the style of the shape.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ShapeBase ShapeStyle { get; set; }
Visual Basic (Declaration)
Public Property ShapeStyle As ShapeBase
Visual C++
public:
property ShapeBase^ ShapeStyle {
    ShapeBase^ get ();
    void set (ShapeBase^ value);
}

See Also

Shape Class
PerpetuumSoft.Reporting.DOM Namespace


Shape Events

[image] [image]

.NET ModelKit Suite ClassReference
Shape Events
Shape Class See Also Send Feedback

The Shape type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

Shape Class
PerpetuumSoft.Reporting.DOM Namespace


SideBySide Class

[image]

.NET ModelKit Suite ClassReference
SideBySide Class
Members See Also Send Feedback
Represents the SideBySide elemet.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class SideBySide : RegularBand
Visual Basic (Declaration)
Public Class SideBySide _
    Inherits RegularBand
Visual C++
public ref class SideBySide : public RegularBand

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.RegularBandBase
PerpetuumSoft.Reporting.DOM..::.RegularBand
PerpetuumSoft.Reporting.DOM..::.SideBySide

See Also

SideBySide Members
PerpetuumSoft.Reporting.DOM Namespace


SideBySide Members

[image] [image]

.NET ModelKit Suite ClassReference
SideBySide Members
SideBySide Class Constructors Methods Properties Events See Also Send Feedback

The SideBySide type exposes the following members.

Constructors

Name | Description
SideBySide | Initializes a new instance of the SideBySide class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Inherited from Section.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Overrides RegularBandBase..::.IsValidChild(ReportControl).)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Overrides ReportControl..::.Render()()().)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

SideBySide Class
PerpetuumSoft.Reporting.DOM Namespace


SideBySide Constructor

[image]

.NET ModelKit Suite ClassReference
SideBySide Constructor
SideBySide Class See Also Send Feedback
Initializes a new instance of the SideBySide class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public SideBySide()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SideBySide()

See Also

SideBySide Class
PerpetuumSoft.Reporting.DOM Namespace


SideBySide Methods

[image] [image]

.NET ModelKit Suite ClassReference
SideBySide Methods
SideBySide Class See Also Send Feedback

The SideBySide type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Inherited from Section.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Overrides RegularBandBase..::.IsValidChild(ReportControl).)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Overrides ReportControl..::.Render()()().)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

See Also

SideBySide Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
SideBySide..::.GetScripts Method
SideBySide Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

SideBySide Class
SideBySide Members
PerpetuumSoft.Reporting.DOM Namespace


IsValidChild Method

[image]

.NET ModelKit Suite ClassReference
SideBySide..::.IsValidChild Method
SideBySide Class See Also Send Feedback
Implements IsValidChild(ReportControl).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValidChild(
    ReportControl c
)
Visual Basic (Declaration)
Public Overrides Function IsValidChild ( _
    c As ReportControl _
) As Boolean
Visual C++
public:
virtual bool IsValidChild(
    ReportControl^ c
) override

Parameters

c
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

Implements

IContainerControl..::.IsValidChild(ReportControl)

See Also

SideBySide Class
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
SideBySide..::.Render Method
SideBySide Class See Also Send Feedback
Overridden. See Render()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

SideBySide Class
PerpetuumSoft.Reporting.DOM Namespace


SideBySide Properties

[image] [image]

.NET ModelKit Suite ClassReference
SideBySide Properties
SideBySide Class See Also Send Feedback

The SideBySide type exposes the following members.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

SideBySide Class
PerpetuumSoft.Reporting.DOM Namespace


SideBySide Events

[image] [image]

.NET ModelKit Suite ClassReference
SideBySide Events
SideBySide Class See Also Send Feedback

The SideBySide type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

SideBySide Class
PerpetuumSoft.Reporting.DOM Namespace


Style Class

[image]

.NET ModelKit Suite ClassReference
Style Class
Members See Also Send Feedback
Defines a style for using in a style sheet.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Style : IDisposable, ICloneable
Visual Basic (Declaration)
Public Class Style _
    Implements IDisposable, ICloneable
Visual C++
public ref class Style : IDisposable, ICloneable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.Style

See Also

Style Members
PerpetuumSoft.Reporting.DOM Namespace


Style Members

[image] [image]

.NET ModelKit Suite ClassReference
Style Members
Style Class Constructors Methods Properties See Also Send Feedback

The Style type exposes the following members.

Constructors

Name | Description
Style | Creates a new instance of Style class.

Methods

Name | Description
Clone | Implements Clone()()().
Dispose | Implements Dispose()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Style object. (Overrides Object..::.ToString()()().)

Properties

Name | Description
Border | Gets and sets the border defined by this style.
Fill | Gets and sets the fill pattern defined by this style.
Font | Gets and sets the font defined by this style.
Name | Gets and sets the name of this style.
TextAlign | Gets or sets ContentAlignment which assignes text alignment.
TextFill | Gets and sets the text fill pattern defined by this style.

See Also

Style Class
PerpetuumSoft.Reporting.DOM Namespace


Style Constructor

[image]

.NET ModelKit Suite ClassReference
Style Constructor
Style Class See Also Send Feedback
Creates a new instance of Style class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Style()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Style()

See Also

Style Class
PerpetuumSoft.Reporting.DOM Namespace


Style Methods

[image] [image]

.NET ModelKit Suite ClassReference
Style Methods
Style Class See Also Send Feedback

The Style type exposes the following members.

Methods

Name | Description
Clone | Implements Clone()()().
Dispose | Implements Dispose()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Style object. (Overrides Object..::.ToString()()().)

See Also

Style Class
PerpetuumSoft.Reporting.DOM Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
Style..::.Clone Method
Style Class See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Implements

ICloneable..::.Clone()()()

See Also

Style Class
PerpetuumSoft.Reporting.DOM Namespace


Dispose Method

[image]

.NET ModelKit Suite ClassReference
Style..::.Dispose Method
Style Class See Also Send Feedback
Implements Dispose()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

Style Class
PerpetuumSoft.Reporting.DOM Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
Style..::.ToString Method
Style Class See Also Send Feedback
Returns a String that represents the current Style object.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Style Class
PerpetuumSoft.Reporting.DOM Namespace


Style Properties

[image] [image]

.NET ModelKit Suite ClassReference
Style Properties
Style Class See Also Send Feedback

The Style type exposes the following members.

Properties

Name | Description
Border | Gets and sets the border defined by this style.
Fill | Gets and sets the fill pattern defined by this style.
Font | Gets and sets the font defined by this style.
Name | Gets and sets the name of this style.
TextAlign | Gets or sets ContentAlignment which assignes text alignment.
TextFill | Gets and sets the text fill pattern defined by this style.

See Also

Style Class
PerpetuumSoft.Reporting.DOM Namespace


Border Property

[image]

.NET ModelKit Suite ClassReference
Style..::.Border Property
Style Class See Also Send Feedback
Gets and sets the border defined by this style.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Border Border { get; set; }
Visual Basic (Declaration)
Public Property Border As Border
Visual C++
public:
property Border^ Border {
    Border^ get ();
    void set (Border^ value);
}

See Also

Style Class
PerpetuumSoft.Reporting.DOM Namespace


Fill Property

[image]

.NET ModelKit Suite ClassReference
Style..::.Fill Property
Style Class See Also Send Feedback
Gets and sets the fill pattern defined by this style.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Fill Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

Style Class
PerpetuumSoft.Reporting.DOM Namespace


Font Property

[image]

.NET ModelKit Suite ClassReference
Style..::.Font Property
Style Class See Also Send Feedback
Gets and sets the font defined by this style.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FontDescriptor Font { get; set; }
Visual Basic (Declaration)
Public Property Font As FontDescriptor
Visual C++
public:
property FontDescriptor^ Font {
    FontDescriptor^ get ();
    void set (FontDescriptor^ value);
}

See Also

Style Class
PerpetuumSoft.Reporting.DOM Namespace


Name Property

[image]

.NET ModelKit Suite ClassReference
Style..::.Name Property
Style Class See Also Send Feedback
Gets and sets the name of this style.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Style Class
PerpetuumSoft.Reporting.DOM Namespace


TextAlign Property

[image]

.NET ModelKit Suite ClassReference
Style..::.TextAlign Property
Style Class See Also Send Feedback
Gets or sets ContentAlignment which assignes text alignment.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ContentAlignment TextAlign { get; set; }
Visual Basic (Declaration)
Public Property TextAlign As ContentAlignment
Visual C++
public:
property ContentAlignment TextAlign {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

Style Class
PerpetuumSoft.Reporting.DOM Namespace


TextFill Property

[image]

.NET ModelKit Suite ClassReference
Style..::.TextFill Property
Style Class See Also Send Feedback
Gets and sets the text fill pattern defined by this style.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Fill TextFill { get; set; }
Visual Basic (Declaration)
Public Property TextFill As Fill
Visual C++
public:
property Fill^ TextFill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

Style Class
PerpetuumSoft.Reporting.DOM Namespace


StyleCollection Class

[image]

.NET ModelKit Suite ClassReference
StyleCollection Class
Members See Also Send Feedback
Defines the collection of styles for a style sheet.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class StyleCollection : CollectionBase
Visual Basic (Declaration)
Public Class StyleCollection _
    Inherits CollectionBase
Visual C++
public ref class StyleCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Reporting.DOM..::.StyleCollection

See Also

StyleCollection Members
PerpetuumSoft.Reporting.DOM Namespace


StyleCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
StyleCollection Members
StyleCollection Class Constructors Methods Properties See Also Send Feedback

The StyleCollection type exposes the following members.

Constructors

Name | Description
StyleCollection | Creates a new instance of StyleCollection class.

Methods

Name | Description
Add | Adds the specified style to the collection.
AddRange | Adds the specified array of styles to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the specified style exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the index of the specified style in the collection.
Insert | Adds the specified style to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified style from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

StyleCollection Class
PerpetuumSoft.Reporting.DOM Namespace


StyleCollection Constructor

[image]

.NET ModelKit Suite ClassReference
StyleCollection Constructor
StyleCollection Class See Also Send Feedback
Creates a new instance of StyleCollection class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public StyleCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StyleCollection()

See Also

StyleCollection Class
PerpetuumSoft.Reporting.DOM Namespace


StyleCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
StyleCollection Methods
StyleCollection Class See Also Send Feedback

The StyleCollection type exposes the following members.

Methods

Name | Description
Add | Adds the specified style to the collection.
AddRange | Adds the specified array of styles to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the specified style exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the index of the specified style in the collection.
Insert | Adds the specified style to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified style from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StyleCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.Add Method
StyleCollection Class See Also Send Feedback
Adds the specified style to the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Style Add(
    Style value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As Style _
) As Style
Visual C++
public:
Style^ Add(
    Style^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.Style

See Also

StyleCollection Class
PerpetuumSoft.Reporting.DOM Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.AddRange Method
StyleCollection Class See Also Send Feedback
Adds the specified array of styles to the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    Style[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As Style() _
)
Visual C++
public:
void AddRange(
    array<Style^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Reporting.DOM..::.Style >[]()[]

See Also

StyleCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.Contains Method
StyleCollection Class See Also Send Feedback
Returns whether the specified style exists in the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    Style value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As Style _
) As Boolean
Visual C++
public:
bool Contains(
    Style^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.Style

See Also

StyleCollection Class
PerpetuumSoft.Reporting.DOM Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.IndexOf Method
StyleCollection Class See Also Send Feedback
Returns the index of the specified style in the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    Style value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As Style _
) As Integer
Visual C++
public:
int IndexOf(
    Style^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.Style

See Also

StyleCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.Insert Method
StyleCollection Class See Also Send Feedback
Adds the specified style to the collection at the specified index.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    Style value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As Style _
)
Visual C++
public:
void Insert(
    int index,
    Style^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Reporting.DOM..::.Style

See Also

StyleCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.Remove Method
StyleCollection Class See Also Send Feedback
Removes the specified style from the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    Style value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As Style _
)
Visual C++
public:
void Remove(
    Style^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.DOM..::.Style

See Also

StyleCollection Class
PerpetuumSoft.Reporting.DOM Namespace


StyleCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
StyleCollection Properties
StyleCollection Class See Also Send Feedback

The StyleCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

StyleCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Item Property

[image] [image]

.NET ModelKit Suite ClassReference
StyleCollection..::.Item Property
StyleCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets a style from the collection at the specified index.
Item[([(String])]) | Gets a style with the specified name from the collection.

See Also

StyleCollection Class
StyleCollection Members
PerpetuumSoft.Reporting.DOM Namespace


Item Property (Int32)

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.Item Property (Int32)
StyleCollection Class See Also Send Feedback
Gets a style from the collection at the specified index.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Style this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Style
Visual C++
public:
property Style^ default[int index] {
    Style^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

StyleCollection Class
Item Overload
PerpetuumSoft.Reporting.DOM Namespace


Item Property (String)

[image]

.NET ModelKit Suite ClassReference
StyleCollection..::.Item Property (String)
StyleCollection Class See Also Send Feedback
Gets a style with the specified name from the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Style this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As Style
Visual C++
public:
property Style^ default[String^ name] {
    Style^ get (String^ name);
}

Parameters

name
Type: System..::.String

See Also

StyleCollection Class
Item Overload
PerpetuumSoft.Reporting.DOM Namespace


StyleSheet Class

[image]

.NET ModelKit Suite ClassReference
StyleSheet Class
Members See Also Send Feedback
Defines a style sheet.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class StyleSheet
Visual Basic (Declaration)
Public Class StyleSheet
Visual C++
public ref class StyleSheet

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.StyleSheet

See Also

StyleSheet Members
PerpetuumSoft.Reporting.DOM Namespace


StyleSheet Members

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheet Members
StyleSheet Class Constructors Methods Fields Properties See Also Send Feedback

The StyleSheet type exposes the following members.

Constructors

Name | Description
StyleSheet | Creates a new instance of StyleSheet class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current StyleSheet object. (Overrides Object..::.ToString()()().)

Fields

Name | Description
StyleSheetExt | Default extension for StyleSheets files.

Properties

Name | Description
Description | Gets and sets the string that represents description of the current style sheet.
Styles | Gets the collection of styles stored in the current style sheet.
Title | Gets and sets the string that represents the title of the current style sheet.

See Also

StyleSheet Class
PerpetuumSoft.Reporting.DOM Namespace


StyleSheet Constructor

[image]

.NET ModelKit Suite ClassReference
StyleSheet Constructor
StyleSheet Class See Also Send Feedback
Creates a new instance of StyleSheet class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public StyleSheet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StyleSheet()

See Also

StyleSheet Class
PerpetuumSoft.Reporting.DOM Namespace


StyleSheet Fields

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheet Fields
StyleSheet Class See Also Send Feedback

The StyleSheet type exposes the following members.

Fields

Name | Description
StyleSheetExt | Default extension for StyleSheets files.

See Also

StyleSheet Class
PerpetuumSoft.Reporting.DOM Namespace


StyleSheetExt Field

[image]

.NET ModelKit Suite ClassReference
StyleSheet..::.StyleSheetExt Field
StyleSheet Class See Also Send Feedback
Default extension for StyleSheets files.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public const string StyleSheetExt
Visual Basic (Declaration)
Public Const StyleSheetExt As String
Visual C++
public:
literal String^ StyleSheetExt

See Also

StyleSheet Class
PerpetuumSoft.Reporting.DOM Namespace


StyleSheet Methods

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheet Methods
StyleSheet Class See Also Send Feedback

The StyleSheet type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current StyleSheet object. (Overrides Object..::.ToString()()().)

See Also

StyleSheet Class
PerpetuumSoft.Reporting.DOM Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
StyleSheet..::.ToString Method
StyleSheet Class See Also Send Feedback
Returns a String that represents the current StyleSheet object.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

StyleSheet Class
PerpetuumSoft.Reporting.DOM Namespace


StyleSheet Properties

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheet Properties
StyleSheet Class See Also Send Feedback

The StyleSheet type exposes the following members.

Properties

Name | Description
Description | Gets and sets the string that represents description of the current style sheet.
Styles | Gets the collection of styles stored in the current style sheet.
Title | Gets and sets the string that represents the title of the current style sheet.

See Also

StyleSheet Class
PerpetuumSoft.Reporting.DOM Namespace


Description Property

[image]

.NET ModelKit Suite ClassReference
StyleSheet..::.Description Property
StyleSheet Class See Also Send Feedback
Gets and sets the string that represents description of the current style sheet.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

StyleSheet Class
PerpetuumSoft.Reporting.DOM Namespace


Styles Property

[image]

.NET ModelKit Suite ClassReference
StyleSheet..::.Styles Property
StyleSheet Class See Also Send Feedback
Gets the collection of styles stored in the current style sheet.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public StyleCollection Styles { get; }
Visual Basic (Declaration)
Public ReadOnly Property Styles As StyleCollection
Visual C++
public:
property StyleCollection^ Styles {
    StyleCollection^ get ();
}

See Also

StyleSheet Class
PerpetuumSoft.Reporting.DOM Namespace


Title Property

[image]

.NET ModelKit Suite ClassReference
StyleSheet..::.Title Property
StyleSheet Class See Also Send Feedback
Gets and sets the string that represents the title of the current style sheet.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

StyleSheet Class
PerpetuumSoft.Reporting.DOM Namespace


SubReport Class

[image]

.NET ModelKit Suite ClassReference
SubReport Class
Members See Also Send Feedback
Represents the SubReport elemet.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class SubReport : SubReportBase
Visual Basic (Declaration)
Public Class SubReport _
    Inherits SubReportBase
Visual C++
public ref class SubReport : public SubReportBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.RegularBandBase
PerpetuumSoft.Reporting.DOM..::.RegularBand
PerpetuumSoft.Reporting.DOM..::.SubReportBase
PerpetuumSoft.Reporting.DOM..::.SubReport

See Also

SubReport Members
PerpetuumSoft.Reporting.DOM Namespace


SubReport Members

[image] [image]

.NET ModelKit Suite ClassReference
SubReport Members
SubReport Class Constructors Methods Properties Events See Also Send Feedback

The SubReport type exposes the following members.

Constructors

Name | Description
SubReport | Initializes a new instance of the SubReport class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Overridden. See CheckConditions()()(). (Inherited from SubReportBase.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Sets caption color. (Overrides SubReportBase..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetTemplate | Returns sub report template. (Overrides SubReportBase..::.GetTemplate()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from SubReportBase.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateParameters | Performs additional custom processes when calculating parameters.
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs additional custom processes when painting subreport. (Overrides BandBase..::.OnPaint(PaintArguments).)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Inherited from SubReportBase.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parameters | The transmission of parameters into the sub report template.
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Shift | Gets or sets shif for sub-report elements. (Inherited from SubReportBase.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
TemplateName | Gets or sets template name.
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
CalculateParameters | Оccurs when the calculation of parameters values are calculated.
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

SubReport Class
PerpetuumSoft.Reporting.DOM Namespace


SubReport Constructor

[image]

.NET ModelKit Suite ClassReference
SubReport Constructor
SubReport Class See Also Send Feedback
Initializes a new instance of the SubReport class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public SubReport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SubReport()

See Also

SubReport Class
PerpetuumSoft.Reporting.DOM Namespace


SubReport Methods

[image] [image]

.NET ModelKit Suite ClassReference
SubReport Methods
SubReport Class See Also Send Feedback

The SubReport type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Overridden. See CheckConditions()()(). (Inherited from SubReportBase.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Sets caption color. (Overrides SubReportBase..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetTemplate | Returns sub report template. (Overrides SubReportBase..::.GetTemplate()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Inherited from SubReportBase.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateParameters | Performs additional custom processes when calculating parameters.
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs additional custom processes when painting subreport. (Overrides BandBase..::.OnPaint(PaintArguments).)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Inherited from SubReportBase.)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

See Also

SubReport Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
SubReport..::.GetScripts Method
SubReport Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Overridden. See GetScripts(ScriptInfoCollection). (Overrides ReportControl..::.GetScripts(ScriptInfoCollection).)

See Also

SubReport Class
SubReport Members
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method (ScriptInfoCollection)

[image]

.NET ModelKit Suite ClassReference
SubReport..::.GetScripts Method (ScriptInfoCollection)
SubReport Class See Also Send Feedback
Overridden. See GetScripts(ScriptInfoCollection).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void GetScripts(
    ScriptInfoCollection scripts
)
Visual Basic (Declaration)
Public Overrides Sub GetScripts ( _
    scripts As ScriptInfoCollection _
)
Visual C++
public:
virtual void GetScripts(
    ScriptInfoCollection^ scripts
) override

Parameters

scripts
Type: PerpetuumSoft.Reporting.Rendering..::.ScriptInfoCollection

See Also

SubReport Class
GetScripts Overload
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaptionColor Method

[image]

.NET ModelKit Suite ClassReference
SubReport..::.GetSectionCaptionColor Method
SubReport Class See Also Send Feedback
Sets caption color.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Color GetSectionCaptionColor()
Visual Basic (Declaration)
Protected Overrides Function GetSectionCaptionColor As Color
Visual C++
protected:
virtual Color GetSectionCaptionColor() override

See Also

SubReport Class
PerpetuumSoft.Reporting.DOM Namespace


GetTemplate Method

[image]

.NET ModelKit Suite ClassReference
SubReport..::.GetTemplate Method
SubReport Class See Also Send Feedback
Returns sub report template.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Document GetTemplate()
Visual Basic (Declaration)
Protected Overrides Function GetTemplate As Document
Visual C++
protected:
virtual Document^ GetTemplate() override

See Also

SubReport Class
PerpetuumSoft.Reporting.DOM Namespace


OnCalculateParameters Method

[image]

.NET ModelKit Suite ClassReference
SubReport..::.OnCalculateParameters Method
SubReport Class See Also Send Feedback
Performs additional custom processes when calculating parameters.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnCalculateParameters(
    CalculateSubReportParameterEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnCalculateParameters ( _
    e As CalculateSubReportParameterEventArgs _
)
Visual C++
protected:
virtual void OnCalculateParameters(
    CalculateSubReportParameterEventArgs^ e
)

Parameters

e
Type: PerpetuumSoft.Reporting.DOM..::.CalculateSubReportParameterEventArgs

See Also

SubReport Class
PerpetuumSoft.Reporting.DOM Namespace


OnPaint Method

[image]

.NET ModelKit Suite ClassReference
SubReport..::.OnPaint Method
SubReport Class See Also Send Feedback
Performs additional custom processes when painting subreport.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
protected:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments

See Also

SubReport Class
PerpetuumSoft.Reporting.DOM Namespace


SubReport Properties

[image] [image]

.NET ModelKit Suite ClassReference
SubReport Properties
SubReport Class See Also Send Feedback

The SubReport type exposes the following members.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parameters | The transmission of parameters into the sub report template.
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Shift | Gets or sets shif for sub-report elements. (Inherited from SubReportBase.)
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
TemplateName | Gets or sets template name.
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

SubReport Class
PerpetuumSoft.Reporting.DOM Namespace


Parameters Property

[image]

.NET ModelKit Suite ClassReference
SubReport..::.Parameters Property
SubReport Class See Also Send Feedback
The transmission of parameters into the sub report template.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public SubReportParameterCollection Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As SubReportParameterCollection
Visual C++
public:
property SubReportParameterCollection^ Parameters {
    SubReportParameterCollection^ get ();
}

See Also

SubReport Class
PerpetuumSoft.Reporting.DOM Namespace


TemplateName Property

[image]

.NET ModelKit Suite ClassReference
SubReport..::.TemplateName Property
SubReport Class See Also Send Feedback
Gets or sets template name.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string TemplateName { get; set; }
Visual Basic (Declaration)
Public Property TemplateName As String
Visual C++
public:
property String^ TemplateName {
    String^ get ();
    void set (String^ value);
}

See Also

SubReport Class
PerpetuumSoft.Reporting.DOM Namespace


SubReport Events

[image] [image]

.NET ModelKit Suite ClassReference
SubReport Events
SubReport Class See Also Send Feedback

The SubReport type exposes the following members.

Events

Name | Description
CalculateParameters | Оccurs when the calculation of parameters values are calculated.
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

SubReport Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateParameters Event

[image]

.NET ModelKit Suite ClassReference
SubReport..::.CalculateParameters Event
SubReport Class See Also Send Feedback
Оccurs when the calculation of parameters values are calculated.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event CalculateSubReportParameterEventHandler CalculateParameters
Visual Basic (Declaration)
Public Event CalculateParameters As CalculateSubReportParameterEventHandler
Visual C++
public:
 event CalculateSubReportParameterEventHandler^ CalculateParameters {
    void add (CalculateSubReportParameterEventHandler^ value);
    void remove (CalculateSubReportParameterEventHandler^ value);
}

See Also

SubReport Class
PerpetuumSoft.Reporting.DOM Namespace


SubReportBase Class

[image]

.NET ModelKit Suite ClassReference
SubReportBase Class
Members See Also Send Feedback
Base class for sub reports.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract class SubReportBase : RegularBand
Visual Basic (Declaration)
Public MustInherit Class SubReportBase _
    Inherits RegularBand
Visual C++
public ref class SubReportBase abstract : public RegularBand

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.RegularBandBase
PerpetuumSoft.Reporting.DOM..::.RegularBand
PerpetuumSoft.Reporting.DOM..::.SubReportBase
PerpetuumSoft.Reporting.DOM..::.Content
PerpetuumSoft.Reporting.DOM..::.SubReport

See Also

SubReportBase Members
PerpetuumSoft.Reporting.DOM Namespace


SubReportBase Members

[image] [image]

.NET ModelKit Suite ClassReference
SubReportBase Members
SubReportBase Class Constructors Methods Properties Events See Also Send Feedback

The SubReportBase type exposes the following members.

Constructors

Name | Description
SubReportBase | Initializes a new instance of the SubReportBase class

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Overridden. See CheckConditions()()(). (Overrides Section..::.CheckConditions()()().)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Overridden. See GetSectionCaptionColor()()(). (Overrides Section..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetTemplate | Returns document template.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Overrides RegularBandBase..::.IsValidChild(ReportControl).)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Overrides ReportControl..::.Render()()().)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Shift | Gets or sets shif for sub-report elements.
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

SubReportBase Class
PerpetuumSoft.Reporting.DOM Namespace


SubReportBase Constructor

[image]

.NET ModelKit Suite ClassReference
SubReportBase Constructor
SubReportBase Class See Also Send Feedback
Initializes a new instance of the SubReportBase class

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected SubReportBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
SubReportBase()

See Also

SubReportBase Class
PerpetuumSoft.Reporting.DOM Namespace


SubReportBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
SubReportBase Methods
SubReportBase Class See Also Send Feedback

The SubReportBase type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Overridden. See CheckConditions()()(). (Overrides Section..::.CheckConditions()()().)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Overridden. See GetSectionCaptionColor()()(). (Overrides Section..::.GetSectionCaptionColor()()().)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetTemplate | Returns document template.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidChild | Implements IsValidChild(ReportControl). (Overrides RegularBandBase..::.IsValidChild(ReportControl).)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs drawing of the band. (Inherited from BandBase.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Overrides ReportControl..::.Render()()().)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

See Also

SubReportBase Class
PerpetuumSoft.Reporting.DOM Namespace


CheckConditions Method

[image]

.NET ModelKit Suite ClassReference
SubReportBase..::.CheckConditions Method
SubReportBase Class See Also Send Feedback
Overridden. See CheckConditions()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override bool CheckConditions()
Visual Basic (Declaration)
Protected Overrides Function CheckConditions As Boolean
Visual C++
protected:
virtual bool CheckConditions() override

See Also

SubReportBase Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
SubReportBase..::.GetScripts Method
SubReportBase Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

SubReportBase Class
SubReportBase Members
PerpetuumSoft.Reporting.DOM Namespace


GetSectionCaptionColor Method

[image]

.NET ModelKit Suite ClassReference
SubReportBase..::.GetSectionCaptionColor Method
SubReportBase Class See Also Send Feedback
Overridden. See GetSectionCaptionColor()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Color GetSectionCaptionColor()
Visual Basic (Declaration)
Protected Overrides Function GetSectionCaptionColor As Color
Visual C++
protected:
virtual Color GetSectionCaptionColor() override

See Also

SubReportBase Class
PerpetuumSoft.Reporting.DOM Namespace


GetTemplate Method

[image]

.NET ModelKit Suite ClassReference
SubReportBase..::.GetTemplate Method
SubReportBase Class See Also Send Feedback
Returns document template.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected abstract Document GetTemplate()
Visual Basic (Declaration)
Protected MustOverride Function GetTemplate As Document
Visual C++
protected:
virtual Document^ GetTemplate() abstract

See Also

SubReportBase Class
PerpetuumSoft.Reporting.DOM Namespace


IsValidChild Method

[image]

.NET ModelKit Suite ClassReference
SubReportBase..::.IsValidChild Method
SubReportBase Class See Also Send Feedback
Implements IsValidChild(ReportControl).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValidChild(
    ReportControl c
)
Visual Basic (Declaration)
Public Overrides Function IsValidChild ( _
    c As ReportControl _
) As Boolean
Visual C++
public:
virtual bool IsValidChild(
    ReportControl^ c
) override

Parameters

c
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

Implements

IContainerControl..::.IsValidChild(ReportControl)

See Also

SubReportBase Class
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
SubReportBase..::.Render Method
SubReportBase Class See Also Send Feedback
Overridden. See Render()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

SubReportBase Class
PerpetuumSoft.Reporting.DOM Namespace


SubReportBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
SubReportBase Properties
SubReportBase Class See Also Send Feedback

The SubReportBase type exposes the following members.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Shift | Gets or sets shif for sub-report elements.
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

SubReportBase Class
PerpetuumSoft.Reporting.DOM Namespace


Shift Property

[image]

.NET ModelKit Suite ClassReference
SubReportBase..::.Shift Property
SubReportBase Class See Also Send Feedback
Gets or sets shif for sub-report elements.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double Shift { get; set; }
Visual Basic (Declaration)
Public Property Shift As Double
Visual C++
public:
property double Shift {
    double get ();
    void set (double value);
}

See Also

SubReportBase Class
PerpetuumSoft.Reporting.DOM Namespace


SubReportBase Events

[image] [image]

.NET ModelKit Suite ClassReference
SubReportBase Events
SubReportBase Class See Also Send Feedback

The SubReportBase type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

SubReportBase Class
PerpetuumSoft.Reporting.DOM Namespace


SubReportParameter Class

[image]

.NET ModelKit Suite ClassReference
SubReportParameter Class
Members See Also Send Feedback
Represents parameters for SubReport element.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class SubReportParameter : ICloneable
Visual Basic (Declaration)
Public Class SubReportParameter _
    Implements ICloneable
Visual C++
public ref class SubReportParameter : ICloneable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.SubReportParameter

See Also

SubReportParameter Members
PerpetuumSoft.Reporting.DOM Namespace


SubReportParameter Members

[image] [image]

.NET ModelKit Suite ClassReference
SubReportParameter Members
SubReportParameter Class Constructors Methods Properties See Also Send Feedback

The SubReportParameter type exposes the following members.

Constructors

Name | Description
SubReportParameter | Overloaded.

Methods

Name | Description
Clone | Implements Clone()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
Expression | Gets or sets expression for parameter.
Name | Gets or sets parameter name.
Value | Gets or sets parameter value.

See Also

SubReportParameter Class
PerpetuumSoft.Reporting.DOM Namespace


SubReportParameter Constructor

[image] [image]

.NET ModelKit Suite ClassReference
SubReportParameter Constructor
SubReportParameter Class See Also Send Feedback

Overload List

Name | Description
SubReportParameter()()() | Initializes a new instance of the SubReportParameter class.
SubReportParameter(String, Object, String) | Initializes a new instance of the SubReportParameter class.

See Also

SubReportParameter Class
SubReportParameter Members
PerpetuumSoft.Reporting.DOM Namespace


SubReportParameter Constructor

[image]

.NET ModelKit Suite ClassReference
SubReportParameter Constructor
SubReportParameter Class See Also Send Feedback
Initializes a new instance of the SubReportParameter class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public SubReportParameter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SubReportParameter()

See Also

SubReportParameter Class
SubReportParameter Overload
PerpetuumSoft.Reporting.DOM Namespace


SubReportParameter Constructor (String, Object, String)

[image]

.NET ModelKit Suite ClassReference
SubReportParameter Constructor (String, Object, String)
SubReportParameter Class See Also Send Feedback
Initializes a new instance of the SubReportParameter class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public SubReportParameter(
    string name,
    Object value,
    string expression
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    value As Object, _
    expression As String _
)
Visual C++
public:
SubReportParameter(
    String^ name,
    Object^ value,
    String^ expression
)

Parameters

name
Type: System..::.String
value
Type: System..::.Object
expression
Type: System..::.String

See Also

SubReportParameter Class
SubReportParameter Overload
PerpetuumSoft.Reporting.DOM Namespace


SubReportParameter Methods

[image] [image]

.NET ModelKit Suite ClassReference
SubReportParameter Methods
SubReportParameter Class See Also Send Feedback

The SubReportParameter type exposes the following members.

Methods

Name | Description
Clone | Implements Clone()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

SubReportParameter Class
PerpetuumSoft.Reporting.DOM Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
SubReportParameter..::.Clone Method
SubReportParameter Class See Also Send Feedback
Implements Clone()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Implements

ICloneable..::.Clone()()()

See Also

SubReportParameter Class
PerpetuumSoft.Reporting.DOM Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
SubReportParameter..::.ToString Method
SubReportParameter Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

SubReportParameter Class
PerpetuumSoft.Reporting.DOM Namespace


SubReportParameter Properties

[image] [image]

.NET ModelKit Suite ClassReference
SubReportParameter Properties
SubReportParameter Class See Also Send Feedback

The SubReportParameter type exposes the following members.

Properties

Name | Description
Expression | Gets or sets expression for parameter.
Name | Gets or sets parameter name.
Value | Gets or sets parameter value.

See Also

SubReportParameter Class
PerpetuumSoft.Reporting.DOM Namespace


Expression Property

[image]

.NET ModelKit Suite ClassReference
SubReportParameter..::.Expression Property
SubReportParameter Class See Also Send Feedback
Gets or sets expression for parameter.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

See Also

SubReportParameter Class
PerpetuumSoft.Reporting.DOM Namespace


Name Property

[image]

.NET ModelKit Suite ClassReference
SubReportParameter..::.Name Property
SubReportParameter Class See Also Send Feedback
Gets or sets parameter name.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

SubReportParameter Class
PerpetuumSoft.Reporting.DOM Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
SubReportParameter..::.Value Property
SubReportParameter Class See Also Send Feedback
Gets or sets parameter value.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

SubReportParameter Class
PerpetuumSoft.Reporting.DOM Namespace


SubReportParameterCollection Class

[image]

.NET ModelKit Suite ClassReference
SubReportParameterCollection Class
Members See Also Send Feedback
Represents collection of SubReportParameter.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
[SerializableAttribute]
public class SubReportParameterCollection : CollectionBase
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SubReportParameterCollection _
    Inherits CollectionBase
Visual C++
[SerializableAttribute]
public ref class SubReportParameterCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Reporting.DOM..::.SubReportParameterCollection

See Also

SubReportParameterCollection Members
PerpetuumSoft.Reporting.DOM Namespace


SubReportParameterCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
SubReportParameterCollection Members
SubReportParameterCollection Class Constructors Methods Properties See Also Send Feedback

The SubReportParameterCollection type exposes the following members.

Constructors

Name | Description
SubReportParameterCollection | Overloaded.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

SubReportParameterCollection Class
PerpetuumSoft.Reporting.DOM Namespace


SubReportParameterCollection Constructor

[image] [image]

.NET ModelKit Suite ClassReference
SubReportParameterCollection Constructor
SubReportParameterCollection Class See Also Send Feedback

Overload List

Name | Description
SubReportParameterCollection()()() | Initializes a new instance of the SubReportParameterCollection class.
SubReportParameterCollection(array<String>[]()[], array<Object>[]()[], array<String>[]()[]) | Initializes a new instance of the SubReportParameterCollection class.

See Also

SubReportParameterCollection Class
SubReportParameterCollection Members
PerpetuumSoft.Reporting.DOM Namespace


SubReportParameterCollection Constructor

[image]

.NET ModelKit Suite ClassReference
SubReportParameterCollection Constructor
SubReportParameterCollection Class See Also Send Feedback
Initializes a new instance of the SubReportParameterCollection class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public SubReportParameterCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SubReportParameterCollection()

See Also

SubReportParameterCollection Class
SubReportParameterCollection Overload
PerpetuumSoft.Reporting.DOM Namespace


SubReportParameterCollection Constructor (String[], Object[], String[])

[image]

.NET ModelKit Suite ClassReference
SubReportParameterCollection Constructor (array<String>[]()[], array<Object>[]()[], array<String>[]()[])
SubReportParameterCollection Class See Also Send Feedback
Initializes a new instance of the SubReportParameterCollection class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public SubReportParameterCollection(
    string[] names,
    Object[] objects,
    string[] expressions
)
Visual Basic (Declaration)
Public Sub New ( _
    names As String(), _
    objects As Object(), _
    expressions As String() _
)
Visual C++
public:
SubReportParameterCollection(
    array<String^>^ names,
    array<Object^>^ objects,
    array<String^>^ expressions
)

Parameters

names
Type: array< System..::.String >[]()[]
objects
Type: array< System..::.Object >[]()[]
expressions
Type: array< System..::.String >[]()[]

See Also

SubReportParameterCollection Class
SubReportParameterCollection Overload
PerpetuumSoft.Reporting.DOM Namespace


SubReportParameterCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
SubReportParameterCollection Methods
SubReportParameterCollection Class See Also Send Feedback

The SubReportParameterCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubReportParameterCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Add Method

[image] [image]

.NET ModelKit Suite ClassReference
SubReportParameterCollection..::.Add Method
SubReportParameterCollection Class See Also Send Feedback

Overload List

Name | Description
Add(SubReportParameter) | Implements Add(Object).
Add(String, Object, String) | Adds a new parameter to the collection.

See Also

SubReportParameterCollection Class
SubReportParameterCollection Members
PerpetuumSoft.Reporting.DOM Namespace


Add Method (SubReportParameter)

[image]

.NET ModelKit Suite ClassReference
SubReportParameterCollection..::.Add Method (SubReportParameter)
SubReportParameterCollection Class See Also Send Feedback
Implements Add(Object).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Add(
    SubReportParameter parameter
)
Visual Basic (Declaration)
Public Sub Add ( _
    parameter As SubReportParameter _
)
Visual C++
public:
void Add(
    SubReportParameter^ parameter
)

Parameters

parameter
Type: PerpetuumSoft.Reporting.DOM..::.SubReportParameter

See Also

SubReportParameterCollection Class
Add Overload
PerpetuumSoft.Reporting.DOM Namespace


Add Method (String, Object, String)

[image]

.NET ModelKit Suite ClassReference
SubReportParameterCollection..::.Add Method (String, Object, String)
SubReportParameterCollection Class See Also Send Feedback
Adds a new parameter to the collection.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Add(
    string name,
    Object value,
    string expression
)
Visual Basic (Declaration)
Public Sub Add ( _
    name As String, _
    value As Object, _
    expression As String _
)
Visual C++
public:
void Add(
    String^ name,
    Object^ value,
    String^ expression
)

Parameters

name
Type: System..::.String
value
Type: System..::.Object
expression
Type: System..::.String

See Also

SubReportParameterCollection Class
Add Overload
PerpetuumSoft.Reporting.DOM Namespace


SubReportParameterCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
SubReportParameterCollection Properties
SubReportParameterCollection Class See Also Send Feedback

The SubReportParameterCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

SubReportParameterCollection Class
PerpetuumSoft.Reporting.DOM Namespace


Item Property

[image] [image]

.NET ModelKit Suite ClassReference
SubReportParameterCollection..::.Item Property
SubReportParameterCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Implements Item[([(Int32])]).
Item[([(String])]) | Gets SubReportParameter by specified name.

See Also

SubReportParameterCollection Class
SubReportParameterCollection Members
PerpetuumSoft.Reporting.DOM Namespace


Item Property (Int32)

[image]

.NET ModelKit Suite ClassReference
SubReportParameterCollection..::.Item Property (Int32)
SubReportParameterCollection Class See Also Send Feedback
Implements Item[([(Int32])]).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public SubReportParameter this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As SubReportParameter
Visual C++
public:
property SubReportParameter^ default[int index] {
    SubReportParameter^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

SubReportParameterCollection Class
Item Overload
PerpetuumSoft.Reporting.DOM Namespace


Item Property (String)

[image]

.NET ModelKit Suite ClassReference
SubReportParameterCollection..::.Item Property (String)
SubReportParameterCollection Class See Also Send Feedback
Gets SubReportParameter by specified name.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public SubReportParameter this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As SubReportParameter
Visual C++
public:
property SubReportParameter^ default[String^ name] {
    SubReportParameter^ get (String^ name);
}

Parameters

name
Type: System..::.String

See Also

SubReportParameterCollection Class
Item Overload
PerpetuumSoft.Reporting.DOM Namespace


TextBox Class

[image]

.NET ModelKit Suite ClassReference
TextBox Class
Members See Also Send Feedback
Represents a boxed text control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class TextBox : TextControl
Visual Basic (Declaration)
Public Class TextBox _
    Inherits TextControl
Visual C++
public ref class TextBox : public TextControl

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.VisualControl
PerpetuumSoft.Reporting.DOM..::.Box
PerpetuumSoft.Reporting.DOM..::.TextControl
PerpetuumSoft.Reporting.DOM..::.TextBox

See Also

TextBox Members
PerpetuumSoft.Reporting.DOM Namespace


TextBox Members

[image] [image]

.NET ModelKit Suite ClassReference
TextBox Members
TextBox Class Constructors Methods Fields Properties Events See Also Send Feedback

The TextBox type exposes the following members.

Constructors

Name | Description
TextBox | Creates a new instance of TextBox class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the final rendered control. (Inherited from TextControl.)
CalculateTextHeight | Returns text height. (Overrides TextControl..::.CalculateTextHeight(Graphics).)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Overridden. See CreateBlankControl()()(). (Overrides ReportControl..::.CreateBlankControl()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Searches the text control for the specified text based on the specified search options. (Overrides ReportControl..::.FindText(String, FindTextOptions).)
GetDesignerToolTip | Overridden. See GetDesignerToolTip()()(). (Overrides ReportControl..::.GetDesignerToolTip()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of a TextBox object created with visual tools such as Report Designer. (Overrides ReportControl..::.InitNew()()().)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed. (Inherited from Box.)
OnFontChanged | Executes if font was changed. (Inherited from TextControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
OnTextAlignmentChanged | Executes if text alignment was changed. (Inherited from TextControl.)
OnTextFillChanged | Executes if text fill was changed. (Inherited from TextControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Paints text control content. (Inherited from TextControl.)
PaintText | Overridden. See PaintText(Graphics, Brush, VectorRectangle). (Overrides TextControl..::.PaintText(Graphics, Brush, VectorRectangle).)
PopulateProperties | Fills the properties of the final rendered control. (Overrides TextControl..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
RunPropertyDesigner | Overridden. See RunPropertyDesigner(IReportDesignerService). (Overrides ReportControlRunPropertyDesigner(IReportDesignerService).)
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DefaultFont | Default font. (Inherited from TextControl.)

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the control can grow in size during rendering to match a bigger size of its rendered content regardless of the control's size in the report template. (Inherited from TextControl.)
CanShrink | Gets and sets whether the control can shrink in size during rendering to match a smaller size of its rendered content regardless of the control's size in the report template. (Inherited from TextControl.)
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
Font | Gets and sets the font for the text control. (Inherited from TextControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
RightToLeft | Indicates whether the control text is printed right-to-left. (Inherited from TextControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StringTrimming | Gets or sets a value indicating how to trim characters from a string that does not completely fit into a TextBox.
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
Text | Gets and sets a string that contains the text.
TextAlign | Gets and sets alignment for the text. (Inherited from TextControl.)
TextFill | Gets and sets the pattern for filling the text. (Inherited from TextControl.)
TextFormat | Gets and sets the text format for the text control. (Inherited from TextControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Value | Gets or sets value that will be displayed.
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

TextBox Class
PerpetuumSoft.Reporting.DOM Namespace


TextBox Constructor

[image]

.NET ModelKit Suite ClassReference
TextBox Constructor
TextBox Class See Also Send Feedback
Creates a new instance of TextBox class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public TextBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextBox()

See Also

TextBox Class
PerpetuumSoft.Reporting.DOM Namespace


TextBox Fields

[image] [image]

.NET ModelKit Suite ClassReference
TextBox Fields
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Fields

Name | Description
DefaultFont | Default font. (Inherited from TextControl.)

See Also

TextBox Class
PerpetuumSoft.Reporting.DOM Namespace


TextBox Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextBox Methods
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the final rendered control. (Inherited from TextControl.)
CalculateTextHeight | Returns text height. (Overrides TextControl..::.CalculateTextHeight(Graphics).)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Overridden. See CreateBlankControl()()(). (Overrides ReportControl..::.CreateBlankControl()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Searches the text control for the specified text based on the specified search options. (Overrides ReportControl..::.FindText(String, FindTextOptions).)
GetDesignerToolTip | Overridden. See GetDesignerToolTip()()(). (Overrides ReportControl..::.GetDesignerToolTip()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of a TextBox object created with visual tools such as Report Designer. (Overrides ReportControl..::.InitNew()()().)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed. (Inherited from Box.)
OnFontChanged | Executes if font was changed. (Inherited from TextControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
OnTextAlignmentChanged | Executes if text alignment was changed. (Inherited from TextControl.)
OnTextFillChanged | Executes if text fill was changed. (Inherited from TextControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Paints text control content. (Inherited from TextControl.)
PaintText | Overridden. See PaintText(Graphics, Brush, VectorRectangle). (Overrides TextControl..::.PaintText(Graphics, Brush, VectorRectangle).)
PopulateProperties | Fills the properties of the final rendered control. (Overrides TextControl..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
RunPropertyDesigner | Overridden. See RunPropertyDesigner(IReportDesignerService). (Overrides ReportControlRunPropertyDesigner(IReportDesignerService).)
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextBox Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateTextHeight Method

[image]

.NET ModelKit Suite ClassReference
TextBox..::.CalculateTextHeight Method
TextBox Class See Also Send Feedback
Returns text height.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override float CalculateTextHeight(
    Graphics g
)
Visual Basic (Declaration)
Protected Overrides Function CalculateTextHeight ( _
    g As Graphics _
) As Single
Visual C++
protected:
virtual float CalculateTextHeight(
    Graphics^ g
) override

Parameters

g
Type: System.Drawing..::.Graphics

See Also

TextBox Class
PerpetuumSoft.Reporting.DOM Namespace


CreateBlankControl Method

[image]

.NET ModelKit Suite ClassReference
TextBox..::.CreateBlankControl Method
TextBox Class See Also Send Feedback
Overridden. See CreateBlankControl()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override ReportControl CreateBlankControl()
Visual Basic (Declaration)
Protected Overrides Function CreateBlankControl As ReportControl
Visual C++
protected:
virtual ReportControl^ CreateBlankControl() override

See Also

TextBox Class
PerpetuumSoft.Reporting.DOM Namespace


FindText Method

[image]

.NET ModelKit Suite ClassReference
TextBox..::.FindText Method
TextBox Class See Also Send Feedback
Searches the text control for the specified text based on the specified search options.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool FindText(
    string pattern,
    FindTextOptions options
)
Visual Basic (Declaration)
Public Overrides Function FindText ( _
    pattern As String, _
    options As FindTextOptions _
) As Boolean
Visual C++
public:
virtual bool FindText(
    String^ pattern,
    FindTextOptions^ options
) override

Parameters

pattern
Type: System..::.String
options
Type: PerpetuumSoft.Reporting.DOM..::.FindTextOptions

See Also

TextBox Class
PerpetuumSoft.Reporting.DOM Namespace


GetDesignerToolTip Method

[image]

.NET ModelKit Suite ClassReference
TextBox..::.GetDesignerToolTip Method
TextBox Class See Also Send Feedback
Overridden. See GetDesignerToolTip()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetDesignerToolTip()
Visual Basic (Declaration)
Public Overrides Function GetDesignerToolTip As String
Visual C++
public:
virtual String^ GetDesignerToolTip() override

See Also

TextBox Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
TextBox..::.GetScripts Method
TextBox Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

TextBox Class
TextBox Members
PerpetuumSoft.Reporting.DOM Namespace


InitNew Method

[image]

.NET ModelKit Suite ClassReference
TextBox..::.InitNew Method
TextBox Class See Also Send Feedback
Sets the predefined values for the properties of a TextBox object created with visual tools such as Report Designer.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void InitNew()
Visual Basic (Declaration)
Public Overrides Sub InitNew
Visual C++
public:
virtual void InitNew() override

See Also

TextBox Class
PerpetuumSoft.Reporting.DOM Namespace


PaintText Method

[image]

.NET ModelKit Suite ClassReference
TextBox..::.PaintText Method
TextBox Class See Also Send Feedback
Overridden. See PaintText(Graphics, Brush, VectorRectangle).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PaintText(
    Graphics g,
    Brush textBrush,
    VectorRectangle textRect
)
Visual Basic (Declaration)
Protected Overrides Sub PaintText ( _
    g As Graphics, _
    textBrush As Brush, _
    textRect As VectorRectangle _
)
Visual C++
protected:
virtual void PaintText(
    Graphics^ g,
    Brush^ textBrush,
    VectorRectangle textRect
) override

Parameters

g
Type: System.Drawing..::.Graphics
textBrush
Type: System.Drawing..::.Brush
textRect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

TextBox Class
PerpetuumSoft.Reporting.DOM Namespace


PopulateProperties Method

[image]

.NET ModelKit Suite ClassReference
TextBox..::.PopulateProperties Method
TextBox Class See Also Send Feedback
Fills the properties of the final rendered control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PopulateProperties(
    ReportControl production
)
Visual Basic (Declaration)
Protected Overrides Sub PopulateProperties ( _
    production As ReportControl _
)
Visual C++
protected:
virtual void PopulateProperties(
    ReportControl^ production
) override

Parameters

production
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

TextBox Class
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
TextBox..::.Render Method
TextBox Class See Also Send Feedback
Renders the control to the final document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

TextBox Class
PerpetuumSoft.Reporting.DOM Namespace


RunPropertyDesigner Method

[image]

.NET ModelKit Suite ClassReference
TextBox..::.RunPropertyDesigner Method
TextBox Class See Also Send Feedback
Overridden. See RunPropertyDesigner(IReportDesignerService).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void RunPropertyDesigner(
    IReportDesignerService service
)
Visual Basic (Declaration)
Public Overrides Sub RunPropertyDesigner ( _
    service As IReportDesignerService _
)
Visual C++
public:
virtual void RunPropertyDesigner(
    IReportDesignerService^ service
) override

Parameters

service
Type: PerpetuumSoft.Reporting.Designer..::.IReportDesignerService

See Also

TextBox Class
PerpetuumSoft.Reporting.DOM Namespace


TextBox Properties

[image] [image]

.NET ModelKit Suite ClassReference
TextBox Properties
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the control can grow in size during rendering to match a bigger size of its rendered content regardless of the control's size in the report template. (Inherited from TextControl.)
CanShrink | Gets and sets whether the control can shrink in size during rendering to match a smaller size of its rendered content regardless of the control's size in the report template. (Inherited from TextControl.)
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
Font | Gets and sets the font for the text control. (Inherited from TextControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
RightToLeft | Indicates whether the control text is printed right-to-left. (Inherited from TextControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StringTrimming | Gets or sets a value indicating how to trim characters from a string that does not completely fit into a TextBox.
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
Text | Gets and sets a string that contains the text.
TextAlign | Gets and sets alignment for the text. (Inherited from TextControl.)
TextFill | Gets and sets the pattern for filling the text. (Inherited from TextControl.)
TextFormat | Gets and sets the text format for the text control. (Inherited from TextControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Value | Gets or sets value that will be displayed.
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

TextBox Class
PerpetuumSoft.Reporting.DOM Namespace


StringTrimming Property

[image]

.NET ModelKit Suite ClassReference
TextBox..::.StringTrimming Property
TextBox Class See Also Send Feedback
Gets or sets a value indicating how to trim characters from a string that does not completely fit into a TextBox.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public StringTrimming StringTrimming { get; set; }
Visual Basic (Declaration)
Public Property StringTrimming As StringTrimming
Visual C++
public:
property StringTrimming StringTrimming {
    StringTrimming get ();
    void set (StringTrimming value);
}

See Also

TextBox Class
PerpetuumSoft.Reporting.DOM Namespace


Text Property

[image]

.NET ModelKit Suite ClassReference
TextBox..::.Text Property
TextBox Class See Also Send Feedback
Gets and sets a string that contains the text.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

TextBox Class
PerpetuumSoft.Reporting.DOM Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
TextBox..::.Value Property
TextBox Class See Also Send Feedback
Gets or sets value that will be displayed.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

TextBox Class
PerpetuumSoft.Reporting.DOM Namespace


TextBox Events

[image] [image]

.NET ModelKit Suite ClassReference
TextBox Events
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

TextBox Class
PerpetuumSoft.Reporting.DOM Namespace


TextControl Class

[image]

.NET ModelKit Suite ClassReference
TextControl Class
Members See Also Send Feedback
Base class for text elements.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract class TextControl : Box
Visual Basic (Declaration)
Public MustInherit Class TextControl _
    Inherits Box
Visual C++
public ref class TextControl abstract : public Box

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.VisualControl
PerpetuumSoft.Reporting.DOM..::.Box
PerpetuumSoft.Reporting.DOM..::.TextControl
PerpetuumSoft.Reporting.DOM..::.AdvancedText
PerpetuumSoft.Reporting.DOM..::.TextBox

See Also

TextControl Members
PerpetuumSoft.Reporting.DOM Namespace


TextControl Members

[image] [image]

.NET ModelKit Suite ClassReference
TextControl Members
TextControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The TextControl type exposes the following members.

Constructors

Name | Description
TextControl | Initializes a new instance of the TextControl class

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the final rendered control. (Overrides ReportControl..::.CalculateRenderHeight()()().)
CalculateTextHeight | When overriden in the derived classes returns text height.
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed. (Inherited from Box.)
OnFontChanged | Executes if font was changed.
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
OnTextAlignmentChanged | Executes if text alignment was changed.
OnTextFillChanged | Executes if text fill was changed.
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Paints text control content. (Overrides Box..::.PaintContent(PaintArguments, RectangleF).)
PaintText | Paints TextControl text on given rectangle with given brush.
PopulateProperties | Fills the properties of the final rendered control. (Overrides Box..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Inherited from ReportControl.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DefaultFont | Default font.

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the control can grow in size during rendering to match a bigger size of its rendered content regardless of the control's size in the report template.
CanShrink | Gets and sets whether the control can shrink in size during rendering to match a smaller size of its rendered content regardless of the control's size in the report template.
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
Font | Gets and sets the font for the text control.
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
RightToLeft | Indicates whether the control text is printed right-to-left.
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
TextAlign | Gets and sets alignment for the text.
TextFill | Gets and sets the pattern for filling the text.
TextFormat | Gets and sets the text format for the text control.
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


TextControl Constructor

[image]

.NET ModelKit Suite ClassReference
TextControl Constructor
TextControl Class See Also Send Feedback
Initializes a new instance of the TextControl class

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected TextControl()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
TextControl()

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


TextControl Fields

[image] [image]

.NET ModelKit Suite ClassReference
TextControl Fields
TextControl Class See Also Send Feedback

The TextControl type exposes the following members.

Fields

Name | Description
DefaultFont | Default font.

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


DefaultFont Field

[image]

.NET ModelKit Suite ClassReference
TextControl..::.DefaultFont Field
TextControl Class See Also Send Feedback
Default font.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected readonly FontDescriptor DefaultFont
Visual Basic (Declaration)
Protected ReadOnly DefaultFont As FontDescriptor
Visual C++
protected:
initonly FontDescriptor^ DefaultFont

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


TextControl Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextControl Methods
TextControl Class See Also Send Feedback

The TextControl type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the final rendered control. (Overrides ReportControl..::.CalculateRenderHeight()()().)
CalculateTextHeight | When overriden in the derived classes returns text height.
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed. (Inherited from Box.)
OnFontChanged | Executes if font was changed.
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
OnTextAlignmentChanged | Executes if text alignment was changed.
OnTextFillChanged | Executes if text fill was changed.
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Paints text control content. (Overrides Box..::.PaintContent(PaintArguments, RectangleF).)
PaintText | Paints TextControl text on given rectangle with given brush.
PopulateProperties | Fills the properties of the final rendered control. (Overrides Box..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Inherited from ReportControl.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateRenderHeight Method

[image]

.NET ModelKit Suite ClassReference
TextControl..::.CalculateRenderHeight Method
TextControl Class See Also Send Feedback
Calculates the height of the final rendered control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void CalculateRenderHeight()
Visual Basic (Declaration)
Protected Overrides Sub CalculateRenderHeight
Visual C++
protected:
virtual void CalculateRenderHeight() override

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


CalculateTextHeight Method

[image]

.NET ModelKit Suite ClassReference
TextControl..::.CalculateTextHeight Method
TextControl Class See Also Send Feedback
When overriden in the derived classes returns text height.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected abstract float CalculateTextHeight(
    Graphics g
)
Visual Basic (Declaration)
Protected MustOverride Function CalculateTextHeight ( _
    g As Graphics _
) As Single
Visual C++
protected:
virtual float CalculateTextHeight(
    Graphics^ g
) abstract

Parameters

g
Type: System.Drawing..::.Graphics

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
TextControl..::.GetScripts Method
TextControl Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

TextControl Class
TextControl Members
PerpetuumSoft.Reporting.DOM Namespace


OnFontChanged Method

[image]

.NET ModelKit Suite ClassReference
TextControl..::.OnFontChanged Method
TextControl Class See Also Send Feedback
Executes if font was changed.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnFontChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnFontChanged
Visual C++
protected:
virtual void OnFontChanged()

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


OnTextAlignmentChanged Method

[image]

.NET ModelKit Suite ClassReference
TextControl..::.OnTextAlignmentChanged Method
TextControl Class See Also Send Feedback
Executes if text alignment was changed.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnTextAlignmentChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnTextAlignmentChanged
Visual C++
protected:
virtual void OnTextAlignmentChanged()

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


OnTextFillChanged Method

[image]

.NET ModelKit Suite ClassReference
TextControl..::.OnTextFillChanged Method
TextControl Class See Also Send Feedback
Executes if text fill was changed.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnTextFillChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnTextFillChanged
Visual C++
protected:
virtual void OnTextFillChanged()

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


PaintContent Method

[image]

.NET ModelKit Suite ClassReference
TextControl..::.PaintContent Method
TextControl Class See Also Send Feedback
Paints text control content.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PaintContent(
    PaintArguments args,
    RectangleF contentRectangle
)
Visual Basic (Declaration)
Protected Overrides Sub PaintContent ( _
    args As PaintArguments, _
    contentRectangle As RectangleF _
)
Visual C++
protected:
virtual void PaintContent(
    PaintArguments^ args,
    RectangleF contentRectangle
) override

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments
contentRectangle
Type: System.Drawing..::.RectangleF

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


PaintText Method

[image]

.NET ModelKit Suite ClassReference
TextControl..::.PaintText Method
TextControl Class See Also Send Feedback
Paints TextControl text on given rectangle with given brush.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected abstract void PaintText(
    Graphics g,
    Brush textBrush,
    VectorRectangle textRect
)
Visual Basic (Declaration)
Protected MustOverride Sub PaintText ( _
    g As Graphics, _
    textBrush As Brush, _
    textRect As VectorRectangle _
)
Visual C++
protected:
virtual void PaintText(
    Graphics^ g,
    Brush^ textBrush,
    VectorRectangle textRect
) abstract

Parameters

g
Type: System.Drawing..::.Graphics
textBrush
Type: System.Drawing..::.Brush
textRect
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


PopulateProperties Method

[image]

.NET ModelKit Suite ClassReference
TextControl..::.PopulateProperties Method
TextControl Class See Also Send Feedback
Fills the properties of the final rendered control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PopulateProperties(
    ReportControl production
)
Visual Basic (Declaration)
Protected Overrides Sub PopulateProperties ( _
    production As ReportControl _
)
Visual C++
protected:
virtual void PopulateProperties(
    ReportControl^ production
) override

Parameters

production
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


TextControl Properties

[image] [image]

.NET ModelKit Suite ClassReference
TextControl Properties
TextControl Class See Also Send Feedback

The TextControl type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the control can grow in size during rendering to match a bigger size of its rendered content regardless of the control's size in the report template.
CanShrink | Gets and sets whether the control can shrink in size during rendering to match a smaller size of its rendered content regardless of the control's size in the report template.
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
Font | Gets and sets the font for the text control.
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
RightToLeft | Indicates whether the control text is printed right-to-left.
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
TextAlign | Gets and sets alignment for the text.
TextFill | Gets and sets the pattern for filling the text.
TextFormat | Gets and sets the text format for the text control.
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


CanGrow Property

[image]

.NET ModelKit Suite ClassReference
TextControl..::.CanGrow Property
TextControl Class See Also Send Feedback
Gets and sets whether the control can grow in size during rendering to match a bigger size of its rendered content regardless of the control's size in the report template.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool CanGrow { get; set; }
Visual Basic (Declaration)
Public Property CanGrow As Boolean
Visual C++
public:
property bool CanGrow {
    bool get ();
    void set (bool value);
}

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


CanShrink Property

[image]

.NET ModelKit Suite ClassReference
TextControl..::.CanShrink Property
TextControl Class See Also Send Feedback
Gets and sets whether the control can shrink in size during rendering to match a smaller size of its rendered content regardless of the control's size in the report template.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool CanShrink { get; set; }
Visual Basic (Declaration)
Public Property CanShrink As Boolean
Visual C++
public:
property bool CanShrink {
    bool get ();
    void set (bool value);
}

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


Font Property

[image]

.NET ModelKit Suite ClassReference
TextControl..::.Font Property
TextControl Class See Also Send Feedback
Gets and sets the font for the text control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FontDescriptor Font { get; set; }
Visual Basic (Declaration)
Public Property Font As FontDescriptor
Visual C++
public:
property FontDescriptor^ Font {
    FontDescriptor^ get ();
    void set (FontDescriptor^ value);
}

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


RightToLeft Property

[image]

.NET ModelKit Suite ClassReference
TextControl..::.RightToLeft Property
TextControl Class See Also Send Feedback
Indicates whether the control text is printed right-to-left.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool RightToLeft { get; set; }
Visual Basic (Declaration)
Public Property RightToLeft As Boolean
Visual C++
public:
property bool RightToLeft {
    bool get ();
    void set (bool value);
}

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


TextAlign Property

[image]

.NET ModelKit Suite ClassReference
TextControl..::.TextAlign Property
TextControl Class See Also Send Feedback
Gets and sets alignment for the text.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ContentAlignment TextAlign { get; set; }
Visual Basic (Declaration)
Public Property TextAlign As ContentAlignment
Visual C++
public:
property ContentAlignment TextAlign {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


TextFill Property

[image]

.NET ModelKit Suite ClassReference
TextControl..::.TextFill Property
TextControl Class See Also Send Feedback
Gets and sets the pattern for filling the text.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Fill TextFill { get; set; }
Visual Basic (Declaration)
Public Property TextFill As Fill
Visual C++
public:
property Fill^ TextFill {
    Fill^ get ();
    void set (Fill^ value);
}

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


TextFormat Property

[image]

.NET ModelKit Suite ClassReference
TextControl..::.TextFormat Property
TextControl Class See Also Send Feedback
Gets and sets the text format for the text control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public TextFormat TextFormat { get; set; }
Visual Basic (Declaration)
Public Property TextFormat As TextFormat
Visual C++
public:
property TextFormat^ TextFormat {
    TextFormat^ get ();
    void set (TextFormat^ value);
}

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


TextControl Events

[image] [image]

.NET ModelKit Suite ClassReference
TextControl Events
TextControl Class See Also Send Feedback

The TextControl type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

TextControl Class
PerpetuumSoft.Reporting.DOM Namespace


VisualControl Class

[image]

.NET ModelKit Suite ClassReference
VisualControl Class
Members See Also Send Feedback
Base class for all visual controls.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class VisualControl : ReportControl
Visual Basic (Declaration)
Public Class VisualControl _
    Inherits ReportControl
Visual C++
public ref class VisualControl : public ReportControl

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.VisualControl
PerpetuumSoft.Reporting.DOM..::.Box
PerpetuumSoft.Reporting.DOM..::.Shape

See Also

VisualControl Members
PerpetuumSoft.Reporting.DOM Namespace


VisualControl Members

[image] [image]

.NET ModelKit Suite ClassReference
VisualControl Members
VisualControl Class Constructors Methods Properties Events See Also Send Feedback

The VisualControl type exposes the following members.

Constructors

Name | Description
VisualControl | Creates a new instance of VisualControl class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Overrides ReportControlGrowRenderHeight(Double).)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs control drawing. (Inherited from ReportControl.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Inherited from ReportControl.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas.
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template.
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

VisualControl Class
PerpetuumSoft.Reporting.DOM Namespace


VisualControl Constructor

[image]

.NET ModelKit Suite ClassReference
VisualControl Constructor
VisualControl Class See Also Send Feedback
Creates a new instance of VisualControl class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public VisualControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VisualControl()

See Also

VisualControl Class
PerpetuumSoft.Reporting.DOM Namespace


VisualControl Methods

[image] [image]

.NET ModelKit Suite ClassReference
VisualControl Methods
VisualControl Class See Also Send Feedback

The VisualControl type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Overrides ReportControlGrowRenderHeight(Double).)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Performs control drawing. (Inherited from ReportControl.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Inherited from ReportControl.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VisualControl Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
VisualControl..::.GetScripts Method
VisualControl Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

VisualControl Class
VisualControl Members
PerpetuumSoft.Reporting.DOM Namespace


GrowRenderHeight Method

[image]

.NET ModelKit Suite ClassReference
VisualControl..::.GrowRenderHeight Method
VisualControl Class See Also Send Feedback
Overridden. See GrowRenderHeight(Double).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void GrowRenderHeight(
    double parentRenderHeight
)
Visual Basic (Declaration)
Public Overrides Sub GrowRenderHeight ( _
    parentRenderHeight As Double _
)
Visual C++
public:
virtual void GrowRenderHeight(
    double parentRenderHeight
) override

Parameters

parentRenderHeight
Type: System..::.Double

See Also

VisualControl Class
PerpetuumSoft.Reporting.DOM Namespace


VisualControl Properties

[image] [image]

.NET ModelKit Suite ClassReference
VisualControl Properties
VisualControl Class See Also Send Feedback

The VisualControl type exposes the following members.

Properties

Name | Description
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas.
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template.
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

VisualControl Class
PerpetuumSoft.Reporting.DOM Namespace


DisplayRectangle Property

[image]

.NET ModelKit Suite ClassReference
VisualControl..::.DisplayRectangle Property
VisualControl Class See Also Send Feedback
Gets the rectangle for displaying the control on the canvas.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public RectangleF DisplayRectangle { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayRectangle As RectangleF
Visual C++
public:
property RectangleF DisplayRectangle {
    RectangleF get ();
}

See Also

VisualControl Class
PerpetuumSoft.Reporting.DOM Namespace


GrowToBottom Property

[image]

.NET ModelKit Suite ClassReference
VisualControl..::.GrowToBottom Property
VisualControl Class See Also Send Feedback
Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool GrowToBottom { get; set; }
Visual Basic (Declaration)
Public Property GrowToBottom As Boolean
Visual C++
public:
property bool GrowToBottom {
    bool get ();
    void set (bool value);
}

See Also

VisualControl Class
PerpetuumSoft.Reporting.DOM Namespace


VisualControl Events

[image] [image]

.NET ModelKit Suite ClassReference
VisualControl Events
VisualControl Class See Also Send Feedback

The VisualControl type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

VisualControl Class
PerpetuumSoft.Reporting.DOM Namespace


Widget Class

[image]

.NET ModelKit Suite ClassReference
Widget Class
Members See Also Send Feedback
Provides report element for displaying an instrument from Instrumentation ModelKit.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Widget : Box
Visual Basic (Declaration)
Public Class Widget _
    Inherits Box
Visual C++
public ref class Widget : public Box

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.VisualControl
PerpetuumSoft.Reporting.DOM..::.Box
PerpetuumSoft.Reporting.DOM..::.Widget

See Also

Widget Members
PerpetuumSoft.Reporting.DOM Namespace


Widget Members

[image] [image]

.NET ModelKit Suite ClassReference
Widget Members
Widget Class Constructors Methods Properties Events See Also Send Feedback

The Widget type exposes the following members.

Constructors

Name | Description
Widget | Initializes a new instance of the Widget class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed. (Inherited from Box.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Draws element's content. (Overrides Box..::.PaintContent(PaintArguments, RectangleF).)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from Box.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Overridden. See Render()()(). (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
RunPropertyDesigner | Overridden. See RunPropertyDesigner(IReportDesignerService). (Overrides ReportControlRunPropertyDesigner(IReportDesignerService).)
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Instrument | Gets or sets the Instrument object representing the displayed instrument.
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

Widget Class
PerpetuumSoft.Reporting.DOM Namespace


Widget Constructor

[image]

.NET ModelKit Suite ClassReference
Widget Constructor
Widget Class See Also Send Feedback
Initializes a new instance of the Widget class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Widget()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Widget()

See Also

Widget Class
PerpetuumSoft.Reporting.DOM Namespace


Widget Methods

[image] [image]

.NET ModelKit Suite ClassReference
Widget Methods
Widget Class See Also Send Feedback

The Widget type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of the control created with visual tools such as Report Designer. (Inherited from ReportControl.)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed. (Inherited from Box.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Draws element's content. (Overrides Box..::.PaintContent(PaintArguments, RectangleF).)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from Box.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Overridden. See Render()()(). (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
RunPropertyDesigner | Overridden. See RunPropertyDesigner(IReportDesignerService). (Overrides ReportControlRunPropertyDesigner(IReportDesignerService).)
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Widget Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
Widget..::.GetScripts Method
Widget Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

Widget Class
Widget Members
PerpetuumSoft.Reporting.DOM Namespace


PaintContent Method

[image]

.NET ModelKit Suite ClassReference
Widget..::.PaintContent Method
Widget Class See Also Send Feedback
Draws element's content.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PaintContent(
    PaintArguments args,
    RectangleF contentRectangle
)
Visual Basic (Declaration)
Protected Overrides Sub PaintContent ( _
    args As PaintArguments, _
    contentRectangle As RectangleF _
)
Visual C++
protected:
virtual void PaintContent(
    PaintArguments^ args,
    RectangleF contentRectangle
) override

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments
contentRectangle
Type: System.Drawing..::.RectangleF

See Also

Widget Class
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
Widget..::.Render Method
Widget Class See Also Send Feedback
Overridden. See Render()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

Widget Class
PerpetuumSoft.Reporting.DOM Namespace


RunPropertyDesigner Method

[image]

.NET ModelKit Suite ClassReference
Widget..::.RunPropertyDesigner Method
Widget Class See Also Send Feedback
Overridden. See RunPropertyDesigner(IReportDesignerService).

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void RunPropertyDesigner(
    IReportDesignerService service
)
Visual Basic (Declaration)
Public Overrides Sub RunPropertyDesigner ( _
    service As IReportDesignerService _
)
Visual C++
public:
virtual void RunPropertyDesigner(
    IReportDesignerService^ service
) override

Parameters

service
Type: PerpetuumSoft.Reporting.Designer..::.IReportDesignerService

See Also

Widget Class
PerpetuumSoft.Reporting.DOM Namespace


Widget Properties

[image] [image]

.NET ModelKit Suite ClassReference
Widget Properties
Widget Class See Also Send Feedback

The Widget type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Instrument | Gets or sets the Instrument object representing the displayed instrument.
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

Widget Class
PerpetuumSoft.Reporting.DOM Namespace


Instrument Property

[image]

.NET ModelKit Suite ClassReference
Widget..::.Instrument Property
Widget Class See Also Send Feedback
Gets or sets the Instrument object representing the displayed instrument.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Instrument Instrument { get; set; }
Visual Basic (Declaration)
Public Property Instrument As Instrument
Visual C++
public:
property Instrument^ Instrument {
    Instrument^ get ();
    void set (Instrument^ value);
}

See Also

Widget Class
PerpetuumSoft.Reporting.DOM Namespace


Widget Events

[image] [image]

.NET ModelKit Suite ClassReference
Widget Events
Widget Class See Also Send Feedback

The Widget type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

Widget Class
PerpetuumSoft.Reporting.DOM Namespace


WinFormsControl Class

[image]

.NET ModelKit Suite ClassReference
WinFormsControl Class
Members See Also Send Feedback
Represents a Windows Forms control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class WinFormsControl : Box
Visual Basic (Declaration)
Public Class WinFormsControl _
    Inherits Box
Visual C++
public ref class WinFormsControl : public Box

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.VisualControl
PerpetuumSoft.Reporting.DOM..::.Box
PerpetuumSoft.Reporting.DOM..::.WinFormsControl

See Also

WinFormsControl Members
PerpetuumSoft.Reporting.DOM Namespace


WinFormsControl Members

[image] [image]

.NET ModelKit Suite ClassReference
WinFormsControl Members
WinFormsControl Class Constructors Methods Properties Events See Also Send Feedback

The WinFormsControl type exposes the following members.

Constructors

Name | Description
WinFormsControl | Creates a new instance of WinFormsControl class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Paints the content of the control. (Overrides ReportControl..::.InitNew()()().)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed. (Inherited from Box.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Overridden. See ['M:PerpetuumSoft.Reporting.DOM.Box.PaintContent(PerpetuumSoft.Reporting.DOM.PaintArguments,System.Drawing.RectangleF)]. (Overrides Box..::.PaintContent(PaintArguments, RectangleF).)
PopulateProperties | Fills the properties of the final rendered control. (Overrides Box..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
Control | Gets control that will displayed.
ControlTypeName | Gets and sets a string that represents the name of the type of the control.
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
Text | Gets and sets a text string for the control.
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

WinFormsControl Class
PerpetuumSoft.Reporting.DOM Namespace


WinFormsControl Constructor

[image]

.NET ModelKit Suite ClassReference
WinFormsControl Constructor
WinFormsControl Class See Also Send Feedback
Creates a new instance of WinFormsControl class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public WinFormsControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WinFormsControl()

See Also

WinFormsControl Class
PerpetuumSoft.Reporting.DOM Namespace


WinFormsControl Methods

[image] [image]

.NET ModelKit Suite ClassReference
WinFormsControl Methods
WinFormsControl Class See Also Send Feedback

The WinFormsControl type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Paints the content of the control. (Overrides ReportControl..::.InitNew()()().)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed. (Inherited from Box.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Overridden. See ['M:PerpetuumSoft.Reporting.DOM.Box.PaintContent(PerpetuumSoft.Reporting.DOM.PaintArguments,System.Drawing.RectangleF)]. (Overrides Box..::.PaintContent(PaintArguments, RectangleF).)
PopulateProperties | Fills the properties of the final rendered control. (Overrides Box..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WinFormsControl Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
WinFormsControl..::.GetScripts Method
WinFormsControl Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

WinFormsControl Class
WinFormsControl Members
PerpetuumSoft.Reporting.DOM Namespace


InitNew Method

[image]

.NET ModelKit Suite ClassReference
WinFormsControl..::.InitNew Method
WinFormsControl Class See Also Send Feedback
Paints the content of the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void InitNew()
Visual Basic (Declaration)
Public Overrides Sub InitNew
Visual C++
public:
virtual void InitNew() override

See Also

WinFormsControl Class
PerpetuumSoft.Reporting.DOM Namespace


PaintContent Method

[image]

.NET ModelKit Suite ClassReference
WinFormsControl..::.PaintContent Method
WinFormsControl Class See Also Send Feedback
Overridden. See ['M:PerpetuumSoft.Reporting.DOM.Box.PaintContent(PerpetuumSoft.Reporting.DOM.PaintArguments,System.Drawing.RectangleF)].

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PaintContent(
    PaintArguments args,
    RectangleF contentRectangle
)
Visual Basic (Declaration)
Protected Overrides Sub PaintContent ( _
    args As PaintArguments, _
    contentRectangle As RectangleF _
)
Visual C++
protected:
virtual void PaintContent(
    PaintArguments^ args,
    RectangleF contentRectangle
) override

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments
contentRectangle
Type: System.Drawing..::.RectangleF

See Also

WinFormsControl Class
PerpetuumSoft.Reporting.DOM Namespace


PopulateProperties Method

[image]

.NET ModelKit Suite ClassReference
WinFormsControl..::.PopulateProperties Method
WinFormsControl Class See Also Send Feedback
Fills the properties of the final rendered control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PopulateProperties(
    ReportControl production
)
Visual Basic (Declaration)
Protected Overrides Sub PopulateProperties ( _
    production As ReportControl _
)
Visual C++
protected:
virtual void PopulateProperties(
    ReportControl^ production
) override

Parameters

production
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

WinFormsControl Class
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
WinFormsControl..::.Render Method
WinFormsControl Class See Also Send Feedback
Renders the control to the final document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

WinFormsControl Class
PerpetuumSoft.Reporting.DOM Namespace


WinFormsControl Properties

[image] [image]

.NET ModelKit Suite ClassReference
WinFormsControl Properties
WinFormsControl Class See Also Send Feedback

The WinFormsControl type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
Control | Gets control that will displayed.
ControlTypeName | Gets and sets a string that represents the name of the type of the control.
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
Text | Gets and sets a text string for the control.
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

WinFormsControl Class
PerpetuumSoft.Reporting.DOM Namespace


Control Property

[image]

.NET ModelKit Suite ClassReference
WinFormsControl..::.Control Property
WinFormsControl Class See Also Send Feedback
Gets control that will displayed.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Control Control { get; }
Visual Basic (Declaration)
Public ReadOnly Property Control As Control
Visual C++
public:
property Control^ Control {
    Control^ get ();
}

See Also

WinFormsControl Class
PerpetuumSoft.Reporting.DOM Namespace


ControlTypeName Property

[image]

.NET ModelKit Suite ClassReference
WinFormsControl..::.ControlTypeName Property
WinFormsControl Class See Also Send Feedback
Gets and sets a string that represents the name of the type of the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string ControlTypeName { get; set; }
Visual Basic (Declaration)
Public Property ControlTypeName As String
Visual C++
public:
property String^ ControlTypeName {
    String^ get ();
    void set (String^ value);
}

See Also

WinFormsControl Class
PerpetuumSoft.Reporting.DOM Namespace


Text Property

[image]

.NET ModelKit Suite ClassReference
WinFormsControl..::.Text Property
WinFormsControl Class See Also Send Feedback
Gets and sets a text string for the control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

WinFormsControl Class
PerpetuumSoft.Reporting.DOM Namespace


WinFormsControl Events

[image] [image]

.NET ModelKit Suite ClassReference
WinFormsControl Events
WinFormsControl Class See Also Send Feedback

The WinFormsControl type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

WinFormsControl Class
PerpetuumSoft.Reporting.DOM Namespace


ZipCode Class

[image]

.NET ModelKit Suite ClassReference
ZipCode Class
Members See Also Send Feedback
Represents a ZIP code control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ZipCode : Box
Visual Basic (Declaration)
Public Class ZipCode _
    Inherits Box
Visual C++
public ref class ZipCode : public Box

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.VisualControl
PerpetuumSoft.Reporting.DOM..::.Box
PerpetuumSoft.Reporting.DOM..::.ZipCode

See Also

ZipCode Members
PerpetuumSoft.Reporting.DOM Namespace


ZipCode Members

[image] [image]

.NET ModelKit Suite ClassReference
ZipCode Members
ZipCode Class Constructors Methods Properties Events See Also Send Feedback

The ZipCode type exposes the following members.

Constructors

Name | Description
ZipCode | Creates a new instance of ZipCode class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Overridden. See CreateBlankControl()()(). (Overrides ReportControl..::.CreateBlankControl()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of a ZipCode object created with visual tools such as Report Designer. (Overrides ReportControl..::.InitNew()()().)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed. (Inherited from Box.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Paints zip code element content. (Overrides Box..::.PaintContent(PaintArguments, RectangleF).)
PopulateProperties | Fills the properties of the final rendered control. (Overrides Box..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
Code | Gets and sets a string that represents the ZIP code.
Color | Gets and sets the color of the ZIP code.
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

ZipCode Class
PerpetuumSoft.Reporting.DOM Namespace


ZipCode Constructor

[image]

.NET ModelKit Suite ClassReference
ZipCode Constructor
ZipCode Class See Also Send Feedback
Creates a new instance of ZipCode class.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ZipCode()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ZipCode()

See Also

ZipCode Class
PerpetuumSoft.Reporting.DOM Namespace


ZipCode Methods

[image] [image]

.NET ModelKit Suite ClassReference
ZipCode Methods
ZipCode Class See Also Send Feedback

The ZipCode type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateRenderHeight | Calculates the height of the control in the rendered report. (Inherited from ReportControl.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from ReportControl.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ReportControl.)
CreateBlankControl | Overridden. See CreateBlankControl()()(). (Overrides ReportControl..::.CreateBlankControl()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the control's parent. (Inherited from ReportControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotatedContentRectangle | Returns a given rectangle, rotated on box angle. (Inherited from Box.)
GetScripts | Overloaded.
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowRenderHeight | Overridden. See GrowRenderHeight(Double). (Inherited from VisualControl.)
InitNew | Sets the predefined values for the properties of a ZipCode object created with visual tools such as Report Designer. (Overrides ReportControl..::.InitNew()()().)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnFillChanged | Is called after the Fill property is changed. (Inherited from Box.)
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Paints the box. (Inherited from Box.)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PaintBackground | Paints the background of the box using the current background fill. (Inherited from Box.)
PaintBorder | Paints a border around the box. (Inherited from Box.)
PaintContent | Paints zip code element content. (Overrides Box..::.PaintContent(PaintArguments, RectangleF).)
PopulateProperties | Fills the properties of the final rendered control. (Overrides Box..::.PopulateProperties(ReportControl).)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates control bounds. (Inherited from ReportControl.)
Render | Renders the control to the final document. (Overrides ReportControl..::.Render()()().)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
ResetBorder | Resets the Border property to its default value. (Inherited from Box.)
ResetFill | Resets the Fill property to its default value. (Inherited from Box.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
ShouldSerializeBorder | Returns whether the Border property should be persisted. (Inherited from Box.)
ShouldSerializeFill | Returns whether the Fill property should be persisted. (Inherited from Box.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZipCode Class
PerpetuumSoft.Reporting.DOM Namespace


CreateBlankControl Method

[image]

.NET ModelKit Suite ClassReference
ZipCode..::.CreateBlankControl Method
ZipCode Class See Also Send Feedback
Overridden. See CreateBlankControl()()().

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override ReportControl CreateBlankControl()
Visual Basic (Declaration)
Protected Overrides Function CreateBlankControl As ReportControl
Visual C++
protected:
virtual ReportControl^ CreateBlankControl() override

See Also

ZipCode Class
PerpetuumSoft.Reporting.DOM Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
ZipCode..::.GetScripts Method
ZipCode Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Fills the specified collection with all scripts assigned to the control. (Inherited from ReportControl.)

See Also

ZipCode Class
ZipCode Members
PerpetuumSoft.Reporting.DOM Namespace


InitNew Method

[image]

.NET ModelKit Suite ClassReference
ZipCode..::.InitNew Method
ZipCode Class See Also Send Feedback
Sets the predefined values for the properties of a ZipCode object created with visual tools such as Report Designer.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void InitNew()
Visual Basic (Declaration)
Public Overrides Sub InitNew
Visual C++
public:
virtual void InitNew() override

See Also

ZipCode Class
PerpetuumSoft.Reporting.DOM Namespace


PaintContent Method

[image]

.NET ModelKit Suite ClassReference
ZipCode..::.PaintContent Method
ZipCode Class See Also Send Feedback
Paints zip code element content.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PaintContent(
    PaintArguments args,
    RectangleF contentRectangle
)
Visual Basic (Declaration)
Protected Overrides Sub PaintContent ( _
    args As PaintArguments, _
    contentRectangle As RectangleF _
)
Visual C++
protected:
virtual void PaintContent(
    PaintArguments^ args,
    RectangleF contentRectangle
) override

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments
contentRectangle
Type: System.Drawing..::.RectangleF

See Also

ZipCode Class
PerpetuumSoft.Reporting.DOM Namespace


PopulateProperties Method

[image]

.NET ModelKit Suite ClassReference
ZipCode..::.PopulateProperties Method
ZipCode Class See Also Send Feedback
Fills the properties of the final rendered control.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void PopulateProperties(
    ReportControl production
)
Visual Basic (Declaration)
Protected Overrides Sub PopulateProperties ( _
    production As ReportControl _
)
Visual C++
protected:
virtual void PopulateProperties(
    ReportControl^ production
) override

Parameters

production
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ZipCode Class
PerpetuumSoft.Reporting.DOM Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
ZipCode..::.Render Method
ZipCode Class See Also Send Feedback
Renders the control to the final document.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

ZipCode Class
PerpetuumSoft.Reporting.DOM Namespace


ZipCode Properties

[image] [image]

.NET ModelKit Suite ClassReference
ZipCode Properties
ZipCode Class See Also Send Feedback

The ZipCode type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the angle of box rotation. (Inherited from Box.)
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Border | Gets and sets the control's border. (Inherited from Box.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
Code | Gets and sets a string that represents the ZIP code.
Color | Gets and sets the color of the ZIP code.
ContentRectangle | Gets the internal rectangle in the box based on the box's Margins settings. (Inherited from Box.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DisplayRectangle | Gets the rectangle for displaying the control on the canvas. (Inherited from VisualControl.)
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
Fill | Gets and sets the control's background fill. (Inherited from Box.)
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
GrowToBottom | Gets and sets whether the control's rendered size should be extended to the bottom of the parent band regardless of the control's size in the template. (Inherited from VisualControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
Margins | Gets and sets the control's margins. (Inherited from Box.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

ZipCode Class
PerpetuumSoft.Reporting.DOM Namespace


Code Property

[image]

.NET ModelKit Suite ClassReference
ZipCode..::.Code Property
ZipCode Class See Also Send Feedback
Gets and sets a string that represents the ZIP code.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Code { get; set; }
Visual Basic (Declaration)
Public Property Code As String
Visual C++
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}

See Also

ZipCode Class
PerpetuumSoft.Reporting.DOM Namespace


Color Property

[image]

.NET ModelKit Suite ClassReference
ZipCode..::.Color Property
ZipCode Class See Also Send Feedback
Gets and sets the color of the ZIP code.

Namespace: PerpetuumSoft.Reporting.DOM
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

ZipCode Class
PerpetuumSoft.Reporting.DOM Namespace


ZipCode Events

[image] [image]

.NET ModelKit Suite ClassReference
ZipCode Events
ZipCode Class See Also Send Feedback

The ZipCode type exposes the following members.

Events

Name | Description
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

ZipCode Class
PerpetuumSoft.Reporting.DOM Namespace


PerpetuumSoft.Reporting.DOM.Design Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.DOM.Design Namespace
Send Feedback
The PerpetuumSoft.Reporting.DOM.Design namespace contains classes that extend design time user interface for document editing.

Classes

Class | Description
DataSourceEditor | Represents editor for data source.
FormattedTextEditorForm | Text editing dialog form
ReportDragData |
RichTextEditorForm | RichText editing dialog form
ScriptEditor | Represents editor for script.
ScriptEditorForm |
ScriptParser |
StyleSheetEditorForm |
TextEditor | Represents editor for text.
TextEditorForm | Text editing dialog form

Enumerations

Enumeration | Description
ScriptParserType |


DataSourceEditor Class

[image]

.NET ModelKit Suite ClassReference
DataSourceEditor Class
Members See Also Send Feedback
Represents editor for data source.

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DataSourceEditor : UITypeEditor
Visual Basic (Declaration)
Public Class DataSourceEditor _
    Inherits UITypeEditor
Visual C++
public ref class DataSourceEditor : public UITypeEditor

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
PerpetuumSoft.Reporting.DOM.Design..::.DataSourceEditor

See Also

DataSourceEditor Members
PerpetuumSoft.Reporting.DOM.Design Namespace


DataSourceEditor Members

[image] [image]

.NET ModelKit Suite ClassReference
DataSourceEditor Members
DataSourceEditor Class Constructors Methods Properties See Also Send Feedback

The DataSourceEditor type exposes the following members.

Constructors

Name | Description
DataSourceEditor | Creates a new instance of DataSourceEditor class.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

DataSourceEditor Class
PerpetuumSoft.Reporting.DOM.Design Namespace


DataSourceEditor Constructor

[image]

.NET ModelKit Suite ClassReference
DataSourceEditor Constructor
DataSourceEditor Class See Also Send Feedback
Creates a new instance of DataSourceEditor class.

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataSourceEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataSourceEditor()

See Also

DataSourceEditor Class
PerpetuumSoft.Reporting.DOM.Design Namespace


DataSourceEditor Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataSourceEditor Methods
DataSourceEditor Class See Also Send Feedback

The DataSourceEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataSourceEditor Class
PerpetuumSoft.Reporting.DOM.Design Namespace


EditValue Method

[image] [image]

.NET ModelKit Suite ClassReference
DataSourceEditor..::.EditValue Method
DataSourceEditor Class See Also Send Feedback

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Overridded. See EditValue(ITypeDescriptorContext, IServiceProvider, Object). (Overrides UITypeEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

DataSourceEditor Class
DataSourceEditor Members
PerpetuumSoft.Reporting.DOM.Design Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

.NET ModelKit Suite ClassReference
DataSourceEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
DataSourceEditor Class See Also Send Feedback
Overridded. See EditValue(ITypeDescriptorContext, IServiceProvider, Object).

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ EditValue(
    ITypeDescriptorContext^ context,
    IServiceProvider^ provider,
    Object^ value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
provider
Type: System..::.IServiceProvider
value
Type: System..::.Object

See Also

DataSourceEditor Class
EditValue Overload
PerpetuumSoft.Reporting.DOM.Design Namespace


GetEditStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
DataSourceEditor..::.GetEditStyle Method
DataSourceEditor Class See Also Send Feedback

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | Overridded. See GetEditStyle(ITypeDescriptorContext). (Overrides UITypeEditor..::.GetEditStyle(ITypeDescriptorContext).)

See Also

DataSourceEditor Class
DataSourceEditor Members
PerpetuumSoft.Reporting.DOM.Design Namespace


GetEditStyle Method (ITypeDescriptorContext)

[image]

.NET ModelKit Suite ClassReference
DataSourceEditor..::.GetEditStyle Method (ITypeDescriptorContext)
DataSourceEditor Class See Also Send Feedback
Overridded. See GetEditStyle(ITypeDescriptorContext).

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetEditStyle ( _
    context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual C++
public:
virtual UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext

See Also

DataSourceEditor Class
GetEditStyle Overload
PerpetuumSoft.Reporting.DOM.Design Namespace


GetPaintValueSupported Method

[image] [image]

.NET ModelKit Suite ClassReference
DataSourceEditor..::.GetPaintValueSupported Method
DataSourceEditor Class See Also Send Feedback

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

DataSourceEditor Class
DataSourceEditor Members
PerpetuumSoft.Reporting.DOM.Design Namespace


PaintValue Method

[image] [image]

.NET ModelKit Suite ClassReference
DataSourceEditor..::.PaintValue Method
DataSourceEditor Class See Also Send Feedback

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

DataSourceEditor Class
DataSourceEditor Members
PerpetuumSoft.Reporting.DOM.Design Namespace


DataSourceEditor Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataSourceEditor Properties
DataSourceEditor Class See Also Send Feedback

The DataSourceEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

DataSourceEditor Class
PerpetuumSoft.Reporting.DOM.Design Namespace


FormattedTextEditorForm Class

[image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm Class
Members See Also Send Feedback
Text editing dialog form

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class FormattedTextEditorForm : Form
Visual Basic (Declaration)
Public Class FormattedTextEditorForm _
    Inherits Form
Visual C++
public ref class FormattedTextEditorForm : public Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
PerpetuumSoft.Reporting.DOM.Design..::.FormattedTextEditorForm

See Also

FormattedTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


FormattedTextEditorForm Members

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm Members
FormattedTextEditorForm Class Constructors Methods Properties Events See Also Send Feedback

The FormattedTextEditorForm type exposes the following members.

Constructors

Name | Description
FormattedTextEditorForm | Initializes a new instance of the FormattedTextEditorForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Overrides Form..::.OnFormClosed(FormClosedEventArgs).)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormattedText | Gets or sets formated text
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Title | Gets and sets text title.
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

FormattedTextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


FormattedTextEditorForm Constructor

[image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm Constructor
FormattedTextEditorForm Class See Also Send Feedback
Initializes a new instance of the FormattedTextEditorForm class.

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FormattedTextEditorForm(
    IReportDesignerService reportDesignerService
)
Visual Basic (Declaration)
Public Sub New ( _
    reportDesignerService As IReportDesignerService _
)
Visual C++
public:
FormattedTextEditorForm(
    IReportDesignerService^ reportDesignerService
)

Parameters

reportDesignerService
Type: PerpetuumSoft.Reporting.Designer..::.IReportDesignerService

See Also

FormattedTextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


FormattedTextEditorForm Methods

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm Methods
FormattedTextEditorForm Class See Also Send Feedback

The FormattedTextEditorForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Overrides Form..::.OnFormClosed(FormClosedEventArgs).)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

FormattedTextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.AccessibilityNotifyClients Method
FormattedTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

FormattedTextEditorForm Class
FormattedTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.BeginInvoke Method
FormattedTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

FormattedTextEditorForm Class
FormattedTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.Dispose Method
FormattedTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | The Dispose Finalize pattern ensures that resources are released when the object is no longer needed (Overrides Form..::.Dispose(Boolean).)

See Also

FormattedTextEditorForm Class
FormattedTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.Dispose Method (Boolean)
FormattedTextEditorForm Class See Also Send Feedback
The Dispose Finalize pattern ensures that resources are released when the object is no longer needed

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

FormattedTextEditorForm Class
Dispose Overload
PerpetuumSoft.Reporting.DOM.Design Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.GetChildAtPoint Method
FormattedTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

FormattedTextEditorForm Class
FormattedTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.Invalidate Method
FormattedTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

FormattedTextEditorForm Class
FormattedTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.Invoke Method
FormattedTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

FormattedTextEditorForm Class
FormattedTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.MemberwiseClone Method
FormattedTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

FormattedTextEditorForm Class
FormattedTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


OnFormClosed Method

[image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.OnFormClosed Method
FormattedTextEditorForm Class See Also Send Feedback
Raises the FormClosed event.

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnFormClosed(
    FormClosedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnFormClosed ( _
    e As FormClosedEventArgs _
)
Visual C++
protected:
virtual void OnFormClosed(
    FormClosedEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.FormClosedEventArgs

See Also

FormattedTextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.OnLoad Method
FormattedTextEditorForm Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

FormattedTextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.PerformLayout Method
FormattedTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

FormattedTextEditorForm Class
FormattedTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.ResumeLayout Method
FormattedTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

FormattedTextEditorForm Class
FormattedTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.RtlTranslateAlignment Method
FormattedTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

FormattedTextEditorForm Class
FormattedTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.Scale Method
FormattedTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

FormattedTextEditorForm Class
FormattedTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.Select Method
FormattedTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

FormattedTextEditorForm Class
FormattedTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.SetBounds Method
FormattedTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

FormattedTextEditorForm Class
FormattedTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Show Method

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.Show Method
FormattedTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

FormattedTextEditorForm Class
FormattedTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ShowDialog Method

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.ShowDialog Method
FormattedTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

FormattedTextEditorForm Class
FormattedTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.UpdateBounds Method
FormattedTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

FormattedTextEditorForm Class
FormattedTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.Validate Method
FormattedTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

FormattedTextEditorForm Class
FormattedTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.ValidateChildren Method
FormattedTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

FormattedTextEditorForm Class
FormattedTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


FormattedTextEditorForm Properties

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm Properties
FormattedTextEditorForm Class See Also Send Feedback

The FormattedTextEditorForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormattedText | Gets or sets formated text
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Title | Gets and sets text title.
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

FormattedTextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


FormattedText Property

[image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.FormattedText Property
FormattedTextEditorForm Class See Also Send Feedback
Gets or sets formated text

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string FormattedText { get; set; }
Visual Basic (Declaration)
Public Property FormattedText As String
Visual C++
public:
property String^ FormattedText {
    String^ get ();
    void set (String^ value);
}

See Also

FormattedTextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


Title Property

[image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm..::.Title Property
FormattedTextEditorForm Class See Also Send Feedback
Gets and sets text title.

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

FormattedTextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


FormattedTextEditorForm Events

[image] [image]

.NET ModelKit Suite ClassReference
FormattedTextEditorForm Events
FormattedTextEditorForm Class See Also Send Feedback

The FormattedTextEditorForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

FormattedTextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


ReportDragData Class

[image]

.NET ModelKit Suite ClassReference
ReportDragData Class
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Reporting.DOM.Design.ReportDragData]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ReportDragData
Visual Basic (Declaration)
Public Class ReportDragData
Visual C++
public ref class ReportDragData

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM.Design..::.ReportDragData

See Also

ReportDragData Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ReportDragData Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportDragData Members
ReportDragData Class Constructors Methods Properties See Also Send Feedback

The ReportDragData type exposes the following members.

Constructors

Name | Description
ReportDragData | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DataField |
DataNavigator |
Expression |

See Also

ReportDragData Class
PerpetuumSoft.Reporting.DOM.Design Namespace


ReportDragData Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ReportDragData Constructor
ReportDragData Class See Also Send Feedback

Overload List

Name | Description
ReportDragData(String, String) | Initializes a new instance of the ReportDragData class
ReportDragData(String, String, DataNavigator) | Initializes a new instance of the ReportDragData class

See Also

ReportDragData Class
ReportDragData Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ReportDragData Constructor (String, String)

[image]

.NET ModelKit Suite ClassReference
ReportDragData Constructor (String, String)
ReportDragData Class See Also Send Feedback
Initializes a new instance of the ReportDragData class

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportDragData(
    string dataField,
    string expression
)
Visual Basic (Declaration)
Public Sub New ( _
    dataField As String, _
    expression As String _
)
Visual C++
public:
ReportDragData(
    String^ dataField,
    String^ expression
)

Parameters

dataField
Type: System..::.String
expression
Type: System..::.String

See Also

ReportDragData Class
ReportDragData Overload
PerpetuumSoft.Reporting.DOM.Design Namespace


ReportDragData Constructor (String, String, DataNavigator)

[image]

.NET ModelKit Suite ClassReference
ReportDragData Constructor (String, String, DataNavigator)
ReportDragData Class See Also Send Feedback
Initializes a new instance of the ReportDragData class

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportDragData(
    string dataField,
    string expression,
    DataNavigator dataNavigator
)
Visual Basic (Declaration)
Public Sub New ( _
    dataField As String, _
    expression As String, _
    dataNavigator As DataNavigator _
)
Visual C++
public:
ReportDragData(
    String^ dataField,
    String^ expression,
    DataNavigator^ dataNavigator
)

Parameters

dataField
Type: System..::.String
expression
Type: System..::.String
dataNavigator
Type: PerpetuumSoft.Reporting.Data..::.DataNavigator

See Also

ReportDragData Class
ReportDragData Overload
PerpetuumSoft.Reporting.DOM.Design Namespace


ReportDragData Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportDragData Methods
ReportDragData Class See Also Send Feedback

The ReportDragData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportDragData Class
PerpetuumSoft.Reporting.DOM.Design Namespace


ReportDragData Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportDragData Properties
ReportDragData Class See Also Send Feedback

The ReportDragData type exposes the following members.

Properties

Name | Description
DataField |
DataNavigator |
Expression |

See Also

ReportDragData Class
PerpetuumSoft.Reporting.DOM.Design Namespace


DataField Property

[image]

.NET ModelKit Suite ClassReference
ReportDragData..::.DataField Property
ReportDragData Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.DOM.Design.ReportDragData.DataField]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string DataField { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataField As String
Visual C++
public:
property String^ DataField {
    String^ get ();
}

See Also

ReportDragData Class
PerpetuumSoft.Reporting.DOM.Design Namespace


DataNavigator Property

[image]

.NET ModelKit Suite ClassReference
ReportDragData..::.DataNavigator Property
ReportDragData Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.DOM.Design.ReportDragData.DataNavigator]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataNavigator DataNavigator { get; set; }
Visual Basic (Declaration)
Public Property DataNavigator As DataNavigator
Visual C++
public:
property DataNavigator^ DataNavigator {
    DataNavigator^ get ();
    void set (DataNavigator^ value);
}

See Also

ReportDragData Class
PerpetuumSoft.Reporting.DOM.Design Namespace


Expression Property

[image]

.NET ModelKit Suite ClassReference
ReportDragData..::.Expression Property
ReportDragData Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.DOM.Design.ReportDragData.Expression]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Expression { get; }
Visual Basic (Declaration)
Public ReadOnly Property Expression As String
Visual C++
public:
property String^ Expression {
    String^ get ();
}

See Also

ReportDragData Class
PerpetuumSoft.Reporting.DOM.Design Namespace


RichTextEditorForm Class

[image]

.NET ModelKit Suite ClassReference
RichTextEditorForm Class
Members See Also Send Feedback
RichText editing dialog form

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class RichTextEditorForm : Form
Visual Basic (Declaration)
Public Class RichTextEditorForm _
    Inherits Form
Visual C++
public ref class RichTextEditorForm : public Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
PerpetuumSoft.Reporting.DOM.Design..::.RichTextEditorForm

See Also

RichTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


RichTextEditorForm Members

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm Members
RichTextEditorForm Class Constructors Methods Properties Events See Also Send Feedback

The RichTextEditorForm type exposes the following members.

Constructors

Name | Description
RichTextEditorForm | Initializes a new instance of the RichTextEditorForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Overrides Form..::.OnClosed(EventArgs).)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
RtfText | Gets or sets String
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
SimpleText | Gets or sets String
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

RichTextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


RichTextEditorForm Constructor

[image]

.NET ModelKit Suite ClassReference
RichTextEditorForm Constructor
RichTextEditorForm Class See Also Send Feedback
Initializes a new instance of the RichTextEditorForm class.

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public RichTextEditorForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RichTextEditorForm()

See Also

RichTextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


RichTextEditorForm Methods

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm Methods
RichTextEditorForm Class See Also Send Feedback

The RichTextEditorForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Overrides Form..::.OnClosed(EventArgs).)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

RichTextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.AccessibilityNotifyClients Method
RichTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

RichTextEditorForm Class
RichTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.BeginInvoke Method
RichTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

RichTextEditorForm Class
RichTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.Dispose Method
RichTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | The Dispose Finalize pattern ensures that resources are released when the object is no longer needed (Overrides Form..::.Dispose(Boolean).)

See Also

RichTextEditorForm Class
RichTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.Dispose Method (Boolean)
RichTextEditorForm Class See Also Send Feedback
The Dispose Finalize pattern ensures that resources are released when the object is no longer needed

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

RichTextEditorForm Class
Dispose Overload
PerpetuumSoft.Reporting.DOM.Design Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.GetChildAtPoint Method
RichTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

RichTextEditorForm Class
RichTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.Invalidate Method
RichTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

RichTextEditorForm Class
RichTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.Invoke Method
RichTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

RichTextEditorForm Class
RichTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.MemberwiseClone Method
RichTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

RichTextEditorForm Class
RichTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


OnClosed Method

[image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.OnClosed Method
RichTextEditorForm Class See Also Send Feedback
Raises the Closed event.

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnClosed(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnClosed ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnClosed(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

RichTextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.OnLoad Method
RichTextEditorForm Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

RichTextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.PerformLayout Method
RichTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

RichTextEditorForm Class
RichTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.ResumeLayout Method
RichTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

RichTextEditorForm Class
RichTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.RtlTranslateAlignment Method
RichTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

RichTextEditorForm Class
RichTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.Scale Method
RichTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

RichTextEditorForm Class
RichTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.Select Method
RichTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

RichTextEditorForm Class
RichTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.SetBounds Method
RichTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

RichTextEditorForm Class
RichTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Show Method

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.Show Method
RichTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

RichTextEditorForm Class
RichTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ShowDialog Method

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.ShowDialog Method
RichTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

RichTextEditorForm Class
RichTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.UpdateBounds Method
RichTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

RichTextEditorForm Class
RichTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.Validate Method
RichTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

RichTextEditorForm Class
RichTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.ValidateChildren Method
RichTextEditorForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

RichTextEditorForm Class
RichTextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


RichTextEditorForm Properties

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm Properties
RichTextEditorForm Class See Also Send Feedback

The RichTextEditorForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
RtfText | Gets or sets String
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
SimpleText | Gets or sets String
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

RichTextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


RtfText Property

[image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.RtfText Property
RichTextEditorForm Class See Also Send Feedback
Gets or sets String

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string RtfText { get; set; }
Visual Basic (Declaration)
Public Property RtfText As String
Visual C++
public:
property String^ RtfText {
    String^ get ();
    void set (String^ value);
}

See Also

RichTextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


SimpleText Property

[image]

.NET ModelKit Suite ClassReference
RichTextEditorForm..::.SimpleText Property
RichTextEditorForm Class See Also Send Feedback
Gets or sets String

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string SimpleText { get; set; }
Visual Basic (Declaration)
Public Property SimpleText As String
Visual C++
public:
property String^ SimpleText {
    String^ get ();
    void set (String^ value);
}

See Also

RichTextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


RichTextEditorForm Events

[image] [image]

.NET ModelKit Suite ClassReference
RichTextEditorForm Events
RichTextEditorForm Class See Also Send Feedback

The RichTextEditorForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

RichTextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


ScriptEditor Class

[image]

.NET ModelKit Suite ClassReference
ScriptEditor Class
Members See Also Send Feedback
Represents editor for script.

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ScriptEditor : UITypeEditor
Visual Basic (Declaration)
Public Class ScriptEditor _
    Inherits UITypeEditor
Visual C++
public ref class ScriptEditor : public UITypeEditor

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
PerpetuumSoft.Reporting.DOM.Design..::.ScriptEditor

See Also

ScriptEditor Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ScriptEditor Members

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditor Members
ScriptEditor Class Constructors Methods Properties See Also Send Feedback

The ScriptEditor type exposes the following members.

Constructors

Name | Description
ScriptEditor | Creates a new instance of ScriptEditor class.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

ScriptEditor Class
PerpetuumSoft.Reporting.DOM.Design Namespace


ScriptEditor Constructor

[image]

.NET ModelKit Suite ClassReference
ScriptEditor Constructor
ScriptEditor Class See Also Send Feedback
Creates a new instance of ScriptEditor class.

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ScriptEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ScriptEditor()

See Also

ScriptEditor Class
PerpetuumSoft.Reporting.DOM.Design Namespace


ScriptEditor Methods

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditor Methods
ScriptEditor Class See Also Send Feedback

The ScriptEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptEditor Class
PerpetuumSoft.Reporting.DOM.Design Namespace


EditValue Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditor..::.EditValue Method
ScriptEditor Class See Also Send Feedback

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Overridded. See EditValue(ITypeDescriptorContext, IServiceProvider, Object). (Overrides UITypeEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

ScriptEditor Class
ScriptEditor Members
PerpetuumSoft.Reporting.DOM.Design Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

.NET ModelKit Suite ClassReference
ScriptEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
ScriptEditor Class See Also Send Feedback
Overridded. See EditValue(ITypeDescriptorContext, IServiceProvider, Object).

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ EditValue(
    ITypeDescriptorContext^ context,
    IServiceProvider^ provider,
    Object^ value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
provider
Type: System..::.IServiceProvider
value
Type: System..::.Object

See Also

ScriptEditor Class
EditValue Overload
PerpetuumSoft.Reporting.DOM.Design Namespace


GetEditStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditor..::.GetEditStyle Method
ScriptEditor Class See Also Send Feedback

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | Overridded. See GetEditStyle(ITypeDescriptorContext). (Overrides UITypeEditor..::.GetEditStyle(ITypeDescriptorContext).)

See Also

ScriptEditor Class
ScriptEditor Members
PerpetuumSoft.Reporting.DOM.Design Namespace


GetEditStyle Method (ITypeDescriptorContext)

[image]

.NET ModelKit Suite ClassReference
ScriptEditor..::.GetEditStyle Method (ITypeDescriptorContext)
ScriptEditor Class See Also Send Feedback
Overridded. See GetEditStyle(ITypeDescriptorContext).

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetEditStyle ( _
    context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual C++
public:
virtual UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext

See Also

ScriptEditor Class
GetEditStyle Overload
PerpetuumSoft.Reporting.DOM.Design Namespace


GetPaintValueSupported Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditor..::.GetPaintValueSupported Method
ScriptEditor Class See Also Send Feedback

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

ScriptEditor Class
ScriptEditor Members
PerpetuumSoft.Reporting.DOM.Design Namespace


PaintValue Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditor..::.PaintValue Method
ScriptEditor Class See Also Send Feedback

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

ScriptEditor Class
ScriptEditor Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ScriptEditor Properties

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditor Properties
ScriptEditor Class See Also Send Feedback

The ScriptEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

ScriptEditor Class
PerpetuumSoft.Reporting.DOM.Design Namespace


ScriptEditorForm Class

[image]

.NET ModelKit Suite ClassReference
ScriptEditorForm Class
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Reporting.DOM.Design.ScriptEditorForm]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ScriptEditorForm : Form
Visual Basic (Declaration)
Public Class ScriptEditorForm _
    Inherits Form
Visual C++
public ref class ScriptEditorForm : public Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
PerpetuumSoft.Reporting.DOM.Design..::.ScriptEditorForm

See Also

ScriptEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ScriptEditorForm Members

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm Members
ScriptEditorForm Class Constructors Methods Properties Events See Also Send Feedback

The ScriptEditorForm type exposes the following members.

Constructors

Name | Description
ScriptEditorForm | Initializes a new instance of the ScriptEditorForm class

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | (Overrides Form..::.OnClosed(EventArgs).)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | (Overrides Form..::.OnFormClosing(FormClosingEventArgs).)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Parser |
Position |
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ScriptText |
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Title |
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ScriptEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


ScriptEditorForm Constructor

[image]

.NET ModelKit Suite ClassReference
ScriptEditorForm Constructor
ScriptEditorForm Class See Also Send Feedback
Initializes a new instance of the ScriptEditorForm class

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ScriptEditorForm(
    IReportDesignerService reportDesignerService
)
Visual Basic (Declaration)
Public Sub New ( _
    reportDesignerService As IReportDesignerService _
)
Visual C++
public:
ScriptEditorForm(
    IReportDesignerService^ reportDesignerService
)

Parameters

reportDesignerService
Type: PerpetuumSoft.Reporting.Designer..::.IReportDesignerService

See Also

ScriptEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


ScriptEditorForm Methods

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm Methods
ScriptEditorForm Class See Also Send Feedback

The ScriptEditorForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | (Overrides Form..::.OnClosed(EventArgs).)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | (Overrides Form..::.OnFormClosing(FormClosingEventArgs).)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ScriptEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.AccessibilityNotifyClients Method
ScriptEditorForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ScriptEditorForm Class
ScriptEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.BeginInvoke Method
ScriptEditorForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ScriptEditorForm Class
ScriptEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.Dispose Method
ScriptEditorForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Overrides Form..::.Dispose(Boolean).)

See Also

ScriptEditorForm Class
ScriptEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.Dispose Method (Boolean)
ScriptEditorForm Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.Design.ScriptEditorForm.Dispose(System.Boolean)]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

ScriptEditorForm Class
Dispose Overload
PerpetuumSoft.Reporting.DOM.Design Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.GetChildAtPoint Method
ScriptEditorForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ScriptEditorForm Class
ScriptEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.Invalidate Method
ScriptEditorForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ScriptEditorForm Class
ScriptEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.Invoke Method
ScriptEditorForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ScriptEditorForm Class
ScriptEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.MemberwiseClone Method
ScriptEditorForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ScriptEditorForm Class
ScriptEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


OnClosed Method

[image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.OnClosed Method
ScriptEditorForm Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.Design.ScriptEditorForm.OnClosed(System.EventArgs)]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnClosed(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnClosed ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnClosed(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

ScriptEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


OnFormClosing Method

[image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.OnFormClosing Method
ScriptEditorForm Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.Design.ScriptEditorForm.OnFormClosing(System.Windows.Forms.FormClosingEventArgs)]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnFormClosing(
    FormClosingEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnFormClosing ( _
    e As FormClosingEventArgs _
)
Visual C++
protected:
virtual void OnFormClosing(
    FormClosingEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.FormClosingEventArgs

See Also

ScriptEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.OnLoad Method
ScriptEditorForm Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.Design.ScriptEditorForm.OnLoad(System.EventArgs)]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

ScriptEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.PerformLayout Method
ScriptEditorForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ScriptEditorForm Class
ScriptEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.ResumeLayout Method
ScriptEditorForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ScriptEditorForm Class
ScriptEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.RtlTranslateAlignment Method
ScriptEditorForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ScriptEditorForm Class
ScriptEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.Scale Method
ScriptEditorForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ScriptEditorForm Class
ScriptEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.Select Method
ScriptEditorForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

ScriptEditorForm Class
ScriptEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.SetBounds Method
ScriptEditorForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ScriptEditorForm Class
ScriptEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Show Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.Show Method
ScriptEditorForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

ScriptEditorForm Class
ScriptEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ShowDialog Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.ShowDialog Method
ScriptEditorForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

ScriptEditorForm Class
ScriptEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.UpdateBounds Method
ScriptEditorForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ScriptEditorForm Class
ScriptEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.Validate Method
ScriptEditorForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ScriptEditorForm Class
ScriptEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.ValidateChildren Method
ScriptEditorForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ScriptEditorForm Class
ScriptEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ScriptEditorForm Properties

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm Properties
ScriptEditorForm Class See Also Send Feedback

The ScriptEditorForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Parser |
Position |
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ScriptText |
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Title |
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

ScriptEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


Parser Property

[image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.Parser Property
ScriptEditorForm Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.DOM.Design.ScriptEditorForm.Parser]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Parser Parser { get; set; }
Visual Basic (Declaration)
Public Property Parser As Parser
Visual C++
public:
property Parser^ Parser {
    Parser^ get ();
    void set (Parser^ value);
}

See Also

ScriptEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


Position Property

[image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.Position Property
ScriptEditorForm Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.DOM.Design.ScriptEditorForm.Position]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Point Position { set; }
Visual Basic (Declaration)
Public WriteOnly Property Position As Point
Visual C++
public:
property Point Position {
    void set (Point value);
}

See Also

ScriptEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


ScriptText Property

[image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.ScriptText Property
ScriptEditorForm Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.DOM.Design.ScriptEditorForm.ScriptText]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string ScriptText { get; set; }
Visual Basic (Declaration)
Public Property ScriptText As String
Visual C++
public:
property String^ ScriptText {
    String^ get ();
    void set (String^ value);
}

See Also

ScriptEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


Title Property

[image]

.NET ModelKit Suite ClassReference
ScriptEditorForm..::.Title Property
ScriptEditorForm Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.DOM.Design.ScriptEditorForm.Title]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

ScriptEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


ScriptEditorForm Events

[image] [image]

.NET ModelKit Suite ClassReference
ScriptEditorForm Events
ScriptEditorForm Class See Also Send Feedback

The ScriptEditorForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ScriptEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


ScriptParser Class

[image]

.NET ModelKit Suite ClassReference
ScriptParser Class
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Reporting.DOM.Design.ScriptParser]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ScriptParser
Visual Basic (Declaration)
Public Class ScriptParser
Visual C++
public ref class ScriptParser

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM.Design..::.ScriptParser

See Also

ScriptParser Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ScriptParser Members

[image] [image]

.NET ModelKit Suite ClassReference
ScriptParser Members
ScriptParser Class Constructors Methods See Also Send Feedback

The ScriptParser type exposes the following members.

Constructors

Name | Description
ScriptParser | Initializes a new instance of the ScriptParser class

Methods

Name | Description
CreateParser |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptParser Class
PerpetuumSoft.Reporting.DOM.Design Namespace


ScriptParser Constructor

[image]

.NET ModelKit Suite ClassReference
ScriptParser Constructor
ScriptParser Class See Also Send Feedback
Initializes a new instance of the ScriptParser class

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ScriptParser(
    Document document,
    ScriptParserType scriptParserType
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document, _
    scriptParserType As ScriptParserType _
)
Visual C++
public:
ScriptParser(
    Document^ document,
    ScriptParserType scriptParserType
)

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
scriptParserType
Type: PerpetuumSoft.Reporting.DOM.Design..::.ScriptParserType

See Also

ScriptParser Class
PerpetuumSoft.Reporting.DOM.Design Namespace


ScriptParser Methods

[image] [image]

.NET ModelKit Suite ClassReference
ScriptParser Methods
ScriptParser Class See Also Send Feedback

The ScriptParser type exposes the following members.

Methods

Name | Description
CreateParser |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptParser Class
PerpetuumSoft.Reporting.DOM.Design Namespace


CreateParser Method

[image]

.NET ModelKit Suite ClassReference
ScriptParser..::.CreateParser Method
ScriptParser Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.Design.ScriptParser.CreateParser]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Parser CreateParser()
Visual Basic (Declaration)
Public Function CreateParser As Parser
Visual C++
public:
Parser^ CreateParser()

See Also

ScriptParser Class
PerpetuumSoft.Reporting.DOM.Design Namespace


ScriptParserType Enumeration

[image]

.NET ModelKit Suite ClassReference
ScriptParserType Enumeration
See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Reporting.DOM.Design.ScriptParserType]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum ScriptParserType
Visual Basic (Declaration)
Public Enumeration ScriptParserType
Visual C++
public enum class ScriptParserType

Members

Member name | Description
ClassBody |
MethodBody |
Expression |

See Also

PerpetuumSoft.Reporting.DOM.Design Namespace


StyleSheetEditorForm Class

[image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm Class
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Reporting.DOM.Design.StyleSheetEditorForm]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class StyleSheetEditorForm : Form
Visual Basic (Declaration)
Public Class StyleSheetEditorForm _
    Inherits Form
Visual C++
public ref class StyleSheetEditorForm : public Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
PerpetuumSoft.Reporting.DOM.Design..::.StyleSheetEditorForm

See Also

StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


StyleSheetEditorForm Members

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm Members
StyleSheetEditorForm Class Constructors Methods Properties Events See Also Send Feedback

The StyleSheetEditorForm type exposes the following members.

Constructors

Name | Description
StyleSheetEditorForm | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | (Overrides Form..::.OnFormClosed(FormClosedEventArgs).)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
StyleSheet |
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

StyleSheetEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


StyleSheetEditorForm Constructor

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm Constructor
StyleSheetEditorForm Class See Also Send Feedback

Overload List

Name | Description
StyleSheetEditorForm(IServiceProvider) | Initializes a new instance of the StyleSheetEditorForm class
StyleSheetEditorForm(StyleSheet, IServiceProvider) | Initializes a new instance of the StyleSheetEditorForm class

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


StyleSheetEditorForm Constructor (IServiceProvider)

[image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm Constructor (IServiceProvider)
StyleSheetEditorForm Class See Also Send Feedback
Initializes a new instance of the StyleSheetEditorForm class

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public StyleSheetEditorForm(
    IServiceProvider provider
)
Visual Basic (Declaration)
Public Sub New ( _
    provider As IServiceProvider _
)
Visual C++
public:
StyleSheetEditorForm(
    IServiceProvider^ provider
)

Parameters

provider
Type: System..::.IServiceProvider

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Overload
PerpetuumSoft.Reporting.DOM.Design Namespace


StyleSheetEditorForm Constructor (StyleSheet, IServiceProvider)

[image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm Constructor (StyleSheet, IServiceProvider)
StyleSheetEditorForm Class See Also Send Feedback
Initializes a new instance of the StyleSheetEditorForm class

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public StyleSheetEditorForm(
    StyleSheet styleSheet,
    IServiceProvider provider
)
Visual Basic (Declaration)
Public Sub New ( _
    styleSheet As StyleSheet, _
    provider As IServiceProvider _
)
Visual C++
public:
StyleSheetEditorForm(
    StyleSheet^ styleSheet,
    IServiceProvider^ provider
)

Parameters

styleSheet
Type: PerpetuumSoft.Reporting.DOM..::.StyleSheet
provider
Type: System..::.IServiceProvider

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Overload
PerpetuumSoft.Reporting.DOM.Design Namespace


StyleSheetEditorForm Methods

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm Methods
StyleSheetEditorForm Class See Also Send Feedback

The StyleSheetEditorForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | (Overrides Form..::.OnFormClosed(FormClosedEventArgs).)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

StyleSheetEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.AccessibilityNotifyClients Method
StyleSheetEditorForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.BeginInvoke Method
StyleSheetEditorForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.Dispose Method
StyleSheetEditorForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | (Overrides Form..::.Dispose(Boolean).)

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.Dispose Method (Boolean)
StyleSheetEditorForm Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.Design.StyleSheetEditorForm.Dispose(System.Boolean)]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

StyleSheetEditorForm Class
Dispose Overload
PerpetuumSoft.Reporting.DOM.Design Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.GetChildAtPoint Method
StyleSheetEditorForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.Invalidate Method
StyleSheetEditorForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.Invoke Method
StyleSheetEditorForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.MemberwiseClone Method
StyleSheetEditorForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


OnFormClosed Method

[image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.OnFormClosed Method
StyleSheetEditorForm Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.Design.StyleSheetEditorForm.OnFormClosed(System.Windows.Forms.FormClosedEventArgs)]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnFormClosed(
    FormClosedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnFormClosed ( _
    e As FormClosedEventArgs _
)
Visual C++
protected:
virtual void OnFormClosed(
    FormClosedEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.FormClosedEventArgs

See Also

StyleSheetEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.OnLoad Method
StyleSheetEditorForm Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.DOM.Design.StyleSheetEditorForm.OnLoad(System.EventArgs)]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

StyleSheetEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.PerformLayout Method
StyleSheetEditorForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.ResumeLayout Method
StyleSheetEditorForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.RtlTranslateAlignment Method
StyleSheetEditorForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.Scale Method
StyleSheetEditorForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.Select Method
StyleSheetEditorForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.SetBounds Method
StyleSheetEditorForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Show Method

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.Show Method
StyleSheetEditorForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ShowDialog Method

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.ShowDialog Method
StyleSheetEditorForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.UpdateBounds Method
StyleSheetEditorForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.Validate Method
StyleSheetEditorForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.ValidateChildren Method
StyleSheetEditorForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

StyleSheetEditorForm Class
StyleSheetEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


StyleSheetEditorForm Properties

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm Properties
StyleSheetEditorForm Class See Also Send Feedback

The StyleSheetEditorForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
StyleSheet |
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

StyleSheetEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


StyleSheet Property

[image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm..::.StyleSheet Property
StyleSheetEditorForm Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.DOM.Design.StyleSheetEditorForm.StyleSheet]

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public StyleSheet StyleSheet { get; set; }
Visual Basic (Declaration)
Public Property StyleSheet As StyleSheet
Visual C++
public:
property StyleSheet^ StyleSheet {
    StyleSheet^ get ();
    void set (StyleSheet^ value);
}

See Also

StyleSheetEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


StyleSheetEditorForm Events

[image] [image]

.NET ModelKit Suite ClassReference
StyleSheetEditorForm Events
StyleSheetEditorForm Class See Also Send Feedback

The StyleSheetEditorForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

StyleSheetEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


TextEditor Class

[image]

.NET ModelKit Suite ClassReference
TextEditor Class
Members See Also Send Feedback
Represents editor for text.

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class TextEditor : UITypeEditor
Visual Basic (Declaration)
Public Class TextEditor _
    Inherits UITypeEditor
Visual C++
public ref class TextEditor : public UITypeEditor

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
PerpetuumSoft.Reporting.DOM.Design..::.TextEditor

See Also

TextEditor Members
PerpetuumSoft.Reporting.DOM.Design Namespace


TextEditor Members

[image] [image]

.NET ModelKit Suite ClassReference
TextEditor Members
TextEditor Class Constructors Methods Properties See Also Send Feedback

The TextEditor type exposes the following members.

Constructors

Name | Description
TextEditor | Creates a new instance of TextEditor class.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

TextEditor Class
PerpetuumSoft.Reporting.DOM.Design Namespace


TextEditor Constructor

[image]

.NET ModelKit Suite ClassReference
TextEditor Constructor
TextEditor Class See Also Send Feedback
Creates a new instance of TextEditor class.

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public TextEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextEditor()

See Also

TextEditor Class
PerpetuumSoft.Reporting.DOM.Design Namespace


TextEditor Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextEditor Methods
TextEditor Class See Also Send Feedback

The TextEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextEditor Class
PerpetuumSoft.Reporting.DOM.Design Namespace


EditValue Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditor..::.EditValue Method
TextEditor Class See Also Send Feedback

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Overridded. See EditValue(ITypeDescriptorContext, IServiceProvider, Object). (Overrides UITypeEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

TextEditor Class
TextEditor Members
PerpetuumSoft.Reporting.DOM.Design Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

.NET ModelKit Suite ClassReference
TextEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
TextEditor Class See Also Send Feedback
Overridded. See EditValue(ITypeDescriptorContext, IServiceProvider, Object).

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ EditValue(
    ITypeDescriptorContext^ context,
    IServiceProvider^ provider,
    Object^ value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
provider
Type: System..::.IServiceProvider
value
Type: System..::.Object

See Also

TextEditor Class
EditValue Overload
PerpetuumSoft.Reporting.DOM.Design Namespace


GetEditStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditor..::.GetEditStyle Method
TextEditor Class See Also Send Feedback

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | Overridded. See GetEditStyle(ITypeDescriptorContext). (Overrides UITypeEditor..::.GetEditStyle(ITypeDescriptorContext).)

See Also

TextEditor Class
TextEditor Members
PerpetuumSoft.Reporting.DOM.Design Namespace


GetEditStyle Method (ITypeDescriptorContext)

[image]

.NET ModelKit Suite ClassReference
TextEditor..::.GetEditStyle Method (ITypeDescriptorContext)
TextEditor Class See Also Send Feedback
Overridded. See GetEditStyle(ITypeDescriptorContext).

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetEditStyle ( _
    context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual C++
public:
virtual UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext

See Also

TextEditor Class
GetEditStyle Overload
PerpetuumSoft.Reporting.DOM.Design Namespace


GetPaintValueSupported Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditor..::.GetPaintValueSupported Method
TextEditor Class See Also Send Feedback

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

TextEditor Class
TextEditor Members
PerpetuumSoft.Reporting.DOM.Design Namespace


PaintValue Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditor..::.PaintValue Method
TextEditor Class See Also Send Feedback

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)

See Also

TextEditor Class
TextEditor Members
PerpetuumSoft.Reporting.DOM.Design Namespace


TextEditor Properties

[image] [image]

.NET ModelKit Suite ClassReference
TextEditor Properties
TextEditor Class See Also Send Feedback

The TextEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

TextEditor Class
PerpetuumSoft.Reporting.DOM.Design Namespace


TextEditorForm Class

[image]

.NET ModelKit Suite ClassReference
TextEditorForm Class
Members See Also Send Feedback
Text editing dialog form

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class TextEditorForm : Form
Visual Basic (Declaration)
Public Class TextEditorForm _
    Inherits Form
Visual C++
public ref class TextEditorForm : public Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
PerpetuumSoft.Reporting.DOM.Design..::.TextEditorForm

See Also

TextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


TextEditorForm Members

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm Members
TextEditorForm Class Constructors Methods Properties Events See Also Send Feedback

The TextEditorForm type exposes the following members.

Constructors

Name | Description
TextEditorForm | Initializes a new instance of the TextEditorForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
ResultText | Gets or sets String
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


TextEditorForm Constructor

[image]

.NET ModelKit Suite ClassReference
TextEditorForm Constructor
TextEditorForm Class See Also Send Feedback
Initializes a new instance of the TextEditorForm class.

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public TextEditorForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextEditorForm()

See Also

TextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


TextEditorForm Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm Methods
TextEditorForm Class See Also Send Feedback

The TextEditorForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

TextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.AccessibilityNotifyClients Method
TextEditorForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

TextEditorForm Class
TextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.BeginInvoke Method
TextEditorForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

TextEditorForm Class
TextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.Dispose Method
TextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | The Dispose Finalize pattern ensures that resources are released when the object is no longer needed (Overrides Form..::.Dispose(Boolean).)

See Also

TextEditorForm Class
TextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.Dispose Method (Boolean)
TextEditorForm Class See Also Send Feedback
The Dispose Finalize pattern ensures that resources are released when the object is no longer needed

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

TextEditorForm Class
Dispose Overload
PerpetuumSoft.Reporting.DOM.Design Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.GetChildAtPoint Method
TextEditorForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

TextEditorForm Class
TextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.Invalidate Method
TextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

TextEditorForm Class
TextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.Invoke Method
TextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

TextEditorForm Class
TextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.MemberwiseClone Method
TextEditorForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TextEditorForm Class
TextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.OnLoad Method
TextEditorForm Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

TextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.PerformLayout Method
TextEditorForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

TextEditorForm Class
TextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.ResumeLayout Method
TextEditorForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

TextEditorForm Class
TextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.RtlTranslateAlignment Method
TextEditorForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

TextEditorForm Class
TextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.Scale Method
TextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

TextEditorForm Class
TextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.Select Method
TextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

TextEditorForm Class
TextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.SetBounds Method
TextEditorForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

TextEditorForm Class
TextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Show Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.Show Method
TextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

TextEditorForm Class
TextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ShowDialog Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.ShowDialog Method
TextEditorForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

TextEditorForm Class
TextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.UpdateBounds Method
TextEditorForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

TextEditorForm Class
TextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.Validate Method
TextEditorForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

TextEditorForm Class
TextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.ValidateChildren Method
TextEditorForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

TextEditorForm Class
TextEditorForm Members
PerpetuumSoft.Reporting.DOM.Design Namespace


TextEditorForm Properties

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm Properties
TextEditorForm Class See Also Send Feedback

The TextEditorForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
ResultText | Gets or sets String
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

TextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


ResultText Property

[image]

.NET ModelKit Suite ClassReference
TextEditorForm..::.ResultText Property
TextEditorForm Class See Also Send Feedback
Gets or sets String

Namespace: PerpetuumSoft.Reporting.DOM.Design
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string ResultText { get; set; }
Visual Basic (Declaration)
Public Property ResultText As String
Visual C++
public:
property String^ ResultText {
    String^ get ();
    void set (String^ value);
}

See Also

TextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


TextEditorForm Events

[image] [image]

.NET ModelKit Suite ClassReference
TextEditorForm Events
TextEditorForm Class See Also Send Feedback

The TextEditorForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TextEditorForm Class
PerpetuumSoft.Reporting.DOM.Design Namespace


PerpetuumSoft.Reporting.DOM.Olap Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.DOM.Olap Namespace
Send Feedback
The PerpetuumSoft.Reporting.DOM.Olap namespace contains classes which are used to build pivot tables in a report.

Classes

Class | Description
CalculateFieldsEventArgs | Provides data for the Pivot table calculate event.
CellCreatingEventArgs | Provides data for the pivot table CellCreating event.
CellCreatingEventArgs..::.ItemInfo | Represents information about pivot table item.
PivotFilterEventArgs | Represents data for the PivotFilter event.
PivotTable | Provides report element for building a pivot table.
PivotTableStyles | Represents styles for pivot table.

Delegates

Delegate | Description
CalculateFieldsEventHandler | Represents the method that calculates values of the pivot table fields.
CellCreatingEventHandler | Represents the method that is called before cell creating.
PivotFilterEventHandler | Represents the method that calculates a condition for pivot table filtering.

Enumerations

Enumeration | Description
CellCreatingEventArgs..::.CellType | Represents pivot table cell type.
PivotTable..::.AutoRowHeightMode | Represents modes of row heights alignment.


CalculateFieldsEventArgs Class

[image]

.NET ModelKit Suite ClassReference
CalculateFieldsEventArgs Class
Members See Also Send Feedback
Provides data for the Pivot table calculate event.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class CalculateFieldsEventArgs
Visual Basic (Declaration)
Public Class CalculateFieldsEventArgs
Visual C++
public ref class CalculateFieldsEventArgs

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM.Olap..::.CalculateFieldsEventArgs

See Also

CalculateFieldsEventArgs Members
PerpetuumSoft.Reporting.DOM.Olap Namespace


CalculateFieldsEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
CalculateFieldsEventArgs Members
CalculateFieldsEventArgs Class Constructors Methods Properties See Also Send Feedback

The CalculateFieldsEventArgs type exposes the following members.

Constructors

Name | Description
CalculateFieldsEventArgs | Initializes a new instance of the CalculateFieldsEventArgs class.

Methods

Name | Description
AddFieldValue | Adds a new field value.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FieldValues | Gets a set of all field values.

See Also

CalculateFieldsEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


CalculateFieldsEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
CalculateFieldsEventArgs Constructor
CalculateFieldsEventArgs Class See Also Send Feedback
Initializes a new instance of the CalculateFieldsEventArgs class.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public CalculateFieldsEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CalculateFieldsEventArgs()

See Also

CalculateFieldsEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


CalculateFieldsEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
CalculateFieldsEventArgs Methods
CalculateFieldsEventArgs Class See Also Send Feedback

The CalculateFieldsEventArgs type exposes the following members.

Methods

Name | Description
AddFieldValue | Adds a new field value.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CalculateFieldsEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


AddFieldValue Method

[image]

.NET ModelKit Suite ClassReference
CalculateFieldsEventArgs..::.AddFieldValue Method
CalculateFieldsEventArgs Class See Also Send Feedback
Adds a new field value.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void AddFieldValue(
    Object key,
    Object value
)
Visual Basic (Declaration)
Public Sub AddFieldValue ( _
    key As Object, _
    value As Object _
)
Visual C++
public:
void AddFieldValue(
    Object^ key,
    Object^ value
)

Parameters

key
Type: System..::.Object
value
Type: System..::.Object

See Also

CalculateFieldsEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


CalculateFieldsEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
CalculateFieldsEventArgs Properties
CalculateFieldsEventArgs Class See Also Send Feedback

The CalculateFieldsEventArgs type exposes the following members.

Properties

Name | Description
FieldValues | Gets a set of all field values.

See Also

CalculateFieldsEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


FieldValues Property

[image]

.NET ModelKit Suite ClassReference
CalculateFieldsEventArgs..::.FieldValues Property
CalculateFieldsEventArgs Class See Also Send Feedback
Gets a set of all field values.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Hashtable FieldValues { get; }
Visual Basic (Declaration)
Public ReadOnly Property FieldValues As Hashtable
Visual C++
public:
property Hashtable^ FieldValues {
    Hashtable^ get ();
}

See Also

CalculateFieldsEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


CalculateFieldsEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
CalculateFieldsEventHandler Delegate
See Also Send Feedback
Represents the method that calculates values of the pivot table fields.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate void CalculateFieldsEventHandler(
    Object sender,
    CalculateFieldsEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub CalculateFieldsEventHandler ( _
    sender As Object, _
    e As CalculateFieldsEventArgs _
)
Visual C++
public delegate void CalculateFieldsEventHandler(
    Object^ sender,
    CalculateFieldsEventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: PerpetuumSoft.Reporting.DOM.Olap..::.CalculateFieldsEventArgs

See Also

PerpetuumSoft.Reporting.DOM.Olap Namespace


CellCreatingEventArgs Class

[image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs Class
Members See Also Send Feedback
Provides data for the pivot table CellCreating event.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class CellCreatingEventArgs : EventArgs
Visual Basic (Declaration)
Public Class CellCreatingEventArgs _
    Inherits EventArgs
Visual C++
public ref class CellCreatingEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.DOM.Olap..::.CellCreatingEventArgs

See Also

CellCreatingEventArgs Members
PerpetuumSoft.Reporting.DOM.Olap Namespace


CellCreatingEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs Members
CellCreatingEventArgs Class Constructors Methods Properties See Also Send Feedback

The CellCreatingEventArgs type exposes the following members.

Constructors

Name | Description
CellCreatingEventArgs | Initializes a new instance of the CellCreatingEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Fact | Gets CellCreatingEventArgs..::.ItemInfo that contains data corresponding to the fact cell.
Style | Gets or sets current cell style.
Text | Gets or sets current cell text.
Type | Gets current cell type.
Value | Gets a current cell value.
XItem | Gets CellCreatingEventArgs..::.ItemInfo that contains data corresponding to the X dimension.
YItem | Gets CellCreatingEventArgs..::.ItemInfo that contains data corresponding to the X dimension.

See Also

CellCreatingEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


CellCreatingEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs Constructor
CellCreatingEventArgs Class See Also Send Feedback
Initializes a new instance of the CellCreatingEventArgs class.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public CellCreatingEventArgs(
    CellCreatingEventArgs..::.CellType type,
    string text,
    string style,
    CellCreatingEventArgs..::.ItemInfo xItem,
    CellCreatingEventArgs..::.ItemInfo yItem,
    CellCreatingEventArgs..::.ItemInfo fact
)
Visual Basic (Declaration)
Public Sub New ( _
    type As CellCreatingEventArgs..::.CellType, _
    text As String, _
    style As String, _
    xItem As CellCreatingEventArgs..::.ItemInfo, _
    yItem As CellCreatingEventArgs..::.ItemInfo, _
    fact As CellCreatingEventArgs..::.ItemInfo _
)
Visual C++
public:
CellCreatingEventArgs(
    CellCreatingEventArgs..::.CellType type,
    String^ text,
    String^ style,
    CellCreatingEventArgs..::.ItemInfo^ xItem,
    CellCreatingEventArgs..::.ItemInfo^ yItem,
    CellCreatingEventArgs..::.ItemInfo^ fact
)

Parameters

type
Type: PerpetuumSoft.Reporting.DOM.Olap..::.CellCreatingEventArgs..::.CellType
text
Type: System..::.String
style
Type: System..::.String
xItem
Type: PerpetuumSoft.Reporting.DOM.Olap..::.CellCreatingEventArgs..::.ItemInfo
yItem
Type: PerpetuumSoft.Reporting.DOM.Olap..::.CellCreatingEventArgs..::.ItemInfo
fact
Type: PerpetuumSoft.Reporting.DOM.Olap..::.CellCreatingEventArgs..::.ItemInfo

See Also

CellCreatingEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


CellCreatingEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs Methods
CellCreatingEventArgs Class See Also Send Feedback

The CellCreatingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CellCreatingEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


CellCreatingEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs Properties
CellCreatingEventArgs Class See Also Send Feedback

The CellCreatingEventArgs type exposes the following members.

Properties

Name | Description
Fact | Gets CellCreatingEventArgs..::.ItemInfo that contains data corresponding to the fact cell.
Style | Gets or sets current cell style.
Text | Gets or sets current cell text.
Type | Gets current cell type.
Value | Gets a current cell value.
XItem | Gets CellCreatingEventArgs..::.ItemInfo that contains data corresponding to the X dimension.
YItem | Gets CellCreatingEventArgs..::.ItemInfo that contains data corresponding to the X dimension.

See Also

CellCreatingEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


Fact Property

[image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs..::.Fact Property
CellCreatingEventArgs Class See Also Send Feedback
Gets CellCreatingEventArgs..::.ItemInfo that contains data corresponding to the fact cell.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public CellCreatingEventArgs..::.ItemInfo Fact { get; }
Visual Basic (Declaration)
Public ReadOnly Property Fact As CellCreatingEventArgs..::.ItemInfo
Visual C++
public:
property CellCreatingEventArgs..::.ItemInfo^ Fact {
    CellCreatingEventArgs..::.ItemInfo^ get ();
}

See Also

CellCreatingEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


Style Property

[image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs..::.Style Property
CellCreatingEventArgs Class See Also Send Feedback
Gets or sets current cell style.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Style { get; set; }
Visual Basic (Declaration)
Public Property Style As String
Visual C++
public:
property String^ Style {
    String^ get ();
    void set (String^ value);
}

See Also

CellCreatingEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


Text Property

[image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs..::.Text Property
CellCreatingEventArgs Class See Also Send Feedback
Gets or sets current cell text.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

CellCreatingEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


Type Property

[image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs..::.Type Property
CellCreatingEventArgs Class See Also Send Feedback
Gets current cell type.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public CellCreatingEventArgs..::.CellType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As CellCreatingEventArgs..::.CellType
Visual C++
public:
property CellCreatingEventArgs..::.CellType Type {
    CellCreatingEventArgs..::.CellType get ();
}

See Also

CellCreatingEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs..::.Value Property
CellCreatingEventArgs Class See Also Send Feedback
Gets a current cell value.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
}

See Also

CellCreatingEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


XItem Property

[image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs..::.XItem Property
CellCreatingEventArgs Class See Also Send Feedback
Gets CellCreatingEventArgs..::.ItemInfo that contains data corresponding to the X dimension.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public CellCreatingEventArgs..::.ItemInfo XItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property XItem As CellCreatingEventArgs..::.ItemInfo
Visual C++
public:
property CellCreatingEventArgs..::.ItemInfo^ XItem {
    CellCreatingEventArgs..::.ItemInfo^ get ();
}

See Also

CellCreatingEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


YItem Property

[image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs..::.YItem Property
CellCreatingEventArgs Class See Also Send Feedback
Gets CellCreatingEventArgs..::.ItemInfo that contains data corresponding to the X dimension.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public CellCreatingEventArgs..::.ItemInfo YItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property YItem As CellCreatingEventArgs..::.ItemInfo
Visual C++
public:
property CellCreatingEventArgs..::.ItemInfo^ YItem {
    CellCreatingEventArgs..::.ItemInfo^ get ();
}

See Also

CellCreatingEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


CellCreatingEventArgs.CellType Enumeration

[image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs..::.CellType Enumeration
CellCreatingEventArgs Class See Also Send Feedback
Represents pivot table cell type.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum CellType
Visual Basic (Declaration)
Public Enumeration CellType
Visual C++
public enum class CellType

Members

Member name | Description
XDimension | X dimension cell type.
YDimension | Ydimension cell type.
Fact | Fact cell type.

See Also

PerpetuumSoft.Reporting.DOM.Olap Namespace


CellCreatingEventArgs.ItemInfo Class

[image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs..::.ItemInfo Class
CellCreatingEventArgs Class Members See Also Send Feedback
Represents information about pivot table item.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ItemInfo
Visual Basic (Declaration)
Public Class ItemInfo
Visual C++
public ref class ItemInfo

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM.Olap..::.CellCreatingEventArgs..::.ItemInfo

See Also

CellCreatingEventArgs..::.ItemInfo Members
PerpetuumSoft.Reporting.DOM.Olap Namespace


CellCreatingEventArgs.ItemInfo Members

[image] [image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs..::.ItemInfo Members
CellCreatingEventArgs..::.ItemInfo Class Constructors Methods Properties See Also Send Feedback

Provides data for the pivot table CellCreating event.

The CellCreatingEventArgs..::.ItemInfo type exposes the following members.

Constructors

Name | Description
CellCreatingEventArgs..::.ItemInfo | Initializes a new instance of the CellCreatingEventArgs..::.ItemInfo class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Field | Gets a current item field.
IsTotal | Gets a value indicating whether the current item has Total value.
Value | Gets a current item value.

See Also

CellCreatingEventArgs..::.ItemInfo Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


CellCreatingEventArgs.ItemInfo Constructor

[image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs..::.ItemInfo Constructor
CellCreatingEventArgs..::.ItemInfo Class See Also Send Feedback
Initializes a new instance of the CellCreatingEventArgs..::.ItemInfo class.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ItemInfo(
    Field field,
    Object value
)
Visual Basic (Declaration)
Public Sub New ( _
    field As Field, _
    value As Object _
)
Visual C++
public:
ItemInfo(
    Field^ field,
    Object^ value
)

Parameters

field
Type: PerpetuumSoft.Reporting.Data.Olap..::.Field
value
Type: System..::.Object

See Also

CellCreatingEventArgs..::.ItemInfo Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


CellCreatingEventArgs.ItemInfo Methods

[image] [image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs..::.ItemInfo Methods
CellCreatingEventArgs..::.ItemInfo Class See Also Send Feedback

The CellCreatingEventArgs..::.ItemInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CellCreatingEventArgs..::.ItemInfo Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


CellCreatingEventArgs.ItemInfo Properties

[image] [image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs..::.ItemInfo Properties
CellCreatingEventArgs..::.ItemInfo Class See Also Send Feedback

The CellCreatingEventArgs..::.ItemInfo type exposes the following members.

Properties

Name | Description
Field | Gets a current item field.
IsTotal | Gets a value indicating whether the current item has Total value.
Value | Gets a current item value.

See Also

CellCreatingEventArgs..::.ItemInfo Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


Field Property

[image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs..::.ItemInfo..::.Field Property
CellCreatingEventArgs..::.ItemInfo Class See Also Send Feedback
Gets a current item field.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Field Field { get; }
Visual Basic (Declaration)
Public ReadOnly Property Field As Field
Visual C++
public:
property Field^ Field {
    Field^ get ();
}

See Also

CellCreatingEventArgs..::.ItemInfo Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


IsTotal Property

[image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs..::.ItemInfo..::.IsTotal Property
CellCreatingEventArgs..::.ItemInfo Class See Also Send Feedback
Gets a value indicating whether the current item has Total value.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool IsTotal { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsTotal As Boolean
Visual C++
public:
property bool IsTotal {
    bool get ();
}

See Also

CellCreatingEventArgs..::.ItemInfo Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


Value Property

[image]

.NET ModelKit Suite ClassReference
CellCreatingEventArgs..::.ItemInfo..::.Value Property
CellCreatingEventArgs..::.ItemInfo Class See Also Send Feedback
Gets a current item value.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
}

See Also

CellCreatingEventArgs..::.ItemInfo Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


CellCreatingEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
CellCreatingEventHandler Delegate
See Also Send Feedback
Represents the method that is called before cell creating.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate void CellCreatingEventHandler(
    Object sender,
    CellCreatingEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub CellCreatingEventHandler ( _
    sender As Object, _
    e As CellCreatingEventArgs _
)
Visual C++
public delegate void CellCreatingEventHandler(
    Object^ sender,
    CellCreatingEventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: PerpetuumSoft.Reporting.DOM.Olap..::.CellCreatingEventArgs

See Also

PerpetuumSoft.Reporting.DOM.Olap Namespace


PivotFilterEventArgs Class

[image]

.NET ModelKit Suite ClassReference
PivotFilterEventArgs Class
Members See Also Send Feedback
Represents data for the PivotFilter event.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class PivotFilterEventArgs : EventArgs
Visual Basic (Declaration)
Public Class PivotFilterEventArgs _
    Inherits EventArgs
Visual C++
public ref class PivotFilterEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.DOM.Olap..::.PivotFilterEventArgs

See Also

PivotFilterEventArgs Members
PerpetuumSoft.Reporting.DOM.Olap Namespace


PivotFilterEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
PivotFilterEventArgs Members
PivotFilterEventArgs Class Constructors Methods Properties See Also Send Feedback

The PivotFilterEventArgs type exposes the following members.

Constructors

Name | Description
PivotFilterEventArgs | Initializes a new instance of the PivotFilterEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PassBy | Gets the value indicating wether the data row is filtered.

See Also

PivotFilterEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


PivotFilterEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
PivotFilterEventArgs Constructor
PivotFilterEventArgs Class See Also Send Feedback
Initializes a new instance of the PivotFilterEventArgs class.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PivotFilterEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PivotFilterEventArgs()

See Also

PivotFilterEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


PivotFilterEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
PivotFilterEventArgs Methods
PivotFilterEventArgs Class See Also Send Feedback

The PivotFilterEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PivotFilterEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


PivotFilterEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
PivotFilterEventArgs Properties
PivotFilterEventArgs Class See Also Send Feedback

The PivotFilterEventArgs type exposes the following members.

Properties

Name | Description
PassBy | Gets the value indicating wether the data row is filtered.

See Also

PivotFilterEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


PassBy Property

[image]

.NET ModelKit Suite ClassReference
PivotFilterEventArgs..::.PassBy Property
PivotFilterEventArgs Class See Also Send Feedback
Gets the value indicating wether the data row is filtered.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool PassBy { get; set; }
Visual Basic (Declaration)
Public Property PassBy As Boolean
Visual C++
public:
property bool PassBy {
    bool get ();
    void set (bool value);
}

See Also

PivotFilterEventArgs Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


PivotFilterEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
PivotFilterEventHandler Delegate
See Also Send Feedback
Represents the method that calculates a condition for pivot table filtering.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate void PivotFilterEventHandler(
    Object sender,
    PivotFilterEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub PivotFilterEventHandler ( _
    sender As Object, _
    e As PivotFilterEventArgs _
)
Visual C++
public delegate void PivotFilterEventHandler(
    Object^ sender,
    PivotFilterEventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: PerpetuumSoft.Reporting.DOM.Olap..::.PivotFilterEventArgs

See Also

PerpetuumSoft.Reporting.DOM.Olap Namespace


PivotTable Class

[image]

.NET ModelKit Suite ClassReference
PivotTable Class
Members See Also Send Feedback
Provides report element for building a pivot table.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class PivotTable : RegularBandBase
Visual Basic (Declaration)
Public Class PivotTable _
    Inherits RegularBandBase
Visual C++
public ref class PivotTable : public RegularBandBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM..::.ReportComponent
PerpetuumSoft.Reporting.DOM..::.ReportControl
PerpetuumSoft.Reporting.DOM..::.ContainerControl
PerpetuumSoft.Reporting.DOM..::.Section
PerpetuumSoft.Reporting.DOM..::.BandBase
PerpetuumSoft.Reporting.DOM..::.RegularBandBase
PerpetuumSoft.Reporting.DOM.Olap..::.PivotTable

See Also

PivotTable Members
PerpetuumSoft.Reporting.DOM.Olap Namespace


PivotTable Members

[image] [image]

.NET ModelKit Suite ClassReference
PivotTable Members
PivotTable Class Constructors Methods Properties Events See Also Send Feedback

The PivotTable type exposes the following members.

Constructors

Name | Description
PivotTable | Initializes a new instance of the PivotTable class.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Inherited from Section.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Overridden. See InitNew()()(). (Overrides ReportControl..::.InitNew()()().)
IsValidChild | Implements IsValidChild(ReportControl). (Overrides RegularBandBase..::.IsValidChild(ReportControl).)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateFields | Raises the CalculateFields event.
OnCellCreating | Raises the CellCreating event.
OnFilter | Raises the Filter event.
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Raises the Paint event. (Overrides BandBase..::.OnPaint(PaintArguments).)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Overrides ReportControl..::.Render()()().)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
RunPropertyDesigner | Overridden. See RunPropertyDesigner(IReportDesignerService). (Overrides ReportControlRunPropertyDesigner(IReportDesignerService).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

Properties

Name | Description
AutoColumnWidth | Gets or sets a value indicating whether the column width was aligned by cell content.
AutoRowHeight | Gets or sets row height aligment mode.
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DataSource | Gets or sets name of a data source used to build the pivot table.
DimensionOnEveryPage | Gets or sets a value indicating whether the dimension will be displayed on each page.
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
FilterExpression | Gets and sets the code for the script that will be invoked during filtering.
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Layout | Gets or sets pivot table layout settings.
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NestedFields | Determines the list of nested data sources.
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
RowHeight | Gets or sets default row height.
Shift | Determines the shift on x-axis.
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
ShowRepeatText | Gets or sets a value indicating whether the endurable text was displayed.
ShowSingleFact | Gets or sets whether a single fact caption should be visible.
ShowTableCaption | Gets or sets a value indicating whether the pivot table caption will be displayed.
ShowZeroValues |
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Styles | Gets or sets styles for each part of a resulting table.
TableCaption | Gets or sets table caption text.
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

Events

Name | Description
CellCreating | Is raised when a cell is created
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


PivotTable Constructor

[image]

.NET ModelKit Suite ClassReference
PivotTable Constructor
PivotTable Class See Also Send Feedback
Initializes a new instance of the PivotTable class.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PivotTable()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PivotTable()

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


PivotTable Methods

[image] [image]

.NET ModelKit Suite ClassReference
PivotTable Methods
PivotTable Class See Also Send Feedback

The PivotTable type exposes the following members.

Methods

Name | Description
BringToFront | Brings the control to the front of all controls in container. (Inherited from ReportControl.)
CalculateCaretPosition | Calculates the current position in the report for placing the current band. (Inherited from Section.)
CalculateRenderHeight | Calculates the height of the current band's content in the final report. (Inherited from BandBase.)
CheckConditions | Checks the band's condition. (Inherited from Section.)
ControlAt | Returns a ReportControl object that is found in the location specified by the given PointF. (Inherited from BandBase.)
ControlByName | Finds a nested ReportControl object with the specified name. (Inherited from ContainerControl.)
CreateBlankControl | Creates a control for locating in the final document. It is used when element rendering. (Inherited from ReportControl.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParent | Finds the ReportControl's parent. (Inherited from ContainerControl.)
FindText | Returns whether the control contains the specified text. (Inherited from ReportControl.)
GetDesignerToolTip | Returns string that will be shown in a control tooltip. (Inherited from ReportControl.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetScripts | Overloaded.
GetSectionCaption | Returns the title string of the band. (Inherited from BandBase.)
GetSectionCaptionColor | Returns the color of the title bar. (Inherited from Section.)
GetStyle | Returns a style object for the control. (Inherited from ReportControl.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GrowControls | Resizes controls within the current band that have the GrowToBottom property set to true. (Inherited from BandBase.)
InitNew | Overridden. See InitNew()()(). (Overrides ReportControl..::.InitNew()()().)
IsValidChild | Implements IsValidChild(ReportControl). (Overrides RegularBandBase..::.IsValidChild(ReportControl).)
IsValidParent | Returns whether the control can be placed into the specified container. (Inherited from ReportControl.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBackward | Moves the control backward in Z-Buffer. (Inherited from ReportControl.)
MoveForward | Moves the control forward in Z-Buffer. (Inherited from ReportControl.)
OnCalculateFields | Raises the CalculateFields event.
OnCellCreating | Raises the CellCreating event.
OnFilter | Raises the Filter event.
OnGenerate | Raises Generate event. (Inherited from ReportControl.)
OnPaint | Raises the Paint event. (Overrides BandBase..::.OnPaint(PaintArguments).)
OnSizeChanged | Is called after the Size property is changed. (Inherited from ReportControl.)
OnStyleNameChanged | Executes if style name was changed. (Inherited from ReportControl.)
Paint | Invokes OnPaint method. (Inherited from ReportControl.)
PopulateProperties | Fills the properties of the final rendered control. (Inherited from ReportControl.)
Prepare | Prepares the control for rendering. (Inherited from ReportControl.)
PrepareControls | Prepares control before displaying. (Inherited from Section.)
PutToBack | Puts the control to the back of all controls in container. (Inherited from ReportControl.)
RaiseGenerate | Invokes OnGenerate method. (Inherited from ReportControl.)
ReCalculateBounds | Recalculates the bounds of the current band object using all environment constraints and specified current state. (Inherited from BandBase.)
Render | Overridden. See Render()()(). (Overrides ReportControl..::.Render()()().)
RenderControls | Renders control for output. (Inherited from Section.)
RenderLocation | Calculates location of the control in the rendered report. (Inherited from ReportControl.)
RunPropertyBindingDesigner | Runs designer for the property binding defined by the bindingName parameter. (Inherited from ReportControl.)
RunPropertyDesigner | Overridden. See RunPropertyDesigner(IReportDesignerService). (Overrides ReportControlRunPropertyDesigner(IReportDesignerService).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdatePageArea | Calculates the remaining free page area after the band is rendered. (Inherited from Section.)

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


GetScripts Method

[image] [image]

.NET ModelKit Suite ClassReference
PivotTable..::.GetScripts Method
PivotTable Class See Also Send Feedback

Overload List

Name | Description
GetScripts()()() | Returns the collection of all scripts assigned to the component. (Inherited from ReportComponent.)
GetScripts(ScriptInfoCollection) | Overridden. See GetScripts(ScriptInfoCollection). (Overrides ReportControl..::.GetScripts(ScriptInfoCollection).)

See Also

PivotTable Class
PivotTable Members
PerpetuumSoft.Reporting.DOM.Olap Namespace


GetScripts Method (ScriptInfoCollection)

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.GetScripts Method (ScriptInfoCollection)
PivotTable Class See Also Send Feedback
Overridden. See GetScripts(ScriptInfoCollection).

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void GetScripts(
    ScriptInfoCollection scripts
)
Visual Basic (Declaration)
Public Overrides Sub GetScripts ( _
    scripts As ScriptInfoCollection _
)
Visual C++
public:
virtual void GetScripts(
    ScriptInfoCollection^ scripts
) override

Parameters

scripts
Type: PerpetuumSoft.Reporting.Rendering..::.ScriptInfoCollection

See Also

PivotTable Class
GetScripts Overload
PerpetuumSoft.Reporting.DOM.Olap Namespace


InitNew Method

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.InitNew Method
PivotTable Class See Also Send Feedback
Overridden. See InitNew()()().

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void InitNew()
Visual Basic (Declaration)
Public Overrides Sub InitNew
Visual C++
public:
virtual void InitNew() override

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


IsValidChild Method

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.IsValidChild Method
PivotTable Class See Also Send Feedback
Implements IsValidChild(ReportControl).

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override bool IsValidChild(
    ReportControl c
)
Visual Basic (Declaration)
Public Overrides Function IsValidChild ( _
    c As ReportControl _
) As Boolean
Visual C++
public:
virtual bool IsValidChild(
    ReportControl^ c
) override

Parameters

c
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

Implements

IContainerControl..::.IsValidChild(ReportControl)

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


OnCalculateFields Method

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.OnCalculateFields Method
PivotTable Class See Also Send Feedback
Raises the CalculateFields event.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnCalculateFields(
    CalculateFieldsEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnCalculateFields ( _
    e As CalculateFieldsEventArgs _
)
Visual C++
protected:
virtual void OnCalculateFields(
    CalculateFieldsEventArgs^ e
)

Parameters

e
Type: PerpetuumSoft.Reporting.DOM.Olap..::.CalculateFieldsEventArgs

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


OnCellCreating Method

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.OnCellCreating Method
PivotTable Class See Also Send Feedback
Raises the CellCreating event.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected void OnCellCreating(
    CellCreatingEventArgs e
)
Visual Basic (Declaration)
Protected Sub OnCellCreating ( _
    e As CellCreatingEventArgs _
)
Visual C++
protected:
void OnCellCreating(
    CellCreatingEventArgs^ e
)

Parameters

e
Type: PerpetuumSoft.Reporting.DOM.Olap..::.CellCreatingEventArgs

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


OnFilter Method

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.OnFilter Method
PivotTable Class See Also Send Feedback
Raises the Filter event.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnFilter(
    PivotFilterEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnFilter ( _
    e As PivotFilterEventArgs _
)
Visual C++
protected:
virtual void OnFilter(
    PivotFilterEventArgs^ e
)

Parameters

e
Type: PerpetuumSoft.Reporting.DOM.Olap..::.PivotFilterEventArgs

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


OnPaint Method

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.OnPaint Method
PivotTable Class See Also Send Feedback
Raises the Paint event.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnPaint(
    PaintArguments args
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    args As PaintArguments _
)
Visual C++
protected:
virtual void OnPaint(
    PaintArguments^ args
) override

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.PaintArguments

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.Render Method
PivotTable Class See Also Send Feedback
Overridden. See Render()()().

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void Render()
Visual Basic (Declaration)
Public Overrides Sub Render
Visual C++
public:
virtual void Render() override

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


RunPropertyDesigner Method

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.RunPropertyDesigner Method
PivotTable Class See Also Send Feedback
Overridden. See RunPropertyDesigner(IReportDesignerService).

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override void RunPropertyDesigner(
    IReportDesignerService service
)
Visual Basic (Declaration)
Public Overrides Sub RunPropertyDesigner ( _
    service As IReportDesignerService _
)
Visual C++
public:
virtual void RunPropertyDesigner(
    IReportDesignerService^ service
) override

Parameters

service
Type: PerpetuumSoft.Reporting.Designer..::.IReportDesignerService

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


PivotTable Properties

[image] [image]

.NET ModelKit Suite ClassReference
PivotTable Properties
PivotTable Class See Also Send Feedback

The PivotTable type exposes the following members.

Properties

Name | Description
AutoColumnWidth | Gets or sets a value indicating whether the column width was aligned by cell content.
AutoRowHeight | Gets or sets row height aligment mode.
Bookmark | Gets and sets a bookmark for the control. (Inherited from ReportControl.)
Bounds | Gets and sets the control's bounds within the parent control. (Inherited from ReportControl.)
CanGrow | Gets and sets whether the current band can grow in size during rendering to match a bigger size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
CanShrink | Gets and sets whether the current band can shrink in size during rendering to match a smaller size of its rendered content regardless of the band's size in the report template. (Inherited from BandBase.)
Controls | Gets the collection of the nested controls. (Inherited from ContainerControl.)
DataBindings | Gets the collection of the control's properties data/expressions bindings. (Inherited from ReportControl.)
DataSource | Gets or sets name of a data source used to build the pivot table.
DimensionOnEveryPage | Gets or sets a value indicating whether the dimension will be displayed on each page.
Document | Gets the document. (Inherited from ReportControl.)
Engine | Gets the RenderEngine used. (Inherited from ReportControl.)
FilterExpression | Gets and sets the code for the script that will be invoked during filtering.
GenerateScript | Gets and sets the code for the script that will be invoked before rendering. (Inherited from ReportControl.)
Hyperlink | Gets and sets a hyperlink for the control. (Inherited from ReportControl.)
Layout | Gets or sets pivot table layout settings.
Location | Gets and sets the control's top-left corner position within the parent control. (Inherited from ReportControl.)
MasterBand | Gets the master band. (Inherited from Section.)
Name | Gets and sets the name of the component. (Inherited from ReportComponent.)
NestedFields | Determines the list of nested data sources.
NewColumnAfter | Gets or sets value indicating whether a new column should be inserted after the band's content. (Inherited from RegularBandBase.)
NewColumnBefore | Gets and sets whether a new column should be started for the band's content rendering. (Inherited from RegularBandBase.)
NewPageAfter | Gets or sets value indicating whether a new page should be inserted after the band's content. (Inherited from RegularBandBase.)
NewPageBefore | Gets and sets whether the band should be rendered on a new page. (Inherited from RegularBandBase.)
Page | Gets the page. (Inherited from ReportControl.)
PageBounds | Gets and sets the control's bounds within the page. (Inherited from ReportControl.)
PageLocation | Gets and sets the control's top-left corner position within the page. (Inherited from ReportControl.)
Parent | Gets and sets the parent control. (Inherited from ReportControl.)
RenderHeight | Gets and sets the height of the final control. (Inherited from ReportControl.)
RowHeight | Gets or sets default row height.
Shift | Determines the shift on x-axis.
ShowCaption | Gets or sets whether the title line should be drawn for the current band object in design mode. (Inherited from BandBase.)
ShowRepeatText | Gets or sets a value indicating whether the endurable text was displayed.
ShowSingleFact | Gets or sets whether a single fact caption should be visible.
ShowTableCaption | Gets or sets a value indicating whether the pivot table caption will be displayed.
ShowZeroValues |
Size | Gets and sets the size of the control. (Inherited from ReportControl.)
SortPriority | Gets the band's priority for sorting operations. (Inherited from Section.)
StyleName | Gets and sets the name of the style applied to the control. (Inherited from ReportControl.)
Styles | Gets or sets styles for each part of a resulting table.
TableCaption | Gets or sets table caption text.
Tag | Gets and sets an additional information for the control. (Inherited from ReportControl.)
ToolTip | Gets and sets a tooltip for the control. (Inherited from ReportControl.)
Visible | Gets and sets whether the control should be rendered to the final document. (Inherited from ReportControl.)

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


AutoColumnWidth Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.AutoColumnWidth Property
PivotTable Class See Also Send Feedback
Gets or sets a value indicating whether the column width was aligned by cell content.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool AutoColumnWidth { get; set; }
Visual Basic (Declaration)
Public Property AutoColumnWidth As Boolean
Visual C++
public:
property bool AutoColumnWidth {
    bool get ();
    void set (bool value);
}

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


AutoRowHeight Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.AutoRowHeight Property
PivotTable Class See Also Send Feedback
Gets or sets row height aligment mode.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PivotTable..::.AutoRowHeightMode AutoRowHeight { get; set; }
Visual Basic (Declaration)
Public Property AutoRowHeight As PivotTable..::.AutoRowHeightMode
Visual C++
public:
property PivotTable..::.AutoRowHeightMode AutoRowHeight {
    PivotTable..::.AutoRowHeightMode get ();
    void set (PivotTable..::.AutoRowHeightMode value);
}

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


DataSource Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.DataSource Property
PivotTable Class See Also Send Feedback
Gets or sets name of a data source used to build the pivot table.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As String
Visual C++
public:
property String^ DataSource {
    String^ get ();
    void set (String^ value);
}

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


DimensionOnEveryPage Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.DimensionOnEveryPage Property
PivotTable Class See Also Send Feedback
Gets or sets a value indicating whether the dimension will be displayed on each page.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool DimensionOnEveryPage { get; set; }
Visual Basic (Declaration)
Public Property DimensionOnEveryPage As Boolean
Visual C++
public:
property bool DimensionOnEveryPage {
    bool get ();
    void set (bool value);
}

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


FilterExpression Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.FilterExpression Property
PivotTable Class See Also Send Feedback
Gets and sets the code for the script that will be invoked during filtering.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string FilterExpression { get; set; }
Visual Basic (Declaration)
Public Property FilterExpression As String
Visual C++
public:
property String^ FilterExpression {
    String^ get ();
    void set (String^ value);
}

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


Layout Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.Layout Property
PivotTable Class See Also Send Feedback
Gets or sets pivot table layout settings.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataCubeLayout Layout { get; set; }
Visual Basic (Declaration)
Public Property Layout As DataCubeLayout
Visual C++
public:
property DataCubeLayout^ Layout {
    DataCubeLayout^ get ();
    void set (DataCubeLayout^ value);
}

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


NestedFields Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.NestedFields Property
PivotTable Class See Also Send Feedback
Determines the list of nested data sources.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public NestedFieldCollection NestedFields { get; set; }
Visual Basic (Declaration)
Public Property NestedFields As NestedFieldCollection
Visual C++
public:
property NestedFieldCollection^ NestedFields {
    NestedFieldCollection^ get ();
    void set (NestedFieldCollection^ value);
}

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


RowHeight Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.RowHeight Property
PivotTable Class See Also Send Feedback
Gets or sets default row height.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double RowHeight { get; set; }
Visual Basic (Declaration)
Public Property RowHeight As Double
Visual C++
public:
property double RowHeight {
    double get ();
    void set (double value);
}

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


Shift Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.Shift Property
PivotTable Class See Also Send Feedback
Determines the shift on x-axis.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double Shift { get; set; }
Visual Basic (Declaration)
Public Property Shift As Double
Visual C++
public:
property double Shift {
    double get ();
    void set (double value);
}

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


ShowRepeatText Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.ShowRepeatText Property
PivotTable Class See Also Send Feedback
Gets or sets a value indicating whether the endurable text was displayed.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowRepeatText { get; set; }
Visual Basic (Declaration)
Public Property ShowRepeatText As Boolean
Visual C++
public:
property bool ShowRepeatText {
    bool get ();
    void set (bool value);
}

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


ShowSingleFact Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.ShowSingleFact Property
PivotTable Class See Also Send Feedback
Gets or sets whether a single fact caption should be visible.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowSingleFact { get; set; }
Visual Basic (Declaration)
Public Property ShowSingleFact As Boolean
Visual C++
public:
property bool ShowSingleFact {
    bool get ();
    void set (bool value);
}

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


ShowTableCaption Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.ShowTableCaption Property
PivotTable Class See Also Send Feedback
Gets or sets a value indicating whether the pivot table caption will be displayed.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowTableCaption { get; set; }
Visual Basic (Declaration)
Public Property ShowTableCaption As Boolean
Visual C++
public:
property bool ShowTableCaption {
    bool get ();
    void set (bool value);
}

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


ShowZeroValues Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.ShowZeroValues Property
PivotTable Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.DOM.Olap.PivotTable.ShowZeroValues]

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowZeroValues { get; set; }
Visual Basic (Declaration)
Public Property ShowZeroValues As Boolean
Visual C++
public:
property bool ShowZeroValues {
    bool get ();
    void set (bool value);
}

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


Styles Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.Styles Property
PivotTable Class See Also Send Feedback
Gets or sets styles for each part of a resulting table.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PivotTableStyles Styles { get; set; }
Visual Basic (Declaration)
Public Property Styles As PivotTableStyles
Visual C++
public:
property PivotTableStyles^ Styles {
    PivotTableStyles^ get ();
    void set (PivotTableStyles^ value);
}

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


TableCaption Property

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.TableCaption Property
PivotTable Class See Also Send Feedback
Gets or sets table caption text.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string TableCaption { get; set; }
Visual Basic (Declaration)
Public Property TableCaption As String
Visual C++
public:
property String^ TableCaption {
    String^ get ();
    void set (String^ value);
}

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


PivotTable Events

[image] [image]

.NET ModelKit Suite ClassReference
PivotTable Events
PivotTable Class See Also Send Feedback

The PivotTable type exposes the following members.

Events

Name | Description
CellCreating | Is raised when a cell is created
Generate | Occurs before the control is rendered. (Inherited from ReportControl.)

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


CellCreating Event

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.CellCreating Event
PivotTable Class See Also Send Feedback
Is raised when a cell is created

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event CellCreatingEventHandler CellCreating
Visual Basic (Declaration)
Public Event CellCreating As CellCreatingEventHandler
Visual C++
public:
 event CellCreatingEventHandler^ CellCreating {
    void add (CellCreatingEventHandler^ value);
    void remove (CellCreatingEventHandler^ value);
}

See Also

PivotTable Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


PivotTable.AutoRowHeightMode Enumeration

[image]

.NET ModelKit Suite ClassReference
PivotTable..::.AutoRowHeightMode Enumeration
PivotTable Class See Also Send Feedback
Represents modes of row heights alignment.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum AutoRowHeightMode
Visual Basic (Declaration)
Public Enumeration AutoRowHeightMode
Visual C++
public enum class AutoRowHeightMode

Members

Member name | Description
None | Row heights align is not set.
Similar | All rows has the same height.
Dissimilar | Each row has its own height.

See Also

PerpetuumSoft.Reporting.DOM.Olap Namespace


PivotTableStyles Class

[image]

.NET ModelKit Suite ClassReference
PivotTableStyles Class
Members See Also Send Feedback
Represents styles for pivot table.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class PivotTableStyles
Visual Basic (Declaration)
Public Class PivotTableStyles
Visual C++
public ref class PivotTableStyles

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.DOM.Olap..::.PivotTableStyles

See Also

PivotTableStyles Members
PerpetuumSoft.Reporting.DOM.Olap Namespace


PivotTableStyles Members

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableStyles Members
PivotTableStyles Class Constructors Methods Properties See Also Send Feedback

The PivotTableStyles type exposes the following members.

Constructors

Name | Description
PivotTableStyles | Initializes a new instance of the PivotTableStyles class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
EvenRowFactStyle | Gets or sets style for fact cells included in even row.
FieldCaptionStyle | Gets or sets style for cells representing field caption.
GroupTotalStyle | Gets or sets style for fact cells containing group total.
MainTotalStyle | Gets or sets style for fact cells containing pivot table total.
OddRowFactStyle | Gets or sets style for fact cells included in odd row.
TableCaptionStyle | Gets or sets style for cells representing table caption.
TotalStyle | Gets or sets style for fact cells containing total by row or column.
XDimensionStyle | Gets or sets style for X dimension cells.
YDimensionStyle | Gets or sets style for Y dimension cells.

See Also

PivotTableStyles Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


PivotTableStyles Constructor

[image]

.NET ModelKit Suite ClassReference
PivotTableStyles Constructor
PivotTableStyles Class See Also Send Feedback
Initializes a new instance of the PivotTableStyles class.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PivotTableStyles()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PivotTableStyles()

See Also

PivotTableStyles Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


PivotTableStyles Methods

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableStyles Methods
PivotTableStyles Class See Also Send Feedback

The PivotTableStyles type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

PivotTableStyles Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
PivotTableStyles..::.ToString Method
PivotTableStyles Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

PivotTableStyles Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


PivotTableStyles Properties

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableStyles Properties
PivotTableStyles Class See Also Send Feedback

The PivotTableStyles type exposes the following members.

Properties

Name | Description
EvenRowFactStyle | Gets or sets style for fact cells included in even row.
FieldCaptionStyle | Gets or sets style for cells representing field caption.
GroupTotalStyle | Gets or sets style for fact cells containing group total.
MainTotalStyle | Gets or sets style for fact cells containing pivot table total.
OddRowFactStyle | Gets or sets style for fact cells included in odd row.
TableCaptionStyle | Gets or sets style for cells representing table caption.
TotalStyle | Gets or sets style for fact cells containing total by row or column.
XDimensionStyle | Gets or sets style for X dimension cells.
YDimensionStyle | Gets or sets style for Y dimension cells.

See Also

PivotTableStyles Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


EvenRowFactStyle Property

[image]

.NET ModelKit Suite ClassReference
PivotTableStyles..::.EvenRowFactStyle Property
PivotTableStyles Class See Also Send Feedback
Gets or sets style for fact cells included in even row.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string EvenRowFactStyle { get; set; }
Visual Basic (Declaration)
Public Property EvenRowFactStyle As String
Visual C++
public:
property String^ EvenRowFactStyle {
    String^ get ();
    void set (String^ value);
}

See Also

PivotTableStyles Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


FieldCaptionStyle Property

[image]

.NET ModelKit Suite ClassReference
PivotTableStyles..::.FieldCaptionStyle Property
PivotTableStyles Class See Also Send Feedback
Gets or sets style for cells representing field caption.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string FieldCaptionStyle { get; set; }
Visual Basic (Declaration)
Public Property FieldCaptionStyle As String
Visual C++
public:
property String^ FieldCaptionStyle {
    String^ get ();
    void set (String^ value);
}

See Also

PivotTableStyles Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


GroupTotalStyle Property

[image]

.NET ModelKit Suite ClassReference
PivotTableStyles..::.GroupTotalStyle Property
PivotTableStyles Class See Also Send Feedback
Gets or sets style for fact cells containing group total.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string GroupTotalStyle { get; set; }
Visual Basic (Declaration)
Public Property GroupTotalStyle As String
Visual C++
public:
property String^ GroupTotalStyle {
    String^ get ();
    void set (String^ value);
}

See Also

PivotTableStyles Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


MainTotalStyle Property

[image]

.NET ModelKit Suite ClassReference
PivotTableStyles..::.MainTotalStyle Property
PivotTableStyles Class See Also Send Feedback
Gets or sets style for fact cells containing pivot table total.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string MainTotalStyle { get; set; }
Visual Basic (Declaration)
Public Property MainTotalStyle As String
Visual C++
public:
property String^ MainTotalStyle {
    String^ get ();
    void set (String^ value);
}

See Also

PivotTableStyles Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


OddRowFactStyle Property

[image]

.NET ModelKit Suite ClassReference
PivotTableStyles..::.OddRowFactStyle Property
PivotTableStyles Class See Also Send Feedback
Gets or sets style for fact cells included in odd row.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string OddRowFactStyle { get; set; }
Visual Basic (Declaration)
Public Property OddRowFactStyle As String
Visual C++
public:
property String^ OddRowFactStyle {
    String^ get ();
    void set (String^ value);
}

See Also

PivotTableStyles Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


TableCaptionStyle Property

[image]

.NET ModelKit Suite ClassReference
PivotTableStyles..::.TableCaptionStyle Property
PivotTableStyles Class See Also Send Feedback
Gets or sets style for cells representing table caption.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string TableCaptionStyle { get; set; }
Visual Basic (Declaration)
Public Property TableCaptionStyle As String
Visual C++
public:
property String^ TableCaptionStyle {
    String^ get ();
    void set (String^ value);
}

See Also

PivotTableStyles Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


TotalStyle Property

[image]

.NET ModelKit Suite ClassReference
PivotTableStyles..::.TotalStyle Property
PivotTableStyles Class See Also Send Feedback
Gets or sets style for fact cells containing total by row or column.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string TotalStyle { get; set; }
Visual Basic (Declaration)
Public Property TotalStyle As String
Visual C++
public:
property String^ TotalStyle {
    String^ get ();
    void set (String^ value);
}

See Also

PivotTableStyles Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


XDimensionStyle Property

[image]

.NET ModelKit Suite ClassReference
PivotTableStyles..::.XDimensionStyle Property
PivotTableStyles Class See Also Send Feedback
Gets or sets style for X dimension cells.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string XDimensionStyle { get; set; }
Visual Basic (Declaration)
Public Property XDimensionStyle As String
Visual C++
public:
property String^ XDimensionStyle {
    String^ get ();
    void set (String^ value);
}

See Also

PivotTableStyles Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


YDimensionStyle Property

[image]

.NET ModelKit Suite ClassReference
PivotTableStyles..::.YDimensionStyle Property
PivotTableStyles Class See Also Send Feedback
Gets or sets style for Y dimension cells.

Namespace: PerpetuumSoft.Reporting.DOM.Olap
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string YDimensionStyle { get; set; }
Visual Basic (Declaration)
Public Property YDimensionStyle As String
Visual C++
public:
property String^ YDimensionStyle {
    String^ get ();
    void set (String^ value);
}

See Also

PivotTableStyles Class
PerpetuumSoft.Reporting.DOM.Olap Namespace


PerpetuumSoft.Reporting.Export Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Export Namespace
Send Feedback
The PerpetuumSoft.Reporting.Export namespace contains classes which are used to export document to different formats

Classes

Class | Description
ExportFilter | Provides common behavoior for all export filters.
ExportFilterFactory | Provides a uniform mechanism for creating export filters instances.
PageRangeControl | UserControl for editing page range.


ExportFilter Class

[image]

.NET ModelKit Suite ClassReference
ExportFilter Class
Members See Also Send Feedback
Provides common behavoior for all export filters.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract class ExportFilter : Component
Visual Basic (Declaration)
Public MustInherit Class ExportFilter _
    Inherits Component
Visual C++
public ref class ExportFilter abstract : public Component

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Export..::.ExportFilter
PerpetuumSoft.Reporting.Export.Csv..::.CsvExportFilter
PerpetuumSoft.Reporting.Export.Excel..::.ExcelExportFilter
PerpetuumSoft.Reporting.Export.ExcelXml..::.ExcelXmlExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.ImageExportFilter
PerpetuumSoft.Reporting.Export.Html..::.HtmlExportFilter
PerpetuumSoft.Reporting.Export.Pdf..::.PdfExportFilter
PerpetuumSoft.Reporting.Export.Rtf..::.RtfExportFilter
PerpetuumSoft.Reporting.Export.Xps..::.XpsExportFilter

See Also

ExportFilter Members
PerpetuumSoft.Reporting.Export Namespace


ExportFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
ExportFilter Members
ExportFilter Class Constructors Methods Properties Events See Also Send Feedback

The ExportFilter type exposes the following members.

Constructors

Name | Description
ExportFilter | Initializes a new instance of the ExportFilter class

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns FilterFactory for the filter.
GetFilterFileExtension | Returns standard file extension for the filter.
GetFilterFormat | Returns export format name for the filter.
GetFilterName | Returns the filter name.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
Register | Registers the standard filters.
RegisterExportFilter | Registers a new export filter factory.
SelectPages | Returns collection of pages for the page range.
ShowDialog | Shows filter settings dialog.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExportFilters | Represents a collection of registered Export Filter Factories.
PagesRange | Gets or sets pages range for export.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ExportFilter Class
PerpetuumSoft.Reporting.Export Namespace


ExportFilter Constructor

[image]

.NET ModelKit Suite ClassReference
ExportFilter Constructor
ExportFilter Class See Also Send Feedback
Initializes a new instance of the ExportFilter class

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected ExportFilter()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ExportFilter()

See Also

ExportFilter Class
PerpetuumSoft.Reporting.Export Namespace


ExportFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ExportFilter Methods
ExportFilter Class See Also Send Feedback

The ExportFilter type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns FilterFactory for the filter.
GetFilterFileExtension | Returns standard file extension for the filter.
GetFilterFormat | Returns export format name for the filter.
GetFilterName | Returns the filter name.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
Register | Registers the standard filters.
RegisterExportFilter | Registers a new export filter factory.
SelectPages | Returns collection of pages for the page range.
ShowDialog | Shows filter settings dialog.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ExportFilter Class
PerpetuumSoft.Reporting.Export Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ExportFilter..::.Dispose Method
ExportFilter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

ExportFilter Class
ExportFilter Members
PerpetuumSoft.Reporting.Export Namespace


Export Method

[image] [image]

.NET ModelKit Suite ClassReference
ExportFilter..::.Export Method
ExportFilter Class See Also Send Feedback

Overload List

Name | Description
Export(Document, Stream) | Exports the specified report document to the specified file.
Export(Document, String) | Exports the specified report document to the specified file.
Export(Document, String, Boolean) | Exports the specified report document to the specified file and optionally shows export filter settings dialog.

See Also

ExportFilter Class
ExportFilter Members
PerpetuumSoft.Reporting.Export Namespace


Export Method (Document, Stream)

[image]

.NET ModelKit Suite ClassReference
ExportFilter..::.Export Method (Document, Stream)
ExportFilter Class See Also Send Feedback
Exports the specified report document to the specified file.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Export(
    Document document,
    Stream stream
)
Visual Basic (Declaration)
Public Sub Export ( _
    document As Document, _
    stream As Stream _
)
Visual C++
public:
void Export(
    Document^ document,
    Stream^ stream
)

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
stream
Type: System.IO..::.Stream

See Also

ExportFilter Class
Export Overload
PerpetuumSoft.Reporting.Export Namespace


Export Method (Document, String)

[image]

.NET ModelKit Suite ClassReference
ExportFilter..::.Export Method (Document, String)
ExportFilter Class See Also Send Feedback
Exports the specified report document to the specified file.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Export(
    Document document,
    string fileName
)
Visual Basic (Declaration)
Public Sub Export ( _
    document As Document, _
    fileName As String _
)
Visual C++
public:
void Export(
    Document^ document,
    String^ fileName
)

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
fileName
Type: System..::.String

See Also

ExportFilter Class
Export Overload
PerpetuumSoft.Reporting.Export Namespace


Export Method (Document, String, Boolean)

[image]

.NET ModelKit Suite ClassReference
ExportFilter..::.Export Method (Document, String, Boolean)
ExportFilter Class See Also Send Feedback
Exports the specified report document to the specified file and optionally shows export filter settings dialog.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Export(
    Document document,
    string fileName,
    bool showDialog
)
Visual Basic (Declaration)
Public Sub Export ( _
    document As Document, _
    fileName As String, _
    showDialog As Boolean _
)
Visual C++
public:
void Export(
    Document^ document,
    String^ fileName,
    bool showDialog
)

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
fileName
Type: System..::.String
showDialog
Type: System..::.Boolean

See Also

ExportFilter Class
Export Overload
PerpetuumSoft.Reporting.Export Namespace


ExportDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
ExportFilter..::.ExportDocument Method
ExportFilter Class See Also Send Feedback

Overload List

Name | Description
ExportDocument(Document, Stream) | Exports given document to the stream.
ExportDocument(Document, String) | Exports given document to the specified file.

See Also

ExportFilter Class
ExportFilter Members
PerpetuumSoft.Reporting.Export Namespace


ExportDocument Method (Document, Stream)

[image]

.NET ModelKit Suite ClassReference
ExportFilter..::.ExportDocument Method (Document, Stream)
ExportFilter Class See Also Send Feedback
Exports given document to the stream.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void ExportDocument(
    Document document,
    Stream stream
)
Visual Basic (Declaration)
Protected Overridable Sub ExportDocument ( _
    document As Document, _
    stream As Stream _
)
Visual C++
protected:
virtual void ExportDocument(
    Document^ document,
    Stream^ stream
)

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
stream
Type: System.IO..::.Stream

See Also

ExportFilter Class
ExportDocument Overload
PerpetuumSoft.Reporting.Export Namespace


ExportDocument Method (Document, String)

[image]

.NET ModelKit Suite ClassReference
ExportFilter..::.ExportDocument Method (Document, String)
ExportFilter Class See Also Send Feedback
Exports given document to the specified file.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected abstract void ExportDocument(
    Document document,
    string fileName
)
Visual Basic (Declaration)
Protected MustOverride Sub ExportDocument ( _
    document As Document, _
    fileName As String _
)
Visual C++
protected:
virtual void ExportDocument(
    Document^ document,
    String^ fileName
) abstract

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
fileName
Type: System..::.String

See Also

ExportFilter Class
ExportDocument Overload
PerpetuumSoft.Reporting.Export Namespace


GetFactory Method

[image]

.NET ModelKit Suite ClassReference
ExportFilter..::.GetFactory Method
ExportFilter Class See Also Send Feedback
Returns FilterFactory for the filter.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract ExportFilterFactory GetFactory()
Visual Basic (Declaration)
Public MustOverride Function GetFactory As ExportFilterFactory
Visual C++
public:
virtual ExportFilterFactory^ GetFactory() abstract

See Also

ExportFilter Class
PerpetuumSoft.Reporting.Export Namespace


GetFilterFileExtension Method

[image]

.NET ModelKit Suite ClassReference
ExportFilter..::.GetFilterFileExtension Method
ExportFilter Class See Also Send Feedback
Returns standard file extension for the filter.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string GetFilterFileExtension()
Visual Basic (Declaration)
Public Function GetFilterFileExtension As String
Visual C++
public:
String^ GetFilterFileExtension()

See Also

ExportFilter Class
PerpetuumSoft.Reporting.Export Namespace


GetFilterFormat Method

[image]

.NET ModelKit Suite ClassReference
ExportFilter..::.GetFilterFormat Method
ExportFilter Class See Also Send Feedback
Returns export format name for the filter.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string GetFilterFormat()
Visual Basic (Declaration)
Public Function GetFilterFormat As String
Visual C++
public:
String^ GetFilterFormat()

See Also

ExportFilter Class
PerpetuumSoft.Reporting.Export Namespace


GetFilterName Method

[image]

.NET ModelKit Suite ClassReference
ExportFilter..::.GetFilterName Method
ExportFilter Class See Also Send Feedback
Returns the filter name.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string GetFilterName()
Visual Basic (Declaration)
Public Function GetFilterName As String
Visual C++
public:
String^ GetFilterName()

See Also

ExportFilter Class
PerpetuumSoft.Reporting.Export Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
ExportFilter..::.MemberwiseClone Method
ExportFilter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ExportFilter Class
ExportFilter Members
PerpetuumSoft.Reporting.Export Namespace


Register Method

[image]

.NET ModelKit Suite ClassReference
ExportFilter..::.Register Method
ExportFilter Class See Also Send Feedback
Registers the standard filters.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static void Register()
Visual Basic (Declaration)
Public Shared Sub Register
Visual C++
public:
static void Register()

See Also

ExportFilter Class
PerpetuumSoft.Reporting.Export Namespace


RegisterExportFilter Method

[image]

.NET ModelKit Suite ClassReference
ExportFilter..::.RegisterExportFilter Method
ExportFilter Class See Also Send Feedback
Registers a new export filter factory.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static void RegisterExportFilter(
    ExportFilterFactory factory
)
Visual Basic (Declaration)
Public Shared Sub RegisterExportFilter ( _
    factory As ExportFilterFactory _
)
Visual C++
public:
static void RegisterExportFilter(
    ExportFilterFactory^ factory
)

Parameters

factory
Type: PerpetuumSoft.Reporting.Export..::.ExportFilterFactory

See Also

ExportFilter Class
PerpetuumSoft.Reporting.Export Namespace


SelectPages Method

[image]

.NET ModelKit Suite ClassReference
ExportFilter..::.SelectPages Method
ExportFilter Class See Also Send Feedback
Returns collection of pages for the page range.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PageCollection SelectPages(
    PageCollection pages
)
Visual Basic (Declaration)
Public Function SelectPages ( _
    pages As PageCollection _
) As PageCollection
Visual C++
public:
PageCollection^ SelectPages(
    PageCollection^ pages
)

Parameters

pages
Type: PerpetuumSoft.Reporting.DOM..::.PageCollection

See Also

ExportFilter Class
PerpetuumSoft.Reporting.Export Namespace


ShowDialog Method

[image]

.NET ModelKit Suite ClassReference
ExportFilter..::.ShowDialog Method
ExportFilter Class See Also Send Feedback
Shows filter settings dialog.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual DialogResult ShowDialog()
Visual Basic (Declaration)
Public Overridable Function ShowDialog As DialogResult
Visual C++
public:
virtual DialogResult ShowDialog()

See Also

ExportFilter Class
PerpetuumSoft.Reporting.Export Namespace


ExportFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
ExportFilter Properties
ExportFilter Class See Also Send Feedback

The ExportFilter type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExportFilters | Represents a collection of registered Export Filter Factories.
PagesRange | Gets or sets pages range for export.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

ExportFilter Class
PerpetuumSoft.Reporting.Export Namespace


ExportFilters Property

[image]

.NET ModelKit Suite ClassReference
ExportFilter..::.ExportFilters Property
ExportFilter Class See Also Send Feedback
Represents a collection of registered Export Filter Factories.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static ArrayList ExportFilters { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ExportFilters As ArrayList
Visual C++
public:
static property ArrayList^ ExportFilters {
    ArrayList^ get ();
}

See Also

ExportFilter Class
PerpetuumSoft.Reporting.Export Namespace


PagesRange Property

[image]

.NET ModelKit Suite ClassReference
ExportFilter..::.PagesRange Property
ExportFilter Class See Also Send Feedback
Gets or sets pages range for export.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string PagesRange { get; set; }
Visual Basic (Declaration)
Public Property PagesRange As String
Visual C++
public:
property String^ PagesRange {
    String^ get ();
    void set (String^ value);
}

See Also

ExportFilter Class
PerpetuumSoft.Reporting.Export Namespace


ExportFilter Events

[image] [image]

.NET ModelKit Suite ClassReference
ExportFilter Events
ExportFilter Class See Also Send Feedback

The ExportFilter type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ExportFilter Class
PerpetuumSoft.Reporting.Export Namespace


ExportFilterFactory Class

[image]

.NET ModelKit Suite ClassReference
ExportFilterFactory Class
Members See Also Send Feedback
Provides a uniform mechanism for creating export filters instances.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract class ExportFilterFactory
Visual Basic (Declaration)
Public MustInherit Class ExportFilterFactory
Visual C++
public ref class ExportFilterFactory abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export..::.ExportFilterFactory
PerpetuumSoft.Reporting.Export.Csv..::.CsvExportFilterFactory
PerpetuumSoft.Reporting.Export.Csv..::.TxtExportFilterFactory
PerpetuumSoft.Reporting.Export.Excel..::.ExcelExportFilterFactory
PerpetuumSoft.Reporting.Export.ExcelXml..::.ExcelXmlExportFilterFactory
PerpetuumSoft.Reporting.Export.Graph..::.BitmapExportFilterFactory
PerpetuumSoft.Reporting.Export.Graph..::.EmfExportFilterFactory
PerpetuumSoft.Reporting.Export.Graph..::.GifExportFilterFactory
PerpetuumSoft.Reporting.Export.Graph..::.JpgExportFilterFactory
PerpetuumSoft.Reporting.Export.Graph..::.PngExportFilterFactory
PerpetuumSoft.Reporting.Export.Graph..::.TiffExportFilterFactory
PerpetuumSoft.Reporting.Export.Html..::.HtmlExportFilterFactory
PerpetuumSoft.Reporting.Export.Pdf..::.PdfExportFilterFactory
PerpetuumSoft.Reporting.Export.Rtf..::.RtfExportFilterFactory
PerpetuumSoft.Reporting.Export.Xps..::.XpsExportFilterFactory

See Also

ExportFilterFactory Members
PerpetuumSoft.Reporting.Export Namespace


ExportFilterFactory Members

[image] [image]

.NET ModelKit Suite ClassReference
ExportFilterFactory Members
ExportFilterFactory Class Constructors Methods See Also Send Feedback

The ExportFilterFactory type exposes the following members.

Constructors

Name | Description
ExportFilterFactory | Initializes a new instance of the ExportFilterFactory class

Methods

Name | Description
CreateFilter | Creates a new instance of the export filter associated with the factory.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns the standard file extension for the export filter associated with the factory.
GetFilterFormat | Returns the format name for the export filter associated with the factory.
GetFilterName | Returns the name of the export filter associated with the factory.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExportFilterFactory Class
PerpetuumSoft.Reporting.Export Namespace


ExportFilterFactory Constructor

[image]

.NET ModelKit Suite ClassReference
ExportFilterFactory Constructor
ExportFilterFactory Class See Also Send Feedback
Initializes a new instance of the ExportFilterFactory class

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected ExportFilterFactory()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ExportFilterFactory()

See Also

ExportFilterFactory Class
PerpetuumSoft.Reporting.Export Namespace


ExportFilterFactory Methods

[image] [image]

.NET ModelKit Suite ClassReference
ExportFilterFactory Methods
ExportFilterFactory Class See Also Send Feedback

The ExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates a new instance of the export filter associated with the factory.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns the standard file extension for the export filter associated with the factory.
GetFilterFormat | Returns the format name for the export filter associated with the factory.
GetFilterName | Returns the name of the export filter associated with the factory.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExportFilterFactory Class
PerpetuumSoft.Reporting.Export Namespace


CreateFilter Method

[image]

.NET ModelKit Suite ClassReference
ExportFilterFactory..::.CreateFilter Method
ExportFilterFactory Class See Also Send Feedback
Creates a new instance of the export filter associated with the factory.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract ExportFilter CreateFilter()
Visual Basic (Declaration)
Public MustOverride Function CreateFilter As ExportFilter
Visual C++
public:
virtual ExportFilter^ CreateFilter() abstract

See Also

ExportFilterFactory Class
PerpetuumSoft.Reporting.Export Namespace


GetFilterFileExtension Method

[image]

.NET ModelKit Suite ClassReference
ExportFilterFactory..::.GetFilterFileExtension Method
ExportFilterFactory Class See Also Send Feedback
Returns the standard file extension for the export filter associated with the factory.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract string GetFilterFileExtension()
Visual Basic (Declaration)
Public MustOverride Function GetFilterFileExtension As String
Visual C++
public:
virtual String^ GetFilterFileExtension() abstract

See Also

ExportFilterFactory Class
PerpetuumSoft.Reporting.Export Namespace


GetFilterFormat Method

[image]

.NET ModelKit Suite ClassReference
ExportFilterFactory..::.GetFilterFormat Method
ExportFilterFactory Class See Also Send Feedback
Returns the format name for the export filter associated with the factory.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract string GetFilterFormat()
Visual Basic (Declaration)
Public MustOverride Function GetFilterFormat As String
Visual C++
public:
virtual String^ GetFilterFormat() abstract

See Also

ExportFilterFactory Class
PerpetuumSoft.Reporting.Export Namespace


GetFilterName Method

[image]

.NET ModelKit Suite ClassReference
ExportFilterFactory..::.GetFilterName Method
ExportFilterFactory Class See Also Send Feedback
Returns the name of the export filter associated with the factory.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public virtual string GetFilterName()
Visual Basic (Declaration)
Public Overridable Function GetFilterName As String
Visual C++
public:
virtual String^ GetFilterName()

See Also

ExportFilterFactory Class
PerpetuumSoft.Reporting.Export Namespace


PageRangeControl Class

[image]

.NET ModelKit Suite ClassReference
PageRangeControl Class
Members See Also Send Feedback
UserControl for editing page range.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class PageRangeControl : UserControl
Visual Basic (Declaration)
Public Class PageRangeControl _
    Inherits UserControl
Visual C++
public ref class PageRangeControl : public UserControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Reporting.Export..::.PageRangeControl

See Also

PageRangeControl Members
PerpetuumSoft.Reporting.Export Namespace


PageRangeControl Members

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl Members
PageRangeControl Class Constructors Methods Properties Events See Also Send Feedback

The PageRangeControl type exposes the following members.

Constructors

Name | Description
PageRangeControl | Creates new instance of the PageRangeControl.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
PageRange | Gets or sets pages range.
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PageRangeControl Class
PerpetuumSoft.Reporting.Export Namespace


PageRangeControl Constructor

[image]

.NET ModelKit Suite ClassReference
PageRangeControl Constructor
PageRangeControl Class See Also Send Feedback
Creates new instance of the PageRangeControl.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PageRangeControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageRangeControl()

See Also

PageRangeControl Class
PerpetuumSoft.Reporting.Export Namespace


PageRangeControl Methods

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl Methods
PageRangeControl Class See Also Send Feedback

The PageRangeControl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

PageRangeControl Class
PerpetuumSoft.Reporting.Export Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl..::.AccessibilityNotifyClients Method
PageRangeControl Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

PageRangeControl Class
PageRangeControl Members
PerpetuumSoft.Reporting.Export Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl..::.BeginInvoke Method
PageRangeControl Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

PageRangeControl Class
PageRangeControl Members
PerpetuumSoft.Reporting.Export Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl..::.Dispose Method
PageRangeControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | The Dispose Finalize pattern ensures that resources are released when the object is no longer needed (Overrides ContainerControl..::.Dispose(Boolean).)

See Also

PageRangeControl Class
PageRangeControl Members
PerpetuumSoft.Reporting.Export Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
PageRangeControl..::.Dispose Method (Boolean)
PageRangeControl Class See Also Send Feedback
The Dispose Finalize pattern ensures that resources are released when the object is no longer needed

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

PageRangeControl Class
Dispose Overload
PerpetuumSoft.Reporting.Export Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl..::.GetChildAtPoint Method
PageRangeControl Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

PageRangeControl Class
PageRangeControl Members
PerpetuumSoft.Reporting.Export Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl..::.Invalidate Method
PageRangeControl Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

PageRangeControl Class
PageRangeControl Members
PerpetuumSoft.Reporting.Export Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl..::.Invoke Method
PageRangeControl Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

PageRangeControl Class
PageRangeControl Members
PerpetuumSoft.Reporting.Export Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl..::.MemberwiseClone Method
PageRangeControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PageRangeControl Class
PageRangeControl Members
PerpetuumSoft.Reporting.Export Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl..::.PerformLayout Method
PageRangeControl Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

PageRangeControl Class
PageRangeControl Members
PerpetuumSoft.Reporting.Export Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl..::.ResumeLayout Method
PageRangeControl Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

PageRangeControl Class
PageRangeControl Members
PerpetuumSoft.Reporting.Export Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl..::.RtlTranslateAlignment Method
PageRangeControl Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

PageRangeControl Class
PageRangeControl Members
PerpetuumSoft.Reporting.Export Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl..::.Scale Method
PageRangeControl Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

PageRangeControl Class
PageRangeControl Members
PerpetuumSoft.Reporting.Export Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl..::.Select Method
PageRangeControl Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

PageRangeControl Class
PageRangeControl Members
PerpetuumSoft.Reporting.Export Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl..::.SetBounds Method
PageRangeControl Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

PageRangeControl Class
PageRangeControl Members
PerpetuumSoft.Reporting.Export Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl..::.UpdateBounds Method
PageRangeControl Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

PageRangeControl Class
PageRangeControl Members
PerpetuumSoft.Reporting.Export Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl..::.Validate Method
PageRangeControl Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

PageRangeControl Class
PageRangeControl Members
PerpetuumSoft.Reporting.Export Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl..::.ValidateChildren Method
PageRangeControl Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

PageRangeControl Class
PageRangeControl Members
PerpetuumSoft.Reporting.Export Namespace


PageRangeControl Properties

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl Properties
PageRangeControl Class See Also Send Feedback

The PageRangeControl type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
PageRange | Gets or sets pages range.
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

PageRangeControl Class
PerpetuumSoft.Reporting.Export Namespace


PageRange Property

[image]

.NET ModelKit Suite ClassReference
PageRangeControl..::.PageRange Property
PageRangeControl Class See Also Send Feedback
Gets or sets pages range.

Namespace: PerpetuumSoft.Reporting.Export
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string PageRange { get; set; }
Visual Basic (Declaration)
Public Property PageRange As String
Visual C++
public:
property String^ PageRange {
    String^ get ();
    void set (String^ value);
}

See Also

PageRangeControl Class
PerpetuumSoft.Reporting.Export Namespace


PageRangeControl Events

[image] [image]

.NET ModelKit Suite ClassReference
PageRangeControl Events
PageRangeControl Class See Also Send Feedback

The PageRangeControl type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PageRangeControl Class
PerpetuumSoft.Reporting.Export Namespace


PerpetuumSoft.Reporting.Export.Csv Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Export.Csv Namespace
Send Feedback
The PerpetuumSoft.Reporting.Export.Cvs namespace contains classes which are used to export document to the CSV (Comma Separated Value(s)) format.

Classes

Class | Description
CsvExportFilter | Csv Format export filter.
CsvExportFilterFactory | Represents factory for Csv Filter instances.
TxtExportFilterFactory | Represents factory for the text format export filters.

Enumerations

Enumeration | Description
ExportMode | Enumerates export modes for csv filter.


CsvExportFilter Class

[image]

.NET ModelKit Suite ClassReference
CsvExportFilter Class
Members See Also Send Feedback
Csv Format export filter.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public class CsvExportFilter : ExportFilter
Visual Basic (Declaration)
Public Class CsvExportFilter _
    Inherits ExportFilter
Visual C++
public ref class CsvExportFilter : public ExportFilter

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Export..::.ExportFilter
PerpetuumSoft.Reporting.Export.Csv..::.CsvExportFilter

See Also

CsvExportFilter Members
PerpetuumSoft.Reporting.Export.Csv Namespace


CsvExportFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
CsvExportFilter Members
CsvExportFilter Class Constructors Methods Properties Events See Also Send Feedback

The CsvExportFilter type exposes the following members.

Constructors

Name | Description
CsvExportFilter | Overloaded.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindAdapter | Finds existing adapter for given control type.
GetFactory | Returns filters factory. (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
RegisterAdapter | Registers a new adapter for the CsvExportFilter.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows dialog with export filter params. (Overrides ExportFilter..::.ShowDialog()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Encoding | Gets or sets filter encoding.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExportMode | Gets or sets export mode.
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Separator | Gets or sets separator char.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

CsvExportFilter Class
PerpetuumSoft.Reporting.Export.Csv Namespace


CsvExportFilter Constructor

[image] [image]

.NET ModelKit Suite ClassReference
CsvExportFilter Constructor
CsvExportFilter Class See Also Send Feedback

Overload List

Name | Description
CsvExportFilter()()() | Initializes a new instance of the TextExportFilter class.
CsvExportFilter(IContainer) | Initializes a new instance of the TextExportFilter class with the specified container.

See Also

CsvExportFilter Class
CsvExportFilter Members
PerpetuumSoft.Reporting.Export.Csv Namespace


CsvExportFilter Constructor

[image]

.NET ModelKit Suite ClassReference
CsvExportFilter Constructor
CsvExportFilter Class See Also Send Feedback
Initializes a new instance of the TextExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public CsvExportFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CsvExportFilter()

See Also

CsvExportFilter Class
CsvExportFilter Overload
PerpetuumSoft.Reporting.Export.Csv Namespace


CsvExportFilter Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
CsvExportFilter Constructor (IContainer)
CsvExportFilter Class See Also Send Feedback
Initializes a new instance of the TextExportFilter class with the specified container.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public CsvExportFilter(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
CsvExportFilter(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

CsvExportFilter Class
CsvExportFilter Overload
PerpetuumSoft.Reporting.Export.Csv Namespace


CsvExportFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
CsvExportFilter Methods
CsvExportFilter Class See Also Send Feedback

The CsvExportFilter type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindAdapter | Finds existing adapter for given control type.
GetFactory | Returns filters factory. (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
RegisterAdapter | Registers a new adapter for the CsvExportFilter.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows dialog with export filter params. (Overrides ExportFilter..::.ShowDialog()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

CsvExportFilter Class
PerpetuumSoft.Reporting.Export.Csv Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
CsvExportFilter..::.Dispose Method
CsvExportFilter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

CsvExportFilter Class
CsvExportFilter Members
PerpetuumSoft.Reporting.Export.Csv Namespace


Export Method

[image] [image]

.NET ModelKit Suite ClassReference
CsvExportFilter..::.Export Method
CsvExportFilter Class See Also Send Feedback

Overload List

Name | Description
Export(Document, Stream) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String, Boolean) | Exports the specified report document to the specified file and optionally shows export filter settings dialog. (Inherited from ExportFilter.)

See Also

CsvExportFilter Class
CsvExportFilter Members
PerpetuumSoft.Reporting.Export.Csv Namespace


ExportDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
CsvExportFilter..::.ExportDocument Method
CsvExportFilter Class See Also Send Feedback

Overload List

Name | Description
ExportDocument(Document, Stream) | Exports given document to the specified stream. (Overrides ExportFilter..::.ExportDocument(Document, Stream).)
ExportDocument(Document, String) | Exports given document to the specified file. (Overrides ExportFilter..::.ExportDocument(Document, String).)

See Also

CsvExportFilter Class
CsvExportFilter Members
PerpetuumSoft.Reporting.Export.Csv Namespace


ExportDocument Method (Document, Stream)

[image]

.NET ModelKit Suite ClassReference
CsvExportFilter..::.ExportDocument Method (Document, Stream)
CsvExportFilter Class See Also Send Feedback
Exports given document to the specified stream.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
protected override void ExportDocument(
    Document document,
    Stream stream
)
Visual Basic (Declaration)
Protected Overrides Sub ExportDocument ( _
    document As Document, _
    stream As Stream _
)
Visual C++
protected:
virtual void ExportDocument(
    Document^ document,
    Stream^ stream
) override

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
stream
Type: System.IO..::.Stream

See Also

CsvExportFilter Class
ExportDocument Overload
PerpetuumSoft.Reporting.Export.Csv Namespace


ExportDocument Method (Document, String)

[image]

.NET ModelKit Suite ClassReference
CsvExportFilter..::.ExportDocument Method (Document, String)
CsvExportFilter Class See Also Send Feedback
Exports given document to the specified file.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
protected override void ExportDocument(
    Document document,
    string fileName
)
Visual Basic (Declaration)
Protected Overrides Sub ExportDocument ( _
    document As Document, _
    fileName As String _
)
Visual C++
protected:
virtual void ExportDocument(
    Document^ document,
    String^ fileName
) override

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
fileName
Type: System..::.String

See Also

CsvExportFilter Class
ExportDocument Overload
PerpetuumSoft.Reporting.Export.Csv Namespace


FindAdapter Method

[image]

.NET ModelKit Suite ClassReference
CsvExportFilter..::.FindAdapter Method
CsvExportFilter Class See Also Send Feedback
Finds existing adapter for given control type.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public CsvAdapter FindAdapter(
    Type type
)
Visual Basic (Declaration)
Public Function FindAdapter ( _
    type As Type _
) As CsvAdapter
Visual C++
public:
CsvAdapter^ FindAdapter(
    Type^ type
)

Parameters

type
Type: System..::.Type

See Also

CsvExportFilter Class
PerpetuumSoft.Reporting.Export.Csv Namespace


GetFactory Method

[image]

.NET ModelKit Suite ClassReference
CsvExportFilter..::.GetFactory Method
CsvExportFilter Class See Also Send Feedback
Returns filters factory.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilterFactory GetFactory()
Visual Basic (Declaration)
Public Overrides Function GetFactory As ExportFilterFactory
Visual C++
public:
virtual ExportFilterFactory^ GetFactory() override

See Also

CsvExportFilter Class
PerpetuumSoft.Reporting.Export.Csv Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
CsvExportFilter..::.MemberwiseClone Method
CsvExportFilter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

CsvExportFilter Class
CsvExportFilter Members
PerpetuumSoft.Reporting.Export.Csv Namespace


RegisterAdapter Method

[image]

.NET ModelKit Suite ClassReference
CsvExportFilter..::.RegisterAdapter Method
CsvExportFilter Class See Also Send Feedback
Registers a new adapter for the CsvExportFilter.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public static void RegisterAdapter(
    Type controlType,
    Type adapterType
)
Visual Basic (Declaration)
Public Shared Sub RegisterAdapter ( _
    controlType As Type, _
    adapterType As Type _
)
Visual C++
public:
static void RegisterAdapter(
    Type^ controlType,
    Type^ adapterType
)

Parameters

controlType
Type: System..::.Type
adapterType
Type: System..::.Type

See Also

CsvExportFilter Class
PerpetuumSoft.Reporting.Export.Csv Namespace


ShowDialog Method

[image]

.NET ModelKit Suite ClassReference
CsvExportFilter..::.ShowDialog Method
CsvExportFilter Class See Also Send Feedback
Shows dialog with export filter params.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public override DialogResult ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As DialogResult
Visual C++
public:
virtual DialogResult ShowDialog() override

See Also

CsvExportFilter Class
PerpetuumSoft.Reporting.Export.Csv Namespace


CsvExportFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
CsvExportFilter Properties
CsvExportFilter Class See Also Send Feedback

The CsvExportFilter type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Encoding | Gets or sets filter encoding.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExportMode | Gets or sets export mode.
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Separator | Gets or sets separator char.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

CsvExportFilter Class
PerpetuumSoft.Reporting.Export.Csv Namespace


Encoding Property

[image]

.NET ModelKit Suite ClassReference
CsvExportFilter..::.Encoding Property
CsvExportFilter Class See Also Send Feedback
Gets or sets filter encoding.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public Encoding Encoding { get; set; }
Visual Basic (Declaration)
Public Property Encoding As Encoding
Visual C++
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}

See Also

CsvExportFilter Class
PerpetuumSoft.Reporting.Export.Csv Namespace


ExportMode Property

[image]

.NET ModelKit Suite ClassReference
CsvExportFilter..::.ExportMode Property
CsvExportFilter Class See Also Send Feedback
Gets or sets export mode.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public ExportMode ExportMode { get; set; }
Visual Basic (Declaration)
Public Property ExportMode As ExportMode
Visual C++
public:
property ExportMode ExportMode {
    ExportMode get ();
    void set (ExportMode value);
}

See Also

CsvExportFilter Class
PerpetuumSoft.Reporting.Export.Csv Namespace


Separator Property

[image]

.NET ModelKit Suite ClassReference
CsvExportFilter..::.Separator Property
CsvExportFilter Class See Also Send Feedback
Gets or sets separator char.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public string Separator { get; set; }
Visual Basic (Declaration)
Public Property Separator As String
Visual C++
public:
property String^ Separator {
    String^ get ();
    void set (String^ value);
}

See Also

CsvExportFilter Class
PerpetuumSoft.Reporting.Export.Csv Namespace


CsvExportFilter Events

[image] [image]

.NET ModelKit Suite ClassReference
CsvExportFilter Events
CsvExportFilter Class See Also Send Feedback

The CsvExportFilter type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

CsvExportFilter Class
PerpetuumSoft.Reporting.Export.Csv Namespace


CsvExportFilterFactory Class

[image]

.NET ModelKit Suite ClassReference
CsvExportFilterFactory Class
Members See Also Send Feedback
Represents factory for Csv Filter instances.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public class CsvExportFilterFactory : ExportFilterFactory
Visual Basic (Declaration)
Public Class CsvExportFilterFactory _
    Inherits ExportFilterFactory
Visual C++
public ref class CsvExportFilterFactory : public ExportFilterFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export..::.ExportFilterFactory
PerpetuumSoft.Reporting.Export.Csv..::.CsvExportFilterFactory

See Also

CsvExportFilterFactory Members
PerpetuumSoft.Reporting.Export.Csv Namespace


CsvExportFilterFactory Members

[image] [image]

.NET ModelKit Suite ClassReference
CsvExportFilterFactory Members
CsvExportFilterFactory Class Constructors Methods Properties See Also Send Feedback

The CsvExportFilterFactory type exposes the following members.

Constructors

Name | Description
CsvExportFilterFactory | Create a new instance of CsvExportFilterFactory class.

Methods

Name | Description
CreateFilter | Creates new instance of the Export filter. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns default file extension. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns filter format name. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Factory | Gets static instance of the CsvExportFilterFactory.

See Also

CsvExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Csv Namespace


CsvExportFilterFactory Constructor

[image]

.NET ModelKit Suite ClassReference
CsvExportFilterFactory Constructor
CsvExportFilterFactory Class See Also Send Feedback
Create a new instance of CsvExportFilterFactory class.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public CsvExportFilterFactory()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CsvExportFilterFactory()

See Also

CsvExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Csv Namespace


CsvExportFilterFactory Methods

[image] [image]

.NET ModelKit Suite ClassReference
CsvExportFilterFactory Methods
CsvExportFilterFactory Class See Also Send Feedback

The CsvExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates new instance of the Export filter. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns default file extension. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns filter format name. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CsvExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Csv Namespace


CreateFilter Method

[image]

.NET ModelKit Suite ClassReference
CsvExportFilterFactory..::.CreateFilter Method
CsvExportFilterFactory Class See Also Send Feedback
Creates new instance of the Export filter.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilter CreateFilter()
Visual Basic (Declaration)
Public Overrides Function CreateFilter As ExportFilter
Visual C++
public:
virtual ExportFilter^ CreateFilter() override

See Also

CsvExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Csv Namespace


GetFilterFileExtension Method

[image]

.NET ModelKit Suite ClassReference
CsvExportFilterFactory..::.GetFilterFileExtension Method
CsvExportFilterFactory Class See Also Send Feedback
Returns default file extension.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFileExtension()
Visual Basic (Declaration)
Public Overrides Function GetFilterFileExtension As String
Visual C++
public:
virtual String^ GetFilterFileExtension() override

See Also

CsvExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Csv Namespace


GetFilterFormat Method

[image]

.NET ModelKit Suite ClassReference
CsvExportFilterFactory..::.GetFilterFormat Method
CsvExportFilterFactory Class See Also Send Feedback
Returns filter format name.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFormat()
Visual Basic (Declaration)
Public Overrides Function GetFilterFormat As String
Visual C++
public:
virtual String^ GetFilterFormat() override

See Also

CsvExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Csv Namespace


CsvExportFilterFactory Properties

[image] [image]

.NET ModelKit Suite ClassReference
CsvExportFilterFactory Properties
CsvExportFilterFactory Class See Also Send Feedback

The CsvExportFilterFactory type exposes the following members.

Properties

Name | Description
Factory | Gets static instance of the CsvExportFilterFactory.

See Also

CsvExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Csv Namespace


Factory Property

[image]

.NET ModelKit Suite ClassReference
CsvExportFilterFactory..::.Factory Property
CsvExportFilterFactory Class See Also Send Feedback
Gets static instance of the CsvExportFilterFactory.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public static CsvExportFilterFactory Factory { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Factory As CsvExportFilterFactory
Visual C++
public:
static property CsvExportFilterFactory^ Factory {
    CsvExportFilterFactory^ get ();
}

See Also

CsvExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Csv Namespace


ExportMode Enumeration

[image]

.NET ModelKit Suite ClassReference
ExportMode Enumeration
See Also Send Feedback
Enumerates export modes for csv filter.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public enum ExportMode
Visual Basic (Declaration)
Public Enumeration ExportMode
Visual C++
public enum class ExportMode

Members

Member name | Description
WholeDocument | Export whole document as single table.
PageByPage | Create table structure for each page.

See Also

PerpetuumSoft.Reporting.Export.Csv Namespace


TxtExportFilterFactory Class

[image]

.NET ModelKit Suite ClassReference
TxtExportFilterFactory Class
Members See Also Send Feedback
Represents factory for the text format export filters.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public class TxtExportFilterFactory : ExportFilterFactory
Visual Basic (Declaration)
Public Class TxtExportFilterFactory _
    Inherits ExportFilterFactory
Visual C++
public ref class TxtExportFilterFactory : public ExportFilterFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export..::.ExportFilterFactory
PerpetuumSoft.Reporting.Export.Csv..::.TxtExportFilterFactory

See Also

TxtExportFilterFactory Members
PerpetuumSoft.Reporting.Export.Csv Namespace


TxtExportFilterFactory Members

[image] [image]

.NET ModelKit Suite ClassReference
TxtExportFilterFactory Members
TxtExportFilterFactory Class Constructors Methods Properties See Also Send Feedback

The TxtExportFilterFactory type exposes the following members.

Constructors

Name | Description
TxtExportFilterFactory | Create a new instance of TxtExportFilterFactory class.

Methods

Name | Description
CreateFilter | Creates new instance of the text export filter. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns default file extension. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns format name. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns filter name. (Overrides ExportFilterFactory..::.GetFilterName()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Factory | Gets static instance of the TxtExportFilterFactory.

See Also

TxtExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Csv Namespace


TxtExportFilterFactory Constructor

[image]

.NET ModelKit Suite ClassReference
TxtExportFilterFactory Constructor
TxtExportFilterFactory Class See Also Send Feedback
Create a new instance of TxtExportFilterFactory class.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public TxtExportFilterFactory()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TxtExportFilterFactory()

See Also

TxtExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Csv Namespace


TxtExportFilterFactory Methods

[image] [image]

.NET ModelKit Suite ClassReference
TxtExportFilterFactory Methods
TxtExportFilterFactory Class See Also Send Feedback

The TxtExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates new instance of the text export filter. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns default file extension. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns format name. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns filter name. (Overrides ExportFilterFactory..::.GetFilterName()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TxtExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Csv Namespace


CreateFilter Method

[image]

.NET ModelKit Suite ClassReference
TxtExportFilterFactory..::.CreateFilter Method
TxtExportFilterFactory Class See Also Send Feedback
Creates new instance of the text export filter.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilter CreateFilter()
Visual Basic (Declaration)
Public Overrides Function CreateFilter As ExportFilter
Visual C++
public:
virtual ExportFilter^ CreateFilter() override

See Also

TxtExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Csv Namespace


GetFilterFileExtension Method

[image]

.NET ModelKit Suite ClassReference
TxtExportFilterFactory..::.GetFilterFileExtension Method
TxtExportFilterFactory Class See Also Send Feedback
Returns default file extension.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFileExtension()
Visual Basic (Declaration)
Public Overrides Function GetFilterFileExtension As String
Visual C++
public:
virtual String^ GetFilterFileExtension() override

See Also

TxtExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Csv Namespace


GetFilterFormat Method

[image]

.NET ModelKit Suite ClassReference
TxtExportFilterFactory..::.GetFilterFormat Method
TxtExportFilterFactory Class See Also Send Feedback
Returns format name.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFormat()
Visual Basic (Declaration)
Public Overrides Function GetFilterFormat As String
Visual C++
public:
virtual String^ GetFilterFormat() override

See Also

TxtExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Csv Namespace


GetFilterName Method

[image]

.NET ModelKit Suite ClassReference
TxtExportFilterFactory..::.GetFilterName Method
TxtExportFilterFactory Class See Also Send Feedback
Returns filter name.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterName()
Visual Basic (Declaration)
Public Overrides Function GetFilterName As String
Visual C++
public:
virtual String^ GetFilterName() override

See Also

TxtExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Csv Namespace


TxtExportFilterFactory Properties

[image] [image]

.NET ModelKit Suite ClassReference
TxtExportFilterFactory Properties
TxtExportFilterFactory Class See Also Send Feedback

The TxtExportFilterFactory type exposes the following members.

Properties

Name | Description
Factory | Gets static instance of the TxtExportFilterFactory.

See Also

TxtExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Csv Namespace


Factory Property

[image]

.NET ModelKit Suite ClassReference
TxtExportFilterFactory..::.Factory Property
TxtExportFilterFactory Class See Also Send Feedback
Gets static instance of the TxtExportFilterFactory.

Namespace: PerpetuumSoft.Reporting.Export.Csv
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public static TxtExportFilterFactory Factory { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Factory As TxtExportFilterFactory
Visual C++
public:
static property TxtExportFilterFactory^ Factory {
    TxtExportFilterFactory^ get ();
}

See Also

TxtExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Csv Namespace


PerpetuumSoft.Reporting.Export.Csv.Adapters Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Export.Csv.Adapters Namespace
Send Feedback
The PerpetuumSoft.Reporting.Export.Cvs.Adapters namespace contains classes which are used to export separate elements of the document to the CSV (Comma Separated Value(s)) format.

Classes

Class | Description
AdvancedTextCsvAdapter | Summary description for AdvancedTextCsvAdapter.
CsvAdapter | Incapsulates conversion methods for different types of report controls.
TextBoxCsvAdapter | Summary description for TextBoxCsvAdapter.


AdvancedTextCsvAdapter Class

[image]

.NET ModelKit Suite ClassReference
AdvancedTextCsvAdapter Class
Members See Also Send Feedback
Summary description for AdvancedTextCsvAdapter.

Namespace: PerpetuumSoft.Reporting.Export.Csv.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public class AdvancedTextCsvAdapter : CsvAdapter
Visual Basic (Declaration)
Public Class AdvancedTextCsvAdapter _
    Inherits CsvAdapter
Visual C++
public ref class AdvancedTextCsvAdapter : public CsvAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Csv.Adapters..::.CsvAdapter
PerpetuumSoft.Reporting.Export.Csv.Adapters..::.AdvancedTextCsvAdapter

See Also

AdvancedTextCsvAdapter Members
PerpetuumSoft.Reporting.Export.Csv.Adapters Namespace


AdvancedTextCsvAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextCsvAdapter Members
AdvancedTextCsvAdapter Class Constructors Methods See Also Send Feedback

The AdvancedTextCsvAdapter type exposes the following members.

Constructors

Name | Description
AdvancedTextCsvAdapter | Create a new instance of AdvancedTextCsvAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAlignment | Returns text alignment for a control. (Inherited from CsvAdapter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetText | Overridden. See GetText(ReportControl). (Overrides CsvAdapter..::.GetText(ReportControl).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdvancedTextCsvAdapter Class
PerpetuumSoft.Reporting.Export.Csv.Adapters Namespace


AdvancedTextCsvAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
AdvancedTextCsvAdapter Constructor
AdvancedTextCsvAdapter Class See Also Send Feedback
Create a new instance of AdvancedTextCsvAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Csv.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public AdvancedTextCsvAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AdvancedTextCsvAdapter()

See Also

AdvancedTextCsvAdapter Class
PerpetuumSoft.Reporting.Export.Csv.Adapters Namespace


AdvancedTextCsvAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextCsvAdapter Methods
AdvancedTextCsvAdapter Class See Also Send Feedback

The AdvancedTextCsvAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAlignment | Returns text alignment for a control. (Inherited from CsvAdapter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetText | Overridden. See GetText(ReportControl). (Overrides CsvAdapter..::.GetText(ReportControl).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdvancedTextCsvAdapter Class
PerpetuumSoft.Reporting.Export.Csv.Adapters Namespace


GetText Method

[image]

.NET ModelKit Suite ClassReference
AdvancedTextCsvAdapter..::.GetText Method
AdvancedTextCsvAdapter Class See Also Send Feedback
Overridden. See GetText(ReportControl).

Namespace: PerpetuumSoft.Reporting.Export.Csv.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public override string GetText(
    ReportControl control
)
Visual Basic (Declaration)
Public Overrides Function GetText ( _
    control As ReportControl _
) As String
Visual C++
public:
virtual String^ GetText(
    ReportControl^ control
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

AdvancedTextCsvAdapter Class
PerpetuumSoft.Reporting.Export.Csv.Adapters Namespace


CsvAdapter Class

[image]

.NET ModelKit Suite ClassReference
CsvAdapter Class
Members See Also Send Feedback
Incapsulates conversion methods for different types of report controls.

Namespace: PerpetuumSoft.Reporting.Export.Csv.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public class CsvAdapter
Visual Basic (Declaration)
Public Class CsvAdapter
Visual C++
public ref class CsvAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Csv.Adapters..::.CsvAdapter
PerpetuumSoft.Reporting.Export.Csv.Adapters..::.AdvancedTextCsvAdapter
PerpetuumSoft.Reporting.Export.Csv.Adapters..::.TextBoxCsvAdapter

See Also

CsvAdapter Members
PerpetuumSoft.Reporting.Export.Csv.Adapters Namespace


CsvAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
CsvAdapter Members
CsvAdapter Class Constructors Methods See Also Send Feedback

The CsvAdapter type exposes the following members.

Constructors

Name | Description
CsvAdapter | Create a new instance of CsvAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAlignment | Returns text alignment for a control.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetText | Returns text containing in a control.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CsvAdapter Class
PerpetuumSoft.Reporting.Export.Csv.Adapters Namespace


CsvAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
CsvAdapter Constructor
CsvAdapter Class See Also Send Feedback
Create a new instance of CsvAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Csv.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public CsvAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CsvAdapter()

See Also

CsvAdapter Class
PerpetuumSoft.Reporting.Export.Csv.Adapters Namespace


CsvAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
CsvAdapter Methods
CsvAdapter Class See Also Send Feedback

The CsvAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAlignment | Returns text alignment for a control.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetText | Returns text containing in a control.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CsvAdapter Class
PerpetuumSoft.Reporting.Export.Csv.Adapters Namespace


GetAlignment Method

[image]

.NET ModelKit Suite ClassReference
CsvAdapter..::.GetAlignment Method
CsvAdapter Class See Also Send Feedback
Returns text alignment for a control.

Namespace: PerpetuumSoft.Reporting.Export.Csv.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public virtual ContentAlignment GetAlignment(
    ReportControl control
)
Visual Basic (Declaration)
Public Overridable Function GetAlignment ( _
    control As ReportControl _
) As ContentAlignment
Visual C++
public:
virtual ContentAlignment GetAlignment(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

CsvAdapter Class
PerpetuumSoft.Reporting.Export.Csv.Adapters Namespace


GetText Method

[image]

.NET ModelKit Suite ClassReference
CsvAdapter..::.GetText Method
CsvAdapter Class See Also Send Feedback
Returns text containing in a control.

Namespace: PerpetuumSoft.Reporting.Export.Csv.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public virtual string GetText(
    ReportControl control
)
Visual Basic (Declaration)
Public Overridable Function GetText ( _
    control As ReportControl _
) As String
Visual C++
public:
virtual String^ GetText(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

CsvAdapter Class
PerpetuumSoft.Reporting.Export.Csv.Adapters Namespace


TextBoxCsvAdapter Class

[image]

.NET ModelKit Suite ClassReference
TextBoxCsvAdapter Class
Members See Also Send Feedback
Summary description for TextBoxCsvAdapter.

Namespace: PerpetuumSoft.Reporting.Export.Csv.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public class TextBoxCsvAdapter : CsvAdapter
Visual Basic (Declaration)
Public Class TextBoxCsvAdapter _
    Inherits CsvAdapter
Visual C++
public ref class TextBoxCsvAdapter : public CsvAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Csv.Adapters..::.CsvAdapter
PerpetuumSoft.Reporting.Export.Csv.Adapters..::.TextBoxCsvAdapter

See Also

TextBoxCsvAdapter Members
PerpetuumSoft.Reporting.Export.Csv.Adapters Namespace


TextBoxCsvAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxCsvAdapter Members
TextBoxCsvAdapter Class Constructors Methods See Also Send Feedback

The TextBoxCsvAdapter type exposes the following members.

Constructors

Name | Description
TextBoxCsvAdapter | Create a new instance of TextBoxCsvAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAlignment | Returns text alignment for a control. (Inherited from CsvAdapter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetText | Overridden. See GetText(ReportControl). (Overrides CsvAdapter..::.GetText(ReportControl).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextBoxCsvAdapter Class
PerpetuumSoft.Reporting.Export.Csv.Adapters Namespace


TextBoxCsvAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
TextBoxCsvAdapter Constructor
TextBoxCsvAdapter Class See Also Send Feedback
Create a new instance of TextBoxCsvAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Csv.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public TextBoxCsvAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextBoxCsvAdapter()

See Also

TextBoxCsvAdapter Class
PerpetuumSoft.Reporting.Export.Csv.Adapters Namespace


TextBoxCsvAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxCsvAdapter Methods
TextBoxCsvAdapter Class See Also Send Feedback

The TextBoxCsvAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAlignment | Returns text alignment for a control. (Inherited from CsvAdapter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetText | Overridden. See GetText(ReportControl). (Overrides CsvAdapter..::.GetText(ReportControl).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextBoxCsvAdapter Class
PerpetuumSoft.Reporting.Export.Csv.Adapters Namespace


GetText Method

[image]

.NET ModelKit Suite ClassReference
TextBoxCsvAdapter..::.GetText Method
TextBoxCsvAdapter Class See Also Send Feedback
Overridden. See GetText(ReportControl).

Namespace: PerpetuumSoft.Reporting.Export.Csv.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Csv (in PerpetuumSoft.Reporting.Export.Csv.dll) Version: 3.9.0.1

Syntax

C#
public override string GetText(
    ReportControl control
)
Visual Basic (Declaration)
Public Overrides Function GetText ( _
    control As ReportControl _
) As String
Visual C++
public:
virtual String^ GetText(
    ReportControl^ control
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

TextBoxCsvAdapter Class
PerpetuumSoft.Reporting.Export.Csv.Adapters Namespace


PerpetuumSoft.Reporting.Export.Excel Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Export.Excel Namespace
Send Feedback
The PerpetuumSoft.Reporting.Export.Excel namespace contains classes which are used to export document to the Microsoft Excel file format.

Classes

Class | Description
ExcelExportFilter | Exports Report Sharp-Shooter document to MS Excel.
ExcelExportFilterFactory | Represents the ExcelFilter factory.

Enumerations

Enumeration | Description
ExportMode | Set behaviour of exporting.


ExcelExportFilter Class

[image]

.NET ModelKit Suite ClassReference
ExcelExportFilter Class
Members See Also Send Feedback
Exports Report Sharp-Shooter document to MS Excel.

Namespace: PerpetuumSoft.Reporting.Export.Excel
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public class ExcelExportFilter : ExportFilter
Visual Basic (Declaration)
Public Class ExcelExportFilter _
    Inherits ExportFilter
Visual C++
public ref class ExcelExportFilter : public ExportFilter

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Export..::.ExportFilter
PerpetuumSoft.Reporting.Export.Excel..::.ExcelExportFilter

See Also

ExcelExportFilter Members
PerpetuumSoft.Reporting.Export.Excel Namespace


ExcelExportFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
ExcelExportFilter Members
ExcelExportFilter Class Constructors Methods Properties Events See Also Send Feedback

The ExcelExportFilter type exposes the following members.

Constructors

Name | Description
ExcelExportFilter | Overloaded.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindAdapter | Returns an existing adapter.
GetFactory | Overrided. See GetFactory()()(). (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
RegisterAdapter | Registers a new adapter for new controls.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Overrided. See ShowDialog()()(). (Overrides ExportFilter..::.ShowDialog()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
Accuracy | Gets or sets the fault of the export.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExportMode | Gets or sets the behaviour of exporting.
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ExcelExportFilter Class
PerpetuumSoft.Reporting.Export.Excel Namespace


ExcelExportFilter Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ExcelExportFilter Constructor
ExcelExportFilter Class See Also Send Feedback

Overload List

Name | Description
ExcelExportFilter()()() | Initializes a new instance of the ExcelExportFilter class.
ExcelExportFilter(IContainer) | Initializes a new instance of the ExcelExportFilter class with the specified container.

See Also

ExcelExportFilter Class
ExcelExportFilter Members
PerpetuumSoft.Reporting.Export.Excel Namespace


ExcelExportFilter Constructor

[image]

.NET ModelKit Suite ClassReference
ExcelExportFilter Constructor
ExcelExportFilter Class See Also Send Feedback
Initializes a new instance of the ExcelExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Excel
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public ExcelExportFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExcelExportFilter()

See Also

ExcelExportFilter Class
ExcelExportFilter Overload
PerpetuumSoft.Reporting.Export.Excel Namespace


ExcelExportFilter Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
ExcelExportFilter Constructor (IContainer)
ExcelExportFilter Class See Also Send Feedback
Initializes a new instance of the ExcelExportFilter class with the specified container.

Namespace: PerpetuumSoft.Reporting.Export.Excel
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public ExcelExportFilter(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
ExcelExportFilter(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

ExcelExportFilter Class
ExcelExportFilter Overload
PerpetuumSoft.Reporting.Export.Excel Namespace


ExcelExportFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ExcelExportFilter Methods
ExcelExportFilter Class See Also Send Feedback

The ExcelExportFilter type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindAdapter | Returns an existing adapter.
GetFactory | Overrided. See GetFactory()()(). (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
RegisterAdapter | Registers a new adapter for new controls.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Overrided. See ShowDialog()()(). (Overrides ExportFilter..::.ShowDialog()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ExcelExportFilter Class
PerpetuumSoft.Reporting.Export.Excel Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ExcelExportFilter..::.Dispose Method
ExcelExportFilter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

ExcelExportFilter Class
ExcelExportFilter Members
PerpetuumSoft.Reporting.Export.Excel Namespace


Export Method

[image] [image]

.NET ModelKit Suite ClassReference
ExcelExportFilter..::.Export Method
ExcelExportFilter Class See Also Send Feedback

Overload List

Name | Description
Export(Document, Stream) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String, Boolean) | Exports the specified report document to the specified file and optionally shows export filter settings dialog. (Inherited from ExportFilter.)

See Also

ExcelExportFilter Class
ExcelExportFilter Members
PerpetuumSoft.Reporting.Export.Excel Namespace


ExportDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
ExcelExportFilter..::.ExportDocument Method
ExcelExportFilter Class See Also Send Feedback

Overload List

Name | Description
ExportDocument(Document, Stream) | Exports the given document to the specified stream. (Overrides ExportFilter..::.ExportDocument(Document, Stream).)
ExportDocument(Document, String) | Exports the given document to the specified file. (Overrides ExportFilter..::.ExportDocument(Document, String).)

See Also

ExcelExportFilter Class
ExcelExportFilter Members
PerpetuumSoft.Reporting.Export.Excel Namespace


ExportDocument Method (Document, Stream)

[image]

.NET ModelKit Suite ClassReference
ExcelExportFilter..::.ExportDocument Method (Document, Stream)
ExcelExportFilter Class See Also Send Feedback
Exports the given document to the specified stream.

Namespace: PerpetuumSoft.Reporting.Export.Excel
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
protected override void ExportDocument(
    Document document,
    Stream stream
)
Visual Basic (Declaration)
Protected Overrides Sub ExportDocument ( _
    document As Document, _
    stream As Stream _
)
Visual C++
protected:
virtual void ExportDocument(
    Document^ document,
    Stream^ stream
) override

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
stream
Type: System.IO..::.Stream

See Also

ExcelExportFilter Class
ExportDocument Overload
PerpetuumSoft.Reporting.Export.Excel Namespace


ExportDocument Method (Document, String)

[image]

.NET ModelKit Suite ClassReference
ExcelExportFilter..::.ExportDocument Method (Document, String)
ExcelExportFilter Class See Also Send Feedback
Exports the given document to the specified file.

Namespace: PerpetuumSoft.Reporting.Export.Excel
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
protected override void ExportDocument(
    Document document,
    string fileName
)
Visual Basic (Declaration)
Protected Overrides Sub ExportDocument ( _
    document As Document, _
    fileName As String _
)
Visual C++
protected:
virtual void ExportDocument(
    Document^ document,
    String^ fileName
) override

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
fileName
Type: System..::.String

See Also

ExcelExportFilter Class
ExportDocument Overload
PerpetuumSoft.Reporting.Export.Excel Namespace


FindAdapter Method

[image]

.NET ModelKit Suite ClassReference
ExcelExportFilter..::.FindAdapter Method
ExcelExportFilter Class See Also Send Feedback
Returns an existing adapter.

Namespace: PerpetuumSoft.Reporting.Export.Excel
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public ExcelAdapter FindAdapter(
    Type type
)
Visual Basic (Declaration)
Public Function FindAdapter ( _
    type As Type _
) As ExcelAdapter
Visual C++
public:
ExcelAdapter^ FindAdapter(
    Type^ type
)

Parameters

type
Type: System..::.Type

See Also

ExcelExportFilter Class
PerpetuumSoft.Reporting.Export.Excel Namespace


GetFactory Method

[image]

.NET ModelKit Suite ClassReference
ExcelExportFilter..::.GetFactory Method
ExcelExportFilter Class See Also Send Feedback
Overrided. See GetFactory()()().

Namespace: PerpetuumSoft.Reporting.Export.Excel
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilterFactory GetFactory()
Visual Basic (Declaration)
Public Overrides Function GetFactory As ExportFilterFactory
Visual C++
public:
virtual ExportFilterFactory^ GetFactory() override

See Also

ExcelExportFilter Class
PerpetuumSoft.Reporting.Export.Excel Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
ExcelExportFilter..::.MemberwiseClone Method
ExcelExportFilter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ExcelExportFilter Class
ExcelExportFilter Members
PerpetuumSoft.Reporting.Export.Excel Namespace


RegisterAdapter Method

[image]

.NET ModelKit Suite ClassReference
ExcelExportFilter..::.RegisterAdapter Method
ExcelExportFilter Class See Also Send Feedback
Registers a new adapter for new controls.

Namespace: PerpetuumSoft.Reporting.Export.Excel
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public static void RegisterAdapter(
    Type controlType,
    Type adapterType
)
Visual Basic (Declaration)
Public Shared Sub RegisterAdapter ( _
    controlType As Type, _
    adapterType As Type _
)
Visual C++
public:
static void RegisterAdapter(
    Type^ controlType,
    Type^ adapterType
)

Parameters

controlType
Type: System..::.Type
adapterType
Type: System..::.Type

See Also

ExcelExportFilter Class
PerpetuumSoft.Reporting.Export.Excel Namespace


ShowDialog Method

[image]

.NET ModelKit Suite ClassReference
ExcelExportFilter..::.ShowDialog Method
ExcelExportFilter Class See Also Send Feedback
Overrided. See ShowDialog()()().

Namespace: PerpetuumSoft.Reporting.Export.Excel
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public override DialogResult ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As DialogResult
Visual C++
public:
virtual DialogResult ShowDialog() override

See Also

ExcelExportFilter Class
PerpetuumSoft.Reporting.Export.Excel Namespace


ExcelExportFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
ExcelExportFilter Properties
ExcelExportFilter Class See Also Send Feedback

The ExcelExportFilter type exposes the following members.

Properties

Name | Description
Accuracy | Gets or sets the fault of the export.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExportMode | Gets or sets the behaviour of exporting.
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

ExcelExportFilter Class
PerpetuumSoft.Reporting.Export.Excel Namespace


Accuracy Property

[image]

.NET ModelKit Suite ClassReference
ExcelExportFilter..::.Accuracy Property
ExcelExportFilter Class See Also Send Feedback
Gets or sets the fault of the export.

Namespace: PerpetuumSoft.Reporting.Export.Excel
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public float Accuracy { get; set; }
Visual Basic (Declaration)
Public Property Accuracy As Single
Visual C++
public:
property float Accuracy {
    float get ();
    void set (float value);
}

See Also

ExcelExportFilter Class
PerpetuumSoft.Reporting.Export.Excel Namespace


ExportMode Property

[image]

.NET ModelKit Suite ClassReference
ExcelExportFilter..::.ExportMode Property
ExcelExportFilter Class See Also Send Feedback
Gets or sets the behaviour of exporting.

Namespace: PerpetuumSoft.Reporting.Export.Excel
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public ExportMode ExportMode { get; set; }
Visual Basic (Declaration)
Public Property ExportMode As ExportMode
Visual C++
public:
property ExportMode ExportMode {
    ExportMode get ();
    void set (ExportMode value);
}

See Also

ExcelExportFilter Class
PerpetuumSoft.Reporting.Export.Excel Namespace


ExcelExportFilter Events

[image] [image]

.NET ModelKit Suite ClassReference
ExcelExportFilter Events
ExcelExportFilter Class See Also Send Feedback

The ExcelExportFilter type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ExcelExportFilter Class
PerpetuumSoft.Reporting.Export.Excel Namespace


ExcelExportFilterFactory Class

[image]

.NET ModelKit Suite ClassReference
ExcelExportFilterFactory Class
Members See Also Send Feedback
Represents the ExcelFilter factory.

Namespace: PerpetuumSoft.Reporting.Export.Excel
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public class ExcelExportFilterFactory : ExportFilterFactory
Visual Basic (Declaration)
Public Class ExcelExportFilterFactory _
    Inherits ExportFilterFactory
Visual C++
public ref class ExcelExportFilterFactory : public ExportFilterFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export..::.ExportFilterFactory
PerpetuumSoft.Reporting.Export.Excel..::.ExcelExportFilterFactory

See Also

ExcelExportFilterFactory Members
PerpetuumSoft.Reporting.Export.Excel Namespace


ExcelExportFilterFactory Members

[image] [image]

.NET ModelKit Suite ClassReference
ExcelExportFilterFactory Members
ExcelExportFilterFactory Class Constructors Methods Properties See Also Send Feedback

The ExcelExportFilterFactory type exposes the following members.

Constructors

Name | Description
ExcelExportFilterFactory | Creates a new instance of ExcelExportFilterFactory class.

Methods

Name | Description
CreateFilter | Overrided. See CreateFilter()()(). (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Overrided. See GetFilterFileExtension()()(). (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Overiided. See GetFilterFormat()()(). (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Factory | Gets the default instance of the ExcelExportFilterFactory class.

See Also

ExcelExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Excel Namespace


ExcelExportFilterFactory Constructor

[image]

.NET ModelKit Suite ClassReference
ExcelExportFilterFactory Constructor
ExcelExportFilterFactory Class See Also Send Feedback
Creates a new instance of ExcelExportFilterFactory class.

Namespace: PerpetuumSoft.Reporting.Export.Excel
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public ExcelExportFilterFactory()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExcelExportFilterFactory()

See Also

ExcelExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Excel Namespace


ExcelExportFilterFactory Methods

[image] [image]

.NET ModelKit Suite ClassReference
ExcelExportFilterFactory Methods
ExcelExportFilterFactory Class See Also Send Feedback

The ExcelExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Overrided. See CreateFilter()()(). (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Overrided. See GetFilterFileExtension()()(). (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Overiided. See GetFilterFormat()()(). (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExcelExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Excel Namespace


CreateFilter Method

[image]

.NET ModelKit Suite ClassReference
ExcelExportFilterFactory..::.CreateFilter Method
ExcelExportFilterFactory Class See Also Send Feedback
Overrided. See CreateFilter()()().

Namespace: PerpetuumSoft.Reporting.Export.Excel
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilter CreateFilter()
Visual Basic (Declaration)
Public Overrides Function CreateFilter As ExportFilter
Visual C++
public:
virtual ExportFilter^ CreateFilter() override

See Also

ExcelExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Excel Namespace


GetFilterFileExtension Method

[image]

.NET ModelKit Suite ClassReference
ExcelExportFilterFactory..::.GetFilterFileExtension Method
ExcelExportFilterFactory Class See Also Send Feedback
Overrided. See GetFilterFileExtension()()().

Namespace: PerpetuumSoft.Reporting.Export.Excel
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFileExtension()
Visual Basic (Declaration)
Public Overrides Function GetFilterFileExtension As String
Visual C++
public:
virtual String^ GetFilterFileExtension() override

See Also

ExcelExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Excel Namespace


GetFilterFormat Method

[image]

.NET ModelKit Suite ClassReference
ExcelExportFilterFactory..::.GetFilterFormat Method
ExcelExportFilterFactory Class See Also Send Feedback
Overiided. See GetFilterFormat()()().

Namespace: PerpetuumSoft.Reporting.Export.Excel
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFormat()
Visual Basic (Declaration)
Public Overrides Function GetFilterFormat As String
Visual C++
public:
virtual String^ GetFilterFormat() override

See Also

ExcelExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Excel Namespace


ExcelExportFilterFactory Properties

[image] [image]

.NET ModelKit Suite ClassReference
ExcelExportFilterFactory Properties
ExcelExportFilterFactory Class See Also Send Feedback

The ExcelExportFilterFactory type exposes the following members.

Properties

Name | Description
Factory | Gets the default instance of the ExcelExportFilterFactory class.

See Also

ExcelExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Excel Namespace


Factory Property

[image]

.NET ModelKit Suite ClassReference
ExcelExportFilterFactory..::.Factory Property
ExcelExportFilterFactory Class See Also Send Feedback
Gets the default instance of the ExcelExportFilterFactory class.

Namespace: PerpetuumSoft.Reporting.Export.Excel
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public static ExcelExportFilterFactory Factory { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Factory As ExcelExportFilterFactory
Visual C++
public:
static property ExcelExportFilterFactory^ Factory {
    ExcelExportFilterFactory^ get ();
}

See Also

ExcelExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Excel Namespace


ExportMode Enumeration

[image]

.NET ModelKit Suite ClassReference
ExportMode Enumeration
See Also Send Feedback
Set behaviour of exporting.

Namespace: PerpetuumSoft.Reporting.Export.Excel
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public enum ExportMode
Visual Basic (Declaration)
Public Enumeration ExportMode
Visual C++
public enum class ExportMode

Members

Member name | Description
PagePerSheet | Each page in report corresponds each page in Excel.
DocumentOnSheet | The whole document on the single page.

See Also

PerpetuumSoft.Reporting.Export.Excel Namespace


PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace
Send Feedback
The PerpetuumSoft.Reporting.Export.Excel.Adapters namespace contains classes which are used to export separate elements of the document to the Microsoft Excel file format.

Classes

Class | Description
AdvancedTextExcelAdapter | Adapter for AdvancedText control.
ExcelAdapter | Incapsulates conversion methods for different types of report controls.
ShapeExcelAdapter | Adapter for Shape control.
TextBoxExcelAdapter | Adapter for TextBox control.
TextControlExcelAdapter | Base class for TextControls.


AdvancedTextExcelAdapter Class

[image]

.NET ModelKit Suite ClassReference
AdvancedTextExcelAdapter Class
Members See Also Send Feedback
Adapter for AdvancedText control.

Namespace: PerpetuumSoft.Reporting.Export.Excel.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public class AdvancedTextExcelAdapter : TextControlExcelAdapter
Visual Basic (Declaration)
Public Class AdvancedTextExcelAdapter _
    Inherits TextControlExcelAdapter
Visual C++
public ref class AdvancedTextExcelAdapter : public TextControlExcelAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Excel.Adapters..::.ExcelAdapter
PerpetuumSoft.Reporting.Export.Excel.Adapters..::.TextControlExcelAdapter
PerpetuumSoft.Reporting.Export.Excel.Adapters..::.AdvancedTextExcelAdapter

See Also

AdvancedTextExcelAdapter Members
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


AdvancedTextExcelAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextExcelAdapter Members
AdvancedTextExcelAdapter Class Constructors Methods See Also Send Feedback

The AdvancedTextExcelAdapter type exposes the following members.

Constructors

Name | Description
AdvancedTextExcelAdapter | Creates a new instance of AdvancedTextExcelAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetText | Returns text contained in an AdvancedText control. (Overrides TextControlExcelAdapter..::.GetText(TextControl).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See [M:PerpetuumSoft.Reporting.Export.Excel.Adapters.ExcelAdapter.Render(ExcelSheet sheet, int row, int col, int height, int width, ReportControl control)]. (Inherited from TextControlExcelAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdvancedTextExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


AdvancedTextExcelAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
AdvancedTextExcelAdapter Constructor
AdvancedTextExcelAdapter Class See Also Send Feedback
Creates a new instance of AdvancedTextExcelAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Excel.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public AdvancedTextExcelAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AdvancedTextExcelAdapter()

See Also

AdvancedTextExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


AdvancedTextExcelAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextExcelAdapter Methods
AdvancedTextExcelAdapter Class See Also Send Feedback

The AdvancedTextExcelAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetText | Returns text contained in an AdvancedText control. (Overrides TextControlExcelAdapter..::.GetText(TextControl).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See [M:PerpetuumSoft.Reporting.Export.Excel.Adapters.ExcelAdapter.Render(ExcelSheet sheet, int row, int col, int height, int width, ReportControl control)]. (Inherited from TextControlExcelAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdvancedTextExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


GetText Method

[image]

.NET ModelKit Suite ClassReference
AdvancedTextExcelAdapter..::.GetText Method
AdvancedTextExcelAdapter Class See Also Send Feedback
Returns text contained in an AdvancedText control.

Namespace: PerpetuumSoft.Reporting.Export.Excel.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
protected override string GetText(
    TextControl control
)
Visual Basic (Declaration)
Protected Overrides Function GetText ( _
    control As TextControl _
) As String
Visual C++
protected:
virtual String^ GetText(
    TextControl^ control
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.TextControl

See Also

AdvancedTextExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


ExcelAdapter Class

[image]

.NET ModelKit Suite ClassReference
ExcelAdapter Class
Members See Also Send Feedback
Incapsulates conversion methods for different types of report controls.

Namespace: PerpetuumSoft.Reporting.Export.Excel.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public abstract class ExcelAdapter
Visual Basic (Declaration)
Public MustInherit Class ExcelAdapter
Visual C++
public ref class ExcelAdapter abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Excel.Adapters..::.ExcelAdapter
PerpetuumSoft.Reporting.Export.Excel.Adapters..::.ShapeExcelAdapter
PerpetuumSoft.Reporting.Export.Excel.Adapters..::.TextControlExcelAdapter

See Also

ExcelAdapter Members
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


ExcelAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
ExcelAdapter Members
ExcelAdapter Class Constructors Methods See Also Send Feedback

The ExcelAdapter type exposes the following members.

Constructors

Name | Description
ExcelAdapter | Creates a new instance of ExcelAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Renders ReportControl into ExcelDocument.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


ExcelAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
ExcelAdapter Constructor
ExcelAdapter Class See Also Send Feedback
Creates a new instance of ExcelAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Excel.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
protected ExcelAdapter()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ExcelAdapter()

See Also

ExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


ExcelAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ExcelAdapter Methods
ExcelAdapter Class See Also Send Feedback

The ExcelAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Renders ReportControl into ExcelDocument.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
ExcelAdapter..::.Render Method
ExcelAdapter Class See Also Send Feedback
Renders ReportControl into ExcelDocument.

Namespace: PerpetuumSoft.Reporting.Export.Excel.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public abstract void Render(
    ExcelSheet sheet,
    int row,
    int col,
    int height,
    int width,
    ReportControl control
)
Visual Basic (Declaration)
Public MustOverride Sub Render ( _
    sheet As ExcelSheet, _
    row As Integer, _
    col As Integer, _
    height As Integer, _
    width As Integer, _
    control As ReportControl _
)
Visual C++
public:
virtual void Render(
    ExcelSheet^ sheet,
    int row,
    int col,
    int height,
    int width,
    ReportControl^ control
) abstract

Parameters

sheet
Type: ExcelSheet
row
Type: System..::.Int32
col
Type: System..::.Int32
height
Type: System..::.Int32
width
Type: System..::.Int32
control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


ShapeExcelAdapter Class

[image]

.NET ModelKit Suite ClassReference
ShapeExcelAdapter Class
Members See Also Send Feedback
Adapter for Shape control.

Namespace: PerpetuumSoft.Reporting.Export.Excel.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public class ShapeExcelAdapter : ExcelAdapter
Visual Basic (Declaration)
Public Class ShapeExcelAdapter _
    Inherits ExcelAdapter
Visual C++
public ref class ShapeExcelAdapter : public ExcelAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Excel.Adapters..::.ExcelAdapter
PerpetuumSoft.Reporting.Export.Excel.Adapters..::.ShapeExcelAdapter

See Also

ShapeExcelAdapter Members
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


ShapeExcelAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
ShapeExcelAdapter Members
ShapeExcelAdapter Class Constructors Methods See Also Send Feedback

The ShapeExcelAdapter type exposes the following members.

Constructors

Name | Description
ShapeExcelAdapter | Creates a new instance of ShapeExcelAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See [M:PerpetuumSoft.Reporting.Export.Excel.Adapters.ExcelAdapter.Render(ExcelSheet sheet, int row, int col, int height, int width, ReportControl control)]. (Overrides ExcelAdapter..::.Render(ExcelSheet, Int32, Int32, Int32, Int32, ReportControl).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShapeExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


ShapeExcelAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
ShapeExcelAdapter Constructor
ShapeExcelAdapter Class See Also Send Feedback
Creates a new instance of ShapeExcelAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Excel.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public ShapeExcelAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ShapeExcelAdapter()

See Also

ShapeExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


ShapeExcelAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ShapeExcelAdapter Methods
ShapeExcelAdapter Class See Also Send Feedback

The ShapeExcelAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See [M:PerpetuumSoft.Reporting.Export.Excel.Adapters.ExcelAdapter.Render(ExcelSheet sheet, int row, int col, int height, int width, ReportControl control)]. (Overrides ExcelAdapter..::.Render(ExcelSheet, Int32, Int32, Int32, Int32, ReportControl).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShapeExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
ShapeExcelAdapter..::.Render Method
ShapeExcelAdapter Class See Also Send Feedback
Overrided. See [M:PerpetuumSoft.Reporting.Export.Excel.Adapters.ExcelAdapter.Render(ExcelSheet sheet, int row, int col, int height, int width, ReportControl control)].

Namespace: PerpetuumSoft.Reporting.Export.Excel.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public override void Render(
    ExcelSheet sheet,
    int row,
    int col,
    int height,
    int width,
    ReportControl control
)
Visual Basic (Declaration)
Public Overrides Sub Render ( _
    sheet As ExcelSheet, _
    row As Integer, _
    col As Integer, _
    height As Integer, _
    width As Integer, _
    control As ReportControl _
)
Visual C++
public:
virtual void Render(
    ExcelSheet^ sheet,
    int row,
    int col,
    int height,
    int width,
    ReportControl^ control
) override

Parameters

sheet
Type: ExcelSheet
row
Type: System..::.Int32
col
Type: System..::.Int32
height
Type: System..::.Int32
width
Type: System..::.Int32
control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ShapeExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


TextBoxExcelAdapter Class

[image]

.NET ModelKit Suite ClassReference
TextBoxExcelAdapter Class
Members See Also Send Feedback
Adapter for TextBox control.

Namespace: PerpetuumSoft.Reporting.Export.Excel.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public class TextBoxExcelAdapter : TextControlExcelAdapter
Visual Basic (Declaration)
Public Class TextBoxExcelAdapter _
    Inherits TextControlExcelAdapter
Visual C++
public ref class TextBoxExcelAdapter : public TextControlExcelAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Excel.Adapters..::.ExcelAdapter
PerpetuumSoft.Reporting.Export.Excel.Adapters..::.TextControlExcelAdapter
PerpetuumSoft.Reporting.Export.Excel.Adapters..::.TextBoxExcelAdapter

See Also

TextBoxExcelAdapter Members
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


TextBoxExcelAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxExcelAdapter Members
TextBoxExcelAdapter Class Constructors Methods See Also Send Feedback

The TextBoxExcelAdapter type exposes the following members.

Constructors

Name | Description
TextBoxExcelAdapter | Creates a new instance of TextBoxExcelAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetText | Returns text contained in the TextBox control. (Overrides TextControlExcelAdapter..::.GetText(TextControl).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See [M:PerpetuumSoft.Reporting.Export.Excel.Adapters.ExcelAdapter.Render(ExcelSheet sheet, int row, int col, int height, int width, ReportControl control)]. (Inherited from TextControlExcelAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextBoxExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


TextBoxExcelAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
TextBoxExcelAdapter Constructor
TextBoxExcelAdapter Class See Also Send Feedback
Creates a new instance of TextBoxExcelAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Excel.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public TextBoxExcelAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextBoxExcelAdapter()

See Also

TextBoxExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


TextBoxExcelAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxExcelAdapter Methods
TextBoxExcelAdapter Class See Also Send Feedback

The TextBoxExcelAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetText | Returns text contained in the TextBox control. (Overrides TextControlExcelAdapter..::.GetText(TextControl).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See [M:PerpetuumSoft.Reporting.Export.Excel.Adapters.ExcelAdapter.Render(ExcelSheet sheet, int row, int col, int height, int width, ReportControl control)]. (Inherited from TextControlExcelAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextBoxExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


GetText Method

[image]

.NET ModelKit Suite ClassReference
TextBoxExcelAdapter..::.GetText Method
TextBoxExcelAdapter Class See Also Send Feedback
Returns text contained in the TextBox control.

Namespace: PerpetuumSoft.Reporting.Export.Excel.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
protected override string GetText(
    TextControl control
)
Visual Basic (Declaration)
Protected Overrides Function GetText ( _
    control As TextControl _
) As String
Visual C++
protected:
virtual String^ GetText(
    TextControl^ control
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.TextControl

See Also

TextBoxExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


TextControlExcelAdapter Class

[image]

.NET ModelKit Suite ClassReference
TextControlExcelAdapter Class
Members See Also Send Feedback
Base class for TextControls.

Namespace: PerpetuumSoft.Reporting.Export.Excel.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public abstract class TextControlExcelAdapter : ExcelAdapter
Visual Basic (Declaration)
Public MustInherit Class TextControlExcelAdapter _
    Inherits ExcelAdapter
Visual C++
public ref class TextControlExcelAdapter abstract : public ExcelAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Excel.Adapters..::.ExcelAdapter
PerpetuumSoft.Reporting.Export.Excel.Adapters..::.TextControlExcelAdapter
PerpetuumSoft.Reporting.Export.Excel.Adapters..::.AdvancedTextExcelAdapter
PerpetuumSoft.Reporting.Export.Excel.Adapters..::.TextBoxExcelAdapter

See Also

TextControlExcelAdapter Members
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


TextControlExcelAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
TextControlExcelAdapter Members
TextControlExcelAdapter Class Constructors Methods See Also Send Feedback

The TextControlExcelAdapter type exposes the following members.

Constructors

Name | Description
TextControlExcelAdapter | Creates a new instance of TextControlExcelAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetText | Returns text if an object is TextControl.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See [M:PerpetuumSoft.Reporting.Export.Excel.Adapters.ExcelAdapter.Render(ExcelSheet sheet, int row, int col, int height, int width, ReportControl control)]. (Overrides ExcelAdapter..::.Render(ExcelSheet, Int32, Int32, Int32, Int32, ReportControl).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextControlExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


TextControlExcelAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
TextControlExcelAdapter Constructor
TextControlExcelAdapter Class See Also Send Feedback
Creates a new instance of TextControlExcelAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Excel.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
protected TextControlExcelAdapter()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
TextControlExcelAdapter()

See Also

TextControlExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


TextControlExcelAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextControlExcelAdapter Methods
TextControlExcelAdapter Class See Also Send Feedback

The TextControlExcelAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetText | Returns text if an object is TextControl.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See [M:PerpetuumSoft.Reporting.Export.Excel.Adapters.ExcelAdapter.Render(ExcelSheet sheet, int row, int col, int height, int width, ReportControl control)]. (Overrides ExcelAdapter..::.Render(ExcelSheet, Int32, Int32, Int32, Int32, ReportControl).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextControlExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


GetText Method

[image]

.NET ModelKit Suite ClassReference
TextControlExcelAdapter..::.GetText Method
TextControlExcelAdapter Class See Also Send Feedback
Returns text if an object is TextControl.

Namespace: PerpetuumSoft.Reporting.Export.Excel.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
protected abstract string GetText(
    TextControl control
)
Visual Basic (Declaration)
Protected MustOverride Function GetText ( _
    control As TextControl _
) As String
Visual C++
protected:
virtual String^ GetText(
    TextControl^ control
) abstract

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.TextControl

See Also

TextControlExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
TextControlExcelAdapter..::.Render Method
TextControlExcelAdapter Class See Also Send Feedback
Overrided. See [M:PerpetuumSoft.Reporting.Export.Excel.Adapters.ExcelAdapter.Render(ExcelSheet sheet, int row, int col, int height, int width, ReportControl control)].

Namespace: PerpetuumSoft.Reporting.Export.Excel.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Excel (in PerpetuumSoft.Reporting.Export.Excel.dll) Version: 3.9.0.1

Syntax

C#
public override void Render(
    ExcelSheet sheet,
    int row,
    int col,
    int height,
    int width,
    ReportControl control
)
Visual Basic (Declaration)
Public Overrides Sub Render ( _
    sheet As ExcelSheet, _
    row As Integer, _
    col As Integer, _
    height As Integer, _
    width As Integer, _
    control As ReportControl _
)
Visual C++
public:
virtual void Render(
    ExcelSheet^ sheet,
    int row,
    int col,
    int height,
    int width,
    ReportControl^ control
) override

Parameters

sheet
Type: ExcelSheet
row
Type: System..::.Int32
col
Type: System..::.Int32
height
Type: System..::.Int32
width
Type: System..::.Int32
control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

TextControlExcelAdapter Class
PerpetuumSoft.Reporting.Export.Excel.Adapters Namespace


PerpetuumSoft.Reporting.Export.ExcelXml Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Export.ExcelXml Namespace
Send Feedback
The PerpetuumSoft.Reporting.ExportExcelXml namespace contains classes which are used to export document to the Microsoft Excel (XML) file format.

Classes

Class | Description
Cell | Represents excel cell.
CellStyle | Represent style of the excel cell.
ExcelXmlExportFilter | Represents excel export filter.
ExcelXmlExportFilterFactory | Represents excel filter factory.
ExcelXmlFile | Represents excel file.


Cell Class

[image]

.NET ModelKit Suite ClassReference
Cell Class
Members See Also Send Feedback
Represents excel cell.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public class Cell
Visual Basic (Declaration)
Public Class Cell
Visual C++
public ref class Cell

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.ExcelXml..::.Cell

See Also

Cell Members
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


Cell Members

[image] [image]

.NET ModelKit Suite ClassReference
Cell Members
Cell Class Constructors Methods Properties See Also Send Feedback

The Cell type exposes the following members.

Constructors

Name | Description
Cell | Creates a new instance of Cell class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CellStyle | Gets and sets cell style.
MergeAcross | Gets and sets number of merged cells.
MergeDown | Gets and sets number of merged cells.
Text | Gets and sets cell text.

See Also

Cell Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


Cell Constructor

[image]

.NET ModelKit Suite ClassReference
Cell Constructor
Cell Class See Also Send Feedback
Creates a new instance of Cell class.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public Cell()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Cell()

See Also

Cell Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


Cell Methods

[image] [image]

.NET ModelKit Suite ClassReference
Cell Methods
Cell Class See Also Send Feedback

The Cell type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Cell Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


Cell Properties

[image] [image]

.NET ModelKit Suite ClassReference
Cell Properties
Cell Class See Also Send Feedback

The Cell type exposes the following members.

Properties

Name | Description
CellStyle | Gets and sets cell style.
MergeAcross | Gets and sets number of merged cells.
MergeDown | Gets and sets number of merged cells.
Text | Gets and sets cell text.

See Also

Cell Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


CellStyle Property

[image]

.NET ModelKit Suite ClassReference
Cell..::.CellStyle Property
Cell Class See Also Send Feedback
Gets and sets cell style.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public CellStyle CellStyle { get; set; }
Visual Basic (Declaration)
Public Property CellStyle As CellStyle
Visual C++
public:
property CellStyle^ CellStyle {
    CellStyle^ get ();
    void set (CellStyle^ value);
}

See Also

Cell Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


MergeAcross Property

[image]

.NET ModelKit Suite ClassReference
Cell..::.MergeAcross Property
Cell Class See Also Send Feedback
Gets and sets number of merged cells.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public int MergeAcross { get; set; }
Visual Basic (Declaration)
Public Property MergeAcross As Integer
Visual C++
public:
property int MergeAcross {
    int get ();
    void set (int value);
}

See Also

Cell Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


MergeDown Property

[image]

.NET ModelKit Suite ClassReference
Cell..::.MergeDown Property
Cell Class See Also Send Feedback
Gets and sets number of merged cells.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public int MergeDown { get; set; }
Visual Basic (Declaration)
Public Property MergeDown As Integer
Visual C++
public:
property int MergeDown {
    int get ();
    void set (int value);
}

See Also

Cell Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


Text Property

[image]

.NET ModelKit Suite ClassReference
Cell..::.Text Property
Cell Class See Also Send Feedback
Gets and sets cell text.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

Cell Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


CellStyle Class

[image]

.NET ModelKit Suite ClassReference
CellStyle Class
Members See Also Send Feedback
Represent style of the excel cell.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public class CellStyle
Visual Basic (Declaration)
Public Class CellStyle
Visual C++
public ref class CellStyle

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.ExcelXml..::.CellStyle

See Also

CellStyle Members
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


CellStyle Members

[image] [image]

.NET ModelKit Suite ClassReference
CellStyle Members
CellStyle Class Constructors Methods Properties See Also Send Feedback

The CellStyle type exposes the following members.

Constructors

Name | Description
CellStyle | Creates new instance of the CellStyle class.

Methods

Name | Description
Equals | Overrides default Equals implementation. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overrides default GetHashCode implementation. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | Gets and sets angle.
Border | Gets and sets border.
FillColor | Gets and sets fill color.
Font | Gets and sets font.
TextAlign | Gets and sets text aligment.
TextColor | Gets and sets text color.

See Also

CellStyle Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


CellStyle Constructor

[image]

.NET ModelKit Suite ClassReference
CellStyle Constructor
CellStyle Class See Also Send Feedback
Creates new instance of the CellStyle class.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public CellStyle(
    FontDescriptor font,
    ContentAlignment textAlign,
    Border border,
    int angle,
    Color fillColor,
    Color textColor
)
Visual Basic (Declaration)
Public Sub New ( _
    font As FontDescriptor, _
    textAlign As ContentAlignment, _
    border As Border, _
    angle As Integer, _
    fillColor As Color, _
    textColor As Color _
)
Visual C++
public:
CellStyle(
    FontDescriptor^ font,
    ContentAlignment textAlign,
    Border^ border,
    int angle,
    Color fillColor,
    Color textColor
)

Parameters

font
Type: PerpetuumSoft.Framework.Drawing..::.FontDescriptor
textAlign
Type: System.Drawing..::.ContentAlignment
border
Type: PerpetuumSoft.Framework.Drawing..::.Border
angle
Type: System..::.Int32
fillColor
Type: System.Drawing..::.Color
textColor
Type: System.Drawing..::.Color

See Also

CellStyle Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


CellStyle Methods

[image] [image]

.NET ModelKit Suite ClassReference
CellStyle Methods
CellStyle Class See Also Send Feedback

The CellStyle type exposes the following members.

Methods

Name | Description
Equals | Overrides default Equals implementation. (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overrides default GetHashCode implementation. (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CellStyle Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
CellStyle..::.Equals Method
CellStyle Class See Also Send Feedback
Overrides default Equals implementation.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::.Object

See Also

CellStyle Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
CellStyle..::.GetHashCode Method
CellStyle Class See Also Send Feedback
Overrides default GetHashCode implementation.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

CellStyle Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


CellStyle Properties

[image] [image]

.NET ModelKit Suite ClassReference
CellStyle Properties
CellStyle Class See Also Send Feedback

The CellStyle type exposes the following members.

Properties

Name | Description
Angle | Gets and sets angle.
Border | Gets and sets border.
FillColor | Gets and sets fill color.
Font | Gets and sets font.
TextAlign | Gets and sets text aligment.
TextColor | Gets and sets text color.

See Also

CellStyle Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


Angle Property

[image]

.NET ModelKit Suite ClassReference
CellStyle..::.Angle Property
CellStyle Class See Also Send Feedback
Gets and sets angle.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public int Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Integer
Visual C++
public:
property int Angle {
    int get ();
    void set (int value);
}

See Also

CellStyle Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


Border Property

[image]

.NET ModelKit Suite ClassReference
CellStyle..::.Border Property
CellStyle Class See Also Send Feedback
Gets and sets border.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public Border Border { get; set; }
Visual Basic (Declaration)
Public Property Border As Border
Visual C++
public:
property Border^ Border {
    Border^ get ();
    void set (Border^ value);
}

See Also

CellStyle Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


FillColor Property

[image]

.NET ModelKit Suite ClassReference
CellStyle..::.FillColor Property
CellStyle Class See Also Send Feedback
Gets and sets fill color.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public Color FillColor { get; set; }
Visual Basic (Declaration)
Public Property FillColor As Color
Visual C++
public:
property Color FillColor {
    Color get ();
    void set (Color value);
}

See Also

CellStyle Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


Font Property

[image]

.NET ModelKit Suite ClassReference
CellStyle..::.Font Property
CellStyle Class See Also Send Feedback
Gets and sets font.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public FontDescriptor Font { get; set; }
Visual Basic (Declaration)
Public Property Font As FontDescriptor
Visual C++
public:
property FontDescriptor^ Font {
    FontDescriptor^ get ();
    void set (FontDescriptor^ value);
}

See Also

CellStyle Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


TextAlign Property

[image]

.NET ModelKit Suite ClassReference
CellStyle..::.TextAlign Property
CellStyle Class See Also Send Feedback
Gets and sets text aligment.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public ContentAlignment TextAlign { get; set; }
Visual Basic (Declaration)
Public Property TextAlign As ContentAlignment
Visual C++
public:
property ContentAlignment TextAlign {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

CellStyle Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


TextColor Property

[image]

.NET ModelKit Suite ClassReference
CellStyle..::.TextColor Property
CellStyle Class See Also Send Feedback
Gets and sets text color.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public Color TextColor { get; set; }
Visual Basic (Declaration)
Public Property TextColor As Color
Visual C++
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}

See Also

CellStyle Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExcelXmlExportFilter Class

[image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilter Class
Members See Also Send Feedback
Represents excel export filter.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public class ExcelXmlExportFilter : ExportFilter
Visual Basic (Declaration)
Public Class ExcelXmlExportFilter _
    Inherits ExportFilter
Visual C++
public ref class ExcelXmlExportFilter : public ExportFilter

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Export..::.ExportFilter
PerpetuumSoft.Reporting.Export.ExcelXml..::.ExcelXmlExportFilter

See Also

ExcelXmlExportFilter Members
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExcelXmlExportFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilter Members
ExcelXmlExportFilter Class Constructors Methods Properties Events See Also Send Feedback

The ExcelXmlExportFilter type exposes the following members.

Constructors

Name | Description
ExcelXmlExportFilter | Overloaded.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindAdapter | Returns adapters type associated with the given control type.
GetFactory | Returns Excel filter factory. (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
RegisterAdapter | Registers new adapter type.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows filter settings dialog. (Inherited from ExportFilter.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ExcelXmlExportFilter Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExcelXmlExportFilter Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilter Constructor
ExcelXmlExportFilter Class See Also Send Feedback

Overload List

Name | Description
ExcelXmlExportFilter()()() | Initializes a new instance of the PDFExportFilter class.
ExcelXmlExportFilter(IContainer) | Initializes a new instance of the PDFExportFilter class with the specified container.

See Also

ExcelXmlExportFilter Class
ExcelXmlExportFilter Members
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExcelXmlExportFilter Constructor

[image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilter Constructor
ExcelXmlExportFilter Class See Also Send Feedback
Initializes a new instance of the PDFExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public ExcelXmlExportFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExcelXmlExportFilter()

See Also

ExcelXmlExportFilter Class
ExcelXmlExportFilter Overload
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExcelXmlExportFilter Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilter Constructor (IContainer)
ExcelXmlExportFilter Class See Also Send Feedback
Initializes a new instance of the PDFExportFilter class with the specified container.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public ExcelXmlExportFilter(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
ExcelXmlExportFilter(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

ExcelXmlExportFilter Class
ExcelXmlExportFilter Overload
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExcelXmlExportFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilter Methods
ExcelXmlExportFilter Class See Also Send Feedback

The ExcelXmlExportFilter type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindAdapter | Returns adapters type associated with the given control type.
GetFactory | Returns Excel filter factory. (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
RegisterAdapter | Registers new adapter type.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows filter settings dialog. (Inherited from ExportFilter.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ExcelXmlExportFilter Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilter..::.Dispose Method
ExcelXmlExportFilter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

ExcelXmlExportFilter Class
ExcelXmlExportFilter Members
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


Export Method

[image] [image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilter..::.Export Method
ExcelXmlExportFilter Class See Also Send Feedback

Overload List

Name | Description
Export(Document, Stream) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String, Boolean) | Exports the specified report document to the specified file and optionally shows export filter settings dialog. (Inherited from ExportFilter.)

See Also

ExcelXmlExportFilter Class
ExcelXmlExportFilter Members
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExportDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilter..::.ExportDocument Method
ExcelXmlExportFilter Class See Also Send Feedback

Overload List

Name | Description
ExportDocument(Document, Stream) | Exports given document to the specified stream. (Overrides ExportFilter..::.ExportDocument(Document, Stream).)
ExportDocument(Document, String) | Exports given document to specified file. (Overrides ExportFilter..::.ExportDocument(Document, String).)

See Also

ExcelXmlExportFilter Class
ExcelXmlExportFilter Members
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExportDocument Method (Document, Stream)

[image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilter..::.ExportDocument Method (Document, Stream)
ExcelXmlExportFilter Class See Also Send Feedback
Exports given document to the specified stream.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
protected override void ExportDocument(
    Document document,
    Stream stream
)
Visual Basic (Declaration)
Protected Overrides Sub ExportDocument ( _
    document As Document, _
    stream As Stream _
)
Visual C++
protected:
virtual void ExportDocument(
    Document^ document,
    Stream^ stream
) override

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
stream
Type: System.IO..::.Stream

See Also

ExcelXmlExportFilter Class
ExportDocument Overload
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExportDocument Method (Document, String)

[image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilter..::.ExportDocument Method (Document, String)
ExcelXmlExportFilter Class See Also Send Feedback
Exports given document to specified file.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
protected override void ExportDocument(
    Document document,
    string fileName
)
Visual Basic (Declaration)
Protected Overrides Sub ExportDocument ( _
    document As Document, _
    fileName As String _
)
Visual C++
protected:
virtual void ExportDocument(
    Document^ document,
    String^ fileName
) override

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
fileName
Type: System..::.String

See Also

ExcelXmlExportFilter Class
ExportDocument Overload
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


FindAdapter Method

[image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilter..::.FindAdapter Method
ExcelXmlExportFilter Class See Also Send Feedback
Returns adapters type associated with the given control type.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public ExcelXmlAdapter FindAdapter(
    Type type
)
Visual Basic (Declaration)
Public Function FindAdapter ( _
    type As Type _
) As ExcelXmlAdapter
Visual C++
public:
ExcelXmlAdapter^ FindAdapter(
    Type^ type
)

Parameters

type
Type: System..::.Type

See Also

ExcelXmlExportFilter Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


GetFactory Method

[image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilter..::.GetFactory Method
ExcelXmlExportFilter Class See Also Send Feedback
Returns Excel filter factory.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilterFactory GetFactory()
Visual Basic (Declaration)
Public Overrides Function GetFactory As ExportFilterFactory
Visual C++
public:
virtual ExportFilterFactory^ GetFactory() override

See Also

ExcelXmlExportFilter Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilter..::.MemberwiseClone Method
ExcelXmlExportFilter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ExcelXmlExportFilter Class
ExcelXmlExportFilter Members
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


RegisterAdapter Method

[image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilter..::.RegisterAdapter Method
ExcelXmlExportFilter Class See Also Send Feedback
Registers new adapter type.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public static void RegisterAdapter(
    Type controlType,
    Type adapterType
)
Visual Basic (Declaration)
Public Shared Sub RegisterAdapter ( _
    controlType As Type, _
    adapterType As Type _
)
Visual C++
public:
static void RegisterAdapter(
    Type^ controlType,
    Type^ adapterType
)

Parameters

controlType
Type: System..::.Type
adapterType
Type: System..::.Type

See Also

ExcelXmlExportFilter Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExcelXmlExportFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilter Properties
ExcelXmlExportFilter Class See Also Send Feedback

The ExcelXmlExportFilter type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

ExcelXmlExportFilter Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExcelXmlExportFilter Events

[image] [image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilter Events
ExcelXmlExportFilter Class See Also Send Feedback

The ExcelXmlExportFilter type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ExcelXmlExportFilter Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExcelXmlExportFilterFactory Class

[image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilterFactory Class
Members See Also Send Feedback
Represents excel filter factory.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public class ExcelXmlExportFilterFactory : ExportFilterFactory
Visual Basic (Declaration)
Public Class ExcelXmlExportFilterFactory _
    Inherits ExportFilterFactory
Visual C++
public ref class ExcelXmlExportFilterFactory : public ExportFilterFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export..::.ExportFilterFactory
PerpetuumSoft.Reporting.Export.ExcelXml..::.ExcelXmlExportFilterFactory

See Also

ExcelXmlExportFilterFactory Members
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExcelXmlExportFilterFactory Members

[image] [image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilterFactory Members
ExcelXmlExportFilterFactory Class Methods Properties See Also Send Feedback

The ExcelXmlExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates excel export filter instance. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns default file extension. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns filter format name. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Factory | Gets the default instance of the ExcelXmlExportFilterFactory class.

See Also

ExcelXmlExportFilterFactory Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExcelXmlExportFilterFactory Methods

[image] [image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilterFactory Methods
ExcelXmlExportFilterFactory Class See Also Send Feedback

The ExcelXmlExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates excel export filter instance. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns default file extension. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns filter format name. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExcelXmlExportFilterFactory Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


CreateFilter Method

[image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilterFactory..::.CreateFilter Method
ExcelXmlExportFilterFactory Class See Also Send Feedback
Creates excel export filter instance.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilter CreateFilter()
Visual Basic (Declaration)
Public Overrides Function CreateFilter As ExportFilter
Visual C++
public:
virtual ExportFilter^ CreateFilter() override

See Also

ExcelXmlExportFilterFactory Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


GetFilterFileExtension Method

[image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilterFactory..::.GetFilterFileExtension Method
ExcelXmlExportFilterFactory Class See Also Send Feedback
Returns default file extension.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFileExtension()
Visual Basic (Declaration)
Public Overrides Function GetFilterFileExtension As String
Visual C++
public:
virtual String^ GetFilterFileExtension() override

See Also

ExcelXmlExportFilterFactory Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


GetFilterFormat Method

[image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilterFactory..::.GetFilterFormat Method
ExcelXmlExportFilterFactory Class See Also Send Feedback
Returns filter format name.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFormat()
Visual Basic (Declaration)
Public Overrides Function GetFilterFormat As String
Visual C++
public:
virtual String^ GetFilterFormat() override

See Also

ExcelXmlExportFilterFactory Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExcelXmlExportFilterFactory Properties

[image] [image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilterFactory Properties
ExcelXmlExportFilterFactory Class See Also Send Feedback

The ExcelXmlExportFilterFactory type exposes the following members.

Properties

Name | Description
Factory | Gets the default instance of the ExcelXmlExportFilterFactory class.

See Also

ExcelXmlExportFilterFactory Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


Factory Property

[image]

.NET ModelKit Suite ClassReference
ExcelXmlExportFilterFactory..::.Factory Property
ExcelXmlExportFilterFactory Class See Also Send Feedback
Gets the default instance of the ExcelXmlExportFilterFactory class.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public static ExcelXmlExportFilterFactory Factory { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Factory As ExcelXmlExportFilterFactory
Visual C++
public:
static property ExcelXmlExportFilterFactory^ Factory {
    ExcelXmlExportFilterFactory^ get ();
}

See Also

ExcelXmlExportFilterFactory Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExcelXmlFile Class

[image]

.NET ModelKit Suite ClassReference
ExcelXmlFile Class
Members See Also Send Feedback
Represents excel file.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public class ExcelXmlFile
Visual Basic (Declaration)
Public Class ExcelXmlFile
Visual C++
public ref class ExcelXmlFile

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.ExcelXml..::.ExcelXmlFile

See Also

ExcelXmlFile Members
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExcelXmlFile Members

[image] [image]

.NET ModelKit Suite ClassReference
ExcelXmlFile Members
ExcelXmlFile Class Constructors Methods Properties See Also Send Feedback

The ExcelXmlFile type exposes the following members.

Constructors

Name | Description
ExcelXmlFile | Creates new instance of the ExcelXmlFile.

Methods

Name | Description
AddRect | Adds rectangle to the global matrix.
CreateCellStyle | Returns a new or existing instance of the CellStyle class with the given parameters.
EndMatrix | Closes global matrix.
EndPage | Ends current page.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Returns cells range corresponded to the given rectangle.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Item | Gets cell with the specified indexes.

See Also

ExcelXmlFile Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExcelXmlFile Constructor

[image]

.NET ModelKit Suite ClassReference
ExcelXmlFile Constructor
ExcelXmlFile Class See Also Send Feedback
Creates new instance of the ExcelXmlFile.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public ExcelXmlFile(
    string title
)
Visual Basic (Declaration)
Public Sub New ( _
    title As String _
)
Visual C++
public:
ExcelXmlFile(
    String^ title
)

Parameters

title
Type: System..::.String

See Also

ExcelXmlFile Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExcelXmlFile Methods

[image] [image]

.NET ModelKit Suite ClassReference
ExcelXmlFile Methods
ExcelXmlFile Class See Also Send Feedback

The ExcelXmlFile type exposes the following members.

Methods

Name | Description
AddRect | Adds rectangle to the global matrix.
CreateCellStyle | Returns a new or existing instance of the CellStyle class with the given parameters.
EndMatrix | Closes global matrix.
EndPage | Ends current page.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Returns cells range corresponded to the given rectangle.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExcelXmlFile Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


AddRect Method

[image]

.NET ModelKit Suite ClassReference
ExcelXmlFile..::.AddRect Method
ExcelXmlFile Class See Also Send Feedback
Adds rectangle to the global matrix.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public void AddRect(
    RectangleF rect
)
Visual Basic (Declaration)
Public Sub AddRect ( _
    rect As RectangleF _
)
Visual C++
public:
void AddRect(
    RectangleF rect
)

Parameters

rect
Type: System.Drawing..::.RectangleF

See Also

ExcelXmlFile Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


CreateCellStyle Method

[image]

.NET ModelKit Suite ClassReference
ExcelXmlFile..::.CreateCellStyle Method
ExcelXmlFile Class See Also Send Feedback
Returns a new or existing instance of the CellStyle class with the given parameters.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public CellStyle CreateCellStyle(
    FontDescriptor font,
    ContentAlignment textAlign,
    Border border,
    int angle,
    Color fillColor,
    Color textColor
)
Visual Basic (Declaration)
Public Function CreateCellStyle ( _
    font As FontDescriptor, _
    textAlign As ContentAlignment, _
    border As Border, _
    angle As Integer, _
    fillColor As Color, _
    textColor As Color _
) As CellStyle
Visual C++
public:
CellStyle^ CreateCellStyle(
    FontDescriptor^ font,
    ContentAlignment textAlign,
    Border^ border,
    int angle,
    Color fillColor,
    Color textColor
)

Parameters

font
Type: PerpetuumSoft.Framework.Drawing..::.FontDescriptor
textAlign
Type: System.Drawing..::.ContentAlignment
border
Type: PerpetuumSoft.Framework.Drawing..::.Border
angle
Type: System..::.Int32
fillColor
Type: System.Drawing..::.Color
textColor
Type: System.Drawing..::.Color

See Also

ExcelXmlFile Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


EndMatrix Method

[image]

.NET ModelKit Suite ClassReference
ExcelXmlFile..::.EndMatrix Method
ExcelXmlFile Class See Also Send Feedback
Closes global matrix.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public void EndMatrix()
Visual Basic (Declaration)
Public Sub EndMatrix
Visual C++
public:
void EndMatrix()

See Also

ExcelXmlFile Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


EndPage Method

[image]

.NET ModelKit Suite ClassReference
ExcelXmlFile..::.EndPage Method
ExcelXmlFile Class See Also Send Feedback
Ends current page.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public void EndPage(
    double pageHeight
)
Visual Basic (Declaration)
Public Sub EndPage ( _
    pageHeight As Double _
)
Visual C++
public:
void EndPage(
    double pageHeight
)

Parameters

pageHeight
Type: System..::.Double

See Also

ExcelXmlFile Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


GetRange Method

[image]

.NET ModelKit Suite ClassReference
ExcelXmlFile..::.GetRange Method
ExcelXmlFile Class See Also Send Feedback
Returns cells range corresponded to the given rectangle.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public Rectangle GetRange(
    RectangleF rect
)
Visual Basic (Declaration)
Public Function GetRange ( _
    rect As RectangleF _
) As Rectangle
Visual C++
public:
Rectangle GetRange(
    RectangleF rect
)

Parameters

rect
Type: System.Drawing..::.RectangleF

See Also

ExcelXmlFile Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


Save Method

[image] [image]

.NET ModelKit Suite ClassReference
ExcelXmlFile..::.Save Method
ExcelXmlFile Class See Also Send Feedback

Overload List

Name | Description
Save(Stream) | Saves excel file to stream.
Save(String) | Saves excel file to specified file.

See Also

ExcelXmlFile Class
ExcelXmlFile Members
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


Save Method (Stream)

[image]

.NET ModelKit Suite ClassReference
ExcelXmlFile..::.Save Method (Stream)
ExcelXmlFile Class See Also Send Feedback
Saves excel file to stream.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public void Save(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Save ( _
    stream As Stream _
)
Visual C++
public:
void Save(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

ExcelXmlFile Class
Save Overload
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


Save Method (String)

[image]

.NET ModelKit Suite ClassReference
ExcelXmlFile..::.Save Method (String)
ExcelXmlFile Class See Also Send Feedback
Saves excel file to specified file.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public void Save(
    string fileName
)
Visual Basic (Declaration)
Public Sub Save ( _
    fileName As String _
)
Visual C++
public:
void Save(
    String^ fileName
)

Parameters

fileName
Type: System..::.String

See Also

ExcelXmlFile Class
Save Overload
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


ExcelXmlFile Properties

[image] [image]

.NET ModelKit Suite ClassReference
ExcelXmlFile Properties
ExcelXmlFile Class See Also Send Feedback

The ExcelXmlFile type exposes the following members.

Properties

Name | Description
Item | Gets cell with the specified indexes.

See Also

ExcelXmlFile Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
ExcelXmlFile..::.Item Property
ExcelXmlFile Class See Also Send Feedback
Gets cell with the specified indexes.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public Cell this[
    int y,
    int x
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    y As Integer, _
    x As Integer _
) As Cell
Visual C++
public:
property Cell^ default[int y, int x] {
    Cell^ get (int y, int x);
    void set (int y, int x, Cell^ value);
}

Parameters

y
Type: System..::.Int32
x
Type: System..::.Int32

See Also

ExcelXmlFile Class
PerpetuumSoft.Reporting.Export.ExcelXml Namespace


PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace
Send Feedback
The PerpetuumSoft.Reporting.Export.ExcelXml.Adapters namespace contains classes which are used to export document elements to the Microsoft Excel (XML) file format.

Classes

Class | Description
AdvancedTextExcelXmlAdapter | Represents adapter for the AdvancedText control.
ExcelXmlAdapter | Represents adapter class.
ReportControlExcelXmlAdapter | Represents adapter for ReportControl class.
TextBoxExcelXmlAdapter | Represents adapter for the TextBox class.
TextControlExcelXmlAdapter | Represents adapter for text control.


AdvancedTextExcelXmlAdapter Class

[image]

.NET ModelKit Suite ClassReference
AdvancedTextExcelXmlAdapter Class
Members See Also Send Feedback
Represents adapter for the AdvancedText control.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml.Adapters
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public class AdvancedTextExcelXmlAdapter : TextControlExcelXmlAdapter
Visual Basic (Declaration)
Public Class AdvancedTextExcelXmlAdapter _
    Inherits TextControlExcelXmlAdapter
Visual C++
public ref class AdvancedTextExcelXmlAdapter : public TextControlExcelXmlAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters..::.ExcelXmlAdapter
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters..::.TextControlExcelXmlAdapter
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters..::.AdvancedTextExcelXmlAdapter

See Also

AdvancedTextExcelXmlAdapter Members
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


AdvancedTextExcelXmlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextExcelXmlAdapter Members
AdvancedTextExcelXmlAdapter Class Constructors Methods See Also Send Feedback

The AdvancedTextExcelXmlAdapter type exposes the following members.

Constructors

Name | Description
AdvancedTextExcelXmlAdapter | Creates a new instance of the AdvancedTextExcelXmlAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetText | Overrided. See GetText(TextControl). (Overrides TextControlExcelXmlAdapter..::.GetText(TextControl).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(ExcelXmlFile, ReportControl). (Inherited from TextControlExcelXmlAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdvancedTextExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


AdvancedTextExcelXmlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
AdvancedTextExcelXmlAdapter Constructor
AdvancedTextExcelXmlAdapter Class See Also Send Feedback
Creates a new instance of the AdvancedTextExcelXmlAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml.Adapters
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public AdvancedTextExcelXmlAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AdvancedTextExcelXmlAdapter()

See Also

AdvancedTextExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


AdvancedTextExcelXmlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextExcelXmlAdapter Methods
AdvancedTextExcelXmlAdapter Class See Also Send Feedback

The AdvancedTextExcelXmlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetText | Overrided. See GetText(TextControl). (Overrides TextControlExcelXmlAdapter..::.GetText(TextControl).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(ExcelXmlFile, ReportControl). (Inherited from TextControlExcelXmlAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdvancedTextExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


GetText Method

[image]

.NET ModelKit Suite ClassReference
AdvancedTextExcelXmlAdapter..::.GetText Method
AdvancedTextExcelXmlAdapter Class See Also Send Feedback
Overrided. See GetText(TextControl).

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml.Adapters
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
protected override string GetText(
    TextControl control
)
Visual Basic (Declaration)
Protected Overrides Function GetText ( _
    control As TextControl _
) As String
Visual C++
protected:
virtual String^ GetText(
    TextControl^ control
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.TextControl

See Also

AdvancedTextExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


ExcelXmlAdapter Class

[image]

.NET ModelKit Suite ClassReference
ExcelXmlAdapter Class
Members See Also Send Feedback
Represents adapter class.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml.Adapters
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public abstract class ExcelXmlAdapter
Visual Basic (Declaration)
Public MustInherit Class ExcelXmlAdapter
Visual C++
public ref class ExcelXmlAdapter abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters..::.ExcelXmlAdapter
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters..::.ReportControlExcelXmlAdapter
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters..::.TextControlExcelXmlAdapter

See Also

ExcelXmlAdapter Members
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


ExcelXmlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
ExcelXmlAdapter Members
ExcelXmlAdapter Class Constructors Methods See Also Send Feedback

The ExcelXmlAdapter type exposes the following members.

Constructors

Name | Description
ExcelXmlAdapter | Creates new instance of ExcelXmlAdapter.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Converts ReportControl to excel cells.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


ExcelXmlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
ExcelXmlAdapter Constructor
ExcelXmlAdapter Class See Also Send Feedback
Creates new instance of ExcelXmlAdapter.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml.Adapters
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
protected ExcelXmlAdapter()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ExcelXmlAdapter()

See Also

ExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


ExcelXmlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ExcelXmlAdapter Methods
ExcelXmlAdapter Class See Also Send Feedback

The ExcelXmlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Converts ReportControl to excel cells.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
ExcelXmlAdapter..::.Render Method
ExcelXmlAdapter Class See Also Send Feedback
Converts ReportControl to excel cells.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml.Adapters
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public abstract void Render(
    ExcelXmlFile file,
    ReportControl control
)
Visual Basic (Declaration)
Public MustOverride Sub Render ( _
    file As ExcelXmlFile, _
    control As ReportControl _
)
Visual C++
public:
virtual void Render(
    ExcelXmlFile^ file,
    ReportControl^ control
) abstract

Parameters

file
Type: PerpetuumSoft.Reporting.Export.ExcelXml..::.ExcelXmlFile
control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


ReportControlExcelXmlAdapter Class

[image]

.NET ModelKit Suite ClassReference
ReportControlExcelXmlAdapter Class
Members See Also Send Feedback
Represents adapter for ReportControl class.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml.Adapters
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public class ReportControlExcelXmlAdapter : ExcelXmlAdapter
Visual Basic (Declaration)
Public Class ReportControlExcelXmlAdapter _
    Inherits ExcelXmlAdapter
Visual C++
public ref class ReportControlExcelXmlAdapter : public ExcelXmlAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters..::.ExcelXmlAdapter
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters..::.ReportControlExcelXmlAdapter

See Also

ReportControlExcelXmlAdapter Members
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


ReportControlExcelXmlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlExcelXmlAdapter Members
ReportControlExcelXmlAdapter Class Constructors Methods See Also Send Feedback

The ReportControlExcelXmlAdapter type exposes the following members.

Constructors

Name | Description
ReportControlExcelXmlAdapter | Creates new instance of ReportControlExcelXmlAdapter.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(ExcelXmlFile, ReportControl). (Overrides ExcelXmlAdapter..::.Render(ExcelXmlFile, ReportControl).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportControlExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


ReportControlExcelXmlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
ReportControlExcelXmlAdapter Constructor
ReportControlExcelXmlAdapter Class See Also Send Feedback
Creates new instance of ReportControlExcelXmlAdapter.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml.Adapters
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public ReportControlExcelXmlAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportControlExcelXmlAdapter()

See Also

ReportControlExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


ReportControlExcelXmlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlExcelXmlAdapter Methods
ReportControlExcelXmlAdapter Class See Also Send Feedback

The ReportControlExcelXmlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(ExcelXmlFile, ReportControl). (Overrides ExcelXmlAdapter..::.Render(ExcelXmlFile, ReportControl).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportControlExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
ReportControlExcelXmlAdapter..::.Render Method
ReportControlExcelXmlAdapter Class See Also Send Feedback
Overridden. See Render(ExcelXmlFile, ReportControl).

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml.Adapters
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public override void Render(
    ExcelXmlFile file,
    ReportControl control
)
Visual Basic (Declaration)
Public Overrides Sub Render ( _
    file As ExcelXmlFile, _
    control As ReportControl _
)
Visual C++
public:
virtual void Render(
    ExcelXmlFile^ file,
    ReportControl^ control
) override

Parameters

file
Type: PerpetuumSoft.Reporting.Export.ExcelXml..::.ExcelXmlFile
control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ReportControlExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


TextBoxExcelXmlAdapter Class

[image]

.NET ModelKit Suite ClassReference
TextBoxExcelXmlAdapter Class
Members See Also Send Feedback
Represents adapter for the TextBox class.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml.Adapters
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public class TextBoxExcelXmlAdapter : TextControlExcelXmlAdapter
Visual Basic (Declaration)
Public Class TextBoxExcelXmlAdapter _
    Inherits TextControlExcelXmlAdapter
Visual C++
public ref class TextBoxExcelXmlAdapter : public TextControlExcelXmlAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters..::.ExcelXmlAdapter
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters..::.TextControlExcelXmlAdapter
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters..::.TextBoxExcelXmlAdapter

See Also

TextBoxExcelXmlAdapter Members
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


TextBoxExcelXmlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxExcelXmlAdapter Members
TextBoxExcelXmlAdapter Class Constructors Methods See Also Send Feedback

The TextBoxExcelXmlAdapter type exposes the following members.

Constructors

Name | Description
TextBoxExcelXmlAdapter | Creates new instance of the TextBoxExcelXmlAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetText | Overrided. See GetText(TextControl). (Overrides TextControlExcelXmlAdapter..::.GetText(TextControl).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(ExcelXmlFile, ReportControl). (Inherited from TextControlExcelXmlAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextBoxExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


TextBoxExcelXmlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
TextBoxExcelXmlAdapter Constructor
TextBoxExcelXmlAdapter Class See Also Send Feedback
Creates new instance of the TextBoxExcelXmlAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml.Adapters
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public TextBoxExcelXmlAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextBoxExcelXmlAdapter()

See Also

TextBoxExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


TextBoxExcelXmlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxExcelXmlAdapter Methods
TextBoxExcelXmlAdapter Class See Also Send Feedback

The TextBoxExcelXmlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetText | Overrided. See GetText(TextControl). (Overrides TextControlExcelXmlAdapter..::.GetText(TextControl).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(ExcelXmlFile, ReportControl). (Inherited from TextControlExcelXmlAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextBoxExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


GetText Method

[image]

.NET ModelKit Suite ClassReference
TextBoxExcelXmlAdapter..::.GetText Method
TextBoxExcelXmlAdapter Class See Also Send Feedback
Overrided. See GetText(TextControl).

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml.Adapters
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
protected override string GetText(
    TextControl textControl
)
Visual Basic (Declaration)
Protected Overrides Function GetText ( _
    textControl As TextControl _
) As String
Visual C++
protected:
virtual String^ GetText(
    TextControl^ textControl
) override

Parameters

textControl
Type: PerpetuumSoft.Reporting.DOM..::.TextControl

See Also

TextBoxExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


TextControlExcelXmlAdapter Class

[image]

.NET ModelKit Suite ClassReference
TextControlExcelXmlAdapter Class
Members See Also Send Feedback
Represents adapter for text control.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml.Adapters
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public abstract class TextControlExcelXmlAdapter : ExcelXmlAdapter
Visual Basic (Declaration)
Public MustInherit Class TextControlExcelXmlAdapter _
    Inherits ExcelXmlAdapter
Visual C++
public ref class TextControlExcelXmlAdapter abstract : public ExcelXmlAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters..::.ExcelXmlAdapter
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters..::.TextControlExcelXmlAdapter
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters..::.AdvancedTextExcelXmlAdapter
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters..::.TextBoxExcelXmlAdapter

See Also

TextControlExcelXmlAdapter Members
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


TextControlExcelXmlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
TextControlExcelXmlAdapter Members
TextControlExcelXmlAdapter Class Constructors Methods See Also Send Feedback

The TextControlExcelXmlAdapter type exposes the following members.

Constructors

Name | Description
TextControlExcelXmlAdapter | Creates a new instance of TextControlExcelXmlAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetText | Returns text contained in the given control.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(ExcelXmlFile, ReportControl). (Overrides ExcelXmlAdapter..::.Render(ExcelXmlFile, ReportControl).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextControlExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


TextControlExcelXmlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
TextControlExcelXmlAdapter Constructor
TextControlExcelXmlAdapter Class See Also Send Feedback
Creates a new instance of TextControlExcelXmlAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml.Adapters
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
protected TextControlExcelXmlAdapter()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
TextControlExcelXmlAdapter()

See Also

TextControlExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


TextControlExcelXmlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextControlExcelXmlAdapter Methods
TextControlExcelXmlAdapter Class See Also Send Feedback

The TextControlExcelXmlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetText | Returns text contained in the given control.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(ExcelXmlFile, ReportControl). (Overrides ExcelXmlAdapter..::.Render(ExcelXmlFile, ReportControl).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextControlExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


GetText Method

[image]

.NET ModelKit Suite ClassReference
TextControlExcelXmlAdapter..::.GetText Method
TextControlExcelXmlAdapter Class See Also Send Feedback
Returns text contained in the given control.

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml.Adapters
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
protected abstract string GetText(
    TextControl textControl
)
Visual Basic (Declaration)
Protected MustOverride Function GetText ( _
    textControl As TextControl _
) As String
Visual C++
protected:
virtual String^ GetText(
    TextControl^ textControl
) abstract

Parameters

textControl
Type: PerpetuumSoft.Reporting.DOM..::.TextControl

See Also

TextControlExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
TextControlExcelXmlAdapter..::.Render Method
TextControlExcelXmlAdapter Class See Also Send Feedback
Overridden. See Render(ExcelXmlFile, ReportControl).

Namespace: PerpetuumSoft.Reporting.Export.ExcelXml.Adapters
Assembly: PerpetuumSoft.Reporting.Export.ExcelXml (in PerpetuumSoft.Reporting.Export.ExcelXml.dll) Version: 3.9.0.1

Syntax

C#
public override void Render(
    ExcelXmlFile file,
    ReportControl control
)
Visual Basic (Declaration)
Public Overrides Sub Render ( _
    file As ExcelXmlFile, _
    control As ReportControl _
)
Visual C++
public:
virtual void Render(
    ExcelXmlFile^ file,
    ReportControl^ control
) override

Parameters

file
Type: PerpetuumSoft.Reporting.Export.ExcelXml..::.ExcelXmlFile
control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

TextControlExcelXmlAdapter Class
PerpetuumSoft.Reporting.Export.ExcelXml.Adapters Namespace


PerpetuumSoft.Reporting.Export.Graph Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Export.Graph Namespace
Send Feedback
The PerpetuumSoft.Reporting.Export.Graph namespace contains classes which are used to export document to the graphic file formats.

Classes

Class | Description
BitmapExportFilter | Allows to export the final documents into Windows Bitmap format.
BitmapExportFilterFactory | Provides creation of BitmapExportFilter instances.
BitmapImageExportFilter | Base class for all bitmap-based report export filters.
EmfExportFilter | Allows to export the final documents into Enhanced Metafile format.
EmfExportFilterFactory | Provides creation of EmfExportFilter instances.
GifExportFilter | Allows to export the final documents into GIF format.
GifExportFilterFactory | Provides creation of GifExportFilter instances.
ImageExportFilter | The base class for all image export filters.
JpegOptionsDialog | A dialog window for assigning parameters of export to JPEG
JpgExportFilter | Allows to export the final documents into JPEG format.
JpgExportFilterFactory | Provides creation of JpgExportFilter instances.
PictureOptionsDialog | Image export dialod form
PngExportFilter | Allows to export the final documents into Png format.
PngExportFilterFactory | Provides creation of PngExportFilter instances.
TiffExportFilter | Allows to export the final documents into Tiff format.
TiffExportFilterFactory | Provides creation of TiffExportFilter instances.
VectorImageExportFilter | Base class for all raster-image-based report export filters.


BitmapExportFilter Class

[image]

.NET ModelKit Suite ClassReference
BitmapExportFilter Class
Members See Also Send Feedback
Allows to export the final documents into Windows Bitmap format.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class BitmapExportFilter : BitmapImageExportFilter
Visual Basic (Declaration)
Public Class BitmapExportFilter _
    Inherits BitmapImageExportFilter
Visual C++
public ref class BitmapExportFilter : public BitmapImageExportFilter

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Export..::.ExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.ImageExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.BitmapImageExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.BitmapExportFilter

See Also

BitmapExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


BitmapExportFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
BitmapExportFilter Members
BitmapExportFilter Class Constructors Methods Properties Events See Also Send Feedback

The BitmapExportFilter type exposes the following members.

Constructors

Name | Description
BitmapExportFilter | Overloaded.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
ExportPage | Exports the specified page to the specified file. (Inherited from BitmapImageExportFilter.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns the factory associated with the current Windows Bitmap export filter. (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Returns the ImageFormat for the Windows Bitmap filter. (Overrides BitmapImageExportFilter..::.GetImageFormat()()().)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows filter settings dialog. (Inherited from BitmapImageExportFilter.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ImageResolution | Gets or sets resolution. (Inherited from BitmapImageExportFilter.)
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

BitmapExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


BitmapExportFilter Constructor

[image] [image]

.NET ModelKit Suite ClassReference
BitmapExportFilter Constructor
BitmapExportFilter Class See Also Send Feedback

Overload List

Name | Description
BitmapExportFilter()()() | Initializes a new instance of the BitmapExportFilter class.
BitmapExportFilter(IContainer) | Initializes a new instance of the BitmapExportFilter class with the specified container.

See Also

BitmapExportFilter Class
BitmapExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


BitmapExportFilter Constructor

[image]

.NET ModelKit Suite ClassReference
BitmapExportFilter Constructor
BitmapExportFilter Class See Also Send Feedback
Initializes a new instance of the BitmapExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public BitmapExportFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BitmapExportFilter()

See Also

BitmapExportFilter Class
BitmapExportFilter Overload
PerpetuumSoft.Reporting.Export.Graph Namespace


BitmapExportFilter Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
BitmapExportFilter Constructor (IContainer)
BitmapExportFilter Class See Also Send Feedback
Initializes a new instance of the BitmapExportFilter class with the specified container.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public BitmapExportFilter(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
BitmapExportFilter(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

BitmapExportFilter Class
BitmapExportFilter Overload
PerpetuumSoft.Reporting.Export.Graph Namespace


BitmapExportFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
BitmapExportFilter Methods
BitmapExportFilter Class See Also Send Feedback

The BitmapExportFilter type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
ExportPage | Exports the specified page to the specified file. (Inherited from BitmapImageExportFilter.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns the factory associated with the current Windows Bitmap export filter. (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Returns the ImageFormat for the Windows Bitmap filter. (Overrides BitmapImageExportFilter..::.GetImageFormat()()().)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows filter settings dialog. (Inherited from BitmapImageExportFilter.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

BitmapExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
BitmapExportFilter..::.Dispose Method
BitmapExportFilter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

BitmapExportFilter Class
BitmapExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Export Method

[image] [image]

.NET ModelKit Suite ClassReference
BitmapExportFilter..::.Export Method
BitmapExportFilter Class See Also Send Feedback

Overload List

Name | Description
Export(Document, Stream) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String, Boolean) | Exports the specified report document to the specified file and optionally shows export filter settings dialog. (Inherited from ExportFilter.)

See Also

BitmapExportFilter Class
BitmapExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ExportDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
BitmapExportFilter..::.ExportDocument Method
BitmapExportFilter Class See Also Send Feedback

Overload List

Name | Description
ExportDocument(Document, Stream) | Exports given document to the stream. (Inherited from ExportFilter.)
ExportDocument(Document, String) | Exports document to the specified file. (Inherited from ImageExportFilter.)

See Also

BitmapExportFilter Class
BitmapExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


GetFactory Method

[image]

.NET ModelKit Suite ClassReference
BitmapExportFilter..::.GetFactory Method
BitmapExportFilter Class See Also Send Feedback
Returns the factory associated with the current Windows Bitmap export filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilterFactory GetFactory()
Visual Basic (Declaration)
Public Overrides Function GetFactory As ExportFilterFactory
Visual C++
public:
virtual ExportFilterFactory^ GetFactory() override

See Also

BitmapExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GetImageFormat Method

[image]

.NET ModelKit Suite ClassReference
BitmapExportFilter..::.GetImageFormat Method
BitmapExportFilter Class See Also Send Feedback
Returns the ImageFormat for the Windows Bitmap filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override ImageFormat GetImageFormat()
Visual Basic (Declaration)
Protected Overrides Function GetImageFormat As ImageFormat
Visual C++
protected:
virtual ImageFormat^ GetImageFormat() override

See Also

BitmapExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
BitmapExportFilter..::.MemberwiseClone Method
BitmapExportFilter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

BitmapExportFilter Class
BitmapExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


BitmapExportFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
BitmapExportFilter Properties
BitmapExportFilter Class See Also Send Feedback

The BitmapExportFilter type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ImageResolution | Gets or sets resolution. (Inherited from BitmapImageExportFilter.)
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

BitmapExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


BitmapExportFilter Events

[image] [image]

.NET ModelKit Suite ClassReference
BitmapExportFilter Events
BitmapExportFilter Class See Also Send Feedback

The BitmapExportFilter type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

BitmapExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


BitmapExportFilterFactory Class

[image]

.NET ModelKit Suite ClassReference
BitmapExportFilterFactory Class
Members See Also Send Feedback
Provides creation of BitmapExportFilter instances.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class BitmapExportFilterFactory : ExportFilterFactory
Visual Basic (Declaration)
Public Class BitmapExportFilterFactory _
    Inherits ExportFilterFactory
Visual C++
public ref class BitmapExportFilterFactory : public ExportFilterFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export..::.ExportFilterFactory
PerpetuumSoft.Reporting.Export.Graph..::.BitmapExportFilterFactory

See Also

BitmapExportFilterFactory Members
PerpetuumSoft.Reporting.Export.Graph Namespace


BitmapExportFilterFactory Members

[image] [image]

.NET ModelKit Suite ClassReference
BitmapExportFilterFactory Members
BitmapExportFilterFactory Class Methods Properties See Also Send Feedback

The BitmapExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates a new instance of the BitmapExportFilter class. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns the standard file extension for the associated BMP export filter. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns the format name for the associated BMP export filter. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Factory | Gets the default instance of the BitmapExportFilterFactory class.

See Also

BitmapExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


BitmapExportFilterFactory Methods

[image] [image]

.NET ModelKit Suite ClassReference
BitmapExportFilterFactory Methods
BitmapExportFilterFactory Class See Also Send Feedback

The BitmapExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates a new instance of the BitmapExportFilter class. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns the standard file extension for the associated BMP export filter. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns the format name for the associated BMP export filter. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BitmapExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


CreateFilter Method

[image]

.NET ModelKit Suite ClassReference
BitmapExportFilterFactory..::.CreateFilter Method
BitmapExportFilterFactory Class See Also Send Feedback
Creates a new instance of the BitmapExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilter CreateFilter()
Visual Basic (Declaration)
Public Overrides Function CreateFilter As ExportFilter
Visual C++
public:
virtual ExportFilter^ CreateFilter() override

See Also

BitmapExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GetFilterFileExtension Method

[image]

.NET ModelKit Suite ClassReference
BitmapExportFilterFactory..::.GetFilterFileExtension Method
BitmapExportFilterFactory Class See Also Send Feedback
Returns the standard file extension for the associated BMP export filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFileExtension()
Visual Basic (Declaration)
Public Overrides Function GetFilterFileExtension As String
Visual C++
public:
virtual String^ GetFilterFileExtension() override

See Also

BitmapExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GetFilterFormat Method

[image]

.NET ModelKit Suite ClassReference
BitmapExportFilterFactory..::.GetFilterFormat Method
BitmapExportFilterFactory Class See Also Send Feedback
Returns the format name for the associated BMP export filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFormat()
Visual Basic (Declaration)
Public Overrides Function GetFilterFormat As String
Visual C++
public:
virtual String^ GetFilterFormat() override

See Also

BitmapExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


BitmapExportFilterFactory Properties

[image] [image]

.NET ModelKit Suite ClassReference
BitmapExportFilterFactory Properties
BitmapExportFilterFactory Class See Also Send Feedback

The BitmapExportFilterFactory type exposes the following members.

Properties

Name | Description
Factory | Gets the default instance of the BitmapExportFilterFactory class.

See Also

BitmapExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


Factory Property

[image]

.NET ModelKit Suite ClassReference
BitmapExportFilterFactory..::.Factory Property
BitmapExportFilterFactory Class See Also Send Feedback
Gets the default instance of the BitmapExportFilterFactory class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static BitmapExportFilterFactory Factory { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Factory As BitmapExportFilterFactory
Visual C++
public:
static property BitmapExportFilterFactory^ Factory {
    BitmapExportFilterFactory^ get ();
}

See Also

BitmapExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


BitmapImageExportFilter Class

[image]

.NET ModelKit Suite ClassReference
BitmapImageExportFilter Class
Members See Also Send Feedback
Base class for all bitmap-based report export filters.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract class BitmapImageExportFilter : ImageExportFilter
Visual Basic (Declaration)
Public MustInherit Class BitmapImageExportFilter _
    Inherits ImageExportFilter
Visual C++
public ref class BitmapImageExportFilter abstract : public ImageExportFilter

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Export..::.ExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.ImageExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.BitmapImageExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.BitmapExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.GifExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.JpgExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.PngExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.TiffExportFilter

See Also

BitmapImageExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


BitmapImageExportFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
BitmapImageExportFilter Members
BitmapImageExportFilter Class Constructors Methods Properties Events See Also Send Feedback

The BitmapImageExportFilter type exposes the following members.

Constructors

Name | Description
BitmapImageExportFilter | Initializes a new instance of the BitmapImageExportFilter class.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
ExportPage | Exports the specified page to the specified file. (Overrides ImageExportFilter..::.ExportPage(Page, String).)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns FilterFactory for the filter. (Inherited from ExportFilter.)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Returns the ImageFormat for the current filter.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows filter settings dialog. (Overrides ExportFilter..::.ShowDialog()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ImageResolution | Gets or sets resolution.
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

BitmapImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


BitmapImageExportFilter Constructor

[image]

.NET ModelKit Suite ClassReference
BitmapImageExportFilter Constructor
BitmapImageExportFilter Class See Also Send Feedback
Initializes a new instance of the BitmapImageExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public BitmapImageExportFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BitmapImageExportFilter()

See Also

BitmapImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


BitmapImageExportFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
BitmapImageExportFilter Methods
BitmapImageExportFilter Class See Also Send Feedback

The BitmapImageExportFilter type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
ExportPage | Exports the specified page to the specified file. (Overrides ImageExportFilter..::.ExportPage(Page, String).)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns FilterFactory for the filter. (Inherited from ExportFilter.)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Returns the ImageFormat for the current filter.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows filter settings dialog. (Overrides ExportFilter..::.ShowDialog()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

BitmapImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
BitmapImageExportFilter..::.Dispose Method
BitmapImageExportFilter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

BitmapImageExportFilter Class
BitmapImageExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Export Method

[image] [image]

.NET ModelKit Suite ClassReference
BitmapImageExportFilter..::.Export Method
BitmapImageExportFilter Class See Also Send Feedback

Overload List

Name | Description
Export(Document, Stream) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String, Boolean) | Exports the specified report document to the specified file and optionally shows export filter settings dialog. (Inherited from ExportFilter.)

See Also

BitmapImageExportFilter Class
BitmapImageExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ExportDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
BitmapImageExportFilter..::.ExportDocument Method
BitmapImageExportFilter Class See Also Send Feedback

Overload List

Name | Description
ExportDocument(Document, Stream) | Exports given document to the stream. (Inherited from ExportFilter.)
ExportDocument(Document, String) | Exports document to the specified file. (Inherited from ImageExportFilter.)

See Also

BitmapImageExportFilter Class
BitmapImageExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ExportPage Method

[image]

.NET ModelKit Suite ClassReference
BitmapImageExportFilter..::.ExportPage Method
BitmapImageExportFilter Class See Also Send Feedback
Exports the specified page to the specified file.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void ExportPage(
    Page page,
    string fileName
)
Visual Basic (Declaration)
Protected Overrides Sub ExportPage ( _
    page As Page, _
    fileName As String _
)
Visual C++
protected:
virtual void ExportPage(
    Page^ page,
    String^ fileName
) override

Parameters

page
Type: PerpetuumSoft.Reporting.DOM..::.Page
fileName
Type: System..::.String

See Also

BitmapImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GetImageFormat Method

[image]

.NET ModelKit Suite ClassReference
BitmapImageExportFilter..::.GetImageFormat Method
BitmapImageExportFilter Class See Also Send Feedback
Returns the ImageFormat for the current filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected abstract ImageFormat GetImageFormat()
Visual Basic (Declaration)
Protected MustOverride Function GetImageFormat As ImageFormat
Visual C++
protected:
virtual ImageFormat^ GetImageFormat() abstract

See Also

BitmapImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
BitmapImageExportFilter..::.MemberwiseClone Method
BitmapImageExportFilter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

BitmapImageExportFilter Class
BitmapImageExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ShowDialog Method

[image]

.NET ModelKit Suite ClassReference
BitmapImageExportFilter..::.ShowDialog Method
BitmapImageExportFilter Class See Also Send Feedback
Shows filter settings dialog.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override DialogResult ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As DialogResult
Visual C++
public:
virtual DialogResult ShowDialog() override

See Also

BitmapImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


BitmapImageExportFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
BitmapImageExportFilter Properties
BitmapImageExportFilter Class See Also Send Feedback

The BitmapImageExportFilter type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ImageResolution | Gets or sets resolution.
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

BitmapImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


ImageResolution Property

[image]

.NET ModelKit Suite ClassReference
BitmapImageExportFilter..::.ImageResolution Property
BitmapImageExportFilter Class See Also Send Feedback
Gets or sets resolution.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int ImageResolution { get; set; }
Visual Basic (Declaration)
Public Property ImageResolution As Integer
Visual C++
public:
property int ImageResolution {
    int get ();
    void set (int value);
}

See Also

BitmapImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


BitmapImageExportFilter Events

[image] [image]

.NET ModelKit Suite ClassReference
BitmapImageExportFilter Events
BitmapImageExportFilter Class See Also Send Feedback

The BitmapImageExportFilter type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

BitmapImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


EmfExportFilter Class

[image]

.NET ModelKit Suite ClassReference
EmfExportFilter Class
Members See Also Send Feedback
Allows to export the final documents into Enhanced Metafile format.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class EmfExportFilter : VectorImageExportFilter
Visual Basic (Declaration)
Public Class EmfExportFilter _
    Inherits VectorImageExportFilter
Visual C++
public ref class EmfExportFilter : public VectorImageExportFilter

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Export..::.ExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.ImageExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.VectorImageExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.EmfExportFilter

See Also

EmfExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


EmfExportFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
EmfExportFilter Members
EmfExportFilter Class Constructors Methods Properties Events See Also Send Feedback

The EmfExportFilter type exposes the following members.

Constructors

Name | Description
EmfExportFilter | Overloaded.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
ExportPage | Exports the specified page to the specified file. (Inherited from VectorImageExportFilter.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns the factory associated with the current export filter. (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows export dialog. (Inherited from VectorImageExportFilter.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

EmfExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


EmfExportFilter Constructor

[image] [image]

.NET ModelKit Suite ClassReference
EmfExportFilter Constructor
EmfExportFilter Class See Also Send Feedback

Overload List

Name | Description
EmfExportFilter()()() | Initializes a new instance of the EmfExportFilter class.
EmfExportFilter(IContainer) | Initializes a new instance of the EmfExportFilter class with the specified container.

See Also

EmfExportFilter Class
EmfExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


EmfExportFilter Constructor

[image]

.NET ModelKit Suite ClassReference
EmfExportFilter Constructor
EmfExportFilter Class See Also Send Feedback
Initializes a new instance of the EmfExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public EmfExportFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EmfExportFilter()

See Also

EmfExportFilter Class
EmfExportFilter Overload
PerpetuumSoft.Reporting.Export.Graph Namespace


EmfExportFilter Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
EmfExportFilter Constructor (IContainer)
EmfExportFilter Class See Also Send Feedback
Initializes a new instance of the EmfExportFilter class with the specified container.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public EmfExportFilter(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
EmfExportFilter(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

EmfExportFilter Class
EmfExportFilter Overload
PerpetuumSoft.Reporting.Export.Graph Namespace


EmfExportFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
EmfExportFilter Methods
EmfExportFilter Class See Also Send Feedback

The EmfExportFilter type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
ExportPage | Exports the specified page to the specified file. (Inherited from VectorImageExportFilter.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns the factory associated with the current export filter. (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows export dialog. (Inherited from VectorImageExportFilter.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

EmfExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
EmfExportFilter..::.Dispose Method
EmfExportFilter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

EmfExportFilter Class
EmfExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Export Method

[image] [image]

.NET ModelKit Suite ClassReference
EmfExportFilter..::.Export Method
EmfExportFilter Class See Also Send Feedback

Overload List

Name | Description
Export(Document, Stream) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String, Boolean) | Exports the specified report document to the specified file and optionally shows export filter settings dialog. (Inherited from ExportFilter.)

See Also

EmfExportFilter Class
EmfExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ExportDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
EmfExportFilter..::.ExportDocument Method
EmfExportFilter Class See Also Send Feedback

Overload List

Name | Description
ExportDocument(Document, Stream) | Exports given document to the stream. (Inherited from ExportFilter.)
ExportDocument(Document, String) | Exports document to the specified file. (Inherited from ImageExportFilter.)

See Also

EmfExportFilter Class
EmfExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


GetFactory Method

[image]

.NET ModelKit Suite ClassReference
EmfExportFilter..::.GetFactory Method
EmfExportFilter Class See Also Send Feedback
Returns the factory associated with the current export filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilterFactory GetFactory()
Visual Basic (Declaration)
Public Overrides Function GetFactory As ExportFilterFactory
Visual C++
public:
virtual ExportFilterFactory^ GetFactory() override

See Also

EmfExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
EmfExportFilter..::.MemberwiseClone Method
EmfExportFilter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

EmfExportFilter Class
EmfExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


EmfExportFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
EmfExportFilter Properties
EmfExportFilter Class See Also Send Feedback

The EmfExportFilter type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

EmfExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


EmfExportFilter Events

[image] [image]

.NET ModelKit Suite ClassReference
EmfExportFilter Events
EmfExportFilter Class See Also Send Feedback

The EmfExportFilter type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

EmfExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


EmfExportFilterFactory Class

[image]

.NET ModelKit Suite ClassReference
EmfExportFilterFactory Class
Members See Also Send Feedback
Provides creation of EmfExportFilter instances.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class EmfExportFilterFactory : ExportFilterFactory
Visual Basic (Declaration)
Public Class EmfExportFilterFactory _
    Inherits ExportFilterFactory
Visual C++
public ref class EmfExportFilterFactory : public ExportFilterFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export..::.ExportFilterFactory
PerpetuumSoft.Reporting.Export.Graph..::.EmfExportFilterFactory

See Also

EmfExportFilterFactory Members
PerpetuumSoft.Reporting.Export.Graph Namespace


EmfExportFilterFactory Members

[image] [image]

.NET ModelKit Suite ClassReference
EmfExportFilterFactory Members
EmfExportFilterFactory Class Methods Properties See Also Send Feedback

The EmfExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates a new instance of the EmfExportFilter class. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns the standard file extension for the associated BMP export filter. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns the format name for the associated EMF export filter. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Factory | Gets the default instance of the EmfExportFilterFactory class.

See Also

EmfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


EmfExportFilterFactory Methods

[image] [image]

.NET ModelKit Suite ClassReference
EmfExportFilterFactory Methods
EmfExportFilterFactory Class See Also Send Feedback

The EmfExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates a new instance of the EmfExportFilter class. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns the standard file extension for the associated BMP export filter. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns the format name for the associated EMF export filter. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


CreateFilter Method

[image]

.NET ModelKit Suite ClassReference
EmfExportFilterFactory..::.CreateFilter Method
EmfExportFilterFactory Class See Also Send Feedback
Creates a new instance of the EmfExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilter CreateFilter()
Visual Basic (Declaration)
Public Overrides Function CreateFilter As ExportFilter
Visual C++
public:
virtual ExportFilter^ CreateFilter() override

See Also

EmfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GetFilterFileExtension Method

[image]

.NET ModelKit Suite ClassReference
EmfExportFilterFactory..::.GetFilterFileExtension Method
EmfExportFilterFactory Class See Also Send Feedback
Returns the standard file extension for the associated BMP export filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFileExtension()
Visual Basic (Declaration)
Public Overrides Function GetFilterFileExtension As String
Visual C++
public:
virtual String^ GetFilterFileExtension() override

See Also

EmfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GetFilterFormat Method

[image]

.NET ModelKit Suite ClassReference
EmfExportFilterFactory..::.GetFilterFormat Method
EmfExportFilterFactory Class See Also Send Feedback
Returns the format name for the associated EMF export filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFormat()
Visual Basic (Declaration)
Public Overrides Function GetFilterFormat As String
Visual C++
public:
virtual String^ GetFilterFormat() override

See Also

EmfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


EmfExportFilterFactory Properties

[image] [image]

.NET ModelKit Suite ClassReference
EmfExportFilterFactory Properties
EmfExportFilterFactory Class See Also Send Feedback

The EmfExportFilterFactory type exposes the following members.

Properties

Name | Description
Factory | Gets the default instance of the EmfExportFilterFactory class.

See Also

EmfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


Factory Property

[image]

.NET ModelKit Suite ClassReference
EmfExportFilterFactory..::.Factory Property
EmfExportFilterFactory Class See Also Send Feedback
Gets the default instance of the EmfExportFilterFactory class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static EmfExportFilterFactory Factory { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Factory As EmfExportFilterFactory
Visual C++
public:
static property EmfExportFilterFactory^ Factory {
    EmfExportFilterFactory^ get ();
}

See Also

EmfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GifExportFilter Class

[image]

.NET ModelKit Suite ClassReference
GifExportFilter Class
Members See Also Send Feedback
Allows to export the final documents into GIF format.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class GifExportFilter : BitmapImageExportFilter
Visual Basic (Declaration)
Public Class GifExportFilter _
    Inherits BitmapImageExportFilter
Visual C++
public ref class GifExportFilter : public BitmapImageExportFilter

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Export..::.ExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.ImageExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.BitmapImageExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.GifExportFilter

See Also

GifExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


GifExportFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
GifExportFilter Members
GifExportFilter Class Constructors Methods Properties Events See Also Send Feedback

The GifExportFilter type exposes the following members.

Constructors

Name | Description
GifExportFilter | Overloaded.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
ExportPage | Exports the specified page to the specified file. (Inherited from BitmapImageExportFilter.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns the factory associated with the current GIF export filter. (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Returns ImageFormat for the GIF filter. (Overrides BitmapImageExportFilter..::.GetImageFormat()()().)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows filter settings dialog. (Inherited from BitmapImageExportFilter.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ImageResolution | Gets or sets resolution. (Inherited from BitmapImageExportFilter.)
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

GifExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GifExportFilter Constructor

[image] [image]

.NET ModelKit Suite ClassReference
GifExportFilter Constructor
GifExportFilter Class See Also Send Feedback

Overload List

Name | Description
GifExportFilter()()() | Initializes a new instance of the GifExportFilter class.
GifExportFilter(IContainer) | Initializes a new instance of the GifExportFilter class with the specified container.

See Also

GifExportFilter Class
GifExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


GifExportFilter Constructor

[image]

.NET ModelKit Suite ClassReference
GifExportFilter Constructor
GifExportFilter Class See Also Send Feedback
Initializes a new instance of the GifExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public GifExportFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GifExportFilter()

See Also

GifExportFilter Class
GifExportFilter Overload
PerpetuumSoft.Reporting.Export.Graph Namespace


GifExportFilter Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
GifExportFilter Constructor (IContainer)
GifExportFilter Class See Also Send Feedback
Initializes a new instance of the GifExportFilter class with the specified container.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public GifExportFilter(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
GifExportFilter(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

GifExportFilter Class
GifExportFilter Overload
PerpetuumSoft.Reporting.Export.Graph Namespace


GifExportFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
GifExportFilter Methods
GifExportFilter Class See Also Send Feedback

The GifExportFilter type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
ExportPage | Exports the specified page to the specified file. (Inherited from BitmapImageExportFilter.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns the factory associated with the current GIF export filter. (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Returns ImageFormat for the GIF filter. (Overrides BitmapImageExportFilter..::.GetImageFormat()()().)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows filter settings dialog. (Inherited from BitmapImageExportFilter.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

GifExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
GifExportFilter..::.Dispose Method
GifExportFilter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

GifExportFilter Class
GifExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Export Method

[image] [image]

.NET ModelKit Suite ClassReference
GifExportFilter..::.Export Method
GifExportFilter Class See Also Send Feedback

Overload List

Name | Description
Export(Document, Stream) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String, Boolean) | Exports the specified report document to the specified file and optionally shows export filter settings dialog. (Inherited from ExportFilter.)

See Also

GifExportFilter Class
GifExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ExportDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
GifExportFilter..::.ExportDocument Method
GifExportFilter Class See Also Send Feedback

Overload List

Name | Description
ExportDocument(Document, Stream) | Exports given document to the stream. (Inherited from ExportFilter.)
ExportDocument(Document, String) | Exports document to the specified file. (Inherited from ImageExportFilter.)

See Also

GifExportFilter Class
GifExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


GetFactory Method

[image]

.NET ModelKit Suite ClassReference
GifExportFilter..::.GetFactory Method
GifExportFilter Class See Also Send Feedback
Returns the factory associated with the current GIF export filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilterFactory GetFactory()
Visual Basic (Declaration)
Public Overrides Function GetFactory As ExportFilterFactory
Visual C++
public:
virtual ExportFilterFactory^ GetFactory() override

See Also

GifExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GetImageFormat Method

[image]

.NET ModelKit Suite ClassReference
GifExportFilter..::.GetImageFormat Method
GifExportFilter Class See Also Send Feedback
Returns ImageFormat for the GIF filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override ImageFormat GetImageFormat()
Visual Basic (Declaration)
Protected Overrides Function GetImageFormat As ImageFormat
Visual C++
protected:
virtual ImageFormat^ GetImageFormat() override

See Also

GifExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
GifExportFilter..::.MemberwiseClone Method
GifExportFilter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

GifExportFilter Class
GifExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


GifExportFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
GifExportFilter Properties
GifExportFilter Class See Also Send Feedback

The GifExportFilter type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ImageResolution | Gets or sets resolution. (Inherited from BitmapImageExportFilter.)
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

GifExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GifExportFilter Events

[image] [image]

.NET ModelKit Suite ClassReference
GifExportFilter Events
GifExportFilter Class See Also Send Feedback

The GifExportFilter type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

GifExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GifExportFilterFactory Class

[image]

.NET ModelKit Suite ClassReference
GifExportFilterFactory Class
Members See Also Send Feedback
Provides creation of GifExportFilter instances.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class GifExportFilterFactory : ExportFilterFactory
Visual Basic (Declaration)
Public Class GifExportFilterFactory _
    Inherits ExportFilterFactory
Visual C++
public ref class GifExportFilterFactory : public ExportFilterFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export..::.ExportFilterFactory
PerpetuumSoft.Reporting.Export.Graph..::.GifExportFilterFactory

See Also

GifExportFilterFactory Members
PerpetuumSoft.Reporting.Export.Graph Namespace


GifExportFilterFactory Members

[image] [image]

.NET ModelKit Suite ClassReference
GifExportFilterFactory Members
GifExportFilterFactory Class Methods Properties See Also Send Feedback

The GifExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates a new instance of the GifExportFilter class. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns the standard file extension for the associated GIF export filter. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns the format name for the associated GIF export filter. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Factory | Gets the default instance of the GifFilterFactory class.

See Also

GifExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GifExportFilterFactory Methods

[image] [image]

.NET ModelKit Suite ClassReference
GifExportFilterFactory Methods
GifExportFilterFactory Class See Also Send Feedback

The GifExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates a new instance of the GifExportFilter class. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns the standard file extension for the associated GIF export filter. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns the format name for the associated GIF export filter. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GifExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


CreateFilter Method

[image]

.NET ModelKit Suite ClassReference
GifExportFilterFactory..::.CreateFilter Method
GifExportFilterFactory Class See Also Send Feedback
Creates a new instance of the GifExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilter CreateFilter()
Visual Basic (Declaration)
Public Overrides Function CreateFilter As ExportFilter
Visual C++
public:
virtual ExportFilter^ CreateFilter() override

See Also

GifExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GetFilterFileExtension Method

[image]

.NET ModelKit Suite ClassReference
GifExportFilterFactory..::.GetFilterFileExtension Method
GifExportFilterFactory Class See Also Send Feedback
Returns the standard file extension for the associated GIF export filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFileExtension()
Visual Basic (Declaration)
Public Overrides Function GetFilterFileExtension As String
Visual C++
public:
virtual String^ GetFilterFileExtension() override

See Also

GifExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GetFilterFormat Method

[image]

.NET ModelKit Suite ClassReference
GifExportFilterFactory..::.GetFilterFormat Method
GifExportFilterFactory Class See Also Send Feedback
Returns the format name for the associated GIF export filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFormat()
Visual Basic (Declaration)
Public Overrides Function GetFilterFormat As String
Visual C++
public:
virtual String^ GetFilterFormat() override

See Also

GifExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GifExportFilterFactory Properties

[image] [image]

.NET ModelKit Suite ClassReference
GifExportFilterFactory Properties
GifExportFilterFactory Class See Also Send Feedback

The GifExportFilterFactory type exposes the following members.

Properties

Name | Description
Factory | Gets the default instance of the GifFilterFactory class.

See Also

GifExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


Factory Property

[image]

.NET ModelKit Suite ClassReference
GifExportFilterFactory..::.Factory Property
GifExportFilterFactory Class See Also Send Feedback
Gets the default instance of the GifFilterFactory class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static GifExportFilterFactory Factory { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Factory As GifExportFilterFactory
Visual C++
public:
static property GifExportFilterFactory^ Factory {
    GifExportFilterFactory^ get ();
}

See Also

GifExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


ImageExportFilter Class

[image]

.NET ModelKit Suite ClassReference
ImageExportFilter Class
Members See Also Send Feedback
The base class for all image export filters.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract class ImageExportFilter : ExportFilter
Visual Basic (Declaration)
Public MustInherit Class ImageExportFilter _
    Inherits ExportFilter
Visual C++
public ref class ImageExportFilter abstract : public ExportFilter

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Export..::.ExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.ImageExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.BitmapImageExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.VectorImageExportFilter

See Also

ImageExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ImageExportFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
ImageExportFilter Members
ImageExportFilter Class Constructors Methods Properties Events See Also Send Feedback

The ImageExportFilter type exposes the following members.

Constructors

Name | Description
ImageExportFilter | Initialaze new instance of ImageExportFilter.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
ExportPage | Exports the specified page to the specified file.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns FilterFactory for the filter. (Inherited from ExportFilter.)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows filter settings dialog. (Inherited from ExportFilter.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


ImageExportFilter Constructor

[image]

.NET ModelKit Suite ClassReference
ImageExportFilter Constructor
ImageExportFilter Class See Also Send Feedback
Initialaze new instance of ImageExportFilter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ImageExportFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ImageExportFilter()

See Also

ImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


ImageExportFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ImageExportFilter Methods
ImageExportFilter Class See Also Send Feedback

The ImageExportFilter type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
ExportPage | Exports the specified page to the specified file.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns FilterFactory for the filter. (Inherited from ExportFilter.)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows filter settings dialog. (Inherited from ExportFilter.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ImageExportFilter..::.Dispose Method
ImageExportFilter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

ImageExportFilter Class
ImageExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Export Method

[image] [image]

.NET ModelKit Suite ClassReference
ImageExportFilter..::.Export Method
ImageExportFilter Class See Also Send Feedback

Overload List

Name | Description
Export(Document, Stream) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String, Boolean) | Exports the specified report document to the specified file and optionally shows export filter settings dialog. (Inherited from ExportFilter.)

See Also

ImageExportFilter Class
ImageExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ExportDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
ImageExportFilter..::.ExportDocument Method
ImageExportFilter Class See Also Send Feedback

Overload List

Name | Description
ExportDocument(Document, Stream) | Exports given document to the stream. (Inherited from ExportFilter.)
ExportDocument(Document, String) | Exports document to the specified file. (Overrides ExportFilter..::.ExportDocument(Document, String).)

See Also

ImageExportFilter Class
ImageExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ExportDocument Method (Document, String)

[image]

.NET ModelKit Suite ClassReference
ImageExportFilter..::.ExportDocument Method (Document, String)
ImageExportFilter Class See Also Send Feedback
Exports document to the specified file.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void ExportDocument(
    Document document,
    string fileName
)
Visual Basic (Declaration)
Protected Overrides Sub ExportDocument ( _
    document As Document, _
    fileName As String _
)
Visual C++
protected:
virtual void ExportDocument(
    Document^ document,
    String^ fileName
) override

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
fileName
Type: System..::.String

See Also

ImageExportFilter Class
ExportDocument Overload
PerpetuumSoft.Reporting.Export.Graph Namespace


ExportPage Method

[image]

.NET ModelKit Suite ClassReference
ImageExportFilter..::.ExportPage Method
ImageExportFilter Class See Also Send Feedback
Exports the specified page to the specified file.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected abstract void ExportPage(
    Page page,
    string fileName
)
Visual Basic (Declaration)
Protected MustOverride Sub ExportPage ( _
    page As Page, _
    fileName As String _
)
Visual C++
protected:
virtual void ExportPage(
    Page^ page,
    String^ fileName
) abstract

Parameters

page
Type: PerpetuumSoft.Reporting.DOM..::.Page
fileName
Type: System..::.String

See Also

ImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
ImageExportFilter..::.MemberwiseClone Method
ImageExportFilter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ImageExportFilter Class
ImageExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ImageExportFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
ImageExportFilter Properties
ImageExportFilter Class See Also Send Feedback

The ImageExportFilter type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

ImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


ImageExportFilter Events

[image] [image]

.NET ModelKit Suite ClassReference
ImageExportFilter Events
ImageExportFilter Class See Also Send Feedback

The ImageExportFilter type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

ImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


JpegOptionsDialog Class

[image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog Class
Members See Also Send Feedback
A dialog window for assigning parameters of export to JPEG

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class JpegOptionsDialog : Form
Visual Basic (Declaration)
Public Class JpegOptionsDialog _
    Inherits Form
Visual C++
public ref class JpegOptionsDialog : public Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
PerpetuumSoft.Reporting.Export.Graph..::.JpegOptionsDialog

See Also

JpegOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


JpegOptionsDialog Members

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog Members
JpegOptionsDialog Class Constructors Methods Properties Events See Also Send Feedback

The JpegOptionsDialog type exposes the following members.

Constructors

Name | Description
JpegOptionsDialog | Initializes a new instance of the JpegOptionsDialog class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

JpegOptionsDialog Class
PerpetuumSoft.Reporting.Export.Graph Namespace


JpegOptionsDialog Constructor

[image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog Constructor
JpegOptionsDialog Class See Also Send Feedback
Initializes a new instance of the JpegOptionsDialog class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public JpegOptionsDialog(
    JpgExportFilter filter
)
Visual Basic (Declaration)
Public Sub New ( _
    filter As JpgExportFilter _
)
Visual C++
public:
JpegOptionsDialog(
    JpgExportFilter^ filter
)

Parameters

filter
Type: PerpetuumSoft.Reporting.Export.Graph..::.JpgExportFilter

See Also

JpegOptionsDialog Class
PerpetuumSoft.Reporting.Export.Graph Namespace


JpegOptionsDialog Methods

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog Methods
JpegOptionsDialog Class See Also Send Feedback

The JpegOptionsDialog type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

JpegOptionsDialog Class
PerpetuumSoft.Reporting.Export.Graph Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.AccessibilityNotifyClients Method
JpegOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

JpegOptionsDialog Class
JpegOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.BeginInvoke Method
JpegOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

JpegOptionsDialog Class
JpegOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.Dispose Method
JpegOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | The Dispose Finalize pattern ensures that resources are released when the object is no longer needed (Overrides Form..::.Dispose(Boolean).)

See Also

JpegOptionsDialog Class
JpegOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.Dispose Method (Boolean)
JpegOptionsDialog Class See Also Send Feedback
The Dispose Finalize pattern ensures that resources are released when the object is no longer needed

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

JpegOptionsDialog Class
Dispose Overload
PerpetuumSoft.Reporting.Export.Graph Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.GetChildAtPoint Method
JpegOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

JpegOptionsDialog Class
JpegOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.Invalidate Method
JpegOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

JpegOptionsDialog Class
JpegOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.Invoke Method
JpegOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

JpegOptionsDialog Class
JpegOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.MemberwiseClone Method
JpegOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

JpegOptionsDialog Class
JpegOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.OnLoad Method
JpegOptionsDialog Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

JpegOptionsDialog Class
PerpetuumSoft.Reporting.Export.Graph Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.PerformLayout Method
JpegOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

JpegOptionsDialog Class
JpegOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.ResumeLayout Method
JpegOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

JpegOptionsDialog Class
JpegOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.RtlTranslateAlignment Method
JpegOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

JpegOptionsDialog Class
JpegOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.Scale Method
JpegOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

JpegOptionsDialog Class
JpegOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.Select Method
JpegOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

JpegOptionsDialog Class
JpegOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.SetBounds Method
JpegOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

JpegOptionsDialog Class
JpegOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Show Method

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.Show Method
JpegOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

JpegOptionsDialog Class
JpegOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ShowDialog Method

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.ShowDialog Method
JpegOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

JpegOptionsDialog Class
JpegOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.UpdateBounds Method
JpegOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

JpegOptionsDialog Class
JpegOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.Validate Method
JpegOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

JpegOptionsDialog Class
JpegOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog..::.ValidateChildren Method
JpegOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

JpegOptionsDialog Class
JpegOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


JpegOptionsDialog Properties

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog Properties
JpegOptionsDialog Class See Also Send Feedback

The JpegOptionsDialog type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

JpegOptionsDialog Class
PerpetuumSoft.Reporting.Export.Graph Namespace


JpegOptionsDialog Events

[image] [image]

.NET ModelKit Suite ClassReference
JpegOptionsDialog Events
JpegOptionsDialog Class See Also Send Feedback

The JpegOptionsDialog type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

JpegOptionsDialog Class
PerpetuumSoft.Reporting.Export.Graph Namespace


JpgExportFilter Class

[image]

.NET ModelKit Suite ClassReference
JpgExportFilter Class
Members See Also Send Feedback
Allows to export the final documents into JPEG format.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class JpgExportFilter : BitmapImageExportFilter
Visual Basic (Declaration)
Public Class JpgExportFilter _
    Inherits BitmapImageExportFilter
Visual C++
public ref class JpgExportFilter : public BitmapImageExportFilter

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Export..::.ExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.ImageExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.BitmapImageExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.JpgExportFilter

See Also

JpgExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


JpgExportFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
JpgExportFilter Members
JpgExportFilter Class Constructors Methods Properties Events See Also Send Feedback

The JpgExportFilter type exposes the following members.

Constructors

Name | Description
JpgExportFilter | Overloaded.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
ExportPage | Exports given page to Jpeg. (Overrides BitmapImageExportFilter..::.ExportPage(Page, String).)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns the factory associated with the current JPG export filter. (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Returns the ImageFormat for the JPG filter. (Overrides BitmapImageExportFilter..::.GetImageFormat()()().)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows options dialog. (Overrides BitmapImageExportFilter..::.ShowDialog()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ImageResolution | Gets or sets resolution. (Inherited from BitmapImageExportFilter.)
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Quality | Gets or sets image quality.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

JpgExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


JpgExportFilter Constructor

[image] [image]

.NET ModelKit Suite ClassReference
JpgExportFilter Constructor
JpgExportFilter Class See Also Send Feedback

Overload List

Name | Description
JpgExportFilter()()() | Initializes a new instance of the JpgExportFilter class.
JpgExportFilter(IContainer) | Initializes a new instance of the JpgExportFilter class with the specified container.

See Also

JpgExportFilter Class
JpgExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


JpgExportFilter Constructor

[image]

.NET ModelKit Suite ClassReference
JpgExportFilter Constructor
JpgExportFilter Class See Also Send Feedback
Initializes a new instance of the JpgExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public JpgExportFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
JpgExportFilter()

See Also

JpgExportFilter Class
JpgExportFilter Overload
PerpetuumSoft.Reporting.Export.Graph Namespace


JpgExportFilter Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
JpgExportFilter Constructor (IContainer)
JpgExportFilter Class See Also Send Feedback
Initializes a new instance of the JpgExportFilter class with the specified container.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public JpgExportFilter(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
JpgExportFilter(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

JpgExportFilter Class
JpgExportFilter Overload
PerpetuumSoft.Reporting.Export.Graph Namespace


JpgExportFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
JpgExportFilter Methods
JpgExportFilter Class See Also Send Feedback

The JpgExportFilter type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
ExportPage | Exports given page to Jpeg. (Overrides BitmapImageExportFilter..::.ExportPage(Page, String).)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns the factory associated with the current JPG export filter. (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Returns the ImageFormat for the JPG filter. (Overrides BitmapImageExportFilter..::.GetImageFormat()()().)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows options dialog. (Overrides BitmapImageExportFilter..::.ShowDialog()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

JpgExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
JpgExportFilter..::.Dispose Method
JpgExportFilter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

JpgExportFilter Class
JpgExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Export Method

[image] [image]

.NET ModelKit Suite ClassReference
JpgExportFilter..::.Export Method
JpgExportFilter Class See Also Send Feedback

Overload List

Name | Description
Export(Document, Stream) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String, Boolean) | Exports the specified report document to the specified file and optionally shows export filter settings dialog. (Inherited from ExportFilter.)

See Also

JpgExportFilter Class
JpgExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ExportDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
JpgExportFilter..::.ExportDocument Method
JpgExportFilter Class See Also Send Feedback

Overload List

Name | Description
ExportDocument(Document, Stream) | Exports given document to the stream. (Inherited from ExportFilter.)
ExportDocument(Document, String) | Exports document to the specified file. (Inherited from ImageExportFilter.)

See Also

JpgExportFilter Class
JpgExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ExportPage Method

[image]

.NET ModelKit Suite ClassReference
JpgExportFilter..::.ExportPage Method
JpgExportFilter Class See Also Send Feedback
Exports given page to Jpeg.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void ExportPage(
    Page page,
    string fileName
)
Visual Basic (Declaration)
Protected Overrides Sub ExportPage ( _
    page As Page, _
    fileName As String _
)
Visual C++
protected:
virtual void ExportPage(
    Page^ page,
    String^ fileName
) override

Parameters

page
Type: PerpetuumSoft.Reporting.DOM..::.Page
fileName
Type: System..::.String

See Also

JpgExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GetFactory Method

[image]

.NET ModelKit Suite ClassReference
JpgExportFilter..::.GetFactory Method
JpgExportFilter Class See Also Send Feedback
Returns the factory associated with the current JPG export filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilterFactory GetFactory()
Visual Basic (Declaration)
Public Overrides Function GetFactory As ExportFilterFactory
Visual C++
public:
virtual ExportFilterFactory^ GetFactory() override

See Also

JpgExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GetImageFormat Method

[image]

.NET ModelKit Suite ClassReference
JpgExportFilter..::.GetImageFormat Method
JpgExportFilter Class See Also Send Feedback
Returns the ImageFormat for the JPG filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override ImageFormat GetImageFormat()
Visual Basic (Declaration)
Protected Overrides Function GetImageFormat As ImageFormat
Visual C++
protected:
virtual ImageFormat^ GetImageFormat() override

See Also

JpgExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
JpgExportFilter..::.MemberwiseClone Method
JpgExportFilter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

JpgExportFilter Class
JpgExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ShowDialog Method

[image]

.NET ModelKit Suite ClassReference
JpgExportFilter..::.ShowDialog Method
JpgExportFilter Class See Also Send Feedback
Shows options dialog.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override DialogResult ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As DialogResult
Visual C++
public:
virtual DialogResult ShowDialog() override

See Also

JpgExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


JpgExportFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
JpgExportFilter Properties
JpgExportFilter Class See Also Send Feedback

The JpgExportFilter type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ImageResolution | Gets or sets resolution. (Inherited from BitmapImageExportFilter.)
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Quality | Gets or sets image quality.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

JpgExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


Quality Property

[image]

.NET ModelKit Suite ClassReference
JpgExportFilter..::.Quality Property
JpgExportFilter Class See Also Send Feedback
Gets or sets image quality.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int Quality { get; set; }
Visual Basic (Declaration)
Public Property Quality As Integer
Visual C++
public:
property int Quality {
    int get ();
    void set (int value);
}

See Also

JpgExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


JpgExportFilter Events

[image] [image]

.NET ModelKit Suite ClassReference
JpgExportFilter Events
JpgExportFilter Class See Also Send Feedback

The JpgExportFilter type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

JpgExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


JpgExportFilterFactory Class

[image]

.NET ModelKit Suite ClassReference
JpgExportFilterFactory Class
Members See Also Send Feedback
Provides creation of JpgExportFilter instances.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class JpgExportFilterFactory : ExportFilterFactory
Visual Basic (Declaration)
Public Class JpgExportFilterFactory _
    Inherits ExportFilterFactory
Visual C++
public ref class JpgExportFilterFactory : public ExportFilterFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export..::.ExportFilterFactory
PerpetuumSoft.Reporting.Export.Graph..::.JpgExportFilterFactory

See Also

JpgExportFilterFactory Members
PerpetuumSoft.Reporting.Export.Graph Namespace


JpgExportFilterFactory Members

[image] [image]

.NET ModelKit Suite ClassReference
JpgExportFilterFactory Members
JpgExportFilterFactory Class Methods Properties See Also Send Feedback

The JpgExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates a new instance of the JpgExportFilter class. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns the standard file extension for the associated JPG export filter. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns the format name for the associated JPG export filter. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Factory | Gets the default instance of the JpgExportFilterFactory class.

See Also

JpgExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


JpgExportFilterFactory Methods

[image] [image]

.NET ModelKit Suite ClassReference
JpgExportFilterFactory Methods
JpgExportFilterFactory Class See Also Send Feedback

The JpgExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates a new instance of the JpgExportFilter class. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns the standard file extension for the associated JPG export filter. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns the format name for the associated JPG export filter. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JpgExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


CreateFilter Method

[image]

.NET ModelKit Suite ClassReference
JpgExportFilterFactory..::.CreateFilter Method
JpgExportFilterFactory Class See Also Send Feedback
Creates a new instance of the JpgExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilter CreateFilter()
Visual Basic (Declaration)
Public Overrides Function CreateFilter As ExportFilter
Visual C++
public:
virtual ExportFilter^ CreateFilter() override

See Also

JpgExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GetFilterFileExtension Method

[image]

.NET ModelKit Suite ClassReference
JpgExportFilterFactory..::.GetFilterFileExtension Method
JpgExportFilterFactory Class See Also Send Feedback
Returns the standard file extension for the associated JPG export filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFileExtension()
Visual Basic (Declaration)
Public Overrides Function GetFilterFileExtension As String
Visual C++
public:
virtual String^ GetFilterFileExtension() override

See Also

JpgExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GetFilterFormat Method

[image]

.NET ModelKit Suite ClassReference
JpgExportFilterFactory..::.GetFilterFormat Method
JpgExportFilterFactory Class See Also Send Feedback
Returns the format name for the associated JPG export filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFormat()
Visual Basic (Declaration)
Public Overrides Function GetFilterFormat As String
Visual C++
public:
virtual String^ GetFilterFormat() override

See Also

JpgExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


JpgExportFilterFactory Properties

[image] [image]

.NET ModelKit Suite ClassReference
JpgExportFilterFactory Properties
JpgExportFilterFactory Class See Also Send Feedback

The JpgExportFilterFactory type exposes the following members.

Properties

Name | Description
Factory | Gets the default instance of the JpgExportFilterFactory class.

See Also

JpgExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


Factory Property

[image]

.NET ModelKit Suite ClassReference
JpgExportFilterFactory..::.Factory Property
JpgExportFilterFactory Class See Also Send Feedback
Gets the default instance of the JpgExportFilterFactory class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static JpgExportFilterFactory Factory { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Factory As JpgExportFilterFactory
Visual C++
public:
static property JpgExportFilterFactory^ Factory {
    JpgExportFilterFactory^ get ();
}

See Also

JpgExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


PictureOptionsDialog Class

[image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog Class
Members See Also Send Feedback
Image export dialod form

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class PictureOptionsDialog : Form
Visual Basic (Declaration)
Public Class PictureOptionsDialog _
    Inherits Form
Visual C++
public ref class PictureOptionsDialog : public Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
PerpetuumSoft.Reporting.Export.Graph..::.PictureOptionsDialog

See Also

PictureOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


PictureOptionsDialog Members

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog Members
PictureOptionsDialog Class Constructors Methods Properties Events See Also Send Feedback

The PictureOptionsDialog type exposes the following members.

Constructors

Name | Description
PictureOptionsDialog | Initializes a new instance of the PictureOptionsDialog class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PictureOptionsDialog Class
PerpetuumSoft.Reporting.Export.Graph Namespace


PictureOptionsDialog Constructor

[image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog Constructor
PictureOptionsDialog Class See Also Send Feedback
Initializes a new instance of the PictureOptionsDialog class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PictureOptionsDialog(
    BitmapImageExportFilter filter
)
Visual Basic (Declaration)
Public Sub New ( _
    filter As BitmapImageExportFilter _
)
Visual C++
public:
PictureOptionsDialog(
    BitmapImageExportFilter^ filter
)

Parameters

filter
Type: PerpetuumSoft.Reporting.Export.Graph..::.BitmapImageExportFilter

See Also

PictureOptionsDialog Class
PerpetuumSoft.Reporting.Export.Graph Namespace


PictureOptionsDialog Methods

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog Methods
PictureOptionsDialog Class See Also Send Feedback

The PictureOptionsDialog type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

PictureOptionsDialog Class
PerpetuumSoft.Reporting.Export.Graph Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.AccessibilityNotifyClients Method
PictureOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

PictureOptionsDialog Class
PictureOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.BeginInvoke Method
PictureOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

PictureOptionsDialog Class
PictureOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.Dispose Method
PictureOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | The Dispose Finalize pattern ensures that resources are released when the object is no longer needed (Overrides Form..::.Dispose(Boolean).)

See Also

PictureOptionsDialog Class
PictureOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.Dispose Method (Boolean)
PictureOptionsDialog Class See Also Send Feedback
The Dispose Finalize pattern ensures that resources are released when the object is no longer needed

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

PictureOptionsDialog Class
Dispose Overload
PerpetuumSoft.Reporting.Export.Graph Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.GetChildAtPoint Method
PictureOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

PictureOptionsDialog Class
PictureOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.Invalidate Method
PictureOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

PictureOptionsDialog Class
PictureOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.Invoke Method
PictureOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

PictureOptionsDialog Class
PictureOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.MemberwiseClone Method
PictureOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PictureOptionsDialog Class
PictureOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.OnLoad Method
PictureOptionsDialog Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

PictureOptionsDialog Class
PerpetuumSoft.Reporting.Export.Graph Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.PerformLayout Method
PictureOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

PictureOptionsDialog Class
PictureOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.ResumeLayout Method
PictureOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

PictureOptionsDialog Class
PictureOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.RtlTranslateAlignment Method
PictureOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

PictureOptionsDialog Class
PictureOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.Scale Method
PictureOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

PictureOptionsDialog Class
PictureOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.Select Method
PictureOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

PictureOptionsDialog Class
PictureOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.SetBounds Method
PictureOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

PictureOptionsDialog Class
PictureOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Show Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.Show Method
PictureOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

PictureOptionsDialog Class
PictureOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ShowDialog Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.ShowDialog Method
PictureOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

PictureOptionsDialog Class
PictureOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.UpdateBounds Method
PictureOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

PictureOptionsDialog Class
PictureOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.Validate Method
PictureOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

PictureOptionsDialog Class
PictureOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog..::.ValidateChildren Method
PictureOptionsDialog Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

PictureOptionsDialog Class
PictureOptionsDialog Members
PerpetuumSoft.Reporting.Export.Graph Namespace


PictureOptionsDialog Properties

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog Properties
PictureOptionsDialog Class See Also Send Feedback

The PictureOptionsDialog type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

PictureOptionsDialog Class
PerpetuumSoft.Reporting.Export.Graph Namespace


PictureOptionsDialog Events

[image] [image]

.NET ModelKit Suite ClassReference
PictureOptionsDialog Events
PictureOptionsDialog Class See Also Send Feedback

The PictureOptionsDialog type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PictureOptionsDialog Class
PerpetuumSoft.Reporting.Export.Graph Namespace


PngExportFilter Class

[image]

.NET ModelKit Suite ClassReference
PngExportFilter Class
Members See Also Send Feedback
Allows to export the final documents into Png format.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class PngExportFilter : BitmapImageExportFilter
Visual Basic (Declaration)
Public Class PngExportFilter _
    Inherits BitmapImageExportFilter
Visual C++
public ref class PngExportFilter : public BitmapImageExportFilter

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Export..::.ExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.ImageExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.BitmapImageExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.PngExportFilter

See Also

PngExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


PngExportFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
PngExportFilter Members
PngExportFilter Class Constructors Methods Properties Events See Also Send Feedback

The PngExportFilter type exposes the following members.

Constructors

Name | Description
PngExportFilter | Overloaded.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
ExportPage | Exports the specified page to the specified file. (Inherited from BitmapImageExportFilter.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns the factory associated with the current Png export filter. (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Returns ImageFormat for the Png filter. (Overrides BitmapImageExportFilter..::.GetImageFormat()()().)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows filter settings dialog. (Inherited from BitmapImageExportFilter.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ImageResolution | Gets or sets resolution. (Inherited from BitmapImageExportFilter.)
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

PngExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


PngExportFilter Constructor

[image] [image]

.NET ModelKit Suite ClassReference
PngExportFilter Constructor
PngExportFilter Class See Also Send Feedback

Overload List

Name | Description
PngExportFilter()()() | Initializes a new instance of the PngExportFilter class.
PngExportFilter(IContainer) | Initializes a new instance of the PngExportFilter class with the specified container.

See Also

PngExportFilter Class
PngExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


PngExportFilter Constructor

[image]

.NET ModelKit Suite ClassReference
PngExportFilter Constructor
PngExportFilter Class See Also Send Feedback
Initializes a new instance of the PngExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PngExportFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PngExportFilter()

See Also

PngExportFilter Class
PngExportFilter Overload
PerpetuumSoft.Reporting.Export.Graph Namespace


PngExportFilter Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
PngExportFilter Constructor (IContainer)
PngExportFilter Class See Also Send Feedback
Initializes a new instance of the PngExportFilter class with the specified container.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PngExportFilter(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
PngExportFilter(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

PngExportFilter Class
PngExportFilter Overload
PerpetuumSoft.Reporting.Export.Graph Namespace


PngExportFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
PngExportFilter Methods
PngExportFilter Class See Also Send Feedback

The PngExportFilter type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
ExportPage | Exports the specified page to the specified file. (Inherited from BitmapImageExportFilter.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns the factory associated with the current Png export filter. (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Returns ImageFormat for the Png filter. (Overrides BitmapImageExportFilter..::.GetImageFormat()()().)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows filter settings dialog. (Inherited from BitmapImageExportFilter.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

PngExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
PngExportFilter..::.Dispose Method
PngExportFilter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

PngExportFilter Class
PngExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Export Method

[image] [image]

.NET ModelKit Suite ClassReference
PngExportFilter..::.Export Method
PngExportFilter Class See Also Send Feedback

Overload List

Name | Description
Export(Document, Stream) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String, Boolean) | Exports the specified report document to the specified file and optionally shows export filter settings dialog. (Inherited from ExportFilter.)

See Also

PngExportFilter Class
PngExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ExportDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
PngExportFilter..::.ExportDocument Method
PngExportFilter Class See Also Send Feedback

Overload List

Name | Description
ExportDocument(Document, Stream) | Exports given document to the stream. (Inherited from ExportFilter.)
ExportDocument(Document, String) | Exports document to the specified file. (Inherited from ImageExportFilter.)

See Also

PngExportFilter Class
PngExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


GetFactory Method

[image]

.NET ModelKit Suite ClassReference
PngExportFilter..::.GetFactory Method
PngExportFilter Class See Also Send Feedback
Returns the factory associated with the current Png export filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilterFactory GetFactory()
Visual Basic (Declaration)
Public Overrides Function GetFactory As ExportFilterFactory
Visual C++
public:
virtual ExportFilterFactory^ GetFactory() override

See Also

PngExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GetImageFormat Method

[image]

.NET ModelKit Suite ClassReference
PngExportFilter..::.GetImageFormat Method
PngExportFilter Class See Also Send Feedback
Returns ImageFormat for the Png filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override ImageFormat GetImageFormat()
Visual Basic (Declaration)
Protected Overrides Function GetImageFormat As ImageFormat
Visual C++
protected:
virtual ImageFormat^ GetImageFormat() override

See Also

PngExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
PngExportFilter..::.MemberwiseClone Method
PngExportFilter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PngExportFilter Class
PngExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


PngExportFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
PngExportFilter Properties
PngExportFilter Class See Also Send Feedback

The PngExportFilter type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ImageResolution | Gets or sets resolution. (Inherited from BitmapImageExportFilter.)
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

PngExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


PngExportFilter Events

[image] [image]

.NET ModelKit Suite ClassReference
PngExportFilter Events
PngExportFilter Class See Also Send Feedback

The PngExportFilter type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

PngExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


PngExportFilterFactory Class

[image]

.NET ModelKit Suite ClassReference
PngExportFilterFactory Class
Members See Also Send Feedback
Provides creation of PngExportFilter instances.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class PngExportFilterFactory : ExportFilterFactory
Visual Basic (Declaration)
Public Class PngExportFilterFactory _
    Inherits ExportFilterFactory
Visual C++
public ref class PngExportFilterFactory : public ExportFilterFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export..::.ExportFilterFactory
PerpetuumSoft.Reporting.Export.Graph..::.PngExportFilterFactory

See Also

PngExportFilterFactory Members
PerpetuumSoft.Reporting.Export.Graph Namespace


PngExportFilterFactory Members

[image] [image]

.NET ModelKit Suite ClassReference
PngExportFilterFactory Members
PngExportFilterFactory Class Methods Properties See Also Send Feedback

The PngExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates a new instance of the PngExportFilter class. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns the standard file extension for the associated Png export filter. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns the format name for the associated Png export filter. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Factory | Gets the default instance of the PngFilterFactory class.

See Also

PngExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


PngExportFilterFactory Methods

[image] [image]

.NET ModelKit Suite ClassReference
PngExportFilterFactory Methods
PngExportFilterFactory Class See Also Send Feedback

The PngExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates a new instance of the PngExportFilter class. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns the standard file extension for the associated Png export filter. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns the format name for the associated Png export filter. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PngExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


CreateFilter Method

[image]

.NET ModelKit Suite ClassReference
PngExportFilterFactory..::.CreateFilter Method
PngExportFilterFactory Class See Also Send Feedback
Creates a new instance of the PngExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilter CreateFilter()
Visual Basic (Declaration)
Public Overrides Function CreateFilter As ExportFilter
Visual C++
public:
virtual ExportFilter^ CreateFilter() override

See Also

PngExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GetFilterFileExtension Method

[image]

.NET ModelKit Suite ClassReference
PngExportFilterFactory..::.GetFilterFileExtension Method
PngExportFilterFactory Class See Also Send Feedback
Returns the standard file extension for the associated Png export filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFileExtension()
Visual Basic (Declaration)
Public Overrides Function GetFilterFileExtension As String
Visual C++
public:
virtual String^ GetFilterFileExtension() override

See Also

PngExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GetFilterFormat Method

[image]

.NET ModelKit Suite ClassReference
PngExportFilterFactory..::.GetFilterFormat Method
PngExportFilterFactory Class See Also Send Feedback
Returns the format name for the associated Png export filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFormat()
Visual Basic (Declaration)
Public Overrides Function GetFilterFormat As String
Visual C++
public:
virtual String^ GetFilterFormat() override

See Also

PngExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


PngExportFilterFactory Properties

[image] [image]

.NET ModelKit Suite ClassReference
PngExportFilterFactory Properties
PngExportFilterFactory Class See Also Send Feedback

The PngExportFilterFactory type exposes the following members.

Properties

Name | Description
Factory | Gets the default instance of the PngFilterFactory class.

See Also

PngExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


Factory Property

[image]

.NET ModelKit Suite ClassReference
PngExportFilterFactory..::.Factory Property
PngExportFilterFactory Class See Also Send Feedback
Gets the default instance of the PngFilterFactory class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static PngExportFilterFactory Factory { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Factory As PngExportFilterFactory
Visual C++
public:
static property PngExportFilterFactory^ Factory {
    PngExportFilterFactory^ get ();
}

See Also

PngExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


TiffExportFilter Class

[image]

.NET ModelKit Suite ClassReference
TiffExportFilter Class
Members See Also Send Feedback
Allows to export the final documents into Tiff format.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class TiffExportFilter : BitmapImageExportFilter
Visual Basic (Declaration)
Public Class TiffExportFilter _
    Inherits BitmapImageExportFilter
Visual C++
public ref class TiffExportFilter : public BitmapImageExportFilter

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Export..::.ExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.ImageExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.BitmapImageExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.TiffExportFilter

See Also

TiffExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


TiffExportFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
TiffExportFilter Members
TiffExportFilter Class Constructors Methods Properties Events See Also Send Feedback

The TiffExportFilter type exposes the following members.

Constructors

Name | Description
TiffExportFilter | Overloaded.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
ExportPage | Exports the specified page to the specified file. (Inherited from BitmapImageExportFilter.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns the factory associated with the current Tiff export filter. (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Returns ImageFormat for the Tiff filter. (Overrides BitmapImageExportFilter..::.GetImageFormat()()().)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows filter settings dialog. (Inherited from BitmapImageExportFilter.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ImageResolution | Gets or sets resolution. (Inherited from BitmapImageExportFilter.)
MultiPage | Gets or sets value indicating that the dociment is exported to images by pages.
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

TiffExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


TiffExportFilter Constructor

[image] [image]

.NET ModelKit Suite ClassReference
TiffExportFilter Constructor
TiffExportFilter Class See Also Send Feedback

Overload List

Name | Description
TiffExportFilter()()() | Initializes a new instance of the TiffExportFilter class.
TiffExportFilter(IContainer) | Initializes a new instance of the TiffExportFilter class with the specified container.

See Also

TiffExportFilter Class
TiffExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


TiffExportFilter Constructor

[image]

.NET ModelKit Suite ClassReference
TiffExportFilter Constructor
TiffExportFilter Class See Also Send Feedback
Initializes a new instance of the TiffExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public TiffExportFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TiffExportFilter()

See Also

TiffExportFilter Class
TiffExportFilter Overload
PerpetuumSoft.Reporting.Export.Graph Namespace


TiffExportFilter Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
TiffExportFilter Constructor (IContainer)
TiffExportFilter Class See Also Send Feedback
Initializes a new instance of the TiffExportFilter class with the specified container.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public TiffExportFilter(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
TiffExportFilter(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

TiffExportFilter Class
TiffExportFilter Overload
PerpetuumSoft.Reporting.Export.Graph Namespace


TiffExportFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
TiffExportFilter Methods
TiffExportFilter Class See Also Send Feedback

The TiffExportFilter type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
ExportPage | Exports the specified page to the specified file. (Inherited from BitmapImageExportFilter.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns the factory associated with the current Tiff export filter. (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageFormat | Returns ImageFormat for the Tiff filter. (Overrides BitmapImageExportFilter..::.GetImageFormat()()().)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows filter settings dialog. (Inherited from BitmapImageExportFilter.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

TiffExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
TiffExportFilter..::.Dispose Method
TiffExportFilter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

TiffExportFilter Class
TiffExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Export Method

[image] [image]

.NET ModelKit Suite ClassReference
TiffExportFilter..::.Export Method
TiffExportFilter Class See Also Send Feedback

Overload List

Name | Description
Export(Document, Stream) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String, Boolean) | Exports the specified report document to the specified file and optionally shows export filter settings dialog. (Inherited from ExportFilter.)

See Also

TiffExportFilter Class
TiffExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ExportDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
TiffExportFilter..::.ExportDocument Method
TiffExportFilter Class See Also Send Feedback

Overload List

Name | Description
ExportDocument(Document, Stream) | Exports given document to the stream. (Inherited from ExportFilter.)
ExportDocument(Document, String) | Exports the document. (Overrides ImageExportFilter..::.ExportDocument(Document, String).)

See Also

TiffExportFilter Class
TiffExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ExportDocument Method (Document, String)

[image]

.NET ModelKit Suite ClassReference
TiffExportFilter..::.ExportDocument Method (Document, String)
TiffExportFilter Class See Also Send Feedback
Exports the document.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void ExportDocument(
    Document document,
    string fileName
)
Visual Basic (Declaration)
Protected Overrides Sub ExportDocument ( _
    document As Document, _
    fileName As String _
)
Visual C++
protected:
virtual void ExportDocument(
    Document^ document,
    String^ fileName
) override

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
fileName
Type: System..::.String

See Also

TiffExportFilter Class
ExportDocument Overload
PerpetuumSoft.Reporting.Export.Graph Namespace


GetFactory Method

[image]

.NET ModelKit Suite ClassReference
TiffExportFilter..::.GetFactory Method
TiffExportFilter Class See Also Send Feedback
Returns the factory associated with the current Tiff export filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilterFactory GetFactory()
Visual Basic (Declaration)
Public Overrides Function GetFactory As ExportFilterFactory
Visual C++
public:
virtual ExportFilterFactory^ GetFactory() override

See Also

TiffExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GetImageFormat Method

[image]

.NET ModelKit Suite ClassReference
TiffExportFilter..::.GetImageFormat Method
TiffExportFilter Class See Also Send Feedback
Returns ImageFormat for the Tiff filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override ImageFormat GetImageFormat()
Visual Basic (Declaration)
Protected Overrides Function GetImageFormat As ImageFormat
Visual C++
protected:
virtual ImageFormat^ GetImageFormat() override

See Also

TiffExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
TiffExportFilter..::.MemberwiseClone Method
TiffExportFilter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TiffExportFilter Class
TiffExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


TiffExportFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
TiffExportFilter Properties
TiffExportFilter Class See Also Send Feedback

The TiffExportFilter type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ImageResolution | Gets or sets resolution. (Inherited from BitmapImageExportFilter.)
MultiPage | Gets or sets value indicating that the dociment is exported to images by pages.
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

TiffExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


MultiPage Property

[image]

.NET ModelKit Suite ClassReference
TiffExportFilter..::.MultiPage Property
TiffExportFilter Class See Also Send Feedback
Gets or sets value indicating that the dociment is exported to images by pages.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool MultiPage { get; set; }
Visual Basic (Declaration)
Public Property MultiPage As Boolean
Visual C++
public:
property bool MultiPage {
    bool get ();
    void set (bool value);
}

See Also

TiffExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


TiffExportFilter Events

[image] [image]

.NET ModelKit Suite ClassReference
TiffExportFilter Events
TiffExportFilter Class See Also Send Feedback

The TiffExportFilter type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

TiffExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


TiffExportFilterFactory Class

[image]

.NET ModelKit Suite ClassReference
TiffExportFilterFactory Class
Members See Also Send Feedback
Provides creation of TiffExportFilter instances.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class TiffExportFilterFactory : ExportFilterFactory
Visual Basic (Declaration)
Public Class TiffExportFilterFactory _
    Inherits ExportFilterFactory
Visual C++
public ref class TiffExportFilterFactory : public ExportFilterFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export..::.ExportFilterFactory
PerpetuumSoft.Reporting.Export.Graph..::.TiffExportFilterFactory

See Also

TiffExportFilterFactory Members
PerpetuumSoft.Reporting.Export.Graph Namespace


TiffExportFilterFactory Members

[image] [image]

.NET ModelKit Suite ClassReference
TiffExportFilterFactory Members
TiffExportFilterFactory Class Methods Properties See Also Send Feedback

The TiffExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates a new instance of the TiffExportFilter class. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns the standard file extension for the associated Tiff export filter. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns the format name for the associated Tiff export filter. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Factory | Gets the default instance of the TiffFilterFactory class.

See Also

TiffExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


TiffExportFilterFactory Methods

[image] [image]

.NET ModelKit Suite ClassReference
TiffExportFilterFactory Methods
TiffExportFilterFactory Class See Also Send Feedback

The TiffExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates a new instance of the TiffExportFilter class. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns the standard file extension for the associated Tiff export filter. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns the format name for the associated Tiff export filter. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TiffExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


CreateFilter Method

[image]

.NET ModelKit Suite ClassReference
TiffExportFilterFactory..::.CreateFilter Method
TiffExportFilterFactory Class See Also Send Feedback
Creates a new instance of the TiffExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilter CreateFilter()
Visual Basic (Declaration)
Public Overrides Function CreateFilter As ExportFilter
Visual C++
public:
virtual ExportFilter^ CreateFilter() override

See Also

TiffExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GetFilterFileExtension Method

[image]

.NET ModelKit Suite ClassReference
TiffExportFilterFactory..::.GetFilterFileExtension Method
TiffExportFilterFactory Class See Also Send Feedback
Returns the standard file extension for the associated Tiff export filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFileExtension()
Visual Basic (Declaration)
Public Overrides Function GetFilterFileExtension As String
Visual C++
public:
virtual String^ GetFilterFileExtension() override

See Also

TiffExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


GetFilterFormat Method

[image]

.NET ModelKit Suite ClassReference
TiffExportFilterFactory..::.GetFilterFormat Method
TiffExportFilterFactory Class See Also Send Feedback
Returns the format name for the associated Tiff export filter.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFormat()
Visual Basic (Declaration)
Public Overrides Function GetFilterFormat As String
Visual C++
public:
virtual String^ GetFilterFormat() override

See Also

TiffExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


TiffExportFilterFactory Properties

[image] [image]

.NET ModelKit Suite ClassReference
TiffExportFilterFactory Properties
TiffExportFilterFactory Class See Also Send Feedback

The TiffExportFilterFactory type exposes the following members.

Properties

Name | Description
Factory | Gets the default instance of the TiffFilterFactory class.

See Also

TiffExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


Factory Property

[image]

.NET ModelKit Suite ClassReference
TiffExportFilterFactory..::.Factory Property
TiffExportFilterFactory Class See Also Send Feedback
Gets the default instance of the TiffFilterFactory class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static TiffExportFilterFactory Factory { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Factory As TiffExportFilterFactory
Visual C++
public:
static property TiffExportFilterFactory^ Factory {
    TiffExportFilterFactory^ get ();
}

See Also

TiffExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Graph Namespace


VectorImageExportFilter Class

[image]

.NET ModelKit Suite ClassReference
VectorImageExportFilter Class
Members See Also Send Feedback
Base class for all raster-image-based report export filters.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract class VectorImageExportFilter : ImageExportFilter
Visual Basic (Declaration)
Public MustInherit Class VectorImageExportFilter _
    Inherits ImageExportFilter
Visual C++
public ref class VectorImageExportFilter abstract : public ImageExportFilter

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Export..::.ExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.ImageExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.VectorImageExportFilter
PerpetuumSoft.Reporting.Export.Graph..::.EmfExportFilter

See Also

VectorImageExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


VectorImageExportFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
VectorImageExportFilter Members
VectorImageExportFilter Class Constructors Methods Properties Events See Also Send Feedback

The VectorImageExportFilter type exposes the following members.

Constructors

Name | Description
VectorImageExportFilter | Initializes a new instance of the VectorImageExportFilter class.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
ExportPage | Exports the specified page to the specified file. (Overrides ImageExportFilter..::.ExportPage(Page, String).)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns FilterFactory for the filter. (Inherited from ExportFilter.)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows export dialog. (Overrides ExportFilter..::.ShowDialog()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

VectorImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


VectorImageExportFilter Constructor

[image]

.NET ModelKit Suite ClassReference
VectorImageExportFilter Constructor
VectorImageExportFilter Class See Also Send Feedback
Initializes a new instance of the VectorImageExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public VectorImageExportFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VectorImageExportFilter()

See Also

VectorImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


VectorImageExportFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
VectorImageExportFilter Methods
VectorImageExportFilter Class See Also Send Feedback

The VectorImageExportFilter type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
ExportPage | Exports the specified page to the specified file. (Overrides ImageExportFilter..::.ExportPage(Page, String).)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetFactory | Returns FilterFactory for the filter. (Inherited from ExportFilter.)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows export dialog. (Overrides ExportFilter..::.ShowDialog()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

VectorImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
VectorImageExportFilter..::.Dispose Method
VectorImageExportFilter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

VectorImageExportFilter Class
VectorImageExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


Export Method

[image] [image]

.NET ModelKit Suite ClassReference
VectorImageExportFilter..::.Export Method
VectorImageExportFilter Class See Also Send Feedback

Overload List

Name | Description
Export(Document, Stream) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String, Boolean) | Exports the specified report document to the specified file and optionally shows export filter settings dialog. (Inherited from ExportFilter.)

See Also

VectorImageExportFilter Class
VectorImageExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ExportDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
VectorImageExportFilter..::.ExportDocument Method
VectorImageExportFilter Class See Also Send Feedback

Overload List

Name | Description
ExportDocument(Document, Stream) | Exports given document to the stream. (Inherited from ExportFilter.)
ExportDocument(Document, String) | Exports document to the specified file. (Inherited from ImageExportFilter.)

See Also

VectorImageExportFilter Class
VectorImageExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ExportPage Method

[image]

.NET ModelKit Suite ClassReference
VectorImageExportFilter..::.ExportPage Method
VectorImageExportFilter Class See Also Send Feedback
Exports the specified page to the specified file.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void ExportPage(
    Page page,
    string fileName
)
Visual Basic (Declaration)
Protected Overrides Sub ExportPage ( _
    page As Page, _
    fileName As String _
)
Visual C++
protected:
virtual void ExportPage(
    Page^ page,
    String^ fileName
) override

Parameters

page
Type: PerpetuumSoft.Reporting.DOM..::.Page
fileName
Type: System..::.String

See Also

VectorImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
VectorImageExportFilter..::.MemberwiseClone Method
VectorImageExportFilter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

VectorImageExportFilter Class
VectorImageExportFilter Members
PerpetuumSoft.Reporting.Export.Graph Namespace


ShowDialog Method

[image]

.NET ModelKit Suite ClassReference
VectorImageExportFilter..::.ShowDialog Method
VectorImageExportFilter Class See Also Send Feedback
Shows export dialog.

Namespace: PerpetuumSoft.Reporting.Export.Graph
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override DialogResult ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As DialogResult
Visual C++
public:
virtual DialogResult ShowDialog() override

See Also

VectorImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


VectorImageExportFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
VectorImageExportFilter Properties
VectorImageExportFilter Class See Also Send Feedback

The VectorImageExportFilter type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

VectorImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


VectorImageExportFilter Events

[image] [image]

.NET ModelKit Suite ClassReference
VectorImageExportFilter Events
VectorImageExportFilter Class See Also Send Feedback

The VectorImageExportFilter type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

VectorImageExportFilter Class
PerpetuumSoft.Reporting.Export.Graph Namespace


PerpetuumSoft.Reporting.Export.Html Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Export.Html Namespace
Send Feedback
The PerpetuumSoft.Reporting.Export.Html namespace contains classes which are used to export document to the HTML (HyperText Markup Language) format.

Classes

Class | Description
HtmlContext | Contains html exporting context.
HtmlExportFilter | Export Report Sharp-Shooter documents to html format.
HtmlExportFilterFactory | Creates HtmlExportFilter instaces.
HtmlTable | Represents HtmlTable.

Interfaces

Interface | Description
IHtmlContext | Defines general interface for the html export filter context.

Enumerations

Enumeration | Description
ExportMode | Enumerates export modes.
Formatting | Enumerate formtting modes.
ImagesFormat | Enumerates image format.
ResultType | Enumerates html generation modes.


ExportMode Enumeration

[image]

.NET ModelKit Suite ClassReference
ExportMode Enumeration
See Also Send Feedback
Enumerates export modes.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public enum ExportMode
Visual Basic (Declaration)
Public Enumeration ExportMode
Visual C++
public enum class ExportMode

Members

Member name | Description
Span | Each report control represented as separate SPAN tag with absolute position.
Table | Report represented as single table. Each report control converted to the table cell.
TablePerPage | Each report page represented as separate table. Each report control converted to the table cell.

See Also

PerpetuumSoft.Reporting.Export.Html Namespace


Formatting Enumeration

[image]

.NET ModelKit Suite ClassReference
Formatting Enumeration
See Also Send Feedback
Enumerate formtting modes.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public enum Formatting
Visual Basic (Declaration)
Public Enumeration Formatting
Visual C++
public enum class Formatting

Members

Member name | Description
Readable | Readable form of html with blanks and indents.
Compact | Compact form of html without blanks and indents.

See Also

PerpetuumSoft.Reporting.Export.Html Namespace


HtmlContext Class

[image]

.NET ModelKit Suite ClassReference
HtmlContext Class
Members See Also Send Feedback
Contains html exporting context.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public class HtmlContext : IHtmlContext
Visual Basic (Declaration)
Public Class HtmlContext _
    Implements IHtmlContext
Visual C++
public ref class HtmlContext : IHtmlContext

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Html..::.HtmlContext

See Also

HtmlContext Members
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlContext Members

[image] [image]

.NET ModelKit Suite ClassReference
HtmlContext Members
HtmlContext Class Constructors Methods Properties See Also Send Feedback

The HtmlContext type exposes the following members.

Constructors

Name | Description
HtmlContext | Overloaded.

Methods

Name | Description
AddImage | Adds image in to the image context and returns path to this image.
DecIndent | Decrements indent.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatUnits | Converts distance to its html representation.
GetBookmark | Returns bookmark for the specified control.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHyperlink | Returns hyperlink string to the specified control.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IncIndent | Increments indent.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScaleValue | Implements ScaleValue(Double).
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteLine | Writes line.

Properties

Name | Description
Filter | Gets HtmlExportFilter instance associated with this context.
Scale | Gets scale factor.
SupportImages | Gets if context support images.
Units | Gets used units.
Writer | Gets underlaying HtmlTextWriter instance.

See Also

HtmlContext Class
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlContext Constructor

[image] [image]

.NET ModelKit Suite ClassReference
HtmlContext Constructor
HtmlContext Class See Also Send Feedback

Overload List

Name | Description
HtmlContext(Stream, HtmlExportFilter) | Creates new instance of the HtmlContext class.
HtmlContext(TextWriter, HtmlExportFilter) | Creates new instance of the HtmlContext class.
HtmlContext(String, HtmlExportFilter) | Creates new instance of the HtmlContext class.

See Also

HtmlContext Class
HtmlContext Members
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlContext Constructor (Stream, HtmlExportFilter)

[image]

.NET ModelKit Suite ClassReference
HtmlContext Constructor (Stream, HtmlExportFilter)
HtmlContext Class See Also Send Feedback
Creates new instance of the HtmlContext class.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public HtmlContext(
    Stream stream,
    HtmlExportFilter filter
)
Visual Basic (Declaration)
Public Sub New ( _
    stream As Stream, _
    filter As HtmlExportFilter _
)
Visual C++
public:
HtmlContext(
    Stream^ stream,
    HtmlExportFilter^ filter
)

Parameters

stream
Type: System.IO..::.Stream
filter
Type: PerpetuumSoft.Reporting.Export.Html..::.HtmlExportFilter

See Also

HtmlContext Class
HtmlContext Overload
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlContext Constructor (TextWriter, HtmlExportFilter)

[image]

.NET ModelKit Suite ClassReference
HtmlContext Constructor (TextWriter, HtmlExportFilter)
HtmlContext Class See Also Send Feedback
Creates new instance of the HtmlContext class.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public HtmlContext(
    TextWriter writer,
    HtmlExportFilter filter
)
Visual Basic (Declaration)
Public Sub New ( _
    writer As TextWriter, _
    filter As HtmlExportFilter _
)
Visual C++
public:
HtmlContext(
    TextWriter^ writer,
    HtmlExportFilter^ filter
)

Parameters

writer
Type: System.IO..::.TextWriter
filter
Type: PerpetuumSoft.Reporting.Export.Html..::.HtmlExportFilter

See Also

HtmlContext Class
HtmlContext Overload
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlContext Constructor (String, HtmlExportFilter)

[image]

.NET ModelKit Suite ClassReference
HtmlContext Constructor (String, HtmlExportFilter)
HtmlContext Class See Also Send Feedback
Creates new instance of the HtmlContext class.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public HtmlContext(
    string fileName,
    HtmlExportFilter filter
)
Visual Basic (Declaration)
Public Sub New ( _
    fileName As String, _
    filter As HtmlExportFilter _
)
Visual C++
public:
HtmlContext(
    String^ fileName,
    HtmlExportFilter^ filter
)

Parameters

fileName
Type: System..::.String
filter
Type: PerpetuumSoft.Reporting.Export.Html..::.HtmlExportFilter

See Also

HtmlContext Class
HtmlContext Overload
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlContext Methods

[image] [image]

.NET ModelKit Suite ClassReference
HtmlContext Methods
HtmlContext Class See Also Send Feedback

The HtmlContext type exposes the following members.

Methods

Name | Description
AddImage | Adds image in to the image context and returns path to this image.
DecIndent | Decrements indent.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatUnits | Converts distance to its html representation.
GetBookmark | Returns bookmark for the specified control.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHyperlink | Returns hyperlink string to the specified control.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IncIndent | Increments indent.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ScaleValue | Implements ScaleValue(Double).
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteLine | Writes line.

See Also

HtmlContext Class
PerpetuumSoft.Reporting.Export.Html Namespace


AddImage Method

[image]

.NET ModelKit Suite ClassReference
HtmlContext..::.AddImage Method
HtmlContext Class See Also Send Feedback
Adds image in to the image context and returns path to this image.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public string AddImage(
    Bitmap bitmap
)
Visual Basic (Declaration)
Public Function AddImage ( _
    bitmap As Bitmap _
) As String
Visual C++
public:
virtual String^ AddImage(
    Bitmap^ bitmap
) sealed

Parameters

bitmap
Type: System.Drawing..::.Bitmap

Implements

IHtmlContext..::.AddImage(Bitmap)

See Also

HtmlContext Class
PerpetuumSoft.Reporting.Export.Html Namespace


DecIndent Method

[image]

.NET ModelKit Suite ClassReference
HtmlContext..::.DecIndent Method
HtmlContext Class See Also Send Feedback
Decrements indent.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public void DecIndent()
Visual Basic (Declaration)
Public Sub DecIndent
Visual C++
public:
virtual void DecIndent() sealed

Implements

IHtmlContext..::.DecIndent()()()

See Also

HtmlContext Class
PerpetuumSoft.Reporting.Export.Html Namespace


FormatUnits Method

[image]

.NET ModelKit Suite ClassReference
HtmlContext..::.FormatUnits Method
HtmlContext Class See Also Send Feedback
Converts distance to its html representation.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public string FormatUnits(
    double value
)
Visual Basic (Declaration)
Public Function FormatUnits ( _
    value As Double _
) As String
Visual C++
public:
virtual String^ FormatUnits(
    double value
) sealed

Parameters

value
Type: System..::.Double

Implements

IHtmlContext..::.FormatUnits(Double)

See Also

HtmlContext Class
PerpetuumSoft.Reporting.Export.Html Namespace


GetBookmark Method

[image]

.NET ModelKit Suite ClassReference
HtmlContext..::.GetBookmark Method
HtmlContext Class See Also Send Feedback
Returns bookmark for the specified control.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public string GetBookmark(
    ReportControl control
)
Visual Basic (Declaration)
Public Function GetBookmark ( _
    control As ReportControl _
) As String
Visual C++
public:
virtual String^ GetBookmark(
    ReportControl^ control
) sealed

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

Implements

IHtmlContext..::.GetBookmark(ReportControl)

See Also

HtmlContext Class
PerpetuumSoft.Reporting.Export.Html Namespace


GetHyperlink Method

[image]

.NET ModelKit Suite ClassReference
HtmlContext..::.GetHyperlink Method
HtmlContext Class See Also Send Feedback
Returns hyperlink string to the specified control.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public string GetHyperlink(
    ReportControl control
)
Visual Basic (Declaration)
Public Function GetHyperlink ( _
    control As ReportControl _
) As String
Visual C++
public:
virtual String^ GetHyperlink(
    ReportControl^ control
) sealed

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

Implements

IHtmlContext..::.GetHyperlink(ReportControl)

See Also

HtmlContext Class
PerpetuumSoft.Reporting.Export.Html Namespace


IncIndent Method

[image]

.NET ModelKit Suite ClassReference
HtmlContext..::.IncIndent Method
HtmlContext Class See Also Send Feedback
Increments indent.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public void IncIndent()
Visual Basic (Declaration)
Public Sub IncIndent
Visual C++
public:
virtual void IncIndent() sealed

Implements

IHtmlContext..::.IncIndent()()()

See Also

HtmlContext Class
PerpetuumSoft.Reporting.Export.Html Namespace


ScaleValue Method

[image]

.NET ModelKit Suite ClassReference
HtmlContext..::.ScaleValue Method
HtmlContext Class See Also Send Feedback
Implements ScaleValue(Double).

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public double ScaleValue(
    double value
)
Visual Basic (Declaration)
Public Function ScaleValue ( _
    value As Double _
) As Double
Visual C++
public:
virtual double ScaleValue(
    double value
) sealed

Parameters

value
Type: System..::.Double

Implements

IHtmlContext..::.ScaleValue(Double)

See Also

HtmlContext Class
PerpetuumSoft.Reporting.Export.Html Namespace


WriteLine Method

[image]

.NET ModelKit Suite ClassReference
HtmlContext..::.WriteLine Method
HtmlContext Class See Also Send Feedback
Writes line.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public void WriteLine()
Visual Basic (Declaration)
Public Sub WriteLine
Visual C++
public:
virtual void WriteLine() sealed

Implements

IHtmlContext..::.WriteLine()()()

See Also

HtmlContext Class
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlContext Properties

[image] [image]

.NET ModelKit Suite ClassReference
HtmlContext Properties
HtmlContext Class See Also Send Feedback

The HtmlContext type exposes the following members.

Properties

Name | Description
Filter | Gets HtmlExportFilter instance associated with this context.
Scale | Gets scale factor.
SupportImages | Gets if context support images.
Units | Gets used units.
Writer | Gets underlaying HtmlTextWriter instance.

See Also

HtmlContext Class
PerpetuumSoft.Reporting.Export.Html Namespace


Filter Property

[image]

.NET ModelKit Suite ClassReference
HtmlContext..::.Filter Property
HtmlContext Class See Also Send Feedback
Gets HtmlExportFilter instance associated with this context.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public HtmlExportFilter Filter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filter As HtmlExportFilter
Visual C++
public:
virtual property HtmlExportFilter^ Filter {
    HtmlExportFilter^ get () sealed;
}

Implements

IHtmlContext..::.Filter

See Also

HtmlContext Class
PerpetuumSoft.Reporting.Export.Html Namespace


Scale Property

[image]

.NET ModelKit Suite ClassReference
HtmlContext..::.Scale Property
HtmlContext Class See Also Send Feedback
Gets scale factor.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public double Scale { get; }
Visual Basic (Declaration)
Public ReadOnly Property Scale As Double
Visual C++
public:
virtual property double Scale {
    double get () sealed;
}

Implements

IHtmlContext..::.Scale

See Also

HtmlContext Class
PerpetuumSoft.Reporting.Export.Html Namespace


SupportImages Property

[image]

.NET ModelKit Suite ClassReference
HtmlContext..::.SupportImages Property
HtmlContext Class See Also Send Feedback
Gets if context support images.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public bool SupportImages { get; }
Visual Basic (Declaration)
Public ReadOnly Property SupportImages As Boolean
Visual C++
public:
virtual property bool SupportImages {
    bool get () sealed;
}

Implements

IHtmlContext..::.SupportImages

See Also

HtmlContext Class
PerpetuumSoft.Reporting.Export.Html Namespace


Units Property

[image]

.NET ModelKit Suite ClassReference
HtmlContext..::.Units Property
HtmlContext Class See Also Send Feedback
Gets used units.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public string Units { get; }
Visual Basic (Declaration)
Public ReadOnly Property Units As String
Visual C++
public:
virtual property String^ Units {
    String^ get () sealed;
}

Implements

IHtmlContext..::.Units

See Also

HtmlContext Class
PerpetuumSoft.Reporting.Export.Html Namespace


Writer Property

[image]

.NET ModelKit Suite ClassReference
HtmlContext..::.Writer Property
HtmlContext Class See Also Send Feedback
Gets underlaying HtmlTextWriter instance.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public HtmlTextWriter Writer { get; }
Visual Basic (Declaration)
Public ReadOnly Property Writer As HtmlTextWriter
Visual C++
public:
virtual property HtmlTextWriter^ Writer {
    HtmlTextWriter^ get () sealed;
}

Implements

IHtmlContext..::.Writer

See Also

HtmlContext Class
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlExportFilter Class

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter Class
Members See Also Send Feedback
Export Report Sharp-Shooter documents to html format.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public class HtmlExportFilter : ExportFilter
Visual Basic (Declaration)
Public Class HtmlExportFilter _
    Inherits ExportFilter
Visual C++
public ref class HtmlExportFilter : public ExportFilter

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Export..::.ExportFilter
PerpetuumSoft.Reporting.Export.Html..::.HtmlExportFilter

See Also

HtmlExportFilter Members
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlExportFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
HtmlExportFilter Members
HtmlExportFilter Class Constructors Methods Properties Events See Also Send Feedback

The HtmlExportFilter type exposes the following members.

Constructors

Name | Description
HtmlExportFilter | Overloaded.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindAdapter | Returns HtmlAdapter instance corresponding to the given control type.
GetFactory | Returns html export filters factory. (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
RegisterAdapter | Registers a new adapter.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows dialog with Export Filter settings. (Overrides ExportFilter..::.ShowDialog()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
Accuracy | Gets and sets filter accuracy.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExportMode | Gets and sets export mode.
Formatting | Gets and sets formatting mode.
IgnoreBorders | Gets ans sets whether information about borders should be excluded from html file.
IgnoreFills | Gets ans sets whether information about fills should be excluded from html file.
IgnoreFonts | Gets ans sets whether information about fonts should be excluded from html file.
IgnoreTextAlignment | Gets ans sets whether information about text alignment should be exluded from html file.
ImagesFormat | Gets and sets images format.
ImagesResolution | Gets and sets images resolution in dpi.
InsertHyperLinks | Gets and sets if hyperlinks will be exported.
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
PreserveBlankCells | Gets and sets whether blank rows and columns will be included in result html file.
PreserveLineBreaks | Gets and sets whether line breaks will be included in result html file as BR tag.
PreserveOriginalSizes | Gets and sets whether filter should try to keep all controls sizes.
ReplaceWhiteSpaceWithNBSP | Gets and sets whether blanks will be replaced with nbsp.
ResultType | Gets ans sets export result type.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
TextObjectOnly | Gets and sets whether only text content of report will be exported.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlExportFilter Constructor

[image] [image]

.NET ModelKit Suite ClassReference
HtmlExportFilter Constructor
HtmlExportFilter Class See Also Send Feedback

Overload List

Name | Description
HtmlExportFilter()()() | Creates new instance of the HtmlExportFilter class.
HtmlExportFilter(IContainer) | Creates new instance of the HtmlExportFilter class.

See Also

HtmlExportFilter Class
HtmlExportFilter Members
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlExportFilter Constructor

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter Constructor
HtmlExportFilter Class See Also Send Feedback
Creates new instance of the HtmlExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public HtmlExportFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HtmlExportFilter()

See Also

HtmlExportFilter Class
HtmlExportFilter Overload
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlExportFilter Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter Constructor (IContainer)
HtmlExportFilter Class See Also Send Feedback
Creates new instance of the HtmlExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public HtmlExportFilter(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
HtmlExportFilter(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

HtmlExportFilter Class
HtmlExportFilter Overload
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlExportFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
HtmlExportFilter Methods
HtmlExportFilter Class See Also Send Feedback

The HtmlExportFilter type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindAdapter | Returns HtmlAdapter instance corresponding to the given control type.
GetFactory | Returns html export filters factory. (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
RegisterAdapter | Registers a new adapter.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Shows dialog with Export Filter settings. (Overrides ExportFilter..::.ShowDialog()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.Dispose Method
HtmlExportFilter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

HtmlExportFilter Class
HtmlExportFilter Members
PerpetuumSoft.Reporting.Export.Html Namespace


Export Method

[image] [image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.Export Method
HtmlExportFilter Class See Also Send Feedback

Overload List

Name | Description
Export(Document, Stream) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, IHtmlContext) | Exports given document.
Export(Document, String, Boolean) | Exports the specified report document to the specified file and optionally shows export filter settings dialog. (Inherited from ExportFilter.)

See Also

HtmlExportFilter Class
HtmlExportFilter Members
PerpetuumSoft.Reporting.Export.Html Namespace


Export Method (Document, IHtmlContext)

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.Export Method (Document, IHtmlContext)
HtmlExportFilter Class See Also Send Feedback
Exports given document.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public void Export(
    Document document,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Sub Export ( _
    document As Document, _
    context As IHtmlContext _
)
Visual C++
public:
void Export(
    Document^ document,
    IHtmlContext^ context
)

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

HtmlExportFilter Class
Export Overload
PerpetuumSoft.Reporting.Export.Html Namespace


ExportDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.ExportDocument Method
HtmlExportFilter Class See Also Send Feedback

Overload List

Name | Description
ExportDocument(Document, Stream) | Exports given document to the specified stream. (Overrides ExportFilter..::.ExportDocument(Document, Stream).)
ExportDocument(Document, String) | Exports given document to the specified file. (Overrides ExportFilter..::.ExportDocument(Document, String).)

See Also

HtmlExportFilter Class
HtmlExportFilter Members
PerpetuumSoft.Reporting.Export.Html Namespace


ExportDocument Method (Document, Stream)

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.ExportDocument Method (Document, Stream)
HtmlExportFilter Class See Also Send Feedback
Exports given document to the specified stream.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
protected override void ExportDocument(
    Document document,
    Stream stream
)
Visual Basic (Declaration)
Protected Overrides Sub ExportDocument ( _
    document As Document, _
    stream As Stream _
)
Visual C++
protected:
virtual void ExportDocument(
    Document^ document,
    Stream^ stream
) override

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
stream
Type: System.IO..::.Stream

See Also

HtmlExportFilter Class
ExportDocument Overload
PerpetuumSoft.Reporting.Export.Html Namespace


ExportDocument Method (Document, String)

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.ExportDocument Method (Document, String)
HtmlExportFilter Class See Also Send Feedback
Exports given document to the specified file.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
protected override void ExportDocument(
    Document document,
    string fileName
)
Visual Basic (Declaration)
Protected Overrides Sub ExportDocument ( _
    document As Document, _
    fileName As String _
)
Visual C++
protected:
virtual void ExportDocument(
    Document^ document,
    String^ fileName
) override

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
fileName
Type: System..::.String

See Also

HtmlExportFilter Class
ExportDocument Overload
PerpetuumSoft.Reporting.Export.Html Namespace


FindAdapter Method

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.FindAdapter Method
HtmlExportFilter Class See Also Send Feedback
Returns HtmlAdapter instance corresponding to the given control type.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public HtmlAdapter FindAdapter(
    Type type
)
Visual Basic (Declaration)
Public Function FindAdapter ( _
    type As Type _
) As HtmlAdapter
Visual C++
public:
HtmlAdapter^ FindAdapter(
    Type^ type
)

Parameters

type
Type: System..::.Type

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


GetFactory Method

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.GetFactory Method
HtmlExportFilter Class See Also Send Feedback
Returns html export filters factory.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilterFactory GetFactory()
Visual Basic (Declaration)
Public Overrides Function GetFactory As ExportFilterFactory
Visual C++
public:
virtual ExportFilterFactory^ GetFactory() override

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.MemberwiseClone Method
HtmlExportFilter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

HtmlExportFilter Class
HtmlExportFilter Members
PerpetuumSoft.Reporting.Export.Html Namespace


RegisterAdapter Method

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.RegisterAdapter Method
HtmlExportFilter Class See Also Send Feedback
Registers a new adapter.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public static void RegisterAdapter(
    Type controlType,
    Type adapterType
)
Visual Basic (Declaration)
Public Shared Sub RegisterAdapter ( _
    controlType As Type, _
    adapterType As Type _
)
Visual C++
public:
static void RegisterAdapter(
    Type^ controlType,
    Type^ adapterType
)

Parameters

controlType
Type: System..::.Type
adapterType
Type: System..::.Type

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


ShowDialog Method

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.ShowDialog Method
HtmlExportFilter Class See Also Send Feedback
Shows dialog with Export Filter settings.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override DialogResult ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As DialogResult
Visual C++
public:
virtual DialogResult ShowDialog() override

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlExportFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
HtmlExportFilter Properties
HtmlExportFilter Class See Also Send Feedback

The HtmlExportFilter type exposes the following members.

Properties

Name | Description
Accuracy | Gets and sets filter accuracy.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ExportMode | Gets and sets export mode.
Formatting | Gets and sets formatting mode.
IgnoreBorders | Gets ans sets whether information about borders should be excluded from html file.
IgnoreFills | Gets ans sets whether information about fills should be excluded from html file.
IgnoreFonts | Gets ans sets whether information about fonts should be excluded from html file.
IgnoreTextAlignment | Gets ans sets whether information about text alignment should be exluded from html file.
ImagesFormat | Gets and sets images format.
ImagesResolution | Gets and sets images resolution in dpi.
InsertHyperLinks | Gets and sets if hyperlinks will be exported.
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
PreserveBlankCells | Gets and sets whether blank rows and columns will be included in result html file.
PreserveLineBreaks | Gets and sets whether line breaks will be included in result html file as BR tag.
PreserveOriginalSizes | Gets and sets whether filter should try to keep all controls sizes.
ReplaceWhiteSpaceWithNBSP | Gets and sets whether blanks will be replaced with nbsp.
ResultType | Gets ans sets export result type.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
TextObjectOnly | Gets and sets whether only text content of report will be exported.

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


Accuracy Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.Accuracy Property
HtmlExportFilter Class See Also Send Feedback
Gets and sets filter accuracy.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public int Accuracy { get; set; }
Visual Basic (Declaration)
Public Property Accuracy As Integer
Visual C++
public:
property int Accuracy {
    int get ();
    void set (int value);
}

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


ExportMode Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.ExportMode Property
HtmlExportFilter Class See Also Send Feedback
Gets and sets export mode.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public ExportMode ExportMode { get; set; }
Visual Basic (Declaration)
Public Property ExportMode As ExportMode
Visual C++
public:
property ExportMode ExportMode {
    ExportMode get ();
    void set (ExportMode value);
}

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


Formatting Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.Formatting Property
HtmlExportFilter Class See Also Send Feedback
Gets and sets formatting mode.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public Formatting Formatting { get; set; }
Visual Basic (Declaration)
Public Property Formatting As Formatting
Visual C++
public:
property Formatting Formatting {
    Formatting get ();
    void set (Formatting value);
}

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


IgnoreBorders Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.IgnoreBorders Property
HtmlExportFilter Class See Also Send Feedback
Gets ans sets whether information about borders should be excluded from html file.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public bool IgnoreBorders { get; set; }
Visual Basic (Declaration)
Public Property IgnoreBorders As Boolean
Visual C++
public:
property bool IgnoreBorders {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


IgnoreFills Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.IgnoreFills Property
HtmlExportFilter Class See Also Send Feedback
Gets ans sets whether information about fills should be excluded from html file.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public bool IgnoreFills { get; set; }
Visual Basic (Declaration)
Public Property IgnoreFills As Boolean
Visual C++
public:
property bool IgnoreFills {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


IgnoreFonts Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.IgnoreFonts Property
HtmlExportFilter Class See Also Send Feedback
Gets ans sets whether information about fonts should be excluded from html file.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public bool IgnoreFonts { get; set; }
Visual Basic (Declaration)
Public Property IgnoreFonts As Boolean
Visual C++
public:
property bool IgnoreFonts {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


IgnoreTextAlignment Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.IgnoreTextAlignment Property
HtmlExportFilter Class See Also Send Feedback
Gets ans sets whether information about text alignment should be exluded from html file.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public bool IgnoreTextAlignment { get; set; }
Visual Basic (Declaration)
Public Property IgnoreTextAlignment As Boolean
Visual C++
public:
property bool IgnoreTextAlignment {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


ImagesFormat Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.ImagesFormat Property
HtmlExportFilter Class See Also Send Feedback
Gets and sets images format.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public ImagesFormat ImagesFormat { get; set; }
Visual Basic (Declaration)
Public Property ImagesFormat As ImagesFormat
Visual C++
public:
property ImagesFormat ImagesFormat {
    ImagesFormat get ();
    void set (ImagesFormat value);
}

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


ImagesResolution Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.ImagesResolution Property
HtmlExportFilter Class See Also Send Feedback
Gets and sets images resolution in dpi.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public int ImagesResolution { get; set; }
Visual Basic (Declaration)
Public Property ImagesResolution As Integer
Visual C++
public:
property int ImagesResolution {
    int get ();
    void set (int value);
}

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


InsertHyperLinks Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.InsertHyperLinks Property
HtmlExportFilter Class See Also Send Feedback
Gets and sets if hyperlinks will be exported.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public bool InsertHyperLinks { get; set; }
Visual Basic (Declaration)
Public Property InsertHyperLinks As Boolean
Visual C++
public:
property bool InsertHyperLinks {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


PreserveBlankCells Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.PreserveBlankCells Property
HtmlExportFilter Class See Also Send Feedback
Gets and sets whether blank rows and columns will be included in result html file.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public bool PreserveBlankCells { get; set; }
Visual Basic (Declaration)
Public Property PreserveBlankCells As Boolean
Visual C++
public:
property bool PreserveBlankCells {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


PreserveLineBreaks Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.PreserveLineBreaks Property
HtmlExportFilter Class See Also Send Feedback
Gets and sets whether line breaks will be included in result html file as BR tag.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public bool PreserveLineBreaks { get; set; }
Visual Basic (Declaration)
Public Property PreserveLineBreaks As Boolean
Visual C++
public:
property bool PreserveLineBreaks {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


PreserveOriginalSizes Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.PreserveOriginalSizes Property
HtmlExportFilter Class See Also Send Feedback
Gets and sets whether filter should try to keep all controls sizes.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public bool PreserveOriginalSizes { get; set; }
Visual Basic (Declaration)
Public Property PreserveOriginalSizes As Boolean
Visual C++
public:
property bool PreserveOriginalSizes {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


ReplaceWhiteSpaceWithNBSP Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.ReplaceWhiteSpaceWithNBSP Property
HtmlExportFilter Class See Also Send Feedback
Gets and sets whether blanks will be replaced with nbsp.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public bool ReplaceWhiteSpaceWithNBSP { get; set; }
Visual Basic (Declaration)
Public Property ReplaceWhiteSpaceWithNBSP As Boolean
Visual C++
public:
property bool ReplaceWhiteSpaceWithNBSP {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


ResultType Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.ResultType Property
HtmlExportFilter Class See Also Send Feedback
Gets ans sets export result type.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public ResultType ResultType { get; set; }
Visual Basic (Declaration)
Public Property ResultType As ResultType
Visual C++
public:
property ResultType ResultType {
    ResultType get ();
    void set (ResultType value);
}

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


TextObjectOnly Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilter..::.TextObjectOnly Property
HtmlExportFilter Class See Also Send Feedback
Gets and sets whether only text content of report will be exported.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public bool TextObjectOnly { get; set; }
Visual Basic (Declaration)
Public Property TextObjectOnly As Boolean
Visual C++
public:
property bool TextObjectOnly {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlExportFilter Events

[image] [image]

.NET ModelKit Suite ClassReference
HtmlExportFilter Events
HtmlExportFilter Class See Also Send Feedback

The HtmlExportFilter type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

HtmlExportFilter Class
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlExportFilterFactory Class

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilterFactory Class
Members See Also Send Feedback
Creates HtmlExportFilter instaces.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public class HtmlExportFilterFactory : ExportFilterFactory
Visual Basic (Declaration)
Public Class HtmlExportFilterFactory _
    Inherits ExportFilterFactory
Visual C++
public ref class HtmlExportFilterFactory : public ExportFilterFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export..::.ExportFilterFactory
PerpetuumSoft.Reporting.Export.Html..::.HtmlExportFilterFactory

See Also

HtmlExportFilterFactory Members
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlExportFilterFactory Members

[image] [image]

.NET ModelKit Suite ClassReference
HtmlExportFilterFactory Members
HtmlExportFilterFactory Class Methods Properties See Also Send Feedback

The HtmlExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates new instance of the export filter. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns default file extension. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns filter format name. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns filter name. (Overrides ExportFilterFactory..::.GetFilterName()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Factory | Gets default instance of the HtmlExportFilterFactory class.

See Also

HtmlExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlExportFilterFactory Methods

[image] [image]

.NET ModelKit Suite ClassReference
HtmlExportFilterFactory Methods
HtmlExportFilterFactory Class See Also Send Feedback

The HtmlExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Creates new instance of the export filter. (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Returns default file extension. (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Returns filter format name. (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns filter name. (Overrides ExportFilterFactory..::.GetFilterName()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HtmlExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Html Namespace


CreateFilter Method

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilterFactory..::.CreateFilter Method
HtmlExportFilterFactory Class See Also Send Feedback
Creates new instance of the export filter.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilter CreateFilter()
Visual Basic (Declaration)
Public Overrides Function CreateFilter As ExportFilter
Visual C++
public:
virtual ExportFilter^ CreateFilter() override

See Also

HtmlExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Html Namespace


GetFilterFileExtension Method

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilterFactory..::.GetFilterFileExtension Method
HtmlExportFilterFactory Class See Also Send Feedback
Returns default file extension.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFileExtension()
Visual Basic (Declaration)
Public Overrides Function GetFilterFileExtension As String
Visual C++
public:
virtual String^ GetFilterFileExtension() override

See Also

HtmlExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Html Namespace


GetFilterFormat Method

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilterFactory..::.GetFilterFormat Method
HtmlExportFilterFactory Class See Also Send Feedback
Returns filter format name.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFormat()
Visual Basic (Declaration)
Public Overrides Function GetFilterFormat As String
Visual C++
public:
virtual String^ GetFilterFormat() override

See Also

HtmlExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Html Namespace


GetFilterName Method

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilterFactory..::.GetFilterName Method
HtmlExportFilterFactory Class See Also Send Feedback
Returns filter name.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterName()
Visual Basic (Declaration)
Public Overrides Function GetFilterName As String
Visual C++
public:
virtual String^ GetFilterName() override

See Also

HtmlExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlExportFilterFactory Properties

[image] [image]

.NET ModelKit Suite ClassReference
HtmlExportFilterFactory Properties
HtmlExportFilterFactory Class See Also Send Feedback

The HtmlExportFilterFactory type exposes the following members.

Properties

Name | Description
Factory | Gets default instance of the HtmlExportFilterFactory class.

See Also

HtmlExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Html Namespace


Factory Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportFilterFactory..::.Factory Property
HtmlExportFilterFactory Class See Also Send Feedback
Gets default instance of the HtmlExportFilterFactory class.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public static HtmlExportFilterFactory Factory { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Factory As HtmlExportFilterFactory
Visual C++
public:
static property HtmlExportFilterFactory^ Factory {
    HtmlExportFilterFactory^ get ();
}

See Also

HtmlExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlTable Class

[image]

.NET ModelKit Suite ClassReference
HtmlTable Class
Members See Also Send Feedback
Represents HtmlTable.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public class HtmlTable
Visual Basic (Declaration)
Public Class HtmlTable
Visual C++
public ref class HtmlTable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Html..::.HtmlTable

See Also

HtmlTable Members
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlTable Members

[image] [image]

.NET ModelKit Suite ClassReference
HtmlTable Members
HtmlTable Class Constructors Methods Properties See Also Send Feedback

The HtmlTable type exposes the following members.

Constructors

Name | Description
HtmlTable | Creates new instance of the HtmlTable class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overloaded.
Save | Writes table to the given context.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PageCollection | Gets the collection of pages.
Tracer | Gets TableTracer instance associated with this table.

See Also

HtmlTable Class
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlTable Constructor

[image]

.NET ModelKit Suite ClassReference
HtmlTable Constructor
HtmlTable Class See Also Send Feedback
Creates new instance of the HtmlTable class.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public HtmlTable(
    string title
)
Visual Basic (Declaration)
Public Sub New ( _
    title As String _
)
Visual C++
public:
HtmlTable(
    String^ title
)

Parameters

title
Type: System..::.String

See Also

HtmlTable Class
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlTable Methods

[image] [image]

.NET ModelKit Suite ClassReference
HtmlTable Methods
HtmlTable Class See Also Send Feedback

The HtmlTable type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overloaded.
Save | Writes table to the given context.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HtmlTable Class
PerpetuumSoft.Reporting.Export.Html Namespace


Render Method

[image] [image]

.NET ModelKit Suite ClassReference
HtmlTable..::.Render Method
HtmlTable Class See Also Send Feedback

Overload List

Name | Description
Render(Page, SupportControlCallback) | Calculates table contents.
Render(PageCollection, SupportControlCallback) | Calculates table contents.
Render(Page, SupportControlCallback, RenderControlCallback) | Calculates table contents.
Render(PageCollection, SupportControlCallback, RenderControlCallback) | Calculates table contents.

See Also

HtmlTable Class
HtmlTable Members
PerpetuumSoft.Reporting.Export.Html Namespace


Render Method (Page, .)

[image]

.NET ModelKit Suite ClassReference
HtmlTable..::.Render Method (Page, ..::.)
HtmlTable Class See Also Send Feedback
Calculates table contents.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public void Render(
    Page page,
    SupportControlCallback callback
)
Visual Basic (Declaration)
Public Sub Render ( _
    page As Page, _
    callback As SupportControlCallback _
)
Visual C++
public:
void Render(
    Page^ page,
    SupportControlCallback^ callback
)

Parameters

page
Type: PerpetuumSoft.Reporting.DOM..::.Page
callback
Type: SupportControlCallback

See Also

HtmlTable Class
Render Overload
PerpetuumSoft.Reporting.Export.Html Namespace


Render Method (PageCollection, .)

[image]

.NET ModelKit Suite ClassReference
HtmlTable..::.Render Method (PageCollection, ..::.)
HtmlTable Class See Also Send Feedback
Calculates table contents.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public void Render(
    PageCollection pages,
    SupportControlCallback callback
)
Visual Basic (Declaration)
Public Sub Render ( _
    pages As PageCollection, _
    callback As SupportControlCallback _
)
Visual C++
public:
void Render(
    PageCollection^ pages,
    SupportControlCallback^ callback
)

Parameters

pages
Type: PerpetuumSoft.Reporting.DOM..::.PageCollection
callback
Type: SupportControlCallback

See Also

HtmlTable Class
Render Overload
PerpetuumSoft.Reporting.Export.Html Namespace


Render Method (Page, ., .)

[image]

.NET ModelKit Suite ClassReference
HtmlTable..::.Render Method (Page, ..::., ..::.)
HtmlTable Class See Also Send Feedback
Calculates table contents.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public void Render(
    Page page,
    SupportControlCallback callback,
    RenderControlCallback renderControl
)
Visual Basic (Declaration)
Public Sub Render ( _
    page As Page, _
    callback As SupportControlCallback, _
    renderControl As RenderControlCallback _
)
Visual C++
public:
void Render(
    Page^ page,
    SupportControlCallback^ callback,
    RenderControlCallback^ renderControl
)

Parameters

page
Type: PerpetuumSoft.Reporting.DOM..::.Page
callback
Type: SupportControlCallback
renderControl
Type: RenderControlCallback

See Also

HtmlTable Class
Render Overload
PerpetuumSoft.Reporting.Export.Html Namespace


Render Method (PageCollection, ., .)

[image]

.NET ModelKit Suite ClassReference
HtmlTable..::.Render Method (PageCollection, ..::., ..::.)
HtmlTable Class See Also Send Feedback
Calculates table contents.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public void Render(
    PageCollection pages,
    SupportControlCallback callback,
    RenderControlCallback renderControl
)
Visual Basic (Declaration)
Public Sub Render ( _
    pages As PageCollection, _
    callback As SupportControlCallback, _
    renderControl As RenderControlCallback _
)
Visual C++
public:
void Render(
    PageCollection^ pages,
    SupportControlCallback^ callback,
    RenderControlCallback^ renderControl
)

Parameters

pages
Type: PerpetuumSoft.Reporting.DOM..::.PageCollection
callback
Type: SupportControlCallback
renderControl
Type: RenderControlCallback

See Also

HtmlTable Class
Render Overload
PerpetuumSoft.Reporting.Export.Html Namespace


Save Method

[image]

.NET ModelKit Suite ClassReference
HtmlTable..::.Save Method
HtmlTable Class See Also Send Feedback
Writes table to the given context.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public void Save(
    IHtmlContext context
)
Visual Basic (Declaration)
Public Sub Save ( _
    context As IHtmlContext _
)
Visual C++
public:
void Save(
    IHtmlContext^ context
)

Parameters

context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

HtmlTable Class
PerpetuumSoft.Reporting.Export.Html Namespace


HtmlTable Properties

[image] [image]

.NET ModelKit Suite ClassReference
HtmlTable Properties
HtmlTable Class See Also Send Feedback

The HtmlTable type exposes the following members.

Properties

Name | Description
PageCollection | Gets the collection of pages.
Tracer | Gets TableTracer instance associated with this table.

See Also

HtmlTable Class
PerpetuumSoft.Reporting.Export.Html Namespace


PageCollection Property

[image]

.NET ModelKit Suite ClassReference
HtmlTable..::.PageCollection Property
HtmlTable Class See Also Send Feedback
Gets the collection of pages.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public PageCollection PageCollection { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageCollection As PageCollection
Visual C++
public:
property PageCollection^ PageCollection {
    PageCollection^ get ();
}

See Also

HtmlTable Class
PerpetuumSoft.Reporting.Export.Html Namespace


Tracer Property

[image]

.NET ModelKit Suite ClassReference
HtmlTable..::.Tracer Property
HtmlTable Class See Also Send Feedback
Gets TableTracer instance associated with this table.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public TableTracer Tracer { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tracer As TableTracer
Visual C++
public:
property TableTracer^ Tracer {
    TableTracer^ get ();
}

See Also

HtmlTable Class
PerpetuumSoft.Reporting.Export.Html Namespace


IHtmlContext Interface

[image]

.NET ModelKit Suite ClassReference
IHtmlContext Interface
Members See Also Send Feedback
Defines general interface for the html export filter context.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public interface IHtmlContext
Visual Basic (Declaration)
Public Interface IHtmlContext
Visual C++
public interface class IHtmlContext

See Also

IHtmlContext Members
PerpetuumSoft.Reporting.Export.Html Namespace


IHtmlContext Members

[image] [image]

.NET ModelKit Suite ClassReference
IHtmlContext Members
IHtmlContext Interface Methods Properties See Also Send Feedback

The IHtmlContext type exposes the following members.

Methods

Name | Description
AddImage | Adds image and returns image url.
DecIndent | Decrements indent.
FormatUnits | Converts distance to its html representation.
GetBookmark | Returns bookmark for the given control.
GetHyperlink | Returns hyperlink for the given control.
IncIndent | Increments indent.
ScaleValue | Converts distance to its html representation.
WriteLine | Writes new line.

Properties

Name | Description
Filter | Gets HtmlExportFilter instance associated with this context.
Scale | Gets scale factor.
SupportImages | Gets if context support images.
Units | Gets current units.
Writer | Gets HtmlTextWriter.

See Also

IHtmlContext Interface
PerpetuumSoft.Reporting.Export.Html Namespace


IHtmlContext Methods

[image] [image]

.NET ModelKit Suite ClassReference
IHtmlContext Methods
IHtmlContext Interface See Also Send Feedback

The IHtmlContext type exposes the following members.

Methods

Name | Description
AddImage | Adds image and returns image url.
DecIndent | Decrements indent.
FormatUnits | Converts distance to its html representation.
GetBookmark | Returns bookmark for the given control.
GetHyperlink | Returns hyperlink for the given control.
IncIndent | Increments indent.
ScaleValue | Converts distance to its html representation.
WriteLine | Writes new line.

See Also

IHtmlContext Interface
PerpetuumSoft.Reporting.Export.Html Namespace


AddImage Method

[image]

.NET ModelKit Suite ClassReference
IHtmlContext..::.AddImage Method
IHtmlContext Interface See Also Send Feedback
Adds image and returns image url.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
string AddImage(
    Bitmap bitmap
)
Visual Basic (Declaration)
Function AddImage ( _
    bitmap As Bitmap _
) As String
Visual C++
String^ AddImage(
    Bitmap^ bitmap
)

Parameters

bitmap
Type: System.Drawing..::.Bitmap

See Also

IHtmlContext Interface
PerpetuumSoft.Reporting.Export.Html Namespace


DecIndent Method

[image]

.NET ModelKit Suite ClassReference
IHtmlContext..::.DecIndent Method
IHtmlContext Interface See Also Send Feedback
Decrements indent.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
void DecIndent()
Visual Basic (Declaration)
Sub DecIndent
Visual C++
void DecIndent()

See Also

IHtmlContext Interface
PerpetuumSoft.Reporting.Export.Html Namespace


FormatUnits Method

[image]

.NET ModelKit Suite ClassReference
IHtmlContext..::.FormatUnits Method
IHtmlContext Interface See Also Send Feedback
Converts distance to its html representation.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
string FormatUnits(
    double value
)
Visual Basic (Declaration)
Function FormatUnits ( _
    value As Double _
) As String
Visual C++
String^ FormatUnits(
    double value
)

Parameters

value
Type: System..::.Double

See Also

IHtmlContext Interface
PerpetuumSoft.Reporting.Export.Html Namespace


GetBookmark Method

[image]

.NET ModelKit Suite ClassReference
IHtmlContext..::.GetBookmark Method
IHtmlContext Interface See Also Send Feedback
Returns bookmark for the given control.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
string GetBookmark(
    ReportControl control
)
Visual Basic (Declaration)
Function GetBookmark ( _
    control As ReportControl _
) As String
Visual C++
String^ GetBookmark(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

IHtmlContext Interface
PerpetuumSoft.Reporting.Export.Html Namespace


GetHyperlink Method

[image]

.NET ModelKit Suite ClassReference
IHtmlContext..::.GetHyperlink Method
IHtmlContext Interface See Also Send Feedback
Returns hyperlink for the given control.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
string GetHyperlink(
    ReportControl control
)
Visual Basic (Declaration)
Function GetHyperlink ( _
    control As ReportControl _
) As String
Visual C++
String^ GetHyperlink(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

IHtmlContext Interface
PerpetuumSoft.Reporting.Export.Html Namespace


IncIndent Method

[image]

.NET ModelKit Suite ClassReference
IHtmlContext..::.IncIndent Method
IHtmlContext Interface See Also Send Feedback
Increments indent.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
void IncIndent()
Visual Basic (Declaration)
Sub IncIndent
Visual C++
void IncIndent()

See Also

IHtmlContext Interface
PerpetuumSoft.Reporting.Export.Html Namespace


ScaleValue Method

[image]

.NET ModelKit Suite ClassReference
IHtmlContext..::.ScaleValue Method
IHtmlContext Interface See Also Send Feedback
Converts distance to its html representation.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
double ScaleValue(
    double value
)
Visual Basic (Declaration)
Function ScaleValue ( _
    value As Double _
) As Double
Visual C++
double ScaleValue(
    double value
)

Parameters

value
Type: System..::.Double

See Also

IHtmlContext Interface
PerpetuumSoft.Reporting.Export.Html Namespace


WriteLine Method

[image]

.NET ModelKit Suite ClassReference
IHtmlContext..::.WriteLine Method
IHtmlContext Interface See Also Send Feedback
Writes new line.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
void WriteLine()
Visual Basic (Declaration)
Sub WriteLine
Visual C++
void WriteLine()

See Also

IHtmlContext Interface
PerpetuumSoft.Reporting.Export.Html Namespace


IHtmlContext Properties

[image] [image]

.NET ModelKit Suite ClassReference
IHtmlContext Properties
IHtmlContext Interface See Also Send Feedback

The IHtmlContext type exposes the following members.

Properties

Name | Description
Filter | Gets HtmlExportFilter instance associated with this context.
Scale | Gets scale factor.
SupportImages | Gets if context support images.
Units | Gets current units.
Writer | Gets HtmlTextWriter.

See Also

IHtmlContext Interface
PerpetuumSoft.Reporting.Export.Html Namespace


Filter Property

[image]

.NET ModelKit Suite ClassReference
IHtmlContext..::.Filter Property
IHtmlContext Interface See Also Send Feedback
Gets HtmlExportFilter instance associated with this context.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
HtmlExportFilter Filter { get; }
Visual Basic (Declaration)
ReadOnly Property Filter As HtmlExportFilter
Visual C++
property HtmlExportFilter^ Filter {
    HtmlExportFilter^ get ();
}

See Also

IHtmlContext Interface
PerpetuumSoft.Reporting.Export.Html Namespace


Scale Property

[image]

.NET ModelKit Suite ClassReference
IHtmlContext..::.Scale Property
IHtmlContext Interface See Also Send Feedback
Gets scale factor.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
double Scale { get; }
Visual Basic (Declaration)
ReadOnly Property Scale As Double
Visual C++
property double Scale {
    double get ();
}

See Also

IHtmlContext Interface
PerpetuumSoft.Reporting.Export.Html Namespace


SupportImages Property

[image]

.NET ModelKit Suite ClassReference
IHtmlContext..::.SupportImages Property
IHtmlContext Interface See Also Send Feedback
Gets if context support images.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
bool SupportImages { get; }
Visual Basic (Declaration)
ReadOnly Property SupportImages As Boolean
Visual C++
property bool SupportImages {
    bool get ();
}

See Also

IHtmlContext Interface
PerpetuumSoft.Reporting.Export.Html Namespace


Units Property

[image]

.NET ModelKit Suite ClassReference
IHtmlContext..::.Units Property
IHtmlContext Interface See Also Send Feedback
Gets current units.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
string Units { get; }
Visual Basic (Declaration)
ReadOnly Property Units As String
Visual C++
property String^ Units {
    String^ get ();
}

See Also

IHtmlContext Interface
PerpetuumSoft.Reporting.Export.Html Namespace


Writer Property

[image]

.NET ModelKit Suite ClassReference
IHtmlContext..::.Writer Property
IHtmlContext Interface See Also Send Feedback
Gets HtmlTextWriter.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
HtmlTextWriter Writer { get; }
Visual Basic (Declaration)
ReadOnly Property Writer As HtmlTextWriter
Visual C++
property HtmlTextWriter^ Writer {
    HtmlTextWriter^ get ();
}

See Also

IHtmlContext Interface
PerpetuumSoft.Reporting.Export.Html Namespace


ImagesFormat Enumeration

[image]

.NET ModelKit Suite ClassReference
ImagesFormat Enumeration
See Also Send Feedback
Enumerates image format.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public enum ImagesFormat
Visual Basic (Declaration)
Public Enumeration ImagesFormat
Visual C++
public enum class ImagesFormat

Members

Member name | Description
Jpeg | Jpeg images.
Gif | Gif images.
Png | Png images.

See Also

PerpetuumSoft.Reporting.Export.Html Namespace


ResultType Enumeration

[image]

.NET ModelKit Suite ClassReference
ResultType Enumeration
See Also Send Feedback
Enumerates html generation modes.

Namespace: PerpetuumSoft.Reporting.Export.Html
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public enum ResultType
Visual Basic (Declaration)
Public Enumeration ResultType
Visual C++
public enum class ResultType

Members

Member name | Description
HtmlFile | Whole html file will be generated including HTML, HEAD and BODY tags.
HtmlFragment | Only html fragment will be generated. Useful if export result will be included in other html file.

See Also

PerpetuumSoft.Reporting.Export.Html Namespace


PerpetuumSoft.Reporting.Export.Html.Adapters Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace
Send Feedback
The PerpetuumSoft.Reporting.Export.Html.Adapters namespace contains classes which are used to export document elements to the HTML (HyperText Markup Language) format.

Classes

Class | Description
AdvancedTextHtmlAdapter | Represents adapter for the AdvancedText class.
BoxHtmlAdapter | Represents adapter for the Box class.
HtmlAdapter | Incapsulates conversion methods for different types of report controls.
ReportControlHtmlAdapter | Represents Html Adapter for ReportControl class.
ShapeHtmlAdapter | Represents adapter for Shape class.
TextBoxHtmlAdapter | Represents adapter for TextBox class.
TextControlHtmlAdapter | Represents adapter for the TextBox class.
VisualControlHtmlAdapter | Represents adapter for the VisualControl class.


AdvancedTextHtmlAdapter Class

[image]

.NET ModelKit Suite ClassReference
AdvancedTextHtmlAdapter Class
Members See Also Send Feedback
Represents adapter for the AdvancedText class.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public class AdvancedTextHtmlAdapter : TextControlHtmlAdapter
Visual Basic (Declaration)
Public Class AdvancedTextHtmlAdapter _
    Inherits TextControlHtmlAdapter
Visual C++
public ref class AdvancedTextHtmlAdapter : public TextControlHtmlAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Html.Adapters..::.HtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.ReportControlHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.VisualControlHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.BoxHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.TextControlHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.AdvancedTextHtmlAdapter

See Also

AdvancedTextHtmlAdapter Members
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


AdvancedTextHtmlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextHtmlAdapter Members
AdvancedTextHtmlAdapter Class Constructors Methods See Also Send Feedback

The AdvancedTextHtmlAdapter type exposes the following members.

Constructors

Name | Description
AdvancedTextHtmlAdapter | Creates a new instance of AdvancedTextHtmlAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHorizontalAlign | Returns a string that assigned horisontal align of a control. (Inherited from TextControlHtmlAdapter.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVerticalAlign | Returns a string that assigned vertical align of a control. (Inherited from TextControlHtmlAdapter.)
HtmlCreateLineStyle | (Inherited from ReportControlHtmlAdapter.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderBody | Overrided. See RenderBody(ReportControl, IHtmlContext). (Overrides BoxHtmlAdapter..::.RenderBody(ReportControl, IHtmlContext).)
RenderSpan | Overrides inherited RenderSpan implementation. (Inherited from ReportControlHtmlAdapter.)
RenderStyle | Overrided. See RenderStyle(ReportControl, IHtmlContext). (Overrides TextControlHtmlAdapter..::.RenderStyle(ReportControl, IHtmlContext).)
RenderStyleCell | Overridden. See RenderStyleCell(ReportControl, IHtmlContext). (Overrides TextControlHtmlAdapterRenderStyleCell(ReportControl, IHtmlContext).)
SetHorizontalAlign | Sets horisontal align in the control context. (Inherited from TextControlHtmlAdapter.)
SetVerticalAlign | Sets vertical align in the control context. (Inherited from TextControlHtmlAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteBeginHref | Writes begin of HRef tag. (Inherited from HtmlAdapter.)
WriteEndHref | Closes href tag. (Inherited from HtmlAdapter.)

See Also

AdvancedTextHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


AdvancedTextHtmlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
AdvancedTextHtmlAdapter Constructor
AdvancedTextHtmlAdapter Class See Also Send Feedback
Creates a new instance of AdvancedTextHtmlAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public AdvancedTextHtmlAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AdvancedTextHtmlAdapter()

See Also

AdvancedTextHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


AdvancedTextHtmlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextHtmlAdapter Methods
AdvancedTextHtmlAdapter Class See Also Send Feedback

The AdvancedTextHtmlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHorizontalAlign | Returns a string that assigned horisontal align of a control. (Inherited from TextControlHtmlAdapter.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVerticalAlign | Returns a string that assigned vertical align of a control. (Inherited from TextControlHtmlAdapter.)
HtmlCreateLineStyle | (Inherited from ReportControlHtmlAdapter.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderBody | Overrided. See RenderBody(ReportControl, IHtmlContext). (Overrides BoxHtmlAdapter..::.RenderBody(ReportControl, IHtmlContext).)
RenderSpan | Overrides inherited RenderSpan implementation. (Inherited from ReportControlHtmlAdapter.)
RenderStyle | Overrided. See RenderStyle(ReportControl, IHtmlContext). (Overrides TextControlHtmlAdapter..::.RenderStyle(ReportControl, IHtmlContext).)
RenderStyleCell | Overridden. See RenderStyleCell(ReportControl, IHtmlContext). (Overrides TextControlHtmlAdapterRenderStyleCell(ReportControl, IHtmlContext).)
SetHorizontalAlign | Sets horisontal align in the control context. (Inherited from TextControlHtmlAdapter.)
SetVerticalAlign | Sets vertical align in the control context. (Inherited from TextControlHtmlAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteBeginHref | Writes begin of HRef tag. (Inherited from HtmlAdapter.)
WriteEndHref | Closes href tag. (Inherited from HtmlAdapter.)

See Also

AdvancedTextHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderBody Method

[image]

.NET ModelKit Suite ClassReference
AdvancedTextHtmlAdapter..::.RenderBody Method
AdvancedTextHtmlAdapter Class See Also Send Feedback
Overrided. See RenderBody(ReportControl, IHtmlContext).

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override void RenderBody(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Overrides Sub RenderBody ( _
    control As ReportControl, _
    context As IHtmlContext _
)
Visual C++
public:
virtual void RenderBody(
    ReportControl^ control,
    IHtmlContext^ context
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

AdvancedTextHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderStyle Method

[image]

.NET ModelKit Suite ClassReference
AdvancedTextHtmlAdapter..::.RenderStyle Method
AdvancedTextHtmlAdapter Class See Also Send Feedback
Overrided. See RenderStyle(ReportControl, IHtmlContext).

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override void RenderStyle(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Overrides Sub RenderStyle ( _
    control As ReportControl, _
    context As IHtmlContext _
)
Visual C++
public:
virtual void RenderStyle(
    ReportControl^ control,
    IHtmlContext^ context
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

AdvancedTextHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderStyleCell Method

[image]

.NET ModelKit Suite ClassReference
AdvancedTextHtmlAdapter..::.RenderStyleCell Method
AdvancedTextHtmlAdapter Class See Also Send Feedback
Overridden. See RenderStyleCell(ReportControl, IHtmlContext).

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override string RenderStyleCell(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Overrides Function RenderStyleCell ( _
    control As ReportControl, _
    context As IHtmlContext _
) As String
Visual C++
public:
virtual String^ RenderStyleCell(
    ReportControl^ control,
    IHtmlContext^ context
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

AdvancedTextHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


BoxHtmlAdapter Class

[image]

.NET ModelKit Suite ClassReference
BoxHtmlAdapter Class
Members See Also Send Feedback
Represents adapter for the Box class.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public class BoxHtmlAdapter : VisualControlHtmlAdapter
Visual Basic (Declaration)
Public Class BoxHtmlAdapter _
    Inherits VisualControlHtmlAdapter
Visual C++
public ref class BoxHtmlAdapter : public VisualControlHtmlAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Html.Adapters..::.HtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.ReportControlHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.VisualControlHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.BoxHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.TextControlHtmlAdapter

See Also

BoxHtmlAdapter Members
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


BoxHtmlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
BoxHtmlAdapter Members
BoxHtmlAdapter Class Constructors Methods See Also Send Feedback

The BoxHtmlAdapter type exposes the following members.

Constructors

Name | Description
BoxHtmlAdapter | Creates a new instance of BoxHtmlAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HtmlCreateLineStyle | (Inherited from ReportControlHtmlAdapter.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderBody | Overrides default RenderBody implementation. (Overrides ReportControlHtmlAdapter..::.RenderBody(ReportControl, IHtmlContext).)
RenderSpan | Overrides inherited RenderSpan implementation. (Inherited from ReportControlHtmlAdapter.)
RenderStyle | Overrides default RenderStyle implementation. (Overrides ReportControlHtmlAdapter..::.RenderStyle(ReportControl, IHtmlContext).)
RenderStyleCell | Overrides default RenderStyleCell implementation. (Overrides VisualControlHtmlAdapter..::.RenderStyleCell(ReportControl, IHtmlContext).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteBeginHref | Writes begin of HRef tag. (Inherited from HtmlAdapter.)
WriteEndHref | Closes href tag. (Inherited from HtmlAdapter.)

See Also

BoxHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


BoxHtmlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
BoxHtmlAdapter Constructor
BoxHtmlAdapter Class See Also Send Feedback
Creates a new instance of BoxHtmlAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public BoxHtmlAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoxHtmlAdapter()

See Also

BoxHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


BoxHtmlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
BoxHtmlAdapter Methods
BoxHtmlAdapter Class See Also Send Feedback

The BoxHtmlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HtmlCreateLineStyle | (Inherited from ReportControlHtmlAdapter.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderBody | Overrides default RenderBody implementation. (Overrides ReportControlHtmlAdapter..::.RenderBody(ReportControl, IHtmlContext).)
RenderSpan | Overrides inherited RenderSpan implementation. (Inherited from ReportControlHtmlAdapter.)
RenderStyle | Overrides default RenderStyle implementation. (Overrides ReportControlHtmlAdapter..::.RenderStyle(ReportControl, IHtmlContext).)
RenderStyleCell | Overrides default RenderStyleCell implementation. (Overrides VisualControlHtmlAdapter..::.RenderStyleCell(ReportControl, IHtmlContext).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteBeginHref | Writes begin of HRef tag. (Inherited from HtmlAdapter.)
WriteEndHref | Closes href tag. (Inherited from HtmlAdapter.)

See Also

BoxHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderBody Method

[image]

.NET ModelKit Suite ClassReference
BoxHtmlAdapter..::.RenderBody Method
BoxHtmlAdapter Class See Also Send Feedback
Overrides default RenderBody implementation.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override void RenderBody(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Overrides Sub RenderBody ( _
    control As ReportControl, _
    context As IHtmlContext _
)
Visual C++
public:
virtual void RenderBody(
    ReportControl^ control,
    IHtmlContext^ context
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

BoxHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderStyle Method

[image]

.NET ModelKit Suite ClassReference
BoxHtmlAdapter..::.RenderStyle Method
BoxHtmlAdapter Class See Also Send Feedback
Overrides default RenderStyle implementation.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override void RenderStyle(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Overrides Sub RenderStyle ( _
    control As ReportControl, _
    context As IHtmlContext _
)
Visual C++
public:
virtual void RenderStyle(
    ReportControl^ control,
    IHtmlContext^ context
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

BoxHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderStyleCell Method

[image]

.NET ModelKit Suite ClassReference
BoxHtmlAdapter..::.RenderStyleCell Method
BoxHtmlAdapter Class See Also Send Feedback
Overrides default RenderStyleCell implementation.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override string RenderStyleCell(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Overrides Function RenderStyleCell ( _
    control As ReportControl, _
    context As IHtmlContext _
) As String
Visual C++
public:
virtual String^ RenderStyleCell(
    ReportControl^ control,
    IHtmlContext^ context
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

BoxHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


HtmlAdapter Class

[image]

.NET ModelKit Suite ClassReference
HtmlAdapter Class
Members See Also Send Feedback
Incapsulates conversion methods for different types of report controls.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public abstract class HtmlAdapter
Visual Basic (Declaration)
Public MustInherit Class HtmlAdapter
Visual C++
public ref class HtmlAdapter abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Html.Adapters..::.HtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.ReportControlHtmlAdapter

See Also

HtmlAdapter Members
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


HtmlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
HtmlAdapter Members
HtmlAdapter Class Constructors Methods See Also Send Feedback

The HtmlAdapter type exposes the following members.

Constructors

Name | Description
HtmlAdapter | Creates a new instance of HtmlAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderBody | Renders control content to the html file.
RenderSpan | Renders control as SPAN element to the html file.
RenderStyle | Renders control style to html file.
RenderStyleCell | Renders table cell style to html file.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteBeginHref | Writes begin of HRef tag.
WriteEndHref | Closes href tag.

See Also

HtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


HtmlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
HtmlAdapter Constructor
HtmlAdapter Class See Also Send Feedback
Creates a new instance of HtmlAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
protected HtmlAdapter()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
HtmlAdapter()

See Also

HtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


HtmlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
HtmlAdapter Methods
HtmlAdapter Class See Also Send Feedback

The HtmlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderBody | Renders control content to the html file.
RenderSpan | Renders control as SPAN element to the html file.
RenderStyle | Renders control style to html file.
RenderStyleCell | Renders table cell style to html file.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteBeginHref | Writes begin of HRef tag.
WriteEndHref | Closes href tag.

See Also

HtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderBody Method

[image]

.NET ModelKit Suite ClassReference
HtmlAdapter..::.RenderBody Method
HtmlAdapter Class See Also Send Feedback
Renders control content to the html file.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public abstract void RenderBody(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public MustOverride Sub RenderBody ( _
    control As ReportControl, _
    context As IHtmlContext _
)
Visual C++
public:
virtual void RenderBody(
    ReportControl^ control,
    IHtmlContext^ context
) abstract

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

HtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderSpan Method

[image]

.NET ModelKit Suite ClassReference
HtmlAdapter..::.RenderSpan Method
HtmlAdapter Class See Also Send Feedback
Renders control as SPAN element to the html file.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public abstract void RenderSpan(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public MustOverride Sub RenderSpan ( _
    control As ReportControl, _
    context As IHtmlContext _
)
Visual C++
public:
virtual void RenderSpan(
    ReportControl^ control,
    IHtmlContext^ context
) abstract

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

HtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderStyle Method

[image]

.NET ModelKit Suite ClassReference
HtmlAdapter..::.RenderStyle Method
HtmlAdapter Class See Also Send Feedback
Renders control style to html file.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public abstract void RenderStyle(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public MustOverride Sub RenderStyle ( _
    control As ReportControl, _
    context As IHtmlContext _
)
Visual C++
public:
virtual void RenderStyle(
    ReportControl^ control,
    IHtmlContext^ context
) abstract

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

HtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderStyleCell Method

[image]

.NET ModelKit Suite ClassReference
HtmlAdapter..::.RenderStyleCell Method
HtmlAdapter Class See Also Send Feedback
Renders table cell style to html file.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public abstract string RenderStyleCell(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public MustOverride Function RenderStyleCell ( _
    control As ReportControl, _
    context As IHtmlContext _
) As String
Visual C++
public:
virtual String^ RenderStyleCell(
    ReportControl^ control,
    IHtmlContext^ context
) abstract

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

HtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


WriteBeginHref Method

[image]

.NET ModelKit Suite ClassReference
HtmlAdapter..::.WriteBeginHref Method
HtmlAdapter Class See Also Send Feedback
Writes begin of HRef tag.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public void WriteBeginHref(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Sub WriteBeginHref ( _
    control As ReportControl, _
    context As IHtmlContext _
)
Visual C++
public:
void WriteBeginHref(
    ReportControl^ control,
    IHtmlContext^ context
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

HtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


WriteEndHref Method

[image]

.NET ModelKit Suite ClassReference
HtmlAdapter..::.WriteEndHref Method
HtmlAdapter Class See Also Send Feedback
Closes href tag.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public void WriteEndHref(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Sub WriteEndHref ( _
    control As ReportControl, _
    context As IHtmlContext _
)
Visual C++
public:
void WriteEndHref(
    ReportControl^ control,
    IHtmlContext^ context
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

HtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


ReportControlHtmlAdapter Class

[image]

.NET ModelKit Suite ClassReference
ReportControlHtmlAdapter Class
Members See Also Send Feedback
Represents Html Adapter for ReportControl class.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public class ReportControlHtmlAdapter : HtmlAdapter
Visual Basic (Declaration)
Public Class ReportControlHtmlAdapter _
    Inherits HtmlAdapter
Visual C++
public ref class ReportControlHtmlAdapter : public HtmlAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Html.Adapters..::.HtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.ReportControlHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.VisualControlHtmlAdapter

See Also

ReportControlHtmlAdapter Members
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


ReportControlHtmlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlHtmlAdapter Members
ReportControlHtmlAdapter Class Constructors Methods See Also Send Feedback

The ReportControlHtmlAdapter type exposes the following members.

Constructors

Name | Description
ReportControlHtmlAdapter | Creates a new instance of ReportControlHtmlAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImage |
GetType | Gets the Type of the current instance. (Inherited from Object.)
HtmlCreateLineStyle |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderBody | Overrides inherited RenderBody implementation. (Overrides HtmlAdapter..::.RenderBody(ReportControl, IHtmlContext).)
RenderSpan | Overrides inherited RenderSpan implementation. (Overrides HtmlAdapter..::.RenderSpan(ReportControl, IHtmlContext).)
RenderStyle | Overrides inherited RenderStyle implementation. (Overrides HtmlAdapter..::.RenderStyle(ReportControl, IHtmlContext).)
RenderStyleCell | Overrides inherited RenderStyleCell implementation. (Overrides HtmlAdapter..::.RenderStyleCell(ReportControl, IHtmlContext).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteBeginHref | Writes begin of HRef tag. (Inherited from HtmlAdapter.)
WriteEndHref | Closes href tag. (Inherited from HtmlAdapter.)

See Also

ReportControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


ReportControlHtmlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
ReportControlHtmlAdapter Constructor
ReportControlHtmlAdapter Class See Also Send Feedback
Creates a new instance of ReportControlHtmlAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public ReportControlHtmlAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportControlHtmlAdapter()

See Also

ReportControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


ReportControlHtmlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlHtmlAdapter Methods
ReportControlHtmlAdapter Class See Also Send Feedback

The ReportControlHtmlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImage |
GetType | Gets the Type of the current instance. (Inherited from Object.)
HtmlCreateLineStyle |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderBody | Overrides inherited RenderBody implementation. (Overrides HtmlAdapter..::.RenderBody(ReportControl, IHtmlContext).)
RenderSpan | Overrides inherited RenderSpan implementation. (Overrides HtmlAdapter..::.RenderSpan(ReportControl, IHtmlContext).)
RenderStyle | Overrides inherited RenderStyle implementation. (Overrides HtmlAdapter..::.RenderStyle(ReportControl, IHtmlContext).)
RenderStyleCell | Overrides inherited RenderStyleCell implementation. (Overrides HtmlAdapter..::.RenderStyleCell(ReportControl, IHtmlContext).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteBeginHref | Writes begin of HRef tag. (Inherited from HtmlAdapter.)
WriteEndHref | Closes href tag. (Inherited from HtmlAdapter.)

See Also

ReportControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


GetImage Method

[image]

.NET ModelKit Suite ClassReference
ReportControlHtmlAdapter..::.GetImage Method
ReportControlHtmlAdapter Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Export.Html.Adapters.ReportControlHtmlAdapter.GetImage(PerpetuumSoft.Reporting.DOM.ReportControl,PerpetuumSoft.Reporting.Export.Html.IHtmlContext)]

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public static Bitmap GetImage(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Shared Function GetImage ( _
    control As ReportControl, _
    context As IHtmlContext _
) As Bitmap
Visual C++
public:
static Bitmap^ GetImage(
    ReportControl^ control,
    IHtmlContext^ context
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

ReportControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


HtmlCreateLineStyle Method

[image]

.NET ModelKit Suite ClassReference
ReportControlHtmlAdapter..::.HtmlCreateLineStyle Method
ReportControlHtmlAdapter Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Export.Html.Adapters.ReportControlHtmlAdapter.HtmlCreateLineStyle(PerpetuumSoft.Framework.Drawing.BorderLine,PerpetuumSoft.Reporting.Export.Html.IHtmlContext)]

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
protected string HtmlCreateLineStyle(
    BorderLine line,
    IHtmlContext context
)
Visual Basic (Declaration)
Protected Function HtmlCreateLineStyle ( _
    line As BorderLine, _
    context As IHtmlContext _
) As String
Visual C++
protected:
String^ HtmlCreateLineStyle(
    BorderLine line,
    IHtmlContext^ context
)

Parameters

line
Type: PerpetuumSoft.Framework.Drawing..::.BorderLine
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

ReportControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderBody Method

[image]

.NET ModelKit Suite ClassReference
ReportControlHtmlAdapter..::.RenderBody Method
ReportControlHtmlAdapter Class See Also Send Feedback
Overrides inherited RenderBody implementation.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override void RenderBody(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Overrides Sub RenderBody ( _
    control As ReportControl, _
    context As IHtmlContext _
)
Visual C++
public:
virtual void RenderBody(
    ReportControl^ control,
    IHtmlContext^ context
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

ReportControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderSpan Method

[image]

.NET ModelKit Suite ClassReference
ReportControlHtmlAdapter..::.RenderSpan Method
ReportControlHtmlAdapter Class See Also Send Feedback
Overrides inherited RenderSpan implementation.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override void RenderSpan(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Overrides Sub RenderSpan ( _
    control As ReportControl, _
    context As IHtmlContext _
)
Visual C++
public:
virtual void RenderSpan(
    ReportControl^ control,
    IHtmlContext^ context
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

ReportControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderStyle Method

[image]

.NET ModelKit Suite ClassReference
ReportControlHtmlAdapter..::.RenderStyle Method
ReportControlHtmlAdapter Class See Also Send Feedback
Overrides inherited RenderStyle implementation.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override void RenderStyle(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Overrides Sub RenderStyle ( _
    control As ReportControl, _
    context As IHtmlContext _
)
Visual C++
public:
virtual void RenderStyle(
    ReportControl^ control,
    IHtmlContext^ context
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

ReportControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderStyleCell Method

[image]

.NET ModelKit Suite ClassReference
ReportControlHtmlAdapter..::.RenderStyleCell Method
ReportControlHtmlAdapter Class See Also Send Feedback
Overrides inherited RenderStyleCell implementation.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override string RenderStyleCell(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Overrides Function RenderStyleCell ( _
    control As ReportControl, _
    context As IHtmlContext _
) As String
Visual C++
public:
virtual String^ RenderStyleCell(
    ReportControl^ control,
    IHtmlContext^ context
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

ReportControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


ShapeHtmlAdapter Class

[image]

.NET ModelKit Suite ClassReference
ShapeHtmlAdapter Class
Members See Also Send Feedback
Represents adapter for Shape class.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public class ShapeHtmlAdapter : VisualControlHtmlAdapter
Visual Basic (Declaration)
Public Class ShapeHtmlAdapter _
    Inherits VisualControlHtmlAdapter
Visual C++
public ref class ShapeHtmlAdapter : public VisualControlHtmlAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Html.Adapters..::.HtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.ReportControlHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.VisualControlHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.ShapeHtmlAdapter

See Also

ShapeHtmlAdapter Members
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


ShapeHtmlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
ShapeHtmlAdapter Members
ShapeHtmlAdapter Class Constructors Methods See Also Send Feedback

The ShapeHtmlAdapter type exposes the following members.

Constructors

Name | Description
ShapeHtmlAdapter | Creates a new instance of ShapeHtmlAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HtmlCreateLineStyle | (Inherited from ReportControlHtmlAdapter.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderBody | Overrides inherited RenderBody implementation. (Overrides ReportControlHtmlAdapter..::.RenderBody(ReportControl, IHtmlContext).)
RenderSpan | Overrides inherited RenderSpan implementation. (Inherited from ReportControlHtmlAdapter.)
RenderStyle | Overrides inherited RenderStyle implementation. (Inherited from ReportControlHtmlAdapter.)
RenderStyleCell | Overrides inherited RenderStyleCell implementation. (Overrides VisualControlHtmlAdapter..::.RenderStyleCell(ReportControl, IHtmlContext).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteBeginHref | Writes begin of HRef tag. (Inherited from HtmlAdapter.)
WriteEndHref | Closes href tag. (Inherited from HtmlAdapter.)

See Also

ShapeHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


ShapeHtmlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
ShapeHtmlAdapter Constructor
ShapeHtmlAdapter Class See Also Send Feedback
Creates a new instance of ShapeHtmlAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public ShapeHtmlAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ShapeHtmlAdapter()

See Also

ShapeHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


ShapeHtmlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ShapeHtmlAdapter Methods
ShapeHtmlAdapter Class See Also Send Feedback

The ShapeHtmlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HtmlCreateLineStyle | (Inherited from ReportControlHtmlAdapter.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderBody | Overrides inherited RenderBody implementation. (Overrides ReportControlHtmlAdapter..::.RenderBody(ReportControl, IHtmlContext).)
RenderSpan | Overrides inherited RenderSpan implementation. (Inherited from ReportControlHtmlAdapter.)
RenderStyle | Overrides inherited RenderStyle implementation. (Inherited from ReportControlHtmlAdapter.)
RenderStyleCell | Overrides inherited RenderStyleCell implementation. (Overrides VisualControlHtmlAdapter..::.RenderStyleCell(ReportControl, IHtmlContext).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteBeginHref | Writes begin of HRef tag. (Inherited from HtmlAdapter.)
WriteEndHref | Closes href tag. (Inherited from HtmlAdapter.)

See Also

ShapeHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderBody Method

[image]

.NET ModelKit Suite ClassReference
ShapeHtmlAdapter..::.RenderBody Method
ShapeHtmlAdapter Class See Also Send Feedback
Overrides inherited RenderBody implementation.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override void RenderBody(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Overrides Sub RenderBody ( _
    control As ReportControl, _
    context As IHtmlContext _
)
Visual C++
public:
virtual void RenderBody(
    ReportControl^ control,
    IHtmlContext^ context
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

ShapeHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderStyleCell Method

[image]

.NET ModelKit Suite ClassReference
ShapeHtmlAdapter..::.RenderStyleCell Method
ShapeHtmlAdapter Class See Also Send Feedback
Overrides inherited RenderStyleCell implementation.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override string RenderStyleCell(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Overrides Function RenderStyleCell ( _
    control As ReportControl, _
    context As IHtmlContext _
) As String
Visual C++
public:
virtual String^ RenderStyleCell(
    ReportControl^ control,
    IHtmlContext^ context
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

ShapeHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


TextBoxHtmlAdapter Class

[image]

.NET ModelKit Suite ClassReference
TextBoxHtmlAdapter Class
Members See Also Send Feedback
Represents adapter for TextBox class.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public class TextBoxHtmlAdapter : TextControlHtmlAdapter
Visual Basic (Declaration)
Public Class TextBoxHtmlAdapter _
    Inherits TextControlHtmlAdapter
Visual C++
public ref class TextBoxHtmlAdapter : public TextControlHtmlAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Html.Adapters..::.HtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.ReportControlHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.VisualControlHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.BoxHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.TextControlHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.TextBoxHtmlAdapter

See Also

TextBoxHtmlAdapter Members
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


TextBoxHtmlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxHtmlAdapter Members
TextBoxHtmlAdapter Class Constructors Methods See Also Send Feedback

The TextBoxHtmlAdapter type exposes the following members.

Constructors

Name | Description
TextBoxHtmlAdapter | Creates a new instance of TextBoxHtmlAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHorizontalAlign | Returns a string that assigned horisontal align of a control. (Inherited from TextControlHtmlAdapter.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVerticalAlign | Returns a string that assigned vertical align of a control. (Inherited from TextControlHtmlAdapter.)
HtmlCreateLineStyle | (Inherited from ReportControlHtmlAdapter.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderBody | Overrides inherited RenderBody implementation. (Overrides BoxHtmlAdapter..::.RenderBody(ReportControl, IHtmlContext).)
RenderSpan | Overrides inherited RenderSpan implementation. (Inherited from ReportControlHtmlAdapter.)
RenderStyle | Overrides inherited RenderStyle implementation. (Overrides TextControlHtmlAdapter..::.RenderStyle(ReportControl, IHtmlContext).)
RenderStyleCell | Overrides inherited RenderStyleCell implementation. (Overrides TextControlHtmlAdapterRenderStyleCell(ReportControl, IHtmlContext).)
SetHorizontalAlign | Sets horisontal align in the control context. (Inherited from TextControlHtmlAdapter.)
SetVerticalAlign | Sets vertical align in the control context. (Inherited from TextControlHtmlAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteBeginHref | Writes begin of HRef tag. (Inherited from HtmlAdapter.)
WriteEndHref | Closes href tag. (Inherited from HtmlAdapter.)

See Also

TextBoxHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


TextBoxHtmlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
TextBoxHtmlAdapter Constructor
TextBoxHtmlAdapter Class See Also Send Feedback
Creates a new instance of TextBoxHtmlAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public TextBoxHtmlAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextBoxHtmlAdapter()

See Also

TextBoxHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


TextBoxHtmlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxHtmlAdapter Methods
TextBoxHtmlAdapter Class See Also Send Feedback

The TextBoxHtmlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHorizontalAlign | Returns a string that assigned horisontal align of a control. (Inherited from TextControlHtmlAdapter.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVerticalAlign | Returns a string that assigned vertical align of a control. (Inherited from TextControlHtmlAdapter.)
HtmlCreateLineStyle | (Inherited from ReportControlHtmlAdapter.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderBody | Overrides inherited RenderBody implementation. (Overrides BoxHtmlAdapter..::.RenderBody(ReportControl, IHtmlContext).)
RenderSpan | Overrides inherited RenderSpan implementation. (Inherited from ReportControlHtmlAdapter.)
RenderStyle | Overrides inherited RenderStyle implementation. (Overrides TextControlHtmlAdapter..::.RenderStyle(ReportControl, IHtmlContext).)
RenderStyleCell | Overrides inherited RenderStyleCell implementation. (Overrides TextControlHtmlAdapterRenderStyleCell(ReportControl, IHtmlContext).)
SetHorizontalAlign | Sets horisontal align in the control context. (Inherited from TextControlHtmlAdapter.)
SetVerticalAlign | Sets vertical align in the control context. (Inherited from TextControlHtmlAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteBeginHref | Writes begin of HRef tag. (Inherited from HtmlAdapter.)
WriteEndHref | Closes href tag. (Inherited from HtmlAdapter.)

See Also

TextBoxHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderBody Method

[image]

.NET ModelKit Suite ClassReference
TextBoxHtmlAdapter..::.RenderBody Method
TextBoxHtmlAdapter Class See Also Send Feedback
Overrides inherited RenderBody implementation.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override void RenderBody(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Overrides Sub RenderBody ( _
    control As ReportControl, _
    context As IHtmlContext _
)
Visual C++
public:
virtual void RenderBody(
    ReportControl^ control,
    IHtmlContext^ context
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

TextBoxHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderStyle Method

[image]

.NET ModelKit Suite ClassReference
TextBoxHtmlAdapter..::.RenderStyle Method
TextBoxHtmlAdapter Class See Also Send Feedback
Overrides inherited RenderStyle implementation.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override void RenderStyle(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Overrides Sub RenderStyle ( _
    control As ReportControl, _
    context As IHtmlContext _
)
Visual C++
public:
virtual void RenderStyle(
    ReportControl^ control,
    IHtmlContext^ context
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

TextBoxHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderStyleCell Method

[image]

.NET ModelKit Suite ClassReference
TextBoxHtmlAdapter..::.RenderStyleCell Method
TextBoxHtmlAdapter Class See Also Send Feedback
Overrides inherited RenderStyleCell implementation.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override string RenderStyleCell(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Overrides Function RenderStyleCell ( _
    control As ReportControl, _
    context As IHtmlContext _
) As String
Visual C++
public:
virtual String^ RenderStyleCell(
    ReportControl^ control,
    IHtmlContext^ context
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

TextBoxHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


TextControlHtmlAdapter Class

[image]

.NET ModelKit Suite ClassReference
TextControlHtmlAdapter Class
Members See Also Send Feedback
Represents adapter for the TextBox class.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public class TextControlHtmlAdapter : BoxHtmlAdapter
Visual Basic (Declaration)
Public Class TextControlHtmlAdapter _
    Inherits BoxHtmlAdapter
Visual C++
public ref class TextControlHtmlAdapter : public BoxHtmlAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Html.Adapters..::.HtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.ReportControlHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.VisualControlHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.BoxHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.TextControlHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.AdvancedTextHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.TextBoxHtmlAdapter

See Also

TextControlHtmlAdapter Members
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


TextControlHtmlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
TextControlHtmlAdapter Members
TextControlHtmlAdapter Class Constructors Methods See Also Send Feedback

The TextControlHtmlAdapter type exposes the following members.

Constructors

Name | Description
TextControlHtmlAdapter | Initializes a new instance of the TextControlHtmlAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHorizontalAlign | Returns a string that assigned horisontal align of a control.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVerticalAlign | Returns a string that assigned vertical align of a control.
HtmlCreateLineStyle | (Inherited from ReportControlHtmlAdapter.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderBody | Overrides default RenderBody implementation. (Inherited from BoxHtmlAdapter.)
RenderSpan | Overrides inherited RenderSpan implementation. (Inherited from ReportControlHtmlAdapter.)
RenderStyle | Overridden. See RenderStyle(ReportControl, IHtmlContext). (Overrides BoxHtmlAdapter..::.RenderStyle(ReportControl, IHtmlContext).)
RenderStyleCell | Overrides default RenderStyleCell implementation. (Inherited from BoxHtmlAdapter.)
SetHorizontalAlign | Sets horisontal align in the control context.
SetVerticalAlign | Sets vertical align in the control context.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteBeginHref | Writes begin of HRef tag. (Inherited from HtmlAdapter.)
WriteEndHref | Closes href tag. (Inherited from HtmlAdapter.)

See Also

TextControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


TextControlHtmlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
TextControlHtmlAdapter Constructor
TextControlHtmlAdapter Class See Also Send Feedback
Initializes a new instance of the TextControlHtmlAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public TextControlHtmlAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextControlHtmlAdapter()

See Also

TextControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


TextControlHtmlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextControlHtmlAdapter Methods
TextControlHtmlAdapter Class See Also Send Feedback

The TextControlHtmlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetHorizontalAlign | Returns a string that assigned horisontal align of a control.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVerticalAlign | Returns a string that assigned vertical align of a control.
HtmlCreateLineStyle | (Inherited from ReportControlHtmlAdapter.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderBody | Overrides default RenderBody implementation. (Inherited from BoxHtmlAdapter.)
RenderSpan | Overrides inherited RenderSpan implementation. (Inherited from ReportControlHtmlAdapter.)
RenderStyle | Overridden. See RenderStyle(ReportControl, IHtmlContext). (Overrides BoxHtmlAdapter..::.RenderStyle(ReportControl, IHtmlContext).)
RenderStyleCell | Overrides default RenderStyleCell implementation. (Inherited from BoxHtmlAdapter.)
SetHorizontalAlign | Sets horisontal align in the control context.
SetVerticalAlign | Sets vertical align in the control context.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteBeginHref | Writes begin of HRef tag. (Inherited from HtmlAdapter.)
WriteEndHref | Closes href tag. (Inherited from HtmlAdapter.)

See Also

TextControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


GetHorizontalAlign Method

[image]

.NET ModelKit Suite ClassReference
TextControlHtmlAdapter..::.GetHorizontalAlign Method
TextControlHtmlAdapter Class See Also Send Feedback
Returns a string that assigned horisontal align of a control.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
protected string GetHorizontalAlign(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Protected Function GetHorizontalAlign ( _
    control As ReportControl, _
    context As IHtmlContext _
) As String
Visual C++
protected:
String^ GetHorizontalAlign(
    ReportControl^ control,
    IHtmlContext^ context
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

TextControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


GetVerticalAlign Method

[image]

.NET ModelKit Suite ClassReference
TextControlHtmlAdapter..::.GetVerticalAlign Method
TextControlHtmlAdapter Class See Also Send Feedback
Returns a string that assigned vertical align of a control.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
protected string GetVerticalAlign(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Protected Function GetVerticalAlign ( _
    control As ReportControl, _
    context As IHtmlContext _
) As String
Visual C++
protected:
String^ GetVerticalAlign(
    ReportControl^ control,
    IHtmlContext^ context
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

TextControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderStyle Method

[image]

.NET ModelKit Suite ClassReference
TextControlHtmlAdapter..::.RenderStyle Method
TextControlHtmlAdapter Class See Also Send Feedback
Overridden. See RenderStyle(ReportControl, IHtmlContext).

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override void RenderStyle(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Overrides Sub RenderStyle ( _
    control As ReportControl, _
    context As IHtmlContext _
)
Visual C++
public:
virtual void RenderStyle(
    ReportControl^ control,
    IHtmlContext^ context
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

TextControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


SetHorizontalAlign Method

[image]

.NET ModelKit Suite ClassReference
TextControlHtmlAdapter..::.SetHorizontalAlign Method
TextControlHtmlAdapter Class See Also Send Feedback
Sets horisontal align in the control context.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
protected void SetHorizontalAlign(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Protected Sub SetHorizontalAlign ( _
    control As ReportControl, _
    context As IHtmlContext _
)
Visual C++
protected:
void SetHorizontalAlign(
    ReportControl^ control,
    IHtmlContext^ context
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

TextControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


SetVerticalAlign Method

[image]

.NET ModelKit Suite ClassReference
TextControlHtmlAdapter..::.SetVerticalAlign Method
TextControlHtmlAdapter Class See Also Send Feedback
Sets vertical align in the control context.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
protected void SetVerticalAlign(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Protected Sub SetVerticalAlign ( _
    control As ReportControl, _
    context As IHtmlContext _
)
Visual C++
protected:
void SetVerticalAlign(
    ReportControl^ control,
    IHtmlContext^ context
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

TextControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


VisualControlHtmlAdapter Class

[image]

.NET ModelKit Suite ClassReference
VisualControlHtmlAdapter Class
Members See Also Send Feedback
Represents adapter for the VisualControl class.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public class VisualControlHtmlAdapter : ReportControlHtmlAdapter
Visual Basic (Declaration)
Public Class VisualControlHtmlAdapter _
    Inherits ReportControlHtmlAdapter
Visual C++
public ref class VisualControlHtmlAdapter : public ReportControlHtmlAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Html.Adapters..::.HtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.ReportControlHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.VisualControlHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.BoxHtmlAdapter
PerpetuumSoft.Reporting.Export.Html.Adapters..::.ShapeHtmlAdapter

See Also

VisualControlHtmlAdapter Members
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


VisualControlHtmlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
VisualControlHtmlAdapter Members
VisualControlHtmlAdapter Class Constructors Methods See Also Send Feedback

The VisualControlHtmlAdapter type exposes the following members.

Constructors

Name | Description
VisualControlHtmlAdapter | Creates a new instance of VisualControlHtmlAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HtmlCreateLineStyle | (Inherited from ReportControlHtmlAdapter.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderBody | Overrides inherited RenderBody implementation. (Inherited from ReportControlHtmlAdapter.)
RenderSpan | Overrides inherited RenderSpan implementation. (Inherited from ReportControlHtmlAdapter.)
RenderStyle | Overrides inherited RenderStyle implementation. (Inherited from ReportControlHtmlAdapter.)
RenderStyleCell | Overrides inherited RenderStyleCell implementation. (Overrides ReportControlHtmlAdapter..::.RenderStyleCell(ReportControl, IHtmlContext).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteBeginHref | Writes begin of HRef tag. (Inherited from HtmlAdapter.)
WriteEndHref | Closes href tag. (Inherited from HtmlAdapter.)

See Also

VisualControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


VisualControlHtmlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
VisualControlHtmlAdapter Constructor
VisualControlHtmlAdapter Class See Also Send Feedback
Creates a new instance of VisualControlHtmlAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public VisualControlHtmlAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VisualControlHtmlAdapter()

See Also

VisualControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


VisualControlHtmlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
VisualControlHtmlAdapter Methods
VisualControlHtmlAdapter Class See Also Send Feedback

The VisualControlHtmlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HtmlCreateLineStyle | (Inherited from ReportControlHtmlAdapter.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderBody | Overrides inherited RenderBody implementation. (Inherited from ReportControlHtmlAdapter.)
RenderSpan | Overrides inherited RenderSpan implementation. (Inherited from ReportControlHtmlAdapter.)
RenderStyle | Overrides inherited RenderStyle implementation. (Inherited from ReportControlHtmlAdapter.)
RenderStyleCell | Overrides inherited RenderStyleCell implementation. (Overrides ReportControlHtmlAdapter..::.RenderStyleCell(ReportControl, IHtmlContext).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteBeginHref | Writes begin of HRef tag. (Inherited from HtmlAdapter.)
WriteEndHref | Closes href tag. (Inherited from HtmlAdapter.)

See Also

VisualControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


RenderStyleCell Method

[image]

.NET ModelKit Suite ClassReference
VisualControlHtmlAdapter..::.RenderStyleCell Method
VisualControlHtmlAdapter Class See Also Send Feedback
Overrides inherited RenderStyleCell implementation.

Namespace: PerpetuumSoft.Reporting.Export.Html.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Html (in PerpetuumSoft.Reporting.Export.Html.dll) Version: 3.9.0.1

Syntax

C#
public override string RenderStyleCell(
    ReportControl control,
    IHtmlContext context
)
Visual Basic (Declaration)
Public Overrides Function RenderStyleCell ( _
    control As ReportControl, _
    context As IHtmlContext _
) As String
Visual C++
public:
virtual String^ RenderStyleCell(
    ReportControl^ control,
    IHtmlContext^ context
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Export.Html..::.IHtmlContext

See Also

VisualControlHtmlAdapter Class
PerpetuumSoft.Reporting.Export.Html.Adapters Namespace


PerpetuumSoft.Reporting.Export.Pdf Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Export.Pdf Namespace
Send Feedback
The PerpetuumSoft.Reporting.Export.PDF namespace contains classes which are used to export document to the PDF (Portable Document Format) format.

Classes

Class | Description
PdfExportFilter | Represents the instance of the pdf filter class.
PdfExportFilterFactory | Creates PdfExportFilter instaces.


PdfExportFilter Class

[image]

.NET ModelKit Suite ClassReference
PdfExportFilter Class
Members See Also Send Feedback
Represents the instance of the pdf filter class.

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public class PdfExportFilter : ExportFilter
Visual Basic (Declaration)
Public Class PdfExportFilter _
    Inherits ExportFilter
Visual C++
public ref class PdfExportFilter : public ExportFilter

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Export..::.ExportFilter
PerpetuumSoft.Reporting.Export.Pdf..::.PdfExportFilter

See Also

PdfExportFilter Members
PerpetuumSoft.Reporting.Export.Pdf Namespace


PdfExportFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
PdfExportFilter Members
PdfExportFilter Class Constructors Methods Properties Events See Also Send Feedback

The PdfExportFilter type exposes the following members.

Constructors

Name | Description
PdfExportFilter | Overloaded.

Methods

Name | Description
CreateAdapter | Registers new adapter.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindAdapterType | Returns PdfAdapter instance corresponding to the given control type.
GetAvailableParametersNames | Overridden. See GetAvailableParametersNames()()(). (Overrides ExportFilterGetAvailableParametersNames()()().)
GetFactory | Overrided. See GetFactory()()(). (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
RegisterAdapter | Registers a new adapter.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Overrided. See ShowDialog()()(). (Overrides ExportFilter..::.ShowDialog()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Compress |
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
EmbedFonts | Gets and sets whether fonts will be embedded in result pdf file.
EmbedPrivateCharacters | Gets or sets value indicating whether eudc characted would be embed into PDF document.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ImageQuality | Gets and sets image quality if needed.
ImageResolution | Gets and sets image resolution if needed.
KeepOriginalImageResolutionAndQuality | Gets and sets whether image resolution and quality will be stored in the result pdf file.
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

PdfExportFilter Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


PdfExportFilter Constructor

[image] [image]

.NET ModelKit Suite ClassReference
PdfExportFilter Constructor
PdfExportFilter Class See Also Send Feedback

Overload List

Name | Description
PdfExportFilter()()() | Initializes a new instance of the PdfExportFilter class.
PdfExportFilter(IContainer) | Initializes a new instance of the PdfExportFilter class with the specified container.

See Also

PdfExportFilter Class
PdfExportFilter Members
PerpetuumSoft.Reporting.Export.Pdf Namespace


PdfExportFilter Constructor

[image]

.NET ModelKit Suite ClassReference
PdfExportFilter Constructor
PdfExportFilter Class See Also Send Feedback
Initializes a new instance of the PdfExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public PdfExportFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PdfExportFilter()

See Also

PdfExportFilter Class
PdfExportFilter Overload
PerpetuumSoft.Reporting.Export.Pdf Namespace


PdfExportFilter Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
PdfExportFilter Constructor (IContainer)
PdfExportFilter Class See Also Send Feedback
Initializes a new instance of the PdfExportFilter class with the specified container.

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public PdfExportFilter(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
PdfExportFilter(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

PdfExportFilter Class
PdfExportFilter Overload
PerpetuumSoft.Reporting.Export.Pdf Namespace


PdfExportFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
PdfExportFilter Methods
PdfExportFilter Class See Also Send Feedback

The PdfExportFilter type exposes the following members.

Methods

Name | Description
CreateAdapter | Registers new adapter.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindAdapterType | Returns PdfAdapter instance corresponding to the given control type.
GetAvailableParametersNames | Overridden. See GetAvailableParametersNames()()(). (Overrides ExportFilterGetAvailableParametersNames()()().)
GetFactory | Overrided. See GetFactory()()(). (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
RegisterAdapter | Registers a new adapter.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Overrided. See ShowDialog()()(). (Overrides ExportFilter..::.ShowDialog()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

PdfExportFilter Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


CreateAdapter Method

[image]

.NET ModelKit Suite ClassReference
PdfExportFilter..::.CreateAdapter Method
PdfExportFilter Class See Also Send Feedback
Registers new adapter.

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public static PdfAdapter CreateAdapter(
    ReportControl control
)
Visual Basic (Declaration)
Public Shared Function CreateAdapter ( _
    control As ReportControl _
) As PdfAdapter
Visual C++
public:
static PdfAdapter^ CreateAdapter(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

PdfExportFilter Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
PdfExportFilter..::.Dispose Method
PdfExportFilter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

PdfExportFilter Class
PdfExportFilter Members
PerpetuumSoft.Reporting.Export.Pdf Namespace


Export Method

[image] [image]

.NET ModelKit Suite ClassReference
PdfExportFilter..::.Export Method
PdfExportFilter Class See Also Send Feedback

Overload List

Name | Description
Export(Document, Stream) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String, Boolean) | Exports the specified report document to the specified file and optionally shows export filter settings dialog. (Inherited from ExportFilter.)

See Also

PdfExportFilter Class
PdfExportFilter Members
PerpetuumSoft.Reporting.Export.Pdf Namespace


ExportDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
PdfExportFilter..::.ExportDocument Method
PdfExportFilter Class See Also Send Feedback

Overload List

Name | Description
ExportDocument(Document, Stream) | Exports given document to the specified stream. (Overrides ExportFilter..::.ExportDocument(Document, Stream).)
ExportDocument(Document, String) | Exports given document to the specified file. (Overrides ExportFilter..::.ExportDocument(Document, String).)

See Also

PdfExportFilter Class
PdfExportFilter Members
PerpetuumSoft.Reporting.Export.Pdf Namespace


ExportDocument Method (Document, Stream)

[image]

.NET ModelKit Suite ClassReference
PdfExportFilter..::.ExportDocument Method (Document, Stream)
PdfExportFilter Class See Also Send Feedback
Exports given document to the specified stream.

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
protected override void ExportDocument(
    Document document,
    Stream stream
)
Visual Basic (Declaration)
Protected Overrides Sub ExportDocument ( _
    document As Document, _
    stream As Stream _
)
Visual C++
protected:
virtual void ExportDocument(
    Document^ document,
    Stream^ stream
) override

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
stream
Type: System.IO..::.Stream

See Also

PdfExportFilter Class
ExportDocument Overload
PerpetuumSoft.Reporting.Export.Pdf Namespace


ExportDocument Method (Document, String)

[image]

.NET ModelKit Suite ClassReference
PdfExportFilter..::.ExportDocument Method (Document, String)
PdfExportFilter Class See Also Send Feedback
Exports given document to the specified file.

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
protected override void ExportDocument(
    Document document,
    string fileName
)
Visual Basic (Declaration)
Protected Overrides Sub ExportDocument ( _
    document As Document, _
    fileName As String _
)
Visual C++
protected:
virtual void ExportDocument(
    Document^ document,
    String^ fileName
) override

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
fileName
Type: System..::.String

See Also

PdfExportFilter Class
ExportDocument Overload
PerpetuumSoft.Reporting.Export.Pdf Namespace


FindAdapterType Method

[image]

.NET ModelKit Suite ClassReference
PdfExportFilter..::.FindAdapterType Method
PdfExportFilter Class See Also Send Feedback
Returns PdfAdapter instance corresponding to the given control type.

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public static Type FindAdapterType(
    Type type
)
Visual Basic (Declaration)
Public Shared Function FindAdapterType ( _
    type As Type _
) As Type
Visual C++
public:
static Type^ FindAdapterType(
    Type^ type
)

Parameters

type
Type: System..::.Type

See Also

PdfExportFilter Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


GetAvailableParametersNames Method

[image]

.NET ModelKit Suite ClassReference
PdfExportFilter..::.GetAvailableParametersNames Method
PdfExportFilter Class See Also Send Feedback
Overridden. See GetAvailableParametersNames()()().

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public override StringCollection GetAvailableParametersNames()
Visual Basic (Declaration)
Public Overrides Function GetAvailableParametersNames As StringCollection
Visual C++
public:
virtual StringCollection^ GetAvailableParametersNames() override

See Also

PdfExportFilter Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


GetFactory Method

[image]

.NET ModelKit Suite ClassReference
PdfExportFilter..::.GetFactory Method
PdfExportFilter Class See Also Send Feedback
Overrided. See GetFactory()()().

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilterFactory GetFactory()
Visual Basic (Declaration)
Public Overrides Function GetFactory As ExportFilterFactory
Visual C++
public:
virtual ExportFilterFactory^ GetFactory() override

See Also

PdfExportFilter Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
PdfExportFilter..::.MemberwiseClone Method
PdfExportFilter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PdfExportFilter Class
PdfExportFilter Members
PerpetuumSoft.Reporting.Export.Pdf Namespace


RegisterAdapter Method

[image]

.NET ModelKit Suite ClassReference
PdfExportFilter..::.RegisterAdapter Method
PdfExportFilter Class See Also Send Feedback
Registers a new adapter.

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public static void RegisterAdapter(
    Type controlType,
    Type adapterType
)
Visual Basic (Declaration)
Public Shared Sub RegisterAdapter ( _
    controlType As Type, _
    adapterType As Type _
)
Visual C++
public:
static void RegisterAdapter(
    Type^ controlType,
    Type^ adapterType
)

Parameters

controlType
Type: System..::.Type
adapterType
Type: System..::.Type

See Also

PdfExportFilter Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


ShowDialog Method

[image]

.NET ModelKit Suite ClassReference
PdfExportFilter..::.ShowDialog Method
PdfExportFilter Class See Also Send Feedback
Overrided. See ShowDialog()()().

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public override DialogResult ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As DialogResult
Visual C++
public:
virtual DialogResult ShowDialog() override

See Also

PdfExportFilter Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


PdfExportFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
PdfExportFilter Properties
PdfExportFilter Class See Also Send Feedback

The PdfExportFilter type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Compress |
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
EmbedFonts | Gets and sets whether fonts will be embedded in result pdf file.
EmbedPrivateCharacters | Gets or sets value indicating whether eudc characted would be embed into PDF document.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ImageQuality | Gets and sets image quality if needed.
ImageResolution | Gets and sets image resolution if needed.
KeepOriginalImageResolutionAndQuality | Gets and sets whether image resolution and quality will be stored in the result pdf file.
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

PdfExportFilter Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


Compress Property

[image]

.NET ModelKit Suite ClassReference
PdfExportFilter..::.Compress Property
PdfExportFilter Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.Export.Pdf.PdfExportFilter.Compress]

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public bool Compress { get; set; }
Visual Basic (Declaration)
Public Property Compress As Boolean
Visual C++
public:
property bool Compress {
    bool get ();
    void set (bool value);
}

See Also

PdfExportFilter Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


EmbedFonts Property

[image]

.NET ModelKit Suite ClassReference
PdfExportFilter..::.EmbedFonts Property
PdfExportFilter Class See Also Send Feedback
Gets and sets whether fonts will be embedded in result pdf file.

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public bool EmbedFonts { get; set; }
Visual Basic (Declaration)
Public Property EmbedFonts As Boolean
Visual C++
public:
property bool EmbedFonts {
    bool get ();
    void set (bool value);
}

See Also

PdfExportFilter Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


EmbedPrivateCharacters Property

[image]

.NET ModelKit Suite ClassReference
PdfExportFilter..::.EmbedPrivateCharacters Property
PdfExportFilter Class See Also Send Feedback
Gets or sets value indicating whether eudc characted would be embed into PDF document.

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public bool EmbedPrivateCharacters { get; set; }
Visual Basic (Declaration)
Public Property EmbedPrivateCharacters As Boolean
Visual C++
public:
property bool EmbedPrivateCharacters {
    bool get ();
    void set (bool value);
}

See Also

PdfExportFilter Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


ImageQuality Property

[image]

.NET ModelKit Suite ClassReference
PdfExportFilter..::.ImageQuality Property
PdfExportFilter Class See Also Send Feedback
Gets and sets image quality if needed.

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public int ImageQuality { get; set; }
Visual Basic (Declaration)
Public Property ImageQuality As Integer
Visual C++
public:
property int ImageQuality {
    int get ();
    void set (int value);
}

See Also

PdfExportFilter Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


ImageResolution Property

[image]

.NET ModelKit Suite ClassReference
PdfExportFilter..::.ImageResolution Property
PdfExportFilter Class See Also Send Feedback
Gets and sets image resolution if needed.

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public int ImageResolution { get; set; }
Visual Basic (Declaration)
Public Property ImageResolution As Integer
Visual C++
public:
property int ImageResolution {
    int get ();
    void set (int value);
}

See Also

PdfExportFilter Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


KeepOriginalImageResolutionAndQuality Property

[image]

.NET ModelKit Suite ClassReference
PdfExportFilter..::.KeepOriginalImageResolutionAndQuality Property
PdfExportFilter Class See Also Send Feedback
Gets and sets whether image resolution and quality will be stored in the result pdf file.

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public bool KeepOriginalImageResolutionAndQuality { get; set; }
Visual Basic (Declaration)
Public Property KeepOriginalImageResolutionAndQuality As Boolean
Visual C++
public:
property bool KeepOriginalImageResolutionAndQuality {
    bool get ();
    void set (bool value);
}

See Also

PdfExportFilter Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


PdfExportFilter Events

[image] [image]

.NET ModelKit Suite ClassReference
PdfExportFilter Events
PdfExportFilter Class See Also Send Feedback

The PdfExportFilter type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

PdfExportFilter Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


PdfExportFilterFactory Class

[image]

.NET ModelKit Suite ClassReference
PdfExportFilterFactory Class
Members See Also Send Feedback
Creates PdfExportFilter instaces.

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public class PdfExportFilterFactory : ExportFilterFactory
Visual Basic (Declaration)
Public Class PdfExportFilterFactory _
    Inherits ExportFilterFactory
Visual C++
public ref class PdfExportFilterFactory : public ExportFilterFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export..::.ExportFilterFactory
PerpetuumSoft.Reporting.Export.Pdf..::.PdfExportFilterFactory

See Also

PdfExportFilterFactory Members
PerpetuumSoft.Reporting.Export.Pdf Namespace


PdfExportFilterFactory Members

[image] [image]

.NET ModelKit Suite ClassReference
PdfExportFilterFactory Members
PdfExportFilterFactory Class Methods Properties See Also Send Feedback

The PdfExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Overrided. See CreateFilter()()(). (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Overrided. See GetFilterFileExtension()()(). (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Overrided. See GetFilterFormat()()(). (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Factory | Gets default instance of the PdfExportFilterFactory class.

See Also

PdfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


PdfExportFilterFactory Methods

[image] [image]

.NET ModelKit Suite ClassReference
PdfExportFilterFactory Methods
PdfExportFilterFactory Class See Also Send Feedback

The PdfExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Overrided. See CreateFilter()()(). (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Overrided. See GetFilterFileExtension()()(). (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Overrided. See GetFilterFormat()()(). (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PdfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


CreateFilter Method

[image]

.NET ModelKit Suite ClassReference
PdfExportFilterFactory..::.CreateFilter Method
PdfExportFilterFactory Class See Also Send Feedback
Overrided. See CreateFilter()()().

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilter CreateFilter()
Visual Basic (Declaration)
Public Overrides Function CreateFilter As ExportFilter
Visual C++
public:
virtual ExportFilter^ CreateFilter() override

See Also

PdfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


GetFilterFileExtension Method

[image]

.NET ModelKit Suite ClassReference
PdfExportFilterFactory..::.GetFilterFileExtension Method
PdfExportFilterFactory Class See Also Send Feedback
Overrided. See GetFilterFileExtension()()().

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFileExtension()
Visual Basic (Declaration)
Public Overrides Function GetFilterFileExtension As String
Visual C++
public:
virtual String^ GetFilterFileExtension() override

See Also

PdfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


GetFilterFormat Method

[image]

.NET ModelKit Suite ClassReference
PdfExportFilterFactory..::.GetFilterFormat Method
PdfExportFilterFactory Class See Also Send Feedback
Overrided. See GetFilterFormat()()().

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFormat()
Visual Basic (Declaration)
Public Overrides Function GetFilterFormat As String
Visual C++
public:
virtual String^ GetFilterFormat() override

See Also

PdfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


PdfExportFilterFactory Properties

[image] [image]

.NET ModelKit Suite ClassReference
PdfExportFilterFactory Properties
PdfExportFilterFactory Class See Also Send Feedback

The PdfExportFilterFactory type exposes the following members.

Properties

Name | Description
Factory | Gets default instance of the PdfExportFilterFactory class.

See Also

PdfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


Factory Property

[image]

.NET ModelKit Suite ClassReference
PdfExportFilterFactory..::.Factory Property
PdfExportFilterFactory Class See Also Send Feedback
Gets default instance of the PdfExportFilterFactory class.

Namespace: PerpetuumSoft.Reporting.Export.Pdf
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public static PdfExportFilterFactory Factory { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Factory As PdfExportFilterFactory
Visual C++
public:
static property PdfExportFilterFactory^ Factory {
    PdfExportFilterFactory^ get ();
}

See Also

PdfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Pdf Namespace


PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace
Send Feedback
The PerpetuumSoft.Reporting.Export.PDF.Adapters namespace contains classes which are used to export document elements to the PDF (Portable Document Format) format.

Classes

Class | Description
AdvancedTextPdfAdapter | Represents adapter for the AdvancedText class.
BoxPdfAdapter | Represents adapter for the Box class.
PdfAdapter | Incapsulates conversion methods for different types of report controls.
PicturePdfAdapter | Represents adapter for the Picture class.
ReportControlPdfAdapter | Represents adapter for the ReportControl class.
RichTextPdfAdapter | Represents adapter for the RichText class.
ShapePdfAdapter | Represents adapter for the Shape class.
TextBoxPdfAdapter | Represents adapter for the TextBox class.


AdvancedTextPdfAdapter Class

[image]

.NET ModelKit Suite ClassReference
AdvancedTextPdfAdapter Class
Members See Also Send Feedback
Represents adapter for the AdvancedText class.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public class AdvancedTextPdfAdapter : BoxPdfAdapter
Visual Basic (Declaration)
Public Class AdvancedTextPdfAdapter _
    Inherits BoxPdfAdapter
Visual C++
public ref class AdvancedTextPdfAdapter : public BoxPdfAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.PdfAdapter
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.BoxPdfAdapter
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.AdvancedTextPdfAdapter

See Also

AdvancedTextPdfAdapter Members
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


AdvancedTextPdfAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextPdfAdapter Members
AdvancedTextPdfAdapter Class Constructors Methods Fields Properties See Also Send Feedback

The AdvancedTextPdfAdapter type exposes the following members.

Constructors

Name | Description
AdvancedTextPdfAdapter | Creates a new instance of AdvancedTextPdfAdapter class.

Methods

Name | Description
Dispose | Implements Dispose()()(). (Inherited from PdfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTempGraphics | Returns temporary Graphics. (Inherited from PdfAdapter.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(PdfWriter). (Inherited from BoxPdfAdapter.)
RenderContent | Overridden. See RenderContent(PdfWriter). (Overrides BoxPdfAdapter..::.RenderContent(PdfWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteHyperlink | Writes HyperLink into a PDF document. (Inherited from PdfAdapter.)

Fields

Name | Description
control | Base ReportControl. (Inherited from PdfAdapter.)

Properties

Name | Description
ContentRectangle | Gets the content rectangle of a Box control. (Inherited from BoxPdfAdapter.)
Location | Control location. (Inherited from PdfAdapter.)
Size | Control size. (Inherited from PdfAdapter.)

See Also

AdvancedTextPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


AdvancedTextPdfAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
AdvancedTextPdfAdapter Constructor
AdvancedTextPdfAdapter Class See Also Send Feedback
Creates a new instance of AdvancedTextPdfAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public AdvancedTextPdfAdapter(
    ReportControl control
)
Visual Basic (Declaration)
Public Sub New ( _
    control As ReportControl _
)
Visual C++
public:
AdvancedTextPdfAdapter(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

AdvancedTextPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


AdvancedTextPdfAdapter Fields

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextPdfAdapter Fields
AdvancedTextPdfAdapter Class See Also Send Feedback

The AdvancedTextPdfAdapter type exposes the following members.

Fields

Name | Description
control | Base ReportControl. (Inherited from PdfAdapter.)

See Also

AdvancedTextPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


AdvancedTextPdfAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextPdfAdapter Methods
AdvancedTextPdfAdapter Class See Also Send Feedback

The AdvancedTextPdfAdapter type exposes the following members.

Methods

Name | Description
Dispose | Implements Dispose()()(). (Inherited from PdfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTempGraphics | Returns temporary Graphics. (Inherited from PdfAdapter.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(PdfWriter). (Inherited from BoxPdfAdapter.)
RenderContent | Overridden. See RenderContent(PdfWriter). (Overrides BoxPdfAdapter..::.RenderContent(PdfWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteHyperlink | Writes HyperLink into a PDF document. (Inherited from PdfAdapter.)

See Also

AdvancedTextPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


RenderContent Method

[image]

.NET ModelKit Suite ClassReference
AdvancedTextPdfAdapter..::.RenderContent Method
AdvancedTextPdfAdapter Class See Also Send Feedback
Overridden. See RenderContent(PdfWriter).

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public override void RenderContent(
    PdfWriter pdfWriter
)
Visual Basic (Declaration)
Public Overrides Sub RenderContent ( _
    pdfWriter As PdfWriter _
)
Visual C++
public:
virtual void RenderContent(
    PdfWriter^ pdfWriter
) override

Parameters

pdfWriter
Type: PdfWriter

See Also

AdvancedTextPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


AdvancedTextPdfAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextPdfAdapter Properties
AdvancedTextPdfAdapter Class See Also Send Feedback

The AdvancedTextPdfAdapter type exposes the following members.

Properties

Name | Description
ContentRectangle | Gets the content rectangle of a Box control. (Inherited from BoxPdfAdapter.)
Location | Control location. (Inherited from PdfAdapter.)
Size | Control size. (Inherited from PdfAdapter.)

See Also

AdvancedTextPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


BoxPdfAdapter Class

[image]

.NET ModelKit Suite ClassReference
BoxPdfAdapter Class
Members See Also Send Feedback
Represents adapter for the Box class.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public class BoxPdfAdapter : PdfAdapter
Visual Basic (Declaration)
Public Class BoxPdfAdapter _
    Inherits PdfAdapter
Visual C++
public ref class BoxPdfAdapter : public PdfAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.PdfAdapter
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.BoxPdfAdapter
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.AdvancedTextPdfAdapter
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.PicturePdfAdapter
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.RichTextPdfAdapter
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.ShapePdfAdapter
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.TextBoxPdfAdapter

See Also

BoxPdfAdapter Members
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


BoxPdfAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
BoxPdfAdapter Members
BoxPdfAdapter Class Constructors Methods Fields Properties See Also Send Feedback

The BoxPdfAdapter type exposes the following members.

Constructors

Name | Description
BoxPdfAdapter | Creates a new instance for BoxPdfAdapter class.

Methods

Name | Description
Dispose | Implements Dispose()()(). (Inherited from PdfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTempGraphics | Returns temporary Graphics. (Inherited from PdfAdapter.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(PdfWriter). (Overrides PdfAdapter..::.Render(PdfWriter).)
RenderContent | Renders contents into PDF.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteHyperlink | Writes HyperLink into a PDF document. (Inherited from PdfAdapter.)

Fields

Name | Description
control | Base ReportControl. (Inherited from PdfAdapter.)

Properties

Name | Description
ContentRectangle | Gets the content rectangle of a Box control.
Location | Control location. (Inherited from PdfAdapter.)
Size | Control size. (Inherited from PdfAdapter.)

See Also

BoxPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


BoxPdfAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
BoxPdfAdapter Constructor
BoxPdfAdapter Class See Also Send Feedback
Creates a new instance for BoxPdfAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public BoxPdfAdapter(
    ReportControl control
)
Visual Basic (Declaration)
Public Sub New ( _
    control As ReportControl _
)
Visual C++
public:
BoxPdfAdapter(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

BoxPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


BoxPdfAdapter Fields

[image] [image]

.NET ModelKit Suite ClassReference
BoxPdfAdapter Fields
BoxPdfAdapter Class See Also Send Feedback

The BoxPdfAdapter type exposes the following members.

Fields

Name | Description
control | Base ReportControl. (Inherited from PdfAdapter.)

See Also

BoxPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


BoxPdfAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
BoxPdfAdapter Methods
BoxPdfAdapter Class See Also Send Feedback

The BoxPdfAdapter type exposes the following members.

Methods

Name | Description
Dispose | Implements Dispose()()(). (Inherited from PdfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTempGraphics | Returns temporary Graphics. (Inherited from PdfAdapter.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(PdfWriter). (Overrides PdfAdapter..::.Render(PdfWriter).)
RenderContent | Renders contents into PDF.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteHyperlink | Writes HyperLink into a PDF document. (Inherited from PdfAdapter.)

See Also

BoxPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
BoxPdfAdapter..::.Render Method
BoxPdfAdapter Class See Also Send Feedback
Overridden. See Render(PdfWriter).

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public override void Render(
    PdfWriter pdfWriter
)
Visual Basic (Declaration)
Public Overrides Sub Render ( _
    pdfWriter As PdfWriter _
)
Visual C++
public:
virtual void Render(
    PdfWriter^ pdfWriter
) override

Parameters

pdfWriter
Type: PdfWriter

See Also

BoxPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


RenderContent Method

[image]

.NET ModelKit Suite ClassReference
BoxPdfAdapter..::.RenderContent Method
BoxPdfAdapter Class See Also Send Feedback
Renders contents into PDF.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public virtual void RenderContent(
    PdfWriter pdfWriter
)
Visual Basic (Declaration)
Public Overridable Sub RenderContent ( _
    pdfWriter As PdfWriter _
)
Visual C++
public:
virtual void RenderContent(
    PdfWriter^ pdfWriter
)

Parameters

pdfWriter
Type: PdfWriter

See Also

BoxPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


BoxPdfAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
BoxPdfAdapter Properties
BoxPdfAdapter Class See Also Send Feedback

The BoxPdfAdapter type exposes the following members.

Properties

Name | Description
ContentRectangle | Gets the content rectangle of a Box control.
Location | Control location. (Inherited from PdfAdapter.)
Size | Control size. (Inherited from PdfAdapter.)

See Also

BoxPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


ContentRectangle Property

[image]

.NET ModelKit Suite ClassReference
BoxPdfAdapter..::.ContentRectangle Property
BoxPdfAdapter Class See Also Send Feedback
Gets the content rectangle of a Box control.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle ContentRectangle { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentRectangle As VectorRectangle
Visual C++
public:
property VectorRectangle ContentRectangle {
    VectorRectangle get ();
}

See Also

BoxPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


PdfAdapter Class

[image]

.NET ModelKit Suite ClassReference
PdfAdapter Class
Members See Also Send Feedback
Incapsulates conversion methods for different types of report controls.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public abstract class PdfAdapter : IDisposable
Visual Basic (Declaration)
Public MustInherit Class PdfAdapter _
    Implements IDisposable
Visual C++
public ref class PdfAdapter abstract : IDisposable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.PdfAdapter
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.BoxPdfAdapter
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.ReportControlPdfAdapter

See Also

PdfAdapter Members
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


PdfAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
PdfAdapter Members
PdfAdapter Class Constructors Methods Fields Properties See Also Send Feedback

The PdfAdapter type exposes the following members.

Constructors

Name | Description
PdfAdapter | Default constructor for PdfAdapter.

Methods

Name | Description
Dispose | Implements Dispose()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTempGraphics | Returns temporary Graphics.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Renders control to Pdf.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteHyperlink | Writes HyperLink into a PDF document.

Fields

Name | Description
control | Base ReportControl.

Properties

Name | Description
Location | Control location.
Size | Control size.

See Also

PdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


PdfAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
PdfAdapter Constructor
PdfAdapter Class See Also Send Feedback
Default constructor for PdfAdapter.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public PdfAdapter(
    ReportControl control
)
Visual Basic (Declaration)
Public Sub New ( _
    control As ReportControl _
)
Visual C++
public:
PdfAdapter(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

PdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


PdfAdapter Fields

[image] [image]

.NET ModelKit Suite ClassReference
PdfAdapter Fields
PdfAdapter Class See Also Send Feedback

The PdfAdapter type exposes the following members.

Fields

Name | Description
control | Base ReportControl.

See Also

PdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


control Field

[image]

.NET ModelKit Suite ClassReference
PdfAdapter..::.control Field
PdfAdapter Class See Also Send Feedback
Base ReportControl.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
protected ReportControl control
Visual Basic (Declaration)
Protected control As ReportControl
Visual C++
protected:
ReportControl^ control

See Also

PdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


PdfAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
PdfAdapter Methods
PdfAdapter Class See Also Send Feedback

The PdfAdapter type exposes the following members.

Methods

Name | Description
Dispose | Implements Dispose()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTempGraphics | Returns temporary Graphics.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Renders control to Pdf.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteHyperlink | Writes HyperLink into a PDF document.

See Also

PdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


Dispose Method

[image]

.NET ModelKit Suite ClassReference
PdfAdapter..::.Dispose Method
PdfAdapter Class See Also Send Feedback
Implements Dispose()()().

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

PdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


GetTempGraphics Method

[image]

.NET ModelKit Suite ClassReference
PdfAdapter..::.GetTempGraphics Method
PdfAdapter Class See Also Send Feedback
Returns temporary Graphics.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
protected Graphics GetTempGraphics()
Visual Basic (Declaration)
Protected Function GetTempGraphics As Graphics
Visual C++
protected:
Graphics^ GetTempGraphics()

See Also

PdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
PdfAdapter..::.Render Method
PdfAdapter Class See Also Send Feedback
Renders control to Pdf.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public abstract void Render(
    PdfWriter pdfWriter
)
Visual Basic (Declaration)
Public MustOverride Sub Render ( _
    pdfWriter As PdfWriter _
)
Visual C++
public:
virtual void Render(
    PdfWriter^ pdfWriter
) abstract

Parameters

pdfWriter
Type: PdfWriter

See Also

PdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


WriteHyperlink Method

[image]

.NET ModelKit Suite ClassReference
PdfAdapter..::.WriteHyperlink Method
PdfAdapter Class See Also Send Feedback
Writes HyperLink into a PDF document.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
protected void WriteHyperlink(
    PdfWriter pdfWriter
)
Visual Basic (Declaration)
Protected Sub WriteHyperlink ( _
    pdfWriter As PdfWriter _
)
Visual C++
protected:
void WriteHyperlink(
    PdfWriter^ pdfWriter
)

Parameters

pdfWriter
Type: PdfWriter

See Also

PdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


PdfAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
PdfAdapter Properties
PdfAdapter Class See Also Send Feedback

The PdfAdapter type exposes the following members.

Properties

Name | Description
Location | Control location.
Size | Control size.

See Also

PdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


Location Property

[image]

.NET ModelKit Suite ClassReference
PdfAdapter..::.Location Property
PdfAdapter Class See Also Send Feedback
Control location.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public PointF Location { get; }
Visual Basic (Declaration)
Public ReadOnly Property Location As PointF
Visual C++
public:
property PointF Location {
    PointF get ();
}

See Also

PdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


Size Property

[image]

.NET ModelKit Suite ClassReference
PdfAdapter..::.Size Property
PdfAdapter Class See Also Send Feedback
Control size.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public SizeF Size { get; }
Visual Basic (Declaration)
Public ReadOnly Property Size As SizeF
Visual C++
public:
property SizeF Size {
    SizeF get ();
}

See Also

PdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


PicturePdfAdapter Class

[image]

.NET ModelKit Suite ClassReference
PicturePdfAdapter Class
Members See Also Send Feedback
Represents adapter for the Picture class.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public class PicturePdfAdapter : BoxPdfAdapter
Visual Basic (Declaration)
Public Class PicturePdfAdapter _
    Inherits BoxPdfAdapter
Visual C++
public ref class PicturePdfAdapter : public BoxPdfAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.PdfAdapter
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.BoxPdfAdapter
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.PicturePdfAdapter

See Also

PicturePdfAdapter Members
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


PicturePdfAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
PicturePdfAdapter Members
PicturePdfAdapter Class Constructors Methods Fields Properties See Also Send Feedback

The PicturePdfAdapter type exposes the following members.

Constructors

Name | Description
PicturePdfAdapter | Default constructor fo PicturePdfAdapter.

Methods

Name | Description
Dispose | Implements Dispose()()(). (Inherited from PdfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTempGraphics | Returns temporary Graphics. (Inherited from PdfAdapter.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(PdfWriter). (Inherited from BoxPdfAdapter.)
RenderContent | Overridden. See RenderContent(PdfWriter). (Overrides BoxPdfAdapter..::.RenderContent(PdfWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteHyperlink | Writes HyperLink into a PDF document. (Inherited from PdfAdapter.)

Fields

Name | Description
control | Base ReportControl. (Inherited from PdfAdapter.)

Properties

Name | Description
ContentRectangle | Gets the content rectangle of a Box control. (Inherited from BoxPdfAdapter.)
Location | Control location. (Inherited from PdfAdapter.)
Size | Control size. (Inherited from PdfAdapter.)

See Also

PicturePdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


PicturePdfAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
PicturePdfAdapter Constructor
PicturePdfAdapter Class See Also Send Feedback
Default constructor fo PicturePdfAdapter.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public PicturePdfAdapter(
    ReportControl control
)
Visual Basic (Declaration)
Public Sub New ( _
    control As ReportControl _
)
Visual C++
public:
PicturePdfAdapter(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

PicturePdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


PicturePdfAdapter Fields

[image] [image]

.NET ModelKit Suite ClassReference
PicturePdfAdapter Fields
PicturePdfAdapter Class See Also Send Feedback

The PicturePdfAdapter type exposes the following members.

Fields

Name | Description
control | Base ReportControl. (Inherited from PdfAdapter.)

See Also

PicturePdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


PicturePdfAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
PicturePdfAdapter Methods
PicturePdfAdapter Class See Also Send Feedback

The PicturePdfAdapter type exposes the following members.

Methods

Name | Description
Dispose | Implements Dispose()()(). (Inherited from PdfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTempGraphics | Returns temporary Graphics. (Inherited from PdfAdapter.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(PdfWriter). (Inherited from BoxPdfAdapter.)
RenderContent | Overridden. See RenderContent(PdfWriter). (Overrides BoxPdfAdapter..::.RenderContent(PdfWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteHyperlink | Writes HyperLink into a PDF document. (Inherited from PdfAdapter.)

See Also

PicturePdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


RenderContent Method

[image]

.NET ModelKit Suite ClassReference
PicturePdfAdapter..::.RenderContent Method
PicturePdfAdapter Class See Also Send Feedback
Overridden. See RenderContent(PdfWriter).

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public override void RenderContent(
    PdfWriter pdfWriter
)
Visual Basic (Declaration)
Public Overrides Sub RenderContent ( _
    pdfWriter As PdfWriter _
)
Visual C++
public:
virtual void RenderContent(
    PdfWriter^ pdfWriter
) override

Parameters

pdfWriter
Type: PdfWriter

See Also

PicturePdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


PicturePdfAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
PicturePdfAdapter Properties
PicturePdfAdapter Class See Also Send Feedback

The PicturePdfAdapter type exposes the following members.

Properties

Name | Description
ContentRectangle | Gets the content rectangle of a Box control. (Inherited from BoxPdfAdapter.)
Location | Control location. (Inherited from PdfAdapter.)
Size | Control size. (Inherited from PdfAdapter.)

See Also

PicturePdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


ReportControlPdfAdapter Class

[image]

.NET ModelKit Suite ClassReference
ReportControlPdfAdapter Class
Members See Also Send Feedback
Represents adapter for the ReportControl class.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public class ReportControlPdfAdapter : PdfAdapter
Visual Basic (Declaration)
Public Class ReportControlPdfAdapter _
    Inherits PdfAdapter
Visual C++
public ref class ReportControlPdfAdapter : public PdfAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.PdfAdapter
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.ReportControlPdfAdapter

See Also

ReportControlPdfAdapter Members
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


ReportControlPdfAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlPdfAdapter Members
ReportControlPdfAdapter Class Constructors Methods Fields Properties See Also Send Feedback

The ReportControlPdfAdapter type exposes the following members.

Constructors

Name | Description
ReportControlPdfAdapter | Default constructor for ReportControlPdfAdapter.

Methods

Name | Description
Dispose | Implements Dispose()()(). (Inherited from PdfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTempGraphics | Returns temporary Graphics. (Inherited from PdfAdapter.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(PdfWriter). (Overrides PdfAdapter..::.Render(PdfWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteHyperlink | Writes HyperLink into a PDF document. (Inherited from PdfAdapter.)

Fields

Name | Description
control | Base ReportControl. (Inherited from PdfAdapter.)

Properties

Name | Description
Location | Control location. (Inherited from PdfAdapter.)
Size | Control size. (Inherited from PdfAdapter.)

See Also

ReportControlPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


ReportControlPdfAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
ReportControlPdfAdapter Constructor
ReportControlPdfAdapter Class See Also Send Feedback
Default constructor for ReportControlPdfAdapter.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public ReportControlPdfAdapter(
    ReportControl control
)
Visual Basic (Declaration)
Public Sub New ( _
    control As ReportControl _
)
Visual C++
public:
ReportControlPdfAdapter(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ReportControlPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


ReportControlPdfAdapter Fields

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlPdfAdapter Fields
ReportControlPdfAdapter Class See Also Send Feedback

The ReportControlPdfAdapter type exposes the following members.

Fields

Name | Description
control | Base ReportControl. (Inherited from PdfAdapter.)

See Also

ReportControlPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


ReportControlPdfAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlPdfAdapter Methods
ReportControlPdfAdapter Class See Also Send Feedback

The ReportControlPdfAdapter type exposes the following members.

Methods

Name | Description
Dispose | Implements Dispose()()(). (Inherited from PdfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTempGraphics | Returns temporary Graphics. (Inherited from PdfAdapter.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(PdfWriter). (Overrides PdfAdapter..::.Render(PdfWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteHyperlink | Writes HyperLink into a PDF document. (Inherited from PdfAdapter.)

See Also

ReportControlPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
ReportControlPdfAdapter..::.Render Method
ReportControlPdfAdapter Class See Also Send Feedback
Overridden. See Render(PdfWriter).

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public override void Render(
    PdfWriter pdfWriter
)
Visual Basic (Declaration)
Public Overrides Sub Render ( _
    pdfWriter As PdfWriter _
)
Visual C++
public:
virtual void Render(
    PdfWriter^ pdfWriter
) override

Parameters

pdfWriter
Type: PdfWriter

See Also

ReportControlPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


ReportControlPdfAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlPdfAdapter Properties
ReportControlPdfAdapter Class See Also Send Feedback

The ReportControlPdfAdapter type exposes the following members.

Properties

Name | Description
Location | Control location. (Inherited from PdfAdapter.)
Size | Control size. (Inherited from PdfAdapter.)

See Also

ReportControlPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


RichTextPdfAdapter Class

[image]

.NET ModelKit Suite ClassReference
RichTextPdfAdapter Class
Members See Also Send Feedback
Represents adapter for the RichText class.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public class RichTextPdfAdapter : BoxPdfAdapter
Visual Basic (Declaration)
Public Class RichTextPdfAdapter _
    Inherits BoxPdfAdapter
Visual C++
public ref class RichTextPdfAdapter : public BoxPdfAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.PdfAdapter
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.BoxPdfAdapter
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.RichTextPdfAdapter

See Also

RichTextPdfAdapter Members
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


RichTextPdfAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
RichTextPdfAdapter Members
RichTextPdfAdapter Class Constructors Methods Fields Properties See Also Send Feedback

The RichTextPdfAdapter type exposes the following members.

Constructors

Name | Description
RichTextPdfAdapter | Default constructor for TextBoxPdfAdapter.

Methods

Name | Description
Dispose | Implements Dispose()()(). (Inherited from PdfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTempGraphics | Returns temporary Graphics. (Inherited from PdfAdapter.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(PdfWriter). (Inherited from BoxPdfAdapter.)
RenderContent | Overridden. See RenderContent(PdfWriter). (Overrides BoxPdfAdapter..::.RenderContent(PdfWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteHyperlink | Writes HyperLink into a PDF document. (Inherited from PdfAdapter.)

Fields

Name | Description
control | Base ReportControl. (Inherited from PdfAdapter.)

Properties

Name | Description
ContentRectangle | Gets the content rectangle of a Box control. (Inherited from BoxPdfAdapter.)
Location | Control location. (Inherited from PdfAdapter.)
Size | Control size. (Inherited from PdfAdapter.)

See Also

RichTextPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


RichTextPdfAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
RichTextPdfAdapter Constructor
RichTextPdfAdapter Class See Also Send Feedback
Default constructor for TextBoxPdfAdapter.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public RichTextPdfAdapter(
    ReportControl control
)
Visual Basic (Declaration)
Public Sub New ( _
    control As ReportControl _
)
Visual C++
public:
RichTextPdfAdapter(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

RichTextPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


RichTextPdfAdapter Fields

[image] [image]

.NET ModelKit Suite ClassReference
RichTextPdfAdapter Fields
RichTextPdfAdapter Class See Also Send Feedback

The RichTextPdfAdapter type exposes the following members.

Fields

Name | Description
control | Base ReportControl. (Inherited from PdfAdapter.)

See Also

RichTextPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


RichTextPdfAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
RichTextPdfAdapter Methods
RichTextPdfAdapter Class See Also Send Feedback

The RichTextPdfAdapter type exposes the following members.

Methods

Name | Description
Dispose | Implements Dispose()()(). (Inherited from PdfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTempGraphics | Returns temporary Graphics. (Inherited from PdfAdapter.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(PdfWriter). (Inherited from BoxPdfAdapter.)
RenderContent | Overridden. See RenderContent(PdfWriter). (Overrides BoxPdfAdapter..::.RenderContent(PdfWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteHyperlink | Writes HyperLink into a PDF document. (Inherited from PdfAdapter.)

See Also

RichTextPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


RenderContent Method

[image]

.NET ModelKit Suite ClassReference
RichTextPdfAdapter..::.RenderContent Method
RichTextPdfAdapter Class See Also Send Feedback
Overridden. See RenderContent(PdfWriter).

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public override void RenderContent(
    PdfWriter pdfWriter
)
Visual Basic (Declaration)
Public Overrides Sub RenderContent ( _
    pdfWriter As PdfWriter _
)
Visual C++
public:
virtual void RenderContent(
    PdfWriter^ pdfWriter
) override

Parameters

pdfWriter
Type: PdfWriter

See Also

RichTextPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


RichTextPdfAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
RichTextPdfAdapter Properties
RichTextPdfAdapter Class See Also Send Feedback

The RichTextPdfAdapter type exposes the following members.

Properties

Name | Description
ContentRectangle | Gets the content rectangle of a Box control. (Inherited from BoxPdfAdapter.)
Location | Control location. (Inherited from PdfAdapter.)
Size | Control size. (Inherited from PdfAdapter.)

See Also

RichTextPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


ShapePdfAdapter Class

[image]

.NET ModelKit Suite ClassReference
ShapePdfAdapter Class
Members See Also Send Feedback
Represents adapter for the Shape class.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public class ShapePdfAdapter : BoxPdfAdapter
Visual Basic (Declaration)
Public Class ShapePdfAdapter _
    Inherits BoxPdfAdapter
Visual C++
public ref class ShapePdfAdapter : public BoxPdfAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.PdfAdapter
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.BoxPdfAdapter
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.ShapePdfAdapter

See Also

ShapePdfAdapter Members
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


ShapePdfAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
ShapePdfAdapter Members
ShapePdfAdapter Class Constructors Methods Fields Properties See Also Send Feedback

The ShapePdfAdapter type exposes the following members.

Constructors

Name | Description
ShapePdfAdapter | Default constructor for ShapePdfAdapter.

Methods

Name | Description
Dispose | Implements Dispose()()(). (Inherited from PdfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTempGraphics | Returns temporary Graphics. (Inherited from PdfAdapter.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(PdfWriter). (Overrides BoxPdfAdapter..::.Render(PdfWriter).)
RenderContent | Renders contents into PDF. (Inherited from BoxPdfAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteHyperlink | Writes HyperLink into a PDF document. (Inherited from PdfAdapter.)

Fields

Name | Description
control | Base ReportControl. (Inherited from PdfAdapter.)

Properties

Name | Description
ContentRectangle | Gets the content rectangle of a Box control. (Inherited from BoxPdfAdapter.)
Location | Control location. (Inherited from PdfAdapter.)
Size | Control size. (Inherited from PdfAdapter.)

See Also

ShapePdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


ShapePdfAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
ShapePdfAdapter Constructor
ShapePdfAdapter Class See Also Send Feedback
Default constructor for ShapePdfAdapter.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public ShapePdfAdapter(
    ReportControl control
)
Visual Basic (Declaration)
Public Sub New ( _
    control As ReportControl _
)
Visual C++
public:
ShapePdfAdapter(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ShapePdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


ShapePdfAdapter Fields

[image] [image]

.NET ModelKit Suite ClassReference
ShapePdfAdapter Fields
ShapePdfAdapter Class See Also Send Feedback

The ShapePdfAdapter type exposes the following members.

Fields

Name | Description
control | Base ReportControl. (Inherited from PdfAdapter.)

See Also

ShapePdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


ShapePdfAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ShapePdfAdapter Methods
ShapePdfAdapter Class See Also Send Feedback

The ShapePdfAdapter type exposes the following members.

Methods

Name | Description
Dispose | Implements Dispose()()(). (Inherited from PdfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTempGraphics | Returns temporary Graphics. (Inherited from PdfAdapter.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(PdfWriter). (Overrides BoxPdfAdapter..::.Render(PdfWriter).)
RenderContent | Renders contents into PDF. (Inherited from BoxPdfAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteHyperlink | Writes HyperLink into a PDF document. (Inherited from PdfAdapter.)

See Also

ShapePdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
ShapePdfAdapter..::.Render Method
ShapePdfAdapter Class See Also Send Feedback
Overridden. See Render(PdfWriter).

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public override void Render(
    PdfWriter pdfWriter
)
Visual Basic (Declaration)
Public Overrides Sub Render ( _
    pdfWriter As PdfWriter _
)
Visual C++
public:
virtual void Render(
    PdfWriter^ pdfWriter
) override

Parameters

pdfWriter
Type: PdfWriter

See Also

ShapePdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


ShapePdfAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
ShapePdfAdapter Properties
ShapePdfAdapter Class See Also Send Feedback

The ShapePdfAdapter type exposes the following members.

Properties

Name | Description
ContentRectangle | Gets the content rectangle of a Box control. (Inherited from BoxPdfAdapter.)
Location | Control location. (Inherited from PdfAdapter.)
Size | Control size. (Inherited from PdfAdapter.)

See Also

ShapePdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


TextBoxPdfAdapter Class

[image]

.NET ModelKit Suite ClassReference
TextBoxPdfAdapter Class
Members See Also Send Feedback
Represents adapter for the TextBox class.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public class TextBoxPdfAdapter : BoxPdfAdapter
Visual Basic (Declaration)
Public Class TextBoxPdfAdapter _
    Inherits BoxPdfAdapter
Visual C++
public ref class TextBoxPdfAdapter : public BoxPdfAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.PdfAdapter
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.BoxPdfAdapter
PerpetuumSoft.Reporting.Export.Pdf.Adapters..::.TextBoxPdfAdapter

See Also

TextBoxPdfAdapter Members
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


TextBoxPdfAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxPdfAdapter Members
TextBoxPdfAdapter Class Constructors Methods Fields Properties See Also Send Feedback

The TextBoxPdfAdapter type exposes the following members.

Constructors

Name | Description
TextBoxPdfAdapter | Default constructor for TextBoxPdfAdapter.

Methods

Name | Description
Dispose | Implements Dispose()()(). (Inherited from PdfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTempGraphics | Returns temporary Graphics. (Inherited from PdfAdapter.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(PdfWriter). (Inherited from BoxPdfAdapter.)
RenderContent | Overridden. See RenderContent(PdfWriter). (Overrides BoxPdfAdapter..::.RenderContent(PdfWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteHyperlink | Writes HyperLink into a PDF document. (Inherited from PdfAdapter.)

Fields

Name | Description
control | Base ReportControl. (Inherited from PdfAdapter.)

Properties

Name | Description
ContentRectangle | Gets the content rectangle of a Box control. (Inherited from BoxPdfAdapter.)
Location | Control location. (Inherited from PdfAdapter.)
Size | Control size. (Inherited from PdfAdapter.)

See Also

TextBoxPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


TextBoxPdfAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
TextBoxPdfAdapter Constructor
TextBoxPdfAdapter Class See Also Send Feedback
Default constructor for TextBoxPdfAdapter.

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public TextBoxPdfAdapter(
    ReportControl control
)
Visual Basic (Declaration)
Public Sub New ( _
    control As ReportControl _
)
Visual C++
public:
TextBoxPdfAdapter(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

TextBoxPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


TextBoxPdfAdapter Fields

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxPdfAdapter Fields
TextBoxPdfAdapter Class See Also Send Feedback

The TextBoxPdfAdapter type exposes the following members.

Fields

Name | Description
control | Base ReportControl. (Inherited from PdfAdapter.)

See Also

TextBoxPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


TextBoxPdfAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxPdfAdapter Methods
TextBoxPdfAdapter Class See Also Send Feedback

The TextBoxPdfAdapter type exposes the following members.

Methods

Name | Description
Dispose | Implements Dispose()()(). (Inherited from PdfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTempGraphics | Returns temporary Graphics. (Inherited from PdfAdapter.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(PdfWriter). (Inherited from BoxPdfAdapter.)
RenderContent | Overridden. See RenderContent(PdfWriter). (Overrides BoxPdfAdapter..::.RenderContent(PdfWriter).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteHyperlink | Writes HyperLink into a PDF document. (Inherited from PdfAdapter.)

See Also

TextBoxPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


RenderContent Method

[image]

.NET ModelKit Suite ClassReference
TextBoxPdfAdapter..::.RenderContent Method
TextBoxPdfAdapter Class See Also Send Feedback
Overridden. See RenderContent(PdfWriter).

Namespace: PerpetuumSoft.Reporting.Export.Pdf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Pdf (in PerpetuumSoft.Reporting.Export.Pdf.dll) Version: 3.9.0.1

Syntax

C#
public override void RenderContent(
    PdfWriter pdfWriter
)
Visual Basic (Declaration)
Public Overrides Sub RenderContent ( _
    pdfWriter As PdfWriter _
)
Visual C++
public:
virtual void RenderContent(
    PdfWriter^ pdfWriter
) override

Parameters

pdfWriter
Type: PdfWriter

See Also

TextBoxPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


TextBoxPdfAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxPdfAdapter Properties
TextBoxPdfAdapter Class See Also Send Feedback

The TextBoxPdfAdapter type exposes the following members.

Properties

Name | Description
ContentRectangle | Gets the content rectangle of a Box control. (Inherited from BoxPdfAdapter.)
Location | Control location. (Inherited from PdfAdapter.)
Size | Control size. (Inherited from PdfAdapter.)

See Also

TextBoxPdfAdapter Class
PerpetuumSoft.Reporting.Export.Pdf.Adapters Namespace


PerpetuumSoft.Reporting.Export.Rtf Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Export.Rtf Namespace
Send Feedback
The PerpetuumSoft.Reporting.Export.Rtf namespace contains classes which are used to export document to the RTF (Rich Text Format) format.

Classes

Class | Description
RtfExportFilter | Exports Report Sharp-Shooter documents to Rtf format.
RtfExportFilterFactory | Creates RtfExportFilter instances.
RtfFile | Represents an image of Rtf file in buffer.


RtfExportFilter Class

[image]

.NET ModelKit Suite ClassReference
RtfExportFilter Class
Members See Also Send Feedback
Exports Report Sharp-Shooter documents to Rtf format.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public class RtfExportFilter : ExportFilter
Visual Basic (Declaration)
Public Class RtfExportFilter _
    Inherits ExportFilter
Visual C++
public ref class RtfExportFilter : public ExportFilter

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Export..::.ExportFilter
PerpetuumSoft.Reporting.Export.Rtf..::.RtfExportFilter

See Also

RtfExportFilter Members
PerpetuumSoft.Reporting.Export.Rtf Namespace


RtfExportFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
RtfExportFilter Members
RtfExportFilter Class Constructors Methods Properties Events See Also Send Feedback

The RtfExportFilter type exposes the following members.

Constructors

Name | Description
RtfExportFilter | Overloaded.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindAdapter | Returns the RtfAdapter instance corresponding to the given control type.
GetFactory | Overridden. See GetFactory()()(). (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
RegisterAdapter | Registers a new adapter.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Overridden. See ShowDialog()()(). (Overrides ExportFilter..::.ShowDialog()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
Accuracy | Gets and sets filter accuracy.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
JpegQuality |
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

RtfExportFilter Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


RtfExportFilter Constructor

[image] [image]

.NET ModelKit Suite ClassReference
RtfExportFilter Constructor
RtfExportFilter Class See Also Send Feedback

Overload List

Name | Description
RtfExportFilter()()() | Creates a new instance of the RtfExportFilter class.
RtfExportFilter(IContainer) | Creates a new instance of the RtfExportFilter class.

See Also

RtfExportFilter Class
RtfExportFilter Members
PerpetuumSoft.Reporting.Export.Rtf Namespace


RtfExportFilter Constructor

[image]

.NET ModelKit Suite ClassReference
RtfExportFilter Constructor
RtfExportFilter Class See Also Send Feedback
Creates a new instance of the RtfExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public RtfExportFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RtfExportFilter()

See Also

RtfExportFilter Class
RtfExportFilter Overload
PerpetuumSoft.Reporting.Export.Rtf Namespace


RtfExportFilter Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
RtfExportFilter Constructor (IContainer)
RtfExportFilter Class See Also Send Feedback
Creates a new instance of the RtfExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public RtfExportFilter(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
RtfExportFilter(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

RtfExportFilter Class
RtfExportFilter Overload
PerpetuumSoft.Reporting.Export.Rtf Namespace


RtfExportFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
RtfExportFilter Methods
RtfExportFilter Class See Also Send Feedback

The RtfExportFilter type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindAdapter | Returns the RtfAdapter instance corresponding to the given control type.
GetFactory | Overridden. See GetFactory()()(). (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
RegisterAdapter | Registers a new adapter.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Overridden. See ShowDialog()()(). (Overrides ExportFilter..::.ShowDialog()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

RtfExportFilter Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
RtfExportFilter..::.Dispose Method
RtfExportFilter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

RtfExportFilter Class
RtfExportFilter Members
PerpetuumSoft.Reporting.Export.Rtf Namespace


Export Method

[image] [image]

.NET ModelKit Suite ClassReference
RtfExportFilter..::.Export Method
RtfExportFilter Class See Also Send Feedback

Overload List

Name | Description
Export(Document, Stream) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String, Boolean) | Exports the specified report document to the specified file and optionally shows export filter settings dialog. (Inherited from ExportFilter.)

See Also

RtfExportFilter Class
RtfExportFilter Members
PerpetuumSoft.Reporting.Export.Rtf Namespace


ExportDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
RtfExportFilter..::.ExportDocument Method
RtfExportFilter Class See Also Send Feedback

Overload List

Name | Description
ExportDocument(Document, Stream) | Exports the given document to the specified stream. (Overrides ExportFilter..::.ExportDocument(Document, Stream).)
ExportDocument(Document, String) | Exports the given document to the specified file. (Overrides ExportFilter..::.ExportDocument(Document, String).)

See Also

RtfExportFilter Class
RtfExportFilter Members
PerpetuumSoft.Reporting.Export.Rtf Namespace


ExportDocument Method (Document, Stream)

[image]

.NET ModelKit Suite ClassReference
RtfExportFilter..::.ExportDocument Method (Document, Stream)
RtfExportFilter Class See Also Send Feedback
Exports the given document to the specified stream.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
protected override void ExportDocument(
    Document document,
    Stream stream
)
Visual Basic (Declaration)
Protected Overrides Sub ExportDocument ( _
    document As Document, _
    stream As Stream _
)
Visual C++
protected:
virtual void ExportDocument(
    Document^ document,
    Stream^ stream
) override

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
stream
Type: System.IO..::.Stream

See Also

RtfExportFilter Class
ExportDocument Overload
PerpetuumSoft.Reporting.Export.Rtf Namespace


ExportDocument Method (Document, String)

[image]

.NET ModelKit Suite ClassReference
RtfExportFilter..::.ExportDocument Method (Document, String)
RtfExportFilter Class See Also Send Feedback
Exports the given document to the specified file.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
protected override void ExportDocument(
    Document document,
    string fileName
)
Visual Basic (Declaration)
Protected Overrides Sub ExportDocument ( _
    document As Document, _
    fileName As String _
)
Visual C++
protected:
virtual void ExportDocument(
    Document^ document,
    String^ fileName
) override

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
fileName
Type: System..::.String

See Also

RtfExportFilter Class
ExportDocument Overload
PerpetuumSoft.Reporting.Export.Rtf Namespace


FindAdapter Method

[image]

.NET ModelKit Suite ClassReference
RtfExportFilter..::.FindAdapter Method
RtfExportFilter Class See Also Send Feedback
Returns the RtfAdapter instance corresponding to the given control type.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public RtfAdapter FindAdapter(
    Type type
)
Visual Basic (Declaration)
Public Function FindAdapter ( _
    type As Type _
) As RtfAdapter
Visual C++
public:
RtfAdapter^ FindAdapter(
    Type^ type
)

Parameters

type
Type: System..::.Type

See Also

RtfExportFilter Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


GetFactory Method

[image]

.NET ModelKit Suite ClassReference
RtfExportFilter..::.GetFactory Method
RtfExportFilter Class See Also Send Feedback
Overridden. See GetFactory()()().

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilterFactory GetFactory()
Visual Basic (Declaration)
Public Overrides Function GetFactory As ExportFilterFactory
Visual C++
public:
virtual ExportFilterFactory^ GetFactory() override

See Also

RtfExportFilter Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
RtfExportFilter..::.MemberwiseClone Method
RtfExportFilter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

RtfExportFilter Class
RtfExportFilter Members
PerpetuumSoft.Reporting.Export.Rtf Namespace


RegisterAdapter Method

[image]

.NET ModelKit Suite ClassReference
RtfExportFilter..::.RegisterAdapter Method
RtfExportFilter Class See Also Send Feedback
Registers a new adapter.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public static void RegisterAdapter(
    Type controlType,
    Type adapterType
)
Visual Basic (Declaration)
Public Shared Sub RegisterAdapter ( _
    controlType As Type, _
    adapterType As Type _
)
Visual C++
public:
static void RegisterAdapter(
    Type^ controlType,
    Type^ adapterType
)

Parameters

controlType
Type: System..::.Type
adapterType
Type: System..::.Type

See Also

RtfExportFilter Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


ShowDialog Method

[image]

.NET ModelKit Suite ClassReference
RtfExportFilter..::.ShowDialog Method
RtfExportFilter Class See Also Send Feedback
Overridden. See ShowDialog()()().

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public override DialogResult ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As DialogResult
Visual C++
public:
virtual DialogResult ShowDialog() override

See Also

RtfExportFilter Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


RtfExportFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
RtfExportFilter Properties
RtfExportFilter Class See Also Send Feedback

The RtfExportFilter type exposes the following members.

Properties

Name | Description
Accuracy | Gets and sets filter accuracy.
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
JpegQuality |
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

RtfExportFilter Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


Accuracy Property

[image]

.NET ModelKit Suite ClassReference
RtfExportFilter..::.Accuracy Property
RtfExportFilter Class See Also Send Feedback
Gets and sets filter accuracy.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public float Accuracy { get; set; }
Visual Basic (Declaration)
Public Property Accuracy As Single
Visual C++
public:
property float Accuracy {
    float get ();
    void set (float value);
}

See Also

RtfExportFilter Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


JpegQuality Property

[image]

.NET ModelKit Suite ClassReference
RtfExportFilter..::.JpegQuality Property
RtfExportFilter Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.Export.Rtf.RtfExportFilter.JpegQuality]

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public int JpegQuality { get; set; }
Visual Basic (Declaration)
Public Property JpegQuality As Integer
Visual C++
public:
property int JpegQuality {
    int get ();
    void set (int value);
}

See Also

RtfExportFilter Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


RtfExportFilter Events

[image] [image]

.NET ModelKit Suite ClassReference
RtfExportFilter Events
RtfExportFilter Class See Also Send Feedback

The RtfExportFilter type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

RtfExportFilter Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


RtfExportFilterFactory Class

[image]

.NET ModelKit Suite ClassReference
RtfExportFilterFactory Class
Members See Also Send Feedback
Creates RtfExportFilter instances.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public class RtfExportFilterFactory : ExportFilterFactory
Visual Basic (Declaration)
Public Class RtfExportFilterFactory _
    Inherits ExportFilterFactory
Visual C++
public ref class RtfExportFilterFactory : public ExportFilterFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export..::.ExportFilterFactory
PerpetuumSoft.Reporting.Export.Rtf..::.RtfExportFilterFactory

See Also

RtfExportFilterFactory Members
PerpetuumSoft.Reporting.Export.Rtf Namespace


RtfExportFilterFactory Members

[image] [image]

.NET ModelKit Suite ClassReference
RtfExportFilterFactory Members
RtfExportFilterFactory Class Constructors Methods Properties See Also Send Feedback

The RtfExportFilterFactory type exposes the following members.

Constructors

Name | Description
RtfExportFilterFactory | Creates a new instance of the RtfExportFilterFactory class.

Methods

Name | Description
CreateFilter | Overrided. See CreateFilter()()(). (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Overrided. See GetFilterFileExtension()()(). (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Overrided. See GetFilterFormat()()(). (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Overrided. See GetFilterName()()(). (Overrides ExportFilterFactory..::.GetFilterName()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Factory | Gets default instance of the RtfExportFilterFactory class.

See Also

RtfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


RtfExportFilterFactory Constructor

[image]

.NET ModelKit Suite ClassReference
RtfExportFilterFactory Constructor
RtfExportFilterFactory Class See Also Send Feedback
Creates a new instance of the RtfExportFilterFactory class.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public RtfExportFilterFactory()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RtfExportFilterFactory()

See Also

RtfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


RtfExportFilterFactory Methods

[image] [image]

.NET ModelKit Suite ClassReference
RtfExportFilterFactory Methods
RtfExportFilterFactory Class See Also Send Feedback

The RtfExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Overrided. See CreateFilter()()(). (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Overrided. See GetFilterFileExtension()()(). (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Overrided. See GetFilterFormat()()(). (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Overrided. See GetFilterName()()(). (Overrides ExportFilterFactory..::.GetFilterName()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RtfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


CreateFilter Method

[image]

.NET ModelKit Suite ClassReference
RtfExportFilterFactory..::.CreateFilter Method
RtfExportFilterFactory Class See Also Send Feedback
Overrided. See CreateFilter()()().

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilter CreateFilter()
Visual Basic (Declaration)
Public Overrides Function CreateFilter As ExportFilter
Visual C++
public:
virtual ExportFilter^ CreateFilter() override

See Also

RtfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


GetFilterFileExtension Method

[image]

.NET ModelKit Suite ClassReference
RtfExportFilterFactory..::.GetFilterFileExtension Method
RtfExportFilterFactory Class See Also Send Feedback
Overrided. See GetFilterFileExtension()()().

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFileExtension()
Visual Basic (Declaration)
Public Overrides Function GetFilterFileExtension As String
Visual C++
public:
virtual String^ GetFilterFileExtension() override

See Also

RtfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


GetFilterFormat Method

[image]

.NET ModelKit Suite ClassReference
RtfExportFilterFactory..::.GetFilterFormat Method
RtfExportFilterFactory Class See Also Send Feedback
Overrided. See GetFilterFormat()()().

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFormat()
Visual Basic (Declaration)
Public Overrides Function GetFilterFormat As String
Visual C++
public:
virtual String^ GetFilterFormat() override

See Also

RtfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


GetFilterName Method

[image]

.NET ModelKit Suite ClassReference
RtfExportFilterFactory..::.GetFilterName Method
RtfExportFilterFactory Class See Also Send Feedback
Overrided. See GetFilterName()()().

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterName()
Visual Basic (Declaration)
Public Overrides Function GetFilterName As String
Visual C++
public:
virtual String^ GetFilterName() override

See Also

RtfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


RtfExportFilterFactory Properties

[image] [image]

.NET ModelKit Suite ClassReference
RtfExportFilterFactory Properties
RtfExportFilterFactory Class See Also Send Feedback

The RtfExportFilterFactory type exposes the following members.

Properties

Name | Description
Factory | Gets default instance of the RtfExportFilterFactory class.

See Also

RtfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


Factory Property

[image]

.NET ModelKit Suite ClassReference
RtfExportFilterFactory..::.Factory Property
RtfExportFilterFactory Class See Also Send Feedback
Gets default instance of the RtfExportFilterFactory class.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public static RtfExportFilterFactory Factory { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Factory As RtfExportFilterFactory
Visual C++
public:
static property RtfExportFilterFactory^ Factory {
    RtfExportFilterFactory^ get ();
}

See Also

RtfExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


RtfFile Class

[image]

.NET ModelKit Suite ClassReference
RtfFile Class
Members See Also Send Feedback
Represents an image of Rtf file in buffer.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public class RtfFile
Visual Basic (Declaration)
Public Class RtfFile
Visual C++
public ref class RtfFile

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Rtf..::.RtfFile

See Also

RtfFile Members
PerpetuumSoft.Reporting.Export.Rtf Namespace


RtfFile Members

[image] [image]

.NET ModelKit Suite ClassReference
RtfFile Members
RtfFile Class Constructors Methods Properties See Also Send Feedback

The RtfFile type exposes the following members.

Constructors

Name | Description
RtfFile | Overloaded.

Methods

Name | Description
ConvertString |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overloaded.
Save | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Accuracy | Gets and sets filter accuracy.
JpegQuality |
PageCollection | Gets PageCollection
Title | Gets or sets title of the result Rtf file.

See Also

RtfFile Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


RtfFile Constructor

[image] [image]

.NET ModelKit Suite ClassReference
RtfFile Constructor
RtfFile Class See Also Send Feedback

Overload List

Name | Description
RtfFile(RtfExportFilter) | Creates a new instance of the RtfFile class.
RtfFile(String, RtfExportFilter) | Creates a new instance of the RtfFile class.

See Also

RtfFile Class
RtfFile Members
PerpetuumSoft.Reporting.Export.Rtf Namespace


RtfFile Constructor (RtfExportFilter)

[image]

.NET ModelKit Suite ClassReference
RtfFile Constructor (RtfExportFilter)
RtfFile Class See Also Send Feedback
Creates a new instance of the RtfFile class.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public RtfFile(
    RtfExportFilter filter
)
Visual Basic (Declaration)
Public Sub New ( _
    filter As RtfExportFilter _
)
Visual C++
public:
RtfFile(
    RtfExportFilter^ filter
)

Parameters

filter
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfExportFilter

See Also

RtfFile Class
RtfFile Overload
PerpetuumSoft.Reporting.Export.Rtf Namespace


RtfFile Constructor (String, RtfExportFilter)

[image]

.NET ModelKit Suite ClassReference
RtfFile Constructor (String, RtfExportFilter)
RtfFile Class See Also Send Feedback
Creates a new instance of the RtfFile class.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public RtfFile(
    string title,
    RtfExportFilter filter
)
Visual Basic (Declaration)
Public Sub New ( _
    title As String, _
    filter As RtfExportFilter _
)
Visual C++
public:
RtfFile(
    String^ title,
    RtfExportFilter^ filter
)

Parameters

title
Type: System..::.String
filter
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfExportFilter

See Also

RtfFile Class
RtfFile Overload
PerpetuumSoft.Reporting.Export.Rtf Namespace


RtfFile Methods

[image] [image]

.NET ModelKit Suite ClassReference
RtfFile Methods
RtfFile Class See Also Send Feedback

The RtfFile type exposes the following members.

Methods

Name | Description
ConvertString |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overloaded.
Save | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RtfFile Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


ConvertString Method

[image]

.NET ModelKit Suite ClassReference
RtfFile..::.ConvertString Method
RtfFile Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Export.Rtf.RtfFile.ConvertString(System.String)]

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public static string ConvertString(
    string text
)
Visual Basic (Declaration)
Public Shared Function ConvertString ( _
    text As String _
) As String
Visual C++
public:
static String^ ConvertString(
    String^ text
)

Parameters

text
Type: System..::.String

See Also

RtfFile Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


Render Method

[image] [image]

.NET ModelKit Suite ClassReference
RtfFile..::.Render Method
RtfFile Class See Also Send Feedback

Overload List

Name | Description
Render(PageCollection) | Begins pages rendering into buffer.
Render(PageCollection, RenderControlCallback) | Begins pages rendering into buffer. Callback-method, that define whether controls will be rendered, is used.

See Also

RtfFile Class
RtfFile Members
PerpetuumSoft.Reporting.Export.Rtf Namespace


Render Method (PageCollection)

[image]

.NET ModelKit Suite ClassReference
RtfFile..::.Render Method (PageCollection)
RtfFile Class See Also Send Feedback
Begins pages rendering into buffer.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public void Render(
    PageCollection pages
)
Visual Basic (Declaration)
Public Sub Render ( _
    pages As PageCollection _
)
Visual C++
public:
void Render(
    PageCollection^ pages
)

Parameters

pages
Type: PerpetuumSoft.Reporting.DOM..::.PageCollection

See Also

RtfFile Class
Render Overload
PerpetuumSoft.Reporting.Export.Rtf Namespace


Render Method (PageCollection, .)

[image]

.NET ModelKit Suite ClassReference
RtfFile..::.Render Method (PageCollection, ..::.)
RtfFile Class See Also Send Feedback
Begins pages rendering into buffer. Callback-method, that define whether controls will be rendered, is used.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public void Render(
    PageCollection pages,
    RenderControlCallback callback
)
Visual Basic (Declaration)
Public Sub Render ( _
    pages As PageCollection, _
    callback As RenderControlCallback _
)
Visual C++
public:
void Render(
    PageCollection^ pages,
    RenderControlCallback^ callback
)

Parameters

pages
Type: PerpetuumSoft.Reporting.DOM..::.PageCollection
callback
Type: RenderControlCallback

See Also

RtfFile Class
Render Overload
PerpetuumSoft.Reporting.Export.Rtf Namespace


Save Method

[image] [image]

.NET ModelKit Suite ClassReference
RtfFile..::.Save Method
RtfFile Class See Also Send Feedback

Overload List

Name | Description
Save(Stream) | Saves image of Rtf file to specified stream.
Save(String) | Saves image of Rtf file to specified file.

See Also

RtfFile Class
RtfFile Members
PerpetuumSoft.Reporting.Export.Rtf Namespace


Save Method (Stream)

[image]

.NET ModelKit Suite ClassReference
RtfFile..::.Save Method (Stream)
RtfFile Class See Also Send Feedback
Saves image of Rtf file to specified stream.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public void Save(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Save ( _
    stream As Stream _
)
Visual C++
public:
void Save(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream

See Also

RtfFile Class
Save Overload
PerpetuumSoft.Reporting.Export.Rtf Namespace


Save Method (String)

[image]

.NET ModelKit Suite ClassReference
RtfFile..::.Save Method (String)
RtfFile Class See Also Send Feedback
Saves image of Rtf file to specified file.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public void Save(
    string fileName
)
Visual Basic (Declaration)
Public Sub Save ( _
    fileName As String _
)
Visual C++
public:
void Save(
    String^ fileName
)

Parameters

fileName
Type: System..::.String

See Also

RtfFile Class
Save Overload
PerpetuumSoft.Reporting.Export.Rtf Namespace


RtfFile Properties

[image] [image]

.NET ModelKit Suite ClassReference
RtfFile Properties
RtfFile Class See Also Send Feedback

The RtfFile type exposes the following members.

Properties

Name | Description
Accuracy | Gets and sets filter accuracy.
JpegQuality |
PageCollection | Gets PageCollection
Title | Gets or sets title of the result Rtf file.

See Also

RtfFile Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


Accuracy Property

[image]

.NET ModelKit Suite ClassReference
RtfFile..::.Accuracy Property
RtfFile Class See Also Send Feedback
Gets and sets filter accuracy.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public float Accuracy { get; set; }
Visual Basic (Declaration)
Public Property Accuracy As Single
Visual C++
public:
property float Accuracy {
    float get ();
    void set (float value);
}

See Also

RtfFile Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


JpegQuality Property

[image]

.NET ModelKit Suite ClassReference
RtfFile..::.JpegQuality Property
RtfFile Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.Export.Rtf.RtfFile.JpegQuality]

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public int JpegQuality { get; set; }
Visual Basic (Declaration)
Public Property JpegQuality As Integer
Visual C++
public:
property int JpegQuality {
    int get ();
    void set (int value);
}

See Also

RtfFile Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


PageCollection Property

[image]

.NET ModelKit Suite ClassReference
RtfFile..::.PageCollection Property
RtfFile Class See Also Send Feedback
Gets PageCollection

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public PageCollection PageCollection { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageCollection As PageCollection
Visual C++
public:
property PageCollection^ PageCollection {
    PageCollection^ get ();
}

See Also

RtfFile Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


Title Property

[image]

.NET ModelKit Suite ClassReference
RtfFile..::.Title Property
RtfFile Class See Also Send Feedback
Gets or sets title of the result Rtf file.

Namespace: PerpetuumSoft.Reporting.Export.Rtf
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

RtfFile Class
PerpetuumSoft.Reporting.Export.Rtf Namespace


PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace
Send Feedback
The PerpetuumSoft.Reporting.Export.Rtf.Adapters namespace contains classes which are used to export document elements to the RTF (Rich Text Format) format.

Classes

Class | Description
AdvancedTextRtfAdapter | Represent adapter for the AdvancedText control.
BoxRtfAdapter | Represent adapter for the box control.
PictureRtfAdapter | Represent adapter for the Picture control.
ReportControlRtfAdapter | Represent adapter for report control.
RtfAdapter | Incapsulates conversion methods for different types of report controls.
TextBoxRtfAdapter | Represent adapter for the TextBox control.
TextControlRtfAdapter | Represent adapter for the text control.


AdvancedTextRtfAdapter Class

[image]

.NET ModelKit Suite ClassReference
AdvancedTextRtfAdapter Class
Members See Also Send Feedback
Represent adapter for the AdvancedText control.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public class AdvancedTextRtfAdapter : TextControlRtfAdapter
Visual Basic (Declaration)
Public Class AdvancedTextRtfAdapter _
    Inherits TextControlRtfAdapter
Visual C++
public ref class AdvancedTextRtfAdapter : public TextControlRtfAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.RtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.ReportControlRtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.BoxRtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.TextControlRtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.AdvancedTextRtfAdapter

See Also

AdvancedTextRtfAdapter Members
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


AdvancedTextRtfAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextRtfAdapter Members
AdvancedTextRtfAdapter Class Constructors Methods See Also Send Feedback

The AdvancedTextRtfAdapter type exposes the following members.

Constructors

Name | Description
AdvancedTextRtfAdapter | Creates a new instance of AdvancedTextRtfAdapter class.

Methods

Name | Description
BeginHyperlink | Writes the beginning of hyperlink. (Inherited from ReportControlRtfAdapter.)
CreateAlignmentString | Returns alignment in the Rich Text format. (Inherited from RtfAdapter.)
CreateRtfString | Overrided. See CreateRtfString(ReportControl, RtfFile). (Overrides ReportControlRtfAdapter..::.CreateRtfString(ReportControl, RtfFile).)
EndHyperlink | Writes the end of hyperlink. (Inherited from ReportControlRtfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See Render(ReportControl, RtfFile). (Overrides BoxRtfAdapter..::.Render(ReportControl, RtfFile).)
RtfSavePicture | (Inherited from RtfAdapter.)
RtfWriteControl | Overrided. See RtfWriteControl(StreamWriter, ReportControl, RtfFile). (Inherited from TextControlRtfAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteAlign | Writes alignment in the Rich Text format. (Inherited from RtfAdapter.)
WriteBorder | Writes border in the Rich Text format. (Inherited from BoxRtfAdapter.)
WriteMargins | Writes margins in the Rich Text format. (Inherited from BoxRtfAdapter.)

See Also

AdvancedTextRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


AdvancedTextRtfAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
AdvancedTextRtfAdapter Constructor
AdvancedTextRtfAdapter Class See Also Send Feedback
Creates a new instance of AdvancedTextRtfAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public AdvancedTextRtfAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AdvancedTextRtfAdapter()

See Also

AdvancedTextRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


AdvancedTextRtfAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextRtfAdapter Methods
AdvancedTextRtfAdapter Class See Also Send Feedback

The AdvancedTextRtfAdapter type exposes the following members.

Methods

Name | Description
BeginHyperlink | Writes the beginning of hyperlink. (Inherited from ReportControlRtfAdapter.)
CreateAlignmentString | Returns alignment in the Rich Text format. (Inherited from RtfAdapter.)
CreateRtfString | Overrided. See CreateRtfString(ReportControl, RtfFile). (Overrides ReportControlRtfAdapter..::.CreateRtfString(ReportControl, RtfFile).)
EndHyperlink | Writes the end of hyperlink. (Inherited from ReportControlRtfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See Render(ReportControl, RtfFile). (Overrides BoxRtfAdapter..::.Render(ReportControl, RtfFile).)
RtfSavePicture | (Inherited from RtfAdapter.)
RtfWriteControl | Overrided. See RtfWriteControl(StreamWriter, ReportControl, RtfFile). (Inherited from TextControlRtfAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteAlign | Writes alignment in the Rich Text format. (Inherited from RtfAdapter.)
WriteBorder | Writes border in the Rich Text format. (Inherited from BoxRtfAdapter.)
WriteMargins | Writes margins in the Rich Text format. (Inherited from BoxRtfAdapter.)

See Also

AdvancedTextRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


CreateRtfString Method

[image]

.NET ModelKit Suite ClassReference
AdvancedTextRtfAdapter..::.CreateRtfString Method
AdvancedTextRtfAdapter Class See Also Send Feedback
Overrided. See CreateRtfString(ReportControl, RtfFile).

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public override string CreateRtfString(
    ReportControl control,
    RtfFile file
)
Visual Basic (Declaration)
Public Overrides Function CreateRtfString ( _
    control As ReportControl, _
    file As RtfFile _
) As String
Visual C++
public:
virtual String^ CreateRtfString(
    ReportControl^ control,
    RtfFile^ file
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
file
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfFile

See Also

AdvancedTextRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
AdvancedTextRtfAdapter..::.Render Method
AdvancedTextRtfAdapter Class See Also Send Feedback
Overrided. See Render(ReportControl, RtfFile).

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public override void Render(
    ReportControl control,
    RtfFile file
)
Visual Basic (Declaration)
Public Overrides Sub Render ( _
    control As ReportControl, _
    file As RtfFile _
)
Visual C++
public:
virtual void Render(
    ReportControl^ control,
    RtfFile^ file
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
file
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfFile

See Also

AdvancedTextRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


BoxRtfAdapter Class

[image]

.NET ModelKit Suite ClassReference
BoxRtfAdapter Class
Members See Also Send Feedback
Represent adapter for the box control.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public class BoxRtfAdapter : ReportControlRtfAdapter
Visual Basic (Declaration)
Public Class BoxRtfAdapter _
    Inherits ReportControlRtfAdapter
Visual C++
public ref class BoxRtfAdapter : public ReportControlRtfAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.RtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.ReportControlRtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.BoxRtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.PictureRtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.TextControlRtfAdapter

See Also

BoxRtfAdapter Members
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


BoxRtfAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
BoxRtfAdapter Members
BoxRtfAdapter Class Constructors Methods See Also Send Feedback

The BoxRtfAdapter type exposes the following members.

Constructors

Name | Description
BoxRtfAdapter | Creates a new instance of BoxRtfAdapter class.

Methods

Name | Description
BeginHyperlink | Writes the beginning of hyperlink. (Inherited from ReportControlRtfAdapter.)
CreateAlignmentString | Returns alignment in the Rich Text format. (Inherited from RtfAdapter.)
CreateRtfString | Overrided. See CreateRtfString(ReportControl, RtfFile). (Inherited from ReportControlRtfAdapter.)
EndHyperlink | Writes the end of hyperlink. (Inherited from ReportControlRtfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See Render(ReportControl, RtfFile). (Overrides ReportControlRtfAdapter..::.Render(ReportControl, RtfFile).)
RtfSavePicture | (Inherited from RtfAdapter.)
RtfWriteControl | Overrided. See RtfWriteControl(StreamWriter, ReportControl, RtfFile). (Overrides ReportControlRtfAdapter..::.RtfWriteControl(StreamWriter, ReportControl, RtfFile).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteAlign | Writes alignment in the Rich Text format. (Inherited from RtfAdapter.)
WriteBorder | Writes border in the Rich Text format.
WriteMargins | Writes margins in the Rich Text format.

See Also

BoxRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


BoxRtfAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
BoxRtfAdapter Constructor
BoxRtfAdapter Class See Also Send Feedback
Creates a new instance of BoxRtfAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public BoxRtfAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoxRtfAdapter()

See Also

BoxRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


BoxRtfAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
BoxRtfAdapter Methods
BoxRtfAdapter Class See Also Send Feedback

The BoxRtfAdapter type exposes the following members.

Methods

Name | Description
BeginHyperlink | Writes the beginning of hyperlink. (Inherited from ReportControlRtfAdapter.)
CreateAlignmentString | Returns alignment in the Rich Text format. (Inherited from RtfAdapter.)
CreateRtfString | Overrided. See CreateRtfString(ReportControl, RtfFile). (Inherited from ReportControlRtfAdapter.)
EndHyperlink | Writes the end of hyperlink. (Inherited from ReportControlRtfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See Render(ReportControl, RtfFile). (Overrides ReportControlRtfAdapter..::.Render(ReportControl, RtfFile).)
RtfSavePicture | (Inherited from RtfAdapter.)
RtfWriteControl | Overrided. See RtfWriteControl(StreamWriter, ReportControl, RtfFile). (Overrides ReportControlRtfAdapter..::.RtfWriteControl(StreamWriter, ReportControl, RtfFile).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteAlign | Writes alignment in the Rich Text format. (Inherited from RtfAdapter.)
WriteBorder | Writes border in the Rich Text format.
WriteMargins | Writes margins in the Rich Text format.

See Also

BoxRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
BoxRtfAdapter..::.Render Method
BoxRtfAdapter Class See Also Send Feedback
Overrided. See Render(ReportControl, RtfFile).

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public override void Render(
    ReportControl control,
    RtfFile file
)
Visual Basic (Declaration)
Public Overrides Sub Render ( _
    control As ReportControl, _
    file As RtfFile _
)
Visual C++
public:
virtual void Render(
    ReportControl^ control,
    RtfFile^ file
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
file
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfFile

See Also

BoxRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


RtfWriteControl Method

[image]

.NET ModelKit Suite ClassReference
BoxRtfAdapter..::.RtfWriteControl Method
BoxRtfAdapter Class See Also Send Feedback
Overrided. See RtfWriteControl(StreamWriter, ReportControl, RtfFile).

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public override void RtfWriteControl(
    StreamWriter writer,
    ReportControl control,
    RtfFile file
)
Visual Basic (Declaration)
Public Overrides Sub RtfWriteControl ( _
    writer As StreamWriter, _
    control As ReportControl, _
    file As RtfFile _
)
Visual C++
public:
virtual void RtfWriteControl(
    StreamWriter^ writer,
    ReportControl^ control,
    RtfFile^ file
) override

Parameters

writer
Type: System.IO..::.StreamWriter
control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
file
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfFile

See Also

BoxRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


WriteBorder Method

[image]

.NET ModelKit Suite ClassReference
BoxRtfAdapter..::.WriteBorder Method
BoxRtfAdapter Class See Also Send Feedback
Writes border in the Rich Text format.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
protected void WriteBorder(
    StreamWriter writer,
    Border border,
    RtfFile file
)
Visual Basic (Declaration)
Protected Sub WriteBorder ( _
    writer As StreamWriter, _
    border As Border, _
    file As RtfFile _
)
Visual C++
protected:
void WriteBorder(
    StreamWriter^ writer,
    Border^ border,
    RtfFile^ file
)

Parameters

writer
Type: System.IO..::.StreamWriter
border
Type: PerpetuumSoft.Framework.Drawing..::.Border
file
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfFile

See Also

BoxRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


WriteMargins Method

[image]

.NET ModelKit Suite ClassReference
BoxRtfAdapter..::.WriteMargins Method
BoxRtfAdapter Class See Also Send Feedback
Writes margins in the Rich Text format.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
protected void WriteMargins(
    StreamWriter writer,
    Margins margins,
    RtfFile file
)
Visual Basic (Declaration)
Protected Sub WriteMargins ( _
    writer As StreamWriter, _
    margins As Margins, _
    file As RtfFile _
)
Visual C++
protected:
void WriteMargins(
    StreamWriter^ writer,
    Margins margins,
    RtfFile^ file
)

Parameters

writer
Type: System.IO..::.StreamWriter
margins
Type: PerpetuumSoft.Framework.Drawing..::.Margins
file
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfFile

See Also

BoxRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


PictureRtfAdapter Class

[image]

.NET ModelKit Suite ClassReference
PictureRtfAdapter Class
Members See Also Send Feedback
Represent adapter for the Picture control.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public class PictureRtfAdapter : BoxRtfAdapter
Visual Basic (Declaration)
Public Class PictureRtfAdapter _
    Inherits BoxRtfAdapter
Visual C++
public ref class PictureRtfAdapter : public BoxRtfAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.RtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.ReportControlRtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.BoxRtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.PictureRtfAdapter

See Also

PictureRtfAdapter Members
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


PictureRtfAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
PictureRtfAdapter Members
PictureRtfAdapter Class Constructors Methods See Also Send Feedback

The PictureRtfAdapter type exposes the following members.

Constructors

Name | Description
PictureRtfAdapter | Creates a new instance of PictureRtfAdapter class.

Methods

Name | Description
BeginHyperlink | Writes the beginning of hyperlink. (Inherited from ReportControlRtfAdapter.)
CreateAlignmentString | Returns alignment in the Rich Text format. (Inherited from RtfAdapter.)
CreateRtfString | Overrided. See CreateRtfString(ReportControl, RtfFile). (Overrides ReportControlRtfAdapter..::.CreateRtfString(ReportControl, RtfFile).)
EndHyperlink | Writes the end of hyperlink. (Inherited from ReportControlRtfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See Render(ReportControl, RtfFile). (Inherited from BoxRtfAdapter.)
RtfSavePicture | (Inherited from RtfAdapter.)
RtfWriteControl | Overrided. See RtfWriteControl(StreamWriter, ReportControl, RtfFile). (Overrides BoxRtfAdapter..::.RtfWriteControl(StreamWriter, ReportControl, RtfFile).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteAlign | Writes alignment in the Rich Text format. (Inherited from RtfAdapter.)
WriteBorder | Writes border in the Rich Text format. (Inherited from BoxRtfAdapter.)
WriteMargins | Writes margins in the Rich Text format. (Inherited from BoxRtfAdapter.)

See Also

PictureRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


PictureRtfAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
PictureRtfAdapter Constructor
PictureRtfAdapter Class See Also Send Feedback
Creates a new instance of PictureRtfAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public PictureRtfAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PictureRtfAdapter()

See Also

PictureRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


PictureRtfAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
PictureRtfAdapter Methods
PictureRtfAdapter Class See Also Send Feedback

The PictureRtfAdapter type exposes the following members.

Methods

Name | Description
BeginHyperlink | Writes the beginning of hyperlink. (Inherited from ReportControlRtfAdapter.)
CreateAlignmentString | Returns alignment in the Rich Text format. (Inherited from RtfAdapter.)
CreateRtfString | Overrided. See CreateRtfString(ReportControl, RtfFile). (Overrides ReportControlRtfAdapter..::.CreateRtfString(ReportControl, RtfFile).)
EndHyperlink | Writes the end of hyperlink. (Inherited from ReportControlRtfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See Render(ReportControl, RtfFile). (Inherited from BoxRtfAdapter.)
RtfSavePicture | (Inherited from RtfAdapter.)
RtfWriteControl | Overrided. See RtfWriteControl(StreamWriter, ReportControl, RtfFile). (Overrides BoxRtfAdapter..::.RtfWriteControl(StreamWriter, ReportControl, RtfFile).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteAlign | Writes alignment in the Rich Text format. (Inherited from RtfAdapter.)
WriteBorder | Writes border in the Rich Text format. (Inherited from BoxRtfAdapter.)
WriteMargins | Writes margins in the Rich Text format. (Inherited from BoxRtfAdapter.)

See Also

PictureRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


CreateRtfString Method

[image]

.NET ModelKit Suite ClassReference
PictureRtfAdapter..::.CreateRtfString Method
PictureRtfAdapter Class See Also Send Feedback
Overrided. See CreateRtfString(ReportControl, RtfFile).

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public override string CreateRtfString(
    ReportControl control,
    RtfFile file
)
Visual Basic (Declaration)
Public Overrides Function CreateRtfString ( _
    control As ReportControl, _
    file As RtfFile _
) As String
Visual C++
public:
virtual String^ CreateRtfString(
    ReportControl^ control,
    RtfFile^ file
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
file
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfFile

See Also

PictureRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


RtfWriteControl Method

[image]

.NET ModelKit Suite ClassReference
PictureRtfAdapter..::.RtfWriteControl Method
PictureRtfAdapter Class See Also Send Feedback
Overrided. See RtfWriteControl(StreamWriter, ReportControl, RtfFile).

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public override void RtfWriteControl(
    StreamWriter writer,
    ReportControl control,
    RtfFile file
)
Visual Basic (Declaration)
Public Overrides Sub RtfWriteControl ( _
    writer As StreamWriter, _
    control As ReportControl, _
    file As RtfFile _
)
Visual C++
public:
virtual void RtfWriteControl(
    StreamWriter^ writer,
    ReportControl^ control,
    RtfFile^ file
) override

Parameters

writer
Type: System.IO..::.StreamWriter
control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
file
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfFile

See Also

PictureRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


ReportControlRtfAdapter Class

[image]

.NET ModelKit Suite ClassReference
ReportControlRtfAdapter Class
Members See Also Send Feedback
Represent adapter for report control.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public class ReportControlRtfAdapter : RtfAdapter
Visual Basic (Declaration)
Public Class ReportControlRtfAdapter _
    Inherits RtfAdapter
Visual C++
public ref class ReportControlRtfAdapter : public RtfAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.RtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.ReportControlRtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.BoxRtfAdapter

See Also

ReportControlRtfAdapter Members
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


ReportControlRtfAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlRtfAdapter Members
ReportControlRtfAdapter Class Constructors Methods See Also Send Feedback

The ReportControlRtfAdapter type exposes the following members.

Constructors

Name | Description
ReportControlRtfAdapter | Creates a new instance of ReportControlRtfAdapter class.

Methods

Name | Description
BeginHyperlink | Writes the beginning of hyperlink.
CreateAlignmentString | Returns alignment in the Rich Text format. (Inherited from RtfAdapter.)
CreateRtfString | Overrided. See CreateRtfString(ReportControl, RtfFile). (Overrides RtfAdapter..::.CreateRtfString(ReportControl, RtfFile).)
EndHyperlink | Writes the end of hyperlink.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See Render(ReportControl, RtfFile). (Overrides RtfAdapter..::.Render(ReportControl, RtfFile).)
RtfSavePicture | (Inherited from RtfAdapter.)
RtfWriteControl | Overrided. See RtfWriteControl(StreamWriter, ReportControl, RtfFile). (Overrides RtfAdapter..::.RtfWriteControl(StreamWriter, ReportControl, RtfFile).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteAlign | Writes alignment in the Rich Text format. (Inherited from RtfAdapter.)

See Also

ReportControlRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


ReportControlRtfAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
ReportControlRtfAdapter Constructor
ReportControlRtfAdapter Class See Also Send Feedback
Creates a new instance of ReportControlRtfAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public ReportControlRtfAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportControlRtfAdapter()

See Also

ReportControlRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


ReportControlRtfAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlRtfAdapter Methods
ReportControlRtfAdapter Class See Also Send Feedback

The ReportControlRtfAdapter type exposes the following members.

Methods

Name | Description
BeginHyperlink | Writes the beginning of hyperlink.
CreateAlignmentString | Returns alignment in the Rich Text format. (Inherited from RtfAdapter.)
CreateRtfString | Overrided. See CreateRtfString(ReportControl, RtfFile). (Overrides RtfAdapter..::.CreateRtfString(ReportControl, RtfFile).)
EndHyperlink | Writes the end of hyperlink.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See Render(ReportControl, RtfFile). (Overrides RtfAdapter..::.Render(ReportControl, RtfFile).)
RtfSavePicture | (Inherited from RtfAdapter.)
RtfWriteControl | Overrided. See RtfWriteControl(StreamWriter, ReportControl, RtfFile). (Overrides RtfAdapter..::.RtfWriteControl(StreamWriter, ReportControl, RtfFile).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteAlign | Writes alignment in the Rich Text format. (Inherited from RtfAdapter.)

See Also

ReportControlRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


BeginHyperlink Method

[image]

.NET ModelKit Suite ClassReference
ReportControlRtfAdapter..::.BeginHyperlink Method
ReportControlRtfAdapter Class See Also Send Feedback
Writes the beginning of hyperlink.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
protected string BeginHyperlink(
    ReportControl control,
    RtfFile file
)
Visual Basic (Declaration)
Protected Function BeginHyperlink ( _
    control As ReportControl, _
    file As RtfFile _
) As String
Visual C++
protected:
String^ BeginHyperlink(
    ReportControl^ control,
    RtfFile^ file
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
file
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfFile

See Also

ReportControlRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


CreateRtfString Method

[image]

.NET ModelKit Suite ClassReference
ReportControlRtfAdapter..::.CreateRtfString Method
ReportControlRtfAdapter Class See Also Send Feedback
Overrided. See CreateRtfString(ReportControl, RtfFile).

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public override string CreateRtfString(
    ReportControl control,
    RtfFile file
)
Visual Basic (Declaration)
Public Overrides Function CreateRtfString ( _
    control As ReportControl, _
    file As RtfFile _
) As String
Visual C++
public:
virtual String^ CreateRtfString(
    ReportControl^ control,
    RtfFile^ file
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
file
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfFile

See Also

ReportControlRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


EndHyperlink Method

[image]

.NET ModelKit Suite ClassReference
ReportControlRtfAdapter..::.EndHyperlink Method
ReportControlRtfAdapter Class See Also Send Feedback
Writes the end of hyperlink.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
protected string EndHyperlink(
    ReportControl control
)
Visual Basic (Declaration)
Protected Function EndHyperlink ( _
    control As ReportControl _
) As String
Visual C++
protected:
String^ EndHyperlink(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ReportControlRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
ReportControlRtfAdapter..::.Render Method
ReportControlRtfAdapter Class See Also Send Feedback
Overrided. See Render(ReportControl, RtfFile).

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public override void Render(
    ReportControl control,
    RtfFile file
)
Visual Basic (Declaration)
Public Overrides Sub Render ( _
    control As ReportControl, _
    file As RtfFile _
)
Visual C++
public:
virtual void Render(
    ReportControl^ control,
    RtfFile^ file
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
file
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfFile

See Also

ReportControlRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


RtfWriteControl Method

[image]

.NET ModelKit Suite ClassReference
ReportControlRtfAdapter..::.RtfWriteControl Method
ReportControlRtfAdapter Class See Also Send Feedback
Overrided. See RtfWriteControl(StreamWriter, ReportControl, RtfFile).

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public override void RtfWriteControl(
    StreamWriter writer,
    ReportControl control,
    RtfFile file
)
Visual Basic (Declaration)
Public Overrides Sub RtfWriteControl ( _
    writer As StreamWriter, _
    control As ReportControl, _
    file As RtfFile _
)
Visual C++
public:
virtual void RtfWriteControl(
    StreamWriter^ writer,
    ReportControl^ control,
    RtfFile^ file
) override

Parameters

writer
Type: System.IO..::.StreamWriter
control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
file
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfFile

See Also

ReportControlRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


RtfAdapter Class

[image]

.NET ModelKit Suite ClassReference
RtfAdapter Class
Members See Also Send Feedback
Incapsulates conversion methods for different types of report controls.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public abstract class RtfAdapter
Visual Basic (Declaration)
Public MustInherit Class RtfAdapter
Visual C++
public ref class RtfAdapter abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.RtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.ReportControlRtfAdapter

See Also

RtfAdapter Members
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


RtfAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
RtfAdapter Members
RtfAdapter Class Constructors Methods See Also Send Feedback

The RtfAdapter type exposes the following members.

Constructors

Name | Description
RtfAdapter | Creates a new instance of RtfAdapter class.

Methods

Name | Description
ConvertString | Prepares text into Rich Text format.
CreateAlignmentString | Returns alignment in the Rich Text format.
CreateRtfString | Creates string from content of control.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Renders control into Rich Text format.
Round | Converts control unit into Rtf unit.
RtfSavePicture |
RtfWriteControl | Writes control parameters in the Rich Text format.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteAlign | Writes alignment in the Rich Text format.

See Also

RtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


RtfAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
RtfAdapter Constructor
RtfAdapter Class See Also Send Feedback
Creates a new instance of RtfAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
protected RtfAdapter()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
RtfAdapter()

See Also

RtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


RtfAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
RtfAdapter Methods
RtfAdapter Class See Also Send Feedback

The RtfAdapter type exposes the following members.

Methods

Name | Description
ConvertString | Prepares text into Rich Text format.
CreateAlignmentString | Returns alignment in the Rich Text format.
CreateRtfString | Creates string from content of control.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Renders control into Rich Text format.
Round | Converts control unit into Rtf unit.
RtfSavePicture |
RtfWriteControl | Writes control parameters in the Rich Text format.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteAlign | Writes alignment in the Rich Text format.

See Also

RtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


ConvertString Method

[image]

.NET ModelKit Suite ClassReference
RtfAdapter..::.ConvertString Method
RtfAdapter Class See Also Send Feedback
Prepares text into Rich Text format.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public static string ConvertString(
    string text
)
Visual Basic (Declaration)
Public Shared Function ConvertString ( _
    text As String _
) As String
Visual C++
public:
static String^ ConvertString(
    String^ text
)

Parameters

text
Type: System..::.String

See Also

RtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


CreateAlignmentString Method

[image]

.NET ModelKit Suite ClassReference
RtfAdapter..::.CreateAlignmentString Method
RtfAdapter Class See Also Send Feedback
Returns alignment in the Rich Text format.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
protected string CreateAlignmentString(
    ContentAlignment alignment
)
Visual Basic (Declaration)
Protected Function CreateAlignmentString ( _
    alignment As ContentAlignment _
) As String
Visual C++
protected:
String^ CreateAlignmentString(
    ContentAlignment alignment
)

Parameters

alignment
Type: System.Drawing..::.ContentAlignment

See Also

RtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


CreateRtfString Method

[image]

.NET ModelKit Suite ClassReference
RtfAdapter..::.CreateRtfString Method
RtfAdapter Class See Also Send Feedback
Creates string from content of control.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public abstract string CreateRtfString(
    ReportControl control,
    RtfFile file
)
Visual Basic (Declaration)
Public MustOverride Function CreateRtfString ( _
    control As ReportControl, _
    file As RtfFile _
) As String
Visual C++
public:
virtual String^ CreateRtfString(
    ReportControl^ control,
    RtfFile^ file
) abstract

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
file
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfFile

See Also

RtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
RtfAdapter..::.Render Method
RtfAdapter Class See Also Send Feedback
Renders control into Rich Text format.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public abstract void Render(
    ReportControl control,
    RtfFile file
)
Visual Basic (Declaration)
Public MustOverride Sub Render ( _
    control As ReportControl, _
    file As RtfFile _
)
Visual C++
public:
virtual void Render(
    ReportControl^ control,
    RtfFile^ file
) abstract

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
file
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfFile

See Also

RtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


Round Method

[image]

.NET ModelKit Suite ClassReference
RtfAdapter..::.Round Method
RtfAdapter Class See Also Send Feedback
Converts control unit into Rtf unit.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
protected static int Round(
    double x
)
Visual Basic (Declaration)
Protected Shared Function Round ( _
    x As Double _
) As Integer
Visual C++
protected:
static int Round(
    double x
)

Parameters

x
Type: System..::.Double

See Also

RtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


RtfSavePicture Method

[image]

.NET ModelKit Suite ClassReference
RtfAdapter..::.RtfSavePicture Method
RtfAdapter Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Export.Rtf.Adapters.RtfAdapter.RtfSavePicture(PerpetuumSoft.Reporting.DOM.Picture,System.Int32)]

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
protected string RtfSavePicture(
    Picture picture,
    int quality
)
Visual Basic (Declaration)
Protected Function RtfSavePicture ( _
    picture As Picture, _
    quality As Integer _
) As String
Visual C++
protected:
String^ RtfSavePicture(
    Picture^ picture,
    int quality
)

Parameters

picture
Type: PerpetuumSoft.Reporting.DOM..::.Picture
quality
Type: System..::.Int32

See Also

RtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


RtfWriteControl Method

[image]

.NET ModelKit Suite ClassReference
RtfAdapter..::.RtfWriteControl Method
RtfAdapter Class See Also Send Feedback
Writes control parameters in the Rich Text format.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public abstract void RtfWriteControl(
    StreamWriter writer,
    ReportControl control,
    RtfFile file
)
Visual Basic (Declaration)
Public MustOverride Sub RtfWriteControl ( _
    writer As StreamWriter, _
    control As ReportControl, _
    file As RtfFile _
)
Visual C++
public:
virtual void RtfWriteControl(
    StreamWriter^ writer,
    ReportControl^ control,
    RtfFile^ file
) abstract

Parameters

writer
Type: System.IO..::.StreamWriter
control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
file
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfFile

See Also

RtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


WriteAlign Method

[image]

.NET ModelKit Suite ClassReference
RtfAdapter..::.WriteAlign Method
RtfAdapter Class See Also Send Feedback
Writes alignment in the Rich Text format.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
protected void WriteAlign(
    StreamWriter writer,
    ContentAlignment alignment
)
Visual Basic (Declaration)
Protected Sub WriteAlign ( _
    writer As StreamWriter, _
    alignment As ContentAlignment _
)
Visual C++
protected:
void WriteAlign(
    StreamWriter^ writer,
    ContentAlignment alignment
)

Parameters

writer
Type: System.IO..::.StreamWriter
alignment
Type: System.Drawing..::.ContentAlignment

See Also

RtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


TextBoxRtfAdapter Class

[image]

.NET ModelKit Suite ClassReference
TextBoxRtfAdapter Class
Members See Also Send Feedback
Represent adapter for the TextBox control.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public class TextBoxRtfAdapter : TextControlRtfAdapter
Visual Basic (Declaration)
Public Class TextBoxRtfAdapter _
    Inherits TextControlRtfAdapter
Visual C++
public ref class TextBoxRtfAdapter : public TextControlRtfAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.RtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.ReportControlRtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.BoxRtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.TextControlRtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.TextBoxRtfAdapter

See Also

TextBoxRtfAdapter Members
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


TextBoxRtfAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxRtfAdapter Members
TextBoxRtfAdapter Class Constructors Methods See Also Send Feedback

The TextBoxRtfAdapter type exposes the following members.

Constructors

Name | Description
TextBoxRtfAdapter | Creates a new instance of TextBoxRtfAdapter class.

Methods

Name | Description
BeginHyperlink | Writes the beginning of hyperlink. (Inherited from ReportControlRtfAdapter.)
CreateAlignmentString | Returns alignment in the Rich Text format. (Inherited from RtfAdapter.)
CreateRtfString | Overrided. See CreateRtfString(ReportControl, RtfFile). (Overrides ReportControlRtfAdapter..::.CreateRtfString(ReportControl, RtfFile).)
EndHyperlink | Writes the end of hyperlink. (Inherited from ReportControlRtfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See Render(ReportControl, RtfFile). (Overrides BoxRtfAdapter..::.Render(ReportControl, RtfFile).)
RtfSavePicture | (Inherited from RtfAdapter.)
RtfWriteControl | Overrided. See RtfWriteControl(StreamWriter, ReportControl, RtfFile). (Inherited from TextControlRtfAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteAlign | Writes alignment in the Rich Text format. (Inherited from RtfAdapter.)
WriteBorder | Writes border in the Rich Text format. (Inherited from BoxRtfAdapter.)
WriteMargins | Writes margins in the Rich Text format. (Inherited from BoxRtfAdapter.)

See Also

TextBoxRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


TextBoxRtfAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
TextBoxRtfAdapter Constructor
TextBoxRtfAdapter Class See Also Send Feedback
Creates a new instance of TextBoxRtfAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public TextBoxRtfAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextBoxRtfAdapter()

See Also

TextBoxRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


TextBoxRtfAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxRtfAdapter Methods
TextBoxRtfAdapter Class See Also Send Feedback

The TextBoxRtfAdapter type exposes the following members.

Methods

Name | Description
BeginHyperlink | Writes the beginning of hyperlink. (Inherited from ReportControlRtfAdapter.)
CreateAlignmentString | Returns alignment in the Rich Text format. (Inherited from RtfAdapter.)
CreateRtfString | Overrided. See CreateRtfString(ReportControl, RtfFile). (Overrides ReportControlRtfAdapter..::.CreateRtfString(ReportControl, RtfFile).)
EndHyperlink | Writes the end of hyperlink. (Inherited from ReportControlRtfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See Render(ReportControl, RtfFile). (Overrides BoxRtfAdapter..::.Render(ReportControl, RtfFile).)
RtfSavePicture | (Inherited from RtfAdapter.)
RtfWriteControl | Overrided. See RtfWriteControl(StreamWriter, ReportControl, RtfFile). (Inherited from TextControlRtfAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteAlign | Writes alignment in the Rich Text format. (Inherited from RtfAdapter.)
WriteBorder | Writes border in the Rich Text format. (Inherited from BoxRtfAdapter.)
WriteMargins | Writes margins in the Rich Text format. (Inherited from BoxRtfAdapter.)

See Also

TextBoxRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


CreateRtfString Method

[image]

.NET ModelKit Suite ClassReference
TextBoxRtfAdapter..::.CreateRtfString Method
TextBoxRtfAdapter Class See Also Send Feedback
Overrided. See CreateRtfString(ReportControl, RtfFile).

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public override string CreateRtfString(
    ReportControl control,
    RtfFile file
)
Visual Basic (Declaration)
Public Overrides Function CreateRtfString ( _
    control As ReportControl, _
    file As RtfFile _
) As String
Visual C++
public:
virtual String^ CreateRtfString(
    ReportControl^ control,
    RtfFile^ file
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
file
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfFile

See Also

TextBoxRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
TextBoxRtfAdapter..::.Render Method
TextBoxRtfAdapter Class See Also Send Feedback
Overrided. See Render(ReportControl, RtfFile).

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public override void Render(
    ReportControl control,
    RtfFile file
)
Visual Basic (Declaration)
Public Overrides Sub Render ( _
    control As ReportControl, _
    file As RtfFile _
)
Visual C++
public:
virtual void Render(
    ReportControl^ control,
    RtfFile^ file
) override

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
file
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfFile

See Also

TextBoxRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


TextControlRtfAdapter Class

[image]

.NET ModelKit Suite ClassReference
TextControlRtfAdapter Class
Members See Also Send Feedback
Represent adapter for the text control.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public class TextControlRtfAdapter : BoxRtfAdapter
Visual Basic (Declaration)
Public Class TextControlRtfAdapter _
    Inherits BoxRtfAdapter
Visual C++
public ref class TextControlRtfAdapter : public BoxRtfAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.RtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.ReportControlRtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.BoxRtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.TextControlRtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.AdvancedTextRtfAdapter
PerpetuumSoft.Reporting.Export.Rtf.Adapters..::.TextBoxRtfAdapter

See Also

TextControlRtfAdapter Members
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


TextControlRtfAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
TextControlRtfAdapter Members
TextControlRtfAdapter Class Constructors Methods See Also Send Feedback

The TextControlRtfAdapter type exposes the following members.

Constructors

Name | Description
TextControlRtfAdapter | Creates a new instance of TextControlRtfAdapter class.

Methods

Name | Description
BeginHyperlink | Writes the beginning of hyperlink. (Inherited from ReportControlRtfAdapter.)
CreateAlignmentString | Returns alignment in the Rich Text format. (Inherited from RtfAdapter.)
CreateRtfString | Overrided. See CreateRtfString(ReportControl, RtfFile). (Inherited from ReportControlRtfAdapter.)
EndHyperlink | Writes the end of hyperlink. (Inherited from ReportControlRtfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See Render(ReportControl, RtfFile). (Inherited from BoxRtfAdapter.)
RtfSavePicture | (Inherited from RtfAdapter.)
RtfWriteControl | Overrided. See RtfWriteControl(StreamWriter, ReportControl, RtfFile). (Overrides BoxRtfAdapter..::.RtfWriteControl(StreamWriter, ReportControl, RtfFile).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteAlign | Writes alignment in the Rich Text format. (Inherited from RtfAdapter.)
WriteBorder | Writes border in the Rich Text format. (Inherited from BoxRtfAdapter.)
WriteMargins | Writes margins in the Rich Text format. (Inherited from BoxRtfAdapter.)

See Also

TextControlRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


TextControlRtfAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
TextControlRtfAdapter Constructor
TextControlRtfAdapter Class See Also Send Feedback
Creates a new instance of TextControlRtfAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public TextControlRtfAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextControlRtfAdapter()

See Also

TextControlRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


TextControlRtfAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextControlRtfAdapter Methods
TextControlRtfAdapter Class See Also Send Feedback

The TextControlRtfAdapter type exposes the following members.

Methods

Name | Description
BeginHyperlink | Writes the beginning of hyperlink. (Inherited from ReportControlRtfAdapter.)
CreateAlignmentString | Returns alignment in the Rich Text format. (Inherited from RtfAdapter.)
CreateRtfString | Overrided. See CreateRtfString(ReportControl, RtfFile). (Inherited from ReportControlRtfAdapter.)
EndHyperlink | Writes the end of hyperlink. (Inherited from ReportControlRtfAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overrided. See Render(ReportControl, RtfFile). (Inherited from BoxRtfAdapter.)
RtfSavePicture | (Inherited from RtfAdapter.)
RtfWriteControl | Overrided. See RtfWriteControl(StreamWriter, ReportControl, RtfFile). (Overrides BoxRtfAdapter..::.RtfWriteControl(StreamWriter, ReportControl, RtfFile).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteAlign | Writes alignment in the Rich Text format. (Inherited from RtfAdapter.)
WriteBorder | Writes border in the Rich Text format. (Inherited from BoxRtfAdapter.)
WriteMargins | Writes margins in the Rich Text format. (Inherited from BoxRtfAdapter.)

See Also

TextControlRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


RtfWriteControl Method

[image]

.NET ModelKit Suite ClassReference
TextControlRtfAdapter..::.RtfWriteControl Method
TextControlRtfAdapter Class See Also Send Feedback
Overrided. See RtfWriteControl(StreamWriter, ReportControl, RtfFile).

Namespace: PerpetuumSoft.Reporting.Export.Rtf.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Rtf (in PerpetuumSoft.Reporting.Export.Rtf.dll) Version: 3.9.0.1

Syntax

C#
public override void RtfWriteControl(
    StreamWriter writer,
    ReportControl control,
    RtfFile file
)
Visual Basic (Declaration)
Public Overrides Sub RtfWriteControl ( _
    writer As StreamWriter, _
    control As ReportControl, _
    file As RtfFile _
)
Visual C++
public:
virtual void RtfWriteControl(
    StreamWriter^ writer,
    ReportControl^ control,
    RtfFile^ file
) override

Parameters

writer
Type: System.IO..::.StreamWriter
control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
file
Type: PerpetuumSoft.Reporting.Export.Rtf..::.RtfFile

See Also

TextControlRtfAdapter Class
PerpetuumSoft.Reporting.Export.Rtf.Adapters Namespace


PerpetuumSoft.Reporting.Export.Xps Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Export.Xps Namespace
Send Feedback
The PerpetuumSoft.Reporting.Export.Xps namespace contains classes which are used to export document to the XPS (XML Paper Specificationt) format.

Classes

Class | Description
MediaFill | Provides methods to get fill adapters by fill types.
Options | Represents export options to XPS format.
XpsExportFilter | Represents an export filter to XPS format.
XpsExportFilterFactory | Represents a Factory for the XPS export filter creation.


MediaFill Class

[image]

.NET ModelKit Suite ClassReference
MediaFill Class
Members See Also Send Feedback
Provides methods to get fill adapters by fill types.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public class MediaFill
Visual Basic (Declaration)
Public Class MediaFill
Visual C++
public ref class MediaFill

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps..::.MediaFill

See Also

MediaFill Members
PerpetuumSoft.Reporting.Export.Xps Namespace


MediaFill Members

[image] [image]

.NET ModelKit Suite ClassReference
MediaFill Members
MediaFill Class Constructors Methods Properties See Also Send Feedback

The MediaFill type exposes the following members.

Constructors

Name | Description
MediaFill | Initializes a new instance of the MediaFill class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindFillAdapterType | Returns adapter type by the fill type.
GetFillAdapter | Returns a fill adapter.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RegisterFillAdapter | Registers a new type of the adapter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format.

See Also

MediaFill Class
PerpetuumSoft.Reporting.Export.Xps Namespace


MediaFill Constructor

[image]

.NET ModelKit Suite ClassReference
MediaFill Constructor
MediaFill Class See Also Send Feedback
Initializes a new instance of the MediaFill class.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public MediaFill(
    Options documentOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    documentOptions As Options _
)
Visual C++
public:
MediaFill(
    Options^ documentOptions
)

Parameters

documentOptions
Type: PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

MediaFill Class
PerpetuumSoft.Reporting.Export.Xps Namespace


MediaFill Methods

[image] [image]

.NET ModelKit Suite ClassReference
MediaFill Methods
MediaFill Class See Also Send Feedback

The MediaFill type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindFillAdapterType | Returns adapter type by the fill type.
GetFillAdapter | Returns a fill adapter.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RegisterFillAdapter | Registers a new type of the adapter.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MediaFill Class
PerpetuumSoft.Reporting.Export.Xps Namespace


FindFillAdapterType Method

[image]

.NET ModelKit Suite ClassReference
MediaFill..::.FindFillAdapterType Method
MediaFill Class See Also Send Feedback
Returns adapter type by the fill type.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public static Type FindFillAdapterType(
    Type type
)
Visual Basic (Declaration)
Public Shared Function FindFillAdapterType ( _
    type As Type _
) As Type
Visual C++
public:
static Type^ FindFillAdapterType(
    Type^ type
)

Parameters

type
Type: System..::.Type

See Also

MediaFill Class
PerpetuumSoft.Reporting.Export.Xps Namespace


GetFillAdapter Method

[image]

.NET ModelKit Suite ClassReference
MediaFill..::.GetFillAdapter Method
MediaFill Class See Also Send Feedback
Returns a fill adapter.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public FillAdapter GetFillAdapter(
    Fill fill
)
Visual Basic (Declaration)
Public Function GetFillAdapter ( _
    fill As Fill _
) As FillAdapter
Visual C++
public:
FillAdapter^ GetFillAdapter(
    Fill^ fill
)

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill

See Also

MediaFill Class
PerpetuumSoft.Reporting.Export.Xps Namespace


RegisterFillAdapter Method

[image]

.NET ModelKit Suite ClassReference
MediaFill..::.RegisterFillAdapter Method
MediaFill Class See Also Send Feedback
Registers a new type of the adapter.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public static void RegisterFillAdapter(
    Type fillType,
    Type adapterType
)
Visual Basic (Declaration)
Public Shared Sub RegisterFillAdapter ( _
    fillType As Type, _
    adapterType As Type _
)
Visual C++
public:
static void RegisterFillAdapter(
    Type^ fillType,
    Type^ adapterType
)

Parameters

fillType
Type: System..::.Type
adapterType
Type: System..::.Type

See Also

MediaFill Class
PerpetuumSoft.Reporting.Export.Xps Namespace


MediaFill Properties

[image] [image]

.NET ModelKit Suite ClassReference
MediaFill Properties
MediaFill Class See Also Send Feedback

The MediaFill type exposes the following members.

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format.

See Also

MediaFill Class
PerpetuumSoft.Reporting.Export.Xps Namespace


DocumentOptions Property

[image]

.NET ModelKit Suite ClassReference
MediaFill..::.DocumentOptions Property
MediaFill Class See Also Send Feedback
Gets or sets Options that represents export options to XPS format.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public Options DocumentOptions { get; set; }
Visual Basic (Declaration)
Public Property DocumentOptions As Options
Visual C++
public:
property Options^ DocumentOptions {
    Options^ get ();
    void set (Options^ value);
}

See Also

MediaFill Class
PerpetuumSoft.Reporting.Export.Xps Namespace


Options Class

[image]

.NET ModelKit Suite ClassReference
Options Class
Members See Also Send Feedback
Represents export options to XPS format.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public class Options
Visual Basic (Declaration)
Public Class Options
Visual C++
public ref class Options

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

Options Members
PerpetuumSoft.Reporting.Export.Xps Namespace


Options Members

[image] [image]

.NET ModelKit Suite ClassReference
Options Members
Options Class Constructors Methods Properties See Also Send Feedback

The Options type exposes the following members.

Constructors

Name | Description
Options | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentCompressionOption | Gets or sets CompressionOption that represents option of the document settings.
ImageResolution | Gets or sets image resolution.
KeepOriginalImageResolution | Gets or sets a value that indicated if the original size of an image should be kept.
ReplaceFill | Gets or sets a value that indicates if a picture should be replaced.

See Also

Options Class
PerpetuumSoft.Reporting.Export.Xps Namespace


Options Constructor

[image] [image]

.NET ModelKit Suite ClassReference
Options Constructor
Options Class See Also Send Feedback

Overload List

Name | Description
Options()()() | Initializes a new instance of the Options class.
Options(Int32, Boolean, CompressionOption, Boolean) | Initializes a new instance of the Options class.

See Also

Options Class
Options Members
PerpetuumSoft.Reporting.Export.Xps Namespace


Options Constructor

[image]

.NET ModelKit Suite ClassReference
Options Constructor
Options Class See Also Send Feedback
Initializes a new instance of the Options class.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public Options()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Options()

See Also

Options Class
Options Overload
PerpetuumSoft.Reporting.Export.Xps Namespace


Options Constructor (Int32, Boolean, CompressionOption, Boolean)

[image]

.NET ModelKit Suite ClassReference
Options Constructor (Int32, Boolean, CompressionOption, Boolean)
Options Class See Also Send Feedback
Initializes a new instance of the Options class.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public Options(
    int imageResolution,
    bool replaceFill,
    CompressionOption documentCompressionOption,
    bool keepOriginalImageResolution
)
Visual Basic (Declaration)
Public Sub New ( _
    imageResolution As Integer, _
    replaceFill As Boolean, _
    documentCompressionOption As CompressionOption, _
    keepOriginalImageResolution As Boolean _
)
Visual C++
public:
Options(
    int imageResolution,
    bool replaceFill,
    CompressionOption documentCompressionOption,
    bool keepOriginalImageResolution
)

Parameters

imageResolution
Type: System..::.Int32
replaceFill
Type: System..::.Boolean
documentCompressionOption
Type: System.IO.Packaging..::.CompressionOption
keepOriginalImageResolution
Type: System..::.Boolean

See Also

Options Class
Options Overload
PerpetuumSoft.Reporting.Export.Xps Namespace


Options Methods

[image] [image]

.NET ModelKit Suite ClassReference
Options Methods
Options Class See Also Send Feedback

The Options type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Options Class
PerpetuumSoft.Reporting.Export.Xps Namespace


Options Properties

[image] [image]

.NET ModelKit Suite ClassReference
Options Properties
Options Class See Also Send Feedback

The Options type exposes the following members.

Properties

Name | Description
DocumentCompressionOption | Gets or sets CompressionOption that represents option of the document settings.
ImageResolution | Gets or sets image resolution.
KeepOriginalImageResolution | Gets or sets a value that indicated if the original size of an image should be kept.
ReplaceFill | Gets or sets a value that indicates if a picture should be replaced.

See Also

Options Class
PerpetuumSoft.Reporting.Export.Xps Namespace


DocumentCompressionOption Property

[image]

.NET ModelKit Suite ClassReference
Options..::.DocumentCompressionOption Property
Options Class See Also Send Feedback
Gets or sets CompressionOption that represents option of the document settings.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public CompressionOption DocumentCompressionOption { get; set; }
Visual Basic (Declaration)
Public Property DocumentCompressionOption As CompressionOption
Visual C++
public:
property CompressionOption DocumentCompressionOption {
    CompressionOption get ();
    void set (CompressionOption value);
}

See Also

Options Class
PerpetuumSoft.Reporting.Export.Xps Namespace


ImageResolution Property

[image]

.NET ModelKit Suite ClassReference
Options..::.ImageResolution Property
Options Class See Also Send Feedback
Gets or sets image resolution.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public int ImageResolution { get; set; }
Visual Basic (Declaration)
Public Property ImageResolution As Integer
Visual C++
public:
property int ImageResolution {
    int get ();
    void set (int value);
}

See Also

Options Class
PerpetuumSoft.Reporting.Export.Xps Namespace


KeepOriginalImageResolution Property

[image]

.NET ModelKit Suite ClassReference
Options..::.KeepOriginalImageResolution Property
Options Class See Also Send Feedback
Gets or sets a value that indicated if the original size of an image should be kept.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public bool KeepOriginalImageResolution { get; set; }
Visual Basic (Declaration)
Public Property KeepOriginalImageResolution As Boolean
Visual C++
public:
property bool KeepOriginalImageResolution {
    bool get ();
    void set (bool value);
}

See Also

Options Class
PerpetuumSoft.Reporting.Export.Xps Namespace


ReplaceFill Property

[image]

.NET ModelKit Suite ClassReference
Options..::.ReplaceFill Property
Options Class See Also Send Feedback
Gets or sets a value that indicates if a picture should be replaced.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public bool ReplaceFill { get; set; }
Visual Basic (Declaration)
Public Property ReplaceFill As Boolean
Visual C++
public:
property bool ReplaceFill {
    bool get ();
    void set (bool value);
}

See Also

Options Class
PerpetuumSoft.Reporting.Export.Xps Namespace


XpsExportFilter Class

[image]

.NET ModelKit Suite ClassReference
XpsExportFilter Class
Members See Also Send Feedback
Represents an export filter to XPS format.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public class XpsExportFilter : ExportFilter
Visual Basic (Declaration)
Public Class XpsExportFilter _
    Inherits ExportFilter
Visual C++
public ref class XpsExportFilter : public ExportFilter

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
PerpetuumSoft.Reporting.Export..::.ExportFilter
PerpetuumSoft.Reporting.Export.Xps..::.XpsExportFilter

See Also

XpsExportFilter Members
PerpetuumSoft.Reporting.Export.Xps Namespace


XpsExportFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
XpsExportFilter Members
XpsExportFilter Class Constructors Methods Properties Events See Also Send Feedback

The XpsExportFilter type exposes the following members.

Constructors

Name | Description
XpsExportFilter | Overloaded.

Methods

Name | Description
CompressionOptionConverter |
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindAdapterType | Returns an adapter type by a filter type.
GetAdapter | Returns an adapter.
GetAvailableParametersNames | Overridden. See GetAvailableParametersNames()()(). (Overrides ExportFilterGetAvailableParametersNames()()().)
GetFactory | Overridden. See GetFactory()()(). (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
RegisterAdapter | Registers a new adapter type.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Overridden. See ShowDialog()()(). (Overrides ExportFilter..::.ShowDialog()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DocumentCompressionOption | Gets or sets CompressionOption that represents document settings options.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ImageResolution | Gets or sets image resolution.
KeepOriginalImageResolution | Gets or sets a value that indicates if the original size of a picture should be kept.
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
ReplaceFill | Gets or sets a value that indicates if a picture should be replaced.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

XpsExportFilter Class
PerpetuumSoft.Reporting.Export.Xps Namespace


XpsExportFilter Constructor

[image] [image]

.NET ModelKit Suite ClassReference
XpsExportFilter Constructor
XpsExportFilter Class See Also Send Feedback

Overload List

Name | Description
XpsExportFilter()()() | Initializes a new instance of the XpsExportFilter class.
XpsExportFilter(IContainer) | Initializes a new instance of the XpsExportFilter class.

See Also

XpsExportFilter Class
XpsExportFilter Members
PerpetuumSoft.Reporting.Export.Xps Namespace


XpsExportFilter Constructor

[image]

.NET ModelKit Suite ClassReference
XpsExportFilter Constructor
XpsExportFilter Class See Also Send Feedback
Initializes a new instance of the XpsExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public XpsExportFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XpsExportFilter()

See Also

XpsExportFilter Class
XpsExportFilter Overload
PerpetuumSoft.Reporting.Export.Xps Namespace


XpsExportFilter Constructor (IContainer)

[image]

.NET ModelKit Suite ClassReference
XpsExportFilter Constructor (IContainer)
XpsExportFilter Class See Also Send Feedback
Initializes a new instance of the XpsExportFilter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public XpsExportFilter(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)
Visual C++
public:
XpsExportFilter(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModel..::.IContainer

See Also

XpsExportFilter Class
XpsExportFilter Overload
PerpetuumSoft.Reporting.Export.Xps Namespace


XpsExportFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
XpsExportFilter Methods
XpsExportFilter Class See Also Send Feedback

The XpsExportFilter type exposes the following members.

Methods

Name | Description
CompressionOptionConverter |
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Export | Overloaded.
ExportDocument | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindAdapterType | Returns an adapter type by a filter type.
GetAdapter | Returns an adapter.
GetAvailableParametersNames | Overridden. See GetAvailableParametersNames()()(). (Overrides ExportFilterGetAvailableParametersNames()()().)
GetFactory | Overridden. See GetFactory()()(). (Overrides ExportFilter..::.GetFactory()()().)
GetFilterFileExtension | Returns standard file extension for the filter. (Inherited from ExportFilter.)
GetFilterFormat | Returns export format name for the filter. (Inherited from ExportFilter.)
GetFilterName | Returns the filter name. (Inherited from ExportFilter.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
RegisterAdapter | Registers a new adapter type.
SelectPages | Returns collection of pages for the page range. (Inherited from ExportFilter.)
ShowDialog | Overridden. See ShowDialog()()(). (Overrides ExportFilter..::.ShowDialog()()().)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

XpsExportFilter Class
PerpetuumSoft.Reporting.Export.Xps Namespace


CompressionOptionConverter Method

[image]

.NET ModelKit Suite ClassReference
XpsExportFilter..::.CompressionOptionConverter Method
XpsExportFilter Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Export.Xps.XpsExportFilter.CompressionOptionConverter(PerpetuumSoft.Reporting.Export.CompressionOptions)]

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public void CompressionOptionConverter(
    CompressionOptions options
)
Visual Basic (Declaration)
Public Sub CompressionOptionConverter ( _
    options As CompressionOptions _
)
Visual C++
public:
virtual void CompressionOptionConverter(
    CompressionOptions options
) sealed

Parameters

options
Type: CompressionOptions

See Also

XpsExportFilter Class
PerpetuumSoft.Reporting.Export.Xps Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
XpsExportFilter..::.Dispose Method
XpsExportFilter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

XpsExportFilter Class
XpsExportFilter Members
PerpetuumSoft.Reporting.Export.Xps Namespace


Export Method

[image] [image]

.NET ModelKit Suite ClassReference
XpsExportFilter..::.Export Method
XpsExportFilter Class See Also Send Feedback

Overload List

Name | Description
Export(Document, Stream) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String) | Exports the specified report document to the specified file. (Inherited from ExportFilter.)
Export(Document, String, Boolean) | Exports the specified report document to the specified file and optionally shows export filter settings dialog. (Inherited from ExportFilter.)

See Also

XpsExportFilter Class
XpsExportFilter Members
PerpetuumSoft.Reporting.Export.Xps Namespace


ExportDocument Method

[image] [image]

.NET ModelKit Suite ClassReference
XpsExportFilter..::.ExportDocument Method
XpsExportFilter Class See Also Send Feedback

Overload List

Name | Description
ExportDocument(Document, Stream) | Exports a document. (Overrides ExportFilter..::.ExportDocument(Document, Stream).)
ExportDocument(Document, String) | Exports a document. (Overrides ExportFilter..::.ExportDocument(Document, String).)

See Also

XpsExportFilter Class
XpsExportFilter Members
PerpetuumSoft.Reporting.Export.Xps Namespace


ExportDocument Method (Document, Stream)

[image]

.NET ModelKit Suite ClassReference
XpsExportFilter..::.ExportDocument Method (Document, Stream)
XpsExportFilter Class See Also Send Feedback
Exports a document.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
protected override void ExportDocument(
    Document document,
    Stream stream
)
Visual Basic (Declaration)
Protected Overrides Sub ExportDocument ( _
    document As Document, _
    stream As Stream _
)
Visual C++
protected:
virtual void ExportDocument(
    Document^ document,
    Stream^ stream
) override

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
stream
Type: System.IO..::.Stream

See Also

XpsExportFilter Class
ExportDocument Overload
PerpetuumSoft.Reporting.Export.Xps Namespace


ExportDocument Method (Document, String)

[image]

.NET ModelKit Suite ClassReference
XpsExportFilter..::.ExportDocument Method (Document, String)
XpsExportFilter Class See Also Send Feedback
Exports a document.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
protected override void ExportDocument(
    Document document,
    string fileName
)
Visual Basic (Declaration)
Protected Overrides Sub ExportDocument ( _
    document As Document, _
    fileName As String _
)
Visual C++
protected:
virtual void ExportDocument(
    Document^ document,
    String^ fileName
) override

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
fileName
Type: System..::.String

See Also

XpsExportFilter Class
ExportDocument Overload
PerpetuumSoft.Reporting.Export.Xps Namespace


FindAdapterType Method

[image]

.NET ModelKit Suite ClassReference
XpsExportFilter..::.FindAdapterType Method
XpsExportFilter Class See Also Send Feedback
Returns an adapter type by a filter type.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public static Type FindAdapterType(
    Type type
)
Visual Basic (Declaration)
Public Shared Function FindAdapterType ( _
    type As Type _
) As Type
Visual C++
public:
static Type^ FindAdapterType(
    Type^ type
)

Parameters

type
Type: System..::.Type

See Also

XpsExportFilter Class
PerpetuumSoft.Reporting.Export.Xps Namespace


GetAdapter Method

[image]

.NET ModelKit Suite ClassReference
XpsExportFilter..::.GetAdapter Method
XpsExportFilter Class See Also Send Feedback
Returns an adapter.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public XpsAdapter GetAdapter(
    ReportControl control
)
Visual Basic (Declaration)
Public Function GetAdapter ( _
    control As ReportControl _
) As XpsAdapter
Visual C++
public:
XpsAdapter^ GetAdapter(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

XpsExportFilter Class
PerpetuumSoft.Reporting.Export.Xps Namespace


GetAvailableParametersNames Method

[image]

.NET ModelKit Suite ClassReference
XpsExportFilter..::.GetAvailableParametersNames Method
XpsExportFilter Class See Also Send Feedback
Overridden. See GetAvailableParametersNames()()().

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override StringCollection GetAvailableParametersNames()
Visual Basic (Declaration)
Public Overrides Function GetAvailableParametersNames As StringCollection
Visual C++
public:
virtual StringCollection^ GetAvailableParametersNames() override

See Also

XpsExportFilter Class
PerpetuumSoft.Reporting.Export.Xps Namespace


GetFactory Method

[image]

.NET ModelKit Suite ClassReference
XpsExportFilter..::.GetFactory Method
XpsExportFilter Class See Also Send Feedback
Overridden. See GetFactory()()().

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilterFactory GetFactory()
Visual Basic (Declaration)
Public Overrides Function GetFactory As ExportFilterFactory
Visual C++
public:
virtual ExportFilterFactory^ GetFactory() override

See Also

XpsExportFilter Class
PerpetuumSoft.Reporting.Export.Xps Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
XpsExportFilter..::.MemberwiseClone Method
XpsExportFilter Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

XpsExportFilter Class
XpsExportFilter Members
PerpetuumSoft.Reporting.Export.Xps Namespace


RegisterAdapter Method

[image]

.NET ModelKit Suite ClassReference
XpsExportFilter..::.RegisterAdapter Method
XpsExportFilter Class See Also Send Feedback
Registers a new adapter type.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public static void RegisterAdapter(
    Type controlType,
    Type adapterType
)
Visual Basic (Declaration)
Public Shared Sub RegisterAdapter ( _
    controlType As Type, _
    adapterType As Type _
)
Visual C++
public:
static void RegisterAdapter(
    Type^ controlType,
    Type^ adapterType
)

Parameters

controlType
Type: System..::.Type
adapterType
Type: System..::.Type

See Also

XpsExportFilter Class
PerpetuumSoft.Reporting.Export.Xps Namespace


ShowDialog Method

[image]

.NET ModelKit Suite ClassReference
XpsExportFilter..::.ShowDialog Method
XpsExportFilter Class See Also Send Feedback
Overridden. See ShowDialog()()().

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override DialogResult ShowDialog()
Visual Basic (Declaration)
Public Overrides Function ShowDialog As DialogResult
Visual C++
public:
virtual DialogResult ShowDialog() override

See Also

XpsExportFilter Class
PerpetuumSoft.Reporting.Export.Xps Namespace


XpsExportFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
XpsExportFilter Properties
XpsExportFilter Class See Also Send Feedback

The XpsExportFilter type exposes the following members.

Properties

Name | Description
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DocumentCompressionOption | Gets or sets CompressionOption that represents document settings options.
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
ImageResolution | Gets or sets image resolution.
KeepOriginalImageResolution | Gets or sets a value that indicates if the original size of a picture should be kept.
PagesRange | Gets or sets pages range for export. (Inherited from ExportFilter.)
ReplaceFill | Gets or sets a value that indicates if a picture should be replaced.
Site | Gets or sets the ISite of the Component. (Inherited from Component.)

See Also

XpsExportFilter Class
PerpetuumSoft.Reporting.Export.Xps Namespace


DocumentCompressionOption Property

[image]

.NET ModelKit Suite ClassReference
XpsExportFilter..::.DocumentCompressionOption Property
XpsExportFilter Class See Also Send Feedback
Gets or sets CompressionOption that represents document settings options.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public CompressionOption DocumentCompressionOption { get; set; }
Visual Basic (Declaration)
Public Property DocumentCompressionOption As CompressionOption
Visual C++
public:
property CompressionOption DocumentCompressionOption {
    CompressionOption get ();
    void set (CompressionOption value);
}

See Also

XpsExportFilter Class
PerpetuumSoft.Reporting.Export.Xps Namespace


ImageResolution Property

[image]

.NET ModelKit Suite ClassReference
XpsExportFilter..::.ImageResolution Property
XpsExportFilter Class See Also Send Feedback
Gets or sets image resolution.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public int ImageResolution { get; set; }
Visual Basic (Declaration)
Public Property ImageResolution As Integer
Visual C++
public:
virtual property int ImageResolution {
    int get () sealed;
    void set (int value) sealed;
}

See Also

XpsExportFilter Class
PerpetuumSoft.Reporting.Export.Xps Namespace


KeepOriginalImageResolution Property

[image]

.NET ModelKit Suite ClassReference
XpsExportFilter..::.KeepOriginalImageResolution Property
XpsExportFilter Class See Also Send Feedback
Gets or sets a value that indicates if the original size of a picture should be kept.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public bool KeepOriginalImageResolution { get; set; }
Visual Basic (Declaration)
Public Property KeepOriginalImageResolution As Boolean
Visual C++
public:
virtual property bool KeepOriginalImageResolution {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

XpsExportFilter Class
PerpetuumSoft.Reporting.Export.Xps Namespace


ReplaceFill Property

[image]

.NET ModelKit Suite ClassReference
XpsExportFilter..::.ReplaceFill Property
XpsExportFilter Class See Also Send Feedback
Gets or sets a value that indicates if a picture should be replaced.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public bool ReplaceFill { get; set; }
Visual Basic (Declaration)
Public Property ReplaceFill As Boolean
Visual C++
public:
virtual property bool ReplaceFill {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

XpsExportFilter Class
PerpetuumSoft.Reporting.Export.Xps Namespace


XpsExportFilter Events

[image] [image]

.NET ModelKit Suite ClassReference
XpsExportFilter Events
XpsExportFilter Class See Also Send Feedback

The XpsExportFilter type exposes the following members.

Events

Name | Description
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)

See Also

XpsExportFilter Class
PerpetuumSoft.Reporting.Export.Xps Namespace


XpsExportFilterFactory Class

[image]

.NET ModelKit Suite ClassReference
XpsExportFilterFactory Class
Members See Also Send Feedback
Represents a Factory for the XPS export filter creation.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public class XpsExportFilterFactory : ExportFilterFactory
Visual Basic (Declaration)
Public Class XpsExportFilterFactory _
    Inherits ExportFilterFactory
Visual C++
public ref class XpsExportFilterFactory : public ExportFilterFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export..::.ExportFilterFactory
PerpetuumSoft.Reporting.Export.Xps..::.XpsExportFilterFactory

See Also

XpsExportFilterFactory Members
PerpetuumSoft.Reporting.Export.Xps Namespace


XpsExportFilterFactory Members

[image] [image]

.NET ModelKit Suite ClassReference
XpsExportFilterFactory Members
XpsExportFilterFactory Class Methods Properties See Also Send Feedback

The XpsExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Overridden. See CreateFilter()()(). (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Overridden. See GetFilterFileExtension()()(). (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Overridden. See GetFilterFormat()()(). (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Factory | Gets XpsExportFilterFactory that represents a Factory for the XPS export filter creation.

See Also

XpsExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Xps Namespace


XpsExportFilterFactory Methods

[image] [image]

.NET ModelKit Suite ClassReference
XpsExportFilterFactory Methods
XpsExportFilterFactory Class See Also Send Feedback

The XpsExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Overridden. See CreateFilter()()(). (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Overridden. See GetFilterFileExtension()()(). (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Overridden. See GetFilterFormat()()(). (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XpsExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Xps Namespace


CreateFilter Method

[image]

.NET ModelKit Suite ClassReference
XpsExportFilterFactory..::.CreateFilter Method
XpsExportFilterFactory Class See Also Send Feedback
Overridden. See CreateFilter()()().

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override ExportFilter CreateFilter()
Visual Basic (Declaration)
Public Overrides Function CreateFilter As ExportFilter
Visual C++
public:
virtual ExportFilter^ CreateFilter() override

See Also

XpsExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Xps Namespace


GetFilterFileExtension Method

[image]

.NET ModelKit Suite ClassReference
XpsExportFilterFactory..::.GetFilterFileExtension Method
XpsExportFilterFactory Class See Also Send Feedback
Overridden. See GetFilterFileExtension()()().

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFileExtension()
Visual Basic (Declaration)
Public Overrides Function GetFilterFileExtension As String
Visual C++
public:
virtual String^ GetFilterFileExtension() override

See Also

XpsExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Xps Namespace


GetFilterFormat Method

[image]

.NET ModelKit Suite ClassReference
XpsExportFilterFactory..::.GetFilterFormat Method
XpsExportFilterFactory Class See Also Send Feedback
Overridden. See GetFilterFormat()()().

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override string GetFilterFormat()
Visual Basic (Declaration)
Public Overrides Function GetFilterFormat As String
Visual C++
public:
virtual String^ GetFilterFormat() override

See Also

XpsExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Xps Namespace


XpsExportFilterFactory Properties

[image] [image]

.NET ModelKit Suite ClassReference
XpsExportFilterFactory Properties
XpsExportFilterFactory Class See Also Send Feedback

The XpsExportFilterFactory type exposes the following members.

Properties

Name | Description
Factory | Gets XpsExportFilterFactory that represents a Factory for the XPS export filter creation.

See Also

XpsExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Xps Namespace


Factory Property

[image]

.NET ModelKit Suite ClassReference
XpsExportFilterFactory..::.Factory Property
XpsExportFilterFactory Class See Also Send Feedback
Gets XpsExportFilterFactory that represents a Factory for the XPS export filter creation.

Namespace: PerpetuumSoft.Reporting.Export.Xps
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public static XpsExportFilterFactory Factory { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Factory As XpsExportFilterFactory
Visual C++
public:
static property XpsExportFilterFactory^ Factory {
    XpsExportFilterFactory^ get ();
}

See Also

XpsExportFilterFactory Class
PerpetuumSoft.Reporting.Export.Xps Namespace


PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace
Send Feedback
The PerpetuumSoft.Reporting.Export.Rtf.Adapters namespace contains classes which are used to export document elements to the XPS (XML Paper Specificationt) format.

Classes

Class | Description
AdvancedTextXpsAdapter | Represents an adapter for the AdvancedText export.
BoxXpsAdapter | Provides methods for the Box element export.
ReportControlXpsAdapter | Represents an adapter for the ReportControl export.
ShapeXpsAdapter | Represents an adapter for the ShapeXps export.
TextBoxXpsAdapter | Represents an adapter for the TextBox export.
XpsAdapter | Represents a base class for all XPS adapters.


AdvancedTextXpsAdapter Class

[image]

.NET ModelKit Suite ClassReference
AdvancedTextXpsAdapter Class
Members See Also Send Feedback
Represents an adapter for the AdvancedText export.

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public class AdvancedTextXpsAdapter : BoxXpsAdapter
Visual Basic (Declaration)
Public Class AdvancedTextXpsAdapter _
    Inherits BoxXpsAdapter
Visual C++
public ref class AdvancedTextXpsAdapter : public BoxXpsAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps.Adapters..::.XpsAdapter
PerpetuumSoft.Reporting.Export.Xps.Adapters..::.BoxXpsAdapter
PerpetuumSoft.Reporting.Export.Xps.Adapters..::.AdvancedTextXpsAdapter

See Also

AdvancedTextXpsAdapter Members
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


AdvancedTextXpsAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextXpsAdapter Members
AdvancedTextXpsAdapter Class Constructors Methods Properties See Also Send Feedback

The AdvancedTextXpsAdapter type exposes the following members.

Constructors

Name | Description
AdvancedTextXpsAdapter | Initializes a new instance of the AdvancedTextXpsAdapter class.

Methods

Name | Description
DrawFill | Draws the fill. (Inherited from BoxXpsAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(Canvas, ReportControl, MediaFill). (Inherited from BoxXpsAdapter.)
RenderContent | Overridden. See RenderContent(Canvas, ReportControl, MediaFill). (Overrides BoxXpsAdapter..::.RenderContent(Canvas, ReportControl, MediaFill).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from XpsAdapter.)

See Also

AdvancedTextXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


AdvancedTextXpsAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
AdvancedTextXpsAdapter Constructor
AdvancedTextXpsAdapter Class See Also Send Feedback
Initializes a new instance of the AdvancedTextXpsAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public AdvancedTextXpsAdapter(
    Options documentOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    documentOptions As Options _
)
Visual C++
public:
AdvancedTextXpsAdapter(
    Options^ documentOptions
)

Parameters

documentOptions
Type: PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

AdvancedTextXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


AdvancedTextXpsAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextXpsAdapter Methods
AdvancedTextXpsAdapter Class See Also Send Feedback

The AdvancedTextXpsAdapter type exposes the following members.

Methods

Name | Description
DrawFill | Draws the fill. (Inherited from BoxXpsAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(Canvas, ReportControl, MediaFill). (Inherited from BoxXpsAdapter.)
RenderContent | Overridden. See RenderContent(Canvas, ReportControl, MediaFill). (Overrides BoxXpsAdapter..::.RenderContent(Canvas, ReportControl, MediaFill).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdvancedTextXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


RenderContent Method

[image]

.NET ModelKit Suite ClassReference
AdvancedTextXpsAdapter..::.RenderContent Method
AdvancedTextXpsAdapter Class See Also Send Feedback
Overridden. See RenderContent(Canvas, ReportControl, MediaFill).

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override void RenderContent(
    Canvas canvas,
    ReportControl control,
    MediaFill fills
)
Visual Basic (Declaration)
Public Overrides Sub RenderContent ( _
    canvas As Canvas, _
    control As ReportControl, _
    fills As MediaFill _
)
Visual C++
public:
virtual void RenderContent(
    Canvas^ canvas,
    ReportControl^ control,
    MediaFill^ fills
) override

Parameters

canvas
Type: System.Windows.Controls..::.Canvas
control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
fills
Type: PerpetuumSoft.Reporting.Export.Xps..::.MediaFill

See Also

AdvancedTextXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


AdvancedTextXpsAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextXpsAdapter Properties
AdvancedTextXpsAdapter Class See Also Send Feedback

The AdvancedTextXpsAdapter type exposes the following members.

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from XpsAdapter.)

See Also

AdvancedTextXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


BoxXpsAdapter Class

[image]

.NET ModelKit Suite ClassReference
BoxXpsAdapter Class
Members See Also Send Feedback
Provides methods for the Box element export.

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public class BoxXpsAdapter : XpsAdapter
Visual Basic (Declaration)
Public Class BoxXpsAdapter _
    Inherits XpsAdapter
Visual C++
public ref class BoxXpsAdapter : public XpsAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps.Adapters..::.XpsAdapter
PerpetuumSoft.Reporting.Export.Xps.Adapters..::.BoxXpsAdapter
PerpetuumSoft.Reporting.Export.Xps.Adapters..::.AdvancedTextXpsAdapter
PerpetuumSoft.Reporting.Export.Xps.Adapters..::.ShapeXpsAdapter
PerpetuumSoft.Reporting.Export.Xps.Adapters..::.TextBoxXpsAdapter

See Also

BoxXpsAdapter Members
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


BoxXpsAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
BoxXpsAdapter Members
BoxXpsAdapter Class Constructors Methods Properties See Also Send Feedback

The BoxXpsAdapter type exposes the following members.

Constructors

Name | Description
BoxXpsAdapter | Initializes a new instance of the BoxXpsAdapter class.

Methods

Name | Description
DrawFill | Draws the fill.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(Canvas, ReportControl, MediaFill). (Overrides XpsAdapter..::.Render(Canvas, ReportControl, MediaFill).)
RenderContent | Exports control content to XPS document.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from XpsAdapter.)

See Also

BoxXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


BoxXpsAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
BoxXpsAdapter Constructor
BoxXpsAdapter Class See Also Send Feedback
Initializes a new instance of the BoxXpsAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public BoxXpsAdapter(
    Options documentOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    documentOptions As Options _
)
Visual C++
public:
BoxXpsAdapter(
    Options^ documentOptions
)

Parameters

documentOptions
Type: PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

BoxXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


BoxXpsAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
BoxXpsAdapter Methods
BoxXpsAdapter Class See Also Send Feedback

The BoxXpsAdapter type exposes the following members.

Methods

Name | Description
DrawFill | Draws the fill.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(Canvas, ReportControl, MediaFill). (Overrides XpsAdapter..::.Render(Canvas, ReportControl, MediaFill).)
RenderContent | Exports control content to XPS document.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoxXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


DrawFill Method

[image]

.NET ModelKit Suite ClassReference
BoxXpsAdapter..::.DrawFill Method
BoxXpsAdapter Class See Also Send Feedback
Draws the fill.

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public void DrawFill(
    Canvas canvas,
    ReportControl control,
    MediaFill fills
)
Visual Basic (Declaration)
Public Sub DrawFill ( _
    canvas As Canvas, _
    control As ReportControl, _
    fills As MediaFill _
)
Visual C++
public:
void DrawFill(
    Canvas^ canvas,
    ReportControl^ control,
    MediaFill^ fills
)

Parameters

canvas
Type: System.Windows.Controls..::.Canvas
control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
fills
Type: PerpetuumSoft.Reporting.Export.Xps..::.MediaFill

See Also

BoxXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
BoxXpsAdapter..::.Render Method
BoxXpsAdapter Class See Also Send Feedback
Overridden. See Render(Canvas, ReportControl, MediaFill).

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override void Render(
    Canvas canvas,
    ReportControl control,
    MediaFill fills
)
Visual Basic (Declaration)
Public Overrides Sub Render ( _
    canvas As Canvas, _
    control As ReportControl, _
    fills As MediaFill _
)
Visual C++
public:
virtual void Render(
    Canvas^ canvas,
    ReportControl^ control,
    MediaFill^ fills
) override

Parameters

canvas
Type: System.Windows.Controls..::.Canvas
control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
fills
Type: PerpetuumSoft.Reporting.Export.Xps..::.MediaFill

See Also

BoxXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


RenderContent Method

[image]

.NET ModelKit Suite ClassReference
BoxXpsAdapter..::.RenderContent Method
BoxXpsAdapter Class See Also Send Feedback
Exports control content to XPS document.

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public virtual void RenderContent(
    Canvas canvas,
    ReportControl control,
    MediaFill fills
)
Visual Basic (Declaration)
Public Overridable Sub RenderContent ( _
    canvas As Canvas, _
    control As ReportControl, _
    fills As MediaFill _
)
Visual C++
public:
virtual void RenderContent(
    Canvas^ canvas,
    ReportControl^ control,
    MediaFill^ fills
)

Parameters

canvas
Type: System.Windows.Controls..::.Canvas
control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
fills
Type: PerpetuumSoft.Reporting.Export.Xps..::.MediaFill

See Also

BoxXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


BoxXpsAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
BoxXpsAdapter Properties
BoxXpsAdapter Class See Also Send Feedback

The BoxXpsAdapter type exposes the following members.

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from XpsAdapter.)

See Also

BoxXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


ReportControlXpsAdapter Class

[image]

.NET ModelKit Suite ClassReference
ReportControlXpsAdapter Class
Members See Also Send Feedback
Represents an adapter for the ReportControl export.

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public class ReportControlXpsAdapter : XpsAdapter
Visual Basic (Declaration)
Public Class ReportControlXpsAdapter _
    Inherits XpsAdapter
Visual C++
public ref class ReportControlXpsAdapter : public XpsAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps.Adapters..::.XpsAdapter
PerpetuumSoft.Reporting.Export.Xps.Adapters..::.ReportControlXpsAdapter

See Also

ReportControlXpsAdapter Members
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


ReportControlXpsAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlXpsAdapter Members
ReportControlXpsAdapter Class Constructors Methods Properties See Also Send Feedback

The ReportControlXpsAdapter type exposes the following members.

Constructors

Name | Description
ReportControlXpsAdapter | Initializes a new instance of the ReportControlXpsAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(Canvas, ReportControl, MediaFill). (Overrides XpsAdapter..::.Render(Canvas, ReportControl, MediaFill).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from XpsAdapter.)

See Also

ReportControlXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


ReportControlXpsAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
ReportControlXpsAdapter Constructor
ReportControlXpsAdapter Class See Also Send Feedback
Initializes a new instance of the ReportControlXpsAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public ReportControlXpsAdapter(
    Options documentOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    documentOptions As Options _
)
Visual C++
public:
ReportControlXpsAdapter(
    Options^ documentOptions
)

Parameters

documentOptions
Type: PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

ReportControlXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


ReportControlXpsAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlXpsAdapter Methods
ReportControlXpsAdapter Class See Also Send Feedback

The ReportControlXpsAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(Canvas, ReportControl, MediaFill). (Overrides XpsAdapter..::.Render(Canvas, ReportControl, MediaFill).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportControlXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
ReportControlXpsAdapter..::.Render Method
ReportControlXpsAdapter Class See Also Send Feedback
Overridden. See Render(Canvas, ReportControl, MediaFill).

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override void Render(
    Canvas canvas,
    ReportControl control,
    MediaFill fills
)
Visual Basic (Declaration)
Public Overrides Sub Render ( _
    canvas As Canvas, _
    control As ReportControl, _
    fills As MediaFill _
)
Visual C++
public:
virtual void Render(
    Canvas^ canvas,
    ReportControl^ control,
    MediaFill^ fills
) override

Parameters

canvas
Type: System.Windows.Controls..::.Canvas
control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
fills
Type: PerpetuumSoft.Reporting.Export.Xps..::.MediaFill

See Also

ReportControlXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


ReportControlXpsAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlXpsAdapter Properties
ReportControlXpsAdapter Class See Also Send Feedback

The ReportControlXpsAdapter type exposes the following members.

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from XpsAdapter.)

See Also

ReportControlXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


ShapeXpsAdapter Class

[image]

.NET ModelKit Suite ClassReference
ShapeXpsAdapter Class
Members See Also Send Feedback
Represents an adapter for the ShapeXps export.

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public class ShapeXpsAdapter : BoxXpsAdapter
Visual Basic (Declaration)
Public Class ShapeXpsAdapter _
    Inherits BoxXpsAdapter
Visual C++
public ref class ShapeXpsAdapter : public BoxXpsAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps.Adapters..::.XpsAdapter
PerpetuumSoft.Reporting.Export.Xps.Adapters..::.BoxXpsAdapter
PerpetuumSoft.Reporting.Export.Xps.Adapters..::.ShapeXpsAdapter

See Also

ShapeXpsAdapter Members
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


ShapeXpsAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
ShapeXpsAdapter Members
ShapeXpsAdapter Class Constructors Methods Properties See Also Send Feedback

The ShapeXpsAdapter type exposes the following members.

Constructors

Name | Description
ShapeXpsAdapter | Initializes a new instance of the ShapeXpsAdapter class.

Methods

Name | Description
DrawFill | Draws the fill. (Inherited from BoxXpsAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(Canvas, ReportControl, MediaFill). (Overrides BoxXpsAdapter..::.Render(Canvas, ReportControl, MediaFill).)
RenderContent | Exports control content to XPS document. (Inherited from BoxXpsAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from XpsAdapter.)

See Also

ShapeXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


ShapeXpsAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
ShapeXpsAdapter Constructor
ShapeXpsAdapter Class See Also Send Feedback
Initializes a new instance of the ShapeXpsAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public ShapeXpsAdapter(
    Options documentOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    documentOptions As Options _
)
Visual C++
public:
ShapeXpsAdapter(
    Options^ documentOptions
)

Parameters

documentOptions
Type: PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

ShapeXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


ShapeXpsAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ShapeXpsAdapter Methods
ShapeXpsAdapter Class See Also Send Feedback

The ShapeXpsAdapter type exposes the following members.

Methods

Name | Description
DrawFill | Draws the fill. (Inherited from BoxXpsAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(Canvas, ReportControl, MediaFill). (Overrides BoxXpsAdapter..::.Render(Canvas, ReportControl, MediaFill).)
RenderContent | Exports control content to XPS document. (Inherited from BoxXpsAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShapeXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
ShapeXpsAdapter..::.Render Method
ShapeXpsAdapter Class See Also Send Feedback
Overridden. See Render(Canvas, ReportControl, MediaFill).

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override void Render(
    Canvas canvas,
    ReportControl control,
    MediaFill fills
)
Visual Basic (Declaration)
Public Overrides Sub Render ( _
    canvas As Canvas, _
    control As ReportControl, _
    fills As MediaFill _
)
Visual C++
public:
virtual void Render(
    Canvas^ canvas,
    ReportControl^ control,
    MediaFill^ fills
) override

Parameters

canvas
Type: System.Windows.Controls..::.Canvas
control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
fills
Type: PerpetuumSoft.Reporting.Export.Xps..::.MediaFill

See Also

ShapeXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


ShapeXpsAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
ShapeXpsAdapter Properties
ShapeXpsAdapter Class See Also Send Feedback

The ShapeXpsAdapter type exposes the following members.

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from XpsAdapter.)

See Also

ShapeXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


TextBoxXpsAdapter Class

[image]

.NET ModelKit Suite ClassReference
TextBoxXpsAdapter Class
Members See Also Send Feedback
Represents an adapter for the TextBox export.

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public class TextBoxXpsAdapter : BoxXpsAdapter
Visual Basic (Declaration)
Public Class TextBoxXpsAdapter _
    Inherits BoxXpsAdapter
Visual C++
public ref class TextBoxXpsAdapter : public BoxXpsAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps.Adapters..::.XpsAdapter
PerpetuumSoft.Reporting.Export.Xps.Adapters..::.BoxXpsAdapter
PerpetuumSoft.Reporting.Export.Xps.Adapters..::.TextBoxXpsAdapter

See Also

TextBoxXpsAdapter Members
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


TextBoxXpsAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxXpsAdapter Members
TextBoxXpsAdapter Class Constructors Methods Properties See Also Send Feedback

The TextBoxXpsAdapter type exposes the following members.

Constructors

Name | Description
TextBoxXpsAdapter | Initializes a new instance of the TextBoxXpsAdapter class.

Methods

Name | Description
DrawFill | Draws the fill. (Inherited from BoxXpsAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(Canvas, ReportControl, MediaFill). (Inherited from BoxXpsAdapter.)
RenderContent | Overridden. See RenderContent(Canvas, ReportControl, MediaFill). (Overrides BoxXpsAdapter..::.RenderContent(Canvas, ReportControl, MediaFill).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from XpsAdapter.)

See Also

TextBoxXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


TextBoxXpsAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
TextBoxXpsAdapter Constructor
TextBoxXpsAdapter Class See Also Send Feedback
Initializes a new instance of the TextBoxXpsAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public TextBoxXpsAdapter(
    Options documentOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    documentOptions As Options _
)
Visual C++
public:
TextBoxXpsAdapter(
    Options^ documentOptions
)

Parameters

documentOptions
Type: PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

TextBoxXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


TextBoxXpsAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxXpsAdapter Methods
TextBoxXpsAdapter Class See Also Send Feedback

The TextBoxXpsAdapter type exposes the following members.

Methods

Name | Description
DrawFill | Draws the fill. (Inherited from BoxXpsAdapter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Overridden. See Render(Canvas, ReportControl, MediaFill). (Inherited from BoxXpsAdapter.)
RenderContent | Overridden. See RenderContent(Canvas, ReportControl, MediaFill). (Overrides BoxXpsAdapter..::.RenderContent(Canvas, ReportControl, MediaFill).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextBoxXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


RenderContent Method

[image]

.NET ModelKit Suite ClassReference
TextBoxXpsAdapter..::.RenderContent Method
TextBoxXpsAdapter Class See Also Send Feedback
Overridden. See RenderContent(Canvas, ReportControl, MediaFill).

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override void RenderContent(
    Canvas canvas,
    ReportControl control,
    MediaFill fills
)
Visual Basic (Declaration)
Public Overrides Sub RenderContent ( _
    canvas As Canvas, _
    control As ReportControl, _
    fills As MediaFill _
)
Visual C++
public:
virtual void RenderContent(
    Canvas^ canvas,
    ReportControl^ control,
    MediaFill^ fills
) override

Parameters

canvas
Type: System.Windows.Controls..::.Canvas
control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
fills
Type: PerpetuumSoft.Reporting.Export.Xps..::.MediaFill

See Also

TextBoxXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


TextBoxXpsAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxXpsAdapter Properties
TextBoxXpsAdapter Class See Also Send Feedback

The TextBoxXpsAdapter type exposes the following members.

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from XpsAdapter.)

See Also

TextBoxXpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


XpsAdapter Class

[image]

.NET ModelKit Suite ClassReference
XpsAdapter Class
Members See Also Send Feedback
Represents a base class for all XPS adapters.

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public abstract class XpsAdapter
Visual Basic (Declaration)
Public MustInherit Class XpsAdapter
Visual C++
public ref class XpsAdapter abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps.Adapters..::.XpsAdapter
PerpetuumSoft.Reporting.Export.Xps.Adapters..::.BoxXpsAdapter
PerpetuumSoft.Reporting.Export.Xps.Adapters..::.ReportControlXpsAdapter

See Also

XpsAdapter Members
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


XpsAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
XpsAdapter Members
XpsAdapter Class Constructors Methods Properties See Also Send Feedback

The XpsAdapter type exposes the following members.

Constructors

Name | Description
XpsAdapter | Initializes a new instance of the XpsAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Exports a defined control to XPS format.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format.

See Also

XpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


XpsAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
XpsAdapter Constructor
XpsAdapter Class See Also Send Feedback
Initializes a new instance of the XpsAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public XpsAdapter(
    Options documentOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    documentOptions As Options _
)
Visual C++
public:
XpsAdapter(
    Options^ documentOptions
)

Parameters

documentOptions
Type: PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

XpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


XpsAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
XpsAdapter Methods
XpsAdapter Class See Also Send Feedback

The XpsAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Render | Exports a defined control to XPS format.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
XpsAdapter..::.Render Method
XpsAdapter Class See Also Send Feedback
Exports a defined control to XPS format.

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public abstract void Render(
    Canvas canvas,
    ReportControl control,
    MediaFill fills
)
Visual Basic (Declaration)
Public MustOverride Sub Render ( _
    canvas As Canvas, _
    control As ReportControl, _
    fills As MediaFill _
)
Visual C++
public:
virtual void Render(
    Canvas^ canvas,
    ReportControl^ control,
    MediaFill^ fills
) abstract

Parameters

canvas
Type: System.Windows.Controls..::.Canvas
control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
fills
Type: PerpetuumSoft.Reporting.Export.Xps..::.MediaFill

See Also

XpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


XpsAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
XpsAdapter Properties
XpsAdapter Class See Also Send Feedback

The XpsAdapter type exposes the following members.

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format.

See Also

XpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


DocumentOptions Property

[image]

.NET ModelKit Suite ClassReference
XpsAdapter..::.DocumentOptions Property
XpsAdapter Class See Also Send Feedback
Gets or sets Options that represents export options to XPS format.

Namespace: PerpetuumSoft.Reporting.Export.Xps.Adapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public Options DocumentOptions { get; set; }
Visual Basic (Declaration)
Public Property DocumentOptions As Options
Visual C++
public:
property Options^ DocumentOptions {
    Options^ get ();
    void set (Options^ value);
}

See Also

XpsAdapter Class
PerpetuumSoft.Reporting.Export.Xps.Adapters Namespace


PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace
Send Feedback
The PerpetuumSoft.Reporting.Export.Rtf.Adapters namespace contains classes which are used to export fill to the XPS (XML Paper Specificationt) format.

Classes

Class | Description
EmptyFillAdapter | Represents an adapter for the EmptyFill export.
FillAdapter | Represents methods for fill export.
LinearGradientFillAdapter | Represents an adapter for the LinearGradienFill export.
MultiGradientFillAdapter | Represents an adapter for the MultiGradienFill export.
SolidFillAdapter | Represents an adapter for the SolidFill export.
SphericalFillAdapter | Represents an adapter for the SphericalFill export.
UnknownFillAdapter | Represents an adapter for the Unknown Fill export.


EmptyFillAdapter Class

[image]

.NET ModelKit Suite ClassReference
EmptyFillAdapter Class
Members See Also Send Feedback
Represents an adapter for the EmptyFill export.

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public class EmptyFillAdapter : FillAdapter
Visual Basic (Declaration)
Public Class EmptyFillAdapter _
    Inherits FillAdapter
Visual C++
public ref class EmptyFillAdapter : public FillAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps.FillAdapters..::.FillAdapter
PerpetuumSoft.Reporting.Export.Xps.FillAdapters..::.EmptyFillAdapter

See Also

EmptyFillAdapter Members
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


EmptyFillAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
EmptyFillAdapter Members
EmptyFillAdapter Class Constructors Methods Properties See Also Send Feedback

The EmptyFillAdapter type exposes the following members.

Constructors

Name | Description
EmptyFillAdapter | Initializes a new instance of the EmptyFillAdapter class.

Methods

Name | Description
CreateBrush | Overridden. See CreateBrush(Fill, VectorRectangle). (Overrides FillAdapter..::.CreateBrush(Fill, VectorRectangle).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from FillAdapter.)

See Also

EmptyFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


EmptyFillAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
EmptyFillAdapter Constructor
EmptyFillAdapter Class See Also Send Feedback
Initializes a new instance of the EmptyFillAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public EmptyFillAdapter(
    Options documentOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    documentOptions As Options _
)
Visual C++
public:
EmptyFillAdapter(
    Options^ documentOptions
)

Parameters

documentOptions
Type: PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

EmptyFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


EmptyFillAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
EmptyFillAdapter Methods
EmptyFillAdapter Class See Also Send Feedback

The EmptyFillAdapter type exposes the following members.

Methods

Name | Description
CreateBrush | Overridden. See CreateBrush(Fill, VectorRectangle). (Overrides FillAdapter..::.CreateBrush(Fill, VectorRectangle).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmptyFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


CreateBrush Method

[image]

.NET ModelKit Suite ClassReference
EmptyFillAdapter..::.CreateBrush Method
EmptyFillAdapter Class See Also Send Feedback
Overridden. See CreateBrush(Fill, VectorRectangle).

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override Brush CreateBrush(
    Fill fill,
    VectorRectangle contentRectangle
)
Visual Basic (Declaration)
Public Overrides Function CreateBrush ( _
    fill As Fill, _
    contentRectangle As VectorRectangle _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    Fill^ fill,
    VectorRectangle contentRectangle
) override

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
contentRectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

EmptyFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


EmptyFillAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
EmptyFillAdapter Properties
EmptyFillAdapter Class See Also Send Feedback

The EmptyFillAdapter type exposes the following members.

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from FillAdapter.)

See Also

EmptyFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


FillAdapter Class

[image]

.NET ModelKit Suite ClassReference
FillAdapter Class
Members See Also Send Feedback
Represents methods for fill export.

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public abstract class FillAdapter
Visual Basic (Declaration)
Public MustInherit Class FillAdapter
Visual C++
public ref class FillAdapter abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps.FillAdapters..::.FillAdapter
PerpetuumSoft.Reporting.Export.Xps.FillAdapters..::.EmptyFillAdapter
PerpetuumSoft.Reporting.Export.Xps.FillAdapters..::.LinearGradientFillAdapter
PerpetuumSoft.Reporting.Export.Xps.FillAdapters..::.MultiGradientFillAdapter
PerpetuumSoft.Reporting.Export.Xps.FillAdapters..::.SolidFillAdapter
PerpetuumSoft.Reporting.Export.Xps.FillAdapters..::.SphericalFillAdapter
PerpetuumSoft.Reporting.Export.Xps.FillAdapters..::.UnknownFillAdapter

See Also

FillAdapter Members
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


FillAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
FillAdapter Members
FillAdapter Class Constructors Methods Properties See Also Send Feedback

The FillAdapter type exposes the following members.

Constructors

Name | Description
FillAdapter | Initializes a new instance of the FillAdapter class.

Methods

Name | Description
CreateBrush | Creates a brush by a specified fill.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format.

See Also

FillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


FillAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
FillAdapter Constructor
FillAdapter Class See Also Send Feedback
Initializes a new instance of the FillAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public FillAdapter(
    Options documentOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    documentOptions As Options _
)
Visual C++
public:
FillAdapter(
    Options^ documentOptions
)

Parameters

documentOptions
Type: PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

FillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


FillAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
FillAdapter Methods
FillAdapter Class See Also Send Feedback

The FillAdapter type exposes the following members.

Methods

Name | Description
CreateBrush | Creates a brush by a specified fill.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


CreateBrush Method

[image]

.NET ModelKit Suite ClassReference
FillAdapter..::.CreateBrush Method
FillAdapter Class See Also Send Feedback
Creates a brush by a specified fill.

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public abstract Brush CreateBrush(
    Fill fill,
    VectorRectangle contentRectangle
)
Visual Basic (Declaration)
Public MustOverride Function CreateBrush ( _
    fill As Fill, _
    contentRectangle As VectorRectangle _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    Fill^ fill,
    VectorRectangle contentRectangle
) abstract

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
contentRectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

FillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


FillAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
FillAdapter Properties
FillAdapter Class See Also Send Feedback

The FillAdapter type exposes the following members.

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format.

See Also

FillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


DocumentOptions Property

[image]

.NET ModelKit Suite ClassReference
FillAdapter..::.DocumentOptions Property
FillAdapter Class See Also Send Feedback
Gets or sets Options that represents export options to XPS format.

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public Options DocumentOptions { get; set; }
Visual Basic (Declaration)
Public Property DocumentOptions As Options
Visual C++
public:
property Options^ DocumentOptions {
    Options^ get ();
    void set (Options^ value);
}

See Also

FillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


LinearGradientFillAdapter Class

[image]

.NET ModelKit Suite ClassReference
LinearGradientFillAdapter Class
Members See Also Send Feedback
Represents an adapter for the LinearGradienFill export.

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public class LinearGradientFillAdapter : FillAdapter
Visual Basic (Declaration)
Public Class LinearGradientFillAdapter _
    Inherits FillAdapter
Visual C++
public ref class LinearGradientFillAdapter : public FillAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps.FillAdapters..::.FillAdapter
PerpetuumSoft.Reporting.Export.Xps.FillAdapters..::.LinearGradientFillAdapter

See Also

LinearGradientFillAdapter Members
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


LinearGradientFillAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
LinearGradientFillAdapter Members
LinearGradientFillAdapter Class Constructors Methods Properties See Also Send Feedback

The LinearGradientFillAdapter type exposes the following members.

Constructors

Name | Description
LinearGradientFillAdapter | Initializes a new instance of the LinearGradientFillAdapter class.

Methods

Name | Description
CreateBrush | Overridden. See CreateBrush(Fill, VectorRectangle). (Overrides FillAdapter..::.CreateBrush(Fill, VectorRectangle).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from FillAdapter.)

See Also

LinearGradientFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


LinearGradientFillAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
LinearGradientFillAdapter Constructor
LinearGradientFillAdapter Class See Also Send Feedback
Initializes a new instance of the LinearGradientFillAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public LinearGradientFillAdapter(
    Options documentOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    documentOptions As Options _
)
Visual C++
public:
LinearGradientFillAdapter(
    Options^ documentOptions
)

Parameters

documentOptions
Type: PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

LinearGradientFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


LinearGradientFillAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
LinearGradientFillAdapter Methods
LinearGradientFillAdapter Class See Also Send Feedback

The LinearGradientFillAdapter type exposes the following members.

Methods

Name | Description
CreateBrush | Overridden. See CreateBrush(Fill, VectorRectangle). (Overrides FillAdapter..::.CreateBrush(Fill, VectorRectangle).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinearGradientFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


CreateBrush Method

[image]

.NET ModelKit Suite ClassReference
LinearGradientFillAdapter..::.CreateBrush Method
LinearGradientFillAdapter Class See Also Send Feedback
Overridden. See CreateBrush(Fill, VectorRectangle).

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override Brush CreateBrush(
    Fill fill,
    VectorRectangle contentRectangle
)
Visual Basic (Declaration)
Public Overrides Function CreateBrush ( _
    fill As Fill, _
    contentRectangle As VectorRectangle _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    Fill^ fill,
    VectorRectangle contentRectangle
) override

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
contentRectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

LinearGradientFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


LinearGradientFillAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
LinearGradientFillAdapter Properties
LinearGradientFillAdapter Class See Also Send Feedback

The LinearGradientFillAdapter type exposes the following members.

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from FillAdapter.)

See Also

LinearGradientFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


MultiGradientFillAdapter Class

[image]

.NET ModelKit Suite ClassReference
MultiGradientFillAdapter Class
Members See Also Send Feedback
Represents an adapter for the MultiGradienFill export.

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public class MultiGradientFillAdapter : FillAdapter
Visual Basic (Declaration)
Public Class MultiGradientFillAdapter _
    Inherits FillAdapter
Visual C++
public ref class MultiGradientFillAdapter : public FillAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps.FillAdapters..::.FillAdapter
PerpetuumSoft.Reporting.Export.Xps.FillAdapters..::.MultiGradientFillAdapter

See Also

MultiGradientFillAdapter Members
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


MultiGradientFillAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
MultiGradientFillAdapter Members
MultiGradientFillAdapter Class Constructors Methods Properties See Also Send Feedback

The MultiGradientFillAdapter type exposes the following members.

Constructors

Name | Description
MultiGradientFillAdapter | Initializes a new instance of the MultiGradientFillAdapter class.

Methods

Name | Description
CreateBrush | Overridden. See CreateBrush(Fill, VectorRectangle). (Overrides FillAdapter..::.CreateBrush(Fill, VectorRectangle).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from FillAdapter.)

See Also

MultiGradientFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


MultiGradientFillAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
MultiGradientFillAdapter Constructor
MultiGradientFillAdapter Class See Also Send Feedback
Initializes a new instance of the MultiGradientFillAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public MultiGradientFillAdapter(
    Options documentOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    documentOptions As Options _
)
Visual C++
public:
MultiGradientFillAdapter(
    Options^ documentOptions
)

Parameters

documentOptions
Type: PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

MultiGradientFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


MultiGradientFillAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
MultiGradientFillAdapter Methods
MultiGradientFillAdapter Class See Also Send Feedback

The MultiGradientFillAdapter type exposes the following members.

Methods

Name | Description
CreateBrush | Overridden. See CreateBrush(Fill, VectorRectangle). (Overrides FillAdapter..::.CreateBrush(Fill, VectorRectangle).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultiGradientFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


CreateBrush Method

[image]

.NET ModelKit Suite ClassReference
MultiGradientFillAdapter..::.CreateBrush Method
MultiGradientFillAdapter Class See Also Send Feedback
Overridden. See CreateBrush(Fill, VectorRectangle).

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override Brush CreateBrush(
    Fill fill,
    VectorRectangle contentRectangle
)
Visual Basic (Declaration)
Public Overrides Function CreateBrush ( _
    fill As Fill, _
    contentRectangle As VectorRectangle _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    Fill^ fill,
    VectorRectangle contentRectangle
) override

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
contentRectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

MultiGradientFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


MultiGradientFillAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
MultiGradientFillAdapter Properties
MultiGradientFillAdapter Class See Also Send Feedback

The MultiGradientFillAdapter type exposes the following members.

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from FillAdapter.)

See Also

MultiGradientFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


SolidFillAdapter Class

[image]

.NET ModelKit Suite ClassReference
SolidFillAdapter Class
Members See Also Send Feedback
Represents an adapter for the SolidFill export.

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public class SolidFillAdapter : FillAdapter
Visual Basic (Declaration)
Public Class SolidFillAdapter _
    Inherits FillAdapter
Visual C++
public ref class SolidFillAdapter : public FillAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps.FillAdapters..::.FillAdapter
PerpetuumSoft.Reporting.Export.Xps.FillAdapters..::.SolidFillAdapter

See Also

SolidFillAdapter Members
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


SolidFillAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
SolidFillAdapter Members
SolidFillAdapter Class Constructors Methods Properties See Also Send Feedback

The SolidFillAdapter type exposes the following members.

Constructors

Name | Description
SolidFillAdapter | Initializes a new instance of the SolidFillAdapter class.

Methods

Name | Description
CreateBrush | Overridden. See CreateBrush(Fill, VectorRectangle). (Overrides FillAdapter..::.CreateBrush(Fill, VectorRectangle).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from FillAdapter.)

See Also

SolidFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


SolidFillAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
SolidFillAdapter Constructor
SolidFillAdapter Class See Also Send Feedback
Initializes a new instance of the SolidFillAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public SolidFillAdapter(
    Options documentOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    documentOptions As Options _
)
Visual C++
public:
SolidFillAdapter(
    Options^ documentOptions
)

Parameters

documentOptions
Type: PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

SolidFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


SolidFillAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
SolidFillAdapter Methods
SolidFillAdapter Class See Also Send Feedback

The SolidFillAdapter type exposes the following members.

Methods

Name | Description
CreateBrush | Overridden. See CreateBrush(Fill, VectorRectangle). (Overrides FillAdapter..::.CreateBrush(Fill, VectorRectangle).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SolidFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


CreateBrush Method

[image]

.NET ModelKit Suite ClassReference
SolidFillAdapter..::.CreateBrush Method
SolidFillAdapter Class See Also Send Feedback
Overridden. See CreateBrush(Fill, VectorRectangle).

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override Brush CreateBrush(
    Fill fill,
    VectorRectangle contentRectangle
)
Visual Basic (Declaration)
Public Overrides Function CreateBrush ( _
    fill As Fill, _
    contentRectangle As VectorRectangle _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    Fill^ fill,
    VectorRectangle contentRectangle
) override

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
contentRectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

SolidFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


SolidFillAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
SolidFillAdapter Properties
SolidFillAdapter Class See Also Send Feedback

The SolidFillAdapter type exposes the following members.

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from FillAdapter.)

See Also

SolidFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


SphericalFillAdapter Class

[image]

.NET ModelKit Suite ClassReference
SphericalFillAdapter Class
Members See Also Send Feedback
Represents an adapter for the SphericalFill export.

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public class SphericalFillAdapter : FillAdapter
Visual Basic (Declaration)
Public Class SphericalFillAdapter _
    Inherits FillAdapter
Visual C++
public ref class SphericalFillAdapter : public FillAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps.FillAdapters..::.FillAdapter
PerpetuumSoft.Reporting.Export.Xps.FillAdapters..::.SphericalFillAdapter

See Also

SphericalFillAdapter Members
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


SphericalFillAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
SphericalFillAdapter Members
SphericalFillAdapter Class Constructors Methods Properties See Also Send Feedback

The SphericalFillAdapter type exposes the following members.

Constructors

Name | Description
SphericalFillAdapter | Initializes a new instance of the SphericalFillAdapter class.

Methods

Name | Description
CreateBrush | Overridden. See CreateBrush(Fill, VectorRectangle). (Overrides FillAdapter..::.CreateBrush(Fill, VectorRectangle).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from FillAdapter.)

See Also

SphericalFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


SphericalFillAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
SphericalFillAdapter Constructor
SphericalFillAdapter Class See Also Send Feedback
Initializes a new instance of the SphericalFillAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public SphericalFillAdapter(
    Options documentOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    documentOptions As Options _
)
Visual C++
public:
SphericalFillAdapter(
    Options^ documentOptions
)

Parameters

documentOptions
Type: PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

SphericalFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


SphericalFillAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
SphericalFillAdapter Methods
SphericalFillAdapter Class See Also Send Feedback

The SphericalFillAdapter type exposes the following members.

Methods

Name | Description
CreateBrush | Overridden. See CreateBrush(Fill, VectorRectangle). (Overrides FillAdapter..::.CreateBrush(Fill, VectorRectangle).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SphericalFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


CreateBrush Method

[image]

.NET ModelKit Suite ClassReference
SphericalFillAdapter..::.CreateBrush Method
SphericalFillAdapter Class See Also Send Feedback
Overridden. See CreateBrush(Fill, VectorRectangle).

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override Brush CreateBrush(
    Fill fill,
    VectorRectangle contentRectangle
)
Visual Basic (Declaration)
Public Overrides Function CreateBrush ( _
    fill As Fill, _
    contentRectangle As VectorRectangle _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    Fill^ fill,
    VectorRectangle contentRectangle
) override

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
contentRectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

SphericalFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


SphericalFillAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
SphericalFillAdapter Properties
SphericalFillAdapter Class See Also Send Feedback

The SphericalFillAdapter type exposes the following members.

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from FillAdapter.)

See Also

SphericalFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


UnknownFillAdapter Class

[image]

.NET ModelKit Suite ClassReference
UnknownFillAdapter Class
Members See Also Send Feedback
Represents an adapter for the Unknown Fill export.

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public class UnknownFillAdapter : FillAdapter
Visual Basic (Declaration)
Public Class UnknownFillAdapter _
    Inherits FillAdapter
Visual C++
public ref class UnknownFillAdapter : public FillAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps.FillAdapters..::.FillAdapter
PerpetuumSoft.Reporting.Export.Xps.FillAdapters..::.UnknownFillAdapter

See Also

UnknownFillAdapter Members
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


UnknownFillAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
UnknownFillAdapter Members
UnknownFillAdapter Class Constructors Methods Properties See Also Send Feedback

The UnknownFillAdapter type exposes the following members.

Constructors

Name | Description
UnknownFillAdapter | Initializes a new instance of the UnknownFillAdapter class.

Methods

Name | Description
CreateBrush | Overridden. See CreateBrush(Fill, VectorRectangle). (Overrides FillAdapter..::.CreateBrush(Fill, VectorRectangle).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from FillAdapter.)

See Also

UnknownFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


UnknownFillAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
UnknownFillAdapter Constructor
UnknownFillAdapter Class See Also Send Feedback
Initializes a new instance of the UnknownFillAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public UnknownFillAdapter(
    Options documentOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    documentOptions As Options _
)
Visual C++
public:
UnknownFillAdapter(
    Options^ documentOptions
)

Parameters

documentOptions
Type: PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

UnknownFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


UnknownFillAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
UnknownFillAdapter Methods
UnknownFillAdapter Class See Also Send Feedback

The UnknownFillAdapter type exposes the following members.

Methods

Name | Description
CreateBrush | Overridden. See CreateBrush(Fill, VectorRectangle). (Overrides FillAdapter..::.CreateBrush(Fill, VectorRectangle).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UnknownFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


CreateBrush Method

[image]

.NET ModelKit Suite ClassReference
UnknownFillAdapter..::.CreateBrush Method
UnknownFillAdapter Class See Also Send Feedback
Overridden. See CreateBrush(Fill, VectorRectangle).

Namespace: PerpetuumSoft.Reporting.Export.Xps.FillAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override Brush CreateBrush(
    Fill fill,
    VectorRectangle contentRectangle
)
Visual Basic (Declaration)
Public Overrides Function CreateBrush ( _
    fill As Fill, _
    contentRectangle As VectorRectangle _
) As Brush
Visual C++
public:
virtual Brush^ CreateBrush(
    Fill^ fill,
    VectorRectangle contentRectangle
) override

Parameters

fill
Type: PerpetuumSoft.Framework.Drawing..::.Fill
contentRectangle
Type: PerpetuumSoft.Framework.Drawing..::.VectorRectangle

See Also

UnknownFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


UnknownFillAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
UnknownFillAdapter Properties
UnknownFillAdapter Class See Also Send Feedback

The UnknownFillAdapter type exposes the following members.

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from FillAdapter.)

See Also

UnknownFillAdapter Class
PerpetuumSoft.Reporting.Export.Xps.FillAdapters Namespace


PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace
Send Feedback
The PerpetuumSoft.Reporting.Export.Rtf.Adapters namespace contains classes which are used to export shape to the XPS (XML Paper Specificationt) format.

Classes

Class | Description
EllipseAdapter | Represents an adapter for the Ellipse export.
LineAdapter | Provides an adapter for the Line control.
PolygonAdapter | Represents an adapter for the Polygon export.
RoundRectangleAdapter | Represents an adapter for the RounRectangle export.
ShapeAdapter | Represents an adapter for the Shape control.


EllipseAdapter Class

[image]

.NET ModelKit Suite ClassReference
EllipseAdapter Class
Members See Also Send Feedback
Represents an adapter for the Ellipse export.

Namespace: PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public class EllipseAdapter : ShapeAdapter
Visual Basic (Declaration)
Public Class EllipseAdapter _
    Inherits ShapeAdapter
Visual C++
public ref class EllipseAdapter : public ShapeAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters..::.ShapeAdapter
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters..::.EllipseAdapter

See Also

EllipseAdapter Members
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


EllipseAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
EllipseAdapter Members
EllipseAdapter Class Constructors Methods Properties See Also Send Feedback

The EllipseAdapter type exposes the following members.

Constructors

Name | Description
EllipseAdapter | Initializes a new instance of the EllipseAdapter class.

Methods

Name | Description
DrawShape | Overridden. See DrawShape(Canvas, Shape, MediaFill). (Overrides ShapeAdapter..::.DrawShape(Canvas, Shape, MediaFill).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from ShapeAdapter.)

See Also

EllipseAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


EllipseAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
EllipseAdapter Constructor
EllipseAdapter Class See Also Send Feedback
Initializes a new instance of the EllipseAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public EllipseAdapter(
    Options documentOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    documentOptions As Options _
)
Visual C++
public:
EllipseAdapter(
    Options^ documentOptions
)

Parameters

documentOptions
Type: PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

EllipseAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


EllipseAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
EllipseAdapter Methods
EllipseAdapter Class See Also Send Feedback

The EllipseAdapter type exposes the following members.

Methods

Name | Description
DrawShape | Overridden. See DrawShape(Canvas, Shape, MediaFill). (Overrides ShapeAdapter..::.DrawShape(Canvas, Shape, MediaFill).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EllipseAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


DrawShape Method

[image]

.NET ModelKit Suite ClassReference
EllipseAdapter..::.DrawShape Method
EllipseAdapter Class See Also Send Feedback
Overridden. See DrawShape(Canvas, Shape, MediaFill).

Namespace: PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawShape(
    Canvas canvas,
    Shape source,
    MediaFill fills
)
Visual Basic (Declaration)
Public Overrides Sub DrawShape ( _
    canvas As Canvas, _
    source As Shape, _
    fills As MediaFill _
)
Visual C++
public:
virtual void DrawShape(
    Canvas^ canvas,
    Shape^ source,
    MediaFill^ fills
) override

Parameters

canvas
Type: System.Windows.Controls..::.Canvas
source
Type: PerpetuumSoft.Reporting.DOM..::.Shape
fills
Type: PerpetuumSoft.Reporting.Export.Xps..::.MediaFill

See Also

EllipseAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


EllipseAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
EllipseAdapter Properties
EllipseAdapter Class See Also Send Feedback

The EllipseAdapter type exposes the following members.

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from ShapeAdapter.)

See Also

EllipseAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


LineAdapter Class

[image]

.NET ModelKit Suite ClassReference
LineAdapter Class
Members See Also Send Feedback
Provides an adapter for the Line control.

Namespace: PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public class LineAdapter : ShapeAdapter
Visual Basic (Declaration)
Public Class LineAdapter _
    Inherits ShapeAdapter
Visual C++
public ref class LineAdapter : public ShapeAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters..::.ShapeAdapter
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters..::.LineAdapter

See Also

LineAdapter Members
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


LineAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
LineAdapter Members
LineAdapter Class Constructors Methods Properties See Also Send Feedback

The LineAdapter type exposes the following members.

Constructors

Name | Description
LineAdapter | Initializes a new instance of the LineAdapter class.

Methods

Name | Description
DrawShape | Overridden. See DrawShape(Canvas, Shape, MediaFill). (Overrides ShapeAdapter..::.DrawShape(Canvas, Shape, MediaFill).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from ShapeAdapter.)

See Also

LineAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


LineAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
LineAdapter Constructor
LineAdapter Class See Also Send Feedback
Initializes a new instance of the LineAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public LineAdapter(
    Options documentOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    documentOptions As Options _
)
Visual C++
public:
LineAdapter(
    Options^ documentOptions
)

Parameters

documentOptions
Type: PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

LineAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


LineAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
LineAdapter Methods
LineAdapter Class See Also Send Feedback

The LineAdapter type exposes the following members.

Methods

Name | Description
DrawShape | Overridden. See DrawShape(Canvas, Shape, MediaFill). (Overrides ShapeAdapter..::.DrawShape(Canvas, Shape, MediaFill).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


DrawShape Method

[image]

.NET ModelKit Suite ClassReference
LineAdapter..::.DrawShape Method
LineAdapter Class See Also Send Feedback
Overridden. See DrawShape(Canvas, Shape, MediaFill).

Namespace: PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawShape(
    Canvas canvas,
    Shape source,
    MediaFill fills
)
Visual Basic (Declaration)
Public Overrides Sub DrawShape ( _
    canvas As Canvas, _
    source As Shape, _
    fills As MediaFill _
)
Visual C++
public:
virtual void DrawShape(
    Canvas^ canvas,
    Shape^ source,
    MediaFill^ fills
) override

Parameters

canvas
Type: System.Windows.Controls..::.Canvas
source
Type: PerpetuumSoft.Reporting.DOM..::.Shape
fills
Type: PerpetuumSoft.Reporting.Export.Xps..::.MediaFill

See Also

LineAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


LineAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
LineAdapter Properties
LineAdapter Class See Also Send Feedback

The LineAdapter type exposes the following members.

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from ShapeAdapter.)

See Also

LineAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


PolygonAdapter Class

[image]

.NET ModelKit Suite ClassReference
PolygonAdapter Class
Members See Also Send Feedback
Represents an adapter for the Polygon export.

Namespace: PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public class PolygonAdapter : ShapeAdapter
Visual Basic (Declaration)
Public Class PolygonAdapter _
    Inherits ShapeAdapter
Visual C++
public ref class PolygonAdapter : public ShapeAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters..::.ShapeAdapter
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters..::.PolygonAdapter

See Also

PolygonAdapter Members
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


PolygonAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
PolygonAdapter Members
PolygonAdapter Class Constructors Methods Properties See Also Send Feedback

The PolygonAdapter type exposes the following members.

Constructors

Name | Description
PolygonAdapter | Initializes a new instance of the PolygonAdapter class.

Methods

Name | Description
DrawShape | Overridden. See DrawShape(Canvas, Shape, MediaFill). (Overrides ShapeAdapter..::.DrawShape(Canvas, Shape, MediaFill).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from ShapeAdapter.)

See Also

PolygonAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


PolygonAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
PolygonAdapter Constructor
PolygonAdapter Class See Also Send Feedback
Initializes a new instance of the PolygonAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public PolygonAdapter(
    Options documentOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    documentOptions As Options _
)
Visual C++
public:
PolygonAdapter(
    Options^ documentOptions
)

Parameters

documentOptions
Type: PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

PolygonAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


PolygonAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
PolygonAdapter Methods
PolygonAdapter Class See Also Send Feedback

The PolygonAdapter type exposes the following members.

Methods

Name | Description
DrawShape | Overridden. See DrawShape(Canvas, Shape, MediaFill). (Overrides ShapeAdapter..::.DrawShape(Canvas, Shape, MediaFill).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PolygonAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


DrawShape Method

[image]

.NET ModelKit Suite ClassReference
PolygonAdapter..::.DrawShape Method
PolygonAdapter Class See Also Send Feedback
Overridden. See DrawShape(Canvas, Shape, MediaFill).

Namespace: PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawShape(
    Canvas canvas,
    Shape source,
    MediaFill fills
)
Visual Basic (Declaration)
Public Overrides Sub DrawShape ( _
    canvas As Canvas, _
    source As Shape, _
    fills As MediaFill _
)
Visual C++
public:
virtual void DrawShape(
    Canvas^ canvas,
    Shape^ source,
    MediaFill^ fills
) override

Parameters

canvas
Type: System.Windows.Controls..::.Canvas
source
Type: PerpetuumSoft.Reporting.DOM..::.Shape
fills
Type: PerpetuumSoft.Reporting.Export.Xps..::.MediaFill

See Also

PolygonAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


PolygonAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
PolygonAdapter Properties
PolygonAdapter Class See Also Send Feedback

The PolygonAdapter type exposes the following members.

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from ShapeAdapter.)

See Also

PolygonAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


RoundRectangleAdapter Class

[image]

.NET ModelKit Suite ClassReference
RoundRectangleAdapter Class
Members See Also Send Feedback
Represents an adapter for the RounRectangle export.

Namespace: PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public class RoundRectangleAdapter : ShapeAdapter
Visual Basic (Declaration)
Public Class RoundRectangleAdapter _
    Inherits ShapeAdapter
Visual C++
public ref class RoundRectangleAdapter : public ShapeAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters..::.ShapeAdapter
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters..::.RoundRectangleAdapter

See Also

RoundRectangleAdapter Members
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


RoundRectangleAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
RoundRectangleAdapter Members
RoundRectangleAdapter Class Constructors Methods Properties See Also Send Feedback

The RoundRectangleAdapter type exposes the following members.

Constructors

Name | Description
RoundRectangleAdapter | Initializes a new instance of the RoundRectangleAdapter class.

Methods

Name | Description
DrawShape | Overridden. See DrawShape(Canvas, Shape, MediaFill). (Overrides ShapeAdapter..::.DrawShape(Canvas, Shape, MediaFill).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from ShapeAdapter.)

See Also

RoundRectangleAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


RoundRectangleAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
RoundRectangleAdapter Constructor
RoundRectangleAdapter Class See Also Send Feedback
Initializes a new instance of the RoundRectangleAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public RoundRectangleAdapter(
    Options documentOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    documentOptions As Options _
)
Visual C++
public:
RoundRectangleAdapter(
    Options^ documentOptions
)

Parameters

documentOptions
Type: PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

RoundRectangleAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


RoundRectangleAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
RoundRectangleAdapter Methods
RoundRectangleAdapter Class See Also Send Feedback

The RoundRectangleAdapter type exposes the following members.

Methods

Name | Description
DrawShape | Overridden. See DrawShape(Canvas, Shape, MediaFill). (Overrides ShapeAdapter..::.DrawShape(Canvas, Shape, MediaFill).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoundRectangleAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


DrawShape Method

[image]

.NET ModelKit Suite ClassReference
RoundRectangleAdapter..::.DrawShape Method
RoundRectangleAdapter Class See Also Send Feedback
Overridden. See DrawShape(Canvas, Shape, MediaFill).

Namespace: PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public override void DrawShape(
    Canvas canvas,
    Shape source,
    MediaFill fills
)
Visual Basic (Declaration)
Public Overrides Sub DrawShape ( _
    canvas As Canvas, _
    source As Shape, _
    fills As MediaFill _
)
Visual C++
public:
virtual void DrawShape(
    Canvas^ canvas,
    Shape^ source,
    MediaFill^ fills
) override

Parameters

canvas
Type: System.Windows.Controls..::.Canvas
source
Type: PerpetuumSoft.Reporting.DOM..::.Shape
fills
Type: PerpetuumSoft.Reporting.Export.Xps..::.MediaFill

See Also

RoundRectangleAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


RoundRectangleAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
RoundRectangleAdapter Properties
RoundRectangleAdapter Class See Also Send Feedback

The RoundRectangleAdapter type exposes the following members.

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format. (Inherited from ShapeAdapter.)

See Also

RoundRectangleAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


ShapeAdapter Class

[image]

.NET ModelKit Suite ClassReference
ShapeAdapter Class
Members See Also Send Feedback
Represents an adapter for the Shape control.

Namespace: PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public abstract class ShapeAdapter
Visual Basic (Declaration)
Public MustInherit Class ShapeAdapter
Visual C++
public ref class ShapeAdapter abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters..::.ShapeAdapter
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters..::.EllipseAdapter
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters..::.LineAdapter
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters..::.PolygonAdapter
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters..::.RoundRectangleAdapter

See Also

ShapeAdapter Members
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


ShapeAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
ShapeAdapter Members
ShapeAdapter Class Constructors Methods Properties See Also Send Feedback

The ShapeAdapter type exposes the following members.

Constructors

Name | Description
ShapeAdapter | Initializes a new instance of the ShapeAdapter class.

Methods

Name | Description
DrawShape | Draws a shape in a XPS document.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format.

See Also

ShapeAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


ShapeAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
ShapeAdapter Constructor
ShapeAdapter Class See Also Send Feedback
Initializes a new instance of the ShapeAdapter class.

Namespace: PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public ShapeAdapter(
    Options documentOptions
)
Visual Basic (Declaration)
Public Sub New ( _
    documentOptions As Options _
)
Visual C++
public:
ShapeAdapter(
    Options^ documentOptions
)

Parameters

documentOptions
Type: PerpetuumSoft.Reporting.Export.Xps..::.Options

See Also

ShapeAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


ShapeAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ShapeAdapter Methods
ShapeAdapter Class See Also Send Feedback

The ShapeAdapter type exposes the following members.

Methods

Name | Description
DrawShape | Draws a shape in a XPS document.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShapeAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


DrawShape Method

[image]

.NET ModelKit Suite ClassReference
ShapeAdapter..::.DrawShape Method
ShapeAdapter Class See Also Send Feedback
Draws a shape in a XPS document.

Namespace: PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public abstract void DrawShape(
    Canvas canvas,
    Shape source,
    MediaFill fills
)
Visual Basic (Declaration)
Public MustOverride Sub DrawShape ( _
    canvas As Canvas, _
    source As Shape, _
    fills As MediaFill _
)
Visual C++
public:
virtual void DrawShape(
    Canvas^ canvas,
    Shape^ source,
    MediaFill^ fills
) abstract

Parameters

canvas
Type: System.Windows.Controls..::.Canvas
source
Type: PerpetuumSoft.Reporting.DOM..::.Shape
fills
Type: PerpetuumSoft.Reporting.Export.Xps..::.MediaFill

See Also

ShapeAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


ShapeAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
ShapeAdapter Properties
ShapeAdapter Class See Also Send Feedback

The ShapeAdapter type exposes the following members.

Properties

Name | Description
DocumentOptions | Gets or sets Options that represents export options to XPS format.

See Also

ShapeAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


DocumentOptions Property

[image]

.NET ModelKit Suite ClassReference
ShapeAdapter..::.DocumentOptions Property
ShapeAdapter Class See Also Send Feedback
Gets or sets Options that represents export options to XPS format.

Namespace: PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters
Assembly: PerpetuumSoft.Reporting.Export.Xps (in PerpetuumSoft.Reporting.Export.Xps.dll) Version: 3.9.0.1

Syntax

C#
public Options DocumentOptions { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentOptions As Options
Visual C++
public:
property Options^ DocumentOptions {
    Options^ get ();
}

See Also

ShapeAdapter Class
PerpetuumSoft.Reporting.Export.Xps.ShapeAdapters Namespace


PerpetuumSoft.Reporting.Rendering Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Rendering Namespace
Send Feedback
The PerpetuumSoft.Reporting.Rendering namespace contains classes which are used while report generation.

Classes

Class | Description
Bookmark | Represents bookmark.
RenderEngine | Manages the report rendering process.
ReportScriptBase | Base class for classes containing user scripts.
ScriptException | Represents a script generation exception.
ScriptGenerator | Generate and compile the script for the document.
ScriptInfoCollection | Represents a collection of scripts.

Interfaces

Interface | Description
IRenderSite | Provides common interface for report render clients.
IResolveSubReport | Provides functionality for supporting reports with subreports.

Enumerations

Enumeration | Description
ExceptionMode | Enumerates exception handling modes.


Bookmark Class

[image]

.NET ModelKit Suite ClassReference
Bookmark Class
Members See Also Send Feedback
Represents bookmark.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Bookmark
Visual Basic (Declaration)
Public Class Bookmark
Visual C++
public ref class Bookmark

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Rendering..::.Bookmark

See Also

Bookmark Members
PerpetuumSoft.Reporting.Rendering Namespace


Bookmark Members

[image] [image]

.NET ModelKit Suite ClassReference
Bookmark Members
Bookmark Class Constructors Methods Properties See Also Send Feedback

The Bookmark type exposes the following members.

Constructors

Name | Description
Bookmark | Initializes a new instance of the Bookmark class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CrossIndex | Gets an index of a page that was added when the vertical space was not enough.
PageIndex | Gets a specified index of page.
PageNumber | Gets a page number.
UsedHeight | Gets the occupied space of a page vertically.

See Also

Bookmark Class
PerpetuumSoft.Reporting.Rendering Namespace


Bookmark Constructor

[image]

.NET ModelKit Suite ClassReference
Bookmark Constructor
Bookmark Class See Also Send Feedback
Initializes a new instance of the Bookmark class.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Bookmark(
    Page page,
    int pageNumber,
    double usedHeight,
    int pageIndex,
    int crossIndex
)
Visual Basic (Declaration)
Public Sub New ( _
    page As Page, _
    pageNumber As Integer, _
    usedHeight As Double, _
    pageIndex As Integer, _
    crossIndex As Integer _
)
Visual C++
public:
Bookmark(
    Page^ page,
    int pageNumber,
    double usedHeight,
    int pageIndex,
    int crossIndex
)

Parameters

page
Type: PerpetuumSoft.Reporting.DOM..::.Page
pageNumber
Type: System..::.Int32
usedHeight
Type: System..::.Double
pageIndex
Type: System..::.Int32
crossIndex
Type: System..::.Int32

See Also

Bookmark Class
PerpetuumSoft.Reporting.Rendering Namespace


Bookmark Methods

[image] [image]

.NET ModelKit Suite ClassReference
Bookmark Methods
Bookmark Class See Also Send Feedback

The Bookmark type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Bookmark Class
PerpetuumSoft.Reporting.Rendering Namespace


Bookmark Properties

[image] [image]

.NET ModelKit Suite ClassReference
Bookmark Properties
Bookmark Class See Also Send Feedback

The Bookmark type exposes the following members.

Properties

Name | Description
CrossIndex | Gets an index of a page that was added when the vertical space was not enough.
PageIndex | Gets a specified index of page.
PageNumber | Gets a page number.
UsedHeight | Gets the occupied space of a page vertically.

See Also

Bookmark Class
PerpetuumSoft.Reporting.Rendering Namespace


CrossIndex Property

[image]

.NET ModelKit Suite ClassReference
Bookmark..::.CrossIndex Property
Bookmark Class See Also Send Feedback
Gets an index of a page that was added when the vertical space was not enough.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int CrossIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property CrossIndex As Integer
Visual C++
public:
property int CrossIndex {
    int get ();
}

See Also

Bookmark Class
PerpetuumSoft.Reporting.Rendering Namespace


PageIndex Property

[image]

.NET ModelKit Suite ClassReference
Bookmark..::.PageIndex Property
Bookmark Class See Also Send Feedback
Gets a specified index of page.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int PageIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageIndex As Integer
Visual C++
public:
property int PageIndex {
    int get ();
}

See Also

Bookmark Class
PerpetuumSoft.Reporting.Rendering Namespace


PageNumber Property

[image]

.NET ModelKit Suite ClassReference
Bookmark..::.PageNumber Property
Bookmark Class See Also Send Feedback
Gets a page number.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int PageNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
}

See Also

Bookmark Class
PerpetuumSoft.Reporting.Rendering Namespace


UsedHeight Property

[image]

.NET ModelKit Suite ClassReference
Bookmark..::.UsedHeight Property
Bookmark Class See Also Send Feedback
Gets the occupied space of a page vertically.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double UsedHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property UsedHeight As Double
Visual C++
public:
property double UsedHeight {
    double get ();
}

See Also

Bookmark Class
PerpetuumSoft.Reporting.Rendering Namespace


ExceptionMode Enumeration

[image]

.NET ModelKit Suite ClassReference
ExceptionMode Enumeration
See Also Send Feedback
Enumerates exception handling modes.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum ExceptionMode
Visual Basic (Declaration)
Public Enumeration ExceptionMode
Visual C++
public enum class ExceptionMode

Members

Member name | Description
Fail | Fail on exception.
Warning | Warning on exception.
Ignore | Ignore all exceptions.

See Also

PerpetuumSoft.Reporting.Rendering Namespace


IRenderSite Interface

[image]

.NET ModelKit Suite ClassReference
IRenderSite Interface
Members See Also Send Feedback
Provides common interface for report render clients.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public interface IRenderSite
Visual Basic (Declaration)
Public Interface IRenderSite
Visual C++
public interface class IRenderSite

See Also

IRenderSite Members
PerpetuumSoft.Reporting.Rendering Namespace


IRenderSite Members

[image] [image]

.NET ModelKit Suite ClassReference
IRenderSite Members
IRenderSite Interface Methods Events See Also Send Feedback

The IRenderSite type exposes the following members.

Methods

Name | Description
DocumentCompleted | Performs any actions after completing rendering of the specified document.
HandleException | Handles Exception.
HandleRenderingException | Returns the "true" value if the Exception is required to be handled.
NotifyCancelRendering | Notifies about the rendering cancel.
ProgressEnd | Ends progress indication.
ProgressStart | Starts progress indication.
ShowError | Shows the error information.
ShowProgress | Shows the progress indicator tool.

Events

Name | Description
CancelRender | Occurs when rendering is canceled by the client.

See Also

IRenderSite Interface
PerpetuumSoft.Reporting.Rendering Namespace


IRenderSite Methods

[image] [image]

.NET ModelKit Suite ClassReference
IRenderSite Methods
IRenderSite Interface See Also Send Feedback

The IRenderSite type exposes the following members.

Methods

Name | Description
DocumentCompleted | Performs any actions after completing rendering of the specified document.
HandleException | Handles Exception.
HandleRenderingException | Returns the "true" value if the Exception is required to be handled.
NotifyCancelRendering | Notifies about the rendering cancel.
ProgressEnd | Ends progress indication.
ProgressStart | Starts progress indication.
ShowError | Shows the error information.
ShowProgress | Shows the progress indicator tool.

See Also

IRenderSite Interface
PerpetuumSoft.Reporting.Rendering Namespace


DocumentCompleted Method

[image]

.NET ModelKit Suite ClassReference
IRenderSite..::.DocumentCompleted Method
IRenderSite Interface See Also Send Feedback
Performs any actions after completing rendering of the specified document.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void DocumentCompleted(
    Document document
)
Visual Basic (Declaration)
Sub DocumentCompleted ( _
    document As Document _
)
Visual C++
void DocumentCompleted(
    Document^ document
)

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document

See Also

IRenderSite Interface
PerpetuumSoft.Reporting.Rendering Namespace


HandleException Method

[image]

.NET ModelKit Suite ClassReference
IRenderSite..::.HandleException Method
IRenderSite Interface See Also Send Feedback
Handles Exception.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void HandleException(
    Exception e
)
Visual Basic (Declaration)
Sub HandleException ( _
    e As Exception _
)
Visual C++
void HandleException(
    Exception^ e
)

Parameters

e
Type: System..::.Exception

See Also

IRenderSite Interface
PerpetuumSoft.Reporting.Rendering Namespace


HandleRenderingException Method

[image]

.NET ModelKit Suite ClassReference
IRenderSite..::.HandleRenderingException Method
IRenderSite Interface See Also Send Feedback
Returns the "true" value if the Exception is required to be handled.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
bool HandleRenderingException(
    Exception e
)
Visual Basic (Declaration)
Function HandleRenderingException ( _
    e As Exception _
) As Boolean
Visual C++
bool HandleRenderingException(
    Exception^ e
)

Parameters

e
Type: System..::.Exception

See Also

IRenderSite Interface
PerpetuumSoft.Reporting.Rendering Namespace


NotifyCancelRendering Method

[image]

.NET ModelKit Suite ClassReference
IRenderSite..::.NotifyCancelRendering Method
IRenderSite Interface See Also Send Feedback
Notifies about the rendering cancel.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void NotifyCancelRendering()
Visual Basic (Declaration)
Sub NotifyCancelRendering
Visual C++
void NotifyCancelRendering()

See Also

IRenderSite Interface
PerpetuumSoft.Reporting.Rendering Namespace


ProgressEnd Method

[image]

.NET ModelKit Suite ClassReference
IRenderSite..::.ProgressEnd Method
IRenderSite Interface See Also Send Feedback
Ends progress indication.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void ProgressEnd()
Visual Basic (Declaration)
Sub ProgressEnd
Visual C++
void ProgressEnd()

See Also

IRenderSite Interface
PerpetuumSoft.Reporting.Rendering Namespace


ProgressStart Method

[image]

.NET ModelKit Suite ClassReference
IRenderSite..::.ProgressStart Method
IRenderSite Interface See Also Send Feedback
Starts progress indication.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void ProgressStart()
Visual Basic (Declaration)
Sub ProgressStart
Visual C++
void ProgressStart()

See Also

IRenderSite Interface
PerpetuumSoft.Reporting.Rendering Namespace


ShowError Method

[image]

.NET ModelKit Suite ClassReference
IRenderSite..::.ShowError Method
IRenderSite Interface See Also Send Feedback
Shows the error information.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void ShowError(
    Exception e
)
Visual Basic (Declaration)
Sub ShowError ( _
    e As Exception _
)
Visual C++
void ShowError(
    Exception^ e
)

Parameters

e
Type: System..::.Exception

See Also

IRenderSite Interface
PerpetuumSoft.Reporting.Rendering Namespace


ShowProgress Method

[image]

.NET ModelKit Suite ClassReference
IRenderSite..::.ShowProgress Method
IRenderSite Interface See Also Send Feedback
Shows the progress indicator tool.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
void ShowProgress(
    string state,
    string subState
)
Visual Basic (Declaration)
Sub ShowProgress ( _
    state As String, _
    subState As String _
)
Visual C++
void ShowProgress(
    String^ state,
    String^ subState
)

Parameters

state
Type: System..::.String
subState
Type: System..::.String

See Also

IRenderSite Interface
PerpetuumSoft.Reporting.Rendering Namespace


IRenderSite Events

[image] [image]

.NET ModelKit Suite ClassReference
IRenderSite Events
IRenderSite Interface See Also Send Feedback

The IRenderSite type exposes the following members.

Events

Name | Description
CancelRender | Occurs when rendering is canceled by the client.

See Also

IRenderSite Interface
PerpetuumSoft.Reporting.Rendering Namespace


CancelRender Event

[image]

.NET ModelKit Suite ClassReference
IRenderSite..::.CancelRender Event
IRenderSite Interface See Also Send Feedback
Occurs when rendering is canceled by the client.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
event EventHandler CancelRender
Visual Basic (Declaration)
Event CancelRender As EventHandler
Visual C++
 event EventHandler^ CancelRender {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

IRenderSite Interface
PerpetuumSoft.Reporting.Rendering Namespace


IResolveSubReport Interface

[image]

.NET ModelKit Suite ClassReference
IResolveSubReport Interface
Members See Also Send Feedback
Provides functionality for supporting reports with subreports.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public interface IResolveSubReport
Visual Basic (Declaration)
Public Interface IResolveSubReport
Visual C++
public interface class IResolveSubReport

See Also

IResolveSubReport Members
PerpetuumSoft.Reporting.Rendering Namespace


IResolveSubReport Members

[image] [image]

.NET ModelKit Suite ClassReference
IResolveSubReport Members
IResolveSubReport Interface Methods See Also Send Feedback

The IResolveSubReport type exposes the following members.

Methods

Name | Description
GetAvailableTemplateNames | Gets names of available templates
GetSubReportSource |
GetSubReportTemplate | Returns subreport template by it name.

See Also

IResolveSubReport Interface
PerpetuumSoft.Reporting.Rendering Namespace


IResolveSubReport Methods

[image] [image]

.NET ModelKit Suite ClassReference
IResolveSubReport Methods
IResolveSubReport Interface See Also Send Feedback

The IResolveSubReport type exposes the following members.

Methods

Name | Description
GetAvailableTemplateNames | Gets names of available templates
GetSubReportSource |
GetSubReportTemplate | Returns subreport template by it name.

See Also

IResolveSubReport Interface
PerpetuumSoft.Reporting.Rendering Namespace


GetAvailableTemplateNames Method

[image]

.NET ModelKit Suite ClassReference
IResolveSubReport..::.GetAvailableTemplateNames Method
IResolveSubReport Interface See Also Send Feedback
Gets names of available templates

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
StringCollection GetAvailableTemplateNames()
Visual Basic (Declaration)
Function GetAvailableTemplateNames As StringCollection
Visual C++
StringCollection^ GetAvailableTemplateNames()

See Also

IResolveSubReport Interface
PerpetuumSoft.Reporting.Rendering Namespace


GetSubReportSource Method

[image]

.NET ModelKit Suite ClassReference
IResolveSubReport..::.GetSubReportSource Method
IResolveSubReport Interface See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Rendering.IResolveSubReport.GetSubReportSource(System.String)]

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
IReportSource GetSubReportSource(
    string name
)
Visual Basic (Declaration)
Function GetSubReportSource ( _
    name As String _
) As IReportSource
Visual C++
IReportSource^ GetSubReportSource(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

IResolveSubReport Interface
PerpetuumSoft.Reporting.Rendering Namespace


GetSubReportTemplate Method

[image]

.NET ModelKit Suite ClassReference
IResolveSubReport..::.GetSubReportTemplate Method
IResolveSubReport Interface See Also Send Feedback
Returns subreport template by it name.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
Document GetSubReportTemplate(
    string name
)
Visual Basic (Declaration)
Function GetSubReportTemplate ( _
    name As String _
) As Document
Visual C++
Document^ GetSubReportTemplate(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

IResolveSubReport Interface
PerpetuumSoft.Reporting.Rendering Namespace


RenderEngine Class

[image]

.NET ModelKit Suite ClassReference
RenderEngine Class
Members See Also Send Feedback
Manages the report rendering process.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class RenderEngine : IDisposable
Visual Basic (Declaration)
Public Class RenderEngine _
    Implements IDisposable
Visual C++
public ref class RenderEngine : IDisposable

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Rendering..::.RenderEngine

See Also

RenderEngine Members
PerpetuumSoft.Reporting.Rendering Namespace


RenderEngine Members

[image] [image]

.NET ModelKit Suite ClassReference
RenderEngine Members
RenderEngine Class Methods Properties Events See Also Send Feedback

The RenderEngine type exposes the following members.

Methods

Name | Description
CancelRender | Cancels rendering.
CheckCancel | Checks if rendering was canceled.
Dispose | Implements Dispose()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCurrentGroup | Get the current group
GetGraphics | Returns a sample Graphics object.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRunningTotal | Gets running total by its name
GetTotal | Gets total value by the field
GetType | Gets the Type of the current instance. (Inherited from Object.)
Handle | Handles exception.
InitColumnState | Initializes column state.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NewColumn | Forces a new column.
NewCrossPage | Forces a new page while rendering a cross report.
NewPage | Forces a new page.
RenderDocument | Renders the document.
ResetCross | Resets cross rendering state.
RestorePosition | Restores engine position.
StartRender | Starts the rendering process.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Caret | Gets and sets the current position on the page being rendered.
ColumnDX | Gets and sets the space beetween the page left margin and the left side of current column.
ColumnNumber | Gets and sets the currently rendered column number.
ColumnsCount | Gets and sets the current count of columns.
ColumnsGap | Gets and sets the space beetween the columns.
ColumnStart | Gets and sets the vertical coordinate of the columns section.
DataNavigationManager | Gets DataNavigationManager associated with this RenderEngine.
FreeHeight | Gets the amount of remaining free page height.
FreeWidth | Gets the amount of remaining free page width.
IsClearColumn | Gets and sets whether the current column is empty.
IsClearPage | Gets and sets whether the currently rendered page is empty.
IsDoublePass | Gets whether the pass currently performed is the second pass.
LineNumber | Gets the line number in the currently rendered band.
Now | Gets the date and time when the rendering began.
Objects | Gets and sets the data sources collection.
PageCount | Gets the count of pages in the final document.
PageNumber | Gets and sets the number of currently rendered page.
PageRenderArea | Gets and sets a rectangle defining the remaining free space available on the page.
Parameters | Gets parameters collection.
ProductionDocument | Gets the final document.
ProductionPage | Gets the current page in the final document.
ScriptInstance | Gets the generated script object instance.
Site | Gets the IRenderSite associates with the RenderEngine.
TemplateDocument | Gets the document template.
TemplatePage | Gets the current Page in the Template.
UsedHeight | Gets the amount of used page height.
UsedWidth | Gets the amount of used page width.

Events

Name | Description
GetReportParameter | Occurs when report rendering to get temtlate parameteres.

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


RenderEngine Methods

[image] [image]

.NET ModelKit Suite ClassReference
RenderEngine Methods
RenderEngine Class See Also Send Feedback

The RenderEngine type exposes the following members.

Methods

Name | Description
CancelRender | Cancels rendering.
CheckCancel | Checks if rendering was canceled.
Dispose | Implements Dispose()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCurrentGroup | Get the current group
GetGraphics | Returns a sample Graphics object.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRunningTotal | Gets running total by its name
GetTotal | Gets total value by the field
GetType | Gets the Type of the current instance. (Inherited from Object.)
Handle | Handles exception.
InitColumnState | Initializes column state.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NewColumn | Forces a new column.
NewCrossPage | Forces a new page while rendering a cross report.
NewPage | Forces a new page.
RenderDocument | Renders the document.
ResetCross | Resets cross rendering state.
RestorePosition | Restores engine position.
StartRender | Starts the rendering process.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


CancelRender Method

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.CancelRender Method
RenderEngine Class See Also Send Feedback
Cancels rendering.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void CancelRender()
Visual Basic (Declaration)
Public Sub CancelRender
Visual C++
public:
void CancelRender()

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


CheckCancel Method

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.CheckCancel Method
RenderEngine Class See Also Send Feedback
Checks if rendering was canceled.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void CheckCancel()
Visual Basic (Declaration)
Public Sub CheckCancel
Visual C++
public:
void CheckCancel()

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


Dispose Method

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.Dispose Method
RenderEngine Class See Also Send Feedback
Implements Dispose()()().

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


GetCurrentGroup Method

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.GetCurrentGroup Method
RenderEngine Class See Also Send Feedback
Get the current group

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object GetCurrentGroup()
Visual Basic (Declaration)
Public Function GetCurrentGroup As Object
Visual C++
public:
Object^ GetCurrentGroup()

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


GetGraphics Method

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.GetGraphics Method
RenderEngine Class See Also Send Feedback
Returns a sample Graphics object.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Graphics GetGraphics()
Visual Basic (Declaration)
Public Function GetGraphics As Graphics
Visual C++
public:
Graphics^ GetGraphics()

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


GetRunningTotal Method

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.GetRunningTotal Method
RenderEngine Class See Also Send Feedback
Gets running total by its name

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double GetRunningTotal(
    string name
)
Visual Basic (Declaration)
Public Function GetRunningTotal ( _
    name As String _
) As Double
Visual C++
public:
double GetRunningTotal(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


GetTotal Method

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.GetTotal Method
RenderEngine Class See Also Send Feedback
Gets total value by the field

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double GetTotal(
    string name
)
Visual Basic (Declaration)
Public Function GetTotal ( _
    name As String _
) As Double
Visual C++
public:
double GetTotal(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


Handle Method

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.Handle Method
RenderEngine Class See Also Send Feedback
Handles exception.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Handle(
    Exception e
)
Visual Basic (Declaration)
Public Sub Handle ( _
    e As Exception _
)
Visual C++
public:
void Handle(
    Exception^ e
)

Parameters

e
Type: System..::.Exception

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


InitColumnState Method

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.InitColumnState Method
RenderEngine Class See Also Send Feedback
Initializes column state.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void InitColumnState(
    int columnDX,
    int columnsCount,
    double columnsGap
)
Visual Basic (Declaration)
Public Sub InitColumnState ( _
    columnDX As Integer, _
    columnsCount As Integer, _
    columnsGap As Double _
)
Visual C++
public:
void InitColumnState(
    int columnDX,
    int columnsCount,
    double columnsGap
)

Parameters

columnDX
Type: System..::.Int32
columnsCount
Type: System..::.Int32
columnsGap
Type: System..::.Double

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


NewColumn Method

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.NewColumn Method
RenderEngine Class See Also Send Feedback
Forces a new column.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void NewColumn()
Visual Basic (Declaration)
Public Sub NewColumn
Visual C++
public:
void NewColumn()

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


NewCrossPage Method

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.NewCrossPage Method
RenderEngine Class See Also Send Feedback
Forces a new page while rendering a cross report.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void NewCrossPage()
Visual Basic (Declaration)
Public Sub NewCrossPage
Visual C++
public:
void NewCrossPage()

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


NewPage Method

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.NewPage Method
RenderEngine Class See Also Send Feedback
Forces a new page.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void NewPage()
Visual Basic (Declaration)
Public Sub NewPage
Visual C++
public:
void NewPage()

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


RenderDocument Method

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.RenderDocument Method
RenderEngine Class See Also Send Feedback
Renders the document.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Document RenderDocument(
    Document template
)
Visual Basic (Declaration)
Public Function RenderDocument ( _
    template As Document _
) As Document
Visual C++
public:
Document^ RenderDocument(
    Document^ template
)

Parameters

template
Type: PerpetuumSoft.Reporting.DOM..::.Document

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


ResetCross Method

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.ResetCross Method
RenderEngine Class See Also Send Feedback
Resets cross rendering state.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void ResetCross()
Visual Basic (Declaration)
Public Sub ResetCross
Visual C++
public:
void ResetCross()

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


RestorePosition Method

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.RestorePosition Method
RenderEngine Class See Also Send Feedback
Restores engine position.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void RestorePosition(
    Bookmark bookmark
)
Visual Basic (Declaration)
Public Sub RestorePosition ( _
    bookmark As Bookmark _
)
Visual C++
public:
void RestorePosition(
    Bookmark^ bookmark
)

Parameters

bookmark
Type: PerpetuumSoft.Reporting.Rendering..::.Bookmark

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


StartRender Method

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.StartRender Method
RenderEngine Class See Also Send Feedback
Starts the rendering process.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void StartRender(
    Document template
)
Visual Basic (Declaration)
Public Sub StartRender ( _
    template As Document _
)
Visual C++
public:
void StartRender(
    Document^ template
)

Parameters

template
Type: PerpetuumSoft.Reporting.DOM..::.Document

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


RenderEngine Properties

[image] [image]

.NET ModelKit Suite ClassReference
RenderEngine Properties
RenderEngine Class See Also Send Feedback

The RenderEngine type exposes the following members.

Properties

Name | Description
Caret | Gets and sets the current position on the page being rendered.
ColumnDX | Gets and sets the space beetween the page left margin and the left side of current column.
ColumnNumber | Gets and sets the currently rendered column number.
ColumnsCount | Gets and sets the current count of columns.
ColumnsGap | Gets and sets the space beetween the columns.
ColumnStart | Gets and sets the vertical coordinate of the columns section.
DataNavigationManager | Gets DataNavigationManager associated with this RenderEngine.
FreeHeight | Gets the amount of remaining free page height.
FreeWidth | Gets the amount of remaining free page width.
IsClearColumn | Gets and sets whether the current column is empty.
IsClearPage | Gets and sets whether the currently rendered page is empty.
IsDoublePass | Gets whether the pass currently performed is the second pass.
LineNumber | Gets the line number in the currently rendered band.
Now | Gets the date and time when the rendering began.
Objects | Gets and sets the data sources collection.
PageCount | Gets the count of pages in the final document.
PageNumber | Gets and sets the number of currently rendered page.
PageRenderArea | Gets and sets a rectangle defining the remaining free space available on the page.
Parameters | Gets parameters collection.
ProductionDocument | Gets the final document.
ProductionPage | Gets the current page in the final document.
ScriptInstance | Gets the generated script object instance.
Site | Gets the IRenderSite associates with the RenderEngine.
TemplateDocument | Gets the document template.
TemplatePage | Gets the current Page in the Template.
UsedHeight | Gets the amount of used page height.
UsedWidth | Gets the amount of used page width.

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


Caret Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.Caret Property
RenderEngine Class See Also Send Feedback
Gets and sets the current position on the page being rendered.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Vector Caret { get; set; }
Visual Basic (Declaration)
Public Property Caret As Vector
Visual C++
public:
property Vector Caret {
    Vector get ();
    void set (Vector value);
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


ColumnDX Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.ColumnDX Property
RenderEngine Class See Also Send Feedback
Gets and sets the space beetween the page left margin and the left side of current column.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double ColumnDX { get; set; }
Visual Basic (Declaration)
Public Property ColumnDX As Double
Visual C++
public:
property double ColumnDX {
    double get ();
    void set (double value);
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


ColumnNumber Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.ColumnNumber Property
RenderEngine Class See Also Send Feedback
Gets and sets the currently rendered column number.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int ColumnNumber { get; set; }
Visual Basic (Declaration)
Public Property ColumnNumber As Integer
Visual C++
public:
property int ColumnNumber {
    int get ();
    void set (int value);
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


ColumnsCount Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.ColumnsCount Property
RenderEngine Class See Also Send Feedback
Gets and sets the current count of columns.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int ColumnsCount { get; set; }
Visual Basic (Declaration)
Public Property ColumnsCount As Integer
Visual C++
public:
property int ColumnsCount {
    int get ();
    void set (int value);
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


ColumnsGap Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.ColumnsGap Property
RenderEngine Class See Also Send Feedback
Gets and sets the space beetween the columns.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double ColumnsGap { get; set; }
Visual Basic (Declaration)
Public Property ColumnsGap As Double
Visual C++
public:
property double ColumnsGap {
    double get ();
    void set (double value);
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


ColumnStart Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.ColumnStart Property
RenderEngine Class See Also Send Feedback
Gets and sets the vertical coordinate of the columns section.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double ColumnStart { get; set; }
Visual Basic (Declaration)
Public Property ColumnStart As Double
Visual C++
public:
property double ColumnStart {
    double get ();
    void set (double value);
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


DataNavigationManager Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.DataNavigationManager Property
RenderEngine Class See Also Send Feedback
Gets DataNavigationManager associated with this RenderEngine.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataNavigationManager DataNavigationManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataNavigationManager As DataNavigationManager
Visual C++
public:
property DataNavigationManager^ DataNavigationManager {
    DataNavigationManager^ get ();
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


FreeHeight Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.FreeHeight Property
RenderEngine Class See Also Send Feedback
Gets the amount of remaining free page height.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double FreeHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property FreeHeight As Double
Visual C++
public:
property double FreeHeight {
    double get ();
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


FreeWidth Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.FreeWidth Property
RenderEngine Class See Also Send Feedback
Gets the amount of remaining free page width.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double FreeWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property FreeWidth As Double
Visual C++
public:
property double FreeWidth {
    double get ();
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


IsClearColumn Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.IsClearColumn Property
RenderEngine Class See Also Send Feedback
Gets and sets whether the current column is empty.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool IsClearColumn { get; set; }
Visual Basic (Declaration)
Public Property IsClearColumn As Boolean
Visual C++
public:
property bool IsClearColumn {
    bool get ();
    void set (bool value);
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


IsClearPage Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.IsClearPage Property
RenderEngine Class See Also Send Feedback
Gets and sets whether the currently rendered page is empty.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool IsClearPage { get; set; }
Visual Basic (Declaration)
Public Property IsClearPage As Boolean
Visual C++
public:
property bool IsClearPage {
    bool get ();
    void set (bool value);
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


IsDoublePass Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.IsDoublePass Property
RenderEngine Class See Also Send Feedback
Gets whether the pass currently performed is the second pass.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool IsDoublePass { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDoublePass As Boolean
Visual C++
public:
property bool IsDoublePass {
    bool get ();
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


LineNumber Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.LineNumber Property
RenderEngine Class See Also Send Feedback
Gets the line number in the currently rendered band.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int LineNumber { get; set; }
Visual Basic (Declaration)
Public Property LineNumber As Integer
Visual C++
public:
property int LineNumber {
    int get ();
    void set (int value);
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


Now Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.Now Property
RenderEngine Class See Also Send Feedback
Gets the date and time when the rendering began.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DateTime Now { get; }
Visual Basic (Declaration)
Public ReadOnly Property Now As DateTime
Visual C++
public:
property DateTime Now {
    DateTime get ();
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


Objects Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.Objects Property
RenderEngine Class See Also Send Feedback
Gets and sets the data sources collection.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ObjectPointerCollection Objects { get; set; }
Visual Basic (Declaration)
Public Property Objects As ObjectPointerCollection
Visual C++
public:
property ObjectPointerCollection^ Objects {
    ObjectPointerCollection^ get ();
    void set (ObjectPointerCollection^ value);
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


PageCount Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.PageCount Property
RenderEngine Class See Also Send Feedback
Gets the count of pages in the final document.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int PageCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageCount As Integer
Visual C++
public:
property int PageCount {
    int get ();
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


PageNumber Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.PageNumber Property
RenderEngine Class See Also Send Feedback
Gets and sets the number of currently rendered page.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int PageNumber { get; set; }
Visual Basic (Declaration)
Public Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
    void set (int value);
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


PageRenderArea Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.PageRenderArea Property
RenderEngine Class See Also Send Feedback
Gets and sets a rectangle defining the remaining free space available on the page.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public VectorRectangle PageRenderArea { get; set; }
Visual Basic (Declaration)
Public Property PageRenderArea As VectorRectangle
Visual C++
public:
property VectorRectangle PageRenderArea {
    VectorRectangle get ();
    void set (VectorRectangle value);
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


Parameters Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.Parameters Property
RenderEngine Class See Also Send Feedback
Gets parameters collection.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ParameterCollection Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterCollection
Visual C++
public:
property ParameterCollection^ Parameters {
    ParameterCollection^ get ();
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


ProductionDocument Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.ProductionDocument Property
RenderEngine Class See Also Send Feedback
Gets the final document.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Document ProductionDocument { get; internal set; }
Visual Basic (Declaration)
Public Property ProductionDocument As Document
Visual C++
public:
property Document^ ProductionDocument {
    Document^ get ();
    void set (Document^ value);
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


ProductionPage Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.ProductionPage Property
RenderEngine Class See Also Send Feedback
Gets the current page in the final document.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Page ProductionPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProductionPage As Page
Visual C++
public:
property Page^ ProductionPage {
    Page^ get ();
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


ScriptInstance Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.ScriptInstance Property
RenderEngine Class See Also Send Feedback
Gets the generated script object instance.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object ScriptInstance { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScriptInstance As Object
Visual C++
public:
property Object^ ScriptInstance {
    Object^ get ();
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


Site Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.Site Property
RenderEngine Class See Also Send Feedback
Gets the IRenderSite associates with the RenderEngine.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public IRenderSite Site { get; }
Visual Basic (Declaration)
Public ReadOnly Property Site As IRenderSite
Visual C++
public:
property IRenderSite^ Site {
    IRenderSite^ get ();
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


TemplateDocument Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.TemplateDocument Property
RenderEngine Class See Also Send Feedback
Gets the document template.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Document TemplateDocument { get; }
Visual Basic (Declaration)
Public ReadOnly Property TemplateDocument As Document
Visual C++
public:
property Document^ TemplateDocument {
    Document^ get ();
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


TemplatePage Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.TemplatePage Property
RenderEngine Class See Also Send Feedback
Gets the current Page in the Template.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Page TemplatePage { get; set; }
Visual Basic (Declaration)
Public Property TemplatePage As Page
Visual C++
public:
property Page^ TemplatePage {
    Page^ get ();
    void set (Page^ value);
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


UsedHeight Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.UsedHeight Property
RenderEngine Class See Also Send Feedback
Gets the amount of used page height.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double UsedHeight { get; set; }
Visual Basic (Declaration)
Public Property UsedHeight As Double
Visual C++
public:
property double UsedHeight {
    double get ();
    void set (double value);
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


UsedWidth Property

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.UsedWidth Property
RenderEngine Class See Also Send Feedback
Gets the amount of used page width.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double UsedWidth { get; set; }
Visual Basic (Declaration)
Public Property UsedWidth As Double
Visual C++
public:
property double UsedWidth {
    double get ();
    void set (double value);
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


RenderEngine Events

[image] [image]

.NET ModelKit Suite ClassReference
RenderEngine Events
RenderEngine Class See Also Send Feedback

The RenderEngine type exposes the following members.

Events

Name | Description
GetReportParameter | Occurs when report rendering to get temtlate parameteres.

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


GetReportParameter Event

[image]

.NET ModelKit Suite ClassReference
RenderEngine..::.GetReportParameter Event
RenderEngine Class See Also Send Feedback
Occurs when report rendering to get temtlate parameteres.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event GetReportParameterEventHandler GetReportParameter
Visual Basic (Declaration)
Public Event GetReportParameter As GetReportParameterEventHandler
Visual C++
public:
 event GetReportParameterEventHandler^ GetReportParameter {
    void add (GetReportParameterEventHandler^ value);
    void remove (GetReportParameterEventHandler^ value);
}

See Also

RenderEngine Class
PerpetuumSoft.Reporting.Rendering Namespace


ReportScriptBase Class

[image]

.NET ModelKit Suite ClassReference
ReportScriptBase Class
Members See Also Send Feedback
Base class for classes containing user scripts.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ReportScriptBase
Visual Basic (Declaration)
Public Class ReportScriptBase
Visual C++
public ref class ReportScriptBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Rendering..::.ReportScriptBase

See Also

ReportScriptBase Members
PerpetuumSoft.Reporting.Rendering Namespace


ReportScriptBase Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportScriptBase Members
ReportScriptBase Class Constructors Methods Properties See Also Send Feedback

The ReportScriptBase type exposes the following members.

Constructors

Name | Description
ReportScriptBase | Initializes a new instance of the ReportBase class with the specified container.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetData | Returns data corresponding to specified data member.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetParameter | Returns parameter by specific name.
GetRunningTotal | Gets running total by its name
GetTotal | Gets total value by the field
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColumnNumber | Gets the number of the current column.
DataObjects | Gets the collection of associated data sources.
Document | Gets the template of the currently rendered document.
Engine | Gets the associated RenderEngine.
Group | Get group
Now | Gets the date and time when the rendering began.
PageCount | Gets the count of pages in the document.
PageNumber | Gets the number of the current page.

See Also

ReportScriptBase Class
PerpetuumSoft.Reporting.Rendering Namespace


ReportScriptBase Constructor

[image]

.NET ModelKit Suite ClassReference
ReportScriptBase Constructor
ReportScriptBase Class See Also Send Feedback
Initializes a new instance of the ReportBase class with the specified container.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportScriptBase(
    Document document,
    ObjectPointerCollection dataObjects,
    RenderEngine engine
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document, _
    dataObjects As ObjectPointerCollection, _
    engine As RenderEngine _
)
Visual C++
public:
ReportScriptBase(
    Document^ document,
    ObjectPointerCollection^ dataObjects,
    RenderEngine^ engine
)

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
dataObjects
Type: PerpetuumSoft.Reporting.Components..::.ObjectPointerCollection
engine
Type: PerpetuumSoft.Reporting.Rendering..::.RenderEngine

See Also

ReportScriptBase Class
PerpetuumSoft.Reporting.Rendering Namespace


ReportScriptBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportScriptBase Methods
ReportScriptBase Class See Also Send Feedback

The ReportScriptBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetData | Returns data corresponding to specified data member.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetParameter | Returns parameter by specific name.
GetRunningTotal | Gets running total by its name
GetTotal | Gets total value by the field
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportScriptBase Class
PerpetuumSoft.Reporting.Rendering Namespace


GetData Method

[image]

.NET ModelKit Suite ClassReference
ReportScriptBase..::.GetData Method
ReportScriptBase Class See Also Send Feedback
Returns data corresponding to specified data member.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object GetData(
    string dataMember
)
Visual Basic (Declaration)
Public Function GetData ( _
    dataMember As String _
) As Object
Visual C++
public:
Object^ GetData(
    String^ dataMember
)

Parameters

dataMember
Type: System..::.String

See Also

ReportScriptBase Class
PerpetuumSoft.Reporting.Rendering Namespace


GetParameter Method

[image]

.NET ModelKit Suite ClassReference
ReportScriptBase..::.GetParameter Method
ReportScriptBase Class See Also Send Feedback
Returns parameter by specific name.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object GetParameter(
    string paramName
)
Visual Basic (Declaration)
Public Function GetParameter ( _
    paramName As String _
) As Object
Visual C++
public:
Object^ GetParameter(
    String^ paramName
)

Parameters

paramName
Type: System..::.String

See Also

ReportScriptBase Class
PerpetuumSoft.Reporting.Rendering Namespace


GetRunningTotal Method

[image]

.NET ModelKit Suite ClassReference
ReportScriptBase..::.GetRunningTotal Method
ReportScriptBase Class See Also Send Feedback
Gets running total by its name

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object GetRunningTotal(
    string name
)
Visual Basic (Declaration)
Public Function GetRunningTotal ( _
    name As String _
) As Object
Visual C++
public:
Object^ GetRunningTotal(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

ReportScriptBase Class
PerpetuumSoft.Reporting.Rendering Namespace


GetTotal Method

[image]

.NET ModelKit Suite ClassReference
ReportScriptBase..::.GetTotal Method
ReportScriptBase Class See Also Send Feedback
Gets total value by the field

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object GetTotal(
    string name
)
Visual Basic (Declaration)
Public Function GetTotal ( _
    name As String _
) As Object
Visual C++
public:
Object^ GetTotal(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

ReportScriptBase Class
PerpetuumSoft.Reporting.Rendering Namespace


ReportScriptBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportScriptBase Properties
ReportScriptBase Class See Also Send Feedback

The ReportScriptBase type exposes the following members.

Properties

Name | Description
ColumnNumber | Gets the number of the current column.
DataObjects | Gets the collection of associated data sources.
Document | Gets the template of the currently rendered document.
Engine | Gets the associated RenderEngine.
Group | Get group
Now | Gets the date and time when the rendering began.
PageCount | Gets the count of pages in the document.
PageNumber | Gets the number of the current page.

See Also

ReportScriptBase Class
PerpetuumSoft.Reporting.Rendering Namespace


ColumnNumber Property

[image]

.NET ModelKit Suite ClassReference
ReportScriptBase..::.ColumnNumber Property
ReportScriptBase Class See Also Send Feedback
Gets the number of the current column.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int ColumnNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property ColumnNumber As Integer
Visual C++
public:
property int ColumnNumber {
    int get ();
}

See Also

ReportScriptBase Class
PerpetuumSoft.Reporting.Rendering Namespace


DataObjects Property

[image]

.NET ModelKit Suite ClassReference
ReportScriptBase..::.DataObjects Property
ReportScriptBase Class See Also Send Feedback
Gets the collection of associated data sources.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ObjectPointerCollection DataObjects { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataObjects As ObjectPointerCollection
Visual C++
public:
property ObjectPointerCollection^ DataObjects {
    ObjectPointerCollection^ get ();
}

See Also

ReportScriptBase Class
PerpetuumSoft.Reporting.Rendering Namespace


Document Property

[image]

.NET ModelKit Suite ClassReference
ReportScriptBase..::.Document Property
ReportScriptBase Class See Also Send Feedback
Gets the template of the currently rendered document.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Document Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

ReportScriptBase Class
PerpetuumSoft.Reporting.Rendering Namespace


Engine Property

[image]

.NET ModelKit Suite ClassReference
ReportScriptBase..::.Engine Property
ReportScriptBase Class See Also Send Feedback
Gets the associated RenderEngine.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public RenderEngine Engine { get; }
Visual Basic (Declaration)
Public ReadOnly Property Engine As RenderEngine
Visual C++
public:
property RenderEngine^ Engine {
    RenderEngine^ get ();
}

See Also

ReportScriptBase Class
PerpetuumSoft.Reporting.Rendering Namespace


Group Property

[image]

.NET ModelKit Suite ClassReference
ReportScriptBase..::.Group Property
ReportScriptBase Class See Also Send Feedback
Get group

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Group { get; }
Visual Basic (Declaration)
Public ReadOnly Property Group As Object
Visual C++
public:
property Object^ Group {
    Object^ get ();
}

See Also

ReportScriptBase Class
PerpetuumSoft.Reporting.Rendering Namespace


Now Property

[image]

.NET ModelKit Suite ClassReference
ReportScriptBase..::.Now Property
ReportScriptBase Class See Also Send Feedback
Gets the date and time when the rendering began.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DateTime Now { get; }
Visual Basic (Declaration)
Public ReadOnly Property Now As DateTime
Visual C++
public:
property DateTime Now {
    DateTime get ();
}

See Also

ReportScriptBase Class
PerpetuumSoft.Reporting.Rendering Namespace


PageCount Property

[image]

.NET ModelKit Suite ClassReference
ReportScriptBase..::.PageCount Property
ReportScriptBase Class See Also Send Feedback
Gets the count of pages in the document.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int PageCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageCount As Integer
Visual C++
public:
property int PageCount {
    int get ();
}

See Also

ReportScriptBase Class
PerpetuumSoft.Reporting.Rendering Namespace


PageNumber Property

[image]

.NET ModelKit Suite ClassReference
ReportScriptBase..::.PageNumber Property
ReportScriptBase Class See Also Send Feedback
Gets the number of the current page.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int PageNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
}

See Also

ReportScriptBase Class
PerpetuumSoft.Reporting.Rendering Namespace


ScriptException Class

[image]

.NET ModelKit Suite ClassReference
ScriptException Class
Members See Also Send Feedback
Represents a script generation exception.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
[SerializableAttribute]
public class ScriptException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ScriptException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class ScriptException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
PerpetuumSoft.Reporting.Rendering..::.ScriptException

See Also

ScriptException Members
PerpetuumSoft.Reporting.Rendering Namespace


ScriptException Members

[image] [image]

.NET ModelKit Suite ClassReference
ScriptException Members
ScriptException Class Constructors Methods Properties See Also Send Feedback

The ScriptException type exposes the following members.

Constructors

Name | Description
ScriptException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
CompilerResults | Gets the compiler result associated with the ScriptException.
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ScriptException Class
PerpetuumSoft.Reporting.Rendering Namespace


ScriptException Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ScriptException Constructor
ScriptException Class See Also Send Feedback

Overload List

Name | Description
ScriptException()()() | Initializes a new instance of the ScriptException class.
ScriptException(CompilerResults) | Initializes a new instance of the ScriptException class.

See Also

ScriptException Class
ScriptException Members
PerpetuumSoft.Reporting.Rendering Namespace


ScriptException Constructor

[image]

.NET ModelKit Suite ClassReference
ScriptException Constructor
ScriptException Class See Also Send Feedback
Initializes a new instance of the ScriptException class.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ScriptException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ScriptException()

See Also

ScriptException Class
ScriptException Overload
PerpetuumSoft.Reporting.Rendering Namespace


ScriptException Constructor (CompilerResults)

[image]

.NET ModelKit Suite ClassReference
ScriptException Constructor (CompilerResults)
ScriptException Class See Also Send Feedback
Initializes a new instance of the ScriptException class.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ScriptException(
    CompilerResults compilerResults
)
Visual Basic (Declaration)
Public Sub New ( _
    compilerResults As CompilerResults _
)
Visual C++
public:
ScriptException(
    CompilerResults^ compilerResults
)

Parameters

compilerResults
Type: System.CodeDom.Compiler..::.CompilerResults

See Also

ScriptException Class
ScriptException Overload
PerpetuumSoft.Reporting.Rendering Namespace


ScriptException Methods

[image] [image]

.NET ModelKit Suite ClassReference
ScriptException Methods
ScriptException Class See Also Send Feedback

The ScriptException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ScriptException Class
PerpetuumSoft.Reporting.Rendering Namespace


ScriptException Properties

[image] [image]

.NET ModelKit Suite ClassReference
ScriptException Properties
ScriptException Class See Also Send Feedback

The ScriptException type exposes the following members.

Properties

Name | Description
CompilerResults | Gets the compiler result associated with the ScriptException.
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ScriptException Class
PerpetuumSoft.Reporting.Rendering Namespace


CompilerResults Property

[image]

.NET ModelKit Suite ClassReference
ScriptException..::.CompilerResults Property
ScriptException Class See Also Send Feedback
Gets the compiler result associated with the ScriptException.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public CompilerResults CompilerResults { get; }
Visual Basic (Declaration)
Public ReadOnly Property CompilerResults As CompilerResults
Visual C++
public:
property CompilerResults^ CompilerResults {
    CompilerResults^ get ();
}

See Also

ScriptException Class
PerpetuumSoft.Reporting.Rendering Namespace


ScriptGenerator Class

[image]

.NET ModelKit Suite ClassReference
ScriptGenerator Class
Members See Also Send Feedback
Generate and compile the script for the document.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ScriptGenerator
Visual Basic (Declaration)
Public Class ScriptGenerator
Visual C++
public ref class ScriptGenerator

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Rendering..::.ScriptGenerator

See Also

ScriptGenerator Members
PerpetuumSoft.Reporting.Rendering Namespace


ScriptGenerator Members

[image] [image]

.NET ModelKit Suite ClassReference
ScriptGenerator Members
ScriptGenerator Class Constructors Methods Properties See Also Send Feedback

The ScriptGenerator type exposes the following members.

Constructors

Name | Description
ScriptGenerator | Overloaded.

Methods

Name | Description
CompileScript | Performs script compilation.
CreateScriptInstance | Returns a new instance of the generated script class.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateAccessFieldExpression | Generates a string that contains the expression for access to the specified field in the data source bound to the specified band.
GenerateScript | Performs script generation.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteScript | Writes the generated script to the specified TextWriter.

Properties

Name | Description
ReportScriptBaseType | Gets or sets the type used as a basic one for the dynamically generated type of the document template scripts
ScriptAssembly | Gets the assembly that contains the compiled script.
ScriptDOM | Gets generated CodeCompileUnit of the CodeDOM.

See Also

ScriptGenerator Class
PerpetuumSoft.Reporting.Rendering Namespace


ScriptGenerator Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ScriptGenerator Constructor
ScriptGenerator Class See Also Send Feedback

Overload List

Name | Description
ScriptGenerator(Document) | Initializes a new instance of the ScriptGenerator class.
ScriptGenerator(Document, String) | Initializes a new instance of the ScriptGenerator class.

See Also

ScriptGenerator Class
ScriptGenerator Members
PerpetuumSoft.Reporting.Rendering Namespace


ScriptGenerator Constructor (Document)

[image]

.NET ModelKit Suite ClassReference
ScriptGenerator Constructor (Document)
ScriptGenerator Class See Also Send Feedback
Initializes a new instance of the ScriptGenerator class.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ScriptGenerator(
    Document document
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document _
)
Visual C++
public:
ScriptGenerator(
    Document^ document
)

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document

See Also

ScriptGenerator Class
ScriptGenerator Overload
PerpetuumSoft.Reporting.Rendering Namespace


ScriptGenerator Constructor (Document, String)

[image]

.NET ModelKit Suite ClassReference
ScriptGenerator Constructor (Document, String)
ScriptGenerator Class See Also Send Feedback
Initializes a new instance of the ScriptGenerator class.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ScriptGenerator(
    Document document,
    string templateName
)
Visual Basic (Declaration)
Public Sub New ( _
    document As Document, _
    templateName As String _
)
Visual C++
public:
ScriptGenerator(
    Document^ document,
    String^ templateName
)

Parameters

document
Type: PerpetuumSoft.Reporting.DOM..::.Document
templateName
Type: System..::.String

See Also

ScriptGenerator Class
ScriptGenerator Overload
PerpetuumSoft.Reporting.Rendering Namespace


ScriptGenerator Methods

[image] [image]

.NET ModelKit Suite ClassReference
ScriptGenerator Methods
ScriptGenerator Class See Also Send Feedback

The ScriptGenerator type exposes the following members.

Methods

Name | Description
CompileScript | Performs script compilation.
CreateScriptInstance | Returns a new instance of the generated script class.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateAccessFieldExpression | Generates a string that contains the expression for access to the specified field in the data source bound to the specified band.
GenerateScript | Performs script generation.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteScript | Writes the generated script to the specified TextWriter.

See Also

ScriptGenerator Class
PerpetuumSoft.Reporting.Rendering Namespace


CompileScript Method

[image]

.NET ModelKit Suite ClassReference
ScriptGenerator..::.CompileScript Method
ScriptGenerator Class See Also Send Feedback
Performs script compilation.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void CompileScript()
Visual Basic (Declaration)
Public Sub CompileScript
Visual C++
public:
void CompileScript()

See Also

ScriptGenerator Class
PerpetuumSoft.Reporting.Rendering Namespace


CreateScriptInstance Method

[image]

.NET ModelKit Suite ClassReference
ScriptGenerator..::.CreateScriptInstance Method
ScriptGenerator Class See Also Send Feedback
Returns a new instance of the generated script class.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportScriptBase CreateScriptInstance(
    ObjectPointerCollection dataObjects,
    RenderEngine engine
)
Visual Basic (Declaration)
Public Function CreateScriptInstance ( _
    dataObjects As ObjectPointerCollection, _
    engine As RenderEngine _
) As ReportScriptBase
Visual C++
public:
ReportScriptBase^ CreateScriptInstance(
    ObjectPointerCollection^ dataObjects,
    RenderEngine^ engine
)

Parameters

dataObjects
Type: PerpetuumSoft.Reporting.Components..::.ObjectPointerCollection
engine
Type: PerpetuumSoft.Reporting.Rendering..::.RenderEngine

See Also

ScriptGenerator Class
PerpetuumSoft.Reporting.Rendering Namespace


GenerateAccessFieldExpression Method

[image]

.NET ModelKit Suite ClassReference
ScriptGenerator..::.GenerateAccessFieldExpression Method
ScriptGenerator Class See Also Send Feedback
Generates a string that contains the expression for access to the specified field in the data source bound to the specified band.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string GenerateAccessFieldExpression(
    string bandName,
    string fieldName
)
Visual Basic (Declaration)
Public Function GenerateAccessFieldExpression ( _
    bandName As String, _
    fieldName As String _
) As String
Visual C++
public:
String^ GenerateAccessFieldExpression(
    String^ bandName,
    String^ fieldName
)

Parameters

bandName
Type: System..::.String
fieldName
Type: System..::.String

See Also

ScriptGenerator Class
PerpetuumSoft.Reporting.Rendering Namespace


GenerateScript Method

[image]

.NET ModelKit Suite ClassReference
ScriptGenerator..::.GenerateScript Method
ScriptGenerator Class See Also Send Feedback
Performs script generation.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void GenerateScript()
Visual Basic (Declaration)
Public Sub GenerateScript
Visual C++
public:
void GenerateScript()

See Also

ScriptGenerator Class
PerpetuumSoft.Reporting.Rendering Namespace


WriteScript Method

[image]

.NET ModelKit Suite ClassReference
ScriptGenerator..::.WriteScript Method
ScriptGenerator Class See Also Send Feedback
Writes the generated script to the specified TextWriter.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void WriteScript(
    TextWriter writer
)
Visual Basic (Declaration)
Public Sub WriteScript ( _
    writer As TextWriter _
)
Visual C++
public:
void WriteScript(
    TextWriter^ writer
)

Parameters

writer
Type: System.IO..::.TextWriter

See Also

ScriptGenerator Class
PerpetuumSoft.Reporting.Rendering Namespace


ScriptGenerator Properties

[image] [image]

.NET ModelKit Suite ClassReference
ScriptGenerator Properties
ScriptGenerator Class See Also Send Feedback

The ScriptGenerator type exposes the following members.

Properties

Name | Description
ReportScriptBaseType | Gets or sets the type used as a basic one for the dynamically generated type of the document template scripts
ScriptAssembly | Gets the assembly that contains the compiled script.
ScriptDOM | Gets generated CodeCompileUnit of the CodeDOM.

See Also

ScriptGenerator Class
PerpetuumSoft.Reporting.Rendering Namespace


ReportScriptBaseType Property

[image]

.NET ModelKit Suite ClassReference
ScriptGenerator..::.ReportScriptBaseType Property
ScriptGenerator Class See Also Send Feedback
Gets or sets the type used as a basic one for the dynamically generated type of the document template scripts

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Type ReportScriptBaseType { get; set; }
Visual Basic (Declaration)
Public Property ReportScriptBaseType As Type
Visual C++
public:
property Type^ ReportScriptBaseType {
    Type^ get ();
    void set (Type^ value);
}

See Also

ScriptGenerator Class
PerpetuumSoft.Reporting.Rendering Namespace


ScriptAssembly Property

[image]

.NET ModelKit Suite ClassReference
ScriptGenerator..::.ScriptAssembly Property
ScriptGenerator Class See Also Send Feedback
Gets the assembly that contains the compiled script.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Assembly ScriptAssembly { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScriptAssembly As Assembly
Visual C++
public:
property Assembly^ ScriptAssembly {
    Assembly^ get ();
}

See Also

ScriptGenerator Class
PerpetuumSoft.Reporting.Rendering Namespace


ScriptDOM Property

[image]

.NET ModelKit Suite ClassReference
ScriptGenerator..::.ScriptDOM Property
ScriptGenerator Class See Also Send Feedback
Gets generated CodeCompileUnit of the CodeDOM.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public CodeCompileUnit ScriptDOM { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScriptDOM As CodeCompileUnit
Visual C++
public:
property CodeCompileUnit^ ScriptDOM {
    CodeCompileUnit^ get ();
}

See Also

ScriptGenerator Class
PerpetuumSoft.Reporting.Rendering Namespace


ScriptInfoCollection Class

[image]

.NET ModelKit Suite ClassReference
ScriptInfoCollection Class
Members See Also Send Feedback
Represents a collection of scripts.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ScriptInfoCollection : CollectionBase
Visual Basic (Declaration)
Public Class ScriptInfoCollection _
    Inherits CollectionBase
Visual C++
public ref class ScriptInfoCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Reporting.Rendering..::.ScriptInfoCollection

See Also

ScriptInfoCollection Members
PerpetuumSoft.Reporting.Rendering Namespace


ScriptInfoCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
ScriptInfoCollection Members
ScriptInfoCollection Class Constructors Methods Properties See Also Send Feedback

The ScriptInfoCollection type exposes the following members.

Constructors

Name | Description
ScriptInfoCollection | Creates a new instance of ScriptInfoCollection class.

Methods

Name | Description
Add | Adds a new script to the collecton.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Inserts a new script at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified script from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets the script at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ScriptInfoCollection Class
PerpetuumSoft.Reporting.Rendering Namespace


ScriptInfoCollection Constructor

[image]

.NET ModelKit Suite ClassReference
ScriptInfoCollection Constructor
ScriptInfoCollection Class See Also Send Feedback
Creates a new instance of ScriptInfoCollection class.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ScriptInfoCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ScriptInfoCollection()

See Also

ScriptInfoCollection Class
PerpetuumSoft.Reporting.Rendering Namespace


ScriptInfoCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
ScriptInfoCollection Methods
ScriptInfoCollection Class See Also Send Feedback

The ScriptInfoCollection type exposes the following members.

Methods

Name | Description
Add | Adds a new script to the collecton.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Inserts a new script at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified script from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptInfoCollection Class
PerpetuumSoft.Reporting.Rendering Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
ScriptInfoCollection..::.Add Method
ScriptInfoCollection Class See Also Send Feedback
Adds a new script to the collecton.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ScriptInfo Add(
    ScriptInfo value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As ScriptInfo _
) As ScriptInfo
Visual C++
public:
ScriptInfo^ Add(
    ScriptInfo^ value
)

Parameters

value
Type: ScriptInfo

See Also

ScriptInfoCollection Class
PerpetuumSoft.Reporting.Rendering Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
ScriptInfoCollection..::.Insert Method
ScriptInfoCollection Class See Also Send Feedback
Inserts a new script at the specified index.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    ScriptInfo value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As ScriptInfo _
)
Visual C++
public:
void Insert(
    int index,
    ScriptInfo^ value
)

Parameters

index
Type: System..::.Int32
value
Type: ScriptInfo

See Also

ScriptInfoCollection Class
PerpetuumSoft.Reporting.Rendering Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
ScriptInfoCollection..::.Remove Method
ScriptInfoCollection Class See Also Send Feedback
Removes the specified script from the collection.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    ScriptInfo value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As ScriptInfo _
)
Visual C++
public:
void Remove(
    ScriptInfo^ value
)

Parameters

value
Type: ScriptInfo

See Also

ScriptInfoCollection Class
PerpetuumSoft.Reporting.Rendering Namespace


ScriptInfoCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
ScriptInfoCollection Properties
ScriptInfoCollection Class See Also Send Feedback

The ScriptInfoCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets the script at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ScriptInfoCollection Class
PerpetuumSoft.Reporting.Rendering Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
ScriptInfoCollection..::.Item Property
ScriptInfoCollection Class See Also Send Feedback
Gets the script at the specified index.

Namespace: PerpetuumSoft.Reporting.Rendering
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ScriptInfo this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As ScriptInfo
Visual C++
public:
property ScriptInfo^ default[int index] {
    ScriptInfo^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

ScriptInfoCollection Class
PerpetuumSoft.Reporting.Rendering Namespace


PerpetuumSoft.Reporting.Silverlight.Client Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Silverlight.Client Namespace
Send Feedback
The PerpetuumSoft.Reporting.Silverlight.Client namespace contains classes to display reports on the client side.

Classes

Class | Description
ContinuedPageModel | One column report view model. There can be displayed many pages on the screen simultaneously - as many pages as area sizes allow.
Cursor | A cursor class.
CursorLayer | A layer class where cursor is displayed. It is used for the Report Viewer template creation.
DisabledTool | Realizes the tool which makes available any actions with the report. Inherited from Tool.
Document | A class which includes report data.
DocumentLoadedEventArgs | Parameters of the event which occurs when report is loaded.
DocumentPresenter | Report presenter.
DocumentViewModel | Report view model.
DynamicZoomTool | The class which realizes tool for view scaling with mouse move at pressed mouse left button.
ErrorMessagePresenter | A class for presentation of report view content when error occurs during report getting.
LoadingPagePresenter | Loading presenter.
MouseWheelEventArgs | Provides data for various events that report changes to the mouse wheel delta value of a mouse device.
MouseWheelManager | Manager for working with mouse scroll-wheel.
NoReportPresenter | A class for presentation of report view content when report is missing.
Page | A class for report page representation.
PageLoadedEventArgs | Report page loading event parameters.
PagePresenter | Report pages presenter.
PageSelectedEventArgs | Parameters of the event which occurs when the page is selected.
PanTool | The class which realizes tool for report scrolling with mouse pointer move at pressed right mouse button. Inherited from StandardTool.
Progress | This class realizes progress bar. Inherited from Control.
RegionZoomTool | Class for realization of the tool which is used for scaling the report in the selected area. Inherited from StandardTool.
ReportErrorEventArgs | Parameters of the event which occurs when there is generation error.
ReportHyperlinkEventArgs | Parameters of the event which occurs when hyperlink is clicked.
ReportViewer | A сcontrol for report preview, navigation by pages, export and search.
Select | Control which is used for checking selection on toolbar.
Separator | Separating control which is used in toolbar.
SinglePageModel | Single page view mode.
StandardTool | A basic class for all standard tools.
ToggleToolButton | Toolbar button control. Inherited from ToggleButton.
Tool | An abstract class. It is basic class for all classes of tools which realize handling of ReportViewer special functionality.
ToolButton | Gets or sets toolbar button control. Inherited from Button.
ToolSlider | Slider control for reports view scaling. Inherited from Slider.
ViewManager | Report Viewer manager.
ViewModel | Report view model.
ViewOptions | Report Viewer parameters.
ZoomChangeTool | A class for the realization of the tools which are used in work with the report scale.
ZoomInTool | A class for realization of the tool which can be used for zooming in report view. Inherited from ZoomChangeTool.
ZoomOutTool | A class for tool (functionality) realization which is used for report zooming out.

Structures

Structure | Description
ReportRegion | Report area.
Zoom | A class which includes data about current report scale.

Interfaces

Interface | Description
IView | Report Viewer control interface.

Enumerations

Enumeration | Description
ActiveTool | Report Viewer active tool type.
ExportFormat | Enumeration of export formats.
PageModel | Page view models list.
ZoomMode | Enumeration which includes scale modes list.


ActiveTool Enumeration

[image]

.NET ModelKit Suite ClassReference
ActiveTool Enumeration
See Also Send Feedback
Report Viewer active tool type.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public enum ActiveTool
Visual Basic (Declaration)
Public Enumeration ActiveTool
Visual C++
public enum class ActiveTool

Members

Member name | Description
Pan | Report panning mode.
DynamicZoom | Dynamic scaling mode.
ZoomToRegion | Scaling mode by the set area.
ZoomIn | Zoom in mode.
ZoomOut | Zoom out mode.

See Also

PerpetuumSoft.Reporting.Silverlight.Client Namespace


ContinuedPageModel Class

[image]

.NET ModelKit Suite ClassReference
ContinuedPageModel Class
Members See Also Send Feedback
One column report view model. There can be displayed many pages on the screen simultaneously - as many pages as area sizes allow.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ContinuedPageModel : DocumentViewModel
Visual Basic (Declaration)
Public Class ContinuedPageModel _
    Inherits DocumentViewModel
Visual C++
public ref class ContinuedPageModel : public DocumentViewModel

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client..::.ViewModel
PerpetuumSoft.Reporting.Silverlight.Client..::.DocumentViewModel
PerpetuumSoft.Reporting.Silverlight.Client..::.ContinuedPageModel

See Also

ContinuedPageModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ContinuedPageModel Members

[image] [image]

.NET ModelKit Suite ClassReference
ContinuedPageModel Members
ContinuedPageModel Class Constructors Methods Fields Properties See Also Send Feedback

The ContinuedPageModel type exposes the following members.

Constructors

Name | Description
ContinuedPageModel | Initializes a new instance of the ContinuedPageModel class.

Methods

Name | Description
AssignParameters | Sets the model display parameters subject to the previous active model. (Inherited from ViewModel.)
CalculateOrigin | Calculates the page location in the report preview area. (Inherited from DocumentViewModel.)
CalculateZoom | Calculates scale. (Inherited from DocumentViewModel.)
ChangeZoom | Overloaded.
Clone | Overridden. See Clone()()(). (Overrides ViewModel..::.Clone()()().)
CreateStoryboard | Creates Storyboard for animation. (Inherited from DocumentViewModel.)
DeleteUnusedPages | Deletes the unused pages. (Inherited from DocumentViewModel.)
DocumentEnd | Overridden. See DocumentEnd()()(). (Overrides ViewModel..::.DocumentEnd()()().)
DocumentHome | Overridden. See DocumentHome()()(). (Overrides ViewModel..::.DocumentHome()()().)
EnsurePageView | Creates the presenter for the selected page if the presenter is missing. (Inherited from DocumentViewModel.)
EnsureVisible | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetGap | Gets the gap between pages. (Overrides DocumentViewModel..::.GetGap(Point).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GoToFirstPage | Overridden. See GoToFirstPage()()(). (Inherited from DocumentViewModel.)
GoToLastPage | Overridden. See GoToLastPage()()(). (Inherited from DocumentViewModel.)
GoToNextPage | Overridden. See GoToNextPage()()(). (Inherited from DocumentViewModel.)
GoToPrevPage | Overridden. See GoToPrevPage()()(). (Inherited from DocumentViewModel.)
Invalidate | Overloaded.
MakeVisible | Forces content to scroll until the coordinate space of a specific rectangle is visible. (Inherited from DocumentViewModel.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from DocumentViewModel.)
PageDown | Overridden. See PageDown()()(). (Inherited from DocumentViewModel.)
PageEnd | Overridden. See PageEnd()()(). (Overrides ViewModel..::.PageEnd()()().)
PageHome | Overridden. See PageHome()()(). (Overrides ViewModel..::.PageHome()()().)
PageUp | Overridden. See PageUp()()(). (Inherited from DocumentViewModel.)
PanView | Overridden. See PanView(Point). (Inherited from DocumentViewModel.)
RectToScreen | Gets page area screen coordinates. (Overrides DocumentViewModel..::.RectToScreen(ReportRegion).)
ResetSearchResult | Overridden. See ResetSearchResult()()(). (Inherited from DocumentViewModel.)
SetupPage | Sets the selected page parameters. (Inherited from DocumentViewModel.)
ShowSearchResult | Overridden. See ShowSearchResult(ReportRegion). (Inherited from DocumentViewModel.)
StartAnimation | Starts animation. (Inherited from DocumentViewModel.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateContent | (Overrides ViewModel..::.UpdateContent(ViewModel, Boolean).)
ZoomIn | Overloaded.
ZoomOut | Overloaded.
ZoomWindow | Overridden. See ZoomWindow(Rect, Boolean). (Inherited from DocumentViewModel.)

Fields

Name | Description
Gap | Gets the gap between pages. (Inherited from DocumentViewModel.)
Margin | Gets page margins. (Inherited from DocumentViewModel.)

Properties

Name | Description
CanGoToNextPage | Overridden. See CanGoToNextPage. (Inherited from DocumentViewModel.)
CanGoToPrevPage | Overridden. See CanGoToPrevPage. (Inherited from DocumentViewModel.)
ClientSize | Gets the client area size. (Inherited from ViewModel.)
Document | Gets Document which is a report. (Inherited from DocumentViewModel.)
HScrollBarActive | Overridden. See HScrollBarActive. (Inherited from DocumentViewModel.)
HScrollBarLarge | Overridden. See HScrollBarLarge. (Inherited from DocumentViewModel.)
HScrollBarMaximum | Overridden. See HScrollBarMaximum. (Inherited from DocumentViewModel.)
HScrollBarPosition | Overridden. See HScrollBarPosition. (Inherited from DocumentViewModel.)
HScrollBarSmall | Overridden. See HScrollBarSmall. (Inherited from DocumentViewModel.)
HScrollBarViewPort | Overridden. See HScrollBarViewPort. (Inherited from DocumentViewModel.)
PageNumber | Overridden. See PageNumber. (Overrides ViewModel..::.PageNumber.)
ScaledPageArea | Gets the page sizes subject to view scale. (Overrides DocumentViewModel..::.ScaledPageArea.)
View | Gets IView which is report preview control. (Inherited from ViewModel.)
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from ViewModel.)
VScrollBarActive | Overridden. See VScrollBarActive. (Inherited from DocumentViewModel.)
VScrollBarLarge | Overridden. See VScrollBarLarge. (Overrides DocumentViewModel..::.VScrollBarLarge.)
VScrollBarMaximum | Overridden. See VScrollBarMaximum. (Inherited from DocumentViewModel.)
VScrollBarPosition | Overridden. See VScrollBarPosition. (Inherited from DocumentViewModel.)
VScrollBarSmall | Overridden. See VScrollBarSmall. (Inherited from DocumentViewModel.)
VScrollBarViewPort | Overridden. See VScrollBarViewPort. (Inherited from DocumentViewModel.)
Zoom | Overridden. See Zoom. (Inherited from DocumentViewModel.)

See Also

ContinuedPageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ContinuedPageModel Constructor

[image]

.NET ModelKit Suite ClassReference
ContinuedPageModel Constructor
ContinuedPageModel Class See Also Send Feedback
Initializes a new instance of the ContinuedPageModel class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ContinuedPageModel(
    ViewManager manager
)
Visual Basic (Declaration)
Public Sub New ( _
    manager As ViewManager _
)
Visual C++
public:
ContinuedPageModel(
    ViewManager^ manager
)

Parameters

manager
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ViewManager

See Also

ContinuedPageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ContinuedPageModel Fields

[image] [image]

.NET ModelKit Suite ClassReference
ContinuedPageModel Fields
ContinuedPageModel Class See Also Send Feedback

The ContinuedPageModel type exposes the following members.

Fields

Name | Description
Gap | Gets the gap between pages. (Inherited from DocumentViewModel.)
Margin | Gets page margins. (Inherited from DocumentViewModel.)

See Also

ContinuedPageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ContinuedPageModel Methods

[image] [image]

.NET ModelKit Suite ClassReference
ContinuedPageModel Methods
ContinuedPageModel Class See Also Send Feedback

The ContinuedPageModel type exposes the following members.

Methods

Name | Description
AssignParameters | Sets the model display parameters subject to the previous active model. (Inherited from ViewModel.)
CalculateOrigin | Calculates the page location in the report preview area. (Inherited from DocumentViewModel.)
CalculateZoom | Calculates scale. (Inherited from DocumentViewModel.)
ChangeZoom | Overloaded.
Clone | Overridden. See Clone()()(). (Overrides ViewModel..::.Clone()()().)
CreateStoryboard | Creates Storyboard for animation. (Inherited from DocumentViewModel.)
DeleteUnusedPages | Deletes the unused pages. (Inherited from DocumentViewModel.)
DocumentEnd | Overridden. See DocumentEnd()()(). (Overrides ViewModel..::.DocumentEnd()()().)
DocumentHome | Overridden. See DocumentHome()()(). (Overrides ViewModel..::.DocumentHome()()().)
EnsurePageView | Creates the presenter for the selected page if the presenter is missing. (Inherited from DocumentViewModel.)
EnsureVisible | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetGap | Gets the gap between pages. (Overrides DocumentViewModel..::.GetGap(Point).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GoToFirstPage | Overridden. See GoToFirstPage()()(). (Inherited from DocumentViewModel.)
GoToLastPage | Overridden. See GoToLastPage()()(). (Inherited from DocumentViewModel.)
GoToNextPage | Overridden. See GoToNextPage()()(). (Inherited from DocumentViewModel.)
GoToPrevPage | Overridden. See GoToPrevPage()()(). (Inherited from DocumentViewModel.)
Invalidate | Overloaded.
MakeVisible | Forces content to scroll until the coordinate space of a specific rectangle is visible. (Inherited from DocumentViewModel.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from DocumentViewModel.)
PageDown | Overridden. See PageDown()()(). (Inherited from DocumentViewModel.)
PageEnd | Overridden. See PageEnd()()(). (Overrides ViewModel..::.PageEnd()()().)
PageHome | Overridden. See PageHome()()(). (Overrides ViewModel..::.PageHome()()().)
PageUp | Overridden. See PageUp()()(). (Inherited from DocumentViewModel.)
PanView | Overridden. See PanView(Point). (Inherited from DocumentViewModel.)
RectToScreen | Gets page area screen coordinates. (Overrides DocumentViewModel..::.RectToScreen(ReportRegion).)
ResetSearchResult | Overridden. See ResetSearchResult()()(). (Inherited from DocumentViewModel.)
SetupPage | Sets the selected page parameters. (Inherited from DocumentViewModel.)
ShowSearchResult | Overridden. See ShowSearchResult(ReportRegion). (Inherited from DocumentViewModel.)
StartAnimation | Starts animation. (Inherited from DocumentViewModel.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateContent | (Overrides ViewModel..::.UpdateContent(ViewModel, Boolean).)
ZoomIn | Overloaded.
ZoomOut | Overloaded.
ZoomWindow | Overridden. See ZoomWindow(Rect, Boolean). (Inherited from DocumentViewModel.)

See Also

ContinuedPageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ChangeZoom Method

[image] [image]

.NET ModelKit Suite ClassReference
ContinuedPageModel..::.ChangeZoom Method
ContinuedPageModel Class See Also Send Feedback

Overload List

Name | Description
ChangeZoom(ZoomMode, Boolean) | Overridden. See ChangeZoom(ZoomMode, Boolean). (Inherited from DocumentViewModel.)
ChangeZoom(Double, Boolean) | Performs scale and scale mode changing. (Inherited from ViewModel.)
ChangeZoom(Point, Double, Boolean) | Overridden. See ChangeZoom(Point, Double, Boolean). (Inherited from DocumentViewModel.)

See Also

ContinuedPageModel Class
ContinuedPageModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
ContinuedPageModel..::.Clone Method
ContinuedPageModel Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override ViewModel Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As ViewModel
Visual C++
public:
virtual ViewModel^ Clone() override

See Also

ContinuedPageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentEnd Method

[image]

.NET ModelKit Suite ClassReference
ContinuedPageModel..::.DocumentEnd Method
ContinuedPageModel Class See Also Send Feedback
Overridden. See DocumentEnd()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void DocumentEnd()
Visual Basic (Declaration)
Public Overrides Sub DocumentEnd
Visual C++
public:
virtual void DocumentEnd() override

See Also

ContinuedPageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentHome Method

[image]

.NET ModelKit Suite ClassReference
ContinuedPageModel..::.DocumentHome Method
ContinuedPageModel Class See Also Send Feedback
Overridden. See DocumentHome()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void DocumentHome()
Visual Basic (Declaration)
Public Overrides Sub DocumentHome
Visual C++
public:
virtual void DocumentHome() override

See Also

ContinuedPageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


EnsureVisible Method

[image] [image]

.NET ModelKit Suite ClassReference
ContinuedPageModel..::.EnsureVisible Method
ContinuedPageModel Class See Also Send Feedback

Overload List

Name | Description
EnsureVisible(ReportRegion) | Shifts the visible area of the screen to guarantee that the specified report is visible. (Inherited from ViewModel.)
EnsureVisible(ReportRegion, Boolean) | Overridden. See EnsureVisible(ReportRegion, Boolean). (Overrides ViewModel..::.EnsureVisible(ReportRegion, Boolean).)

See Also

ContinuedPageModel Class
ContinuedPageModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


EnsureVisible Method (ReportRegion, Boolean)

[image]

.NET ModelKit Suite ClassReference
ContinuedPageModel..::.EnsureVisible Method (ReportRegion, Boolean)
ContinuedPageModel Class See Also Send Feedback
Overridden. See EnsureVisible(ReportRegion, Boolean).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void EnsureVisible(
    ReportRegion region,
    bool alignTop
)
Visual Basic (Declaration)
Public Overrides Sub EnsureVisible ( _
    region As ReportRegion, _
    alignTop As Boolean _
)
Visual C++
public:
virtual void EnsureVisible(
    ReportRegion region,
    bool alignTop
) override

Parameters

region
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ReportRegion
alignTop
Type: System..::.Boolean

See Also

ContinuedPageModel Class
EnsureVisible Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


GetGap Method

[image]

.NET ModelKit Suite ClassReference
ContinuedPageModel..::.GetGap Method
ContinuedPageModel Class See Also Send Feedback
Gets the gap between pages.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected override Size GetGap(
    Point center
)
Visual Basic (Declaration)
Protected Overrides Function GetGap ( _
    center As Point _
) As Size
Visual C++
protected:
virtual Size GetGap(
    Point center
) override

Parameters

center
Type: System.Windows..::.Point

See Also

ContinuedPageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ContinuedPageModel..::.Invalidate Method
ContinuedPageModel Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates report viewer. (Inherited from DocumentViewModel.)
Invalidate(Boolean) | Invalidates report viewer. (Inherited from DocumentViewModel.)

See Also

ContinuedPageModel Class
ContinuedPageModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageEnd Method

[image]

.NET ModelKit Suite ClassReference
ContinuedPageModel..::.PageEnd Method
ContinuedPageModel Class See Also Send Feedback
Overridden. See PageEnd()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void PageEnd()
Visual Basic (Declaration)
Public Overrides Sub PageEnd
Visual C++
public:
virtual void PageEnd() override

See Also

ContinuedPageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageHome Method

[image]

.NET ModelKit Suite ClassReference
ContinuedPageModel..::.PageHome Method
ContinuedPageModel Class See Also Send Feedback
Overridden. See PageHome()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void PageHome()
Visual Basic (Declaration)
Public Overrides Sub PageHome
Visual C++
public:
virtual void PageHome() override

See Also

ContinuedPageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


RectToScreen Method

[image]

.NET ModelKit Suite ClassReference
ContinuedPageModel..::.RectToScreen Method
ContinuedPageModel Class See Also Send Feedback
Gets page area screen coordinates.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected override Rect RectToScreen(
    ReportRegion region
)
Visual Basic (Declaration)
Protected Overrides Function RectToScreen ( _
    region As ReportRegion _
) As Rect
Visual C++
protected:
virtual Rect RectToScreen(
    ReportRegion region
) override

Parameters

region
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ReportRegion

See Also

ContinuedPageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


UpdateContent Method

[image]

.NET ModelKit Suite ClassReference
ContinuedPageModel..::.UpdateContent Method
ContinuedPageModel Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Silverlight.Client.ContinuedPageModel.UpdateContent(PerpetuumSoft.Reporting.Silverlight.Client.ViewModel,System.Boolean)]

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected internal override void UpdateContent(
    ViewModel prevViewModel,
    bool useAnimation
)
Visual Basic (Declaration)
Protected Friend Overrides Sub UpdateContent ( _
    prevViewModel As ViewModel, _
    useAnimation As Boolean _
)
Visual C++
protected public:
virtual void UpdateContent(
    ViewModel^ prevViewModel,
    bool useAnimation
) override

Parameters

prevViewModel
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ViewModel
useAnimation
Type: System..::.Boolean

See Also

ContinuedPageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomIn Method

[image] [image]

.NET ModelKit Suite ClassReference
ContinuedPageModel..::.ZoomIn Method
ContinuedPageModel Class See Also Send Feedback

Overload List

Name | Description
ZoomIn(Boolean) | Performs zoom in. (Inherited from ViewModel.)
ZoomIn(Point, Boolean) | Performs zoom in. (Inherited from ViewModel.)

See Also

ContinuedPageModel Class
ContinuedPageModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomOut Method

[image] [image]

.NET ModelKit Suite ClassReference
ContinuedPageModel..::.ZoomOut Method
ContinuedPageModel Class See Also Send Feedback

Overload List

Name | Description
ZoomOut(Boolean) | Performs zoom out. (Inherited from ViewModel.)
ZoomOut(Point, Boolean) | Performs zoom out. (Inherited from ViewModel.)

See Also

ContinuedPageModel Class
ContinuedPageModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ContinuedPageModel Properties

[image] [image]

.NET ModelKit Suite ClassReference
ContinuedPageModel Properties
ContinuedPageModel Class See Also Send Feedback

The ContinuedPageModel type exposes the following members.

Properties

Name | Description
CanGoToNextPage | Overridden. See CanGoToNextPage. (Inherited from DocumentViewModel.)
CanGoToPrevPage | Overridden. See CanGoToPrevPage. (Inherited from DocumentViewModel.)
ClientSize | Gets the client area size. (Inherited from ViewModel.)
Document | Gets Document which is a report. (Inherited from DocumentViewModel.)
HScrollBarActive | Overridden. See HScrollBarActive. (Inherited from DocumentViewModel.)
HScrollBarLarge | Overridden. See HScrollBarLarge. (Inherited from DocumentViewModel.)
HScrollBarMaximum | Overridden. See HScrollBarMaximum. (Inherited from DocumentViewModel.)
HScrollBarPosition | Overridden. See HScrollBarPosition. (Inherited from DocumentViewModel.)
HScrollBarSmall | Overridden. See HScrollBarSmall. (Inherited from DocumentViewModel.)
HScrollBarViewPort | Overridden. See HScrollBarViewPort. (Inherited from DocumentViewModel.)
PageNumber | Overridden. See PageNumber. (Overrides ViewModel..::.PageNumber.)
ScaledPageArea | Gets the page sizes subject to view scale. (Overrides DocumentViewModel..::.ScaledPageArea.)
View | Gets IView which is report preview control. (Inherited from ViewModel.)
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from ViewModel.)
VScrollBarActive | Overridden. See VScrollBarActive. (Inherited from DocumentViewModel.)
VScrollBarLarge | Overridden. See VScrollBarLarge. (Overrides DocumentViewModel..::.VScrollBarLarge.)
VScrollBarMaximum | Overridden. See VScrollBarMaximum. (Inherited from DocumentViewModel.)
VScrollBarPosition | Overridden. See VScrollBarPosition. (Inherited from DocumentViewModel.)
VScrollBarSmall | Overridden. See VScrollBarSmall. (Inherited from DocumentViewModel.)
VScrollBarViewPort | Overridden. See VScrollBarViewPort. (Inherited from DocumentViewModel.)
Zoom | Overridden. See Zoom. (Inherited from DocumentViewModel.)

See Also

ContinuedPageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageNumber Property

[image]

.NET ModelKit Suite ClassReference
ContinuedPageModel..::.PageNumber Property
ContinuedPageModel Class See Also Send Feedback
Overridden. See PageNumber.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override int PageNumber { get; set; }
Visual Basic (Declaration)
Public Overrides Property PageNumber As Integer
Visual C++
public:
virtual property int PageNumber {
    int get () override;
    void set (int value) override;
}

See Also

ContinuedPageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ScaledPageArea Property

[image]

.NET ModelKit Suite ClassReference
ContinuedPageModel..::.ScaledPageArea Property
ContinuedPageModel Class See Also Send Feedback
Gets the page sizes subject to view scale.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected override Size ScaledPageArea { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property ScaledPageArea As Size
Visual C++
protected:
virtual property Size ScaledPageArea {
    Size get () override;
}

See Also

ContinuedPageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


VScrollBarLarge Property

[image]

.NET ModelKit Suite ClassReference
ContinuedPageModel..::.VScrollBarLarge Property
ContinuedPageModel Class See Also Send Feedback
Overridden. See VScrollBarLarge.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override double VScrollBarLarge { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property VScrollBarLarge As Double
Visual C++
public:
virtual property double VScrollBarLarge {
    double get () override;
}

See Also

ContinuedPageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Cursor Class

[image]

.NET ModelKit Suite ClassReference
Cursor Class
Members See Also Send Feedback
A cursor class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class Cursor : Control
Visual Basic (Declaration)
Public Class Cursor _
    Inherits Control
Visual C++
public ref class Cursor : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.Reporting.Silverlight.Client..::.Cursor

See Also

Cursor Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Cursor Members

[image] [image]

.NET ModelKit Suite ClassReference
Cursor Members
Cursor Class Constructors Methods Fields Properties Events See Also Send Feedback

The Cursor type exposes the following members.

Constructors

Name | Description
Cursor | Initializes a new instance of the Cursor class.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
CenterPointXProperty | Gets or sets X coordinate of the cursor pointer on the image. Takes values from 0 to 1. Dependency property.
CenterPointYProperty | Gets or sets Y coordinate of the cursor pointer on the image. Takes values from 0 to 1. Dependency property.
CursorImageSourceProperty | Gets or sets a cursor image. Dependency property.
IsCursorMouseDownProperty | Gets or sets the property which indicates that left mouse button is pressed. Dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CenterPointX | Gets or sets X coordinate of the cursor pointer on report view. Takes values from 0 to 1.
CenterPointY | Gets or sets Y coordinate of the cursor pointer on report view. Takes values from 0 to 1.
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
CursorImageSource | Gets or sets the cursor image.
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsCursorMouseDown | Gets or sets the property which indicates that left mouse button is pressed.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Cursor Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Cursor Constructor

[image]

.NET ModelKit Suite ClassReference
Cursor Constructor
Cursor Class See Also Send Feedback
Initializes a new instance of the Cursor class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Cursor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Cursor()

See Also

Cursor Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Cursor Fields

[image] [image]

.NET ModelKit Suite ClassReference
Cursor Fields
Cursor Class See Also Send Feedback

The Cursor type exposes the following members.

Fields

Name | Description
CenterPointXProperty | Gets or sets X coordinate of the cursor pointer on the image. Takes values from 0 to 1. Dependency property.
CenterPointYProperty | Gets or sets Y coordinate of the cursor pointer on the image. Takes values from 0 to 1. Dependency property.
CursorImageSourceProperty | Gets or sets a cursor image. Dependency property.
IsCursorMouseDownProperty | Gets or sets the property which indicates that left mouse button is pressed. Dependency property.

See Also

Cursor Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CenterPointXProperty Field

[image]

.NET ModelKit Suite ClassReference
Cursor..::.CenterPointXProperty Field
Cursor Class See Also Send Feedback
Gets or sets X coordinate of the cursor pointer on the image. Takes values from 0 to 1. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static DependencyProperty CenterPointXProperty
Visual Basic (Declaration)
Public Shared CenterPointXProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ CenterPointXProperty

See Also

Cursor Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CenterPointYProperty Field

[image]

.NET ModelKit Suite ClassReference
Cursor..::.CenterPointYProperty Field
Cursor Class See Also Send Feedback
Gets or sets Y coordinate of the cursor pointer on the image. Takes values from 0 to 1. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static DependencyProperty CenterPointYProperty
Visual Basic (Declaration)
Public Shared CenterPointYProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ CenterPointYProperty

See Also

Cursor Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CursorImageSourceProperty Field

[image]

.NET ModelKit Suite ClassReference
Cursor..::.CursorImageSourceProperty Field
Cursor Class See Also Send Feedback
Gets or sets a cursor image. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static DependencyProperty CursorImageSourceProperty
Visual Basic (Declaration)
Public Shared CursorImageSourceProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ CursorImageSourceProperty

See Also

Cursor Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


IsCursorMouseDownProperty Field

[image]

.NET ModelKit Suite ClassReference
Cursor..::.IsCursorMouseDownProperty Field
Cursor Class See Also Send Feedback
Gets or sets the property which indicates that left mouse button is pressed. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static DependencyProperty IsCursorMouseDownProperty
Visual Basic (Declaration)
Public Shared IsCursorMouseDownProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ IsCursorMouseDownProperty

See Also

Cursor Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Cursor Methods

[image] [image]

.NET ModelKit Suite ClassReference
Cursor Methods
Cursor Class See Also Send Feedback

The Cursor type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

Cursor Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Cursor Properties

[image] [image]

.NET ModelKit Suite ClassReference
Cursor Properties
Cursor Class See Also Send Feedback

The Cursor type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CenterPointX | Gets or sets X coordinate of the cursor pointer on report view. Takes values from 0 to 1.
CenterPointY | Gets or sets Y coordinate of the cursor pointer on report view. Takes values from 0 to 1.
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
CursorImageSource | Gets or sets the cursor image.
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsCursorMouseDown | Gets or sets the property which indicates that left mouse button is pressed.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

Cursor Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CenterPointX Property

[image]

.NET ModelKit Suite ClassReference
Cursor..::.CenterPointX Property
Cursor Class See Also Send Feedback
Gets or sets X coordinate of the cursor pointer on report view. Takes values from 0 to 1.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public double CenterPointX { get; set; }
Visual Basic (Declaration)
Public Property CenterPointX As Double
Visual C++
public:
property double CenterPointX {
    double get ();
    void set (double value);
}

See Also

Cursor Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CenterPointY Property

[image]

.NET ModelKit Suite ClassReference
Cursor..::.CenterPointY Property
Cursor Class See Also Send Feedback
Gets or sets Y coordinate of the cursor pointer on report view. Takes values from 0 to 1.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public double CenterPointY { get; set; }
Visual Basic (Declaration)
Public Property CenterPointY As Double
Visual C++
public:
property double CenterPointY {
    double get ();
    void set (double value);
}

See Also

Cursor Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CursorImageSource Property

[image]

.NET ModelKit Suite ClassReference
Cursor..::.CursorImageSource Property
Cursor Class See Also Send Feedback
Gets or sets the cursor image.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ImageSource CursorImageSource { get; set; }
Visual Basic (Declaration)
Public Property CursorImageSource As ImageSource
Visual C++
public:
property ImageSource^ CursorImageSource {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

See Also

Cursor Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


IsCursorMouseDown Property

[image]

.NET ModelKit Suite ClassReference
Cursor..::.IsCursorMouseDown Property
Cursor Class See Also Send Feedback
Gets or sets the property which indicates that left mouse button is pressed.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool IsCursorMouseDown { get; set; }
Visual Basic (Declaration)
Public Property IsCursorMouseDown As Boolean
Visual C++
public:
property bool IsCursorMouseDown {
    bool get ();
    void set (bool value);
}

See Also

Cursor Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Cursor Events

[image] [image]

.NET ModelKit Suite ClassReference
Cursor Events
Cursor Class See Also Send Feedback

The Cursor type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Cursor Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CursorLayer Class

[image]

.NET ModelKit Suite ClassReference
CursorLayer Class
Members See Also Send Feedback
A layer class where cursor is displayed. It is used for the Report Viewer template creation.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class CursorLayer : Canvas
Visual Basic (Declaration)
Public Class CursorLayer _
    Inherits Canvas
Visual C++
public ref class CursorLayer : public Canvas

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Panel
System.Windows.Controls..::.Canvas
PerpetuumSoft.Reporting.Silverlight.Client..::.CursorLayer

See Also

CursorLayer Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CursorLayer Members

[image] [image]

.NET ModelKit Suite ClassReference
CursorLayer Members
CursorLayer Class Constructors Methods Properties Events See Also Send Feedback

The CursorLayer type exposes the following members.

Constructors

Name | Description
CursorLayer | Initializes a new instance of the CursorLayer class.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from Canvas.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from Canvas.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnMoseLeave | Occurs when the pointer leaves report viewer bounds.
OnMoseMove | Occurs when the pointer is moving in report viewer bounds.
OnMouseDown | Occurs when the mouse left button is pressed when the pointer is in report viewer bounds.
OnMouseUp | Occurs when the mouse left button is released when the pointer is in report viewer bounds.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetCursor | Sets active cursor.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
CurrentCursor | Gets or sets Cursor which is current cursor.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsCursorUnderHyperlink | Gets or sets the property which indicates that cursor is above the hyperlink.
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
ViewManager | Gets or sets ViewManager which is Report Viewer manager.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

CursorLayer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CursorLayer Constructor

[image]

.NET ModelKit Suite ClassReference
CursorLayer Constructor
CursorLayer Class See Also Send Feedback
Initializes a new instance of the CursorLayer class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public CursorLayer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CursorLayer()

See Also

CursorLayer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CursorLayer Methods

[image] [image]

.NET ModelKit Suite ClassReference
CursorLayer Methods
CursorLayer Class See Also Send Feedback

The CursorLayer type exposes the following members.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from Canvas.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from Canvas.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnMoseLeave | Occurs when the pointer leaves report viewer bounds.
OnMoseMove | Occurs when the pointer is moving in report viewer bounds.
OnMouseDown | Occurs when the mouse left button is pressed when the pointer is in report viewer bounds.
OnMouseUp | Occurs when the mouse left button is released when the pointer is in report viewer bounds.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetCursor | Sets active cursor.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

CursorLayer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


OnMoseLeave Method

[image]

.NET ModelKit Suite ClassReference
CursorLayer..::.OnMoseLeave Method
CursorLayer Class See Also Send Feedback
Occurs when the pointer leaves report viewer bounds.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void OnMoseLeave()
Visual Basic (Declaration)
Public Sub OnMoseLeave
Visual C++
public:
void OnMoseLeave()

See Also

CursorLayer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


OnMoseMove Method

[image]

.NET ModelKit Suite ClassReference
CursorLayer..::.OnMoseMove Method
CursorLayer Class See Also Send Feedback
Occurs when the pointer is moving in report viewer bounds.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void OnMoseMove(
    Point position
)
Visual Basic (Declaration)
Public Sub OnMoseMove ( _
    position As Point _
)
Visual C++
public:
void OnMoseMove(
    Point position
)

Parameters

position
Type: System.Windows..::.Point

See Also

CursorLayer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


OnMouseDown Method

[image]

.NET ModelKit Suite ClassReference
CursorLayer..::.OnMouseDown Method
CursorLayer Class See Also Send Feedback
Occurs when the mouse left button is pressed when the pointer is in report viewer bounds.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void OnMouseDown()
Visual Basic (Declaration)
Public Sub OnMouseDown
Visual C++
public:
void OnMouseDown()

See Also

CursorLayer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


OnMouseUp Method

[image]

.NET ModelKit Suite ClassReference
CursorLayer..::.OnMouseUp Method
CursorLayer Class See Also Send Feedback
Occurs when the mouse left button is released when the pointer is in report viewer bounds.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void OnMouseUp()
Visual Basic (Declaration)
Public Sub OnMouseUp
Visual C++
public:
void OnMouseUp()

See Also

CursorLayer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


SetCursor Method

[image]

.NET ModelKit Suite ClassReference
CursorLayer..::.SetCursor Method
CursorLayer Class See Also Send Feedback
Sets active cursor.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public virtual void SetCursor(
    BitmapImage bitmapImage,
    double centerX,
    double centerY
)
Visual Basic (Declaration)
Public Overridable Sub SetCursor ( _
    bitmapImage As BitmapImage, _
    centerX As Double, _
    centerY As Double _
)
Visual C++
public:
virtual void SetCursor(
    BitmapImage^ bitmapImage,
    double centerX,
    double centerY
)

Parameters

bitmapImage
Type: System.Windows.Media.Imaging..::.BitmapImage
centerX
Type: System..::.Double
centerY
Type: System..::.Double

See Also

CursorLayer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CursorLayer Properties

[image] [image]

.NET ModelKit Suite ClassReference
CursorLayer Properties
CursorLayer Class See Also Send Feedback

The CursorLayer type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
CurrentCursor | Gets or sets Cursor which is current cursor.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsCursorUnderHyperlink | Gets or sets the property which indicates that cursor is above the hyperlink.
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
ViewManager | Gets or sets ViewManager which is Report Viewer manager.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

CursorLayer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CurrentCursor Property

[image]

.NET ModelKit Suite ClassReference
CursorLayer..::.CurrentCursor Property
CursorLayer Class See Also Send Feedback
Gets or sets Cursor which is current cursor.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Cursor CurrentCursor { get; set; }
Visual Basic (Declaration)
Public Property CurrentCursor As Cursor
Visual C++
public:
property Cursor^ CurrentCursor {
    Cursor^ get ();
    void set (Cursor^ value);
}

See Also

CursorLayer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


IsCursorUnderHyperlink Property

[image]

.NET ModelKit Suite ClassReference
CursorLayer..::.IsCursorUnderHyperlink Property
CursorLayer Class See Also Send Feedback
Gets or sets the property which indicates that cursor is above the hyperlink.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool IsCursorUnderHyperlink { get; internal set; }
Visual Basic (Declaration)
Public Property IsCursorUnderHyperlink As Boolean
Visual C++
public:
property bool IsCursorUnderHyperlink {
    bool get ();
    void set (bool value);
}

See Also

CursorLayer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewManager Property

[image]

.NET ModelKit Suite ClassReference
CursorLayer..::.ViewManager Property
CursorLayer Class See Also Send Feedback
Gets or sets ViewManager which is Report Viewer manager.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ViewManager ViewManager { get; set; }
Visual Basic (Declaration)
Public Property ViewManager As ViewManager
Visual C++
public:
property ViewManager^ ViewManager {
    ViewManager^ get ();
    void set (ViewManager^ value);
}

See Also

CursorLayer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CursorLayer Events

[image] [image]

.NET ModelKit Suite ClassReference
CursorLayer Events
CursorLayer Class See Also Send Feedback

The CursorLayer type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

CursorLayer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DisabledTool Class

[image]

.NET ModelKit Suite ClassReference
DisabledTool Class
Members See Also Send Feedback
Realizes the tool which makes available any actions with the report. Inherited from Tool.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public sealed class DisabledTool : Tool
Visual Basic (Declaration)
Public NotInheritable Class DisabledTool _
    Inherits Tool
Visual C++
public ref class DisabledTool sealed : public Tool

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client..::.Tool
PerpetuumSoft.Reporting.Silverlight.Client..::.DisabledTool

See Also

DisabledTool Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DisabledTool Members

[image] [image]

.NET ModelKit Suite ClassReference
DisabledTool Members
DisabledTool Class Constructors Methods Properties See Also Send Feedback

The DisabledTool type exposes the following members.

Constructors

Name | Description
DisabledTool | Initializes a new instance of the DisabledTool class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Overrides Tool..::.KeyDown(KeyEventArgs).)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Overrides Tool..::.KeyUp(KeyEventArgs).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Overrides Tool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides Tool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides Tool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Overrides Tool..::.MouseWheel(Double).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates active cursor. (Inherited from Tool.)

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

DisabledTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DisabledTool Constructor

[image]

.NET ModelKit Suite ClassReference
DisabledTool Constructor
DisabledTool Class See Also Send Feedback
Initializes a new instance of the DisabledTool class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public DisabledTool()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DisabledTool()

See Also

DisabledTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DisabledTool Methods

[image] [image]

.NET ModelKit Suite ClassReference
DisabledTool Methods
DisabledTool Class See Also Send Feedback

The DisabledTool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Overrides Tool..::.KeyDown(KeyEventArgs).)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Overrides Tool..::.KeyUp(KeyEventArgs).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Overrides Tool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides Tool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides Tool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Overrides Tool..::.MouseWheel(Double).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates active cursor. (Inherited from Tool.)

See Also

DisabledTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


KeyDown Method

[image]

.NET ModelKit Suite ClassReference
DisabledTool..::.KeyDown Method
DisabledTool Class See Also Send Feedback
Overridden. See KeyDown(KeyEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void KeyDown(
    KeyEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub KeyDown ( _
    args As KeyEventArgs _
)
Visual C++
public:
virtual void KeyDown(
    KeyEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.KeyEventArgs

See Also

DisabledTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


KeyUp Method

[image]

.NET ModelKit Suite ClassReference
DisabledTool..::.KeyUp Method
DisabledTool Class See Also Send Feedback
Overridden. See KeyUp(KeyEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void KeyUp(
    KeyEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub KeyUp ( _
    args As KeyEventArgs _
)
Visual C++
public:
virtual void KeyUp(
    KeyEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.KeyEventArgs

See Also

DisabledTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseDown Method

[image]

.NET ModelKit Suite ClassReference
DisabledTool..::.MouseDown Method
DisabledTool Class See Also Send Feedback
Overridden. See MouseDown(MouseEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseDown(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseDown ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseDown(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

DisabledTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseMove Method

[image]

.NET ModelKit Suite ClassReference
DisabledTool..::.MouseMove Method
DisabledTool Class See Also Send Feedback
Overridden. See MouseMove(MouseEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseMove(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseMove ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseMove(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

DisabledTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseUp Method

[image]

.NET ModelKit Suite ClassReference
DisabledTool..::.MouseUp Method
DisabledTool Class See Also Send Feedback
Overridden. See MouseUp(MouseEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseUp(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseUp ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseUp(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

DisabledTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseWheel Method

[image]

.NET ModelKit Suite ClassReference
DisabledTool..::.MouseWheel Method
DisabledTool Class See Also Send Feedback
Overridden. See MouseWheel(Double).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseWheel(
    double delta
)
Visual Basic (Declaration)
Public Overrides Sub MouseWheel ( _
    delta As Double _
)
Visual C++
public:
virtual void MouseWheel(
    double delta
) override

Parameters

delta
Type: System..::.Double

See Also

DisabledTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DisabledTool Properties

[image] [image]

.NET ModelKit Suite ClassReference
DisabledTool Properties
DisabledTool Class See Also Send Feedback

The DisabledTool type exposes the following members.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

DisabledTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Document Class

[image]

.NET ModelKit Suite ClassReference
Document Class
Members See Also Send Feedback
A class which includes report data.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class Document
Visual Basic (Declaration)
Public Class Document
Visual C++
public ref class Document

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client..::.Document

See Also

Document Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Document Members

[image] [image]

.NET ModelKit Suite ClassReference
Document Members
Document Class Constructors Methods Properties See Also Send Feedback

The Document type exposes the following members.

Constructors

Name | Description
Document | Initializes a new instance of the Document class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Id | Gets or sets document ID.
Pages | Gets or sets IList<(Of <(Page>)>) which are report pages.
Title | Gets or sets document title.

See Also

Document Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Document Constructor

[image]

.NET ModelKit Suite ClassReference
Document Constructor
Document Class See Also Send Feedback
Initializes a new instance of the Document class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Document()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Document()

See Also

Document Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Document Methods

[image] [image]

.NET ModelKit Suite ClassReference
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Document Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Document Properties

[image] [image]

.NET ModelKit Suite ClassReference
Document Properties
Document Class See Also Send Feedback

The Document type exposes the following members.

Properties

Name | Description
Id | Gets or sets document ID.
Pages | Gets or sets IList<(Of <(Page>)>) which are report pages.
Title | Gets or sets document title.

See Also

Document Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Id Property

[image]

.NET ModelKit Suite ClassReference
Document..::.Id Property
Document Class See Also Send Feedback
Gets or sets document ID.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

Document Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Pages Property

[image]

.NET ModelKit Suite ClassReference
Document..::.Pages Property
Document Class See Also Send Feedback
Gets or sets IList<(Of <(Page>)>) which are report pages.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public IList<Page> Pages { get; private set; }
Visual Basic (Declaration)
Public Property Pages As IList(Of Page)
Visual C++
public:
property IList<Page^>^ Pages {
    IList<Page^>^ get ();
    void set (IList<Page^>^ value);
}

See Also

Document Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Title Property

[image]

.NET ModelKit Suite ClassReference
Document..::.Title Property
Document Class See Also Send Feedback
Gets or sets document title.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

Document Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentLoadedEventArgs Class

[image]

.NET ModelKit Suite ClassReference
DocumentLoadedEventArgs Class
Members See Also Send Feedback
Parameters of the event which occurs when report is loaded.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class DocumentLoadedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class DocumentLoadedEventArgs _
    Inherits EventArgs
Visual C++
public ref class DocumentLoadedEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.Silverlight.Client..::.DocumentLoadedEventArgs

See Also

DocumentLoadedEventArgs Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentLoadedEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
DocumentLoadedEventArgs Members
DocumentLoadedEventArgs Class Constructors Methods Properties See Also Send Feedback

The DocumentLoadedEventArgs type exposes the following members.

Constructors

Name | Description
DocumentLoadedEventArgs | Initializes a new instance of the DocumentLoadedEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Document | Gets or sets Document which is a document.

See Also

DocumentLoadedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentLoadedEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
DocumentLoadedEventArgs Constructor
DocumentLoadedEventArgs Class See Also Send Feedback
Initializes a new instance of the DocumentLoadedEventArgs class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public DocumentLoadedEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentLoadedEventArgs()

See Also

DocumentLoadedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentLoadedEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
DocumentLoadedEventArgs Methods
DocumentLoadedEventArgs Class See Also Send Feedback

The DocumentLoadedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentLoadedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentLoadedEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
DocumentLoadedEventArgs Properties
DocumentLoadedEventArgs Class See Also Send Feedback

The DocumentLoadedEventArgs type exposes the following members.

Properties

Name | Description
Document | Gets or sets Document which is a document.

See Also

DocumentLoadedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Document Property

[image]

.NET ModelKit Suite ClassReference
DocumentLoadedEventArgs..::.Document Property
DocumentLoadedEventArgs Class See Also Send Feedback
Gets or sets Document which is a document.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Document Document { get; set; }
Visual Basic (Declaration)
Public Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
    void set (Document^ value);
}

See Also

DocumentLoadedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentPresenter Class

[image]

.NET ModelKit Suite ClassReference
DocumentPresenter Class
Members See Also Send Feedback
Report presenter.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class DocumentPresenter : Control
Visual Basic (Declaration)
Public Class DocumentPresenter _
    Inherits Control
Visual C++
public ref class DocumentPresenter : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.Reporting.Silverlight.Client..::.DocumentPresenter

See Also

DocumentPresenter Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentPresenter Members

[image] [image]

.NET ModelKit Suite ClassReference
DocumentPresenter Members
DocumentPresenter Class Constructors Methods Properties Events See Also Send Feedback

The DocumentPresenter type exposes the following members.

Constructors

Name | Description
DocumentPresenter | Initializes a new instance of the DocumentPresenter class.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)
UpdateView | Updates report view.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AdornersLayer | Gets the borders layout.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
ClientSize | Gets the сclient area size.
Clip | (Inherited from UIElement.)
ContentLayer | Gets report content layer.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
ViewManager | Gets or sets ViewManager which is Report Viewer manager.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DocumentPresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentPresenter Constructor

[image]

.NET ModelKit Suite ClassReference
DocumentPresenter Constructor
DocumentPresenter Class See Also Send Feedback
Initializes a new instance of the DocumentPresenter class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public DocumentPresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentPresenter()

See Also

DocumentPresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentPresenter Methods

[image] [image]

.NET ModelKit Suite ClassReference
DocumentPresenter Methods
DocumentPresenter Class See Also Send Feedback

The DocumentPresenter type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)
UpdateView | Updates report view.

See Also

DocumentPresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


OnApplyTemplate Method

[image]

.NET ModelKit Suite ClassReference
DocumentPresenter..::.OnApplyTemplate Method
DocumentPresenter Class See Also Send Feedback
Overridden. See OnApplyTemplate()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

DocumentPresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


UpdateView Method

[image]

.NET ModelKit Suite ClassReference
DocumentPresenter..::.UpdateView Method
DocumentPresenter Class See Also Send Feedback
Updates report view.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void UpdateView()
Visual Basic (Declaration)
Public Sub UpdateView
Visual C++
public:
void UpdateView()

See Also

DocumentPresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentPresenter Properties

[image] [image]

.NET ModelKit Suite ClassReference
DocumentPresenter Properties
DocumentPresenter Class See Also Send Feedback

The DocumentPresenter type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AdornersLayer | Gets the borders layout.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
ClientSize | Gets the сclient area size.
Clip | (Inherited from UIElement.)
ContentLayer | Gets report content layer.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
ViewManager | Gets or sets ViewManager which is Report Viewer manager.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DocumentPresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


AdornersLayer Property

[image]

.NET ModelKit Suite ClassReference
DocumentPresenter..::.AdornersLayer Property
DocumentPresenter Class See Also Send Feedback
Gets the borders layout.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Canvas AdornersLayer { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdornersLayer As Canvas
Visual C++
public:
property Canvas^ AdornersLayer {
    Canvas^ get ();
}

See Also

DocumentPresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ClientSize Property

[image]

.NET ModelKit Suite ClassReference
DocumentPresenter..::.ClientSize Property
DocumentPresenter Class See Also Send Feedback
Gets the сclient area size.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Size ClientSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClientSize As Size
Visual C++
public:
property Size ClientSize {
    Size get ();
}

See Also

DocumentPresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ContentLayer Property

[image]

.NET ModelKit Suite ClassReference
DocumentPresenter..::.ContentLayer Property
DocumentPresenter Class See Also Send Feedback
Gets report content layer.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Canvas ContentLayer { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentLayer As Canvas
Visual C++
public:
property Canvas^ ContentLayer {
    Canvas^ get ();
}

See Also

DocumentPresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewManager Property

[image]

.NET ModelKit Suite ClassReference
DocumentPresenter..::.ViewManager Property
DocumentPresenter Class See Also Send Feedback
Gets or sets ViewManager which is Report Viewer manager.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ViewManager ViewManager { get; set; }
Visual Basic (Declaration)
Public Property ViewManager As ViewManager
Visual C++
public:
property ViewManager^ ViewManager {
    ViewManager^ get ();
    void set (ViewManager^ value);
}

See Also

DocumentPresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentPresenter Events

[image] [image]

.NET ModelKit Suite ClassReference
DocumentPresenter Events
DocumentPresenter Class See Also Send Feedback

The DocumentPresenter type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DocumentPresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentViewModel Class

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel Class
Members See Also Send Feedback
Report view model.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract class DocumentViewModel : ViewModel
Visual Basic (Declaration)
Public MustInherit Class DocumentViewModel _
    Inherits ViewModel
Visual C++
public ref class DocumentViewModel abstract : public ViewModel

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client..::.ViewModel
PerpetuumSoft.Reporting.Silverlight.Client..::.DocumentViewModel
PerpetuumSoft.Reporting.Silverlight.Client..::.ContinuedPageModel
PerpetuumSoft.Reporting.Silverlight.Client..::.SinglePageModel

See Also

DocumentViewModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentViewModel Members

[image] [image]

.NET ModelKit Suite ClassReference
DocumentViewModel Members
DocumentViewModel Class Constructors Methods Fields Properties See Also Send Feedback

The DocumentViewModel type exposes the following members.

Constructors

Name | Description
DocumentViewModel | Initializes a new instance of the DocumentViewModel class.

Methods

Name | Description
AssignParameters | Sets the model display parameters subject to the previous active model. (Inherited from ViewModel.)
CalculateOrigin | Calculates the page location in the report preview area.
CalculateZoom | Calculates scale.
ChangeZoom | Overloaded.
Clone | Creates object clone. (Inherited from ViewModel.)
CreateStoryboard | Creates Storyboard for animation.
DeleteUnusedPages | Deletes the unused pages.
DocumentEnd | Performs switching to the end of the report. (Inherited from ViewModel.)
DocumentHome | Performs switching to the beginning of the report. (Inherited from ViewModel.)
EnsurePageView | Creates the presenter for the selected page if the presenter is missing.
EnsureVisible | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetGap | Gets the gap between pages.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GoToFirstPage | Overridden. See GoToFirstPage()()(). (Overrides ViewModel..::.GoToFirstPage()()().)
GoToLastPage | Overridden. See GoToLastPage()()(). (Overrides ViewModel..::.GoToLastPage()()().)
GoToNextPage | Overridden. See GoToNextPage()()(). (Overrides ViewModel..::.GoToNextPage()()().)
GoToPrevPage | Overridden. See GoToPrevPage()()(). (Overrides ViewModel..::.GoToPrevPage()()().)
Invalidate | Overloaded.
MakeVisible | Forces content to scroll until the coordinate space of a specific rectangle is visible.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseWheel | Overridden. See MouseWheel(Double). (Overrides ViewModel..::.MouseWheel(Double).)
PageDown | Overridden. See PageDown()()(). (Overrides ViewModel..::.PageDown()()().)
PageEnd | Performs switching to the bottom of the page. (Inherited from ViewModel.)
PageHome | Performs switching to the top of the page. (Inherited from ViewModel.)
PageUp | Overridden. See PageUp()()(). (Overrides ViewModel..::.PageUp()()().)
PanView | Overridden. See PanView(Point). (Overrides ViewModel..::.PanView(Point).)
RectToScreen | Gets the screen coordinates of the selected area.
ResetSearchResult | Overridden. See ResetSearchResult()()(). (Overrides ViewModel..::.ResetSearchResult()()().)
SetupPage | Sets the selected page parameters.
ShowSearchResult | Overridden. See ShowSearchResult(ReportRegion). (Overrides ViewModel..::.ShowSearchResult(ReportRegion).)
StartAnimation | Starts animation.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateContent | (Inherited from ViewModel.)
ZoomIn | Overloaded.
ZoomOut | Overloaded.
ZoomWindow | Overridden. See ZoomWindow(Rect, Boolean). (Overrides ViewModel..::.ZoomWindow(Rect, Boolean).)

Fields

Name | Description
Gap | Gets the gap between pages.
Margin | Gets page margins.

Properties

Name | Description
CanGoToNextPage | Overridden. See CanGoToNextPage. (Overrides ViewModel..::.CanGoToNextPage.)
CanGoToPrevPage | Overridden. See CanGoToPrevPage. (Overrides ViewModel..::.CanGoToPrevPage.)
ClientSize | Gets the client area size. (Inherited from ViewModel.)
Document | Gets Document which is a report.
HScrollBarActive | Overridden. See HScrollBarActive. (Overrides ViewModel..::.HScrollBarActive.)
HScrollBarLarge | Overridden. See HScrollBarLarge. (Overrides ViewModel..::.HScrollBarLarge.)
HScrollBarMaximum | Overridden. See HScrollBarMaximum. (Overrides ViewModel..::.HScrollBarMaximum.)
HScrollBarPosition | Overridden. See HScrollBarPosition. (Overrides ViewModel..::.HScrollBarPosition.)
HScrollBarSmall | Overridden. See HScrollBarSmall. (Overrides ViewModel..::.HScrollBarSmall.)
HScrollBarViewPort | Overridden. See HScrollBarViewPort. (Overrides ViewModel..::.HScrollBarViewPort.)
PageNumber | Gets or sets page number. (Inherited from ViewModel.)
ScaledPageArea | Gets page view area.
View | Gets IView which is report preview control. (Inherited from ViewModel.)
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from ViewModel.)
VScrollBarActive | Overridden. See VScrollBarActive. (Overrides ViewModel..::.VScrollBarActive.)
VScrollBarLarge | Overridden. See VScrollBarLarge. (Overrides ViewModel..::.VScrollBarLarge.)
VScrollBarMaximum | Overridden. See VScrollBarMaximum. (Overrides ViewModel..::.VScrollBarMaximum.)
VScrollBarPosition | Overridden. See VScrollBarPosition. (Overrides ViewModel..::.VScrollBarPosition.)
VScrollBarSmall | Overridden. See VScrollBarSmall. (Overrides ViewModel..::.VScrollBarSmall.)
VScrollBarViewPort | Overridden. See VScrollBarViewPort. (Overrides ViewModel..::.VScrollBarViewPort.)
Zoom | Overridden. See Zoom. (Overrides ViewModel..::.Zoom.)

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentViewModel Constructor

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel Constructor
DocumentViewModel Class See Also Send Feedback
Initializes a new instance of the DocumentViewModel class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public DocumentViewModel(
    ViewManager viewManager
)
Visual Basic (Declaration)
Public Sub New ( _
    viewManager As ViewManager _
)
Visual C++
public:
DocumentViewModel(
    ViewManager^ viewManager
)

Parameters

viewManager
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ViewManager

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentViewModel Fields

[image] [image]

.NET ModelKit Suite ClassReference
DocumentViewModel Fields
DocumentViewModel Class See Also Send Feedback

The DocumentViewModel type exposes the following members.

Fields

Name | Description
Gap | Gets the gap between pages.
Margin | Gets page margins.

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Gap Field

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.Gap Field
DocumentViewModel Class See Also Send Feedback
Gets the gap between pages.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected readonly double Gap
Visual Basic (Declaration)
Protected ReadOnly Gap As Double
Visual C++
protected:
initonly double Gap

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Margin Field

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.Margin Field
DocumentViewModel Class See Also Send Feedback
Gets page margins.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected readonly double Margin
Visual Basic (Declaration)
Protected ReadOnly Margin As Double
Visual C++
protected:
initonly double Margin

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentViewModel Methods

[image] [image]

.NET ModelKit Suite ClassReference
DocumentViewModel Methods
DocumentViewModel Class See Also Send Feedback

The DocumentViewModel type exposes the following members.

Methods

Name | Description
AssignParameters | Sets the model display parameters subject to the previous active model. (Inherited from ViewModel.)
CalculateOrigin | Calculates the page location in the report preview area.
CalculateZoom | Calculates scale.
ChangeZoom | Overloaded.
Clone | Creates object clone. (Inherited from ViewModel.)
CreateStoryboard | Creates Storyboard for animation.
DeleteUnusedPages | Deletes the unused pages.
DocumentEnd | Performs switching to the end of the report. (Inherited from ViewModel.)
DocumentHome | Performs switching to the beginning of the report. (Inherited from ViewModel.)
EnsurePageView | Creates the presenter for the selected page if the presenter is missing.
EnsureVisible | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetGap | Gets the gap between pages.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GoToFirstPage | Overridden. See GoToFirstPage()()(). (Overrides ViewModel..::.GoToFirstPage()()().)
GoToLastPage | Overridden. See GoToLastPage()()(). (Overrides ViewModel..::.GoToLastPage()()().)
GoToNextPage | Overridden. See GoToNextPage()()(). (Overrides ViewModel..::.GoToNextPage()()().)
GoToPrevPage | Overridden. See GoToPrevPage()()(). (Overrides ViewModel..::.GoToPrevPage()()().)
Invalidate | Overloaded.
MakeVisible | Forces content to scroll until the coordinate space of a specific rectangle is visible.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseWheel | Overridden. See MouseWheel(Double). (Overrides ViewModel..::.MouseWheel(Double).)
PageDown | Overridden. See PageDown()()(). (Overrides ViewModel..::.PageDown()()().)
PageEnd | Performs switching to the bottom of the page. (Inherited from ViewModel.)
PageHome | Performs switching to the top of the page. (Inherited from ViewModel.)
PageUp | Overridden. See PageUp()()(). (Overrides ViewModel..::.PageUp()()().)
PanView | Overridden. See PanView(Point). (Overrides ViewModel..::.PanView(Point).)
RectToScreen | Gets the screen coordinates of the selected area.
ResetSearchResult | Overridden. See ResetSearchResult()()(). (Overrides ViewModel..::.ResetSearchResult()()().)
SetupPage | Sets the selected page parameters.
ShowSearchResult | Overridden. See ShowSearchResult(ReportRegion). (Overrides ViewModel..::.ShowSearchResult(ReportRegion).)
StartAnimation | Starts animation.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateContent | (Inherited from ViewModel.)
ZoomIn | Overloaded.
ZoomOut | Overloaded.
ZoomWindow | Overridden. See ZoomWindow(Rect, Boolean). (Overrides ViewModel..::.ZoomWindow(Rect, Boolean).)

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CalculateOrigin Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.CalculateOrigin Method
DocumentViewModel Class See Also Send Feedback
Calculates the page location in the report preview area.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected virtual void CalculateOrigin()
Visual Basic (Declaration)
Protected Overridable Sub CalculateOrigin
Visual C++
protected:
virtual void CalculateOrigin()

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CalculateZoom Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.CalculateZoom Method
DocumentViewModel Class See Also Send Feedback
Calculates scale.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected void CalculateZoom()
Visual Basic (Declaration)
Protected Sub CalculateZoom
Visual C++
protected:
void CalculateZoom()

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ChangeZoom Method

[image] [image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.ChangeZoom Method
DocumentViewModel Class See Also Send Feedback

Overload List

Name | Description
ChangeZoom(ZoomMode, Boolean) | Overridden. See ChangeZoom(ZoomMode, Boolean). (Overrides ViewModel..::.ChangeZoom(ZoomMode, Boolean).)
ChangeZoom(Double, Boolean) | Performs scale and scale mode changing. (Inherited from ViewModel.)
ChangeZoom(Point, Double, Boolean) | Overridden. See ChangeZoom(Point, Double, Boolean). (Overrides ViewModel..::.ChangeZoom(Point, Double, Boolean).)

See Also

DocumentViewModel Class
DocumentViewModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ChangeZoom Method (ZoomMode, Boolean)

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.ChangeZoom Method (ZoomMode, Boolean)
DocumentViewModel Class See Also Send Feedback
Overridden. See ChangeZoom(ZoomMode, Boolean).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void ChangeZoom(
    ZoomMode mode,
    bool useAnimation
)
Visual Basic (Declaration)
Public Overrides Sub ChangeZoom ( _
    mode As ZoomMode, _
    useAnimation As Boolean _
)
Visual C++
public:
virtual void ChangeZoom(
    ZoomMode mode,
    bool useAnimation
) override

Parameters

mode
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ZoomMode
useAnimation
Type: System..::.Boolean

See Also

DocumentViewModel Class
ChangeZoom Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ChangeZoom Method (Point, Double, Boolean)

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.ChangeZoom Method (Point, Double, Boolean)
DocumentViewModel Class See Also Send Feedback
Overridden. See ChangeZoom(Point, Double, Boolean).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void ChangeZoom(
    Point center,
    double scale,
    bool useAnimation
)
Visual Basic (Declaration)
Public Overrides Sub ChangeZoom ( _
    center As Point, _
    scale As Double, _
    useAnimation As Boolean _
)
Visual C++
public:
virtual void ChangeZoom(
    Point center,
    double scale,
    bool useAnimation
) override

Parameters

center
Type: System.Windows..::.Point
scale
Type: System..::.Double
useAnimation
Type: System..::.Boolean

See Also

DocumentViewModel Class
ChangeZoom Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CreateStoryboard Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.CreateStoryboard Method
DocumentViewModel Class See Also Send Feedback
Creates Storyboard for animation.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected Storyboard CreateStoryboard(
    bool useAnimation
)
Visual Basic (Declaration)
Protected Function CreateStoryboard ( _
    useAnimation As Boolean _
) As Storyboard
Visual C++
protected:
Storyboard^ CreateStoryboard(
    bool useAnimation
)

Parameters

useAnimation
Type: System..::.Boolean

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DeleteUnusedPages Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.DeleteUnusedPages Method
DocumentViewModel Class See Also Send Feedback
Deletes the unused pages.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected void DeleteUnusedPages(
    int firstPage,
    int lastPage
)
Visual Basic (Declaration)
Protected Sub DeleteUnusedPages ( _
    firstPage As Integer, _
    lastPage As Integer _
)
Visual C++
protected:
void DeleteUnusedPages(
    int firstPage,
    int lastPage
)

Parameters

firstPage
Type: System..::.Int32
lastPage
Type: System..::.Int32

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


EnsurePageView Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.EnsurePageView Method
DocumentViewModel Class See Also Send Feedback
Creates the presenter for the selected page if the presenter is missing.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected PagePresenter EnsurePageView(
    int pageNumber
)
Visual Basic (Declaration)
Protected Function EnsurePageView ( _
    pageNumber As Integer _
) As PagePresenter
Visual C++
protected:
PagePresenter^ EnsurePageView(
    int pageNumber
)

Parameters

pageNumber
Type: System..::.Int32

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


EnsureVisible Method

[image] [image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.EnsureVisible Method
DocumentViewModel Class See Also Send Feedback

Overload List

Name | Description
EnsureVisible(ReportRegion) | Shifts the visible area of the screen to guarantee that the specified report is visible. (Inherited from ViewModel.)
EnsureVisible(ReportRegion, Boolean) | Shifts the visible area of the screen to guarantee that the specified report is visible. (Inherited from ViewModel.)

See Also

DocumentViewModel Class
DocumentViewModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


GetGap Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.GetGap Method
DocumentViewModel Class See Also Send Feedback
Gets the gap between pages.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected abstract Size GetGap(
    Point center
)
Visual Basic (Declaration)
Protected MustOverride Function GetGap ( _
    center As Point _
) As Size
Visual C++
protected:
virtual Size GetGap(
    Point center
) abstract

Parameters

center
Type: System.Windows..::.Point

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


GoToFirstPage Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.GoToFirstPage Method
DocumentViewModel Class See Also Send Feedback
Overridden. See GoToFirstPage()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void GoToFirstPage()
Visual Basic (Declaration)
Public Overrides Sub GoToFirstPage
Visual C++
public:
virtual void GoToFirstPage() override

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


GoToLastPage Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.GoToLastPage Method
DocumentViewModel Class See Also Send Feedback
Overridden. See GoToLastPage()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void GoToLastPage()
Visual Basic (Declaration)
Public Overrides Sub GoToLastPage
Visual C++
public:
virtual void GoToLastPage() override

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


GoToNextPage Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.GoToNextPage Method
DocumentViewModel Class See Also Send Feedback
Overridden. See GoToNextPage()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void GoToNextPage()
Visual Basic (Declaration)
Public Overrides Sub GoToNextPage
Visual C++
public:
virtual void GoToNextPage() override

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


GoToPrevPage Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.GoToPrevPage Method
DocumentViewModel Class See Also Send Feedback
Overridden. See GoToPrevPage()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void GoToPrevPage()
Visual Basic (Declaration)
Public Overrides Sub GoToPrevPage
Visual C++
public:
virtual void GoToPrevPage() override

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.Invalidate Method
DocumentViewModel Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates report viewer.
Invalidate(Boolean) | Invalidates report viewer.

See Also

DocumentViewModel Class
DocumentViewModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Invalidate Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.Invalidate Method
DocumentViewModel Class See Also Send Feedback
Invalidates report viewer.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected void Invalidate()
Visual Basic (Declaration)
Protected Sub Invalidate
Visual C++
protected:
void Invalidate()

See Also

DocumentViewModel Class
Invalidate Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Invalidate Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.Invalidate Method (Boolean)
DocumentViewModel Class See Also Send Feedback
Invalidates report viewer.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected void Invalidate(
    bool useAnimation
)
Visual Basic (Declaration)
Protected Sub Invalidate ( _
    useAnimation As Boolean _
)
Visual C++
protected:
void Invalidate(
    bool useAnimation
)

Parameters

useAnimation
Type: System..::.Boolean

See Also

DocumentViewModel Class
Invalidate Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MakeVisible Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.MakeVisible Method
DocumentViewModel Class See Also Send Feedback
Forces content to scroll until the coordinate space of a specific rectangle is visible.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected void MakeVisible(
    ReportRegion region,
    bool alignTop
)
Visual Basic (Declaration)
Protected Sub MakeVisible ( _
    region As ReportRegion, _
    alignTop As Boolean _
)
Visual C++
protected:
void MakeVisible(
    ReportRegion region,
    bool alignTop
)

Parameters

region
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ReportRegion
alignTop
Type: System..::.Boolean

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseWheel Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.MouseWheel Method
DocumentViewModel Class See Also Send Feedback
Overridden. See MouseWheel(Double).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseWheel(
    double delta
)
Visual Basic (Declaration)
Public Overrides Sub MouseWheel ( _
    delta As Double _
)
Visual C++
public:
virtual void MouseWheel(
    double delta
) override

Parameters

delta
Type: System..::.Double

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageDown Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.PageDown Method
DocumentViewModel Class See Also Send Feedback
Overridden. See PageDown()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void PageDown()
Visual Basic (Declaration)
Public Overrides Sub PageDown
Visual C++
public:
virtual void PageDown() override

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageUp Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.PageUp Method
DocumentViewModel Class See Also Send Feedback
Overridden. See PageUp()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void PageUp()
Visual Basic (Declaration)
Public Overrides Sub PageUp
Visual C++
public:
virtual void PageUp() override

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PanView Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.PanView Method
DocumentViewModel Class See Also Send Feedback
Overridden. See PanView(Point).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void PanView(
    Point point
)
Visual Basic (Declaration)
Public Overrides Sub PanView ( _
    point As Point _
)
Visual C++
public:
virtual void PanView(
    Point point
) override

Parameters

point
Type: System.Windows..::.Point

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


RectToScreen Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.RectToScreen Method
DocumentViewModel Class See Also Send Feedback
Gets the screen coordinates of the selected area.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected abstract Rect RectToScreen(
    ReportRegion region
)
Visual Basic (Declaration)
Protected MustOverride Function RectToScreen ( _
    region As ReportRegion _
) As Rect
Visual C++
protected:
virtual Rect RectToScreen(
    ReportRegion region
) abstract

Parameters

region
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ReportRegion

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ResetSearchResult Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.ResetSearchResult Method
DocumentViewModel Class See Also Send Feedback
Overridden. See ResetSearchResult()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void ResetSearchResult()
Visual Basic (Declaration)
Public Overrides Sub ResetSearchResult
Visual C++
public:
virtual void ResetSearchResult() override

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


SetupPage Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.SetupPage Method
DocumentViewModel Class See Also Send Feedback
Sets the selected page parameters.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected void SetupPage(
    int pageNumber,
    double scale,
    Point pos,
    double oldScale,
    Point oldPos,
    Storyboard storyboard
)
Visual Basic (Declaration)
Protected Sub SetupPage ( _
    pageNumber As Integer, _
    scale As Double, _
    pos As Point, _
    oldScale As Double, _
    oldPos As Point, _
    storyboard As Storyboard _
)
Visual C++
protected:
void SetupPage(
    int pageNumber,
    double scale,
    Point pos,
    double oldScale,
    Point oldPos,
    Storyboard^ storyboard
)

Parameters

pageNumber
Type: System..::.Int32
scale
Type: System..::.Double
pos
Type: System.Windows..::.Point
oldScale
Type: System..::.Double
oldPos
Type: System.Windows..::.Point
storyboard
Type: System.Windows.Media.Animation..::.Storyboard

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ShowSearchResult Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.ShowSearchResult Method
DocumentViewModel Class See Also Send Feedback
Overridden. See ShowSearchResult(ReportRegion).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void ShowSearchResult(
    ReportRegion region
)
Visual Basic (Declaration)
Public Overrides Sub ShowSearchResult ( _
    region As ReportRegion _
)
Visual C++
public:
virtual void ShowSearchResult(
    ReportRegion region
) override

Parameters

region
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ReportRegion

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


StartAnimation Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.StartAnimation Method
DocumentViewModel Class See Also Send Feedback
Starts animation.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected void StartAnimation(
    Storyboard storyboard
)
Visual Basic (Declaration)
Protected Sub StartAnimation ( _
    storyboard As Storyboard _
)
Visual C++
protected:
void StartAnimation(
    Storyboard^ storyboard
)

Parameters

storyboard
Type: System.Windows.Media.Animation..::.Storyboard

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomIn Method

[image] [image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.ZoomIn Method
DocumentViewModel Class See Also Send Feedback

Overload List

Name | Description
ZoomIn(Boolean) | Performs zoom in. (Inherited from ViewModel.)
ZoomIn(Point, Boolean) | Performs zoom in. (Inherited from ViewModel.)

See Also

DocumentViewModel Class
DocumentViewModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomOut Method

[image] [image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.ZoomOut Method
DocumentViewModel Class See Also Send Feedback

Overload List

Name | Description
ZoomOut(Boolean) | Performs zoom out. (Inherited from ViewModel.)
ZoomOut(Point, Boolean) | Performs zoom out. (Inherited from ViewModel.)

See Also

DocumentViewModel Class
DocumentViewModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomWindow Method

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.ZoomWindow Method
DocumentViewModel Class See Also Send Feedback
Overridden. See ZoomWindow(Rect, Boolean).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void ZoomWindow(
    Rect rect,
    bool useAnimation
)
Visual Basic (Declaration)
Public Overrides Sub ZoomWindow ( _
    rect As Rect, _
    useAnimation As Boolean _
)
Visual C++
public:
virtual void ZoomWindow(
    Rect rect,
    bool useAnimation
) override

Parameters

rect
Type: System.Windows..::.Rect
useAnimation
Type: System..::.Boolean

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentViewModel Properties

[image] [image]

.NET ModelKit Suite ClassReference
DocumentViewModel Properties
DocumentViewModel Class See Also Send Feedback

The DocumentViewModel type exposes the following members.

Properties

Name | Description
CanGoToNextPage | Overridden. See CanGoToNextPage. (Overrides ViewModel..::.CanGoToNextPage.)
CanGoToPrevPage | Overridden. See CanGoToPrevPage. (Overrides ViewModel..::.CanGoToPrevPage.)
ClientSize | Gets the client area size. (Inherited from ViewModel.)
Document | Gets Document which is a report.
HScrollBarActive | Overridden. See HScrollBarActive. (Overrides ViewModel..::.HScrollBarActive.)
HScrollBarLarge | Overridden. See HScrollBarLarge. (Overrides ViewModel..::.HScrollBarLarge.)
HScrollBarMaximum | Overridden. See HScrollBarMaximum. (Overrides ViewModel..::.HScrollBarMaximum.)
HScrollBarPosition | Overridden. See HScrollBarPosition. (Overrides ViewModel..::.HScrollBarPosition.)
HScrollBarSmall | Overridden. See HScrollBarSmall. (Overrides ViewModel..::.HScrollBarSmall.)
HScrollBarViewPort | Overridden. See HScrollBarViewPort. (Overrides ViewModel..::.HScrollBarViewPort.)
PageNumber | Gets or sets page number. (Inherited from ViewModel.)
ScaledPageArea | Gets page view area.
View | Gets IView which is report preview control. (Inherited from ViewModel.)
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from ViewModel.)
VScrollBarActive | Overridden. See VScrollBarActive. (Overrides ViewModel..::.VScrollBarActive.)
VScrollBarLarge | Overridden. See VScrollBarLarge. (Overrides ViewModel..::.VScrollBarLarge.)
VScrollBarMaximum | Overridden. See VScrollBarMaximum. (Overrides ViewModel..::.VScrollBarMaximum.)
VScrollBarPosition | Overridden. See VScrollBarPosition. (Overrides ViewModel..::.VScrollBarPosition.)
VScrollBarSmall | Overridden. See VScrollBarSmall. (Overrides ViewModel..::.VScrollBarSmall.)
VScrollBarViewPort | Overridden. See VScrollBarViewPort. (Overrides ViewModel..::.VScrollBarViewPort.)
Zoom | Overridden. See Zoom. (Overrides ViewModel..::.Zoom.)

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CanGoToNextPage Property

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.CanGoToNextPage Property
DocumentViewModel Class See Also Send Feedback
Overridden. See CanGoToNextPage.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override bool CanGoToNextPage { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGoToNextPage As Boolean
Visual C++
public:
virtual property bool CanGoToNextPage {
    bool get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CanGoToPrevPage Property

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.CanGoToPrevPage Property
DocumentViewModel Class See Also Send Feedback
Overridden. See CanGoToPrevPage.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override bool CanGoToPrevPage { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanGoToPrevPage As Boolean
Visual C++
public:
virtual property bool CanGoToPrevPage {
    bool get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Document Property

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.Document Property
DocumentViewModel Class See Also Send Feedback
Gets Document which is a report.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected Document Document { get; }
Visual Basic (Declaration)
Protected ReadOnly Property Document As Document
Visual C++
protected:
property Document^ Document {
    Document^ get ();
}

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


HScrollBarActive Property

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.HScrollBarActive Property
DocumentViewModel Class See Also Send Feedback
Overridden. See HScrollBarActive.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override bool HScrollBarActive { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property HScrollBarActive As Boolean
Visual C++
public:
virtual property bool HScrollBarActive {
    bool get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


HScrollBarLarge Property

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.HScrollBarLarge Property
DocumentViewModel Class See Also Send Feedback
Overridden. See HScrollBarLarge.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override double HScrollBarLarge { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property HScrollBarLarge As Double
Visual C++
public:
virtual property double HScrollBarLarge {
    double get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


HScrollBarMaximum Property

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.HScrollBarMaximum Property
DocumentViewModel Class See Also Send Feedback
Overridden. See HScrollBarMaximum.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override double HScrollBarMaximum { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property HScrollBarMaximum As Double
Visual C++
public:
virtual property double HScrollBarMaximum {
    double get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


HScrollBarPosition Property

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.HScrollBarPosition Property
DocumentViewModel Class See Also Send Feedback
Overridden. See HScrollBarPosition.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override double HScrollBarPosition { get; set; }
Visual Basic (Declaration)
Public Overrides Property HScrollBarPosition As Double
Visual C++
public:
virtual property double HScrollBarPosition {
    double get () override;
    void set (double value) override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


HScrollBarSmall Property

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.HScrollBarSmall Property
DocumentViewModel Class See Also Send Feedback
Overridden. See HScrollBarSmall.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override double HScrollBarSmall { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property HScrollBarSmall As Double
Visual C++
public:
virtual property double HScrollBarSmall {
    double get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


HScrollBarViewPort Property

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.HScrollBarViewPort Property
DocumentViewModel Class See Also Send Feedback
Overridden. See HScrollBarViewPort.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override double HScrollBarViewPort { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property HScrollBarViewPort As Double
Visual C++
public:
virtual property double HScrollBarViewPort {
    double get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ScaledPageArea Property

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.ScaledPageArea Property
DocumentViewModel Class See Also Send Feedback
Gets page view area.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected abstract Size ScaledPageArea { get; }
Visual Basic (Declaration)
Protected MustOverride ReadOnly Property ScaledPageArea As Size
Visual C++
protected:
virtual property Size ScaledPageArea {
    Size get () abstract;
}

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


VScrollBarActive Property

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.VScrollBarActive Property
DocumentViewModel Class See Also Send Feedback
Overridden. See VScrollBarActive.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override bool VScrollBarActive { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property VScrollBarActive As Boolean
Visual C++
public:
virtual property bool VScrollBarActive {
    bool get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


VScrollBarLarge Property

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.VScrollBarLarge Property
DocumentViewModel Class See Also Send Feedback
Overridden. See VScrollBarLarge.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override double VScrollBarLarge { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property VScrollBarLarge As Double
Visual C++
public:
virtual property double VScrollBarLarge {
    double get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


VScrollBarMaximum Property

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.VScrollBarMaximum Property
DocumentViewModel Class See Also Send Feedback
Overridden. See VScrollBarMaximum.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override double VScrollBarMaximum { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property VScrollBarMaximum As Double
Visual C++
public:
virtual property double VScrollBarMaximum {
    double get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


VScrollBarPosition Property

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.VScrollBarPosition Property
DocumentViewModel Class See Also Send Feedback
Overridden. See VScrollBarPosition.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override double VScrollBarPosition { get; set; }
Visual Basic (Declaration)
Public Overrides Property VScrollBarPosition As Double
Visual C++
public:
virtual property double VScrollBarPosition {
    double get () override;
    void set (double value) override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


VScrollBarSmall Property

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.VScrollBarSmall Property
DocumentViewModel Class See Also Send Feedback
Overridden. See VScrollBarSmall.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override double VScrollBarSmall { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property VScrollBarSmall As Double
Visual C++
public:
virtual property double VScrollBarSmall {
    double get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


VScrollBarViewPort Property

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.VScrollBarViewPort Property
DocumentViewModel Class See Also Send Feedback
Overridden. See VScrollBarViewPort.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override double VScrollBarViewPort { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property VScrollBarViewPort As Double
Visual C++
public:
virtual property double VScrollBarViewPort {
    double get () override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Zoom Property

[image]

.NET ModelKit Suite ClassReference
DocumentViewModel..::.Zoom Property
DocumentViewModel Class See Also Send Feedback
Overridden. See Zoom.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override Zoom Zoom { get; set; }
Visual Basic (Declaration)
Public Overrides Property Zoom As Zoom
Visual C++
public:
virtual property Zoom Zoom {
    Zoom get () override;
    void set (Zoom value) override;
}

See Also

DocumentViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DynamicZoomTool Class

[image]

.NET ModelKit Suite ClassReference
DynamicZoomTool Class
Members See Also Send Feedback
The class which realizes tool for view scaling with mouse move at pressed mouse left button.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class DynamicZoomTool : StandardTool
Visual Basic (Declaration)
Public Class DynamicZoomTool _
    Inherits StandardTool
Visual C++
public ref class DynamicZoomTool : public StandardTool

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client..::.Tool
PerpetuumSoft.Reporting.Silverlight.Client..::.StandardTool
PerpetuumSoft.Reporting.Silverlight.Client..::.DynamicZoomTool

See Also

DynamicZoomTool Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DynamicZoomTool Members

[image] [image]

.NET ModelKit Suite ClassReference
DynamicZoomTool Members
DynamicZoomTool Class Constructors Methods Properties See Also Send Feedback

The DynamicZoomTool type exposes the following members.

Constructors

Name | Description
DynamicZoomTool | Initializes a new instance of the DynamicZoomTool class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Overrides StandardTool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides StandardTool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides StandardTool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Overridden. See UpdateCursor()()(). (Overrides Tool..::.UpdateCursor()()().)

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

DynamicZoomTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DynamicZoomTool Constructor

[image]

.NET ModelKit Suite ClassReference
DynamicZoomTool Constructor
DynamicZoomTool Class See Also Send Feedback
Initializes a new instance of the DynamicZoomTool class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public DynamicZoomTool(
    ViewManager manager
)
Visual Basic (Declaration)
Public Sub New ( _
    manager As ViewManager _
)
Visual C++
public:
DynamicZoomTool(
    ViewManager^ manager
)

Parameters

manager
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ViewManager

See Also

DynamicZoomTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DynamicZoomTool Methods

[image] [image]

.NET ModelKit Suite ClassReference
DynamicZoomTool Methods
DynamicZoomTool Class See Also Send Feedback

The DynamicZoomTool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Overrides StandardTool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides StandardTool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides StandardTool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Overridden. See UpdateCursor()()(). (Overrides Tool..::.UpdateCursor()()().)

See Also

DynamicZoomTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseDown Method

[image]

.NET ModelKit Suite ClassReference
DynamicZoomTool..::.MouseDown Method
DynamicZoomTool Class See Also Send Feedback
Overridden. See MouseDown(MouseEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseDown(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseDown ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseDown(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

DynamicZoomTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseMove Method

[image]

.NET ModelKit Suite ClassReference
DynamicZoomTool..::.MouseMove Method
DynamicZoomTool Class See Also Send Feedback
Overridden. See MouseMove(MouseEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseMove(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseMove ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseMove(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

DynamicZoomTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseUp Method

[image]

.NET ModelKit Suite ClassReference
DynamicZoomTool..::.MouseUp Method
DynamicZoomTool Class See Also Send Feedback
Overridden. See MouseUp(MouseEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseUp(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseUp ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseUp(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

DynamicZoomTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


UpdateCursor Method

[image]

.NET ModelKit Suite ClassReference
DynamicZoomTool..::.UpdateCursor Method
DynamicZoomTool Class See Also Send Feedback
Overridden. See UpdateCursor()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void UpdateCursor()
Visual Basic (Declaration)
Public Overrides Sub UpdateCursor
Visual C++
public:
virtual void UpdateCursor() override

See Also

DynamicZoomTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DynamicZoomTool Properties

[image] [image]

.NET ModelKit Suite ClassReference
DynamicZoomTool Properties
DynamicZoomTool Class See Also Send Feedback

The DynamicZoomTool type exposes the following members.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

DynamicZoomTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ErrorMessagePresenter Class

[image]

.NET ModelKit Suite ClassReference
ErrorMessagePresenter Class
Members See Also Send Feedback
A class for presentation of report view content when error occurs during report getting.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ErrorMessagePresenter : Control
Visual Basic (Declaration)
Public Class ErrorMessagePresenter _
    Inherits Control
Visual C++
public ref class ErrorMessagePresenter : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.Reporting.Silverlight.Client..::.ErrorMessagePresenter

See Also

ErrorMessagePresenter Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ErrorMessagePresenter Members

[image] [image]

.NET ModelKit Suite ClassReference
ErrorMessagePresenter Members
ErrorMessagePresenter Class Constructors Methods Fields Properties Events See Also Send Feedback

The ErrorMessagePresenter type exposes the following members.

Constructors

Name | Description
ErrorMessagePresenter | Initializes a new instance of the ErrorMessagePresenter class.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
CaptionProperty | Gets or sets error title. Dependency property.
TextProperty | Gets or sets error description. Dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Caption | Gets or sets error title.
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets or sets error description.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ErrorMessagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ErrorMessagePresenter Constructor

[image]

.NET ModelKit Suite ClassReference
ErrorMessagePresenter Constructor
ErrorMessagePresenter Class See Also Send Feedback
Initializes a new instance of the ErrorMessagePresenter class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ErrorMessagePresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ErrorMessagePresenter()

See Also

ErrorMessagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ErrorMessagePresenter Fields

[image] [image]

.NET ModelKit Suite ClassReference
ErrorMessagePresenter Fields
ErrorMessagePresenter Class See Also Send Feedback

The ErrorMessagePresenter type exposes the following members.

Fields

Name | Description
CaptionProperty | Gets or sets error title. Dependency property.
TextProperty | Gets or sets error description. Dependency property.

See Also

ErrorMessagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CaptionProperty Field

[image]

.NET ModelKit Suite ClassReference
ErrorMessagePresenter..::.CaptionProperty Field
ErrorMessagePresenter Class See Also Send Feedback
Gets or sets error title. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty CaptionProperty
Visual Basic (Declaration)
Public Shared ReadOnly CaptionProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CaptionProperty

See Also

ErrorMessagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


TextProperty Field

[image]

.NET ModelKit Suite ClassReference
ErrorMessagePresenter..::.TextProperty Field
ErrorMessagePresenter Class See Also Send Feedback
Gets or sets error description. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty TextProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TextProperty

See Also

ErrorMessagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ErrorMessagePresenter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ErrorMessagePresenter Methods
ErrorMessagePresenter Class See Also Send Feedback

The ErrorMessagePresenter type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ErrorMessagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ErrorMessagePresenter Properties

[image] [image]

.NET ModelKit Suite ClassReference
ErrorMessagePresenter Properties
ErrorMessagePresenter Class See Also Send Feedback

The ErrorMessagePresenter type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Caption | Gets or sets error title.
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets or sets error description.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ErrorMessagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Caption Property

[image]

.NET ModelKit Suite ClassReference
ErrorMessagePresenter..::.Caption Property
ErrorMessagePresenter Class See Also Send Feedback
Gets or sets error title.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string Caption { get; set; }
Visual Basic (Declaration)
Public Property Caption As String
Visual C++
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}

See Also

ErrorMessagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Text Property

[image]

.NET ModelKit Suite ClassReference
ErrorMessagePresenter..::.Text Property
ErrorMessagePresenter Class See Also Send Feedback
Gets or sets error description.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

ErrorMessagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ErrorMessagePresenter Events

[image] [image]

.NET ModelKit Suite ClassReference
ErrorMessagePresenter Events
ErrorMessagePresenter Class See Also Send Feedback

The ErrorMessagePresenter type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ErrorMessagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ExportFormat Enumeration

[image]

.NET ModelKit Suite ClassReference
ExportFormat Enumeration
See Also Send Feedback
Enumeration of export formats.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public enum ExportFormat
Visual Basic (Declaration)
Public Enumeration ExportFormat
Visual C++
public enum class ExportFormat

Members

Member name | Description
Pdf | Execution of export to the PDF format.
Xps | Execution of export to the XPS format.
Excel | Execution of export to the Excel format.
Html | Execution of export to the Html format.
Rtf | Execution of export to the RTF format.

See Also

PerpetuumSoft.Reporting.Silverlight.Client Namespace


IView Interface

[image]

.NET ModelKit Suite ClassReference
IView Interface
Members See Also Send Feedback
Report Viewer control interface.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public interface IView
Visual Basic (Declaration)
Public Interface IView
Visual C++
public interface class IView

See Also

IView Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


IView Members

[image] [image]

.NET ModelKit Suite ClassReference
IView Members
IView Interface Methods Properties See Also Send Feedback

The IView type exposes the following members.

Methods

Name | Description
UpdateView | Updates view of the displayed report.

Properties

Name | Description
AdornersLayer | Gets the layer for borders which highlight the selected report element.
ClientSize | Gets report display area size.
ContentLayer | Gets report content layer.
ViewManager | Gets ViewManager which is Report Viewer manager.

See Also

IView Interface
PerpetuumSoft.Reporting.Silverlight.Client Namespace


IView Methods

[image] [image]

.NET ModelKit Suite ClassReference
IView Methods
IView Interface See Also Send Feedback

The IView type exposes the following members.

Methods

Name | Description
UpdateView | Updates view of the displayed report.

See Also

IView Interface
PerpetuumSoft.Reporting.Silverlight.Client Namespace


UpdateView Method

[image]

.NET ModelKit Suite ClassReference
IView..::.UpdateView Method
IView Interface See Also Send Feedback
Updates view of the displayed report.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
void UpdateView()
Visual Basic (Declaration)
Sub UpdateView
Visual C++
void UpdateView()

See Also

IView Interface
PerpetuumSoft.Reporting.Silverlight.Client Namespace


IView Properties

[image] [image]

.NET ModelKit Suite ClassReference
IView Properties
IView Interface See Also Send Feedback

The IView type exposes the following members.

Properties

Name | Description
AdornersLayer | Gets the layer for borders which highlight the selected report element.
ClientSize | Gets report display area size.
ContentLayer | Gets report content layer.
ViewManager | Gets ViewManager which is Report Viewer manager.

See Also

IView Interface
PerpetuumSoft.Reporting.Silverlight.Client Namespace


AdornersLayer Property

[image]

.NET ModelKit Suite ClassReference
IView..::.AdornersLayer Property
IView Interface See Also Send Feedback
Gets the layer for borders which highlight the selected report element.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
Canvas AdornersLayer { get; }
Visual Basic (Declaration)
ReadOnly Property AdornersLayer As Canvas
Visual C++
property Canvas^ AdornersLayer {
    Canvas^ get ();
}

See Also

IView Interface
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ClientSize Property

[image]

.NET ModelKit Suite ClassReference
IView..::.ClientSize Property
IView Interface See Also Send Feedback
Gets report display area size.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
Size ClientSize { get; }
Visual Basic (Declaration)
ReadOnly Property ClientSize As Size
Visual C++
property Size ClientSize {
    Size get ();
}

See Also

IView Interface
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ContentLayer Property

[image]

.NET ModelKit Suite ClassReference
IView..::.ContentLayer Property
IView Interface See Also Send Feedback
Gets report content layer.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
Canvas ContentLayer { get; }
Visual Basic (Declaration)
ReadOnly Property ContentLayer As Canvas
Visual C++
property Canvas^ ContentLayer {
    Canvas^ get ();
}

See Also

IView Interface
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewManager Property

[image]

.NET ModelKit Suite ClassReference
IView..::.ViewManager Property
IView Interface See Also Send Feedback
Gets ViewManager which is Report Viewer manager.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
ViewManager ViewManager { get; }
Visual Basic (Declaration)
ReadOnly Property ViewManager As ViewManager
Visual C++
property ViewManager^ ViewManager {
    ViewManager^ get ();
}

See Also

IView Interface
PerpetuumSoft.Reporting.Silverlight.Client Namespace


LoadingPagePresenter Class

[image]

.NET ModelKit Suite ClassReference
LoadingPagePresenter Class
Members See Also Send Feedback
Loading presenter.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class LoadingPagePresenter : Control
Visual Basic (Declaration)
Public Class LoadingPagePresenter _
    Inherits Control
Visual C++
public ref class LoadingPagePresenter : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.Reporting.Silverlight.Client..::.LoadingPagePresenter

See Also

LoadingPagePresenter Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


LoadingPagePresenter Members

[image] [image]

.NET ModelKit Suite ClassReference
LoadingPagePresenter Members
LoadingPagePresenter Class Constructors Methods Fields Properties Events See Also Send Feedback

The LoadingPagePresenter type exposes the following members.

Constructors

Name | Description
LoadingPagePresenter | Initializes a new instance of the LoadingPagePresenter class.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
LoadingTextProperty | Gets or sets the text which is displayed during loading. Dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LoadingText | Gets or sets the text which is displayed during the loading.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

LoadingPagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


LoadingPagePresenter Constructor

[image]

.NET ModelKit Suite ClassReference
LoadingPagePresenter Constructor
LoadingPagePresenter Class See Also Send Feedback
Initializes a new instance of the LoadingPagePresenter class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public LoadingPagePresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoadingPagePresenter()

See Also

LoadingPagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


LoadingPagePresenter Fields

[image] [image]

.NET ModelKit Suite ClassReference
LoadingPagePresenter Fields
LoadingPagePresenter Class See Also Send Feedback

The LoadingPagePresenter type exposes the following members.

Fields

Name | Description
LoadingTextProperty | Gets or sets the text which is displayed during loading. Dependency property.

See Also

LoadingPagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


LoadingTextProperty Field

[image]

.NET ModelKit Suite ClassReference
LoadingPagePresenter..::.LoadingTextProperty Field
LoadingPagePresenter Class See Also Send Feedback
Gets or sets the text which is displayed during loading. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public readonly DependencyProperty LoadingTextProperty
Visual Basic (Declaration)
Public ReadOnly LoadingTextProperty As DependencyProperty
Visual C++
public:
initonly DependencyProperty^ LoadingTextProperty

See Also

LoadingPagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


LoadingPagePresenter Methods

[image] [image]

.NET ModelKit Suite ClassReference
LoadingPagePresenter Methods
LoadingPagePresenter Class See Also Send Feedback

The LoadingPagePresenter type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

LoadingPagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


LoadingPagePresenter Properties

[image] [image]

.NET ModelKit Suite ClassReference
LoadingPagePresenter Properties
LoadingPagePresenter Class See Also Send Feedback

The LoadingPagePresenter type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LoadingText | Gets or sets the text which is displayed during the loading.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

LoadingPagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


LoadingText Property

[image]

.NET ModelKit Suite ClassReference
LoadingPagePresenter..::.LoadingText Property
LoadingPagePresenter Class See Also Send Feedback
Gets or sets the text which is displayed during the loading.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string LoadingText { get; set; }
Visual Basic (Declaration)
Public Property LoadingText As String
Visual C++
public:
property String^ LoadingText {
    String^ get ();
    void set (String^ value);
}

See Also

LoadingPagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


LoadingPagePresenter Events

[image] [image]

.NET ModelKit Suite ClassReference
LoadingPagePresenter Events
LoadingPagePresenter Class See Also Send Feedback

The LoadingPagePresenter type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

LoadingPagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseWheelEventArgs Class

[image]

.NET ModelKit Suite ClassReference
MouseWheelEventArgs Class
Members See Also Send Feedback
Provides data for various events that report changes to the mouse wheel delta value of a mouse device.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class MouseWheelEventArgs : EventArgs
Visual Basic (Declaration)
Public Class MouseWheelEventArgs _
    Inherits EventArgs
Visual C++
public ref class MouseWheelEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.Silverlight.Client..::.MouseWheelEventArgs

See Also

MouseWheelEventArgs Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseWheelEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
MouseWheelEventArgs Members
MouseWheelEventArgs Class Constructors Methods Properties See Also Send Feedback

The MouseWheelEventArgs type exposes the following members.

Constructors

Name | Description
MouseWheelEventArgs | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Delta | Gets or sets a value that indicates the amount that the mouse wheel has changed.
Handled | Gets or sets a value that indicates the present state of the event handling.
Location | Gets or sets mouse pointer location.

See Also

MouseWheelEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseWheelEventArgs Constructor

[image] [image]

.NET ModelKit Suite ClassReference
MouseWheelEventArgs Constructor
MouseWheelEventArgs Class See Also Send Feedback

Overload List

Name | Description
MouseWheelEventArgs(Double) | Initializes a new instance of the MouseWheelEventArgs class.
MouseWheelEventArgs(Double, Point) | Initializes a new instance of the MouseWheelEventArgs class.

See Also

MouseWheelEventArgs Class
MouseWheelEventArgs Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseWheelEventArgs Constructor (Double)

[image]

.NET ModelKit Suite ClassReference
MouseWheelEventArgs Constructor (Double)
MouseWheelEventArgs Class See Also Send Feedback
Initializes a new instance of the MouseWheelEventArgs class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public MouseWheelEventArgs(
    double delta
)
Visual Basic (Declaration)
Public Sub New ( _
    delta As Double _
)
Visual C++
public:
MouseWheelEventArgs(
    double delta
)

Parameters

delta
Type: System..::.Double

See Also

MouseWheelEventArgs Class
MouseWheelEventArgs Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseWheelEventArgs Constructor (Double, Point)

[image]

.NET ModelKit Suite ClassReference
MouseWheelEventArgs Constructor (Double, Point)
MouseWheelEventArgs Class See Also Send Feedback
Initializes a new instance of the MouseWheelEventArgs class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public MouseWheelEventArgs(
    double delta,
    Point location
)
Visual Basic (Declaration)
Public Sub New ( _
    delta As Double, _
    location As Point _
)
Visual C++
public:
MouseWheelEventArgs(
    double delta,
    Point location
)

Parameters

delta
Type: System..::.Double
location
Type: System.Windows..::.Point

See Also

MouseWheelEventArgs Class
MouseWheelEventArgs Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseWheelEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
MouseWheelEventArgs Methods
MouseWheelEventArgs Class See Also Send Feedback

The MouseWheelEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MouseWheelEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseWheelEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
MouseWheelEventArgs Properties
MouseWheelEventArgs Class See Also Send Feedback

The MouseWheelEventArgs type exposes the following members.

Properties

Name | Description
Delta | Gets or sets a value that indicates the amount that the mouse wheel has changed.
Handled | Gets or sets a value that indicates the present state of the event handling.
Location | Gets or sets mouse pointer location.

See Also

MouseWheelEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Delta Property

[image]

.NET ModelKit Suite ClassReference
MouseWheelEventArgs..::.Delta Property
MouseWheelEventArgs Class See Also Send Feedback
Gets or sets a value that indicates the amount that the mouse wheel has changed.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public double Delta { get; private set; }
Visual Basic (Declaration)
Public Property Delta As Double
Visual C++
public:
property double Delta {
    double get ();
    void set (double value);
}

See Also

MouseWheelEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Handled Property

[image]

.NET ModelKit Suite ClassReference
MouseWheelEventArgs..::.Handled Property
MouseWheelEventArgs Class See Also Send Feedback
Gets or sets a value that indicates the present state of the event handling.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool Handled { get; set; }
Visual Basic (Declaration)
Public Property Handled As Boolean
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

See Also

MouseWheelEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Location Property

[image]

.NET ModelKit Suite ClassReference
MouseWheelEventArgs..::.Location Property
MouseWheelEventArgs Class See Also Send Feedback
Gets or sets mouse pointer location.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Point Location { get; private set; }
Visual Basic (Declaration)
Public Property Location As Point
Visual C++
public:
property Point Location {
    Point get ();
    void set (Point value);
}

See Also

MouseWheelEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseWheelManager Class

[image]

.NET ModelKit Suite ClassReference
MouseWheelManager Class
Members See Also Send Feedback
Manager for working with mouse scroll-wheel.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class MouseWheelManager
Visual Basic (Declaration)
Public Class MouseWheelManager
Visual C++
public ref class MouseWheelManager

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client..::.MouseWheelManager

See Also

MouseWheelManager Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseWheelManager Members

[image] [image]

.NET ModelKit Suite ClassReference
MouseWheelManager Members
MouseWheelManager Class Constructors Methods Properties See Also Send Feedback

The MouseWheelManager type exposes the following members.

Constructors

Name | Description
MouseWheelManager | Initializes a new instance of the MouseWheelManager class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
RootVisual | Gets or sets the element to which mouse scroll-wheel manager is bound.

See Also

MouseWheelManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseWheelManager Constructor

[image]

.NET ModelKit Suite ClassReference
MouseWheelManager Constructor
MouseWheelManager Class See Also Send Feedback
Initializes a new instance of the MouseWheelManager class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public MouseWheelManager(
    UIElement rootVisual
)
Visual Basic (Declaration)
Public Sub New ( _
    rootVisual As UIElement _
)
Visual C++
public:
MouseWheelManager(
    UIElement^ rootVisual
)

Parameters

rootVisual
Type: System.Windows..::.UIElement

See Also

MouseWheelManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseWheelManager Methods

[image] [image]

.NET ModelKit Suite ClassReference
MouseWheelManager Methods
MouseWheelManager Class See Also Send Feedback

The MouseWheelManager type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MouseWheelManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseWheelManager Properties

[image] [image]

.NET ModelKit Suite ClassReference
MouseWheelManager Properties
MouseWheelManager Class See Also Send Feedback

The MouseWheelManager type exposes the following members.

Properties

Name | Description
RootVisual | Gets or sets the element to which mouse scroll-wheel manager is bound.

See Also

MouseWheelManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


RootVisual Property

[image]

.NET ModelKit Suite ClassReference
MouseWheelManager..::.RootVisual Property
MouseWheelManager Class See Also Send Feedback
Gets or sets the element to which mouse scroll-wheel manager is bound.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public UIElement RootVisual { get; set; }
Visual Basic (Declaration)
Public Property RootVisual As UIElement
Visual C++
public:
property UIElement^ RootVisual {
    UIElement^ get ();
    void set (UIElement^ value);
}

See Also

MouseWheelManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


NoReportPresenter Class

[image]

.NET ModelKit Suite ClassReference
NoReportPresenter Class
Members See Also Send Feedback
A class for presentation of report view content when report is missing.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class NoReportPresenter : Control
Visual Basic (Declaration)
Public Class NoReportPresenter _
    Inherits Control
Visual C++
public ref class NoReportPresenter : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.Reporting.Silverlight.Client..::.NoReportPresenter

See Also

NoReportPresenter Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


NoReportPresenter Members

[image] [image]

.NET ModelKit Suite ClassReference
NoReportPresenter Members
NoReportPresenter Class Constructors Methods Properties Events See Also Send Feedback

The NoReportPresenter type exposes the following members.

Constructors

Name | Description
NoReportPresenter | Initializes a new instance of the NoReportPresenter class.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

NoReportPresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


NoReportPresenter Constructor

[image]

.NET ModelKit Suite ClassReference
NoReportPresenter Constructor
NoReportPresenter Class See Also Send Feedback
Initializes a new instance of the NoReportPresenter class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public NoReportPresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NoReportPresenter()

See Also

NoReportPresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


NoReportPresenter Methods

[image] [image]

.NET ModelKit Suite ClassReference
NoReportPresenter Methods
NoReportPresenter Class See Also Send Feedback

The NoReportPresenter type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

NoReportPresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


NoReportPresenter Properties

[image] [image]

.NET ModelKit Suite ClassReference
NoReportPresenter Properties
NoReportPresenter Class See Also Send Feedback

The NoReportPresenter type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

NoReportPresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


NoReportPresenter Events

[image] [image]

.NET ModelKit Suite ClassReference
NoReportPresenter Events
NoReportPresenter Class See Also Send Feedback

The NoReportPresenter type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

NoReportPresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Page Class

[image]

.NET ModelKit Suite ClassReference
Page Class
Members See Also Send Feedback
A class for report page representation.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public sealed class Page
Visual Basic (Declaration)
Public NotInheritable Class Page
Visual C++
public ref class Page sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client..::.Page

See Also

Page Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Page Members

[image] [image]

.NET ModelKit Suite ClassReference
Page Members
Page Class Methods Properties Events See Also Send Feedback

The Page type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Document | Gets or sets Document which is the report to which the page belongs.
Height | Gets or sets page height.
IsLoaded | Gets the property which indicates that the page is loaded.
IsLoading | Gets or sets the property which indicates that the page is loading.
PageNumber | Gets or sets page number.
Size | Gets page size.
Width | Gets or sets page width.
XamlContent | Gets or sets page content in Xaml representation.

Events

Name | Description
Loaded | Occurs when the page is loaded.

See Also

Page Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Page Methods

[image] [image]

.NET ModelKit Suite ClassReference
Page Methods
Page Class See Also Send Feedback

The Page type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Page Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Page Properties

[image] [image]

.NET ModelKit Suite ClassReference
Page Properties
Page Class See Also Send Feedback

The Page type exposes the following members.

Properties

Name | Description
Document | Gets or sets Document which is the report to which the page belongs.
Height | Gets or sets page height.
IsLoaded | Gets the property which indicates that the page is loaded.
IsLoading | Gets or sets the property which indicates that the page is loading.
PageNumber | Gets or sets page number.
Size | Gets page size.
Width | Gets or sets page width.
XamlContent | Gets or sets page content in Xaml representation.

See Also

Page Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Document Property

[image]

.NET ModelKit Suite ClassReference
Page..::.Document Property
Page Class See Also Send Feedback
Gets or sets Document which is the report to which the page belongs.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Document Document { get; private set; }
Visual Basic (Declaration)
Public Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
    void set (Document^ value);
}

See Also

Page Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Height Property

[image]

.NET ModelKit Suite ClassReference
Page..::.Height Property
Page Class See Also Send Feedback
Gets or sets page height.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public double Height { get; private set; }
Visual Basic (Declaration)
Public Property Height As Double
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

See Also

Page Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


IsLoaded Property

[image]

.NET ModelKit Suite ClassReference
Page..::.IsLoaded Property
Page Class See Also Send Feedback
Gets the property which indicates that the page is loaded.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool IsLoaded { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsLoaded As Boolean
Visual C++
public:
property bool IsLoaded {
    bool get ();
}

See Also

Page Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


IsLoading Property

[image]

.NET ModelKit Suite ClassReference
Page..::.IsLoading Property
Page Class See Also Send Feedback
Gets or sets the property which indicates that the page is loading.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool IsLoading { get; internal set; }
Visual Basic (Declaration)
Public Property IsLoading As Boolean
Visual C++
public:
property bool IsLoading {
    bool get ();
    void set (bool value);
}

See Also

Page Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageNumber Property

[image]

.NET ModelKit Suite ClassReference
Page..::.PageNumber Property
Page Class See Also Send Feedback
Gets or sets page number.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public int PageNumber { get; private set; }
Visual Basic (Declaration)
Public Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
    void set (int value);
}

See Also

Page Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Size Property

[image]

.NET ModelKit Suite ClassReference
Page..::.Size Property
Page Class See Also Send Feedback
Gets page size.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Size Size { get; }
Visual Basic (Declaration)
Public ReadOnly Property Size As Size
Visual C++
public:
property Size Size {
    Size get ();
}

See Also

Page Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
Page..::.Width Property
Page Class See Also Send Feedback
Gets or sets page width.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public double Width { get; private set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

Page Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


XamlContent Property

[image]

.NET ModelKit Suite ClassReference
Page..::.XamlContent Property
Page Class See Also Send Feedback
Gets or sets page content in Xaml representation.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string XamlContent { get; internal set; }
Visual Basic (Declaration)
Public Property XamlContent As String
Visual C++
public:
property String^ XamlContent {
    String^ get ();
    void set (String^ value);
}

See Also

Page Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Page Events

[image] [image]

.NET ModelKit Suite ClassReference
Page Events
Page Class See Also Send Feedback

The Page type exposes the following members.

Events

Name | Description
Loaded | Occurs when the page is loaded.

See Also

Page Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Loaded Event

[image]

.NET ModelKit Suite ClassReference
Page..::.Loaded Event
Page Class See Also Send Feedback
Occurs when the page is loaded.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler Loaded
Visual Basic (Declaration)
Public Event Loaded As EventHandler
Visual C++
public:
 event EventHandler^ Loaded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

Page Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageLoadedEventArgs Class

[image]

.NET ModelKit Suite ClassReference
PageLoadedEventArgs Class
Members See Also Send Feedback
Report page loading event parameters.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class PageLoadedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class PageLoadedEventArgs _
    Inherits EventArgs
Visual C++
public ref class PageLoadedEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.Silverlight.Client..::.PageLoadedEventArgs

See Also

PageLoadedEventArgs Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageLoadedEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
PageLoadedEventArgs Members
PageLoadedEventArgs Class Constructors Methods Properties See Also Send Feedback

The PageLoadedEventArgs type exposes the following members.

Constructors

Name | Description
PageLoadedEventArgs | Initializes a new instance of the PageLoadedEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Document | Gets or sets Documentwhich is a loaded report.
PageNumber | Gets or sets page number.

See Also

PageLoadedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageLoadedEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
PageLoadedEventArgs Constructor
PageLoadedEventArgs Class See Also Send Feedback
Initializes a new instance of the PageLoadedEventArgs class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public PageLoadedEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageLoadedEventArgs()

See Also

PageLoadedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageLoadedEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
PageLoadedEventArgs Methods
PageLoadedEventArgs Class See Also Send Feedback

The PageLoadedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageLoadedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageLoadedEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
PageLoadedEventArgs Properties
PageLoadedEventArgs Class See Also Send Feedback

The PageLoadedEventArgs type exposes the following members.

Properties

Name | Description
Document | Gets or sets Documentwhich is a loaded report.
PageNumber | Gets or sets page number.

See Also

PageLoadedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Document Property

[image]

.NET ModelKit Suite ClassReference
PageLoadedEventArgs..::.Document Property
PageLoadedEventArgs Class See Also Send Feedback
Gets or sets Documentwhich is a loaded report.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Document Document { get; set; }
Visual Basic (Declaration)
Public Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
    void set (Document^ value);
}

See Also

PageLoadedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageNumber Property

[image]

.NET ModelKit Suite ClassReference
PageLoadedEventArgs..::.PageNumber Property
PageLoadedEventArgs Class See Also Send Feedback
Gets or sets page number.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public int PageNumber { get; set; }
Visual Basic (Declaration)
Public Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
    void set (int value);
}

See Also

PageLoadedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageModel Enumeration

[image]

.NET ModelKit Suite ClassReference
PageModel Enumeration
See Also Send Feedback
Page view models list.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public enum PageModel
Visual Basic (Declaration)
Public Enumeration PageModel
Visual C++
public enum class PageModel

Members

Member name | Description
Single | Gets the property which indicates that only one page is viewed each time.
Continued | Gets the property which indicates that there viewed as many page as possible.

See Also

PerpetuumSoft.Reporting.Silverlight.Client Namespace


PagePresenter Class

[image]

.NET ModelKit Suite ClassReference
PagePresenter Class
Members See Also Send Feedback
Report pages presenter.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class PagePresenter : Control
Visual Basic (Declaration)
Public Class PagePresenter _
    Inherits Control
Visual C++
public ref class PagePresenter : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.Reporting.Silverlight.Client..::.PagePresenter

See Also

PagePresenter Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PagePresenter Members

[image] [image]

.NET ModelKit Suite ClassReference
PagePresenter Members
PagePresenter Class Constructors Methods Properties Events See Also Send Feedback

The PagePresenter type exposes the following members.

Constructors

Name | Description
PagePresenter | Initializes a new instance of the PagePresenter class.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
HideSearch | Removes the highlight from the selected area.
Init | Performs page presenter initialization.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ShowSearch | Shifts the visible area of the screen to guarantee that the specified report area is visible and highlights it.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
Hightlight | Gets or sets the element for highlighting.
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Page | Gets or sets Page which is a page.
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
ViewManager | Gets or sets ViewManager which is Report Viewer manager.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

PagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PagePresenter Constructor

[image]

.NET ModelKit Suite ClassReference
PagePresenter Constructor
PagePresenter Class See Also Send Feedback
Initializes a new instance of the PagePresenter class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public PagePresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PagePresenter()

See Also

PagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PagePresenter Methods

[image] [image]

.NET ModelKit Suite ClassReference
PagePresenter Methods
PagePresenter Class See Also Send Feedback

The PagePresenter type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
HideSearch | Removes the highlight from the selected area.
Init | Performs page presenter initialization.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ShowSearch | Shifts the visible area of the screen to guarantee that the specified report area is visible and highlights it.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

PagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


HideSearch Method

[image]

.NET ModelKit Suite ClassReference
PagePresenter..::.HideSearch Method
PagePresenter Class See Also Send Feedback
Removes the highlight from the selected area.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void HideSearch()
Visual Basic (Declaration)
Public Sub HideSearch
Visual C++
public:
void HideSearch()

See Also

PagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Init Method

[image]

.NET ModelKit Suite ClassReference
PagePresenter..::.Init Method
PagePresenter Class See Also Send Feedback
Performs page presenter initialization.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void Init(
    Page page,
    Style loadingPageStyle
)
Visual Basic (Declaration)
Public Sub Init ( _
    page As Page, _
    loadingPageStyle As Style _
)
Visual C++
public:
void Init(
    Page^ page,
    Style^ loadingPageStyle
)

Parameters

page
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.Page
loadingPageStyle
Type: System.Windows..::.Style

See Also

PagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


OnApplyTemplate Method

[image]

.NET ModelKit Suite ClassReference
PagePresenter..::.OnApplyTemplate Method
PagePresenter Class See Also Send Feedback
Overridden. See OnApplyTemplate()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

PagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ShowSearch Method

[image]

.NET ModelKit Suite ClassReference
PagePresenter..::.ShowSearch Method
PagePresenter Class See Also Send Feedback
Shifts the visible area of the screen to guarantee that the specified report area is visible and highlights it.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void ShowSearch(
    Rect rect
)
Visual Basic (Declaration)
Public Sub ShowSearch ( _
    rect As Rect _
)
Visual C++
public:
void ShowSearch(
    Rect rect
)

Parameters

rect
Type: System.Windows..::.Rect

See Also

PagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PagePresenter Properties

[image] [image]

.NET ModelKit Suite ClassReference
PagePresenter Properties
PagePresenter Class See Also Send Feedback

The PagePresenter type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
Hightlight | Gets or sets the element for highlighting.
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Page | Gets or sets Page which is a page.
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
ViewManager | Gets or sets ViewManager which is Report Viewer manager.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

PagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Hightlight Property

[image]

.NET ModelKit Suite ClassReference
PagePresenter..::.Hightlight Property
PagePresenter Class See Also Send Feedback
Gets or sets the element for highlighting.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public FrameworkElement Hightlight { get; private set; }
Visual Basic (Declaration)
Public Property Hightlight As FrameworkElement
Visual C++
public:
property FrameworkElement^ Hightlight {
    FrameworkElement^ get ();
    void set (FrameworkElement^ value);
}

See Also

PagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Page Property

[image]

.NET ModelKit Suite ClassReference
PagePresenter..::.Page Property
PagePresenter Class See Also Send Feedback
Gets or sets Page which is a page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Page Page { get; private set; }
Visual Basic (Declaration)
Public Property Page As Page
Visual C++
public:
property Page^ Page {
    Page^ get ();
    void set (Page^ value);
}

See Also

PagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewManager Property

[image]

.NET ModelKit Suite ClassReference
PagePresenter..::.ViewManager Property
PagePresenter Class See Also Send Feedback
Gets or sets ViewManager which is Report Viewer manager.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ViewManager ViewManager { get; internal set; }
Visual Basic (Declaration)
Public Property ViewManager As ViewManager
Visual C++
public:
property ViewManager^ ViewManager {
    ViewManager^ get ();
    void set (ViewManager^ value);
}

See Also

PagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PagePresenter Events

[image] [image]

.NET ModelKit Suite ClassReference
PagePresenter Events
PagePresenter Class See Also Send Feedback

The PagePresenter type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

PagePresenter Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageSelectedEventArgs Class

[image]

.NET ModelKit Suite ClassReference
PageSelectedEventArgs Class
Members See Also Send Feedback
Parameters of the event which occurs when the page is selected.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class PageSelectedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class PageSelectedEventArgs _
    Inherits EventArgs
Visual C++
public ref class PageSelectedEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.Silverlight.Client..::.PageSelectedEventArgs

See Also

PageSelectedEventArgs Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageSelectedEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
PageSelectedEventArgs Members
PageSelectedEventArgs Class Constructors Methods Properties See Also Send Feedback

The PageSelectedEventArgs type exposes the following members.

Constructors

Name | Description
PageSelectedEventArgs | Initializes a new instance of the PageSelectedEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PageNumber | Gets page number.

See Also

PageSelectedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageSelectedEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
PageSelectedEventArgs Constructor
PageSelectedEventArgs Class See Also Send Feedback
Initializes a new instance of the PageSelectedEventArgs class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public PageSelectedEventArgs(
    int pageNumber
)
Visual Basic (Declaration)
Public Sub New ( _
    pageNumber As Integer _
)
Visual C++
public:
PageSelectedEventArgs(
    int pageNumber
)

Parameters

pageNumber
Type: System..::.Int32

See Also

PageSelectedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageSelectedEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
PageSelectedEventArgs Methods
PageSelectedEventArgs Class See Also Send Feedback

The PageSelectedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageSelectedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageSelectedEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
PageSelectedEventArgs Properties
PageSelectedEventArgs Class See Also Send Feedback

The PageSelectedEventArgs type exposes the following members.

Properties

Name | Description
PageNumber | Gets page number.

See Also

PageSelectedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageNumber Property

[image]

.NET ModelKit Suite ClassReference
PageSelectedEventArgs..::.PageNumber Property
PageSelectedEventArgs Class See Also Send Feedback
Gets page number.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public int PageNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
}

See Also

PageSelectedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PanTool Class

[image]

.NET ModelKit Suite ClassReference
PanTool Class
Members See Also Send Feedback
The class which realizes tool for report scrolling with mouse pointer move at pressed right mouse button. Inherited from StandardTool.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class PanTool : StandardTool
Visual Basic (Declaration)
Public Class PanTool _
    Inherits StandardTool
Visual C++
public ref class PanTool : public StandardTool

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client..::.Tool
PerpetuumSoft.Reporting.Silverlight.Client..::.StandardTool
PerpetuumSoft.Reporting.Silverlight.Client..::.PanTool

See Also

PanTool Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PanTool Members

[image] [image]

.NET ModelKit Suite ClassReference
PanTool Members
PanTool Class Constructors Methods Properties See Also Send Feedback

The PanTool type exposes the following members.

Constructors

Name | Description
PanTool | Initializes a new instance of the PanTool class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Overrides StandardTool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides StandardTool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides StandardTool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Overridden. See UpdateCursor()()(). (Overrides Tool..::.UpdateCursor()()().)

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

PanTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PanTool Constructor

[image]

.NET ModelKit Suite ClassReference
PanTool Constructor
PanTool Class See Also Send Feedback
Initializes a new instance of the PanTool class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public PanTool(
    ViewManager manager
)
Visual Basic (Declaration)
Public Sub New ( _
    manager As ViewManager _
)
Visual C++
public:
PanTool(
    ViewManager^ manager
)

Parameters

manager
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ViewManager

See Also

PanTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PanTool Methods

[image] [image]

.NET ModelKit Suite ClassReference
PanTool Methods
PanTool Class See Also Send Feedback

The PanTool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Overrides StandardTool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides StandardTool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides StandardTool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Overridden. See UpdateCursor()()(). (Overrides Tool..::.UpdateCursor()()().)

See Also

PanTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseDown Method

[image]

.NET ModelKit Suite ClassReference
PanTool..::.MouseDown Method
PanTool Class See Also Send Feedback
Overridden. See MouseDown(MouseEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseDown(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseDown ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseDown(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

PanTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseMove Method

[image]

.NET ModelKit Suite ClassReference
PanTool..::.MouseMove Method
PanTool Class See Also Send Feedback
Overridden. See MouseMove(MouseEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseMove(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseMove ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseMove(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

PanTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseUp Method

[image]

.NET ModelKit Suite ClassReference
PanTool..::.MouseUp Method
PanTool Class See Also Send Feedback
Overridden. See MouseUp(MouseEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseUp(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseUp ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseUp(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

PanTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


UpdateCursor Method

[image]

.NET ModelKit Suite ClassReference
PanTool..::.UpdateCursor Method
PanTool Class See Also Send Feedback
Overridden. See UpdateCursor()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void UpdateCursor()
Visual Basic (Declaration)
Public Overrides Sub UpdateCursor
Visual C++
public:
virtual void UpdateCursor() override

See Also

PanTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PanTool Properties

[image] [image]

.NET ModelKit Suite ClassReference
PanTool Properties
PanTool Class See Also Send Feedback

The PanTool type exposes the following members.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

PanTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Progress Class

[image]

.NET ModelKit Suite ClassReference
Progress Class
Members See Also Send Feedback
This class realizes progress bar. Inherited from Control.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class Progress : Control
Visual Basic (Declaration)
Public Class Progress _
    Inherits Control
Visual C++
public ref class Progress : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.Reporting.Silverlight.Client..::.Progress

See Also

Progress Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Progress Members

[image] [image]

.NET ModelKit Suite ClassReference
Progress Members
Progress Class Constructors Methods Fields Properties Events See Also Send Feedback

The Progress type exposes the following members.

Constructors

Name | Description
Progress | Initializes a new instance of the Progress class.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
TextProperty | Gets or sets the text which is displayed in progress bar. Dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets or sets the text which is displayed in progress bar.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Progress Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Progress Constructor

[image]

.NET ModelKit Suite ClassReference
Progress Constructor
Progress Class See Also Send Feedback
Initializes a new instance of the Progress class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Progress()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Progress()

See Also

Progress Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Progress Fields

[image] [image]

.NET ModelKit Suite ClassReference
Progress Fields
Progress Class See Also Send Feedback

The Progress type exposes the following members.

Fields

Name | Description
TextProperty | Gets or sets the text which is displayed in progress bar. Dependency property.

See Also

Progress Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


TextProperty Field

[image]

.NET ModelKit Suite ClassReference
Progress..::.TextProperty Field
Progress Class See Also Send Feedback
Gets or sets the text which is displayed in progress bar. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty TextProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TextProperty

See Also

Progress Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Progress Methods

[image] [image]

.NET ModelKit Suite ClassReference
Progress Methods
Progress Class See Also Send Feedback

The Progress type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

Progress Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


OnApplyTemplate Method

[image]

.NET ModelKit Suite ClassReference
Progress..::.OnApplyTemplate Method
Progress Class See Also Send Feedback
Overridden. See OnApplyTemplate()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

Progress Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Progress Properties

[image] [image]

.NET ModelKit Suite ClassReference
Progress Properties
Progress Class See Also Send Feedback

The Progress type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets or sets the text which is displayed in progress bar.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

Progress Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Text Property

[image]

.NET ModelKit Suite ClassReference
Progress..::.Text Property
Progress Class See Also Send Feedback
Gets or sets the text which is displayed in progress bar.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

Progress Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Progress Events

[image] [image]

.NET ModelKit Suite ClassReference
Progress Events
Progress Class See Also Send Feedback

The Progress type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Progress Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


RegionZoomTool Class

[image]

.NET ModelKit Suite ClassReference
RegionZoomTool Class
Members See Also Send Feedback
Class for realization of the tool which is used for scaling the report in the selected area. Inherited from StandardTool.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class RegionZoomTool : StandardTool
Visual Basic (Declaration)
Public Class RegionZoomTool _
    Inherits StandardTool
Visual C++
public ref class RegionZoomTool : public StandardTool

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client..::.Tool
PerpetuumSoft.Reporting.Silverlight.Client..::.StandardTool
PerpetuumSoft.Reporting.Silverlight.Client..::.RegionZoomTool

See Also

RegionZoomTool Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


RegionZoomTool Members

[image] [image]

.NET ModelKit Suite ClassReference
RegionZoomTool Members
RegionZoomTool Class Constructors Methods Properties See Also Send Feedback

The RegionZoomTool type exposes the following members.

Constructors

Name | Description
RegionZoomTool | Initializes a new instance of the RegionZoomTool class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Overrides StandardTool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides StandardTool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides StandardTool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Overridden. See UpdateCursor()()(). (Overrides Tool..::.UpdateCursor()()().)

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

RegionZoomTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


RegionZoomTool Constructor

[image]

.NET ModelKit Suite ClassReference
RegionZoomTool Constructor
RegionZoomTool Class See Also Send Feedback
Initializes a new instance of the RegionZoomTool class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public RegionZoomTool(
    ViewManager manager
)
Visual Basic (Declaration)
Public Sub New ( _
    manager As ViewManager _
)
Visual C++
public:
RegionZoomTool(
    ViewManager^ manager
)

Parameters

manager
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ViewManager

See Also

RegionZoomTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


RegionZoomTool Methods

[image] [image]

.NET ModelKit Suite ClassReference
RegionZoomTool Methods
RegionZoomTool Class See Also Send Feedback

The RegionZoomTool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Overrides StandardTool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides StandardTool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides StandardTool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Overridden. See UpdateCursor()()(). (Overrides Tool..::.UpdateCursor()()().)

See Also

RegionZoomTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseDown Method

[image]

.NET ModelKit Suite ClassReference
RegionZoomTool..::.MouseDown Method
RegionZoomTool Class See Also Send Feedback
Overridden. See MouseDown(MouseEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseDown(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseDown ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseDown(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

RegionZoomTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseMove Method

[image]

.NET ModelKit Suite ClassReference
RegionZoomTool..::.MouseMove Method
RegionZoomTool Class See Also Send Feedback
Overridden. See MouseMove(MouseEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseMove(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseMove ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseMove(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

RegionZoomTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseUp Method

[image]

.NET ModelKit Suite ClassReference
RegionZoomTool..::.MouseUp Method
RegionZoomTool Class See Also Send Feedback
Overridden. See MouseUp(MouseEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseUp(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseUp ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseUp(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

RegionZoomTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


UpdateCursor Method

[image]

.NET ModelKit Suite ClassReference
RegionZoomTool..::.UpdateCursor Method
RegionZoomTool Class See Also Send Feedback
Overridden. See UpdateCursor()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void UpdateCursor()
Visual Basic (Declaration)
Public Overrides Sub UpdateCursor
Visual C++
public:
virtual void UpdateCursor() override

See Also

RegionZoomTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


RegionZoomTool Properties

[image] [image]

.NET ModelKit Suite ClassReference
RegionZoomTool Properties
RegionZoomTool Class See Also Send Feedback

The RegionZoomTool type exposes the following members.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

RegionZoomTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportErrorEventArgs Class

[image]

.NET ModelKit Suite ClassReference
ReportErrorEventArgs Class
Members See Also Send Feedback
Parameters of the event which occurs when there is generation error.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ReportErrorEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ReportErrorEventArgs _
    Inherits EventArgs
Visual C++
public ref class ReportErrorEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.Silverlight.Client..::.ReportErrorEventArgs

See Also

ReportErrorEventArgs Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportErrorEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportErrorEventArgs Members
ReportErrorEventArgs Class Constructors Methods Properties See Also Send Feedback

The ReportErrorEventArgs type exposes the following members.

Constructors

Name | Description
ReportErrorEventArgs | Initializes a new instance of the ReportErrorEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Exception | Gets or sets ExceptionDetailBase which is wrapper of exception occurred during operation execution.
Handled | Gets or sets a value that indicates the present state of the event handling.
ViewModel | Gets or sets ViewModel which is the report view model.

See Also

ReportErrorEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportErrorEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
ReportErrorEventArgs Constructor
ReportErrorEventArgs Class See Also Send Feedback
Initializes a new instance of the ReportErrorEventArgs class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ReportErrorEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportErrorEventArgs()

See Also

ReportErrorEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportErrorEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportErrorEventArgs Methods
ReportErrorEventArgs Class See Also Send Feedback

The ReportErrorEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportErrorEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportErrorEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportErrorEventArgs Properties
ReportErrorEventArgs Class See Also Send Feedback

The ReportErrorEventArgs type exposes the following members.

Properties

Name | Description
Exception | Gets or sets ExceptionDetailBase which is wrapper of exception occurred during operation execution.
Handled | Gets or sets a value that indicates the present state of the event handling.
ViewModel | Gets or sets ViewModel which is the report view model.

See Also

ReportErrorEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Exception Property

[image]

.NET ModelKit Suite ClassReference
ReportErrorEventArgs..::.Exception Property
ReportErrorEventArgs Class See Also Send Feedback
Gets or sets ExceptionDetailBase which is wrapper of exception occurred during operation execution.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ExceptionDetailBase Exception { get; set; }
Visual Basic (Declaration)
Public Property Exception As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ Exception {
    ExceptionDetailBase^ get ();
    void set (ExceptionDetailBase^ value);
}

See Also

ReportErrorEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Handled Property

[image]

.NET ModelKit Suite ClassReference
ReportErrorEventArgs..::.Handled Property
ReportErrorEventArgs Class See Also Send Feedback
Gets or sets a value that indicates the present state of the event handling.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool Handled { get; set; }
Visual Basic (Declaration)
Public Property Handled As Boolean
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

See Also

ReportErrorEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewModel Property

[image]

.NET ModelKit Suite ClassReference
ReportErrorEventArgs..::.ViewModel Property
ReportErrorEventArgs Class See Also Send Feedback
Gets or sets ViewModel which is the report view model.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ViewModel ViewModel { get; set; }
Visual Basic (Declaration)
Public Property ViewModel As ViewModel
Visual C++
public:
property ViewModel^ ViewModel {
    ViewModel^ get ();
    void set (ViewModel^ value);
}

See Also

ReportErrorEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportHyperlinkEventArgs Class

[image]

.NET ModelKit Suite ClassReference
ReportHyperlinkEventArgs Class
Members See Also Send Feedback
Parameters of the event which occurs when hyperlink is clicked.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ReportHyperlinkEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ReportHyperlinkEventArgs _
    Inherits EventArgs
Visual C++
public ref class ReportHyperlinkEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.Silverlight.Client..::.ReportHyperlinkEventArgs

See Also

ReportHyperlinkEventArgs Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportHyperlinkEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportHyperlinkEventArgs Members
ReportHyperlinkEventArgs Class Constructors Methods Properties See Also Send Feedback

The ReportHyperlinkEventArgs type exposes the following members.

Constructors

Name | Description
ReportHyperlinkEventArgs | Initializes a new instance of the ReportHyperlinkEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Handled | Gets or sets a value that indicates the present state of the event handling.
Hyperlink | Gets or sets hyperlink text.

See Also

ReportHyperlinkEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportHyperlinkEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
ReportHyperlinkEventArgs Constructor
ReportHyperlinkEventArgs Class See Also Send Feedback
Initializes a new instance of the ReportHyperlinkEventArgs class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ReportHyperlinkEventArgs(
    string hyperlink
)
Visual Basic (Declaration)
Public Sub New ( _
    hyperlink As String _
)
Visual C++
public:
ReportHyperlinkEventArgs(
    String^ hyperlink
)

Parameters

hyperlink
Type: System..::.String

See Also

ReportHyperlinkEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportHyperlinkEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportHyperlinkEventArgs Methods
ReportHyperlinkEventArgs Class See Also Send Feedback

The ReportHyperlinkEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportHyperlinkEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportHyperlinkEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportHyperlinkEventArgs Properties
ReportHyperlinkEventArgs Class See Also Send Feedback

The ReportHyperlinkEventArgs type exposes the following members.

Properties

Name | Description
Handled | Gets or sets a value that indicates the present state of the event handling.
Hyperlink | Gets or sets hyperlink text.

See Also

ReportHyperlinkEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Handled Property

[image]

.NET ModelKit Suite ClassReference
ReportHyperlinkEventArgs..::.Handled Property
ReportHyperlinkEventArgs Class See Also Send Feedback
Gets or sets a value that indicates the present state of the event handling.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool Handled { get; set; }
Visual Basic (Declaration)
Public Property Handled As Boolean
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

See Also

ReportHyperlinkEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Hyperlink Property

[image]

.NET ModelKit Suite ClassReference
ReportHyperlinkEventArgs..::.Hyperlink Property
ReportHyperlinkEventArgs Class See Also Send Feedback
Gets or sets hyperlink text.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string Hyperlink { get; private set; }
Visual Basic (Declaration)
Public Property Hyperlink As String
Visual C++
public:
property String^ Hyperlink {
    String^ get ();
    void set (String^ value);
}

See Also

ReportHyperlinkEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportRegion Structure

[image]

.NET ModelKit Suite ClassReference
ReportRegion Structure
Members See Also Send Feedback
Report area.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public struct ReportRegion
Visual Basic (Declaration)
Public Structure ReportRegion
Visual C++
public value class ReportRegion

See Also

ReportRegion Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportRegion Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportRegion Members
ReportRegion Structure Constructors Methods Properties See Also Send Feedback

The ReportRegion type exposes the following members.

Constructors

Name | Description
ReportRegion | Initializes a new instance of the ReportRegion class.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
PageNumber | Gets page number.
Rectangle | Gets area coordinates.

See Also

ReportRegion Structure
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportRegion Constructor

[image]

.NET ModelKit Suite ClassReference
ReportRegion Constructor
ReportRegion Structure See Also Send Feedback
Initializes a new instance of the ReportRegion class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ReportRegion(
    int pageNumber,
    Rect rectangle
)
Visual Basic (Declaration)
Public Sub New ( _
    pageNumber As Integer, _
    rectangle As Rect _
)
Visual C++
public:
ReportRegion(
    int pageNumber,
    Rect rectangle
)

Parameters

pageNumber
Type: System..::.Int32
rectangle
Type: System.Windows..::.Rect

See Also

ReportRegion Structure
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportRegion Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportRegion Methods
ReportRegion Structure See Also Send Feedback

The ReportRegion type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

ReportRegion Structure
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportRegion Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportRegion Properties
ReportRegion Structure See Also Send Feedback

The ReportRegion type exposes the following members.

Properties

Name | Description
PageNumber | Gets page number.
Rectangle | Gets area coordinates.

See Also

ReportRegion Structure
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageNumber Property

[image]

.NET ModelKit Suite ClassReference
ReportRegion..::.PageNumber Property
ReportRegion Structure See Also Send Feedback
Gets page number.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public int PageNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
}

See Also

ReportRegion Structure
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Rectangle Property

[image]

.NET ModelKit Suite ClassReference
ReportRegion..::.Rectangle Property
ReportRegion Structure See Also Send Feedback
Gets area coordinates.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Rect Rectangle { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rectangle As Rect
Visual C++
public:
property Rect Rectangle {
    Rect get ();
}

See Also

ReportRegion Structure
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportViewer Class

[image]

.NET ModelKit Suite ClassReference
ReportViewer Class
Members See Also Send Feedback
A сcontrol for report preview, navigation by pages, export and search.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ReportViewer : Control,
    IView
Visual Basic (Declaration)
Public Class ReportViewer _
    Inherits Control _
    Implements IView
Visual C++
public ref class ReportViewer : public Control,
    IView

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.Reporting.Silverlight.Client..::.ReportViewer

See Also

ReportViewer Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportViewer Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer Members
ReportViewer Class Constructors Methods Fields Properties Events See Also Send Feedback

The ReportViewer type exposes the following members.

Constructors

Name | Description
ReportViewer | Initializes a new instance of the ReportViewer class.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDocumentLoaded | Raises the DocumentLoaded event.
OnGotFocus | (Inherited from Control.)
OnHyperlinkClick | Raises the HyperlinkClick event.
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnPageLoaded | Raises the PageLoaded event.
OnReportError | Raises the ReportError event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RenderDocument | Performs report rendering.
SaveInHistory | Saves the current report display state.
Search | Executes text search through report.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
SetZoom | Sets view scale.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
AnimationDurationProperty | Gets or sets animation duration. Dependency property.
ErrorPresenterStyleProperty | Gets or sets errors presenter style. Dependency property.
LoadingPageStyleProperty | Gets or sets report viewer style during the page loading.
LoadingStateStyleProperty | Gets or sets report viewer style during the report loading.
MouseWheelSpeedProperty | Gets or sets mouse wheel speed. Dependency property.
NoReportStyleProperty | Gets or sets viewer display style without a report. Dependency property.
PageGapProperty | Gets or sets page gap. Dependency property.
PageMarginProperty | Gets or sets page margins. Dependency property.
PagePresenterStyleProperty | Gets or sets page presenter style. Dependency property.
RenderingStateStyleProperty | Gets or sets viewer display style during report rendering. Dependency property.
ReportNameProperty | Gets or sets active report name. Dependency property.
SelectStyleProperty | Gets or sets report active element style. Dependency property.
ServiceUrlProperty | Gets or sets reports WCF service url. Dependency property.
StatusBarVisibleProperty | Gets or sets the property which indicates if the status bar is visible. Dependency property.
ToolBarBackgroundProperty | Gets or sets toolbar background. Dependency property.
ToolBarForegroundProperty | Gets or sets foreground brush of the toolbar. Dependency property.
ToolBarVisibleProperty | Gets or sets the property which indicates if toolbar is visible. Dependency property.
ViewOptionsProperty | Gets or sets report viewer parameters. Dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AnimationDuration | Implements AnimationDuration()()().
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
ErrorPresenterStyle | Implements ErrorPresenterStyle()()().
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LoadingPageStyle | Implements LoadingPageStyle()()().
LoadingStateStyle | Implements LoadingStateStyle()()().
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MouseWheelSpeed | Implements MouseWheelSpeed()()().
Name | (Inherited from FrameworkElement.)
NoReportStyle | Implements NoReportStyle()()().
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
PageGap | Implements PageGap()()().
PageMargin | Implements PageMargin()()().
PagePresenterStyle | Implements PagePresenterStyle()()().
Parameters | Gets Dictionary<(Of <(String, Object>)>)which are active report parameters.
Parent | (Inherited from FrameworkElement.)
RenderingStateStyle | Implements RenderingStateStyle()()().
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
ReportName | Gets or sets active report name.
Resources | (Inherited from FrameworkElement.)
SearchText | Gets or sets search text.
SelectStyle | Implements SelectStyle()()().
ServiceUrl | Implements ServiceUrl()()().
StatusBarVisible | Gets or sets the property which indicates if status bar is visible.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
ToolBarBackground | Gets or sets a toolbar background.
ToolBarForeground | Gets or sets the labels colors on toolbar.
ToolBarVisible | Gets or sets the property which shows if toolbar is visible.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
ViewManager | Implements ViewManager.
ViewOptions | Gets or sets ViewOptions which are кreport preview options (switch on/off element functions used for preview).
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
DocumentLoaded | Occurs when a report is loaded.
GotFocus | (Inherited from UIElement.)
HyperlinkClick | Occurs when user clicks on a hyperlink in report preview.
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
PageLoaded | Occurs when a page is loaded.
ReportError | Occurs when there is an error in report generation.
SizeChanged | (Inherited from FrameworkElement.)

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportViewer Constructor

[image]

.NET ModelKit Suite ClassReference
ReportViewer Constructor
ReportViewer Class See Also Send Feedback
Initializes a new instance of the ReportViewer class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ReportViewer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportViewer()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportViewer Fields

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer Fields
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Fields

Name | Description
AnimationDurationProperty | Gets or sets animation duration. Dependency property.
ErrorPresenterStyleProperty | Gets or sets errors presenter style. Dependency property.
LoadingPageStyleProperty | Gets or sets report viewer style during the page loading.
LoadingStateStyleProperty | Gets or sets report viewer style during the report loading.
MouseWheelSpeedProperty | Gets or sets mouse wheel speed. Dependency property.
NoReportStyleProperty | Gets or sets viewer display style without a report. Dependency property.
PageGapProperty | Gets or sets page gap. Dependency property.
PageMarginProperty | Gets or sets page margins. Dependency property.
PagePresenterStyleProperty | Gets or sets page presenter style. Dependency property.
RenderingStateStyleProperty | Gets or sets viewer display style during report rendering. Dependency property.
ReportNameProperty | Gets or sets active report name. Dependency property.
SelectStyleProperty | Gets or sets report active element style. Dependency property.
ServiceUrlProperty | Gets or sets reports WCF service url. Dependency property.
StatusBarVisibleProperty | Gets or sets the property which indicates if the status bar is visible. Dependency property.
ToolBarBackgroundProperty | Gets or sets toolbar background. Dependency property.
ToolBarForegroundProperty | Gets or sets foreground brush of the toolbar. Dependency property.
ToolBarVisibleProperty | Gets or sets the property which indicates if toolbar is visible. Dependency property.
ViewOptionsProperty | Gets or sets report viewer parameters. Dependency property.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


AnimationDurationProperty Field

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.AnimationDurationProperty Field
ReportViewer Class See Also Send Feedback
Gets or sets animation duration. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty AnimationDurationProperty
Visual Basic (Declaration)
Public Shared ReadOnly AnimationDurationProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ AnimationDurationProperty

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ErrorPresenterStyleProperty Field

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ErrorPresenterStyleProperty Field
ReportViewer Class See Also Send Feedback
Gets or sets errors presenter style. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty ErrorPresenterStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ErrorPresenterStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ErrorPresenterStyleProperty

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


LoadingPageStyleProperty Field

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.LoadingPageStyleProperty Field
ReportViewer Class See Also Send Feedback
Gets or sets report viewer style during the page loading.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty LoadingPageStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly LoadingPageStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ LoadingPageStyleProperty

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


LoadingStateStyleProperty Field

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.LoadingStateStyleProperty Field
ReportViewer Class See Also Send Feedback
Gets or sets report viewer style during the report loading.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty LoadingStateStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly LoadingStateStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ LoadingStateStyleProperty

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseWheelSpeedProperty Field

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.MouseWheelSpeedProperty Field
ReportViewer Class See Also Send Feedback
Gets or sets mouse wheel speed. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty MouseWheelSpeedProperty
Visual Basic (Declaration)
Public Shared ReadOnly MouseWheelSpeedProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ MouseWheelSpeedProperty

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


NoReportStyleProperty Field

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.NoReportStyleProperty Field
ReportViewer Class See Also Send Feedback
Gets or sets viewer display style without a report. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty NoReportStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly NoReportStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ NoReportStyleProperty

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageGapProperty Field

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.PageGapProperty Field
ReportViewer Class See Also Send Feedback
Gets or sets page gap. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty PageGapProperty
Visual Basic (Declaration)
Public Shared ReadOnly PageGapProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ PageGapProperty

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageMarginProperty Field

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.PageMarginProperty Field
ReportViewer Class See Also Send Feedback
Gets or sets page margins. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty PageMarginProperty
Visual Basic (Declaration)
Public Shared ReadOnly PageMarginProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ PageMarginProperty

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PagePresenterStyleProperty Field

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.PagePresenterStyleProperty Field
ReportViewer Class See Also Send Feedback
Gets or sets page presenter style. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty PagePresenterStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly PagePresenterStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ PagePresenterStyleProperty

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


RenderingStateStyleProperty Field

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.RenderingStateStyleProperty Field
ReportViewer Class See Also Send Feedback
Gets or sets viewer display style during report rendering. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty RenderingStateStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly RenderingStateStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ RenderingStateStyleProperty

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportNameProperty Field

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ReportNameProperty Field
ReportViewer Class See Also Send Feedback
Gets or sets active report name. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static DependencyProperty ReportNameProperty
Visual Basic (Declaration)
Public Shared ReportNameProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ ReportNameProperty

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


SelectStyleProperty Field

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.SelectStyleProperty Field
ReportViewer Class See Also Send Feedback
Gets or sets report active element style. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty SelectStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectStyleProperty

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ServiceUrlProperty Field

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ServiceUrlProperty Field
ReportViewer Class See Also Send Feedback
Gets or sets reports WCF service url. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static DependencyProperty ServiceUrlProperty
Visual Basic (Declaration)
Public Shared ServiceUrlProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ ServiceUrlProperty

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


StatusBarVisibleProperty Field

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.StatusBarVisibleProperty Field
ReportViewer Class See Also Send Feedback
Gets or sets the property which indicates if the status bar is visible. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty StatusBarVisibleProperty
Visual Basic (Declaration)
Public Shared ReadOnly StatusBarVisibleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ StatusBarVisibleProperty

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToolBarBackgroundProperty Field

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ToolBarBackgroundProperty Field
ReportViewer Class See Also Send Feedback
Gets or sets toolbar background. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty ToolBarBackgroundProperty
Visual Basic (Declaration)
Public Shared ReadOnly ToolBarBackgroundProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ToolBarBackgroundProperty

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToolBarForegroundProperty Field

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ToolBarForegroundProperty Field
ReportViewer Class See Also Send Feedback
Gets or sets foreground brush of the toolbar. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty ToolBarForegroundProperty
Visual Basic (Declaration)
Public Shared ReadOnly ToolBarForegroundProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ToolBarForegroundProperty

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToolBarVisibleProperty Field

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ToolBarVisibleProperty Field
ReportViewer Class See Also Send Feedback
Gets or sets the property which indicates if toolbar is visible. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty ToolBarVisibleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ToolBarVisibleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ToolBarVisibleProperty

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewOptionsProperty Field

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ViewOptionsProperty Field
ReportViewer Class See Also Send Feedback
Gets or sets report viewer parameters. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty ViewOptionsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ViewOptionsProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ViewOptionsProperty

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportViewer Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer Methods
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDocumentLoaded | Raises the DocumentLoaded event.
OnGotFocus | (Inherited from Control.)
OnHyperlinkClick | Raises the HyperlinkClick event.
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnPageLoaded | Raises the PageLoaded event.
OnReportError | Raises the ReportError event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RenderDocument | Performs report rendering.
SaveInHistory | Saves the current report display state.
Search | Executes text search through report.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
SetZoom | Sets view scale.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


OnApplyTemplate Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.OnApplyTemplate Method
ReportViewer Class See Also Send Feedback
Overridden. See OnApplyTemplate()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


OnDocumentLoaded Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.OnDocumentLoaded Method
ReportViewer Class See Also Send Feedback
Raises the DocumentLoaded event.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected virtual void OnDocumentLoaded(
    DocumentLoadedEventArgs args
)
Visual Basic (Declaration)
Protected Overridable Sub OnDocumentLoaded ( _
    args As DocumentLoadedEventArgs _
)
Visual C++
protected:
virtual void OnDocumentLoaded(
    DocumentLoadedEventArgs^ args
)

Parameters

args
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.DocumentLoadedEventArgs

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


OnHyperlinkClick Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.OnHyperlinkClick Method
ReportViewer Class See Also Send Feedback
Raises the HyperlinkClick event.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected virtual void OnHyperlinkClick(
    ReportHyperlinkEventArgs args
)
Visual Basic (Declaration)
Protected Overridable Sub OnHyperlinkClick ( _
    args As ReportHyperlinkEventArgs _
)
Visual C++
protected:
virtual void OnHyperlinkClick(
    ReportHyperlinkEventArgs^ args
)

Parameters

args
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ReportHyperlinkEventArgs

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


OnPageLoaded Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.OnPageLoaded Method
ReportViewer Class See Also Send Feedback
Raises the PageLoaded event.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected virtual void OnPageLoaded(
    PageLoadedEventArgs args
)
Visual Basic (Declaration)
Protected Overridable Sub OnPageLoaded ( _
    args As PageLoadedEventArgs _
)
Visual C++
protected:
virtual void OnPageLoaded(
    PageLoadedEventArgs^ args
)

Parameters

args
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.PageLoadedEventArgs

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


OnReportError Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.OnReportError Method
ReportViewer Class See Also Send Feedback
Raises the ReportError event.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected virtual void OnReportError(
    ReportErrorEventArgs args
)
Visual Basic (Declaration)
Protected Overridable Sub OnReportError ( _
    args As ReportErrorEventArgs _
)
Visual C++
protected:
virtual void OnReportError(
    ReportErrorEventArgs^ args
)

Parameters

args
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ReportErrorEventArgs

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


RenderDocument Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.RenderDocument Method
ReportViewer Class See Also Send Feedback
Performs report rendering.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void RenderDocument()
Visual Basic (Declaration)
Public Sub RenderDocument
Visual C++
public:
void RenderDocument()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


SaveInHistory Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.SaveInHistory Method
ReportViewer Class See Also Send Feedback
Saves the current report display state.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void SaveInHistory()
Visual Basic (Declaration)
Public Sub SaveInHistory
Visual C++
public:
void SaveInHistory()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Search Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.Search Method
ReportViewer Class See Also Send Feedback
Executes text search through report.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void Search(
    string text,
    SearchDirection direction,
    bool fromBeginning
)
Visual Basic (Declaration)
Public Sub Search ( _
    text As String, _
    direction As SearchDirection, _
    fromBeginning As Boolean _
)
Visual C++
public:
void Search(
    String^ text,
    SearchDirection direction,
    bool fromBeginning
)

Parameters

text
Type: System..::.String
direction
Type: PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.SearchDirection
fromBeginning
Type: System..::.Boolean

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


SetZoom Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.SetZoom Method
ReportViewer Class See Also Send Feedback
Sets view scale.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void SetZoom(
    ZoomMode mode,
    double scale
)
Visual Basic (Declaration)
Public Sub SetZoom ( _
    mode As ZoomMode, _
    scale As Double _
)
Visual C++
public:
void SetZoom(
    ZoomMode mode,
    double scale
)

Parameters

mode
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ZoomMode
scale
Type: System..::.Double

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportViewer Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer Properties
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AnimationDuration | Implements AnimationDuration()()().
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
ErrorPresenterStyle | Implements ErrorPresenterStyle()()().
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LoadingPageStyle | Implements LoadingPageStyle()()().
LoadingStateStyle | Implements LoadingStateStyle()()().
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MouseWheelSpeed | Implements MouseWheelSpeed()()().
Name | (Inherited from FrameworkElement.)
NoReportStyle | Implements NoReportStyle()()().
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
PageGap | Implements PageGap()()().
PageMargin | Implements PageMargin()()().
PagePresenterStyle | Implements PagePresenterStyle()()().
Parameters | Gets Dictionary<(Of <(String, Object>)>)which are active report parameters.
Parent | (Inherited from FrameworkElement.)
RenderingStateStyle | Implements RenderingStateStyle()()().
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
ReportName | Gets or sets active report name.
Resources | (Inherited from FrameworkElement.)
SearchText | Gets or sets search text.
SelectStyle | Implements SelectStyle()()().
ServiceUrl | Implements ServiceUrl()()().
StatusBarVisible | Gets or sets the property which indicates if status bar is visible.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
ToolBarBackground | Gets or sets a toolbar background.
ToolBarForeground | Gets or sets the labels colors on toolbar.
ToolBarVisible | Gets or sets the property which shows if toolbar is visible.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
ViewManager | Implements ViewManager.
ViewOptions | Gets or sets ViewOptions which are кreport preview options (switch on/off element functions used for preview).
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


AnimationDuration Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.AnimationDuration Property
ReportViewer Class See Also Send Feedback
Implements AnimationDuration()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Duration AnimationDuration { get; set; }
Visual Basic (Declaration)
Public Property AnimationDuration As Duration
Visual C++
public:
virtual property Duration AnimationDuration {
    Duration get () sealed;
    void set (Duration value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ErrorPresenterStyle Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ErrorPresenterStyle Property
ReportViewer Class See Also Send Feedback
Implements ErrorPresenterStyle()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Style ErrorPresenterStyle { get; set; }
Visual Basic (Declaration)
Public Property ErrorPresenterStyle As Style
Visual C++
public:
virtual property Style^ ErrorPresenterStyle {
    Style^ get () sealed;
    void set (Style^ value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


LoadingPageStyle Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.LoadingPageStyle Property
ReportViewer Class See Also Send Feedback
Implements LoadingPageStyle()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Style LoadingPageStyle { get; set; }
Visual Basic (Declaration)
Public Property LoadingPageStyle As Style
Visual C++
public:
virtual property Style^ LoadingPageStyle {
    Style^ get () sealed;
    void set (Style^ value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


LoadingStateStyle Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.LoadingStateStyle Property
ReportViewer Class See Also Send Feedback
Implements LoadingStateStyle()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Style LoadingStateStyle { get; set; }
Visual Basic (Declaration)
Public Property LoadingStateStyle As Style
Visual C++
public:
virtual property Style^ LoadingStateStyle {
    Style^ get () sealed;
    void set (Style^ value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseWheelSpeed Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.MouseWheelSpeed Property
ReportViewer Class See Also Send Feedback
Implements MouseWheelSpeed()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public double MouseWheelSpeed { get; set; }
Visual Basic (Declaration)
Public Property MouseWheelSpeed As Double
Visual C++
public:
virtual property double MouseWheelSpeed {
    double get () sealed;
    void set (double value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


NoReportStyle Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.NoReportStyle Property
ReportViewer Class See Also Send Feedback
Implements NoReportStyle()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Style NoReportStyle { get; set; }
Visual Basic (Declaration)
Public Property NoReportStyle As Style
Visual C++
public:
virtual property Style^ NoReportStyle {
    Style^ get () sealed;
    void set (Style^ value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageGap Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.PageGap Property
ReportViewer Class See Also Send Feedback
Implements PageGap()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public double PageGap { get; set; }
Visual Basic (Declaration)
Public Property PageGap As Double
Visual C++
public:
virtual property double PageGap {
    double get () sealed;
    void set (double value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageMargin Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.PageMargin Property
ReportViewer Class See Also Send Feedback
Implements PageMargin()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public double PageMargin { get; set; }
Visual Basic (Declaration)
Public Property PageMargin As Double
Visual C++
public:
virtual property double PageMargin {
    double get () sealed;
    void set (double value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PagePresenterStyle Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.PagePresenterStyle Property
ReportViewer Class See Also Send Feedback
Implements PagePresenterStyle()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Style PagePresenterStyle { get; set; }
Visual Basic (Declaration)
Public Property PagePresenterStyle As Style
Visual C++
public:
virtual property Style^ PagePresenterStyle {
    Style^ get () sealed;
    void set (Style^ value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Parameters Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.Parameters Property
ReportViewer Class See Also Send Feedback
Gets Dictionary<(Of <(String, Object>)>)which are active report parameters.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Dictionary<string, Object> Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As Dictionary(Of String, Object)
Visual C++
public:
property Dictionary<String^, Object^>^ Parameters {
    Dictionary<String^, Object^>^ get ();
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


RenderingStateStyle Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.RenderingStateStyle Property
ReportViewer Class See Also Send Feedback
Implements RenderingStateStyle()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Style RenderingStateStyle { get; set; }
Visual Basic (Declaration)
Public Property RenderingStateStyle As Style
Visual C++
public:
virtual property Style^ RenderingStateStyle {
    Style^ get () sealed;
    void set (Style^ value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportName Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ReportName Property
ReportViewer Class See Also Send Feedback
Gets or sets active report name.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string ReportName { get; set; }
Visual Basic (Declaration)
Public Property ReportName As String
Visual C++
public:
property String^ ReportName {
    String^ get ();
    void set (String^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


SearchText Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.SearchText Property
ReportViewer Class See Also Send Feedback
Gets or sets search text.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string SearchText { get; set; }
Visual Basic (Declaration)
Public Property SearchText As String
Visual C++
public:
property String^ SearchText {
    String^ get ();
    void set (String^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


SelectStyle Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.SelectStyle Property
ReportViewer Class See Also Send Feedback
Implements SelectStyle()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Style SelectStyle { get; set; }
Visual Basic (Declaration)
Public Property SelectStyle As Style
Visual C++
public:
virtual property Style^ SelectStyle {
    Style^ get () sealed;
    void set (Style^ value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ServiceUrl Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ServiceUrl Property
ReportViewer Class See Also Send Feedback
Implements ServiceUrl()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string ServiceUrl { get; set; }
Visual Basic (Declaration)
Public Property ServiceUrl As String
Visual C++
public:
virtual property String^ ServiceUrl {
    String^ get () sealed;
    void set (String^ value) sealed;
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


StatusBarVisible Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.StatusBarVisible Property
ReportViewer Class See Also Send Feedback
Gets or sets the property which indicates if status bar is visible.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Visibility StatusBarVisible { get; set; }
Visual Basic (Declaration)
Public Property StatusBarVisible As Visibility
Visual C++
public:
property Visibility StatusBarVisible {
    Visibility get ();
    void set (Visibility value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToolBarBackground Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ToolBarBackground Property
ReportViewer Class See Also Send Feedback
Gets or sets a toolbar background.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Brush ToolBarBackground { get; set; }
Visual Basic (Declaration)
Public Property ToolBarBackground As Brush
Visual C++
public:
property Brush^ ToolBarBackground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToolBarForeground Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ToolBarForeground Property
ReportViewer Class See Also Send Feedback
Gets or sets the labels colors on toolbar.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Brush ToolBarForeground { get; set; }
Visual Basic (Declaration)
Public Property ToolBarForeground As Brush
Visual C++
public:
property Brush^ ToolBarForeground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToolBarVisible Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ToolBarVisible Property
ReportViewer Class See Also Send Feedback
Gets or sets the property which shows if toolbar is visible.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Visibility ToolBarVisible { get; set; }
Visual Basic (Declaration)
Public Property ToolBarVisible As Visibility
Visual C++
public:
property Visibility ToolBarVisible {
    Visibility get ();
    void set (Visibility value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewManager Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ViewManager Property
ReportViewer Class See Also Send Feedback
Implements ViewManager.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ViewManager ViewManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewManager As ViewManager
Visual C++
public:
property ViewManager^ ViewManager {
    ViewManager^ get ();
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewOptions Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ViewOptions Property
ReportViewer Class See Also Send Feedback
Gets or sets ViewOptions which are кreport preview options (switch on/off element functions used for preview).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ViewOptions ViewOptions { get; set; }
Visual Basic (Declaration)
Public Property ViewOptions As ViewOptions
Visual C++
public:
property ViewOptions^ ViewOptions {
    ViewOptions^ get ();
    void set (ViewOptions^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportViewer Events

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer Events
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
DocumentLoaded | Occurs when a report is loaded.
GotFocus | (Inherited from UIElement.)
HyperlinkClick | Occurs when user clicks on a hyperlink in report preview.
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
PageLoaded | Occurs when a page is loaded.
ReportError | Occurs when there is an error in report generation.
SizeChanged | (Inherited from FrameworkElement.)

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentLoaded Event

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.DocumentLoaded Event
ReportViewer Class See Also Send Feedback
Occurs when a report is loaded.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler<DocumentLoadedEventArgs> DocumentLoaded
Visual Basic (Declaration)
Public Event DocumentLoaded As EventHandler(Of DocumentLoadedEventArgs)
Visual C++
public:
 event EventHandler<DocumentLoadedEventArgs^>^ DocumentLoaded {
    void add (EventHandler<DocumentLoadedEventArgs^>^ value);
    void remove (EventHandler<DocumentLoadedEventArgs^>^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


HyperlinkClick Event

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.HyperlinkClick Event
ReportViewer Class See Also Send Feedback
Occurs when user clicks on a hyperlink in report preview.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler<ReportHyperlinkEventArgs> HyperlinkClick
Visual Basic (Declaration)
Public Event HyperlinkClick As EventHandler(Of ReportHyperlinkEventArgs)
Visual C++
public:
 event EventHandler<ReportHyperlinkEventArgs^>^ HyperlinkClick {
    void add (EventHandler<ReportHyperlinkEventArgs^>^ value);
    void remove (EventHandler<ReportHyperlinkEventArgs^>^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageLoaded Event

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.PageLoaded Event
ReportViewer Class See Also Send Feedback
Occurs when a page is loaded.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler<PageLoadedEventArgs> PageLoaded
Visual Basic (Declaration)
Public Event PageLoaded As EventHandler(Of PageLoadedEventArgs)
Visual C++
public:
 event EventHandler<PageLoadedEventArgs^>^ PageLoaded {
    void add (EventHandler<PageLoadedEventArgs^>^ value);
    void remove (EventHandler<PageLoadedEventArgs^>^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ReportError Event

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ReportError Event
ReportViewer Class See Also Send Feedback
Occurs when there is an error in report generation.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler<ReportErrorEventArgs> ReportError
Visual Basic (Declaration)
Public Event ReportError As EventHandler(Of ReportErrorEventArgs)
Visual C++
public:
 event EventHandler<ReportErrorEventArgs^>^ ReportError {
    void add (EventHandler<ReportErrorEventArgs^>^ value);
    void remove (EventHandler<ReportErrorEventArgs^>^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Select Class

[image]

.NET ModelKit Suite ClassReference
Select Class
Members See Also Send Feedback
Control which is used for checking selection on toolbar.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class Select : Control
Visual Basic (Declaration)
Public Class Select _
    Inherits Control
Visual C++
public ref class Select : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.Reporting.Silverlight.Client..::.Select

See Also

Select Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Select Members

[image] [image]

.NET ModelKit Suite ClassReference
Select Members
Select Class Constructors Methods Properties Events See Also Send Feedback

The Select type exposes the following members.

Constructors

Name | Description
Select | Initializes a new instance of the Select class.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Select Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Select Constructor

[image]

.NET ModelKit Suite ClassReference
Select Constructor
Select Class See Also Send Feedback
Initializes a new instance of the Select class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Select()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Select()

See Also

Select Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Select Methods

[image] [image]

.NET ModelKit Suite ClassReference
Select Methods
Select Class See Also Send Feedback

The Select type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

Select Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Select Properties

[image] [image]

.NET ModelKit Suite ClassReference
Select Properties
Select Class See Also Send Feedback

The Select type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

Select Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Select Events

[image] [image]

.NET ModelKit Suite ClassReference
Select Events
Select Class See Also Send Feedback

The Select type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Select Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Separator Class

[image]

.NET ModelKit Suite ClassReference
Separator Class
Members See Also Send Feedback
Separating control which is used in toolbar.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class Separator : Control
Visual Basic (Declaration)
Public Class Separator _
    Inherits Control
Visual C++
public ref class Separator : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
PerpetuumSoft.Reporting.Silverlight.Client..::.Separator

See Also

Separator Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Separator Members

[image] [image]

.NET ModelKit Suite ClassReference
Separator Members
Separator Class Constructors Methods Properties Events See Also Send Feedback

The Separator type exposes the following members.

Constructors

Name | Description
Separator | Initializes a new instance of the Separator class.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Separator Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Separator Constructor

[image]

.NET ModelKit Suite ClassReference
Separator Constructor
Separator Class See Also Send Feedback
Initializes a new instance of the Separator class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Separator()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Separator()

See Also

Separator Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Separator Methods

[image] [image]

.NET ModelKit Suite ClassReference
Separator Methods
Separator Class See Also Send Feedback

The Separator type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

Separator Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Separator Properties

[image] [image]

.NET ModelKit Suite ClassReference
Separator Properties
Separator Class See Also Send Feedback

The Separator type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

Separator Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Separator Events

[image] [image]

.NET ModelKit Suite ClassReference
Separator Events
Separator Class See Also Send Feedback

The Separator type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Separator Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


SinglePageModel Class

[image]

.NET ModelKit Suite ClassReference
SinglePageModel Class
Members See Also Send Feedback
Single page view mode.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class SinglePageModel : DocumentViewModel
Visual Basic (Declaration)
Public Class SinglePageModel _
    Inherits DocumentViewModel
Visual C++
public ref class SinglePageModel : public DocumentViewModel

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client..::.ViewModel
PerpetuumSoft.Reporting.Silverlight.Client..::.DocumentViewModel
PerpetuumSoft.Reporting.Silverlight.Client..::.SinglePageModel

See Also

SinglePageModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


SinglePageModel Members

[image] [image]

.NET ModelKit Suite ClassReference
SinglePageModel Members
SinglePageModel Class Constructors Methods Fields Properties See Also Send Feedback

The SinglePageModel type exposes the following members.

Constructors

Name | Description
SinglePageModel | Initializes a new instance of the SinglePageModel class.

Methods

Name | Description
AssignParameters | Sets the model display parameters subject to the previous active model. (Inherited from ViewModel.)
CalculateOrigin | Calculates the page location in the report preview area. (Overrides DocumentViewModel..::.CalculateOrigin()()().)
CalculateZoom | Calculates scale. (Inherited from DocumentViewModel.)
ChangeZoom | Overloaded.
Clone | Overridden. See Clone()()(). (Overrides ViewModel..::.Clone()()().)
CreateStoryboard | Creates Storyboard for animation. (Inherited from DocumentViewModel.)
DeleteUnusedPages | Deletes the unused pages. (Inherited from DocumentViewModel.)
DocumentEnd | Overridden. See DocumentEnd()()(). (Overrides ViewModel..::.DocumentEnd()()().)
DocumentHome | Overridden. See DocumentHome()()(). (Overrides ViewModel..::.DocumentHome()()().)
EnsurePageView | Creates the presenter for the selected page if the presenter is missing. (Inherited from DocumentViewModel.)
EnsureVisible | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetGap | Gets the gap between pages. (Overrides DocumentViewModel..::.GetGap(Point).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GoToFirstPage | Overridden. See GoToFirstPage()()(). (Inherited from DocumentViewModel.)
GoToLastPage | Overridden. See GoToLastPage()()(). (Inherited from DocumentViewModel.)
GoToNextPage | Overridden. See GoToNextPage()()(). (Inherited from DocumentViewModel.)
GoToPrevPage | Overridden. See GoToPrevPage()()(). (Inherited from DocumentViewModel.)
Invalidate | Overloaded.
MakeVisible | Forces content to scroll until the coordinate space of a specific rectangle is visible. (Inherited from DocumentViewModel.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from DocumentViewModel.)
PageDown | Overridden. See PageDown()()(). (Inherited from DocumentViewModel.)
PageEnd | Overridden. See PageEnd()()(). (Overrides ViewModel..::.PageEnd()()().)
PageHome | Overridden. See PageHome()()(). (Overrides ViewModel..::.PageHome()()().)
PageUp | Overridden. See PageUp()()(). (Inherited from DocumentViewModel.)
PanView | Overridden. See PanView(Point). (Inherited from DocumentViewModel.)
RectToScreen | Gets the page area screen coordinates. (Overrides DocumentViewModel..::.RectToScreen(ReportRegion).)
ResetSearchResult | Overridden. See ResetSearchResult()()(). (Inherited from DocumentViewModel.)
SetupPage | Sets the selected page parameters. (Inherited from DocumentViewModel.)
ShowSearchResult | Overridden. See ShowSearchResult(ReportRegion). (Inherited from DocumentViewModel.)
StartAnimation | Starts animation. (Inherited from DocumentViewModel.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateContent | (Overrides ViewModel..::.UpdateContent(ViewModel, Boolean).)
ZoomIn | Overloaded.
ZoomOut | Overloaded.
ZoomWindow | Overridden. See ZoomWindow(Rect, Boolean). (Inherited from DocumentViewModel.)

Fields

Name | Description
Gap | Gets the gap between pages. (Inherited from DocumentViewModel.)
Margin | Gets page margins. (Inherited from DocumentViewModel.)

Properties

Name | Description
CanGoToNextPage | Overridden. See CanGoToNextPage. (Inherited from DocumentViewModel.)
CanGoToPrevPage | Overridden. See CanGoToPrevPage. (Inherited from DocumentViewModel.)
ClientSize | Gets the client area size. (Inherited from ViewModel.)
Document | Gets Document which is a report. (Inherited from DocumentViewModel.)
HScrollBarActive | Overridden. See HScrollBarActive. (Inherited from DocumentViewModel.)
HScrollBarLarge | Overridden. See HScrollBarLarge. (Inherited from DocumentViewModel.)
HScrollBarMaximum | Overridden. See HScrollBarMaximum. (Inherited from DocumentViewModel.)
HScrollBarPosition | Overridden. See HScrollBarPosition. (Inherited from DocumentViewModel.)
HScrollBarSmall | Overridden. See HScrollBarSmall. (Inherited from DocumentViewModel.)
HScrollBarViewPort | Overridden. See HScrollBarViewPort. (Inherited from DocumentViewModel.)
PageNumber | Overridden. See PageNumber. (Overrides ViewModel..::.PageNumber.)
ScaledPageArea | Gets the page area size subject to view scale. (Overrides DocumentViewModel..::.ScaledPageArea.)
View | Gets IView which is report preview control. (Inherited from ViewModel.)
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from ViewModel.)
VScrollBarActive | Overridden. See VScrollBarActive. (Inherited from DocumentViewModel.)
VScrollBarLarge | Overridden. See VScrollBarLarge. (Inherited from DocumentViewModel.)
VScrollBarMaximum | Overridden. See VScrollBarMaximum. (Inherited from DocumentViewModel.)
VScrollBarPosition | Overridden. See VScrollBarPosition. (Inherited from DocumentViewModel.)
VScrollBarSmall | Overridden. See VScrollBarSmall. (Inherited from DocumentViewModel.)
VScrollBarViewPort | Overridden. See VScrollBarViewPort. (Inherited from DocumentViewModel.)
Zoom | Overridden. See Zoom. (Inherited from DocumentViewModel.)

See Also

SinglePageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


SinglePageModel Constructor

[image]

.NET ModelKit Suite ClassReference
SinglePageModel Constructor
SinglePageModel Class See Also Send Feedback
Initializes a new instance of the SinglePageModel class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public SinglePageModel(
    ViewManager manager
)
Visual Basic (Declaration)
Public Sub New ( _
    manager As ViewManager _
)
Visual C++
public:
SinglePageModel(
    ViewManager^ manager
)

Parameters

manager
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ViewManager

See Also

SinglePageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


SinglePageModel Fields

[image] [image]

.NET ModelKit Suite ClassReference
SinglePageModel Fields
SinglePageModel Class See Also Send Feedback

The SinglePageModel type exposes the following members.

Fields

Name | Description
Gap | Gets the gap between pages. (Inherited from DocumentViewModel.)
Margin | Gets page margins. (Inherited from DocumentViewModel.)

See Also

SinglePageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


SinglePageModel Methods

[image] [image]

.NET ModelKit Suite ClassReference
SinglePageModel Methods
SinglePageModel Class See Also Send Feedback

The SinglePageModel type exposes the following members.

Methods

Name | Description
AssignParameters | Sets the model display parameters subject to the previous active model. (Inherited from ViewModel.)
CalculateOrigin | Calculates the page location in the report preview area. (Overrides DocumentViewModel..::.CalculateOrigin()()().)
CalculateZoom | Calculates scale. (Inherited from DocumentViewModel.)
ChangeZoom | Overloaded.
Clone | Overridden. See Clone()()(). (Overrides ViewModel..::.Clone()()().)
CreateStoryboard | Creates Storyboard for animation. (Inherited from DocumentViewModel.)
DeleteUnusedPages | Deletes the unused pages. (Inherited from DocumentViewModel.)
DocumentEnd | Overridden. See DocumentEnd()()(). (Overrides ViewModel..::.DocumentEnd()()().)
DocumentHome | Overridden. See DocumentHome()()(). (Overrides ViewModel..::.DocumentHome()()().)
EnsurePageView | Creates the presenter for the selected page if the presenter is missing. (Inherited from DocumentViewModel.)
EnsureVisible | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetGap | Gets the gap between pages. (Overrides DocumentViewModel..::.GetGap(Point).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GoToFirstPage | Overridden. See GoToFirstPage()()(). (Inherited from DocumentViewModel.)
GoToLastPage | Overridden. See GoToLastPage()()(). (Inherited from DocumentViewModel.)
GoToNextPage | Overridden. See GoToNextPage()()(). (Inherited from DocumentViewModel.)
GoToPrevPage | Overridden. See GoToPrevPage()()(). (Inherited from DocumentViewModel.)
Invalidate | Overloaded.
MakeVisible | Forces content to scroll until the coordinate space of a specific rectangle is visible. (Inherited from DocumentViewModel.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from DocumentViewModel.)
PageDown | Overridden. See PageDown()()(). (Inherited from DocumentViewModel.)
PageEnd | Overridden. See PageEnd()()(). (Overrides ViewModel..::.PageEnd()()().)
PageHome | Overridden. See PageHome()()(). (Overrides ViewModel..::.PageHome()()().)
PageUp | Overridden. See PageUp()()(). (Inherited from DocumentViewModel.)
PanView | Overridden. See PanView(Point). (Inherited from DocumentViewModel.)
RectToScreen | Gets the page area screen coordinates. (Overrides DocumentViewModel..::.RectToScreen(ReportRegion).)
ResetSearchResult | Overridden. See ResetSearchResult()()(). (Inherited from DocumentViewModel.)
SetupPage | Sets the selected page parameters. (Inherited from DocumentViewModel.)
ShowSearchResult | Overridden. See ShowSearchResult(ReportRegion). (Inherited from DocumentViewModel.)
StartAnimation | Starts animation. (Inherited from DocumentViewModel.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateContent | (Overrides ViewModel..::.UpdateContent(ViewModel, Boolean).)
ZoomIn | Overloaded.
ZoomOut | Overloaded.
ZoomWindow | Overridden. See ZoomWindow(Rect, Boolean). (Inherited from DocumentViewModel.)

See Also

SinglePageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CalculateOrigin Method

[image]

.NET ModelKit Suite ClassReference
SinglePageModel..::.CalculateOrigin Method
SinglePageModel Class See Also Send Feedback
Calculates the page location in the report preview area.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected override void CalculateOrigin()
Visual Basic (Declaration)
Protected Overrides Sub CalculateOrigin
Visual C++
protected:
virtual void CalculateOrigin() override

See Also

SinglePageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ChangeZoom Method

[image] [image]

.NET ModelKit Suite ClassReference
SinglePageModel..::.ChangeZoom Method
SinglePageModel Class See Also Send Feedback

Overload List

Name | Description
ChangeZoom(ZoomMode, Boolean) | Overridden. See ChangeZoom(ZoomMode, Boolean). (Inherited from DocumentViewModel.)
ChangeZoom(Double, Boolean) | Performs scale and scale mode changing. (Inherited from ViewModel.)
ChangeZoom(Point, Double, Boolean) | Overridden. See ChangeZoom(Point, Double, Boolean). (Inherited from DocumentViewModel.)

See Also

SinglePageModel Class
SinglePageModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
SinglePageModel..::.Clone Method
SinglePageModel Class See Also Send Feedback
Overridden. See Clone()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override ViewModel Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As ViewModel
Visual C++
public:
virtual ViewModel^ Clone() override

See Also

SinglePageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentEnd Method

[image]

.NET ModelKit Suite ClassReference
SinglePageModel..::.DocumentEnd Method
SinglePageModel Class See Also Send Feedback
Overridden. See DocumentEnd()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void DocumentEnd()
Visual Basic (Declaration)
Public Overrides Sub DocumentEnd
Visual C++
public:
virtual void DocumentEnd() override

See Also

SinglePageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentHome Method

[image]

.NET ModelKit Suite ClassReference
SinglePageModel..::.DocumentHome Method
SinglePageModel Class See Also Send Feedback
Overridden. See DocumentHome()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void DocumentHome()
Visual Basic (Declaration)
Public Overrides Sub DocumentHome
Visual C++
public:
virtual void DocumentHome() override

See Also

SinglePageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


EnsureVisible Method

[image] [image]

.NET ModelKit Suite ClassReference
SinglePageModel..::.EnsureVisible Method
SinglePageModel Class See Also Send Feedback

Overload List

Name | Description
EnsureVisible(ReportRegion) | Shifts the visible area of the screen to guarantee that the specified report is visible. (Inherited from ViewModel.)
EnsureVisible(ReportRegion, Boolean) | Overridden. See EnsureVisible(ReportRegion, Boolean). (Overrides ViewModel..::.EnsureVisible(ReportRegion, Boolean).)

See Also

SinglePageModel Class
SinglePageModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


EnsureVisible Method (ReportRegion, Boolean)

[image]

.NET ModelKit Suite ClassReference
SinglePageModel..::.EnsureVisible Method (ReportRegion, Boolean)
SinglePageModel Class See Also Send Feedback
Overridden. See EnsureVisible(ReportRegion, Boolean).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void EnsureVisible(
    ReportRegion region,
    bool alignTop
)
Visual Basic (Declaration)
Public Overrides Sub EnsureVisible ( _
    region As ReportRegion, _
    alignTop As Boolean _
)
Visual C++
public:
virtual void EnsureVisible(
    ReportRegion region,
    bool alignTop
) override

Parameters

region
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ReportRegion
alignTop
Type: System..::.Boolean

See Also

SinglePageModel Class
EnsureVisible Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


GetGap Method

[image]

.NET ModelKit Suite ClassReference
SinglePageModel..::.GetGap Method
SinglePageModel Class See Also Send Feedback
Gets the gap between pages.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected override Size GetGap(
    Point center
)
Visual Basic (Declaration)
Protected Overrides Function GetGap ( _
    center As Point _
) As Size
Visual C++
protected:
virtual Size GetGap(
    Point center
) override

Parameters

center
Type: System.Windows..::.Point

See Also

SinglePageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
SinglePageModel..::.Invalidate Method
SinglePageModel Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates report viewer. (Inherited from DocumentViewModel.)
Invalidate(Boolean) | Invalidates report viewer. (Inherited from DocumentViewModel.)

See Also

SinglePageModel Class
SinglePageModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageEnd Method

[image]

.NET ModelKit Suite ClassReference
SinglePageModel..::.PageEnd Method
SinglePageModel Class See Also Send Feedback
Overridden. See PageEnd()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void PageEnd()
Visual Basic (Declaration)
Public Overrides Sub PageEnd
Visual C++
public:
virtual void PageEnd() override

See Also

SinglePageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageHome Method

[image]

.NET ModelKit Suite ClassReference
SinglePageModel..::.PageHome Method
SinglePageModel Class See Also Send Feedback
Overridden. See PageHome()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void PageHome()
Visual Basic (Declaration)
Public Overrides Sub PageHome
Visual C++
public:
virtual void PageHome() override

See Also

SinglePageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


RectToScreen Method

[image]

.NET ModelKit Suite ClassReference
SinglePageModel..::.RectToScreen Method
SinglePageModel Class See Also Send Feedback
Gets the page area screen coordinates.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected override Rect RectToScreen(
    ReportRegion region
)
Visual Basic (Declaration)
Protected Overrides Function RectToScreen ( _
    region As ReportRegion _
) As Rect
Visual C++
protected:
virtual Rect RectToScreen(
    ReportRegion region
) override

Parameters

region
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ReportRegion

See Also

SinglePageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


UpdateContent Method

[image]

.NET ModelKit Suite ClassReference
SinglePageModel..::.UpdateContent Method
SinglePageModel Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Silverlight.Client.SinglePageModel.UpdateContent(PerpetuumSoft.Reporting.Silverlight.Client.ViewModel,System.Boolean)]

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected internal override void UpdateContent(
    ViewModel prevViewModel,
    bool useAnimation
)
Visual Basic (Declaration)
Protected Friend Overrides Sub UpdateContent ( _
    prevViewModel As ViewModel, _
    useAnimation As Boolean _
)
Visual C++
protected public:
virtual void UpdateContent(
    ViewModel^ prevViewModel,
    bool useAnimation
) override

Parameters

prevViewModel
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ViewModel
useAnimation
Type: System..::.Boolean

See Also

SinglePageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomIn Method

[image] [image]

.NET ModelKit Suite ClassReference
SinglePageModel..::.ZoomIn Method
SinglePageModel Class See Also Send Feedback

Overload List

Name | Description
ZoomIn(Boolean) | Performs zoom in. (Inherited from ViewModel.)
ZoomIn(Point, Boolean) | Performs zoom in. (Inherited from ViewModel.)

See Also

SinglePageModel Class
SinglePageModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomOut Method

[image] [image]

.NET ModelKit Suite ClassReference
SinglePageModel..::.ZoomOut Method
SinglePageModel Class See Also Send Feedback

Overload List

Name | Description
ZoomOut(Boolean) | Performs zoom out. (Inherited from ViewModel.)
ZoomOut(Point, Boolean) | Performs zoom out. (Inherited from ViewModel.)

See Also

SinglePageModel Class
SinglePageModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


SinglePageModel Properties

[image] [image]

.NET ModelKit Suite ClassReference
SinglePageModel Properties
SinglePageModel Class See Also Send Feedback

The SinglePageModel type exposes the following members.

Properties

Name | Description
CanGoToNextPage | Overridden. See CanGoToNextPage. (Inherited from DocumentViewModel.)
CanGoToPrevPage | Overridden. See CanGoToPrevPage. (Inherited from DocumentViewModel.)
ClientSize | Gets the client area size. (Inherited from ViewModel.)
Document | Gets Document which is a report. (Inherited from DocumentViewModel.)
HScrollBarActive | Overridden. See HScrollBarActive. (Inherited from DocumentViewModel.)
HScrollBarLarge | Overridden. See HScrollBarLarge. (Inherited from DocumentViewModel.)
HScrollBarMaximum | Overridden. See HScrollBarMaximum. (Inherited from DocumentViewModel.)
HScrollBarPosition | Overridden. See HScrollBarPosition. (Inherited from DocumentViewModel.)
HScrollBarSmall | Overridden. See HScrollBarSmall. (Inherited from DocumentViewModel.)
HScrollBarViewPort | Overridden. See HScrollBarViewPort. (Inherited from DocumentViewModel.)
PageNumber | Overridden. See PageNumber. (Overrides ViewModel..::.PageNumber.)
ScaledPageArea | Gets the page area size subject to view scale. (Overrides DocumentViewModel..::.ScaledPageArea.)
View | Gets IView which is report preview control. (Inherited from ViewModel.)
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from ViewModel.)
VScrollBarActive | Overridden. See VScrollBarActive. (Inherited from DocumentViewModel.)
VScrollBarLarge | Overridden. See VScrollBarLarge. (Inherited from DocumentViewModel.)
VScrollBarMaximum | Overridden. See VScrollBarMaximum. (Inherited from DocumentViewModel.)
VScrollBarPosition | Overridden. See VScrollBarPosition. (Inherited from DocumentViewModel.)
VScrollBarSmall | Overridden. See VScrollBarSmall. (Inherited from DocumentViewModel.)
VScrollBarViewPort | Overridden. See VScrollBarViewPort. (Inherited from DocumentViewModel.)
Zoom | Overridden. See Zoom. (Inherited from DocumentViewModel.)

See Also

SinglePageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageNumber Property

[image]

.NET ModelKit Suite ClassReference
SinglePageModel..::.PageNumber Property
SinglePageModel Class See Also Send Feedback
Overridden. See PageNumber.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override int PageNumber { get; set; }
Visual Basic (Declaration)
Public Overrides Property PageNumber As Integer
Visual C++
public:
virtual property int PageNumber {
    int get () override;
    void set (int value) override;
}

See Also

SinglePageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ScaledPageArea Property

[image]

.NET ModelKit Suite ClassReference
SinglePageModel..::.ScaledPageArea Property
SinglePageModel Class See Also Send Feedback
Gets the page area size subject to view scale.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected override Size ScaledPageArea { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property ScaledPageArea As Size
Visual C++
protected:
virtual property Size ScaledPageArea {
    Size get () override;
}

See Also

SinglePageModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


StandardTool Class

[image]

.NET ModelKit Suite ClassReference
StandardTool Class
Members See Also Send Feedback
A basic class for all standard tools.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class StandardTool : Tool
Visual Basic (Declaration)
Public Class StandardTool _
    Inherits Tool
Visual C++
public ref class StandardTool : public Tool

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client..::.Tool
PerpetuumSoft.Reporting.Silverlight.Client..::.StandardTool
PerpetuumSoft.Reporting.Silverlight.Client..::.DynamicZoomTool
PerpetuumSoft.Reporting.Silverlight.Client..::.PanTool
PerpetuumSoft.Reporting.Silverlight.Client..::.RegionZoomTool
PerpetuumSoft.Reporting.Silverlight.Client..::.ZoomChangeTool

See Also

StandardTool Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


StandardTool Members

[image] [image]

.NET ModelKit Suite ClassReference
StandardTool Members
StandardTool Class Methods Properties See Also Send Feedback

The StandardTool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Overrides Tool..::.KeyDown(KeyEventArgs).)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Overrides Tool..::.KeyUp(KeyEventArgs).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Overrides Tool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides Tool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides Tool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Overrides Tool..::.MouseWheel(Double).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates active cursor. (Inherited from Tool.)

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

StandardTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


StandardTool Methods

[image] [image]

.NET ModelKit Suite ClassReference
StandardTool Methods
StandardTool Class See Also Send Feedback

The StandardTool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Overrides Tool..::.KeyDown(KeyEventArgs).)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Overrides Tool..::.KeyUp(KeyEventArgs).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Overrides Tool..::.MouseDown(MouseEventArgs).)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides Tool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides Tool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Overrides Tool..::.MouseWheel(Double).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates active cursor. (Inherited from Tool.)

See Also

StandardTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


KeyDown Method

[image]

.NET ModelKit Suite ClassReference
StandardTool..::.KeyDown Method
StandardTool Class See Also Send Feedback
Overridden. See KeyDown(KeyEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void KeyDown(
    KeyEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub KeyDown ( _
    args As KeyEventArgs _
)
Visual C++
public:
virtual void KeyDown(
    KeyEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.KeyEventArgs

See Also

StandardTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


KeyUp Method

[image]

.NET ModelKit Suite ClassReference
StandardTool..::.KeyUp Method
StandardTool Class See Also Send Feedback
Overridden. See KeyUp(KeyEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void KeyUp(
    KeyEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub KeyUp ( _
    args As KeyEventArgs _
)
Visual C++
public:
virtual void KeyUp(
    KeyEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.KeyEventArgs

See Also

StandardTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseDown Method

[image]

.NET ModelKit Suite ClassReference
StandardTool..::.MouseDown Method
StandardTool Class See Also Send Feedback
Overridden. See MouseDown(MouseEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseDown(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseDown ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseDown(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

StandardTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseMove Method

[image]

.NET ModelKit Suite ClassReference
StandardTool..::.MouseMove Method
StandardTool Class See Also Send Feedback
Overridden. See MouseMove(MouseEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseMove(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseMove ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseMove(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

StandardTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseUp Method

[image]

.NET ModelKit Suite ClassReference
StandardTool..::.MouseUp Method
StandardTool Class See Also Send Feedback
Overridden. See MouseUp(MouseEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseUp(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseUp ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseUp(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

StandardTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseWheel Method

[image]

.NET ModelKit Suite ClassReference
StandardTool..::.MouseWheel Method
StandardTool Class See Also Send Feedback
Overridden. See MouseWheel(Double).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseWheel(
    double delta
)
Visual Basic (Declaration)
Public Overrides Sub MouseWheel ( _
    delta As Double _
)
Visual C++
public:
virtual void MouseWheel(
    double delta
) override

Parameters

delta
Type: System..::.Double

See Also

StandardTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


StandardTool Properties

[image] [image]

.NET ModelKit Suite ClassReference
StandardTool Properties
StandardTool Class See Also Send Feedback

The StandardTool type exposes the following members.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

StandardTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToggleToolButton Class

[image]

.NET ModelKit Suite ClassReference
ToggleToolButton Class
Members See Also Send Feedback
Toolbar button control. Inherited from ToggleButton.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ToggleToolButton : ToggleButton
Visual Basic (Declaration)
Public Class ToggleToolButton _
    Inherits ToggleButton
Visual C++
public ref class ToggleToolButton : public ToggleButton

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
System.Windows.Controls.Primitives..::.ButtonBase
System.Windows.Controls.Primitives..::.ToggleButton
PerpetuumSoft.Reporting.Silverlight.Client..::.ToggleToolButton

See Also

ToggleToolButton Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToggleToolButton Members

[image] [image]

.NET ModelKit Suite ClassReference
ToggleToolButton Members
ToggleToolButton Class Constructors Methods Fields Properties Events See Also Send Feedback

The ToggleToolButton type exposes the following members.

Constructors

Name | Description
ToggleToolButton | Initializes a new instance of the ToggleToolButton class.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ToggleButton.)
OnClick | (Inherited from ToggleButton.)
OnContentChanged | (Inherited from ToggleButton.)
OnCreateAutomationPeer | (Inherited from ToggleButton.)
OnGotFocus | (Inherited from ButtonBase.)
OnIsPressedChanged | (Inherited from ButtonBase.)
OnKeyDown | (Inherited from ButtonBase.)
OnKeyUp | (Inherited from ButtonBase.)
OnLostFocus | (Inherited from ButtonBase.)
OnMouseEnter | (Inherited from ButtonBase.)
OnMouseLeave | (Inherited from ButtonBase.)
OnMouseLeftButtonDown | (Inherited from ButtonBase.)
OnMouseLeftButtonUp | (Inherited from ButtonBase.)
OnMouseMove | (Inherited from ButtonBase.)
OnToggle | (Inherited from ToggleButton.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | (Inherited from ToggleButton.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
DisabledContentProperty | Gets or sets disabled button state content. Dependency property.
TooltipTextProperty | Gets or sets the button text. Dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
ClickMode | (Inherited from ButtonBase.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledContent | Gets or sets disabled button state content.
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsChecked | (Inherited from ToggleButton.)
IsEnabled | (Inherited from Control.)
IsFocused | (Inherited from ButtonBase.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | (Inherited from ButtonBase.)
IsPressed | (Inherited from ButtonBase.)
IsTabStop | (Inherited from Control.)
IsThreeState | (Inherited from ToggleButton.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TooltipText | Gets or sets the button text.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Checked | (Inherited from ToggleButton.)
Click | (Inherited from ButtonBase.)
GotFocus | (Inherited from UIElement.)
Indeterminate | (Inherited from ToggleButton.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
Unchecked | (Inherited from ToggleButton.)

See Also

ToggleToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToggleToolButton Constructor

[image]

.NET ModelKit Suite ClassReference
ToggleToolButton Constructor
ToggleToolButton Class See Also Send Feedback
Initializes a new instance of the ToggleToolButton class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ToggleToolButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ToggleToolButton()

See Also

ToggleToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToggleToolButton Fields

[image] [image]

.NET ModelKit Suite ClassReference
ToggleToolButton Fields
ToggleToolButton Class See Also Send Feedback

The ToggleToolButton type exposes the following members.

Fields

Name | Description
DisabledContentProperty | Gets or sets disabled button state content. Dependency property.
TooltipTextProperty | Gets or sets the button text. Dependency property.

See Also

ToggleToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DisabledContentProperty Field

[image]

.NET ModelKit Suite ClassReference
ToggleToolButton..::.DisabledContentProperty Field
ToggleToolButton Class See Also Send Feedback
Gets or sets disabled button state content. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty DisabledContentProperty
Visual Basic (Declaration)
Public Shared ReadOnly DisabledContentProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DisabledContentProperty

See Also

ToggleToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


TooltipTextProperty Field

[image]

.NET ModelKit Suite ClassReference
ToggleToolButton..::.TooltipTextProperty Field
ToggleToolButton Class See Also Send Feedback
Gets or sets the button text. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty TooltipTextProperty
Visual Basic (Declaration)
Public Shared ReadOnly TooltipTextProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TooltipTextProperty

See Also

ToggleToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToggleToolButton Methods

[image] [image]

.NET ModelKit Suite ClassReference
ToggleToolButton Methods
ToggleToolButton Class See Also Send Feedback

The ToggleToolButton type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ToggleButton.)
OnClick | (Inherited from ToggleButton.)
OnContentChanged | (Inherited from ToggleButton.)
OnCreateAutomationPeer | (Inherited from ToggleButton.)
OnGotFocus | (Inherited from ButtonBase.)
OnIsPressedChanged | (Inherited from ButtonBase.)
OnKeyDown | (Inherited from ButtonBase.)
OnKeyUp | (Inherited from ButtonBase.)
OnLostFocus | (Inherited from ButtonBase.)
OnMouseEnter | (Inherited from ButtonBase.)
OnMouseLeave | (Inherited from ButtonBase.)
OnMouseLeftButtonDown | (Inherited from ButtonBase.)
OnMouseLeftButtonUp | (Inherited from ButtonBase.)
OnMouseMove | (Inherited from ButtonBase.)
OnToggle | (Inherited from ToggleButton.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | (Inherited from ToggleButton.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ToggleToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToggleToolButton Properties

[image] [image]

.NET ModelKit Suite ClassReference
ToggleToolButton Properties
ToggleToolButton Class See Also Send Feedback

The ToggleToolButton type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
ClickMode | (Inherited from ButtonBase.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledContent | Gets or sets disabled button state content.
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsChecked | (Inherited from ToggleButton.)
IsEnabled | (Inherited from Control.)
IsFocused | (Inherited from ButtonBase.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | (Inherited from ButtonBase.)
IsPressed | (Inherited from ButtonBase.)
IsTabStop | (Inherited from Control.)
IsThreeState | (Inherited from ToggleButton.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TooltipText | Gets or sets the button text.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ToggleToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DisabledContent Property

[image]

.NET ModelKit Suite ClassReference
ToggleToolButton..::.DisabledContent Property
ToggleToolButton Class See Also Send Feedback
Gets or sets disabled button state content.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Object DisabledContent { get; set; }
Visual Basic (Declaration)
Public Property DisabledContent As Object
Visual C++
public:
property Object^ DisabledContent {
    Object^ get ();
    void set (Object^ value);
}

See Also

ToggleToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


TooltipText Property

[image]

.NET ModelKit Suite ClassReference
ToggleToolButton..::.TooltipText Property
ToggleToolButton Class See Also Send Feedback
Gets or sets the button text.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipText { get; set; }
Visual Basic (Declaration)
Public Property TooltipText As String
Visual C++
public:
property String^ TooltipText {
    String^ get ();
    void set (String^ value);
}

See Also

ToggleToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToggleToolButton Events

[image] [image]

.NET ModelKit Suite ClassReference
ToggleToolButton Events
ToggleToolButton Class See Also Send Feedback

The ToggleToolButton type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Checked | (Inherited from ToggleButton.)
Click | (Inherited from ButtonBase.)
GotFocus | (Inherited from UIElement.)
Indeterminate | (Inherited from ToggleButton.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
Unchecked | (Inherited from ToggleButton.)

See Also

ToggleToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Tool Class

[image]

.NET ModelKit Suite ClassReference
Tool Class
Members See Also Send Feedback
An abstract class. It is basic class for all classes of tools which realize handling of ReportViewer special functionality.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract class Tool
Visual Basic (Declaration)
Public MustInherit Class Tool
Visual C++
public ref class Tool abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client..::.Tool
PerpetuumSoft.Reporting.Silverlight.Client..::.DisabledTool
PerpetuumSoft.Reporting.Silverlight.Client..::.StandardTool

See Also

Tool Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Tool Members

[image] [image]

.NET ModelKit Suite ClassReference
Tool Members
Tool Class Constructors Methods Properties See Also Send Feedback

The Tool type exposes the following members.

Constructors

Name | Description
Tool | Initializes a new instance of the Tool class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Handles keyboard key pressing.
KeyUp | Handles keyboard key releasing.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Handles mouse click.
MouseMove | Handles mouse pointer moving.
MouseUp | Handles mouse button release.
MouseWheel | Handles mouse scroll-wheel.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates active cursor.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager.

See Also

Tool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Tool Constructor

[image]

.NET ModelKit Suite ClassReference
Tool Constructor
Tool Class See Also Send Feedback
Initializes a new instance of the Tool class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Tool(
    ViewManager manager
)
Visual Basic (Declaration)
Public Sub New ( _
    manager As ViewManager _
)
Visual C++
public:
Tool(
    ViewManager^ manager
)

Parameters

manager
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ViewManager

See Also

Tool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Tool Methods

[image] [image]

.NET ModelKit Suite ClassReference
Tool Methods
Tool Class See Also Send Feedback

The Tool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
KeyDown | Handles keyboard key pressing.
KeyUp | Handles keyboard key releasing.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Handles mouse click.
MouseMove | Handles mouse pointer moving.
MouseUp | Handles mouse button release.
MouseWheel | Handles mouse scroll-wheel.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates active cursor.

See Also

Tool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


KeyDown Method

[image]

.NET ModelKit Suite ClassReference
Tool..::.KeyDown Method
Tool Class See Also Send Feedback
Handles keyboard key pressing.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void KeyDown(
    KeyEventArgs args
)
Visual Basic (Declaration)
Public MustOverride Sub KeyDown ( _
    args As KeyEventArgs _
)
Visual C++
public:
virtual void KeyDown(
    KeyEventArgs^ args
) abstract

Parameters

args
Type: System.Windows.Input..::.KeyEventArgs

See Also

Tool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


KeyUp Method

[image]

.NET ModelKit Suite ClassReference
Tool..::.KeyUp Method
Tool Class See Also Send Feedback
Handles keyboard key releasing.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void KeyUp(
    KeyEventArgs args
)
Visual Basic (Declaration)
Public MustOverride Sub KeyUp ( _
    args As KeyEventArgs _
)
Visual C++
public:
virtual void KeyUp(
    KeyEventArgs^ args
) abstract

Parameters

args
Type: System.Windows.Input..::.KeyEventArgs

See Also

Tool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseDown Method

[image]

.NET ModelKit Suite ClassReference
Tool..::.MouseDown Method
Tool Class See Also Send Feedback
Handles mouse click.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void MouseDown(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public MustOverride Sub MouseDown ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseDown(
    MouseEventArgs^ args
) abstract

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

Tool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseMove Method

[image]

.NET ModelKit Suite ClassReference
Tool..::.MouseMove Method
Tool Class See Also Send Feedback
Handles mouse pointer moving.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void MouseMove(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public MustOverride Sub MouseMove ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseMove(
    MouseEventArgs^ args
) abstract

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

Tool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseUp Method

[image]

.NET ModelKit Suite ClassReference
Tool..::.MouseUp Method
Tool Class See Also Send Feedback
Handles mouse button release.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void MouseUp(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public MustOverride Sub MouseUp ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseUp(
    MouseEventArgs^ args
) abstract

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

Tool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseWheel Method

[image]

.NET ModelKit Suite ClassReference
Tool..::.MouseWheel Method
Tool Class See Also Send Feedback
Handles mouse scroll-wheel.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void MouseWheel(
    double delta
)
Visual Basic (Declaration)
Public MustOverride Sub MouseWheel ( _
    delta As Double _
)
Visual C++
public:
virtual void MouseWheel(
    double delta
) abstract

Parameters

delta
Type: System..::.Double

See Also

Tool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


UpdateCursor Method

[image]

.NET ModelKit Suite ClassReference
Tool..::.UpdateCursor Method
Tool Class See Also Send Feedback
Updates active cursor.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public virtual void UpdateCursor()
Visual Basic (Declaration)
Public Overridable Sub UpdateCursor
Visual C++
public:
virtual void UpdateCursor()

See Also

Tool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Tool Properties

[image] [image]

.NET ModelKit Suite ClassReference
Tool Properties
Tool Class See Also Send Feedback

The Tool type exposes the following members.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager.

See Also

Tool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewManager Property

[image]

.NET ModelKit Suite ClassReference
Tool..::.ViewManager Property
Tool Class See Also Send Feedback
Gets ViewManager which is Report Viewer manager.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ViewManager ViewManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewManager As ViewManager
Visual C++
public:
property ViewManager^ ViewManager {
    ViewManager^ get ();
}

See Also

Tool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToolButton Class

[image]

.NET ModelKit Suite ClassReference
ToolButton Class
Members See Also Send Feedback
Gets or sets toolbar button control. Inherited from Button.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ToolButton : Button
Visual Basic (Declaration)
Public Class ToolButton _
    Inherits Button
Visual C++
public ref class ToolButton : public Button

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
System.Windows.Controls.Primitives..::.ButtonBase
System.Windows.Controls..::.Button
PerpetuumSoft.Reporting.Silverlight.Client..::.ToolButton

See Also

ToolButton Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToolButton Members

[image] [image]

.NET ModelKit Suite ClassReference
ToolButton Members
ToolButton Class Constructors Methods Fields Properties Events See Also Send Feedback

The ToolButton type exposes the following members.

Constructors

Name | Description
ToolButton | Initializes a new instance of the ToolButton class.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Button.)
OnClick | (Inherited from Button.)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from Button.)
OnGotFocus | (Inherited from ButtonBase.)
OnIsPressedChanged | (Inherited from ButtonBase.)
OnKeyDown | (Inherited from ButtonBase.)
OnKeyUp | (Inherited from ButtonBase.)
OnLostFocus | (Inherited from ButtonBase.)
OnMouseEnter | (Inherited from ButtonBase.)
OnMouseLeave | (Inherited from ButtonBase.)
OnMouseLeftButtonDown | (Inherited from ButtonBase.)
OnMouseLeftButtonUp | (Inherited from ButtonBase.)
OnMouseMove | (Inherited from ButtonBase.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
DisabledContentProperty | Gets or sets disabled button state content. Dependency property.
TooltipTextProperty | Gets or sets the button text. Dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
ClickMode | (Inherited from ButtonBase.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledContent | Gets or sets disabled button state content.
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsFocused | (Inherited from ButtonBase.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | (Inherited from ButtonBase.)
IsPressed | (Inherited from ButtonBase.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TooltipText | Gets or sets the button text.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Click | (Inherited from ButtonBase.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToolButton Constructor

[image]

.NET ModelKit Suite ClassReference
ToolButton Constructor
ToolButton Class See Also Send Feedback
Initializes a new instance of the ToolButton class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ToolButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ToolButton()

See Also

ToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToolButton Fields

[image] [image]

.NET ModelKit Suite ClassReference
ToolButton Fields
ToolButton Class See Also Send Feedback

The ToolButton type exposes the following members.

Fields

Name | Description
DisabledContentProperty | Gets or sets disabled button state content. Dependency property.
TooltipTextProperty | Gets or sets the button text. Dependency property.

See Also

ToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DisabledContentProperty Field

[image]

.NET ModelKit Suite ClassReference
ToolButton..::.DisabledContentProperty Field
ToolButton Class See Also Send Feedback
Gets or sets disabled button state content. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty DisabledContentProperty
Visual Basic (Declaration)
Public Shared ReadOnly DisabledContentProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DisabledContentProperty

See Also

ToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


TooltipTextProperty Field

[image]

.NET ModelKit Suite ClassReference
ToolButton..::.TooltipTextProperty Field
ToolButton Class See Also Send Feedback
Gets or sets the button text. Dependency property.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static readonly DependencyProperty TooltipTextProperty
Visual Basic (Declaration)
Public Shared ReadOnly TooltipTextProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TooltipTextProperty

See Also

ToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToolButton Methods

[image] [image]

.NET ModelKit Suite ClassReference
ToolButton Methods
ToolButton Class See Also Send Feedback

The ToolButton type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Button.)
OnClick | (Inherited from Button.)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from Button.)
OnGotFocus | (Inherited from ButtonBase.)
OnIsPressedChanged | (Inherited from ButtonBase.)
OnKeyDown | (Inherited from ButtonBase.)
OnKeyUp | (Inherited from ButtonBase.)
OnLostFocus | (Inherited from ButtonBase.)
OnMouseEnter | (Inherited from ButtonBase.)
OnMouseLeave | (Inherited from ButtonBase.)
OnMouseLeftButtonDown | (Inherited from ButtonBase.)
OnMouseLeftButtonUp | (Inherited from ButtonBase.)
OnMouseMove | (Inherited from ButtonBase.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToolButton Properties

[image] [image]

.NET ModelKit Suite ClassReference
ToolButton Properties
ToolButton Class See Also Send Feedback

The ToolButton type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
ClickMode | (Inherited from ButtonBase.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledContent | Gets or sets disabled button state content.
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsFocused | (Inherited from ButtonBase.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | (Inherited from ButtonBase.)
IsPressed | (Inherited from ButtonBase.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TooltipText | Gets or sets the button text.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DisabledContent Property

[image]

.NET ModelKit Suite ClassReference
ToolButton..::.DisabledContent Property
ToolButton Class See Also Send Feedback
Gets or sets disabled button state content.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Object DisabledContent { get; set; }
Visual Basic (Declaration)
Public Property DisabledContent As Object
Visual C++
public:
property Object^ DisabledContent {
    Object^ get ();
    void set (Object^ value);
}

See Also

ToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


TooltipText Property

[image]

.NET ModelKit Suite ClassReference
ToolButton..::.TooltipText Property
ToolButton Class See Also Send Feedback
Gets or sets the button text.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipText { get; set; }
Visual Basic (Declaration)
Public Property TooltipText As String
Visual C++
public:
property String^ TooltipText {
    String^ get ();
    void set (String^ value);
}

See Also

ToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToolButton Events

[image] [image]

.NET ModelKit Suite ClassReference
ToolButton Events
ToolButton Class See Also Send Feedback

The ToolButton type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Click | (Inherited from ButtonBase.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ToolButton Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToolSlider Class

[image]

.NET ModelKit Suite ClassReference
ToolSlider Class
Members See Also Send Feedback
Slider control for reports view scaling. Inherited from Slider.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ToolSlider : Slider
Visual Basic (Declaration)
Public Class ToolSlider _
    Inherits Slider
Visual C++
public ref class ToolSlider : public Slider

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls.Primitives..::.RangeBase
System.Windows.Controls..::.Slider
PerpetuumSoft.Reporting.Silverlight.Client..::.ToolSlider

See Also

ToolSlider Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToolSlider Members

[image] [image]

.NET ModelKit Suite ClassReference
ToolSlider Members
ToolSlider Class Constructors Methods Properties Events See Also Send Feedback

The ToolSlider type exposes the following members.

Constructors

Name | Description
ToolSlider | Initializes a new instance of the ToolSlider class.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides Slider..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from Slider.)
OnGotFocus | (Inherited from Slider.)
OnKeyDown | (Inherited from Slider.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Slider.)
OnMaximumChanged | (Inherited from Slider.)
OnMinimumChanged | (Inherited from Slider.)
OnMouseEnter | (Inherited from Slider.)
OnMouseLeave | (Inherited from Slider.)
OnMouseLeftButtonDown | (Inherited from Slider.)
OnMouseLeftButtonUp | (Inherited from Slider.)
OnMouseMove | (Inherited from Control.)
OnValueChanged | (Inherited from Slider.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | (Inherited from RangeBase.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDirectionReversed | (Inherited from Slider.)
IsEnabled | (Inherited from Control.)
IsFocused | (Inherited from Slider.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LargeChange | (Inherited from RangeBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | (Inherited from RangeBase.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | (Inherited from RangeBase.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Orientation | (Inherited from Slider.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SmallChange | (Inherited from RangeBase.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
Value | (Inherited from RangeBase.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
DragCompleted | Occurs when the slider's scroll box dragging is finished.
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ValueChanged | (Inherited from RangeBase.)

See Also

ToolSlider Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToolSlider Constructor

[image]

.NET ModelKit Suite ClassReference
ToolSlider Constructor
ToolSlider Class See Also Send Feedback
Initializes a new instance of the ToolSlider class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ToolSlider()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ToolSlider()

See Also

ToolSlider Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToolSlider Methods

[image] [image]

.NET ModelKit Suite ClassReference
ToolSlider Methods
ToolSlider Class See Also Send Feedback

The ToolSlider type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Overridden. See OnApplyTemplate()()(). (Overrides Slider..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from Slider.)
OnGotFocus | (Inherited from Slider.)
OnKeyDown | (Inherited from Slider.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Slider.)
OnMaximumChanged | (Inherited from Slider.)
OnMinimumChanged | (Inherited from Slider.)
OnMouseEnter | (Inherited from Slider.)
OnMouseLeave | (Inherited from Slider.)
OnMouseLeftButtonDown | (Inherited from Slider.)
OnMouseLeftButtonUp | (Inherited from Slider.)
OnMouseMove | (Inherited from Control.)
OnValueChanged | (Inherited from Slider.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | (Inherited from RangeBase.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ToolSlider Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


OnApplyTemplate Method

[image]

.NET ModelKit Suite ClassReference
ToolSlider..::.OnApplyTemplate Method
ToolSlider Class See Also Send Feedback
Overridden. See OnApplyTemplate()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

ToolSlider Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToolSlider Properties

[image] [image]

.NET ModelKit Suite ClassReference
ToolSlider Properties
ToolSlider Class See Also Send Feedback

The ToolSlider type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDirectionReversed | (Inherited from Slider.)
IsEnabled | (Inherited from Control.)
IsFocused | (Inherited from Slider.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LargeChange | (Inherited from RangeBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | (Inherited from RangeBase.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | (Inherited from RangeBase.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Orientation | (Inherited from Slider.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SmallChange | (Inherited from RangeBase.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
Value | (Inherited from RangeBase.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ToolSlider Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ToolSlider Events

[image] [image]

.NET ModelKit Suite ClassReference
ToolSlider Events
ToolSlider Class See Also Send Feedback

The ToolSlider type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
DragCompleted | Occurs when the slider's scroll box dragging is finished.
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ValueChanged | (Inherited from RangeBase.)

See Also

ToolSlider Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DragCompleted Event

[image]

.NET ModelKit Suite ClassReference
ToolSlider..::.DragCompleted Event
ToolSlider Class See Also Send Feedback
Occurs when the slider's scroll box dragging is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler DragCompleted
Visual Basic (Declaration)
Public Event DragCompleted As EventHandler
Visual C++
public:
 event EventHandler^ DragCompleted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ToolSlider Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewManager Class

[image]

.NET ModelKit Suite ClassReference
ViewManager Class
Members See Also Send Feedback
Report Viewer manager.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ViewManager
Visual Basic (Declaration)
Public Class ViewManager
Visual C++
public ref class ViewManager

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client..::.ViewManager

See Also

ViewManager Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewManager Members

[image] [image]

.NET ModelKit Suite ClassReference
ViewManager Members
ViewManager Class Methods Properties See Also Send Feedback

The ViewManager type exposes the following members.

Methods

Name | Description
AddService | Registers service.
Backward | Returns the view state to the previous state saved in history.
BeginAnimation | Starts animation.
ClearHistory | Clears the history of saved states.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Forward | Switches the view state to the next state saved in history.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetService<(Of <(T>)>) |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrintNotFound | Shows the message which state that the report was not found.
RememberViewModel | Saves the current view state.
SetViewModel | Sets report view model.
StopAnimation | Stops animation.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateView | Updates report view.

Properties

Name | Description
CanBackward | Gets the property which defines possibility of switching backward through display state history.
CanForward | Gets the property which defines possibility of switching forward through display state history.
FontsManager | Gets FontsManager which is fonts manager.
Tool | Gets or sets Tool which is active tool.
View | Gets or sets IView which is the element used for report view.
ViewModel | Gets ViewModel which is report view model.

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewManager Methods

[image] [image]

.NET ModelKit Suite ClassReference
ViewManager Methods
ViewManager Class See Also Send Feedback

The ViewManager type exposes the following members.

Methods

Name | Description
AddService | Registers service.
Backward | Returns the view state to the previous state saved in history.
BeginAnimation | Starts animation.
ClearHistory | Clears the history of saved states.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Forward | Switches the view state to the next state saved in history.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetService<(Of <(T>)>) |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrintNotFound | Shows the message which state that the report was not found.
RememberViewModel | Saves the current view state.
SetViewModel | Sets report view model.
StopAnimation | Stops animation.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateView | Updates report view.

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


AddService Method

[image]

.NET ModelKit Suite ClassReference
ViewManager..::.AddService Method
ViewManager Class See Also Send Feedback
Registers service.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void AddService(
    Type type,
    Object service
)
Visual Basic (Declaration)
Public Sub AddService ( _
    type As Type, _
    service As Object _
)
Visual C++
public:
void AddService(
    Type^ type,
    Object^ service
)

Parameters

type
Type: System..::.Type
service
Type: System..::.Object

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Backward Method

[image]

.NET ModelKit Suite ClassReference
ViewManager..::.Backward Method
ViewManager Class See Also Send Feedback
Returns the view state to the previous state saved in history.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void Backward()
Visual Basic (Declaration)
Public Sub Backward
Visual C++
public:
void Backward()

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


BeginAnimation Method

[image]

.NET ModelKit Suite ClassReference
ViewManager..::.BeginAnimation Method
ViewManager Class See Also Send Feedback
Starts animation.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void BeginAnimation(
    Storyboard storyboard
)
Visual Basic (Declaration)
Public Sub BeginAnimation ( _
    storyboard As Storyboard _
)
Visual C++
public:
void BeginAnimation(
    Storyboard^ storyboard
)

Parameters

storyboard
Type: System.Windows.Media.Animation..::.Storyboard

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ClearHistory Method

[image]

.NET ModelKit Suite ClassReference
ViewManager..::.ClearHistory Method
ViewManager Class See Also Send Feedback
Clears the history of saved states.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void ClearHistory()
Visual Basic (Declaration)
Public Sub ClearHistory
Visual C++
public:
void ClearHistory()

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Forward Method

[image]

.NET ModelKit Suite ClassReference
ViewManager..::.Forward Method
ViewManager Class See Also Send Feedback
Switches the view state to the next state saved in history.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void Forward()
Visual Basic (Declaration)
Public Sub Forward
Visual C++
public:
void Forward()

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


GetService(T) Method

[image]

.NET ModelKit Suite ClassReference
ViewManager..::.GetService<(Of <(T>)>) Method
ViewManager Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Silverlight.Client.ViewManager.GetService``1]

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public T GetService<T>()
where T : class
Visual Basic (Declaration)
Public Function GetService(Of T As Class) As T
Visual C++
public:
generic<typename T>
where T : ref class
T GetService()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:PerpetuumSoft.Reporting.Silverlight.Client.ViewManager.GetService``1"]

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PrintNotFound Method

[image]

.NET ModelKit Suite ClassReference
ViewManager..::.PrintNotFound Method
ViewManager Class See Also Send Feedback
Shows the message which state that the report was not found.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void PrintNotFound()
Visual Basic (Declaration)
Public Sub PrintNotFound
Visual C++
public:
void PrintNotFound()

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


RememberViewModel Method

[image]

.NET ModelKit Suite ClassReference
ViewManager..::.RememberViewModel Method
ViewManager Class See Also Send Feedback
Saves the current view state.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void RememberViewModel()
Visual Basic (Declaration)
Public Sub RememberViewModel
Visual C++
public:
void RememberViewModel()

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


SetViewModel Method

[image]

.NET ModelKit Suite ClassReference
ViewManager..::.SetViewModel Method
ViewManager Class See Also Send Feedback
Sets report view model.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void SetViewModel(
    ViewModel viewModel,
    bool useAnimation
)
Visual Basic (Declaration)
Public Sub SetViewModel ( _
    viewModel As ViewModel, _
    useAnimation As Boolean _
)
Visual C++
public:
void SetViewModel(
    ViewModel^ viewModel,
    bool useAnimation
)

Parameters

viewModel
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ViewModel
useAnimation
Type: System..::.Boolean

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


StopAnimation Method

[image]

.NET ModelKit Suite ClassReference
ViewManager..::.StopAnimation Method
ViewManager Class See Also Send Feedback
Stops animation.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void StopAnimation()
Visual Basic (Declaration)
Public Sub StopAnimation
Visual C++
public:
void StopAnimation()

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


UpdateView Method

[image]

.NET ModelKit Suite ClassReference
ViewManager..::.UpdateView Method
ViewManager Class See Also Send Feedback
Updates report view.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void UpdateView(
    bool useAnimation
)
Visual Basic (Declaration)
Public Sub UpdateView ( _
    useAnimation As Boolean _
)
Visual C++
public:
void UpdateView(
    bool useAnimation
)

Parameters

useAnimation
Type: System..::.Boolean

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewManager Properties

[image] [image]

.NET ModelKit Suite ClassReference
ViewManager Properties
ViewManager Class See Also Send Feedback

The ViewManager type exposes the following members.

Properties

Name | Description
CanBackward | Gets the property which defines possibility of switching backward through display state history.
CanForward | Gets the property which defines possibility of switching forward through display state history.
FontsManager | Gets FontsManager which is fonts manager.
Tool | Gets or sets Tool which is active tool.
View | Gets or sets IView which is the element used for report view.
ViewModel | Gets ViewModel which is report view model.

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CanBackward Property

[image]

.NET ModelKit Suite ClassReference
ViewManager..::.CanBackward Property
ViewManager Class See Also Send Feedback
Gets the property which defines possibility of switching backward through display state history.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool CanBackward { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanBackward As Boolean
Visual C++
public:
property bool CanBackward {
    bool get ();
}

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CanForward Property

[image]

.NET ModelKit Suite ClassReference
ViewManager..::.CanForward Property
ViewManager Class See Also Send Feedback
Gets the property which defines possibility of switching forward through display state history.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool CanForward { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanForward As Boolean
Visual C++
public:
property bool CanForward {
    bool get ();
}

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


FontsManager Property

[image]

.NET ModelKit Suite ClassReference
ViewManager..::.FontsManager Property
ViewManager Class See Also Send Feedback
Gets FontsManager which is fonts manager.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public FontsManager FontsManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property FontsManager As FontsManager
Visual C++
public:
property FontsManager^ FontsManager {
    FontsManager^ get ();
}

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Tool Property

[image]

.NET ModelKit Suite ClassReference
ViewManager..::.Tool Property
ViewManager Class See Also Send Feedback
Gets or sets Tool which is active tool.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Tool Tool { get; set; }
Visual Basic (Declaration)
Public Property Tool As Tool
Visual C++
public:
property Tool^ Tool {
    Tool^ get ();
    void set (Tool^ value);
}

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


View Property

[image]

.NET ModelKit Suite ClassReference
ViewManager..::.View Property
ViewManager Class See Also Send Feedback
Gets or sets IView which is the element used for report view.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public IView View { get; set; }
Visual Basic (Declaration)
Public Property View As IView
Visual C++
public:
property IView^ View {
    IView^ get ();
    void set (IView^ value);
}

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewModel Property

[image]

.NET ModelKit Suite ClassReference
ViewManager..::.ViewModel Property
ViewManager Class See Also Send Feedback
Gets ViewModel which is report view model.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ViewModel ViewModel { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewModel As ViewModel
Visual C++
public:
property ViewModel^ ViewModel {
    ViewModel^ get ();
}

See Also

ViewManager Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewModel Class

[image]

.NET ModelKit Suite ClassReference
ViewModel Class
Members See Also Send Feedback
Report view model.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract class ViewModel
Visual Basic (Declaration)
Public MustInherit Class ViewModel
Visual C++
public ref class ViewModel abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client..::.ViewModel
PerpetuumSoft.Reporting.Silverlight.Client..::.DocumentViewModel

See Also

ViewModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewModel Members

[image] [image]

.NET ModelKit Suite ClassReference
ViewModel Members
ViewModel Class Constructors Methods Fields Properties See Also Send Feedback

The ViewModel type exposes the following members.

Constructors

Name | Description
ViewModel | Initializes a new instance of the ViewModel class.

Methods

Name | Description
AssignParameters | Sets the model display parameters subject to the previous active model.
ChangeZoom | Overloaded.
Clone | Creates object clone.
DocumentEnd | Performs switching to the end of the report.
DocumentHome | Performs switching to the beginning of the report.
EnsureVisible | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GoToFirstPage | Initiates switching to the first page.
GoToLastPage | Initiates switching to the last page.
GoToNextPage | Initiates switching to the next page.
GoToPrevPage | Initiates switching to the previous page.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus.
PageDown | Performs page scroll down.
PageEnd | Performs switching to the bottom of the page.
PageHome | Performs switching to the top of the page.
PageUp | Performs page scroll up.
PanView | Performs report scrolling.
ResetSearchResult | Resets search results.
ShowSearchResult | Shows area with text search results.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateContent |
ZoomIn | Overloaded.
ZoomOut | Overloaded.
ZoomWindow | Performs scaling by the selected area.

Fields

Name | Description
MaxZoom | Gets max scale.
MinZoom | Gets min scale.

Properties

Name | Description
CanGoToNextPage | Gets the property which indicates if it is possible to switch to the next page.
CanGoToPrevPage | Gets the property which indicates if it is possible to switch to the previous page.
ClientSize | Gets the client area size.
HScrollBarActive | Gets the property which indicates if horizontal scrolling is active.
HScrollBarLarge | Gets value to be added to value property when the scroll box is moved at a large distance.
HScrollBarMaximum | Gets max value of the [T:System.Windows.Controls. Primitives.RangeBase.Value] scrolling control.
HScrollBarPosition | Gets or sets the scroll box position on horizontal scroll bar.
HScrollBarSmall | Gets value to be added to value property when the scroll box is moved at a small distance.
HScrollBarViewPort | Gets a part of visible content of horizontal scroll bar.
PageNumber | Gets or sets page number.
View | Gets IView which is report preview control.
ViewManager | Gets ViewManager which is Report Viewer manager.
VScrollBarActive | Gets the property which indicates if vertical scroll bar is active.
VScrollBarLarge | Gets value to be added to value property when the scroll box is moved at a large distance.
VScrollBarMaximum | Gets max value of the [T:System.Windows.Controls. Primitives.RangeBase.Value] scroll bar.
VScrollBarPosition | Gets or sets scroll box position on vertical scroll bar.
VScrollBarSmall | Gets value to be added to value property when the scroll box is moved at a small distance.
VScrollBarViewPort | Gets a part of visible content of vertical scroll bar.
Zoom | Gets or sets Zoom which is report scale.

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewModel Constructor

[image]

.NET ModelKit Suite ClassReference
ViewModel Constructor
ViewModel Class See Also Send Feedback
Initializes a new instance of the ViewModel class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ViewModel(
    ViewManager viewManager
)
Visual Basic (Declaration)
Public Sub New ( _
    viewManager As ViewManager _
)
Visual C++
public:
ViewModel(
    ViewManager^ viewManager
)

Parameters

viewManager
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ViewManager

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewModel Fields

[image] [image]

.NET ModelKit Suite ClassReference
ViewModel Fields
ViewModel Class See Also Send Feedback

The ViewModel type exposes the following members.

Fields

Name | Description
MaxZoom | Gets max scale.
MinZoom | Gets min scale.

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MaxZoom Field

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.MaxZoom Field
ViewModel Class See Also Send Feedback
Gets max scale.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const double MaxZoom
Visual Basic (Declaration)
Public Const MaxZoom As Double
Visual C++
public:
literal double MaxZoom

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MinZoom Field

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.MinZoom Field
ViewModel Class See Also Send Feedback
Gets min scale.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const double MinZoom
Visual Basic (Declaration)
Public Const MinZoom As Double
Visual C++
public:
literal double MinZoom

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewModel Methods

[image] [image]

.NET ModelKit Suite ClassReference
ViewModel Methods
ViewModel Class See Also Send Feedback

The ViewModel type exposes the following members.

Methods

Name | Description
AssignParameters | Sets the model display parameters subject to the previous active model.
ChangeZoom | Overloaded.
Clone | Creates object clone.
DocumentEnd | Performs switching to the end of the report.
DocumentHome | Performs switching to the beginning of the report.
EnsureVisible | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GoToFirstPage | Initiates switching to the first page.
GoToLastPage | Initiates switching to the last page.
GoToNextPage | Initiates switching to the next page.
GoToPrevPage | Initiates switching to the previous page.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus.
PageDown | Performs page scroll down.
PageEnd | Performs switching to the bottom of the page.
PageHome | Performs switching to the top of the page.
PageUp | Performs page scroll up.
PanView | Performs report scrolling.
ResetSearchResult | Resets search results.
ShowSearchResult | Shows area with text search results.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateContent |
ZoomIn | Overloaded.
ZoomOut | Overloaded.
ZoomWindow | Performs scaling by the selected area.

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


AssignParameters Method

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.AssignParameters Method
ViewModel Class See Also Send Feedback
Sets the model display parameters subject to the previous active model.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void AssignParameters(
    ViewModel previousModel
)
Visual Basic (Declaration)
Public Sub AssignParameters ( _
    previousModel As ViewModel _
)
Visual C++
public:
void AssignParameters(
    ViewModel^ previousModel
)

Parameters

previousModel
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ViewModel

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ChangeZoom Method

[image] [image]

.NET ModelKit Suite ClassReference
ViewModel..::.ChangeZoom Method
ViewModel Class See Also Send Feedback

Overload List

Name | Description
ChangeZoom(ZoomMode, Boolean) | Performs scale and scale mode changing.
ChangeZoom(Double, Boolean) | Performs scale and scale mode changing.
ChangeZoom(Point, Double, Boolean) | Performs scale and scale mode changing.

See Also

ViewModel Class
ViewModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ChangeZoom Method (ZoomMode, Boolean)

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.ChangeZoom Method (ZoomMode, Boolean)
ViewModel Class See Also Send Feedback
Performs scale and scale mode changing.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void ChangeZoom(
    ZoomMode mode,
    bool useAnimation
)
Visual Basic (Declaration)
Public MustOverride Sub ChangeZoom ( _
    mode As ZoomMode, _
    useAnimation As Boolean _
)
Visual C++
public:
virtual void ChangeZoom(
    ZoomMode mode,
    bool useAnimation
) abstract

Parameters

mode
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ZoomMode
useAnimation
Type: System..::.Boolean

See Also

ViewModel Class
ChangeZoom Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ChangeZoom Method (Double, Boolean)

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.ChangeZoom Method (Double, Boolean)
ViewModel Class See Also Send Feedback
Performs scale and scale mode changing.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void ChangeZoom(
    double scale,
    bool useAnimation
)
Visual Basic (Declaration)
Public Sub ChangeZoom ( _
    scale As Double, _
    useAnimation As Boolean _
)
Visual C++
public:
void ChangeZoom(
    double scale,
    bool useAnimation
)

Parameters

scale
Type: System..::.Double
useAnimation
Type: System..::.Boolean

See Also

ViewModel Class
ChangeZoom Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ChangeZoom Method (Point, Double, Boolean)

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.ChangeZoom Method (Point, Double, Boolean)
ViewModel Class See Also Send Feedback
Performs scale and scale mode changing.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void ChangeZoom(
    Point center,
    double scale,
    bool useAnimation
)
Visual Basic (Declaration)
Public MustOverride Sub ChangeZoom ( _
    center As Point, _
    scale As Double, _
    useAnimation As Boolean _
)
Visual C++
public:
virtual void ChangeZoom(
    Point center,
    double scale,
    bool useAnimation
) abstract

Parameters

center
Type: System.Windows..::.Point
scale
Type: System..::.Double
useAnimation
Type: System..::.Boolean

See Also

ViewModel Class
ChangeZoom Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Clone Method

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.Clone Method
ViewModel Class See Also Send Feedback
Creates object clone.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract ViewModel Clone()
Visual Basic (Declaration)
Public MustOverride Function Clone As ViewModel
Visual C++
public:
virtual ViewModel^ Clone() abstract

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentEnd Method

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.DocumentEnd Method
ViewModel Class See Also Send Feedback
Performs switching to the end of the report.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void DocumentEnd()
Visual Basic (Declaration)
Public MustOverride Sub DocumentEnd
Visual C++
public:
virtual void DocumentEnd() abstract

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


DocumentHome Method

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.DocumentHome Method
ViewModel Class See Also Send Feedback
Performs switching to the beginning of the report.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void DocumentHome()
Visual Basic (Declaration)
Public MustOverride Sub DocumentHome
Visual C++
public:
virtual void DocumentHome() abstract

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


EnsureVisible Method

[image] [image]

.NET ModelKit Suite ClassReference
ViewModel..::.EnsureVisible Method
ViewModel Class See Also Send Feedback

Overload List

Name | Description
EnsureVisible(ReportRegion) | Shifts the visible area of the screen to guarantee that the specified report is visible.
EnsureVisible(ReportRegion, Boolean) | Shifts the visible area of the screen to guarantee that the specified report is visible.

See Also

ViewModel Class
ViewModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


EnsureVisible Method (ReportRegion)

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.EnsureVisible Method (ReportRegion)
ViewModel Class See Also Send Feedback
Shifts the visible area of the screen to guarantee that the specified report is visible.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void EnsureVisible(
    ReportRegion region
)
Visual Basic (Declaration)
Public Sub EnsureVisible ( _
    region As ReportRegion _
)
Visual C++
public:
void EnsureVisible(
    ReportRegion region
)

Parameters

region
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ReportRegion

See Also

ViewModel Class
EnsureVisible Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


EnsureVisible Method (ReportRegion, Boolean)

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.EnsureVisible Method (ReportRegion, Boolean)
ViewModel Class See Also Send Feedback
Shifts the visible area of the screen to guarantee that the specified report is visible.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void EnsureVisible(
    ReportRegion region,
    bool alignTop
)
Visual Basic (Declaration)
Public MustOverride Sub EnsureVisible ( _
    region As ReportRegion, _
    alignTop As Boolean _
)
Visual C++
public:
virtual void EnsureVisible(
    ReportRegion region,
    bool alignTop
) abstract

Parameters

region
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ReportRegion
alignTop
Type: System..::.Boolean

See Also

ViewModel Class
EnsureVisible Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


GoToFirstPage Method

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.GoToFirstPage Method
ViewModel Class See Also Send Feedback
Initiates switching to the first page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void GoToFirstPage()
Visual Basic (Declaration)
Public MustOverride Sub GoToFirstPage
Visual C++
public:
virtual void GoToFirstPage() abstract

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


GoToLastPage Method

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.GoToLastPage Method
ViewModel Class See Also Send Feedback
Initiates switching to the last page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void GoToLastPage()
Visual Basic (Declaration)
Public MustOverride Sub GoToLastPage
Visual C++
public:
virtual void GoToLastPage() abstract

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


GoToNextPage Method

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.GoToNextPage Method
ViewModel Class See Also Send Feedback
Initiates switching to the next page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void GoToNextPage()
Visual Basic (Declaration)
Public MustOverride Sub GoToNextPage
Visual C++
public:
virtual void GoToNextPage() abstract

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


GoToPrevPage Method

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.GoToPrevPage Method
ViewModel Class See Also Send Feedback
Initiates switching to the previous page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void GoToPrevPage()
Visual Basic (Declaration)
Public MustOverride Sub GoToPrevPage
Visual C++
public:
virtual void GoToPrevPage() abstract

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseWheel Method

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.MouseWheel Method
ViewModel Class See Also Send Feedback
Occurs when the mouse wheel moves while the control has focus.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void MouseWheel(
    double delta
)
Visual Basic (Declaration)
Public MustOverride Sub MouseWheel ( _
    delta As Double _
)
Visual C++
public:
virtual void MouseWheel(
    double delta
) abstract

Parameters

delta
Type: System..::.Double

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageDown Method

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.PageDown Method
ViewModel Class See Also Send Feedback
Performs page scroll down.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void PageDown()
Visual Basic (Declaration)
Public MustOverride Sub PageDown
Visual C++
public:
virtual void PageDown() abstract

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageEnd Method

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.PageEnd Method
ViewModel Class See Also Send Feedback
Performs switching to the bottom of the page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void PageEnd()
Visual Basic (Declaration)
Public MustOverride Sub PageEnd
Visual C++
public:
virtual void PageEnd() abstract

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageHome Method

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.PageHome Method
ViewModel Class See Also Send Feedback
Performs switching to the top of the page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void PageHome()
Visual Basic (Declaration)
Public MustOverride Sub PageHome
Visual C++
public:
virtual void PageHome() abstract

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageUp Method

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.PageUp Method
ViewModel Class See Also Send Feedback
Performs page scroll up.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void PageUp()
Visual Basic (Declaration)
Public MustOverride Sub PageUp
Visual C++
public:
virtual void PageUp() abstract

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PanView Method

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.PanView Method
ViewModel Class See Also Send Feedback
Performs report scrolling.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void PanView(
    Point point
)
Visual Basic (Declaration)
Public MustOverride Sub PanView ( _
    point As Point _
)
Visual C++
public:
virtual void PanView(
    Point point
) abstract

Parameters

point
Type: System.Windows..::.Point

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ResetSearchResult Method

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.ResetSearchResult Method
ViewModel Class See Also Send Feedback
Resets search results.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void ResetSearchResult()
Visual Basic (Declaration)
Public MustOverride Sub ResetSearchResult
Visual C++
public:
virtual void ResetSearchResult() abstract

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ShowSearchResult Method

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.ShowSearchResult Method
ViewModel Class See Also Send Feedback
Shows area with text search results.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void ShowSearchResult(
    ReportRegion region
)
Visual Basic (Declaration)
Public MustOverride Sub ShowSearchResult ( _
    region As ReportRegion _
)
Visual C++
public:
virtual void ShowSearchResult(
    ReportRegion region
) abstract

Parameters

region
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ReportRegion

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


UpdateContent Method

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.UpdateContent Method
ViewModel Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Silverlight.Client.ViewModel.UpdateContent(PerpetuumSoft.Reporting.Silverlight.Client.ViewModel,System.Boolean)]

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected internal abstract void UpdateContent(
    ViewModel prevViewModel,
    bool useAnimation
)
Visual Basic (Declaration)
Protected Friend MustOverride Sub UpdateContent ( _
    prevViewModel As ViewModel, _
    useAnimation As Boolean _
)
Visual C++
protected public:
virtual void UpdateContent(
    ViewModel^ prevViewModel,
    bool useAnimation
) abstract

Parameters

prevViewModel
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ViewModel
useAnimation
Type: System..::.Boolean

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomIn Method

[image] [image]

.NET ModelKit Suite ClassReference
ViewModel..::.ZoomIn Method
ViewModel Class See Also Send Feedback

Overload List

Name | Description
ZoomIn(Boolean) | Performs zoom in.
ZoomIn(Point, Boolean) | Performs zoom in.

See Also

ViewModel Class
ViewModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomIn Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.ZoomIn Method (Boolean)
ViewModel Class See Also Send Feedback
Performs zoom in.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void ZoomIn(
    bool useAnimation
)
Visual Basic (Declaration)
Public Sub ZoomIn ( _
    useAnimation As Boolean _
)
Visual C++
public:
void ZoomIn(
    bool useAnimation
)

Parameters

useAnimation
Type: System..::.Boolean

See Also

ViewModel Class
ZoomIn Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomIn Method (Point, Boolean)

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.ZoomIn Method (Point, Boolean)
ViewModel Class See Also Send Feedback
Performs zoom in.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void ZoomIn(
    Point center,
    bool useAnimation
)
Visual Basic (Declaration)
Public Sub ZoomIn ( _
    center As Point, _
    useAnimation As Boolean _
)
Visual C++
public:
void ZoomIn(
    Point center,
    bool useAnimation
)

Parameters

center
Type: System.Windows..::.Point
useAnimation
Type: System..::.Boolean

See Also

ViewModel Class
ZoomIn Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomOut Method

[image] [image]

.NET ModelKit Suite ClassReference
ViewModel..::.ZoomOut Method
ViewModel Class See Also Send Feedback

Overload List

Name | Description
ZoomOut(Boolean) | Performs zoom out.
ZoomOut(Point, Boolean) | Performs zoom out.

See Also

ViewModel Class
ViewModel Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomOut Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.ZoomOut Method (Boolean)
ViewModel Class See Also Send Feedback
Performs zoom out.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void ZoomOut(
    bool useAnimation
)
Visual Basic (Declaration)
Public Sub ZoomOut ( _
    useAnimation As Boolean _
)
Visual C++
public:
void ZoomOut(
    bool useAnimation
)

Parameters

useAnimation
Type: System..::.Boolean

See Also

ViewModel Class
ZoomOut Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomOut Method (Point, Boolean)

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.ZoomOut Method (Point, Boolean)
ViewModel Class See Also Send Feedback
Performs zoom out.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void ZoomOut(
    Point center,
    bool useAnimation
)
Visual Basic (Declaration)
Public Sub ZoomOut ( _
    center As Point, _
    useAnimation As Boolean _
)
Visual C++
public:
void ZoomOut(
    Point center,
    bool useAnimation
)

Parameters

center
Type: System.Windows..::.Point
useAnimation
Type: System..::.Boolean

See Also

ViewModel Class
ZoomOut Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomWindow Method

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.ZoomWindow Method
ViewModel Class See Also Send Feedback
Performs scaling by the selected area.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract void ZoomWindow(
    Rect rect,
    bool useAnimation
)
Visual Basic (Declaration)
Public MustOverride Sub ZoomWindow ( _
    rect As Rect, _
    useAnimation As Boolean _
)
Visual C++
public:
virtual void ZoomWindow(
    Rect rect,
    bool useAnimation
) abstract

Parameters

rect
Type: System.Windows..::.Rect
useAnimation
Type: System..::.Boolean

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewModel Properties

[image] [image]

.NET ModelKit Suite ClassReference
ViewModel Properties
ViewModel Class See Also Send Feedback

The ViewModel type exposes the following members.

Properties

Name | Description
CanGoToNextPage | Gets the property which indicates if it is possible to switch to the next page.
CanGoToPrevPage | Gets the property which indicates if it is possible to switch to the previous page.
ClientSize | Gets the client area size.
HScrollBarActive | Gets the property which indicates if horizontal scrolling is active.
HScrollBarLarge | Gets value to be added to value property when the scroll box is moved at a large distance.
HScrollBarMaximum | Gets max value of the [T:System.Windows.Controls. Primitives.RangeBase.Value] scrolling control.
HScrollBarPosition | Gets or sets the scroll box position on horizontal scroll bar.
HScrollBarSmall | Gets value to be added to value property when the scroll box is moved at a small distance.
HScrollBarViewPort | Gets a part of visible content of horizontal scroll bar.
PageNumber | Gets or sets page number.
View | Gets IView which is report preview control.
ViewManager | Gets ViewManager which is Report Viewer manager.
VScrollBarActive | Gets the property which indicates if vertical scroll bar is active.
VScrollBarLarge | Gets value to be added to value property when the scroll box is moved at a large distance.
VScrollBarMaximum | Gets max value of the [T:System.Windows.Controls. Primitives.RangeBase.Value] scroll bar.
VScrollBarPosition | Gets or sets scroll box position on vertical scroll bar.
VScrollBarSmall | Gets value to be added to value property when the scroll box is moved at a small distance.
VScrollBarViewPort | Gets a part of visible content of vertical scroll bar.
Zoom | Gets or sets Zoom which is report scale.

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CanGoToNextPage Property

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.CanGoToNextPage Property
ViewModel Class See Also Send Feedback
Gets the property which indicates if it is possible to switch to the next page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract bool CanGoToNextPage { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property CanGoToNextPage As Boolean
Visual C++
public:
virtual property bool CanGoToNextPage {
    bool get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


CanGoToPrevPage Property

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.CanGoToPrevPage Property
ViewModel Class See Also Send Feedback
Gets the property which indicates if it is possible to switch to the previous page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract bool CanGoToPrevPage { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property CanGoToPrevPage As Boolean
Visual C++
public:
virtual property bool CanGoToPrevPage {
    bool get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ClientSize Property

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.ClientSize Property
ViewModel Class See Also Send Feedback
Gets the client area size.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected Size ClientSize { get; }
Visual Basic (Declaration)
Protected ReadOnly Property ClientSize As Size
Visual C++
protected:
property Size ClientSize {
    Size get ();
}

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


HScrollBarActive Property

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.HScrollBarActive Property
ViewModel Class See Also Send Feedback
Gets the property which indicates if horizontal scrolling is active.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract bool HScrollBarActive { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property HScrollBarActive As Boolean
Visual C++
public:
virtual property bool HScrollBarActive {
    bool get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


HScrollBarLarge Property

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.HScrollBarLarge Property
ViewModel Class See Also Send Feedback
Gets value to be added to value property when the scroll box is moved at a large distance.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract double HScrollBarLarge { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property HScrollBarLarge As Double
Visual C++
public:
virtual property double HScrollBarLarge {
    double get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


HScrollBarMaximum Property

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.HScrollBarMaximum Property
ViewModel Class See Also Send Feedback
Gets max value of the [T:System.Windows.Controls. Primitives.RangeBase.Value] scrolling control.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract double HScrollBarMaximum { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property HScrollBarMaximum As Double
Visual C++
public:
virtual property double HScrollBarMaximum {
    double get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


HScrollBarPosition Property

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.HScrollBarPosition Property
ViewModel Class See Also Send Feedback
Gets or sets the scroll box position on horizontal scroll bar.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract double HScrollBarPosition { get; set; }
Visual Basic (Declaration)
Public MustOverride Property HScrollBarPosition As Double
Visual C++
public:
virtual property double HScrollBarPosition {
    double get () abstract;
    void set (double value) abstract;
}

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


HScrollBarSmall Property

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.HScrollBarSmall Property
ViewModel Class See Also Send Feedback
Gets value to be added to value property when the scroll box is moved at a small distance.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract double HScrollBarSmall { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property HScrollBarSmall As Double
Visual C++
public:
virtual property double HScrollBarSmall {
    double get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


HScrollBarViewPort Property

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.HScrollBarViewPort Property
ViewModel Class See Also Send Feedback
Gets a part of visible content of horizontal scroll bar.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract double HScrollBarViewPort { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property HScrollBarViewPort As Double
Visual C++
public:
virtual property double HScrollBarViewPort {
    double get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageNumber Property

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.PageNumber Property
ViewModel Class See Also Send Feedback
Gets or sets page number.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract int PageNumber { get; set; }
Visual Basic (Declaration)
Public MustOverride Property PageNumber As Integer
Visual C++
public:
virtual property int PageNumber {
    int get () abstract;
    void set (int value) abstract;
}

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


View Property

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.View Property
ViewModel Class See Also Send Feedback
Gets IView which is report preview control.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public IView View { get; }
Visual Basic (Declaration)
Public ReadOnly Property View As IView
Visual C++
public:
property IView^ View {
    IView^ get ();
}

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewManager Property

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.ViewManager Property
ViewModel Class See Also Send Feedback
Gets ViewManager which is Report Viewer manager.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ViewManager ViewManager { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewManager As ViewManager
Visual C++
public:
property ViewManager^ ViewManager {
    ViewManager^ get ();
}

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


VScrollBarActive Property

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.VScrollBarActive Property
ViewModel Class See Also Send Feedback
Gets the property which indicates if vertical scroll bar is active.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract bool VScrollBarActive { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property VScrollBarActive As Boolean
Visual C++
public:
virtual property bool VScrollBarActive {
    bool get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


VScrollBarLarge Property

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.VScrollBarLarge Property
ViewModel Class See Also Send Feedback
Gets value to be added to value property when the scroll box is moved at a large distance.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract double VScrollBarLarge { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property VScrollBarLarge As Double
Visual C++
public:
virtual property double VScrollBarLarge {
    double get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


VScrollBarMaximum Property

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.VScrollBarMaximum Property
ViewModel Class See Also Send Feedback
Gets max value of the [T:System.Windows.Controls. Primitives.RangeBase.Value] scroll bar.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract double VScrollBarMaximum { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property VScrollBarMaximum As Double
Visual C++
public:
virtual property double VScrollBarMaximum {
    double get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


VScrollBarPosition Property

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.VScrollBarPosition Property
ViewModel Class See Also Send Feedback
Gets or sets scroll box position on vertical scroll bar.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract double VScrollBarPosition { get; set; }
Visual Basic (Declaration)
Public MustOverride Property VScrollBarPosition As Double
Visual C++
public:
virtual property double VScrollBarPosition {
    double get () abstract;
    void set (double value) abstract;
}

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


VScrollBarSmall Property

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.VScrollBarSmall Property
ViewModel Class See Also Send Feedback
Gets value to be added to value property when the scroll box is moved at a small distance.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract double VScrollBarSmall { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property VScrollBarSmall As Double
Visual C++
public:
virtual property double VScrollBarSmall {
    double get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


VScrollBarViewPort Property

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.VScrollBarViewPort Property
ViewModel Class See Also Send Feedback
Gets a part of visible content of vertical scroll bar.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract double VScrollBarViewPort { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property VScrollBarViewPort As Double
Visual C++
public:
virtual property double VScrollBarViewPort {
    double get () abstract;
}

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Zoom Property

[image]

.NET ModelKit Suite ClassReference
ViewModel..::.Zoom Property
ViewModel Class See Also Send Feedback
Gets or sets Zoom which is report scale.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract Zoom Zoom { get; set; }
Visual Basic (Declaration)
Public MustOverride Property Zoom As Zoom
Visual C++
public:
virtual property Zoom Zoom {
    Zoom get () abstract;
    void set (Zoom value) abstract;
}

See Also

ViewModel Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewOptions Class

[image]

.NET ModelKit Suite ClassReference
ViewOptions Class
Members See Also Send Feedback
Report Viewer parameters.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ViewOptions : DependencyObject
Visual Basic (Declaration)
Public Class ViewOptions _
    Inherits DependencyObject
Visual C++
public ref class ViewOptions : public DependencyObject

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
PerpetuumSoft.Reporting.Silverlight.Client..::.ViewOptions

See Also

ViewOptions Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewOptions Members

[image] [image]

.NET ModelKit Suite ClassReference
ViewOptions Members
ViewOptions Class Constructors Methods Properties See Also Send Feedback

The ViewOptions type exposes the following members.

Constructors

Name | Description
ViewOptions | Initializes a new instance of the ViewOptions class.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)
ExcelExportBrowsing | Gets or sets the property which indicates that export to Excel is available.
HistoryNavigatorBrowsing | Gets or sets the property which indicates that view status history navigation buttons are available.
HtmlExportBrowsing | Gets or sets the property which indicates that export to Html is available.
PageModelNavigatorBrowsing | Gets or sets the property which indicates that page display model changing element are available.
PageNavigatorBrowsing | Gets or sets the property which indicates that page navigation elements are available.
PDFExportBrowsing | Gets or sets the property which indicates that export to PDF is available.
RTFExportBrowsing | Gets or sets the property which indicates that export to RTF is available.
SearchElementsBrowsing | Gets or sets the property which indicates that search elements are available.
XPSExportBrowsing | Gets or sets the property which indicates that export to XPS is available.
ZoomElementsBrowsing | Gets or sets the property which indicates that display scaling elements are available.

See Also

ViewOptions Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewOptions Constructor

[image]

.NET ModelKit Suite ClassReference
ViewOptions Constructor
ViewOptions Class See Also Send Feedback
Initializes a new instance of the ViewOptions class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ViewOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ViewOptions()

See Also

ViewOptions Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewOptions Methods

[image] [image]

.NET ModelKit Suite ClassReference
ViewOptions Methods
ViewOptions Class See Also Send Feedback

The ViewOptions type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewOptions Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ViewOptions Properties

[image] [image]

.NET ModelKit Suite ClassReference
ViewOptions Properties
ViewOptions Class See Also Send Feedback

The ViewOptions type exposes the following members.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)
ExcelExportBrowsing | Gets or sets the property which indicates that export to Excel is available.
HistoryNavigatorBrowsing | Gets or sets the property which indicates that view status history navigation buttons are available.
HtmlExportBrowsing | Gets or sets the property which indicates that export to Html is available.
PageModelNavigatorBrowsing | Gets or sets the property which indicates that page display model changing element are available.
PageNavigatorBrowsing | Gets or sets the property which indicates that page navigation elements are available.
PDFExportBrowsing | Gets or sets the property which indicates that export to PDF is available.
RTFExportBrowsing | Gets or sets the property which indicates that export to RTF is available.
SearchElementsBrowsing | Gets or sets the property which indicates that search elements are available.
XPSExportBrowsing | Gets or sets the property which indicates that export to XPS is available.
ZoomElementsBrowsing | Gets or sets the property which indicates that display scaling elements are available.

See Also

ViewOptions Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ExcelExportBrowsing Property

[image]

.NET ModelKit Suite ClassReference
ViewOptions..::.ExcelExportBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that export to Excel is available.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool ExcelExportBrowsing { get; set; }
Visual Basic (Declaration)
Public Property ExcelExportBrowsing As Boolean
Visual C++
public:
property bool ExcelExportBrowsing {
    bool get ();
    void set (bool value);
}

See Also

ViewOptions Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


HistoryNavigatorBrowsing Property

[image]

.NET ModelKit Suite ClassReference
ViewOptions..::.HistoryNavigatorBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that view status history navigation buttons are available.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool HistoryNavigatorBrowsing { get; set; }
Visual Basic (Declaration)
Public Property HistoryNavigatorBrowsing As Boolean
Visual C++
public:
property bool HistoryNavigatorBrowsing {
    bool get ();
    void set (bool value);
}

See Also

ViewOptions Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


HtmlExportBrowsing Property

[image]

.NET ModelKit Suite ClassReference
ViewOptions..::.HtmlExportBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that export to Html is available.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool HtmlExportBrowsing { get; set; }
Visual Basic (Declaration)
Public Property HtmlExportBrowsing As Boolean
Visual C++
public:
property bool HtmlExportBrowsing {
    bool get ();
    void set (bool value);
}

See Also

ViewOptions Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageModelNavigatorBrowsing Property

[image]

.NET ModelKit Suite ClassReference
ViewOptions..::.PageModelNavigatorBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that page display model changing element are available.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool PageModelNavigatorBrowsing { get; set; }
Visual Basic (Declaration)
Public Property PageModelNavigatorBrowsing As Boolean
Visual C++
public:
property bool PageModelNavigatorBrowsing {
    bool get ();
    void set (bool value);
}

See Also

ViewOptions Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PageNavigatorBrowsing Property

[image]

.NET ModelKit Suite ClassReference
ViewOptions..::.PageNavigatorBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that page navigation elements are available.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool PageNavigatorBrowsing { get; set; }
Visual Basic (Declaration)
Public Property PageNavigatorBrowsing As Boolean
Visual C++
public:
property bool PageNavigatorBrowsing {
    bool get ();
    void set (bool value);
}

See Also

ViewOptions Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PDFExportBrowsing Property

[image]

.NET ModelKit Suite ClassReference
ViewOptions..::.PDFExportBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that export to PDF is available.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool PDFExportBrowsing { get; set; }
Visual Basic (Declaration)
Public Property PDFExportBrowsing As Boolean
Visual C++
public:
property bool PDFExportBrowsing {
    bool get ();
    void set (bool value);
}

See Also

ViewOptions Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


RTFExportBrowsing Property

[image]

.NET ModelKit Suite ClassReference
ViewOptions..::.RTFExportBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that export to RTF is available.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool RTFExportBrowsing { get; set; }
Visual Basic (Declaration)
Public Property RTFExportBrowsing As Boolean
Visual C++
public:
property bool RTFExportBrowsing {
    bool get ();
    void set (bool value);
}

See Also

ViewOptions Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


SearchElementsBrowsing Property

[image]

.NET ModelKit Suite ClassReference
ViewOptions..::.SearchElementsBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that search elements are available.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool SearchElementsBrowsing { get; set; }
Visual Basic (Declaration)
Public Property SearchElementsBrowsing As Boolean
Visual C++
public:
property bool SearchElementsBrowsing {
    bool get ();
    void set (bool value);
}

See Also

ViewOptions Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


XPSExportBrowsing Property

[image]

.NET ModelKit Suite ClassReference
ViewOptions..::.XPSExportBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that export to XPS is available.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool XPSExportBrowsing { get; set; }
Visual Basic (Declaration)
Public Property XPSExportBrowsing As Boolean
Visual C++
public:
property bool XPSExportBrowsing {
    bool get ();
    void set (bool value);
}

See Also

ViewOptions Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomElementsBrowsing Property

[image]

.NET ModelKit Suite ClassReference
ViewOptions..::.ZoomElementsBrowsing Property
ViewOptions Class See Also Send Feedback
Gets or sets the property which indicates that display scaling elements are available.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool ZoomElementsBrowsing { get; set; }
Visual Basic (Declaration)
Public Property ZoomElementsBrowsing As Boolean
Visual C++
public:
property bool ZoomElementsBrowsing {
    bool get ();
    void set (bool value);
}

See Also

ViewOptions Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Zoom Structure

[image]

.NET ModelKit Suite ClassReference
Zoom Structure
Members See Also Send Feedback
A class which includes data about current report scale.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public struct Zoom
Visual Basic (Declaration)
Public Structure Zoom
Visual C++
public value class Zoom

See Also

Zoom Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Zoom Members

[image] [image]

.NET ModelKit Suite ClassReference
Zoom Members
Zoom Structure Constructors Methods Properties See Also Send Feedback

The Zoom type exposes the following members.

Constructors

Name | Description
Zoom | Overloaded.

Methods

Name | Description
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Mode | Gets ZoomMode which is scale mode.
Scale | Gets scale value.

See Also

Zoom Structure
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Zoom Constructor

[image] [image]

.NET ModelKit Suite ClassReference
Zoom Constructor
Zoom Structure See Also Send Feedback

Overload List

Name | Description
Zoom(ZoomMode) | Initializes a new instance of the Zoom class.
Zoom(Double) | Initializes a new instance of the Zoom class.
Zoom(ZoomMode, Double) | Initializes a new instance of the Zoom class.

See Also

Zoom Structure
Zoom Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Zoom Constructor (ZoomMode)

[image]

.NET ModelKit Suite ClassReference
Zoom Constructor (ZoomMode)
Zoom Structure See Also Send Feedback
Initializes a new instance of the Zoom class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Zoom(
    ZoomMode mode
)
Visual Basic (Declaration)
Public Sub New ( _
    mode As ZoomMode _
)
Visual C++
public:
Zoom(
    ZoomMode mode
)

Parameters

mode
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ZoomMode

See Also

Zoom Structure
Zoom Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Zoom Constructor (Double)

[image]

.NET ModelKit Suite ClassReference
Zoom Constructor (Double)
Zoom Structure See Also Send Feedback
Initializes a new instance of the Zoom class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Zoom(
    double scale
)
Visual Basic (Declaration)
Public Sub New ( _
    scale As Double _
)
Visual C++
public:
Zoom(
    double scale
)

Parameters

scale
Type: System..::.Double

See Also

Zoom Structure
Zoom Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Zoom Constructor (ZoomMode, Double)

[image]

.NET ModelKit Suite ClassReference
Zoom Constructor (ZoomMode, Double)
Zoom Structure See Also Send Feedback
Initializes a new instance of the Zoom class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Zoom(
    ZoomMode mode,
    double scale
)
Visual Basic (Declaration)
Public Sub New ( _
    mode As ZoomMode, _
    scale As Double _
)
Visual C++
public:
Zoom(
    ZoomMode mode,
    double scale
)

Parameters

mode
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ZoomMode
scale
Type: System..::.Double

See Also

Zoom Structure
Zoom Overload
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Zoom Methods

[image] [image]

.NET ModelKit Suite ClassReference
Zoom Methods
Zoom Structure See Also Send Feedback

The Zoom type exposes the following members.

Methods

Name | Description
Equals | Overridden. See Equals(Object). (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Zoom Structure
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Equals Method

[image]

.NET ModelKit Suite ClassReference
Zoom..::.Equals Method
Zoom Structure See Also Send Feedback
Overridden. See Equals(Object).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

Zoom Structure
PerpetuumSoft.Reporting.Silverlight.Client Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
Zoom..::.GetHashCode Method
Zoom Structure See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

Zoom Structure
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Zoom Properties

[image] [image]

.NET ModelKit Suite ClassReference
Zoom Properties
Zoom Structure See Also Send Feedback

The Zoom type exposes the following members.

Properties

Name | Description
Mode | Gets ZoomMode which is scale mode.
Scale | Gets scale value.

See Also

Zoom Structure
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Mode Property

[image]

.NET ModelKit Suite ClassReference
Zoom..::.Mode Property
Zoom Structure See Also Send Feedback
Gets ZoomMode which is scale mode.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ZoomMode Mode { get; }
Visual Basic (Declaration)
Public ReadOnly Property Mode As ZoomMode
Visual C++
public:
property ZoomMode Mode {
    ZoomMode get ();
}

See Also

Zoom Structure
PerpetuumSoft.Reporting.Silverlight.Client Namespace


Scale Property

[image]

.NET ModelKit Suite ClassReference
Zoom..::.Scale Property
Zoom Structure See Also Send Feedback
Gets scale value.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public double Scale { get; }
Visual Basic (Declaration)
Public ReadOnly Property Scale As Double
Visual C++
public:
property double Scale {
    double get ();
}

See Also

Zoom Structure
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomChangeTool Class

[image]

.NET ModelKit Suite ClassReference
ZoomChangeTool Class
Members See Also Send Feedback
A class for the realization of the tools which are used in work with the report scale.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract class ZoomChangeTool : StandardTool
Visual Basic (Declaration)
Public MustInherit Class ZoomChangeTool _
    Inherits StandardTool
Visual C++
public ref class ZoomChangeTool abstract : public StandardTool

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client..::.Tool
PerpetuumSoft.Reporting.Silverlight.Client..::.StandardTool
PerpetuumSoft.Reporting.Silverlight.Client..::.ZoomChangeTool
PerpetuumSoft.Reporting.Silverlight.Client..::.ZoomInTool
PerpetuumSoft.Reporting.Silverlight.Client..::.ZoomOutTool

See Also

ZoomChangeTool Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomChangeTool Members

[image] [image]

.NET ModelKit Suite ClassReference
ZoomChangeTool Members
ZoomChangeTool Class Constructors Methods Fields Properties See Also Send Feedback

The ZoomChangeTool type exposes the following members.

Constructors

Name | Description
ZoomChangeTool | Initializes a new instance of the ZoomChangeTool class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetZoomFactor | Gets the scale step.
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Inherited from StandardTool.)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides StandardTool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides StandardTool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates active cursor. (Inherited from Tool.)

Fields

Name | Description
zoomScaleFactor | Gets the scale step.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

ZoomChangeTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomChangeTool Constructor

[image]

.NET ModelKit Suite ClassReference
ZoomChangeTool Constructor
ZoomChangeTool Class See Also Send Feedback
Initializes a new instance of the ZoomChangeTool class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected ZoomChangeTool(
    ViewManager manager
)
Visual Basic (Declaration)
Protected Sub New ( _
    manager As ViewManager _
)
Visual C++
protected:
ZoomChangeTool(
    ViewManager^ manager
)

Parameters

manager
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ViewManager

See Also

ZoomChangeTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomChangeTool Fields

[image] [image]

.NET ModelKit Suite ClassReference
ZoomChangeTool Fields
ZoomChangeTool Class See Also Send Feedback

The ZoomChangeTool type exposes the following members.

Fields

Name | Description
zoomScaleFactor | Gets the scale step.

See Also

ZoomChangeTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


zoomScaleFactor Field

[image]

.NET ModelKit Suite ClassReference
ZoomChangeTool..::.zoomScaleFactor Field
ZoomChangeTool Class See Also Send Feedback
Gets the scale step.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected const double zoomScaleFactor
Visual Basic (Declaration)
Protected Const zoomScaleFactor As Double
Visual C++
protected:
literal double zoomScaleFactor

See Also

ZoomChangeTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomChangeTool Methods

[image] [image]

.NET ModelKit Suite ClassReference
ZoomChangeTool Methods
ZoomChangeTool Class See Also Send Feedback

The ZoomChangeTool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetZoomFactor | Gets the scale step.
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Inherited from StandardTool.)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Overrides StandardTool..::.MouseMove(MouseEventArgs).)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Overrides StandardTool..::.MouseUp(MouseEventArgs).)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Updates active cursor. (Inherited from Tool.)

See Also

ZoomChangeTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


GetZoomFactor Method

[image]

.NET ModelKit Suite ClassReference
ZoomChangeTool..::.GetZoomFactor Method
ZoomChangeTool Class See Also Send Feedback
Gets the scale step.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected abstract double GetZoomFactor()
Visual Basic (Declaration)
Protected MustOverride Function GetZoomFactor As Double
Visual C++
protected:
virtual double GetZoomFactor() abstract

See Also

ZoomChangeTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseMove Method

[image]

.NET ModelKit Suite ClassReference
ZoomChangeTool..::.MouseMove Method
ZoomChangeTool Class See Also Send Feedback
Overridden. See MouseMove(MouseEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseMove(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseMove ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseMove(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

ZoomChangeTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


MouseUp Method

[image]

.NET ModelKit Suite ClassReference
ZoomChangeTool..::.MouseUp Method
ZoomChangeTool Class See Also Send Feedback
Overridden. See MouseUp(MouseEventArgs).

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void MouseUp(
    MouseEventArgs args
)
Visual Basic (Declaration)
Public Overrides Sub MouseUp ( _
    args As MouseEventArgs _
)
Visual C++
public:
virtual void MouseUp(
    MouseEventArgs^ args
) override

Parameters

args
Type: System.Windows.Input..::.MouseEventArgs

See Also

ZoomChangeTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomChangeTool Properties

[image] [image]

.NET ModelKit Suite ClassReference
ZoomChangeTool Properties
ZoomChangeTool Class See Also Send Feedback

The ZoomChangeTool type exposes the following members.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

ZoomChangeTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomInTool Class

[image]

.NET ModelKit Suite ClassReference
ZoomInTool Class
Members See Also Send Feedback
A class for realization of the tool which can be used for zooming in report view. Inherited from ZoomChangeTool.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public sealed class ZoomInTool : ZoomChangeTool
Visual Basic (Declaration)
Public NotInheritable Class ZoomInTool _
    Inherits ZoomChangeTool
Visual C++
public ref class ZoomInTool sealed : public ZoomChangeTool

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client..::.Tool
PerpetuumSoft.Reporting.Silverlight.Client..::.StandardTool
PerpetuumSoft.Reporting.Silverlight.Client..::.ZoomChangeTool
PerpetuumSoft.Reporting.Silverlight.Client..::.ZoomInTool

See Also

ZoomInTool Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomInTool Members

[image] [image]

.NET ModelKit Suite ClassReference
ZoomInTool Members
ZoomInTool Class Constructors Methods Properties See Also Send Feedback

The ZoomInTool type exposes the following members.

Constructors

Name | Description
ZoomInTool | Initializes a new instance of the ZoomInTool class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetZoomFactor | Gets the scale step. (Inherited from ZoomChangeTool.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Inherited from StandardTool.)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Inherited from ZoomChangeTool.)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Inherited from ZoomChangeTool.)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Overridden. See UpdateCursor()()(). (Overrides Tool..::.UpdateCursor()()().)

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

ZoomInTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomInTool Constructor

[image]

.NET ModelKit Suite ClassReference
ZoomInTool Constructor
ZoomInTool Class See Also Send Feedback
Initializes a new instance of the ZoomInTool class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ZoomInTool(
    ViewManager manager
)
Visual Basic (Declaration)
Public Sub New ( _
    manager As ViewManager _
)
Visual C++
public:
ZoomInTool(
    ViewManager^ manager
)

Parameters

manager
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ViewManager

See Also

ZoomInTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomInTool Methods

[image] [image]

.NET ModelKit Suite ClassReference
ZoomInTool Methods
ZoomInTool Class See Also Send Feedback

The ZoomInTool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetZoomFactor | Gets the scale step. (Inherited from ZoomChangeTool.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Inherited from StandardTool.)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Inherited from ZoomChangeTool.)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Inherited from ZoomChangeTool.)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Overridden. See UpdateCursor()()(). (Overrides Tool..::.UpdateCursor()()().)

See Also

ZoomInTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


UpdateCursor Method

[image]

.NET ModelKit Suite ClassReference
ZoomInTool..::.UpdateCursor Method
ZoomInTool Class See Also Send Feedback
Overridden. See UpdateCursor()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void UpdateCursor()
Visual Basic (Declaration)
Public Overrides Sub UpdateCursor
Visual C++
public:
virtual void UpdateCursor() override

See Also

ZoomInTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomInTool Properties

[image] [image]

.NET ModelKit Suite ClassReference
ZoomInTool Properties
ZoomInTool Class See Also Send Feedback

The ZoomInTool type exposes the following members.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

ZoomInTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomMode Enumeration

[image]

.NET ModelKit Suite ClassReference
ZoomMode Enumeration
See Also Send Feedback
Enumeration which includes scale modes list.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public enum ZoomMode
Visual Basic (Declaration)
Public Enumeration ZoomMode
Visual C++
public enum class ZoomMode

Members

Member name | Description
Scale | Scale mode which is set by fractional number.
WholePage | Scale mode by page sizes.
PageWidth | Scale mode by page width.

See Also

PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomOutTool Class

[image]

.NET ModelKit Suite ClassReference
ZoomOutTool Class
Members See Also Send Feedback
A class for tool (functionality) realization which is used for report zooming out.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public sealed class ZoomOutTool : ZoomChangeTool
Visual Basic (Declaration)
Public NotInheritable Class ZoomOutTool _
    Inherits ZoomChangeTool
Visual C++
public ref class ZoomOutTool sealed : public ZoomChangeTool

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client..::.Tool
PerpetuumSoft.Reporting.Silverlight.Client..::.StandardTool
PerpetuumSoft.Reporting.Silverlight.Client..::.ZoomChangeTool
PerpetuumSoft.Reporting.Silverlight.Client..::.ZoomOutTool

See Also

ZoomOutTool Members
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomOutTool Members

[image] [image]

.NET ModelKit Suite ClassReference
ZoomOutTool Members
ZoomOutTool Class Constructors Methods Properties See Also Send Feedback

The ZoomOutTool type exposes the following members.

Constructors

Name | Description
ZoomOutTool | Initializes a new instance of the ZoomOutTool class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetZoomFactor | Gets the scale step. (Inherited from ZoomChangeTool.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Inherited from StandardTool.)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Inherited from ZoomChangeTool.)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Inherited from ZoomChangeTool.)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Overridden. See UpdateCursor()()(). (Overrides Tool..::.UpdateCursor()()().)

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

ZoomOutTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomOutTool Constructor

[image]

.NET ModelKit Suite ClassReference
ZoomOutTool Constructor
ZoomOutTool Class See Also Send Feedback
Initializes a new instance of the ZoomOutTool class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ZoomOutTool(
    ViewManager manager
)
Visual Basic (Declaration)
Public Sub New ( _
    manager As ViewManager _
)
Visual C++
public:
ZoomOutTool(
    ViewManager^ manager
)

Parameters

manager
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ViewManager

See Also

ZoomOutTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomOutTool Methods

[image] [image]

.NET ModelKit Suite ClassReference
ZoomOutTool Methods
ZoomOutTool Class See Also Send Feedback

The ZoomOutTool type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetZoomFactor | Gets the scale step. (Inherited from ZoomChangeTool.)
KeyDown | Overridden. See KeyDown(KeyEventArgs). (Inherited from StandardTool.)
KeyUp | Overridden. See KeyUp(KeyEventArgs). (Inherited from StandardTool.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseDown | Overridden. See MouseDown(MouseEventArgs). (Inherited from StandardTool.)
MouseMove | Overridden. See MouseMove(MouseEventArgs). (Inherited from ZoomChangeTool.)
MouseUp | Overridden. See MouseUp(MouseEventArgs). (Inherited from ZoomChangeTool.)
MouseWheel | Overridden. See MouseWheel(Double). (Inherited from StandardTool.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCursor | Overridden. See UpdateCursor()()(). (Overrides Tool..::.UpdateCursor()()().)

See Also

ZoomOutTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


UpdateCursor Method

[image]

.NET ModelKit Suite ClassReference
ZoomOutTool..::.UpdateCursor Method
ZoomOutTool Class See Also Send Feedback
Overridden. See UpdateCursor()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override void UpdateCursor()
Visual Basic (Declaration)
Public Overrides Sub UpdateCursor
Visual C++
public:
virtual void UpdateCursor() override

See Also

ZoomOutTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


ZoomOutTool Properties

[image] [image]

.NET ModelKit Suite ClassReference
ZoomOutTool Properties
ZoomOutTool Class See Also Send Feedback

The ZoomOutTool type exposes the following members.

Properties

Name | Description
ViewManager | Gets ViewManager which is Report Viewer manager. (Inherited from Tool.)

See Also

ZoomOutTool Class
PerpetuumSoft.Reporting.Silverlight.Client Namespace


PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace
Send Feedback
The PerpetuumSoft.Reporting.Silverlight.Client.Fonts namespace contains classes to work with report fonts.

Classes

Class | Description
FontsManager | Fonts manager.
FontUtils | A static class for working with fonts.

Structures

Structure | Description
FontKey | Font key for its unique identification.


FontKey Structure

[image]

.NET ModelKit Suite ClassReference
FontKey Structure
Members See Also Send Feedback
Font key for its unique identification.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Fonts
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public struct FontKey
Visual Basic (Declaration)
Public Structure FontKey
Visual C++
public value class FontKey

See Also

FontKey Members
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace


FontKey Members

[image] [image]

.NET ModelKit Suite ClassReference
FontKey Members
FontKey Structure Methods Fields See Also Send Feedback

The FontKey type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides ValueType..::.ToString()()().)

Fields

Name | Description
Family | Gets or sets fonts family.
Weight | Gets or sets font weight.

See Also

FontKey Structure
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace


FontKey Fields

[image] [image]

.NET ModelKit Suite ClassReference
FontKey Fields
FontKey Structure See Also Send Feedback

The FontKey type exposes the following members.

Fields

Name | Description
Family | Gets or sets fonts family.
Weight | Gets or sets font weight.

See Also

FontKey Structure
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace


Family Field

[image]

.NET ModelKit Suite ClassReference
FontKey..::.Family Field
FontKey Structure See Also Send Feedback
Gets or sets fonts family.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Fonts
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string Family
Visual Basic (Declaration)
Public Family As String
Visual C++
public:
String^ Family

See Also

FontKey Structure
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace


Weight Field

[image]

.NET ModelKit Suite ClassReference
FontKey..::.Weight Field
FontKey Structure See Also Send Feedback
Gets or sets font weight.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Fonts
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public FontWeight Weight
Visual Basic (Declaration)
Public Weight As FontWeight
Visual C++
public:
FontWeight Weight

See Also

FontKey Structure
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace


FontKey Methods

[image] [image]

.NET ModelKit Suite ClassReference
FontKey Methods
FontKey Structure See Also Send Feedback

The FontKey type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overridden. See GetHashCode()()(). (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides ValueType..::.ToString()()().)

See Also

FontKey Structure
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace


GetHashCode Method

[image]

.NET ModelKit Suite ClassReference
FontKey..::.GetHashCode Method
FontKey Structure See Also Send Feedback
Overridden. See GetHashCode()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Fonts
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

FontKey Structure
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
FontKey..::.ToString Method
FontKey Structure See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Fonts
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

FontKey Structure
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace


FontsManager Class

[image]

.NET ModelKit Suite ClassReference
FontsManager Class
Members See Also Send Feedback
Fonts manager.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Fonts
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class FontsManager
Visual Basic (Declaration)
Public Class FontsManager
Visual C++
public ref class FontsManager

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client.Fonts..::.FontsManager

See Also

FontsManager Members
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace


FontsManager Members

[image] [image]

.NET ModelKit Suite ClassReference
FontsManager Members
FontsManager Class Methods See Also Send Feedback

The FontsManager type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultFont | Gets value which indicates that the font family is Silverlight standard font.
IsLoadedFont | Gets the value which indicates if font is loaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
QueryFontSource | Requires font loading source from server.
SetFontSource | Sets the font loading source for control.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontsManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace


FontsManager Methods

[image] [image]

.NET ModelKit Suite ClassReference
FontsManager Methods
FontsManager Class See Also Send Feedback

The FontsManager type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultFont | Gets value which indicates that the font family is Silverlight standard font.
IsLoadedFont | Gets the value which indicates if font is loaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
QueryFontSource | Requires font loading source from server.
SetFontSource | Sets the font loading source for control.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontsManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace


IsDefaultFont Method

[image]

.NET ModelKit Suite ClassReference
FontsManager..::.IsDefaultFont Method
FontsManager Class See Also Send Feedback
Gets value which indicates that the font family is Silverlight standard font.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Fonts
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static bool IsDefaultFont(
    string fontFamily
)
Visual Basic (Declaration)
Public Shared Function IsDefaultFont ( _
    fontFamily As String _
) As Boolean
Visual C++
public:
static bool IsDefaultFont(
    String^ fontFamily
)

Parameters

fontFamily
Type: System..::.String

See Also

FontsManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace


IsLoadedFont Method

[image]

.NET ModelKit Suite ClassReference
FontsManager..::.IsLoadedFont Method
FontsManager Class See Also Send Feedback
Gets the value which indicates if font is loaded.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Fonts
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool IsLoadedFont(
    FontKey fontKey
)
Visual Basic (Declaration)
Public Function IsLoadedFont ( _
    fontKey As FontKey _
) As Boolean
Visual C++
public:
bool IsLoadedFont(
    FontKey fontKey
)

Parameters

fontKey
Type: PerpetuumSoft.Reporting.Silverlight.Client.Fonts..::.FontKey

See Also

FontsManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace


QueryFontSource Method

[image]

.NET ModelKit Suite ClassReference
FontsManager..::.QueryFontSource Method
FontsManager Class See Also Send Feedback
Requires font loading source from server.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Fonts
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void QueryFontSource(
    FontKey fontKey,
    Action<FontKey, FontSource> callBack
)
Visual Basic (Declaration)
Public Sub QueryFontSource ( _
    fontKey As FontKey, _
    callBack As Action(Of FontKey, FontSource) _
)
Visual C++
public:
void QueryFontSource(
    FontKey fontKey,
    Action<FontKey, FontSource^>^ callBack
)

Parameters

fontKey
Type: PerpetuumSoft.Reporting.Silverlight.Client.Fonts..::.FontKey
callBack
Type: System..::.Action <(Of <( FontKey, FontSource>)>)

See Also

FontsManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace


SetFontSource Method

[image]

.NET ModelKit Suite ClassReference
FontsManager..::.SetFontSource Method
FontsManager Class See Also Send Feedback
Sets the font loading source for control.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Fonts
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void SetFontSource(
    DependencyObject control
)
Visual Basic (Declaration)
Public Sub SetFontSource ( _
    control As DependencyObject _
)
Visual C++
public:
void SetFontSource(
    DependencyObject^ control
)

Parameters

control
Type: System.Windows..::.DependencyObject

See Also

FontsManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace


FontUtils Class

[image]

.NET ModelKit Suite ClassReference
FontUtils Class
Members See Also Send Feedback
A static class for working with fonts.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Fonts
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static class FontUtils
Visual Basic (Declaration)
Public NotInheritable Class FontUtils
Visual C++
public ref class FontUtils abstract sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client.Fonts..::.FontUtils

See Also

FontUtils Members
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace


FontUtils Members

[image] [image]

.NET ModelKit Suite ClassReference
FontUtils Members
FontUtils Class Methods See Also Send Feedback

The FontUtils type exposes the following members.

Methods

Name | Description
SetFontSource | Sets font source.

See Also

FontUtils Class
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace


FontUtils Methods

[image] [image]

.NET ModelKit Suite ClassReference
FontUtils Methods
FontUtils Class See Also Send Feedback

The FontUtils type exposes the following members.

Methods

Name | Description
SetFontSource | Sets font source.

See Also

FontUtils Class
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace


SetFontSource Method

[image]

.NET ModelKit Suite ClassReference
FontUtils..::.SetFontSource Method
FontUtils Class See Also Send Feedback
Sets font source.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Fonts
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static void SetFontSource(
    DependencyObject control,
    FontSource fontSource
)
Visual Basic (Declaration)
Public Shared Sub SetFontSource ( _
    control As DependencyObject, _
    fontSource As FontSource _
)
Visual C++
public:
static void SetFontSource(
    DependencyObject^ control,
    FontSource^ fontSource
)

Parameters

control
Type: System.Windows..::.DependencyObject
fontSource
Type: FontSource

See Also

FontUtils Class
PerpetuumSoft.Reporting.Silverlight.Client.Fonts Namespace


PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace
Send Feedback
The PerpetuumSoft.Reporting.Silverlight.Client.Localization namespace contains classes to localize user interface.

Classes

Class | Description
LocalizationManager | The class which realizes methods for the ReportViewer interface localization.


LocalizationManager Class

[image]

.NET ModelKit Suite ClassReference
LocalizationManager Class
Members See Also Send Feedback
The class which realizes methods for the ReportViewer interface localization.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class LocalizationManager : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class LocalizationManager _
    Implements INotifyPropertyChanged
Visual C++
public ref class LocalizationManager : INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client.Localization..::.LocalizationManager

See Also

LocalizationManager Members
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


LocalizationManager Members

[image] [image]

.NET ModelKit Suite ClassReference
LocalizationManager Members
LocalizationManager Class Constructors Methods Fields Properties Events See Also Send Feedback

The LocalizationManager type exposes the following members.

Constructors

Name | Description
LocalizationManager | Initializes a new instance of the LocalizationManager class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
NoReportToDisplayProperty | Gets default message which states that the selected report is not available.
PageLoadingProperty | Gets default page loading message.
ProgressLoadingProperty | Gets default text which informs about report loading process.
ProgressRenderingProperty | Gets default text which informs about report rendering process.
ServerErrorProperty | Gets default server error message.
TooltipBackwardProperty | Gets default tooltip for the control which is responsible for switching to the previous state saved in history.
TooltipContinuedPageModeProperty | Gets default tooltip for the control which is responsible for switching to the continued page viewing mode.
TooltipCurrentPageProperty | Gets default tooltip for the control which is responsible for displaying the current page number.
TooltipExportToExcelProperty | Gets default tooltip for the control which is responsible for export to Excel.
TooltipExportToHtmlProperty | Gets default tooltip for the control which is responsible for export to HTML.
TooltipExportToPDFProperty | Gets default tooltip for the control which is responsible for export to PDF.
TooltipExportToRTFProperty | Gets default tooltip for the control which is responsible for export to RTF.
TooltipExportToXPSProperty | Gets default tooltip for the control which is responsible for export to Xps.
TooltipFindNextProperty | Gets default tooltip for the control which is responsible for the next search result.
TooltipFindPreviousProperty | Gets default tooltip for the control which is responsible for switching to the previous search result.
TooltipFindProperty | Gets default tooltip for the control which is responsible for search starting.
TooltipFirstPageProperty | Gets default tooltip for the control which is responsible for switching to the first page.
TooltipForwardProperty | Gets default tooltip for the control which is responsible for switching to the next state saved in history.
TooltipLastPageProperty | Gets default tooltip for the control which is responsible for switching to the last page.
TooltipMultiPageModeProperty | Gets default tooltip for the control which is responsible for the multipage viewing mode.
TooltipNextPageProperty | Gets default tooltip for the control which is responsible for switching to the next page.
TooltipPageWidthProperty | Gets default tooltip for the control which is responsible for scaling equal to the page width.
TooltipPanProperty | Gets default tooltip for the control which is responsible for report scrolling mode.
TooltipPreviousPageProperty | Gets default tooltip for the control which is responsible for switching to the previous search result.
TooltipSearchProperty | Gets default tooltip for the control which is responsible for the search text input.
TooltipSelectProperty | Gets default tooltip for the control which is responsible for setting mode of the report elements selection.
TooltipSinglePageModeProperty | Gets default tooltip for the control which is responsible for switching to report single page viewing mode.
TooltipWholePageProperty | Gets default tooltip for the control which is responsible for scaling equal to the whole page.
TooltipZoom100Property | Gets default tooltip for the control which is responsible for 100% scaling of original.
TooltipZoomDecreaseProperty | Gets default tooltip for the control which is responsible for scale decreasing.
TooltipZoomDynamicProperty | Gets default tooltip for the control which is responsible for dynamic scaling. The scaling is performed with dragging.
TooltipZoomIncreaseProperty | Gets default tooltip for the control which is responsible for scale increasing.
TooltipZoomInProperty | Gets default tooltip for the control which is responsible for zooming in a report.
TooltipZoomOutProperty | Gets default tooltip for the control which is responsible for zooming out a report.
TooltipZoomToRegionProperty | Gets default tooltip for the control which is responsible for scaling in the selected region.

Properties

Name | Description
NoReportToDisplay | Gets the message which states that selected report is not available.
PageLoading | Gets the page loading message.
ProgressLoading | Gets the text which informs about the report loading process.
ProgressRendering | Gets the text which informs about the report rendering process.
ServerError | Gets the server error message.
TooltipBackward | Gets the tooltip for the control which is responsible for switching to the previous state saved in history.
TooltipContinuedPageMode | Gets the tooltip for the control which is responsible for switching to the continued page viewing mode.
TooltipCurrentPage | Gets the tooltip for the control which is responsible for displaying the current page number.
TooltipExportToExcel | Gets the tooltip for the control which is responsible for export to Excel.
TooltipExportToHtml | Gets the tooltip for the control which is responsible for export to HTML.
TooltipExportToPDF | Gets the tooltip for the control which is responsible for export to PDF.
TooltipExportToRTF | Gets the tooltip for the control which is responsible for export to RTF.
TooltipExportToXPS | Gets the tooltip for the control which is responsible for export to Xps.
TooltipFind | Gets the tooltip for the control which is responsible for search starting.
TooltipFindNext | Gets the tooltip for the control which is responsible for switching to the next search result.
TooltipFindPrevious | Gets the tooltip for the control which is responsible for switching to the previous search result.
TooltipFirstPage | Gets the tooltip for the control which is responsible for switching to the first page.
TooltipForward | Gets the tooltip for the control which is responsible for switching to the next state saved in history.
TooltipLastPage | Gets the tooltip for the control which is responsible for switching to the last page.
TooltipMultiPageMode | Gets the tooltip for the control which is responsible for the multipage viewing mode.
TooltipNextPage | Gets the tooltip for the control which is responsible for switching to the next page.
TooltipPageWidth | Gets the tooltip for the control which is responsible for scaling equal to the page width.
TooltipPan | Gets the tooltip for the control which is responsible for report panning mode.
TooltipPreviousPage | Gets the tooltip for the control which is responsible for switching to the previous search result.
TooltipSearch | Gets the tooltip for the control which is responsible for the search text input.
TooltipSelect | Gets the tooltip for the control which is responsible for setting mode of the report elements selection.
TooltipSinglePageMode | Gets the tooltip for the control which is responsible for switching to report single page viewing mode.
TooltipWholePage | Gets the tooltip for the control which is responsible for scaling equal to the whole page.
TooltipZoom100 | Gets the tooltip for the control which is responsible for 100% scaling of original.
TooltipZoomDecrease | Gets the tooltip for the control which is responsible for the scale decreasing.
TooltipZoomDynamic | Gets the tooltip for the control which is responsible for dynamic scaling. The scaling is performed by pressing the left mouse button and moving pointer.
TooltipZoomIn | Gets the tooltip for the control which is responsible for zooming in the report.
TooltipZoomIncrease | Gets the tooltip for the control which is responsible for the scale increasing.
TooltipZoomOut | Gets the tooltip for the control which is responsible for zooming out the report.
TooltipZoomToRegion | Gets the tooltip for the control which is responsible for scaling in the selected area.

Events

Name | Description
Loaded | Occurs when the dictionary is loaded.
PropertyChanged | Occurs when localization strings are changed.

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


LocalizationManager Constructor

[image]

.NET ModelKit Suite ClassReference
LocalizationManager Constructor
LocalizationManager Class See Also Send Feedback
Initializes a new instance of the LocalizationManager class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public LocalizationManager(
    ViewManager viewManager
)
Visual Basic (Declaration)
Public Sub New ( _
    viewManager As ViewManager _
)
Visual C++
public:
LocalizationManager(
    ViewManager^ viewManager
)

Parameters

viewManager
Type: PerpetuumSoft.Reporting.Silverlight.Client..::.ViewManager

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


LocalizationManager Fields

[image] [image]

.NET ModelKit Suite ClassReference
LocalizationManager Fields
LocalizationManager Class See Also Send Feedback

The LocalizationManager type exposes the following members.

Fields

Name | Description
NoReportToDisplayProperty | Gets default message which states that the selected report is not available.
PageLoadingProperty | Gets default page loading message.
ProgressLoadingProperty | Gets default text which informs about report loading process.
ProgressRenderingProperty | Gets default text which informs about report rendering process.
ServerErrorProperty | Gets default server error message.
TooltipBackwardProperty | Gets default tooltip for the control which is responsible for switching to the previous state saved in history.
TooltipContinuedPageModeProperty | Gets default tooltip for the control which is responsible for switching to the continued page viewing mode.
TooltipCurrentPageProperty | Gets default tooltip for the control which is responsible for displaying the current page number.
TooltipExportToExcelProperty | Gets default tooltip for the control which is responsible for export to Excel.
TooltipExportToHtmlProperty | Gets default tooltip for the control which is responsible for export to HTML.
TooltipExportToPDFProperty | Gets default tooltip for the control which is responsible for export to PDF.
TooltipExportToRTFProperty | Gets default tooltip for the control which is responsible for export to RTF.
TooltipExportToXPSProperty | Gets default tooltip for the control which is responsible for export to Xps.
TooltipFindNextProperty | Gets default tooltip for the control which is responsible for the next search result.
TooltipFindPreviousProperty | Gets default tooltip for the control which is responsible for switching to the previous search result.
TooltipFindProperty | Gets default tooltip for the control which is responsible for search starting.
TooltipFirstPageProperty | Gets default tooltip for the control which is responsible for switching to the first page.
TooltipForwardProperty | Gets default tooltip for the control which is responsible for switching to the next state saved in history.
TooltipLastPageProperty | Gets default tooltip for the control which is responsible for switching to the last page.
TooltipMultiPageModeProperty | Gets default tooltip for the control which is responsible for the multipage viewing mode.
TooltipNextPageProperty | Gets default tooltip for the control which is responsible for switching to the next page.
TooltipPageWidthProperty | Gets default tooltip for the control which is responsible for scaling equal to the page width.
TooltipPanProperty | Gets default tooltip for the control which is responsible for report scrolling mode.
TooltipPreviousPageProperty | Gets default tooltip for the control which is responsible for switching to the previous search result.
TooltipSearchProperty | Gets default tooltip for the control which is responsible for the search text input.
TooltipSelectProperty | Gets default tooltip for the control which is responsible for setting mode of the report elements selection.
TooltipSinglePageModeProperty | Gets default tooltip for the control which is responsible for switching to report single page viewing mode.
TooltipWholePageProperty | Gets default tooltip for the control which is responsible for scaling equal to the whole page.
TooltipZoom100Property | Gets default tooltip for the control which is responsible for 100% scaling of original.
TooltipZoomDecreaseProperty | Gets default tooltip for the control which is responsible for scale decreasing.
TooltipZoomDynamicProperty | Gets default tooltip for the control which is responsible for dynamic scaling. The scaling is performed with dragging.
TooltipZoomIncreaseProperty | Gets default tooltip for the control which is responsible for scale increasing.
TooltipZoomInProperty | Gets default tooltip for the control which is responsible for zooming in a report.
TooltipZoomOutProperty | Gets default tooltip for the control which is responsible for zooming out a report.
TooltipZoomToRegionProperty | Gets default tooltip for the control which is responsible for scaling in the selected region.

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


NoReportToDisplayProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.NoReportToDisplayProperty Field
LocalizationManager Class See Also Send Feedback
Gets default message which states that the selected report is not available.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string NoReportToDisplayProperty
Visual Basic (Declaration)
Public Const NoReportToDisplayProperty As String
Visual C++
public:
literal String^ NoReportToDisplayProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


PageLoadingProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.PageLoadingProperty Field
LocalizationManager Class See Also Send Feedback
Gets default page loading message.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string PageLoadingProperty
Visual Basic (Declaration)
Public Const PageLoadingProperty As String
Visual C++
public:
literal String^ PageLoadingProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


ProgressLoadingProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.ProgressLoadingProperty Field
LocalizationManager Class See Also Send Feedback
Gets default text which informs about report loading process.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string ProgressLoadingProperty
Visual Basic (Declaration)
Public Const ProgressLoadingProperty As String
Visual C++
public:
literal String^ ProgressLoadingProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


ProgressRenderingProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.ProgressRenderingProperty Field
LocalizationManager Class See Also Send Feedback
Gets default text which informs about report rendering process.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string ProgressRenderingProperty
Visual Basic (Declaration)
Public Const ProgressRenderingProperty As String
Visual C++
public:
literal String^ ProgressRenderingProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


ServerErrorProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.ServerErrorProperty Field
LocalizationManager Class See Also Send Feedback
Gets default server error message.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string ServerErrorProperty
Visual Basic (Declaration)
Public Const ServerErrorProperty As String
Visual C++
public:
literal String^ ServerErrorProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipBackwardProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipBackwardProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for switching to the previous state saved in history.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipBackwardProperty
Visual Basic (Declaration)
Public Const TooltipBackwardProperty As String
Visual C++
public:
literal String^ TooltipBackwardProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipContinuedPageModeProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipContinuedPageModeProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for switching to the continued page viewing mode.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipContinuedPageModeProperty
Visual Basic (Declaration)
Public Const TooltipContinuedPageModeProperty As String
Visual C++
public:
literal String^ TooltipContinuedPageModeProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipCurrentPageProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipCurrentPageProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for displaying the current page number.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipCurrentPageProperty
Visual Basic (Declaration)
Public Const TooltipCurrentPageProperty As String
Visual C++
public:
literal String^ TooltipCurrentPageProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipExportToExcelProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipExportToExcelProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for export to Excel.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipExportToExcelProperty
Visual Basic (Declaration)
Public Const TooltipExportToExcelProperty As String
Visual C++
public:
literal String^ TooltipExportToExcelProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipExportToHtmlProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipExportToHtmlProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for export to HTML.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipExportToHtmlProperty
Visual Basic (Declaration)
Public Const TooltipExportToHtmlProperty As String
Visual C++
public:
literal String^ TooltipExportToHtmlProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipExportToPDFProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipExportToPDFProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for export to PDF.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipExportToPDFProperty
Visual Basic (Declaration)
Public Const TooltipExportToPDFProperty As String
Visual C++
public:
literal String^ TooltipExportToPDFProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipExportToRTFProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipExportToRTFProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for export to RTF.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipExportToRTFProperty
Visual Basic (Declaration)
Public Const TooltipExportToRTFProperty As String
Visual C++
public:
literal String^ TooltipExportToRTFProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipExportToXPSProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipExportToXPSProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for export to Xps.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipExportToXPSProperty
Visual Basic (Declaration)
Public Const TooltipExportToXPSProperty As String
Visual C++
public:
literal String^ TooltipExportToXPSProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipFindNextProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipFindNextProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for the next search result.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipFindNextProperty
Visual Basic (Declaration)
Public Const TooltipFindNextProperty As String
Visual C++
public:
literal String^ TooltipFindNextProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipFindPreviousProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipFindPreviousProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for switching to the previous search result.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipFindPreviousProperty
Visual Basic (Declaration)
Public Const TooltipFindPreviousProperty As String
Visual C++
public:
literal String^ TooltipFindPreviousProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipFindProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipFindProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for search starting.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipFindProperty
Visual Basic (Declaration)
Public Const TooltipFindProperty As String
Visual C++
public:
literal String^ TooltipFindProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipFirstPageProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipFirstPageProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for switching to the first page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipFirstPageProperty
Visual Basic (Declaration)
Public Const TooltipFirstPageProperty As String
Visual C++
public:
literal String^ TooltipFirstPageProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipForwardProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipForwardProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for switching to the next state saved in history.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipForwardProperty
Visual Basic (Declaration)
Public Const TooltipForwardProperty As String
Visual C++
public:
literal String^ TooltipForwardProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipLastPageProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipLastPageProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for switching to the last page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipLastPageProperty
Visual Basic (Declaration)
Public Const TooltipLastPageProperty As String
Visual C++
public:
literal String^ TooltipLastPageProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipMultiPageModeProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipMultiPageModeProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for the multipage viewing mode.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipMultiPageModeProperty
Visual Basic (Declaration)
Public Const TooltipMultiPageModeProperty As String
Visual C++
public:
literal String^ TooltipMultiPageModeProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipNextPageProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipNextPageProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for switching to the next page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipNextPageProperty
Visual Basic (Declaration)
Public Const TooltipNextPageProperty As String
Visual C++
public:
literal String^ TooltipNextPageProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipPageWidthProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipPageWidthProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for scaling equal to the page width.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipPageWidthProperty
Visual Basic (Declaration)
Public Const TooltipPageWidthProperty As String
Visual C++
public:
literal String^ TooltipPageWidthProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipPanProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipPanProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for report scrolling mode.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipPanProperty
Visual Basic (Declaration)
Public Const TooltipPanProperty As String
Visual C++
public:
literal String^ TooltipPanProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipPreviousPageProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipPreviousPageProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for switching to the previous search result.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipPreviousPageProperty
Visual Basic (Declaration)
Public Const TooltipPreviousPageProperty As String
Visual C++
public:
literal String^ TooltipPreviousPageProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipSearchProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipSearchProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for the search text input.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipSearchProperty
Visual Basic (Declaration)
Public Const TooltipSearchProperty As String
Visual C++
public:
literal String^ TooltipSearchProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipSelectProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipSelectProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for setting mode of the report elements selection.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipSelectProperty
Visual Basic (Declaration)
Public Const TooltipSelectProperty As String
Visual C++
public:
literal String^ TooltipSelectProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipSinglePageModeProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipSinglePageModeProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for switching to report single page viewing mode.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipSinglePageModeProperty
Visual Basic (Declaration)
Public Const TooltipSinglePageModeProperty As String
Visual C++
public:
literal String^ TooltipSinglePageModeProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipWholePageProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipWholePageProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for scaling equal to the whole page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipWholePageProperty
Visual Basic (Declaration)
Public Const TooltipWholePageProperty As String
Visual C++
public:
literal String^ TooltipWholePageProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipZoom100Property Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipZoom100Property Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for 100% scaling of original.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipZoom100Property
Visual Basic (Declaration)
Public Const TooltipZoom100Property As String
Visual C++
public:
literal String^ TooltipZoom100Property

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipZoomDecreaseProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipZoomDecreaseProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for scale decreasing.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipZoomDecreaseProperty
Visual Basic (Declaration)
Public Const TooltipZoomDecreaseProperty As String
Visual C++
public:
literal String^ TooltipZoomDecreaseProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipZoomDynamicProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipZoomDynamicProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for dynamic scaling. The scaling is performed with dragging.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipZoomDynamicProperty
Visual Basic (Declaration)
Public Const TooltipZoomDynamicProperty As String
Visual C++
public:
literal String^ TooltipZoomDynamicProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipZoomIncreaseProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipZoomIncreaseProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for scale increasing.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipZoomIncreaseProperty
Visual Basic (Declaration)
Public Const TooltipZoomIncreaseProperty As String
Visual C++
public:
literal String^ TooltipZoomIncreaseProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipZoomInProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipZoomInProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for zooming in a report.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipZoomInProperty
Visual Basic (Declaration)
Public Const TooltipZoomInProperty As String
Visual C++
public:
literal String^ TooltipZoomInProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipZoomOutProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipZoomOutProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for zooming out a report.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipZoomOutProperty
Visual Basic (Declaration)
Public Const TooltipZoomOutProperty As String
Visual C++
public:
literal String^ TooltipZoomOutProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipZoomToRegionProperty Field

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipZoomToRegionProperty Field
LocalizationManager Class See Also Send Feedback
Gets default tooltip for the control which is responsible for scaling in the selected region.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public const string TooltipZoomToRegionProperty
Visual Basic (Declaration)
Public Const TooltipZoomToRegionProperty As String
Visual C++
public:
literal String^ TooltipZoomToRegionProperty

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


LocalizationManager Methods

[image] [image]

.NET ModelKit Suite ClassReference
LocalizationManager Methods
LocalizationManager Class See Also Send Feedback

The LocalizationManager type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


LocalizationManager Properties

[image] [image]

.NET ModelKit Suite ClassReference
LocalizationManager Properties
LocalizationManager Class See Also Send Feedback

The LocalizationManager type exposes the following members.

Properties

Name | Description
NoReportToDisplay | Gets the message which states that selected report is not available.
PageLoading | Gets the page loading message.
ProgressLoading | Gets the text which informs about the report loading process.
ProgressRendering | Gets the text which informs about the report rendering process.
ServerError | Gets the server error message.
TooltipBackward | Gets the tooltip for the control which is responsible for switching to the previous state saved in history.
TooltipContinuedPageMode | Gets the tooltip for the control which is responsible for switching to the continued page viewing mode.
TooltipCurrentPage | Gets the tooltip for the control which is responsible for displaying the current page number.
TooltipExportToExcel | Gets the tooltip for the control which is responsible for export to Excel.
TooltipExportToHtml | Gets the tooltip for the control which is responsible for export to HTML.
TooltipExportToPDF | Gets the tooltip for the control which is responsible for export to PDF.
TooltipExportToRTF | Gets the tooltip for the control which is responsible for export to RTF.
TooltipExportToXPS | Gets the tooltip for the control which is responsible for export to Xps.
TooltipFind | Gets the tooltip for the control which is responsible for search starting.
TooltipFindNext | Gets the tooltip for the control which is responsible for switching to the next search result.
TooltipFindPrevious | Gets the tooltip for the control which is responsible for switching to the previous search result.
TooltipFirstPage | Gets the tooltip for the control which is responsible for switching to the first page.
TooltipForward | Gets the tooltip for the control which is responsible for switching to the next state saved in history.
TooltipLastPage | Gets the tooltip for the control which is responsible for switching to the last page.
TooltipMultiPageMode | Gets the tooltip for the control which is responsible for the multipage viewing mode.
TooltipNextPage | Gets the tooltip for the control which is responsible for switching to the next page.
TooltipPageWidth | Gets the tooltip for the control which is responsible for scaling equal to the page width.
TooltipPan | Gets the tooltip for the control which is responsible for report panning mode.
TooltipPreviousPage | Gets the tooltip for the control which is responsible for switching to the previous search result.
TooltipSearch | Gets the tooltip for the control which is responsible for the search text input.
TooltipSelect | Gets the tooltip for the control which is responsible for setting mode of the report elements selection.
TooltipSinglePageMode | Gets the tooltip for the control which is responsible for switching to report single page viewing mode.
TooltipWholePage | Gets the tooltip for the control which is responsible for scaling equal to the whole page.
TooltipZoom100 | Gets the tooltip for the control which is responsible for 100% scaling of original.
TooltipZoomDecrease | Gets the tooltip for the control which is responsible for the scale decreasing.
TooltipZoomDynamic | Gets the tooltip for the control which is responsible for dynamic scaling. The scaling is performed by pressing the left mouse button and moving pointer.
TooltipZoomIn | Gets the tooltip for the control which is responsible for zooming in the report.
TooltipZoomIncrease | Gets the tooltip for the control which is responsible for the scale increasing.
TooltipZoomOut | Gets the tooltip for the control which is responsible for zooming out the report.
TooltipZoomToRegion | Gets the tooltip for the control which is responsible for scaling in the selected area.

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


NoReportToDisplay Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.NoReportToDisplay Property
LocalizationManager Class See Also Send Feedback
Gets the message which states that selected report is not available.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string NoReportToDisplay { get; }
Visual Basic (Declaration)
Public ReadOnly Property NoReportToDisplay As String
Visual C++
public:
property String^ NoReportToDisplay {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


PageLoading Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.PageLoading Property
LocalizationManager Class See Also Send Feedback
Gets the page loading message.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string PageLoading { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageLoading As String
Visual C++
public:
property String^ PageLoading {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


ProgressLoading Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.ProgressLoading Property
LocalizationManager Class See Also Send Feedback
Gets the text which informs about the report loading process.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string ProgressLoading { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProgressLoading As String
Visual C++
public:
property String^ ProgressLoading {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


ProgressRendering Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.ProgressRendering Property
LocalizationManager Class See Also Send Feedback
Gets the text which informs about the report rendering process.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string ProgressRendering { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProgressRendering As String
Visual C++
public:
property String^ ProgressRendering {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


ServerError Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.ServerError Property
LocalizationManager Class See Also Send Feedback
Gets the server error message.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string ServerError { get; }
Visual Basic (Declaration)
Public ReadOnly Property ServerError As String
Visual C++
public:
property String^ ServerError {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipBackward Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipBackward Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for switching to the previous state saved in history.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipBackward { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipBackward As String
Visual C++
public:
property String^ TooltipBackward {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipContinuedPageMode Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipContinuedPageMode Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for switching to the continued page viewing mode.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipContinuedPageMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipContinuedPageMode As String
Visual C++
public:
property String^ TooltipContinuedPageMode {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipCurrentPage Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipCurrentPage Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for displaying the current page number.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipCurrentPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipCurrentPage As String
Visual C++
public:
property String^ TooltipCurrentPage {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipExportToExcel Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipExportToExcel Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for export to Excel.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipExportToExcel { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipExportToExcel As String
Visual C++
public:
property String^ TooltipExportToExcel {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipExportToHtml Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipExportToHtml Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for export to HTML.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipExportToHtml { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipExportToHtml As String
Visual C++
public:
property String^ TooltipExportToHtml {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipExportToPDF Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipExportToPDF Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for export to PDF.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipExportToPDF { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipExportToPDF As String
Visual C++
public:
property String^ TooltipExportToPDF {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipExportToRTF Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipExportToRTF Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for export to RTF.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipExportToRTF { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipExportToRTF As String
Visual C++
public:
property String^ TooltipExportToRTF {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipExportToXPS Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipExportToXPS Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for export to Xps.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipExportToXPS { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipExportToXPS As String
Visual C++
public:
property String^ TooltipExportToXPS {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipFind Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipFind Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for search starting.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipFind { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipFind As String
Visual C++
public:
property String^ TooltipFind {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipFindNext Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipFindNext Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for switching to the next search result.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipFindNext { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipFindNext As String
Visual C++
public:
property String^ TooltipFindNext {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipFindPrevious Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipFindPrevious Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for switching to the previous search result.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipFindPrevious { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipFindPrevious As String
Visual C++
public:
property String^ TooltipFindPrevious {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipFirstPage Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipFirstPage Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for switching to the first page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipFirstPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipFirstPage As String
Visual C++
public:
property String^ TooltipFirstPage {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipForward Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipForward Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for switching to the next state saved in history.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipForward { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipForward As String
Visual C++
public:
property String^ TooltipForward {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipLastPage Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipLastPage Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for switching to the last page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipLastPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipLastPage As String
Visual C++
public:
property String^ TooltipLastPage {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipMultiPageMode Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipMultiPageMode Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for the multipage viewing mode.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipMultiPageMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipMultiPageMode As String
Visual C++
public:
property String^ TooltipMultiPageMode {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipNextPage Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipNextPage Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for switching to the next page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipNextPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipNextPage As String
Visual C++
public:
property String^ TooltipNextPage {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipPageWidth Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipPageWidth Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for scaling equal to the page width.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipPageWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipPageWidth As String
Visual C++
public:
property String^ TooltipPageWidth {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipPan Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipPan Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for report panning mode.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipPan { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipPan As String
Visual C++
public:
property String^ TooltipPan {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipPreviousPage Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipPreviousPage Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for switching to the previous search result.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipPreviousPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipPreviousPage As String
Visual C++
public:
property String^ TooltipPreviousPage {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipSearch Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipSearch Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for the search text input.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipSearch { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipSearch As String
Visual C++
public:
property String^ TooltipSearch {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipSelect Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipSelect Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for setting mode of the report elements selection.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipSelect { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipSelect As String
Visual C++
public:
property String^ TooltipSelect {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipSinglePageMode Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipSinglePageMode Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for switching to report single page viewing mode.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipSinglePageMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipSinglePageMode As String
Visual C++
public:
property String^ TooltipSinglePageMode {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipWholePage Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipWholePage Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for scaling equal to the whole page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipWholePage { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipWholePage As String
Visual C++
public:
property String^ TooltipWholePage {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipZoom100 Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipZoom100 Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for 100% scaling of original.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipZoom100 { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipZoom100 As String
Visual C++
public:
property String^ TooltipZoom100 {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipZoomDecrease Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipZoomDecrease Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for the scale decreasing.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipZoomDecrease { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipZoomDecrease As String
Visual C++
public:
property String^ TooltipZoomDecrease {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipZoomDynamic Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipZoomDynamic Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for dynamic scaling. The scaling is performed by pressing the left mouse button and moving pointer.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipZoomDynamic { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipZoomDynamic As String
Visual C++
public:
property String^ TooltipZoomDynamic {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipZoomIn Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipZoomIn Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for zooming in the report.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipZoomIn { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipZoomIn As String
Visual C++
public:
property String^ TooltipZoomIn {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipZoomIncrease Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipZoomIncrease Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for the scale increasing.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipZoomIncrease { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipZoomIncrease As String
Visual C++
public:
property String^ TooltipZoomIncrease {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipZoomOut Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipZoomOut Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for zooming out the report.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipZoomOut { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipZoomOut As String
Visual C++
public:
property String^ TooltipZoomOut {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


TooltipZoomToRegion Property

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.TooltipZoomToRegion Property
LocalizationManager Class See Also Send Feedback
Gets the tooltip for the control which is responsible for scaling in the selected area.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string TooltipZoomToRegion { get; }
Visual Basic (Declaration)
Public ReadOnly Property TooltipZoomToRegion As String
Visual C++
public:
property String^ TooltipZoomToRegion {
    String^ get ();
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


LocalizationManager Events

[image] [image]

.NET ModelKit Suite ClassReference
LocalizationManager Events
LocalizationManager Class See Also Send Feedback

The LocalizationManager type exposes the following members.

Events

Name | Description
Loaded | Occurs when the dictionary is loaded.
PropertyChanged | Occurs when localization strings are changed.

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


Loaded Event

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.Loaded Event
LocalizationManager Class See Also Send Feedback
Occurs when the dictionary is loaded.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler Loaded
Visual Basic (Declaration)
Public Event Loaded As EventHandler
Visual C++
public:
 event EventHandler^ Loaded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


PropertyChanged Event

[image]

.NET ModelKit Suite ClassReference
LocalizationManager..::.PropertyChanged Event
LocalizationManager Class See Also Send Feedback
Occurs when localization strings are changed.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Localization
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

LocalizationManager Class
PerpetuumSoft.Reporting.Silverlight.Client.Localization Namespace


PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace
Send Feedback
The PerpetuumSoft.Reporting.Silverlight.ReportService namespace contains classes to interact with report build service.

Classes

Class | Description
DocumentInfo | Represents document data.
ExceptionDetailBase | Represents a basic class for all exceptions wrappers generated by server.
ExportCompletedEventArgs | Parameters class of the event which occurs when report export is finished.
FindCompletedEventArgs | Parameters of the event which occurs when text search is finished.
GetDocumentInfoCompletedEventArgs | Parameters of the event which occurs when document information getting is finished.
GetFontCompletedEventArgs | Parameters class of the event which occurs when font loading is finished.
GetImageCompletedEventArgs | Parameters class of the event which occurs when image getting is finished.
GetPageInfoCompletedEventArgs | Parameters of the event which occurs when report page information getting is finished.
GetResourceCompletedEventArgs | Parameters class of the event which occurs when resource getting is finished.
NoCachedDocumentExceptionDetail | Represents an exception wrapper generated when document is not found in cash.
PageInfo | Represents report page metadata.
RenderCompletedEventArgs | Parameters of the event which occurs when report rendering is finished.
ReportServiceClient | Reports service class.
ReportServiceResourcesClient | A class for getting resources from server. The resources are needed for getting the report.
SearchResult | Represents text search results.

Structures

Structure | Description
FindOptions | Represents text search mode data.
SizeF | Size.

Interfaces

Interface | Description
IReportService | Exposes a method for getting report.
IReportServiceChannel | The interface which defines channel methods between client application and report service.
IReportServiceResources | Exposes a method for report resources getting.
IReportServiceResourcesChannel | The interface which defines the channel methods between client application and resource service.

Enumerations

Enumeration | Description
SearchDirection | Sets search direction.


DocumentInfo Class

[image]

.NET ModelKit Suite ClassReference
DocumentInfo Class
Members See Also Send Feedback
Represents document data.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class DocumentInfo : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class DocumentInfo _
    Implements INotifyPropertyChanged
Visual C++
public ref class DocumentInfo : INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.DocumentInfo

See Also

DocumentInfo Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


DocumentInfo Members

[image] [image]

.NET ModelKit Suite ClassReference
DocumentInfo Members
DocumentInfo Class Constructors Methods Properties Events See Also Send Feedback

The DocumentInfo type exposes the following members.

Constructors

Name | Description
DocumentInfo | Initializes a new instance of the DocumentInfo class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged | Raises the PropertyChanged event.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PagesSizes | Gets or sets ObservableCollection<(Of <(SizeF>)>) which are page sizes.
Title | Gets or sets document title.

Events

Name | Description
PropertyChanged | Occurs after the value of an document property is changed.

See Also

DocumentInfo Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


DocumentInfo Constructor

[image]

.NET ModelKit Suite ClassReference
DocumentInfo Constructor
DocumentInfo Class See Also Send Feedback
Initializes a new instance of the DocumentInfo class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public DocumentInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentInfo()

See Also

DocumentInfo Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


DocumentInfo Methods

[image] [image]

.NET ModelKit Suite ClassReference
DocumentInfo Methods
DocumentInfo Class See Also Send Feedback

The DocumentInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged | Raises the PropertyChanged event.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentInfo Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


RaisePropertyChanged Method

[image]

.NET ModelKit Suite ClassReference
DocumentInfo..::.RaisePropertyChanged Method
DocumentInfo Class See Also Send Feedback
Raises the PropertyChanged event.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::.String

See Also

DocumentInfo Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


DocumentInfo Properties

[image] [image]

.NET ModelKit Suite ClassReference
DocumentInfo Properties
DocumentInfo Class See Also Send Feedback

The DocumentInfo type exposes the following members.

Properties

Name | Description
PagesSizes | Gets or sets ObservableCollection<(Of <(SizeF>)>) which are page sizes.
Title | Gets or sets document title.

See Also

DocumentInfo Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


PagesSizes Property

[image]

.NET ModelKit Suite ClassReference
DocumentInfo..::.PagesSizes Property
DocumentInfo Class See Also Send Feedback
Gets or sets ObservableCollection<(Of <(SizeF>)>) which are page sizes.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ObservableCollection<SizeF> PagesSizes { get; set; }
Visual Basic (Declaration)
Public Property PagesSizes As ObservableCollection(Of SizeF)
Visual C++
public:
property ObservableCollection<SizeF>^ PagesSizes {
    ObservableCollection<SizeF>^ get ();
    void set (ObservableCollection<SizeF>^ value);
}

See Also

DocumentInfo Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


Title Property

[image]

.NET ModelKit Suite ClassReference
DocumentInfo..::.Title Property
DocumentInfo Class See Also Send Feedback
Gets or sets document title.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

DocumentInfo Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


DocumentInfo Events

[image] [image]

.NET ModelKit Suite ClassReference
DocumentInfo Events
DocumentInfo Class See Also Send Feedback

The DocumentInfo type exposes the following members.

Events

Name | Description
PropertyChanged | Occurs after the value of an document property is changed.

See Also

DocumentInfo Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


PropertyChanged Event

[image]

.NET ModelKit Suite ClassReference
DocumentInfo..::.PropertyChanged Event
DocumentInfo Class See Also Send Feedback
Occurs after the value of an document property is changed.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DocumentInfo Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ExceptionDetailBase Class

[image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase Class
Members See Also Send Feedback
Represents a basic class for all exceptions wrappers generated by server.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ExceptionDetailBase : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class ExceptionDetailBase _
    Implements INotifyPropertyChanged
Visual C++
public ref class ExceptionDetailBase : INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.ExceptionDetailBase
PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.NoCachedDocumentExceptionDetail

See Also

ExceptionDetailBase Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ExceptionDetailBase Members

[image] [image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase Members
ExceptionDetailBase Class Constructors Methods Properties Events See Also Send Feedback

The ExceptionDetailBase type exposes the following members.

Constructors

Name | Description
ExceptionDetailBase | Initializes a new instance of the ExceptionDetailBase class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged | Raises the PropertyChanged event.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
InnerException | Gets or sets ExceptionDetailBase which is the inner exception wrapper.
Message | Gets or sets error message.

Events

Name | Description
PropertyChanged | Occurs after the value of an exception property is changed.

See Also

ExceptionDetailBase Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ExceptionDetailBase Constructor

[image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase Constructor
ExceptionDetailBase Class See Also Send Feedback
Initializes a new instance of the ExceptionDetailBase class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ExceptionDetailBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExceptionDetailBase()

See Also

ExceptionDetailBase Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ExceptionDetailBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase Methods
ExceptionDetailBase Class See Also Send Feedback

The ExceptionDetailBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged | Raises the PropertyChanged event.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExceptionDetailBase Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


RaisePropertyChanged Method

[image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase..::.RaisePropertyChanged Method
ExceptionDetailBase Class See Also Send Feedback
Raises the PropertyChanged event.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::.String

See Also

ExceptionDetailBase Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ExceptionDetailBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase Properties
ExceptionDetailBase Class See Also Send Feedback

The ExceptionDetailBase type exposes the following members.

Properties

Name | Description
InnerException | Gets or sets ExceptionDetailBase which is the inner exception wrapper.
Message | Gets or sets error message.

See Also

ExceptionDetailBase Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


InnerException Property

[image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase..::.InnerException Property
ExceptionDetailBase Class See Also Send Feedback
Gets or sets ExceptionDetailBase which is the inner exception wrapper.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ExceptionDetailBase InnerException { get; set; }
Visual Basic (Declaration)
Public Property InnerException As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ InnerException {
    ExceptionDetailBase^ get ();
    void set (ExceptionDetailBase^ value);
}

See Also

ExceptionDetailBase Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


Message Property

[image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase..::.Message Property
ExceptionDetailBase Class See Also Send Feedback
Gets or sets error message.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string Message { get; set; }
Visual Basic (Declaration)
Public Property Message As String
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

See Also

ExceptionDetailBase Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ExceptionDetailBase Events

[image] [image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase Events
ExceptionDetailBase Class See Also Send Feedback

The ExceptionDetailBase type exposes the following members.

Events

Name | Description
PropertyChanged | Occurs after the value of an exception property is changed.

See Also

ExceptionDetailBase Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


PropertyChanged Event

[image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase..::.PropertyChanged Event
ExceptionDetailBase Class See Also Send Feedback
Occurs after the value of an exception property is changed.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ExceptionDetailBase Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ExportCompletedEventArgs Class

[image]

.NET ModelKit Suite ClassReference
ExportCompletedEventArgs Class
Members See Also Send Feedback
Parameters class of the event which occurs when report export is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ExportCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class ExportCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class ExportCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.ExportCompletedEventArgs

See Also

ExportCompletedEventArgs Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ExportCompletedEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
ExportCompletedEventArgs Members
ExportCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ExportCompletedEventArgs type exposes the following members.

Constructors

Name | Description
ExportCompletedEventArgs | Initializes a new instance of the ExportCompletedEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result | Gets the operation execution result.
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ExportCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ExportCompletedEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
ExportCompletedEventArgs Constructor
ExportCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the ExportCompletedEventArgs class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ExportCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
ExportCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

ExportCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ExportCompletedEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
ExportCompletedEventArgs Methods
ExportCompletedEventArgs Class See Also Send Feedback

The ExportCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExportCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ExportCompletedEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
ExportCompletedEventArgs Properties
ExportCompletedEventArgs Class See Also Send Feedback

The ExportCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result | Gets the operation execution result.
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ExportCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


Result Property

[image]

.NET ModelKit Suite ClassReference
ExportCompletedEventArgs..::.Result Property
ExportCompletedEventArgs Class See Also Send Feedback
Gets the operation execution result.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public byte[] Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As Byte()
Visual C++
public:
property array<unsigned char>^ Result {
    array<unsigned char>^ get ();
}

See Also

ExportCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


FindCompletedEventArgs Class

[image]

.NET ModelKit Suite ClassReference
FindCompletedEventArgs Class
Members See Also Send Feedback
Parameters of the event which occurs when text search is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class FindCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class FindCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class FindCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.FindCompletedEventArgs

See Also

FindCompletedEventArgs Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


FindCompletedEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
FindCompletedEventArgs Members
FindCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The FindCompletedEventArgs type exposes the following members.

Constructors

Name | Description
FindCompletedEventArgs | Initializes a new instance of the FindCompletedEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError | Gets ExceptionDetailBase which is wrapper of exception occurred during operation execution.
Result | Gets SearchResult which is operation execution result.
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

FindCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


FindCompletedEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
FindCompletedEventArgs Constructor
FindCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the FindCompletedEventArgs class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public FindCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
FindCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

FindCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


FindCompletedEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
FindCompletedEventArgs Methods
FindCompletedEventArgs Class See Also Send Feedback

The FindCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FindCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


FindCompletedEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
FindCompletedEventArgs Properties
FindCompletedEventArgs Class See Also Send Feedback

The FindCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError | Gets ExceptionDetailBase which is wrapper of exception occurred during operation execution.
Result | Gets SearchResult which is operation execution result.
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

FindCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportError Property

[image]

.NET ModelKit Suite ClassReference
FindCompletedEventArgs..::.ReportError Property
FindCompletedEventArgs Class See Also Send Feedback
Gets ExceptionDetailBase which is wrapper of exception occurred during operation execution.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ExceptionDetailBase ReportError { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReportError As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ ReportError {
    ExceptionDetailBase^ get ();
}

See Also

FindCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


Result Property

[image]

.NET ModelKit Suite ClassReference
FindCompletedEventArgs..::.Result Property
FindCompletedEventArgs Class See Also Send Feedback
Gets SearchResult which is operation execution result.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public SearchResult Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As SearchResult
Visual C++
public:
property SearchResult^ Result {
    SearchResult^ get ();
}

See Also

FindCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


FindOptions Structure

[image]

.NET ModelKit Suite ClassReference
FindOptions Structure
Members See Also Send Feedback
Represents text search mode data.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public struct FindOptions : INotifyPropertyChanged
Visual Basic (Declaration)
Public Structure FindOptions _
    Implements INotifyPropertyChanged
Visual C++
public value class FindOptions : INotifyPropertyChanged

See Also

FindOptions Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


FindOptions Members

[image] [image]

.NET ModelKit Suite ClassReference
FindOptions Members
FindOptions Structure Methods Properties Events See Also Send Feedback

The FindOptions type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Direction | Gets or sets SearchDirection which defines search direction.
FindText | Gets or sets a required text.
StartLocation | Gets or sets SearchResult which sets where to begin text search from.

Events

Name | Description
PropertyChanged | Occurs after the value of an search options property is changed.

See Also

FindOptions Structure
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


FindOptions Methods

[image] [image]

.NET ModelKit Suite ClassReference
FindOptions Methods
FindOptions Structure See Also Send Feedback

The FindOptions type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

FindOptions Structure
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


FindOptions Properties

[image] [image]

.NET ModelKit Suite ClassReference
FindOptions Properties
FindOptions Structure See Also Send Feedback

The FindOptions type exposes the following members.

Properties

Name | Description
Direction | Gets or sets SearchDirection which defines search direction.
FindText | Gets or sets a required text.
StartLocation | Gets or sets SearchResult which sets where to begin text search from.

See Also

FindOptions Structure
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


Direction Property

[image]

.NET ModelKit Suite ClassReference
FindOptions..::.Direction Property
FindOptions Structure See Also Send Feedback
Gets or sets SearchDirection which defines search direction.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public SearchDirection Direction { get; set; }
Visual Basic (Declaration)
Public Property Direction As SearchDirection
Visual C++
public:
property SearchDirection Direction {
    SearchDirection get ();
    void set (SearchDirection value);
}

See Also

FindOptions Structure
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


FindText Property

[image]

.NET ModelKit Suite ClassReference
FindOptions..::.FindText Property
FindOptions Structure See Also Send Feedback
Gets or sets a required text.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string FindText { get; set; }
Visual Basic (Declaration)
Public Property FindText As String
Visual C++
public:
property String^ FindText {
    String^ get ();
    void set (String^ value);
}

See Also

FindOptions Structure
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


StartLocation Property

[image]

.NET ModelKit Suite ClassReference
FindOptions..::.StartLocation Property
FindOptions Structure See Also Send Feedback
Gets or sets SearchResult which sets where to begin text search from.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public SearchResult StartLocation { get; set; }
Visual Basic (Declaration)
Public Property StartLocation As SearchResult
Visual C++
public:
property SearchResult^ StartLocation {
    SearchResult^ get ();
    void set (SearchResult^ value);
}

See Also

FindOptions Structure
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


FindOptions Events

[image] [image]

.NET ModelKit Suite ClassReference
FindOptions Events
FindOptions Structure See Also Send Feedback

The FindOptions type exposes the following members.

Events

Name | Description
PropertyChanged | Occurs after the value of an search options property is changed.

See Also

FindOptions Structure
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


PropertyChanged Event

[image]

.NET ModelKit Suite ClassReference
FindOptions..::.PropertyChanged Event
FindOptions Structure See Also Send Feedback
Occurs after the value of an search options property is changed.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

FindOptions Structure
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetDocumentInfoCompletedEventArgs Class

[image]

.NET ModelKit Suite ClassReference
GetDocumentInfoCompletedEventArgs Class
Members See Also Send Feedback
Parameters of the event which occurs when document information getting is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class GetDocumentInfoCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class GetDocumentInfoCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class GetDocumentInfoCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.GetDocumentInfoCompletedEventArgs

See Also

GetDocumentInfoCompletedEventArgs Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetDocumentInfoCompletedEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
GetDocumentInfoCompletedEventArgs Members
GetDocumentInfoCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetDocumentInfoCompletedEventArgs type exposes the following members.

Constructors

Name | Description
GetDocumentInfoCompletedEventArgs | Initializes a new instance of the GetDocumentInfoCompletedEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError | Gets ExceptionDetailBase which is wrapper of exception occurred during operation execution.
Result | Gets DocumentInfo which is operation execution result.
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetDocumentInfoCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetDocumentInfoCompletedEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
GetDocumentInfoCompletedEventArgs Constructor
GetDocumentInfoCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetDocumentInfoCompletedEventArgs class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public GetDocumentInfoCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
GetDocumentInfoCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

GetDocumentInfoCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetDocumentInfoCompletedEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
GetDocumentInfoCompletedEventArgs Methods
GetDocumentInfoCompletedEventArgs Class See Also Send Feedback

The GetDocumentInfoCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetDocumentInfoCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetDocumentInfoCompletedEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
GetDocumentInfoCompletedEventArgs Properties
GetDocumentInfoCompletedEventArgs Class See Also Send Feedback

The GetDocumentInfoCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError | Gets ExceptionDetailBase which is wrapper of exception occurred during operation execution.
Result | Gets DocumentInfo which is operation execution result.
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetDocumentInfoCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportError Property

[image]

.NET ModelKit Suite ClassReference
GetDocumentInfoCompletedEventArgs..::.ReportError Property
GetDocumentInfoCompletedEventArgs Class See Also Send Feedback
Gets ExceptionDetailBase which is wrapper of exception occurred during operation execution.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ExceptionDetailBase ReportError { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReportError As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ ReportError {
    ExceptionDetailBase^ get ();
}

See Also

GetDocumentInfoCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


Result Property

[image]

.NET ModelKit Suite ClassReference
GetDocumentInfoCompletedEventArgs..::.Result Property
GetDocumentInfoCompletedEventArgs Class See Also Send Feedback
Gets DocumentInfo which is operation execution result.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public DocumentInfo Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As DocumentInfo
Visual C++
public:
property DocumentInfo^ Result {
    DocumentInfo^ get ();
}

See Also

GetDocumentInfoCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetFontCompletedEventArgs Class

[image]

.NET ModelKit Suite ClassReference
GetFontCompletedEventArgs Class
Members See Also Send Feedback
Parameters class of the event which occurs when font loading is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class GetFontCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class GetFontCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class GetFontCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.GetFontCompletedEventArgs

See Also

GetFontCompletedEventArgs Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetFontCompletedEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
GetFontCompletedEventArgs Members
GetFontCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetFontCompletedEventArgs type exposes the following members.

Constructors

Name | Description
GetFontCompletedEventArgs | Initializes a new instance of the GetFontCompletedEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result | Gets the operation execution result.
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetFontCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetFontCompletedEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
GetFontCompletedEventArgs Constructor
GetFontCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetFontCompletedEventArgs class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public GetFontCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
GetFontCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

GetFontCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetFontCompletedEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
GetFontCompletedEventArgs Methods
GetFontCompletedEventArgs Class See Also Send Feedback

The GetFontCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetFontCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetFontCompletedEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
GetFontCompletedEventArgs Properties
GetFontCompletedEventArgs Class See Also Send Feedback

The GetFontCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result | Gets the operation execution result.
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetFontCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


Result Property

[image]

.NET ModelKit Suite ClassReference
GetFontCompletedEventArgs..::.Result Property
GetFontCompletedEventArgs Class See Also Send Feedback
Gets the operation execution result.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public byte[] Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As Byte()
Visual C++
public:
property array<unsigned char>^ Result {
    array<unsigned char>^ get ();
}

See Also

GetFontCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetImageCompletedEventArgs Class

[image]

.NET ModelKit Suite ClassReference
GetImageCompletedEventArgs Class
Members See Also Send Feedback
Parameters class of the event which occurs when image getting is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class GetImageCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class GetImageCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class GetImageCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.GetImageCompletedEventArgs

See Also

GetImageCompletedEventArgs Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetImageCompletedEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
GetImageCompletedEventArgs Members
GetImageCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetImageCompletedEventArgs type exposes the following members.

Constructors

Name | Description
GetImageCompletedEventArgs | Initializes a new instance of the GetImageCompletedEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result | Gets the operation result.
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetImageCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetImageCompletedEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
GetImageCompletedEventArgs Constructor
GetImageCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetImageCompletedEventArgs class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public GetImageCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
GetImageCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

GetImageCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetImageCompletedEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
GetImageCompletedEventArgs Methods
GetImageCompletedEventArgs Class See Also Send Feedback

The GetImageCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetImageCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetImageCompletedEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
GetImageCompletedEventArgs Properties
GetImageCompletedEventArgs Class See Also Send Feedback

The GetImageCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result | Gets the operation result.
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetImageCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


Result Property

[image]

.NET ModelKit Suite ClassReference
GetImageCompletedEventArgs..::.Result Property
GetImageCompletedEventArgs Class See Also Send Feedback
Gets the operation result.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public byte[] Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As Byte()
Visual C++
public:
property array<unsigned char>^ Result {
    array<unsigned char>^ get ();
}

See Also

GetImageCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetPageInfoCompletedEventArgs Class

[image]

.NET ModelKit Suite ClassReference
GetPageInfoCompletedEventArgs Class
Members See Also Send Feedback
Parameters of the event which occurs when report page information getting is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class GetPageInfoCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class GetPageInfoCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class GetPageInfoCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.GetPageInfoCompletedEventArgs

See Also

GetPageInfoCompletedEventArgs Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetPageInfoCompletedEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
GetPageInfoCompletedEventArgs Members
GetPageInfoCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetPageInfoCompletedEventArgs type exposes the following members.

Constructors

Name | Description
GetPageInfoCompletedEventArgs | Initializes a new instance of the GetPageInfoCompletedEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError | Gets ExceptionDetailBase which is wrapper of exception occurred during operation execution.
Result | Gets PageInfo which is operation execution result.
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetPageInfoCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetPageInfoCompletedEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
GetPageInfoCompletedEventArgs Constructor
GetPageInfoCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetPageInfoCompletedEventArgs class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public GetPageInfoCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
GetPageInfoCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

GetPageInfoCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetPageInfoCompletedEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
GetPageInfoCompletedEventArgs Methods
GetPageInfoCompletedEventArgs Class See Also Send Feedback

The GetPageInfoCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetPageInfoCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetPageInfoCompletedEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
GetPageInfoCompletedEventArgs Properties
GetPageInfoCompletedEventArgs Class See Also Send Feedback

The GetPageInfoCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError | Gets ExceptionDetailBase which is wrapper of exception occurred during operation execution.
Result | Gets PageInfo which is operation execution result.
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetPageInfoCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportError Property

[image]

.NET ModelKit Suite ClassReference
GetPageInfoCompletedEventArgs..::.ReportError Property
GetPageInfoCompletedEventArgs Class See Also Send Feedback
Gets ExceptionDetailBase which is wrapper of exception occurred during operation execution.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ExceptionDetailBase ReportError { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReportError As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ ReportError {
    ExceptionDetailBase^ get ();
}

See Also

GetPageInfoCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


Result Property

[image]

.NET ModelKit Suite ClassReference
GetPageInfoCompletedEventArgs..::.Result Property
GetPageInfoCompletedEventArgs Class See Also Send Feedback
Gets PageInfo which is operation execution result.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public PageInfo Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As PageInfo
Visual C++
public:
property PageInfo^ Result {
    PageInfo^ get ();
}

See Also

GetPageInfoCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetResourceCompletedEventArgs Class

[image]

.NET ModelKit Suite ClassReference
GetResourceCompletedEventArgs Class
Members See Also Send Feedback
Parameters class of the event which occurs when resource getting is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class GetResourceCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class GetResourceCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class GetResourceCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.GetResourceCompletedEventArgs

See Also

GetResourceCompletedEventArgs Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetResourceCompletedEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
GetResourceCompletedEventArgs Members
GetResourceCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetResourceCompletedEventArgs type exposes the following members.

Constructors

Name | Description
GetResourceCompletedEventArgs | Initializes a new instance of the GetResourceCompletedEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result | Gets the operation result.
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetResourceCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetResourceCompletedEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
GetResourceCompletedEventArgs Constructor
GetResourceCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetResourceCompletedEventArgs class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public GetResourceCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
GetResourceCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

GetResourceCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetResourceCompletedEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
GetResourceCompletedEventArgs Methods
GetResourceCompletedEventArgs Class See Also Send Feedback

The GetResourceCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetResourceCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetResourceCompletedEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
GetResourceCompletedEventArgs Properties
GetResourceCompletedEventArgs Class See Also Send Feedback

The GetResourceCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result | Gets the operation result.
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetResourceCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


Result Property

[image]

.NET ModelKit Suite ClassReference
GetResourceCompletedEventArgs..::.Result Property
GetResourceCompletedEventArgs Class See Also Send Feedback
Gets the operation result.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public byte[] Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As Byte()
Visual C++
public:
property array<unsigned char>^ Result {
    array<unsigned char>^ get ();
}

See Also

GetResourceCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


IReportService Interface

[image]

.NET ModelKit Suite ClassReference
IReportService Interface
Members See Also Send Feedback
Exposes a method for getting report.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public interface IReportService
Visual Basic (Declaration)
Public Interface IReportService
Visual C++
public interface class IReportService

See Also

IReportService Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


IReportService Members

[image] [image]

.NET ModelKit Suite ClassReference
IReportService Members
IReportService Interface Methods See Also Send Feedback

The IReportService type exposes the following members.

Methods

Name | Description
BeginFind | Starts text search in a report.
BeginGetDocumentInfo | Begins the document data getting.
BeginGetPageInfo | Begins the page data getting.
BeginInit | Starts service initialization.
BeginRender | Starts report rendering.
EndFind | Ends text search in a report.
EndGetDocumentInfo | Ends the document data getting.
EndGetPageInfo | Ends the page data getting.
EndInit | Ends service initialization.
EndRender | Ends report rendering.

See Also

IReportService Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


IReportService Methods

[image] [image]

.NET ModelKit Suite ClassReference
IReportService Methods
IReportService Interface See Also Send Feedback

The IReportService type exposes the following members.

Methods

Name | Description
BeginFind | Starts text search in a report.
BeginGetDocumentInfo | Begins the document data getting.
BeginGetPageInfo | Begins the page data getting.
BeginInit | Starts service initialization.
BeginRender | Starts report rendering.
EndFind | Ends text search in a report.
EndGetDocumentInfo | Ends the document data getting.
EndGetPageInfo | Ends the page data getting.
EndInit | Ends service initialization.
EndRender | Ends report rendering.

See Also

IReportService Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


BeginFind Method

[image]

.NET ModelKit Suite ClassReference
IReportService..::.BeginFind Method
IReportService Interface See Also Send Feedback
Starts text search in a report.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
IAsyncResult BeginFind(
    string id,
    FindOptions findOptions,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginFind ( _
    id As String, _
    findOptions As FindOptions, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginFind(
    String^ id,
    FindOptions findOptions,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

id
Type: System..::.String
findOptions
Type: PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.FindOptions
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportService Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


BeginGetDocumentInfo Method

[image]

.NET ModelKit Suite ClassReference
IReportService..::.BeginGetDocumentInfo Method
IReportService Interface See Also Send Feedback
Begins the document data getting.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
IAsyncResult BeginGetDocumentInfo(
    string id,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginGetDocumentInfo ( _
    id As String, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginGetDocumentInfo(
    String^ id,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

id
Type: System..::.String
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportService Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


BeginGetPageInfo Method

[image]

.NET ModelKit Suite ClassReference
IReportService..::.BeginGetPageInfo Method
IReportService Interface See Also Send Feedback
Begins the page data getting.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
IAsyncResult BeginGetPageInfo(
    string id,
    int pageNumber,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginGetPageInfo ( _
    id As String, _
    pageNumber As Integer, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginGetPageInfo(
    String^ id,
    int pageNumber,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

id
Type: System..::.String
pageNumber
Type: System..::.Int32
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportService Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


BeginInit Method

[image]

.NET ModelKit Suite ClassReference
IReportService..::.BeginInit Method
IReportService Interface See Also Send Feedback
Starts service initialization.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
IAsyncResult BeginInit(
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginInit ( _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginInit(
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportService Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


BeginRender Method

[image]

.NET ModelKit Suite ClassReference
IReportService..::.BeginRender Method
IReportService Interface See Also Send Feedback
Starts report rendering.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
IAsyncResult BeginRender(
    Dictionary<string, Object> parameters,
    string reportName,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginRender ( _
    parameters As Dictionary(Of String, Object), _
    reportName As String, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginRender(
    Dictionary<String^, Object^>^ parameters,
    String^ reportName,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

parameters
Type: System.Collections.Generic..::.Dictionary <(Of <( String, Object >)>)
reportName
Type: System..::.String
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportService Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


EndFind Method

[image]

.NET ModelKit Suite ClassReference
IReportService..::.EndFind Method
IReportService Interface See Also Send Feedback
Ends text search in a report.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
SearchResult EndFind(
    out ExceptionDetailBase ReportError,
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndFind ( _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase, _
    result As IAsyncResult _
) As SearchResult
Visual C++
SearchResult^ EndFind(
    [OutAttribute] ExceptionDetailBase^% ReportError,
    IAsyncResult^ result
)

Parameters

ReportError
Type: PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.ExceptionDetailBase %
result
Type: System..::.IAsyncResult

See Also

IReportService Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


EndGetDocumentInfo Method

[image]

.NET ModelKit Suite ClassReference
IReportService..::.EndGetDocumentInfo Method
IReportService Interface See Also Send Feedback
Ends the document data getting.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
DocumentInfo EndGetDocumentInfo(
    out ExceptionDetailBase ReportError,
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndGetDocumentInfo ( _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase, _
    result As IAsyncResult _
) As DocumentInfo
Visual C++
DocumentInfo^ EndGetDocumentInfo(
    [OutAttribute] ExceptionDetailBase^% ReportError,
    IAsyncResult^ result
)

Parameters

ReportError
Type: PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.ExceptionDetailBase %
result
Type: System..::.IAsyncResult

See Also

IReportService Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


EndGetPageInfo Method

[image]

.NET ModelKit Suite ClassReference
IReportService..::.EndGetPageInfo Method
IReportService Interface See Also Send Feedback
Ends the page data getting.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
PageInfo EndGetPageInfo(
    out ExceptionDetailBase ReportError,
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndGetPageInfo ( _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase, _
    result As IAsyncResult _
) As PageInfo
Visual C++
PageInfo^ EndGetPageInfo(
    [OutAttribute] ExceptionDetailBase^% ReportError,
    IAsyncResult^ result
)

Parameters

ReportError
Type: PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.ExceptionDetailBase %
result
Type: System..::.IAsyncResult

See Also

IReportService Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


EndInit Method

[image]

.NET ModelKit Suite ClassReference
IReportService..::.EndInit Method
IReportService Interface See Also Send Feedback
Ends service initialization.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
void EndInit(
    IAsyncResult result
)
Visual Basic (Declaration)
Sub EndInit ( _
    result As IAsyncResult _
)
Visual C++
void EndInit(
    IAsyncResult^ result
)

Parameters

result
Type: System..::.IAsyncResult

See Also

IReportService Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


EndRender Method

[image]

.NET ModelKit Suite ClassReference
IReportService..::.EndRender Method
IReportService Interface See Also Send Feedback
Ends report rendering.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
string EndRender(
    out ExceptionDetailBase ReportError,
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndRender ( _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase, _
    result As IAsyncResult _
) As String
Visual C++
String^ EndRender(
    [OutAttribute] ExceptionDetailBase^% ReportError,
    IAsyncResult^ result
)

Parameters

ReportError
Type: PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.ExceptionDetailBase %
result
Type: System..::.IAsyncResult

See Also

IReportService Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


IReportServiceChannel Interface

[image]

.NET ModelKit Suite ClassReference
IReportServiceChannel Interface
Members See Also Send Feedback
The interface which defines channel methods between client application and report service.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public interface IReportServiceChannel : IReportService,
    IClientChannel, IContextChannel, IChannel, ICommunicationObject, IExtensibleObject<IContextChannel>,
    IDisposable
Visual Basic (Declaration)
Public Interface IReportServiceChannel _
    Implements IReportService, IClientChannel, IContextChannel, IChannel,  _
    ICommunicationObject, IExtensibleObject(Of IContextChannel), IDisposable
Visual C++
public interface class IReportServiceChannel : IReportService,
    IClientChannel, IContextChannel, IChannel, ICommunicationObject, IExtensibleObject<IContextChannel^>,
    IDisposable

See Also

IReportServiceChannel Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


IReportServiceChannel Members

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceChannel Members
IReportServiceChannel Interface Methods Properties Events See Also Send Feedback

The IReportServiceChannel type exposes the following members.

Methods

Name | Description
Abort | (Inherited from ICommunicationObject.)
BeginClose | Overloaded.
BeginDisplayInitializationUI | (Inherited from IClientChannel.)
BeginFind | Starts text search in a report. (Inherited from IReportService.)
BeginGetDocumentInfo | Begins the document data getting. (Inherited from IReportService.)
BeginGetPageInfo | Begins the page data getting. (Inherited from IReportService.)
BeginInit | Starts service initialization. (Inherited from IReportService.)
BeginOpen | Overloaded.
BeginRender | Starts report rendering. (Inherited from IReportService.)
Close | Overloaded.
DisplayInitializationUI | (Inherited from IClientChannel.)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
EndClose | (Inherited from ICommunicationObject.)
EndDisplayInitializationUI | (Inherited from IClientChannel.)
EndFind | Ends text search in a report. (Inherited from IReportService.)
EndGetDocumentInfo | Ends the document data getting. (Inherited from IReportService.)
EndGetPageInfo | Ends the page data getting. (Inherited from IReportService.)
EndInit | Ends service initialization. (Inherited from IReportService.)
EndOpen | (Inherited from ICommunicationObject.)
EndRender | Ends report rendering. (Inherited from IReportService.)
GetProperty<(Of <(T>)>) | (Inherited from IChannel.)
Open | Overloaded.

Properties

Name | Description
AllowInitializationUI | (Inherited from IClientChannel.)
AllowOutputBatching | (Inherited from IContextChannel.)
DidInteractiveInitialization | (Inherited from IClientChannel.)
Extensions | (Inherited from IExtensibleObject <(Of <( IContextChannel >)>).)
InputSession | (Inherited from IContextChannel.)
LocalAddress | (Inherited from IContextChannel.)
OperationTimeout | (Inherited from IContextChannel.)
OutputSession | (Inherited from IContextChannel.)
RemoteAddress | (Inherited from IContextChannel.)
SessionId | (Inherited from IContextChannel.)
State | (Inherited from ICommunicationObject.)
Via | (Inherited from IClientChannel.)

Events

Name | Description
Closed | (Inherited from ICommunicationObject.)
Closing | (Inherited from ICommunicationObject.)
Faulted | (Inherited from ICommunicationObject.)
Opened | (Inherited from ICommunicationObject.)
Opening | (Inherited from ICommunicationObject.)
UnknownMessageReceived | (Inherited from IClientChannel.)

See Also

IReportServiceChannel Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


IReportServiceChannel Methods

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceChannel Methods
IReportServiceChannel Interface See Also Send Feedback

The IReportServiceChannel type exposes the following members.

Methods

Name | Description
Abort | (Inherited from ICommunicationObject.)
BeginClose | Overloaded.
BeginDisplayInitializationUI | (Inherited from IClientChannel.)
BeginFind | Starts text search in a report. (Inherited from IReportService.)
BeginGetDocumentInfo | Begins the document data getting. (Inherited from IReportService.)
BeginGetPageInfo | Begins the page data getting. (Inherited from IReportService.)
BeginInit | Starts service initialization. (Inherited from IReportService.)
BeginOpen | Overloaded.
BeginRender | Starts report rendering. (Inherited from IReportService.)
Close | Overloaded.
DisplayInitializationUI | (Inherited from IClientChannel.)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
EndClose | (Inherited from ICommunicationObject.)
EndDisplayInitializationUI | (Inherited from IClientChannel.)
EndFind | Ends text search in a report. (Inherited from IReportService.)
EndGetDocumentInfo | Ends the document data getting. (Inherited from IReportService.)
EndGetPageInfo | Ends the page data getting. (Inherited from IReportService.)
EndInit | Ends service initialization. (Inherited from IReportService.)
EndOpen | (Inherited from ICommunicationObject.)
EndRender | Ends report rendering. (Inherited from IReportService.)
GetProperty<(Of <(T>)>) | (Inherited from IChannel.)
Open | Overloaded.

See Also

IReportServiceChannel Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


BeginClose Method

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceChannel..::.BeginClose Method
IReportServiceChannel Interface See Also Send Feedback

Overload List

Name | Description
BeginClose(AsyncCallback, Object) | (Inherited from ICommunicationObject.)
BeginClose(TimeSpan, AsyncCallback, Object) | (Inherited from ICommunicationObject.)

See Also

IReportServiceChannel Interface
IReportServiceChannel Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


BeginOpen Method

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceChannel..::.BeginOpen Method
IReportServiceChannel Interface See Also Send Feedback

Overload List

Name | Description
BeginOpen(AsyncCallback, Object) | (Inherited from ICommunicationObject.)
BeginOpen(TimeSpan, AsyncCallback, Object) | (Inherited from ICommunicationObject.)

See Also

IReportServiceChannel Interface
IReportServiceChannel Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


Close Method

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceChannel..::.Close Method
IReportServiceChannel Interface See Also Send Feedback

Overload List

Name | Description
Close()()() | (Inherited from ICommunicationObject.)
Close(TimeSpan) | (Inherited from ICommunicationObject.)

See Also

IReportServiceChannel Interface
IReportServiceChannel Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


Open Method

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceChannel..::.Open Method
IReportServiceChannel Interface See Also Send Feedback

Overload List

Name | Description
Open()()() | (Inherited from ICommunicationObject.)
Open(TimeSpan) | (Inherited from ICommunicationObject.)

See Also

IReportServiceChannel Interface
IReportServiceChannel Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


IReportServiceChannel Properties

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceChannel Properties
IReportServiceChannel Interface See Also Send Feedback

The IReportServiceChannel type exposes the following members.

Properties

Name | Description
AllowInitializationUI | (Inherited from IClientChannel.)
AllowOutputBatching | (Inherited from IContextChannel.)
DidInteractiveInitialization | (Inherited from IClientChannel.)
Extensions | (Inherited from IExtensibleObject <(Of <( IContextChannel >)>).)
InputSession | (Inherited from IContextChannel.)
LocalAddress | (Inherited from IContextChannel.)
OperationTimeout | (Inherited from IContextChannel.)
OutputSession | (Inherited from IContextChannel.)
RemoteAddress | (Inherited from IContextChannel.)
SessionId | (Inherited from IContextChannel.)
State | (Inherited from ICommunicationObject.)
Via | (Inherited from IClientChannel.)

See Also

IReportServiceChannel Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


IReportServiceChannel Events

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceChannel Events
IReportServiceChannel Interface See Also Send Feedback

The IReportServiceChannel type exposes the following members.

Events

Name | Description
Closed | (Inherited from ICommunicationObject.)
Closing | (Inherited from ICommunicationObject.)
Faulted | (Inherited from ICommunicationObject.)
Opened | (Inherited from ICommunicationObject.)
Opening | (Inherited from ICommunicationObject.)
UnknownMessageReceived | (Inherited from IClientChannel.)

See Also

IReportServiceChannel Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


IReportServiceResources Interface

[image]

.NET ModelKit Suite ClassReference
IReportServiceResources Interface
Members See Also Send Feedback
Exposes a method for report resources getting.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public interface IReportServiceResources
Visual Basic (Declaration)
Public Interface IReportServiceResources
Visual C++
public interface class IReportServiceResources

See Also

IReportServiceResources Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


IReportServiceResources Members

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceResources Members
IReportServiceResources Interface Methods See Also Send Feedback

The IReportServiceResources type exposes the following members.

Methods

Name | Description
BeginExport | Begins report export.
BeginGetFont | Begins font getting.
BeginGetImage | Begins getting image.
BeginGetResource | Begins resource getting.
EndExport | Ends report export.
EndGetFont | Ends font getting.
EndGetImage | Ends getting image.
EndGetResource | Ends resource getting.

See Also

IReportServiceResources Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


IReportServiceResources Methods

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceResources Methods
IReportServiceResources Interface See Also Send Feedback

The IReportServiceResources type exposes the following members.

Methods

Name | Description
BeginExport | Begins report export.
BeginGetFont | Begins font getting.
BeginGetImage | Begins getting image.
BeginGetResource | Begins resource getting.
EndExport | Ends report export.
EndGetFont | Ends font getting.
EndGetImage | Ends getting image.
EndGetResource | Ends resource getting.

See Also

IReportServiceResources Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


BeginExport Method

[image]

.NET ModelKit Suite ClassReference
IReportServiceResources..::.BeginExport Method
IReportServiceResources Interface See Also Send Feedback
Begins report export.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
IAsyncResult BeginExport(
    string id,
    string format,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginExport ( _
    id As String, _
    format As String, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginExport(
    String^ id,
    String^ format,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

id
Type: System..::.String
format
Type: System..::.String
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportServiceResources Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


BeginGetFont Method

[image]

.NET ModelKit Suite ClassReference
IReportServiceResources..::.BeginGetFont Method
IReportServiceResources Interface See Also Send Feedback
Begins font getting.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
IAsyncResult BeginGetFont(
    string resourceKey,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginGetFont ( _
    resourceKey As String, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginGetFont(
    String^ resourceKey,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

resourceKey
Type: System..::.String
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportServiceResources Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


BeginGetImage Method

[image]

.NET ModelKit Suite ClassReference
IReportServiceResources..::.BeginGetImage Method
IReportServiceResources Interface See Also Send Feedback
Begins getting image.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
IAsyncResult BeginGetImage(
    string id,
    int pageIndex,
    int controlIndex,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginGetImage ( _
    id As String, _
    pageIndex As Integer, _
    controlIndex As Integer, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginGetImage(
    String^ id,
    int pageIndex,
    int controlIndex,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

id
Type: System..::.String
pageIndex
Type: System..::.Int32
controlIndex
Type: System..::.Int32
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportServiceResources Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


BeginGetResource Method

[image]

.NET ModelKit Suite ClassReference
IReportServiceResources..::.BeginGetResource Method
IReportServiceResources Interface See Also Send Feedback
Begins resource getting.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
IAsyncResult BeginGetResource(
    string culture,
    AsyncCallback callback,
    Object asyncState
)
Visual Basic (Declaration)
Function BeginGetResource ( _
    culture As String, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginGetResource(
    String^ culture,
    AsyncCallback^ callback,
    Object^ asyncState
)

Parameters

culture
Type: System..::.String
callback
Type: System..::.AsyncCallback
asyncState
Type: System..::.Object

See Also

IReportServiceResources Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


EndExport Method

[image]

.NET ModelKit Suite ClassReference
IReportServiceResources..::.EndExport Method
IReportServiceResources Interface See Also Send Feedback
Ends report export.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
byte[] EndExport(
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndExport ( _
    result As IAsyncResult _
) As Byte()
Visual C++
array<unsigned char>^ EndExport(
    IAsyncResult^ result
)

Parameters

result
Type: System..::.IAsyncResult

See Also

IReportServiceResources Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


EndGetFont Method

[image]

.NET ModelKit Suite ClassReference
IReportServiceResources..::.EndGetFont Method
IReportServiceResources Interface See Also Send Feedback
Ends font getting.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
byte[] EndGetFont(
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndGetFont ( _
    result As IAsyncResult _
) As Byte()
Visual C++
array<unsigned char>^ EndGetFont(
    IAsyncResult^ result
)

Parameters

result
Type: System..::.IAsyncResult

See Also

IReportServiceResources Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


EndGetImage Method

[image]

.NET ModelKit Suite ClassReference
IReportServiceResources..::.EndGetImage Method
IReportServiceResources Interface See Also Send Feedback
Ends getting image.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
byte[] EndGetImage(
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndGetImage ( _
    result As IAsyncResult _
) As Byte()
Visual C++
array<unsigned char>^ EndGetImage(
    IAsyncResult^ result
)

Parameters

result
Type: System..::.IAsyncResult

See Also

IReportServiceResources Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


EndGetResource Method

[image]

.NET ModelKit Suite ClassReference
IReportServiceResources..::.EndGetResource Method
IReportServiceResources Interface See Also Send Feedback
Ends resource getting.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
byte[] EndGetResource(
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndGetResource ( _
    result As IAsyncResult _
) As Byte()
Visual C++
array<unsigned char>^ EndGetResource(
    IAsyncResult^ result
)

Parameters

result
Type: System..::.IAsyncResult

See Also

IReportServiceResources Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


IReportServiceResourcesChannel Interface

[image]

.NET ModelKit Suite ClassReference
IReportServiceResourcesChannel Interface
Members See Also Send Feedback
The interface which defines the channel methods between client application and resource service.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public interface IReportServiceResourcesChannel : IReportServiceResources,
    IClientChannel, IContextChannel, IChannel, ICommunicationObject, IExtensibleObject<IContextChannel>,
    IDisposable
Visual Basic (Declaration)
Public Interface IReportServiceResourcesChannel _
    Implements IReportServiceResources, IClientChannel, IContextChannel, IChannel,  _
    ICommunicationObject, IExtensibleObject(Of IContextChannel), IDisposable
Visual C++
public interface class IReportServiceResourcesChannel : IReportServiceResources,
    IClientChannel, IContextChannel, IChannel, ICommunicationObject, IExtensibleObject<IContextChannel^>,
    IDisposable

See Also

IReportServiceResourcesChannel Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


IReportServiceResourcesChannel Members

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceResourcesChannel Members
IReportServiceResourcesChannel Interface Methods Properties Events See Also Send Feedback

The IReportServiceResourcesChannel type exposes the following members.

Methods

Name | Description
Abort | (Inherited from ICommunicationObject.)
BeginClose | Overloaded.
BeginDisplayInitializationUI | (Inherited from IClientChannel.)
BeginExport | Begins report export. (Inherited from IReportServiceResources.)
BeginGetFont | Begins font getting. (Inherited from IReportServiceResources.)
BeginGetImage | Begins getting image. (Inherited from IReportServiceResources.)
BeginGetResource | Begins resource getting. (Inherited from IReportServiceResources.)
BeginOpen | Overloaded.
Close | Overloaded.
DisplayInitializationUI | (Inherited from IClientChannel.)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
EndClose | (Inherited from ICommunicationObject.)
EndDisplayInitializationUI | (Inherited from IClientChannel.)
EndExport | Ends report export. (Inherited from IReportServiceResources.)
EndGetFont | Ends font getting. (Inherited from IReportServiceResources.)
EndGetImage | Ends getting image. (Inherited from IReportServiceResources.)
EndGetResource | Ends resource getting. (Inherited from IReportServiceResources.)
EndOpen | (Inherited from ICommunicationObject.)
GetProperty<(Of <(T>)>) | (Inherited from IChannel.)
Open | Overloaded.

Properties

Name | Description
AllowInitializationUI | (Inherited from IClientChannel.)
AllowOutputBatching | (Inherited from IContextChannel.)
DidInteractiveInitialization | (Inherited from IClientChannel.)
Extensions | (Inherited from IExtensibleObject <(Of <( IContextChannel >)>).)
InputSession | (Inherited from IContextChannel.)
LocalAddress | (Inherited from IContextChannel.)
OperationTimeout | (Inherited from IContextChannel.)
OutputSession | (Inherited from IContextChannel.)
RemoteAddress | (Inherited from IContextChannel.)
SessionId | (Inherited from IContextChannel.)
State | (Inherited from ICommunicationObject.)
Via | (Inherited from IClientChannel.)

Events

Name | Description
Closed | (Inherited from ICommunicationObject.)
Closing | (Inherited from ICommunicationObject.)
Faulted | (Inherited from ICommunicationObject.)
Opened | (Inherited from ICommunicationObject.)
Opening | (Inherited from ICommunicationObject.)
UnknownMessageReceived | (Inherited from IClientChannel.)

See Also

IReportServiceResourcesChannel Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


IReportServiceResourcesChannel Methods

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceResourcesChannel Methods
IReportServiceResourcesChannel Interface See Also Send Feedback

The IReportServiceResourcesChannel type exposes the following members.

Methods

Name | Description
Abort | (Inherited from ICommunicationObject.)
BeginClose | Overloaded.
BeginDisplayInitializationUI | (Inherited from IClientChannel.)
BeginExport | Begins report export. (Inherited from IReportServiceResources.)
BeginGetFont | Begins font getting. (Inherited from IReportServiceResources.)
BeginGetImage | Begins getting image. (Inherited from IReportServiceResources.)
BeginGetResource | Begins resource getting. (Inherited from IReportServiceResources.)
BeginOpen | Overloaded.
Close | Overloaded.
DisplayInitializationUI | (Inherited from IClientChannel.)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
EndClose | (Inherited from ICommunicationObject.)
EndDisplayInitializationUI | (Inherited from IClientChannel.)
EndExport | Ends report export. (Inherited from IReportServiceResources.)
EndGetFont | Ends font getting. (Inherited from IReportServiceResources.)
EndGetImage | Ends getting image. (Inherited from IReportServiceResources.)
EndGetResource | Ends resource getting. (Inherited from IReportServiceResources.)
EndOpen | (Inherited from ICommunicationObject.)
GetProperty<(Of <(T>)>) | (Inherited from IChannel.)
Open | Overloaded.

See Also

IReportServiceResourcesChannel Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


BeginClose Method

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceResourcesChannel..::.BeginClose Method
IReportServiceResourcesChannel Interface See Also Send Feedback

Overload List

Name | Description
BeginClose(AsyncCallback, Object) | (Inherited from ICommunicationObject.)
BeginClose(TimeSpan, AsyncCallback, Object) | (Inherited from ICommunicationObject.)

See Also

IReportServiceResourcesChannel Interface
IReportServiceResourcesChannel Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


BeginOpen Method

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceResourcesChannel..::.BeginOpen Method
IReportServiceResourcesChannel Interface See Also Send Feedback

Overload List

Name | Description
BeginOpen(AsyncCallback, Object) | (Inherited from ICommunicationObject.)
BeginOpen(TimeSpan, AsyncCallback, Object) | (Inherited from ICommunicationObject.)

See Also

IReportServiceResourcesChannel Interface
IReportServiceResourcesChannel Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


Close Method

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceResourcesChannel..::.Close Method
IReportServiceResourcesChannel Interface See Also Send Feedback

Overload List

Name | Description
Close()()() | (Inherited from ICommunicationObject.)
Close(TimeSpan) | (Inherited from ICommunicationObject.)

See Also

IReportServiceResourcesChannel Interface
IReportServiceResourcesChannel Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


Open Method

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceResourcesChannel..::.Open Method
IReportServiceResourcesChannel Interface See Also Send Feedback

Overload List

Name | Description
Open()()() | (Inherited from ICommunicationObject.)
Open(TimeSpan) | (Inherited from ICommunicationObject.)

See Also

IReportServiceResourcesChannel Interface
IReportServiceResourcesChannel Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


IReportServiceResourcesChannel Properties

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceResourcesChannel Properties
IReportServiceResourcesChannel Interface See Also Send Feedback

The IReportServiceResourcesChannel type exposes the following members.

Properties

Name | Description
AllowInitializationUI | (Inherited from IClientChannel.)
AllowOutputBatching | (Inherited from IContextChannel.)
DidInteractiveInitialization | (Inherited from IClientChannel.)
Extensions | (Inherited from IExtensibleObject <(Of <( IContextChannel >)>).)
InputSession | (Inherited from IContextChannel.)
LocalAddress | (Inherited from IContextChannel.)
OperationTimeout | (Inherited from IContextChannel.)
OutputSession | (Inherited from IContextChannel.)
RemoteAddress | (Inherited from IContextChannel.)
SessionId | (Inherited from IContextChannel.)
State | (Inherited from ICommunicationObject.)
Via | (Inherited from IClientChannel.)

See Also

IReportServiceResourcesChannel Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


IReportServiceResourcesChannel Events

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceResourcesChannel Events
IReportServiceResourcesChannel Interface See Also Send Feedback

The IReportServiceResourcesChannel type exposes the following members.

Events

Name | Description
Closed | (Inherited from ICommunicationObject.)
Closing | (Inherited from ICommunicationObject.)
Faulted | (Inherited from ICommunicationObject.)
Opened | (Inherited from ICommunicationObject.)
Opening | (Inherited from ICommunicationObject.)
UnknownMessageReceived | (Inherited from IClientChannel.)

See Also

IReportServiceResourcesChannel Interface
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


NoCachedDocumentExceptionDetail Class

[image]

.NET ModelKit Suite ClassReference
NoCachedDocumentExceptionDetail Class
Members See Also Send Feedback
Represents an exception wrapper generated when document is not found in cash.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class NoCachedDocumentExceptionDetail : ExceptionDetailBase
Visual Basic (Declaration)
Public Class NoCachedDocumentExceptionDetail _
    Inherits ExceptionDetailBase
Visual C++
public ref class NoCachedDocumentExceptionDetail : public ExceptionDetailBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.ExceptionDetailBase
PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.NoCachedDocumentExceptionDetail

See Also

NoCachedDocumentExceptionDetail Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


NoCachedDocumentExceptionDetail Members

[image] [image]

.NET ModelKit Suite ClassReference
NoCachedDocumentExceptionDetail Members
NoCachedDocumentExceptionDetail Class Constructors Methods Properties Events See Also Send Feedback

The NoCachedDocumentExceptionDetail type exposes the following members.

Constructors

Name | Description
NoCachedDocumentExceptionDetail | Initializes a new instance of the NoCachedDocumentExceptionDetail class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged | Raises the PropertyChanged event. (Inherited from ExceptionDetailBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
InnerException | Gets or sets ExceptionDetailBase which is the inner exception wrapper. (Inherited from ExceptionDetailBase.)
Message | Gets or sets error message. (Inherited from ExceptionDetailBase.)

Events

Name | Description
PropertyChanged | Occurs after the value of an exception property is changed. (Inherited from ExceptionDetailBase.)

See Also

NoCachedDocumentExceptionDetail Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


NoCachedDocumentExceptionDetail Constructor

[image]

.NET ModelKit Suite ClassReference
NoCachedDocumentExceptionDetail Constructor
NoCachedDocumentExceptionDetail Class See Also Send Feedback
Initializes a new instance of the NoCachedDocumentExceptionDetail class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public NoCachedDocumentExceptionDetail()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NoCachedDocumentExceptionDetail()

See Also

NoCachedDocumentExceptionDetail Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


NoCachedDocumentExceptionDetail Methods

[image] [image]

.NET ModelKit Suite ClassReference
NoCachedDocumentExceptionDetail Methods
NoCachedDocumentExceptionDetail Class See Also Send Feedback

The NoCachedDocumentExceptionDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged | Raises the PropertyChanged event. (Inherited from ExceptionDetailBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NoCachedDocumentExceptionDetail Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


NoCachedDocumentExceptionDetail Properties

[image] [image]

.NET ModelKit Suite ClassReference
NoCachedDocumentExceptionDetail Properties
NoCachedDocumentExceptionDetail Class See Also Send Feedback

The NoCachedDocumentExceptionDetail type exposes the following members.

Properties

Name | Description
InnerException | Gets or sets ExceptionDetailBase which is the inner exception wrapper. (Inherited from ExceptionDetailBase.)
Message | Gets or sets error message. (Inherited from ExceptionDetailBase.)

See Also

NoCachedDocumentExceptionDetail Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


NoCachedDocumentExceptionDetail Events

[image] [image]

.NET ModelKit Suite ClassReference
NoCachedDocumentExceptionDetail Events
NoCachedDocumentExceptionDetail Class See Also Send Feedback

The NoCachedDocumentExceptionDetail type exposes the following members.

Events

Name | Description
PropertyChanged | Occurs after the value of an exception property is changed. (Inherited from ExceptionDetailBase.)

See Also

NoCachedDocumentExceptionDetail Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


PageInfo Class

[image]

.NET ModelKit Suite ClassReference
PageInfo Class
Members See Also Send Feedback
Represents report page metadata.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class PageInfo : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class PageInfo _
    Implements INotifyPropertyChanged
Visual C++
public ref class PageInfo : INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.PageInfo

See Also

PageInfo Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


PageInfo Members

[image] [image]

.NET ModelKit Suite ClassReference
PageInfo Members
PageInfo Class Constructors Methods Properties Events See Also Send Feedback

The PageInfo type exposes the following members.

Constructors

Name | Description
PageInfo | Initializes a new instance of the PageInfo class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged | Raises the PropertyChanged event.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CompresedXamlPage | Gets or sets compressed Xaml page content.
DocumentId | Gets or sets identification of the document which contains the page.
PageNumber | Gets or sets page number.

Events

Name | Description
PropertyChanged | Occurs after the value of an page property is changed.

See Also

PageInfo Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


PageInfo Constructor

[image]

.NET ModelKit Suite ClassReference
PageInfo Constructor
PageInfo Class See Also Send Feedback
Initializes a new instance of the PageInfo class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public PageInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageInfo()

See Also

PageInfo Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


PageInfo Methods

[image] [image]

.NET ModelKit Suite ClassReference
PageInfo Methods
PageInfo Class See Also Send Feedback

The PageInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged | Raises the PropertyChanged event.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageInfo Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


RaisePropertyChanged Method

[image]

.NET ModelKit Suite ClassReference
PageInfo..::.RaisePropertyChanged Method
PageInfo Class See Also Send Feedback
Raises the PropertyChanged event.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::.String

See Also

PageInfo Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


PageInfo Properties

[image] [image]

.NET ModelKit Suite ClassReference
PageInfo Properties
PageInfo Class See Also Send Feedback

The PageInfo type exposes the following members.

Properties

Name | Description
CompresedXamlPage | Gets or sets compressed Xaml page content.
DocumentId | Gets or sets identification of the document which contains the page.
PageNumber | Gets or sets page number.

See Also

PageInfo Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


CompresedXamlPage Property

[image]

.NET ModelKit Suite ClassReference
PageInfo..::.CompresedXamlPage Property
PageInfo Class See Also Send Feedback
Gets or sets compressed Xaml page content.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public byte[] CompresedXamlPage { get; set; }
Visual Basic (Declaration)
Public Property CompresedXamlPage As Byte()
Visual C++
public:
property array<unsigned char>^ CompresedXamlPage {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

PageInfo Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


DocumentId Property

[image]

.NET ModelKit Suite ClassReference
PageInfo..::.DocumentId Property
PageInfo Class See Also Send Feedback
Gets or sets identification of the document which contains the page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string DocumentId { get; set; }
Visual Basic (Declaration)
Public Property DocumentId As String
Visual C++
public:
property String^ DocumentId {
    String^ get ();
    void set (String^ value);
}

See Also

PageInfo Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


PageNumber Property

[image]

.NET ModelKit Suite ClassReference
PageInfo..::.PageNumber Property
PageInfo Class See Also Send Feedback
Gets or sets page number.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public int PageNumber { get; set; }
Visual Basic (Declaration)
Public Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
    void set (int value);
}

See Also

PageInfo Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


PageInfo Events

[image] [image]

.NET ModelKit Suite ClassReference
PageInfo Events
PageInfo Class See Also Send Feedback

The PageInfo type exposes the following members.

Events

Name | Description
PropertyChanged | Occurs after the value of an page property is changed.

See Also

PageInfo Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


PropertyChanged Event

[image]

.NET ModelKit Suite ClassReference
PageInfo..::.PropertyChanged Event
PageInfo Class See Also Send Feedback
Occurs after the value of an page property is changed.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PageInfo Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


RenderCompletedEventArgs Class

[image]

.NET ModelKit Suite ClassReference
RenderCompletedEventArgs Class
Members See Also Send Feedback
Parameters of the event which occurs when report rendering is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class RenderCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class RenderCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
Visual C++
public ref class RenderCompletedEventArgs : public AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.RenderCompletedEventArgs

See Also

RenderCompletedEventArgs Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


RenderCompletedEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
RenderCompletedEventArgs Members
RenderCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The RenderCompletedEventArgs type exposes the following members.

Constructors

Name | Description
RenderCompletedEventArgs | Initializes a new instance of the RenderCompletedEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError | Gets ExceptionDetailBase which is wrapper of exception occurred during operation execution.
Result | Gets String which is operation execution result.
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

RenderCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


RenderCompletedEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
RenderCompletedEventArgs Constructor
RenderCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the RenderCompletedEventArgs class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public RenderCompletedEventArgs(
    Object[] results,
    Exception exception,
    bool cancelled,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    results As Object(), _
    exception As Exception, _
    cancelled As Boolean, _
    userState As Object _
)
Visual C++
public:
RenderCompletedEventArgs(
    array<Object^>^ results,
    Exception^ exception,
    bool cancelled,
    Object^ userState
)

Parameters

results
Type: array< System..::.Object >[]()[]
exception
Type: System..::.Exception
cancelled
Type: System..::.Boolean
userState
Type: System..::.Object

See Also

RenderCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


RenderCompletedEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
RenderCompletedEventArgs Methods
RenderCompletedEventArgs Class See Also Send Feedback

The RenderCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


RenderCompletedEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
RenderCompletedEventArgs Properties
RenderCompletedEventArgs Class See Also Send Feedback

The RenderCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
ReportError | Gets ExceptionDetailBase which is wrapper of exception occurred during operation execution.
Result | Gets String which is operation execution result.
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

RenderCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportError Property

[image]

.NET ModelKit Suite ClassReference
RenderCompletedEventArgs..::.ReportError Property
RenderCompletedEventArgs Class See Also Send Feedback
Gets ExceptionDetailBase which is wrapper of exception occurred during operation execution.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ExceptionDetailBase ReportError { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReportError As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ ReportError {
    ExceptionDetailBase^ get ();
}

See Also

RenderCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


Result Property

[image]

.NET ModelKit Suite ClassReference
RenderCompletedEventArgs..::.Result Property
RenderCompletedEventArgs Class See Also Send Feedback
Gets String which is operation execution result.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string Result { get; }
Visual Basic (Declaration)
Public ReadOnly Property Result As String
Visual C++
public:
property String^ Result {
    String^ get ();
}

See Also

RenderCompletedEventArgs Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceClient Class

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient Class
Members See Also Send Feedback
Reports service class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ReportServiceClient : ClientBase<IReportService>,
    IReportService
Visual Basic (Declaration)
Public Class ReportServiceClient _
    Inherits ClientBase(Of IReportService) _
    Implements IReportService
Visual C++
public ref class ReportServiceClient : public ClientBase<IReportService^>,
    IReportService

Inheritance Hierarchy

System..::.Object
System.ServiceModel..::.ClientBase <(Of <( IReportService >)>)
PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.ReportServiceClient

See Also

ReportServiceClient Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceClient Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceClient Members
ReportServiceClient Class Constructors Methods Properties Events See Also Send Feedback

The ReportServiceClient type exposes the following members.

Constructors

Name | Description
ReportServiceClient | Overloaded.

Methods

Name | Description
Abort | (Inherited from ClientBase <(Of <( IReportService >)>).)
CloseAsync | Overloaded.
CreateChannel | Creates channel. (Overrides ClientBase<(Of <(TChannel>)>)..::.CreateChannel()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAsync | Overloaded.
GetDefaultValueForInitialization<(Of <(T>)>) | (Inherited from ClientBase <(Of <( IReportService >)>).)
GetDocumentInfoAsync | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPageInfoAsync | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitAsync | Overloaded.
InvokeAsync | (Inherited from ClientBase <(Of <( IReportService >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OpenAsync | Overloaded.
RenderAsync | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Channel | (Inherited from ClientBase <(Of <( IReportService >)>).)
ChannelFactory | (Inherited from ClientBase <(Of <( IReportService >)>).)
Endpoint | (Inherited from ClientBase <(Of <( IReportService >)>).)
InnerChannel | (Inherited from ClientBase <(Of <( IReportService >)>).)
State | (Inherited from ClientBase <(Of <( IReportService >)>).)

Events

Name | Description
CloseCompleted | Occurs when connection closing is finished.
FindCompleted | Occurs when text search is finished.
GetDocumentInfoCompleted | Occurs when report information getting is finished.
GetPageInfoCompleted | Occurs when page information getting is finished.
InitCompleted | Occurs when service initialization is finished.
OpenCompleted | Occurs when connection opening is finished.
RenderCompleted | Occurs when rendering is finished.

See Also

ReportServiceClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceClient Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceClient Constructor
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
ReportServiceClient()()() | Initializes a new instance of the ReportServiceClient class.
ReportServiceClient(String) | Initializes a new instance of the ReportServiceClient class.
ReportServiceClient(Binding, EndpointAddress) | Initializes a new instance of the ReportServiceClient class.
ReportServiceClient(String, EndpointAddress) | Initializes a new instance of the ReportServiceClient class.
ReportServiceClient(String, String) | Initializes a new instance of the ReportServiceClient class.

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceClient Constructor

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient Constructor
ReportServiceClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceClient class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ReportServiceClient()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportServiceClient()

See Also

ReportServiceClient Class
ReportServiceClient Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceClient Constructor (String)

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient Constructor (String)
ReportServiceClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceClient class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ReportServiceClient(
    string endpointConfigurationName
)
Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String _
)
Visual C++
public:
ReportServiceClient(
    String^ endpointConfigurationName
)

Parameters

endpointConfigurationName
Type: System..::.String

See Also

ReportServiceClient Class
ReportServiceClient Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceClient Constructor (Binding, EndpointAddress)

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient Constructor (Binding, EndpointAddress)
ReportServiceClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceClient class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ReportServiceClient(
    Binding binding,
    EndpointAddress remoteAddress
)
Visual Basic (Declaration)
Public Sub New ( _
    binding As Binding, _
    remoteAddress As EndpointAddress _
)
Visual C++
public:
ReportServiceClient(
    Binding^ binding,
    EndpointAddress^ remoteAddress
)

Parameters

binding
Type: System.ServiceModel.Channels..::.Binding
remoteAddress
Type: System.ServiceModel..::.EndpointAddress

See Also

ReportServiceClient Class
ReportServiceClient Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceClient Constructor (String, EndpointAddress)

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient Constructor (String, EndpointAddress)
ReportServiceClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceClient class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ReportServiceClient(
    string endpointConfigurationName,
    EndpointAddress remoteAddress
)
Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String, _
    remoteAddress As EndpointAddress _
)
Visual C++
public:
ReportServiceClient(
    String^ endpointConfigurationName,
    EndpointAddress^ remoteAddress
)

Parameters

endpointConfigurationName
Type: System..::.String
remoteAddress
Type: System.ServiceModel..::.EndpointAddress

See Also

ReportServiceClient Class
ReportServiceClient Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceClient Constructor (String, String)

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient Constructor (String, String)
ReportServiceClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceClient class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ReportServiceClient(
    string endpointConfigurationName,
    string remoteAddress
)
Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String, _
    remoteAddress As String _
)
Visual C++
public:
ReportServiceClient(
    String^ endpointConfigurationName,
    String^ remoteAddress
)

Parameters

endpointConfigurationName
Type: System..::.String
remoteAddress
Type: System..::.String

See Also

ReportServiceClient Class
ReportServiceClient Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceClient Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceClient Methods
ReportServiceClient Class See Also Send Feedback

The ReportServiceClient type exposes the following members.

Methods

Name | Description
Abort | (Inherited from ClientBase <(Of <( IReportService >)>).)
CloseAsync | Overloaded.
CreateChannel | Creates channel. (Overrides ClientBase<(Of <(TChannel>)>)..::.CreateChannel()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindAsync | Overloaded.
GetDefaultValueForInitialization<(Of <(T>)>) | (Inherited from ClientBase <(Of <( IReportService >)>).)
GetDocumentInfoAsync | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPageInfoAsync | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitAsync | Overloaded.
InvokeAsync | (Inherited from ClientBase <(Of <( IReportService >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OpenAsync | Overloaded.
RenderAsync | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportServiceClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


CloseAsync Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.CloseAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
CloseAsync()()() | Requests connection closing.
CloseAsync(Object) | Requests connection closing.

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


CloseAsync Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.CloseAsync Method
ReportServiceClient Class See Also Send Feedback
Requests connection closing.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void CloseAsync()
Visual Basic (Declaration)
Public Sub CloseAsync
Visual C++
public:
void CloseAsync()

See Also

ReportServiceClient Class
CloseAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


CloseAsync Method (Object)

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.CloseAsync Method (Object)
ReportServiceClient Class See Also Send Feedback
Requests connection closing.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void CloseAsync(
    Object userState
)
Visual Basic (Declaration)
Public Sub CloseAsync ( _
    userState As Object _
)
Visual C++
public:
void CloseAsync(
    Object^ userState
)

Parameters

userState
Type: System..::.Object

See Also

ReportServiceClient Class
CloseAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


CreateChannel Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.CreateChannel Method
ReportServiceClient Class See Also Send Feedback
Creates channel.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected override IReportService CreateChannel()
Visual Basic (Declaration)
Protected Overrides Function CreateChannel As IReportService
Visual C++
protected:
virtual IReportService^ CreateChannel() override

See Also

ReportServiceClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


FindAsync Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.FindAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
FindAsync(String, FindOptions) | Requests text search.
FindAsync(String, FindOptions, Object) | Requests text search.

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


FindAsync Method (String, FindOptions)

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.FindAsync Method (String, FindOptions)
ReportServiceClient Class See Also Send Feedback
Requests text search.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void FindAsync(
    string id,
    FindOptions findOptions
)
Visual Basic (Declaration)
Public Sub FindAsync ( _
    id As String, _
    findOptions As FindOptions _
)
Visual C++
public:
void FindAsync(
    String^ id,
    FindOptions findOptions
)

Parameters

id
Type: System..::.String
findOptions
Type: PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.FindOptions

See Also

ReportServiceClient Class
FindAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


FindAsync Method (String, FindOptions, Object)

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.FindAsync Method (String, FindOptions, Object)
ReportServiceClient Class See Also Send Feedback
Requests text search.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void FindAsync(
    string id,
    FindOptions findOptions,
    Object userState
)
Visual Basic (Declaration)
Public Sub FindAsync ( _
    id As String, _
    findOptions As FindOptions, _
    userState As Object _
)
Visual C++
public:
void FindAsync(
    String^ id,
    FindOptions findOptions,
    Object^ userState
)

Parameters

id
Type: System..::.String
findOptions
Type: PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.FindOptions
userState
Type: System..::.Object

See Also

ReportServiceClient Class
FindAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetDocumentInfoAsync Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.GetDocumentInfoAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
GetDocumentInfoAsync(String) | Requests getting of the report information.
GetDocumentInfoAsync(String, Object) | Requests getting of the report information.

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetDocumentInfoAsync Method (String)

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.GetDocumentInfoAsync Method (String)
ReportServiceClient Class See Also Send Feedback
Requests getting of the report information.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void GetDocumentInfoAsync(
    string id
)
Visual Basic (Declaration)
Public Sub GetDocumentInfoAsync ( _
    id As String _
)
Visual C++
public:
void GetDocumentInfoAsync(
    String^ id
)

Parameters

id
Type: System..::.String

See Also

ReportServiceClient Class
GetDocumentInfoAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetDocumentInfoAsync Method (String, Object)

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.GetDocumentInfoAsync Method (String, Object)
ReportServiceClient Class See Also Send Feedback
Requests getting of the report information.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void GetDocumentInfoAsync(
    string id,
    Object userState
)
Visual Basic (Declaration)
Public Sub GetDocumentInfoAsync ( _
    id As String, _
    userState As Object _
)
Visual C++
public:
void GetDocumentInfoAsync(
    String^ id,
    Object^ userState
)

Parameters

id
Type: System..::.String
userState
Type: System..::.Object

See Also

ReportServiceClient Class
GetDocumentInfoAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetPageInfoAsync Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.GetPageInfoAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
GetPageInfoAsync(String, Int32) | Requests getting of the report page information.
GetPageInfoAsync(String, Int32, Object) | Requests getting of the report page information.

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetPageInfoAsync Method (String, Int32)

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.GetPageInfoAsync Method (String, Int32)
ReportServiceClient Class See Also Send Feedback
Requests getting of the report page information.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void GetPageInfoAsync(
    string id,
    int pageNumber
)
Visual Basic (Declaration)
Public Sub GetPageInfoAsync ( _
    id As String, _
    pageNumber As Integer _
)
Visual C++
public:
void GetPageInfoAsync(
    String^ id,
    int pageNumber
)

Parameters

id
Type: System..::.String
pageNumber
Type: System..::.Int32

See Also

ReportServiceClient Class
GetPageInfoAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetPageInfoAsync Method (String, Int32, Object)

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.GetPageInfoAsync Method (String, Int32, Object)
ReportServiceClient Class See Also Send Feedback
Requests getting of the report page information.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void GetPageInfoAsync(
    string id,
    int pageNumber,
    Object userState
)
Visual Basic (Declaration)
Public Sub GetPageInfoAsync ( _
    id As String, _
    pageNumber As Integer, _
    userState As Object _
)
Visual C++
public:
void GetPageInfoAsync(
    String^ id,
    int pageNumber,
    Object^ userState
)

Parameters

id
Type: System..::.String
pageNumber
Type: System..::.Int32
userState
Type: System..::.Object

See Also

ReportServiceClient Class
GetPageInfoAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


InitAsync Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.InitAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
InitAsync()()() | Requests service initialization.
InitAsync(Object) | Requests service initialization.

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


InitAsync Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.InitAsync Method
ReportServiceClient Class See Also Send Feedback
Requests service initialization.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void InitAsync()
Visual Basic (Declaration)
Public Sub InitAsync
Visual C++
public:
void InitAsync()

See Also

ReportServiceClient Class
InitAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


InitAsync Method (Object)

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.InitAsync Method (Object)
ReportServiceClient Class See Also Send Feedback
Requests service initialization.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void InitAsync(
    Object userState
)
Visual Basic (Declaration)
Public Sub InitAsync ( _
    userState As Object _
)
Visual C++
public:
void InitAsync(
    Object^ userState
)

Parameters

userState
Type: System..::.Object

See Also

ReportServiceClient Class
InitAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


OpenAsync Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.OpenAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
OpenAsync()()() | Requests connection opening.
OpenAsync(Object) | Requests connection opening.

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


OpenAsync Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.OpenAsync Method
ReportServiceClient Class See Also Send Feedback
Requests connection opening.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void OpenAsync()
Visual Basic (Declaration)
Public Sub OpenAsync
Visual C++
public:
void OpenAsync()

See Also

ReportServiceClient Class
OpenAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


OpenAsync Method (Object)

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.OpenAsync Method (Object)
ReportServiceClient Class See Also Send Feedback
Requests connection opening.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void OpenAsync(
    Object userState
)
Visual Basic (Declaration)
Public Sub OpenAsync ( _
    userState As Object _
)
Visual C++
public:
void OpenAsync(
    Object^ userState
)

Parameters

userState
Type: System..::.Object

See Also

ReportServiceClient Class
OpenAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


RenderAsync Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.RenderAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
RenderAsync(Dictionary<(Of <(String, Object>)>), String) | Requests report rendering.
RenderAsync(Dictionary<(Of <(String, Object>)>), String, Object) | Requests report rendering.

See Also

ReportServiceClient Class
ReportServiceClient Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


RenderAsync Method (Dictionary(String, Object), String)

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.RenderAsync Method (Dictionary<(Of <(String, Object>)>), String)
ReportServiceClient Class See Also Send Feedback
Requests report rendering.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void RenderAsync(
    Dictionary<string, Object> parameters,
    string reportName
)
Visual Basic (Declaration)
Public Sub RenderAsync ( _
    parameters As Dictionary(Of String, Object), _
    reportName As String _
)
Visual C++
public:
void RenderAsync(
    Dictionary<String^, Object^>^ parameters,
    String^ reportName
)

Parameters

parameters
Type: System.Collections.Generic..::.Dictionary <(Of <( String, Object >)>)
reportName
Type: System..::.String

See Also

ReportServiceClient Class
RenderAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


RenderAsync Method (Dictionary(String, Object), String, Object)

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.RenderAsync Method (Dictionary<(Of <(String, Object>)>), String, Object)
ReportServiceClient Class See Also Send Feedback
Requests report rendering.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void RenderAsync(
    Dictionary<string, Object> parameters,
    string reportName,
    Object userState
)
Visual Basic (Declaration)
Public Sub RenderAsync ( _
    parameters As Dictionary(Of String, Object), _
    reportName As String, _
    userState As Object _
)
Visual C++
public:
void RenderAsync(
    Dictionary<String^, Object^>^ parameters,
    String^ reportName,
    Object^ userState
)

Parameters

parameters
Type: System.Collections.Generic..::.Dictionary <(Of <( String, Object >)>)
reportName
Type: System..::.String
userState
Type: System..::.Object

See Also

ReportServiceClient Class
RenderAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceClient Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceClient Properties
ReportServiceClient Class See Also Send Feedback

The ReportServiceClient type exposes the following members.

Properties

Name | Description
Channel | (Inherited from ClientBase <(Of <( IReportService >)>).)
ChannelFactory | (Inherited from ClientBase <(Of <( IReportService >)>).)
Endpoint | (Inherited from ClientBase <(Of <( IReportService >)>).)
InnerChannel | (Inherited from ClientBase <(Of <( IReportService >)>).)
State | (Inherited from ClientBase <(Of <( IReportService >)>).)

See Also

ReportServiceClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceClient Events

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceClient Events
ReportServiceClient Class See Also Send Feedback

The ReportServiceClient type exposes the following members.

Events

Name | Description
CloseCompleted | Occurs when connection closing is finished.
FindCompleted | Occurs when text search is finished.
GetDocumentInfoCompleted | Occurs when report information getting is finished.
GetPageInfoCompleted | Occurs when page information getting is finished.
InitCompleted | Occurs when service initialization is finished.
OpenCompleted | Occurs when connection opening is finished.
RenderCompleted | Occurs when rendering is finished.

See Also

ReportServiceClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


CloseCompleted Event

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.CloseCompleted Event
ReportServiceClient Class See Also Send Feedback
Occurs when connection closing is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler<AsyncCompletedEventArgs> CloseCompleted
Visual Basic (Declaration)
Public Event CloseCompleted As EventHandler(Of AsyncCompletedEventArgs)
Visual C++
public:
 event EventHandler<AsyncCompletedEventArgs^>^ CloseCompleted {
    void add (EventHandler<AsyncCompletedEventArgs^>^ value);
    void remove (EventHandler<AsyncCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


FindCompleted Event

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.FindCompleted Event
ReportServiceClient Class See Also Send Feedback
Occurs when text search is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler<FindCompletedEventArgs> FindCompleted
Visual Basic (Declaration)
Public Event FindCompleted As EventHandler(Of FindCompletedEventArgs)
Visual C++
public:
 event EventHandler<FindCompletedEventArgs^>^ FindCompleted {
    void add (EventHandler<FindCompletedEventArgs^>^ value);
    void remove (EventHandler<FindCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetDocumentInfoCompleted Event

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.GetDocumentInfoCompleted Event
ReportServiceClient Class See Also Send Feedback
Occurs when report information getting is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler<GetDocumentInfoCompletedEventArgs> GetDocumentInfoCompleted
Visual Basic (Declaration)
Public Event GetDocumentInfoCompleted As EventHandler(Of GetDocumentInfoCompletedEventArgs)
Visual C++
public:
 event EventHandler<GetDocumentInfoCompletedEventArgs^>^ GetDocumentInfoCompleted {
    void add (EventHandler<GetDocumentInfoCompletedEventArgs^>^ value);
    void remove (EventHandler<GetDocumentInfoCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetPageInfoCompleted Event

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.GetPageInfoCompleted Event
ReportServiceClient Class See Also Send Feedback
Occurs when page information getting is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler<GetPageInfoCompletedEventArgs> GetPageInfoCompleted
Visual Basic (Declaration)
Public Event GetPageInfoCompleted As EventHandler(Of GetPageInfoCompletedEventArgs)
Visual C++
public:
 event EventHandler<GetPageInfoCompletedEventArgs^>^ GetPageInfoCompleted {
    void add (EventHandler<GetPageInfoCompletedEventArgs^>^ value);
    void remove (EventHandler<GetPageInfoCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


InitCompleted Event

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.InitCompleted Event
ReportServiceClient Class See Also Send Feedback
Occurs when service initialization is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler<AsyncCompletedEventArgs> InitCompleted
Visual Basic (Declaration)
Public Event InitCompleted As EventHandler(Of AsyncCompletedEventArgs)
Visual C++
public:
 event EventHandler<AsyncCompletedEventArgs^>^ InitCompleted {
    void add (EventHandler<AsyncCompletedEventArgs^>^ value);
    void remove (EventHandler<AsyncCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


OpenCompleted Event

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.OpenCompleted Event
ReportServiceClient Class See Also Send Feedback
Occurs when connection opening is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler<AsyncCompletedEventArgs> OpenCompleted
Visual Basic (Declaration)
Public Event OpenCompleted As EventHandler(Of AsyncCompletedEventArgs)
Visual C++
public:
 event EventHandler<AsyncCompletedEventArgs^>^ OpenCompleted {
    void add (EventHandler<AsyncCompletedEventArgs^>^ value);
    void remove (EventHandler<AsyncCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


RenderCompleted Event

[image]

.NET ModelKit Suite ClassReference
ReportServiceClient..::.RenderCompleted Event
ReportServiceClient Class See Also Send Feedback
Occurs when rendering is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler<RenderCompletedEventArgs> RenderCompleted
Visual Basic (Declaration)
Public Event RenderCompleted As EventHandler(Of RenderCompletedEventArgs)
Visual C++
public:
 event EventHandler<RenderCompletedEventArgs^>^ RenderCompleted {
    void add (EventHandler<RenderCompletedEventArgs^>^ value);
    void remove (EventHandler<RenderCompletedEventArgs^>^ value);
}

See Also

ReportServiceClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceResourcesClient Class

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient Class
Members See Also Send Feedback
A class for getting resources from server. The resources are needed for getting the report.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ReportServiceResourcesClient : ClientBase<IReportServiceResources>,
    IReportServiceResources
Visual Basic (Declaration)
Public Class ReportServiceResourcesClient _
    Inherits ClientBase(Of IReportServiceResources) _
    Implements IReportServiceResources
Visual C++
public ref class ReportServiceResourcesClient : public ClientBase<IReportServiceResources^>,
    IReportServiceResources

Inheritance Hierarchy

System..::.Object
System.ServiceModel..::.ClientBase <(Of <( IReportServiceResources >)>)
PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.ReportServiceResourcesClient

See Also

ReportServiceResourcesClient Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceResourcesClient Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient Members
ReportServiceResourcesClient Class Constructors Methods Properties Events See Also Send Feedback

The ReportServiceResourcesClient type exposes the following members.

Constructors

Name | Description
ReportServiceResourcesClient | Overloaded.

Methods

Name | Description
Abort | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
CloseAsync | Overloaded.
CreateChannel | Creates connection channel. (Overrides ClientBase<(Of <(TChannel>)>)..::.CreateChannel()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportAsync | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDefaultValueForInitialization<(Of <(T>)>) | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
GetFontAsync | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageAsync | Overloaded.
GetResourceAsync | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
InvokeAsync | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OpenAsync | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Channel | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
ChannelFactory | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
Endpoint | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
InnerChannel | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
State | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)

Events

Name | Description
CloseCompleted | Occurs when connection closing is finished.
ExportCompleted | Occurs when report export is finished.
GetFontCompleted | Occurs when font getting is finished.
GetImageCompleted | Occurs when image getting is finished.
GetResourceCompleted | Occurs when resource getting is finished.
OpenCompleted | Occurs when connection opening is finished.

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceResourcesClient Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient Constructor
ReportServiceResourcesClient Class See Also Send Feedback

Overload List

Name | Description
ReportServiceResourcesClient()()() | Initializes a new instance of the ReportServiceResourcesClient class.
ReportServiceResourcesClient(String) | Initializes a new instance of the ReportServiceResourcesClient class.
ReportServiceResourcesClient(Binding, EndpointAddress) | Initializes a new instance of the ReportServiceResourcesClient class.
ReportServiceResourcesClient(String, EndpointAddress) | Initializes a new instance of the ReportServiceResourcesClient class.
ReportServiceResourcesClient(String, String) | Initializes a new instance of the ReportServiceResourcesClient class.

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceResourcesClient Constructor

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient Constructor
ReportServiceResourcesClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceResourcesClient class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ReportServiceResourcesClient()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportServiceResourcesClient()

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceResourcesClient Constructor (String)

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient Constructor (String)
ReportServiceResourcesClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceResourcesClient class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ReportServiceResourcesClient(
    string endpointConfigurationName
)
Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String _
)
Visual C++
public:
ReportServiceResourcesClient(
    String^ endpointConfigurationName
)

Parameters

endpointConfigurationName
Type: System..::.String

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceResourcesClient Constructor (Binding, EndpointAddress)

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient Constructor (Binding, EndpointAddress)
ReportServiceResourcesClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceResourcesClient class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ReportServiceResourcesClient(
    Binding binding,
    EndpointAddress remoteAddress
)
Visual Basic (Declaration)
Public Sub New ( _
    binding As Binding, _
    remoteAddress As EndpointAddress _
)
Visual C++
public:
ReportServiceResourcesClient(
    Binding^ binding,
    EndpointAddress^ remoteAddress
)

Parameters

binding
Type: System.ServiceModel.Channels..::.Binding
remoteAddress
Type: System.ServiceModel..::.EndpointAddress

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceResourcesClient Constructor (String, EndpointAddress)

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient Constructor (String, EndpointAddress)
ReportServiceResourcesClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceResourcesClient class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ReportServiceResourcesClient(
    string endpointConfigurationName,
    EndpointAddress remoteAddress
)
Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String, _
    remoteAddress As EndpointAddress _
)
Visual C++
public:
ReportServiceResourcesClient(
    String^ endpointConfigurationName,
    EndpointAddress^ remoteAddress
)

Parameters

endpointConfigurationName
Type: System..::.String
remoteAddress
Type: System.ServiceModel..::.EndpointAddress

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceResourcesClient Constructor (String, String)

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient Constructor (String, String)
ReportServiceResourcesClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceResourcesClient class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ReportServiceResourcesClient(
    string endpointConfigurationName,
    string remoteAddress
)
Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String, _
    remoteAddress As String _
)
Visual C++
public:
ReportServiceResourcesClient(
    String^ endpointConfigurationName,
    String^ remoteAddress
)

Parameters

endpointConfigurationName
Type: System..::.String
remoteAddress
Type: System..::.String

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceResourcesClient Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient Methods
ReportServiceResourcesClient Class See Also Send Feedback

The ReportServiceResourcesClient type exposes the following members.

Methods

Name | Description
Abort | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
CloseAsync | Overloaded.
CreateChannel | Creates connection channel. (Overrides ClientBase<(Of <(TChannel>)>)..::.CreateChannel()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportAsync | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDefaultValueForInitialization<(Of <(T>)>) | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
GetFontAsync | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetImageAsync | Overloaded.
GetResourceAsync | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
InvokeAsync | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OpenAsync | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


CloseAsync Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.CloseAsync Method
ReportServiceResourcesClient Class See Also Send Feedback

Overload List

Name | Description
CloseAsync()()() | Requests connection closing.
CloseAsync(Object) | Requests connection closing.

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


CloseAsync Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.CloseAsync Method
ReportServiceResourcesClient Class See Also Send Feedback
Requests connection closing.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void CloseAsync()
Visual Basic (Declaration)
Public Sub CloseAsync
Visual C++
public:
void CloseAsync()

See Also

ReportServiceResourcesClient Class
CloseAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


CloseAsync Method (Object)

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.CloseAsync Method (Object)
ReportServiceResourcesClient Class See Also Send Feedback
Requests connection closing.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void CloseAsync(
    Object userState
)
Visual Basic (Declaration)
Public Sub CloseAsync ( _
    userState As Object _
)
Visual C++
public:
void CloseAsync(
    Object^ userState
)

Parameters

userState
Type: System..::.Object

See Also

ReportServiceResourcesClient Class
CloseAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


CreateChannel Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.CreateChannel Method
ReportServiceResourcesClient Class See Also Send Feedback
Creates connection channel.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected override IReportServiceResources CreateChannel()
Visual Basic (Declaration)
Protected Overrides Function CreateChannel As IReportServiceResources
Visual C++
protected:
virtual IReportServiceResources^ CreateChannel() override

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ExportAsync Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.ExportAsync Method
ReportServiceResourcesClient Class See Also Send Feedback

Overload List

Name | Description
ExportAsync(String, String) | Requests report export.
ExportAsync(String, String, Object) | Requests report export.

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ExportAsync Method (String, String)

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.ExportAsync Method (String, String)
ReportServiceResourcesClient Class See Also Send Feedback
Requests report export.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void ExportAsync(
    string id,
    string format
)
Visual Basic (Declaration)
Public Sub ExportAsync ( _
    id As String, _
    format As String _
)
Visual C++
public:
void ExportAsync(
    String^ id,
    String^ format
)

Parameters

id
Type: System..::.String
format
Type: System..::.String

See Also

ReportServiceResourcesClient Class
ExportAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ExportAsync Method (String, String, Object)

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.ExportAsync Method (String, String, Object)
ReportServiceResourcesClient Class See Also Send Feedback
Requests report export.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void ExportAsync(
    string id,
    string format,
    Object userState
)
Visual Basic (Declaration)
Public Sub ExportAsync ( _
    id As String, _
    format As String, _
    userState As Object _
)
Visual C++
public:
void ExportAsync(
    String^ id,
    String^ format,
    Object^ userState
)

Parameters

id
Type: System..::.String
format
Type: System..::.String
userState
Type: System..::.Object

See Also

ReportServiceResourcesClient Class
ExportAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetFontAsync Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.GetFontAsync Method
ReportServiceResourcesClient Class See Also Send Feedback

Overload List

Name | Description
GetFontAsync(String) | Requests font loading.
GetFontAsync(String, Object) | Requests font loading.

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetFontAsync Method (String)

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.GetFontAsync Method (String)
ReportServiceResourcesClient Class See Also Send Feedback
Requests font loading.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void GetFontAsync(
    string resourceKey
)
Visual Basic (Declaration)
Public Sub GetFontAsync ( _
    resourceKey As String _
)
Visual C++
public:
void GetFontAsync(
    String^ resourceKey
)

Parameters

resourceKey
Type: System..::.String

See Also

ReportServiceResourcesClient Class
GetFontAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetFontAsync Method (String, Object)

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.GetFontAsync Method (String, Object)
ReportServiceResourcesClient Class See Also Send Feedback
Requests font loading.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void GetFontAsync(
    string resourceKey,
    Object userState
)
Visual Basic (Declaration)
Public Sub GetFontAsync ( _
    resourceKey As String, _
    userState As Object _
)
Visual C++
public:
void GetFontAsync(
    String^ resourceKey,
    Object^ userState
)

Parameters

resourceKey
Type: System..::.String
userState
Type: System..::.Object

See Also

ReportServiceResourcesClient Class
GetFontAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetImageAsync Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.GetImageAsync Method
ReportServiceResourcesClient Class See Also Send Feedback

Overload List

Name | Description
GetImageAsync(String, Int32, Int32) | Requests image loading.
GetImageAsync(String, Int32, Int32, Object) | Requests image loading.

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetImageAsync Method (String, Int32, Int32)

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.GetImageAsync Method (String, Int32, Int32)
ReportServiceResourcesClient Class See Also Send Feedback
Requests image loading.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void GetImageAsync(
    string id,
    int pageIndex,
    int controlIndex
)
Visual Basic (Declaration)
Public Sub GetImageAsync ( _
    id As String, _
    pageIndex As Integer, _
    controlIndex As Integer _
)
Visual C++
public:
void GetImageAsync(
    String^ id,
    int pageIndex,
    int controlIndex
)

Parameters

id
Type: System..::.String
pageIndex
Type: System..::.Int32
controlIndex
Type: System..::.Int32

See Also

ReportServiceResourcesClient Class
GetImageAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetImageAsync Method (String, Int32, Int32, Object)

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.GetImageAsync Method (String, Int32, Int32, Object)
ReportServiceResourcesClient Class See Also Send Feedback
Requests image loading.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void GetImageAsync(
    string id,
    int pageIndex,
    int controlIndex,
    Object userState
)
Visual Basic (Declaration)
Public Sub GetImageAsync ( _
    id As String, _
    pageIndex As Integer, _
    controlIndex As Integer, _
    userState As Object _
)
Visual C++
public:
void GetImageAsync(
    String^ id,
    int pageIndex,
    int controlIndex,
    Object^ userState
)

Parameters

id
Type: System..::.String
pageIndex
Type: System..::.Int32
controlIndex
Type: System..::.Int32
userState
Type: System..::.Object

See Also

ReportServiceResourcesClient Class
GetImageAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetResourceAsync Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.GetResourceAsync Method
ReportServiceResourcesClient Class See Also Send Feedback

Overload List

Name | Description
GetResourceAsync(String) | Requests resource loading.
GetResourceAsync(String, Object) | Requests resource loading.

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetResourceAsync Method (String)

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.GetResourceAsync Method (String)
ReportServiceResourcesClient Class See Also Send Feedback
Requests resource loading.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void GetResourceAsync(
    string culture
)
Visual Basic (Declaration)
Public Sub GetResourceAsync ( _
    culture As String _
)
Visual C++
public:
void GetResourceAsync(
    String^ culture
)

Parameters

culture
Type: System..::.String

See Also

ReportServiceResourcesClient Class
GetResourceAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetResourceAsync Method (String, Object)

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.GetResourceAsync Method (String, Object)
ReportServiceResourcesClient Class See Also Send Feedback
Requests resource loading.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void GetResourceAsync(
    string culture,
    Object userState
)
Visual Basic (Declaration)
Public Sub GetResourceAsync ( _
    culture As String, _
    userState As Object _
)
Visual C++
public:
void GetResourceAsync(
    String^ culture,
    Object^ userState
)

Parameters

culture
Type: System..::.String
userState
Type: System..::.Object

See Also

ReportServiceResourcesClient Class
GetResourceAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


OpenAsync Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.OpenAsync Method
ReportServiceResourcesClient Class See Also Send Feedback

Overload List

Name | Description
OpenAsync()()() | Requests connection opening.
OpenAsync(Object) | Requests connection opening.

See Also

ReportServiceResourcesClient Class
ReportServiceResourcesClient Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


OpenAsync Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.OpenAsync Method
ReportServiceResourcesClient Class See Also Send Feedback
Requests connection opening.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void OpenAsync()
Visual Basic (Declaration)
Public Sub OpenAsync
Visual C++
public:
void OpenAsync()

See Also

ReportServiceResourcesClient Class
OpenAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


OpenAsync Method (Object)

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.OpenAsync Method (Object)
ReportServiceResourcesClient Class See Also Send Feedback
Requests connection opening.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void OpenAsync(
    Object userState
)
Visual Basic (Declaration)
Public Sub OpenAsync ( _
    userState As Object _
)
Visual C++
public:
void OpenAsync(
    Object^ userState
)

Parameters

userState
Type: System..::.Object

See Also

ReportServiceResourcesClient Class
OpenAsync Overload
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceResourcesClient Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient Properties
ReportServiceResourcesClient Class See Also Send Feedback

The ReportServiceResourcesClient type exposes the following members.

Properties

Name | Description
Channel | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
ChannelFactory | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
Endpoint | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
InnerChannel | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)
State | (Inherited from ClientBase <(Of <( IReportServiceResources >)>).)

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ReportServiceResourcesClient Events

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient Events
ReportServiceResourcesClient Class See Also Send Feedback

The ReportServiceResourcesClient type exposes the following members.

Events

Name | Description
CloseCompleted | Occurs when connection closing is finished.
ExportCompleted | Occurs when report export is finished.
GetFontCompleted | Occurs when font getting is finished.
GetImageCompleted | Occurs when image getting is finished.
GetResourceCompleted | Occurs when resource getting is finished.
OpenCompleted | Occurs when connection opening is finished.

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


CloseCompleted Event

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.CloseCompleted Event
ReportServiceResourcesClient Class See Also Send Feedback
Occurs when connection closing is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler<AsyncCompletedEventArgs> CloseCompleted
Visual Basic (Declaration)
Public Event CloseCompleted As EventHandler(Of AsyncCompletedEventArgs)
Visual C++
public:
 event EventHandler<AsyncCompletedEventArgs^>^ CloseCompleted {
    void add (EventHandler<AsyncCompletedEventArgs^>^ value);
    void remove (EventHandler<AsyncCompletedEventArgs^>^ value);
}

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ExportCompleted Event

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.ExportCompleted Event
ReportServiceResourcesClient Class See Also Send Feedback
Occurs when report export is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler<ExportCompletedEventArgs> ExportCompleted
Visual Basic (Declaration)
Public Event ExportCompleted As EventHandler(Of ExportCompletedEventArgs)
Visual C++
public:
 event EventHandler<ExportCompletedEventArgs^>^ ExportCompleted {
    void add (EventHandler<ExportCompletedEventArgs^>^ value);
    void remove (EventHandler<ExportCompletedEventArgs^>^ value);
}

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetFontCompleted Event

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.GetFontCompleted Event
ReportServiceResourcesClient Class See Also Send Feedback
Occurs when font getting is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler<GetFontCompletedEventArgs> GetFontCompleted
Visual Basic (Declaration)
Public Event GetFontCompleted As EventHandler(Of GetFontCompletedEventArgs)
Visual C++
public:
 event EventHandler<GetFontCompletedEventArgs^>^ GetFontCompleted {
    void add (EventHandler<GetFontCompletedEventArgs^>^ value);
    void remove (EventHandler<GetFontCompletedEventArgs^>^ value);
}

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetImageCompleted Event

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.GetImageCompleted Event
ReportServiceResourcesClient Class See Also Send Feedback
Occurs when image getting is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler<GetImageCompletedEventArgs> GetImageCompleted
Visual Basic (Declaration)
Public Event GetImageCompleted As EventHandler(Of GetImageCompletedEventArgs)
Visual C++
public:
 event EventHandler<GetImageCompletedEventArgs^>^ GetImageCompleted {
    void add (EventHandler<GetImageCompletedEventArgs^>^ value);
    void remove (EventHandler<GetImageCompletedEventArgs^>^ value);
}

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


GetResourceCompleted Event

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.GetResourceCompleted Event
ReportServiceResourcesClient Class See Also Send Feedback
Occurs when resource getting is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler<GetResourceCompletedEventArgs> GetResourceCompleted
Visual Basic (Declaration)
Public Event GetResourceCompleted As EventHandler(Of GetResourceCompletedEventArgs)
Visual C++
public:
 event EventHandler<GetResourceCompletedEventArgs^>^ GetResourceCompleted {
    void add (EventHandler<GetResourceCompletedEventArgs^>^ value);
    void remove (EventHandler<GetResourceCompletedEventArgs^>^ value);
}

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


OpenCompleted Event

[image]

.NET ModelKit Suite ClassReference
ReportServiceResourcesClient..::.OpenCompleted Event
ReportServiceResourcesClient Class See Also Send Feedback
Occurs when connection opening is finished.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event EventHandler<AsyncCompletedEventArgs> OpenCompleted
Visual Basic (Declaration)
Public Event OpenCompleted As EventHandler(Of AsyncCompletedEventArgs)
Visual C++
public:
 event EventHandler<AsyncCompletedEventArgs^>^ OpenCompleted {
    void add (EventHandler<AsyncCompletedEventArgs^>^ value);
    void remove (EventHandler<AsyncCompletedEventArgs^>^ value);
}

See Also

ReportServiceResourcesClient Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


SearchDirection Enumeration

[image]

.NET ModelKit Suite ClassReference
SearchDirection Enumeration
See Also Send Feedback
Sets search direction.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public enum SearchDirection
Visual Basic (Declaration)
Public Enumeration SearchDirection
Visual C++
public enum class SearchDirection

Members

Member name | Description
Forward | Sets search forward direction.
Backward | Sets search backward direction.

See Also

PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


SearchResult Class

[image]

.NET ModelKit Suite ClassReference
SearchResult Class
Members See Also Send Feedback
Represents text search results.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class SearchResult : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class SearchResult _
    Implements INotifyPropertyChanged
Visual C++
public ref class SearchResult : INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client.ReportService..::.SearchResult

See Also

SearchResult Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


SearchResult Members

[image] [image]

.NET ModelKit Suite ClassReference
SearchResult Members
SearchResult Class Constructors Methods Properties Events See Also Send Feedback

The SearchResult type exposes the following members.

Constructors

Name | Description
SearchResult | Initializes a new instance of the SearchResult class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged | Raises the PropertyChanged event.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ControlIndex | Gets or sets a report control number on a page.
Height | Gets or sets the height of the fragment which contains required text.
PageIndex | Gets or sets a page number.
Region | Gets ReportRegion the report area where the element with the required text is located.
TextFound | Gets or sets values which indicate if required text was found.
Width | Gets or sets the width of the fragment which includes required text.
X | Gets or sets the abscissa of the fragment beginning which includes required text.
Y | Gets or sets the ordinate of the fragment beginning which includes required text.

Events

Name | Description
PropertyChanged | Occurs after the value of an search result property is changed.

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


SearchResult Constructor

[image]

.NET ModelKit Suite ClassReference
SearchResult Constructor
SearchResult Class See Also Send Feedback
Initializes a new instance of the SearchResult class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public SearchResult()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SearchResult()

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


SearchResult Methods

[image] [image]

.NET ModelKit Suite ClassReference
SearchResult Methods
SearchResult Class See Also Send Feedback

The SearchResult type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged | Raises the PropertyChanged event.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


RaisePropertyChanged Method

[image]

.NET ModelKit Suite ClassReference
SearchResult..::.RaisePropertyChanged Method
SearchResult Class See Also Send Feedback
Raises the PropertyChanged event.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::.String

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


SearchResult Properties

[image] [image]

.NET ModelKit Suite ClassReference
SearchResult Properties
SearchResult Class See Also Send Feedback

The SearchResult type exposes the following members.

Properties

Name | Description
ControlIndex | Gets or sets a report control number on a page.
Height | Gets or sets the height of the fragment which contains required text.
PageIndex | Gets or sets a page number.
Region | Gets ReportRegion the report area where the element with the required text is located.
TextFound | Gets or sets values which indicate if required text was found.
Width | Gets or sets the width of the fragment which includes required text.
X | Gets or sets the abscissa of the fragment beginning which includes required text.
Y | Gets or sets the ordinate of the fragment beginning which includes required text.

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


ControlIndex Property

[image]

.NET ModelKit Suite ClassReference
SearchResult..::.ControlIndex Property
SearchResult Class See Also Send Feedback
Gets or sets a report control number on a page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public int ControlIndex { get; set; }
Visual Basic (Declaration)
Public Property ControlIndex As Integer
Visual C++
public:
property int ControlIndex {
    int get ();
    void set (int value);
}

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


Height Property

[image]

.NET ModelKit Suite ClassReference
SearchResult..::.Height Property
SearchResult Class See Also Send Feedback
Gets or sets the height of the fragment which contains required text.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public double Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Double
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


PageIndex Property

[image]

.NET ModelKit Suite ClassReference
SearchResult..::.PageIndex Property
SearchResult Class See Also Send Feedback
Gets or sets a page number.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public int PageIndex { get; set; }
Visual Basic (Declaration)
Public Property PageIndex As Integer
Visual C++
public:
property int PageIndex {
    int get ();
    void set (int value);
}

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


Region Property

[image]

.NET ModelKit Suite ClassReference
SearchResult..::.Region Property
SearchResult Class See Also Send Feedback
Gets ReportRegion the report area where the element with the required text is located.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ReportRegion Region { get; }
Visual Basic (Declaration)
Public ReadOnly Property Region As ReportRegion
Visual C++
public:
property ReportRegion Region {
    ReportRegion get ();
}

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


TextFound Property

[image]

.NET ModelKit Suite ClassReference
SearchResult..::.TextFound Property
SearchResult Class See Also Send Feedback
Gets or sets values which indicate if required text was found.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool TextFound { get; set; }
Visual Basic (Declaration)
Public Property TextFound As Boolean
Visual C++
public:
property bool TextFound {
    bool get ();
    void set (bool value);
}

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
SearchResult..::.Width Property
SearchResult Class See Also Send Feedback
Gets or sets the width of the fragment which includes required text.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


X Property

[image]

.NET ModelKit Suite ClassReference
SearchResult..::.X Property
SearchResult Class See Also Send Feedback
Gets or sets the abscissa of the fragment beginning which includes required text.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public double X { get; set; }
Visual Basic (Declaration)
Public Property X As Double
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


Y Property

[image]

.NET ModelKit Suite ClassReference
SearchResult..::.Y Property
SearchResult Class See Also Send Feedback
Gets or sets the ordinate of the fragment beginning which includes required text.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public double Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Double
Visual C++
public:
property double Y {
    double get ();
    void set (double value);
}

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


SearchResult Events

[image] [image]

.NET ModelKit Suite ClassReference
SearchResult Events
SearchResult Class See Also Send Feedback

The SearchResult type exposes the following members.

Events

Name | Description
PropertyChanged | Occurs after the value of an search result property is changed.

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


PropertyChanged Event

[image]

.NET ModelKit Suite ClassReference
SearchResult..::.PropertyChanged Event
SearchResult Class See Also Send Feedback
Occurs after the value of an search result property is changed.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


SizeF Structure

[image]

.NET ModelKit Suite ClassReference
SizeF Structure
Members See Also Send Feedback
Size.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public struct SizeF : INotifyPropertyChanged
Visual Basic (Declaration)
Public Structure SizeF _
    Implements INotifyPropertyChanged
Visual C++
public value class SizeF : INotifyPropertyChanged

See Also

SizeF Members
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


SizeF Members

[image] [image]

.NET ModelKit Suite ClassReference
SizeF Members
SizeF Structure Methods Properties Events See Also Send Feedback

The SizeF type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
height | Gets or sets height.
width | Gets or sets width.

Events

Name | Description
PropertyChanged | Occurs after the value of an size property is changed.

See Also

SizeF Structure
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


SizeF Methods

[image] [image]

.NET ModelKit Suite ClassReference
SizeF Methods
SizeF Structure See Also Send Feedback

The SizeF type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

SizeF Structure
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


SizeF Properties

[image] [image]

.NET ModelKit Suite ClassReference
SizeF Properties
SizeF Structure See Also Send Feedback

The SizeF type exposes the following members.

Properties

Name | Description
height | Gets or sets height.
width | Gets or sets width.

See Also

SizeF Structure
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


height Property

[image]

.NET ModelKit Suite ClassReference
SizeF..::.height Property
SizeF Structure See Also Send Feedback
Gets or sets height.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public float height { get; set; }
Visual Basic (Declaration)
Public Property height As Single
Visual C++
public:
property float height {
    float get ();
    void set (float value);
}

See Also

SizeF Structure
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


width Property

[image]

.NET ModelKit Suite ClassReference
SizeF..::.width Property
SizeF Structure See Also Send Feedback
Gets or sets width.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public float width { get; set; }
Visual Basic (Declaration)
Public Property width As Single
Visual C++
public:
property float width {
    float get ();
    void set (float value);
}

See Also

SizeF Structure
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


SizeF Events

[image] [image]

.NET ModelKit Suite ClassReference
SizeF Events
SizeF Structure See Also Send Feedback

The SizeF type exposes the following members.

Events

Name | Description
PropertyChanged | Occurs after the value of an size property is changed.

See Also

SizeF Structure
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


PropertyChanged Event

[image]

.NET ModelKit Suite ClassReference
SizeF..::.PropertyChanged Event
SizeF Structure See Also Send Feedback
Occurs after the value of an size property is changed.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.ReportService
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

SizeF Structure
PerpetuumSoft.Reporting.Silverlight.Client.ReportService Namespace


PerpetuumSoft.Reporting.Silverlight.Client.Utils Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Silverlight.Client.Utils Namespace
Send Feedback
The PerpetuumSoft.Reporting.Silverlight.Utils namespace contains classes implementing various secondary functions.

Classes

Class | Description
IsolatedStorageUtils | A static class which includes methods for working with isolated cash data storage.


IsolatedStorageUtils Class

[image]

.NET ModelKit Suite ClassReference
IsolatedStorageUtils Class
Members See Also Send Feedback
A static class which includes methods for working with isolated cash data storage.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Utils
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static class IsolatedStorageUtils
Visual Basic (Declaration)
Public NotInheritable Class IsolatedStorageUtils
Visual C++
public ref class IsolatedStorageUtils abstract sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Client.Utils..::.IsolatedStorageUtils

See Also

IsolatedStorageUtils Members
PerpetuumSoft.Reporting.Silverlight.Client.Utils Namespace


IsolatedStorageUtils Members

[image] [image]

.NET ModelKit Suite ClassReference
IsolatedStorageUtils Members
IsolatedStorageUtils Class Methods See Also Send Feedback

The IsolatedStorageUtils type exposes the following members.

Methods

Name | Description
GetNewQuota | Gets a new quota value for a storage.
IncreaseQuotaTo | Increases a quota value for a storage file.
SafeCreateFile | Creates storage file and writes data in it.
SafeWrite | Writes cash data in the storage.

See Also

IsolatedStorageUtils Class
PerpetuumSoft.Reporting.Silverlight.Client.Utils Namespace


IsolatedStorageUtils Methods

[image] [image]

.NET ModelKit Suite ClassReference
IsolatedStorageUtils Methods
IsolatedStorageUtils Class See Also Send Feedback

The IsolatedStorageUtils type exposes the following members.

Methods

Name | Description
GetNewQuota | Gets a new quota value for a storage.
IncreaseQuotaTo | Increases a quota value for a storage file.
SafeCreateFile | Creates storage file and writes data in it.
SafeWrite | Writes cash data in the storage.

See Also

IsolatedStorageUtils Class
PerpetuumSoft.Reporting.Silverlight.Client.Utils Namespace


GetNewQuota Method

[image]

.NET ModelKit Suite ClassReference
IsolatedStorageUtils..::.GetNewQuota Method
IsolatedStorageUtils Class See Also Send Feedback
Gets a new quota value for a storage.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Utils
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static long GetNewQuota(
    IsolatedStorageFile storage,
    long needSize
)
Visual Basic (Declaration)
Public Shared Function GetNewQuota ( _
    storage As IsolatedStorageFile, _
    needSize As Long _
) As Long
Visual C++
public:
static long long GetNewQuota(
    IsolatedStorageFile^ storage,
    long long needSize
)

Parameters

storage
Type: System.IO.IsolatedStorage..::.IsolatedStorageFile
needSize
Type: System..::.Int64

See Also

IsolatedStorageUtils Class
PerpetuumSoft.Reporting.Silverlight.Client.Utils Namespace


IncreaseQuotaTo Method

[image]

.NET ModelKit Suite ClassReference
IsolatedStorageUtils..::.IncreaseQuotaTo Method
IsolatedStorageUtils Class See Also Send Feedback
Increases a quota value for a storage file.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Utils
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static bool IncreaseQuotaTo(
    IsolatedStorageFile storage,
    long needSize
)
Visual Basic (Declaration)
Public Shared Function IncreaseQuotaTo ( _
    storage As IsolatedStorageFile, _
    needSize As Long _
) As Boolean
Visual C++
public:
static bool IncreaseQuotaTo(
    IsolatedStorageFile^ storage,
    long long needSize
)

Parameters

storage
Type: System.IO.IsolatedStorage..::.IsolatedStorageFile
needSize
Type: System..::.Int64

See Also

IsolatedStorageUtils Class
PerpetuumSoft.Reporting.Silverlight.Client.Utils Namespace


SafeCreateFile Method

[image]

.NET ModelKit Suite ClassReference
IsolatedStorageUtils..::.SafeCreateFile Method
IsolatedStorageUtils Class See Also Send Feedback
Creates storage file and writes data in it.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Utils
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static bool SafeCreateFile(
    IsolatedStorageFile storage,
    string filePath,
    byte[] data
)
Visual Basic (Declaration)
Public Shared Function SafeCreateFile ( _
    storage As IsolatedStorageFile, _
    filePath As String, _
    data As Byte() _
) As Boolean
Visual C++
public:
static bool SafeCreateFile(
    IsolatedStorageFile^ storage,
    String^ filePath,
    array<unsigned char>^ data
)

Parameters

storage
Type: System.IO.IsolatedStorage..::.IsolatedStorageFile
filePath
Type: System..::.String
data
Type: array< System..::.Byte >[]()[]

See Also

IsolatedStorageUtils Class
PerpetuumSoft.Reporting.Silverlight.Client.Utils Namespace


SafeWrite Method

[image]

.NET ModelKit Suite ClassReference
IsolatedStorageUtils..::.SafeWrite Method
IsolatedStorageUtils Class See Also Send Feedback
Writes cash data in the storage.

Namespace: PerpetuumSoft.Reporting.Silverlight.Client.Utils
Assembly: PerpetuumSoft.Reporting.Silverlight.Client (in PerpetuumSoft.Reporting.Silverlight.Client.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static bool SafeWrite(
    IsolatedStorageFile storage,
    IsolatedStorageFileStream stream,
    byte[] buffer,
    int offset,
    int count
)
Visual Basic (Declaration)
Public Shared Function SafeWrite ( _
    storage As IsolatedStorageFile, _
    stream As IsolatedStorageFileStream, _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
) As Boolean
Visual C++
public:
static bool SafeWrite(
    IsolatedStorageFile^ storage,
    IsolatedStorageFileStream^ stream,
    array<unsigned char>^ buffer,
    int offset,
    int count
)

Parameters

storage
Type: System.IO.IsolatedStorage..::.IsolatedStorageFile
stream
Type: System.IO.IsolatedStorage..::.IsolatedStorageFileStream
buffer
Type: array< System..::.Byte >[]()[]
offset
Type: System..::.Int32
count
Type: System..::.Int32

See Also

IsolatedStorageUtils Class
PerpetuumSoft.Reporting.Silverlight.Client.Utils Namespace


PerpetuumSoft.Reporting.Silverlight.Export Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Silverlight.Export Namespace
Send Feedback
The PerpetuumSoft.Reporting.Silverlight.Export namespace contains classes for the report export to the XAML format.

Classes

Class | Description
AdvancedTextXamlAdapter | This class is used for Xaml markup creation of the AdvancedTextBox class elements during the report export to Xaml. Inherited from BoxXamlAdapter.
BoxXamlAdapter | This class is used for Xaml markup creation for report element borders. Inherited from XamlAdapter.
EllipseAdapter | This adapter is used for the export of Ellipse element to Xaml. Inherited from ShapeAdapter.
LineAdapter | This adapter is used for the export of a Line element to Xaml. Inherited from ShapeAdapter.
PolygonAdapter | This adapter is used for the export of Polygon element to Xaml. Inherited from ShapeAdapter.
ReportControlXamlAdapter | This class is used for Xaml markup creation of custom elements class, images and gauges during report export to Xaml. Inherited from BoxXamlAdapter.
RichTextXamlAdapter | This class is used for Xaml markup creation of the RichText class elements during the report export to Xaml. Inherited from BoxXamlAdapter.
RoundRectangleAdapter | This adapter is used for the export of RoundedRectangle element to Xaml. Inherited from ShapeAdapter.
ShapeAdapter | This class is used as a basic class for all adapters which realize export of various Shape element to Xaml.
ShapeXamlAdapter | This class is used as a basic class for all adapters which realize export of various Shape element to Xaml.
StyleExtensions | Contains methods for work with report elements styles.
TextBoxXamlAdapter | This class is used for Xaml markup creation of the TextBox class elements during the report export to Xaml. Inherited from BoxXamlAdapter.
XamlAdapter | An abstract class. It is a basic class for creation of all export filters. The class is used for getting Xaml markup for all report elements.
XamlExportFilter | The Xaml export filter.
XamlExportFilterFactory | The Xaml export filter factory.
XamlMediaShapes | A class for working with various adapters for Shapes. Contains methods for registration of new adapters declared by a user.

Interfaces

Interface | Description
IXamlContext | The interface which defines a method for realization of the parameters class for report element export to Xaml.


AdvancedTextXamlAdapter Class

[image]

.NET ModelKit Suite ClassReference
AdvancedTextXamlAdapter Class
Members See Also Send Feedback
This class is used for Xaml markup creation of the AdvancedTextBox class elements during the report export to Xaml. Inherited from BoxXamlAdapter.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class AdvancedTextXamlAdapter : BoxXamlAdapter
Visual Basic (Declaration)
Public Class AdvancedTextXamlAdapter _
    Inherits BoxXamlAdapter
Visual C++
public ref class AdvancedTextXamlAdapter : public BoxXamlAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Export..::.XamlAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.BoxXamlAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.AdvancedTextXamlAdapter

See Also

AdvancedTextXamlAdapter Members
PerpetuumSoft.Reporting.Silverlight.Export Namespace


AdvancedTextXamlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextXamlAdapter Members
AdvancedTextXamlAdapter Class Constructors Methods Properties See Also Send Feedback

The AdvancedTextXamlAdapter type exposes the following members.

Constructors

Name | Description
AdvancedTextXamlAdapter | Initializes a new instance of the AdvancedTextXamlAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportControl | Overridden. See ExportControl(XmlElement, ReportControl, IXamlContext). (Overrides BoxXamlAdapter..::.ExportControl(XmlElement, ReportControl, IXamlContext).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetBorder | Exports element's border to Xaml. (Inherited from BoxXamlAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportFilter | Gets XamlExportFilter which is уexport filter. (Inherited from XamlAdapter.)

See Also

AdvancedTextXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


AdvancedTextXamlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
AdvancedTextXamlAdapter Constructor
AdvancedTextXamlAdapter Class See Also Send Feedback
Initializes a new instance of the AdvancedTextXamlAdapter class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public AdvancedTextXamlAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AdvancedTextXamlAdapter()

See Also

AdvancedTextXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


AdvancedTextXamlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextXamlAdapter Methods
AdvancedTextXamlAdapter Class See Also Send Feedback

The AdvancedTextXamlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportControl | Overridden. See ExportControl(XmlElement, ReportControl, IXamlContext). (Overrides BoxXamlAdapter..::.ExportControl(XmlElement, ReportControl, IXamlContext).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetBorder | Exports element's border to Xaml. (Inherited from BoxXamlAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdvancedTextXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ExportControl Method

[image]

.NET ModelKit Suite ClassReference
AdvancedTextXamlAdapter..::.ExportControl Method
AdvancedTextXamlAdapter Class See Also Send Feedback
Overridden. See ExportControl(XmlElement, ReportControl, IXamlContext).

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override XmlElement ExportControl(
    XmlElement pageTag,
    ReportControl reportControl,
    IXamlContext context
)
Visual Basic (Declaration)
Public Overrides Function ExportControl ( _
    pageTag As XmlElement, _
    reportControl As ReportControl, _
    context As IXamlContext _
) As XmlElement
Visual C++
public:
virtual XmlElement^ ExportControl(
    XmlElement^ pageTag,
    ReportControl^ reportControl,
    IXamlContext^ context
) override

Parameters

pageTag
Type: System.Xml..::.XmlElement
reportControl
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Silverlight.Export..::.IXamlContext

See Also

AdvancedTextXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


AdvancedTextXamlAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
AdvancedTextXamlAdapter Properties
AdvancedTextXamlAdapter Class See Also Send Feedback

The AdvancedTextXamlAdapter type exposes the following members.

Properties

Name | Description
ExportFilter | Gets XamlExportFilter which is уexport filter. (Inherited from XamlAdapter.)

See Also

AdvancedTextXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


BoxXamlAdapter Class

[image]

.NET ModelKit Suite ClassReference
BoxXamlAdapter Class
Members See Also Send Feedback
This class is used for Xaml markup creation for report element borders. Inherited from XamlAdapter.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class BoxXamlAdapter : XamlAdapter
Visual Basic (Declaration)
Public Class BoxXamlAdapter _
    Inherits XamlAdapter
Visual C++
public ref class BoxXamlAdapter : public XamlAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Export..::.XamlAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.BoxXamlAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.AdvancedTextXamlAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.ReportControlXamlAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.RichTextXamlAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.TextBoxXamlAdapter

See Also

BoxXamlAdapter Members
PerpetuumSoft.Reporting.Silverlight.Export Namespace


BoxXamlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
BoxXamlAdapter Members
BoxXamlAdapter Class Constructors Methods Properties See Also Send Feedback

The BoxXamlAdapter type exposes the following members.

Constructors

Name | Description
BoxXamlAdapter | Initializes a new instance of the BoxXamlAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportControl | Overridden. See ExportControl(XmlElement, ReportControl, IXamlContext). (Overrides XamlAdapter..::.ExportControl(XmlElement, ReportControl, IXamlContext).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetBorder | Exports element's border to Xaml.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportFilter | Gets XamlExportFilter which is уexport filter. (Inherited from XamlAdapter.)

See Also

BoxXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


BoxXamlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
BoxXamlAdapter Constructor
BoxXamlAdapter Class See Also Send Feedback
Initializes a new instance of the BoxXamlAdapter class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public BoxXamlAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BoxXamlAdapter()

See Also

BoxXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


BoxXamlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
BoxXamlAdapter Methods
BoxXamlAdapter Class See Also Send Feedback

The BoxXamlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportControl | Overridden. See ExportControl(XmlElement, ReportControl, IXamlContext). (Overrides XamlAdapter..::.ExportControl(XmlElement, ReportControl, IXamlContext).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetBorder | Exports element's border to Xaml.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoxXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ExportControl Method

[image]

.NET ModelKit Suite ClassReference
BoxXamlAdapter..::.ExportControl Method
BoxXamlAdapter Class See Also Send Feedback
Overridden. See ExportControl(XmlElement, ReportControl, IXamlContext).

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override XmlElement ExportControl(
    XmlElement pageTag,
    ReportControl reportControl,
    IXamlContext context
)
Visual Basic (Declaration)
Public Overrides Function ExportControl ( _
    pageTag As XmlElement, _
    reportControl As ReportControl, _
    context As IXamlContext _
) As XmlElement
Visual C++
public:
virtual XmlElement^ ExportControl(
    XmlElement^ pageTag,
    ReportControl^ reportControl,
    IXamlContext^ context
) override

Parameters

pageTag
Type: System.Xml..::.XmlElement
reportControl
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Silverlight.Export..::.IXamlContext

See Also

BoxXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


SetBorder Method

[image]

.NET ModelKit Suite ClassReference
BoxXamlAdapter..::.SetBorder Method
BoxXamlAdapter Class See Also Send Feedback
Exports element's border to Xaml.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected void SetBorder(
    XmlElement rectTag,
    Box box
)
Visual Basic (Declaration)
Protected Sub SetBorder ( _
    rectTag As XmlElement, _
    box As Box _
)
Visual C++
protected:
void SetBorder(
    XmlElement^ rectTag,
    Box^ box
)

Parameters

rectTag
Type: System.Xml..::.XmlElement
box
Type: PerpetuumSoft.Reporting.DOM..::.Box

See Also

BoxXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


BoxXamlAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
BoxXamlAdapter Properties
BoxXamlAdapter Class See Also Send Feedback

The BoxXamlAdapter type exposes the following members.

Properties

Name | Description
ExportFilter | Gets XamlExportFilter which is уexport filter. (Inherited from XamlAdapter.)

See Also

BoxXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


EllipseAdapter Class

[image]

.NET ModelKit Suite ClassReference
EllipseAdapter Class
Members See Also Send Feedback
This adapter is used for the export of Ellipse element to Xaml. Inherited from ShapeAdapter.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class EllipseAdapter : ShapeAdapter
Visual Basic (Declaration)
Public Class EllipseAdapter _
    Inherits ShapeAdapter
Visual C++
public ref class EllipseAdapter : public ShapeAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Export..::.ShapeAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.EllipseAdapter

See Also

EllipseAdapter Members
PerpetuumSoft.Reporting.Silverlight.Export Namespace


EllipseAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
EllipseAdapter Members
EllipseAdapter Class Constructors Methods See Also Send Feedback

The EllipseAdapter type exposes the following members.

Constructors

Name | Description
EllipseAdapter | Initializes a new instance of the EllipseAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteShape | Overridden. See WriteShape(XmlElement, Shape). (Overrides ShapeAdapter..::.WriteShape(XmlElement, Shape).)

See Also

EllipseAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


EllipseAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
EllipseAdapter Constructor
EllipseAdapter Class See Also Send Feedback
Initializes a new instance of the EllipseAdapter class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public EllipseAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EllipseAdapter()

See Also

EllipseAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


EllipseAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
EllipseAdapter Methods
EllipseAdapter Class See Also Send Feedback

The EllipseAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteShape | Overridden. See WriteShape(XmlElement, Shape). (Overrides ShapeAdapter..::.WriteShape(XmlElement, Shape).)

See Also

EllipseAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


WriteShape Method

[image]

.NET ModelKit Suite ClassReference
EllipseAdapter..::.WriteShape Method
EllipseAdapter Class See Also Send Feedback
Overridden. See WriteShape(XmlElement, Shape).

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override XmlElement WriteShape(
    XmlElement pageTag,
    Shape source
)
Visual Basic (Declaration)
Public Overrides Function WriteShape ( _
    pageTag As XmlElement, _
    source As Shape _
) As XmlElement
Visual C++
public:
virtual XmlElement^ WriteShape(
    XmlElement^ pageTag,
    Shape^ source
) override

Parameters

pageTag
Type: System.Xml..::.XmlElement
source
Type: PerpetuumSoft.Reporting.DOM..::.Shape

See Also

EllipseAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


IXamlContext Interface

[image]

.NET ModelKit Suite ClassReference
IXamlContext Interface
Members See Also Send Feedback
The interface which defines a method for realization of the parameters class for report element export to Xaml.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public interface IXamlContext
Visual Basic (Declaration)
Public Interface IXamlContext
Visual C++
public interface class IXamlContext

See Also

IXamlContext Members
PerpetuumSoft.Reporting.Silverlight.Export Namespace


IXamlContext Members

[image] [image]

.NET ModelKit Suite ClassReference
IXamlContext Members
IXamlContext Interface Methods See Also Send Feedback

The IXamlContext type exposes the following members.

Methods

Name | Description
GetUrl | Gets the URL address for hyperlink realization.

See Also

IXamlContext Interface
PerpetuumSoft.Reporting.Silverlight.Export Namespace


IXamlContext Methods

[image] [image]

.NET ModelKit Suite ClassReference
IXamlContext Methods
IXamlContext Interface See Also Send Feedback

The IXamlContext type exposes the following members.

Methods

Name | Description
GetUrl | Gets the URL address for hyperlink realization.

See Also

IXamlContext Interface
PerpetuumSoft.Reporting.Silverlight.Export Namespace


GetUrl Method

[image]

.NET ModelKit Suite ClassReference
IXamlContext..::.GetUrl Method
IXamlContext Interface See Also Send Feedback
Gets the URL address for hyperlink realization.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
string GetUrl(
    Object resource
)
Visual Basic (Declaration)
Function GetUrl ( _
    resource As Object _
) As String
Visual C++
String^ GetUrl(
    Object^ resource
)

Parameters

resource
Type: System..::.Object

See Also

IXamlContext Interface
PerpetuumSoft.Reporting.Silverlight.Export Namespace


LineAdapter Class

[image]

.NET ModelKit Suite ClassReference
LineAdapter Class
Members See Also Send Feedback
This adapter is used for the export of a Line element to Xaml. Inherited from ShapeAdapter.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class LineAdapter : ShapeAdapter
Visual Basic (Declaration)
Public Class LineAdapter _
    Inherits ShapeAdapter
Visual C++
public ref class LineAdapter : public ShapeAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Export..::.ShapeAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.LineAdapter

See Also

LineAdapter Members
PerpetuumSoft.Reporting.Silverlight.Export Namespace


LineAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
LineAdapter Members
LineAdapter Class Constructors Methods See Also Send Feedback

The LineAdapter type exposes the following members.

Constructors

Name | Description
LineAdapter | Initializes a new instance of the LineAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteShape | Overridden. See WriteShape(XmlElement, Shape). (Overrides ShapeAdapter..::.WriteShape(XmlElement, Shape).)

See Also

LineAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


LineAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
LineAdapter Constructor
LineAdapter Class See Also Send Feedback
Initializes a new instance of the LineAdapter class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public LineAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LineAdapter()

See Also

LineAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


LineAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
LineAdapter Methods
LineAdapter Class See Also Send Feedback

The LineAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteShape | Overridden. See WriteShape(XmlElement, Shape). (Overrides ShapeAdapter..::.WriteShape(XmlElement, Shape).)

See Also

LineAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


WriteShape Method

[image]

.NET ModelKit Suite ClassReference
LineAdapter..::.WriteShape Method
LineAdapter Class See Also Send Feedback
Overridden. See WriteShape(XmlElement, Shape).

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override XmlElement WriteShape(
    XmlElement pageTag,
    Shape source
)
Visual Basic (Declaration)
Public Overrides Function WriteShape ( _
    pageTag As XmlElement, _
    source As Shape _
) As XmlElement
Visual C++
public:
virtual XmlElement^ WriteShape(
    XmlElement^ pageTag,
    Shape^ source
) override

Parameters

pageTag
Type: System.Xml..::.XmlElement
source
Type: PerpetuumSoft.Reporting.DOM..::.Shape

See Also

LineAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


PolygonAdapter Class

[image]

.NET ModelKit Suite ClassReference
PolygonAdapter Class
Members See Also Send Feedback
This adapter is used for the export of Polygon element to Xaml. Inherited from ShapeAdapter.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class PolygonAdapter : ShapeAdapter
Visual Basic (Declaration)
Public Class PolygonAdapter _
    Inherits ShapeAdapter
Visual C++
public ref class PolygonAdapter : public ShapeAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Export..::.ShapeAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.PolygonAdapter

See Also

PolygonAdapter Members
PerpetuumSoft.Reporting.Silverlight.Export Namespace


PolygonAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
PolygonAdapter Members
PolygonAdapter Class Constructors Methods See Also Send Feedback

The PolygonAdapter type exposes the following members.

Constructors

Name | Description
PolygonAdapter | Initializes a new instance of the PolygonAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteShape | Overridden. See WriteShape(XmlElement, Shape). (Overrides ShapeAdapter..::.WriteShape(XmlElement, Shape).)

See Also

PolygonAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


PolygonAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
PolygonAdapter Constructor
PolygonAdapter Class See Also Send Feedback
Initializes a new instance of the PolygonAdapter class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public PolygonAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PolygonAdapter()

See Also

PolygonAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


PolygonAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
PolygonAdapter Methods
PolygonAdapter Class See Also Send Feedback

The PolygonAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteShape | Overridden. See WriteShape(XmlElement, Shape). (Overrides ShapeAdapter..::.WriteShape(XmlElement, Shape).)

See Also

PolygonAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


WriteShape Method

[image]

.NET ModelKit Suite ClassReference
PolygonAdapter..::.WriteShape Method
PolygonAdapter Class See Also Send Feedback
Overridden. See WriteShape(XmlElement, Shape).

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override XmlElement WriteShape(
    XmlElement pageTag,
    Shape source
)
Visual Basic (Declaration)
Public Overrides Function WriteShape ( _
    pageTag As XmlElement, _
    source As Shape _
) As XmlElement
Visual C++
public:
virtual XmlElement^ WriteShape(
    XmlElement^ pageTag,
    Shape^ source
) override

Parameters

pageTag
Type: System.Xml..::.XmlElement
source
Type: PerpetuumSoft.Reporting.DOM..::.Shape

See Also

PolygonAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ReportControlXamlAdapter Class

[image]

.NET ModelKit Suite ClassReference
ReportControlXamlAdapter Class
Members See Also Send Feedback
This class is used for Xaml markup creation of custom elements class, images and gauges during report export to Xaml. Inherited from BoxXamlAdapter.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ReportControlXamlAdapter : BoxXamlAdapter
Visual Basic (Declaration)
Public Class ReportControlXamlAdapter _
    Inherits BoxXamlAdapter
Visual C++
public ref class ReportControlXamlAdapter : public BoxXamlAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Export..::.XamlAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.BoxXamlAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.ReportControlXamlAdapter

See Also

ReportControlXamlAdapter Members
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ReportControlXamlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlXamlAdapter Members
ReportControlXamlAdapter Class Constructors Methods Properties See Also Send Feedback

The ReportControlXamlAdapter type exposes the following members.

Constructors

Name | Description
ReportControlXamlAdapter | Initializes a new instance of the ReportControlXamlAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportControl | Overridden. See ExportControl(XmlElement, ReportControl, IXamlContext). (Overrides BoxXamlAdapter..::.ExportControl(XmlElement, ReportControl, IXamlContext).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetBorder | Exports element's border to Xaml. (Inherited from BoxXamlAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportFilter | Gets XamlExportFilter which is уexport filter. (Inherited from XamlAdapter.)

See Also

ReportControlXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ReportControlXamlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
ReportControlXamlAdapter Constructor
ReportControlXamlAdapter Class See Also Send Feedback
Initializes a new instance of the ReportControlXamlAdapter class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ReportControlXamlAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportControlXamlAdapter()

See Also

ReportControlXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ReportControlXamlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlXamlAdapter Methods
ReportControlXamlAdapter Class See Also Send Feedback

The ReportControlXamlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportControl | Overridden. See ExportControl(XmlElement, ReportControl, IXamlContext). (Overrides BoxXamlAdapter..::.ExportControl(XmlElement, ReportControl, IXamlContext).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetBorder | Exports element's border to Xaml. (Inherited from BoxXamlAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportControlXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ExportControl Method

[image]

.NET ModelKit Suite ClassReference
ReportControlXamlAdapter..::.ExportControl Method
ReportControlXamlAdapter Class See Also Send Feedback
Overridden. See ExportControl(XmlElement, ReportControl, IXamlContext).

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override XmlElement ExportControl(
    XmlElement pageTag,
    ReportControl reportControl,
    IXamlContext context
)
Visual Basic (Declaration)
Public Overrides Function ExportControl ( _
    pageTag As XmlElement, _
    reportControl As ReportControl, _
    context As IXamlContext _
) As XmlElement
Visual C++
public:
virtual XmlElement^ ExportControl(
    XmlElement^ pageTag,
    ReportControl^ reportControl,
    IXamlContext^ context
) override

Parameters

pageTag
Type: System.Xml..::.XmlElement
reportControl
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Silverlight.Export..::.IXamlContext

See Also

ReportControlXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ReportControlXamlAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportControlXamlAdapter Properties
ReportControlXamlAdapter Class See Also Send Feedback

The ReportControlXamlAdapter type exposes the following members.

Properties

Name | Description
ExportFilter | Gets XamlExportFilter which is уexport filter. (Inherited from XamlAdapter.)

See Also

ReportControlXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


RichTextXamlAdapter Class

[image]

.NET ModelKit Suite ClassReference
RichTextXamlAdapter Class
Members See Also Send Feedback
This class is used for Xaml markup creation of the RichText class elements during the report export to Xaml. Inherited from BoxXamlAdapter.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class RichTextXamlAdapter : BoxXamlAdapter
Visual Basic (Declaration)
Public Class RichTextXamlAdapter _
    Inherits BoxXamlAdapter
Visual C++
public ref class RichTextXamlAdapter : public BoxXamlAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Export..::.XamlAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.BoxXamlAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.RichTextXamlAdapter

See Also

RichTextXamlAdapter Members
PerpetuumSoft.Reporting.Silverlight.Export Namespace


RichTextXamlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
RichTextXamlAdapter Members
RichTextXamlAdapter Class Constructors Methods Properties See Also Send Feedback

The RichTextXamlAdapter type exposes the following members.

Constructors

Name | Description
RichTextXamlAdapter | Initializes a new instance of the RichTextXamlAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportControl | Overridden. See ExportControl(XmlElement, ReportControl, IXamlContext). (Overrides BoxXamlAdapter..::.ExportControl(XmlElement, ReportControl, IXamlContext).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetBorder | Exports element's border to Xaml. (Inherited from BoxXamlAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportFilter | Gets XamlExportFilter which is уexport filter. (Inherited from XamlAdapter.)

See Also

RichTextXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


RichTextXamlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
RichTextXamlAdapter Constructor
RichTextXamlAdapter Class See Also Send Feedback
Initializes a new instance of the RichTextXamlAdapter class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public RichTextXamlAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RichTextXamlAdapter()

See Also

RichTextXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


RichTextXamlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
RichTextXamlAdapter Methods
RichTextXamlAdapter Class See Also Send Feedback

The RichTextXamlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportControl | Overridden. See ExportControl(XmlElement, ReportControl, IXamlContext). (Overrides BoxXamlAdapter..::.ExportControl(XmlElement, ReportControl, IXamlContext).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetBorder | Exports element's border to Xaml. (Inherited from BoxXamlAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RichTextXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ExportControl Method

[image]

.NET ModelKit Suite ClassReference
RichTextXamlAdapter..::.ExportControl Method
RichTextXamlAdapter Class See Also Send Feedback
Overridden. See ExportControl(XmlElement, ReportControl, IXamlContext).

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override XmlElement ExportControl(
    XmlElement pageTag,
    ReportControl reportControl,
    IXamlContext context
)
Visual Basic (Declaration)
Public Overrides Function ExportControl ( _
    pageTag As XmlElement, _
    reportControl As ReportControl, _
    context As IXamlContext _
) As XmlElement
Visual C++
public:
virtual XmlElement^ ExportControl(
    XmlElement^ pageTag,
    ReportControl^ reportControl,
    IXamlContext^ context
) override

Parameters

pageTag
Type: System.Xml..::.XmlElement
reportControl
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Silverlight.Export..::.IXamlContext

See Also

RichTextXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


RichTextXamlAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
RichTextXamlAdapter Properties
RichTextXamlAdapter Class See Also Send Feedback

The RichTextXamlAdapter type exposes the following members.

Properties

Name | Description
ExportFilter | Gets XamlExportFilter which is уexport filter. (Inherited from XamlAdapter.)

See Also

RichTextXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


RoundRectangleAdapter Class

[image]

.NET ModelKit Suite ClassReference
RoundRectangleAdapter Class
Members See Also Send Feedback
This adapter is used for the export of RoundedRectangle element to Xaml. Inherited from ShapeAdapter.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class RoundRectangleAdapter : ShapeAdapter
Visual Basic (Declaration)
Public Class RoundRectangleAdapter _
    Inherits ShapeAdapter
Visual C++
public ref class RoundRectangleAdapter : public ShapeAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Export..::.ShapeAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.RoundRectangleAdapter

See Also

RoundRectangleAdapter Members
PerpetuumSoft.Reporting.Silverlight.Export Namespace


RoundRectangleAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
RoundRectangleAdapter Members
RoundRectangleAdapter Class Constructors Methods See Also Send Feedback

The RoundRectangleAdapter type exposes the following members.

Constructors

Name | Description
RoundRectangleAdapter | Initializes a new instance of the RoundRectangleAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteShape | Overridden. See WriteShape(XmlElement, Shape). (Overrides ShapeAdapter..::.WriteShape(XmlElement, Shape).)

See Also

RoundRectangleAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


RoundRectangleAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
RoundRectangleAdapter Constructor
RoundRectangleAdapter Class See Also Send Feedback
Initializes a new instance of the RoundRectangleAdapter class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public RoundRectangleAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoundRectangleAdapter()

See Also

RoundRectangleAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


RoundRectangleAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
RoundRectangleAdapter Methods
RoundRectangleAdapter Class See Also Send Feedback

The RoundRectangleAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteShape | Overridden. See WriteShape(XmlElement, Shape). (Overrides ShapeAdapter..::.WriteShape(XmlElement, Shape).)

See Also

RoundRectangleAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


WriteShape Method

[image]

.NET ModelKit Suite ClassReference
RoundRectangleAdapter..::.WriteShape Method
RoundRectangleAdapter Class See Also Send Feedback
Overridden. See WriteShape(XmlElement, Shape).

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override XmlElement WriteShape(
    XmlElement pageTag,
    Shape source
)
Visual Basic (Declaration)
Public Overrides Function WriteShape ( _
    pageTag As XmlElement, _
    source As Shape _
) As XmlElement
Visual C++
public:
virtual XmlElement^ WriteShape(
    XmlElement^ pageTag,
    Shape^ source
) override

Parameters

pageTag
Type: System.Xml..::.XmlElement
source
Type: PerpetuumSoft.Reporting.DOM..::.Shape

See Also

RoundRectangleAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ShapeAdapter Class

[image]

.NET ModelKit Suite ClassReference
ShapeAdapter Class
Members See Also Send Feedback
This class is used as a basic class for all adapters which realize export of various Shape element to Xaml.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract class ShapeAdapter
Visual Basic (Declaration)
Public MustInherit Class ShapeAdapter
Visual C++
public ref class ShapeAdapter abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Export..::.ShapeAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.EllipseAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.LineAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.PolygonAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.RoundRectangleAdapter

See Also

ShapeAdapter Members
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ShapeAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
ShapeAdapter Members
ShapeAdapter Class Constructors Methods See Also Send Feedback

The ShapeAdapter type exposes the following members.

Constructors

Name | Description
ShapeAdapter | Initializes a new instance of the ShapeAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteShape | Creates a node in the Xaml file for the corresponding Shape element.

See Also

ShapeAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ShapeAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
ShapeAdapter Constructor
ShapeAdapter Class See Also Send Feedback
Initializes a new instance of the ShapeAdapter class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ShapeAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ShapeAdapter()

See Also

ShapeAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ShapeAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ShapeAdapter Methods
ShapeAdapter Class See Also Send Feedback

The ShapeAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteShape | Creates a node in the Xaml file for the corresponding Shape element.

See Also

ShapeAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


WriteShape Method

[image]

.NET ModelKit Suite ClassReference
ShapeAdapter..::.WriteShape Method
ShapeAdapter Class See Also Send Feedback
Creates a node in the Xaml file for the corresponding Shape element.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract XmlElement WriteShape(
    XmlElement pageTag,
    Shape source
)
Visual Basic (Declaration)
Public MustOverride Function WriteShape ( _
    pageTag As XmlElement, _
    source As Shape _
) As XmlElement
Visual C++
public:
virtual XmlElement^ WriteShape(
    XmlElement^ pageTag,
    Shape^ source
) abstract

Parameters

pageTag
Type: System.Xml..::.XmlElement
source
Type: PerpetuumSoft.Reporting.DOM..::.Shape

See Also

ShapeAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ShapeXamlAdapter Class

[image]

.NET ModelKit Suite ClassReference
ShapeXamlAdapter Class
Members See Also Send Feedback
This class is used as a basic class for all adapters which realize export of various Shape element to Xaml.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ShapeXamlAdapter : XamlAdapter
Visual Basic (Declaration)
Public Class ShapeXamlAdapter _
    Inherits XamlAdapter
Visual C++
public ref class ShapeXamlAdapter : public XamlAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Export..::.XamlAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.ShapeXamlAdapter

See Also

ShapeXamlAdapter Members
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ShapeXamlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
ShapeXamlAdapter Members
ShapeXamlAdapter Class Constructors Methods Properties See Also Send Feedback

The ShapeXamlAdapter type exposes the following members.

Constructors

Name | Description
ShapeXamlAdapter | Initializes a new instance of the ShapeXamlAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportControl | Overridden. See ExportControl(XmlElement, ReportControl, IXamlContext). (Overrides XamlAdapter..::.ExportControl(XmlElement, ReportControl, IXamlContext).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportFilter | Gets XamlExportFilter which is уexport filter. (Inherited from XamlAdapter.)

See Also

ShapeXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ShapeXamlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
ShapeXamlAdapter Constructor
ShapeXamlAdapter Class See Also Send Feedback
Initializes a new instance of the ShapeXamlAdapter class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ShapeXamlAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ShapeXamlAdapter()

See Also

ShapeXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ShapeXamlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
ShapeXamlAdapter Methods
ShapeXamlAdapter Class See Also Send Feedback

The ShapeXamlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportControl | Overridden. See ExportControl(XmlElement, ReportControl, IXamlContext). (Overrides XamlAdapter..::.ExportControl(XmlElement, ReportControl, IXamlContext).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShapeXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ExportControl Method

[image]

.NET ModelKit Suite ClassReference
ShapeXamlAdapter..::.ExportControl Method
ShapeXamlAdapter Class See Also Send Feedback
Overridden. See ExportControl(XmlElement, ReportControl, IXamlContext).

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override XmlElement ExportControl(
    XmlElement pageTag,
    ReportControl reportControl,
    IXamlContext context
)
Visual Basic (Declaration)
Public Overrides Function ExportControl ( _
    pageTag As XmlElement, _
    reportControl As ReportControl, _
    context As IXamlContext _
) As XmlElement
Visual C++
public:
virtual XmlElement^ ExportControl(
    XmlElement^ pageTag,
    ReportControl^ reportControl,
    IXamlContext^ context
) override

Parameters

pageTag
Type: System.Xml..::.XmlElement
reportControl
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Silverlight.Export..::.IXamlContext

See Also

ShapeXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ShapeXamlAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
ShapeXamlAdapter Properties
ShapeXamlAdapter Class See Also Send Feedback

The ShapeXamlAdapter type exposes the following members.

Properties

Name | Description
ExportFilter | Gets XamlExportFilter which is уexport filter. (Inherited from XamlAdapter.)

See Also

ShapeXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


StyleExtensions Class

[image]

.NET ModelKit Suite ClassReference
StyleExtensions Class
Members See Also Send Feedback
Contains methods for work with report elements styles.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static class StyleExtensions
Visual Basic (Declaration)
Public NotInheritable Class StyleExtensions
Visual C++
public ref class StyleExtensions abstract sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Export..::.StyleExtensions

See Also

StyleExtensions Members
PerpetuumSoft.Reporting.Silverlight.Export Namespace


StyleExtensions Members

[image] [image]

.NET ModelKit Suite ClassReference
StyleExtensions Members
StyleExtensions Class Methods See Also Send Feedback

The StyleExtensions type exposes the following members.

Methods

Name | Description
EqualsTo | Returns a value indicating whether the value of the given style object is equal to that of the calling style object.

See Also

StyleExtensions Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


StyleExtensions Methods

[image] [image]

.NET ModelKit Suite ClassReference
StyleExtensions Methods
StyleExtensions Class See Also Send Feedback

The StyleExtensions type exposes the following members.

Methods

Name | Description
EqualsTo | Returns a value indicating whether the value of the given style object is equal to that of the calling style object.

See Also

StyleExtensions Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


EqualsTo Method

[image]

.NET ModelKit Suite ClassReference
StyleExtensions..::.EqualsTo Method
StyleExtensions Class See Also Send Feedback
Returns a value indicating whether the value of the given style object is equal to that of the calling style object.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static bool EqualsTo(
    Style thisObj,
    Style otherObj
)
Visual Basic (Declaration)
Public Shared Function EqualsTo ( _
    thisObj As Style, _
    otherObj As Style _
) As Boolean
Visual C++
public:
static bool EqualsTo(
    Style^ thisObj,
    Style^ otherObj
)

Parameters

thisObj
Type: PerpetuumSoft.Reporting.DOM..::.Style
otherObj
Type: PerpetuumSoft.Reporting.DOM..::.Style

See Also

StyleExtensions Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


TextBoxXamlAdapter Class

[image]

.NET ModelKit Suite ClassReference
TextBoxXamlAdapter Class
Members See Also Send Feedback
This class is used for Xaml markup creation of the TextBox class elements during the report export to Xaml. Inherited from BoxXamlAdapter.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class TextBoxXamlAdapter : BoxXamlAdapter
Visual Basic (Declaration)
Public Class TextBoxXamlAdapter _
    Inherits BoxXamlAdapter
Visual C++
public ref class TextBoxXamlAdapter : public BoxXamlAdapter

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Export..::.XamlAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.BoxXamlAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.TextBoxXamlAdapter

See Also

TextBoxXamlAdapter Members
PerpetuumSoft.Reporting.Silverlight.Export Namespace


TextBoxXamlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxXamlAdapter Members
TextBoxXamlAdapter Class Constructors Methods Properties See Also Send Feedback

The TextBoxXamlAdapter type exposes the following members.

Constructors

Name | Description
TextBoxXamlAdapter | Initializes a new instance of the TextBoxXamlAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportControl | Overridden. See ExportControl(XmlElement, ReportControl, IXamlContext). (Overrides BoxXamlAdapter..::.ExportControl(XmlElement, ReportControl, IXamlContext).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetBorder | Exports element's border to Xaml. (Inherited from BoxXamlAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ExportFilter | Gets XamlExportFilter which is уexport filter. (Inherited from XamlAdapter.)

See Also

TextBoxXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


TextBoxXamlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
TextBoxXamlAdapter Constructor
TextBoxXamlAdapter Class See Also Send Feedback
Initializes a new instance of the TextBoxXamlAdapter class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public TextBoxXamlAdapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextBoxXamlAdapter()

See Also

TextBoxXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


TextBoxXamlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxXamlAdapter Methods
TextBoxXamlAdapter Class See Also Send Feedback

The TextBoxXamlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportControl | Overridden. See ExportControl(XmlElement, ReportControl, IXamlContext). (Overrides BoxXamlAdapter..::.ExportControl(XmlElement, ReportControl, IXamlContext).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetBorder | Exports element's border to Xaml. (Inherited from BoxXamlAdapter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextBoxXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ExportControl Method

[image]

.NET ModelKit Suite ClassReference
TextBoxXamlAdapter..::.ExportControl Method
TextBoxXamlAdapter Class See Also Send Feedback
Overridden. See ExportControl(XmlElement, ReportControl, IXamlContext).

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override XmlElement ExportControl(
    XmlElement pageTag,
    ReportControl reportControl,
    IXamlContext context
)
Visual Basic (Declaration)
Public Overrides Function ExportControl ( _
    pageTag As XmlElement, _
    reportControl As ReportControl, _
    context As IXamlContext _
) As XmlElement
Visual C++
public:
virtual XmlElement^ ExportControl(
    XmlElement^ pageTag,
    ReportControl^ reportControl,
    IXamlContext^ context
) override

Parameters

pageTag
Type: System.Xml..::.XmlElement
reportControl
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Silverlight.Export..::.IXamlContext

See Also

TextBoxXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


TextBoxXamlAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
TextBoxXamlAdapter Properties
TextBoxXamlAdapter Class See Also Send Feedback

The TextBoxXamlAdapter type exposes the following members.

Properties

Name | Description
ExportFilter | Gets XamlExportFilter which is уexport filter. (Inherited from XamlAdapter.)

See Also

TextBoxXamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


XamlAdapter Class

[image]

.NET ModelKit Suite ClassReference
XamlAdapter Class
Members See Also Send Feedback
An abstract class. It is a basic class for creation of all export filters. The class is used for getting Xaml markup for all report elements.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract class XamlAdapter
Visual Basic (Declaration)
Public MustInherit Class XamlAdapter
Visual C++
public ref class XamlAdapter abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Export..::.XamlAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.BoxXamlAdapter
PerpetuumSoft.Reporting.Silverlight.Export..::.ShapeXamlAdapter

See Also

XamlAdapter Members
PerpetuumSoft.Reporting.Silverlight.Export Namespace


XamlAdapter Members

[image] [image]

.NET ModelKit Suite ClassReference
XamlAdapter Members
XamlAdapter Class Constructors Methods Fields Properties See Also Send Feedback

The XamlAdapter type exposes the following members.

Constructors

Name | Description
XamlAdapter | Initializes a new instance of the XamlAdapter class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportControl | Creates Xaml markup for the report element.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Accuracy | Gets min report element width and height at which it is exported to Xaml.

Properties

Name | Description
ExportFilter | Gets XamlExportFilter which is уexport filter.

See Also

XamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


XamlAdapter Constructor

[image]

.NET ModelKit Suite ClassReference
XamlAdapter Constructor
XamlAdapter Class See Also Send Feedback
Initializes a new instance of the XamlAdapter class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected XamlAdapter()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
XamlAdapter()

See Also

XamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


XamlAdapter Fields

[image] [image]

.NET ModelKit Suite ClassReference
XamlAdapter Fields
XamlAdapter Class See Also Send Feedback

The XamlAdapter type exposes the following members.

Fields

Name | Description
Accuracy | Gets min report element width and height at which it is exported to Xaml.

See Also

XamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


Accuracy Field

[image]

.NET ModelKit Suite ClassReference
XamlAdapter..::.Accuracy Field
XamlAdapter Class See Also Send Feedback
Gets min report element width and height at which it is exported to Xaml.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected const double Accuracy
Visual Basic (Declaration)
Protected Const Accuracy As Double
Visual C++
protected:
literal double Accuracy

See Also

XamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


XamlAdapter Methods

[image] [image]

.NET ModelKit Suite ClassReference
XamlAdapter Methods
XamlAdapter Class See Also Send Feedback

The XamlAdapter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportControl | Creates Xaml markup for the report element.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ExportControl Method

[image]

.NET ModelKit Suite ClassReference
XamlAdapter..::.ExportControl Method
XamlAdapter Class See Also Send Feedback
Creates Xaml markup for the report element.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public abstract XmlElement ExportControl(
    XmlElement pageTag,
    ReportControl reportControl,
    IXamlContext context
)
Visual Basic (Declaration)
Public MustOverride Function ExportControl ( _
    pageTag As XmlElement, _
    reportControl As ReportControl, _
    context As IXamlContext _
) As XmlElement
Visual C++
public:
virtual XmlElement^ ExportControl(
    XmlElement^ pageTag,
    ReportControl^ reportControl,
    IXamlContext^ context
) abstract

Parameters

pageTag
Type: System.Xml..::.XmlElement
reportControl
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
context
Type: PerpetuumSoft.Reporting.Silverlight.Export..::.IXamlContext

See Also

XamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


XamlAdapter Properties

[image] [image]

.NET ModelKit Suite ClassReference
XamlAdapter Properties
XamlAdapter Class See Also Send Feedback

The XamlAdapter type exposes the following members.

Properties

Name | Description
ExportFilter | Gets XamlExportFilter which is уexport filter.

See Also

XamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ExportFilter Property

[image]

.NET ModelKit Suite ClassReference
XamlAdapter..::.ExportFilter Property
XamlAdapter Class See Also Send Feedback
Gets XamlExportFilter which is уexport filter.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public XamlExportFilter ExportFilter { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExportFilter As XamlExportFilter
Visual C++
public:
property XamlExportFilter^ ExportFilter {
    XamlExportFilter^ get ();
}

See Also

XamlAdapter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


XamlExportFilter Class

[image]

.NET ModelKit Suite ClassReference
XamlExportFilter Class
Members See Also Send Feedback
The Xaml export filter.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public sealed class XamlExportFilter : ExportFilter
Visual Basic (Declaration)
Public NotInheritable Class XamlExportFilter _
    Inherits ExportFilter
Visual C++
public ref class XamlExportFilter sealed : public ExportFilter

Inheritance Hierarchy

[T:]
PerpetuumSoft.Reporting.Export..::.ExportFilter
PerpetuumSoft.Reporting.Silverlight.Export..::.XamlExportFilter

See Also

XamlExportFilter Members
PerpetuumSoft.Reporting.Silverlight.Export Namespace


XamlExportFilter Members

[image] [image]

.NET ModelKit Suite ClassReference
XamlExportFilter Members
XamlExportFilter Class Constructors Methods Properties See Also Send Feedback

The XamlExportFilter type exposes the following members.

Constructors

Name | Description
XamlExportFilter | Initializes a new instance of the XamlExportFilter class.

Methods

Name | Description
Export |
ExportPage | Exports a page to Xaml.
FindAdapterType | Finds adapter type for the set report element type.
GetAdapter | Gets adapter for the set report element.
GetAnchorControl | Gets bounds in which the element with hyperlink is located.
GetFactory | Overridden. See GetFactory()()().
GetImage | Gets report element as an image.
RegisterAdapter | Registers adapter for the export of report element to Xaml.

Properties

Name | Description
ServiceUri | Gets or sets service uri.

See Also

XamlExportFilter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


XamlExportFilter Constructor

[image]

.NET ModelKit Suite ClassReference
XamlExportFilter Constructor
XamlExportFilter Class See Also Send Feedback
Initializes a new instance of the XamlExportFilter class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public XamlExportFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XamlExportFilter()

See Also

XamlExportFilter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


XamlExportFilter Methods

[image] [image]

.NET ModelKit Suite ClassReference
XamlExportFilter Methods
XamlExportFilter Class See Also Send Feedback

The XamlExportFilter type exposes the following members.

Methods

Name | Description
Export |
ExportPage | Exports a page to Xaml.
FindAdapterType | Finds adapter type for the set report element type.
GetAdapter | Gets adapter for the set report element.
GetAnchorControl | Gets bounds in which the element with hyperlink is located.
GetFactory | Overridden. See GetFactory()()().
GetImage | Gets report element as an image.
RegisterAdapter | Registers adapter for the export of report element to Xaml.

See Also

XamlExportFilter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


Export Method

[image]

.NET ModelKit Suite ClassReference
XamlExportFilter..::.Export Method
XamlExportFilter Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Silverlight.Export.XamlExportFilter.Export(,System.IO.Stream,PerpetuumSoft.Reporting.Silverlight.Export.IXamlContext)]

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void Export(
    [T:] document,
    Stream stream,
    IXamlContext xamlContext
)
Visual Basic (Declaration)
Public Sub Export ( _
    document As [T:], _
    stream As Stream, _
    xamlContext As IXamlContext _
)
Visual C++
public:
void Export(
    [T:]^ document,
    Stream^ stream,
    IXamlContext^ xamlContext
)

Parameters

document
Type: [T:]
stream
Type: System.IO..::.Stream
xamlContext
Type: PerpetuumSoft.Reporting.Silverlight.Export..::.IXamlContext

See Also

XamlExportFilter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ExportPage Method

[image]

.NET ModelKit Suite ClassReference
XamlExportFilter..::.ExportPage Method
XamlExportFilter Class See Also Send Feedback
Exports a page to Xaml.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void ExportPage(
    Page page,
    Stream stream,
    IXamlContext context
)
Visual Basic (Declaration)
Public Sub ExportPage ( _
    page As Page, _
    stream As Stream, _
    context As IXamlContext _
)
Visual C++
public:
void ExportPage(
    Page^ page,
    Stream^ stream,
    IXamlContext^ context
)

Parameters

page
Type: PerpetuumSoft.Reporting.DOM..::.Page
stream
Type: System.IO..::.Stream
context
Type: PerpetuumSoft.Reporting.Silverlight.Export..::.IXamlContext

See Also

XamlExportFilter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


FindAdapterType Method

[image]

.NET ModelKit Suite ClassReference
XamlExportFilter..::.FindAdapterType Method
XamlExportFilter Class See Also Send Feedback
Finds adapter type for the set report element type.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static Type FindAdapterType(
    Type type
)
Visual Basic (Declaration)
Public Shared Function FindAdapterType ( _
    type As Type _
) As Type
Visual C++
public:
static Type^ FindAdapterType(
    Type^ type
)

Parameters

type
Type: System..::.Type

See Also

XamlExportFilter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


GetAdapter Method

[image]

.NET ModelKit Suite ClassReference
XamlExportFilter..::.GetAdapter Method
XamlExportFilter Class See Also Send Feedback
Gets adapter for the set report element.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public XamlAdapter GetAdapter(
    ReportControl control
)
Visual Basic (Declaration)
Public Function GetAdapter ( _
    control As ReportControl _
) As XamlAdapter
Visual C++
public:
XamlAdapter^ GetAdapter(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

XamlExportFilter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


GetAnchorControl Method

[image]

.NET ModelKit Suite ClassReference
XamlExportFilter..::.GetAnchorControl Method
XamlExportFilter Class See Also Send Feedback
Gets bounds in which the element with hyperlink is located.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string GetAnchorControl(
    string link
)
Visual Basic (Declaration)
Public Function GetAnchorControl ( _
    link As String _
) As String
Visual C++
public:
String^ GetAnchorControl(
    String^ link
)

Parameters

link
Type: System..::.String

See Also

XamlExportFilter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


GetFactory Method

[image]

.NET ModelKit Suite ClassReference
XamlExportFilter..::.GetFactory Method
XamlExportFilter Class See Also Send Feedback
Overridden. See GetFactory()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public virtual ExportFilterFactory GetFactory()
Visual Basic (Declaration)
Public Overridable Function GetFactory As ExportFilterFactory
Visual C++
public:
virtual ExportFilterFactory^ GetFactory()

See Also

XamlExportFilter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


GetImage Method

[image]

.NET ModelKit Suite ClassReference
XamlExportFilter..::.GetImage Method
XamlExportFilter Class See Also Send Feedback
Gets report element as an image.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public byte[] GetImage(
    ReportControl control,
    int dpi
)
Visual Basic (Declaration)
Public Function GetImage ( _
    control As ReportControl, _
    dpi As Integer _
) As Byte()
Visual C++
public:
array<unsigned char>^ GetImage(
    ReportControl^ control,
    int dpi
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl
dpi
Type: System..::.Int32

See Also

XamlExportFilter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


RegisterAdapter Method

[image]

.NET ModelKit Suite ClassReference
XamlExportFilter..::.RegisterAdapter Method
XamlExportFilter Class See Also Send Feedback
Registers adapter for the export of report element to Xaml.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static void RegisterAdapter(
    Type controlType,
    Type adapterType
)
Visual Basic (Declaration)
Public Shared Sub RegisterAdapter ( _
    controlType As Type, _
    adapterType As Type _
)
Visual C++
public:
static void RegisterAdapter(
    Type^ controlType,
    Type^ adapterType
)

Parameters

controlType
Type: System..::.Type
adapterType
Type: System..::.Type

See Also

XamlExportFilter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


XamlExportFilter Properties

[image] [image]

.NET ModelKit Suite ClassReference
XamlExportFilter Properties
XamlExportFilter Class See Also Send Feedback

The XamlExportFilter type exposes the following members.

Properties

Name | Description
ServiceUri | Gets or sets service uri.

See Also

XamlExportFilter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


ServiceUri Property

[image]

.NET ModelKit Suite ClassReference
XamlExportFilter..::.ServiceUri Property
XamlExportFilter Class See Also Send Feedback
Gets or sets service uri.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string ServiceUri { get; set; }
Visual Basic (Declaration)
Public Property ServiceUri As String
Visual C++
public:
property String^ ServiceUri {
    String^ get ();
    void set (String^ value);
}

See Also

XamlExportFilter Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


XamlExportFilterFactory Class

[image]

.NET ModelKit Suite ClassReference
XamlExportFilterFactory Class
Members See Also Send Feedback
The Xaml export filter factory.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public sealed class XamlExportFilterFactory : ExportFilterFactory
Visual Basic (Declaration)
Public NotInheritable Class XamlExportFilterFactory _
    Inherits ExportFilterFactory
Visual C++
public ref class XamlExportFilterFactory sealed : public ExportFilterFactory

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Export..::.ExportFilterFactory
PerpetuumSoft.Reporting.Silverlight.Export..::.XamlExportFilterFactory

See Also

XamlExportFilterFactory Members
PerpetuumSoft.Reporting.Silverlight.Export Namespace


XamlExportFilterFactory Members

[image] [image]

.NET ModelKit Suite ClassReference
XamlExportFilterFactory Members
XamlExportFilterFactory Class Methods Properties See Also Send Feedback

The XamlExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Overridden. See CreateFilter()()(). (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Overridden. See GetFilterFileExtension()()(). (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Overridden. See GetFilterFormat()()(). (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Factory | Gets XamlExportFilterFactory.

See Also

XamlExportFilterFactory Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


XamlExportFilterFactory Methods

[image] [image]

.NET ModelKit Suite ClassReference
XamlExportFilterFactory Methods
XamlExportFilterFactory Class See Also Send Feedback

The XamlExportFilterFactory type exposes the following members.

Methods

Name | Description
CreateFilter | Overridden. See CreateFilter()()(). (Overrides ExportFilterFactory..::.CreateFilter()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFilterFileExtension | Overridden. See GetFilterFileExtension()()(). (Overrides ExportFilterFactory..::.GetFilterFileExtension()()().)
GetFilterFormat | Overridden. See GetFilterFormat()()(). (Overrides ExportFilterFactory..::.GetFilterFormat()()().)
GetFilterName | Returns the name of the export filter associated with the factory. (Inherited from ExportFilterFactory.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XamlExportFilterFactory Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


CreateFilter Method

[image]

.NET ModelKit Suite ClassReference
XamlExportFilterFactory..::.CreateFilter Method
XamlExportFilterFactory Class See Also Send Feedback
Overridden. See CreateFilter()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override ExportFilter CreateFilter()
Visual Basic (Declaration)
Public Overrides Function CreateFilter As ExportFilter
Visual C++
public:
virtual ExportFilter^ CreateFilter() override

See Also

XamlExportFilterFactory Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


GetFilterFileExtension Method

[image]

.NET ModelKit Suite ClassReference
XamlExportFilterFactory..::.GetFilterFileExtension Method
XamlExportFilterFactory Class See Also Send Feedback
Overridden. See GetFilterFileExtension()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override string GetFilterFileExtension()
Visual Basic (Declaration)
Public Overrides Function GetFilterFileExtension As String
Visual C++
public:
virtual String^ GetFilterFileExtension() override

See Also

XamlExportFilterFactory Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


GetFilterFormat Method

[image]

.NET ModelKit Suite ClassReference
XamlExportFilterFactory..::.GetFilterFormat Method
XamlExportFilterFactory Class See Also Send Feedback
Overridden. See GetFilterFormat()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override string GetFilterFormat()
Visual Basic (Declaration)
Public Overrides Function GetFilterFormat As String
Visual C++
public:
virtual String^ GetFilterFormat() override

See Also

XamlExportFilterFactory Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


XamlExportFilterFactory Properties

[image] [image]

.NET ModelKit Suite ClassReference
XamlExportFilterFactory Properties
XamlExportFilterFactory Class See Also Send Feedback

The XamlExportFilterFactory type exposes the following members.

Properties

Name | Description
Factory | Gets XamlExportFilterFactory.

See Also

XamlExportFilterFactory Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


Factory Property

[image]

.NET ModelKit Suite ClassReference
XamlExportFilterFactory..::.Factory Property
XamlExportFilterFactory Class See Also Send Feedback
Gets XamlExportFilterFactory.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static XamlExportFilterFactory Factory { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Factory As XamlExportFilterFactory
Visual C++
public:
static property XamlExportFilterFactory^ Factory {
    XamlExportFilterFactory^ get ();
}

See Also

XamlExportFilterFactory Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


XamlMediaShapes Class

[image]

.NET ModelKit Suite ClassReference
XamlMediaShapes Class
Members See Also Send Feedback
A class for working with various adapters for Shapes. Contains methods for registration of new adapters declared by a user.

Namespace: PerpetuumSoft.Reporting.Silverlight.Export
Assembly: PerpetuumSoft.Reporting.Silverlight.Export (in PerpetuumSoft.Reporting.Silverlight.Export.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class XamlMediaShapes
Visual Basic (Declaration)
Public Class XamlMediaShapes
Visual C++
public ref class XamlMediaShapes

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Export..::.XamlMediaShapes

See Also

XamlMediaShapes Members
PerpetuumSoft.Reporting.Silverlight.Export Namespace


XamlMediaShapes Members

[image] [image]

.NET ModelKit Suite ClassReference
XamlMediaShapes Members
XamlMediaShapes Class Methods See Also Send Feedback

The XamlMediaShapes type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XamlMediaShapes Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


XamlMediaShapes Methods

[image] [image]

.NET ModelKit Suite ClassReference
XamlMediaShapes Methods
XamlMediaShapes Class See Also Send Feedback

The XamlMediaShapes type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XamlMediaShapes Class
PerpetuumSoft.Reporting.Silverlight.Export Namespace


PerpetuumSoft.Reporting.Silverlight.Server Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Silverlight.Server Namespace
Send Feedback
The PerpetuumSoft.Reporting.Silverlight.Server namespace contains classes which is used for report representation service.

Classes

Class | Description
DocumentInfo | Represents document data.
ErrorMessage | Encapsulates data about errors which are got by server.
ExceptionDetailBase | Represents a basic class for all exceptions wrappers generated by server.
FontsProvider | Represents a set of methods for work with fonts.
NoCachedDocumentExceptionDetail | Represents an exception wrapper generated when document is not found in cash.
PageInfo | Represents report page metadata.
ReportServiceBase | Represents service for report generation and getting data about generated report.
SearchResult | Represents text search results.

Structures

Structure | Description
FindOptions | Represents text search mode data.

Interfaces

Interface | Description
IReportService | Exposes a method for getting report.
IReportServiceResources | Exposes a method for report resources getting.

Enumerations

Enumeration | Description
Direction | Sets direction.
SearchDirection | Sets search direction.


Direction Enumeration

[image]

.NET ModelKit Suite ClassReference
Direction Enumeration
See Also Send Feedback
Sets direction.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public enum Direction
Visual Basic (Declaration)
Public Enumeration Direction
Visual C++
public enum class Direction

Members

Member name | Description
Forward | Sets forward direction.
Backward | Sets backward direction.

See Also

PerpetuumSoft.Reporting.Silverlight.Server Namespace


DocumentInfo Class

[image]

.NET ModelKit Suite ClassReference
DocumentInfo Class
Members See Also Send Feedback
Represents document data.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class DocumentInfo
Visual Basic (Declaration)
Public Class DocumentInfo
Visual C++
public ref class DocumentInfo

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Server..::.DocumentInfo

See Also

DocumentInfo Members
PerpetuumSoft.Reporting.Silverlight.Server Namespace


DocumentInfo Members

[image] [image]

.NET ModelKit Suite ClassReference
DocumentInfo Members
DocumentInfo Class Constructors Methods Properties See Also Send Feedback

The DocumentInfo type exposes the following members.

Constructors

Name | Description
DocumentInfo | Initializes a new instance of the DocumentInfo class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Title | Gets or sets document title.

See Also

DocumentInfo Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


DocumentInfo Constructor

[image]

.NET ModelKit Suite ClassReference
DocumentInfo Constructor
DocumentInfo Class See Also Send Feedback
Initializes a new instance of the DocumentInfo class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public DocumentInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentInfo()

See Also

DocumentInfo Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


DocumentInfo Methods

[image] [image]

.NET ModelKit Suite ClassReference
DocumentInfo Methods
DocumentInfo Class See Also Send Feedback

The DocumentInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentInfo Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


DocumentInfo Properties

[image] [image]

.NET ModelKit Suite ClassReference
DocumentInfo Properties
DocumentInfo Class See Also Send Feedback

The DocumentInfo type exposes the following members.

Properties

Name | Description
Title | Gets or sets document title.

See Also

DocumentInfo Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


Title Property

[image]

.NET ModelKit Suite ClassReference
DocumentInfo..::.Title Property
DocumentInfo Class See Also Send Feedback
Gets or sets document title.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

DocumentInfo Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ErrorMessage Class

[image]

.NET ModelKit Suite ClassReference
ErrorMessage Class
Members See Also Send Feedback
Encapsulates data about errors which are got by server.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ErrorMessage
Visual Basic (Declaration)
Public Class ErrorMessage
Visual C++
public ref class ErrorMessage

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Server..::.ErrorMessage

See Also

ErrorMessage Members
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ErrorMessage Members

[image] [image]

.NET ModelKit Suite ClassReference
ErrorMessage Members
ErrorMessage Class Constructors Methods Properties See Also Send Feedback

The ErrorMessage type exposes the following members.

Constructors

Name | Description
ErrorMessage | Initializes a new instance of the ErrorMessage class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Message | Gets or sets error message.

See Also

ErrorMessage Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ErrorMessage Constructor

[image]

.NET ModelKit Suite ClassReference
ErrorMessage Constructor
ErrorMessage Class See Also Send Feedback
Initializes a new instance of the ErrorMessage class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ErrorMessage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ErrorMessage()

See Also

ErrorMessage Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ErrorMessage Methods

[image] [image]

.NET ModelKit Suite ClassReference
ErrorMessage Methods
ErrorMessage Class See Also Send Feedback

The ErrorMessage type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ErrorMessage Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ErrorMessage Properties

[image] [image]

.NET ModelKit Suite ClassReference
ErrorMessage Properties
ErrorMessage Class See Also Send Feedback

The ErrorMessage type exposes the following members.

Properties

Name | Description
Message | Gets or sets error message.

See Also

ErrorMessage Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


Message Property

[image]

.NET ModelKit Suite ClassReference
ErrorMessage..::.Message Property
ErrorMessage Class See Also Send Feedback
Gets or sets error message.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string Message { get; set; }
Visual Basic (Declaration)
Public Property Message As String
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

See Also

ErrorMessage Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ExceptionDetailBase Class

[image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase Class
Members See Also Send Feedback
Represents a basic class for all exceptions wrappers generated by server.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ExceptionDetailBase
Visual Basic (Declaration)
Public Class ExceptionDetailBase
Visual C++
public ref class ExceptionDetailBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Server..::.ExceptionDetailBase
PerpetuumSoft.Reporting.Silverlight.Server..::.NoCachedDocumentExceptionDetail

See Also

ExceptionDetailBase Members
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ExceptionDetailBase Members

[image] [image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase Members
ExceptionDetailBase Class Constructors Methods Properties See Also Send Feedback

The ExceptionDetailBase type exposes the following members.

Constructors

Name | Description
ExceptionDetailBase | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Exception | Gets or sets an exception generated by server.
InnerException | Gets or sets inner exception wrapper.
Message | Gets or sets error message.

See Also

ExceptionDetailBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ExceptionDetailBase Constructor

[image] [image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase Constructor
ExceptionDetailBase Class See Also Send Feedback

Overload List

Name | Description
ExceptionDetailBase(Exception) | Initializes a new instance of the ExceptionDetailBase class.
ExceptionDetailBase(Exception, ExceptionDetailBase) | Initializes a new instance of the ExceptionDetailBase class.

See Also

ExceptionDetailBase Class
ExceptionDetailBase Members
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ExceptionDetailBase Constructor (Exception)

[image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase Constructor (Exception)
ExceptionDetailBase Class See Also Send Feedback
Initializes a new instance of the ExceptionDetailBase class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ExceptionDetailBase(
    Exception exception
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception _
)
Visual C++
public:
ExceptionDetailBase(
    Exception^ exception
)

Parameters

exception
Type: System..::.Exception

See Also

ExceptionDetailBase Class
ExceptionDetailBase Overload
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ExceptionDetailBase Constructor (Exception, ExceptionDetailBase)

[image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase Constructor (Exception, ExceptionDetailBase)
ExceptionDetailBase Class See Also Send Feedback
Initializes a new instance of the ExceptionDetailBase class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ExceptionDetailBase(
    Exception exception,
    ExceptionDetailBase innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception, _
    innerException As ExceptionDetailBase _
)
Visual C++
public:
ExceptionDetailBase(
    Exception^ exception,
    ExceptionDetailBase^ innerException
)

Parameters

exception
Type: System..::.Exception
innerException
Type: PerpetuumSoft.Reporting.Silverlight.Server..::.ExceptionDetailBase

See Also

ExceptionDetailBase Class
ExceptionDetailBase Overload
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ExceptionDetailBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase Methods
ExceptionDetailBase Class See Also Send Feedback

The ExceptionDetailBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExceptionDetailBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ExceptionDetailBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase Properties
ExceptionDetailBase Class See Also Send Feedback

The ExceptionDetailBase type exposes the following members.

Properties

Name | Description
Exception | Gets or sets an exception generated by server.
InnerException | Gets or sets inner exception wrapper.
Message | Gets or sets error message.

See Also

ExceptionDetailBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


Exception Property

[image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase..::.Exception Property
ExceptionDetailBase Class See Also Send Feedback
Gets or sets an exception generated by server.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Exception Exception { get; private set; }
Visual Basic (Declaration)
Public Property Exception As Exception
Visual C++
public:
property Exception^ Exception {
    Exception^ get ();
    void set (Exception^ value);
}

See Also

ExceptionDetailBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


InnerException Property

[image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase..::.InnerException Property
ExceptionDetailBase Class See Also Send Feedback
Gets or sets inner exception wrapper.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ExceptionDetailBase InnerException { get; set; }
Visual Basic (Declaration)
Public Property InnerException As ExceptionDetailBase
Visual C++
public:
property ExceptionDetailBase^ InnerException {
    ExceptionDetailBase^ get ();
    void set (ExceptionDetailBase^ value);
}

See Also

ExceptionDetailBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


Message Property

[image]

.NET ModelKit Suite ClassReference
ExceptionDetailBase..::.Message Property
ExceptionDetailBase Class See Also Send Feedback
Gets or sets error message.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string Message { get; private set; }
Visual Basic (Declaration)
Public Property Message As String
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

See Also

ExceptionDetailBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


FindOptions Structure

[image]

.NET ModelKit Suite ClassReference
FindOptions Structure
Members See Also Send Feedback
Represents text search mode data.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public struct FindOptions
Visual Basic (Declaration)
Public Structure FindOptions
Visual C++
public value class FindOptions

See Also

FindOptions Members
PerpetuumSoft.Reporting.Silverlight.Server Namespace


FindOptions Members

[image] [image]

.NET ModelKit Suite ClassReference
FindOptions Members
FindOptions Structure Methods Properties See Also Send Feedback

The FindOptions type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Direction | Gets or sets SearchDirection which defines search direction.
FindText | Gets or sets the required text.
StartLocation | Gets or sets SearchResult which sets where to begin text search from.

See Also

FindOptions Structure
PerpetuumSoft.Reporting.Silverlight.Server Namespace


FindOptions Methods

[image] [image]

.NET ModelKit Suite ClassReference
FindOptions Methods
FindOptions Structure See Also Send Feedback

The FindOptions type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

FindOptions Structure
PerpetuumSoft.Reporting.Silverlight.Server Namespace


FindOptions Properties

[image] [image]

.NET ModelKit Suite ClassReference
FindOptions Properties
FindOptions Structure See Also Send Feedback

The FindOptions type exposes the following members.

Properties

Name | Description
Direction | Gets or sets SearchDirection which defines search direction.
FindText | Gets or sets the required text.
StartLocation | Gets or sets SearchResult which sets where to begin text search from.

See Also

FindOptions Structure
PerpetuumSoft.Reporting.Silverlight.Server Namespace


Direction Property

[image]

.NET ModelKit Suite ClassReference
FindOptions..::.Direction Property
FindOptions Structure See Also Send Feedback
Gets or sets SearchDirection which defines search direction.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public SearchDirection Direction { get; set; }
Visual Basic (Declaration)
Public Property Direction As SearchDirection
Visual C++
public:
property SearchDirection Direction {
    SearchDirection get ();
    void set (SearchDirection value);
}

See Also

FindOptions Structure
PerpetuumSoft.Reporting.Silverlight.Server Namespace


FindText Property

[image]

.NET ModelKit Suite ClassReference
FindOptions..::.FindText Property
FindOptions Structure See Also Send Feedback
Gets or sets the required text.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string FindText { get; set; }
Visual Basic (Declaration)
Public Property FindText As String
Visual C++
public:
property String^ FindText {
    String^ get ();
    void set (String^ value);
}

See Also

FindOptions Structure
PerpetuumSoft.Reporting.Silverlight.Server Namespace


StartLocation Property

[image]

.NET ModelKit Suite ClassReference
FindOptions..::.StartLocation Property
FindOptions Structure See Also Send Feedback
Gets or sets SearchResult which sets where to begin text search from.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public SearchResult StartLocation { get; set; }
Visual Basic (Declaration)
Public Property StartLocation As SearchResult
Visual C++
public:
property SearchResult^ StartLocation {
    SearchResult^ get ();
    void set (SearchResult^ value);
}

See Also

FindOptions Structure
PerpetuumSoft.Reporting.Silverlight.Server Namespace


FontsProvider Class

[image]

.NET ModelKit Suite ClassReference
FontsProvider Class
Members See Also Send Feedback
Represents a set of methods for work with fonts.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class FontsProvider
Visual Basic (Declaration)
Public Class FontsProvider
Visual C++
public ref class FontsProvider

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Server..::.FontsProvider

See Also

FontsProvider Members
PerpetuumSoft.Reporting.Silverlight.Server Namespace


FontsProvider Members

[image] [image]

.NET ModelKit Suite ClassReference
FontsProvider Members
FontsProvider Class Constructors Methods See Also Send Feedback

The FontsProvider type exposes the following members.

Constructors

Name | Description
FontsProvider | Initializes a new instance of the FontsProvider class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFontFamilyKey | Returns font name by family name and its weight.
GetFontSource | Writes a font definition by name to stream.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultFont | Defines if font with the set name is default font.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontsProvider Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


FontsProvider Constructor

[image]

.NET ModelKit Suite ClassReference
FontsProvider Constructor
FontsProvider Class See Also Send Feedback
Initializes a new instance of the FontsProvider class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public FontsProvider()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FontsProvider()

See Also

FontsProvider Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


FontsProvider Methods

[image] [image]

.NET ModelKit Suite ClassReference
FontsProvider Methods
FontsProvider Class See Also Send Feedback

The FontsProvider type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetFontFamilyKey | Returns font name by family name and its weight.
GetFontSource | Writes a font definition by name to stream.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultFont | Defines if font with the set name is default font.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontsProvider Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


GetFontFamilyKey Method

[image]

.NET ModelKit Suite ClassReference
FontsProvider..::.GetFontFamilyKey Method
FontsProvider Class See Also Send Feedback
Returns font name by family name and its weight.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static string GetFontFamilyKey(
    string familyName,
    FontWeight fontWeight
)
Visual Basic (Declaration)
Public Shared Function GetFontFamilyKey ( _
    familyName As String, _
    fontWeight As FontWeight _
) As String
Visual C++
public:
static String^ GetFontFamilyKey(
    String^ familyName,
    FontWeight fontWeight
)

Parameters

familyName
Type: System..::.String
fontWeight
Type: System.Windows..::.FontWeight

See Also

FontsProvider Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


GetFontSource Method

[image]

.NET ModelKit Suite ClassReference
FontsProvider..::.GetFontSource Method
FontsProvider Class See Also Send Feedback
Writes a font definition by name to stream.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void GetFontSource(
    string fontFamilyKey,
    Stream outStream
)
Visual Basic (Declaration)
Public Sub GetFontSource ( _
    fontFamilyKey As String, _
    outStream As Stream _
)
Visual C++
public:
void GetFontSource(
    String^ fontFamilyKey,
    Stream^ outStream
)

Parameters

fontFamilyKey
Type: System..::.String
outStream
Type: System.IO..::.Stream

See Also

FontsProvider Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


IsDefaultFont Method

[image]

.NET ModelKit Suite ClassReference
FontsProvider..::.IsDefaultFont Method
FontsProvider Class See Also Send Feedback
Defines if font with the set name is default font.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static bool IsDefaultFont(
    string fontFamily
)
Visual Basic (Declaration)
Public Shared Function IsDefaultFont ( _
    fontFamily As String _
) As Boolean
Visual C++
public:
static bool IsDefaultFont(
    String^ fontFamily
)

Parameters

fontFamily
Type: System..::.String

See Also

FontsProvider Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


IReportService Interface

[image]

.NET ModelKit Suite ClassReference
IReportService Interface
Members See Also Send Feedback
Exposes a method for getting report.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public interface IReportService
Visual Basic (Declaration)
Public Interface IReportService
Visual C++
public interface class IReportService

See Also

IReportService Members
PerpetuumSoft.Reporting.Silverlight.Server Namespace


IReportService Members

[image] [image]

.NET ModelKit Suite ClassReference
IReportService Members
IReportService Interface Methods See Also Send Feedback

The IReportService type exposes the following members.

Methods

Name | Description
Find | Returns search results in the document set by identificator.
GetDocumentInfo | Returns report metadata.
GetPageInfo | Returns page metadata by report identificator and page number.
Init | It is invoked for data initialization.
Render | Generates the report which was set by name and gets identificator of the generated and saved in cash report.

See Also

IReportService Interface
PerpetuumSoft.Reporting.Silverlight.Server Namespace


IReportService Methods

[image] [image]

.NET ModelKit Suite ClassReference
IReportService Methods
IReportService Interface See Also Send Feedback

The IReportService type exposes the following members.

Methods

Name | Description
Find | Returns search results in the document set by identificator.
GetDocumentInfo | Returns report metadata.
GetPageInfo | Returns page metadata by report identificator and page number.
Init | It is invoked for data initialization.
Render | Generates the report which was set by name and gets identificator of the generated and saved in cash report.

See Also

IReportService Interface
PerpetuumSoft.Reporting.Silverlight.Server Namespace


Find Method

[image]

.NET ModelKit Suite ClassReference
IReportService..::.Find Method
IReportService Interface See Also Send Feedback
Returns search results in the document set by identificator.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
SearchResult Find(
    string id,
    FindOptions findOptions,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Function Find ( _
    id As String, _
    findOptions As FindOptions, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As SearchResult
Visual C++
SearchResult^ Find(
    String^ id,
    FindOptions findOptions,
    [OutAttribute] ExceptionDetailBase^% ReportError
)

Parameters

id
Type: System..::.String
findOptions
Type: PerpetuumSoft.Reporting.Silverlight.Server..::.FindOptions
ReportError
Type: PerpetuumSoft.Reporting.Silverlight.Server..::.ExceptionDetailBase %

See Also

IReportService Interface
PerpetuumSoft.Reporting.Silverlight.Server Namespace


GetDocumentInfo Method

[image]

.NET ModelKit Suite ClassReference
IReportService..::.GetDocumentInfo Method
IReportService Interface See Also Send Feedback
Returns report metadata.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
DocumentInfo GetDocumentInfo(
    string id,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Function GetDocumentInfo ( _
    id As String, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As DocumentInfo
Visual C++
DocumentInfo^ GetDocumentInfo(
    String^ id,
    [OutAttribute] ExceptionDetailBase^% ReportError
)

Parameters

id
Type: System..::.String
ReportError
Type: PerpetuumSoft.Reporting.Silverlight.Server..::.ExceptionDetailBase %

See Also

IReportService Interface
PerpetuumSoft.Reporting.Silverlight.Server Namespace


GetPageInfo Method

[image]

.NET ModelKit Suite ClassReference
IReportService..::.GetPageInfo Method
IReportService Interface See Also Send Feedback
Returns page metadata by report identificator and page number.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
PageInfo GetPageInfo(
    string id,
    int pageNumber,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Function GetPageInfo ( _
    id As String, _
    pageNumber As Integer, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As PageInfo
Visual C++
PageInfo^ GetPageInfo(
    String^ id,
    int pageNumber,
    [OutAttribute] ExceptionDetailBase^% ReportError
)

Parameters

id
Type: System..::.String
pageNumber
Type: System..::.Int32
ReportError
Type: PerpetuumSoft.Reporting.Silverlight.Server..::.ExceptionDetailBase %

See Also

IReportService Interface
PerpetuumSoft.Reporting.Silverlight.Server Namespace


Init Method

[image]

.NET ModelKit Suite ClassReference
IReportService..::.Init Method
IReportService Interface See Also Send Feedback
It is invoked for data initialization.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
void Init()
Visual Basic (Declaration)
Sub Init
Visual C++
void Init()

See Also

IReportService Interface
PerpetuumSoft.Reporting.Silverlight.Server Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
IReportService..::.Render Method
IReportService Interface See Also Send Feedback
Generates the report which was set by name and gets identificator of the generated and saved in cash report.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
string Render(
    IDictionary<string, Object> parameters,
    string reportName,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Function Render ( _
    parameters As IDictionary(Of String, Object), _
    reportName As String, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As String
Visual C++
String^ Render(
    IDictionary<String^, Object^>^ parameters,
    String^ reportName,
    [OutAttribute] ExceptionDetailBase^% ReportError
)

Parameters

parameters
Type: System.Collections.Generic..::.IDictionary <(Of <( String, Object >)>)
reportName
Type: System..::.String
ReportError
Type: PerpetuumSoft.Reporting.Silverlight.Server..::.ExceptionDetailBase %

See Also

IReportService Interface
PerpetuumSoft.Reporting.Silverlight.Server Namespace


IReportServiceResources Interface

[image]

.NET ModelKit Suite ClassReference
IReportServiceResources Interface
Members See Also Send Feedback
Exposes a method for report resources getting.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public interface IReportServiceResources
Visual Basic (Declaration)
Public Interface IReportServiceResources
Visual C++
public interface class IReportServiceResources

See Also

IReportServiceResources Members
PerpetuumSoft.Reporting.Silverlight.Server Namespace


IReportServiceResources Members

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceResources Members
IReportServiceResources Interface Methods See Also Send Feedback

The IReportServiceResources type exposes the following members.

Methods

Name | Description
Export | Returns result of document export to the specified format.
GetFont | Returns font definition by font name.
GetImage | Returns image from document by the set control identificator and the page where it is located.
GetResource | Returns a resource by set culture.

See Also

IReportServiceResources Interface
PerpetuumSoft.Reporting.Silverlight.Server Namespace


IReportServiceResources Methods

[image] [image]

.NET ModelKit Suite ClassReference
IReportServiceResources Methods
IReportServiceResources Interface See Also Send Feedback

The IReportServiceResources type exposes the following members.

Methods

Name | Description
Export | Returns result of document export to the specified format.
GetFont | Returns font definition by font name.
GetImage | Returns image from document by the set control identificator and the page where it is located.
GetResource | Returns a resource by set culture.

See Also

IReportServiceResources Interface
PerpetuumSoft.Reporting.Silverlight.Server Namespace


Export Method

[image]

.NET ModelKit Suite ClassReference
IReportServiceResources..::.Export Method
IReportServiceResources Interface See Also Send Feedback
Returns result of document export to the specified format.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
Stream Export(
    string id,
    string format
)
Visual Basic (Declaration)
Function Export ( _
    id As String, _
    format As String _
) As Stream
Visual C++
Stream^ Export(
    String^ id,
    String^ format
)

Parameters

id
Type: System..::.String
format
Type: System..::.String

See Also

IReportServiceResources Interface
PerpetuumSoft.Reporting.Silverlight.Server Namespace


GetFont Method

[image]

.NET ModelKit Suite ClassReference
IReportServiceResources..::.GetFont Method
IReportServiceResources Interface See Also Send Feedback
Returns font definition by font name.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
Stream GetFont(
    string resourceKey
)
Visual Basic (Declaration)
Function GetFont ( _
    resourceKey As String _
) As Stream
Visual C++
Stream^ GetFont(
    String^ resourceKey
)

Parameters

resourceKey
Type: System..::.String

See Also

IReportServiceResources Interface
PerpetuumSoft.Reporting.Silverlight.Server Namespace


GetImage Method

[image]

.NET ModelKit Suite ClassReference
IReportServiceResources..::.GetImage Method
IReportServiceResources Interface See Also Send Feedback
Returns image from document by the set control identificator and the page where it is located.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
Stream GetImage(
    string id,
    int pageIndex,
    int controlIndex
)
Visual Basic (Declaration)
Function GetImage ( _
    id As String, _
    pageIndex As Integer, _
    controlIndex As Integer _
) As Stream
Visual C++
Stream^ GetImage(
    String^ id,
    int pageIndex,
    int controlIndex
)

Parameters

id
Type: System..::.String
pageIndex
Type: System..::.Int32
controlIndex
Type: System..::.Int32

See Also

IReportServiceResources Interface
PerpetuumSoft.Reporting.Silverlight.Server Namespace


GetResource Method

[image]

.NET ModelKit Suite ClassReference
IReportServiceResources..::.GetResource Method
IReportServiceResources Interface See Also Send Feedback
Returns a resource by set culture.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
Stream GetResource(
    string culture
)
Visual Basic (Declaration)
Function GetResource ( _
    culture As String _
) As Stream
Visual C++
Stream^ GetResource(
    String^ culture
)

Parameters

culture
Type: System..::.String

See Also

IReportServiceResources Interface
PerpetuumSoft.Reporting.Silverlight.Server Namespace


NoCachedDocumentExceptionDetail Class

[image]

.NET ModelKit Suite ClassReference
NoCachedDocumentExceptionDetail Class
Members See Also Send Feedback
Represents an exception wrapper generated when document is not found in cash.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class NoCachedDocumentExceptionDetail : ExceptionDetailBase
Visual Basic (Declaration)
Public Class NoCachedDocumentExceptionDetail _
    Inherits ExceptionDetailBase
Visual C++
public ref class NoCachedDocumentExceptionDetail : public ExceptionDetailBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Server..::.ExceptionDetailBase
PerpetuumSoft.Reporting.Silverlight.Server..::.NoCachedDocumentExceptionDetail

See Also

NoCachedDocumentExceptionDetail Members
PerpetuumSoft.Reporting.Silverlight.Server Namespace


NoCachedDocumentExceptionDetail Members

[image] [image]

.NET ModelKit Suite ClassReference
NoCachedDocumentExceptionDetail Members
NoCachedDocumentExceptionDetail Class Constructors Methods Properties See Also Send Feedback

The NoCachedDocumentExceptionDetail type exposes the following members.

Constructors

Name | Description
NoCachedDocumentExceptionDetail | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Exception | Gets or sets an exception generated by server. (Inherited from ExceptionDetailBase.)
InnerException | Gets or sets inner exception wrapper. (Inherited from ExceptionDetailBase.)
Message | Gets or sets error message. (Inherited from ExceptionDetailBase.)

See Also

NoCachedDocumentExceptionDetail Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


NoCachedDocumentExceptionDetail Constructor

[image] [image]

.NET ModelKit Suite ClassReference
NoCachedDocumentExceptionDetail Constructor
NoCachedDocumentExceptionDetail Class See Also Send Feedback

Overload List

Name | Description
NoCachedDocumentExceptionDetail(Exception) | Initializes a new instance of the NoCachedDocumentExceptionDetail class.
NoCachedDocumentExceptionDetail(Exception, ExceptionDetailBase) | Initializes a new instance of the NoCachedDocumentExceptionDetail class.

See Also

NoCachedDocumentExceptionDetail Class
NoCachedDocumentExceptionDetail Members
PerpetuumSoft.Reporting.Silverlight.Server Namespace


NoCachedDocumentExceptionDetail Constructor (Exception)

[image]

.NET ModelKit Suite ClassReference
NoCachedDocumentExceptionDetail Constructor (Exception)
NoCachedDocumentExceptionDetail Class See Also Send Feedback
Initializes a new instance of the NoCachedDocumentExceptionDetail class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public NoCachedDocumentExceptionDetail(
    Exception exception
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception _
)
Visual C++
public:
NoCachedDocumentExceptionDetail(
    Exception^ exception
)

Parameters

exception
Type: System..::.Exception

See Also

NoCachedDocumentExceptionDetail Class
NoCachedDocumentExceptionDetail Overload
PerpetuumSoft.Reporting.Silverlight.Server Namespace


NoCachedDocumentExceptionDetail Constructor (Exception, ExceptionDetailBase)

[image]

.NET ModelKit Suite ClassReference
NoCachedDocumentExceptionDetail Constructor (Exception, ExceptionDetailBase)
NoCachedDocumentExceptionDetail Class See Also Send Feedback
Initializes a new instance of the NoCachedDocumentExceptionDetail class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public NoCachedDocumentExceptionDetail(
    Exception exception,
    ExceptionDetailBase innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    exception As Exception, _
    innerException As ExceptionDetailBase _
)
Visual C++
public:
NoCachedDocumentExceptionDetail(
    Exception^ exception,
    ExceptionDetailBase^ innerException
)

Parameters

exception
Type: System..::.Exception
innerException
Type: PerpetuumSoft.Reporting.Silverlight.Server..::.ExceptionDetailBase

See Also

NoCachedDocumentExceptionDetail Class
NoCachedDocumentExceptionDetail Overload
PerpetuumSoft.Reporting.Silverlight.Server Namespace


NoCachedDocumentExceptionDetail Methods

[image] [image]

.NET ModelKit Suite ClassReference
NoCachedDocumentExceptionDetail Methods
NoCachedDocumentExceptionDetail Class See Also Send Feedback

The NoCachedDocumentExceptionDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NoCachedDocumentExceptionDetail Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


NoCachedDocumentExceptionDetail Properties

[image] [image]

.NET ModelKit Suite ClassReference
NoCachedDocumentExceptionDetail Properties
NoCachedDocumentExceptionDetail Class See Also Send Feedback

The NoCachedDocumentExceptionDetail type exposes the following members.

Properties

Name | Description
Exception | Gets or sets an exception generated by server. (Inherited from ExceptionDetailBase.)
InnerException | Gets or sets inner exception wrapper. (Inherited from ExceptionDetailBase.)
Message | Gets or sets error message. (Inherited from ExceptionDetailBase.)

See Also

NoCachedDocumentExceptionDetail Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


PageInfo Class

[image]

.NET ModelKit Suite ClassReference
PageInfo Class
Members See Also Send Feedback
Represents report page metadata.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class PageInfo
Visual Basic (Declaration)
Public Class PageInfo
Visual C++
public ref class PageInfo

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Server..::.PageInfo

See Also

PageInfo Members
PerpetuumSoft.Reporting.Silverlight.Server Namespace


PageInfo Members

[image] [image]

.NET ModelKit Suite ClassReference
PageInfo Members
PageInfo Class Constructors Methods Properties See Also Send Feedback

The PageInfo type exposes the following members.

Constructors

Name | Description
PageInfo | Initializes a new instance of the PageInfo class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentId | Gets or sets identificator of the document which contains the page.
PageNumber | Gets or sets a page number.

See Also

PageInfo Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


PageInfo Constructor

[image]

.NET ModelKit Suite ClassReference
PageInfo Constructor
PageInfo Class See Also Send Feedback
Initializes a new instance of the PageInfo class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public PageInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageInfo()

See Also

PageInfo Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


PageInfo Methods

[image] [image]

.NET ModelKit Suite ClassReference
PageInfo Methods
PageInfo Class See Also Send Feedback

The PageInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PageInfo Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


PageInfo Properties

[image] [image]

.NET ModelKit Suite ClassReference
PageInfo Properties
PageInfo Class See Also Send Feedback

The PageInfo type exposes the following members.

Properties

Name | Description
DocumentId | Gets or sets identificator of the document which contains the page.
PageNumber | Gets or sets a page number.

See Also

PageInfo Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


DocumentId Property

[image]

.NET ModelKit Suite ClassReference
PageInfo..::.DocumentId Property
PageInfo Class See Also Send Feedback
Gets or sets identificator of the document which contains the page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public string DocumentId { get; set; }
Visual Basic (Declaration)
Public Property DocumentId As String
Visual C++
public:
property String^ DocumentId {
    String^ get ();
    void set (String^ value);
}

See Also

PageInfo Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


PageNumber Property

[image]

.NET ModelKit Suite ClassReference
PageInfo..::.PageNumber Property
PageInfo Class See Also Send Feedback
Gets or sets a page number.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public int PageNumber { get; set; }
Visual Basic (Declaration)
Public Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
    void set (int value);
}

See Also

PageInfo Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ReportServiceBase Class

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase Class
Members See Also Send Feedback
Represents service for report generation and getting data about generated report.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ReportServiceBase : [T:],
    IReportService, IReportServiceResources
Visual Basic (Declaration)
Public Class ReportServiceBase _
    Inherits [T:] _
    Implements IReportService, IReportServiceResources
Visual C++
public ref class ReportServiceBase : public [T:],
    IReportService, IReportServiceResources

Inheritance Hierarchy

[T:]
PerpetuumSoft.Reporting.Silverlight.Server..::.ReportServiceBase

See Also

ReportServiceBase Members
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ReportServiceBase Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceBase Members
ReportServiceBase Class Constructors Methods Properties See Also Send Feedback

The ReportServiceBase type exposes the following members.

Constructors

Name | Description
ReportServiceBase | Initializes a new instance of the ReportServiceBase class.

Methods

Name | Description
CreateCache | Implements AddDocumentToCache(String, Document, array<Object>[]()[]).
Export | Implements Export(String, String).
Find | Implements Find(String, FindOptions, ExceptionDetailBase%).
FindTextCore |
GenerateDocumentId |
GenetatePageId | Generates key to refer to the report page.
GetDocument | Returns the document saved in cash by its name.
GetDocumentInfo | Implements GetDocumentInfo(String, ExceptionDetailBase%).
GetFont | Implements GetFont(String).
GetImage | Implements GetImage(String, Int32, Int32).
GetPageInfo | Implements GetPageInfo(String, Int32, ExceptionDetailBase%).
GetReportSlot | Returns the object which represents the report template storage.
GetResource | Implements GetResource(String).
HandleError | It is evoked if there is report generation error.
Init | Implements Init()()().
OnLoadData | It is evoked for data sources initialization.
Render | Implements Render(IDictionary<(Of <(String, Object>)>), String, ExceptionDetailBase%).
RenderCore | Returns generated report by the report set name and parameters.

Properties

Name | Description
ImageDPI | Gets or sets report images resolution.
ReportCache | Gets or sets the IReportCache object which is intended for storing a generated report on server.
ReportManager | Gets or sets the ReportManager object which controls report generation.

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ReportServiceBase Constructor

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase Constructor
ReportServiceBase Class See Also Send Feedback
Initializes a new instance of the ReportServiceBase class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ReportServiceBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportServiceBase()

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ReportServiceBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceBase Methods
ReportServiceBase Class See Also Send Feedback

The ReportServiceBase type exposes the following members.

Methods

Name | Description
CreateCache | Implements AddDocumentToCache(String, Document, array<Object>[]()[]).
Export | Implements Export(String, String).
Find | Implements Find(String, FindOptions, ExceptionDetailBase%).
FindTextCore |
GenerateDocumentId |
GenetatePageId | Generates key to refer to the report page.
GetDocument | Returns the document saved in cash by its name.
GetDocumentInfo | Implements GetDocumentInfo(String, ExceptionDetailBase%).
GetFont | Implements GetFont(String).
GetImage | Implements GetImage(String, Int32, Int32).
GetPageInfo | Implements GetPageInfo(String, Int32, ExceptionDetailBase%).
GetReportSlot | Returns the object which represents the report template storage.
GetResource | Implements GetResource(String).
HandleError | It is evoked if there is report generation error.
Init | Implements Init()()().
OnLoadData | It is evoked for data sources initialization.
Render | Implements Render(IDictionary<(Of <(String, Object>)>), String, ExceptionDetailBase%).
RenderCore | Returns generated report by the report set name and parameters.

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


CreateCache Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.CreateCache Method
ReportServiceBase Class See Also Send Feedback
Implements AddDocumentToCache(String, Document, array<Object>[]()[]).

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected virtual IReportCache CreateCache()
Visual Basic (Declaration)
Protected Overridable Function CreateCache As IReportCache
Visual C++
protected:
virtual IReportCache^ CreateCache()

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


Export Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.Export Method
ReportServiceBase Class See Also Send Feedback
Implements Export(String, String).

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Stream Export(
    string id,
    string format
)
Visual Basic (Declaration)
Public Function Export ( _
    id As String, _
    format As String _
) As Stream
Visual C++
public:
virtual Stream^ Export(
    String^ id,
    String^ format
) sealed

Parameters

id
Type: System..::.String
format
Type: System..::.String

Implements

IReportServiceResources..::.Export(String, String)

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


Find Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.Find Method
ReportServiceBase Class See Also Send Feedback
Implements Find(String, FindOptions, ExceptionDetailBase%).

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public SearchResult Find(
    string id,
    FindOptions findOptions,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public Function Find ( _
    id As String, _
    findOptions As FindOptions, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As SearchResult
Visual C++
public:
virtual SearchResult^ Find(
    String^ id,
    FindOptions findOptions,
    [OutAttribute] ExceptionDetailBase^% ReportError
) sealed

Parameters

id
Type: System..::.String
findOptions
Type: PerpetuumSoft.Reporting.Silverlight.Server..::.FindOptions
ReportError
Type: PerpetuumSoft.Reporting.Silverlight.Server..::.ExceptionDetailBase %

Implements

IReportService..::.Find(String, FindOptions, ExceptionDetailBase%)

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


FindTextCore Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.FindTextCore Method
ReportServiceBase Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Silverlight.Server.ReportServiceBase.FindTextCore(,PerpetuumSoft.Reporting.Silverlight.Server.FindOptions)]

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public SearchResult FindTextCore(
    [T:] document,
    FindOptions options
)
Visual Basic (Declaration)
Public Function FindTextCore ( _
    document As [T:], _
    options As FindOptions _
) As SearchResult
Visual C++
public:
SearchResult^ FindTextCore(
    [T:]^ document,
    FindOptions options
)

Parameters

document
Type: [T:]
options
Type: PerpetuumSoft.Reporting.Silverlight.Server..::.FindOptions

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


GenerateDocumentId Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.GenerateDocumentId Method
ReportServiceBase Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Silverlight.Server.ReportServiceBase.GenerateDocumentId(System.Collections.Generic.IDictionary{System.String,System.Object},System.String,)]

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected virtual string GenerateDocumentId(
    IDictionary<string, Object> parameters,
    string reportName,
    [T:] document
)
Visual Basic (Declaration)
Protected Overridable Function GenerateDocumentId ( _
    parameters As IDictionary(Of String, Object), _
    reportName As String, _
    document As [T:] _
) As String
Visual C++
protected:
virtual String^ GenerateDocumentId(
    IDictionary<String^, Object^>^ parameters,
    String^ reportName,
    [T:]^ document
)

Parameters

parameters
Type: System.Collections.Generic..::.IDictionary <(Of <( String, Object >)>)
reportName
Type: System..::.String
document
Type: [T:]

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


GenetatePageId Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.GenetatePageId Method
ReportServiceBase Class See Also Send Feedback
Generates key to refer to the report page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected virtual string GenetatePageId(
    string documentId,
    int pageNumber
)
Visual Basic (Declaration)
Protected Overridable Function GenetatePageId ( _
    documentId As String, _
    pageNumber As Integer _
) As String
Visual C++
protected:
virtual String^ GenetatePageId(
    String^ documentId,
    int pageNumber
)

Parameters

documentId
Type: System..::.String
pageNumber
Type: System..::.Int32

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


GetDocument Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.GetDocument Method
ReportServiceBase Class See Also Send Feedback
Returns the document saved in cash by its name.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected virtual [T:] GetDocument(
    string id
)
Visual Basic (Declaration)
Protected Overridable Function GetDocument ( _
    id As String _
) As [T:]
Visual C++
protected:
virtual [T:]^ GetDocument(
    String^ id
)

Parameters

id
Type: System..::.String

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


GetDocumentInfo Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.GetDocumentInfo Method
ReportServiceBase Class See Also Send Feedback
Implements GetDocumentInfo(String, ExceptionDetailBase%).

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public DocumentInfo GetDocumentInfo(
    string id,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public Function GetDocumentInfo ( _
    id As String, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As DocumentInfo
Visual C++
public:
virtual DocumentInfo^ GetDocumentInfo(
    String^ id,
    [OutAttribute] ExceptionDetailBase^% ReportError
) sealed

Parameters

id
Type: System..::.String
ReportError
Type: PerpetuumSoft.Reporting.Silverlight.Server..::.ExceptionDetailBase %

Implements

IReportService..::.GetDocumentInfo(String, ExceptionDetailBase%)

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


GetFont Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.GetFont Method
ReportServiceBase Class See Also Send Feedback
Implements GetFont(String).

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Stream GetFont(
    string resourceId
)
Visual Basic (Declaration)
Public Function GetFont ( _
    resourceId As String _
) As Stream
Visual C++
public:
virtual Stream^ GetFont(
    String^ resourceId
) sealed

Parameters

resourceId
Type: System..::.String

Implements

IReportServiceResources..::.GetFont(String)

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


GetImage Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.GetImage Method
ReportServiceBase Class See Also Send Feedback
Implements GetImage(String, Int32, Int32).

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Stream GetImage(
    string id,
    int pageIndex,
    int controlIndex
)
Visual Basic (Declaration)
Public Function GetImage ( _
    id As String, _
    pageIndex As Integer, _
    controlIndex As Integer _
) As Stream
Visual C++
public:
virtual Stream^ GetImage(
    String^ id,
    int pageIndex,
    int controlIndex
) sealed

Parameters

id
Type: System..::.String
pageIndex
Type: System..::.Int32
controlIndex
Type: System..::.Int32

Implements

IReportServiceResources..::.GetImage(String, Int32, Int32)

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


GetPageInfo Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.GetPageInfo Method
ReportServiceBase Class See Also Send Feedback
Implements GetPageInfo(String, Int32, ExceptionDetailBase%).

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public PageInfo GetPageInfo(
    string id,
    int pageNumber,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public Function GetPageInfo ( _
    id As String, _
    pageNumber As Integer, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As PageInfo
Visual C++
public:
virtual PageInfo^ GetPageInfo(
    String^ id,
    int pageNumber,
    [OutAttribute] ExceptionDetailBase^% ReportError
) sealed

Parameters

id
Type: System..::.String
pageNumber
Type: System..::.Int32
ReportError
Type: PerpetuumSoft.Reporting.Silverlight.Server..::.ExceptionDetailBase %

Implements

IReportService..::.GetPageInfo(String, Int32, ExceptionDetailBase%)

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


GetReportSlot Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.GetReportSlot Method
ReportServiceBase Class See Also Send Feedback
Returns the object which represents the report template storage.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected virtual ReportSlot GetReportSlot(
    IDictionary<string, Object> parameters,
    string reportName
)
Visual Basic (Declaration)
Protected Overridable Function GetReportSlot ( _
    parameters As IDictionary(Of String, Object), _
    reportName As String _
) As ReportSlot
Visual C++
protected:
virtual ReportSlot^ GetReportSlot(
    IDictionary<String^, Object^>^ parameters,
    String^ reportName
)

Parameters

parameters
Type: System.Collections.Generic..::.IDictionary <(Of <( String, Object >)>)
reportName
Type: System..::.String

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


GetResource Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.GetResource Method
ReportServiceBase Class See Also Send Feedback
Implements GetResource(String).

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Stream GetResource(
    string culture
)
Visual Basic (Declaration)
Public Function GetResource ( _
    culture As String _
) As Stream
Visual C++
public:
virtual Stream^ GetResource(
    String^ culture
) sealed

Parameters

culture
Type: System..::.String

Implements

IReportServiceResources..::.GetResource(String)

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


HandleError Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.HandleError Method
ReportServiceBase Class See Also Send Feedback
It is evoked if there is report generation error.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected virtual ExceptionDetailBase HandleError(
    Exception e
)
Visual Basic (Declaration)
Protected Overridable Function HandleError ( _
    e As Exception _
) As ExceptionDetailBase
Visual C++
protected:
virtual ExceptionDetailBase^ HandleError(
    Exception^ e
)

Parameters

e
Type: System..::.Exception

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


Init Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.Init Method
ReportServiceBase Class See Also Send Feedback
Implements Init()()().

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public void Init()
Visual Basic (Declaration)
Public Sub Init
Visual C++
public:
virtual void Init() sealed

Implements

IReportService..::.Init()()()

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


OnLoadData Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.OnLoadData Method
ReportServiceBase Class See Also Send Feedback
It is evoked for data sources initialization.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected virtual void OnLoadData(
    IDictionary<string, Object> parameters,
    string reportName,
    ReportSlot reportSlot
)
Visual Basic (Declaration)
Protected Overridable Sub OnLoadData ( _
    parameters As IDictionary(Of String, Object), _
    reportName As String, _
    reportSlot As ReportSlot _
)
Visual C++
protected:
virtual void OnLoadData(
    IDictionary<String^, Object^>^ parameters,
    String^ reportName,
    ReportSlot^ reportSlot
)

Parameters

parameters
Type: System.Collections.Generic..::.IDictionary <(Of <( String, Object >)>)
reportName
Type: System..::.String
reportSlot
Type: PerpetuumSoft.Reporting.Components..::.ReportSlot

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


Render Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.Render Method
ReportServiceBase Class See Also Send Feedback
Implements Render(IDictionary<(Of <(String, Object>)>), String, ExceptionDetailBase%).

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public virtual string Render(
    IDictionary<string, Object> parameters,
    string reportName,
    out ExceptionDetailBase ReportError
)
Visual Basic (Declaration)
Public Overridable Function Render ( _
    parameters As IDictionary(Of String, Object), _
    reportName As String, _
    <OutAttribute> ByRef ReportError As ExceptionDetailBase _
) As String
Visual C++
public:
virtual String^ Render(
    IDictionary<String^, Object^>^ parameters,
    String^ reportName,
    [OutAttribute] ExceptionDetailBase^% ReportError
)

Parameters

parameters
Type: System.Collections.Generic..::.IDictionary <(Of <( String, Object >)>)
reportName
Type: System..::.String
ReportError
Type: PerpetuumSoft.Reporting.Silverlight.Server..::.ExceptionDetailBase %

Implements

IReportService..::.Render(IDictionary<(Of <(String, Object>)>), String, ExceptionDetailBase%)

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


RenderCore Method

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.RenderCore Method
ReportServiceBase Class See Also Send Feedback
Returns generated report by the report set name and parameters.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected virtual [T:] RenderCore(
    IDictionary<string, Object> parameters,
    string reportName
)
Visual Basic (Declaration)
Protected Overridable Function RenderCore ( _
    parameters As IDictionary(Of String, Object), _
    reportName As String _
) As [T:]
Visual C++
protected:
virtual [T:]^ RenderCore(
    IDictionary<String^, Object^>^ parameters,
    String^ reportName
)

Parameters

parameters
Type: System.Collections.Generic..::.IDictionary <(Of <( String, Object >)>)
reportName
Type: System..::.String

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ReportServiceBase Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportServiceBase Properties
ReportServiceBase Class See Also Send Feedback

The ReportServiceBase type exposes the following members.

Properties

Name | Description
ImageDPI | Gets or sets report images resolution.
ReportCache | Gets or sets the IReportCache object which is intended for storing a generated report on server.
ReportManager | Gets or sets the ReportManager object which controls report generation.

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ImageDPI Property

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.ImageDPI Property
ReportServiceBase Class See Also Send Feedback
Gets or sets report images resolution.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public int ImageDPI { get; set; }
Visual Basic (Declaration)
Public Property ImageDPI As Integer
Visual C++
public:
property int ImageDPI {
    int get ();
    void set (int value);
}

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ReportCache Property

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.ReportCache Property
ReportServiceBase Class See Also Send Feedback
Gets or sets the IReportCache object which is intended for storing a generated report on server.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public IReportCache ReportCache { get; set; }
Visual Basic (Declaration)
Public Property ReportCache As IReportCache
Visual C++
public:
property IReportCache^ ReportCache {
    IReportCache^ get ();
    void set (IReportCache^ value);
}

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ReportManager Property

[image]

.NET ModelKit Suite ClassReference
ReportServiceBase..::.ReportManager Property
ReportServiceBase Class See Also Send Feedback
Gets or sets the ReportManager object which controls report generation.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ReportManager ReportManager { get; set; }
Visual Basic (Declaration)
Public Property ReportManager As ReportManager
Visual C++
public:
property ReportManager^ ReportManager {
    ReportManager^ get ();
    void set (ReportManager^ value);
}

See Also

ReportServiceBase Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


SearchDirection Enumeration

[image]

.NET ModelKit Suite ClassReference
SearchDirection Enumeration
See Also Send Feedback
Sets search direction.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public enum SearchDirection
Visual Basic (Declaration)
Public Enumeration SearchDirection
Visual C++
public enum class SearchDirection

Members

Member name | Description
Forward | Sets search forward direction.
Backward | Sets search backward direction.

See Also

PerpetuumSoft.Reporting.Silverlight.Server Namespace


SearchResult Class

[image]

.NET ModelKit Suite ClassReference
SearchResult Class
Members See Also Send Feedback
Represents text search results.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class SearchResult
Visual Basic (Declaration)
Public Class SearchResult
Visual C++
public ref class SearchResult

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Server..::.SearchResult

See Also

SearchResult Members
PerpetuumSoft.Reporting.Silverlight.Server Namespace


SearchResult Members

[image] [image]

.NET ModelKit Suite ClassReference
SearchResult Members
SearchResult Class Constructors Methods Properties See Also Send Feedback

The SearchResult type exposes the following members.

Constructors

Name | Description
SearchResult | Initializes a new instance of the SearchResult class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ControlIndex | Gets or sets a report control number on a page.
Height | Gets or sets the height of the fragment which contains required text.
PageIndex | Gets or sets a page number.
TextFound | Gets or sets values which indicate if required text was found.
Width | Gets or sets the width of the fragment which includes required text.
X | Gets or sets the abscissa of the fragment beginning which includes required text.
Y | Gets or sets the ordinate of the fragment beginning which includes required text.

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


SearchResult Constructor

[image]

.NET ModelKit Suite ClassReference
SearchResult Constructor
SearchResult Class See Also Send Feedback
Initializes a new instance of the SearchResult class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public SearchResult()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SearchResult()

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


SearchResult Methods

[image] [image]

.NET ModelKit Suite ClassReference
SearchResult Methods
SearchResult Class See Also Send Feedback

The SearchResult type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


SearchResult Properties

[image] [image]

.NET ModelKit Suite ClassReference
SearchResult Properties
SearchResult Class See Also Send Feedback

The SearchResult type exposes the following members.

Properties

Name | Description
ControlIndex | Gets or sets a report control number on a page.
Height | Gets or sets the height of the fragment which contains required text.
PageIndex | Gets or sets a page number.
TextFound | Gets or sets values which indicate if required text was found.
Width | Gets or sets the width of the fragment which includes required text.
X | Gets or sets the abscissa of the fragment beginning which includes required text.
Y | Gets or sets the ordinate of the fragment beginning which includes required text.

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


ControlIndex Property

[image]

.NET ModelKit Suite ClassReference
SearchResult..::.ControlIndex Property
SearchResult Class See Also Send Feedback
Gets or sets a report control number on a page.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public int ControlIndex { get; set; }
Visual Basic (Declaration)
Public Property ControlIndex As Integer
Visual C++
public:
property int ControlIndex {
    int get ();
    void set (int value);
}

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


Height Property

[image]

.NET ModelKit Suite ClassReference
SearchResult..::.Height Property
SearchResult Class See Also Send Feedback
Gets or sets the height of the fragment which contains required text.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public double Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Double
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


PageIndex Property

[image]

.NET ModelKit Suite ClassReference
SearchResult..::.PageIndex Property
SearchResult Class See Also Send Feedback
Gets or sets a page number.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public int PageIndex { get; set; }
Visual Basic (Declaration)
Public Property PageIndex As Integer
Visual C++
public:
property int PageIndex {
    int get ();
    void set (int value);
}

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


TextFound Property

[image]

.NET ModelKit Suite ClassReference
SearchResult..::.TextFound Property
SearchResult Class See Also Send Feedback
Gets or sets values which indicate if required text was found.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public bool TextFound { get; set; }
Visual Basic (Declaration)
Public Property TextFound As Boolean
Visual C++
public:
property bool TextFound {
    bool get ();
    void set (bool value);
}

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
SearchResult..::.Width Property
SearchResult Class See Also Send Feedback
Gets or sets the width of the fragment which includes required text.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


X Property

[image]

.NET ModelKit Suite ClassReference
SearchResult..::.X Property
SearchResult Class See Also Send Feedback
Gets or sets the abscissa of the fragment beginning which includes required text.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public double X { get; set; }
Visual Basic (Declaration)
Public Property X As Double
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


Y Property

[image]

.NET ModelKit Suite ClassReference
SearchResult..::.Y Property
SearchResult Class See Also Send Feedback
Gets or sets the ordinate of the fragment beginning which includes required text.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public double Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Double
Visual C++
public:
property double Y {
    double get ();
    void set (double value);
}

See Also

SearchResult Class
PerpetuumSoft.Reporting.Silverlight.Server Namespace


PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace
Send Feedback
The PerpetuumSoft.Reporting.Silverlight.Export.Binding namespace contains classes for realization of ability to use vafious data sources in ReportManager.

Classes

Class | Description
DataSourceListEditor | Represents the editor for data source setting.
ObjectBindingSource | Encapsulates the data source for a form.


DataSourceListEditor Class

[image]

.NET ModelKit Suite ClassReference
DataSourceListEditor Class
Members See Also Send Feedback
Represents the editor for data source setting.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Binding
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class DataSourceListEditor : UITypeEditor
Visual Basic (Declaration)
Public Class DataSourceListEditor _
    Inherits UITypeEditor
Visual C++
public ref class DataSourceListEditor : public UITypeEditor

Inheritance Hierarchy

System..::.Object
System.Drawing.Design..::.UITypeEditor
PerpetuumSoft.Reporting.Silverlight.Server.Binding..::.DataSourceListEditor

See Also

DataSourceListEditor Members
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


DataSourceListEditor Members

[image] [image]

.NET ModelKit Suite ClassReference
DataSourceListEditor Members
DataSourceListEditor Class Constructors Methods Properties See Also Send Feedback

The DataSourceListEditor type exposes the following members.

Constructors

Name | Description
DataSourceListEditor | Initializes a new instance of the DataSourceListEditor class.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

DataSourceListEditor Class
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


DataSourceListEditor Constructor

[image]

.NET ModelKit Suite ClassReference
DataSourceListEditor Constructor
DataSourceListEditor Class See Also Send Feedback
Initializes a new instance of the DataSourceListEditor class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Binding
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public DataSourceListEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataSourceListEditor()

See Also

DataSourceListEditor Class
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


DataSourceListEditor Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataSourceListEditor Methods
DataSourceListEditor Class See Also Send Feedback

The DataSourceListEditor type exposes the following members.

Methods

Name | Description
EditValue | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEditStyle | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPaintValueSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PaintValue | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataSourceListEditor Class
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


EditValue Method

[image] [image]

.NET ModelKit Suite ClassReference
DataSourceListEditor..::.EditValue Method
DataSourceListEditor Class See Also Send Feedback

Overload List

Name | Description
EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()()() method. (Inherited from UITypeEditor.)
EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Overriden. See EditValue(ITypeDescriptorContext, IServiceProvider, Object). (Overrides UITypeEditor..::.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)

See Also

DataSourceListEditor Class
DataSourceListEditor Members
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

[image]

.NET ModelKit Suite ClassReference
DataSourceListEditor..::.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)
DataSourceListEditor Class See Also Send Feedback
Overriden. See EditValue(ITypeDescriptorContext, IServiceProvider, Object).

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Binding
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function EditValue ( _
    context As ITypeDescriptorContext, _
    provider As IServiceProvider, _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ EditValue(
    ITypeDescriptorContext^ context,
    IServiceProvider^ provider,
    Object^ value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
provider
Type: System..::.IServiceProvider
value
Type: System..::.Object

See Also

DataSourceListEditor Class
EditValue Overload
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


GetEditStyle Method

[image] [image]

.NET ModelKit Suite ClassReference
DataSourceListEditor..::.GetEditStyle Method
DataSourceListEditor Class See Also Send Feedback

Overload List

Name | Description
GetEditStyle()()() | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
GetEditStyle(ITypeDescriptorContext) | 'Overriden. See GetEditStyle(ITypeDescriptorContext). (Overrides UITypeEditor..::.GetEditStyle(ITypeDescriptorContext).)

See Also

DataSourceListEditor Class
DataSourceListEditor Members
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


GetEditStyle Method (ITypeDescriptorContext)

[image]

.NET ModelKit Suite ClassReference
DataSourceListEditor..::.GetEditStyle Method (ITypeDescriptorContext)
DataSourceListEditor Class See Also Send Feedback
'Overriden. See GetEditStyle(ITypeDescriptorContext).

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Binding
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetEditStyle ( _
    context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual C++
public:
virtual UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext

See Also

DataSourceListEditor Class
GetEditStyle Overload
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


GetPaintValueSupported Method

[image] [image]

.NET ModelKit Suite ClassReference
DataSourceListEditor..::.GetPaintValueSupported Method
DataSourceListEditor Class See Also Send Feedback

Overload List

Name | Description
GetPaintValueSupported()()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)

See Also

DataSourceListEditor Class
DataSourceListEditor Members
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


PaintValue Method

[image] [image]

.NET ModelKit Suite ClassReference
DataSourceListEditor..::.PaintValue Method
DataSourceListEditor Class See Also Send Feedback

Overload List

Name | Description
PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
[M:System.Drawing.Design.UITypeEditor.PaintValue(System.Object,,System.Drawing.Rectangle)] | (Inherited from UITypeEditor.)

See Also

DataSourceListEditor Class
DataSourceListEditor Members
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


DataSourceListEditor Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataSourceListEditor Properties
DataSourceListEditor Class See Also Send Feedback

The DataSourceListEditor type exposes the following members.

Properties

Name | Description
IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)

See Also

DataSourceListEditor Class
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


ObjectBindingSource Class

[image]

.NET ModelKit Suite ClassReference
ObjectBindingSource Class
Members See Also Send Feedback
Encapsulates the data source for a form.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Binding
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class ObjectBindingSource : BindingSource
Visual Basic (Declaration)
Public Class ObjectBindingSource _
    Inherits BindingSource
Visual C++
public ref class ObjectBindingSource : public BindingSource

Inheritance Hierarchy

[T:]
System.Windows.Forms..::.BindingSource
PerpetuumSoft.Reporting.Silverlight.Server.Binding..::.ObjectBindingSource

See Also

ObjectBindingSource Members
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


ObjectBindingSource Members

[image] [image]

.NET ModelKit Suite ClassReference
ObjectBindingSource Members
ObjectBindingSource Class Constructors Methods Properties Events See Also Send Feedback

The ObjectBindingSource type exposes the following members.

Constructors

Name | Description
ObjectBindingSource | Initializes a new instance of the ObjectBindingSource class.

Methods

Name | Description
Add | Adds an existing item to the internal list. (Inherited from BindingSource.)
AddNew | Adds a new item to the underlying list. (Inherited from BindingSource.)
ApplySort | Overloaded.
CancelEdit | Cancels the current edit operation. (Inherited from BindingSource.)
Clear | Removes all elements from the list. (Inherited from BindingSource.)
Contains | Determines whether an object is an item in the list. (Inherited from BindingSource.)
CopyTo | Copies the contents of the List to the specified array, starting at the specified index value. (Inherited from BindingSource.)
Dispose | Releases the unmanaged resources used by the BindingSource and optionally releases the managed resources. (Inherited from BindingSource.)
EndEdit | Applies pending changes to the underlying data source. (Inherited from BindingSource.)
Find | Overloaded.
GetEnumerator | Retrieves an enumerator for the List. (Inherited from BindingSource.)
GetItemProperties | Retrieves an array of PropertyDescriptor objects representing the bindable properties of the data source list type. (Inherited from BindingSource.)
GetListName | Gets the name of the list supplying data for the binding. (Inherited from BindingSource.)
GetRelatedCurrencyManager | Gets the related currency manager for the specified data member. (Inherited from BindingSource.)
IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list. (Inherited from BindingSource.)
Insert | Inserts an item into the list at the specified index. (Inherited from BindingSource.)
MoveFirst | Moves to the first item in the list. (Inherited from BindingSource.)
MoveLast | Moves to the last item in the list. (Inherited from BindingSource.)
MoveNext | Moves to the next item in the list. (Inherited from BindingSource.)
MovePrevious | Moves to the previous item in the list. (Inherited from BindingSource.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingSource.)
OnBindingComplete | Raises the BindingComplete event. (Inherited from BindingSource.)
OnCurrentChanged | Raises the CurrentChanged event. (Inherited from BindingSource.)
OnCurrentItemChanged | Raises the CurrentItemChanged event. (Inherited from BindingSource.)
OnDataError | Raises the DataError event. (Inherited from BindingSource.)
OnDataMemberChanged | Raises the DataMemberChanged event. (Inherited from BindingSource.)
OnDataSourceChanged | Raises the DataSourceChanged event. (Inherited from BindingSource.)
OnListChanged | Raises the ListChanged event. (Inherited from BindingSource.)
OnPositionChanged | Raises the PositionChanged event. (Inherited from BindingSource.)
Remove | Removes the specified item from the list. (Inherited from BindingSource.)
RemoveAt | Removes the item at the specified index in the list. (Inherited from BindingSource.)
RemoveCurrent | Removes the current item from the list. (Inherited from BindingSource.)
RemoveFilter | Removes the filter associated with the BindingSource. (Inherited from BindingSource.)
RemoveSort | Removes the sort associated with the BindingSource. (Inherited from BindingSource.)
ResetAllowNew | Reinitializes the AllowNew property. (Inherited from BindingSource.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from BindingSource.)
ResetCurrentItem | Causes a control bound to the BindingSource to reread the currently selected item and refresh its displayed value. (Inherited from BindingSource.)
ResetItem | Causes a control bound to the BindingSource to reread the item at the specified index, and refresh its displayed value. (Inherited from BindingSource.)
ResumeBinding | Resumes data binding. (Inherited from BindingSource.)
SuspendBinding | Suspends data binding to prevent changes from updating the bound data source. (Inherited from BindingSource.)

Properties

Name | Description
AllowEdit | Gets a value indicating whether items in the underlying list can be edited. (Inherited from BindingSource.)
AllowNew | Gets or sets a value indicating whether the AddNew()()() method can be used to add items to the list. (Inherited from BindingSource.)
AllowRemove | Gets a value indicating whether items can be removed from the underlying list. (Inherited from BindingSource.)
Count | Gets the total number of items in the underlying list. (Inherited from BindingSource.)
CurrencyManager | Gets the currency manager associated with this BindingSource. (Inherited from BindingSource.)
Current | Gets the current item in the list. (Inherited from BindingSource.)
DataMember | Gets or sets the specific list in the data source to which the connector currently binds to. (Inherited from BindingSource.)
DataSource | Gets or sets data source object.
Filter | Gets or sets the expression used to filter which rows are viewed. (Inherited from BindingSource.)
IsBindingSuspended | Gets a value indicating whether the list binding is suspended. (Inherited from BindingSource.)
IsFixedSize | Gets a value indicating whether the underlying list has a fixed size. (Inherited from BindingSource.)
IsReadOnly | Gets a value indicating whether the underlying list is read-only. (Inherited from BindingSource.)
IsSorted | Gets a value indicating whether the items in the underlying list are sorted. (Inherited from BindingSource.)
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from BindingSource.)
Item | Gets or sets the list element at the specified index. (Inherited from BindingSource.)
List | Gets the list that the connector is bound to. (Inherited from BindingSource.)
Position | Gets or sets the index of the current item in the underlying list. (Inherited from BindingSource.)
RaiseListChangedEvents | Gets or sets a value indicating whether ListChanged events should be raised. (Inherited from BindingSource.)
Sort | Gets or sets the column names used for sorting, and the sort order for viewing the rows in the data source. (Inherited from BindingSource.)
SortDescriptions | Gets the collection of sort descriptions applied to the data source. (Inherited from BindingSource.)
SortDirection | Gets the direction the items in the list are sorted. (Inherited from BindingSource.)
SortProperty | Gets the PropertyDescriptor that is being used for sorting the list. (Inherited from BindingSource.)
SupportsAdvancedSorting | Gets a value indicating whether the data source supports multi-column sorting. (Inherited from BindingSource.)
SupportsChangeNotification | Gets a value indicating whether the data source supports change notification. (Inherited from BindingSource.)
SupportsFiltering | Gets a value indicating whether the data source supports filtering. (Inherited from BindingSource.)
SupportsSearching | Gets a value indicating whether the data source supports searching with the Find(PropertyDescriptor, Object) method. (Inherited from BindingSource.)
SupportsSorting | Gets a value indicating whether the data source supports sorting. (Inherited from BindingSource.)
SyncRoot | Gets an object that can be used to synchronize access to the underlying list. (Inherited from BindingSource.)

Events

Name | Description
AddingNew | Occurs before an item is added to the underlying list. (Inherited from BindingSource.)
BindingComplete | Occurs when all the clients have been bound to this BindingSource. (Inherited from BindingSource.)
CurrentChanged | Occurs when the currently bound item changes. (Inherited from BindingSource.)
CurrentItemChanged | Occurs when a property value of the Current property has changed. (Inherited from BindingSource.)
DataError | Occurs when a currency-related exception is silently handled by the BindingSource. (Inherited from BindingSource.)
DataMemberChanged | Occurs when the DataMember property value has changed. (Inherited from BindingSource.)
DataSourceChanged | Occurs when the DataSource property value has changed. (Inherited from BindingSource.)
ListChanged | Occurs when the underlying list changes or an item in the list changes. (Inherited from BindingSource.)
PositionChanged | Occurs after the value of the Position property has changed. (Inherited from BindingSource.)

See Also

ObjectBindingSource Class
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


ObjectBindingSource Constructor

[image]

.NET ModelKit Suite ClassReference
ObjectBindingSource Constructor
ObjectBindingSource Class See Also Send Feedback
Initializes a new instance of the ObjectBindingSource class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Binding
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public ObjectBindingSource()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ObjectBindingSource()

See Also

ObjectBindingSource Class
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


ObjectBindingSource Methods

[image] [image]

.NET ModelKit Suite ClassReference
ObjectBindingSource Methods
ObjectBindingSource Class See Also Send Feedback

The ObjectBindingSource type exposes the following members.

Methods

Name | Description
Add | Adds an existing item to the internal list. (Inherited from BindingSource.)
AddNew | Adds a new item to the underlying list. (Inherited from BindingSource.)
ApplySort | Overloaded.
CancelEdit | Cancels the current edit operation. (Inherited from BindingSource.)
Clear | Removes all elements from the list. (Inherited from BindingSource.)
Contains | Determines whether an object is an item in the list. (Inherited from BindingSource.)
CopyTo | Copies the contents of the List to the specified array, starting at the specified index value. (Inherited from BindingSource.)
Dispose | Releases the unmanaged resources used by the BindingSource and optionally releases the managed resources. (Inherited from BindingSource.)
EndEdit | Applies pending changes to the underlying data source. (Inherited from BindingSource.)
Find | Overloaded.
GetEnumerator | Retrieves an enumerator for the List. (Inherited from BindingSource.)
GetItemProperties | Retrieves an array of PropertyDescriptor objects representing the bindable properties of the data source list type. (Inherited from BindingSource.)
GetListName | Gets the name of the list supplying data for the binding. (Inherited from BindingSource.)
GetRelatedCurrencyManager | Gets the related currency manager for the specified data member. (Inherited from BindingSource.)
IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list. (Inherited from BindingSource.)
Insert | Inserts an item into the list at the specified index. (Inherited from BindingSource.)
MoveFirst | Moves to the first item in the list. (Inherited from BindingSource.)
MoveLast | Moves to the last item in the list. (Inherited from BindingSource.)
MoveNext | Moves to the next item in the list. (Inherited from BindingSource.)
MovePrevious | Moves to the previous item in the list. (Inherited from BindingSource.)
OnAddingNew | Raises the AddingNew event. (Inherited from BindingSource.)
OnBindingComplete | Raises the BindingComplete event. (Inherited from BindingSource.)
OnCurrentChanged | Raises the CurrentChanged event. (Inherited from BindingSource.)
OnCurrentItemChanged | Raises the CurrentItemChanged event. (Inherited from BindingSource.)
OnDataError | Raises the DataError event. (Inherited from BindingSource.)
OnDataMemberChanged | Raises the DataMemberChanged event. (Inherited from BindingSource.)
OnDataSourceChanged | Raises the DataSourceChanged event. (Inherited from BindingSource.)
OnListChanged | Raises the ListChanged event. (Inherited from BindingSource.)
OnPositionChanged | Raises the PositionChanged event. (Inherited from BindingSource.)
Remove | Removes the specified item from the list. (Inherited from BindingSource.)
RemoveAt | Removes the item at the specified index in the list. (Inherited from BindingSource.)
RemoveCurrent | Removes the current item from the list. (Inherited from BindingSource.)
RemoveFilter | Removes the filter associated with the BindingSource. (Inherited from BindingSource.)
RemoveSort | Removes the sort associated with the BindingSource. (Inherited from BindingSource.)
ResetAllowNew | Reinitializes the AllowNew property. (Inherited from BindingSource.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from BindingSource.)
ResetCurrentItem | Causes a control bound to the BindingSource to reread the currently selected item and refresh its displayed value. (Inherited from BindingSource.)
ResetItem | Causes a control bound to the BindingSource to reread the item at the specified index, and refresh its displayed value. (Inherited from BindingSource.)
ResumeBinding | Resumes data binding. (Inherited from BindingSource.)
SuspendBinding | Suspends data binding to prevent changes from updating the bound data source. (Inherited from BindingSource.)

See Also

ObjectBindingSource Class
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


ApplySort Method

[image] [image]

.NET ModelKit Suite ClassReference
ObjectBindingSource..::.ApplySort Method
ObjectBindingSource Class See Also Send Feedback

Overload List

Name | Description
ApplySort(ListSortDescriptionCollection) | Sorts the data source with the specified sort descriptions. (Inherited from BindingSource.)
ApplySort(PropertyDescriptor, ListSortDirection) | Sorts the data source using the specified property descriptor and sort direction. (Inherited from BindingSource.)

See Also

ObjectBindingSource Class
ObjectBindingSource Members
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


Find Method

[image] [image]

.NET ModelKit Suite ClassReference
ObjectBindingSource..::.Find Method
ObjectBindingSource Class See Also Send Feedback

Overload List

Name | Description
Find(String, Object) | Returns the index of the item in the list with the specified property name and value. (Inherited from BindingSource.)
Find(PropertyDescriptor, Object) | Searches for the index of the item that has the given property descriptor. (Inherited from BindingSource.)

See Also

ObjectBindingSource Class
ObjectBindingSource Members
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


ObjectBindingSource Properties

[image] [image]

.NET ModelKit Suite ClassReference
ObjectBindingSource Properties
ObjectBindingSource Class See Also Send Feedback

The ObjectBindingSource type exposes the following members.

Properties

Name | Description
AllowEdit | Gets a value indicating whether items in the underlying list can be edited. (Inherited from BindingSource.)
AllowNew | Gets or sets a value indicating whether the AddNew()()() method can be used to add items to the list. (Inherited from BindingSource.)
AllowRemove | Gets a value indicating whether items can be removed from the underlying list. (Inherited from BindingSource.)
Count | Gets the total number of items in the underlying list. (Inherited from BindingSource.)
CurrencyManager | Gets the currency manager associated with this BindingSource. (Inherited from BindingSource.)
Current | Gets the current item in the list. (Inherited from BindingSource.)
DataMember | Gets or sets the specific list in the data source to which the connector currently binds to. (Inherited from BindingSource.)
DataSource | Gets or sets data source object.
Filter | Gets or sets the expression used to filter which rows are viewed. (Inherited from BindingSource.)
IsBindingSuspended | Gets a value indicating whether the list binding is suspended. (Inherited from BindingSource.)
IsFixedSize | Gets a value indicating whether the underlying list has a fixed size. (Inherited from BindingSource.)
IsReadOnly | Gets a value indicating whether the underlying list is read-only. (Inherited from BindingSource.)
IsSorted | Gets a value indicating whether the items in the underlying list are sorted. (Inherited from BindingSource.)
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from BindingSource.)
Item | Gets or sets the list element at the specified index. (Inherited from BindingSource.)
List | Gets the list that the connector is bound to. (Inherited from BindingSource.)
Position | Gets or sets the index of the current item in the underlying list. (Inherited from BindingSource.)
RaiseListChangedEvents | Gets or sets a value indicating whether ListChanged events should be raised. (Inherited from BindingSource.)
Sort | Gets or sets the column names used for sorting, and the sort order for viewing the rows in the data source. (Inherited from BindingSource.)
SortDescriptions | Gets the collection of sort descriptions applied to the data source. (Inherited from BindingSource.)
SortDirection | Gets the direction the items in the list are sorted. (Inherited from BindingSource.)
SortProperty | Gets the PropertyDescriptor that is being used for sorting the list. (Inherited from BindingSource.)
SupportsAdvancedSorting | Gets a value indicating whether the data source supports multi-column sorting. (Inherited from BindingSource.)
SupportsChangeNotification | Gets a value indicating whether the data source supports change notification. (Inherited from BindingSource.)
SupportsFiltering | Gets a value indicating whether the data source supports filtering. (Inherited from BindingSource.)
SupportsSearching | Gets a value indicating whether the data source supports searching with the Find(PropertyDescriptor, Object) method. (Inherited from BindingSource.)
SupportsSorting | Gets a value indicating whether the data source supports sorting. (Inherited from BindingSource.)
SyncRoot | Gets an object that can be used to synchronize access to the underlying list. (Inherited from BindingSource.)

See Also

ObjectBindingSource Class
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


DataSource Property

[image]

.NET ModelKit Suite ClassReference
ObjectBindingSource..::.DataSource Property
ObjectBindingSource Class See Also Send Feedback
Gets or sets data source object.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Binding
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public Object DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As Object
Visual C++
public:
property Object^ DataSource {
    Object^ get ();
    void set (Object^ value);
}

See Also

ObjectBindingSource Class
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


ObjectBindingSource Events

[image] [image]

.NET ModelKit Suite ClassReference
ObjectBindingSource Events
ObjectBindingSource Class See Also Send Feedback

The ObjectBindingSource type exposes the following members.

Events

Name | Description
AddingNew | Occurs before an item is added to the underlying list. (Inherited from BindingSource.)
BindingComplete | Occurs when all the clients have been bound to this BindingSource. (Inherited from BindingSource.)
CurrentChanged | Occurs when the currently bound item changes. (Inherited from BindingSource.)
CurrentItemChanged | Occurs when a property value of the Current property has changed. (Inherited from BindingSource.)
DataError | Occurs when a currency-related exception is silently handled by the BindingSource. (Inherited from BindingSource.)
DataMemberChanged | Occurs when the DataMember property value has changed. (Inherited from BindingSource.)
DataSourceChanged | Occurs when the DataSource property value has changed. (Inherited from BindingSource.)
ListChanged | Occurs when the underlying list changes or an item in the list changes. (Inherited from BindingSource.)
PositionChanged | Occurs after the value of the Position property has changed. (Inherited from BindingSource.)

See Also

ObjectBindingSource Class
PerpetuumSoft.Reporting.Silverlight.Server.Binding Namespace


PerpetuumSoft.Reporting.Silverlight.Server.Cache Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Silverlight.Server.Cache Namespace
Send Feedback
The PerpetuumSoft.Reporting.Silverlight.Server.Cache namespace contains classes which is used for cashing of the document generated on server.

Classes

Class | Description
AspNetCache | Realizes cash for storing objects in the current application domain.

Interfaces

Interface | Description
IReportCache | Exposes a method for report saving in cash.


AspNetCache Class

[image]

.NET ModelKit Suite ClassReference
AspNetCache Class
Members See Also Send Feedback
Realizes cash for storing objects in the current application domain.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Cache
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public class AspNetCache : IReportCache
Visual Basic (Declaration)
Public Class AspNetCache _
    Implements IReportCache
Visual C++
public ref class AspNetCache : IReportCache

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Server.Cache..::.AspNetCache

See Also

AspNetCache Members
PerpetuumSoft.Reporting.Silverlight.Server.Cache Namespace


AspNetCache Members

[image] [image]

.NET ModelKit Suite ClassReference
AspNetCache Members
AspNetCache Class Constructors Methods See Also Send Feedback

The AspNetCache type exposes the following members.

Constructors

Name | Description
AspNetCache | Initializes a new instance of the AspNetCache class.

Methods

Name | Description
AddDocumentToCache |
AddPageToCache | Implements AddPageToCache(String, PageInfo, array<Object>[]()[]).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDocumentFromCache | Implements GetDocumentFromCache(String).
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPageFromCache | Implements GetPageFromCache(String).
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AspNetCache Class
PerpetuumSoft.Reporting.Silverlight.Server.Cache Namespace


AspNetCache Constructor

[image]

.NET ModelKit Suite ClassReference
AspNetCache Constructor
AspNetCache Class See Also Send Feedback
Initializes a new instance of the AspNetCache class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Cache
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public AspNetCache()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AspNetCache()

See Also

AspNetCache Class
PerpetuumSoft.Reporting.Silverlight.Server.Cache Namespace


AspNetCache Methods

[image] [image]

.NET ModelKit Suite ClassReference
AspNetCache Methods
AspNetCache Class See Also Send Feedback

The AspNetCache type exposes the following members.

Methods

Name | Description
AddDocumentToCache |
AddPageToCache | Implements AddPageToCache(String, PageInfo, array<Object>[]()[]).
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDocumentFromCache | Implements GetDocumentFromCache(String).
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetPageFromCache | Implements GetPageFromCache(String).
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AspNetCache Class
PerpetuumSoft.Reporting.Silverlight.Server.Cache Namespace


AddDocumentToCache Method

[image]

.NET ModelKit Suite ClassReference
AspNetCache..::.AddDocumentToCache Method
AspNetCache Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Silverlight.Server.Cache.AspNetCache.AddDocumentToCache(System.String,,System.Object[])]

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Cache
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public virtual void AddDocumentToCache(
    string key,
    [T:] value,
    params Object[] parameters
)
Visual Basic (Declaration)
Public Overridable Sub AddDocumentToCache ( _
    key As String, _
    value As [T:], _
    ParamArray parameters As Object() _
)
Visual C++
public:
virtual void AddDocumentToCache(
    String^ key,
    [T:]^ value,
    ... array<Object^>^ parameters
)

Parameters

key
Type: System..::.String
value
Type: [T:]
parameters
Type: array< System..::.Object >[]()[]

Implements

IReportCache..::.AddDocumentToCache(String, , array<Object>[]()[])

See Also

AspNetCache Class
PerpetuumSoft.Reporting.Silverlight.Server.Cache Namespace


AddPageToCache Method

[image]

.NET ModelKit Suite ClassReference
AspNetCache..::.AddPageToCache Method
AspNetCache Class See Also Send Feedback
Implements AddPageToCache(String, PageInfo, array<Object>[]()[]).

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Cache
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public virtual void AddPageToCache(
    string key,
    PageInfo value,
    params Object[] parameters
)
Visual Basic (Declaration)
Public Overridable Sub AddPageToCache ( _
    key As String, _
    value As PageInfo, _
    ParamArray parameters As Object() _
)
Visual C++
public:
virtual void AddPageToCache(
    String^ key,
    PageInfo^ value,
    ... array<Object^>^ parameters
)

Parameters

key
Type: System..::.String
value
Type: PerpetuumSoft.Reporting.Silverlight.Server..::.PageInfo
parameters
Type: array< System..::.Object >[]()[]

Implements

IReportCache..::.AddPageToCache(String, PageInfo, array<Object>[]()[])

See Also

AspNetCache Class
PerpetuumSoft.Reporting.Silverlight.Server.Cache Namespace


GetDocumentFromCache Method

[image]

.NET ModelKit Suite ClassReference
AspNetCache..::.GetDocumentFromCache Method
AspNetCache Class See Also Send Feedback
Implements GetDocumentFromCache(String).

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Cache
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public virtual Object GetDocumentFromCache(
    string key
)
Visual Basic (Declaration)
Public Overridable Function GetDocumentFromCache ( _
    key As String _
) As Object
Visual C++
public:
virtual Object^ GetDocumentFromCache(
    String^ key
)

Parameters

key
Type: System..::.String

Implements

IReportCache..::.GetDocumentFromCache(String)

See Also

AspNetCache Class
PerpetuumSoft.Reporting.Silverlight.Server.Cache Namespace


GetPageFromCache Method

[image]

.NET ModelKit Suite ClassReference
AspNetCache..::.GetPageFromCache Method
AspNetCache Class See Also Send Feedback
Implements GetPageFromCache(String).

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Cache
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public virtual Object GetPageFromCache(
    string key
)
Visual Basic (Declaration)
Public Overridable Function GetPageFromCache ( _
    key As String _
) As Object
Visual C++
public:
virtual Object^ GetPageFromCache(
    String^ key
)

Parameters

key
Type: System..::.String

Implements

IReportCache..::.GetPageFromCache(String)

See Also

AspNetCache Class
PerpetuumSoft.Reporting.Silverlight.Server.Cache Namespace


IReportCache Interface

[image]

.NET ModelKit Suite ClassReference
IReportCache Interface
Members See Also Send Feedback
Exposes a method for report saving in cash.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Cache
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public interface IReportCache
Visual Basic (Declaration)
Public Interface IReportCache
Visual C++
public interface class IReportCache

See Also

IReportCache Members
PerpetuumSoft.Reporting.Silverlight.Server.Cache Namespace


IReportCache Members

[image] [image]

.NET ModelKit Suite ClassReference
IReportCache Members
IReportCache Interface Methods See Also Send Feedback

The IReportCache type exposes the following members.

Methods

Name | Description
AddDocumentToCache |
AddPageToCache | Saves page data in cash with the set name.
GetDocumentFromCache | Gets report from cash by name.
GetPageFromCache | Gets page data from cash by name.

See Also

IReportCache Interface
PerpetuumSoft.Reporting.Silverlight.Server.Cache Namespace


IReportCache Methods

[image] [image]

.NET ModelKit Suite ClassReference
IReportCache Methods
IReportCache Interface See Also Send Feedback

The IReportCache type exposes the following members.

Methods

Name | Description
AddDocumentToCache |
AddPageToCache | Saves page data in cash with the set name.
GetDocumentFromCache | Gets report from cash by name.
GetPageFromCache | Gets page data from cash by name.

See Also

IReportCache Interface
PerpetuumSoft.Reporting.Silverlight.Server.Cache Namespace


AddDocumentToCache Method

[image]

.NET ModelKit Suite ClassReference
IReportCache..::.AddDocumentToCache Method
IReportCache Interface See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Silverlight.Server.Cache.IReportCache.AddDocumentToCache(System.String,,System.Object[])]

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Cache
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
void AddDocumentToCache(
    string key,
    [T:] value,
    params Object[] parameters
)
Visual Basic (Declaration)
Sub AddDocumentToCache ( _
    key As String, _
    value As [T:], _
    ParamArray parameters As Object() _
)
Visual C++
void AddDocumentToCache(
    String^ key,
    [T:]^ value,
    ... array<Object^>^ parameters
)

Parameters

key
Type: System..::.String
value
Type: [T:]
parameters
Type: array< System..::.Object >[]()[]

See Also

IReportCache Interface
PerpetuumSoft.Reporting.Silverlight.Server.Cache Namespace


AddPageToCache Method

[image]

.NET ModelKit Suite ClassReference
IReportCache..::.AddPageToCache Method
IReportCache Interface See Also Send Feedback
Saves page data in cash with the set name.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Cache
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
void AddPageToCache(
    string key,
    PageInfo value,
    params Object[] parameters
)
Visual Basic (Declaration)
Sub AddPageToCache ( _
    key As String, _
    value As PageInfo, _
    ParamArray parameters As Object() _
)
Visual C++
void AddPageToCache(
    String^ key,
    PageInfo^ value,
    ... array<Object^>^ parameters
)

Parameters

key
Type: System..::.String
value
Type: PerpetuumSoft.Reporting.Silverlight.Server..::.PageInfo
parameters
Type: array< System..::.Object >[]()[]

See Also

IReportCache Interface
PerpetuumSoft.Reporting.Silverlight.Server.Cache Namespace


GetDocumentFromCache Method

[image]

.NET ModelKit Suite ClassReference
IReportCache..::.GetDocumentFromCache Method
IReportCache Interface See Also Send Feedback
Gets report from cash by name.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Cache
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
Object GetDocumentFromCache(
    string key
)
Visual Basic (Declaration)
Function GetDocumentFromCache ( _
    key As String _
) As Object
Visual C++
Object^ GetDocumentFromCache(
    String^ key
)

Parameters

key
Type: System..::.String

See Also

IReportCache Interface
PerpetuumSoft.Reporting.Silverlight.Server.Cache Namespace


GetPageFromCache Method

[image]

.NET ModelKit Suite ClassReference
IReportCache..::.GetPageFromCache Method
IReportCache Interface See Also Send Feedback
Gets page data from cash by name.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Cache
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
Object GetPageFromCache(
    string key
)
Visual Basic (Declaration)
Function GetPageFromCache ( _
    key As String _
) As Object
Visual C++
Object^ GetPageFromCache(
    String^ key
)

Parameters

key
Type: System..::.String

See Also

IReportCache Interface
PerpetuumSoft.Reporting.Silverlight.Server.Cache Namespace


PerpetuumSoft.Reporting.Silverlight.Server.Exceptions Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Silverlight.Server.Exceptions Namespace
Send Feedback
The PerpetuumSoft.Reporting.Silverlight.Server.Exception namespace contains classes which are exceptions generated by server.

Classes

Class | Description
ExceptionBuilder | Represents a set of methods for exceptions creation.
NoCachedDocumentException | Exceptions are generated when the required document is not found in cash.


ExceptionBuilder Class

[image]

.NET ModelKit Suite ClassReference
ExceptionBuilder Class
Members See Also Send Feedback
Represents a set of methods for exceptions creation.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Exceptions
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static class ExceptionBuilder
Visual Basic (Declaration)
Public NotInheritable Class ExceptionBuilder
Visual C++
public ref class ExceptionBuilder abstract sealed

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Silverlight.Server.Exceptions..::.ExceptionBuilder

See Also

ExceptionBuilder Members
PerpetuumSoft.Reporting.Silverlight.Server.Exceptions Namespace


ExceptionBuilder Members

[image] [image]

.NET ModelKit Suite ClassReference
ExceptionBuilder Members
ExceptionBuilder Class Methods See Also Send Feedback

The ExceptionBuilder type exposes the following members.

Methods

Name | Description
DocumentOutOfCache | Gets the object, exception which indicates that the required document was not found in cash.

See Also

ExceptionBuilder Class
PerpetuumSoft.Reporting.Silverlight.Server.Exceptions Namespace


ExceptionBuilder Methods

[image] [image]

.NET ModelKit Suite ClassReference
ExceptionBuilder Methods
ExceptionBuilder Class See Also Send Feedback

The ExceptionBuilder type exposes the following members.

Methods

Name | Description
DocumentOutOfCache | Gets the object, exception which indicates that the required document was not found in cash.

See Also

ExceptionBuilder Class
PerpetuumSoft.Reporting.Silverlight.Server.Exceptions Namespace


DocumentOutOfCache Method

[image]

.NET ModelKit Suite ClassReference
ExceptionBuilder..::.DocumentOutOfCache Method
ExceptionBuilder Class See Also Send Feedback
Gets the object, exception which indicates that the required document was not found in cash.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Exceptions
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public static Exception DocumentOutOfCache()
Visual Basic (Declaration)
Public Shared Function DocumentOutOfCache As Exception
Visual C++
public:
static Exception^ DocumentOutOfCache()

See Also

ExceptionBuilder Class
PerpetuumSoft.Reporting.Silverlight.Server.Exceptions Namespace


NoCachedDocumentException Class

[image]

.NET ModelKit Suite ClassReference
NoCachedDocumentException Class
Members See Also Send Feedback
Exceptions are generated when the required document is not found in cash.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Exceptions
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
[SerializableAttribute]
public class NoCachedDocumentException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class NoCachedDocumentException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class NoCachedDocumentException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
PerpetuumSoft.Reporting.Silverlight.Server.Exceptions..::.NoCachedDocumentException

See Also

NoCachedDocumentException Members
PerpetuumSoft.Reporting.Silverlight.Server.Exceptions Namespace


NoCachedDocumentException Members

[image] [image]

.NET ModelKit Suite ClassReference
NoCachedDocumentException Members
NoCachedDocumentException Class Constructors Methods Properties See Also Send Feedback

The NoCachedDocumentException type exposes the following members.

Constructors

Name | Description
NoCachedDocumentException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)

See Also

NoCachedDocumentException Class
PerpetuumSoft.Reporting.Silverlight.Server.Exceptions Namespace


NoCachedDocumentException Constructor

[image] [image]

.NET ModelKit Suite ClassReference
NoCachedDocumentException Constructor
NoCachedDocumentException Class See Also Send Feedback

Overload List

Name | Description
NoCachedDocumentException()()() | Initializes a new instance of the NoCachedDocumentException class.
NoCachedDocumentException(String) | Initializes a new instance of the NoCachedDocumentException class.
NoCachedDocumentException(SerializationInfo, StreamingContext) | Initializes a new instance of the NoCachedDocumentException class.
NoCachedDocumentException(String, Exception) | Initializes a new instance of the NoCachedDocumentException class.

See Also

NoCachedDocumentException Class
NoCachedDocumentException Members
PerpetuumSoft.Reporting.Silverlight.Server.Exceptions Namespace


NoCachedDocumentException Constructor

[image]

.NET ModelKit Suite ClassReference
NoCachedDocumentException Constructor
NoCachedDocumentException Class See Also Send Feedback
Initializes a new instance of the NoCachedDocumentException class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Exceptions
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public NoCachedDocumentException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NoCachedDocumentException()

See Also

NoCachedDocumentException Class
NoCachedDocumentException Overload
PerpetuumSoft.Reporting.Silverlight.Server.Exceptions Namespace


NoCachedDocumentException Constructor (String)

[image]

.NET ModelKit Suite ClassReference
NoCachedDocumentException Constructor (String)
NoCachedDocumentException Class See Also Send Feedback
Initializes a new instance of the NoCachedDocumentException class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Exceptions
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public NoCachedDocumentException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
NoCachedDocumentException(
    String^ message
)

Parameters

message
Type: System..::.String

See Also

NoCachedDocumentException Class
NoCachedDocumentException Overload
PerpetuumSoft.Reporting.Silverlight.Server.Exceptions Namespace


NoCachedDocumentException Constructor (SerializationInfo, StreamingContext)

[image]

.NET ModelKit Suite ClassReference
NoCachedDocumentException Constructor (SerializationInfo, StreamingContext)
NoCachedDocumentException Class See Also Send Feedback
Initializes a new instance of the NoCachedDocumentException class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Exceptions
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
protected NoCachedDocumentException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
NoCachedDocumentException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
context
Type: System.Runtime.Serialization..::.StreamingContext

See Also

NoCachedDocumentException Class
NoCachedDocumentException Overload
PerpetuumSoft.Reporting.Silverlight.Server.Exceptions Namespace


NoCachedDocumentException Constructor (String, Exception)

[image]

.NET ModelKit Suite ClassReference
NoCachedDocumentException Constructor (String, Exception)
NoCachedDocumentException Class See Also Send Feedback
Initializes a new instance of the NoCachedDocumentException class.

Namespace: PerpetuumSoft.Reporting.Silverlight.Server.Exceptions
Assembly: PerpetuumSoft.Reporting.Silverlight.Server (in PerpetuumSoft.Reporting.Silverlight.Server.dll) Version: 1.0.1.0 (1.0.1.0)

Syntax

C#
public NoCachedDocumentException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
NoCachedDocumentException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
inner
Type: System..::.Exception

See Also

NoCachedDocumentException Class
NoCachedDocumentException Overload
PerpetuumSoft.Reporting.Silverlight.Server.Exceptions Namespace


NoCachedDocumentException Methods

[image] [image]

.NET ModelKit Suite ClassReference
NoCachedDocumentException Methods
NoCachedDocumentException Class See Also Send Feedback

The NoCachedDocumentException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

NoCachedDocumentException Class
PerpetuumSoft.Reporting.Silverlight.Server.Exceptions Namespace


NoCachedDocumentException Properties

[image] [image]

.NET ModelKit Suite ClassReference
NoCachedDocumentException Properties
NoCachedDocumentException Class See Also Send Feedback

The NoCachedDocumentException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)

See Also

NoCachedDocumentException Class
PerpetuumSoft.Reporting.Silverlight.Server.Exceptions Namespace


PerpetuumSoft.Reporting.View Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.View Namespace
Send Feedback
The PerpetuumSoft.Reporting.View namespace contains classes which are used to view documents.

Classes

Class | Description
FindEventArgs | Provides data for the Find events.
FindForm | A dialog window for searching the text in the document
PageNumberControl | A dialog window for searching page number
PageNumberForm | A dialog window for searching page number
PreviewForm | Defines the default form for reports preview.
ReportViewer | Summary description for Viewer.
ReportViewEventArgs | Provides data for the ReportViewer's events.
ZoomForm | A dialog window for assigning zoom

Structures

Structure | Description
Zoom | Incapsulates viewer zoom properties.

Delegates

Delegate | Description
FindEventHandler | Represents the method that will handle the Find events.
ReportViewEventHandler | Represents the method that will handle the Report Viewer's events.

Enumerations

Enumeration | Description
MouseMode | Modes of the user interaction.
ViewMode | Viewer modes.
ZoomMode | Zooming mode.


FindEventArgs Class

[image]

.NET ModelKit Suite ClassReference
FindEventArgs Class
Members See Also Send Feedback
Provides data for the Find events.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class FindEventArgs : EventArgs
Visual Basic (Declaration)
Public Class FindEventArgs _
    Inherits EventArgs
Visual C++
public ref class FindEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.View..::.FindEventArgs

See Also

FindEventArgs Members
PerpetuumSoft.Reporting.View Namespace


FindEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
FindEventArgs Members
FindEventArgs Class Constructors Methods Properties See Also Send Feedback

The FindEventArgs type exposes the following members.

Constructors

Name | Description
FindEventArgs | Initializes a new instance of FindEventArgs.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FindTextArgument | Gets and sets the search text.

See Also

FindEventArgs Class
PerpetuumSoft.Reporting.View Namespace


FindEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
FindEventArgs Constructor
FindEventArgs Class See Also Send Feedback
Initializes a new instance of FindEventArgs.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FindEventArgs(
    FindTextArgument text
)
Visual Basic (Declaration)
Public Sub New ( _
    text As FindTextArgument _
)
Visual C++
public:
FindEventArgs(
    FindTextArgument^ text
)

Parameters

text
Type: PerpetuumSoft.Reporting.DOM..::.FindTextArgument

See Also

FindEventArgs Class
PerpetuumSoft.Reporting.View Namespace


FindEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
FindEventArgs Methods
FindEventArgs Class See Also Send Feedback

The FindEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FindEventArgs Class
PerpetuumSoft.Reporting.View Namespace


FindEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
FindEventArgs Properties
FindEventArgs Class See Also Send Feedback

The FindEventArgs type exposes the following members.

Properties

Name | Description
FindTextArgument | Gets and sets the search text.

See Also

FindEventArgs Class
PerpetuumSoft.Reporting.View Namespace


FindTextArgument Property

[image]

.NET ModelKit Suite ClassReference
FindEventArgs..::.FindTextArgument Property
FindEventArgs Class See Also Send Feedback
Gets and sets the search text.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FindTextArgument FindTextArgument { get; set; }
Visual Basic (Declaration)
Public Property FindTextArgument As FindTextArgument
Visual C++
public:
property FindTextArgument^ FindTextArgument {
    FindTextArgument^ get ();
    void set (FindTextArgument^ value);
}

See Also

FindEventArgs Class
PerpetuumSoft.Reporting.View Namespace


FindEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
FindEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the Find events.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate void FindEventHandler(
    Object sender,
    FindEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub FindEventHandler ( _
    sender As Object, _
    e As FindEventArgs _
)
Visual C++
public delegate void FindEventHandler(
    Object^ sender,
    FindEventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: PerpetuumSoft.Reporting.View..::.FindEventArgs

See Also

PerpetuumSoft.Reporting.View Namespace


FindForm Class

[image]

.NET ModelKit Suite ClassReference
FindForm Class
Members See Also Send Feedback
A dialog window for searching the text in the document

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class FindForm : Form
Visual Basic (Declaration)
Public Class FindForm _
    Inherits Form
Visual C++
public ref class FindForm : public Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
PerpetuumSoft.Reporting.View..::.FindForm

See Also

FindForm Members
PerpetuumSoft.Reporting.View Namespace


FindForm Members

[image] [image]

.NET ModelKit Suite ClassReference
FindForm Members
FindForm Class Constructors Methods Properties Events See Also Send Feedback

The FindForm type exposes the following members.

Constructors

Name | Description
FindForm | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FindText | Searches the text
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
Find | Is raised if the required text is found
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

FindForm Class
PerpetuumSoft.Reporting.View Namespace


FindForm Constructor

[image] [image]

.NET ModelKit Suite ClassReference
FindForm Constructor
FindForm Class See Also Send Feedback

Overload List

Name | Description
FindForm()()() | Initializes a new instance of the FindForm class.
FindForm(FindTextArgument, FindEventHandler) | Initializes a new instance of the FindForm class.

See Also

FindForm Class
FindForm Members
PerpetuumSoft.Reporting.View Namespace


FindForm Constructor

[image]

.NET ModelKit Suite ClassReference
FindForm Constructor
FindForm Class See Also Send Feedback
Initializes a new instance of the FindForm class.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FindForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FindForm()

See Also

FindForm Class
FindForm Overload
PerpetuumSoft.Reporting.View Namespace


FindForm Constructor (FindTextArgument, FindEventHandler)

[image]

.NET ModelKit Suite ClassReference
FindForm Constructor (FindTextArgument, FindEventHandler)
FindForm Class See Also Send Feedback
Initializes a new instance of the FindForm class.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FindForm(
    FindTextArgument args,
    FindEventHandler find
)
Visual Basic (Declaration)
Public Sub New ( _
    args As FindTextArgument, _
    find As FindEventHandler _
)
Visual C++
public:
FindForm(
    FindTextArgument^ args,
    FindEventHandler^ find
)

Parameters

args
Type: PerpetuumSoft.Reporting.DOM..::.FindTextArgument
find
Type: PerpetuumSoft.Reporting.View..::.FindEventHandler

See Also

FindForm Class
FindForm Overload
PerpetuumSoft.Reporting.View Namespace


FindForm Methods

[image] [image]

.NET ModelKit Suite ClassReference
FindForm Methods
FindForm Class See Also Send Feedback

The FindForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FindText | Searches the text
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

FindForm Class
PerpetuumSoft.Reporting.View Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
FindForm..::.AccessibilityNotifyClients Method
FindForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

FindForm Class
FindForm Members
PerpetuumSoft.Reporting.View Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
FindForm..::.BeginInvoke Method
FindForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

FindForm Class
FindForm Members
PerpetuumSoft.Reporting.View Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
FindForm..::.Dispose Method
FindForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | The Dispose Finalize pattern ensures that resources are released when the object is no longer needed (Overrides Form..::.Dispose(Boolean).)

See Also

FindForm Class
FindForm Members
PerpetuumSoft.Reporting.View Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
FindForm..::.Dispose Method (Boolean)
FindForm Class See Also Send Feedback
The Dispose Finalize pattern ensures that resources are released when the object is no longer needed

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

FindForm Class
Dispose Overload
PerpetuumSoft.Reporting.View Namespace


FindText Method

[image]

.NET ModelKit Suite ClassReference
FindForm..::.FindText Method
FindForm Class See Also Send Feedback
Searches the text

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void FindText(
    bool findNext
)
Visual Basic (Declaration)
Public Sub FindText ( _
    findNext As Boolean _
)
Visual C++
public:
void FindText(
    bool findNext
)

Parameters

findNext
Type: System..::.Boolean

See Also

FindForm Class
PerpetuumSoft.Reporting.View Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
FindForm..::.GetChildAtPoint Method
FindForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

FindForm Class
FindForm Members
PerpetuumSoft.Reporting.View Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
FindForm..::.Invalidate Method
FindForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

FindForm Class
FindForm Members
PerpetuumSoft.Reporting.View Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
FindForm..::.Invoke Method
FindForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

FindForm Class
FindForm Members
PerpetuumSoft.Reporting.View Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
FindForm..::.MemberwiseClone Method
FindForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

FindForm Class
FindForm Members
PerpetuumSoft.Reporting.View Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
FindForm..::.OnLoad Method
FindForm Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

FindForm Class
PerpetuumSoft.Reporting.View Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
FindForm..::.PerformLayout Method
FindForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

FindForm Class
FindForm Members
PerpetuumSoft.Reporting.View Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
FindForm..::.ResumeLayout Method
FindForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

FindForm Class
FindForm Members
PerpetuumSoft.Reporting.View Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
FindForm..::.RtlTranslateAlignment Method
FindForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

FindForm Class
FindForm Members
PerpetuumSoft.Reporting.View Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
FindForm..::.Scale Method
FindForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

FindForm Class
FindForm Members
PerpetuumSoft.Reporting.View Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
FindForm..::.Select Method
FindForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

FindForm Class
FindForm Members
PerpetuumSoft.Reporting.View Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
FindForm..::.SetBounds Method
FindForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

FindForm Class
FindForm Members
PerpetuumSoft.Reporting.View Namespace


Show Method

[image] [image]

.NET ModelKit Suite ClassReference
FindForm..::.Show Method
FindForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

FindForm Class
FindForm Members
PerpetuumSoft.Reporting.View Namespace


ShowDialog Method

[image] [image]

.NET ModelKit Suite ClassReference
FindForm..::.ShowDialog Method
FindForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

FindForm Class
FindForm Members
PerpetuumSoft.Reporting.View Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
FindForm..::.UpdateBounds Method
FindForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

FindForm Class
FindForm Members
PerpetuumSoft.Reporting.View Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
FindForm..::.Validate Method
FindForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

FindForm Class
FindForm Members
PerpetuumSoft.Reporting.View Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
FindForm..::.ValidateChildren Method
FindForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

FindForm Class
FindForm Members
PerpetuumSoft.Reporting.View Namespace


FindForm Properties

[image] [image]

.NET ModelKit Suite ClassReference
FindForm Properties
FindForm Class See Also Send Feedback

The FindForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

FindForm Class
PerpetuumSoft.Reporting.View Namespace


FindForm Events

[image] [image]

.NET ModelKit Suite ClassReference
FindForm Events
FindForm Class See Also Send Feedback

The FindForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
Find | Is raised if the required text is found
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

FindForm Class
PerpetuumSoft.Reporting.View Namespace


Find Event

[image]

.NET ModelKit Suite ClassReference
FindForm..::.Find Event
FindForm Class See Also Send Feedback
Is raised if the required text is found

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event FindEventHandler Find
Visual Basic (Declaration)
Public Event Find As FindEventHandler
Visual C++
public:
 event FindEventHandler^ Find {
    void add (FindEventHandler^ value);
    void remove (FindEventHandler^ value);
}

See Also

FindForm Class
PerpetuumSoft.Reporting.View Namespace


MouseMode Enumeration

[image]

.NET ModelKit Suite ClassReference
MouseMode Enumeration
See Also Send Feedback
Modes of the user interaction.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum MouseMode
Visual Basic (Declaration)
Public Enumeration MouseMode
Visual C++
public enum class MouseMode

Members

Member name | Description
Pan | Pan mode.
ZoomIn | Zoom in mode.
ZoomOut | Zoom out mode.
DynamicZoom | Dynamic zoom mode.
WindowZoom | Window zoom mode.

See Also

PerpetuumSoft.Reporting.View Namespace


PageNumberControl Class

[image]

.NET ModelKit Suite ClassReference
PageNumberControl Class
Members See Also Send Feedback
A dialog window for searching page number

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class PageNumberControl : UserControl
Visual Basic (Declaration)
Public Class PageNumberControl _
    Inherits UserControl
Visual C++
public ref class PageNumberControl : public UserControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Reporting.View..::.PageNumberControl

See Also

PageNumberControl Members
PerpetuumSoft.Reporting.View Namespace


PageNumberControl Members

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl Members
PageNumberControl Class Constructors Methods Properties Events See Also Send Feedback

The PageNumberControl type exposes the following members.

Constructors

Name | Description
PageNumberControl | Initializes a new instance of the PageNumberControl class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
Maximum | Gets or sets maximum page number value
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
PageNumber | Gets or sets page number
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PageNumberControl Class
PerpetuumSoft.Reporting.View Namespace


PageNumberControl Constructor

[image]

.NET ModelKit Suite ClassReference
PageNumberControl Constructor
PageNumberControl Class See Also Send Feedback
Initializes a new instance of the PageNumberControl class.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PageNumberControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageNumberControl()

See Also

PageNumberControl Class
PerpetuumSoft.Reporting.View Namespace


PageNumberControl Methods

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl Methods
PageNumberControl Class See Also Send Feedback

The PageNumberControl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

PageNumberControl Class
PerpetuumSoft.Reporting.View Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.AccessibilityNotifyClients Method
PageNumberControl Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

PageNumberControl Class
PageNumberControl Members
PerpetuumSoft.Reporting.View Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.BeginInvoke Method
PageNumberControl Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

PageNumberControl Class
PageNumberControl Members
PerpetuumSoft.Reporting.View Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.Dispose Method
PageNumberControl Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | The Dispose Finalize pattern ensures that resources are released when the object is no longer needed (Overrides ContainerControl..::.Dispose(Boolean).)

See Also

PageNumberControl Class
PageNumberControl Members
PerpetuumSoft.Reporting.View Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.Dispose Method (Boolean)
PageNumberControl Class See Also Send Feedback
The Dispose Finalize pattern ensures that resources are released when the object is no longer needed

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

PageNumberControl Class
Dispose Overload
PerpetuumSoft.Reporting.View Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.GetChildAtPoint Method
PageNumberControl Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

PageNumberControl Class
PageNumberControl Members
PerpetuumSoft.Reporting.View Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.Invalidate Method
PageNumberControl Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

PageNumberControl Class
PageNumberControl Members
PerpetuumSoft.Reporting.View Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.Invoke Method
PageNumberControl Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

PageNumberControl Class
PageNumberControl Members
PerpetuumSoft.Reporting.View Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.MemberwiseClone Method
PageNumberControl Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PageNumberControl Class
PageNumberControl Members
PerpetuumSoft.Reporting.View Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.OnLoad Method
PageNumberControl Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

PageNumberControl Class
PerpetuumSoft.Reporting.View Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.PerformLayout Method
PageNumberControl Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

PageNumberControl Class
PageNumberControl Members
PerpetuumSoft.Reporting.View Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.ResumeLayout Method
PageNumberControl Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

PageNumberControl Class
PageNumberControl Members
PerpetuumSoft.Reporting.View Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.RtlTranslateAlignment Method
PageNumberControl Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

PageNumberControl Class
PageNumberControl Members
PerpetuumSoft.Reporting.View Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.Scale Method
PageNumberControl Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

PageNumberControl Class
PageNumberControl Members
PerpetuumSoft.Reporting.View Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.Select Method
PageNumberControl Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

PageNumberControl Class
PageNumberControl Members
PerpetuumSoft.Reporting.View Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.SetBounds Method
PageNumberControl Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

PageNumberControl Class
PageNumberControl Members
PerpetuumSoft.Reporting.View Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.UpdateBounds Method
PageNumberControl Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

PageNumberControl Class
PageNumberControl Members
PerpetuumSoft.Reporting.View Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.Validate Method
PageNumberControl Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

PageNumberControl Class
PageNumberControl Members
PerpetuumSoft.Reporting.View Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.ValidateChildren Method
PageNumberControl Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

PageNumberControl Class
PageNumberControl Members
PerpetuumSoft.Reporting.View Namespace


PageNumberControl Properties

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl Properties
PageNumberControl Class See Also Send Feedback

The PageNumberControl type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
Maximum | Gets or sets maximum page number value
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
PageNumber | Gets or sets page number
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

PageNumberControl Class
PerpetuumSoft.Reporting.View Namespace


Maximum Property

[image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.Maximum Property
PageNumberControl Class See Also Send Feedback
Gets or sets maximum page number value

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int Maximum { get; set; }
Visual Basic (Declaration)
Public Property Maximum As Integer
Visual C++
public:
property int Maximum {
    int get ();
    void set (int value);
}

See Also

PageNumberControl Class
PerpetuumSoft.Reporting.View Namespace


PageNumber Property

[image]

.NET ModelKit Suite ClassReference
PageNumberControl..::.PageNumber Property
PageNumberControl Class See Also Send Feedback
Gets or sets page number

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int PageNumber { get; set; }
Visual Basic (Declaration)
Public Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
    void set (int value);
}

See Also

PageNumberControl Class
PerpetuumSoft.Reporting.View Namespace


PageNumberControl Events

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberControl Events
PageNumberControl Class See Also Send Feedback

The PageNumberControl type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PageNumberControl Class
PerpetuumSoft.Reporting.View Namespace


PageNumberForm Class

[image]

.NET ModelKit Suite ClassReference
PageNumberForm Class
Members See Also Send Feedback
A dialog window for searching page number

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class PageNumberForm : Form
Visual Basic (Declaration)
Public Class PageNumberForm _
    Inherits Form
Visual C++
public ref class PageNumberForm : public Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
PerpetuumSoft.Reporting.View..::.PageNumberForm

See Also

PageNumberForm Members
PerpetuumSoft.Reporting.View Namespace


PageNumberForm Members

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm Members
PageNumberForm Class Constructors Methods Properties Events See Also Send Feedback

The PageNumberForm type exposes the following members.

Constructors

Name | Description
PageNumberForm | Initializes a new instance of the PageNumberForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetParams | Sets page number value
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
PageNumber | Gets or sets page number
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PageNumberForm Class
PerpetuumSoft.Reporting.View Namespace


PageNumberForm Constructor

[image]

.NET ModelKit Suite ClassReference
PageNumberForm Constructor
PageNumberForm Class See Also Send Feedback
Initializes a new instance of the PageNumberForm class.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PageNumberForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageNumberForm()

See Also

PageNumberForm Class
PerpetuumSoft.Reporting.View Namespace


PageNumberForm Methods

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm Methods
PageNumberForm Class See Also Send Feedback

The PageNumberForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetParams | Sets page number value
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

PageNumberForm Class
PerpetuumSoft.Reporting.View Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.AccessibilityNotifyClients Method
PageNumberForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

PageNumberForm Class
PageNumberForm Members
PerpetuumSoft.Reporting.View Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.BeginInvoke Method
PageNumberForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

PageNumberForm Class
PageNumberForm Members
PerpetuumSoft.Reporting.View Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.Dispose Method
PageNumberForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | The Dispose Finalize pattern ensures that resources are released when the object is no longer needed (Overrides Form..::.Dispose(Boolean).)

See Also

PageNumberForm Class
PageNumberForm Members
PerpetuumSoft.Reporting.View Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.Dispose Method (Boolean)
PageNumberForm Class See Also Send Feedback
The Dispose Finalize pattern ensures that resources are released when the object is no longer needed

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

PageNumberForm Class
Dispose Overload
PerpetuumSoft.Reporting.View Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.GetChildAtPoint Method
PageNumberForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

PageNumberForm Class
PageNumberForm Members
PerpetuumSoft.Reporting.View Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.Invalidate Method
PageNumberForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

PageNumberForm Class
PageNumberForm Members
PerpetuumSoft.Reporting.View Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.Invoke Method
PageNumberForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

PageNumberForm Class
PageNumberForm Members
PerpetuumSoft.Reporting.View Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.MemberwiseClone Method
PageNumberForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PageNumberForm Class
PageNumberForm Members
PerpetuumSoft.Reporting.View Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.OnLoad Method
PageNumberForm Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

PageNumberForm Class
PerpetuumSoft.Reporting.View Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.PerformLayout Method
PageNumberForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

PageNumberForm Class
PageNumberForm Members
PerpetuumSoft.Reporting.View Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.ResumeLayout Method
PageNumberForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

PageNumberForm Class
PageNumberForm Members
PerpetuumSoft.Reporting.View Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.RtlTranslateAlignment Method
PageNumberForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

PageNumberForm Class
PageNumberForm Members
PerpetuumSoft.Reporting.View Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.Scale Method
PageNumberForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

PageNumberForm Class
PageNumberForm Members
PerpetuumSoft.Reporting.View Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.Select Method
PageNumberForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

PageNumberForm Class
PageNumberForm Members
PerpetuumSoft.Reporting.View Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.SetBounds Method
PageNumberForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

PageNumberForm Class
PageNumberForm Members
PerpetuumSoft.Reporting.View Namespace


SetParams Method

[image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.SetParams Method
PageNumberForm Class See Also Send Feedback
Sets page number value

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void SetParams(
    int currentPage,
    int maxPage
)
Visual Basic (Declaration)
Public Sub SetParams ( _
    currentPage As Integer, _
    maxPage As Integer _
)
Visual C++
public:
void SetParams(
    int currentPage,
    int maxPage
)

Parameters

currentPage
Type: System..::.Int32
maxPage
Type: System..::.Int32

See Also

PageNumberForm Class
PerpetuumSoft.Reporting.View Namespace


Show Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.Show Method
PageNumberForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

PageNumberForm Class
PageNumberForm Members
PerpetuumSoft.Reporting.View Namespace


ShowDialog Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.ShowDialog Method
PageNumberForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

PageNumberForm Class
PageNumberForm Members
PerpetuumSoft.Reporting.View Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.UpdateBounds Method
PageNumberForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

PageNumberForm Class
PageNumberForm Members
PerpetuumSoft.Reporting.View Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.Validate Method
PageNumberForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

PageNumberForm Class
PageNumberForm Members
PerpetuumSoft.Reporting.View Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.ValidateChildren Method
PageNumberForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

PageNumberForm Class
PageNumberForm Members
PerpetuumSoft.Reporting.View Namespace


PageNumberForm Properties

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm Properties
PageNumberForm Class See Also Send Feedback

The PageNumberForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
PageNumber | Gets or sets page number
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

PageNumberForm Class
PerpetuumSoft.Reporting.View Namespace


PageNumber Property

[image]

.NET ModelKit Suite ClassReference
PageNumberForm..::.PageNumber Property
PageNumberForm Class See Also Send Feedback
Gets or sets page number

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int PageNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Integer
Visual C++
public:
property int PageNumber {
    int get ();
}

See Also

PageNumberForm Class
PerpetuumSoft.Reporting.View Namespace


PageNumberForm Events

[image] [image]

.NET ModelKit Suite ClassReference
PageNumberForm Events
PageNumberForm Class See Also Send Feedback

The PageNumberForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PageNumberForm Class
PerpetuumSoft.Reporting.View Namespace


PreviewForm Class

[image]

.NET ModelKit Suite ClassReference
PreviewForm Class
Members See Also Send Feedback
Defines the default form for reports preview.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class PreviewForm : Form
Visual Basic (Declaration)
Public Class PreviewForm _
    Inherits Form
Visual C++
public ref class PreviewForm : public Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
PerpetuumSoft.Reporting.View..::.PreviewForm

See Also

PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


PreviewForm Members

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm Members
PreviewForm Class Constructors Methods Properties Events See Also Send Feedback

The PreviewForm type exposes the following members.

Constructors

Name | Description
PreviewForm | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Overrides Form..::.OnResize(EventArgs).)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ReportViewer | Gets the report viewer contained by the PreviewForm.
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowMenu | Gets and sets if menu will be shown.
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PreviewForm Class
PerpetuumSoft.Reporting.View Namespace


PreviewForm Constructor

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm Constructor
PreviewForm Class See Also Send Feedback

Overload List

Name | Description
PreviewForm()()() | Initializes a new instance of PreviewForm.
PreviewForm(IReportSource) | Initializes a new instance of the PreviewForm class.

See Also

PreviewForm Class
PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


PreviewForm Constructor

[image]

.NET ModelKit Suite ClassReference
PreviewForm Constructor
PreviewForm Class See Also Send Feedback
Initializes a new instance of PreviewForm.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PreviewForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PreviewForm()

See Also

PreviewForm Class
PreviewForm Overload
PerpetuumSoft.Reporting.View Namespace


PreviewForm Constructor (IReportSource)

[image]

.NET ModelKit Suite ClassReference
PreviewForm Constructor (IReportSource)
PreviewForm Class See Also Send Feedback
Initializes a new instance of the PreviewForm class.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PreviewForm(
    IReportSource report
)
Visual Basic (Declaration)
Public Sub New ( _
    report As IReportSource _
)
Visual C++
public:
PreviewForm(
    IReportSource^ report
)

Parameters

report
Type: PerpetuumSoft.Reporting.Components..::.IReportSource

See Also

PreviewForm Class
PreviewForm Overload
PerpetuumSoft.Reporting.View Namespace


PreviewForm Methods

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm Methods
PreviewForm Class See Also Send Feedback

The PreviewForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | Raises the Resize event. (Overrides Form..::.OnResize(EventArgs).)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

PreviewForm Class
PerpetuumSoft.Reporting.View Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm..::.AccessibilityNotifyClients Method
PreviewForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

PreviewForm Class
PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm..::.BeginInvoke Method
PreviewForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

PreviewForm Class
PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm..::.Dispose Method
PreviewForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)

See Also

PreviewForm Class
PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
PreviewForm..::.Dispose Method (Boolean)
PreviewForm Class See Also Send Feedback
Clean up any resources being used.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

PreviewForm Class
Dispose Overload
PerpetuumSoft.Reporting.View Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm..::.GetChildAtPoint Method
PreviewForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

PreviewForm Class
PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm..::.Invalidate Method
PreviewForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

PreviewForm Class
PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm..::.Invoke Method
PreviewForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

PreviewForm Class
PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm..::.MemberwiseClone Method
PreviewForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PreviewForm Class
PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


OnResize Method

[image]

.NET ModelKit Suite ClassReference
PreviewForm..::.OnResize Method
PreviewForm Class See Also Send Feedback
Raises the Resize event.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnResize(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnResize ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnResize(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

PreviewForm Class
PerpetuumSoft.Reporting.View Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm..::.PerformLayout Method
PreviewForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

PreviewForm Class
PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm..::.ResumeLayout Method
PreviewForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

PreviewForm Class
PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm..::.RtlTranslateAlignment Method
PreviewForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

PreviewForm Class
PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm..::.Scale Method
PreviewForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

PreviewForm Class
PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm..::.Select Method
PreviewForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

PreviewForm Class
PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm..::.SetBounds Method
PreviewForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

PreviewForm Class
PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


Show Method

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm..::.Show Method
PreviewForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

PreviewForm Class
PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


ShowDialog Method

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm..::.ShowDialog Method
PreviewForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

PreviewForm Class
PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm..::.UpdateBounds Method
PreviewForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

PreviewForm Class
PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm..::.Validate Method
PreviewForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

PreviewForm Class
PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm..::.ValidateChildren Method
PreviewForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

PreviewForm Class
PreviewForm Members
PerpetuumSoft.Reporting.View Namespace


PreviewForm Properties

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm Properties
PreviewForm Class See Also Send Feedback

The PreviewForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ReportViewer | Gets the report viewer contained by the PreviewForm.
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowMenu | Gets and sets if menu will be shown.
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

PreviewForm Class
PerpetuumSoft.Reporting.View Namespace


ReportViewer Property

[image]

.NET ModelKit Suite ClassReference
PreviewForm..::.ReportViewer Property
PreviewForm Class See Also Send Feedback
Gets the report viewer contained by the PreviewForm.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportViewer ReportViewer { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReportViewer As ReportViewer
Visual C++
public:
property ReportViewer^ ReportViewer {
    ReportViewer^ get ();
}

See Also

PreviewForm Class
PerpetuumSoft.Reporting.View Namespace


ShowMenu Property

[image]

.NET ModelKit Suite ClassReference
PreviewForm..::.ShowMenu Property
PreviewForm Class See Also Send Feedback
Gets and sets if menu will be shown.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowMenu { get; set; }
Visual Basic (Declaration)
Public Property ShowMenu As Boolean
Visual C++
public:
property bool ShowMenu {
    bool get ();
    void set (bool value);
}

See Also

PreviewForm Class
PerpetuumSoft.Reporting.View Namespace


PreviewForm Events

[image] [image]

.NET ModelKit Suite ClassReference
PreviewForm Events
PreviewForm Class See Also Send Feedback

The PreviewForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PreviewForm Class
PerpetuumSoft.Reporting.View Namespace


ReportViewer Class

[image]

.NET ModelKit Suite ClassReference
ReportViewer Class
Members See Also Send Feedback
Summary description for Viewer.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ReportViewer : UserControl
Visual Basic (Declaration)
Public Class ReportViewer _
    Inherits UserControl
Visual C++
public ref class ReportViewer : public UserControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
PerpetuumSoft.Reporting.View..::.ReportViewer

See Also

ReportViewer Members
PerpetuumSoft.Reporting.View Namespace


ReportViewer Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer Members
ReportViewer Class Constructors Methods Properties Events See Also Send Feedback

The ReportViewer type exposes the following members.

Constructors

Name | Description
ReportViewer | Creates new instance of the ReportViewer class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
ChangeReport | Runs designer for the final rendered report.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportReport | Runs the ExportReport dialog.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FindNextText | Finds the next occurence of the current search string.
FindText | Runs the Find Text dialog.
FirstPage | Goes to the first page.
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LastPage | Goes to the last page.
LoadReport | Runs the LoadReport dialog.
MemberwiseClone | Overloaded.
MoveBackward | Moves to the previous position.
MoveForward | Moves to the next position.
NextPage | Goes to the next page.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDocumentLoaded | Called when a document is loaded.
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | 'Performs additional custom processes when loading report viewer. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnViewObjectClick | Raises OnViewObjectClick event.
OnViewObjectDoubleClick | Raises OnViewObjectDoubleClick event.
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreviousPage | Goes to the previous page.
PrintReport | Runs the PrintReport dialog.
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RefreshReport | Refreshes the report document.
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetContextMenu | Resets comtextual menu.
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveReport | Runs the SaveReport dialog.
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetContextMenu | Sets contextual menu in the ReportViewer
SetCurrentPage | Switches preview to the specified page.
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetNewZoom | Sets new zoom
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowCustomZoomDialog | Shows zoom dialog.
ShowGotoPageDialog | Shows pages dialog.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
StartFindText | Finds the first occurrence of the specified text.
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
About | Gets the copyright string.
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Actions | Gets collection of all actions of the ReportViewer.
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Document | Gets current document.
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MouseMode | Gets ansd sets mouse interaction mode.
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
PageIndex | Gets ans sets the number of the displayed page.
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowContent | Gets and sets whether the Content toolbutton should be visible.
ShowDesigner | Gets and sets whether the Designer toolbutton should be visible.
ShowExport | Gets and sets whether the Export toolbutton should be visible.
ShowFind | Gets and sets whether the Find toolbutton should be visible.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowNavigator | Gets and sets whether the Forward and Backward toolbuttons should be visible.
ShowOpen | Gets and sets whether the Open toolbutton should be visible.
ShowPageNavigator | Gets and sets whether the Page Navigation buttons should be visible.
ShowPrint | Gets and sets whether the Print toolbutton should be visible.
ShowRefresh | Gets and sets whether the Refresh toolbutton should be visible.
ShowSave | Gets and sets whether the Save toolbutton should be visible.
ShowScale | Gets and sets whether the Zoom toolbutton should be visible.
ShowStatusBar | Gets and sets whether the Status Bar should be visible.
ShowStatusBarGrip | Gets and sets whether the Status Bar Grip should be visible.
ShowToolBar | Gets and sets whether the ToolBar should be visible.
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
Source | Gets and sets the source for the report document.
StringRegKey | Gets or sets String
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewMode | Gets and sets view mode.
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Zoom | Gets and sets zoom for the report viewer.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DocumentLoaded | Occurs after document load.
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
ViewObjectClick | Occurs when the object is clicked.
ViewObjectDoubleClick | Occurs when the object is double-clicked.
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ReportViewer Constructor

[image]

.NET ModelKit Suite ClassReference
ReportViewer Constructor
ReportViewer Class See Also Send Feedback
Creates new instance of the ReportViewer class.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportViewer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportViewer()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ReportViewer Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer Methods
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
ChangeReport | Runs designer for the final rendered report.
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExportReport | Runs the ExportReport dialog.
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FindNextText | Finds the next occurence of the current search string.
FindText | Runs the Find Text dialog.
FirstPage | Goes to the first page.
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LastPage | Goes to the last page.
LoadReport | Runs the LoadReport dialog.
MemberwiseClone | Overloaded.
MoveBackward | Moves to the previous position.
MoveForward | Moves to the next position.
NextPage | Goes to the next page.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDocumentLoaded | Called when a document is loaded.
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | 'Performs additional custom processes when loading report viewer. (Overrides UserControl..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnViewObjectClick | Raises OnViewObjectClick event.
OnViewObjectDoubleClick | Raises OnViewObjectDoubleClick event.
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreviousPage | Goes to the previous page.
PrintReport | Runs the PrintReport dialog.
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RefreshReport | Refreshes the report document.
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetContextMenu | Resets comtextual menu.
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
SaveReport | Runs the SaveReport dialog.
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetContextMenu | Sets contextual menu in the ReportViewer
SetCurrentPage | Switches preview to the specified page.
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetNewZoom | Sets new zoom
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
ShowCustomZoomDialog | Shows zoom dialog.
ShowGotoPageDialog | Shows pages dialog.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
StartFindText | Finds the first occurrence of the specified text.
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer..::.AccessibilityNotifyClients Method
ReportViewer Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ReportViewer Class
ReportViewer Members
PerpetuumSoft.Reporting.View Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer..::.BeginInvoke Method
ReportViewer Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ReportViewer Class
ReportViewer Members
PerpetuumSoft.Reporting.View Namespace


ChangeReport Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ChangeReport Method
ReportViewer Class See Also Send Feedback
Runs designer for the final rendered report.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void ChangeReport()
Visual Basic (Declaration)
Public Sub ChangeReport
Visual C++
public:
void ChangeReport()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer..::.Dispose Method
ReportViewer Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl..::.Dispose(Boolean).)

See Also

ReportViewer Class
ReportViewer Members
PerpetuumSoft.Reporting.View Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.Dispose Method (Boolean)
ReportViewer Class See Also Send Feedback
Clean up any resources being used.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

ReportViewer Class
Dispose Overload
PerpetuumSoft.Reporting.View Namespace


ExportReport Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ExportReport Method
ReportViewer Class See Also Send Feedback
Runs the ExportReport dialog.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void ExportReport()
Visual Basic (Declaration)
Public Sub ExportReport
Visual C++
public:
void ExportReport()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


FindNextText Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.FindNextText Method
ReportViewer Class See Also Send Feedback
Finds the next occurence of the current search string.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void FindNextText()
Visual Basic (Declaration)
Public Sub FindNextText
Visual C++
public:
void FindNextText()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


FindText Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.FindText Method
ReportViewer Class See Also Send Feedback
Runs the Find Text dialog.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void FindText()
Visual Basic (Declaration)
Public Sub FindText
Visual C++
public:
void FindText()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


FirstPage Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.FirstPage Method
ReportViewer Class See Also Send Feedback
Goes to the first page.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void FirstPage()
Visual Basic (Declaration)
Public Sub FirstPage
Visual C++
public:
void FirstPage()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer..::.GetChildAtPoint Method
ReportViewer Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ReportViewer Class
ReportViewer Members
PerpetuumSoft.Reporting.View Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer..::.Invalidate Method
ReportViewer Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ReportViewer Class
ReportViewer Members
PerpetuumSoft.Reporting.View Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer..::.Invoke Method
ReportViewer Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ReportViewer Class
ReportViewer Members
PerpetuumSoft.Reporting.View Namespace


LastPage Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.LastPage Method
ReportViewer Class See Also Send Feedback
Goes to the last page.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void LastPage()
Visual Basic (Declaration)
Public Sub LastPage
Visual C++
public:
void LastPage()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


LoadReport Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.LoadReport Method
ReportViewer Class See Also Send Feedback
Runs the LoadReport dialog.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void LoadReport()
Visual Basic (Declaration)
Public Sub LoadReport
Visual C++
public:
void LoadReport()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer..::.MemberwiseClone Method
ReportViewer Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ReportViewer Class
ReportViewer Members
PerpetuumSoft.Reporting.View Namespace


MoveBackward Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.MoveBackward Method
ReportViewer Class See Also Send Feedback
Moves to the previous position.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void MoveBackward()
Visual Basic (Declaration)
Public Sub MoveBackward
Visual C++
public:
void MoveBackward()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


MoveForward Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.MoveForward Method
ReportViewer Class See Also Send Feedback
Moves to the next position.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void MoveForward()
Visual Basic (Declaration)
Public Sub MoveForward
Visual C++
public:
void MoveForward()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


NextPage Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.NextPage Method
ReportViewer Class See Also Send Feedback
Goes to the next page.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void NextPage()
Visual Basic (Declaration)
Public Sub NextPage
Visual C++
public:
void NextPage()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


OnDocumentLoaded Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.OnDocumentLoaded Method
ReportViewer Class See Also Send Feedback
Called when a document is loaded.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnDocumentLoaded(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnDocumentLoaded ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnDocumentLoaded(
    EventArgs^ e
)

Parameters

e
Type: System..::.EventArgs

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.OnLoad Method
ReportViewer Class See Also Send Feedback
'Performs additional custom processes when loading report viewer.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


OnViewObjectClick Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.OnViewObjectClick Method
ReportViewer Class See Also Send Feedback
Raises OnViewObjectClick event.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnViewObjectClick(
    ReportViewEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnViewObjectClick ( _
    e As ReportViewEventArgs _
)
Visual C++
protected:
virtual void OnViewObjectClick(
    ReportViewEventArgs^ e
)

Parameters

e
Type: PerpetuumSoft.Reporting.View..::.ReportViewEventArgs

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


OnViewObjectDoubleClick Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.OnViewObjectDoubleClick Method
ReportViewer Class See Also Send Feedback
Raises OnViewObjectDoubleClick event.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void OnViewObjectDoubleClick(
    ReportViewEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnViewObjectDoubleClick ( _
    e As ReportViewEventArgs _
)
Visual C++
protected:
virtual void OnViewObjectDoubleClick(
    ReportViewEventArgs^ e
)

Parameters

e
Type: PerpetuumSoft.Reporting.View..::.ReportViewEventArgs

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer..::.PerformLayout Method
ReportViewer Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ReportViewer Class
ReportViewer Members
PerpetuumSoft.Reporting.View Namespace


PreviousPage Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.PreviousPage Method
ReportViewer Class See Also Send Feedback
Goes to the previous page.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void PreviousPage()
Visual Basic (Declaration)
Public Sub PreviousPage
Visual C++
public:
void PreviousPage()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


PrintReport Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.PrintReport Method
ReportViewer Class See Also Send Feedback
Runs the PrintReport dialog.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void PrintReport()
Visual Basic (Declaration)
Public Sub PrintReport
Visual C++
public:
void PrintReport()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


RefreshReport Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.RefreshReport Method
ReportViewer Class See Also Send Feedback
Refreshes the report document.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void RefreshReport()
Visual Basic (Declaration)
Public Sub RefreshReport
Visual C++
public:
void RefreshReport()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ResetContextMenu Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ResetContextMenu Method
ReportViewer Class See Also Send Feedback
Resets comtextual menu.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void ResetContextMenu()
Visual Basic (Declaration)
Public Sub ResetContextMenu
Visual C++
public:
void ResetContextMenu()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ResumeLayout Method
ReportViewer Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ReportViewer Class
ReportViewer Members
PerpetuumSoft.Reporting.View Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer..::.RtlTranslateAlignment Method
ReportViewer Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ReportViewer Class
ReportViewer Members
PerpetuumSoft.Reporting.View Namespace


SaveReport Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.SaveReport Method
ReportViewer Class See Also Send Feedback
Runs the SaveReport dialog.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void SaveReport()
Visual Basic (Declaration)
Public Sub SaveReport
Visual C++
public:
void SaveReport()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer..::.Scale Method
ReportViewer Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ReportViewer Class
ReportViewer Members
PerpetuumSoft.Reporting.View Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer..::.Select Method
ReportViewer Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ReportViewer Class
ReportViewer Members
PerpetuumSoft.Reporting.View Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer..::.SetBounds Method
ReportViewer Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ReportViewer Class
ReportViewer Members
PerpetuumSoft.Reporting.View Namespace


SetContextMenu Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.SetContextMenu Method
ReportViewer Class See Also Send Feedback
Sets contextual menu in the ReportViewer

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void SetContextMenu(
    ContextMenu contextMenu
)
Visual Basic (Declaration)
Public Sub SetContextMenu ( _
    contextMenu As ContextMenu _
)
Visual C++
public:
void SetContextMenu(
    ContextMenu^ contextMenu
)

Parameters

contextMenu
Type: System.Windows.Forms..::.ContextMenu

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


SetCurrentPage Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.SetCurrentPage Method
ReportViewer Class See Also Send Feedback
Switches preview to the specified page.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void SetCurrentPage(
    int page
)
Visual Basic (Declaration)
Public Sub SetCurrentPage ( _
    page As Integer _
)
Visual C++
public:
void SetCurrentPage(
    int page
)

Parameters

page
Type: System..::.Int32

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


SetNewZoom Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.SetNewZoom Method
ReportViewer Class See Also Send Feedback
Sets new zoom

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void SetNewZoom(
    Zoom zoom
)
Visual Basic (Declaration)
Public Sub SetNewZoom ( _
    zoom As Zoom _
)
Visual C++
public:
void SetNewZoom(
    Zoom zoom
)

Parameters

zoom
Type: PerpetuumSoft.Reporting.View..::.Zoom

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ShowCustomZoomDialog Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ShowCustomZoomDialog Method
ReportViewer Class See Also Send Feedback
Shows zoom dialog.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void ShowCustomZoomDialog()
Visual Basic (Declaration)
Public Sub ShowCustomZoomDialog
Visual C++
public:
void ShowCustomZoomDialog()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ShowGotoPageDialog Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ShowGotoPageDialog Method
ReportViewer Class See Also Send Feedback
Shows pages dialog.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void ShowGotoPageDialog()
Visual Basic (Declaration)
Public Sub ShowGotoPageDialog
Visual C++
public:
void ShowGotoPageDialog()

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


StartFindText Method

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.StartFindText Method
ReportViewer Class See Also Send Feedback
Finds the first occurrence of the specified text.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void StartFindText(
    Object sender,
    FindEventArgs e
)
Visual Basic (Declaration)
Public Sub StartFindText ( _
    sender As Object, _
    e As FindEventArgs _
)
Visual C++
public:
void StartFindText(
    Object^ sender,
    FindEventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: PerpetuumSoft.Reporting.View..::.FindEventArgs

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer..::.UpdateBounds Method
ReportViewer Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ReportViewer Class
ReportViewer Members
PerpetuumSoft.Reporting.View Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer..::.Validate Method
ReportViewer Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ReportViewer Class
ReportViewer Members
PerpetuumSoft.Reporting.View Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ValidateChildren Method
ReportViewer Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ReportViewer Class
ReportViewer Members
PerpetuumSoft.Reporting.View Namespace


ReportViewer Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer Properties
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Properties

Name | Description
About | Gets the copyright string.
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Actions | Gets collection of all actions of the ReportViewer.
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Document | Gets current document.
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MouseMode | Gets ansd sets mouse interaction mode.
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
PageIndex | Gets ans sets the number of the displayed page.
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowContent | Gets and sets whether the Content toolbutton should be visible.
ShowDesigner | Gets and sets whether the Designer toolbutton should be visible.
ShowExport | Gets and sets whether the Export toolbutton should be visible.
ShowFind | Gets and sets whether the Find toolbutton should be visible.
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowNavigator | Gets and sets whether the Forward and Backward toolbuttons should be visible.
ShowOpen | Gets and sets whether the Open toolbutton should be visible.
ShowPageNavigator | Gets and sets whether the Page Navigation buttons should be visible.
ShowPrint | Gets and sets whether the Print toolbutton should be visible.
ShowRefresh | Gets and sets whether the Refresh toolbutton should be visible.
ShowSave | Gets and sets whether the Save toolbutton should be visible.
ShowScale | Gets and sets whether the Zoom toolbutton should be visible.
ShowStatusBar | Gets and sets whether the Status Bar should be visible.
ShowStatusBarGrip | Gets and sets whether the Status Bar Grip should be visible.
ShowToolBar | Gets and sets whether the ToolBar should be visible.
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
Source | Gets and sets the source for the report document.
StringRegKey | Gets or sets String
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
ViewMode | Gets and sets view mode.
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Zoom | Gets and sets zoom for the report viewer.

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


About Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.About Property
ReportViewer Class See Also Send Feedback
Gets the copyright string.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string About { get; }
Visual Basic (Declaration)
Public ReadOnly Property About As String
Visual C++
public:
property String^ About {
    String^ get ();
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


Actions Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.Actions Property
ReportViewer Class See Also Send Feedback
Gets collection of all actions of the ReportViewer.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ActionCollection Actions { get; }
Visual Basic (Declaration)
Public ReadOnly Property Actions As ActionCollection
Visual C++
public:
property ActionCollection^ Actions {
    ActionCollection^ get ();
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


Document Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.Document Property
ReportViewer Class See Also Send Feedback
Gets current document.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Document Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As Document
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


MouseMode Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.MouseMode Property
ReportViewer Class See Also Send Feedback
Gets ansd sets mouse interaction mode.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public MouseMode MouseMode { get; set; }
Visual Basic (Declaration)
Public Property MouseMode As MouseMode
Visual C++
public:
property MouseMode MouseMode {
    MouseMode get ();
    void set (MouseMode value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


PageIndex Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.PageIndex Property
ReportViewer Class See Also Send Feedback
Gets ans sets the number of the displayed page.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int PageIndex { get; set; }
Visual Basic (Declaration)
Public Property PageIndex As Integer
Visual C++
public:
property int PageIndex {
    int get ();
    void set (int value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ShowContent Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ShowContent Property
ReportViewer Class See Also Send Feedback
Gets and sets whether the Content toolbutton should be visible.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowContent { get; set; }
Visual Basic (Declaration)
Public Property ShowContent As Boolean
Visual C++
public:
property bool ShowContent {
    bool get ();
    void set (bool value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ShowDesigner Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ShowDesigner Property
ReportViewer Class See Also Send Feedback
Gets and sets whether the Designer toolbutton should be visible.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowDesigner { get; set; }
Visual Basic (Declaration)
Public Property ShowDesigner As Boolean
Visual C++
public:
property bool ShowDesigner {
    bool get ();
    void set (bool value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ShowExport Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ShowExport Property
ReportViewer Class See Also Send Feedback
Gets and sets whether the Export toolbutton should be visible.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowExport { get; set; }
Visual Basic (Declaration)
Public Property ShowExport As Boolean
Visual C++
public:
property bool ShowExport {
    bool get ();
    void set (bool value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ShowFind Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ShowFind Property
ReportViewer Class See Also Send Feedback
Gets and sets whether the Find toolbutton should be visible.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowFind { get; set; }
Visual Basic (Declaration)
Public Property ShowFind As Boolean
Visual C++
public:
property bool ShowFind {
    bool get ();
    void set (bool value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ShowNavigator Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ShowNavigator Property
ReportViewer Class See Also Send Feedback
Gets and sets whether the Forward and Backward toolbuttons should be visible.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowNavigator { get; set; }
Visual Basic (Declaration)
Public Property ShowNavigator As Boolean
Visual C++
public:
property bool ShowNavigator {
    bool get ();
    void set (bool value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ShowOpen Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ShowOpen Property
ReportViewer Class See Also Send Feedback
Gets and sets whether the Open toolbutton should be visible.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowOpen { get; set; }
Visual Basic (Declaration)
Public Property ShowOpen As Boolean
Visual C++
public:
property bool ShowOpen {
    bool get ();
    void set (bool value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ShowPageNavigator Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ShowPageNavigator Property
ReportViewer Class See Also Send Feedback
Gets and sets whether the Page Navigation buttons should be visible.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowPageNavigator { get; set; }
Visual Basic (Declaration)
Public Property ShowPageNavigator As Boolean
Visual C++
public:
property bool ShowPageNavigator {
    bool get ();
    void set (bool value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ShowPrint Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ShowPrint Property
ReportViewer Class See Also Send Feedback
Gets and sets whether the Print toolbutton should be visible.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowPrint { get; set; }
Visual Basic (Declaration)
Public Property ShowPrint As Boolean
Visual C++
public:
property bool ShowPrint {
    bool get ();
    void set (bool value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ShowRefresh Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ShowRefresh Property
ReportViewer Class See Also Send Feedback
Gets and sets whether the Refresh toolbutton should be visible.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowRefresh { get; set; }
Visual Basic (Declaration)
Public Property ShowRefresh As Boolean
Visual C++
public:
property bool ShowRefresh {
    bool get ();
    void set (bool value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ShowSave Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ShowSave Property
ReportViewer Class See Also Send Feedback
Gets and sets whether the Save toolbutton should be visible.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowSave { get; set; }
Visual Basic (Declaration)
Public Property ShowSave As Boolean
Visual C++
public:
property bool ShowSave {
    bool get ();
    void set (bool value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ShowScale Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ShowScale Property
ReportViewer Class See Also Send Feedback
Gets and sets whether the Zoom toolbutton should be visible.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowScale { get; set; }
Visual Basic (Declaration)
Public Property ShowScale As Boolean
Visual C++
public:
property bool ShowScale {
    bool get ();
    void set (bool value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ShowStatusBar Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ShowStatusBar Property
ReportViewer Class See Also Send Feedback
Gets and sets whether the Status Bar should be visible.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowStatusBar { get; set; }
Visual Basic (Declaration)
Public Property ShowStatusBar As Boolean
Visual C++
public:
property bool ShowStatusBar {
    bool get ();
    void set (bool value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ShowStatusBarGrip Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ShowStatusBarGrip Property
ReportViewer Class See Also Send Feedback
Gets and sets whether the Status Bar Grip should be visible.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowStatusBarGrip { get; set; }
Visual Basic (Declaration)
Public Property ShowStatusBarGrip As Boolean
Visual C++
public:
property bool ShowStatusBarGrip {
    bool get ();
    void set (bool value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ShowToolBar Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ShowToolBar Property
ReportViewer Class See Also Send Feedback
Gets and sets whether the ToolBar should be visible.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowToolBar { get; set; }
Visual Basic (Declaration)
Public Property ShowToolBar As Boolean
Visual C++
public:
property bool ShowToolBar {
    bool get ();
    void set (bool value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


Source Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.Source Property
ReportViewer Class See Also Send Feedback
Gets and sets the source for the report document.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public IReportSource Source { get; set; }
Visual Basic (Declaration)
Public Property Source As IReportSource
Visual C++
public:
property IReportSource^ Source {
    IReportSource^ get ();
    void set (IReportSource^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


StringRegKey Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.StringRegKey Property
ReportViewer Class See Also Send Feedback
Gets or sets String

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string StringRegKey { get; set; }
Visual Basic (Declaration)
Public Property StringRegKey As String
Visual C++
public:
property String^ StringRegKey {
    String^ get ();
    void set (String^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ViewMode Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ViewMode Property
ReportViewer Class See Also Send Feedback
Gets and sets view mode.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ViewMode ViewMode { get; set; }
Visual Basic (Declaration)
Public Property ViewMode As ViewMode
Visual C++
public:
property ViewMode ViewMode {
    ViewMode get ();
    void set (ViewMode value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


Zoom Property

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.Zoom Property
ReportViewer Class See Also Send Feedback
Gets and sets zoom for the report viewer.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Zoom Zoom { get; set; }
Visual Basic (Declaration)
Public Property Zoom As Zoom
Visual C++
public:
property Zoom Zoom {
    Zoom get ();
    void set (Zoom value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ReportViewer Events

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewer Events
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DocumentLoaded | Occurs after document load.
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
ViewObjectClick | Occurs when the object is clicked.
ViewObjectDoubleClick | Occurs when the object is double-clicked.
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


DocumentLoaded Event

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.DocumentLoaded Event
ReportViewer Class See Also Send Feedback
Occurs after document load.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler DocumentLoaded
Visual Basic (Declaration)
Public Event DocumentLoaded As EventHandler
Visual C++
public:
 event EventHandler^ DocumentLoaded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ViewObjectClick Event

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ViewObjectClick Event
ReportViewer Class See Also Send Feedback
Occurs when the object is clicked.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event ReportViewEventHandler ViewObjectClick
Visual Basic (Declaration)
Public Event ViewObjectClick As ReportViewEventHandler
Visual C++
public:
 event ReportViewEventHandler^ ViewObjectClick {
    void add (ReportViewEventHandler^ value);
    void remove (ReportViewEventHandler^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ViewObjectDoubleClick Event

[image]

.NET ModelKit Suite ClassReference
ReportViewer..::.ViewObjectDoubleClick Event
ReportViewer Class See Also Send Feedback
Occurs when the object is double-clicked.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event ReportViewEventHandler ViewObjectDoubleClick
Visual Basic (Declaration)
Public Event ViewObjectDoubleClick As ReportViewEventHandler
Visual C++
public:
 event ReportViewEventHandler^ ViewObjectDoubleClick {
    void add (ReportViewEventHandler^ value);
    void remove (ReportViewEventHandler^ value);
}

See Also

ReportViewer Class
PerpetuumSoft.Reporting.View Namespace


ReportViewEventArgs Class

[image]

.NET ModelKit Suite ClassReference
ReportViewEventArgs Class
Members See Also Send Feedback
Provides data for the ReportViewer's events.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ReportViewEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ReportViewEventArgs _
    Inherits EventArgs
Visual C++
public ref class ReportViewEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.View..::.ReportViewEventArgs

See Also

ReportViewEventArgs Members
PerpetuumSoft.Reporting.View Namespace


ReportViewEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewEventArgs Members
ReportViewEventArgs Class Constructors Methods Properties See Also Send Feedback

The ReportViewEventArgs type exposes the following members.

Constructors

Name | Description
ReportViewEventArgs | Initializes a new instance of the ReportViewEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Control | Gets the associated report control.
Handled | Gets or sets if evant is handled.

See Also

ReportViewEventArgs Class
PerpetuumSoft.Reporting.View Namespace


ReportViewEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
ReportViewEventArgs Constructor
ReportViewEventArgs Class See Also Send Feedback
Initializes a new instance of the ReportViewEventArgs class.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportViewEventArgs(
    ReportControl control
)
Visual Basic (Declaration)
Public Sub New ( _
    control As ReportControl _
)
Visual C++
public:
ReportViewEventArgs(
    ReportControl^ control
)

Parameters

control
Type: PerpetuumSoft.Reporting.DOM..::.ReportControl

See Also

ReportViewEventArgs Class
PerpetuumSoft.Reporting.View Namespace


ReportViewEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewEventArgs Methods
ReportViewEventArgs Class See Also Send Feedback

The ReportViewEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportViewEventArgs Class
PerpetuumSoft.Reporting.View Namespace


ReportViewEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
ReportViewEventArgs Properties
ReportViewEventArgs Class See Also Send Feedback

The ReportViewEventArgs type exposes the following members.

Properties

Name | Description
Control | Gets the associated report control.
Handled | Gets or sets if evant is handled.

See Also

ReportViewEventArgs Class
PerpetuumSoft.Reporting.View Namespace


Control Property

[image]

.NET ModelKit Suite ClassReference
ReportViewEventArgs..::.Control Property
ReportViewEventArgs Class See Also Send Feedback
Gets the associated report control.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ReportControl Control { get; }
Visual Basic (Declaration)
Public ReadOnly Property Control As ReportControl
Visual C++
public:
property ReportControl^ Control {
    ReportControl^ get ();
}

See Also

ReportViewEventArgs Class
PerpetuumSoft.Reporting.View Namespace


Handled Property

[image]

.NET ModelKit Suite ClassReference
ReportViewEventArgs..::.Handled Property
ReportViewEventArgs Class See Also Send Feedback
Gets or sets if evant is handled.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Handled { get; set; }
Visual Basic (Declaration)
Public Property Handled As Boolean
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

See Also

ReportViewEventArgs Class
PerpetuumSoft.Reporting.View Namespace


ReportViewEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
ReportViewEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the Report Viewer's events.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate void ReportViewEventHandler(
    Object Sender,
    ReportViewEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub ReportViewEventHandler ( _
    Sender As Object, _
    e As ReportViewEventArgs _
)
Visual C++
public delegate void ReportViewEventHandler(
    Object^ Sender,
    ReportViewEventArgs^ e
)

Parameters

Sender
Type: System..::.Object
e
Type: PerpetuumSoft.Reporting.View..::.ReportViewEventArgs

See Also

PerpetuumSoft.Reporting.View Namespace


ViewMode Enumeration

[image]

.NET ModelKit Suite ClassReference
ViewMode Enumeration
See Also Send Feedback
Viewer modes.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum ViewMode
Visual Basic (Declaration)
Public Enumeration ViewMode
Visual C++
public enum class ViewMode

Members

Member name | Description
SinglePage | Single page view mode.
ContinuedPage | Continued page view mode.

See Also

PerpetuumSoft.Reporting.View Namespace


Zoom Structure

[image]

.NET ModelKit Suite ClassReference
Zoom Structure
Members See Also Send Feedback
Incapsulates viewer zoom properties.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public struct Zoom
Visual Basic (Declaration)
Public Structure Zoom
Visual C++
public value class Zoom

See Also

Zoom Members
PerpetuumSoft.Reporting.View Namespace


Zoom Members

[image] [image]

.NET ModelKit Suite ClassReference
Zoom Members
Zoom Structure Constructors Methods Properties See Also Send Feedback

The Zoom type exposes the following members.

Constructors

Name | Description
Zoom | Overloaded.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Mode | Gets zooming mode for the current Zoom struct.
Scale | Gets scale value for the current Zoom struct.

See Also

Zoom Structure
PerpetuumSoft.Reporting.View Namespace


Zoom Constructor

[image] [image]

.NET ModelKit Suite ClassReference
Zoom Constructor
Zoom Structure See Also Send Feedback

Overload List

Name | Description
Zoom(ZoomMode) | Creates new instance of the Zoom struct with the specified mode.
Zoom(Double) | Initializes a new instance of the Zoom class.
Zoom(ZoomMode, Double) | Initializes a new instance of the Zoom class.

See Also

Zoom Structure
Zoom Members
PerpetuumSoft.Reporting.View Namespace


Zoom Constructor (ZoomMode)

[image]

.NET ModelKit Suite ClassReference
Zoom Constructor (ZoomMode)
Zoom Structure See Also Send Feedback
Creates new instance of the Zoom struct with the specified mode.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Zoom(
    ZoomMode mode
)
Visual Basic (Declaration)
Public Sub New ( _
    mode As ZoomMode _
)
Visual C++
public:
Zoom(
    ZoomMode mode
)

Parameters

mode
Type: PerpetuumSoft.Reporting.View..::.ZoomMode

See Also

Zoom Structure
Zoom Overload
PerpetuumSoft.Reporting.View Namespace


Zoom Constructor (Double)

[image]

.NET ModelKit Suite ClassReference
Zoom Constructor (Double)
Zoom Structure See Also Send Feedback
Initializes a new instance of the Zoom class.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Zoom(
    double scale
)
Visual Basic (Declaration)
Public Sub New ( _
    scale As Double _
)
Visual C++
public:
Zoom(
    double scale
)

Parameters

scale
Type: System..::.Double

See Also

Zoom Structure
Zoom Overload
PerpetuumSoft.Reporting.View Namespace


Zoom Constructor (ZoomMode, Double)

[image]

.NET ModelKit Suite ClassReference
Zoom Constructor (ZoomMode, Double)
Zoom Structure See Also Send Feedback
Initializes a new instance of the Zoom class.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Zoom(
    ZoomMode mode,
    double scale
)
Visual Basic (Declaration)
Public Sub New ( _
    mode As ZoomMode, _
    scale As Double _
)
Visual C++
public:
Zoom(
    ZoomMode mode,
    double scale
)

Parameters

mode
Type: PerpetuumSoft.Reporting.View..::.ZoomMode
scale
Type: System..::.Double

See Also

Zoom Structure
Zoom Overload
PerpetuumSoft.Reporting.View Namespace


Zoom Methods

[image] [image]

.NET ModelKit Suite ClassReference
Zoom Methods
Zoom Structure See Also Send Feedback

The Zoom type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Zoom Structure
PerpetuumSoft.Reporting.View Namespace


Zoom Properties

[image] [image]

.NET ModelKit Suite ClassReference
Zoom Properties
Zoom Structure See Also Send Feedback

The Zoom type exposes the following members.

Properties

Name | Description
Mode | Gets zooming mode for the current Zoom struct.
Scale | Gets scale value for the current Zoom struct.

See Also

Zoom Structure
PerpetuumSoft.Reporting.View Namespace


Mode Property

[image]

.NET ModelKit Suite ClassReference
Zoom..::.Mode Property
Zoom Structure See Also Send Feedback
Gets zooming mode for the current Zoom struct.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ZoomMode Mode { get; }
Visual Basic (Declaration)
Public ReadOnly Property Mode As ZoomMode
Visual C++
public:
property ZoomMode Mode {
    ZoomMode get ();
}

See Also

Zoom Structure
PerpetuumSoft.Reporting.View Namespace


Scale Property

[image]

.NET ModelKit Suite ClassReference
Zoom..::.Scale Property
Zoom Structure See Also Send Feedback
Gets scale value for the current Zoom struct.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double Scale { get; }
Visual Basic (Declaration)
Public ReadOnly Property Scale As Double
Visual C++
public:
property double Scale {
    double get ();
}

See Also

Zoom Structure
PerpetuumSoft.Reporting.View Namespace


ZoomForm Class

[image]

.NET ModelKit Suite ClassReference
ZoomForm Class
Members See Also Send Feedback
A dialog window for assigning zoom

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ZoomForm : Form
Visual Basic (Declaration)
Public Class ZoomForm _
    Inherits Form
Visual C++
public ref class ZoomForm : public Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
PerpetuumSoft.Reporting.View..::.ZoomForm

See Also

ZoomForm Members
PerpetuumSoft.Reporting.View Namespace


ZoomForm Members

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm Members
ZoomForm Class Constructors Methods Properties Events See Also Send Feedback

The ZoomForm type exposes the following members.

Constructors

Name | Description
ZoomForm | Initializes a new instance of the ZoomForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
ZoomScale | Gets or sets zoom

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ZoomForm Class
PerpetuumSoft.Reporting.View Namespace


ZoomForm Constructor

[image]

.NET ModelKit Suite ClassReference
ZoomForm Constructor
ZoomForm Class See Also Send Feedback
Initializes a new instance of the ZoomForm class.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ZoomForm()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ZoomForm()

See Also

ZoomForm Class
PerpetuumSoft.Reporting.View Namespace


ZoomForm Methods

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm Methods
ZoomForm Class See Also Send Feedback

The ZoomForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Overrides Form..::.OnLoad(EventArgs).)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ZoomForm Class
PerpetuumSoft.Reporting.View Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm..::.AccessibilityNotifyClients Method
ZoomForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ZoomForm Class
ZoomForm Members
PerpetuumSoft.Reporting.View Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm..::.BeginInvoke Method
ZoomForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ZoomForm Class
ZoomForm Members
PerpetuumSoft.Reporting.View Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm..::.Dispose Method
ZoomForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | The Dispose Finalize pattern ensures that resources are released when the object is no longer needed (Overrides Form..::.Dispose(Boolean).)

See Also

ZoomForm Class
ZoomForm Members
PerpetuumSoft.Reporting.View Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
ZoomForm..::.Dispose Method (Boolean)
ZoomForm Class See Also Send Feedback
The Dispose Finalize pattern ensures that resources are released when the object is no longer needed

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

ZoomForm Class
Dispose Overload
PerpetuumSoft.Reporting.View Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm..::.GetChildAtPoint Method
ZoomForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ZoomForm Class
ZoomForm Members
PerpetuumSoft.Reporting.View Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm..::.Invalidate Method
ZoomForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ZoomForm Class
ZoomForm Members
PerpetuumSoft.Reporting.View Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm..::.Invoke Method
ZoomForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ZoomForm Class
ZoomForm Members
PerpetuumSoft.Reporting.View Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm..::.MemberwiseClone Method
ZoomForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ZoomForm Class
ZoomForm Members
PerpetuumSoft.Reporting.View Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
ZoomForm..::.OnLoad Method
ZoomForm Class See Also Send Feedback
Raises the Load event.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

ZoomForm Class
PerpetuumSoft.Reporting.View Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm..::.PerformLayout Method
ZoomForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ZoomForm Class
ZoomForm Members
PerpetuumSoft.Reporting.View Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm..::.ResumeLayout Method
ZoomForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ZoomForm Class
ZoomForm Members
PerpetuumSoft.Reporting.View Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm..::.RtlTranslateAlignment Method
ZoomForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ZoomForm Class
ZoomForm Members
PerpetuumSoft.Reporting.View Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm..::.Scale Method
ZoomForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

ZoomForm Class
ZoomForm Members
PerpetuumSoft.Reporting.View Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm..::.Select Method
ZoomForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

ZoomForm Class
ZoomForm Members
PerpetuumSoft.Reporting.View Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm..::.SetBounds Method
ZoomForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ZoomForm Class
ZoomForm Members
PerpetuumSoft.Reporting.View Namespace


Show Method

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm..::.Show Method
ZoomForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

ZoomForm Class
ZoomForm Members
PerpetuumSoft.Reporting.View Namespace


ShowDialog Method

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm..::.ShowDialog Method
ZoomForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

ZoomForm Class
ZoomForm Members
PerpetuumSoft.Reporting.View Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm..::.UpdateBounds Method
ZoomForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ZoomForm Class
ZoomForm Members
PerpetuumSoft.Reporting.View Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm..::.Validate Method
ZoomForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ZoomForm Class
ZoomForm Members
PerpetuumSoft.Reporting.View Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm..::.ValidateChildren Method
ZoomForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ZoomForm Class
ZoomForm Members
PerpetuumSoft.Reporting.View Namespace


ZoomForm Properties

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm Properties
ZoomForm Class See Also Send Feedback

The ZoomForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
ZoomScale | Gets or sets zoom

See Also

ZoomForm Class
PerpetuumSoft.Reporting.View Namespace


ZoomScale Property

[image]

.NET ModelKit Suite ClassReference
ZoomForm..::.ZoomScale Property
ZoomForm Class See Also Send Feedback
Gets or sets zoom

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public double ZoomScale { get; set; }
Visual Basic (Declaration)
Public Property ZoomScale As Double
Visual C++
public:
property double ZoomScale {
    double get ();
    void set (double value);
}

See Also

ZoomForm Class
PerpetuumSoft.Reporting.View Namespace


ZoomForm Events

[image] [image]

.NET ModelKit Suite ClassReference
ZoomForm Events
ZoomForm Class See Also Send Feedback

The ZoomForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ZoomForm Class
PerpetuumSoft.Reporting.View Namespace


ZoomMode Enumeration

[image]

.NET ModelKit Suite ClassReference
ZoomMode Enumeration
See Also Send Feedback
Zooming mode.

Namespace: PerpetuumSoft.Reporting.View
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum ZoomMode
Visual Basic (Declaration)
Public Enumeration ZoomMode
Visual C++
public enum class ZoomMode

Members

Member name | Description
Scale | Custom scale mode.
WholePage | Whole page mode.
PageWidth | Page width mode.

See Also

PerpetuumSoft.Reporting.View Namespace


PerpetuumSoft.Reporting.Web Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Web Namespace
Send Feedback
The PerpetuumSoft.Reporting.Web namespace contains classes which are used to dysplay a document on Windows Forms.

Classes

Class | Description
Cache |
Cache..::.PageCache |
CsvExportSettings | Represents settings for the export to CSV format.
ExcelExportSettings | Represents settings for the export to Excel.
ExportSettings | Represents export settings.
HtmlExportSettings | Represents settings for the export to HTML.
PdfExportSettings | Represents settings for the export to PDF format.
RtfExportSettings | Represents settings for the export to RTF format.
SharpShooterWebViewer | ASP.NET Viewer Web Control for Report Sharp-Shooter documents.
XpsExportSettings |

Enumerations

Enumeration | Description
PagerPosition | Position of the pager.
ViewMode | Viewer Mode.


Cache Class

[image]

.NET ModelKit Suite ClassReference
Cache Class
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Reporting.Web.Cache]

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public abstract class Cache
Visual Basic (Declaration)
Public MustInherit Class Cache
Visual C++
public ref class Cache abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Web..::.Cache
PerpetuumSoft.Reporting.Web..::.Cache..::.PageCache

See Also

Cache Members
PerpetuumSoft.Reporting.Web Namespace


Cache Members

[image] [image]

.NET ModelKit Suite ClassReference
Cache Members
Cache Class Methods See Also Send Feedback

The Cache type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Get |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Cache Class
PerpetuumSoft.Reporting.Web Namespace


Cache Methods

[image] [image]

.NET ModelKit Suite ClassReference
Cache Methods
Cache Class See Also Send Feedback

The Cache type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Get |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Cache Class
PerpetuumSoft.Reporting.Web Namespace


Get Method

[image]

.NET ModelKit Suite ClassReference
Cache..::.Get Method
Cache Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Web.Cache.Get(System.Web.UI.Page,System.String)]

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public abstract Object Get(
    Page page,
    string key
)
Visual Basic (Declaration)
Public MustOverride Function Get ( _
    page As Page, _
    key As String _
) As Object
Visual C++
public:
virtual Object^ Get(
    Page^ page,
    String^ key
) abstract

Parameters

page
Type: System.Web.UI..::.Page
key
Type: System..::.String

See Also

Cache Class
PerpetuumSoft.Reporting.Web Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
Cache..::.Insert Method
Cache Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Web.Cache.Insert(System.Web.UI.Page,System.String,System.Object,System.TimeSpan)]

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public abstract void Insert(
    Page page,
    string key,
    Object value,
    TimeSpan timeout
)
Visual Basic (Declaration)
Public MustOverride Sub Insert ( _
    page As Page, _
    key As String, _
    value As Object, _
    timeout As TimeSpan _
)
Visual C++
public:
virtual void Insert(
    Page^ page,
    String^ key,
    Object^ value,
    TimeSpan timeout
) abstract

Parameters

page
Type: System.Web.UI..::.Page
key
Type: System..::.String
value
Type: System..::.Object
timeout
Type: System..::.TimeSpan

See Also

Cache Class
PerpetuumSoft.Reporting.Web Namespace


Cache.PageCache Class

[image]

.NET ModelKit Suite ClassReference
Cache..::.PageCache Class
Cache Class Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Reporting.Web.Cache.PageCache]

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public class PageCache : Cache
Visual Basic (Declaration)
Public Class PageCache _
    Inherits Cache
Visual C++
public ref class PageCache : public Cache

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Web..::.Cache
PerpetuumSoft.Reporting.Web..::.Cache..::.PageCache

See Also

Cache..::.PageCache Members
PerpetuumSoft.Reporting.Web Namespace


Cache.PageCache Members

[image] [image]

.NET ModelKit Suite ClassReference
Cache..::.PageCache Members
Cache..::.PageCache Class Constructors Methods See Also Send Feedback

The Cache..::.PageCache type exposes the following members.

Constructors

Name | Description
Cache..::.PageCache | Initializes a new instance of the Cache..::.PageCache class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Get | (Overrides Cache..::.Get(Page, String).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | (Overrides Cache..::.Insert(Page, String, Object, TimeSpan).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Cache..::.PageCache Class
PerpetuumSoft.Reporting.Web Namespace


Cache.PageCache Constructor

[image]

.NET ModelKit Suite ClassReference
Cache..::.PageCache Constructor
Cache..::.PageCache Class See Also Send Feedback
Initializes a new instance of the Cache..::.PageCache class

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public PageCache()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageCache()

See Also

Cache..::.PageCache Class
PerpetuumSoft.Reporting.Web Namespace


Cache.PageCache Methods

[image] [image]

.NET ModelKit Suite ClassReference
Cache..::.PageCache Methods
Cache..::.PageCache Class See Also Send Feedback

The Cache..::.PageCache type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Get | (Overrides Cache..::.Get(Page, String).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | (Overrides Cache..::.Insert(Page, String, Object, TimeSpan).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Cache..::.PageCache Class
PerpetuumSoft.Reporting.Web Namespace


Get Method

[image]

.NET ModelKit Suite ClassReference
Cache..::.PageCache..::.Get Method
Cache..::.PageCache Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Web.Cache.PageCache.Get(System.Web.UI.Page,System.String)]

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public override Object Get(
    Page page,
    string key
)
Visual Basic (Declaration)
Public Overrides Function Get ( _
    page As Page, _
    key As String _
) As Object
Visual C++
public:
virtual Object^ Get(
    Page^ page,
    String^ key
) override

Parameters

page
Type: System.Web.UI..::.Page
key
Type: System..::.String

See Also

Cache..::.PageCache Class
PerpetuumSoft.Reporting.Web Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
Cache..::.PageCache..::.Insert Method
Cache..::.PageCache Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Web.Cache.PageCache.Insert(System.Web.UI.Page,System.String,System.Object,System.TimeSpan)]

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public override void Insert(
    Page page,
    string key,
    Object value,
    TimeSpan timeout
)
Visual Basic (Declaration)
Public Overrides Sub Insert ( _
    page As Page, _
    key As String, _
    value As Object, _
    timeout As TimeSpan _
)
Visual C++
public:
virtual void Insert(
    Page^ page,
    String^ key,
    Object^ value,
    TimeSpan timeout
) override

Parameters

page
Type: System.Web.UI..::.Page
key
Type: System..::.String
value
Type: System..::.Object
timeout
Type: System..::.TimeSpan

See Also

Cache..::.PageCache Class
PerpetuumSoft.Reporting.Web Namespace


CsvExportSettings Class

[image]

.NET ModelKit Suite ClassReference
CsvExportSettings Class
Members See Also Send Feedback
Represents settings for the export to CSV format.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public class CsvExportSettings : ExportSettings
Visual Basic (Declaration)
Public Class CsvExportSettings _
    Inherits ExportSettings
Visual C++
public ref class CsvExportSettings : public ExportSettings

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Web..::.ExportSettings
PerpetuumSoft.Reporting.Web..::.CsvExportSettings

See Also

CsvExportSettings Members
PerpetuumSoft.Reporting.Web Namespace


CsvExportSettings Members

[image] [image]

.NET ModelKit Suite ClassReference
CsvExportSettings Members
CsvExportSettings Class Constructors Methods Properties See Also Send Feedback

The CsvExportSettings type exposes the following members.

Constructors

Name | Description
CsvExportSettings | Initializes a new instance of the CsvExportSettings class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetExportSettings | Overridden. See SetExportSettings(ExportFilter). (Overrides ExportSettings..::.SetExportSettings(ExportFilter).)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
Encoding | Gets or sets export encoding.
ExportMode | Gets or sets ExportMode which represents export mode.
Separator | Gets or sets separator string.

See Also

CsvExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


CsvExportSettings Constructor

[image]

.NET ModelKit Suite ClassReference
CsvExportSettings Constructor
CsvExportSettings Class See Also Send Feedback
Initializes a new instance of the CsvExportSettings class.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public CsvExportSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CsvExportSettings()

See Also

CsvExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


CsvExportSettings Methods

[image] [image]

.NET ModelKit Suite ClassReference
CsvExportSettings Methods
CsvExportSettings Class See Also Send Feedback

The CsvExportSettings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetExportSettings | Overridden. See SetExportSettings(ExportFilter). (Overrides ExportSettings..::.SetExportSettings(ExportFilter).)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

CsvExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


SetExportSettings Method

[image]

.NET ModelKit Suite ClassReference
CsvExportSettings..::.SetExportSettings Method
CsvExportSettings Class See Also Send Feedback
Overridden. See SetExportSettings(ExportFilter).

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public override void SetExportSettings(
    ExportFilter filter
)
Visual Basic (Declaration)
Public Overrides Sub SetExportSettings ( _
    filter As ExportFilter _
)
Visual C++
public:
virtual void SetExportSettings(
    ExportFilter^ filter
) override

Parameters

filter
Type: PerpetuumSoft.Reporting.Export..::.ExportFilter

See Also

CsvExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
CsvExportSettings..::.ToString Method
CsvExportSettings Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

CsvExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


CsvExportSettings Properties

[image] [image]

.NET ModelKit Suite ClassReference
CsvExportSettings Properties
CsvExportSettings Class See Also Send Feedback

The CsvExportSettings type exposes the following members.

Properties

Name | Description
Encoding | Gets or sets export encoding.
ExportMode | Gets or sets ExportMode which represents export mode.
Separator | Gets or sets separator string.

See Also

CsvExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


Encoding Property

[image]

.NET ModelKit Suite ClassReference
CsvExportSettings..::.Encoding Property
CsvExportSettings Class See Also Send Feedback
Gets or sets export encoding.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public Encoding Encoding { get; set; }
Visual Basic (Declaration)
Public Property Encoding As Encoding
Visual C++
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}

See Also

CsvExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ExportMode Property

[image]

.NET ModelKit Suite ClassReference
CsvExportSettings..::.ExportMode Property
CsvExportSettings Class See Also Send Feedback
Gets or sets ExportMode which represents export mode.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public ExportMode ExportMode { get; set; }
Visual Basic (Declaration)
Public Property ExportMode As ExportMode
Visual C++
public:
property ExportMode ExportMode {
    ExportMode get ();
    void set (ExportMode value);
}

See Also

CsvExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


Separator Property

[image]

.NET ModelKit Suite ClassReference
CsvExportSettings..::.Separator Property
CsvExportSettings Class See Also Send Feedback
Gets or sets separator string.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public string Separator { get; set; }
Visual Basic (Declaration)
Public Property Separator As String
Visual C++
public:
property String^ Separator {
    String^ get ();
    void set (String^ value);
}

See Also

CsvExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ExcelExportSettings Class

[image]

.NET ModelKit Suite ClassReference
ExcelExportSettings Class
Members See Also Send Feedback
Represents settings for the export to Excel.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public class ExcelExportSettings : ExportSettings
Visual Basic (Declaration)
Public Class ExcelExportSettings _
    Inherits ExportSettings
Visual C++
public ref class ExcelExportSettings : public ExportSettings

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Web..::.ExportSettings
PerpetuumSoft.Reporting.Web..::.ExcelExportSettings

See Also

ExcelExportSettings Members
PerpetuumSoft.Reporting.Web Namespace


ExcelExportSettings Members

[image] [image]

.NET ModelKit Suite ClassReference
ExcelExportSettings Members
ExcelExportSettings Class Constructors Methods Properties See Also Send Feedback

The ExcelExportSettings type exposes the following members.

Constructors

Name | Description
ExcelExportSettings | Initializes a new instance of the ExcelExportSettings class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetExportSettings | Overridden. See SetExportSettings(ExportFilter). (Overrides ExportSettings..::.SetExportSettings(ExportFilter).)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
Accuracy | Gets or sets accuracy for elements diversity by cells during export to table format.
ExportMode | Gets or sets ExportMode which represents export mode

See Also

ExcelExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ExcelExportSettings Constructor

[image]

.NET ModelKit Suite ClassReference
ExcelExportSettings Constructor
ExcelExportSettings Class See Also Send Feedback
Initializes a new instance of the ExcelExportSettings class.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public ExcelExportSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExcelExportSettings()

See Also

ExcelExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ExcelExportSettings Methods

[image] [image]

.NET ModelKit Suite ClassReference
ExcelExportSettings Methods
ExcelExportSettings Class See Also Send Feedback

The ExcelExportSettings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetExportSettings | Overridden. See SetExportSettings(ExportFilter). (Overrides ExportSettings..::.SetExportSettings(ExportFilter).)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

ExcelExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


SetExportSettings Method

[image]

.NET ModelKit Suite ClassReference
ExcelExportSettings..::.SetExportSettings Method
ExcelExportSettings Class See Also Send Feedback
Overridden. See SetExportSettings(ExportFilter).

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public override void SetExportSettings(
    ExportFilter filter
)
Visual Basic (Declaration)
Public Overrides Sub SetExportSettings ( _
    filter As ExportFilter _
)
Visual C++
public:
virtual void SetExportSettings(
    ExportFilter^ filter
) override

Parameters

filter
Type: PerpetuumSoft.Reporting.Export..::.ExportFilter

See Also

ExcelExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
ExcelExportSettings..::.ToString Method
ExcelExportSettings Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

ExcelExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ExcelExportSettings Properties

[image] [image]

.NET ModelKit Suite ClassReference
ExcelExportSettings Properties
ExcelExportSettings Class See Also Send Feedback

The ExcelExportSettings type exposes the following members.

Properties

Name | Description
Accuracy | Gets or sets accuracy for elements diversity by cells during export to table format.
ExportMode | Gets or sets ExportMode which represents export mode

See Also

ExcelExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


Accuracy Property

[image]

.NET ModelKit Suite ClassReference
ExcelExportSettings..::.Accuracy Property
ExcelExportSettings Class See Also Send Feedback
Gets or sets accuracy for elements diversity by cells during export to table format.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public float Accuracy { get; set; }
Visual Basic (Declaration)
Public Property Accuracy As Single
Visual C++
public:
property float Accuracy {
    float get ();
    void set (float value);
}

See Also

ExcelExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ExportMode Property

[image]

.NET ModelKit Suite ClassReference
ExcelExportSettings..::.ExportMode Property
ExcelExportSettings Class See Also Send Feedback
Gets or sets ExportMode which represents export mode

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public ExportMode ExportMode { get; set; }
Visual Basic (Declaration)
Public Property ExportMode As ExportMode
Visual C++
public:
property ExportMode ExportMode {
    ExportMode get ();
    void set (ExportMode value);
}

See Also

ExcelExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ExportSettings Class

[image]

.NET ModelKit Suite ClassReference
ExportSettings Class
Members See Also Send Feedback
Represents export settings.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public abstract class ExportSettings
Visual Basic (Declaration)
Public MustInherit Class ExportSettings
Visual C++
public ref class ExportSettings abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Web..::.ExportSettings
PerpetuumSoft.Reporting.Web..::.CsvExportSettings
PerpetuumSoft.Reporting.Web..::.ExcelExportSettings
PerpetuumSoft.Reporting.Web..::.HtmlExportSettings
PerpetuumSoft.Reporting.Web..::.PdfExportSettings
PerpetuumSoft.Reporting.Web..::.RtfExportSettings
PerpetuumSoft.Reporting.Web..::.XpsExportSettings

See Also

ExportSettings Members
PerpetuumSoft.Reporting.Web Namespace


ExportSettings Members

[image] [image]

.NET ModelKit Suite ClassReference
ExportSettings Members
ExportSettings Class Constructors Methods See Also Send Feedback

The ExportSettings type exposes the following members.

Constructors

Name | Description
ExportSettings | Initializes a new instance of the ExportSettings class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetExportSettings | Sets export settings.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ExportSettings Constructor

[image]

.NET ModelKit Suite ClassReference
ExportSettings Constructor
ExportSettings Class See Also Send Feedback
Initializes a new instance of the ExportSettings class.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
protected ExportSettings()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ExportSettings()

See Also

ExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ExportSettings Methods

[image] [image]

.NET ModelKit Suite ClassReference
ExportSettings Methods
ExportSettings Class See Also Send Feedback

The ExportSettings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetExportSettings | Sets export settings.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


SetExportSettings Method

[image]

.NET ModelKit Suite ClassReference
ExportSettings..::.SetExportSettings Method
ExportSettings Class See Also Send Feedback
Sets export settings.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public abstract void SetExportSettings(
    ExportFilter filter
)
Visual Basic (Declaration)
Public MustOverride Sub SetExportSettings ( _
    filter As ExportFilter _
)
Visual C++
public:
virtual void SetExportSettings(
    ExportFilter^ filter
) abstract

Parameters

filter
Type: PerpetuumSoft.Reporting.Export..::.ExportFilter

See Also

ExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


HtmlExportSettings Class

[image]

.NET ModelKit Suite ClassReference
HtmlExportSettings Class
Members See Also Send Feedback
Represents settings for the export to HTML.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public sealed class HtmlExportSettings : ExportSettings
Visual Basic (Declaration)
Public NotInheritable Class HtmlExportSettings _
    Inherits ExportSettings
Visual C++
public ref class HtmlExportSettings sealed : public ExportSettings

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Web..::.ExportSettings
PerpetuumSoft.Reporting.Web..::.HtmlExportSettings

See Also

HtmlExportSettings Members
PerpetuumSoft.Reporting.Web Namespace


HtmlExportSettings Members

[image] [image]

.NET ModelKit Suite ClassReference
HtmlExportSettings Members
HtmlExportSettings Class Constructors Methods Properties See Also Send Feedback

The HtmlExportSettings type exposes the following members.

Constructors

Name | Description
HtmlExportSettings | Initializes a new instance of the HtmlExportSettings class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetExportSettings | Overridden. See SetExportSettings(ExportFilter). (Overrides ExportSettings..::.SetExportSettings(ExportFilter).)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
Accuracy | Gets or sets accuracy for elements diversity by cells during export to table format.
ExportMode | Gets or sets ExportMode which represents export mode.
Formatting | Gets or sets Formatting which represents export formatting.
IgnoreBorders | Gets or sets a value indicating whether border settings will be ignored.
IgnoreFills | Gets a value indicating whether the fill settings will be ignored.
IgnoreFonts | Gets or sets a value indicating whether font settings will be ignored.
IgnoreTextAlignment | Gets or sets a value indicating whether text aligment setting will be ignored.
ImagesResolution | Gets or sets image resolution used during export to HTML.
InsertHyperLinks | Gets a value indicating whether the hyperlinks will be inserted into pdf document.
PreserveBlankCells | Gets a value indicating whether blank cells will be preserved.
PreserveLineBreaks | Gets a value indicating whether break lines will be preserved.
PreserveOriginalSizes | Gets or sets a value indicating whether original size will be preserved.
ReplaceWhiteSpaceWithNBSP | Gets a value indicating whether the space symbols will be changed to NBSP simbol.
ResultType | Gets or sets ResultType which represents result file format.
TextObjectOnly | Gets and sets whether only report text content will be exported.

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


HtmlExportSettings Constructor

[image]

.NET ModelKit Suite ClassReference
HtmlExportSettings Constructor
HtmlExportSettings Class See Also Send Feedback
Initializes a new instance of the HtmlExportSettings class.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public HtmlExportSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HtmlExportSettings()

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


HtmlExportSettings Methods

[image] [image]

.NET ModelKit Suite ClassReference
HtmlExportSettings Methods
HtmlExportSettings Class See Also Send Feedback

The HtmlExportSettings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetExportSettings | Overridden. See SetExportSettings(ExportFilter). (Overrides ExportSettings..::.SetExportSettings(ExportFilter).)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


SetExportSettings Method

[image]

.NET ModelKit Suite ClassReference
HtmlExportSettings..::.SetExportSettings Method
HtmlExportSettings Class See Also Send Feedback
Overridden. See SetExportSettings(ExportFilter).

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public override void SetExportSettings(
    ExportFilter filter
)
Visual Basic (Declaration)
Public Overrides Sub SetExportSettings ( _
    filter As ExportFilter _
)
Visual C++
public:
virtual void SetExportSettings(
    ExportFilter^ filter
) override

Parameters

filter
Type: PerpetuumSoft.Reporting.Export..::.ExportFilter

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
HtmlExportSettings..::.ToString Method
HtmlExportSettings Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


HtmlExportSettings Properties

[image] [image]

.NET ModelKit Suite ClassReference
HtmlExportSettings Properties
HtmlExportSettings Class See Also Send Feedback

The HtmlExportSettings type exposes the following members.

Properties

Name | Description
Accuracy | Gets or sets accuracy for elements diversity by cells during export to table format.
ExportMode | Gets or sets ExportMode which represents export mode.
Formatting | Gets or sets Formatting which represents export formatting.
IgnoreBorders | Gets or sets a value indicating whether border settings will be ignored.
IgnoreFills | Gets a value indicating whether the fill settings will be ignored.
IgnoreFonts | Gets or sets a value indicating whether font settings will be ignored.
IgnoreTextAlignment | Gets or sets a value indicating whether text aligment setting will be ignored.
ImagesResolution | Gets or sets image resolution used during export to HTML.
InsertHyperLinks | Gets a value indicating whether the hyperlinks will be inserted into pdf document.
PreserveBlankCells | Gets a value indicating whether blank cells will be preserved.
PreserveLineBreaks | Gets a value indicating whether break lines will be preserved.
PreserveOriginalSizes | Gets or sets a value indicating whether original size will be preserved.
ReplaceWhiteSpaceWithNBSP | Gets a value indicating whether the space symbols will be changed to NBSP simbol.
ResultType | Gets or sets ResultType which represents result file format.
TextObjectOnly | Gets and sets whether only report text content will be exported.

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


Accuracy Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportSettings..::.Accuracy Property
HtmlExportSettings Class See Also Send Feedback
Gets or sets accuracy for elements diversity by cells during export to table format.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public int Accuracy { get; set; }
Visual Basic (Declaration)
Public Property Accuracy As Integer
Visual C++
public:
property int Accuracy {
    int get ();
    void set (int value);
}

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ExportMode Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportSettings..::.ExportMode Property
HtmlExportSettings Class See Also Send Feedback
Gets or sets ExportMode which represents export mode.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public ExportMode ExportMode { get; set; }
Visual Basic (Declaration)
Public Property ExportMode As ExportMode
Visual C++
public:
property ExportMode ExportMode {
    ExportMode get ();
    void set (ExportMode value);
}

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


Formatting Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportSettings..::.Formatting Property
HtmlExportSettings Class See Also Send Feedback
Gets or sets Formatting which represents export formatting.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public Formatting Formatting { get; set; }
Visual Basic (Declaration)
Public Property Formatting As Formatting
Visual C++
public:
property Formatting Formatting {
    Formatting get ();
    void set (Formatting value);
}

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


IgnoreBorders Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportSettings..::.IgnoreBorders Property
HtmlExportSettings Class See Also Send Feedback
Gets or sets a value indicating whether border settings will be ignored.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public bool IgnoreBorders { get; set; }
Visual Basic (Declaration)
Public Property IgnoreBorders As Boolean
Visual C++
public:
property bool IgnoreBorders {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


IgnoreFills Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportSettings..::.IgnoreFills Property
HtmlExportSettings Class See Also Send Feedback
Gets a value indicating whether the fill settings will be ignored.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public bool IgnoreFills { get; set; }
Visual Basic (Declaration)
Public Property IgnoreFills As Boolean
Visual C++
public:
property bool IgnoreFills {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


IgnoreFonts Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportSettings..::.IgnoreFonts Property
HtmlExportSettings Class See Also Send Feedback
Gets or sets a value indicating whether font settings will be ignored.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public bool IgnoreFonts { get; set; }
Visual Basic (Declaration)
Public Property IgnoreFonts As Boolean
Visual C++
public:
property bool IgnoreFonts {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


IgnoreTextAlignment Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportSettings..::.IgnoreTextAlignment Property
HtmlExportSettings Class See Also Send Feedback
Gets or sets a value indicating whether text aligment setting will be ignored.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public bool IgnoreTextAlignment { get; set; }
Visual Basic (Declaration)
Public Property IgnoreTextAlignment As Boolean
Visual C++
public:
property bool IgnoreTextAlignment {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ImagesResolution Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportSettings..::.ImagesResolution Property
HtmlExportSettings Class See Also Send Feedback
Gets or sets image resolution used during export to HTML.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public int ImagesResolution { get; set; }
Visual Basic (Declaration)
Public Property ImagesResolution As Integer
Visual C++
public:
property int ImagesResolution {
    int get ();
    void set (int value);
}

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


InsertHyperLinks Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportSettings..::.InsertHyperLinks Property
HtmlExportSettings Class See Also Send Feedback
Gets a value indicating whether the hyperlinks will be inserted into pdf document.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public bool InsertHyperLinks { get; set; }
Visual Basic (Declaration)
Public Property InsertHyperLinks As Boolean
Visual C++
public:
property bool InsertHyperLinks {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


PreserveBlankCells Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportSettings..::.PreserveBlankCells Property
HtmlExportSettings Class See Also Send Feedback
Gets a value indicating whether blank cells will be preserved.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public bool PreserveBlankCells { get; set; }
Visual Basic (Declaration)
Public Property PreserveBlankCells As Boolean
Visual C++
public:
property bool PreserveBlankCells {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


PreserveLineBreaks Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportSettings..::.PreserveLineBreaks Property
HtmlExportSettings Class See Also Send Feedback
Gets a value indicating whether break lines will be preserved.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public bool PreserveLineBreaks { get; set; }
Visual Basic (Declaration)
Public Property PreserveLineBreaks As Boolean
Visual C++
public:
property bool PreserveLineBreaks {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


PreserveOriginalSizes Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportSettings..::.PreserveOriginalSizes Property
HtmlExportSettings Class See Also Send Feedback
Gets or sets a value indicating whether original size will be preserved.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public bool PreserveOriginalSizes { get; set; }
Visual Basic (Declaration)
Public Property PreserveOriginalSizes As Boolean
Visual C++
public:
property bool PreserveOriginalSizes {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ReplaceWhiteSpaceWithNBSP Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportSettings..::.ReplaceWhiteSpaceWithNBSP Property
HtmlExportSettings Class See Also Send Feedback
Gets a value indicating whether the space symbols will be changed to NBSP simbol.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public bool ReplaceWhiteSpaceWithNBSP { get; set; }
Visual Basic (Declaration)
Public Property ReplaceWhiteSpaceWithNBSP As Boolean
Visual C++
public:
property bool ReplaceWhiteSpaceWithNBSP {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ResultType Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportSettings..::.ResultType Property
HtmlExportSettings Class See Also Send Feedback
Gets or sets ResultType which represents result file format.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public ResultType ResultType { get; set; }
Visual Basic (Declaration)
Public Property ResultType As ResultType
Visual C++
public:
property ResultType ResultType {
    ResultType get ();
    void set (ResultType value);
}

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


TextObjectOnly Property

[image]

.NET ModelKit Suite ClassReference
HtmlExportSettings..::.TextObjectOnly Property
HtmlExportSettings Class See Also Send Feedback
Gets and sets whether only report text content will be exported.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public bool TextObjectOnly { get; set; }
Visual Basic (Declaration)
Public Property TextObjectOnly As Boolean
Visual C++
public:
property bool TextObjectOnly {
    bool get ();
    void set (bool value);
}

See Also

HtmlExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


PagerPosition Enumeration

[image]

.NET ModelKit Suite ClassReference
PagerPosition Enumeration
See Also Send Feedback
Position of the pager.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public enum PagerPosition
Visual Basic (Declaration)
Public Enumeration PagerPosition
Visual C++
public enum class PagerPosition

Members

Member name | Description
Top | At top.
Bottom | At bottom.
Both | At both top and bottom.
None | Don't show pager.

See Also

PerpetuumSoft.Reporting.Web Namespace


PdfExportSettings Class

[image]

.NET ModelKit Suite ClassReference
PdfExportSettings Class
Members See Also Send Feedback
Represents settings for the export to PDF format.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public class PdfExportSettings : ExportSettings
Visual Basic (Declaration)
Public Class PdfExportSettings _
    Inherits ExportSettings
Visual C++
public ref class PdfExportSettings : public ExportSettings

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Web..::.ExportSettings
PerpetuumSoft.Reporting.Web..::.PdfExportSettings

See Also

PdfExportSettings Members
PerpetuumSoft.Reporting.Web Namespace


PdfExportSettings Members

[image] [image]

.NET ModelKit Suite ClassReference
PdfExportSettings Members
PdfExportSettings Class Constructors Methods Properties See Also Send Feedback

The PdfExportSettings type exposes the following members.

Constructors

Name | Description
PdfExportSettings | Initializes a new instance of the PdfExportSettings class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetExportSettings | Overridden. See SetExportSettings(ExportFilter). (Overrides ExportSettings..::.SetExportSettings(ExportFilter).)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
Compress |
EmbedFonts | Gets a value indicating whether fonts used will be embeded into a pdf document.
EmbedPrivateCharacters | Gets a value indicating whether the private characters will be embeded into a pdf document.
ImageQuality | Gets or sets images quality during export to PDF.
ImageResolution | Gets or sets images resolution during export to PDF.
KeepOriginalImageResolutionAndQuality | Gets or sets a value indicating whether images quality and resolution will be used without changes.

See Also

PdfExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


PdfExportSettings Constructor

[image]

.NET ModelKit Suite ClassReference
PdfExportSettings Constructor
PdfExportSettings Class See Also Send Feedback
Initializes a new instance of the PdfExportSettings class.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public PdfExportSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PdfExportSettings()

See Also

PdfExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


PdfExportSettings Methods

[image] [image]

.NET ModelKit Suite ClassReference
PdfExportSettings Methods
PdfExportSettings Class See Also Send Feedback

The PdfExportSettings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetExportSettings | Overridden. See SetExportSettings(ExportFilter). (Overrides ExportSettings..::.SetExportSettings(ExportFilter).)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

PdfExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


SetExportSettings Method

[image]

.NET ModelKit Suite ClassReference
PdfExportSettings..::.SetExportSettings Method
PdfExportSettings Class See Also Send Feedback
Overridden. See SetExportSettings(ExportFilter).

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public override void SetExportSettings(
    ExportFilter filter
)
Visual Basic (Declaration)
Public Overrides Sub SetExportSettings ( _
    filter As ExportFilter _
)
Visual C++
public:
virtual void SetExportSettings(
    ExportFilter^ filter
) override

Parameters

filter
Type: PerpetuumSoft.Reporting.Export..::.ExportFilter

See Also

PdfExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
PdfExportSettings..::.ToString Method
PdfExportSettings Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

PdfExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


PdfExportSettings Properties

[image] [image]

.NET ModelKit Suite ClassReference
PdfExportSettings Properties
PdfExportSettings Class See Also Send Feedback

The PdfExportSettings type exposes the following members.

Properties

Name | Description
Compress |
EmbedFonts | Gets a value indicating whether fonts used will be embeded into a pdf document.
EmbedPrivateCharacters | Gets a value indicating whether the private characters will be embeded into a pdf document.
ImageQuality | Gets or sets images quality during export to PDF.
ImageResolution | Gets or sets images resolution during export to PDF.
KeepOriginalImageResolutionAndQuality | Gets or sets a value indicating whether images quality and resolution will be used without changes.

See Also

PdfExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


Compress Property

[image]

.NET ModelKit Suite ClassReference
PdfExportSettings..::.Compress Property
PdfExportSettings Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.Web.PdfExportSettings.Compress]

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public bool Compress { get; set; }
Visual Basic (Declaration)
Public Property Compress As Boolean
Visual C++
public:
property bool Compress {
    bool get ();
    void set (bool value);
}

See Also

PdfExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


EmbedFonts Property

[image]

.NET ModelKit Suite ClassReference
PdfExportSettings..::.EmbedFonts Property
PdfExportSettings Class See Also Send Feedback
Gets a value indicating whether fonts used will be embeded into a pdf document.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public bool EmbedFonts { get; set; }
Visual Basic (Declaration)
Public Property EmbedFonts As Boolean
Visual C++
public:
property bool EmbedFonts {
    bool get ();
    void set (bool value);
}

See Also

PdfExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


EmbedPrivateCharacters Property

[image]

.NET ModelKit Suite ClassReference
PdfExportSettings..::.EmbedPrivateCharacters Property
PdfExportSettings Class See Also Send Feedback
Gets a value indicating whether the private characters will be embeded into a pdf document.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public bool EmbedPrivateCharacters { get; set; }
Visual Basic (Declaration)
Public Property EmbedPrivateCharacters As Boolean
Visual C++
public:
property bool EmbedPrivateCharacters {
    bool get ();
    void set (bool value);
}

See Also

PdfExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ImageQuality Property

[image]

.NET ModelKit Suite ClassReference
PdfExportSettings..::.ImageQuality Property
PdfExportSettings Class See Also Send Feedback
Gets or sets images quality during export to PDF.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public int ImageQuality { get; set; }
Visual Basic (Declaration)
Public Property ImageQuality As Integer
Visual C++
public:
property int ImageQuality {
    int get ();
    void set (int value);
}

See Also

PdfExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ImageResolution Property

[image]

.NET ModelKit Suite ClassReference
PdfExportSettings..::.ImageResolution Property
PdfExportSettings Class See Also Send Feedback
Gets or sets images resolution during export to PDF.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public int ImageResolution { get; set; }
Visual Basic (Declaration)
Public Property ImageResolution As Integer
Visual C++
public:
property int ImageResolution {
    int get ();
    void set (int value);
}

See Also

PdfExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


KeepOriginalImageResolutionAndQuality Property

[image]

.NET ModelKit Suite ClassReference
PdfExportSettings..::.KeepOriginalImageResolutionAndQuality Property
PdfExportSettings Class See Also Send Feedback
Gets or sets a value indicating whether images quality and resolution will be used without changes.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public bool KeepOriginalImageResolutionAndQuality { get; set; }
Visual Basic (Declaration)
Public Property KeepOriginalImageResolutionAndQuality As Boolean
Visual C++
public:
property bool KeepOriginalImageResolutionAndQuality {
    bool get ();
    void set (bool value);
}

See Also

PdfExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


RtfExportSettings Class

[image]

.NET ModelKit Suite ClassReference
RtfExportSettings Class
Members See Also Send Feedback
Represents settings for the export to RTF format.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public class RtfExportSettings : ExportSettings
Visual Basic (Declaration)
Public Class RtfExportSettings _
    Inherits ExportSettings
Visual C++
public ref class RtfExportSettings : public ExportSettings

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Web..::.ExportSettings
PerpetuumSoft.Reporting.Web..::.RtfExportSettings

See Also

RtfExportSettings Members
PerpetuumSoft.Reporting.Web Namespace


RtfExportSettings Members

[image] [image]

.NET ModelKit Suite ClassReference
RtfExportSettings Members
RtfExportSettings Class Constructors Methods Properties See Also Send Feedback

The RtfExportSettings type exposes the following members.

Constructors

Name | Description
RtfExportSettings | Initializes a new instance of the RtfExportSettings class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetExportSettings | Overridden. See SetExportSettings(ExportFilter). (Overrides ExportSettings..::.SetExportSettings(ExportFilter).)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

Properties

Name | Description
Accuracy | Gets or sets accuracy for elements diversity by cells during export to table format.

See Also

RtfExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


RtfExportSettings Constructor

[image]

.NET ModelKit Suite ClassReference
RtfExportSettings Constructor
RtfExportSettings Class See Also Send Feedback
Initializes a new instance of the RtfExportSettings class.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public RtfExportSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RtfExportSettings()

See Also

RtfExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


RtfExportSettings Methods

[image] [image]

.NET ModelKit Suite ClassReference
RtfExportSettings Methods
RtfExportSettings Class See Also Send Feedback

The RtfExportSettings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetExportSettings | Overridden. See SetExportSettings(ExportFilter). (Overrides ExportSettings..::.SetExportSettings(ExportFilter).)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)

See Also

RtfExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


SetExportSettings Method

[image]

.NET ModelKit Suite ClassReference
RtfExportSettings..::.SetExportSettings Method
RtfExportSettings Class See Also Send Feedback
Overridden. See SetExportSettings(ExportFilter).

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public override void SetExportSettings(
    ExportFilter filter
)
Visual Basic (Declaration)
Public Overrides Sub SetExportSettings ( _
    filter As ExportFilter _
)
Visual C++
public:
virtual void SetExportSettings(
    ExportFilter^ filter
) override

Parameters

filter
Type: PerpetuumSoft.Reporting.Export..::.ExportFilter

See Also

RtfExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
RtfExportSettings..::.ToString Method
RtfExportSettings Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

RtfExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


RtfExportSettings Properties

[image] [image]

.NET ModelKit Suite ClassReference
RtfExportSettings Properties
RtfExportSettings Class See Also Send Feedback

The RtfExportSettings type exposes the following members.

Properties

Name | Description
Accuracy | Gets or sets accuracy for elements diversity by cells during export to table format.

See Also

RtfExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


Accuracy Property

[image]

.NET ModelKit Suite ClassReference
RtfExportSettings..::.Accuracy Property
RtfExportSettings Class See Also Send Feedback
Gets or sets accuracy for elements diversity by cells during export to table format.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public float Accuracy { get; set; }
Visual Basic (Declaration)
Public Property Accuracy As Single
Visual C++
public:
property float Accuracy {
    float get ();
    void set (float value);
}

See Also

RtfExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


SharpShooterWebViewer Class

[image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer Class
Members See Also Send Feedback
ASP.NET Viewer Web Control for Report Sharp-Shooter documents.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public class SharpShooterWebViewer : WebControl
Visual Basic (Declaration)
Public Class SharpShooterWebViewer _
    Inherits WebControl
Visual C++
public ref class SharpShooterWebViewer : public WebControl

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI.WebControls..::.WebControl
PerpetuumSoft.Reporting.Web..::.SharpShooterWebViewer

See Also

SharpShooterWebViewer Members
PerpetuumSoft.Reporting.Web Namespace


SharpShooterWebViewer Members

[image] [image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer Members
SharpShooterWebViewer Class Constructors Methods Properties Events See Also Send Feedback

The SharpShooterWebViewer type exposes the following members.

Constructors

Name | Description
SharpShooterWebViewer | Initializes a new instance of the SharpShooterWebViewer class.

Methods

Name | Description
AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnInit | Overrides inherited OnInit method. (Overrides Control..::.OnInit(EventArgs).)
OnLoad | Overrides inherited OnLoad method. (Overrides Control..::.OnLoad(EventArgs).)
OnPreRender | Overrides inherited OnPreRender method. (Overrides Control..::.OnPreRender(EventArgs).)
OnUnload | Raises the Unload event. (Inherited from Control.)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderContents | Render this control to the output parameter specified. (Overrides WebControl..::.RenderContents(HtmlTextWriter).)
RenderControl | Overloaded.
RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
ResetCachedDocument | Clears report cache.
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SaveViewState | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

Properties

Name | Description
AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Cache |
CachedReportName | Gets and sets id for cache item which contains report.
CacheTimeOut | Gets and sets cache timeout (how long report sholud be keeped in cache).
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
CsvExportSettings | Gets CsvExportSettings
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
ExcelExportSettings | Gets ExcelExportSettings
Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
HtmlExportSettings | Gets HtmlExportSettings
ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
ImageFormat | Gets and sets Image Format for html report converter.
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
PdfExportSettings | Gets PdfExportSettings
RtfExportSettings | Gets RtfExportSettings
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Source | Gets and sets the source for the report document.
Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
ViewMode | Gets and sets viewer mode.
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
XpsExportSetting |

Events

Name | Description
DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


SharpShooterWebViewer Constructor

[image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer Constructor
SharpShooterWebViewer Class See Also Send Feedback
Initializes a new instance of the SharpShooterWebViewer class.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public SharpShooterWebViewer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SharpShooterWebViewer()

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


SharpShooterWebViewer Methods

[image] [image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer Methods
SharpShooterWebViewer Class See Also Send Feedback

The SharpShooterWebViewer type exposes the following members.

Methods

Name | Description
AddAttributesToRender | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateControlStyle | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadViewState | Restores view-state information from a previous request that was saved with the SaveViewState()()() method. (Inherited from WebControl.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnInit | Overrides inherited OnInit method. (Overrides Control..::.OnInit(EventArgs).)
OnLoad | Overrides inherited OnLoad method. (Overrides Control..::.OnLoad(EventArgs).)
OnPreRender | Overrides inherited OnPreRender method. (Overrides Control..::.OnPreRender(EventArgs).)
OnUnload | Raises the Unload event. (Inherited from Control.)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Render | Renders the control to the specified HTML writer. (Inherited from WebControl.)
RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderContents | Render this control to the output parameter specified. (Overrides WebControl..::.RenderContents(HtmlTextWriter).)
RenderControl | Overloaded.
RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
ResetCachedDocument | Clears report cache.
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SaveViewState | Saves any state that was modified after the TrackViewState()()() method was invoked. (Inherited from WebControl.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


DataBind Method

[image] [image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.DataBind Method
SharpShooterWebViewer Class See Also Send Feedback

Overload List

Name | Description
DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

SharpShooterWebViewer Class
SharpShooterWebViewer Members
PerpetuumSoft.Reporting.Web Namespace


FindControl Method

[image] [image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.FindControl Method
SharpShooterWebViewer Class See Also Send Feedback

Overload List

Name | Description
FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)

See Also

SharpShooterWebViewer Class
SharpShooterWebViewer Members
PerpetuumSoft.Reporting.Web Namespace


OnInit Method

[image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.OnInit Method
SharpShooterWebViewer Class See Also Send Feedback
Overrides inherited OnInit method.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnInit(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnInit ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnInit(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


OnLoad Method

[image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.OnLoad Method
SharpShooterWebViewer Class See Also Send Feedback
Overrides inherited OnLoad method.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLoad(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


OnPreRender Method

[image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.OnPreRender Method
SharpShooterWebViewer Class See Also Send Feedback
Overrides inherited OnPreRender method.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnPreRender(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnPreRender ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnPreRender(
    EventArgs^ e
) override

Parameters

e
Type: System..::.EventArgs

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


RenderContents Method

[image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.RenderContents Method
SharpShooterWebViewer Class See Also Send Feedback
Render this control to the output parameter specified.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
protected override void RenderContents(
    HtmlTextWriter output
)
Visual Basic (Declaration)
Protected Overrides Sub RenderContents ( _
    output As HtmlTextWriter _
)
Visual C++
protected:
virtual void RenderContents(
    HtmlTextWriter^ output
) override

Parameters

output
Type: System.Web.UI..::.HtmlTextWriter

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


RenderControl Method

[image] [image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.RenderControl Method
SharpShooterWebViewer Class See Also Send Feedback

Overload List

Name | Description
RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

SharpShooterWebViewer Class
SharpShooterWebViewer Members
PerpetuumSoft.Reporting.Web Namespace


ResetCachedDocument Method

[image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.ResetCachedDocument Method
SharpShooterWebViewer Class See Also Send Feedback
Clears report cache.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public void ResetCachedDocument()
Visual Basic (Declaration)
Public Sub ResetCachedDocument
Visual C++
public:
void ResetCachedDocument()

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


SharpShooterWebViewer Properties

[image] [image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer Properties
SharpShooterWebViewer Class See Also Send Feedback

The SharpShooterWebViewer type exposes the following members.

Properties

Name | Description
AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
Cache |
CachedReportName | Gets and sets id for cache item which contains report.
CacheTimeOut | Gets and sets cache timeout (how long report sholud be keeped in cache).
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
CsvExportSettings | Gets CsvExportSettings
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
ExcelExportSettings | Gets ExcelExportSettings
Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
HtmlExportSettings | Gets HtmlExportSettings
ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
ImageFormat | Gets and sets Image Format for html report converter.
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
PdfExportSettings | Gets PdfExportSettings
RtfExportSettings | Gets RtfExportSettings
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
Source | Gets and sets the source for the report document.
Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
ViewMode | Gets and sets viewer mode.
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
XpsExportSetting |

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


Cache Property

[image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.Cache Property
SharpShooterWebViewer Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.Web.SharpShooterWebViewer.Cache]

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public Cache Cache { get; set; }
Visual Basic (Declaration)
Public Property Cache As Cache
Visual C++
public:
property Cache^ Cache {
    Cache^ get ();
    void set (Cache^ value);
}

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


CachedReportName Property

[image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.CachedReportName Property
SharpShooterWebViewer Class See Also Send Feedback
Gets and sets id for cache item which contains report.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public string CachedReportName { get; set; }
Visual Basic (Declaration)
Public Property CachedReportName As String
Visual C++
public:
property String^ CachedReportName {
    String^ get ();
    void set (String^ value);
}

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


CacheTimeOut Property

[image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.CacheTimeOut Property
SharpShooterWebViewer Class See Also Send Feedback
Gets and sets cache timeout (how long report sholud be keeped in cache).

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public TimeSpan CacheTimeOut { get; set; }
Visual Basic (Declaration)
Public Property CacheTimeOut As TimeSpan
Visual C++
public:
property TimeSpan CacheTimeOut {
    TimeSpan get ();
    void set (TimeSpan value);
}

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


CsvExportSettings Property

[image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.CsvExportSettings Property
SharpShooterWebViewer Class See Also Send Feedback
Gets CsvExportSettings

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public CsvExportSettings CsvExportSettings { get; }
Visual Basic (Declaration)
Public ReadOnly Property CsvExportSettings As CsvExportSettings
Visual C++
public:
property CsvExportSettings^ CsvExportSettings {
    CsvExportSettings^ get ();
}

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


ExcelExportSettings Property

[image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.ExcelExportSettings Property
SharpShooterWebViewer Class See Also Send Feedback
Gets ExcelExportSettings

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public ExcelExportSettings ExcelExportSettings { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExcelExportSettings As ExcelExportSettings
Visual C++
public:
property ExcelExportSettings^ ExcelExportSettings {
    ExcelExportSettings^ get ();
}

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


HtmlExportSettings Property

[image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.HtmlExportSettings Property
SharpShooterWebViewer Class See Also Send Feedback
Gets HtmlExportSettings

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public HtmlExportSettings HtmlExportSettings { get; }
Visual Basic (Declaration)
Public ReadOnly Property HtmlExportSettings As HtmlExportSettings
Visual C++
public:
property HtmlExportSettings^ HtmlExportSettings {
    HtmlExportSettings^ get ();
}

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


ImageFormat Property

[image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.ImageFormat Property
SharpShooterWebViewer Class See Also Send Feedback
Gets and sets Image Format for html report converter.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public ImageFormat ImageFormat { get; set; }
Visual Basic (Declaration)
Public Property ImageFormat As ImageFormat
Visual C++
public:
property ImageFormat^ ImageFormat {
    ImageFormat^ get ();
    void set (ImageFormat^ value);
}

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


PdfExportSettings Property

[image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.PdfExportSettings Property
SharpShooterWebViewer Class See Also Send Feedback
Gets PdfExportSettings

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public PdfExportSettings PdfExportSettings { get; }
Visual Basic (Declaration)
Public ReadOnly Property PdfExportSettings As PdfExportSettings
Visual C++
public:
property PdfExportSettings^ PdfExportSettings {
    PdfExportSettings^ get ();
}

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


RtfExportSettings Property

[image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.RtfExportSettings Property
SharpShooterWebViewer Class See Also Send Feedback
Gets RtfExportSettings

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public RtfExportSettings RtfExportSettings { get; }
Visual Basic (Declaration)
Public ReadOnly Property RtfExportSettings As RtfExportSettings
Visual C++
public:
property RtfExportSettings^ RtfExportSettings {
    RtfExportSettings^ get ();
}

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


Source Property

[image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.Source Property
SharpShooterWebViewer Class See Also Send Feedback
Gets and sets the source for the report document.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public Object Source { get; set; }
Visual Basic (Declaration)
Public Property Source As Object
Visual C++
public:
property Object^ Source {
    Object^ get ();
    void set (Object^ value);
}

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


ViewMode Property

[image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.ViewMode Property
SharpShooterWebViewer Class See Also Send Feedback
Gets and sets viewer mode.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public ViewMode ViewMode { get; set; }
Visual Basic (Declaration)
Public Property ViewMode As ViewMode
Visual C++
public:
property ViewMode ViewMode {
    ViewMode get ();
    void set (ViewMode value);
}

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


XpsExportSetting Property

[image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer..::.XpsExportSetting Property
SharpShooterWebViewer Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.Web.SharpShooterWebViewer.XpsExportSetting]

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public XpsExportSettings XpsExportSetting { get; }
Visual Basic (Declaration)
Public ReadOnly Property XpsExportSetting As XpsExportSettings
Visual C++
public:
property XpsExportSettings^ XpsExportSetting {
    XpsExportSettings^ get ();
}

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


SharpShooterWebViewer Events

[image] [image]

.NET ModelKit Suite ClassReference
SharpShooterWebViewer Events
SharpShooterWebViewer Class See Also Send Feedback

The SharpShooterWebViewer type exposes the following members.

Events

Name | Description
DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

See Also

SharpShooterWebViewer Class
PerpetuumSoft.Reporting.Web Namespace


ViewMode Enumeration

[image]

.NET ModelKit Suite ClassReference
ViewMode Enumeration
See Also Send Feedback
Viewer Mode.

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public enum ViewMode
Visual Basic (Declaration)
Public Enumeration ViewMode
Visual C++
public enum class ViewMode

Members

Member name | Description
HtmlSinglePage | Show single page in Html format.
HtmlWholeReport | Show whole report in Html format.
WindowsForms | Place Windows Forms Viewer inside page.
PdfWholeReport | Shows the whole report in PDF format.

See Also

PerpetuumSoft.Reporting.Web Namespace


XpsExportSettings Class

[image]

.NET ModelKit Suite ClassReference
XpsExportSettings Class
Members See Also Send Feedback

[Missing <summary> documentation for T:PerpetuumSoft.Reporting.Web.XpsExportSettings]

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public class XpsExportSettings : ExportSettings
Visual Basic (Declaration)
Public Class XpsExportSettings _
    Inherits ExportSettings
Visual C++
public ref class XpsExportSettings : public ExportSettings

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Web..::.ExportSettings
PerpetuumSoft.Reporting.Web..::.XpsExportSettings

See Also

XpsExportSettings Members
PerpetuumSoft.Reporting.Web Namespace


XpsExportSettings Members

[image] [image]

.NET ModelKit Suite ClassReference
XpsExportSettings Members
XpsExportSettings Class Constructors Methods Properties See Also Send Feedback

The XpsExportSettings type exposes the following members.

Constructors

Name | Description
XpsExportSettings | Initializes a new instance of the XpsExportSettings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetExportSettings | (Overrides ExportSettings..::.SetExportSettings(ExportFilter).)
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
DocumentCompressionOption |
ExtraParameters |
ImageResolution |
KeepOriginalImageResolution |
PagesRange |
ReplaceFill |

See Also

XpsExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


XpsExportSettings Constructor

[image]

.NET ModelKit Suite ClassReference
XpsExportSettings Constructor
XpsExportSettings Class See Also Send Feedback
Initializes a new instance of the XpsExportSettings class

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public XpsExportSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XpsExportSettings()

See Also

XpsExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


XpsExportSettings Methods

[image] [image]

.NET ModelKit Suite ClassReference
XpsExportSettings Methods
XpsExportSettings Class See Also Send Feedback

The XpsExportSettings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetExportSettings | (Overrides ExportSettings..::.SetExportSettings(ExportFilter).)
ToString | (Overrides Object..::.ToString()()().)

See Also

XpsExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


SetExportSettings Method

[image]

.NET ModelKit Suite ClassReference
XpsExportSettings..::.SetExportSettings Method
XpsExportSettings Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Web.XpsExportSettings.SetExportSettings(PerpetuumSoft.Reporting.Export.ExportFilter)]

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public override void SetExportSettings(
    ExportFilter filter
)
Visual Basic (Declaration)
Public Overrides Sub SetExportSettings ( _
    filter As ExportFilter _
)
Visual C++
public:
virtual void SetExportSettings(
    ExportFilter^ filter
) override

Parameters

filter
Type: PerpetuumSoft.Reporting.Export..::.ExportFilter

See Also

XpsExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
XpsExportSettings..::.ToString Method
XpsExportSettings Class See Also Send Feedback

[Missing <summary> documentation for M:PerpetuumSoft.Reporting.Web.XpsExportSettings.ToString]

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

XpsExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


XpsExportSettings Properties

[image] [image]

.NET ModelKit Suite ClassReference
XpsExportSettings Properties
XpsExportSettings Class See Also Send Feedback

The XpsExportSettings type exposes the following members.

Properties

Name | Description
DocumentCompressionOption |
ExtraParameters |
ImageResolution |
KeepOriginalImageResolution |
PagesRange |
ReplaceFill |

See Also

XpsExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


DocumentCompressionOption Property

[image]

.NET ModelKit Suite ClassReference
XpsExportSettings..::.DocumentCompressionOption Property
XpsExportSettings Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.Web.XpsExportSettings.DocumentCompressionOption]

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public CompressionOptions DocumentCompressionOption { get; set; }
Visual Basic (Declaration)
Public Property DocumentCompressionOption As CompressionOptions
Visual C++
public:
property CompressionOptions DocumentCompressionOption {
    CompressionOptions get ();
    void set (CompressionOptions value);
}

See Also

XpsExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ExtraParameters Property

[image]

.NET ModelKit Suite ClassReference
XpsExportSettings..::.ExtraParameters Property
XpsExportSettings Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.Web.XpsExportSettings.ExtraParameters]

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public ExtraParameters ExtraParameters { get; set; }
Visual Basic (Declaration)
Public Property ExtraParameters As ExtraParameters
Visual C++
public:
property ExtraParameters^ ExtraParameters {
    ExtraParameters^ get ();
    void set (ExtraParameters^ value);
}

See Also

XpsExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ImageResolution Property

[image]

.NET ModelKit Suite ClassReference
XpsExportSettings..::.ImageResolution Property
XpsExportSettings Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.Web.XpsExportSettings.ImageResolution]

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public int ImageResolution { get; set; }
Visual Basic (Declaration)
Public Property ImageResolution As Integer
Visual C++
public:
property int ImageResolution {
    int get ();
    void set (int value);
}

See Also

XpsExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


KeepOriginalImageResolution Property

[image]

.NET ModelKit Suite ClassReference
XpsExportSettings..::.KeepOriginalImageResolution Property
XpsExportSettings Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.Web.XpsExportSettings.KeepOriginalImageResolution]

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public bool KeepOriginalImageResolution { get; set; }
Visual Basic (Declaration)
Public Property KeepOriginalImageResolution As Boolean
Visual C++
public:
property bool KeepOriginalImageResolution {
    bool get ();
    void set (bool value);
}

See Also

XpsExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


PagesRange Property

[image]

.NET ModelKit Suite ClassReference
XpsExportSettings..::.PagesRange Property
XpsExportSettings Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.Web.XpsExportSettings.PagesRange]

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public string PagesRange { get; set; }
Visual Basic (Declaration)
Public Property PagesRange As String
Visual C++
public:
property String^ PagesRange {
    String^ get ();
    void set (String^ value);
}

See Also

XpsExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


ReplaceFill Property

[image]

.NET ModelKit Suite ClassReference
XpsExportSettings..::.ReplaceFill Property
XpsExportSettings Class See Also Send Feedback

[Missing <summary> documentation for P:PerpetuumSoft.Reporting.Web.XpsExportSettings.ReplaceFill]

Namespace: PerpetuumSoft.Reporting.Web
Assembly: PerpetuumSoft.Reporting.Web (in PerpetuumSoft.Reporting.Web.dll) Version: 3.9.0.1

Syntax

C#
public bool ReplaceFill { get; set; }
Visual Basic (Declaration)
Public Property ReplaceFill As Boolean
Visual C++
public:
property bool ReplaceFill {
    bool get ();
    void set (bool value);
}

See Also

XpsExportSettings Class
PerpetuumSoft.Reporting.Web Namespace


PerpetuumSoft.Reporting.Windows.Forms Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Windows.Forms Namespace
Send Feedback
The PerpetuumSoft.Reporting.Windows.Forms namespace contains classes which are used to realize user interface in Windows Forms applications.

Classes

Class | Description
Action | Provides uniform mechanism for binding menu and toobar items with corresponding actions.
ActionBind | Represents instance, that sets correspondence beetwen Action and Control.
ActionCollection | Summary description for ActionCollection.
ExecutingEventArgs | Provides data fo executing event.

Delegates

Delegate | Description
Action..::.ExecutingEventHandler | Represents the method that will handle the executing event of Action.


Action Class

[image]

.NET ModelKit Suite ClassReference
Action Class
Members See Also Send Feedback
Provides uniform mechanism for binding menu and toobar items with corresponding actions.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class Action
Visual Basic (Declaration)
Public Class Action
Visual C++
public ref class Action

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Windows.Forms..::.Action

See Also

Action Members
PerpetuumSoft.Reporting.Windows.Forms Namespace


Action Members

[image] [image]

.NET ModelKit Suite ClassReference
Action Members
Action Class Constructors Methods Properties Events See Also Send Feedback

The Action type exposes the following members.

Constructors

Name | Description
Action | Overloaded.

Methods

Name | Description
Bind | Binds this action with ActionBind object.
BindControl | Binds control to action.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteAction | Executes action.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)
Unbind | Overloaded.
UnbindControl | Unbind control from action.

Properties

Name | Description
Checked | Gets and sets if binded control is checked.
Enabled | Gets and sets if binded control is enabled.
Name | Gets and sets name of Action.
Shortcut | Gets and sets action's ShortCut.
ShowTextInToolBar | Gets and sets whether text should be shown in ToolBar items.
Tag | Gets or sets the object that contains data about the action.
Text | Gets and sets action's text.
ToolTip | Gets and sets action's tooltip.
Visible | Gets and sets if binded control is visible.

Events

Name | Description
Execute | Occurs when action is executed.
Executing | Occurs before action is executed.

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Action Constructor

[image] [image]

.NET ModelKit Suite ClassReference
Action Constructor
Action Class See Also Send Feedback

Overload List

Name | Description
Action()()() | Creates new instance of Action class.
Action(ActionCollection, String, String, String, Boolean, EventHandler) | Creates new instance of Action class.
Action(ActionCollection, String, String, String, Boolean, EventHandler, Shortcut) | Creates new instance of Action class.

See Also

Action Class
Action Members
PerpetuumSoft.Reporting.Windows.Forms Namespace


Action Constructor

[image]

.NET ModelKit Suite ClassReference
Action Constructor
Action Class See Also Send Feedback
Creates new instance of Action class.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Action()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Action()

See Also

Action Class
Action Overload
PerpetuumSoft.Reporting.Windows.Forms Namespace


Action Constructor (ActionCollection, String, String, String, Boolean, EventHandler)

[image]

.NET ModelKit Suite ClassReference
Action Constructor (ActionCollection, String, String, String, Boolean, EventHandler)
Action Class See Also Send Feedback
Creates new instance of Action class.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Action(
    ActionCollection collection,
    string name,
    string text,
    string toolTip,
    bool showTextInToolBar,
    EventHandler execute
)
Visual Basic (Declaration)
Public Sub New ( _
    collection As ActionCollection, _
    name As String, _
    text As String, _
    toolTip As String, _
    showTextInToolBar As Boolean, _
    execute As EventHandler _
)
Visual C++
public:
Action(
    ActionCollection^ collection,
    String^ name,
    String^ text,
    String^ toolTip,
    bool showTextInToolBar,
    EventHandler^ execute
)

Parameters

collection
Type: PerpetuumSoft.Reporting.Windows.Forms..::.ActionCollection
name
Type: System..::.String
text
Type: System..::.String
toolTip
Type: System..::.String
showTextInToolBar
Type: System..::.Boolean
execute
Type: System..::.EventHandler

See Also

Action Class
Action Overload
PerpetuumSoft.Reporting.Windows.Forms Namespace


Action Constructor (ActionCollection, String, String, String, Boolean, EventHandler, Shortcut)

[image]

.NET ModelKit Suite ClassReference
Action Constructor (ActionCollection, String, String, String, Boolean, EventHandler, Shortcut)
Action Class See Also Send Feedback
Creates new instance of Action class.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Action(
    ActionCollection collection,
    string name,
    string text,
    string toolTip,
    bool showTextInToolBar,
    EventHandler execute,
    Shortcut shortcut
)
Visual Basic (Declaration)
Public Sub New ( _
    collection As ActionCollection, _
    name As String, _
    text As String, _
    toolTip As String, _
    showTextInToolBar As Boolean, _
    execute As EventHandler, _
    shortcut As Shortcut _
)
Visual C++
public:
Action(
    ActionCollection^ collection,
    String^ name,
    String^ text,
    String^ toolTip,
    bool showTextInToolBar,
    EventHandler^ execute,
    Shortcut shortcut
)

Parameters

collection
Type: PerpetuumSoft.Reporting.Windows.Forms..::.ActionCollection
name
Type: System..::.String
text
Type: System..::.String
toolTip
Type: System..::.String
showTextInToolBar
Type: System..::.Boolean
execute
Type: System..::.EventHandler
shortcut
Type: System.Windows.Forms..::.Shortcut

See Also

Action Class
Action Overload
PerpetuumSoft.Reporting.Windows.Forms Namespace


Action Methods

[image] [image]

.NET ModelKit Suite ClassReference
Action Methods
Action Class See Also Send Feedback

The Action type exposes the following members.

Methods

Name | Description
Bind | Binds this action with ActionBind object.
BindControl | Binds control to action.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteAction | Executes action.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overridden. See ToString()()(). (Overrides Object..::.ToString()()().)
Unbind | Overloaded.
UnbindControl | Unbind control from action.

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Bind Method

[image]

.NET ModelKit Suite ClassReference
Action..::.Bind Method
Action Class See Also Send Feedback
Binds this action with ActionBind object.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Bind(
    ActionBind bind
)
Visual Basic (Declaration)
Public Sub Bind ( _
    bind As ActionBind _
)
Visual C++
public:
void Bind(
    ActionBind^ bind
)

Parameters

bind
Type: PerpetuumSoft.Reporting.Windows.Forms..::.ActionBind

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


BindControl Method

[image]

.NET ModelKit Suite ClassReference
Action..::.BindControl Method
Action Class See Also Send Feedback
Binds control to action.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void BindControl(
    Object control
)
Visual Basic (Declaration)
Public Sub BindControl ( _
    control As Object _
)
Visual C++
public:
void BindControl(
    Object^ control
)

Parameters

control
Type: System..::.Object

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


ExecuteAction Method

[image]

.NET ModelKit Suite ClassReference
Action..::.ExecuteAction Method
Action Class See Also Send Feedback
Executes action.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void ExecuteAction()
Visual Basic (Declaration)
Public Sub ExecuteAction
Visual C++
public:
void ExecuteAction()

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
Action..::.ToString Method
Action Class See Also Send Feedback
Overridden. See ToString()()().

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Unbind Method

[image] [image]

.NET ModelKit Suite ClassReference
Action..::.Unbind Method
Action Class See Also Send Feedback

Overload List

Name | Description
Unbind()()() | Unbinds this action with all ActionBind objects.
Unbind(ActionBind) | Unbinds this action with ActionBind object.

See Also

Action Class
Action Members
PerpetuumSoft.Reporting.Windows.Forms Namespace


Unbind Method

[image]

.NET ModelKit Suite ClassReference
Action..::.Unbind Method
Action Class See Also Send Feedback
Unbinds this action with all ActionBind objects.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Unbind()
Visual Basic (Declaration)
Public Sub Unbind
Visual C++
public:
void Unbind()

See Also

Action Class
Unbind Overload
PerpetuumSoft.Reporting.Windows.Forms Namespace


Unbind Method (ActionBind)

[image]

.NET ModelKit Suite ClassReference
Action..::.Unbind Method (ActionBind)
Action Class See Also Send Feedback
Unbinds this action with ActionBind object.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Unbind(
    ActionBind bind
)
Visual Basic (Declaration)
Public Sub Unbind ( _
    bind As ActionBind _
)
Visual C++
public:
void Unbind(
    ActionBind^ bind
)

Parameters

bind
Type: PerpetuumSoft.Reporting.Windows.Forms..::.ActionBind

See Also

Action Class
Unbind Overload
PerpetuumSoft.Reporting.Windows.Forms Namespace


UnbindControl Method

[image]

.NET ModelKit Suite ClassReference
Action..::.UnbindControl Method
Action Class See Also Send Feedback
Unbind control from action.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void UnbindControl(
    Object control
)
Visual Basic (Declaration)
Public Sub UnbindControl ( _
    control As Object _
)
Visual C++
public:
void UnbindControl(
    Object^ control
)

Parameters

control
Type: System..::.Object

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Action Properties

[image] [image]

.NET ModelKit Suite ClassReference
Action Properties
Action Class See Also Send Feedback

The Action type exposes the following members.

Properties

Name | Description
Checked | Gets and sets if binded control is checked.
Enabled | Gets and sets if binded control is enabled.
Name | Gets and sets name of Action.
Shortcut | Gets and sets action's ShortCut.
ShowTextInToolBar | Gets and sets whether text should be shown in ToolBar items.
Tag | Gets or sets the object that contains data about the action.
Text | Gets and sets action's text.
ToolTip | Gets and sets action's tooltip.
Visible | Gets and sets if binded control is visible.

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Checked Property

[image]

.NET ModelKit Suite ClassReference
Action..::.Checked Property
Action Class See Also Send Feedback
Gets and sets if binded control is checked.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Checked { get; set; }
Visual Basic (Declaration)
Public Property Checked As Boolean
Visual C++
public:
property bool Checked {
    bool get ();
    void set (bool value);
}

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Enabled Property

[image]

.NET ModelKit Suite ClassReference
Action..::.Enabled Property
Action Class See Also Send Feedback
Gets and sets if binded control is enabled.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Name Property

[image]

.NET ModelKit Suite ClassReference
Action..::.Name Property
Action Class See Also Send Feedback
Gets and sets name of Action.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Shortcut Property

[image]

.NET ModelKit Suite ClassReference
Action..::.Shortcut Property
Action Class See Also Send Feedback
Gets and sets action's ShortCut.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Shortcut Shortcut { get; set; }
Visual Basic (Declaration)
Public Property Shortcut As Shortcut
Visual C++
public:
property Shortcut Shortcut {
    Shortcut get ();
    void set (Shortcut value);
}

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


ShowTextInToolBar Property

[image]

.NET ModelKit Suite ClassReference
Action..::.ShowTextInToolBar Property
Action Class See Also Send Feedback
Gets and sets whether text should be shown in ToolBar items.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowTextInToolBar { get; set; }
Visual Basic (Declaration)
Public Property ShowTextInToolBar As Boolean
Visual C++
public:
property bool ShowTextInToolBar {
    bool get ();
    void set (bool value);
}

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Tag Property

[image]

.NET ModelKit Suite ClassReference
Action..::.Tag Property
Action Class See Also Send Feedback
Gets or sets the object that contains data about the action.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Tag { get; set; }
Visual Basic (Declaration)
Public Property Tag As Object
Visual C++
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Text Property

[image]

.NET ModelKit Suite ClassReference
Action..::.Text Property
Action Class See Also Send Feedback
Gets and sets action's text.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


ToolTip Property

[image]

.NET ModelKit Suite ClassReference
Action..::.ToolTip Property
Action Class See Also Send Feedback
Gets and sets action's tooltip.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string ToolTip { get; set; }
Visual Basic (Declaration)
Public Property ToolTip As String
Visual C++
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Visible Property

[image]

.NET ModelKit Suite ClassReference
Action..::.Visible Property
Action Class See Also Send Feedback
Gets and sets if binded control is visible.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Action Events

[image] [image]

.NET ModelKit Suite ClassReference
Action Events
Action Class See Also Send Feedback

The Action type exposes the following members.

Events

Name | Description
Execute | Occurs when action is executed.
Executing | Occurs before action is executed.

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Execute Event

[image]

.NET ModelKit Suite ClassReference
Action..::.Execute Event
Action Class See Also Send Feedback
Occurs when action is executed.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event EventHandler Execute
Visual Basic (Declaration)
Public Event Execute As EventHandler
Visual C++
public:
 event EventHandler^ Execute {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Executing Event

[image]

.NET ModelKit Suite ClassReference
Action..::.Executing Event
Action Class See Also Send Feedback
Occurs before action is executed.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public event Action..::.ExecutingEventHandler Executing
Visual Basic (Declaration)
Public Event Executing As Action..::.ExecutingEventHandler
Visual C++
public:
 event Action..::.ExecutingEventHandler^ Executing {
    void add (Action..::.ExecutingEventHandler^ value);
    void remove (Action..::.ExecutingEventHandler^ value);
}

See Also

Action Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Action.ExecutingEventHandler Delegate

[image]

.NET ModelKit Suite ClassReference
Action..::.ExecutingEventHandler Delegate
Action Class See Also Send Feedback
Represents the method that will handle the executing event of Action.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public delegate void ExecutingEventHandler(
    Object sender,
    ExecutingEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub ExecutingEventHandler ( _
    sender As Object, _
    e As ExecutingEventArgs _
)
Visual C++
public delegate void ExecutingEventHandler(
    Object^ sender,
    ExecutingEventArgs^ e
)

Parameters

sender
Type: System..::.Object
e
Type: PerpetuumSoft.Reporting.Windows.Forms..::.ExecutingEventArgs

See Also

PerpetuumSoft.Reporting.Windows.Forms Namespace


ActionBind Class

[image]

.NET ModelKit Suite ClassReference
ActionBind Class
Members See Also Send Feedback
Represents instance, that sets correspondence beetwen Action and Control.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract class ActionBind
Visual Basic (Declaration)
Public MustInherit Class ActionBind
Visual C++
public ref class ActionBind abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Windows.Forms..::.ActionBind

See Also

ActionBind Members
PerpetuumSoft.Reporting.Windows.Forms Namespace


ActionBind Members

[image] [image]

.NET ModelKit Suite ClassReference
ActionBind Members
ActionBind Class Constructors Methods Properties See Also Send Feedback

The ActionBind type exposes the following members.

Constructors

Name | Description
ActionBind | Initializes a new instance of the ActionBind class

Methods

Name | Description
Bind | When overriden in the derived classes binds control.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetComponent | Sets new control.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unbind | When overriden in the derived classes unbinds control.
Update | Synchronizes Action and Control states.

Properties

Name | Description
Action | Gets assigned Action.
Component | Gets assigned Control.

See Also

ActionBind Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


ActionBind Constructor

[image]

.NET ModelKit Suite ClassReference
ActionBind Constructor
ActionBind Class See Also Send Feedback
Initializes a new instance of the ActionBind class

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected ActionBind()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ActionBind()

See Also

ActionBind Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


ActionBind Methods

[image] [image]

.NET ModelKit Suite ClassReference
ActionBind Methods
ActionBind Class See Also Send Feedback

The ActionBind type exposes the following members.

Methods

Name | Description
Bind | When overriden in the derived classes binds control.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetComponent | Sets new control.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unbind | When overriden in the derived classes unbinds control.
Update | Synchronizes Action and Control states.

See Also

ActionBind Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Bind Method

[image]

.NET ModelKit Suite ClassReference
ActionBind..::.Bind Method
ActionBind Class See Also Send Feedback
When overriden in the derived classes binds control.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected abstract void Bind()
Visual Basic (Declaration)
Protected MustOverride Sub Bind
Visual C++
protected:
virtual void Bind() abstract

See Also

ActionBind Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


SetComponent Method

[image]

.NET ModelKit Suite ClassReference
ActionBind..::.SetComponent Method
ActionBind Class See Also Send Feedback
Sets new control.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected void SetComponent(
    Object component
)
Visual Basic (Declaration)
Protected Sub SetComponent ( _
    component As Object _
)
Visual C++
protected:
void SetComponent(
    Object^ component
)

Parameters

component
Type: System..::.Object

See Also

ActionBind Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Unbind Method

[image]

.NET ModelKit Suite ClassReference
ActionBind..::.Unbind Method
ActionBind Class See Also Send Feedback
When overriden in the derived classes unbinds control.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected abstract void Unbind()
Visual Basic (Declaration)
Protected MustOverride Sub Unbind
Visual C++
protected:
virtual void Unbind() abstract

See Also

ActionBind Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Update Method

[image]

.NET ModelKit Suite ClassReference
ActionBind..::.Update Method
ActionBind Class See Also Send Feedback
Synchronizes Action and Control states.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract void Update()
Visual Basic (Declaration)
Public MustOverride Sub Update
Visual C++
public:
virtual void Update() abstract

See Also

ActionBind Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


ActionBind Properties

[image] [image]

.NET ModelKit Suite ClassReference
ActionBind Properties
ActionBind Class See Also Send Feedback

The ActionBind type exposes the following members.

Properties

Name | Description
Action | Gets assigned Action.
Component | Gets assigned Control.

See Also

ActionBind Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Action Property

[image]

.NET ModelKit Suite ClassReference
ActionBind..::.Action Property
ActionBind Class See Also Send Feedback
Gets assigned Action.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Action Action { get; }
Visual Basic (Declaration)
Public ReadOnly Property Action As Action
Visual C++
public:
property Action^ Action {
    Action^ get ();
}

See Also

ActionBind Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Component Property

[image]

.NET ModelKit Suite ClassReference
ActionBind..::.Component Property
ActionBind Class See Also Send Feedback
Gets assigned Control.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Object Component { get; }
Visual Basic (Declaration)
Public ReadOnly Property Component As Object
Visual C++
public:
property Object^ Component {
    Object^ get ();
}

See Also

ActionBind Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


ActionCollection Class

[image]

.NET ModelKit Suite ClassReference
ActionCollection Class
Members See Also Send Feedback
Summary description for ActionCollection.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ActionCollection : CollectionBase
Visual Basic (Declaration)
Public Class ActionCollection _
    Inherits CollectionBase
Visual C++
public ref class ActionCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Reporting.Windows.Forms..::.ActionCollection

See Also

ActionCollection Members
PerpetuumSoft.Reporting.Windows.Forms Namespace


ActionCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
ActionCollection Members
ActionCollection Class Constructors Methods Properties See Also Send Feedback

The ActionCollection type exposes the following members.

Constructors

Name | Description
ActionCollection | Creates a new instance of ActionCollection class.

Methods

Name | Description
Add | Adds the specified action to the collection.
AddRange | Adds the specified array of actions to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the specified action exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified actionэы index in the collection.
Insert | Inserts the specified action to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified action from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ActionCollection Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


ActionCollection Constructor

[image]

.NET ModelKit Suite ClassReference
ActionCollection Constructor
ActionCollection Class See Also Send Feedback
Creates a new instance of ActionCollection class.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ActionCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ActionCollection()

See Also

ActionCollection Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


ActionCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
ActionCollection Methods
ActionCollection Class See Also Send Feedback

The ActionCollection type exposes the following members.

Methods

Name | Description
Add | Adds the specified action to the collection.
AddRange | Adds the specified array of actions to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the specified action exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified actionэы index in the collection.
Insert | Inserts the specified action to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified action from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ActionCollection Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
ActionCollection..::.Add Method
ActionCollection Class See Also Send Feedback
Adds the specified action to the collection.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Action Add(
    Action value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As Action _
) As Action
Visual C++
public:
Action^ Add(
    Action^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Windows.Forms..::.Action

See Also

ActionCollection Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
ActionCollection..::.AddRange Method
ActionCollection Class See Also Send Feedback
Adds the specified array of actions to the collection.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    Action[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As Action() _
)
Visual C++
public:
void AddRange(
    array<Action^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Reporting.Windows.Forms..::.Action >[]()[]

See Also

ActionCollection Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
ActionCollection..::.Contains Method
ActionCollection Class See Also Send Feedback
Returns whether the specified action exists in the collection.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    Action value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As Action _
) As Boolean
Visual C++
public:
bool Contains(
    Action^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Windows.Forms..::.Action

See Also

ActionCollection Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
ActionCollection..::.IndexOf Method
ActionCollection Class See Also Send Feedback
Returns the specified actionэы index in the collection.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    Action value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As Action _
) As Integer
Visual C++
public:
int IndexOf(
    Action^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Windows.Forms..::.Action

See Also

ActionCollection Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
ActionCollection..::.Insert Method
ActionCollection Class See Also Send Feedback
Inserts the specified action to the collection at the specified index.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    Action value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As Action _
)
Visual C++
public:
void Insert(
    int index,
    Action^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Reporting.Windows.Forms..::.Action

See Also

ActionCollection Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
ActionCollection..::.Remove Method
ActionCollection Class See Also Send Feedback
Removes the specified action from the collection.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    Action value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As Action _
)
Visual C++
public:
void Remove(
    Action^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Windows.Forms..::.Action

See Also

ActionCollection Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


ActionCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
ActionCollection Properties
ActionCollection Class See Also Send Feedback

The ActionCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Overloaded.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

ActionCollection Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Item Property

[image] [image]

.NET ModelKit Suite ClassReference
ActionCollection..::.Item Property
ActionCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets a action from the collection at the specified index.
Item[([(String])]) | Gets the action with specified name.

See Also

ActionCollection Class
ActionCollection Members
PerpetuumSoft.Reporting.Windows.Forms Namespace


Item Property (Int32)

[image]

.NET ModelKit Suite ClassReference
ActionCollection..::.Item Property (Int32)
ActionCollection Class See Also Send Feedback
Gets a action from the collection at the specified index.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Action this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Action
Visual C++
public:
property Action^ default[int index] {
    Action^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

ActionCollection Class
Item Overload
PerpetuumSoft.Reporting.Windows.Forms Namespace


Item Property (String)

[image]

.NET ModelKit Suite ClassReference
ActionCollection..::.Item Property (String)
ActionCollection Class See Also Send Feedback
Gets the action with specified name.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Action this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As Action
Visual C++
public:
property Action^ default[String^ name] {
    Action^ get (String^ name);
}

Parameters

name
Type: System..::.String

See Also

ActionCollection Class
Item Overload
PerpetuumSoft.Reporting.Windows.Forms Namespace


ExecutingEventArgs Class

[image]

.NET ModelKit Suite ClassReference
ExecutingEventArgs Class
Members See Also Send Feedback
Provides data fo executing event.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class ExecutingEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ExecutingEventArgs _
    Inherits EventArgs
Visual C++
public ref class ExecutingEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
PerpetuumSoft.Reporting.Windows.Forms..::.ExecutingEventArgs

See Also

ExecutingEventArgs Members
PerpetuumSoft.Reporting.Windows.Forms Namespace


ExecutingEventArgs Members

[image] [image]

.NET ModelKit Suite ClassReference
ExecutingEventArgs Members
ExecutingEventArgs Class Constructors Methods Properties See Also Send Feedback

The ExecutingEventArgs type exposes the following members.

Constructors

Name | Description
ExecutingEventArgs | Creates a new instance of ExecutingEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Handled | Gets and sets whether action is already handled.

See Also

ExecutingEventArgs Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


ExecutingEventArgs Constructor

[image]

.NET ModelKit Suite ClassReference
ExecutingEventArgs Constructor
ExecutingEventArgs Class See Also Send Feedback
Creates a new instance of ExecutingEventArgs class.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ExecutingEventArgs()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExecutingEventArgs()

See Also

ExecutingEventArgs Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


ExecutingEventArgs Methods

[image] [image]

.NET ModelKit Suite ClassReference
ExecutingEventArgs Methods
ExecutingEventArgs Class See Also Send Feedback

The ExecutingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExecutingEventArgs Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


ExecutingEventArgs Properties

[image] [image]

.NET ModelKit Suite ClassReference
ExecutingEventArgs Properties
ExecutingEventArgs Class See Also Send Feedback

The ExecutingEventArgs type exposes the following members.

Properties

Name | Description
Handled | Gets and sets whether action is already handled.

See Also

ExecutingEventArgs Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


Handled Property

[image]

.NET ModelKit Suite ClassReference
ExecutingEventArgs..::.Handled Property
ExecutingEventArgs Class See Also Send Feedback
Gets and sets whether action is already handled.

Namespace: PerpetuumSoft.Reporting.Windows.Forms
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Handled { get; set; }
Visual Basic (Declaration)
Public Property Handled As Boolean
Visual C++
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

See Also

ExecutingEventArgs Class
PerpetuumSoft.Reporting.Windows.Forms Namespace


PerpetuumSoft.Reporting.Wizards Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Wizards Namespace
Send Feedback
The PerpetuumSoft.Reporting.Wizards namespace contains classes which are used for report creation using wizard.

Classes

Class | Description
BlankReportWizard | Creates blank report.
CommonWizard | Incapsulates common wizard behavior.
CommonWizardForm | A dialog window for specifying common wizard settings
DataWizardInfo | Incapsulates data section properties.
DataWizardInfoCollection | Defines a collection of DataWizardInfo in the wizard.
FieldWizardInfo | Incapsulates displayed field properties.
FieldWizardInfoCollection | Defines a collection of FieldWizardInfo in the report.
GroupWizardInfo | Incapsulates groupping settings.
GroupWizardInfoCollection | Defines a collection of data groups in the report.
StandardWizard | Standard wizard. Creates templates for all common reports types.
WizardBase | Base class for the Report Sharp-Shooter wizards.
WizardNameAttribute | Assigns name to the wizard type.

Enumerations

Enumeration | Description
DataLayoutType | Fields layout.
PageNumberAlign | Page numbers align.
PageNumberPosition | Page numbers position.
WizardAggregateType | Aggregate type.


BlankReportWizard Class

[image]

.NET ModelKit Suite ClassReference
BlankReportWizard Class
Members See Also Send Feedback
Creates blank report.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class BlankReportWizard : WizardBase
Visual Basic (Declaration)
Public Class BlankReportWizard _
    Inherits WizardBase
Visual C++
public ref class BlankReportWizard : public WizardBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Wizards..::.WizardBase
PerpetuumSoft.Reporting.Wizards..::.BlankReportWizard

See Also

BlankReportWizard Members
PerpetuumSoft.Reporting.Wizards Namespace


BlankReportWizard Members

[image] [image]

.NET ModelKit Suite ClassReference
BlankReportWizard Members
BlankReportWizard Class Constructors Methods See Also Send Feedback

The BlankReportWizard type exposes the following members.

Constructors

Name | Description
BlankReportWizard | Creates a new instance of BlankReportWizard class.

Methods

Name | Description
BuildTemplate | Builds template. (Inherited from WizardBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InternalBuildTemplate | Performs actual template generation. (Overrides WizardBase..::.InternalBuildTemplate()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ShowDialog | Shows wizard dialog. (Overrides WizardBase..::.ShowDialog(Form, IReportDesignerService).)
ToString | Converts object to its string representation. (Overrides Object..::.ToString()()().)

See Also

BlankReportWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


BlankReportWizard Constructor

[image]

.NET ModelKit Suite ClassReference
BlankReportWizard Constructor
BlankReportWizard Class See Also Send Feedback
Creates a new instance of BlankReportWizard class.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public BlankReportWizard()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BlankReportWizard()

See Also

BlankReportWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


BlankReportWizard Methods

[image] [image]

.NET ModelKit Suite ClassReference
BlankReportWizard Methods
BlankReportWizard Class See Also Send Feedback

The BlankReportWizard type exposes the following members.

Methods

Name | Description
BuildTemplate | Builds template. (Inherited from WizardBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InternalBuildTemplate | Performs actual template generation. (Overrides WizardBase..::.InternalBuildTemplate()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ShowDialog | Shows wizard dialog. (Overrides WizardBase..::.ShowDialog(Form, IReportDesignerService).)
ToString | Converts object to its string representation. (Overrides Object..::.ToString()()().)

See Also

BlankReportWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


InternalBuildTemplate Method

[image]

.NET ModelKit Suite ClassReference
BlankReportWizard..::.InternalBuildTemplate Method
BlankReportWizard Class See Also Send Feedback
Performs actual template generation.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Document InternalBuildTemplate()
Visual Basic (Declaration)
Protected Overrides Function InternalBuildTemplate As Document
Visual C++
protected:
virtual Document^ InternalBuildTemplate() override

See Also

BlankReportWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


ShowDialog Method

[image]

.NET ModelKit Suite ClassReference
BlankReportWizard..::.ShowDialog Method
BlankReportWizard Class See Also Send Feedback
Shows wizard dialog.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override DialogResult ShowDialog(
    Form owner,
    IReportDesignerService rds
)
Visual Basic (Declaration)
Public Overrides Function ShowDialog ( _
    owner As Form, _
    rds As IReportDesignerService _
) As DialogResult
Visual C++
public:
virtual DialogResult ShowDialog(
    Form^ owner,
    IReportDesignerService^ rds
) override

Parameters

owner
Type: System.Windows.Forms..::.Form
rds
Type: PerpetuumSoft.Reporting.Designer..::.IReportDesignerService

See Also

BlankReportWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


ToString Method

[image]

.NET ModelKit Suite ClassReference
BlankReportWizard..::.ToString Method
BlankReportWizard Class See Also Send Feedback
Converts object to its string representation.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

BlankReportWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


CommonWizard Class

[image]

.NET ModelKit Suite ClassReference
CommonWizard Class
Members See Also Send Feedback
Incapsulates common wizard behavior.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class CommonWizard : WizardBase
Visual Basic (Declaration)
Public Class CommonWizard _
    Inherits WizardBase
Visual C++
public ref class CommonWizard : public WizardBase

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Wizards..::.WizardBase
PerpetuumSoft.Reporting.Wizards..::.CommonWizard
PerpetuumSoft.Reporting.Wizards.PivotTableWizard..::.PivotTableWizard
PerpetuumSoft.Reporting.Wizards..::.StandardWizard

See Also

CommonWizard Members
PerpetuumSoft.Reporting.Wizards Namespace


CommonWizard Members

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizard Members
CommonWizard Class Constructors Methods Properties See Also Send Feedback

The CommonWizard type exposes the following members.

Constructors

Name | Description
CommonWizard | Creates a new instance of CommonWizard class.

Methods

Name | Description
AddBand | Adds a band to a template.
BuildTemplate | Builds template. (Inherited from WizardBase.)
CreateDataBands | Creates data sections.
CreatePageFooter | Creates page footer.
CreatePageHeader | Creates page header.
CreateReportTitle | Creates report title.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InternalBuildTemplate | Perform actual template generation. (Overrides WizardBase..::.InternalBuildTemplate()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ShowDialog | Shows wizard dialog. (Overrides WizardBase..::.ShowDialog(Form, IReportDesignerService).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CustomPageSize | Get or sets custom page size.
Gap | Gets gap.
InsertTitle | Gets or sets if report title should be inserted in template.
MeasureUnit | Gets or sets measure units.
Page | Currently generated page.
PageNumberAlign | Gets or sets page number align mode.
PageNumberPosition | Gets or sets page number position.
PageOrientation | Gets or sets page orientation.
PaperKind | Gets or sets paper kind.
ReportTitle | Gets or sets report title.
ScriptLanguage | Gets or sets script language.
Step | Gets step.
StyleSheet | Gets or sets template stylesheet.
Y | Current position.

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


CommonWizard Constructor

[image]

.NET ModelKit Suite ClassReference
CommonWizard Constructor
CommonWizard Class See Also Send Feedback
Creates a new instance of CommonWizard class.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public CommonWizard()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CommonWizard()

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


CommonWizard Methods

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizard Methods
CommonWizard Class See Also Send Feedback

The CommonWizard type exposes the following members.

Methods

Name | Description
AddBand | Adds a band to a template.
BuildTemplate | Builds template. (Inherited from WizardBase.)
CreateDataBands | Creates data sections.
CreatePageFooter | Creates page footer.
CreatePageHeader | Creates page header.
CreateReportTitle | Creates report title.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InternalBuildTemplate | Perform actual template generation. (Overrides WizardBase..::.InternalBuildTemplate()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ShowDialog | Shows wizard dialog. (Overrides WizardBase..::.ShowDialog(Form, IReportDesignerService).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


AddBand Method

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.AddBand Method
CommonWizard Class See Also Send Feedback
Adds a band to a template.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected void AddBand(
    BandBase band,
    double height
)
Visual Basic (Declaration)
Protected Sub AddBand ( _
    band As BandBase, _
    height As Double _
)
Visual C++
protected:
void AddBand(
    BandBase^ band,
    double height
)

Parameters

band
Type: PerpetuumSoft.Reporting.DOM..::.BandBase
height
Type: System..::.Double

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


CreateDataBands Method

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.CreateDataBands Method
CommonWizard Class See Also Send Feedback
Creates data sections.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void CreateDataBands()
Visual Basic (Declaration)
Protected Overridable Sub CreateDataBands
Visual C++
protected:
virtual void CreateDataBands()

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


CreatePageFooter Method

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.CreatePageFooter Method
CommonWizard Class See Also Send Feedback
Creates page footer.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void CreatePageFooter()
Visual Basic (Declaration)
Protected Overridable Sub CreatePageFooter
Visual C++
protected:
virtual void CreatePageFooter()

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


CreatePageHeader Method

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.CreatePageHeader Method
CommonWizard Class See Also Send Feedback
Creates page header.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void CreatePageHeader()
Visual Basic (Declaration)
Protected Overridable Sub CreatePageHeader
Visual C++
protected:
virtual void CreatePageHeader()

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


CreateReportTitle Method

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.CreateReportTitle Method
CommonWizard Class See Also Send Feedback
Creates report title.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected virtual void CreateReportTitle()
Visual Basic (Declaration)
Protected Overridable Sub CreateReportTitle
Visual C++
protected:
virtual void CreateReportTitle()

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


InternalBuildTemplate Method

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.InternalBuildTemplate Method
CommonWizard Class See Also Send Feedback
Perform actual template generation.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Document InternalBuildTemplate()
Visual Basic (Declaration)
Protected Overrides Function InternalBuildTemplate As Document
Visual C++
protected:
virtual Document^ InternalBuildTemplate() override

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


ShowDialog Method

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.ShowDialog Method
CommonWizard Class See Also Send Feedback
Shows wizard dialog.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override DialogResult ShowDialog(
    Form owner,
    IReportDesignerService rds
)
Visual Basic (Declaration)
Public Overrides Function ShowDialog ( _
    owner As Form, _
    rds As IReportDesignerService _
) As DialogResult
Visual C++
public:
virtual DialogResult ShowDialog(
    Form^ owner,
    IReportDesignerService^ rds
) override

Parameters

owner
Type: System.Windows.Forms..::.Form
rds
Type: PerpetuumSoft.Reporting.Designer..::.IReportDesignerService

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


CommonWizard Properties

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizard Properties
CommonWizard Class See Also Send Feedback

The CommonWizard type exposes the following members.

Properties

Name | Description
CustomPageSize | Get or sets custom page size.
Gap | Gets gap.
InsertTitle | Gets or sets if report title should be inserted in template.
MeasureUnit | Gets or sets measure units.
Page | Currently generated page.
PageNumberAlign | Gets or sets page number align mode.
PageNumberPosition | Gets or sets page number position.
PageOrientation | Gets or sets page orientation.
PaperKind | Gets or sets paper kind.
ReportTitle | Gets or sets report title.
ScriptLanguage | Gets or sets script language.
Step | Gets step.
StyleSheet | Gets or sets template stylesheet.
Y | Current position.

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


CustomPageSize Property

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.CustomPageSize Property
CommonWizard Class See Also Send Feedback
Get or sets custom page size.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Vector CustomPageSize { get; set; }
Visual Basic (Declaration)
Public Property CustomPageSize As Vector
Visual C++
public:
property Vector CustomPageSize {
    Vector get ();
    void set (Vector value);
}

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


Gap Property

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.Gap Property
CommonWizard Class See Also Send Feedback
Gets gap.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected double Gap { get; }
Visual Basic (Declaration)
Protected ReadOnly Property Gap As Double
Visual C++
protected:
property double Gap {
    double get ();
}

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


InsertTitle Property

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.InsertTitle Property
CommonWizard Class See Also Send Feedback
Gets or sets if report title should be inserted in template.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool InsertTitle { get; set; }
Visual Basic (Declaration)
Public Property InsertTitle As Boolean
Visual C++
public:
property bool InsertTitle {
    bool get ();
    void set (bool value);
}

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


MeasureUnit Property

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.MeasureUnit Property
CommonWizard Class See Also Send Feedback
Gets or sets measure units.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Unit MeasureUnit { get; set; }
Visual Basic (Declaration)
Public Property MeasureUnit As Unit
Visual C++
public:
property Unit MeasureUnit {
    Unit get ();
    void set (Unit value);
}

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


Page Property

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.Page Property
CommonWizard Class See Also Send Feedback
Currently generated page.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Page Page { get; }
Visual Basic (Declaration)
Public ReadOnly Property Page As Page
Visual C++
public:
property Page^ Page {
    Page^ get ();
}

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


PageNumberAlign Property

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.PageNumberAlign Property
CommonWizard Class See Also Send Feedback
Gets or sets page number align mode.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PageNumberAlign PageNumberAlign { get; set; }
Visual Basic (Declaration)
Public Property PageNumberAlign As PageNumberAlign
Visual C++
public:
property PageNumberAlign PageNumberAlign {
    PageNumberAlign get ();
    void set (PageNumberAlign value);
}

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


PageNumberPosition Property

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.PageNumberPosition Property
CommonWizard Class See Also Send Feedback
Gets or sets page number position.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PageNumberPosition PageNumberPosition { get; set; }
Visual Basic (Declaration)
Public Property PageNumberPosition As PageNumberPosition
Visual C++
public:
property PageNumberPosition PageNumberPosition {
    PageNumberPosition get ();
    void set (PageNumberPosition value);
}

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


PageOrientation Property

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.PageOrientation Property
CommonWizard Class See Also Send Feedback
Gets or sets page orientation.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PageOrientation PageOrientation { get; set; }
Visual Basic (Declaration)
Public Property PageOrientation As PageOrientation
Visual C++
public:
property PageOrientation PageOrientation {
    PageOrientation get ();
    void set (PageOrientation value);
}

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


PaperKind Property

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.PaperKind Property
CommonWizard Class See Also Send Feedback
Gets or sets paper kind.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PaperKind PaperKind { get; set; }
Visual Basic (Declaration)
Public Property PaperKind As PaperKind
Visual C++
public:
property PaperKind PaperKind {
    PaperKind get ();
    void set (PaperKind value);
}

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


ReportTitle Property

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.ReportTitle Property
CommonWizard Class See Also Send Feedback
Gets or sets report title.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string ReportTitle { get; set; }
Visual Basic (Declaration)
Public Property ReportTitle As String
Visual C++
public:
property String^ ReportTitle {
    String^ get ();
    void set (String^ value);
}

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


ScriptLanguage Property

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.ScriptLanguage Property
CommonWizard Class See Also Send Feedback
Gets or sets script language.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public ScriptLanguage ScriptLanguage { get; set; }
Visual Basic (Declaration)
Public Property ScriptLanguage As ScriptLanguage
Visual C++
public:
property ScriptLanguage ScriptLanguage {
    ScriptLanguage get ();
    void set (ScriptLanguage value);
}

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


Step Property

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.Step Property
CommonWizard Class See Also Send Feedback
Gets step.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected double Step { get; }
Visual Basic (Declaration)
Protected ReadOnly Property Step As Double
Visual C++
protected:
property double Step {
    double get ();
}

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


StyleSheet Property

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.StyleSheet Property
CommonWizard Class See Also Send Feedback
Gets or sets template stylesheet.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public StyleSheet StyleSheet { get; set; }
Visual Basic (Declaration)
Public Property StyleSheet As StyleSheet
Visual C++
public:
property StyleSheet^ StyleSheet {
    StyleSheet^ get ();
    void set (StyleSheet^ value);
}

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


Y Property

[image]

.NET ModelKit Suite ClassReference
CommonWizard..::.Y Property
CommonWizard Class See Also Send Feedback
Current position.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected double Y { get; set; }
Visual Basic (Declaration)
Protected Property Y As Double
Visual C++
protected:
property double Y {
    double get ();
    void set (double value);
}

See Also

CommonWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


CommonWizardForm Class

[image]

.NET ModelKit Suite ClassReference
CommonWizardForm Class
Members See Also Send Feedback
A dialog window for specifying common wizard settings

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class CommonWizardForm : Form
Visual Basic (Declaration)
Public Class CommonWizardForm _
    Inherits Form
Visual C++
public ref class CommonWizardForm : public Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
PerpetuumSoft.Reporting.Wizards..::.CommonWizardForm

See Also

CommonWizardForm Members
PerpetuumSoft.Reporting.Wizards Namespace


CommonWizardForm Members

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm Members
CommonWizardForm Class Constructors Methods Properties Events See Also Send Feedback

The CommonWizardForm type exposes the following members.

Constructors

Name | Description
CommonWizardForm | Initializes a new instance of the CommonWizardForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

CommonWizardForm Class
PerpetuumSoft.Reporting.Wizards Namespace


CommonWizardForm Constructor

[image]

.NET ModelKit Suite ClassReference
CommonWizardForm Constructor
CommonWizardForm Class See Also Send Feedback
Initializes a new instance of the CommonWizardForm class.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public CommonWizardForm(
    WizardBase wizard,
    IReportDesignerService rds
)
Visual Basic (Declaration)
Public Sub New ( _
    wizard As WizardBase, _
    rds As IReportDesignerService _
)
Visual C++
public:
CommonWizardForm(
    WizardBase^ wizard,
    IReportDesignerService^ rds
)

Parameters

wizard
Type: PerpetuumSoft.Reporting.Wizards..::.WizardBase
rds
Type: PerpetuumSoft.Reporting.Designer..::.IReportDesignerService

See Also

CommonWizardForm Class
PerpetuumSoft.Reporting.Wizards Namespace


CommonWizardForm Methods

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm Methods
CommonWizardForm Class See Also Send Feedback

The CommonWizardForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

CommonWizardForm Class
PerpetuumSoft.Reporting.Wizards Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm..::.AccessibilityNotifyClients Method
CommonWizardForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

CommonWizardForm Class
CommonWizardForm Members
PerpetuumSoft.Reporting.Wizards Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm..::.BeginInvoke Method
CommonWizardForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

CommonWizardForm Class
CommonWizardForm Members
PerpetuumSoft.Reporting.Wizards Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm..::.Dispose Method
CommonWizardForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | The Dispose Finalize pattern ensures that resources are released when the object is no longer needed (Overrides Form..::.Dispose(Boolean).)

See Also

CommonWizardForm Class
CommonWizardForm Members
PerpetuumSoft.Reporting.Wizards Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
CommonWizardForm..::.Dispose Method (Boolean)
CommonWizardForm Class See Also Send Feedback
The Dispose Finalize pattern ensures that resources are released when the object is no longer needed

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

CommonWizardForm Class
Dispose Overload
PerpetuumSoft.Reporting.Wizards Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm..::.GetChildAtPoint Method
CommonWizardForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

CommonWizardForm Class
CommonWizardForm Members
PerpetuumSoft.Reporting.Wizards Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm..::.Invalidate Method
CommonWizardForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

CommonWizardForm Class
CommonWizardForm Members
PerpetuumSoft.Reporting.Wizards Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm..::.Invoke Method
CommonWizardForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

CommonWizardForm Class
CommonWizardForm Members
PerpetuumSoft.Reporting.Wizards Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm..::.MemberwiseClone Method
CommonWizardForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

CommonWizardForm Class
CommonWizardForm Members
PerpetuumSoft.Reporting.Wizards Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm..::.PerformLayout Method
CommonWizardForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

CommonWizardForm Class
CommonWizardForm Members
PerpetuumSoft.Reporting.Wizards Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm..::.ResumeLayout Method
CommonWizardForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

CommonWizardForm Class
CommonWizardForm Members
PerpetuumSoft.Reporting.Wizards Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm..::.RtlTranslateAlignment Method
CommonWizardForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

CommonWizardForm Class
CommonWizardForm Members
PerpetuumSoft.Reporting.Wizards Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm..::.Scale Method
CommonWizardForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

CommonWizardForm Class
CommonWizardForm Members
PerpetuumSoft.Reporting.Wizards Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm..::.Select Method
CommonWizardForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

CommonWizardForm Class
CommonWizardForm Members
PerpetuumSoft.Reporting.Wizards Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm..::.SetBounds Method
CommonWizardForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

CommonWizardForm Class
CommonWizardForm Members
PerpetuumSoft.Reporting.Wizards Namespace


Show Method

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm..::.Show Method
CommonWizardForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

CommonWizardForm Class
CommonWizardForm Members
PerpetuumSoft.Reporting.Wizards Namespace


ShowDialog Method

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm..::.ShowDialog Method
CommonWizardForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

CommonWizardForm Class
CommonWizardForm Members
PerpetuumSoft.Reporting.Wizards Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm..::.UpdateBounds Method
CommonWizardForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

CommonWizardForm Class
CommonWizardForm Members
PerpetuumSoft.Reporting.Wizards Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm..::.Validate Method
CommonWizardForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

CommonWizardForm Class
CommonWizardForm Members
PerpetuumSoft.Reporting.Wizards Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm..::.ValidateChildren Method
CommonWizardForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

CommonWizardForm Class
CommonWizardForm Members
PerpetuumSoft.Reporting.Wizards Namespace


CommonWizardForm Properties

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm Properties
CommonWizardForm Class See Also Send Feedback

The CommonWizardForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

CommonWizardForm Class
PerpetuumSoft.Reporting.Wizards Namespace


CommonWizardForm Events

[image] [image]

.NET ModelKit Suite ClassReference
CommonWizardForm Events
CommonWizardForm Class See Also Send Feedback

The CommonWizardForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

CommonWizardForm Class
PerpetuumSoft.Reporting.Wizards Namespace


DataLayoutType Enumeration

[image]

.NET ModelKit Suite ClassReference
DataLayoutType Enumeration
See Also Send Feedback
Fields layout.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum DataLayoutType
Visual Basic (Declaration)
Public Enumeration DataLayoutType
Visual C++
public enum class DataLayoutType

Members

Member name | Description
Card | Card layout.
List | List layout.

See Also

PerpetuumSoft.Reporting.Wizards Namespace


DataWizardInfo Class

[image]

.NET ModelKit Suite ClassReference
DataWizardInfo Class
Members See Also Send Feedback
Incapsulates data section properties.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DataWizardInfo
Visual Basic (Declaration)
Public Class DataWizardInfo
Visual C++
public ref class DataWizardInfo

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Wizards..::.DataWizardInfo

See Also

DataWizardInfo Members
PerpetuumSoft.Reporting.Wizards Namespace


DataWizardInfo Members

[image] [image]

.NET ModelKit Suite ClassReference
DataWizardInfo Members
DataWizardInfo Class Constructors Methods Properties See Also Send Feedback

The DataWizardInfo type exposes the following members.

Constructors

Name | Description
DataWizardInfo | Creates a new instance of DataWizardInfo class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DataSource | Gets or sets data source.
Fields | Gets displayed fiels collection.
Groups | Gets groups collection.
LayoutType | Gets or sets layout type.
NestedSections | Gets nested data sections collection.

See Also

DataWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


DataWizardInfo Constructor

[image]

.NET ModelKit Suite ClassReference
DataWizardInfo Constructor
DataWizardInfo Class See Also Send Feedback
Creates a new instance of DataWizardInfo class.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataWizardInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataWizardInfo()

See Also

DataWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


DataWizardInfo Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataWizardInfo Methods
DataWizardInfo Class See Also Send Feedback

The DataWizardInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


DataWizardInfo Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataWizardInfo Properties
DataWizardInfo Class See Also Send Feedback

The DataWizardInfo type exposes the following members.

Properties

Name | Description
DataSource | Gets or sets data source.
Fields | Gets displayed fiels collection.
Groups | Gets groups collection.
LayoutType | Gets or sets layout type.
NestedSections | Gets nested data sections collection.

See Also

DataWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


DataSource Property

[image]

.NET ModelKit Suite ClassReference
DataWizardInfo..::.DataSource Property
DataWizardInfo Class See Also Send Feedback
Gets or sets data source.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As String
Visual C++
public:
property String^ DataSource {
    String^ get ();
    void set (String^ value);
}

See Also

DataWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


Fields Property

[image]

.NET ModelKit Suite ClassReference
DataWizardInfo..::.Fields Property
DataWizardInfo Class See Also Send Feedback
Gets displayed fiels collection.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldWizardInfoCollection Fields { get; }
Visual Basic (Declaration)
Public ReadOnly Property Fields As FieldWizardInfoCollection
Visual C++
public:
property FieldWizardInfoCollection^ Fields {
    FieldWizardInfoCollection^ get ();
}

See Also

DataWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


Groups Property

[image]

.NET ModelKit Suite ClassReference
DataWizardInfo..::.Groups Property
DataWizardInfo Class See Also Send Feedback
Gets groups collection.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public GroupWizardInfoCollection Groups { get; }
Visual Basic (Declaration)
Public ReadOnly Property Groups As GroupWizardInfoCollection
Visual C++
public:
property GroupWizardInfoCollection^ Groups {
    GroupWizardInfoCollection^ get ();
}

See Also

DataWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


LayoutType Property

[image]

.NET ModelKit Suite ClassReference
DataWizardInfo..::.LayoutType Property
DataWizardInfo Class See Also Send Feedback
Gets or sets layout type.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataLayoutType LayoutType { get; set; }
Visual Basic (Declaration)
Public Property LayoutType As DataLayoutType
Visual C++
public:
property DataLayoutType LayoutType {
    DataLayoutType get ();
    void set (DataLayoutType value);
}

See Also

DataWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


NestedSections Property

[image]

.NET ModelKit Suite ClassReference
DataWizardInfo..::.NestedSections Property
DataWizardInfo Class See Also Send Feedback
Gets nested data sections collection.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataWizardInfoCollection NestedSections { get; }
Visual Basic (Declaration)
Public ReadOnly Property NestedSections As DataWizardInfoCollection
Visual C++
public:
property DataWizardInfoCollection^ NestedSections {
    DataWizardInfoCollection^ get ();
}

See Also

DataWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


DataWizardInfoCollection Class

[image]

.NET ModelKit Suite ClassReference
DataWizardInfoCollection Class
Members See Also Send Feedback
Defines a collection of DataWizardInfo in the wizard.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class DataWizardInfoCollection : CollectionBase
Visual Basic (Declaration)
Public Class DataWizardInfoCollection _
    Inherits CollectionBase
Visual C++
public ref class DataWizardInfoCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Reporting.Wizards..::.DataWizardInfoCollection

See Also

DataWizardInfoCollection Members
PerpetuumSoft.Reporting.Wizards Namespace


DataWizardInfoCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
DataWizardInfoCollection Members
DataWizardInfoCollection Class Constructors Methods Properties See Also Send Feedback

The DataWizardInfoCollection type exposes the following members.

Constructors

Name | Description
DataWizardInfoCollection | Creates a new instance of DataWizardInfoCollection class.

Methods

Name | Description
Add | Adds the specified DataWizardInfo to the collection.
AddRange | Adds the specified array of DataWizardInfos to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the specified DataWizardInfo exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified DataWizardInfoэы index in the collection.
Insert | Inserts the specified DataWizardInfo to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified DataWizardInfo from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets a DataWizardInfo from the collection at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

DataWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


DataWizardInfoCollection Constructor

[image]

.NET ModelKit Suite ClassReference
DataWizardInfoCollection Constructor
DataWizardInfoCollection Class See Also Send Feedback
Creates a new instance of DataWizardInfoCollection class.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataWizardInfoCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataWizardInfoCollection()

See Also

DataWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


DataWizardInfoCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
DataWizardInfoCollection Methods
DataWizardInfoCollection Class See Also Send Feedback

The DataWizardInfoCollection type exposes the following members.

Methods

Name | Description
Add | Adds the specified DataWizardInfo to the collection.
AddRange | Adds the specified array of DataWizardInfos to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the specified DataWizardInfo exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified DataWizardInfoэы index in the collection.
Insert | Inserts the specified DataWizardInfo to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified DataWizardInfo from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
DataWizardInfoCollection..::.Add Method
DataWizardInfoCollection Class See Also Send Feedback
Adds the specified DataWizardInfo to the collection.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataWizardInfo Add(
    DataWizardInfo value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As DataWizardInfo _
) As DataWizardInfo
Visual C++
public:
DataWizardInfo^ Add(
    DataWizardInfo^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Wizards..::.DataWizardInfo

See Also

DataWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
DataWizardInfoCollection..::.AddRange Method
DataWizardInfoCollection Class See Also Send Feedback
Adds the specified array of DataWizardInfos to the collection.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    DataWizardInfo[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As DataWizardInfo() _
)
Visual C++
public:
void AddRange(
    array<DataWizardInfo^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Reporting.Wizards..::.DataWizardInfo >[]()[]

See Also

DataWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
DataWizardInfoCollection..::.Contains Method
DataWizardInfoCollection Class See Also Send Feedback
Returns whether the specified DataWizardInfo exists in the collection.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    DataWizardInfo value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As DataWizardInfo _
) As Boolean
Visual C++
public:
bool Contains(
    DataWizardInfo^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Wizards..::.DataWizardInfo

See Also

DataWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
DataWizardInfoCollection..::.IndexOf Method
DataWizardInfoCollection Class See Also Send Feedback
Returns the specified DataWizardInfoэы index in the collection.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    DataWizardInfo value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As DataWizardInfo _
) As Integer
Visual C++
public:
int IndexOf(
    DataWizardInfo^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Wizards..::.DataWizardInfo

See Also

DataWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
DataWizardInfoCollection..::.Insert Method
DataWizardInfoCollection Class See Also Send Feedback
Inserts the specified DataWizardInfo to the collection at the specified index.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    DataWizardInfo value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As DataWizardInfo _
)
Visual C++
public:
void Insert(
    int index,
    DataWizardInfo^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Reporting.Wizards..::.DataWizardInfo

See Also

DataWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
DataWizardInfoCollection..::.Remove Method
DataWizardInfoCollection Class See Also Send Feedback
Removes the specified DataWizardInfo from the collection.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    DataWizardInfo value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As DataWizardInfo _
)
Visual C++
public:
void Remove(
    DataWizardInfo^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Wizards..::.DataWizardInfo

See Also

DataWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


DataWizardInfoCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
DataWizardInfoCollection Properties
DataWizardInfoCollection Class See Also Send Feedback

The DataWizardInfoCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets a DataWizardInfo from the collection at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

DataWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
DataWizardInfoCollection..::.Item Property
DataWizardInfoCollection Class See Also Send Feedback
Gets a DataWizardInfo from the collection at the specified index.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataWizardInfo this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As DataWizardInfo
Visual C++
public:
property DataWizardInfo^ default[int index] {
    DataWizardInfo^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

DataWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


FieldWizardInfo Class

[image]

.NET ModelKit Suite ClassReference
FieldWizardInfo Class
Members See Also Send Feedback
Incapsulates displayed field properties.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class FieldWizardInfo
Visual Basic (Declaration)
Public Class FieldWizardInfo
Visual C++
public ref class FieldWizardInfo

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Wizards..::.FieldWizardInfo

See Also

FieldWizardInfo Members
PerpetuumSoft.Reporting.Wizards Namespace


FieldWizardInfo Members

[image] [image]

.NET ModelKit Suite ClassReference
FieldWizardInfo Members
FieldWizardInfo Class Constructors Methods Properties See Also Send Feedback

The FieldWizardInfo type exposes the following members.

Constructors

Name | Description
FieldWizardInfo | Creates a new instance of FieldWizardInfo class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AggregateType | Gets or sets column aggregate type.
DataMember | Gets or sets data member.
Title | Gets or sets column title.
Width | Gets or sets column relative width.

See Also

FieldWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


FieldWizardInfo Constructor

[image]

.NET ModelKit Suite ClassReference
FieldWizardInfo Constructor
FieldWizardInfo Class See Also Send Feedback
Creates a new instance of FieldWizardInfo class.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldWizardInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FieldWizardInfo()

See Also

FieldWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


FieldWizardInfo Methods

[image] [image]

.NET ModelKit Suite ClassReference
FieldWizardInfo Methods
FieldWizardInfo Class See Also Send Feedback

The FieldWizardInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


FieldWizardInfo Properties

[image] [image]

.NET ModelKit Suite ClassReference
FieldWizardInfo Properties
FieldWizardInfo Class See Also Send Feedback

The FieldWizardInfo type exposes the following members.

Properties

Name | Description
AggregateType | Gets or sets column aggregate type.
DataMember | Gets or sets data member.
Title | Gets or sets column title.
Width | Gets or sets column relative width.

See Also

FieldWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


AggregateType Property

[image]

.NET ModelKit Suite ClassReference
FieldWizardInfo..::.AggregateType Property
FieldWizardInfo Class See Also Send Feedback
Gets or sets column aggregate type.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public WizardAggregateType AggregateType { get; set; }
Visual Basic (Declaration)
Public Property AggregateType As WizardAggregateType
Visual C++
public:
property WizardAggregateType AggregateType {
    WizardAggregateType get ();
    void set (WizardAggregateType value);
}

See Also

FieldWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


DataMember Property

[image]

.NET ModelKit Suite ClassReference
FieldWizardInfo..::.DataMember Property
FieldWizardInfo Class See Also Send Feedback
Gets or sets data member.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string DataMember { get; set; }
Visual Basic (Declaration)
Public Property DataMember As String
Visual C++
public:
property String^ DataMember {
    String^ get ();
    void set (String^ value);
}

See Also

FieldWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


Title Property

[image]

.NET ModelKit Suite ClassReference
FieldWizardInfo..::.Title Property
FieldWizardInfo Class See Also Send Feedback
Gets or sets column title.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

FieldWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


Width Property

[image]

.NET ModelKit Suite ClassReference
FieldWizardInfo..::.Width Property
FieldWizardInfo Class See Also Send Feedback
Gets or sets column relative width.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public float Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Single
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}

See Also

FieldWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


FieldWizardInfoCollection Class

[image]

.NET ModelKit Suite ClassReference
FieldWizardInfoCollection Class
Members See Also Send Feedback
Defines a collection of FieldWizardInfo in the report.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class FieldWizardInfoCollection : CollectionBase
Visual Basic (Declaration)
Public Class FieldWizardInfoCollection _
    Inherits CollectionBase
Visual C++
public ref class FieldWizardInfoCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Reporting.Wizards..::.FieldWizardInfoCollection

See Also

FieldWizardInfoCollection Members
PerpetuumSoft.Reporting.Wizards Namespace


FieldWizardInfoCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
FieldWizardInfoCollection Members
FieldWizardInfoCollection Class Constructors Methods Properties See Also Send Feedback

The FieldWizardInfoCollection type exposes the following members.

Constructors

Name | Description
FieldWizardInfoCollection | Creates a new instance of FieldWizardInfoCollection class.

Methods

Name | Description
Add | Adds the specified field info to the collection.
AddRange | Adds the specified array of field infos to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the specified field info exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified field infoэы index in the collection.
Insert | Inserts the specified field info to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified field info from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets a field info from the collection at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

FieldWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


FieldWizardInfoCollection Constructor

[image]

.NET ModelKit Suite ClassReference
FieldWizardInfoCollection Constructor
FieldWizardInfoCollection Class See Also Send Feedback
Creates a new instance of FieldWizardInfoCollection class.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldWizardInfoCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FieldWizardInfoCollection()

See Also

FieldWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


FieldWizardInfoCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
FieldWizardInfoCollection Methods
FieldWizardInfoCollection Class See Also Send Feedback

The FieldWizardInfoCollection type exposes the following members.

Methods

Name | Description
Add | Adds the specified field info to the collection.
AddRange | Adds the specified array of field infos to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the specified field info exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified field infoэы index in the collection.
Insert | Inserts the specified field info to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified field info from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
FieldWizardInfoCollection..::.Add Method
FieldWizardInfoCollection Class See Also Send Feedback
Adds the specified field info to the collection.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldWizardInfo Add(
    FieldWizardInfo value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As FieldWizardInfo _
) As FieldWizardInfo
Visual C++
public:
FieldWizardInfo^ Add(
    FieldWizardInfo^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Wizards..::.FieldWizardInfo

See Also

FieldWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
FieldWizardInfoCollection..::.AddRange Method
FieldWizardInfoCollection Class See Also Send Feedback
Adds the specified array of field infos to the collection.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    FieldWizardInfo[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As FieldWizardInfo() _
)
Visual C++
public:
void AddRange(
    array<FieldWizardInfo^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Reporting.Wizards..::.FieldWizardInfo >[]()[]

See Also

FieldWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
FieldWizardInfoCollection..::.Contains Method
FieldWizardInfoCollection Class See Also Send Feedback
Returns whether the specified field info exists in the collection.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    FieldWizardInfo value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As FieldWizardInfo _
) As Boolean
Visual C++
public:
bool Contains(
    FieldWizardInfo^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Wizards..::.FieldWizardInfo

See Also

FieldWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
FieldWizardInfoCollection..::.IndexOf Method
FieldWizardInfoCollection Class See Also Send Feedback
Returns the specified field infoэы index in the collection.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    FieldWizardInfo value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As FieldWizardInfo _
) As Integer
Visual C++
public:
int IndexOf(
    FieldWizardInfo^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Wizards..::.FieldWizardInfo

See Also

FieldWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
FieldWizardInfoCollection..::.Insert Method
FieldWizardInfoCollection Class See Also Send Feedback
Inserts the specified field info to the collection at the specified index.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    FieldWizardInfo value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As FieldWizardInfo _
)
Visual C++
public:
void Insert(
    int index,
    FieldWizardInfo^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Reporting.Wizards..::.FieldWizardInfo

See Also

FieldWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
FieldWizardInfoCollection..::.Remove Method
FieldWizardInfoCollection Class See Also Send Feedback
Removes the specified field info from the collection.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    FieldWizardInfo value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As FieldWizardInfo _
)
Visual C++
public:
void Remove(
    FieldWizardInfo^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Wizards..::.FieldWizardInfo

See Also

FieldWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


FieldWizardInfoCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
FieldWizardInfoCollection Properties
FieldWizardInfoCollection Class See Also Send Feedback

The FieldWizardInfoCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets a field info from the collection at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

FieldWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
FieldWizardInfoCollection..::.Item Property
FieldWizardInfoCollection Class See Also Send Feedback
Gets a field info from the collection at the specified index.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public FieldWizardInfo this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As FieldWizardInfo
Visual C++
public:
property FieldWizardInfo^ default[int index] {
    FieldWizardInfo^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

FieldWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


GroupWizardInfo Class

[image]

.NET ModelKit Suite ClassReference
GroupWizardInfo Class
Members See Also Send Feedback
Incapsulates groupping settings.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class GroupWizardInfo
Visual Basic (Declaration)
Public Class GroupWizardInfo
Visual C++
public ref class GroupWizardInfo

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Wizards..::.GroupWizardInfo

See Also

GroupWizardInfo Members
PerpetuumSoft.Reporting.Wizards Namespace


GroupWizardInfo Members

[image] [image]

.NET ModelKit Suite ClassReference
GroupWizardInfo Members
GroupWizardInfo Class Constructors Methods Properties See Also Send Feedback

The GroupWizardInfo type exposes the following members.

Constructors

Name | Description
GroupWizardInfo | Creates a new instance of GroupWizardInfo class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetResultExpression | Return group expression.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DataMember | Gets or sets group data member.
GroupExpression | Gets or sets group expression.

See Also

GroupWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


GroupWizardInfo Constructor

[image]

.NET ModelKit Suite ClassReference
GroupWizardInfo Constructor
GroupWizardInfo Class See Also Send Feedback
Creates a new instance of GroupWizardInfo class.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public GroupWizardInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupWizardInfo()

See Also

GroupWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


GroupWizardInfo Methods

[image] [image]

.NET ModelKit Suite ClassReference
GroupWizardInfo Methods
GroupWizardInfo Class See Also Send Feedback

The GroupWizardInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetResultExpression | Return group expression.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


GetResultExpression Method

[image]

.NET ModelKit Suite ClassReference
GroupWizardInfo..::.GetResultExpression Method
GroupWizardInfo Class See Also Send Feedback
Return group expression.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string GetResultExpression()
Visual Basic (Declaration)
Public Function GetResultExpression As String
Visual C++
public:
String^ GetResultExpression()

See Also

GroupWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


GroupWizardInfo Properties

[image] [image]

.NET ModelKit Suite ClassReference
GroupWizardInfo Properties
GroupWizardInfo Class See Also Send Feedback

The GroupWizardInfo type exposes the following members.

Properties

Name | Description
DataMember | Gets or sets group data member.
GroupExpression | Gets or sets group expression.

See Also

GroupWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


DataMember Property

[image]

.NET ModelKit Suite ClassReference
GroupWizardInfo..::.DataMember Property
GroupWizardInfo Class See Also Send Feedback
Gets or sets group data member.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string DataMember { get; set; }
Visual Basic (Declaration)
Public Property DataMember As String
Visual C++
public:
property String^ DataMember {
    String^ get ();
    void set (String^ value);
}

See Also

GroupWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


GroupExpression Property

[image]

.NET ModelKit Suite ClassReference
GroupWizardInfo..::.GroupExpression Property
GroupWizardInfo Class See Also Send Feedback
Gets or sets group expression.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string GroupExpression { get; set; }
Visual Basic (Declaration)
Public Property GroupExpression As String
Visual C++
public:
property String^ GroupExpression {
    String^ get ();
    void set (String^ value);
}

See Also

GroupWizardInfo Class
PerpetuumSoft.Reporting.Wizards Namespace


GroupWizardInfoCollection Class

[image]

.NET ModelKit Suite ClassReference
GroupWizardInfoCollection Class
Members See Also Send Feedback
Defines a collection of data groups in the report.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class GroupWizardInfoCollection : CollectionBase
Visual Basic (Declaration)
Public Class GroupWizardInfoCollection _
    Inherits CollectionBase
Visual C++
public ref class GroupWizardInfoCollection : public CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
PerpetuumSoft.Reporting.Wizards..::.GroupWizardInfoCollection

See Also

GroupWizardInfoCollection Members
PerpetuumSoft.Reporting.Wizards Namespace


GroupWizardInfoCollection Members

[image] [image]

.NET ModelKit Suite ClassReference
GroupWizardInfoCollection Members
GroupWizardInfoCollection Class Constructors Methods Properties See Also Send Feedback

The GroupWizardInfoCollection type exposes the following members.

Constructors

Name | Description
GroupWizardInfoCollection | Creates a new instance of GroupWizardInfoCollection class.

Methods

Name | Description
Add | Adds the specified group to the collection.
AddRange | Adds the specified array of groups to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the specified group exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified groupэы index in the collection.
Insert | Inserts the specified group to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified group from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets a group from the collection at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

GroupWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


GroupWizardInfoCollection Constructor

[image]

.NET ModelKit Suite ClassReference
GroupWizardInfoCollection Constructor
GroupWizardInfoCollection Class See Also Send Feedback
Creates a new instance of GroupWizardInfoCollection class.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public GroupWizardInfoCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupWizardInfoCollection()

See Also

GroupWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


GroupWizardInfoCollection Methods

[image] [image]

.NET ModelKit Suite ClassReference
GroupWizardInfoCollection Methods
GroupWizardInfoCollection Class See Also Send Feedback

The GroupWizardInfoCollection type exposes the following members.

Methods

Name | Description
Add | Adds the specified group to the collection.
AddRange | Adds the specified array of groups to the collection.
Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Contains | Returns whether the specified group exists in the collection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Returns the specified groupэы index in the collection.
Insert | Inserts the specified group to the collection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
OnValidate | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
Remove | Removes the specified group from the collection.
RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


Add Method

[image]

.NET ModelKit Suite ClassReference
GroupWizardInfoCollection..::.Add Method
GroupWizardInfoCollection Class See Also Send Feedback
Adds the specified group to the collection.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public GroupWizardInfo Add(
    GroupWizardInfo value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As GroupWizardInfo _
) As GroupWizardInfo
Visual C++
public:
GroupWizardInfo^ Add(
    GroupWizardInfo^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Wizards..::.GroupWizardInfo

See Also

GroupWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


AddRange Method

[image]

.NET ModelKit Suite ClassReference
GroupWizardInfoCollection..::.AddRange Method
GroupWizardInfoCollection Class See Also Send Feedback
Adds the specified array of groups to the collection.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void AddRange(
    GroupWizardInfo[] values
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    values As GroupWizardInfo() _
)
Visual C++
public:
void AddRange(
    array<GroupWizardInfo^>^ values
)

Parameters

values
Type: array< PerpetuumSoft.Reporting.Wizards..::.GroupWizardInfo >[]()[]

See Also

GroupWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


Contains Method

[image]

.NET ModelKit Suite ClassReference
GroupWizardInfoCollection..::.Contains Method
GroupWizardInfoCollection Class See Also Send Feedback
Returns whether the specified group exists in the collection.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool Contains(
    GroupWizardInfo value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As GroupWizardInfo _
) As Boolean
Visual C++
public:
bool Contains(
    GroupWizardInfo^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Wizards..::.GroupWizardInfo

See Also

GroupWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


IndexOf Method

[image]

.NET ModelKit Suite ClassReference
GroupWizardInfoCollection..::.IndexOf Method
GroupWizardInfoCollection Class See Also Send Feedback
Returns the specified groupэы index in the collection.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int IndexOf(
    GroupWizardInfo value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As GroupWizardInfo _
) As Integer
Visual C++
public:
int IndexOf(
    GroupWizardInfo^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Wizards..::.GroupWizardInfo

See Also

GroupWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


Insert Method

[image]

.NET ModelKit Suite ClassReference
GroupWizardInfoCollection..::.Insert Method
GroupWizardInfoCollection Class See Also Send Feedback
Inserts the specified group to the collection at the specified index.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Insert(
    int index,
    GroupWizardInfo value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As GroupWizardInfo _
)
Visual C++
public:
void Insert(
    int index,
    GroupWizardInfo^ value
)

Parameters

index
Type: System..::.Int32
value
Type: PerpetuumSoft.Reporting.Wizards..::.GroupWizardInfo

See Also

GroupWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


Remove Method

[image]

.NET ModelKit Suite ClassReference
GroupWizardInfoCollection..::.Remove Method
GroupWizardInfoCollection Class See Also Send Feedback
Removes the specified group from the collection.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public void Remove(
    GroupWizardInfo value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As GroupWizardInfo _
)
Visual C++
public:
void Remove(
    GroupWizardInfo^ value
)

Parameters

value
Type: PerpetuumSoft.Reporting.Wizards..::.GroupWizardInfo

See Also

GroupWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


GroupWizardInfoCollection Properties

[image] [image]

.NET ModelKit Suite ClassReference
GroupWizardInfoCollection Properties
GroupWizardInfoCollection Class See Also Send Feedback

The GroupWizardInfoCollection type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
Item | Gets a group from the collection at the specified index.
List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)

See Also

GroupWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


Item Property

[image]

.NET ModelKit Suite ClassReference
GroupWizardInfoCollection..::.Item Property
GroupWizardInfoCollection Class See Also Send Feedback
Gets a group from the collection at the specified index.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public GroupWizardInfo this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As GroupWizardInfo
Visual C++
public:
property GroupWizardInfo^ default[int index] {
    GroupWizardInfo^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

GroupWizardInfoCollection Class
PerpetuumSoft.Reporting.Wizards Namespace


PageNumberAlign Enumeration

[image]

.NET ModelKit Suite ClassReference
PageNumberAlign Enumeration
See Also Send Feedback
Page numbers align.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum PageNumberAlign
Visual Basic (Declaration)
Public Enumeration PageNumberAlign
Visual C++
public enum class PageNumberAlign

Members

Member name | Description
Left | At left.
Center | At center.
Right | At right.

See Also

PerpetuumSoft.Reporting.Wizards Namespace


PageNumberPosition Enumeration

[image]

.NET ModelKit Suite ClassReference
PageNumberPosition Enumeration
See Also Send Feedback
Page numbers position.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
[FlagsAttribute]
public enum PageNumberPosition
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration PageNumberPosition
Visual C++
[FlagsAttribute]
public enum class PageNumberPosition

Members

Member name | Description
None | Do not show.
Header | Show in header.
Footer | Show in footer.
Both | Show in header and footer.

See Also

PerpetuumSoft.Reporting.Wizards Namespace


StandardWizard Class

[image]

.NET ModelKit Suite ClassReference
StandardWizard Class
Members See Also Send Feedback
Standard wizard. Creates templates for all common reports types.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class StandardWizard : CommonWizard
Visual Basic (Declaration)
Public Class StandardWizard _
    Inherits CommonWizard
Visual C++
public ref class StandardWizard : public CommonWizard

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Wizards..::.WizardBase
PerpetuumSoft.Reporting.Wizards..::.CommonWizard
PerpetuumSoft.Reporting.Wizards..::.StandardWizard

See Also

StandardWizard Members
PerpetuumSoft.Reporting.Wizards Namespace


StandardWizard Members

[image] [image]

.NET ModelKit Suite ClassReference
StandardWizard Members
StandardWizard Class Constructors Methods Properties See Also Send Feedback

The StandardWizard type exposes the following members.

Constructors

Name | Description
StandardWizard | Creates a new instance of StandardWizard class.

Methods

Name | Description
AddBand | Adds a band to a template. (Inherited from CommonWizard.)
BuildTemplate | Builds template. (Inherited from WizardBase.)
CreateDataBands | Creates data sections. (Overrides CommonWizard..::.CreateDataBands()()().)
CreatePageFooter | Creates page footer. (Inherited from CommonWizard.)
CreatePageHeader | Creates page header. (Inherited from CommonWizard.)
CreateReportTitle | Creates report title. (Inherited from CommonWizard.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InternalBuildTemplate | Performs actual template creation. (Overrides CommonWizard..::.InternalBuildTemplate()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ShowDialog | Shows wizard dialog. (Overrides CommonWizard..::.ShowDialog(Form, IReportDesignerService).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColumnsCount | Gets or sets columns count.
ColumnsGap | Gets or sets column Gap.
CustomPageSize | Get or sets custom page size. (Inherited from CommonWizard.)
DataSections | Gets collection of data sections in report.
Gap | Gets gap. (Inherited from CommonWizard.)
InsertTitle | Gets or sets if report title should be inserted in template. (Inherited from CommonWizard.)
MeasureUnit | Gets or sets measure units. (Inherited from CommonWizard.)
Page | Currently generated page. (Inherited from CommonWizard.)
PageNumberAlign | Gets or sets page number align mode. (Inherited from CommonWizard.)
PageNumberPosition | Gets or sets page number position. (Inherited from CommonWizard.)
PageOrientation | Gets or sets page orientation. (Inherited from CommonWizard.)
PaperKind | Gets or sets paper kind. (Inherited from CommonWizard.)
ReportTitle | Gets or sets report title. (Inherited from CommonWizard.)
ScriptLanguage | Gets or sets script language. (Inherited from CommonWizard.)
Step | Gets step. (Inherited from CommonWizard.)
StyleSheet | Gets or sets template stylesheet. (Inherited from CommonWizard.)
Y | Current position. (Inherited from CommonWizard.)

See Also

StandardWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


StandardWizard Constructor

[image]

.NET ModelKit Suite ClassReference
StandardWizard Constructor
StandardWizard Class See Also Send Feedback
Creates a new instance of StandardWizard class.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public StandardWizard()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StandardWizard()

See Also

StandardWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


StandardWizard Methods

[image] [image]

.NET ModelKit Suite ClassReference
StandardWizard Methods
StandardWizard Class See Also Send Feedback

The StandardWizard type exposes the following members.

Methods

Name | Description
AddBand | Adds a band to a template. (Inherited from CommonWizard.)
BuildTemplate | Builds template. (Inherited from WizardBase.)
CreateDataBands | Creates data sections. (Overrides CommonWizard..::.CreateDataBands()()().)
CreatePageFooter | Creates page footer. (Inherited from CommonWizard.)
CreatePageHeader | Creates page header. (Inherited from CommonWizard.)
CreateReportTitle | Creates report title. (Inherited from CommonWizard.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InternalBuildTemplate | Performs actual template creation. (Overrides CommonWizard..::.InternalBuildTemplate()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ShowDialog | Shows wizard dialog. (Overrides CommonWizard..::.ShowDialog(Form, IReportDesignerService).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StandardWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


CreateDataBands Method

[image]

.NET ModelKit Suite ClassReference
StandardWizard..::.CreateDataBands Method
StandardWizard Class See Also Send Feedback
Creates data sections.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void CreateDataBands()
Visual Basic (Declaration)
Protected Overrides Sub CreateDataBands
Visual C++
protected:
virtual void CreateDataBands() override

See Also

StandardWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


InternalBuildTemplate Method

[image]

.NET ModelKit Suite ClassReference
StandardWizard..::.InternalBuildTemplate Method
StandardWizard Class See Also Send Feedback
Performs actual template creation.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override Document InternalBuildTemplate()
Visual Basic (Declaration)
Protected Overrides Function InternalBuildTemplate As Document
Visual C++
protected:
virtual Document^ InternalBuildTemplate() override

See Also

StandardWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


ShowDialog Method

[image]

.NET ModelKit Suite ClassReference
StandardWizard..::.ShowDialog Method
StandardWizard Class See Also Send Feedback
Shows wizard dialog.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override DialogResult ShowDialog(
    Form owner,
    IReportDesignerService rds
)
Visual Basic (Declaration)
Public Overrides Function ShowDialog ( _
    owner As Form, _
    rds As IReportDesignerService _
) As DialogResult
Visual C++
public:
virtual DialogResult ShowDialog(
    Form^ owner,
    IReportDesignerService^ rds
) override

Parameters

owner
Type: System.Windows.Forms..::.Form
rds
Type: PerpetuumSoft.Reporting.Designer..::.IReportDesignerService

See Also

StandardWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


StandardWizard Properties

[image] [image]

.NET ModelKit Suite ClassReference
StandardWizard Properties
StandardWizard Class See Also Send Feedback

The StandardWizard type exposes the following members.

Properties

Name | Description
ColumnsCount | Gets or sets columns count.
ColumnsGap | Gets or sets column Gap.
CustomPageSize | Get or sets custom page size. (Inherited from CommonWizard.)
DataSections | Gets collection of data sections in report.
Gap | Gets gap. (Inherited from CommonWizard.)
InsertTitle | Gets or sets if report title should be inserted in template. (Inherited from CommonWizard.)
MeasureUnit | Gets or sets measure units. (Inherited from CommonWizard.)
Page | Currently generated page. (Inherited from CommonWizard.)
PageNumberAlign | Gets or sets page number align mode. (Inherited from CommonWizard.)
PageNumberPosition | Gets or sets page number position. (Inherited from CommonWizard.)
PageOrientation | Gets or sets page orientation. (Inherited from CommonWizard.)
PaperKind | Gets or sets paper kind. (Inherited from CommonWizard.)
ReportTitle | Gets or sets report title. (Inherited from CommonWizard.)
ScriptLanguage | Gets or sets script language. (Inherited from CommonWizard.)
Step | Gets step. (Inherited from CommonWizard.)
StyleSheet | Gets or sets template stylesheet. (Inherited from CommonWizard.)
Y | Current position. (Inherited from CommonWizard.)

See Also

StandardWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


ColumnsCount Property

[image]

.NET ModelKit Suite ClassReference
StandardWizard..::.ColumnsCount Property
StandardWizard Class See Also Send Feedback
Gets or sets columns count.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int ColumnsCount { get; set; }
Visual Basic (Declaration)
Public Property ColumnsCount As Integer
Visual C++
public:
property int ColumnsCount {
    int get ();
    void set (int value);
}

See Also

StandardWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


ColumnsGap Property

[image]

.NET ModelKit Suite ClassReference
StandardWizard..::.ColumnsGap Property
StandardWizard Class See Also Send Feedback
Gets or sets column Gap.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public float ColumnsGap { get; set; }
Visual Basic (Declaration)
Public Property ColumnsGap As Single
Visual C++
public:
property float ColumnsGap {
    float get ();
    void set (float value);
}

See Also

StandardWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


DataSections Property

[image]

.NET ModelKit Suite ClassReference
StandardWizard..::.DataSections Property
StandardWizard Class See Also Send Feedback
Gets collection of data sections in report.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataWizardInfoCollection DataSections { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataSections As DataWizardInfoCollection
Visual C++
public:
property DataWizardInfoCollection^ DataSections {
    DataWizardInfoCollection^ get ();
}

See Also

StandardWizard Class
PerpetuumSoft.Reporting.Wizards Namespace


WizardAggregateType Enumeration

[image]

.NET ModelKit Suite ClassReference
WizardAggregateType Enumeration
See Also Send Feedback
Aggregate type.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public enum WizardAggregateType
Visual Basic (Declaration)
Public Enumeration WizardAggregateType
Visual C++
public enum class WizardAggregateType

Members

Member name | Description
None | None.
Sum | Sum.
Count | Count.
Min | Minimum.
Max | Maximum.
Avg | Average.
StandardDeviation | Standard deviation
EstimateOfStandardDeviation | Estimate of standard deviation
Variance | Variance
EstimateOfVariance | Estimate of variance
Median | Median
Skewness | Skewness
Kurtosis | Kurtosis

See Also

PerpetuumSoft.Reporting.Wizards Namespace


WizardBase Class

[image]

.NET ModelKit Suite ClassReference
WizardBase Class
Members See Also Send Feedback
Base class for the Report Sharp-Shooter wizards.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract class WizardBase
Visual Basic (Declaration)
Public MustInherit Class WizardBase
Visual C++
public ref class WizardBase abstract

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Wizards..::.WizardBase
PerpetuumSoft.Reporting.Wizards..::.BlankReportWizard
PerpetuumSoft.Reporting.Wizards..::.CommonWizard

See Also

WizardBase Members
PerpetuumSoft.Reporting.Wizards Namespace


WizardBase Members

[image] [image]

.NET ModelKit Suite ClassReference
WizardBase Members
WizardBase Class Constructors Methods Fields See Also Send Feedback

The WizardBase type exposes the following members.

Constructors

Name | Description
WizardBase | Initializes a new instance of the WizardBase class

Methods

Name | Description
BuildTemplate | Builds template.
CreateWizard | Creates wizard instance.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InternalBuildTemplate | When overriden in the derived class performs actual template creation.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareName | Prepare name
Register | Registers the controls library.
RegisterWizardType | Adds the specified control type to the registered controls list.
ShowDialog | When overriden in the derived class shows wizard settings dialog.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
WizardTypes | Collection of all registered wizard types.

See Also

WizardBase Class
PerpetuumSoft.Reporting.Wizards Namespace


WizardBase Constructor

[image]

.NET ModelKit Suite ClassReference
WizardBase Constructor
WizardBase Class See Also Send Feedback
Initializes a new instance of the WizardBase class

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected WizardBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
WizardBase()

See Also

WizardBase Class
PerpetuumSoft.Reporting.Wizards Namespace


WizardBase Fields

[image] [image]

.NET ModelKit Suite ClassReference
WizardBase Fields
WizardBase Class See Also Send Feedback

The WizardBase type exposes the following members.

Fields

Name | Description
WizardTypes | Collection of all registered wizard types.

See Also

WizardBase Class
PerpetuumSoft.Reporting.Wizards Namespace


WizardTypes Field

[image]

.NET ModelKit Suite ClassReference
WizardBase..::.WizardTypes Field
WizardBase Class See Also Send Feedback
Collection of all registered wizard types.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static readonly ArrayList WizardTypes
Visual Basic (Declaration)
Public Shared ReadOnly WizardTypes As ArrayList
Visual C++
public:
static initonly ArrayList^ WizardTypes

See Also

WizardBase Class
PerpetuumSoft.Reporting.Wizards Namespace


WizardBase Methods

[image] [image]

.NET ModelKit Suite ClassReference
WizardBase Methods
WizardBase Class See Also Send Feedback

The WizardBase type exposes the following members.

Methods

Name | Description
BuildTemplate | Builds template.
CreateWizard | Creates wizard instance.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InternalBuildTemplate | When overriden in the derived class performs actual template creation.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareName | Prepare name
Register | Registers the controls library.
RegisterWizardType | Adds the specified control type to the registered controls list.
ShowDialog | When overriden in the derived class shows wizard settings dialog.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WizardBase Class
PerpetuumSoft.Reporting.Wizards Namespace


BuildTemplate Method

[image]

.NET ModelKit Suite ClassReference
WizardBase..::.BuildTemplate Method
WizardBase Class See Also Send Feedback
Builds template.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public Document BuildTemplate()
Visual Basic (Declaration)
Public Function BuildTemplate As Document
Visual C++
public:
Document^ BuildTemplate()

See Also

WizardBase Class
PerpetuumSoft.Reporting.Wizards Namespace


CreateWizard Method

[image]

.NET ModelKit Suite ClassReference
WizardBase..::.CreateWizard Method
WizardBase Class See Also Send Feedback
Creates wizard instance.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static WizardBase CreateWizard(
    Type wizardType
)
Visual Basic (Declaration)
Public Shared Function CreateWizard ( _
    wizardType As Type _
) As WizardBase
Visual C++
public:
static WizardBase^ CreateWizard(
    Type^ wizardType
)

Parameters

wizardType
Type: System..::.Type

See Also

WizardBase Class
PerpetuumSoft.Reporting.Wizards Namespace


InternalBuildTemplate Method

[image]

.NET ModelKit Suite ClassReference
WizardBase..::.InternalBuildTemplate Method
WizardBase Class See Also Send Feedback
When overriden in the derived class performs actual template creation.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected abstract Document InternalBuildTemplate()
Visual Basic (Declaration)
Protected MustOverride Function InternalBuildTemplate As Document
Visual C++
protected:
virtual Document^ InternalBuildTemplate() abstract

See Also

WizardBase Class
PerpetuumSoft.Reporting.Wizards Namespace


PrepareName Method

[image]

.NET ModelKit Suite ClassReference
WizardBase..::.PrepareName Method
WizardBase Class See Also Send Feedback
Prepare name

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected static string PrepareName(
    string name
)
Visual Basic (Declaration)
Protected Shared Function PrepareName ( _
    name As String _
) As String
Visual C++
protected:
static String^ PrepareName(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

WizardBase Class
PerpetuumSoft.Reporting.Wizards Namespace


Register Method

[image]

.NET ModelKit Suite ClassReference
WizardBase..::.Register Method
WizardBase Class See Also Send Feedback
Registers the controls library.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static void Register()
Visual Basic (Declaration)
Public Shared Sub Register
Visual C++
public:
static void Register()

See Also

WizardBase Class
PerpetuumSoft.Reporting.Wizards Namespace


RegisterWizardType Method

[image]

.NET ModelKit Suite ClassReference
WizardBase..::.RegisterWizardType Method
WizardBase Class See Also Send Feedback
Adds the specified control type to the registered controls list.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static void RegisterWizardType(
    Type wizardType
)
Visual Basic (Declaration)
Public Shared Sub RegisterWizardType ( _
    wizardType As Type _
)
Visual C++
public:
static void RegisterWizardType(
    Type^ wizardType
)

Parameters

wizardType
Type: System..::.Type

See Also

WizardBase Class
PerpetuumSoft.Reporting.Wizards Namespace


ShowDialog Method

[image]

.NET ModelKit Suite ClassReference
WizardBase..::.ShowDialog Method
WizardBase Class See Also Send Feedback
When overriden in the derived class shows wizard settings dialog.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public abstract DialogResult ShowDialog(
    Form owner,
    IReportDesignerService rds
)
Visual Basic (Declaration)
Public MustOverride Function ShowDialog ( _
    owner As Form, _
    rds As IReportDesignerService _
) As DialogResult
Visual C++
public:
virtual DialogResult ShowDialog(
    Form^ owner,
    IReportDesignerService^ rds
) abstract

Parameters

owner
Type: System.Windows.Forms..::.Form
rds
Type: PerpetuumSoft.Reporting.Designer..::.IReportDesignerService

See Also

WizardBase Class
PerpetuumSoft.Reporting.Wizards Namespace


WizardNameAttribute Class

[image]

.NET ModelKit Suite ClassReference
WizardNameAttribute Class
Members See Also Send Feedback
Assigns name to the wizard type.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class WizardNameAttribute : Attribute
Visual Basic (Declaration)
Public Class WizardNameAttribute _
    Inherits Attribute
Visual C++
public ref class WizardNameAttribute : public Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
PerpetuumSoft.Reporting.Wizards..::.WizardNameAttribute

See Also

WizardNameAttribute Members
PerpetuumSoft.Reporting.Wizards Namespace


WizardNameAttribute Members

[image] [image]

.NET ModelKit Suite ClassReference
WizardNameAttribute Members
WizardNameAttribute Class Constructors Methods Properties See Also Send Feedback

The WizardNameAttribute type exposes the following members.

Constructors

Name | Description
WizardNameAttribute | Creates new instance of the WizardNameAttribute.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWizardName | Gets the name for the given wizards type.
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name | Gets or sets wizard name.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

WizardNameAttribute Class
PerpetuumSoft.Reporting.Wizards Namespace


WizardNameAttribute Constructor

[image]

.NET ModelKit Suite ClassReference
WizardNameAttribute Constructor
WizardNameAttribute Class See Also Send Feedback
Creates new instance of the WizardNameAttribute.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public WizardNameAttribute(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)
Visual C++
public:
WizardNameAttribute(
    String^ name
)

Parameters

name
Type: System..::.String

See Also

WizardNameAttribute Class
PerpetuumSoft.Reporting.Wizards Namespace


WizardNameAttribute Methods

[image] [image]

.NET ModelKit Suite ClassReference
WizardNameAttribute Methods
WizardNameAttribute Class See Also Send Feedback

The WizardNameAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWizardName | Gets the name for the given wizards type.
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WizardNameAttribute Class
PerpetuumSoft.Reporting.Wizards Namespace


GetWizardName Method

[image]

.NET ModelKit Suite ClassReference
WizardNameAttribute..::.GetWizardName Method
WizardNameAttribute Class See Also Send Feedback
Gets the name for the given wizards type.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public static string GetWizardName(
    Type wizardType
)
Visual Basic (Declaration)
Public Shared Function GetWizardName ( _
    wizardType As Type _
) As String
Visual C++
public:
static String^ GetWizardName(
    Type^ wizardType
)

Parameters

wizardType
Type: System..::.Type

See Also

WizardNameAttribute Class
PerpetuumSoft.Reporting.Wizards Namespace


WizardNameAttribute Properties

[image] [image]

.NET ModelKit Suite ClassReference
WizardNameAttribute Properties
WizardNameAttribute Class See Also Send Feedback

The WizardNameAttribute type exposes the following members.

Properties

Name | Description
Name | Gets or sets wizard name.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

WizardNameAttribute Class
PerpetuumSoft.Reporting.Wizards Namespace


Name Property

[image]

.NET ModelKit Suite ClassReference
WizardNameAttribute..::.Name Property
WizardNameAttribute Class See Also Send Feedback
Gets or sets wizard name.

Namespace: PerpetuumSoft.Reporting.Wizards
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

WizardNameAttribute Class
PerpetuumSoft.Reporting.Wizards Namespace


PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace

[image]

.NET ModelKit Suite ClassReference
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace
Send Feedback
The PerpetuumSoft.Reporting.Wizards.PivotTableWizard namespace contains classes which are used for creation of pivot table reports using wizard.

Classes

Class | Description
PivotTableWizard | Pivot table wizard. Creates report templates with pivot table.
PivotTableWizardForm | A dialog window for assigning settings of the pivote table wizard


PivotTableWizard Class

[image]

.NET ModelKit Suite ClassReference
PivotTableWizard Class
Members See Also Send Feedback
Pivot table wizard. Creates report templates with pivot table.

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class PivotTableWizard : CommonWizard
Visual Basic (Declaration)
Public Class PivotTableWizard _
    Inherits CommonWizard
Visual C++
public ref class PivotTableWizard : public CommonWizard

Inheritance Hierarchy

System..::.Object
PerpetuumSoft.Reporting.Wizards..::.WizardBase
PerpetuumSoft.Reporting.Wizards..::.CommonWizard
PerpetuumSoft.Reporting.Wizards.PivotTableWizard..::.PivotTableWizard

See Also

PivotTableWizard Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


PivotTableWizard Members

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizard Members
PivotTableWizard Class Constructors Methods Properties See Also Send Feedback

The PivotTableWizard type exposes the following members.

Constructors

Name | Description
PivotTableWizard | Initializes a new instance of the PivotTableWizard class.

Methods

Name | Description
AddBand | Adds a band to a template. (Inherited from CommonWizard.)
BuildTemplate | Builds template. (Inherited from WizardBase.)
CreateDataBands | Creates data sections. (Overrides CommonWizard..::.CreateDataBands()()().)
CreatePageFooter | Creates page footer. (Inherited from CommonWizard.)
CreatePageHeader | Creates page header. (Inherited from CommonWizard.)
CreateReportTitle | Creates report title. (Overrides CommonWizard..::.CreateReportTitle()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InternalBuildTemplate | Perform actual template generation. (Inherited from CommonWizard.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ShowDialog | Overridden. See ShowDialog(Form, IReportDesignerService). (Overrides CommonWizard..::.ShowDialog(Form, IReportDesignerService).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AutoColumnWidth | Gets or sets a value indicating whether the column width will be aligned by cell content.
AutoRowHeight | Gets or sets row heidth aligment mode.
CustomPageSize | Get or sets custom page size. (Inherited from CommonWizard.)
DimensionOnEveryPage | Gets or sets the value indicating whether dimension cells will be printed on every page.
Gap | Gets gap. (Inherited from CommonWizard.)
InsertTitle | Gets or sets if report title should be inserted in template. (Inherited from CommonWizard.)
Layout | Gets or sets pivot table settings.
MeasureUnit | Gets or sets measure units. (Inherited from CommonWizard.)
NestedFields | Gets or sets a collection of data source fields which are used as the nested source.
Page | Currently generated page. (Inherited from CommonWizard.)
PageNumberAlign | Gets or sets page number align mode. (Inherited from CommonWizard.)
PageNumberPosition | Gets or sets page number position. (Inherited from CommonWizard.)
PageOrientation | Gets or sets page orientation. (Inherited from CommonWizard.)
PaperKind | Gets or sets paper kind. (Inherited from CommonWizard.)
PivotTableDataSource | Gets or sets pivot table data source.
ReportTitle | Gets or sets report title. (Inherited from CommonWizard.)
RowHeight | Gets or sets default row height.
ScriptLanguage | Gets or sets script language. (Inherited from CommonWizard.)
ShowRepeatText | Gets or sets a value indicating whether the endurable text will be displayed.
ShowSingleFact | Gets or sets whether a single fact caption should be visible.
ShowTableCaption | Gets or sets a value indicating whether the pivot table caption will be displayed.
Step | Gets step. (Inherited from CommonWizard.)
StyleSheet | Gets or sets template stylesheet. (Inherited from CommonWizard.)
TableCaption | Gets or sets pivot table caption.
Y | Current position. (Inherited from CommonWizard.)

See Also

PivotTableWizard Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


PivotTableWizard Constructor

[image]

.NET ModelKit Suite ClassReference
PivotTableWizard Constructor
PivotTableWizard Class See Also Send Feedback
Initializes a new instance of the PivotTableWizard class.

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PivotTableWizard()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PivotTableWizard()

See Also

PivotTableWizard Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


PivotTableWizard Methods

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizard Methods
PivotTableWizard Class See Also Send Feedback

The PivotTableWizard type exposes the following members.

Methods

Name | Description
AddBand | Adds a band to a template. (Inherited from CommonWizard.)
BuildTemplate | Builds template. (Inherited from WizardBase.)
CreateDataBands | Creates data sections. (Overrides CommonWizard..::.CreateDataBands()()().)
CreatePageFooter | Creates page footer. (Inherited from CommonWizard.)
CreatePageHeader | Creates page header. (Inherited from CommonWizard.)
CreateReportTitle | Creates report title. (Overrides CommonWizard..::.CreateReportTitle()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InternalBuildTemplate | Perform actual template generation. (Inherited from CommonWizard.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ShowDialog | Overridden. See ShowDialog(Form, IReportDesignerService). (Overrides CommonWizard..::.ShowDialog(Form, IReportDesignerService).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PivotTableWizard Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


CreateDataBands Method

[image]

.NET ModelKit Suite ClassReference
PivotTableWizard..::.CreateDataBands Method
PivotTableWizard Class See Also Send Feedback
Creates data sections.

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void CreateDataBands()
Visual Basic (Declaration)
Protected Overrides Sub CreateDataBands
Visual C++
protected:
virtual void CreateDataBands() override

See Also

PivotTableWizard Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


CreateReportTitle Method

[image]

.NET ModelKit Suite ClassReference
PivotTableWizard..::.CreateReportTitle Method
PivotTableWizard Class See Also Send Feedback
Creates report title.

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void CreateReportTitle()
Visual Basic (Declaration)
Protected Overrides Sub CreateReportTitle
Visual C++
protected:
virtual void CreateReportTitle() override

See Also

PivotTableWizard Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


ShowDialog Method

[image]

.NET ModelKit Suite ClassReference
PivotTableWizard..::.ShowDialog Method
PivotTableWizard Class See Also Send Feedback
Overridden. See ShowDialog(Form, IReportDesignerService).

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public override DialogResult ShowDialog(
    Form owner,
    IReportDesignerService rds
)
Visual Basic (Declaration)
Public Overrides Function ShowDialog ( _
    owner As Form, _
    rds As IReportDesignerService _
) As DialogResult
Visual C++
public:
virtual DialogResult ShowDialog(
    Form^ owner,
    IReportDesignerService^ rds
) override

Parameters

owner
Type: System.Windows.Forms..::.Form
rds
Type: PerpetuumSoft.Reporting.Designer..::.IReportDesignerService

See Also

PivotTableWizard Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


PivotTableWizard Properties

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizard Properties
PivotTableWizard Class See Also Send Feedback

The PivotTableWizard type exposes the following members.

Properties

Name | Description
AutoColumnWidth | Gets or sets a value indicating whether the column width will be aligned by cell content.
AutoRowHeight | Gets or sets row heidth aligment mode.
CustomPageSize | Get or sets custom page size. (Inherited from CommonWizard.)
DimensionOnEveryPage | Gets or sets the value indicating whether dimension cells will be printed on every page.
Gap | Gets gap. (Inherited from CommonWizard.)
InsertTitle | Gets or sets if report title should be inserted in template. (Inherited from CommonWizard.)
Layout | Gets or sets pivot table settings.
MeasureUnit | Gets or sets measure units. (Inherited from CommonWizard.)
NestedFields | Gets or sets a collection of data source fields which are used as the nested source.
Page | Currently generated page. (Inherited from CommonWizard.)
PageNumberAlign | Gets or sets page number align mode. (Inherited from CommonWizard.)
PageNumberPosition | Gets or sets page number position. (Inherited from CommonWizard.)
PageOrientation | Gets or sets page orientation. (Inherited from CommonWizard.)
PaperKind | Gets or sets paper kind. (Inherited from CommonWizard.)
PivotTableDataSource | Gets or sets pivot table data source.
ReportTitle | Gets or sets report title. (Inherited from CommonWizard.)
RowHeight | Gets or sets default row height.
ScriptLanguage | Gets or sets script language. (Inherited from CommonWizard.)
ShowRepeatText | Gets or sets a value indicating whether the endurable text will be displayed.
ShowSingleFact | Gets or sets whether a single fact caption should be visible.
ShowTableCaption | Gets or sets a value indicating whether the pivot table caption will be displayed.
Step | Gets step. (Inherited from CommonWizard.)
StyleSheet | Gets or sets template stylesheet. (Inherited from CommonWizard.)
TableCaption | Gets or sets pivot table caption.
Y | Current position. (Inherited from CommonWizard.)

See Also

PivotTableWizard Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


AutoColumnWidth Property

[image]

.NET ModelKit Suite ClassReference
PivotTableWizard..::.AutoColumnWidth Property
PivotTableWizard Class See Also Send Feedback
Gets or sets a value indicating whether the column width will be aligned by cell content.

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool AutoColumnWidth { get; set; }
Visual Basic (Declaration)
Public Property AutoColumnWidth As Boolean
Visual C++
public:
property bool AutoColumnWidth {
    bool get ();
    void set (bool value);
}

See Also

PivotTableWizard Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


AutoRowHeight Property

[image]

.NET ModelKit Suite ClassReference
PivotTableWizard..::.AutoRowHeight Property
PivotTableWizard Class See Also Send Feedback
Gets or sets row heidth aligment mode.

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PivotTable..::.AutoRowHeightMode AutoRowHeight { get; set; }
Visual Basic (Declaration)
Public Property AutoRowHeight As PivotTable..::.AutoRowHeightMode
Visual C++
public:
property PivotTable..::.AutoRowHeightMode AutoRowHeight {
    PivotTable..::.AutoRowHeightMode get ();
    void set (PivotTable..::.AutoRowHeightMode value);
}

See Also

PivotTableWizard Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


DimensionOnEveryPage Property

[image]

.NET ModelKit Suite ClassReference
PivotTableWizard..::.DimensionOnEveryPage Property
PivotTableWizard Class See Also Send Feedback
Gets or sets the value indicating whether dimension cells will be printed on every page.

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool DimensionOnEveryPage { get; set; }
Visual Basic (Declaration)
Public Property DimensionOnEveryPage As Boolean
Visual C++
public:
property bool DimensionOnEveryPage {
    bool get ();
    void set (bool value);
}

See Also

PivotTableWizard Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


Layout Property

[image]

.NET ModelKit Suite ClassReference
PivotTableWizard..::.Layout Property
PivotTableWizard Class See Also Send Feedback
Gets or sets pivot table settings.

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public DataCubeLayout Layout { get; set; }
Visual Basic (Declaration)
Public Property Layout As DataCubeLayout
Visual C++
public:
property DataCubeLayout^ Layout {
    DataCubeLayout^ get ();
    void set (DataCubeLayout^ value);
}

See Also

PivotTableWizard Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


NestedFields Property

[image]

.NET ModelKit Suite ClassReference
PivotTableWizard..::.NestedFields Property
PivotTableWizard Class See Also Send Feedback
Gets or sets a collection of data source fields which are used as the nested source.

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public NestedFieldCollection NestedFields { get; set; }
Visual Basic (Declaration)
Public Property NestedFields As NestedFieldCollection
Visual C++
public:
property NestedFieldCollection^ NestedFields {
    NestedFieldCollection^ get ();
    void set (NestedFieldCollection^ value);
}

See Also

PivotTableWizard Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


PivotTableDataSource Property

[image]

.NET ModelKit Suite ClassReference
PivotTableWizard..::.PivotTableDataSource Property
PivotTableWizard Class See Also Send Feedback
Gets or sets pivot table data source.

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string PivotTableDataSource { get; set; }
Visual Basic (Declaration)
Public Property PivotTableDataSource As String
Visual C++
public:
property String^ PivotTableDataSource {
    String^ get ();
    void set (String^ value);
}

See Also

PivotTableWizard Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


RowHeight Property

[image]

.NET ModelKit Suite ClassReference
PivotTableWizard..::.RowHeight Property
PivotTableWizard Class See Also Send Feedback
Gets or sets default row height.

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public int RowHeight { get; set; }
Visual Basic (Declaration)
Public Property RowHeight As Integer
Visual C++
public:
property int RowHeight {
    int get ();
    void set (int value);
}

See Also

PivotTableWizard Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


ShowRepeatText Property

[image]

.NET ModelKit Suite ClassReference
PivotTableWizard..::.ShowRepeatText Property
PivotTableWizard Class See Also Send Feedback
Gets or sets a value indicating whether the endurable text will be displayed.

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowRepeatText { get; set; }
Visual Basic (Declaration)
Public Property ShowRepeatText As Boolean
Visual C++
public:
property bool ShowRepeatText {
    bool get ();
    void set (bool value);
}

See Also

PivotTableWizard Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


ShowSingleFact Property

[image]

.NET ModelKit Suite ClassReference
PivotTableWizard..::.ShowSingleFact Property
PivotTableWizard Class See Also Send Feedback
Gets or sets whether a single fact caption should be visible.

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowSingleFact { get; set; }
Visual Basic (Declaration)
Public Property ShowSingleFact As Boolean
Visual C++
public:
property bool ShowSingleFact {
    bool get ();
    void set (bool value);
}

See Also

PivotTableWizard Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


ShowTableCaption Property

[image]

.NET ModelKit Suite ClassReference
PivotTableWizard..::.ShowTableCaption Property
PivotTableWizard Class See Also Send Feedback
Gets or sets a value indicating whether the pivot table caption will be displayed.

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public bool ShowTableCaption { get; set; }
Visual Basic (Declaration)
Public Property ShowTableCaption As Boolean
Visual C++
public:
property bool ShowTableCaption {
    bool get ();
    void set (bool value);
}

See Also

PivotTableWizard Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


TableCaption Property

[image]

.NET ModelKit Suite ClassReference
PivotTableWizard..::.TableCaption Property
PivotTableWizard Class See Also Send Feedback
Gets or sets pivot table caption.

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public string TableCaption { get; set; }
Visual Basic (Declaration)
Public Property TableCaption As String
Visual C++
public:
property String^ TableCaption {
    String^ get ();
    void set (String^ value);
}

See Also

PivotTableWizard Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


PivotTableWizardForm Class

[image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm Class
Members See Also Send Feedback
A dialog window for assigning settings of the pivote table wizard

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public class PivotTableWizardForm : Form
Visual Basic (Declaration)
Public Class PivotTableWizardForm _
    Inherits Form
Visual C++
public ref class PivotTableWizardForm : public Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
PerpetuumSoft.Reporting.Wizards.PivotTableWizard..::.PivotTableWizardForm

See Also

PivotTableWizardForm Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


PivotTableWizardForm Members

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm Members
PivotTableWizardForm Class Constructors Methods Properties Events See Also Send Feedback

The PivotTableWizardForm type exposes the following members.

Constructors

Name | Description
PivotTableWizardForm | Initializes a new instance of the PivotTableWizardForm class.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Overrides Form..::.OnFormClosed(FormClosedEventArgs).)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Rds | Gets or sets IReportDesignerService
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Wizard | Gets or sets PivotTableWizard

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PivotTableWizardForm Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


PivotTableWizardForm Constructor

[image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm Constructor
PivotTableWizardForm Class See Also Send Feedback
Initializes a new instance of the PivotTableWizardForm class.

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PivotTableWizardForm(
    PivotTableWizard pivotTableWizard,
    IReportDesignerService rds
)
Visual Basic (Declaration)
Public Sub New ( _
    pivotTableWizard As PivotTableWizard, _
    rds As IReportDesignerService _
)
Visual C++
public:
PivotTableWizardForm(
    PivotTableWizard^ pivotTableWizard,
    IReportDesignerService^ rds
)

Parameters

pivotTableWizard
Type: PerpetuumSoft.Reporting.Wizards.PivotTableWizard..::.PivotTableWizard
rds
Type: PerpetuumSoft.Reporting.Designer..::.IReportDesignerService

See Also

PivotTableWizardForm Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


PivotTableWizardForm Methods

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm Methods
PivotTableWizardForm Class See Also Send Feedback

The PivotTableWizardForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Overrides Form..::.OnFormClosed(FormClosedEventArgs).)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

PivotTableWizardForm Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


AccessibilityNotifyClients Method

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.AccessibilityNotifyClients Method
PivotTableWizardForm Class See Also Send Feedback

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

PivotTableWizardForm Class
PivotTableWizardForm Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


BeginInvoke Method

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.BeginInvoke Method
PivotTableWizardForm Class See Also Send Feedback

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

PivotTableWizardForm Class
PivotTableWizardForm Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


Dispose Method

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.Dispose Method
PivotTableWizardForm Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | The Dispose Finalize pattern ensures that resources are released when the object is no longer needed (Overrides Form..::.Dispose(Boolean).)

See Also

PivotTableWizardForm Class
PivotTableWizardForm Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


Dispose Method (Boolean)

[image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.Dispose Method (Boolean)
PivotTableWizardForm Class See Also Send Feedback
The Dispose Finalize pattern ensures that resources are released when the object is no longer needed

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::.Boolean

See Also

PivotTableWizardForm Class
Dispose Overload
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


GetChildAtPoint Method

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.GetChildAtPoint Method
PivotTableWizardForm Class See Also Send Feedback

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

PivotTableWizardForm Class
PivotTableWizardForm Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


Invalidate Method

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.Invalidate Method
PivotTableWizardForm Class See Also Send Feedback

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

PivotTableWizardForm Class
PivotTableWizardForm Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


Invoke Method

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.Invoke Method
PivotTableWizardForm Class See Also Send Feedback

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

PivotTableWizardForm Class
PivotTableWizardForm Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


MemberwiseClone Method

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.MemberwiseClone Method
PivotTableWizardForm Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PivotTableWizardForm Class
PivotTableWizardForm Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


OnFormClosed Method

[image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.OnFormClosed Method
PivotTableWizardForm Class See Also Send Feedback
Raises the FormClosed event.

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
protected override void OnFormClosed(
    FormClosedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnFormClosed ( _
    e As FormClosedEventArgs _
)
Visual C++
protected:
virtual void OnFormClosed(
    FormClosedEventArgs^ e
) override

Parameters

e
Type: System.Windows.Forms..::.FormClosedEventArgs

See Also

PivotTableWizardForm Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


PerformLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.PerformLayout Method
PivotTableWizardForm Class See Also Send Feedback

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

PivotTableWizardForm Class
PivotTableWizardForm Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


ResumeLayout Method

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.ResumeLayout Method
PivotTableWizardForm Class See Also Send Feedback

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

PivotTableWizardForm Class
PivotTableWizardForm Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


RtlTranslateAlignment Method

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.RtlTranslateAlignment Method
PivotTableWizardForm Class See Also Send Feedback

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

PivotTableWizardForm Class
PivotTableWizardForm Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


Scale Method

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.Scale Method
PivotTableWizardForm Class See Also Send Feedback

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

PivotTableWizardForm Class
PivotTableWizardForm Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


Select Method

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.Select Method
PivotTableWizardForm Class See Also Send Feedback

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

PivotTableWizardForm Class
PivotTableWizardForm Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


SetBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.SetBounds Method
PivotTableWizardForm Class See Also Send Feedback

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

PivotTableWizardForm Class
PivotTableWizardForm Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


Show Method

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.Show Method
PivotTableWizardForm Class See Also Send Feedback

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

PivotTableWizardForm Class
PivotTableWizardForm Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


ShowDialog Method

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.ShowDialog Method
PivotTableWizardForm Class See Also Send Feedback

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

PivotTableWizardForm Class
PivotTableWizardForm Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


UpdateBounds Method

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.UpdateBounds Method
PivotTableWizardForm Class See Also Send Feedback

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

PivotTableWizardForm Class
PivotTableWizardForm Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


Validate Method

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.Validate Method
PivotTableWizardForm Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

PivotTableWizardForm Class
PivotTableWizardForm Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


ValidateChildren Method

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.ValidateChildren Method
PivotTableWizardForm Class See Also Send Feedback

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

PivotTableWizardForm Class
PivotTableWizardForm Members
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


PivotTableWizardForm Properties

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm Properties
PivotTableWizardForm Class See Also Send Feedback

The PivotTableWizardForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeBase | (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Rds | Gets or sets IReportDesignerService
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Wizard | Gets or sets PivotTableWizard

See Also

PivotTableWizardForm Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


Rds Property

[image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.Rds Property
PivotTableWizardForm Class See Also Send Feedback
Gets or sets IReportDesignerService

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public IReportDesignerService Rds { get; set; }
Visual Basic (Declaration)
Public Property Rds As IReportDesignerService
Visual C++
public:
property IReportDesignerService^ Rds {
    IReportDesignerService^ get ();
    void set (IReportDesignerService^ value);
}

See Also

PivotTableWizardForm Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


Wizard Property

[image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm..::.Wizard Property
PivotTableWizardForm Class See Also Send Feedback
Gets or sets PivotTableWizard

Namespace: PerpetuumSoft.Reporting.Wizards.PivotTableWizard
Assembly: PerpetuumSoft.Reporting (in PerpetuumSoft.Reporting.dll) Version: 3.9.0.1

Syntax

C#
public PivotTableWizard Wizard { get; set; }
Visual Basic (Declaration)
Public Property Wizard As PivotTableWizard
Visual C++
public:
property PivotTableWizard^ Wizard {
    PivotTableWizard^ get ();
    void set (PivotTableWizard^ value);
}

See Also

PivotTableWizardForm Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace


PivotTableWizardForm Events

[image] [image]

.NET ModelKit Suite ClassReference
PivotTableWizardForm Events
PivotTableWizardForm Class See Also Send Feedback

The PivotTableWizardForm type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PivotTableWizardForm Class
PerpetuumSoft.Reporting.Wizards.PivotTableWizard Namespace